Overview

[image]

Merge DICOM .NET/C# Toolkit
Overview
Send Feedback

Merge DICOM .NET/C# Toolkit

This reference is targeted toward the developer of medical imaging applications using the Merge DICOM .NET Toolkit to supply DICOM network or media functionality.

Merge DICOM .NET toolkit supplies you with a powerful and simplified interface to DICOM. It lets you focus on the important details of your application and immediate needs of your end users, rather than the often complex and confusing details of the DICOM Standard.

Development Platform Requirements

The Merge DICOM .NET/C# Toolkit requires at least version 2.0 of the .NET Framework and a Windows OS supporting that framework.

The toolkit requires the 32-bit or 64-bit C toolkit run-time library depending on whether the application runs as a 32-bit or 64-bit process.

New!

  • Starting with version 5.12.0, the Merge DICOM Toolkit also supports .NET Core on 64-bit Windows and Linux platforms. The Merge DICOM .NET Core Toolkit requires at least version 3.1.6 of .NET Core.
  • Starting with version 5.17.0, the Merge DICOM Toolkit also supports .NET 6 on 64-bit Windows and Linux platforms. The Merge DICOM .NET 6 Toolkit requires at least version 6.0 of .NET.

Send comments on this topic to MDT Support

Copyright (c) Merge Healthcare Solutions Inc. 2024. All rights reserved.


Distribution Structure

[image]

Merge DICOM .NET/C# Toolkit
Distribution Structure
Send Feedback

Distribution Structure of the Merge DICOM .NET/C# Toolkit

The toolkit is distributed in the following folders and files:

  • bin folder - contains the toolkit assemblies, utility applications and the default initialization file.
  • config folder - contains the toolkit's default configuration files and DICOM database files.
  • doc folder - contains the toolkit's documentation.
  • samples folder - contains various sample C# source files and Microsoft Visual Studio project files for the samples.
  • read_me.txt file - details the differences between versions of the toolkit.
  • MCdicom.cs file - source file generated from the toolkit's DICOM database containing constant definitions with tag numbers for every data element.
  • MCitems.cs file - source file generated from the toolkit's DICOM database containing constant definitions for the DICOM sequence items as defined in the MERGECOM.SRV file.
  • MCservices.cs file - source file generated from the toolkit's DICOM database containing constant definitions for the DICOM services as defined in the MERGECOM.SRV file.

The bin Folder

The bin folder contains the following files:

File | Description
Mergecom.dll | The main Merge DICOM Toolkit assembly.
Mergecomws.dll | The Merge DICOM Web Services Toolkit assembly (built only for .NET Framework 4.5).
MC3Messages.dll | The Merge DICOM Toolkit assembly containing additional message specific classes.
Mergecom.Native.dll | The native Merge DICOM Toolkit library for 32-bit Windows platforms.
Mergecom.Native64.dll | The native Merge DICOM Toolkit library for 64-bit Windows platforms.
lnx64\mc3adv.so | The native Merge DICOM Toolkit library for 64-bit Linux platforms (.NET Core and .NET 6 editions). NOTE: lnx64\mc3adv.so must be renamed to Mergecom.Native64.dll on deployment.
Newtonsoft.Json.dll | Third party, high-performance JSON framework for .NET (Permission and copyright notice).
picn*.dll | Pegasus compression library files for 32-bit Windows platforms.
picx20.dll and picx*.ssm | Pegasus compression library files for 64-bit Windows platforms.
lnx64/libpiclx20.so.dll and picx*.ssm | Pegasus compression library files for 64-bit Linux platforms (.NET Core and .NET 6 editions only).
Mergecom.xml | XML documentation files for Microsoft Visual Studio intellisense support.
merge.ini | The default initialization file.
mc3*.exe | Utility applications for Windows platforms. See Utility Programs section in the User's Manual for a description of each utility.
lnx64/mc3* | Utility applications for 64-bit Linux platforms (.NET Core and .NET 6 editions only). See Utility Programs section in the User's Manual for a description of each utility.

The config Folder

The config folder contains the following files:

File | Description
*.pfl | DICOM database configuration files. See the Database Manual for a description of each file.
mergecom.app | Application Profile, specifying the characteristics of your application entity and the AE’s your application will connect with over a network.
mergecom.pro | The Merge System Profile containing configuration parameters for the DICOM Toolkit itself.
mergecom.srv | The Service Profile containing the types of services and commands the toolkit supports.
message.txt | A text file containing all message types defined in the toolkit's DICOM database.
mrgcom3.dct | The toolkit's binary DICOM dictionary file.
mrgcom3.msg | The toolkit's DICOM message information file.


Legal and Support

[image]

Merge DICOM .NET/C# Toolkit
Legal and Support
Send Feedback

Legal Information

This document has been prepared by Merge Healthcare for its customers. The content of this document is confidential. It may be reproduced only with written permission from Merge Healthcare. Specifications contained herein are subject to change, and these changes will be reported in subsequent revisions or editions.

DICOM is a registered trademark of National Electrical Manufacturers Association (NEMA). Merge DICOM Toolkit™ is a trademark of Merge Healthcare. The names of other products mentioned in this document may be the trademarks or registered trademarks of their respective companies.

Copyright © 2023 Merge Healthcare Solutions Inc.

All rights reserved. Unauthorized use, reproduction, or disclosure is prohibited.

Merge Healthcare Incorporated

900 Walnut Ridge Drive, Hartland, WI 53029

Customer Support

For application support or to report issues with user documentation, please contact Merge Healthcare Solutions Inc. Customer Support:

  • 1-877-741-5369 (North America)
  • +31.20.514.5073 (Europe, the Middle East and Africa)
  • 1800 316 746 (Australia)
  • Email: MC3Support@merative.com

See also

Permission and copyright notice for Json.NET


Mergecom Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom Namespace
Send Feedback
This is the top level namespace that contains all MergeCOM namespaces and classes.

Classes

 | Class | Description
Public class | MC | This class contains several static methods used for library initialization and release. It also contains utility methods for cleaning up C tool kit related memory and getting a version string for the library.
Public class | MCabstractMessage | Represents a common base class for MCfile and MCdimseMessage.
Public class | MCage | Encapsulates a DICOM values with Value Representation Age String.
Public class | MCapplication | Represents a DICOM application entity.
Public class | MCassociation | Represents a DICOM association.
Public class | MCassocRejectInfo | The class encapsulates the set of 3 parameters describing the circumstances in which and reasons for which an association may be rejected (as per DICOM PS3.8, section 9.3.4 A-ASSOCIATE-RJ PDU Structure): result, source, reason.
Public class | MCattribute | Represents a single DICOM attribute.
Public class | MCattributeSet | Provides base functionality to control a collection of DICOM attributes.
Public class | MCbasicCodedEntry | Common Attribute Set for Code Sequence Attributes (Invoked as "Code Sequence Macro")
Public class | MCbasicWorklistManagementService | Represents a DICOM Basic Worklist Management Service class.
Public class | MCcommandSet | Represents a DICOM DIMSE Command Set.
Public class | MCconfig | Contains methods to set and retrieve various Merge DICOM toolkit configuration parameters.
Public class | MCdata | Represents bulk data being transferred between program entities.
Public class | MCdataElement | Represents a DICOM data element.
Public class | MCdataSet | Represents a DICOM DIMSE Data Set.
Public class | MCdate | Represents a DICOM date value.
Public class | MCdateTime | Represents a DICOM date/time value.
Public class | MCdimseMessage | Encapsulates a DICOM message used by the DICOM Message Service Element (DIMSE) protocol.
Public class | MCdimseService | Implements basic functionality for DIMSE services. Sub-classes provide methods particular to specific DICOM DIMSE services.
Public class | MCdir | Represents a DICOMDIR directory file.
Public class | MCdirRecord | Represents a DICOMDIR record.
Public class | MCfailedSopInfo | Represents a Failed SOP Sequence item.
Public class | MCfile | Represents a DICOM Media Storage file.
Public class | MCfileDataSink | Implementation of the MCdataSink interface which writes to a file.
Public class | MCfileDataSource | Implementation of the MCdataSource interface which reads from a file.
Public class | MCfileMetaInfo | Represents the Meta Information for DICOM Media Storage.
Public class | MCinstanceUid | Identifies a unique instance belonging to a unique SOP Class.
Public class | MCitem | Represents the attributes of a DICOM item.
Public class | MCmediaStorageService | Represents a DICOM Media Storage Service class.
Public class | MCmemoryDataSink | A memory buffer that implements both MCdataSink and MCdataSource interfaces.
Public class | MCnegotiationInfo | Represents base methods for extended user information during association negotiation.
Public class | MCpatientManagementService | Represents a DICOM Patient Management Service class.
Public class | MCpersonName | Represents a DICOM person name value.
Public class | MCpnComponentGroup | Represents a DICOM person name component group.
Public class | MCprintManagementService | Represents a DICOM Print Management Service class.
Public class | MCproposedContext | Represents a DICOM service which is being proposed for use in a DICOM association between two DICOM application entities.
Public class | MCproposedContextList | Represents a list of presentation contexts that are being proposed for association negotiation.
Public class | MCqueryRetrieveNegotiation | Contains Query/Retrieve Service Class Extended Negotiation data.
Public class | MCqueryRetrieveService | Represents a DICOM Query Retrieve Service class.
Public class | MCqueueManagementService | Represents a DICOM Queue Management Service class.
Public class | MCrefSopInfo | Represents a Referenced SOP Sequence item.
Public class | MCrefStudyInfo | Represents a Referenced Performed Procedure Step Sequence item (formerly Referenced Study Component Sequence item).
Public class | MCremoteApplication | Contains information about a remote DICOM application.
Public class | MCresultContext | Contains information about a DICOM service that has been rejected or accepted by the remote DICOM application.
Public class | MCresultsManagementService | Represents a DICOM Results Management Service class.
Public class | MCrleCompressor | This standard compressor implements the MCcompression interface and it can be used to compress images into the Run-length encoding (RLE) transfer syntax.
Public class | MCrleDecompressor | This standard decompressor implements the MCcompression interface and it can be used to decompress images from the Run-length encoding (RLE) transfer syntax.
Public class | MCsecureContext | SSL context is used to to support Mergecom secure associations in DICOM applications
Public class | MCsocket | Helper class to create System.Net objects
Public class | MCsopClass | Represents a DICOM SOP (Service-Object Pair) Class.
Public class | MCsopInstanceReference | Encapsulates the attributes that reference an SOP instance
Public class | MCstandardCompressor | This standard compressor implements the MCcompression interface and it can be used to compress the JPEG Lossless Non-Hierarchical 14 transfer syntax, the JPEG Baseline transfer syntax and the JPEG Extended 2,4 transfer syntaxes.
Public class | MCstandardDecompressor | This standard decompressor implements the MCcompression interface and it can be used to decompress the JPEG Lossless Non-Hierarchical 14 transfer syntax, the JPEG Baseline transfer syntax and the JPEG Extended 2,4 transfer syntaxes.
Public class | MCstorageCommitmentService | Represents a DICOM Storage Commitment Service class.
Public class | MCstorageNegotiation | Contains Storage Service Class Extended Negotiation data.
Public class | MCstorageService | Represents the DICOM Storage Service Class.
Public class | MCstreamDataSink | An implementation of the MCdataSink interface which writes to a Stream.
Public class | MCstreamDataSource | Implementation of the MCdataSource interface which reads from a Stream.
Public class | MCstudyContentNotificationService | Represents a DICOM Study Content Notification Service class.
Public class | MCstudyManagementService | Represents a DICOM Study Management Service class.
Public class | MCtag | Represents a DICOM data element identifier normally referred to as a "tag".
Public class | MCtime | Represents a DICOM time value.
Public class | MCtransferSyntax | Represents a DICOM Transfer Syntax.
Public class | MCtransferSyntaxList | Represents a list of transfer syntaxes used in association negotiation.
Public class | MCunifiedProcedureStepService | Represents a DICOM Unified Worklist and Procedure Step Service class.
Public class | MCvalidationError | Represents a dataset validation error.
Public class | MCverificationService | Represents the DICOM Verification Service Class and it provides methods to support the Verification SOP Class.
Public class | MCvr | This class represents a DICOM Value Representation.

Structures

Structure Description
Public structure MCdicom
MCdicom structure contains fields representing tags from Part 6 of the DICOM Standard. As the standard changes the structure will be updated in order to remain current. In particular, the following changes can be expected: 1. New fields will be added as new tags are defined with new Supplements and Change Proposals. 2. Some fields will be appended with the _RETIRED suffix as tags are retired from the standard. 2. The list of aliases at the end of this structure will grow as tags are renamed in the standard.
Public structure MCitems
MCitems structure contains constant strings representing names for the DICOM sequence items as defined in the mergecom.srv configuration file. It eliminates the need to hard code these names and makes possible compile time checking.

As the standard evolves the structure will be updated in order to remain current. In particular, the following changes can be expected:

  1. New fields will be added as new sequence item types are defined in new Supplements and Change Proposals.

Public structure MCsecureContext..::..SecureSocketFunctions
Structure referenced to SSL session callbacks
Public structure MCservices
The MCservices structure contains constant strings representing names for the DICOM services as defined in the mergecom.srv configuration file. It eliminates the need to hard code these names and makes possible compile time checking.

As the standard evolves the structure will be updated in order to remain current. In particular, the following changes can be expected:

  1. New fields will be added as new services are defined in new Supplements and Change Proposals.

Interfaces

 | Interface | Description
Public interface | MC..::..ExceptionHandler | Interface prototyping the user-defined exception handling method
Public interface | MCacceptor | Defines the method to handle incoming association requests.
Public interface | MCattributeContainer | This interface defines the requirements for a class which is to serve as a container for an attribute's value.
Public interface | MCattributeContainerEx | This interface extends MCattributeContainer interface allowing to read a stream data of an attribute's value with a given offset.
Public interface | MCbulkDataUriHandler | An interface to handle BulkDataURI attribute when dealing with Native DICOM Model XML or DICOM JSON Model.
Public interface | MCcompression | This interface is used to represent a compression or decompression class.
Public interface | MCdataSetSerializable | Public interface for streaming attributes to dataset
Public interface | MCdataSink | Defines the requirements for a class that will receive data from the library.
Public interface | MCdataSource | Defines the requirements for a class which will be called by the library when reading data from a source.
Public interface | MCdataSourceEx | Extends MCdataSource with a method utilizing the offset to read the source data
Public interface | MCrequester | Defines the methods required for handling a newly created association as a requester.
Public interface | MCstringEncoder | Defines the interface used to encode/decode strings in attribute values.
Public interface | MCstringEncoderEx | Defines extended interface used to encode/decode strings in attribute values.

Delegates

 | Delegate | Description
Public delegate | MCsecureContext..::..Read | SSL read session delegate
Public delegate | MCsecureContext..::..Shutdown | SSL shutdown session delegate
Public delegate | MCsecureContext..::..Start | SSL start session delegate
Public delegate | MCsecureContext..::..Write | SSL write session delegate

Enumerations

 | Enumeration | Description
Public enumeration | MCReadError | Define the status of a "Read" operation in an association
Public enumeration | MCrejectReason | Enumerated value used by MCassociation.reject(MCrejectReason) to set a reason as specified in the DICOM standard for rejecting an association.
Public enumeration | MCsecureContext..::..Status | SSL status for secure association operation (Open, Read, Write and Shutdown)
Public enumeration | MCuserIdentity | The User Identity used to notify the association acceptor of the user identity of the association requestor.
Public enumeration | MCvalidationLevel | Defines levels at which attribute sets can be validated.
Public enumeration | MCxmlOptions | Defines Xml conversion configuration options.


MC Class

[image]

Merge DICOM .NET/C# Toolkit
MC Class
Members See Also Send Feedback
This class contains several static methods used for library initialization and release. It also contains utility methods for cleaning up C tool kit related memory and getting a version string for the library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public sealed class MC
Visual Basic
Public NotInheritable Class MC
Visual C++
public ref class MC sealed

Inheritance Hierarchy

System..::..Object
Mergecom..::..MC

See Also

MC Members
Mergecom Namespace


MC Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MC Members
MC Class Methods Properties See Also Send Feedback

The MC type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeywords | This method returns a Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM attribute tags and associated string keywords.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | mcCleanupMemory | Cleanup unmanaged memory associated with the C library.
 | mcForcedInitialization(FileInfo) | Resets and Initializes the Merge DICOM toolkit library, even if it was already initialized previously, and resets configuration information.
 | mcForcedInitialization(FileInfo, String) |
 | mcGetStringEncoder | Gets the object used for encoding/decoding string attribute values.
 | mcGetVersionString | Retrieves the library version number.
 | mcInitialization(FileInfo) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.
 | mcInitialization(FileInfo, String) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.
 | mcIsInitialized | Determines whether the library is initialized for the current application domain.
 | mcLibraryRelease | Performs a graceful shutdown of the library.
 | mcSetStringEncoder | Sets the object used for encoding/decoding string attribute values.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReleaseLibraryExceptionHandler | Release user-defined exception handler
 | SetLibraryExceptionHandler | Register user-defined exception handler
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllowNonASCIIDefaultEncoding | This property determines how the string attributes are encoded if DICOM (0008,0005) character set attribute is not present.
AllowRenumberPrivateTags | This property allows private tags to be renumbered on copying private attributes in sequent order
AssocWaitInCallerThread | This property determines if the associations will wait for read events in its own thread if false or in the caller thread if true.
ReportInvalidEncodingWarning | This property determines whether invalid attribute warnings are reported.

See Also

MC Class


MC Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MC Methods
MC Class See Also Send Feedback

The MC type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeywords | This method returns a Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM attribute tags and associated string keywords.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | mcCleanupMemory | Cleanup unmanaged memory associated with the C library.
 | mcForcedInitialization(FileInfo) | Resets and Initializes the Merge DICOM toolkit library, even if it was already initialized previously, and resets configuration information.
 | mcForcedInitialization(FileInfo, String) |
 | mcGetStringEncoder | Gets the object used for encoding/decoding string attribute values.
 | mcGetVersionString | Retrieves the library version number.
 | mcInitialization(FileInfo) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.
 | mcInitialization(FileInfo, String) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.
 | mcIsInitialized | Determines whether the library is initialized for the current application domain.
 | mcLibraryRelease | Performs a graceful shutdown of the library.
 | mcSetStringEncoder | Sets the object used for encoding/decoding string attribute values.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReleaseLibraryExceptionHandler | Release user-defined exception handler
 | SetLibraryExceptionHandler | Register user-defined exception handler
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MC Class


GetKeywords Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..GetKeywords Method
MC Class See Also Send Feedback
This method returns a Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM attribute tags and associated string keywords.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static Dictionary<uint, string> GetKeywords()
Visual Basic
Public Shared Function GetKeywords As Dictionary(Of UInteger, String)
Visual C++
public:
static Dictionary<unsigned int, String^>^ GetKeywords()

Return Value

Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM attributes tags and associated string keywords.

See Also

MC Class
MC Members


mcCleanupMemory Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcCleanupMemory Method
MC Class See Also Send Feedback
Cleanup unmanaged memory associated with the C library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool mcCleanupMemory(
    int timeout
)
Visual Basic
Public Shared Function mcCleanupMemory ( _
    timeout As Integer _
) As Boolean
Visual C++
public:
static bool mcCleanupMemory(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
A timeout, in seconds, for the cleanup method. If this parameter is zero, the method runs until the cleanup is complete.

Return Value

true if the cleanup is complete, false if the operation timed out.

Remarks

This method allows an application to reduce the amount of memory consumed by the toolkit. The Merge toolkit uses an internal memory management system to increase performance. This increase in performance is at the expense of keeping allocated memory block available by not freeing them to the operating system. This call allows memory blocks not in use to be returned to the operating system.

This call can take a significant amount of time if a large amount of memory is to be freed. The timeout can be used to make incremental improvements in the memory usage. Calls to this method pick up where the previous call left off. If the timeout expires before the cleanup is complete, false is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | mcInitialization(FileInfo) has not been called yet
Mergecom.Exceptions..::..MCillegalArgumentException | The timeout argument was less than 0.
Mergecom.Exceptions..::..MCruntimeException | Unexpected status returned by the native library.

See Also

MC Class
MC Members


mcForcedInitialization Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MC..::..mcForcedInitialization Method
MC Class See Also Send Feedback

Overload List

Name | Description
mcForcedInitialization(FileInfo) | Resets and Initializes the Merge DICOM toolkit library, even if it was already initialized previously, and resets configuration information.
mcForcedInitialization(FileInfo, String) |

See Also

MC Class
MC Members


mcForcedInitialization Method (FileInfo)

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcForcedInitialization Method (FileInfo)
MC Class See Also Send Feedback
Resets and Initializes the Merge DICOM toolkit library, even if it was already initialized previously, and resets configuration information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcForcedInitialization(
    FileInfo mergeIniFile
)
Visual Basic
Public Shared Sub mcForcedInitialization ( _
    mergeIniFile As FileInfo _
)
Visual C++
public:
static void mcForcedInitialization(
    FileInfo^ mergeIniFile
)

Parameters

mergeIniFile
Type: System.IO..::..FileInfo
A FileInfo object representing the merge.ini file's location. This parameter can be null.

Remarks

This method should be called only once, in case if the library status gets abnormal (configuration parameters are lost, corrupted or otherwise changed so that the library becomes unusable)

Because this toolkit provides a wrapper to the native Merge DICOM toolkit, it cannot be used from different application domains at the same time. Applications using multiple application domains must ensure the toolkit is released in the current application domain before being able to initialize it in another application domain.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The initialization failed. Check the merge.log file for details.
Mergecom.Exceptions..::..MCruntimeException | The native library (mergecom.native.dll) could not be loaded.
Mergecom.Exceptions..::..MCinvalidLicenseInfoError | A proper license could not be detected.

See Also

MC Class
MC Members
mcForcedInitialization Overload


mcForcedInitialization Method (FileInfo, String)

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcForcedInitialization Method (FileInfo, String)
MC Class See Also Send Feedback

[Missing <summary> documentation for "M:Mergecom.MC.mcForcedInitialization(System.IO.FileInfo,System.String)"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcForcedInitialization(
    FileInfo mergeIniFile,
    string License
)
Visual Basic
Public Shared Sub mcForcedInitialization ( _
    mergeIniFile As FileInfo, _
    License As String _
)
Visual C++
public:
static void mcForcedInitialization(
    FileInfo^ mergeIniFile,
    String^ License
)

Parameters

mergeIniFile
Type: System.IO..::..FileInfo

[Missing <param name="mergeIniFile"/> documentation for "M:Mergecom.MC.mcForcedInitialization(System.IO.FileInfo,System.String)"]

License
Type: System..::..String

[Missing <param name="License"/> documentation for "M:Mergecom.MC.mcForcedInitialization(System.IO.FileInfo,System.String)"]

See Also

MC Class
MC Members
mcForcedInitialization Overload


mcGetStringEncoder Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcGetStringEncoder Method
MC Class See Also Send Feedback
Gets the object used for encoding/decoding string attribute values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCstringEncoder mcGetStringEncoder()
Visual Basic
Public Shared Function mcGetStringEncoder As MCstringEncoder
Visual C++
public:
static MCstringEncoder^ mcGetStringEncoder()

Return Value

An object implementing the MCstringEncoder interface.

See Also

MC Class
MC Members


mcGetVersionString Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcGetVersionString Method
MC Class See Also Send Feedback
Retrieves the library version number.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static string mcGetVersionString()
Visual Basic
Public Shared Function mcGetVersionString As String
Visual C++
public:
static String^ mcGetVersionString()

Return Value

A not null string containing the library's version numbers.

See Also

MC Class
MC Members


mcInitialization Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MC..::..mcInitialization Method
MC Class See Also Send Feedback

Overload List

Name | Description
mcInitialization(FileInfo) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.
mcInitialization(FileInfo, String) | Initializes the Merge DICOM toolkit library and provides necessary configuration information.

See Also

MC Class
MC Members


mcInitialization Method (FileInfo)

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcInitialization Method (FileInfo)
MC Class See Also Send Feedback
Initializes the Merge DICOM toolkit library and provides necessary configuration information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcInitialization(
    FileInfo mergeIniFile
)
Visual Basic
Public Shared Sub mcInitialization ( _
    mergeIniFile As FileInfo _
)
Visual C++
public:
static void mcInitialization(
    FileInfo^ mergeIniFile
)

Parameters

mergeIniFile
Type: System.IO..::..FileInfo
A FileInfo object representing the merge.ini file's location. This parameter can be null.

Remarks

This method may be called multiple times (by multiple application threads, for example) but the mergeIniFile parameter must specify the same file path or an MCalreadyInitializedException will be thrown. Each mcInitialization(FileInfo) call must be paired with an mcLibraryRelease()()()() call. After all required mcLibraryRelease()()()() calls have been made, the library will permit an mcInitialization(FileInfo) call using a different merge ini file specification.

Because this toolkit provides a wrapper to the native Merge DICOM toolkit, it cannot be used from different application domains at the same time. Applications using multiple application domains must ensure the toolkit is released in the current application domain before being able to initialize it in another application domain.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCalreadyInitializedException | The library is already initialized with a different configuration file or the library is initialized in a different application domain..
Mergecom.Exceptions..::..MCnotInitializedError | The initialization failed. Check the merge.log file for details.
Mergecom.Exceptions..::..MCruntimeException | The native library (mergecom.native.dll) could not be loaded.
Mergecom.Exceptions..::..MCinvalidLicenseInfoError | A proper license could not be detected.

See Also

MC Class
MC Members
mcInitialization Overload


mcInitialization Method (FileInfo, String)

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcInitialization Method (FileInfo, String)
MC Class See Also Send Feedback
Initializes the Merge DICOM toolkit library and provides necessary configuration information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcInitialization(
    FileInfo mergeIniFile,
    string License
)
Visual Basic
Public Shared Sub mcInitialization ( _
    mergeIniFile As FileInfo, _
    License As String _
)
Visual C++
public:
static void mcInitialization(
    FileInfo^ mergeIniFile,
    String^ License
)

Parameters

mergeIniFile
Type: System.IO..::..FileInfo
A FileInfo object representing the merge.ini file's location. This parameter can be null.
License
Type: System..::..String
A input string representing valid license for Merge DICOM library. This parameter can be null.

Remarks

This method may be called multiple times (by multiple application threads, for example) but the mergeIniFile parameter must specify the same file path or an MCalreadyInitializedException will be thrown. Each mcInitialization(FileInfo, String) call must be paired with an mcLibraryRelease()()()() call. After all required mcLibraryRelease()()()() calls have been made, the library will permit an mcInitialization(FileInfo, String) call using a different merge ini file specification.

Because this toolkit provides a wrapper to the native Merge DICOM toolkit, it cannot be used from different application domains at the same time. Applications using multiple application domains must ensure the toolkit is released in the current application domain before being able to initialize it in another application domain.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCalreadyInitializedException | The library is already initialized with a different configuration file or the library is initialized in a different application domain.
Mergecom.Exceptions..::..MCnotInitializedError | The initialization failed. Check the merge.log file for details.
Mergecom.Exceptions..::..MCruntimeException | The native library (mergecom.native.dll) could not be loaded.
Mergecom.Exceptions..::..MCinvalidLicenseInfoError | A proper license could not be detected.

See Also

MC Class
MC Members
mcInitialization Overload


mcIsInitialized Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcIsInitialized Method
MC Class See Also Send Feedback
Determines whether the library is initialized for the current application domain.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool mcIsInitialized()
Visual Basic
Public Shared Function mcIsInitialized As Boolean
Visual C++
public:
static bool mcIsInitialized()

Return Value

true if mcInitialization(FileInfo) has been called successfully, otherwise false.

Remarks

This method determines whether the mcInitialization(FileInfo) method has been successfully called at least once. If the mcInitialization(FileInfo) method was called at least one time without a corresponding mcLibraryRelease()()()() call, this method returns true.

See Also

MC Class
MC Members


mcLibraryRelease Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcLibraryRelease Method
MC Class See Also Send Feedback
Performs a graceful shutdown of the library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcLibraryRelease()
Visual Basic
Public Shared Sub mcLibraryRelease
Visual C++
public:
static void mcLibraryRelease()

Remarks

The library is not released until mcLibraryRelease()()()() is called the same number of times that the mcInitialization(FileInfo) method was called.

This call is ignored if the library is not initialized.

See Also

MC Class
MC Members


mcSetStringEncoder Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..mcSetStringEncoder Method
MC Class See Also Send Feedback
Sets the object used for encoding/decoding string attribute values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void mcSetStringEncoder(
    MCstringEncoder encoder
)
Visual Basic
Public Shared Sub mcSetStringEncoder ( _
    encoder As MCstringEncoder _
)
Visual C++
public:
static void mcSetStringEncoder(
    MCstringEncoder^ encoder
)

Parameters

encoder
Type: Mergecom..::..MCstringEncoder
An object implementing the MCstringEncoder interface.

See Also

MC Class
MC Members


ReleaseLibraryExceptionHandler Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..ReleaseLibraryExceptionHandler Method
MC Class See Also Send Feedback
Release user-defined exception handler

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void ReleaseLibraryExceptionHandler()
Visual Basic
Public Shared Sub ReleaseLibraryExceptionHandler
Visual C++
public:
static void ReleaseLibraryExceptionHandler()

See Also

MC Class
MC Members


SetLibraryExceptionHandler Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..SetLibraryExceptionHandler Method
MC Class See Also Send Feedback
Register user-defined exception handler

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void SetLibraryExceptionHandler(
    MC..::..ExceptionHandler handler
)
Visual Basic
Public Shared Sub SetLibraryExceptionHandler ( _
    handler As MC..::..ExceptionHandler _
)
Visual C++
public:
static void SetLibraryExceptionHandler(
    MC..::..ExceptionHandler^ handler
)

Parameters

handler
Type: Mergecom..::..MC..::..ExceptionHandler
MC..::..ExceptionHandlerException handler

See Also

MC Class
MC Members


MC Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MC Properties
MC Class See Also Send Feedback

The MC type exposes the following members.

Properties

Name | Description
AllowNonASCIIDefaultEncoding | This property determines how the string attributes are encoded if DICOM (0008,0005) character set attribute is not present.
AllowRenumberPrivateTags | This property allows private tags to be renumbered on copying private attributes in sequent order
AssocWaitInCallerThread | This property determines if the associations will wait for read events in its own thread if false or in the caller thread if true.
ReportInvalidEncodingWarning | This property determines whether invalid attribute warnings are reported.

See Also

MC Class


AllowNonASCIIDefaultEncoding Property

[image]

Merge DICOM .NET/C# Toolkit
MC..::..AllowNonASCIIDefaultEncoding Property
MC Class See Also Send Feedback
This property determines how the string attributes are encoded if DICOM (0008,0005) character set attribute is not present.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool AllowNonASCIIDefaultEncoding { get; set; }
Visual Basic
Public Shared Property AllowNonASCIIDefaultEncoding As Boolean
    Get
    Set
Visual C++
public:
static property bool AllowNonASCIIDefaultEncoding {
    bool get ();
    void set (bool value);
}

Field Value

If false the string encoding is done using ISO-IR 6 character set and if true the specific character set of Windows System Locale is used.

Remarks

The default value of this property is false.

See Also

MC Class
MC Members


AllowRenumberPrivateTags Property

[image]

Merge DICOM .NET/C# Toolkit
MC..::..AllowRenumberPrivateTags Property
MC Class See Also Send Feedback
This property allows private tags to be renumbered on copying private attributes in sequent order

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool AllowRenumberPrivateTags { get; set; }
Visual Basic
Public Shared Property AllowRenumberPrivateTags As Boolean
    Get
    Set
Visual C++
public:
static property bool AllowRenumberPrivateTags {
    bool get ();
    void set (bool value);
}

Field Value

true if private tags are allowed to be renumbered (DICOM standard behavior)

Remarks

The default value of this property is true.

See Also

MC Class
MC Members


AssocWaitInCallerThread Property

[image]

Merge DICOM .NET/C# Toolkit
MC..::..AssocWaitInCallerThread Property
MC Class See Also Send Feedback
This property determines if the associations will wait for read events in its own thread if false or in the caller thread if true.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool AssocWaitInCallerThread { get; set; }
Visual Basic
Public Shared Property AssocWaitInCallerThread As Boolean
    Get
    Set
Visual C++
public:
static property bool AssocWaitInCallerThread {
    bool get ();
    void set (bool value);
}

Remarks

The default value of this property is true.

Setting the property to true will allow the caller to dispatch commands on a server association in multiple threads for true asynchronous/parallel processing.

This is a global setting and will affect all MCassociation objects created in the application. If you want to modify the behaviour on an individual, per-MCassociation basis, use MCassociation.WaitInCallerThread.

See Also

MC Class
MC Members


ReportInvalidEncodingWarning Property

[image]

Merge DICOM .NET/C# Toolkit
MC..::..ReportInvalidEncodingWarning Property
MC Class See Also Send Feedback
This property determines whether invalid attribute warnings are reported.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool ReportInvalidEncodingWarning { get; set; }
Visual Basic
Public Shared Property ReportInvalidEncodingWarning As Boolean
    Get
    Set
Visual C++
public:
static property bool ReportInvalidEncodingWarning {
    bool get ();
    void set (bool value);
}

Field Value

true if setting invalid attribute values will generate an MCinvalidEncodingWarning exception.

Remarks

The default value of this property is true.

See Also

MC Class
MC Members


MC.ExceptionHandler Interface

[image]

Merge DICOM .NET/C# Toolkit
MC..::..ExceptionHandler Interface
MC Class Members See Also Send Feedback
Interface prototyping the user-defined exception handling method

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface ExceptionHandler
Visual Basic
Public Interface ExceptionHandler
Visual C++
public interface class ExceptionHandler

See Also

MC..::..ExceptionHandler Members


MC.ExceptionHandler Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MC..::..ExceptionHandler Members
MC..::..ExceptionHandler Interface Methods See Also Send Feedback

The MC..::..ExceptionHandler type exposes the following members.

Methods

 | Name | Description
Public method | handleException | Exception handling method.

See Also

MC..::..ExceptionHandler Interface


MC.ExceptionHandler Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MC..::..ExceptionHandler Methods
MC..::..ExceptionHandler Interface See Also Send Feedback

The MC..::..ExceptionHandler type exposes the following members.

Methods

 | Name | Description
Public method | handleException | Exception handling method.

See Also

MC..::..ExceptionHandler Interface


handleException Method

[image]

Merge DICOM .NET/C# Toolkit
MC..::..ExceptionHandler..::..handleException Method
MC..::..ExceptionHandler Interface See Also Send Feedback
Exception handling method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void handleException(
    long code
)
Visual Basic
Sub handleException ( _
    code As Long _
)
Visual C++
void handleException(
    long long code
)

Parameters

code
Type: System..::..Int64
Exception code

See Also

MC..::..ExceptionHandler Interface
MC..::..ExceptionHandler Members


MCabstractMessage Class

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage Class
Members See Also Send Feedback
Represents a common base class for MCfile and MCdimseMessage.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCabstractMessage
Visual Basic
Public MustInherit Class MCabstractMessage
Visual C++
public ref class MCabstractMessage abstract

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCabstractMessage
Mergecom..::..MCdimseMessage
Mergecom..::..MCfile

See Also

MCabstractMessage Members


MCabstractMessage Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage Members
MCabstractMessage Class Constructors Methods See Also Send Feedback

The MCabstractMessage type exposes the following members.

Constructors

 | Name | Description
Protected method | MCabstractMessage | Initializes a new instance of the MCabstractMessage class

Methods

 | Name | Description
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message.
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria.
Public method | validateAttribute | Validates an attribute in this message's data set.
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).

See Also

MCabstractMessage Class


MCabstractMessage Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage Constructor
MCabstractMessage Class See Also Send Feedback
Initializes a new instance of the MCabstractMessage class

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCabstractMessage()
Visual Basic
Protected Sub New
Visual C++
protected:
MCabstractMessage()

See Also

MCabstractMessage Class
MCabstractMessage Members


MCabstractMessage Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage Methods
MCabstractMessage Class See Also Send Feedback

The MCabstractMessage type exposes the following members.

Methods

 | Name | Description
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message.
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria.
Public method | validateAttribute | Validates an attribute in this message's data set.
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).

See Also

MCabstractMessage Class


duplicate Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..duplicate Method
MCabstractMessage Class See Also Send Feedback
Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCabstractMessage duplicate(
    MCtransferSyntax resultSyntax,
    MCcompression compressor,
    MCcompression decompressor
)
Visual Basic
Public Function duplicate ( _
    resultSyntax As MCtransferSyntax, _
    compressor As MCcompression, _
    decompressor As MCcompression _
) As MCabstractMessage
Visual C++
public:
MCabstractMessage^ duplicate(
    MCtransferSyntax^ resultSyntax,
    MCcompression^ compressor,
    MCcompression^ decompressor
)

Parameters

resultSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the newly created message or file object.
compressor
Type: Mergecom..::..MCcompression
If resultSyntax is a compressed transfer syntax, a compressor must be supplied in this parameter.
decompressor
Type: Mergecom..::..MCcompression
If the message is encoded in a compressed transfer syntax, a decompressor must be supplied in this parameter.

Return Value

A newly created MCdimseMessage or MCfile object.

Remarks

This method is the primary method for compressing or decompressing objects with the Merge DICOM toolkit. This method can convert between different compressed transfer syntaxes, it can be used to compress an uncompressed message, or it can be used to decompress a compressed message.

When compressing an uncompressed MCabstractMessage instance, the decompressor parameter should be set to null and the compressor parameter should be set to an MCcompression instance that can compress the image in the transfer syntax specified by resultSyntax.

Similarly, when decompressing an MCabstractMessage instance, the compressor parameter should be set to null and the decompressor parameter should be set to an MCcompression instance that can decompress the image in the transfer syntax specified by resultSyntax.

Finally, when converting between compressed transfer syntaxes, an appropriate compressor and decompressor must be specified.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The compressor or decompressor returned an error when duplicating.
Mergecom.Exceptions..::..MCoperationNotAllowedException | The MCabstractMessage instance is not of type MCdimseMessage or MCfile.
Mergecom.Exceptions..::..MCillegalArgumentException | A compressor or decompressor was required to complete the operation and was not specified.

See Also

MCabstractMessage Class
MCabstractMessage Members


getNextValidationError Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..getNextValidationError Method
MCabstractMessage Class See Also Send Feedback
Gets validation error information created by the validate() method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCvalidationError getNextValidationError()
Visual Basic
Public Function getNextValidationError As MCvalidationError
Visual C++
public:
MCvalidationError^ getNextValidationError()

Return Value

An MCvalidationError object describing the error or null if there are no more errors.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCabstractMessage Class
MCabstractMessage Members


readFromJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromJSON Method
MCabstractMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.

See Also

MCabstractMessage Class
MCabstractMessage Members


readFromJSON Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromJSON Method (TextReader)
MCabstractMessage Class See Also Send Feedback
Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromJSON(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromJSON ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromJSON(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
readFromJSON Overload


readFromJSON Method (TextReader, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromJSON Method (TextReader, MCbulkDataUriHandler)
MCabstractMessage Class See Also Send Feedback
Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromJSON(
    TextReader source,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub readFromJSON ( _
    source As TextReader, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void readFromJSON(
    TextReader^ source,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
An implementation of MCbulkDataUri interface that can handle reading of BulkDataURI from the JSON stream. When an attribute contains BulkDataURI, the MCbulkDataUriHandler.provideData method will be called.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
readFromJSON Overload


readFromXML Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromXML Method
MCabstractMessage Class See Also Send Feedback
Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXML(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromXML ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromXML(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members


readFromXMLNative Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromXMLNative Method
MCabstractMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.

See Also

MCabstractMessage Class
MCabstractMessage Members


readFromXMLNative Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromXMLNative Method (TextReader)
MCabstractMessage Class See Also Send Feedback
Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXMLNative(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromXMLNative ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromXMLNative(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
readFromXMLNative Overload


readFromXMLNative Method (TextReader, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..readFromXMLNative Method (TextReader, MCbulkDataUriHandler)
MCabstractMessage Class See Also Send Feedback
Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXMLNative(
    TextReader source,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub readFromXMLNative ( _
    source As TextReader, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void readFromXMLNative(
    TextReader^ source,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
An implementation of MCbulkDataUri interface that can handle reading of BulkDataURI from the XML stream. When an attribute contains BulkDataURI, the MCbulkDataUriHandler.provideData method will be called.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
readFromXMLNative Overload


registerCompression Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..registerCompression Method
MCabstractMessage Class See Also Send Feedback
Register compression callbacks for future use of compression/decompression operation

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void registerCompression(
    MCcompression compressor,
    MCcompression decompressor
)
Visual Basic
Public Sub registerCompression ( _
    compressor As MCcompression, _
    decompressor As MCcompression _
)
Visual C++
public:
void registerCompression(
    MCcompression^ compressor,
    MCcompression^ decompressor
)

Parameters

compressor
Type: Mergecom..::..MCcompression
Default compressor
decompressor
Type: Mergecom..::..MCcompression
Default decompressor

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The compressor or decompressor returned an error when duplicating.
Mergecom.Exceptions..::..MCillegalArgumentException | A compressor or decompressor was required to complete the operation and was not specified.

See Also

MCabstractMessage Class
MCabstractMessage Members


validate Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..validate Method
MCabstractMessage Class See Also Send Feedback
Checks whether this message meets the DICOM validation criteria.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool validate(
    MCvalidationLevel level
)
Visual Basic
Public Overridable Function validate ( _
    level As MCvalidationLevel _
) As Boolean
Visual C++
public:
virtual bool validate(
    MCvalidationLevel level
)

Parameters

level
Type: Mergecom..::..MCvalidationLevel
The requested level of validation.

Return Value

true if the message is valid, otherwise false.

Remarks

This method validates the current message to determine that required attributes are present and that all attribute values are valid. The message is validated to insure that it meets the requirements of the specified service and command.

While the validation is quite comprehensive there are limitations in validating files:

  • If the attribute was specified by DICOM Part 3 as being in either a user optional module, or a conditional module, it will always be treated as a Type 3 attribute (optional attribute).
  • The Ultrasound Image Object used in storage services has mutually exclusive Image, Overlay, and Curve information entities. The attributes defined in these entities are all treated as Type 3 (optional attributes).
  • This method does not validate properly for application profiles that modify the standard content of a message.

In any case, this method is a powerful tool that can catch almost all problems with a message. The DICOM Standard should always be the final word on whether or not a message satisfies the DICOM protocol.

If the file is not valid, a list of validation violations is created that can be retrieved using getNextValidationError() method. Also, the results of the validation are logged into the message log (usually merge.log) at the T5_MESSAGE level.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCabstractMessage Class
MCabstractMessage Members


validateAttribute Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..validateAttribute Method
MCabstractMessage Class See Also Send Feedback
Validates an attribute in this message's data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool validateAttribute(
    uint tag,
    MCvalidationLevel level
)
Visual Basic
Public Overridable Function validateAttribute ( _
    tag As UInteger, _
    level As MCvalidationLevel _
) As Boolean
Visual C++
public:
virtual bool validateAttribute(
    unsigned int tag,
    MCvalidationLevel level
)

Parameters

tag
Type: System..::..UInt32
Identifies the attribute to validate.
level
Type: Mergecom..::..MCvalidationLevel
The requested level of validation.

Return Value

true if the attribute value is valid, otherwise false.

Remarks

See MCdataSet.validateAttribute for more details.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCabstractMessage Class
MCabstractMessage Members


writeToJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToJSON Method
MCabstractMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).

See Also

MCabstractMessage Class
MCabstractMessage Members


writeToJSON Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToJSON Method (TextWriter)
MCabstractMessage Class See Also Send Feedback
Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToJSON(
    TextWriter destination
)
Visual Basic
Public Overridable Sub writeToJSON ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void writeToJSON(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
writeToJSON Overload


writeToJSON Method (TextWriter, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToJSON Method (TextWriter, MCbulkDataUriHandler)
MCabstractMessage Class See Also Send Feedback
Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToJSON(
    TextWriter destination,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub writeToJSON ( _
    destination As TextWriter, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void writeToJSON(
    TextWriter^ destination,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the JSON attributes representation to.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
MCbulkDataUriHandler implementation to handle writing BulkDataURI during generation of JSON stream. When set to null, all bulk attributes will be send as actual value. MCbulkDataUriHandler.provideUri method will only be called if vr is one of: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
writeToJSON Overload


writeToXML Method

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToXML Method
MCabstractMessage Class See Also Send Feedback
Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXML(
    TextWriter destination,
    MCxmlOptions xmlOptions
)
Visual Basic
Public Overridable Sub writeToXML ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions _
)
Visual C++
public:
virtual void writeToXML(
    TextWriter^ destination,
    MCxmlOptions xmlOptions
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members


writeToXMLNative Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToXMLNative Method
MCabstractMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).

See Also

MCabstractMessage Class
MCabstractMessage Members


writeToXMLNative Method (TextWriter, MCxmlOptions)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToXMLNative Method (TextWriter, MCxmlOptions)
MCabstractMessage Class See Also Send Feedback
Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXMLNative(
    TextWriter destination,
    MCxmlOptions xmlOptions
)
Visual Basic
Public Overridable Sub writeToXMLNative ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions _
)
Visual C++
public:
virtual void writeToXMLNative(
    TextWriter^ destination,
    MCxmlOptions xmlOptions
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
writeToXMLNative Overload


writeToXMLNative Method (TextWriter, MCxmlOptions, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCabstractMessage..::..writeToXMLNative Method (TextWriter, MCxmlOptions, MCbulkDataUriHandler)
MCabstractMessage Class See Also Send Feedback
Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXMLNative(
    TextWriter destination,
    MCxmlOptions xmlOptions,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub writeToXMLNative ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void writeToXMLNative(
    TextWriter^ destination,
    MCxmlOptions xmlOptions,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
MCbulkDataUriHandler implementation to handle writing BulkDataURI during generation of XML stream. When set to null, all bulk attributes will be send as actual value. MCbulkDataUriHandler.provideUri method will only be called if vr is one of: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCabstractMessage Class
MCabstractMessage Members
writeToXMLNative Overload


MCacceptor Interface

[image]

Merge DICOM .NET/C# Toolkit
MCacceptor Interface
Members See Also Send Feedback
Defines the method to handle incoming association requests.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCacceptor
Visual Basic
Public Interface MCacceptor
Visual C++
public interface class MCacceptor

Remarks

Applications that will provide a server that listens for DICOM association requests and processes them need to provide an implementation of this interface.

When an association request arrives at a specific port for a specific DICOM application, the Merge DICOM toolkit starts a new thread and calls the start method to process the received association request.

The startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) method of the MCassociation class is used to provide the Merge DICOM toolkit with an object that implements this interface.

See Also

MCacceptor Members


MCacceptor Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCacceptor Members
MCacceptor Interface Methods See Also Send Feedback

The MCacceptor type exposes the following members.

Methods

 | Name | Description
Public method | start | Starts processing of the user's acceptor handler thread. The thread will end when start() returns.

See Also

MCacceptor Interface


MCacceptor Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCacceptor Methods
MCacceptor Interface See Also Send Feedback

The MCacceptor type exposes the following members.

Methods

 | Name | Description
Public method | start | Starts processing of the user's acceptor handler thread. The thread will end when start() returns.

See Also

MCacceptor Interface


start Method

[image]

Merge DICOM .NET/C# Toolkit
MCacceptor..::..start Method
MCacceptor Interface See Also Send Feedback
Starts processing of the user's acceptor handler thread. The thread will end when start() returns.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void start(
    MCassociation assoc
)
Visual Basic
Sub start ( _
    assoc As MCassociation _
)
Visual C++
void start(
    MCassociation^ assoc
)

Parameters

assoc
Type: Mergecom..::..MCassociation
MCassociation representing the received association.

Remarks

If start() fails to catch an Exceptions, - a message will be logged.

See Also

MCacceptor Interface
MCacceptor Members


MCage Class

[image]

Merge DICOM .NET/C# Toolkit
MCage Class
Members See Also Send Feedback
Encapsulates a DICOM values with Value Representation Age String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCage
Visual Basic
Public Class MCage
Visual C++
public ref class MCage

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCage

See Also

MCage Members


MCage Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCage Members
MCage Class Constructors Methods See Also Send Feedback

The MCage type exposes the following members.

Constructors

 | Name | Description
Public method | MCage(String) | Constructs an MCage object using a preformatted DICOM age string.
Public method | MCage(Int32, String) | Constructs a new DICOM age value.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCage instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this object. (Overrides Object..::..ToString()()()().)

See Also

MCage Class


MCage Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCage Constructor
MCage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCage(String) | Constructs an MCage object using a preformatted DICOM age string.
Public method | MCage(Int32, String) | Constructs a new DICOM age value.

See Also

MCage Class
MCage Members


MCage Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCage Constructor (String)
MCage Class See Also Send Feedback
Constructs an MCage object using a preformatted DICOM age string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCage(
    string ageStr
)
Visual Basic
Public Sub New ( _
    ageStr As String _
)
Visual C++
public:
MCage(
    String^ ageStr
)

Parameters

ageStr
Type: System..::..String
The DICOM age string.

Remarks

This form of constructor does not check the value for conformance to DICOM Age String rules.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The parameter was null.

See Also

MCage Class
MCage Members
MCage Overload


MCage Constructor (Int32, String)

[image]

Merge DICOM .NET/C# Toolkit
MCage Constructor (Int32, String)
MCage Class See Also Send Feedback
Constructs a new DICOM age value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCage(
    int number,
    string period
)
Visual Basic
Public Sub New ( _
    number As Integer, _
    period As String _
)
Visual C++
public:
MCage(
    int number,
    String^ period
)

Parameters

number
Type: System..::..Int32
The number of days, weeks, months or years.
period
Type: System..::..String
The period represented by the number parameter: "D"ays, "W"eeks, "M"onths or "Y"ears.

Remarks

This form of the constructor is preferred since it insures the value will be properly formatted for the DICOM Age String(AS) Value Representation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments had illegal value.

See Also

MCage Class
MCage Members
MCage Overload


MCage Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCage Methods
MCage Class See Also Send Feedback

The MCage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCage instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this object. (Overrides Object..::..ToString()()()().)

See Also

MCage Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCage..::..Equals Method
MCage Class See Also Send Feedback
Determines whether the specified Object is equal to the current MCage instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current age string.

Return Value

true if the specified Object is an MCage instance and it represents the same age string as the current instance; otherwise false.

See Also

MCage Class
MCage Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCage..::..GetHashCode Method
MCage Class See Also Send Feedback
Returns a hash code representing this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current instance.

See Also

MCage Class
MCage Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCage..::..ToString Method
MCage Class See Also Send Feedback
Returns the string representation of this object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A non-null String containing the DICOM representation of the Age String.

See Also

MCage Class
MCage Members


MCapplication Class

[image]

Merge DICOM .NET/C# Toolkit
MCapplication Class
Members See Also Send Feedback
Represents a DICOM application entity.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCapplication
Visual Basic
Public Class MCapplication
Visual C++
public ref class MCapplication

Remarks

The MCapplication class represents an instance of a DICOM application entity. Each DICOM entity is identified by a 1-16 byte application entity title. Association negotiation, for example, uses an application's entity title to create a network connection between two participating applications.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCapplication

See Also

MCapplication Members


MCapplication Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCapplication Members
MCapplication Class Methods Properties See Also Send Feedback

The MCapplication type exposes the following members.

Methods

 | Name | Description
Public method | dispose | Disposes this application object.
Public method | Equals | Determines if this application equals another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getApplication | Retrieves the MCapplication object associated with an AE title.
Public method | GetHashCode | Returns a hash code representing this application. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | isValidAE | Determines if a string is a valid DICOM Application Entity Title.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | registerAttributeContainer | Registers an attribute value container for this application.
Public method | releaseAttributeContainer | Releases an attribute value container previously registered.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationTitle | Gets the DICOM Application Entity Title that identifies this application.

See Also

MCapplication Class


MCapplication Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCapplication Methods
MCapplication Class See Also Send Feedback

The MCapplication type exposes the following members.

Methods

 | Name | Description
Public method | dispose | Disposes this application object.
Public method | Equals | Determines if this application equals another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getApplication | Retrieves the MCapplication object associated with an AE title.
Public method | GetHashCode | Returns a hash code representing this application. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | isValidAE | Determines if a string is a valid DICOM Application Entity Title.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | registerAttributeContainer | Registers an attribute value container for this application.
Public method | releaseAttributeContainer | Releases an attribute value container previously registered.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCapplication Class


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..dispose Method
MCapplication Class See Also Send Feedback
Disposes this application object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void dispose()
Visual Basic
Public Overridable Sub dispose
Visual C++
public:
virtual void dispose()

Remarks

This method gives the library the opportunity to release any object references it may have in this application.

Any attempt to use this application object after it was dispose will result in an exception being thrown. To get a new application instance for the same AE Title use getApplication(String) method.

See Also

MCapplication Class
MCapplication Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..Equals Method
MCapplication Class See Also Send Feedback
Determines if this application equals another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare to.

Return Value

true if the object is an instance of MCapplication and it has the same AE title.

See Also

MCapplication Class
MCapplication Members


getApplication Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..getApplication Method
MCapplication Class See Also Send Feedback
Retrieves the MCapplication object associated with an AE title.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCapplication getApplication(
    string aeTitle
)
Visual Basic
Public Shared Function getApplication ( _
    aeTitle As String _
) As MCapplication
Visual C++
public:
static MCapplication^ getApplication(
    String^ aeTitle
)

Parameters

aeTitle
Type: System..::..String
The Application Entity Title of the requested application.

Return Value

An MCapplication instances for the requested AE title

Remarks

If there is no application object registered under the specified AE title this method creates a new one and registers it with the Merge DICOM .NET toolkit. If the application has already been created, that instance is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | Thrown if aeTitle is null or it has an invalid value.

See Also

MCapplication Class
MCapplication Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..GetHashCode Method
MCapplication Class See Also Send Feedback
Returns a hash code representing this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCapplication Class
MCapplication Members


isValidAE Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..isValidAE Method
MCapplication Class See Also Send Feedback
Determines if a string is a valid DICOM Application Entity Title.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool isValidAE(
    string ae
)
Visual Basic
Public Shared Function isValidAE ( _
    ae As String _
) As Boolean
Visual C++
public:
static bool isValidAE(
    String^ ae
)

Parameters

ae
Type: System..::..String
A string containing the application entity title.

Return Value

true if the string value validates according to the encoding rules for application entity titles.

See Also

MCapplication Class
MCapplication Members


registerAttributeContainer Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..registerAttributeContainer Method
MCapplication Class See Also Send Feedback
Registers an attribute value container for this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCattributeContainer registerAttributeContainer(
    MCtag tag,
    MCattributeContainer cb
)
Visual Basic
Public Overridable Function registerAttributeContainer ( _
    tag As MCtag, _
    cb As MCattributeContainer _
) As MCattributeContainer
Visual C++
public:
virtual MCattributeContainer^ registerAttributeContainer(
    MCtag^ tag,
    MCattributeContainer^ cb
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute for which the container is registered.
cb
Type: Mergecom..::..MCattributeContainer
The attribute value container to register.

Return Value

The previously registered attribute container or null if there was no attribute container registered.

Remarks

This method informs Merge DICOM toolkit that the MCattributeContainer instance will be responsible for maintaining the value of a given attribute. Methods of the registered MCattributeContainer are called by Merge DICOM toolkit to provide or retrieve an attribute's values as they are transmitted or received on a DICOM association or read or written to a DICOM file.

This method may only be called for attributes with Value Representations of OB, OW, OL, OD or OF.

Remarks

Please note that the method works correctly for standard attributes and for private attribute whose private creator code is an ASCII string as MCapplication does not have a specific character set context to be able to encode Unicode strings.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | The application has been disposed.

See Also

MCapplication Class
MCapplication Members


releaseAttributeContainer Method

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..releaseAttributeContainer Method
MCapplication Class See Also Send Feedback
Releases an attribute value container previously registered.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void releaseAttributeContainer(
    MCtag tag
)
Visual Basic
Public Overridable Sub releaseAttributeContainer ( _
    tag As MCtag _
)
Visual C++
public:
virtual void releaseAttributeContainer(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag that identifies the attribute for which the container was registered.

Remarks

This method releases the value container object that was registered for the attribute identified by tag. The container's methods will no longer be called when the attribute's value is being received or when the attribute's value is required. The container's methods will still be called, however, for MCdimseMessage objects or MCfile objects that were created before this method was called.

Remarks

Please note that the method works correctly for standard attributes and for private attribute whose private creator code is an ASCII string as MCapplication does not have a specific character set context to be able to encode Unicode strings.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCapplication Class
MCapplication Members


MCapplication Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCapplication Properties
MCapplication Class See Also Send Feedback

The MCapplication type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationTitle | Gets the DICOM Application Entity Title that identifies this application.

See Also

MCapplication Class


ApplicationTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCapplication..::..ApplicationTitle Property
MCapplication Class See Also Send Feedback
Gets the DICOM Application Entity Title that identifies this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ApplicationTitle { get; }
Visual Basic
Public Overridable ReadOnly Property ApplicationTitle As String
    Get
Visual C++
public:
virtual property String^ ApplicationTitle {
    String^ get ();
}

Field Value

A String representing this application's entity title.

See Also

MCapplication Class
MCapplication Members


MCassociation Class

[image]

Merge DICOM .NET/C# Toolkit
MCassociation Class
Members See Also Send Feedback
Represents a DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCassociation
Visual Basic
Public Class MCassociation
Visual C++
public ref class MCassociation

Remarks

This class represents a connection established between two DICOM application entities. It can be instantiated such that a specified MCapplication will serve the Service Class User (SCU) role and/or the Service Class Provider (SCP) role. The connection (known as an association) supports the exchange of network messages related to specifically negotiated DICOM services.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCassociation

See Also

MCassociation Members


MCassociation Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation Members
MCassociation Class Methods Fields Properties See Also Send Feedback

The MCassociation type exposes the following members.

Methods

 | Name | Description
Public method | abort | Requests that the association be aborted.
Public method | accept()()()() | Accepts an association request sent by an remote application.
Public method | accept(array<Byte>[]()[][]) | Accepts an association request sent by an remote application with User Identity server response.
Public method | continueRead | Reads one message intended for the caller until the end finishing any previous ToTag calls.
Public method | continueReadToStream | Continues the reading of the current message to a data sink
Public method | continueReadToTag | Reads one message intended for the caller up until the specified tag, starting from the previous ToTag call.
Public method | dispose | This routine disposes of native resources related to the association.
Public method | Equals | Determines if this object refers to the same association as another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | freeAcceptableContextInfo | Frees resources used to store acceptable context information.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
 | getThreadsAssociation | Returns the association that is being handled by the current thread.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | read(Int64) | Requests that a DIMSE message be read from the network.
Public method | read(Int64, MCReadError%) | Requests that a DIMSE message be read from the network.
Public method | readToStream | Reads data to a data sink
Public method | readToTag | Reads one message intended for the caller up until a specified tag
Public method | reject()()()() | Rejects an association request received from a remote application. The type of rejection is transient and the source is UL service user. No reason is given for the rejection.
Public method | reject(MCrejectReason) | Rejects an association request received from a remote application.
Public method | reject(Boolean, MCrejectReason) | Obsolete. Rejects an association request received from a remote application.
Public method | reject(UInt16, UInt16, UInt16) | Rejects an association request received from a remote application.
Public method | release | Releases an open association connection.
 | requestAssociation(MCapplication, MCremoteApplication, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
 | requestAssociation(MCapplication, MCremoteApplication, MCrequester, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
 | requestAssociation(MCapplication, MCremoteApplication, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application with User Identity.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCrequester, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application with User Identity.
 | setAETitles | Sets the list of allowed SCP AE titles
Public method | setNegotiationInfo | Sets extended user negotiation information for a specific service. This method may be called only for accepted associations.
 | startListening(MCapplication, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, Int32, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | stopListening(MCapplication, Int32) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given port.
 | stopListening(MCapplication, IPEndPoint) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given address and port.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MAX_CONCURRENT_ASSOCIATIONS | Maximum number of concurrent associations allowed by the library.

Properties

Name Description
Public property Acceptor
Determines if the local application is an association acceptor (or an association requester).
Public property Active
Determines if the association is active.
Public property ApplicationContextName
Gets the application context name used for the association.
Public property CalledApplicationTitle
Retrieves the application entity title of the acceptor application.
Public property CallingApplicationTitle
Retrieves the application entity title of the application that requested this association.
Public property FirstAcceptableContext
Retrieves the first acceptable context for this association.
Public property ListenPort
Retrieves the port number the acceptor is using.
Public property LocalApplication
Retrieves the local application identifying that is using this association.
Public property LocalApplicationTitle
Retrieves the local application entity title.
Public property LocalImplementationClassUid
Retrieves the local Implementation Class UID.
Public property LocalImplementationVersion
Retrieves the local Implementation Version property.
Public property LocalMaxPDUsize
Retrieves the maximum PDU size the local system is willing to receive.
Public property MaxOperationsInvoked
Retrieves the maximum number of simnultaneous operations negotiated over the association.
Public property MaxOperationsPerformed
Retrieves the maximum number of operations performed negotiated over the association.
Public property NextAcceptableContext
Retrieves the next acceptable context for this association.
Public property NumberOfAcceptableContexts
Retrieves the number of services accepted on this association.
Public property NumberOfProposedContexts
Retrieves the number of Presentation Contexts proposed on this association.
Public property ProposedContextList
Retrieves the Proposed Contexts used by this association.
Public property ReadTimeout
Retrieves the timeout value specified in the last read(Int64) or read(Int64, MCReadError%) call.
Public property RemoteAddress
Retrieves the IPEndPoint object of the remote system.
Public property RemoteApplicationTitle
Retrieves the application entity title of the remote application.
Public property RemoteHostName
Retrieves the Host Name of the remote application.
Public property RemoteImplementationClassUid
Retrieves the Implementation Class UID of the remote application.
Public property RemoteImplementationVersion
Retrieves the Implementation Version of the remote application.
Public property RemoteIp
Retrieves IP address of the remote application.
Public property RemoteIpAddress
Retrieves the Presentation Address of the remote application.
Public property RemoteMaxPDUsize
Retrieves the maximum PDU size the remote system is willing to receive.
Public property RemotePort
Retrieves the port number the remote system is listening on.
Public property Requester
Determines if the local application is an association requester (or an association acceptor).
Public property UserIdentity
Return the MCuserIdentity type of the association.
Value | Meaning
0 | Undefined User Identity
1 | Username as a string in UTF-8
2 | Username as a string in UTF-8 and passcode
3 | Kerberos Service ticket
4 | SAML Assertion
5 | JSON Web Token (JWT)
Public property UserIdentityPrimaryField
User Identity Primary Field
Public property UserIdentityResponse
User Identity Server Response
Public property UserIdentityResponseReceived
Returns True if user identity response was received.
Public property UserIdentityResponseRequested
Returns True if user identity response was requested.
Public property UserIdentitySecondaryField
User Identity Secondary Field
Public property WaitInCallerThread
This property determines if the association will wait for read events in its own thread if false or in the caller thread if true.

See Also

MCassociation Class


MCassociation Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation Fields
MCassociation Class See Also Send Feedback

The MCassociation type exposes the following members.

Fields

Name | Description
MAX_CONCURRENT_ASSOCIATIONS | Maximum number of concurrent associations allowed by the library.

See Also

MCassociation Class


MAX_CONCURRENT_ASSOCIATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..MAX_CONCURRENT_ASSOCIATIONS Field
MCassociation Class See Also Send Feedback
Maximum number of concurrent associations allowed by the library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int MAX_CONCURRENT_ASSOCIATIONS
Visual Basic
Public Shared ReadOnly MAX_CONCURRENT_ASSOCIATIONS As Integer
Visual C++
public:
static initonly int MAX_CONCURRENT_ASSOCIATIONS

See Also

MCassociation Class
MCassociation Members


MCassociation Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation Methods
MCassociation Class See Also Send Feedback

The MCassociation type exposes the following members.

Methods

 | Name | Description
Public method | abort | Requests that the association be aborted.
Public method | accept()()()() | Accepts an association request sent by an remote application.
Public method | accept(array<Byte>[]()[][]) | Accepts an association request sent by an remote application with User Identity server response.
Public method | continueRead | Reads one message intended for the caller until the end finishing any previous ToTag calls.
Public method | continueReadToStream | Continues the reading of the current message to a data sink
Public method | continueReadToTag | Reads one message intended for the caller up until the specified tag, starting from the previous ToTag call.
Public method | dispose | This routine disposes of native resources related to the association.
Public method | Equals | Determines if this object refers to the same association as another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | freeAcceptableContextInfo | Frees resources used to store acceptable context information.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
 | getThreadsAssociation | Returns the association that is being handled by the current thread.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | read(Int64) | Requests that a DIMSE message be read from the network.
Public method | read(Int64, MCReadError%) | Requests that a DIMSE message be read from the network.
Public method | readToStream | Reads data to a data sink
Public method | readToTag | Reads one message intended for the caller up until a specified tag
Public method | reject()()()() | Rejects an association request received from a remote application. The type of rejection is transient and the source is UL service user. No reason is given for the rejection.
Public method | reject(MCrejectReason) | Rejects an association request received from a remote application.
Public method | reject(Boolean, MCrejectReason) | Obsolete. Rejects an association request received from a remote application.
Public method | reject(UInt16, UInt16, UInt16) | Rejects an association request received from a remote application.
Public method | release | Releases an open association connection.
 | requestAssociation(MCapplication, MCremoteApplication, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
 | requestAssociation(MCapplication, MCremoteApplication, MCrequester, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
 | requestAssociation(MCapplication, MCremoteApplication, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application with User Identity.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCrequester, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
 | requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application with User Identity.
 | setAETitles | Sets the list of allowed SCP AE titles
Public method | setNegotiationInfo | Sets extended user negotiation information for a specific service. This method may be called only for accepted associations.
 | startListening(MCapplication, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, Int32, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
 | stopListening(MCapplication, Int32) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given port.
 | stopListening(MCapplication, IPEndPoint) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given address and port.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCassociation Class


abort Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..abort Method
MCassociation Class See Also Send Feedback
Requests that the association be aborted.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void abort()
Visual Basic
Public Overridable Sub abort
Visual C++
public:
virtual void abort()

Remarks

Either an association acceptor or an association requestor may issue the abort request to bring an abrupt end to the association. The corresponding TCP/IP connection is also released. When this method call returns, the association is no longer "active".

See Also

MCassociation Class
MCassociation Members


accept Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..accept Method
MCassociation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | accept()()()() | Accepts an association request sent by an remote application.
Public method | accept(array<Byte>[]()[][]) | Accepts an association request sent by an remote application with User Identity server response.

See Also

MCassociation Class
MCassociation Members


accept Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..accept Method
MCassociation Class See Also Send Feedback
Accepts an association request sent by an remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void accept()
Visual Basic
Public Overridable Sub accept
Visual C++
public:
virtual void accept()

Remarks

Merge DICOM toolkit notifies the MCacceptor class when an association request is received from a remote DICOM application by calling its start method. The start method may call accept to indicate that it is satisfied with the parameters of the association as proposed by the remote requester application.

The Merge DICOM toolkit library has already determined that both the local and remote applications wish to perform at least one common service. The FirstAcceptableContext and NextAcceptableContext properties may be used to examine the services that are agreeable to both sides. Several other properties are available to inquire about the remote application. If this application agrees with the acceptable services, it issues this accept method to establish an association between the two applications.

Note that a reject()()()() method call may be made to reject the association request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCruntimeException | The call is not appropriate in the current context.

See Also

MCassociation Class
MCassociation Members
accept Overload


accept Method (Byte[])

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..accept Method (array<Byte>[]()[][])
MCassociation Class See Also Send Feedback
Accepts an association request sent by an remote application with User Identity server response.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void accept(
    byte[] userIdentityResponse
)
Visual Basic
Public Overridable Sub accept ( _
    userIdentityResponse As Byte() _
)
Visual C++
public:
virtual void accept(
    array<unsigned char>^ userIdentityResponse
)

Parameters

userIdentityResponse
Type: array<System..::..Byte>[]()[][]
If the association requestor has requested a positive acknowledgment the response has to be the Kerberos Server ticket if User Identity value was Kerberos Service ticket (3) or the SAML assertion if User Identity value was SAML Assertion (4).

Remarks

Merge DICOM toolkit notifies the MCacceptor class when an association request is received from a remote DICOM application by calling its start method. The start method may call accept to indicate that it is satisfied with the parameters of the association as proposed by the remote requester application.

The Merge DICOM toolkit library has already determined that both the local and remote applications wish to perform at least one common service. The FirstAcceptableContext and NextAcceptableContext properties may be used to examine the services that are agreeable to both sides. Several other properties are available to inquire about the remote application. If this application agrees with the acceptable services, it issues this accept method to establish an association between the two applications.

Note that a reject()()()() method call may be made to reject the association request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCruntimeException | The call is not appropriate in the current context.

See Also

MCassociation Class
MCassociation Members
accept Overload


continueRead Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..continueRead Method
MCassociation Class See Also Send Feedback
Reads one message intended for the caller until the end finishing any previous ToTag calls.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCReadError continueRead(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function continueRead ( _
    msg As MCdimseMessage _
) As MCReadError
Visual C++
public:
virtual MCReadError continueRead(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
An instance of MCdimseMessage containing the received message which was returned from previous readToTag or continueReadToTag call. continueRead doesn't create another new message, it just adds more attributes to the msg if the previous operation didn't read to the end of the message.

Return Value

A MCReadError object that stores the "read" operation error .

Remarks

continueRead requires that a previous readToTag or continueReadToTag was called, otherwise the operation is not allowed.

See Also

MCassociation Class
MCassociation Members


continueReadToStream Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..continueReadToStream Method
MCassociation Class See Also Send Feedback
Continues the reading of the current message to a data sink

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCReadError continueReadToStream(
    MCdataSink stream,
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function continueReadToStream ( _
    stream As MCdataSink, _
    msg As MCdimseMessage _
) As MCReadError
Visual C++
public:
virtual MCReadError continueReadToStream(
    MCdataSink^ stream,
    MCdimseMessage^ msg
)

Parameters

stream
Type: Mergecom..::..MCdataSink
The destination for the received message
msg
Type: Mergecom..::..MCdimseMessage
An instance of MCdimseMessage containing the received message which was returned from previous readToTag or continueReadToTag call.

Return Value

A MCReadError object that stores the "read" operation error .

Remarks

continueReadToStream requires that a previous readToTag or continueReadToTag was called, otherwise the operation is not allowed.

See Also

MCassociation Class
MCassociation Members


continueReadToTag Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..continueReadToTag Method
MCassociation Class See Also Send Feedback
Reads one message intended for the caller up until the specified tag, starting from the previous ToTag call.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCReadError continueReadToTag(
    uint stopTag,
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function continueReadToTag ( _
    stopTag As UInteger, _
    msg As MCdimseMessage _
) As MCReadError
Visual C++
public:
virtual MCReadError continueReadToTag(
    unsigned int stopTag,
    MCdimseMessage^ msg
)

Parameters

stopTag
Type: System..::..UInt32
Read up to and include this tag when reading from the remote application. Must be outside the command section ( greater than or equal to (0001,0000))
msg
Type: Mergecom..::..MCdimseMessage
An instance of MCdimseMessage containing the received message which was returned from previous readToTag or continueReadToTag call. continueReadToTag doesn't create another new message, it just adds more attributes to the msg if the previous operation didn't read to the end of the message.

Return Value

A MCReadError object that stores the "read" operation error.

Remarks

continueReadToTag requires that a previous readToTag or continueReadToTag was called, otherwise the operation is not allowed.

See Also

MCassociation Class
MCassociation Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..dispose Method
MCassociation Class See Also Send Feedback
This routine disposes of native resources related to the association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCassociation Class
MCassociation Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..Equals Method
MCassociation Class See Also Send Feedback
Determines if this object refers to the same association as another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare to.

Return Value

true if the object is an instance of MCassociation and it refers to the same association.

See Also

MCassociation Class
MCassociation Members


freeAcceptableContextInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..freeAcceptableContextInfo Method
MCassociation Class See Also Send Feedback
Frees resources used to store acceptable context information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void freeAcceptableContextInfo()
Visual Basic
Public Overridable Sub freeAcceptableContextInfo
Visual C++
public:
virtual void freeAcceptableContextInfo()

Remarks

The library saves information about presentation contexts that are agreeable to both the association acceptor and association requester. This information is retrieved using the FirstAcceptableContext and NextAcceptableContext methods. If there is no further need to retrieve the information, this method may be called to free up the resources needed to store the information.

See Also

MCassociation Class
MCassociation Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..GetHashCode Method
MCassociation Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCassociation Class
MCassociation Members


getThreadsAssociation Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..getThreadsAssociation Method
MCassociation Class See Also Send Feedback
Returns the association that is being handled by the current thread.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassociation getThreadsAssociation()
Visual Basic
Public Shared Function getThreadsAssociation As MCassociation
Visual C++
public:
static MCassociation^ getThreadsAssociation()

Return Value

The MCassociation object being handled by the current thread or null if no association is running on the current thread.

Remarks

This method is to be used by MCattributeContainer instances to determine which association is being handled by the current thread.

See Also

MCassociation Class
MCassociation Members


read Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..read Method
MCassociation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | read(Int64) | Requests that a DIMSE message be read from the network.
Public method | read(Int64, MCReadError%) | Requests that a DIMSE message be read from the network.

See Also

MCassociation Class
MCassociation Members


read Method (Int64)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..read Method (Int64)
MCassociation Class See Also Send Feedback
Requests that a DIMSE message be read from the network.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage read(
    long timeout
)
Visual Basic
Public Overridable Function read ( _
    timeout As Long _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ read(
    long long timeout
)

Parameters

timeout
Type: System..::..Int64
The time (in milliseconds, but gets rounded to the nearest second) to wait for a message to arrive. Zero (0) means "check one time" and minus one (-1) means "wait forever".

Return Value

An instance of MCdimseMessage containing the received message. If a timeout occurs, null is returned.

Remarks

DICOM messages are exchanged over an active association connection. After successfully constructing a new MCassociation object and negotiating the association parameters, applications must read for DIMSE messages sent by the remote application. (DIMSE stands for DICOM Message Service Element.)

A DICOM service class user (SCU) sends request messages to the remote application to request that a service be performed. The service class provider (SCP) responds by sending one or more response messages back. The read method is used to retrieve these request and response messages.

Once a message begins arriving, the INACTIVITY_TIMEOUT configuration value is used. While receiving the message, the association will be aborted if there is no activity on the network for the length of time specified by this configuration value.

When a message arrives, the Merge DICOM toolkit returns an MCdimseMessage object. That object encapsulates both the DIMSE command set and the DIMSE data set which comprise the message. Methods of the MCdimseMessage class provide access to the command set (MCcommandSet object) and data set (MCdataSet object).

Normally, attributes of the command set may be accessed by using methods of the MCdimseMessage class rather than interrogating the MCcommandSet object. The name of the service associated with the message may be obtained using the getServiceName method of the MCdimseMessage class.

If the message is a request message, methods of one of the MCdimseService classes are used to send a response to the remote application.

NOTES: A read operation requires that a previous partial reading operation if there is one, readToTag or continueReadToTag read to the end of the message, otherwise the operation is not allowed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationReleasedStatus | The remote network partner released the network connection. The association is no longer active and no further network activity may be requested.
Mergecom.Exceptions..::..MCassociationAbortedException | The association has been aborted by local or remote application or by the local or remote DIMSE provider (e.g. Merge DICOM toolkit). A message describing the error has been written to the Merge DICOM toolkit log file. No further network activity may be requested.
Mergecom.Exceptions..::..MCinactivityTimeoutException | An inactivity timeout occurred on the network during the read operation. The association is no longer active and no further network activity may be requested.
Mergecom.Exceptions..::..MCinvalidMessageReceivedException | An improperly formatted DICOM message was received. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.
Mergecom.Exceptions..::..MCnetworkShutdownException | The network connection unexpectedly dropped. The association is no longer active and no further network activity may be requested.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.
Mergecom.Exceptions..::..MCoperationNotAllowedException | If a previous partial reading operation readToTag or continueReadToTag didn't read to the end of the message.

See Also

MCassociation Class
MCassociation Members
read Overload


read Method (Int64, MCReadError)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..read Method (Int64, MCReadError%)
MCassociation Class See Also Send Feedback
Requests that a DIMSE message be read from the network.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage read(
    long timeout,
    out MCReadError errorCode
)
Visual Basic
Public Overridable Function read ( _
    timeout As Long, _
    <OutAttribute> ByRef errorCode As MCReadError _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ read(
    long long timeout,
    [OutAttribute] MCReadError% errorCode
)

Parameters

timeout
Type: System..::..Int64
The time (in milliseconds, but gets rounded to the nearest second) to wait for a message to arrive. Zero (0) means "check one time" and minus one (-1) means "wait forever".
errorCode
Type: Mergecom..::..MCReadError %
A MCReadError object that stores the "read" operation error .

Return Value

An instance of MCdimseMessage containing the received message.If a reading error occurs, null is returned.

Remarks

It has the same functionality with read(Int64). The difference lies on the style of dealing with errors. Instead of throwing all kinds of exceptions, it stores the reading operation error in a MCReadError object which is passed by reference as an argument.

NOTES: A read operation requires that a previous partial reading operation if there is one, readToTag or continueReadToTag read to the end of the message, otherwise the operation is not allowed.

See Also

MCassociation Class
MCassociation Members
read Overload


readToStream Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..readToStream Method
MCassociation Class See Also Send Feedback
Reads data to a data sink

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCReadError readToStream(
    MCdataSink stream,
    long timeout,
    string name
)
Visual Basic
Public Overridable Function readToStream ( _
    stream As MCdataSink, _
    timeout As Long, _
    name As String _
) As MCReadError
Visual C++
public:
virtual MCReadError readToStream(
    MCdataSink^ stream,
    long long timeout,
    String^ name
)

Parameters

stream
Type: Mergecom..::..MCdataSink
The destination for the received message
timeout
Type: System..::..Int64
The time (in milliseconds, but gets rounded to the nearest second) to wait for a message to arrive. Zero (0) means "check one time" and minus one (-1) means "wait forever".
name
Type: System..::..String
The destination name for the received message (may be null)

Return Value

A MCReadError object that stores the "read" operation error .

Remarks

ReadToStream dosn't require previous read, readToTag or continueReadToTagwas called.

See Also

MCassociation Class
MCassociation Members


readToTag Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..readToTag Method
MCassociation Class See Also Send Feedback
Reads one message intended for the caller up until a specified tag

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage readToTag(
    long timeout,
    uint stopTag,
    out MCReadError errorCode
)
Visual Basic
Public Overridable Function readToTag ( _
    timeout As Long, _
    stopTag As UInteger, _
    <OutAttribute> ByRef errorCode As MCReadError _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ readToTag(
    long long timeout,
    unsigned int stopTag,
    [OutAttribute] MCReadError% errorCode
)

Parameters

timeout
Type: System..::..Int64
The time (in milliseconds, but gets rounded to the nearest second) to wait for a message to arrive. Zero (0) means "check one time" and minus one (-1) means "wait forever".
stopTag
Type: System..::..UInt32
Read up to and include this tag when reading from the remote application. Must be outside the command section ( greater than or equal to (0001,0000))
errorCode
Type: Mergecom..::..MCReadError %
A MCReadError object that stores the "read" operation error .

Return Value

An instance of MCdimseMessage containing the received message. If a reading error occurs, null is returned.

Remarks

NOTES: A readToTag operation requires that a previous partial reading operation if there is one, readToTag or continueReadToTag read to the end of the message, otherwise the operation is not allowed.

See Also

MCassociation Class
MCassociation Members


reject Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..reject Method
MCassociation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | reject()()()() | Rejects an association request received from a remote application. The type of rejection is transient and the source is UL service user. No reason is given for the rejection.
Public method | reject(MCrejectReason) | Rejects an association request received from a remote application.
Public method | reject(Boolean, MCrejectReason) | Obsolete. Rejects an association request received from a remote application.
Public method | reject(UInt16, UInt16, UInt16) | Rejects an association request received from a remote application.

See Also

MCassociation Class
MCassociation Members


reject Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..reject Method
MCassociation Class See Also Send Feedback
Rejects an association request received from a remote application. The type of rejection is transient and the source is UL service user. No reason is given for the rejection.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void reject()
Visual Basic
Public Overridable Sub reject
Visual C++
public:
virtual void reject()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCoperationNotAllowedException | The method was called at an inappropriate time.

See Also

MCassociation Class
MCassociation Members
reject Overload


reject Method (MCrejectReason)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..reject Method (MCrejectReason)
MCassociation Class See Also Send Feedback
Rejects an association request received from a remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void reject(
    MCrejectReason reason
)
Visual Basic
Public Overridable Sub reject ( _
    reason As MCrejectReason _
)
Visual C++
public:
virtual void reject(
    MCrejectReason reason
)

Parameters

reason
Type: Mergecom..::..MCrejectReason
One of the reasons specified by the MCrejectReason enum.

Remarks

The value of the reason parameter determines the transient or permanent character of the rejection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCruntimeException | The method was called at an inappropriate time.

See Also

MCassociation Class
MCassociation Members
reject Overload


reject Method (Boolean, MCrejectReason)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..reject Method (Boolean, MCrejectReason)
MCassociation Class See Also Send Feedback
Rejects an association request received from a remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete as there are inconsistencies between the method parameters. Use the other reject() overloads instead.")]
public virtual void reject(
    bool permanentRejection,
    MCrejectReason reason
)
Visual Basic
<ObsoleteAttribute("This method is obsolete as there are inconsistencies between the method parameters. Use the other reject() overloads instead.")> _
Public Overridable Sub reject ( _
    permanentRejection As Boolean, _
    reason As MCrejectReason _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete as there are inconsistencies between the method parameters. Use the other reject() overloads instead.")]
virtual void reject(
    bool permanentRejection,
    MCrejectReason reason
)

Parameters

permanentRejection
Type: System..::..Boolean
If true the rejection is permanent and no further association requests are expected.
reason
Type: Mergecom..::..MCrejectReason
One of the reasons specified by the MCrejectReason enum.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCruntimeException | The method was called at an inappropriate time.

See Also

MCassociation Class
MCassociation Members
reject Overload


reject Method (UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..reject Method (UInt16, UInt16, UInt16)
MCassociation Class See Also Send Feedback
Rejects an association request received from a remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void reject(
    ushort result,
    ushort source,
    ushort reason
)
Visual Basic
Public Overridable Sub reject ( _
    result As UShort, _
    source As UShort, _
    reason As UShort _
)
Visual C++
public:
virtual void reject(
    unsigned short result,
    unsigned short source,
    unsigned short reason
)

Parameters

result
Type: System..::..UInt16
Permanent or transient rejection (1, 2)
source
Type: System..::..UInt16
A valid DICOM sourcr code (1, 2, 3)
reason
Type: System..::..UInt16
A valid DICOM reason code (1, 2, 3, 7)

Remarks

The value of the reason parameter determines the transient or permanent character of the rejection.

See the DICOM Standard (DICOM PS3.8 2018c, Section 9.3.4 A-ASSOCIATE-RJ PDU Structure for more details.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCruntimeException | The method was called at an inappropriate time.

See Also

MCassociation Class
MCassociation Members
reject Overload


release Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..release Method
MCassociation Class See Also Send Feedback
Releases an open association connection.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void release()
Visual Basic
Public Overridable Sub release
Visual C++
public:
virtual void release()

Remarks

An association requestor can release an association when it has completed its work for the association.

Note that an association acceptor cannot release an association. It is required by DICOM to abort()()()() an association if it wants to close the association.

When an association requester application releases the association, the two application entities must react as follows:

Association Type | Description
Association Requestor | Once the release method is called, the association is considered inactive and the requester may no longer make any method calls other than an abort()()()(). MCassociation objects created for this association may no longer send messages to the association partner. The requestor may, however, continue to receive messages until it is informed that the association has been closed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | The association is called at an invalid time or by an associationacceptor.
Mergecom.Exceptions..::..MCassociationAbortedException | The association has been aborted

See Also

MCassociation Class
MCassociation Members


requestAssociation Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestAssociation Method
MCassociation Class See Also Send Feedback

Overload List

Name | Description
requestAssociation(MCapplication, MCremoteApplication, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
requestAssociation(MCapplication, MCremoteApplication, MCrequester, Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.
requestAssociation(MCapplication, MCremoteApplication, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application with User Identity.

See Also

MCassociation Class
MCassociation Members


requestAssociation Method (MCapplication, MCremoteApplication, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestAssociation Method (MCapplication, MCremoteApplication, Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassociation requestAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    int connectTimeout = 0
)
Visual Basic
Public Shared Function requestAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    Optional connectTimeout As Integer = 0 _
) As MCassociation
Visual C++
public:
static MCassociation^ requestAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several properties are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService sub-classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected the association request. The information about the circumstances and reason the association was rejected (result, source & reason) can be retrieved from the RejectInfo property of the MCassociationRejectedException.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestAssociation Overload


requestAssociation Method (MCapplication, MCremoteApplication, MCrequester, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestAssociation Method (MCapplication, MCremoteApplication, MCrequester, Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void requestAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    MCrequester handler,
    int connectTimeout = 0
)
Visual Basic
Public Shared Sub requestAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    handler As MCrequester, _
    Optional connectTimeout As Integer = 0 _
)
Visual C++
public:
static void requestAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    MCrequester^ handler,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
handler
Type: Mergecom..::..MCrequester
A not null reference to an instance of a class that implements the MCrequester interface.
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by the Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the setNegotiationInfo(MCapplication, String, MCnegotiationInfo) method must be used to provide the negotiation information to the Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several methods of the MCassociation class are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService derived classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected the association request. The information about the circumstances and reason the association was rejected (result, source & reason) can be retrieved from the RejectInfo propery of the MCassociationRejectedException.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestAssociation Overload


requestAssociation Method (MCapplication, MCremoteApplication, MCuserIdentity, Boolean, Byte[], Byte[], Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestAssociation Method (MCapplication, MCremoteApplication, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a DICOM association between this application and a remote DICOM application with User Identity.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassociation requestAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    MCuserIdentity userIdentity,
    bool requestResponse,
    byte[] primaryField,
    byte[] secondaryField,
    int connectTimeout = 0
)
Visual Basic
Public Shared Function requestAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    userIdentity As MCuserIdentity, _
    requestResponse As Boolean, _
    primaryField As Byte(), _
    secondaryField As Byte(), _
    Optional connectTimeout As Integer = 0 _
) As MCassociation
Visual C++
public:
static MCassociation^ requestAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    MCuserIdentity userIdentity,
    bool requestResponse,
    array<unsigned char>^ primaryField,
    array<unsigned char>^ secondaryField,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
userIdentity
Type: Mergecom..::..MCuserIdentity
An MCuserIdentity value
requestResponse
Type: System..::..Boolean
True if the positive response is requested
primaryField
Type: array<System..::..Byte>[]()[][]
The primary field that conveys the user identity, either the username as a series of characters, or the Kerberos Service ticket encoded in accordance with RFC-1510, or the JWT encoded in accordance with RFC 7519 using base64url encoded parts.
secondaryField
Type: array<System..::..Byte>[]()[][]
The secondary field is present only if MCuserIdentity value is USERNAME_AND_PASSCODE and contains the passcode value.
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several properties are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService sub-classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected the association request. The information about the circumstances and reason the association was rejected (result, source & reason) can be retrieved from the RejectInfo property of the MCassociationRejectedException.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestAssociation Overload


requestSecureAssociation Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestSecureAssociation Method
MCassociation Class See Also Send Feedback

Overload List

Name | Description
requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
requestSecureAssociation(MCapplication, MCremoteApplication, MCrequester, MCsecureContext, Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.
requestSecureAssociation(MCapplication, MCremoteApplication, MCsecureContext, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32) | Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application with User Identity.

See Also

MCassociation Class
MCassociation Members


requestSecureAssociation Method (MCapplication, MCremoteApplication, MCsecureContext, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestSecureAssociation Method (MCapplication, MCremoteApplication, MCsecureContext, Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassociation requestSecureAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    MCsecureContext secureContext,
    int connectTimeout = 0
)
Visual Basic
Public Shared Function requestSecureAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    secureContext As MCsecureContext, _
    Optional connectTimeout As Integer = 0 _
) As MCassociation
Visual C++
public:
static MCassociation^ requestSecureAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    MCsecureContext^ secureContext,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestSecureAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several properties are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService sub-classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected this association requester's association request.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestSecureAssociation Overload


requestSecureAssociation Method (MCapplication, MCremoteApplication, MCrequester, MCsecureContext, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestSecureAssociation Method (MCapplication, MCremoteApplication, MCrequester, MCsecureContext, Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void requestSecureAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    MCrequester handler,
    MCsecureContext secureContext,
    int connectTimeout = 0
)
Visual Basic
Public Shared Sub requestSecureAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    handler As MCrequester, _
    secureContext As MCsecureContext, _
    Optional connectTimeout As Integer = 0 _
)
Visual C++
public:
static void requestSecureAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    MCrequester^ handler,
    MCsecureContext^ secureContext,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
handler
Type: Mergecom..::..MCrequester
A not null reference to an instance of a class that implements the MCrequester interface.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestSecureAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by the Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the information to the Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several methods of the MCassociation class are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService derived classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected this association requester's association request.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestSecureAssociation Overload


requestSecureAssociation Method (MCapplication, MCremoteApplication, MCsecureContext, MCuserIdentity, Boolean, Byte[], Byte[], Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..requestSecureAssociation Method (MCapplication, MCremoteApplication, MCsecureContext, MCuserIdentity, Boolean, array<Byte>[]()[][], array<Byte>[]()[][], Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit establish a secure DICOM association between this application and a remote DICOM application with User Identity.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassociation requestSecureAssociation(
    MCapplication app,
    MCremoteApplication remoteAE,
    MCsecureContext secureContext,
    MCuserIdentity userIdentity,
    bool requestResponse,
    byte[] primaryField,
    byte[] secondaryField,
    int connectTimeout = 0
)
Visual Basic
Public Shared Function requestSecureAssociation ( _
    app As MCapplication, _
    remoteAE As MCremoteApplication, _
    secureContext As MCsecureContext, _
    userIdentity As MCuserIdentity, _
    requestResponse As Boolean, _
    primaryField As Byte(), _
    secondaryField As Byte(), _
    Optional connectTimeout As Integer = 0 _
) As MCassociation
Visual C++
public:
static MCassociation^ requestSecureAssociation(
    MCapplication^ app,
    MCremoteApplication^ remoteAE,
    MCsecureContext^ secureContext,
    MCuserIdentity userIdentity,
    bool requestResponse,
    array<unsigned char>^ primaryField,
    array<unsigned char>^ secondaryField,
    int connectTimeout = 0
)

Parameters

app
Type: Mergecom..::..MCapplication
An MCapplication instance for the local application opening the association.
remoteAE
Type: Mergecom..::..MCremoteApplication
An instance to connect to.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session
userIdentity
Type: Mergecom..::..MCuserIdentity
An MCuserIdentity value
requestResponse
Type: System..::..Boolean
True if the positive response is requested
primaryField
Type: array<System..::..Byte>[]()[][]
The primary field that conveys the user identity, either the username as a series of characters, or the Kerberos Service ticket encoded in accordance with RFC-1510, or the JWT encoded in accordance with RFC 7519 using base64url encoded parts.
secondaryField
Type: array<System..::..Byte>[]()[][]
The secondary field is present only if MCuserIdentity value is USERNAME_AND_PASSCODE and contains the passcode value.
connectTimeout (Optional)
Type: System..::..Int32
Connect timeout for this association request only (supersedes the global CONNECT_TIMEOUT configuration setting)

Return Value

An MCassociation instance for the connected association.

Remarks

Two options are available for processing the resulting association. If the thread that is making the requestSecureAssociation call wishes to process the association that results from this call, a form without an MCrequester parameter should be used. In that case, an MCassociation object is returned and the calling thread uses that object to send and receives DICOM messages over the association.

Alternatively, methods that include an MCrequester parameter are used to have a separate thread process the resulting association. In that case, the start method of the handler provided is called by Merge DICOM toolkit from a newly created thread after the association has been negotiated, passing an MCassociation object. When the handler returns from its start method the thread in which it is running is ended. Refer to the MCrequester interface for more details on the handler.

The MCassociation object that results from this method call represents a connection established between two DICOM application entities. An application can be either an association acceptor or an association requestor, but not both on the same association connection. An association acceptor waits for incoming connections and decides whether or not to accept the proposed association. An association requester connects to a remote application and requests that it accept its proposed association. If the application is to serve both as an association acceptor and as association requester, multiple MCassociation instances must be started. Refer to the startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) method for information on how to play the acceptor role.

For some forms of this method, before requesting a new MCassociation instance, an MCproposedContextList object may be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to Merge DICOM toolkit.

As a result of calling this method, the library will attempt to negotiate an association with the remote DICOM application. When the association request is received by the remote DICOM system, the remote application must be able to perform at least one of the services in this application's service list. If not, the remote DICOM system rejects the request and an MCassociationRejectedException is thrown. The remote application may also reject the association request for other reasons. If the association is accepted, several properties are available to retrieve information about the services that were acceptable to both sides.

If the remote application releases or aborts the association, the library will notify the local application in response to a read method call of the MCassociation class, by throwing either MCassociationReleasedStatus or MCassociationAbortedException.

Methods of the MCdimseService sub-classes are used to send messages over the opened association connection.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.
Mergecom.Exceptions..::..MCunknownHostNameException | The remoteHostName is unknown to the system, or the host name configured for remoteAeTitle is unknown to the system.
Mergecom.Exceptions..::..MCassociationRejectedException | The remote DICOM application rejected this association requester's association request.
Mergecom.Exceptions..::..MCconnectionFailedException | The attempt to connect to the application on the remote host failed.
Mergecom.Exceptions..::..MCnegotiationAbortedException | The association was aborted during the negotiation process. Normally this situation is handled by retrying.

See Also

MCassociation Class
MCassociation Members
requestSecureAssociation Overload


setAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..setAETitles Method
MCassociation Class See Also Send Feedback
Sets the list of allowed SCP AE titles

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setAETitles(
    string[] AETitles
)
Visual Basic
Public Shared Sub setAETitles ( _
    AETitles As String() _
)
Visual C++
public:
static void setAETitles(
    array<String^>^ AETitles
)

Parameters

AETitles
Type: array<System..::..String>[]()[][]
The list of AE titles

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An invalid application info or "out of memory" system error.

See Also

MCassociation Class
MCassociation Members


setNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..setNegotiationInfo Method
MCassociation Class See Also Send Feedback
Sets extended user negotiation information for a specific service. This method may be called only for accepted associations.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void setNegotiationInfo(
    string serviceName,
    byte[] extendedInfo
)
Visual Basic
Public Overridable Sub setNegotiationInfo ( _
    serviceName As String, _
    extendedInfo As Byte() _
)
Visual C++
public:
virtual void setNegotiationInfo(
    String^ serviceName,
    array<unsigned char>^ extendedInfo
)

Parameters

serviceName
Type: System..::..String
The name of the service for which the extended negotiation information is set.
extendedInfo
Type: array<System..::..Byte>[]()[][]
A byte array containing the extended negotiation information.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCoperationNotAllowedException | The current association is a requested association or it was already accepted, or rejected.

See Also

MCassociation Class
MCassociation Members


startListening Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method
MCassociation Class See Also Send Feedback

Overload List

Name | Description
startListening(MCapplication, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
startListening(MCapplication, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
startListening(MCapplication, Int32, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
startListening(MCapplication, Int32, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor) | Request that the Merge DICOM toolkit listen for association requests directed to this application.
startListening(MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor, MCsecureContext) | Request that the Merge DICOM toolkit listen for association requests directed to this application.

See Also

MCassociation Class
MCassociation Members


startListening Method (MCapplication, MCproposedContextList, MCacceptor)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, MCproposedContextList, MCacceptor)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    MCproposedContextList contextList,
    MCacceptor handler
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    contextList As MCproposedContextList, _
    handler As MCacceptor _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    MCproposedContextList^ contextList,
    MCacceptor^ handler
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form takes the listen port number from the TCPIP_LISTEN_PORT configuration option. Applications can listen on same port multiple times with different Application Entity titles.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the MCacceptor.start method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the MCacceptor.start call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, Int32) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to the Merge DICOM toolkit.

The toolkit will listen for connections on all network interfaces, but depending on the IP_TYPE configuration option it will set up either an IPv4 or an IPv6 socket listener. If the IP_TYPE configuration value is 'AVAILABLE' the toolkit will set up an IPv6 listener if the system supports it and an IPv4 listener if not. By default Merge-COM-3 is configured to use only IPv4 sockets.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


startListening Method (MCapplication, MCproposedContextList, MCacceptor, MCsecureContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, MCproposedContextList, MCacceptor, MCsecureContext)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    MCproposedContextList contextList,
    MCacceptor handler,
    MCsecureContext secureContext
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    contextList As MCproposedContextList, _
    handler As MCacceptor, _
    secureContext As MCsecureContext _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    MCproposedContextList^ contextList,
    MCacceptor^ handler,
    MCsecureContext^ secureContext
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form takes the listen port number from the TCPIP_LISTEN_PORT configuration option. Applications can listen on same port multiple times with different Application Entity titles.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the MCacceptor.start method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the MCacceptor.start call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, Int32) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to the Merge DICOM toolkit.

The toolkit will listen for connections on all network interfaces, but depending on the IP_TYPE configuration option it will set up either an IPv4 or an IPv6 socket listener. If the IP_TYPE configuration value is 'AVAILABLE' the toolkit will set up an IPv6 listener if the system supports it and an IPv4 listener if not. By default Merge-COM-3 is configured to use only IPv4 sockets.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


startListening Method (MCapplication, Int32, MCproposedContextList, MCacceptor)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, Int32, MCproposedContextList, MCacceptor)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    int port,
    MCproposedContextList contextList,
    MCacceptor handler
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    port As Integer, _
    contextList As MCproposedContextList, _
    handler As MCacceptor _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    int port,
    MCproposedContextList^ contextList,
    MCacceptor^ handler
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
port
Type: System..::..Int32
The port number to listen on.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form allows a listen port to be specified as a parameter. Applications can listen on same port multiple times with different Application Entity titles.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the MCacceptor.start method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the MCacceptor.start call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, Int32) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to the Merge DICOM toolkit.

The toolkit will listen for connections on all network interfaces, but depending on the IP_TYPE configuration option it will set up either an IPv4 or an IPv6 socket listener. If the IP_TYPE configuration value is 'AVAILABLE' the toolkit will set up an IPv6 listener if the system supports it and an IPv4 listener if not. By default Merge-COM-3 is configured to use only IPv4 sockets.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


startListening Method (MCapplication, Int32, MCproposedContextList, MCacceptor, MCsecureContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, Int32, MCproposedContextList, MCacceptor, MCsecureContext)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    int port,
    MCproposedContextList contextList,
    MCacceptor handler,
    MCsecureContext secureContext
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    port As Integer, _
    contextList As MCproposedContextList, _
    handler As MCacceptor, _
    secureContext As MCsecureContext _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    int port,
    MCproposedContextList^ contextList,
    MCacceptor^ handler,
    MCsecureContext^ secureContext
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
port
Type: System..::..Int32
The port number to listen on.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form allows a listen port to be specified as a parameter. Applications can listen on same port multiple times with different Application Entity titles.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the MCacceptor.start method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the MCacceptor.start call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, Int32) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to the Merge DICOM toolkit.

The toolkit will listen for connections on all network interfaces, but depending on the IP_TYPE configuration option it will set up either an IPv4 or an IPv6 socket listener. If the IP_TYPE configuration value is 'AVAILABLE' the toolkit will set up an IPv6 listener if the system supports it and an IPv4 listener if not. By default Merge-COM-3 is configured to use only IPv4 sockets.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


startListening Method (MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    IPEndPoint endPoint,
    bool dualMode,
    MCproposedContextList contextList,
    MCacceptor handler
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    endPoint As IPEndPoint, _
    dualMode As Boolean, _
    contextList As MCproposedContextList, _
    handler As MCacceptor _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    IPEndPoint^ endPoint,
    bool dualMode,
    MCproposedContextList^ contextList,
    MCacceptor^ handler
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
endPoint
Type: System.Net..::..IPEndPoint
The address and port number to start the listener on.
dualMode
Type: System..::..Boolean
This parameter controls whether an IPv6 listener will accept IPv4 connections. See the remarks section for more details on availability of this feature.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form allows a specific address and listen port to be specified for the listener allowing the application to receive association request on specific network interfaces.

For IPv6 addresses the toolkit supports accepting both IPv6 and IPv4 connections on the same listener socket (dual-mode socket). This functionality can be enabled through the dualMode parameter and it is available only on platforms that support such sockets (Windows Vista and later). The dualMode parameter is ignored on other platforms.

Different applications can listen on the same address and port. Also the same application can listen on multiple addresses and/or ports.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the start(MCassociation) method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the start(MCassociation) call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, IPEndPoint) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the setNegotiationInfo(MCapplication, String, MCnegotiationInfo) method must be used to provide the negotiation information to the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


startListening Method (MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor, MCsecureContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..startListening Method (MCapplication, IPEndPoint, Boolean, MCproposedContextList, MCacceptor, MCsecureContext)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit listen for association requests directed to this application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int startListening(
    MCapplication app,
    IPEndPoint endPoint,
    bool dualMode,
    MCproposedContextList contextList,
    MCacceptor handler,
    MCsecureContext secureContext
)
Visual Basic
Public Shared Function startListening ( _
    app As MCapplication, _
    endPoint As IPEndPoint, _
    dualMode As Boolean, _
    contextList As MCproposedContextList, _
    handler As MCacceptor, _
    secureContext As MCsecureContext _
) As Integer
Visual C++
public:
static int startListening(
    MCapplication^ app,
    IPEndPoint^ endPoint,
    bool dualMode,
    MCproposedContextList^ contextList,
    MCacceptor^ handler,
    MCsecureContext^ secureContext
)

Parameters

app
Type: Mergecom..::..MCapplication
The application for which to start the listener.
endPoint
Type: System.Net..::..IPEndPoint
The address and port number to start the listener on.
dualMode
Type: System..::..Boolean
This parameter controls whether an IPv6 listener will accept IPv4 connections. See the remarks section for more details on availability of this feature.
contextList
Type: Mergecom..::..MCproposedContextList
A list of DICOM services supported on the received association.
handler
Type: Mergecom..::..MCacceptor
An object that will handle incoming associations.
secureContext
Type: Mergecom..::..MCsecureContext
MCsecureContext of SSL session

Return Value

The port number listening on.

Remarks

This method is used to start a socket listener so that this application is able to receive association requests from other applications.

Three forms of this method are available. All forms require an application object, an association handler and a list of the presentation contexts to be waited for. This form allows a specific address and listen port to be specified for the listener allowing the application to receive association request on specific network interfaces.

For IPv6 addresses the toolkit supports accepting both IPv6 and IPv4 connections on the same listener socket (dual-mode socket). This functionality can be enabled through the dualMode parameter and it is available only on platforms that support such sockets (Windows Vista and later). The dualMode parameter is ignored on other platforms.

Different applications can listen on the same address and port. Also the same application can listen on multiple addresses and/or ports.

The method requests that the Merge DICOM toolkit wait for association requests to arrive that propose to connect to this application and conduct at least one of the services specified in contextList. The application provides a MCacceptor instance as a handler for received associations. When an association request is received for this application and at least one of the services in contextList is acceptable to the remote application, the Merge DICOM toolkit calls the start method of the handler, passing the MCassociation object that represents the association being negotiated. It is the handler's responsibility to call either the accept()()()() or reject()()()() methods on the association object to accept or reject it.

Each association request is handled in a separate thread, meaning the MCacceptor.start method of the handler is called by the toolkit in a thread reserved for that association. The lifetime of the association is tied to the MCacceptor.start call, after the method returns the application is considered inactive, and no further operations are accepted on the association. After an association ends, the Merge DICOM toolkit will reuse the association's thread for a future association.

If the association is rejected, no further MCassociation method calls may be made on that particular association. If the association is accepted, the read method of the MCassociation object is used to read DIMSE messages on the association, and methods of one of the MCdimseService derived class are used to send DIMSE messages over the association.

The association connection may end if either this application or the remote application aborts or if the requester releases the association. (See release()()()() and abort()()()() methods.) If the remote application releases or aborts the association, this local application is notified by exceptions thrown by the read(Int64) method.

To have the Merge DICOM toolkit stop listening for connections on a given port for this application, use the stopListening(MCapplication, IPEndPoint) method.

Service Lists are encapsulated in MCproposedContextList: Before starting to listen for associations, an MCproposedContextList object must be created and supplied as the contextList argument. If any of the proposed services need negotiation information the MCproposedContextList.setNegotiationInfo method must be used to provide the negotiation information to the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.
Mergecom.Exceptions..::..MCalreadyListeningException | The Merge DICOM toolkit is already listening on the port.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
startListening Overload


stopListening Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..stopListening Method
MCassociation Class See Also Send Feedback

Overload List

Name | Description
stopListening(MCapplication, Int32) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given port.
stopListening(MCapplication, IPEndPoint) | Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given address and port.

See Also

MCassociation Class
MCassociation Members


stopListening Method (MCapplication, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..stopListening Method (MCapplication, Int32)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given port.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void stopListening(
    MCapplication app,
    int port
)
Visual Basic
Public Shared Sub stopListening ( _
    app As MCapplication, _
    port As Integer _
)
Visual C++
public:
static void stopListening(
    MCapplication^ app,
    int port
)

Parameters

app
Type: Mergecom..::..MCapplication
The application that started listening.
port
Type: System..::..Int32
The port number to stop listening on. If zero (0), the Merge DICOM toolkit will stop listening on all ports.

Remarks

NOTE: any associations that may currently be active will not be affected.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The port parameter was negative, or the application parameter was null.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
stopListening Overload


stopListening Method (MCapplication, IPEndPoint)

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..stopListening Method (MCapplication, IPEndPoint)
MCassociation Class See Also Send Feedback
Request that the Merge DICOM toolkit no longer listen for association requests directed to this application on a given address and port.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void stopListening(
    MCapplication app,
    IPEndPoint endPoint
)
Visual Basic
Public Shared Sub stopListening ( _
    app As MCapplication, _
    endPoint As IPEndPoint _
)
Visual C++
public:
static void stopListening(
    MCapplication^ app,
    IPEndPoint^ endPoint
)

Parameters

app
Type: Mergecom..::..MCapplication
The application that started listening.
endPoint
Type: System.Net..::..IPEndPoint
The address and port number to stop listening on. If null, the Merge DICOM toolkit will stop all listeners for the specified application.

Remarks

NOTE: any associations that may currently be active will not be affected.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The application parameter was null.
Mergecom.Exceptions..::..MCruntimeException | An error occurred in the operating environment while processing the request. A message describing the error has been written to the Merge DICOM toolkit log file. The association is no longer active and no further network activity may be requested.

See Also

MCassociation Class
MCassociation Members
stopListening Overload


MCassociation Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociation Properties
MCassociation Class See Also Send Feedback

The MCassociation type exposes the following members.

Properties

Name Description
Public property Acceptor
Determines if the local application is an association acceptor (or an association requester).
Public property Active
Determines if the association is active.
Public property ApplicationContextName
Gets the application context name used for the association.
Public property CalledApplicationTitle
Retrieves the application entity title of the acceptor application.
Public property CallingApplicationTitle
Retrieves the application entity title of the application that requested this association.
Public property FirstAcceptableContext
Retrieves the first acceptable context for this association.
Public property ListenPort
Retrieves the port number the acceptor is using.
Public property LocalApplication
Retrieves the local application identifying that is using this association.
Public property LocalApplicationTitle
Retrieves the local application entity title.
Public property LocalImplementationClassUid
Retrieves the local Implementation Class UID.
Public property LocalImplementationVersion
Retrieves the local Implementation Version property.
Public property LocalMaxPDUsize
Retrieves the maximum PDU size the local system is willing to receive.
Public property MaxOperationsInvoked
Retrieves the maximum number of simnultaneous operations negotiated over the association.
Public property MaxOperationsPerformed
Retrieves the maximum number of operations performed negotiated over the association.
Public property NextAcceptableContext
Retrieves the next acceptable context for this association.
Public property NumberOfAcceptableContexts
Retrieves the number of services accepted on this association.
Public property NumberOfProposedContexts
Retrieves the number of Presentation Contexts proposed on this association.
Public property ProposedContextList
Retrieves the Proposed Contexts used by this association.
Public property ReadTimeout
Retrieves the timeout value specified in the last read(Int64) or read(Int64, MCReadError%) call.
Public property RemoteAddress
Retrieves the IPEndPoint object of the remote system.
Public property RemoteApplicationTitle
Retrieves the application entity title of the remote application.
Public property RemoteHostName
Retrieves the Host Name of the remote application.
Public property RemoteImplementationClassUid
Retrieves the Implementation Class UID of the remote application.
Public property RemoteImplementationVersion
Retrieves the Implementation Version of the remote application.
Public property RemoteIp
Retrieves IP address of the remote application.
Public property RemoteIpAddress
Retrieves the Presentation Address of the remote application.
Public property RemoteMaxPDUsize
Retrieves the maximum PDU size the remote system is willing to receive.
Public property RemotePort
Retrieves the port number the remote system is listening on.
Public property Requester
Determines if the local application is an association requester (or an association acceptor).
Public property UserIdentity
Return the MCuserIdentity type of the association.
Value | Meaning
0 | Undefined User Identity
1 | Username as a string in UTF-8
2 | Username as a string in UTF-8 and passcode
3 | Kerberos Service ticket
4 | SAML Assertion
5 | JSON Web Token (JWT)
Public property UserIdentityPrimaryField
User Identity Primary Field
Public property UserIdentityResponse
User Identity Server Response
Public property UserIdentityResponseReceived
Returns True if user identity response was received.
Public property UserIdentityResponseRequested
Returns True if user identity response was requested.
Public property UserIdentitySecondaryField
User Identity Secondary Field
Public property WaitInCallerThread
This property determines if the association will wait for read events in its own thread if false or in the caller thread if true.

See Also

MCassociation Class


Acceptor Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..Acceptor Property
MCassociation Class See Also Send Feedback
Determines if the local application is an association acceptor (or an association requester).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool Acceptor { get; }
Visual Basic
Public Overridable ReadOnly Property Acceptor As Boolean
    Get
Visual C++
public:
virtual property bool Acceptor {
    bool get ();
}

Field Value

true if the local application is an association acceptor.

See Also

MCassociation Class
MCassociation Members


Active Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..Active Property
MCassociation Class See Also Send Feedback
Determines if the association is active.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool Active { get; internal set; }
Visual Basic
Public Overridable Property Active As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool Active {
    bool get ();
    internal: void set (bool value);
}

Field Value

true if the association is active.

Remarks

For a DICOM association requester application, an association is considered active from the moment the requester receives a successful return from the requestAssociation(MCapplication, MCremoteApplication, Int32) call until it calls the release method or until the association is aborted by either the local requester or remote acceptor application.

For a DICOM association acceptor application, an association is considered active from the moment the local acceptor calls the accept method until the association is released by the remote requester or until the association is aborted by either the local acceptor or remote requester application.

Association Release Type | Description
Association Release by the association requester: When an association requester application releases the association, the two application entities must react as follows:
Association Requestor activities | Once the release method is called, the association is considered inactive and the requester may no longer make any method calls other than an abort. MCassociation objects created for this association may no longer send messages to the association partner. The requestor may, however, continue to receive messages until it is informed that the association has been closed.
Association Acceptor activities | The Merge DICOM toolkit library automatically responds to release association request received from the association requestor. An association acceptor simply continues to receive messages until it is informed the association has been released. The acceptor may also issue an abort call at any time.
Association Abort by either side

When either application entity issues an abort method call it may no longer receive messages and its service classes may no longer send request messages. The association is terminated immediately.

Therefore, an association is no longer “active” (i.e. this method returns false). When a release method call is made by an association requester application. When a DICOM association acceptor is notified that the association has been released. When an abort method call is made by either side.

See Also

MCassociation Class
MCassociation Members


ApplicationContextName Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..ApplicationContextName Property
MCassociation Class See Also Send Feedback
Gets the application context name used for the association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ApplicationContextName { get; }
Visual Basic
Public Overridable ReadOnly Property ApplicationContextName As String
    Get
Visual C++
public:
virtual property String^ ApplicationContextName {
    String^ get ();
}

Field Value

The DICOM Application Context Name used for this association.

Remarks

This value is the result of negotiation. Originally this is the context name as specified by the LocalApplicationContextName configuration parameter. The association acceptor may supply a different context. If the association requester doesn't like the new context supplied by the acceptor it should issue an abort request.

See Also

MCassociation Class
MCassociation Members


CalledApplicationTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..CalledApplicationTitle Property
MCassociation Class See Also Send Feedback
Retrieves the application entity title of the acceptor application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CalledApplicationTitle { get; }
Visual Basic
Public Overridable ReadOnly Property CalledApplicationTitle As String
    Get
Visual C++
public:
virtual property String^ CalledApplicationTitle {
    String^ get ();
}

Field Value

The DICOM AE title of the called application.

See Also

MCassociation Class
MCassociation Members


CallingApplicationTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..CallingApplicationTitle Property
MCassociation Class See Also Send Feedback
Retrieves the application entity title of the application that requested this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CallingApplicationTitle { get; }
Visual Basic
Public Overridable ReadOnly Property CallingApplicationTitle As String
    Get
Visual C++
public:
virtual property String^ CallingApplicationTitle {
    String^ get ();
}

Field Value

The DICOM AE title of the calling application.

See Also

MCassociation Class
MCassociation Members


FirstAcceptableContext Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..FirstAcceptableContext Property
MCassociation Class See Also Send Feedback
Retrieves the first acceptable context for this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCresultContext FirstAcceptableContext { get; }
Visual Basic
Public Overridable ReadOnly Property FirstAcceptableContext As MCresultContext
    Get
Visual C++
public:
virtual property MCresultContext^ FirstAcceptableContext {
    MCresultContext^ get ();
}

Field Value

The MCresultContext object representing the first acceptable context, or null if there is none.

Remarks

An acceptable context describes a service that is acceptable to both the local application and the remote application. The MCresultContext object returned describes the service and provides the transfer syntax that has been negotiated for use with the service, as well as other items that may have been negotiated.

This method may be called by an association acceptor to examine the contexts proposed by the remote association requester.

The Merge DICOM library automatically accepts contexts received from the remote requestor if the service proposed matches one of the services in the local acceptor's MCproposedContextList (see the startListening methods), and if one of the transfer syntaxes proposed matches one of the transfer syntaxes in the corresponding MCproposedContext of the local acceptor's MCproposedContextList. If not, the library automatically rejects the proposed context.

An association requester may use this method to review the contexts that have been accepted by the remote application.

See Also

MCassociation Class
MCassociation Members


ListenPort Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..ListenPort Property
MCassociation Class See Also Send Feedback
Retrieves the port number the acceptor is using.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int ListenPort { get; internal set; }
Visual Basic
Public Overridable Property ListenPort As Integer
    Get
    Friend Set
Visual C++
public:
virtual property int ListenPort {
    int get ();
    internal: void set (int value);
}

Field Value

The port number this acceptor is using or zero if the local application is not an acceptor.

See Also

MCassociation Class
MCassociation Members


LocalApplication Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..LocalApplication Property
MCassociation Class See Also Send Feedback
Retrieves the local application identifying that is using this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCapplication LocalApplication { get; }
Visual Basic
Public Overridable ReadOnly Property LocalApplication As MCapplication
    Get
Visual C++
public:
virtual property MCapplication^ LocalApplication {
    MCapplication^ get ();
}

Field Value

The associated MCapplication object.

See Also

MCassociation Class
MCassociation Members


LocalApplicationTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..LocalApplicationTitle Property
MCassociation Class See Also Send Feedback
Retrieves the local application entity title.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string LocalApplicationTitle { get; }
Visual Basic
Public Overridable ReadOnly Property LocalApplicationTitle As String
    Get
Visual C++
public:
virtual property String^ LocalApplicationTitle {
    String^ get ();
}

Field Value

A String containing the local application title.

Remarks

Note that, for an acceptor application, this may not be the same as that returned by the CalledApplicationTitle property if the local application has elected to accept association requests directed to other application titles.

See Also

MCassociation Class
MCassociation Members


LocalImplementationClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..LocalImplementationClassUid Property
MCassociation Class See Also Send Feedback
Retrieves the local Implementation Class UID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string LocalImplementationClassUid { get; }
Visual Basic
Public Overridable ReadOnly Property LocalImplementationClassUid As String
    Get
Visual C++
public:
virtual property String^ LocalImplementationClassUid {
    String^ get ();
}

Field Value

A String containing the local Implementation Class UID.

See Also

MCassociation Class
MCassociation Members


LocalImplementationVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..LocalImplementationVersion Property
MCassociation Class See Also Send Feedback
Retrieves the local Implementation Version property.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string LocalImplementationVersion { get; }
Visual Basic
Public Overridable ReadOnly Property LocalImplementationVersion As String
    Get
Visual C++
public:
virtual property String^ LocalImplementationVersion {
    String^ get ();
}

Field Value

The local application's Implementation Version string.

See Also

MCassociation Class
MCassociation Members


LocalMaxPDUsize Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..LocalMaxPDUsize Property
MCassociation Class See Also Send Feedback
Retrieves the maximum PDU size the local system is willing to receive.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long LocalMaxPDUsize { get; }
Visual Basic
Public Overridable ReadOnly Property LocalMaxPDUsize As Long
    Get
Visual C++
public:
virtual property long long LocalMaxPDUsize {
    long long get ();
}

Field Value

The size (in bytes) of the largest Protocol Data Unit that the local system is willing to receive.

See Also

MCassociation Class
MCassociation Members


MaxOperationsInvoked Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..MaxOperationsInvoked Property
MCassociation Class See Also Send Feedback
Retrieves the maximum number of simnultaneous operations negotiated over the association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long MaxOperationsInvoked { get; }
Visual Basic
Public Overridable ReadOnly Property MaxOperationsInvoked As Long
    Get
Visual C++
public:
virtual property long long MaxOperationsInvoked {
    long long get ();
}

Field Value

The maximum number of invoked operations negotiated.

See Also

MCassociation Class
MCassociation Members


MaxOperationsPerformed Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..MaxOperationsPerformed Property
MCassociation Class See Also Send Feedback
Retrieves the maximum number of operations performed negotiated over the association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long MaxOperationsPerformed { get; }
Visual Basic
Public Overridable ReadOnly Property MaxOperationsPerformed As Long
    Get
Visual C++
public:
virtual property long long MaxOperationsPerformed {
    long long get ();
}

Field Value

The maximum number of performed operations negotiated.

See Also

MCassociation Class
MCassociation Members


NextAcceptableContext Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..NextAcceptableContext Property
MCassociation Class See Also Send Feedback
Retrieves the next acceptable context for this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCresultContext NextAcceptableContext { get; }
Visual Basic
Public Overridable ReadOnly Property NextAcceptableContext As MCresultContext
    Get
Visual C++
public:
virtual property MCresultContext^ NextAcceptableContext {
    MCresultContext^ get ();
}

Field Value

The MCresultContext object describing the next context, or null if no more acceptable services are in the list.

Remarks

An acceptable context describes a service that is acceptable to both the local application and the remote application. The MCresultContext object returned describes the service and provides the transfer syntax that has been negotiated for use with the service, as well as other items that may have been negotiated.

This method may be called by an association acceptor to examine the contexts proposed by the remote association requester.

The Merge DICOM toolkit library automatically accepts contexts received from the remote requestor if the service proposed matches one of the services in the local acceptor's MCproposedContextList (see the startListening methods), and if one of the transfer syntaxes proposed matches one of the transfer syntaxes in the corresponding MCproposedContext of the local acceptor's MCproposedContextList. If not, the library automatically rejects the proposed context.

An association requester may use this method to review the contexts that have been accepted by the remote application.

See Also

MCassociation Class
MCassociation Members


NumberOfAcceptableContexts Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..NumberOfAcceptableContexts Property
MCassociation Class See Also Send Feedback
Retrieves the number of services accepted on this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int NumberOfAcceptableContexts { get; }
Visual Basic
Public Overridable ReadOnly Property NumberOfAcceptableContexts As Integer
    Get
Visual C++
public:
virtual property int NumberOfAcceptableContexts {
    int get ();
}

Field Value

The number of acceptable presentation contexts.

Remarks

During association negotiation the DICOM association requestor proposes the services it wishes to use. An association acceptor application can then reject or accept each of the proposed services. This method retrieves the number of services acceptable to the association acceptor.

See Also

MCassociation Class
MCassociation Members


NumberOfProposedContexts Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..NumberOfProposedContexts Property
MCassociation Class See Also Send Feedback
Retrieves the number of Presentation Contexts proposed on this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int NumberOfProposedContexts { get; }
Visual Basic
Public Overridable ReadOnly Property NumberOfProposedContexts As Integer
    Get
Visual C++
public:
virtual property int NumberOfProposedContexts {
    int get ();
}

Field Value

The number of proposed presentation contexts.

Remarks

During association negotiation the DICOM association requestor proposes the services it wishes to use. The association acceptor can then reject or accept each of the proposed services. This method retrieves the number of services proposed by the association requestor.

See Also

MCassociation Class
MCassociation Members


ProposedContextList Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..ProposedContextList Property
MCassociation Class See Also Send Feedback
Retrieves the Proposed Contexts used by this association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCproposedContextList ProposedContextList { get; }
Visual Basic
Public Overridable ReadOnly Property ProposedContextList As MCproposedContextList
    Get
Visual C++
public:
virtual property MCproposedContextList^ ProposedContextList {
    MCproposedContextList^ get ();
}

Field Value

The MCproposedContextList used by this association.

See Also

MCassociation Class
MCassociation Members


ReadTimeout Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..ReadTimeout Property
MCassociation Class See Also Send Feedback
Retrieves the timeout value specified in the last read(Int64) or read(Int64, MCReadError%) call.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long ReadTimeout { get; }
Visual Basic
Public Overridable ReadOnly Property ReadTimeout As Long
    Get
Visual C++
public:
virtual property long long ReadTimeout {
    long long get ();
}

Field Value

The timeout value in milliseconds.

See Also

MCassociation Class
MCassociation Members


RemoteAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteAddress Property
MCassociation Class See Also Send Feedback
Retrieves the IPEndPoint object of the remote system.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IPEndPoint RemoteAddress { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteAddress As IPEndPoint
    Get
Visual C++
public:
virtual property IPEndPoint^ RemoteAddress {
    IPEndPoint^ get ();
}

Field Value

The IPEndPoint object of the remote system.

See Also

MCassociation Class
MCassociation Members


RemoteApplicationTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteApplicationTitle Property
MCassociation Class See Also Send Feedback
Retrieves the application entity title of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteApplicationTitle { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteApplicationTitle As String
    Get
Visual C++
public:
virtual property String^ RemoteApplicationTitle {
    String^ get ();
}

Field Value

The DICOM AE title of the remote application.

See Also

MCassociation Class
MCassociation Members


RemoteHostName Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteHostName Property
MCassociation Class See Also Send Feedback
Retrieves the Host Name of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteHostName { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteHostName As String
    Get
Visual C++
public:
virtual property String^ RemoteHostName {
    String^ get ();
}

Field Value

The TCP/IP host name of the remote application.

See Also

MCassociation Class
MCassociation Members


RemoteImplementationClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteImplementationClassUid Property
MCassociation Class See Also Send Feedback
Retrieves the Implementation Class UID of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteImplementationClassUid { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteImplementationClassUid As String
    Get
Visual C++
public:
virtual property String^ RemoteImplementationClassUid {
    String^ get ();
}

Field Value

The remote application's Implementation Class UID.

See Also

MCassociation Class
MCassociation Members


RemoteImplementationVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteImplementationVersion Property
MCassociation Class See Also Send Feedback
Retrieves the Implementation Version of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteImplementationVersion { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteImplementationVersion As String
    Get
Visual C++
public:
virtual property String^ RemoteImplementationVersion {
    String^ get ();
}

Field Value

The remote application's Implementation Version string.

See Also

MCassociation Class
MCassociation Members


RemoteIp Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteIp Property
MCassociation Class See Also Send Feedback
Retrieves IP address of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteIp { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteIp As String
    Get
Visual C++
public:
virtual property String^ RemoteIp {
    String^ get ();
}

Field Value

IP Address of remote host.

See Also

MCassociation Class
MCassociation Members


RemoteIpAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteIpAddress Property
MCassociation Class See Also Send Feedback
Retrieves the Presentation Address of the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RemoteIpAddress { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteIpAddress As String
    Get
Visual C++
public:
virtual property String^ RemoteIpAddress {
    String^ get ();
}

Field Value

The Presentation Address of remote host.

See Also

MCassociation Class
MCassociation Members


RemoteMaxPDUsize Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemoteMaxPDUsize Property
MCassociation Class See Also Send Feedback
Retrieves the maximum PDU size the remote system is willing to receive.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long RemoteMaxPDUsize { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteMaxPDUsize As Long
    Get
Visual C++
public:
virtual property long long RemoteMaxPDUsize {
    long long get ();
}

Field Value

The size (in bytes) of the largest Protocol Data Unit that the remote system is willing to receive.

See Also

MCassociation Class
MCassociation Members


RemotePort Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..RemotePort Property
MCassociation Class See Also Send Feedback
Retrieves the port number the remote system is listening on.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int RemotePort { get; }
Visual Basic
Public Overridable ReadOnly Property RemotePort As Integer
    Get
Visual C++
public:
virtual property int RemotePort {
    int get ();
}

Field Value

The port number of the remote system.

See Also

MCassociation Class
MCassociation Members


Requester Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..Requester Property
MCassociation Class See Also Send Feedback
Determines if the local application is an association requester (or an association acceptor).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool Requester { get; }
Visual Basic
Public Overridable ReadOnly Property Requester As Boolean
    Get
Visual C++
public:
virtual property bool Requester {
    bool get ();
}

Field Value

true if the local application is an association requester.

See Also

MCassociation Class
MCassociation Members


UserIdentity Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentity Property
MCassociation Class See Also Send Feedback
Return the MCuserIdentity type of the association.
Value | Meaning
0 | Undefined User Identity
1 | Username as a string in UTF-8
2 | Username as a string in UTF-8 and passcode
3 | Kerberos Service ticket
4 | SAML Assertion
5 | JSON Web Token (JWT)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCuserIdentity UserIdentity { get; }
Visual Basic
Public ReadOnly Property UserIdentity As MCuserIdentity
    Get
Visual C++
public:
property MCuserIdentity UserIdentity {
    MCuserIdentity get ();
}

See Also

MCassociation Class
MCassociation Members


UserIdentityPrimaryField Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentityPrimaryField Property
MCassociation Class See Also Send Feedback
User Identity Primary Field

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public byte[] UserIdentityPrimaryField { get; }
Visual Basic
Public ReadOnly Property UserIdentityPrimaryField As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ UserIdentityPrimaryField {
    array<unsigned char>^ get ();
}

Return Value

Returns the user identity, either the username as a series of characters, or the Kerberos Service ticket encoded in accordance with RFC-1510, or the JWT encoded in accordance with RFC 7519 using base64url encoded parts.

See Also

MCassociation Class
MCassociation Members


UserIdentityResponse Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentityResponse Property
MCassociation Class See Also Send Feedback
User Identity Server Response

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public byte[] UserIdentityResponse { get; }
Visual Basic
Public ReadOnly Property UserIdentityResponse As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ UserIdentityResponse {
    array<unsigned char>^ get ();
}

Return Value

Returns the Kerberos Server ticket if User Identity value was Kerberos Service ticket (3) or the SAML response if the User Identity value was SAML Assertion (4) and if the Association requestor has requested a positive acknowledgment.

See Also

MCassociation Class
MCassociation Members


UserIdentityResponseReceived Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentityResponseReceived Property
MCassociation Class See Also Send Feedback
Returns True if user identity response was received.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool UserIdentityResponseReceived { get; }
Visual Basic
Public ReadOnly Property UserIdentityResponseReceived As Boolean
    Get
Visual C++
public:
property bool UserIdentityResponseReceived {
    bool get ();
}

See Also

MCassociation Class
MCassociation Members


UserIdentityResponseRequested Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentityResponseRequested Property
MCassociation Class See Also Send Feedback
Returns True if user identity response was requested.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool UserIdentityResponseRequested { get; }
Visual Basic
Public ReadOnly Property UserIdentityResponseRequested As Boolean
    Get
Visual C++
public:
property bool UserIdentityResponseRequested {
    bool get ();
}

See Also

MCassociation Class
MCassociation Members


UserIdentitySecondaryField Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..UserIdentitySecondaryField Property
MCassociation Class See Also Send Feedback
User Identity Secondary Field

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public byte[] UserIdentitySecondaryField { get; }
Visual Basic
Public ReadOnly Property UserIdentitySecondaryField As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ UserIdentitySecondaryField {
    array<unsigned char>^ get ();
}

Return Value

Returns the passcode value only if User Identity is MCuserIdentity.USERNAME_AND_PASSCODE.

See Also

MCassociation Class
MCassociation Members


WaitInCallerThread Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociation..::..WaitInCallerThread Property
MCassociation Class See Also Send Feedback
This property determines if the association will wait for read events in its own thread if false or in the caller thread if true.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool WaitInCallerThread { get; set; }
Visual Basic
Public Property WaitInCallerThread As Boolean
    Get
    Set
Visual C++
public:
property bool WaitInCallerThread {
    bool get ();
    void set (bool value);
}

Remarks

The default value of this property is true.

Setting the property to true will allow the caller to dispatch commands on a server association in multiple threads for true asynchronous/parallel processing.

This is an individual, per-MCassociation basis setting and will affect only the association it is applied to. If you want to modify the behaviour on a global basis, use MC.AssocWaitInCallerThread.

See Also

MCassociation Class
MCassociation Members


MCassocRejectInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Class
Members See Also Send Feedback
The class encapsulates the set of 3 parameters describing the circumstances in which and reasons for which an association may be rejected (as per DICOM PS3.8, section 9.3.4 A-ASSOCIATE-RJ PDU Structure): result, source, reason.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCassocRejectInfo
Visual Basic
Public Class MCassocRejectInfo
Visual C++
public ref class MCassocRejectInfo

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCassocRejectInfo

See Also

MCassocRejectInfo Members


MCassocRejectInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Members
MCassocRejectInfo Class Constructors Methods Fields See Also Send Feedback

The MCassocRejectInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MCassocRejectInfo()()()() | Initializes a new instance of the MCassocRejectInfo class
Public method | MCassocRejectInfo(UInt16, UInt16, UInt16) | Initializes a new instance of the MCassocRejectInfo class

Methods

 | Name | Description
 | EncodeRejectReason | Convert MCrejectReason enumerated value to an MCassocRejectInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRejectMessages | Return string descriptions for the 3 components of a MCassocRejectInfo object.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | reason | Diagnostic: reason for rejection A. If source == 1: 1 - no-reason-given, 2 - application-context-name-not-recognized, 4-6 - reserved, 7 - called-AE-title-not-recognized, 8-10 - reserved B. If source = 2: 1 - no-reason-given, 2 - protocol-version-not-supported C. If source = 3: 0 - reserved, 1 - temporary-congestion, 2 - local-limit-exceeded, 3-7 - reserved
Public field | result | Result: 1 - rejected (permanent), 2 - rejected (transient)
Public field | source | Source: 1 - UL service-user, 2 - UL service-provider (ACSE related function), 3 - UL service-provider (Presentation related function)

See Also

MCassocRejectInfo Class


MCassocRejectInfo Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Constructor
MCassocRejectInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCassocRejectInfo()()()() | Initializes a new instance of the MCassocRejectInfo class
Public method | MCassocRejectInfo(UInt16, UInt16, UInt16) | Initializes a new instance of the MCassocRejectInfo class

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


MCassocRejectInfo Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Constructor
MCassocRejectInfo Class See Also Send Feedback
Initializes a new instance of the MCassocRejectInfo class

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassocRejectInfo()
Visual Basic
Public Sub New
Visual C++
public:
MCassocRejectInfo()

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members
MCassocRejectInfo Overload


MCassocRejectInfo Constructor (UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Constructor (UInt16, UInt16, UInt16)
MCassocRejectInfo Class See Also Send Feedback
Initializes a new instance of the MCassocRejectInfo class

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassocRejectInfo(
    ushort result,
    ushort source,
    ushort reason
)
Visual Basic
Public Sub New ( _
    result As UShort, _
    source As UShort, _
    reason As UShort _
)
Visual C++
public:
MCassocRejectInfo(
    unsigned short result,
    unsigned short source,
    unsigned short reason
)

Parameters

result
Type: System..::..UInt16
Type of rejection (temporary or permanent)
source
Type: System..::..UInt16
Source of rejection
reason
Type: System..::..UInt16
Reason for rejection

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members
MCassocRejectInfo Overload


MCassocRejectInfo Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Fields
MCassocRejectInfo Class See Also Send Feedback

The MCassocRejectInfo type exposes the following members.

Fields

 | Name | Description
Public field | reason | Diagnostic: reason for rejection A. If source == 1: 1 - no-reason-given, 2 - application-context-name-not-recognized, 4-6 - reserved, 7 - called-AE-title-not-recognized, 8-10 - reserved B. If source = 2: 1 - no-reason-given, 2 - protocol-version-not-supported C. If source = 3: 0 - reserved, 1 - temporary-congestion, 2 - local-limit-exceeded, 3-7 - reserved
Public field | result | Result: 1 - rejected (permanent), 2 - rejected (transient)
Public field | source | Source: 1 - UL service-user, 2 - UL service-provider (ACSE related function), 3 - UL service-provider (Presentation related function)

See Also

MCassocRejectInfo Class


reason Field

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo..::..reason Field
MCassocRejectInfo Class See Also Send Feedback
Diagnostic: reason for rejection

A. If source == 1: 1 - no-reason-given, 2 - application-context-name-not-recognized, 4-6 - reserved, 7 - called-AE-title-not-recognized, 8-10 - reserved

B. If source = 2: 1 - no-reason-given, 2 - protocol-version-not-supported

C. If source = 3: 0 - reserved, 1 - temporary-congestion, 2 - local-limit-exceeded, 3-7 - reserved

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ushort reason
Visual Basic
Public reason As UShort
Visual C++
public:
unsigned short reason

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


result Field

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo..::..result Field
MCassocRejectInfo Class See Also Send Feedback
Result: 1 - rejected (permanent), 2 - rejected (transient)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ushort result
Visual Basic
Public result As UShort
Visual C++
public:
unsigned short result

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


source Field

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo..::..source Field
MCassocRejectInfo Class See Also Send Feedback
Source: 1 - UL service-user, 2 - UL service-provider (ACSE related function), 3 - UL service-provider (Presentation related function)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ushort source
Visual Basic
Public source As UShort
Visual C++
public:
unsigned short source

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


MCassocRejectInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo Methods
MCassocRejectInfo Class See Also Send Feedback

The MCassocRejectInfo type exposes the following members.

Methods

 | Name | Description
 | EncodeRejectReason | Convert MCrejectReason enumerated value to an MCassocRejectInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRejectMessages | Return string descriptions for the 3 components of a MCassocRejectInfo object.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCassocRejectInfo Class


EncodeRejectReason Method

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo..::..EncodeRejectReason Method
MCassocRejectInfo Class See Also Send Feedback
Convert MCrejectReason enumerated value to an MCassocRejectInfo object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCassocRejectInfo EncodeRejectReason(
    MCrejectReason reason
)
Visual Basic
Public Shared Function EncodeRejectReason ( _
    reason As MCrejectReason _
) As MCassocRejectInfo
Visual C++
public:
static MCassocRejectInfo^ EncodeRejectReason(
    MCrejectReason reason
)

Parameters

reason
Type: Mergecom..::..MCrejectReason
Enumerated reason

Return Value

The converted MCassocRejectInfo instance

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


GetRejectMessages Method

[image]

Merge DICOM .NET/C# Toolkit
MCassocRejectInfo..::..GetRejectMessages Method
MCassocRejectInfo Class See Also Send Feedback
Return string descriptions for the 3 components of a MCassocRejectInfo object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool GetRejectMessages(
    ref string resultMsg,
    ref string sourceMsg,
    ref string reasonMsg
)
Visual Basic
Public Function GetRejectMessages ( _
    ByRef resultMsg As String, _
    ByRef sourceMsg As String, _
    ByRef reasonMsg As String _
) As Boolean
Visual C++
public:
bool GetRejectMessages(
    String^% resultMsg,
    String^% sourceMsg,
    String^% reasonMsg
)

Parameters

resultMsg
Type: System..::..String%
Output parameter receiving the string description for result
sourceMsg
Type: System..::..String%
Output parameter receiving the string description for source
reasonMsg
Type: System..::..String%
Output parameter receiving the string description for reason

Return Value

true if the string descriptions for the 3 components have been constructed successfully, false otherwise

See Also

MCassocRejectInfo Class
MCassocRejectInfo Members


MCattribute Class

[image]

Merge DICOM .NET/C# Toolkit
MCattribute Class
Members See Also Send Feedback
Represents a single DICOM attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCattribute
Visual Basic
Public Class MCattribute
Visual C++
public ref class MCattribute

Remarks

This class presents an array view on the values contained in an attribute. The .NET type of the values is determined by the value representation of the attribute (See MCvr.ValueType).

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattribute

See Also

MCattribute Members


MCattribute Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute Members
MCattribute Class Constructors Methods Fields Properties See Also Send Feedback

The MCattribute type exposes the following members.

Constructors

 | Name | Description
Public method | MCattribute(MCdataElement) | Initializes a new instance of this class for the specified data element.
Public method | MCattribute(MCtag) | Initializes a new instance of this class with the specified tag.

Methods

 | Name | Description
Public method | addEncapsulatedFrame | Adds a frame of encapsulated data.
Public method | addValue | Adds a value to this attribute.
Public method | clear | Removes all values from this attribute.
Public method | clone | Creates a copy of this attribute.
Public method | Equals | Determines whether two attributes instances are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getBytes | Gets the bulk value of this attribute as a byte array.
Public method | getDoubleValue | Gets the double representation of this attribute's value.
Public method | getEncapsulatedFrame | Retrieves a frame of encapsulated pixel data.
Public method | getFrame | Retrieves a frame of pixel data.
Public method | GetHashCode | Gets the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getIntValue | Gets the integer representation of this attribute's value.
Public method | getKeyword | Gets the attributes element keyword as defined in Part 6 of DICOM standard.
Public method | getLongValue | Gets the long representation of this attribute's value.
Public method | getOffsetTable | Retrieves a frame of pixel data.
Public method | getStringValue | Gets the string representation of this attribute's value.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | getUIntValue | Gets the unsigned integer representation of this attribute's value.
Public method | getULongValue | Gets the unsigned long representation of this attribute's value.
Public method | getValues | Gets the values of this attribute as an array.
Public method | getValuesAsString | Gets the values of this attributes represented as a string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readBulkData | Retrieves the value of this attribute as bulk data.
Public method | setValue(Object) | Sets the value of this attribute.
Public method | setValue(MCdataSource, UInt32) | Sets the source of the value for OB, OW, OL, OD or OF type attributes.
Public method | ToString | Returns a string representation of this attribute. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
MultipleValuesDelimiter | The character used in DICOM messages to separate multiple values of an attribute.

Properties

 | Name | Description
Public property | Count | Gets the number of values in this attribute.
Public property | Element | Gets the data element associated with this attribute.
Public property | IsBulk | Checks whether this attribute is an OB, OW, OL, OD or OF type attribute.
Public property | IsEncapsulated | Get/Set property whether the bulk data are encapsulated, true by default for the encapsulated transfer syntax
Public property | Item[([( Int32])]) | Gets or sets values of this attribute.
Public property | Item[([( Int32, Object])]) | Gets a value of this attribute using a specified default value if the requested attribute does not exist.
Public property | MultipleValuesDelimitation | This property allows for attributes to set multiple string values, i.e. concatenated with backslash '\\' delimiters, as a single string without delimitation
Public property | ParentId | Gets AttributeSet Id hosting the current attribute
Public property | Tag | Gets the tag identifying this attribute.
Public property | ValueLength | Gets the data length of this attribute's value.
Public property | ValueNull | Get/Set whether this attribute has NULL value.
Public property | ValueRepresentation | Gets and sets the attribute's DICOM Value Representation.

See Also

MCattribute Class


MCattribute Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute Constructor
MCattribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCattribute(MCdataElement) | Initializes a new instance of this class for the specified data element.
Public method | MCattribute(MCtag) | Initializes a new instance of this class with the specified tag.

See Also

MCattribute Class
MCattribute Members


MCattribute Constructor (MCdataElement)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute Constructor (MCdataElement)
MCattribute Class See Also Send Feedback
Initializes a new instance of this class for the specified data element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute(
    MCdataElement dataElement
)
Visual Basic
Public Sub New ( _
    dataElement As MCdataElement _
)
Visual C++
public:
MCattribute(
    MCdataElement^ dataElement
)

Parameters

dataElement
Type: Mergecom..::..MCdataElement
An MCdataElement object containing the attribute's tag, VR, VM and name.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattribute Class
MCattribute Members
MCattribute Overload


MCattribute Constructor (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute Constructor (MCtag)
MCattribute Class See Also Send Feedback
Initializes a new instance of this class with the specified tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute(
    MCtag tag
)
Visual Basic
Public Sub New ( _
    tag As MCtag _
)
Visual C++
public:
MCattribute(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
The MCtag identifying this attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is non-private and is not defined in the dictionary.
Mergecom.Exceptions..::..MCillegalArgumentException | The tag argument was null.

See Also

MCattribute Class
MCattribute Members
MCattribute Overload


MCattribute Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute Fields
MCattribute Class See Also Send Feedback

The MCattribute type exposes the following members.

Fields

Name | Description
MultipleValuesDelimiter | The character used in DICOM messages to separate multiple values of an attribute.

See Also

MCattribute Class


MultipleValuesDelimiter Field

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..MultipleValuesDelimiter Field
MCattribute Class See Also Send Feedback
The character used in DICOM messages to separate multiple values of an attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static char MultipleValuesDelimiter
Visual Basic
Public Shared MultipleValuesDelimiter As Char
Visual C++
public:
static wchar_t MultipleValuesDelimiter

See Also

MCattribute Class
MCattribute Members


MCattribute Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute Methods
MCattribute Class See Also Send Feedback

The MCattribute type exposes the following members.

Methods

 | Name | Description
Public method | addEncapsulatedFrame | Adds a frame of encapsulated data.
Public method | addValue | Adds a value to this attribute.
Public method | clear | Removes all values from this attribute.
Public method | clone | Creates a copy of this attribute.
Public method | Equals | Determines whether two attributes instances are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getBytes | Gets the bulk value of this attribute as a byte array.
Public method | getDoubleValue | Gets the double representation of this attribute's value.
Public method | getEncapsulatedFrame | Retrieves a frame of encapsulated pixel data.
Public method | getFrame | Retrieves a frame of pixel data.
Public method | GetHashCode | Gets the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getIntValue | Gets the integer representation of this attribute's value.
Public method | getKeyword | Gets the attributes element keyword as defined in Part 6 of DICOM standard.
Public method | getLongValue | Gets the long representation of this attribute's value.
Public method | getOffsetTable | Retrieves a frame of pixel data.
Public method | getStringValue | Gets the string representation of this attribute's value.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | getUIntValue | Gets the unsigned integer representation of this attribute's value.
Public method | getULongValue | Gets the unsigned long representation of this attribute's value.
Public method | getValues | Gets the values of this attribute as an array.
Public method | getValuesAsString | Gets the values of this attributes represented as a string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readBulkData | Retrieves the value of this attribute as bulk data.
Public method | setValue(Object) | Sets the value of this attribute.
Public method | setValue(MCdataSource, UInt32) | Sets the source of the value for OB, OW, OL, OD or OF type attributes.
Public method | ToString | Returns a string representation of this attribute. (Overrides Object..::..ToString()()()().)

See Also

MCattribute Class


addEncapsulatedFrame Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..addEncapsulatedFrame Method
MCattribute Class See Also Send Feedback
Adds a frame of encapsulated data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void addEncapsulatedFrame(
    MCdataSource source
)
Visual Basic
Public Sub addEncapsulatedFrame ( _
    source As MCdataSource _
)
Visual C++
public:
void addEncapsulatedFrame(
    MCdataSource^ source
)

Parameters

source
Type: Mergecom..::..MCdataSource
A data source containing the frame data.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The source argument was null.

See Also

MCattribute Class
MCattribute Members


addValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..addValue Method
MCattribute Class See Also Send Feedback
Adds a value to this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void addValue(
    Object val
)
Visual Basic
Public Sub addValue ( _
    val As Object _
)
Visual C++
public:
void addValue(
    Object^ val
)

Parameters

val
Type: System..::..Object
The value to add.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set the value on a bulk type attribute or an incompatible conversion was attempted for the value representation.
Mergecom.Exceptions..::..MCillegalArgumentException | The type of the value to set can not be converted to the type required by the attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattribute Class
MCattribute Members


clear Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..clear Method
MCattribute Class See Also Send Feedback
Removes all values from this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void clear()
Visual Basic
Public Sub clear
Visual C++
public:
void clear()

See Also

MCattribute Class
MCattribute Members


clone Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..clone Method
MCattribute Class See Also Send Feedback
Creates a copy of this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute clone()
Visual Basic
Public Function clone As MCattribute
Visual C++
public:
MCattribute^ clone()

Return Value

The new attribute that has the same values as the current one.

Remarks

All values are copied into the new attribute by creating new value objects except for bulk attributes for which the data source is shared with the new attribute.

See Also

MCattribute Class
MCattribute Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Equals Method
MCattribute Class See Also Send Feedback
Determines whether two attributes instances are equal.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current attribute

Return Value

true if the specified object is an MCattribute and it's value is equal to this attribute's value; otherwise, false

Remarks

Note that two bulk attributes with the same tag are considered equal when their data lenght is equal, even if the data is different.

See Also

MCattribute Class
MCattribute Members


getBytes Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getBytes Method
MCattribute Class See Also Send Feedback
Gets the bulk value of this attribute as a byte array.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public byte[] getBytes()
Visual Basic
Public Function getBytes As Byte()
Visual C++
public:
array<unsigned char>^ getBytes()

Return Value

A byte array containing the value of this attribute

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This attribute is not a bulk attribute.

See Also

MCattribute Class
MCattribute Members


getDoubleValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getDoubleValue Method
MCattribute Class See Also Send Feedback
Gets the double representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public double getDoubleValue(
    int valueIndex
)
Visual Basic
Public Function getDoubleValue ( _
    valueIndex As Integer _
) As Double
Visual C++
public:
double getDoubleValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

A double representing the requested value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The value could not be converted to a double or the value was null.

See Also

MCattribute Class
MCattribute Members


getEncapsulatedFrame Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getEncapsulatedFrame Method
MCattribute Class See Also Send Feedback
Retrieves a frame of encapsulated pixel data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool getEncapsulatedFrame(
    MCdataSink destination,
    bool first
)
Visual Basic
Public Function getEncapsulatedFrame ( _
    destination As MCdataSink, _
    first As Boolean _
) As Boolean
Visual C++
public:
bool getEncapsulatedFrame(
    MCdataSink^ destination,
    bool first
)

Parameters

destination
Type: Mergecom..::..MCdataSink
An MCdataSink implementation that will receive the frame data.
first
Type: System..::..Boolean
Flag indicating wheter the first or next frame in the sequence is requested.

Return Value

true if there are more frames to retrieve; otherwise false.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This is not a bulk attribute.
Mergecom.Exceptions..::..MCillegalArgumentException | The destination argument was null.

See Also

MCattribute Class
MCattribute Members


getFrame Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getFrame Method
MCattribute Class See Also Send Feedback
Retrieves a frame of pixel data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool getFrame(
    MCdataSink destination,
    int frame
)
Visual Basic
Public Function getFrame ( _
    destination As MCdataSink, _
    frame As Integer _
) As Boolean
Visual C++
public:
bool getFrame(
    MCdataSink^ destination,
    int frame
)

Parameters

destination
Type: Mergecom..::..MCdataSink
An MCdataSink implementation that will receive the frame data.
frame
Type: System..::..Int32
Requested frame in the sequence.

Return Value

true if there are more frames to retrieve; otherwise false.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This is not a bulk attribute.
Mergecom.Exceptions..::..MCillegalArgumentException | The destination argument was null.

See Also

MCattribute Class
MCattribute Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..GetHashCode Method
MCattribute Class See Also Send Feedback
Gets the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

MCattribute Class
MCattribute Members


getIntValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getIntValue Method
MCattribute Class See Also Send Feedback
Gets the integer representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int getIntValue(
    int valueIndex
)
Visual Basic
Public Function getIntValue ( _
    valueIndex As Integer _
) As Integer
Visual C++
public:
int getIntValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

An integer representing the requested value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The value could not be converted to an integer or the value was null.

See Also

MCattribute Class
MCattribute Members


getKeyword Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getKeyword Method
MCattribute Class See Also Send Feedback
Gets the attributes element keyword as defined in Part 6 of DICOM standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string getKeyword()
Visual Basic
Public Function getKeyword As String
Visual C++
public:
String^ getKeyword()

Return Value

A keyword corresponding to the element name or null if no keyword is defined.

Remarks

Note that the value returned can change from a version of the toolkit to another as the data dictionary is updated with changes in the latest version of the DICOM standard.

See Also

MCattribute Class
MCattribute Members


getLongValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getLongValue Method
MCattribute Class See Also Send Feedback
Gets the long representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public long getLongValue(
    int valueIndex
)
Visual Basic
Public Function getLongValue ( _
    valueIndex As Integer _
) As Long
Visual C++
public:
long long getLongValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

A long representing the requested value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The value could not be converted to a long or the value was null.

See Also

MCattribute Class
MCattribute Members


getOffsetTable Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getOffsetTable Method
MCattribute Class See Also Send Feedback
Retrieves a frame of pixel data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool getOffsetTable(
    MCdataSink destination
)
Visual Basic
Public Function getOffsetTable ( _
    destination As MCdataSink _
) As Boolean
Visual C++
public:
bool getOffsetTable(
    MCdataSink^ destination
)

Parameters

destination
Type: Mergecom..::..MCdataSink
An MCdataSink implementation that will receive the frame data.

Return Value

true if there are more frames to retrieve; otherwise false.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This is not a bulk attribute.
Mergecom.Exceptions..::..MCillegalArgumentException | The destination argument was null.

See Also

MCattribute Class
MCattribute Members


getStringValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getStringValue Method
MCattribute Class See Also Send Feedback
Gets the string representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string getStringValue(
    int valueIndex
)
Visual Basic
Public Function getStringValue ( _
    valueIndex As Integer _
) As String
Visual C++
public:
String^ getStringValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

A string representing the requested value or null if this attribute is null (zero length).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of this attribute is OB, OW, OL, OD or OF.

See Also

MCattribute Class
MCattribute Members


getUIntValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getUIntValue Method
MCattribute Class See Also Send Feedback
Gets the unsigned integer representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public uint getUIntValue(
    int valueIndex
)
Visual Basic
Public Function getUIntValue ( _
    valueIndex As Integer _
) As UInteger
Visual C++
public:
unsigned int getUIntValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

An unsigned integer representing the requested value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The value could not be converted to an unsigned integer or the value was null.

See Also

MCattribute Class
MCattribute Members


getULongValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getULongValue Method
MCattribute Class See Also Send Feedback
Gets the unsigned long representation of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ulong getULongValue(
    int valueIndex
)
Visual Basic
Public Function getULongValue ( _
    valueIndex As Integer _
) As ULong
Visual C++
public:
unsigned long long getULongValue(
    int valueIndex
)

Parameters

valueIndex
Type: System..::..Int32
The zero based index of the value to get.

Return Value

An unsigned integer representing the requested value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The value could not be converted to an unsigned long or the value was null.

See Also

MCattribute Class
MCattribute Members


getValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getValues Method
MCattribute Class See Also Send Feedback
Gets the values of this attribute as an array.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Array getValues()
Visual Basic
Public Function getValues As Array
Visual C++
public:
Array^ getValues()

Return Value

An array of objects representing the values.

Remarks

Modifying the elements of the returned array does not affect the values contained in this attribute.

If this attribute is a null value attribute the returned array will be empty (zero length).

See Also

MCattribute Class
MCattribute Members


getValuesAsString Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..getValuesAsString Method
MCattribute Class See Also Send Feedback
Gets the values of this attributes represented as a string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string getValuesAsString()
Visual Basic
Public Overridable Function getValuesAsString As String
Visual C++
public:
virtual String^ getValuesAsString()

Return Value

A String representing the values of this object

Remarks

This method returns a string containing each value separated by the '\' charcter. If this attribute is a single valued text type the returned string is the exact value, which may contain the value separator charcter ('\').

If this attribute has no values, or if the only value is null this method returns an empty string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This is a bulk attribute.

See Also

MCattribute Class
MCattribute Members


readBulkData Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..readBulkData Method
MCattribute Class See Also Send Feedback
Retrieves the value of this attribute as bulk data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void readBulkData(
    MCdataSink destination
)
Visual Basic
Public Sub readBulkData ( _
    destination As MCdataSink _
)
Visual C++
public:
void readBulkData(
    MCdataSink^ destination
)

Parameters

destination
Type: Mergecom..::..MCdataSink
The destination for the bulk data.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | This is not a bulk attribute.
Mergecom.Exceptions..::..MCillegalArgumentException | The destination argument was null.

See Also

MCattribute Class
MCattribute Members


setValue Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..setValue Method
MCattribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | setValue(Object) | Sets the value of this attribute.
Public method | setValue(MCdataSource, UInt32) | Sets the source of the value for OB, OW, OL, OD or OF type attributes.

See Also

MCattribute Class
MCattribute Members


setValue Method (Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..setValue Method (Object)
MCattribute Class See Also Send Feedback
Sets the value of this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void setValue(
    Object val
)
Visual Basic
Public Sub setValue ( _
    val As Object _
)
Visual C++
public:
void setValue(
    Object^ val
)

Parameters

val
Type: System..::..Object
The value to set. If it is an array then all its elements are added to the attribute.

Remarks

This method replaces any existing value with the value provided.

For multi-values text type attributes the value can be a string containing multiple values separated by the '\' character.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set a non-bulk value on a bulk-type attribute or an invalid conversion was attempted between data types.
Mergecom.Exceptions..::..MCillegalArgumentException | The type of the value to set can not be converted to the type required by the attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattribute Class
MCattribute Members
setValue Overload


setValue Method (MCdataSource, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..setValue Method (MCdataSource, UInt32)
MCattribute Class See Also Send Feedback
Sets the source of the value for OB, OW, OL, OD or OF type attributes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void setValue(
    MCdataSource source,
    uint length
)
Visual Basic
Public Sub setValue ( _
    source As MCdataSource, _
    length As UInteger _
)
Visual C++
public:
void setValue(
    MCdataSource^ source,
    unsigned int length
)

Parameters

source
Type: Mergecom..::..MCdataSource
The data source that will provide the value.
length
Type: System..::..UInt32
The length of the data in bytes.

Remarks

This method will replace any previously set value with the data source provided.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The source argument was null.

See Also

MCattribute Class
MCattribute Members
setValue Overload


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..ToString Method
MCattribute Class See Also Send Feedback
Returns a string representation of this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents this attribute.

See Also

MCattribute Class
MCattribute Members


MCattribute Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute Properties
MCattribute Class See Also Send Feedback

The MCattribute type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of values in this attribute.
Public property | Element | Gets the data element associated with this attribute.
Public property | IsBulk | Checks whether this attribute is an OB, OW, OL, OD or OF type attribute.
Public property | IsEncapsulated | Get/Set property whether the bulk data are encapsulated, true by default for the encapsulated transfer syntax
Public property | Item[([( Int32])]) | Gets or sets values of this attribute.
Public property | Item[([( Int32, Object])]) | Gets a value of this attribute using a specified default value if the requested attribute does not exist.
Public property | MultipleValuesDelimitation | This property allows for attributes to set multiple string values, i.e. concatenated with backslash '\\' delimiters, as a single string without delimitation
Public property | ParentId | Gets AttributeSet Id hosting the current attribute
Public property | Tag | Gets the tag identifying this attribute.
Public property | ValueLength | Gets the data length of this attribute's value.
Public property | ValueNull | Get/Set whether this attribute has NULL value.
Public property | ValueRepresentation | Gets and sets the attribute's DICOM Value Representation.

See Also

MCattribute Class


Count Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Count Property
MCattribute Class See Also Send Feedback
Gets the number of values in this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

An int representing the number of values.

See Also

MCattribute Class
MCattribute Members


Element Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Element Property
MCattribute Class See Also Send Feedback
Gets the data element associated with this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataElement Element { get; }
Visual Basic
Public Overridable ReadOnly Property Element As MCdataElement
    Get
Visual C++
public:
virtual property MCdataElement^ Element {
    MCdataElement^ get ();
}

Field Value

An MCdataElement object.

See Also

MCattribute Class
MCattribute Members


IsBulk Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..IsBulk Property
MCattribute Class See Also Send Feedback
Checks whether this attribute is an OB, OW, OL, OD or OF type attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsBulk { get; }
Visual Basic
Public Overridable ReadOnly Property IsBulk As Boolean
    Get
Visual C++
public:
virtual property bool IsBulk {
    bool get ();
}

Field Value

true if this attribute's value is bulk data; otherwise false.

See Also

MCattribute Class
MCattribute Members


IsEncapsulated Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..IsEncapsulated Property
MCattribute Class See Also Send Feedback
Get/Set property whether the bulk data are encapsulated, true by default for the encapsulated transfer syntax

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool IsEncapsulated { get; set; }
Visual Basic
Public Property IsEncapsulated As Boolean
    Get
    Set
Visual C++
public:
property bool IsEncapsulated {
    bool get ();
    void set (bool value);
}

See Also

MCattribute Class
MCattribute Members


Item Property

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Item Property
MCattribute Class See Also Send Feedback
Gets or sets values of this attribute. In C#, this property is the indexer for the MCattribute class.

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets values of this attribute.
Public property | Item[([( Int32, Object])]) | Gets a value of this attribute using a specified default value if the requested attribute does not exist.

See Also

MCattribute Class
MCattribute Members


Item Property (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Item Property (Int32)
MCattribute Class See Also Send Feedback
Gets or sets values of this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero based index of the value to get or set.

Field Value

An object representing the value at the specified index. The concrete type of the object is determined by the value representation of the attribute.

Remarks

This property provides an array view for the values of this attribute.

If the attribute does not have the specified value, attempting to get it returns a null reference, and attempting to set it adds it to the list of existing values increasing the Count property to index + 1.

When setting this property, if the specified value already exists, the value is replaced otherwise a new value is added and all intermediate values are set to null or 0. For example setting the value with index 3 on an attribute with one value (Count == 1) will set the fourth value to the assigned object and set the second and third values to null. If the value assigned is an array of objects all elements of the array are set or added to the list of values of this attribute starting with the value specified by the index parameter.

This property is thread-safe.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of this attribute is OB, OW, OL, OD or OF.
Mergecom.Exceptions..::..MCillegalArgumentException | When setting this property, the type of the value specified is incompatible with the VR of this attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | When setting this property, the value contains invalid characters for the VR of the attribute.
Mergecom.Exceptions..::..MCnoSuchValueException | When getting this attribute, index is not a valid value for the attribute.

See Also

MCattribute Class
MCattribute Members
Item Overload


Item Property (Int32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Item Property (Int32, Object)
MCattribute Class See Also Send Feedback
Gets a value of this attribute using a specified default value if the requested attribute does not exist.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    int index,
    Object defaultValue
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer, _
    defaultValue As Object _
) As Object
    Get
Visual C++
public:
property Object^ default[int index, Object^ defaultValue] {
    Object^ get (int index, Object^ defaultValue);
}

Parameters

index
Type: System..::..Int32
The zero based index of the value to get.
defaultValue
Type: System..::..Object
The value to return if a value with the specified index does not exist.

Field Value

An object representing the value at the specified index.

Remarks

The concrete type of the object is determined by the value representation of the attribute.

This property is thread-safe.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of this attribute is OB, OW, OL, OD or OF.

See Also

MCattribute Class
MCattribute Members
Item Overload


MultipleValuesDelimitation Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..MultipleValuesDelimitation Property
MCattribute Class See Also Send Feedback
This property allows for attributes to set multiple string values, i.e. concatenated with backslash '\\' delimiters, as a single string without delimitation

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultipleValuesDelimitation { get; set; }
Visual Basic
Public Overridable Property MultipleValuesDelimitation As Boolean
    Get
    Set
Visual C++
public:
virtual property bool MultipleValuesDelimitation {
    bool get ();
    void set (bool value);
}

Field Value

true = DICOM standard behavior, when multiple string values are delimited

Remarks

The default value of this property is true.

See Also

MCattribute Class
MCattribute Members


ParentId Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..ParentId Property
MCattribute Class See Also Send Feedback
Gets AttributeSet Id hosting the current attribute

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int ParentId { get; }
Visual Basic
Public Overridable ReadOnly Property ParentId As Integer
    Get
Visual C++
public:
virtual property int ParentId {
    int get ();
}

Field Value

An MCattributeSet Id or -1 if there is no AttributeSet host

See Also

MCattribute Class
MCattribute Members


Tag Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..Tag Property
MCattribute Class See Also Send Feedback
Gets the tag identifying this attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtag Tag { get; }
Visual Basic
Public Overridable ReadOnly Property Tag As MCtag
    Get
Visual C++
public:
virtual property MCtag^ Tag {
    MCtag^ get ();
}

Field Value

An MCtag object.

See Also

MCattribute Class
MCattribute Members


ValueLength Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..ValueLength Property
MCattribute Class See Also Send Feedback
Gets the data length of this attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint ValueLength { get; }
Visual Basic
Public Overridable ReadOnly Property ValueLength As UInteger
    Get
Visual C++
public:
virtual property unsigned int ValueLength {
    unsigned int get ();
}

Field Value

A uint representing the total length of the attribute's values. For string type attributes (AE, AS, CS, DA, DS, DT, IS, LO, PN, SH, TM, UI, LT, ST, UT) the length returned is the total number of characters of this attribute's values including the values separators if there is more than one value. For binary tipe values (SS, US, AT, SL, UL, FL, FD, UN, OB, OW, OL, OD, OF) the length is the total number of bytes in the encoded value. For sequence attributes (SQ) the length returned is the number of items contained in the sequence.

See Also

MCattribute Class
MCattribute Members


ValueNull Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..ValueNull Property
MCattribute Class See Also Send Feedback
Get/Set whether this attribute has NULL value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool ValueNull { get; internal set; }
Visual Basic
Public Overridable Property ValueNull As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool ValueNull {
    bool get ();
    internal: void set (bool value);
}

Field Value

true if attribute has no value but must be included in message, false otherwise.

Remarks

An attribute with a ValueLength of zero and a Count of 1 will return true.

Note: A bulk attribute may have a ValueLength of zero and a Count of 1 without this property returning true in the case the bulk data are stored in an MCattributeContainer.

See Also

MCattribute Class
MCattribute Members


ValueRepresentation Property

[image]

Merge DICOM .NET/C# Toolkit
MCattribute..::..ValueRepresentation Property
MCattribute Class See Also Send Feedback
Gets and sets the attribute's DICOM Value Representation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCvr ValueRepresentation { get; set; }
Visual Basic
Public Overridable Property ValueRepresentation As MCvr
    Get
    Set
Visual C++
public:
virtual property MCvr^ ValueRepresentation {
    MCvr^ get ();
    void set (MCvr^ value);
}

Field Value

An MCvr object identifying the DICOM Value Representation of this attribute.

Remarks

When setting this property the toolkit will attempt to convert the value of the attribute to the proper type. Note that conversions from unknown VR to string types that depend on the specific character set are done using the default dicom character set.

The change in VR is reflected locally in the attribute, while the data element remains unchanged, so it is possible that ValueRepresentation has a different value than Element .VR. This is because data elements can be shared between attributes.

When setting this property, valid conversions are: US -> SS, SS -> US, SS -> OW, US -> OW, OW -> US, OW -> SS, OW -> OB, OB -> OW, UN -> Any VR.

If an attribute is a bulk attribute, namely pixel data, it can only be converted between OW and OB but not to SS or US.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCincompatibleValueException | Data type not convertible.
Mergecom.Exceptions..::..MCillegalArgumentException | The target VR is invalid.

See Also

MCattribute Class
MCattribute Members


MCattributeContainer Interface

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer Interface
Members See Also Send Feedback
This interface defines the requirements for a class which is to serve as a container for an attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCattributeContainer
Visual Basic
Public Interface MCattributeContainer
Visual C++
public interface class MCattributeContainer

Remarks

The library will call the interface methods to get/set values for specific attributes.

The MCapplication.registerAttributeContainer method can be used to register an attribute container and MCapplication.releaseAttributeContainer method can be used to de-register an attribute container.

See Also

MCattributeContainer Members


MCattributeContainer Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer Members
MCattributeContainer Interface Methods See Also Send Feedback

The MCattributeContainer type exposes the following members.

Methods

 | Name | Description
Public method | provideData | Called to retrieve stream data for an attribute's value.
Public method | provideDataLength | Called to retrieve the length of an attribute's value.
Public method | receiveData | Called by the library to provide stream data for an attribute.
Public method | receiveDataLength | Provides the length of an attribute's value.
Public method | receiveMediaDataLength | Provides the data length of the specified attribute and also the byte offset from the beginning of the media file of the attribute's value.
Public method | receiveOffsetTable | Called by the library to provide a Basic Offset Table for an attribute with encapsulated value.

See Also

MCattributeContainer Interface


MCattributeContainer Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer Methods
MCattributeContainer Interface See Also Send Feedback

The MCattributeContainer type exposes the following members.

Methods

 | Name | Description
Public method | provideData | Called to retrieve stream data for an attribute's value.
Public method | provideDataLength | Called to retrieve the length of an attribute's value.
Public method | receiveData | Called by the library to provide stream data for an attribute.
Public method | receiveDataLength | Provides the length of an attribute's value.
Public method | receiveMediaDataLength | Provides the data length of the specified attribute and also the byte offset from the beginning of the media file of the attribute's value.
Public method | receiveOffsetTable | Called by the library to provide a Basic Offset Table for an attribute with encapsulated value.

See Also

MCattributeContainer Interface


provideData Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..provideData Method
MCattributeContainer Interface See Also Send Feedback
Called to retrieve stream data for an attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
MCdata provideData(
    MCattributeSet set,
    MCtag tag,
    bool isFirst
)
Visual Basic
Function provideData ( _
    set As MCattributeSet, _
    tag As MCtag, _
    isFirst As Boolean _
) As MCdata
Visual C++
MCdata^ provideData(
    MCattributeSet^ set,
    MCtag^ tag,
    bool isFirst
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
isFirst
Type: System..::..Boolean
true if this is the first call for this stream.

Return Value

An MCdata object containing a portion or all of the stream data.

Remarks

The data provided must be in the standard Little Endian format.

The returned MCdata must have IsLast property set to true if no more data is available.

See Also

MCattributeContainer Interface
MCattributeContainer Members


provideDataLength Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..provideDataLength Method
MCattributeContainer Interface See Also Send Feedback
Called to retrieve the length of an attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
uint provideDataLength(
    MCattributeSet set,
    MCtag tag
)
Visual Basic
Function provideDataLength ( _
    set As MCattributeSet, _
    tag As MCtag _
) As UInteger
Visual C++
unsigned int provideDataLength(
    MCattributeSet^ set,
    MCtag^ tag
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.

Return Value

The total size (in bytes) of the attribute's value. This must be an even number.

See Also

MCattributeContainer Interface
MCattributeContainer Members


receiveData Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..receiveData Method
MCattributeContainer Interface See Also Send Feedback
Called by the library to provide stream data for an attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveData(
    MCattributeSet set,
    MCtag tag,
    MCdata data,
    bool isFirst
)
Visual Basic
Sub receiveData ( _
    set As MCattributeSet, _
    tag As MCtag, _
    data As MCdata, _
    isFirst As Boolean _
)
Visual C++
void receiveData(
    MCattributeSet^ set,
    MCtag^ tag,
    MCdata^ data,
    bool isFirst
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
data
Type: Mergecom..::..MCdata
An MCdata object containing the data. The IsLast property of this object tells whether this is the last piece of data for the specified attribute's value.
isFirst
Type: System..::..Boolean
true if this is the first receiveData call for the specified attribute.

See Also

MCattributeContainer Interface
MCattributeContainer Members


receiveDataLength Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..receiveDataLength Method
MCattributeContainer Interface See Also Send Feedback
Provides the length of an attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveDataLength(
    MCattributeSet set,
    MCtag tag,
    uint dataLength
)
Visual Basic
Sub receiveDataLength ( _
    set As MCattributeSet, _
    tag As MCtag, _
    dataLength As UInteger _
)
Visual C++
void receiveDataLength(
    MCattributeSet^ set,
    MCtag^ tag,
    unsigned int dataLength
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
dataLength
Type: System..::..UInt32
The length (in bytes) of the attribute's value.

See Also

MCattributeContainer Interface
MCattributeContainer Members


receiveMediaDataLength Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..receiveMediaDataLength Method
MCattributeContainer Interface See Also Send Feedback
Provides the data length of the specified attribute and also the byte offset from the beginning of the media file of the attribute's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveMediaDataLength(
    MCattributeSet set,
    MCtag tag,
    uint dataLength,
    uint dataOffset
)
Visual Basic
Sub receiveMediaDataLength ( _
    set As MCattributeSet, _
    tag As MCtag, _
    dataLength As UInteger, _
    dataOffset As UInteger _
)
Visual C++
void receiveMediaDataLength(
    MCattributeSet^ set,
    MCtag^ tag,
    unsigned int dataLength,
    unsigned int dataOffset
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
dataLength
Type: System..::..UInt32
The length (in bytes) of the attribute's value.
dataOffset
Type: System..::..UInt32
The byte offset to the value from the beginning of the file.

See Also

MCattributeContainer Interface
MCattributeContainer Members


receiveOffsetTable Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainer..::..receiveOffsetTable Method
MCattributeContainer Interface See Also Send Feedback
Called by the library to provide a Basic Offset Table for an attribute with encapsulated value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveOffsetTable(
    MCattributeSet set,
    MCtag tag,
    MCdata data,
    bool isFirst
)
Visual Basic
Sub receiveOffsetTable ( _
    set As MCattributeSet, _
    tag As MCtag, _
    data As MCdata, _
    isFirst As Boolean _
)
Visual C++
void receiveOffsetTable(
    MCattributeSet^ set,
    MCtag^ tag,
    MCdata^ data,
    bool isFirst
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
data
Type: Mergecom..::..MCdata
An MCdata containing data for the offset table. The IsLast property of this object tells whether this is the last piece of the offset table.
isFirst
Type: System..::..Boolean
true if this is the first receiveData call for this stream.

Remarks

This method is primarily called when compressing an image. It can be called multiple times for a single image if a multiframe image is being compressed. As each frame is compressed, an updated offset table is supplied.

See Also

MCattributeContainer Interface
MCattributeContainer Members


MCattributeContainerEx Interface

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainerEx Interface
Members See Also Send Feedback
This interface extends MCattributeContainer interface allowing to read a stream data of an attribute's value with a given offset.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCattributeContainerEx : MCattributeContainer
Visual Basic
Public Interface MCattributeContainerEx _
    Inherits MCattributeContainer
Visual C++
public interface class MCattributeContainerEx : MCattributeContainer

Remarks

The library will call the interface methods to get/set values for specific attributes.

The MCapplication.registerAttributeContainer method can be used to register an attribute container and MCapplication.releaseAttributeContainer method can be used to de-register an attribute container.

See Also

MCattributeContainerEx Members


MCattributeContainerEx Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeContainerEx Members
MCattributeContainerEx Interface Methods See Also Send Feedback

The MCattributeContainerEx type exposes the following members.

Methods

 | Name | Description
Public method | provideData(MCattributeSet, MCtag, Boolean) | Called to retrieve stream data for an attribute's value. (Inherited from MCattributeContainer.)
Public method | provideData(MCattributeSet, MCtag, UInt32, Boolean) | Called to retrieve a stream data of an attribute's value with a given offset.
Public method | provideDataLength | Called to retrieve the length of an attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveData | Called by the library to provide stream data for an attribute. (Inherited from MCattributeContainer.)
Public method | receiveDataLength | Provides the length of an attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveMediaDataLength | Provides the data length of the specified attribute and also the byte offset from the beginning of the media file of the attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveOffsetTable | Called by the library to provide a Basic Offset Table for an attribute with encapsulated value. (Inherited from MCattributeContainer.)

See Also

MCattributeContainerEx Interface


MCattributeContainerEx Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeContainerEx Methods
MCattributeContainerEx Interface See Also Send Feedback

The MCattributeContainerEx type exposes the following members.

Methods

 | Name | Description
Public method | provideData(MCattributeSet, MCtag, Boolean) | Called to retrieve stream data for an attribute's value. (Inherited from MCattributeContainer.)
Public method | provideData(MCattributeSet, MCtag, UInt32, Boolean) | Called to retrieve a stream data of an attribute's value with a given offset.
Public method | provideDataLength | Called to retrieve the length of an attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveData | Called by the library to provide stream data for an attribute. (Inherited from MCattributeContainer.)
Public method | receiveDataLength | Provides the length of an attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveMediaDataLength | Provides the data length of the specified attribute and also the byte offset from the beginning of the media file of the attribute's value. (Inherited from MCattributeContainer.)
Public method | receiveOffsetTable | Called by the library to provide a Basic Offset Table for an attribute with encapsulated value. (Inherited from MCattributeContainer.)

See Also

MCattributeContainerEx Interface


provideData Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeContainerEx..::..provideData Method
MCattributeContainerEx Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | provideData(MCattributeSet, MCtag, Boolean) | Called to retrieve stream data for an attribute's value. (Inherited from MCattributeContainer.)
Public method | provideData(MCattributeSet, MCtag, UInt32, Boolean) | Called to retrieve a stream data of an attribute's value with a given offset.

See Also

MCattributeContainerEx Interface
MCattributeContainerEx Members


provideData Method (MCattributeSet, MCtag, UInt32, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeContainerEx..::..provideData Method (MCattributeSet, MCtag, UInt32, Boolean)
MCattributeContainerEx Interface See Also Send Feedback
Called to retrieve a stream data of an attribute's value with a given offset.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
MCdata provideData(
    MCattributeSet set,
    MCtag tag,
    uint offset,
    bool isFirst
)
Visual Basic
Function provideData ( _
    set As MCattributeSet, _
    tag As MCtag, _
    offset As UInteger, _
    isFirst As Boolean _
) As MCdata
Visual C++
MCdata^ provideData(
    MCattributeSet^ set,
    MCtag^ tag,
    unsigned int offset,
    bool isFirst
)

Parameters

set
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing the attribute involved.
tag
Type: Mergecom..::..MCtag
An MCtag identifying the attribute involved.
offset
Type: System..::..UInt32
An offset of the stream to read the data from.
isFirst
Type: System..::..Boolean
true if this is the first call for this stream.

Return Value

An MCdata object containing a portion or all of the stream data.

Remarks

The data provided must be in the standard Little Endian format.

The returned MCdata must have IsLast property set to true if no more data is available.

See Also

MCattributeContainerEx Interface
MCattributeContainerEx Members
provideData Overload


MCattributeSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet Class
Members See Also Send Feedback
Provides base functionality to control a collection of DICOM attributes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCattributeSet
Visual Basic
Public Class MCattributeSet
Visual C++
public ref class MCattributeSet

Remarks

Five subclasses are provided that represent different types of DICOM attribute collections: MCcommandSet MCdataSet MCfileMetaInfo MCitem MCdicomDirRecord

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom.Dicomdir..::..MCdicomDirRecord
Mergecom..::..MCcommandSet
Mergecom..::..MCdataSet
Mergecom..::..MCfileMetaInfo
Mergecom..::..MCitem

See Also

MCattributeSet Members


MCattributeSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet Members
MCattributeSet Class Methods Properties See Also Send Feedback

The MCattributeSet type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set.
Public method | add(MCtag) | Adds an empty attribute to this attribute set.
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute.
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute.
Public method | clear | Removes all attributes.
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one.
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one.
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set.
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set.
Public method | copyTo | Copies the attributes within this set to another attribute set.
Public method | dispose | Disposes this attribute set.
Public method | emptyValues | Sets all attributes to empty.
Public method | Equals | Determines if this attribute set is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output.
Public method | list(TextWriter) | Lists the contents of this attribute set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set.
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string.
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set.
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set.
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set.
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set.
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard).
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard).
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner.
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set.
Public property | Attributes | Gets a collection view of the attributes of this attribute set.
Public property | Count | Gets the number of attributes in this set.
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set.
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes).
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set.
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set.
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set.
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set.
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set.
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set.
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set.
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set.
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set.
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set.
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute.
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set.
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set.
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set.
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set.
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set.
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set.

See Also

MCattributeSet Class


MCattributeSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet Methods
MCattributeSet Class See Also Send Feedback

The MCattributeSet type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set.
Public method | add(MCtag) | Adds an empty attribute to this attribute set.
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute.
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute.
Public method | clear | Removes all attributes.
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one.
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one.
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set.
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set.
Public method | copyTo | Copies the attributes within this set to another attribute set.
Public method | dispose | Disposes this attribute set.
Public method | emptyValues | Sets all attributes to empty.
Public method | Equals | Determines if this attribute set is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output.
Public method | list(TextWriter) | Lists the contents of this attribute set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set.
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string.
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set.
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set.
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set.
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set.
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard).
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard).
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner.
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).

See Also

MCattributeSet Class


add Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..add Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set.
Public method | add(MCtag) | Adds an empty attribute to this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


add Method (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..add Method (UInt32)
MCattributeSet Class See Also Send Feedback
Adds an empty standard attribute to this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute add(
    uint tag
)
Visual Basic
Public Function add ( _
    tag As UInteger _
) As MCattribute
Visual C++
public:
MCattribute^ add(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag identifying the attribute to add.

Return Value

The newly created attribute or if an attribute with the specified tag already exists in this attribute set, the existing attribute is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.

See Also

MCattributeSet Class
MCattributeSet Members
add Overload


add Method (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..add Method (MCtag)
MCattributeSet Class See Also Send Feedback
Adds an empty attribute to this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute add(
    MCtag tag
)
Visual Basic
Public Function add ( _
    tag As MCtag _
) As MCattribute
Visual C++
public:
MCattribute^ add(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag identifying the attribute to add.

Return Value

The newly created attribute or if an attribute with the specified tag already exists in this attribute set, the existing attribute is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.

See Also

MCattributeSet Class
MCattributeSet Members
add Overload


addValue Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..addValue Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute.
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute.

See Also

MCattributeSet Class
MCattributeSet Members


addValue Method (UInt32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..addValue Method (UInt32, Object)
MCattributeSet Class See Also Send Feedback
Adds a value to the list of values of a standard attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void addValue(
    uint tag,
    Object value
)
Visual Basic
Public Sub addValue ( _
    tag As UInteger, _
    value As Object _
)
Visual C++
public:
void addValue(
    unsigned int tag,
    Object^ value
)

Parameters

tag
Type: System..::..UInt32
The tag identifying the attribute
value
Type: System..::..Object
The value to add.

Remarks

If the attribute does not exits in this set it is created first.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set or the type of the value is invalid for the specified attribute.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set the value on a bulk type attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
addValue Overload


addValue Method (MCtag, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..addValue Method (MCtag, Object)
MCattributeSet Class See Also Send Feedback
Adds a value to the list of values of an attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void addValue(
    MCtag tag,
    Object value
)
Visual Basic
Public Sub addValue ( _
    tag As MCtag, _
    value As Object _
)
Visual C++
public:
void addValue(
    MCtag^ tag,
    Object^ value
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag identifying the attribute
value
Type: System..::..Object
The value to add.

Remarks

If the attribute does not exits in this set it is created first.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set or the type of the value is invalid for the specified attribute.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set the value on a bulk type attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
addValue Overload


clear Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..clear Method
MCattributeSet Class See Also Send Feedback
Removes all attributes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void clear()
Visual Basic
Public Sub clear
Visual C++
public:
void clear()

See Also

MCattributeSet Class
MCattributeSet Members


compareTo Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..compareTo Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one.
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one.

See Also

MCattributeSet Class
MCattributeSet Members


compareTo Method (MCattributeSet)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..compareTo Method (MCattributeSet)
MCattributeSet Class See Also Send Feedback
Compares another MCattributeSet instance to this one.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string compareTo(
    MCattributeSet other
)
Visual Basic
Public Function compareTo ( _
    other As MCattributeSet _
) As String
Visual C++
public:
String^ compareTo(
    MCattributeSet^ other
)

Parameters

other
Type: Mergecom..::..MCattributeSet
The MCattributeSet to compare with this one.

Return Value

A String describing the first difference between the attribute sets or null if the two attribute sets contain the same data.

Remarks

This method compares each attribute within the two attribute sets using Equals(Object) method.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.

See Also

MCattributeSet Class
MCattributeSet Members
compareTo Overload


compareTo Method (MCattributeSet, UInt32, UInt32, UInt32[])

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..compareTo Method (MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][])
MCattributeSet Class See Also Send Feedback
Compares another MCattributeSet instance to this one.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string compareTo(
    MCattributeSet other,
    uint startTag,
    uint stopTag,
    uint[] skipTags
)
Visual Basic
Public Function compareTo ( _
    other As MCattributeSet, _
    startTag As UInteger, _
    stopTag As UInteger, _
    skipTags As UInteger() _
) As String
Visual C++
public:
String^ compareTo(
    MCattributeSet^ other,
    unsigned int startTag,
    unsigned int stopTag,
    array<unsigned int>^ skipTags
)

Parameters

other
Type: Mergecom..::..MCattributeSet
The MCattributeSet to compare with this one.
startTag
Type: System..::..UInt32
Starting tag number to compare
stopTag
Type: System..::..UInt32
Stop tag number to compare
skipTags
Type: array<System..::..UInt32>[]()[][]
Tag numbers to skip

Return Value

A String describing the first difference between the attribute sets or null if the two attribute sets contain the same data.

Remarks

This method compares each attribute within the two attribute sets using Equals(Object) method.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.

See Also

MCattributeSet Class
MCattributeSet Members
compareTo Overload


contains Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..contains Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set.
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


contains Method (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..contains Method (UInt32)
MCattributeSet Class See Also Send Feedback
Checks if an attribute is present in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool contains(
    uint tag
)
Visual Basic
Public Function contains ( _
    tag As UInteger _
) As Boolean
Visual C++
public:
bool contains(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag identifying the attribute to query.

Return Value

true if an attribute with the specified tag exists.

See Also

MCattributeSet Class
MCattributeSet Members
contains Overload


contains Method (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..contains Method (MCtag)
MCattributeSet Class See Also Send Feedback
Checks if an attribute is present in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool contains(
    MCtag tag
)
Visual Basic
Public Function contains ( _
    tag As MCtag _
) As Boolean
Visual C++
public:
bool contains(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag identifying the attribute to query.

Return Value

true if an attribute with the specified tag exists.

See Also

MCattributeSet Class
MCattributeSet Members
contains Overload


copyTo Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..copyTo Method
MCattributeSet Class See Also Send Feedback
Copies the attributes within this set to another attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void copyTo(
    MCattributeSet destination
)
Visual Basic
Public Sub copyTo ( _
    destination As MCattributeSet _
)
Visual C++
public:
void copyTo(
    MCattributeSet^ destination
)

Parameters

destination
Type: Mergecom..::..MCattributeSet
The attribute set to to copy this attribute set into.

Remarks

This method utilizes the MCattribute.clone method to copy the attributes to destination. A copy is made of all attributes except the bulk data (OB, OW, OL, OD, OF tags) for which the data is shared.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | An attribute being copied is not valid for the destination attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..dispose Method
MCattributeSet Class See Also Send Feedback
Disposes this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void dispose()
Visual Basic
Public Overridable Sub dispose
Visual C++
public:
virtual void dispose()

See Also

MCattributeSet Class
MCattributeSet Members


emptyValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..emptyValues Method
MCattributeSet Class See Also Send Feedback
Sets all attributes to empty.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void emptyValues()
Visual Basic
Public Sub emptyValues
Visual C++
public:
void emptyValues()

See Also

MCattributeSet Class
MCattributeSet Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Equals Method
MCattributeSet Class See Also Send Feedback
Determines if this attribute set is equal to another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare to this instance

Return Value

true if the object is an MCattributeSet instance and it contains the same data as the current attribute set.

Remarks

Two attribute sets are considered equal if compareTo(MCattributeSet)method returns null.

See Also

MCattributeSet Class
MCattributeSet Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..GetHashCode Method
MCattributeSet Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCattributeSet Class
MCattributeSet Members


list Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..list Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | list()()()() | Lists the contents of this attribute set to the console output.
Public method | list(TextWriter) | Lists the contents of this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


list Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..list Method
MCattributeSet Class See Also Send Feedback
Lists the contents of this attribute set to the console output.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void list()
Visual Basic
Public Sub list
Visual C++
public:
void list()

See Also

MCattributeSet Class
MCattributeSet Members
list Overload


list Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..list Method (TextWriter)
MCattributeSet Class See Also Send Feedback
Lists the contents of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void list(
    TextWriter destination
)
Visual Basic
Public Sub list ( _
    destination As TextWriter _
)
Visual C++
public:
void list(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the attribute listing to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
list Overload


readFromJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromJSON Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


readFromJSON Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromJSON Method (TextReader)
MCattributeSet Class See Also Send Feedback
Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromJSON(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromJSON ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromJSON(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the JSON attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromJSON Overload


readFromJSON Method (TextReader, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromJSON Method (TextReader, MCbulkDataUriHandler)
MCattributeSet Class See Also Send Feedback
Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromJSON(
    TextReader source,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub readFromJSON ( _
    source As TextReader, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void readFromJSON(
    TextReader^ source,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the JSON attributes from.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
An implementation of MCbulkDataUri interface that can handle reading of BulkDataURI from the JSON stream. When an attribute contains BulkDataURI, the MCbulkDataUriHandler.provideData method will be called.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromJSON Overload


readFromXML Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXML Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set.
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string.

See Also

MCattributeSet Class
MCattributeSet Members


readFromXML Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXML Method (TextReader)
MCattributeSet Class See Also Send Feedback
Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXML(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromXML ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromXML(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromXML Overload


readFromXML Method (XmlReader)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXML Method (XmlReader)
MCattributeSet Class See Also Send Feedback
Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete because the white space within value may not be preserved; use readFromXML(TextReader) instead")]
public virtual void readFromXML(
    XmlReader source
)
Visual Basic
<ObsoleteAttribute("This method is obsolete because the white space within value may not be preserved; use readFromXML(TextReader) instead")> _
Public Overridable Sub readFromXML ( _
    source As XmlReader _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete because the white space within value may not be preserved; use readFromXML(TextReader) instead")]
virtual void readFromXML(
    XmlReader^ source
)

Parameters

source
Type: System.Xml..::..XmlReader
The source XmlReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromXML Overload


readFromXMLNative Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXMLNative Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


readFromXMLNative Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXMLNative Method (TextReader)
MCattributeSet Class See Also Send Feedback
Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXMLNative(
    TextReader source
)
Visual Basic
Public Overridable Sub readFromXMLNative ( _
    source As TextReader _
)
Visual C++
public:
virtual void readFromXMLNative(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromXMLNative Overload


readFromXMLNative Method (TextReader, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..readFromXMLNative Method (TextReader, MCbulkDataUriHandler)
MCattributeSet Class See Also Send Feedback
Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFromXMLNative(
    TextReader source,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub readFromXMLNative ( _
    source As TextReader, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void readFromXMLNative(
    TextReader^ source,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

source
Type: System.IO..::..TextReader
The source TextReader to read the XML attributes from.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
An implementation of MCbulkDataUri interface that can handle reading of BulkDataURI from the XML stream. When an attribute contains BulkDataURI, the MCbulkDataUriHandler.provideData method will be called.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
readFromXMLNative Overload


removeAttribute Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..removeAttribute Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set.
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


removeAttribute Method (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..removeAttribute Method (UInt32)
MCattributeSet Class See Also Send Feedback
Removes a standard attribute from this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void removeAttribute(
    uint tag
)
Visual Basic
Public Sub removeAttribute ( _
    tag As UInteger _
)
Visual C++
public:
void removeAttribute(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag of the attribute to remove.

Remarks

Removing a bulk attribute from an attribute set causes the attribute to loose its value. This is because bulk attribute values are stored in unmanaged memory by the native toolkit's message object and removing the attribute from the message causes the value to be freed.

See Also

MCattributeSet Class
MCattributeSet Members
removeAttribute Overload


removeAttribute Method (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..removeAttribute Method (MCtag)
MCattributeSet Class See Also Send Feedback
Removes an attribute from this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void removeAttribute(
    MCtag tag
)
Visual Basic
Public Sub removeAttribute ( _
    tag As MCtag _
)
Visual C++
public:
void removeAttribute(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute to remove.

Remarks

Removing a bulk attribute from an attribute set causes the attribute to loose its value. This is because bulk attribute values are stored in unmanaged memory by the native toolkit's message object and removing the attribute from the message causes the value to be freed.

See Also

MCattributeSet Class
MCattributeSet Members
removeAttribute Overload


setValue Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..setValue Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set.
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


setValue Method (UInt32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..setValue Method (UInt32, Object)
MCattributeSet Class See Also Send Feedback
Sets the value of a standard attribute in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void setValue(
    uint tag,
    Object val
)
Visual Basic
Public Sub setValue ( _
    tag As UInteger, _
    val As Object _
)
Visual C++
public:
void setValue(
    unsigned int tag,
    Object^ val
)

Parameters

tag
Type: System..::..UInt32
The tag of the attribute to set.
val
Type: System..::..Object
The value to set.

Remarks

If the attribute to set does not exits in this set it is created first.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set or the type of the value is invalid for the specified attribute.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set the value on a bulk type attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
setValue Overload


setValue Method (MCtag, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..setValue Method (MCtag, Object)
MCattributeSet Class See Also Send Feedback
Sets the value of an attribute in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void setValue(
    MCtag tag,
    Object val
)
Visual Basic
Public Sub setValue ( _
    tag As MCtag, _
    val As Object _
)
Visual C++
public:
void setValue(
    MCtag^ tag,
    Object^ val
)

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute to set.
val
Type: System..::..Object
The value to set.

Remarks

If the attribute to set does not exits in this set it is created first.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set or the type of the value is invalid for the specified attribute.
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is not a standard DICOM tag.
Mergecom.Exceptions..::..MCincompatibleValueException | Trying to set the value on a bulk type attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
setValue Overload


streamIn Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamIn Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


streamIn Method (MCtransferSyntax, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamIn Method (MCtransferSyntax, MCdataSource)
MCattributeSet Class See Also Send Feedback
Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public uint streamIn(
    MCtransferSyntax transferSyntax,
    MCdataSource stream
)
Visual Basic
Public Function streamIn ( _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSource _
) As UInteger
Visual C++
public:
unsigned int streamIn(
    MCtransferSyntax^ transferSyntax,
    MCdataSource^ stream
)

Parameters

transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the stream.
stream
Type: Mergecom..::..MCdataSource
An MCdataSink that provides access to the stream data.

Return Value

The byte offset in the stream where the decoding stopped.

Remarks

All attributes within the stream are to be placed into this attribute list.

If the stream contains any attributes with a value representation of SQ (i.e. the stream contains one or more sequences of items), an MCitem object is automatically created for each item in the stream. An MCitem object is used as the value for each item in each sequence attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCinvalidEncodingException | A tag was found in the stream that was not in ascending order or an invalid DICOM tag was detected in the stream or the stream ended without passing the entire value for an attribute or too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCattributeSet Class
MCattributeSet Members
streamIn Overload


streamIn Method (UInt32, UInt32, MCtransferSyntax, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamIn Method (UInt32, UInt32, MCtransferSyntax, MCdataSource)
MCattributeSet Class See Also Send Feedback
Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public uint streamIn(
    uint startTag,
    uint stopTag,
    MCtransferSyntax transferSyntax,
    MCdataSource stream
)
Visual Basic
Public Function streamIn ( _
    startTag As UInteger, _
    stopTag As UInteger, _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSource _
) As UInteger
Visual C++
public:
unsigned int streamIn(
    unsigned int startTag,
    unsigned int stopTag,
    MCtransferSyntax^ transferSyntax,
    MCdataSource^ stream
)

Parameters

startTag
Type: System..::..UInt32
The tag number of the first attribute to decode.
stopTag
Type: System..::..UInt32
The tag number of the last attribute to decode.
transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the stream.
stream
Type: Mergecom..::..MCdataSource
An MCdataSink that provides access to the stream data.

Return Value

The byte offset in the stream where the decoding stopped.

Remarks

Any attributes in the stream with tags less than startTag or greater than stopTag will be ignored. Neither startTag nor stopTag need to be in the stream.

If the stream contains any attributes with a value representation of SQ (i.e. the stream contains one or more sequences of items), an MCitem object is automatically created for each item in the stream. An MCitem object is used as the value for each item in each sequence attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCinvalidEncodingException | A tag was found in the stream that was not in ascending order or an invalid DICOM tag was detected in the stream or the stream ended without passing the entire value for an attribute or too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCattributeSet Class
MCattributeSet Members
streamIn Overload


streamOut Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamOut Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard).
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard).

See Also

MCattributeSet Class
MCattributeSet Members


streamOut Method (MCtransferSyntax, MCdataSink)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamOut Method (MCtransferSyntax, MCdataSink)
MCattributeSet Class See Also Send Feedback
Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void streamOut(
    MCtransferSyntax transferSyntax,
    MCdataSink stream
)
Visual Basic
Public Overridable Sub streamOut ( _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSink _
)
Visual C++
public:
virtual void streamOut(
    MCtransferSyntax^ transferSyntax,
    MCdataSink^ stream
)

Parameters

transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax for the output stream.
stream
Type: Mergecom..::..MCdataSink
The destination for the output stream.

Remarks

All attributes within this attribute set will be placed in the stream.

The streamed message is passed to the destination stream in blocks by calling MCdataSink.receiveData until the entire message has been transferred.

The transfer syntax specifies the byte order used in the streamed message, whether or not each attribute's value representation is explicitly encoded in the stream, and how the pixel data is encoded in the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCattributeSet Class
MCattributeSet Members
streamOut Overload


streamOut Method (UInt32, UInt32, MCtransferSyntax, MCdataSink)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..streamOut Method (UInt32, UInt32, MCtransferSyntax, MCdataSink)
MCattributeSet Class See Also Send Feedback
Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void streamOut(
    uint startTag,
    uint stopTag,
    MCtransferSyntax transferSyntax,
    MCdataSink stream
)
Visual Basic
Public Overridable Sub streamOut ( _
    startTag As UInteger, _
    stopTag As UInteger, _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSink _
)
Visual C++
public:
virtual void streamOut(
    unsigned int startTag,
    unsigned int stopTag,
    MCtransferSyntax^ transferSyntax,
    MCdataSink^ stream
)

Parameters

startTag
Type: System..::..UInt32
The tag number of the first attribute to be streamed.
stopTag
Type: System..::..UInt32
The tag number of the last attribute to be streamed.
transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax for the output stream.
stream
Type: Mergecom..::..MCdataSink
The destination for the output stream.

Remarks

The streamed message is passed to the destination stream in blocks by calling MCdataSink.receiveData until the entire message has been transferred.

startTag and stopTag specify which attributes in the attribute set are to be placed in the stream. Any attributes in the message with tags less than startTag or greater than stopTag will be ignored. Neither startTag nor stopTag need to be in the message.

The transfer syntax specifies the byte order used in the streamed message, whether or not each attribute's value representation is explicitly encoded in the stream, and how the pixel data is encoded in the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCattributeSet Class
MCattributeSet Members
streamOut Overload


syncAttribute Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..syncAttribute Method
MCattributeSet Class See Also Send Feedback
Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete; use the syncPixelData method instead")]
public void syncAttribute(
    uint tag
)
Visual Basic
<ObsoleteAttribute("This method is obsolete; use the syncPixelData method instead")> _
Public Sub syncAttribute ( _
    tag As UInteger _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete; use the syncPixelData method instead")]
void syncAttribute(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag of the attribute.

Remarks

Especially useful for bulk attributes such as pixel data.

See Also

MCattributeSet Class
MCattributeSet Members


syncPixelData Method

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..syncPixelData Method
MCattributeSet Class See Also Send Feedback
Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void syncPixelData()
Visual Basic
Public Sub syncPixelData
Visual C++
public:
void syncPixelData()

See Also

MCattributeSet Class
MCattributeSet Members


writeToJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToJSON Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).

See Also

MCattributeSet Class
MCattributeSet Members


writeToJSON Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToJSON Method (TextWriter)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToJSON(
    TextWriter destination
)
Visual Basic
Public Overridable Sub writeToJSON ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void writeToJSON(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the JSON attributes representation to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToJSON Overload


writeToJSON Method (TextWriter, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToJSON Method (TextWriter, MCbulkDataUriHandler)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToJSON(
    TextWriter destination,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub writeToJSON ( _
    destination As TextWriter, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void writeToJSON(
    TextWriter^ destination,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the JSON attributes representation to.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
MCbulkDataUriHandler implementation to handle writing BulkDataURI during generation of JSON stream. When set to null, all bulk attributes will be send as actual value. MCbulkDataUriHandler.provideUri method will only be called if vr is one of: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToJSON Overload


writeToXML Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXML Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).

See Also

MCattributeSet Class
MCattributeSet Members


writeToXML Method (TextWriter, MCxmlOptions)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXML Method (TextWriter, MCxmlOptions)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXML(
    TextWriter destination,
    MCxmlOptions xmlOptions
)
Visual Basic
Public Overridable Sub writeToXML ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions _
)
Visual C++
public:
virtual void writeToXML(
    TextWriter^ destination,
    MCxmlOptions xmlOptions
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToXML Overload


writeToXML Method (XmlWriter, MCxmlOptions)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXML Method (XmlWriter, MCxmlOptions)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete because the white space within value may not be preserved; use writeToXML(TextWriter, MCxmlOptions) instead")]
public virtual void writeToXML(
    XmlWriter destination,
    MCxmlOptions xmlOptions
)
Visual Basic
<ObsoleteAttribute("This method is obsolete because the white space within value may not be preserved; use writeToXML(TextWriter, MCxmlOptions) instead")> _
Public Overridable Sub writeToXML ( _
    destination As XmlWriter, _
    xmlOptions As MCxmlOptions _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete because the white space within value may not be preserved; use writeToXML(TextWriter, MCxmlOptions) instead")]
virtual void writeToXML(
    XmlWriter^ destination,
    MCxmlOptions xmlOptions
)

Parameters

destination
Type: System.Xml..::..XmlWriter
The destination XmlWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToXML Overload


writeToXMLNative Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXMLNative Method
MCattributeSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).

See Also

MCattributeSet Class
MCattributeSet Members


writeToXMLNative Method (TextWriter, MCxmlOptions)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXMLNative Method (TextWriter, MCxmlOptions)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXMLNative(
    TextWriter destination,
    MCxmlOptions xmlOptions
)
Visual Basic
Public Overridable Sub writeToXMLNative ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions _
)
Visual C++
public:
virtual void writeToXMLNative(
    TextWriter^ destination,
    MCxmlOptions xmlOptions
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToXMLNative Overload


writeToXMLNative Method (TextWriter, MCxmlOptions, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..writeToXMLNative Method (TextWriter, MCxmlOptions, MCbulkDataUriHandler)
MCattributeSet Class See Also Send Feedback
Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeToXMLNative(
    TextWriter destination,
    MCxmlOptions xmlOptions,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Overridable Sub writeToXMLNative ( _
    destination As TextWriter, _
    xmlOptions As MCxmlOptions, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
virtual void writeToXMLNative(
    TextWriter^ destination,
    MCxmlOptions xmlOptions,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

destination
Type: System.IO..::..TextWriter
The destination TextWriter to write the XML attributes representation to.
xmlOptions
Type: Mergecom..::..MCxmlOptions
The XML configuration options.
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
MCbulkDataUriHandler implementation to handle writing BulkDataURI during generation of Native XML stream. When set to null, all bulk attributes will be send as actual value. MCbulkDataUriHandler.provideUri method will only be called if vr is one of: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCattributeSet Class
MCattributeSet Members
writeToXMLNative Overload


MCattributeSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet Properties
MCattributeSet Class See Also Send Feedback

The MCattributeSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set.
Public property | Attributes | Gets a collection view of the attributes of this attribute set.
Public property | Count | Gets the number of attributes in this set.
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set.
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes).
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set.
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set.
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set.
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set.
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set.
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set.
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set.
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set.
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set.
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set.
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute.
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set.
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set.
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set.
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set.
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set.
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set.

See Also

MCattributeSet Class


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..AccessionNumber Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string AccessionNumber { get; set; }
Visual Basic
Public Property AccessionNumber As String
    Get
    Set
Visual C++
public:
property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Accession Number (0008,0050) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


Attributes Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Attributes Property
MCattributeSet Class See Also Send Feedback
Gets a collection view of the attributes of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ICollection Attributes { get; }
Visual Basic
Public Overridable ReadOnly Property Attributes As ICollection
    Get
Visual C++
public:
virtual property ICollection^ Attributes {
    ICollection^ get ();
}

Field Value

An ICollection implementation that allows enumeration of this set's attributes.

See Also

MCattributeSet Class
MCattributeSet Members


Count Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Count Property
MCattributeSet Class See Also Send Feedback
Gets the number of attributes in this set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of attributes in the set.

See Also

MCattributeSet Class
MCattributeSet Members


InstanceNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..InstanceNumber Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string InstanceNumber { get; set; }
Visual Basic
Public Property InstanceNumber As String
    Get
    Set
Visual C++
public:
property String^ InstanceNumber {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Instance Number (0020,0013) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


IsEmpty Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..IsEmpty Property
MCattributeSet Class See Also Send Feedback
Tells whether this attribute set is empty (no attributes).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Field Value

true if there are no attributes in this set.

See Also

MCattributeSet Class
MCattributeSet Members


Item Property

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property
MCattributeSet Class See Also Send Feedback
Gets or sets attributes or attribute values of this attribute set. In C#, this property is the indexer for the MCattributeSet class.

Overload List

 | Name | Description
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set.
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set.
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set.
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set.
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set.

See Also

MCattributeSet Class
MCattributeSet Members


Item Property (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (UInt32)
MCattributeSet Class See Also Send Feedback
Gets or sets a non-private attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute this[
    uint tag
] { get; set; }
Visual Basic
Public Default Property Item ( _
    tag As UInteger _
) As MCattribute
    Get
    Set
Visual C++
public:
property MCattribute^ default[unsigned int tag] {
    MCattribute^ get (unsigned int tag);
    void set (unsigned int tag, MCattribute^ value);
}

Parameters

tag
Type: System..::..UInt32
The tag number of the attribute to get or set.

Field Value

The MCattribute object with the specified tag.

Remarks

When setting this property, if the specified attribute already exists, the attribute is replaced. If the assigned value is null this call is equivalent to a removeAttribute() call.

When getting this property, if the requested attribute does not exists, an MCattributeNotFoundException exception is thrown.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not in the attribute set.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Item Property (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (MCtag)
MCattributeSet Class See Also Send Feedback
Gets or sets an attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattribute this[
    MCtag tag
] { get; set; }
Visual Basic
Public Default Property Item ( _
    tag As MCtag _
) As MCattribute
    Get
    Set
Visual C++
public:
property MCattribute^ default[MCtag^ tag] {
    MCattribute^ get (MCtag^ tag);
    void set (MCtag^ tag, MCattribute^ value);
}

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute to get or set.

Field Value

The MCattribute object with the specified tag.

Remarks

When setting this property, if the specified attribute already exists, the attribute is replaced. If the assigned value is null this call is equivalent to a removeAttribute() call.

When getting this property, if the requested attribute does not exists, an MCattributeNotFoundException exception is thrown.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute tag is not valid for this attribute set.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not in the attribute set.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Item Property (UInt32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (UInt32, Int32)
MCattributeSet Class See Also Send Feedback
Gets or sets attribute values of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    uint tag,
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    tag As UInteger, _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[unsigned int tag, int index] {
    Object^ get (unsigned int tag, int index);
    void set (unsigned int tag, int index, Object^ value);
}

Parameters

tag
Type: System..::..UInt32
The tag number of the attribute.
index
Type: System..::..Int32
The zero based index of the value to get or set.

Field Value

An object representing the value requested.

Remarks

When setting this property, if the attribute with the specified tag does not exists, an new one is added. Setting this property is equivalent with the following call:

myAttributeSet.add(tag)[index]

When getting this property, if the requested attribute does not exists, an MCattributeNotFoundException exception is thrown. If a value with the specified index does not exist null is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The tag is not in the attribute set.
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of the attribute is OB, OW, OL, OD or OF.
Mergecom.Exceptions..::..MCillegalArgumentException | When setting this property, the type of the value specified is incompatible with the VR of the attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | When setting this property, the value contains invalid characters for the VR of the attribute.
Mergecom.Exceptions..::..MCnoSuchValueException | When getting this attribute, index is not a valid value for the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Item Property (MCtag, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (MCtag, Int32)
MCattributeSet Class See Also Send Feedback
Gets or sets attribute values of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    MCtag tag,
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    tag As MCtag, _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[MCtag^ tag, int index] {
    Object^ get (MCtag^ tag, int index);
    void set (MCtag^ tag, int index, Object^ value);
}

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute.
index
Type: System..::..Int32
The zero based index of the value to get or set.

Field Value

An object representing the value requested.

Remarks

When setting this property, if the attribute with the specified tag does not exists, an new one is added. Setting this property is equivalent with the following call:

myAttributeSet.add(tag)[index]

When getting this property, if the requested attribute does not exists, an MCattributeNotFoundException exception is thrown. If a value with the specified index does not exist null is returned.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The tag is not in the attribute set.
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of the attribute is OB, OW, OL, OD or OF.
Mergecom.Exceptions..::..MCillegalArgumentException | When setting this property, the type of the value specified is incompatible with the VR of the attribute.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | When setting this property, the value contains invalid characters for the VR of the attribute.
Mergecom.Exceptions..::..MCnoSuchValueException | When getting this attribute, index is not a valid value for the attribute.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Item Property (UInt32, Int32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (UInt32, Int32, Object)
MCattributeSet Class See Also Send Feedback
Gets attribute values of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    uint tag,
    int index,
    Object defaultValue
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    tag As UInteger, _
    index As Integer, _
    defaultValue As Object _
) As Object
    Get
Visual C++
public:
property Object^ default[unsigned int tag, int index, Object^ defaultValue] {
    Object^ get (unsigned int tag, int index, Object^ defaultValue);
}

Parameters

tag
Type: System..::..UInt32
The tag of the attribute.
index
Type: System..::..Int32
The zero based index of the value to get.
defaultValue
Type: System..::..Object
The value to return if the attribute is missing or if it does not have the requested value.

Field Value

An object representing the value requested.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed and contains no attributes
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of the attribute is OB, OW, OL, OD or OF.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Item Property (MCtag, Int32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Item Property (MCtag, Int32, Object)
MCattributeSet Class See Also Send Feedback
Gets attribute values of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object this[
    MCtag tag,
    int index,
    Object defaultValue
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    tag As MCtag, _
    index As Integer, _
    defaultValue As Object _
) As Object
    Get
Visual C++
public:
property Object^ default[MCtag^ tag, int index, Object^ defaultValue] {
    Object^ get (MCtag^ tag, int index, Object^ defaultValue);
}

Parameters

tag
Type: Mergecom..::..MCtag
The tag of the attribute.
index
Type: System..::..Int32
The zero based index of the value to get.
defaultValue
Type: System..::..Object
The value to return if the attribute is missing or if it does not have the requested value.

Field Value

An object representing the value requested.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed and contains no attributes
Mergecom.Exceptions..::..MCincompatibleValueException | The VR of the attribute is OB, OW, OL, OD or OF.

See Also

MCattributeSet Class
MCattributeSet Members
Item Overload


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..Modality Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Modality (0008,0060) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string Modality { get; set; }
Visual Basic
Public Property Modality As String
    Get
    Set
Visual C++
public:
property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Modality (0008,0060) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..PatientID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string PatientID { get; set; }
Visual Basic
Public Property PatientID As String
    Get
    Set
Visual C++
public:
property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Patient ID (0010,0020) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..PatientsName Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string PatientsName { get; set; }
Visual Basic
Public Property PatientsName As String
    Get
    Set
Visual C++
public:
property String^ PatientsName {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Patient's Name (0010,0010) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SeriesDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SeriesDescription Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SeriesDescription { get; set; }
Visual Basic
Public Property SeriesDescription As String
    Get
    Set
Visual C++
public:
property String^ SeriesDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Series Description (0008,103E) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SeriesInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SeriesInstanceUID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SeriesInstanceUID { get; set; }
Visual Basic
Public Property SeriesInstanceUID As String
    Get
    Set
Visual C++
public:
property String^ SeriesInstanceUID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Series Instance UID (0020,000E) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SeriesNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SeriesNumber Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SeriesNumber { get; set; }
Visual Basic
Public Property SeriesNumber As String
    Get
    Set
Visual C++
public:
property String^ SeriesNumber {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Series Number (0020,0011) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SOPClassUID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SOPClassUID { get; set; }
Visual Basic
Public Property SOPClassUID As String
    Get
    Set
Visual C++
public:
property String^ SOPClassUID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the SOP Class UID (0008,0016) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SOPInstanceUID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SOPInstanceUID { get; set; }
Visual Basic
Public Property SOPInstanceUID As String
    Get
    Set
Visual C++
public:
property String^ SOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the SOP Instance UID (0008,0018) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


SpecificCharacterSet Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..SpecificCharacterSet Property
MCattributeSet Class See Also Send Feedback
Gets or sets the values of the Specific Character Set (0008,0005) attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SpecificCharacterSet { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSet As String
    Get
    Set
Visual C++
public:
virtual property String^ SpecificCharacterSet {
    String^ get ();
    void set (String^ value);
}

Field Value

A string representation of the values of the Specific Character Set (0008,0005) attribute with each value separated by the backslash '\' character.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..StudyDate Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string StudyDate { get; set; }
Visual Basic
Public Property StudyDate As String
    Get
    Set
Visual C++
public:
property String^ StudyDate {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Study Date (0008,0020) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..StudyDescription Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string StudyDescription { get; set; }
Visual Basic
Public Property StudyDescription As String
    Get
    Set
Visual C++
public:
property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Study Description (0008,1030) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..StudyID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string StudyID { get; set; }
Visual Basic
Public Property StudyID As String
    Get
    Set
Visual C++
public:
property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Study ID (0020,0010) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..StudyInstanceUID Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string StudyInstanceUID { get; set; }
Visual Basic
Public Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Study Instance UID (0020,000D) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..StudyTime Property
MCattributeSet Class See Also Send Feedback
Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string StudyTime { get; set; }
Visual Basic
Public Property StudyTime As String
    Get
    Set
Visual C++
public:
property String^ StudyTime {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Study Time (0008,0030) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCattributeSet Class
MCattributeSet Members


TransferSyntax Property

[image]

Merge DICOM .NET/C# Toolkit
MCattributeSet..::..TransferSyntax Property
MCattributeSet Class See Also Send Feedback
Gets or sets the transfer syntax used to encode or decode this attribute set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax TransferSyntax { get; set; }
Visual Basic
Public Overridable Property TransferSyntax As MCtransferSyntax
    Get
    Set
Visual C++
public:
virtual property MCtransferSyntax^ TransferSyntax {
    MCtransferSyntax^ get ();
    void set (MCtransferSyntax^ value);
}

Field Value

An MCtransferSyntax object.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.

See Also

MCattributeSet Class
MCattributeSet Members


MCbasicCodedEntry Class

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Class
Members See Also Send Feedback
Common Attribute Set for Code Sequence Attributes (Invoked as "Code Sequence Macro")

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbasicCodedEntry : MCdataSetSerializable
Visual Basic
Public Class MCbasicCodedEntry _
    Implements MCdataSetSerializable
Visual C++
public ref class MCbasicCodedEntry : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCbasicCodedEntry

See Also

MCbasicCodedEntry Members


MCbasicCodedEntry Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Members
MCbasicCodedEntry Class Constructors Methods Properties See Also Send Feedback

The MCbasicCodedEntry type exposes the following members.

Constructors

 | Name | Description
Public method | MCbasicCodedEntry()()()() | Default constructor
Public method | MCbasicCodedEntry(String, String, String) | Creates Code Sequence Attributes

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

Properties

 | Name | Description
Public property | CodeMeaning | The Code Meaning (0008,0104) is text which has meaning to a human and which conveys the meaning of the term defined by the combination of Code Value and Coding Scheme Designator. Though such a meaning can be "looked up" in the dictionary for the coding scheme, it is encoded for the convenience of applications that do not have access to such a dictionary.
Public property | CodeValue | The Code Value (0008,0100) is an identifier that is unambiguous within the Coding Scheme denoted by Coding Scheme Designator (0008,0102) and Coding Scheme Version (0008,0103). Note: The Code Value is typically not a natural language string, e.g. "T-04000".
Public property | CodingSchemeDesignator | The attribute Coding Scheme Designator (0008,0102) identifies the coding scheme in which the code for a term is defined. Standard coding scheme designators used in DICOM information interchange are listed in PS 3.16. Other coding scheme designators, for both private and public coding schemes, may be used.
Public property | CodingSchemeVersion | The attribute Coding Scheme Version (0008,0103) may be used to identify the version of a coding scheme if necessary to resolve ambiguity in the Code Value (0008,0100) or Code Meaning (0008,0104). Coding Scheme Version (0008,0103) is not required for backward-compatible revisions of a coding scheme, as the Coding Scheme Designator (0008,0102) identifies the coding scheme as a whole as currently published by the responsible organization.

See Also

MCbasicCodedEntry Class


MCbasicCodedEntry Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Constructor
MCbasicCodedEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCbasicCodedEntry()()()() | Default constructor
Public method | MCbasicCodedEntry(String, String, String) | Creates Code Sequence Attributes

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


MCbasicCodedEntry Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Constructor
MCbasicCodedEntry Class See Also Send Feedback
Default constructor

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry()
Visual Basic
Public Sub New
Visual C++
public:
MCbasicCodedEntry()

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members
MCbasicCodedEntry Overload


MCbasicCodedEntry Constructor (String, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Constructor (String, String, String)
MCbasicCodedEntry Class See Also Send Feedback
Creates Code Sequence Attributes

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry(
    string codeValue,
    string codingSchemeDesignator,
    string codeMeaning
)
Visual Basic
Public Sub New ( _
    codeValue As String, _
    codingSchemeDesignator As String, _
    codeMeaning As String _
)
Visual C++
public:
MCbasicCodedEntry(
    String^ codeValue,
    String^ codingSchemeDesignator,
    String^ codeMeaning
)

Parameters

codeValue
Type: System..::..String
Code Value (0008,0100)
codingSchemeDesignator
Type: System..::..String
Coding Scheme Designator (0008,0102)
codeMeaning
Type: System..::..String
Code Meaning (0008,0104)

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members
MCbasicCodedEntry Overload


MCbasicCodedEntry Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Methods
MCbasicCodedEntry Class See Also Send Feedback

The MCbasicCodedEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

See Also

MCbasicCodedEntry Class


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..Read Method
MCbasicCodedEntry Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Read(
    MCattributeSet source
)
Visual Basic
Public Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) sealed

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..Write Method
MCbasicCodedEntry Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Write(
    MCattributeSet destination
)
Visual Basic
Public Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) sealed

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


MCbasicCodedEntry Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry Properties
MCbasicCodedEntry Class See Also Send Feedback

The MCbasicCodedEntry type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | The Code Meaning (0008,0104) is text which has meaning to a human and which conveys the meaning of the term defined by the combination of Code Value and Coding Scheme Designator. Though such a meaning can be "looked up" in the dictionary for the coding scheme, it is encoded for the convenience of applications that do not have access to such a dictionary.
Public property | CodeValue | The Code Value (0008,0100) is an identifier that is unambiguous within the Coding Scheme denoted by Coding Scheme Designator (0008,0102) and Coding Scheme Version (0008,0103). Note: The Code Value is typically not a natural language string, e.g. "T-04000".
Public property | CodingSchemeDesignator | The attribute Coding Scheme Designator (0008,0102) identifies the coding scheme in which the code for a term is defined. Standard coding scheme designators used in DICOM information interchange are listed in PS 3.16. Other coding scheme designators, for both private and public coding schemes, may be used.
Public property | CodingSchemeVersion | The attribute Coding Scheme Version (0008,0103) may be used to identify the version of a coding scheme if necessary to resolve ambiguity in the Code Value (0008,0100) or Code Meaning (0008,0104). Coding Scheme Version (0008,0103) is not required for backward-compatible revisions of a coding scheme, as the Coding Scheme Designator (0008,0102) identifies the coding scheme as a whole as currently published by the responsible organization.

See Also

MCbasicCodedEntry Class


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..CodeMeaning Property
MCbasicCodedEntry Class See Also Send Feedback
The Code Meaning (0008,0104) is text which has meaning to a human and which conveys the meaning of the term defined by the combination of Code Value and Coding Scheme Designator. Though such a meaning can be "looked up" in the dictionary for the coding scheme, it is encoded for the convenience of applications that do not have access to such a dictionary.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string CodeMeaning { get; set; }
Visual Basic
Public Property CodeMeaning As String
    Get
    Set
Visual C++
public:
property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..CodeValue Property
MCbasicCodedEntry Class See Also Send Feedback
The Code Value (0008,0100) is an identifier that is unambiguous within the Coding Scheme denoted by Coding Scheme Designator (0008,0102) and Coding Scheme Version (0008,0103). Note: The Code Value is typically not a natural language string, e.g. "T-04000".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string CodeValue { get; set; }
Visual Basic
Public Property CodeValue As String
    Get
    Set
Visual C++
public:
property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..CodingSchemeDesignator Property
MCbasicCodedEntry Class See Also Send Feedback
The attribute Coding Scheme Designator (0008,0102) identifies the coding scheme in which the code for a term is defined. Standard coding scheme designators used in DICOM information interchange are listed in PS 3.16. Other coding scheme designators, for both private and public coding schemes, may be used.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string CodingSchemeDesignator { get; set; }
Visual Basic
Public Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbasicCodedEntry..::..CodingSchemeVersion Property
MCbasicCodedEntry Class See Also Send Feedback
The attribute Coding Scheme Version (0008,0103) may be used to identify the version of a coding scheme if necessary to resolve ambiguity in the Code Value (0008,0100) or Code Meaning (0008,0104). Coding Scheme Version (0008,0103) is not required for backward-compatible revisions of a coding scheme, as the Coding Scheme Designator (0008,0102) identifies the coding scheme as a whole as currently published by the responsible organization.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string CodingSchemeVersion { get; set; }
Visual Basic
Public Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

See Also

MCbasicCodedEntry Class
MCbasicCodedEntry Members


MCbasicWorklistManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Class
Members See Also Send Feedback
Represents a DICOM Basic Worklist Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbasicWorklistManagementService : MCdimseService
Visual Basic
Public Class MCbasicWorklistManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCbasicWorklistManagementService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:
  • Modality Worklist Information Model - FIND
  • General Purpose Worklist Information Model - FIND

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCbasicWorklistManagementService

See Also

MCbasicWorklistManagementService Members


MCbasicWorklistManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Members
MCbasicWorklistManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCbasicWorklistManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCbasicWorklistManagementService | Initializes a new instance of this class for the specified association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelRequest | Sends a C-CANCEL DIMSE message to the network peer.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner.
Public method | sendFindRequest(MCdataSet, String) | Sends a normal C-FIND request, providing the message to send and the affected SOP Class UID to use.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a normal C-FIND request, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a normal C-FIND request, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of MCdimseService.C_FIND_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCbasicWorklistManagementService Class


MCbasicWorklistManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Constructor
MCbasicWorklistManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicWorklistManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCbasicWorklistManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members


MCbasicWorklistManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Fields
MCbasicWorklistManagementService Class See Also Send Feedback

The MCbasicWorklistManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCbasicWorklistManagementService Class


MCbasicWorklistManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Methods
MCbasicWorklistManagementService Class See Also Send Feedback

The MCbasicWorklistManagementService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelRequest | Sends a C-CANCEL DIMSE message to the network peer.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner.
Public method | sendFindRequest(MCdataSet, String) | Sends a normal C-FIND request, providing the message to send and the affected SOP Class UID to use.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a normal C-FIND request, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a normal C-FIND request, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of MCdimseService.C_FIND_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbasicWorklistManagementService Class


sendCancelRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendCancelRequest Method
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a C-CANCEL DIMSE message to the network peer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCancelRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Function sendCancelRequest ( _
    requestMsg As MCdimseMessage _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCancelRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message used to send the original find request.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

This method is used to cancel a pending C-FIND operation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members


sendFindRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendFindRequest Method
MCbasicWorklistManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner.
Public method | sendFindRequest(MCdataSet, String) | Sends a normal C-FIND request, providing the message to send and the affected SOP Class UID to use.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a normal C-FIND request, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a normal C-FIND request, providing the identifier to send, the affected SOP Class UID and message priority.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members


sendFindRequest Method (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendFindRequest Method (MCdataSet)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

When using this form of the method, the message priority will be medium, and the affected SOP Class UID will be taken from the message's presentation context.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier was invalid.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendFindRequest Method (MCdataSet, String)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a normal C-FIND request, providing the message to send and the affected SOP Class UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    string affectedSopClassUID
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The message priority defaults to medium priority.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier was invalid.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendFindRequest Method (MCdataSet, UInt16)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a normal C-FIND request, providing the identifier to send and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    ushort priority
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The message priority is provided by the priority parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier was invalid.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendFindRequest Method (MCdataSet, String, UInt16)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a normal C-FIND request, providing the identifier to send, the affected SOP Class UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    string affectedSopClassUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association if the affectedClassUID parameter is null or an empty string.

The message priority is provided by the priority parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier was invalid.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendFindRequest Overload


sendProcessingFailureResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendProcessingFailureResponse Method
MCbasicWorklistManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String) | Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members


sendProcessingFailureResponse Method (MCdimseMessage, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendProcessingFailureResponse Method (MCdimseMessage, array<UInt32>[]()[][], String)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Elements involved with the error.
errorComment
Type: System..::..String
The error description.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The message or the command associated with the message was invalid.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendProcessingFailureResponse Overload


sendProcessingFailureResponse Method (MCdimseMessage, UInt16, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendProcessingFailureResponse Method (MCdimseMessage, UInt16, array<UInt32>[]()[][], String)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a Response message with a status of MCdimseService.C_FIND_FAILURE_UNABLE_TO_PROCESS.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    ushort errorId,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    errorId As UShort, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    unsigned short errorId,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
errorId
Type: System..::..UInt16
Error identification number.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Elements involved with the error.
errorComment
Type: System..::..String
The error description.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid, the error Id was less than one or the message was null.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendProcessingFailureResponse Overload


sendSuccessResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendSuccessResponse Method
MCbasicWorklistManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of MCdimseService.C_FIND_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members


sendSuccessResponse Method (MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService..::..sendSuccessResponse Method (MCdimseMessage)
MCbasicWorklistManagementService Class See Also Send Feedback
Sends a Response message with a status of MCdimseService.C_FIND_SUCCESS.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendSuccessResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCbasicWorklistManagementService Class
MCbasicWorklistManagementService Members
sendSuccessResponse Overload


MCbasicWorklistManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbasicWorklistManagementService Properties
MCbasicWorklistManagementService Class See Also Send Feedback

The MCbasicWorklistManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCbasicWorklistManagementService Class


MCbulkDataUriHandler Interface

[image]

Merge DICOM .NET/C# Toolkit
MCbulkDataUriHandler Interface
Members See Also Send Feedback
An interface to handle BulkDataURI attribute when dealing with Native DICOM Model XML or DICOM JSON Model.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCbulkDataUriHandler
Visual Basic
Public Interface MCbulkDataUriHandler
Visual C++
public interface class MCbulkDataUriHandler

See Also

MCbulkDataUriHandler Members


MCbulkDataUriHandler Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbulkDataUriHandler Members
MCbulkDataUriHandler Interface Methods See Also Send Feedback

The MCbulkDataUriHandler type exposes the following members.

Methods

Name Description
Public method provideData
Receive a BulkDataURI from parsing XML native or JSON. Implementation should provide data by returning an array of data according to the VR type (by retrieving the data from the URI location) to the toolkit for creating a proper attribute with value. If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

Remarks

For JSON stream with multiple data sets ( MCdataSet.readDataSetsFromJSON(System.IO.TextReader, MCbulkDataUriHandler)), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.
Public method provideUri
Send a BulkDataURI instead of actual bulk data. Implementation should return a URI location if it desires to send URI instead of the bulk data. If the return value is null or empty string, the toolkit will send the original data. This method will be called when generating XML native or JSON stream for one of the following vr: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Remarks

For JSON stream with multiple data sets ( MCdataSet.writeDataSetsToJSON), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.

See Also

MCbulkDataUriHandler Interface


MCbulkDataUriHandler Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbulkDataUriHandler Methods
MCbulkDataUriHandler Interface See Also Send Feedback

The MCbulkDataUriHandler type exposes the following members.

Methods

Name Description
Public method provideData
Receive a BulkDataURI from parsing XML native or JSON. Implementation should provide data by returning an array of data according to the VR type (by retrieving the data from the URI location) to the toolkit for creating a proper attribute with value. If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

Remarks

For JSON stream with multiple data sets ( MCdataSet.readDataSetsFromJSON(System.IO.TextReader, MCbulkDataUriHandler)), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.
Public method provideUri
Send a BulkDataURI instead of actual bulk data. Implementation should return a URI location if it desires to send URI instead of the bulk data. If the return value is null or empty string, the toolkit will send the original data. This method will be called when generating XML native or JSON stream for one of the following vr: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Remarks

For JSON stream with multiple data sets ( MCdataSet.writeDataSetsToJSON), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.

See Also

MCbulkDataUriHandler Interface


provideData Method

[image]

Merge DICOM .NET/C# Toolkit
MCbulkDataUriHandler..::..provideData Method
MCbulkDataUriHandler Interface See Also Send Feedback
Receive a BulkDataURI from parsing XML native or JSON. Implementation should provide data by returning an array of data according to the VR type (by retrieving the data from the URI location) to the toolkit for creating a proper attribute with value. If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

Remarks

For JSON stream with multiple data sets ( MCdataSet.readDataSetsFromJSON(System.IO.TextReader, MCbulkDataUriHandler)), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
Object provideData(
    MCattributeSet attrSet,
    uint tag,
    MCvr vr,
    string uri
)
Visual Basic
Function provideData ( _
    attrSet As MCattributeSet, _
    tag As UInteger, _
    vr As MCvr, _
    uri As String _
) As Object
Visual C++
Object^ provideData(
    MCattributeSet^ attrSet,
    unsigned int tag,
    MCvr^ vr,
    String^ uri
)

Parameters

attrSet
Type: Mergecom..::..MCattributeSet
Only valid for MCdataSet.readDataSetsFromJSON(System.IO.TextReader, MCbulkDataUriHandler) method, identifies the current data set in process
tag
Type: System..::..UInt32
The attribute tag
vr
Type: Mergecom..::..MCvr
The value representation
uri
Type: System..::..String
The received uri

Return Value

Array of data according to VR type

See Also

MCbulkDataUriHandler Interface
MCbulkDataUriHandler Members


provideUri Method

[image]

Merge DICOM .NET/C# Toolkit
MCbulkDataUriHandler..::..provideUri Method
MCbulkDataUriHandler Interface See Also Send Feedback
Send a BulkDataURI instead of actual bulk data. Implementation should return a URI location if it desires to send URI instead of the bulk data. If the return value is null or empty string, the toolkit will send the original data. This method will be called when generating XML native or JSON stream for one of the following vr: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

Remarks

For JSON stream with multiple data sets ( MCdataSet.writeDataSetsToJSON), the parameter attrSet is used to identify the current data set in process. For any other API, the attrSet value is a temporary variable supplied only for consistency of the interface, user shouldn't use the attrSet value in this case.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
string provideUri(
    MCattributeSet attrSet,
    uint tag,
    MCvr vr
)
Visual Basic
Function provideUri ( _
    attrSet As MCattributeSet, _
    tag As UInteger, _
    vr As MCvr _
) As String
Visual C++
String^ provideUri(
    MCattributeSet^ attrSet,
    unsigned int tag,
    MCvr^ vr
)

Parameters

attrSet
Type: Mergecom..::..MCattributeSet
Only valid for MCdataSet.writeDataSetsToJSON method, identifies the current data set in process
tag
Type: System..::..UInt32
The attribute tag
vr
Type: Mergecom..::..MCvr
The value repreentation

Return Value

uri string to be send in XML or JSON object

See Also

MCbulkDataUriHandler Interface
MCbulkDataUriHandler Members


MCcommandSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCcommandSet Class
Members See Also Send Feedback
Represents a DICOM DIMSE Command Set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcommandSet : MCattributeSet
Visual Basic
Public Class MCcommandSet _
    Inherits MCattributeSet
Visual C++
public ref class MCcommandSet : public MCattributeSet

Remarks

A DICOM Command Set contains attributes with tag numbers (0000,0000) through (0007,FFFF).

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom..::..MCcommandSet

See Also

MCcommandSet Members


MCcommandSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcommandSet Members
MCcommandSet Class Methods Properties See Also Send Feedback

The MCcommandSet type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCcommandSet Class


MCcommandSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcommandSet Methods
MCcommandSet Class See Also Send Feedback

The MCcommandSet type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

See Also

MCcommandSet Class


MCcommandSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcommandSet Properties
MCcommandSet Class See Also Send Feedback

The MCcommandSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCcommandSet Class


MCcompression Interface

[image]

Merge DICOM .NET/C# Toolkit
MCcompression Interface
Members See Also Send Feedback
This interface is used to represent a compression or decompression class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCcompression
Visual Basic
Public Interface MCcompression
Visual C++
public interface class MCcompression

Remarks

An implementation of this interface is given data to compress or decompress. The implementation then may choose to return data, or if required wait for a subsequent call to return data.

See Also

MCcompression Members


MCcompression Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompression Members
MCcompression Interface Methods See Also Send Feedback

The MCcompression type exposes the following members.

Methods

 | Name | Description
Public method | createContext | This method is the first method called when Merge DICOM .NET toolkit starts compressing data. It allows the implementing class to create a context object which can be used during compression and decompression to hold the state of the compression.
Public method | processData | Data is passed to this method to be processed. When applicable, data is returned.
Public method | releaseContext | This method is called to release the context that was allocated by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax).

See Also

MCcompression Interface


MCcompression Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompression Methods
MCcompression Interface See Also Send Feedback

The MCcompression type exposes the following members.

Methods

 | Name | Description
Public method | createContext | This method is the first method called when Merge DICOM .NET toolkit starts compressing data. It allows the implementing class to create a context object which can be used during compression and decompression to hold the state of the compression.
Public method | processData | Data is passed to this method to be processed. When applicable, data is returned.
Public method | releaseContext | This method is called to release the context that was allocated by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax).

See Also

MCcompression Interface


createContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCcompression..::..createContext Method
MCcompression Interface See Also Send Feedback
This method is the first method called when Merge DICOM .NET toolkit starts compressing data. It allows the implementing class to create a context object which can be used during compression and decompression to hold the state of the compression.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
Object createContext(
    MCattributeSet ats,
    MCtransferSyntax source,
    MCtransferSyntax destination
)
Visual Basic
Function createContext ( _
    ats As MCattributeSet, _
    source As MCtransferSyntax, _
    destination As MCtransferSyntax _
) As Object
Visual C++
Object^ createContext(
    MCattributeSet^ ats,
    MCtransferSyntax^ source,
    MCtransferSyntax^ destination
)

Parameters

ats
Type: Mergecom..::..MCattributeSet
The attribute set being compressed or decompressed.
source
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the source data.
destination
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the destination data.

Return Value

The application defined context object.

Remarks

The releaseContext(Object) method is called to release the context and potentially native resources associated with the compression.

See Also

MCcompression Interface
MCcompression Members


processData Method

[image]

Merge DICOM .NET/C# Toolkit
MCcompression..::..processData Method
MCcompression Interface See Also Send Feedback
Data is passed to this method to be processed. When applicable, data is returned.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
MCdata processData(
    Object context,
    MCdata inputData,
    bool isFirst
)
Visual Basic
Function processData ( _
    context As Object, _
    inputData As MCdata, _
    isFirst As Boolean _
) As MCdata
Visual C++
MCdata^ processData(
    Object^ context,
    MCdata^ inputData,
    bool isFirst
)

Parameters

context
Type: System..::..Object
The context returned by the createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.
inputData
Type: Mergecom..::..MCdata
Input data to work on.
isFirst
Type: System..::..Boolean
This parameter is set to true on the first call.

Return Value

Data that has been compressed or decompressed. If not enough data has been passed to the instance to generate output data, the method may return null.

Remarks

When decompressing, the IsLast property may be set if an offset table was created with the compressed data. If not, the decompression must determine when the end of data has been reached.

The routine also should set IsLast as appropriate if it has completed decompressing its data. Note also that DICOM .NET Toolkit will be looking at the amount of data returned from the function to determine if an entire frame of decompressed data has been returned.

See Also

MCcompression Interface
MCcompression Members


releaseContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCcompression..::..releaseContext Method
MCcompression Interface See Also Send Feedback
This method is called to release the context that was allocated by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void releaseContext(
    Object context
)
Visual Basic
Sub releaseContext ( _
    context As Object _
)
Visual C++
void releaseContext(
    Object^ context
)

Parameters

context
Type: System..::..Object
The context object to release.

See Also

MCcompression Interface
MCcompression Members


MCconfig Class

[image]

Merge DICOM .NET/C# Toolkit
MCconfig Class
Members See Also Send Feedback
Contains methods to set and retrieve various Merge DICOM toolkit configuration parameters.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCconfig
Visual Basic
Public Class MCconfig
Visual C++
public ref class MCconfig

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCconfig

See Also

MCconfig Members


MCconfig Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfig Members
MCconfig Class Methods See Also Send Feedback

The MCconfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getBooleanConfigValue | Retrieves the value of a boolean configuration parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getIntConfigValue | Retrieves the value of an integer configuration parameter.
 | getShortConfigValue | Retrieves the value of a short configuration parameter.
 | getStringConfigValue | Retrieves the value of a string configuration parameter.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | setConfigValue(String, Boolean) | Sets a new value for a specified configuration parameter. Only boolean type configuration values may be set with this method.
 | setConfigValue(String, Int16) | Sets a new value for a specified configuration parameter. Only short type configuration values may be set with a short value.
 | setConfigValue(String, Int32) | Sets a new value for a specified configuration parameter. Only integer type configuration values may be set with this method.
 | setConfigValue(String, String) | Sets a new value for a specified configuration parameter. Only string type configuration values may be set with this method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCconfig Class


MCconfig Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfig Methods
MCconfig Class See Also Send Feedback

The MCconfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getBooleanConfigValue | Retrieves the value of a boolean configuration parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getIntConfigValue | Retrieves the value of an integer configuration parameter.
 | getShortConfigValue | Retrieves the value of a short configuration parameter.
 | getStringConfigValue | Retrieves the value of a string configuration parameter.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | setConfigValue(String, Boolean) | Sets a new value for a specified configuration parameter. Only boolean type configuration values may be set with this method.
 | setConfigValue(String, Int16) | Sets a new value for a specified configuration parameter. Only short type configuration values may be set with a short value.
 | setConfigValue(String, Int32) | Sets a new value for a specified configuration parameter. Only integer type configuration values may be set with this method.
 | setConfigValue(String, String) | Sets a new value for a specified configuration parameter. Only string type configuration values may be set with this method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCconfig Class


getBooleanConfigValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..getBooleanConfigValue Method
MCconfig Class See Also Send Feedback
Retrieves the value of a boolean configuration parameter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool getBooleanConfigValue(
    string parm
)
Visual Basic
Public Shared Function getBooleanConfigValue ( _
    parm As String _
) As Boolean
Visual C++
public:
static bool getBooleanConfigValue(
    String^ parm
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to retrieve.

Return Value

The value of the parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The configuration name was invalid.

See Also

MCconfig Class
MCconfig Members


getIntConfigValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..getIntConfigValue Method
MCconfig Class See Also Send Feedback
Retrieves the value of an integer configuration parameter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int getIntConfigValue(
    string parm
)
Visual Basic
Public Shared Function getIntConfigValue ( _
    parm As String _
) As Integer
Visual C++
public:
static int getIntConfigValue(
    String^ parm
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to retrieve.

Return Value

The value of the parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The configuration name was invalid.

See Also

MCconfig Class
MCconfig Members


getShortConfigValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..getShortConfigValue Method
MCconfig Class See Also Send Feedback
Retrieves the value of a short configuration parameter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static short getShortConfigValue(
    string parm
)
Visual Basic
Public Shared Function getShortConfigValue ( _
    parm As String _
) As Short
Visual C++
public:
static short getShortConfigValue(
    String^ parm
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to retrieve.

Return Value

The value of the parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The configuration name was invalid.

See Also

MCconfig Class
MCconfig Members


getStringConfigValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..getStringConfigValue Method
MCconfig Class See Also Send Feedback
Retrieves the value of a string configuration parameter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static string getStringConfigValue(
    string parm
)
Visual Basic
Public Shared Function getStringConfigValue ( _
    parm As String _
) As String
Visual C++
public:
static String^ getStringConfigValue(
    String^ parm
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to retrieve.

Return Value

The value of the parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The configuration name was invalid.

See Also

MCconfig Class
MCconfig Members


setConfigValue Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..setConfigValue Method
MCconfig Class See Also Send Feedback

Overload List

Name | Description
setConfigValue(String, Boolean) | Sets a new value for a specified configuration parameter. Only boolean type configuration values may be set with this method.
setConfigValue(String, Int16) | Sets a new value for a specified configuration parameter. Only short type configuration values may be set with a short value.
setConfigValue(String, Int32) | Sets a new value for a specified configuration parameter. Only integer type configuration values may be set with this method.
setConfigValue(String, String) | Sets a new value for a specified configuration parameter. Only string type configuration values may be set with this method.

See Also

MCconfig Class
MCconfig Members


setConfigValue Method (String, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..setConfigValue Method (String, Boolean)
MCconfig Class See Also Send Feedback
Sets a new value for a specified configuration parameter. Only boolean type configuration values may be set with this method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setConfigValue(
    string parm,
    bool boolValue
)
Visual Basic
Public Shared Sub setConfigValue ( _
    parm As String, _
    boolValue As Boolean _
)
Visual C++
public:
static void setConfigValue(
    String^ parm,
    bool boolValue
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to set.
boolValue
Type: System..::..Boolean
The new value to set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid parameter or or invalid value was set.

See Also

MCconfig Class
MCconfig Members
setConfigValue Overload


setConfigValue Method (String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..setConfigValue Method (String, Int16)
MCconfig Class See Also Send Feedback
Sets a new value for a specified configuration parameter. Only short type configuration values may be set with a short value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setConfigValue(
    string parm,
    short shortValue
)
Visual Basic
Public Shared Sub setConfigValue ( _
    parm As String, _
    shortValue As Short _
)
Visual C++
public:
static void setConfigValue(
    String^ parm,
    short shortValue
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to set.
shortValue
Type: System..::..Int16
The new value to set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid parameter or or invalid value was set.

See Also

MCconfig Class
MCconfig Members
setConfigValue Overload


setConfigValue Method (String, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..setConfigValue Method (String, Int32)
MCconfig Class See Also Send Feedback
Sets a new value for a specified configuration parameter. Only integer type configuration values may be set with this method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setConfigValue(
    string parm,
    int intValue
)
Visual Basic
Public Shared Sub setConfigValue ( _
    parm As String, _
    intValue As Integer _
)
Visual C++
public:
static void setConfigValue(
    String^ parm,
    int intValue
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to set.
intValue
Type: System..::..Int32
The new value to set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid parameter or or invalid value was set.

See Also

MCconfig Class
MCconfig Members
setConfigValue Overload


setConfigValue Method (String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCconfig..::..setConfigValue Method (String, String)
MCconfig Class See Also Send Feedback
Sets a new value for a specified configuration parameter. Only string type configuration values may be set with this method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setConfigValue(
    string parm,
    string stringValue
)
Visual Basic
Public Shared Sub setConfigValue ( _
    parm As String, _
    stringValue As String _
)
Visual C++
public:
static void setConfigValue(
    String^ parm,
    String^ stringValue
)

Parameters

parm
Type: System..::..String
The name of the configuration parameter to set.
stringValue
Type: System..::..String
The new value to set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid parameter or or invalid value was set.

See Also

MCconfig Class
MCconfig Members
setConfigValue Overload


MCdata Class

[image]

Merge DICOM .NET/C# Toolkit
MCdata Class
Members See Also Send Feedback
Represents bulk data being transferred between program entities.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdata : IDisposable
Visual Basic
Public Class MCdata _
    Implements IDisposable
Visual C++
public ref class MCdata : IDisposable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdata

See Also

MCdata Members


MCdata Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdata Members
MCdata Class Constructors Methods Properties See Also Send Feedback

The MCdata type exposes the following members.

Constructors

 | Name | Description
Public method | MCdata(array<Byte>[]()[][], UInt32) | Creates a new MCdata object backed by a managed byte array.
Public method | MCdata(IntPtr, UInt32, Boolean) | Creates a new MCdata object backed by an unmanaged memory buffer.

Methods

 | Name | Description
Public method | clone | Creates a deep copy of the current instance.
Public method | dispose | This method is same with Dispose(). It was provided before the IDisposable interface was implemented. Now it is kept for backward compatibility. Please use Dispose()
Public method | Dispose | Implement IDisposable. Disposes the buffer handled by this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | The destructor for the MCdata class. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Capacity | Represents the capacity of the buffer being managed by this object.
Public property | IsLast | Tells whether this buffer is the last buffer in a series of data passed to or read from the library.
Public property | IsPersistent | Tells whether this buffer is the persistent memory buffer in a series of data passed.
Public property | IsUnmanaged | Tells whether the buffer managed by this instance is an unmanaged buffer.
Public property | Length | Represents the size of the actual data in use within the buffer managed by this object.
Public property | ManagedBuffer | Represents the managed buffer of this instance.
Public property | UnmanagedBuffer | The pointer to the unmanaged memory buffer.

See Also

MCdata Class


MCdata Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdata Constructor
MCdata Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdata(array<Byte>[]()[][], UInt32) | Creates a new MCdata object backed by a managed byte array.
Public method | MCdata(IntPtr, UInt32, Boolean) | Creates a new MCdata object backed by an unmanaged memory buffer.

See Also

MCdata Class
MCdata Members


MCdata Constructor (Byte[], UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCdata Constructor (array<Byte>[]()[][], UInt32)
MCdata Class See Also Send Feedback
Creates a new MCdata object backed by a managed byte array.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata(
    byte[] data,
    uint length
)
Visual Basic
Public Sub New ( _
    data As Byte(), _
    length As UInteger _
)
Visual C++
public:
MCdata(
    array<unsigned char>^ data,
    unsigned int length
)

Parameters

data
Type: array<System..::..Byte>[]()[][]
The managed array holding the data
length
Type: System..::..UInt32
The length of data stored in data.

Remarks

This constructor creates an MCdata object containing a managed array. Note that the length parameter can be used if the entire array is not filled with data.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The data buffer was null.

See Also

MCdata Class
MCdata Members
MCdata Overload


MCdata Constructor (IntPtr, UInt32, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCdata Constructor (IntPtr, UInt32, Boolean)
MCdata Class See Also Send Feedback
Creates a new MCdata object backed by an unmanaged memory buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata(
    IntPtr unmanagedBuffer,
    uint length,
    bool takeOwnership
)
Visual Basic
Public Sub New ( _
    unmanagedBuffer As IntPtr, _
    length As UInteger, _
    takeOwnership As Boolean _
)
Visual C++
public:
MCdata(
    IntPtr unmanagedBuffer,
    unsigned int length,
    bool takeOwnership
)

Parameters

unmanagedBuffer
Type: System..::..IntPtr
Pointer to the unmanaged memory buffer. If the pointer value is null the constructor allocates a new unmanaged buffer.
length
Type: System..::..UInt32
The length in bytes of the buffer.
takeOwnership
Type: System..::..Boolean
Flag indicating whether the MCdata object should take ownership of the unmanaged buffer. If true, MCdata releases the unmanaged buffer when dispose()()()() is called or when it is garbage collected.

See Also

MCdata Class
MCdata Members
MCdata Overload


MCdata Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdata Methods
MCdata Class See Also Send Feedback

The MCdata type exposes the following members.

Methods

 | Name | Description
Public method | clone | Creates a deep copy of the current instance.
Public method | dispose | This method is same with Dispose(). It was provided before the IDisposable interface was implemented. Now it is kept for backward compatibility. Please use Dispose()
Public method | Dispose | Implement IDisposable. Disposes the buffer handled by this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | The destructor for the MCdata class. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this instance. (Overrides Object..::..ToString()()()().)

See Also

MCdata Class


clone Method

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..clone Method
MCdata Class See Also Send Feedback
Creates a deep copy of the current instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata clone()
Visual Basic
Public Function clone As MCdata
Visual C++
public:
MCdata^ clone()

Return Value

A new MCdata instance containing the copy of the data.

Remarks

The data stays managed or unmanaged depending on the source format of the data.

If this instance contains an unmanaged buffer, the returned instance will be the owner of its copy of the buffer.

See Also

MCdata Class
MCdata Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..dispose Method
MCdata Class See Also Send Feedback
This method is same with Dispose(). It was provided before the IDisposable interface was implemented. Now it is kept for backward compatibility. Please use Dispose()

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCdata Class
MCdata Members


Dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..Dispose Method
MCdata Class See Also Send Feedback
Implement IDisposable. Disposes the buffer handled by this object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MCdata Class
MCdata Members


Finalize Method

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..Finalize Method
MCdata Class See Also Send Feedback
The destructor for the MCdata class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

MCdata Class
MCdata Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..ToString Method
MCdata Class See Also Send Feedback
Returns a string representation of this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string describing the capacity and length of the buffer being managed by this object.

See Also

MCdata Class
MCdata Members


MCdata Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdata Properties
MCdata Class See Also Send Feedback

The MCdata type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Represents the capacity of the buffer being managed by this object.
Public property | IsLast | Tells whether this buffer is the last buffer in a series of data passed to or read from the library.
Public property | IsPersistent | Tells whether this buffer is the persistent memory buffer in a series of data passed.
Public property | IsUnmanaged | Tells whether the buffer managed by this instance is an unmanaged buffer.
Public property | Length | Represents the size of the actual data in use within the buffer managed by this object.
Public property | ManagedBuffer | Represents the managed buffer of this instance.
Public property | UnmanagedBuffer | The pointer to the unmanaged memory buffer.

See Also

MCdata Class


Capacity Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..Capacity Property
MCdata Class See Also Send Feedback
Represents the capacity of the buffer being managed by this object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint Capacity { get; }
Visual Basic
Public Overridable ReadOnly Property Capacity As UInteger
    Get
Visual C++
public:
virtual property unsigned int Capacity {
    unsigned int get ();
}

Field Value

The maximum number of bytes this object can hold.

See Also

MCdata Class
MCdata Members


IsLast Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..IsLast Property
MCdata Class See Also Send Feedback
Tells whether this buffer is the last buffer in a series of data passed to or read from the library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsLast { get; set; }
Visual Basic
Public Overridable Property IsLast As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsLast {
    bool get ();
    void set (bool value);
}

Field Value

true if this is the last piece of a transfer; otherwise false.

See Also

MCdata Class
MCdata Members


IsPersistent Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..IsPersistent Property
MCdata Class See Also Send Feedback
Tells whether this buffer is the persistent memory buffer in a series of data passed.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsPersistent { get; set; }
Visual Basic
Public Overridable Property IsPersistent As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsPersistent {
    bool get ();
    void set (bool value);
}

Field Value

true if this is the persistent memory buffer; otherwise false.

See Also

MCdata Class
MCdata Members


IsUnmanaged Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..IsUnmanaged Property
MCdata Class See Also Send Feedback
Tells whether the buffer managed by this instance is an unmanaged buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsUnmanaged { get; }
Visual Basic
Public Overridable ReadOnly Property IsUnmanaged As Boolean
    Get
Visual C++
public:
virtual property bool IsUnmanaged {
    bool get ();
}

Field Value

true if the backing store for this object is an unmanaged memory buffer; otherwise false.

See Also

MCdata Class
MCdata Members


Length Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..Length Property
MCdata Class See Also Send Feedback
Represents the size of the actual data in use within the buffer managed by this object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint Length { get; set; }
Visual Basic
Public Overridable Property Length As UInteger
    Get
    Set
Visual C++
public:
virtual property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Field Value

The number of actual bytes in the buffer.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The value exceeds the capacity of the buffer, when setting the property

See Also

MCdata Class
MCdata Members


ManagedBuffer Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..ManagedBuffer Property
MCdata Class See Also Send Feedback
Represents the managed buffer of this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte[] ManagedBuffer { get; }
Visual Basic
Public Overridable ReadOnly Property ManagedBuffer As Byte()
    Get
Visual C++
public:
virtual property array<unsigned char>^ ManagedBuffer {
    array<unsigned char>^ get ();
}

Field Value

A byte array containing the data represented by this instance.

Remarks

If this instance is based on a managed byte array the reference to that array is returned.

If the buffer in this instance is unmanaged, a new byte array is created for every call. This means that modifying the elements of the returned array will not affect the data in this instance.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCruntimeException | The data has been disposed.

See Also

MCdata Class
MCdata Members


UnmanagedBuffer Property

[image]

Merge DICOM .NET/C# Toolkit
MCdata..::..UnmanagedBuffer Property
MCdata Class See Also Send Feedback
The pointer to the unmanaged memory buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IntPtr UnmanagedBuffer { get; }
Visual Basic
Public Overridable ReadOnly Property UnmanagedBuffer As IntPtr
    Get
Visual C++
public:
virtual property IntPtr UnmanagedBuffer {
    IntPtr get ();
}

Field Value

An IntPtr containing the pointer to this instance's memory buffer.

Remarks

If the buffer in this instance is unmanaged, this property returns the address of the unmanaged memory buffer.

If this instance is based on a managed byte array, a new unmanaged memory buffer is created for every call and any previous address returned by this property becomes invalid.

The returned address is valid until the current instance is disposed or garbage collected, except for instances based on unmanaged buffers that are not owners of the buffer.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCruntimeException | The data has been disposed.

See Also

MCdata Class
MCdata Members


MCdataElement Class

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement Class
Members See Also Send Feedback
Represents a DICOM data element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdataElement
Visual Basic
Public Class MCdataElement
Visual C++
public ref class MCdataElement

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdataElement

See Also

MCdataElement Members


MCdataElement Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataElement Members
MCdataElement Class Constructors Methods Properties See Also Send Feedback

The MCdataElement type exposes the following members.

Constructors

 | Name | Description
Public method | MCdataElement(MCtag) | Constructs a "standard" data element (one in the data dictionary).
Public method | MCdataElement(MCvr, MCtag, UInt16, UInt16, String) | Constructs a data element.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getKeyword | Gets the element's keyword as defined in Part 6 of DICOM standard.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsInDictionary | Check if tag is in data dictionary
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this Data Element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsStandardElement | Tells whether this data element is defined in the data dictionary (that is, it is "standard").
Public property | Name | The element's name.
Public property | Tag | Element's identifying tag.
Public property | VmHigh | The high-end value multiplicity for this element.
Public property | VmLow | The low-end value multiplicity for this element.
Public property | Vr | The value representation for this element.

See Also

MCdataElement Class


MCdataElement Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataElement Constructor
MCdataElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdataElement(MCtag) | Constructs a "standard" data element (one in the data dictionary).
Public method | MCdataElement(MCvr, MCtag, UInt16, UInt16, String) | Constructs a data element.

See Also

MCdataElement Class
MCdataElement Members


MCdataElement Constructor (MCtag)

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement Constructor (MCtag)
MCdataElement Class See Also Send Feedback
Constructs a "standard" data element (one in the data dictionary).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdataElement(
    MCtag tag
)
Visual Basic
Public Sub New ( _
    tag As MCtag _
)
Visual C++
public:
MCdataElement(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
MCtag object identifying the data element to create.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotStandardElementException | The tag is non-private and is not defined in the dictionary.
Mergecom.Exceptions..::..MCillegalArgumentException | The tag argument was null.

See Also

MCdataElement Class
MCdataElement Members
MCdataElement Overload


MCdataElement Constructor (MCvr, MCtag, UInt16, UInt16, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement Constructor (MCvr, MCtag, UInt16, UInt16, String)
MCdataElement Class See Also Send Feedback
Constructs a data element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdataElement(
    MCvr vr,
    MCtag tag,
    ushort lowVM,
    ushort highVM,
    string name
)
Visual Basic
Public Sub New ( _
    vr As MCvr, _
    tag As MCtag, _
    lowVM As UShort, _
    highVM As UShort, _
    name As String _
)
Visual C++
public:
MCdataElement(
    MCvr^ vr,
    MCtag^ tag,
    unsigned short lowVM,
    unsigned short highVM,
    String^ name
)

Parameters

vr
Type: Mergecom..::..MCvr
The DICOM value representation this element uses. If this parameter is null the value representation is determined from the data dictionary.
tag
Type: Mergecom..::..MCtag
The tag identifying the data element.
lowVM
Type: System..::..UInt16
Lowest value multiplicity. This value must be between 0 and the value of the next parameter highVM.
highVM
Type: System..::..UInt16
Highest value multiplicity. If this value is MaxValue the number of values is unlimited.
name
Type: System..::..String
The name of the data element or null if the name is unknown

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters had an illegal value.

See Also

MCdataElement Class
MCdataElement Members
MCdataElement Overload


MCdataElement Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataElement Methods
MCdataElement Class See Also Send Feedback

The MCdataElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getKeyword | Gets the element's keyword as defined in Part 6 of DICOM standard.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsInDictionary | Check if tag is in data dictionary
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this Data Element. (Overrides Object..::..ToString()()()().)

See Also

MCdataElement Class


getKeyword Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..getKeyword Method
MCdataElement Class See Also Send Feedback
Gets the element's keyword as defined in Part 6 of DICOM standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string getKeyword()
Visual Basic
Public Function getKeyword As String
Visual C++
public:
String^ getKeyword()

Return Value

A keyword corresponding to the element's name or null if this element has no keyword defined.

Remarks

Note that the value returned can change from a version of the toolkit to another as the data dictionary is updated with changes in the latest version of the DICOM standard.

See Also

MCdataElement Class
MCdataElement Members


IsInDictionary Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..IsInDictionary Method
MCdataElement Class See Also Send Feedback
Check if tag is in data dictionary

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool IsInDictionary(
    MCtag tag
)
Visual Basic
Public Shared Function IsInDictionary ( _
    tag As MCtag _
) As Boolean
Visual C++
public:
static bool IsInDictionary(
    MCtag^ tag
)

Parameters

tag
Type: Mergecom..::..MCtag
DICOM tag

Return Value

true if in dictionary, false otherwise

See Also

MCdataElement Class
MCdataElement Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..ToString Method
MCdataElement Class See Also Send Feedback
Returns a string representation of this Data Element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String in the form: Tag: (xxxxxxxx) [(Non-standard)] Name: xxxxxxxxxx VM: nnn-nnn VR: xxxx

See Also

MCdataElement Class
MCdataElement Members


MCdataElement Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataElement Properties
MCdataElement Class See Also Send Feedback

The MCdataElement type exposes the following members.

Properties

 | Name | Description
Public property | IsStandardElement | Tells whether this data element is defined in the data dictionary (that is, it is "standard").
Public property | Name | The element's name.
Public property | Tag | Element's identifying tag.
Public property | VmHigh | The high-end value multiplicity for this element.
Public property | VmLow | The low-end value multiplicity for this element.
Public property | Vr | The value representation for this element.

See Also

MCdataElement Class


IsStandardElement Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..IsStandardElement Property
MCdataElement Class See Also Send Feedback
Tells whether this data element is defined in the data dictionary (that is, it is "standard").

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool IsStandardElement { get; }
Visual Basic
Public ReadOnly Property IsStandardElement As Boolean
    Get
Visual C++
public:
property bool IsStandardElement {
    bool get ();
}

Field Value

true if the data element is defined in the data dictionary; otherwise false.

Remarks

Private data elements are considered standard elements.

See Also

MCdataElement Class
MCdataElement Members


Name Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..Name Property
MCdataElement Class See Also Send Feedback
The element's name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name of the element which may be null.

See Also

MCdataElement Class
MCdataElement Members


Tag Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..Tag Property
MCdataElement Class See Also Send Feedback
Element's identifying tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtag Tag { get; }
Visual Basic
Public Overridable ReadOnly Property Tag As MCtag
    Get
Visual C++
public:
virtual property MCtag^ Tag {
    MCtag^ get ();
}

Field Value

The MCtag object identifying this element.

See Also

MCdataElement Class
MCdataElement Members


VmHigh Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..VmHigh Property
MCdataElement Class See Also Send Feedback
The high-end value multiplicity for this element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort VmHigh { get; }
Visual Basic
Public Overridable ReadOnly Property VmHigh As UShort
    Get
Visual C++
public:
virtual property unsigned short VmHigh {
    unsigned short get ();
}

Field Value

A number specifying the highest number of values this data element can have.

Remarks

A value equal to ushort.MaxValue means the high-end value multiplicity is unlimited

See Also

MCdataElement Class
MCdataElement Members


VmLow Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..VmLow Property
MCdataElement Class See Also Send Feedback
The low-end value multiplicity for this element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort VmLow { get; }
Visual Basic
Public Overridable ReadOnly Property VmLow As UShort
    Get
Visual C++
public:
virtual property unsigned short VmLow {
    unsigned short get ();
}

Field Value

A number specifying the lowest number of values this data element can have

See Also

MCdataElement Class
MCdataElement Members


Vr Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataElement..::..Vr Property
MCdataElement Class See Also Send Feedback
The value representation for this element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCvr Vr { get; }
Visual Basic
Public Overridable ReadOnly Property Vr As MCvr
    Get
Visual C++
public:
virtual property MCvr^ Vr {
    MCvr^ get ();
}

Field Value

An MCvr object that identifies this element's DICOM Value Representation.

See Also

MCdataElement Class
MCdataElement Members


MCdataSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet Class
Members See Also Send Feedback
Represents a DICOM DIMSE Data Set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdataSet : MCattributeSet
Visual Basic
Public Class MCdataSet _
    Inherits MCattributeSet
Visual C++
public ref class MCdataSet : public MCattributeSet

Remarks

A DICOM DIMSE Data Set contains attributes with tag numbers greater than or equal to 0x00080000 (starting with group 8 attributes).

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom..::..MCdataSet

See Also

MCdataSet Members


MCdataSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet Members
MCdataSet Class Constructors Methods Properties See Also Send Feedback

The MCdataSet type exposes the following members.

Constructors

 | Name | Description
Public method | MCdataSet()()()() | Initializes a new instance of this class as an empty DICOM data set.
Public method | MCdataSet(UInt16, String) | Initializes a new instance of this class populated with attributes appropriate to the specified service.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, HashAlgorithm) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, String) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.
Public method | deleteSignature | Deletes a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object.
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | getNextValidationError | Gets validation error information created by the validate() or validateAttribute(UInt32, MCvalidationLevel) method.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | readDataSetsFromJSON(TextReader) | Read an array of MCdataSet from a JSON stream
 | readDataSetsFromJSON(TextReader, MCbulkDataUriHandler) | Read an array of MCdataSet from a JSON stream
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setServiceCommand | Sets the Service Name associated with the contained data set.
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Validates all attributes in the attribute set. Ensures that the attribute values conform to the DICOM standard.
Public method | validateAttribute | Ensures that an attribute value conform to the DICOM standard.
Public method | verifySignature | Verifies a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object
 | writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter) | Write an array of MCdataSet to a JSON stream
 | writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter, MCbulkDataUriHandler) | Write an array of MCdataSet to a JSON stream
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Command | Gets he DIMSE Command for this data set.
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | ServiceName | Gets the service name associated with this DIMSE message.
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCdataSet Class


MCdataSet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet Constructor
MCdataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdataSet()()()() | Initializes a new instance of this class as an empty DICOM data set.
Public method | MCdataSet(UInt16, String) | Initializes a new instance of this class populated with attributes appropriate to the specified service.

See Also

MCdataSet Class
MCdataSet Members


MCdataSet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet Constructor
MCdataSet Class See Also Send Feedback
Initializes a new instance of this class as an empty DICOM data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdataSet()
Visual Basic
Public Sub New
Visual C++
public:
MCdataSet()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members
MCdataSet Overload


MCdataSet Constructor (UInt16, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet Constructor (UInt16, String)
MCdataSet Class See Also Send Feedback
Initializes a new instance of this class populated with attributes appropriate to the specified service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdataSet(
    ushort command,
    string serviceName
)
Visual Basic
Public Sub New ( _
    command As UShort, _
    serviceName As String _
)
Visual C++
public:
MCdataSet(
    unsigned short command,
    String^ serviceName
)

Parameters

command
Type: System..::..UInt16
The command to be used with this dataset. See MCdimseService for valid commands.
serviceName
Type: System..::..String
The name of a service as configured in Mergecom.srv file

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | A parameter invalid.
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members
MCdataSet Overload


MCdataSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet Methods
MCdataSet Class See Also Send Feedback

The MCdataSet type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, HashAlgorithm) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, String) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.
Public method | deleteSignature | Deletes a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object.
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | getNextValidationError | Gets validation error information created by the validate() or validateAttribute(UInt32, MCvalidationLevel) method.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | readDataSetsFromJSON(TextReader) | Read an array of MCdataSet from a JSON stream
 | readDataSetsFromJSON(TextReader, MCbulkDataUriHandler) | Read an array of MCdataSet from a JSON stream
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setServiceCommand | Sets the Service Name associated with the contained data set.
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Validates all attributes in the attribute set. Ensures that the attribute values conform to the DICOM standard.
Public method | validateAttribute | Ensures that an attribute value conform to the DICOM standard.
Public method | verifySignature | Verifies a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object
 | writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter) | Write an array of MCdataSet to a JSON stream
 | writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter, MCbulkDataUriHandler) | Write an array of MCdataSet to a JSON stream
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

See Also

MCdataSet Class


createSignature Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..createSignature Method
MCdataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, HashAlgorithm) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.
Public method | createSignature(array<UInt32>[]()[][], X509Certificate2, String) | Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys: openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx where CSP parameter defines Microsoft Cryptographic Service Provider.

See Also

MCdataSet Class
MCdataSet Members


createSignature Method (UInt32[], X509Certificate2, HashAlgorithm)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..createSignature Method (array<UInt32>[]()[][], X509Certificate2, HashAlgorithm)
MCdataSet Class See Also Send Feedback
Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object

Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys:

openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx

where CSP parameter defines Microsoft Cryptographic Service Provider.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool createSignature(
    uint[] tags,
    X509Certificate2 pfx,
    HashAlgorithm ha
)
Visual Basic
Public Overridable Function createSignature ( _
    tags As UInteger(), _
    pfx As X509Certificate2, _
    ha As HashAlgorithm _
) As Boolean
Visual C++
public:
virtual bool createSignature(
    array<unsigned int>^ tags,
    X509Certificate2^ pfx,
    HashAlgorithm^ ha
)

Parameters

tags
Type: array<System..::..UInt32>[]()[][]
A list of Data Element Tags that identify the Data Elements used in creating the MAC for the Digital Signature
pfx
Type: System.Security.Cryptography.X509Certificates..::..X509Certificate2
PKCS 12 X509Certificate2 certificate object which contains X509 certificate and the corresponding private key
ha
Type: System.Security.Cryptography..::..HashAlgorithm
Hash algorithm HashAlgorithm object. Defined algorithms are: RIPEMD160, MD5, SHA1, SHA256, SHA384 and SHA512

Return Value

true if Digital Signature is created successfully, false otherwise

See Also

MCdataSet Class
MCdataSet Members
createSignature Overload


createSignature Method (UInt32[], X509Certificate2, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..createSignature Method (array<UInt32>[]()[][], X509Certificate2, String)
MCdataSet Class See Also Send Feedback
Creates a new digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object

Digital Signature uses a X509Certificate2 object which contains Public and Private keys. One of the ways to instantiate X509Certificate2 object is to use PKCS 12 file generated by openssl with private and public keys:

openssl pkcs12 -export -aes256 -CSP "Microsoft Enhanced RSA and AES Cryptographic Provider" -inkey privatekey.pem -in publickey.crt -out certificate.pfx

where CSP parameter defines Microsoft Cryptographic Service Provider.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool createSignature(
    uint[] tags,
    X509Certificate2 pfx,
    string ha
)
Visual Basic
Public Overridable Function createSignature ( _
    tags As UInteger(), _
    pfx As X509Certificate2, _
    ha As String _
) As Boolean
Visual C++
public:
virtual bool createSignature(
    array<unsigned int>^ tags,
    X509Certificate2^ pfx,
    String^ ha
)

Parameters

tags
Type: array<System..::..UInt32>[]()[][]
A list of Data Element Tags that identify the Data Elements used in creating the MAC for the Digital Signature
pfx
Type: System.Security.Cryptography.X509Certificates..::..X509Certificate2
PKCS 12 X509Certificate2 certificate object which contains X509 certificate and the corresponding private key
ha
Type: System..::..String
Term for MAC Algorithm (0400,0015) attribute in Digital Signatures Macro (DICOM PS3.3, Table C.12-6). Defined Terms are "RIPEMD160", "MD5", "SHA1", "SHA256", "SHA384" and "SHA512"

Return Value

true if Digital Signature is created successfully, false otherwise

See Also

MCdataSet Class
MCdataSet Members
createSignature Overload


deleteSignature Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..deleteSignature Method
MCdataSet Class See Also Send Feedback
Deletes a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void deleteSignature()
Visual Basic
Public Overridable Sub deleteSignature
Visual C++
public:
virtual void deleteSignature()

See Also

MCdataSet Class
MCdataSet Members


getNextValidationError Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..getNextValidationError Method
MCdataSet Class See Also Send Feedback
Gets validation error information created by the validate() or validateAttribute(UInt32, MCvalidationLevel) method.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCvalidationError getNextValidationError()
Visual Basic
Public Function getNextValidationError As MCvalidationError
Visual C++
public:
MCvalidationError^ getNextValidationError()

Return Value

An MCvalidationError object describing the error or null if there are no more errors.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members


readDataSetsFromJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..readDataSetsFromJSON Method
MCdataSet Class See Also Send Feedback

Overload List

Name | Description
readDataSetsFromJSON(TextReader) | Read an array of MCdataSet from a JSON stream
readDataSetsFromJSON(TextReader, MCbulkDataUriHandler) | Read an array of MCdataSet from a JSON stream

See Also

MCdataSet Class
MCdataSet Members


readDataSetsFromJSON Method (TextReader)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..readDataSetsFromJSON Method (TextReader)
MCdataSet Class See Also Send Feedback
Read an array of MCdataSet from a JSON stream

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCdataSet[] readDataSetsFromJSON(
    TextReader source
)
Visual Basic
Public Shared Function readDataSetsFromJSON ( _
    source As TextReader _
) As MCdataSet()
Visual C++
public:
static array<MCdataSet^>^ readDataSetsFromJSON(
    TextReader^ source
)

Parameters

source
Type: System.IO..::..TextReader
TextReader object

Return Value

array of MCdataSet

See Also

MCdataSet Class
MCdataSet Members
readDataSetsFromJSON Overload


readDataSetsFromJSON Method (TextReader, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..readDataSetsFromJSON Method (TextReader, MCbulkDataUriHandler)
MCdataSet Class See Also Send Feedback
Read an array of MCdataSet from a JSON stream

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCdataSet[] readDataSetsFromJSON(
    TextReader source,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Shared Function readDataSetsFromJSON ( _
    source As TextReader, _
    bulkDataUriHandler As MCbulkDataUriHandler _
) As MCdataSet()
Visual C++
public:
static array<MCdataSet^>^ readDataSetsFromJSON(
    TextReader^ source,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

source
Type: System.IO..::..TextReader
TextReader object
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
An implementation of MCbulkDataUri interface that can handle reading of BulkDataURI from the JSON stream. When an attribute contains BulkDataURI, the MCbulkDataUriHandler.provideData method will be called.

Return Value

array of MCdataSet

See Also

MCdataSet Class
MCdataSet Members
readDataSetsFromJSON Overload


setServiceCommand Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..setServiceCommand Method
MCdataSet Class See Also Send Feedback
Sets the Service Name associated with the contained data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void setServiceCommand(
    string serviceName,
    ushort command
)
Visual Basic
Public Overridable Sub setServiceCommand ( _
    serviceName As String, _
    command As UShort _
)
Visual C++
public:
virtual void setServiceCommand(
    String^ serviceName,
    unsigned short command
)

Parameters

serviceName
Type: System..::..String
The service name to be associated with this data set.
command
Type: System..::..UInt16
The command to be used with this data set. See MCdimseService for valid commands.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The data set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members


validate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..validate Method
MCdataSet Class See Also Send Feedback
Validates all attributes in the attribute set. Ensures that the attribute values conform to the DICOM standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool validate(
    MCvalidationLevel level
)
Visual Basic
Public Overridable Function validate ( _
    level As MCvalidationLevel _
) As Boolean
Visual C++
public:
virtual bool validate(
    MCvalidationLevel level
)

Parameters

level
Type: Mergecom..::..MCvalidationLevel
The requested level of validation.

Return Value

true if the data set is valid.

Remarks

See MCabstractMessage.validate for specifics of the validation process.

Use getNextValidationError()()()() to get details on the validation error after this method returns false.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members


validateAttribute Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..validateAttribute Method
MCdataSet Class See Also Send Feedback
Ensures that an attribute value conform to the DICOM standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool validateAttribute(
    uint tag,
    MCvalidationLevel level
)
Visual Basic
Public Overridable Function validateAttribute ( _
    tag As UInteger, _
    level As MCvalidationLevel _
) As Boolean
Visual C++
public:
virtual bool validateAttribute(
    unsigned int tag,
    MCvalidationLevel level
)

Parameters

tag
Type: System..::..UInt32
The tag number of the attribute to validate.
level
Type: Mergecom..::..MCvalidationLevel
The requested level of validation.

Return Value

true if the attribute value is valid, otherwise false.

Remarks

This method validates an attribute contained in the current data set to determine if its values are valid. The attribute is validated to insure that it meets the requirements of the service and command of the data set.

Performance tuning: validateAttribute() has a lower overhead than validate(). When validation is only required for a select group of attributes, this method should be used.

While the validation is quite comprehensive there are limitations in validation:

  • If the attribute was specified by DICOM Part 3 as being in either a user optional module, or a conditional module, it will always be treated as a Type 3 attribute (optional attribute).
  • The Ultrasound Image Object used in storage services has mutually exclusive Image, Overlay, and Curve information entities. The attributes defined in these entities are all treated as Type 3 (optional attributes).

In any case, this method is a powerful tool that can catch almost all problems with an attribute. The DICOM Standard should always be the final word on whether or not an attribute satisfies the DICOM protocol.

If the attribute is not valid a list of validation violations is created that can be retrieved using getNextValidationError() method. Also, the results of the validation are logged into the message log (usually merge.log) at the T5_MESSAGE level.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The attribute set has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | There is no attribute with the specified tag.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdataSet Class
MCdataSet Members


verifySignature Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..verifySignature Method
MCdataSet Class See Also Send Feedback
Verifies a digital signature (DICOM PS 3.3, C.12.1.1.3 Digital Signatures Macro) in the current MCdataSet object

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool verifySignature()
Visual Basic
Public Overridable Function verifySignature As Boolean
Visual C++
public:
virtual bool verifySignature()

Return Value

true if Digital Signature is verified successfully, false otherwise

See Also

MCdataSet Class
MCdataSet Members


writeDataSetsToJSON Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..writeDataSetsToJSON Method
MCdataSet Class See Also Send Feedback

Overload List

Name | Description
writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter) | Write an array of MCdataSet to a JSON stream
writeDataSetsToJSON(array<MCdataSet>[]()[][], TextWriter, MCbulkDataUriHandler) | Write an array of MCdataSet to a JSON stream

See Also

MCdataSet Class
MCdataSet Members


writeDataSetsToJSON Method (MCdataSet[], TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..writeDataSetsToJSON Method (array<MCdataSet>[]()[][], TextWriter)
MCdataSet Class See Also Send Feedback
Write an array of MCdataSet to a JSON stream

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void writeDataSetsToJSON(
    MCdataSet[] dsArray,
    TextWriter destination
)
Visual Basic
Public Shared Sub writeDataSetsToJSON ( _
    dsArray As MCdataSet(), _
    destination As TextWriter _
)
Visual C++
public:
static void writeDataSetsToJSON(
    array<MCdataSet^>^ dsArray,
    TextWriter^ destination
)

Parameters

dsArray
Type: array< Mergecom..::..MCdataSet >[]()[][]
MCdataSet array
destination
Type: System.IO..::..TextWriter
TextWriter object

See Also

MCdataSet Class
MCdataSet Members
writeDataSetsToJSON Overload


writeDataSetsToJSON Method (MCdataSet[], TextWriter, MCbulkDataUriHandler)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..writeDataSetsToJSON Method (array<MCdataSet>[]()[][], TextWriter, MCbulkDataUriHandler)
MCdataSet Class See Also Send Feedback
Write an array of MCdataSet to a JSON stream

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void writeDataSetsToJSON(
    MCdataSet[] dsArray,
    TextWriter destination,
    MCbulkDataUriHandler bulkDataUriHandler
)
Visual Basic
Public Shared Sub writeDataSetsToJSON ( _
    dsArray As MCdataSet(), _
    destination As TextWriter, _
    bulkDataUriHandler As MCbulkDataUriHandler _
)
Visual C++
public:
static void writeDataSetsToJSON(
    array<MCdataSet^>^ dsArray,
    TextWriter^ destination,
    MCbulkDataUriHandler^ bulkDataUriHandler
)

Parameters

dsArray
Type: array< Mergecom..::..MCdataSet >[]()[][]
MCdataSet array
destination
Type: System.IO..::..TextWriter
TextWriter object
bulkDataUriHandler
Type: Mergecom..::..MCbulkDataUriHandler
MCbulkDataUriHandler implementation to handle writing BulkDataURI during generation of JSON stream. When set to null, all bulk attributes will be send as actual value. MCbulkDataUriHandler.provideUri method will only be called if vr is one of: FL, FD, IS, LT, OB, OL, OD, OF, OW, SL, SS, ST, UL, UN, US, or UT.

See Also

MCdataSet Class
MCdataSet Members
writeDataSetsToJSON Overload


MCdataSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSet Properties
MCdataSet Class See Also Send Feedback

The MCdataSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Command | Gets he DIMSE Command for this data set.
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | ServiceName | Gets the service name associated with this DIMSE message.
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCdataSet Class


Command Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..Command Property
MCdataSet Class See Also Send Feedback
Gets he DIMSE Command for this data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort Command { get; }
Visual Basic
Public Overridable ReadOnly Property Command As UShort
    Get
Visual C++
public:
virtual property unsigned short Command {
    unsigned short get ();
}

Field Value

An unsigned short representing the associated DIMSE Command. UInt16.MaxValue if the command was not set yet or the data set was disposed.

Remarks

The command code returned will be one of these defined by the MCdimseService class:
  • Composite Store Service Request and Reply: C_STORE_RQ, C_STORE_RSP
  • Composite Get Service Request, Reply and Cancel: C_GET_RQ, C_GET_RSP, C_CANCEL_GET_RQ
  • Composite Find Service Request, Reply and Cancel: C_FIND_RQ, C_FIND_RSP, C_CANCEL_FIND_RQ
  • Composite Move Service Request, Reply and Cancel: C_MOVE_RQ, C_MOVE_RSP, C_CANCEL_MOVE_RQ
  • Verification Service Request and Reply: C_ECHO_RQ, C_ECHO_RSP
  • Normalized Report Service Request and Reply: N_EVENT_REPORT_RQ, N_EVENT_REPORT_RSP
  • Normalized Get Service Request and Reply: N_GET_RQ, N_GET_RSP
  • Normalized Set Service Request and Reply: N_SET_RQ, N_SET_RSP
  • Normalized Action Service Request and Reply: N_ACTION_RQ, N_ACTION_RSP
  • Normalized Create Service Request and Reply: N_CREATE_RQ, N_CREATE_RSP
  • Normalized Delete Service Request and Reply: N_DELETE_RQ, N_DELETE_RSP

See Also

MCdataSet Class
MCdataSet Members


ServiceName Property

[image]

Merge DICOM .NET/C# Toolkit
MCdataSet..::..ServiceName Property
MCdataSet Class See Also Send Feedback
Gets the service name associated with this DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceName { get; }
Visual Basic
Public Overridable ReadOnly Property ServiceName As String
    Get
Visual C++
public:
virtual property String^ ServiceName {
    String^ get ();
}

Field Value

A String representing the service name, or null if it has not yet been set.

See Also

MCdataSet Class
MCdataSet Members


MCdataSetSerializable Interface

[image]

Merge DICOM .NET/C# Toolkit
MCdataSetSerializable Interface
Members See Also Send Feedback
Public interface for streaming attributes to dataset

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCdataSetSerializable
Visual Basic
Public Interface MCdataSetSerializable
Visual C++
public interface class MCdataSetSerializable

See Also

MCdataSetSerializable Members


MCdataSetSerializable Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSetSerializable Members
MCdataSetSerializable Interface Methods See Also Send Feedback

The MCdataSetSerializable type exposes the following members.

Methods

 | Name | Description
Public method | Read | Read attributes from DataSet
Public method | Write | Write attributes to DataSet

See Also

MCdataSetSerializable Interface


MCdataSetSerializable Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSetSerializable Methods
MCdataSetSerializable Interface See Also Send Feedback

The MCdataSetSerializable type exposes the following members.

Methods

 | Name | Description
Public method | Read | Read attributes from DataSet
Public method | Write | Write attributes to DataSet

See Also

MCdataSetSerializable Interface


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSetSerializable..::..Read Method
MCdataSetSerializable Interface See Also Send Feedback
Read attributes from DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void Read(
    MCattributeSet source
)
Visual Basic
Sub Read ( _
    source As MCattributeSet _
)
Visual C++
void Read(
    MCattributeSet^ source
)

Parameters

source
Type: Mergecom..::..MCattributeSet
Source DataSet

See Also

MCdataSetSerializable Interface
MCdataSetSerializable Members


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSetSerializable..::..Write Method
MCdataSetSerializable Interface See Also Send Feedback
Write attributes to DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void Write(
    MCattributeSet destination
)
Visual Basic
Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
void Write(
    MCattributeSet^ destination
)

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

See Also

MCdataSetSerializable Interface
MCdataSetSerializable Members


MCdataSink Interface

[image]

Merge DICOM .NET/C# Toolkit
MCdataSink Interface
Members See Also Send Feedback
Defines the requirements for a class that will receive data from the library.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCdataSink
Visual Basic
Public Interface MCdataSink
Visual C++
public interface class MCdataSink

Remarks

The method of this interface will be called by the library when writing a DICOM Part 10 format file with the MCmediaStorageService class, or writing a DICOM stream with the MCattributeSet class.

See Also

MCdataSink Members


MCdataSink Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSink Members
MCdataSink Interface Methods See Also Send Feedback

The MCdataSink type exposes the following members.

Methods

 | Name | Description
Public method | receiveData | This method is called repeatedly by the library to provide blocks of stream data while writing a DICOM Part 10 file or stream.

See Also

MCdataSink Interface


MCdataSink Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSink Methods
MCdataSink Interface See Also Send Feedback

The MCdataSink type exposes the following members.

Methods

 | Name | Description
Public method | receiveData | This method is called repeatedly by the library to provide blocks of stream data while writing a DICOM Part 10 file or stream.

See Also

MCdataSink Interface


receiveData Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSink..::..receiveData Method
MCdataSink Interface See Also Send Feedback
This method is called repeatedly by the library to provide blocks of stream data while writing a DICOM Part 10 file or stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveData(
    MCdata bulk,
    Object origin
)
Visual Basic
Sub receiveData ( _
    bulk As MCdata, _
    origin As Object _
)
Visual C++
void receiveData(
    MCdata^ bulk,
    Object^ origin
)

Parameters

bulk
Type: Mergecom..::..MCdata
A not null MCdata object containing the data block and its properties.
origin
Type: System..::..Object
The object that originated this call.

Remarks

The provided bulk field value will contain an even number of bytes and may be empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | Unable to receive the data provided.

See Also

MCdataSink Interface
MCdataSink Members


MCdataSource Interface

[image]

Merge DICOM .NET/C# Toolkit
MCdataSource Interface
Members See Also Send Feedback
Defines the requirements for a class which will be called by the library when reading data from a source.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCdataSource
Visual Basic
Public Interface MCdataSource
Visual C++
public interface class MCdataSource

Remarks

It is utilized by the MCmediaStorageService when reading in DICOM Part 10 format files and by the MCattributeSet class when streaming in DICOM "stream" format files.

For very large size data that potentially consumes a lot of memory, it is recommended to keep track of the MCdata object that is returned to the toolkit in each iteration to facilitate prompt disposal of the intermediate object. See the User Manual section "Using an MCdataSource class to assign an attribute value" for a detail example.

Use the following guideline to tackle large data size implementation: 1. Create an implementation of MCdataSource that also implements IDisposable interface. 2. Re-use the same buffer to create a MCdata object. 3. In the implementation, keep track of the MCdata returned to the toolkit. 4. Each time toolkit calls provideData interface, dispose the previous MCdata object if exists. 5. Dispose the impelementation after successfuly streamed or written out the entire DICOM object.

This interface is also used to read or provide bulk data values such as the pixel data.

See Also

MCdataSource Members


MCdataSource Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSource Members
MCdataSource Interface Methods See Also Send Feedback

The MCdataSource type exposes the following members.

Methods

 | Name | Description
Public method | provideData | Called repeatedly to request blocks of a stream.

See Also

MCdataSource Interface


MCdataSource Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSource Methods
MCdataSource Interface See Also Send Feedback

The MCdataSource type exposes the following members.

Methods

 | Name | Description
Public method | provideData | Called repeatedly to request blocks of a stream.

See Also

MCdataSource Interface


provideData Method

[image]

Merge DICOM .NET/C# Toolkit
MCdataSource..::..provideData Method
MCdataSource Interface See Also Send Feedback
Called repeatedly to request blocks of a stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
MCdata provideData(
    bool first,
    Object origin
)
Visual Basic
Function provideData ( _
    first As Boolean, _
    origin As Object _
) As MCdata
Visual C++
MCdata^ provideData(
    bool first,
    Object^ origin
)

Parameters

first
Type: System..::..Boolean
true if the first block is being requested.
origin
Type: System..::..Object
The origin of this call.

Return Value

A not null MCdata object containing the data requested.

Remarks

The caller sets first to true if this is the first time it is calling this method for all or a portion of the stream data.

The returned MCdata must contain an even number of bytes and may be empty. Its isLast field must be set to true if no more data is available.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | If there was a problem providing the data.

See Also

MCdataSource Interface
MCdataSource Members


MCdataSourceEx Interface

[image]

Merge DICOM .NET/C# Toolkit
MCdataSourceEx Interface
Members See Also Send Feedback
Extends MCdataSource with a method utilizing the offset to read the source data

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCdataSourceEx : MCdataSource
Visual Basic
Public Interface MCdataSourceEx _
    Inherits MCdataSource
Visual C++
public interface class MCdataSourceEx : MCdataSource

Remarks

For very large size data that potentially consumes a lot of memory, it is recommended to keep track of the MCdata object that is returned to the toolkit in each iteration to facilitate prompt disposal of the intermediate object. See the User Manual section "Using an MCdataSourceEx class to assign an attribute value" for a detail example.

Use the following guideline to tackle large data size implementation: 1. Create an implementation of MCdataSourceEx that also implements IDisposable interface. 2. Re-use the same buffer to create a MCdata object. 3. In the implementation, keep track of the MCdata returned to the toolkit. 4. Each time toolkit calls provideData interface, dispose the previous MCdata object if exists. 5. Dispose the impelementation after successfuly streamed or written out the entire DICOM object.

This interface is also used to read or provide bulk data values such as the pixel data.

See Also

MCdataSourceEx Members


MCdataSourceEx Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSourceEx Members
MCdataSourceEx Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | provideData(Boolean, Object) | Called repeatedly to request blocks of a stream. (Inherited from MCdataSource.)
Public method | provideData(Boolean, UInt32, Object) | Called repeatedly to request blocks of a stream with specified offset.

See Also

MCdataSourceEx Interface


MCdataSourceEx Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSourceEx Methods
MCdataSourceEx Interface See Also Send Feedback

Methods

 | Name | Description
Public method | provideData(Boolean, Object) | Called repeatedly to request blocks of a stream. (Inherited from MCdataSource.)
Public method | provideData(Boolean, UInt32, Object) | Called repeatedly to request blocks of a stream with specified offset.

See Also

MCdataSourceEx Interface


provideData Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdataSourceEx..::..provideData Method
MCdataSourceEx Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | provideData(Boolean, Object) | Called repeatedly to request blocks of a stream. (Inherited from MCdataSource.)
Public method | provideData(Boolean, UInt32, Object) | Called repeatedly to request blocks of a stream with specified offset.

See Also

MCdataSourceEx Interface
MCdataSourceEx Members


provideData Method (Boolean, UInt32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCdataSourceEx..::..provideData Method (Boolean, UInt32, Object)
MCdataSourceEx Interface See Also Send Feedback
Called repeatedly to request blocks of a stream with specified offset.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
MCdata provideData(
    bool first,
    uint pos,
    Object origin
)
Visual Basic
Function provideData ( _
    first As Boolean, _
    pos As UInteger, _
    origin As Object _
) As MCdata
Visual C++
MCdata^ provideData(
    bool first,
    unsigned int pos,
    Object^ origin
)

Parameters

first
Type: System..::..Boolean
true if the first block is being requested.
pos
Type: System..::..UInt32
An offset from the beginning of the file to seek to.
origin
Type: System..::..Object
The origin of this call.

Return Value

A not null MCdata object containing the data requested.

Remarks

The caller sets first to true if this is the first time it is calling this method, a pos is an offset from the beginning of the file to seek to for all or a portion of the stream data.

The returned MCdata must contain an even number of bytes and may be empty. Its isLast field must be set to true if no more data is available.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | If there was a problem providing the data.

See Also

MCdataSourceEx Interface
MCdataSourceEx Members
provideData Overload


MCdate Class

[image]

Merge DICOM .NET/C# Toolkit
MCdate Class
Members See Also Send Feedback
Represents a DICOM date value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdate
Visual Basic
Public Class MCdate
Visual C++
public ref class MCdate

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdate

See Also

MCdate Members


MCdate Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdate Members
MCdate Class Constructors Methods Properties See Also Send Feedback

The MCdate type exposes the following members.

Constructors

 | Name | Description
Public method | MCdate(String) | Initializes a new instance of MCdate using a preformatted DICOM date string
Public method | MCdate(Int32, Int32, Int32) | Initializes a new instance of MCdate using year, month and day values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCdate instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the content of this DICOM date. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Date | The DICOM date string in the form YYYYMMDD.
Public property | Day | The day portion of the DICOM date string.
Public property | Month | The month portion of the DICOM date string.
Public property | Year | The year portion of the DICOM date string.

See Also

MCdate Class


MCdate Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdate Constructor
MCdate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdate(String) | Initializes a new instance of MCdate using a preformatted DICOM date string
Public method | MCdate(Int32, Int32, Int32) | Initializes a new instance of MCdate using year, month and day values.

See Also

MCdate Class
MCdate Members


MCdate Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdate Constructor (String)
MCdate Class See Also Send Feedback
Initializes a new instance of MCdate using a preformatted DICOM date string

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdate(
    string dateStr
)
Visual Basic
Public Sub New ( _
    dateStr As String _
)
Visual C++
public:
MCdate(
    String^ dateStr
)

Parameters

dateStr
Type: System..::..String
A DICOM formatted date string.

Remarks

This form of the constructor does not validate the content of the argument.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCdate Class
MCdate Members
MCdate Overload


MCdate Constructor (Int32, Int32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCdate Constructor (Int32, Int32, Int32)
MCdate Class See Also Send Feedback
Initializes a new instance of MCdate using year, month and day values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdate(
    int year,
    int month,
    int day
)
Visual Basic
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
)
Visual C++
public:
MCdate(
    int year,
    int month,
    int day
)

Parameters

year
Type: System..::..Int32
The four-digit year portion of the DICOM year.
month
Type: System..::..Int32
The month portion of the DICOM date.
day
Type: System..::..Int32
The day portion of the DICOM date.

Remarks

Using this constructor insures a properly formatted DICOM date string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | Invalid value for year, month, or day.

See Also

MCdate Class
MCdate Members
MCdate Overload


MCdate Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdate Methods
MCdate Class See Also Send Feedback

The MCdate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCdate instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the content of this DICOM date. (Overrides Object..::..ToString()()()().)

See Also

MCdate Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..Equals Method
MCdate Class See Also Send Feedback
Determines whether the specified Object is equal to the current MCdate instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current date.

Return Value

true if the specified Object is an MCdate instance and it represents the same date as the current instance; otherwise false.

See Also

MCdate Class
MCdate Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..GetHashCode Method
MCdate Class See Also Send Feedback
Returns a hash code representing this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current instance.

See Also

MCdate Class
MCdate Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..ToString Method
MCdate Class See Also Send Feedback
Gets the content of this DICOM date.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String representing the date as it was and/or will be sent on a DICOM stream.

See Also

MCdate Class
MCdate Members


MCdate Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdate Properties
MCdate Class See Also Send Feedback

The MCdate type exposes the following members.

Properties

 | Name | Description
Public property | Date | The DICOM date string in the form YYYYMMDD.
Public property | Day | The day portion of the DICOM date string.
Public property | Month | The month portion of the DICOM date string.
Public property | Year | The year portion of the DICOM date string.

See Also

MCdate Class


Date Property

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..Date Property
MCdate Class See Also Send Feedback
The DICOM date string in the form YYYYMMDD.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Date { get; }
Visual Basic
Public Overridable ReadOnly Property Date As String
    Get
Visual C++
public:
virtual property String^ Date {
    String^ get ();
}

Field Value

A String representing the DICOM format date.

Remarks

The YYYYMMDD form is returned even if the date was received in the old YYYY.MM.DD format.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The format of the date string contained in this object was invalid. (Use toString to retrieve the date string.)

See Also

MCdate Class
MCdate Members


Day Property

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..Day Property
MCdate Class See Also Send Feedback
The day portion of the DICOM date string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Day { get; }
Visual Basic
Public Overridable ReadOnly Property Day As String
    Get
Visual C++
public:
virtual property String^ Day {
    String^ get ();
}

Field Value

A String containing the two-digit day number.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The date string is not of the form YYYYMMDD or YYYY.MM.DD (retired form), or the day number is not in the range 01-31. (Use toString to retrieve the date string.)

See Also

MCdate Class
MCdate Members


Month Property

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..Month Property
MCdate Class See Also Send Feedback
The month portion of the DICOM date string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Month { get; }
Visual Basic
Public Overridable ReadOnly Property Month As String
    Get
Visual C++
public:
virtual property String^ Month {
    String^ get ();
}

Field Value

A String containing the 2-digit month number.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The date string is not of the form YYYYMMDD or YYYY.MM.DD (retired form), or the month number is not in the range 01-12. (Use toString to retrieve the date string.)

See Also

MCdate Class
MCdate Members


Year Property

[image]

Merge DICOM .NET/C# Toolkit
MCdate..::..Year Property
MCdate Class See Also Send Feedback
The year portion of the DICOM date string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Year { get; }
Visual Basic
Public Overridable ReadOnly Property Year As String
    Get
Visual C++
public:
virtual property String^ Year {
    String^ get ();
}

Field Value

A String containing the 4-digit year number.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The date string is not of the form YYYYMMDD or YYYY.MM.DD (retired form), or the year number is not positive. (Use toString if an Exceptions occurs to retrieve the date string.)

See Also

MCdate Class
MCdate Members


MCdateTime Class

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime Class
Members See Also Send Feedback
Represents a DICOM date/time value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdateTime
Visual Basic
Public Class MCdateTime
Visual C++
public ref class MCdateTime

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdateTime

See Also

MCdateTime Members


MCdateTime Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTime Members
MCdateTime Class Constructors Methods Properties See Also Send Feedback

The MCdateTime type exposes the following members.

Constructors

 | Name | Description
Public method | MCdateTime(String) | Initializes a new instance of this class using a preformatted DICOM date/time string.
Public method | MCdateTime(MCdate, MCtime) | Initializes a new instance of this class using a date and a time object.
Public method | MCdateTime(MCdate, MCtime, String, Int32, Int32) | Initializes a new instance of this class using date, time and offset values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCdateTime instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Retrieves the string representation of this date/time. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Date | The date portion of this date/time.
Public property | Offset | The hours/minutes offset from Coordinated Universal Time.
Public property | Time | The time portion of this date/time.

See Also

MCdateTime Class


MCdateTime Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTime Constructor
MCdateTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdateTime(String) | Initializes a new instance of this class using a preformatted DICOM date/time string.
Public method | MCdateTime(MCdate, MCtime) | Initializes a new instance of this class using a date and a time object.
Public method | MCdateTime(MCdate, MCtime, String, Int32, Int32) | Initializes a new instance of this class using date, time and offset values.

See Also

MCdateTime Class
MCdateTime Members


MCdateTime Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime Constructor (String)
MCdateTime Class See Also Send Feedback
Initializes a new instance of this class using a preformatted DICOM date/time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTime(
    string dateTimeStr
)
Visual Basic
Public Sub New ( _
    dateTimeStr As String _
)
Visual C++
public:
MCdateTime(
    String^ dateTimeStr
)

Parameters

dateTimeStr
Type: System..::..String
The DICOM formmated date/time string.

Remarks

This form of the constructor does not validate the time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCdateTime Class
MCdateTime Members
MCdateTime Overload


MCdateTime Constructor (MCdate, MCtime)

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime Constructor (MCdate, MCtime)
MCdateTime Class See Also Send Feedback
Initializes a new instance of this class using a date and a time object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTime(
    MCdate date,
    MCtime time
)
Visual Basic
Public Sub New ( _
    date As MCdate, _
    time As MCtime _
)
Visual C++
public:
MCdateTime(
    MCdate^ date,
    MCtime^ time
)

Parameters

date
Type: Mergecom..::..MCdate
The date portion of the date/time to create.
time
Type: Mergecom..::..MCtime
The time portion of the date/time to create. This parameter can be null.

Remarks

Using this constructor insures a properly formatted DICOM date/time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException |

See Also

MCdateTime Class
MCdateTime Members
MCdateTime Overload


MCdateTime Constructor (MCdate, MCtime, String, Int32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime Constructor (MCdate, MCtime, String, Int32, Int32)
MCdateTime Class See Also Send Feedback
Initializes a new instance of this class using date, time and offset values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTime(
    MCdate date,
    MCtime time,
    string plusMinus,
    int hoursOffset,
    int minutesOffset
)
Visual Basic
Public Sub New ( _
    date As MCdate, _
    time As MCtime, _
    plusMinus As String, _
    hoursOffset As Integer, _
    minutesOffset As Integer _
)
Visual C++
public:
MCdateTime(
    MCdate^ date,
    MCtime^ time,
    String^ plusMinus,
    int hoursOffset,
    int minutesOffset
)

Parameters

date
Type: Mergecom..::..MCdate
The date portion of the date/time to create.
time
Type: Mergecom..::..MCtime
The time portion of the date/time to create or null if the time is unknown.
plusMinus
Type: System..::..String
The sign of the offset, "+", "-" or null.
hoursOffset
Type: System..::..Int32
The hours offset, an integer between 0 and 59 inclusive.
minutesOffset
Type: System..::..Int32
The minutes offset, an integer between 0 and 59 inclusive.

Remarks

Using this constructor insures a properly formatted DICOM date/time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters specified was invalid.

See Also

MCdateTime Class
MCdateTime Members
MCdateTime Overload


MCdateTime Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTime Methods
MCdateTime Class See Also Send Feedback

The MCdateTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current MCdateTime instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Retrieves the string representation of this date/time. (Overrides Object..::..ToString()()()().)

See Also

MCdateTime Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..Equals Method
MCdateTime Class See Also Send Feedback
Determines whether the specified Object is equal to the current MCdateTime instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current date/time.

Return Value

true if the specified Object is an MCdateTime instance and it represents the same date and time as the current instance; otherwise false.

See Also

MCdateTime Class
MCdateTime Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..GetHashCode Method
MCdateTime Class See Also Send Feedback
Returns a hash code representing this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current instance.

See Also

MCdateTime Class
MCdateTime Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..ToString Method
MCdateTime Class See Also Send Feedback
Retrieves the string representation of this date/time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String representing this date/time as it was or will be sent on a DICOM stream.

See Also

MCdateTime Class
MCdateTime Members


MCdateTime Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTime Properties
MCdateTime Class See Also Send Feedback

The MCdateTime type exposes the following members.

Properties

 | Name | Description
Public property | Date | The date portion of this date/time.
Public property | Offset | The hours/minutes offset from Coordinated Universal Time.
Public property | Time | The time portion of this date/time.

See Also

MCdateTime Class


Date Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..Date Property
MCdateTime Class See Also Send Feedback
The date portion of this date/time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate Date { get; }
Visual Basic
Public Overridable ReadOnly Property Date As MCdate
    Get
Visual C++
public:
virtual property MCdate^ Date {
    MCdate^ get ();
}

Field Value

The MCdate representing the date portion of this date/time.

See Also

MCdateTime Class
MCdateTime Members


Offset Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..Offset Property
MCdateTime Class See Also Send Feedback
The hours/minutes offset from Coordinated Universal Time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Offset { get; }
Visual Basic
Public Overridable ReadOnly Property Offset As String
    Get
Visual C++
public:
virtual property String^ Offset {
    String^ get ();
}

Field Value

A five character string in the form *HHMM where * is + or -, or an empty string if there is no offset.

Remarks

The returned string begins with either a plus(+) or minus(-) sign.

See Also

MCdateTime Class
MCdateTime Members


Time Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateTime..::..Time Property
MCdateTime Class See Also Send Feedback
The time portion of this date/time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime Time { get; }
Visual Basic
Public Overridable ReadOnly Property Time As MCtime
    Get
Visual C++
public:
virtual property MCtime^ Time {
    MCtime^ get ();
}

Field Value

The MCtime representing the time portion of this date/time, or null if the time portion is not specified.

See Also

MCdateTime Class
MCdateTime Members


MCdicom Structure

[image]

Merge DICOM .NET/C# Toolkit
MCdicom Structure
Members See Also Send Feedback
MCdicom structure contains fields representing tags from Part 6 of the DICOM Standard. As the standard changes the structure will be updated in order to remain current. In particular, the following changes can be expected: 1. New fields will be added as new tags are defined with new Supplements and Change Proposals. 2. Some fields will be appended with the _RETIRED suffix as tags are retired from the standard. 2. The list of aliases at the end of this structure will grow as tags are renamed in the standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public struct MCdicom
Visual Basic
Public Structure MCdicom
Visual C++
public value class MCdicom

See Also

MCdicom Members


MCdicom Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicom Members
MCdicom Structure Methods Fields See Also Send Feedback

The MCdicom type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
A_LINE_PIXEL_SPACING | A-line Pixel Spacing (0052,0014)
A_LINE_RATE | A-line Rate (0052,0011)
A_LINES_PER_FRAME | A-lines Per Frame (0052,0012)
A_SCAN_RATE | A-scan Rate (0022,1649)
ABORT_FLAG | Abort Flag (4010,1024)
ABORT_REASON | Abort Reason (4010,1021)
ABSOLUTE_CHANNEL_DISPLAY_SCALE | Absolute Channel Display Scale (003A,0248)
ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG | Absolute Dosimetric Objective Flag (3010,0073)
ABSORBED_DOSE_TO_METERSET_RATIO | Absorbed Dose to Meterset Ratio (300C,0121)
ABSTRACT_PRIOR_CODE_SEQUENCE | Abstract Prior Code Sequence (0072,003E)
ABSTRACT_PRIOR_VALUE | Abstract Prior Value (0072,003C)
ACCELERATION | Acceleration (0016,0034)
ACCESSION_NUMBER | Accession Number (0008,0050)
ACCESSORY_CODE | Accessory Code (300A,00F9)
ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE | Acoustic Coupling Medium Code Sequence (0018,982A)
ACOUSTIC_COUPLING_MEDIUM_FLAG | Acoustic Coupling Medium Flag (0018,9829)
ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED | Acoustic Coupling Medium Sound Speed (0018,9834)
ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE | Acoustic Coupling Medium Temperature (0018,982B)
ACQUIRED_IMAGE_AREA_DOSE_PRODUCT | Acquired Image Area Dose Product (0018,9473)
ACQUIRED_SOUNDPATH_LENGTH | Acquired Soundpath Length (0014,4031)
ACQUIRED_SUBTRACTION_MASK_FLAG | Acquired Subtraction Mask Flag (0018,11B2)
ACQUISITION_COMMENTS_RETIRED | Acquisition Comments RETIRED (0018,4000)
ACQUISITION_COMPRESSION_TYPE | Acquisition Compression Type (0014,4032)
ACQUISITION_CONTEXT_DESCRIPTION | Acquisition Context Description (0040,0556)
ACQUISITION_CONTEXT_SEQUENCE | Acquisition Context Sequence (0040,0555)
ACQUISITION_CONTRAST | Acquisition Contrast (0008,9209)
ACQUISITION_DATE | Acquisition Date (0008,0022)
ACQUISITION_DATETIME | Acquisition DateTime (0008,002A)
ACQUISITION_DEVICE_PROCESSING_CODE | Acquisition Device Processing Code (0018,1401)
ACQUISITION_DEVICE_PROCESSING_DESCRIPTION | Acquisition Device Processing Description (0018,1400)
ACQUISITION_DEVICE_SEQUENCE | Acquisition Device Sequence (3002,0117)
ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE | Acquisition Device Type Code Sequence (0022,0015)
ACQUISITION_DURATION | Acquisition Duration (0018,9073)
ACQUISITION_END_LOCATION_SEQUENCE | Acquisition End Location Sequence (0018,9932)
ACQUISITION_FIELD_OF_VIEW_LABEL | Acquisition Field of View Label (0018,11BB)
ACQUISITION_INDEX | Acquisition Index (0020,9518)
ACQUISITION_INITIATION_SEQUENCE | Acquisition Initiation Sequence (3002,0135)
ACQUISITION_MATRIX | Acquisition Matrix (0018,1310)
ACQUISITION_METHOD | Acquisition Method (3002,012A)
ACQUISITION_METHOD_ALGORITHM_SEQUENCE | Acquisition Method Algorithm Sequence (0022,1423)
ACQUISITION_METHOD_CODE_SEQUENCE | Acquisition Method Code Sequence (0022,1420)
ACQUISITION_MODE | Acquisition Mode (0018,11B0)
ACQUISITION_MOTION | Acquisition Motion (0018,9930)
ACQUISITION_NUMBER | Acquisition Number (0020,0012)
ACQUISITION_PROTOCOL_DESCRIPTION | Acquisition Protocol Description (0018,9424)
ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE | Acquisition Protocol Element Sequence (0018,9920)
ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Acquisition Protocol Element Specification Sequence (0018,991F)
ACQUISITION_PROTOCOL_NAME | Acquisition Protocol Name (0018,9423)
ACQUISITION_SAMPLE_SIZE | Acquisition Sample Size (0014,4033)
ACQUISITION_SIGNAL_TYPE | Acquisition Signal Type (3002,0129)
ACQUISITION_START_CONDITION | Acquisition Start Condition (0018,0073)
ACQUISITION_START_CONDITION_DATA | Acquisition Start Condition Data (0018,0074)
ACQUISITION_START_LOCATION_SEQUENCE | Acquisition Start Location Sequence (0018,9931)
ACQUISITION_STATUS | Acquisition Status (4010,1044)
ACQUISITION_SUBTASK_INDEX | Acquisition Subtask Index (3002,011D)
ACQUISITION_SUBTASK_SEQUENCE | Acquisition Subtask Sequence (3002,011A)
ACQUISITION_TASK_APPLICABILITY_SEQUENCE | Acquisition Task Applicability Sequence (3002,0124)
ACQUISITION_TASK_INDEX | Acquisition Task Index (3002,011C)
ACQUISITION_TASK_SEQUENCE | Acquisition Task Sequence (3002,0118)
ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE | Acquisition Task Workitem Code Sequence (3002,0119)
ACQUISITION_TERMINATION_CONDITION | Acquisition Termination Condition (0018,0071)
ACQUISITION_TERMINATION_CONDITION_DATA | Acquisition Termination Condition Data (0018,0075)
ACQUISITION_TIME | Acquisition Time (0008,0032)
ACQUISITION_TIME_SYNCHRONIZED | Acquisition Time Synchronized (0018,1800)
ACQUISITION_TYPE | Acquisition Type (0018,9302)
ACQUISITION_UID | Acquisition UID (0008,0017)
ACQUISITIONS_IN_SERIES_RETIRED | Acquisitions in Series RETIRED (0020,1001)
ACQUISITIONS_IN_STUDY_RETIRED | Acquisitions in Study RETIRED (0020,1004)
ACROSS_SCAN_SPATIAL_RESOLUTION | Across-scan Spatial Resolution (0022,0048)
ACTION_TYPE_ID | Action Type ID (0000,1008)
ACTIVE_IMAGE_AREA_OVERLAY_GROUP | Active Image Area Overlay Group (0018,6070)
ACTIVE_SOURCE_DIAMETER | Active Source Diameter (300A,0218)
ACTIVE_SOURCE_LENGTH | Active Source Length (300A,021A)
ACTUAL_CARDIAC_TRIGGER_DELAY_TIME | Actual Cardiac Trigger Delay Time (0020,9252)
ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK | Actual Cardiac Trigger Time Prior To R-Peak (0020,9155)
ACTUAL_ENVIRONMENTAL_CONDITIONS | Actual Environmental Conditions (0014,1010)
ACTUAL_FRAME_DURATION | Actual Frame Duration (0018,1242)
ACTUAL_HUMAN_PERFORMERS_SEQUENCE | Actual Human Performers Sequence (0040,4035)
ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME | Actual Respiratory Trigger Delay Time (0020,9257)
ADD_GRAY_SCALE_RETIRED | Add Gray Scale RETIRED (0000,5150)
ADD_INTERMEDIATE_SEQUENCE | Add Intermediate Sequence (0046,0101)
ADD_NEAR_SEQUENCE | Add Near Sequence (0046,0100)
ADD_OTHER_SEQUENCE | Add Other Sequence (0046,0102)
ADD_POWER | Add Power (0046,0104)
ADDITIONAL_DRUG_SEQUENCE | Additional Drug Sequence (0018,002A)
ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE | Additional Parameter Recording Instance Sequence (300A,0780)
ADDITIONAL_PATIENT_HISTORY | Additional Patient History (0010,21B0)
ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE | Additional RT Accessory Device Sequence (3002,0130)
ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED | Additional RT ROI Identification Code Sequence RETIRED (3006,00B9)
ADDRESS_TRIAL_RETIRED | Address (Trial) RETIRED (0040,A353)
ADMINISTRATION_ROUTE_CODE_SEQUENCE | Administration Route Code Sequence (0054,0302)
ADMISSION_ID | Admission ID (0038,0010)
ADMITTING_DATE | Admitting Date (0038,0020)
ADMITTING_DIAGNOSES_CODE_SEQUENCE | Admitting Diagnoses Code Sequence (0008,1084)
ADMITTING_DIAGNOSES_DESCRIPTION | Admitting Diagnoses Description (0008,1080)
ADMITTING_TIME | Admitting Time (0038,0021)
ADVANCED_BLENDING_SEQUENCE | Advanced Blending Sequence (0070,1B01)
AFFECTED_SOP_CLASS_UID | Affected SOP Class UID (0000,0002)
AFFECTED_SOP_INSTANCE_UID | Affected SOP Instance UID (0000,1000)
AFTERLOADER_CHANNEL_ID | Afterloader Channel ID (300A,0273)
AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE | Age Corrected Sensitivity Deviation Algorithm Sequence (0024,0065)
AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE | Age Corrected Sensitivity Deviation Probability Value (0024,0100)
AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE | Age Corrected Sensitivity Deviation Value (0024,0092)
AIR_COUNTS | Air Counts (0014,3070)
ALARM_DECISION | Alarm Decision (4010,1031)
ALARM_DECISION_TIME | Alarm Decision Time (4010,102B)
ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED | Algorithm Code Sequence (Trial) RETIRED (0040,A296)
ALGORITHM_DESCRIPTION | Algorithm Description (0018,9528)
ALGORITHM_DESCRIPTION_TRIAL_RETIRED | Algorithm Description (Trial) RETIRED (0040,A297)
ALGORITHM_FAMILY_CODE_SEQUENCE | Algorithm Family Code Sequence (0066,002F)
ALGORITHM_NAME | Algorithm Name (0066,0036)
ALGORITHM_NAME_CODE_SEQUENCE | Algorithm Name Code Sequence (0066,0030)
ALGORITHM_PARAMETERS | Algorithm Parameters (0066,0032)
ALGORITHM_ROUTING_CODE_SEQUENCE | Algorithm Routing Code Sequence (4010,1064)
ALGORITHM_SOURCE | Algorithm Source (0024,0202)
ALGORITHM_TYPE | Algorithm Type (0018,9527)
ALGORITHM_VERSION | Algorithm Version (0066,0031)
ALIASED_DATA_TYPE | Aliased Data Type (0018,980B)
ALLERGIES | Allergies (0010,2110)
ALLOW_LOSSY_COMPRESSION | Allow Lossy Compression (2200,000F)
ALLOW_MEDIA_SPLITTING | Allow Media Splitting (2200,0007)
ALONG_SCAN_SPATIAL_RESOLUTION | Along-scan Spatial Resolution (0022,0037)
ALPHA_LUT_TRANSFER_FUNCTION | Alpha LUT Transfer Function (0028,1410)
ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA | Alpha Palette Color Lookup Table Data (0028,1204)
ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Alpha Palette Color Lookup Table Descriptor (0028,1104)
ALTERNATE_BEAM_DOSE | Alternate Beam Dose (300A,0091)
ALTERNATE_BEAM_DOSE_TYPE | Alternate Beam Dose Type (300A,0092)
ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE | Alternate Container Identifier Sequence (0040,0515)
ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE | Alternate Content Description Sequence (0070,0087)
ALTERNATE_REPRESENTATION_SEQUENCE | Alternate Representation Sequence (0008,3001)
ALTERNATE_VALUE_SEQUENCE | Alternate Value Sequence (300A,073E)
AMBIENT_LIGHT_VALUE_SOURCE | Ambient Light Value Source (0028,7025)
AMBIENT_REFLECTION_INTENSITY | Ambient Reflection Intensity (0070,1702)
AMPLIFIER_TYPE | Amplifier Type (0014,400A)
ANALOG_FILTER_CHARACTERISTICS_SEQUENCE | Analog Filter Characteristics Sequence (003A,0323)
ANALOG_FILTER_ROLL_OFF | Analog Filter Roll Off (003A,0324)
ANALOG_FILTER_TYPE_CODE_SEQUENCE | Analog Filter Type Code Sequence (003A,0325)
ANALYZED_AREA | Analyzed Area (0046,0227)
ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Approach Direction Code Sequence (Trial) RETIRED (0008,2255)
ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Location Of Examining Instrument Code Sequence (Trial) RETIRED (0008,2259)
ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED | Anatomic Location Of Examining Instrument Description (Trial) RETIRED (0008,2258)
ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Perspective Code Sequence (Trial) RETIRED (0008,2257)
ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED | Anatomic Perspective Description (Trial) RETIRED (0008,2256)
ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Portal Of Entrance Code Sequence (Trial) RETIRED (0008,2253)
ANATOMIC_REGION_MODIFIER_SEQUENCE | Anatomic Region Modifier Sequence (0008,2220)
ANATOMIC_REGION_SEQUENCE | Anatomic Region Sequence (0008,2218)
ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE | Anatomic Regions in Study Code Sequence (0008,0063)
ANATOMIC_STRUCTURE_REFERENCE_POINT | Anatomic Structure Reference Point (0022,1463)
ANATOMIC_STRUCTURE_RETIRED | Anatomic Structure RETIRED (0008,2208)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Structure Space Or Region Code Sequence (Trial) RETIRED (0008,2251)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Structure Space Or Region Modifier Code Sequence (Trial) RETIRED (0008,225A)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED | Anatomic Structure Space or Region Sequence RETIRED (0008,2229)
ANATOMICAL_ORIENTATION_TYPE | Anatomical Orientation Type (0010,2210)
ANCHOR_POINT | Anchor Point (0070,0014)
ANCHOR_POINT_ANNOTATION_UNITS | Anchor Point Annotation Units (0070,0004)
ANCHOR_POINT_VISIBILITY | Anchor Point Visibility (0070,0015)
ANGIO_FLAG | Angio Flag (0018,0025)
ANGLE_NUMBER_RETIRED | Angle Number RETIRED (0020,0018)
ANGULAR_POSITION_RETIRED | Angular Position RETIRED (0018,1141)
ANGULAR_STEP | Angular Step (0018,1144)
ANGULAR_VIEW_VECTOR | Angular View Vector (0054,0090)
ANIMATION_CURVE_SEQUENCE | Animation Curve Sequence (0070,1A04)
ANIMATION_STEP_SIZE | Animation Step Size (0070,1A05)
ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS | Annotation Applies to All Optical Paths (006A,000D)
ANNOTATION_APPLIES_TO_ALL_Z_PLANES | Annotation Applies to All Z Planes (006A,000F)
ANNOTATION_CLIPPING | Annotation Clipping (0070,1907)
ANNOTATION_CONTENT_SEQUENCE_RETIRED | Annotation Content Sequence RETIRED (2130,0050)
ANNOTATION_COORDINATE_TYPE | Annotation Coordinate Type (006A,0001)
ANNOTATION_DISPLAY_FORMAT_ID | Annotation Display Format ID (2010,0030)
ANNOTATION_FLAG_RETIRED | Annotation Flag RETIRED (2000,0065)
ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE | Annotation Group Algorithm Identification Sequence (006A,0008)
ANNOTATION_GROUP_DESCRIPTION | Annotation Group Description (006A,0006)
ANNOTATION_GROUP_GENERATION_TYPE | Annotation Group Generation Type (006A,0007)
ANNOTATION_GROUP_LABEL | Annotation Group Label (006A,0005)
ANNOTATION_GROUP_NUMBER | Annotation Group Number (0040,A180)
ANNOTATION_GROUP_SEQUENCE | Annotation Group Sequence (006A,0002)
ANNOTATION_GROUP_UID | Annotation Group UID (006A,0003)
ANNOTATION_INDEX_LIST | Annotation Index List (006A,0011)
ANNOTATION_POSITION | Annotation Position (2030,0010)
ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE | Annotation Property Category Code Sequence (006A,0009)
ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE | Annotation Property Type Code Sequence (006A,000A)
ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE | Annotation Property Type Modifier Code Sequence (006A,000B)
ANNOTATION_SEQUENCE | Alias for tag WAVEFORM_ANNOTATION_SEQUENCE (0040,B020)
ANODE_TARGET_MATERIAL | Anode Target Material (0018,1191)
ANTERIOR_CHAMBER_DEPTH | Anterior Chamber Depth (0022,1131)
ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE | Anterior Chamber Depth Definition Code Sequence (0022,1125)
ANTERIOR_CHAMBER_DEPTH_SEQUENCE | Anterior Chamber Depth Sequence (0022,1128)
APERTURE_VALUE | Aperture Value (0016,0022)
APEX_POSITION | Apex Position (0020,9308)
APPLICABLE_FRAME_RANGE | Applicable Frame Range (0028,6102)
APPLICABLE_SAFETY_STANDARD_AGENCY | Applicable Safety Standard Agency (0018,9174)
APPLICABLE_SAFETY_STANDARD_DESCRIPTION | Applicable Safety Standard Description (0018,9175)
APPLICATION_MANUFACTURER | Application Manufacturer (0018,9526)
APPLICATION_MAXIMUM_REPAINT_TIME | Application Maximum Repaint Time (0072,010E)
APPLICATION_NAME | Application Name (0018,9524)
APPLICATION_SETUP_CHECK | Application Setup Check (3008,0116)
APPLICATION_SETUP_MANUFACTURER | Application Setup Manufacturer (300A,0238)
APPLICATION_SETUP_NAME | Application Setup Name (300A,0236)
APPLICATION_SETUP_NUMBER | Application Setup Number (300A,0234)
APPLICATION_SETUP_SEQUENCE | Application Setup Sequence (300A,0230)
APPLICATION_SETUP_TYPE | Application Setup Type (300A,0232)
APPLICATION_VERSION | Application Version (0018,9525)
APPLICATOINS_SETUP_SEQUENCE | Alias for tag APPLICATION_SETUP_SEQUENCE (300A,0230)
APPLICATOR_APERTURE_SHAPE | Applicator Aperture Shape (300A,0432)
APPLICATOR_DESCRIPTION | Applicator Description (300A,010A)
APPLICATOR_GEOMETRY_SEQUENCE | Applicator Geometry Sequence (300A,0431)
APPLICATOR_ID | Applicator ID (300A,0108)
APPLICATOR_OPENING | Applicator Opening (300A,0433)
APPLICATOR_OPENING_X | Applicator Opening X (300A,0434)
APPLICATOR_OPENING_Y | Applicator Opening Y (300A,0435)
APPLICATOR_SEQUENCE | Applicator Sequence (300A,0107)
APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER | Applicator Shape Referenced ROI Number (300A,02A1)
APPLICATOR_TYPE | Applicator Type (300A,0109)
APPLIED_MASK_SUBTRACTION_FLAG | Applied Mask Subtraction Flag (0018,11C0)
APPROVAL_SEQUENCE | Approval Sequence (0044,0100)
APPROVAL_STATUS | Approval Status (300E,0002)
APPROVAL_STATUS_DATETIME | Approval Status DateTime (0044,0004)
APPROVAL_STATUS_FURTHER_DESCRIPTION | Approval Status Further Description (0044,0003)
APPROVAL_SUBJECT_SEQUENCE | Approval Subject Sequence (0044,0109)
ARBITRARY_RETIRED | Arbitrary RETIRED (4000,0010)
ARCHIVE_REQUESTED | Archive Requested (0040,A494)
ARTERIAL_SPIN_LABELING_CONTRAST | Arterial Spin Labeling Contrast (0018,9250)
ASL_BOLUS_CUT_OFF_DELAY_TIME | ASL Bolus Cut-off Delay Time (0018,925F)
ASL_BOLUS_CUT_OFF_FLAG | ASL Bolus Cut-off Flag (0018,925C)
ASL_BOLUS_CUT_OFF_TECHNIQUE | ASL Bolus Cut-off Technique (0018,925E)
ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE | ASL Bolus Cut-off Timing Sequence (0018,925D)
ASL_CONTEXT | ASL Context (0018,9257)
ASL_CRUSHER_DESCRIPTION | ASL Crusher Description (0018,925B)
ASL_CRUSHER_FLAG | ASL Crusher Flag (0018,9259)
ASL_CRUSHER_FLOW | Alias for tag ASL_CRUSHER_FLOW_LIMIT (0018,925A)
ASL_CRUSHER_FLOW_LIMIT | ASL Crusher Flow Limit (0018,925A)
ASL_MID_SLAB_POSITION | ASL Mid Slab Position (0018,9256)
ASL_PULSE_TRAIN_DURATION | ASL Pulse Train Duration (0018,9258)
ASL_SLAB_NUMBER | ASL Slab Number (0018,9253)
ASL_SLAB_ORIENTATION | ASL Slab Orientation (0018,9255)
ASL_SLAB_SEQUENCE | ASL Slab Sequence (0018,9260)
ASL_SLAB_THICKNESS | ASL Slab Thickness (0018,9254)
ASL_TECHNIQUE_DESCRIPTION | ASL Technique Description (0018,9252)
ASSERTER_IDENTIFICATION_SEQUENCE | Asserter Identification Sequence (0044,0103)
ASSERTION_CODE_SEQUENCE | Assertion Code Sequence (0044,0101)
ASSERTION_COMMENTS | Assertion Comments (0044,0106)
ASSERTION_DATETIME | Assertion DateTime (0044,0104)
ASSERTION_EXPIRATION_DATETIME | Assertion Expiration DateTime (0044,0105)
ASSERTION_UID | Assertion UID (0044,0102)
ASSESSED_ATTRIBUTE_VALUE_SEQUENCE | Assessed Attribute Value Sequence (0082,0010)
ASSESSED_SOP_INSTANCE_SEQUENCE | Assessed SOP Instance Sequence (0082,0004)
ASSESSMENT_LABEL | Assessment Label (0082,0023)
ASSESSMENT_OBSERVATIONS_SEQUENCE | Assessment Observations Sequence (0082,0007)
ASSESSMENT_REQUESTER_SEQUENCE | Assessment Requester Sequence (0082,0017)
ASSESSMENT_SET_ID | Assessment Set ID (0082,0016)
ASSESSMENT_SUMMARY | Assessment Summary (0082,0001)
ASSESSMENT_SUMMARY_DESCRIPTION | Assessment Summary Description (0082,0003)
ASSESSMENT_TYPE_CODE_SEQUENCE | Assessment Type Code Sequence (0082,0021)
ASSIGNED_LOCATION | Assigned Location (4010,102A)
ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE | Assigning Agency or Department Code Sequence (0040,003A)
ASSIGNING_FACILITY_SEQUENCE | Assigning Facility Sequence (0040,0036)
ASSIGNING_JURISDICTION_CODE_SEQUENCE | Assigning Jurisdiction Code Sequence (0040,0039)
ATD_ABILITY_ASSESSMENT | ATD Ability Assessment (4010,1014)
ATD_ASSESSMENT_FLAG | ATD Assessment Flag (4010,1015)
ATD_ASSESSMENT_PROBABILITY | ATD Assessment Probability (4010,1016)
ATD_ASSESSMENT_SEQUENCE | ATD Assessment Sequence (4010,1038)
ATTACHED_CONTOURS_RETIRED | Attached Contours RETIRED (3006,0049)
ATTENUATION_CORRECTED | Attenuation Corrected (0018,9759)
ATTENUATION_CORRECTION_METHOD | Attenuation Correction Method (0054,1101)
ATTENUATION_CORRECTION_SOURCE | Attenuation Correction Source (0018,9738)
ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP | Attenuation Correction Temporal Relationship (0018,9770)
ATTRIBUTE_IDENTIFIER_LIST | Attribute Identifier List (0000,1005)
ATTRIBUTE_ITEM_SELECTOR | Attribute Item Selector (0074,1054)
ATTRIBUTE_MODIFICATION_DATETIME | Attribute Modification DateTime (0400,0562)
ATTRIBUTE_OCCURRENCE_POINTER | Attribute Occurrence Pointer (0074,1052)
ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR | Attribute Occurrence Private Creator (0074,1056)
ATTRIBUTE_OCCURRENCE_SEQUENCE | Attribute Occurrence Sequence (0074,1050)
ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE | Attribute Tolerance Values Sequence (300A,062B)
AUDIO_COMMENTS_RETIRED | Audio Comments RETIRED (5000,200E)
AUDIO_SAMPLE_DATA_RETIRED | Audio Sample Data RETIRED (5000,200C)
AUDIO_SAMPLE_FORMAT_RETIRED | Audio Sample Format RETIRED (5000,2002)
AUDIO_TYPE_RETIRED | Audio Type RETIRED (5000,2000)
AUTHOR_IDENTIFICATION_SEQUENCE | Author Identification Sequence (3010,0019)
AUTHOR_OBSERVER_SEQUENCE | Author Observer Sequence (0040,A078)
AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER | Authorization Equipment Certification Number (0100,0426)
AUTO_KVP_LOWER_BOUND | Auto KVP Lower Bound (0018,9946)
AUTO_KVP_SELECTION_TYPE | Auto KVP Selection Type (0018,9944)
AUTO_KVP_UPPER_BOUND | Auto KVP Upper Bound (0018,9945)
AUTOREFRACTION_LEFT_EYE_SEQUENCE | Autorefraction Left Eye Sequence (0046,0052)
AUTOREFRACTION_RIGHT_EYE_SEQUENCE | Autorefraction Right Eye Sequence (0046,0050)
AUTOSEQUENCE_FLAG | Autosequence Flag (0074,1025)
AVAILABLE_TRANSFER_SYNTAX_UID | Available Transfer Syntax UID (0008,3002)
AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED | Average Beam Dose Point Depth RETIRED (300A,008D)
AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED | Average Beam Dose Point Equivalent Depth RETIRED (300A,008E)
AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Average Beam Dose Point Source to External Contour Distance (300A,0131)
AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED | Average Beam Dose Point SSD RETIRED (300A,008F)
AVERAGE_CORNEAL_POWER | Average Corneal Power (0046,0220)
AVERAGE_PULSE_WIDTH | Average Pulse Width (0018,1154)
AXIAL_ACCEPTANCE | Axial Acceptance (0054,1200)
AXIAL_DETECTOR_DIMENSION | Axial Detector Dimension (0018,9727)
AXIAL_LENGTH_OF_THE_EYE | Axial Length of the Eye (0022,0030)
AXIAL_MASH | Axial Mash (0054,1201)
AXIAL_POWER | Axial Power (0046,0249)
AXIAL_RESOLUTION | Axial Resolution (0052,0008)
AXIS_LABELS_RETIRED | Axis Labels RETIRED (5000,0040)
AXIS_OF_ROTATION | Axis of Rotation (0066,001B)
AXIS_UNITS_RETIRED | Axis Units RETIRED (5000,0030)
B_SCAN_CYCLE_TIME | B-scan Cycle Time (0022,1645)
B_SCAN_CYCLE_TIME_VECTOR | B-scan Cycle Time Vector (0022,1646)
B_SCAN_RATE | B-scan Rate (0022,1650)
B_SCAN_SLAB_THICKNESS | B-scan Slab Thickness (0022,1643)
B1RMS | B1rms (0018,1320)
BACKGROUND_COLOR | Background Color (0046,0092)
BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE | Background Illumination Color Code Sequence (0024,0024)
BACKGROUND_LUMINANCE | Background Luminance (0024,0020)
BAD_PIXEL_IMAGE | Bad Pixel Image (0014,3080)
BARCODE_SYMBOLOGY | Barcode Symbology (2200,0006)
BARCODE_VALUE | Barcode Value (2200,0005)
BASELINE_CORRECTION | Baseline Correction (0018,9067)
BASIC_COLOR_IMAGE_SEQUENCE | Basic Color Image Sequence (2020,0111)
BASIC_GRAYSCALE_IMAGE_SEQUENCE | Basic Grayscale Image Sequence (2020,0110)
BASIS_MATERIALS_CODE_SEQUENCE | Basis Materials Code Sequence (4010,1045)
BASIS_RT_TREATMENT_PHASE_INDEX | Basis RT Treatment Phase Index (3010,003E)
BATTERY_LEVEL | Battery Level (0016,0003)
BEAM_ANGLE | Beam Angle (0018,9449)
BEAM_AREA_LIMIT_SEQUENCE | Beam Area Limit Sequence (300A,0689)
BEAM_CURRENT_MODULATION_ID | Beam Current Modulation ID (300A,034C)
BEAM_DELIVERY_DURATION_LIMIT | Beam Delivery Duration Limit (300A,00C5)
BEAM_DESCRIPTION | Beam Description (300A,00C3)
BEAM_DOSE | Beam Dose (300A,0084)
BEAM_DOSE_MEANING | Beam Dose Meaning (300A,008B)
BEAM_DOSE_POINT_DEPTH | Beam Dose Point Depth (300A,0088)
BEAM_DOSE_POINT_EQUIVALENT_DEPTH | Beam Dose Point Equivalent Depth (300A,0089)
BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Beam Dose Point Source to External Contour Distance (300A,0094)
BEAM_DOSE_POINT_SSD | Beam Dose Point SSD (300A,008A)
BEAM_DOSE_SPECIFICATION_POINT_RETIRED | Beam Dose Specification Point RETIRED (300A,0082)
BEAM_DOSE_TYPE | Beam Dose Type (300A,0090)
BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE | Beam Dose Verification Control Point Sequence (300A,008C)
BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE | Beam Hold Originating Device Sequence (300C,0128)
BEAM_HOLD_TRANSITION | Beam Hold Transition (300C,0126)
BEAM_HOLD_TRANSITION_DATETIME | Beam Hold Transition DateTime (300C,0127)
BEAM_LIMITING_DEVICE_ANGLE | Beam Limiting Device Angle (300A,0120)
BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE | Beam Limiting Device Angle Tolerance (300A,0046)
BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE | Beam Limiting Device Leaf Pairs Sequence (3008,00A0)
BEAM_LIMITING_DEVICE_POSITION_SEQUENCE | Beam Limiting Device Position Sequence (300A,011A)
BEAM_LIMITING_DEVICE_POSITION_TOLERANCE | Beam Limiting Device Position Tolerance (300A,004A)
BEAM_LIMITING_DEVICE_ROTATION_DIRECTION | Beam Limiting Device Rotation Direction (300A,0121)
BEAM_LIMITING_DEVICE_SEQUENCE | Beam Limiting Device Sequence (300A,00B6)
BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE | Beam Limiting Device Tolerance Sequence (300A,0048)
BEAM_METERSET | Beam Meterset (300A,0086)
BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG | Beam Modifier Coordinates Presence Flag (3002,0105)
BEAM_MODIFIER_ORIENTATION_ANGLE | Beam Modifier Orientation Angle (300A,0645)
BEAM_NAME | Beam Name (300A,00C2)
BEAM_NUMBER | Beam Number (300A,00C0)
BEAM_ORDER_INDEX | Beam Order Index (0074,1324)
BEAM_ORDER_INDEX_TRIAL_RETIRED | Beam Order Index (Trial) RETIRED (0074,1024)
BEAM_SEQUENCE | Beam Sequence (300A,00B0)
BEAM_SPOT_SIZE | Beam Spot Size (0052,0003)
BEAM_STOPPER_POSITION | Beam Stopper Position (3008,0230)
BEAM_TASK_SEQUENCE | Beam Task Sequence (0074,1020)
BEAM_TASK_TYPE | Beam Task Type (0074,1022)
BEAM_TYPE | Beam Type (300A,00C4)
BEAT_REJECTION_FLAG | Beat Rejection Flag (0018,1080)
BELT_HEIGHT | Belt Height (4010,1062)
BI_PLANE_ACQUISITION_SEQUENCE_RETIRED | Bi-Plane Acquisition Sequence RETIRED (0028,5000)
BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED | Bibliographic Citation (Trial) RETIRED (0040,A16A)
BILLING_ITEM_SEQUENCE | Billing Item Sequence (0040,0296)
BILLING_PROCEDURE_STEP_SEQUENCE | Billing Procedure Step Sequence (0040,0320)
BILLING_SUPPLIES_AND_DEVICES_SEQUENCE | Billing Supplies and Devices Sequence (0040,0324)
BIOPSY_TARGET_SEQUENCE | Biopsy Target Sequence (0018,2041)
BIT_POSITION | Alias for tag OVERLAY_BIT_POSITION (6000,0102)
BITS_ALLOCATED | Bits Allocated (0028,0100)
BITS_MAPPED_TO_COLOR_LOOKUP_TABLE | Bits Mapped to Color Lookup Table (0028,1403)
BITS_STORED | Bits Stored (0028,0101)
BLENDING_DISPLAY_INPUT_SEQUENCE | Blending Display Input Sequence (0070,1B03)
BLENDING_DISPLAY_SEQUENCE | Blending Display Sequence (0070,1B04)
BLENDING_INPUT_NUMBER | Blending Input Number (0070,1B02)
BLENDING_LOOKUP_TABLE_DATA | Blending Lookup Table Data (0028,1408)
BLENDING_LOOKUP_TABLE_DESCRIPTOR | Blending Lookup Table Descriptor (0028,1407)
BLENDING_LUT_1_SEQUENCE | Blending LUT 1 Sequence (0028,1404)
BLENDING_LUT_1_TRANSFER_FUNCTION | Blending LUT 1 Transfer Function (0028,1405)
BLENDING_LUT_2_SEQUENCE | Blending LUT 2 Sequence (0028,140C)
BLENDING_LUT_2_TRANSFER_FUNCTION | Blending LUT 2 Transfer Function (0028,140D)
BLENDING_MODE | Blending Mode (0070,1B06)
BLENDING_OPERATION_TYPE | Blending Operation Type (0072,0500)
BLENDING_POSITION | Blending Position (0070,0405)
BLENDING_SEQUENCE | Blending Sequence (0070,0402)
BLENDING_WEIGHT_CONSTANT | Blending Weight Constant (0028,1406)
BLIND_SPOT_LOCALIZED | Blind Spot Localized (0024,0106)
BLIND_SPOT_X_COORDINATE | Blind Spot X-Coordinate (0024,0107)
BLIND_SPOT_Y_COORDINATE | Blind Spot Y-Coordinate (0024,0108)
BLOCK_DATA | Block Data (300A,0106)
BLOCK_DEFINITION_SEQUENCE | Block Definition Sequence (300A,066A)
BLOCK_DIVERGENCE | Block Divergence (300A,00FA)
BLOCK_EDGE_DATA | Block Edge Data (300A,066B)
BLOCK_EDGE_DATA_SEQUENCE | Block Edge Data Sequence (300A,066F)
BLOCK_IDENTIFYING_INFORMATION_STATUS | Block Identifying Information Status (0008,0303)
BLOCK_MOUNTING_POSITION | Block Mounting Position (300A,00FB)
BLOCK_NAME | Block Name (300A,00FE)
BLOCK_NUMBER | Block Number (300A,00FC)
BLOCK_NUMBER_OF_POINTS | Block Number of Points (300A,0104)
BLOCK_ORIENTATION | Block Orientation (300A,066C)
BLOCK_SEQUENCE | Block Sequence (300A,00F4)
BLOCK_SLAB_NUMBER | Block Slab Number (300A,0443)
BLOCK_SLAB_SEQUENCE | Block Slab Sequence (300A,0441)
BLOCK_SLAB_THICKNESS | Block Slab Thickness (300A,0442)
BLOCK_THICKNESS | Block Thickness (300A,0100)
BLOCK_TRANSMISSION | Block Transmission (300A,0102)
BLOCK_TRAY_ID | Block Tray ID (300A,00F5)
BLOCK_TYPE | Block Type (300A,00F8)
BLOOD_SIGNAL_NULLING | Blood Signal Nulling (0018,9022)
BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA | Blue Palette Color Lookup Table Data (0028,1203)
BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Blue Palette Color Lookup Table Descriptor (0028,1103)
BOARDING_PASS_ID | Boarding Pass ID (4010,101A)
BODY_PART_EXAMINED | Body Part Examined (0018,0015)
BODY_PART_THICKNESS | Body Part Thickness (0018,11A0)
BOLD | Bold (0070,0249)
BOLUS_DEFINITION_SEQUENCE | Bolus Definition Sequence (300A,0673)
BOLUS_DESCRIPTION | Bolus Description (300A,00DD)
BOLUS_ID | Bolus ID (300A,00DC)
BONE_THERMAL_INDEX | Bone Thermal Index (0018,5024)
BORDER_DENSITY | Border Density (2010,0100)
BORDERS_RETIRED | Borders RETIRED (0000,5160)
BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED | Bottom Right Hand Corner of Localizer Area RETIRED (0048,0202)
BOUNDING_BOX_ANNOTATION_UNITS | Bounding Box Annotation Units (0070,0003)
BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER | Bounding Box Bottom Right Hand Corner (0070,0011)
BOUNDING_BOX_CROP | Bounding Box Crop (0070,1303)
BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION | Bounding Box Text Horizontal Justification (0070,0012)
BOUNDING_BOX_TOP_LEFT_HAND_CORNER | Bounding Box Top Left Hand Corner (0070,0010)
BOUNDING_POLYGON | Bounding Polygon (4010,101D)
BOUNDING_RECTANGLE | Bounding Rectangle (0068,6347)
BRACHY_ACCESSORY_DEVICE_ID | Brachy Accessory Device ID (300A,0263)
BRACHY_ACCESSORY_DEVICE_NAME | Brachy Accessory Device Name (300A,0266)
BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS | Brachy Accessory Device Nominal Thickness (300A,026A)
BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION | Brachy Accessory Device Nominal Transmission (300A,026C)
BRACHY_ACCESSORY_DEVICE_NUMBER | Brachy Accessory Device Number (300A,0262)
BRACHY_ACCESSORY_DEVICE_SEQUENCE | Brachy Accessory Device Sequence (300A,0260)
BRACHY_ACCESSORY_DEVICE_TYPE | Brachy Accessory Device Type (300A,0264)
BRACHY_APPLICATION_SETUP_DOSE | Brachy Application Setup Dose (300A,00A4)
BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT | Brachy Application Setup Dose Specification Point (300A,00A2)
BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE | Brachy Control Point Delivered Sequence (3008,0160)
BRACHY_CONTROL_POINT_SEQUENCE | Brachy Control Point Sequence (300A,02D0)
BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE | Brachy Pulse Control Point Delivered Sequence (3008,0173)
BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE | Brachy Referenced Dose Reference Sequence (300C,0055)
BRACHY_TASK_SEQUENCE | Brachy Task Sequence (0074,1401)
BRACHY_TREATMENT_TECHNIQUE | Brachy Treatment Technique (300A,0200)
BRACHY_TREATMENT_TYPE | Brachy Treatment Type (300A,0202)
BRACHYTHERAPY_SOURCE_TYPE | Brachytherapy Source Type (3010,0048)
BRANCH_OF_SERVICE | Branch of Service (0010,1081)
BREAST_IMPLANT_PRESENT | Breast Implant Present (0028,1300)
BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE | Breast Support Isocenter Primary Angle (0018,9545)
BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE | Breast Support Isocenter Secondary Angle (0018,9546)
BREAST_SUPPORT_X_POSITION_TO_ISOCENTER | Breast Support X Position to Isocenter (0018,9547)
BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER | Breast Support Y Position to Isocenter (0018,9548)
BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER | Breast Support Z Position to Isocenter (0018,9549)
BREED_REGISTRATION_NUMBER | Breed Registration Number (0010,2295)
BREED_REGISTRATION_SEQUENCE | Breed Registration Sequence (0010,2294)
BREED_REGISTRY_CODE_SEQUENCE | Breed Registry Code Sequence (0010,2296)
BRIGHTNESS_VALUE | Brightness Value (0016,0023)
BULK_MOTION_COMPENSATION_TECHNIQUE | Bulk Motion Compensation Technique (0018,9172)
BULK_MOTION_SIGNAL_SOURCE | Bulk Motion Signal Source (0018,9173)
BULK_MOTION_STATUS_RETIRED | Bulk Motion Status RETIRED (0018,9166)
BURNED_IN_ANNOTATION | Burned In Annotation (0028,0301)
C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE | C-Arm Photon-Electron Control Point Sequence (300A,062F)
C_ARM_POSITIONER_TABLETOP_RELATIONSHIP | C-arm Positioner Tabletop Relationship (0018,9474)
CAD_FILE_FORMAT_RETIRED | CAD File Format RETIRED (0014,0023)
CALCIUM_SCORING_MASS_FACTOR_DEVICE | Calcium Scoring Mass Factor Device (0018,9352)
CALCIUM_SCORING_MASS_FACTOR_PATIENT | Calcium Scoring Mass Factor Patient (0018,9351)
CALCULATED_ANATOMY_THICKNESS | Calculated Anatomy Thickness (0018,9452)
CALCULATED_DOSE_REFERENCE_DESCRIPTION | Calculated Dose Reference Description (3008,0074)
CALCULATED_DOSE_REFERENCE_DOSE_VALUE | Calculated Dose Reference Dose Value (3008,0076)
CALCULATED_DOSE_REFERENCE_NUMBER | Calculated Dose Reference Number (3008,0072)
CALCULATED_DOSE_REFERENCE_SEQUENCE | Calculated Dose Reference Sequence (3008,0070)
CALCULATED_FRAME_LIST | Calculated Frame List (0008,1162)
CALCULATED_TARGET_POSITION | Calculated Target Position (0018,2044)
CALCULATION_COMMENT | Calculation Comment (0022,112C)
CALCULATION_COMMENT_SEQUENCE | Calculation Comment Sequence (0022,112A)
CALCULATION_COMMENT_TYPE | Calculation Comment Type (0022,112B)
CALIBRATION_DATA_SEQUENCE | Calibration Data Sequence (0054,0306)
CALIBRATION_DATE | Calibration Date (0014,407E)
CALIBRATION_DATETIME | Calibration DateTime (0018,1203)
CALIBRATION_IMAGE | Calibration Image (0050,0004)
CALIBRATION_NOTES | Calibration Notes (0014,3099)
CALIBRATION_OBJECT | Alias for tag CALIBRATION_IMAGE (0050,0004)
CALIBRATION_PROCEDURE | Calibration Procedure (0014,4072)
CALIBRATION_REFERENCE_POINT_DEPTH | Calibration Reference Point Depth (300C,0124)
CALIBRATION_SEQUENCE | Calibration Sequence (0018,9455)
CALIBRATION_SETTINGS_SEQUENCE | Calibration Settings Sequence (0014,4070)
CALIBRATION_TIME | Calibration Time (0014,407C)
CAMERA_ANGLE_OF_VIEW | Camera Angle of View (0022,001E)
CAMERA_ELEVATION_ANGLE | Camera Elevation Angle (0016,0035)
CAMERA_OWNER_NAME | Camera Owner Name (0016,004D)
CAMERA_POSITION_GROUP_SEQUENCE | Camera Position Group Sequence (0034,000B)
CARDIAC_BEAT_REJECTION_TECHNIQUE | Cardiac Beat Rejection Technique (0018,9169)
CARDIAC_CYCLE_POSITION | Cardiac Cycle Position (0018,9236)
CARDIAC_FRAMING_TYPE | Cardiac Framing Type (0018,1064)
CARDIAC_NUMBER_OF_IMAGES | Cardiac Number of Images (0018,1090)
CARDIAC_R_R_INTERVAL_SPECIFIED | Cardiac R-R Interval Specified (0018,9070)
CARDIAC_SIGNAL_SOURCE | Cardiac Signal Source (0018,9085)
CARDIAC_SYNCHRONIZATION_SEQUENCE | Cardiac Synchronization Sequence (0018,9118)
CARDIAC_SYNCHRONIZATION_TECHNIQUE | Cardiac Synchronization Technique (0018,9037)
CARDIAC_TRIGGER_DELAY_TIME | Alias for tag NOMINAL_CARDIAC_TRIGGER_DELAY_TIME (0020,9153)
CARDIAC_TRIGGER_SEQUENCE | Alias for tag CARDIAC_SYNCHRONIZATION_SEQUENCE (0018,9118)
CARRIER_ID | Carrier ID (4010,1058)
CARRIER_ID_ASSIGNING_AUTHORITY | Carrier ID Assigning Authority (4010,1059)
CASSETTE_ID | Cassette ID (0018,1007)
CASSETTE_ORIENTATION | Cassette Orientation (0018,1402)
CASSETTE_SIZE | Cassette Size (0018,1403)
CATCH_TRIALS_DATA_FLAG | Catch Trials Data Flag (0024,0055)
CATHETER_DIRECTION_OF_ROTATION | Catheter Direction of Rotation (0052,0031)
CATHETER_ROTATIONAL_RATE | Catheter Rotational Rate (0052,0013)
CELL_VALUES_SEQUENCE | Cell Values Sequence (0040,A808)
CENTER_FREQUENCY | Center Frequency (0018,982D)
CENTER_OF_CIRCULAR_COLLIMATOR | Center of Circular Collimator (0018,1710)
CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION | Center of Circular Exposure Control Sensing Region (0018,9440)
CENTER_OF_CIRCULAR_OUTLINE | Center of Circular Outline (0018,1635)
CENTER_OF_CIRCULAR_SHUTTER | Center of Circular Shutter (0018,1610)
CENTER_OF_MASS | Center of Mass (4010,101B)
CENTER_OF_PTO | Center of PTO (4010,101C)
CENTER_OF_ROTATION | Center of Rotation (0066,001C)
CENTER_OF_ROTATION_OFFSET | Center of Rotation Offset (0018,1145)
CERTIFICATE_OF_SIGNER | Certificate of Signer (0400,0115)
CERTIFICATE_TYPE | Certificate Type (0400,0110)
CERTIFIED_TIMESTAMP | Certified Timestamp (0400,0310)
CERTIFIED_TIMESTAMP_TYPE | Certified Timestamp Type (0400,0305)
CHAIR_HEAD_FRAME_POSITION | Chair Head Frame Position (300A,0151)
CHAIR_HEAD_FRAME_POSITION_TOLERANCE | Chair Head Frame Position Tolerance (300A,0153)
CHANNEL_BASELINE | Channel Baseline (003A,0213)
CHANNEL_DEFINITION_SEQUENCE | Channel Definition Sequence (003A,0200)
CHANNEL_DELIVERY_CONTINUATION_SEQUENCE | Channel Delivery Continuation Sequence (0074,140D)
CHANNEL_DELIVERY_ORDER_INDEX | Channel Delivery Order Index (0074,140C)
CHANNEL_DELIVERY_ORDER_SEQUENCE | Channel Delivery Order Sequence (0074,1405)
CHANNEL_DERIVATION_DESCRIPTION | Channel Derivation Description (003A,020C)
CHANNEL_DESCRIPTION_CODE_SEQUENCE | Channel Description Code Sequence (0022,001A)
CHANNEL_DISPLAY_SEQUENCE | Channel Display Sequence (003A,0242)
CHANNEL_EFFECTIVE_LENGTH | Channel Effective Length (300A,0271)
CHANNEL_IDENTIFICATION_CODE | Channel Identification Code (003A,0301)
CHANNEL_IMPEDANCE_SEQUENCE | Channel Impedance Sequence (003A,0312)
CHANNEL_INNER_LENGTH | Channel Inner Length (300A,0272)
CHANNEL_LABEL | Channel Label (003A,0203)
CHANNEL_LENGTH | Channel Length (300A,0284)
CHANNEL_MAXIMUM_VALUE | Channel Maximum Value (5400,0112)
CHANNEL_MINIMUM_VALUE | Channel Minimum Value (5400,0110)
CHANNEL_MODE | Channel Mode (003A,0302)
CHANNEL_NUMBER | Channel Number (300A,0282)
CHANNEL_OFFSET | Channel Offset (003A,0218)
CHANNEL_POSITION | Channel Position (003A,0245)
CHANNEL_PRESENTATION_GROUP_SEQUENCE | Alias for tag WAVEFORM_PRESENTATION_GROUP_SEQUENCE (003A,0240)
CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE | Channel Recommended Display CIELab Value (003A,0244)
CHANNEL_SAMPLE_SKEW | Channel Sample Skew (003A,0215)
CHANNEL_SENSITIVITY | Channel Sensitivity (003A,0210)
CHANNEL_SENSITIVITY_CORRECTION_FACTOR | Channel Sensitivity Correction Factor (003A,0212)
CHANNEL_SENSITIVITY_UNITS_SEQUENCE | Channel Sensitivity Units Sequence (003A,0211)
CHANNEL_SEQUENCE | Channel Sequence (300A,0280)
CHANNEL_SHIELD_ID | Channel Shield ID (300A,02B3)
CHANNEL_SHIELD_NAME | Channel Shield Name (300A,02B4)
CHANNEL_SHIELD_NOMINAL_THICKNESS | Channel Shield Nominal Thickness (300A,02B8)
CHANNEL_SHIELD_NOMINAL_TRANSMISSION | Channel Shield Nominal Transmission (300A,02BA)
CHANNEL_SHIELD_NUMBER | Channel Shield Number (300A,02B2)
CHANNEL_SHIELD_SEQUENCE | Channel Shield Sequence (300A,02B0)
CHANNEL_SOURCE_MODIFIERS_SEQUENCE | Channel Source Modifiers Sequence (003A,0209)
CHANNEL_SOURCE_SEQUENCE | Channel Source Sequence (003A,0208)
CHANNEL_STATUS | Channel Status (003A,0205)
CHANNEL_TIME_SKEW | Channel Time Skew (003A,0214)
CHANNEL_TOTAL_TIME | Channel Total Time (300A,0286)
CHANNEL_WIDTH | Channel Width (0046,0042)
CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED | Chemical Shift Maximum Integration Limit in Hz RETIRED (0018,9196)
CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM | Chemical Shift Maximum Integration Limit in ppm (0018,9296)
CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED | Chemical Shift Minimum Integration Limit in Hz RETIRED (0018,9195)
CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM | Chemical Shift Minimum Integration Limit in ppm (0018,9295)
CHEMICAL_SHIFT_REFERENCE | Chemical Shift Reference (0018,9053)
CHEMICAL_SHIFT_SEQUENCE | Chemical Shift Sequence (0018,9084)
CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ | Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9196)
CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM | Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9296)
CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ | Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9195)
CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM | Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9295)
CIEXY_WHITE_POINT | CIExy White Point (0028,7018)
CINE_RATE | Cine Rate (0018,0040)
CINE_RELATIVE_TO_REAL_TIME | Cine Relative to Real-Time (0072,0330)
CLINICAL_FRACTION_NUMBER | Clinical Fraction Number (300A,0705)
CLINICAL_TRIAL_COORDINATING_CENTER_NAME | Clinical Trial Coordinating Center Name (0012,0060)
CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER | Clinical Trial Protocol Ethics Committee Approval Number (0012,0082)
CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME | Clinical Trial Protocol Ethics Committee Name (0012,0081)
CLINICAL_TRIAL_PROTOCOL_ID | Clinical Trial Protocol ID (0012,0020)
CLINICAL_TRIAL_PROTOCOL_NAME | Clinical Trial Protocol Name (0012,0021)
CLINICAL_TRIAL_SERIES_DESCRIPTION | Clinical Trial Series Description (0012,0072)
CLINICAL_TRIAL_SERIES_ID | Clinical Trial Series ID (0012,0071)
CLINICAL_TRIAL_SITE_ID | Clinical Trial Site ID (0012,0030)
CLINICAL_TRIAL_SITE_NAME | Clinical Trial Site Name (0012,0031)
CLINICAL_TRIAL_SPONSOR_NAME | Clinical Trial Sponsor Name (0012,0010)
CLINICAL_TRIAL_SUBJECT_ID | Clinical Trial Subject ID (0012,0040)
CLINICAL_TRIAL_SUBJECT_READING_ID | Clinical Trial Subject Reading ID (0012,0042)
CLINICAL_TRIAL_TIME_POINT_DESCRIPTION | Clinical Trial Time Point Description (0012,0051)
CLINICAL_TRIAL_TIME_POINT_ID | Clinical Trial Time Point ID (0012,0050)
CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE | Clinical Trial Time Point Type Code Sequence (0012,0054)
COATING_MATERIALS_CODE_SEQUENCE | Coating Materials Code Sequence (0068,63A4)
CODE_MEANING | Code Meaning (0008,0104)
CODE_VALUE | Code Value (0008,0100)
CODING_SCHEME_DESIGNATOR | Coding Scheme Designator (0008,0102)
CODING_SCHEME_EXTERNAL_ID | Coding Scheme External ID (0008,0114)
CODING_SCHEME_IDENTIFICATION_SEQUENCE | Coding Scheme Identification Sequence (0008,0110)
CODING_SCHEME_NAME | Coding Scheme Name (0008,0115)
CODING_SCHEME_REGISTRY | Coding Scheme Registry (0008,0112)
CODING_SCHEME_RESOURCES_SEQUENCE | Coding Scheme Resources Sequence (0008,0109)
CODING_SCHEME_RESPONSIBLE_ORGANIZATION | Coding Scheme Responsible Organization (0008,0116)
CODING_SCHEME_UID | Coding Scheme UID (0008,010C)
CODING_SCHEME_URL | Coding Scheme URL (0008,010E)
CODING_SCHEME_URL_TYPE | Coding Scheme URL Type (0008,010A)
CODING_SCHEME_VERSION | Coding Scheme Version (0008,0103)
COINCIDENCE_WINDOW_WIDTH | Coincidence Window Width (0054,1210)
COLLATION_FLAG_RETIRED | Collation Flag RETIRED (2000,0063)
COLLIMATOR_GRID_NAME | Collimator/Grid Name (0018,1180)
COLLIMATOR_LEFT_VERTICAL_EDGE | Collimator Left Vertical Edge (0018,1702)
COLLIMATOR_LOWER_HORIZONTAL_EDGE | Collimator Lower Horizontal Edge (0018,1708)
COLLIMATOR_RIGHT_VERTICAL_EDGE | Collimator Right Vertical Edge (0018,1704)
COLLIMATOR_SHAPE | Collimator Shape (0018,1700)
COLLIMATOR_SHAPE_SEQUENCE | Collimator Shape Sequence (0018,9407)
COLLIMATOR_TYPE | Collimator Type (0018,1181)
COLLIMATOR_UPPER_HORIZONTAL_EDGE | Collimator Upper Horizontal Edge (0018,1706)
COLOR_FILTER_ARRAY_PATTERN_COLUMNS | Color Filter Array Pattern Columns (0016,000F)
COLOR_FILTER_ARRAY_PATTERN_ROWS | Color Filter Array Pattern Rows (0016,000E)
COLOR_FILTER_ARRAY_PATTERN_VALUES | Color Filter Array Pattern Values (0016,0010)
COLOR_IMAGE_PRINTING_FLAG_RETIRED | Color Image Printing Flag RETIRED (2000,0062)
COLOR_SPACE | Color Space (0028,2002)
COLUMN_ANGULATION | Column Angulation (0018,1450)
COLUMN_ANGULATION_PATIENT | Column Angulation (Patient) (0018,9447)
COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX | Column Position In Total Image Pixel Matrix (0048,021E)
COLUMNS | Columns (0028,0011)
COMBINATION_SEGMENT_REFERENCE_SEQUENCE | Combination Segment Reference Sequence (3010,0024)
COMMAND_DATA_SET_TYPE | Command Data Set Type (0000,0800)
COMMAND_FIELD | Command Field (0000,0100)
COMMAND_GROUP_LENGTH | Command Group Length (0000,0000)
COMMAND_LENGTH_TO_END_RETIRED | Command Length to End RETIRED (0000,0001)
COMMAND_MAGNIFICATION_TYPE_RETIRED | Command Magnification Type RETIRED (0000,5180)
COMMAND_RECOGNITION_CODE_RETIRED | Command Recognition Code RETIRED (0000,0010)
COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD | Alias for tag COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD (0024,0044)
COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD | Comments on Patient's Performance of Visual Field (0024,0044)
COMMENTS_ON_RADIATION_DOSE | Comments on Radiation Dose (0040,0310)
COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP | Comments on the Performed Procedure Step (0040,0280)
COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP | Comments on the Scheduled Procedure Step (0040,0400)
COMMON_Z_COORDINATE_VALUE | Common Z Coordinate Value (006A,0010)
COMPENSATOR_BASE_PLANE_OFFSET | Compensator Base Plane Offset (300A,0666)
COMPENSATOR_COLUMN_OFFSET | Compensator Column Offset (300A,02E5)
COMPENSATOR_COLUMNS | Compensator Columns (300A,00E8)
COMPENSATOR_DEFINITION_SEQUENCE | Compensator Definition Sequence (300A,0662)
COMPENSATOR_DESCRIPTION | Compensator Description (300A,02EB)
COMPENSATOR_DISTAL_THICKNESS_MAP | Compensator Distal Thickness Map (300A,0665)
COMPENSATOR_DIVERGENCE | Compensator Divergence (300A,02E0)
COMPENSATOR_ID | Compensator ID (300A,00E5)
COMPENSATOR_MAP_ORIENTATION | Compensator Map Orientation (300A,0663)
COMPENSATOR_MILLING_TOOL_DIAMETER | Compensator Milling Tool Diameter (300A,02E8)
COMPENSATOR_MOUNTING_POSITION | Compensator Mounting Position (300A,02E1)
COMPENSATOR_NUMBER | Compensator Number (300A,00E4)
COMPENSATOR_PIXEL_SPACING | Compensator Pixel Spacing (300A,00E9)
COMPENSATOR_POSITION | Compensator Position (300A,00EA)
COMPENSATOR_PROXIMAL_THICKNESS_MAP | Compensator Proximal Thickness Map (300A,0664)
COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO | Compensator Relative Stopping Power Ratio (300A,02E7)
COMPENSATOR_ROWS | Compensator Rows (300A,00E7)
COMPENSATOR_SEQUENCE | Compensator Sequence (300A,00E3)
COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE | Compensator Shape Fabrication Code Sequence (300A,0667)
COMPENSATOR_SHAPE_SEQUENCE | Compensator Shape Sequence (300A,0668)
COMPENSATOR_THICKNESS_DATA | Compensator Thickness Data (300A,00EC)
COMPENSATOR_TRANSMISSION_DATA | Compensator Transmission Data (300A,00EB)
COMPENSATOR_TRAY_ID | Compensator Tray ID (300A,00EF)
COMPENSATOR_TYPE | Compensator Type (300A,00EE)
COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE | Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A375)
COMPLETION_FLAG | Completion Flag (0040,A491)
COMPLETION_FLAG_DESCRIPTION | Completion Flag Description (0040,A492)
COMPLEX_IMAGE_COMPONENT | Complex Image Component (0008,9208)
COMPONENT_1_REFERENCED_ID | Component 1 Referenced ID (0076,0070)
COMPONENT_1_REFERENCED_MATING_FEATURE_ID | Component 1 Referenced Mating Feature ID (0076,0090)
COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID | Component 1 Referenced Mating Feature Set ID (0076,0080)
COMPONENT_2_REFERENCED_ID | Component 2 Referenced ID (0076,00A0)
COMPONENT_2_REFERENCED_MATING_FEATURE_ID | Component 2 Referenced Mating Feature ID (0076,00C0)
COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID | Component 2 Referenced Mating Feature Set ID (0076,00B0)
COMPONENT_ASSEMBLY_SEQUENCE | Component Assembly Sequence (0076,0060)
COMPONENT_ID | Component ID (0076,0055)
COMPONENT_INPUT_SEQUENCE | Component Input Sequence (0070,1803)
COMPONENT_MANUFACTURER | Component Manufacturer (0014,0028)
COMPONENT_MANUFACTURING_PROCEDURE | Component Manufacturing Procedure (0014,0025)
COMPONENT_REFERENCE_SYSTEM_RETIRED | Component Reference System RETIRED (0014,0024)
COMPONENT_SEQUENCE | Component Sequence (0076,0040)
COMPONENT_SHAPE | Component Shape (0014,0050)
COMPONENT_TYPE | Component Type (0070,1802)
COMPONENT_TYPE_CODE_SEQUENCE | Component Type Code Sequence (0076,0034)
COMPONENT_TYPES_SEQUENCE | Component Types Sequence (0076,0032)
COMPOSITING_METHOD_RETIRED | Compositing Method RETIRED (0070,1206)
COMPOUND_GRAPHIC_INSTANCE_ID | Compound Graphic Instance ID (0070,0226)
COMPOUND_GRAPHIC_SEQUENCE | Compound Graphic Sequence (0070,0209)
COMPOUND_GRAPHIC_TYPE | Compound Graphic Type (0070,0294)
COMPOUND_GRAPHIC_UNITS | Compound Graphic Units (0070,0282)
COMPRESSION_CODE_RETIRED | Compression Code RETIRED (0028,0060)
COMPRESSION_CONTACT_AREA | Compression Contact Area (0018,11A5)
COMPRESSION_FORCE | Compression Force (0018,11A2)
COMPRESSION_PRESSURE | Compression Pressure (0018,11A3)
CONCATENATION_FRAME_OFFSET_NUMBER | Concatenation Frame Offset Number (0020,9228)
CONCATENATION_UID | Concatenation UID (0020,9161)
CONCEPT_CODE_SEQUENCE | Concept Code Sequence (0040,A168)
CONCEPT_NAME_CODE_SEQUENCE | Concept Name Code Sequence (0040,A043)
CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT | Conceptual Volume Blocking Constraint (3010,0068)
CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE | Conceptual Volume Category Code Sequence (3010,0067)
CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION | Conceptual Volume Combination Description (3010,000F)
CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION | Conceptual Volume Combination Expression (3010,000C)
CONCEPTUAL_VOLUME_COMBINATION_FLAG | Conceptual Volume Combination Flag (3010,000E)
CONCEPTUAL_VOLUME_CONSTITUENT_INDEX | Conceptual Volume Constituent Index (3010,000D)
CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE | Conceptual Volume Constituent Segmentation Reference Sequence (3010,0012)
CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE | Conceptual Volume Constituent Sequence (3010,0008)
CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE | Conceptual Volume Derivation Algorithm Sequence (3010,0016)
CONCEPTUAL_VOLUME_DESCRIPTION | Conceptual Volume Description (3010,0017)
CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE | Conceptual Volume Identification Sequence (3010,00A0)
CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE | Conceptual Volume Optimization Precedence (3010,0066)
CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG | Conceptual Volume Segmentation Defined Flag (3010,0010)
CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE | Conceptual Volume Segmentation Reference Sequence (3010,0011)
CONCEPTUAL_VOLUME_SEQUENCE | Conceptual Volume Sequence (3010,0025)
CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE | Conceptual Volume Type Code Sequence (3010,0069)
CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE | Conceptual Volume Type Modifier Code Sequence (3010,006A)
CONCEPTUAL_VOLUME_UID | Conceptual Volume UID (3010,0006)
CONDENSER_LENS_POWER | Condenser Lens Power (0048,0111)
CONFIDENTIALITY_CODE | Confidentiality Code (0040,1008)
CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION | Confidentiality Constraint on Patient Data Description (0040,3001)
CONFIGURATION_DESCRIPTION | Configuration Description (0028,700D)
CONFIGURATION_ID | Configuration ID (0028,700B)
CONFIGURATION_INFORMATION | Configuration Information (2010,0150)
CONFIGURATION_INFORMATION_DESCRIPTION | Configuration Information Description (2010,0152)
CONFIGURATION_NAME | Configuration Name (0028,700C)
CONFIGURATION_QA_RESULTS_SEQUENCE | Configuration QA Results Sequence (0028,7011)
CONFIRMATION_SEQUENCE | Confirmation Sequence (300A,073F)
CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE | Consent for Clinical Trial Use Sequence (0012,0083)
CONSENT_FOR_DISTRIBUTION_FLAG | Consent for Distribution Flag (0012,0085)
CONSTANT_VOLUME_FLAG | Constant Volume Flag (0018,9333)
CONSTITUENT_CONCEPTUAL_VOLUME_UID | Constituent Conceptual Volume UID (3010,0013)
CONSTRAINT_TYPE | Constraint Type (0082,0032)
CONSTRAINT_VALUE_SEQUENCE | Constraint Value Sequence (0082,0034)
CONSTRAINT_VIOLATION_CONDITION | Constraint Violation Condition (0082,0037)
CONSTRAINT_VIOLATION_SIGNIFICANCE | Constraint Violation Significance (0082,0036)
CONSTRAINT_WEIGHT | Constraint Weight (300A,0021)
CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Consulting Physician Identification Sequence (0008,009D)
CONSULTING_PHYSICIANS_NAME | Consulting Physician's Name (0008,009C)
CONTACT_DISPLAY_NAME | Contact Display Name (0074,100C)
CONTACT_METHOD | Contact Method (0016,1003)
CONTACT_URI | Contact URI (0074,100A)
CONTAINER_COMPONENT_DESCRIPTION | Container Component Description (0050,001E)
CONTAINER_COMPONENT_DIAMETER | Container Component Diameter (0050,001D)
CONTAINER_COMPONENT_ID | Container Component ID (0050,001B)
CONTAINER_COMPONENT_LENGTH | Container Component Length (0050,001C)
CONTAINER_COMPONENT_MATERIAL | Container Component Material (0050,001A)
CONTAINER_COMPONENT_SEQUENCE | Container Component Sequence (0040,0520)
CONTAINER_COMPONENT_THICKNESS | Container Component Thickness (0050,0013)
CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE | Container Component Type Code Sequence (0050,0012)
CONTAINER_COMPONENT_WIDTH | Container Component Width (0050,0015)
CONTAINER_DESCRIPTION | Container Description (0040,051A)
CONTAINER_FILE_TYPE | Container File Type (0008,040A)
CONTAINER_IDENTIFIER | Container Identifier (0040,0512)
CONTAINER_TYPE_CODE_SEQUENCE | Container Type Code Sequence (0040,0518)
CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE | Content Creator's Identification Code Sequence (0070,0086)
CONTENT_CREATORS_IDENTIFICATION_SEQUENCE | Alias for tag CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE (0070,0086)
CONTENT_CREATORS_NAME | Content Creator's Name (0070,0084)
CONTENT_DATE | Content Date (0008,0023)
CONTENT_DESCRIPTION | Content Description (0070,0081)
CONTENT_ITEM_MODIFIER_SEQUENCE | Content Item Modifier Sequence (0040,0441)
CONTENT_LABEL | Content Label (0070,0080)
CONTENT_QUALIFICATION | Content Qualification (0018,9004)
CONTENT_SEQUENCE | Content Sequence (0040,A730)
CONTENT_TEMPLATE_SEQUENCE | Content Template Sequence (0040,A504)
CONTENT_TIME | Content Time (0008,0033)
CONTEXT_GROUP_EXTENSION_CREATOR_UID | Context Group Extension Creator UID (0008,010D)
CONTEXT_GROUP_EXTENSION_FLAG | Context Group Extension Flag (0008,010B)
CONTEXT_GROUP_IDENTIFICATION_SEQUENCE | Context Group Identification Sequence (0008,0123)
CONTEXT_GROUP_LOCAL_VERSION | Context Group Local Version (0008,0107)
CONTEXT_GROUP_VERSION | Context Group Version (0008,0106)
CONTEXT_IDENTIFIER | Context Identifier (0008,010F)
CONTEXT_UID | Context UID (0008,0117)
CONTINUATION_END_METERSET | Continuation End Meterset (0074,0121)
CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA | Continuation End Total Reference Air Kerma (0074,1403)
CONTINUATION_PULSE_NUMBER | Continuation Pulse Number (0074,1404)
CONTINUATION_START_METERSET | Continuation Start Meterset (0074,0120)
CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA | Continuation Start Total Reference Air Kerma (0074,1402)
CONTINUITY_OF_CONTENT | Continuity Of Content (0040,A050)
CONTOUR_DATA | Contour Data (3006,0050)
CONTOUR_GEOMETRIC_TYPE | Contour Geometric Type (3006,0042)
CONTOUR_IMAGE_SEQUENCE | Contour Image Sequence (3006,0016)
CONTOUR_NUMBER | Contour Number (3006,0048)
CONTOUR_OFFSET_VECTOR_RETIRED | Contour Offset Vector RETIRED (3006,0045)
CONTOUR_SEQUENCE | Contour Sequence (3006,0040)
CONTOUR_SLAB_THICKNESS_RETIRED | Contour Slab Thickness RETIRED (3006,0044)
CONTOUR_UNCERTAINTY_RADIUS | Contour Uncertainty Radius (0070,0312)
CONTRAINDICATIONS_CODE_SEQUENCE | Contraindications Code Sequence (0018,990B)
CONTRAST | Contrast (0016,0048)
CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE | Contrast Administration Profile Sequence (0018,9340)
CONTRAST_ALLERGIES | Alias for tag ALLERGIES (0010,2110)
CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE | Contrast/Bolus Administration Route Sequence (0018,0014)
CONTRAST_BOLUS_AGENT | Contrast/Bolus Agent (0018,0010)
CONTRAST_BOLUS_AGENT_ADMINISTERED | Contrast/Bolus Agent Administered (0018,9342)
CONTRAST_BOLUS_AGENT_DETECTED | Contrast/Bolus Agent Detected (0018,9343)
CONTRAST_BOLUS_AGENT_NUMBER | Contrast/Bolus Agent Number (0018,9337)
CONTRAST_BOLUS_AGENT_PHASE | Contrast/Bolus Agent Phase (0018,9344)
CONTRAST_BOLUS_AGENT_SEQUENCE | Contrast/Bolus Agent Sequence (0018,0012)
CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG | Contrast/Bolus Auto Injection Trigger Flag (0018,11B6)
CONTRAST_BOLUS_INGREDIENT | Contrast/Bolus Ingredient (0018,1048)
CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE | Contrast/Bolus Ingredient Code Sequence (0018,9338)
CONTRAST_BOLUS_INGREDIENT_CONCENTRATION | Contrast/Bolus Ingredient Concentration (0018,1049)
CONTRAST_BOLUS_INGREDIENT_OPAQUE | Contrast/Bolus Ingredient Opaque (0018,9425)
CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME | Contrast/Bolus Ingredient Percent by Volume (0052,0001)
CONTRAST_BOLUS_INJECTION_DELAY | Contrast/Bolus Injection Delay (0018,11B7)
CONTRAST_BOLUS_ROUTE | Contrast/Bolus Route (0018,1040)
CONTRAST_BOLUS_START_TIME | Contrast/Bolus Start Time (0018,1042)
CONTRAST_BOLUS_STOP_TIME | Contrast/Bolus Stop Time (0018,1043)
CONTRAST_BOLUS_T1_RELAXIVITY | Contrast/Bolus T1 Relaxivity (0018,0013)
CONTRAST_BOLUS_TOTAL_DOSE | Contrast/Bolus Total Dose (0018,1044)
CONTRAST_BOLUS_USAGE_SEQUENCE | Contrast/Bolus Usage Sequence (0018,9341)
CONTRAST_BOLUS_VOLUME | Contrast/Bolus Volume (0018,1041)
CONTRAST_FLOW_DURATION | Contrast Flow Duration (0018,1047)
CONTRAST_FLOW_DURATIONS | Alias for tag CONTRAST_FLOW_DURATION (0018,1047)
CONTRAST_FLOW_RATE | Contrast Flow Rate (0018,1046)
CONTRAST_FLOW_RATES | Alias for tag CONTRAST_FLOW_RATE (0018,1046)
CONTRAST_FRAME_AVERAGING | Contrast Frame Averaging (0028,6112)
CONTRIBUTING_EQUIPMENT_SEQUENCE | Contributing Equipment Sequence (0018,A001)
CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE | Contributing SOP Instances Reference Sequence (0020,9529)
CONTRIBUTING_SOURCES_SEQUENCE | Contributing Sources Sequence (0018,9506)
CONTRIBUTION_DATETIME | Contribution DateTime (0018,A002)
CONTRIBUTION_DESCRIPTION | Contribution Description (0018,A003)
CONTROL_POINT_3D_POSITION | Control Point 3D Position (300A,02D4)
CONTROL_POINT_DELIVERY_SEQUENCE | Control Point Delivery Sequence (3008,0040)
CONTROL_POINT_INDEX | Control Point Index (300A,0112)
CONTROL_POINT_ORIENTATION | Control Point Orientation (300A,0412)
CONTROL_POINT_RELATIVE_POSITION | Control Point Relative Position (300A,02D2)
CONTROL_POINT_SEQUENCE | Control Point Sequence (300A,0111)
CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE | Conventional Control Point Verification Sequence (0074,104C)
CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE | Conventional Machine Verification Sequence (0074,1044)
CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE | Conversion Source Attributes Sequence (0020,9172)
CONVERSION_TYPE | Conversion Type (0008,0064)
CONVOLUTION_KERNEL | Convolution Kernel (0018,1210)
CONVOLUTION_KERNEL_GROUP | Convolution Kernel Group (0018,9316)
COORDINATE_START_VALUE_RETIRED | Coordinate Start Value RETIRED (5000,0112)
COORDINATE_STEP_VALUE_RETIRED | Coordinate Step Value RETIRED (5000,0114)
COORDINATE_SYSTEM_AXES_SEQUENCE | Coordinate System Axes Sequence (0014,2204)
COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED | Coordinate System Axis Code Sequence RETIRED (0040,08DA)
COORDINATE_SYSTEM_AXIS_DESCRIPTION | Coordinate System Axis Description (0014,2206)
COORDINATE_SYSTEM_AXIS_NUMBER | Coordinate System Axis Number (0014,220A)
COORDINATE_SYSTEM_AXIS_TYPE | Coordinate System Axis Type (0014,220C)
COORDINATE_SYSTEM_AXIS_UNITS | Coordinate System Axis Units (0014,220E)
COORDINATE_SYSTEM_AXIS_VALUES | Coordinate System Axis Values (0014,2210)
COORDINATE_SYSTEM_DATA_SET_MAPPING | Coordinate System Data Set Mapping (0014,2208)
COORDINATE_SYSTEM_NUMBER_OF_AXES | Coordinate System Number of Axes (0014,2202)
COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX | Coordinate System Transform Rotation and Scale Matrix (0014,222A)
COORDINATE_SYSTEM_TRANSFORM_SEQUENCE | Coordinate System Transform Sequence (0014,2220)
COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX | Coordinate System Transform Translation Matrix (0014,222C)
COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED | Coordinates Set Geometric Type (Trial) RETIRED (0040,A290)
COPIES_RETIRED | Copies RETIRED (0000,5170)
CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE | Cornea Measurement Method Code Sequence (0046,0116)
CORNEA_MEASUREMENTS_SEQUENCE | Cornea Measurements Sequence (0046,0110)
CORNEAL_AXIS | Corneal Axis (0046,0115)
CORNEAL_ECCENTRICITY_INDEX | Corneal Eccentricity Index (0046,0234)
CORNEAL_I_S_VALUE | Corneal I-S Value (0046,0224)
CORNEAL_POINT_ESTIMATED | Corneal Point Estimated (0046,0248)
CORNEAL_POINT_LOCATION | Corneal Point Location (0046,0247)
CORNEAL_POWER | Corneal Power (0046,0114)
CORNEAL_SIZE | Corneal Size (0046,0046)
CORNEAL_SIZE_SEQUENCE | Corneal Size Sequence (0046,0047)
CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION | Corneal Topography Map Quality Evaluation (0046,0242)
CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE | Corneal Topography Map Type Code Sequence (0046,0207)
CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE | Corneal Topography Mapping Normals Sequence (0046,0210)
CORNEAL_TOPOGRAPHY_SURFACE | Corneal Topography Surface (0046,0201)
CORNEAL_VERTEX_LOCATION | Corneal Vertex Location (0046,0202)
CORNEAL_WAVEFRONT | Corneal Wavefront (0046,0253)
CORRECTED_IMAGE | Corrected Image (0028,0051)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL | Corrected Localized Deviation From Normal (0024,0079)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED | Corrected Localized Deviation From Normal Calculated (0024,0078)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY | Corrected Localized Deviation From Normal Probability (0024,0081)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED | Corrected Localized Deviation From Normal Probability Calculated (0024,0080)
CORRECTED_PARAMETER_SEQUENCE | Corrected Parameter Sequence (3008,0068)
CORRECTED_VALUE | Alias for tag CORRECTION_VALUE (3008,006A)
CORRECTION_VALUE | Correction Value (3008,006A)
COUNT_LOSS_NORMALIZATION_CORRECTED | Count Loss Normalization Corrected (0018,9764)
COUNT_RATE | Count Rate (0018,1243)
COUNTRY_OF_RESIDENCE | Country of Residence (0010,2150)
COUNTS_ACCUMULATED | Counts Accumulated (0018,0070)
COUNTS_INCLUDED_RETIRED | Counts Included RETIRED (0054,1400)
COUNTS_SOURCE | Counts Source (0054,1002)
COUPLING_MEDIUM | Coupling Medium (0014,4056)
COUPLING_TECHNIQUE | Coupling Technique (0014,4054)
COUPLING_VELOCITY | Coupling Velocity (0014,4057)
COVERAGE_OF_K_SPACE | Coverage of k-Space (0018,9094)
CRANIAL_THERMAL_INDEX | Cranial Thermal Index (0018,5026)
CREATION_DATE | Creation Date (2100,0040)
CREATION_TIME | Creation Time (2100,0050)
CREATOR_VERSION_UID | Creator-Version UID (0008,9123)
CROP | Crop (0070,1204)
CROPPING_SPECIFICATION_INDEX | Cropping Specification Index (0070,1205)
CROPPING_SPECIFICATION_NUMBER | Cropping Specification Number (0070,1309)
CSS_FONT_NAME | CSS Font Name (0070,0229)
CT_ACQUISITION_DETAILS_SEQUENCE | CT Acquisition Details Sequence (0018,9304)
CT_ACQUISITION_TYPE_SEQUENCE | CT Acquisition Type Sequence (0018,9301)
CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE | CT Additional X-Ray Source Sequence (0018,9360)
CT_EXPOSURE_SEQUENCE | CT Exposure Sequence (0018,9321)
CT_GEOMETRY_SEQUENCE | CT Geometry Sequence (0018,9312)
CT_IMAGE_FRAME_TYPE_SEQUENCE | CT Image Frame Type Sequence (0018,9329)
CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE | CT Imaging Acquisition Parameter Sequence (3002,0126)
CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE | Alias for tag CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE (0018,9360)
CT_POSITION_SEQUENCE | CT Position Sequence (0018,9326)
CT_RECONSTRUCTION_SEQUENCE | CT Reconstruction Sequence (0018,9314)
CT_TABLE_DYNAMICS_SEQUENCE | CT Table Dynamics Sequence (0018,9308)
CT_X_RAY_DETAILS_SEQUENCE | CT X-Ray Details Sequence (0018,9325)
CTDI_PHANTOM_TYPE_CODE_SEQUENCE | CTDI Phantom Type Code Sequence (0018,9346)
CTDIVOL | CTDIvol (0018,9345)
CTDIVOL_NOTIFICATION_TRIGGER | CTDIvol Notification Trigger (0018,9942)
CUMULATIVE_DOSE_REFERENCE_COEFFICIENT | Cumulative Dose Reference Coefficient (300A,010C)
CUMULATIVE_DOSE_TO_DOSE_REFERENCE | Cumulative Dose to Dose Reference (3008,0052)
CUMULATIVE_METERSET | Cumulative Meterset (300A,063C)
CUMULATIVE_METERSET_WEIGHT | Cumulative Meterset Weight (300A,0134)
CUMULATIVE_TIME_WEIGHT | Cumulative Time Weight (300A,02D6)
CURRENT_CONFIGURATION_ID | Current Configuration ID (0028,7002)
CURRENT_FRACTION_NUMBER | Current Fraction Number (3008,0022)
CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Current Frame Functional Groups Sequence (0006,0001)
CURRENT_OBSERVER_TRIAL_RETIRED | Current Observer (Trial) RETIRED (0040,A307)
CURRENT_PATIENT_LOCATION | Current Patient Location (0038,0300)
CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE | Current Requested Procedure Evidence Sequence (0040,A375)
CURRENT_TREATMENT_STATUS | Current Treatment Status (3008,0200)
CURVATURE_TYPE | Curvature Type (0014,0052)
CURVE_ACTIVATION_LAYER_RETIRED | Curve Activation Layer RETIRED (5000,1001)
CURVE_DATA_DESCRIPTOR_RETIRED | Curve Data Descriptor RETIRED (5000,0110)
CURVE_DATA_RETIRED | Curve Data RETIRED (5000,3000)
CURVE_DATE_RETIRED | Curve Date RETIRED (0008,0025)
CURVE_DESCRIPTION_RETIRED | Curve Description RETIRED (5000,0022)
CURVE_DIMENSIONS_RETIRED | Curve Dimensions RETIRED (5000,0005)
CURVE_LABEL_RETIRED | Curve Label RETIRED (5000,2500)
CURVE_NUMBER_RETIRED | Curve Number RETIRED (0020,0024)
CURVE_RANGE_RETIRED | Curve Range RETIRED (5000,0106)
CURVE_REFERENCED_OVERLAY_GROUP_RETIRED | Curve Referenced Overlay Group RETIRED (5000,2610)
CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED | Curve Referenced Overlay Sequence RETIRED (5000,2600)
CURVE_TIME_RETIRED | Curve Time RETIRED (0008,0035)
CUSTODIAL_ORGANIZATION_SEQUENCE | Custodial Organization Sequence (0040,A07C)
CUSTOM_RENDERED | Custom Rendered (0016,0041)
CYLINDER_AXIS | Cylinder Axis (0022,0009)
CYLINDER_LENS_POWER | Cylinder Lens Power (0022,0008)
CYLINDER_POWER | Cylinder Power (0046,0147)
CYLINDER_SEQUENCE | Cylinder Sequence (0046,0018)
DAC_AMPLITUDE | DAC Amplitude (0014,403C)
DAC_GAIN_POINTS | DAC Gain Points (0014,4038)
DAC_SEQUENCE | DAC Sequence (0014,4035)
DAC_TIME_POINTS | DAC Time Points (0014,403A)
DAC_TYPE | DAC Type (0014,4036)
DAMPING | Damping (0014,4028)
DARK_CURRENT_COUNTS | Dark Current Counts (0014,3050)
DARK_CURRENT_SEQUENCE | Dark Current Sequence (0014,3040)
DATA_COLLECTION_CENTER_PATIENT | Data Collection Center (Patient) (0018,9313)
DATA_COLLECTION_DIAMETER | Data Collection Diameter (0018,0090)
DATA_ELEMENTS_SIGNED | Data Elements Signed (0400,0020)
DATA_FRAME_ASSIGNMENT_SEQUENCE | Data Frame Assignment Sequence (0028,1401)
DATA_INFORMATION_SEQUENCE | Data Information Sequence (0054,0063)
DATA_OBSERVATION_SEQUENCE | Data Observation Sequence (0024,0325)
DATA_PATH_ASSIGNMENT | Data Path Assignment (0028,1402)
DATA_PATH_ID | Data Path ID (0028,140E)
DATA_POINT_COLUMNS | Data Point Columns (0028,9002)
DATA_POINT_ROWS | Data Point Rows (0028,9001)
DATA_REPRESENTATION | Data Representation (0028,9108)
DATA_SET_DESCRIPTION | Data Set Description (0024,0309)
DATA_SET_NAME | Data Set Name (0024,0306)
DATA_SET_SOURCE | Data Set Source (0024,0308)
DATA_SET_SUBTYPE_RETIRED | Data Set Subtype RETIRED (0008,0041)
DATA_SET_TRAILING_PADDING | Data Set Trailing Padding (FFFC,FFFC)
DATA_SET_TYPE | Alias for tag COMMAND_DATA_SET_TYPE (0000,0800)
DATA_SET_TYPE_RETIRED | Data Set Type RETIRED (0008,0040)
DATA_SET_VERSION | Data Set Version (0024,0307)
DATA_TYPE | Data Type (0018,9808)
DATA_VALUE_REPRESENTATION_RETIRED | Data Value Representation RETIRED (5000,0103)
DATE | Date (0040,A121)
DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED | Date of Document or Verbal Transaction (Trial) RETIRED (0040,A110)
DATE_OF_GAIN_CALIBRATION | Date of Gain Calibration (0014,3076)
DATE_OF_INSTALLATION | Date of Installation (0018,1205)
DATE_OF_LAST_CALIBRATION | Date of Last Calibration (0018,1200)
DATE_OF_LAST_DETECTOR_CALIBRATION | Date of Last Detector Calibration (0018,700C)
DATE_OF_MANUFACTURE | Date of Manufacture (0018,1204)
DATE_OF_SECONDARY_CAPTURE | Date of Secondary Capture (0018,1012)
DATETIME | DateTime (0040,A120)
DATETIME_OF_LAST_CALIBRATION | DateTime of Last Calibration (0018,1202)
DB_DT | dB/dt (0018,1318)
DDL_VALUE | DDL Value (0028,7017)
DE_COUPLED_NUCLEUS | De-coupled Nucleus (0018,9060)
DE_COUPLING | De-coupling (0018,9059)
DE_COUPLING_CHEMICAL_SHIFT_REFERENCE | De-coupling Chemical Shift Reference (0018,9063)
DE_COUPLING_FREQUENCY | De-coupling Frequency (0018,9061)
DE_COUPLING_METHOD | De-coupling Method (0018,9062)
DE_IDENTIFICATION_METHOD | De-identification Method (0012,0063)
DE_IDENTIFICATION_METHOD_CODE_SEQUENCE | De-identification Method Code Sequence (0012,0064)
DEAD_TIME_CORRECTED | Dead Time Corrected (0018,9761)
DEAD_TIME_CORRECTION_FLAG_RETIRED | Dead Time Correction Flag RETIRED (0054,1401)
DEAD_TIME_FACTOR | Dead Time Factor (0054,1324)
DECAY_CORRECTED | Decay Corrected (0018,9758)
DECAY_CORRECTION | Decay Correction (0054,1102)
DECAY_CORRECTION_DATETIME | Decay Correction DateTime (0018,9701)
DECAY_FACTOR | Decay Factor (0054,1321)
DECIMAL_POTENTIAL_VISUAL_ACUITY | Decimal Potential Visual Acuity (0046,0238)
DECIMAL_VISUAL_ACUITY | Decimal Visual Acuity (0046,0137)
DECIMATE_CROP_RESULT | Decimate/Crop Result (2020,00A2)
DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE | Decomposition Algorithm Identification Sequence (0018,9380)
DECOMPOSITION_DESCRIPTION | Decomposition Description (0018,937F)
DECOMPOSITION_MATERIAL_SEQUENCE | Decomposition Material Sequence (0018,9381)
DECOMPOSITION_METHOD | Decomposition Method (0018,937E)
DEFAULT_MAGNIFICATION_TYPE | Default Magnification Type (2010,00A6)
DEFAULT_PRINTER_RESOLUTION_ID | Default Printer Resolution ID (2010,0054)
DEFAULT_SMOOTHING_TYPE | Default Smoothing Type (2010,00A8)
DEFINITION_SOURCE_SEQUENCE | Definition Source Sequence (0008,1156)
DEFORMABLE_REGISTRATION_GRID_SEQUENCE | Deformable Registration Grid Sequence (0064,0005)
DEFORMABLE_REGISTRATION_SEQUENCE | Deformable Registration Sequence (0064,0002)
DEGREE_OF_DILATION | Degree of Dilation (0022,000E)
DEGREE_OF_FREEDOM_ID | Degree of Freedom ID (0068,6410)
DEGREE_OF_FREEDOM_TYPE | Degree of Freedom Type (0068,6420)
DEIDENTIFICATION_ACTION | Deidentification Action (0008,0307)
DEIDENTIFICATION_ACTION_SEQUENCE | Deidentification Action Sequence (0008,0305)
DELAY_LAW_IDENTIFIER | Delay Law Identifier (0014,405C)
DELETION_LOCK | Deletion Lock (0074,1230)
DELINEATED_RADIATION_FIELD_SIZE | Delineated Radiation Field Size (300C,0122)
DELIVERED_CHANNEL_TOTAL_TIME | Delivered Channel Total Time (3008,0134)
DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE | Delivered Depth Dose Parameters Sequence (300A,0506)
DELIVERED_DISTAL_DEPTH | Delivered Distal Depth (300A,0508)
DELIVERED_DISTAL_DEPTH_FRACTION | Delivered Distal Depth Fraction (300A,0507)
DELIVERED_METERSET | Delivered Meterset (3008,0044)
DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS | Delivered Nominal Range Modulated Region Depths (300A,0510)
DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS | Delivered Nominal Range Modulation Fractions (300A,0509)
DELIVERED_NUMBER_OF_PULSES | Delivered Number of Pulses (3008,0138)
DELIVERED_PRIMARY_METERSET | Delivered Primary Meterset (3008,0036)
DELIVERED_PULSE_REPETITION_INTERVAL | Delivered Pulse Repetition Interval (3008,013C)
DELIVERED_REFERENCE_DOSE_DEFINITION | Delivered Reference Dose Definition (300A,0511)
DELIVERED_SECONDARY_METERSET | Delivered Secondary Meterset (3008,0037)
DELIVERED_TREATMENT_TIME | Delivered Treatment Time (3008,003B)
DELIVERY_MAXIMUM_DOSE | Delivery Maximum Dose (300A,0023)
DELIVERY_RATE | Delivery Rate (300A,063D)
DELIVERY_RATE_UNIT_SEQUENCE | Delivery Rate Unit Sequence (300A,063E)
DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE | Delivery Time Structure Code Sequence (3010,0088)
DELIVERY_VERIFICATION_IMAGE_SEQUENCE | Delivery Verification Image Sequence (0074,1030)
DELIVERY_WARNING_DOSE | Delivery Warning Dose (300A,0022)
DENSITY | Density (4010,1018)
DEPTH_DOSE_PARAMETERS_SEQUENCE | Depth Dose Parameters Sequence (300A,0505)
DEPTH_OF_SCAN_FIELD | Depth of Scan Field (0018,5050)
DEPTH_OF_TRANSVERSE_IMAGE | Depth of Transverse Image (0022,0041)
DEPTH_SPATIAL_RESOLUTION | Depth Spatial Resolution (0022,0035)
DEPTH_VALUE_AVERAGING_FLAG | Depth Value Averaging Flag (300A,0093)
DEPTHS_OF_FOCUS | Depth(s) of Focus (0018,9801)
DERIVATION_ALGORITHM_SEQUENCE | Derivation Algorithm Sequence (0022,1612)
DERIVATION_CODE_SEQUENCE | Derivation Code Sequence (0008,9215)
DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE | Derivation Conceptual Volume Sequence (3010,0014)
DERIVATION_DESCRIPTION | Derivation Description (0008,2111)
DERIVATION_IMAGE_SEQUENCE | Derivation Image Sequence (0008,9124)
DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Derivation Implant Assembly Template Sequence (0076,000E)
DERIVATION_IMPLANT_TEMPLATE_SEQUENCE | Derivation Implant Template Sequence (0068,6224)
DESTINATION_AE | Destination AE (2100,0140)
DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE | Detector Activation Offset From Exposure (0018,7016)
DETECTOR_ACTIVE_AREA_ORIENTATION | Detector Active Area Orientation (0018,9558)
DETECTOR_ACTIVE_AREA_TLHC_POSITION | Detector Active Area TLHC Position (0018,9557)
DETECTOR_ACTIVE_DIMENSIONS | Detector Active Dimension(s) (0018,7026)
DETECTOR_ACTIVE_ORIGIN | Detector Active Origin (0018,7028)
DETECTOR_ACTIVE_SHAPE | Detector Active Shape (0018,7024)
DETECTOR_ACTIVE_TIME | Detector Active Time (0018,7014)
DETECTOR_BINNING | Detector Binning (0018,701A)
DETECTOR_CALIBRATION_DATA | Detector Calibration Data (4010,106C)
DETECTOR_CONDITIONS_NOMINAL_FLAG | Detector Conditions Nominal Flag (0018,7000)
DETECTOR_CONFIGURATION | Detector Configuration (0018,7005)
DETECTOR_DESCRIPTION | Detector Description (0018,7006)
DETECTOR_ELEMENT_PHYSICAL_SIZE | Detector Element Physical Size (0018,7020)
DETECTOR_ELEMENT_SIZE | Detector Element Size (0054,1203)
DETECTOR_ELEMENT_SPACING | Detector Element Spacing (0018,7022)
DETECTOR_GEOMETRY | Detector Geometry (0018,9725)
DETECTOR_GEOMETRY_SEQUENCE | Detector Geometry Sequence (4010,0004)
DETECTOR_ID | Detector ID (0018,700A)
DETECTOR_INFORMATION_SEQUENCE | Detector Information Sequence (0054,0022)
DETECTOR_ISOCENTER_PRIMARY_ANGLE | Detector Isocenter Primary Angle (0018,9550)
DETECTOR_ISOCENTER_SECONDARY_ANGLE | Detector Isocenter Secondary Angle (0018,9551)
DETECTOR_LINES_OF_RESPONSE_USED | Detector Lines of Response Used (0054,1104)
DETECTOR_MANUFACTURER_NAME | Detector Manufacturer Name (0018,702A)
DETECTOR_MANUFACTURERS_MODEL_NAME | Detector Manufacturer's Model Name (0018,702B)
DETECTOR_MODE | Detector Mode (0018,7008)
DETECTOR_NORMALIZATION_CORRECTION | Detector Normalization Correction (0018,9768)
DETECTOR_POSITION_SEQUENCE | Detector Position Sequence (0018,9541)
DETECTOR_POSITIONING_TYPE | Detector Positioning Type (3002,012F)
DETECTOR_PRIMARY_ANGLE | Detector Primary Angle (0018,1530)
DETECTOR_SECONDARY_ANGLE | Detector Secondary Angle (0018,1531)
DETECTOR_TEMPERATURE | Detector Temperature (0018,7001)
DETECTOR_TEMPERATURE_SEQUENCE | Detector Temperature Sequence (0014,3020)
DETECTOR_TIME_SINCE_LAST_EXPOSURE | Detector Time Since Last Exposure (0018,7012)
DETECTOR_TYPE | Detector Type (0018,7004)
DETECTOR_VECTOR | Detector Vector (0054,0020)
DETECTOR_X_POSITION_TO_ISOCENTER | Detector X Position to Isocenter (0018,9552)
DETECTOR_Y_POSITION_TO_ISOCENTER | Detector Y Position to Isocenter (0018,9553)
DETECTOR_Z_POSITION_TO_ISOCENTER | Detector Z Position to Isocenter (0018,9554)
DEVIATION_INDEX | Deviation Index (0018,1413)
DEVICE_ALTERNATE_IDENTIFIER | Device Alternate Identifier (3010,001B)
DEVICE_ALTERNATE_IDENTIFIER_FORMAT | Device Alternate Identifier Format (3010,001D)
DEVICE_ALTERNATE_IDENTIFIER_TYPE | Device Alternate Identifier Type (3010,001C)
DEVICE_DESCRIPTION | Device Description (0050,0020)
DEVICE_DIAMETER | Device Diameter (0050,0016)
DEVICE_DIAMETER_UNITS | Device Diameter Units (0050,0017)
DEVICE_ID | Device ID (0018,1003)
DEVICE_INDEX | Device Index (3010,0039)
DEVICE_LABEL | Device Label (3010,002D)
DEVICE_LENGTH | Device Length (0050,0014)
DEVICE_MOTION_CONTROL_SEQUENCE | Device Motion Control Sequence (300A,0450)
DEVICE_MOTION_EXECUTION_MODE | Device Motion Execution Mode (300A,0451)
DEVICE_MOTION_OBSERVATION_MODE | Device Motion Observation Mode (300A,0452)
DEVICE_MOTION_PARAMETER_CODE_SEQUENCE | Device Motion Parameter Code Sequence (300A,0453)
DEVICE_ORDER_INDEX | Device Order Index (300A,065E)
DEVICE_POSITION_PARAMETER_SEQUENCE | Device Position Parameter Sequence (3002,0110)
DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX | Device Position to Equipment Mapping Matrix (3002,010F)
DEVICE_SEQUENCE | Device Sequence (0050,0010)
DEVICE_SERIAL_NUMBER | Device Serial Number (0018,1000)
DEVICE_SETTING_DESCRIPTION | Device Setting Description (0016,004B)
DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE | Device-Specific Acquisition Parameter Sequence (3002,0131)
DEVICE_TYPE_CODE_SEQUENCE | Device Type Code Sequence (3010,002E)
DEVICE_UID | Device UID (0018,1002)
DEVICE_VOLUME | Device Volume (0050,0018)
DIALOG_RECEIVER_RETIRED | Dialog Receiver RETIRED (0000,4000)
DIAMETER_OF_CIRCULAR_OUTLINE | Diameter of Circular Outline (0018,1636)
DIAMETER_OF_VISIBILITY | Diameter of Visibility (0070,0262)
DIAPHRAGM_POSITION | Diaphragm Position (3002,0034)
DICOM_MEDIA_RETRIEVAL_SEQUENCE | DICOM Media Retrieval Sequence (0040,E022)
DICOM_RETRIEVAL_SEQUENCE | DICOM Retrieval Sequence (0040,E021)
DICOM_STORAGE_SEQUENCE | DICOM Storage Sequence (0040,4071)
DICOS_VERSION | DICOS Version (4010,103A)
DIFFUSE_REFLECTION_INTENSITY | Diffuse Reflection Intensity (0070,1704)
DIFFUSION_ACQUISITION_CODE_SEQUENCE | Diffusion Acquisition Code Sequence (0066,0133)
DIFFUSION_ANISOTROPY_TYPE | Diffusion Anisotropy Type (0018,9147)
DIFFUSION_B_MATRIX_SEQUENCE | Diffusion b-matrix Sequence (0018,9601)
DIFFUSION_B_VALUE | Diffusion b-value (0018,9087)
DIFFUSION_B_VALUE_XX | Diffusion b-value XX (0018,9602)
DIFFUSION_B_VALUE_XY | Diffusion b-value XY (0018,9603)
DIFFUSION_B_VALUE_XZ | Diffusion b-value XZ (0018,9604)
DIFFUSION_B_VALUE_YY | Diffusion b-value YY (0018,9605)
DIFFUSION_B_VALUE_YZ | Diffusion b-value YZ (0018,9606)
DIFFUSION_B_VALUE_ZZ | Diffusion b-value ZZ (0018,9607)
DIFFUSION_DIRECTIONALITY | Diffusion Directionality (0018,9075)
DIFFUSION_GRADIENT_DIRECTION_SEQUENCE | Diffusion Gradient Direction Sequence (0018,9076)
DIFFUSION_GRADIENT_ORIENTATION | Diffusion Gradient Orientation (0018,9089)
DIFFUSION_MODEL_CODE_SEQUENCE | Diffusion Model Code Sequence (0066,0134)
DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE | Digital Filter Characteristics Sequence (003A,0326)
DIGITAL_FILTER_ORDER | Digital Filter Order (003A,0327)
DIGITAL_FILTER_TYPE_CODE_SEQUENCE | Digital Filter Type Code Sequence (003A,0328)
DIGITAL_IMAGE_FORMAT_ACQUIRED | Digital Image Format Acquired (0018,1023)
DIGITAL_SIGNATURE_DATETIME | Digital Signature DateTime (0400,0105)
DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE | Digital Signature Purpose Code Sequence (0400,0401)
DIGITAL_SIGNATURE_UID | Digital Signature UID (0400,0100)
DIGITAL_SIGNATURES_SEQUENCE | Digital Signatures Sequence (FFFA,FFFA)
DIGITAL_ZOOM_RATIO | Digital Zoom Ratio (0016,0044)
DIGITIZING_DEVICE_TRANSPORT_DIRECTION | Digitizing Device Transport Direction (0018,2020)
DIMENSION_DESCRIPTION_LABEL | Dimension Description Label (0020,9421)
DIMENSION_INDEX_POINTER | Dimension Index Pointer (0020,9165)
DIMENSION_INDEX_PRIVATE_CREATOR | Dimension Index Private Creator (0020,9213)
DIMENSION_INDEX_SEQUENCE | Dimension Index Sequence (0020,9222)
DIMENSION_INDEX_VALUES | Dimension Index Values (0020,9157)
DIMENSION_ORGANIZATION_SEQUENCE | Dimension Organization Sequence (0020,9221)
DIMENSION_ORGANIZATION_TYPE | Dimension Organization Type (0020,9311)
DIMENSION_ORGANIZATION_UID | Dimension Organization UID (0020,9164)
DIRECT_SEGMENT_REFERENCE_SEQUENCE | Direct Segment Reference Sequence (3010,0023)
DIRECTORY_RECORD_SEQUENCE | Directory Record Sequence (0004,1220)
DIRECTORY_RECORD_TYPE | Directory Record Type (0004,1430)
DISCHARGE_DATE_RETIRED | Discharge Date RETIRED (0038,0030)
DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED | Discharge Diagnosis Code Sequence RETIRED (0038,0044)
DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED | Discharge Diagnosis Description RETIRED (0038,0040)
DISCHARGE_TIME_RETIRED | Discharge Time RETIRED (0038,0032)
DISPLACEMENT_MATRIX | Displacement Matrix (300A,079B)
DISPLACEMENT_REFERENCE_LABEL | Displacement Reference Label (300A,079A)
DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE | Displacement Reference Location Code Sequence (300A,079D)
DISPLAY_CALIBRATION_RESULT_SEQUENCE | Display Calibration Result Sequence (0028,7016)
DISPLAY_DEVICE_TYPE_CODE_SEQUENCE | Display Device Type Code Sequence (0028,7022)
DISPLAY_ENVIRONMENT_SPATIAL_POSITION | Display Environment Spatial Position (0072,0108)
DISPLAY_FILTER_PERCENTAGE | Display Filter Percentage (0028,9411)
DISPLAY_FORMAT_RETIRED | Display Format RETIRED (0000,5110)
DISPLAY_FUNCTION_TYPE | Display Function Type (0028,7019)
DISPLAY_SET_HORIZONTAL_JUSTIFICATION | Display Set Horizontal Justification (0072,0717)
DISPLAY_SET_LABEL | Display Set Label (0072,0203)
DISPLAY_SET_NUMBER | Display Set Number (0072,0202)
DISPLAY_SET_PATIENT_ORIENTATION | Display Set Patient Orientation (0072,0700)
DISPLAY_SET_PRESENTATION_GROUP | Display Set Presentation Group (0072,0204)
DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION | Display Set Presentation Group Description (0072,0206)
DISPLAY_SET_SCROLLING_GROUP | Display Set Scrolling Group (0072,0212)
DISPLAY_SET_VERTICAL_JUSTIFICATION | Display Set Vertical Justification (0072,0718)
DISPLAY_SETS_SEQUENCE | Display Sets Sequence (0072,0200)
DISPLAY_SHADING_FLAG | Display Shading Flag (003A,0246)
DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE | Display Subsystem Configuration Sequence (0028,700A)
DISPLAY_SUBSYSTEM_DESCRIPTION | Display Subsystem Description (0028,7005)
DISPLAY_SUBSYSTEM_ID | Display Subsystem ID (0028,7003)
DISPLAY_SUBSYSTEM_NAME | Display Subsystem Name (0028,7004)
DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE | Display Subsystem QA Results Sequence (0028,7010)
DISPLAY_SUBSYSTEM_SEQUENCE | Display Subsystem Sequence (0028,7023)
DISPLAY_WINDOW_LABEL_VECTOR | Display Window Label Vector (0018,2006)
DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER | Displayed Area Bottom Right Hand Corner (0070,0053)
DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED | Displayed Area Bottom Right Hand Corner (Trial) RETIRED (0070,0051)
DISPLAYED_AREA_SELECTION_SEQUENCE | Displayed Area Selection Sequence (0070,005A)
DISPLAYED_AREA_TOP_LEFT_HAND_CORNER | Displayed Area Top Left Hand Corner (0070,0052)
DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED | Displayed Area Top Left Hand Corner (Trial) RETIRED (0070,0050)
DISPLAYED_Z_VALUE | Displayed Z Value (0018,2046)
DISTAL_DEPTH | Distal Depth (300A,0502)
DISTAL_DEPTH_FRACTION | Distal Depth Fraction (300A,0501)
DISTANCE_BETWEEN_B_SCAN_SLABS | Distance Between B-scan Slabs (0022,1644)
DISTANCE_BETWEEN_FOCAL_PLANES | Distance Between Focal Planes (0048,0014)
DISTANCE_OBJECT_TO_TABLE_TOP | Distance Object to Table Top (0018,9403)
DISTANCE_PUPILLARY_DISTANCE | Distance Pupillary Distance (0046,0060)
DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING | Distance Receptor Plane to Detector Housing (0018,9426)
DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER | Distance Source to Data Collection Center (0018,9335)
DISTANCE_SOURCE_TO_DETECTOR | Distance Source to Detector (0018,1110)
DISTANCE_SOURCE_TO_ENTRANCE | Distance Source to Entrance (0040,0306)
DISTANCE_SOURCE_TO_ISOCENTER | Distance Source to Isocenter (0018,9402)
DISTANCE_SOURCE_TO_PATIENT | Distance Source to Patient (0018,1111)
DISTANCE_SOURCE_TO_SUPPORT_RETIRED | Distance Source to Support RETIRED (0040,0307)
DISTRIBUTION_ADDRESS_RETIRED | Distribution Address RETIRED (4008,011A)
DISTRIBUTION_NAME_RETIRED | Distribution Name RETIRED (4008,0119)
DISTRIBUTION_TYPE | Distribution Type (0012,0084)
DLP_NOTIFICATION_TRIGGER | DLP Notification Trigger (0018,9943)
DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Document Author Identifier Code Sequence (Trial) RETIRED (0040,A068)
DOCUMENT_AUTHOR_TRIAL_RETIRED | Document Author (Trial) RETIRED (0040,A067)
DOCUMENT_CLASS_CODE_SEQUENCE | Document Class Code Sequence (0040,E008)
DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Document Identifier Code Sequence (Trial) RETIRED (0040,A066)
DOCUMENT_TITLE | Document Title (0042,0010)
DOCUMENTING_OBSERVER | Alias for tag VERIFYING_OBSERVER_NAME (0040,A075)
DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Documenting Observer Identifier Code Sequence (Trial) RETIRED (0040,A076)
DOCUMENTING_ORGANIZATION | Alias for tag VERIFYING_ORGANIZATION 0040,A027)
DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Documenting Organization Identifier Code Sequence (Trial) RETIRED (0040,A028)
DOPPLER_CORRECTION_ANGLE | Doppler Correction Angle (0018,6034)
DOPPLER_SAMPLE_VOLUME_X_POSITION | Doppler Sample Volume X Position (0018,6039)
DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED | Doppler Sample Volume X Position (Retired) (0018,6038)
DOPPLER_SAMPLE_VOLUME_Y_POSITION | Doppler Sample Volume Y Position (0018,603B)
DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED | Doppler Sample Volume Y Position (Retired) (0018,603A)
DOSE_CALIBRATION_CONDITIONS_SEQUENCE | Dose Calibration Conditions Sequence (300C,0120)
DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG | Dose Calibration Conditions Verified Flag (300C,0123)
DOSE_CALIBRATION_FACTOR | Dose Calibration Factor (0054,1322)
DOSE_COMMENT | Dose Comment (3004,0006)
DOSE_GRID_SCALING | Dose Grid Scaling (3004,000E)
DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE | Dose Measurement Device Code Sequence (300A,0774)
DOSE_MODE_NAME | Dose Mode Name (0018,11B1)
DOSE_RATE_DELIVERED | Dose Rate Delivered (3008,0048)
DOSE_RATE_SET | Dose Rate Set (300A,0115)
DOSE_REFERENCE_DESCRIPTION | Dose Reference Description (300A,0016)
DOSE_REFERENCE_NUMBER | Dose Reference Number (300A,0012)
DOSE_REFERENCE_POINT_COORDINATES | Dose Reference Point Coordinates (300A,0018)
DOSE_REFERENCE_SEQUENCE | Dose Reference Sequence (300A,0010)
DOSE_REFERENCE_STRUCTURE_TYPE | Dose Reference Structure Type (300A,0014)
DOSE_REFERENCE_TYPE | Dose Reference Type (300A,0020)
DOSE_REFERENCE_UID | Dose Reference UID (300A,0013)
DOSE_SUMMATION_TYPE | Dose Summation Type (3004,000A)
DOSE_TYPE | Dose Type (3004,0004)
DOSE_UNITS | Dose Units (3004,0002)
DOSE_VALUE | Dose Value RETIRED (3004,0012)
DOSE_VALUE_PURPOSE | Dose Value Purpose (300A,061D)
DOSE_VALUE_RETIRED | Dose Value RETIRED (3004,0012)
DOSE_VALUES_SEQUENCE | Dose Values Sequence (300A,061C)
DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE | Dosimetric Objective Evaluation Scope (3010,0063)
DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE | Dosimetric Objective Parameter Sequence (3010,0070)
DOSIMETRIC_OBJECTIVE_PURPOSE | Dosimetric Objective Purpose (3010,0075)
DOSIMETRIC_OBJECTIVE_SEQUENCE | Dosimetric Objective Sequence (3010,006C)
DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE | Dosimetric Objective Type Code Sequence (3010,006D)
DOSIMETRIC_OBJECTIVE_UID | Dosimetric Objective UID (3010,006E)
DOSIMETRIC_OBJECTIVE_WEIGHT | Dosimetric Objective Weight (3010,0074)
DOUBLE_EXPOSURE_FIELD_DELTA | Double Exposure Field Delta (0074,133A)
DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED | Double Exposure Field Delta (Trial) RETIRED (0074,103A)
DOUBLE_EXPOSURE_FLAG | Double Exposure Flag (0074,1034)
DOUBLE_EXPOSURE_METERSET | Double Exposure Meterset (0074,1338)
DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED | Double Exposure Meterset (Trial) RETIRED (0074,1038)
DOUBLE_EXPOSURE_ORDERING | Double Exposure Ordering (0074,1036)
DOUBLE_FLOAT_PIXEL_DATA | Double Float Pixel Data (7FE0,0009)
DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT | Double Float Pixel Padding Range Limit (0028,0125)
DOUBLE_FLOAT_PIXEL_PADDING_VALUE | Double Float Pixel Padding Value (0028,0123)
DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED | Double Float Real World Value First Value Mapped (0040,9214)
DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED | Double Float Real World Value Last Value Mapped (0040,9213)
DOUBLE_POINT_COORDINATES_DATA | Double Point Coordinates Data (0066,0022)
DVH_DATA | DVH Data (3004,0058)
DVH_DOSE_SCALING | DVH Dose Scaling (3004,0052)
DVH_MAXIMUM_DOSE | DVH Maximum Dose (3004,0072)
DVH_MEAN_DOSE | DVH Mean Dose (3004,0074)
DVH_MINIMUM_DOSE | DVH Minimum Dose (3004,0070)
DVH_NORMALIZATION_DOSE_VALUE | DVH Normalization Dose Value (3004,0042)
DVH_NORMALIZATION_POINT | DVH Normalization Point (3004,0040)
DVH_NUMBER_OF_BINS | DVH Number of Bins (3004,0056)
DVH_REFERENCED_ROI_SEQUENCE | DVH Referenced ROI Sequence (3004,0060)
DVH_ROI_CONTRIBUTION_TYPE | DVH ROI Contribution Type (3004,0062)
DVH_SEQUENCE | DVH Sequence (3004,0050)
DVH_TYPE | DVH Type (3004,0001)
DVH_VOLUME_UNITS | DVH Volume Units (3004,0054)
DYNAMIC_RANGE_RETIRED | Dynamic Range RETIRED (0018,5030)
ECHO_NUMBERS | Echo Number(s) (0018,0086)
ECHO_PEAK_POSITION | Echo Peak Position (0018,9298)
ECHO_PLANAR_PULSE_SEQUENCE | Echo Planar Pulse Sequence (0018,9018)
ECHO_PULSE_SEQUENCE | Echo Pulse Sequence (0018,9008)
ECHO_TIME | Echo Time (0018,0081)
ECHO_TRAIN_LENGTH | Echo Train Length (0018,0091)
EDGE_POINT_INDEX_LIST_RETIRED | Edge Point Index List RETIRED (0066,0024)
EFFECTIVE_BIN_ENERGY | Effective Bin Energy (0018,936E)
EFFECTIVE_DATETIME | Effective DateTime (0068,6226)
EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE | Effective Dose Calculation Method Category Code Sequence (3010,0003)
EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE | Effective Dose Calculation Method Code Sequence (3010,0004)
EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION | Effective Dose Calculation Method Description (3010,0005)
EFFECTIVE_DURATION | Effective Duration (0018,0072)
EFFECTIVE_ECHO_TIME | Effective Echo Time (0018,9082)
EFFECTIVE_REFRACTIVE_INDEX | Effective Refractive Index (0052,0004)
EFFECTIVE_SERIES_DURATION | Alias for tag EFFECTIVE_DURATION (0018,0072)
EFFECTIVE_WEDGE_ANGLE | Effective Wedge Angle (300A,00DE)
ELEMENT_DIMENSION_A | Element Dimension A (0014,4014)
ELEMENT_DIMENSION_B | Element Dimension B (0014,4015)
ELEMENT_PITCH_A | Element Pitch A (0014,4016)
ELEMENT_PITCH_B | Element Pitch B (0014,401D)
ELEMENT_SHAPE | Element Shape (0014,4013)
EMITTER_COLOR_TEMPERATURE | Emitter Color Temperature (0016,1002)
EMMETROPIC_MAGNIFICATION | Emmetropic Magnification (0022,000A)
EMPTY_IMAGE_BOX_CIELAB_VALUE | Empty Image Box CIELab Value (0072,0421)
EMPTY_IMAGE_DENSITY | Empty Image Density (2010,0110)
EMPTY_VALUE_MATCHING_SEQUENCE | Empty Value Matching Sequence (0008,0412)
ENCAPSULATED_DOCUMENT | Encapsulated Document (0042,0011)
ENCAPSULATED_DOCUMENT_LENGTH | Encapsulated Document Length (0042,0015)
ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH | Encapsulated Pixel Data Value Total Length (7FE0,0003)
ENCRYPTED_ATTRIBUTES_SEQUENCE | Encrypted Attributes Sequence (0400,0500)
ENCRYPTED_CONTENT | Encrypted Content (0400,0520)
ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID | Encrypted Content Transfer Syntax UID (0400,0510)
END_ACQUISITION_DATETIME | End Acquisition DateTime (0018,9517)
END_CUMULATIVE_METERSET_WEIGHT | End Cumulative Meterset Weight (300C,0009)
END_CUMULATIVE_TIME_WEIGHT | End Cumulative Time Weight (0074,1408)
END_MESSAGE_ID_RETIRED | End Message ID RETIRED (0000,5020)
END_METERSET | End Meterset (3008,007A)
ENDING_RESPIRATORY_AMPLITUDE | Ending Respiratory Amplitude (0020,9248)
ENDING_RESPIRATORY_PHASE | Ending Respiratory Phase (0020,9249)
ENERGY_DERIVATION_CODE_SEQUENCE | Energy Derivation Code Sequence (3002,0133)
ENERGY_UNIT_CODE_SEQUENCE | Energy Unit Code Sequence (300A,0684)
ENERGY_WEIGHTING_FACTOR | Energy Weighting Factor (0018,9353)
ENERGY_WINDOW_CENTERLINE_RETIRED | Energy Window Centerline RETIRED (0018,0032)
ENERGY_WINDOW_INFORMATION_SEQUENCE | Energy Window Information Sequence (0054,0012)
ENERGY_WINDOW_LOWER_LIMIT | Energy Window Lower Limit (0054,0014)
ENERGY_WINDOW_NAME | Energy Window Name (0054,0018)
ENERGY_WINDOW_NUMBER | Energy Window Number (0054,0308)
ENERGY_WINDOW_RANGE_SEQUENCE | Energy Window Range Sequence (0054,0013)
ENERGY_WINDOW_TOTAL_WIDTH_RETIRED | Energy Window Total Width RETIRED (0018,0033)
ENERGY_WINDOW_UPPER_LIMIT | Energy Window Upper Limit (0054,0015)
ENERGY_WINDOW_VECTOR | Energy Window Vector (0054,0010)
ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE | Enhanced Palette Color Lookup Table Sequence (0028,140B)
ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG | Enhanced RT Beam Limiting Device Definition Flag (3008,00A3)
ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE | Enhanced RT Beam Limiting Device Sequence (3008,00A1)
ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE | Enhanced RT Beam Limiting Opening Sequence (3008,00A2)
ENTITY_DESCRIPTION | Entity Description (3010,0037)
ENTITY_LABEL | Entity Label (3010,0035)
ENTITY_LONG_LABEL | Entity Long Label (3010,0038)
ENTITY_NAME | Entity Name (3010,0036)
ENTRANCE_DOSE | Entrance Dose (0040,0302)
ENTRANCE_DOSE_DERIVATION | Entrance Dose Derivation (0040,8303)
ENTRANCE_DOSE_IN_MGY | Entrance Dose in mGy (0040,8302)
ENVIRONMENTAL_CONDITIONS | Environmental Conditions (0014,1040)
EQUIPMENT_ADMINISTRATOR_SEQUENCE | Equipment Administrator Sequence (0028,7000)
EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION | Equipment Coordinate System Identification (0028,9537)
EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION | Equipment Frame of Reference Description (300A,0676)
EQUIPMENT_FRAME_OF_REFERENCE_UID | Equipment Frame of Reference UID (300A,0675)
EQUIPMENT_MODALITY | Equipment Modality (0008,0221)
EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE | Equipment Reference Point Code Sequence (300A,0678)
EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE | Equipment Reference Point Coordinates Sequence (300A,0677)
EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED | Equivalent CDA Document Sequence RETIRED (0040,A090)
EQUIVALENT_CODE_SEQUENCE | Equivalent Code Sequence (0008,0121)
EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE | Equivalent Conceptual Volume Instance Reference Sequence (3010,0009)
EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE | Equivalent Conceptual Volumes Sequence (3010,000A)
EQUIVALENT_PUPIL_RADIUS | Equivalent Pupil Radius (0046,0205)
ERASE_RETIRED | Erase RETIRED (0000,5190)
ERROR_COMMENT | Error Comment (0000,0902)
ERROR_ID | Error ID (0000,0903)
ESTIMATED_DOSE_SAVING_RETIRED | Estimated Dose Saving RETIRED (0018,9324)
ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR | Estimated Radiographic Magnification Factor (0018,1114)
ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE | Ethics Committee Approval Effectiveness End Date (0012,0087)
ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE | Ethics Committee Approval Effectiveness Start Date (0012,0086)
ETHNIC_GROUP | Ethnic Group (0010,2160)
EVALUATION_ATTEMPT | Evaluation Attempt (0014,2008)
EVALUATOR_NAME | Evaluator Name (0014,2006)
EVALUATOR_NUMBER | Evaluator Number (0014,2004)
EVALUATOR_SEQUENCE | Evaluator Sequence (0014,2002)
EVENT_CODE_SEQUENCE | Event Code Sequence (0008,2135)
EVENT_ELAPSED_TIMES | Event Elapsed Time(s) (0008,2130)
EVENT_TIME_OFFSET | Event Time Offset (0008,2134)
EVENT_TIMER_NAMES | Event Timer Name(s) (0008,2132)
EVENT_TIMER_SEQUENCE | Event Timer Sequence (0008,2133)
EVENT_TYPE_ID | Event Type ID (0000,1002)
EXAMINED_BODY_THICKNESS | Examined Body Thickness (0010,9431)
EXCESSIVE_FALSE_NEGATIVES | Excessive False Negatives (0024,0052)
EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG | Excessive False Negatives Data Flag (0024,0051)
EXCESSIVE_FALSE_POSITIVES | Excessive False Positives (0024,0062)
EXCESSIVE_FALSE_POSITIVES_DATA_FLAG | Excessive False Positives Data Flag (0024,0061)
EXCESSIVE_FIXATION_LOSSES | Excessive Fixation Losses (0024,0040)
EXCESSIVE_FIXATION_LOSSES_DATA_FLAG | Excessive Fixation Losses Data Flag (0024,0039)
EXCITATION_ENERGY | Excitation Energy (0018,9823)
EXCITATION_FREQUENCY | Excitation Frequency (0014,4024)
EXCITATION_PULSE_DURATION | Excitation Pulse Duration (0018,9824)
EXCITATION_SPECTRAL_WIDTH | Excitation Spectral Width (0018,9822)
EXCITATION_WAVELENGTH | Excitation Wavelength (0018,9826)
EXCITATION_WAVELENGTH_SEQUENCE | Excitation Wavelength Sequence (0018,9825)
EXCLUDED_INTERVALS_SEQUENCE | Excluded Intervals Sequence (0018,9803)
EXCLUSION_DURATION | Exclusion Duration (0018,9805)
EXCLUSION_START_DATETIME | Exclusion Start DateTime (0018,9804)
EXCLUSIVE_COMPONENT_TYPE | Exclusive Component Type (0076,0036)
EXECUTION_STATUS | Execution Status (2100,0020)
EXECUTION_STATUS_INFO | Execution Status Info (2100,0030)
EXIF_VERSION | EXIF Version (0016,0020)
EXPECTED_COMPLETION_DATE_AND_TIME | Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)
EXPECTED_COMPLETION_DATE_TIME | Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)
EXPECTED_COMPLETION_DATETIME | Expected Completion DateTime (0040,4011)
EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX | Expected In-Vivo Measurement Value Index (300A,0622)
EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE | Expected In-Vivo Measurement Values Sequence (300A,0621)
EXPIRATION_DATETIME | Expiration DateTime (0008,0416)
EXPIRY_DATE | Expiry Date (0014,1020)
EXPOSED_AREA | Exposed Area (0040,0303)
EXPOSURE | Exposure (0018,1152)
EXPOSURE_BIAS_VALUE | Exposure Bias Value (0016,0024)
EXPOSURE_CONTROL_MODE | Exposure Control Mode (0018,7060)
EXPOSURE_CONTROL_MODE_DESCRIPTION | Exposure Control Mode Description (0018,7062)
EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE | Exposure Control Sensing Region Left Vertical Edge (0018,9436)
EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE | Exposure Control Sensing Region Lower Horizontal Edge (0018,9439)
EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE | Exposure Control Sensing Region Right Vertical Edge (0018,9437)
EXPOSURE_CONTROL_SENSING_REGION_SHAPE | Exposure Control Sensing Region Shape (0018,9435)
EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE | Exposure Control Sensing Region Upper Horizontal Edge (0018,9438)
EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE | Exposure Control Sensing Regions Sequence (0018,9434)
EXPOSURE_DOSE_SEQUENCE_RETIRED | Exposure Dose Sequence RETIRED (0040,030E)
EXPOSURE_IN_MAS | Exposure in mAs (0018,9332)
EXPOSURE_IN_UAS | Exposure in uAs (0018,1153)
EXPOSURE_INDEX | Exposure Index (0018,1411)
EXPOSURE_MODE | Exposure Mode (0016,0042)
EXPOSURE_MODULATION_TYPE | Exposure Modulation Type (0018,9323)
EXPOSURE_PROGRAM | Exposure Program (0016,0016)
EXPOSURE_SEQUENCE | Exposure Sequence (3002,0030)
EXPOSURE_STATUS | Exposure Status (0018,7064)
EXPOSURE_TIME | Exposure Time (0018,1150)
EXPOSURE_TIME_IN_MS | Exposure Time in ms (0018,9328)
EXPOSURE_TIME_IN_SECONDS | Exposure Time in Seconds (0016,0004)
EXPOSURE_TIME_IN_US | Exposure Time in uS (0018,8150)
EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION | Exposures on Detector Since Last Calibration (0018,7010)
EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED | Exposures on Detector Since Manufactured (0018,7011)
EXPOSURES_ON_PLATE | Exposures on Plate (0018,1404)
EXTENDED_DEPTH_OF_FIELD | Extended Depth of Field (0048,0012)
EXTENDED_MATCHING_MECHANISMS | Extended Matching Mechanisms (0008,040F)
EXTENDED_OFFSET_TABLE | Extended Offset Table (7FE0,0001)
EXTENDED_OFFSET_TABLE_LENGTHS | Extended Offset Table Lengths (7FE0,0002)
EXTERNAL_CONTOUR_ENTRY_POINT | External Contour Entry Point (300A,0133)
F_NUMBER | F-Number (0016,0005)
FACET_SEQUENCE | Facet Sequence (0066,0034)
FAILED_ATTRIBUTES_SEQUENCE | Failed Attributes Sequence (0074,1048)
FAILED_SOP_INSTANCE_UID_LIST | Failed SOP Instance UID List (0008,0058)
FAILED_SOP_SEQUENCE | Failed SOP Sequence (0008,1198)
FAILURE_ATTRIBUTES | Failure Attributes (2200,000E)
FAILURE_REASON | Failure Reason (0008,1197)
FALSE_NEGATIVES_ESTIMATE | False Negatives Estimate (0024,0046)
FALSE_NEGATIVES_ESTIMATE_FLAG | False Negatives Estimate Flag (0024,0045)
FALSE_NEGATIVES_QUANTITY | False Negatives Quantity (0024,0050)
FALSE_POSITIVES_ESTIMATE | False Positives Estimate (0024,0054)
FALSE_POSITIVES_ESTIMATE_FLAG | False Positives Estimate Flag (0024,0053)
FALSE_POSITIVES_QUANTITY | False Positives Quantity (0024,0060)
FIDUCIAL_DESCRIPTION | Fiducial Description (0070,030F)
FIDUCIAL_IDENTIFIER | Fiducial Identifier (0070,0310)
FIDUCIAL_IDENTIFIER_CODE_SEQUENCE | Fiducial Identifier Code Sequence (0070,0311)
FIDUCIAL_SEQUENCE | Fiducial Sequence (0070,031E)
FIDUCIAL_SET_SEQUENCE | Fiducial Set Sequence (0070,031C)
FIDUCIAL_UID | Fiducial UID (0070,031A)
FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE | Fiducials Property Category Code Sequence (0070,031F)
FIELD_OF_VIEW_DESCRIPTION | Field of View Description (0018,9433)
FIELD_OF_VIEW_DIMENSIONS | Field of View Dimension(s) (0018,1149)
FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT | Field of View Dimension(s) in Float (0018,9461)
FIELD_OF_VIEW_HORIZONTAL_FLIP | Field of View Horizontal Flip (0018,7034)
FIELD_OF_VIEW_ORIGIN | Field of View Origin (0018,7030)
FIELD_OF_VIEW_ROTATION | Field of View Rotation (0018,7032)
FIELD_OF_VIEW_SEQUENCE | Field of View Sequence (0018,9432)
FIELD_OF_VIEW_SHAPE | Field of View Shape (0018,1147)
FILE_ACCESS_SEQUENCE | File Access Sequence (0008,041A)
FILE_ACCESS_URI | File Access URI (0008,0409)
FILE_LENGTH_IN_CONTAINER | File Length in Container (0008,040D)
FILE_META_INFORMATION_GROUP_LENGTH | File Meta Information Group Length (0002,0000)
FILE_META_INFORMATION_VERSION | File Meta Information Version (0002,0001)
FILE_OFFSET_IN_CONTAINER | File Offset in Container (0008,040C)
FILE_SET_ACCESS_SEQUENCE | File Set Access Sequence (0008,0419)
FILE_SET_CONSISTENCY_FLAG | File-set Consistency Flag (0004,1212)
FILE_SET_DESCRIPTOR_FILE_ID | File-set Descriptor File ID (0004,1141)
FILE_SET_ID | File-set ID (0004,1130)
FILE_SOURCE | File Source (0016,003A)
FILENAME_IN_CONTAINER | Filename in Container (0008,040B)
FILL_MODE | Fill Mode (0070,0257)
FILL_PATTERN | Fill Pattern (0070,0256)
FILL_STYLE_SEQUENCE | Fill Style Sequence (0070,0233)
FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST | Filler Order Number / Imaging Service Request (0040,2017)
FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED | Filler Order Number Imaging Service Request (Retired) (0040,2007)
FILLER_ORDER_NUMBER_PROCEDURE_RETIRED | Filler Order Number / Procedure RETIRED (0040,1007)
FILM_BOX_CONTENT_SEQUENCE_RETIRED | Film Box Content Sequence RETIRED (2130,0030)
FILM_CONSUMPTION_SEQUENCE | Film Consumption Sequence (0040,0321)
FILM_DESTINATION | Film Destination (2000,0040)
FILM_ORIENTATION | Film Orientation (2010,0040)
FILM_SESSION_LABEL | Film Session Label (2000,0050)
FILM_SIZE_ID | Film Size ID (2010,0050)
FILTER_BEAM_PATH_LENGTH_MAXIMUM | Filter Beam Path Length Maximum (0018,7058)
FILTER_BEAM_PATH_LENGTH_MINIMUM | Filter Beam Path Length Minimum (0018,7056)
FILTER_BY_ATTRIBUTE_PRESENCE | Filter-by Attribute Presence (0072,0404)
FILTER_BY_CATEGORY | Filter-by Category (0072,0402)
FILTER_BY_OPERATOR | Filter-by Operator (0072,0406)
FILTER_HIGH_FREQUENCY | Filter High Frequency (003A,0221)
FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE | Filter High Frequency Characteristics Sequence (003A,0319)
FILTER_LOOKUP_TABLE_DATA | Filter Lookup Table Data (003A,032E)
FILTER_LOOKUP_TABLE_DESCRIPTION | Filter Lookup Table Description (003A,032B)
FILTER_LOOKUP_TABLE_SEQUENCE | Filter Lookup Table Sequence (003A,032A)
FILTER_LOW_FREQUENCY | Filter Low Frequency (003A,0220)
FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE | Filter Low Frequency Characteristics Sequence (003A,0318)
FILTER_MATERIAL | Filter Material (0018,7050)
FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION | Filter Material Used in Gain Calibration (0014,3074)
FILTER_OPERATIONS_SEQUENCE | Filter Operations Sequence (0072,0400)
FILTER_THICKNESS_MAXIMUM | Filter Thickness Maximum (0018,7054)
FILTER_THICKNESS_MINIMUM | Filter Thickness Minimum (0018,7052)
FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION | Filter Thickness Used in Gain Calibration (0014,3075)
FILTER_TYPE | Filter Type (0018,1160)
FINAL_CUMULATIVE_METERSET_WEIGHT | Final Cumulative Meterset Weight (300A,010E)
FINAL_CUMULATIVE_TIME_WEIGHT | Final Cumulative Time Weight (300A,02C8)
FIND_LOCATION_RETIRED | Find Location RETIRED (0000,0400)
FINDINGS_FLAG_TRIAL_RETIRED | Findings Flag (Trial) RETIRED (0040,A007)
FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED | Findings Group Recording Date (Trial) RETIRED (0040,A023)
FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED | Findings Group Recording Time (Trial) RETIRED (0040,A024)
FINDINGS_GROUP_UID_TRIAL_RETIRED | Findings Group UID (Trial) RETIRED (0040,A021)
FINDINGS_SEQUENCE_TRIAL_RETIRED | Findings Sequence (Trial) RETIRED (0040,A020)
FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED | Findings Source Category Code Sequence (Trial) RETIRED (0040,A026)
FINITE_VOLUME | Finite Volume (0066,000E)
FIRST_A_LINE_LOCATION | First A-line Location (0052,0034)
FIRST_ORDER_PHASE_CORRECTION | First Order Phase Correction (0018,9198)
FIRST_ORDER_PHASE_CORRECTION_ANGLE | First Order Phase Correction Angle (5600,0010)
FIRST_TREATMENT_DATE | First Treatment Date (3008,0054)
FIXATION_CHECKED_QUANTITY | Fixation Checked Quantity (0024,0035)
FIXATION_DEVICE_DESCRIPTION | Fixation Device Description (300A,0196)
FIXATION_DEVICE_LABEL | Fixation Device Label (300A,0194)
FIXATION_DEVICE_PITCH_ANGLE | Fixation Device Pitch Angle (300A,0199)
FIXATION_DEVICE_POSITION | Fixation Device Position (300A,0198)
FIXATION_DEVICE_ROLL_ANGLE | Fixation Device Roll Angle (300A,019A)
FIXATION_DEVICE_SEQUENCE | Fixation Device Sequence (300A,0190)
FIXATION_DEVICE_TYPE | Fixation Device Type (300A,0192)
FIXATION_EYE | Fixation Eye (300A,0150)
FIXATION_LIGHT_AZIMUTHAL_ANGLE | Fixation Light Azimuthal Angle (300A,0356)
FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE | Fixation Light Azimuthal Angle Tolerance (300A,0154)
FIXATION_LIGHT_POLAR_ANGLE | Fixation Light Polar Angle (300A,0358)
FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE | Fixation Light Polar Angle Tolerance (300A,0155)
FIXATION_METHOD_CODE_SEQUENCE | Fixation Method Code Sequence (0068,63AC)
FIXATION_MONITORING_CODE_SEQUENCE | Fixation Monitoring Code Sequence (0024,0033)
FIXATION_SEQUENCE | Fixation Sequence (0024,0032)
FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE | Fixed RT Beam Delimiter Device Sequence (300A,0646)
FLASH_ENERGY | Flash Energy (0016,0036)
FLASH_FIRING_STATUS | Flash Firing Status (0016,0011)
FLASH_FUNCTION_PRESENT | Flash Function Present (0016,0014)
FLASH_MODE | Flash Mode (0016,0013)
FLASH_RED_EYE_MODE | Flash Red Eye Mode (0016,0015)
FLASH_RETURN_STATUS | Flash Return Status (0016,0012)
FLAT_CORNEAL_AXIS_SEQUENCE | Flat Corneal Axis Sequence (0046,0113)
FLAT_KERATOMETRIC_AXIS_SEQUENCE | Flat Keratometric Axis Sequence (0046,0080)
FLIP_ANGLE | Flip Angle (0018,1314)
FLOAT_PIXEL_DATA | Float Pixel Data (7FE0,0008)
FLOAT_PIXEL_PADDING_RANGE_LIMIT | Float Pixel Padding Range Limit (0028,0124)
FLOAT_PIXEL_PADDING_VALUE | Float Pixel Padding Value (0028,0122)
FLOATING_POINT_VALUE | Floating Point Value (0040,A161)
FLOATING_POINT_VALUES | Floating Point Values (0066,0125)
FLOW_COMPENSATION | Flow Compensation (0018,9010)
FLOW_COMPENSATION_DIRECTION | Flow Compensation Direction (0018,9183)
FLOW_IDENTIFIER | Flow Identifier (0034,0002)
FLOW_IDENTIFIER_SEQUENCE | Flow Identifier Sequence (0034,0001)
FLOW_RTP_SAMPLING_RATE | Flow RTP Sampling Rate (0034,0004)
FLOW_TRANSFER_SYNTAX_UID | Flow Transfer Syntax UID (0034,0003)
FLUENCE_DATA_SCALE | Fluence Data Scale (3002,0042)
FLUENCE_DATA_SOURCE | Fluence Data Source (3002,0041)
FLUENCE_MAP_SEQUENCE | Fluence Map Sequence (3002,0040)
FLUENCE_MODE | Fluence Mode (3002,0051)
FLUENCE_MODE_ID | Fluence Mode ID (3002,0052)
FLUOROSCOPY_FLAG | Fluoroscopy Flag (0018,9334)
FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG | Fluoroscopy Last Image Hold Persistence Flag (0018,11B4)
FLUOROSCOPY_PERSISTENCE_FLAG | Fluoroscopy Persistence Flag (0018,11B3)
FOCAL_DISTANCE | Focal Distance (0018,1182)
FOCAL_LENGTH | Focal Length (0016,0029)
FOCAL_LENGTH_IN_35MM_FILM | Focal Length In 35mm Film (0016,0045)
FOCAL_SPOTS | Focal Spot(s) (0018,1190)
FOCUS_DEPTH | Focus Depth (0018,5012)
FOCUS_METHOD | Focus Method (0048,0011)
FOLDER_ACCESS_URI | Folder Access URI (0008,0408)
FONT_NAME | Font Name (0070,0227)
FONT_NAME_TYPE | Font Name Type (0070,0228)
FOVEAL_POINT_NORMATIVE_DATA_FLAG | Foveal Point Normative Data Flag (0024,0117)
FOVEAL_POINT_PROBABILITY_VALUE | Foveal Point Probability Value (0024,0118)
FOVEAL_SENSITIVITY | Foveal Sensitivity (0024,0087)
FOVEAL_SENSITIVITY_MEASURED | Foveal Sensitivity Measured (0024,0086)
FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR | Fraction-Based Relationship Interval Anchor (3010,0083)
FRACTION_BASED_RELATIONSHIP_SEQUENCE | Fraction-Based Relationship Sequence (3010,0082)
FRACTION_GROUP_DESCRIPTION | Fraction Group Description (300A,0072)
FRACTION_GROUP_NUMBER | Fraction Group Number (300A,0071)
FRACTION_GROUP_SEQUENCE | Fraction Group Sequence (300A,0070)
FRACTION_GROUP_SUMMARY_SEQUENCE | Fraction Group Summary Sequence (3008,0220)
FRACTION_GROUP_TYPE | Fraction Group Type (3008,0224)
FRACTION_NUMBER | Fraction Number (3002,0029)
FRACTION_PATTERN | Fraction Pattern (300A,007B)
FRACTION_PATTERN_SEQUENCE | Fraction Pattern Sequence (3010,0079)
FRACTION_STATUS_SUMMARY_SEQUENCE | Fraction Status Summary Sequence (3008,0240)
FRACTIONAL_BANDWIDTH | Fractional Bandwidth (0018,982E)
FRACTIONAL_CHANNEL_DISPLAY_SCALE | Fractional Channel Display Scale (003A,0247)
FRACTIONATION_NOTES | Fractionation Notes (3010,007F)
FRAME_ACQUISITION_DATETIME | Frame Acquisition DateTime (0018,9074)
FRAME_ACQUISITION_DURATION | Frame Acquisition Duration (0018,9220)
FRAME_ACQUISITION_NUMBER | Frame Acquisition Number (0020,9156)
FRAME_ACQUISITION_SEQUENCE | Frame Acquisition Sequence (0018,9417)
FRAME_ANATOMY_SEQUENCE | Frame Anatomy Sequence (0020,9071)
FRAME_COMMENTS | Frame Comments (0020,9158)
FRAME_CONTENT_SEQUENCE | Frame Content Sequence (0020,9111)
FRAME_DELAY | Frame Delay (0018,1066)
FRAME_DETECTOR_PARAMETERS_SEQUENCE | Frame Detector Parameters Sequence (0018,9451)
FRAME_DIMENSION_POINTER | Frame Dimension Pointer (0028,000A)
FRAME_DISPLAY_SEQUENCE | Frame Display Sequence (0008,9458)
FRAME_DISPLAY_SHUTTER_SEQUENCE | Frame Display Shutter Sequence (0018,9472)
FRAME_EXTRACTION_SEQUENCE | Frame Extraction Sequence (0008,1164)
FRAME_INCREMENT_POINTER | Frame Increment Pointer (0028,0009)
FRAME_LABEL | Frame Label (0020,9453)
FRAME_LABEL_VECTOR | Frame Label Vector (0018,2002)
FRAME_LATERALITY | Frame Laterality (0020,9072)
FRAME_NUMBERS_OF_INTEREST | Frame Numbers of Interest (0028,6020)
FRAME_NUMBERS_OF_INTEREST_FOI | Alias for tag FRAME_NUMBERS_OF_INTEREST (0028,6020)
FRAME_OF_INTEREST_DESCRIPTION | Frame of Interest Description (0028,6022)
FRAME_OF_INTEREST_TYPE | Frame of Interest Type (0028,6023)
FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED | Frame of Reference Relationship Sequence RETIRED (3006,00C0)
FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX | Frame of Reference to Displayed Coordinate System Transformation Matrix (0070,030B)
FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT | Frame of Reference Transformation Comment (3006,00C8)
FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX | Frame of Reference Transformation Matrix (3006,00C6)
FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE | Frame of Reference Transformation Matrix Type (0070,030C)
FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED | Frame of Reference Transformation Type RETIRED (3006,00C4)
FRAME_OF_REFERENCE_UID | Frame of Reference UID (0020,0052)
FRAME_ORIGIN_TIMESTAMP | Frame Origin Timestamp (0034,0007)
FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE | Frame Pixel Data Properties Sequence (0028,9443)
FRAME_PIXEL_SHIFT_SEQUENCE | Frame Pixel Shift Sequence (0028,9415)
FRAME_PRIMARY_ANGLE_VECTOR | Frame Primary Angle Vector (0018,2003)
FRAME_REFERENCE_DATETIME | Frame Reference DateTime (0018,9151)
FRAME_REFERENCE_TIME | Frame Reference Time (0054,1300)
FRAME_SECONDARY_ANGLE_VECTOR | Frame Secondary Angle Vector (0018,2004)
FRAME_TIME | Frame Time (0018,1063)
FRAME_TIME_VECTOR | Frame Time Vector (0018,1065)
FRAME_TYPE | Frame Type (0008,9007)
FRAME_USEFULNESS_GROUP_SEQUENCE | Frame Usefulness Group Sequence (0034,0009)
FRAME_VOI_LUT_SEQUENCE | Frame VOI LUT Sequence (0028,9132)
FRAMES_OF_INTEREST_DESCRIPTION | Alias for tag FRAME_OF_INTEREST_DESCRIPTION (0028,6022)
FRAMING_TYPE | Alias for tag CARDIAC_FRAMING_TYPE (0018,1064)
FREQUENCY_CORRECTION | Frequency Correction (0018,9101)
FREQUENCY_ENCODING_CODE_SEQUENCE | Frequency Encoding Code Sequence (003A,032C)
FUNCTIONAL_GROUP_POINTER | Functional Group Pointer (0020,9167)
FUNCTIONAL_GROUP_PRIVATE_CREATOR | Functional Group Private Creator (0020,9238)
FUNCTIONAL_MR_SEQUENCE | Functional MR Sequence (0018,9621)
FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT | Functional Settling Phase Frames Present (0018,9622)
FUNCTIONAL_SYNC_PULSE | Functional Sync Pulse (0018,9623)
GAIN_CONTROL | Gain Control (0016,0047)
GAIN_CORRECTION_REFERENCE_SEQUENCE | Gain Correction Reference Sequence (0014,3060)
GAMMA_VALUE | Gamma Value (0028,701A)
GANTRY_ANGLE | Gantry Angle (300A,011E)
GANTRY_ANGLE_TOLERANCE | Gantry Angle Tolerance (300A,0044)
GANTRY_DETECTOR_SLEW | Gantry/Detector Slew (0018,1121)
GANTRY_DETECTOR_TILT | Gantry/Detector Tilt (0018,1120)
GANTRY_ID | Gantry ID (0018,1008)
GANTRY_MOTION_CORRECTED | Gantry Motion Corrected (0018,9762)
GANTRY_PITCH_ANGLE | Gantry Pitch Angle (300A,014A)
GANTRY_PITCH_ANGLE_TOLERANCE | Gantry Pitch Angle Tolerance (300A,014E)
GANTRY_PITCH_ROTATION_DIRECTION | Gantry Pitch Rotation Direction (300A,014C)
GANTRY_ROTATION_DIRECTION | Gantry Rotation Direction (300A,011F)
GANTRY_TYPE | Gantry Type (4010,1008)
GAP_LENGTH | Gap Length (0070,0261)
GATE_SETTINGS_SEQUENCE | Gate Settings Sequence (0014,4060)
GATE_THRESHOLD | Gate Threshold (0014,4062)
GATED_INFORMATION_SEQUENCE | Gated Information Sequence (0054,0062)
GATING_BEAM_HOLD_TRANSITION_SEQUENCE | Gating Beam Hold Transition Sequence (300C,0125)
GENERAL_ACCESSORY_DEFINITION_SEQUENCE | General Accessory Definition Sequence (300A,0671)
GENERAL_ACCESSORY_DESCRIPTION | General Accessory Description (300A,0422)
GENERAL_ACCESSORY_ID | General Accessory ID (300A,0421)
GENERAL_ACCESSORY_NUMBER | General Accessory Number (300A,0424)
GENERAL_ACCESSORY_SEQUENCE | General Accessory Sequence (300A,0420)
GENERAL_ACCESSORY_TYPE | General Accessory Type (300A,0423)
GENERAL_MACHINE_VERIFICATION_SEQUENCE | General Machine Verification Sequence (0074,1042)
GENERAL_MATCHING_SEQUENCE | General Matching Sequence (0008,0413)
GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED | General Purpose Performed Procedure Step Status RETIRED (0040,4002)
GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED | General Purpose Scheduled Procedure Step Priority RETIRED (0040,4003)
GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED | General Purpose Scheduled Procedure Step Status RETIRED (0040,4001)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG | Generalized Defect Corrected Sensitivity Deviation Flag (0024,0102)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE | Generalized Defect Corrected Sensitivity Deviation Probability Value (0024,0104)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE | Generalized Defect Corrected Sensitivity Deviation Value (0024,0103)
GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE | Generalized Defect Sensitivity Deviation Algorithm Sequence (0024,0067)
GENERATOR_ID | Generator ID (0018,1005)
GENERATOR_POWER | Generator Power (0018,1170)
GENETIC_MODIFICATIONS_CODE_SEQUENCE | Genetic Modifications Code Sequence (0010,0229)
GENETIC_MODIFICATIONS_DESCRIPTION | Genetic Modifications Description (0010,0222)
GENETIC_MODIFICATIONS_NOMENCLATURE | Genetic Modifications Nomenclature (0010,0223)
GENETIC_MODIFICATIONS_SEQUENCE | Genetic Modifications Sequence (0010,0221)
GEOMETRIC_MAXIMUM_DISTORTION | Geometric Maximum Distortion (0028,9445)
GEOMETRICAL_PROPERTIES | Geometrical Properties (0028,9444)
GEOMETRY_FOR_DISPLAY | Geometry for Display (0070,1B08)
GEOMETRY_OF_K_SPACE_TRAVERSAL | Geometry of k-Space Traversal (0018,9032)
GLOBAL_CROP | Global Crop (0070,120B)
GLOBAL_CROPPING_SPECIFICATION_INDEX | Global Cropping Specification Index (0070,120C)
GLOBAL_DEVIATION_FROM_NORMAL | Global Deviation From Normal (0024,0066)
GLOBAL_DEVIATION_PROBABILITY | Global Deviation Probability (0024,0071)
GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG | Global Deviation Probability Normals Flag (0024,0059)
GLOBAL_DEVIATION_PROBABILITY_SEQUENCE | Global Deviation Probability Sequence (0024,0083)
GPS_ALTITUDE | GPS Altitude (0016,0076)
GPS_ALTITUDE_REF | GPS Altitude Ref (0016,0075)
GPS_AREA_INFORMATION | GPS Area Information (0016,008C)
GPS_DATE_STAMP | GPS Date Stamp (0016,008D)
GPS_DEST_BEARING | GPS Dest Bearing (0016,0088)
GPS_DEST_BEARING_REF | GPS Dest Bearing Ref (0016,0087)
GPS_DEST_DISTANCE | GPS Dest Distance (0016,008A)
GPS_DEST_DISTANCE_REF | GPS Dest Distance Ref (0016,0089)
GPS_DEST_LATITUDE | GPS Dest Latitude (0016,0084)
GPS_DEST_LATITUDE_REF | GPS Dest Latitude Ref (0016,0083)
GPS_DEST_LONGITUDE | GPS Dest Longitude (0016,0086)
GPS_DEST_LONGITUDE_REF | GPS Dest Longitude Ref (0016,0085)
GPS_DIFFERENTIAL | GPS Differential (0016,008E)
GPS_DOP | GPS DOP (0016,007B)
GPS_IMG_DIRECTION | GPS Img Direction (0016,0081)
GPS_IMG_DIRECTION_REF | GPS Img Direction Ref (0016,0080)
GPS_LATITUDE | GPS Latitude (0016,0072)
GPS_LATITUDE_REF | GPS Latitude Ref (0016,0071)
GPS_LONGITUDE | GPS Longitude (0016,0074)
GPS_LONGITUDE_REF | GPS Longitude Ref (0016,0073)
GPS_MAP_DATUM | GPS Map Datum (0016,0082)
GPS_MEASURE_MODE | GPS Measure Mode (0016,007A)
GPS_PROCESSING_METHOD | GPS Processing Method (0016,008B)
GPS_SATELLITES | GPS Satellites (0016,0078)
GPS_SPEED | GPS Speed (0016,007D)
GPS_SPEED_REF | GPS Speed Ref (0016,007C)
GPS_STATUS | GPS Status (0016,0079)
GPS_TIME_STAMP | GPS Time Stamp (0016,0077)
GPS_TRACK | GPS Track (0016,007F)
GPS_TRACK_REF | GPS Track Ref (0016,007E)
GPS_VERSION_ID | GPS Version ID (0016,0070)
GRADIENT_ECHO_TRAIN_LENGTH | Gradient Echo Train Length (0018,9241)
GRADIENT_OUTPUT | Gradient Output (0018,9182)
GRADIENT_OUTPUT_TYPE | Gradient Output Type (0018,9180)
GRAPHIC_ANNOTATION_SEQUENCE | Graphic Annotation Sequence (0070,0001)
GRAPHIC_ANNOTATION_UNITS | Graphic Annotation Units (0070,0005)
GRAPHIC_COORDINATES_DATA_SEQUENCE | Graphic Coordinates Data Sequence (0070,0318)
GRAPHIC_DATA | Graphic Data (0070,0022)
GRAPHIC_DIMENSIONS | Graphic Dimensions (0070,0020)
GRAPHIC_FILLED | Graphic Filled (0070,0024)
GRAPHIC_GROUP_DESCRIPTION | Graphic Group Description (0070,0208)
GRAPHIC_GROUP_ID | Graphic Group ID (0070,0295)
GRAPHIC_GROUP_LABEL | Graphic Group Label (0070,0207)
GRAPHIC_GROUP_SEQUENCE | Graphic Group Sequence (0070,0234)
GRAPHIC_LAYER | Graphic Layer (0070,0002)
GRAPHIC_LAYER_DESCRIPTION | Graphic Layer Description (0070,0068)
GRAPHIC_LAYER_ORDER | Graphic Layer Order (0070,0062)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE | Graphic Layer Recommended Display CIELab Value (0070,0401)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE | Graphic Layer Recommended Display Grayscale Value (0070,0066)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED | Graphic Layer Recommended Display RGB Value RETIRED (0070,0067)
GRAPHIC_LAYER_SEQUENCE | Graphic Layer Sequence (0070,0060)
GRAPHIC_OBJECT_SEQUENCE | Graphic Object Sequence (0070,0009)
GRAPHIC_TYPE | Graphic Type (0070,0023)
GRAY_LOOKUP_TABLE_DATA_RETIRED | Gray Lookup Table Data RETIRED (0028,1200)
GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED | Gray Lookup Table Descriptor RETIRED (0028,1100)
GRAY_SCALE_RETIRED | Gray Scale RETIRED (0028,1080)
GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA | Green Palette Color Lookup Table Data (0028,1202)
GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Green Palette Color Lookup Table Descriptor (0028,1102)
GRID | Grid (0018,1166)
GRID_ABSORBING_MATERIAL | Grid Absorbing Material (0018,7040)
GRID_ASPECT_RATIO | Grid Aspect Ratio (0018,7046)
GRID_DIMENSIONS | Grid Dimensions (0064,0007)
GRID_FOCAL_DISTANCE | Grid Focal Distance (0018,704C)
GRID_FRAME_OFFSET_VECTOR | Grid Frame Offset Vector (3004,000C)
GRID_ID | Grid ID (0018,1006)
GRID_PERIOD | Grid Period (0018,7048)
GRID_PITCH | Grid Pitch (0018,7044)
GRID_RESOLUTION | Grid Resolution (0064,0008)
GRID_SPACING_MATERIAL | Grid Spacing Material (0018,7041)
GRID_THICKNESS | Grid Thickness (0018,7042)
GROUP_0000_LENGTH | Alias for tag COMMAND_GROUP_LENGTH (0000,0000)
GROUP_0002_LENGTH | Alias for tag FILE_META_INFORMATION_GROUP_LENGTH (0002,0000)
GROUP_0008_LENGTH_RETIRED | Group 0008 Length RETIRED (0008,0000)
GROUP_0010_LENGTH_RETIRED | Group 0010 Length RETIRED (0010,0000)
GROUP_0012_LENGTH_RETIRED | Group 0012 Length RETIRED (0012,0000)
GROUP_0018_LENGTH_RETIRED | Group 0018 Length RETIRED (0018,0000)
GROUP_0020_LENGTH_RETIRED | Group 0020 Length RETIRED (0020,0000)
GROUP_0022_LENGTH_RETIRED | Group 0022 Length RETIRED (0022,0000)
GROUP_0028_LENGTH_RETIRED | Group 0028 Length RETIRED (0028,0000)
GROUP_0032_LENGTH_RETIRED | Group 0032 Length RETIRED (0032,0000)
GROUP_0038_LENGTH_RETIRED | Group 0038 Length RETIRED (0038,0000)
GROUP_003A_LENGTH_RETIRED | Group 003A Length RETIRED (003A,0000)
GROUP_0040_LENGTH_RETIRED | Group 0040 Length RETIRED (0040,0000)
GROUP_0042_LENGTH_RETIRED | Group 0042 Length RETIRED (0042,0000)
GROUP_0044_LENGTH_RETIRED | Group 0044 Length RETIRED (0044,0000)
GROUP_0050_LENGTH_RETIRED | Group 0050 Length RETIRED (0050,0000)
GROUP_0054_LENGTH_RETIRED | Group 0054 Length RETIRED (0054,0000)
GROUP_0060_LENGTH_RETIRED | Group 0060 Length RETIRED (0060,0000)
GROUP_0062_LENGTH_RETIRED | Group 0062 Length RETIRED (0062,0000)
GROUP_0064_LENGTH_RETIRED | Group 0064 Length RETIRED (0064,0000)
GROUP_0070_LENGTH_RETIRED | Group 0070 Length RETIRED (0070,0000)
GROUP_0072_LENGTH_RETIRED | Group 0072 Length RETIRED (0072,0000)
GROUP_0088_LENGTH_RETIRED | Group 0088 Length RETIRED (0088,0000)
GROUP_0100_LENGTH_RETIRED | Group 0100 Length RETIRED (0100,0000)
GROUP_0400_LENGTH_RETIRED | Group 0400 Length RETIRED (0400,0000)
GROUP_2000_LENGTH_RETIRED | Group 2000 Length RETIRED (2000,0000)
GROUP_2010_LENGTH_RETIRED | Group 2010 Length RETIRED (2010,0000)
GROUP_2020_LENGTH_RETIRED | Group 2020 Length RETIRED (2020,0000)
GROUP_2030_LENGTH_RETIRED | Group 2030 Length RETIRED (2030,0000)
GROUP_2040_LENGTH_RETIRED | Group 2040 Length RETIRED (2040,0000)
GROUP_2050_LENGTH_RETIRED | Group 2050 Length RETIRED (2050,0000)
GROUP_2100_LENGTH_RETIRED | Group 2100 Length RETIRED (2100,0000)
GROUP_2110_LENGTH_RETIRED | Group 2110 Length RETIRED (2110,0000)
GROUP_2120_LENGTH_RETIRED | Group 2120 Length RETIRED (2120,0000)
GROUP_2130_LENGTH_RETIRED | Group 2130 Length RETIRED (2130,0000)
GROUP_2200_LENGTH_RETIRED | Group 2200 Length RETIRED (2200,0000)
GROUP_3002_LENGTH_RETIRED | Group 3002 Length RETIRED (3002,0000)
GROUP_3004_LENGTH_RETIRED | Group 3004 Length RETIRED (3004,0000)
GROUP_3006_LENGTH_RETIRED | Group 3006 Length RETIRED (3006,0000)
GROUP_3008_LENGTH_RETIRED | Group 3008 Length RETIRED (3008,0000)
GROUP_300A_LENGTH_RETIRED | Group 300A Length RETIRED (300A,0000)
GROUP_300C_LENGTH_RETIRED | Group 300C Length RETIRED (300C,0000)
GROUP_300E_LENGTH_RETIRED | Group 300E Length RETIRED (300E,0000)
GROUP_4000_LENGTH_RETIRED | Group 4000 Length RETIRED (4000,0000)
GROUP_4008_LENGTH_RETIRED | Group 4008 Length RETIRED (4008,0000)
GROUP_4FFE_LENGTH_RETIRED | Group 4FFE Length RETIRED (4FFE,0000)
GROUP_5000_LENGTH_RETIRED | Group 5000 Length RETIRED (5000,0000)
GROUP_5200_LENGTH_RETIRED | Group 5200 Length RETIRED (5200,0000)
GROUP_5400_LENGTH_RETIRED | Group 5400 Length RETIRED (5400,0000)
GROUP_5600_LENGTH_RETIRED | Group 5600 Length RETIRED (5600,0000)
GROUP_6000_LENGTH_RETIRED | Group 6000 Length RETIRED (6000,0000)
GROUP_7FE0_LENGTH_RETIRED | Group 7FE0 Length RETIRED (7FE0,0000)
GROUP_FFFA_LENGTH_RETIRED | Group FFFA Length RETIRED (FFFA,0000)
GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE | Group of Patients Identification Sequence (0010,0027)
HALF_VALUE_LAYER | Half Value Layer (0040,0314)
HANGING_PROTOCOL_CREATION_DATETIME | Hanging Protocol Creation DateTime (0072,000A)
HANGING_PROTOCOL_CREATOR | Hanging Protocol Creator (0072,0008)
HANGING_PROTOCOL_DEFINITION_SEQUENCE | Hanging Protocol Definition Sequence (0072,000C)
HANGING_PROTOCOL_DESCRIPTION | Hanging Protocol Description (0072,0004)
HANGING_PROTOCOL_LEVEL | Hanging Protocol Level (0072,0006)
HANGING_PROTOCOL_NAME | Hanging Protocol Name (0072,0002)
HANGING_PROTOCOL_USER_GROUP_NAME | Hanging Protocol User Group Name (0072,0010)
HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE | Hanging Protocol User Identification Code Sequence (0072,000E)
HARCOPY_DEVICE_SOFTWARE_VERSION | Alias for tag HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED (0018,101A)
HARDCOPY_CREATION_DEVICE_ID_RETIRED | Hardcopy Creation Device ID RETIRED (0018,1011)
HARDCOPY_DEVICE_MANUFACTURER_RETIRED | Hardcopy Device Manufacturer RETIRED (0018,1017)
HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED | Hardcopy Device Manufacturer's Model Name RETIRED (0018,101B)
HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED | Hardcopy Device Software Version RETIRED (0018,101A)
HEAD_FIXATION_ANGLE | Head Fixation Angle (300A,0148)
HEAD_FIXATION_ANGLE_TOLERANCE | Head Fixation Angle Tolerance (300A,0152)
HEART_RATE | Heart Rate (0018,1088)
HIGH_BIT | High Bit (0028,0102)
HIGH_DOSE_TECHNIQUE_TYPE | High-Dose Technique Type (300A,00C7)
HIGH_ENERGY_DETECTORS | High Energy Detectors (4010,0002)
HIGH_R_R_VALUE | High R-R Value (0018,1082)
HISTOGRAM_BIN_WIDTH | Histogram Bin Width (0060,3008)
HISTOGRAM_DATA | Histogram Data (0060,3020)
HISTOGRAM_EXPLANATION | Histogram Explanation (0060,3010)
HISTOGRAM_FIRST_BIN_VALUE | Histogram First Bin Value (0060,3004)
HISTOGRAM_LAST_BIN_VALUE | Histogram Last Bin Value (0060,3006)
HISTOGRAM_NUMBER_OF_BINS | Histogram Number of Bins (0060,3002)
HISTOGRAM_SEQUENCE | Histogram Sequence (0060,3000)
HL7_DOCUMENT_EFFECTIVE_TIME | HL7 Document Effective Time (0040,E004)
HL7_DOCUMENT_TYPE_CODE_SEQUENCE | HL7 Document Type Code Sequence (0040,E006)
HL7_INSTANCE_IDENTIFIER | HL7 Instance Identifier (0040,E001)
HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE | HL7 Structured Document Reference Sequence (0040,A390)
HOME_COMMUNITY_ID | Home Community ID (0040,E031)
HORIZONTAL_ALIGNMENT | Horizontal Alignment (0070,0242)
HORIZONTAL_FIELD_OF_VIEW | Horizontal Field of View (0022,000C)
HORIZONTAL_OFFSET_OF_SENSOR | Horizontal Offset of Sensor (0014,3024)
HORIZONTAL_PRISM_BASE | Horizontal Prism Base (0046,0032)
HORIZONTAL_PRISM_POWER | Horizontal Prism Power (0046,0030)
HPGL_CONTOUR_PEN_NUMBER | HPGL Contour Pen Number (0068,6310)
HPGL_DOCUMENT | HPGL Document (0068,6300)
HPGL_DOCUMENT_ID | HPGL Document ID (0068,62D0)
HPGL_DOCUMENT_LABEL | HPGL Document Label (0068,62D5)
HPGL_DOCUMENT_SCALING | HPGL Document Scaling (0068,62F2)
HPGL_DOCUMENT_SEQUENCE | HPGL Document Sequence (0068,62C0)
HPGL_PEN_DESCRIPTION | HPGL Pen Description (0068,6345)
HPGL_PEN_LABEL | HPGL Pen Label (0068,6340)
HPGL_PEN_NUMBER | HPGL Pen Number (0068,6330)
HPGL_PEN_SEQUENCE | HPGL Pen Sequence (0068,6320)
HUMAN_PERFORMER_CODE_SEQUENCE | Human Performer Code Sequence (0040,4009)
HUMAN_PERFORMERS_NAME | Human Performer's Name (0040,4037)
HUMAN_PERFORMERS_ORGANIZATION | Human Performer's Organization (0040,4036)
HUMIDITY | Humidity (0016,0031)
ICC_PROFILE | ICC Profile (0028,2000)
ICON_IMAGE | Alias for tag ICON_IMAGE_SEQUENCE (0088,0200)
ICON_IMAGE_SEQUENCE | Icon Image Sequence (0088,0200)
IDENTICAL_DOCUMENTS | Alias for tag IDENTICAL_DOCUMENTS_SEQUENCE (0040,A525)
IDENTICAL_DOCUMENTS_SEQUENCE | Identical Documents Sequence (0040,A525)
IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED | Identification Description (Trial) RETIRED (0040,A224)
IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Identifier Code Sequence (Trial) RETIRED (0040,A070)
IDENTIFIER_TYPE_CODE | Identifier Type Code (0040,0035)
IDENTIFYING_COMMENTS_RETIRED | Identifying Comments RETIRED (0008,4000)
IDENTIFYING_PRIVATE_ELEMENTS | Identifying Private Elements (0008,0306)
ILLUMINATION | Illumination (2010,015E)
ILLUMINATION_BANDWIDTH | Illumination Bandwidth (0022,0057)
ILLUMINATION_COLOR_CODE_SEQUENCE | Illumination Color Code Sequence (0048,0108)
ILLUMINATION_POWER | Illumination Power (0022,0056)
ILLUMINATION_TRANSLATION_FLAG | Illumination Translation Flag (0018,9828)
ILLUMINATION_TYPE_CODE_SEQUENCE | Illumination Type Code Sequence (0022,0016)
ILLUMINATION_WAVE_LENGTH | Illumination Wave Length (0022,0055)
ILLUMINATOR_TYPE_CODE_SEQUENCE | Illuminator Type Code Sequence (0048,0100)
IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT | Image and Fluoroscopy Area Dose Product (0018,115E)
IMAGE_BOX_CONTENT_SEQUENCE_RETIRED | Image Box Content Sequence RETIRED (2130,0040)
IMAGE_BOX_LARGE_SCROLL_AMOUNT | Image Box Large Scroll Amount (0072,0318)
IMAGE_BOX_LARGE_SCROLL_TYPE | Image Box Large Scroll Type (0072,0316)
IMAGE_BOX_LAYOUT_TYPE | Image Box Layout Type (0072,0304)
IMAGE_BOX_NUMBER | Image Box Number (0072,0302)
IMAGE_BOX_OVERLAP_PRIORITY | Image Box Overlap Priority (0072,0320)
IMAGE_BOX_POSITION | Image Box Position (2020,0010)
IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED | Image Box Presentation LUT Flag RETIRED (2000,006A)
IMAGE_BOX_SCROLL_DIRECTION | Image Box Scroll Direction (0072,0310)
IMAGE_BOX_SMALL_SCROLL_AMOUNT | Image Box Small Scroll Amount (0072,0314)
IMAGE_BOX_SMALL_SCROLL_TYPE | Image Box Small Scroll Type (0072,0312)
IMAGE_BOX_SYNCHRONIZATION_SEQUENCE | Image Box Synchronization Sequence (0072,0430)
IMAGE_BOX_TILE_HORIZONTAL_DIMENSION | Image Box Tile Horizontal Dimension (0072,0306)
IMAGE_BOX_TILE_VERTICAL_DIMENSION | Image Box Tile Vertical Dimension (0072,0308)
IMAGE_BOXES_SEQUENCE | Image Boxes Sequence (0072,0300)
IMAGE_CENTER_POINT_COORDINATES_SEQUENCE | Image Center Point Coordinates Sequence (0040,071A)
IMAGE_COMMENTS | Image Comments (0020,4000)
IMAGE_DATA_TYPE_CODE_SEQUENCE | Image Data Type Code Sequence (0018,9836)
IMAGE_DATA_TYPE_SEQUENCE | Image Data Type Sequence (0018,9807)
IMAGE_DATE | Alias for tag CONTENT_DATE (0008,0023)
IMAGE_DIMENSIONS_RETIRED | Image Dimensions RETIRED (0028,0005)
IMAGE_DISPLAY_FORMAT | Image Display Format (2010,0010)
IMAGE_FILTER | Image Filter (0018,9320)
IMAGE_FILTER_DESCRIPTION | Image Filter Description (0018,9941)
IMAGE_FILTER_DETAILS_SEQUENCE | Image Filter Details Sequence (0018,11BF)
IMAGE_FORMAT_RETIRED | Image Format RETIRED (0028,0040)
IMAGE_FRAME_ORIGIN | Image Frame Origin (6000,0051)
IMAGE_GEOMETRY_TYPE_RETIRED | Image Geometry Type RETIRED (0020,0070)
IMAGE_HORIZONTAL_FLIP | Image Horizontal Flip (0070,0041)
IMAGE_ID | Image ID (0054,0400)
IMAGE_INDEX | Image Index (0054,1330)
IMAGE_LATERALITY | Image Laterality (0020,0062)
IMAGE_LOCATION_RETIRED | Image Location RETIRED (0028,0200)
IMAGE_NUMBER | Alias for tag INSTANCE_NUMBER (0020,0013)
IMAGE_ORIENTATION_PATIENT | Image Orientation (Patient) (0020,0037)
IMAGE_ORIENTATION_RETIRED | Image Orientation RETIRED (0020,0035)
IMAGE_ORIENTATION_SLIDE | Image Orientation (Slide) (0048,0102)
IMAGE_ORIENTATION_VOLUME | Image Orientation (Volume) (0020,9302)
IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED | Image Overlay Box Content Sequence RETIRED (2130,0060)
IMAGE_OVERLAY_FLAG_RETIRED | Image Overlay Flag RETIRED (2000,0067)
IMAGE_PATH_FILTER_PASS_BAND | Image Path Filter Pass Band (0022,0004)
IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH | Image Path Filter Pass-Through Wavelength (0022,0003)
IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE | Image Path Filter Type Stack Code Sequence (0022,0018)
IMAGE_PLANE_PIXEL_SPACING | Image Plane Pixel Spacing (3002,0011)
IMAGE_POSITION | Alias for tag IMAGE_BOX_POSITION (2020,0010)
IMAGE_POSITION_PATIENT | Image Position (Patient) (0020,0032)
IMAGE_POSITION_RETIRED | Image Position RETIRED (0020,0030)
IMAGE_POSITION_VOLUME | Image Position (Volume) (0020,9301)
IMAGE_PRESENTATION_COMMENTS_RETIRED | Image Presentation Comments RETIRED (0028,4000)
IMAGE_PROCESSING_APPLIED | Image Processing Applied (0028,9446)
IMAGE_RECEPTOR_POSITION_SEQUENCE | Image Receptor Position Sequence (3002,010E)
IMAGE_ROTATION | Image Rotation (0070,0042)
IMAGE_ROTATION_RETIRED | Image Rotation (Retired) (0070,0040)
IMAGE_SET_LABEL | Image Set Label (0072,0040)
IMAGE_SET_NUMBER | Image Set Number (0072,0032)
IMAGE_SET_SELECTOR_CATEGORY | Image Set Selector Category (0072,0034)
IMAGE_SET_SELECTOR_SEQUENCE | Image Set Selector Sequence (0072,0022)
IMAGE_SET_SELECTOR_USAGE_FLAG | Image Set Selector Usage Flag (0072,0024)
IMAGE_SETS_SEQUENCE | Image Sets Sequence (0072,0020)
IMAGE_TIME | Alias for tag CONTENT_TIME (0008,0033)
IMAGE_TO_EQUIPMENT_MAPPING_MATRIX | Image to Equipment Mapping Matrix (0028,9520)
IMAGE_TRANSFORMATION_MATRIX_RETIRED | Image Transformation Matrix RETIRED (0018,5210)
IMAGE_TRANSLATION_VECTOR_RETIRED | Image Translation Vector RETIRED (0018,5212)
IMAGE_TRIGGER_DELAY | Image Trigger Delay (0018,1067)
IMAGE_TYPE | Image Type (0008,0008)
IMAGE_VOLUME_GEOMETRY | Image Volume Geometry (0070,1208)
IMAGED_NUCLEUS | Imaged Nucleus (0018,0085)
IMAGED_VOLUME_DEPTH | Imaged Volume Depth (0048,0003)
IMAGED_VOLUME_HEIGHT | Imaged Volume Height (0048,0002)
IMAGED_VOLUME_WIDTH | Imaged Volume Width (0048,0001)
IMAGER_PIXEL_SPACING | Imager Pixel Spacing (0018,1164)
IMAGES_IN_ACQUISITION | Images in Acquisition (0020,1002)
IMAGING_APERTURE_SEQUENCE | Imaging Aperture Sequence (3002,0114)
IMAGING_APERTURE_SPECIFICATION_TYPE | Imaging Aperture Specification Type (3002,0115)
IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE | Imaging Device Location Matrix Sequence (3002,0112)
IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE | Imaging Device Location Parameter Sequence (3002,0113)
IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS | Imaging Device-Specific Acquisition Parameters (300A,00CC)
IMAGING_FREQUENCY | Imaging Frequency (0018,0084)
IMAGING_SERVICE_REQUEST_COMMENTS | Imaging Service Request Comments (0040,2400)
IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE | Imaging Source Location Specification Type (3002,0111)
IMAGING_SOURCE_POSITION_SEQUENCE | Imaging Source Position Sequence (3002,010D)
IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE | Imaging Source to Beam Modifier Definition Plane Distance (3002,012D)
IMMERSION_MEDIA | Immersion Media (0016,1004)
IMPEDANCE_MEASUREMENT_CURRENT_TYPE | Impedance Measurement Current Type (003A,0316)
IMPEDANCE_MEASUREMENT_DATETIME | Impedance Measurement DateTime (003A,0314)
IMPEDANCE_MEASUREMENT_FREQUENCY | Impedance Measurement Frequency (003A,0315)
IMPEDANCE_VALUE | Impedance Value (003A,0313)
IMPLANT_ASSEMBLY_TEMPLATE_ISSUER | Implant Assembly Template Issuer (0076,0003)
IMPLANT_ASSEMBLY_TEMPLATE_NAME | Implant Assembly Template Name (0076,0001)
IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE | Implant Assembly Template Target Anatomy Sequence (0076,0010)
IMPLANT_ASSEMBLY_TEMPLATE_TYPE | Implant Assembly Template Type (0076,000A)
IMPLANT_ASSEMBLY_TEMPLATE_VERSION | Implant Assembly Template Version (0076,0006)
IMPLANT_NAME | Implant Name (0022,1095)
IMPLANT_PART_NUMBER | Implant Part Number (0022,1097)
IMPLANT_PRESENT | Alias for tag BREAST_IMPLANT_PRESENT (0028,1300)
IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE | Implant Regulatory Disapproval Code Sequence (0068,62A0)
IMPLANT_SIZE | Implant Size (0068,6210)
IMPLANT_TARGET_ANATOMY_SEQUENCE | Implant Target Anatomy Sequence (0068,6230)
IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER | Implant Template 3D Model Surface Number (0068,6350)
IMPLANT_TEMPLATE_GROUP_DESCRIPTION | Implant Template Group Description (0078,0010)
IMPLANT_TEMPLATE_GROUP_ISSUER | Implant Template Group Issuer (0078,0020)
IMPLANT_TEMPLATE_GROUP_MEMBER_ID | Implant Template Group Member ID (0078,002E)
IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE | Implant Template Group Member Matching 2D Coordinates Sequence (0078,0070)
IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE | Implant Template Group Members Sequence (0078,002A)
IMPLANT_TEMPLATE_GROUP_NAME | Implant Template Group Name (0078,0001)
IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE | Implant Template Group Target Anatomy Sequence (0078,0028)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME | Implant Template Group Variation Dimension Name (0078,00B2)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK | Implant Template Group Variation Dimension Rank (0078,00B8)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE | Implant Template Group Variation Dimension Rank Sequence (0078,00B4)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE | Implant Template Group Variation Dimension Sequence (0078,00B0)
IMPLANT_TEMPLATE_GROUP_VERSION | Implant Template Group Version (0078,0024)
IMPLANT_TEMPLATE_VERSION | Implant Template Version (0068,6221)
IMPLANT_TYPE | Implant Type (0068,6223)
IMPLANT_TYPE_CODE_SEQUENCE | Implant Type Code Sequence (0068,63A8)
IMPLEMENTATION_CLASS_UID | Implementation Class UID (0002,0012)
IMPLEMENTATION_VERSION_NAME | Implementation Version Name (0002,0013)
IMPRESSIONS_RETIRED | Impressions RETIRED (4008,0300)
IN_CONCATENATION_NUMBER | In-concatenation Number (0020,9162)
IN_CONCATENATION_TOTAL_NUMBER | In-concatenation Total Number (0020,9163)
IN_PLANE_PHASE_ENCODING_DIRECTION | In-plane Phase Encoding Direction (0018,1312)
IN_STACK_POSITION_NUMBER | In-Stack Position Number (0020,9057)
INBOUND_ARRIVAL_TYPE | Inbound Arrival Type (4010,1056)
INCIDENT_ANGLE | Incident Angle (0014,4052)
INCLUDE_DISPLAY_APPLICATION | Include Display Application (2200,0009)
INCLUDE_NON_DICOM_OBJECTS | Include Non-DICOM Objects (2200,0008)
INCLUDES_IMAGING_SUBJECT | Includes Imaging Subject (0034,0008)
INCLUDES_INFORMATION | Includes Information (0034,000C)
INCORPORATED_INVENTORY_INSTANCE_SEQUENCE | Incorporated Inventory Instance Sequence (0008,0422)
INDEX_NORMALS_FLAG | Index Normals Flag (0024,0338)
INDEX_PROBABILITY | Index Probability (0024,0341)
INDEX_PROBABILITY_SEQUENCE | Index Probability Sequence (0024,0344)
INDICATION_DESCRIPTION | Indication Description (0014,2018)
INDICATION_DISPOSITION | Indication Disposition (0014,201C)
INDICATION_LABEL | Indication Label (0014,2016)
INDICATION_NUMBER | Indication Number (0014,2014)
INDICATION_PHYSICAL_PROPERTY_SEQUENCE | Indication Physical Property Sequence (0014,2030)
INDICATION_ROI_SEQUENCE | Indication ROI Sequence (0014,201E)
INDICATION_SEQUENCE | Indication Sequence (0014,2012)
INDICATION_TYPE | Indication Type (0014,201A)
INFORMATION_FROM_MANUFACTURER_SEQUENCE | Information From Manufacturer Sequence (0068,6260)
INFORMATION_ISSUE_DATETIME | Information Issue DateTime (0068,6270)
INFORMATION_SUMMARY | Information Summary (0068,6280)
INITIAL_CINE_RUN_STATE | Initial Cine Run State (0018,0042)
INITIATOR_RETIRED | Initiator RETIRED (0000,0200)
INNER_DIAMETER | Inner Diameter (0014,0056)
INPUT_AVAILABILITY_FLAG_RETIRED | Input Availability Flag RETIRED (0040,4020)
INPUT_INFORMATION_SEQUENCE | Input Information Sequence (0040,4021)
INPUT_READINESS_STATE | Input Readiness State (0040,4041)
INPUT_SEQUENCE_POSITION_INDEX | Input Sequence Position Index (0070,1203)
INSTANCE_AVAILABILITY | Instance Availability (0008,0056)
INSTANCE_COERCION_DATETIME | Instance Coercion DateTime (0008,0015)
INSTANCE_CREATION_DATE | Instance Creation Date (0008,0012)
INSTANCE_CREATION_TIME | Instance Creation Time (0008,0013)
INSTANCE_CREATOR_UID | Instance Creator UID (0008,0014)
INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE | Instance-Level Referenced Performed Procedure Step Sequence (3010,0044)
INSTANCE_NUMBER | Instance Number (0020,0013)
INSTANCE_ORIGIN_STATUS | Instance Origin Status (0400,0600)
INSTITUTION_ADDRESS | Institution Address (0008,0081)
INSTITUTION_CODE_SEQUENCE | Institution Code Sequence (0008,0082)
INSTITUTION_NAME | Institution Name (0008,0080)
INSTITUTIONAL_DEPARTMENT_NAME | Institutional Department Name (0008,1040)
INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE | Institutional Department Type Code Sequence (0008,1041)
INSTRUCTION_DESCRIPTION | Instruction Description (0018,9917)
INSTRUCTION_INDEX | Instruction Index (0018,9915)
INSTRUCTION_PERFORMANCE_COMMENT | Instruction Performance Comment (0018,991A)
INSTRUCTION_PERFORMED_DATETIME | Instruction Performed DateTime (0018,9919)
INSTRUCTION_PERFORMED_FLAG | Instruction Performed Flag (0018,9918)
INSTRUCTION_SEQUENCE | Instruction Sequence (0018,9914)
INSTRUCTION_TEXT | Instruction Text (0018,9916)
INSURANCE_PLAN_IDENTIFICATION_RETIRED | Insurance Plan Identification RETIRED (0010,1050)
INTENDED_DELIVERY_DURATION | Intended Delivery Duration (3010,007E)
INTENDED_FRACTION_START_TIME | Intended Fraction Start Time (3010,0085)
INTENDED_NUMBER_OF_FRACTIONS | Intended Number of Fractions (300A,0636)
INTENDED_PHASE_END_DATE | Intended Phase End Date (3010,004D)
INTENDED_PHASE_START_DATE | Intended Phase Start Date (3010,004C)
INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE | Intended Recipients of Results Identification Sequence (0040,1011)
INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE | Alias for tag INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE (0040,1011)
INTENDED_RT_TREATMENT_PHASE_SEQUENCE | Intended RT Treatment Phase Sequence (3010,004B)
INTENDED_START_DAY_OF_WEEK | Intended Start Day of Week (3010,0086)
INTENSIFIER_ACTIVE_DIMENSIONS | Intensifier Active Dimension(s) (0018,9428)
INTENSIFIER_ACTIVE_SHAPE | Intensifier Active Shape (0018,9427)
INTENSIFIER_SIZE | Intensifier Size (0018,1162)
INTER_MARKER_DISTANCE | Inter-Marker Distance (0050,0019)
INTERLOCK_CODE_SEQUENCE | Interlock Code Sequence (300A,0744)
INTERLOCK_DATETIME | Interlock DateTime (300A,0741)
INTERLOCK_DESCRIPTION | Interlock Description (300A,0742)
INTERLOCK_ORIGIN_DESCRIPTION | Interlock Origin Description (300A,0783)
INTERLOCK_ORIGINATING_DEVICE_SEQUENCE | Interlock Originating Device Sequence (300A,0743)
INTERLOCK_RESOLUTION_CODE_SEQUENCE | Interlock Resolution Code Sequence (300A,0745)
INTERLOCK_RESOLUTION_USER_SEQUENCE | Interlock Resolution User Sequence (300A,0746)
INTERLOCK_SEQUENCE | Interlock Sequence (300A,0740)
INTERMEDIATE_PUPILLARY_DISTANCE | Intermediate Pupillary Distance (0046,0063)
INTERNAL_DETECTOR_FRAME_TIME | Internal Detector Frame Time (0014,3011)
INTERNATIONAL_ROUTE_SEGMENT | International Route Segment (4010,1028)
INTEROPERABILITY_INDEX | Interoperability Index (0016,0061)
INTEROPERABILITY_VERSION | Interoperability Version (0016,0062)
INTERPOLATION_TYPE | Interpolation Type (0052,0039)
INTERPRETATION_APPROVAL_DATE_RETIRED | Interpretation Approval Date RETIRED (4008,0112)
INTERPRETATION_APPROVAL_TIME_RETIRED | Interpretation Approval Time RETIRED (4008,0113)
INTERPRETATION_APPROVER_SEQUENCE_RETIRED | Interpretation Approver Sequence RETIRED (4008,0111)
INTERPRETATION_AUTHOR_RETIRED | Interpretation Author RETIRED (4008,010C)
INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED | Interpretation Diagnosis Code Sequence RETIRED (4008,0117)
INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED | Interpretation Diagnosis Description RETIRED (4008,0115)
INTERPRETATION_ID_ISSUER_RETIRED | Interpretation ID Issuer RETIRED (4008,0202)
INTERPRETATION_ID_RETIRED | Interpretation ID RETIRED (4008,0200)
INTERPRETATION_RECORDED_DATE_RETIRED | Interpretation Recorded Date RETIRED (4008,0100)
INTERPRETATION_RECORDED_TIME_RETIRED | Interpretation Recorded Time RETIRED (4008,0101)
INTERPRETATION_RECORDER_RETIRED | Interpretation Recorder RETIRED (4008,0102)
INTERPRETATION_STATUS_ID_RETIRED | Interpretation Status ID RETIRED (4008,0212)
INTERPRETATION_TEXT_RETIRED | Interpretation Text RETIRED (4008,010B)
INTERPRETATION_TRANSCRIBER_RETIRED | Interpretation Transcriber RETIRED (4008,010A)
INTERPRETATION_TRANSCRIPTION_DATE_RETIRED | Interpretation Transcription Date RETIRED (4008,0108)
INTERPRETATION_TRANSCRIPTION_TIME_RETIRED | Interpretation Transcription Time RETIRED (4008,0109)
INTERPRETATION_TYPE_ID_RETIRED | Interpretation Type ID RETIRED (4008,0210)
INTERVAL_NUMBER_RETIRED | Interval Number RETIRED (0020,0016)
INTERVALS_ACQUIRED | Intervals Acquired (0018,1083)
INTERVALS_REJECTED | Intervals Rejected (0018,1084)
INTERVENTION_DESCRIPTION | Intervention Description (0018,003A)
INTERVENTION_DRUG_CODE_SEQUENCE | Intervention Drug Code Sequence (0018,0029)
INTERVENTION_DRUG_DOSE | Intervention Drug Dose (0018,0028)
INTERVENTION_DRUG_INFORMATION_SEQUENCE | Intervention Drug Information Sequence (0018,0026)
INTERVENTION_DRUG_NAME | Intervention Drug Name (0018,0034)
INTERVENTION_DRUG_SEQUENCE | Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)
INTERVENTION_DRUG_START_TIME | Intervention Drug Start Time (0018,0035)
INTERVENTION_DRUG_STOP_TIME | Intervention Drug Stop Time (0018,0027)
INTERVENTION_SEQUENCE | Intervention Sequence (0018,0036)
INTERVENTION_STATUS | Intervention Status (0018,0038)
INTERVENTIONAL_DRUG_CODE_SEQUENCE | Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)
INTERVENTIONAL_STATUS | Alias for tag INTERVENTION_STATUS (0018,0038)
INTERVENTIONAL_THERAPY_SEQUENCE | Alias for tag INTERVENTION_SEQUENCE (0018,0036)
INTRA_OCULAR_PRESSURE | Intra Ocular Pressure (0022,000B)
INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE | Intraocular Lens Calculations Left Eye Sequence (0022,1310)
INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE | Intraocular Lens Calculations Right Eye Sequence (0022,1300)
INTRAVASCULAR_FRAME_CONTENT_SEQUENCE | Intravascular Frame Content Sequence (0052,0027)
INTRAVASCULAR_LONGITUDINAL_DISTANCE | Intravascular Longitudinal Distance (0052,0028)
INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE | Intravascular OCT Frame Content Sequence (0052,0029)
INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE | Intravascular OCT Frame Type Sequence (0052,0025)
INVENTORIED_INSTANCES_SEQUENCE | Inventoried Instances Sequence (0008,0425)
INVENTORIED_SERIES_SEQUENCE | Inventoried Series Sequence (0008,0424)
INVENTORIED_STUDIES_SEQUENCE | Inventoried Studies Sequence (0008,0423)
INVENTORY_ACCESS_END_POINTS_SEQUENCE | Inventory Access End Points Sequence (0008,0420)
INVENTORY_COMPLETION_STATUS | Inventory Completion Status (0008,0426)
INVENTORY_INSTANCE_DESCRIPTION | Inventory Instance Description (0008,0402)
INVENTORY_LEVEL | Inventory Level (0008,0403)
INVENTORY_PURPOSE | Inventory Purpose (0008,0401)
INVERSION_RECOVERY | Inversion Recovery (0018,9009)
INVERSION_TIME | Inversion Time (0018,0082)
INVERSION_TIMES | Inversion Times (0018,9079)
IOL_FORMULA_CODE_SEQUENCE | IOL Formula Code Sequence (0022,1028)
IOL_FORMULA_DETAIL | IOL Formula Detail (0022,1029)
IOL_MANUFACTURER | IOL Manufacturer (0022,1093)
IOL_POWER | IOL Power (0022,1053)
IOL_POWER_FOR_EXACT_EMMETROPIA | IOL Power For Exact Emmetropia (0022,1121)
IOL_POWER_FOR_EXACT_TARGET_REFRACTION | IOL Power For Exact Target Refraction (0022,1122)
IOL_POWER_SEQUENCE | IOL Power Sequence (0022,1090)
ION_BEAM_LIMITING_DEVICE_SEQUENCE | Ion Beam Limiting Device Sequence (300A,03A4)
ION_BEAM_SEQUENCE | Ion Beam Sequence (300A,03A2)
ION_BLOCK_SEQUENCE | Ion Block Sequence (300A,03A6)
ION_CONTROL_POINT_DELIVERY_SEQUENCE | Ion Control Point Delivery Sequence (3008,0041)
ION_CONTROL_POINT_SEQUENCE | Ion Control Point Sequence (300A,03A8)
ION_CONTROL_POINT_VERIFICATION_SEQUENCE | Ion Control Point Verification Sequence (0074,104E)
ION_MACHINE_VERIFICATION_SEQUENCE | Ion Machine Verification Sequence (0074,1046)
ION_RANGE_COMPENSATOR_SEQUENCE | Ion Range Compensator Sequence (300A,02EA)
ION_TOLERANCE_TABLE_SEQUENCE | Ion Tolerance Table Sequence (300A,03A0)
ION_WEDGE_POSITION_SEQUENCE | Ion Wedge Position Sequence (300A,03AC)
ION_WEDGE_SEQUENCE | Ion Wedge Sequence (300A,03AA)
IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE | Irradiation Event Identification Sequence (0018,9477)
IRRADIATION_EVENT_UID | Irradiation Event UID (0008,3010)
ISO_SPEED | ISO Speed (0016,001D)
ISO_SPEED_LATITUDE_YYY | ISO Speed Latitude yyy (0016,001E)
ISO_SPEED_LATITUDE_ZZZ | ISO Speed Latitude zzz (0016,001F)
ISOCENTER_POSITION | Isocenter Position (300A,012C)
ISOCENTER_REFERENCE_SYSTEM_SEQUENCE | Isocenter Reference System Sequence (0018,9462)
ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE | Isocenter to Beam Limiting Device Distance (300A,00BB)
ISOCENTER_TO_BLOCK_TRAY_DISTANCE | Isocenter to Block Tray Distance (300A,00F7)
ISOCENTER_TO_COMPENSATOR_DISTANCES | Isocenter to Compensator Distances (300A,02E6)
ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE | Isocenter to Compensator Tray Distance (300A,02E4)
ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE | Isocenter to General Accessory Distance (300A,0426)
ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE | Isocenter to Lateral Spreading Device Distance (300A,0374)
ISOCENTER_TO_RANGE_MODULATOR_DISTANCE | Isocenter to Range Modulator Distance (300A,038A)
ISOCENTER_TO_RANGE_SHIFTER_DISTANCE | Isocenter to Range Shifter Distance (300A,0364)
ISOCENTER_TO_WEDGE_TRAY_DISTANCE | Isocenter to Wedge Tray Distance (300A,00D9)
ISOTOPE_NUMBER_RETIRED | Isotope Number RETIRED (0020,0014)
ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST | Issue Date of Imaging Service Request (0040,2004)
ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST | Issue Time of Imaging Service Request (0040,2005)
ISSUER_OF_ACCESSION_NUMBER_SEQUENCE | Issuer of Accession Number Sequence (0008,0051)
ISSUER_OF_ADMISSION_ID_RETIRED | Issuer of Admission ID RETIRED (0038,0011)
ISSUER_OF_ADMISSION_ID_SEQUENCE | Issuer of Admission ID Sequence (0038,0014)
ISSUER_OF_PATIENT_ID | Issuer of Patient ID (0010,0021)
ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE | Issuer of Patient ID Qualifiers Sequence (0010,0024)
ISSUER_OF_SERVICE_EPISODE_ID_RETIRED | Issuer of Service Episode ID RETIRED (0038,0061)
ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE | Issuer of Service Episode ID Sequence (0038,0064)
ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE | Issuer of the Container Identifier Sequence (0040,0513)
ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE | Issuer of the Specimen Identifier Sequence (0040,0562)
ITALIC | Italic (0070,0250)
ITEM_INVENTORY_DATETIME | Item Inventory DateTime (0008,0404)
ITEM_NUMBER | Item Number (0020,0019)
ITERATIVE_RECONSTRUCTION_METHOD | Iterative Reconstruction Method (0018,9769)
ITINERARY_ID | Itinerary ID (4010,1051)
ITINERARY_ID_ASSIGNING_AUTHORITY | Itinerary ID Assigning Authority (4010,1053)
ITINERARY_ID_TYPE | Itinerary ID Type (4010,1052)
IVUS_ACQUISITION | IVUS Acquisition (0018,3100)
IVUS_GATED_RATE | IVUS Gated Rate (0018,3102)
IVUS_PULLBACK_RATE | IVUS Pullback Rate (0018,3101)
IVUS_PULLBACK_START_FRAME_NUMBER | IVUS Pullback Start Frame Number (0018,3103)
IVUS_PULLBACK_STOP_FRAME_NUMBER | IVUS Pullback Stop Frame Number (0018,3104)
K_SPACE_FILTERING | k-space Filtering (0018,9064)
KERATOCONUS_PREDICTION_INDEX | Keratoconus Prediction Index (0046,0236)
KERATOMETER_INDEX | Keratometer Index (0022,1033)
KERATOMETRIC_AXIS | Keratometric Axis (0046,0077)
KERATOMETRIC_POWER | Keratometric Power (0046,0076)
KERATOMETRY_LEFT_EYE_SEQUENCE | Keratometry Left Eye Sequence (0046,0071)
KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE | Keratometry Measurement Type Code Sequence (0022,1096)
KERATOMETRY_RIGHT_EYE_SEQUENCE | Keratometry Right Eye Sequence (0046,0070)
KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE | KV Imaging Generation Parameters Sequence (3002,0127)
KV_USED_IN_GAIN_CALIBRATION | KV Used in Gain Calibration (0014,3071)
KVP | KVP (0018,0060)
LABEL_STYLE_SELECTION | Label Style Selection (2200,0003)
LABEL_TEXT | Label Text (2200,0002)
LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES | Label Using Information Extracted From Instances (2200,0001)
LANGUAGE_CODE_SEQUENCE | Language Code Sequence (0008,0006)
LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED | Language Code Sequence (Trial) RETIRED (0040,A744)
LARGEST_IMAGE_PIXEL_VALUE | Largest Image Pixel Value (0028,0107)
LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED | Largest Image Pixel Value in Plane RETIRED (0028,0111)
LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED | Largest Monochrome Pixel Value RETIRED (0028,9099)
LARGEST_PIXEL_VALUE_IN_SERIES | Largest Pixel Value in Series (0028,0109)
LARGEST_PIXEL_VALUE_RETIRED | Alias for tag LARGEST_VALID_PIXEL_VALUE_RETIRED (0028,0105)
LARGEST_VALID_PIXEL_VALUE_RETIRED | Largest Valid Pixel Value RETIRED (0028,0105)
LAST_MENSTRUAL_DATE | Last Menstrual Date (0010,21D0)
LATERAL_SPREADING_DEVICE_DESCRIPTION | Lateral Spreading Device Description (300A,033A)
LATERAL_SPREADING_DEVICE_ID | Lateral Spreading Device ID (300A,0336)
LATERAL_SPREADING_DEVICE_NUMBER | Lateral Spreading Device Number (300A,0334)
LATERAL_SPREADING_DEVICE_SEQUENCE | Lateral Spreading Device Sequence (300A,0332)
LATERAL_SPREADING_DEVICE_SETTING | Lateral Spreading Device Setting (300A,0372)
LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE | Lateral Spreading Device Settings Sequence (300A,0370)
LATERAL_SPREADING_DEVICE_TYPE | Lateral Spreading Device Type (300A,0338)
LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS | Lateral Spreading Device Water Equivalent Thickness (300A,033C)
LATERALITY | Laterality (0020,0060)
LEAF_JAW_POSITIONS | Leaf/Jaw Positions (300A,011C)
LEAF_POSITION_BOUNDARIES | Leaf Position Boundaries (300A,00BE)
LEFT_IMAGE_SEQUENCE | Left Image Sequence (0022,0021)
LEFT_LENS_SEQUENCE | Left Lens Sequence (0046,0015)
LENGTH_TO_END_RETIRED | Length to End RETIRED (0008,0001)
LENS_CONSTANT_DESCRIPTION_RETIRED | Lens Constant Description RETIRED (0022,1094)
LENS_CONSTANT_SEQUENCE | Lens Constant Sequence (0022,1092)
LENS_DESCRIPTION | Lens Description (0046,0012)
LENS_MAKE | Lens Make (0016,004F)
LENS_MODEL | Lens Model (0016,0050)
LENS_SEGMENT_TYPE | Lens Segment Type (0046,0038)
LENS_SERIAL_NUMBER | Lens Serial Number (0016,0051)
LENS_SPECIFICATION | Lens Specification (0016,004E)
LENS_STATUS_CODE_SEQUENCE | Lens Status Code Sequence (0022,1024)
LENS_STATUS_DESCRIPTION | Lens Status Description (0022,1065)
LENS_THICKNESS | Lens Thickness (0022,1130)
LENS_THICKNESS_SEQUENCE | Lens Thickness Sequence (0022,1127)
LENSES_CODE_SEQUENCE | Lenses Code Sequence (0022,0019)
LESION_NUMBER | Lesion Number (0018,3105)
LIGHT_DIRECTION | Light Direction (0070,1703)
LIGHT_PATH_FILTER_PASS_BAND | Light Path Filter Pass Band (0022,0002)
LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH | Light Path Filter Pass-Through Wavelength (0022,0001)
LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE | Light Path Filter Type Stack Code Sequence (0022,0017)
LIGHT_SOURCE | Light Source (0016,0028)
LIGHT_SOURCE_POLARIZATION | Light Source Polarization (0016,1001)
LINAC_ENERGY | LINAC Energy (0014,5002)
LINAC_OUTPUT | LINAC Output (0014,5004)
LINE_DASHING_STYLE | Line Dashing Style (0070,0254)
LINE_PATTERN | Line Pattern (0070,0255)
LINE_SEQUENCE | Line Sequence (0066,0028)
LINE_STYLE_SEQUENCE | Line Style Sequence (0070,0232)
LINE_THICKNESS | Line Thickness (0070,0253)
LIST_OF_MIME_TYPES | List of MIME Types (0042,0014)
LIST_OF_UID_MATCHING_SEQUENCE | List of UID Matching Sequence (0008,0411)
LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG | Local Deviation Probability Normals Flag (0024,0072)
LOCAL_NAMESPACE_ENTITY_ID | Local Namespace Entity ID (0040,0031)
LOCALIZED_DEVIATION_FROM_NORMAL | Localized Deviation From Normal (0024,0068)
LOCALIZED_DEVIATION_PROBABILITY | Localized Deviation Probability (0024,0073)
LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE | Localized Deviation Probability Sequence (0024,0085)
LOCALIZING_CURSOR_POSITION | Localizing Cursor Position (0018,2043)
LOCATION_OF_MEASURED_BEAM_DIAMETER | Location of Measured Beam Diameter (0014,4019)
LOCATION_RETIRED | Location RETIRED (0020,0050)
LONG_CODE_VALUE | Long Code Value (0008,0119)
LONG_DEVICE_DESCRIPTION | Long Device Description (0050,0021)
LONG_EDGE_POINT_INDEX_LIST | Long Edge Point Index List (0066,0042)
LONG_PRIMITIVE_POINT_INDEX_LIST | Long Primitive Point Index List (0066,0040)
LONG_TRIANGLE_POINT_INDEX_LIST | Long Triangle Point Index List (0066,0041)
LONG_VERTEX_POINT_INDEX_LIST | Long Vertex Point Index List (0066,0043)
LONGITUDINAL_TEMPORAL_EVENT_TYPE | Longitudinal Temporal Event Type (0012,0053)
LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED | Longitudinal Temporal Information Modified (0028,0303)
LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT | Longitudinal Temporal Offset from Event (0012,0052)
LOOKUP_TABLE_NUMBER | Alias for tag LUT_NUMBER_RETIRED (0020,0026)
LOSSY_IMAGE_COMPRESSION | Lossy Image Compression (0028,2110)
LOSSY_IMAGE_COMPRESSION_METHOD | Lossy Image Compression Method (0028,2114)
LOSSY_IMAGE_COMPRESSION_RATIO | Lossy Image Compression Ratio (0028,2112)
LOSSY_IMAGE_COMPRESSION_RETIRED | Lossy Image Compression (Retired) (0008,2110)
LOW_ENERGY_DETECTORS | Low Energy Detectors (4010,0001)
LOW_R_R_VALUE | Low R-R Value (0018,1081)
LOWER_CUTOFF_FREQUENCY | Lower Cutoff Frequency (0018,982F)
LUMINANCE_CHARACTERISTICS_ID | Luminance Characteristics ID (0028,7009)
LUMINANCE_RESPONSE_DESCRIPTION | Luminance Response Description (0028,7020)
LUMINANCE_RESPONSE_SEQUENCE | Luminance Response Sequence (0028,701C)
LUMINANCE_RESULT_SEQUENCE | Luminance Result Sequence (0028,7024)
LUMINANCE_UNIFORMITY_RESULT_SEQUENCE | Luminance Uniformity Result Sequence (0028,7027)
LUMINANCE_VALUE | Luminance Value (0028,701F)
LUT_DATA | LUT Data (0028,3006)
LUT_DESCRIPTOR | LUT Descriptor (0028,3002)
LUT_EXPLANATION | LUT Explanation (0028,3003)
LUT_FRAME_RANGE | LUT Frame Range (0028,9507)
LUT_FUNCTION | LUT Function (0028,9474)
LUT_LABEL | LUT Label (0040,9210)
LUT_NUMBER_RETIRED | LUT Number RETIRED (0020,0026)
MA_USED_IN_GAIN_CALIBRATION | MA Used in Gain Calibration (0014,3072)
MAC | MAC (0400,0404)
MAC_ALGORITHM | MAC Algorithm (0400,0015)
MAC_CALCULATION_TRANSFER_SYNTAX_UID | MAC Calculation Transfer Syntax UID (0400,0010)
MAC_ID_NUMBER | MAC ID Number (0400,0005)
MAC_PARAMETERS_SEQUENCE | MAC Parameters Sequence (4FFE,0001)
MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE | Machine-Specific Treatment Termination Code Sequence (300A,0716)
MAGNETIC_FIELD_STRENGTH | Magnetic Field Strength (0018,0087)
MAGNETIZATION_TRANSFER | Magnetization Transfer (0018,9020)
MAGNIFICATION_TYPE | Magnification Type (2010,0060)
MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED | Magnify to Number of Columns RETIRED (2040,0074)
MAGNITUDE_ENCODING_CODE_SEQUENCE | Magnitude Encoding Code Sequence (003A,032D)
MAJOR_TICKS_SEQUENCE | Major Ticks Sequence (0070,0287)
MAKER_NOTE | Maker Note (0016,002B)
MANDATORY_COMPONENT_TYPE | Mandatory Component Type (0076,0038)
MANIFOLD | Manifold (0066,0010)
MANIPULATED_IMAGE_RETIRED | Manipulated Image RETIRED (0028,0050)
MANUFACTURER | Manufacturer (0008,0070)
MANUFACTURERS_DEVICE_CLASS_UID | Manufacturer's Device Class UID (0018,100B)
MANUFACTURERS_DEVICE_IDENTIFIER | Manufacturer's Device Identifier (3010,0043)
MANUFACTURERS_MODEL_NAME | Manufacturer's Model Name (0008,1090)
MANUFACTURERS_MODEL_VERSION | Manufacturer's Model Version (3010,001A)
MANUFACTURERS_RELATED_MODEL_GROUP | Manufacturer's Related Model Group (0008,0222)
MAPPED_PIXEL_VALUE | Mapped Pixel Value (0022,1452)
MAPPING_RESOURCE | Mapping Resource (0008,0105)
MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE | Mapping Resource Identification Sequence (0008,0124)
MAPPING_RESOURCE_NAME | Mapping Resource Name (0008,0122)
MAPPING_RESOURCE_UID | Mapping Resource UID (0008,0118)
MASK_FRAME_NUMBERS | Mask Frame Numbers (0028,6110)
MASK_OPERATION | Mask Operation (0028,6101)
MASK_OPERATION_EXPLANATION | Mask Operation Explanation (0028,6190)
MASK_POINTERS_RETIRED | Mask Pointer(s) RETIRED (0028,6030)
MASK_SELECTION_MODE | Mask Selection Mode (0028,9454)
MASK_SUB_PIXEL_SHIFT | Mask Sub-pixel Shift (0028,6114)
MASK_SUBTRACTION_SEQUENCE | Mask Subtraction Sequence (0028,6100)
MASK_VISIBILITY_PERCENTAGE | Mask Visibility Percentage (0028,9478)
MASKING_IMAGE_RETIRED | Masking Image RETIRED (0020,0080)
MASS | Mass (4010,1017)
MATERIAL_ATTENUATION_SEQUENCE | Material Attenuation Sequence (0018,9382)
MATERIAL_CODE_SEQUENCE | Material Code Sequence (0018,937D)
MATERIAL_GRADE | Material Grade (0014,0042)
MATERIAL_ID | Material ID (300A,00E1)
MATERIAL_ISOLATION_DIAMETER | Material Isolation Diameter (0014,0034)
MATERIAL_NOTES | Material Notes (0014,0046)
MATERIAL_PIPE_DIAMETER | Material Pipe Diameter (0014,0032)
MATERIAL_PROPERTIES_DESCRIPTION | Material Properties Description (0014,0044)
MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED | Material Properties File Format (Retired) (0014,0045)
MATERIAL_THICKNESS | Material Thickness (0014,0030)
MATERIALS_CODE_SEQUENCE | Materials Code Sequence (0068,63A0)
MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE | Mating Feature Degree of Freedom Sequence (0068,6400)
MATING_FEATURE_ID | Mating Feature ID (0068,63F0)
MATING_FEATURE_SEQUENCE | Mating Feature Sequence (0068,63E0)
MATING_FEATURE_SET_ID | Mating Feature Set ID (0068,63C0)
MATING_FEATURE_SET_LABEL | Mating Feature Set Label (0068,63D0)
MATING_FEATURE_SETS_SEQUENCE | Mating Feature Sets Sequence (0068,63B0)
MATRIX_REGISTRATION_SEQUENCE | Matrix Registration Sequence (0070,0309)
MATRIX_SEQUENCE | Matrix Sequence (0070,030A)
MAX_APERTURE_VALUE | Max Aperture Value (0016,0025)
MAX_DENSITY | Max Density (2010,0130)
MAXIMUM_ACROSS_SCAN_DISTORTION | Maximum Across-scan Distortion (0022,0049)
MAXIMUM_ALONG_SCAN_DISTORTION | Maximum Along-scan Distortion (0022,0038)
MAXIMUM_COLLATED_FILMS | Maximum Collated Films (2010,0154)
MAXIMUM_COORDINATE_VALUE_RETIRED | Maximum Coordinate Value RETIRED (5000,0105)
MAXIMUM_CORNEAL_CURVATURE | Maximum Corneal Curvature (0046,0212)
MAXIMUM_CORNEAL_CURVATURE_LOCATION | Maximum Corneal Curvature Location (0046,0213)
MAXIMUM_CORNEAL_CURVATURE_SEQUENCE | Maximum Corneal Curvature Sequence (0046,0211)
MAXIMUM_CUMULATIVE_METERSET_EXPOSURE | Maximum Cumulative Meterset Exposure (3002,0134)
MAXIMUM_DEPTH_DISTORTION | Maximum Depth Distortion (0022,0036)
MAXIMUM_FRACTIONAL_VALUE | Maximum Fractional Value (0062,000E)
MAXIMUM_MEMORY_ALLOCATION | Maximum Memory Allocation (2000,0061)
MAXIMUM_NOMINAL_ENERGY | Maximum Nominal Energy (300A,0682)
MAXIMUM_NUMBER_OF_INTERVAL_DAYS | Maximum Number of Interval Days (3010,0051)
MAXIMUM_NUMBER_OF_RECORDS | Maximum Number of Records (0008,0429)
MAXIMUM_POINT_DISTANCE | Maximum Point Distance (0066,0019)
MAXIMUM_STIMULUS_LUMINANCE | Maximum Stimulus Luminance (0024,0018)
MAXIMUM_STORED_VALUE_MAPPED | Maximum Stored Value Mapped (0028,1232)
MEAN_POINT_DISTANCE | Mean Point Distance (0066,0018)
MEASURED_AP_DIMENSION | Measured AP Dimension (0010,1023)
MEASURED_BANDWIDTH | Measured Bandwidth (0014,401C)
MEASURED_BEAM_DIMENSION_A | Measured Beam Dimension A (0014,4017)
MEASURED_BEAM_DIMENSION_B | Measured Beam Dimension B (0014,4018)
MEASURED_CENTER_FREQUENCY | Measured Center Frequency (0014,401B)
MEASURED_CHARACTERISTICS | Measured Characteristics (0028,7026)
MEASURED_DOSE_DESCRIPTION | Measured Dose Description (3008,0012)
MEASURED_DOSE_REFERENCE_NUMBER | Measured Dose Reference Number (3008,0064)
MEASURED_DOSE_REFERENCE_SEQUENCE | Measured Dose Reference Sequence (3008,0010)
MEASURED_DOSE_TYPE | Measured Dose Type (3008,0014)
MEASURED_DOSE_VALUE | Measured Dose Value (3008,0016)
MEASURED_LATERAL_DIMENSION | Measured Lateral Dimension (0010,1024)
MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE | Measured Meterset to Dose Mapping Sequence (300A,0772)
MEASURED_VALUE_SEQUENCE | Measured Value Sequence (0040,A300)
MEASUREMENT_AUTOMATION_TRIAL_RETIRED | Measurement Automation (Trial) RETIRED (0040,A194)
MEASUREMENT_EQUIPMENT_SEQUENCE | Measurement Equipment Sequence (0028,7012)
MEASUREMENT_EQUIPMENT_TYPE | Measurement Equipment Type (0028,7014)
MEASUREMENT_FUNCTIONS | Measurement Functions (0028,7013)
MEASUREMENT_LATERALITY | Measurement Laterality (0024,0113)
MEASUREMENT_PATTERN_CODE_SEQUENCE | Measurement Pattern Code Sequence (0028,702D)
MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED | Measurement Precision Description (Trial) RETIRED (0040,A047)
MEASUREMENT_UNITS_CODE_SEQUENCE | Measurement Units Code Sequence (0040,08EA)
MEASUREMENT_VALUES_SEQUENCE | Measurement Values Sequence (0066,0132)
MEASUREMENTS_SEQUENCE | Measurements Sequence (0066,0121)
MEASURING_UNITS_SEQUENCE | Measuring Units Sequence (0040,0295)
MECHANICAL_INDEX | Mechanical Index (0018,5022)
MEDIA_DISPOSITION | Media Disposition (2200,0004)
MEDIA_INSTALLED_SEQUENCE | Media Installed Sequence (2000,00A2)
MEDIA_STORAGE_SOP_CLASS_UID | Media Storage SOP Class UID (0002,0002)
MEDIA_STORAGE_SOP_INSTANCE_UID | Media Storage SOP Instance UID (0002,0003)
MEDICAL_ALERTS | Medical Alerts (0010,2000)
MEDICAL_RECORD_LOCATOR_RETIRED | Medical Record Locator RETIRED (0010,1090)
MEDIUM_TYPE | Medium Type (2000,0030)
MEMORY_ALLOCATION | Memory Allocation (2000,0060)
MEMORY_BIT_DEPTH | Memory Bit Depth (2000,00A0)
MESSAGE_ID | Message ID (0000,0110)
MESSAGE_ID_BEING_RESPONDED_TO | Message ID Being Responded To (0000,0120)
MESSAGE_SET_ID_RETIRED | Message Set ID RETIRED (0000,5010)
METABOLITE_MAP_CODE_SEQUENCE | Metabolite Map Code Sequence (0018,9083)
METABOLITE_MAP_DESCRIPTION | Metabolite Map Description (0018,9080)
METADATA_SEQUENCE | Metadata Sequence (0008,041D)
METERING_MODE | Metering Mode (0016,0027)
METERSET_EXPOSURE | Meterset Exposure (3002,0032)
METERSET_RATE | Meterset Rate (300A,035A)
METERSET_RATE_DELIVERED | Meterset Rate Delivered (3008,0046)
METERSET_RATE_SET | Meterset Rate Set (3008,0045)
METERSET_TO_DOSE_MAPPING_SEQUENCE | Meterset to Dose Mapping Sequence (300A,0620)
MID_SLAB_POSITION | Mid Slab Position (0018,9106)
MILITARY_RANK | Military Rank (0010,1080)
MIME_TYPE_OF_ENCAPSULATED_DOCUMENT | MIME Type of Encapsulated Document (0042,0012)
MIN_DENSITY | Min Density (2010,0120)
MINIMUM_COORDINATE_VALUE_RETIRED | Minimum Coordinate Value RETIRED (5000,0104)
MINIMUM_HOURS_BETWEEN_FRACTIONS | Minimum Hours between Fractions (3010,0084)
MINIMUM_KERATOMETRIC_SEQUENCE | Minimum Keratometric Sequence (0046,0215)
MINIMUM_NOMINAL_ENERGY | Minimum Nominal Energy (300A,0681)
MINIMUM_NUMBER_OF_INTERVAL_DAYS | Minimum Number of Interval Days (3010,0050)
MINIMUM_SENSITIVITY_VALUE | Minimum Sensitivity Value (0024,0105)
MINIMUM_STORED_VALUE_MAPPED | Minimum Stored Value Mapped (0028,1231)
MODALITIES_IN_STUDY | Modalities in Study (0008,0061)
MODALITY | Modality (0008,0060)
MODALITY_LUT_SEQUENCE | Modality LUT Sequence (0028,3000)
MODALITY_LUT_TYPE | Modality LUT Type (0028,3004)
MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE | Mode of Percutaneous Access Sequence (0052,0016)
MODEL_GROUP_UID | Model Group UID (0068,7004)
MODEL_MIRRORING | Model Mirroring (0068,7002)
MODEL_MODIFICATION | Model Modification (0068,7001)
MODEL_SPECIFICATION_SEQUENCE | Model Specification Sequence (0018,9912)
MODEL_USAGE_CODE_SEQUENCE | Model Usage Code Sequence (0068,7003)
MODIFIABLE_CONSTRAINT_FLAG | Modifiable Constraint Flag (0082,0038)
MODIFIED_ATTRIBUTES_SEQUENCE | Modified Attributes Sequence (0400,0550)
MODIFIED_IMAGE_DATE_RETIRED | Modified Image Date RETIRED (0020,3403)
MODIFIED_IMAGE_DESCRIPTION_RETIRED | Modified Image Description RETIRED (0020,3406)
MODIFIED_IMAGE_ID_RETIRED | Modified Image ID RETIRED (0020,3402)
MODIFIED_IMAGE_TIME_RETIRED | Modified Image Time RETIRED (0020,3405)
MODIFIER_CODE_SEQUENCE | Modifier Code Sequence (0040,A195)
MODIFYING_DEVICE_ID_RETIRED | Modifying Device ID RETIRED (0020,3401)
MODIFYING_DEVICE_MANUFACTURER_RETIRED | Modifying Device Manufacturer RETIRED (0020,3404)
MODIFYING_SYSTEM | Modifying System (0400,0563)
MODULATED_SCAN_MODE_TYPE | Modulated Scan Mode Type (300A,0309)
MODULATION_TYPE | Modulation Type (0014,4026)
MONOENERGETIC_ENERGY_EQUIVALENT | Monoenergetic Energy Equivalent (0018,937C)
MOST_RECENT_TREATMENT_DATE | Most Recent Treatment Date (3008,0056)
MOTION_SYNCHRONIZATION_SEQUENCE | Motion Synchronization Sequence (300A,0410)
MOVE_DESTINATION | Move Destination (0000,0600)
MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE | Move Originator Application Entity Title (0000,1030)
MOVE_ORIGINATOR_MESSAGE_ID | Move Originator Message ID (0000,1031)
MPR_SLAB_THICKNESS | MPR Slab Thickness (0070,1503)
MPR_THICKNESS_TYPE | MPR Thickness Type (0070,1502)
MPR_TOP_LEFT_HAND_CORNER | MPR Top Left Hand Corner (0070,1505)
MPR_VIEW_HEIGHT | MPR View Height (0070,1512)
MPR_VIEW_HEIGHT_DIRECTION | MPR View Height Direction (0070,1511)
MPR_VIEW_WIDTH | MPR View Width (0070,1508)
MPR_VIEW_WIDTH_DIRECTION | MPR View Width Direction (0070,1507)
MR_ACQUISITION_FREQ_ENC_STEPS | Alias for tag MR_ACQUISITION_FREQUENCY_ENCODING_STEPS (0018,9058)
MR_ACQUISITION_FREQUENCY_ENCODING_STEPS | MR Acquisition Frequency Encoding Steps (0018,9058)
MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE | MR Acquisition Phase Encoding Steps in-plane (0018,9231)
MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE | MR Acquisition Phase Encoding Steps out-of-plane (0018,9232)
MR_ACQUISITION_TYPE | MR Acquisition Type (0018,0023)
MR_ARTERIAL_SPIN_LABELING_SEQUENCE | MR Arterial Spin Labeling Sequence (0018,9251)
MR_AVERAGES_SEQUENCE | MR Averages Sequence (0018,9119)
MR_DIFFUSION_SEQUENCE | MR Diffusion Sequence (0018,9117)
MR_ECHO_SEQUENCE | MR Echo Sequence (0018,9114)
MR_FOV_GEOMETRY_SEQUENCE | MR FOV/Geometry Sequence (0018,9125)
MR_IMAGE_FRAME_TYPE_SEQUENCE | MR Image Frame Type Sequence (0018,9226)
MR_IMAGING_MODIFIER_SEQUENCE | MR Imaging Modifier Sequence (0018,9006)
MR_METABOLITE_MAP_SEQUENCE | MR Metabolite Map Sequence (0018,9152)
MR_MODIFIER_SEQUENCE | MR Modifier Sequence (0018,9115)
MR_RECEIVE_COIL_SEQUENCE | MR Receive Coil Sequence (0018,9042)
MR_SPATIAL_SATURATION_SEQUENCE | MR Spatial Saturation Sequence (0018,9107)
MR_SPECTROSCOPY_ACQUISITION_TYPE | MR Spectroscopy Acquisition Type (0018,9200)
MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE | MR Spectroscopy FOV/Geometry Sequence (0018,9103)
MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE | MR Spectroscopy Frame Type Sequence (0018,9227)
MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE | MR Timing and Related Parameters Sequence (0018,9112)
MR_TRANSMIT_COIL_SEQUENCE | MR Transmit Coil Sequence (0018,9049)
MR_VELOCITY_ENCODING_SEQUENCE | MR Velocity Encoding Sequence (0018,9197)
MRDR_DIRECTORY_RECORD_OFFSET_RETIRED | MRDR Directory Record Offset RETIRED (0004,1504)
MULIPLEX_GROUP_LABEL | Alias for tag MULTIPLEX_GROUP_LABEL (003A,0020)
MULTI_COIL_CONFIGURATION | Multi-Coil Configuration (0018,9046)
MULTI_COIL_DEFINITION_SEQUENCE | Multi-Coil Definition Sequence (0018,9045)
MULTI_COIL_ELEMENT_NAME | Multi-Coil Element Name (0018,9047)
MULTI_COIL_ELEMENT_USED | Multi-Coil Element Used (0018,9048)
MULTI_ENERGY_ACQUISITION_DESCRIPTION | Multi-energy Acquisition Description (0018,937B)
MULTI_ENERGY_CT_ACQUISITION | Multi-energy CT Acquisition (0018,9361)
MULTI_ENERGY_CT_ACQUISITION_SEQUENCE | Multi-energy CT Acquisition Sequence (0018,9362)
MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE | Multi-energy CT Characteristics Sequence (0018,9364)
MULTI_ENERGY_CT_PATH_INDEX | Multi-energy CT Path Index (0018,937A)
MULTI_ENERGY_CT_PATH_SEQUENCE | Multi-energy CT Path Sequence (0018,9379)
MULTI_ENERGY_CT_PROCESSING_SEQUENCE | Multi-energy CT Processing Sequence (0018,9363)
MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE | Multi-energy CT X-Ray Detector Sequence (0018,936F)
MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE | Multi-energy CT X-Ray Source Sequence (0018,9365)
MULTI_ENERGY_DETECTOR_TYPE | Multi-energy Detector Type (0018,9372)
MULTI_ENERGY_SOURCE_TECHNIQUE | Multi-energy Source Technique (0018,9368)
MULTI_FRAME_PRESENTATION_SEQUENCE | Multi-frame Presentation Sequence (0028,9505)
MULTI_FRAME_SOURCE_SOP_INSTANCE_UID | Multi-frame Source SOP Instance UID (0008,1167)
MULTI_PLANAR_EXCITATION | Multi-planar Excitation (0018,9012)
MULTI_PLANAR_RECONSTRUCTION_STYLE | Multi-Planar Reconstruction Style (0070,1501)
MULTIPLE_COPIES_FLAG_RETIRED | Multiple Copies Flag RETIRED (0040,4006)
MULTIPLE_SPIN_ECHO | Multiple Spin Echo (0018,9011)
MULTIPLEX_GROUP_LABEL | Multiplex Group Label (003A,0020)
MULTIPLEX_GROUP_TIME_OFFSET | Multiplex Group Time Offset (0018,1068)
MULTIPLEX_GROUP_UID | Multiplex Group UID (003A,0310)
MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE | Multiplexed Audio Channels Description Code Sequence (003A,0300)
MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE | MV Imaging Generation Parameters Sequence (3002,0128)
MYDRIATIC_AGENT_CODE_SEQUENCE | Mydriatic Agent Code Sequence (0022,001C)
MYDRIATIC_AGENT_CONCENTRATION | Mydriatic Agent Concentration (0022,004E)
MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE | Mydriatic Agent Concentration Units Sequence (0022,0042)
MYDRIATIC_AGENT_SEQUENCE | Mydriatic Agent Sequence (0022,0058)
NAME_OF_PHYSICIANS_READING_STUDY | Name of Physician(s) Reading Study (0008,1060)
NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS | Names of Intended Recipients of Results (0040,1010)
NAVIGATION_DISPLAY_SET | Navigation Display Set (0072,0216)
NAVIGATION_INDICATOR_SEQUENCE | Navigation Indicator Sequence (0072,0214)
NEAR_PUPILLARY_DISTANCE | Near Pupillary Distance (0046,0062)
NEGATIVE_CATCH_TRIALS_QUANTITY | Negative Catch Trials Quantity (0024,0048)
NETWORK_ID_RETIRED | Network ID RETIRED (0008,1000)
NOMINAL_BEAM_ENERGY | Nominal Beam Energy (300A,0114)
NOMINAL_BEAM_ENERGY_UNIT | Nominal Beam Energy Unit (300A,0015)
NOMINAL_CARDIAC_TRIGGER_DELAY_TIME | Nominal Cardiac Trigger Delay Time (0020,9153)
NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK | Nominal Cardiac Trigger Time Prior To R-Peak (0020,9154)
NOMINAL_ENERGY | Nominal Energy (300A,0680)
NOMINAL_FREQUENCY | Nominal Frequency (0014,401A)
NOMINAL_INTERVAL | Nominal Interval (0018,1062)
NOMINAL_MAX_ENERGY | Nominal Max Energy (0018,9374)
NOMINAL_MIN_ENERGY | Nominal Min Energy (0018,9375)
NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE | Nominal Percentage of Cardiac Phase (0020,9241)
NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE | Nominal Percentage of Respiratory Phase (0020,9245)
NOMINAL_PRIOR_DOSE | Nominal Prior Dose (300A,001A)
NOMINAL_RANGE_MODULATED_REGION_DEPTHS | Nominal Range Modulated Region Depths (300A,0504)
NOMINAL_RANGE_MODULATION_FRACTIONS | Nominal Range Modulation Fractions (300A,0503)
NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME | Nominal Respiratory Trigger Delay Time (0020,9255)
NOMINAL_SCANNED_PIXEL_SPACING | Nominal Scanned Pixel Spacing (0018,2010)
NOMINAL_SCREEN_DEFINITION_SEQUENCE | Nominal Screen Definition Sequence (0072,0102)
NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED | Non-DICOM Output Code Sequence RETIRED (0040,4032)
NON_UNIFORM_RADIAL_SAMPLING_CORRECTED | Non-uniform Radial Sampling Corrected (0018,9766)
NONCONFORMING_DATA_ELEMENT_VALUE | Nonconforming Data Element Value (0400,0552)
NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE | Nonconforming Modified Attributes Sequence (0400,0551)
NONIDENTIFYING_PRIVATE_ELEMENTS | Nonidentifying Private Elements (0008,0304)
NORMAL_REVERSE_RETIRED | Normal/Reverse RETIRED (0000,5140)
NORMALIZATION_POINT | Normalization Point (3004,0008)
NOTCH_FILTER_BANDWIDTH | Notch Filter Bandwidth (003A,0223)
NOTCH_FILTER_CHARACTERISTICS_SEQUENCE | Notch Filter Characteristics Sequence (003A,0321)
NOTCH_FILTER_FREQUENCY | Notch Filter Frequency (003A,0222)
NOTIFICATION_FROM_MANUFACTURER_SEQUENCE | Notification From Manufacturer Sequence (0068,6265)
NTP_SOURCE_ADDRESS | NTP Source Address (0018,1803)
NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED | Nuclear Medicine Series Type RETIRED (0008,0042)
NUMBER_OF_ACQUISITION_DEVICES | Number of Acquisition Devices (3002,0116)
NUMBER_OF_ALARM_OBJECTS | Number of Alarm Objects (4010,1034)
NUMBER_OF_ANNOTATIONS | Number of Annotations (006A,000C)
NUMBER_OF_ASSESSMENT_OBSERVATIONS | Number of Assessment Observations (0082,0006)
NUMBER_OF_AVERAGES | Number of Averages (0018,0083)
NUMBER_OF_B_SCANS_PER_FRAME | Number of B-scans Per Frame (0022,1642)
NUMBER_OF_BEAMS | Number of Beams (300A,0080)
NUMBER_OF_BLOCK_SLAB_ITEMS | Number of Block Slab Items (300A,0440)
NUMBER_OF_BLOCKS | Number of Blocks (300A,00F0)
NUMBER_OF_BOLI | Number of Boli (300A,00ED)
NUMBER_OF_BOLUSES | Number of Boluses (300A,0674)
NUMBER_OF_BRACHY_APPLICATION_SETUPS | Number of Brachy Application Setups (300A,00A0)
NUMBER_OF_CHANNELS_RETIRED | Number of Channels RETIRED (5000,2004)
NUMBER_OF_COMPENSATORS | Number of Compensators (300A,00E0)
NUMBER_OF_COMPLETED_SUB_OPERATIONS | Number of Completed Sub-operations (0000,1021)
NUMBER_OF_COMPLETED_SUBOPERATIONS | Alias for tag NUMBER_OF_COMPLETED_SUB_OPERATIONS (0000,1021)
NUMBER_OF_CONTOUR_POINTS | Number of Contour Points (3006,0046)
NUMBER_OF_CONTROL_POINTS | Number of Control Points (300A,0110)
NUMBER_OF_COPIES | Number of Copies (2000,0010)
NUMBER_OF_DETECTORS | Number of Detectors (0054,0021)
NUMBER_OF_DISPLAY_SUBSYSTEMS | Number of Display Subsystems (0028,7001)
NUMBER_OF_ELEMENTS | Number of Elements (0014,4012)
NUMBER_OF_ENERGY_WINDOWS | Number of Energy Windows (0054,0011)
NUMBER_OF_EVENT_TIMERS | Number of Event Timers (0008,2129)
NUMBER_OF_FAILED_SUB_OPERATIONS | Number of Failed Sub-operations (0000,1022)
NUMBER_OF_FAILED_SUBOPERATIONS | Alias for tag NUMBER_OF_FAILED_SUB_OPERATIONS (0000,1022)
NUMBER_OF_FILMS | Number of Films (2100,0170)
NUMBER_OF_FOCAL_PLANES | Number of Focal Planes (0048,0013)
NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY | Number of Fraction Pattern Digits Per Day (300A,0079)
NUMBER_OF_FRACTIONS | Number of Fractions (3010,007D)
NUMBER_OF_FRACTIONS_DELIVERED | Number of Fractions Delivered (3008,005A)
NUMBER_OF_FRACTIONS_INCLUDED | Number of Fractions Included (300C,0119)
NUMBER_OF_FRACTIONS_PER_DAY | Alias for tag NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY (300A,0079)
NUMBER_OF_FRACTIONS_PLANNED | Number of Fractions Planned (300A,0078)
NUMBER_OF_FRAMES | Number of Frames (0028,0008)
NUMBER_OF_FRAMES_IN_OVERLAY | Number of Frames in Overlay (6000,0015)
NUMBER_OF_FRAMES_IN_PHASE | Number of Frames in Phase (0054,0033)
NUMBER_OF_FRAMES_IN_ROTATION | Number of Frames in Rotation (0054,0053)
NUMBER_OF_FRAMES_INTEGRATED | Number of Frames Integrated (0014,3012)
NUMBER_OF_FRAMES_USED_FOR_INTEGRATION | Number of Frames Used for Integration (0014,3073)
NUMBER_OF_GENERAL_ACCESSORIES | Number of General Accessories (300A,0672)
NUMBER_OF_GRAPHIC_POINTS | Number of Graphic Points (0070,0021)
NUMBER_OF_HORIZONTAL_PIXELS | Number of Horizontal Pixels (0072,0106)
NUMBER_OF_INTERVAL_FRACTIONS | Number of Interval Fractions (3010,007C)
NUMBER_OF_ITERATIONS | Number of Iterations (0018,9739)
NUMBER_OF_K_SPACE_TRAJECTORIES | Number of k-Space Trajectories (0018,9093)
NUMBER_OF_LATERAL_SPREADING_DEVICES | Number of Lateral Spreading Devices (300A,0330)
NUMBER_OF_LEAF_JAW_PAIRS | Number of Leaf/Jaw Pairs (300A,00BC)
NUMBER_OF_LUMINANCE_POINTS | Number of Luminance Points (0028,701B)
NUMBER_OF_MAP_POINTS | Number of Map Points (0022,1530)
NUMBER_OF_MATCHES_RETIRED | Number of Matches RETIRED (0000,0850)
NUMBER_OF_OPTICAL_PATHS | Number of Optical Paths (0048,0302)
NUMBER_OF_PADDED_A_LINES | Number of Padded A-lines (0052,0038)
NUMBER_OF_PAINTINGS | Number of Paintings (300A,039A)
NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS | Number of Parallel RT Beam Delimiters (300A,0648)
NUMBER_OF_PATIENT_RELATED_IMAGES | Alias for tag NUMBER_OF_PATIENT_RELATED_INSTANCES (0020,1204)
NUMBER_OF_PATIENT_RELATED_INSTANCES | Number of Patient Related Instances (0020,1204)
NUMBER_OF_PATIENT_RELATED_SERIES | Number of Patient Related Series (0020,1202)
NUMBER_OF_PATIENT_RELATED_STUDIES | Number of Patient Related Studies (0020,1200)
NUMBER_OF_PATIENT_SUPPORT_DEVICES | Number of Patient Support Devices (300A,0687)
NUMBER_OF_PHASE_ENCODING_STEPS | Number of Phase Encoding Steps (0018,0089)
NUMBER_OF_PHASES | Number of Phases (0054,0031)
NUMBER_OF_POINTS | Alias for tag NUMBER_OF_SURFACE_POINTS (0066,0015)
NUMBER_OF_POINTS_RETIRED | Number of Points RETIRED (5000,0010)
NUMBER_OF_POLYGONAL_VERTICES | Number of Polygonal Vertices (0018,1637)
NUMBER_OF_PRIORS_REFERENCED | Number of Priors Referenced (0072,0014)
NUMBER_OF_PULSES | Number of Pulses (300A,028A)
NUMBER_OF_R_R_INTERVALS | Number of R-R Intervals (0054,0061)
NUMBER_OF_RADIATION_GENERATION_MODES | Number of Radiation Generation Modes (300A,0685)
NUMBER_OF_RANGE_MODULATORS | Number of Range Modulators (300A,0340)
NUMBER_OF_RANGE_SHIFTERS | Number of Range Shifters (300A,0312)
NUMBER_OF_REFERENCES_RETIRED | Number of References RETIRED (0004,1600)
NUMBER_OF_REMAINING_SUB_OPERATIONS | Number of Remaining Sub-operations (0000,1020)
NUMBER_OF_REMAINING_SUBOPERATIONS | Alias for tag NUMBER_OF_REMAINING_SUB_OPERATIONS (0000,1020)
NUMBER_OF_ROTATIONS | Number of Rotations (0054,0051)
NUMBER_OF_RT_ACCESSORY_HOLDERS | Number of RT Accessory Holders (300A,0670)
NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS | Number of RT Beam Limiting Device Openings (300A,0657)
NUMBER_OF_RT_BEAM_LIMITING_DEVICES | Number of RT Beam Limiting Devices (300A,0641)
NUMBER_OF_RT_CONTROL_POINTS | Number of RT Control Points (300A,0604)
NUMBER_OF_SAMPLES_RETIRED | Number of Samples RETIRED (5000,2006)
NUMBER_OF_SCAN_SPOT_POSITIONS | Number of Scan Spot Positions (300A,0392)
NUMBER_OF_SCREENS | Number of Screens (0072,0100)
NUMBER_OF_SERIES_RELATED_IMAGES | Alias for tag NUMBER_OF_SERIES_RELATED_INSTANCES (0020,1209)
NUMBER_OF_SERIES_RELATED_INSTANCES | Number of Series Related Instances (0020,1209)
NUMBER_OF_SLICES | Number of Slices (0054,0081)
NUMBER_OF_STAGES | Number of Stages (0008,2124)
NUMBER_OF_STUDY_RECORDS_IN_INSTANCE | Number of Study Records in Instance (0008,0427)
NUMBER_OF_STUDY_RELATED_IMAGES | Alias for tag NUMBER_OF_STUDY_RELATED_INSTANCES (0020,1208)
NUMBER_OF_STUDY_RELATED_INSTANCES | Number of Study Related Instances (0020,1208)
NUMBER_OF_STUDY_RELATED_SERIES | Number of Study Related Series (0020,1206)
NUMBER_OF_SUBSETS | Number of Subsets (0018,9740)
NUMBER_OF_SURFACE_POINTS | Number of Surface Points (0066,0015)
NUMBER_OF_SURFACES | Number of Surfaces (0066,0001)
NUMBER_OF_TABLE_BREAK_POINTS | Number of Table Break Points (0018,6050)
NUMBER_OF_TABLE_COLUMNS | Number of Table Columns (0040,A803)
NUMBER_OF_TABLE_ENTRIES | Number of Table Entries (0018,6056)
NUMBER_OF_TABLE_ROWS | Number of Table Rows (0040,A802)
NUMBER_OF_TEMPORAL_POSITIONS | Number of Temporal Positions (0020,0105)
NUMBER_OF_TIME_SLICES | Number of Time Slices (0054,0101)
NUMBER_OF_TIME_SLOTS | Number of Time Slots (0054,0071)
NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES | Number of Tomosynthesis Source Images (0018,1495)
NUMBER_OF_TOTAL_OBJECTS | Number of Total Objects (4010,1033)
NUMBER_OF_TRIGGERS_IN_PHASE | Number of Triggers in Phase (0054,0211)
NUMBER_OF_VECTORS | Number of Vectors (0066,001E)
NUMBER_OF_VERTICAL_PIXELS | Number of Vertical Pixels (0072,0104)
NUMBER_OF_VIEWS_IN_STAGE | Number of Views in Stage (0008,212A)
NUMBER_OF_VISUAL_STIMULI | Number of Visual Stimuli (0024,0038)
NUMBER_OF_VOLUMETRIC_CURVE_POINTS | Number of Volumetric Curve Points (0070,150C)
NUMBER_OF_WARNING_SUB_OPERATIONS | Number of Warning Sub-operations (0000,1023)
NUMBER_OF_WARNING_SUBOPERATIONS | Alias for tag NUMBER_OF_WARNING_SUB_OPERATIONS (0000,1023)
NUMBER_OF_WAVEFORM_CHANNELS | Number of Waveform Channels (003A,0005)
NUMBER_OF_WAVEFORM_SAMPLES | Number of Waveform Samples (003A,0010)
NUMBER_OF_WEDGE_POSITIONS | Number of Wedge Positions (300A,0655)
NUMBER_OF_WEDGES | Number of Wedges (300A,00D0)
NUMBER_OF_ZERO_FILLS | Number of Zero Fills (0018,9066)
NUMERIC_VALUE | Numeric Value (0040,A30A)
NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE | Numeric Value Qualifier Code Sequence (0040,A301)
OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED | Object Binary Identifier (Trial) RETIRED (0040,A074)
OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED | Object Directory Binary Identifier (Trial) RETIRED (0040,A089)
OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM | Object Pixel Spacing in Center of Beam (0018,9404)
OBJECT_SOUND_SPEED | Object Sound Speed (0018,9833)
OBJECT_THICKNESS_SEQUENCE | Object Thickness Sequence (0018,9456)
OBJECTIVE_LENS_NUMERICAL_APERTURE | Objective Lens Numerical Aperture (0048,0113)
OBJECTIVE_LENS_POWER | Objective Lens Power (0048,0112)
OBLIQUE_CROPPING_PLANE | Alias for tag PLANE (0070,1305)
OBLIQUE_CROPPING_PLANE_NORMAL | Alias for tag PLANE_NORMAL (0070,1306)
OBLIQUE_CROPPING_PLANE_SEQUENCE | Oblique Cropping Plane Sequence (0070,1304)
OBSERVATION_BASIS_CODE_SEQUENCE | Observation Basis Code Sequence (0082,0022)
OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED | Observation Category Code Sequence (Trial) RETIRED (0040,A167)
OBSERVATION_DATE_TRIAL_RETIRED | Observation Date (Trial) RETIRED (0040,A192)
OBSERVATION_DATETIME | Observation DateTime (0040,A032)
OBSERVATION_DESCRIPTION | Observation Description (0082,000A)
OBSERVATION_NUMBER | Observation Number (3006,0082)
OBSERVATION_SIGNIFICANCE | Observation Significance (0082,0008)
OBSERVATION_START_DATETIME | Observation Start DateTime (0040,A033)
OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED | Observation Subject Class (Trial) RETIRED (0040,A403)
OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED | Observation Subject Context Flag (Trial) RETIRED (0040,A600)
OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED | Observation Subject Type Code Sequence (Trial) RETIRED (0040,A404)
OBSERVATION_SUBJECT_UID_TRIAL_RETIRED | Observation Subject UID (Trial) RETIRED (0040,A402)
OBSERVATION_TIME_TRIAL_RETIRED | Observation Time (Trial) RETIRED (0040,A193)
OBSERVATION_UID | Observation UID (0040,A171)
OBSERVATIONS_NUMBER | Alias for tag OBSERVATION_NUMBER (3006,0082)
OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED | Observer Context Flag (Trial) RETIRED (0040,A601)
OBSERVER_TYPE | Observer Type (0040,A084)
OCCUPATION | Occupation (0010,2180)
OCT_ACQUISITION_DOMAIN | OCT Acquisition Domain (0052,0006)
OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE | OCT B-scan Analysis Acquisition Parameters Sequence (0022,1640)
OCT_FOCAL_DISTANCE | OCT Focal Distance (0052,0002)
OCT_OPTICAL_CENTER_WAVELENGTH | OCT Optical Center Wavelength (0052,0007)
OCT_Z_OFFSET_APPLIED | OCT Z Offset Applied (0052,0026)
OCT_Z_OFFSET_CORRECTION | OCT Z Offset Correction (0052,0030)
OECF_COLUMN_NAMES | OECF Column Names (0016,0008)
OECF_COLUMNS | OECF Columns (0016,0007)
OECF_ROWS | OECF Rows (0016,0006)
OECF_VALUES | OECF Values (0016,0009)
OFFENDING_ELEMENT | Offending Element (0000,0901)
OFFSET_DIRECTION | Offset Direction (0018,9905)
OFFSET_DISTANCE | Offset Distance (0018,9904)
OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY | Alias for tag OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1200)
OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY | Alias for tag OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1202)
OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY | Offset of Referenced Lower-Level Directory Entity (0004,1420)
OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY | Offset of the First Directory Record of the Root Directory Entity (0004,1200)
OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY | Offset of the Last Directory Record of the Root Directory Entity (0004,1202)
OFFSET_OF_THE_NEXT_DIRECTORY_RECORD | Offset of the Next Directory Record (0004,1400)
OMITTED_APPLICATION_SETUP_SEQUENCE | Omitted Application Setup Sequence (0074,140E)
OMITTED_BEAM_TASK_SEQUENCE | Omitted Beam Task Sequence (300C,0111)
OMITTED_CHANNEL_SEQUENCE | Omitted Channel Sequence (0074,1409)
OMITTED_RADIATION_SEQUENCE | Omitted Radiation Sequence (300A,0787)
ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED | On Axis Background Anatomic Structure Code Sequence (Trial) RETIRED (0008,225C)
OOI_OWNER_CREATION_TIME | OOI Owner Creation Time (4010,1041)
OOI_OWNER_SEQUENCE | OOI Owner Sequence (4010,1047)
OOI_OWNER_TYPE | OOI Owner Type (4010,1009)
OOI_SIZE | OOI Size (4010,1043)
OOI_TYPE | OOI Type (4010,1042)
OOI_TYPE_DESCRIPTOR | OOI Type Descriptor (4010,1068)
OPERATING_MODE | Operating Mode (0018,9178)
OPERATING_MODE_SEQUENCE | Operating Mode Sequence (0018,9176)
OPERATING_MODE_TYPE | Operating Mode Type (0018,9177)
OPERATOR_IDENTIFICATION_SEQUENCE | Operator Identification Sequence (0008,1072)
OPERATORS_NAME | Operators' Name (0008,1070)
OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE | Ophthalmic Anatomic Reference Point X-Coordinate (0022,1624)
OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE | Ophthalmic Anatomic Reference Point Y-Coordinate (0022,1626)
OPHTHALMIC_AXIAL_LENGTH | Ophthalmic Axial Length (0022,1019)
OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED | Ophthalmic Axial Length Acquisition Method Code Sequence RETIRED (0022,1153)
OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE | Ophthalmic Axial Length Data Source Code Sequence (0022,1150)
OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION | Ophthalmic Axial Length Data Source Description (0022,1159)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED | Ophthalmic Axial Length Measurement Modified (0022,1140)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE | Ophthalmic Axial Length Measurements Length Summation Sequence (0022,1212)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE | Ophthalmic Axial Length Measurements Segment Name Code Sequence (0022,1101)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Measurements Segmental Length Sequence (0022,1211)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Ophthalmic Axial Length Measurements Sequence (0022,1050)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Measurements Total Length Sequence (0022,1210)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE | Ophthalmic Axial Length Measurements Type (0022,1010)
OPHTHALMIC_AXIAL_LENGTH_METHOD | Ophthalmic Axial Length Method (0022,1515)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE | Ophthalmic Axial Length Quality Metric Sequence (0022,1262)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED | Ophthalmic Axial Length Quality Metric Type Code Sequence RETIRED (0022,1265)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED | Ophthalmic Axial Length Quality Metric Type Description RETIRED (0022,1273)
OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE | Ophthalmic Axial Length Selection Method Code Sequence (0022,1250)
OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Sequence (0022,1012)
OPHTHALMIC_AXIAL_LENGTH_VELOCITY | Ophthalmic Axial Length Velocity (0022,1059)
OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE | Ophthalmic Axial Measurements Device Type (0022,1009)
OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE | Ophthalmic Axial Measurements Left Eye Sequence (0022,1008)
OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE | Ophthalmic Axial Measurements Right Eye Sequence (0022,1007)
OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE | Ophthalmic En Face Image Quality Rating Sequence (0022,1628)
OPHTHALMIC_FOV | Ophthalmic FOV (0022,1517)
OPHTHALMIC_FRAME_LOCATION_SEQUENCE | Ophthalmic Frame Location Sequence (0022,0031)
OPHTHALMIC_IMAGE_ORIENTATION | Ophthalmic Image Orientation (0022,0039)
OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE | Ophthalmic Image Type Code Sequence (0022,1615)
OPHTHALMIC_IMAGE_TYPE_DESCRIPTION | Ophthalmic Image Type Description (0022,1616)
OPHTHALMIC_MAPPING_DEVICE_TYPE | Ophthalmic Mapping Device Type (0022,1415)
OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE | Ophthalmic Patient Clinical Information Left Eye Sequence (0024,0114)
OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE | Ophthalmic Patient Clinical Information Right Eye Sequence (0024,0115)
OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE | Ophthalmic Thickness Map Quality Rating Sequence (0022,1470)
OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE | Ophthalmic Thickness Map Quality Threshold Sequence (0022,1458)
OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING | Ophthalmic Thickness Map Threshold Quality Rating (0022,1460)
OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE | Ophthalmic Thickness Map Type Code Sequence (0022,1436)
OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE | Ophthalmic Thickness Mapping Normals Sequence (0022,1443)
OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE | Alias for tag OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE (0022,1044)
OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE | Ophthalmic Ultrasound Method Code Sequence (0022,1044)
OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG | Ophthalmic Volumetric Properties Flag (0022,1622)
OPTICAL_MAGNIFICATION_FACTOR | Optical Magnification Factor (0016,1005)
OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Optical Ophthalmic Axial Length Measurements Sequence (0022,1225)
OPTICAL_PATH_DESCRIPTION | Optical Path Description (0048,0107)
OPTICAL_PATH_IDENTIFICATION_SEQUENCE | Optical Path Identification Sequence (0048,0207)
OPTICAL_PATH_IDENTIFIER | Optical Path Identifier (0048,0106)
OPTICAL_PATH_SEQUENCE | Optical Path Sequence (0048,0105)
OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Optical Selected Ophthalmic Axial Length Sequence (0022,1255)
OPTICAL_TRANSMITTANCE | Optical Transmittance (0046,0040)
OPTOTYPE | Optotype (0046,0094)
OPTOTYPE_DETAILED_DEFINITION | Optotype Detailed Definition (0046,0139)
OPTOTYPE_PRESENTATION | Optotype Presentation (0046,0095)
ORDER_CALLBACK_PHONE_NUMBER | Order Callback Phone Number (0040,2010)
ORDER_CALLBACK_TELECOM_INFORMATION | Order Callback Telecom Information (0040,2011)
ORDER_ENTERED_BY | Order Entered By (0040,2008)
ORDER_ENTERERS_LOCATION | Order Enterer's Location (0040,2009)
ORDER_FILLER_IDENTIFIER_SEQUENCE | Order Filler Identifier Sequence (0040,0027)
ORDER_PLACER_IDENTIFIER_SEQUENCE | Order Placer Identifier Sequence (0040,0026)
ORGAN_AT_RISK_FULL_VOLUME_DOSE | Organ at Risk Full-volume Dose (300A,002A)
ORGAN_AT_RISK_LIMIT_DOSE | Organ at Risk Limit Dose (300A,002B)
ORGAN_AT_RISK_MAXIMUM_DOSE | Organ at Risk Maximum Dose (300A,002C)
ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION | Organ at Risk Overdose Volume Fraction (300A,002D)
ORGAN_DOSE | Organ Dose (0040,0316)
ORGAN_EXPOSED | Organ Exposed (0040,0318)
ORGANIZATIONAL_ROLE_CODE_SEQUENCE | Organizational Role Code Sequence (0044,010A)
ORIGIN | Alias for tag OVERLAY_ORIGIN (6000,0050)
ORIGINAL_ATTRIBUTES_SEQUENCE | Original Attributes Sequence (0400,0561)
ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED | Original Image Identification Nomenclature RETIRED (0020,5002)
ORIGINAL_IMAGE_IDENTIFICATION_RETIRED | Original Image Identification RETIRED (0020,5000)
ORIGINAL_IMAGE_SEQUENCE | Original Image Sequence (2130,00C0)
ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Original Implant Assembly Template Sequence (0076,000C)
ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE | Original Implant Template Sequence (0068,6225)
ORIGINAL_SPECIALIZED_SOP_CLASS_UID | Original Specialized SOP Class UID (0008,001B)
ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE | Originating SOP Instance Reference Sequence (3010,0007)
ORIGINATOR | Originator (2100,0070)
OTHER_FAILURES_SEQUENCE | Other Failures Sequence (0008,119A)
OTHER_MAGNIFICATION_TYPES_AVAILABLE | Other Magnification Types Available (2010,00A7)
OTHER_MEDIA_AVAILABLE_SEQUENCE | Other Media Available Sequence (2000,00A4)
OTHER_PATIENT_IDS_RETIRED | Other Patient IDs RETIRED (0010,1000)
OTHER_PATIENT_IDS_SEQUENCE | Other Patient IDs Sequence (0010,1002)
OTHER_PATIENT_NAMES | Other Patient Names (0010,1001)
OTHER_PUPILLARY_DISTANCE | Other Pupillary Distance (0046,0064)
OTHER_SMOOTHING_TYPES_AVAILABLE | Other Smoothing Types Available (2010,00A9)
OTHER_STUDY_NUMBERS_RETIRED | Other Study Numbers RETIRED (0020,1070)
OUTER_DIAMETER | Outer Diameter (0014,0054)
OUTLINE_LEFT_VERTICAL_EDGE | Outline Left Vertical Edge (0018,1631)
OUTLINE_LOWER_HORIZONTAL_EDGE | Outline Lower Horizontal Edge (0018,1634)
OUTLINE_RIGHT_VERTICAL_EDGE | Outline Right Vertical Edge (0018,1632)
OUTLINE_SHAPE_TYPE | Outline Shape Type (0018,1630)
OUTLINE_UPPER_HORIZONTAL_EDGE | Outline Upper Horizontal Edge (0018,1633)
OUTPUT_DESTINATION_SEQUENCE | Output Destination Sequence (0040,4070)
OUTPUT_INFORMATION_SEQUENCE | Output Information Sequence (0040,4033)
OUTPUT_POWER | Output Power (0018,5000)
OVERALL_TEMPLATE_SPATIAL_TOLERANCE | Overall Template Spatial Tolerance (0068,62A5)
OVERLAY_ACTIVATION_LAYER | Overlay Activation Layer (6000,1001)
OVERLAY_BACKGROUND_DENSITY_RETIRED | Overlay Background Density RETIRED (2040,0082)
OVERLAY_BIT_POSITION | Overlay Bit Position (6000,0102)
OVERLAY_BITS_ALLOCATED | Overlay Bits Allocated (6000,0100)
OVERLAY_COLUMNS | Overlay Columns (6000,0011)
OVERLAY_COMMENTS_RETIRED | Overlay Comments RETIRED (6000,4000)
OVERLAY_COMPRESSION_CODE_RETIRED | Overlay Compression Code RETIRED (6000,0060)
OVERLAY_DATA | Overlay Data (6000,3000)
OVERLAY_DATE_RETIRED | Overlay Date RETIRED (0008,0024)
OVERLAY_DESCRIPTION | Overlay Description (6000,0022)
OVERLAY_DESCRIPTOR_BLUE_RETIRED | Overlay Descriptor - Blue RETIRED (6000,1103)
OVERLAY_DESCRIPTOR_GRAY_RETIRED | Overlay Descriptor - Gray RETIRED (6000,1100)
OVERLAY_DESCRIPTOR_GREEN_RETIRED | Overlay Descriptor - Green RETIRED (6000,1102)
OVERLAY_DESCRIPTOR_RED_RETIRED | Overlay Descriptor - Red RETIRED (6000,1101)
OVERLAY_FOREGROUND_DENSITY_RETIRED | Overlay Foreground Density RETIRED (2040,0080)
OVERLAY_FORMAT_RETIRED | Overlay Format RETIRED (6000,0110)
OVERLAY_LABEL | Overlay Label (6000,1500)
OVERLAY_LOCATION_RETIRED | Overlay Location RETIRED (6000,0200)
OVERLAY_MAGNIFICATION_TYPE_RETIRED | Overlay Magnification Type RETIRED (2040,0060)
OVERLAY_MODE_RETIRED | Overlay Mode RETIRED (2040,0090)
OVERLAY_NUMBER_RETIRED | Overlay Number RETIRED (0020,0022)
OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED | Overlay or Image Magnification RETIRED (2040,0072)
OVERLAY_ORIGIN | Overlay Origin (6000,0050)
OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED | Overlay Pixel Data Sequence RETIRED (2040,0020)
OVERLAY_PLANE_ORIGIN_RETIRED | Overlay Plane Origin RETIRED (6000,0052)
OVERLAY_PLANES_RETIRED | Overlay Planes RETIRED (6000,0012)
OVERLAY_ROWS | Overlay Rows (6000,0010)
OVERLAY_SMOOTHING_TYPE_RETIRED | Overlay Smoothing Type RETIRED (2040,0070)
OVERLAY_SUBTYPE | Overlay Subtype (6000,0045)
OVERLAY_TIME_RETIRED | Overlay Time RETIRED (0008,0034)
OVERLAY_TYPE | Overlay Type (6000,0040)
OVERLAYS_BLUE_RETIRED | Overlays - Blue RETIRED (6000,1203)
OVERLAYS_GRAY_RETIRED | Overlays - Gray RETIRED (6000,1200)
OVERLAYS_GREEN_RETIRED | Overlays - Green RETIRED (6000,1202)
OVERLAYS_RED_RETIRED | Overlays - Red RETIRED (6000,1201)
OVERLAYS_RETIRED | Overlays RETIRED (0000,51B0)
OVERRIDDEN_ATTRIBUTES_SEQUENCE | Overridden Attributes Sequence (0074,104A)
OVERRIDE_DATETIME | Override DateTime (300A,0760)
OVERRIDE_PARAMETER_POINTER | Override Parameter Pointer (3008,0062)
OVERRIDE_REASON | Override Reason (3008,0066)
OVERRIDE_SEQUENCE | Override Sequence (3008,0060)
OVERSAMPLING_PHASE | Oversampling Phase (0018,9029)
OWNER_ID | Owner ID (2100,0160)
PADDLE_DESCRIPTION | Paddle Description (0018,11A4)
PAGE_NUMBER_VECTOR | Page Number Vector (0018,2001)
PAGE_POSITION_ID_RETIRED | Page Position ID RETIRED (0000,5120)
PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE | Palette Color Lookup Table Sequence (0048,0120)
PALETTE_COLOR_LOOKUP_TABLE_UID | Palette Color Lookup Table UID (0028,1199)
PARALLEL_ACQUISITION | Parallel Acquisition (0018,9077)
PARALLEL_ACQUISITION_TECHNIQUE | Parallel Acquisition Technique (0018,9078)
PARALLEL_REDUCTION_FACTOR_IN_PLANE | Parallel Reduction Factor In-plane (0018,9069)
PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED | Parallel Reduction Factor In-plane (Retired) (0018,9096)
PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE | Parallel Reduction Factor out-of-plane (0018,9155)
PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE | Parallel Reduction Factor Second In-plane (0018,9168)
PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES | Parallel RT Beam Delimiter Boundaries (300A,0649)
PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE | Parallel RT Beam Delimiter Device Orientation Label Code Sequence (300A,0644)
PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE | Parallel RT Beam Delimiter Device Sequence (300A,0647)
PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE | Parallel RT Beam Delimiter Leaf Mounting Side (300A,064F)
PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS | Parallel RT Beam Delimiter Opening Extents (3008,00A4)
PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE | Parallel RT Beam Delimiter Opening Mode (300A,064E)
PARALLEL_RT_BEAM_DELIMITER_POSITIONS | Parallel RT Beam Delimiter Positions (300A,064A)
PARAMETER_ITEM_INDEX | Parameter Item Index (3008,0063)
PARAMETER_POINTER | Parameter Pointer (3008,0065)
PARAMETER_SEQUENCE_POINTER | Parameter Sequence Pointer (3008,0061)
PARAMETER_VALUE_NUMBER | Parameter Value Number (3008,0067)
PARAMETERS_SPECIFICATION_SEQUENCE | Parameters Specification Sequence (0018,9913)
PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE | Parametric Map Frame Type Sequence (0040,9092)
PARTIAL_DATA_DISPLAY_HANDLING | Partial Data Display Handling (0072,0208)
PARTIAL_FOURIER | Partial Fourier (0018,9081)
PARTIAL_FOURIER_DIRECTION | Partial Fourier Direction (0018,9036)
PARTIAL_VIEW | Partial View (0028,1350)
PARTIAL_VIEW_CODE_SEQUENCE | Partial View Code Sequence (0028,1352)
PARTIAL_VIEW_DESCRIPTION | Partial View Description (0028,1351)
PARTICIPANT_SEQUENCE | Participant Sequence (0040,A07A)
PARTICIPATION_DATETIME | Participation DateTime (0040,A082)
PARTICIPATION_TYPE | Participation Type (0040,A080)
PATIENT_ADDITIONAL_POSITION | Patient Additional Position (300A,0184)
PATIENT_BREED_CODE_SEQUENCE | Patient Breed Code Sequence (0010,2293)
PATIENT_BREED_DESCRIPTION | Patient Breed Description (0010,2292)
PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE | Patient Clinical Trial Participation Sequence (0038,0502)
PATIENT_COMMENTS | Patient Comments (0010,4000)
PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE | Patient Equipment Relationship Code Sequence (3010,0030)
PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE | Patient Eye Movement Command Code Sequence (0022,0006)
PATIENT_EYE_MOVEMENT_COMMANDED | Patient Eye Movement Commanded (0022,0005)
PATIENT_FRAME_OF_REFERENCE_SOURCE | Patient Frame of Reference Source (0020,930C)
PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE | Patient Gantry Relationship Code Sequence (0054,0414)
PATIENT_ID | Patient ID (0010,0020)
PATIENT_IDENTITY_REMOVED | Patient Identity Removed (0012,0062)
PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE | Patient Location Coordinates Code Sequence (3006,00CA)
PATIENT_LOCATION_COORDINATES_SEQUENCE | Patient Location Coordinates Sequence (3006,00C9)
PATIENT_MOTION_CORRECTED | Patient Motion Corrected (0018,9763)
PATIENT_NOT_PROPERLY_FIXATED_QUANTITY | Patient Not Properly Fixated Quantity (0024,0036)
PATIENT_ORIENTATION | Patient Orientation (0020,0020)
PATIENT_ORIENTATION_CODE_SEQUENCE | Patient Orientation Code Sequence (0054,0410)
PATIENT_ORIENTATION_IN_FRAME_SEQUENCE | Patient Orientation in Frame Sequence (0020,9450)
PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE | Patient Orientation Modifier Code Sequence (0054,0412)
PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE | Patient Physiological State Code Sequence (0018,9772)
PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE | Patient Physiological State Sequence (0018,9771)
PATIENT_POSITION | Patient Position (0018,5100)
PATIENT_POSITIONING_INSTRUCTION_SEQUENCE | Patient Positioning Instruction Sequence (0018,991B)
PATIENT_RELIABILITY_INDICATOR | Patient Reliability Indicator (0024,0069)
PATIENT_SETUP_LABEL | Patient Setup Label (300A,0183)
PATIENT_SETUP_NUMBER | Patient Setup Number (300A,0182)
PATIENT_SETUP_PHOTO_DESCRIPTION | Patient Setup Photo Description (300A,0794)
PATIENT_SETUP_SEQUENCE | Patient Setup Sequence (300A,0180)
PATIENT_SETUP_UID_RETIRED | Patient Setup UID RETIRED (300A,0650)
PATIENT_SPECIES_CODE_SEQUENCE | Patient Species Code Sequence (0010,2202)
PATIENT_SPECIES_DESCRIPTION | Patient Species Description (0010,2201)
PATIENT_SPECIFICATION_SEQUENCE | Patient Specification Sequence (0018,9911)
PATIENT_STATE | Patient State (0038,0500)
PATIENT_SUPPORT_ACCESSORY_CODE | Patient Support Accessory Code (300A,0354)
PATIENT_SUPPORT_ADJUSTED_ANGLE | Patient Support Adjusted Angle (0074,102A)
PATIENT_SUPPORT_ANGLE | Patient Support Angle (300A,0122)
PATIENT_SUPPORT_ANGLE_TOLERANCE | Patient Support Angle Tolerance (300A,004C)
PATIENT_SUPPORT_DEVICES_SEQUENCE | Patient Support Devices Sequence (300A,0686)
PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE | Patient Support Displacement Sequence (300A,079C)
PATIENT_SUPPORT_ID | Patient Support ID (300A,0352)
PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE | Patient Support Position Device Parameter Sequence (300A,065D)
PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE | Patient Support Position Device Tolerance Sequence (300A,0660)
PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX | Patient Support Position Parameter Order Index (300A,065F)
PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE | Patient Support Position Parameter Sequence (300A,065B)
PATIENT_SUPPORT_POSITION_SEQUENCE | Patient Support Position Sequence (3006,00CB)
PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD | Patient Support Position Specification Method (300A,065C)
PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX | Patient Support Position Tolerance Order Index (300A,0661)
PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE | Patient Support Position Tolerance Sequence (300A,062D)
PATIENT_SUPPORT_ROTATION_DIRECTION | Patient Support Rotation Direction (300A,0123)
PATIENT_SUPPORT_TYPE | Patient Support Type (300A,0350)
PATIENT_TRANSPORT_ARRANGEMENTS | Patient Transport Arrangements (0040,1004)
PATIENT_TREATMENT_ORIENTATION_SEQUENCE | Patient Treatment Orientation Sequence (3010,0032)
PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE | Patient Treatment Preparation Device Sequence (300A,078F)
PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE | Patient Treatment Preparation Method Code Sequence (300A,078D)
PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION | Patient Treatment Preparation Method Description (300A,0792)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE | Patient Treatment Preparation Procedure Code Sequence (300A,0791)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX | Patient Treatment Preparation Procedure Index (300A,0795)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION | Patient Treatment Preparation Procedure Parameter Description (300A,078E)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE | Patient Treatment Preparation Procedure Parameter Sequence (300A,0793)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE | Patient Treatment Preparation Procedure Sequence (300A,0790)
PATIENTS_ADDRESS | Patient's Address (0010,1040)
PATIENTS_AGE | Patient's Age (0010,1010)
PATIENTS_ALTERNATIVE_CALENDAR | Patient's Alternative Calendar (0010,0035)
PATIENTS_BIRTH_DATE | Patient's Birth Date (0010,0030)
PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR | Patient's Birth Date in Alternative Calendar (0010,0033)
PATIENTS_BIRTH_NAME | Patient's Birth Name (0010,1005)
PATIENTS_BIRTH_TIME | Patient's Birth Time (0010,0032)
PATIENTS_BODY_MASS_INDEX | Patient's Body Mass Index (0010,1022)
PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR | Patient's Death Date in Alternative Calendar (0010,0034)
PATIENTS_INSTITUTION_RESIDENCE | Patient's Institution Residence (0038,0400)
PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE | Patient's Insurance Plan Code Sequence (0010,0050)
PATIENTS_MOTHERS_BIRTH_NAME | Patient's Mother's Birth Name (0010,1060)
PATIENTS_NAME | Patient's Name (0010,0010)
PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE | Patient's Primary Language Code Sequence (0010,0101)
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE | Patient's Primary Language Modifier Code Sequence (0010,0102)
PATIENTS_RELIGIOUS_PREFERENCE | Patient's Religious Preference (0010,21F0)
PATIENTS_SEX | Patient's Sex (0010,0040)
PATIENTS_SEX_NEUTERED | Patient's Sex Neutered (0010,2203)
PATIENTS_SIZE | Patient's Size (0010,1020)
PATIENTS_SIZE_CODE_SEQUENCE | Patient's Size Code Sequence (0010,1021)
PATIENTS_TELECOM_INFORMATION | Patient's Telecom Information (0010,2155)
PATIENTS_TELEPHONE_NUMBERS | Patient's Telephone Numbers (0010,2154)
PATIENTS_WEIGHT | Patient's Weight (0010,1030)
PATTERN_OFF_COLOR_CIELAB_VALUE | Pattern Off Color CIELab Value (0070,0252)
PATTERN_OFF_OPACITY | Pattern Off Opacity (0070,0285)
PATTERN_ON_COLOR_CIELAB_VALUE | Pattern On Color CIELab Value (0070,0251)
PATTERN_ON_OPACITY | Pattern On Opacity (0070,0284)
PAUSE_BETWEEN_FRAMES | Pause Between Frames (0054,0038)
PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Per-frame Functional Groups Sequence (5200,9230)
PER_PROJECTION_ACQUISITION_SEQUENCE | Per Projection Acquisition Sequence (0018,9538)
PERCENT_PHASE_FIELD_OF_VIEW | Percent Phase Field of View (0018,0094)
PERCENT_SAMPLING | Percent Sampling (0018,0093)
PERFORMED_LOCATION | Performed Location (0040,0243)
PERFORMED_PROCEDURE_CODE_SEQUENCE | Performed Procedure Code Sequence (0040,A372)
PERFORMED_PROCEDURE_STEP_DESCRIPTION | Performed Procedure Step Description (0040,0254)
PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Performed Procedure Step Discontinuation Reason Code Sequence (0040,0281)
PERFORMED_PROCEDURE_STEP_END_DATE | Performed Procedure Step End Date (0040,0250)
PERFORMED_PROCEDURE_STEP_END_DATETIME | Performed Procedure Step End DateTime (0040,4051)
PERFORMED_PROCEDURE_STEP_END_TIME | Performed Procedure Step End Time (0040,0251)
PERFORMED_PROCEDURE_STEP_ID | Performed Procedure Step ID (0040,0253)
PERFORMED_PROCEDURE_STEP_START_DATE | Performed Procedure Step Start Date (0040,0244)
PERFORMED_PROCEDURE_STEP_START_DATETIME | Performed Procedure Step Start DateTime (0040,4050)
PERFORMED_PROCEDURE_STEP_START_TIME | Performed Procedure Step Start Time (0040,0245)
PERFORMED_PROCEDURE_STEP_STATUS | Performed Procedure Step Status (0040,0252)
PERFORMED_PROCEDURE_TYPE_DESCRIPTION | Performed Procedure Type Description (0040,0255)
PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED | Performed Processing Applications Code Sequence RETIRED (0040,4007)
PERFORMED_PROCESSING_PARAMETERS_SEQUENCE | Performed Processing Parameters Sequence (0074,1212)
PERFORMED_PROTOCOL_CODE_SEQUENCE | Performed Protocol Code Sequence (0040,0260)
PERFORMED_PROTOCOL_TYPE | Performed Protocol Type (0040,0261)
PERFORMED_SERIES_SEQUENCE | Performed Series Sequence (0040,0340)
PERFORMED_STATION_AE_TITLE | Performed Station AE Title (0040,0241)
PERFORMED_STATION_CLASS_CODE_SEQUENCE | Performed Station Class Code Sequence (0040,4029)
PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE | Performed Station Geographic Location Code Sequence (0040,4030)
PERFORMED_STATION_NAME | Performed Station Name (0040,0242)
PERFORMED_STATION_NAME_CODE_SEQUENCE | Performed Station Name Code Sequence (0040,4028)
PERFORMED_WORKITEM_CODE_SEQUENCE | Performed Workitem Code Sequence (0040,4019)
PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Performing Physician Identification Sequence (0008,1052)
PERFORMING_PHYSICIANS_NAME | Performing Physician's Name (0008,1050)
PERSON_IDENTIFICATION_CODE_SEQUENCE | Person Identification Code Sequence (0040,1101)
PERSON_NAME | Person Name (0040,A123)
PERSONS_ADDRESS | Person's Address (0040,1102)
PERSONS_TELECOM_INFORMATION | Person's Telecom Information (0040,1104)
PERSONS_TELEPHONE_NUMBERS | Person's Telephone Numbers (0040,1103)
PERTINENT_DOCUMENTS_SEQUENCE | Pertinent Documents Sequence (0038,0100)
PERTINENT_OTHER_EVIDENCE_SEQUENCE | Pertinent Other Evidence Sequence (0040,A385)
PERTINENT_PRIOR_EVIDENCE_SEQUENCE | Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A385)
PERTINENT_RESOURCES_SEQUENCE | Pertinent Resources Sequence (0038,0101)
PERTINENT_SOP_CLASSES_IN_SERIES | Pertinent SOP Classes in Series (3010,0053)
PERTINENT_SOP_CLASSES_IN_STUDY | Pertinent SOP Classes in Study (3010,0052)
PET_DETECTOR_MOTION_DETAILS_SEQUENCE | PET Detector Motion Details Sequence (0018,9733)
PET_FRAME_ACQUISITION_SEQUENCE | PET Frame Acquisition Sequence (0018,9732)
PET_FRAME_CORRECTION_FACTORS_SEQUENCE | PET Frame Correction Factors Sequence (0018,9736)
PET_FRAME_TYPE_SEQUENCE | PET Frame Type Sequence (0018,9751)
PET_POSITION_SEQUENCE | PET Position Sequence (0018,9735)
PET_RECONSTRUCTION_SEQUENCE | PET Reconstruction Sequence (0018,9749)
PET_TABLE_DYNAMICS_SEQUENCE | PET Table Dynamics Sequence (0018,9734)
PHANTOM_TYPE | Phantom Type (4010,1046)
PHASE_CONTRAST | Phase Contrast (0018,9014)
PHASE_DELAY | Phase Delay (0054,0036)
PHASE_DESCRIPTION | Phase Description (0054,0039)
PHASE_INFORMATION_SEQUENCE | Phase Information Sequence (0054,0032)
PHASE_NUMBER_RETIRED | Phase Number RETIRED (0020,0015)
PHASE_VECTOR | Phase Vector (0054,0030)
PHOSPHOR_TYPE | Phosphor Type (0018,1261)
PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE | Photoacoustic Excitation Characteristics Sequence (0018,9821)
PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE | Photoacoustic Image Frame Type Sequence (0018,9835)
PHOTOGRAPHIC_EXPOSURE_INDEX | Photographic Exposure Index (0016,0038)
PHOTOGRAPHIC_SENSITIVITY | Photographic Sensitivity (0016,0018)
PHOTOMETRIC_INTERPRETATION | Photometric Interpretation (0028,0004)
PHOTON_ENERGY | Photon Energy (0018,9383)
PHOTOTIMER_SETTING | Phototimer Setting (0018,7065)
PHYSICAL_DELTA_X | Physical Delta X (0018,602C)
PHYSICAL_DELTA_Y | Physical Delta Y (0018,602E)
PHYSICAL_DETECTOR_SIZE | Physical Detector Size (0018,9429)
PHYSICAL_UNITS_X_DIRECTION | Physical Units X Direction (0018,6024)
PHYSICAL_UNITS_Y_DIRECTION | Physical Units Y Direction (0018,6026)
PHYSICIAN_APPROVING_INTERPRETATION_RETIRED | Physician Approving Interpretation RETIRED (4008,0114)
PHYSICIANS_OF_RECORD | Physician(s) of Record (0008,1048)
PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE | Physician(s) of Record Identification Sequence (0008,1049)
PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE | Physician(s) Reading Study Identification Sequence (0008,1062)
PIXEL_ASPECT_RATIO | Pixel Aspect Ratio (0028,0034)
PIXEL_BANDWIDTH | Pixel Bandwidth (0018,0095)
PIXEL_COMPONENT_DATA_TYPE | Pixel Component Data Type (0018,604E)
PIXEL_COMPONENT_MASK | Pixel Component Mask (0018,6046)
PIXEL_COMPONENT_ORGANIZATION | Pixel Component Organization (0018,6044)
PIXEL_COMPONENT_PHYSICAL_UNITS | Pixel Component Physical Units (0018,604C)
PIXEL_COMPONENT_RANGE_START | Pixel Component Range Start (0018,6048)
PIXEL_COMPONENT_RANGE_STOP | Pixel Component Range Stop (0018,604A)
PIXEL_COORDINATES_SET_TRIAL_RETIRED | Pixel Coordinates Set (Trial) RETIRED (0040,A29A)
PIXEL_DATA | Pixel Data (7FE0,0010)
PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV | Pixel Data Area Origin Relative To FOV (0018,7036)
PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV | Pixel Data Area Rotation Angle Relative To FOV (0018,7038)
PIXEL_DATA_PROVIDER_URL | Pixel Data Provider URL (0028,7FE0)
PIXEL_INTENSITY_RELATIONSHIP | Pixel Intensity Relationship (0028,1040)
PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE | Pixel Intensity Relationship LUT Sequence (0028,9422)
PIXEL_INTENSITY_RELATIONSHIP_SIGN | Pixel Intensity Relationship Sign (0028,1041)
PIXEL_MEASURES_SEQUENCE | Pixel Measures Sequence (0028,9110)
PIXEL_ORIGIN_INTERPRETATION | Pixel Origin Interpretation (0048,0301)
PIXEL_PADDING_RANGE_LIMIT | Pixel Padding Range Limit (0028,0121)
PIXEL_PADDING_VALUE | Pixel Padding Value (0028,0120)
PIXEL_PRESENTATION | Pixel Presentation (0008,9205)
PIXEL_REPRESENTATION | Pixel Representation (0028,0103)
PIXEL_SHIFT_FRAME_RANGE | Pixel Shift Frame Range (0028,9506)
PIXEL_SHIFT_SEQUENCE | Pixel Shift Sequence (0028,9501)
PIXEL_SPACING | Pixel Spacing (0028,0030)
PIXEL_SPACING_CALIBRATION_DESCRIPTION | Pixel Spacing Calibration Description (0028,0A04)
PIXEL_SPACING_CALIBRATION_TYPE | Pixel Spacing Calibration Type (0028,0A02)
PIXEL_SPACING_SEQUENCE_RETIRED | Pixel Spacing Sequence RETIRED (0040,08D8)
PIXEL_VALUE_MAPPING_CODE_SEQUENCE | Pixel Value Mapping Code Sequence (0040,9098)
PIXEL_VALUE_MAPPING_EXPLANATION | Pixel Value Mapping Explanation (0022,1454)
PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE | Pixel Value Mapping to Coded Concept Sequence (0022,1450)
PIXEL_VALUE_TRANSFORMATION_SEQUENCE | Pixel Value Transformation Sequence (0028,9145)
PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST | Placer Order Number / Imaging Service Request (0040,2016)
PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED | Placer Order Number Imaging Service Request (Retired) (0040,2006)
PLACER_ORDER_NUMBER_PROCEDURE_RETIRED | Placer Order Number / Procedure RETIRED (0040,1006)
PLAN_INTENT | Plan Intent (300A,000A)
PLAN_OVERVIEW_INDEX | Plan Overview Index (300C,0117)
PLAN_OVERVIEW_SEQUENCE | Plan Overview Sequence (300C,0116)
PLANAR_CONFIGURATION | Planar Configuration (0028,0006)
PLANE | Plane (0070,1305)
PLANE_IDENTIFICATION | Plane Identification (0018,9457)
PLANE_NORMAL | Plane Normal (0070,1306)
PLANE_ORIENTATION_SEQUENCE | Plane Orientation Sequence (0020,9116)
PLANE_ORIENTATION_VOLEME_SEQUENCE | Alias for tag PLANE_ORIENTATION_VOLUME_SEQUENCE (0020,930F)
PLANE_ORIENTATION_VOLUME_SEQUENCE | Plane Orientation (Volume) Sequence (0020,930F)
PLANE_POSITION_SEQUENCE | Plane Position Sequence (0020,9113)
PLANE_POSITION_SLIDE_SEQUENCE | Plane Position (Slide) Sequence (0048,021A)
PLANE_POSITION_VOLUME_SEQUENCE | Plane Position (Volume) Sequence (0020,930E)
PLANES_IN_ACQUISITION | Planes in Acquisition (0018,9410)
PLANES_RETIRED | Planes RETIRED (0028,0012)
PLANNED_VERIFICATION_IMAGE_SEQUENCE | Planned Verification Image Sequence (300A,00CA)
PLANNING_INPUT_INFORMATION_SEQUENCE | Planning Input Information Sequence (3010,0076)
PLANNING_LANDMARK_DESCRIPTION | Planning Landmark Description (0068,6540)
PLANNING_LANDMARK_ID | Planning Landmark ID (0068,6530)
PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE | Planning Landmark Identification Code Sequence (0068,6545)
PLANNING_LANDMARK_LINE_SEQUENCE | Planning Landmark Line Sequence (0068,6510)
PLANNING_LANDMARK_PLANE_SEQUENCE | Planning Landmark Plane Sequence (0068,6520)
PLANNING_LANDMARK_POINT_SEQUENCE | Planning Landmark Point Sequence (0068,6500)
PLATE_ID | Plate ID (0018,1004)
PLATE_TYPE | Plate Type (0018,1260)
POINT_COORDINATES_DATA | Point Coordinates Data (0066,0016)
POINT_POSITION_ACCURACY | Point Position Accuracy (0066,0017)
POINTS_BOUNDING_BOX_COORDINATES | Points Bounding Box Coordinates (0066,001A)
POLARITY | Polarity (2020,0020)
POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE | Position Acquisition Template Code Sequence (3002,0122)
POSITION_ACQUISITION_TEMPLATE_DESCRIPTION | Position Acquisition Template Description (3002,0123)
POSITION_ACQUISITION_TEMPLATE_ID | Position Acquisition Template ID (3002,0120)
POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE | Position Acquisition Template Identification Sequence (3002,011F)
POSITION_ACQUISITION_TEMPLATE_NAME | Position Acquisition Template Name (3002,0121)
POSITION_MEASURING_DEVICE_USED | Position Measuring Device Used (0018,980C)
POSITION_OF_ISOCENTER_PROJECTION | Position of Isocenter Projection (0018,9430)
POSITION_REFERENCE_INDICATOR | Position Reference Indicator (0020,1040)
POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE | Positioner Isocenter Detector Rotation Angle (0018,9465)
POSITIONER_ISOCENTER_PRIMARY_ANGLE | Positioner Isocenter Primary Angle (0018,9463)
POSITIONER_ISOCENTER_SECONDARY_ANGLE | Positioner Isocenter Secondary Angle (0018,9464)
POSITIONER_MOTION | Positioner Motion (0018,1500)
POSITIONER_POSITION_SEQUENCE | Positioner Position Sequence (0018,9405)
POSITIONER_PRIMARY_ANGLE | Positioner Primary Angle (0018,1510)
POSITIONER_PRIMARY_ANGLE_DIRECTION | Positioner Primary Angle Direction (0018,9559)
POSITIONER_PRIMARY_ANGLE_INCREMENT | Positioner Primary Angle Increment (0018,1520)
POSITIONER_SECONDARY_ANGLE | Positioner Secondary Angle (0018,1511)
POSITIONER_SECONDARY_ANGLE_INCREMENT | Positioner Secondary Angle Increment (0018,1521)
POSITIONER_TYPE | Positioner Type (0018,1508)
POSITIONING_LANDMARK_SEQUENCE | Positioning Landmark Sequence (0018,991D)
POSITIONING_METHOD_CODE_SEQUENCE | Positioning Method Code Sequence (0018,991C)
POSITIVE_CATCH_TRIALS_QUANTITY | Positive Catch Trials Quantity (0024,0056)
POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE | Post Deformation Matrix Registration Sequence (0064,0010)
POSTPROCESSING_FUNCTION_RETIRED | Postprocessing Function RETIRED (0018,5021)
POTENTIAL_DIAGNOSTIC_TASKS | Potential Diagnostic Tasks (0018,990A)
POTENTIAL_REASONS_FOR_PROCEDURE | Potential Reasons for Procedure (0018,9908)
POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE | Potential Reasons for Procedure Code Sequence (0018,9909)
POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE | Potential Requested Procedure Code Sequence (0018,9907)
POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE | Potential Scheduled Protocol Code Sequence (0018,9906)
POTENTIAL_THREAT_OBJECT_ID | Potential Threat Object ID (4010,1010)
POWERLINE_FREQUENCY | Powerline Frequency (003A,0311)
PPS_DISCONTINUATION_REASON_CODE_SEQUENCE | Alias for tag PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0040,0281)
PRE_AMPLIFIER_EQUIPMENT_SEQUENCE | Pre-Amplifier Equipment Sequence (0014,400E)
PRE_AMPLIFIER_NOTES | Pre-Amplifier Notes (0014,400F)
PRE_AMPLIFIER_SETTINGS_SEQUENCE | Pre-Amplifier Settings Sequence (0014,4040)
PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE | Pre Deformation Matrix Registration Sequence (0064,000F)
PRE_MEDICATION | Pre-Medication (0040,0012)
PRE_SELECTED_FOR_IMPLANTATION | Pre-Selected for Implantation (0022,1049)
PREDECESSOR_DOCUMENTS_SEQUENCE | Predecessor Documents Sequence (0040,A360)
PREDECESSOR_PROTOCOL_SEQUENCE | Predecessor Protocol Sequence (0018,990E)
PREDECESSOR_STRUCTURE_SET_SEQUENCE | Predecessor Structure Set Sequence (3006,0018)
PREDICTED_REFRACTIVE_ERROR | Predicted Refractive Error (0022,1054)
PREDICTED_TORIC_ERROR_SEQUENCE | Predicted Toric Error Sequence (0022,1048)
PREFERRED_PLAYBACK_SEQUENCING | Preferred Playback Sequencing (0018,1244)
PREGNANCY_STATUS | Pregnancy Status (0010,21C0)
PRELIMINARY_FLAG | Preliminary Flag (0040,A496)
PRESCRIPTION_DESCRIPTION | Prescription Description (300A,000E)
PRESCRIPTION_NOTES | Prescription Notes (3010,007B)
PRESCRIPTION_NOTES_SEQUENCE | Prescription Notes Sequence (3010,0081)
PRESCRIPTION_OVERVIEW_SEQUENCE | Prescription Overview Sequence (300C,0114)
PRESENTATION_ANIMATION_STYLE | Presentation Animation Style (0070,1A01)
PRESENTATION_CREATION_DATE | Presentation Creation Date (0070,0082)
PRESENTATION_CREATION_TIME | Presentation Creation Time (0070,0083)
PRESENTATION_CREATORS_NAME | Alias for tag CONTENT_CREATORS_NAME (0070,0084)
PRESENTATION_DESCRIPTION | Alias for tag CONTENT_DESCRIPTION (0070,0081)
PRESENTATION_DISPLAY_COLLECTION_UID | Presentation Display Collection UID (0070,1101)
PRESENTATION_GROUP_NUMBER | Presentation Group Number (003A,0241)
PRESENTATION_INPUT_TYPE | Presentation Input Type (0070,1202)
PRESENTATION_INTENT_TYPE | Presentation Intent Type (0008,0068)
PRESENTATION_LABEL | Alias for tag CONTENT_LABEL (0070,0080)
PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED | Presentation LUT Content Sequence RETIRED (2130,0080)
PRESENTATION_LUT_FLAG_RETIRED | Presentation LUT Flag RETIRED (2000,0069)
PRESENTATION_LUT_SEQUENCE | Presentation LUT Sequence (2050,0010)
PRESENTATION_LUT_SHAPE | Presentation LUT Shape (2050,0020)
PRESENTATION_PIXEL_ASPECT_RATIO | Presentation Pixel Aspect Ratio (0070,0102)
PRESENTATION_PIXEL_MAGNIFICATION_RATIO | Presentation Pixel Magnification Ratio (0070,0103)
PRESENTATION_PIXEL_SPACING | Presentation Pixel Spacing (0070,0101)
PRESENTATION_SEQUENCE_COLLECTION_UID | Presentation Sequence Collection UID (0070,1102)
PRESENTATION_SEQUENCE_POSITION_INDEX | Presentation Sequence Position Index (0070,1103)
PRESENTATION_SIZE_MODE | Presentation Size Mode (0070,0100)
PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE | Presentation State Classification Component Sequence (0070,1801)
PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE | Presentation State Compositor Component Sequence (0070,1805)
PRESENTED_VISUAL_STIMULI_DATA_FLAG | Presented Visual Stimuli Data Flag (0024,0037)
PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION | Preserve Composite Instances After Media Creation (2200,000A)
PRESSURE | Pressure (0016,0032)
PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE | Primary Anatomic Structure Modifier Sequence (0008,2230)
PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE | Primary Anatomic Structure Sequence (0008,2228)
PRIMARY_CHROMATICITIES | Primary Chromaticities (0016,0002)
PRIMARY_DOSE_VALUE_INDICATOR | Primary Dose Value Indicator (300A,061B)
PRIMARY_DOSIMETER_UNIT | Primary Dosimeter Unit (300A,00B3)
PRIMARY_FLUENCE_MODE_SEQUENCE | Primary Fluence Mode Sequence (3002,0050)
PRIMARY_POSITIONER_INCREMENT | Primary Positioner Increment (0018,9514)
PRIMARY_POSITIONER_INCREMENT_SIGN | Primary Positioner Increment Sign (0018,9518)
PRIMARY_POSITIONER_SCAN_ARC | Primary Positioner Scan Arc (0018,9508)
PRIMARY_POSITIONER_SCAN_START_ANGLE | Primary Positioner Scan Start Angle (0018,9510)
PRIMARY_PROMPTS_COUNTS_ACCUMULATED | Primary (Prompts) Counts Accumulated (0054,1310)
PRIMITIVE_POINT_INDEX_LIST_RETIRED | Primitive Point Index List RETIRED (0066,0029)
PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED | Print Job Description Sequence RETIRED (2120,0050)
PRINT_JOB_ID_RETIRED | Print Job ID RETIRED (2100,0010)
PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED | Print Management Capabilities Sequence RETIRED (2130,0010)
PRINT_PRIORITY | Print Priority (2000,0020)
PRINT_QUEUE_ID_RETIRED | Print Queue ID RETIRED (2110,0099)
PRINT_RETIRED | Print RETIRED (0000,51A0)
PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED | Printer Characteristics Sequence RETIRED (2130,0015)
PRINTER_CONFIGURATION_SEQUENCE | Printer Configuration Sequence (2000,001E)
PRINTER_NAME | Printer Name (2110,0030)
PRINTER_PIXEL_SPACING | Printer Pixel Spacing (2010,0376)
PRINTER_RESOLUTION_ID | Printer Resolution ID (2010,0052)
PRINTER_STATUS | Printer Status (2110,0010)
PRINTER_STATUS_INFO | Printer Status Info (2110,0020)
PRINTING_BIT_DEPTH | Printing Bit Depth (2000,00A1)
PRIOR_RECORD_KEY | Prior Record Key (0008,041C)
PRIOR_TREATMENT_DOSE_DESCRIPTION | Prior Treatment Dose Description (3010,0061)
PRIOR_TREATMENT_REFERENCE_SEQUENCE | Prior Treatment Reference Sequence (3010,0062)
PRIORITY | Priority (0000,0700)
PRISM_SEQUENCE | Prism Sequence (0046,0028)
PRIVATE_CREATOR_REFERENCE | Private Creator Reference (0008,0302)
PRIVATE_DATA_ELEMENT | Private Data Element (0008,0308)
PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE | Private Data Element Characteristics Sequence (0008,0300)
PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE | Private Data Element Definition Sequence (0008,0310)
PRIVATE_DATA_ELEMENT_DESCRIPTION | Private Data Element Description (0008,030E)
PRIVATE_DATA_ELEMENT_ENCODING | Private Data Element Encoding (0008,030F)
PRIVATE_DATA_ELEMENT_KEYWORD | Private Data Element Keyword (0008,030D)
PRIVATE_DATA_ELEMENT_NAME | Private Data Element Name (0008,030C)
PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS | Private Data Element Number of Items (0008,030B)
PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY | Private Data Element Value Multiplicity (0008,0309)
PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION | Private Data Element Value Representation (0008,030A)
PRIVATE_GROUP_REFERENCE | Private Group Reference (0008,0301)
PRIVATE_INFORMATION | Private Information (0002,0102)
PRIVATE_INFORMATION_CREATOR_UID | Private Information Creator UID (0002,0100)
PRIVATE_RECORD_UID | Private Record UID (0004,1432)
PROBE_CENTER_LOCATION_X | Probe Center Location X (0014,4058)
PROBE_CENTER_LOCATION_Z | Probe Center Location Z (0014,4059)
PROCEDURE_CODE_SEQUENCE | Procedure Code Sequence (0008,1032)
PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED | Procedure Context Flag (Trial) RETIRED (0040,A603)
PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED | Procedure Context Sequence (Trial) RETIRED (0040,A340)
PROCEDURE_CREATION_DATE | Procedure Creation Date (0014,4076)
PROCEDURE_EXPIRATION_DATE | Procedure Expiration Date (0014,4078)
PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Procedure Identifier Code Sequence (Trial) RETIRED (0040,A085)
PROCEDURE_LAST_MODIFIED_DATE | Procedure Last Modified Date (0014,407A)
PROCEDURE_STEP_CANCELLATION_DATETIME | Procedure Step Cancellation DateTime (0040,4052)
PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE | Procedure Step Communications URI Sequence (0074,1008)
PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Procedure Step Discontinuation Reason Code Sequence (0074,100E)
PROCEDURE_STEP_LABEL | Procedure Step Label (0074,1204)
PROCEDURE_STEP_PROGRESS | Procedure Step Progress (0074,1004)
PROCEDURE_STEP_PROGRESS_DESCRIPTION | Procedure Step Progress Description (0074,1006)
PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE | Procedure Step Progress Information Sequence (0074,1002)
PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE | Procedure Step Progress Parameters Sequence (0074,1007)
PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED | Procedure Step Relationship Type RETIRED (0074,1222)
PROCEDURE_STEP_STATE | Procedure Step State (0074,1000)
PROCEDURE_TYPE_CODE_SEQUENCE | Procedure Type Code Sequence (0076,0020)
PROCEDURE_VERSION | Procedure Version (0014,4074)
PROCESSING_FUNCTION | Processing Function (0018,5020)
PRODUCT_DESCRIPTION | Product Description (0044,0009)
PRODUCT_EXPIRATION_DATETIME | Product Expiration DateTime (0044,000B)
PRODUCT_LOT_IDENTIFIER | Product Lot Identifier (0044,000A)
PRODUCT_NAME | Product Name (0044,0008)
PRODUCT_PACKAGE_IDENTIFIER | Product Package Identifier (0044,0001)
PRODUCT_PARAMETER_SEQUENCE | Product Parameter Sequence (0044,0013)
PRODUCT_TYPE_CODE_SEQUENCE | Product Type Code Sequence (0044,0007)
PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE | Projection Eponymous Name Code Sequence (0018,5104)
PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE | Projection Imaging Acquisition Parameter Sequence (3002,0125)
PROJECTION_PIXEL_CALIBRATION_SEQUENCE | Projection Pixel Calibration Sequence (0018,9401)
PROPERTY_LABEL | Property Label (0014,2032)
PROPOSED_STUDY_SEQUENCE | Proposed Study Sequence (2130,00A0)
PROTOCOL_CONTEXT_SEQUENCE | Protocol Context Sequence (0040,0440)
PROTOCOL_DEFINED_PATIENT_POSITION | Protocol Defined Patient Position (0018,9947)
PROTOCOL_DESIGN_RATIONALE | Protocol Design Rationale (0018,9910)
PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY | Protocol Element Characteristics Summary (0018,9923)
PROTOCOL_ELEMENT_NAME | Protocol Element Name (0018,9922)
PROTOCOL_ELEMENT_NUMBER | Protocol Element Number (0018,9921)
PROTOCOL_ELEMENT_PURPOSE | Protocol Element Purpose (0018,9924)
PROTOCOL_NAME | Protocol Name (0018,1030)
PROTOCOL_PLANNING_INFORMATION | Protocol Planning Information (0018,990F)
PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE | Pseudo-Color Palette Instance Reference Sequence (0072,0705)
PSEUDO_COLOR_TYPE | Pseudo-Color Type (0072,0704)
PTO_REPRESENTATION_SEQUENCE | PTO Representation Sequence (4010,1037)
PULSE_NUMBER | Pulse Number (3008,0172)
PULSE_REPETITION_FREQUENCY | Pulse Repetition Frequency (0018,6032)
PULSE_REPETITION_INTERVAL | Pulse Repetition Interval (300A,028C)
PULSE_SEQUENCE_NAME | Pulse Sequence Name (0018,9005)
PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE | Pulse Specific Brachy Control Point Delivered Sequence (3008,0171)
PULSE_WIDTH | Pulse Width (0014,4022)
PULSER_EQUIPMENT_SEQUENCE | Pulser Equipment Sequence (0014,4002)
PULSER_NOTES | Pulser Notes (0014,4006)
PULSER_SETTINGS_SEQUENCE | Pulser Settings Sequence (0014,4020)
PULSER_TYPE | Pulser Type (0014,4004)
PUPIL_CENTROID_X_COORDINATE | Pupil Centroid X-Coordinate (0046,0203)
PUPIL_CENTROID_Y_COORDINATE | Pupil Centroid Y-Coordinate (0046,0204)
PUPIL_DIAMETER | Alias for tag EMMETROPIC_MAGNIFICATION (0022,000A)
PUPIL_DILATED | Pupil Dilated (0022,000D)
PUPIL_SIZE | Pupil Size (0046,0044)
PURPOSE_OF_REFERENCE_CODE_SEQUENCE | Purpose of Reference Code Sequence (0040,A170)
PVC_REJECTION | PVC Rejection (0018,1085)
PYRAMID_DESCRIPTION | Pyramid Description (0008,1088)
PYRAMID_LABEL | Pyramid Label (0020,0027)
PYRAMID_UID | Pyramid UID (0008,0019)
QA_RESULTS_SEQUENCE | QA Results Sequence (0028,700F)
QUADRATURE_RECEIVE_COIL | Quadrature Receive Coil (0018,9044)
QUALITY | Alias for tag QUANTITY (0040,0294)
QUALITY_CONTROL_IMAGE | Quality Control Image (0028,0300)
QUALITY_CONTROL_SUBJECT | Quality Control Subject (0010,0200)
QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE | Quality Control Subject Type Code Sequence (0010,0201)
QUALITY_SEQUENCE | Alias for tag QUANTITY_SEQUENCE (0040,0293)
QUALITY_THRESHOLD | Quality Threshold (0022,1630)
QUANTIFIED_DEFECT | Quantified Defect (0024,0098)
QUANTITY | Quantity (0040,0294)
QUANTITY_DEFINITION_SEQUENCE | Quantity Definition Sequence (0040,9220)
QUANTITY_SEQUENCE | Quantity Sequence (0040,0293)
QUERY_RETRIEVE_LEVEL | Query/Retrieve Level (0008,0052)
QUERY_RETRIEVE_VIEW | Query/Retrieve View (0008,0053)
QUEUE_STATUS_RETIRED | Queue Status RETIRED (2120,0010)
R_R_INTERVAL_TIME_MEASURED | Alias for tag R_R_INTERVAL_TIME_NOMINAL (0020,9251)
R_R_INTERVAL_TIME_NOMINAL | R-R Interval Time Nominal (0020,9251)
R_R_INTERVAL_VECTOR | R-R Interval Vector (0054,0060)
R_WAVE_POINTER | R Wave Pointer (0028,6040)
R_WAVE_TIME_VECTOR | R Wave Time Vector (0018,6060)
RADIAL_POSITION | Radial Position (0018,1142)
RADIATION_ATOMIC_NUMBER | Radiation Atomic Number (300A,0304)
RADIATION_BEAM_BLOCK_SLAB_THICKNESS | Radiation Beam Block Slab Thickness (300A,066E)
RADIATION_BEAM_BLOCK_THICKNESS | Radiation Beam Block Thickness (300A,066D)
RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER | Radiation Beam Compensator Milling Tool Diameter (300A,0669)
RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE | Radiation Beam Effective Wedge Angle (300A,0654)
RADIATION_BEAM_WEDGE_ANGLE | Radiation Beam Wedge Angle (300A,0652)
RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE | Radiation Beam Wedge Thin Edge Distance (300A,0653)
RADIATION_CHARGE_STATE | Radiation Charge State (300A,0306)
RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE | Radiation Device Configuration and Commissioning Key Sequence (300A,065A)
RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT | Radiation Dose Central Axis Displacement (300A,0624)
RADIATION_DOSE_IDENTIFICATION_INDEX | Radiation Dose Identification Index (300A,0603)
RADIATION_DOSE_IDENTIFICATION_LABEL | Radiation Dose Identification Label (300A,0619)
RADIATION_DOSE_IDENTIFICATION_SEQUENCE | Radiation Dose Identification Sequence (300A,0618)
RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL | Radiation Dose In-Vivo Measurement Label (300A,0623)
RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES | Radiation Dose Measurement Point Coordinates (300A,0627)
RADIATION_DOSE_SEQUENCE | Radiation Dose Sequence (300A,0617)
RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Radiation Dose Source to External Contour Distance (300A,0628)
RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE | Radiation Dose Source to Skin Distance (300A,0626)
RADIATION_DOSE_VALUE | Radiation Dose Value (300A,0625)
RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE | Radiation Dose Values Parameters Sequence (300A,061F)
RADIATION_DOSIMETER_UNIT_SEQUENCE | Radiation Dosimeter Unit Sequence (300A,0658)
RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE | Radiation Fluence Modifier Code Sequence (300A,0683)
RADIATION_GENERATION_MODE_DESCRIPTION | Radiation Generation Mode Description (300A,067D)
RADIATION_GENERATION_MODE_INDEX | Radiation Generation Mode Index (300A,0601)
RADIATION_GENERATION_MODE_LABEL | Radiation Generation Mode Label (300A,067C)
RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE | Radiation Generation Mode Machine Code Sequence (300A,067E)
RADIATION_GENERATION_MODE_SEQUENCE | Radiation Generation Mode Sequence (300A,067B)
RADIATION_MACHINE_NAME | Radiation Machine Name (3002,0020)
RADIATION_MACHINE_SAD | Radiation Machine SAD (3002,0022)
RADIATION_MACHINE_SSD | Radiation Machine SSD (3002,0024)
RADIATION_MASS_NUMBER | Radiation Mass Number (300A,0302)
RADIATION_MODE | Radiation Mode (0018,115A)
RADIATION_ORDER_INDEX | Radiation Order Index (300A,0786)
RADIATION_SETTING | Radiation Setting (0018,1155)
RADIATION_SOURCE_AXIS_DISTANCE | Radiation Source-Axis Distance (300A,0640)
RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE | Radiation Source Coordinate System Pitch Angle (3010,0096)
RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE | Radiation Source Coordinate System Roll Angle (3010,0095)
RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE | Radiation Source Coordinate System Yaw Angle (3010,0094)
RADIATION_TYPE | Radiation Type (300A,00C6)
RADIATION_TYPE_CODE_SEQUENCE | Radiation Type Code Sequence (300A,067F)
RADIOBIOLOGICAL_DOSE_EFFECT_FLAG | Radiobiological Dose Effect Flag (3010,0002)
RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE | Radiobiological Dose Effect Sequence (3010,0001)
RADIONUCLIDE_CODE_SEQUENCE | Radionuclide Code Sequence (0054,0300)
RADIONUCLIDE_HALF_LIFE | Radionuclide Half Life (0018,1075)
RADIONUCLIDE_POSITRON_FRACTION | Radionuclide Positron Fraction (0018,1076)
RADIONUCLIDE_RETIRED | Radionuclide RETIRED (0018,0030)
RADIONUCLIDE_TOTAL_DOSE | Radionuclide Total Dose (0018,1074)
RADIOPHARMACEUTICAL | Radiopharmaceutical (0018,0031)
RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID | Radiopharmaceutical Administration Event UID (0008,3012)
RADIOPHARMACEUTICAL_AGENT_NUMBER | Radiopharmaceutical Agent Number (0018,9729)
RADIOPHARMACEUTICAL_CODE_SEQUENCE | Radiopharmaceutical Code Sequence (0054,0304)
RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE | Radiopharmaceutical Information Sequence (0054,0016)
RADIOPHARMACEUTICAL_ROUTE | Radiopharmaceutical Route (0018,1070)
RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE | Alias for tag ADMINISTRATION_ROUTE_CODE_SEQUENCE (0054,0302)
RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY | Radiopharmaceutical Specific Activity (0018,1077)
RADIOPHARMACEUTICAL_START_DATETIME | Radiopharmaceutical Start DateTime (0018,1078)
RADIOPHARMACEUTICAL_START_TIME | Radiopharmaceutical Start Time (0018,1072)
RADIOPHARMACEUTICAL_STOP_DATETIME | Radiopharmaceutical Stop DateTime (0018,1079)
RADIOPHARMACEUTICAL_STOP_TIME | Radiopharmaceutical Stop Time (0018,1073)
RADIOPHARMACEUTICAL_USAGE_SEQUENCE | Radiopharmaceutical Usage Sequence (0018,9737)
RADIOPHARMACEUTICAL_VOLUME | Radiopharmaceutical Volume (0018,1071)
RADIOTHERAPY_TREATMENT_TYPE | Radiotherapy Treatment Type (3010,0046)
RADIUS_OF_CIRCULAR_COLLIMATOR | Radius of Circular Collimator (0018,1712)
RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION | Radius of Circular Exposure Control Sensing Region (0018,9441)
RADIUS_OF_CIRCULAR_SHUTTER | Radius of Circular Shutter (0018,1612)
RADIUS_OF_CURVATURE | Radius of Curvature (0046,0075)
RANDOMS_CORRECTED | Randoms Corrected (0018,9765)
RANDOMS_CORRECTION_METHOD | Randoms Correction Method (0054,1100)
RANGE_MATCHING_SEQUENCE | Range Matching Sequence (0008,0410)
RANGE_MODULATOR_DESCRIPTION | Range Modulator Description (300A,034A)
RANGE_MODULATOR_GATING_START_VALUE | Range Modulator Gating Start Value (300A,0382)
RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS | Range Modulator Gating Start Water Equivalent Thickness (300A,0386)
RANGE_MODULATOR_GATING_STOP_VALUE | Range Modulator Gating Stop Value (300A,0384)
RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS | Range Modulator Gating Stop Water Equivalent Thickness (300A,0388)
RANGE_MODULATOR_ID | Range Modulator ID (300A,0346)
RANGE_MODULATOR_NUMBER | Range Modulator Number (300A,0344)
RANGE_MODULATOR_SEQUENCE | Range Modulator Sequence (300A,0342)
RANGE_MODULATOR_SETTINGS_SEQUENCE | Range Modulator Settings Sequence (300A,0380)
RANGE_MODULATOR_TYPE | Range Modulator Type (300A,0348)
RANGE_OF_FREEDOM | Range of Freedom (0068,64A0)
RANGE_SHIFTER_DESCRIPTION | Range Shifter Description (300A,0322)
RANGE_SHIFTER_ID | Range Shifter ID (300A,0318)
RANGE_SHIFTER_NUMBER | Range Shifter Number (300A,0316)
RANGE_SHIFTER_SEQUENCE | Range Shifter Sequence (300A,0314)
RANGE_SHIFTER_SETTING | Range Shifter Setting (300A,0362)
RANGE_SHIFTER_SETTINGS_SEQUENCE | Range Shifter Settings Sequence (300A,0360)
RANGE_SHIFTER_TYPE | Range Shifter Type (300A,0320)
RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS | Range Shifter Water Equivalent Thickness (300A,0366)
RANGING_DEPTH | Ranging Depth (0052,0009)
RATIONAL_DENOMINATOR_VALUE | Rational Denominator Value (0040,A163)
RATIONAL_NUMERATOR_VALUE | Rational Numerator Value (0040,A162)
RAW_DATA_HANDLING | Raw Data Handling (0040,4040)
REAL_TIME_BULK_DATA_FLOW_SEQUENCE | Real-Time Bulk Data Flow Sequence (0034,000A)
REAL_WORLD_VALUE_FIRST_VALUE_MAPPED | Real World Value First Value Mapped (0040,9216)
REAL_WORLD_VALUE_INTERCEPT | Real World Value Intercept (0040,9224)
REAL_WORLD_VALUE_LAST_VALUE_MAPPED | Real World Value Last Value Mapped (0040,9211)
REAL_WORLD_VALUE_LUT_DATA | Real World Value LUT Data (0040,9212)
REAL_WORLD_VALUE_MAPPING_SEQUENCE | Real World Value Mapping Sequence (0040,9096)
REAL_WORLD_VALUE_SLOPE | Real World Value Slope (0040,9225)
REASON_FOR_CANCELLATION | Reason for Cancellation (0074,1238)
REASON_FOR_CHANNEL_OMISSION | Reason for Channel Omission (0074,140A)
REASON_FOR_CHANNEL_OMISSION_DESCRIPTION | Reason for Channel Omission Description (0074,140B)
REASON_FOR_OMISSION | Reason for Omission (300C,0112)
REASON_FOR_OMISSION_CODE_SEQUENCE | Reason for Omission Code Sequence (300A,0788)
REASON_FOR_OMISSION_DESCRIPTION | Reason for Omission Description (300C,0113)
REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE | Reason For Performed Procedure Code Sequence (0040,1012)
REASON_FOR_REMOVAL_CODE_SEQUENCE | Reason for Removal Code Sequence (0008,0406)
REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE | Reason for Requested Procedure Code Sequence (0040,100A)
REASON_FOR_STUDY_RETIRED | Reason for Study RETIRED (0032,1030)
REASON_FOR_SUPERSEDING | Reason for Superseding (3010,005C)
REASON_FOR_THE_ATTRIBUTE_MODIFICATION | Reason for the Attribute Modification (0400,0565)
REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED | Reason for the Imaging Service Request RETIRED (0040,2001)
REASON_FOR_THE_REQUESTED_PROCEDURE | Reason for the Requested Procedure (0040,1002)
REASON_FOR_VISIT | Reason for Visit (0032,1066)
REASON_FOR_VISIT_CODE_SEQUENCE | Reason for Visit Code Sequence (0032,1067)
RECEIVE_COIL_MANUFACTURER_NAME | Receive Coil Manufacturer Name (0018,9041)
RECEIVE_COIL_NAME | Receive Coil Name (0018,1250)
RECEIVE_COIL_TYPE | Receive Coil Type (0018,9043)
RECEIVE_TRANSDUCER_SEQUENCE | Receive Transducer Sequence (0014,4011)
RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE | Receive Transducer Settings Sequence (0014,4051)
RECEIVER_EQUIPMENT_SEQUENCE | Receiver Equipment Sequence (0014,4008)
RECEIVER_NOTES | Receiver Notes (0014,400C)
RECEIVER_RETIRED | Receiver RETIRED (0000,0300)
RECEIVER_SETTINGS_SEQUENCE | Receiver Settings Sequence (0014,4030)
RECEIVING_AE | Receiving AE (0074,1234)
RECEIVING_APPLICATION_ENTITY_TITLE | Receiving Application Entity Title (0002,0018)
RECEIVING_COIL | Alias for tag RECEIVE_COIL_NAME (0018,1250)
RECEIVING_PRESENTATION_ADDRESS | Receiving Presentation Address (0002,0028)
RECOGNITION_CODE_RETIRED | Recognition Code RETIRED (0008,0010)
RECOGNIZABLE_VISUAL_FEATURES | Recognizable Visual Features (0028,0302)
RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE | Recommended Absent Pixel CIELab Value (0048,0015)
RECOMMENDED_ANIMATION_RATE | Recommended Animation Rate (0070,1A03)
RECOMMENDED_DEFAULT_VALUE_SEQUENCE | Recommended Default Value Sequence (0082,0035)
RECOMMENDED_DISPLAY_CIELAB_VALUE | Recommended Display CIELab Value (0062,000D)
RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST | Recommended Display CIELab Value List (0066,0103)
RECOMMENDED_DISPLAY_FRAME_RATE | Recommended Display Frame Rate (0008,2144)
RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT | Recommended Display Frame Rate in Float (0008,9459)
RECOMMENDED_DISPLAY_GRAYSCALE_VALUE | Recommended Display Grayscale Value (0062,000C)
RECOMMENDED_EXPOSURE_INDEX | Recommended Exposure Index (0016,001C)
RECOMMENDED_LINE_THICKNESS | Recommended Line Thickness (0066,0038)
RECOMMENDED_POINT_RADIUS | Recommended Point Radius (0066,0037)
RECOMMENDED_PRESENTATION_OPACITY | Recommended Presentation Opacity (0066,000C)
RECOMMENDED_PRESENTATION_TYPE | Recommended Presentation Type (0066,000D)
RECOMMENDED_ROTATION_POINT | Recommended Rotation Point (0068,6346)
RECOMMENDED_VIEWING_MODE | Recommended Viewing Mode (0028,1090)
RECONSTRUCTION_ALGORITHM | Reconstruction Algorithm (0018,9315)
RECONSTRUCTION_ALGORITHM_SEQUENCE | Reconstruction Algorithm Sequence (0018,993D)
RECONSTRUCTION_ANGLE | Reconstruction Angle (0018,9319)
RECONSTRUCTION_DESCRIPTION | Reconstruction Description (0018,9531)
RECONSTRUCTION_DIAMETER | Reconstruction Diameter (0018,1100)
RECONSTRUCTION_END_LOCATION_SEQUENCE | Reconstruction End Location Sequence (0018,993C)
RECONSTRUCTION_FIELD_OF_VIEW | Reconstruction Field of View (0018,9317)
RECONSTRUCTION_INDEX | Reconstruction Index (0020,9536)
RECONSTRUCTION_METHOD | Reconstruction Method (0054,1103)
RECONSTRUCTION_PIPELINE_TYPE | Reconstruction Pipeline Type (0018,11BE)
RECONSTRUCTION_PIXEL_SPACING | Reconstruction Pixel Spacing (0018,9322)
RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE | Reconstruction Protocol Element Sequence (0018,9934)
RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Reconstruction Protocol Element Specification Sequence (0018,9933)
RECONSTRUCTION_START_LOCATION_SEQUENCE | Reconstruction Start Location Sequence (0018,993B)
RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE | Reconstruction Target Center Location Sequence (0018,993E)
RECONSTRUCTION_TARGET_CENTER_PATIENT | Reconstruction Target Center (Patient) (0018,9318)
RECONSTRUCTION_TYPE | Reconstruction Type (0018,9756)
RECORD_IN_USE_FLAG | Record In-use Flag (0004,1410)
RECORD_KEY | Record Key (0008,041B)
RECORDED_BLOCK_SEQUENCE | Recorded Block Sequence (3008,00D0)
RECORDED_BLOCK_SLAB_SEQUENCE | Recorded Block Slab Sequence (3008,00D1)
RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE | Recorded Brachy Accessory Device Sequence (3008,0120)
RECORDED_CHANNEL_SEQUENCE | Recorded Channel Sequence (3008,0130)
RECORDED_CHANNEL_SHIELD_SEQUENCE | Recorded Channel Shield Sequence (3008,0150)
RECORDED_CHANNEL_SHIELD_SEQUNCE | Alias for tag RECORDED_CHANNEL_SHIELD_SEQUENCE (3008,0150)
RECORDED_COMPENSATOR_SEQUENCE | Recorded Compensator Sequence (3008,00C0)
RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE | Recorded Lateral Spreading Device Sequence (3008,00F4)
RECORDED_RANGE_MODULATOR_SEQUENCE | Recorded Range Modulator Sequence (3008,00F6)
RECORDED_RANGE_SHIFTER_SEQUENCE | Recorded Range Shifter Sequence (3008,00F2)
RECORDED_RT_CONTROL_POINT_DATETIME | Recorded RT Control Point DateTime (300A,073A)
RECORDED_SNOUT_SEQUENCE | Recorded Snout Sequence (3008,00F0)
RECORDED_SOURCE_APPLICATION_SEQUENCE | Alias for tag RECORDED_SOURCE_APPLICATOR_SEQUENCE (3008,0140)
RECORDED_SOURCE_APPLICATOR_SEQUENCE | Recorded Source Applicator Sequence (3008,0140)
RECORDED_SOURCE_SEQUENCE | Recorded Source Sequence (3008,0100)
RECORDED_WEDGE_SEQUENCE | Recorded Wedge Sequence (3008,00B0)
RECTIFICATION_TYPE | Rectification Type (0018,1156)
RECTIFIER_SMOOTHING | Rectifier Smoothing (0014,4034)
RECTILINEAR_PHASE_ENCODE_REORDERING | Rectilinear Phase Encode Reordering (0018,9034)
RED_PALETTE_COLOR_LOOKUP_TABLE_DATA | Red Palette Color Lookup Table Data (0028,1201)
RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Red Palette Color Lookup Table Descriptor (0028,1101)
REFERENCE_AIR_KERMA_RATE | Reference Air Kerma Rate (300A,022A)
REFERENCE_BASIS_CODE_SEQUENCE | Reference Basis Code Sequence (0018,9902)
REFERENCE_COORDINATES | Reference Coordinates (0022,0032)
REFERENCE_DISPLAY_SETS | Reference Display Sets (0072,0218)
REFERENCE_DOSE_DEFINITION | Reference Dose Definition (300A,0512)
REFERENCE_DOSE_POINT_COORDINATES | Reference Dose Point Coordinates (300A,061E)
REFERENCE_DOSE_TYPE | Reference Dose Type (300A,061A)
REFERENCE_GEOMETRY_CODE_SEQUENCE | Reference Geometry Code Sequence (0018,9903)
REFERENCE_IMAGE_NUMBER | Reference Image Number (300A,00C8)
REFERENCE_LOCATION_DESCRIPTION | Reference Location Description (0018,9901)
REFERENCE_LOCATION_LABEL | Reference Location Label (0018,9900)
REFERENCE_PIXEL_PHYSICAL_VALUE_X | Reference Pixel Physical Value X (0018,6028)
REFERENCE_PIXEL_PHYSICAL_VALUE_Y | Reference Pixel Physical Value Y (0018,602A)
REFERENCE_PIXEL_X0 | Reference Pixel X0 (0018,6020)
REFERENCE_PIXEL_Y0 | Reference Pixel Y0 (0018,6022)
REFERENCE_RETIRED | Reference RETIRED (0020,1020)
REFERENCE_TO_RECORDED_SOUND_RETIRED | Reference to Recorded Sound RETIRED (4008,0103)
REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED | Referenced Accession Sequence (Trial) RETIRED (0040,A313)
REFERENCED_ASSERTION_UID | Referenced Assertion UID (0044,0108)
REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE | Referenced Baseline Parameters RT Radiation Instance Sequence (3002,011E)
REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE | Referenced Basic Annotation Box Sequence (2010,0520)
REFERENCED_BEAM_NUMBER | Referenced Beam Number (300C,0006)
REFERENCED_BEAM_SEQUENCE | Referenced Beam Sequence (300C,0004)
REFERENCED_BLOCK_NUMBER | Referenced Block Number (300C,00E0)
REFERENCED_BOLUS_SEQUENCE | Referenced Bolus Sequence (300C,00B0)
REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER | Referenced Brachy Accessory Device Number (3008,0122)
REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER | Referenced Brachy Application Setup Number (300C,000C)
REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE | Referenced Brachy Application Setup Sequence (300C,000A)
REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER | Referenced Calculated Dose Reference Number (3008,0092)
REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE | Referenced Calculated Dose Reference Sequence (3008,0090)
REFERENCED_CHANNEL_NUMBER | Referenced Channel Number (0074,1406)
REFERENCED_CHANNEL_SHIELD_NUMBER | Referenced Channel Shield Number (3008,0152)
REFERENCED_COLOR_PALETTE_INSTANCE_UID | Referenced Color Palette Instance UID (0028,0304)
REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE | Referenced Comparison SOP Instance Sequence (0082,0005)
REFERENCED_COMPENSATOR_NUMBER | Referenced Compensator Number (300C,00D0)
REFERENCED_CONCEPTUAL_VOLUME_UID | Referenced Conceptual Volume UID (3010,000B)
REFERENCED_CONTENT_ITEM | Referenced Content Item (0070,1904)
REFERENCED_CONTENT_ITEM_IDENTIFIER | Referenced Content Item Identifier (0040,DB73)
REFERENCED_CONTROL_POINT | Alias for tag REFERENCED_CONTROL_POINT_INDEX (300C,00F0)
REFERENCED_CONTROL_POINT_INDEX | Referenced Control Point Index (300C,00F0)
REFERENCED_CONTROL_POINT_SEQUENCE | Referenced Control Point Sequence (300C,00F2)
REFERENCED_CURVE_SEQUENCE_RETIRED | Referenced Curve Sequence RETIRED (0008,1145)
REFERENCED_DATETIME | Referenced DateTime (0040,A13A)
REFERENCED_DEFINED_DEVICE_INDEX | Referenced Defined Device Index (300A,0602)
REFERENCED_DEFINED_PROTOCOL_SEQUENCE | Referenced Defined Protocol Sequence (0018,990C)
REFERENCED_DEVICE_INDEX | Referenced Device Index (300A,0607)
REFERENCED_DIGITAL_SIGNATURE_SEQUENCE | Referenced Digital Signature Sequence (0400,0402)
REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE | Referenced Direct Segment Instance Sequence (3010,004A)
REFERENCED_DOSE_REFERENCE_NUMBER | Referenced Dose Reference Number (300C,0051)
REFERENCED_DOSE_REFERENCE_SEQUENCE | Referenced Dose Reference Sequence (300C,0050)
REFERENCED_DOSE_REFERENCE_UID | Referenced Dose Reference UID (300A,0083)
REFERENCED_DOSE_SEQUENCE | Referenced Dose Sequence (300C,0080)
REFERENCED_DOSIMETRIC_OBJECTIVE_UID | Referenced Dosimetric Objective UID (3010,006F)
REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE | Referenced Dosimetric Objectives Sequence (3010,0071)
REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX | Referenced Expected In-Vivo Measurement Value Index (300A,0773)
REFERENCED_FIDUCIAL_UID | Referenced Fiducial UID (0070,031B)
REFERENCED_FIDUCIALS_UID | Referenced Fiducials UID (3010,0031)
REFERENCED_FILE_ID | Referenced File ID (0004,1500)
REFERENCED_FILM_BOX_SEQUENCE | Referenced Film Box Sequence (2000,0500)
REFERENCED_FILM_SESSION_SEQUENCE | Referenced Film Session Sequence (2010,0500)
REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED | Referenced Findings Group UID (Trial) RETIRED (0040,A022)
REFERENCED_FIRST_FRAME_SEQUENCE | Referenced First Frame Sequence (0072,0427)
REFERENCED_FRACTION_GROUP_NUMBER | Referenced Fraction Group Number (300C,0022)
REFERENCED_FRACTION_GROUP_SEQUENCE | Referenced Fraction Group Sequence (300C,0020)
REFERENCED_FRACTION_NUMBER | Referenced Fraction Number (3008,0223)
REFERENCED_FRAME_NUMBER | Referenced Frame Number (0008,1160)
REFERENCED_FRAME_NUMBERS_RETIRED | Referenced Frame Numbers RETIRED (0040,A136)
REFERENCED_FRAME_OF_REFERENCE_SEQUENCE | Referenced Frame of Reference Sequence (3006,0010)
REFERENCED_FRAME_OF_REFERENCE_UID | Referenced Frame of Reference UID (3006,0024)
REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED | Referenced General Purpose Scheduled Procedure Step Sequence RETIRED (0040,4016)
REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED | Referenced General Purpose Scheduled Procedure Step Transaction UID RETIRED (0040,4023)
REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION | Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)
REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID | Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)
REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE | Alias for tag REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE (0008,9237)
REFERENCED_HPGL_DOCUMENT_ID | Referenced HPGL Document ID (0068,6440)
REFERENCED_IMAGE_BOX_SEQUENCE | Referenced Image Box Sequence (2010,0510)
REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED | Referenced Image Box Sequence (Retired) (2040,0500)
REFERENCED_IMAGE_EVIDENCE_SEQUENCE | Referenced Image Evidence Sequence (0008,9092)
REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED | Referenced Image Navigation Sequence RETIRED (0048,0200)
REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED | Referenced Image Overlay Box Sequence RETIRED (2020,0130)
REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE | Referenced Image Real World Value Mapping Sequence (0040,9094)
REFERENCED_IMAGE_SEQUENCE | Referenced Image Sequence (0008,1140)
REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID | Referenced Implant Template Group Member ID (0078,00B6)
REFERENCED_INSTANCE_SEQUENCE | Referenced Instance Sequence (0008,114A)
REFERENCED_INTERPRETATION_SEQUENCE_RETIRED | Referenced Interpretation Sequence RETIRED (4008,0050)
REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER | Referenced Lateral Spreading Device Number (300C,0102)
REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER | Referenced Measured Dose Reference Number (3008,0082)
REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE | Referenced Measured Dose Reference Sequence (3008,0080)
REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE | Referenced Non-Image Composite SOP Instance Sequence (0040,0220)
REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED | Referenced Object Observation Class (Trial) RETIRED (0040,A174)
REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED | Referenced Observation Class (Trial) RETIRED (0040,A173)
REFERENCED_OBSERVATION_UID_TRIAL_RETIRED | Referenced Observation UID (Trial) RETIRED (0040,A172)
REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE | Referenced Ophthalmic Axial Length Measurement QC Image Sequence (0022,1330)
REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE | Referenced Ophthalmic Axial Measurements Sequence (0022,1100)
REFERENCED_OPTICAL_PATH_IDENTIFIER | Referenced Optical Path Identifier (006A,000E)
REFERENCED_OTHER_PLANE_SEQUENCE | Referenced Other Plane Sequence (0008,9410)
REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED | Referenced Overlay Plane Groups RETIRED (2040,0011)
REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED | Referenced Overlay Plane Sequence RETIRED (2040,0010)
REFERENCED_OVERLAY_SEQUENCE_RETIRED | Referenced Overlay Sequence RETIRED (0008,1130)
REFERENCED_PARENT_RT_PRESCRIPTION_INDEX | Referenced Parent RT Prescription Index (3010,0042)
REFERENCED_PATH_INDEX | Referenced Path Index (0018,9378)
REFERENCED_PATIENT_ALIAS_SEQUENCE | Referenced Patient Alias Sequence (0038,0004)
REFERENCED_PATIENT_PHOTO_SEQUENCE | Referenced Patient Photo Sequence (0010,1100)
REFERENCED_PATIENT_SEQUENCE | Referenced Patient Sequence (0008,1120)
REFERENCED_PATIENT_SETUP_NUMBER | Referenced Patient Setup Number (300C,006A)
REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE | Referenced Patient Setup Photo Sequence (300A,078C)
REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX | Referenced Patient Setup Procedure Index (300A,0796)
REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE | Referenced Performed Procedure Step Sequence (0008,1111)
REFERENCED_PERFORMED_PROTOCOL_SEQUENCE | Referenced Performed Protocol Sequence (0018,990D)
REFERENCED_PLAN_OVERVIEW_INDEX | Referenced Plan Overview Index (300C,0118)
REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE | Referenced Position Reference Instance Sequence (3002,0132)
REFERENCED_PRESENTATION_LUT_SEQUENCE | Referenced Presentation LUT Sequence (2050,0500)
REFERENCED_PRESENTATION_STATE_SEQUENCE | Referenced Presentation State Sequence (0008,9237)
REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED | Referenced Print Job Sequence (Pull Stored Print) RETIRED (2100,0500)
REFERENCED_PRINT_JOB_SEQUENCE_RETIRED | Referenced Print Job Sequence RETIRED (2120,0070)
REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED | Referenced Procedure Step Sequence RETIRED (0040,0330)
REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX | Referenced Radiation Dose Identification Index (300A,060C)
REFERENCED_RADIATION_GENERATION_MODE_INDEX | Referenced Radiation Generation Mode Index (300A,0605)
REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX | Referenced Radiation RT Control Point Index (300A,073B)
REFERENCED_RANGE_MODULATOR_NUMBER | Referenced Range Modulator Number (300C,0104)
REFERENCED_RANGE_SHIFTER_NUMBER | Referenced Range Shifter Number (300C,0100)
REFERENCED_RAW_DATA_SEQUENCE | Referenced Raw Data Sequence (0008,9121)
REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE | Referenced Real World Value Mapping Instance Sequence (0008,114B)
REFERENCED_REFERENCE_IMAGE_NUMBER | Referenced Reference Image Number (300C,0007)
REFERENCED_REFERENCE_IMAGE_SEQUENCE | Referenced Reference Image Sequence (300C,0042)
REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE | Referenced Refractive Measurements Sequence (0046,0145)
REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE | Referenced Related General SOP Class UID in File (0004,151A)
REFERENCED_REQUEST_SEQUENCE | Referenced Request Sequence (0040,A370)
REFERENCED_RESULTS_SEQUENCE_RETIRED | Referenced Results Sequence RETIRED (0008,1100)
REFERENCED_ROI_NUMBER | Referenced ROI Number (3006,0084)
REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX | Referenced RT Accessory Holder Device Index (300A,060E)
REFERENCED_RT_INSTANCE_SEQUENCE | Referenced RT Instance Sequence (300A,0631)
REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED | Referenced RT Patient Setup Sequence RETIRED (300A,0632)
REFERENCED_RT_PHYSICIAN_INTENT_INDEX | Referenced RT Physician Intent Index (3010,005E)
REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE | Referenced RT Physician Intent Sequence (300A,063B)
REFERENCED_RT_PLAN_SEQUENCE | Referenced RT Plan Sequence (300C,0002)
REFERENCED_RT_PRESCRIPTION_INDEX | Referenced RT Prescription Index (3010,0041)
REFERENCED_RT_PRESCRIPTION_SEQUENCE | Referenced RT Prescription Sequence (300A,068A)
REFERENCED_RT_RADIATION_RECORD_SEQUENCE | Referenced RT Radiation Record Sequence (300A,0703)
REFERENCED_RT_RADIATION_SEQUENCE | Referenced RT Radiation Sequence (300A,0630)
REFERENCED_RT_RADIATION_SET_SEQUENCE | Referenced RT Radiation Set Sequence (300A,0702)
REFERENCED_RT_TREATMENT_PHASE_INDEX | Referenced RT Treatment Phase Index (3010,0040)
REFERENCED_RT_TREATMENT_PHASE_SEQUENCE | Referenced RT Treatment Phase Sequence (3010,0049)
REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE | Referenced RT Treatment Preparation Sequence (300A,078B)
REFERENCED_SAMPLE_POSITIONS | Referenced Sample Positions (0040,A132)
REFERENCED_SEGMENT_NUMBER | Referenced Segment Number (0062,000B)
REFERENCED_SEGMENT_REFERENCE_INDEX | Referenced Segment Reference Index (3010,0020)
REFERENCED_SERIES_SEQUENCE | Referenced Series Sequence (0008,1115)
REFERENCED_SETUP_IMAGE_SEQUENCE | Referenced Setup Image Sequence (300A,0401)
REFERENCED_SOP_CLASS_UID | Referenced SOP Class UID (0008,1150)
REFERENCED_SOP_CLASS_UID_IN_FILE | Referenced SOP Class UID in File (0004,1510)
REFERENCED_SOP_INSTANCE_MAC_SEQUENCE | Referenced SOP Instance MAC Sequence (0400,0403)
REFERENCED_SOP_INSTANCE_UID | Referenced SOP Instance UID (0008,1155)
REFERENCED_SOP_INSTANCE_UID_IN_FILE | Referenced SOP Instance UID in File (0004,1511)
REFERENCED_SOP_SEQUENCE | Referenced SOP Sequence (0008,1199)
REFERENCED_SOURCE_APPLICATOR_NUMBER | Referenced Source Applicator Number (3008,0142)
REFERENCED_SOURCE_NUMBER | Referenced Source Number (300C,000E)
REFERENCED_SPATIAL_REGISTRATION_SEQUENCE | Referenced Spatial Registration Sequence (0070,0404)
REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE | Alias for tag REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE (0040,0220)
REFERENCED_START_CONTROL_POINT_INDEX | Referenced Start Control Point Index (300C,00F4)
REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE | Referenced Stereometric Instance Sequence (0008,1134)
REFERENCED_STOP_CONTROL_POINT_INDEX | Referenced Stop Control Point Index (300C,00F6)
REFERENCED_STORAGE_MEDIA_SEQUENCE | Referenced Storage Media Sequence (2200,000D)
REFERENCED_STORED_PRINT_SEQUENCE_RETIRED | Referenced Stored Print Sequence RETIRED (2000,0510)
REFERENCED_STRUCTURE_SET_SEQUENCE | Referenced Structure Set Sequence (300C,0060)
REFERENCED_STRUCTURED_CONTEXT_SEQUENCE | Referenced Structured Context Sequence (0070,1903)
REFERENCED_STUDY_COMPONENT_SEQUENCE | Alias for tag REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE (0008,1111)
REFERENCED_STUDY_SEQUENCE | Referenced Study Sequence (0008,1110)
REFERENCED_SURFACE_DATA_SEQUENCE | Referenced Surface Data Sequence (0080,0013)
REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE | Referenced Surface Mesh Identification Sequence (0022,1620)
REFERENCED_SURFACE_NUMBER | Referenced Surface Number (0066,002C)
REFERENCED_SURFACE_SEQUENCE | Referenced Surface Sequence (0066,002B)
REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID | Referenced Target Luminance Characteristics ID (0028,700E)
REFERENCED_TEXTURE_SEQUENCE | Referenced Texture Sequence (0080,0012)
REFERENCED_TIME_OFFSETS | Referenced Time Offsets (0040,A138)
REFERENCED_TOLERANCE_TABLE_NUMBER | Referenced Tolerance Table Number (300C,00A0)
REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE | Referenced Transfer Syntax UID in File (0004,1512)
REFERENCED_TREATMENT_POSITION_GROUP_UID | Referenced Treatment Position Group UID (300A,0785)
REFERENCED_TREATMENT_POSITION_INDEX | Referenced Treatment Position Index (300A,060B)
REFERENCED_TREATMENT_RECORD_SEQUENCE | Referenced Treatment Record Sequence (3008,0030)
REFERENCED_VERIFICATION_IMAGE_SEQUENCE | Referenced Verification Image Sequence (300C,0040)
REFERENCED_VISIT_SEQUENCE | Referenced Visit Sequence (0008,1125)
REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED | Referenced VOI LUT Box Sequence RETIRED (2020,0140)
REFERENCED_WAVEFORM_CHANNELS | Referenced Waveform Channels (0040,A0B0)
REFERENCED_WAVEFORM_SEQUENCE | Referenced Waveform Sequence (0008,113A)
REFERENCED_WEDGE_NUMBER | Referenced Wedge Number (300C,00C0)
REFERENCED_X_RAY_DETECTOR_INDEX | Referenced X-Ray Detector Index (0018,9376)
REFERENCED_X_RAY_SOURCE_INDEX | Referenced X-Ray Source Index (0018,9377)
REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Referring Physician Identification Sequence (0008,0096)
REFERRING_PHYSICIANS_ADDRESS | Referring Physician's Address (0008,0092)
REFERRING_PHYSICIANS_NAME | Referring Physician's Name (0008,0090)
REFERRING_PHYSICIANS_TELEPHONE_NUMBERS | Referring Physician's Telephone Numbers (0008,0094)
REFLECTED_AMBIENT_LIGHT | Reflected Ambient Light (2010,0160)
REFORMATTING_INTERVAL | Reformatting Interval (0072,0514)
REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION | Reformatting Operation Initial View Direction (0072,0516)
REFORMATTING_OPERATION_TYPE | Reformatting Operation Type (0072,0510)
REFORMATTING_THICKNESS | Reformatting Thickness (0072,0512)
REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE | Refractive Error Before Refractive Surgery Code Sequence (0022,1103)
REFRACTIVE_INDEX_APPLIED | Refractive Index Applied (0052,003A)
REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR | Refractive Index of Aqueous Humor (0046,0118)
REFRACTIVE_INDEX_OF_CORNEA | Refractive Index of Cornea (0046,0117)
REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE | Refractive Parameters Used on Patient Sequence (0024,0112)
REFRACTIVE_POWER | Refractive Power (0046,0251)
REFRACTIVE_PROCEDURE_OCCURRED | Refractive Procedure Occurred (0022,1039)
REFRACTIVE_STATE_SEQUENCE | Refractive State Sequence (0022,001B)
REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE | Refractive Surgery Type Code Sequence (0022,1040)
REGION_DATA_TYPE | Region Data Type (0018,6014)
REGION_FLAGS | Region Flags (0018,6016)
REGION_LOCATION_MAX_X1 | Region Location Max X1 (0018,601C)
REGION_LOCATION_MAX_Y1 | Region Location Max Y1 (0018,601E)
REGION_LOCATION_MIN_X0 | Region Location Min X0 (0018,6018)
REGION_LOCATION_MIN_Y0 | Region Location Min Y0 (0018,601A)
REGION_OF_RESIDENCE | Region of Residence (0010,2152)
REGION_PIXEL_SHIFT_SEQUENCE | Region Pixel Shift Sequence (0028,9502)
REGION_SPATIAL_FORMAT | Region Spatial Format (0018,6012)
REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER | Registered Localizer Bottom Right Hand Corner (0022,1468)
REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER | Registered Localizer Top Left Hand Corner (0022,1467)
REGISTERED_LOCALIZER_UNITS | Registered Localizer Units (0022,1466)
REGISTRATION_METHOD_CODE_SEQUENCE | Registration Method Code Sequence (0080,0003)
REGISTRATION_SEQUENCE | Registration Sequence (0070,0308)
REGISTRATION_TO_LOCALIZER_SEQUENCE | Registration to Localizer Sequence (0022,1465)
REGISTRATION_TYPE_CODE_SEQUENCE | Registration Type Code Sequence (0070,030D)
RELATED_ASSERTION_SEQUENCE | Related Assertion Sequence (0044,0107)
RELATED_FRAME_OF_REFERENCE_UID_RETIRED | Related Frame of Reference UID RETIRED (3006,00C2)
RELATED_GENERAL_SOP_CLASS_UID | Related General SOP Class UID (0008,001A)
RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED | Related Procedure Step Sequence RETIRED (0074,1220)
RELATED_REFERENCE_RT_IMAGE_SEQUENCE | Related Reference RT Image Sequence (0074,1040)
RELATED_RT_ROI_OBSERVATIONS_SEQUENCE | Related RT ROI Observations Sequence (3006,00A0)
RELATED_RT_TREATMENT_PHASE_INDEX | Related RT Treatment Phase Index (3010,003F)
RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE | Related Segment Characteristics Sequence (3010,0028)
RELATED_SERIES_SEQUENCE | Related Series Sequence (0008,1250)
RELATIONSHIP_SEQUENCE_TRIAL_RETIRED | Relationship Sequence (Trial) RETIRED (0040,A731)
RELATIONSHIP_TYPE | Relationship Type (0040,A010)
RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED | Relationship Type Code Sequence (Trial) RETIRED (0040,A732)
RELATIVE_ELEVATION | Relative Elevation (0046,0252)
RELATIVE_IMAGE_POSITION_CODE_SEQUENCE | Relative Image Position Code Sequence (0022,001D)
RELATIVE_OPACITY | Relative Opacity (0070,0403)
RELATIVE_TIME | Relative Time (0072,0038)
RELATIVE_TIME_UNITS | Relative Time Units (0072,003A)
RELATIVE_X_RAY_EXPOSURE | Relative X-Ray Exposure (0018,1405)
RELEVANT_INFORMATION_SEQUENCE_RETIRED | Relevant Information Sequence RETIRED (0040,4022)
RELEVANT_OPT_ATTRIBUTES_SEQUENCE | Relevant OPT Attributes Sequence (0022,1472)
REMOVED_FROM_OPERATIONAL_USE | Removed from Operational Use (0008,0405)
RENDER_FIELD_OF_VIEW | Render Field of View (0070,1606)
RENDER_PROJECTION | Render Projection (0070,1602)
RENDERED_IMAGE_REFERENCE_SEQUENCE | Rendered Image Reference Sequence (0070,1104)
RENDERING_METHOD | Rendering Method (0070,120D)
REPEAT_FRACTION_CYCLE_LENGTH | Repeat Fraction Cycle Length (300A,007A)
REPETITION_TIME | Repetition Time (0018,0080)
REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Replaced Implant Assembly Template Sequence (0076,0008)
REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE | Replaced Implant Template Group Sequence (0078,0026)
REPLACED_IMPLANT_TEMPLATE_SEQUENCE | Replaced Implant Template Sequence (0068,6222)
REPLACED_PROCEDURE_STEP_SEQUENCE | Replaced Procedure Step Sequence (0074,1224)
REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED | Report Detail Sequence (Trial) RETIRED (0040,A380)
REPORT_NUMBER | Report Number (0020,00AA)
REPORT_PRODUCTION_STATUS_TRIAL_RETIRED | Report Production Status (Trial) RETIRED (4008,00FF)
REPORT_STATUS_COMMENT_TRIAL_RETIRED | Report Status Comment (Trial) RETIRED (0040,A33A)
REPORT_STATUS_ID_TRIAL_RETIRED | Report Status ID (Trial) RETIRED (0040,A125)
REPORTED_VALUES_ORIGIN | Reported Values Origin (3002,000A)
REPORTING_PRIORITY | Reporting Priority (0040,1009)
REPOSITORY_UNIQUE_ID | Repository Unique ID (0040,E030)
REPRESENTATIVE_FRAME_NUMBER | Representative Frame Number (0028,6010)
REPROJECTION_METHOD | Reprojection Method (0054,1004)
REQUEST_ATTRIBUTES_SEQUENCE | Request Attributes Sequence (0040,0275)
REQUEST_PRIORITY | Request Priority (2200,0020)
REQUESTED_CONTRAST_AGENT | Requested Contrast Agent (0032,1070)
REQUESTED_DECIMATE_CROP_BEHAVIOR | Requested Decimate/Crop Behavior (2020,0040)
REQUESTED_IMAGE_SIZE | Requested Image Size (2020,0030)
REQUESTED_IMAGE_SIZE_FLAG | Requested Image Size Flag (2020,00A0)
REQUESTED_LATERALITY_CODE_SEQUENCE | Requested Laterality Code Sequence (0032,1065)
REQUESTED_MEDIA_APPLICATION_PROFILE | Requested Media Application Profile (2200,000C)
REQUESTED_PROCEDURE_CODE_SEQUENCE | Requested Procedure Code Sequence (0032,1064)
REQUESTED_PROCEDURE_COMMENTS | Requested Procedure Comments (0040,1400)
REQUESTED_PROCEDURE_DESCRIPTION | Requested Procedure Description (0032,1060)
REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED | Requested Procedure Description (Trial) RETIRED (0040,1060)
REQUESTED_PROCEDURE_ID | Requested Procedure ID (0040,1001)
REQUESTED_PROCEDURE_LOCATION | Requested Procedure Location (0040,1005)
REQUESTED_PROCEDURE_PRIORITY | Requested Procedure Priority (0040,1003)
REQUESTED_RESOLUTION_ID | Requested Resolution ID (2020,0050)
REQUESTED_SERIES_DESCRIPTION | Requested Series Description (0018,9937)
REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE | Requested Series Description Code Sequence (0018,11C1)
REQUESTED_SOP_CLASS_UID | Requested SOP Class UID (0000,0003)
REQUESTED_SOP_INSTANCE_UID | Requested SOP Instance UID (0000,1001)
REQUESTED_STATUS_INTERVAL | Requested Status Interval (0008,0414)
REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED | Requested Subsequent Workitem Code Sequence RETIRED (0040,4031)
REQUESTING_AE | Requesting AE (0074,1236)
REQUESTING_PHYSICIAN | Requesting Physician (0032,1032)
REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Requesting Physician Identification Sequence (0032,1031)
REQUESTING_SERVICE | Requesting Service (0032,1033)
REQUESTING_SERVICE_CODE_SEQUENCE | Requesting Service Code Sequence (0032,1034)
RESCALE_INTERCEPT | Rescale Intercept (0028,1052)
RESCALE_SLOPE | Rescale Slope (0028,1053)
RESCALE_TYPE | Rescale Type (0028,1054)
RESIDUAL_SYRINGE_COUNTS | Residual Syringe Counts (0054,0017)
RESONANT_NUCLEUS | Resonant Nucleus (0018,9100)
RESOURCE_DESCRIPTION | Resource Description (0038,0102)
RESPIRATORY_CYCLE_POSITION | Respiratory Cycle Position (0018,9214)
RESPIRATORY_INTERVAL_TIME | Respiratory Interval Time (0020,9254)
RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE | Respiratory Motion Compensation Technique (0018,9170)
RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION | Respiratory Motion Compensation Technique Description (0018,9185)
RESPIRATORY_SIGNAL_SOURCE | Respiratory Signal Source (0018,9171)
RESPIRATORY_SIGNAL_SOURCE_ID | Respiratory Signal Source ID (0018,9186)
RESPIRATORY_SYNCHRONIZATION_SEQUENCE | Respiratory Synchronization Sequence (0020,9253)
RESPIRATORY_TRIGGER_DELAY_THRESHOLD | Respiratory Trigger Delay Threshold (0020,9256)
RESPIRATORY_TRIGGER_TYPE | Respiratory Trigger Type (0020,9250)
RESPITORY_TRIGGER_DELAY_TIME | Alias for tag NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME (0020,9255)
RESPITORY_TRIGGER_SEQUENCE | Alias for tag RESPIRATORY_SYNCHRONIZATION_SEQUENCE (0020,9253)
RESPONSE_SEQUENCE_NUMBER_RETIRED | Response Sequence Number RETIRED (0000,0860)
RESPONSIBLE_GROUP_CODE_SEQUENCE | Responsible Group Code Sequence (0008,0220)
RESPONSIBLE_ORGANIZATION | Responsible Organization (0010,2299)
RESPONSIBLE_PERSON | Responsible Person (0010,2297)
RESPONSIBLE_PERSON_ROLE | Responsible Person Role (0010,2298)
RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED | Resulting General Purpose Performed Procedure Steps Sequence RETIRED (0040,4015)
RESULTS_COMMENTS_RETIRED | Results Comments RETIRED (4008,4000)
RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED | Results Distribution List Sequence RETIRED (4008,0118)
RESULTS_ID_ISSUER_RETIRED | Results ID Issuer RETIRED (4008,0042)
RESULTS_ID_RETIRED | Results ID RETIRED (4008,0040)
RESULTS_NORMALS_SEQUENCE | Results Normals Sequence (0024,0064)
RETAIN_INSTANCES | Retain Instances (0008,0415)
RETAIN_RAW_DATA | Alias for tag RAW_DATA_HANDLING (0040,4040)
RETEST_SENSITIVITY_VALUE | Retest Sensitivity Value (0024,0096)
RETEST_STIMULUS_SEEN | Retest Stimulus Seen (0024,0095)
RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE | Retinal Thickness Definition Code Sequence (0022,1445)
RETRIEVE_AE_TITLE | Retrieve AE Title (0008,0054)
RETRIEVE_LOCATION_UID | Retrieve Location UID (0040,E011)
RETRIEVE_URI | Retrieve URI (0040,E010)
RETRIEVE_URL | Retrieve URL (0008,1190)
REVIEW_DATE | Review Date (300E,0004)
REVIEW_TIME | Review Time (300E,0005)
REVIEWER_NAME | Reviewer Name (300E,0008)
REVOLUTION_TIME | Revolution Time (0018,9305)
RF_ECHO_TRAIN_LENGTH | RF Echo Train Length (0018,9240)
RGB_LUT_TRANSFER_FUNCTION | RGB LUT Transfer Function (0028,140F)
RGBA_TRANSFER_FUNCTION_DESCRIPTION | RGBA Transfer Function Description (0070,1A09)
RIGHT_IMAGE_SEQUENCE | Right Image Sequence (0022,0022)
RIGHT_LENS_SEQUENCE | Right Lens Sequence (0046,0014)
ROBOTIC_BASE_LOCATION_INDICATOR | Alias for tag ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED (3010,0090)
ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED | Robotic Base Location Indicator RETIRED (3010,0090)
ROBOTIC_NODE_IDENTIFIER | Robotic Node Identifier (3010,0092)
ROBOTIC_PATH_CONTROL_POINT_SEQUENCE | Robotic Path Control Point Sequence (3010,0097)
ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE | Robotic Path Node Set Code Sequence (3010,0091)
ROI_AREA | ROI Area (6000,1301)
ROI_CONTOUR_SEQUENCE | ROI Contour Sequence (3006,0039)
ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE | ROI Derivation Algorithm Identification Sequence (3006,0037)
ROI_DESCRIPTION | ROI Description (3006,0028)
ROI_DISPLAY_COLOR | ROI Display Color (3006,002A)
ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION | ROI Elemental Composition Atomic Mass Fraction (3006,00B8)
ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER | ROI Elemental Composition Atomic Number (3006,00B7)
ROI_ELEMENTAL_COMPOSITION_SEQUENCE | ROI Elemental Composition Sequence (3006,00B6)
ROI_GENERATION_ALGORITHM | ROI Generation Algorithm (3006,0036)
ROI_GENERATION_DESCRIPTION | ROI Generation Description (3006,0038)
ROI_INTERPRETED_TYPE | Alias for tag RT_ROI_INTERPRETED_TYPE (3006,00A4)
ROI_INTERPRETER | ROI Interpreter (3006,00A6)
ROI_MEAN | ROI Mean (6000,1302)
ROI_NAME | ROI Name (3006,0026)
ROI_NUMBER | ROI Number (3006,0022)
ROI_OBSERVATION_DESCRIPTION_RETIRED | ROI Observation Description RETIRED (3006,0088)
ROI_OBSERVATION_LABEL_RETIRED | ROI Observation Label RETIRED (3006,0085)
ROI_PHYSICAL_PROPERTIES_SEQUENCE | ROI Physical Properties Sequence (3006,00B0)
ROI_PHYSICAL_PROPERTY | ROI Physical Property (3006,00B2)
ROI_PHYSICAL_PROPERTY_VALUE | ROI Physical Property Value (3006,00B4)
ROI_STANDARD_DEVIATION | ROI Standard Deviation (6000,1303)
ROI_VOLUME | ROI Volume (3006,002C)
ROTATION_ANGLE | Rotation Angle (0070,0230)
ROTATION_DIRECTION | Rotation Direction (0018,1140)
ROTATION_INFORMATION_SEQUENCE | Rotation Information Sequence (0054,0052)
ROTATION_OF_SCANNED_FILM | Rotation of Scanned Film (0018,2030)
ROTATION_OFFSET_RETIRED | Rotation Offset RETIRED (0018,1146)
ROTATION_POINT | Rotation Point (0070,0273)
ROTATION_VECTOR | Rotation Vector (0054,0050)
ROUTE_ID | Route ID (4010,1054)
ROUTE_ID_ASSIGNING_AUTHORITY | Route ID Assigning Authority (4010,1055)
ROUTE_OF_ADMISSIONS | Route of Admissions (0038,0016)
ROUTE_SEGMENT_END_LOCATION_ID | Route Segment End Location ID (4010,101F)
ROUTE_SEGMENT_END_TIME | Route Segment End Time (4010,1026)
ROUTE_SEGMENT_ID | Route Segment ID (4010,1007)
ROUTE_SEGMENT_LOCATION_ID_TYPE | Route Segment Location ID Type (4010,1020)
ROUTE_SEGMENT_SEQUENCE | Route Segment Sequence (4010,100A)
ROUTE_SEGMENT_START_LOCATION_ID | Route Segment Start Location ID (4010,101E)
ROUTE_SEGMENT_START_TIME | Route Segment Start Time (4010,1025)
ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX | Row Position In Total Image Pixel Matrix (0048,021F)
ROWS | Rows (0028,0010)
RT_ACCESSORY_DEVICE_SLOT_ID | RT Accessory Device Slot ID (300A,0615)
RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE | RT Accessory Holder Definition Sequence (300A,0614)
RT_ACCESSORY_HOLDER_SLOT_DISTANCE | RT Accessory Holder Slot Distance (300A,0612)
RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG | RT Accessory Holder Slot Existence Flag (300A,060F)
RT_ACCESSORY_HOLDER_SLOT_ID | RT Accessory Holder Slot ID (300A,0611)
RT_ACCESSORY_HOLDER_SLOT_SEQUENCE | RT Accessory Holder Slot Sequence (300A,0610)
RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS | RT Accessory Holder Water-Equivalent Thickness (300A,060D)
RT_ACCESSORY_SLOT_DISTANCE | RT Accessory Slot Distance (300A,0613)
RT_ACQUISITION_PATIENT_POSITION_SEQUENCE | RT Acquisition Patient Position Sequence (3002,0108)
RT_ANATOMIC_PRESCRIPTION_SEQUENCE | RT Anatomic Prescription Sequence (3010,0060)
RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE | RT Beam Delimiter Geometry Sequence (300A,064C)
RT_BEAM_LIMITING_DEVICE_ANGLE | RT Beam Limiting Device Angle (300A,0679)
RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE | RT Beam Limiting Device Definition Sequence (300A,064D)
RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE | RT Beam Limiting Device Distal Distance (300A,0643)
RT_BEAM_LIMITING_DEVICE_OFFSET | RT Beam Limiting Device Offset (300A,064B)
RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE | RT Beam Limiting Device Opening Sequence (300A,0656)
RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE | RT Beam Limiting Device Proximal Distance (300A,0642)
RT_BEAM_LIMITING_DEVICE_TYPE | RT Beam Limiting Device Type (300A,00B8)
RT_BEAM_MODIFIER_DEFINITION_DISTANCE | RT Beam Modifier Definition Distance (300A,0688)
RT_CONTROL_POINT_INDEX | RT Control Point Index (300A,0600)
RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE | RT Delivery Start Patient Position Sequence (300A,0789)
RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE | RT Device Distance Reference Location Code Sequence (300A,0659)
RT_DIAGNOSIS_CODE_SEQUENCE | RT Diagnosis Code Sequence (3010,005D)
RT_DOSE_ROI_SEQUENCE | RT Dose ROI Sequence RETIRED (3004,0010)
RT_DOSE_ROI_SEQUENCE_RETIRED | RT Dose ROI Sequence RETIRED (3004,0010)
RT_IMAGE_DESCRIPTION | RT Image Description (3002,0004)
RT_IMAGE_FRAME_CONTEXT_SEQUENCE | RT Image Frame Context Sequence (3002,0103)
RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE | RT Image Frame General Content Sequence (3002,0102)
RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE | RT Image Frame Imaging Device Position Sequence (3002,0109)
RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame kV Radiation Acquisition Sequence (3002,010A)
RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame MV Radiation Acquisition Sequence (3002,010B)
RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame Radiation Acquisition Sequence (3002,010C)
RT_IMAGE_LABEL | RT Image Label (3002,0002)
RT_IMAGE_NAME | RT Image Name (3002,0003)
RT_IMAGE_ORIENTATION | RT Image Orientation (3002,0010)
RT_IMAGE_PLANE | RT Image Plane (3002,000C)
RT_IMAGE_POSITION | RT Image Position (3002,0012)
RT_IMAGE_SCOPE_SEQUENCE | RT Image Scope Sequence (3002,0104)
RT_IMAGE_SID | RT Image SID (3002,0026)
RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE | RT Patient Position Displacement Sequence (300A,0798)
RT_PATIENT_POSITION_SCOPE_SEQUENCE | RT Patient Position Scope Sequence (300A,0784)
RT_PATIENT_POSITION_SEQUENCE | RT Patient Position Sequence (300A,0799)
RT_PHYSICIAN_INTENT_INDEX | RT Physician Intent Index (3010,0058)
RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE | RT Physician Intent Input Instance Sequence (3010,005F)
RT_PHYSICIAN_INTENT_NARRATIVE | RT Physician Intent Narrative (3010,005A)
RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE | RT Physician Intent Predecessor Sequence (3010,0055)
RT_PHYSICIAN_INTENT_SEQUENCE | RT Physician Intent Sequence (3010,0057)
RT_PLAN_DATE | RT Plan Date (300A,0006)
RT_PLAN_DESCRIPTION | RT Plan Description (300A,0004)
RT_PLAN_GEOMETRY | RT Plan Geometry (300A,000C)
RT_PLAN_LABEL | RT Plan Label (300A,0002)
RT_PLAN_NAME | RT Plan Name (300A,0003)
RT_PLAN_RELATIONSHIP | RT Plan Relationship (300A,0055)
RT_PLAN_TIME | RT Plan Time (300A,0007)
RT_PRESCRIPTION_INDEX | RT Prescription Index (3010,003C)
RT_PRESCRIPTION_LABEL | RT Prescription Label (3010,0054)
RT_PRESCRIPTION_SEQUENCE | RT Prescription Sequence (3010,006B)
RT_PROTOCOL_CODE_SEQUENCE | RT Protocol Code Sequence (3010,005B)
RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG | RT Radiation Physical and Geometric Content Detail Flag (300A,0638)
RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE | RT Radiation Salvage Record Control Point Sequence (300A,0722)
RT_RADIATION_SEQUENCE | RT Radiation Sequence (300A,0616)
RT_RADIATION_SET_DELIVERY_NUMBER | RT Radiation Set Delivery Number (300A,0704)
RT_RADIATION_SET_DELIVERY_USAGE | RT Radiation Set Delivery Usage (300A,079E)
RT_RADIATION_SET_INTENT | RT Radiation Set Intent (300A,0637)
RT_RADIATION_SET_USAGE | RT Radiation Set Usage (300A,0707)
RT_RADIATION_TASK_SEQUENCE | RT Radiation Task Sequence (300A,0797)
RT_RADIATION_USAGE | RT Radiation Usage (300A,0701)
RT_RECORD_FLAG | RT Record Flag (300A,0639)
RT_REFERENCED_SERIES_SEQUENCE | RT Referenced Series Sequence (3006,0014)
RT_REFERENCED_STUDY_SEQUENCE | RT Referenced Study Sequence (3006,0012)
RT_RELATED_ROI_SEQUENCE | RT Related ROI Sequence (3006,0030)
RT_ROI_IDENTIFICATION_CODE_SEQUENCE | RT ROI Identification Code Sequence (3006,0086)
RT_ROI_INTERPRETED_TYPE | RT ROI Interpreted Type (3006,00A4)
RT_ROI_OBERVATIONS_SEQUENCE | Alias for tag RT_ROI_OBSERVATIONS_SEQUENCE (3006,0080)
RT_ROI_OBSERVATIONS_SEQUENCE | RT ROI Observations Sequence (3006,0080)
RT_ROI_RELATIONSHIP | RT ROI Relationship (3006,0033)
RT_SEGMENT_ANNOTATION_INDEX | RT Segment Annotation Index (3010,003D)
RT_SEGMENT_ANNOTATION_SEQUENCE | RT Segment Annotation Sequence (3010,002A)
RT_TOLERANCE_SET_LABEL | RT Tolerance Set Label (300A,062A)
RT_TOLERANCE_SET_SEQUENCE | RT Tolerance Set Sequence (300A,0629)
RT_TREATMENT_APPROACH_LABEL | RT Treatment Approach Label (3010,0056)
RT_TREATMENT_FRACTION_COMPLETION_STATUS | RT Treatment Fraction Completion Status (300A,0706)
RT_TREATMENT_INTENT_TYPE | RT Treatment Intent Type (3010,0059)
RT_TREATMENT_PHASE_INDEX | RT Treatment Phase Index (3010,003A)
RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG | RT Treatment Phase Intent Presence Flag (3010,0045)
RT_TREATMENT_PHASE_INTERVAL_SEQUENCE | RT Treatment Phase Interval Sequence (3010,004E)
RT_TREATMENT_PHASE_UID | RT Treatment Phase UID (3010,003B)
RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE | RT Treatment Preparation Patient Position Sequence (300A,078A)
RT_TREATMENT_SOURCE_COORDINATES | RT Treatment Source Coordinates (3010,0093)
RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE | RT Treatment Technique Code Sequence (3010,0080)
RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE | RT Treatment Termination Reason Code Sequence (300A,0715)
RT_TREATMENT_TERMINATION_STATUS | RT Treatment Termination Status (300A,0714)
RTV_COMMUNICATION_SOP_CLASS_UID | RTV Communication SOP Class UID (0002,0032)
RTV_COMMUNICATION_SOP_INSTANCE_UID | RTV Communication SOP Instance UID (0002,0033)
RTV_FLOW_ACTUAL_FRAME_DURATION | RTV Flow Actual Frame Duration (0002,0038)
RTV_FLOW_IDENTIFIER | RTV Flow Identifier (0002,0036)
RTV_FLOW_RTP_SAMPLING_RATE | RTV Flow RTP Sampling Rate (0002,0037)
RTV_META_INFORMATION_VERSION | RTV Meta Information Version (0002,0031)
RTV_SOURCE_IDENTIFIER | RTV Source Identifier (0002,0035)
SAFE_POSITION_EXIT_DATE | Safe Position Exit Date (3008,0162)
SAFE_POSITION_EXIT_TIME | Safe Position Exit Time (3008,0164)
SAFE_POSITION_RETURN_DATE | Safe Position Return Date (3008,0166)
SAFE_POSITION_RETURN_TIME | Safe Position Return Time (3008,0168)
SAMPLE_RATE_RETIRED | Sample Rate RETIRED (5000,2008)
SAMPLES_PER_PIXEL | Samples per Pixel (0028,0002)
SAMPLES_PER_PIXEL_USED | Samples per Pixel Used (0028,0003)
SAMPLING_FREQUENCY | Sampling Frequency (003A,001A)
SAMPLING_STEP_SIZE | Sampling Step Size (0070,1607)
SAR | SAR (0018,1316)
SATURATION | Saturation (0016,0049)
SATURATION_RECOVERY | Saturation Recovery (0018,9024)
SCAN_ARC | Scan Arc (0018,1143)
SCAN_ARC_TYPE | Scan Arc Type (3002,012E)
SCAN_LENGTH | Scan Length (0018,1302)
SCAN_MODE | Scan Mode (300A,0308)
SCAN_OPTIONS | Scan Options (0018,0022)
SCAN_PATTERN_TYPE_CODE_SEQUENCE | Scan Pattern Type Code Sequence (0022,1618)
SCAN_PROGRESSION_DIRECTION | Scan Progression Direction (0054,0501)
SCAN_SPOT_METERSET_WEIGHTS | Scan Spot Meterset Weights (300A,0396)
SCAN_SPOT_METERSETS_DELIVERED | Scan Spot Metersets Delivered (3008,0047)
SCAN_SPOT_POSITION_MAP | Scan Spot Position Map (300A,0394)
SCAN_SPOT_PRESCRIBED_INDICES | Scan Spot Prescribed Indices (300A,0391)
SCAN_SPOT_REORDERED | Scan Spot Reordered (300A,0393)
SCAN_SPOT_REORDERING_ALLOWED | Scan Spot Reordering Allowed (300A,0395)
SCAN_SPOT_SIZES_DELIVERED | Scan Spot Sizes Delivered (300A,0399)
SCAN_SPOT_TIME_OFFSET | Scan Spot Time Offset (300A,038F)
SCAN_SPOT_TUNE_ID | Scan Spot Tune ID (300A,0390)
SCAN_START_POSITION_SEQUENCE | Scan Start Position Sequence (3002,012B)
SCAN_STOP_POSITION_SEQUENCE | Scan Stop Position Sequence (3002,012C)
SCAN_TYPE | Scan Type (4010,1048)
SCAN_VELOCITY | Scan Velocity (0018,1300)
SCANNING_SEQUENCE | Scanning Sequence (0018,0020)
SCANNING_SPOT_SIZE | Scanning Spot Size (300A,0398)
SCATTER_CORRECTED | Scatter Corrected (0018,9760)
SCATTER_CORRECTION_METHOD | Scatter Correction Method (0054,1105)
SCATTER_FRACTION_FACTOR | Scatter Fraction Factor (0054,1323)
SCENE_CAPTURE_TYPE | Scene Capture Type (0016,0046)
SCENE_TYPE | Scene Type (0016,003B)
SCHEDULED_ADMISSION_DATE_RETIRED | Scheduled Admission Date RETIRED (0038,001A)
SCHEDULED_ADMISSION_TIME_RETIRED | Scheduled Admission Time RETIRED (0038,001B)
SCHEDULED_DISCHARGE_DATE_RETIRED | Scheduled Discharge Date RETIRED (0038,001C)
SCHEDULED_DISCHARGE_TIME_RETIRED | Scheduled Discharge Time RETIRED (0038,001D)
SCHEDULED_HUMAN_PERFORMERS_SEQUENCE | Scheduled Human Performers Sequence (0040,4034)
SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED | Scheduled Patient Institution Residence RETIRED (0038,001E)
SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE | Alias for tag SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE (0040,000B)
SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Scheduled Performing Physician Identification Sequence (0040,000B)
SCHEDULED_PERFORMING_PHYSICIANS_NAME | Scheduled Performing Physician's Name (0040,0006)
SCHEDULED_PROCEDURE_STEP_DESCRIPTION | Scheduled Procedure Step Description (0040,0007)
SCHEDULED_PROCEDURE_STEP_END_DATE | Scheduled Procedure Step End Date (0040,0004)
SCHEDULED_PROCEDURE_STEP_END_TIME | Scheduled Procedure Step End Time (0040,0005)
SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME | Scheduled Procedure Step Expiration DateTime (0040,4008)
SCHEDULED_PROCEDURE_STEP_ID | Scheduled Procedure Step ID (0040,0009)
SCHEDULED_PROCEDURE_STEP_LOCATION | Scheduled Procedure Step Location (0040,0011)
SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME | Scheduled Procedure Step Modification DateTime (0040,4010)
SCHEDULED_PROCEDURE_STEP_PRIORITY | Scheduled Procedure Step Priority (0074,1200)
SCHEDULED_PROCEDURE_STEP_SEQUENCE | Scheduled Procedure Step Sequence (0040,0100)
SCHEDULED_PROCEDURE_STEP_START_DATE | Scheduled Procedure Step Start Date (0040,0002)
SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME | Alias for tag SCHEDULED_PROCEDURE_STEP_START_DATETIME (0040,4005)
SCHEDULED_PROCEDURE_STEP_START_DATETIME | Scheduled Procedure Step Start DateTime (0040,4005)
SCHEDULED_PROCEDURE_STEP_START_TIME | Scheduled Procedure Step Start Time (0040,0003)
SCHEDULED_PROCEDURE_STEP_STATUS | Scheduled Procedure Step Status (0040,0020)
SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED | Scheduled Processing Applications Code Sequence RETIRED (0040,4004)
SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE | Scheduled Processing Parameters Sequence (0074,1210)
SCHEDULED_PROTOCOL_CODE_SEQUENCE | Scheduled Protocol Code Sequence (0040,0008)
SCHEDULED_SPECIMEN_SEQUENCE | Scheduled Specimen Sequence (0040,0500)
SCHEDULED_STATION_AE_TITLE | Scheduled Station AE Title (0040,0001)
SCHEDULED_STATION_CLASS_CODE_SEQUENCE | Scheduled Station Class Code Sequence (0040,4026)
SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE | Scheduled Station Geographic Location Code Sequence (0040,4027)
SCHEDULED_STATION_NAME | Scheduled Station Name (0040,0010)
SCHEDULED_STATION_NAME_CODE_SEQUENCE | Scheduled Station Name Code Sequence (0040,4025)
SCHEDULED_STEP_ATTRIBUTES_SEQUENCE | Scheduled Step Attributes Sequence (0040,0270)
SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED | Scheduled Study Location AE Title RETIRED (0032,1021)
SCHEDULED_STUDY_LOCATION_RETIRED | Scheduled Study Location RETIRED (0032,1020)
SCHEDULED_STUDY_START_DATE_RETIRED | Scheduled Study Start Date RETIRED (0032,1000)
SCHEDULED_STUDY_START_TIME_RETIRED | Scheduled Study Start Time RETIRED (0032,1001)
SCHEDULED_STUDY_STOP_DATE_RETIRED | Scheduled Study Stop Date RETIRED (0032,1010)
SCHEDULED_STUDY_STOP_TIME_RETIRED | Scheduled Study Stop Time RETIRED (0032,1011)
SCHEDULED_WORKITEM_CODE_SEQUENCE | Scheduled Workitem Code Sequence (0040,4018)
SCOPE_OF_INVENTORY_SEQUENCE | Scope of Inventory Sequence (0008,0400)
SCP_STATUS | SCP Status (0074,1242)
SCREEN_MINIMUM_COLOR_BIT_DEPTH | Screen Minimum Color Bit Depth (0072,010C)
SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH | Screen Minimum Grayscale Bit Depth (0072,010A)
SCREENING_BASELINE_MEASURED | Screening Baseline Measured (0024,0120)
SCREENING_BASELINE_MEASURED_SEQUENCE | Screening Baseline Measured Sequence (0024,0122)
SCREENING_BASELINE_TYPE | Screening Baseline Type (0024,0124)
SCREENING_BASELINE_VALUE | Screening Baseline Value (0024,0126)
SCREENING_TEST_MODE_CODE_SEQUENCE | Screening Test Mode Code Sequence (0024,0016)
SEAM_LINE_INDEX | Seam Line Index (0052,0036)
SEAM_LINE_LOCATION | Seam Line Location (0052,0033)
SECONDARY_CAPTURE_DEVICE_ID | Secondary Capture Device ID (0018,1010)
SECONDARY_CAPTURE_DEVICE_MANUFACTURER | Secondary Capture Device Manufacturer (0018,1016)
SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME | Secondary Capture Device Manufacturer's Model Name (0018,1018)
SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS | Secondary Capture Device Software Versions (0018,1019)
SECONDARY_COUNTS_ACCUMULATED | Secondary Counts Accumulated (0054,1311)
SECONDARY_COUNTS_TYPE | Secondary Counts Type (0054,1220)
SECONDARY_POSITIONER_INCREMENT | Secondary Positioner Increment (0018,9515)
SECONDARY_POSITIONER_INCREMENT_SIGN | Secondary Positioner Increment Sign (0018,9519)
SECONDARY_POSITIONER_SCAN_ARC | Secondary Positioner Scan Arc (0018,9509)
SECONDARY_POSITIONER_SCAN_START_ANGLE | Secondary Positioner Scan Start Angle (0018,9511)
SEGMENT_ALGORITHM_NAME | Segment Algorithm Name (0062,0009)
SEGMENT_ALGORITHM_TYPE | Segment Algorithm Type (0062,0008)
SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE | Segment Annotation Category Code Sequence (3010,002B)
SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE | Segment Annotation Type Code Sequence (3010,002C)
SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE | Segment Annotation Type Modifier Code Sequence (3010,002F)
SEGMENT_CHARACTERISTICS_PRECEDENCE | Segment Characteristics Precedence (3010,0029)
SEGMENT_CHARACTERISTICS_SEQUENCE | Segment Characteristics Sequence (3010,0027)
SEGMENT_DESCRIPTION | Segment Description (0062,0006)
SEGMENT_IDENTIFICATION_SEQUENCE | Segment Identification Sequence (0062,000A)
SEGMENT_LABEL | Segment Label (0062,0005)
SEGMENT_NUMBER | Segment Number (0062,0004)
SEGMENT_REFERENCE_INDEX | Segment Reference Index (3010,0022)
SEGMENT_REFERENCE_SEQUENCE | Segment Reference Sequence (3010,0021)
SEGMENT_SEQUENCE | Segment Sequence (0062,0002)
SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE | Segment Surface Generation Algorithm Identification Sequence (0066,002D)
SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE | Segment Surface Source Instance Sequence (0066,002E)
SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE | Segmentation Algorithm Identification Sequence (0062,0007)
SEGMENTATION_CREATION_TEMPLATE_LABEL | Segmentation Creation Template Label (3010,001E)
SEGMENTATION_FRACTIONAL_TYPE | Segmentation Fractional Type (0062,0010)
SEGMENTATION_TEMPLATE_UID | Segmentation Template UID (3010,001F)
SEGMENTATION_TYPE | Segmentation Type (0062,0001)
SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Alpha Palette Color Lookup Table Data (0028,1224)
SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1223)
SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Blue Palette Color Lookup Table Data (0028,1223)
SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1222)
SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Green Palette Color Lookup Table Data (0028,1222)
SEGMENTED_K_SPACE_TRAVERSAL | Segmented k-Space Traversal (0018,9033)
SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE | Segmented Property Category Code Sequence (0062,0003)
SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE | Segmented Property Type Code Sequence (0062,000F)
SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE | Segmented Property Type Modifier Code Sequence (0062,0011)
SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1221)
SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Red Palette Color Lookup Table Data (0028,1221)
SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE | Segmented RT Accessory Device Sequence (3010,0026)
SEGMENTS_OVERLAP | Segments Overlap (0062,0013)
SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Selected Frame Functional Groups Sequence (3002,0101)
SELECTED_FRAME_NUMBER | Selected Frame Number (3002,0100)
SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Selected Segmental Ophthalmic Axial Length Sequence (0022,1257)
SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Selected Total Ophthalmic Axial Length Sequence (0022,1260)
SELECTOR_AE_VALUE | Selector AE Value (0072,005E)
SELECTOR_AS_VALUE | Selector AS Value (0072,005F)
SELECTOR_AT_VALUE | Selector AT Value (0072,0060)
SELECTOR_ATTRIBUTE | Selector Attribute (0072,0026)
SELECTOR_ATTRIBUTE_KEYWORD | Selector Attribute Keyword (0082,0019)
SELECTOR_ATTRIBUTE_NAME | Selector Attribute Name (0082,0018)
SELECTOR_ATTRIBUTE_PRIVATE_CREATOR | Selector Attribute Private Creator (0072,0056)
SELECTOR_ATTRIBUTE_VR | Selector Attribute VR (0072,0050)
SELECTOR_CODE_SEQUENCE_VALUE | Selector Code Sequence Value (0072,0080)
SELECTOR_CS_VALUE | Selector CS Value (0072,0062)
SELECTOR_DA_VALUE | Selector DA Value (0072,0061)
SELECTOR_DS_VALUE | Selector DS Value (0072,0072)
SELECTOR_DT_VALUE | Selector DT Value (0072,0063)
SELECTOR_FD_VALUE | Selector FD Value (0072,0074)
SELECTOR_FL_VALUE | Selector FL Value (0072,0076)
SELECTOR_IS_VALUE | Selector IS Value (0072,0064)
SELECTOR_LO_VALUE | Selector LO Value (0072,0066)
SELECTOR_LT_VALUE | Selector LT Value (0072,0068)
SELECTOR_OB_VALUE | Selector OB Value (0072,0065)
SELECTOR_OD_VALUE | Selector OD Value (0072,0073)
SELECTOR_OF_VALUE | Selector OF Value (0072,0067)
SELECTOR_OL_VALUE | Selector OL Value (0072,0075)
SELECTOR_OV_VALUE | Selector OV Value (0072,0081)
SELECTOR_OW_VALUE | Selector OW Value (0072,0069)
SELECTOR_PN_VALUE | Selector PN Value (0072,006A)
SELECTOR_SEQUENCE_POINTER | Selector Sequence Pointer (0072,0052)
SELECTOR_SEQUENCE_POINTER_ITEMS | Selector Sequence Pointer Items (0074,1057)
SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR | Selector Sequence Pointer Private Creator (0072,0054)
SELECTOR_SH_VALUE | Selector SH Value (0072,006C)
SELECTOR_SL_VALUE | Selector SL Value (0072,007C)
SELECTOR_SS_VALUE | Selector SS Value (0072,007E)
SELECTOR_ST_VALUE | Selector ST Value (0072,006E)
SELECTOR_SV_VALUE | Selector SV Value (0072,0082)
SELECTOR_TM_VALUE | Selector TM Value (0072,006B)
SELECTOR_UC_VALUE | Selector UC Value (0072,006F)
SELECTOR_UI_VALUE | Selector UI Value (0072,007F)
SELECTOR_UL_VALUE | Selector UL Value (0072,0078)
SELECTOR_UN_VALUE | Selector UN Value (0072,006D)
SELECTOR_UR_VALUE | Selector UR Value (0072,0071)
SELECTOR_US_VALUE | Selector US Value (0072,007A)
SELECTOR_UT_VALUE | Selector UT Value (0072,0070)
SELECTOR_UV_VALUE | Selector UV Value (0072,0083)
SELECTOR_VALUE_NUMBER | Selector Value Number (0072,0028)
SELF_TIMER_MODE | Self Timer Mode (0016,0019)
SENDING_APPLICATION_ENTITY_TITLE | Sending Application Entity Title (0002,0017)
SENDING_PRESENTATION_ADDRESS | Sending Presentation Address (0002,0027)
SENSING_METHOD | Sensing Method (0016,0039)
SENSITIVITY | Sensitivity (0018,6000)
SENSITIVITY_CALIBRATED | Sensitivity Calibrated (0018,9767)
SENSITIVITY_TYPE | Sensitivity Type (0016,001A)
SENSITIVITY_VALUE | Sensitivity Value (0024,0094)
SENSOR_NAME | Sensor Name (0014,3022)
SENSOR_TEMPERATURE | Sensor Temperature (0014,3028)
SEQUENCE_NAME | Sequence Name (0018,0024)
SEQUENCE_OF_ULTRASOUND_REGIONS | Sequence of Ultrasound Regions (0018,6011)
SEQUENCE_VARIANT | Sequence Variant (0018,0021)
SEQUENCING_INDICATOR_TRIAL_RETIRED | Sequencing Indicator (Trial) RETIRED (0040,A060)
SERIES_DATE | Series Date (0008,0021)
SERIES_DESCRIPTION | Series Description (0008,103E)
SERIES_DESCRIPTION_CODE_SEQUENCE | Series Description Code Sequence (0008,103F)
SERIES_IN_STUDY_RETIRED | Series in Study RETIRED (0020,1000)
SERIES_INSTANCE_UID | Series Instance UID (0020,000E)
SERIES_NUMBER | Series Number (0020,0011)
SERIES_TIME | Series Time (0008,0031)
SERIES_TYPE | Series Type (0054,1000)
SERVICE_EPISODE_DESCRIPTION | Service Episode Description (0038,0062)
SERVICE_EPISODE_ID | Service Episode ID (0038,0060)
SETTLING_PHASE_FRAME | Settling Phase Frame (0018,9624)
SETUP_DEVICE_DESCRIPTION | Setup Device Description (300A,01BA)
SETUP_DEVICE_LABEL | Setup Device Label (300A,01B8)
SETUP_DEVICE_PARAMETER | Setup Device Parameter (300A,01BC)
SETUP_DEVICE_SEQUENCE | Setup Device Sequence (300A,01B4)
SETUP_DEVICE_TYPE | Setup Device Type (300A,01B6)
SETUP_IMAGE_COMMENT | Setup Image Comment (300A,0402)
SETUP_REFERENCE_DESCRIPTION | Setup Reference Description (300A,01D0)
SETUP_TECHNIQUE | Setup Technique (300A,01B0)
SETUP_TECHNIQUE_DESCRIPTION | Setup Technique Description (300A,01B2)
SHADING_STYLE | Shading Style (0070,1701)
SHADOW_COLOR_CIELAB_VALUE | Shadow Color CIELab Value (0070,0247)
SHADOW_OFFSET_X | Shadow Offset X (0070,0245)
SHADOW_OFFSET_Y | Shadow Offset Y (0070,0246)
SHADOW_OPACITY | Shadow Opacity (0070,0258)
SHADOW_STYLE | Shadow Style (0070,0244)
SHAPE_TYPE | Shape Type (0070,0306)
SHARED_FUNCTIONAL_GROUPS_SEQUENCE | Shared Functional Groups Sequence (5200,9229)
SHARPNESS | Sharpness (0016,004A)
SHIELDING_DEVICE_DESCRIPTION | Shielding Device Description (300A,01A6)
SHIELDING_DEVICE_LABEL | Shielding Device Label (300A,01A4)
SHIELDING_DEVICE_POSITION | Shielding Device Position (300A,01A8)
SHIELDING_DEVICE_SEQUENCE | Shielding Device Sequence (300A,01A0)
SHIELDING_DEVICE_TYPE | Shielding Device Type (300A,01A2)
SHININESS | Shininess (0070,1706)
SHORT_TERM_FLUCTUATION | Short Term Fluctuation (0024,0075)
SHORT_TERM_FLUCTUATION_CALCULATED | Short Term Fluctuation Calculated (0024,0074)
SHORT_TERM_FLUCTUATION_PROBABILITY | Short Term Fluctuation Probability (0024,0077)
SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED | Short Term Fluctuation Probability Calculated (0024,0076)
SHOT_DURATION_TIME | Shot Duration Time (0080,0004)
SHOT_OFFSET_TIME | Shot Offset Time (0080,0005)
SHOW_ACQUISITION_TECHNIQUES_FLAG | Show Acquisition Techniques Flag (0072,0716)
SHOW_GRAPHIC_ANNOTATION_FLAG | Show Graphic Annotation Flag (0072,0712)
SHOW_GRAYSCALE_INVERTED | Show Grayscale Inverted (0072,0706)
SHOW_IMAGE_TRUE_SIZE_FLAG | Show Image True Size Flag (0072,0710)
SHOW_PATIENT_DEMOGRAPHICS_FLAG | Show Patient Demographics Flag (0072,0714)
SHOW_TICK_LABEL | Show Tick Label (0070,0278)
SHUTTER_LEFT_VERTICAL_EDGE | Shutter Left Vertical Edge (0018,1602)
SHUTTER_LOWER_HORIZONTAL_EDGE | Shutter Lower Horizontal Edge (0018,1608)
SHUTTER_OVERLAY_GROUP | Shutter Overlay Group (0018,1623)
SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE | Shutter Presentation Color CIELab Value (0018,1624)
SHUTTER_PRESENTATION_VALUE | Shutter Presentation Value (0018,1622)
SHUTTER_RIGHT_VERTICAL_EDGE | Shutter Right Vertical Edge (0018,1604)
SHUTTER_SHAPE | Shutter Shape (0018,1600)
SHUTTER_SPEED_VALUE | Shutter Speed Value (0016,0021)
SHUTTER_UPPER_HORIZONTAL_EDGE | Shutter Upper Horizontal Edge (0018,1606)
SIGNAL_DOMAIN_COLUMNS | Signal Domain Columns (0028,9003)
SIGNAL_DOMAIN_ROWS | Signal Domain Rows (0028,9235)
SIGNAL_TO_NOISE_RATIO | Signal to Noise Ratio (0022,1155)
SIGNATURE | Signature (0400,0120)
SIMPLE_FRAME_LIST | Simple Frame List (0008,1161)
SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE | Simulated Keratometric Cylinder Sequence (0046,0218)
SINGLE_COLLIMATION_WIDTH | Single Collimation Width (0018,9306)
SKIP_BEATS | Skip Beats (0018,1086)
SKIP_FRAME_RANGE_FLAG | Skip Frame Range Flag (0008,9460)
SLAB_ORIENTATION | Slab Orientation (0018,9105)
SLAB_THICKNESS | Slab Thickness (0018,9104)
SLICE_LOCATION | Slice Location (0020,1041)
SLICE_LOCATION_VECTOR | Slice Location Vector (0018,2005)
SLICE_PROGRESS_DIRECTION | Alias for tag SLICE_PROGRESSION_DIRECTION (0054,0500)
SLICE_PROGRESSION_DIRECTION | Slice Progression Direction (0054,0500)
SLICE_SENSITIVITY_FACTOR | Slice Sensitivity Factor (0054,1320)
SLICE_THICKNESS | Slice Thickness (0018,0050)
SLICE_VECTOR | Slice Vector (0054,0080)
SLIDE_IDENTIFIER_RETIRED | Slide Identifier RETIRED (0040,06FA)
SMALLEST_IMAGE_PIXEL_VALUE | Smallest Image Pixel Value (0028,0106)
SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED | Smallest Image Pixel Value in Plane RETIRED (0028,0110)
SMALLEST_PIXEL_VALUE_IN_SERIES | Smallest Pixel Value in Series (0028,0108)
SMALLEST_PIXEL_VALUE_RETIRED | Alias for tag SMALLEST_VALID_PIXEL_VALUE_RETIRED (0028,0104)
SMALLEST_VALID_PIXEL_VALUE_RETIRED | Smallest Valid Pixel Value RETIRED (0028,0104)
SMOKING_STATUS | Smoking Status (0010,21A0)
SMOOTHING_TYPE | Smoothing Type (2010,0080)
SNOUT_ID | Snout ID (300A,030F)
SNOUT_POSITION | Snout Position (300A,030D)
SNOUT_POSITION_TOLERANCE | Snout Position Tolerance (300A,004B)
SNOUT_SEQUENCE | Snout Sequence (300A,030C)
SOFT_TISSUE_FOCUS_THERMAL_INDEX | Soft Tissue-focus Thermal Index (0018,5028)
SOFT_TISSUE_SURFACE_THERMAL_INDEX | Soft Tissue-surface Thermal Index (0018,5029)
SOFT_TISSUE_THERMAL_INDEX | Soft Tissue Thermal Index (0018,5027)
SOFTCOPY_VOI_LUT_SEQUENCE | Softcopy VOI LUT Sequence (0028,3110)
SOFTWARE_VERSIONS | Software Version(s) (0018,1020)
SOP_AUTHORIZATION_COMMENT | SOP Authorization Comment (0100,0424)
SOP_AUTHORIZATION_DATE_AND_TIME | Alias for tag SOP_AUTHORIZATION_DATETIME (0100,0420)
SOP_AUTHORIZATION_DATETIME | SOP Authorization DateTime (0100,0420)
SOP_CLASS_UID | SOP Class UID (0008,0016)
SOP_CLASSES_IN_STUDY | SOP Classes in Study (0008,0062)
SOP_CLASSES_SUPPORTED | SOP Classes Supported (0008,115A)
SOP_INSTANCE_STATUS | SOP Instance Status (0100,0410)
SOP_INSTANCE_UID | SOP Instance UID (0008,0018)
SOP_INSTANCE_UID_CONCATENATION_SOURCE | Alias for tag SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE (0020,0242)
SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE | SOP Instance UID of Concatenation Source (0020,0242)
SORT_BY_CATEGORY | Sort-by Category (0072,0602)
SORTING_DIRECTION | Sorting Direction (0072,0604)
SORTING_OPERATIONS_SEQUENCE | Sorting Operations Sequence (0072,0600)
SOUND_PATH_LENGTH | Sound Path Length (0014,405A)
SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE | Sound Speed Correction Mechanism Code Sequence (0018,9832)
SOURCE_ACQUISITION_BEAM_NUMBER | Source Acquisition Beam Number (0018,9939)
SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER | Source Acquisition Protocol Element Number (0018,9938)
SOURCE_APPLICATION_ENTITY_TITLE | Source Application Entity Title (0002,0016)
SOURCE_APPLICATOR_ID | Source Applicator ID (300A,0291)
SOURCE_APPLICATOR_LENGTH | Source Applicator Length (300A,0296)
SOURCE_APPLICATOR_MANUFACTURER | Source Applicator Manufacturer (300A,0298)
SOURCE_APPLICATOR_NAME | Source Applicator Name (300A,0294)
SOURCE_APPLICATOR_NUMBER | Source Applicator Number (300A,0290)
SOURCE_APPLICATOR_STEP_SIZE | Source Applicator Step Size (300A,02A0)
SOURCE_APPLICATOR_TIP_LENGTH | Source Applicator Tip Length (300A,0274)
SOURCE_APPLICATOR_TYPE | Source Applicator Type (300A,0292)
SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS | Source Applicator Wall Nominal Thickness (300A,029C)
SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION | Source Applicator Wall Nominal Transmission (300A,029E)
SOURCE_AXIS_DISTANCE | Source-Axis Distance (300A,00B4)
SOURCE_CONCEPTUAL_VOLUME_SEQUENCE | Source Conceptual Volume Sequence (3010,0018)
SOURCE_CONCEPTUAL_VOLUME_UID | Source Conceptual Volume UID (3010,0015)
SOURCE_DESCRIPTION | Source Description (300A,021C)
SOURCE_ENCAPSULATION_NOMINAL_THICKNESS | Source Encapsulation Nominal Thickness (300A,0222)
SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION | Source Encapsulation Nominal Transmission (300A,0224)
SOURCE_END_DATE_TIME | Source End Date Time (0018,936A)
SOURCE_FRAME_OF_REFERENCE_UID | Source Frame of Reference UID (0064,0003)
SOURCE_HANGING_PROTOCOL_SEQUENCE | Source Hanging Protocol Sequence (0072,0012)
SOURCE_IDENTIFIER | Source Identifier (0034,0005)
SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE | Source Image Corneal Processed Data Sequence (0046,0244)
SOURCE_IMAGE_EVIDENCE_SEQUENCE | Source Image Evidence Sequence (0008,9154)
SOURCE_IMAGE_IDS_RETIRED | Source Image IDs RETIRED (0020,3100)
SOURCE_IMAGE_SEQUENCE | Source Image Sequence (0008,2112)
SOURCE_INSTANCE_SEQUENCE | Source Instance Sequence (0042,0013)
SOURCE_IRRADIATION_EVENT_SEQUENCE | Source Irradiation Event Sequence (0008,3011)
SOURCE_ISOTOPE_HALF_LIFE | Source Isotope Half Life (300A,0228)
SOURCE_ISOTOPE_NAME | Source Isotope Name (300A,0226)
SOURCE_MANUFACTURER | Source Manufacturer (300A,0216)
SOURCE_MODEL_ID | Source Model ID (300A,021B)
SOURCE_MOVEMENT_TYPE | Source Movement Type (300A,0288)
SOURCE_NUMBER | Source Number (300A,0212)
SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE | Source of Anterior Chamber Depth Data Code Sequence (0022,1133)
SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE | Source of Cornea Measurement Data Code Sequence (0046,0111)
SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE | Source of Corneal Size Data Code Sequence (0022,1036)
SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE | Source of Lens Thickness Data Code Sequence (0022,1132)
SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE | Source of Ophthalmic Axial Length Code Sequence (0022,1035)
SOURCE_OF_PREVIOUS_VALUES | Source of Previous Values (0400,0564)
SOURCE_OF_REFERENCE_OBJECT_DISTANCE | Alias for tag SOURCE_TO_REFERENCE_OBJECT_DISTANCE (3002,0028)
SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE | Alias for tag SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE (0022,1135)
SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE | Source of Refractive Measurements Code Sequence (0022,1135)
SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE | Source of Refractive Measurements Sequence (0022,1134)
SOURCE_ORIENTATION | Source Orientation (4010,1060)
SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE | Source Patient Group Identification Sequence (0010,0026)
SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE | Source Pixel Planes Characteristics Sequence (3006,004A)
SOURCE_POSITION | Source Position (4010,1061)
SOURCE_PRESENTATION_ADDRESS | Source Presentation Address (0002,0026)
SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER | Source Reconstruction Protocol Element Number (0018,993A)
SOURCE_ROLL_ANGLE | Source Roll Angle (300A,067A)
SOURCE_SEQUENCE | Source Sequence (300A,0210)
SOURCE_SERIAL_NUMBER | Source Serial Number (3008,0105)
SOURCE_START_DATE_TIME | Source Start Date Time (0018,9369)
SOURCE_STRENGTH | Source Strength (300A,022B)
SOURCE_STRENGTH_REFERENCE_DATE | Source Strength Reference Date (300A,022C)
SOURCE_STRENGTH_REFERENCE_TIME | Source Strength Reference Time (300A,022E)
SOURCE_STRENGTH_UNIT | Alias for tag SOURCE_STRENGTH_UNITS (300A,0229)
SOURCE_STRENGTH_UNITS | Source Strength Units (300A,0229)
SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE | Source to Applicator Mounting Position Distance (300A,0436)
SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE | Source to Beam Limiting Device Distance (300A,00BA)
SOURCE_TO_BLOCK_TRAY_DISTANCE | Source to Block Tray Distance (300A,00F6)
SOURCE_TO_COMPENSATOR_DISTANCE | Source to Compensator Distance (300A,02E2)
SOURCE_TO_COMPENSATOR_TRAY_DISTANCE | Source to Compensator Tray Distance (300A,00E6)
SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Source to External Contour Distance (300A,0132)
SOURCE_TO_GENERAL_ACCESSORY_DISTANCE | Source to General Accessory Distance (300A,0425)
SOURCE_TO_PATIENT_SURFACE_DISTANCE | Source to Patient Surface Distance (300A,0634)
SOURCE_TO_REFERENCE_OBJECT_DISTANCE | Source to Reference Object Distance (3002,0028)
SOURCE_TO_SURFACE_DISTANCE | Source to Surface Distance (300A,0130)
SOURCE_TO_WEDGE_TRAY_DISTANCE | Source to Wedge Tray Distance (300A,00DA)
SOURCE_TYPE | Source Type (300A,0214)
SOURCE_WAVEFORM_SEQUENCE | Source Waveform Sequence (003A,020A)
SPACING_BETWEEN_SLICES | Spacing Between Slices (0018,0088)
SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES | Spatial Frequency Response Column Names (0016,000C)
SPATIAL_FREQUENCY_RESPONSE_COLUMNS | Spatial Frequency Response Columns (0016,000B)
SPATIAL_FREQUENCY_RESPONSE_ROWS | Spatial Frequency Response Rows (0016,000A)
SPATIAL_FREQUENCY_RESPONSE_VALUES | Spatial Frequency Response Values (0016,000D)
SPATIAL_LOCATIONS_PRESERVED | Spatial Locations Preserved (0028,135A)
SPATIAL_PRE_SATURATION | Spatial Pre-saturation (0018,9027)
SPATIAL_RESOLUTION | Spatial Resolution (0018,1050)
SPATIAL_TRANSFORM_OF_DOSE | Spatial Transform of Dose (3004,0005)
SPECIAL_NEEDS | Special Needs (0038,0050)
SPECIFIC_ABSORPTION_RATE_DEFINITION | Specific Absorption Rate Definition (0018,9179)
SPECIFIC_ABSORPTION_RATE_SEQUENCE | Specific Absorption Rate Sequence (0018,9239)
SPECIFIC_ABSORPTION_RATE_VALUE | Specific Absorption Rate Value (0018,9181)
SPECIFIC_CHARACTER_SET | Specific Character Set (0008,0005)
SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE | Specific Character Set of File-set Descriptor File (0004,1142)
SPECIFICATION_SELECTION_GUIDANCE | Specification Selection Guidance (0082,0033)
SPECIFIED_CHANNEL_TOTAL_TIME | Specified Channel Total Time (3008,0132)
SPECIFIED_METERSET | Specified Meterset (3008,0042)
SPECIFIED_NUMBER_OF_PULSES | Specified Number of Pulses (3008,0136)
SPECIFIED_PRIMARY_METERSET | Specified Primary Meterset (3008,0032)
SPECIFIED_PULSE_REPETITION_INTERVAL | Specified Pulse Repetition Interval (3008,013A)
SPECIFIED_SECONDARY_METERSET | Specified Secondary Meterset (3008,0033)
SPECIFIED_TREATMENT_TIME | Specified Treatment Time (3008,003A)
SPECIMEN_ACCESSION_NUMBER_RETIRED | Specimen Accession Number RETIRED (0040,050A)
SPECIMEN_DESCRIPTION_SEQUENCE | Specimen Description Sequence (0040,0560)
SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED | Specimen Description Sequence (Trial) RETIRED (0040,0552)
SPECIMEN_DESCRIPTION_TRIAL_RETIRED | Specimen Description (Trial) RETIRED (0040,0553)
SPECIMEN_DETAILED_DESCRIPTION | Specimen Detailed Description (0040,0602)
SPECIMEN_IDENTIFIER | Specimen Identifier (0040,0551)
SPECIMEN_LABEL_IN_IMAGE | Specimen Label in Image (0048,0010)
SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE | Specimen Localization Content Item Sequence (0040,0620)
SPECIMEN_PREPARATION_SEQUENCE | Specimen Preparation Sequence (0040,0610)
SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE | Specimen Preparation Step Content Item Sequence (0040,0612)
SPECIMEN_REFERENCE_SEQUENCE | Specimen Reference Sequence (0048,0110)
SPECIMEN_SEQUENCE_RETIRED | Specimen Sequence RETIRED (0040,0550)
SPECIMEN_SHORT_DESCRIPTION | Specimen Short Description (0040,0600)
SPECIMEN_TYPE_CODE_SEQUENCE | Specimen Type Code Sequence (0040,059A)
SPECIMEN_UID | Specimen UID (0040,0554)
SPECTRAL_SENSITIVITY | Spectral Sensitivity (0016,0017)
SPECTRAL_WIDTH | Spectral Width (0018,9052)
SPECTRALLY_SELECTED_EXCITATION | Spectrally Selected Excitation (0018,9026)
SPECTRALLY_SELECTED_SUPPRESSION | Spectrally Selected Suppression (0018,9025)
SPECTROSCOPY_ACQUISITION_DATA_COLUMNS | Spectroscopy Acquisition Data Columns (0018,9127)
SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS | Spectroscopy Acquisition Out-of-plane Phase Steps (0018,9159)
SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS | Alias for tag SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS (0018,9159)
SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS | Spectroscopy Acquisition Phase Columns (0018,9234)
SPECTROSCOPY_ACQUISITION_PHASE_ROWS | Spectroscopy Acquisition Phase Rows (0018,9095)
SPECTROSCOPY_DATA | Spectroscopy Data (5600,0020)
SPECULAR_REFLECTION_INTENSITY | Specular Reflection Intensity (0070,1705)
SPHERE_POWER | Sphere Power (0046,0146)
SPHERICAL_LENS_POWER | Spherical Lens Power (0022,0007)
SPIRAL_PITCH_FACTOR | Spiral Pitch Factor (0018,9311)
SPOILING | Spoiling (0018,9016)
STACK_ID | Stack ID (0020,9056)
STAGE_CODE_SEQUENCE | Stage Code Sequence (0040,000A)
STAGE_NAME | Stage Name (0008,2120)
STAGE_NUMBER | Stage Number (0008,2122)
STANDARD_OUTPUT_SENSITIVITY | Standard Output Sensitivity (0016,001B)
START_ACQUISITION_DATETIME | Start Acquisition DateTime (0018,9516)
START_ANGLE | Start Angle (0054,0200)
START_CARDIAC_TRIGGER_COUNT_THRESHOLD | Start Cardiac Trigger Count Threshold (0018,9717)
START_CUMULATIVE_METERSET | Start Cumulative Meterset (3002,0106)
START_CUMULATIVE_METERSET_WEIGHT | Start Cumulative Meterset Weight (300C,0008)
START_CUMULATIVE_TIME_WEIGHT | Start Cumulative Time Weight (0074,1407)
START_DENSITY_THRESHOLD | Start Density Threshold (0018,9715)
START_METERSET | Start Meterset (3008,0078)
START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD | Start Relative Density Difference Threshold (0018,9716)
START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD | Start Respiratory Trigger Count Threshold (0018,9718)
START_TRIM | Start Trim (0008,2142)
STARTING_METERSET_VALUE_KNOWN_FLAG | Starting Meterset Value Known Flag (300A,0723)
STARTING_RESPIRATORY_AMPLITUDE | Starting Respiratory Amplitude (0020,9246)
STARTING_RESPIRATORY_PHASE | Starting Respiratory Phase (0020,9247)
STATION_AE_TITLE | Station AE Title (0008,0055)
STATION_NAME | Station Name (0008,1010)
STATUS | Status (0000,0900)
STEADY_STATE_PULSE_SEQUENCE | Steady State Pulse Sequence (0018,9017)
STEEP_CORNEAL_AXIS_SEQUENCE | Steep Corneal Axis Sequence (0046,0112)
STEEP_KERATOMETRIC_AXIS_SEQUENCE | Steep Keratometric Axis Sequence (0046,0074)
STEERING_ANGLE | Steering Angle (0018,6036)
STEREO_BASELINE_ANGLE | Stereo Baseline Angle (0022,0010)
STEREO_BASELINE_DISPLACEMENT | Stereo Baseline Displacement (0022,0011)
STEREO_HORIZONTAL_PIXEL_OFFSET | Stereo Horizontal Pixel Offset (0022,0012)
STEREO_PAIRS_PRESENT | Stereo Pairs Present (0022,0028)
STEREO_PAIRS_SEQUENCE | Stereo Pairs Sequence (0022,0020)
STEREO_ROTATION | Stereo Rotation (0022,0014)
STEREO_VERTICAL_PIXEL_OFFSET | Stereo Vertical Pixel Offset (0022,0013)
STIMULI_RETESTING_QUANTITY | Stimuli Retesting Quantity (0024,0042)
STIMULUS_AREA | Stimulus Area (0024,0025)
STIMULUS_COLOR_CODE_SEQUENCE | Stimulus Color Code Sequence (0024,0021)
STIMULUS_PRESENTATION_TIME | Stimulus Presentation Time (0024,0028)
STIMULUS_RESULTS | Stimulus Results (0024,0093)
STOP_CUMULATIVE_METERSET | Stop Cumulative Meterset (3002,0107)
STOP_TRIM | Stop Trim (0008,2143)
STORAGE_MEDIA_FILE_SET_ID | Storage Media File-set ID (0088,0130)
STORAGE_MEDIA_FILE_SET_UID | Storage Media File-set UID (0088,0140)
STORAGE_PROTOCOL_ELEMENT_SEQUENCE | Storage Protocol Element Sequence (0018,9936)
STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Storage Protocol Element Specification Sequence (0018,9935)
STORAGE_URL | Storage URL (0040,4073)
STORED_INSTANCE_BASE_URI | Stored Instance Base URI (0008,0407)
STORED_INSTANCE_TRANSFER_SYNTAX_UID | Stored Instance Transfer Syntax UID (0008,040E)
STORED_VALUE_COLOR_RANGE_SEQUENCE | Stored Value Color Range Sequence (0028,1230)
STOW_RS_STORAGE_SEQUENCE | STOW-RS Storage Sequence (0040,4072)
STRAIN_ADDITIONAL_INFORMATION | Strain Additional Information (0010,0218)
STRAIN_CODE_SEQUENCE | Strain Code Sequence (0010,0219)
STRAIN_DESCRIPTION | Strain Description (0010,0212)
STRAIN_NOMENCLATURE | Strain Nomenclature (0010,0213)
STRAIN_SOURCE | Strain Source (0010,0217)
STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE | Strain Source Registry Code Sequence (0010,0215)
STRAIN_STOCK_NUMBER | Strain Stock Number (0010,0214)
STRAIN_STOCK_SEQUENCE | Strain Stock Sequence (0010,0216)
STRUCTURE_SET_DATE | Structure Set Date (3006,0008)
STRUCTURE_SET_DESCRIPTION | Structure Set Description (3006,0006)
STRUCTURE_SET_LABEL | Structure Set Label (3006,0002)
STRUCTURE_SET_NAME | Structure Set Name (3006,0004)
STRUCTURE_SET_ROI_SEQUENCE | Structure Set ROI Sequence (3006,0020)
STRUCTURE_SET_TIME | Structure Set Time (3006,0009)
STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE | Structured Constraint Observation Sequence (0082,000C)
STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE | Structured Display Background CIELab Value (0072,0420)
STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE | Structured Display Image Box Sequence (0072,0422)
STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE | Structured Display Text Box Sequence (0072,0424)
STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE | Studies Containing Other Referenced Instances Sequence (0008,1200)
STUDY_ACCESS_END_POINTS_SEQUENCE | Study Access End Points Sequence (0008,0421)
STUDY_ARRIVAL_DATE_RETIRED | Study Arrival Date RETIRED (0032,1040)
STUDY_ARRIVAL_TIME_RETIRED | Study Arrival Time RETIRED (0032,1041)
STUDY_COMMENTS_RETIRED | Study Comments RETIRED (0032,4000)
STUDY_COMPLETION_DATE_RETIRED | Study Completion Date RETIRED (0032,1050)
STUDY_COMPLETION_TIME_RETIRED | Study Completion Time RETIRED (0032,1051)
STUDY_COMPONENT_STATUS_ID_RETIRED | Study Component Status ID RETIRED (0032,1055)
STUDY_DATE | Study Date (0008,0020)
STUDY_DESCRIPTION | Study Description (0008,1030)
STUDY_ID | Study ID (0020,0010)
STUDY_ID_ISSUER_RETIRED | Study ID Issuer RETIRED (0032,0012)
STUDY_INSTANCE_UID | Study Instance UID (0020,000D)
STUDY_PRIORITY_ID_RETIRED | Study Priority ID RETIRED (0032,000C)
STUDY_READ_DATE_RETIRED | Study Read Date RETIRED (0032,0034)
STUDY_READ_TIME_RETIRED | Study Read Time RETIRED (0032,0035)
STUDY_STATUS_ID_RETIRED | Study Status ID RETIRED (0032,000A)
STUDY_TIME | Study Time (0008,0030)
STUDY_UPDATE_DATETIME | Study Update DateTime (0008,041F)
STUDY_VERIFIED_DATE_RETIRED | Study Verified Date RETIRED (0032,0032)
STUDY_VERIFIED_TIME_RETIRED | Study Verified Time RETIRED (0032,0033)
SUBJECT_AREA | Subject Area (0016,002A)
SUBJECT_DISTANCE | Subject Distance (0016,0026)
SUBJECT_DISTANCE_RANGE | Subject Distance Range (0016,004C)
SUBJECT_LOCATION | Subject Location (0016,0037)
SUBJECT_RELATIVE_POSITION_IN_IMAGE | Subject Relative Position in Image (0010,0028)
SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE | Subjective Refraction Left Eye Sequence (0046,0098)
SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE | Subjective Refraction Right Eye Sequence (0046,0097)
SUBSCRIPTION_LIST_STATUS | Subscription List Status (0074,1244)
SUBSTANCE_ADMINISTRATION_APPROVAL | Substance Administration Approval (0044,0002)
SUBSTANCE_ADMINISTRATION_DATETIME | Substance Administration DateTime (0044,0010)
SUBSTANCE_ADMINISTRATION_DEVICE_ID | Substance Administration Device ID (0044,0012)
SUBSTANCE_ADMINISTRATION_NOTES | Substance Administration Notes (0044,0011)
SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE | Substance Administration Parameter Sequence (0044,0019)
SUBTASK_WORKITEM_CODE_SEQUENCE | Subtask Workitem Code Sequence (3002,011B)
SUBTRACTION_ITEM_ID | Subtraction Item ID (0028,9416)
SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE | Summarized Filter Lookup Table Sequence (003A,0320)
SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE | Supported Image Display Formats Sequence (2000,00A8)
SURFACE_ASYMMETRY_INDEX | Surface Asymmetry Index (0046,0232)
SURFACE_COMMENTS | Surface Comments (0066,0004)
SURFACE_COUNT | Surface Count (0066,002A)
SURFACE_ENTRY_POINT | Surface Entry Point (300A,012E)
SURFACE_MESH_PRIMITIVES_SEQUENCE | Surface Mesh Primitives Sequence (0066,0013)
SURFACE_MESH_Z_PIXEL_OFFSET | Surface Mesh Z-Pixel Offset (0022,1658)
SURFACE_MODEL_DESCRIPTION_SEQUENCE | Surface Model Description Sequence (0068,6360)
SURFACE_MODEL_LABEL | Surface Model Label (0068,6380)
SURFACE_MODEL_SCALING_FACTOR | Surface Model Scaling Factor (0068,6390)
SURFACE_NUMBER | Surface Number (0066,0003)
SURFACE_POINT_COLOR_CIELAB_VALUE_DATA | Surface Point Color CIELab Value Data (0080,0007)
SURFACE_POINT_PRESENTATION_VALUE_DATA | Surface Point Presentation Value Data (0080,0006)
SURFACE_POINTS_NORMALS_SEQUENCE | Surface Points Normals Sequence (0066,0012)
SURFACE_POINTS_SEQUENCE | Surface Points Sequence (0066,0011)
SURFACE_PROCESSING | Surface Processing (0066,0009)
SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE | Surface Processing Algorithm Identification Sequence (0066,0035)
SURFACE_PROCESSING_DESCRIPTION | Surface Processing Description (0066,000B)
SURFACE_PROCESSING_RATIO | Surface Processing Ratio (0066,000A)
SURFACE_REGULARITY_INDEX | Surface Regularity Index (0046,0230)
SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE | Surface Scan Acquisition Type Code Sequence (0080,0001)
SURFACE_SCAN_MODE_CODE_SEQUENCE | Surface Scan Mode Code Sequence (0080,0002)
SURFACE_SEQUENCE | Surface Sequence (0066,0002)
SURGICAL_TECHNIQUE | Surgical Technique (0076,0030)
SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE | Surgically Induced Astigmatism Sequence (0022,1045)
SUV_TYPE | SUV Type (0054,1006)
SWITCHING_PHASE_NOMINAL_DURATION | Switching Phase Nominal Duration (0018,936C)
SWITCHING_PHASE_NUMBER | Switching Phase Number (0018,936B)
SWITCHING_PHASE_TRANSITION_DURATION | Switching Phase Transition Duration (0018,936D)
SWIVEL_RANGE | Swivel Range (0070,1A06)
SYNCHRONIZATION_CHANNEL | Synchronization Channel (0018,106C)
SYNCHRONIZATION_FRAME_OF_REFERENCE_UID | Synchronization Frame of Reference UID (0020,0200)
SYNCHRONIZATION_TRIGGER | Synchronization Trigger (0018,106A)
SYNCHRONIZED_IMAGE_BOX_LIST | Synchronized Image Box List (0072,0432)
SYNCHRONIZED_SCROLLING_SEQUENCE | Synchronized Scrolling Sequence (0072,0210)
SYRINGE_COUNTS | Syringe Counts (0018,1045)
SYSTEM_STATUS | System Status (0028,7006)
SYSTEM_STATUS_COMMENT | System Status Comment (0028,7007)
T2_PREPARATION | T2 Preparation (0018,9021)
TABLE_ANGLE | Table Angle (0018,1138)
TABLE_COLUMN_DEFINITION_SEQUENCE | Table Column Definition Sequence (0040,A807)
TABLE_COLUMN_NUMBER | Table Column Number (0040,A805)
TABLE_CRADLE_TILT_ANGLE | Table Cradle Tilt Angle (0018,9471)
TABLE_FEED_PER_ROTATION | Table Feed per Rotation (0018,9310)
TABLE_FRAME_OF_REFERENCE_UID | Table Frame of Reference UID (0020,9313)
TABLE_HEAD_TILT_ANGLE | Table Head Tilt Angle (0018,9470)
TABLE_HEIGHT | Table Height (0018,1130)
TABLE_HORIZONTAL_ROTATION_ANGLE | Table Horizontal Rotation Angle (0018,9469)
TABLE_LATERAL_INCREMENT | Table Lateral Increment (0018,1136)
TABLE_LONGITUDINAL_INCREMENT | Table Longitudinal Increment (0018,1137)
TABLE_MOTION | Table Motion (0018,1134)
TABLE_OF_PARAMETER_VALUES | Table of Parameter Values (0018,605A)
TABLE_OF_PIXEL_VALUES | Table of Pixel Values (0018,6058)
TABLE_OF_X_BREAK_POINTS | Table of X Break Points (0018,6052)
TABLE_OF_Y_BREAK_POINTS | Table of Y Break Points (0018,6054)
TABLE_POSITION | Table Position (0018,9327)
TABLE_POSITION_SEQUENCE | Table Position Sequence (0018,9406)
TABLE_ROW_DEFINITION_SEQUENCE | Table Row Definition Sequence (0040,A806)
TABLE_ROW_NUMBER | Table Row Number (0040,A804)
TABLE_SPEED | Table Speed (0018,9309)
TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE | Table Top Eccentric Adjusted Angle (0074,102B)
TABLE_TOP_ECCENTRIC_ANGLE | Table Top Eccentric Angle (300A,0125)
TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE | Table Top Eccentric Angle Tolerance (300A,004E)
TABLE_TOP_ECCENTRIC_AXIS_DISTANCE | Table Top Eccentric Axis Distance (300A,0124)
TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION | Table Top Eccentric Rotation Direction (300A,0126)
TABLE_TOP_LATERAL_ADJUSTED_POSITION | Table Top Lateral Adjusted Position (0074,1028)
TABLE_TOP_LATERAL_POSITION | Table Top Lateral Position (300A,012A)
TABLE_TOP_LATERAL_POSITION_TOLERANCE | Table Top Lateral Position Tolerance (300A,0053)
TABLE_TOP_LATERAL_SETUP_DISPLACEMENT | Table Top Lateral Setup Displacement (300A,01D6)
TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION | Table Top Longitudinal Adjusted Position (0074,1027)
TABLE_TOP_LONGITUDINAL_POSITION | Table Top Longitudinal Position (300A,0129)
TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE | Table Top Longitudinal Position Tolerance (300A,0052)
TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT | Table Top Longitudinal Setup Displacement (300A,01D4)
TABLE_TOP_PITCH_ADJUSTED_ANGLE | Table Top Pitch Adjusted Angle (0074,102C)
TABLE_TOP_PITCH_ANGLE | Table Top Pitch Angle (300A,0140)
TABLE_TOP_PITCH_ANGLE_TOLERANCE | Table Top Pitch Angle Tolerance (300A,004F)
TABLE_TOP_PITCH_ROTATION_DIRECTION | Table Top Pitch Rotation Direction (300A,0142)
TABLE_TOP_ROLL_ADJUSTED_ANGLE | Table Top Roll Adjusted Angle (0074,102D)
TABLE_TOP_ROLL_ANGLE | Table Top Roll Angle (300A,0144)
TABLE_TOP_ROLL_ANGLE_TOLERANCE | Table Top Roll Angle Tolerance (300A,0050)
TABLE_TOP_ROLL_ROTATION_DIRECTION | Table Top Roll Rotation Direction (300A,0146)
TABLE_TOP_VERTICAL_ADJUSTED_POSITION | Table Top Vertical Adjusted Position (0074,1026)
TABLE_TOP_VERTICAL_POSITION | Table Top Vertical Position (300A,0128)
TABLE_TOP_VERTICAL_POSITION_TOLERANCE | Table Top Vertical Position Tolerance (300A,0051)
TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT | Table Top Vertical Setup Displacement (300A,01D2)
TABLE_TRAVERSE | Table Traverse (0018,1131)
TABLE_TYPE | Table Type (0018,113A)
TABLE_VERTICAL_INCREMENT | Table Vertical Increment (0018,1135)
TABLE_X_POSITION_TO_ISOCENTER | Table X Position to Isocenter (0018,9466)
TABLE_Y_POSITION_TO_ISOCENTER | Table Y Position to Isocenter (0018,9467)
TABLE_Z_POSITION_TO_ISOCENTER | Table Z Position to Isocenter (0018,9468)
TABULATED_VALUES_SEQUENCE | Tabulated Values Sequence (0040,A801)
TAG_2D_DEGREE_OF_FREEDOM_AXIS | 2D Degree of Freedom Axis (0068,64F0)
TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE | 2D Degree of Freedom Sequence (0068,6470)
TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES | 2D Implant Template Group Member Matching Axes (0078,00A0)
TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT | 2D Implant Template Group Member Matching Point (0078,0090)
TAG_2D_LINE_COORDINATES | 2D Line Coordinates (0068,65B0)
TAG_2D_LINE_COORDINATES_SEQUENCE | 2D Line Coordinates Sequence (0068,65A0)
TAG_2D_MATING_AXES | 2D Mating Axes (0068,6460)
TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE | 2D Mating Feature Coordinates Sequence (0068,6430)
TAG_2D_MATING_POINT | 2D Mating Point (0068,6450)
TAG_2D_PLANE_COORDINATES_SEQUENCE | 2D Plane Coordinates Sequence (0068,65E0)
TAG_2D_PLANE_INTERSECTION | 2D Plane Intersection (0068,65F0)
TAG_2D_POINT_COORDINATES | 2D Point Coordinates (0068,6560)
TAG_2D_POINT_COORDINATES_SEQUENCE | 2D Point Coordinates Sequence (0068,6550)
TAG_3D_DEGREE_OF_FREEDOM_AXIS | 3D Degree of Freedom Axis (0068,6490)
TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES | 3D Implant Template Group Member Matching Axes (0078,0060)
TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT | 3D Implant Template Group Member Matching Point (0078,0050)
TAG_3D_LINE_COORDINATES | 3D Line Coordinates (0068,65D0)
TAG_3D_MATING_AXES | 3D Mating Axes (0068,64D0)
TAG_3D_MATING_POINT | 3D Mating Point (0068,64C0)
TAG_3D_PLANE_NORMAL | 3D Plane Normal (0068,6620)
TAG_3D_PLANE_ORIGIN | 3D Plane Origin (0068,6610)
TAG_3D_POINT_COORDINATES | 3D Point Coordinates (0068,6590)
TAG_3D_RENDERING_TYPE | 3D Rendering Type (0072,0520)
TAG_ANGLE_FIRST_AXIS | Tag Angle First Axis (0018,9019)
TAG_ANGLE_SECOND_AXIS | Tag Angle Second Axis (0018,9219)
TAG_SPACING_FIRST_DIMENSION | Tag Spacing First Dimension (0018,9030)
TAG_SPACING_SECOND_DIMENSION | Tag Spacing Second Dimension (0018,9218)
TAG_THICKNESS | Tag Thickness (0018,9035)
TAGGING | Tagging (0018,9028)
TAGGING_DELAY | Tagging Delay (0018,9184)
TANGENTIAL_POWER | Tangential Power (0046,0250)
TARGET_EXPOSURE_INDEX | Target Exposure Index (0018,1412)
TARGET_FRAME_OF_REFERENCE_UID | Target Frame of Reference UID (0018,991E)
TARGET_LABEL | Target Label (0018,2045)
TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE | Target Luminance Characteristics Sequence (0028,7008)
TARGET_MAXIMUM_DOSE | Target Maximum Dose (300A,0027)
TARGET_MAXIMUM_LUMINANCE | Target Maximum Luminance (0028,701E)
TARGET_MINIMUM_DOSE | Target Minimum Dose (300A,0025)
TARGET_MINIMUM_LUMINANCE | Target Minimum Luminance (0028,701D)
TARGET_POSITION_REFERENCE_INDICATOR | Target Position Reference Indicator (0020,103F)
TARGET_PRESCIPTION_DOSE | Alias for tag TARGET_PRESCRIPTION_DOSE (300A,0026)
TARGET_PRESCRIPTION_DOSE | Target Prescription Dose (300A,0026)
TARGET_REFRACTION | Target Refraction (0022,1037)
TARGET_UID | Target UID (0018,2042)
TARGET_UNDERDOSE_VOLUME_FRACTION | Target Underdose Volume Fraction (300A,0028)
TDR_TYPE | TDR Type (4010,1027)
TELEPHONE_NUMBER_TRIAL_RETIRED | Telephone Number (Trial) RETIRED (0040,A354)
TELETHERAPY_RADIATION_TYPE | Teletherapy Radiation Type (3010,0047)
TEMPERATURE | Temperature (0016,0030)
TEMPLATE_EXTENSION_CREATOR_UID_RETIRED | Template Extension Creator UID RETIRED (0040,DB0D)
TEMPLATE_EXTENSION_FLAG_RETIRED | Template Extension Flag RETIRED (0040,DB0B)
TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED | Template Extension Organization UID RETIRED (0040,DB0C)
TEMPLATE_IDENTIFIER | Template Identifier (0040,DB00)
TEMPLATE_LOCAL_VERSION_RETIRED | Template Local Version RETIRED (0040,DB07)
TEMPLATE_NAME | Template Name (300A,0244)
TEMPLATE_NUMBER | Template Number (300A,0240)
TEMPLATE_TYPE | Template Type (300A,0242)
TEMPLATE_VERSION_RETIRED | Template Version RETIRED (0040,DB06)
TEMPORAL_POSITION_IDENTIFIER | Temporal Position Identifier (0020,0100)
TEMPORAL_POSITION_INDEX | Temporal Position Index (0020,9128)
TEMPORAL_POSITION_SEQUENCE | Temporal Position Sequence (0020,9310)
TEMPORAL_POSITION_TIME_OFFSET | Temporal Position Time Offset (0020,930D)
TEMPORAL_RANGE_TYPE | Temporal Range Type (0040,A130)
TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR | Temporal Relationship Interval Anchor (3010,004F)
TEMPORAL_RESOLUTION | Temporal Resolution (0020,0110)
TERMINAL_TYPE_RETIRED | Terminal Type RETIRED (0000,4010)
TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD | Termination Cardiac Trigger Count Threshold (0018,9723)
TERMINATION_COUNTS_THRESHOLD | Termination Counts Threshold (0018,9719)
TERMINATION_DENSITY_THRESHOLD | Termination Density Threshold (0018,9720)
TERMINATION_RELATIVE_DENSITY_THRESHOLD | Termination Relative Density Threshold (0018,9721)
TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD | Termination Respiratory Trigger Count Threshold (0018,9724)
TERMINATION_TIME_THRESHOLD | Termination Time Threshold (0018,9722)
TEST_IMAGE_VALIDATION | Test Image Validation (0028,702B)
TEST_PATTERN_CODE_SEQUENCE | Test Pattern Code Sequence (0028,702C)
TEST_POINT_NORMALS_DATA_FLAG | Test Point Normals Data Flag (0024,0057)
TEST_POINT_NORMALS_SEQUENCE | Test Point Normals Sequence (0024,0058)
TEST_RESULT | Test Result (0028,7029)
TEST_RESULT_COMMENT | Test Result Comment (0028,702A)
TEXT_COLOR_CIELAB_VALUE | Text Color CIELab Value (0070,0241)
TEXT_COMMENTS_RETIRED | Text Comments RETIRED (4000,4000)
TEXT_FORMAT_ID_RETIRED | Text Format ID RETIRED (0000,5130)
TEXT_OBJECT_SEQUENCE | Text Object Sequence (0070,0008)
TEXT_STRING | Text String (2030,0020)
TEXT_STYLE_SEQUENCE | Text Style Sequence (0070,0231)
TEXT_VALUE | Text Value (0040,A160)
TEXTURE_LABEL | Texture Label (0080,0009)
THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE | Therapeutic Role Category Code Sequence (3010,0064)
THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE | Therapeutic Role Type Code Sequence (3010,0065)
THERAPY_DESCRIPTION_RETIRED | Therapy Description RETIRED (0018,0039)
THERAPY_TYPE_RETIRED | Therapy Type RETIRED (0018,0037)
THREAT_CATEGORY | Threat Category (4010,1012)
THREAT_CATEGORY_DESCRIPTION | Threat Category Description (4010,1013)
THREAT_DETECTION_ALGORITHM_AND_VERSION | Threat Detection Algorithm and Version (4010,1029)
THREAT_ROI_BASE | Threat ROI Base (4010,1004)
THREAT_ROI_BITMAP | Threat ROI Bitmap (4010,1006)
THREAT_ROI_EXTENTS | Threat ROI Extents (4010,1005)
THREAT_ROI_VOXEL_SEQUENCE | Threat ROI Voxel Sequence (4010,1001)
THREAT_SEQUENCE | Threat Sequence (4010,1011)
THRESHOLD_DENSITY_RETIRED | Threshold Density RETIRED (2040,0100)
THRESHOLD_SEQUENCE | Threshold Sequence (0070,1B11)
THRESHOLD_TYPE | Threshold Type (0070,1B13)
THRESHOLD_VALUE | Threshold Value (0070,1B14)
THRESHOLD_VALUE_SEQUENCE | Threshold Value Sequence (0070,1B12)
TICK_ALIGNMENT | Tick Alignment (0070,0274)
TICK_LABEL | Tick Label (0070,0289)
TICK_LABEL_ALIGNMENT | Tick Label Alignment (0070,0279)
TICK_POSITION | Tick Position (0070,0288)
TID_OFFSET | TID Offset (0028,6120)
TIME | Time (0040,A122)
TIME_BASED_IMAGE_SETS_SEQUENCE | Time Based Image Sets Sequence (0072,0030)
TIME_DISTRIBUTION_PROTOCOL | Time Distribution Protocol (0018,1802)
TIME_DOMAIN_FILTERING | Time Domain Filtering (0018,9065)
TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED | Time of Document Creation or Verbal Transaction (Trial) RETIRED (0040,A112)
TIME_OF_FLIGHT_CONTRAST | Time of Flight Contrast (0018,9015)
TIME_OF_FLIGHT_INFORMATION_USED | Time of Flight Information Used (0018,9755)
TIME_OF_FRAME_GROUP_SEQUENCE | Time of Frame Group Sequence (0034,000D)
TIME_OF_GAIN_CALIBRATION | Time of Gain Calibration (0014,3077)
TIME_OF_LAST_CALIBRATION | Time of Last Calibration (0018,1201)
TIME_OF_LAST_DETECTOR_CALIBRATION | Time of Last Detector Calibration (0018,700E)
TIME_OF_SECONDARY_CAPTURE | Time of Secondary Capture (0018,1014)
TIME_RANGE | Time Range (0008,1163)
TIME_SERIES_BLENDING | Time Series Blending (0070,1B07)
TIME_SLICE_VECTOR | Time Slice Vector (0054,0100)
TIME_SLOT_INFORMATION_SEQUENCE | Time Slot Information Sequence (0054,0072)
TIME_SLOT_NUMBER_RETIRED | Time Slot Number RETIRED (0020,0017)
TIME_SLOT_TIME | Time Slot Time (0054,0073)
TIME_SLOT_VECTOR | Time Slot Vector (0054,0070)
TIME_SOURCE | Time Source (0018,1801)
TIMEZONE_OFFSET_FROM_UTC | Timezone Offset From UTC (0008,0201)
TIP_TYPE | TIP Type (4010,1039)
TISSUE_HETEROGENEITY_CORRECTION | Tissue Heterogeneity Correction (3004,0014)
TM_LINE_POSITION_X0 | TM-Line Position X0 (0018,603D)
TM_LINE_POSITION_X0_RETIRED | TM-Line Position X0 (Retired) (0018,603C)
TM_LINE_POSITION_X1 | TM-Line Position X1 (0018,6041)
TM_LINE_POSITION_X1_RETIRED | TM-Line Position X1 (Retired) (0018,6040)
TM_LINE_POSITION_Y0 | TM-Line Position Y0 (0018,603F)
TM_LINE_POSITION_Y0_RETIRED | TM-Line Position Y0 (Retired) (0018,603E)
TM_LINE_POSITION_Y1 | TM-Line Position Y1 (0018,6043)
TM_LINE_POSITION_Y1_RETIRED | TM-Line Position Y1 (Retired) (0018,6042)
TOLERANCE_TABLE_LABEL | Tolerance Table Label (300A,0043)
TOLERANCE_TABLE_NUMBER | Tolerance Table Number (300A,0042)
TOLERANCE_TABLE_SEQUENCE | Tolerance Table Sequence (300A,0040)
TOLERANCE_VALUE | Tolerance Value (300A,062C)
TOMO_ANGLE | Tomo Angle (0018,1470)
TOMO_CLASS | Tomo Class (0018,1491)
TOMO_LAYER_HEIGHT | Tomo Layer Height (0018,1460)
TOMO_TIME | Tomo Time (0018,1480)
TOMO_TYPE | Tomo Type (0018,1490)
TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE | Tomotherapeutic Control Point Sequence (3010,0098)
TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS | Tomotherapeutic Leaf Initial Closed Durations (3010,009A)
TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS | Tomotherapeutic Leaf Open Durations (3010,0099)
TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED | Top Left Hand Corner of Localizer Area RETIRED (0048,0201)
TOPIC_AUTHOR_RETIRED | Topic Author RETIRED (0088,0910)
TOPIC_KEYWORDS_RETIRED | Topic Keywords RETIRED (0088,0912)
TOPIC_SUBJECT_RETIRED | Topic Subject RETIRED (0088,0906)
TOPIC_TITLE_RETIRED | Topic Title RETIRED (0088,0904)
TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE | Toric IOL Power for Exact Emmetropia Sequence (0022,104A)
TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE | Toric IOL Power for Exact Target Refraction Sequence (0022,104B)
TORIC_IOL_POWER_SEQUENCE | Toric IOL Power Sequence (0022,1047)
TOTAL_BLOCK_TRAY_FACTOR | Total Block Tray Factor (300A,00F2)
TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS | Total Block Tray Water-Equivalent Thickness (300A,00F3)
TOTAL_COLLIMATION_WIDTH | Total Collimation Width (0018,9307)
TOTAL_COMPENSATOR_TRAY_FACTOR | Total Compensator Tray Factor (300A,00E2)
TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS | Total Compensator Tray Water-Equivalent Thickness (300A,02E3)
TOTAL_GAIN_RETIRED | Total Gain RETIRED (0018,5040)
TOTAL_NUMBER_OF_EXPOSURES_RETIRED | Total Number of Exposures RETIRED (0040,0301)
TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED | Total Number of Pieces of Media Created (2200,000B)
TOTAL_NUMBER_OF_STUDY_RECORDS | Total Number of Study Records (0008,0428)
TOTAL_PIXEL_MATRIX_COLUMNS | Total Pixel Matrix Columns (0048,0006)
TOTAL_PIXEL_MATRIX_FOCAL_PLANES | Total Pixel Matrix Focal Planes (0048,0303)
TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE | Total Pixel Matrix Origin Sequence (0048,0008)
TOTAL_PIXEL_MATRIX_ROWS | Total Pixel Matrix Rows (0048,0007)
TOTAL_PRESCRIPTION_DOSE | Total Prescription Dose (300C,0115)
TOTAL_PROCESSING_TIME | Total Processing Time (4010,1069)
TOTAL_REFERENCE_AIR_KERMA | Total Reference Air Kerma (300A,0250)
TOTAL_TIME_OF_FLUOROSCOPY_RETIRED | Total Time of Fluoroscopy RETIRED (0040,0300)
TOTAL_TIME_RETIRED | Total Time RETIRED (5000,200A)
TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS | Total Wedge Tray Water-Equivalent Thickness (300A,00D7)
TRACK_POINT_INDEX_LIST | Track Point Index List (0066,0129)
TRACK_SEQUENCE | Track Sequence (0066,0102)
TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE | Track Set Anatomical Type Code Sequence (0066,0108)
TRACK_SET_DESCRIPTION | Track Set Description (0066,0107)
TRACK_SET_LABEL | Track Set Label (0066,0106)
TRACK_SET_NUMBER | Track Set Number (0066,0105)
TRACK_SET_SEQUENCE | Track Set Sequence (0066,0101)
TRACK_SET_STATISTICS_SEQUENCE | Track Set Statistics Sequence (0066,0124)
TRACK_STATISTICS_SEQUENCE | Track Statistics Sequence (0066,0130)
TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE | Tracking Algorithm Identification Sequence (0066,0104)
TRACKING_ID | Tracking ID (0062,0020)
TRACKING_UID | Tracking UID (0062,0021)
TRANSACTION_STATUS | Transaction Status (0008,0417)
TRANSACTION_STATUS_COMMENT | Transaction Status Comment (0008,0418)
TRANSACTION_UID | Transaction UID (0008,1195)
TRANSDUCER_APPLICATION_CODE_SEQUENCE | Transducer Application Code Sequence (0018,980F)
TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE | Transducer Beam Steering Code Sequence (0018,980E)
TRANSDUCER_DATA | Transducer Data (0018,5010)
TRANSDUCER_FREQUENCY | Transducer Frequency (0018,6030)
TRANSDUCER_GEOMETRY_CODE_SEQUENCE | Transducer Geometry Code Sequence (0018,980D)
TRANSDUCER_IDENTIFICATION_SEQUENCE | Transducer Identification Sequence (0018,5011)
TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED | Transducer Orientation Modifier Sequence RETIRED (0008,2246)
TRANSDUCER_ORIENTATION_RETIRED | Transducer Orientation RETIRED (0008,2204)
TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED | Transducer Orientation Sequence RETIRED (0008,2244)
TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED | Transducer Position Modifier Sequence RETIRED (0008,2242)
TRANSDUCER_POSITION_RETIRED | Transducer Position RETIRED (0008,2200)
TRANSDUCER_POSITION_SEQUENCE_RETIRED | Transducer Position Sequence RETIRED (0008,2240)
TRANSDUCER_RESPONSE_SEQUENCE | Transducer Response Sequence (0018,982C)
TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE | Transducer Scan Pattern Code Sequence (0018,9809)
TRANSDUCER_TECHNOLOGY_SEQUENCE | Transducer Technology Sequence (0018,9831)
TRANSDUCER_TYPE | Transducer Type (0018,6031)
TRANSFER_SYNTAX_UID | Transfer Syntax UID (0002,0010)
TRANSFER_TUBE_LENGTH | Transfer Tube Length (300A,02A4)
TRANSFER_TUBE_NUMBER | Transfer Tube Number (300A,02A2)
TRANSFORM_DESCRIPTION | Transform Description (0014,2222)
TRANSFORM_NUMBER_OF_AXES | Transform Number of Axes (0014,2224)
TRANSFORM_ORDER_OF_AXES | Transform Order of Axes (0014,2226)
TRANSFORMATION_ALGORITHM_SEQUENCE | Transformation Algorithm Sequence (0022,1513)
TRANSFORMATION_METHOD_CODE_SEQUENCE | Transformation Method Code Sequence (0022,1512)
TRANSFORMED_AXIS_UNITS | Transformed Axis Units (0014,2228)
TRANSMIT_COIL_MANUFACTURER_NAME | Transmit Coil Manufacturer Name (0018,9050)
TRANSMIT_COIL_NAME | Transmit Coil Name (0018,1251)
TRANSMIT_COIL_TYPE | Transmit Coil Type (0018,9051)
TRANSMIT_TRANSDUCER_SEQUENCE | Transmit Transducer Sequence (0014,4010)
TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE | Transmit Transducer Settings Sequence (0014,4050)
TRANSMITTER_FREQUENCY | Transmitter Frequency (0018,9098)
TRANSMITTING_COIL | Alias for tag TRANSMIT_COIL_NAME (0018,1251)
TRANSPORT_CLASSIFICATION | Transport Classification (4010,1067)
TRANSVERSE_DETECTOR_SEPARATION | Transverse Detector Separation (0018,9726)
TRANSVERSE_MASH | Transverse Mash (0054,1202)
TRAY_ACCESSORY_CODE | Tray Accessory Code (300A,0355)
TREATMENT_CONTROL_POINT_DATE | Treatment Control Point Date (3008,0024)
TREATMENT_CONTROL_POINT_TIME | Treatment Control Point Time (3008,0025)
TREATMENT_DATE | Treatment Date (3008,0250)
TREATMENT_DELIVERY_CONTINUATION_FLAG | Treatment Delivery Continuation Flag (300A,0708)
TREATMENT_DELIVERY_TYPE | Treatment Delivery Type (300A,00CE)
TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE | Treatment Device Identification Sequence (300A,063A)
TREATMENT_MACHINE_NAME | Treatment Machine Name (300A,00B2)
TREATMENT_MACHINE_SEQUENCE | Treatment Machine Sequence (300A,0206)
TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE | Treatment Machine Special Mode Code Sequence (300A,0635)
TREATMENT_POSITION_GROUP_LABEL | Treatment Position Group Label (300A,0608)
TREATMENT_POSITION_GROUP_SEQUENCE | Treatment Position Group Sequence (300A,060A)
TREATMENT_POSITION_GROUP_UID | Treatment Position Group UID (300A,0609)
TREATMENT_POSITION_INDEX | Treatment Position Index (300A,0606)
TREATMENT_POSITION_SEQUENCE | Treatment Position Sequence (300A,063F)
TREATMENT_PROTOCOLS | Treatment Protocols (300A,0009)
TREATMENT_RECORD_CONTENT_ORIGIN | Treatment Record Content Origin (300A,0709)
TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE | Treatment Session Application Setup Sequence (3008,0110)
TREATMENT_SESSION_BEAM_SEQUENCE | Treatment Session Beam Sequence (3008,0020)
TREATMENT_SESSION_ION_BEAM_SEQUENCE | Treatment Session Ion Beam Sequence (3008,0021)
TREATMENT_SESSION_UID | Treatment Session UID (300A,0700)
TREATMENT_SITE | Treatment Site (3010,0077)
TREATMENT_SITE_CODE_SEQUENCE | Treatment Site Code Sequence (3010,0078)
TREATMENT_SITE_MODIFIER_CODE_SEQUENCE | Treatment Site Modifier Code Sequence (3010,0089)
TREATMENT_SITES_RETIRED | Treatment Sites RETIRED (300A,000B)
TREATMENT_STATUS_COMMENT | Treatment Status Comment (3008,0202)
TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE | Treatment Summary Calculated Dose Reference Sequence (3008,0050)
TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE | Treatment Summary Measured Dose Reference Sequence (3008,00E0)
TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE | Alias for tag TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE (3008,00E0)
TREATMENT_TECHNIQUE_NOTES | Treatment Technique Notes (3010,007A)
TREATMENT_TERMINATION_CODE | Alias for tag Treatment Termination Code RETIRED (3008,002B)
TREATMENT_TERMINATION_CODE_RETIRED | Treatment Termination Code RETIRED (3008,002B)
TREATMENT_TERMINATION_DESCRIPTION | Treatment Termination Description (300A,0730)
TREATMENT_TERMINATION_STATUS | Treatment Termination Status (3008,002A)
TREATMENT_TIME | Treatment Time (3008,0251)
TREATMENT_TIME_LIMIT | Treatment Time Limit (300A,062E)
TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE | Treatment Tolerance Violation Attribute Sequence (300A,0733)
TREATMENT_TOLERANCE_VIOLATION_CATEGORY | Treatment Tolerance Violation Category (300A,0732)
TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE | Treatment Tolerance Violation Cause Code Sequence (300A,0762)
TREATMENT_TOLERANCE_VIOLATION_DATETIME | Treatment Tolerance Violation DateTime (300A,0736)
TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION | Treatment Tolerance Violation Description (300A,0734)
TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION | Treatment Tolerance Violation Identification (300A,0735)
TREATMENT_TOLERANCE_VIOLATION_SEQUENCE | Treatment Tolerance Violation Sequence (300A,0731)
TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE | Treatment Tolerance Violation Type Code Sequence (300A,0761)
TREATMENT_VERIFICATION_STATUS | Treatment Verification Status (3008,002C)
TRIANGLE_FAN_SEQUENCE | Triangle Fan Sequence (0066,0027)
TRIANGLE_POINT_INDEX_LIST_RETIRED | Triangle Point Index List RETIRED (0066,0023)
TRIANGLE_STRIP_SEQUENCE | Triangle Strip Sequence (0066,0026)
TRIGGER_SAMPLE_POSITION | Trigger Sample Position (0018,106E)
TRIGGER_SOURCE_OR_TYPE | Trigger Source or Type (0018,1061)
TRIGGER_TIME | Trigger Time (0018,1060)
TRIGGER_TIME_OFFSET | Trigger Time Offset (0018,1069)
TRIGGER_VECTOR | Trigger Vector (0054,0210)
TRIGGER_WINDOW | Trigger Window (0018,1094)
TRIM | Trim (2010,0140)
TUBE_ANGLE | Tube Angle (0018,9303)
TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA | Two Dimensional to Three Dimensional Map Data (0022,1531)
TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE | Two Dimensional to Three Dimensional Map Sequence (0022,1518)
TYPE_OF_DATA_RETIRED | Type of Data RETIRED (5000,0020)
TYPE_OF_DETECTOR_MOTION | Type of Detector Motion (0054,0202)
TYPE_OF_FILTERS | Type of Filters (0018,1161)
TYPE_OF_INSTANCES | Type of Instances (0040,E020)
TYPE_OF_OPTICAL_CORRECTION | Type of Optical Correction (0022,1046)
TYPE_OF_PATIENT_ID | Type of Patient ID (0010,0022)
TYPE_OF_SYNCHRONIZATION | Type of Synchronization (0072,0434)
U_VALUE_DATA | U Value Data (0080,0010)
UDI_SEQUENCE | UDI Sequence (0018,100A)
UID | UID (0040,A124)
ULTRASOUND_ACQUISITION_GEOMETRY | Ultrasound Acquisition Geometry (0020,9307)
ULTRASOUND_COLOR_DATA_PRESENT | Ultrasound Color Data Present (0028,0014)
ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Ultrasound Ophthalmic Axial Length Measurements Sequence (0022,1220)
ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Ultrasound Selected Ophthalmic Axial Length Sequence (0022,1230)
UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE | Unassigned Per-Frame Converted Attributes Sequence (0020,9171)
UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE | Unassigned Shared Converted Attributes Sequence (0020,9170)
UNDERLINED | Underlined (0070,0248)
UNFORMATTED_TEXT_VALUE | Unformatted Text Value (0070,0006)
UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE | Alias for tag PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE (0074,1008)
UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Alias for tag PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0074,100E)
UNIFIED_PROCEDURE_STEP_LIST_STATUS | Unified Procedure Step List Status (0074,1246)
UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE | Unified Procedure Step Performed Procedure Sequence (0074,1216)
UNIFIED_PROCEDURE_STEP_PROGRESS | Alias for tag PROCEDURE_STEP_PROGRESS (0074,1004)
UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION | Alias for tag PROCEDURE_STEP_PROGRESS_DESCRIPTION (0074,1006)
UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE | Alias for tag PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)
UNIFIED_PROCEDURE_STEP_STATE | Alias for tag PROCEDURE_STEP_STATE (0074,1000)
UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED | Uniform Resource Locator (Trial) RETIRED (0040,A992)
UNIQUE_DEVICE_IDENTIFIER | Unique Device Identifier (0018,1009)
UNITS | Units (0054,1001)
UNIVERSAL_ENTITY_ID | Universal Entity ID (0040,0032)
UNIVERSAL_ENTITY_ID_TYPE | Universal Entity ID Type (0040,0033)
UNSPECIFIED_LATERALITY_LENS_SEQUENCE | Unspecified Laterality Lens Sequence (0046,0016)
UPDATED_METADATA_SEQUENCE | Updated Metadata Sequence (0008,041E)
UPPER_CUTOFF_FREQUENCY | Upper Cutoff Frequency (0018,9830)
UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES | Upper Limit Number Of Persistent Fluoroscopy Frames (0018,11B5)
UPPER_LOWER_PIXEL_VALUES_RETIRED | Upper/Lower Pixel Values RETIRED (0018,1240)
UPS_LIST_STATUS | Alias for tag UNIFIED_PROCEDURE_STEP_LIST_STATUS (0074,1246)
UPS_PERFORMED_PROCEDURE_SEQUENCE | Alias for tag UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE (0074,1216)
UPS_PROGRESS_INFORMATION_SEQUENCE | Alias for tag UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)
URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED | Urgency or Priority Alerts (Trial) RETIRED (0040,A057)
URI_WITHIN_ENCAPSULATED_DOCUMENT | URI Within Encapsulated Document (0068,7005)
URN_CODE_VALUE | URN Code Value (0008,0120)
US_IMAGE_DESCRIPTION_SEQUENCE | US Image Description Sequence (0018,9806)
USED_FIDUCIALS_SEQUENCE | Used Fiducials Sequence (0070,0314)
USED_RT_STRUCTURE_SET_ROI_SEQUENCE | Used RT Structure Set ROI Sequence (0070,0315)
USED_SEGMENTS_SEQUENCE | Used Segments Sequence (0062,0012)
USER_CONTENT_LABEL | User Content Label (3010,0033)
USER_CONTENT_LONG_LABEL | User Content Long Label (3010,0034)
UV_MAPPING_SEQUENCE | UV Mapping Sequence (0080,0008)
V_VALUE_DATA | V Value Data (0080,0011)
VALUE_TYPE | Value Type (0040,A040)
VARIABLE_FLIP_ANGLE_FLAG | Variable Flip Angle Flag (0018,1315)
VARIABLE_MODALITY_LUT_SEQUENCE | Variable Modality LUT Sequence (0028,3001)
VECTOR_ACCURACY | Vector Accuracy (0066,0020)
VECTOR_COORDINATE_DATA | Vector Coordinate Data (0066,0021)
VECTOR_DIMENSIONALITY | Vector Dimensionality (0066,001F)
VECTOR_GRID_DATA | Vector Grid Data (0064,0009)
VELOCITY_ENCODING_ACQUISITION_SEQUENCE | Velocity Encoding Acquisition Sequence (0018,9092)
VELOCITY_ENCODING_DIRECTION | Velocity Encoding Direction (0018,9090)
VELOCITY_ENCODING_MAXIMUM_VALUE | Velocity Encoding Maximum Value (0018,9217)
VELOCITY_ENCODING_MINIMUM_VALUE | Velocity Encoding Minimum Value (0018,9091)
VELOCITY_OF_SOUND | Velocity of Sound (0014,4064)
VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Verbal Source Identifier Code Sequence (Trial) RETIRED (0040,A358)
VERBAL_SOURCE_TRIAL_RETIRED | Verbal Source (Trial) RETIRED (0040,A352)
VERIFICATION_DATE_TIME | Alias for tag VERIFICATION_DATETIME (0040,A030)
VERIFICATION_DATETIME | Verification DateTime (0040,A030)
VERIFICATION_FLAG | Verification Flag (0040,A493)
VERIFICATION_IMAGE_TIMING | Verification Image Timing (0074,1032)
VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE | Verifying Observer Identification Code Sequence (0040,A088)
VERIFYING_OBSERVER_NAME | Verifying Observer Name (0040,A075)
VERIFYING_OBSERVER_SEQUENCE | Verifying Observer Sequence (0040,A073)
VERIFYING_ORGANIZATION | Verifying Organization (0040,A027)
VERTEX_POINT_INDEX_LIST_RETIRED | Vertex Point Index List RETIRED (0066,0025)
VERTICAL_ALIGNMENT | Vertical Alignment (0070,0243)
VERTICAL_OFFSET_OF_SENSOR | Vertical Offset of Sensor (0014,3026)
VERTICAL_PRISM_BASE | Vertical Prism Base (0046,0036)
VERTICAL_PRISM_POWER | Vertical Prism Power (0046,0034)
VERTICES_OF_THE_OUTLINE_OF_PUPIL | Vertices of the Outline of Pupil (0046,0208)
VERTICES_OF_THE_POLYGONAL_COLLIMATOR | Vertices of the Polygonal Collimator (0018,1720)
VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION | Vertices of the Polygonal Exposure Control Sensing Region (0018,9442)
VERTICES_OF_THE_POLYGONAL_OUTLINE | Vertices of the Polygonal Outline (0018,1638)
VERTICES_OF_THE_POLYGONAL_SHUTTER | Vertices of the Polygonal Shutter (0018,1620)
VERTICES_OF_THE_REGION | Vertices of the Region (0028,9503)
VIDEO_IMAGE_FORMAT_ACQUIRED | Video Image Format Acquired (0018,1022)
VIEW_CODE_SEQUENCE | View Code Sequence (0054,0220)
VIEW_MODIFIER_CODE_SEQUENCE | View Modifier Code Sequence (0054,0222)
VIEW_MODIFIER_SEQUENCE | Alias for tag VIEW_MODIFIER_CODE_SEQUENCE (0054,0222)
VIEW_NAME | View Name (0008,2127)
VIEW_NUMBER | View Number (0008,2128)
VIEW_ORIENTATION_CODE_SEQUENCE | View Orientation Code Sequence (0068,62E0)
VIEW_ORIENTATION_MODIFIER | Alias for tag VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE (0068,62F0)
VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE | View Orientation Modifier Code Sequence (0068,62F0)
VIEW_POSITION | View Position (0018,5101)
VIEWING_DISTANCE | Viewing Distance (0046,0106)
VIEWING_DISTANCE_TYPE | Viewing Distance Type (0046,0125)
VIEWPOINT_LOOKAT_POINT | Viewpoint LookAt Point (0070,1604)
VIEWPOINT_POSITION | Viewpoint Position (0070,1603)
VIEWPOINT_UP_DIRECTION | Viewpoint Up Direction (0070,1605)
VIRTUAL_SOURCE_AXIS_DISTANCES | Virtual Source-Axis Distances (300A,030A)
VISIT_COMMENTS | Visit Comments (0038,4000)
VISIT_STATUS_ID | Visit Status ID (0038,0008)
VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE | Visual Acuity Both Eyes Open Sequence (0046,0124)
VISUAL_ACUITY_LEFT_EYE_SEQUENCE | Visual Acuity Left Eye Sequence (0046,0123)
VISUAL_ACUITY_MEASUREMENT_SEQUENCE | Visual Acuity Measurement Sequence (0024,0110)
VISUAL_ACUITY_MODIFIERS | Visual Acuity Modifiers (0046,0135)
VISUAL_ACUITY_RIGHT_EYE_SEQUENCE | Visual Acuity Right Eye Sequence (0046,0122)
VISUAL_ACUITY_TYPE_CODE_SEQUENCE | Visual Acuity Type Code Sequence (0046,0121)
VISUAL_EVALUATION_METHOD_CODE_SEQUENCE | Visual Evaluation Method Code Sequence (0028,702E)
VISUAL_EVALUATION_RESULT_SEQUENCE | Visual Evaluation Result Sequence (0028,7015)
VISUAL_EVALUATION_TEST_SEQUENCE | Visual Evaluation Test Sequence (0028,7028)
VISUAL_FIELD_CATCH_TRIAL_SEQUENCE | Visual Field Catch Trial Sequence (0024,0034)
VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE | Visual Field Global Results Index Sequence (0024,0320)
VISUAL_FIELD_HORIZONTAL_EXTENT | Visual Field Horizontal Extent (0024,0010)
VISUAL_FIELD_MEAN_SENSITIVITY | Visual Field Mean Sensitivity (0024,0070)
VISUAL_FIELD_SHAPE | Visual Field Shape (0024,0012)
VISUAL_FIELD_TEST_DURATION | Visual Field Test Duration (0024,0088)
VISUAL_FIELD_TEST_NORMALS_FLAG | Visual Field Test Normals Flag (0024,0063)
VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE | Visual Field Test Point Normals Sequence (0024,0097)
VISUAL_FIELD_TEST_POINT_SEQUENCE | Visual Field Test Point Sequence (0024,0089)
VISUAL_FIELD_TEST_POINT_X_COORDINATE | Visual Field Test Point X-Coordinate (0024,0090)
VISUAL_FIELD_TEST_POINT_Y_COORDINATE | Visual Field Test Point Y-Coordinate (0024,0091)
VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE | Visual Field Test Reliability Global Index Sequence (0024,0317)
VISUAL_FIELD_VERTICAL_EXTENT | Visual Field Vertical Extent (0024,0011)
VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED | Vital Stain Code Sequence (Trial) RETIRED (0040,09F8)
VITREOUS_STATUS_CODE_SEQUENCE | Vitreous Status Code Sequence (0022,1025)
VITREOUS_STATUS_DESCRIPTION | Vitreous Status Description (0022,1066)
VOI_LUT_FUNCTION | VOI LUT Function (0028,1056)
VOI_LUT_SEQUENCE | VOI LUT Sequence (0028,3010)
VOI_TYPE | VOI Type (0072,0702)
VOLUME_BASED_CALCULATION_TECHNIQUE | Volume Based Calculation Technique (0008,9207)
VOLUME_CROPPING_METHOD | Volume Cropping Method (0070,1302)
VOLUME_CROPPING_SEQUENCE | Volume Cropping Sequence (0070,1301)
VOLUME_FRAME_OF_REFERENCE_UID | Volume Frame of Reference UID (0020,9312)
VOLUME_LOCALIZATION_SEQUENCE | Volume Localization Sequence (0018,9126)
VOLUME_LOCALIZATION_TECHNIQUE | Volume Localization Technique (0018,9054)
VOLUME_OF_PTO | Volume of PTO (4010,1023)
VOLUME_STREAM_SEQUENCE | Volume Stream Sequence (0070,1A08)
VOLUME_TO_TABLE_MAPPING_MATRIX | Volume to Table Mapping Matrix (0020,930A)
VOLUME_TO_TRANSDUCER_MAPPING_MATRIX | Volume to Transducer Mapping Matrix (0020,9309)
VOLUME_TO_TRANSDUCER_RELATIONSHIP | Volume to Transducer Relationship (0020,930B)
VOLUMETRIC_ANNOTATION_SEQUENCE | Volumetric Annotation Sequence (0070,1901)
VOLUMETRIC_CURVE_POINTS | Volumetric Curve Points (0070,150D)
VOLUMETRIC_CURVE_UP_DIRECTIONS | Volumetric Curve Up Directions (0070,1A07)
VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE | Volumetric Presentation Input Annotation Sequence (0070,1905)
VOLUMETRIC_PRESENTATION_INPUT_INDEX | Volumetric Presentation Input Index (0070,1804)
VOLUMETRIC_PRESENTATION_INPUT_NUMBER | Volumetric Presentation Input Number (0070,1207)
VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE | Volumetric Presentation Input Set Sequence (0070,120A)
VOLUMETRIC_PRESENTATION_INPUT_SET_UID | Volumetric Presentation Input Set UID (0070,1209)
VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE | Volumetric Presentation State Input Sequence (0070,1201)
VOLUMETRIC_PROPERTIES | Volumetric Properties (0008,9206)
WADO_RETRIEVAL_SEQUENCE | WADO Retrieval Sequence (0040,E023)
WADO_RS_RETRIEVAL_SEQUENCE | WADO-RS Retrieval Sequence (0040,E025)
WARNING_REASON | Warning Reason (0008,1196)
WATER_DEPTH | Water Depth (0016,0033)
WATER_EQUIVALENT_DIAMETER | Water Equivalent Diameter (0018,1271)
WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE | Water Equivalent Diameter Calculation Method Code Sequence (0018,1272)
WATER_REFERENCE_ACQUISITION | Water Reference Acquisition (0018,9297)
WATER_REFERENCED_PHASE_CORRECTION | Water Referenced Phase Correction (0018,9199)
WAVEFORM_AMPLIFIER_TYPE | Waveform Amplifier Type (003A,0317)
WAVEFORM_ANNOTATION_SEQUENCE | Waveform Annotation Sequence (0040,B020)
WAVEFORM_BITS_ALLOCATED | Waveform Bits Allocated (5400,1004)
WAVEFORM_BITS_STORED | Waveform Bits Stored (003A,021A)
WAVEFORM_CHANNEL_NUMBER | Waveform Channel Number (003A,0202)
WAVEFORM_DATA | Waveform Data (5400,1010)
WAVEFORM_DATA_DISPLAY_SCALE | Waveform Data Display Scale (003A,0230)
WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE | Waveform Display Background CIELab Value (003A,0231)
WAVEFORM_FILTER_DESCRIPTION | Waveform Filter Description (003A,0329)
WAVEFORM_FILTER_TYPE | Waveform Filter Type (003A,0322)
WAVEFORM_ORIGINALITY | Waveform Originality (003A,0004)
WAVEFORM_PADDING_VALUE | Waveform Padding Value (5400,100A)
WAVEFORM_PRESENTATION_GROUP_SEQUENCE | Waveform Presentation Group Sequence (003A,0240)
WAVEFORM_SAMPLE_INTERPRETATION | Waveform Sample Interpretation (5400,1006)
WAVEFORM_SEQUENCE | Waveform Sequence (5400,0100)
WEDGE_ANGLE | Wedge Angle (300A,00D5)
WEDGE_DEFINITION_SEQUENCE | Wedge Definition Sequence (300A,0651)
WEDGE_FACTOR | Wedge Factor (300A,00D6)
WEDGE_ID | Wedge ID (300A,00D4)
WEDGE_NUMBER | Wedge Number (300A,00D2)
WEDGE_ORIENTATION | Wedge Orientation (300A,00D8)
WEDGE_POSITION | Wedge Position (300A,0118)
WEDGE_POSITION_SEQUENCE | Wedge Position Sequence (300A,0116)
WEDGE_SEQUENCE | Wedge Sequence (300A,00D1)
WEDGE_THIN_EDGE_POSITION | Wedge Thin Edge Position (300A,00DB)
WEDGE_TYPE | Wedge Type (300A,00D3)
WEEKDAY_FRACTION_PATTERN_SEQUENCE | Weekday Fraction Pattern Sequence (3010,0087)
WEIGHTING_LOOKUP_TABLE_DATA | Weighting Lookup Table Data (0070,1808)
WEIGHTING_LOOKUP_TABLE_DESCRIPTOR | Weighting Lookup Table Descriptor (0070,1807)
WEIGHTING_TRANSFER_FUNCTION_SEQUENCE | Weighting Transfer Function Sequence (0070,1806)
WHITE_BALANCE | White Balance (0016,0043)
WHITE_POINT | White Point (0016,0001)
WHITE_POINT_FLAG | White Point Flag (0028,7021)
WHOLE_BODY_TECHNIQUE | Whole Body Technique (0018,1301)
WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE | Whole Slide Microscopy Image Frame Type Sequence (0040,0710)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE | Wide Field Ophthalmic Photography Quality Rating Sequence (0022,1525)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE | Wide Field Ophthalmic Photography Quality Threshold Sequence (0022,1526)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING | Wide Field Ophthalmic Photography Threshold Quality Rating (0022,1527)
WINDOW_CENTER | Window Center (0028,1050)
WINDOW_CENTER_AND_WIDTH_EXPLANATION | Alias for tag WINDOW_CENTER_WIDTH_EXPLANATION (0028,1055)
WINDOW_CENTER_WIDTH_EXPLANATION | Window Center Width Explanation (0028,1055)
WINDOW_WIDTH | Window Width (0028,1051)
WORKLIST_LABEL | Worklist Label (0074,1202)
X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE | X Coordinates Center Pixel View Angle (0022,1528)
X_FOCUS_CENTER | X Focus Center (0018,1183)
X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | X Offset in Slide Coordinate System (0040,072A)
X_RAY_3D_ACQUISITION_SEQUENCE | X-Ray 3D Acquisition Sequence (0018,9507)
X_RAY_3D_FRAME_TYPE_SEQUENCE | X-Ray 3D Frame Type Sequence (0018,9504)
X_RAY_3D_RECONSTRUCTION_SEQUENCE | X-Ray 3D Reconstruction Sequence (0018,9530)
X_RAY_ACQUISITION_DOSE_SEQUENCE | X-Ray Acquisition Dose Sequence (0018,9542)
X_RAY_DETECTOR_ID | X-Ray Detector ID (0018,9371)
X_RAY_DETECTOR_INDEX | X-Ray Detector Index (0018,9370)
X_RAY_DETECTOR_LABEL | X-Ray Detector Label (0018,9373)
X_RAY_FILTER_DETAILS_SEQUENCE | X-Ray Filter Details Sequence (0018,11BC)
X_RAY_FILTER_SEQUENCE | X-Ray Filter Sequence (0018,9556)
X_RAY_GEOMETRY_SEQUENCE | X-Ray Geometry Sequence (0018,9476)
X_RAY_GRID_SEQUENCE | X-Ray Grid Sequence (0018,9555)
X_RAY_IMAGE_RECEPTOR_ANGLE | X-Ray Image Receptor Angle (3002,000E)
X_RAY_IMAGE_RECEPTOR_TRANSLATION | X-Ray Image Receptor Translation (3002,000D)
X_RAY_MASS_ATTENUATION_COEFFICIENT | X-Ray Mass Attenuation Coefficient (0018,9384)
X_RAY_OUTPUT | X-Ray Output (0040,0312)
X_RAY_RECEPTOR_TYPE | X-Ray Receptor Type (0018,9420)
X_RAY_SOURCE_ID | X-Ray Source ID (0018,9367)
X_RAY_SOURCE_INDEX | X-Ray Source Index (0018,9366)
X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE | X-Ray Source Isocenter Primary Angle (0018,9543)
X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE | X-Ray Source Isocenter Secondary Angle (0018,9544)
X_RAY_TUBE_CURRENT | X-Ray Tube Current (0018,1151)
X_RAY_TUBE_CURRENT_IN_MA | X-Ray Tube Current in mA (0018,9330)
X_RAY_TUBE_CURRENT_IN_UA | X-Ray Tube Current in uA (0018,8151)
XA_ACQUISITION_DURATION | XA Acquisition Duration (0018,11BD)
XA_ACQUISITION_FRAME_RATE | XA Acquisition Frame Rate (0018,11B9)
XA_ACQUISITION_PHASE_DETAILS_SEQUENCE | XA Acquisition Phase Details Sequence (0018,11B8)
XA_PLANE_DETAILS_SEQUENCE | XA Plane Details Sequence (0018,11BA)
XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE | XA/XRF Frame Characteristics Sequence (0018,9412)
XDS_RETRIEVAL_SEQUENCE | XDS Retrieval Sequence (0040,E024)
XDS_STORAGE_SEQUENCE | XDS Storage Sequence (0040,4074)
Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE | Y Coordinates Center Pixel View Angle (0022,1529)
Y_FOCUS_CENTER | Y Focus Center (0018,1184)
Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | Y Offset in Slide Coordinate System (0040,073A)
Z_EFFECTIVE | Z Effective (4010,1019)
Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | Z Offset in Slide Coordinate System (0040,074A)
ZERO_VELOCITY_PIXEL_VALUE | Zero Velocity Pixel Value (0018,9810)
ZOOM_CENTER | Zoom Center (0028,0032)
ZOOM_FACTOR | Zoom Factor (0028,0031)

See Also

MCdicom Structure


MCdicom Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicom Fields
MCdicom Structure See Also Send Feedback

The MCdicom type exposes the following members.

Fields

Name | Description
A_LINE_PIXEL_SPACING | A-line Pixel Spacing (0052,0014)
A_LINE_RATE | A-line Rate (0052,0011)
A_LINES_PER_FRAME | A-lines Per Frame (0052,0012)
A_SCAN_RATE | A-scan Rate (0022,1649)
ABORT_FLAG | Abort Flag (4010,1024)
ABORT_REASON | Abort Reason (4010,1021)
ABSOLUTE_CHANNEL_DISPLAY_SCALE | Absolute Channel Display Scale (003A,0248)
ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG | Absolute Dosimetric Objective Flag (3010,0073)
ABSORBED_DOSE_TO_METERSET_RATIO | Absorbed Dose to Meterset Ratio (300C,0121)
ABSTRACT_PRIOR_CODE_SEQUENCE | Abstract Prior Code Sequence (0072,003E)
ABSTRACT_PRIOR_VALUE | Abstract Prior Value (0072,003C)
ACCELERATION | Acceleration (0016,0034)
ACCESSION_NUMBER | Accession Number (0008,0050)
ACCESSORY_CODE | Accessory Code (300A,00F9)
ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE | Acoustic Coupling Medium Code Sequence (0018,982A)
ACOUSTIC_COUPLING_MEDIUM_FLAG | Acoustic Coupling Medium Flag (0018,9829)
ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED | Acoustic Coupling Medium Sound Speed (0018,9834)
ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE | Acoustic Coupling Medium Temperature (0018,982B)
ACQUIRED_IMAGE_AREA_DOSE_PRODUCT | Acquired Image Area Dose Product (0018,9473)
ACQUIRED_SOUNDPATH_LENGTH | Acquired Soundpath Length (0014,4031)
ACQUIRED_SUBTRACTION_MASK_FLAG | Acquired Subtraction Mask Flag (0018,11B2)
ACQUISITION_COMMENTS_RETIRED | Acquisition Comments RETIRED (0018,4000)
ACQUISITION_COMPRESSION_TYPE | Acquisition Compression Type (0014,4032)
ACQUISITION_CONTEXT_DESCRIPTION | Acquisition Context Description (0040,0556)
ACQUISITION_CONTEXT_SEQUENCE | Acquisition Context Sequence (0040,0555)
ACQUISITION_CONTRAST | Acquisition Contrast (0008,9209)
ACQUISITION_DATE | Acquisition Date (0008,0022)
ACQUISITION_DATETIME | Acquisition DateTime (0008,002A)
ACQUISITION_DEVICE_PROCESSING_CODE | Acquisition Device Processing Code (0018,1401)
ACQUISITION_DEVICE_PROCESSING_DESCRIPTION | Acquisition Device Processing Description (0018,1400)
ACQUISITION_DEVICE_SEQUENCE | Acquisition Device Sequence (3002,0117)
ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE | Acquisition Device Type Code Sequence (0022,0015)
ACQUISITION_DURATION | Acquisition Duration (0018,9073)
ACQUISITION_END_LOCATION_SEQUENCE | Acquisition End Location Sequence (0018,9932)
ACQUISITION_FIELD_OF_VIEW_LABEL | Acquisition Field of View Label (0018,11BB)
ACQUISITION_INDEX | Acquisition Index (0020,9518)
ACQUISITION_INITIATION_SEQUENCE | Acquisition Initiation Sequence (3002,0135)
ACQUISITION_MATRIX | Acquisition Matrix (0018,1310)
ACQUISITION_METHOD | Acquisition Method (3002,012A)
ACQUISITION_METHOD_ALGORITHM_SEQUENCE | Acquisition Method Algorithm Sequence (0022,1423)
ACQUISITION_METHOD_CODE_SEQUENCE | Acquisition Method Code Sequence (0022,1420)
ACQUISITION_MODE | Acquisition Mode (0018,11B0)
ACQUISITION_MOTION | Acquisition Motion (0018,9930)
ACQUISITION_NUMBER | Acquisition Number (0020,0012)
ACQUISITION_PROTOCOL_DESCRIPTION | Acquisition Protocol Description (0018,9424)
ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE | Acquisition Protocol Element Sequence (0018,9920)
ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Acquisition Protocol Element Specification Sequence (0018,991F)
ACQUISITION_PROTOCOL_NAME | Acquisition Protocol Name (0018,9423)
ACQUISITION_SAMPLE_SIZE | Acquisition Sample Size (0014,4033)
ACQUISITION_SIGNAL_TYPE | Acquisition Signal Type (3002,0129)
ACQUISITION_START_CONDITION | Acquisition Start Condition (0018,0073)
ACQUISITION_START_CONDITION_DATA | Acquisition Start Condition Data (0018,0074)
ACQUISITION_START_LOCATION_SEQUENCE | Acquisition Start Location Sequence (0018,9931)
ACQUISITION_STATUS | Acquisition Status (4010,1044)
ACQUISITION_SUBTASK_INDEX | Acquisition Subtask Index (3002,011D)
ACQUISITION_SUBTASK_SEQUENCE | Acquisition Subtask Sequence (3002,011A)
ACQUISITION_TASK_APPLICABILITY_SEQUENCE | Acquisition Task Applicability Sequence (3002,0124)
ACQUISITION_TASK_INDEX | Acquisition Task Index (3002,011C)
ACQUISITION_TASK_SEQUENCE | Acquisition Task Sequence (3002,0118)
ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE | Acquisition Task Workitem Code Sequence (3002,0119)
ACQUISITION_TERMINATION_CONDITION | Acquisition Termination Condition (0018,0071)
ACQUISITION_TERMINATION_CONDITION_DATA | Acquisition Termination Condition Data (0018,0075)
ACQUISITION_TIME | Acquisition Time (0008,0032)
ACQUISITION_TIME_SYNCHRONIZED | Acquisition Time Synchronized (0018,1800)
ACQUISITION_TYPE | Acquisition Type (0018,9302)
ACQUISITION_UID | Acquisition UID (0008,0017)
ACQUISITIONS_IN_SERIES_RETIRED | Acquisitions in Series RETIRED (0020,1001)
ACQUISITIONS_IN_STUDY_RETIRED | Acquisitions in Study RETIRED (0020,1004)
ACROSS_SCAN_SPATIAL_RESOLUTION | Across-scan Spatial Resolution (0022,0048)
ACTION_TYPE_ID | Action Type ID (0000,1008)
ACTIVE_IMAGE_AREA_OVERLAY_GROUP | Active Image Area Overlay Group (0018,6070)
ACTIVE_SOURCE_DIAMETER | Active Source Diameter (300A,0218)
ACTIVE_SOURCE_LENGTH | Active Source Length (300A,021A)
ACTUAL_CARDIAC_TRIGGER_DELAY_TIME | Actual Cardiac Trigger Delay Time (0020,9252)
ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK | Actual Cardiac Trigger Time Prior To R-Peak (0020,9155)
ACTUAL_ENVIRONMENTAL_CONDITIONS | Actual Environmental Conditions (0014,1010)
ACTUAL_FRAME_DURATION | Actual Frame Duration (0018,1242)
ACTUAL_HUMAN_PERFORMERS_SEQUENCE | Actual Human Performers Sequence (0040,4035)
ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME | Actual Respiratory Trigger Delay Time (0020,9257)
ADD_GRAY_SCALE_RETIRED | Add Gray Scale RETIRED (0000,5150)
ADD_INTERMEDIATE_SEQUENCE | Add Intermediate Sequence (0046,0101)
ADD_NEAR_SEQUENCE | Add Near Sequence (0046,0100)
ADD_OTHER_SEQUENCE | Add Other Sequence (0046,0102)
ADD_POWER | Add Power (0046,0104)
ADDITIONAL_DRUG_SEQUENCE | Additional Drug Sequence (0018,002A)
ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE | Additional Parameter Recording Instance Sequence (300A,0780)
ADDITIONAL_PATIENT_HISTORY | Additional Patient History (0010,21B0)
ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE | Additional RT Accessory Device Sequence (3002,0130)
ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED | Additional RT ROI Identification Code Sequence RETIRED (3006,00B9)
ADDRESS_TRIAL_RETIRED | Address (Trial) RETIRED (0040,A353)
ADMINISTRATION_ROUTE_CODE_SEQUENCE | Administration Route Code Sequence (0054,0302)
ADMISSION_ID | Admission ID (0038,0010)
ADMITTING_DATE | Admitting Date (0038,0020)
ADMITTING_DIAGNOSES_CODE_SEQUENCE | Admitting Diagnoses Code Sequence (0008,1084)
ADMITTING_DIAGNOSES_DESCRIPTION | Admitting Diagnoses Description (0008,1080)
ADMITTING_TIME | Admitting Time (0038,0021)
ADVANCED_BLENDING_SEQUENCE | Advanced Blending Sequence (0070,1B01)
AFFECTED_SOP_CLASS_UID | Affected SOP Class UID (0000,0002)
AFFECTED_SOP_INSTANCE_UID | Affected SOP Instance UID (0000,1000)
AFTERLOADER_CHANNEL_ID | Afterloader Channel ID (300A,0273)
AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE | Age Corrected Sensitivity Deviation Algorithm Sequence (0024,0065)
AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE | Age Corrected Sensitivity Deviation Probability Value (0024,0100)
AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE | Age Corrected Sensitivity Deviation Value (0024,0092)
AIR_COUNTS | Air Counts (0014,3070)
ALARM_DECISION | Alarm Decision (4010,1031)
ALARM_DECISION_TIME | Alarm Decision Time (4010,102B)
ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED | Algorithm Code Sequence (Trial) RETIRED (0040,A296)
ALGORITHM_DESCRIPTION | Algorithm Description (0018,9528)
ALGORITHM_DESCRIPTION_TRIAL_RETIRED | Algorithm Description (Trial) RETIRED (0040,A297)
ALGORITHM_FAMILY_CODE_SEQUENCE | Algorithm Family Code Sequence (0066,002F)
ALGORITHM_NAME | Algorithm Name (0066,0036)
ALGORITHM_NAME_CODE_SEQUENCE | Algorithm Name Code Sequence (0066,0030)
ALGORITHM_PARAMETERS | Algorithm Parameters (0066,0032)
ALGORITHM_ROUTING_CODE_SEQUENCE | Algorithm Routing Code Sequence (4010,1064)
ALGORITHM_SOURCE | Algorithm Source (0024,0202)
ALGORITHM_TYPE | Algorithm Type (0018,9527)
ALGORITHM_VERSION | Algorithm Version (0066,0031)
ALIASED_DATA_TYPE | Aliased Data Type (0018,980B)
ALLERGIES | Allergies (0010,2110)
ALLOW_LOSSY_COMPRESSION | Allow Lossy Compression (2200,000F)
ALLOW_MEDIA_SPLITTING | Allow Media Splitting (2200,0007)
ALONG_SCAN_SPATIAL_RESOLUTION | Along-scan Spatial Resolution (0022,0037)
ALPHA_LUT_TRANSFER_FUNCTION | Alpha LUT Transfer Function (0028,1410)
ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA | Alpha Palette Color Lookup Table Data (0028,1204)
ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Alpha Palette Color Lookup Table Descriptor (0028,1104)
ALTERNATE_BEAM_DOSE | Alternate Beam Dose (300A,0091)
ALTERNATE_BEAM_DOSE_TYPE | Alternate Beam Dose Type (300A,0092)
ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE | Alternate Container Identifier Sequence (0040,0515)
ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE | Alternate Content Description Sequence (0070,0087)
ALTERNATE_REPRESENTATION_SEQUENCE | Alternate Representation Sequence (0008,3001)
ALTERNATE_VALUE_SEQUENCE | Alternate Value Sequence (300A,073E)
AMBIENT_LIGHT_VALUE_SOURCE | Ambient Light Value Source (0028,7025)
AMBIENT_REFLECTION_INTENSITY | Ambient Reflection Intensity (0070,1702)
AMPLIFIER_TYPE | Amplifier Type (0014,400A)
ANALOG_FILTER_CHARACTERISTICS_SEQUENCE | Analog Filter Characteristics Sequence (003A,0323)
ANALOG_FILTER_ROLL_OFF | Analog Filter Roll Off (003A,0324)
ANALOG_FILTER_TYPE_CODE_SEQUENCE | Analog Filter Type Code Sequence (003A,0325)
ANALYZED_AREA | Analyzed Area (0046,0227)
ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Approach Direction Code Sequence (Trial) RETIRED (0008,2255)
ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Location Of Examining Instrument Code Sequence (Trial) RETIRED (0008,2259)
ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED | Anatomic Location Of Examining Instrument Description (Trial) RETIRED (0008,2258)
ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Perspective Code Sequence (Trial) RETIRED (0008,2257)
ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED | Anatomic Perspective Description (Trial) RETIRED (0008,2256)
ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Portal Of Entrance Code Sequence (Trial) RETIRED (0008,2253)
ANATOMIC_REGION_MODIFIER_SEQUENCE | Anatomic Region Modifier Sequence (0008,2220)
ANATOMIC_REGION_SEQUENCE | Anatomic Region Sequence (0008,2218)
ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE | Anatomic Regions in Study Code Sequence (0008,0063)
ANATOMIC_STRUCTURE_REFERENCE_POINT | Anatomic Structure Reference Point (0022,1463)
ANATOMIC_STRUCTURE_RETIRED | Anatomic Structure RETIRED (0008,2208)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Structure Space Or Region Code Sequence (Trial) RETIRED (0008,2251)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Anatomic Structure Space Or Region Modifier Code Sequence (Trial) RETIRED (0008,225A)
ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED | Anatomic Structure Space or Region Sequence RETIRED (0008,2229)
ANATOMICAL_ORIENTATION_TYPE | Anatomical Orientation Type (0010,2210)
ANCHOR_POINT | Anchor Point (0070,0014)
ANCHOR_POINT_ANNOTATION_UNITS | Anchor Point Annotation Units (0070,0004)
ANCHOR_POINT_VISIBILITY | Anchor Point Visibility (0070,0015)
ANGIO_FLAG | Angio Flag (0018,0025)
ANGLE_NUMBER_RETIRED | Angle Number RETIRED (0020,0018)
ANGULAR_POSITION_RETIRED | Angular Position RETIRED (0018,1141)
ANGULAR_STEP | Angular Step (0018,1144)
ANGULAR_VIEW_VECTOR | Angular View Vector (0054,0090)
ANIMATION_CURVE_SEQUENCE | Animation Curve Sequence (0070,1A04)
ANIMATION_STEP_SIZE | Animation Step Size (0070,1A05)
ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS | Annotation Applies to All Optical Paths (006A,000D)
ANNOTATION_APPLIES_TO_ALL_Z_PLANES | Annotation Applies to All Z Planes (006A,000F)
ANNOTATION_CLIPPING | Annotation Clipping (0070,1907)
ANNOTATION_CONTENT_SEQUENCE_RETIRED | Annotation Content Sequence RETIRED (2130,0050)
ANNOTATION_COORDINATE_TYPE | Annotation Coordinate Type (006A,0001)
ANNOTATION_DISPLAY_FORMAT_ID | Annotation Display Format ID (2010,0030)
ANNOTATION_FLAG_RETIRED | Annotation Flag RETIRED (2000,0065)
ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE | Annotation Group Algorithm Identification Sequence (006A,0008)
ANNOTATION_GROUP_DESCRIPTION | Annotation Group Description (006A,0006)
ANNOTATION_GROUP_GENERATION_TYPE | Annotation Group Generation Type (006A,0007)
ANNOTATION_GROUP_LABEL | Annotation Group Label (006A,0005)
ANNOTATION_GROUP_NUMBER | Annotation Group Number (0040,A180)
ANNOTATION_GROUP_SEQUENCE | Annotation Group Sequence (006A,0002)
ANNOTATION_GROUP_UID | Annotation Group UID (006A,0003)
ANNOTATION_INDEX_LIST | Annotation Index List (006A,0011)
ANNOTATION_POSITION | Annotation Position (2030,0010)
ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE | Annotation Property Category Code Sequence (006A,0009)
ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE | Annotation Property Type Code Sequence (006A,000A)
ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE | Annotation Property Type Modifier Code Sequence (006A,000B)
ANNOTATION_SEQUENCE | Alias for tag WAVEFORM_ANNOTATION_SEQUENCE (0040,B020)
ANODE_TARGET_MATERIAL | Anode Target Material (0018,1191)
ANTERIOR_CHAMBER_DEPTH | Anterior Chamber Depth (0022,1131)
ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE | Anterior Chamber Depth Definition Code Sequence (0022,1125)
ANTERIOR_CHAMBER_DEPTH_SEQUENCE | Anterior Chamber Depth Sequence (0022,1128)
APERTURE_VALUE | Aperture Value (0016,0022)
APEX_POSITION | Apex Position (0020,9308)
APPLICABLE_FRAME_RANGE | Applicable Frame Range (0028,6102)
APPLICABLE_SAFETY_STANDARD_AGENCY | Applicable Safety Standard Agency (0018,9174)
APPLICABLE_SAFETY_STANDARD_DESCRIPTION | Applicable Safety Standard Description (0018,9175)
APPLICATION_MANUFACTURER | Application Manufacturer (0018,9526)
APPLICATION_MAXIMUM_REPAINT_TIME | Application Maximum Repaint Time (0072,010E)
APPLICATION_NAME | Application Name (0018,9524)
APPLICATION_SETUP_CHECK | Application Setup Check (3008,0116)
APPLICATION_SETUP_MANUFACTURER | Application Setup Manufacturer (300A,0238)
APPLICATION_SETUP_NAME | Application Setup Name (300A,0236)
APPLICATION_SETUP_NUMBER | Application Setup Number (300A,0234)
APPLICATION_SETUP_SEQUENCE | Application Setup Sequence (300A,0230)
APPLICATION_SETUP_TYPE | Application Setup Type (300A,0232)
APPLICATION_VERSION | Application Version (0018,9525)
APPLICATOINS_SETUP_SEQUENCE | Alias for tag APPLICATION_SETUP_SEQUENCE (300A,0230)
APPLICATOR_APERTURE_SHAPE | Applicator Aperture Shape (300A,0432)
APPLICATOR_DESCRIPTION | Applicator Description (300A,010A)
APPLICATOR_GEOMETRY_SEQUENCE | Applicator Geometry Sequence (300A,0431)
APPLICATOR_ID | Applicator ID (300A,0108)
APPLICATOR_OPENING | Applicator Opening (300A,0433)
APPLICATOR_OPENING_X | Applicator Opening X (300A,0434)
APPLICATOR_OPENING_Y | Applicator Opening Y (300A,0435)
APPLICATOR_SEQUENCE | Applicator Sequence (300A,0107)
APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER | Applicator Shape Referenced ROI Number (300A,02A1)
APPLICATOR_TYPE | Applicator Type (300A,0109)
APPLIED_MASK_SUBTRACTION_FLAG | Applied Mask Subtraction Flag (0018,11C0)
APPROVAL_SEQUENCE | Approval Sequence (0044,0100)
APPROVAL_STATUS | Approval Status (300E,0002)
APPROVAL_STATUS_DATETIME | Approval Status DateTime (0044,0004)
APPROVAL_STATUS_FURTHER_DESCRIPTION | Approval Status Further Description (0044,0003)
APPROVAL_SUBJECT_SEQUENCE | Approval Subject Sequence (0044,0109)
ARBITRARY_RETIRED | Arbitrary RETIRED (4000,0010)
ARCHIVE_REQUESTED | Archive Requested (0040,A494)
ARTERIAL_SPIN_LABELING_CONTRAST | Arterial Spin Labeling Contrast (0018,9250)
ASL_BOLUS_CUT_OFF_DELAY_TIME | ASL Bolus Cut-off Delay Time (0018,925F)
ASL_BOLUS_CUT_OFF_FLAG | ASL Bolus Cut-off Flag (0018,925C)
ASL_BOLUS_CUT_OFF_TECHNIQUE | ASL Bolus Cut-off Technique (0018,925E)
ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE | ASL Bolus Cut-off Timing Sequence (0018,925D)
ASL_CONTEXT | ASL Context (0018,9257)
ASL_CRUSHER_DESCRIPTION | ASL Crusher Description (0018,925B)
ASL_CRUSHER_FLAG | ASL Crusher Flag (0018,9259)
ASL_CRUSHER_FLOW | Alias for tag ASL_CRUSHER_FLOW_LIMIT (0018,925A)
ASL_CRUSHER_FLOW_LIMIT | ASL Crusher Flow Limit (0018,925A)
ASL_MID_SLAB_POSITION | ASL Mid Slab Position (0018,9256)
ASL_PULSE_TRAIN_DURATION | ASL Pulse Train Duration (0018,9258)
ASL_SLAB_NUMBER | ASL Slab Number (0018,9253)
ASL_SLAB_ORIENTATION | ASL Slab Orientation (0018,9255)
ASL_SLAB_SEQUENCE | ASL Slab Sequence (0018,9260)
ASL_SLAB_THICKNESS | ASL Slab Thickness (0018,9254)
ASL_TECHNIQUE_DESCRIPTION | ASL Technique Description (0018,9252)
ASSERTER_IDENTIFICATION_SEQUENCE | Asserter Identification Sequence (0044,0103)
ASSERTION_CODE_SEQUENCE | Assertion Code Sequence (0044,0101)
ASSERTION_COMMENTS | Assertion Comments (0044,0106)
ASSERTION_DATETIME | Assertion DateTime (0044,0104)
ASSERTION_EXPIRATION_DATETIME | Assertion Expiration DateTime (0044,0105)
ASSERTION_UID | Assertion UID (0044,0102)
ASSESSED_ATTRIBUTE_VALUE_SEQUENCE | Assessed Attribute Value Sequence (0082,0010)
ASSESSED_SOP_INSTANCE_SEQUENCE | Assessed SOP Instance Sequence (0082,0004)
ASSESSMENT_LABEL | Assessment Label (0082,0023)
ASSESSMENT_OBSERVATIONS_SEQUENCE | Assessment Observations Sequence (0082,0007)
ASSESSMENT_REQUESTER_SEQUENCE | Assessment Requester Sequence (0082,0017)
ASSESSMENT_SET_ID | Assessment Set ID (0082,0016)
ASSESSMENT_SUMMARY | Assessment Summary (0082,0001)
ASSESSMENT_SUMMARY_DESCRIPTION | Assessment Summary Description (0082,0003)
ASSESSMENT_TYPE_CODE_SEQUENCE | Assessment Type Code Sequence (0082,0021)
ASSIGNED_LOCATION | Assigned Location (4010,102A)
ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE | Assigning Agency or Department Code Sequence (0040,003A)
ASSIGNING_FACILITY_SEQUENCE | Assigning Facility Sequence (0040,0036)
ASSIGNING_JURISDICTION_CODE_SEQUENCE | Assigning Jurisdiction Code Sequence (0040,0039)
ATD_ABILITY_ASSESSMENT | ATD Ability Assessment (4010,1014)
ATD_ASSESSMENT_FLAG | ATD Assessment Flag (4010,1015)
ATD_ASSESSMENT_PROBABILITY | ATD Assessment Probability (4010,1016)
ATD_ASSESSMENT_SEQUENCE | ATD Assessment Sequence (4010,1038)
ATTACHED_CONTOURS_RETIRED | Attached Contours RETIRED (3006,0049)
ATTENUATION_CORRECTED | Attenuation Corrected (0018,9759)
ATTENUATION_CORRECTION_METHOD | Attenuation Correction Method (0054,1101)
ATTENUATION_CORRECTION_SOURCE | Attenuation Correction Source (0018,9738)
ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP | Attenuation Correction Temporal Relationship (0018,9770)
ATTRIBUTE_IDENTIFIER_LIST | Attribute Identifier List (0000,1005)
ATTRIBUTE_ITEM_SELECTOR | Attribute Item Selector (0074,1054)
ATTRIBUTE_MODIFICATION_DATETIME | Attribute Modification DateTime (0400,0562)
ATTRIBUTE_OCCURRENCE_POINTER | Attribute Occurrence Pointer (0074,1052)
ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR | Attribute Occurrence Private Creator (0074,1056)
ATTRIBUTE_OCCURRENCE_SEQUENCE | Attribute Occurrence Sequence (0074,1050)
ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE | Attribute Tolerance Values Sequence (300A,062B)
AUDIO_COMMENTS_RETIRED | Audio Comments RETIRED (5000,200E)
AUDIO_SAMPLE_DATA_RETIRED | Audio Sample Data RETIRED (5000,200C)
AUDIO_SAMPLE_FORMAT_RETIRED | Audio Sample Format RETIRED (5000,2002)
AUDIO_TYPE_RETIRED | Audio Type RETIRED (5000,2000)
AUTHOR_IDENTIFICATION_SEQUENCE | Author Identification Sequence (3010,0019)
AUTHOR_OBSERVER_SEQUENCE | Author Observer Sequence (0040,A078)
AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER | Authorization Equipment Certification Number (0100,0426)
AUTO_KVP_LOWER_BOUND | Auto KVP Lower Bound (0018,9946)
AUTO_KVP_SELECTION_TYPE | Auto KVP Selection Type (0018,9944)
AUTO_KVP_UPPER_BOUND | Auto KVP Upper Bound (0018,9945)
AUTOREFRACTION_LEFT_EYE_SEQUENCE | Autorefraction Left Eye Sequence (0046,0052)
AUTOREFRACTION_RIGHT_EYE_SEQUENCE | Autorefraction Right Eye Sequence (0046,0050)
AUTOSEQUENCE_FLAG | Autosequence Flag (0074,1025)
AVAILABLE_TRANSFER_SYNTAX_UID | Available Transfer Syntax UID (0008,3002)
AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED | Average Beam Dose Point Depth RETIRED (300A,008D)
AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED | Average Beam Dose Point Equivalent Depth RETIRED (300A,008E)
AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Average Beam Dose Point Source to External Contour Distance (300A,0131)
AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED | Average Beam Dose Point SSD RETIRED (300A,008F)
AVERAGE_CORNEAL_POWER | Average Corneal Power (0046,0220)
AVERAGE_PULSE_WIDTH | Average Pulse Width (0018,1154)
AXIAL_ACCEPTANCE | Axial Acceptance (0054,1200)
AXIAL_DETECTOR_DIMENSION | Axial Detector Dimension (0018,9727)
AXIAL_LENGTH_OF_THE_EYE | Axial Length of the Eye (0022,0030)
AXIAL_MASH | Axial Mash (0054,1201)
AXIAL_POWER | Axial Power (0046,0249)
AXIAL_RESOLUTION | Axial Resolution (0052,0008)
AXIS_LABELS_RETIRED | Axis Labels RETIRED (5000,0040)
AXIS_OF_ROTATION | Axis of Rotation (0066,001B)
AXIS_UNITS_RETIRED | Axis Units RETIRED (5000,0030)
B_SCAN_CYCLE_TIME | B-scan Cycle Time (0022,1645)
B_SCAN_CYCLE_TIME_VECTOR | B-scan Cycle Time Vector (0022,1646)
B_SCAN_RATE | B-scan Rate (0022,1650)
B_SCAN_SLAB_THICKNESS | B-scan Slab Thickness (0022,1643)
B1RMS | B1rms (0018,1320)
BACKGROUND_COLOR | Background Color (0046,0092)
BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE | Background Illumination Color Code Sequence (0024,0024)
BACKGROUND_LUMINANCE | Background Luminance (0024,0020)
BAD_PIXEL_IMAGE | Bad Pixel Image (0014,3080)
BARCODE_SYMBOLOGY | Barcode Symbology (2200,0006)
BARCODE_VALUE | Barcode Value (2200,0005)
BASELINE_CORRECTION | Baseline Correction (0018,9067)
BASIC_COLOR_IMAGE_SEQUENCE | Basic Color Image Sequence (2020,0111)
BASIC_GRAYSCALE_IMAGE_SEQUENCE | Basic Grayscale Image Sequence (2020,0110)
BASIS_MATERIALS_CODE_SEQUENCE | Basis Materials Code Sequence (4010,1045)
BASIS_RT_TREATMENT_PHASE_INDEX | Basis RT Treatment Phase Index (3010,003E)
BATTERY_LEVEL | Battery Level (0016,0003)
BEAM_ANGLE | Beam Angle (0018,9449)
BEAM_AREA_LIMIT_SEQUENCE | Beam Area Limit Sequence (300A,0689)
BEAM_CURRENT_MODULATION_ID | Beam Current Modulation ID (300A,034C)
BEAM_DELIVERY_DURATION_LIMIT | Beam Delivery Duration Limit (300A,00C5)
BEAM_DESCRIPTION | Beam Description (300A,00C3)
BEAM_DOSE | Beam Dose (300A,0084)
BEAM_DOSE_MEANING | Beam Dose Meaning (300A,008B)
BEAM_DOSE_POINT_DEPTH | Beam Dose Point Depth (300A,0088)
BEAM_DOSE_POINT_EQUIVALENT_DEPTH | Beam Dose Point Equivalent Depth (300A,0089)
BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Beam Dose Point Source to External Contour Distance (300A,0094)
BEAM_DOSE_POINT_SSD | Beam Dose Point SSD (300A,008A)
BEAM_DOSE_SPECIFICATION_POINT_RETIRED | Beam Dose Specification Point RETIRED (300A,0082)
BEAM_DOSE_TYPE | Beam Dose Type (300A,0090)
BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE | Beam Dose Verification Control Point Sequence (300A,008C)
BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE | Beam Hold Originating Device Sequence (300C,0128)
BEAM_HOLD_TRANSITION | Beam Hold Transition (300C,0126)
BEAM_HOLD_TRANSITION_DATETIME | Beam Hold Transition DateTime (300C,0127)
BEAM_LIMITING_DEVICE_ANGLE | Beam Limiting Device Angle (300A,0120)
BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE | Beam Limiting Device Angle Tolerance (300A,0046)
BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE | Beam Limiting Device Leaf Pairs Sequence (3008,00A0)
BEAM_LIMITING_DEVICE_POSITION_SEQUENCE | Beam Limiting Device Position Sequence (300A,011A)
BEAM_LIMITING_DEVICE_POSITION_TOLERANCE | Beam Limiting Device Position Tolerance (300A,004A)
BEAM_LIMITING_DEVICE_ROTATION_DIRECTION | Beam Limiting Device Rotation Direction (300A,0121)
BEAM_LIMITING_DEVICE_SEQUENCE | Beam Limiting Device Sequence (300A,00B6)
BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE | Beam Limiting Device Tolerance Sequence (300A,0048)
BEAM_METERSET | Beam Meterset (300A,0086)
BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG | Beam Modifier Coordinates Presence Flag (3002,0105)
BEAM_MODIFIER_ORIENTATION_ANGLE | Beam Modifier Orientation Angle (300A,0645)
BEAM_NAME | Beam Name (300A,00C2)
BEAM_NUMBER | Beam Number (300A,00C0)
BEAM_ORDER_INDEX | Beam Order Index (0074,1324)
BEAM_ORDER_INDEX_TRIAL_RETIRED | Beam Order Index (Trial) RETIRED (0074,1024)
BEAM_SEQUENCE | Beam Sequence (300A,00B0)
BEAM_SPOT_SIZE | Beam Spot Size (0052,0003)
BEAM_STOPPER_POSITION | Beam Stopper Position (3008,0230)
BEAM_TASK_SEQUENCE | Beam Task Sequence (0074,1020)
BEAM_TASK_TYPE | Beam Task Type (0074,1022)
BEAM_TYPE | Beam Type (300A,00C4)
BEAT_REJECTION_FLAG | Beat Rejection Flag (0018,1080)
BELT_HEIGHT | Belt Height (4010,1062)
BI_PLANE_ACQUISITION_SEQUENCE_RETIRED | Bi-Plane Acquisition Sequence RETIRED (0028,5000)
BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED | Bibliographic Citation (Trial) RETIRED (0040,A16A)
BILLING_ITEM_SEQUENCE | Billing Item Sequence (0040,0296)
BILLING_PROCEDURE_STEP_SEQUENCE | Billing Procedure Step Sequence (0040,0320)
BILLING_SUPPLIES_AND_DEVICES_SEQUENCE | Billing Supplies and Devices Sequence (0040,0324)
BIOPSY_TARGET_SEQUENCE | Biopsy Target Sequence (0018,2041)
BIT_POSITION | Alias for tag OVERLAY_BIT_POSITION (6000,0102)
BITS_ALLOCATED | Bits Allocated (0028,0100)
BITS_MAPPED_TO_COLOR_LOOKUP_TABLE | Bits Mapped to Color Lookup Table (0028,1403)
BITS_STORED | Bits Stored (0028,0101)
BLENDING_DISPLAY_INPUT_SEQUENCE | Blending Display Input Sequence (0070,1B03)
BLENDING_DISPLAY_SEQUENCE | Blending Display Sequence (0070,1B04)
BLENDING_INPUT_NUMBER | Blending Input Number (0070,1B02)
BLENDING_LOOKUP_TABLE_DATA | Blending Lookup Table Data (0028,1408)
BLENDING_LOOKUP_TABLE_DESCRIPTOR | Blending Lookup Table Descriptor (0028,1407)
BLENDING_LUT_1_SEQUENCE | Blending LUT 1 Sequence (0028,1404)
BLENDING_LUT_1_TRANSFER_FUNCTION | Blending LUT 1 Transfer Function (0028,1405)
BLENDING_LUT_2_SEQUENCE | Blending LUT 2 Sequence (0028,140C)
BLENDING_LUT_2_TRANSFER_FUNCTION | Blending LUT 2 Transfer Function (0028,140D)
BLENDING_MODE | Blending Mode (0070,1B06)
BLENDING_OPERATION_TYPE | Blending Operation Type (0072,0500)
BLENDING_POSITION | Blending Position (0070,0405)
BLENDING_SEQUENCE | Blending Sequence (0070,0402)
BLENDING_WEIGHT_CONSTANT | Blending Weight Constant (0028,1406)
BLIND_SPOT_LOCALIZED | Blind Spot Localized (0024,0106)
BLIND_SPOT_X_COORDINATE | Blind Spot X-Coordinate (0024,0107)
BLIND_SPOT_Y_COORDINATE | Blind Spot Y-Coordinate (0024,0108)
BLOCK_DATA | Block Data (300A,0106)
BLOCK_DEFINITION_SEQUENCE | Block Definition Sequence (300A,066A)
BLOCK_DIVERGENCE | Block Divergence (300A,00FA)
BLOCK_EDGE_DATA | Block Edge Data (300A,066B)
BLOCK_EDGE_DATA_SEQUENCE | Block Edge Data Sequence (300A,066F)
BLOCK_IDENTIFYING_INFORMATION_STATUS | Block Identifying Information Status (0008,0303)
BLOCK_MOUNTING_POSITION | Block Mounting Position (300A,00FB)
BLOCK_NAME | Block Name (300A,00FE)
BLOCK_NUMBER | Block Number (300A,00FC)
BLOCK_NUMBER_OF_POINTS | Block Number of Points (300A,0104)
BLOCK_ORIENTATION | Block Orientation (300A,066C)
BLOCK_SEQUENCE | Block Sequence (300A,00F4)
BLOCK_SLAB_NUMBER | Block Slab Number (300A,0443)
BLOCK_SLAB_SEQUENCE | Block Slab Sequence (300A,0441)
BLOCK_SLAB_THICKNESS | Block Slab Thickness (300A,0442)
BLOCK_THICKNESS | Block Thickness (300A,0100)
BLOCK_TRANSMISSION | Block Transmission (300A,0102)
BLOCK_TRAY_ID | Block Tray ID (300A,00F5)
BLOCK_TYPE | Block Type (300A,00F8)
BLOOD_SIGNAL_NULLING | Blood Signal Nulling (0018,9022)
BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA | Blue Palette Color Lookup Table Data (0028,1203)
BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Blue Palette Color Lookup Table Descriptor (0028,1103)
BOARDING_PASS_ID | Boarding Pass ID (4010,101A)
BODY_PART_EXAMINED | Body Part Examined (0018,0015)
BODY_PART_THICKNESS | Body Part Thickness (0018,11A0)
BOLD | Bold (0070,0249)
BOLUS_DEFINITION_SEQUENCE | Bolus Definition Sequence (300A,0673)
BOLUS_DESCRIPTION | Bolus Description (300A,00DD)
BOLUS_ID | Bolus ID (300A,00DC)
BONE_THERMAL_INDEX | Bone Thermal Index (0018,5024)
BORDER_DENSITY | Border Density (2010,0100)
BORDERS_RETIRED | Borders RETIRED (0000,5160)
BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED | Bottom Right Hand Corner of Localizer Area RETIRED (0048,0202)
BOUNDING_BOX_ANNOTATION_UNITS | Bounding Box Annotation Units (0070,0003)
BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER | Bounding Box Bottom Right Hand Corner (0070,0011)
BOUNDING_BOX_CROP | Bounding Box Crop (0070,1303)
BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION | Bounding Box Text Horizontal Justification (0070,0012)
BOUNDING_BOX_TOP_LEFT_HAND_CORNER | Bounding Box Top Left Hand Corner (0070,0010)
BOUNDING_POLYGON | Bounding Polygon (4010,101D)
BOUNDING_RECTANGLE | Bounding Rectangle (0068,6347)
BRACHY_ACCESSORY_DEVICE_ID | Brachy Accessory Device ID (300A,0263)
BRACHY_ACCESSORY_DEVICE_NAME | Brachy Accessory Device Name (300A,0266)
BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS | Brachy Accessory Device Nominal Thickness (300A,026A)
BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION | Brachy Accessory Device Nominal Transmission (300A,026C)
BRACHY_ACCESSORY_DEVICE_NUMBER | Brachy Accessory Device Number (300A,0262)
BRACHY_ACCESSORY_DEVICE_SEQUENCE | Brachy Accessory Device Sequence (300A,0260)
BRACHY_ACCESSORY_DEVICE_TYPE | Brachy Accessory Device Type (300A,0264)
BRACHY_APPLICATION_SETUP_DOSE | Brachy Application Setup Dose (300A,00A4)
BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT | Brachy Application Setup Dose Specification Point (300A,00A2)
BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE | Brachy Control Point Delivered Sequence (3008,0160)
BRACHY_CONTROL_POINT_SEQUENCE | Brachy Control Point Sequence (300A,02D0)
BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE | Brachy Pulse Control Point Delivered Sequence (3008,0173)
BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE | Brachy Referenced Dose Reference Sequence (300C,0055)
BRACHY_TASK_SEQUENCE | Brachy Task Sequence (0074,1401)
BRACHY_TREATMENT_TECHNIQUE | Brachy Treatment Technique (300A,0200)
BRACHY_TREATMENT_TYPE | Brachy Treatment Type (300A,0202)
BRACHYTHERAPY_SOURCE_TYPE | Brachytherapy Source Type (3010,0048)
BRANCH_OF_SERVICE | Branch of Service (0010,1081)
BREAST_IMPLANT_PRESENT | Breast Implant Present (0028,1300)
BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE | Breast Support Isocenter Primary Angle (0018,9545)
BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE | Breast Support Isocenter Secondary Angle (0018,9546)
BREAST_SUPPORT_X_POSITION_TO_ISOCENTER | Breast Support X Position to Isocenter (0018,9547)
BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER | Breast Support Y Position to Isocenter (0018,9548)
BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER | Breast Support Z Position to Isocenter (0018,9549)
BREED_REGISTRATION_NUMBER | Breed Registration Number (0010,2295)
BREED_REGISTRATION_SEQUENCE | Breed Registration Sequence (0010,2294)
BREED_REGISTRY_CODE_SEQUENCE | Breed Registry Code Sequence (0010,2296)
BRIGHTNESS_VALUE | Brightness Value (0016,0023)
BULK_MOTION_COMPENSATION_TECHNIQUE | Bulk Motion Compensation Technique (0018,9172)
BULK_MOTION_SIGNAL_SOURCE | Bulk Motion Signal Source (0018,9173)
BULK_MOTION_STATUS_RETIRED | Bulk Motion Status RETIRED (0018,9166)
BURNED_IN_ANNOTATION | Burned In Annotation (0028,0301)
C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE | C-Arm Photon-Electron Control Point Sequence (300A,062F)
C_ARM_POSITIONER_TABLETOP_RELATIONSHIP | C-arm Positioner Tabletop Relationship (0018,9474)
CAD_FILE_FORMAT_RETIRED | CAD File Format RETIRED (0014,0023)
CALCIUM_SCORING_MASS_FACTOR_DEVICE | Calcium Scoring Mass Factor Device (0018,9352)
CALCIUM_SCORING_MASS_FACTOR_PATIENT | Calcium Scoring Mass Factor Patient (0018,9351)
CALCULATED_ANATOMY_THICKNESS | Calculated Anatomy Thickness (0018,9452)
CALCULATED_DOSE_REFERENCE_DESCRIPTION | Calculated Dose Reference Description (3008,0074)
CALCULATED_DOSE_REFERENCE_DOSE_VALUE | Calculated Dose Reference Dose Value (3008,0076)
CALCULATED_DOSE_REFERENCE_NUMBER | Calculated Dose Reference Number (3008,0072)
CALCULATED_DOSE_REFERENCE_SEQUENCE | Calculated Dose Reference Sequence (3008,0070)
CALCULATED_FRAME_LIST | Calculated Frame List (0008,1162)
CALCULATED_TARGET_POSITION | Calculated Target Position (0018,2044)
CALCULATION_COMMENT | Calculation Comment (0022,112C)
CALCULATION_COMMENT_SEQUENCE | Calculation Comment Sequence (0022,112A)
CALCULATION_COMMENT_TYPE | Calculation Comment Type (0022,112B)
CALIBRATION_DATA_SEQUENCE | Calibration Data Sequence (0054,0306)
CALIBRATION_DATE | Calibration Date (0014,407E)
CALIBRATION_DATETIME | Calibration DateTime (0018,1203)
CALIBRATION_IMAGE | Calibration Image (0050,0004)
CALIBRATION_NOTES | Calibration Notes (0014,3099)
CALIBRATION_OBJECT | Alias for tag CALIBRATION_IMAGE (0050,0004)
CALIBRATION_PROCEDURE | Calibration Procedure (0014,4072)
CALIBRATION_REFERENCE_POINT_DEPTH | Calibration Reference Point Depth (300C,0124)
CALIBRATION_SEQUENCE | Calibration Sequence (0018,9455)
CALIBRATION_SETTINGS_SEQUENCE | Calibration Settings Sequence (0014,4070)
CALIBRATION_TIME | Calibration Time (0014,407C)
CAMERA_ANGLE_OF_VIEW | Camera Angle of View (0022,001E)
CAMERA_ELEVATION_ANGLE | Camera Elevation Angle (0016,0035)
CAMERA_OWNER_NAME | Camera Owner Name (0016,004D)
CAMERA_POSITION_GROUP_SEQUENCE | Camera Position Group Sequence (0034,000B)
CARDIAC_BEAT_REJECTION_TECHNIQUE | Cardiac Beat Rejection Technique (0018,9169)
CARDIAC_CYCLE_POSITION | Cardiac Cycle Position (0018,9236)
CARDIAC_FRAMING_TYPE | Cardiac Framing Type (0018,1064)
CARDIAC_NUMBER_OF_IMAGES | Cardiac Number of Images (0018,1090)
CARDIAC_R_R_INTERVAL_SPECIFIED | Cardiac R-R Interval Specified (0018,9070)
CARDIAC_SIGNAL_SOURCE | Cardiac Signal Source (0018,9085)
CARDIAC_SYNCHRONIZATION_SEQUENCE | Cardiac Synchronization Sequence (0018,9118)
CARDIAC_SYNCHRONIZATION_TECHNIQUE | Cardiac Synchronization Technique (0018,9037)
CARDIAC_TRIGGER_DELAY_TIME | Alias for tag NOMINAL_CARDIAC_TRIGGER_DELAY_TIME (0020,9153)
CARDIAC_TRIGGER_SEQUENCE | Alias for tag CARDIAC_SYNCHRONIZATION_SEQUENCE (0018,9118)
CARRIER_ID | Carrier ID (4010,1058)
CARRIER_ID_ASSIGNING_AUTHORITY | Carrier ID Assigning Authority (4010,1059)
CASSETTE_ID | Cassette ID (0018,1007)
CASSETTE_ORIENTATION | Cassette Orientation (0018,1402)
CASSETTE_SIZE | Cassette Size (0018,1403)
CATCH_TRIALS_DATA_FLAG | Catch Trials Data Flag (0024,0055)
CATHETER_DIRECTION_OF_ROTATION | Catheter Direction of Rotation (0052,0031)
CATHETER_ROTATIONAL_RATE | Catheter Rotational Rate (0052,0013)
CELL_VALUES_SEQUENCE | Cell Values Sequence (0040,A808)
CENTER_FREQUENCY | Center Frequency (0018,982D)
CENTER_OF_CIRCULAR_COLLIMATOR | Center of Circular Collimator (0018,1710)
CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION | Center of Circular Exposure Control Sensing Region (0018,9440)
CENTER_OF_CIRCULAR_OUTLINE | Center of Circular Outline (0018,1635)
CENTER_OF_CIRCULAR_SHUTTER | Center of Circular Shutter (0018,1610)
CENTER_OF_MASS | Center of Mass (4010,101B)
CENTER_OF_PTO | Center of PTO (4010,101C)
CENTER_OF_ROTATION | Center of Rotation (0066,001C)
CENTER_OF_ROTATION_OFFSET | Center of Rotation Offset (0018,1145)
CERTIFICATE_OF_SIGNER | Certificate of Signer (0400,0115)
CERTIFICATE_TYPE | Certificate Type (0400,0110)
CERTIFIED_TIMESTAMP | Certified Timestamp (0400,0310)
CERTIFIED_TIMESTAMP_TYPE | Certified Timestamp Type (0400,0305)
CHAIR_HEAD_FRAME_POSITION | Chair Head Frame Position (300A,0151)
CHAIR_HEAD_FRAME_POSITION_TOLERANCE | Chair Head Frame Position Tolerance (300A,0153)
CHANNEL_BASELINE | Channel Baseline (003A,0213)
CHANNEL_DEFINITION_SEQUENCE | Channel Definition Sequence (003A,0200)
CHANNEL_DELIVERY_CONTINUATION_SEQUENCE | Channel Delivery Continuation Sequence (0074,140D)
CHANNEL_DELIVERY_ORDER_INDEX | Channel Delivery Order Index (0074,140C)
CHANNEL_DELIVERY_ORDER_SEQUENCE | Channel Delivery Order Sequence (0074,1405)
CHANNEL_DERIVATION_DESCRIPTION | Channel Derivation Description (003A,020C)
CHANNEL_DESCRIPTION_CODE_SEQUENCE | Channel Description Code Sequence (0022,001A)
CHANNEL_DISPLAY_SEQUENCE | Channel Display Sequence (003A,0242)
CHANNEL_EFFECTIVE_LENGTH | Channel Effective Length (300A,0271)
CHANNEL_IDENTIFICATION_CODE | Channel Identification Code (003A,0301)
CHANNEL_IMPEDANCE_SEQUENCE | Channel Impedance Sequence (003A,0312)
CHANNEL_INNER_LENGTH | Channel Inner Length (300A,0272)
CHANNEL_LABEL | Channel Label (003A,0203)
CHANNEL_LENGTH | Channel Length (300A,0284)
CHANNEL_MAXIMUM_VALUE | Channel Maximum Value (5400,0112)
CHANNEL_MINIMUM_VALUE | Channel Minimum Value (5400,0110)
CHANNEL_MODE | Channel Mode (003A,0302)
CHANNEL_NUMBER | Channel Number (300A,0282)
CHANNEL_OFFSET | Channel Offset (003A,0218)
CHANNEL_POSITION | Channel Position (003A,0245)
CHANNEL_PRESENTATION_GROUP_SEQUENCE | Alias for tag WAVEFORM_PRESENTATION_GROUP_SEQUENCE (003A,0240)
CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE | Channel Recommended Display CIELab Value (003A,0244)
CHANNEL_SAMPLE_SKEW | Channel Sample Skew (003A,0215)
CHANNEL_SENSITIVITY | Channel Sensitivity (003A,0210)
CHANNEL_SENSITIVITY_CORRECTION_FACTOR | Channel Sensitivity Correction Factor (003A,0212)
CHANNEL_SENSITIVITY_UNITS_SEQUENCE | Channel Sensitivity Units Sequence (003A,0211)
CHANNEL_SEQUENCE | Channel Sequence (300A,0280)
CHANNEL_SHIELD_ID | Channel Shield ID (300A,02B3)
CHANNEL_SHIELD_NAME | Channel Shield Name (300A,02B4)
CHANNEL_SHIELD_NOMINAL_THICKNESS | Channel Shield Nominal Thickness (300A,02B8)
CHANNEL_SHIELD_NOMINAL_TRANSMISSION | Channel Shield Nominal Transmission (300A,02BA)
CHANNEL_SHIELD_NUMBER | Channel Shield Number (300A,02B2)
CHANNEL_SHIELD_SEQUENCE | Channel Shield Sequence (300A,02B0)
CHANNEL_SOURCE_MODIFIERS_SEQUENCE | Channel Source Modifiers Sequence (003A,0209)
CHANNEL_SOURCE_SEQUENCE | Channel Source Sequence (003A,0208)
CHANNEL_STATUS | Channel Status (003A,0205)
CHANNEL_TIME_SKEW | Channel Time Skew (003A,0214)
CHANNEL_TOTAL_TIME | Channel Total Time (300A,0286)
CHANNEL_WIDTH | Channel Width (0046,0042)
CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED | Chemical Shift Maximum Integration Limit in Hz RETIRED (0018,9196)
CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM | Chemical Shift Maximum Integration Limit in ppm (0018,9296)
CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED | Chemical Shift Minimum Integration Limit in Hz RETIRED (0018,9195)
CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM | Chemical Shift Minimum Integration Limit in ppm (0018,9295)
CHEMICAL_SHIFT_REFERENCE | Chemical Shift Reference (0018,9053)
CHEMICAL_SHIFT_SEQUENCE | Chemical Shift Sequence (0018,9084)
CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ | Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9196)
CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM | Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9296)
CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ | Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9195)
CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM | Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9295)
CIEXY_WHITE_POINT | CIExy White Point (0028,7018)
CINE_RATE | Cine Rate (0018,0040)
CINE_RELATIVE_TO_REAL_TIME | Cine Relative to Real-Time (0072,0330)
CLINICAL_FRACTION_NUMBER | Clinical Fraction Number (300A,0705)
CLINICAL_TRIAL_COORDINATING_CENTER_NAME | Clinical Trial Coordinating Center Name (0012,0060)
CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER | Clinical Trial Protocol Ethics Committee Approval Number (0012,0082)
CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME | Clinical Trial Protocol Ethics Committee Name (0012,0081)
CLINICAL_TRIAL_PROTOCOL_ID | Clinical Trial Protocol ID (0012,0020)
CLINICAL_TRIAL_PROTOCOL_NAME | Clinical Trial Protocol Name (0012,0021)
CLINICAL_TRIAL_SERIES_DESCRIPTION | Clinical Trial Series Description (0012,0072)
CLINICAL_TRIAL_SERIES_ID | Clinical Trial Series ID (0012,0071)
CLINICAL_TRIAL_SITE_ID | Clinical Trial Site ID (0012,0030)
CLINICAL_TRIAL_SITE_NAME | Clinical Trial Site Name (0012,0031)
CLINICAL_TRIAL_SPONSOR_NAME | Clinical Trial Sponsor Name (0012,0010)
CLINICAL_TRIAL_SUBJECT_ID | Clinical Trial Subject ID (0012,0040)
CLINICAL_TRIAL_SUBJECT_READING_ID | Clinical Trial Subject Reading ID (0012,0042)
CLINICAL_TRIAL_TIME_POINT_DESCRIPTION | Clinical Trial Time Point Description (0012,0051)
CLINICAL_TRIAL_TIME_POINT_ID | Clinical Trial Time Point ID (0012,0050)
CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE | Clinical Trial Time Point Type Code Sequence (0012,0054)
COATING_MATERIALS_CODE_SEQUENCE | Coating Materials Code Sequence (0068,63A4)
CODE_MEANING | Code Meaning (0008,0104)
CODE_VALUE | Code Value (0008,0100)
CODING_SCHEME_DESIGNATOR | Coding Scheme Designator (0008,0102)
CODING_SCHEME_EXTERNAL_ID | Coding Scheme External ID (0008,0114)
CODING_SCHEME_IDENTIFICATION_SEQUENCE | Coding Scheme Identification Sequence (0008,0110)
CODING_SCHEME_NAME | Coding Scheme Name (0008,0115)
CODING_SCHEME_REGISTRY | Coding Scheme Registry (0008,0112)
CODING_SCHEME_RESOURCES_SEQUENCE | Coding Scheme Resources Sequence (0008,0109)
CODING_SCHEME_RESPONSIBLE_ORGANIZATION | Coding Scheme Responsible Organization (0008,0116)
CODING_SCHEME_UID | Coding Scheme UID (0008,010C)
CODING_SCHEME_URL | Coding Scheme URL (0008,010E)
CODING_SCHEME_URL_TYPE | Coding Scheme URL Type (0008,010A)
CODING_SCHEME_VERSION | Coding Scheme Version (0008,0103)
COINCIDENCE_WINDOW_WIDTH | Coincidence Window Width (0054,1210)
COLLATION_FLAG_RETIRED | Collation Flag RETIRED (2000,0063)
COLLIMATOR_GRID_NAME | Collimator/Grid Name (0018,1180)
COLLIMATOR_LEFT_VERTICAL_EDGE | Collimator Left Vertical Edge (0018,1702)
COLLIMATOR_LOWER_HORIZONTAL_EDGE | Collimator Lower Horizontal Edge (0018,1708)
COLLIMATOR_RIGHT_VERTICAL_EDGE | Collimator Right Vertical Edge (0018,1704)
COLLIMATOR_SHAPE | Collimator Shape (0018,1700)
COLLIMATOR_SHAPE_SEQUENCE | Collimator Shape Sequence (0018,9407)
COLLIMATOR_TYPE | Collimator Type (0018,1181)
COLLIMATOR_UPPER_HORIZONTAL_EDGE | Collimator Upper Horizontal Edge (0018,1706)
COLOR_FILTER_ARRAY_PATTERN_COLUMNS | Color Filter Array Pattern Columns (0016,000F)
COLOR_FILTER_ARRAY_PATTERN_ROWS | Color Filter Array Pattern Rows (0016,000E)
COLOR_FILTER_ARRAY_PATTERN_VALUES | Color Filter Array Pattern Values (0016,0010)
COLOR_IMAGE_PRINTING_FLAG_RETIRED | Color Image Printing Flag RETIRED (2000,0062)
COLOR_SPACE | Color Space (0028,2002)
COLUMN_ANGULATION | Column Angulation (0018,1450)
COLUMN_ANGULATION_PATIENT | Column Angulation (Patient) (0018,9447)
COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX | Column Position In Total Image Pixel Matrix (0048,021E)
COLUMNS | Columns (0028,0011)
COMBINATION_SEGMENT_REFERENCE_SEQUENCE | Combination Segment Reference Sequence (3010,0024)
COMMAND_DATA_SET_TYPE | Command Data Set Type (0000,0800)
COMMAND_FIELD | Command Field (0000,0100)
COMMAND_GROUP_LENGTH | Command Group Length (0000,0000)
COMMAND_LENGTH_TO_END_RETIRED | Command Length to End RETIRED (0000,0001)
COMMAND_MAGNIFICATION_TYPE_RETIRED | Command Magnification Type RETIRED (0000,5180)
COMMAND_RECOGNITION_CODE_RETIRED | Command Recognition Code RETIRED (0000,0010)
COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD | Alias for tag COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD (0024,0044)
COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD | Comments on Patient's Performance of Visual Field (0024,0044)
COMMENTS_ON_RADIATION_DOSE | Comments on Radiation Dose (0040,0310)
COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP | Comments on the Performed Procedure Step (0040,0280)
COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP | Comments on the Scheduled Procedure Step (0040,0400)
COMMON_Z_COORDINATE_VALUE | Common Z Coordinate Value (006A,0010)
COMPENSATOR_BASE_PLANE_OFFSET | Compensator Base Plane Offset (300A,0666)
COMPENSATOR_COLUMN_OFFSET | Compensator Column Offset (300A,02E5)
COMPENSATOR_COLUMNS | Compensator Columns (300A,00E8)
COMPENSATOR_DEFINITION_SEQUENCE | Compensator Definition Sequence (300A,0662)
COMPENSATOR_DESCRIPTION | Compensator Description (300A,02EB)
COMPENSATOR_DISTAL_THICKNESS_MAP | Compensator Distal Thickness Map (300A,0665)
COMPENSATOR_DIVERGENCE | Compensator Divergence (300A,02E0)
COMPENSATOR_ID | Compensator ID (300A,00E5)
COMPENSATOR_MAP_ORIENTATION | Compensator Map Orientation (300A,0663)
COMPENSATOR_MILLING_TOOL_DIAMETER | Compensator Milling Tool Diameter (300A,02E8)
COMPENSATOR_MOUNTING_POSITION | Compensator Mounting Position (300A,02E1)
COMPENSATOR_NUMBER | Compensator Number (300A,00E4)
COMPENSATOR_PIXEL_SPACING | Compensator Pixel Spacing (300A,00E9)
COMPENSATOR_POSITION | Compensator Position (300A,00EA)
COMPENSATOR_PROXIMAL_THICKNESS_MAP | Compensator Proximal Thickness Map (300A,0664)
COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO | Compensator Relative Stopping Power Ratio (300A,02E7)
COMPENSATOR_ROWS | Compensator Rows (300A,00E7)
COMPENSATOR_SEQUENCE | Compensator Sequence (300A,00E3)
COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE | Compensator Shape Fabrication Code Sequence (300A,0667)
COMPENSATOR_SHAPE_SEQUENCE | Compensator Shape Sequence (300A,0668)
COMPENSATOR_THICKNESS_DATA | Compensator Thickness Data (300A,00EC)
COMPENSATOR_TRANSMISSION_DATA | Compensator Transmission Data (300A,00EB)
COMPENSATOR_TRAY_ID | Compensator Tray ID (300A,00EF)
COMPENSATOR_TYPE | Compensator Type (300A,00EE)
COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE | Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A375)
COMPLETION_FLAG | Completion Flag (0040,A491)
COMPLETION_FLAG_DESCRIPTION | Completion Flag Description (0040,A492)
COMPLEX_IMAGE_COMPONENT | Complex Image Component (0008,9208)
COMPONENT_1_REFERENCED_ID | Component 1 Referenced ID (0076,0070)
COMPONENT_1_REFERENCED_MATING_FEATURE_ID | Component 1 Referenced Mating Feature ID (0076,0090)
COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID | Component 1 Referenced Mating Feature Set ID (0076,0080)
COMPONENT_2_REFERENCED_ID | Component 2 Referenced ID (0076,00A0)
COMPONENT_2_REFERENCED_MATING_FEATURE_ID | Component 2 Referenced Mating Feature ID (0076,00C0)
COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID | Component 2 Referenced Mating Feature Set ID (0076,00B0)
COMPONENT_ASSEMBLY_SEQUENCE | Component Assembly Sequence (0076,0060)
COMPONENT_ID | Component ID (0076,0055)
COMPONENT_INPUT_SEQUENCE | Component Input Sequence (0070,1803)
COMPONENT_MANUFACTURER | Component Manufacturer (0014,0028)
COMPONENT_MANUFACTURING_PROCEDURE | Component Manufacturing Procedure (0014,0025)
COMPONENT_REFERENCE_SYSTEM_RETIRED | Component Reference System RETIRED (0014,0024)
COMPONENT_SEQUENCE | Component Sequence (0076,0040)
COMPONENT_SHAPE | Component Shape (0014,0050)
COMPONENT_TYPE | Component Type (0070,1802)
COMPONENT_TYPE_CODE_SEQUENCE | Component Type Code Sequence (0076,0034)
COMPONENT_TYPES_SEQUENCE | Component Types Sequence (0076,0032)
COMPOSITING_METHOD_RETIRED | Compositing Method RETIRED (0070,1206)
COMPOUND_GRAPHIC_INSTANCE_ID | Compound Graphic Instance ID (0070,0226)
COMPOUND_GRAPHIC_SEQUENCE | Compound Graphic Sequence (0070,0209)
COMPOUND_GRAPHIC_TYPE | Compound Graphic Type (0070,0294)
COMPOUND_GRAPHIC_UNITS | Compound Graphic Units (0070,0282)
COMPRESSION_CODE_RETIRED | Compression Code RETIRED (0028,0060)
COMPRESSION_CONTACT_AREA | Compression Contact Area (0018,11A5)
COMPRESSION_FORCE | Compression Force (0018,11A2)
COMPRESSION_PRESSURE | Compression Pressure (0018,11A3)
CONCATENATION_FRAME_OFFSET_NUMBER | Concatenation Frame Offset Number (0020,9228)
CONCATENATION_UID | Concatenation UID (0020,9161)
CONCEPT_CODE_SEQUENCE | Concept Code Sequence (0040,A168)
CONCEPT_NAME_CODE_SEQUENCE | Concept Name Code Sequence (0040,A043)
CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT | Conceptual Volume Blocking Constraint (3010,0068)
CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE | Conceptual Volume Category Code Sequence (3010,0067)
CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION | Conceptual Volume Combination Description (3010,000F)
CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION | Conceptual Volume Combination Expression (3010,000C)
CONCEPTUAL_VOLUME_COMBINATION_FLAG | Conceptual Volume Combination Flag (3010,000E)
CONCEPTUAL_VOLUME_CONSTITUENT_INDEX | Conceptual Volume Constituent Index (3010,000D)
CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE | Conceptual Volume Constituent Segmentation Reference Sequence (3010,0012)
CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE | Conceptual Volume Constituent Sequence (3010,0008)
CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE | Conceptual Volume Derivation Algorithm Sequence (3010,0016)
CONCEPTUAL_VOLUME_DESCRIPTION | Conceptual Volume Description (3010,0017)
CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE | Conceptual Volume Identification Sequence (3010,00A0)
CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE | Conceptual Volume Optimization Precedence (3010,0066)
CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG | Conceptual Volume Segmentation Defined Flag (3010,0010)
CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE | Conceptual Volume Segmentation Reference Sequence (3010,0011)
CONCEPTUAL_VOLUME_SEQUENCE | Conceptual Volume Sequence (3010,0025)
CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE | Conceptual Volume Type Code Sequence (3010,0069)
CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE | Conceptual Volume Type Modifier Code Sequence (3010,006A)
CONCEPTUAL_VOLUME_UID | Conceptual Volume UID (3010,0006)
CONDENSER_LENS_POWER | Condenser Lens Power (0048,0111)
CONFIDENTIALITY_CODE | Confidentiality Code (0040,1008)
CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION | Confidentiality Constraint on Patient Data Description (0040,3001)
CONFIGURATION_DESCRIPTION | Configuration Description (0028,700D)
CONFIGURATION_ID | Configuration ID (0028,700B)
CONFIGURATION_INFORMATION | Configuration Information (2010,0150)
CONFIGURATION_INFORMATION_DESCRIPTION | Configuration Information Description (2010,0152)
CONFIGURATION_NAME | Configuration Name (0028,700C)
CONFIGURATION_QA_RESULTS_SEQUENCE | Configuration QA Results Sequence (0028,7011)
CONFIRMATION_SEQUENCE | Confirmation Sequence (300A,073F)
CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE | Consent for Clinical Trial Use Sequence (0012,0083)
CONSENT_FOR_DISTRIBUTION_FLAG | Consent for Distribution Flag (0012,0085)
CONSTANT_VOLUME_FLAG | Constant Volume Flag (0018,9333)
CONSTITUENT_CONCEPTUAL_VOLUME_UID | Constituent Conceptual Volume UID (3010,0013)
CONSTRAINT_TYPE | Constraint Type (0082,0032)
CONSTRAINT_VALUE_SEQUENCE | Constraint Value Sequence (0082,0034)
CONSTRAINT_VIOLATION_CONDITION | Constraint Violation Condition (0082,0037)
CONSTRAINT_VIOLATION_SIGNIFICANCE | Constraint Violation Significance (0082,0036)
CONSTRAINT_WEIGHT | Constraint Weight (300A,0021)
CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Consulting Physician Identification Sequence (0008,009D)
CONSULTING_PHYSICIANS_NAME | Consulting Physician's Name (0008,009C)
CONTACT_DISPLAY_NAME | Contact Display Name (0074,100C)
CONTACT_METHOD | Contact Method (0016,1003)
CONTACT_URI | Contact URI (0074,100A)
CONTAINER_COMPONENT_DESCRIPTION | Container Component Description (0050,001E)
CONTAINER_COMPONENT_DIAMETER | Container Component Diameter (0050,001D)
CONTAINER_COMPONENT_ID | Container Component ID (0050,001B)
CONTAINER_COMPONENT_LENGTH | Container Component Length (0050,001C)
CONTAINER_COMPONENT_MATERIAL | Container Component Material (0050,001A)
CONTAINER_COMPONENT_SEQUENCE | Container Component Sequence (0040,0520)
CONTAINER_COMPONENT_THICKNESS | Container Component Thickness (0050,0013)
CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE | Container Component Type Code Sequence (0050,0012)
CONTAINER_COMPONENT_WIDTH | Container Component Width (0050,0015)
CONTAINER_DESCRIPTION | Container Description (0040,051A)
CONTAINER_FILE_TYPE | Container File Type (0008,040A)
CONTAINER_IDENTIFIER | Container Identifier (0040,0512)
CONTAINER_TYPE_CODE_SEQUENCE | Container Type Code Sequence (0040,0518)
CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE | Content Creator's Identification Code Sequence (0070,0086)
CONTENT_CREATORS_IDENTIFICATION_SEQUENCE | Alias for tag CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE (0070,0086)
CONTENT_CREATORS_NAME | Content Creator's Name (0070,0084)
CONTENT_DATE | Content Date (0008,0023)
CONTENT_DESCRIPTION | Content Description (0070,0081)
CONTENT_ITEM_MODIFIER_SEQUENCE | Content Item Modifier Sequence (0040,0441)
CONTENT_LABEL | Content Label (0070,0080)
CONTENT_QUALIFICATION | Content Qualification (0018,9004)
CONTENT_SEQUENCE | Content Sequence (0040,A730)
CONTENT_TEMPLATE_SEQUENCE | Content Template Sequence (0040,A504)
CONTENT_TIME | Content Time (0008,0033)
CONTEXT_GROUP_EXTENSION_CREATOR_UID | Context Group Extension Creator UID (0008,010D)
CONTEXT_GROUP_EXTENSION_FLAG | Context Group Extension Flag (0008,010B)
CONTEXT_GROUP_IDENTIFICATION_SEQUENCE | Context Group Identification Sequence (0008,0123)
CONTEXT_GROUP_LOCAL_VERSION | Context Group Local Version (0008,0107)
CONTEXT_GROUP_VERSION | Context Group Version (0008,0106)
CONTEXT_IDENTIFIER | Context Identifier (0008,010F)
CONTEXT_UID | Context UID (0008,0117)
CONTINUATION_END_METERSET | Continuation End Meterset (0074,0121)
CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA | Continuation End Total Reference Air Kerma (0074,1403)
CONTINUATION_PULSE_NUMBER | Continuation Pulse Number (0074,1404)
CONTINUATION_START_METERSET | Continuation Start Meterset (0074,0120)
CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA | Continuation Start Total Reference Air Kerma (0074,1402)
CONTINUITY_OF_CONTENT | Continuity Of Content (0040,A050)
CONTOUR_DATA | Contour Data (3006,0050)
CONTOUR_GEOMETRIC_TYPE | Contour Geometric Type (3006,0042)
CONTOUR_IMAGE_SEQUENCE | Contour Image Sequence (3006,0016)
CONTOUR_NUMBER | Contour Number (3006,0048)
CONTOUR_OFFSET_VECTOR_RETIRED | Contour Offset Vector RETIRED (3006,0045)
CONTOUR_SEQUENCE | Contour Sequence (3006,0040)
CONTOUR_SLAB_THICKNESS_RETIRED | Contour Slab Thickness RETIRED (3006,0044)
CONTOUR_UNCERTAINTY_RADIUS | Contour Uncertainty Radius (0070,0312)
CONTRAINDICATIONS_CODE_SEQUENCE | Contraindications Code Sequence (0018,990B)
CONTRAST | Contrast (0016,0048)
CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE | Contrast Administration Profile Sequence (0018,9340)
CONTRAST_ALLERGIES | Alias for tag ALLERGIES (0010,2110)
CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE | Contrast/Bolus Administration Route Sequence (0018,0014)
CONTRAST_BOLUS_AGENT | Contrast/Bolus Agent (0018,0010)
CONTRAST_BOLUS_AGENT_ADMINISTERED | Contrast/Bolus Agent Administered (0018,9342)
CONTRAST_BOLUS_AGENT_DETECTED | Contrast/Bolus Agent Detected (0018,9343)
CONTRAST_BOLUS_AGENT_NUMBER | Contrast/Bolus Agent Number (0018,9337)
CONTRAST_BOLUS_AGENT_PHASE | Contrast/Bolus Agent Phase (0018,9344)
CONTRAST_BOLUS_AGENT_SEQUENCE | Contrast/Bolus Agent Sequence (0018,0012)
CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG | Contrast/Bolus Auto Injection Trigger Flag (0018,11B6)
CONTRAST_BOLUS_INGREDIENT | Contrast/Bolus Ingredient (0018,1048)
CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE | Contrast/Bolus Ingredient Code Sequence (0018,9338)
CONTRAST_BOLUS_INGREDIENT_CONCENTRATION | Contrast/Bolus Ingredient Concentration (0018,1049)
CONTRAST_BOLUS_INGREDIENT_OPAQUE | Contrast/Bolus Ingredient Opaque (0018,9425)
CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME | Contrast/Bolus Ingredient Percent by Volume (0052,0001)
CONTRAST_BOLUS_INJECTION_DELAY | Contrast/Bolus Injection Delay (0018,11B7)
CONTRAST_BOLUS_ROUTE | Contrast/Bolus Route (0018,1040)
CONTRAST_BOLUS_START_TIME | Contrast/Bolus Start Time (0018,1042)
CONTRAST_BOLUS_STOP_TIME | Contrast/Bolus Stop Time (0018,1043)
CONTRAST_BOLUS_T1_RELAXIVITY | Contrast/Bolus T1 Relaxivity (0018,0013)
CONTRAST_BOLUS_TOTAL_DOSE | Contrast/Bolus Total Dose (0018,1044)
CONTRAST_BOLUS_USAGE_SEQUENCE | Contrast/Bolus Usage Sequence (0018,9341)
CONTRAST_BOLUS_VOLUME | Contrast/Bolus Volume (0018,1041)
CONTRAST_FLOW_DURATION | Contrast Flow Duration (0018,1047)
CONTRAST_FLOW_DURATIONS | Alias for tag CONTRAST_FLOW_DURATION (0018,1047)
CONTRAST_FLOW_RATE | Contrast Flow Rate (0018,1046)
CONTRAST_FLOW_RATES | Alias for tag CONTRAST_FLOW_RATE (0018,1046)
CONTRAST_FRAME_AVERAGING | Contrast Frame Averaging (0028,6112)
CONTRIBUTING_EQUIPMENT_SEQUENCE | Contributing Equipment Sequence (0018,A001)
CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE | Contributing SOP Instances Reference Sequence (0020,9529)
CONTRIBUTING_SOURCES_SEQUENCE | Contributing Sources Sequence (0018,9506)
CONTRIBUTION_DATETIME | Contribution DateTime (0018,A002)
CONTRIBUTION_DESCRIPTION | Contribution Description (0018,A003)
CONTROL_POINT_3D_POSITION | Control Point 3D Position (300A,02D4)
CONTROL_POINT_DELIVERY_SEQUENCE | Control Point Delivery Sequence (3008,0040)
CONTROL_POINT_INDEX | Control Point Index (300A,0112)
CONTROL_POINT_ORIENTATION | Control Point Orientation (300A,0412)
CONTROL_POINT_RELATIVE_POSITION | Control Point Relative Position (300A,02D2)
CONTROL_POINT_SEQUENCE | Control Point Sequence (300A,0111)
CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE | Conventional Control Point Verification Sequence (0074,104C)
CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE | Conventional Machine Verification Sequence (0074,1044)
CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE | Conversion Source Attributes Sequence (0020,9172)
CONVERSION_TYPE | Conversion Type (0008,0064)
CONVOLUTION_KERNEL | Convolution Kernel (0018,1210)
CONVOLUTION_KERNEL_GROUP | Convolution Kernel Group (0018,9316)
COORDINATE_START_VALUE_RETIRED | Coordinate Start Value RETIRED (5000,0112)
COORDINATE_STEP_VALUE_RETIRED | Coordinate Step Value RETIRED (5000,0114)
COORDINATE_SYSTEM_AXES_SEQUENCE | Coordinate System Axes Sequence (0014,2204)
COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED | Coordinate System Axis Code Sequence RETIRED (0040,08DA)
COORDINATE_SYSTEM_AXIS_DESCRIPTION | Coordinate System Axis Description (0014,2206)
COORDINATE_SYSTEM_AXIS_NUMBER | Coordinate System Axis Number (0014,220A)
COORDINATE_SYSTEM_AXIS_TYPE | Coordinate System Axis Type (0014,220C)
COORDINATE_SYSTEM_AXIS_UNITS | Coordinate System Axis Units (0014,220E)
COORDINATE_SYSTEM_AXIS_VALUES | Coordinate System Axis Values (0014,2210)
COORDINATE_SYSTEM_DATA_SET_MAPPING | Coordinate System Data Set Mapping (0014,2208)
COORDINATE_SYSTEM_NUMBER_OF_AXES | Coordinate System Number of Axes (0014,2202)
COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX | Coordinate System Transform Rotation and Scale Matrix (0014,222A)
COORDINATE_SYSTEM_TRANSFORM_SEQUENCE | Coordinate System Transform Sequence (0014,2220)
COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX | Coordinate System Transform Translation Matrix (0014,222C)
COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED | Coordinates Set Geometric Type (Trial) RETIRED (0040,A290)
COPIES_RETIRED | Copies RETIRED (0000,5170)
CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE | Cornea Measurement Method Code Sequence (0046,0116)
CORNEA_MEASUREMENTS_SEQUENCE | Cornea Measurements Sequence (0046,0110)
CORNEAL_AXIS | Corneal Axis (0046,0115)
CORNEAL_ECCENTRICITY_INDEX | Corneal Eccentricity Index (0046,0234)
CORNEAL_I_S_VALUE | Corneal I-S Value (0046,0224)
CORNEAL_POINT_ESTIMATED | Corneal Point Estimated (0046,0248)
CORNEAL_POINT_LOCATION | Corneal Point Location (0046,0247)
CORNEAL_POWER | Corneal Power (0046,0114)
CORNEAL_SIZE | Corneal Size (0046,0046)
CORNEAL_SIZE_SEQUENCE | Corneal Size Sequence (0046,0047)
CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION | Corneal Topography Map Quality Evaluation (0046,0242)
CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE | Corneal Topography Map Type Code Sequence (0046,0207)
CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE | Corneal Topography Mapping Normals Sequence (0046,0210)
CORNEAL_TOPOGRAPHY_SURFACE | Corneal Topography Surface (0046,0201)
CORNEAL_VERTEX_LOCATION | Corneal Vertex Location (0046,0202)
CORNEAL_WAVEFRONT | Corneal Wavefront (0046,0253)
CORRECTED_IMAGE | Corrected Image (0028,0051)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL | Corrected Localized Deviation From Normal (0024,0079)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED | Corrected Localized Deviation From Normal Calculated (0024,0078)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY | Corrected Localized Deviation From Normal Probability (0024,0081)
CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED | Corrected Localized Deviation From Normal Probability Calculated (0024,0080)
CORRECTED_PARAMETER_SEQUENCE | Corrected Parameter Sequence (3008,0068)
CORRECTED_VALUE | Alias for tag CORRECTION_VALUE (3008,006A)
CORRECTION_VALUE | Correction Value (3008,006A)
COUNT_LOSS_NORMALIZATION_CORRECTED | Count Loss Normalization Corrected (0018,9764)
COUNT_RATE | Count Rate (0018,1243)
COUNTRY_OF_RESIDENCE | Country of Residence (0010,2150)
COUNTS_ACCUMULATED | Counts Accumulated (0018,0070)
COUNTS_INCLUDED_RETIRED | Counts Included RETIRED (0054,1400)
COUNTS_SOURCE | Counts Source (0054,1002)
COUPLING_MEDIUM | Coupling Medium (0014,4056)
COUPLING_TECHNIQUE | Coupling Technique (0014,4054)
COUPLING_VELOCITY | Coupling Velocity (0014,4057)
COVERAGE_OF_K_SPACE | Coverage of k-Space (0018,9094)
CRANIAL_THERMAL_INDEX | Cranial Thermal Index (0018,5026)
CREATION_DATE | Creation Date (2100,0040)
CREATION_TIME | Creation Time (2100,0050)
CREATOR_VERSION_UID | Creator-Version UID (0008,9123)
CROP | Crop (0070,1204)
CROPPING_SPECIFICATION_INDEX | Cropping Specification Index (0070,1205)
CROPPING_SPECIFICATION_NUMBER | Cropping Specification Number (0070,1309)
CSS_FONT_NAME | CSS Font Name (0070,0229)
CT_ACQUISITION_DETAILS_SEQUENCE | CT Acquisition Details Sequence (0018,9304)
CT_ACQUISITION_TYPE_SEQUENCE | CT Acquisition Type Sequence (0018,9301)
CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE | CT Additional X-Ray Source Sequence (0018,9360)
CT_EXPOSURE_SEQUENCE | CT Exposure Sequence (0018,9321)
CT_GEOMETRY_SEQUENCE | CT Geometry Sequence (0018,9312)
CT_IMAGE_FRAME_TYPE_SEQUENCE | CT Image Frame Type Sequence (0018,9329)
CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE | CT Imaging Acquisition Parameter Sequence (3002,0126)
CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE | Alias for tag CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE (0018,9360)
CT_POSITION_SEQUENCE | CT Position Sequence (0018,9326)
CT_RECONSTRUCTION_SEQUENCE | CT Reconstruction Sequence (0018,9314)
CT_TABLE_DYNAMICS_SEQUENCE | CT Table Dynamics Sequence (0018,9308)
CT_X_RAY_DETAILS_SEQUENCE | CT X-Ray Details Sequence (0018,9325)
CTDI_PHANTOM_TYPE_CODE_SEQUENCE | CTDI Phantom Type Code Sequence (0018,9346)
CTDIVOL | CTDIvol (0018,9345)
CTDIVOL_NOTIFICATION_TRIGGER | CTDIvol Notification Trigger (0018,9942)
CUMULATIVE_DOSE_REFERENCE_COEFFICIENT | Cumulative Dose Reference Coefficient (300A,010C)
CUMULATIVE_DOSE_TO_DOSE_REFERENCE | Cumulative Dose to Dose Reference (3008,0052)
CUMULATIVE_METERSET | Cumulative Meterset (300A,063C)
CUMULATIVE_METERSET_WEIGHT | Cumulative Meterset Weight (300A,0134)
CUMULATIVE_TIME_WEIGHT | Cumulative Time Weight (300A,02D6)
CURRENT_CONFIGURATION_ID | Current Configuration ID (0028,7002)
CURRENT_FRACTION_NUMBER | Current Fraction Number (3008,0022)
CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Current Frame Functional Groups Sequence (0006,0001)
CURRENT_OBSERVER_TRIAL_RETIRED | Current Observer (Trial) RETIRED (0040,A307)
CURRENT_PATIENT_LOCATION | Current Patient Location (0038,0300)
CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE | Current Requested Procedure Evidence Sequence (0040,A375)
CURRENT_TREATMENT_STATUS | Current Treatment Status (3008,0200)
CURVATURE_TYPE | Curvature Type (0014,0052)
CURVE_ACTIVATION_LAYER_RETIRED | Curve Activation Layer RETIRED (5000,1001)
CURVE_DATA_DESCRIPTOR_RETIRED | Curve Data Descriptor RETIRED (5000,0110)
CURVE_DATA_RETIRED | Curve Data RETIRED (5000,3000)
CURVE_DATE_RETIRED | Curve Date RETIRED (0008,0025)
CURVE_DESCRIPTION_RETIRED | Curve Description RETIRED (5000,0022)
CURVE_DIMENSIONS_RETIRED | Curve Dimensions RETIRED (5000,0005)
CURVE_LABEL_RETIRED | Curve Label RETIRED (5000,2500)
CURVE_NUMBER_RETIRED | Curve Number RETIRED (0020,0024)
CURVE_RANGE_RETIRED | Curve Range RETIRED (5000,0106)
CURVE_REFERENCED_OVERLAY_GROUP_RETIRED | Curve Referenced Overlay Group RETIRED (5000,2610)
CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED | Curve Referenced Overlay Sequence RETIRED (5000,2600)
CURVE_TIME_RETIRED | Curve Time RETIRED (0008,0035)
CUSTODIAL_ORGANIZATION_SEQUENCE | Custodial Organization Sequence (0040,A07C)
CUSTOM_RENDERED | Custom Rendered (0016,0041)
CYLINDER_AXIS | Cylinder Axis (0022,0009)
CYLINDER_LENS_POWER | Cylinder Lens Power (0022,0008)
CYLINDER_POWER | Cylinder Power (0046,0147)
CYLINDER_SEQUENCE | Cylinder Sequence (0046,0018)
DAC_AMPLITUDE | DAC Amplitude (0014,403C)
DAC_GAIN_POINTS | DAC Gain Points (0014,4038)
DAC_SEQUENCE | DAC Sequence (0014,4035)
DAC_TIME_POINTS | DAC Time Points (0014,403A)
DAC_TYPE | DAC Type (0014,4036)
DAMPING | Damping (0014,4028)
DARK_CURRENT_COUNTS | Dark Current Counts (0014,3050)
DARK_CURRENT_SEQUENCE | Dark Current Sequence (0014,3040)
DATA_COLLECTION_CENTER_PATIENT | Data Collection Center (Patient) (0018,9313)
DATA_COLLECTION_DIAMETER | Data Collection Diameter (0018,0090)
DATA_ELEMENTS_SIGNED | Data Elements Signed (0400,0020)
DATA_FRAME_ASSIGNMENT_SEQUENCE | Data Frame Assignment Sequence (0028,1401)
DATA_INFORMATION_SEQUENCE | Data Information Sequence (0054,0063)
DATA_OBSERVATION_SEQUENCE | Data Observation Sequence (0024,0325)
DATA_PATH_ASSIGNMENT | Data Path Assignment (0028,1402)
DATA_PATH_ID | Data Path ID (0028,140E)
DATA_POINT_COLUMNS | Data Point Columns (0028,9002)
DATA_POINT_ROWS | Data Point Rows (0028,9001)
DATA_REPRESENTATION | Data Representation (0028,9108)
DATA_SET_DESCRIPTION | Data Set Description (0024,0309)
DATA_SET_NAME | Data Set Name (0024,0306)
DATA_SET_SOURCE | Data Set Source (0024,0308)
DATA_SET_SUBTYPE_RETIRED | Data Set Subtype RETIRED (0008,0041)
DATA_SET_TRAILING_PADDING | Data Set Trailing Padding (FFFC,FFFC)
DATA_SET_TYPE | Alias for tag COMMAND_DATA_SET_TYPE (0000,0800)
DATA_SET_TYPE_RETIRED | Data Set Type RETIRED (0008,0040)
DATA_SET_VERSION | Data Set Version (0024,0307)
DATA_TYPE | Data Type (0018,9808)
DATA_VALUE_REPRESENTATION_RETIRED | Data Value Representation RETIRED (5000,0103)
DATE | Date (0040,A121)
DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED | Date of Document or Verbal Transaction (Trial) RETIRED (0040,A110)
DATE_OF_GAIN_CALIBRATION | Date of Gain Calibration (0014,3076)
DATE_OF_INSTALLATION | Date of Installation (0018,1205)
DATE_OF_LAST_CALIBRATION | Date of Last Calibration (0018,1200)
DATE_OF_LAST_DETECTOR_CALIBRATION | Date of Last Detector Calibration (0018,700C)
DATE_OF_MANUFACTURE | Date of Manufacture (0018,1204)
DATE_OF_SECONDARY_CAPTURE | Date of Secondary Capture (0018,1012)
DATETIME | DateTime (0040,A120)
DATETIME_OF_LAST_CALIBRATION | DateTime of Last Calibration (0018,1202)
DB_DT | dB/dt (0018,1318)
DDL_VALUE | DDL Value (0028,7017)
DE_COUPLED_NUCLEUS | De-coupled Nucleus (0018,9060)
DE_COUPLING | De-coupling (0018,9059)
DE_COUPLING_CHEMICAL_SHIFT_REFERENCE | De-coupling Chemical Shift Reference (0018,9063)
DE_COUPLING_FREQUENCY | De-coupling Frequency (0018,9061)
DE_COUPLING_METHOD | De-coupling Method (0018,9062)
DE_IDENTIFICATION_METHOD | De-identification Method (0012,0063)
DE_IDENTIFICATION_METHOD_CODE_SEQUENCE | De-identification Method Code Sequence (0012,0064)
DEAD_TIME_CORRECTED | Dead Time Corrected (0018,9761)
DEAD_TIME_CORRECTION_FLAG_RETIRED | Dead Time Correction Flag RETIRED (0054,1401)
DEAD_TIME_FACTOR | Dead Time Factor (0054,1324)
DECAY_CORRECTED | Decay Corrected (0018,9758)
DECAY_CORRECTION | Decay Correction (0054,1102)
DECAY_CORRECTION_DATETIME | Decay Correction DateTime (0018,9701)
DECAY_FACTOR | Decay Factor (0054,1321)
DECIMAL_POTENTIAL_VISUAL_ACUITY | Decimal Potential Visual Acuity (0046,0238)
DECIMAL_VISUAL_ACUITY | Decimal Visual Acuity (0046,0137)
DECIMATE_CROP_RESULT | Decimate/Crop Result (2020,00A2)
DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE | Decomposition Algorithm Identification Sequence (0018,9380)
DECOMPOSITION_DESCRIPTION | Decomposition Description (0018,937F)
DECOMPOSITION_MATERIAL_SEQUENCE | Decomposition Material Sequence (0018,9381)
DECOMPOSITION_METHOD | Decomposition Method (0018,937E)
DEFAULT_MAGNIFICATION_TYPE | Default Magnification Type (2010,00A6)
DEFAULT_PRINTER_RESOLUTION_ID | Default Printer Resolution ID (2010,0054)
DEFAULT_SMOOTHING_TYPE | Default Smoothing Type (2010,00A8)
DEFINITION_SOURCE_SEQUENCE | Definition Source Sequence (0008,1156)
DEFORMABLE_REGISTRATION_GRID_SEQUENCE | Deformable Registration Grid Sequence (0064,0005)
DEFORMABLE_REGISTRATION_SEQUENCE | Deformable Registration Sequence (0064,0002)
DEGREE_OF_DILATION | Degree of Dilation (0022,000E)
DEGREE_OF_FREEDOM_ID | Degree of Freedom ID (0068,6410)
DEGREE_OF_FREEDOM_TYPE | Degree of Freedom Type (0068,6420)
DEIDENTIFICATION_ACTION | Deidentification Action (0008,0307)
DEIDENTIFICATION_ACTION_SEQUENCE | Deidentification Action Sequence (0008,0305)
DELAY_LAW_IDENTIFIER | Delay Law Identifier (0014,405C)
DELETION_LOCK | Deletion Lock (0074,1230)
DELINEATED_RADIATION_FIELD_SIZE | Delineated Radiation Field Size (300C,0122)
DELIVERED_CHANNEL_TOTAL_TIME | Delivered Channel Total Time (3008,0134)
DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE | Delivered Depth Dose Parameters Sequence (300A,0506)
DELIVERED_DISTAL_DEPTH | Delivered Distal Depth (300A,0508)
DELIVERED_DISTAL_DEPTH_FRACTION | Delivered Distal Depth Fraction (300A,0507)
DELIVERED_METERSET | Delivered Meterset (3008,0044)
DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS | Delivered Nominal Range Modulated Region Depths (300A,0510)
DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS | Delivered Nominal Range Modulation Fractions (300A,0509)
DELIVERED_NUMBER_OF_PULSES | Delivered Number of Pulses (3008,0138)
DELIVERED_PRIMARY_METERSET | Delivered Primary Meterset (3008,0036)
DELIVERED_PULSE_REPETITION_INTERVAL | Delivered Pulse Repetition Interval (3008,013C)
DELIVERED_REFERENCE_DOSE_DEFINITION | Delivered Reference Dose Definition (300A,0511)
DELIVERED_SECONDARY_METERSET | Delivered Secondary Meterset (3008,0037)
DELIVERED_TREATMENT_TIME | Delivered Treatment Time (3008,003B)
DELIVERY_MAXIMUM_DOSE | Delivery Maximum Dose (300A,0023)
DELIVERY_RATE | Delivery Rate (300A,063D)
DELIVERY_RATE_UNIT_SEQUENCE | Delivery Rate Unit Sequence (300A,063E)
DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE | Delivery Time Structure Code Sequence (3010,0088)
DELIVERY_VERIFICATION_IMAGE_SEQUENCE | Delivery Verification Image Sequence (0074,1030)
DELIVERY_WARNING_DOSE | Delivery Warning Dose (300A,0022)
DENSITY | Density (4010,1018)
DEPTH_DOSE_PARAMETERS_SEQUENCE | Depth Dose Parameters Sequence (300A,0505)
DEPTH_OF_SCAN_FIELD | Depth of Scan Field (0018,5050)
DEPTH_OF_TRANSVERSE_IMAGE | Depth of Transverse Image (0022,0041)
DEPTH_SPATIAL_RESOLUTION | Depth Spatial Resolution (0022,0035)
DEPTH_VALUE_AVERAGING_FLAG | Depth Value Averaging Flag (300A,0093)
DEPTHS_OF_FOCUS | Depth(s) of Focus (0018,9801)
DERIVATION_ALGORITHM_SEQUENCE | Derivation Algorithm Sequence (0022,1612)
DERIVATION_CODE_SEQUENCE | Derivation Code Sequence (0008,9215)
DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE | Derivation Conceptual Volume Sequence (3010,0014)
DERIVATION_DESCRIPTION | Derivation Description (0008,2111)
DERIVATION_IMAGE_SEQUENCE | Derivation Image Sequence (0008,9124)
DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Derivation Implant Assembly Template Sequence (0076,000E)
DERIVATION_IMPLANT_TEMPLATE_SEQUENCE | Derivation Implant Template Sequence (0068,6224)
DESTINATION_AE | Destination AE (2100,0140)
DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE | Detector Activation Offset From Exposure (0018,7016)
DETECTOR_ACTIVE_AREA_ORIENTATION | Detector Active Area Orientation (0018,9558)
DETECTOR_ACTIVE_AREA_TLHC_POSITION | Detector Active Area TLHC Position (0018,9557)
DETECTOR_ACTIVE_DIMENSIONS | Detector Active Dimension(s) (0018,7026)
DETECTOR_ACTIVE_ORIGIN | Detector Active Origin (0018,7028)
DETECTOR_ACTIVE_SHAPE | Detector Active Shape (0018,7024)
DETECTOR_ACTIVE_TIME | Detector Active Time (0018,7014)
DETECTOR_BINNING | Detector Binning (0018,701A)
DETECTOR_CALIBRATION_DATA | Detector Calibration Data (4010,106C)
DETECTOR_CONDITIONS_NOMINAL_FLAG | Detector Conditions Nominal Flag (0018,7000)
DETECTOR_CONFIGURATION | Detector Configuration (0018,7005)
DETECTOR_DESCRIPTION | Detector Description (0018,7006)
DETECTOR_ELEMENT_PHYSICAL_SIZE | Detector Element Physical Size (0018,7020)
DETECTOR_ELEMENT_SIZE | Detector Element Size (0054,1203)
DETECTOR_ELEMENT_SPACING | Detector Element Spacing (0018,7022)
DETECTOR_GEOMETRY | Detector Geometry (0018,9725)
DETECTOR_GEOMETRY_SEQUENCE | Detector Geometry Sequence (4010,0004)
DETECTOR_ID | Detector ID (0018,700A)
DETECTOR_INFORMATION_SEQUENCE | Detector Information Sequence (0054,0022)
DETECTOR_ISOCENTER_PRIMARY_ANGLE | Detector Isocenter Primary Angle (0018,9550)
DETECTOR_ISOCENTER_SECONDARY_ANGLE | Detector Isocenter Secondary Angle (0018,9551)
DETECTOR_LINES_OF_RESPONSE_USED | Detector Lines of Response Used (0054,1104)
DETECTOR_MANUFACTURER_NAME | Detector Manufacturer Name (0018,702A)
DETECTOR_MANUFACTURERS_MODEL_NAME | Detector Manufacturer's Model Name (0018,702B)
DETECTOR_MODE | Detector Mode (0018,7008)
DETECTOR_NORMALIZATION_CORRECTION | Detector Normalization Correction (0018,9768)
DETECTOR_POSITION_SEQUENCE | Detector Position Sequence (0018,9541)
DETECTOR_POSITIONING_TYPE | Detector Positioning Type (3002,012F)
DETECTOR_PRIMARY_ANGLE | Detector Primary Angle (0018,1530)
DETECTOR_SECONDARY_ANGLE | Detector Secondary Angle (0018,1531)
DETECTOR_TEMPERATURE | Detector Temperature (0018,7001)
DETECTOR_TEMPERATURE_SEQUENCE | Detector Temperature Sequence (0014,3020)
DETECTOR_TIME_SINCE_LAST_EXPOSURE | Detector Time Since Last Exposure (0018,7012)
DETECTOR_TYPE | Detector Type (0018,7004)
DETECTOR_VECTOR | Detector Vector (0054,0020)
DETECTOR_X_POSITION_TO_ISOCENTER | Detector X Position to Isocenter (0018,9552)
DETECTOR_Y_POSITION_TO_ISOCENTER | Detector Y Position to Isocenter (0018,9553)
DETECTOR_Z_POSITION_TO_ISOCENTER | Detector Z Position to Isocenter (0018,9554)
DEVIATION_INDEX | Deviation Index (0018,1413)
DEVICE_ALTERNATE_IDENTIFIER | Device Alternate Identifier (3010,001B)
DEVICE_ALTERNATE_IDENTIFIER_FORMAT | Device Alternate Identifier Format (3010,001D)
DEVICE_ALTERNATE_IDENTIFIER_TYPE | Device Alternate Identifier Type (3010,001C)
DEVICE_DESCRIPTION | Device Description (0050,0020)
DEVICE_DIAMETER | Device Diameter (0050,0016)
DEVICE_DIAMETER_UNITS | Device Diameter Units (0050,0017)
DEVICE_ID | Device ID (0018,1003)
DEVICE_INDEX | Device Index (3010,0039)
DEVICE_LABEL | Device Label (3010,002D)
DEVICE_LENGTH | Device Length (0050,0014)
DEVICE_MOTION_CONTROL_SEQUENCE | Device Motion Control Sequence (300A,0450)
DEVICE_MOTION_EXECUTION_MODE | Device Motion Execution Mode (300A,0451)
DEVICE_MOTION_OBSERVATION_MODE | Device Motion Observation Mode (300A,0452)
DEVICE_MOTION_PARAMETER_CODE_SEQUENCE | Device Motion Parameter Code Sequence (300A,0453)
DEVICE_ORDER_INDEX | Device Order Index (300A,065E)
DEVICE_POSITION_PARAMETER_SEQUENCE | Device Position Parameter Sequence (3002,0110)
DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX | Device Position to Equipment Mapping Matrix (3002,010F)
DEVICE_SEQUENCE | Device Sequence (0050,0010)
DEVICE_SERIAL_NUMBER | Device Serial Number (0018,1000)
DEVICE_SETTING_DESCRIPTION | Device Setting Description (0016,004B)
DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE | Device-Specific Acquisition Parameter Sequence (3002,0131)
DEVICE_TYPE_CODE_SEQUENCE | Device Type Code Sequence (3010,002E)
DEVICE_UID | Device UID (0018,1002)
DEVICE_VOLUME | Device Volume (0050,0018)
DIALOG_RECEIVER_RETIRED | Dialog Receiver RETIRED (0000,4000)
DIAMETER_OF_CIRCULAR_OUTLINE | Diameter of Circular Outline (0018,1636)
DIAMETER_OF_VISIBILITY | Diameter of Visibility (0070,0262)
DIAPHRAGM_POSITION | Diaphragm Position (3002,0034)
DICOM_MEDIA_RETRIEVAL_SEQUENCE | DICOM Media Retrieval Sequence (0040,E022)
DICOM_RETRIEVAL_SEQUENCE | DICOM Retrieval Sequence (0040,E021)
DICOM_STORAGE_SEQUENCE | DICOM Storage Sequence (0040,4071)
DICOS_VERSION | DICOS Version (4010,103A)
DIFFUSE_REFLECTION_INTENSITY | Diffuse Reflection Intensity (0070,1704)
DIFFUSION_ACQUISITION_CODE_SEQUENCE | Diffusion Acquisition Code Sequence (0066,0133)
DIFFUSION_ANISOTROPY_TYPE | Diffusion Anisotropy Type (0018,9147)
DIFFUSION_B_MATRIX_SEQUENCE | Diffusion b-matrix Sequence (0018,9601)
DIFFUSION_B_VALUE | Diffusion b-value (0018,9087)
DIFFUSION_B_VALUE_XX | Diffusion b-value XX (0018,9602)
DIFFUSION_B_VALUE_XY | Diffusion b-value XY (0018,9603)
DIFFUSION_B_VALUE_XZ | Diffusion b-value XZ (0018,9604)
DIFFUSION_B_VALUE_YY | Diffusion b-value YY (0018,9605)
DIFFUSION_B_VALUE_YZ | Diffusion b-value YZ (0018,9606)
DIFFUSION_B_VALUE_ZZ | Diffusion b-value ZZ (0018,9607)
DIFFUSION_DIRECTIONALITY | Diffusion Directionality (0018,9075)
DIFFUSION_GRADIENT_DIRECTION_SEQUENCE | Diffusion Gradient Direction Sequence (0018,9076)
DIFFUSION_GRADIENT_ORIENTATION | Diffusion Gradient Orientation (0018,9089)
DIFFUSION_MODEL_CODE_SEQUENCE | Diffusion Model Code Sequence (0066,0134)
DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE | Digital Filter Characteristics Sequence (003A,0326)
DIGITAL_FILTER_ORDER | Digital Filter Order (003A,0327)
DIGITAL_FILTER_TYPE_CODE_SEQUENCE | Digital Filter Type Code Sequence (003A,0328)
DIGITAL_IMAGE_FORMAT_ACQUIRED | Digital Image Format Acquired (0018,1023)
DIGITAL_SIGNATURE_DATETIME | Digital Signature DateTime (0400,0105)
DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE | Digital Signature Purpose Code Sequence (0400,0401)
DIGITAL_SIGNATURE_UID | Digital Signature UID (0400,0100)
DIGITAL_SIGNATURES_SEQUENCE | Digital Signatures Sequence (FFFA,FFFA)
DIGITAL_ZOOM_RATIO | Digital Zoom Ratio (0016,0044)
DIGITIZING_DEVICE_TRANSPORT_DIRECTION | Digitizing Device Transport Direction (0018,2020)
DIMENSION_DESCRIPTION_LABEL | Dimension Description Label (0020,9421)
DIMENSION_INDEX_POINTER | Dimension Index Pointer (0020,9165)
DIMENSION_INDEX_PRIVATE_CREATOR | Dimension Index Private Creator (0020,9213)
DIMENSION_INDEX_SEQUENCE | Dimension Index Sequence (0020,9222)
DIMENSION_INDEX_VALUES | Dimension Index Values (0020,9157)
DIMENSION_ORGANIZATION_SEQUENCE | Dimension Organization Sequence (0020,9221)
DIMENSION_ORGANIZATION_TYPE | Dimension Organization Type (0020,9311)
DIMENSION_ORGANIZATION_UID | Dimension Organization UID (0020,9164)
DIRECT_SEGMENT_REFERENCE_SEQUENCE | Direct Segment Reference Sequence (3010,0023)
DIRECTORY_RECORD_SEQUENCE | Directory Record Sequence (0004,1220)
DIRECTORY_RECORD_TYPE | Directory Record Type (0004,1430)
DISCHARGE_DATE_RETIRED | Discharge Date RETIRED (0038,0030)
DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED | Discharge Diagnosis Code Sequence RETIRED (0038,0044)
DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED | Discharge Diagnosis Description RETIRED (0038,0040)
DISCHARGE_TIME_RETIRED | Discharge Time RETIRED (0038,0032)
DISPLACEMENT_MATRIX | Displacement Matrix (300A,079B)
DISPLACEMENT_REFERENCE_LABEL | Displacement Reference Label (300A,079A)
DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE | Displacement Reference Location Code Sequence (300A,079D)
DISPLAY_CALIBRATION_RESULT_SEQUENCE | Display Calibration Result Sequence (0028,7016)
DISPLAY_DEVICE_TYPE_CODE_SEQUENCE | Display Device Type Code Sequence (0028,7022)
DISPLAY_ENVIRONMENT_SPATIAL_POSITION | Display Environment Spatial Position (0072,0108)
DISPLAY_FILTER_PERCENTAGE | Display Filter Percentage (0028,9411)
DISPLAY_FORMAT_RETIRED | Display Format RETIRED (0000,5110)
DISPLAY_FUNCTION_TYPE | Display Function Type (0028,7019)
DISPLAY_SET_HORIZONTAL_JUSTIFICATION | Display Set Horizontal Justification (0072,0717)
DISPLAY_SET_LABEL | Display Set Label (0072,0203)
DISPLAY_SET_NUMBER | Display Set Number (0072,0202)
DISPLAY_SET_PATIENT_ORIENTATION | Display Set Patient Orientation (0072,0700)
DISPLAY_SET_PRESENTATION_GROUP | Display Set Presentation Group (0072,0204)
DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION | Display Set Presentation Group Description (0072,0206)
DISPLAY_SET_SCROLLING_GROUP | Display Set Scrolling Group (0072,0212)
DISPLAY_SET_VERTICAL_JUSTIFICATION | Display Set Vertical Justification (0072,0718)
DISPLAY_SETS_SEQUENCE | Display Sets Sequence (0072,0200)
DISPLAY_SHADING_FLAG | Display Shading Flag (003A,0246)
DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE | Display Subsystem Configuration Sequence (0028,700A)
DISPLAY_SUBSYSTEM_DESCRIPTION | Display Subsystem Description (0028,7005)
DISPLAY_SUBSYSTEM_ID | Display Subsystem ID (0028,7003)
DISPLAY_SUBSYSTEM_NAME | Display Subsystem Name (0028,7004)
DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE | Display Subsystem QA Results Sequence (0028,7010)
DISPLAY_SUBSYSTEM_SEQUENCE | Display Subsystem Sequence (0028,7023)
DISPLAY_WINDOW_LABEL_VECTOR | Display Window Label Vector (0018,2006)
DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER | Displayed Area Bottom Right Hand Corner (0070,0053)
DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED | Displayed Area Bottom Right Hand Corner (Trial) RETIRED (0070,0051)
DISPLAYED_AREA_SELECTION_SEQUENCE | Displayed Area Selection Sequence (0070,005A)
DISPLAYED_AREA_TOP_LEFT_HAND_CORNER | Displayed Area Top Left Hand Corner (0070,0052)
DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED | Displayed Area Top Left Hand Corner (Trial) RETIRED (0070,0050)
DISPLAYED_Z_VALUE | Displayed Z Value (0018,2046)
DISTAL_DEPTH | Distal Depth (300A,0502)
DISTAL_DEPTH_FRACTION | Distal Depth Fraction (300A,0501)
DISTANCE_BETWEEN_B_SCAN_SLABS | Distance Between B-scan Slabs (0022,1644)
DISTANCE_BETWEEN_FOCAL_PLANES | Distance Between Focal Planes (0048,0014)
DISTANCE_OBJECT_TO_TABLE_TOP | Distance Object to Table Top (0018,9403)
DISTANCE_PUPILLARY_DISTANCE | Distance Pupillary Distance (0046,0060)
DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING | Distance Receptor Plane to Detector Housing (0018,9426)
DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER | Distance Source to Data Collection Center (0018,9335)
DISTANCE_SOURCE_TO_DETECTOR | Distance Source to Detector (0018,1110)
DISTANCE_SOURCE_TO_ENTRANCE | Distance Source to Entrance (0040,0306)
DISTANCE_SOURCE_TO_ISOCENTER | Distance Source to Isocenter (0018,9402)
DISTANCE_SOURCE_TO_PATIENT | Distance Source to Patient (0018,1111)
DISTANCE_SOURCE_TO_SUPPORT_RETIRED | Distance Source to Support RETIRED (0040,0307)
DISTRIBUTION_ADDRESS_RETIRED | Distribution Address RETIRED (4008,011A)
DISTRIBUTION_NAME_RETIRED | Distribution Name RETIRED (4008,0119)
DISTRIBUTION_TYPE | Distribution Type (0012,0084)
DLP_NOTIFICATION_TRIGGER | DLP Notification Trigger (0018,9943)
DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Document Author Identifier Code Sequence (Trial) RETIRED (0040,A068)
DOCUMENT_AUTHOR_TRIAL_RETIRED | Document Author (Trial) RETIRED (0040,A067)
DOCUMENT_CLASS_CODE_SEQUENCE | Document Class Code Sequence (0040,E008)
DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Document Identifier Code Sequence (Trial) RETIRED (0040,A066)
DOCUMENT_TITLE | Document Title (0042,0010)
DOCUMENTING_OBSERVER | Alias for tag VERIFYING_OBSERVER_NAME (0040,A075)
DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Documenting Observer Identifier Code Sequence (Trial) RETIRED (0040,A076)
DOCUMENTING_ORGANIZATION | Alias for tag VERIFYING_ORGANIZATION 0040,A027)
DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Documenting Organization Identifier Code Sequence (Trial) RETIRED (0040,A028)
DOPPLER_CORRECTION_ANGLE | Doppler Correction Angle (0018,6034)
DOPPLER_SAMPLE_VOLUME_X_POSITION | Doppler Sample Volume X Position (0018,6039)
DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED | Doppler Sample Volume X Position (Retired) (0018,6038)
DOPPLER_SAMPLE_VOLUME_Y_POSITION | Doppler Sample Volume Y Position (0018,603B)
DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED | Doppler Sample Volume Y Position (Retired) (0018,603A)
DOSE_CALIBRATION_CONDITIONS_SEQUENCE | Dose Calibration Conditions Sequence (300C,0120)
DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG | Dose Calibration Conditions Verified Flag (300C,0123)
DOSE_CALIBRATION_FACTOR | Dose Calibration Factor (0054,1322)
DOSE_COMMENT | Dose Comment (3004,0006)
DOSE_GRID_SCALING | Dose Grid Scaling (3004,000E)
DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE | Dose Measurement Device Code Sequence (300A,0774)
DOSE_MODE_NAME | Dose Mode Name (0018,11B1)
DOSE_RATE_DELIVERED | Dose Rate Delivered (3008,0048)
DOSE_RATE_SET | Dose Rate Set (300A,0115)
DOSE_REFERENCE_DESCRIPTION | Dose Reference Description (300A,0016)
DOSE_REFERENCE_NUMBER | Dose Reference Number (300A,0012)
DOSE_REFERENCE_POINT_COORDINATES | Dose Reference Point Coordinates (300A,0018)
DOSE_REFERENCE_SEQUENCE | Dose Reference Sequence (300A,0010)
DOSE_REFERENCE_STRUCTURE_TYPE | Dose Reference Structure Type (300A,0014)
DOSE_REFERENCE_TYPE | Dose Reference Type (300A,0020)
DOSE_REFERENCE_UID | Dose Reference UID (300A,0013)
DOSE_SUMMATION_TYPE | Dose Summation Type (3004,000A)
DOSE_TYPE | Dose Type (3004,0004)
DOSE_UNITS | Dose Units (3004,0002)
DOSE_VALUE | Dose Value RETIRED (3004,0012)
DOSE_VALUE_PURPOSE | Dose Value Purpose (300A,061D)
DOSE_VALUE_RETIRED | Dose Value RETIRED (3004,0012)
DOSE_VALUES_SEQUENCE | Dose Values Sequence (300A,061C)
DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE | Dosimetric Objective Evaluation Scope (3010,0063)
DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE | Dosimetric Objective Parameter Sequence (3010,0070)
DOSIMETRIC_OBJECTIVE_PURPOSE | Dosimetric Objective Purpose (3010,0075)
DOSIMETRIC_OBJECTIVE_SEQUENCE | Dosimetric Objective Sequence (3010,006C)
DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE | Dosimetric Objective Type Code Sequence (3010,006D)
DOSIMETRIC_OBJECTIVE_UID | Dosimetric Objective UID (3010,006E)
DOSIMETRIC_OBJECTIVE_WEIGHT | Dosimetric Objective Weight (3010,0074)
DOUBLE_EXPOSURE_FIELD_DELTA | Double Exposure Field Delta (0074,133A)
DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED | Double Exposure Field Delta (Trial) RETIRED (0074,103A)
DOUBLE_EXPOSURE_FLAG | Double Exposure Flag (0074,1034)
DOUBLE_EXPOSURE_METERSET | Double Exposure Meterset (0074,1338)
DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED | Double Exposure Meterset (Trial) RETIRED (0074,1038)
DOUBLE_EXPOSURE_ORDERING | Double Exposure Ordering (0074,1036)
DOUBLE_FLOAT_PIXEL_DATA | Double Float Pixel Data (7FE0,0009)
DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT | Double Float Pixel Padding Range Limit (0028,0125)
DOUBLE_FLOAT_PIXEL_PADDING_VALUE | Double Float Pixel Padding Value (0028,0123)
DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED | Double Float Real World Value First Value Mapped (0040,9214)
DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED | Double Float Real World Value Last Value Mapped (0040,9213)
DOUBLE_POINT_COORDINATES_DATA | Double Point Coordinates Data (0066,0022)
DVH_DATA | DVH Data (3004,0058)
DVH_DOSE_SCALING | DVH Dose Scaling (3004,0052)
DVH_MAXIMUM_DOSE | DVH Maximum Dose (3004,0072)
DVH_MEAN_DOSE | DVH Mean Dose (3004,0074)
DVH_MINIMUM_DOSE | DVH Minimum Dose (3004,0070)
DVH_NORMALIZATION_DOSE_VALUE | DVH Normalization Dose Value (3004,0042)
DVH_NORMALIZATION_POINT | DVH Normalization Point (3004,0040)
DVH_NUMBER_OF_BINS | DVH Number of Bins (3004,0056)
DVH_REFERENCED_ROI_SEQUENCE | DVH Referenced ROI Sequence (3004,0060)
DVH_ROI_CONTRIBUTION_TYPE | DVH ROI Contribution Type (3004,0062)
DVH_SEQUENCE | DVH Sequence (3004,0050)
DVH_TYPE | DVH Type (3004,0001)
DVH_VOLUME_UNITS | DVH Volume Units (3004,0054)
DYNAMIC_RANGE_RETIRED | Dynamic Range RETIRED (0018,5030)
ECHO_NUMBERS | Echo Number(s) (0018,0086)
ECHO_PEAK_POSITION | Echo Peak Position (0018,9298)
ECHO_PLANAR_PULSE_SEQUENCE | Echo Planar Pulse Sequence (0018,9018)
ECHO_PULSE_SEQUENCE | Echo Pulse Sequence (0018,9008)
ECHO_TIME | Echo Time (0018,0081)
ECHO_TRAIN_LENGTH | Echo Train Length (0018,0091)
EDGE_POINT_INDEX_LIST_RETIRED | Edge Point Index List RETIRED (0066,0024)
EFFECTIVE_BIN_ENERGY | Effective Bin Energy (0018,936E)
EFFECTIVE_DATETIME | Effective DateTime (0068,6226)
EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE | Effective Dose Calculation Method Category Code Sequence (3010,0003)
EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE | Effective Dose Calculation Method Code Sequence (3010,0004)
EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION | Effective Dose Calculation Method Description (3010,0005)
EFFECTIVE_DURATION | Effective Duration (0018,0072)
EFFECTIVE_ECHO_TIME | Effective Echo Time (0018,9082)
EFFECTIVE_REFRACTIVE_INDEX | Effective Refractive Index (0052,0004)
EFFECTIVE_SERIES_DURATION | Alias for tag EFFECTIVE_DURATION (0018,0072)
EFFECTIVE_WEDGE_ANGLE | Effective Wedge Angle (300A,00DE)
ELEMENT_DIMENSION_A | Element Dimension A (0014,4014)
ELEMENT_DIMENSION_B | Element Dimension B (0014,4015)
ELEMENT_PITCH_A | Element Pitch A (0014,4016)
ELEMENT_PITCH_B | Element Pitch B (0014,401D)
ELEMENT_SHAPE | Element Shape (0014,4013)
EMITTER_COLOR_TEMPERATURE | Emitter Color Temperature (0016,1002)
EMMETROPIC_MAGNIFICATION | Emmetropic Magnification (0022,000A)
EMPTY_IMAGE_BOX_CIELAB_VALUE | Empty Image Box CIELab Value (0072,0421)
EMPTY_IMAGE_DENSITY | Empty Image Density (2010,0110)
EMPTY_VALUE_MATCHING_SEQUENCE | Empty Value Matching Sequence (0008,0412)
ENCAPSULATED_DOCUMENT | Encapsulated Document (0042,0011)
ENCAPSULATED_DOCUMENT_LENGTH | Encapsulated Document Length (0042,0015)
ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH | Encapsulated Pixel Data Value Total Length (7FE0,0003)
ENCRYPTED_ATTRIBUTES_SEQUENCE | Encrypted Attributes Sequence (0400,0500)
ENCRYPTED_CONTENT | Encrypted Content (0400,0520)
ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID | Encrypted Content Transfer Syntax UID (0400,0510)
END_ACQUISITION_DATETIME | End Acquisition DateTime (0018,9517)
END_CUMULATIVE_METERSET_WEIGHT | End Cumulative Meterset Weight (300C,0009)
END_CUMULATIVE_TIME_WEIGHT | End Cumulative Time Weight (0074,1408)
END_MESSAGE_ID_RETIRED | End Message ID RETIRED (0000,5020)
END_METERSET | End Meterset (3008,007A)
ENDING_RESPIRATORY_AMPLITUDE | Ending Respiratory Amplitude (0020,9248)
ENDING_RESPIRATORY_PHASE | Ending Respiratory Phase (0020,9249)
ENERGY_DERIVATION_CODE_SEQUENCE | Energy Derivation Code Sequence (3002,0133)
ENERGY_UNIT_CODE_SEQUENCE | Energy Unit Code Sequence (300A,0684)
ENERGY_WEIGHTING_FACTOR | Energy Weighting Factor (0018,9353)
ENERGY_WINDOW_CENTERLINE_RETIRED | Energy Window Centerline RETIRED (0018,0032)
ENERGY_WINDOW_INFORMATION_SEQUENCE | Energy Window Information Sequence (0054,0012)
ENERGY_WINDOW_LOWER_LIMIT | Energy Window Lower Limit (0054,0014)
ENERGY_WINDOW_NAME | Energy Window Name (0054,0018)
ENERGY_WINDOW_NUMBER | Energy Window Number (0054,0308)
ENERGY_WINDOW_RANGE_SEQUENCE | Energy Window Range Sequence (0054,0013)
ENERGY_WINDOW_TOTAL_WIDTH_RETIRED | Energy Window Total Width RETIRED (0018,0033)
ENERGY_WINDOW_UPPER_LIMIT | Energy Window Upper Limit (0054,0015)
ENERGY_WINDOW_VECTOR | Energy Window Vector (0054,0010)
ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE | Enhanced Palette Color Lookup Table Sequence (0028,140B)
ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG | Enhanced RT Beam Limiting Device Definition Flag (3008,00A3)
ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE | Enhanced RT Beam Limiting Device Sequence (3008,00A1)
ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE | Enhanced RT Beam Limiting Opening Sequence (3008,00A2)
ENTITY_DESCRIPTION | Entity Description (3010,0037)
ENTITY_LABEL | Entity Label (3010,0035)
ENTITY_LONG_LABEL | Entity Long Label (3010,0038)
ENTITY_NAME | Entity Name (3010,0036)
ENTRANCE_DOSE | Entrance Dose (0040,0302)
ENTRANCE_DOSE_DERIVATION | Entrance Dose Derivation (0040,8303)
ENTRANCE_DOSE_IN_MGY | Entrance Dose in mGy (0040,8302)
ENVIRONMENTAL_CONDITIONS | Environmental Conditions (0014,1040)
EQUIPMENT_ADMINISTRATOR_SEQUENCE | Equipment Administrator Sequence (0028,7000)
EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION | Equipment Coordinate System Identification (0028,9537)
EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION | Equipment Frame of Reference Description (300A,0676)
EQUIPMENT_FRAME_OF_REFERENCE_UID | Equipment Frame of Reference UID (300A,0675)
EQUIPMENT_MODALITY | Equipment Modality (0008,0221)
EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE | Equipment Reference Point Code Sequence (300A,0678)
EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE | Equipment Reference Point Coordinates Sequence (300A,0677)
EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED | Equivalent CDA Document Sequence RETIRED (0040,A090)
EQUIVALENT_CODE_SEQUENCE | Equivalent Code Sequence (0008,0121)
EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE | Equivalent Conceptual Volume Instance Reference Sequence (3010,0009)
EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE | Equivalent Conceptual Volumes Sequence (3010,000A)
EQUIVALENT_PUPIL_RADIUS | Equivalent Pupil Radius (0046,0205)
ERASE_RETIRED | Erase RETIRED (0000,5190)
ERROR_COMMENT | Error Comment (0000,0902)
ERROR_ID | Error ID (0000,0903)
ESTIMATED_DOSE_SAVING_RETIRED | Estimated Dose Saving RETIRED (0018,9324)
ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR | Estimated Radiographic Magnification Factor (0018,1114)
ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE | Ethics Committee Approval Effectiveness End Date (0012,0087)
ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE | Ethics Committee Approval Effectiveness Start Date (0012,0086)
ETHNIC_GROUP | Ethnic Group (0010,2160)
EVALUATION_ATTEMPT | Evaluation Attempt (0014,2008)
EVALUATOR_NAME | Evaluator Name (0014,2006)
EVALUATOR_NUMBER | Evaluator Number (0014,2004)
EVALUATOR_SEQUENCE | Evaluator Sequence (0014,2002)
EVENT_CODE_SEQUENCE | Event Code Sequence (0008,2135)
EVENT_ELAPSED_TIMES | Event Elapsed Time(s) (0008,2130)
EVENT_TIME_OFFSET | Event Time Offset (0008,2134)
EVENT_TIMER_NAMES | Event Timer Name(s) (0008,2132)
EVENT_TIMER_SEQUENCE | Event Timer Sequence (0008,2133)
EVENT_TYPE_ID | Event Type ID (0000,1002)
EXAMINED_BODY_THICKNESS | Examined Body Thickness (0010,9431)
EXCESSIVE_FALSE_NEGATIVES | Excessive False Negatives (0024,0052)
EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG | Excessive False Negatives Data Flag (0024,0051)
EXCESSIVE_FALSE_POSITIVES | Excessive False Positives (0024,0062)
EXCESSIVE_FALSE_POSITIVES_DATA_FLAG | Excessive False Positives Data Flag (0024,0061)
EXCESSIVE_FIXATION_LOSSES | Excessive Fixation Losses (0024,0040)
EXCESSIVE_FIXATION_LOSSES_DATA_FLAG | Excessive Fixation Losses Data Flag (0024,0039)
EXCITATION_ENERGY | Excitation Energy (0018,9823)
EXCITATION_FREQUENCY | Excitation Frequency (0014,4024)
EXCITATION_PULSE_DURATION | Excitation Pulse Duration (0018,9824)
EXCITATION_SPECTRAL_WIDTH | Excitation Spectral Width (0018,9822)
EXCITATION_WAVELENGTH | Excitation Wavelength (0018,9826)
EXCITATION_WAVELENGTH_SEQUENCE | Excitation Wavelength Sequence (0018,9825)
EXCLUDED_INTERVALS_SEQUENCE | Excluded Intervals Sequence (0018,9803)
EXCLUSION_DURATION | Exclusion Duration (0018,9805)
EXCLUSION_START_DATETIME | Exclusion Start DateTime (0018,9804)
EXCLUSIVE_COMPONENT_TYPE | Exclusive Component Type (0076,0036)
EXECUTION_STATUS | Execution Status (2100,0020)
EXECUTION_STATUS_INFO | Execution Status Info (2100,0030)
EXIF_VERSION | EXIF Version (0016,0020)
EXPECTED_COMPLETION_DATE_AND_TIME | Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)
EXPECTED_COMPLETION_DATE_TIME | Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)
EXPECTED_COMPLETION_DATETIME | Expected Completion DateTime (0040,4011)
EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX | Expected In-Vivo Measurement Value Index (300A,0622)
EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE | Expected In-Vivo Measurement Values Sequence (300A,0621)
EXPIRATION_DATETIME | Expiration DateTime (0008,0416)
EXPIRY_DATE | Expiry Date (0014,1020)
EXPOSED_AREA | Exposed Area (0040,0303)
EXPOSURE | Exposure (0018,1152)
EXPOSURE_BIAS_VALUE | Exposure Bias Value (0016,0024)
EXPOSURE_CONTROL_MODE | Exposure Control Mode (0018,7060)
EXPOSURE_CONTROL_MODE_DESCRIPTION | Exposure Control Mode Description (0018,7062)
EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE | Exposure Control Sensing Region Left Vertical Edge (0018,9436)
EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE | Exposure Control Sensing Region Lower Horizontal Edge (0018,9439)
EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE | Exposure Control Sensing Region Right Vertical Edge (0018,9437)
EXPOSURE_CONTROL_SENSING_REGION_SHAPE | Exposure Control Sensing Region Shape (0018,9435)
EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE | Exposure Control Sensing Region Upper Horizontal Edge (0018,9438)
EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE | Exposure Control Sensing Regions Sequence (0018,9434)
EXPOSURE_DOSE_SEQUENCE_RETIRED | Exposure Dose Sequence RETIRED (0040,030E)
EXPOSURE_IN_MAS | Exposure in mAs (0018,9332)
EXPOSURE_IN_UAS | Exposure in uAs (0018,1153)
EXPOSURE_INDEX | Exposure Index (0018,1411)
EXPOSURE_MODE | Exposure Mode (0016,0042)
EXPOSURE_MODULATION_TYPE | Exposure Modulation Type (0018,9323)
EXPOSURE_PROGRAM | Exposure Program (0016,0016)
EXPOSURE_SEQUENCE | Exposure Sequence (3002,0030)
EXPOSURE_STATUS | Exposure Status (0018,7064)
EXPOSURE_TIME | Exposure Time (0018,1150)
EXPOSURE_TIME_IN_MS | Exposure Time in ms (0018,9328)
EXPOSURE_TIME_IN_SECONDS | Exposure Time in Seconds (0016,0004)
EXPOSURE_TIME_IN_US | Exposure Time in uS (0018,8150)
EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION | Exposures on Detector Since Last Calibration (0018,7010)
EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED | Exposures on Detector Since Manufactured (0018,7011)
EXPOSURES_ON_PLATE | Exposures on Plate (0018,1404)
EXTENDED_DEPTH_OF_FIELD | Extended Depth of Field (0048,0012)
EXTENDED_MATCHING_MECHANISMS | Extended Matching Mechanisms (0008,040F)
EXTENDED_OFFSET_TABLE | Extended Offset Table (7FE0,0001)
EXTENDED_OFFSET_TABLE_LENGTHS | Extended Offset Table Lengths (7FE0,0002)
EXTERNAL_CONTOUR_ENTRY_POINT | External Contour Entry Point (300A,0133)
F_NUMBER | F-Number (0016,0005)
FACET_SEQUENCE | Facet Sequence (0066,0034)
FAILED_ATTRIBUTES_SEQUENCE | Failed Attributes Sequence (0074,1048)
FAILED_SOP_INSTANCE_UID_LIST | Failed SOP Instance UID List (0008,0058)
FAILED_SOP_SEQUENCE | Failed SOP Sequence (0008,1198)
FAILURE_ATTRIBUTES | Failure Attributes (2200,000E)
FAILURE_REASON | Failure Reason (0008,1197)
FALSE_NEGATIVES_ESTIMATE | False Negatives Estimate (0024,0046)
FALSE_NEGATIVES_ESTIMATE_FLAG | False Negatives Estimate Flag (0024,0045)
FALSE_NEGATIVES_QUANTITY | False Negatives Quantity (0024,0050)
FALSE_POSITIVES_ESTIMATE | False Positives Estimate (0024,0054)
FALSE_POSITIVES_ESTIMATE_FLAG | False Positives Estimate Flag (0024,0053)
FALSE_POSITIVES_QUANTITY | False Positives Quantity (0024,0060)
FIDUCIAL_DESCRIPTION | Fiducial Description (0070,030F)
FIDUCIAL_IDENTIFIER | Fiducial Identifier (0070,0310)
FIDUCIAL_IDENTIFIER_CODE_SEQUENCE | Fiducial Identifier Code Sequence (0070,0311)
FIDUCIAL_SEQUENCE | Fiducial Sequence (0070,031E)
FIDUCIAL_SET_SEQUENCE | Fiducial Set Sequence (0070,031C)
FIDUCIAL_UID | Fiducial UID (0070,031A)
FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE | Fiducials Property Category Code Sequence (0070,031F)
FIELD_OF_VIEW_DESCRIPTION | Field of View Description (0018,9433)
FIELD_OF_VIEW_DIMENSIONS | Field of View Dimension(s) (0018,1149)
FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT | Field of View Dimension(s) in Float (0018,9461)
FIELD_OF_VIEW_HORIZONTAL_FLIP | Field of View Horizontal Flip (0018,7034)
FIELD_OF_VIEW_ORIGIN | Field of View Origin (0018,7030)
FIELD_OF_VIEW_ROTATION | Field of View Rotation (0018,7032)
FIELD_OF_VIEW_SEQUENCE | Field of View Sequence (0018,9432)
FIELD_OF_VIEW_SHAPE | Field of View Shape (0018,1147)
FILE_ACCESS_SEQUENCE | File Access Sequence (0008,041A)
FILE_ACCESS_URI | File Access URI (0008,0409)
FILE_LENGTH_IN_CONTAINER | File Length in Container (0008,040D)
FILE_META_INFORMATION_GROUP_LENGTH | File Meta Information Group Length (0002,0000)
FILE_META_INFORMATION_VERSION | File Meta Information Version (0002,0001)
FILE_OFFSET_IN_CONTAINER | File Offset in Container (0008,040C)
FILE_SET_ACCESS_SEQUENCE | File Set Access Sequence (0008,0419)
FILE_SET_CONSISTENCY_FLAG | File-set Consistency Flag (0004,1212)
FILE_SET_DESCRIPTOR_FILE_ID | File-set Descriptor File ID (0004,1141)
FILE_SET_ID | File-set ID (0004,1130)
FILE_SOURCE | File Source (0016,003A)
FILENAME_IN_CONTAINER | Filename in Container (0008,040B)
FILL_MODE | Fill Mode (0070,0257)
FILL_PATTERN | Fill Pattern (0070,0256)
FILL_STYLE_SEQUENCE | Fill Style Sequence (0070,0233)
FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST | Filler Order Number / Imaging Service Request (0040,2017)
FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED | Filler Order Number Imaging Service Request (Retired) (0040,2007)
FILLER_ORDER_NUMBER_PROCEDURE_RETIRED | Filler Order Number / Procedure RETIRED (0040,1007)
FILM_BOX_CONTENT_SEQUENCE_RETIRED | Film Box Content Sequence RETIRED (2130,0030)
FILM_CONSUMPTION_SEQUENCE | Film Consumption Sequence (0040,0321)
FILM_DESTINATION | Film Destination (2000,0040)
FILM_ORIENTATION | Film Orientation (2010,0040)
FILM_SESSION_LABEL | Film Session Label (2000,0050)
FILM_SIZE_ID | Film Size ID (2010,0050)
FILTER_BEAM_PATH_LENGTH_MAXIMUM | Filter Beam Path Length Maximum (0018,7058)
FILTER_BEAM_PATH_LENGTH_MINIMUM | Filter Beam Path Length Minimum (0018,7056)
FILTER_BY_ATTRIBUTE_PRESENCE | Filter-by Attribute Presence (0072,0404)
FILTER_BY_CATEGORY | Filter-by Category (0072,0402)
FILTER_BY_OPERATOR | Filter-by Operator (0072,0406)
FILTER_HIGH_FREQUENCY | Filter High Frequency (003A,0221)
FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE | Filter High Frequency Characteristics Sequence (003A,0319)
FILTER_LOOKUP_TABLE_DATA | Filter Lookup Table Data (003A,032E)
FILTER_LOOKUP_TABLE_DESCRIPTION | Filter Lookup Table Description (003A,032B)
FILTER_LOOKUP_TABLE_SEQUENCE | Filter Lookup Table Sequence (003A,032A)
FILTER_LOW_FREQUENCY | Filter Low Frequency (003A,0220)
FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE | Filter Low Frequency Characteristics Sequence (003A,0318)
FILTER_MATERIAL | Filter Material (0018,7050)
FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION | Filter Material Used in Gain Calibration (0014,3074)
FILTER_OPERATIONS_SEQUENCE | Filter Operations Sequence (0072,0400)
FILTER_THICKNESS_MAXIMUM | Filter Thickness Maximum (0018,7054)
FILTER_THICKNESS_MINIMUM | Filter Thickness Minimum (0018,7052)
FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION | Filter Thickness Used in Gain Calibration (0014,3075)
FILTER_TYPE | Filter Type (0018,1160)
FINAL_CUMULATIVE_METERSET_WEIGHT | Final Cumulative Meterset Weight (300A,010E)
FINAL_CUMULATIVE_TIME_WEIGHT | Final Cumulative Time Weight (300A,02C8)
FIND_LOCATION_RETIRED | Find Location RETIRED (0000,0400)
FINDINGS_FLAG_TRIAL_RETIRED | Findings Flag (Trial) RETIRED (0040,A007)
FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED | Findings Group Recording Date (Trial) RETIRED (0040,A023)
FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED | Findings Group Recording Time (Trial) RETIRED (0040,A024)
FINDINGS_GROUP_UID_TRIAL_RETIRED | Findings Group UID (Trial) RETIRED (0040,A021)
FINDINGS_SEQUENCE_TRIAL_RETIRED | Findings Sequence (Trial) RETIRED (0040,A020)
FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED | Findings Source Category Code Sequence (Trial) RETIRED (0040,A026)
FINITE_VOLUME | Finite Volume (0066,000E)
FIRST_A_LINE_LOCATION | First A-line Location (0052,0034)
FIRST_ORDER_PHASE_CORRECTION | First Order Phase Correction (0018,9198)
FIRST_ORDER_PHASE_CORRECTION_ANGLE | First Order Phase Correction Angle (5600,0010)
FIRST_TREATMENT_DATE | First Treatment Date (3008,0054)
FIXATION_CHECKED_QUANTITY | Fixation Checked Quantity (0024,0035)
FIXATION_DEVICE_DESCRIPTION | Fixation Device Description (300A,0196)
FIXATION_DEVICE_LABEL | Fixation Device Label (300A,0194)
FIXATION_DEVICE_PITCH_ANGLE | Fixation Device Pitch Angle (300A,0199)
FIXATION_DEVICE_POSITION | Fixation Device Position (300A,0198)
FIXATION_DEVICE_ROLL_ANGLE | Fixation Device Roll Angle (300A,019A)
FIXATION_DEVICE_SEQUENCE | Fixation Device Sequence (300A,0190)
FIXATION_DEVICE_TYPE | Fixation Device Type (300A,0192)
FIXATION_EYE | Fixation Eye (300A,0150)
FIXATION_LIGHT_AZIMUTHAL_ANGLE | Fixation Light Azimuthal Angle (300A,0356)
FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE | Fixation Light Azimuthal Angle Tolerance (300A,0154)
FIXATION_LIGHT_POLAR_ANGLE | Fixation Light Polar Angle (300A,0358)
FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE | Fixation Light Polar Angle Tolerance (300A,0155)
FIXATION_METHOD_CODE_SEQUENCE | Fixation Method Code Sequence (0068,63AC)
FIXATION_MONITORING_CODE_SEQUENCE | Fixation Monitoring Code Sequence (0024,0033)
FIXATION_SEQUENCE | Fixation Sequence (0024,0032)
FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE | Fixed RT Beam Delimiter Device Sequence (300A,0646)
FLASH_ENERGY | Flash Energy (0016,0036)
FLASH_FIRING_STATUS | Flash Firing Status (0016,0011)
FLASH_FUNCTION_PRESENT | Flash Function Present (0016,0014)
FLASH_MODE | Flash Mode (0016,0013)
FLASH_RED_EYE_MODE | Flash Red Eye Mode (0016,0015)
FLASH_RETURN_STATUS | Flash Return Status (0016,0012)
FLAT_CORNEAL_AXIS_SEQUENCE | Flat Corneal Axis Sequence (0046,0113)
FLAT_KERATOMETRIC_AXIS_SEQUENCE | Flat Keratometric Axis Sequence (0046,0080)
FLIP_ANGLE | Flip Angle (0018,1314)
FLOAT_PIXEL_DATA | Float Pixel Data (7FE0,0008)
FLOAT_PIXEL_PADDING_RANGE_LIMIT | Float Pixel Padding Range Limit (0028,0124)
FLOAT_PIXEL_PADDING_VALUE | Float Pixel Padding Value (0028,0122)
FLOATING_POINT_VALUE | Floating Point Value (0040,A161)
FLOATING_POINT_VALUES | Floating Point Values (0066,0125)
FLOW_COMPENSATION | Flow Compensation (0018,9010)
FLOW_COMPENSATION_DIRECTION | Flow Compensation Direction (0018,9183)
FLOW_IDENTIFIER | Flow Identifier (0034,0002)
FLOW_IDENTIFIER_SEQUENCE | Flow Identifier Sequence (0034,0001)
FLOW_RTP_SAMPLING_RATE | Flow RTP Sampling Rate (0034,0004)
FLOW_TRANSFER_SYNTAX_UID | Flow Transfer Syntax UID (0034,0003)
FLUENCE_DATA_SCALE | Fluence Data Scale (3002,0042)
FLUENCE_DATA_SOURCE | Fluence Data Source (3002,0041)
FLUENCE_MAP_SEQUENCE | Fluence Map Sequence (3002,0040)
FLUENCE_MODE | Fluence Mode (3002,0051)
FLUENCE_MODE_ID | Fluence Mode ID (3002,0052)
FLUOROSCOPY_FLAG | Fluoroscopy Flag (0018,9334)
FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG | Fluoroscopy Last Image Hold Persistence Flag (0018,11B4)
FLUOROSCOPY_PERSISTENCE_FLAG | Fluoroscopy Persistence Flag (0018,11B3)
FOCAL_DISTANCE | Focal Distance (0018,1182)
FOCAL_LENGTH | Focal Length (0016,0029)
FOCAL_LENGTH_IN_35MM_FILM | Focal Length In 35mm Film (0016,0045)
FOCAL_SPOTS | Focal Spot(s) (0018,1190)
FOCUS_DEPTH | Focus Depth (0018,5012)
FOCUS_METHOD | Focus Method (0048,0011)
FOLDER_ACCESS_URI | Folder Access URI (0008,0408)
FONT_NAME | Font Name (0070,0227)
FONT_NAME_TYPE | Font Name Type (0070,0228)
FOVEAL_POINT_NORMATIVE_DATA_FLAG | Foveal Point Normative Data Flag (0024,0117)
FOVEAL_POINT_PROBABILITY_VALUE | Foveal Point Probability Value (0024,0118)
FOVEAL_SENSITIVITY | Foveal Sensitivity (0024,0087)
FOVEAL_SENSITIVITY_MEASURED | Foveal Sensitivity Measured (0024,0086)
FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR | Fraction-Based Relationship Interval Anchor (3010,0083)
FRACTION_BASED_RELATIONSHIP_SEQUENCE | Fraction-Based Relationship Sequence (3010,0082)
FRACTION_GROUP_DESCRIPTION | Fraction Group Description (300A,0072)
FRACTION_GROUP_NUMBER | Fraction Group Number (300A,0071)
FRACTION_GROUP_SEQUENCE | Fraction Group Sequence (300A,0070)
FRACTION_GROUP_SUMMARY_SEQUENCE | Fraction Group Summary Sequence (3008,0220)
FRACTION_GROUP_TYPE | Fraction Group Type (3008,0224)
FRACTION_NUMBER | Fraction Number (3002,0029)
FRACTION_PATTERN | Fraction Pattern (300A,007B)
FRACTION_PATTERN_SEQUENCE | Fraction Pattern Sequence (3010,0079)
FRACTION_STATUS_SUMMARY_SEQUENCE | Fraction Status Summary Sequence (3008,0240)
FRACTIONAL_BANDWIDTH | Fractional Bandwidth (0018,982E)
FRACTIONAL_CHANNEL_DISPLAY_SCALE | Fractional Channel Display Scale (003A,0247)
FRACTIONATION_NOTES | Fractionation Notes (3010,007F)
FRAME_ACQUISITION_DATETIME | Frame Acquisition DateTime (0018,9074)
FRAME_ACQUISITION_DURATION | Frame Acquisition Duration (0018,9220)
FRAME_ACQUISITION_NUMBER | Frame Acquisition Number (0020,9156)
FRAME_ACQUISITION_SEQUENCE | Frame Acquisition Sequence (0018,9417)
FRAME_ANATOMY_SEQUENCE | Frame Anatomy Sequence (0020,9071)
FRAME_COMMENTS | Frame Comments (0020,9158)
FRAME_CONTENT_SEQUENCE | Frame Content Sequence (0020,9111)
FRAME_DELAY | Frame Delay (0018,1066)
FRAME_DETECTOR_PARAMETERS_SEQUENCE | Frame Detector Parameters Sequence (0018,9451)
FRAME_DIMENSION_POINTER | Frame Dimension Pointer (0028,000A)
FRAME_DISPLAY_SEQUENCE | Frame Display Sequence (0008,9458)
FRAME_DISPLAY_SHUTTER_SEQUENCE | Frame Display Shutter Sequence (0018,9472)
FRAME_EXTRACTION_SEQUENCE | Frame Extraction Sequence (0008,1164)
FRAME_INCREMENT_POINTER | Frame Increment Pointer (0028,0009)
FRAME_LABEL | Frame Label (0020,9453)
FRAME_LABEL_VECTOR | Frame Label Vector (0018,2002)
FRAME_LATERALITY | Frame Laterality (0020,9072)
FRAME_NUMBERS_OF_INTEREST | Frame Numbers of Interest (0028,6020)
FRAME_NUMBERS_OF_INTEREST_FOI | Alias for tag FRAME_NUMBERS_OF_INTEREST (0028,6020)
FRAME_OF_INTEREST_DESCRIPTION | Frame of Interest Description (0028,6022)
FRAME_OF_INTEREST_TYPE | Frame of Interest Type (0028,6023)
FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED | Frame of Reference Relationship Sequence RETIRED (3006,00C0)
FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX | Frame of Reference to Displayed Coordinate System Transformation Matrix (0070,030B)
FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT | Frame of Reference Transformation Comment (3006,00C8)
FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX | Frame of Reference Transformation Matrix (3006,00C6)
FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE | Frame of Reference Transformation Matrix Type (0070,030C)
FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED | Frame of Reference Transformation Type RETIRED (3006,00C4)
FRAME_OF_REFERENCE_UID | Frame of Reference UID (0020,0052)
FRAME_ORIGIN_TIMESTAMP | Frame Origin Timestamp (0034,0007)
FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE | Frame Pixel Data Properties Sequence (0028,9443)
FRAME_PIXEL_SHIFT_SEQUENCE | Frame Pixel Shift Sequence (0028,9415)
FRAME_PRIMARY_ANGLE_VECTOR | Frame Primary Angle Vector (0018,2003)
FRAME_REFERENCE_DATETIME | Frame Reference DateTime (0018,9151)
FRAME_REFERENCE_TIME | Frame Reference Time (0054,1300)
FRAME_SECONDARY_ANGLE_VECTOR | Frame Secondary Angle Vector (0018,2004)
FRAME_TIME | Frame Time (0018,1063)
FRAME_TIME_VECTOR | Frame Time Vector (0018,1065)
FRAME_TYPE | Frame Type (0008,9007)
FRAME_USEFULNESS_GROUP_SEQUENCE | Frame Usefulness Group Sequence (0034,0009)
FRAME_VOI_LUT_SEQUENCE | Frame VOI LUT Sequence (0028,9132)
FRAMES_OF_INTEREST_DESCRIPTION | Alias for tag FRAME_OF_INTEREST_DESCRIPTION (0028,6022)
FRAMING_TYPE | Alias for tag CARDIAC_FRAMING_TYPE (0018,1064)
FREQUENCY_CORRECTION | Frequency Correction (0018,9101)
FREQUENCY_ENCODING_CODE_SEQUENCE | Frequency Encoding Code Sequence (003A,032C)
FUNCTIONAL_GROUP_POINTER | Functional Group Pointer (0020,9167)
FUNCTIONAL_GROUP_PRIVATE_CREATOR | Functional Group Private Creator (0020,9238)
FUNCTIONAL_MR_SEQUENCE | Functional MR Sequence (0018,9621)
FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT | Functional Settling Phase Frames Present (0018,9622)
FUNCTIONAL_SYNC_PULSE | Functional Sync Pulse (0018,9623)
GAIN_CONTROL | Gain Control (0016,0047)
GAIN_CORRECTION_REFERENCE_SEQUENCE | Gain Correction Reference Sequence (0014,3060)
GAMMA_VALUE | Gamma Value (0028,701A)
GANTRY_ANGLE | Gantry Angle (300A,011E)
GANTRY_ANGLE_TOLERANCE | Gantry Angle Tolerance (300A,0044)
GANTRY_DETECTOR_SLEW | Gantry/Detector Slew (0018,1121)
GANTRY_DETECTOR_TILT | Gantry/Detector Tilt (0018,1120)
GANTRY_ID | Gantry ID (0018,1008)
GANTRY_MOTION_CORRECTED | Gantry Motion Corrected (0018,9762)
GANTRY_PITCH_ANGLE | Gantry Pitch Angle (300A,014A)
GANTRY_PITCH_ANGLE_TOLERANCE | Gantry Pitch Angle Tolerance (300A,014E)
GANTRY_PITCH_ROTATION_DIRECTION | Gantry Pitch Rotation Direction (300A,014C)
GANTRY_ROTATION_DIRECTION | Gantry Rotation Direction (300A,011F)
GANTRY_TYPE | Gantry Type (4010,1008)
GAP_LENGTH | Gap Length (0070,0261)
GATE_SETTINGS_SEQUENCE | Gate Settings Sequence (0014,4060)
GATE_THRESHOLD | Gate Threshold (0014,4062)
GATED_INFORMATION_SEQUENCE | Gated Information Sequence (0054,0062)
GATING_BEAM_HOLD_TRANSITION_SEQUENCE | Gating Beam Hold Transition Sequence (300C,0125)
GENERAL_ACCESSORY_DEFINITION_SEQUENCE | General Accessory Definition Sequence (300A,0671)
GENERAL_ACCESSORY_DESCRIPTION | General Accessory Description (300A,0422)
GENERAL_ACCESSORY_ID | General Accessory ID (300A,0421)
GENERAL_ACCESSORY_NUMBER | General Accessory Number (300A,0424)
GENERAL_ACCESSORY_SEQUENCE | General Accessory Sequence (300A,0420)
GENERAL_ACCESSORY_TYPE | General Accessory Type (300A,0423)
GENERAL_MACHINE_VERIFICATION_SEQUENCE | General Machine Verification Sequence (0074,1042)
GENERAL_MATCHING_SEQUENCE | General Matching Sequence (0008,0413)
GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED | General Purpose Performed Procedure Step Status RETIRED (0040,4002)
GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED | General Purpose Scheduled Procedure Step Priority RETIRED (0040,4003)
GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED | General Purpose Scheduled Procedure Step Status RETIRED (0040,4001)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG | Generalized Defect Corrected Sensitivity Deviation Flag (0024,0102)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE | Generalized Defect Corrected Sensitivity Deviation Probability Value (0024,0104)
GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE | Generalized Defect Corrected Sensitivity Deviation Value (0024,0103)
GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE | Generalized Defect Sensitivity Deviation Algorithm Sequence (0024,0067)
GENERATOR_ID | Generator ID (0018,1005)
GENERATOR_POWER | Generator Power (0018,1170)
GENETIC_MODIFICATIONS_CODE_SEQUENCE | Genetic Modifications Code Sequence (0010,0229)
GENETIC_MODIFICATIONS_DESCRIPTION | Genetic Modifications Description (0010,0222)
GENETIC_MODIFICATIONS_NOMENCLATURE | Genetic Modifications Nomenclature (0010,0223)
GENETIC_MODIFICATIONS_SEQUENCE | Genetic Modifications Sequence (0010,0221)
GEOMETRIC_MAXIMUM_DISTORTION | Geometric Maximum Distortion (0028,9445)
GEOMETRICAL_PROPERTIES | Geometrical Properties (0028,9444)
GEOMETRY_FOR_DISPLAY | Geometry for Display (0070,1B08)
GEOMETRY_OF_K_SPACE_TRAVERSAL | Geometry of k-Space Traversal (0018,9032)
GLOBAL_CROP | Global Crop (0070,120B)
GLOBAL_CROPPING_SPECIFICATION_INDEX | Global Cropping Specification Index (0070,120C)
GLOBAL_DEVIATION_FROM_NORMAL | Global Deviation From Normal (0024,0066)
GLOBAL_DEVIATION_PROBABILITY | Global Deviation Probability (0024,0071)
GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG | Global Deviation Probability Normals Flag (0024,0059)
GLOBAL_DEVIATION_PROBABILITY_SEQUENCE | Global Deviation Probability Sequence (0024,0083)
GPS_ALTITUDE | GPS Altitude (0016,0076)
GPS_ALTITUDE_REF | GPS Altitude Ref (0016,0075)
GPS_AREA_INFORMATION | GPS Area Information (0016,008C)
GPS_DATE_STAMP | GPS Date Stamp (0016,008D)
GPS_DEST_BEARING | GPS Dest Bearing (0016,0088)
GPS_DEST_BEARING_REF | GPS Dest Bearing Ref (0016,0087)
GPS_DEST_DISTANCE | GPS Dest Distance (0016,008A)
GPS_DEST_DISTANCE_REF | GPS Dest Distance Ref (0016,0089)
GPS_DEST_LATITUDE | GPS Dest Latitude (0016,0084)
GPS_DEST_LATITUDE_REF | GPS Dest Latitude Ref (0016,0083)
GPS_DEST_LONGITUDE | GPS Dest Longitude (0016,0086)
GPS_DEST_LONGITUDE_REF | GPS Dest Longitude Ref (0016,0085)
GPS_DIFFERENTIAL | GPS Differential (0016,008E)
GPS_DOP | GPS DOP (0016,007B)
GPS_IMG_DIRECTION | GPS Img Direction (0016,0081)
GPS_IMG_DIRECTION_REF | GPS Img Direction Ref (0016,0080)
GPS_LATITUDE | GPS Latitude (0016,0072)
GPS_LATITUDE_REF | GPS Latitude Ref (0016,0071)
GPS_LONGITUDE | GPS Longitude (0016,0074)
GPS_LONGITUDE_REF | GPS Longitude Ref (0016,0073)
GPS_MAP_DATUM | GPS Map Datum (0016,0082)
GPS_MEASURE_MODE | GPS Measure Mode (0016,007A)
GPS_PROCESSING_METHOD | GPS Processing Method (0016,008B)
GPS_SATELLITES | GPS Satellites (0016,0078)
GPS_SPEED | GPS Speed (0016,007D)
GPS_SPEED_REF | GPS Speed Ref (0016,007C)
GPS_STATUS | GPS Status (0016,0079)
GPS_TIME_STAMP | GPS Time Stamp (0016,0077)
GPS_TRACK | GPS Track (0016,007F)
GPS_TRACK_REF | GPS Track Ref (0016,007E)
GPS_VERSION_ID | GPS Version ID (0016,0070)
GRADIENT_ECHO_TRAIN_LENGTH | Gradient Echo Train Length (0018,9241)
GRADIENT_OUTPUT | Gradient Output (0018,9182)
GRADIENT_OUTPUT_TYPE | Gradient Output Type (0018,9180)
GRAPHIC_ANNOTATION_SEQUENCE | Graphic Annotation Sequence (0070,0001)
GRAPHIC_ANNOTATION_UNITS | Graphic Annotation Units (0070,0005)
GRAPHIC_COORDINATES_DATA_SEQUENCE | Graphic Coordinates Data Sequence (0070,0318)
GRAPHIC_DATA | Graphic Data (0070,0022)
GRAPHIC_DIMENSIONS | Graphic Dimensions (0070,0020)
GRAPHIC_FILLED | Graphic Filled (0070,0024)
GRAPHIC_GROUP_DESCRIPTION | Graphic Group Description (0070,0208)
GRAPHIC_GROUP_ID | Graphic Group ID (0070,0295)
GRAPHIC_GROUP_LABEL | Graphic Group Label (0070,0207)
GRAPHIC_GROUP_SEQUENCE | Graphic Group Sequence (0070,0234)
GRAPHIC_LAYER | Graphic Layer (0070,0002)
GRAPHIC_LAYER_DESCRIPTION | Graphic Layer Description (0070,0068)
GRAPHIC_LAYER_ORDER | Graphic Layer Order (0070,0062)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE | Graphic Layer Recommended Display CIELab Value (0070,0401)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE | Graphic Layer Recommended Display Grayscale Value (0070,0066)
GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED | Graphic Layer Recommended Display RGB Value RETIRED (0070,0067)
GRAPHIC_LAYER_SEQUENCE | Graphic Layer Sequence (0070,0060)
GRAPHIC_OBJECT_SEQUENCE | Graphic Object Sequence (0070,0009)
GRAPHIC_TYPE | Graphic Type (0070,0023)
GRAY_LOOKUP_TABLE_DATA_RETIRED | Gray Lookup Table Data RETIRED (0028,1200)
GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED | Gray Lookup Table Descriptor RETIRED (0028,1100)
GRAY_SCALE_RETIRED | Gray Scale RETIRED (0028,1080)
GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA | Green Palette Color Lookup Table Data (0028,1202)
GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Green Palette Color Lookup Table Descriptor (0028,1102)
GRID | Grid (0018,1166)
GRID_ABSORBING_MATERIAL | Grid Absorbing Material (0018,7040)
GRID_ASPECT_RATIO | Grid Aspect Ratio (0018,7046)
GRID_DIMENSIONS | Grid Dimensions (0064,0007)
GRID_FOCAL_DISTANCE | Grid Focal Distance (0018,704C)
GRID_FRAME_OFFSET_VECTOR | Grid Frame Offset Vector (3004,000C)
GRID_ID | Grid ID (0018,1006)
GRID_PERIOD | Grid Period (0018,7048)
GRID_PITCH | Grid Pitch (0018,7044)
GRID_RESOLUTION | Grid Resolution (0064,0008)
GRID_SPACING_MATERIAL | Grid Spacing Material (0018,7041)
GRID_THICKNESS | Grid Thickness (0018,7042)
GROUP_0000_LENGTH | Alias for tag COMMAND_GROUP_LENGTH (0000,0000)
GROUP_0002_LENGTH | Alias for tag FILE_META_INFORMATION_GROUP_LENGTH (0002,0000)
GROUP_0008_LENGTH_RETIRED | Group 0008 Length RETIRED (0008,0000)
GROUP_0010_LENGTH_RETIRED | Group 0010 Length RETIRED (0010,0000)
GROUP_0012_LENGTH_RETIRED | Group 0012 Length RETIRED (0012,0000)
GROUP_0018_LENGTH_RETIRED | Group 0018 Length RETIRED (0018,0000)
GROUP_0020_LENGTH_RETIRED | Group 0020 Length RETIRED (0020,0000)
GROUP_0022_LENGTH_RETIRED | Group 0022 Length RETIRED (0022,0000)
GROUP_0028_LENGTH_RETIRED | Group 0028 Length RETIRED (0028,0000)
GROUP_0032_LENGTH_RETIRED | Group 0032 Length RETIRED (0032,0000)
GROUP_0038_LENGTH_RETIRED | Group 0038 Length RETIRED (0038,0000)
GROUP_003A_LENGTH_RETIRED | Group 003A Length RETIRED (003A,0000)
GROUP_0040_LENGTH_RETIRED | Group 0040 Length RETIRED (0040,0000)
GROUP_0042_LENGTH_RETIRED | Group 0042 Length RETIRED (0042,0000)
GROUP_0044_LENGTH_RETIRED | Group 0044 Length RETIRED (0044,0000)
GROUP_0050_LENGTH_RETIRED | Group 0050 Length RETIRED (0050,0000)
GROUP_0054_LENGTH_RETIRED | Group 0054 Length RETIRED (0054,0000)
GROUP_0060_LENGTH_RETIRED | Group 0060 Length RETIRED (0060,0000)
GROUP_0062_LENGTH_RETIRED | Group 0062 Length RETIRED (0062,0000)
GROUP_0064_LENGTH_RETIRED | Group 0064 Length RETIRED (0064,0000)
GROUP_0070_LENGTH_RETIRED | Group 0070 Length RETIRED (0070,0000)
GROUP_0072_LENGTH_RETIRED | Group 0072 Length RETIRED (0072,0000)
GROUP_0088_LENGTH_RETIRED | Group 0088 Length RETIRED (0088,0000)
GROUP_0100_LENGTH_RETIRED | Group 0100 Length RETIRED (0100,0000)
GROUP_0400_LENGTH_RETIRED | Group 0400 Length RETIRED (0400,0000)
GROUP_2000_LENGTH_RETIRED | Group 2000 Length RETIRED (2000,0000)
GROUP_2010_LENGTH_RETIRED | Group 2010 Length RETIRED (2010,0000)
GROUP_2020_LENGTH_RETIRED | Group 2020 Length RETIRED (2020,0000)
GROUP_2030_LENGTH_RETIRED | Group 2030 Length RETIRED (2030,0000)
GROUP_2040_LENGTH_RETIRED | Group 2040 Length RETIRED (2040,0000)
GROUP_2050_LENGTH_RETIRED | Group 2050 Length RETIRED (2050,0000)
GROUP_2100_LENGTH_RETIRED | Group 2100 Length RETIRED (2100,0000)
GROUP_2110_LENGTH_RETIRED | Group 2110 Length RETIRED (2110,0000)
GROUP_2120_LENGTH_RETIRED | Group 2120 Length RETIRED (2120,0000)
GROUP_2130_LENGTH_RETIRED | Group 2130 Length RETIRED (2130,0000)
GROUP_2200_LENGTH_RETIRED | Group 2200 Length RETIRED (2200,0000)
GROUP_3002_LENGTH_RETIRED | Group 3002 Length RETIRED (3002,0000)
GROUP_3004_LENGTH_RETIRED | Group 3004 Length RETIRED (3004,0000)
GROUP_3006_LENGTH_RETIRED | Group 3006 Length RETIRED (3006,0000)
GROUP_3008_LENGTH_RETIRED | Group 3008 Length RETIRED (3008,0000)
GROUP_300A_LENGTH_RETIRED | Group 300A Length RETIRED (300A,0000)
GROUP_300C_LENGTH_RETIRED | Group 300C Length RETIRED (300C,0000)
GROUP_300E_LENGTH_RETIRED | Group 300E Length RETIRED (300E,0000)
GROUP_4000_LENGTH_RETIRED | Group 4000 Length RETIRED (4000,0000)
GROUP_4008_LENGTH_RETIRED | Group 4008 Length RETIRED (4008,0000)
GROUP_4FFE_LENGTH_RETIRED | Group 4FFE Length RETIRED (4FFE,0000)
GROUP_5000_LENGTH_RETIRED | Group 5000 Length RETIRED (5000,0000)
GROUP_5200_LENGTH_RETIRED | Group 5200 Length RETIRED (5200,0000)
GROUP_5400_LENGTH_RETIRED | Group 5400 Length RETIRED (5400,0000)
GROUP_5600_LENGTH_RETIRED | Group 5600 Length RETIRED (5600,0000)
GROUP_6000_LENGTH_RETIRED | Group 6000 Length RETIRED (6000,0000)
GROUP_7FE0_LENGTH_RETIRED | Group 7FE0 Length RETIRED (7FE0,0000)
GROUP_FFFA_LENGTH_RETIRED | Group FFFA Length RETIRED (FFFA,0000)
GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE | Group of Patients Identification Sequence (0010,0027)
HALF_VALUE_LAYER | Half Value Layer (0040,0314)
HANGING_PROTOCOL_CREATION_DATETIME | Hanging Protocol Creation DateTime (0072,000A)
HANGING_PROTOCOL_CREATOR | Hanging Protocol Creator (0072,0008)
HANGING_PROTOCOL_DEFINITION_SEQUENCE | Hanging Protocol Definition Sequence (0072,000C)
HANGING_PROTOCOL_DESCRIPTION | Hanging Protocol Description (0072,0004)
HANGING_PROTOCOL_LEVEL | Hanging Protocol Level (0072,0006)
HANGING_PROTOCOL_NAME | Hanging Protocol Name (0072,0002)
HANGING_PROTOCOL_USER_GROUP_NAME | Hanging Protocol User Group Name (0072,0010)
HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE | Hanging Protocol User Identification Code Sequence (0072,000E)
HARCOPY_DEVICE_SOFTWARE_VERSION | Alias for tag HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED (0018,101A)
HARDCOPY_CREATION_DEVICE_ID_RETIRED | Hardcopy Creation Device ID RETIRED (0018,1011)
HARDCOPY_DEVICE_MANUFACTURER_RETIRED | Hardcopy Device Manufacturer RETIRED (0018,1017)
HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED | Hardcopy Device Manufacturer's Model Name RETIRED (0018,101B)
HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED | Hardcopy Device Software Version RETIRED (0018,101A)
HEAD_FIXATION_ANGLE | Head Fixation Angle (300A,0148)
HEAD_FIXATION_ANGLE_TOLERANCE | Head Fixation Angle Tolerance (300A,0152)
HEART_RATE | Heart Rate (0018,1088)
HIGH_BIT | High Bit (0028,0102)
HIGH_DOSE_TECHNIQUE_TYPE | High-Dose Technique Type (300A,00C7)
HIGH_ENERGY_DETECTORS | High Energy Detectors (4010,0002)
HIGH_R_R_VALUE | High R-R Value (0018,1082)
HISTOGRAM_BIN_WIDTH | Histogram Bin Width (0060,3008)
HISTOGRAM_DATA | Histogram Data (0060,3020)
HISTOGRAM_EXPLANATION | Histogram Explanation (0060,3010)
HISTOGRAM_FIRST_BIN_VALUE | Histogram First Bin Value (0060,3004)
HISTOGRAM_LAST_BIN_VALUE | Histogram Last Bin Value (0060,3006)
HISTOGRAM_NUMBER_OF_BINS | Histogram Number of Bins (0060,3002)
HISTOGRAM_SEQUENCE | Histogram Sequence (0060,3000)
HL7_DOCUMENT_EFFECTIVE_TIME | HL7 Document Effective Time (0040,E004)
HL7_DOCUMENT_TYPE_CODE_SEQUENCE | HL7 Document Type Code Sequence (0040,E006)
HL7_INSTANCE_IDENTIFIER | HL7 Instance Identifier (0040,E001)
HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE | HL7 Structured Document Reference Sequence (0040,A390)
HOME_COMMUNITY_ID | Home Community ID (0040,E031)
HORIZONTAL_ALIGNMENT | Horizontal Alignment (0070,0242)
HORIZONTAL_FIELD_OF_VIEW | Horizontal Field of View (0022,000C)
HORIZONTAL_OFFSET_OF_SENSOR | Horizontal Offset of Sensor (0014,3024)
HORIZONTAL_PRISM_BASE | Horizontal Prism Base (0046,0032)
HORIZONTAL_PRISM_POWER | Horizontal Prism Power (0046,0030)
HPGL_CONTOUR_PEN_NUMBER | HPGL Contour Pen Number (0068,6310)
HPGL_DOCUMENT | HPGL Document (0068,6300)
HPGL_DOCUMENT_ID | HPGL Document ID (0068,62D0)
HPGL_DOCUMENT_LABEL | HPGL Document Label (0068,62D5)
HPGL_DOCUMENT_SCALING | HPGL Document Scaling (0068,62F2)
HPGL_DOCUMENT_SEQUENCE | HPGL Document Sequence (0068,62C0)
HPGL_PEN_DESCRIPTION | HPGL Pen Description (0068,6345)
HPGL_PEN_LABEL | HPGL Pen Label (0068,6340)
HPGL_PEN_NUMBER | HPGL Pen Number (0068,6330)
HPGL_PEN_SEQUENCE | HPGL Pen Sequence (0068,6320)
HUMAN_PERFORMER_CODE_SEQUENCE | Human Performer Code Sequence (0040,4009)
HUMAN_PERFORMERS_NAME | Human Performer's Name (0040,4037)
HUMAN_PERFORMERS_ORGANIZATION | Human Performer's Organization (0040,4036)
HUMIDITY | Humidity (0016,0031)
ICC_PROFILE | ICC Profile (0028,2000)
ICON_IMAGE | Alias for tag ICON_IMAGE_SEQUENCE (0088,0200)
ICON_IMAGE_SEQUENCE | Icon Image Sequence (0088,0200)
IDENTICAL_DOCUMENTS | Alias for tag IDENTICAL_DOCUMENTS_SEQUENCE (0040,A525)
IDENTICAL_DOCUMENTS_SEQUENCE | Identical Documents Sequence (0040,A525)
IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED | Identification Description (Trial) RETIRED (0040,A224)
IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Identifier Code Sequence (Trial) RETIRED (0040,A070)
IDENTIFIER_TYPE_CODE | Identifier Type Code (0040,0035)
IDENTIFYING_COMMENTS_RETIRED | Identifying Comments RETIRED (0008,4000)
IDENTIFYING_PRIVATE_ELEMENTS | Identifying Private Elements (0008,0306)
ILLUMINATION | Illumination (2010,015E)
ILLUMINATION_BANDWIDTH | Illumination Bandwidth (0022,0057)
ILLUMINATION_COLOR_CODE_SEQUENCE | Illumination Color Code Sequence (0048,0108)
ILLUMINATION_POWER | Illumination Power (0022,0056)
ILLUMINATION_TRANSLATION_FLAG | Illumination Translation Flag (0018,9828)
ILLUMINATION_TYPE_CODE_SEQUENCE | Illumination Type Code Sequence (0022,0016)
ILLUMINATION_WAVE_LENGTH | Illumination Wave Length (0022,0055)
ILLUMINATOR_TYPE_CODE_SEQUENCE | Illuminator Type Code Sequence (0048,0100)
IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT | Image and Fluoroscopy Area Dose Product (0018,115E)
IMAGE_BOX_CONTENT_SEQUENCE_RETIRED | Image Box Content Sequence RETIRED (2130,0040)
IMAGE_BOX_LARGE_SCROLL_AMOUNT | Image Box Large Scroll Amount (0072,0318)
IMAGE_BOX_LARGE_SCROLL_TYPE | Image Box Large Scroll Type (0072,0316)
IMAGE_BOX_LAYOUT_TYPE | Image Box Layout Type (0072,0304)
IMAGE_BOX_NUMBER | Image Box Number (0072,0302)
IMAGE_BOX_OVERLAP_PRIORITY | Image Box Overlap Priority (0072,0320)
IMAGE_BOX_POSITION | Image Box Position (2020,0010)
IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED | Image Box Presentation LUT Flag RETIRED (2000,006A)
IMAGE_BOX_SCROLL_DIRECTION | Image Box Scroll Direction (0072,0310)
IMAGE_BOX_SMALL_SCROLL_AMOUNT | Image Box Small Scroll Amount (0072,0314)
IMAGE_BOX_SMALL_SCROLL_TYPE | Image Box Small Scroll Type (0072,0312)
IMAGE_BOX_SYNCHRONIZATION_SEQUENCE | Image Box Synchronization Sequence (0072,0430)
IMAGE_BOX_TILE_HORIZONTAL_DIMENSION | Image Box Tile Horizontal Dimension (0072,0306)
IMAGE_BOX_TILE_VERTICAL_DIMENSION | Image Box Tile Vertical Dimension (0072,0308)
IMAGE_BOXES_SEQUENCE | Image Boxes Sequence (0072,0300)
IMAGE_CENTER_POINT_COORDINATES_SEQUENCE | Image Center Point Coordinates Sequence (0040,071A)
IMAGE_COMMENTS | Image Comments (0020,4000)
IMAGE_DATA_TYPE_CODE_SEQUENCE | Image Data Type Code Sequence (0018,9836)
IMAGE_DATA_TYPE_SEQUENCE | Image Data Type Sequence (0018,9807)
IMAGE_DATE | Alias for tag CONTENT_DATE (0008,0023)
IMAGE_DIMENSIONS_RETIRED | Image Dimensions RETIRED (0028,0005)
IMAGE_DISPLAY_FORMAT | Image Display Format (2010,0010)
IMAGE_FILTER | Image Filter (0018,9320)
IMAGE_FILTER_DESCRIPTION | Image Filter Description (0018,9941)
IMAGE_FILTER_DETAILS_SEQUENCE | Image Filter Details Sequence (0018,11BF)
IMAGE_FORMAT_RETIRED | Image Format RETIRED (0028,0040)
IMAGE_FRAME_ORIGIN | Image Frame Origin (6000,0051)
IMAGE_GEOMETRY_TYPE_RETIRED | Image Geometry Type RETIRED (0020,0070)
IMAGE_HORIZONTAL_FLIP | Image Horizontal Flip (0070,0041)
IMAGE_ID | Image ID (0054,0400)
IMAGE_INDEX | Image Index (0054,1330)
IMAGE_LATERALITY | Image Laterality (0020,0062)
IMAGE_LOCATION_RETIRED | Image Location RETIRED (0028,0200)
IMAGE_NUMBER | Alias for tag INSTANCE_NUMBER (0020,0013)
IMAGE_ORIENTATION_PATIENT | Image Orientation (Patient) (0020,0037)
IMAGE_ORIENTATION_RETIRED | Image Orientation RETIRED (0020,0035)
IMAGE_ORIENTATION_SLIDE | Image Orientation (Slide) (0048,0102)
IMAGE_ORIENTATION_VOLUME | Image Orientation (Volume) (0020,9302)
IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED | Image Overlay Box Content Sequence RETIRED (2130,0060)
IMAGE_OVERLAY_FLAG_RETIRED | Image Overlay Flag RETIRED (2000,0067)
IMAGE_PATH_FILTER_PASS_BAND | Image Path Filter Pass Band (0022,0004)
IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH | Image Path Filter Pass-Through Wavelength (0022,0003)
IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE | Image Path Filter Type Stack Code Sequence (0022,0018)
IMAGE_PLANE_PIXEL_SPACING | Image Plane Pixel Spacing (3002,0011)
IMAGE_POSITION | Alias for tag IMAGE_BOX_POSITION (2020,0010)
IMAGE_POSITION_PATIENT | Image Position (Patient) (0020,0032)
IMAGE_POSITION_RETIRED | Image Position RETIRED (0020,0030)
IMAGE_POSITION_VOLUME | Image Position (Volume) (0020,9301)
IMAGE_PRESENTATION_COMMENTS_RETIRED | Image Presentation Comments RETIRED (0028,4000)
IMAGE_PROCESSING_APPLIED | Image Processing Applied (0028,9446)
IMAGE_RECEPTOR_POSITION_SEQUENCE | Image Receptor Position Sequence (3002,010E)
IMAGE_ROTATION | Image Rotation (0070,0042)
IMAGE_ROTATION_RETIRED | Image Rotation (Retired) (0070,0040)
IMAGE_SET_LABEL | Image Set Label (0072,0040)
IMAGE_SET_NUMBER | Image Set Number (0072,0032)
IMAGE_SET_SELECTOR_CATEGORY | Image Set Selector Category (0072,0034)
IMAGE_SET_SELECTOR_SEQUENCE | Image Set Selector Sequence (0072,0022)
IMAGE_SET_SELECTOR_USAGE_FLAG | Image Set Selector Usage Flag (0072,0024)
IMAGE_SETS_SEQUENCE | Image Sets Sequence (0072,0020)
IMAGE_TIME | Alias for tag CONTENT_TIME (0008,0033)
IMAGE_TO_EQUIPMENT_MAPPING_MATRIX | Image to Equipment Mapping Matrix (0028,9520)
IMAGE_TRANSFORMATION_MATRIX_RETIRED | Image Transformation Matrix RETIRED (0018,5210)
IMAGE_TRANSLATION_VECTOR_RETIRED | Image Translation Vector RETIRED (0018,5212)
IMAGE_TRIGGER_DELAY | Image Trigger Delay (0018,1067)
IMAGE_TYPE | Image Type (0008,0008)
IMAGE_VOLUME_GEOMETRY | Image Volume Geometry (0070,1208)
IMAGED_NUCLEUS | Imaged Nucleus (0018,0085)
IMAGED_VOLUME_DEPTH | Imaged Volume Depth (0048,0003)
IMAGED_VOLUME_HEIGHT | Imaged Volume Height (0048,0002)
IMAGED_VOLUME_WIDTH | Imaged Volume Width (0048,0001)
IMAGER_PIXEL_SPACING | Imager Pixel Spacing (0018,1164)
IMAGES_IN_ACQUISITION | Images in Acquisition (0020,1002)
IMAGING_APERTURE_SEQUENCE | Imaging Aperture Sequence (3002,0114)
IMAGING_APERTURE_SPECIFICATION_TYPE | Imaging Aperture Specification Type (3002,0115)
IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE | Imaging Device Location Matrix Sequence (3002,0112)
IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE | Imaging Device Location Parameter Sequence (3002,0113)
IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS | Imaging Device-Specific Acquisition Parameters (300A,00CC)
IMAGING_FREQUENCY | Imaging Frequency (0018,0084)
IMAGING_SERVICE_REQUEST_COMMENTS | Imaging Service Request Comments (0040,2400)
IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE | Imaging Source Location Specification Type (3002,0111)
IMAGING_SOURCE_POSITION_SEQUENCE | Imaging Source Position Sequence (3002,010D)
IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE | Imaging Source to Beam Modifier Definition Plane Distance (3002,012D)
IMMERSION_MEDIA | Immersion Media (0016,1004)
IMPEDANCE_MEASUREMENT_CURRENT_TYPE | Impedance Measurement Current Type (003A,0316)
IMPEDANCE_MEASUREMENT_DATETIME | Impedance Measurement DateTime (003A,0314)
IMPEDANCE_MEASUREMENT_FREQUENCY | Impedance Measurement Frequency (003A,0315)
IMPEDANCE_VALUE | Impedance Value (003A,0313)
IMPLANT_ASSEMBLY_TEMPLATE_ISSUER | Implant Assembly Template Issuer (0076,0003)
IMPLANT_ASSEMBLY_TEMPLATE_NAME | Implant Assembly Template Name (0076,0001)
IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE | Implant Assembly Template Target Anatomy Sequence (0076,0010)
IMPLANT_ASSEMBLY_TEMPLATE_TYPE | Implant Assembly Template Type (0076,000A)
IMPLANT_ASSEMBLY_TEMPLATE_VERSION | Implant Assembly Template Version (0076,0006)
IMPLANT_NAME | Implant Name (0022,1095)
IMPLANT_PART_NUMBER | Implant Part Number (0022,1097)
IMPLANT_PRESENT | Alias for tag BREAST_IMPLANT_PRESENT (0028,1300)
IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE | Implant Regulatory Disapproval Code Sequence (0068,62A0)
IMPLANT_SIZE | Implant Size (0068,6210)
IMPLANT_TARGET_ANATOMY_SEQUENCE | Implant Target Anatomy Sequence (0068,6230)
IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER | Implant Template 3D Model Surface Number (0068,6350)
IMPLANT_TEMPLATE_GROUP_DESCRIPTION | Implant Template Group Description (0078,0010)
IMPLANT_TEMPLATE_GROUP_ISSUER | Implant Template Group Issuer (0078,0020)
IMPLANT_TEMPLATE_GROUP_MEMBER_ID | Implant Template Group Member ID (0078,002E)
IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE | Implant Template Group Member Matching 2D Coordinates Sequence (0078,0070)
IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE | Implant Template Group Members Sequence (0078,002A)
IMPLANT_TEMPLATE_GROUP_NAME | Implant Template Group Name (0078,0001)
IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE | Implant Template Group Target Anatomy Sequence (0078,0028)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME | Implant Template Group Variation Dimension Name (0078,00B2)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK | Implant Template Group Variation Dimension Rank (0078,00B8)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE | Implant Template Group Variation Dimension Rank Sequence (0078,00B4)
IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE | Implant Template Group Variation Dimension Sequence (0078,00B0)
IMPLANT_TEMPLATE_GROUP_VERSION | Implant Template Group Version (0078,0024)
IMPLANT_TEMPLATE_VERSION | Implant Template Version (0068,6221)
IMPLANT_TYPE | Implant Type (0068,6223)
IMPLANT_TYPE_CODE_SEQUENCE | Implant Type Code Sequence (0068,63A8)
IMPLEMENTATION_CLASS_UID | Implementation Class UID (0002,0012)
IMPLEMENTATION_VERSION_NAME | Implementation Version Name (0002,0013)
IMPRESSIONS_RETIRED | Impressions RETIRED (4008,0300)
IN_CONCATENATION_NUMBER | In-concatenation Number (0020,9162)
IN_CONCATENATION_TOTAL_NUMBER | In-concatenation Total Number (0020,9163)
IN_PLANE_PHASE_ENCODING_DIRECTION | In-plane Phase Encoding Direction (0018,1312)
IN_STACK_POSITION_NUMBER | In-Stack Position Number (0020,9057)
INBOUND_ARRIVAL_TYPE | Inbound Arrival Type (4010,1056)
INCIDENT_ANGLE | Incident Angle (0014,4052)
INCLUDE_DISPLAY_APPLICATION | Include Display Application (2200,0009)
INCLUDE_NON_DICOM_OBJECTS | Include Non-DICOM Objects (2200,0008)
INCLUDES_IMAGING_SUBJECT | Includes Imaging Subject (0034,0008)
INCLUDES_INFORMATION | Includes Information (0034,000C)
INCORPORATED_INVENTORY_INSTANCE_SEQUENCE | Incorporated Inventory Instance Sequence (0008,0422)
INDEX_NORMALS_FLAG | Index Normals Flag (0024,0338)
INDEX_PROBABILITY | Index Probability (0024,0341)
INDEX_PROBABILITY_SEQUENCE | Index Probability Sequence (0024,0344)
INDICATION_DESCRIPTION | Indication Description (0014,2018)
INDICATION_DISPOSITION | Indication Disposition (0014,201C)
INDICATION_LABEL | Indication Label (0014,2016)
INDICATION_NUMBER | Indication Number (0014,2014)
INDICATION_PHYSICAL_PROPERTY_SEQUENCE | Indication Physical Property Sequence (0014,2030)
INDICATION_ROI_SEQUENCE | Indication ROI Sequence (0014,201E)
INDICATION_SEQUENCE | Indication Sequence (0014,2012)
INDICATION_TYPE | Indication Type (0014,201A)
INFORMATION_FROM_MANUFACTURER_SEQUENCE | Information From Manufacturer Sequence (0068,6260)
INFORMATION_ISSUE_DATETIME | Information Issue DateTime (0068,6270)
INFORMATION_SUMMARY | Information Summary (0068,6280)
INITIAL_CINE_RUN_STATE | Initial Cine Run State (0018,0042)
INITIATOR_RETIRED | Initiator RETIRED (0000,0200)
INNER_DIAMETER | Inner Diameter (0014,0056)
INPUT_AVAILABILITY_FLAG_RETIRED | Input Availability Flag RETIRED (0040,4020)
INPUT_INFORMATION_SEQUENCE | Input Information Sequence (0040,4021)
INPUT_READINESS_STATE | Input Readiness State (0040,4041)
INPUT_SEQUENCE_POSITION_INDEX | Input Sequence Position Index (0070,1203)
INSTANCE_AVAILABILITY | Instance Availability (0008,0056)
INSTANCE_COERCION_DATETIME | Instance Coercion DateTime (0008,0015)
INSTANCE_CREATION_DATE | Instance Creation Date (0008,0012)
INSTANCE_CREATION_TIME | Instance Creation Time (0008,0013)
INSTANCE_CREATOR_UID | Instance Creator UID (0008,0014)
INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE | Instance-Level Referenced Performed Procedure Step Sequence (3010,0044)
INSTANCE_NUMBER | Instance Number (0020,0013)
INSTANCE_ORIGIN_STATUS | Instance Origin Status (0400,0600)
INSTITUTION_ADDRESS | Institution Address (0008,0081)
INSTITUTION_CODE_SEQUENCE | Institution Code Sequence (0008,0082)
INSTITUTION_NAME | Institution Name (0008,0080)
INSTITUTIONAL_DEPARTMENT_NAME | Institutional Department Name (0008,1040)
INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE | Institutional Department Type Code Sequence (0008,1041)
INSTRUCTION_DESCRIPTION | Instruction Description (0018,9917)
INSTRUCTION_INDEX | Instruction Index (0018,9915)
INSTRUCTION_PERFORMANCE_COMMENT | Instruction Performance Comment (0018,991A)
INSTRUCTION_PERFORMED_DATETIME | Instruction Performed DateTime (0018,9919)
INSTRUCTION_PERFORMED_FLAG | Instruction Performed Flag (0018,9918)
INSTRUCTION_SEQUENCE | Instruction Sequence (0018,9914)
INSTRUCTION_TEXT | Instruction Text (0018,9916)
INSURANCE_PLAN_IDENTIFICATION_RETIRED | Insurance Plan Identification RETIRED (0010,1050)
INTENDED_DELIVERY_DURATION | Intended Delivery Duration (3010,007E)
INTENDED_FRACTION_START_TIME | Intended Fraction Start Time (3010,0085)
INTENDED_NUMBER_OF_FRACTIONS | Intended Number of Fractions (300A,0636)
INTENDED_PHASE_END_DATE | Intended Phase End Date (3010,004D)
INTENDED_PHASE_START_DATE | Intended Phase Start Date (3010,004C)
INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE | Intended Recipients of Results Identification Sequence (0040,1011)
INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE | Alias for tag INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE (0040,1011)
INTENDED_RT_TREATMENT_PHASE_SEQUENCE | Intended RT Treatment Phase Sequence (3010,004B)
INTENDED_START_DAY_OF_WEEK | Intended Start Day of Week (3010,0086)
INTENSIFIER_ACTIVE_DIMENSIONS | Intensifier Active Dimension(s) (0018,9428)
INTENSIFIER_ACTIVE_SHAPE | Intensifier Active Shape (0018,9427)
INTENSIFIER_SIZE | Intensifier Size (0018,1162)
INTER_MARKER_DISTANCE | Inter-Marker Distance (0050,0019)
INTERLOCK_CODE_SEQUENCE | Interlock Code Sequence (300A,0744)
INTERLOCK_DATETIME | Interlock DateTime (300A,0741)
INTERLOCK_DESCRIPTION | Interlock Description (300A,0742)
INTERLOCK_ORIGIN_DESCRIPTION | Interlock Origin Description (300A,0783)
INTERLOCK_ORIGINATING_DEVICE_SEQUENCE | Interlock Originating Device Sequence (300A,0743)
INTERLOCK_RESOLUTION_CODE_SEQUENCE | Interlock Resolution Code Sequence (300A,0745)
INTERLOCK_RESOLUTION_USER_SEQUENCE | Interlock Resolution User Sequence (300A,0746)
INTERLOCK_SEQUENCE | Interlock Sequence (300A,0740)
INTERMEDIATE_PUPILLARY_DISTANCE | Intermediate Pupillary Distance (0046,0063)
INTERNAL_DETECTOR_FRAME_TIME | Internal Detector Frame Time (0014,3011)
INTERNATIONAL_ROUTE_SEGMENT | International Route Segment (4010,1028)
INTEROPERABILITY_INDEX | Interoperability Index (0016,0061)
INTEROPERABILITY_VERSION | Interoperability Version (0016,0062)
INTERPOLATION_TYPE | Interpolation Type (0052,0039)
INTERPRETATION_APPROVAL_DATE_RETIRED | Interpretation Approval Date RETIRED (4008,0112)
INTERPRETATION_APPROVAL_TIME_RETIRED | Interpretation Approval Time RETIRED (4008,0113)
INTERPRETATION_APPROVER_SEQUENCE_RETIRED | Interpretation Approver Sequence RETIRED (4008,0111)
INTERPRETATION_AUTHOR_RETIRED | Interpretation Author RETIRED (4008,010C)
INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED | Interpretation Diagnosis Code Sequence RETIRED (4008,0117)
INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED | Interpretation Diagnosis Description RETIRED (4008,0115)
INTERPRETATION_ID_ISSUER_RETIRED | Interpretation ID Issuer RETIRED (4008,0202)
INTERPRETATION_ID_RETIRED | Interpretation ID RETIRED (4008,0200)
INTERPRETATION_RECORDED_DATE_RETIRED | Interpretation Recorded Date RETIRED (4008,0100)
INTERPRETATION_RECORDED_TIME_RETIRED | Interpretation Recorded Time RETIRED (4008,0101)
INTERPRETATION_RECORDER_RETIRED | Interpretation Recorder RETIRED (4008,0102)
INTERPRETATION_STATUS_ID_RETIRED | Interpretation Status ID RETIRED (4008,0212)
INTERPRETATION_TEXT_RETIRED | Interpretation Text RETIRED (4008,010B)
INTERPRETATION_TRANSCRIBER_RETIRED | Interpretation Transcriber RETIRED (4008,010A)
INTERPRETATION_TRANSCRIPTION_DATE_RETIRED | Interpretation Transcription Date RETIRED (4008,0108)
INTERPRETATION_TRANSCRIPTION_TIME_RETIRED | Interpretation Transcription Time RETIRED (4008,0109)
INTERPRETATION_TYPE_ID_RETIRED | Interpretation Type ID RETIRED (4008,0210)
INTERVAL_NUMBER_RETIRED | Interval Number RETIRED (0020,0016)
INTERVALS_ACQUIRED | Intervals Acquired (0018,1083)
INTERVALS_REJECTED | Intervals Rejected (0018,1084)
INTERVENTION_DESCRIPTION | Intervention Description (0018,003A)
INTERVENTION_DRUG_CODE_SEQUENCE | Intervention Drug Code Sequence (0018,0029)
INTERVENTION_DRUG_DOSE | Intervention Drug Dose (0018,0028)
INTERVENTION_DRUG_INFORMATION_SEQUENCE | Intervention Drug Information Sequence (0018,0026)
INTERVENTION_DRUG_NAME | Intervention Drug Name (0018,0034)
INTERVENTION_DRUG_SEQUENCE | Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)
INTERVENTION_DRUG_START_TIME | Intervention Drug Start Time (0018,0035)
INTERVENTION_DRUG_STOP_TIME | Intervention Drug Stop Time (0018,0027)
INTERVENTION_SEQUENCE | Intervention Sequence (0018,0036)
INTERVENTION_STATUS | Intervention Status (0018,0038)
INTERVENTIONAL_DRUG_CODE_SEQUENCE | Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)
INTERVENTIONAL_STATUS | Alias for tag INTERVENTION_STATUS (0018,0038)
INTERVENTIONAL_THERAPY_SEQUENCE | Alias for tag INTERVENTION_SEQUENCE (0018,0036)
INTRA_OCULAR_PRESSURE | Intra Ocular Pressure (0022,000B)
INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE | Intraocular Lens Calculations Left Eye Sequence (0022,1310)
INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE | Intraocular Lens Calculations Right Eye Sequence (0022,1300)
INTRAVASCULAR_FRAME_CONTENT_SEQUENCE | Intravascular Frame Content Sequence (0052,0027)
INTRAVASCULAR_LONGITUDINAL_DISTANCE | Intravascular Longitudinal Distance (0052,0028)
INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE | Intravascular OCT Frame Content Sequence (0052,0029)
INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE | Intravascular OCT Frame Type Sequence (0052,0025)
INVENTORIED_INSTANCES_SEQUENCE | Inventoried Instances Sequence (0008,0425)
INVENTORIED_SERIES_SEQUENCE | Inventoried Series Sequence (0008,0424)
INVENTORIED_STUDIES_SEQUENCE | Inventoried Studies Sequence (0008,0423)
INVENTORY_ACCESS_END_POINTS_SEQUENCE | Inventory Access End Points Sequence (0008,0420)
INVENTORY_COMPLETION_STATUS | Inventory Completion Status (0008,0426)
INVENTORY_INSTANCE_DESCRIPTION | Inventory Instance Description (0008,0402)
INVENTORY_LEVEL | Inventory Level (0008,0403)
INVENTORY_PURPOSE | Inventory Purpose (0008,0401)
INVERSION_RECOVERY | Inversion Recovery (0018,9009)
INVERSION_TIME | Inversion Time (0018,0082)
INVERSION_TIMES | Inversion Times (0018,9079)
IOL_FORMULA_CODE_SEQUENCE | IOL Formula Code Sequence (0022,1028)
IOL_FORMULA_DETAIL | IOL Formula Detail (0022,1029)
IOL_MANUFACTURER | IOL Manufacturer (0022,1093)
IOL_POWER | IOL Power (0022,1053)
IOL_POWER_FOR_EXACT_EMMETROPIA | IOL Power For Exact Emmetropia (0022,1121)
IOL_POWER_FOR_EXACT_TARGET_REFRACTION | IOL Power For Exact Target Refraction (0022,1122)
IOL_POWER_SEQUENCE | IOL Power Sequence (0022,1090)
ION_BEAM_LIMITING_DEVICE_SEQUENCE | Ion Beam Limiting Device Sequence (300A,03A4)
ION_BEAM_SEQUENCE | Ion Beam Sequence (300A,03A2)
ION_BLOCK_SEQUENCE | Ion Block Sequence (300A,03A6)
ION_CONTROL_POINT_DELIVERY_SEQUENCE | Ion Control Point Delivery Sequence (3008,0041)
ION_CONTROL_POINT_SEQUENCE | Ion Control Point Sequence (300A,03A8)
ION_CONTROL_POINT_VERIFICATION_SEQUENCE | Ion Control Point Verification Sequence (0074,104E)
ION_MACHINE_VERIFICATION_SEQUENCE | Ion Machine Verification Sequence (0074,1046)
ION_RANGE_COMPENSATOR_SEQUENCE | Ion Range Compensator Sequence (300A,02EA)
ION_TOLERANCE_TABLE_SEQUENCE | Ion Tolerance Table Sequence (300A,03A0)
ION_WEDGE_POSITION_SEQUENCE | Ion Wedge Position Sequence (300A,03AC)
ION_WEDGE_SEQUENCE | Ion Wedge Sequence (300A,03AA)
IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE | Irradiation Event Identification Sequence (0018,9477)
IRRADIATION_EVENT_UID | Irradiation Event UID (0008,3010)
ISO_SPEED | ISO Speed (0016,001D)
ISO_SPEED_LATITUDE_YYY | ISO Speed Latitude yyy (0016,001E)
ISO_SPEED_LATITUDE_ZZZ | ISO Speed Latitude zzz (0016,001F)
ISOCENTER_POSITION | Isocenter Position (300A,012C)
ISOCENTER_REFERENCE_SYSTEM_SEQUENCE | Isocenter Reference System Sequence (0018,9462)
ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE | Isocenter to Beam Limiting Device Distance (300A,00BB)
ISOCENTER_TO_BLOCK_TRAY_DISTANCE | Isocenter to Block Tray Distance (300A,00F7)
ISOCENTER_TO_COMPENSATOR_DISTANCES | Isocenter to Compensator Distances (300A,02E6)
ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE | Isocenter to Compensator Tray Distance (300A,02E4)
ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE | Isocenter to General Accessory Distance (300A,0426)
ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE | Isocenter to Lateral Spreading Device Distance (300A,0374)
ISOCENTER_TO_RANGE_MODULATOR_DISTANCE | Isocenter to Range Modulator Distance (300A,038A)
ISOCENTER_TO_RANGE_SHIFTER_DISTANCE | Isocenter to Range Shifter Distance (300A,0364)
ISOCENTER_TO_WEDGE_TRAY_DISTANCE | Isocenter to Wedge Tray Distance (300A,00D9)
ISOTOPE_NUMBER_RETIRED | Isotope Number RETIRED (0020,0014)
ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST | Issue Date of Imaging Service Request (0040,2004)
ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST | Issue Time of Imaging Service Request (0040,2005)
ISSUER_OF_ACCESSION_NUMBER_SEQUENCE | Issuer of Accession Number Sequence (0008,0051)
ISSUER_OF_ADMISSION_ID_RETIRED | Issuer of Admission ID RETIRED (0038,0011)
ISSUER_OF_ADMISSION_ID_SEQUENCE | Issuer of Admission ID Sequence (0038,0014)
ISSUER_OF_PATIENT_ID | Issuer of Patient ID (0010,0021)
ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE | Issuer of Patient ID Qualifiers Sequence (0010,0024)
ISSUER_OF_SERVICE_EPISODE_ID_RETIRED | Issuer of Service Episode ID RETIRED (0038,0061)
ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE | Issuer of Service Episode ID Sequence (0038,0064)
ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE | Issuer of the Container Identifier Sequence (0040,0513)
ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE | Issuer of the Specimen Identifier Sequence (0040,0562)
ITALIC | Italic (0070,0250)
ITEM_INVENTORY_DATETIME | Item Inventory DateTime (0008,0404)
ITEM_NUMBER | Item Number (0020,0019)
ITERATIVE_RECONSTRUCTION_METHOD | Iterative Reconstruction Method (0018,9769)
ITINERARY_ID | Itinerary ID (4010,1051)
ITINERARY_ID_ASSIGNING_AUTHORITY | Itinerary ID Assigning Authority (4010,1053)
ITINERARY_ID_TYPE | Itinerary ID Type (4010,1052)
IVUS_ACQUISITION | IVUS Acquisition (0018,3100)
IVUS_GATED_RATE | IVUS Gated Rate (0018,3102)
IVUS_PULLBACK_RATE | IVUS Pullback Rate (0018,3101)
IVUS_PULLBACK_START_FRAME_NUMBER | IVUS Pullback Start Frame Number (0018,3103)
IVUS_PULLBACK_STOP_FRAME_NUMBER | IVUS Pullback Stop Frame Number (0018,3104)
K_SPACE_FILTERING | k-space Filtering (0018,9064)
KERATOCONUS_PREDICTION_INDEX | Keratoconus Prediction Index (0046,0236)
KERATOMETER_INDEX | Keratometer Index (0022,1033)
KERATOMETRIC_AXIS | Keratometric Axis (0046,0077)
KERATOMETRIC_POWER | Keratometric Power (0046,0076)
KERATOMETRY_LEFT_EYE_SEQUENCE | Keratometry Left Eye Sequence (0046,0071)
KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE | Keratometry Measurement Type Code Sequence (0022,1096)
KERATOMETRY_RIGHT_EYE_SEQUENCE | Keratometry Right Eye Sequence (0046,0070)
KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE | KV Imaging Generation Parameters Sequence (3002,0127)
KV_USED_IN_GAIN_CALIBRATION | KV Used in Gain Calibration (0014,3071)
KVP | KVP (0018,0060)
LABEL_STYLE_SELECTION | Label Style Selection (2200,0003)
LABEL_TEXT | Label Text (2200,0002)
LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES | Label Using Information Extracted From Instances (2200,0001)
LANGUAGE_CODE_SEQUENCE | Language Code Sequence (0008,0006)
LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED | Language Code Sequence (Trial) RETIRED (0040,A744)
LARGEST_IMAGE_PIXEL_VALUE | Largest Image Pixel Value (0028,0107)
LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED | Largest Image Pixel Value in Plane RETIRED (0028,0111)
LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED | Largest Monochrome Pixel Value RETIRED (0028,9099)
LARGEST_PIXEL_VALUE_IN_SERIES | Largest Pixel Value in Series (0028,0109)
LARGEST_PIXEL_VALUE_RETIRED | Alias for tag LARGEST_VALID_PIXEL_VALUE_RETIRED (0028,0105)
LARGEST_VALID_PIXEL_VALUE_RETIRED | Largest Valid Pixel Value RETIRED (0028,0105)
LAST_MENSTRUAL_DATE | Last Menstrual Date (0010,21D0)
LATERAL_SPREADING_DEVICE_DESCRIPTION | Lateral Spreading Device Description (300A,033A)
LATERAL_SPREADING_DEVICE_ID | Lateral Spreading Device ID (300A,0336)
LATERAL_SPREADING_DEVICE_NUMBER | Lateral Spreading Device Number (300A,0334)
LATERAL_SPREADING_DEVICE_SEQUENCE | Lateral Spreading Device Sequence (300A,0332)
LATERAL_SPREADING_DEVICE_SETTING | Lateral Spreading Device Setting (300A,0372)
LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE | Lateral Spreading Device Settings Sequence (300A,0370)
LATERAL_SPREADING_DEVICE_TYPE | Lateral Spreading Device Type (300A,0338)
LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS | Lateral Spreading Device Water Equivalent Thickness (300A,033C)
LATERALITY | Laterality (0020,0060)
LEAF_JAW_POSITIONS | Leaf/Jaw Positions (300A,011C)
LEAF_POSITION_BOUNDARIES | Leaf Position Boundaries (300A,00BE)
LEFT_IMAGE_SEQUENCE | Left Image Sequence (0022,0021)
LEFT_LENS_SEQUENCE | Left Lens Sequence (0046,0015)
LENGTH_TO_END_RETIRED | Length to End RETIRED (0008,0001)
LENS_CONSTANT_DESCRIPTION_RETIRED | Lens Constant Description RETIRED (0022,1094)
LENS_CONSTANT_SEQUENCE | Lens Constant Sequence (0022,1092)
LENS_DESCRIPTION | Lens Description (0046,0012)
LENS_MAKE | Lens Make (0016,004F)
LENS_MODEL | Lens Model (0016,0050)
LENS_SEGMENT_TYPE | Lens Segment Type (0046,0038)
LENS_SERIAL_NUMBER | Lens Serial Number (0016,0051)
LENS_SPECIFICATION | Lens Specification (0016,004E)
LENS_STATUS_CODE_SEQUENCE | Lens Status Code Sequence (0022,1024)
LENS_STATUS_DESCRIPTION | Lens Status Description (0022,1065)
LENS_THICKNESS | Lens Thickness (0022,1130)
LENS_THICKNESS_SEQUENCE | Lens Thickness Sequence (0022,1127)
LENSES_CODE_SEQUENCE | Lenses Code Sequence (0022,0019)
LESION_NUMBER | Lesion Number (0018,3105)
LIGHT_DIRECTION | Light Direction (0070,1703)
LIGHT_PATH_FILTER_PASS_BAND | Light Path Filter Pass Band (0022,0002)
LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH | Light Path Filter Pass-Through Wavelength (0022,0001)
LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE | Light Path Filter Type Stack Code Sequence (0022,0017)
LIGHT_SOURCE | Light Source (0016,0028)
LIGHT_SOURCE_POLARIZATION | Light Source Polarization (0016,1001)
LINAC_ENERGY | LINAC Energy (0014,5002)
LINAC_OUTPUT | LINAC Output (0014,5004)
LINE_DASHING_STYLE | Line Dashing Style (0070,0254)
LINE_PATTERN | Line Pattern (0070,0255)
LINE_SEQUENCE | Line Sequence (0066,0028)
LINE_STYLE_SEQUENCE | Line Style Sequence (0070,0232)
LINE_THICKNESS | Line Thickness (0070,0253)
LIST_OF_MIME_TYPES | List of MIME Types (0042,0014)
LIST_OF_UID_MATCHING_SEQUENCE | List of UID Matching Sequence (0008,0411)
LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG | Local Deviation Probability Normals Flag (0024,0072)
LOCAL_NAMESPACE_ENTITY_ID | Local Namespace Entity ID (0040,0031)
LOCALIZED_DEVIATION_FROM_NORMAL | Localized Deviation From Normal (0024,0068)
LOCALIZED_DEVIATION_PROBABILITY | Localized Deviation Probability (0024,0073)
LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE | Localized Deviation Probability Sequence (0024,0085)
LOCALIZING_CURSOR_POSITION | Localizing Cursor Position (0018,2043)
LOCATION_OF_MEASURED_BEAM_DIAMETER | Location of Measured Beam Diameter (0014,4019)
LOCATION_RETIRED | Location RETIRED (0020,0050)
LONG_CODE_VALUE | Long Code Value (0008,0119)
LONG_DEVICE_DESCRIPTION | Long Device Description (0050,0021)
LONG_EDGE_POINT_INDEX_LIST | Long Edge Point Index List (0066,0042)
LONG_PRIMITIVE_POINT_INDEX_LIST | Long Primitive Point Index List (0066,0040)
LONG_TRIANGLE_POINT_INDEX_LIST | Long Triangle Point Index List (0066,0041)
LONG_VERTEX_POINT_INDEX_LIST | Long Vertex Point Index List (0066,0043)
LONGITUDINAL_TEMPORAL_EVENT_TYPE | Longitudinal Temporal Event Type (0012,0053)
LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED | Longitudinal Temporal Information Modified (0028,0303)
LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT | Longitudinal Temporal Offset from Event (0012,0052)
LOOKUP_TABLE_NUMBER | Alias for tag LUT_NUMBER_RETIRED (0020,0026)
LOSSY_IMAGE_COMPRESSION | Lossy Image Compression (0028,2110)
LOSSY_IMAGE_COMPRESSION_METHOD | Lossy Image Compression Method (0028,2114)
LOSSY_IMAGE_COMPRESSION_RATIO | Lossy Image Compression Ratio (0028,2112)
LOSSY_IMAGE_COMPRESSION_RETIRED | Lossy Image Compression (Retired) (0008,2110)
LOW_ENERGY_DETECTORS | Low Energy Detectors (4010,0001)
LOW_R_R_VALUE | Low R-R Value (0018,1081)
LOWER_CUTOFF_FREQUENCY | Lower Cutoff Frequency (0018,982F)
LUMINANCE_CHARACTERISTICS_ID | Luminance Characteristics ID (0028,7009)
LUMINANCE_RESPONSE_DESCRIPTION | Luminance Response Description (0028,7020)
LUMINANCE_RESPONSE_SEQUENCE | Luminance Response Sequence (0028,701C)
LUMINANCE_RESULT_SEQUENCE | Luminance Result Sequence (0028,7024)
LUMINANCE_UNIFORMITY_RESULT_SEQUENCE | Luminance Uniformity Result Sequence (0028,7027)
LUMINANCE_VALUE | Luminance Value (0028,701F)
LUT_DATA | LUT Data (0028,3006)
LUT_DESCRIPTOR | LUT Descriptor (0028,3002)
LUT_EXPLANATION | LUT Explanation (0028,3003)
LUT_FRAME_RANGE | LUT Frame Range (0028,9507)
LUT_FUNCTION | LUT Function (0028,9474)
LUT_LABEL | LUT Label (0040,9210)
LUT_NUMBER_RETIRED | LUT Number RETIRED (0020,0026)
MA_USED_IN_GAIN_CALIBRATION | MA Used in Gain Calibration (0014,3072)
MAC | MAC (0400,0404)
MAC_ALGORITHM | MAC Algorithm (0400,0015)
MAC_CALCULATION_TRANSFER_SYNTAX_UID | MAC Calculation Transfer Syntax UID (0400,0010)
MAC_ID_NUMBER | MAC ID Number (0400,0005)
MAC_PARAMETERS_SEQUENCE | MAC Parameters Sequence (4FFE,0001)
MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE | Machine-Specific Treatment Termination Code Sequence (300A,0716)
MAGNETIC_FIELD_STRENGTH | Magnetic Field Strength (0018,0087)
MAGNETIZATION_TRANSFER | Magnetization Transfer (0018,9020)
MAGNIFICATION_TYPE | Magnification Type (2010,0060)
MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED | Magnify to Number of Columns RETIRED (2040,0074)
MAGNITUDE_ENCODING_CODE_SEQUENCE | Magnitude Encoding Code Sequence (003A,032D)
MAJOR_TICKS_SEQUENCE | Major Ticks Sequence (0070,0287)
MAKER_NOTE | Maker Note (0016,002B)
MANDATORY_COMPONENT_TYPE | Mandatory Component Type (0076,0038)
MANIFOLD | Manifold (0066,0010)
MANIPULATED_IMAGE_RETIRED | Manipulated Image RETIRED (0028,0050)
MANUFACTURER | Manufacturer (0008,0070)
MANUFACTURERS_DEVICE_CLASS_UID | Manufacturer's Device Class UID (0018,100B)
MANUFACTURERS_DEVICE_IDENTIFIER | Manufacturer's Device Identifier (3010,0043)
MANUFACTURERS_MODEL_NAME | Manufacturer's Model Name (0008,1090)
MANUFACTURERS_MODEL_VERSION | Manufacturer's Model Version (3010,001A)
MANUFACTURERS_RELATED_MODEL_GROUP | Manufacturer's Related Model Group (0008,0222)
MAPPED_PIXEL_VALUE | Mapped Pixel Value (0022,1452)
MAPPING_RESOURCE | Mapping Resource (0008,0105)
MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE | Mapping Resource Identification Sequence (0008,0124)
MAPPING_RESOURCE_NAME | Mapping Resource Name (0008,0122)
MAPPING_RESOURCE_UID | Mapping Resource UID (0008,0118)
MASK_FRAME_NUMBERS | Mask Frame Numbers (0028,6110)
MASK_OPERATION | Mask Operation (0028,6101)
MASK_OPERATION_EXPLANATION | Mask Operation Explanation (0028,6190)
MASK_POINTERS_RETIRED | Mask Pointer(s) RETIRED (0028,6030)
MASK_SELECTION_MODE | Mask Selection Mode (0028,9454)
MASK_SUB_PIXEL_SHIFT | Mask Sub-pixel Shift (0028,6114)
MASK_SUBTRACTION_SEQUENCE | Mask Subtraction Sequence (0028,6100)
MASK_VISIBILITY_PERCENTAGE | Mask Visibility Percentage (0028,9478)
MASKING_IMAGE_RETIRED | Masking Image RETIRED (0020,0080)
MASS | Mass (4010,1017)
MATERIAL_ATTENUATION_SEQUENCE | Material Attenuation Sequence (0018,9382)
MATERIAL_CODE_SEQUENCE | Material Code Sequence (0018,937D)
MATERIAL_GRADE | Material Grade (0014,0042)
MATERIAL_ID | Material ID (300A,00E1)
MATERIAL_ISOLATION_DIAMETER | Material Isolation Diameter (0014,0034)
MATERIAL_NOTES | Material Notes (0014,0046)
MATERIAL_PIPE_DIAMETER | Material Pipe Diameter (0014,0032)
MATERIAL_PROPERTIES_DESCRIPTION | Material Properties Description (0014,0044)
MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED | Material Properties File Format (Retired) (0014,0045)
MATERIAL_THICKNESS | Material Thickness (0014,0030)
MATERIALS_CODE_SEQUENCE | Materials Code Sequence (0068,63A0)
MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE | Mating Feature Degree of Freedom Sequence (0068,6400)
MATING_FEATURE_ID | Mating Feature ID (0068,63F0)
MATING_FEATURE_SEQUENCE | Mating Feature Sequence (0068,63E0)
MATING_FEATURE_SET_ID | Mating Feature Set ID (0068,63C0)
MATING_FEATURE_SET_LABEL | Mating Feature Set Label (0068,63D0)
MATING_FEATURE_SETS_SEQUENCE | Mating Feature Sets Sequence (0068,63B0)
MATRIX_REGISTRATION_SEQUENCE | Matrix Registration Sequence (0070,0309)
MATRIX_SEQUENCE | Matrix Sequence (0070,030A)
MAX_APERTURE_VALUE | Max Aperture Value (0016,0025)
MAX_DENSITY | Max Density (2010,0130)
MAXIMUM_ACROSS_SCAN_DISTORTION | Maximum Across-scan Distortion (0022,0049)
MAXIMUM_ALONG_SCAN_DISTORTION | Maximum Along-scan Distortion (0022,0038)
MAXIMUM_COLLATED_FILMS | Maximum Collated Films (2010,0154)
MAXIMUM_COORDINATE_VALUE_RETIRED | Maximum Coordinate Value RETIRED (5000,0105)
MAXIMUM_CORNEAL_CURVATURE | Maximum Corneal Curvature (0046,0212)
MAXIMUM_CORNEAL_CURVATURE_LOCATION | Maximum Corneal Curvature Location (0046,0213)
MAXIMUM_CORNEAL_CURVATURE_SEQUENCE | Maximum Corneal Curvature Sequence (0046,0211)
MAXIMUM_CUMULATIVE_METERSET_EXPOSURE | Maximum Cumulative Meterset Exposure (3002,0134)
MAXIMUM_DEPTH_DISTORTION | Maximum Depth Distortion (0022,0036)
MAXIMUM_FRACTIONAL_VALUE | Maximum Fractional Value (0062,000E)
MAXIMUM_MEMORY_ALLOCATION | Maximum Memory Allocation (2000,0061)
MAXIMUM_NOMINAL_ENERGY | Maximum Nominal Energy (300A,0682)
MAXIMUM_NUMBER_OF_INTERVAL_DAYS | Maximum Number of Interval Days (3010,0051)
MAXIMUM_NUMBER_OF_RECORDS | Maximum Number of Records (0008,0429)
MAXIMUM_POINT_DISTANCE | Maximum Point Distance (0066,0019)
MAXIMUM_STIMULUS_LUMINANCE | Maximum Stimulus Luminance (0024,0018)
MAXIMUM_STORED_VALUE_MAPPED | Maximum Stored Value Mapped (0028,1232)
MEAN_POINT_DISTANCE | Mean Point Distance (0066,0018)
MEASURED_AP_DIMENSION | Measured AP Dimension (0010,1023)
MEASURED_BANDWIDTH | Measured Bandwidth (0014,401C)
MEASURED_BEAM_DIMENSION_A | Measured Beam Dimension A (0014,4017)
MEASURED_BEAM_DIMENSION_B | Measured Beam Dimension B (0014,4018)
MEASURED_CENTER_FREQUENCY | Measured Center Frequency (0014,401B)
MEASURED_CHARACTERISTICS | Measured Characteristics (0028,7026)
MEASURED_DOSE_DESCRIPTION | Measured Dose Description (3008,0012)
MEASURED_DOSE_REFERENCE_NUMBER | Measured Dose Reference Number (3008,0064)
MEASURED_DOSE_REFERENCE_SEQUENCE | Measured Dose Reference Sequence (3008,0010)
MEASURED_DOSE_TYPE | Measured Dose Type (3008,0014)
MEASURED_DOSE_VALUE | Measured Dose Value (3008,0016)
MEASURED_LATERAL_DIMENSION | Measured Lateral Dimension (0010,1024)
MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE | Measured Meterset to Dose Mapping Sequence (300A,0772)
MEASURED_VALUE_SEQUENCE | Measured Value Sequence (0040,A300)
MEASUREMENT_AUTOMATION_TRIAL_RETIRED | Measurement Automation (Trial) RETIRED (0040,A194)
MEASUREMENT_EQUIPMENT_SEQUENCE | Measurement Equipment Sequence (0028,7012)
MEASUREMENT_EQUIPMENT_TYPE | Measurement Equipment Type (0028,7014)
MEASUREMENT_FUNCTIONS | Measurement Functions (0028,7013)
MEASUREMENT_LATERALITY | Measurement Laterality (0024,0113)
MEASUREMENT_PATTERN_CODE_SEQUENCE | Measurement Pattern Code Sequence (0028,702D)
MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED | Measurement Precision Description (Trial) RETIRED (0040,A047)
MEASUREMENT_UNITS_CODE_SEQUENCE | Measurement Units Code Sequence (0040,08EA)
MEASUREMENT_VALUES_SEQUENCE | Measurement Values Sequence (0066,0132)
MEASUREMENTS_SEQUENCE | Measurements Sequence (0066,0121)
MEASURING_UNITS_SEQUENCE | Measuring Units Sequence (0040,0295)
MECHANICAL_INDEX | Mechanical Index (0018,5022)
MEDIA_DISPOSITION | Media Disposition (2200,0004)
MEDIA_INSTALLED_SEQUENCE | Media Installed Sequence (2000,00A2)
MEDIA_STORAGE_SOP_CLASS_UID | Media Storage SOP Class UID (0002,0002)
MEDIA_STORAGE_SOP_INSTANCE_UID | Media Storage SOP Instance UID (0002,0003)
MEDICAL_ALERTS | Medical Alerts (0010,2000)
MEDICAL_RECORD_LOCATOR_RETIRED | Medical Record Locator RETIRED (0010,1090)
MEDIUM_TYPE | Medium Type (2000,0030)
MEMORY_ALLOCATION | Memory Allocation (2000,0060)
MEMORY_BIT_DEPTH | Memory Bit Depth (2000,00A0)
MESSAGE_ID | Message ID (0000,0110)
MESSAGE_ID_BEING_RESPONDED_TO | Message ID Being Responded To (0000,0120)
MESSAGE_SET_ID_RETIRED | Message Set ID RETIRED (0000,5010)
METABOLITE_MAP_CODE_SEQUENCE | Metabolite Map Code Sequence (0018,9083)
METABOLITE_MAP_DESCRIPTION | Metabolite Map Description (0018,9080)
METADATA_SEQUENCE | Metadata Sequence (0008,041D)
METERING_MODE | Metering Mode (0016,0027)
METERSET_EXPOSURE | Meterset Exposure (3002,0032)
METERSET_RATE | Meterset Rate (300A,035A)
METERSET_RATE_DELIVERED | Meterset Rate Delivered (3008,0046)
METERSET_RATE_SET | Meterset Rate Set (3008,0045)
METERSET_TO_DOSE_MAPPING_SEQUENCE | Meterset to Dose Mapping Sequence (300A,0620)
MID_SLAB_POSITION | Mid Slab Position (0018,9106)
MILITARY_RANK | Military Rank (0010,1080)
MIME_TYPE_OF_ENCAPSULATED_DOCUMENT | MIME Type of Encapsulated Document (0042,0012)
MIN_DENSITY | Min Density (2010,0120)
MINIMUM_COORDINATE_VALUE_RETIRED | Minimum Coordinate Value RETIRED (5000,0104)
MINIMUM_HOURS_BETWEEN_FRACTIONS | Minimum Hours between Fractions (3010,0084)
MINIMUM_KERATOMETRIC_SEQUENCE | Minimum Keratometric Sequence (0046,0215)
MINIMUM_NOMINAL_ENERGY | Minimum Nominal Energy (300A,0681)
MINIMUM_NUMBER_OF_INTERVAL_DAYS | Minimum Number of Interval Days (3010,0050)
MINIMUM_SENSITIVITY_VALUE | Minimum Sensitivity Value (0024,0105)
MINIMUM_STORED_VALUE_MAPPED | Minimum Stored Value Mapped (0028,1231)
MODALITIES_IN_STUDY | Modalities in Study (0008,0061)
MODALITY | Modality (0008,0060)
MODALITY_LUT_SEQUENCE | Modality LUT Sequence (0028,3000)
MODALITY_LUT_TYPE | Modality LUT Type (0028,3004)
MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE | Mode of Percutaneous Access Sequence (0052,0016)
MODEL_GROUP_UID | Model Group UID (0068,7004)
MODEL_MIRRORING | Model Mirroring (0068,7002)
MODEL_MODIFICATION | Model Modification (0068,7001)
MODEL_SPECIFICATION_SEQUENCE | Model Specification Sequence (0018,9912)
MODEL_USAGE_CODE_SEQUENCE | Model Usage Code Sequence (0068,7003)
MODIFIABLE_CONSTRAINT_FLAG | Modifiable Constraint Flag (0082,0038)
MODIFIED_ATTRIBUTES_SEQUENCE | Modified Attributes Sequence (0400,0550)
MODIFIED_IMAGE_DATE_RETIRED | Modified Image Date RETIRED (0020,3403)
MODIFIED_IMAGE_DESCRIPTION_RETIRED | Modified Image Description RETIRED (0020,3406)
MODIFIED_IMAGE_ID_RETIRED | Modified Image ID RETIRED (0020,3402)
MODIFIED_IMAGE_TIME_RETIRED | Modified Image Time RETIRED (0020,3405)
MODIFIER_CODE_SEQUENCE | Modifier Code Sequence (0040,A195)
MODIFYING_DEVICE_ID_RETIRED | Modifying Device ID RETIRED (0020,3401)
MODIFYING_DEVICE_MANUFACTURER_RETIRED | Modifying Device Manufacturer RETIRED (0020,3404)
MODIFYING_SYSTEM | Modifying System (0400,0563)
MODULATED_SCAN_MODE_TYPE | Modulated Scan Mode Type (300A,0309)
MODULATION_TYPE | Modulation Type (0014,4026)
MONOENERGETIC_ENERGY_EQUIVALENT | Monoenergetic Energy Equivalent (0018,937C)
MOST_RECENT_TREATMENT_DATE | Most Recent Treatment Date (3008,0056)
MOTION_SYNCHRONIZATION_SEQUENCE | Motion Synchronization Sequence (300A,0410)
MOVE_DESTINATION | Move Destination (0000,0600)
MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE | Move Originator Application Entity Title (0000,1030)
MOVE_ORIGINATOR_MESSAGE_ID | Move Originator Message ID (0000,1031)
MPR_SLAB_THICKNESS | MPR Slab Thickness (0070,1503)
MPR_THICKNESS_TYPE | MPR Thickness Type (0070,1502)
MPR_TOP_LEFT_HAND_CORNER | MPR Top Left Hand Corner (0070,1505)
MPR_VIEW_HEIGHT | MPR View Height (0070,1512)
MPR_VIEW_HEIGHT_DIRECTION | MPR View Height Direction (0070,1511)
MPR_VIEW_WIDTH | MPR View Width (0070,1508)
MPR_VIEW_WIDTH_DIRECTION | MPR View Width Direction (0070,1507)
MR_ACQUISITION_FREQ_ENC_STEPS | Alias for tag MR_ACQUISITION_FREQUENCY_ENCODING_STEPS (0018,9058)
MR_ACQUISITION_FREQUENCY_ENCODING_STEPS | MR Acquisition Frequency Encoding Steps (0018,9058)
MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE | MR Acquisition Phase Encoding Steps in-plane (0018,9231)
MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE | MR Acquisition Phase Encoding Steps out-of-plane (0018,9232)
MR_ACQUISITION_TYPE | MR Acquisition Type (0018,0023)
MR_ARTERIAL_SPIN_LABELING_SEQUENCE | MR Arterial Spin Labeling Sequence (0018,9251)
MR_AVERAGES_SEQUENCE | MR Averages Sequence (0018,9119)
MR_DIFFUSION_SEQUENCE | MR Diffusion Sequence (0018,9117)
MR_ECHO_SEQUENCE | MR Echo Sequence (0018,9114)
MR_FOV_GEOMETRY_SEQUENCE | MR FOV/Geometry Sequence (0018,9125)
MR_IMAGE_FRAME_TYPE_SEQUENCE | MR Image Frame Type Sequence (0018,9226)
MR_IMAGING_MODIFIER_SEQUENCE | MR Imaging Modifier Sequence (0018,9006)
MR_METABOLITE_MAP_SEQUENCE | MR Metabolite Map Sequence (0018,9152)
MR_MODIFIER_SEQUENCE | MR Modifier Sequence (0018,9115)
MR_RECEIVE_COIL_SEQUENCE | MR Receive Coil Sequence (0018,9042)
MR_SPATIAL_SATURATION_SEQUENCE | MR Spatial Saturation Sequence (0018,9107)
MR_SPECTROSCOPY_ACQUISITION_TYPE | MR Spectroscopy Acquisition Type (0018,9200)
MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE | MR Spectroscopy FOV/Geometry Sequence (0018,9103)
MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE | MR Spectroscopy Frame Type Sequence (0018,9227)
MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE | MR Timing and Related Parameters Sequence (0018,9112)
MR_TRANSMIT_COIL_SEQUENCE | MR Transmit Coil Sequence (0018,9049)
MR_VELOCITY_ENCODING_SEQUENCE | MR Velocity Encoding Sequence (0018,9197)
MRDR_DIRECTORY_RECORD_OFFSET_RETIRED | MRDR Directory Record Offset RETIRED (0004,1504)
MULIPLEX_GROUP_LABEL | Alias for tag MULTIPLEX_GROUP_LABEL (003A,0020)
MULTI_COIL_CONFIGURATION | Multi-Coil Configuration (0018,9046)
MULTI_COIL_DEFINITION_SEQUENCE | Multi-Coil Definition Sequence (0018,9045)
MULTI_COIL_ELEMENT_NAME | Multi-Coil Element Name (0018,9047)
MULTI_COIL_ELEMENT_USED | Multi-Coil Element Used (0018,9048)
MULTI_ENERGY_ACQUISITION_DESCRIPTION | Multi-energy Acquisition Description (0018,937B)
MULTI_ENERGY_CT_ACQUISITION | Multi-energy CT Acquisition (0018,9361)
MULTI_ENERGY_CT_ACQUISITION_SEQUENCE | Multi-energy CT Acquisition Sequence (0018,9362)
MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE | Multi-energy CT Characteristics Sequence (0018,9364)
MULTI_ENERGY_CT_PATH_INDEX | Multi-energy CT Path Index (0018,937A)
MULTI_ENERGY_CT_PATH_SEQUENCE | Multi-energy CT Path Sequence (0018,9379)
MULTI_ENERGY_CT_PROCESSING_SEQUENCE | Multi-energy CT Processing Sequence (0018,9363)
MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE | Multi-energy CT X-Ray Detector Sequence (0018,936F)
MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE | Multi-energy CT X-Ray Source Sequence (0018,9365)
MULTI_ENERGY_DETECTOR_TYPE | Multi-energy Detector Type (0018,9372)
MULTI_ENERGY_SOURCE_TECHNIQUE | Multi-energy Source Technique (0018,9368)
MULTI_FRAME_PRESENTATION_SEQUENCE | Multi-frame Presentation Sequence (0028,9505)
MULTI_FRAME_SOURCE_SOP_INSTANCE_UID | Multi-frame Source SOP Instance UID (0008,1167)
MULTI_PLANAR_EXCITATION | Multi-planar Excitation (0018,9012)
MULTI_PLANAR_RECONSTRUCTION_STYLE | Multi-Planar Reconstruction Style (0070,1501)
MULTIPLE_COPIES_FLAG_RETIRED | Multiple Copies Flag RETIRED (0040,4006)
MULTIPLE_SPIN_ECHO | Multiple Spin Echo (0018,9011)
MULTIPLEX_GROUP_LABEL | Multiplex Group Label (003A,0020)
MULTIPLEX_GROUP_TIME_OFFSET | Multiplex Group Time Offset (0018,1068)
MULTIPLEX_GROUP_UID | Multiplex Group UID (003A,0310)
MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE | Multiplexed Audio Channels Description Code Sequence (003A,0300)
MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE | MV Imaging Generation Parameters Sequence (3002,0128)
MYDRIATIC_AGENT_CODE_SEQUENCE | Mydriatic Agent Code Sequence (0022,001C)
MYDRIATIC_AGENT_CONCENTRATION | Mydriatic Agent Concentration (0022,004E)
MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE | Mydriatic Agent Concentration Units Sequence (0022,0042)
MYDRIATIC_AGENT_SEQUENCE | Mydriatic Agent Sequence (0022,0058)
NAME_OF_PHYSICIANS_READING_STUDY | Name of Physician(s) Reading Study (0008,1060)
NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS | Names of Intended Recipients of Results (0040,1010)
NAVIGATION_DISPLAY_SET | Navigation Display Set (0072,0216)
NAVIGATION_INDICATOR_SEQUENCE | Navigation Indicator Sequence (0072,0214)
NEAR_PUPILLARY_DISTANCE | Near Pupillary Distance (0046,0062)
NEGATIVE_CATCH_TRIALS_QUANTITY | Negative Catch Trials Quantity (0024,0048)
NETWORK_ID_RETIRED | Network ID RETIRED (0008,1000)
NOMINAL_BEAM_ENERGY | Nominal Beam Energy (300A,0114)
NOMINAL_BEAM_ENERGY_UNIT | Nominal Beam Energy Unit (300A,0015)
NOMINAL_CARDIAC_TRIGGER_DELAY_TIME | Nominal Cardiac Trigger Delay Time (0020,9153)
NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK | Nominal Cardiac Trigger Time Prior To R-Peak (0020,9154)
NOMINAL_ENERGY | Nominal Energy (300A,0680)
NOMINAL_FREQUENCY | Nominal Frequency (0014,401A)
NOMINAL_INTERVAL | Nominal Interval (0018,1062)
NOMINAL_MAX_ENERGY | Nominal Max Energy (0018,9374)
NOMINAL_MIN_ENERGY | Nominal Min Energy (0018,9375)
NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE | Nominal Percentage of Cardiac Phase (0020,9241)
NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE | Nominal Percentage of Respiratory Phase (0020,9245)
NOMINAL_PRIOR_DOSE | Nominal Prior Dose (300A,001A)
NOMINAL_RANGE_MODULATED_REGION_DEPTHS | Nominal Range Modulated Region Depths (300A,0504)
NOMINAL_RANGE_MODULATION_FRACTIONS | Nominal Range Modulation Fractions (300A,0503)
NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME | Nominal Respiratory Trigger Delay Time (0020,9255)
NOMINAL_SCANNED_PIXEL_SPACING | Nominal Scanned Pixel Spacing (0018,2010)
NOMINAL_SCREEN_DEFINITION_SEQUENCE | Nominal Screen Definition Sequence (0072,0102)
NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED | Non-DICOM Output Code Sequence RETIRED (0040,4032)
NON_UNIFORM_RADIAL_SAMPLING_CORRECTED | Non-uniform Radial Sampling Corrected (0018,9766)
NONCONFORMING_DATA_ELEMENT_VALUE | Nonconforming Data Element Value (0400,0552)
NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE | Nonconforming Modified Attributes Sequence (0400,0551)
NONIDENTIFYING_PRIVATE_ELEMENTS | Nonidentifying Private Elements (0008,0304)
NORMAL_REVERSE_RETIRED | Normal/Reverse RETIRED (0000,5140)
NORMALIZATION_POINT | Normalization Point (3004,0008)
NOTCH_FILTER_BANDWIDTH | Notch Filter Bandwidth (003A,0223)
NOTCH_FILTER_CHARACTERISTICS_SEQUENCE | Notch Filter Characteristics Sequence (003A,0321)
NOTCH_FILTER_FREQUENCY | Notch Filter Frequency (003A,0222)
NOTIFICATION_FROM_MANUFACTURER_SEQUENCE | Notification From Manufacturer Sequence (0068,6265)
NTP_SOURCE_ADDRESS | NTP Source Address (0018,1803)
NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED | Nuclear Medicine Series Type RETIRED (0008,0042)
NUMBER_OF_ACQUISITION_DEVICES | Number of Acquisition Devices (3002,0116)
NUMBER_OF_ALARM_OBJECTS | Number of Alarm Objects (4010,1034)
NUMBER_OF_ANNOTATIONS | Number of Annotations (006A,000C)
NUMBER_OF_ASSESSMENT_OBSERVATIONS | Number of Assessment Observations (0082,0006)
NUMBER_OF_AVERAGES | Number of Averages (0018,0083)
NUMBER_OF_B_SCANS_PER_FRAME | Number of B-scans Per Frame (0022,1642)
NUMBER_OF_BEAMS | Number of Beams (300A,0080)
NUMBER_OF_BLOCK_SLAB_ITEMS | Number of Block Slab Items (300A,0440)
NUMBER_OF_BLOCKS | Number of Blocks (300A,00F0)
NUMBER_OF_BOLI | Number of Boli (300A,00ED)
NUMBER_OF_BOLUSES | Number of Boluses (300A,0674)
NUMBER_OF_BRACHY_APPLICATION_SETUPS | Number of Brachy Application Setups (300A,00A0)
NUMBER_OF_CHANNELS_RETIRED | Number of Channels RETIRED (5000,2004)
NUMBER_OF_COMPENSATORS | Number of Compensators (300A,00E0)
NUMBER_OF_COMPLETED_SUB_OPERATIONS | Number of Completed Sub-operations (0000,1021)
NUMBER_OF_COMPLETED_SUBOPERATIONS | Alias for tag NUMBER_OF_COMPLETED_SUB_OPERATIONS (0000,1021)
NUMBER_OF_CONTOUR_POINTS | Number of Contour Points (3006,0046)
NUMBER_OF_CONTROL_POINTS | Number of Control Points (300A,0110)
NUMBER_OF_COPIES | Number of Copies (2000,0010)
NUMBER_OF_DETECTORS | Number of Detectors (0054,0021)
NUMBER_OF_DISPLAY_SUBSYSTEMS | Number of Display Subsystems (0028,7001)
NUMBER_OF_ELEMENTS | Number of Elements (0014,4012)
NUMBER_OF_ENERGY_WINDOWS | Number of Energy Windows (0054,0011)
NUMBER_OF_EVENT_TIMERS | Number of Event Timers (0008,2129)
NUMBER_OF_FAILED_SUB_OPERATIONS | Number of Failed Sub-operations (0000,1022)
NUMBER_OF_FAILED_SUBOPERATIONS | Alias for tag NUMBER_OF_FAILED_SUB_OPERATIONS (0000,1022)
NUMBER_OF_FILMS | Number of Films (2100,0170)
NUMBER_OF_FOCAL_PLANES | Number of Focal Planes (0048,0013)
NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY | Number of Fraction Pattern Digits Per Day (300A,0079)
NUMBER_OF_FRACTIONS | Number of Fractions (3010,007D)
NUMBER_OF_FRACTIONS_DELIVERED | Number of Fractions Delivered (3008,005A)
NUMBER_OF_FRACTIONS_INCLUDED | Number of Fractions Included (300C,0119)
NUMBER_OF_FRACTIONS_PER_DAY | Alias for tag NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY (300A,0079)
NUMBER_OF_FRACTIONS_PLANNED | Number of Fractions Planned (300A,0078)
NUMBER_OF_FRAMES | Number of Frames (0028,0008)
NUMBER_OF_FRAMES_IN_OVERLAY | Number of Frames in Overlay (6000,0015)
NUMBER_OF_FRAMES_IN_PHASE | Number of Frames in Phase (0054,0033)
NUMBER_OF_FRAMES_IN_ROTATION | Number of Frames in Rotation (0054,0053)
NUMBER_OF_FRAMES_INTEGRATED | Number of Frames Integrated (0014,3012)
NUMBER_OF_FRAMES_USED_FOR_INTEGRATION | Number of Frames Used for Integration (0014,3073)
NUMBER_OF_GENERAL_ACCESSORIES | Number of General Accessories (300A,0672)
NUMBER_OF_GRAPHIC_POINTS | Number of Graphic Points (0070,0021)
NUMBER_OF_HORIZONTAL_PIXELS | Number of Horizontal Pixels (0072,0106)
NUMBER_OF_INTERVAL_FRACTIONS | Number of Interval Fractions (3010,007C)
NUMBER_OF_ITERATIONS | Number of Iterations (0018,9739)
NUMBER_OF_K_SPACE_TRAJECTORIES | Number of k-Space Trajectories (0018,9093)
NUMBER_OF_LATERAL_SPREADING_DEVICES | Number of Lateral Spreading Devices (300A,0330)
NUMBER_OF_LEAF_JAW_PAIRS | Number of Leaf/Jaw Pairs (300A,00BC)
NUMBER_OF_LUMINANCE_POINTS | Number of Luminance Points (0028,701B)
NUMBER_OF_MAP_POINTS | Number of Map Points (0022,1530)
NUMBER_OF_MATCHES_RETIRED | Number of Matches RETIRED (0000,0850)
NUMBER_OF_OPTICAL_PATHS | Number of Optical Paths (0048,0302)
NUMBER_OF_PADDED_A_LINES | Number of Padded A-lines (0052,0038)
NUMBER_OF_PAINTINGS | Number of Paintings (300A,039A)
NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS | Number of Parallel RT Beam Delimiters (300A,0648)
NUMBER_OF_PATIENT_RELATED_IMAGES | Alias for tag NUMBER_OF_PATIENT_RELATED_INSTANCES (0020,1204)
NUMBER_OF_PATIENT_RELATED_INSTANCES | Number of Patient Related Instances (0020,1204)
NUMBER_OF_PATIENT_RELATED_SERIES | Number of Patient Related Series (0020,1202)
NUMBER_OF_PATIENT_RELATED_STUDIES | Number of Patient Related Studies (0020,1200)
NUMBER_OF_PATIENT_SUPPORT_DEVICES | Number of Patient Support Devices (300A,0687)
NUMBER_OF_PHASE_ENCODING_STEPS | Number of Phase Encoding Steps (0018,0089)
NUMBER_OF_PHASES | Number of Phases (0054,0031)
NUMBER_OF_POINTS | Alias for tag NUMBER_OF_SURFACE_POINTS (0066,0015)
NUMBER_OF_POINTS_RETIRED | Number of Points RETIRED (5000,0010)
NUMBER_OF_POLYGONAL_VERTICES | Number of Polygonal Vertices (0018,1637)
NUMBER_OF_PRIORS_REFERENCED | Number of Priors Referenced (0072,0014)
NUMBER_OF_PULSES | Number of Pulses (300A,028A)
NUMBER_OF_R_R_INTERVALS | Number of R-R Intervals (0054,0061)
NUMBER_OF_RADIATION_GENERATION_MODES | Number of Radiation Generation Modes (300A,0685)
NUMBER_OF_RANGE_MODULATORS | Number of Range Modulators (300A,0340)
NUMBER_OF_RANGE_SHIFTERS | Number of Range Shifters (300A,0312)
NUMBER_OF_REFERENCES_RETIRED | Number of References RETIRED (0004,1600)
NUMBER_OF_REMAINING_SUB_OPERATIONS | Number of Remaining Sub-operations (0000,1020)
NUMBER_OF_REMAINING_SUBOPERATIONS | Alias for tag NUMBER_OF_REMAINING_SUB_OPERATIONS (0000,1020)
NUMBER_OF_ROTATIONS | Number of Rotations (0054,0051)
NUMBER_OF_RT_ACCESSORY_HOLDERS | Number of RT Accessory Holders (300A,0670)
NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS | Number of RT Beam Limiting Device Openings (300A,0657)
NUMBER_OF_RT_BEAM_LIMITING_DEVICES | Number of RT Beam Limiting Devices (300A,0641)
NUMBER_OF_RT_CONTROL_POINTS | Number of RT Control Points (300A,0604)
NUMBER_OF_SAMPLES_RETIRED | Number of Samples RETIRED (5000,2006)
NUMBER_OF_SCAN_SPOT_POSITIONS | Number of Scan Spot Positions (300A,0392)
NUMBER_OF_SCREENS | Number of Screens (0072,0100)
NUMBER_OF_SERIES_RELATED_IMAGES | Alias for tag NUMBER_OF_SERIES_RELATED_INSTANCES (0020,1209)
NUMBER_OF_SERIES_RELATED_INSTANCES | Number of Series Related Instances (0020,1209)
NUMBER_OF_SLICES | Number of Slices (0054,0081)
NUMBER_OF_STAGES | Number of Stages (0008,2124)
NUMBER_OF_STUDY_RECORDS_IN_INSTANCE | Number of Study Records in Instance (0008,0427)
NUMBER_OF_STUDY_RELATED_IMAGES | Alias for tag NUMBER_OF_STUDY_RELATED_INSTANCES (0020,1208)
NUMBER_OF_STUDY_RELATED_INSTANCES | Number of Study Related Instances (0020,1208)
NUMBER_OF_STUDY_RELATED_SERIES | Number of Study Related Series (0020,1206)
NUMBER_OF_SUBSETS | Number of Subsets (0018,9740)
NUMBER_OF_SURFACE_POINTS | Number of Surface Points (0066,0015)
NUMBER_OF_SURFACES | Number of Surfaces (0066,0001)
NUMBER_OF_TABLE_BREAK_POINTS | Number of Table Break Points (0018,6050)
NUMBER_OF_TABLE_COLUMNS | Number of Table Columns (0040,A803)
NUMBER_OF_TABLE_ENTRIES | Number of Table Entries (0018,6056)
NUMBER_OF_TABLE_ROWS | Number of Table Rows (0040,A802)
NUMBER_OF_TEMPORAL_POSITIONS | Number of Temporal Positions (0020,0105)
NUMBER_OF_TIME_SLICES | Number of Time Slices (0054,0101)
NUMBER_OF_TIME_SLOTS | Number of Time Slots (0054,0071)
NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES | Number of Tomosynthesis Source Images (0018,1495)
NUMBER_OF_TOTAL_OBJECTS | Number of Total Objects (4010,1033)
NUMBER_OF_TRIGGERS_IN_PHASE | Number of Triggers in Phase (0054,0211)
NUMBER_OF_VECTORS | Number of Vectors (0066,001E)
NUMBER_OF_VERTICAL_PIXELS | Number of Vertical Pixels (0072,0104)
NUMBER_OF_VIEWS_IN_STAGE | Number of Views in Stage (0008,212A)
NUMBER_OF_VISUAL_STIMULI | Number of Visual Stimuli (0024,0038)
NUMBER_OF_VOLUMETRIC_CURVE_POINTS | Number of Volumetric Curve Points (0070,150C)
NUMBER_OF_WARNING_SUB_OPERATIONS | Number of Warning Sub-operations (0000,1023)
NUMBER_OF_WARNING_SUBOPERATIONS | Alias for tag NUMBER_OF_WARNING_SUB_OPERATIONS (0000,1023)
NUMBER_OF_WAVEFORM_CHANNELS | Number of Waveform Channels (003A,0005)
NUMBER_OF_WAVEFORM_SAMPLES | Number of Waveform Samples (003A,0010)
NUMBER_OF_WEDGE_POSITIONS | Number of Wedge Positions (300A,0655)
NUMBER_OF_WEDGES | Number of Wedges (300A,00D0)
NUMBER_OF_ZERO_FILLS | Number of Zero Fills (0018,9066)
NUMERIC_VALUE | Numeric Value (0040,A30A)
NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE | Numeric Value Qualifier Code Sequence (0040,A301)
OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED | Object Binary Identifier (Trial) RETIRED (0040,A074)
OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED | Object Directory Binary Identifier (Trial) RETIRED (0040,A089)
OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM | Object Pixel Spacing in Center of Beam (0018,9404)
OBJECT_SOUND_SPEED | Object Sound Speed (0018,9833)
OBJECT_THICKNESS_SEQUENCE | Object Thickness Sequence (0018,9456)
OBJECTIVE_LENS_NUMERICAL_APERTURE | Objective Lens Numerical Aperture (0048,0113)
OBJECTIVE_LENS_POWER | Objective Lens Power (0048,0112)
OBLIQUE_CROPPING_PLANE | Alias for tag PLANE (0070,1305)
OBLIQUE_CROPPING_PLANE_NORMAL | Alias for tag PLANE_NORMAL (0070,1306)
OBLIQUE_CROPPING_PLANE_SEQUENCE | Oblique Cropping Plane Sequence (0070,1304)
OBSERVATION_BASIS_CODE_SEQUENCE | Observation Basis Code Sequence (0082,0022)
OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED | Observation Category Code Sequence (Trial) RETIRED (0040,A167)
OBSERVATION_DATE_TRIAL_RETIRED | Observation Date (Trial) RETIRED (0040,A192)
OBSERVATION_DATETIME | Observation DateTime (0040,A032)
OBSERVATION_DESCRIPTION | Observation Description (0082,000A)
OBSERVATION_NUMBER | Observation Number (3006,0082)
OBSERVATION_SIGNIFICANCE | Observation Significance (0082,0008)
OBSERVATION_START_DATETIME | Observation Start DateTime (0040,A033)
OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED | Observation Subject Class (Trial) RETIRED (0040,A403)
OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED | Observation Subject Context Flag (Trial) RETIRED (0040,A600)
OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED | Observation Subject Type Code Sequence (Trial) RETIRED (0040,A404)
OBSERVATION_SUBJECT_UID_TRIAL_RETIRED | Observation Subject UID (Trial) RETIRED (0040,A402)
OBSERVATION_TIME_TRIAL_RETIRED | Observation Time (Trial) RETIRED (0040,A193)
OBSERVATION_UID | Observation UID (0040,A171)
OBSERVATIONS_NUMBER | Alias for tag OBSERVATION_NUMBER (3006,0082)
OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED | Observer Context Flag (Trial) RETIRED (0040,A601)
OBSERVER_TYPE | Observer Type (0040,A084)
OCCUPATION | Occupation (0010,2180)
OCT_ACQUISITION_DOMAIN | OCT Acquisition Domain (0052,0006)
OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE | OCT B-scan Analysis Acquisition Parameters Sequence (0022,1640)
OCT_FOCAL_DISTANCE | OCT Focal Distance (0052,0002)
OCT_OPTICAL_CENTER_WAVELENGTH | OCT Optical Center Wavelength (0052,0007)
OCT_Z_OFFSET_APPLIED | OCT Z Offset Applied (0052,0026)
OCT_Z_OFFSET_CORRECTION | OCT Z Offset Correction (0052,0030)
OECF_COLUMN_NAMES | OECF Column Names (0016,0008)
OECF_COLUMNS | OECF Columns (0016,0007)
OECF_ROWS | OECF Rows (0016,0006)
OECF_VALUES | OECF Values (0016,0009)
OFFENDING_ELEMENT | Offending Element (0000,0901)
OFFSET_DIRECTION | Offset Direction (0018,9905)
OFFSET_DISTANCE | Offset Distance (0018,9904)
OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY | Alias for tag OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1200)
OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY | Alias for tag OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1202)
OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY | Offset of Referenced Lower-Level Directory Entity (0004,1420)
OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY | Offset of the First Directory Record of the Root Directory Entity (0004,1200)
OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY | Offset of the Last Directory Record of the Root Directory Entity (0004,1202)
OFFSET_OF_THE_NEXT_DIRECTORY_RECORD | Offset of the Next Directory Record (0004,1400)
OMITTED_APPLICATION_SETUP_SEQUENCE | Omitted Application Setup Sequence (0074,140E)
OMITTED_BEAM_TASK_SEQUENCE | Omitted Beam Task Sequence (300C,0111)
OMITTED_CHANNEL_SEQUENCE | Omitted Channel Sequence (0074,1409)
OMITTED_RADIATION_SEQUENCE | Omitted Radiation Sequence (300A,0787)
ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED | On Axis Background Anatomic Structure Code Sequence (Trial) RETIRED (0008,225C)
OOI_OWNER_CREATION_TIME | OOI Owner Creation Time (4010,1041)
OOI_OWNER_SEQUENCE | OOI Owner Sequence (4010,1047)
OOI_OWNER_TYPE | OOI Owner Type (4010,1009)
OOI_SIZE | OOI Size (4010,1043)
OOI_TYPE | OOI Type (4010,1042)
OOI_TYPE_DESCRIPTOR | OOI Type Descriptor (4010,1068)
OPERATING_MODE | Operating Mode (0018,9178)
OPERATING_MODE_SEQUENCE | Operating Mode Sequence (0018,9176)
OPERATING_MODE_TYPE | Operating Mode Type (0018,9177)
OPERATOR_IDENTIFICATION_SEQUENCE | Operator Identification Sequence (0008,1072)
OPERATORS_NAME | Operators' Name (0008,1070)
OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE | Ophthalmic Anatomic Reference Point X-Coordinate (0022,1624)
OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE | Ophthalmic Anatomic Reference Point Y-Coordinate (0022,1626)
OPHTHALMIC_AXIAL_LENGTH | Ophthalmic Axial Length (0022,1019)
OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED | Ophthalmic Axial Length Acquisition Method Code Sequence RETIRED (0022,1153)
OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE | Ophthalmic Axial Length Data Source Code Sequence (0022,1150)
OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION | Ophthalmic Axial Length Data Source Description (0022,1159)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED | Ophthalmic Axial Length Measurement Modified (0022,1140)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE | Ophthalmic Axial Length Measurements Length Summation Sequence (0022,1212)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE | Ophthalmic Axial Length Measurements Segment Name Code Sequence (0022,1101)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Measurements Segmental Length Sequence (0022,1211)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Ophthalmic Axial Length Measurements Sequence (0022,1050)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Measurements Total Length Sequence (0022,1210)
OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE | Ophthalmic Axial Length Measurements Type (0022,1010)
OPHTHALMIC_AXIAL_LENGTH_METHOD | Ophthalmic Axial Length Method (0022,1515)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE | Ophthalmic Axial Length Quality Metric Sequence (0022,1262)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED | Ophthalmic Axial Length Quality Metric Type Code Sequence RETIRED (0022,1265)
OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED | Ophthalmic Axial Length Quality Metric Type Description RETIRED (0022,1273)
OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE | Ophthalmic Axial Length Selection Method Code Sequence (0022,1250)
OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Ophthalmic Axial Length Sequence (0022,1012)
OPHTHALMIC_AXIAL_LENGTH_VELOCITY | Ophthalmic Axial Length Velocity (0022,1059)
OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE | Ophthalmic Axial Measurements Device Type (0022,1009)
OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE | Ophthalmic Axial Measurements Left Eye Sequence (0022,1008)
OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE | Ophthalmic Axial Measurements Right Eye Sequence (0022,1007)
OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE | Ophthalmic En Face Image Quality Rating Sequence (0022,1628)
OPHTHALMIC_FOV | Ophthalmic FOV (0022,1517)
OPHTHALMIC_FRAME_LOCATION_SEQUENCE | Ophthalmic Frame Location Sequence (0022,0031)
OPHTHALMIC_IMAGE_ORIENTATION | Ophthalmic Image Orientation (0022,0039)
OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE | Ophthalmic Image Type Code Sequence (0022,1615)
OPHTHALMIC_IMAGE_TYPE_DESCRIPTION | Ophthalmic Image Type Description (0022,1616)
OPHTHALMIC_MAPPING_DEVICE_TYPE | Ophthalmic Mapping Device Type (0022,1415)
OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE | Ophthalmic Patient Clinical Information Left Eye Sequence (0024,0114)
OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE | Ophthalmic Patient Clinical Information Right Eye Sequence (0024,0115)
OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE | Ophthalmic Thickness Map Quality Rating Sequence (0022,1470)
OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE | Ophthalmic Thickness Map Quality Threshold Sequence (0022,1458)
OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING | Ophthalmic Thickness Map Threshold Quality Rating (0022,1460)
OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE | Ophthalmic Thickness Map Type Code Sequence (0022,1436)
OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE | Ophthalmic Thickness Mapping Normals Sequence (0022,1443)
OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE | Alias for tag OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE (0022,1044)
OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE | Ophthalmic Ultrasound Method Code Sequence (0022,1044)
OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG | Ophthalmic Volumetric Properties Flag (0022,1622)
OPTICAL_MAGNIFICATION_FACTOR | Optical Magnification Factor (0016,1005)
OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Optical Ophthalmic Axial Length Measurements Sequence (0022,1225)
OPTICAL_PATH_DESCRIPTION | Optical Path Description (0048,0107)
OPTICAL_PATH_IDENTIFICATION_SEQUENCE | Optical Path Identification Sequence (0048,0207)
OPTICAL_PATH_IDENTIFIER | Optical Path Identifier (0048,0106)
OPTICAL_PATH_SEQUENCE | Optical Path Sequence (0048,0105)
OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Optical Selected Ophthalmic Axial Length Sequence (0022,1255)
OPTICAL_TRANSMITTANCE | Optical Transmittance (0046,0040)
OPTOTYPE | Optotype (0046,0094)
OPTOTYPE_DETAILED_DEFINITION | Optotype Detailed Definition (0046,0139)
OPTOTYPE_PRESENTATION | Optotype Presentation (0046,0095)
ORDER_CALLBACK_PHONE_NUMBER | Order Callback Phone Number (0040,2010)
ORDER_CALLBACK_TELECOM_INFORMATION | Order Callback Telecom Information (0040,2011)
ORDER_ENTERED_BY | Order Entered By (0040,2008)
ORDER_ENTERERS_LOCATION | Order Enterer's Location (0040,2009)
ORDER_FILLER_IDENTIFIER_SEQUENCE | Order Filler Identifier Sequence (0040,0027)
ORDER_PLACER_IDENTIFIER_SEQUENCE | Order Placer Identifier Sequence (0040,0026)
ORGAN_AT_RISK_FULL_VOLUME_DOSE | Organ at Risk Full-volume Dose (300A,002A)
ORGAN_AT_RISK_LIMIT_DOSE | Organ at Risk Limit Dose (300A,002B)
ORGAN_AT_RISK_MAXIMUM_DOSE | Organ at Risk Maximum Dose (300A,002C)
ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION | Organ at Risk Overdose Volume Fraction (300A,002D)
ORGAN_DOSE | Organ Dose (0040,0316)
ORGAN_EXPOSED | Organ Exposed (0040,0318)
ORGANIZATIONAL_ROLE_CODE_SEQUENCE | Organizational Role Code Sequence (0044,010A)
ORIGIN | Alias for tag OVERLAY_ORIGIN (6000,0050)
ORIGINAL_ATTRIBUTES_SEQUENCE | Original Attributes Sequence (0400,0561)
ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED | Original Image Identification Nomenclature RETIRED (0020,5002)
ORIGINAL_IMAGE_IDENTIFICATION_RETIRED | Original Image Identification RETIRED (0020,5000)
ORIGINAL_IMAGE_SEQUENCE | Original Image Sequence (2130,00C0)
ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Original Implant Assembly Template Sequence (0076,000C)
ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE | Original Implant Template Sequence (0068,6225)
ORIGINAL_SPECIALIZED_SOP_CLASS_UID | Original Specialized SOP Class UID (0008,001B)
ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE | Originating SOP Instance Reference Sequence (3010,0007)
ORIGINATOR | Originator (2100,0070)
OTHER_FAILURES_SEQUENCE | Other Failures Sequence (0008,119A)
OTHER_MAGNIFICATION_TYPES_AVAILABLE | Other Magnification Types Available (2010,00A7)
OTHER_MEDIA_AVAILABLE_SEQUENCE | Other Media Available Sequence (2000,00A4)
OTHER_PATIENT_IDS_RETIRED | Other Patient IDs RETIRED (0010,1000)
OTHER_PATIENT_IDS_SEQUENCE | Other Patient IDs Sequence (0010,1002)
OTHER_PATIENT_NAMES | Other Patient Names (0010,1001)
OTHER_PUPILLARY_DISTANCE | Other Pupillary Distance (0046,0064)
OTHER_SMOOTHING_TYPES_AVAILABLE | Other Smoothing Types Available (2010,00A9)
OTHER_STUDY_NUMBERS_RETIRED | Other Study Numbers RETIRED (0020,1070)
OUTER_DIAMETER | Outer Diameter (0014,0054)
OUTLINE_LEFT_VERTICAL_EDGE | Outline Left Vertical Edge (0018,1631)
OUTLINE_LOWER_HORIZONTAL_EDGE | Outline Lower Horizontal Edge (0018,1634)
OUTLINE_RIGHT_VERTICAL_EDGE | Outline Right Vertical Edge (0018,1632)
OUTLINE_SHAPE_TYPE | Outline Shape Type (0018,1630)
OUTLINE_UPPER_HORIZONTAL_EDGE | Outline Upper Horizontal Edge (0018,1633)
OUTPUT_DESTINATION_SEQUENCE | Output Destination Sequence (0040,4070)
OUTPUT_INFORMATION_SEQUENCE | Output Information Sequence (0040,4033)
OUTPUT_POWER | Output Power (0018,5000)
OVERALL_TEMPLATE_SPATIAL_TOLERANCE | Overall Template Spatial Tolerance (0068,62A5)
OVERLAY_ACTIVATION_LAYER | Overlay Activation Layer (6000,1001)
OVERLAY_BACKGROUND_DENSITY_RETIRED | Overlay Background Density RETIRED (2040,0082)
OVERLAY_BIT_POSITION | Overlay Bit Position (6000,0102)
OVERLAY_BITS_ALLOCATED | Overlay Bits Allocated (6000,0100)
OVERLAY_COLUMNS | Overlay Columns (6000,0011)
OVERLAY_COMMENTS_RETIRED | Overlay Comments RETIRED (6000,4000)
OVERLAY_COMPRESSION_CODE_RETIRED | Overlay Compression Code RETIRED (6000,0060)
OVERLAY_DATA | Overlay Data (6000,3000)
OVERLAY_DATE_RETIRED | Overlay Date RETIRED (0008,0024)
OVERLAY_DESCRIPTION | Overlay Description (6000,0022)
OVERLAY_DESCRIPTOR_BLUE_RETIRED | Overlay Descriptor - Blue RETIRED (6000,1103)
OVERLAY_DESCRIPTOR_GRAY_RETIRED | Overlay Descriptor - Gray RETIRED (6000,1100)
OVERLAY_DESCRIPTOR_GREEN_RETIRED | Overlay Descriptor - Green RETIRED (6000,1102)
OVERLAY_DESCRIPTOR_RED_RETIRED | Overlay Descriptor - Red RETIRED (6000,1101)
OVERLAY_FOREGROUND_DENSITY_RETIRED | Overlay Foreground Density RETIRED (2040,0080)
OVERLAY_FORMAT_RETIRED | Overlay Format RETIRED (6000,0110)
OVERLAY_LABEL | Overlay Label (6000,1500)
OVERLAY_LOCATION_RETIRED | Overlay Location RETIRED (6000,0200)
OVERLAY_MAGNIFICATION_TYPE_RETIRED | Overlay Magnification Type RETIRED (2040,0060)
OVERLAY_MODE_RETIRED | Overlay Mode RETIRED (2040,0090)
OVERLAY_NUMBER_RETIRED | Overlay Number RETIRED (0020,0022)
OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED | Overlay or Image Magnification RETIRED (2040,0072)
OVERLAY_ORIGIN | Overlay Origin (6000,0050)
OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED | Overlay Pixel Data Sequence RETIRED (2040,0020)
OVERLAY_PLANE_ORIGIN_RETIRED | Overlay Plane Origin RETIRED (6000,0052)
OVERLAY_PLANES_RETIRED | Overlay Planes RETIRED (6000,0012)
OVERLAY_ROWS | Overlay Rows (6000,0010)
OVERLAY_SMOOTHING_TYPE_RETIRED | Overlay Smoothing Type RETIRED (2040,0070)
OVERLAY_SUBTYPE | Overlay Subtype (6000,0045)
OVERLAY_TIME_RETIRED | Overlay Time RETIRED (0008,0034)
OVERLAY_TYPE | Overlay Type (6000,0040)
OVERLAYS_BLUE_RETIRED | Overlays - Blue RETIRED (6000,1203)
OVERLAYS_GRAY_RETIRED | Overlays - Gray RETIRED (6000,1200)
OVERLAYS_GREEN_RETIRED | Overlays - Green RETIRED (6000,1202)
OVERLAYS_RED_RETIRED | Overlays - Red RETIRED (6000,1201)
OVERLAYS_RETIRED | Overlays RETIRED (0000,51B0)
OVERRIDDEN_ATTRIBUTES_SEQUENCE | Overridden Attributes Sequence (0074,104A)
OVERRIDE_DATETIME | Override DateTime (300A,0760)
OVERRIDE_PARAMETER_POINTER | Override Parameter Pointer (3008,0062)
OVERRIDE_REASON | Override Reason (3008,0066)
OVERRIDE_SEQUENCE | Override Sequence (3008,0060)
OVERSAMPLING_PHASE | Oversampling Phase (0018,9029)
OWNER_ID | Owner ID (2100,0160)
PADDLE_DESCRIPTION | Paddle Description (0018,11A4)
PAGE_NUMBER_VECTOR | Page Number Vector (0018,2001)
PAGE_POSITION_ID_RETIRED | Page Position ID RETIRED (0000,5120)
PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE | Palette Color Lookup Table Sequence (0048,0120)
PALETTE_COLOR_LOOKUP_TABLE_UID | Palette Color Lookup Table UID (0028,1199)
PARALLEL_ACQUISITION | Parallel Acquisition (0018,9077)
PARALLEL_ACQUISITION_TECHNIQUE | Parallel Acquisition Technique (0018,9078)
PARALLEL_REDUCTION_FACTOR_IN_PLANE | Parallel Reduction Factor In-plane (0018,9069)
PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED | Parallel Reduction Factor In-plane (Retired) (0018,9096)
PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE | Parallel Reduction Factor out-of-plane (0018,9155)
PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE | Parallel Reduction Factor Second In-plane (0018,9168)
PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES | Parallel RT Beam Delimiter Boundaries (300A,0649)
PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE | Parallel RT Beam Delimiter Device Orientation Label Code Sequence (300A,0644)
PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE | Parallel RT Beam Delimiter Device Sequence (300A,0647)
PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE | Parallel RT Beam Delimiter Leaf Mounting Side (300A,064F)
PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS | Parallel RT Beam Delimiter Opening Extents (3008,00A4)
PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE | Parallel RT Beam Delimiter Opening Mode (300A,064E)
PARALLEL_RT_BEAM_DELIMITER_POSITIONS | Parallel RT Beam Delimiter Positions (300A,064A)
PARAMETER_ITEM_INDEX | Parameter Item Index (3008,0063)
PARAMETER_POINTER | Parameter Pointer (3008,0065)
PARAMETER_SEQUENCE_POINTER | Parameter Sequence Pointer (3008,0061)
PARAMETER_VALUE_NUMBER | Parameter Value Number (3008,0067)
PARAMETERS_SPECIFICATION_SEQUENCE | Parameters Specification Sequence (0018,9913)
PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE | Parametric Map Frame Type Sequence (0040,9092)
PARTIAL_DATA_DISPLAY_HANDLING | Partial Data Display Handling (0072,0208)
PARTIAL_FOURIER | Partial Fourier (0018,9081)
PARTIAL_FOURIER_DIRECTION | Partial Fourier Direction (0018,9036)
PARTIAL_VIEW | Partial View (0028,1350)
PARTIAL_VIEW_CODE_SEQUENCE | Partial View Code Sequence (0028,1352)
PARTIAL_VIEW_DESCRIPTION | Partial View Description (0028,1351)
PARTICIPANT_SEQUENCE | Participant Sequence (0040,A07A)
PARTICIPATION_DATETIME | Participation DateTime (0040,A082)
PARTICIPATION_TYPE | Participation Type (0040,A080)
PATIENT_ADDITIONAL_POSITION | Patient Additional Position (300A,0184)
PATIENT_BREED_CODE_SEQUENCE | Patient Breed Code Sequence (0010,2293)
PATIENT_BREED_DESCRIPTION | Patient Breed Description (0010,2292)
PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE | Patient Clinical Trial Participation Sequence (0038,0502)
PATIENT_COMMENTS | Patient Comments (0010,4000)
PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE | Patient Equipment Relationship Code Sequence (3010,0030)
PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE | Patient Eye Movement Command Code Sequence (0022,0006)
PATIENT_EYE_MOVEMENT_COMMANDED | Patient Eye Movement Commanded (0022,0005)
PATIENT_FRAME_OF_REFERENCE_SOURCE | Patient Frame of Reference Source (0020,930C)
PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE | Patient Gantry Relationship Code Sequence (0054,0414)
PATIENT_ID | Patient ID (0010,0020)
PATIENT_IDENTITY_REMOVED | Patient Identity Removed (0012,0062)
PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE | Patient Location Coordinates Code Sequence (3006,00CA)
PATIENT_LOCATION_COORDINATES_SEQUENCE | Patient Location Coordinates Sequence (3006,00C9)
PATIENT_MOTION_CORRECTED | Patient Motion Corrected (0018,9763)
PATIENT_NOT_PROPERLY_FIXATED_QUANTITY | Patient Not Properly Fixated Quantity (0024,0036)
PATIENT_ORIENTATION | Patient Orientation (0020,0020)
PATIENT_ORIENTATION_CODE_SEQUENCE | Patient Orientation Code Sequence (0054,0410)
PATIENT_ORIENTATION_IN_FRAME_SEQUENCE | Patient Orientation in Frame Sequence (0020,9450)
PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE | Patient Orientation Modifier Code Sequence (0054,0412)
PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE | Patient Physiological State Code Sequence (0018,9772)
PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE | Patient Physiological State Sequence (0018,9771)
PATIENT_POSITION | Patient Position (0018,5100)
PATIENT_POSITIONING_INSTRUCTION_SEQUENCE | Patient Positioning Instruction Sequence (0018,991B)
PATIENT_RELIABILITY_INDICATOR | Patient Reliability Indicator (0024,0069)
PATIENT_SETUP_LABEL | Patient Setup Label (300A,0183)
PATIENT_SETUP_NUMBER | Patient Setup Number (300A,0182)
PATIENT_SETUP_PHOTO_DESCRIPTION | Patient Setup Photo Description (300A,0794)
PATIENT_SETUP_SEQUENCE | Patient Setup Sequence (300A,0180)
PATIENT_SETUP_UID_RETIRED | Patient Setup UID RETIRED (300A,0650)
PATIENT_SPECIES_CODE_SEQUENCE | Patient Species Code Sequence (0010,2202)
PATIENT_SPECIES_DESCRIPTION | Patient Species Description (0010,2201)
PATIENT_SPECIFICATION_SEQUENCE | Patient Specification Sequence (0018,9911)
PATIENT_STATE | Patient State (0038,0500)
PATIENT_SUPPORT_ACCESSORY_CODE | Patient Support Accessory Code (300A,0354)
PATIENT_SUPPORT_ADJUSTED_ANGLE | Patient Support Adjusted Angle (0074,102A)
PATIENT_SUPPORT_ANGLE | Patient Support Angle (300A,0122)
PATIENT_SUPPORT_ANGLE_TOLERANCE | Patient Support Angle Tolerance (300A,004C)
PATIENT_SUPPORT_DEVICES_SEQUENCE | Patient Support Devices Sequence (300A,0686)
PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE | Patient Support Displacement Sequence (300A,079C)
PATIENT_SUPPORT_ID | Patient Support ID (300A,0352)
PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE | Patient Support Position Device Parameter Sequence (300A,065D)
PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE | Patient Support Position Device Tolerance Sequence (300A,0660)
PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX | Patient Support Position Parameter Order Index (300A,065F)
PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE | Patient Support Position Parameter Sequence (300A,065B)
PATIENT_SUPPORT_POSITION_SEQUENCE | Patient Support Position Sequence (3006,00CB)
PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD | Patient Support Position Specification Method (300A,065C)
PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX | Patient Support Position Tolerance Order Index (300A,0661)
PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE | Patient Support Position Tolerance Sequence (300A,062D)
PATIENT_SUPPORT_ROTATION_DIRECTION | Patient Support Rotation Direction (300A,0123)
PATIENT_SUPPORT_TYPE | Patient Support Type (300A,0350)
PATIENT_TRANSPORT_ARRANGEMENTS | Patient Transport Arrangements (0040,1004)
PATIENT_TREATMENT_ORIENTATION_SEQUENCE | Patient Treatment Orientation Sequence (3010,0032)
PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE | Patient Treatment Preparation Device Sequence (300A,078F)
PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE | Patient Treatment Preparation Method Code Sequence (300A,078D)
PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION | Patient Treatment Preparation Method Description (300A,0792)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE | Patient Treatment Preparation Procedure Code Sequence (300A,0791)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX | Patient Treatment Preparation Procedure Index (300A,0795)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION | Patient Treatment Preparation Procedure Parameter Description (300A,078E)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE | Patient Treatment Preparation Procedure Parameter Sequence (300A,0793)
PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE | Patient Treatment Preparation Procedure Sequence (300A,0790)
PATIENTS_ADDRESS | Patient's Address (0010,1040)
PATIENTS_AGE | Patient's Age (0010,1010)
PATIENTS_ALTERNATIVE_CALENDAR | Patient's Alternative Calendar (0010,0035)
PATIENTS_BIRTH_DATE | Patient's Birth Date (0010,0030)
PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR | Patient's Birth Date in Alternative Calendar (0010,0033)
PATIENTS_BIRTH_NAME | Patient's Birth Name (0010,1005)
PATIENTS_BIRTH_TIME | Patient's Birth Time (0010,0032)
PATIENTS_BODY_MASS_INDEX | Patient's Body Mass Index (0010,1022)
PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR | Patient's Death Date in Alternative Calendar (0010,0034)
PATIENTS_INSTITUTION_RESIDENCE | Patient's Institution Residence (0038,0400)
PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE | Patient's Insurance Plan Code Sequence (0010,0050)
PATIENTS_MOTHERS_BIRTH_NAME | Patient's Mother's Birth Name (0010,1060)
PATIENTS_NAME | Patient's Name (0010,0010)
PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE | Patient's Primary Language Code Sequence (0010,0101)
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE | Patient's Primary Language Modifier Code Sequence (0010,0102)
PATIENTS_RELIGIOUS_PREFERENCE | Patient's Religious Preference (0010,21F0)
PATIENTS_SEX | Patient's Sex (0010,0040)
PATIENTS_SEX_NEUTERED | Patient's Sex Neutered (0010,2203)
PATIENTS_SIZE | Patient's Size (0010,1020)
PATIENTS_SIZE_CODE_SEQUENCE | Patient's Size Code Sequence (0010,1021)
PATIENTS_TELECOM_INFORMATION | Patient's Telecom Information (0010,2155)
PATIENTS_TELEPHONE_NUMBERS | Patient's Telephone Numbers (0010,2154)
PATIENTS_WEIGHT | Patient's Weight (0010,1030)
PATTERN_OFF_COLOR_CIELAB_VALUE | Pattern Off Color CIELab Value (0070,0252)
PATTERN_OFF_OPACITY | Pattern Off Opacity (0070,0285)
PATTERN_ON_COLOR_CIELAB_VALUE | Pattern On Color CIELab Value (0070,0251)
PATTERN_ON_OPACITY | Pattern On Opacity (0070,0284)
PAUSE_BETWEEN_FRAMES | Pause Between Frames (0054,0038)
PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Per-frame Functional Groups Sequence (5200,9230)
PER_PROJECTION_ACQUISITION_SEQUENCE | Per Projection Acquisition Sequence (0018,9538)
PERCENT_PHASE_FIELD_OF_VIEW | Percent Phase Field of View (0018,0094)
PERCENT_SAMPLING | Percent Sampling (0018,0093)
PERFORMED_LOCATION | Performed Location (0040,0243)
PERFORMED_PROCEDURE_CODE_SEQUENCE | Performed Procedure Code Sequence (0040,A372)
PERFORMED_PROCEDURE_STEP_DESCRIPTION | Performed Procedure Step Description (0040,0254)
PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Performed Procedure Step Discontinuation Reason Code Sequence (0040,0281)
PERFORMED_PROCEDURE_STEP_END_DATE | Performed Procedure Step End Date (0040,0250)
PERFORMED_PROCEDURE_STEP_END_DATETIME | Performed Procedure Step End DateTime (0040,4051)
PERFORMED_PROCEDURE_STEP_END_TIME | Performed Procedure Step End Time (0040,0251)
PERFORMED_PROCEDURE_STEP_ID | Performed Procedure Step ID (0040,0253)
PERFORMED_PROCEDURE_STEP_START_DATE | Performed Procedure Step Start Date (0040,0244)
PERFORMED_PROCEDURE_STEP_START_DATETIME | Performed Procedure Step Start DateTime (0040,4050)
PERFORMED_PROCEDURE_STEP_START_TIME | Performed Procedure Step Start Time (0040,0245)
PERFORMED_PROCEDURE_STEP_STATUS | Performed Procedure Step Status (0040,0252)
PERFORMED_PROCEDURE_TYPE_DESCRIPTION | Performed Procedure Type Description (0040,0255)
PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED | Performed Processing Applications Code Sequence RETIRED (0040,4007)
PERFORMED_PROCESSING_PARAMETERS_SEQUENCE | Performed Processing Parameters Sequence (0074,1212)
PERFORMED_PROTOCOL_CODE_SEQUENCE | Performed Protocol Code Sequence (0040,0260)
PERFORMED_PROTOCOL_TYPE | Performed Protocol Type (0040,0261)
PERFORMED_SERIES_SEQUENCE | Performed Series Sequence (0040,0340)
PERFORMED_STATION_AE_TITLE | Performed Station AE Title (0040,0241)
PERFORMED_STATION_CLASS_CODE_SEQUENCE | Performed Station Class Code Sequence (0040,4029)
PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE | Performed Station Geographic Location Code Sequence (0040,4030)
PERFORMED_STATION_NAME | Performed Station Name (0040,0242)
PERFORMED_STATION_NAME_CODE_SEQUENCE | Performed Station Name Code Sequence (0040,4028)
PERFORMED_WORKITEM_CODE_SEQUENCE | Performed Workitem Code Sequence (0040,4019)
PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Performing Physician Identification Sequence (0008,1052)
PERFORMING_PHYSICIANS_NAME | Performing Physician's Name (0008,1050)
PERSON_IDENTIFICATION_CODE_SEQUENCE | Person Identification Code Sequence (0040,1101)
PERSON_NAME | Person Name (0040,A123)
PERSONS_ADDRESS | Person's Address (0040,1102)
PERSONS_TELECOM_INFORMATION | Person's Telecom Information (0040,1104)
PERSONS_TELEPHONE_NUMBERS | Person's Telephone Numbers (0040,1103)
PERTINENT_DOCUMENTS_SEQUENCE | Pertinent Documents Sequence (0038,0100)
PERTINENT_OTHER_EVIDENCE_SEQUENCE | Pertinent Other Evidence Sequence (0040,A385)
PERTINENT_PRIOR_EVIDENCE_SEQUENCE | Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A385)
PERTINENT_RESOURCES_SEQUENCE | Pertinent Resources Sequence (0038,0101)
PERTINENT_SOP_CLASSES_IN_SERIES | Pertinent SOP Classes in Series (3010,0053)
PERTINENT_SOP_CLASSES_IN_STUDY | Pertinent SOP Classes in Study (3010,0052)
PET_DETECTOR_MOTION_DETAILS_SEQUENCE | PET Detector Motion Details Sequence (0018,9733)
PET_FRAME_ACQUISITION_SEQUENCE | PET Frame Acquisition Sequence (0018,9732)
PET_FRAME_CORRECTION_FACTORS_SEQUENCE | PET Frame Correction Factors Sequence (0018,9736)
PET_FRAME_TYPE_SEQUENCE | PET Frame Type Sequence (0018,9751)
PET_POSITION_SEQUENCE | PET Position Sequence (0018,9735)
PET_RECONSTRUCTION_SEQUENCE | PET Reconstruction Sequence (0018,9749)
PET_TABLE_DYNAMICS_SEQUENCE | PET Table Dynamics Sequence (0018,9734)
PHANTOM_TYPE | Phantom Type (4010,1046)
PHASE_CONTRAST | Phase Contrast (0018,9014)
PHASE_DELAY | Phase Delay (0054,0036)
PHASE_DESCRIPTION | Phase Description (0054,0039)
PHASE_INFORMATION_SEQUENCE | Phase Information Sequence (0054,0032)
PHASE_NUMBER_RETIRED | Phase Number RETIRED (0020,0015)
PHASE_VECTOR | Phase Vector (0054,0030)
PHOSPHOR_TYPE | Phosphor Type (0018,1261)
PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE | Photoacoustic Excitation Characteristics Sequence (0018,9821)
PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE | Photoacoustic Image Frame Type Sequence (0018,9835)
PHOTOGRAPHIC_EXPOSURE_INDEX | Photographic Exposure Index (0016,0038)
PHOTOGRAPHIC_SENSITIVITY | Photographic Sensitivity (0016,0018)
PHOTOMETRIC_INTERPRETATION | Photometric Interpretation (0028,0004)
PHOTON_ENERGY | Photon Energy (0018,9383)
PHOTOTIMER_SETTING | Phototimer Setting (0018,7065)
PHYSICAL_DELTA_X | Physical Delta X (0018,602C)
PHYSICAL_DELTA_Y | Physical Delta Y (0018,602E)
PHYSICAL_DETECTOR_SIZE | Physical Detector Size (0018,9429)
PHYSICAL_UNITS_X_DIRECTION | Physical Units X Direction (0018,6024)
PHYSICAL_UNITS_Y_DIRECTION | Physical Units Y Direction (0018,6026)
PHYSICIAN_APPROVING_INTERPRETATION_RETIRED | Physician Approving Interpretation RETIRED (4008,0114)
PHYSICIANS_OF_RECORD | Physician(s) of Record (0008,1048)
PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE | Physician(s) of Record Identification Sequence (0008,1049)
PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE | Physician(s) Reading Study Identification Sequence (0008,1062)
PIXEL_ASPECT_RATIO | Pixel Aspect Ratio (0028,0034)
PIXEL_BANDWIDTH | Pixel Bandwidth (0018,0095)
PIXEL_COMPONENT_DATA_TYPE | Pixel Component Data Type (0018,604E)
PIXEL_COMPONENT_MASK | Pixel Component Mask (0018,6046)
PIXEL_COMPONENT_ORGANIZATION | Pixel Component Organization (0018,6044)
PIXEL_COMPONENT_PHYSICAL_UNITS | Pixel Component Physical Units (0018,604C)
PIXEL_COMPONENT_RANGE_START | Pixel Component Range Start (0018,6048)
PIXEL_COMPONENT_RANGE_STOP | Pixel Component Range Stop (0018,604A)
PIXEL_COORDINATES_SET_TRIAL_RETIRED | Pixel Coordinates Set (Trial) RETIRED (0040,A29A)
PIXEL_DATA | Pixel Data (7FE0,0010)
PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV | Pixel Data Area Origin Relative To FOV (0018,7036)
PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV | Pixel Data Area Rotation Angle Relative To FOV (0018,7038)
PIXEL_DATA_PROVIDER_URL | Pixel Data Provider URL (0028,7FE0)
PIXEL_INTENSITY_RELATIONSHIP | Pixel Intensity Relationship (0028,1040)
PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE | Pixel Intensity Relationship LUT Sequence (0028,9422)
PIXEL_INTENSITY_RELATIONSHIP_SIGN | Pixel Intensity Relationship Sign (0028,1041)
PIXEL_MEASURES_SEQUENCE | Pixel Measures Sequence (0028,9110)
PIXEL_ORIGIN_INTERPRETATION | Pixel Origin Interpretation (0048,0301)
PIXEL_PADDING_RANGE_LIMIT | Pixel Padding Range Limit (0028,0121)
PIXEL_PADDING_VALUE | Pixel Padding Value (0028,0120)
PIXEL_PRESENTATION | Pixel Presentation (0008,9205)
PIXEL_REPRESENTATION | Pixel Representation (0028,0103)
PIXEL_SHIFT_FRAME_RANGE | Pixel Shift Frame Range (0028,9506)
PIXEL_SHIFT_SEQUENCE | Pixel Shift Sequence (0028,9501)
PIXEL_SPACING | Pixel Spacing (0028,0030)
PIXEL_SPACING_CALIBRATION_DESCRIPTION | Pixel Spacing Calibration Description (0028,0A04)
PIXEL_SPACING_CALIBRATION_TYPE | Pixel Spacing Calibration Type (0028,0A02)
PIXEL_SPACING_SEQUENCE_RETIRED | Pixel Spacing Sequence RETIRED (0040,08D8)
PIXEL_VALUE_MAPPING_CODE_SEQUENCE | Pixel Value Mapping Code Sequence (0040,9098)
PIXEL_VALUE_MAPPING_EXPLANATION | Pixel Value Mapping Explanation (0022,1454)
PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE | Pixel Value Mapping to Coded Concept Sequence (0022,1450)
PIXEL_VALUE_TRANSFORMATION_SEQUENCE | Pixel Value Transformation Sequence (0028,9145)
PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST | Placer Order Number / Imaging Service Request (0040,2016)
PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED | Placer Order Number Imaging Service Request (Retired) (0040,2006)
PLACER_ORDER_NUMBER_PROCEDURE_RETIRED | Placer Order Number / Procedure RETIRED (0040,1006)
PLAN_INTENT | Plan Intent (300A,000A)
PLAN_OVERVIEW_INDEX | Plan Overview Index (300C,0117)
PLAN_OVERVIEW_SEQUENCE | Plan Overview Sequence (300C,0116)
PLANAR_CONFIGURATION | Planar Configuration (0028,0006)
PLANE | Plane (0070,1305)
PLANE_IDENTIFICATION | Plane Identification (0018,9457)
PLANE_NORMAL | Plane Normal (0070,1306)
PLANE_ORIENTATION_SEQUENCE | Plane Orientation Sequence (0020,9116)
PLANE_ORIENTATION_VOLEME_SEQUENCE | Alias for tag PLANE_ORIENTATION_VOLUME_SEQUENCE (0020,930F)
PLANE_ORIENTATION_VOLUME_SEQUENCE | Plane Orientation (Volume) Sequence (0020,930F)
PLANE_POSITION_SEQUENCE | Plane Position Sequence (0020,9113)
PLANE_POSITION_SLIDE_SEQUENCE | Plane Position (Slide) Sequence (0048,021A)
PLANE_POSITION_VOLUME_SEQUENCE | Plane Position (Volume) Sequence (0020,930E)
PLANES_IN_ACQUISITION | Planes in Acquisition (0018,9410)
PLANES_RETIRED | Planes RETIRED (0028,0012)
PLANNED_VERIFICATION_IMAGE_SEQUENCE | Planned Verification Image Sequence (300A,00CA)
PLANNING_INPUT_INFORMATION_SEQUENCE | Planning Input Information Sequence (3010,0076)
PLANNING_LANDMARK_DESCRIPTION | Planning Landmark Description (0068,6540)
PLANNING_LANDMARK_ID | Planning Landmark ID (0068,6530)
PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE | Planning Landmark Identification Code Sequence (0068,6545)
PLANNING_LANDMARK_LINE_SEQUENCE | Planning Landmark Line Sequence (0068,6510)
PLANNING_LANDMARK_PLANE_SEQUENCE | Planning Landmark Plane Sequence (0068,6520)
PLANNING_LANDMARK_POINT_SEQUENCE | Planning Landmark Point Sequence (0068,6500)
PLATE_ID | Plate ID (0018,1004)
PLATE_TYPE | Plate Type (0018,1260)
POINT_COORDINATES_DATA | Point Coordinates Data (0066,0016)
POINT_POSITION_ACCURACY | Point Position Accuracy (0066,0017)
POINTS_BOUNDING_BOX_COORDINATES | Points Bounding Box Coordinates (0066,001A)
POLARITY | Polarity (2020,0020)
POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE | Position Acquisition Template Code Sequence (3002,0122)
POSITION_ACQUISITION_TEMPLATE_DESCRIPTION | Position Acquisition Template Description (3002,0123)
POSITION_ACQUISITION_TEMPLATE_ID | Position Acquisition Template ID (3002,0120)
POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE | Position Acquisition Template Identification Sequence (3002,011F)
POSITION_ACQUISITION_TEMPLATE_NAME | Position Acquisition Template Name (3002,0121)
POSITION_MEASURING_DEVICE_USED | Position Measuring Device Used (0018,980C)
POSITION_OF_ISOCENTER_PROJECTION | Position of Isocenter Projection (0018,9430)
POSITION_REFERENCE_INDICATOR | Position Reference Indicator (0020,1040)
POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE | Positioner Isocenter Detector Rotation Angle (0018,9465)
POSITIONER_ISOCENTER_PRIMARY_ANGLE | Positioner Isocenter Primary Angle (0018,9463)
POSITIONER_ISOCENTER_SECONDARY_ANGLE | Positioner Isocenter Secondary Angle (0018,9464)
POSITIONER_MOTION | Positioner Motion (0018,1500)
POSITIONER_POSITION_SEQUENCE | Positioner Position Sequence (0018,9405)
POSITIONER_PRIMARY_ANGLE | Positioner Primary Angle (0018,1510)
POSITIONER_PRIMARY_ANGLE_DIRECTION | Positioner Primary Angle Direction (0018,9559)
POSITIONER_PRIMARY_ANGLE_INCREMENT | Positioner Primary Angle Increment (0018,1520)
POSITIONER_SECONDARY_ANGLE | Positioner Secondary Angle (0018,1511)
POSITIONER_SECONDARY_ANGLE_INCREMENT | Positioner Secondary Angle Increment (0018,1521)
POSITIONER_TYPE | Positioner Type (0018,1508)
POSITIONING_LANDMARK_SEQUENCE | Positioning Landmark Sequence (0018,991D)
POSITIONING_METHOD_CODE_SEQUENCE | Positioning Method Code Sequence (0018,991C)
POSITIVE_CATCH_TRIALS_QUANTITY | Positive Catch Trials Quantity (0024,0056)
POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE | Post Deformation Matrix Registration Sequence (0064,0010)
POSTPROCESSING_FUNCTION_RETIRED | Postprocessing Function RETIRED (0018,5021)
POTENTIAL_DIAGNOSTIC_TASKS | Potential Diagnostic Tasks (0018,990A)
POTENTIAL_REASONS_FOR_PROCEDURE | Potential Reasons for Procedure (0018,9908)
POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE | Potential Reasons for Procedure Code Sequence (0018,9909)
POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE | Potential Requested Procedure Code Sequence (0018,9907)
POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE | Potential Scheduled Protocol Code Sequence (0018,9906)
POTENTIAL_THREAT_OBJECT_ID | Potential Threat Object ID (4010,1010)
POWERLINE_FREQUENCY | Powerline Frequency (003A,0311)
PPS_DISCONTINUATION_REASON_CODE_SEQUENCE | Alias for tag PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0040,0281)
PRE_AMPLIFIER_EQUIPMENT_SEQUENCE | Pre-Amplifier Equipment Sequence (0014,400E)
PRE_AMPLIFIER_NOTES | Pre-Amplifier Notes (0014,400F)
PRE_AMPLIFIER_SETTINGS_SEQUENCE | Pre-Amplifier Settings Sequence (0014,4040)
PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE | Pre Deformation Matrix Registration Sequence (0064,000F)
PRE_MEDICATION | Pre-Medication (0040,0012)
PRE_SELECTED_FOR_IMPLANTATION | Pre-Selected for Implantation (0022,1049)
PREDECESSOR_DOCUMENTS_SEQUENCE | Predecessor Documents Sequence (0040,A360)
PREDECESSOR_PROTOCOL_SEQUENCE | Predecessor Protocol Sequence (0018,990E)
PREDECESSOR_STRUCTURE_SET_SEQUENCE | Predecessor Structure Set Sequence (3006,0018)
PREDICTED_REFRACTIVE_ERROR | Predicted Refractive Error (0022,1054)
PREDICTED_TORIC_ERROR_SEQUENCE | Predicted Toric Error Sequence (0022,1048)
PREFERRED_PLAYBACK_SEQUENCING | Preferred Playback Sequencing (0018,1244)
PREGNANCY_STATUS | Pregnancy Status (0010,21C0)
PRELIMINARY_FLAG | Preliminary Flag (0040,A496)
PRESCRIPTION_DESCRIPTION | Prescription Description (300A,000E)
PRESCRIPTION_NOTES | Prescription Notes (3010,007B)
PRESCRIPTION_NOTES_SEQUENCE | Prescription Notes Sequence (3010,0081)
PRESCRIPTION_OVERVIEW_SEQUENCE | Prescription Overview Sequence (300C,0114)
PRESENTATION_ANIMATION_STYLE | Presentation Animation Style (0070,1A01)
PRESENTATION_CREATION_DATE | Presentation Creation Date (0070,0082)
PRESENTATION_CREATION_TIME | Presentation Creation Time (0070,0083)
PRESENTATION_CREATORS_NAME | Alias for tag CONTENT_CREATORS_NAME (0070,0084)
PRESENTATION_DESCRIPTION | Alias for tag CONTENT_DESCRIPTION (0070,0081)
PRESENTATION_DISPLAY_COLLECTION_UID | Presentation Display Collection UID (0070,1101)
PRESENTATION_GROUP_NUMBER | Presentation Group Number (003A,0241)
PRESENTATION_INPUT_TYPE | Presentation Input Type (0070,1202)
PRESENTATION_INTENT_TYPE | Presentation Intent Type (0008,0068)
PRESENTATION_LABEL | Alias for tag CONTENT_LABEL (0070,0080)
PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED | Presentation LUT Content Sequence RETIRED (2130,0080)
PRESENTATION_LUT_FLAG_RETIRED | Presentation LUT Flag RETIRED (2000,0069)
PRESENTATION_LUT_SEQUENCE | Presentation LUT Sequence (2050,0010)
PRESENTATION_LUT_SHAPE | Presentation LUT Shape (2050,0020)
PRESENTATION_PIXEL_ASPECT_RATIO | Presentation Pixel Aspect Ratio (0070,0102)
PRESENTATION_PIXEL_MAGNIFICATION_RATIO | Presentation Pixel Magnification Ratio (0070,0103)
PRESENTATION_PIXEL_SPACING | Presentation Pixel Spacing (0070,0101)
PRESENTATION_SEQUENCE_COLLECTION_UID | Presentation Sequence Collection UID (0070,1102)
PRESENTATION_SEQUENCE_POSITION_INDEX | Presentation Sequence Position Index (0070,1103)
PRESENTATION_SIZE_MODE | Presentation Size Mode (0070,0100)
PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE | Presentation State Classification Component Sequence (0070,1801)
PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE | Presentation State Compositor Component Sequence (0070,1805)
PRESENTED_VISUAL_STIMULI_DATA_FLAG | Presented Visual Stimuli Data Flag (0024,0037)
PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION | Preserve Composite Instances After Media Creation (2200,000A)
PRESSURE | Pressure (0016,0032)
PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE | Primary Anatomic Structure Modifier Sequence (0008,2230)
PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE | Primary Anatomic Structure Sequence (0008,2228)
PRIMARY_CHROMATICITIES | Primary Chromaticities (0016,0002)
PRIMARY_DOSE_VALUE_INDICATOR | Primary Dose Value Indicator (300A,061B)
PRIMARY_DOSIMETER_UNIT | Primary Dosimeter Unit (300A,00B3)
PRIMARY_FLUENCE_MODE_SEQUENCE | Primary Fluence Mode Sequence (3002,0050)
PRIMARY_POSITIONER_INCREMENT | Primary Positioner Increment (0018,9514)
PRIMARY_POSITIONER_INCREMENT_SIGN | Primary Positioner Increment Sign (0018,9518)
PRIMARY_POSITIONER_SCAN_ARC | Primary Positioner Scan Arc (0018,9508)
PRIMARY_POSITIONER_SCAN_START_ANGLE | Primary Positioner Scan Start Angle (0018,9510)
PRIMARY_PROMPTS_COUNTS_ACCUMULATED | Primary (Prompts) Counts Accumulated (0054,1310)
PRIMITIVE_POINT_INDEX_LIST_RETIRED | Primitive Point Index List RETIRED (0066,0029)
PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED | Print Job Description Sequence RETIRED (2120,0050)
PRINT_JOB_ID_RETIRED | Print Job ID RETIRED (2100,0010)
PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED | Print Management Capabilities Sequence RETIRED (2130,0010)
PRINT_PRIORITY | Print Priority (2000,0020)
PRINT_QUEUE_ID_RETIRED | Print Queue ID RETIRED (2110,0099)
PRINT_RETIRED | Print RETIRED (0000,51A0)
PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED | Printer Characteristics Sequence RETIRED (2130,0015)
PRINTER_CONFIGURATION_SEQUENCE | Printer Configuration Sequence (2000,001E)
PRINTER_NAME | Printer Name (2110,0030)
PRINTER_PIXEL_SPACING | Printer Pixel Spacing (2010,0376)
PRINTER_RESOLUTION_ID | Printer Resolution ID (2010,0052)
PRINTER_STATUS | Printer Status (2110,0010)
PRINTER_STATUS_INFO | Printer Status Info (2110,0020)
PRINTING_BIT_DEPTH | Printing Bit Depth (2000,00A1)
PRIOR_RECORD_KEY | Prior Record Key (0008,041C)
PRIOR_TREATMENT_DOSE_DESCRIPTION | Prior Treatment Dose Description (3010,0061)
PRIOR_TREATMENT_REFERENCE_SEQUENCE | Prior Treatment Reference Sequence (3010,0062)
PRIORITY | Priority (0000,0700)
PRISM_SEQUENCE | Prism Sequence (0046,0028)
PRIVATE_CREATOR_REFERENCE | Private Creator Reference (0008,0302)
PRIVATE_DATA_ELEMENT | Private Data Element (0008,0308)
PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE | Private Data Element Characteristics Sequence (0008,0300)
PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE | Private Data Element Definition Sequence (0008,0310)
PRIVATE_DATA_ELEMENT_DESCRIPTION | Private Data Element Description (0008,030E)
PRIVATE_DATA_ELEMENT_ENCODING | Private Data Element Encoding (0008,030F)
PRIVATE_DATA_ELEMENT_KEYWORD | Private Data Element Keyword (0008,030D)
PRIVATE_DATA_ELEMENT_NAME | Private Data Element Name (0008,030C)
PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS | Private Data Element Number of Items (0008,030B)
PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY | Private Data Element Value Multiplicity (0008,0309)
PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION | Private Data Element Value Representation (0008,030A)
PRIVATE_GROUP_REFERENCE | Private Group Reference (0008,0301)
PRIVATE_INFORMATION | Private Information (0002,0102)
PRIVATE_INFORMATION_CREATOR_UID | Private Information Creator UID (0002,0100)
PRIVATE_RECORD_UID | Private Record UID (0004,1432)
PROBE_CENTER_LOCATION_X | Probe Center Location X (0014,4058)
PROBE_CENTER_LOCATION_Z | Probe Center Location Z (0014,4059)
PROCEDURE_CODE_SEQUENCE | Procedure Code Sequence (0008,1032)
PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED | Procedure Context Flag (Trial) RETIRED (0040,A603)
PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED | Procedure Context Sequence (Trial) RETIRED (0040,A340)
PROCEDURE_CREATION_DATE | Procedure Creation Date (0014,4076)
PROCEDURE_EXPIRATION_DATE | Procedure Expiration Date (0014,4078)
PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Procedure Identifier Code Sequence (Trial) RETIRED (0040,A085)
PROCEDURE_LAST_MODIFIED_DATE | Procedure Last Modified Date (0014,407A)
PROCEDURE_STEP_CANCELLATION_DATETIME | Procedure Step Cancellation DateTime (0040,4052)
PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE | Procedure Step Communications URI Sequence (0074,1008)
PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Procedure Step Discontinuation Reason Code Sequence (0074,100E)
PROCEDURE_STEP_LABEL | Procedure Step Label (0074,1204)
PROCEDURE_STEP_PROGRESS | Procedure Step Progress (0074,1004)
PROCEDURE_STEP_PROGRESS_DESCRIPTION | Procedure Step Progress Description (0074,1006)
PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE | Procedure Step Progress Information Sequence (0074,1002)
PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE | Procedure Step Progress Parameters Sequence (0074,1007)
PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED | Procedure Step Relationship Type RETIRED (0074,1222)
PROCEDURE_STEP_STATE | Procedure Step State (0074,1000)
PROCEDURE_TYPE_CODE_SEQUENCE | Procedure Type Code Sequence (0076,0020)
PROCEDURE_VERSION | Procedure Version (0014,4074)
PROCESSING_FUNCTION | Processing Function (0018,5020)
PRODUCT_DESCRIPTION | Product Description (0044,0009)
PRODUCT_EXPIRATION_DATETIME | Product Expiration DateTime (0044,000B)
PRODUCT_LOT_IDENTIFIER | Product Lot Identifier (0044,000A)
PRODUCT_NAME | Product Name (0044,0008)
PRODUCT_PACKAGE_IDENTIFIER | Product Package Identifier (0044,0001)
PRODUCT_PARAMETER_SEQUENCE | Product Parameter Sequence (0044,0013)
PRODUCT_TYPE_CODE_SEQUENCE | Product Type Code Sequence (0044,0007)
PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE | Projection Eponymous Name Code Sequence (0018,5104)
PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE | Projection Imaging Acquisition Parameter Sequence (3002,0125)
PROJECTION_PIXEL_CALIBRATION_SEQUENCE | Projection Pixel Calibration Sequence (0018,9401)
PROPERTY_LABEL | Property Label (0014,2032)
PROPOSED_STUDY_SEQUENCE | Proposed Study Sequence (2130,00A0)
PROTOCOL_CONTEXT_SEQUENCE | Protocol Context Sequence (0040,0440)
PROTOCOL_DEFINED_PATIENT_POSITION | Protocol Defined Patient Position (0018,9947)
PROTOCOL_DESIGN_RATIONALE | Protocol Design Rationale (0018,9910)
PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY | Protocol Element Characteristics Summary (0018,9923)
PROTOCOL_ELEMENT_NAME | Protocol Element Name (0018,9922)
PROTOCOL_ELEMENT_NUMBER | Protocol Element Number (0018,9921)
PROTOCOL_ELEMENT_PURPOSE | Protocol Element Purpose (0018,9924)
PROTOCOL_NAME | Protocol Name (0018,1030)
PROTOCOL_PLANNING_INFORMATION | Protocol Planning Information (0018,990F)
PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE | Pseudo-Color Palette Instance Reference Sequence (0072,0705)
PSEUDO_COLOR_TYPE | Pseudo-Color Type (0072,0704)
PTO_REPRESENTATION_SEQUENCE | PTO Representation Sequence (4010,1037)
PULSE_NUMBER | Pulse Number (3008,0172)
PULSE_REPETITION_FREQUENCY | Pulse Repetition Frequency (0018,6032)
PULSE_REPETITION_INTERVAL | Pulse Repetition Interval (300A,028C)
PULSE_SEQUENCE_NAME | Pulse Sequence Name (0018,9005)
PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE | Pulse Specific Brachy Control Point Delivered Sequence (3008,0171)
PULSE_WIDTH | Pulse Width (0014,4022)
PULSER_EQUIPMENT_SEQUENCE | Pulser Equipment Sequence (0014,4002)
PULSER_NOTES | Pulser Notes (0014,4006)
PULSER_SETTINGS_SEQUENCE | Pulser Settings Sequence (0014,4020)
PULSER_TYPE | Pulser Type (0014,4004)
PUPIL_CENTROID_X_COORDINATE | Pupil Centroid X-Coordinate (0046,0203)
PUPIL_CENTROID_Y_COORDINATE | Pupil Centroid Y-Coordinate (0046,0204)
PUPIL_DIAMETER | Alias for tag EMMETROPIC_MAGNIFICATION (0022,000A)
PUPIL_DILATED | Pupil Dilated (0022,000D)
PUPIL_SIZE | Pupil Size (0046,0044)
PURPOSE_OF_REFERENCE_CODE_SEQUENCE | Purpose of Reference Code Sequence (0040,A170)
PVC_REJECTION | PVC Rejection (0018,1085)
PYRAMID_DESCRIPTION | Pyramid Description (0008,1088)
PYRAMID_LABEL | Pyramid Label (0020,0027)
PYRAMID_UID | Pyramid UID (0008,0019)
QA_RESULTS_SEQUENCE | QA Results Sequence (0028,700F)
QUADRATURE_RECEIVE_COIL | Quadrature Receive Coil (0018,9044)
QUALITY | Alias for tag QUANTITY (0040,0294)
QUALITY_CONTROL_IMAGE | Quality Control Image (0028,0300)
QUALITY_CONTROL_SUBJECT | Quality Control Subject (0010,0200)
QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE | Quality Control Subject Type Code Sequence (0010,0201)
QUALITY_SEQUENCE | Alias for tag QUANTITY_SEQUENCE (0040,0293)
QUALITY_THRESHOLD | Quality Threshold (0022,1630)
QUANTIFIED_DEFECT | Quantified Defect (0024,0098)
QUANTITY | Quantity (0040,0294)
QUANTITY_DEFINITION_SEQUENCE | Quantity Definition Sequence (0040,9220)
QUANTITY_SEQUENCE | Quantity Sequence (0040,0293)
QUERY_RETRIEVE_LEVEL | Query/Retrieve Level (0008,0052)
QUERY_RETRIEVE_VIEW | Query/Retrieve View (0008,0053)
QUEUE_STATUS_RETIRED | Queue Status RETIRED (2120,0010)
R_R_INTERVAL_TIME_MEASURED | Alias for tag R_R_INTERVAL_TIME_NOMINAL (0020,9251)
R_R_INTERVAL_TIME_NOMINAL | R-R Interval Time Nominal (0020,9251)
R_R_INTERVAL_VECTOR | R-R Interval Vector (0054,0060)
R_WAVE_POINTER | R Wave Pointer (0028,6040)
R_WAVE_TIME_VECTOR | R Wave Time Vector (0018,6060)
RADIAL_POSITION | Radial Position (0018,1142)
RADIATION_ATOMIC_NUMBER | Radiation Atomic Number (300A,0304)
RADIATION_BEAM_BLOCK_SLAB_THICKNESS | Radiation Beam Block Slab Thickness (300A,066E)
RADIATION_BEAM_BLOCK_THICKNESS | Radiation Beam Block Thickness (300A,066D)
RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER | Radiation Beam Compensator Milling Tool Diameter (300A,0669)
RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE | Radiation Beam Effective Wedge Angle (300A,0654)
RADIATION_BEAM_WEDGE_ANGLE | Radiation Beam Wedge Angle (300A,0652)
RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE | Radiation Beam Wedge Thin Edge Distance (300A,0653)
RADIATION_CHARGE_STATE | Radiation Charge State (300A,0306)
RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE | Radiation Device Configuration and Commissioning Key Sequence (300A,065A)
RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT | Radiation Dose Central Axis Displacement (300A,0624)
RADIATION_DOSE_IDENTIFICATION_INDEX | Radiation Dose Identification Index (300A,0603)
RADIATION_DOSE_IDENTIFICATION_LABEL | Radiation Dose Identification Label (300A,0619)
RADIATION_DOSE_IDENTIFICATION_SEQUENCE | Radiation Dose Identification Sequence (300A,0618)
RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL | Radiation Dose In-Vivo Measurement Label (300A,0623)
RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES | Radiation Dose Measurement Point Coordinates (300A,0627)
RADIATION_DOSE_SEQUENCE | Radiation Dose Sequence (300A,0617)
RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Radiation Dose Source to External Contour Distance (300A,0628)
RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE | Radiation Dose Source to Skin Distance (300A,0626)
RADIATION_DOSE_VALUE | Radiation Dose Value (300A,0625)
RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE | Radiation Dose Values Parameters Sequence (300A,061F)
RADIATION_DOSIMETER_UNIT_SEQUENCE | Radiation Dosimeter Unit Sequence (300A,0658)
RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE | Radiation Fluence Modifier Code Sequence (300A,0683)
RADIATION_GENERATION_MODE_DESCRIPTION | Radiation Generation Mode Description (300A,067D)
RADIATION_GENERATION_MODE_INDEX | Radiation Generation Mode Index (300A,0601)
RADIATION_GENERATION_MODE_LABEL | Radiation Generation Mode Label (300A,067C)
RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE | Radiation Generation Mode Machine Code Sequence (300A,067E)
RADIATION_GENERATION_MODE_SEQUENCE | Radiation Generation Mode Sequence (300A,067B)
RADIATION_MACHINE_NAME | Radiation Machine Name (3002,0020)
RADIATION_MACHINE_SAD | Radiation Machine SAD (3002,0022)
RADIATION_MACHINE_SSD | Radiation Machine SSD (3002,0024)
RADIATION_MASS_NUMBER | Radiation Mass Number (300A,0302)
RADIATION_MODE | Radiation Mode (0018,115A)
RADIATION_ORDER_INDEX | Radiation Order Index (300A,0786)
RADIATION_SETTING | Radiation Setting (0018,1155)
RADIATION_SOURCE_AXIS_DISTANCE | Radiation Source-Axis Distance (300A,0640)
RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE | Radiation Source Coordinate System Pitch Angle (3010,0096)
RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE | Radiation Source Coordinate System Roll Angle (3010,0095)
RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE | Radiation Source Coordinate System Yaw Angle (3010,0094)
RADIATION_TYPE | Radiation Type (300A,00C6)
RADIATION_TYPE_CODE_SEQUENCE | Radiation Type Code Sequence (300A,067F)
RADIOBIOLOGICAL_DOSE_EFFECT_FLAG | Radiobiological Dose Effect Flag (3010,0002)
RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE | Radiobiological Dose Effect Sequence (3010,0001)
RADIONUCLIDE_CODE_SEQUENCE | Radionuclide Code Sequence (0054,0300)
RADIONUCLIDE_HALF_LIFE | Radionuclide Half Life (0018,1075)
RADIONUCLIDE_POSITRON_FRACTION | Radionuclide Positron Fraction (0018,1076)
RADIONUCLIDE_RETIRED | Radionuclide RETIRED (0018,0030)
RADIONUCLIDE_TOTAL_DOSE | Radionuclide Total Dose (0018,1074)
RADIOPHARMACEUTICAL | Radiopharmaceutical (0018,0031)
RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID | Radiopharmaceutical Administration Event UID (0008,3012)
RADIOPHARMACEUTICAL_AGENT_NUMBER | Radiopharmaceutical Agent Number (0018,9729)
RADIOPHARMACEUTICAL_CODE_SEQUENCE | Radiopharmaceutical Code Sequence (0054,0304)
RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE | Radiopharmaceutical Information Sequence (0054,0016)
RADIOPHARMACEUTICAL_ROUTE | Radiopharmaceutical Route (0018,1070)
RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE | Alias for tag ADMINISTRATION_ROUTE_CODE_SEQUENCE (0054,0302)
RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY | Radiopharmaceutical Specific Activity (0018,1077)
RADIOPHARMACEUTICAL_START_DATETIME | Radiopharmaceutical Start DateTime (0018,1078)
RADIOPHARMACEUTICAL_START_TIME | Radiopharmaceutical Start Time (0018,1072)
RADIOPHARMACEUTICAL_STOP_DATETIME | Radiopharmaceutical Stop DateTime (0018,1079)
RADIOPHARMACEUTICAL_STOP_TIME | Radiopharmaceutical Stop Time (0018,1073)
RADIOPHARMACEUTICAL_USAGE_SEQUENCE | Radiopharmaceutical Usage Sequence (0018,9737)
RADIOPHARMACEUTICAL_VOLUME | Radiopharmaceutical Volume (0018,1071)
RADIOTHERAPY_TREATMENT_TYPE | Radiotherapy Treatment Type (3010,0046)
RADIUS_OF_CIRCULAR_COLLIMATOR | Radius of Circular Collimator (0018,1712)
RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION | Radius of Circular Exposure Control Sensing Region (0018,9441)
RADIUS_OF_CIRCULAR_SHUTTER | Radius of Circular Shutter (0018,1612)
RADIUS_OF_CURVATURE | Radius of Curvature (0046,0075)
RANDOMS_CORRECTED | Randoms Corrected (0018,9765)
RANDOMS_CORRECTION_METHOD | Randoms Correction Method (0054,1100)
RANGE_MATCHING_SEQUENCE | Range Matching Sequence (0008,0410)
RANGE_MODULATOR_DESCRIPTION | Range Modulator Description (300A,034A)
RANGE_MODULATOR_GATING_START_VALUE | Range Modulator Gating Start Value (300A,0382)
RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS | Range Modulator Gating Start Water Equivalent Thickness (300A,0386)
RANGE_MODULATOR_GATING_STOP_VALUE | Range Modulator Gating Stop Value (300A,0384)
RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS | Range Modulator Gating Stop Water Equivalent Thickness (300A,0388)
RANGE_MODULATOR_ID | Range Modulator ID (300A,0346)
RANGE_MODULATOR_NUMBER | Range Modulator Number (300A,0344)
RANGE_MODULATOR_SEQUENCE | Range Modulator Sequence (300A,0342)
RANGE_MODULATOR_SETTINGS_SEQUENCE | Range Modulator Settings Sequence (300A,0380)
RANGE_MODULATOR_TYPE | Range Modulator Type (300A,0348)
RANGE_OF_FREEDOM | Range of Freedom (0068,64A0)
RANGE_SHIFTER_DESCRIPTION | Range Shifter Description (300A,0322)
RANGE_SHIFTER_ID | Range Shifter ID (300A,0318)
RANGE_SHIFTER_NUMBER | Range Shifter Number (300A,0316)
RANGE_SHIFTER_SEQUENCE | Range Shifter Sequence (300A,0314)
RANGE_SHIFTER_SETTING | Range Shifter Setting (300A,0362)
RANGE_SHIFTER_SETTINGS_SEQUENCE | Range Shifter Settings Sequence (300A,0360)
RANGE_SHIFTER_TYPE | Range Shifter Type (300A,0320)
RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS | Range Shifter Water Equivalent Thickness (300A,0366)
RANGING_DEPTH | Ranging Depth (0052,0009)
RATIONAL_DENOMINATOR_VALUE | Rational Denominator Value (0040,A163)
RATIONAL_NUMERATOR_VALUE | Rational Numerator Value (0040,A162)
RAW_DATA_HANDLING | Raw Data Handling (0040,4040)
REAL_TIME_BULK_DATA_FLOW_SEQUENCE | Real-Time Bulk Data Flow Sequence (0034,000A)
REAL_WORLD_VALUE_FIRST_VALUE_MAPPED | Real World Value First Value Mapped (0040,9216)
REAL_WORLD_VALUE_INTERCEPT | Real World Value Intercept (0040,9224)
REAL_WORLD_VALUE_LAST_VALUE_MAPPED | Real World Value Last Value Mapped (0040,9211)
REAL_WORLD_VALUE_LUT_DATA | Real World Value LUT Data (0040,9212)
REAL_WORLD_VALUE_MAPPING_SEQUENCE | Real World Value Mapping Sequence (0040,9096)
REAL_WORLD_VALUE_SLOPE | Real World Value Slope (0040,9225)
REASON_FOR_CANCELLATION | Reason for Cancellation (0074,1238)
REASON_FOR_CHANNEL_OMISSION | Reason for Channel Omission (0074,140A)
REASON_FOR_CHANNEL_OMISSION_DESCRIPTION | Reason for Channel Omission Description (0074,140B)
REASON_FOR_OMISSION | Reason for Omission (300C,0112)
REASON_FOR_OMISSION_CODE_SEQUENCE | Reason for Omission Code Sequence (300A,0788)
REASON_FOR_OMISSION_DESCRIPTION | Reason for Omission Description (300C,0113)
REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE | Reason For Performed Procedure Code Sequence (0040,1012)
REASON_FOR_REMOVAL_CODE_SEQUENCE | Reason for Removal Code Sequence (0008,0406)
REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE | Reason for Requested Procedure Code Sequence (0040,100A)
REASON_FOR_STUDY_RETIRED | Reason for Study RETIRED (0032,1030)
REASON_FOR_SUPERSEDING | Reason for Superseding (3010,005C)
REASON_FOR_THE_ATTRIBUTE_MODIFICATION | Reason for the Attribute Modification (0400,0565)
REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED | Reason for the Imaging Service Request RETIRED (0040,2001)
REASON_FOR_THE_REQUESTED_PROCEDURE | Reason for the Requested Procedure (0040,1002)
REASON_FOR_VISIT | Reason for Visit (0032,1066)
REASON_FOR_VISIT_CODE_SEQUENCE | Reason for Visit Code Sequence (0032,1067)
RECEIVE_COIL_MANUFACTURER_NAME | Receive Coil Manufacturer Name (0018,9041)
RECEIVE_COIL_NAME | Receive Coil Name (0018,1250)
RECEIVE_COIL_TYPE | Receive Coil Type (0018,9043)
RECEIVE_TRANSDUCER_SEQUENCE | Receive Transducer Sequence (0014,4011)
RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE | Receive Transducer Settings Sequence (0014,4051)
RECEIVER_EQUIPMENT_SEQUENCE | Receiver Equipment Sequence (0014,4008)
RECEIVER_NOTES | Receiver Notes (0014,400C)
RECEIVER_RETIRED | Receiver RETIRED (0000,0300)
RECEIVER_SETTINGS_SEQUENCE | Receiver Settings Sequence (0014,4030)
RECEIVING_AE | Receiving AE (0074,1234)
RECEIVING_APPLICATION_ENTITY_TITLE | Receiving Application Entity Title (0002,0018)
RECEIVING_COIL | Alias for tag RECEIVE_COIL_NAME (0018,1250)
RECEIVING_PRESENTATION_ADDRESS | Receiving Presentation Address (0002,0028)
RECOGNITION_CODE_RETIRED | Recognition Code RETIRED (0008,0010)
RECOGNIZABLE_VISUAL_FEATURES | Recognizable Visual Features (0028,0302)
RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE | Recommended Absent Pixel CIELab Value (0048,0015)
RECOMMENDED_ANIMATION_RATE | Recommended Animation Rate (0070,1A03)
RECOMMENDED_DEFAULT_VALUE_SEQUENCE | Recommended Default Value Sequence (0082,0035)
RECOMMENDED_DISPLAY_CIELAB_VALUE | Recommended Display CIELab Value (0062,000D)
RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST | Recommended Display CIELab Value List (0066,0103)
RECOMMENDED_DISPLAY_FRAME_RATE | Recommended Display Frame Rate (0008,2144)
RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT | Recommended Display Frame Rate in Float (0008,9459)
RECOMMENDED_DISPLAY_GRAYSCALE_VALUE | Recommended Display Grayscale Value (0062,000C)
RECOMMENDED_EXPOSURE_INDEX | Recommended Exposure Index (0016,001C)
RECOMMENDED_LINE_THICKNESS | Recommended Line Thickness (0066,0038)
RECOMMENDED_POINT_RADIUS | Recommended Point Radius (0066,0037)
RECOMMENDED_PRESENTATION_OPACITY | Recommended Presentation Opacity (0066,000C)
RECOMMENDED_PRESENTATION_TYPE | Recommended Presentation Type (0066,000D)
RECOMMENDED_ROTATION_POINT | Recommended Rotation Point (0068,6346)
RECOMMENDED_VIEWING_MODE | Recommended Viewing Mode (0028,1090)
RECONSTRUCTION_ALGORITHM | Reconstruction Algorithm (0018,9315)
RECONSTRUCTION_ALGORITHM_SEQUENCE | Reconstruction Algorithm Sequence (0018,993D)
RECONSTRUCTION_ANGLE | Reconstruction Angle (0018,9319)
RECONSTRUCTION_DESCRIPTION | Reconstruction Description (0018,9531)
RECONSTRUCTION_DIAMETER | Reconstruction Diameter (0018,1100)
RECONSTRUCTION_END_LOCATION_SEQUENCE | Reconstruction End Location Sequence (0018,993C)
RECONSTRUCTION_FIELD_OF_VIEW | Reconstruction Field of View (0018,9317)
RECONSTRUCTION_INDEX | Reconstruction Index (0020,9536)
RECONSTRUCTION_METHOD | Reconstruction Method (0054,1103)
RECONSTRUCTION_PIPELINE_TYPE | Reconstruction Pipeline Type (0018,11BE)
RECONSTRUCTION_PIXEL_SPACING | Reconstruction Pixel Spacing (0018,9322)
RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE | Reconstruction Protocol Element Sequence (0018,9934)
RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Reconstruction Protocol Element Specification Sequence (0018,9933)
RECONSTRUCTION_START_LOCATION_SEQUENCE | Reconstruction Start Location Sequence (0018,993B)
RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE | Reconstruction Target Center Location Sequence (0018,993E)
RECONSTRUCTION_TARGET_CENTER_PATIENT | Reconstruction Target Center (Patient) (0018,9318)
RECONSTRUCTION_TYPE | Reconstruction Type (0018,9756)
RECORD_IN_USE_FLAG | Record In-use Flag (0004,1410)
RECORD_KEY | Record Key (0008,041B)
RECORDED_BLOCK_SEQUENCE | Recorded Block Sequence (3008,00D0)
RECORDED_BLOCK_SLAB_SEQUENCE | Recorded Block Slab Sequence (3008,00D1)
RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE | Recorded Brachy Accessory Device Sequence (3008,0120)
RECORDED_CHANNEL_SEQUENCE | Recorded Channel Sequence (3008,0130)
RECORDED_CHANNEL_SHIELD_SEQUENCE | Recorded Channel Shield Sequence (3008,0150)
RECORDED_CHANNEL_SHIELD_SEQUNCE | Alias for tag RECORDED_CHANNEL_SHIELD_SEQUENCE (3008,0150)
RECORDED_COMPENSATOR_SEQUENCE | Recorded Compensator Sequence (3008,00C0)
RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE | Recorded Lateral Spreading Device Sequence (3008,00F4)
RECORDED_RANGE_MODULATOR_SEQUENCE | Recorded Range Modulator Sequence (3008,00F6)
RECORDED_RANGE_SHIFTER_SEQUENCE | Recorded Range Shifter Sequence (3008,00F2)
RECORDED_RT_CONTROL_POINT_DATETIME | Recorded RT Control Point DateTime (300A,073A)
RECORDED_SNOUT_SEQUENCE | Recorded Snout Sequence (3008,00F0)
RECORDED_SOURCE_APPLICATION_SEQUENCE | Alias for tag RECORDED_SOURCE_APPLICATOR_SEQUENCE (3008,0140)
RECORDED_SOURCE_APPLICATOR_SEQUENCE | Recorded Source Applicator Sequence (3008,0140)
RECORDED_SOURCE_SEQUENCE | Recorded Source Sequence (3008,0100)
RECORDED_WEDGE_SEQUENCE | Recorded Wedge Sequence (3008,00B0)
RECTIFICATION_TYPE | Rectification Type (0018,1156)
RECTIFIER_SMOOTHING | Rectifier Smoothing (0014,4034)
RECTILINEAR_PHASE_ENCODE_REORDERING | Rectilinear Phase Encode Reordering (0018,9034)
RED_PALETTE_COLOR_LOOKUP_TABLE_DATA | Red Palette Color Lookup Table Data (0028,1201)
RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR | Red Palette Color Lookup Table Descriptor (0028,1101)
REFERENCE_AIR_KERMA_RATE | Reference Air Kerma Rate (300A,022A)
REFERENCE_BASIS_CODE_SEQUENCE | Reference Basis Code Sequence (0018,9902)
REFERENCE_COORDINATES | Reference Coordinates (0022,0032)
REFERENCE_DISPLAY_SETS | Reference Display Sets (0072,0218)
REFERENCE_DOSE_DEFINITION | Reference Dose Definition (300A,0512)
REFERENCE_DOSE_POINT_COORDINATES | Reference Dose Point Coordinates (300A,061E)
REFERENCE_DOSE_TYPE | Reference Dose Type (300A,061A)
REFERENCE_GEOMETRY_CODE_SEQUENCE | Reference Geometry Code Sequence (0018,9903)
REFERENCE_IMAGE_NUMBER | Reference Image Number (300A,00C8)
REFERENCE_LOCATION_DESCRIPTION | Reference Location Description (0018,9901)
REFERENCE_LOCATION_LABEL | Reference Location Label (0018,9900)
REFERENCE_PIXEL_PHYSICAL_VALUE_X | Reference Pixel Physical Value X (0018,6028)
REFERENCE_PIXEL_PHYSICAL_VALUE_Y | Reference Pixel Physical Value Y (0018,602A)
REFERENCE_PIXEL_X0 | Reference Pixel X0 (0018,6020)
REFERENCE_PIXEL_Y0 | Reference Pixel Y0 (0018,6022)
REFERENCE_RETIRED | Reference RETIRED (0020,1020)
REFERENCE_TO_RECORDED_SOUND_RETIRED | Reference to Recorded Sound RETIRED (4008,0103)
REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED | Referenced Accession Sequence (Trial) RETIRED (0040,A313)
REFERENCED_ASSERTION_UID | Referenced Assertion UID (0044,0108)
REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE | Referenced Baseline Parameters RT Radiation Instance Sequence (3002,011E)
REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE | Referenced Basic Annotation Box Sequence (2010,0520)
REFERENCED_BEAM_NUMBER | Referenced Beam Number (300C,0006)
REFERENCED_BEAM_SEQUENCE | Referenced Beam Sequence (300C,0004)
REFERENCED_BLOCK_NUMBER | Referenced Block Number (300C,00E0)
REFERENCED_BOLUS_SEQUENCE | Referenced Bolus Sequence (300C,00B0)
REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER | Referenced Brachy Accessory Device Number (3008,0122)
REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER | Referenced Brachy Application Setup Number (300C,000C)
REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE | Referenced Brachy Application Setup Sequence (300C,000A)
REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER | Referenced Calculated Dose Reference Number (3008,0092)
REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE | Referenced Calculated Dose Reference Sequence (3008,0090)
REFERENCED_CHANNEL_NUMBER | Referenced Channel Number (0074,1406)
REFERENCED_CHANNEL_SHIELD_NUMBER | Referenced Channel Shield Number (3008,0152)
REFERENCED_COLOR_PALETTE_INSTANCE_UID | Referenced Color Palette Instance UID (0028,0304)
REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE | Referenced Comparison SOP Instance Sequence (0082,0005)
REFERENCED_COMPENSATOR_NUMBER | Referenced Compensator Number (300C,00D0)
REFERENCED_CONCEPTUAL_VOLUME_UID | Referenced Conceptual Volume UID (3010,000B)
REFERENCED_CONTENT_ITEM | Referenced Content Item (0070,1904)
REFERENCED_CONTENT_ITEM_IDENTIFIER | Referenced Content Item Identifier (0040,DB73)
REFERENCED_CONTROL_POINT | Alias for tag REFERENCED_CONTROL_POINT_INDEX (300C,00F0)
REFERENCED_CONTROL_POINT_INDEX | Referenced Control Point Index (300C,00F0)
REFERENCED_CONTROL_POINT_SEQUENCE | Referenced Control Point Sequence (300C,00F2)
REFERENCED_CURVE_SEQUENCE_RETIRED | Referenced Curve Sequence RETIRED (0008,1145)
REFERENCED_DATETIME | Referenced DateTime (0040,A13A)
REFERENCED_DEFINED_DEVICE_INDEX | Referenced Defined Device Index (300A,0602)
REFERENCED_DEFINED_PROTOCOL_SEQUENCE | Referenced Defined Protocol Sequence (0018,990C)
REFERENCED_DEVICE_INDEX | Referenced Device Index (300A,0607)
REFERENCED_DIGITAL_SIGNATURE_SEQUENCE | Referenced Digital Signature Sequence (0400,0402)
REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE | Referenced Direct Segment Instance Sequence (3010,004A)
REFERENCED_DOSE_REFERENCE_NUMBER | Referenced Dose Reference Number (300C,0051)
REFERENCED_DOSE_REFERENCE_SEQUENCE | Referenced Dose Reference Sequence (300C,0050)
REFERENCED_DOSE_REFERENCE_UID | Referenced Dose Reference UID (300A,0083)
REFERENCED_DOSE_SEQUENCE | Referenced Dose Sequence (300C,0080)
REFERENCED_DOSIMETRIC_OBJECTIVE_UID | Referenced Dosimetric Objective UID (3010,006F)
REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE | Referenced Dosimetric Objectives Sequence (3010,0071)
REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX | Referenced Expected In-Vivo Measurement Value Index (300A,0773)
REFERENCED_FIDUCIAL_UID | Referenced Fiducial UID (0070,031B)
REFERENCED_FIDUCIALS_UID | Referenced Fiducials UID (3010,0031)
REFERENCED_FILE_ID | Referenced File ID (0004,1500)
REFERENCED_FILM_BOX_SEQUENCE | Referenced Film Box Sequence (2000,0500)
REFERENCED_FILM_SESSION_SEQUENCE | Referenced Film Session Sequence (2010,0500)
REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED | Referenced Findings Group UID (Trial) RETIRED (0040,A022)
REFERENCED_FIRST_FRAME_SEQUENCE | Referenced First Frame Sequence (0072,0427)
REFERENCED_FRACTION_GROUP_NUMBER | Referenced Fraction Group Number (300C,0022)
REFERENCED_FRACTION_GROUP_SEQUENCE | Referenced Fraction Group Sequence (300C,0020)
REFERENCED_FRACTION_NUMBER | Referenced Fraction Number (3008,0223)
REFERENCED_FRAME_NUMBER | Referenced Frame Number (0008,1160)
REFERENCED_FRAME_NUMBERS_RETIRED | Referenced Frame Numbers RETIRED (0040,A136)
REFERENCED_FRAME_OF_REFERENCE_SEQUENCE | Referenced Frame of Reference Sequence (3006,0010)
REFERENCED_FRAME_OF_REFERENCE_UID | Referenced Frame of Reference UID (3006,0024)
REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED | Referenced General Purpose Scheduled Procedure Step Sequence RETIRED (0040,4016)
REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED | Referenced General Purpose Scheduled Procedure Step Transaction UID RETIRED (0040,4023)
REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION | Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)
REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID | Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)
REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE | Alias for tag REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE (0008,9237)
REFERENCED_HPGL_DOCUMENT_ID | Referenced HPGL Document ID (0068,6440)
REFERENCED_IMAGE_BOX_SEQUENCE | Referenced Image Box Sequence (2010,0510)
REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED | Referenced Image Box Sequence (Retired) (2040,0500)
REFERENCED_IMAGE_EVIDENCE_SEQUENCE | Referenced Image Evidence Sequence (0008,9092)
REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED | Referenced Image Navigation Sequence RETIRED (0048,0200)
REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED | Referenced Image Overlay Box Sequence RETIRED (2020,0130)
REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE | Referenced Image Real World Value Mapping Sequence (0040,9094)
REFERENCED_IMAGE_SEQUENCE | Referenced Image Sequence (0008,1140)
REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID | Referenced Implant Template Group Member ID (0078,00B6)
REFERENCED_INSTANCE_SEQUENCE | Referenced Instance Sequence (0008,114A)
REFERENCED_INTERPRETATION_SEQUENCE_RETIRED | Referenced Interpretation Sequence RETIRED (4008,0050)
REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER | Referenced Lateral Spreading Device Number (300C,0102)
REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER | Referenced Measured Dose Reference Number (3008,0082)
REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE | Referenced Measured Dose Reference Sequence (3008,0080)
REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE | Referenced Non-Image Composite SOP Instance Sequence (0040,0220)
REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED | Referenced Object Observation Class (Trial) RETIRED (0040,A174)
REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED | Referenced Observation Class (Trial) RETIRED (0040,A173)
REFERENCED_OBSERVATION_UID_TRIAL_RETIRED | Referenced Observation UID (Trial) RETIRED (0040,A172)
REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE | Referenced Ophthalmic Axial Length Measurement QC Image Sequence (0022,1330)
REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE | Referenced Ophthalmic Axial Measurements Sequence (0022,1100)
REFERENCED_OPTICAL_PATH_IDENTIFIER | Referenced Optical Path Identifier (006A,000E)
REFERENCED_OTHER_PLANE_SEQUENCE | Referenced Other Plane Sequence (0008,9410)
REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED | Referenced Overlay Plane Groups RETIRED (2040,0011)
REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED | Referenced Overlay Plane Sequence RETIRED (2040,0010)
REFERENCED_OVERLAY_SEQUENCE_RETIRED | Referenced Overlay Sequence RETIRED (0008,1130)
REFERENCED_PARENT_RT_PRESCRIPTION_INDEX | Referenced Parent RT Prescription Index (3010,0042)
REFERENCED_PATH_INDEX | Referenced Path Index (0018,9378)
REFERENCED_PATIENT_ALIAS_SEQUENCE | Referenced Patient Alias Sequence (0038,0004)
REFERENCED_PATIENT_PHOTO_SEQUENCE | Referenced Patient Photo Sequence (0010,1100)
REFERENCED_PATIENT_SEQUENCE | Referenced Patient Sequence (0008,1120)
REFERENCED_PATIENT_SETUP_NUMBER | Referenced Patient Setup Number (300C,006A)
REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE | Referenced Patient Setup Photo Sequence (300A,078C)
REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX | Referenced Patient Setup Procedure Index (300A,0796)
REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE | Referenced Performed Procedure Step Sequence (0008,1111)
REFERENCED_PERFORMED_PROTOCOL_SEQUENCE | Referenced Performed Protocol Sequence (0018,990D)
REFERENCED_PLAN_OVERVIEW_INDEX | Referenced Plan Overview Index (300C,0118)
REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE | Referenced Position Reference Instance Sequence (3002,0132)
REFERENCED_PRESENTATION_LUT_SEQUENCE | Referenced Presentation LUT Sequence (2050,0500)
REFERENCED_PRESENTATION_STATE_SEQUENCE | Referenced Presentation State Sequence (0008,9237)
REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED | Referenced Print Job Sequence (Pull Stored Print) RETIRED (2100,0500)
REFERENCED_PRINT_JOB_SEQUENCE_RETIRED | Referenced Print Job Sequence RETIRED (2120,0070)
REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED | Referenced Procedure Step Sequence RETIRED (0040,0330)
REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX | Referenced Radiation Dose Identification Index (300A,060C)
REFERENCED_RADIATION_GENERATION_MODE_INDEX | Referenced Radiation Generation Mode Index (300A,0605)
REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX | Referenced Radiation RT Control Point Index (300A,073B)
REFERENCED_RANGE_MODULATOR_NUMBER | Referenced Range Modulator Number (300C,0104)
REFERENCED_RANGE_SHIFTER_NUMBER | Referenced Range Shifter Number (300C,0100)
REFERENCED_RAW_DATA_SEQUENCE | Referenced Raw Data Sequence (0008,9121)
REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE | Referenced Real World Value Mapping Instance Sequence (0008,114B)
REFERENCED_REFERENCE_IMAGE_NUMBER | Referenced Reference Image Number (300C,0007)
REFERENCED_REFERENCE_IMAGE_SEQUENCE | Referenced Reference Image Sequence (300C,0042)
REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE | Referenced Refractive Measurements Sequence (0046,0145)
REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE | Referenced Related General SOP Class UID in File (0004,151A)
REFERENCED_REQUEST_SEQUENCE | Referenced Request Sequence (0040,A370)
REFERENCED_RESULTS_SEQUENCE_RETIRED | Referenced Results Sequence RETIRED (0008,1100)
REFERENCED_ROI_NUMBER | Referenced ROI Number (3006,0084)
REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX | Referenced RT Accessory Holder Device Index (300A,060E)
REFERENCED_RT_INSTANCE_SEQUENCE | Referenced RT Instance Sequence (300A,0631)
REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED | Referenced RT Patient Setup Sequence RETIRED (300A,0632)
REFERENCED_RT_PHYSICIAN_INTENT_INDEX | Referenced RT Physician Intent Index (3010,005E)
REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE | Referenced RT Physician Intent Sequence (300A,063B)
REFERENCED_RT_PLAN_SEQUENCE | Referenced RT Plan Sequence (300C,0002)
REFERENCED_RT_PRESCRIPTION_INDEX | Referenced RT Prescription Index (3010,0041)
REFERENCED_RT_PRESCRIPTION_SEQUENCE | Referenced RT Prescription Sequence (300A,068A)
REFERENCED_RT_RADIATION_RECORD_SEQUENCE | Referenced RT Radiation Record Sequence (300A,0703)
REFERENCED_RT_RADIATION_SEQUENCE | Referenced RT Radiation Sequence (300A,0630)
REFERENCED_RT_RADIATION_SET_SEQUENCE | Referenced RT Radiation Set Sequence (300A,0702)
REFERENCED_RT_TREATMENT_PHASE_INDEX | Referenced RT Treatment Phase Index (3010,0040)
REFERENCED_RT_TREATMENT_PHASE_SEQUENCE | Referenced RT Treatment Phase Sequence (3010,0049)
REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE | Referenced RT Treatment Preparation Sequence (300A,078B)
REFERENCED_SAMPLE_POSITIONS | Referenced Sample Positions (0040,A132)
REFERENCED_SEGMENT_NUMBER | Referenced Segment Number (0062,000B)
REFERENCED_SEGMENT_REFERENCE_INDEX | Referenced Segment Reference Index (3010,0020)
REFERENCED_SERIES_SEQUENCE | Referenced Series Sequence (0008,1115)
REFERENCED_SETUP_IMAGE_SEQUENCE | Referenced Setup Image Sequence (300A,0401)
REFERENCED_SOP_CLASS_UID | Referenced SOP Class UID (0008,1150)
REFERENCED_SOP_CLASS_UID_IN_FILE | Referenced SOP Class UID in File (0004,1510)
REFERENCED_SOP_INSTANCE_MAC_SEQUENCE | Referenced SOP Instance MAC Sequence (0400,0403)
REFERENCED_SOP_INSTANCE_UID | Referenced SOP Instance UID (0008,1155)
REFERENCED_SOP_INSTANCE_UID_IN_FILE | Referenced SOP Instance UID in File (0004,1511)
REFERENCED_SOP_SEQUENCE | Referenced SOP Sequence (0008,1199)
REFERENCED_SOURCE_APPLICATOR_NUMBER | Referenced Source Applicator Number (3008,0142)
REFERENCED_SOURCE_NUMBER | Referenced Source Number (300C,000E)
REFERENCED_SPATIAL_REGISTRATION_SEQUENCE | Referenced Spatial Registration Sequence (0070,0404)
REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE | Alias for tag REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE (0040,0220)
REFERENCED_START_CONTROL_POINT_INDEX | Referenced Start Control Point Index (300C,00F4)
REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE | Referenced Stereometric Instance Sequence (0008,1134)
REFERENCED_STOP_CONTROL_POINT_INDEX | Referenced Stop Control Point Index (300C,00F6)
REFERENCED_STORAGE_MEDIA_SEQUENCE | Referenced Storage Media Sequence (2200,000D)
REFERENCED_STORED_PRINT_SEQUENCE_RETIRED | Referenced Stored Print Sequence RETIRED (2000,0510)
REFERENCED_STRUCTURE_SET_SEQUENCE | Referenced Structure Set Sequence (300C,0060)
REFERENCED_STRUCTURED_CONTEXT_SEQUENCE | Referenced Structured Context Sequence (0070,1903)
REFERENCED_STUDY_COMPONENT_SEQUENCE | Alias for tag REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE (0008,1111)
REFERENCED_STUDY_SEQUENCE | Referenced Study Sequence (0008,1110)
REFERENCED_SURFACE_DATA_SEQUENCE | Referenced Surface Data Sequence (0080,0013)
REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE | Referenced Surface Mesh Identification Sequence (0022,1620)
REFERENCED_SURFACE_NUMBER | Referenced Surface Number (0066,002C)
REFERENCED_SURFACE_SEQUENCE | Referenced Surface Sequence (0066,002B)
REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID | Referenced Target Luminance Characteristics ID (0028,700E)
REFERENCED_TEXTURE_SEQUENCE | Referenced Texture Sequence (0080,0012)
REFERENCED_TIME_OFFSETS | Referenced Time Offsets (0040,A138)
REFERENCED_TOLERANCE_TABLE_NUMBER | Referenced Tolerance Table Number (300C,00A0)
REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE | Referenced Transfer Syntax UID in File (0004,1512)
REFERENCED_TREATMENT_POSITION_GROUP_UID | Referenced Treatment Position Group UID (300A,0785)
REFERENCED_TREATMENT_POSITION_INDEX | Referenced Treatment Position Index (300A,060B)
REFERENCED_TREATMENT_RECORD_SEQUENCE | Referenced Treatment Record Sequence (3008,0030)
REFERENCED_VERIFICATION_IMAGE_SEQUENCE | Referenced Verification Image Sequence (300C,0040)
REFERENCED_VISIT_SEQUENCE | Referenced Visit Sequence (0008,1125)
REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED | Referenced VOI LUT Box Sequence RETIRED (2020,0140)
REFERENCED_WAVEFORM_CHANNELS | Referenced Waveform Channels (0040,A0B0)
REFERENCED_WAVEFORM_SEQUENCE | Referenced Waveform Sequence (0008,113A)
REFERENCED_WEDGE_NUMBER | Referenced Wedge Number (300C,00C0)
REFERENCED_X_RAY_DETECTOR_INDEX | Referenced X-Ray Detector Index (0018,9376)
REFERENCED_X_RAY_SOURCE_INDEX | Referenced X-Ray Source Index (0018,9377)
REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Referring Physician Identification Sequence (0008,0096)
REFERRING_PHYSICIANS_ADDRESS | Referring Physician's Address (0008,0092)
REFERRING_PHYSICIANS_NAME | Referring Physician's Name (0008,0090)
REFERRING_PHYSICIANS_TELEPHONE_NUMBERS | Referring Physician's Telephone Numbers (0008,0094)
REFLECTED_AMBIENT_LIGHT | Reflected Ambient Light (2010,0160)
REFORMATTING_INTERVAL | Reformatting Interval (0072,0514)
REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION | Reformatting Operation Initial View Direction (0072,0516)
REFORMATTING_OPERATION_TYPE | Reformatting Operation Type (0072,0510)
REFORMATTING_THICKNESS | Reformatting Thickness (0072,0512)
REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE | Refractive Error Before Refractive Surgery Code Sequence (0022,1103)
REFRACTIVE_INDEX_APPLIED | Refractive Index Applied (0052,003A)
REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR | Refractive Index of Aqueous Humor (0046,0118)
REFRACTIVE_INDEX_OF_CORNEA | Refractive Index of Cornea (0046,0117)
REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE | Refractive Parameters Used on Patient Sequence (0024,0112)
REFRACTIVE_POWER | Refractive Power (0046,0251)
REFRACTIVE_PROCEDURE_OCCURRED | Refractive Procedure Occurred (0022,1039)
REFRACTIVE_STATE_SEQUENCE | Refractive State Sequence (0022,001B)
REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE | Refractive Surgery Type Code Sequence (0022,1040)
REGION_DATA_TYPE | Region Data Type (0018,6014)
REGION_FLAGS | Region Flags (0018,6016)
REGION_LOCATION_MAX_X1 | Region Location Max X1 (0018,601C)
REGION_LOCATION_MAX_Y1 | Region Location Max Y1 (0018,601E)
REGION_LOCATION_MIN_X0 | Region Location Min X0 (0018,6018)
REGION_LOCATION_MIN_Y0 | Region Location Min Y0 (0018,601A)
REGION_OF_RESIDENCE | Region of Residence (0010,2152)
REGION_PIXEL_SHIFT_SEQUENCE | Region Pixel Shift Sequence (0028,9502)
REGION_SPATIAL_FORMAT | Region Spatial Format (0018,6012)
REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER | Registered Localizer Bottom Right Hand Corner (0022,1468)
REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER | Registered Localizer Top Left Hand Corner (0022,1467)
REGISTERED_LOCALIZER_UNITS | Registered Localizer Units (0022,1466)
REGISTRATION_METHOD_CODE_SEQUENCE | Registration Method Code Sequence (0080,0003)
REGISTRATION_SEQUENCE | Registration Sequence (0070,0308)
REGISTRATION_TO_LOCALIZER_SEQUENCE | Registration to Localizer Sequence (0022,1465)
REGISTRATION_TYPE_CODE_SEQUENCE | Registration Type Code Sequence (0070,030D)
RELATED_ASSERTION_SEQUENCE | Related Assertion Sequence (0044,0107)
RELATED_FRAME_OF_REFERENCE_UID_RETIRED | Related Frame of Reference UID RETIRED (3006,00C2)
RELATED_GENERAL_SOP_CLASS_UID | Related General SOP Class UID (0008,001A)
RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED | Related Procedure Step Sequence RETIRED (0074,1220)
RELATED_REFERENCE_RT_IMAGE_SEQUENCE | Related Reference RT Image Sequence (0074,1040)
RELATED_RT_ROI_OBSERVATIONS_SEQUENCE | Related RT ROI Observations Sequence (3006,00A0)
RELATED_RT_TREATMENT_PHASE_INDEX | Related RT Treatment Phase Index (3010,003F)
RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE | Related Segment Characteristics Sequence (3010,0028)
RELATED_SERIES_SEQUENCE | Related Series Sequence (0008,1250)
RELATIONSHIP_SEQUENCE_TRIAL_RETIRED | Relationship Sequence (Trial) RETIRED (0040,A731)
RELATIONSHIP_TYPE | Relationship Type (0040,A010)
RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED | Relationship Type Code Sequence (Trial) RETIRED (0040,A732)
RELATIVE_ELEVATION | Relative Elevation (0046,0252)
RELATIVE_IMAGE_POSITION_CODE_SEQUENCE | Relative Image Position Code Sequence (0022,001D)
RELATIVE_OPACITY | Relative Opacity (0070,0403)
RELATIVE_TIME | Relative Time (0072,0038)
RELATIVE_TIME_UNITS | Relative Time Units (0072,003A)
RELATIVE_X_RAY_EXPOSURE | Relative X-Ray Exposure (0018,1405)
RELEVANT_INFORMATION_SEQUENCE_RETIRED | Relevant Information Sequence RETIRED (0040,4022)
RELEVANT_OPT_ATTRIBUTES_SEQUENCE | Relevant OPT Attributes Sequence (0022,1472)
REMOVED_FROM_OPERATIONAL_USE | Removed from Operational Use (0008,0405)
RENDER_FIELD_OF_VIEW | Render Field of View (0070,1606)
RENDER_PROJECTION | Render Projection (0070,1602)
RENDERED_IMAGE_REFERENCE_SEQUENCE | Rendered Image Reference Sequence (0070,1104)
RENDERING_METHOD | Rendering Method (0070,120D)
REPEAT_FRACTION_CYCLE_LENGTH | Repeat Fraction Cycle Length (300A,007A)
REPETITION_TIME | Repetition Time (0018,0080)
REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE | Replaced Implant Assembly Template Sequence (0076,0008)
REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE | Replaced Implant Template Group Sequence (0078,0026)
REPLACED_IMPLANT_TEMPLATE_SEQUENCE | Replaced Implant Template Sequence (0068,6222)
REPLACED_PROCEDURE_STEP_SEQUENCE | Replaced Procedure Step Sequence (0074,1224)
REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED | Report Detail Sequence (Trial) RETIRED (0040,A380)
REPORT_NUMBER | Report Number (0020,00AA)
REPORT_PRODUCTION_STATUS_TRIAL_RETIRED | Report Production Status (Trial) RETIRED (4008,00FF)
REPORT_STATUS_COMMENT_TRIAL_RETIRED | Report Status Comment (Trial) RETIRED (0040,A33A)
REPORT_STATUS_ID_TRIAL_RETIRED | Report Status ID (Trial) RETIRED (0040,A125)
REPORTED_VALUES_ORIGIN | Reported Values Origin (3002,000A)
REPORTING_PRIORITY | Reporting Priority (0040,1009)
REPOSITORY_UNIQUE_ID | Repository Unique ID (0040,E030)
REPRESENTATIVE_FRAME_NUMBER | Representative Frame Number (0028,6010)
REPROJECTION_METHOD | Reprojection Method (0054,1004)
REQUEST_ATTRIBUTES_SEQUENCE | Request Attributes Sequence (0040,0275)
REQUEST_PRIORITY | Request Priority (2200,0020)
REQUESTED_CONTRAST_AGENT | Requested Contrast Agent (0032,1070)
REQUESTED_DECIMATE_CROP_BEHAVIOR | Requested Decimate/Crop Behavior (2020,0040)
REQUESTED_IMAGE_SIZE | Requested Image Size (2020,0030)
REQUESTED_IMAGE_SIZE_FLAG | Requested Image Size Flag (2020,00A0)
REQUESTED_LATERALITY_CODE_SEQUENCE | Requested Laterality Code Sequence (0032,1065)
REQUESTED_MEDIA_APPLICATION_PROFILE | Requested Media Application Profile (2200,000C)
REQUESTED_PROCEDURE_CODE_SEQUENCE | Requested Procedure Code Sequence (0032,1064)
REQUESTED_PROCEDURE_COMMENTS | Requested Procedure Comments (0040,1400)
REQUESTED_PROCEDURE_DESCRIPTION | Requested Procedure Description (0032,1060)
REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED | Requested Procedure Description (Trial) RETIRED (0040,1060)
REQUESTED_PROCEDURE_ID | Requested Procedure ID (0040,1001)
REQUESTED_PROCEDURE_LOCATION | Requested Procedure Location (0040,1005)
REQUESTED_PROCEDURE_PRIORITY | Requested Procedure Priority (0040,1003)
REQUESTED_RESOLUTION_ID | Requested Resolution ID (2020,0050)
REQUESTED_SERIES_DESCRIPTION | Requested Series Description (0018,9937)
REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE | Requested Series Description Code Sequence (0018,11C1)
REQUESTED_SOP_CLASS_UID | Requested SOP Class UID (0000,0003)
REQUESTED_SOP_INSTANCE_UID | Requested SOP Instance UID (0000,1001)
REQUESTED_STATUS_INTERVAL | Requested Status Interval (0008,0414)
REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED | Requested Subsequent Workitem Code Sequence RETIRED (0040,4031)
REQUESTING_AE | Requesting AE (0074,1236)
REQUESTING_PHYSICIAN | Requesting Physician (0032,1032)
REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Requesting Physician Identification Sequence (0032,1031)
REQUESTING_SERVICE | Requesting Service (0032,1033)
REQUESTING_SERVICE_CODE_SEQUENCE | Requesting Service Code Sequence (0032,1034)
RESCALE_INTERCEPT | Rescale Intercept (0028,1052)
RESCALE_SLOPE | Rescale Slope (0028,1053)
RESCALE_TYPE | Rescale Type (0028,1054)
RESIDUAL_SYRINGE_COUNTS | Residual Syringe Counts (0054,0017)
RESONANT_NUCLEUS | Resonant Nucleus (0018,9100)
RESOURCE_DESCRIPTION | Resource Description (0038,0102)
RESPIRATORY_CYCLE_POSITION | Respiratory Cycle Position (0018,9214)
RESPIRATORY_INTERVAL_TIME | Respiratory Interval Time (0020,9254)
RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE | Respiratory Motion Compensation Technique (0018,9170)
RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION | Respiratory Motion Compensation Technique Description (0018,9185)
RESPIRATORY_SIGNAL_SOURCE | Respiratory Signal Source (0018,9171)
RESPIRATORY_SIGNAL_SOURCE_ID | Respiratory Signal Source ID (0018,9186)
RESPIRATORY_SYNCHRONIZATION_SEQUENCE | Respiratory Synchronization Sequence (0020,9253)
RESPIRATORY_TRIGGER_DELAY_THRESHOLD | Respiratory Trigger Delay Threshold (0020,9256)
RESPIRATORY_TRIGGER_TYPE | Respiratory Trigger Type (0020,9250)
RESPITORY_TRIGGER_DELAY_TIME | Alias for tag NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME (0020,9255)
RESPITORY_TRIGGER_SEQUENCE | Alias for tag RESPIRATORY_SYNCHRONIZATION_SEQUENCE (0020,9253)
RESPONSE_SEQUENCE_NUMBER_RETIRED | Response Sequence Number RETIRED (0000,0860)
RESPONSIBLE_GROUP_CODE_SEQUENCE | Responsible Group Code Sequence (0008,0220)
RESPONSIBLE_ORGANIZATION | Responsible Organization (0010,2299)
RESPONSIBLE_PERSON | Responsible Person (0010,2297)
RESPONSIBLE_PERSON_ROLE | Responsible Person Role (0010,2298)
RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED | Resulting General Purpose Performed Procedure Steps Sequence RETIRED (0040,4015)
RESULTS_COMMENTS_RETIRED | Results Comments RETIRED (4008,4000)
RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED | Results Distribution List Sequence RETIRED (4008,0118)
RESULTS_ID_ISSUER_RETIRED | Results ID Issuer RETIRED (4008,0042)
RESULTS_ID_RETIRED | Results ID RETIRED (4008,0040)
RESULTS_NORMALS_SEQUENCE | Results Normals Sequence (0024,0064)
RETAIN_INSTANCES | Retain Instances (0008,0415)
RETAIN_RAW_DATA | Alias for tag RAW_DATA_HANDLING (0040,4040)
RETEST_SENSITIVITY_VALUE | Retest Sensitivity Value (0024,0096)
RETEST_STIMULUS_SEEN | Retest Stimulus Seen (0024,0095)
RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE | Retinal Thickness Definition Code Sequence (0022,1445)
RETRIEVE_AE_TITLE | Retrieve AE Title (0008,0054)
RETRIEVE_LOCATION_UID | Retrieve Location UID (0040,E011)
RETRIEVE_URI | Retrieve URI (0040,E010)
RETRIEVE_URL | Retrieve URL (0008,1190)
REVIEW_DATE | Review Date (300E,0004)
REVIEW_TIME | Review Time (300E,0005)
REVIEWER_NAME | Reviewer Name (300E,0008)
REVOLUTION_TIME | Revolution Time (0018,9305)
RF_ECHO_TRAIN_LENGTH | RF Echo Train Length (0018,9240)
RGB_LUT_TRANSFER_FUNCTION | RGB LUT Transfer Function (0028,140F)
RGBA_TRANSFER_FUNCTION_DESCRIPTION | RGBA Transfer Function Description (0070,1A09)
RIGHT_IMAGE_SEQUENCE | Right Image Sequence (0022,0022)
RIGHT_LENS_SEQUENCE | Right Lens Sequence (0046,0014)
ROBOTIC_BASE_LOCATION_INDICATOR | Alias for tag ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED (3010,0090)
ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED | Robotic Base Location Indicator RETIRED (3010,0090)
ROBOTIC_NODE_IDENTIFIER | Robotic Node Identifier (3010,0092)
ROBOTIC_PATH_CONTROL_POINT_SEQUENCE | Robotic Path Control Point Sequence (3010,0097)
ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE | Robotic Path Node Set Code Sequence (3010,0091)
ROI_AREA | ROI Area (6000,1301)
ROI_CONTOUR_SEQUENCE | ROI Contour Sequence (3006,0039)
ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE | ROI Derivation Algorithm Identification Sequence (3006,0037)
ROI_DESCRIPTION | ROI Description (3006,0028)
ROI_DISPLAY_COLOR | ROI Display Color (3006,002A)
ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION | ROI Elemental Composition Atomic Mass Fraction (3006,00B8)
ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER | ROI Elemental Composition Atomic Number (3006,00B7)
ROI_ELEMENTAL_COMPOSITION_SEQUENCE | ROI Elemental Composition Sequence (3006,00B6)
ROI_GENERATION_ALGORITHM | ROI Generation Algorithm (3006,0036)
ROI_GENERATION_DESCRIPTION | ROI Generation Description (3006,0038)
ROI_INTERPRETED_TYPE | Alias for tag RT_ROI_INTERPRETED_TYPE (3006,00A4)
ROI_INTERPRETER | ROI Interpreter (3006,00A6)
ROI_MEAN | ROI Mean (6000,1302)
ROI_NAME | ROI Name (3006,0026)
ROI_NUMBER | ROI Number (3006,0022)
ROI_OBSERVATION_DESCRIPTION_RETIRED | ROI Observation Description RETIRED (3006,0088)
ROI_OBSERVATION_LABEL_RETIRED | ROI Observation Label RETIRED (3006,0085)
ROI_PHYSICAL_PROPERTIES_SEQUENCE | ROI Physical Properties Sequence (3006,00B0)
ROI_PHYSICAL_PROPERTY | ROI Physical Property (3006,00B2)
ROI_PHYSICAL_PROPERTY_VALUE | ROI Physical Property Value (3006,00B4)
ROI_STANDARD_DEVIATION | ROI Standard Deviation (6000,1303)
ROI_VOLUME | ROI Volume (3006,002C)
ROTATION_ANGLE | Rotation Angle (0070,0230)
ROTATION_DIRECTION | Rotation Direction (0018,1140)
ROTATION_INFORMATION_SEQUENCE | Rotation Information Sequence (0054,0052)
ROTATION_OF_SCANNED_FILM | Rotation of Scanned Film (0018,2030)
ROTATION_OFFSET_RETIRED | Rotation Offset RETIRED (0018,1146)
ROTATION_POINT | Rotation Point (0070,0273)
ROTATION_VECTOR | Rotation Vector (0054,0050)
ROUTE_ID | Route ID (4010,1054)
ROUTE_ID_ASSIGNING_AUTHORITY | Route ID Assigning Authority (4010,1055)
ROUTE_OF_ADMISSIONS | Route of Admissions (0038,0016)
ROUTE_SEGMENT_END_LOCATION_ID | Route Segment End Location ID (4010,101F)
ROUTE_SEGMENT_END_TIME | Route Segment End Time (4010,1026)
ROUTE_SEGMENT_ID | Route Segment ID (4010,1007)
ROUTE_SEGMENT_LOCATION_ID_TYPE | Route Segment Location ID Type (4010,1020)
ROUTE_SEGMENT_SEQUENCE | Route Segment Sequence (4010,100A)
ROUTE_SEGMENT_START_LOCATION_ID | Route Segment Start Location ID (4010,101E)
ROUTE_SEGMENT_START_TIME | Route Segment Start Time (4010,1025)
ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX | Row Position In Total Image Pixel Matrix (0048,021F)
ROWS | Rows (0028,0010)
RT_ACCESSORY_DEVICE_SLOT_ID | RT Accessory Device Slot ID (300A,0615)
RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE | RT Accessory Holder Definition Sequence (300A,0614)
RT_ACCESSORY_HOLDER_SLOT_DISTANCE | RT Accessory Holder Slot Distance (300A,0612)
RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG | RT Accessory Holder Slot Existence Flag (300A,060F)
RT_ACCESSORY_HOLDER_SLOT_ID | RT Accessory Holder Slot ID (300A,0611)
RT_ACCESSORY_HOLDER_SLOT_SEQUENCE | RT Accessory Holder Slot Sequence (300A,0610)
RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS | RT Accessory Holder Water-Equivalent Thickness (300A,060D)
RT_ACCESSORY_SLOT_DISTANCE | RT Accessory Slot Distance (300A,0613)
RT_ACQUISITION_PATIENT_POSITION_SEQUENCE | RT Acquisition Patient Position Sequence (3002,0108)
RT_ANATOMIC_PRESCRIPTION_SEQUENCE | RT Anatomic Prescription Sequence (3010,0060)
RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE | RT Beam Delimiter Geometry Sequence (300A,064C)
RT_BEAM_LIMITING_DEVICE_ANGLE | RT Beam Limiting Device Angle (300A,0679)
RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE | RT Beam Limiting Device Definition Sequence (300A,064D)
RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE | RT Beam Limiting Device Distal Distance (300A,0643)
RT_BEAM_LIMITING_DEVICE_OFFSET | RT Beam Limiting Device Offset (300A,064B)
RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE | RT Beam Limiting Device Opening Sequence (300A,0656)
RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE | RT Beam Limiting Device Proximal Distance (300A,0642)
RT_BEAM_LIMITING_DEVICE_TYPE | RT Beam Limiting Device Type (300A,00B8)
RT_BEAM_MODIFIER_DEFINITION_DISTANCE | RT Beam Modifier Definition Distance (300A,0688)
RT_CONTROL_POINT_INDEX | RT Control Point Index (300A,0600)
RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE | RT Delivery Start Patient Position Sequence (300A,0789)
RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE | RT Device Distance Reference Location Code Sequence (300A,0659)
RT_DIAGNOSIS_CODE_SEQUENCE | RT Diagnosis Code Sequence (3010,005D)
RT_DOSE_ROI_SEQUENCE | RT Dose ROI Sequence RETIRED (3004,0010)
RT_DOSE_ROI_SEQUENCE_RETIRED | RT Dose ROI Sequence RETIRED (3004,0010)
RT_IMAGE_DESCRIPTION | RT Image Description (3002,0004)
RT_IMAGE_FRAME_CONTEXT_SEQUENCE | RT Image Frame Context Sequence (3002,0103)
RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE | RT Image Frame General Content Sequence (3002,0102)
RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE | RT Image Frame Imaging Device Position Sequence (3002,0109)
RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame kV Radiation Acquisition Sequence (3002,010A)
RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame MV Radiation Acquisition Sequence (3002,010B)
RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE | RT Image Frame Radiation Acquisition Sequence (3002,010C)
RT_IMAGE_LABEL | RT Image Label (3002,0002)
RT_IMAGE_NAME | RT Image Name (3002,0003)
RT_IMAGE_ORIENTATION | RT Image Orientation (3002,0010)
RT_IMAGE_PLANE | RT Image Plane (3002,000C)
RT_IMAGE_POSITION | RT Image Position (3002,0012)
RT_IMAGE_SCOPE_SEQUENCE | RT Image Scope Sequence (3002,0104)
RT_IMAGE_SID | RT Image SID (3002,0026)
RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE | RT Patient Position Displacement Sequence (300A,0798)
RT_PATIENT_POSITION_SCOPE_SEQUENCE | RT Patient Position Scope Sequence (300A,0784)
RT_PATIENT_POSITION_SEQUENCE | RT Patient Position Sequence (300A,0799)
RT_PHYSICIAN_INTENT_INDEX | RT Physician Intent Index (3010,0058)
RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE | RT Physician Intent Input Instance Sequence (3010,005F)
RT_PHYSICIAN_INTENT_NARRATIVE | RT Physician Intent Narrative (3010,005A)
RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE | RT Physician Intent Predecessor Sequence (3010,0055)
RT_PHYSICIAN_INTENT_SEQUENCE | RT Physician Intent Sequence (3010,0057)
RT_PLAN_DATE | RT Plan Date (300A,0006)
RT_PLAN_DESCRIPTION | RT Plan Description (300A,0004)
RT_PLAN_GEOMETRY | RT Plan Geometry (300A,000C)
RT_PLAN_LABEL | RT Plan Label (300A,0002)
RT_PLAN_NAME | RT Plan Name (300A,0003)
RT_PLAN_RELATIONSHIP | RT Plan Relationship (300A,0055)
RT_PLAN_TIME | RT Plan Time (300A,0007)
RT_PRESCRIPTION_INDEX | RT Prescription Index (3010,003C)
RT_PRESCRIPTION_LABEL | RT Prescription Label (3010,0054)
RT_PRESCRIPTION_SEQUENCE | RT Prescription Sequence (3010,006B)
RT_PROTOCOL_CODE_SEQUENCE | RT Protocol Code Sequence (3010,005B)
RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG | RT Radiation Physical and Geometric Content Detail Flag (300A,0638)
RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE | RT Radiation Salvage Record Control Point Sequence (300A,0722)
RT_RADIATION_SEQUENCE | RT Radiation Sequence (300A,0616)
RT_RADIATION_SET_DELIVERY_NUMBER | RT Radiation Set Delivery Number (300A,0704)
RT_RADIATION_SET_DELIVERY_USAGE | RT Radiation Set Delivery Usage (300A,079E)
RT_RADIATION_SET_INTENT | RT Radiation Set Intent (300A,0637)
RT_RADIATION_SET_USAGE | RT Radiation Set Usage (300A,0707)
RT_RADIATION_TASK_SEQUENCE | RT Radiation Task Sequence (300A,0797)
RT_RADIATION_USAGE | RT Radiation Usage (300A,0701)
RT_RECORD_FLAG | RT Record Flag (300A,0639)
RT_REFERENCED_SERIES_SEQUENCE | RT Referenced Series Sequence (3006,0014)
RT_REFERENCED_STUDY_SEQUENCE | RT Referenced Study Sequence (3006,0012)
RT_RELATED_ROI_SEQUENCE | RT Related ROI Sequence (3006,0030)
RT_ROI_IDENTIFICATION_CODE_SEQUENCE | RT ROI Identification Code Sequence (3006,0086)
RT_ROI_INTERPRETED_TYPE | RT ROI Interpreted Type (3006,00A4)
RT_ROI_OBERVATIONS_SEQUENCE | Alias for tag RT_ROI_OBSERVATIONS_SEQUENCE (3006,0080)
RT_ROI_OBSERVATIONS_SEQUENCE | RT ROI Observations Sequence (3006,0080)
RT_ROI_RELATIONSHIP | RT ROI Relationship (3006,0033)
RT_SEGMENT_ANNOTATION_INDEX | RT Segment Annotation Index (3010,003D)
RT_SEGMENT_ANNOTATION_SEQUENCE | RT Segment Annotation Sequence (3010,002A)
RT_TOLERANCE_SET_LABEL | RT Tolerance Set Label (300A,062A)
RT_TOLERANCE_SET_SEQUENCE | RT Tolerance Set Sequence (300A,0629)
RT_TREATMENT_APPROACH_LABEL | RT Treatment Approach Label (3010,0056)
RT_TREATMENT_FRACTION_COMPLETION_STATUS | RT Treatment Fraction Completion Status (300A,0706)
RT_TREATMENT_INTENT_TYPE | RT Treatment Intent Type (3010,0059)
RT_TREATMENT_PHASE_INDEX | RT Treatment Phase Index (3010,003A)
RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG | RT Treatment Phase Intent Presence Flag (3010,0045)
RT_TREATMENT_PHASE_INTERVAL_SEQUENCE | RT Treatment Phase Interval Sequence (3010,004E)
RT_TREATMENT_PHASE_UID | RT Treatment Phase UID (3010,003B)
RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE | RT Treatment Preparation Patient Position Sequence (300A,078A)
RT_TREATMENT_SOURCE_COORDINATES | RT Treatment Source Coordinates (3010,0093)
RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE | RT Treatment Technique Code Sequence (3010,0080)
RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE | RT Treatment Termination Reason Code Sequence (300A,0715)
RT_TREATMENT_TERMINATION_STATUS | RT Treatment Termination Status (300A,0714)
RTV_COMMUNICATION_SOP_CLASS_UID | RTV Communication SOP Class UID (0002,0032)
RTV_COMMUNICATION_SOP_INSTANCE_UID | RTV Communication SOP Instance UID (0002,0033)
RTV_FLOW_ACTUAL_FRAME_DURATION | RTV Flow Actual Frame Duration (0002,0038)
RTV_FLOW_IDENTIFIER | RTV Flow Identifier (0002,0036)
RTV_FLOW_RTP_SAMPLING_RATE | RTV Flow RTP Sampling Rate (0002,0037)
RTV_META_INFORMATION_VERSION | RTV Meta Information Version (0002,0031)
RTV_SOURCE_IDENTIFIER | RTV Source Identifier (0002,0035)
SAFE_POSITION_EXIT_DATE | Safe Position Exit Date (3008,0162)
SAFE_POSITION_EXIT_TIME | Safe Position Exit Time (3008,0164)
SAFE_POSITION_RETURN_DATE | Safe Position Return Date (3008,0166)
SAFE_POSITION_RETURN_TIME | Safe Position Return Time (3008,0168)
SAMPLE_RATE_RETIRED | Sample Rate RETIRED (5000,2008)
SAMPLES_PER_PIXEL | Samples per Pixel (0028,0002)
SAMPLES_PER_PIXEL_USED | Samples per Pixel Used (0028,0003)
SAMPLING_FREQUENCY | Sampling Frequency (003A,001A)
SAMPLING_STEP_SIZE | Sampling Step Size (0070,1607)
SAR | SAR (0018,1316)
SATURATION | Saturation (0016,0049)
SATURATION_RECOVERY | Saturation Recovery (0018,9024)
SCAN_ARC | Scan Arc (0018,1143)
SCAN_ARC_TYPE | Scan Arc Type (3002,012E)
SCAN_LENGTH | Scan Length (0018,1302)
SCAN_MODE | Scan Mode (300A,0308)
SCAN_OPTIONS | Scan Options (0018,0022)
SCAN_PATTERN_TYPE_CODE_SEQUENCE | Scan Pattern Type Code Sequence (0022,1618)
SCAN_PROGRESSION_DIRECTION | Scan Progression Direction (0054,0501)
SCAN_SPOT_METERSET_WEIGHTS | Scan Spot Meterset Weights (300A,0396)
SCAN_SPOT_METERSETS_DELIVERED | Scan Spot Metersets Delivered (3008,0047)
SCAN_SPOT_POSITION_MAP | Scan Spot Position Map (300A,0394)
SCAN_SPOT_PRESCRIBED_INDICES | Scan Spot Prescribed Indices (300A,0391)
SCAN_SPOT_REORDERED | Scan Spot Reordered (300A,0393)
SCAN_SPOT_REORDERING_ALLOWED | Scan Spot Reordering Allowed (300A,0395)
SCAN_SPOT_SIZES_DELIVERED | Scan Spot Sizes Delivered (300A,0399)
SCAN_SPOT_TIME_OFFSET | Scan Spot Time Offset (300A,038F)
SCAN_SPOT_TUNE_ID | Scan Spot Tune ID (300A,0390)
SCAN_START_POSITION_SEQUENCE | Scan Start Position Sequence (3002,012B)
SCAN_STOP_POSITION_SEQUENCE | Scan Stop Position Sequence (3002,012C)
SCAN_TYPE | Scan Type (4010,1048)
SCAN_VELOCITY | Scan Velocity (0018,1300)
SCANNING_SEQUENCE | Scanning Sequence (0018,0020)
SCANNING_SPOT_SIZE | Scanning Spot Size (300A,0398)
SCATTER_CORRECTED | Scatter Corrected (0018,9760)
SCATTER_CORRECTION_METHOD | Scatter Correction Method (0054,1105)
SCATTER_FRACTION_FACTOR | Scatter Fraction Factor (0054,1323)
SCENE_CAPTURE_TYPE | Scene Capture Type (0016,0046)
SCENE_TYPE | Scene Type (0016,003B)
SCHEDULED_ADMISSION_DATE_RETIRED | Scheduled Admission Date RETIRED (0038,001A)
SCHEDULED_ADMISSION_TIME_RETIRED | Scheduled Admission Time RETIRED (0038,001B)
SCHEDULED_DISCHARGE_DATE_RETIRED | Scheduled Discharge Date RETIRED (0038,001C)
SCHEDULED_DISCHARGE_TIME_RETIRED | Scheduled Discharge Time RETIRED (0038,001D)
SCHEDULED_HUMAN_PERFORMERS_SEQUENCE | Scheduled Human Performers Sequence (0040,4034)
SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED | Scheduled Patient Institution Residence RETIRED (0038,001E)
SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE | Alias for tag SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE (0040,000B)
SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE | Scheduled Performing Physician Identification Sequence (0040,000B)
SCHEDULED_PERFORMING_PHYSICIANS_NAME | Scheduled Performing Physician's Name (0040,0006)
SCHEDULED_PROCEDURE_STEP_DESCRIPTION | Scheduled Procedure Step Description (0040,0007)
SCHEDULED_PROCEDURE_STEP_END_DATE | Scheduled Procedure Step End Date (0040,0004)
SCHEDULED_PROCEDURE_STEP_END_TIME | Scheduled Procedure Step End Time (0040,0005)
SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME | Scheduled Procedure Step Expiration DateTime (0040,4008)
SCHEDULED_PROCEDURE_STEP_ID | Scheduled Procedure Step ID (0040,0009)
SCHEDULED_PROCEDURE_STEP_LOCATION | Scheduled Procedure Step Location (0040,0011)
SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME | Scheduled Procedure Step Modification DateTime (0040,4010)
SCHEDULED_PROCEDURE_STEP_PRIORITY | Scheduled Procedure Step Priority (0074,1200)
SCHEDULED_PROCEDURE_STEP_SEQUENCE | Scheduled Procedure Step Sequence (0040,0100)
SCHEDULED_PROCEDURE_STEP_START_DATE | Scheduled Procedure Step Start Date (0040,0002)
SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME | Alias for tag SCHEDULED_PROCEDURE_STEP_START_DATETIME (0040,4005)
SCHEDULED_PROCEDURE_STEP_START_DATETIME | Scheduled Procedure Step Start DateTime (0040,4005)
SCHEDULED_PROCEDURE_STEP_START_TIME | Scheduled Procedure Step Start Time (0040,0003)
SCHEDULED_PROCEDURE_STEP_STATUS | Scheduled Procedure Step Status (0040,0020)
SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED | Scheduled Processing Applications Code Sequence RETIRED (0040,4004)
SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE | Scheduled Processing Parameters Sequence (0074,1210)
SCHEDULED_PROTOCOL_CODE_SEQUENCE | Scheduled Protocol Code Sequence (0040,0008)
SCHEDULED_SPECIMEN_SEQUENCE | Scheduled Specimen Sequence (0040,0500)
SCHEDULED_STATION_AE_TITLE | Scheduled Station AE Title (0040,0001)
SCHEDULED_STATION_CLASS_CODE_SEQUENCE | Scheduled Station Class Code Sequence (0040,4026)
SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE | Scheduled Station Geographic Location Code Sequence (0040,4027)
SCHEDULED_STATION_NAME | Scheduled Station Name (0040,0010)
SCHEDULED_STATION_NAME_CODE_SEQUENCE | Scheduled Station Name Code Sequence (0040,4025)
SCHEDULED_STEP_ATTRIBUTES_SEQUENCE | Scheduled Step Attributes Sequence (0040,0270)
SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED | Scheduled Study Location AE Title RETIRED (0032,1021)
SCHEDULED_STUDY_LOCATION_RETIRED | Scheduled Study Location RETIRED (0032,1020)
SCHEDULED_STUDY_START_DATE_RETIRED | Scheduled Study Start Date RETIRED (0032,1000)
SCHEDULED_STUDY_START_TIME_RETIRED | Scheduled Study Start Time RETIRED (0032,1001)
SCHEDULED_STUDY_STOP_DATE_RETIRED | Scheduled Study Stop Date RETIRED (0032,1010)
SCHEDULED_STUDY_STOP_TIME_RETIRED | Scheduled Study Stop Time RETIRED (0032,1011)
SCHEDULED_WORKITEM_CODE_SEQUENCE | Scheduled Workitem Code Sequence (0040,4018)
SCOPE_OF_INVENTORY_SEQUENCE | Scope of Inventory Sequence (0008,0400)
SCP_STATUS | SCP Status (0074,1242)
SCREEN_MINIMUM_COLOR_BIT_DEPTH | Screen Minimum Color Bit Depth (0072,010C)
SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH | Screen Minimum Grayscale Bit Depth (0072,010A)
SCREENING_BASELINE_MEASURED | Screening Baseline Measured (0024,0120)
SCREENING_BASELINE_MEASURED_SEQUENCE | Screening Baseline Measured Sequence (0024,0122)
SCREENING_BASELINE_TYPE | Screening Baseline Type (0024,0124)
SCREENING_BASELINE_VALUE | Screening Baseline Value (0024,0126)
SCREENING_TEST_MODE_CODE_SEQUENCE | Screening Test Mode Code Sequence (0024,0016)
SEAM_LINE_INDEX | Seam Line Index (0052,0036)
SEAM_LINE_LOCATION | Seam Line Location (0052,0033)
SECONDARY_CAPTURE_DEVICE_ID | Secondary Capture Device ID (0018,1010)
SECONDARY_CAPTURE_DEVICE_MANUFACTURER | Secondary Capture Device Manufacturer (0018,1016)
SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME | Secondary Capture Device Manufacturer's Model Name (0018,1018)
SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS | Secondary Capture Device Software Versions (0018,1019)
SECONDARY_COUNTS_ACCUMULATED | Secondary Counts Accumulated (0054,1311)
SECONDARY_COUNTS_TYPE | Secondary Counts Type (0054,1220)
SECONDARY_POSITIONER_INCREMENT | Secondary Positioner Increment (0018,9515)
SECONDARY_POSITIONER_INCREMENT_SIGN | Secondary Positioner Increment Sign (0018,9519)
SECONDARY_POSITIONER_SCAN_ARC | Secondary Positioner Scan Arc (0018,9509)
SECONDARY_POSITIONER_SCAN_START_ANGLE | Secondary Positioner Scan Start Angle (0018,9511)
SEGMENT_ALGORITHM_NAME | Segment Algorithm Name (0062,0009)
SEGMENT_ALGORITHM_TYPE | Segment Algorithm Type (0062,0008)
SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE | Segment Annotation Category Code Sequence (3010,002B)
SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE | Segment Annotation Type Code Sequence (3010,002C)
SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE | Segment Annotation Type Modifier Code Sequence (3010,002F)
SEGMENT_CHARACTERISTICS_PRECEDENCE | Segment Characteristics Precedence (3010,0029)
SEGMENT_CHARACTERISTICS_SEQUENCE | Segment Characteristics Sequence (3010,0027)
SEGMENT_DESCRIPTION | Segment Description (0062,0006)
SEGMENT_IDENTIFICATION_SEQUENCE | Segment Identification Sequence (0062,000A)
SEGMENT_LABEL | Segment Label (0062,0005)
SEGMENT_NUMBER | Segment Number (0062,0004)
SEGMENT_REFERENCE_INDEX | Segment Reference Index (3010,0022)
SEGMENT_REFERENCE_SEQUENCE | Segment Reference Sequence (3010,0021)
SEGMENT_SEQUENCE | Segment Sequence (0062,0002)
SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE | Segment Surface Generation Algorithm Identification Sequence (0066,002D)
SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE | Segment Surface Source Instance Sequence (0066,002E)
SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE | Segmentation Algorithm Identification Sequence (0062,0007)
SEGMENTATION_CREATION_TEMPLATE_LABEL | Segmentation Creation Template Label (3010,001E)
SEGMENTATION_FRACTIONAL_TYPE | Segmentation Fractional Type (0062,0010)
SEGMENTATION_TEMPLATE_UID | Segmentation Template UID (3010,001F)
SEGMENTATION_TYPE | Segmentation Type (0062,0001)
SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Alpha Palette Color Lookup Table Data (0028,1224)
SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1223)
SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Blue Palette Color Lookup Table Data (0028,1223)
SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1222)
SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Green Palette Color Lookup Table Data (0028,1222)
SEGMENTED_K_SPACE_TRAVERSAL | Segmented k-Space Traversal (0018,9033)
SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE | Segmented Property Category Code Sequence (0062,0003)
SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE | Segmented Property Type Code Sequence (0062,000F)
SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE | Segmented Property Type Modifier Code Sequence (0062,0011)
SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE | Alias for tag SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1221)
SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA | Segmented Red Palette Color Lookup Table Data (0028,1221)
SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE | Segmented RT Accessory Device Sequence (3010,0026)
SEGMENTS_OVERLAP | Segments Overlap (0062,0013)
SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE | Selected Frame Functional Groups Sequence (3002,0101)
SELECTED_FRAME_NUMBER | Selected Frame Number (3002,0100)
SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Selected Segmental Ophthalmic Axial Length Sequence (0022,1257)
SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Selected Total Ophthalmic Axial Length Sequence (0022,1260)
SELECTOR_AE_VALUE | Selector AE Value (0072,005E)
SELECTOR_AS_VALUE | Selector AS Value (0072,005F)
SELECTOR_AT_VALUE | Selector AT Value (0072,0060)
SELECTOR_ATTRIBUTE | Selector Attribute (0072,0026)
SELECTOR_ATTRIBUTE_KEYWORD | Selector Attribute Keyword (0082,0019)
SELECTOR_ATTRIBUTE_NAME | Selector Attribute Name (0082,0018)
SELECTOR_ATTRIBUTE_PRIVATE_CREATOR | Selector Attribute Private Creator (0072,0056)
SELECTOR_ATTRIBUTE_VR | Selector Attribute VR (0072,0050)
SELECTOR_CODE_SEQUENCE_VALUE | Selector Code Sequence Value (0072,0080)
SELECTOR_CS_VALUE | Selector CS Value (0072,0062)
SELECTOR_DA_VALUE | Selector DA Value (0072,0061)
SELECTOR_DS_VALUE | Selector DS Value (0072,0072)
SELECTOR_DT_VALUE | Selector DT Value (0072,0063)
SELECTOR_FD_VALUE | Selector FD Value (0072,0074)
SELECTOR_FL_VALUE | Selector FL Value (0072,0076)
SELECTOR_IS_VALUE | Selector IS Value (0072,0064)
SELECTOR_LO_VALUE | Selector LO Value (0072,0066)
SELECTOR_LT_VALUE | Selector LT Value (0072,0068)
SELECTOR_OB_VALUE | Selector OB Value (0072,0065)
SELECTOR_OD_VALUE | Selector OD Value (0072,0073)
SELECTOR_OF_VALUE | Selector OF Value (0072,0067)
SELECTOR_OL_VALUE | Selector OL Value (0072,0075)
SELECTOR_OV_VALUE | Selector OV Value (0072,0081)
SELECTOR_OW_VALUE | Selector OW Value (0072,0069)
SELECTOR_PN_VALUE | Selector PN Value (0072,006A)
SELECTOR_SEQUENCE_POINTER | Selector Sequence Pointer (0072,0052)
SELECTOR_SEQUENCE_POINTER_ITEMS | Selector Sequence Pointer Items (0074,1057)
SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR | Selector Sequence Pointer Private Creator (0072,0054)
SELECTOR_SH_VALUE | Selector SH Value (0072,006C)
SELECTOR_SL_VALUE | Selector SL Value (0072,007C)
SELECTOR_SS_VALUE | Selector SS Value (0072,007E)
SELECTOR_ST_VALUE | Selector ST Value (0072,006E)
SELECTOR_SV_VALUE | Selector SV Value (0072,0082)
SELECTOR_TM_VALUE | Selector TM Value (0072,006B)
SELECTOR_UC_VALUE | Selector UC Value (0072,006F)
SELECTOR_UI_VALUE | Selector UI Value (0072,007F)
SELECTOR_UL_VALUE | Selector UL Value (0072,0078)
SELECTOR_UN_VALUE | Selector UN Value (0072,006D)
SELECTOR_UR_VALUE | Selector UR Value (0072,0071)
SELECTOR_US_VALUE | Selector US Value (0072,007A)
SELECTOR_UT_VALUE | Selector UT Value (0072,0070)
SELECTOR_UV_VALUE | Selector UV Value (0072,0083)
SELECTOR_VALUE_NUMBER | Selector Value Number (0072,0028)
SELF_TIMER_MODE | Self Timer Mode (0016,0019)
SENDING_APPLICATION_ENTITY_TITLE | Sending Application Entity Title (0002,0017)
SENDING_PRESENTATION_ADDRESS | Sending Presentation Address (0002,0027)
SENSING_METHOD | Sensing Method (0016,0039)
SENSITIVITY | Sensitivity (0018,6000)
SENSITIVITY_CALIBRATED | Sensitivity Calibrated (0018,9767)
SENSITIVITY_TYPE | Sensitivity Type (0016,001A)
SENSITIVITY_VALUE | Sensitivity Value (0024,0094)
SENSOR_NAME | Sensor Name (0014,3022)
SENSOR_TEMPERATURE | Sensor Temperature (0014,3028)
SEQUENCE_NAME | Sequence Name (0018,0024)
SEQUENCE_OF_ULTRASOUND_REGIONS | Sequence of Ultrasound Regions (0018,6011)
SEQUENCE_VARIANT | Sequence Variant (0018,0021)
SEQUENCING_INDICATOR_TRIAL_RETIRED | Sequencing Indicator (Trial) RETIRED (0040,A060)
SERIES_DATE | Series Date (0008,0021)
SERIES_DESCRIPTION | Series Description (0008,103E)
SERIES_DESCRIPTION_CODE_SEQUENCE | Series Description Code Sequence (0008,103F)
SERIES_IN_STUDY_RETIRED | Series in Study RETIRED (0020,1000)
SERIES_INSTANCE_UID | Series Instance UID (0020,000E)
SERIES_NUMBER | Series Number (0020,0011)
SERIES_TIME | Series Time (0008,0031)
SERIES_TYPE | Series Type (0054,1000)
SERVICE_EPISODE_DESCRIPTION | Service Episode Description (0038,0062)
SERVICE_EPISODE_ID | Service Episode ID (0038,0060)
SETTLING_PHASE_FRAME | Settling Phase Frame (0018,9624)
SETUP_DEVICE_DESCRIPTION | Setup Device Description (300A,01BA)
SETUP_DEVICE_LABEL | Setup Device Label (300A,01B8)
SETUP_DEVICE_PARAMETER | Setup Device Parameter (300A,01BC)
SETUP_DEVICE_SEQUENCE | Setup Device Sequence (300A,01B4)
SETUP_DEVICE_TYPE | Setup Device Type (300A,01B6)
SETUP_IMAGE_COMMENT | Setup Image Comment (300A,0402)
SETUP_REFERENCE_DESCRIPTION | Setup Reference Description (300A,01D0)
SETUP_TECHNIQUE | Setup Technique (300A,01B0)
SETUP_TECHNIQUE_DESCRIPTION | Setup Technique Description (300A,01B2)
SHADING_STYLE | Shading Style (0070,1701)
SHADOW_COLOR_CIELAB_VALUE | Shadow Color CIELab Value (0070,0247)
SHADOW_OFFSET_X | Shadow Offset X (0070,0245)
SHADOW_OFFSET_Y | Shadow Offset Y (0070,0246)
SHADOW_OPACITY | Shadow Opacity (0070,0258)
SHADOW_STYLE | Shadow Style (0070,0244)
SHAPE_TYPE | Shape Type (0070,0306)
SHARED_FUNCTIONAL_GROUPS_SEQUENCE | Shared Functional Groups Sequence (5200,9229)
SHARPNESS | Sharpness (0016,004A)
SHIELDING_DEVICE_DESCRIPTION | Shielding Device Description (300A,01A6)
SHIELDING_DEVICE_LABEL | Shielding Device Label (300A,01A4)
SHIELDING_DEVICE_POSITION | Shielding Device Position (300A,01A8)
SHIELDING_DEVICE_SEQUENCE | Shielding Device Sequence (300A,01A0)
SHIELDING_DEVICE_TYPE | Shielding Device Type (300A,01A2)
SHININESS | Shininess (0070,1706)
SHORT_TERM_FLUCTUATION | Short Term Fluctuation (0024,0075)
SHORT_TERM_FLUCTUATION_CALCULATED | Short Term Fluctuation Calculated (0024,0074)
SHORT_TERM_FLUCTUATION_PROBABILITY | Short Term Fluctuation Probability (0024,0077)
SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED | Short Term Fluctuation Probability Calculated (0024,0076)
SHOT_DURATION_TIME | Shot Duration Time (0080,0004)
SHOT_OFFSET_TIME | Shot Offset Time (0080,0005)
SHOW_ACQUISITION_TECHNIQUES_FLAG | Show Acquisition Techniques Flag (0072,0716)
SHOW_GRAPHIC_ANNOTATION_FLAG | Show Graphic Annotation Flag (0072,0712)
SHOW_GRAYSCALE_INVERTED | Show Grayscale Inverted (0072,0706)
SHOW_IMAGE_TRUE_SIZE_FLAG | Show Image True Size Flag (0072,0710)
SHOW_PATIENT_DEMOGRAPHICS_FLAG | Show Patient Demographics Flag (0072,0714)
SHOW_TICK_LABEL | Show Tick Label (0070,0278)
SHUTTER_LEFT_VERTICAL_EDGE | Shutter Left Vertical Edge (0018,1602)
SHUTTER_LOWER_HORIZONTAL_EDGE | Shutter Lower Horizontal Edge (0018,1608)
SHUTTER_OVERLAY_GROUP | Shutter Overlay Group (0018,1623)
SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE | Shutter Presentation Color CIELab Value (0018,1624)
SHUTTER_PRESENTATION_VALUE | Shutter Presentation Value (0018,1622)
SHUTTER_RIGHT_VERTICAL_EDGE | Shutter Right Vertical Edge (0018,1604)
SHUTTER_SHAPE | Shutter Shape (0018,1600)
SHUTTER_SPEED_VALUE | Shutter Speed Value (0016,0021)
SHUTTER_UPPER_HORIZONTAL_EDGE | Shutter Upper Horizontal Edge (0018,1606)
SIGNAL_DOMAIN_COLUMNS | Signal Domain Columns (0028,9003)
SIGNAL_DOMAIN_ROWS | Signal Domain Rows (0028,9235)
SIGNAL_TO_NOISE_RATIO | Signal to Noise Ratio (0022,1155)
SIGNATURE | Signature (0400,0120)
SIMPLE_FRAME_LIST | Simple Frame List (0008,1161)
SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE | Simulated Keratometric Cylinder Sequence (0046,0218)
SINGLE_COLLIMATION_WIDTH | Single Collimation Width (0018,9306)
SKIP_BEATS | Skip Beats (0018,1086)
SKIP_FRAME_RANGE_FLAG | Skip Frame Range Flag (0008,9460)
SLAB_ORIENTATION | Slab Orientation (0018,9105)
SLAB_THICKNESS | Slab Thickness (0018,9104)
SLICE_LOCATION | Slice Location (0020,1041)
SLICE_LOCATION_VECTOR | Slice Location Vector (0018,2005)
SLICE_PROGRESS_DIRECTION | Alias for tag SLICE_PROGRESSION_DIRECTION (0054,0500)
SLICE_PROGRESSION_DIRECTION | Slice Progression Direction (0054,0500)
SLICE_SENSITIVITY_FACTOR | Slice Sensitivity Factor (0054,1320)
SLICE_THICKNESS | Slice Thickness (0018,0050)
SLICE_VECTOR | Slice Vector (0054,0080)
SLIDE_IDENTIFIER_RETIRED | Slide Identifier RETIRED (0040,06FA)
SMALLEST_IMAGE_PIXEL_VALUE | Smallest Image Pixel Value (0028,0106)
SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED | Smallest Image Pixel Value in Plane RETIRED (0028,0110)
SMALLEST_PIXEL_VALUE_IN_SERIES | Smallest Pixel Value in Series (0028,0108)
SMALLEST_PIXEL_VALUE_RETIRED | Alias for tag SMALLEST_VALID_PIXEL_VALUE_RETIRED (0028,0104)
SMALLEST_VALID_PIXEL_VALUE_RETIRED | Smallest Valid Pixel Value RETIRED (0028,0104)
SMOKING_STATUS | Smoking Status (0010,21A0)
SMOOTHING_TYPE | Smoothing Type (2010,0080)
SNOUT_ID | Snout ID (300A,030F)
SNOUT_POSITION | Snout Position (300A,030D)
SNOUT_POSITION_TOLERANCE | Snout Position Tolerance (300A,004B)
SNOUT_SEQUENCE | Snout Sequence (300A,030C)
SOFT_TISSUE_FOCUS_THERMAL_INDEX | Soft Tissue-focus Thermal Index (0018,5028)
SOFT_TISSUE_SURFACE_THERMAL_INDEX | Soft Tissue-surface Thermal Index (0018,5029)
SOFT_TISSUE_THERMAL_INDEX | Soft Tissue Thermal Index (0018,5027)
SOFTCOPY_VOI_LUT_SEQUENCE | Softcopy VOI LUT Sequence (0028,3110)
SOFTWARE_VERSIONS | Software Version(s) (0018,1020)
SOP_AUTHORIZATION_COMMENT | SOP Authorization Comment (0100,0424)
SOP_AUTHORIZATION_DATE_AND_TIME | Alias for tag SOP_AUTHORIZATION_DATETIME (0100,0420)
SOP_AUTHORIZATION_DATETIME | SOP Authorization DateTime (0100,0420)
SOP_CLASS_UID | SOP Class UID (0008,0016)
SOP_CLASSES_IN_STUDY | SOP Classes in Study (0008,0062)
SOP_CLASSES_SUPPORTED | SOP Classes Supported (0008,115A)
SOP_INSTANCE_STATUS | SOP Instance Status (0100,0410)
SOP_INSTANCE_UID | SOP Instance UID (0008,0018)
SOP_INSTANCE_UID_CONCATENATION_SOURCE | Alias for tag SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE (0020,0242)
SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE | SOP Instance UID of Concatenation Source (0020,0242)
SORT_BY_CATEGORY | Sort-by Category (0072,0602)
SORTING_DIRECTION | Sorting Direction (0072,0604)
SORTING_OPERATIONS_SEQUENCE | Sorting Operations Sequence (0072,0600)
SOUND_PATH_LENGTH | Sound Path Length (0014,405A)
SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE | Sound Speed Correction Mechanism Code Sequence (0018,9832)
SOURCE_ACQUISITION_BEAM_NUMBER | Source Acquisition Beam Number (0018,9939)
SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER | Source Acquisition Protocol Element Number (0018,9938)
SOURCE_APPLICATION_ENTITY_TITLE | Source Application Entity Title (0002,0016)
SOURCE_APPLICATOR_ID | Source Applicator ID (300A,0291)
SOURCE_APPLICATOR_LENGTH | Source Applicator Length (300A,0296)
SOURCE_APPLICATOR_MANUFACTURER | Source Applicator Manufacturer (300A,0298)
SOURCE_APPLICATOR_NAME | Source Applicator Name (300A,0294)
SOURCE_APPLICATOR_NUMBER | Source Applicator Number (300A,0290)
SOURCE_APPLICATOR_STEP_SIZE | Source Applicator Step Size (300A,02A0)
SOURCE_APPLICATOR_TIP_LENGTH | Source Applicator Tip Length (300A,0274)
SOURCE_APPLICATOR_TYPE | Source Applicator Type (300A,0292)
SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS | Source Applicator Wall Nominal Thickness (300A,029C)
SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION | Source Applicator Wall Nominal Transmission (300A,029E)
SOURCE_AXIS_DISTANCE | Source-Axis Distance (300A,00B4)
SOURCE_CONCEPTUAL_VOLUME_SEQUENCE | Source Conceptual Volume Sequence (3010,0018)
SOURCE_CONCEPTUAL_VOLUME_UID | Source Conceptual Volume UID (3010,0015)
SOURCE_DESCRIPTION | Source Description (300A,021C)
SOURCE_ENCAPSULATION_NOMINAL_THICKNESS | Source Encapsulation Nominal Thickness (300A,0222)
SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION | Source Encapsulation Nominal Transmission (300A,0224)
SOURCE_END_DATE_TIME | Source End Date Time (0018,936A)
SOURCE_FRAME_OF_REFERENCE_UID | Source Frame of Reference UID (0064,0003)
SOURCE_HANGING_PROTOCOL_SEQUENCE | Source Hanging Protocol Sequence (0072,0012)
SOURCE_IDENTIFIER | Source Identifier (0034,0005)
SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE | Source Image Corneal Processed Data Sequence (0046,0244)
SOURCE_IMAGE_EVIDENCE_SEQUENCE | Source Image Evidence Sequence (0008,9154)
SOURCE_IMAGE_IDS_RETIRED | Source Image IDs RETIRED (0020,3100)
SOURCE_IMAGE_SEQUENCE | Source Image Sequence (0008,2112)
SOURCE_INSTANCE_SEQUENCE | Source Instance Sequence (0042,0013)
SOURCE_IRRADIATION_EVENT_SEQUENCE | Source Irradiation Event Sequence (0008,3011)
SOURCE_ISOTOPE_HALF_LIFE | Source Isotope Half Life (300A,0228)
SOURCE_ISOTOPE_NAME | Source Isotope Name (300A,0226)
SOURCE_MANUFACTURER | Source Manufacturer (300A,0216)
SOURCE_MODEL_ID | Source Model ID (300A,021B)
SOURCE_MOVEMENT_TYPE | Source Movement Type (300A,0288)
SOURCE_NUMBER | Source Number (300A,0212)
SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE | Source of Anterior Chamber Depth Data Code Sequence (0022,1133)
SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE | Source of Cornea Measurement Data Code Sequence (0046,0111)
SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE | Source of Corneal Size Data Code Sequence (0022,1036)
SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE | Source of Lens Thickness Data Code Sequence (0022,1132)
SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE | Source of Ophthalmic Axial Length Code Sequence (0022,1035)
SOURCE_OF_PREVIOUS_VALUES | Source of Previous Values (0400,0564)
SOURCE_OF_REFERENCE_OBJECT_DISTANCE | Alias for tag SOURCE_TO_REFERENCE_OBJECT_DISTANCE (3002,0028)
SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE | Alias for tag SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE (0022,1135)
SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE | Source of Refractive Measurements Code Sequence (0022,1135)
SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE | Source of Refractive Measurements Sequence (0022,1134)
SOURCE_ORIENTATION | Source Orientation (4010,1060)
SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE | Source Patient Group Identification Sequence (0010,0026)
SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE | Source Pixel Planes Characteristics Sequence (3006,004A)
SOURCE_POSITION | Source Position (4010,1061)
SOURCE_PRESENTATION_ADDRESS | Source Presentation Address (0002,0026)
SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER | Source Reconstruction Protocol Element Number (0018,993A)
SOURCE_ROLL_ANGLE | Source Roll Angle (300A,067A)
SOURCE_SEQUENCE | Source Sequence (300A,0210)
SOURCE_SERIAL_NUMBER | Source Serial Number (3008,0105)
SOURCE_START_DATE_TIME | Source Start Date Time (0018,9369)
SOURCE_STRENGTH | Source Strength (300A,022B)
SOURCE_STRENGTH_REFERENCE_DATE | Source Strength Reference Date (300A,022C)
SOURCE_STRENGTH_REFERENCE_TIME | Source Strength Reference Time (300A,022E)
SOURCE_STRENGTH_UNIT | Alias for tag SOURCE_STRENGTH_UNITS (300A,0229)
SOURCE_STRENGTH_UNITS | Source Strength Units (300A,0229)
SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE | Source to Applicator Mounting Position Distance (300A,0436)
SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE | Source to Beam Limiting Device Distance (300A,00BA)
SOURCE_TO_BLOCK_TRAY_DISTANCE | Source to Block Tray Distance (300A,00F6)
SOURCE_TO_COMPENSATOR_DISTANCE | Source to Compensator Distance (300A,02E2)
SOURCE_TO_COMPENSATOR_TRAY_DISTANCE | Source to Compensator Tray Distance (300A,00E6)
SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE | Source to External Contour Distance (300A,0132)
SOURCE_TO_GENERAL_ACCESSORY_DISTANCE | Source to General Accessory Distance (300A,0425)
SOURCE_TO_PATIENT_SURFACE_DISTANCE | Source to Patient Surface Distance (300A,0634)
SOURCE_TO_REFERENCE_OBJECT_DISTANCE | Source to Reference Object Distance (3002,0028)
SOURCE_TO_SURFACE_DISTANCE | Source to Surface Distance (300A,0130)
SOURCE_TO_WEDGE_TRAY_DISTANCE | Source to Wedge Tray Distance (300A,00DA)
SOURCE_TYPE | Source Type (300A,0214)
SOURCE_WAVEFORM_SEQUENCE | Source Waveform Sequence (003A,020A)
SPACING_BETWEEN_SLICES | Spacing Between Slices (0018,0088)
SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES | Spatial Frequency Response Column Names (0016,000C)
SPATIAL_FREQUENCY_RESPONSE_COLUMNS | Spatial Frequency Response Columns (0016,000B)
SPATIAL_FREQUENCY_RESPONSE_ROWS | Spatial Frequency Response Rows (0016,000A)
SPATIAL_FREQUENCY_RESPONSE_VALUES | Spatial Frequency Response Values (0016,000D)
SPATIAL_LOCATIONS_PRESERVED | Spatial Locations Preserved (0028,135A)
SPATIAL_PRE_SATURATION | Spatial Pre-saturation (0018,9027)
SPATIAL_RESOLUTION | Spatial Resolution (0018,1050)
SPATIAL_TRANSFORM_OF_DOSE | Spatial Transform of Dose (3004,0005)
SPECIAL_NEEDS | Special Needs (0038,0050)
SPECIFIC_ABSORPTION_RATE_DEFINITION | Specific Absorption Rate Definition (0018,9179)
SPECIFIC_ABSORPTION_RATE_SEQUENCE | Specific Absorption Rate Sequence (0018,9239)
SPECIFIC_ABSORPTION_RATE_VALUE | Specific Absorption Rate Value (0018,9181)
SPECIFIC_CHARACTER_SET | Specific Character Set (0008,0005)
SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE | Specific Character Set of File-set Descriptor File (0004,1142)
SPECIFICATION_SELECTION_GUIDANCE | Specification Selection Guidance (0082,0033)
SPECIFIED_CHANNEL_TOTAL_TIME | Specified Channel Total Time (3008,0132)
SPECIFIED_METERSET | Specified Meterset (3008,0042)
SPECIFIED_NUMBER_OF_PULSES | Specified Number of Pulses (3008,0136)
SPECIFIED_PRIMARY_METERSET | Specified Primary Meterset (3008,0032)
SPECIFIED_PULSE_REPETITION_INTERVAL | Specified Pulse Repetition Interval (3008,013A)
SPECIFIED_SECONDARY_METERSET | Specified Secondary Meterset (3008,0033)
SPECIFIED_TREATMENT_TIME | Specified Treatment Time (3008,003A)
SPECIMEN_ACCESSION_NUMBER_RETIRED | Specimen Accession Number RETIRED (0040,050A)
SPECIMEN_DESCRIPTION_SEQUENCE | Specimen Description Sequence (0040,0560)
SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED | Specimen Description Sequence (Trial) RETIRED (0040,0552)
SPECIMEN_DESCRIPTION_TRIAL_RETIRED | Specimen Description (Trial) RETIRED (0040,0553)
SPECIMEN_DETAILED_DESCRIPTION | Specimen Detailed Description (0040,0602)
SPECIMEN_IDENTIFIER | Specimen Identifier (0040,0551)
SPECIMEN_LABEL_IN_IMAGE | Specimen Label in Image (0048,0010)
SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE | Specimen Localization Content Item Sequence (0040,0620)
SPECIMEN_PREPARATION_SEQUENCE | Specimen Preparation Sequence (0040,0610)
SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE | Specimen Preparation Step Content Item Sequence (0040,0612)
SPECIMEN_REFERENCE_SEQUENCE | Specimen Reference Sequence (0048,0110)
SPECIMEN_SEQUENCE_RETIRED | Specimen Sequence RETIRED (0040,0550)
SPECIMEN_SHORT_DESCRIPTION | Specimen Short Description (0040,0600)
SPECIMEN_TYPE_CODE_SEQUENCE | Specimen Type Code Sequence (0040,059A)
SPECIMEN_UID | Specimen UID (0040,0554)
SPECTRAL_SENSITIVITY | Spectral Sensitivity (0016,0017)
SPECTRAL_WIDTH | Spectral Width (0018,9052)
SPECTRALLY_SELECTED_EXCITATION | Spectrally Selected Excitation (0018,9026)
SPECTRALLY_SELECTED_SUPPRESSION | Spectrally Selected Suppression (0018,9025)
SPECTROSCOPY_ACQUISITION_DATA_COLUMNS | Spectroscopy Acquisition Data Columns (0018,9127)
SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS | Spectroscopy Acquisition Out-of-plane Phase Steps (0018,9159)
SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS | Alias for tag SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS (0018,9159)
SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS | Spectroscopy Acquisition Phase Columns (0018,9234)
SPECTROSCOPY_ACQUISITION_PHASE_ROWS | Spectroscopy Acquisition Phase Rows (0018,9095)
SPECTROSCOPY_DATA | Spectroscopy Data (5600,0020)
SPECULAR_REFLECTION_INTENSITY | Specular Reflection Intensity (0070,1705)
SPHERE_POWER | Sphere Power (0046,0146)
SPHERICAL_LENS_POWER | Spherical Lens Power (0022,0007)
SPIRAL_PITCH_FACTOR | Spiral Pitch Factor (0018,9311)
SPOILING | Spoiling (0018,9016)
STACK_ID | Stack ID (0020,9056)
STAGE_CODE_SEQUENCE | Stage Code Sequence (0040,000A)
STAGE_NAME | Stage Name (0008,2120)
STAGE_NUMBER | Stage Number (0008,2122)
STANDARD_OUTPUT_SENSITIVITY | Standard Output Sensitivity (0016,001B)
START_ACQUISITION_DATETIME | Start Acquisition DateTime (0018,9516)
START_ANGLE | Start Angle (0054,0200)
START_CARDIAC_TRIGGER_COUNT_THRESHOLD | Start Cardiac Trigger Count Threshold (0018,9717)
START_CUMULATIVE_METERSET | Start Cumulative Meterset (3002,0106)
START_CUMULATIVE_METERSET_WEIGHT | Start Cumulative Meterset Weight (300C,0008)
START_CUMULATIVE_TIME_WEIGHT | Start Cumulative Time Weight (0074,1407)
START_DENSITY_THRESHOLD | Start Density Threshold (0018,9715)
START_METERSET | Start Meterset (3008,0078)
START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD | Start Relative Density Difference Threshold (0018,9716)
START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD | Start Respiratory Trigger Count Threshold (0018,9718)
START_TRIM | Start Trim (0008,2142)
STARTING_METERSET_VALUE_KNOWN_FLAG | Starting Meterset Value Known Flag (300A,0723)
STARTING_RESPIRATORY_AMPLITUDE | Starting Respiratory Amplitude (0020,9246)
STARTING_RESPIRATORY_PHASE | Starting Respiratory Phase (0020,9247)
STATION_AE_TITLE | Station AE Title (0008,0055)
STATION_NAME | Station Name (0008,1010)
STATUS | Status (0000,0900)
STEADY_STATE_PULSE_SEQUENCE | Steady State Pulse Sequence (0018,9017)
STEEP_CORNEAL_AXIS_SEQUENCE | Steep Corneal Axis Sequence (0046,0112)
STEEP_KERATOMETRIC_AXIS_SEQUENCE | Steep Keratometric Axis Sequence (0046,0074)
STEERING_ANGLE | Steering Angle (0018,6036)
STEREO_BASELINE_ANGLE | Stereo Baseline Angle (0022,0010)
STEREO_BASELINE_DISPLACEMENT | Stereo Baseline Displacement (0022,0011)
STEREO_HORIZONTAL_PIXEL_OFFSET | Stereo Horizontal Pixel Offset (0022,0012)
STEREO_PAIRS_PRESENT | Stereo Pairs Present (0022,0028)
STEREO_PAIRS_SEQUENCE | Stereo Pairs Sequence (0022,0020)
STEREO_ROTATION | Stereo Rotation (0022,0014)
STEREO_VERTICAL_PIXEL_OFFSET | Stereo Vertical Pixel Offset (0022,0013)
STIMULI_RETESTING_QUANTITY | Stimuli Retesting Quantity (0024,0042)
STIMULUS_AREA | Stimulus Area (0024,0025)
STIMULUS_COLOR_CODE_SEQUENCE | Stimulus Color Code Sequence (0024,0021)
STIMULUS_PRESENTATION_TIME | Stimulus Presentation Time (0024,0028)
STIMULUS_RESULTS | Stimulus Results (0024,0093)
STOP_CUMULATIVE_METERSET | Stop Cumulative Meterset (3002,0107)
STOP_TRIM | Stop Trim (0008,2143)
STORAGE_MEDIA_FILE_SET_ID | Storage Media File-set ID (0088,0130)
STORAGE_MEDIA_FILE_SET_UID | Storage Media File-set UID (0088,0140)
STORAGE_PROTOCOL_ELEMENT_SEQUENCE | Storage Protocol Element Sequence (0018,9936)
STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE | Storage Protocol Element Specification Sequence (0018,9935)
STORAGE_URL | Storage URL (0040,4073)
STORED_INSTANCE_BASE_URI | Stored Instance Base URI (0008,0407)
STORED_INSTANCE_TRANSFER_SYNTAX_UID | Stored Instance Transfer Syntax UID (0008,040E)
STORED_VALUE_COLOR_RANGE_SEQUENCE | Stored Value Color Range Sequence (0028,1230)
STOW_RS_STORAGE_SEQUENCE | STOW-RS Storage Sequence (0040,4072)
STRAIN_ADDITIONAL_INFORMATION | Strain Additional Information (0010,0218)
STRAIN_CODE_SEQUENCE | Strain Code Sequence (0010,0219)
STRAIN_DESCRIPTION | Strain Description (0010,0212)
STRAIN_NOMENCLATURE | Strain Nomenclature (0010,0213)
STRAIN_SOURCE | Strain Source (0010,0217)
STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE | Strain Source Registry Code Sequence (0010,0215)
STRAIN_STOCK_NUMBER | Strain Stock Number (0010,0214)
STRAIN_STOCK_SEQUENCE | Strain Stock Sequence (0010,0216)
STRUCTURE_SET_DATE | Structure Set Date (3006,0008)
STRUCTURE_SET_DESCRIPTION | Structure Set Description (3006,0006)
STRUCTURE_SET_LABEL | Structure Set Label (3006,0002)
STRUCTURE_SET_NAME | Structure Set Name (3006,0004)
STRUCTURE_SET_ROI_SEQUENCE | Structure Set ROI Sequence (3006,0020)
STRUCTURE_SET_TIME | Structure Set Time (3006,0009)
STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE | Structured Constraint Observation Sequence (0082,000C)
STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE | Structured Display Background CIELab Value (0072,0420)
STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE | Structured Display Image Box Sequence (0072,0422)
STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE | Structured Display Text Box Sequence (0072,0424)
STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE | Studies Containing Other Referenced Instances Sequence (0008,1200)
STUDY_ACCESS_END_POINTS_SEQUENCE | Study Access End Points Sequence (0008,0421)
STUDY_ARRIVAL_DATE_RETIRED | Study Arrival Date RETIRED (0032,1040)
STUDY_ARRIVAL_TIME_RETIRED | Study Arrival Time RETIRED (0032,1041)
STUDY_COMMENTS_RETIRED | Study Comments RETIRED (0032,4000)
STUDY_COMPLETION_DATE_RETIRED | Study Completion Date RETIRED (0032,1050)
STUDY_COMPLETION_TIME_RETIRED | Study Completion Time RETIRED (0032,1051)
STUDY_COMPONENT_STATUS_ID_RETIRED | Study Component Status ID RETIRED (0032,1055)
STUDY_DATE | Study Date (0008,0020)
STUDY_DESCRIPTION | Study Description (0008,1030)
STUDY_ID | Study ID (0020,0010)
STUDY_ID_ISSUER_RETIRED | Study ID Issuer RETIRED (0032,0012)
STUDY_INSTANCE_UID | Study Instance UID (0020,000D)
STUDY_PRIORITY_ID_RETIRED | Study Priority ID RETIRED (0032,000C)
STUDY_READ_DATE_RETIRED | Study Read Date RETIRED (0032,0034)
STUDY_READ_TIME_RETIRED | Study Read Time RETIRED (0032,0035)
STUDY_STATUS_ID_RETIRED | Study Status ID RETIRED (0032,000A)
STUDY_TIME | Study Time (0008,0030)
STUDY_UPDATE_DATETIME | Study Update DateTime (0008,041F)
STUDY_VERIFIED_DATE_RETIRED | Study Verified Date RETIRED (0032,0032)
STUDY_VERIFIED_TIME_RETIRED | Study Verified Time RETIRED (0032,0033)
SUBJECT_AREA | Subject Area (0016,002A)
SUBJECT_DISTANCE | Subject Distance (0016,0026)
SUBJECT_DISTANCE_RANGE | Subject Distance Range (0016,004C)
SUBJECT_LOCATION | Subject Location (0016,0037)
SUBJECT_RELATIVE_POSITION_IN_IMAGE | Subject Relative Position in Image (0010,0028)
SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE | Subjective Refraction Left Eye Sequence (0046,0098)
SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE | Subjective Refraction Right Eye Sequence (0046,0097)
SUBSCRIPTION_LIST_STATUS | Subscription List Status (0074,1244)
SUBSTANCE_ADMINISTRATION_APPROVAL | Substance Administration Approval (0044,0002)
SUBSTANCE_ADMINISTRATION_DATETIME | Substance Administration DateTime (0044,0010)
SUBSTANCE_ADMINISTRATION_DEVICE_ID | Substance Administration Device ID (0044,0012)
SUBSTANCE_ADMINISTRATION_NOTES | Substance Administration Notes (0044,0011)
SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE | Substance Administration Parameter Sequence (0044,0019)
SUBTASK_WORKITEM_CODE_SEQUENCE | Subtask Workitem Code Sequence (3002,011B)
SUBTRACTION_ITEM_ID | Subtraction Item ID (0028,9416)
SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE | Summarized Filter Lookup Table Sequence (003A,0320)
SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE | Supported Image Display Formats Sequence (2000,00A8)
SURFACE_ASYMMETRY_INDEX | Surface Asymmetry Index (0046,0232)
SURFACE_COMMENTS | Surface Comments (0066,0004)
SURFACE_COUNT | Surface Count (0066,002A)
SURFACE_ENTRY_POINT | Surface Entry Point (300A,012E)
SURFACE_MESH_PRIMITIVES_SEQUENCE | Surface Mesh Primitives Sequence (0066,0013)
SURFACE_MESH_Z_PIXEL_OFFSET | Surface Mesh Z-Pixel Offset (0022,1658)
SURFACE_MODEL_DESCRIPTION_SEQUENCE | Surface Model Description Sequence (0068,6360)
SURFACE_MODEL_LABEL | Surface Model Label (0068,6380)
SURFACE_MODEL_SCALING_FACTOR | Surface Model Scaling Factor (0068,6390)
SURFACE_NUMBER | Surface Number (0066,0003)
SURFACE_POINT_COLOR_CIELAB_VALUE_DATA | Surface Point Color CIELab Value Data (0080,0007)
SURFACE_POINT_PRESENTATION_VALUE_DATA | Surface Point Presentation Value Data (0080,0006)
SURFACE_POINTS_NORMALS_SEQUENCE | Surface Points Normals Sequence (0066,0012)
SURFACE_POINTS_SEQUENCE | Surface Points Sequence (0066,0011)
SURFACE_PROCESSING | Surface Processing (0066,0009)
SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE | Surface Processing Algorithm Identification Sequence (0066,0035)
SURFACE_PROCESSING_DESCRIPTION | Surface Processing Description (0066,000B)
SURFACE_PROCESSING_RATIO | Surface Processing Ratio (0066,000A)
SURFACE_REGULARITY_INDEX | Surface Regularity Index (0046,0230)
SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE | Surface Scan Acquisition Type Code Sequence (0080,0001)
SURFACE_SCAN_MODE_CODE_SEQUENCE | Surface Scan Mode Code Sequence (0080,0002)
SURFACE_SEQUENCE | Surface Sequence (0066,0002)
SURGICAL_TECHNIQUE | Surgical Technique (0076,0030)
SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE | Surgically Induced Astigmatism Sequence (0022,1045)
SUV_TYPE | SUV Type (0054,1006)
SWITCHING_PHASE_NOMINAL_DURATION | Switching Phase Nominal Duration (0018,936C)
SWITCHING_PHASE_NUMBER | Switching Phase Number (0018,936B)
SWITCHING_PHASE_TRANSITION_DURATION | Switching Phase Transition Duration (0018,936D)
SWIVEL_RANGE | Swivel Range (0070,1A06)
SYNCHRONIZATION_CHANNEL | Synchronization Channel (0018,106C)
SYNCHRONIZATION_FRAME_OF_REFERENCE_UID | Synchronization Frame of Reference UID (0020,0200)
SYNCHRONIZATION_TRIGGER | Synchronization Trigger (0018,106A)
SYNCHRONIZED_IMAGE_BOX_LIST | Synchronized Image Box List (0072,0432)
SYNCHRONIZED_SCROLLING_SEQUENCE | Synchronized Scrolling Sequence (0072,0210)
SYRINGE_COUNTS | Syringe Counts (0018,1045)
SYSTEM_STATUS | System Status (0028,7006)
SYSTEM_STATUS_COMMENT | System Status Comment (0028,7007)
T2_PREPARATION | T2 Preparation (0018,9021)
TABLE_ANGLE | Table Angle (0018,1138)
TABLE_COLUMN_DEFINITION_SEQUENCE | Table Column Definition Sequence (0040,A807)
TABLE_COLUMN_NUMBER | Table Column Number (0040,A805)
TABLE_CRADLE_TILT_ANGLE | Table Cradle Tilt Angle (0018,9471)
TABLE_FEED_PER_ROTATION | Table Feed per Rotation (0018,9310)
TABLE_FRAME_OF_REFERENCE_UID | Table Frame of Reference UID (0020,9313)
TABLE_HEAD_TILT_ANGLE | Table Head Tilt Angle (0018,9470)
TABLE_HEIGHT | Table Height (0018,1130)
TABLE_HORIZONTAL_ROTATION_ANGLE | Table Horizontal Rotation Angle (0018,9469)
TABLE_LATERAL_INCREMENT | Table Lateral Increment (0018,1136)
TABLE_LONGITUDINAL_INCREMENT | Table Longitudinal Increment (0018,1137)
TABLE_MOTION | Table Motion (0018,1134)
TABLE_OF_PARAMETER_VALUES | Table of Parameter Values (0018,605A)
TABLE_OF_PIXEL_VALUES | Table of Pixel Values (0018,6058)
TABLE_OF_X_BREAK_POINTS | Table of X Break Points (0018,6052)
TABLE_OF_Y_BREAK_POINTS | Table of Y Break Points (0018,6054)
TABLE_POSITION | Table Position (0018,9327)
TABLE_POSITION_SEQUENCE | Table Position Sequence (0018,9406)
TABLE_ROW_DEFINITION_SEQUENCE | Table Row Definition Sequence (0040,A806)
TABLE_ROW_NUMBER | Table Row Number (0040,A804)
TABLE_SPEED | Table Speed (0018,9309)
TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE | Table Top Eccentric Adjusted Angle (0074,102B)
TABLE_TOP_ECCENTRIC_ANGLE | Table Top Eccentric Angle (300A,0125)
TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE | Table Top Eccentric Angle Tolerance (300A,004E)
TABLE_TOP_ECCENTRIC_AXIS_DISTANCE | Table Top Eccentric Axis Distance (300A,0124)
TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION | Table Top Eccentric Rotation Direction (300A,0126)
TABLE_TOP_LATERAL_ADJUSTED_POSITION | Table Top Lateral Adjusted Position (0074,1028)
TABLE_TOP_LATERAL_POSITION | Table Top Lateral Position (300A,012A)
TABLE_TOP_LATERAL_POSITION_TOLERANCE | Table Top Lateral Position Tolerance (300A,0053)
TABLE_TOP_LATERAL_SETUP_DISPLACEMENT | Table Top Lateral Setup Displacement (300A,01D6)
TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION | Table Top Longitudinal Adjusted Position (0074,1027)
TABLE_TOP_LONGITUDINAL_POSITION | Table Top Longitudinal Position (300A,0129)
TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE | Table Top Longitudinal Position Tolerance (300A,0052)
TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT | Table Top Longitudinal Setup Displacement (300A,01D4)
TABLE_TOP_PITCH_ADJUSTED_ANGLE | Table Top Pitch Adjusted Angle (0074,102C)
TABLE_TOP_PITCH_ANGLE | Table Top Pitch Angle (300A,0140)
TABLE_TOP_PITCH_ANGLE_TOLERANCE | Table Top Pitch Angle Tolerance (300A,004F)
TABLE_TOP_PITCH_ROTATION_DIRECTION | Table Top Pitch Rotation Direction (300A,0142)
TABLE_TOP_ROLL_ADJUSTED_ANGLE | Table Top Roll Adjusted Angle (0074,102D)
TABLE_TOP_ROLL_ANGLE | Table Top Roll Angle (300A,0144)
TABLE_TOP_ROLL_ANGLE_TOLERANCE | Table Top Roll Angle Tolerance (300A,0050)
TABLE_TOP_ROLL_ROTATION_DIRECTION | Table Top Roll Rotation Direction (300A,0146)
TABLE_TOP_VERTICAL_ADJUSTED_POSITION | Table Top Vertical Adjusted Position (0074,1026)
TABLE_TOP_VERTICAL_POSITION | Table Top Vertical Position (300A,0128)
TABLE_TOP_VERTICAL_POSITION_TOLERANCE | Table Top Vertical Position Tolerance (300A,0051)
TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT | Table Top Vertical Setup Displacement (300A,01D2)
TABLE_TRAVERSE | Table Traverse (0018,1131)
TABLE_TYPE | Table Type (0018,113A)
TABLE_VERTICAL_INCREMENT | Table Vertical Increment (0018,1135)
TABLE_X_POSITION_TO_ISOCENTER | Table X Position to Isocenter (0018,9466)
TABLE_Y_POSITION_TO_ISOCENTER | Table Y Position to Isocenter (0018,9467)
TABLE_Z_POSITION_TO_ISOCENTER | Table Z Position to Isocenter (0018,9468)
TABULATED_VALUES_SEQUENCE | Tabulated Values Sequence (0040,A801)
TAG_2D_DEGREE_OF_FREEDOM_AXIS | 2D Degree of Freedom Axis (0068,64F0)
TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE | 2D Degree of Freedom Sequence (0068,6470)
TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES | 2D Implant Template Group Member Matching Axes (0078,00A0)
TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT | 2D Implant Template Group Member Matching Point (0078,0090)
TAG_2D_LINE_COORDINATES | 2D Line Coordinates (0068,65B0)
TAG_2D_LINE_COORDINATES_SEQUENCE | 2D Line Coordinates Sequence (0068,65A0)
TAG_2D_MATING_AXES | 2D Mating Axes (0068,6460)
TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE | 2D Mating Feature Coordinates Sequence (0068,6430)
TAG_2D_MATING_POINT | 2D Mating Point (0068,6450)
TAG_2D_PLANE_COORDINATES_SEQUENCE | 2D Plane Coordinates Sequence (0068,65E0)
TAG_2D_PLANE_INTERSECTION | 2D Plane Intersection (0068,65F0)
TAG_2D_POINT_COORDINATES | 2D Point Coordinates (0068,6560)
TAG_2D_POINT_COORDINATES_SEQUENCE | 2D Point Coordinates Sequence (0068,6550)
TAG_3D_DEGREE_OF_FREEDOM_AXIS | 3D Degree of Freedom Axis (0068,6490)
TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES | 3D Implant Template Group Member Matching Axes (0078,0060)
TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT | 3D Implant Template Group Member Matching Point (0078,0050)
TAG_3D_LINE_COORDINATES | 3D Line Coordinates (0068,65D0)
TAG_3D_MATING_AXES | 3D Mating Axes (0068,64D0)
TAG_3D_MATING_POINT | 3D Mating Point (0068,64C0)
TAG_3D_PLANE_NORMAL | 3D Plane Normal (0068,6620)
TAG_3D_PLANE_ORIGIN | 3D Plane Origin (0068,6610)
TAG_3D_POINT_COORDINATES | 3D Point Coordinates (0068,6590)
TAG_3D_RENDERING_TYPE | 3D Rendering Type (0072,0520)
TAG_ANGLE_FIRST_AXIS | Tag Angle First Axis (0018,9019)
TAG_ANGLE_SECOND_AXIS | Tag Angle Second Axis (0018,9219)
TAG_SPACING_FIRST_DIMENSION | Tag Spacing First Dimension (0018,9030)
TAG_SPACING_SECOND_DIMENSION | Tag Spacing Second Dimension (0018,9218)
TAG_THICKNESS | Tag Thickness (0018,9035)
TAGGING | Tagging (0018,9028)
TAGGING_DELAY | Tagging Delay (0018,9184)
TANGENTIAL_POWER | Tangential Power (0046,0250)
TARGET_EXPOSURE_INDEX | Target Exposure Index (0018,1412)
TARGET_FRAME_OF_REFERENCE_UID | Target Frame of Reference UID (0018,991E)
TARGET_LABEL | Target Label (0018,2045)
TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE | Target Luminance Characteristics Sequence (0028,7008)
TARGET_MAXIMUM_DOSE | Target Maximum Dose (300A,0027)
TARGET_MAXIMUM_LUMINANCE | Target Maximum Luminance (0028,701E)
TARGET_MINIMUM_DOSE | Target Minimum Dose (300A,0025)
TARGET_MINIMUM_LUMINANCE | Target Minimum Luminance (0028,701D)
TARGET_POSITION_REFERENCE_INDICATOR | Target Position Reference Indicator (0020,103F)
TARGET_PRESCIPTION_DOSE | Alias for tag TARGET_PRESCRIPTION_DOSE (300A,0026)
TARGET_PRESCRIPTION_DOSE | Target Prescription Dose (300A,0026)
TARGET_REFRACTION | Target Refraction (0022,1037)
TARGET_UID | Target UID (0018,2042)
TARGET_UNDERDOSE_VOLUME_FRACTION | Target Underdose Volume Fraction (300A,0028)
TDR_TYPE | TDR Type (4010,1027)
TELEPHONE_NUMBER_TRIAL_RETIRED | Telephone Number (Trial) RETIRED (0040,A354)
TELETHERAPY_RADIATION_TYPE | Teletherapy Radiation Type (3010,0047)
TEMPERATURE | Temperature (0016,0030)
TEMPLATE_EXTENSION_CREATOR_UID_RETIRED | Template Extension Creator UID RETIRED (0040,DB0D)
TEMPLATE_EXTENSION_FLAG_RETIRED | Template Extension Flag RETIRED (0040,DB0B)
TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED | Template Extension Organization UID RETIRED (0040,DB0C)
TEMPLATE_IDENTIFIER | Template Identifier (0040,DB00)
TEMPLATE_LOCAL_VERSION_RETIRED | Template Local Version RETIRED (0040,DB07)
TEMPLATE_NAME | Template Name (300A,0244)
TEMPLATE_NUMBER | Template Number (300A,0240)
TEMPLATE_TYPE | Template Type (300A,0242)
TEMPLATE_VERSION_RETIRED | Template Version RETIRED (0040,DB06)
TEMPORAL_POSITION_IDENTIFIER | Temporal Position Identifier (0020,0100)
TEMPORAL_POSITION_INDEX | Temporal Position Index (0020,9128)
TEMPORAL_POSITION_SEQUENCE | Temporal Position Sequence (0020,9310)
TEMPORAL_POSITION_TIME_OFFSET | Temporal Position Time Offset (0020,930D)
TEMPORAL_RANGE_TYPE | Temporal Range Type (0040,A130)
TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR | Temporal Relationship Interval Anchor (3010,004F)
TEMPORAL_RESOLUTION | Temporal Resolution (0020,0110)
TERMINAL_TYPE_RETIRED | Terminal Type RETIRED (0000,4010)
TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD | Termination Cardiac Trigger Count Threshold (0018,9723)
TERMINATION_COUNTS_THRESHOLD | Termination Counts Threshold (0018,9719)
TERMINATION_DENSITY_THRESHOLD | Termination Density Threshold (0018,9720)
TERMINATION_RELATIVE_DENSITY_THRESHOLD | Termination Relative Density Threshold (0018,9721)
TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD | Termination Respiratory Trigger Count Threshold (0018,9724)
TERMINATION_TIME_THRESHOLD | Termination Time Threshold (0018,9722)
TEST_IMAGE_VALIDATION | Test Image Validation (0028,702B)
TEST_PATTERN_CODE_SEQUENCE | Test Pattern Code Sequence (0028,702C)
TEST_POINT_NORMALS_DATA_FLAG | Test Point Normals Data Flag (0024,0057)
TEST_POINT_NORMALS_SEQUENCE | Test Point Normals Sequence (0024,0058)
TEST_RESULT | Test Result (0028,7029)
TEST_RESULT_COMMENT | Test Result Comment (0028,702A)
TEXT_COLOR_CIELAB_VALUE | Text Color CIELab Value (0070,0241)
TEXT_COMMENTS_RETIRED | Text Comments RETIRED (4000,4000)
TEXT_FORMAT_ID_RETIRED | Text Format ID RETIRED (0000,5130)
TEXT_OBJECT_SEQUENCE | Text Object Sequence (0070,0008)
TEXT_STRING | Text String (2030,0020)
TEXT_STYLE_SEQUENCE | Text Style Sequence (0070,0231)
TEXT_VALUE | Text Value (0040,A160)
TEXTURE_LABEL | Texture Label (0080,0009)
THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE | Therapeutic Role Category Code Sequence (3010,0064)
THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE | Therapeutic Role Type Code Sequence (3010,0065)
THERAPY_DESCRIPTION_RETIRED | Therapy Description RETIRED (0018,0039)
THERAPY_TYPE_RETIRED | Therapy Type RETIRED (0018,0037)
THREAT_CATEGORY | Threat Category (4010,1012)
THREAT_CATEGORY_DESCRIPTION | Threat Category Description (4010,1013)
THREAT_DETECTION_ALGORITHM_AND_VERSION | Threat Detection Algorithm and Version (4010,1029)
THREAT_ROI_BASE | Threat ROI Base (4010,1004)
THREAT_ROI_BITMAP | Threat ROI Bitmap (4010,1006)
THREAT_ROI_EXTENTS | Threat ROI Extents (4010,1005)
THREAT_ROI_VOXEL_SEQUENCE | Threat ROI Voxel Sequence (4010,1001)
THREAT_SEQUENCE | Threat Sequence (4010,1011)
THRESHOLD_DENSITY_RETIRED | Threshold Density RETIRED (2040,0100)
THRESHOLD_SEQUENCE | Threshold Sequence (0070,1B11)
THRESHOLD_TYPE | Threshold Type (0070,1B13)
THRESHOLD_VALUE | Threshold Value (0070,1B14)
THRESHOLD_VALUE_SEQUENCE | Threshold Value Sequence (0070,1B12)
TICK_ALIGNMENT | Tick Alignment (0070,0274)
TICK_LABEL | Tick Label (0070,0289)
TICK_LABEL_ALIGNMENT | Tick Label Alignment (0070,0279)
TICK_POSITION | Tick Position (0070,0288)
TID_OFFSET | TID Offset (0028,6120)
TIME | Time (0040,A122)
TIME_BASED_IMAGE_SETS_SEQUENCE | Time Based Image Sets Sequence (0072,0030)
TIME_DISTRIBUTION_PROTOCOL | Time Distribution Protocol (0018,1802)
TIME_DOMAIN_FILTERING | Time Domain Filtering (0018,9065)
TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED | Time of Document Creation or Verbal Transaction (Trial) RETIRED (0040,A112)
TIME_OF_FLIGHT_CONTRAST | Time of Flight Contrast (0018,9015)
TIME_OF_FLIGHT_INFORMATION_USED | Time of Flight Information Used (0018,9755)
TIME_OF_FRAME_GROUP_SEQUENCE | Time of Frame Group Sequence (0034,000D)
TIME_OF_GAIN_CALIBRATION | Time of Gain Calibration (0014,3077)
TIME_OF_LAST_CALIBRATION | Time of Last Calibration (0018,1201)
TIME_OF_LAST_DETECTOR_CALIBRATION | Time of Last Detector Calibration (0018,700E)
TIME_OF_SECONDARY_CAPTURE | Time of Secondary Capture (0018,1014)
TIME_RANGE | Time Range (0008,1163)
TIME_SERIES_BLENDING | Time Series Blending (0070,1B07)
TIME_SLICE_VECTOR | Time Slice Vector (0054,0100)
TIME_SLOT_INFORMATION_SEQUENCE | Time Slot Information Sequence (0054,0072)
TIME_SLOT_NUMBER_RETIRED | Time Slot Number RETIRED (0020,0017)
TIME_SLOT_TIME | Time Slot Time (0054,0073)
TIME_SLOT_VECTOR | Time Slot Vector (0054,0070)
TIME_SOURCE | Time Source (0018,1801)
TIMEZONE_OFFSET_FROM_UTC | Timezone Offset From UTC (0008,0201)
TIP_TYPE | TIP Type (4010,1039)
TISSUE_HETEROGENEITY_CORRECTION | Tissue Heterogeneity Correction (3004,0014)
TM_LINE_POSITION_X0 | TM-Line Position X0 (0018,603D)
TM_LINE_POSITION_X0_RETIRED | TM-Line Position X0 (Retired) (0018,603C)
TM_LINE_POSITION_X1 | TM-Line Position X1 (0018,6041)
TM_LINE_POSITION_X1_RETIRED | TM-Line Position X1 (Retired) (0018,6040)
TM_LINE_POSITION_Y0 | TM-Line Position Y0 (0018,603F)
TM_LINE_POSITION_Y0_RETIRED | TM-Line Position Y0 (Retired) (0018,603E)
TM_LINE_POSITION_Y1 | TM-Line Position Y1 (0018,6043)
TM_LINE_POSITION_Y1_RETIRED | TM-Line Position Y1 (Retired) (0018,6042)
TOLERANCE_TABLE_LABEL | Tolerance Table Label (300A,0043)
TOLERANCE_TABLE_NUMBER | Tolerance Table Number (300A,0042)
TOLERANCE_TABLE_SEQUENCE | Tolerance Table Sequence (300A,0040)
TOLERANCE_VALUE | Tolerance Value (300A,062C)
TOMO_ANGLE | Tomo Angle (0018,1470)
TOMO_CLASS | Tomo Class (0018,1491)
TOMO_LAYER_HEIGHT | Tomo Layer Height (0018,1460)
TOMO_TIME | Tomo Time (0018,1480)
TOMO_TYPE | Tomo Type (0018,1490)
TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE | Tomotherapeutic Control Point Sequence (3010,0098)
TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS | Tomotherapeutic Leaf Initial Closed Durations (3010,009A)
TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS | Tomotherapeutic Leaf Open Durations (3010,0099)
TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED | Top Left Hand Corner of Localizer Area RETIRED (0048,0201)
TOPIC_AUTHOR_RETIRED | Topic Author RETIRED (0088,0910)
TOPIC_KEYWORDS_RETIRED | Topic Keywords RETIRED (0088,0912)
TOPIC_SUBJECT_RETIRED | Topic Subject RETIRED (0088,0906)
TOPIC_TITLE_RETIRED | Topic Title RETIRED (0088,0904)
TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE | Toric IOL Power for Exact Emmetropia Sequence (0022,104A)
TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE | Toric IOL Power for Exact Target Refraction Sequence (0022,104B)
TORIC_IOL_POWER_SEQUENCE | Toric IOL Power Sequence (0022,1047)
TOTAL_BLOCK_TRAY_FACTOR | Total Block Tray Factor (300A,00F2)
TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS | Total Block Tray Water-Equivalent Thickness (300A,00F3)
TOTAL_COLLIMATION_WIDTH | Total Collimation Width (0018,9307)
TOTAL_COMPENSATOR_TRAY_FACTOR | Total Compensator Tray Factor (300A,00E2)
TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS | Total Compensator Tray Water-Equivalent Thickness (300A,02E3)
TOTAL_GAIN_RETIRED | Total Gain RETIRED (0018,5040)
TOTAL_NUMBER_OF_EXPOSURES_RETIRED | Total Number of Exposures RETIRED (0040,0301)
TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED | Total Number of Pieces of Media Created (2200,000B)
TOTAL_NUMBER_OF_STUDY_RECORDS | Total Number of Study Records (0008,0428)
TOTAL_PIXEL_MATRIX_COLUMNS | Total Pixel Matrix Columns (0048,0006)
TOTAL_PIXEL_MATRIX_FOCAL_PLANES | Total Pixel Matrix Focal Planes (0048,0303)
TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE | Total Pixel Matrix Origin Sequence (0048,0008)
TOTAL_PIXEL_MATRIX_ROWS | Total Pixel Matrix Rows (0048,0007)
TOTAL_PRESCRIPTION_DOSE | Total Prescription Dose (300C,0115)
TOTAL_PROCESSING_TIME | Total Processing Time (4010,1069)
TOTAL_REFERENCE_AIR_KERMA | Total Reference Air Kerma (300A,0250)
TOTAL_TIME_OF_FLUOROSCOPY_RETIRED | Total Time of Fluoroscopy RETIRED (0040,0300)
TOTAL_TIME_RETIRED | Total Time RETIRED (5000,200A)
TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS | Total Wedge Tray Water-Equivalent Thickness (300A,00D7)
TRACK_POINT_INDEX_LIST | Track Point Index List (0066,0129)
TRACK_SEQUENCE | Track Sequence (0066,0102)
TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE | Track Set Anatomical Type Code Sequence (0066,0108)
TRACK_SET_DESCRIPTION | Track Set Description (0066,0107)
TRACK_SET_LABEL | Track Set Label (0066,0106)
TRACK_SET_NUMBER | Track Set Number (0066,0105)
TRACK_SET_SEQUENCE | Track Set Sequence (0066,0101)
TRACK_SET_STATISTICS_SEQUENCE | Track Set Statistics Sequence (0066,0124)
TRACK_STATISTICS_SEQUENCE | Track Statistics Sequence (0066,0130)
TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE | Tracking Algorithm Identification Sequence (0066,0104)
TRACKING_ID | Tracking ID (0062,0020)
TRACKING_UID | Tracking UID (0062,0021)
TRANSACTION_STATUS | Transaction Status (0008,0417)
TRANSACTION_STATUS_COMMENT | Transaction Status Comment (0008,0418)
TRANSACTION_UID | Transaction UID (0008,1195)
TRANSDUCER_APPLICATION_CODE_SEQUENCE | Transducer Application Code Sequence (0018,980F)
TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE | Transducer Beam Steering Code Sequence (0018,980E)
TRANSDUCER_DATA | Transducer Data (0018,5010)
TRANSDUCER_FREQUENCY | Transducer Frequency (0018,6030)
TRANSDUCER_GEOMETRY_CODE_SEQUENCE | Transducer Geometry Code Sequence (0018,980D)
TRANSDUCER_IDENTIFICATION_SEQUENCE | Transducer Identification Sequence (0018,5011)
TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED | Transducer Orientation Modifier Sequence RETIRED (0008,2246)
TRANSDUCER_ORIENTATION_RETIRED | Transducer Orientation RETIRED (0008,2204)
TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED | Transducer Orientation Sequence RETIRED (0008,2244)
TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED | Transducer Position Modifier Sequence RETIRED (0008,2242)
TRANSDUCER_POSITION_RETIRED | Transducer Position RETIRED (0008,2200)
TRANSDUCER_POSITION_SEQUENCE_RETIRED | Transducer Position Sequence RETIRED (0008,2240)
TRANSDUCER_RESPONSE_SEQUENCE | Transducer Response Sequence (0018,982C)
TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE | Transducer Scan Pattern Code Sequence (0018,9809)
TRANSDUCER_TECHNOLOGY_SEQUENCE | Transducer Technology Sequence (0018,9831)
TRANSDUCER_TYPE | Transducer Type (0018,6031)
TRANSFER_SYNTAX_UID | Transfer Syntax UID (0002,0010)
TRANSFER_TUBE_LENGTH | Transfer Tube Length (300A,02A4)
TRANSFER_TUBE_NUMBER | Transfer Tube Number (300A,02A2)
TRANSFORM_DESCRIPTION | Transform Description (0014,2222)
TRANSFORM_NUMBER_OF_AXES | Transform Number of Axes (0014,2224)
TRANSFORM_ORDER_OF_AXES | Transform Order of Axes (0014,2226)
TRANSFORMATION_ALGORITHM_SEQUENCE | Transformation Algorithm Sequence (0022,1513)
TRANSFORMATION_METHOD_CODE_SEQUENCE | Transformation Method Code Sequence (0022,1512)
TRANSFORMED_AXIS_UNITS | Transformed Axis Units (0014,2228)
TRANSMIT_COIL_MANUFACTURER_NAME | Transmit Coil Manufacturer Name (0018,9050)
TRANSMIT_COIL_NAME | Transmit Coil Name (0018,1251)
TRANSMIT_COIL_TYPE | Transmit Coil Type (0018,9051)
TRANSMIT_TRANSDUCER_SEQUENCE | Transmit Transducer Sequence (0014,4010)
TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE | Transmit Transducer Settings Sequence (0014,4050)
TRANSMITTER_FREQUENCY | Transmitter Frequency (0018,9098)
TRANSMITTING_COIL | Alias for tag TRANSMIT_COIL_NAME (0018,1251)
TRANSPORT_CLASSIFICATION | Transport Classification (4010,1067)
TRANSVERSE_DETECTOR_SEPARATION | Transverse Detector Separation (0018,9726)
TRANSVERSE_MASH | Transverse Mash (0054,1202)
TRAY_ACCESSORY_CODE | Tray Accessory Code (300A,0355)
TREATMENT_CONTROL_POINT_DATE | Treatment Control Point Date (3008,0024)
TREATMENT_CONTROL_POINT_TIME | Treatment Control Point Time (3008,0025)
TREATMENT_DATE | Treatment Date (3008,0250)
TREATMENT_DELIVERY_CONTINUATION_FLAG | Treatment Delivery Continuation Flag (300A,0708)
TREATMENT_DELIVERY_TYPE | Treatment Delivery Type (300A,00CE)
TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE | Treatment Device Identification Sequence (300A,063A)
TREATMENT_MACHINE_NAME | Treatment Machine Name (300A,00B2)
TREATMENT_MACHINE_SEQUENCE | Treatment Machine Sequence (300A,0206)
TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE | Treatment Machine Special Mode Code Sequence (300A,0635)
TREATMENT_POSITION_GROUP_LABEL | Treatment Position Group Label (300A,0608)
TREATMENT_POSITION_GROUP_SEQUENCE | Treatment Position Group Sequence (300A,060A)
TREATMENT_POSITION_GROUP_UID | Treatment Position Group UID (300A,0609)
TREATMENT_POSITION_INDEX | Treatment Position Index (300A,0606)
TREATMENT_POSITION_SEQUENCE | Treatment Position Sequence (300A,063F)
TREATMENT_PROTOCOLS | Treatment Protocols (300A,0009)
TREATMENT_RECORD_CONTENT_ORIGIN | Treatment Record Content Origin (300A,0709)
TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE | Treatment Session Application Setup Sequence (3008,0110)
TREATMENT_SESSION_BEAM_SEQUENCE | Treatment Session Beam Sequence (3008,0020)
TREATMENT_SESSION_ION_BEAM_SEQUENCE | Treatment Session Ion Beam Sequence (3008,0021)
TREATMENT_SESSION_UID | Treatment Session UID (300A,0700)
TREATMENT_SITE | Treatment Site (3010,0077)
TREATMENT_SITE_CODE_SEQUENCE | Treatment Site Code Sequence (3010,0078)
TREATMENT_SITE_MODIFIER_CODE_SEQUENCE | Treatment Site Modifier Code Sequence (3010,0089)
TREATMENT_SITES_RETIRED | Treatment Sites RETIRED (300A,000B)
TREATMENT_STATUS_COMMENT | Treatment Status Comment (3008,0202)
TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE | Treatment Summary Calculated Dose Reference Sequence (3008,0050)
TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE | Treatment Summary Measured Dose Reference Sequence (3008,00E0)
TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE | Alias for tag TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE (3008,00E0)
TREATMENT_TECHNIQUE_NOTES | Treatment Technique Notes (3010,007A)
TREATMENT_TERMINATION_CODE | Alias for tag Treatment Termination Code RETIRED (3008,002B)
TREATMENT_TERMINATION_CODE_RETIRED | Treatment Termination Code RETIRED (3008,002B)
TREATMENT_TERMINATION_DESCRIPTION | Treatment Termination Description (300A,0730)
TREATMENT_TERMINATION_STATUS | Treatment Termination Status (3008,002A)
TREATMENT_TIME | Treatment Time (3008,0251)
TREATMENT_TIME_LIMIT | Treatment Time Limit (300A,062E)
TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE | Treatment Tolerance Violation Attribute Sequence (300A,0733)
TREATMENT_TOLERANCE_VIOLATION_CATEGORY | Treatment Tolerance Violation Category (300A,0732)
TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE | Treatment Tolerance Violation Cause Code Sequence (300A,0762)
TREATMENT_TOLERANCE_VIOLATION_DATETIME | Treatment Tolerance Violation DateTime (300A,0736)
TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION | Treatment Tolerance Violation Description (300A,0734)
TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION | Treatment Tolerance Violation Identification (300A,0735)
TREATMENT_TOLERANCE_VIOLATION_SEQUENCE | Treatment Tolerance Violation Sequence (300A,0731)
TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE | Treatment Tolerance Violation Type Code Sequence (300A,0761)
TREATMENT_VERIFICATION_STATUS | Treatment Verification Status (3008,002C)
TRIANGLE_FAN_SEQUENCE | Triangle Fan Sequence (0066,0027)
TRIANGLE_POINT_INDEX_LIST_RETIRED | Triangle Point Index List RETIRED (0066,0023)
TRIANGLE_STRIP_SEQUENCE | Triangle Strip Sequence (0066,0026)
TRIGGER_SAMPLE_POSITION | Trigger Sample Position (0018,106E)
TRIGGER_SOURCE_OR_TYPE | Trigger Source or Type (0018,1061)
TRIGGER_TIME | Trigger Time (0018,1060)
TRIGGER_TIME_OFFSET | Trigger Time Offset (0018,1069)
TRIGGER_VECTOR | Trigger Vector (0054,0210)
TRIGGER_WINDOW | Trigger Window (0018,1094)
TRIM | Trim (2010,0140)
TUBE_ANGLE | Tube Angle (0018,9303)
TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA | Two Dimensional to Three Dimensional Map Data (0022,1531)
TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE | Two Dimensional to Three Dimensional Map Sequence (0022,1518)
TYPE_OF_DATA_RETIRED | Type of Data RETIRED (5000,0020)
TYPE_OF_DETECTOR_MOTION | Type of Detector Motion (0054,0202)
TYPE_OF_FILTERS | Type of Filters (0018,1161)
TYPE_OF_INSTANCES | Type of Instances (0040,E020)
TYPE_OF_OPTICAL_CORRECTION | Type of Optical Correction (0022,1046)
TYPE_OF_PATIENT_ID | Type of Patient ID (0010,0022)
TYPE_OF_SYNCHRONIZATION | Type of Synchronization (0072,0434)
U_VALUE_DATA | U Value Data (0080,0010)
UDI_SEQUENCE | UDI Sequence (0018,100A)
UID | UID (0040,A124)
ULTRASOUND_ACQUISITION_GEOMETRY | Ultrasound Acquisition Geometry (0020,9307)
ULTRASOUND_COLOR_DATA_PRESENT | Ultrasound Color Data Present (0028,0014)
ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE | Ultrasound Ophthalmic Axial Length Measurements Sequence (0022,1220)
ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE | Ultrasound Selected Ophthalmic Axial Length Sequence (0022,1230)
UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE | Unassigned Per-Frame Converted Attributes Sequence (0020,9171)
UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE | Unassigned Shared Converted Attributes Sequence (0020,9170)
UNDERLINED | Underlined (0070,0248)
UNFORMATTED_TEXT_VALUE | Unformatted Text Value (0070,0006)
UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE | Alias for tag PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE (0074,1008)
UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE | Alias for tag PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0074,100E)
UNIFIED_PROCEDURE_STEP_LIST_STATUS | Unified Procedure Step List Status (0074,1246)
UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE | Unified Procedure Step Performed Procedure Sequence (0074,1216)
UNIFIED_PROCEDURE_STEP_PROGRESS | Alias for tag PROCEDURE_STEP_PROGRESS (0074,1004)
UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION | Alias for tag PROCEDURE_STEP_PROGRESS_DESCRIPTION (0074,1006)
UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE | Alias for tag PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)
UNIFIED_PROCEDURE_STEP_STATE | Alias for tag PROCEDURE_STEP_STATE (0074,1000)
UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED | Uniform Resource Locator (Trial) RETIRED (0040,A992)
UNIQUE_DEVICE_IDENTIFIER | Unique Device Identifier (0018,1009)
UNITS | Units (0054,1001)
UNIVERSAL_ENTITY_ID | Universal Entity ID (0040,0032)
UNIVERSAL_ENTITY_ID_TYPE | Universal Entity ID Type (0040,0033)
UNSPECIFIED_LATERALITY_LENS_SEQUENCE | Unspecified Laterality Lens Sequence (0046,0016)
UPDATED_METADATA_SEQUENCE | Updated Metadata Sequence (0008,041E)
UPPER_CUTOFF_FREQUENCY | Upper Cutoff Frequency (0018,9830)
UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES | Upper Limit Number Of Persistent Fluoroscopy Frames (0018,11B5)
UPPER_LOWER_PIXEL_VALUES_RETIRED | Upper/Lower Pixel Values RETIRED (0018,1240)
UPS_LIST_STATUS | Alias for tag UNIFIED_PROCEDURE_STEP_LIST_STATUS (0074,1246)
UPS_PERFORMED_PROCEDURE_SEQUENCE | Alias for tag UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE (0074,1216)
UPS_PROGRESS_INFORMATION_SEQUENCE | Alias for tag UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)
URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED | Urgency or Priority Alerts (Trial) RETIRED (0040,A057)
URI_WITHIN_ENCAPSULATED_DOCUMENT | URI Within Encapsulated Document (0068,7005)
URN_CODE_VALUE | URN Code Value (0008,0120)
US_IMAGE_DESCRIPTION_SEQUENCE | US Image Description Sequence (0018,9806)
USED_FIDUCIALS_SEQUENCE | Used Fiducials Sequence (0070,0314)
USED_RT_STRUCTURE_SET_ROI_SEQUENCE | Used RT Structure Set ROI Sequence (0070,0315)
USED_SEGMENTS_SEQUENCE | Used Segments Sequence (0062,0012)
USER_CONTENT_LABEL | User Content Label (3010,0033)
USER_CONTENT_LONG_LABEL | User Content Long Label (3010,0034)
UV_MAPPING_SEQUENCE | UV Mapping Sequence (0080,0008)
V_VALUE_DATA | V Value Data (0080,0011)
VALUE_TYPE | Value Type (0040,A040)
VARIABLE_FLIP_ANGLE_FLAG | Variable Flip Angle Flag (0018,1315)
VARIABLE_MODALITY_LUT_SEQUENCE | Variable Modality LUT Sequence (0028,3001)
VECTOR_ACCURACY | Vector Accuracy (0066,0020)
VECTOR_COORDINATE_DATA | Vector Coordinate Data (0066,0021)
VECTOR_DIMENSIONALITY | Vector Dimensionality (0066,001F)
VECTOR_GRID_DATA | Vector Grid Data (0064,0009)
VELOCITY_ENCODING_ACQUISITION_SEQUENCE | Velocity Encoding Acquisition Sequence (0018,9092)
VELOCITY_ENCODING_DIRECTION | Velocity Encoding Direction (0018,9090)
VELOCITY_ENCODING_MAXIMUM_VALUE | Velocity Encoding Maximum Value (0018,9217)
VELOCITY_ENCODING_MINIMUM_VALUE | Velocity Encoding Minimum Value (0018,9091)
VELOCITY_OF_SOUND | Velocity of Sound (0014,4064)
VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED | Verbal Source Identifier Code Sequence (Trial) RETIRED (0040,A358)
VERBAL_SOURCE_TRIAL_RETIRED | Verbal Source (Trial) RETIRED (0040,A352)
VERIFICATION_DATE_TIME | Alias for tag VERIFICATION_DATETIME (0040,A030)
VERIFICATION_DATETIME | Verification DateTime (0040,A030)
VERIFICATION_FLAG | Verification Flag (0040,A493)
VERIFICATION_IMAGE_TIMING | Verification Image Timing (0074,1032)
VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE | Verifying Observer Identification Code Sequence (0040,A088)
VERIFYING_OBSERVER_NAME | Verifying Observer Name (0040,A075)
VERIFYING_OBSERVER_SEQUENCE | Verifying Observer Sequence (0040,A073)
VERIFYING_ORGANIZATION | Verifying Organization (0040,A027)
VERTEX_POINT_INDEX_LIST_RETIRED | Vertex Point Index List RETIRED (0066,0025)
VERTICAL_ALIGNMENT | Vertical Alignment (0070,0243)
VERTICAL_OFFSET_OF_SENSOR | Vertical Offset of Sensor (0014,3026)
VERTICAL_PRISM_BASE | Vertical Prism Base (0046,0036)
VERTICAL_PRISM_POWER | Vertical Prism Power (0046,0034)
VERTICES_OF_THE_OUTLINE_OF_PUPIL | Vertices of the Outline of Pupil (0046,0208)
VERTICES_OF_THE_POLYGONAL_COLLIMATOR | Vertices of the Polygonal Collimator (0018,1720)
VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION | Vertices of the Polygonal Exposure Control Sensing Region (0018,9442)
VERTICES_OF_THE_POLYGONAL_OUTLINE | Vertices of the Polygonal Outline (0018,1638)
VERTICES_OF_THE_POLYGONAL_SHUTTER | Vertices of the Polygonal Shutter (0018,1620)
VERTICES_OF_THE_REGION | Vertices of the Region (0028,9503)
VIDEO_IMAGE_FORMAT_ACQUIRED | Video Image Format Acquired (0018,1022)
VIEW_CODE_SEQUENCE | View Code Sequence (0054,0220)
VIEW_MODIFIER_CODE_SEQUENCE | View Modifier Code Sequence (0054,0222)
VIEW_MODIFIER_SEQUENCE | Alias for tag VIEW_MODIFIER_CODE_SEQUENCE (0054,0222)
VIEW_NAME | View Name (0008,2127)
VIEW_NUMBER | View Number (0008,2128)
VIEW_ORIENTATION_CODE_SEQUENCE | View Orientation Code Sequence (0068,62E0)
VIEW_ORIENTATION_MODIFIER | Alias for tag VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE (0068,62F0)
VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE | View Orientation Modifier Code Sequence (0068,62F0)
VIEW_POSITION | View Position (0018,5101)
VIEWING_DISTANCE | Viewing Distance (0046,0106)
VIEWING_DISTANCE_TYPE | Viewing Distance Type (0046,0125)
VIEWPOINT_LOOKAT_POINT | Viewpoint LookAt Point (0070,1604)
VIEWPOINT_POSITION | Viewpoint Position (0070,1603)
VIEWPOINT_UP_DIRECTION | Viewpoint Up Direction (0070,1605)
VIRTUAL_SOURCE_AXIS_DISTANCES | Virtual Source-Axis Distances (300A,030A)
VISIT_COMMENTS | Visit Comments (0038,4000)
VISIT_STATUS_ID | Visit Status ID (0038,0008)
VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE | Visual Acuity Both Eyes Open Sequence (0046,0124)
VISUAL_ACUITY_LEFT_EYE_SEQUENCE | Visual Acuity Left Eye Sequence (0046,0123)
VISUAL_ACUITY_MEASUREMENT_SEQUENCE | Visual Acuity Measurement Sequence (0024,0110)
VISUAL_ACUITY_MODIFIERS | Visual Acuity Modifiers (0046,0135)
VISUAL_ACUITY_RIGHT_EYE_SEQUENCE | Visual Acuity Right Eye Sequence (0046,0122)
VISUAL_ACUITY_TYPE_CODE_SEQUENCE | Visual Acuity Type Code Sequence (0046,0121)
VISUAL_EVALUATION_METHOD_CODE_SEQUENCE | Visual Evaluation Method Code Sequence (0028,702E)
VISUAL_EVALUATION_RESULT_SEQUENCE | Visual Evaluation Result Sequence (0028,7015)
VISUAL_EVALUATION_TEST_SEQUENCE | Visual Evaluation Test Sequence (0028,7028)
VISUAL_FIELD_CATCH_TRIAL_SEQUENCE | Visual Field Catch Trial Sequence (0024,0034)
VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE | Visual Field Global Results Index Sequence (0024,0320)
VISUAL_FIELD_HORIZONTAL_EXTENT | Visual Field Horizontal Extent (0024,0010)
VISUAL_FIELD_MEAN_SENSITIVITY | Visual Field Mean Sensitivity (0024,0070)
VISUAL_FIELD_SHAPE | Visual Field Shape (0024,0012)
VISUAL_FIELD_TEST_DURATION | Visual Field Test Duration (0024,0088)
VISUAL_FIELD_TEST_NORMALS_FLAG | Visual Field Test Normals Flag (0024,0063)
VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE | Visual Field Test Point Normals Sequence (0024,0097)
VISUAL_FIELD_TEST_POINT_SEQUENCE | Visual Field Test Point Sequence (0024,0089)
VISUAL_FIELD_TEST_POINT_X_COORDINATE | Visual Field Test Point X-Coordinate (0024,0090)
VISUAL_FIELD_TEST_POINT_Y_COORDINATE | Visual Field Test Point Y-Coordinate (0024,0091)
VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE | Visual Field Test Reliability Global Index Sequence (0024,0317)
VISUAL_FIELD_VERTICAL_EXTENT | Visual Field Vertical Extent (0024,0011)
VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED | Vital Stain Code Sequence (Trial) RETIRED (0040,09F8)
VITREOUS_STATUS_CODE_SEQUENCE | Vitreous Status Code Sequence (0022,1025)
VITREOUS_STATUS_DESCRIPTION | Vitreous Status Description (0022,1066)
VOI_LUT_FUNCTION | VOI LUT Function (0028,1056)
VOI_LUT_SEQUENCE | VOI LUT Sequence (0028,3010)
VOI_TYPE | VOI Type (0072,0702)
VOLUME_BASED_CALCULATION_TECHNIQUE | Volume Based Calculation Technique (0008,9207)
VOLUME_CROPPING_METHOD | Volume Cropping Method (0070,1302)
VOLUME_CROPPING_SEQUENCE | Volume Cropping Sequence (0070,1301)
VOLUME_FRAME_OF_REFERENCE_UID | Volume Frame of Reference UID (0020,9312)
VOLUME_LOCALIZATION_SEQUENCE | Volume Localization Sequence (0018,9126)
VOLUME_LOCALIZATION_TECHNIQUE | Volume Localization Technique (0018,9054)
VOLUME_OF_PTO | Volume of PTO (4010,1023)
VOLUME_STREAM_SEQUENCE | Volume Stream Sequence (0070,1A08)
VOLUME_TO_TABLE_MAPPING_MATRIX | Volume to Table Mapping Matrix (0020,930A)
VOLUME_TO_TRANSDUCER_MAPPING_MATRIX | Volume to Transducer Mapping Matrix (0020,9309)
VOLUME_TO_TRANSDUCER_RELATIONSHIP | Volume to Transducer Relationship (0020,930B)
VOLUMETRIC_ANNOTATION_SEQUENCE | Volumetric Annotation Sequence (0070,1901)
VOLUMETRIC_CURVE_POINTS | Volumetric Curve Points (0070,150D)
VOLUMETRIC_CURVE_UP_DIRECTIONS | Volumetric Curve Up Directions (0070,1A07)
VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE | Volumetric Presentation Input Annotation Sequence (0070,1905)
VOLUMETRIC_PRESENTATION_INPUT_INDEX | Volumetric Presentation Input Index (0070,1804)
VOLUMETRIC_PRESENTATION_INPUT_NUMBER | Volumetric Presentation Input Number (0070,1207)
VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE | Volumetric Presentation Input Set Sequence (0070,120A)
VOLUMETRIC_PRESENTATION_INPUT_SET_UID | Volumetric Presentation Input Set UID (0070,1209)
VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE | Volumetric Presentation State Input Sequence (0070,1201)
VOLUMETRIC_PROPERTIES | Volumetric Properties (0008,9206)
WADO_RETRIEVAL_SEQUENCE | WADO Retrieval Sequence (0040,E023)
WADO_RS_RETRIEVAL_SEQUENCE | WADO-RS Retrieval Sequence (0040,E025)
WARNING_REASON | Warning Reason (0008,1196)
WATER_DEPTH | Water Depth (0016,0033)
WATER_EQUIVALENT_DIAMETER | Water Equivalent Diameter (0018,1271)
WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE | Water Equivalent Diameter Calculation Method Code Sequence (0018,1272)
WATER_REFERENCE_ACQUISITION | Water Reference Acquisition (0018,9297)
WATER_REFERENCED_PHASE_CORRECTION | Water Referenced Phase Correction (0018,9199)
WAVEFORM_AMPLIFIER_TYPE | Waveform Amplifier Type (003A,0317)
WAVEFORM_ANNOTATION_SEQUENCE | Waveform Annotation Sequence (0040,B020)
WAVEFORM_BITS_ALLOCATED | Waveform Bits Allocated (5400,1004)
WAVEFORM_BITS_STORED | Waveform Bits Stored (003A,021A)
WAVEFORM_CHANNEL_NUMBER | Waveform Channel Number (003A,0202)
WAVEFORM_DATA | Waveform Data (5400,1010)
WAVEFORM_DATA_DISPLAY_SCALE | Waveform Data Display Scale (003A,0230)
WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE | Waveform Display Background CIELab Value (003A,0231)
WAVEFORM_FILTER_DESCRIPTION | Waveform Filter Description (003A,0329)
WAVEFORM_FILTER_TYPE | Waveform Filter Type (003A,0322)
WAVEFORM_ORIGINALITY | Waveform Originality (003A,0004)
WAVEFORM_PADDING_VALUE | Waveform Padding Value (5400,100A)
WAVEFORM_PRESENTATION_GROUP_SEQUENCE | Waveform Presentation Group Sequence (003A,0240)
WAVEFORM_SAMPLE_INTERPRETATION | Waveform Sample Interpretation (5400,1006)
WAVEFORM_SEQUENCE | Waveform Sequence (5400,0100)
WEDGE_ANGLE | Wedge Angle (300A,00D5)
WEDGE_DEFINITION_SEQUENCE | Wedge Definition Sequence (300A,0651)
WEDGE_FACTOR | Wedge Factor (300A,00D6)
WEDGE_ID | Wedge ID (300A,00D4)
WEDGE_NUMBER | Wedge Number (300A,00D2)
WEDGE_ORIENTATION | Wedge Orientation (300A,00D8)
WEDGE_POSITION | Wedge Position (300A,0118)
WEDGE_POSITION_SEQUENCE | Wedge Position Sequence (300A,0116)
WEDGE_SEQUENCE | Wedge Sequence (300A,00D1)
WEDGE_THIN_EDGE_POSITION | Wedge Thin Edge Position (300A,00DB)
WEDGE_TYPE | Wedge Type (300A,00D3)
WEEKDAY_FRACTION_PATTERN_SEQUENCE | Weekday Fraction Pattern Sequence (3010,0087)
WEIGHTING_LOOKUP_TABLE_DATA | Weighting Lookup Table Data (0070,1808)
WEIGHTING_LOOKUP_TABLE_DESCRIPTOR | Weighting Lookup Table Descriptor (0070,1807)
WEIGHTING_TRANSFER_FUNCTION_SEQUENCE | Weighting Transfer Function Sequence (0070,1806)
WHITE_BALANCE | White Balance (0016,0043)
WHITE_POINT | White Point (0016,0001)
WHITE_POINT_FLAG | White Point Flag (0028,7021)
WHOLE_BODY_TECHNIQUE | Whole Body Technique (0018,1301)
WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE | Whole Slide Microscopy Image Frame Type Sequence (0040,0710)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE | Wide Field Ophthalmic Photography Quality Rating Sequence (0022,1525)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE | Wide Field Ophthalmic Photography Quality Threshold Sequence (0022,1526)
WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING | Wide Field Ophthalmic Photography Threshold Quality Rating (0022,1527)
WINDOW_CENTER | Window Center (0028,1050)
WINDOW_CENTER_AND_WIDTH_EXPLANATION | Alias for tag WINDOW_CENTER_WIDTH_EXPLANATION (0028,1055)
WINDOW_CENTER_WIDTH_EXPLANATION | Window Center Width Explanation (0028,1055)
WINDOW_WIDTH | Window Width (0028,1051)
WORKLIST_LABEL | Worklist Label (0074,1202)
X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE | X Coordinates Center Pixel View Angle (0022,1528)
X_FOCUS_CENTER | X Focus Center (0018,1183)
X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | X Offset in Slide Coordinate System (0040,072A)
X_RAY_3D_ACQUISITION_SEQUENCE | X-Ray 3D Acquisition Sequence (0018,9507)
X_RAY_3D_FRAME_TYPE_SEQUENCE | X-Ray 3D Frame Type Sequence (0018,9504)
X_RAY_3D_RECONSTRUCTION_SEQUENCE | X-Ray 3D Reconstruction Sequence (0018,9530)
X_RAY_ACQUISITION_DOSE_SEQUENCE | X-Ray Acquisition Dose Sequence (0018,9542)
X_RAY_DETECTOR_ID | X-Ray Detector ID (0018,9371)
X_RAY_DETECTOR_INDEX | X-Ray Detector Index (0018,9370)
X_RAY_DETECTOR_LABEL | X-Ray Detector Label (0018,9373)
X_RAY_FILTER_DETAILS_SEQUENCE | X-Ray Filter Details Sequence (0018,11BC)
X_RAY_FILTER_SEQUENCE | X-Ray Filter Sequence (0018,9556)
X_RAY_GEOMETRY_SEQUENCE | X-Ray Geometry Sequence (0018,9476)
X_RAY_GRID_SEQUENCE | X-Ray Grid Sequence (0018,9555)
X_RAY_IMAGE_RECEPTOR_ANGLE | X-Ray Image Receptor Angle (3002,000E)
X_RAY_IMAGE_RECEPTOR_TRANSLATION | X-Ray Image Receptor Translation (3002,000D)
X_RAY_MASS_ATTENUATION_COEFFICIENT | X-Ray Mass Attenuation Coefficient (0018,9384)
X_RAY_OUTPUT | X-Ray Output (0040,0312)
X_RAY_RECEPTOR_TYPE | X-Ray Receptor Type (0018,9420)
X_RAY_SOURCE_ID | X-Ray Source ID (0018,9367)
X_RAY_SOURCE_INDEX | X-Ray Source Index (0018,9366)
X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE | X-Ray Source Isocenter Primary Angle (0018,9543)
X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE | X-Ray Source Isocenter Secondary Angle (0018,9544)
X_RAY_TUBE_CURRENT | X-Ray Tube Current (0018,1151)
X_RAY_TUBE_CURRENT_IN_MA | X-Ray Tube Current in mA (0018,9330)
X_RAY_TUBE_CURRENT_IN_UA | X-Ray Tube Current in uA (0018,8151)
XA_ACQUISITION_DURATION | XA Acquisition Duration (0018,11BD)
XA_ACQUISITION_FRAME_RATE | XA Acquisition Frame Rate (0018,11B9)
XA_ACQUISITION_PHASE_DETAILS_SEQUENCE | XA Acquisition Phase Details Sequence (0018,11B8)
XA_PLANE_DETAILS_SEQUENCE | XA Plane Details Sequence (0018,11BA)
XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE | XA/XRF Frame Characteristics Sequence (0018,9412)
XDS_RETRIEVAL_SEQUENCE | XDS Retrieval Sequence (0040,E024)
XDS_STORAGE_SEQUENCE | XDS Storage Sequence (0040,4074)
Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE | Y Coordinates Center Pixel View Angle (0022,1529)
Y_FOCUS_CENTER | Y Focus Center (0018,1184)
Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | Y Offset in Slide Coordinate System (0040,073A)
Z_EFFECTIVE | Z Effective (4010,1019)
Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM | Z Offset in Slide Coordinate System (0040,074A)
ZERO_VELOCITY_PIXEL_VALUE | Zero Velocity Pixel Value (0018,9810)
ZOOM_CENTER | Zoom Center (0028,0032)
ZOOM_FACTOR | Zoom Factor (0028,0031)

See Also

MCdicom Structure


A_LINE_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..A_LINE_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
A-line Pixel Spacing (0052,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint A_LINE_PIXEL_SPACING
Visual Basic
Public Const A_LINE_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int A_LINE_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


A_LINE_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..A_LINE_RATE Field
MCdicom Structure See Also Send Feedback
A-line Rate (0052,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint A_LINE_RATE
Visual Basic
Public Const A_LINE_RATE As UInteger
Visual C++
public:
literal unsigned int A_LINE_RATE

See Also

MCdicom Structure
MCdicom Members


A_LINES_PER_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..A_LINES_PER_FRAME Field
MCdicom Structure See Also Send Feedback
A-lines Per Frame (0052,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint A_LINES_PER_FRAME
Visual Basic
Public Const A_LINES_PER_FRAME As UInteger
Visual C++
public:
literal unsigned int A_LINES_PER_FRAME

See Also

MCdicom Structure
MCdicom Members


A_SCAN_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..A_SCAN_RATE Field
MCdicom Structure See Also Send Feedback
A-scan Rate (0022,1649)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint A_SCAN_RATE
Visual Basic
Public Const A_SCAN_RATE As UInteger
Visual C++
public:
literal unsigned int A_SCAN_RATE

See Also

MCdicom Structure
MCdicom Members


ABORT_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABORT_FLAG Field
MCdicom Structure See Also Send Feedback
Abort Flag (4010,1024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABORT_FLAG
Visual Basic
Public Const ABORT_FLAG As UInteger
Visual C++
public:
literal unsigned int ABORT_FLAG

See Also

MCdicom Structure
MCdicom Members


ABORT_REASON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABORT_REASON Field
MCdicom Structure See Also Send Feedback
Abort Reason (4010,1021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABORT_REASON
Visual Basic
Public Const ABORT_REASON As UInteger
Visual C++
public:
literal unsigned int ABORT_REASON

See Also

MCdicom Structure
MCdicom Members


ABSOLUTE_CHANNEL_DISPLAY_SCALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABSOLUTE_CHANNEL_DISPLAY_SCALE Field
MCdicom Structure See Also Send Feedback
Absolute Channel Display Scale (003A,0248)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABSOLUTE_CHANNEL_DISPLAY_SCALE
Visual Basic
Public Const ABSOLUTE_CHANNEL_DISPLAY_SCALE As UInteger
Visual C++
public:
literal unsigned int ABSOLUTE_CHANNEL_DISPLAY_SCALE

See Also

MCdicom Structure
MCdicom Members


ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG Field
MCdicom Structure See Also Send Feedback
Absolute Dosimetric Objective Flag (3010,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG
Visual Basic
Public Const ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG As UInteger
Visual C++
public:
literal unsigned int ABSOLUTE_DOSIMETRIC_OBJECTIVE_FLAG

See Also

MCdicom Structure
MCdicom Members


ABSORBED_DOSE_TO_METERSET_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABSORBED_DOSE_TO_METERSET_RATIO Field
MCdicom Structure See Also Send Feedback
Absorbed Dose to Meterset Ratio (300C,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABSORBED_DOSE_TO_METERSET_RATIO
Visual Basic
Public Const ABSORBED_DOSE_TO_METERSET_RATIO As UInteger
Visual C++
public:
literal unsigned int ABSORBED_DOSE_TO_METERSET_RATIO

See Also

MCdicom Structure
MCdicom Members


ABSTRACT_PRIOR_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABSTRACT_PRIOR_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Abstract Prior Code Sequence (0072,003E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABSTRACT_PRIOR_CODE_SEQUENCE
Visual Basic
Public Const ABSTRACT_PRIOR_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ABSTRACT_PRIOR_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ABSTRACT_PRIOR_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ABSTRACT_PRIOR_VALUE Field
MCdicom Structure See Also Send Feedback
Abstract Prior Value (0072,003C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ABSTRACT_PRIOR_VALUE
Visual Basic
Public Const ABSTRACT_PRIOR_VALUE As UInteger
Visual C++
public:
literal unsigned int ABSTRACT_PRIOR_VALUE

See Also

MCdicom Structure
MCdicom Members


ACCELERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACCELERATION Field
MCdicom Structure See Also Send Feedback
Acceleration (0016,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACCELERATION
Visual Basic
Public Const ACCELERATION As UInteger
Visual C++
public:
literal unsigned int ACCELERATION

See Also

MCdicom Structure
MCdicom Members


ACCESSION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACCESSION_NUMBER Field
MCdicom Structure See Also Send Feedback
Accession Number (0008,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACCESSION_NUMBER
Visual Basic
Public Const ACCESSION_NUMBER As UInteger
Visual C++
public:
literal unsigned int ACCESSION_NUMBER

See Also

MCdicom Structure
MCdicom Members


ACCESSORY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACCESSORY_CODE Field
MCdicom Structure See Also Send Feedback
Accessory Code (300A,00F9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACCESSORY_CODE
Visual Basic
Public Const ACCESSORY_CODE As UInteger
Visual C++
public:
literal unsigned int ACCESSORY_CODE

See Also

MCdicom Structure
MCdicom Members


ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acoustic Coupling Medium Code Sequence (0018,982A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE
Visual Basic
Public Const ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACOUSTIC_COUPLING_MEDIUM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACOUSTIC_COUPLING_MEDIUM_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACOUSTIC_COUPLING_MEDIUM_FLAG Field
MCdicom Structure See Also Send Feedback
Acoustic Coupling Medium Flag (0018,9829)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACOUSTIC_COUPLING_MEDIUM_FLAG
Visual Basic
Public Const ACOUSTIC_COUPLING_MEDIUM_FLAG As UInteger
Visual C++
public:
literal unsigned int ACOUSTIC_COUPLING_MEDIUM_FLAG

See Also

MCdicom Structure
MCdicom Members


ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED Field
MCdicom Structure See Also Send Feedback
Acoustic Coupling Medium Sound Speed (0018,9834)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED
Visual Basic
Public Const ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED As UInteger
Visual C++
public:
literal unsigned int ACOUSTIC_COUPLING_MEDIUM_SOUND_SPEED

See Also

MCdicom Structure
MCdicom Members


ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE Field
MCdicom Structure See Also Send Feedback
Acoustic Coupling Medium Temperature (0018,982B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE
Visual Basic
Public Const ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE As UInteger
Visual C++
public:
literal unsigned int ACOUSTIC_COUPLING_MEDIUM_TEMPERATURE

See Also

MCdicom Structure
MCdicom Members


ACQUIRED_IMAGE_AREA_DOSE_PRODUCT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUIRED_IMAGE_AREA_DOSE_PRODUCT Field
MCdicom Structure See Also Send Feedback
Acquired Image Area Dose Product (0018,9473)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUIRED_IMAGE_AREA_DOSE_PRODUCT
Visual Basic
Public Const ACQUIRED_IMAGE_AREA_DOSE_PRODUCT As UInteger
Visual C++
public:
literal unsigned int ACQUIRED_IMAGE_AREA_DOSE_PRODUCT

See Also

MCdicom Structure
MCdicom Members


ACQUIRED_SOUNDPATH_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUIRED_SOUNDPATH_LENGTH Field
MCdicom Structure See Also Send Feedback
Acquired Soundpath Length (0014,4031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUIRED_SOUNDPATH_LENGTH
Visual Basic
Public Const ACQUIRED_SOUNDPATH_LENGTH As UInteger
Visual C++
public:
literal unsigned int ACQUIRED_SOUNDPATH_LENGTH

See Also

MCdicom Structure
MCdicom Members


ACQUIRED_SUBTRACTION_MASK_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUIRED_SUBTRACTION_MASK_FLAG Field
MCdicom Structure See Also Send Feedback
Acquired Subtraction Mask Flag (0018,11B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUIRED_SUBTRACTION_MASK_FLAG
Visual Basic
Public Const ACQUIRED_SUBTRACTION_MASK_FLAG As UInteger
Visual C++
public:
literal unsigned int ACQUIRED_SUBTRACTION_MASK_FLAG

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Acquisition Comments RETIRED (0018,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_COMMENTS_RETIRED
Visual Basic
Public Const ACQUISITION_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_COMPRESSION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_COMPRESSION_TYPE Field
MCdicom Structure See Also Send Feedback
Acquisition Compression Type (0014,4032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_COMPRESSION_TYPE
Visual Basic
Public Const ACQUISITION_COMPRESSION_TYPE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_COMPRESSION_TYPE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_CONTEXT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_CONTEXT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Acquisition Context Description (0040,0556)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_CONTEXT_DESCRIPTION
Visual Basic
Public Const ACQUISITION_CONTEXT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_CONTEXT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_CONTEXT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_CONTEXT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Context Sequence (0040,0555)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_CONTEXT_SEQUENCE
Visual Basic
Public Const ACQUISITION_CONTEXT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_CONTEXT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_CONTRAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_CONTRAST Field
MCdicom Structure See Also Send Feedback
Acquisition Contrast (0008,9209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_CONTRAST
Visual Basic
Public Const ACQUISITION_CONTRAST As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_CONTRAST

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DATE Field
MCdicom Structure See Also Send Feedback
Acquisition Date (0008,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DATE
Visual Basic
Public Const ACQUISITION_DATE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DATE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DATETIME Field
MCdicom Structure See Also Send Feedback
Acquisition DateTime (0008,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DATETIME
Visual Basic
Public Const ACQUISITION_DATETIME As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DATETIME

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DEVICE_PROCESSING_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DEVICE_PROCESSING_CODE Field
MCdicom Structure See Also Send Feedback
Acquisition Device Processing Code (0018,1401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DEVICE_PROCESSING_CODE
Visual Basic
Public Const ACQUISITION_DEVICE_PROCESSING_CODE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DEVICE_PROCESSING_CODE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DEVICE_PROCESSING_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DEVICE_PROCESSING_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Acquisition Device Processing Description (0018,1400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DEVICE_PROCESSING_DESCRIPTION
Visual Basic
Public Const ACQUISITION_DEVICE_PROCESSING_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DEVICE_PROCESSING_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Device Sequence (3002,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DEVICE_SEQUENCE
Visual Basic
Public Const ACQUISITION_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Device Type Code Sequence (0022,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DEVICE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_DURATION Field
MCdicom Structure See Also Send Feedback
Acquisition Duration (0018,9073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_DURATION
Visual Basic
Public Const ACQUISITION_DURATION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_DURATION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_END_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_END_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition End Location Sequence (0018,9932)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_END_LOCATION_SEQUENCE
Visual Basic
Public Const ACQUISITION_END_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_END_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_FIELD_OF_VIEW_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_FIELD_OF_VIEW_LABEL Field
MCdicom Structure See Also Send Feedback
Acquisition Field of View Label (0018,11BB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_FIELD_OF_VIEW_LABEL
Visual Basic
Public Const ACQUISITION_FIELD_OF_VIEW_LABEL As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_FIELD_OF_VIEW_LABEL

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_INDEX Field
MCdicom Structure See Also Send Feedback
Acquisition Index (0020,9518)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_INDEX
Visual Basic
Public Const ACQUISITION_INDEX As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_INDEX

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_INITIATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_INITIATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Initiation Sequence (3002,0135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_INITIATION_SEQUENCE
Visual Basic
Public Const ACQUISITION_INITIATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_INITIATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_MATRIX Field
MCdicom Structure See Also Send Feedback
Acquisition Matrix (0018,1310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_MATRIX
Visual Basic
Public Const ACQUISITION_MATRIX As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_MATRIX

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_METHOD Field
MCdicom Structure See Also Send Feedback
Acquisition Method (3002,012A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_METHOD
Visual Basic
Public Const ACQUISITION_METHOD As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_METHOD

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_METHOD_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_METHOD_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Method Algorithm Sequence (0022,1423)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_METHOD_ALGORITHM_SEQUENCE
Visual Basic
Public Const ACQUISITION_METHOD_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_METHOD_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Method Code Sequence (0022,1420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const ACQUISITION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_MODE Field
MCdicom Structure See Also Send Feedback
Acquisition Mode (0018,11B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_MODE
Visual Basic
Public Const ACQUISITION_MODE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_MODE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_MOTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_MOTION Field
MCdicom Structure See Also Send Feedback
Acquisition Motion (0018,9930)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_MOTION
Visual Basic
Public Const ACQUISITION_MOTION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_MOTION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_NUMBER Field
MCdicom Structure See Also Send Feedback
Acquisition Number (0020,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_NUMBER
Visual Basic
Public Const ACQUISITION_NUMBER As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_NUMBER

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_PROTOCOL_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_PROTOCOL_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Acquisition Protocol Description (0018,9424)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_PROTOCOL_DESCRIPTION
Visual Basic
Public Const ACQUISITION_PROTOCOL_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_PROTOCOL_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Protocol Element Sequence (0018,9920)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE
Visual Basic
Public Const ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_PROTOCOL_ELEMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Protocol Element Specification Sequence (0018,991F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE
Visual Basic
Public Const ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_PROTOCOL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_PROTOCOL_NAME Field
MCdicom Structure See Also Send Feedback
Acquisition Protocol Name (0018,9423)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_PROTOCOL_NAME
Visual Basic
Public Const ACQUISITION_PROTOCOL_NAME As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_PROTOCOL_NAME

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_SAMPLE_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_SAMPLE_SIZE Field
MCdicom Structure See Also Send Feedback
Acquisition Sample Size (0014,4033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_SAMPLE_SIZE
Visual Basic
Public Const ACQUISITION_SAMPLE_SIZE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_SAMPLE_SIZE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_SIGNAL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_SIGNAL_TYPE Field
MCdicom Structure See Also Send Feedback
Acquisition Signal Type (3002,0129)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_SIGNAL_TYPE
Visual Basic
Public Const ACQUISITION_SIGNAL_TYPE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_SIGNAL_TYPE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_START_CONDITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_START_CONDITION Field
MCdicom Structure See Also Send Feedback
Acquisition Start Condition (0018,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_START_CONDITION
Visual Basic
Public Const ACQUISITION_START_CONDITION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_START_CONDITION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_START_CONDITION_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_START_CONDITION_DATA Field
MCdicom Structure See Also Send Feedback
Acquisition Start Condition Data (0018,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_START_CONDITION_DATA
Visual Basic
Public Const ACQUISITION_START_CONDITION_DATA As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_START_CONDITION_DATA

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_START_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_START_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Start Location Sequence (0018,9931)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_START_LOCATION_SEQUENCE
Visual Basic
Public Const ACQUISITION_START_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_START_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_STATUS Field
MCdicom Structure See Also Send Feedback
Acquisition Status (4010,1044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_STATUS
Visual Basic
Public Const ACQUISITION_STATUS As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_STATUS

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_SUBTASK_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_SUBTASK_INDEX Field
MCdicom Structure See Also Send Feedback
Acquisition Subtask Index (3002,011D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_SUBTASK_INDEX
Visual Basic
Public Const ACQUISITION_SUBTASK_INDEX As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_SUBTASK_INDEX

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_SUBTASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_SUBTASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Subtask Sequence (3002,011A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_SUBTASK_SEQUENCE
Visual Basic
Public Const ACQUISITION_SUBTASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_SUBTASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TASK_APPLICABILITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TASK_APPLICABILITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Task Applicability Sequence (3002,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TASK_APPLICABILITY_SEQUENCE
Visual Basic
Public Const ACQUISITION_TASK_APPLICABILITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TASK_APPLICABILITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TASK_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TASK_INDEX Field
MCdicom Structure See Also Send Feedback
Acquisition Task Index (3002,011C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TASK_INDEX
Visual Basic
Public Const ACQUISITION_TASK_INDEX As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TASK_INDEX

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Task Sequence (3002,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TASK_SEQUENCE
Visual Basic
Public Const ACQUISITION_TASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Acquisition Task Workitem Code Sequence (3002,0119)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE
Visual Basic
Public Const ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TASK_WORKITEM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TERMINATION_CONDITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TERMINATION_CONDITION Field
MCdicom Structure See Also Send Feedback
Acquisition Termination Condition (0018,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TERMINATION_CONDITION
Visual Basic
Public Const ACQUISITION_TERMINATION_CONDITION As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TERMINATION_CONDITION

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TERMINATION_CONDITION_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TERMINATION_CONDITION_DATA Field
MCdicom Structure See Also Send Feedback
Acquisition Termination Condition Data (0018,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TERMINATION_CONDITION_DATA
Visual Basic
Public Const ACQUISITION_TERMINATION_CONDITION_DATA As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TERMINATION_CONDITION_DATA

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TIME Field
MCdicom Structure See Also Send Feedback
Acquisition Time (0008,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TIME
Visual Basic
Public Const ACQUISITION_TIME As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TIME

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TIME_SYNCHRONIZED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TIME_SYNCHRONIZED Field
MCdicom Structure See Also Send Feedback
Acquisition Time Synchronized (0018,1800)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TIME_SYNCHRONIZED
Visual Basic
Public Const ACQUISITION_TIME_SYNCHRONIZED As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TIME_SYNCHRONIZED

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_TYPE Field
MCdicom Structure See Also Send Feedback
Acquisition Type (0018,9302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_TYPE
Visual Basic
Public Const ACQUISITION_TYPE As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_TYPE

See Also

MCdicom Structure
MCdicom Members


ACQUISITION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITION_UID Field
MCdicom Structure See Also Send Feedback
Acquisition UID (0008,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITION_UID
Visual Basic
Public Const ACQUISITION_UID As UInteger
Visual C++
public:
literal unsigned int ACQUISITION_UID

See Also

MCdicom Structure
MCdicom Members


ACQUISITIONS_IN_SERIES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITIONS_IN_SERIES_RETIRED Field
MCdicom Structure See Also Send Feedback
Acquisitions in Series RETIRED (0020,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITIONS_IN_SERIES_RETIRED
Visual Basic
Public Const ACQUISITIONS_IN_SERIES_RETIRED As UInteger
Visual C++
public:
literal unsigned int ACQUISITIONS_IN_SERIES_RETIRED

See Also

MCdicom Structure
MCdicom Members


ACQUISITIONS_IN_STUDY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACQUISITIONS_IN_STUDY_RETIRED Field
MCdicom Structure See Also Send Feedback
Acquisitions in Study RETIRED (0020,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACQUISITIONS_IN_STUDY_RETIRED
Visual Basic
Public Const ACQUISITIONS_IN_STUDY_RETIRED As UInteger
Visual C++
public:
literal unsigned int ACQUISITIONS_IN_STUDY_RETIRED

See Also

MCdicom Structure
MCdicom Members


ACROSS_SCAN_SPATIAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACROSS_SCAN_SPATIAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Across-scan Spatial Resolution (0022,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACROSS_SCAN_SPATIAL_RESOLUTION
Visual Basic
Public Const ACROSS_SCAN_SPATIAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int ACROSS_SCAN_SPATIAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


ACTION_TYPE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTION_TYPE_ID Field
MCdicom Structure See Also Send Feedback
Action Type ID (0000,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTION_TYPE_ID
Visual Basic
Public Const ACTION_TYPE_ID As UInteger
Visual C++
public:
literal unsigned int ACTION_TYPE_ID

See Also

MCdicom Structure
MCdicom Members


ACTIVE_IMAGE_AREA_OVERLAY_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTIVE_IMAGE_AREA_OVERLAY_GROUP Field
MCdicom Structure See Also Send Feedback
Active Image Area Overlay Group (0018,6070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTIVE_IMAGE_AREA_OVERLAY_GROUP
Visual Basic
Public Const ACTIVE_IMAGE_AREA_OVERLAY_GROUP As UInteger
Visual C++
public:
literal unsigned int ACTIVE_IMAGE_AREA_OVERLAY_GROUP

See Also

MCdicom Structure
MCdicom Members


ACTIVE_SOURCE_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTIVE_SOURCE_DIAMETER Field
MCdicom Structure See Also Send Feedback
Active Source Diameter (300A,0218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTIVE_SOURCE_DIAMETER
Visual Basic
Public Const ACTIVE_SOURCE_DIAMETER As UInteger
Visual C++
public:
literal unsigned int ACTIVE_SOURCE_DIAMETER

See Also

MCdicom Structure
MCdicom Members


ACTIVE_SOURCE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTIVE_SOURCE_LENGTH Field
MCdicom Structure See Also Send Feedback
Active Source Length (300A,021A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTIVE_SOURCE_LENGTH
Visual Basic
Public Const ACTIVE_SOURCE_LENGTH As UInteger
Visual C++
public:
literal unsigned int ACTIVE_SOURCE_LENGTH

See Also

MCdicom Structure
MCdicom Members


ACTUAL_CARDIAC_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_CARDIAC_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Actual Cardiac Trigger Delay Time (0020,9252)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_CARDIAC_TRIGGER_DELAY_TIME
Visual Basic
Public Const ACTUAL_CARDIAC_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int ACTUAL_CARDIAC_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK Field
MCdicom Structure See Also Send Feedback
Actual Cardiac Trigger Time Prior To R-Peak (0020,9155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK
Visual Basic
Public Const ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK As UInteger
Visual C++
public:
literal unsigned int ACTUAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK

See Also

MCdicom Structure
MCdicom Members


ACTUAL_ENVIRONMENTAL_CONDITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_ENVIRONMENTAL_CONDITIONS Field
MCdicom Structure See Also Send Feedback
Actual Environmental Conditions (0014,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_ENVIRONMENTAL_CONDITIONS
Visual Basic
Public Const ACTUAL_ENVIRONMENTAL_CONDITIONS As UInteger
Visual C++
public:
literal unsigned int ACTUAL_ENVIRONMENTAL_CONDITIONS

See Also

MCdicom Structure
MCdicom Members


ACTUAL_FRAME_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_FRAME_DURATION Field
MCdicom Structure See Also Send Feedback
Actual Frame Duration (0018,1242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_FRAME_DURATION
Visual Basic
Public Const ACTUAL_FRAME_DURATION As UInteger
Visual C++
public:
literal unsigned int ACTUAL_FRAME_DURATION

See Also

MCdicom Structure
MCdicom Members


ACTUAL_HUMAN_PERFORMERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_HUMAN_PERFORMERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Actual Human Performers Sequence (0040,4035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_HUMAN_PERFORMERS_SEQUENCE
Visual Basic
Public Const ACTUAL_HUMAN_PERFORMERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ACTUAL_HUMAN_PERFORMERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Actual Respiratory Trigger Delay Time (0020,9257)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME
Visual Basic
Public Const ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int ACTUAL_RESPIRATORY_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


ADD_GRAY_SCALE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADD_GRAY_SCALE_RETIRED Field
MCdicom Structure See Also Send Feedback
Add Gray Scale RETIRED (0000,5150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADD_GRAY_SCALE_RETIRED
Visual Basic
Public Const ADD_GRAY_SCALE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ADD_GRAY_SCALE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ADD_INTERMEDIATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADD_INTERMEDIATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Add Intermediate Sequence (0046,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADD_INTERMEDIATE_SEQUENCE
Visual Basic
Public Const ADD_INTERMEDIATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADD_INTERMEDIATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADD_NEAR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADD_NEAR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Add Near Sequence (0046,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADD_NEAR_SEQUENCE
Visual Basic
Public Const ADD_NEAR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADD_NEAR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADD_OTHER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADD_OTHER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Add Other Sequence (0046,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADD_OTHER_SEQUENCE
Visual Basic
Public Const ADD_OTHER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADD_OTHER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADD_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADD_POWER Field
MCdicom Structure See Also Send Feedback
Add Power (0046,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADD_POWER
Visual Basic
Public Const ADD_POWER As UInteger
Visual C++
public:
literal unsigned int ADD_POWER

See Also

MCdicom Structure
MCdicom Members


ADDITIONAL_DRUG_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDITIONAL_DRUG_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Additional Drug Sequence (0018,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDITIONAL_DRUG_SEQUENCE
Visual Basic
Public Const ADDITIONAL_DRUG_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADDITIONAL_DRUG_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Additional Parameter Recording Instance Sequence (300A,0780)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE
Visual Basic
Public Const ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADDITIONAL_PARAMETER_RECORDING_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADDITIONAL_PATIENT_HISTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDITIONAL_PATIENT_HISTORY Field
MCdicom Structure See Also Send Feedback
Additional Patient History (0010,21B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDITIONAL_PATIENT_HISTORY
Visual Basic
Public Const ADDITIONAL_PATIENT_HISTORY As UInteger
Visual C++
public:
literal unsigned int ADDITIONAL_PATIENT_HISTORY

See Also

MCdicom Structure
MCdicom Members


ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Additional RT Accessory Device Sequence (3002,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE
Visual Basic
Public Const ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADDITIONAL_RT_ACCESSORY_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Additional RT ROI Identification Code Sequence RETIRED (3006,00B9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ADDITIONAL_RT_ROI_IDENTIFICATION_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ADDRESS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADDRESS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Address (Trial) RETIRED (0040,A353)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADDRESS_TRIAL_RETIRED
Visual Basic
Public Const ADDRESS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ADDRESS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ADMINISTRATION_ROUTE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMINISTRATION_ROUTE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Administration Route Code Sequence (0054,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMINISTRATION_ROUTE_CODE_SEQUENCE
Visual Basic
Public Const ADMINISTRATION_ROUTE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADMINISTRATION_ROUTE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADMISSION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMISSION_ID Field
MCdicom Structure See Also Send Feedback
Admission ID (0038,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMISSION_ID
Visual Basic
Public Const ADMISSION_ID As UInteger
Visual C++
public:
literal unsigned int ADMISSION_ID

See Also

MCdicom Structure
MCdicom Members


ADMITTING_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMITTING_DATE Field
MCdicom Structure See Also Send Feedback
Admitting Date (0038,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMITTING_DATE
Visual Basic
Public Const ADMITTING_DATE As UInteger
Visual C++
public:
literal unsigned int ADMITTING_DATE

See Also

MCdicom Structure
MCdicom Members


ADMITTING_DIAGNOSES_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMITTING_DIAGNOSES_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Admitting Diagnoses Code Sequence (0008,1084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMITTING_DIAGNOSES_CODE_SEQUENCE
Visual Basic
Public Const ADMITTING_DIAGNOSES_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADMITTING_DIAGNOSES_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ADMITTING_DIAGNOSES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMITTING_DIAGNOSES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Admitting Diagnoses Description (0008,1080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMITTING_DIAGNOSES_DESCRIPTION
Visual Basic
Public Const ADMITTING_DIAGNOSES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ADMITTING_DIAGNOSES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ADMITTING_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADMITTING_TIME Field
MCdicom Structure See Also Send Feedback
Admitting Time (0038,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADMITTING_TIME
Visual Basic
Public Const ADMITTING_TIME As UInteger
Visual C++
public:
literal unsigned int ADMITTING_TIME

See Also

MCdicom Structure
MCdicom Members


ADVANCED_BLENDING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ADVANCED_BLENDING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Advanced Blending Sequence (0070,1B01)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ADVANCED_BLENDING_SEQUENCE
Visual Basic
Public Const ADVANCED_BLENDING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ADVANCED_BLENDING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AFFECTED_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AFFECTED_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Affected SOP Class UID (0000,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AFFECTED_SOP_CLASS_UID
Visual Basic
Public Const AFFECTED_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int AFFECTED_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


AFFECTED_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AFFECTED_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Affected SOP Instance UID (0000,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AFFECTED_SOP_INSTANCE_UID
Visual Basic
Public Const AFFECTED_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int AFFECTED_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


AFTERLOADER_CHANNEL_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AFTERLOADER_CHANNEL_ID Field
MCdicom Structure See Also Send Feedback
Afterloader Channel ID (300A,0273)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AFTERLOADER_CHANNEL_ID
Visual Basic
Public Const AFTERLOADER_CHANNEL_ID As UInteger
Visual C++
public:
literal unsigned int AFTERLOADER_CHANNEL_ID

See Also

MCdicom Structure
MCdicom Members


AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Age Corrected Sensitivity Deviation Algorithm Sequence (0024,0065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE
Visual Basic
Public Const AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int AGE_CORRECTED_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE Field
MCdicom Structure See Also Send Feedback
Age Corrected Sensitivity Deviation Probability Value (0024,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE
Visual Basic
Public Const AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE As UInteger
Visual C++
public:
literal unsigned int AGE_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE

See Also

MCdicom Structure
MCdicom Members


AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE Field
MCdicom Structure See Also Send Feedback
Age Corrected Sensitivity Deviation Value (0024,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE
Visual Basic
Public Const AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE As UInteger
Visual C++
public:
literal unsigned int AGE_CORRECTED_SENSITIVITY_DEVIATION_VALUE

See Also

MCdicom Structure
MCdicom Members


AIR_COUNTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AIR_COUNTS Field
MCdicom Structure See Also Send Feedback
Air Counts (0014,3070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AIR_COUNTS
Visual Basic
Public Const AIR_COUNTS As UInteger
Visual C++
public:
literal unsigned int AIR_COUNTS

See Also

MCdicom Structure
MCdicom Members


ALARM_DECISION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALARM_DECISION Field
MCdicom Structure See Also Send Feedback
Alarm Decision (4010,1031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALARM_DECISION
Visual Basic
Public Const ALARM_DECISION As UInteger
Visual C++
public:
literal unsigned int ALARM_DECISION

See Also

MCdicom Structure
MCdicom Members


ALARM_DECISION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALARM_DECISION_TIME Field
MCdicom Structure See Also Send Feedback
Alarm Decision Time (4010,102B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALARM_DECISION_TIME
Visual Basic
Public Const ALARM_DECISION_TIME As UInteger
Visual C++
public:
literal unsigned int ALARM_DECISION_TIME

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Algorithm Code Sequence (Trial) RETIRED (0040,A296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Algorithm Description (0018,9528)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_DESCRIPTION
Visual Basic
Public Const ALGORITHM_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Algorithm Description (Trial) RETIRED (0040,A297)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const ALGORITHM_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_FAMILY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_FAMILY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Algorithm Family Code Sequence (0066,002F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_FAMILY_CODE_SEQUENCE
Visual Basic
Public Const ALGORITHM_FAMILY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_FAMILY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_NAME Field
MCdicom Structure See Also Send Feedback
Algorithm Name (0066,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_NAME
Visual Basic
Public Const ALGORITHM_NAME As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_NAME

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Algorithm Name Code Sequence (0066,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_NAME_CODE_SEQUENCE
Visual Basic
Public Const ALGORITHM_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_PARAMETERS Field
MCdicom Structure See Also Send Feedback
Algorithm Parameters (0066,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_PARAMETERS
Visual Basic
Public Const ALGORITHM_PARAMETERS As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_PARAMETERS

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_ROUTING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_ROUTING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Algorithm Routing Code Sequence (4010,1064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_ROUTING_CODE_SEQUENCE
Visual Basic
Public Const ALGORITHM_ROUTING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_ROUTING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_SOURCE Field
MCdicom Structure See Also Send Feedback
Algorithm Source (0024,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_SOURCE
Visual Basic
Public Const ALGORITHM_SOURCE As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_SOURCE

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_TYPE Field
MCdicom Structure See Also Send Feedback
Algorithm Type (0018,9527)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_TYPE
Visual Basic
Public Const ALGORITHM_TYPE As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_TYPE

See Also

MCdicom Structure
MCdicom Members


ALGORITHM_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALGORITHM_VERSION Field
MCdicom Structure See Also Send Feedback
Algorithm Version (0066,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALGORITHM_VERSION
Visual Basic
Public Const ALGORITHM_VERSION As UInteger
Visual C++
public:
literal unsigned int ALGORITHM_VERSION

See Also

MCdicom Structure
MCdicom Members


ALIASED_DATA_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALIASED_DATA_TYPE Field
MCdicom Structure See Also Send Feedback
Aliased Data Type (0018,980B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALIASED_DATA_TYPE
Visual Basic
Public Const ALIASED_DATA_TYPE As UInteger
Visual C++
public:
literal unsigned int ALIASED_DATA_TYPE

See Also

MCdicom Structure
MCdicom Members


ALLERGIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALLERGIES Field
MCdicom Structure See Also Send Feedback
Allergies (0010,2110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALLERGIES
Visual Basic
Public Const ALLERGIES As UInteger
Visual C++
public:
literal unsigned int ALLERGIES

See Also

MCdicom Structure
MCdicom Members


ALLOW_LOSSY_COMPRESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALLOW_LOSSY_COMPRESSION Field
MCdicom Structure See Also Send Feedback
Allow Lossy Compression (2200,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALLOW_LOSSY_COMPRESSION
Visual Basic
Public Const ALLOW_LOSSY_COMPRESSION As UInteger
Visual C++
public:
literal unsigned int ALLOW_LOSSY_COMPRESSION

See Also

MCdicom Structure
MCdicom Members


ALLOW_MEDIA_SPLITTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALLOW_MEDIA_SPLITTING Field
MCdicom Structure See Also Send Feedback
Allow Media Splitting (2200,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALLOW_MEDIA_SPLITTING
Visual Basic
Public Const ALLOW_MEDIA_SPLITTING As UInteger
Visual C++
public:
literal unsigned int ALLOW_MEDIA_SPLITTING

See Also

MCdicom Structure
MCdicom Members


ALONG_SCAN_SPATIAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALONG_SCAN_SPATIAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Along-scan Spatial Resolution (0022,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALONG_SCAN_SPATIAL_RESOLUTION
Visual Basic
Public Const ALONG_SCAN_SPATIAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int ALONG_SCAN_SPATIAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


ALPHA_LUT_TRANSFER_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALPHA_LUT_TRANSFER_FUNCTION Field
MCdicom Structure See Also Send Feedback
Alpha LUT Transfer Function (0028,1410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALPHA_LUT_TRANSFER_FUNCTION
Visual Basic
Public Const ALPHA_LUT_TRANSFER_FUNCTION As UInteger
Visual C++
public:
literal unsigned int ALPHA_LUT_TRANSFER_FUNCTION

See Also

MCdicom Structure
MCdicom Members


ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Alpha Palette Color Lookup Table Data (0028,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Alpha Palette Color Lookup Table Descriptor (0028,1104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_BEAM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_BEAM_DOSE Field
MCdicom Structure See Also Send Feedback
Alternate Beam Dose (300A,0091)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_BEAM_DOSE
Visual Basic
Public Const ALTERNATE_BEAM_DOSE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_BEAM_DOSE

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_BEAM_DOSE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_BEAM_DOSE_TYPE Field
MCdicom Structure See Also Send Feedback
Alternate Beam Dose Type (300A,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_BEAM_DOSE_TYPE
Visual Basic
Public Const ALTERNATE_BEAM_DOSE_TYPE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_BEAM_DOSE_TYPE

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alternate Container Identifier Sequence (0040,0515)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE
Visual Basic
Public Const ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_CONTAINER_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alternate Content Description Sequence (0070,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE
Visual Basic
Public Const ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_CONTENT_DESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_REPRESENTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_REPRESENTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alternate Representation Sequence (0008,3001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_REPRESENTATION_SEQUENCE
Visual Basic
Public Const ALTERNATE_REPRESENTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_REPRESENTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ALTERNATE_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ALTERNATE_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alternate Value Sequence (300A,073E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ALTERNATE_VALUE_SEQUENCE
Visual Basic
Public Const ALTERNATE_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ALTERNATE_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AMBIENT_LIGHT_VALUE_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AMBIENT_LIGHT_VALUE_SOURCE Field
MCdicom Structure See Also Send Feedback
Ambient Light Value Source (0028,7025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AMBIENT_LIGHT_VALUE_SOURCE
Visual Basic
Public Const AMBIENT_LIGHT_VALUE_SOURCE As UInteger
Visual C++
public:
literal unsigned int AMBIENT_LIGHT_VALUE_SOURCE

See Also

MCdicom Structure
MCdicom Members


AMBIENT_REFLECTION_INTENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AMBIENT_REFLECTION_INTENSITY Field
MCdicom Structure See Also Send Feedback
Ambient Reflection Intensity (0070,1702)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AMBIENT_REFLECTION_INTENSITY
Visual Basic
Public Const AMBIENT_REFLECTION_INTENSITY As UInteger
Visual C++
public:
literal unsigned int AMBIENT_REFLECTION_INTENSITY

See Also

MCdicom Structure
MCdicom Members


AMPLIFIER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AMPLIFIER_TYPE Field
MCdicom Structure See Also Send Feedback
Amplifier Type (0014,400A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AMPLIFIER_TYPE
Visual Basic
Public Const AMPLIFIER_TYPE As UInteger
Visual C++
public:
literal unsigned int AMPLIFIER_TYPE

See Also

MCdicom Structure
MCdicom Members


ANALOG_FILTER_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANALOG_FILTER_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Analog Filter Characteristics Sequence (003A,0323)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANALOG_FILTER_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const ANALOG_FILTER_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANALOG_FILTER_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANALOG_FILTER_ROLL_OFF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANALOG_FILTER_ROLL_OFF Field
MCdicom Structure See Also Send Feedback
Analog Filter Roll Off (003A,0324)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANALOG_FILTER_ROLL_OFF
Visual Basic
Public Const ANALOG_FILTER_ROLL_OFF As UInteger
Visual C++
public:
literal unsigned int ANALOG_FILTER_ROLL_OFF

See Also

MCdicom Structure
MCdicom Members


ANALOG_FILTER_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANALOG_FILTER_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Analog Filter Type Code Sequence (003A,0325)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANALOG_FILTER_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ANALOG_FILTER_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANALOG_FILTER_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANALYZED_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANALYZED_AREA Field
MCdicom Structure See Also Send Feedback
Analyzed Area (0046,0227)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANALYZED_AREA
Visual Basic
Public Const ANALYZED_AREA As UInteger
Visual C++
public:
literal unsigned int ANALYZED_AREA

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Approach Direction Code Sequence (Trial) RETIRED (0008,2255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_APPROACH_DIRECTION_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Location Of Examining Instrument Code Sequence (Trial) RETIRED (0008,2259)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Location Of Examining Instrument Description (Trial) RETIRED (0008,2258)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_LOCATION_OF_EXAMINING_INSTRUMENT_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Perspective Code Sequence (Trial) RETIRED (0008,2257)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_PERSPECTIVE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Perspective Description (Trial) RETIRED (0008,2256)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_PERSPECTIVE_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Portal Of Entrance Code Sequence (Trial) RETIRED (0008,2253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_PORTAL_OF_ENTRANCE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_REGION_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_REGION_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Anatomic Region Modifier Sequence (0008,2220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_REGION_MODIFIER_SEQUENCE
Visual Basic
Public Const ANATOMIC_REGION_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_REGION_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_REGION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_REGION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Anatomic Region Sequence (0008,2218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_REGION_SEQUENCE
Visual Basic
Public Const ANATOMIC_REGION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_REGION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Anatomic Regions in Study Code Sequence (0008,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE
Visual Basic
Public Const ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_REGIONS_IN_STUDY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_STRUCTURE_REFERENCE_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_STRUCTURE_REFERENCE_POINT Field
MCdicom Structure See Also Send Feedback
Anatomic Structure Reference Point (0022,1463)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_STRUCTURE_REFERENCE_POINT
Visual Basic
Public Const ANATOMIC_STRUCTURE_REFERENCE_POINT As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_STRUCTURE_REFERENCE_POINT

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_STRUCTURE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_STRUCTURE_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Structure RETIRED (0008,2208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_STRUCTURE_RETIRED
Visual Basic
Public Const ANATOMIC_STRUCTURE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_STRUCTURE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Structure Space Or Region Code Sequence (Trial) RETIRED (0008,2251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_STRUCTURE_SPACE_OR_REGION_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Structure Space Or Region Modifier Code Sequence (Trial) RETIRED (0008,225A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_STRUCTURE_SPACE_OR_REGION_MODIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Anatomic Structure Space or Region Sequence RETIRED (0008,2229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED
Visual Basic
Public Const ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANATOMIC_STRUCTURE_SPACE_OR_REGION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANATOMICAL_ORIENTATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANATOMICAL_ORIENTATION_TYPE Field
MCdicom Structure See Also Send Feedback
Anatomical Orientation Type (0010,2210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANATOMICAL_ORIENTATION_TYPE
Visual Basic
Public Const ANATOMICAL_ORIENTATION_TYPE As UInteger
Visual C++
public:
literal unsigned int ANATOMICAL_ORIENTATION_TYPE

See Also

MCdicom Structure
MCdicom Members


ANCHOR_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANCHOR_POINT Field
MCdicom Structure See Also Send Feedback
Anchor Point (0070,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANCHOR_POINT
Visual Basic
Public Const ANCHOR_POINT As UInteger
Visual C++
public:
literal unsigned int ANCHOR_POINT

See Also

MCdicom Structure
MCdicom Members


ANCHOR_POINT_ANNOTATION_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANCHOR_POINT_ANNOTATION_UNITS Field
MCdicom Structure See Also Send Feedback
Anchor Point Annotation Units (0070,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANCHOR_POINT_ANNOTATION_UNITS
Visual Basic
Public Const ANCHOR_POINT_ANNOTATION_UNITS As UInteger
Visual C++
public:
literal unsigned int ANCHOR_POINT_ANNOTATION_UNITS

See Also

MCdicom Structure
MCdicom Members


ANCHOR_POINT_VISIBILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANCHOR_POINT_VISIBILITY Field
MCdicom Structure See Also Send Feedback
Anchor Point Visibility (0070,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANCHOR_POINT_VISIBILITY
Visual Basic
Public Const ANCHOR_POINT_VISIBILITY As UInteger
Visual C++
public:
literal unsigned int ANCHOR_POINT_VISIBILITY

See Also

MCdicom Structure
MCdicom Members


ANGIO_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANGIO_FLAG Field
MCdicom Structure See Also Send Feedback
Angio Flag (0018,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANGIO_FLAG
Visual Basic
Public Const ANGIO_FLAG As UInteger
Visual C++
public:
literal unsigned int ANGIO_FLAG

See Also

MCdicom Structure
MCdicom Members


ANGLE_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANGLE_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Angle Number RETIRED (0020,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANGLE_NUMBER_RETIRED
Visual Basic
Public Const ANGLE_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANGLE_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANGULAR_POSITION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANGULAR_POSITION_RETIRED Field
MCdicom Structure See Also Send Feedback
Angular Position RETIRED (0018,1141)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANGULAR_POSITION_RETIRED
Visual Basic
Public Const ANGULAR_POSITION_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANGULAR_POSITION_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANGULAR_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANGULAR_STEP Field
MCdicom Structure See Also Send Feedback
Angular Step (0018,1144)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANGULAR_STEP
Visual Basic
Public Const ANGULAR_STEP As UInteger
Visual C++
public:
literal unsigned int ANGULAR_STEP

See Also

MCdicom Structure
MCdicom Members


ANGULAR_VIEW_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANGULAR_VIEW_VECTOR Field
MCdicom Structure See Also Send Feedback
Angular View Vector (0054,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANGULAR_VIEW_VECTOR
Visual Basic
Public Const ANGULAR_VIEW_VECTOR As UInteger
Visual C++
public:
literal unsigned int ANGULAR_VIEW_VECTOR

See Also

MCdicom Structure
MCdicom Members


ANIMATION_CURVE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANIMATION_CURVE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Animation Curve Sequence (0070,1A04)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANIMATION_CURVE_SEQUENCE
Visual Basic
Public Const ANIMATION_CURVE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANIMATION_CURVE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANIMATION_STEP_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANIMATION_STEP_SIZE Field
MCdicom Structure See Also Send Feedback
Animation Step Size (0070,1A05)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANIMATION_STEP_SIZE
Visual Basic
Public Const ANIMATION_STEP_SIZE As UInteger
Visual C++
public:
literal unsigned int ANIMATION_STEP_SIZE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS Field
MCdicom Structure See Also Send Feedback
Annotation Applies to All Optical Paths (006A,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS
Visual Basic
Public Const ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_APPLIES_TO_ALL_OPTICAL_PATHS

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_APPLIES_TO_ALL_Z_PLANES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_APPLIES_TO_ALL_Z_PLANES Field
MCdicom Structure See Also Send Feedback
Annotation Applies to All Z Planes (006A,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_APPLIES_TO_ALL_Z_PLANES
Visual Basic
Public Const ANNOTATION_APPLIES_TO_ALL_Z_PLANES As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_APPLIES_TO_ALL_Z_PLANES

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_CLIPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_CLIPPING Field
MCdicom Structure See Also Send Feedback
Annotation Clipping (0070,1907)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_CLIPPING
Visual Basic
Public Const ANNOTATION_CLIPPING As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_CLIPPING

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_CONTENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_CONTENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Annotation Content Sequence RETIRED (2130,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_CONTENT_SEQUENCE_RETIRED
Visual Basic
Public Const ANNOTATION_CONTENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_CONTENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_COORDINATE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_COORDINATE_TYPE Field
MCdicom Structure See Also Send Feedback
Annotation Coordinate Type (006A,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_COORDINATE_TYPE
Visual Basic
Public Const ANNOTATION_COORDINATE_TYPE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_COORDINATE_TYPE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_DISPLAY_FORMAT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_DISPLAY_FORMAT_ID Field
MCdicom Structure See Also Send Feedback
Annotation Display Format ID (2010,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_DISPLAY_FORMAT_ID
Visual Basic
Public Const ANNOTATION_DISPLAY_FORMAT_ID As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_DISPLAY_FORMAT_ID

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Annotation Flag RETIRED (2000,0065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_FLAG_RETIRED
Visual Basic
Public Const ANNOTATION_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Annotation Group Algorithm Identification Sequence (006A,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Annotation Group Description (006A,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_DESCRIPTION
Visual Basic
Public Const ANNOTATION_GROUP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_GENERATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_GENERATION_TYPE Field
MCdicom Structure See Also Send Feedback
Annotation Group Generation Type (006A,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_GENERATION_TYPE
Visual Basic
Public Const ANNOTATION_GROUP_GENERATION_TYPE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_GENERATION_TYPE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_LABEL Field
MCdicom Structure See Also Send Feedback
Annotation Group Label (006A,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_LABEL
Visual Basic
Public Const ANNOTATION_GROUP_LABEL As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_LABEL

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Annotation Group Number (0040,A180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_NUMBER
Visual Basic
Public Const ANNOTATION_GROUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Annotation Group Sequence (006A,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_SEQUENCE
Visual Basic
Public Const ANNOTATION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_GROUP_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_GROUP_UID Field
MCdicom Structure See Also Send Feedback
Annotation Group UID (006A,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_GROUP_UID
Visual Basic
Public Const ANNOTATION_GROUP_UID As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_GROUP_UID

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Annotation Index List (006A,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_INDEX_LIST
Visual Basic
Public Const ANNOTATION_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_POSITION Field
MCdicom Structure See Also Send Feedback
Annotation Position (2030,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_POSITION
Visual Basic
Public Const ANNOTATION_POSITION As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_POSITION

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Annotation Property Category Code Sequence (006A,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_PROPERTY_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Annotation Property Type Code Sequence (006A,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_PROPERTY_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Annotation Property Type Modifier Code Sequence (006A,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag WAVEFORM_ANNOTATION_SEQUENCE (0040,B020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANNOTATION_SEQUENCE
Visual Basic
Public Const ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANODE_TARGET_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANODE_TARGET_MATERIAL Field
MCdicom Structure See Also Send Feedback
Anode Target Material (0018,1191)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANODE_TARGET_MATERIAL
Visual Basic
Public Const ANODE_TARGET_MATERIAL As UInteger
Visual C++
public:
literal unsigned int ANODE_TARGET_MATERIAL

See Also

MCdicom Structure
MCdicom Members


ANTERIOR_CHAMBER_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANTERIOR_CHAMBER_DEPTH Field
MCdicom Structure See Also Send Feedback
Anterior Chamber Depth (0022,1131)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANTERIOR_CHAMBER_DEPTH
Visual Basic
Public Const ANTERIOR_CHAMBER_DEPTH As UInteger
Visual C++
public:
literal unsigned int ANTERIOR_CHAMBER_DEPTH

See Also

MCdicom Structure
MCdicom Members


ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Anterior Chamber Depth Definition Code Sequence (0022,1125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE
Visual Basic
Public Const ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANTERIOR_CHAMBER_DEPTH_DEFINITION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ANTERIOR_CHAMBER_DEPTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ANTERIOR_CHAMBER_DEPTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Anterior Chamber Depth Sequence (0022,1128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ANTERIOR_CHAMBER_DEPTH_SEQUENCE
Visual Basic
Public Const ANTERIOR_CHAMBER_DEPTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ANTERIOR_CHAMBER_DEPTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APERTURE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APERTURE_VALUE Field
MCdicom Structure See Also Send Feedback
Aperture Value (0016,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APERTURE_VALUE
Visual Basic
Public Const APERTURE_VALUE As UInteger
Visual C++
public:
literal unsigned int APERTURE_VALUE

See Also

MCdicom Structure
MCdicom Members


APEX_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APEX_POSITION Field
MCdicom Structure See Also Send Feedback
Apex Position (0020,9308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APEX_POSITION
Visual Basic
Public Const APEX_POSITION As UInteger
Visual C++
public:
literal unsigned int APEX_POSITION

See Also

MCdicom Structure
MCdicom Members


APPLICABLE_FRAME_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICABLE_FRAME_RANGE Field
MCdicom Structure See Also Send Feedback
Applicable Frame Range (0028,6102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICABLE_FRAME_RANGE
Visual Basic
Public Const APPLICABLE_FRAME_RANGE As UInteger
Visual C++
public:
literal unsigned int APPLICABLE_FRAME_RANGE

See Also

MCdicom Structure
MCdicom Members


APPLICABLE_SAFETY_STANDARD_AGENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICABLE_SAFETY_STANDARD_AGENCY Field
MCdicom Structure See Also Send Feedback
Applicable Safety Standard Agency (0018,9174)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICABLE_SAFETY_STANDARD_AGENCY
Visual Basic
Public Const APPLICABLE_SAFETY_STANDARD_AGENCY As UInteger
Visual C++
public:
literal unsigned int APPLICABLE_SAFETY_STANDARD_AGENCY

See Also

MCdicom Structure
MCdicom Members


APPLICABLE_SAFETY_STANDARD_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICABLE_SAFETY_STANDARD_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Applicable Safety Standard Description (0018,9175)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICABLE_SAFETY_STANDARD_DESCRIPTION
Visual Basic
Public Const APPLICABLE_SAFETY_STANDARD_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int APPLICABLE_SAFETY_STANDARD_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


APPLICATION_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Application Manufacturer (0018,9526)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_MANUFACTURER
Visual Basic
Public Const APPLICATION_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int APPLICATION_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


APPLICATION_MAXIMUM_REPAINT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_MAXIMUM_REPAINT_TIME Field
MCdicom Structure See Also Send Feedback
Application Maximum Repaint Time (0072,010E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_MAXIMUM_REPAINT_TIME
Visual Basic
Public Const APPLICATION_MAXIMUM_REPAINT_TIME As UInteger
Visual C++
public:
literal unsigned int APPLICATION_MAXIMUM_REPAINT_TIME

See Also

MCdicom Structure
MCdicom Members


APPLICATION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_NAME Field
MCdicom Structure See Also Send Feedback
Application Name (0018,9524)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_NAME
Visual Basic
Public Const APPLICATION_NAME As UInteger
Visual C++
public:
literal unsigned int APPLICATION_NAME

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_CHECK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_CHECK Field
MCdicom Structure See Also Send Feedback
Application Setup Check (3008,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_CHECK
Visual Basic
Public Const APPLICATION_SETUP_CHECK As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_CHECK

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Application Setup Manufacturer (300A,0238)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_MANUFACTURER
Visual Basic
Public Const APPLICATION_SETUP_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_NAME Field
MCdicom Structure See Also Send Feedback
Application Setup Name (300A,0236)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_NAME
Visual Basic
Public Const APPLICATION_SETUP_NAME As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_NAME

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Application Setup Number (300A,0234)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_NUMBER
Visual Basic
Public Const APPLICATION_SETUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Application Setup Sequence (300A,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_SEQUENCE
Visual Basic
Public Const APPLICATION_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APPLICATION_SETUP_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_SETUP_TYPE Field
MCdicom Structure See Also Send Feedback
Application Setup Type (300A,0232)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_SETUP_TYPE
Visual Basic
Public Const APPLICATION_SETUP_TYPE As UInteger
Visual C++
public:
literal unsigned int APPLICATION_SETUP_TYPE

See Also

MCdicom Structure
MCdicom Members


APPLICATION_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATION_VERSION Field
MCdicom Structure See Also Send Feedback
Application Version (0018,9525)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATION_VERSION
Visual Basic
Public Const APPLICATION_VERSION As UInteger
Visual C++
public:
literal unsigned int APPLICATION_VERSION

See Also

MCdicom Structure
MCdicom Members


APPLICATOINS_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOINS_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag APPLICATION_SETUP_SEQUENCE (300A,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOINS_SETUP_SEQUENCE
Visual Basic
Public Const APPLICATOINS_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPLICATOINS_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_APERTURE_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_APERTURE_SHAPE Field
MCdicom Structure See Also Send Feedback
Applicator Aperture Shape (300A,0432)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_APERTURE_SHAPE
Visual Basic
Public Const APPLICATOR_APERTURE_SHAPE As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_APERTURE_SHAPE

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Applicator Description (300A,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_DESCRIPTION
Visual Basic
Public Const APPLICATOR_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Applicator Geometry Sequence (300A,0431)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_GEOMETRY_SEQUENCE
Visual Basic
Public Const APPLICATOR_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_ID Field
MCdicom Structure See Also Send Feedback
Applicator ID (300A,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_ID
Visual Basic
Public Const APPLICATOR_ID As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_ID

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_OPENING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_OPENING Field
MCdicom Structure See Also Send Feedback
Applicator Opening (300A,0433)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_OPENING
Visual Basic
Public Const APPLICATOR_OPENING As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_OPENING

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_OPENING_X Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_OPENING_X Field
MCdicom Structure See Also Send Feedback
Applicator Opening X (300A,0434)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_OPENING_X
Visual Basic
Public Const APPLICATOR_OPENING_X As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_OPENING_X

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_OPENING_Y Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_OPENING_Y Field
MCdicom Structure See Also Send Feedback
Applicator Opening Y (300A,0435)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_OPENING_Y
Visual Basic
Public Const APPLICATOR_OPENING_Y As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_OPENING_Y

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Applicator Sequence (300A,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_SEQUENCE
Visual Basic
Public Const APPLICATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER Field
MCdicom Structure See Also Send Feedback
Applicator Shape Referenced ROI Number (300A,02A1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER
Visual Basic
Public Const APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_SHAPE_REFERENCED_ROI_NUMBER

See Also

MCdicom Structure
MCdicom Members


APPLICATOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLICATOR_TYPE Field
MCdicom Structure See Also Send Feedback
Applicator Type (300A,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLICATOR_TYPE
Visual Basic
Public Const APPLICATOR_TYPE As UInteger
Visual C++
public:
literal unsigned int APPLICATOR_TYPE

See Also

MCdicom Structure
MCdicom Members


APPLIED_MASK_SUBTRACTION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPLIED_MASK_SUBTRACTION_FLAG Field
MCdicom Structure See Also Send Feedback
Applied Mask Subtraction Flag (0018,11C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPLIED_MASK_SUBTRACTION_FLAG
Visual Basic
Public Const APPLIED_MASK_SUBTRACTION_FLAG As UInteger
Visual C++
public:
literal unsigned int APPLIED_MASK_SUBTRACTION_FLAG

See Also

MCdicom Structure
MCdicom Members


APPROVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPROVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Approval Sequence (0044,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPROVAL_SEQUENCE
Visual Basic
Public Const APPROVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPROVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


APPROVAL_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPROVAL_STATUS Field
MCdicom Structure See Also Send Feedback
Approval Status (300E,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPROVAL_STATUS
Visual Basic
Public Const APPROVAL_STATUS As UInteger
Visual C++
public:
literal unsigned int APPROVAL_STATUS

See Also

MCdicom Structure
MCdicom Members


APPROVAL_STATUS_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPROVAL_STATUS_DATETIME Field
MCdicom Structure See Also Send Feedback
Approval Status DateTime (0044,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPROVAL_STATUS_DATETIME
Visual Basic
Public Const APPROVAL_STATUS_DATETIME As UInteger
Visual C++
public:
literal unsigned int APPROVAL_STATUS_DATETIME

See Also

MCdicom Structure
MCdicom Members


APPROVAL_STATUS_FURTHER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPROVAL_STATUS_FURTHER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Approval Status Further Description (0044,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPROVAL_STATUS_FURTHER_DESCRIPTION
Visual Basic
Public Const APPROVAL_STATUS_FURTHER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int APPROVAL_STATUS_FURTHER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


APPROVAL_SUBJECT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..APPROVAL_SUBJECT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Approval Subject Sequence (0044,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint APPROVAL_SUBJECT_SEQUENCE
Visual Basic
Public Const APPROVAL_SUBJECT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int APPROVAL_SUBJECT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ARBITRARY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ARBITRARY_RETIRED Field
MCdicom Structure See Also Send Feedback
Arbitrary RETIRED (4000,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ARBITRARY_RETIRED
Visual Basic
Public Const ARBITRARY_RETIRED As UInteger
Visual C++
public:
literal unsigned int ARBITRARY_RETIRED

See Also

MCdicom Structure
MCdicom Members


ARCHIVE_REQUESTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ARCHIVE_REQUESTED Field
MCdicom Structure See Also Send Feedback
Archive Requested (0040,A494)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ARCHIVE_REQUESTED
Visual Basic
Public Const ARCHIVE_REQUESTED As UInteger
Visual C++
public:
literal unsigned int ARCHIVE_REQUESTED

See Also

MCdicom Structure
MCdicom Members


ARTERIAL_SPIN_LABELING_CONTRAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ARTERIAL_SPIN_LABELING_CONTRAST Field
MCdicom Structure See Also Send Feedback
Arterial Spin Labeling Contrast (0018,9250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ARTERIAL_SPIN_LABELING_CONTRAST
Visual Basic
Public Const ARTERIAL_SPIN_LABELING_CONTRAST As UInteger
Visual C++
public:
literal unsigned int ARTERIAL_SPIN_LABELING_CONTRAST

See Also

MCdicom Structure
MCdicom Members


ASL_BOLUS_CUT_OFF_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_BOLUS_CUT_OFF_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
ASL Bolus Cut-off Delay Time (0018,925F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_BOLUS_CUT_OFF_DELAY_TIME
Visual Basic
Public Const ASL_BOLUS_CUT_OFF_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int ASL_BOLUS_CUT_OFF_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


ASL_BOLUS_CUT_OFF_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_BOLUS_CUT_OFF_FLAG Field
MCdicom Structure See Also Send Feedback
ASL Bolus Cut-off Flag (0018,925C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_BOLUS_CUT_OFF_FLAG
Visual Basic
Public Const ASL_BOLUS_CUT_OFF_FLAG As UInteger
Visual C++
public:
literal unsigned int ASL_BOLUS_CUT_OFF_FLAG

See Also

MCdicom Structure
MCdicom Members


ASL_BOLUS_CUT_OFF_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_BOLUS_CUT_OFF_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
ASL Bolus Cut-off Technique (0018,925E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_BOLUS_CUT_OFF_TECHNIQUE
Visual Basic
Public Const ASL_BOLUS_CUT_OFF_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int ASL_BOLUS_CUT_OFF_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ASL Bolus Cut-off Timing Sequence (0018,925D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE
Visual Basic
Public Const ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASL_BOLUS_CUT_OFF_TIMING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASL_CONTEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_CONTEXT Field
MCdicom Structure See Also Send Feedback
ASL Context (0018,9257)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_CONTEXT
Visual Basic
Public Const ASL_CONTEXT As UInteger
Visual C++
public:
literal unsigned int ASL_CONTEXT

See Also

MCdicom Structure
MCdicom Members


ASL_CRUSHER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_CRUSHER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
ASL Crusher Description (0018,925B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_CRUSHER_DESCRIPTION
Visual Basic
Public Const ASL_CRUSHER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ASL_CRUSHER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ASL_CRUSHER_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_CRUSHER_FLAG Field
MCdicom Structure See Also Send Feedback
ASL Crusher Flag (0018,9259)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_CRUSHER_FLAG
Visual Basic
Public Const ASL_CRUSHER_FLAG As UInteger
Visual C++
public:
literal unsigned int ASL_CRUSHER_FLAG

See Also

MCdicom Structure
MCdicom Members


ASL_CRUSHER_FLOW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_CRUSHER_FLOW Field
MCdicom Structure See Also Send Feedback
Alias for tag ASL_CRUSHER_FLOW_LIMIT (0018,925A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_CRUSHER_FLOW
Visual Basic
Public Const ASL_CRUSHER_FLOW As UInteger
Visual C++
public:
literal unsigned int ASL_CRUSHER_FLOW

See Also

MCdicom Structure
MCdicom Members


ASL_CRUSHER_FLOW_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_CRUSHER_FLOW_LIMIT Field
MCdicom Structure See Also Send Feedback
ASL Crusher Flow Limit (0018,925A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_CRUSHER_FLOW_LIMIT
Visual Basic
Public Const ASL_CRUSHER_FLOW_LIMIT As UInteger
Visual C++
public:
literal unsigned int ASL_CRUSHER_FLOW_LIMIT

See Also

MCdicom Structure
MCdicom Members


ASL_MID_SLAB_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_MID_SLAB_POSITION Field
MCdicom Structure See Also Send Feedback
ASL Mid Slab Position (0018,9256)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_MID_SLAB_POSITION
Visual Basic
Public Const ASL_MID_SLAB_POSITION As UInteger
Visual C++
public:
literal unsigned int ASL_MID_SLAB_POSITION

See Also

MCdicom Structure
MCdicom Members


ASL_PULSE_TRAIN_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_PULSE_TRAIN_DURATION Field
MCdicom Structure See Also Send Feedback
ASL Pulse Train Duration (0018,9258)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_PULSE_TRAIN_DURATION
Visual Basic
Public Const ASL_PULSE_TRAIN_DURATION As UInteger
Visual C++
public:
literal unsigned int ASL_PULSE_TRAIN_DURATION

See Also

MCdicom Structure
MCdicom Members


ASL_SLAB_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_SLAB_NUMBER Field
MCdicom Structure See Also Send Feedback
ASL Slab Number (0018,9253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_SLAB_NUMBER
Visual Basic
Public Const ASL_SLAB_NUMBER As UInteger
Visual C++
public:
literal unsigned int ASL_SLAB_NUMBER

See Also

MCdicom Structure
MCdicom Members


ASL_SLAB_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_SLAB_ORIENTATION Field
MCdicom Structure See Also Send Feedback
ASL Slab Orientation (0018,9255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_SLAB_ORIENTATION
Visual Basic
Public Const ASL_SLAB_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int ASL_SLAB_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


ASL_SLAB_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_SLAB_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ASL Slab Sequence (0018,9260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_SLAB_SEQUENCE
Visual Basic
Public Const ASL_SLAB_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASL_SLAB_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASL_SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
ASL Slab Thickness (0018,9254)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_SLAB_THICKNESS
Visual Basic
Public Const ASL_SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int ASL_SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


ASL_TECHNIQUE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASL_TECHNIQUE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
ASL Technique Description (0018,9252)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASL_TECHNIQUE_DESCRIPTION
Visual Basic
Public Const ASL_TECHNIQUE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ASL_TECHNIQUE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ASSERTER_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTER_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Asserter Identification Sequence (0044,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTER_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const ASSERTER_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSERTER_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSERTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assertion Code Sequence (0044,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTION_CODE_SEQUENCE
Visual Basic
Public Const ASSERTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSERTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSERTION_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTION_COMMENTS Field
MCdicom Structure See Also Send Feedback
Assertion Comments (0044,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTION_COMMENTS
Visual Basic
Public Const ASSERTION_COMMENTS As UInteger
Visual C++
public:
literal unsigned int ASSERTION_COMMENTS

See Also

MCdicom Structure
MCdicom Members


ASSERTION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTION_DATETIME Field
MCdicom Structure See Also Send Feedback
Assertion DateTime (0044,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTION_DATETIME
Visual Basic
Public Const ASSERTION_DATETIME As UInteger
Visual C++
public:
literal unsigned int ASSERTION_DATETIME

See Also

MCdicom Structure
MCdicom Members


ASSERTION_EXPIRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTION_EXPIRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Assertion Expiration DateTime (0044,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTION_EXPIRATION_DATETIME
Visual Basic
Public Const ASSERTION_EXPIRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int ASSERTION_EXPIRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


ASSERTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSERTION_UID Field
MCdicom Structure See Also Send Feedback
Assertion UID (0044,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSERTION_UID
Visual Basic
Public Const ASSERTION_UID As UInteger
Visual C++
public:
literal unsigned int ASSERTION_UID

See Also

MCdicom Structure
MCdicom Members


ASSESSED_ATTRIBUTE_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSED_ATTRIBUTE_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assessed Attribute Value Sequence (0082,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSED_ATTRIBUTE_VALUE_SEQUENCE
Visual Basic
Public Const ASSESSED_ATTRIBUTE_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSESSED_ATTRIBUTE_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSESSED_SOP_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSED_SOP_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assessed SOP Instance Sequence (0082,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSED_SOP_INSTANCE_SEQUENCE
Visual Basic
Public Const ASSESSED_SOP_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSESSED_SOP_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_LABEL Field
MCdicom Structure See Also Send Feedback
Assessment Label (0082,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_LABEL
Visual Basic
Public Const ASSESSMENT_LABEL As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_LABEL

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_OBSERVATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_OBSERVATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assessment Observations Sequence (0082,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_OBSERVATIONS_SEQUENCE
Visual Basic
Public Const ASSESSMENT_OBSERVATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_OBSERVATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_REQUESTER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_REQUESTER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assessment Requester Sequence (0082,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_REQUESTER_SEQUENCE
Visual Basic
Public Const ASSESSMENT_REQUESTER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_REQUESTER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_SET_ID Field
MCdicom Structure See Also Send Feedback
Assessment Set ID (0082,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_SET_ID
Visual Basic
Public Const ASSESSMENT_SET_ID As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_SET_ID

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_SUMMARY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_SUMMARY Field
MCdicom Structure See Also Send Feedback
Assessment Summary (0082,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_SUMMARY
Visual Basic
Public Const ASSESSMENT_SUMMARY As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_SUMMARY

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_SUMMARY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_SUMMARY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Assessment Summary Description (0082,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_SUMMARY_DESCRIPTION
Visual Basic
Public Const ASSESSMENT_SUMMARY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_SUMMARY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ASSESSMENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSESSMENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assessment Type Code Sequence (0082,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSESSMENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ASSESSMENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSESSMENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSIGNED_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSIGNED_LOCATION Field
MCdicom Structure See Also Send Feedback
Assigned Location (4010,102A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSIGNED_LOCATION
Visual Basic
Public Const ASSIGNED_LOCATION As UInteger
Visual C++
public:
literal unsigned int ASSIGNED_LOCATION

See Also

MCdicom Structure
MCdicom Members


ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assigning Agency or Department Code Sequence (0040,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE
Visual Basic
Public Const ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSIGNING_AGENCY_OR_DEPARTMENT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSIGNING_FACILITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSIGNING_FACILITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assigning Facility Sequence (0040,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSIGNING_FACILITY_SEQUENCE
Visual Basic
Public Const ASSIGNING_FACILITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSIGNING_FACILITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ASSIGNING_JURISDICTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ASSIGNING_JURISDICTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Assigning Jurisdiction Code Sequence (0040,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ASSIGNING_JURISDICTION_CODE_SEQUENCE
Visual Basic
Public Const ASSIGNING_JURISDICTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ASSIGNING_JURISDICTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ATD_ABILITY_ASSESSMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATD_ABILITY_ASSESSMENT Field
MCdicom Structure See Also Send Feedback
ATD Ability Assessment (4010,1014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATD_ABILITY_ASSESSMENT
Visual Basic
Public Const ATD_ABILITY_ASSESSMENT As UInteger
Visual C++
public:
literal unsigned int ATD_ABILITY_ASSESSMENT

See Also

MCdicom Structure
MCdicom Members


ATD_ASSESSMENT_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATD_ASSESSMENT_FLAG Field
MCdicom Structure See Also Send Feedback
ATD Assessment Flag (4010,1015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATD_ASSESSMENT_FLAG
Visual Basic
Public Const ATD_ASSESSMENT_FLAG As UInteger
Visual C++
public:
literal unsigned int ATD_ASSESSMENT_FLAG

See Also

MCdicom Structure
MCdicom Members


ATD_ASSESSMENT_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATD_ASSESSMENT_PROBABILITY Field
MCdicom Structure See Also Send Feedback
ATD Assessment Probability (4010,1016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATD_ASSESSMENT_PROBABILITY
Visual Basic
Public Const ATD_ASSESSMENT_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int ATD_ASSESSMENT_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


ATD_ASSESSMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATD_ASSESSMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ATD Assessment Sequence (4010,1038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATD_ASSESSMENT_SEQUENCE
Visual Basic
Public Const ATD_ASSESSMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ATD_ASSESSMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ATTACHED_CONTOURS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTACHED_CONTOURS_RETIRED Field
MCdicom Structure See Also Send Feedback
Attached Contours RETIRED (3006,0049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTACHED_CONTOURS_RETIRED
Visual Basic
Public Const ATTACHED_CONTOURS_RETIRED As UInteger
Visual C++
public:
literal unsigned int ATTACHED_CONTOURS_RETIRED

See Also

MCdicom Structure
MCdicom Members


ATTENUATION_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTENUATION_CORRECTED Field
MCdicom Structure See Also Send Feedback
Attenuation Corrected (0018,9759)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTENUATION_CORRECTED
Visual Basic
Public Const ATTENUATION_CORRECTED As UInteger
Visual C++
public:
literal unsigned int ATTENUATION_CORRECTED

See Also

MCdicom Structure
MCdicom Members


ATTENUATION_CORRECTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTENUATION_CORRECTION_METHOD Field
MCdicom Structure See Also Send Feedback
Attenuation Correction Method (0054,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTENUATION_CORRECTION_METHOD
Visual Basic
Public Const ATTENUATION_CORRECTION_METHOD As UInteger
Visual C++
public:
literal unsigned int ATTENUATION_CORRECTION_METHOD

See Also

MCdicom Structure
MCdicom Members


ATTENUATION_CORRECTION_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTENUATION_CORRECTION_SOURCE Field
MCdicom Structure See Also Send Feedback
Attenuation Correction Source (0018,9738)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTENUATION_CORRECTION_SOURCE
Visual Basic
Public Const ATTENUATION_CORRECTION_SOURCE As UInteger
Visual C++
public:
literal unsigned int ATTENUATION_CORRECTION_SOURCE

See Also

MCdicom Structure
MCdicom Members


ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
Attenuation Correction Temporal Relationship (0018,9770)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP
Visual Basic
Public Const ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int ATTENUATION_CORRECTION_TEMPORAL_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_IDENTIFIER_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_IDENTIFIER_LIST Field
MCdicom Structure See Also Send Feedback
Attribute Identifier List (0000,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_IDENTIFIER_LIST
Visual Basic
Public Const ATTRIBUTE_IDENTIFIER_LIST As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_IDENTIFIER_LIST

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_ITEM_SELECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_ITEM_SELECTOR Field
MCdicom Structure See Also Send Feedback
Attribute Item Selector (0074,1054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_ITEM_SELECTOR
Visual Basic
Public Const ATTRIBUTE_ITEM_SELECTOR As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_ITEM_SELECTOR

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_MODIFICATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_MODIFICATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Attribute Modification DateTime (0400,0562)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_MODIFICATION_DATETIME
Visual Basic
Public Const ATTRIBUTE_MODIFICATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_MODIFICATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_OCCURRENCE_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_OCCURRENCE_POINTER Field
MCdicom Structure See Also Send Feedback
Attribute Occurrence Pointer (0074,1052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_OCCURRENCE_POINTER
Visual Basic
Public Const ATTRIBUTE_OCCURRENCE_POINTER As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_OCCURRENCE_POINTER

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR Field
MCdicom Structure See Also Send Feedback
Attribute Occurrence Private Creator (0074,1056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR
Visual Basic
Public Const ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_OCCURRENCE_PRIVATE_CREATOR

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_OCCURRENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_OCCURRENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Attribute Occurrence Sequence (0074,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_OCCURRENCE_SEQUENCE
Visual Basic
Public Const ATTRIBUTE_OCCURRENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_OCCURRENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Attribute Tolerance Values Sequence (300A,062B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE
Visual Basic
Public Const ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ATTRIBUTE_TOLERANCE_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AUDIO_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUDIO_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Audio Comments RETIRED (5000,200E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUDIO_COMMENTS_RETIRED
Visual Basic
Public Const AUDIO_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int AUDIO_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


AUDIO_SAMPLE_DATA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUDIO_SAMPLE_DATA_RETIRED Field
MCdicom Structure See Also Send Feedback
Audio Sample Data RETIRED (5000,200C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUDIO_SAMPLE_DATA_RETIRED
Visual Basic
Public Const AUDIO_SAMPLE_DATA_RETIRED As UInteger
Visual C++
public:
literal unsigned int AUDIO_SAMPLE_DATA_RETIRED

See Also

MCdicom Structure
MCdicom Members


AUDIO_SAMPLE_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUDIO_SAMPLE_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
Audio Sample Format RETIRED (5000,2002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUDIO_SAMPLE_FORMAT_RETIRED
Visual Basic
Public Const AUDIO_SAMPLE_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int AUDIO_SAMPLE_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


AUDIO_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUDIO_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Audio Type RETIRED (5000,2000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUDIO_TYPE_RETIRED
Visual Basic
Public Const AUDIO_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int AUDIO_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


AUTHOR_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTHOR_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Author Identification Sequence (3010,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTHOR_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const AUTHOR_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int AUTHOR_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AUTHOR_OBSERVER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTHOR_OBSERVER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Author Observer Sequence (0040,A078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTHOR_OBSERVER_SEQUENCE
Visual Basic
Public Const AUTHOR_OBSERVER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int AUTHOR_OBSERVER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER Field
MCdicom Structure See Also Send Feedback
Authorization Equipment Certification Number (0100,0426)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER
Visual Basic
Public Const AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int AUTHORIZATION_EQUIPMENT_CERTIFICATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


AUTO_KVP_LOWER_BOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTO_KVP_LOWER_BOUND Field
MCdicom Structure See Also Send Feedback
Auto KVP Lower Bound (0018,9946)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTO_KVP_LOWER_BOUND
Visual Basic
Public Const AUTO_KVP_LOWER_BOUND As UInteger
Visual C++
public:
literal unsigned int AUTO_KVP_LOWER_BOUND

See Also

MCdicom Structure
MCdicom Members


AUTO_KVP_SELECTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTO_KVP_SELECTION_TYPE Field
MCdicom Structure See Also Send Feedback
Auto KVP Selection Type (0018,9944)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTO_KVP_SELECTION_TYPE
Visual Basic
Public Const AUTO_KVP_SELECTION_TYPE As UInteger
Visual C++
public:
literal unsigned int AUTO_KVP_SELECTION_TYPE

See Also

MCdicom Structure
MCdicom Members


AUTO_KVP_UPPER_BOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTO_KVP_UPPER_BOUND Field
MCdicom Structure See Also Send Feedback
Auto KVP Upper Bound (0018,9945)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTO_KVP_UPPER_BOUND
Visual Basic
Public Const AUTO_KVP_UPPER_BOUND As UInteger
Visual C++
public:
literal unsigned int AUTO_KVP_UPPER_BOUND

See Also

MCdicom Structure
MCdicom Members


AUTOREFRACTION_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTOREFRACTION_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Autorefraction Left Eye Sequence (0046,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTOREFRACTION_LEFT_EYE_SEQUENCE
Visual Basic
Public Const AUTOREFRACTION_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int AUTOREFRACTION_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AUTOREFRACTION_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTOREFRACTION_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Autorefraction Right Eye Sequence (0046,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTOREFRACTION_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const AUTOREFRACTION_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int AUTOREFRACTION_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


AUTOSEQUENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AUTOSEQUENCE_FLAG Field
MCdicom Structure See Also Send Feedback
Autosequence Flag (0074,1025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AUTOSEQUENCE_FLAG
Visual Basic
Public Const AUTOSEQUENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int AUTOSEQUENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


AVAILABLE_TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVAILABLE_TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
Available Transfer Syntax UID (0008,3002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVAILABLE_TRANSFER_SYNTAX_UID
Visual Basic
Public Const AVAILABLE_TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int AVAILABLE_TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Average Beam Dose Point Depth RETIRED (300A,008D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED
Visual Basic
Public Const AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int AVERAGE_BEAM_DOSE_POINT_DEPTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Average Beam Dose Point Equivalent Depth RETIRED (300A,008E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED
Visual Basic
Public Const AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int AVERAGE_BEAM_DOSE_POINT_EQUIVALENT_DEPTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Average Beam Dose Point Source to External Contour Distance (300A,0131)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE
Visual Basic
Public Const AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int AVERAGE_BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED Field
MCdicom Structure See Also Send Feedback
Average Beam Dose Point SSD RETIRED (300A,008F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED
Visual Basic
Public Const AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED As UInteger
Visual C++
public:
literal unsigned int AVERAGE_BEAM_DOSE_POINT_SSD_RETIRED

See Also

MCdicom Structure
MCdicom Members


AVERAGE_CORNEAL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_CORNEAL_POWER Field
MCdicom Structure See Also Send Feedback
Average Corneal Power (0046,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_CORNEAL_POWER
Visual Basic
Public Const AVERAGE_CORNEAL_POWER As UInteger
Visual C++
public:
literal unsigned int AVERAGE_CORNEAL_POWER

See Also

MCdicom Structure
MCdicom Members


AVERAGE_PULSE_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AVERAGE_PULSE_WIDTH Field
MCdicom Structure See Also Send Feedback
Average Pulse Width (0018,1154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AVERAGE_PULSE_WIDTH
Visual Basic
Public Const AVERAGE_PULSE_WIDTH As UInteger
Visual C++
public:
literal unsigned int AVERAGE_PULSE_WIDTH

See Also

MCdicom Structure
MCdicom Members


AXIAL_ACCEPTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_ACCEPTANCE Field
MCdicom Structure See Also Send Feedback
Axial Acceptance (0054,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_ACCEPTANCE
Visual Basic
Public Const AXIAL_ACCEPTANCE As UInteger
Visual C++
public:
literal unsigned int AXIAL_ACCEPTANCE

See Also

MCdicom Structure
MCdicom Members


AXIAL_DETECTOR_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_DETECTOR_DIMENSION Field
MCdicom Structure See Also Send Feedback
Axial Detector Dimension (0018,9727)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_DETECTOR_DIMENSION
Visual Basic
Public Const AXIAL_DETECTOR_DIMENSION As UInteger
Visual C++
public:
literal unsigned int AXIAL_DETECTOR_DIMENSION

See Also

MCdicom Structure
MCdicom Members


AXIAL_LENGTH_OF_THE_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_LENGTH_OF_THE_EYE Field
MCdicom Structure See Also Send Feedback
Axial Length of the Eye (0022,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_LENGTH_OF_THE_EYE
Visual Basic
Public Const AXIAL_LENGTH_OF_THE_EYE As UInteger
Visual C++
public:
literal unsigned int AXIAL_LENGTH_OF_THE_EYE

See Also

MCdicom Structure
MCdicom Members


AXIAL_MASH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_MASH Field
MCdicom Structure See Also Send Feedback
Axial Mash (0054,1201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_MASH
Visual Basic
Public Const AXIAL_MASH As UInteger
Visual C++
public:
literal unsigned int AXIAL_MASH

See Also

MCdicom Structure
MCdicom Members


AXIAL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_POWER Field
MCdicom Structure See Also Send Feedback
Axial Power (0046,0249)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_POWER
Visual Basic
Public Const AXIAL_POWER As UInteger
Visual C++
public:
literal unsigned int AXIAL_POWER

See Also

MCdicom Structure
MCdicom Members


AXIAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Axial Resolution (0052,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIAL_RESOLUTION
Visual Basic
Public Const AXIAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int AXIAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


AXIS_LABELS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIS_LABELS_RETIRED Field
MCdicom Structure See Also Send Feedback
Axis Labels RETIRED (5000,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIS_LABELS_RETIRED
Visual Basic
Public Const AXIS_LABELS_RETIRED As UInteger
Visual C++
public:
literal unsigned int AXIS_LABELS_RETIRED

See Also

MCdicom Structure
MCdicom Members


AXIS_OF_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIS_OF_ROTATION Field
MCdicom Structure See Also Send Feedback
Axis of Rotation (0066,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIS_OF_ROTATION
Visual Basic
Public Const AXIS_OF_ROTATION As UInteger
Visual C++
public:
literal unsigned int AXIS_OF_ROTATION

See Also

MCdicom Structure
MCdicom Members


AXIS_UNITS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..AXIS_UNITS_RETIRED Field
MCdicom Structure See Also Send Feedback
Axis Units RETIRED (5000,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint AXIS_UNITS_RETIRED
Visual Basic
Public Const AXIS_UNITS_RETIRED As UInteger
Visual C++
public:
literal unsigned int AXIS_UNITS_RETIRED

See Also

MCdicom Structure
MCdicom Members


B_SCAN_CYCLE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..B_SCAN_CYCLE_TIME Field
MCdicom Structure See Also Send Feedback
B-scan Cycle Time (0022,1645)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint B_SCAN_CYCLE_TIME
Visual Basic
Public Const B_SCAN_CYCLE_TIME As UInteger
Visual C++
public:
literal unsigned int B_SCAN_CYCLE_TIME

See Also

MCdicom Structure
MCdicom Members


B_SCAN_CYCLE_TIME_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..B_SCAN_CYCLE_TIME_VECTOR Field
MCdicom Structure See Also Send Feedback
B-scan Cycle Time Vector (0022,1646)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint B_SCAN_CYCLE_TIME_VECTOR
Visual Basic
Public Const B_SCAN_CYCLE_TIME_VECTOR As UInteger
Visual C++
public:
literal unsigned int B_SCAN_CYCLE_TIME_VECTOR

See Also

MCdicom Structure
MCdicom Members


B_SCAN_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..B_SCAN_RATE Field
MCdicom Structure See Also Send Feedback
B-scan Rate (0022,1650)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint B_SCAN_RATE
Visual Basic
Public Const B_SCAN_RATE As UInteger
Visual C++
public:
literal unsigned int B_SCAN_RATE

See Also

MCdicom Structure
MCdicom Members


B_SCAN_SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..B_SCAN_SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
B-scan Slab Thickness (0022,1643)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint B_SCAN_SLAB_THICKNESS
Visual Basic
Public Const B_SCAN_SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int B_SCAN_SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


B1RMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..B1RMS Field
MCdicom Structure See Also Send Feedback
B1rms (0018,1320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint B1RMS
Visual Basic
Public Const B1RMS As UInteger
Visual C++
public:
literal unsigned int B1RMS

See Also

MCdicom Structure
MCdicom Members


BACKGROUND_COLOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BACKGROUND_COLOR Field
MCdicom Structure See Also Send Feedback
Background Color (0046,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BACKGROUND_COLOR
Visual Basic
Public Const BACKGROUND_COLOR As UInteger
Visual C++
public:
literal unsigned int BACKGROUND_COLOR

See Also

MCdicom Structure
MCdicom Members


BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Background Illumination Color Code Sequence (0024,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE
Visual Basic
Public Const BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BACKGROUND_ILLUMINATION_COLOR_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BACKGROUND_LUMINANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BACKGROUND_LUMINANCE Field
MCdicom Structure See Also Send Feedback
Background Luminance (0024,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BACKGROUND_LUMINANCE
Visual Basic
Public Const BACKGROUND_LUMINANCE As UInteger
Visual C++
public:
literal unsigned int BACKGROUND_LUMINANCE

See Also

MCdicom Structure
MCdicom Members


BAD_PIXEL_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BAD_PIXEL_IMAGE Field
MCdicom Structure See Also Send Feedback
Bad Pixel Image (0014,3080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BAD_PIXEL_IMAGE
Visual Basic
Public Const BAD_PIXEL_IMAGE As UInteger
Visual C++
public:
literal unsigned int BAD_PIXEL_IMAGE

See Also

MCdicom Structure
MCdicom Members


BARCODE_SYMBOLOGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BARCODE_SYMBOLOGY Field
MCdicom Structure See Also Send Feedback
Barcode Symbology (2200,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BARCODE_SYMBOLOGY
Visual Basic
Public Const BARCODE_SYMBOLOGY As UInteger
Visual C++
public:
literal unsigned int BARCODE_SYMBOLOGY

See Also

MCdicom Structure
MCdicom Members


BARCODE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BARCODE_VALUE Field
MCdicom Structure See Also Send Feedback
Barcode Value (2200,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BARCODE_VALUE
Visual Basic
Public Const BARCODE_VALUE As UInteger
Visual C++
public:
literal unsigned int BARCODE_VALUE

See Also

MCdicom Structure
MCdicom Members


BASELINE_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BASELINE_CORRECTION Field
MCdicom Structure See Also Send Feedback
Baseline Correction (0018,9067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BASELINE_CORRECTION
Visual Basic
Public Const BASELINE_CORRECTION As UInteger
Visual C++
public:
literal unsigned int BASELINE_CORRECTION

See Also

MCdicom Structure
MCdicom Members


BASIC_COLOR_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BASIC_COLOR_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Basic Color Image Sequence (2020,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BASIC_COLOR_IMAGE_SEQUENCE
Visual Basic
Public Const BASIC_COLOR_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BASIC_COLOR_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BASIC_GRAYSCALE_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BASIC_GRAYSCALE_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Basic Grayscale Image Sequence (2020,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BASIC_GRAYSCALE_IMAGE_SEQUENCE
Visual Basic
Public Const BASIC_GRAYSCALE_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BASIC_GRAYSCALE_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BASIS_MATERIALS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BASIS_MATERIALS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Basis Materials Code Sequence (4010,1045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BASIS_MATERIALS_CODE_SEQUENCE
Visual Basic
Public Const BASIS_MATERIALS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BASIS_MATERIALS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BASIS_RT_TREATMENT_PHASE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BASIS_RT_TREATMENT_PHASE_INDEX Field
MCdicom Structure See Also Send Feedback
Basis RT Treatment Phase Index (3010,003E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BASIS_RT_TREATMENT_PHASE_INDEX
Visual Basic
Public Const BASIS_RT_TREATMENT_PHASE_INDEX As UInteger
Visual C++
public:
literal unsigned int BASIS_RT_TREATMENT_PHASE_INDEX

See Also

MCdicom Structure
MCdicom Members


BATTERY_LEVEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BATTERY_LEVEL Field
MCdicom Structure See Also Send Feedback
Battery Level (0016,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BATTERY_LEVEL
Visual Basic
Public Const BATTERY_LEVEL As UInteger
Visual C++
public:
literal unsigned int BATTERY_LEVEL

See Also

MCdicom Structure
MCdicom Members


BEAM_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_ANGLE Field
MCdicom Structure See Also Send Feedback
Beam Angle (0018,9449)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_ANGLE
Visual Basic
Public Const BEAM_ANGLE As UInteger
Visual C++
public:
literal unsigned int BEAM_ANGLE

See Also

MCdicom Structure
MCdicom Members


BEAM_AREA_LIMIT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_AREA_LIMIT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Area Limit Sequence (300A,0689)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_AREA_LIMIT_SEQUENCE
Visual Basic
Public Const BEAM_AREA_LIMIT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_AREA_LIMIT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_CURRENT_MODULATION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_CURRENT_MODULATION_ID Field
MCdicom Structure See Also Send Feedback
Beam Current Modulation ID (300A,034C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_CURRENT_MODULATION_ID
Visual Basic
Public Const BEAM_CURRENT_MODULATION_ID As UInteger
Visual C++
public:
literal unsigned int BEAM_CURRENT_MODULATION_ID

See Also

MCdicom Structure
MCdicom Members


BEAM_DELIVERY_DURATION_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DELIVERY_DURATION_LIMIT Field
MCdicom Structure See Also Send Feedback
Beam Delivery Duration Limit (300A,00C5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DELIVERY_DURATION_LIMIT
Visual Basic
Public Const BEAM_DELIVERY_DURATION_LIMIT As UInteger
Visual C++
public:
literal unsigned int BEAM_DELIVERY_DURATION_LIMIT

See Also

MCdicom Structure
MCdicom Members


BEAM_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Beam Description (300A,00C3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DESCRIPTION
Visual Basic
Public Const BEAM_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int BEAM_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE Field
MCdicom Structure See Also Send Feedback
Beam Dose (300A,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE
Visual Basic
Public Const BEAM_DOSE As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_MEANING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_MEANING Field
MCdicom Structure See Also Send Feedback
Beam Dose Meaning (300A,008B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_MEANING
Visual Basic
Public Const BEAM_DOSE_MEANING As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_MEANING

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_POINT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_POINT_DEPTH Field
MCdicom Structure See Also Send Feedback
Beam Dose Point Depth (300A,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_POINT_DEPTH
Visual Basic
Public Const BEAM_DOSE_POINT_DEPTH As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_POINT_DEPTH

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_POINT_EQUIVALENT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_POINT_EQUIVALENT_DEPTH Field
MCdicom Structure See Also Send Feedback
Beam Dose Point Equivalent Depth (300A,0089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_POINT_EQUIVALENT_DEPTH
Visual Basic
Public Const BEAM_DOSE_POINT_EQUIVALENT_DEPTH As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_POINT_EQUIVALENT_DEPTH

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Beam Dose Point Source to External Contour Distance (300A,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE
Visual Basic
Public Const BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_POINT_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_POINT_SSD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_POINT_SSD Field
MCdicom Structure See Also Send Feedback
Beam Dose Point SSD (300A,008A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_POINT_SSD
Visual Basic
Public Const BEAM_DOSE_POINT_SSD As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_POINT_SSD

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_SPECIFICATION_POINT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_SPECIFICATION_POINT_RETIRED Field
MCdicom Structure See Also Send Feedback
Beam Dose Specification Point RETIRED (300A,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_SPECIFICATION_POINT_RETIRED
Visual Basic
Public Const BEAM_DOSE_SPECIFICATION_POINT_RETIRED As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_SPECIFICATION_POINT_RETIRED

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_TYPE Field
MCdicom Structure See Also Send Feedback
Beam Dose Type (300A,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_TYPE
Visual Basic
Public Const BEAM_DOSE_TYPE As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_TYPE

See Also

MCdicom Structure
MCdicom Members


BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Dose Verification Control Point Sequence (300A,008C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_DOSE_VERIFICATION_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Hold Originating Device Sequence (300C,0128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE
Visual Basic
Public Const BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_HOLD_ORIGINATING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_HOLD_TRANSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_HOLD_TRANSITION Field
MCdicom Structure See Also Send Feedback
Beam Hold Transition (300C,0126)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_HOLD_TRANSITION
Visual Basic
Public Const BEAM_HOLD_TRANSITION As UInteger
Visual C++
public:
literal unsigned int BEAM_HOLD_TRANSITION

See Also

MCdicom Structure
MCdicom Members


BEAM_HOLD_TRANSITION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_HOLD_TRANSITION_DATETIME Field
MCdicom Structure See Also Send Feedback
Beam Hold Transition DateTime (300C,0127)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_HOLD_TRANSITION_DATETIME
Visual Basic
Public Const BEAM_HOLD_TRANSITION_DATETIME As UInteger
Visual C++
public:
literal unsigned int BEAM_HOLD_TRANSITION_DATETIME

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_ANGLE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Angle (300A,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_ANGLE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_ANGLE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_ANGLE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Angle Tolerance (300A,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Leaf Pairs Sequence (3008,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_LEAF_PAIRS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Position Sequence (300A,011A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_POSITION_SEQUENCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Position Tolerance (300A,004A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_POSITION_TOLERANCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Rotation Direction (300A,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_ROTATION_DIRECTION
Visual Basic
Public Const BEAM_LIMITING_DEVICE_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Sequence (300A,00B6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_SEQUENCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Limiting Device Tolerance Sequence (300A,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE
Visual Basic
Public Const BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_LIMITING_DEVICE_TOLERANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_METERSET Field
MCdicom Structure See Also Send Feedback
Beam Meterset (300A,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_METERSET
Visual Basic
Public Const BEAM_METERSET As UInteger
Visual C++
public:
literal unsigned int BEAM_METERSET

See Also

MCdicom Structure
MCdicom Members


BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG Field
MCdicom Structure See Also Send Feedback
Beam Modifier Coordinates Presence Flag (3002,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG
Visual Basic
Public Const BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int BEAM_MODIFIER_COORDINATES_PRESENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


BEAM_MODIFIER_ORIENTATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_MODIFIER_ORIENTATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Beam Modifier Orientation Angle (300A,0645)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_MODIFIER_ORIENTATION_ANGLE
Visual Basic
Public Const BEAM_MODIFIER_ORIENTATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int BEAM_MODIFIER_ORIENTATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


BEAM_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_NAME Field
MCdicom Structure See Also Send Feedback
Beam Name (300A,00C2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_NAME
Visual Basic
Public Const BEAM_NAME As UInteger
Visual C++
public:
literal unsigned int BEAM_NAME

See Also

MCdicom Structure
MCdicom Members


BEAM_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_NUMBER Field
MCdicom Structure See Also Send Feedback
Beam Number (300A,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_NUMBER
Visual Basic
Public Const BEAM_NUMBER As UInteger
Visual C++
public:
literal unsigned int BEAM_NUMBER

See Also

MCdicom Structure
MCdicom Members


BEAM_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Beam Order Index (0074,1324)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_ORDER_INDEX
Visual Basic
Public Const BEAM_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int BEAM_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


BEAM_ORDER_INDEX_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_ORDER_INDEX_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Beam Order Index (Trial) RETIRED (0074,1024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_ORDER_INDEX_TRIAL_RETIRED
Visual Basic
Public Const BEAM_ORDER_INDEX_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int BEAM_ORDER_INDEX_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


BEAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Sequence (300A,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_SEQUENCE
Visual Basic
Public Const BEAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_SPOT_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_SPOT_SIZE Field
MCdicom Structure See Also Send Feedback
Beam Spot Size (0052,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_SPOT_SIZE
Visual Basic
Public Const BEAM_SPOT_SIZE As UInteger
Visual C++
public:
literal unsigned int BEAM_SPOT_SIZE

See Also

MCdicom Structure
MCdicom Members


BEAM_STOPPER_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_STOPPER_POSITION Field
MCdicom Structure See Also Send Feedback
Beam Stopper Position (3008,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_STOPPER_POSITION
Visual Basic
Public Const BEAM_STOPPER_POSITION As UInteger
Visual C++
public:
literal unsigned int BEAM_STOPPER_POSITION

See Also

MCdicom Structure
MCdicom Members


BEAM_TASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_TASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Beam Task Sequence (0074,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_TASK_SEQUENCE
Visual Basic
Public Const BEAM_TASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BEAM_TASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BEAM_TASK_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_TASK_TYPE Field
MCdicom Structure See Also Send Feedback
Beam Task Type (0074,1022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_TASK_TYPE
Visual Basic
Public Const BEAM_TASK_TYPE As UInteger
Visual C++
public:
literal unsigned int BEAM_TASK_TYPE

See Also

MCdicom Structure
MCdicom Members


BEAM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAM_TYPE Field
MCdicom Structure See Also Send Feedback
Beam Type (300A,00C4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAM_TYPE
Visual Basic
Public Const BEAM_TYPE As UInteger
Visual C++
public:
literal unsigned int BEAM_TYPE

See Also

MCdicom Structure
MCdicom Members


BEAT_REJECTION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BEAT_REJECTION_FLAG Field
MCdicom Structure See Also Send Feedback
Beat Rejection Flag (0018,1080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BEAT_REJECTION_FLAG
Visual Basic
Public Const BEAT_REJECTION_FLAG As UInteger
Visual C++
public:
literal unsigned int BEAT_REJECTION_FLAG

See Also

MCdicom Structure
MCdicom Members


BELT_HEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BELT_HEIGHT Field
MCdicom Structure See Also Send Feedback
Belt Height (4010,1062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BELT_HEIGHT
Visual Basic
Public Const BELT_HEIGHT As UInteger
Visual C++
public:
literal unsigned int BELT_HEIGHT

See Also

MCdicom Structure
MCdicom Members


BI_PLANE_ACQUISITION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BI_PLANE_ACQUISITION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Bi-Plane Acquisition Sequence RETIRED (0028,5000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BI_PLANE_ACQUISITION_SEQUENCE_RETIRED
Visual Basic
Public Const BI_PLANE_ACQUISITION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int BI_PLANE_ACQUISITION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Bibliographic Citation (Trial) RETIRED (0040,A16A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED
Visual Basic
Public Const BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int BIBLIOGRAPHIC_CITATION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


BILLING_ITEM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BILLING_ITEM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Billing Item Sequence (0040,0296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BILLING_ITEM_SEQUENCE
Visual Basic
Public Const BILLING_ITEM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BILLING_ITEM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BILLING_PROCEDURE_STEP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BILLING_PROCEDURE_STEP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Billing Procedure Step Sequence (0040,0320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BILLING_PROCEDURE_STEP_SEQUENCE
Visual Basic
Public Const BILLING_PROCEDURE_STEP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BILLING_PROCEDURE_STEP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BILLING_SUPPLIES_AND_DEVICES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BILLING_SUPPLIES_AND_DEVICES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Billing Supplies and Devices Sequence (0040,0324)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BILLING_SUPPLIES_AND_DEVICES_SEQUENCE
Visual Basic
Public Const BILLING_SUPPLIES_AND_DEVICES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BILLING_SUPPLIES_AND_DEVICES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BIOPSY_TARGET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BIOPSY_TARGET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Biopsy Target Sequence (0018,2041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BIOPSY_TARGET_SEQUENCE
Visual Basic
Public Const BIOPSY_TARGET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BIOPSY_TARGET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BIT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BIT_POSITION Field
MCdicom Structure See Also Send Feedback
Alias for tag OVERLAY_BIT_POSITION (6000,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BIT_POSITION
Visual Basic
Public Const BIT_POSITION As UInteger
Visual C++
public:
literal unsigned int BIT_POSITION

See Also

MCdicom Structure
MCdicom Members


BITS_ALLOCATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BITS_ALLOCATED Field
MCdicom Structure See Also Send Feedback
Bits Allocated (0028,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BITS_ALLOCATED
Visual Basic
Public Const BITS_ALLOCATED As UInteger
Visual C++
public:
literal unsigned int BITS_ALLOCATED

See Also

MCdicom Structure
MCdicom Members


BITS_MAPPED_TO_COLOR_LOOKUP_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BITS_MAPPED_TO_COLOR_LOOKUP_TABLE Field
MCdicom Structure See Also Send Feedback
Bits Mapped to Color Lookup Table (0028,1403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BITS_MAPPED_TO_COLOR_LOOKUP_TABLE
Visual Basic
Public Const BITS_MAPPED_TO_COLOR_LOOKUP_TABLE As UInteger
Visual C++
public:
literal unsigned int BITS_MAPPED_TO_COLOR_LOOKUP_TABLE

See Also

MCdicom Structure
MCdicom Members


BITS_STORED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BITS_STORED Field
MCdicom Structure See Also Send Feedback
Bits Stored (0028,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BITS_STORED
Visual Basic
Public Const BITS_STORED As UInteger
Visual C++
public:
literal unsigned int BITS_STORED

See Also

MCdicom Structure
MCdicom Members


BLENDING_DISPLAY_INPUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_DISPLAY_INPUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Blending Display Input Sequence (0070,1B03)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_DISPLAY_INPUT_SEQUENCE
Visual Basic
Public Const BLENDING_DISPLAY_INPUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLENDING_DISPLAY_INPUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLENDING_DISPLAY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_DISPLAY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Blending Display Sequence (0070,1B04)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_DISPLAY_SEQUENCE
Visual Basic
Public Const BLENDING_DISPLAY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLENDING_DISPLAY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLENDING_INPUT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_INPUT_NUMBER Field
MCdicom Structure See Also Send Feedback
Blending Input Number (0070,1B02)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_INPUT_NUMBER
Visual Basic
Public Const BLENDING_INPUT_NUMBER As UInteger
Visual C++
public:
literal unsigned int BLENDING_INPUT_NUMBER

See Also

MCdicom Structure
MCdicom Members


BLENDING_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Blending Lookup Table Data (0028,1408)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LOOKUP_TABLE_DATA
Visual Basic
Public Const BLENDING_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int BLENDING_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


BLENDING_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Blending Lookup Table Descriptor (0028,1407)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const BLENDING_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int BLENDING_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


BLENDING_LUT_1_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LUT_1_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Blending LUT 1 Sequence (0028,1404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LUT_1_SEQUENCE
Visual Basic
Public Const BLENDING_LUT_1_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLENDING_LUT_1_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLENDING_LUT_1_TRANSFER_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LUT_1_TRANSFER_FUNCTION Field
MCdicom Structure See Also Send Feedback
Blending LUT 1 Transfer Function (0028,1405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LUT_1_TRANSFER_FUNCTION
Visual Basic
Public Const BLENDING_LUT_1_TRANSFER_FUNCTION As UInteger
Visual C++
public:
literal unsigned int BLENDING_LUT_1_TRANSFER_FUNCTION

See Also

MCdicom Structure
MCdicom Members


BLENDING_LUT_2_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LUT_2_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Blending LUT 2 Sequence (0028,140C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LUT_2_SEQUENCE
Visual Basic
Public Const BLENDING_LUT_2_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLENDING_LUT_2_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLENDING_LUT_2_TRANSFER_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_LUT_2_TRANSFER_FUNCTION Field
MCdicom Structure See Also Send Feedback
Blending LUT 2 Transfer Function (0028,140D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_LUT_2_TRANSFER_FUNCTION
Visual Basic
Public Const BLENDING_LUT_2_TRANSFER_FUNCTION As UInteger
Visual C++
public:
literal unsigned int BLENDING_LUT_2_TRANSFER_FUNCTION

See Also

MCdicom Structure
MCdicom Members


BLENDING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_MODE Field
MCdicom Structure See Also Send Feedback
Blending Mode (0070,1B06)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_MODE
Visual Basic
Public Const BLENDING_MODE As UInteger
Visual C++
public:
literal unsigned int BLENDING_MODE

See Also

MCdicom Structure
MCdicom Members


BLENDING_OPERATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_OPERATION_TYPE Field
MCdicom Structure See Also Send Feedback
Blending Operation Type (0072,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_OPERATION_TYPE
Visual Basic
Public Const BLENDING_OPERATION_TYPE As UInteger
Visual C++
public:
literal unsigned int BLENDING_OPERATION_TYPE

See Also

MCdicom Structure
MCdicom Members


BLENDING_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_POSITION Field
MCdicom Structure See Also Send Feedback
Blending Position (0070,0405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_POSITION
Visual Basic
Public Const BLENDING_POSITION As UInteger
Visual C++
public:
literal unsigned int BLENDING_POSITION

See Also

MCdicom Structure
MCdicom Members


BLENDING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Blending Sequence (0070,0402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_SEQUENCE
Visual Basic
Public Const BLENDING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLENDING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLENDING_WEIGHT_CONSTANT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLENDING_WEIGHT_CONSTANT Field
MCdicom Structure See Also Send Feedback
Blending Weight Constant (0028,1406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLENDING_WEIGHT_CONSTANT
Visual Basic
Public Const BLENDING_WEIGHT_CONSTANT As UInteger
Visual C++
public:
literal unsigned int BLENDING_WEIGHT_CONSTANT

See Also

MCdicom Structure
MCdicom Members


BLIND_SPOT_LOCALIZED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLIND_SPOT_LOCALIZED Field
MCdicom Structure See Also Send Feedback
Blind Spot Localized (0024,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLIND_SPOT_LOCALIZED
Visual Basic
Public Const BLIND_SPOT_LOCALIZED As UInteger
Visual C++
public:
literal unsigned int BLIND_SPOT_LOCALIZED

See Also

MCdicom Structure
MCdicom Members


BLIND_SPOT_X_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLIND_SPOT_X_COORDINATE Field
MCdicom Structure See Also Send Feedback
Blind Spot X-Coordinate (0024,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLIND_SPOT_X_COORDINATE
Visual Basic
Public Const BLIND_SPOT_X_COORDINATE As UInteger
Visual C++
public:
literal unsigned int BLIND_SPOT_X_COORDINATE

See Also

MCdicom Structure
MCdicom Members


BLIND_SPOT_Y_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLIND_SPOT_Y_COORDINATE Field
MCdicom Structure See Also Send Feedback
Blind Spot Y-Coordinate (0024,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLIND_SPOT_Y_COORDINATE
Visual Basic
Public Const BLIND_SPOT_Y_COORDINATE As UInteger
Visual C++
public:
literal unsigned int BLIND_SPOT_Y_COORDINATE

See Also

MCdicom Structure
MCdicom Members


BLOCK_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_DATA Field
MCdicom Structure See Also Send Feedback
Block Data (300A,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_DATA
Visual Basic
Public Const BLOCK_DATA As UInteger
Visual C++
public:
literal unsigned int BLOCK_DATA

See Also

MCdicom Structure
MCdicom Members


BLOCK_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Block Definition Sequence (300A,066A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_DEFINITION_SEQUENCE
Visual Basic
Public Const BLOCK_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLOCK_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLOCK_DIVERGENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_DIVERGENCE Field
MCdicom Structure See Also Send Feedback
Block Divergence (300A,00FA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_DIVERGENCE
Visual Basic
Public Const BLOCK_DIVERGENCE As UInteger
Visual C++
public:
literal unsigned int BLOCK_DIVERGENCE

See Also

MCdicom Structure
MCdicom Members


BLOCK_EDGE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_EDGE_DATA Field
MCdicom Structure See Also Send Feedback
Block Edge Data (300A,066B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_EDGE_DATA
Visual Basic
Public Const BLOCK_EDGE_DATA As UInteger
Visual C++
public:
literal unsigned int BLOCK_EDGE_DATA

See Also

MCdicom Structure
MCdicom Members


BLOCK_EDGE_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_EDGE_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Block Edge Data Sequence (300A,066F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_EDGE_DATA_SEQUENCE
Visual Basic
Public Const BLOCK_EDGE_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLOCK_EDGE_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLOCK_IDENTIFYING_INFORMATION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_IDENTIFYING_INFORMATION_STATUS Field
MCdicom Structure See Also Send Feedback
Block Identifying Information Status (0008,0303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_IDENTIFYING_INFORMATION_STATUS
Visual Basic
Public Const BLOCK_IDENTIFYING_INFORMATION_STATUS As UInteger
Visual C++
public:
literal unsigned int BLOCK_IDENTIFYING_INFORMATION_STATUS

See Also

MCdicom Structure
MCdicom Members


BLOCK_MOUNTING_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_MOUNTING_POSITION Field
MCdicom Structure See Also Send Feedback
Block Mounting Position (300A,00FB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_MOUNTING_POSITION
Visual Basic
Public Const BLOCK_MOUNTING_POSITION As UInteger
Visual C++
public:
literal unsigned int BLOCK_MOUNTING_POSITION

See Also

MCdicom Structure
MCdicom Members


BLOCK_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_NAME Field
MCdicom Structure See Also Send Feedback
Block Name (300A,00FE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_NAME
Visual Basic
Public Const BLOCK_NAME As UInteger
Visual C++
public:
literal unsigned int BLOCK_NAME

See Also

MCdicom Structure
MCdicom Members


BLOCK_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_NUMBER Field
MCdicom Structure See Also Send Feedback
Block Number (300A,00FC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_NUMBER
Visual Basic
Public Const BLOCK_NUMBER As UInteger
Visual C++
public:
literal unsigned int BLOCK_NUMBER

See Also

MCdicom Structure
MCdicom Members


BLOCK_NUMBER_OF_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_NUMBER_OF_POINTS Field
MCdicom Structure See Also Send Feedback
Block Number of Points (300A,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_NUMBER_OF_POINTS
Visual Basic
Public Const BLOCK_NUMBER_OF_POINTS As UInteger
Visual C++
public:
literal unsigned int BLOCK_NUMBER_OF_POINTS

See Also

MCdicom Structure
MCdicom Members


BLOCK_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Block Orientation (300A,066C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_ORIENTATION
Visual Basic
Public Const BLOCK_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int BLOCK_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


BLOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Block Sequence (300A,00F4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_SEQUENCE
Visual Basic
Public Const BLOCK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLOCK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLOCK_SLAB_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_SLAB_NUMBER Field
MCdicom Structure See Also Send Feedback
Block Slab Number (300A,0443)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_SLAB_NUMBER
Visual Basic
Public Const BLOCK_SLAB_NUMBER As UInteger
Visual C++
public:
literal unsigned int BLOCK_SLAB_NUMBER

See Also

MCdicom Structure
MCdicom Members


BLOCK_SLAB_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_SLAB_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Block Slab Sequence (300A,0441)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_SLAB_SEQUENCE
Visual Basic
Public Const BLOCK_SLAB_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BLOCK_SLAB_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BLOCK_SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
Block Slab Thickness (300A,0442)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_SLAB_THICKNESS
Visual Basic
Public Const BLOCK_SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int BLOCK_SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


BLOCK_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_THICKNESS Field
MCdicom Structure See Also Send Feedback
Block Thickness (300A,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_THICKNESS
Visual Basic
Public Const BLOCK_THICKNESS As UInteger
Visual C++
public:
literal unsigned int BLOCK_THICKNESS

See Also

MCdicom Structure
MCdicom Members


BLOCK_TRANSMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_TRANSMISSION Field
MCdicom Structure See Also Send Feedback
Block Transmission (300A,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_TRANSMISSION
Visual Basic
Public Const BLOCK_TRANSMISSION As UInteger
Visual C++
public:
literal unsigned int BLOCK_TRANSMISSION

See Also

MCdicom Structure
MCdicom Members


BLOCK_TRAY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_TRAY_ID Field
MCdicom Structure See Also Send Feedback
Block Tray ID (300A,00F5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_TRAY_ID
Visual Basic
Public Const BLOCK_TRAY_ID As UInteger
Visual C++
public:
literal unsigned int BLOCK_TRAY_ID

See Also

MCdicom Structure
MCdicom Members


BLOCK_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOCK_TYPE Field
MCdicom Structure See Also Send Feedback
Block Type (300A,00F8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOCK_TYPE
Visual Basic
Public Const BLOCK_TYPE As UInteger
Visual C++
public:
literal unsigned int BLOCK_TYPE

See Also

MCdicom Structure
MCdicom Members


BLOOD_SIGNAL_NULLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLOOD_SIGNAL_NULLING Field
MCdicom Structure See Also Send Feedback
Blood Signal Nulling (0018,9022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLOOD_SIGNAL_NULLING
Visual Basic
Public Const BLOOD_SIGNAL_NULLING As UInteger
Visual C++
public:
literal unsigned int BLOOD_SIGNAL_NULLING

See Also

MCdicom Structure
MCdicom Members


BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Blue Palette Color Lookup Table Data (0028,1203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Blue Palette Color Lookup Table Descriptor (0028,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int BLUE_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


BOARDING_PASS_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOARDING_PASS_ID Field
MCdicom Structure See Also Send Feedback
Boarding Pass ID (4010,101A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOARDING_PASS_ID
Visual Basic
Public Const BOARDING_PASS_ID As UInteger
Visual C++
public:
literal unsigned int BOARDING_PASS_ID

See Also

MCdicom Structure
MCdicom Members


BODY_PART_EXAMINED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BODY_PART_EXAMINED Field
MCdicom Structure See Also Send Feedback
Body Part Examined (0018,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BODY_PART_EXAMINED
Visual Basic
Public Const BODY_PART_EXAMINED As UInteger
Visual C++
public:
literal unsigned int BODY_PART_EXAMINED

See Also

MCdicom Structure
MCdicom Members


BODY_PART_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BODY_PART_THICKNESS Field
MCdicom Structure See Also Send Feedback
Body Part Thickness (0018,11A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BODY_PART_THICKNESS
Visual Basic
Public Const BODY_PART_THICKNESS As UInteger
Visual C++
public:
literal unsigned int BODY_PART_THICKNESS

See Also

MCdicom Structure
MCdicom Members


BOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOLD Field
MCdicom Structure See Also Send Feedback
Bold (0070,0249)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOLD
Visual Basic
Public Const BOLD As UInteger
Visual C++
public:
literal unsigned int BOLD

See Also

MCdicom Structure
MCdicom Members


BOLUS_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOLUS_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Bolus Definition Sequence (300A,0673)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOLUS_DEFINITION_SEQUENCE
Visual Basic
Public Const BOLUS_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BOLUS_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BOLUS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOLUS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Bolus Description (300A,00DD)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOLUS_DESCRIPTION
Visual Basic
Public Const BOLUS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int BOLUS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


BOLUS_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOLUS_ID Field
MCdicom Structure See Also Send Feedback
Bolus ID (300A,00DC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOLUS_ID
Visual Basic
Public Const BOLUS_ID As UInteger
Visual C++
public:
literal unsigned int BOLUS_ID

See Also

MCdicom Structure
MCdicom Members


BONE_THERMAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BONE_THERMAL_INDEX Field
MCdicom Structure See Also Send Feedback
Bone Thermal Index (0018,5024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BONE_THERMAL_INDEX
Visual Basic
Public Const BONE_THERMAL_INDEX As UInteger
Visual C++
public:
literal unsigned int BONE_THERMAL_INDEX

See Also

MCdicom Structure
MCdicom Members


BORDER_DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BORDER_DENSITY Field
MCdicom Structure See Also Send Feedback
Border Density (2010,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BORDER_DENSITY
Visual Basic
Public Const BORDER_DENSITY As UInteger
Visual C++
public:
literal unsigned int BORDER_DENSITY

See Also

MCdicom Structure
MCdicom Members


BORDERS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BORDERS_RETIRED Field
MCdicom Structure See Also Send Feedback
Borders RETIRED (0000,5160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BORDERS_RETIRED
Visual Basic
Public Const BORDERS_RETIRED As UInteger
Visual C++
public:
literal unsigned int BORDERS_RETIRED

See Also

MCdicom Structure
MCdicom Members


BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED Field
MCdicom Structure See Also Send Feedback
Bottom Right Hand Corner of Localizer Area RETIRED (0048,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED
Visual Basic
Public Const BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED As UInteger
Visual C++
public:
literal unsigned int BOTTOM_RIGHT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED

See Also

MCdicom Structure
MCdicom Members


BOUNDING_BOX_ANNOTATION_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_BOX_ANNOTATION_UNITS Field
MCdicom Structure See Also Send Feedback
Bounding Box Annotation Units (0070,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_BOX_ANNOTATION_UNITS
Visual Basic
Public Const BOUNDING_BOX_ANNOTATION_UNITS As UInteger
Visual C++
public:
literal unsigned int BOUNDING_BOX_ANNOTATION_UNITS

See Also

MCdicom Structure
MCdicom Members


BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Bounding Box Bottom Right Hand Corner (0070,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER
Visual Basic
Public Const BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int BOUNDING_BOX_BOTTOM_RIGHT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


BOUNDING_BOX_CROP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_BOX_CROP Field
MCdicom Structure See Also Send Feedback
Bounding Box Crop (0070,1303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_BOX_CROP
Visual Basic
Public Const BOUNDING_BOX_CROP As UInteger
Visual C++
public:
literal unsigned int BOUNDING_BOX_CROP

See Also

MCdicom Structure
MCdicom Members


BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION Field
MCdicom Structure See Also Send Feedback
Bounding Box Text Horizontal Justification (0070,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION
Visual Basic
Public Const BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION As UInteger
Visual C++
public:
literal unsigned int BOUNDING_BOX_TEXT_HORIZONTAL_JUSTIFICATION

See Also

MCdicom Structure
MCdicom Members


BOUNDING_BOX_TOP_LEFT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_BOX_TOP_LEFT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Bounding Box Top Left Hand Corner (0070,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_BOX_TOP_LEFT_HAND_CORNER
Visual Basic
Public Const BOUNDING_BOX_TOP_LEFT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int BOUNDING_BOX_TOP_LEFT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


BOUNDING_POLYGON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_POLYGON Field
MCdicom Structure See Also Send Feedback
Bounding Polygon (4010,101D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_POLYGON
Visual Basic
Public Const BOUNDING_POLYGON As UInteger
Visual C++
public:
literal unsigned int BOUNDING_POLYGON

See Also

MCdicom Structure
MCdicom Members


BOUNDING_RECTANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BOUNDING_RECTANGLE Field
MCdicom Structure See Also Send Feedback
Bounding Rectangle (0068,6347)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BOUNDING_RECTANGLE
Visual Basic
Public Const BOUNDING_RECTANGLE As UInteger
Visual C++
public:
literal unsigned int BOUNDING_RECTANGLE

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_ID Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device ID (300A,0263)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_ID
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_ID As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_ID

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_NAME Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Name (300A,0266)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_NAME
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_NAME As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_NAME

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Nominal Thickness (300A,026A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_NOMINAL_THICKNESS

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Nominal Transmission (300A,026C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_NOMINAL_TRANSMISSION

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_NUMBER Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Number (300A,0262)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_NUMBER
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_NUMBER As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_NUMBER

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Sequence (300A,0260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_SEQUENCE
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_ACCESSORY_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_ACCESSORY_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Brachy Accessory Device Type (300A,0264)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_ACCESSORY_DEVICE_TYPE
Visual Basic
Public Const BRACHY_ACCESSORY_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int BRACHY_ACCESSORY_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


BRACHY_APPLICATION_SETUP_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_APPLICATION_SETUP_DOSE Field
MCdicom Structure See Also Send Feedback
Brachy Application Setup Dose (300A,00A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_APPLICATION_SETUP_DOSE
Visual Basic
Public Const BRACHY_APPLICATION_SETUP_DOSE As UInteger
Visual C++
public:
literal unsigned int BRACHY_APPLICATION_SETUP_DOSE

See Also

MCdicom Structure
MCdicom Members


BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT Field
MCdicom Structure See Also Send Feedback
Brachy Application Setup Dose Specification Point (300A,00A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT
Visual Basic
Public Const BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT As UInteger
Visual C++
public:
literal unsigned int BRACHY_APPLICATION_SETUP_DOSE_SPECIFICATION_POINT

See Also

MCdicom Structure
MCdicom Members


BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Control Point Delivered Sequence (3008,0160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE
Visual Basic
Public Const BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Control Point Sequence (300A,02D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const BRACHY_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Pulse Control Point Delivered Sequence (3008,0173)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE
Visual Basic
Public Const BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_PULSE_CONTROL_POINT_DELIVERED_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Referenced Dose Reference Sequence (300C,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_REFERENCED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_TASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_TASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Brachy Task Sequence (0074,1401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_TASK_SEQUENCE
Visual Basic
Public Const BRACHY_TASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BRACHY_TASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRACHY_TREATMENT_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_TREATMENT_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Brachy Treatment Technique (300A,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_TREATMENT_TECHNIQUE
Visual Basic
Public Const BRACHY_TREATMENT_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int BRACHY_TREATMENT_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


BRACHY_TREATMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHY_TREATMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Brachy Treatment Type (300A,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHY_TREATMENT_TYPE
Visual Basic
Public Const BRACHY_TREATMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int BRACHY_TREATMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


BRACHYTHERAPY_SOURCE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRACHYTHERAPY_SOURCE_TYPE Field
MCdicom Structure See Also Send Feedback
Brachytherapy Source Type (3010,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRACHYTHERAPY_SOURCE_TYPE
Visual Basic
Public Const BRACHYTHERAPY_SOURCE_TYPE As UInteger
Visual C++
public:
literal unsigned int BRACHYTHERAPY_SOURCE_TYPE

See Also

MCdicom Structure
MCdicom Members


BRANCH_OF_SERVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRANCH_OF_SERVICE Field
MCdicom Structure See Also Send Feedback
Branch of Service (0010,1081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRANCH_OF_SERVICE
Visual Basic
Public Const BRANCH_OF_SERVICE As UInteger
Visual C++
public:
literal unsigned int BRANCH_OF_SERVICE

See Also

MCdicom Structure
MCdicom Members


BREAST_IMPLANT_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_IMPLANT_PRESENT Field
MCdicom Structure See Also Send Feedback
Breast Implant Present (0028,1300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_IMPLANT_PRESENT
Visual Basic
Public Const BREAST_IMPLANT_PRESENT As UInteger
Visual C++
public:
literal unsigned int BREAST_IMPLANT_PRESENT

See Also

MCdicom Structure
MCdicom Members


BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Breast Support Isocenter Primary Angle (0018,9545)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE
Visual Basic
Public Const BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int BREAST_SUPPORT_ISOCENTER_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Breast Support Isocenter Secondary Angle (0018,9546)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE
Visual Basic
Public Const BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int BREAST_SUPPORT_ISOCENTER_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


BREAST_SUPPORT_X_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_SUPPORT_X_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Breast Support X Position to Isocenter (0018,9547)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_SUPPORT_X_POSITION_TO_ISOCENTER
Visual Basic
Public Const BREAST_SUPPORT_X_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int BREAST_SUPPORT_X_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Breast Support Y Position to Isocenter (0018,9548)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER
Visual Basic
Public Const BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int BREAST_SUPPORT_Y_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Breast Support Z Position to Isocenter (0018,9549)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER
Visual Basic
Public Const BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int BREAST_SUPPORT_Z_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


BREED_REGISTRATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREED_REGISTRATION_NUMBER Field
MCdicom Structure See Also Send Feedback
Breed Registration Number (0010,2295)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREED_REGISTRATION_NUMBER
Visual Basic
Public Const BREED_REGISTRATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int BREED_REGISTRATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


BREED_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREED_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Breed Registration Sequence (0010,2294)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREED_REGISTRATION_SEQUENCE
Visual Basic
Public Const BREED_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BREED_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BREED_REGISTRY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BREED_REGISTRY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Breed Registry Code Sequence (0010,2296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BREED_REGISTRY_CODE_SEQUENCE
Visual Basic
Public Const BREED_REGISTRY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int BREED_REGISTRY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


BRIGHTNESS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BRIGHTNESS_VALUE Field
MCdicom Structure See Also Send Feedback
Brightness Value (0016,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BRIGHTNESS_VALUE
Visual Basic
Public Const BRIGHTNESS_VALUE As UInteger
Visual C++
public:
literal unsigned int BRIGHTNESS_VALUE

See Also

MCdicom Structure
MCdicom Members


BULK_MOTION_COMPENSATION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BULK_MOTION_COMPENSATION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Bulk Motion Compensation Technique (0018,9172)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BULK_MOTION_COMPENSATION_TECHNIQUE
Visual Basic
Public Const BULK_MOTION_COMPENSATION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int BULK_MOTION_COMPENSATION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


BULK_MOTION_SIGNAL_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BULK_MOTION_SIGNAL_SOURCE Field
MCdicom Structure See Also Send Feedback
Bulk Motion Signal Source (0018,9173)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BULK_MOTION_SIGNAL_SOURCE
Visual Basic
Public Const BULK_MOTION_SIGNAL_SOURCE As UInteger
Visual C++
public:
literal unsigned int BULK_MOTION_SIGNAL_SOURCE

See Also

MCdicom Structure
MCdicom Members


BULK_MOTION_STATUS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BULK_MOTION_STATUS_RETIRED Field
MCdicom Structure See Also Send Feedback
Bulk Motion Status RETIRED (0018,9166)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BULK_MOTION_STATUS_RETIRED
Visual Basic
Public Const BULK_MOTION_STATUS_RETIRED As UInteger
Visual C++
public:
literal unsigned int BULK_MOTION_STATUS_RETIRED

See Also

MCdicom Structure
MCdicom Members


BURNED_IN_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..BURNED_IN_ANNOTATION Field
MCdicom Structure See Also Send Feedback
Burned In Annotation (0028,0301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint BURNED_IN_ANNOTATION
Visual Basic
Public Const BURNED_IN_ANNOTATION As UInteger
Visual C++
public:
literal unsigned int BURNED_IN_ANNOTATION

See Also

MCdicom Structure
MCdicom Members


C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
C-Arm Photon-Electron Control Point Sequence (300A,062F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int C_ARM_PHOTON_ELECTRON_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


C_ARM_POSITIONER_TABLETOP_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..C_ARM_POSITIONER_TABLETOP_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
C-arm Positioner Tabletop Relationship (0018,9474)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint C_ARM_POSITIONER_TABLETOP_RELATIONSHIP
Visual Basic
Public Const C_ARM_POSITIONER_TABLETOP_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int C_ARM_POSITIONER_TABLETOP_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


CAD_FILE_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CAD_FILE_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
CAD File Format RETIRED (0014,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CAD_FILE_FORMAT_RETIRED
Visual Basic
Public Const CAD_FILE_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int CAD_FILE_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


CALCIUM_SCORING_MASS_FACTOR_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCIUM_SCORING_MASS_FACTOR_DEVICE Field
MCdicom Structure See Also Send Feedback
Calcium Scoring Mass Factor Device (0018,9352)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCIUM_SCORING_MASS_FACTOR_DEVICE
Visual Basic
Public Const CALCIUM_SCORING_MASS_FACTOR_DEVICE As UInteger
Visual C++
public:
literal unsigned int CALCIUM_SCORING_MASS_FACTOR_DEVICE

See Also

MCdicom Structure
MCdicom Members


CALCIUM_SCORING_MASS_FACTOR_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCIUM_SCORING_MASS_FACTOR_PATIENT Field
MCdicom Structure See Also Send Feedback
Calcium Scoring Mass Factor Patient (0018,9351)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCIUM_SCORING_MASS_FACTOR_PATIENT
Visual Basic
Public Const CALCIUM_SCORING_MASS_FACTOR_PATIENT As UInteger
Visual C++
public:
literal unsigned int CALCIUM_SCORING_MASS_FACTOR_PATIENT

See Also

MCdicom Structure
MCdicom Members


CALCULATED_ANATOMY_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_ANATOMY_THICKNESS Field
MCdicom Structure See Also Send Feedback
Calculated Anatomy Thickness (0018,9452)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_ANATOMY_THICKNESS
Visual Basic
Public Const CALCULATED_ANATOMY_THICKNESS As UInteger
Visual C++
public:
literal unsigned int CALCULATED_ANATOMY_THICKNESS

See Also

MCdicom Structure
MCdicom Members


CALCULATED_DOSE_REFERENCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_DOSE_REFERENCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Calculated Dose Reference Description (3008,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_DOSE_REFERENCE_DESCRIPTION
Visual Basic
Public Const CALCULATED_DOSE_REFERENCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CALCULATED_DOSE_REFERENCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CALCULATED_DOSE_REFERENCE_DOSE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_DOSE_REFERENCE_DOSE_VALUE Field
MCdicom Structure See Also Send Feedback
Calculated Dose Reference Dose Value (3008,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_DOSE_REFERENCE_DOSE_VALUE
Visual Basic
Public Const CALCULATED_DOSE_REFERENCE_DOSE_VALUE As UInteger
Visual C++
public:
literal unsigned int CALCULATED_DOSE_REFERENCE_DOSE_VALUE

See Also

MCdicom Structure
MCdicom Members


CALCULATED_DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Calculated Dose Reference Number (3008,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_DOSE_REFERENCE_NUMBER
Visual Basic
Public Const CALCULATED_DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int CALCULATED_DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


CALCULATED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Calculated Dose Reference Sequence (3008,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const CALCULATED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CALCULATED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CALCULATED_FRAME_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_FRAME_LIST Field
MCdicom Structure See Also Send Feedback
Calculated Frame List (0008,1162)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_FRAME_LIST
Visual Basic
Public Const CALCULATED_FRAME_LIST As UInteger
Visual C++
public:
literal unsigned int CALCULATED_FRAME_LIST

See Also

MCdicom Structure
MCdicom Members


CALCULATED_TARGET_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATED_TARGET_POSITION Field
MCdicom Structure See Also Send Feedback
Calculated Target Position (0018,2044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATED_TARGET_POSITION
Visual Basic
Public Const CALCULATED_TARGET_POSITION As UInteger
Visual C++
public:
literal unsigned int CALCULATED_TARGET_POSITION

See Also

MCdicom Structure
MCdicom Members


CALCULATION_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATION_COMMENT Field
MCdicom Structure See Also Send Feedback
Calculation Comment (0022,112C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATION_COMMENT
Visual Basic
Public Const CALCULATION_COMMENT As UInteger
Visual C++
public:
literal unsigned int CALCULATION_COMMENT

See Also

MCdicom Structure
MCdicom Members


CALCULATION_COMMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATION_COMMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Calculation Comment Sequence (0022,112A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATION_COMMENT_SEQUENCE
Visual Basic
Public Const CALCULATION_COMMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CALCULATION_COMMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CALCULATION_COMMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALCULATION_COMMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Calculation Comment Type (0022,112B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALCULATION_COMMENT_TYPE
Visual Basic
Public Const CALCULATION_COMMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int CALCULATION_COMMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Calibration Data Sequence (0054,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_DATA_SEQUENCE
Visual Basic
Public Const CALIBRATION_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_DATE Field
MCdicom Structure See Also Send Feedback
Calibration Date (0014,407E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_DATE
Visual Basic
Public Const CALIBRATION_DATE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_DATE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Calibration DateTime (0018,1203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_DATETIME
Visual Basic
Public Const CALIBRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_IMAGE Field
MCdicom Structure See Also Send Feedback
Calibration Image (0050,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_IMAGE
Visual Basic
Public Const CALIBRATION_IMAGE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_IMAGE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_NOTES Field
MCdicom Structure See Also Send Feedback
Calibration Notes (0014,3099)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_NOTES
Visual Basic
Public Const CALIBRATION_NOTES As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_NOTES

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_OBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_OBJECT Field
MCdicom Structure See Also Send Feedback
Alias for tag CALIBRATION_IMAGE (0050,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_OBJECT
Visual Basic
Public Const CALIBRATION_OBJECT As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_OBJECT

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_PROCEDURE Field
MCdicom Structure See Also Send Feedback
Calibration Procedure (0014,4072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_PROCEDURE
Visual Basic
Public Const CALIBRATION_PROCEDURE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_PROCEDURE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_REFERENCE_POINT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_REFERENCE_POINT_DEPTH Field
MCdicom Structure See Also Send Feedback
Calibration Reference Point Depth (300C,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_REFERENCE_POINT_DEPTH
Visual Basic
Public Const CALIBRATION_REFERENCE_POINT_DEPTH As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_REFERENCE_POINT_DEPTH

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Calibration Sequence (0018,9455)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_SEQUENCE
Visual Basic
Public Const CALIBRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Calibration Settings Sequence (0014,4070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_SETTINGS_SEQUENCE
Visual Basic
Public Const CALIBRATION_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CALIBRATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CALIBRATION_TIME Field
MCdicom Structure See Also Send Feedback
Calibration Time (0014,407C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CALIBRATION_TIME
Visual Basic
Public Const CALIBRATION_TIME As UInteger
Visual C++
public:
literal unsigned int CALIBRATION_TIME

See Also

MCdicom Structure
MCdicom Members


CAMERA_ANGLE_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CAMERA_ANGLE_OF_VIEW Field
MCdicom Structure See Also Send Feedback
Camera Angle of View (0022,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CAMERA_ANGLE_OF_VIEW
Visual Basic
Public Const CAMERA_ANGLE_OF_VIEW As UInteger
Visual C++
public:
literal unsigned int CAMERA_ANGLE_OF_VIEW

See Also

MCdicom Structure
MCdicom Members


CAMERA_ELEVATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CAMERA_ELEVATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Camera Elevation Angle (0016,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CAMERA_ELEVATION_ANGLE
Visual Basic
Public Const CAMERA_ELEVATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int CAMERA_ELEVATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


CAMERA_OWNER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CAMERA_OWNER_NAME Field
MCdicom Structure See Also Send Feedback
Camera Owner Name (0016,004D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CAMERA_OWNER_NAME
Visual Basic
Public Const CAMERA_OWNER_NAME As UInteger
Visual C++
public:
literal unsigned int CAMERA_OWNER_NAME

See Also

MCdicom Structure
MCdicom Members


CAMERA_POSITION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CAMERA_POSITION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Camera Position Group Sequence (0034,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CAMERA_POSITION_GROUP_SEQUENCE
Visual Basic
Public Const CAMERA_POSITION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CAMERA_POSITION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_BEAT_REJECTION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_BEAT_REJECTION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Cardiac Beat Rejection Technique (0018,9169)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_BEAT_REJECTION_TECHNIQUE
Visual Basic
Public Const CARDIAC_BEAT_REJECTION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_BEAT_REJECTION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_CYCLE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_CYCLE_POSITION Field
MCdicom Structure See Also Send Feedback
Cardiac Cycle Position (0018,9236)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_CYCLE_POSITION
Visual Basic
Public Const CARDIAC_CYCLE_POSITION As UInteger
Visual C++
public:
literal unsigned int CARDIAC_CYCLE_POSITION

See Also

MCdicom Structure
MCdicom Members


CARDIAC_FRAMING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_FRAMING_TYPE Field
MCdicom Structure See Also Send Feedback
Cardiac Framing Type (0018,1064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_FRAMING_TYPE
Visual Basic
Public Const CARDIAC_FRAMING_TYPE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_FRAMING_TYPE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_NUMBER_OF_IMAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_NUMBER_OF_IMAGES Field
MCdicom Structure See Also Send Feedback
Cardiac Number of Images (0018,1090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_NUMBER_OF_IMAGES
Visual Basic
Public Const CARDIAC_NUMBER_OF_IMAGES As UInteger
Visual C++
public:
literal unsigned int CARDIAC_NUMBER_OF_IMAGES

See Also

MCdicom Structure
MCdicom Members


CARDIAC_R_R_INTERVAL_SPECIFIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_R_R_INTERVAL_SPECIFIED Field
MCdicom Structure See Also Send Feedback
Cardiac R-R Interval Specified (0018,9070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_R_R_INTERVAL_SPECIFIED
Visual Basic
Public Const CARDIAC_R_R_INTERVAL_SPECIFIED As UInteger
Visual C++
public:
literal unsigned int CARDIAC_R_R_INTERVAL_SPECIFIED

See Also

MCdicom Structure
MCdicom Members


CARDIAC_SIGNAL_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_SIGNAL_SOURCE Field
MCdicom Structure See Also Send Feedback
Cardiac Signal Source (0018,9085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_SIGNAL_SOURCE
Visual Basic
Public Const CARDIAC_SIGNAL_SOURCE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_SIGNAL_SOURCE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_SYNCHRONIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_SYNCHRONIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Cardiac Synchronization Sequence (0018,9118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_SYNCHRONIZATION_SEQUENCE
Visual Basic
Public Const CARDIAC_SYNCHRONIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_SYNCHRONIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_SYNCHRONIZATION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_SYNCHRONIZATION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Cardiac Synchronization Technique (0018,9037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_SYNCHRONIZATION_TECHNIQUE
Visual Basic
Public Const CARDIAC_SYNCHRONIZATION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_SYNCHRONIZATION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


CARDIAC_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag NOMINAL_CARDIAC_TRIGGER_DELAY_TIME (0020,9153)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_TRIGGER_DELAY_TIME
Visual Basic
Public Const CARDIAC_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int CARDIAC_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


CARDIAC_TRIGGER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARDIAC_TRIGGER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag CARDIAC_SYNCHRONIZATION_SEQUENCE (0018,9118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARDIAC_TRIGGER_SEQUENCE
Visual Basic
Public Const CARDIAC_TRIGGER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CARDIAC_TRIGGER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CARRIER_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARRIER_ID Field
MCdicom Structure See Also Send Feedback
Carrier ID (4010,1058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARRIER_ID
Visual Basic
Public Const CARRIER_ID As UInteger
Visual C++
public:
literal unsigned int CARRIER_ID

See Also

MCdicom Structure
MCdicom Members


CARRIER_ID_ASSIGNING_AUTHORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CARRIER_ID_ASSIGNING_AUTHORITY Field
MCdicom Structure See Also Send Feedback
Carrier ID Assigning Authority (4010,1059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CARRIER_ID_ASSIGNING_AUTHORITY
Visual Basic
Public Const CARRIER_ID_ASSIGNING_AUTHORITY As UInteger
Visual C++
public:
literal unsigned int CARRIER_ID_ASSIGNING_AUTHORITY

See Also

MCdicom Structure
MCdicom Members


CASSETTE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CASSETTE_ID Field
MCdicom Structure See Also Send Feedback
Cassette ID (0018,1007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CASSETTE_ID
Visual Basic
Public Const CASSETTE_ID As UInteger
Visual C++
public:
literal unsigned int CASSETTE_ID

See Also

MCdicom Structure
MCdicom Members


CASSETTE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CASSETTE_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Cassette Orientation (0018,1402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CASSETTE_ORIENTATION
Visual Basic
Public Const CASSETTE_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int CASSETTE_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


CASSETTE_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CASSETTE_SIZE Field
MCdicom Structure See Also Send Feedback
Cassette Size (0018,1403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CASSETTE_SIZE
Visual Basic
Public Const CASSETTE_SIZE As UInteger
Visual C++
public:
literal unsigned int CASSETTE_SIZE

See Also

MCdicom Structure
MCdicom Members


CATCH_TRIALS_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CATCH_TRIALS_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Catch Trials Data Flag (0024,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CATCH_TRIALS_DATA_FLAG
Visual Basic
Public Const CATCH_TRIALS_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int CATCH_TRIALS_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


CATHETER_DIRECTION_OF_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CATHETER_DIRECTION_OF_ROTATION Field
MCdicom Structure See Also Send Feedback
Catheter Direction of Rotation (0052,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CATHETER_DIRECTION_OF_ROTATION
Visual Basic
Public Const CATHETER_DIRECTION_OF_ROTATION As UInteger
Visual C++
public:
literal unsigned int CATHETER_DIRECTION_OF_ROTATION

See Also

MCdicom Structure
MCdicom Members


CATHETER_ROTATIONAL_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CATHETER_ROTATIONAL_RATE Field
MCdicom Structure See Also Send Feedback
Catheter Rotational Rate (0052,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CATHETER_ROTATIONAL_RATE
Visual Basic
Public Const CATHETER_ROTATIONAL_RATE As UInteger
Visual C++
public:
literal unsigned int CATHETER_ROTATIONAL_RATE

See Also

MCdicom Structure
MCdicom Members


CELL_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CELL_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Cell Values Sequence (0040,A808)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CELL_VALUES_SEQUENCE
Visual Basic
Public Const CELL_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CELL_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CENTER_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Center Frequency (0018,982D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_FREQUENCY
Visual Basic
Public Const CENTER_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int CENTER_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_CIRCULAR_COLLIMATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_CIRCULAR_COLLIMATOR Field
MCdicom Structure See Also Send Feedback
Center of Circular Collimator (0018,1710)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_CIRCULAR_COLLIMATOR
Visual Basic
Public Const CENTER_OF_CIRCULAR_COLLIMATOR As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_CIRCULAR_COLLIMATOR

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION Field
MCdicom Structure See Also Send Feedback
Center of Circular Exposure Control Sensing Region (0018,9440)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION
Visual Basic
Public Const CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_CIRCULAR_OUTLINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_CIRCULAR_OUTLINE Field
MCdicom Structure See Also Send Feedback
Center of Circular Outline (0018,1635)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_CIRCULAR_OUTLINE
Visual Basic
Public Const CENTER_OF_CIRCULAR_OUTLINE As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_CIRCULAR_OUTLINE

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_CIRCULAR_SHUTTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_CIRCULAR_SHUTTER Field
MCdicom Structure See Also Send Feedback
Center of Circular Shutter (0018,1610)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_CIRCULAR_SHUTTER
Visual Basic
Public Const CENTER_OF_CIRCULAR_SHUTTER As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_CIRCULAR_SHUTTER

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_MASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_MASS Field
MCdicom Structure See Also Send Feedback
Center of Mass (4010,101B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_MASS
Visual Basic
Public Const CENTER_OF_MASS As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_MASS

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_PTO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_PTO Field
MCdicom Structure See Also Send Feedback
Center of PTO (4010,101C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_PTO
Visual Basic
Public Const CENTER_OF_PTO As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_PTO

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_ROTATION Field
MCdicom Structure See Also Send Feedback
Center of Rotation (0066,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_ROTATION
Visual Basic
Public Const CENTER_OF_ROTATION As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_ROTATION

See Also

MCdicom Structure
MCdicom Members


CENTER_OF_ROTATION_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CENTER_OF_ROTATION_OFFSET Field
MCdicom Structure See Also Send Feedback
Center of Rotation Offset (0018,1145)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CENTER_OF_ROTATION_OFFSET
Visual Basic
Public Const CENTER_OF_ROTATION_OFFSET As UInteger
Visual C++
public:
literal unsigned int CENTER_OF_ROTATION_OFFSET

See Also

MCdicom Structure
MCdicom Members


CERTIFICATE_OF_SIGNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CERTIFICATE_OF_SIGNER Field
MCdicom Structure See Also Send Feedback
Certificate of Signer (0400,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CERTIFICATE_OF_SIGNER
Visual Basic
Public Const CERTIFICATE_OF_SIGNER As UInteger
Visual C++
public:
literal unsigned int CERTIFICATE_OF_SIGNER

See Also

MCdicom Structure
MCdicom Members


CERTIFICATE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CERTIFICATE_TYPE Field
MCdicom Structure See Also Send Feedback
Certificate Type (0400,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CERTIFICATE_TYPE
Visual Basic
Public Const CERTIFICATE_TYPE As UInteger
Visual C++
public:
literal unsigned int CERTIFICATE_TYPE

See Also

MCdicom Structure
MCdicom Members


CERTIFIED_TIMESTAMP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CERTIFIED_TIMESTAMP Field
MCdicom Structure See Also Send Feedback
Certified Timestamp (0400,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CERTIFIED_TIMESTAMP
Visual Basic
Public Const CERTIFIED_TIMESTAMP As UInteger
Visual C++
public:
literal unsigned int CERTIFIED_TIMESTAMP

See Also

MCdicom Structure
MCdicom Members


CERTIFIED_TIMESTAMP_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CERTIFIED_TIMESTAMP_TYPE Field
MCdicom Structure See Also Send Feedback
Certified Timestamp Type (0400,0305)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CERTIFIED_TIMESTAMP_TYPE
Visual Basic
Public Const CERTIFIED_TIMESTAMP_TYPE As UInteger
Visual C++
public:
literal unsigned int CERTIFIED_TIMESTAMP_TYPE

See Also

MCdicom Structure
MCdicom Members


CHAIR_HEAD_FRAME_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHAIR_HEAD_FRAME_POSITION Field
MCdicom Structure See Also Send Feedback
Chair Head Frame Position (300A,0151)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHAIR_HEAD_FRAME_POSITION
Visual Basic
Public Const CHAIR_HEAD_FRAME_POSITION As UInteger
Visual C++
public:
literal unsigned int CHAIR_HEAD_FRAME_POSITION

See Also

MCdicom Structure
MCdicom Members


CHAIR_HEAD_FRAME_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHAIR_HEAD_FRAME_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Chair Head Frame Position Tolerance (300A,0153)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHAIR_HEAD_FRAME_POSITION_TOLERANCE
Visual Basic
Public Const CHAIR_HEAD_FRAME_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int CHAIR_HEAD_FRAME_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_BASELINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_BASELINE Field
MCdicom Structure See Also Send Feedback
Channel Baseline (003A,0213)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_BASELINE
Visual Basic
Public Const CHANNEL_BASELINE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_BASELINE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Definition Sequence (003A,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DEFINITION_SEQUENCE
Visual Basic
Public Const CHANNEL_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DELIVERY_CONTINUATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DELIVERY_CONTINUATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Delivery Continuation Sequence (0074,140D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DELIVERY_CONTINUATION_SEQUENCE
Visual Basic
Public Const CHANNEL_DELIVERY_CONTINUATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DELIVERY_CONTINUATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DELIVERY_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DELIVERY_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Channel Delivery Order Index (0074,140C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DELIVERY_ORDER_INDEX
Visual Basic
Public Const CHANNEL_DELIVERY_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DELIVERY_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DELIVERY_ORDER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DELIVERY_ORDER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Delivery Order Sequence (0074,1405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DELIVERY_ORDER_SEQUENCE
Visual Basic
Public Const CHANNEL_DELIVERY_ORDER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DELIVERY_ORDER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DERIVATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DERIVATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Channel Derivation Description (003A,020C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DERIVATION_DESCRIPTION
Visual Basic
Public Const CHANNEL_DERIVATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DERIVATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DESCRIPTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DESCRIPTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Description Code Sequence (0022,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DESCRIPTION_CODE_SEQUENCE
Visual Basic
Public Const CHANNEL_DESCRIPTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DESCRIPTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_DISPLAY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_DISPLAY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Display Sequence (003A,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_DISPLAY_SEQUENCE
Visual Basic
Public Const CHANNEL_DISPLAY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_DISPLAY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_EFFECTIVE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_EFFECTIVE_LENGTH Field
MCdicom Structure See Also Send Feedback
Channel Effective Length (300A,0271)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_EFFECTIVE_LENGTH
Visual Basic
Public Const CHANNEL_EFFECTIVE_LENGTH As UInteger
Visual C++
public:
literal unsigned int CHANNEL_EFFECTIVE_LENGTH

See Also

MCdicom Structure
MCdicom Members


CHANNEL_IDENTIFICATION_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_IDENTIFICATION_CODE Field
MCdicom Structure See Also Send Feedback
Channel Identification Code (003A,0301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_IDENTIFICATION_CODE
Visual Basic
Public Const CHANNEL_IDENTIFICATION_CODE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_IDENTIFICATION_CODE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_IMPEDANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_IMPEDANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Impedance Sequence (003A,0312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_IMPEDANCE_SEQUENCE
Visual Basic
Public Const CHANNEL_IMPEDANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_IMPEDANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_INNER_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_INNER_LENGTH Field
MCdicom Structure See Also Send Feedback
Channel Inner Length (300A,0272)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_INNER_LENGTH
Visual Basic
Public Const CHANNEL_INNER_LENGTH As UInteger
Visual C++
public:
literal unsigned int CHANNEL_INNER_LENGTH

See Also

MCdicom Structure
MCdicom Members


CHANNEL_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_LABEL Field
MCdicom Structure See Also Send Feedback
Channel Label (003A,0203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_LABEL
Visual Basic
Public Const CHANNEL_LABEL As UInteger
Visual C++
public:
literal unsigned int CHANNEL_LABEL

See Also

MCdicom Structure
MCdicom Members


CHANNEL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_LENGTH Field
MCdicom Structure See Also Send Feedback
Channel Length (300A,0284)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_LENGTH
Visual Basic
Public Const CHANNEL_LENGTH As UInteger
Visual C++
public:
literal unsigned int CHANNEL_LENGTH

See Also

MCdicom Structure
MCdicom Members


CHANNEL_MAXIMUM_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_MAXIMUM_VALUE Field
MCdicom Structure See Also Send Feedback
Channel Maximum Value (5400,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_MAXIMUM_VALUE
Visual Basic
Public Const CHANNEL_MAXIMUM_VALUE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_MAXIMUM_VALUE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_MINIMUM_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_MINIMUM_VALUE Field
MCdicom Structure See Also Send Feedback
Channel Minimum Value (5400,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_MINIMUM_VALUE
Visual Basic
Public Const CHANNEL_MINIMUM_VALUE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_MINIMUM_VALUE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_MODE Field
MCdicom Structure See Also Send Feedback
Channel Mode (003A,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_MODE
Visual Basic
Public Const CHANNEL_MODE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_MODE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_NUMBER Field
MCdicom Structure See Also Send Feedback
Channel Number (300A,0282)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_NUMBER
Visual Basic
Public Const CHANNEL_NUMBER As UInteger
Visual C++
public:
literal unsigned int CHANNEL_NUMBER

See Also

MCdicom Structure
MCdicom Members


CHANNEL_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_OFFSET Field
MCdicom Structure See Also Send Feedback
Channel Offset (003A,0218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_OFFSET
Visual Basic
Public Const CHANNEL_OFFSET As UInteger
Visual C++
public:
literal unsigned int CHANNEL_OFFSET

See Also

MCdicom Structure
MCdicom Members


CHANNEL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_POSITION Field
MCdicom Structure See Also Send Feedback
Channel Position (003A,0245)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_POSITION
Visual Basic
Public Const CHANNEL_POSITION As UInteger
Visual C++
public:
literal unsigned int CHANNEL_POSITION

See Also

MCdicom Structure
MCdicom Members


CHANNEL_PRESENTATION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_PRESENTATION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag WAVEFORM_PRESENTATION_GROUP_SEQUENCE (003A,0240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_PRESENTATION_GROUP_SEQUENCE
Visual Basic
Public Const CHANNEL_PRESENTATION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_PRESENTATION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Channel Recommended Display CIELab Value (003A,0244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE
Visual Basic
Public Const CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_RECOMMENDED_DISPLAY_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SAMPLE_SKEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SAMPLE_SKEW Field
MCdicom Structure See Also Send Feedback
Channel Sample Skew (003A,0215)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SAMPLE_SKEW
Visual Basic
Public Const CHANNEL_SAMPLE_SKEW As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SAMPLE_SKEW

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Channel Sensitivity (003A,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SENSITIVITY
Visual Basic
Public Const CHANNEL_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SENSITIVITY_CORRECTION_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SENSITIVITY_CORRECTION_FACTOR Field
MCdicom Structure See Also Send Feedback
Channel Sensitivity Correction Factor (003A,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SENSITIVITY_CORRECTION_FACTOR
Visual Basic
Public Const CHANNEL_SENSITIVITY_CORRECTION_FACTOR As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SENSITIVITY_CORRECTION_FACTOR

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SENSITIVITY_UNITS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SENSITIVITY_UNITS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Sensitivity Units Sequence (003A,0211)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SENSITIVITY_UNITS_SEQUENCE
Visual Basic
Public Const CHANNEL_SENSITIVITY_UNITS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SENSITIVITY_UNITS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Sequence (300A,0280)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SEQUENCE
Visual Basic
Public Const CHANNEL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_ID Field
MCdicom Structure See Also Send Feedback
Channel Shield ID (300A,02B3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_ID
Visual Basic
Public Const CHANNEL_SHIELD_ID As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_ID

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_NAME Field
MCdicom Structure See Also Send Feedback
Channel Shield Name (300A,02B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_NAME
Visual Basic
Public Const CHANNEL_SHIELD_NAME As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_NAME

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_NOMINAL_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_NOMINAL_THICKNESS Field
MCdicom Structure See Also Send Feedback
Channel Shield Nominal Thickness (300A,02B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_NOMINAL_THICKNESS
Visual Basic
Public Const CHANNEL_SHIELD_NOMINAL_THICKNESS As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_NOMINAL_THICKNESS

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_NOMINAL_TRANSMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_NOMINAL_TRANSMISSION Field
MCdicom Structure See Also Send Feedback
Channel Shield Nominal Transmission (300A,02BA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_NOMINAL_TRANSMISSION
Visual Basic
Public Const CHANNEL_SHIELD_NOMINAL_TRANSMISSION As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_NOMINAL_TRANSMISSION

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_NUMBER Field
MCdicom Structure See Also Send Feedback
Channel Shield Number (300A,02B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_NUMBER
Visual Basic
Public Const CHANNEL_SHIELD_NUMBER As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_NUMBER

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SHIELD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SHIELD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Shield Sequence (300A,02B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SHIELD_SEQUENCE
Visual Basic
Public Const CHANNEL_SHIELD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SHIELD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SOURCE_MODIFIERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SOURCE_MODIFIERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Source Modifiers Sequence (003A,0209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SOURCE_MODIFIERS_SEQUENCE
Visual Basic
Public Const CHANNEL_SOURCE_MODIFIERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SOURCE_MODIFIERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Channel Source Sequence (003A,0208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_SOURCE_SEQUENCE
Visual Basic
Public Const CHANNEL_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHANNEL_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHANNEL_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_STATUS Field
MCdicom Structure See Also Send Feedback
Channel Status (003A,0205)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_STATUS
Visual Basic
Public Const CHANNEL_STATUS As UInteger
Visual C++
public:
literal unsigned int CHANNEL_STATUS

See Also

MCdicom Structure
MCdicom Members


CHANNEL_TIME_SKEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_TIME_SKEW Field
MCdicom Structure See Also Send Feedback
Channel Time Skew (003A,0214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_TIME_SKEW
Visual Basic
Public Const CHANNEL_TIME_SKEW As UInteger
Visual C++
public:
literal unsigned int CHANNEL_TIME_SKEW

See Also

MCdicom Structure
MCdicom Members


CHANNEL_TOTAL_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_TOTAL_TIME Field
MCdicom Structure See Also Send Feedback
Channel Total Time (300A,0286)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_TOTAL_TIME
Visual Basic
Public Const CHANNEL_TOTAL_TIME As UInteger
Visual C++
public:
literal unsigned int CHANNEL_TOTAL_TIME

See Also

MCdicom Structure
MCdicom Members


CHANNEL_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHANNEL_WIDTH Field
MCdicom Structure See Also Send Feedback
Channel Width (0046,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHANNEL_WIDTH
Visual Basic
Public Const CHANNEL_WIDTH As UInteger
Visual C++
public:
literal unsigned int CHANNEL_WIDTH

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED Field
MCdicom Structure See Also Send Feedback
Chemical Shift Maximum Integration Limit in Hz RETIRED (0018,9196)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED
Visual Basic
Public Const CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM Field
MCdicom Structure See Also Send Feedback
Chemical Shift Maximum Integration Limit in ppm (0018,9296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM
Visual Basic
Public Const CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED Field
MCdicom Structure See Also Send Feedback
Chemical Shift Minimum Integration Limit in Hz RETIRED (0018,9195)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED
Visual Basic
Public Const CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM Field
MCdicom Structure See Also Send Feedback
Chemical Shift Minimum Integration Limit in ppm (0018,9295)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM
Visual Basic
Public Const CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_REFERENCE Field
MCdicom Structure See Also Send Feedback
Chemical Shift Reference (0018,9053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_REFERENCE
Visual Basic
Public Const CHEMICAL_SHIFT_REFERENCE As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_REFERENCE

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Chemical Shift Sequence (0018,9084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFT_SEQUENCE
Visual Basic
Public Const CHEMICAL_SHIFT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ Field
MCdicom Structure See Also Send Feedback
Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9196)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ
Visual Basic
Public Const CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_HZ

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM Field
MCdicom Structure See Also Send Feedback
Alias for tag CHEMICAL_SHIFT_MAXIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM
Visual Basic
Public Const CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFTS_MAXIMUM_INTEGRATION_LIMIT_IN_PPM

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ Field
MCdicom Structure See Also Send Feedback
Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_HZ_RETIRED (0018,9195)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ
Visual Basic
Public Const CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_HZ

See Also

MCdicom Structure
MCdicom Members


CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM Field
MCdicom Structure See Also Send Feedback
Alias for tag CHEMICAL_SHIFT_MINIMUM_INTEGRATION_LIMIT_IN_PPM (0018,9295)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM
Visual Basic
Public Const CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM As UInteger
Visual C++
public:
literal unsigned int CHEMICAL_SHIFTS_MINIMUM_INTEGRATION_LIMIT_IN_PPM

See Also

MCdicom Structure
MCdicom Members


CIEXY_WHITE_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CIEXY_WHITE_POINT Field
MCdicom Structure See Also Send Feedback
CIExy White Point (0028,7018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CIEXY_WHITE_POINT
Visual Basic
Public Const CIEXY_WHITE_POINT As UInteger
Visual C++
public:
literal unsigned int CIEXY_WHITE_POINT

See Also

MCdicom Structure
MCdicom Members


CINE_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CINE_RATE Field
MCdicom Structure See Also Send Feedback
Cine Rate (0018,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CINE_RATE
Visual Basic
Public Const CINE_RATE As UInteger
Visual C++
public:
literal unsigned int CINE_RATE

See Also

MCdicom Structure
MCdicom Members


CINE_RELATIVE_TO_REAL_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CINE_RELATIVE_TO_REAL_TIME Field
MCdicom Structure See Also Send Feedback
Cine Relative to Real-Time (0072,0330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CINE_RELATIVE_TO_REAL_TIME
Visual Basic
Public Const CINE_RELATIVE_TO_REAL_TIME As UInteger
Visual C++
public:
literal unsigned int CINE_RELATIVE_TO_REAL_TIME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_FRACTION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_FRACTION_NUMBER Field
MCdicom Structure See Also Send Feedback
Clinical Fraction Number (300A,0705)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_FRACTION_NUMBER
Visual Basic
Public Const CLINICAL_FRACTION_NUMBER As UInteger
Visual C++
public:
literal unsigned int CLINICAL_FRACTION_NUMBER

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_COORDINATING_CENTER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_COORDINATING_CENTER_NAME Field
MCdicom Structure See Also Send Feedback
Clinical Trial Coordinating Center Name (0012,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_COORDINATING_CENTER_NAME
Visual Basic
Public Const CLINICAL_TRIAL_COORDINATING_CENTER_NAME As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_COORDINATING_CENTER_NAME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER Field
MCdicom Structure See Also Send Feedback
Clinical Trial Protocol Ethics Committee Approval Number (0012,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER
Visual Basic
Public Const CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_APPROVAL_NUMBER

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME Field
MCdicom Structure See Also Send Feedback
Clinical Trial Protocol Ethics Committee Name (0012,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME
Visual Basic
Public Const CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_PROTOCOL_ETHICS_COMMITTEE_NAME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_PROTOCOL_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_PROTOCOL_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Protocol ID (0012,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_PROTOCOL_ID
Visual Basic
Public Const CLINICAL_TRIAL_PROTOCOL_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_PROTOCOL_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_PROTOCOL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_PROTOCOL_NAME Field
MCdicom Structure See Also Send Feedback
Clinical Trial Protocol Name (0012,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_PROTOCOL_NAME
Visual Basic
Public Const CLINICAL_TRIAL_PROTOCOL_NAME As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_PROTOCOL_NAME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SERIES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SERIES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Clinical Trial Series Description (0012,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SERIES_DESCRIPTION
Visual Basic
Public Const CLINICAL_TRIAL_SERIES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SERIES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SERIES_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SERIES_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Series ID (0012,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SERIES_ID
Visual Basic
Public Const CLINICAL_TRIAL_SERIES_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SERIES_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SITE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SITE_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Site ID (0012,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SITE_ID
Visual Basic
Public Const CLINICAL_TRIAL_SITE_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SITE_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SITE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SITE_NAME Field
MCdicom Structure See Also Send Feedback
Clinical Trial Site Name (0012,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SITE_NAME
Visual Basic
Public Const CLINICAL_TRIAL_SITE_NAME As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SITE_NAME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SPONSOR_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SPONSOR_NAME Field
MCdicom Structure See Also Send Feedback
Clinical Trial Sponsor Name (0012,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SPONSOR_NAME
Visual Basic
Public Const CLINICAL_TRIAL_SPONSOR_NAME As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SPONSOR_NAME

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SUBJECT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SUBJECT_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Subject ID (0012,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SUBJECT_ID
Visual Basic
Public Const CLINICAL_TRIAL_SUBJECT_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SUBJECT_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_SUBJECT_READING_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_SUBJECT_READING_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Subject Reading ID (0012,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_SUBJECT_READING_ID
Visual Basic
Public Const CLINICAL_TRIAL_SUBJECT_READING_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_SUBJECT_READING_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_TIME_POINT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_TIME_POINT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Clinical Trial Time Point Description (0012,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_TIME_POINT_DESCRIPTION
Visual Basic
Public Const CLINICAL_TRIAL_TIME_POINT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_TIME_POINT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_TIME_POINT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_TIME_POINT_ID Field
MCdicom Structure See Also Send Feedback
Clinical Trial Time Point ID (0012,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_TIME_POINT_ID
Visual Basic
Public Const CLINICAL_TRIAL_TIME_POINT_ID As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_TIME_POINT_ID

See Also

MCdicom Structure
MCdicom Members


CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Clinical Trial Time Point Type Code Sequence (0012,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CLINICAL_TRIAL_TIME_POINT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COATING_MATERIALS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COATING_MATERIALS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Coating Materials Code Sequence (0068,63A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COATING_MATERIALS_CODE_SEQUENCE
Visual Basic
Public Const COATING_MATERIALS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COATING_MATERIALS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CODE_MEANING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODE_MEANING Field
MCdicom Structure See Also Send Feedback
Code Meaning (0008,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODE_MEANING
Visual Basic
Public Const CODE_MEANING As UInteger
Visual C++
public:
literal unsigned int CODE_MEANING

See Also

MCdicom Structure
MCdicom Members


CODE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODE_VALUE Field
MCdicom Structure See Also Send Feedback
Code Value (0008,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODE_VALUE
Visual Basic
Public Const CODE_VALUE As UInteger
Visual C++
public:
literal unsigned int CODE_VALUE

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_DESIGNATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_DESIGNATOR Field
MCdicom Structure See Also Send Feedback
Coding Scheme Designator (0008,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_DESIGNATOR
Visual Basic
Public Const CODING_SCHEME_DESIGNATOR As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_DESIGNATOR

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_EXTERNAL_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_EXTERNAL_ID Field
MCdicom Structure See Also Send Feedback
Coding Scheme External ID (0008,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_EXTERNAL_ID
Visual Basic
Public Const CODING_SCHEME_EXTERNAL_ID As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_EXTERNAL_ID

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Coding Scheme Identification Sequence (0008,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const CODING_SCHEME_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_NAME Field
MCdicom Structure See Also Send Feedback
Coding Scheme Name (0008,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_NAME
Visual Basic
Public Const CODING_SCHEME_NAME As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_NAME

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_REGISTRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_REGISTRY Field
MCdicom Structure See Also Send Feedback
Coding Scheme Registry (0008,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_REGISTRY
Visual Basic
Public Const CODING_SCHEME_REGISTRY As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_REGISTRY

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_RESOURCES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_RESOURCES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Coding Scheme Resources Sequence (0008,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_RESOURCES_SEQUENCE
Visual Basic
Public Const CODING_SCHEME_RESOURCES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_RESOURCES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_RESPONSIBLE_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_RESPONSIBLE_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Coding Scheme Responsible Organization (0008,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_RESPONSIBLE_ORGANIZATION
Visual Basic
Public Const CODING_SCHEME_RESPONSIBLE_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_RESPONSIBLE_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_UID Field
MCdicom Structure See Also Send Feedback
Coding Scheme UID (0008,010C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_UID
Visual Basic
Public Const CODING_SCHEME_UID As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_UID

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_URL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_URL Field
MCdicom Structure See Also Send Feedback
Coding Scheme URL (0008,010E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_URL
Visual Basic
Public Const CODING_SCHEME_URL As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_URL

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_URL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_URL_TYPE Field
MCdicom Structure See Also Send Feedback
Coding Scheme URL Type (0008,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_URL_TYPE
Visual Basic
Public Const CODING_SCHEME_URL_TYPE As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_URL_TYPE

See Also

MCdicom Structure
MCdicom Members


CODING_SCHEME_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CODING_SCHEME_VERSION Field
MCdicom Structure See Also Send Feedback
Coding Scheme Version (0008,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CODING_SCHEME_VERSION
Visual Basic
Public Const CODING_SCHEME_VERSION As UInteger
Visual C++
public:
literal unsigned int CODING_SCHEME_VERSION

See Also

MCdicom Structure
MCdicom Members


COINCIDENCE_WINDOW_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COINCIDENCE_WINDOW_WIDTH Field
MCdicom Structure See Also Send Feedback
Coincidence Window Width (0054,1210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COINCIDENCE_WINDOW_WIDTH
Visual Basic
Public Const COINCIDENCE_WINDOW_WIDTH As UInteger
Visual C++
public:
literal unsigned int COINCIDENCE_WINDOW_WIDTH

See Also

MCdicom Structure
MCdicom Members


COLLATION_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLATION_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Collation Flag RETIRED (2000,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLATION_FLAG_RETIRED
Visual Basic
Public Const COLLATION_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int COLLATION_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_GRID_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_GRID_NAME Field
MCdicom Structure See Also Send Feedback
Collimator/Grid Name (0018,1180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_GRID_NAME
Visual Basic
Public Const COLLIMATOR_GRID_NAME As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_GRID_NAME

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_LEFT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_LEFT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Collimator Left Vertical Edge (0018,1702)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_LEFT_VERTICAL_EDGE
Visual Basic
Public Const COLLIMATOR_LEFT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_LEFT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_LOWER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_LOWER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Collimator Lower Horizontal Edge (0018,1708)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_LOWER_HORIZONTAL_EDGE
Visual Basic
Public Const COLLIMATOR_LOWER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_LOWER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_RIGHT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_RIGHT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Collimator Right Vertical Edge (0018,1704)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_RIGHT_VERTICAL_EDGE
Visual Basic
Public Const COLLIMATOR_RIGHT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_RIGHT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_SHAPE Field
MCdicom Structure See Also Send Feedback
Collimator Shape (0018,1700)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_SHAPE
Visual Basic
Public Const COLLIMATOR_SHAPE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_SHAPE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_SHAPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_SHAPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Collimator Shape Sequence (0018,9407)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_SHAPE_SEQUENCE
Visual Basic
Public Const COLLIMATOR_SHAPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_SHAPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_TYPE Field
MCdicom Structure See Also Send Feedback
Collimator Type (0018,1181)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_TYPE
Visual Basic
Public Const COLLIMATOR_TYPE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_TYPE

See Also

MCdicom Structure
MCdicom Members


COLLIMATOR_UPPER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLLIMATOR_UPPER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Collimator Upper Horizontal Edge (0018,1706)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLLIMATOR_UPPER_HORIZONTAL_EDGE
Visual Basic
Public Const COLLIMATOR_UPPER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int COLLIMATOR_UPPER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


COLOR_FILTER_ARRAY_PATTERN_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLOR_FILTER_ARRAY_PATTERN_COLUMNS Field
MCdicom Structure See Also Send Feedback
Color Filter Array Pattern Columns (0016,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLOR_FILTER_ARRAY_PATTERN_COLUMNS
Visual Basic
Public Const COLOR_FILTER_ARRAY_PATTERN_COLUMNS As UInteger
Visual C++
public:
literal unsigned int COLOR_FILTER_ARRAY_PATTERN_COLUMNS

See Also

MCdicom Structure
MCdicom Members


COLOR_FILTER_ARRAY_PATTERN_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLOR_FILTER_ARRAY_PATTERN_ROWS Field
MCdicom Structure See Also Send Feedback
Color Filter Array Pattern Rows (0016,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLOR_FILTER_ARRAY_PATTERN_ROWS
Visual Basic
Public Const COLOR_FILTER_ARRAY_PATTERN_ROWS As UInteger
Visual C++
public:
literal unsigned int COLOR_FILTER_ARRAY_PATTERN_ROWS

See Also

MCdicom Structure
MCdicom Members


COLOR_FILTER_ARRAY_PATTERN_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLOR_FILTER_ARRAY_PATTERN_VALUES Field
MCdicom Structure See Also Send Feedback
Color Filter Array Pattern Values (0016,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLOR_FILTER_ARRAY_PATTERN_VALUES
Visual Basic
Public Const COLOR_FILTER_ARRAY_PATTERN_VALUES As UInteger
Visual C++
public:
literal unsigned int COLOR_FILTER_ARRAY_PATTERN_VALUES

See Also

MCdicom Structure
MCdicom Members


COLOR_IMAGE_PRINTING_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLOR_IMAGE_PRINTING_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Color Image Printing Flag RETIRED (2000,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLOR_IMAGE_PRINTING_FLAG_RETIRED
Visual Basic
Public Const COLOR_IMAGE_PRINTING_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int COLOR_IMAGE_PRINTING_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


COLOR_SPACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLOR_SPACE Field
MCdicom Structure See Also Send Feedback
Color Space (0028,2002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLOR_SPACE
Visual Basic
Public Const COLOR_SPACE As UInteger
Visual C++
public:
literal unsigned int COLOR_SPACE

See Also

MCdicom Structure
MCdicom Members


COLUMN_ANGULATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLUMN_ANGULATION Field
MCdicom Structure See Also Send Feedback
Column Angulation (0018,1450)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLUMN_ANGULATION
Visual Basic
Public Const COLUMN_ANGULATION As UInteger
Visual C++
public:
literal unsigned int COLUMN_ANGULATION

See Also

MCdicom Structure
MCdicom Members


COLUMN_ANGULATION_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLUMN_ANGULATION_PATIENT Field
MCdicom Structure See Also Send Feedback
Column Angulation (Patient) (0018,9447)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLUMN_ANGULATION_PATIENT
Visual Basic
Public Const COLUMN_ANGULATION_PATIENT As UInteger
Visual C++
public:
literal unsigned int COLUMN_ANGULATION_PATIENT

See Also

MCdicom Structure
MCdicom Members


COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX Field
MCdicom Structure See Also Send Feedback
Column Position In Total Image Pixel Matrix (0048,021E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX
Visual Basic
Public Const COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX As UInteger
Visual C++
public:
literal unsigned int COLUMN_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX

See Also

MCdicom Structure
MCdicom Members


COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COLUMNS Field
MCdicom Structure See Also Send Feedback
Columns (0028,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COLUMNS
Visual Basic
Public Const COLUMNS As UInteger
Visual C++
public:
literal unsigned int COLUMNS

See Also

MCdicom Structure
MCdicom Members


COMBINATION_SEGMENT_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMBINATION_SEGMENT_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Combination Segment Reference Sequence (3010,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMBINATION_SEGMENT_REFERENCE_SEQUENCE
Visual Basic
Public Const COMBINATION_SEGMENT_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMBINATION_SEGMENT_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMMAND_DATA_SET_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_DATA_SET_TYPE Field
MCdicom Structure See Also Send Feedback
Command Data Set Type (0000,0800)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_DATA_SET_TYPE
Visual Basic
Public Const COMMAND_DATA_SET_TYPE As UInteger
Visual C++
public:
literal unsigned int COMMAND_DATA_SET_TYPE

See Also

MCdicom Structure
MCdicom Members


COMMAND_FIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_FIELD Field
MCdicom Structure See Also Send Feedback
Command Field (0000,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_FIELD
Visual Basic
Public Const COMMAND_FIELD As UInteger
Visual C++
public:
literal unsigned int COMMAND_FIELD

See Also

MCdicom Structure
MCdicom Members


COMMAND_GROUP_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_GROUP_LENGTH Field
MCdicom Structure See Also Send Feedback
Command Group Length (0000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_GROUP_LENGTH
Visual Basic
Public Const COMMAND_GROUP_LENGTH As UInteger
Visual C++
public:
literal unsigned int COMMAND_GROUP_LENGTH

See Also

MCdicom Structure
MCdicom Members


COMMAND_LENGTH_TO_END_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_LENGTH_TO_END_RETIRED Field
MCdicom Structure See Also Send Feedback
Command Length to End RETIRED (0000,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_LENGTH_TO_END_RETIRED
Visual Basic
Public Const COMMAND_LENGTH_TO_END_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMMAND_LENGTH_TO_END_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMMAND_MAGNIFICATION_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_MAGNIFICATION_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Command Magnification Type RETIRED (0000,5180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_MAGNIFICATION_TYPE_RETIRED
Visual Basic
Public Const COMMAND_MAGNIFICATION_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMMAND_MAGNIFICATION_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMMAND_RECOGNITION_CODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMAND_RECOGNITION_CODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Command Recognition Code RETIRED (0000,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMAND_RECOGNITION_CODE_RETIRED
Visual Basic
Public Const COMMAND_RECOGNITION_CODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMMAND_RECOGNITION_CODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD Field
MCdicom Structure See Also Send Feedback
Alias for tag COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD (0024,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD
Visual Basic
Public Const COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD As UInteger
Visual C++
public:
literal unsigned int COMMENTS_ON_PATIENT_PERFORMANCE_OF_VISUAL_FIELD

See Also

MCdicom Structure
MCdicom Members


COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD Field
MCdicom Structure See Also Send Feedback
Comments on Patient's Performance of Visual Field (0024,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD
Visual Basic
Public Const COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD As UInteger
Visual C++
public:
literal unsigned int COMMENTS_ON_PATIENTS_PERFORMANCE_OF_VISUAL_FIELD

See Also

MCdicom Structure
MCdicom Members


COMMENTS_ON_RADIATION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMENTS_ON_RADIATION_DOSE Field
MCdicom Structure See Also Send Feedback
Comments on Radiation Dose (0040,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMENTS_ON_RADIATION_DOSE
Visual Basic
Public Const COMMENTS_ON_RADIATION_DOSE As UInteger
Visual C++
public:
literal unsigned int COMMENTS_ON_RADIATION_DOSE

See Also

MCdicom Structure
MCdicom Members


COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP Field
MCdicom Structure See Also Send Feedback
Comments on the Performed Procedure Step (0040,0280)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP
Visual Basic
Public Const COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP As UInteger
Visual C++
public:
literal unsigned int COMMENTS_ON_THE_PERFORMED_PROCEDURE_STEP

See Also

MCdicom Structure
MCdicom Members


COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP Field
MCdicom Structure See Also Send Feedback
Comments on the Scheduled Procedure Step (0040,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP
Visual Basic
Public Const COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP As UInteger
Visual C++
public:
literal unsigned int COMMENTS_ON_THE_SCHEDULED_PROCEDURE_STEP

See Also

MCdicom Structure
MCdicom Members


COMMON_Z_COORDINATE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMMON_Z_COORDINATE_VALUE Field
MCdicom Structure See Also Send Feedback
Common Z Coordinate Value (006A,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMMON_Z_COORDINATE_VALUE
Visual Basic
Public Const COMMON_Z_COORDINATE_VALUE As UInteger
Visual C++
public:
literal unsigned int COMMON_Z_COORDINATE_VALUE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_BASE_PLANE_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_BASE_PLANE_OFFSET Field
MCdicom Structure See Also Send Feedback
Compensator Base Plane Offset (300A,0666)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_BASE_PLANE_OFFSET
Visual Basic
Public Const COMPENSATOR_BASE_PLANE_OFFSET As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_BASE_PLANE_OFFSET

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_COLUMN_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_COLUMN_OFFSET Field
MCdicom Structure See Also Send Feedback
Compensator Column Offset (300A,02E5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_COLUMN_OFFSET
Visual Basic
Public Const COMPENSATOR_COLUMN_OFFSET As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_COLUMN_OFFSET

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_COLUMNS Field
MCdicom Structure See Also Send Feedback
Compensator Columns (300A,00E8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_COLUMNS
Visual Basic
Public Const COMPENSATOR_COLUMNS As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_COLUMNS

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Compensator Definition Sequence (300A,0662)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_DEFINITION_SEQUENCE
Visual Basic
Public Const COMPENSATOR_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Compensator Description (300A,02EB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_DESCRIPTION
Visual Basic
Public Const COMPENSATOR_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_DISTAL_THICKNESS_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_DISTAL_THICKNESS_MAP Field
MCdicom Structure See Also Send Feedback
Compensator Distal Thickness Map (300A,0665)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_DISTAL_THICKNESS_MAP
Visual Basic
Public Const COMPENSATOR_DISTAL_THICKNESS_MAP As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_DISTAL_THICKNESS_MAP

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_DIVERGENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_DIVERGENCE Field
MCdicom Structure See Also Send Feedback
Compensator Divergence (300A,02E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_DIVERGENCE
Visual Basic
Public Const COMPENSATOR_DIVERGENCE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_DIVERGENCE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_ID Field
MCdicom Structure See Also Send Feedback
Compensator ID (300A,00E5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_ID
Visual Basic
Public Const COMPENSATOR_ID As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_ID

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_MAP_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_MAP_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Compensator Map Orientation (300A,0663)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_MAP_ORIENTATION
Visual Basic
Public Const COMPENSATOR_MAP_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_MAP_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_MILLING_TOOL_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_MILLING_TOOL_DIAMETER Field
MCdicom Structure See Also Send Feedback
Compensator Milling Tool Diameter (300A,02E8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_MILLING_TOOL_DIAMETER
Visual Basic
Public Const COMPENSATOR_MILLING_TOOL_DIAMETER As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_MILLING_TOOL_DIAMETER

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_MOUNTING_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_MOUNTING_POSITION Field
MCdicom Structure See Also Send Feedback
Compensator Mounting Position (300A,02E1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_MOUNTING_POSITION
Visual Basic
Public Const COMPENSATOR_MOUNTING_POSITION As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_MOUNTING_POSITION

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Compensator Number (300A,00E4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_NUMBER
Visual Basic
Public Const COMPENSATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Compensator Pixel Spacing (300A,00E9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_PIXEL_SPACING
Visual Basic
Public Const COMPENSATOR_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_POSITION Field
MCdicom Structure See Also Send Feedback
Compensator Position (300A,00EA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_POSITION
Visual Basic
Public Const COMPENSATOR_POSITION As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_POSITION

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_PROXIMAL_THICKNESS_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_PROXIMAL_THICKNESS_MAP Field
MCdicom Structure See Also Send Feedback
Compensator Proximal Thickness Map (300A,0664)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_PROXIMAL_THICKNESS_MAP
Visual Basic
Public Const COMPENSATOR_PROXIMAL_THICKNESS_MAP As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_PROXIMAL_THICKNESS_MAP

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO Field
MCdicom Structure See Also Send Feedback
Compensator Relative Stopping Power Ratio (300A,02E7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO
Visual Basic
Public Const COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_RELATIVE_STOPPING_POWER_RATIO

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_ROWS Field
MCdicom Structure See Also Send Feedback
Compensator Rows (300A,00E7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_ROWS
Visual Basic
Public Const COMPENSATOR_ROWS As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_ROWS

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Compensator Sequence (300A,00E3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_SEQUENCE
Visual Basic
Public Const COMPENSATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Compensator Shape Fabrication Code Sequence (300A,0667)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE
Visual Basic
Public Const COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_SHAPE_FABRICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_SHAPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_SHAPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Compensator Shape Sequence (300A,0668)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_SHAPE_SEQUENCE
Visual Basic
Public Const COMPENSATOR_SHAPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_SHAPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_THICKNESS_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_THICKNESS_DATA Field
MCdicom Structure See Also Send Feedback
Compensator Thickness Data (300A,00EC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_THICKNESS_DATA
Visual Basic
Public Const COMPENSATOR_THICKNESS_DATA As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_THICKNESS_DATA

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_TRANSMISSION_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_TRANSMISSION_DATA Field
MCdicom Structure See Also Send Feedback
Compensator Transmission Data (300A,00EB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_TRANSMISSION_DATA
Visual Basic
Public Const COMPENSATOR_TRANSMISSION_DATA As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_TRANSMISSION_DATA

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_TRAY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_TRAY_ID Field
MCdicom Structure See Also Send Feedback
Compensator Tray ID (300A,00EF)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_TRAY_ID
Visual Basic
Public Const COMPENSATOR_TRAY_ID As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_TRAY_ID

See Also

MCdicom Structure
MCdicom Members


COMPENSATOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPENSATOR_TYPE Field
MCdicom Structure See Also Send Feedback
Compensator Type (300A,00EE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPENSATOR_TYPE
Visual Basic
Public Const COMPENSATOR_TYPE As UInteger
Visual C++
public:
literal unsigned int COMPENSATOR_TYPE

See Also

MCdicom Structure
MCdicom Members


COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A375)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE
Visual Basic
Public Const COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPLETE_COMPOSITE_OBJECT_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPLETION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPLETION_FLAG Field
MCdicom Structure See Also Send Feedback
Completion Flag (0040,A491)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPLETION_FLAG
Visual Basic
Public Const COMPLETION_FLAG As UInteger
Visual C++
public:
literal unsigned int COMPLETION_FLAG

See Also

MCdicom Structure
MCdicom Members


COMPLETION_FLAG_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPLETION_FLAG_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Completion Flag Description (0040,A492)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPLETION_FLAG_DESCRIPTION
Visual Basic
Public Const COMPLETION_FLAG_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int COMPLETION_FLAG_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


COMPLEX_IMAGE_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPLEX_IMAGE_COMPONENT Field
MCdicom Structure See Also Send Feedback
Complex Image Component (0008,9208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPLEX_IMAGE_COMPONENT
Visual Basic
Public Const COMPLEX_IMAGE_COMPONENT As UInteger
Visual C++
public:
literal unsigned int COMPLEX_IMAGE_COMPONENT

See Also

MCdicom Structure
MCdicom Members


COMPONENT_1_REFERENCED_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_1_REFERENCED_ID Field
MCdicom Structure See Also Send Feedback
Component 1 Referenced ID (0076,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_1_REFERENCED_ID
Visual Basic
Public Const COMPONENT_1_REFERENCED_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_1_REFERENCED_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_1_REFERENCED_MATING_FEATURE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_1_REFERENCED_MATING_FEATURE_ID Field
MCdicom Structure See Also Send Feedback
Component 1 Referenced Mating Feature ID (0076,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_1_REFERENCED_MATING_FEATURE_ID
Visual Basic
Public Const COMPONENT_1_REFERENCED_MATING_FEATURE_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_1_REFERENCED_MATING_FEATURE_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID Field
MCdicom Structure See Also Send Feedback
Component 1 Referenced Mating Feature Set ID (0076,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID
Visual Basic
Public Const COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_1_REFERENCED_MATING_FEATURE_SET_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_2_REFERENCED_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_2_REFERENCED_ID Field
MCdicom Structure See Also Send Feedback
Component 2 Referenced ID (0076,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_2_REFERENCED_ID
Visual Basic
Public Const COMPONENT_2_REFERENCED_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_2_REFERENCED_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_2_REFERENCED_MATING_FEATURE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_2_REFERENCED_MATING_FEATURE_ID Field
MCdicom Structure See Also Send Feedback
Component 2 Referenced Mating Feature ID (0076,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_2_REFERENCED_MATING_FEATURE_ID
Visual Basic
Public Const COMPONENT_2_REFERENCED_MATING_FEATURE_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_2_REFERENCED_MATING_FEATURE_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID Field
MCdicom Structure See Also Send Feedback
Component 2 Referenced Mating Feature Set ID (0076,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID
Visual Basic
Public Const COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_2_REFERENCED_MATING_FEATURE_SET_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_ASSEMBLY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_ASSEMBLY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Component Assembly Sequence (0076,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_ASSEMBLY_SEQUENCE
Visual Basic
Public Const COMPONENT_ASSEMBLY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_ASSEMBLY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_ID Field
MCdicom Structure See Also Send Feedback
Component ID (0076,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_ID
Visual Basic
Public Const COMPONENT_ID As UInteger
Visual C++
public:
literal unsigned int COMPONENT_ID

See Also

MCdicom Structure
MCdicom Members


COMPONENT_INPUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_INPUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Component Input Sequence (0070,1803)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_INPUT_SEQUENCE
Visual Basic
Public Const COMPONENT_INPUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_INPUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Component Manufacturer (0014,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_MANUFACTURER
Visual Basic
Public Const COMPONENT_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int COMPONENT_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


COMPONENT_MANUFACTURING_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_MANUFACTURING_PROCEDURE Field
MCdicom Structure See Also Send Feedback
Component Manufacturing Procedure (0014,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_MANUFACTURING_PROCEDURE
Visual Basic
Public Const COMPONENT_MANUFACTURING_PROCEDURE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_MANUFACTURING_PROCEDURE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_REFERENCE_SYSTEM_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_REFERENCE_SYSTEM_RETIRED Field
MCdicom Structure See Also Send Feedback
Component Reference System RETIRED (0014,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_REFERENCE_SYSTEM_RETIRED
Visual Basic
Public Const COMPONENT_REFERENCE_SYSTEM_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMPONENT_REFERENCE_SYSTEM_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMPONENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Component Sequence (0076,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_SEQUENCE
Visual Basic
Public Const COMPONENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_SHAPE Field
MCdicom Structure See Also Send Feedback
Component Shape (0014,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_SHAPE
Visual Basic
Public Const COMPONENT_SHAPE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_SHAPE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_TYPE Field
MCdicom Structure See Also Send Feedback
Component Type (0070,1802)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_TYPE
Visual Basic
Public Const COMPONENT_TYPE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_TYPE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Component Type Code Sequence (0076,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const COMPONENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPONENT_TYPES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPONENT_TYPES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Component Types Sequence (0076,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPONENT_TYPES_SEQUENCE
Visual Basic
Public Const COMPONENT_TYPES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPONENT_TYPES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPOSITING_METHOD_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPOSITING_METHOD_RETIRED Field
MCdicom Structure See Also Send Feedback
Compositing Method RETIRED (0070,1206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPOSITING_METHOD_RETIRED
Visual Basic
Public Const COMPOSITING_METHOD_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMPOSITING_METHOD_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMPOUND_GRAPHIC_INSTANCE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPOUND_GRAPHIC_INSTANCE_ID Field
MCdicom Structure See Also Send Feedback
Compound Graphic Instance ID (0070,0226)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPOUND_GRAPHIC_INSTANCE_ID
Visual Basic
Public Const COMPOUND_GRAPHIC_INSTANCE_ID As UInteger
Visual C++
public:
literal unsigned int COMPOUND_GRAPHIC_INSTANCE_ID

See Also

MCdicom Structure
MCdicom Members


COMPOUND_GRAPHIC_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPOUND_GRAPHIC_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Compound Graphic Sequence (0070,0209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPOUND_GRAPHIC_SEQUENCE
Visual Basic
Public Const COMPOUND_GRAPHIC_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COMPOUND_GRAPHIC_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COMPOUND_GRAPHIC_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPOUND_GRAPHIC_TYPE Field
MCdicom Structure See Also Send Feedback
Compound Graphic Type (0070,0294)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPOUND_GRAPHIC_TYPE
Visual Basic
Public Const COMPOUND_GRAPHIC_TYPE As UInteger
Visual C++
public:
literal unsigned int COMPOUND_GRAPHIC_TYPE

See Also

MCdicom Structure
MCdicom Members


COMPOUND_GRAPHIC_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPOUND_GRAPHIC_UNITS Field
MCdicom Structure See Also Send Feedback
Compound Graphic Units (0070,0282)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPOUND_GRAPHIC_UNITS
Visual Basic
Public Const COMPOUND_GRAPHIC_UNITS As UInteger
Visual C++
public:
literal unsigned int COMPOUND_GRAPHIC_UNITS

See Also

MCdicom Structure
MCdicom Members


COMPRESSION_CODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPRESSION_CODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Compression Code RETIRED (0028,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPRESSION_CODE_RETIRED
Visual Basic
Public Const COMPRESSION_CODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COMPRESSION_CODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COMPRESSION_CONTACT_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPRESSION_CONTACT_AREA Field
MCdicom Structure See Also Send Feedback
Compression Contact Area (0018,11A5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPRESSION_CONTACT_AREA
Visual Basic
Public Const COMPRESSION_CONTACT_AREA As UInteger
Visual C++
public:
literal unsigned int COMPRESSION_CONTACT_AREA

See Also

MCdicom Structure
MCdicom Members


COMPRESSION_FORCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPRESSION_FORCE Field
MCdicom Structure See Also Send Feedback
Compression Force (0018,11A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPRESSION_FORCE
Visual Basic
Public Const COMPRESSION_FORCE As UInteger
Visual C++
public:
literal unsigned int COMPRESSION_FORCE

See Also

MCdicom Structure
MCdicom Members


COMPRESSION_PRESSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COMPRESSION_PRESSURE Field
MCdicom Structure See Also Send Feedback
Compression Pressure (0018,11A3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COMPRESSION_PRESSURE
Visual Basic
Public Const COMPRESSION_PRESSURE As UInteger
Visual C++
public:
literal unsigned int COMPRESSION_PRESSURE

See Also

MCdicom Structure
MCdicom Members


CONCATENATION_FRAME_OFFSET_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCATENATION_FRAME_OFFSET_NUMBER Field
MCdicom Structure See Also Send Feedback
Concatenation Frame Offset Number (0020,9228)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCATENATION_FRAME_OFFSET_NUMBER
Visual Basic
Public Const CONCATENATION_FRAME_OFFSET_NUMBER As UInteger
Visual C++
public:
literal unsigned int CONCATENATION_FRAME_OFFSET_NUMBER

See Also

MCdicom Structure
MCdicom Members


CONCATENATION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCATENATION_UID Field
MCdicom Structure See Also Send Feedback
Concatenation UID (0020,9161)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCATENATION_UID
Visual Basic
Public Const CONCATENATION_UID As UInteger
Visual C++
public:
literal unsigned int CONCATENATION_UID

See Also

MCdicom Structure
MCdicom Members


CONCEPT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Concept Code Sequence (0040,A168)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPT_CODE_SEQUENCE
Visual Basic
Public Const CONCEPT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPT_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPT_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Concept Name Code Sequence (0040,A043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPT_NAME_CODE_SEQUENCE
Visual Basic
Public Const CONCEPT_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPT_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Blocking Constraint (3010,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT
Visual Basic
Public Const CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_BLOCKING_CONSTRAINT

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Category Code Sequence (3010,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Combination Description (3010,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION
Visual Basic
Public Const CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_COMBINATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Combination Expression (3010,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION
Visual Basic
Public Const CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_COMBINATION_EXPRESSION

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_COMBINATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_COMBINATION_FLAG Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Combination Flag (3010,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_COMBINATION_FLAG
Visual Basic
Public Const CONCEPTUAL_VOLUME_COMBINATION_FLAG As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_COMBINATION_FLAG

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_CONSTITUENT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_CONSTITUENT_INDEX Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Constituent Index (3010,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_CONSTITUENT_INDEX
Visual Basic
Public Const CONCEPTUAL_VOLUME_CONSTITUENT_INDEX As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_CONSTITUENT_INDEX

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Constituent Segmentation Reference Sequence (3010,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Constituent Sequence (3010,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_CONSTITUENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Derivation Algorithm Sequence (3010,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_DERIVATION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Description (3010,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_DESCRIPTION
Visual Basic
Public Const CONCEPTUAL_VOLUME_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Identification Sequence (3010,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Optimization Precedence (3010,0066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_OPTIMIZATION_PRECEDENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Segmentation Defined Flag (3010,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG
Visual Basic
Public Const CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_SEGMENTATION_DEFINED_FLAG

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Segmentation Reference Sequence (3010,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Sequence (3010,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Type Code Sequence (3010,0069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conceptual Volume Type Modifier Code Sequence (3010,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_TYPE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONCEPTUAL_VOLUME_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONCEPTUAL_VOLUME_UID Field
MCdicom Structure See Also Send Feedback
Conceptual Volume UID (3010,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONCEPTUAL_VOLUME_UID
Visual Basic
Public Const CONCEPTUAL_VOLUME_UID As UInteger
Visual C++
public:
literal unsigned int CONCEPTUAL_VOLUME_UID

See Also

MCdicom Structure
MCdicom Members


CONDENSER_LENS_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONDENSER_LENS_POWER Field
MCdicom Structure See Also Send Feedback
Condenser Lens Power (0048,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONDENSER_LENS_POWER
Visual Basic
Public Const CONDENSER_LENS_POWER As UInteger
Visual C++
public:
literal unsigned int CONDENSER_LENS_POWER

See Also

MCdicom Structure
MCdicom Members


CONFIDENTIALITY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIDENTIALITY_CODE Field
MCdicom Structure See Also Send Feedback
Confidentiality Code (0040,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIDENTIALITY_CODE
Visual Basic
Public Const CONFIDENTIALITY_CODE As UInteger
Visual C++
public:
literal unsigned int CONFIDENTIALITY_CODE

See Also

MCdicom Structure
MCdicom Members


CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Confidentiality Constraint on Patient Data Description (0040,3001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION
Visual Basic
Public Const CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONFIDENTIALITY_CONSTRAINT_ON_PATIENT_DATA_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Configuration Description (0028,700D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_DESCRIPTION
Visual Basic
Public Const CONFIGURATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_ID Field
MCdicom Structure See Also Send Feedback
Configuration ID (0028,700B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_ID
Visual Basic
Public Const CONFIGURATION_ID As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_ID

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_INFORMATION Field
MCdicom Structure See Also Send Feedback
Configuration Information (2010,0150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_INFORMATION
Visual Basic
Public Const CONFIGURATION_INFORMATION As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_INFORMATION

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_INFORMATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_INFORMATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Configuration Information Description (2010,0152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_INFORMATION_DESCRIPTION
Visual Basic
Public Const CONFIGURATION_INFORMATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_INFORMATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_NAME Field
MCdicom Structure See Also Send Feedback
Configuration Name (0028,700C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_NAME
Visual Basic
Public Const CONFIGURATION_NAME As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_NAME

See Also

MCdicom Structure
MCdicom Members


CONFIGURATION_QA_RESULTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIGURATION_QA_RESULTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Configuration QA Results Sequence (0028,7011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIGURATION_QA_RESULTS_SEQUENCE
Visual Basic
Public Const CONFIGURATION_QA_RESULTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONFIGURATION_QA_RESULTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONFIRMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONFIRMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Confirmation Sequence (300A,073F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONFIRMATION_SEQUENCE
Visual Basic
Public Const CONFIRMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONFIRMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Consent for Clinical Trial Use Sequence (0012,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE
Visual Basic
Public Const CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONSENT_FOR_CLINICAL_TRIAL_USE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONSENT_FOR_DISTRIBUTION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSENT_FOR_DISTRIBUTION_FLAG Field
MCdicom Structure See Also Send Feedback
Consent for Distribution Flag (0012,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSENT_FOR_DISTRIBUTION_FLAG
Visual Basic
Public Const CONSENT_FOR_DISTRIBUTION_FLAG As UInteger
Visual C++
public:
literal unsigned int CONSENT_FOR_DISTRIBUTION_FLAG

See Also

MCdicom Structure
MCdicom Members


CONSTANT_VOLUME_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTANT_VOLUME_FLAG Field
MCdicom Structure See Also Send Feedback
Constant Volume Flag (0018,9333)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTANT_VOLUME_FLAG
Visual Basic
Public Const CONSTANT_VOLUME_FLAG As UInteger
Visual C++
public:
literal unsigned int CONSTANT_VOLUME_FLAG

See Also

MCdicom Structure
MCdicom Members


CONSTITUENT_CONCEPTUAL_VOLUME_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTITUENT_CONCEPTUAL_VOLUME_UID Field
MCdicom Structure See Also Send Feedback
Constituent Conceptual Volume UID (3010,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTITUENT_CONCEPTUAL_VOLUME_UID
Visual Basic
Public Const CONSTITUENT_CONCEPTUAL_VOLUME_UID As UInteger
Visual C++
public:
literal unsigned int CONSTITUENT_CONCEPTUAL_VOLUME_UID

See Also

MCdicom Structure
MCdicom Members


CONSTRAINT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTRAINT_TYPE Field
MCdicom Structure See Also Send Feedback
Constraint Type (0082,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTRAINT_TYPE
Visual Basic
Public Const CONSTRAINT_TYPE As UInteger
Visual C++
public:
literal unsigned int CONSTRAINT_TYPE

See Also

MCdicom Structure
MCdicom Members


CONSTRAINT_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTRAINT_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Constraint Value Sequence (0082,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTRAINT_VALUE_SEQUENCE
Visual Basic
Public Const CONSTRAINT_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONSTRAINT_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONSTRAINT_VIOLATION_CONDITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTRAINT_VIOLATION_CONDITION Field
MCdicom Structure See Also Send Feedback
Constraint Violation Condition (0082,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTRAINT_VIOLATION_CONDITION
Visual Basic
Public Const CONSTRAINT_VIOLATION_CONDITION As UInteger
Visual C++
public:
literal unsigned int CONSTRAINT_VIOLATION_CONDITION

See Also

MCdicom Structure
MCdicom Members


CONSTRAINT_VIOLATION_SIGNIFICANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTRAINT_VIOLATION_SIGNIFICANCE Field
MCdicom Structure See Also Send Feedback
Constraint Violation Significance (0082,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTRAINT_VIOLATION_SIGNIFICANCE
Visual Basic
Public Const CONSTRAINT_VIOLATION_SIGNIFICANCE As UInteger
Visual C++
public:
literal unsigned int CONSTRAINT_VIOLATION_SIGNIFICANCE

See Also

MCdicom Structure
MCdicom Members


CONSTRAINT_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSTRAINT_WEIGHT Field
MCdicom Structure See Also Send Feedback
Constraint Weight (300A,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSTRAINT_WEIGHT
Visual Basic
Public Const CONSTRAINT_WEIGHT As UInteger
Visual C++
public:
literal unsigned int CONSTRAINT_WEIGHT

See Also

MCdicom Structure
MCdicom Members


CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Consulting Physician Identification Sequence (0008,009D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONSULTING_PHYSICIAN_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONSULTING_PHYSICIANS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONSULTING_PHYSICIANS_NAME Field
MCdicom Structure See Also Send Feedback
Consulting Physician's Name (0008,009C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONSULTING_PHYSICIANS_NAME
Visual Basic
Public Const CONSULTING_PHYSICIANS_NAME As UInteger
Visual C++
public:
literal unsigned int CONSULTING_PHYSICIANS_NAME

See Also

MCdicom Structure
MCdicom Members


CONTACT_DISPLAY_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTACT_DISPLAY_NAME Field
MCdicom Structure See Also Send Feedback
Contact Display Name (0074,100C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTACT_DISPLAY_NAME
Visual Basic
Public Const CONTACT_DISPLAY_NAME As UInteger
Visual C++
public:
literal unsigned int CONTACT_DISPLAY_NAME

See Also

MCdicom Structure
MCdicom Members


CONTACT_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTACT_METHOD Field
MCdicom Structure See Also Send Feedback
Contact Method (0016,1003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTACT_METHOD
Visual Basic
Public Const CONTACT_METHOD As UInteger
Visual C++
public:
literal unsigned int CONTACT_METHOD

See Also

MCdicom Structure
MCdicom Members


CONTACT_URI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTACT_URI Field
MCdicom Structure See Also Send Feedback
Contact URI (0074,100A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTACT_URI
Visual Basic
Public Const CONTACT_URI As UInteger
Visual C++
public:
literal unsigned int CONTACT_URI

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Container Component Description (0050,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_DESCRIPTION
Visual Basic
Public Const CONTAINER_COMPONENT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_DIAMETER Field
MCdicom Structure See Also Send Feedback
Container Component Diameter (0050,001D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_DIAMETER
Visual Basic
Public Const CONTAINER_COMPONENT_DIAMETER As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_DIAMETER

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_ID Field
MCdicom Structure See Also Send Feedback
Container Component ID (0050,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_ID
Visual Basic
Public Const CONTAINER_COMPONENT_ID As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_ID

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_LENGTH Field
MCdicom Structure See Also Send Feedback
Container Component Length (0050,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_LENGTH
Visual Basic
Public Const CONTAINER_COMPONENT_LENGTH As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_LENGTH

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_MATERIAL Field
MCdicom Structure See Also Send Feedback
Container Component Material (0050,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_MATERIAL
Visual Basic
Public Const CONTAINER_COMPONENT_MATERIAL As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_MATERIAL

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Container Component Sequence (0040,0520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_SEQUENCE
Visual Basic
Public Const CONTAINER_COMPONENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Container Component Thickness (0050,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_THICKNESS
Visual Basic
Public Const CONTAINER_COMPONENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Container Component Type Code Sequence (0050,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTAINER_COMPONENT_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_COMPONENT_WIDTH Field
MCdicom Structure See Also Send Feedback
Container Component Width (0050,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_COMPONENT_WIDTH
Visual Basic
Public Const CONTAINER_COMPONENT_WIDTH As UInteger
Visual C++
public:
literal unsigned int CONTAINER_COMPONENT_WIDTH

See Also

MCdicom Structure
MCdicom Members


CONTAINER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Container Description (0040,051A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_DESCRIPTION
Visual Basic
Public Const CONTAINER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONTAINER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONTAINER_FILE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_FILE_TYPE Field
MCdicom Structure See Also Send Feedback
Container File Type (0008,040A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_FILE_TYPE
Visual Basic
Public Const CONTAINER_FILE_TYPE As UInteger
Visual C++
public:
literal unsigned int CONTAINER_FILE_TYPE

See Also

MCdicom Structure
MCdicom Members


CONTAINER_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Container Identifier (0040,0512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_IDENTIFIER
Visual Basic
Public Const CONTAINER_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int CONTAINER_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


CONTAINER_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTAINER_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Container Type Code Sequence (0040,0518)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTAINER_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CONTAINER_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTAINER_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Content Creator's Identification Code Sequence (0070,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_CREATORS_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_CREATORS_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_CREATORS_IDENTIFICATION_CODE_SEQUENCE (0070,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_CREATORS_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const CONTENT_CREATORS_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTENT_CREATORS_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_CREATORS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_CREATORS_NAME Field
MCdicom Structure See Also Send Feedback
Content Creator's Name (0070,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_CREATORS_NAME
Visual Basic
Public Const CONTENT_CREATORS_NAME As UInteger
Visual C++
public:
literal unsigned int CONTENT_CREATORS_NAME

See Also

MCdicom Structure
MCdicom Members


CONTENT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_DATE Field
MCdicom Structure See Also Send Feedback
Content Date (0008,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_DATE
Visual Basic
Public Const CONTENT_DATE As UInteger
Visual C++
public:
literal unsigned int CONTENT_DATE

See Also

MCdicom Structure
MCdicom Members


CONTENT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Content Description (0070,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_DESCRIPTION
Visual Basic
Public Const CONTENT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONTENT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONTENT_ITEM_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_ITEM_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Content Item Modifier Sequence (0040,0441)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_ITEM_MODIFIER_SEQUENCE
Visual Basic
Public Const CONTENT_ITEM_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTENT_ITEM_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_LABEL Field
MCdicom Structure See Also Send Feedback
Content Label (0070,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_LABEL
Visual Basic
Public Const CONTENT_LABEL As UInteger
Visual C++
public:
literal unsigned int CONTENT_LABEL

See Also

MCdicom Structure
MCdicom Members


CONTENT_QUALIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_QUALIFICATION Field
MCdicom Structure See Also Send Feedback
Content Qualification (0018,9004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_QUALIFICATION
Visual Basic
Public Const CONTENT_QUALIFICATION As UInteger
Visual C++
public:
literal unsigned int CONTENT_QUALIFICATION

See Also

MCdicom Structure
MCdicom Members


CONTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Content Sequence (0040,A730)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_SEQUENCE
Visual Basic
Public Const CONTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Content Template Sequence (0040,A504)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_TEMPLATE_SEQUENCE
Visual Basic
Public Const CONTENT_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTENT_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTENT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTENT_TIME Field
MCdicom Structure See Also Send Feedback
Content Time (0008,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTENT_TIME
Visual Basic
Public Const CONTENT_TIME As UInteger
Visual C++
public:
literal unsigned int CONTENT_TIME

See Also

MCdicom Structure
MCdicom Members


CONTEXT_GROUP_EXTENSION_CREATOR_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_GROUP_EXTENSION_CREATOR_UID Field
MCdicom Structure See Also Send Feedback
Context Group Extension Creator UID (0008,010D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_GROUP_EXTENSION_CREATOR_UID
Visual Basic
Public Const CONTEXT_GROUP_EXTENSION_CREATOR_UID As UInteger
Visual C++
public:
literal unsigned int CONTEXT_GROUP_EXTENSION_CREATOR_UID

See Also

MCdicom Structure
MCdicom Members


CONTEXT_GROUP_EXTENSION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_GROUP_EXTENSION_FLAG Field
MCdicom Structure See Also Send Feedback
Context Group Extension Flag (0008,010B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_GROUP_EXTENSION_FLAG
Visual Basic
Public Const CONTEXT_GROUP_EXTENSION_FLAG As UInteger
Visual C++
public:
literal unsigned int CONTEXT_GROUP_EXTENSION_FLAG

See Also

MCdicom Structure
MCdicom Members


CONTEXT_GROUP_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_GROUP_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Context Group Identification Sequence (0008,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_GROUP_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const CONTEXT_GROUP_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTEXT_GROUP_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTEXT_GROUP_LOCAL_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_GROUP_LOCAL_VERSION Field
MCdicom Structure See Also Send Feedback
Context Group Local Version (0008,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_GROUP_LOCAL_VERSION
Visual Basic
Public Const CONTEXT_GROUP_LOCAL_VERSION As UInteger
Visual C++
public:
literal unsigned int CONTEXT_GROUP_LOCAL_VERSION

See Also

MCdicom Structure
MCdicom Members


CONTEXT_GROUP_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_GROUP_VERSION Field
MCdicom Structure See Also Send Feedback
Context Group Version (0008,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_GROUP_VERSION
Visual Basic
Public Const CONTEXT_GROUP_VERSION As UInteger
Visual C++
public:
literal unsigned int CONTEXT_GROUP_VERSION

See Also

MCdicom Structure
MCdicom Members


CONTEXT_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Context Identifier (0008,010F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_IDENTIFIER
Visual Basic
Public Const CONTEXT_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int CONTEXT_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


CONTEXT_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTEXT_UID Field
MCdicom Structure See Also Send Feedback
Context UID (0008,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTEXT_UID
Visual Basic
Public Const CONTEXT_UID As UInteger
Visual C++
public:
literal unsigned int CONTEXT_UID

See Also

MCdicom Structure
MCdicom Members


CONTINUATION_END_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUATION_END_METERSET Field
MCdicom Structure See Also Send Feedback
Continuation End Meterset (0074,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUATION_END_METERSET
Visual Basic
Public Const CONTINUATION_END_METERSET As UInteger
Visual C++
public:
literal unsigned int CONTINUATION_END_METERSET

See Also

MCdicom Structure
MCdicom Members


CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA Field
MCdicom Structure See Also Send Feedback
Continuation End Total Reference Air Kerma (0074,1403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA
Visual Basic
Public Const CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA As UInteger
Visual C++
public:
literal unsigned int CONTINUATION_END_TOTAL_REFERENCE_AIR_KERMA

See Also

MCdicom Structure
MCdicom Members


CONTINUATION_PULSE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUATION_PULSE_NUMBER Field
MCdicom Structure See Also Send Feedback
Continuation Pulse Number (0074,1404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUATION_PULSE_NUMBER
Visual Basic
Public Const CONTINUATION_PULSE_NUMBER As UInteger
Visual C++
public:
literal unsigned int CONTINUATION_PULSE_NUMBER

See Also

MCdicom Structure
MCdicom Members


CONTINUATION_START_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUATION_START_METERSET Field
MCdicom Structure See Also Send Feedback
Continuation Start Meterset (0074,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUATION_START_METERSET
Visual Basic
Public Const CONTINUATION_START_METERSET As UInteger
Visual C++
public:
literal unsigned int CONTINUATION_START_METERSET

See Also

MCdicom Structure
MCdicom Members


CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA Field
MCdicom Structure See Also Send Feedback
Continuation Start Total Reference Air Kerma (0074,1402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA
Visual Basic
Public Const CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA As UInteger
Visual C++
public:
literal unsigned int CONTINUATION_START_TOTAL_REFERENCE_AIR_KERMA

See Also

MCdicom Structure
MCdicom Members


CONTINUITY_OF_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTINUITY_OF_CONTENT Field
MCdicom Structure See Also Send Feedback
Continuity Of Content (0040,A050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTINUITY_OF_CONTENT
Visual Basic
Public Const CONTINUITY_OF_CONTENT As UInteger
Visual C++
public:
literal unsigned int CONTINUITY_OF_CONTENT

See Also

MCdicom Structure
MCdicom Members


CONTOUR_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_DATA Field
MCdicom Structure See Also Send Feedback
Contour Data (3006,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_DATA
Visual Basic
Public Const CONTOUR_DATA As UInteger
Visual C++
public:
literal unsigned int CONTOUR_DATA

See Also

MCdicom Structure
MCdicom Members


CONTOUR_GEOMETRIC_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_GEOMETRIC_TYPE Field
MCdicom Structure See Also Send Feedback
Contour Geometric Type (3006,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_GEOMETRIC_TYPE
Visual Basic
Public Const CONTOUR_GEOMETRIC_TYPE As UInteger
Visual C++
public:
literal unsigned int CONTOUR_GEOMETRIC_TYPE

See Also

MCdicom Structure
MCdicom Members


CONTOUR_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contour Image Sequence (3006,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_IMAGE_SEQUENCE
Visual Basic
Public Const CONTOUR_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTOUR_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTOUR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_NUMBER Field
MCdicom Structure See Also Send Feedback
Contour Number (3006,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_NUMBER
Visual Basic
Public Const CONTOUR_NUMBER As UInteger
Visual C++
public:
literal unsigned int CONTOUR_NUMBER

See Also

MCdicom Structure
MCdicom Members


CONTOUR_OFFSET_VECTOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_OFFSET_VECTOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Contour Offset Vector RETIRED (3006,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_OFFSET_VECTOR_RETIRED
Visual Basic
Public Const CONTOUR_OFFSET_VECTOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int CONTOUR_OFFSET_VECTOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


CONTOUR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contour Sequence (3006,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_SEQUENCE
Visual Basic
Public Const CONTOUR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTOUR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTOUR_SLAB_THICKNESS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_SLAB_THICKNESS_RETIRED Field
MCdicom Structure See Also Send Feedback
Contour Slab Thickness RETIRED (3006,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_SLAB_THICKNESS_RETIRED
Visual Basic
Public Const CONTOUR_SLAB_THICKNESS_RETIRED As UInteger
Visual C++
public:
literal unsigned int CONTOUR_SLAB_THICKNESS_RETIRED

See Also

MCdicom Structure
MCdicom Members


CONTOUR_UNCERTAINTY_RADIUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTOUR_UNCERTAINTY_RADIUS Field
MCdicom Structure See Also Send Feedback
Contour Uncertainty Radius (0070,0312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTOUR_UNCERTAINTY_RADIUS
Visual Basic
Public Const CONTOUR_UNCERTAINTY_RADIUS As UInteger
Visual C++
public:
literal unsigned int CONTOUR_UNCERTAINTY_RADIUS

See Also

MCdicom Structure
MCdicom Members


CONTRAINDICATIONS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAINDICATIONS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contraindications Code Sequence (0018,990B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAINDICATIONS_CODE_SEQUENCE
Visual Basic
Public Const CONTRAINDICATIONS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAINDICATIONS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST Field
MCdicom Structure See Also Send Feedback
Contrast (0016,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST
Visual Basic
Public Const CONTRAST As UInteger
Visual C++
public:
literal unsigned int CONTRAST

See Also

MCdicom Structure
MCdicom Members


CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contrast Administration Profile Sequence (0018,9340)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE
Visual Basic
Public Const CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_ADMINISTRATION_PROFILE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_ALLERGIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_ALLERGIES Field
MCdicom Structure See Also Send Feedback
Alias for tag ALLERGIES (0010,2110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_ALLERGIES
Visual Basic
Public Const CONTRAST_ALLERGIES As UInteger
Visual C++
public:
literal unsigned int CONTRAST_ALLERGIES

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Administration Route Sequence (0018,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE
Visual Basic
Public Const CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_ADMINISTRATION_ROUTE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent (0018,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT
Visual Basic
Public Const CONTRAST_BOLUS_AGENT As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT_ADMINISTERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT_ADMINISTERED Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent Administered (0018,9342)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT_ADMINISTERED
Visual Basic
Public Const CONTRAST_BOLUS_AGENT_ADMINISTERED As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT_ADMINISTERED

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT_DETECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT_DETECTED Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent Detected (0018,9343)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT_DETECTED
Visual Basic
Public Const CONTRAST_BOLUS_AGENT_DETECTED As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT_DETECTED

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent Number (0018,9337)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT_NUMBER
Visual Basic
Public Const CONTRAST_BOLUS_AGENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT_PHASE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent Phase (0018,9344)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT_PHASE
Visual Basic
Public Const CONTRAST_BOLUS_AGENT_PHASE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT_PHASE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AGENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AGENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Agent Sequence (0018,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AGENT_SEQUENCE
Visual Basic
Public Const CONTRAST_BOLUS_AGENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AGENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Auto Injection Trigger Flag (0018,11B6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG
Visual Basic
Public Const CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_AUTO_INJECTION_TRIGGER_FLAG

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INGREDIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INGREDIENT Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Ingredient (0018,1048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INGREDIENT
Visual Basic
Public Const CONTRAST_BOLUS_INGREDIENT As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INGREDIENT

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Ingredient Code Sequence (0018,9338)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE
Visual Basic
Public Const CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INGREDIENT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INGREDIENT_CONCENTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INGREDIENT_CONCENTRATION Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Ingredient Concentration (0018,1049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INGREDIENT_CONCENTRATION
Visual Basic
Public Const CONTRAST_BOLUS_INGREDIENT_CONCENTRATION As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INGREDIENT_CONCENTRATION

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INGREDIENT_OPAQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INGREDIENT_OPAQUE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Ingredient Opaque (0018,9425)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INGREDIENT_OPAQUE
Visual Basic
Public Const CONTRAST_BOLUS_INGREDIENT_OPAQUE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INGREDIENT_OPAQUE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Ingredient Percent by Volume (0052,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME
Visual Basic
Public Const CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INGREDIENT_PERCENT_BY_VOLUME

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_INJECTION_DELAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_INJECTION_DELAY Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Injection Delay (0018,11B7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_INJECTION_DELAY
Visual Basic
Public Const CONTRAST_BOLUS_INJECTION_DELAY As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_INJECTION_DELAY

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_ROUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_ROUTE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Route (0018,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_ROUTE
Visual Basic
Public Const CONTRAST_BOLUS_ROUTE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_ROUTE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_START_TIME Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Start Time (0018,1042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_START_TIME
Visual Basic
Public Const CONTRAST_BOLUS_START_TIME As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_START_TIME

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_STOP_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_STOP_TIME Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Stop Time (0018,1043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_STOP_TIME
Visual Basic
Public Const CONTRAST_BOLUS_STOP_TIME As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_STOP_TIME

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_T1_RELAXIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_T1_RELAXIVITY Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus T1 Relaxivity (0018,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_T1_RELAXIVITY
Visual Basic
Public Const CONTRAST_BOLUS_T1_RELAXIVITY As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_T1_RELAXIVITY

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_TOTAL_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_TOTAL_DOSE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Total Dose (0018,1044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_TOTAL_DOSE
Visual Basic
Public Const CONTRAST_BOLUS_TOTAL_DOSE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_TOTAL_DOSE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_USAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_USAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Usage Sequence (0018,9341)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_USAGE_SEQUENCE
Visual Basic
Public Const CONTRAST_BOLUS_USAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_USAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_BOLUS_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_BOLUS_VOLUME Field
MCdicom Structure See Also Send Feedback
Contrast/Bolus Volume (0018,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_BOLUS_VOLUME
Visual Basic
Public Const CONTRAST_BOLUS_VOLUME As UInteger
Visual C++
public:
literal unsigned int CONTRAST_BOLUS_VOLUME

See Also

MCdicom Structure
MCdicom Members


CONTRAST_FLOW_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_FLOW_DURATION Field
MCdicom Structure See Also Send Feedback
Contrast Flow Duration (0018,1047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_FLOW_DURATION
Visual Basic
Public Const CONTRAST_FLOW_DURATION As UInteger
Visual C++
public:
literal unsigned int CONTRAST_FLOW_DURATION

See Also

MCdicom Structure
MCdicom Members


CONTRAST_FLOW_DURATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_FLOW_DURATIONS Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTRAST_FLOW_DURATION (0018,1047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_FLOW_DURATIONS
Visual Basic
Public Const CONTRAST_FLOW_DURATIONS As UInteger
Visual C++
public:
literal unsigned int CONTRAST_FLOW_DURATIONS

See Also

MCdicom Structure
MCdicom Members


CONTRAST_FLOW_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_FLOW_RATE Field
MCdicom Structure See Also Send Feedback
Contrast Flow Rate (0018,1046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_FLOW_RATE
Visual Basic
Public Const CONTRAST_FLOW_RATE As UInteger
Visual C++
public:
literal unsigned int CONTRAST_FLOW_RATE

See Also

MCdicom Structure
MCdicom Members


CONTRAST_FLOW_RATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_FLOW_RATES Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTRAST_FLOW_RATE (0018,1046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_FLOW_RATES
Visual Basic
Public Const CONTRAST_FLOW_RATES As UInteger
Visual C++
public:
literal unsigned int CONTRAST_FLOW_RATES

See Also

MCdicom Structure
MCdicom Members


CONTRAST_FRAME_AVERAGING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRAST_FRAME_AVERAGING Field
MCdicom Structure See Also Send Feedback
Contrast Frame Averaging (0028,6112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRAST_FRAME_AVERAGING
Visual Basic
Public Const CONTRAST_FRAME_AVERAGING As UInteger
Visual C++
public:
literal unsigned int CONTRAST_FRAME_AVERAGING

See Also

MCdicom Structure
MCdicom Members


CONTRIBUTING_EQUIPMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRIBUTING_EQUIPMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contributing Equipment Sequence (0018,A001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRIBUTING_EQUIPMENT_SEQUENCE
Visual Basic
Public Const CONTRIBUTING_EQUIPMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRIBUTING_EQUIPMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contributing SOP Instances Reference Sequence (0020,9529)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE
Visual Basic
Public Const CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRIBUTING_SOP_INSTANCES_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRIBUTING_SOURCES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRIBUTING_SOURCES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Contributing Sources Sequence (0018,9506)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRIBUTING_SOURCES_SEQUENCE
Visual Basic
Public Const CONTRIBUTING_SOURCES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTRIBUTING_SOURCES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTRIBUTION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRIBUTION_DATETIME Field
MCdicom Structure See Also Send Feedback
Contribution DateTime (0018,A002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRIBUTION_DATETIME
Visual Basic
Public Const CONTRIBUTION_DATETIME As UInteger
Visual C++
public:
literal unsigned int CONTRIBUTION_DATETIME

See Also

MCdicom Structure
MCdicom Members


CONTRIBUTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTRIBUTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Contribution Description (0018,A003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTRIBUTION_DESCRIPTION
Visual Basic
Public Const CONTRIBUTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int CONTRIBUTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_3D_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_3D_POSITION Field
MCdicom Structure See Also Send Feedback
Control Point 3D Position (300A,02D4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_3D_POSITION
Visual Basic
Public Const CONTROL_POINT_3D_POSITION As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_3D_POSITION

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_DELIVERY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_DELIVERY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Control Point Delivery Sequence (3008,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_DELIVERY_SEQUENCE
Visual Basic
Public Const CONTROL_POINT_DELIVERY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_DELIVERY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
Control Point Index (300A,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_INDEX
Visual Basic
Public Const CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Control Point Orientation (300A,0412)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_ORIENTATION
Visual Basic
Public Const CONTROL_POINT_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_RELATIVE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_RELATIVE_POSITION Field
MCdicom Structure See Also Send Feedback
Control Point Relative Position (300A,02D2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_RELATIVE_POSITION
Visual Basic
Public Const CONTROL_POINT_RELATIVE_POSITION As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_RELATIVE_POSITION

See Also

MCdicom Structure
MCdicom Members


CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Control Point Sequence (300A,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONTROL_POINT_SEQUENCE
Visual Basic
Public Const CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conventional Control Point Verification Sequence (0074,104C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE
Visual Basic
Public Const CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONVENTIONAL_CONTROL_POINT_VERIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conventional Machine Verification Sequence (0074,1044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE
Visual Basic
Public Const CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONVENTIONAL_MACHINE_VERIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Conversion Source Attributes Sequence (0020,9172)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CONVERSION_SOURCE_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CONVERSION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVERSION_TYPE Field
MCdicom Structure See Also Send Feedback
Conversion Type (0008,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVERSION_TYPE
Visual Basic
Public Const CONVERSION_TYPE As UInteger
Visual C++
public:
literal unsigned int CONVERSION_TYPE

See Also

MCdicom Structure
MCdicom Members


CONVOLUTION_KERNEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVOLUTION_KERNEL Field
MCdicom Structure See Also Send Feedback
Convolution Kernel (0018,1210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVOLUTION_KERNEL
Visual Basic
Public Const CONVOLUTION_KERNEL As UInteger
Visual C++
public:
literal unsigned int CONVOLUTION_KERNEL

See Also

MCdicom Structure
MCdicom Members


CONVOLUTION_KERNEL_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CONVOLUTION_KERNEL_GROUP Field
MCdicom Structure See Also Send Feedback
Convolution Kernel Group (0018,9316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CONVOLUTION_KERNEL_GROUP
Visual Basic
Public Const CONVOLUTION_KERNEL_GROUP As UInteger
Visual C++
public:
literal unsigned int CONVOLUTION_KERNEL_GROUP

See Also

MCdicom Structure
MCdicom Members


COORDINATE_START_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_START_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Coordinate Start Value RETIRED (5000,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_START_VALUE_RETIRED
Visual Basic
Public Const COORDINATE_START_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COORDINATE_START_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COORDINATE_STEP_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_STEP_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Coordinate Step Value RETIRED (5000,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_STEP_VALUE_RETIRED
Visual Basic
Public Const COORDINATE_STEP_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COORDINATE_STEP_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Coordinate System Axes Sequence (0014,2204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXES_SEQUENCE
Visual Basic
Public Const COORDINATE_SYSTEM_AXES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Code Sequence RETIRED (0040,08DA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Description (0014,2206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_DESCRIPTION
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_NUMBER Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Number (0014,220A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_NUMBER
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_NUMBER As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_NUMBER

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_TYPE Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Type (0014,220C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_TYPE
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_TYPE As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_TYPE

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_UNITS Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Units (0014,220E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_UNITS
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_UNITS As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_UNITS

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_AXIS_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_AXIS_VALUES Field
MCdicom Structure See Also Send Feedback
Coordinate System Axis Values (0014,2210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_AXIS_VALUES
Visual Basic
Public Const COORDINATE_SYSTEM_AXIS_VALUES As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_AXIS_VALUES

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_DATA_SET_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_DATA_SET_MAPPING Field
MCdicom Structure See Also Send Feedback
Coordinate System Data Set Mapping (0014,2208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_DATA_SET_MAPPING
Visual Basic
Public Const COORDINATE_SYSTEM_DATA_SET_MAPPING As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_DATA_SET_MAPPING

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_NUMBER_OF_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_NUMBER_OF_AXES Field
MCdicom Structure See Also Send Feedback
Coordinate System Number of Axes (0014,2202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_NUMBER_OF_AXES
Visual Basic
Public Const COORDINATE_SYSTEM_NUMBER_OF_AXES As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_NUMBER_OF_AXES

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX Field
MCdicom Structure See Also Send Feedback
Coordinate System Transform Rotation and Scale Matrix (0014,222A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX
Visual Basic
Public Const COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_TRANSFORM_ROTATION_AND_SCALE_MATRIX

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_TRANSFORM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_TRANSFORM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Coordinate System Transform Sequence (0014,2220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_TRANSFORM_SEQUENCE
Visual Basic
Public Const COORDINATE_SYSTEM_TRANSFORM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_TRANSFORM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX Field
MCdicom Structure See Also Send Feedback
Coordinate System Transform Translation Matrix (0014,222C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX
Visual Basic
Public Const COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX As UInteger
Visual C++
public:
literal unsigned int COORDINATE_SYSTEM_TRANSFORM_TRANSLATION_MATRIX

See Also

MCdicom Structure
MCdicom Members


COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Coordinates Set Geometric Type (Trial) RETIRED (0040,A290)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED
Visual Basic
Public Const COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int COORDINATES_SET_GEOMETRIC_TYPE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


COPIES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COPIES_RETIRED Field
MCdicom Structure See Also Send Feedback
Copies RETIRED (0000,5170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COPIES_RETIRED
Visual Basic
Public Const COPIES_RETIRED As UInteger
Visual C++
public:
literal unsigned int COPIES_RETIRED

See Also

MCdicom Structure
MCdicom Members


CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Cornea Measurement Method Code Sequence (0046,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE
Visual Basic
Public Const CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORNEA_MEASUREMENT_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORNEA_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEA_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Cornea Measurements Sequence (0046,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEA_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const CORNEA_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORNEA_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_AXIS Field
MCdicom Structure See Also Send Feedback
Corneal Axis (0046,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_AXIS
Visual Basic
Public Const CORNEAL_AXIS As UInteger
Visual C++
public:
literal unsigned int CORNEAL_AXIS

See Also

MCdicom Structure
MCdicom Members


CORNEAL_ECCENTRICITY_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_ECCENTRICITY_INDEX Field
MCdicom Structure See Also Send Feedback
Corneal Eccentricity Index (0046,0234)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_ECCENTRICITY_INDEX
Visual Basic
Public Const CORNEAL_ECCENTRICITY_INDEX As UInteger
Visual C++
public:
literal unsigned int CORNEAL_ECCENTRICITY_INDEX

See Also

MCdicom Structure
MCdicom Members


CORNEAL_I_S_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_I_S_VALUE Field
MCdicom Structure See Also Send Feedback
Corneal I-S Value (0046,0224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_I_S_VALUE
Visual Basic
Public Const CORNEAL_I_S_VALUE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_I_S_VALUE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_POINT_ESTIMATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_POINT_ESTIMATED Field
MCdicom Structure See Also Send Feedback
Corneal Point Estimated (0046,0248)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_POINT_ESTIMATED
Visual Basic
Public Const CORNEAL_POINT_ESTIMATED As UInteger
Visual C++
public:
literal unsigned int CORNEAL_POINT_ESTIMATED

See Also

MCdicom Structure
MCdicom Members


CORNEAL_POINT_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_POINT_LOCATION Field
MCdicom Structure See Also Send Feedback
Corneal Point Location (0046,0247)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_POINT_LOCATION
Visual Basic
Public Const CORNEAL_POINT_LOCATION As UInteger
Visual C++
public:
literal unsigned int CORNEAL_POINT_LOCATION

See Also

MCdicom Structure
MCdicom Members


CORNEAL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_POWER Field
MCdicom Structure See Also Send Feedback
Corneal Power (0046,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_POWER
Visual Basic
Public Const CORNEAL_POWER As UInteger
Visual C++
public:
literal unsigned int CORNEAL_POWER

See Also

MCdicom Structure
MCdicom Members


CORNEAL_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_SIZE Field
MCdicom Structure See Also Send Feedback
Corneal Size (0046,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_SIZE
Visual Basic
Public Const CORNEAL_SIZE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_SIZE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_SIZE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_SIZE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Corneal Size Sequence (0046,0047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_SIZE_SEQUENCE
Visual Basic
Public Const CORNEAL_SIZE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_SIZE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION Field
MCdicom Structure See Also Send Feedback
Corneal Topography Map Quality Evaluation (0046,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION
Visual Basic
Public Const CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION As UInteger
Visual C++
public:
literal unsigned int CORNEAL_TOPOGRAPHY_MAP_QUALITY_EVALUATION

See Also

MCdicom Structure
MCdicom Members


CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Corneal Topography Map Type Code Sequence (0046,0207)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_TOPOGRAPHY_MAP_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Corneal Topography Mapping Normals Sequence (0046,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE
Visual Basic
Public Const CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_TOPOGRAPHY_MAPPING_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_TOPOGRAPHY_SURFACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_TOPOGRAPHY_SURFACE Field
MCdicom Structure See Also Send Feedback
Corneal Topography Surface (0046,0201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_TOPOGRAPHY_SURFACE
Visual Basic
Public Const CORNEAL_TOPOGRAPHY_SURFACE As UInteger
Visual C++
public:
literal unsigned int CORNEAL_TOPOGRAPHY_SURFACE

See Also

MCdicom Structure
MCdicom Members


CORNEAL_VERTEX_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_VERTEX_LOCATION Field
MCdicom Structure See Also Send Feedback
Corneal Vertex Location (0046,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_VERTEX_LOCATION
Visual Basic
Public Const CORNEAL_VERTEX_LOCATION As UInteger
Visual C++
public:
literal unsigned int CORNEAL_VERTEX_LOCATION

See Also

MCdicom Structure
MCdicom Members


CORNEAL_WAVEFRONT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORNEAL_WAVEFRONT Field
MCdicom Structure See Also Send Feedback
Corneal Wavefront (0046,0253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORNEAL_WAVEFRONT
Visual Basic
Public Const CORNEAL_WAVEFRONT As UInteger
Visual C++
public:
literal unsigned int CORNEAL_WAVEFRONT

See Also

MCdicom Structure
MCdicom Members


CORRECTED_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_IMAGE Field
MCdicom Structure See Also Send Feedback
Corrected Image (0028,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_IMAGE
Visual Basic
Public Const CORRECTED_IMAGE As UInteger
Visual C++
public:
literal unsigned int CORRECTED_IMAGE

See Also

MCdicom Structure
MCdicom Members


CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL Field
MCdicom Structure See Also Send Feedback
Corrected Localized Deviation From Normal (0024,0079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL
Visual Basic
Public Const CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL As UInteger
Visual C++
public:
literal unsigned int CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL

See Also

MCdicom Structure
MCdicom Members


CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED Field
MCdicom Structure See Also Send Feedback
Corrected Localized Deviation From Normal Calculated (0024,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED
Visual Basic
Public Const CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED As UInteger
Visual C++
public:
literal unsigned int CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_CALCULATED

See Also

MCdicom Structure
MCdicom Members


CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY Field
MCdicom Structure See Also Send Feedback
Corrected Localized Deviation From Normal Probability (0024,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY
Visual Basic
Public Const CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED Field
MCdicom Structure See Also Send Feedback
Corrected Localized Deviation From Normal Probability Calculated (0024,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED
Visual Basic
Public Const CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED As UInteger
Visual C++
public:
literal unsigned int CORRECTED_LOCALIZED_DEVIATION_FROM_NORMAL_PROBABILITY_CALCULATED

See Also

MCdicom Structure
MCdicom Members


CORRECTED_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Corrected Parameter Sequence (3008,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_PARAMETER_SEQUENCE
Visual Basic
Public Const CORRECTED_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CORRECTED_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CORRECTED_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTED_VALUE Field
MCdicom Structure See Also Send Feedback
Alias for tag CORRECTION_VALUE (3008,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTED_VALUE
Visual Basic
Public Const CORRECTED_VALUE As UInteger
Visual C++
public:
literal unsigned int CORRECTED_VALUE

See Also

MCdicom Structure
MCdicom Members


CORRECTION_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CORRECTION_VALUE Field
MCdicom Structure See Also Send Feedback
Correction Value (3008,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CORRECTION_VALUE
Visual Basic
Public Const CORRECTION_VALUE As UInteger
Visual C++
public:
literal unsigned int CORRECTION_VALUE

See Also

MCdicom Structure
MCdicom Members


COUNT_LOSS_NORMALIZATION_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNT_LOSS_NORMALIZATION_CORRECTED Field
MCdicom Structure See Also Send Feedback
Count Loss Normalization Corrected (0018,9764)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNT_LOSS_NORMALIZATION_CORRECTED
Visual Basic
Public Const COUNT_LOSS_NORMALIZATION_CORRECTED As UInteger
Visual C++
public:
literal unsigned int COUNT_LOSS_NORMALIZATION_CORRECTED

See Also

MCdicom Structure
MCdicom Members


COUNT_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNT_RATE Field
MCdicom Structure See Also Send Feedback
Count Rate (0018,1243)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNT_RATE
Visual Basic
Public Const COUNT_RATE As UInteger
Visual C++
public:
literal unsigned int COUNT_RATE

See Also

MCdicom Structure
MCdicom Members


COUNTRY_OF_RESIDENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNTRY_OF_RESIDENCE Field
MCdicom Structure See Also Send Feedback
Country of Residence (0010,2150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNTRY_OF_RESIDENCE
Visual Basic
Public Const COUNTRY_OF_RESIDENCE As UInteger
Visual C++
public:
literal unsigned int COUNTRY_OF_RESIDENCE

See Also

MCdicom Structure
MCdicom Members


COUNTS_ACCUMULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNTS_ACCUMULATED Field
MCdicom Structure See Also Send Feedback
Counts Accumulated (0018,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNTS_ACCUMULATED
Visual Basic
Public Const COUNTS_ACCUMULATED As UInteger
Visual C++
public:
literal unsigned int COUNTS_ACCUMULATED

See Also

MCdicom Structure
MCdicom Members


COUNTS_INCLUDED_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNTS_INCLUDED_RETIRED Field
MCdicom Structure See Also Send Feedback
Counts Included RETIRED (0054,1400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNTS_INCLUDED_RETIRED
Visual Basic
Public Const COUNTS_INCLUDED_RETIRED As UInteger
Visual C++
public:
literal unsigned int COUNTS_INCLUDED_RETIRED

See Also

MCdicom Structure
MCdicom Members


COUNTS_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUNTS_SOURCE Field
MCdicom Structure See Also Send Feedback
Counts Source (0054,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUNTS_SOURCE
Visual Basic
Public Const COUNTS_SOURCE As UInteger
Visual C++
public:
literal unsigned int COUNTS_SOURCE

See Also

MCdicom Structure
MCdicom Members


COUPLING_MEDIUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUPLING_MEDIUM Field
MCdicom Structure See Also Send Feedback
Coupling Medium (0014,4056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUPLING_MEDIUM
Visual Basic
Public Const COUPLING_MEDIUM As UInteger
Visual C++
public:
literal unsigned int COUPLING_MEDIUM

See Also

MCdicom Structure
MCdicom Members


COUPLING_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUPLING_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Coupling Technique (0014,4054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUPLING_TECHNIQUE
Visual Basic
Public Const COUPLING_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int COUPLING_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


COUPLING_VELOCITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COUPLING_VELOCITY Field
MCdicom Structure See Also Send Feedback
Coupling Velocity (0014,4057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COUPLING_VELOCITY
Visual Basic
Public Const COUPLING_VELOCITY As UInteger
Visual C++
public:
literal unsigned int COUPLING_VELOCITY

See Also

MCdicom Structure
MCdicom Members


COVERAGE_OF_K_SPACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..COVERAGE_OF_K_SPACE Field
MCdicom Structure See Also Send Feedback
Coverage of k-Space (0018,9094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint COVERAGE_OF_K_SPACE
Visual Basic
Public Const COVERAGE_OF_K_SPACE As UInteger
Visual C++
public:
literal unsigned int COVERAGE_OF_K_SPACE

See Also

MCdicom Structure
MCdicom Members


CRANIAL_THERMAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CRANIAL_THERMAL_INDEX Field
MCdicom Structure See Also Send Feedback
Cranial Thermal Index (0018,5026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CRANIAL_THERMAL_INDEX
Visual Basic
Public Const CRANIAL_THERMAL_INDEX As UInteger
Visual C++
public:
literal unsigned int CRANIAL_THERMAL_INDEX

See Also

MCdicom Structure
MCdicom Members


CREATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CREATION_DATE Field
MCdicom Structure See Also Send Feedback
Creation Date (2100,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CREATION_DATE
Visual Basic
Public Const CREATION_DATE As UInteger
Visual C++
public:
literal unsigned int CREATION_DATE

See Also

MCdicom Structure
MCdicom Members


CREATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CREATION_TIME Field
MCdicom Structure See Also Send Feedback
Creation Time (2100,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CREATION_TIME
Visual Basic
Public Const CREATION_TIME As UInteger
Visual C++
public:
literal unsigned int CREATION_TIME

See Also

MCdicom Structure
MCdicom Members


CREATOR_VERSION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CREATOR_VERSION_UID Field
MCdicom Structure See Also Send Feedback
Creator-Version UID (0008,9123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CREATOR_VERSION_UID
Visual Basic
Public Const CREATOR_VERSION_UID As UInteger
Visual C++
public:
literal unsigned int CREATOR_VERSION_UID

See Also

MCdicom Structure
MCdicom Members


CROP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CROP Field
MCdicom Structure See Also Send Feedback
Crop (0070,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CROP
Visual Basic
Public Const CROP As UInteger
Visual C++
public:
literal unsigned int CROP

See Also

MCdicom Structure
MCdicom Members


CROPPING_SPECIFICATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CROPPING_SPECIFICATION_INDEX Field
MCdicom Structure See Also Send Feedback
Cropping Specification Index (0070,1205)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CROPPING_SPECIFICATION_INDEX
Visual Basic
Public Const CROPPING_SPECIFICATION_INDEX As UInteger
Visual C++
public:
literal unsigned int CROPPING_SPECIFICATION_INDEX

See Also

MCdicom Structure
MCdicom Members


CROPPING_SPECIFICATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CROPPING_SPECIFICATION_NUMBER Field
MCdicom Structure See Also Send Feedback
Cropping Specification Number (0070,1309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CROPPING_SPECIFICATION_NUMBER
Visual Basic
Public Const CROPPING_SPECIFICATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int CROPPING_SPECIFICATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


CSS_FONT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CSS_FONT_NAME Field
MCdicom Structure See Also Send Feedback
CSS Font Name (0070,0229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CSS_FONT_NAME
Visual Basic
Public Const CSS_FONT_NAME As UInteger
Visual C++
public:
literal unsigned int CSS_FONT_NAME

See Also

MCdicom Structure
MCdicom Members


CT_ACQUISITION_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_ACQUISITION_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Acquisition Details Sequence (0018,9304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_ACQUISITION_DETAILS_SEQUENCE
Visual Basic
Public Const CT_ACQUISITION_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_ACQUISITION_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_ACQUISITION_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_ACQUISITION_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Acquisition Type Sequence (0018,9301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_ACQUISITION_TYPE_SEQUENCE
Visual Basic
Public Const CT_ACQUISITION_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_ACQUISITION_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Additional X-Ray Source Sequence (0018,9360)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE
Visual Basic
Public Const CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_EXPOSURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_EXPOSURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Exposure Sequence (0018,9321)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_EXPOSURE_SEQUENCE
Visual Basic
Public Const CT_EXPOSURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_EXPOSURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Geometry Sequence (0018,9312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_GEOMETRY_SEQUENCE
Visual Basic
Public Const CT_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_IMAGE_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_IMAGE_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Image Frame Type Sequence (0018,9329)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_IMAGE_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const CT_IMAGE_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_IMAGE_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Imaging Acquisition Parameter Sequence (3002,0126)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE
Visual Basic
Public Const CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_IMAGING_ACQUISITION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag CT_ADDITIONAL_X_RAY_SOURCE_SEQUENCE (0018,9360)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE
Visual Basic
Public Const CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_MULTIPLE_X_RAY_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Position Sequence (0018,9326)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_POSITION_SEQUENCE
Visual Basic
Public Const CT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_RECONSTRUCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_RECONSTRUCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Reconstruction Sequence (0018,9314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_RECONSTRUCTION_SEQUENCE
Visual Basic
Public Const CT_RECONSTRUCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_RECONSTRUCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_TABLE_DYNAMICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_TABLE_DYNAMICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT Table Dynamics Sequence (0018,9308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_TABLE_DYNAMICS_SEQUENCE
Visual Basic
Public Const CT_TABLE_DYNAMICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_TABLE_DYNAMICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CT_X_RAY_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CT_X_RAY_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CT X-Ray Details Sequence (0018,9325)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CT_X_RAY_DETAILS_SEQUENCE
Visual Basic
Public Const CT_X_RAY_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CT_X_RAY_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CTDI_PHANTOM_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CTDI_PHANTOM_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
CTDI Phantom Type Code Sequence (0018,9346)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CTDI_PHANTOM_TYPE_CODE_SEQUENCE
Visual Basic
Public Const CTDI_PHANTOM_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CTDI_PHANTOM_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CTDIVOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CTDIVOL Field
MCdicom Structure See Also Send Feedback
CTDIvol (0018,9345)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CTDIVOL
Visual Basic
Public Const CTDIVOL As UInteger
Visual C++
public:
literal unsigned int CTDIVOL

See Also

MCdicom Structure
MCdicom Members


CTDIVOL_NOTIFICATION_TRIGGER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CTDIVOL_NOTIFICATION_TRIGGER Field
MCdicom Structure See Also Send Feedback
CTDIvol Notification Trigger (0018,9942)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CTDIVOL_NOTIFICATION_TRIGGER
Visual Basic
Public Const CTDIVOL_NOTIFICATION_TRIGGER As UInteger
Visual C++
public:
literal unsigned int CTDIVOL_NOTIFICATION_TRIGGER

See Also

MCdicom Structure
MCdicom Members


CUMULATIVE_DOSE_REFERENCE_COEFFICIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUMULATIVE_DOSE_REFERENCE_COEFFICIENT Field
MCdicom Structure See Also Send Feedback
Cumulative Dose Reference Coefficient (300A,010C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUMULATIVE_DOSE_REFERENCE_COEFFICIENT
Visual Basic
Public Const CUMULATIVE_DOSE_REFERENCE_COEFFICIENT As UInteger
Visual C++
public:
literal unsigned int CUMULATIVE_DOSE_REFERENCE_COEFFICIENT

See Also

MCdicom Structure
MCdicom Members


CUMULATIVE_DOSE_TO_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUMULATIVE_DOSE_TO_DOSE_REFERENCE Field
MCdicom Structure See Also Send Feedback
Cumulative Dose to Dose Reference (3008,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUMULATIVE_DOSE_TO_DOSE_REFERENCE
Visual Basic
Public Const CUMULATIVE_DOSE_TO_DOSE_REFERENCE As UInteger
Visual C++
public:
literal unsigned int CUMULATIVE_DOSE_TO_DOSE_REFERENCE

See Also

MCdicom Structure
MCdicom Members


CUMULATIVE_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUMULATIVE_METERSET Field
MCdicom Structure See Also Send Feedback
Cumulative Meterset (300A,063C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUMULATIVE_METERSET
Visual Basic
Public Const CUMULATIVE_METERSET As UInteger
Visual C++
public:
literal unsigned int CUMULATIVE_METERSET

See Also

MCdicom Structure
MCdicom Members


CUMULATIVE_METERSET_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUMULATIVE_METERSET_WEIGHT Field
MCdicom Structure See Also Send Feedback
Cumulative Meterset Weight (300A,0134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUMULATIVE_METERSET_WEIGHT
Visual Basic
Public Const CUMULATIVE_METERSET_WEIGHT As UInteger
Visual C++
public:
literal unsigned int CUMULATIVE_METERSET_WEIGHT

See Also

MCdicom Structure
MCdicom Members


CUMULATIVE_TIME_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUMULATIVE_TIME_WEIGHT Field
MCdicom Structure See Also Send Feedback
Cumulative Time Weight (300A,02D6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUMULATIVE_TIME_WEIGHT
Visual Basic
Public Const CUMULATIVE_TIME_WEIGHT As UInteger
Visual C++
public:
literal unsigned int CUMULATIVE_TIME_WEIGHT

See Also

MCdicom Structure
MCdicom Members


CURRENT_CONFIGURATION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_CONFIGURATION_ID Field
MCdicom Structure See Also Send Feedback
Current Configuration ID (0028,7002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_CONFIGURATION_ID
Visual Basic
Public Const CURRENT_CONFIGURATION_ID As UInteger
Visual C++
public:
literal unsigned int CURRENT_CONFIGURATION_ID

See Also

MCdicom Structure
MCdicom Members


CURRENT_FRACTION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_FRACTION_NUMBER Field
MCdicom Structure See Also Send Feedback
Current Fraction Number (3008,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_FRACTION_NUMBER
Visual Basic
Public Const CURRENT_FRACTION_NUMBER As UInteger
Visual C++
public:
literal unsigned int CURRENT_FRACTION_NUMBER

See Also

MCdicom Structure
MCdicom Members


CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Current Frame Functional Groups Sequence (0006,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE
Visual Basic
Public Const CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CURRENT_FRAME_FUNCTIONAL_GROUPS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CURRENT_OBSERVER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_OBSERVER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Current Observer (Trial) RETIRED (0040,A307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_OBSERVER_TRIAL_RETIRED
Visual Basic
Public Const CURRENT_OBSERVER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURRENT_OBSERVER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURRENT_PATIENT_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_PATIENT_LOCATION Field
MCdicom Structure See Also Send Feedback
Current Patient Location (0038,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_PATIENT_LOCATION
Visual Basic
Public Const CURRENT_PATIENT_LOCATION As UInteger
Visual C++
public:
literal unsigned int CURRENT_PATIENT_LOCATION

See Also

MCdicom Structure
MCdicom Members


CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Current Requested Procedure Evidence Sequence (0040,A375)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE
Visual Basic
Public Const CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CURRENT_TREATMENT_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURRENT_TREATMENT_STATUS Field
MCdicom Structure See Also Send Feedback
Current Treatment Status (3008,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURRENT_TREATMENT_STATUS
Visual Basic
Public Const CURRENT_TREATMENT_STATUS As UInteger
Visual C++
public:
literal unsigned int CURRENT_TREATMENT_STATUS

See Also

MCdicom Structure
MCdicom Members


CURVATURE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVATURE_TYPE Field
MCdicom Structure See Also Send Feedback
Curvature Type (0014,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVATURE_TYPE
Visual Basic
Public Const CURVATURE_TYPE As UInteger
Visual C++
public:
literal unsigned int CURVATURE_TYPE

See Also

MCdicom Structure
MCdicom Members


CURVE_ACTIVATION_LAYER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_ACTIVATION_LAYER_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Activation Layer RETIRED (5000,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_ACTIVATION_LAYER_RETIRED
Visual Basic
Public Const CURVE_ACTIVATION_LAYER_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_ACTIVATION_LAYER_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_DATA_DESCRIPTOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_DATA_DESCRIPTOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Data Descriptor RETIRED (5000,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_DATA_DESCRIPTOR_RETIRED
Visual Basic
Public Const CURVE_DATA_DESCRIPTOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_DATA_DESCRIPTOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_DATA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_DATA_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Data RETIRED (5000,3000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_DATA_RETIRED
Visual Basic
Public Const CURVE_DATA_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_DATA_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Date RETIRED (0008,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_DATE_RETIRED
Visual Basic
Public Const CURVE_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Description RETIRED (5000,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_DESCRIPTION_RETIRED
Visual Basic
Public Const CURVE_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_DIMENSIONS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_DIMENSIONS_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Dimensions RETIRED (5000,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_DIMENSIONS_RETIRED
Visual Basic
Public Const CURVE_DIMENSIONS_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_DIMENSIONS_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_LABEL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_LABEL_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Label RETIRED (5000,2500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_LABEL_RETIRED
Visual Basic
Public Const CURVE_LABEL_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_LABEL_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Number RETIRED (0020,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_NUMBER_RETIRED
Visual Basic
Public Const CURVE_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_RANGE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_RANGE_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Range RETIRED (5000,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_RANGE_RETIRED
Visual Basic
Public Const CURVE_RANGE_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_RANGE_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_REFERENCED_OVERLAY_GROUP_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_REFERENCED_OVERLAY_GROUP_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Referenced Overlay Group RETIRED (5000,2610)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_REFERENCED_OVERLAY_GROUP_RETIRED
Visual Basic
Public Const CURVE_REFERENCED_OVERLAY_GROUP_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_REFERENCED_OVERLAY_GROUP_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Referenced Overlay Sequence RETIRED (5000,2600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED
Visual Basic
Public Const CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_REFERENCED_OVERLAY_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


CURVE_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CURVE_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Curve Time RETIRED (0008,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CURVE_TIME_RETIRED
Visual Basic
Public Const CURVE_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int CURVE_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


CUSTODIAL_ORGANIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUSTODIAL_ORGANIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Custodial Organization Sequence (0040,A07C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUSTODIAL_ORGANIZATION_SEQUENCE
Visual Basic
Public Const CUSTODIAL_ORGANIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CUSTODIAL_ORGANIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


CUSTOM_RENDERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CUSTOM_RENDERED Field
MCdicom Structure See Also Send Feedback
Custom Rendered (0016,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CUSTOM_RENDERED
Visual Basic
Public Const CUSTOM_RENDERED As UInteger
Visual C++
public:
literal unsigned int CUSTOM_RENDERED

See Also

MCdicom Structure
MCdicom Members


CYLINDER_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CYLINDER_AXIS Field
MCdicom Structure See Also Send Feedback
Cylinder Axis (0022,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CYLINDER_AXIS
Visual Basic
Public Const CYLINDER_AXIS As UInteger
Visual C++
public:
literal unsigned int CYLINDER_AXIS

See Also

MCdicom Structure
MCdicom Members


CYLINDER_LENS_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CYLINDER_LENS_POWER Field
MCdicom Structure See Also Send Feedback
Cylinder Lens Power (0022,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CYLINDER_LENS_POWER
Visual Basic
Public Const CYLINDER_LENS_POWER As UInteger
Visual C++
public:
literal unsigned int CYLINDER_LENS_POWER

See Also

MCdicom Structure
MCdicom Members


CYLINDER_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CYLINDER_POWER Field
MCdicom Structure See Also Send Feedback
Cylinder Power (0046,0147)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CYLINDER_POWER
Visual Basic
Public Const CYLINDER_POWER As UInteger
Visual C++
public:
literal unsigned int CYLINDER_POWER

See Also

MCdicom Structure
MCdicom Members


CYLINDER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..CYLINDER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Cylinder Sequence (0046,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint CYLINDER_SEQUENCE
Visual Basic
Public Const CYLINDER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int CYLINDER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DAC_AMPLITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAC_AMPLITUDE Field
MCdicom Structure See Also Send Feedback
DAC Amplitude (0014,403C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAC_AMPLITUDE
Visual Basic
Public Const DAC_AMPLITUDE As UInteger
Visual C++
public:
literal unsigned int DAC_AMPLITUDE

See Also

MCdicom Structure
MCdicom Members


DAC_GAIN_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAC_GAIN_POINTS Field
MCdicom Structure See Also Send Feedback
DAC Gain Points (0014,4038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAC_GAIN_POINTS
Visual Basic
Public Const DAC_GAIN_POINTS As UInteger
Visual C++
public:
literal unsigned int DAC_GAIN_POINTS

See Also

MCdicom Structure
MCdicom Members


DAC_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAC_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DAC Sequence (0014,4035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAC_SEQUENCE
Visual Basic
Public Const DAC_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DAC_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DAC_TIME_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAC_TIME_POINTS Field
MCdicom Structure See Also Send Feedback
DAC Time Points (0014,403A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAC_TIME_POINTS
Visual Basic
Public Const DAC_TIME_POINTS As UInteger
Visual C++
public:
literal unsigned int DAC_TIME_POINTS

See Also

MCdicom Structure
MCdicom Members


DAC_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAC_TYPE Field
MCdicom Structure See Also Send Feedback
DAC Type (0014,4036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAC_TYPE
Visual Basic
Public Const DAC_TYPE As UInteger
Visual C++
public:
literal unsigned int DAC_TYPE

See Also

MCdicom Structure
MCdicom Members


DAMPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DAMPING Field
MCdicom Structure See Also Send Feedback
Damping (0014,4028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DAMPING
Visual Basic
Public Const DAMPING As UInteger
Visual C++
public:
literal unsigned int DAMPING

See Also

MCdicom Structure
MCdicom Members


DARK_CURRENT_COUNTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DARK_CURRENT_COUNTS Field
MCdicom Structure See Also Send Feedback
Dark Current Counts (0014,3050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DARK_CURRENT_COUNTS
Visual Basic
Public Const DARK_CURRENT_COUNTS As UInteger
Visual C++
public:
literal unsigned int DARK_CURRENT_COUNTS

See Also

MCdicom Structure
MCdicom Members


DARK_CURRENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DARK_CURRENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dark Current Sequence (0014,3040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DARK_CURRENT_SEQUENCE
Visual Basic
Public Const DARK_CURRENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DARK_CURRENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DATA_COLLECTION_CENTER_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_COLLECTION_CENTER_PATIENT Field
MCdicom Structure See Also Send Feedback
Data Collection Center (Patient) (0018,9313)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_COLLECTION_CENTER_PATIENT
Visual Basic
Public Const DATA_COLLECTION_CENTER_PATIENT As UInteger
Visual C++
public:
literal unsigned int DATA_COLLECTION_CENTER_PATIENT

See Also

MCdicom Structure
MCdicom Members


DATA_COLLECTION_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_COLLECTION_DIAMETER Field
MCdicom Structure See Also Send Feedback
Data Collection Diameter (0018,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_COLLECTION_DIAMETER
Visual Basic
Public Const DATA_COLLECTION_DIAMETER As UInteger
Visual C++
public:
literal unsigned int DATA_COLLECTION_DIAMETER

See Also

MCdicom Structure
MCdicom Members


DATA_ELEMENTS_SIGNED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_ELEMENTS_SIGNED Field
MCdicom Structure See Also Send Feedback
Data Elements Signed (0400,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_ELEMENTS_SIGNED
Visual Basic
Public Const DATA_ELEMENTS_SIGNED As UInteger
Visual C++
public:
literal unsigned int DATA_ELEMENTS_SIGNED

See Also

MCdicom Structure
MCdicom Members


DATA_FRAME_ASSIGNMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_FRAME_ASSIGNMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Data Frame Assignment Sequence (0028,1401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_FRAME_ASSIGNMENT_SEQUENCE
Visual Basic
Public Const DATA_FRAME_ASSIGNMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DATA_FRAME_ASSIGNMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DATA_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Data Information Sequence (0054,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_INFORMATION_SEQUENCE
Visual Basic
Public Const DATA_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DATA_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DATA_OBSERVATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_OBSERVATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Data Observation Sequence (0024,0325)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_OBSERVATION_SEQUENCE
Visual Basic
Public Const DATA_OBSERVATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DATA_OBSERVATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DATA_PATH_ASSIGNMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_PATH_ASSIGNMENT Field
MCdicom Structure See Also Send Feedback
Data Path Assignment (0028,1402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_PATH_ASSIGNMENT
Visual Basic
Public Const DATA_PATH_ASSIGNMENT As UInteger
Visual C++
public:
literal unsigned int DATA_PATH_ASSIGNMENT

See Also

MCdicom Structure
MCdicom Members


DATA_PATH_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_PATH_ID Field
MCdicom Structure See Also Send Feedback
Data Path ID (0028,140E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_PATH_ID
Visual Basic
Public Const DATA_PATH_ID As UInteger
Visual C++
public:
literal unsigned int DATA_PATH_ID

See Also

MCdicom Structure
MCdicom Members


DATA_POINT_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_POINT_COLUMNS Field
MCdicom Structure See Also Send Feedback
Data Point Columns (0028,9002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_POINT_COLUMNS
Visual Basic
Public Const DATA_POINT_COLUMNS As UInteger
Visual C++
public:
literal unsigned int DATA_POINT_COLUMNS

See Also

MCdicom Structure
MCdicom Members


DATA_POINT_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_POINT_ROWS Field
MCdicom Structure See Also Send Feedback
Data Point Rows (0028,9001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_POINT_ROWS
Visual Basic
Public Const DATA_POINT_ROWS As UInteger
Visual C++
public:
literal unsigned int DATA_POINT_ROWS

See Also

MCdicom Structure
MCdicom Members


DATA_REPRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_REPRESENTATION Field
MCdicom Structure See Also Send Feedback
Data Representation (0028,9108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_REPRESENTATION
Visual Basic
Public Const DATA_REPRESENTATION As UInteger
Visual C++
public:
literal unsigned int DATA_REPRESENTATION

See Also

MCdicom Structure
MCdicom Members


DATA_SET_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Data Set Description (0024,0309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_DESCRIPTION
Visual Basic
Public Const DATA_SET_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DATA_SET_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DATA_SET_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_NAME Field
MCdicom Structure See Also Send Feedback
Data Set Name (0024,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_NAME
Visual Basic
Public Const DATA_SET_NAME As UInteger
Visual C++
public:
literal unsigned int DATA_SET_NAME

See Also

MCdicom Structure
MCdicom Members


DATA_SET_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_SOURCE Field
MCdicom Structure See Also Send Feedback
Data Set Source (0024,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_SOURCE
Visual Basic
Public Const DATA_SET_SOURCE As UInteger
Visual C++
public:
literal unsigned int DATA_SET_SOURCE

See Also

MCdicom Structure
MCdicom Members


DATA_SET_SUBTYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_SUBTYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Data Set Subtype RETIRED (0008,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_SUBTYPE_RETIRED
Visual Basic
Public Const DATA_SET_SUBTYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DATA_SET_SUBTYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


DATA_SET_TRAILING_PADDING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_TRAILING_PADDING Field
MCdicom Structure See Also Send Feedback
Data Set Trailing Padding (FFFC,FFFC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_TRAILING_PADDING
Visual Basic
Public Const DATA_SET_TRAILING_PADDING As UInteger
Visual C++
public:
literal unsigned int DATA_SET_TRAILING_PADDING

See Also

MCdicom Structure
MCdicom Members


DATA_SET_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_TYPE Field
MCdicom Structure See Also Send Feedback
Alias for tag COMMAND_DATA_SET_TYPE (0000,0800)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_TYPE
Visual Basic
Public Const DATA_SET_TYPE As UInteger
Visual C++
public:
literal unsigned int DATA_SET_TYPE

See Also

MCdicom Structure
MCdicom Members


DATA_SET_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Data Set Type RETIRED (0008,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_TYPE_RETIRED
Visual Basic
Public Const DATA_SET_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DATA_SET_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


DATA_SET_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_SET_VERSION Field
MCdicom Structure See Also Send Feedback
Data Set Version (0024,0307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_SET_VERSION
Visual Basic
Public Const DATA_SET_VERSION As UInteger
Visual C++
public:
literal unsigned int DATA_SET_VERSION

See Also

MCdicom Structure
MCdicom Members


DATA_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_TYPE Field
MCdicom Structure See Also Send Feedback
Data Type (0018,9808)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_TYPE
Visual Basic
Public Const DATA_TYPE As UInteger
Visual C++
public:
literal unsigned int DATA_TYPE

See Also

MCdicom Structure
MCdicom Members


DATA_VALUE_REPRESENTATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATA_VALUE_REPRESENTATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Data Value Representation RETIRED (5000,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATA_VALUE_REPRESENTATION_RETIRED
Visual Basic
Public Const DATA_VALUE_REPRESENTATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int DATA_VALUE_REPRESENTATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE Field
MCdicom Structure See Also Send Feedback
Date (0040,A121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE
Visual Basic
Public Const DATE As UInteger
Visual C++
public:
literal unsigned int DATE

See Also

MCdicom Structure
MCdicom Members


DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Date of Document or Verbal Transaction (Trial) RETIRED (0040,A110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED
Visual Basic
Public Const DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DATE_OF_DOCUMENT_OR_VERBAL_TRANSACTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DATE_OF_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Date of Gain Calibration (0014,3076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_GAIN_CALIBRATION
Visual Basic
Public Const DATE_OF_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int DATE_OF_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


DATE_OF_INSTALLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_INSTALLATION Field
MCdicom Structure See Also Send Feedback
Date of Installation (0018,1205)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_INSTALLATION
Visual Basic
Public Const DATE_OF_INSTALLATION As UInteger
Visual C++
public:
literal unsigned int DATE_OF_INSTALLATION

See Also

MCdicom Structure
MCdicom Members


DATE_OF_LAST_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_LAST_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Date of Last Calibration (0018,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_LAST_CALIBRATION
Visual Basic
Public Const DATE_OF_LAST_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int DATE_OF_LAST_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


DATE_OF_LAST_DETECTOR_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_LAST_DETECTOR_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Date of Last Detector Calibration (0018,700C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_LAST_DETECTOR_CALIBRATION
Visual Basic
Public Const DATE_OF_LAST_DETECTOR_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int DATE_OF_LAST_DETECTOR_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


DATE_OF_MANUFACTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_MANUFACTURE Field
MCdicom Structure See Also Send Feedback
Date of Manufacture (0018,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_MANUFACTURE
Visual Basic
Public Const DATE_OF_MANUFACTURE As UInteger
Visual C++
public:
literal unsigned int DATE_OF_MANUFACTURE

See Also

MCdicom Structure
MCdicom Members


DATE_OF_SECONDARY_CAPTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATE_OF_SECONDARY_CAPTURE Field
MCdicom Structure See Also Send Feedback
Date of Secondary Capture (0018,1012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATE_OF_SECONDARY_CAPTURE
Visual Basic
Public Const DATE_OF_SECONDARY_CAPTURE As UInteger
Visual C++
public:
literal unsigned int DATE_OF_SECONDARY_CAPTURE

See Also

MCdicom Structure
MCdicom Members


DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATETIME Field
MCdicom Structure See Also Send Feedback
DateTime (0040,A120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATETIME
Visual Basic
Public Const DATETIME As UInteger
Visual C++
public:
literal unsigned int DATETIME

See Also

MCdicom Structure
MCdicom Members


DATETIME_OF_LAST_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DATETIME_OF_LAST_CALIBRATION Field
MCdicom Structure See Also Send Feedback
DateTime of Last Calibration (0018,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DATETIME_OF_LAST_CALIBRATION
Visual Basic
Public Const DATETIME_OF_LAST_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int DATETIME_OF_LAST_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


DB_DT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DB_DT Field
MCdicom Structure See Also Send Feedback
dB/dt (0018,1318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DB_DT
Visual Basic
Public Const DB_DT As UInteger
Visual C++
public:
literal unsigned int DB_DT

See Also

MCdicom Structure
MCdicom Members


DDL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DDL_VALUE Field
MCdicom Structure See Also Send Feedback
DDL Value (0028,7017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DDL_VALUE
Visual Basic
Public Const DDL_VALUE As UInteger
Visual C++
public:
literal unsigned int DDL_VALUE

See Also

MCdicom Structure
MCdicom Members


DE_COUPLED_NUCLEUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_COUPLED_NUCLEUS Field
MCdicom Structure See Also Send Feedback
De-coupled Nucleus (0018,9060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_COUPLED_NUCLEUS
Visual Basic
Public Const DE_COUPLED_NUCLEUS As UInteger
Visual C++
public:
literal unsigned int DE_COUPLED_NUCLEUS

See Also

MCdicom Structure
MCdicom Members


DE_COUPLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_COUPLING Field
MCdicom Structure See Also Send Feedback
De-coupling (0018,9059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_COUPLING
Visual Basic
Public Const DE_COUPLING As UInteger
Visual C++
public:
literal unsigned int DE_COUPLING

See Also

MCdicom Structure
MCdicom Members


DE_COUPLING_CHEMICAL_SHIFT_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_COUPLING_CHEMICAL_SHIFT_REFERENCE Field
MCdicom Structure See Also Send Feedback
De-coupling Chemical Shift Reference (0018,9063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_COUPLING_CHEMICAL_SHIFT_REFERENCE
Visual Basic
Public Const DE_COUPLING_CHEMICAL_SHIFT_REFERENCE As UInteger
Visual C++
public:
literal unsigned int DE_COUPLING_CHEMICAL_SHIFT_REFERENCE

See Also

MCdicom Structure
MCdicom Members


DE_COUPLING_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_COUPLING_FREQUENCY Field
MCdicom Structure See Also Send Feedback
De-coupling Frequency (0018,9061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_COUPLING_FREQUENCY
Visual Basic
Public Const DE_COUPLING_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int DE_COUPLING_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


DE_COUPLING_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_COUPLING_METHOD Field
MCdicom Structure See Also Send Feedback
De-coupling Method (0018,9062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_COUPLING_METHOD
Visual Basic
Public Const DE_COUPLING_METHOD As UInteger
Visual C++
public:
literal unsigned int DE_COUPLING_METHOD

See Also

MCdicom Structure
MCdicom Members


DE_IDENTIFICATION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_IDENTIFICATION_METHOD Field
MCdicom Structure See Also Send Feedback
De-identification Method (0012,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_IDENTIFICATION_METHOD
Visual Basic
Public Const DE_IDENTIFICATION_METHOD As UInteger
Visual C++
public:
literal unsigned int DE_IDENTIFICATION_METHOD

See Also

MCdicom Structure
MCdicom Members


DE_IDENTIFICATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DE_IDENTIFICATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
De-identification Method Code Sequence (0012,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DE_IDENTIFICATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const DE_IDENTIFICATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DE_IDENTIFICATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEAD_TIME_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEAD_TIME_CORRECTED Field
MCdicom Structure See Also Send Feedback
Dead Time Corrected (0018,9761)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEAD_TIME_CORRECTED
Visual Basic
Public Const DEAD_TIME_CORRECTED As UInteger
Visual C++
public:
literal unsigned int DEAD_TIME_CORRECTED

See Also

MCdicom Structure
MCdicom Members


DEAD_TIME_CORRECTION_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEAD_TIME_CORRECTION_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Dead Time Correction Flag RETIRED (0054,1401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEAD_TIME_CORRECTION_FLAG_RETIRED
Visual Basic
Public Const DEAD_TIME_CORRECTION_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int DEAD_TIME_CORRECTION_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


DEAD_TIME_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEAD_TIME_FACTOR Field
MCdicom Structure See Also Send Feedback
Dead Time Factor (0054,1324)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEAD_TIME_FACTOR
Visual Basic
Public Const DEAD_TIME_FACTOR As UInteger
Visual C++
public:
literal unsigned int DEAD_TIME_FACTOR

See Also

MCdicom Structure
MCdicom Members


DECAY_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECAY_CORRECTED Field
MCdicom Structure See Also Send Feedback
Decay Corrected (0018,9758)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECAY_CORRECTED
Visual Basic
Public Const DECAY_CORRECTED As UInteger
Visual C++
public:
literal unsigned int DECAY_CORRECTED

See Also

MCdicom Structure
MCdicom Members


DECAY_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECAY_CORRECTION Field
MCdicom Structure See Also Send Feedback
Decay Correction (0054,1102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECAY_CORRECTION
Visual Basic
Public Const DECAY_CORRECTION As UInteger
Visual C++
public:
literal unsigned int DECAY_CORRECTION

See Also

MCdicom Structure
MCdicom Members


DECAY_CORRECTION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECAY_CORRECTION_DATETIME Field
MCdicom Structure See Also Send Feedback
Decay Correction DateTime (0018,9701)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECAY_CORRECTION_DATETIME
Visual Basic
Public Const DECAY_CORRECTION_DATETIME As UInteger
Visual C++
public:
literal unsigned int DECAY_CORRECTION_DATETIME

See Also

MCdicom Structure
MCdicom Members


DECAY_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECAY_FACTOR Field
MCdicom Structure See Also Send Feedback
Decay Factor (0054,1321)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECAY_FACTOR
Visual Basic
Public Const DECAY_FACTOR As UInteger
Visual C++
public:
literal unsigned int DECAY_FACTOR

See Also

MCdicom Structure
MCdicom Members


DECIMAL_POTENTIAL_VISUAL_ACUITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECIMAL_POTENTIAL_VISUAL_ACUITY Field
MCdicom Structure See Also Send Feedback
Decimal Potential Visual Acuity (0046,0238)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECIMAL_POTENTIAL_VISUAL_ACUITY
Visual Basic
Public Const DECIMAL_POTENTIAL_VISUAL_ACUITY As UInteger
Visual C++
public:
literal unsigned int DECIMAL_POTENTIAL_VISUAL_ACUITY

See Also

MCdicom Structure
MCdicom Members


DECIMAL_VISUAL_ACUITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECIMAL_VISUAL_ACUITY Field
MCdicom Structure See Also Send Feedback
Decimal Visual Acuity (0046,0137)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECIMAL_VISUAL_ACUITY
Visual Basic
Public Const DECIMAL_VISUAL_ACUITY As UInteger
Visual C++
public:
literal unsigned int DECIMAL_VISUAL_ACUITY

See Also

MCdicom Structure
MCdicom Members


DECIMATE_CROP_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECIMATE_CROP_RESULT Field
MCdicom Structure See Also Send Feedback
Decimate/Crop Result (2020,00A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECIMATE_CROP_RESULT
Visual Basic
Public Const DECIMATE_CROP_RESULT As UInteger
Visual C++
public:
literal unsigned int DECIMATE_CROP_RESULT

See Also

MCdicom Structure
MCdicom Members


DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Decomposition Algorithm Identification Sequence (0018,9380)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DECOMPOSITION_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DECOMPOSITION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECOMPOSITION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Decomposition Description (0018,937F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECOMPOSITION_DESCRIPTION
Visual Basic
Public Const DECOMPOSITION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DECOMPOSITION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DECOMPOSITION_MATERIAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECOMPOSITION_MATERIAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Decomposition Material Sequence (0018,9381)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECOMPOSITION_MATERIAL_SEQUENCE
Visual Basic
Public Const DECOMPOSITION_MATERIAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DECOMPOSITION_MATERIAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DECOMPOSITION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DECOMPOSITION_METHOD Field
MCdicom Structure See Also Send Feedback
Decomposition Method (0018,937E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DECOMPOSITION_METHOD
Visual Basic
Public Const DECOMPOSITION_METHOD As UInteger
Visual C++
public:
literal unsigned int DECOMPOSITION_METHOD

See Also

MCdicom Structure
MCdicom Members


DEFAULT_MAGNIFICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFAULT_MAGNIFICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Default Magnification Type (2010,00A6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFAULT_MAGNIFICATION_TYPE
Visual Basic
Public Const DEFAULT_MAGNIFICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int DEFAULT_MAGNIFICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


DEFAULT_PRINTER_RESOLUTION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFAULT_PRINTER_RESOLUTION_ID Field
MCdicom Structure See Also Send Feedback
Default Printer Resolution ID (2010,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFAULT_PRINTER_RESOLUTION_ID
Visual Basic
Public Const DEFAULT_PRINTER_RESOLUTION_ID As UInteger
Visual C++
public:
literal unsigned int DEFAULT_PRINTER_RESOLUTION_ID

See Also

MCdicom Structure
MCdicom Members


DEFAULT_SMOOTHING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFAULT_SMOOTHING_TYPE Field
MCdicom Structure See Also Send Feedback
Default Smoothing Type (2010,00A8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFAULT_SMOOTHING_TYPE
Visual Basic
Public Const DEFAULT_SMOOTHING_TYPE As UInteger
Visual C++
public:
literal unsigned int DEFAULT_SMOOTHING_TYPE

See Also

MCdicom Structure
MCdicom Members


DEFINITION_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFINITION_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Definition Source Sequence (0008,1156)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFINITION_SOURCE_SEQUENCE
Visual Basic
Public Const DEFINITION_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEFINITION_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEFORMABLE_REGISTRATION_GRID_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFORMABLE_REGISTRATION_GRID_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Deformable Registration Grid Sequence (0064,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFORMABLE_REGISTRATION_GRID_SEQUENCE
Visual Basic
Public Const DEFORMABLE_REGISTRATION_GRID_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEFORMABLE_REGISTRATION_GRID_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEFORMABLE_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEFORMABLE_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Deformable Registration Sequence (0064,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEFORMABLE_REGISTRATION_SEQUENCE
Visual Basic
Public Const DEFORMABLE_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEFORMABLE_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEGREE_OF_DILATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEGREE_OF_DILATION Field
MCdicom Structure See Also Send Feedback
Degree of Dilation (0022,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEGREE_OF_DILATION
Visual Basic
Public Const DEGREE_OF_DILATION As UInteger
Visual C++
public:
literal unsigned int DEGREE_OF_DILATION

See Also

MCdicom Structure
MCdicom Members


DEGREE_OF_FREEDOM_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEGREE_OF_FREEDOM_ID Field
MCdicom Structure See Also Send Feedback
Degree of Freedom ID (0068,6410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEGREE_OF_FREEDOM_ID
Visual Basic
Public Const DEGREE_OF_FREEDOM_ID As UInteger
Visual C++
public:
literal unsigned int DEGREE_OF_FREEDOM_ID

See Also

MCdicom Structure
MCdicom Members


DEGREE_OF_FREEDOM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEGREE_OF_FREEDOM_TYPE Field
MCdicom Structure See Also Send Feedback
Degree of Freedom Type (0068,6420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEGREE_OF_FREEDOM_TYPE
Visual Basic
Public Const DEGREE_OF_FREEDOM_TYPE As UInteger
Visual C++
public:
literal unsigned int DEGREE_OF_FREEDOM_TYPE

See Also

MCdicom Structure
MCdicom Members


DEIDENTIFICATION_ACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEIDENTIFICATION_ACTION Field
MCdicom Structure See Also Send Feedback
Deidentification Action (0008,0307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEIDENTIFICATION_ACTION
Visual Basic
Public Const DEIDENTIFICATION_ACTION As UInteger
Visual C++
public:
literal unsigned int DEIDENTIFICATION_ACTION

See Also

MCdicom Structure
MCdicom Members


DEIDENTIFICATION_ACTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEIDENTIFICATION_ACTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Deidentification Action Sequence (0008,0305)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEIDENTIFICATION_ACTION_SEQUENCE
Visual Basic
Public Const DEIDENTIFICATION_ACTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEIDENTIFICATION_ACTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DELAY_LAW_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELAY_LAW_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Delay Law Identifier (0014,405C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELAY_LAW_IDENTIFIER
Visual Basic
Public Const DELAY_LAW_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int DELAY_LAW_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


DELETION_LOCK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELETION_LOCK Field
MCdicom Structure See Also Send Feedback
Deletion Lock (0074,1230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELETION_LOCK
Visual Basic
Public Const DELETION_LOCK As UInteger
Visual C++
public:
literal unsigned int DELETION_LOCK

See Also

MCdicom Structure
MCdicom Members


DELINEATED_RADIATION_FIELD_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELINEATED_RADIATION_FIELD_SIZE Field
MCdicom Structure See Also Send Feedback
Delineated Radiation Field Size (300C,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELINEATED_RADIATION_FIELD_SIZE
Visual Basic
Public Const DELINEATED_RADIATION_FIELD_SIZE As UInteger
Visual C++
public:
literal unsigned int DELINEATED_RADIATION_FIELD_SIZE

See Also

MCdicom Structure
MCdicom Members


DELIVERED_CHANNEL_TOTAL_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_CHANNEL_TOTAL_TIME Field
MCdicom Structure See Also Send Feedback
Delivered Channel Total Time (3008,0134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_CHANNEL_TOTAL_TIME
Visual Basic
Public Const DELIVERED_CHANNEL_TOTAL_TIME As UInteger
Visual C++
public:
literal unsigned int DELIVERED_CHANNEL_TOTAL_TIME

See Also

MCdicom Structure
MCdicom Members


DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Delivered Depth Dose Parameters Sequence (300A,0506)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE
Visual Basic
Public Const DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DELIVERED_DEPTH_DOSE_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DELIVERED_DISTAL_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_DISTAL_DEPTH Field
MCdicom Structure See Also Send Feedback
Delivered Distal Depth (300A,0508)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_DISTAL_DEPTH
Visual Basic
Public Const DELIVERED_DISTAL_DEPTH As UInteger
Visual C++
public:
literal unsigned int DELIVERED_DISTAL_DEPTH

See Also

MCdicom Structure
MCdicom Members


DELIVERED_DISTAL_DEPTH_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_DISTAL_DEPTH_FRACTION Field
MCdicom Structure See Also Send Feedback
Delivered Distal Depth Fraction (300A,0507)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_DISTAL_DEPTH_FRACTION
Visual Basic
Public Const DELIVERED_DISTAL_DEPTH_FRACTION As UInteger
Visual C++
public:
literal unsigned int DELIVERED_DISTAL_DEPTH_FRACTION

See Also

MCdicom Structure
MCdicom Members


DELIVERED_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_METERSET Field
MCdicom Structure See Also Send Feedback
Delivered Meterset (3008,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_METERSET
Visual Basic
Public Const DELIVERED_METERSET As UInteger
Visual C++
public:
literal unsigned int DELIVERED_METERSET

See Also

MCdicom Structure
MCdicom Members


DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS Field
MCdicom Structure See Also Send Feedback
Delivered Nominal Range Modulated Region Depths (300A,0510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS
Visual Basic
Public Const DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS As UInteger
Visual C++
public:
literal unsigned int DELIVERED_NOMINAL_RANGE_MODULATED_REGION_DEPTHS

See Also

MCdicom Structure
MCdicom Members


DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Delivered Nominal Range Modulation Fractions (300A,0509)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS
Visual Basic
Public Const DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int DELIVERED_NOMINAL_RANGE_MODULATION_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


DELIVERED_NUMBER_OF_PULSES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_NUMBER_OF_PULSES Field
MCdicom Structure See Also Send Feedback
Delivered Number of Pulses (3008,0138)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_NUMBER_OF_PULSES
Visual Basic
Public Const DELIVERED_NUMBER_OF_PULSES As UInteger
Visual C++
public:
literal unsigned int DELIVERED_NUMBER_OF_PULSES

See Also

MCdicom Structure
MCdicom Members


DELIVERED_PRIMARY_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_PRIMARY_METERSET Field
MCdicom Structure See Also Send Feedback
Delivered Primary Meterset (3008,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_PRIMARY_METERSET
Visual Basic
Public Const DELIVERED_PRIMARY_METERSET As UInteger
Visual C++
public:
literal unsigned int DELIVERED_PRIMARY_METERSET

See Also

MCdicom Structure
MCdicom Members


DELIVERED_PULSE_REPETITION_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_PULSE_REPETITION_INTERVAL Field
MCdicom Structure See Also Send Feedback
Delivered Pulse Repetition Interval (3008,013C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_PULSE_REPETITION_INTERVAL
Visual Basic
Public Const DELIVERED_PULSE_REPETITION_INTERVAL As UInteger
Visual C++
public:
literal unsigned int DELIVERED_PULSE_REPETITION_INTERVAL

See Also

MCdicom Structure
MCdicom Members


DELIVERED_REFERENCE_DOSE_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_REFERENCE_DOSE_DEFINITION Field
MCdicom Structure See Also Send Feedback
Delivered Reference Dose Definition (300A,0511)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_REFERENCE_DOSE_DEFINITION
Visual Basic
Public Const DELIVERED_REFERENCE_DOSE_DEFINITION As UInteger
Visual C++
public:
literal unsigned int DELIVERED_REFERENCE_DOSE_DEFINITION

See Also

MCdicom Structure
MCdicom Members


DELIVERED_SECONDARY_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_SECONDARY_METERSET Field
MCdicom Structure See Also Send Feedback
Delivered Secondary Meterset (3008,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_SECONDARY_METERSET
Visual Basic
Public Const DELIVERED_SECONDARY_METERSET As UInteger
Visual C++
public:
literal unsigned int DELIVERED_SECONDARY_METERSET

See Also

MCdicom Structure
MCdicom Members


DELIVERED_TREATMENT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERED_TREATMENT_TIME Field
MCdicom Structure See Also Send Feedback
Delivered Treatment Time (3008,003B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERED_TREATMENT_TIME
Visual Basic
Public Const DELIVERED_TREATMENT_TIME As UInteger
Visual C++
public:
literal unsigned int DELIVERED_TREATMENT_TIME

See Also

MCdicom Structure
MCdicom Members


DELIVERY_MAXIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_MAXIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
Delivery Maximum Dose (300A,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_MAXIMUM_DOSE
Visual Basic
Public Const DELIVERY_MAXIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_MAXIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


DELIVERY_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_RATE Field
MCdicom Structure See Also Send Feedback
Delivery Rate (300A,063D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_RATE
Visual Basic
Public Const DELIVERY_RATE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_RATE

See Also

MCdicom Structure
MCdicom Members


DELIVERY_RATE_UNIT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_RATE_UNIT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Delivery Rate Unit Sequence (300A,063E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_RATE_UNIT_SEQUENCE
Visual Basic
Public Const DELIVERY_RATE_UNIT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_RATE_UNIT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Delivery Time Structure Code Sequence (3010,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE
Visual Basic
Public Const DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_TIME_STRUCTURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DELIVERY_VERIFICATION_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_VERIFICATION_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Delivery Verification Image Sequence (0074,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_VERIFICATION_IMAGE_SEQUENCE
Visual Basic
Public Const DELIVERY_VERIFICATION_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_VERIFICATION_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DELIVERY_WARNING_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DELIVERY_WARNING_DOSE Field
MCdicom Structure See Also Send Feedback
Delivery Warning Dose (300A,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DELIVERY_WARNING_DOSE
Visual Basic
Public Const DELIVERY_WARNING_DOSE As UInteger
Visual C++
public:
literal unsigned int DELIVERY_WARNING_DOSE

See Also

MCdicom Structure
MCdicom Members


DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DENSITY Field
MCdicom Structure See Also Send Feedback
Density (4010,1018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DENSITY
Visual Basic
Public Const DENSITY As UInteger
Visual C++
public:
literal unsigned int DENSITY

See Also

MCdicom Structure
MCdicom Members


DEPTH_DOSE_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTH_DOSE_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Depth Dose Parameters Sequence (300A,0505)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTH_DOSE_PARAMETERS_SEQUENCE
Visual Basic
Public Const DEPTH_DOSE_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEPTH_DOSE_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEPTH_OF_SCAN_FIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTH_OF_SCAN_FIELD Field
MCdicom Structure See Also Send Feedback
Depth of Scan Field (0018,5050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTH_OF_SCAN_FIELD
Visual Basic
Public Const DEPTH_OF_SCAN_FIELD As UInteger
Visual C++
public:
literal unsigned int DEPTH_OF_SCAN_FIELD

See Also

MCdicom Structure
MCdicom Members


DEPTH_OF_TRANSVERSE_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTH_OF_TRANSVERSE_IMAGE Field
MCdicom Structure See Also Send Feedback
Depth of Transverse Image (0022,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTH_OF_TRANSVERSE_IMAGE
Visual Basic
Public Const DEPTH_OF_TRANSVERSE_IMAGE As UInteger
Visual C++
public:
literal unsigned int DEPTH_OF_TRANSVERSE_IMAGE

See Also

MCdicom Structure
MCdicom Members


DEPTH_SPATIAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTH_SPATIAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Depth Spatial Resolution (0022,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTH_SPATIAL_RESOLUTION
Visual Basic
Public Const DEPTH_SPATIAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int DEPTH_SPATIAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


DEPTH_VALUE_AVERAGING_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTH_VALUE_AVERAGING_FLAG Field
MCdicom Structure See Also Send Feedback
Depth Value Averaging Flag (300A,0093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTH_VALUE_AVERAGING_FLAG
Visual Basic
Public Const DEPTH_VALUE_AVERAGING_FLAG As UInteger
Visual C++
public:
literal unsigned int DEPTH_VALUE_AVERAGING_FLAG

See Also

MCdicom Structure
MCdicom Members


DEPTHS_OF_FOCUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEPTHS_OF_FOCUS Field
MCdicom Structure See Also Send Feedback
Depth(s) of Focus (0018,9801)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEPTHS_OF_FOCUS
Visual Basic
Public Const DEPTHS_OF_FOCUS As UInteger
Visual C++
public:
literal unsigned int DEPTHS_OF_FOCUS

See Also

MCdicom Structure
MCdicom Members


DERIVATION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Algorithm Sequence (0022,1612)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_ALGORITHM_SEQUENCE
Visual Basic
Public Const DERIVATION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DERIVATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Code Sequence (0008,9215)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_CODE_SEQUENCE
Visual Basic
Public Const DERIVATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Conceptual Volume Sequence (3010,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE
Visual Basic
Public Const DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_CONCEPTUAL_VOLUME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DERIVATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Derivation Description (0008,2111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_DESCRIPTION
Visual Basic
Public Const DERIVATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DERIVATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DERIVATION_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Image Sequence (0008,9124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_IMAGE_SEQUENCE
Visual Basic
Public Const DERIVATION_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Implant Assembly Template Sequence (0076,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE
Visual Basic
Public Const DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DERIVATION_IMPLANT_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DERIVATION_IMPLANT_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Derivation Implant Template Sequence (0068,6224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DERIVATION_IMPLANT_TEMPLATE_SEQUENCE
Visual Basic
Public Const DERIVATION_IMPLANT_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DERIVATION_IMPLANT_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DESTINATION_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DESTINATION_AE Field
MCdicom Structure See Also Send Feedback
Destination AE (2100,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DESTINATION_AE
Visual Basic
Public Const DESTINATION_AE As UInteger
Visual C++
public:
literal unsigned int DESTINATION_AE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE Field
MCdicom Structure See Also Send Feedback
Detector Activation Offset From Exposure (0018,7016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE
Visual Basic
Public Const DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVATION_OFFSET_FROM_EXPOSURE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_AREA_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_AREA_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Detector Active Area Orientation (0018,9558)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_AREA_ORIENTATION
Visual Basic
Public Const DETECTOR_ACTIVE_AREA_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_AREA_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_AREA_TLHC_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_AREA_TLHC_POSITION Field
MCdicom Structure See Also Send Feedback
Detector Active Area TLHC Position (0018,9557)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_AREA_TLHC_POSITION
Visual Basic
Public Const DETECTOR_ACTIVE_AREA_TLHC_POSITION As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_AREA_TLHC_POSITION

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_DIMENSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_DIMENSIONS Field
MCdicom Structure See Also Send Feedback
Detector Active Dimension(s) (0018,7026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_DIMENSIONS
Visual Basic
Public Const DETECTOR_ACTIVE_DIMENSIONS As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_DIMENSIONS

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_ORIGIN Field
MCdicom Structure See Also Send Feedback
Detector Active Origin (0018,7028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_ORIGIN
Visual Basic
Public Const DETECTOR_ACTIVE_ORIGIN As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_ORIGIN

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_SHAPE Field
MCdicom Structure See Also Send Feedback
Detector Active Shape (0018,7024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_SHAPE
Visual Basic
Public Const DETECTOR_ACTIVE_SHAPE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_SHAPE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ACTIVE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ACTIVE_TIME Field
MCdicom Structure See Also Send Feedback
Detector Active Time (0018,7014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ACTIVE_TIME
Visual Basic
Public Const DETECTOR_ACTIVE_TIME As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ACTIVE_TIME

See Also

MCdicom Structure
MCdicom Members


DETECTOR_BINNING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_BINNING Field
MCdicom Structure See Also Send Feedback
Detector Binning (0018,701A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_BINNING
Visual Basic
Public Const DETECTOR_BINNING As UInteger
Visual C++
public:
literal unsigned int DETECTOR_BINNING

See Also

MCdicom Structure
MCdicom Members


DETECTOR_CALIBRATION_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_CALIBRATION_DATA Field
MCdicom Structure See Also Send Feedback
Detector Calibration Data (4010,106C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_CALIBRATION_DATA
Visual Basic
Public Const DETECTOR_CALIBRATION_DATA As UInteger
Visual C++
public:
literal unsigned int DETECTOR_CALIBRATION_DATA

See Also

MCdicom Structure
MCdicom Members


DETECTOR_CONDITIONS_NOMINAL_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_CONDITIONS_NOMINAL_FLAG Field
MCdicom Structure See Also Send Feedback
Detector Conditions Nominal Flag (0018,7000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_CONDITIONS_NOMINAL_FLAG
Visual Basic
Public Const DETECTOR_CONDITIONS_NOMINAL_FLAG As UInteger
Visual C++
public:
literal unsigned int DETECTOR_CONDITIONS_NOMINAL_FLAG

See Also

MCdicom Structure
MCdicom Members


DETECTOR_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_CONFIGURATION Field
MCdicom Structure See Also Send Feedback
Detector Configuration (0018,7005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_CONFIGURATION
Visual Basic
Public Const DETECTOR_CONFIGURATION As UInteger
Visual C++
public:
literal unsigned int DETECTOR_CONFIGURATION

See Also

MCdicom Structure
MCdicom Members


DETECTOR_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Detector Description (0018,7006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_DESCRIPTION
Visual Basic
Public Const DETECTOR_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DETECTOR_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ELEMENT_PHYSICAL_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ELEMENT_PHYSICAL_SIZE Field
MCdicom Structure See Also Send Feedback
Detector Element Physical Size (0018,7020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ELEMENT_PHYSICAL_SIZE
Visual Basic
Public Const DETECTOR_ELEMENT_PHYSICAL_SIZE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ELEMENT_PHYSICAL_SIZE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ELEMENT_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ELEMENT_SIZE Field
MCdicom Structure See Also Send Feedback
Detector Element Size (0054,1203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ELEMENT_SIZE
Visual Basic
Public Const DETECTOR_ELEMENT_SIZE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ELEMENT_SIZE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ELEMENT_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ELEMENT_SPACING Field
MCdicom Structure See Also Send Feedback
Detector Element Spacing (0018,7022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ELEMENT_SPACING
Visual Basic
Public Const DETECTOR_ELEMENT_SPACING As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ELEMENT_SPACING

See Also

MCdicom Structure
MCdicom Members


DETECTOR_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_GEOMETRY Field
MCdicom Structure See Also Send Feedback
Detector Geometry (0018,9725)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_GEOMETRY
Visual Basic
Public Const DETECTOR_GEOMETRY As UInteger
Visual C++
public:
literal unsigned int DETECTOR_GEOMETRY

See Also

MCdicom Structure
MCdicom Members


DETECTOR_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Detector Geometry Sequence (4010,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_GEOMETRY_SEQUENCE
Visual Basic
Public Const DETECTOR_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ID Field
MCdicom Structure See Also Send Feedback
Detector ID (0018,700A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ID
Visual Basic
Public Const DETECTOR_ID As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ID

See Also

MCdicom Structure
MCdicom Members


DETECTOR_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Detector Information Sequence (0054,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_INFORMATION_SEQUENCE
Visual Basic
Public Const DETECTOR_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ISOCENTER_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ISOCENTER_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Detector Isocenter Primary Angle (0018,9550)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ISOCENTER_PRIMARY_ANGLE
Visual Basic
Public Const DETECTOR_ISOCENTER_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ISOCENTER_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_ISOCENTER_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_ISOCENTER_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Detector Isocenter Secondary Angle (0018,9551)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_ISOCENTER_SECONDARY_ANGLE
Visual Basic
Public Const DETECTOR_ISOCENTER_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_ISOCENTER_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_LINES_OF_RESPONSE_USED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_LINES_OF_RESPONSE_USED Field
MCdicom Structure See Also Send Feedback
Detector Lines of Response Used (0054,1104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_LINES_OF_RESPONSE_USED
Visual Basic
Public Const DETECTOR_LINES_OF_RESPONSE_USED As UInteger
Visual C++
public:
literal unsigned int DETECTOR_LINES_OF_RESPONSE_USED

See Also

MCdicom Structure
MCdicom Members


DETECTOR_MANUFACTURER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_MANUFACTURER_NAME Field
MCdicom Structure See Also Send Feedback
Detector Manufacturer Name (0018,702A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_MANUFACTURER_NAME
Visual Basic
Public Const DETECTOR_MANUFACTURER_NAME As UInteger
Visual C++
public:
literal unsigned int DETECTOR_MANUFACTURER_NAME

See Also

MCdicom Structure
MCdicom Members


DETECTOR_MANUFACTURERS_MODEL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_MANUFACTURERS_MODEL_NAME Field
MCdicom Structure See Also Send Feedback
Detector Manufacturer's Model Name (0018,702B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_MANUFACTURERS_MODEL_NAME
Visual Basic
Public Const DETECTOR_MANUFACTURERS_MODEL_NAME As UInteger
Visual C++
public:
literal unsigned int DETECTOR_MANUFACTURERS_MODEL_NAME

See Also

MCdicom Structure
MCdicom Members


DETECTOR_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_MODE Field
MCdicom Structure See Also Send Feedback
Detector Mode (0018,7008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_MODE
Visual Basic
Public Const DETECTOR_MODE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_MODE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_NORMALIZATION_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_NORMALIZATION_CORRECTION Field
MCdicom Structure See Also Send Feedback
Detector Normalization Correction (0018,9768)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_NORMALIZATION_CORRECTION
Visual Basic
Public Const DETECTOR_NORMALIZATION_CORRECTION As UInteger
Visual C++
public:
literal unsigned int DETECTOR_NORMALIZATION_CORRECTION

See Also

MCdicom Structure
MCdicom Members


DETECTOR_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Detector Position Sequence (0018,9541)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_POSITION_SEQUENCE
Visual Basic
Public Const DETECTOR_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_POSITIONING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_POSITIONING_TYPE Field
MCdicom Structure See Also Send Feedback
Detector Positioning Type (3002,012F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_POSITIONING_TYPE
Visual Basic
Public Const DETECTOR_POSITIONING_TYPE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_POSITIONING_TYPE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Detector Primary Angle (0018,1530)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_PRIMARY_ANGLE
Visual Basic
Public Const DETECTOR_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Detector Secondary Angle (0018,1531)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_SECONDARY_ANGLE
Visual Basic
Public Const DETECTOR_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_TEMPERATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_TEMPERATURE Field
MCdicom Structure See Also Send Feedback
Detector Temperature (0018,7001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_TEMPERATURE
Visual Basic
Public Const DETECTOR_TEMPERATURE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_TEMPERATURE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_TEMPERATURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_TEMPERATURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Detector Temperature Sequence (0014,3020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_TEMPERATURE_SEQUENCE
Visual Basic
Public Const DETECTOR_TEMPERATURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_TEMPERATURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_TIME_SINCE_LAST_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_TIME_SINCE_LAST_EXPOSURE Field
MCdicom Structure See Also Send Feedback
Detector Time Since Last Exposure (0018,7012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_TIME_SINCE_LAST_EXPOSURE
Visual Basic
Public Const DETECTOR_TIME_SINCE_LAST_EXPOSURE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_TIME_SINCE_LAST_EXPOSURE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_TYPE Field
MCdicom Structure See Also Send Feedback
Detector Type (0018,7004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_TYPE
Visual Basic
Public Const DETECTOR_TYPE As UInteger
Visual C++
public:
literal unsigned int DETECTOR_TYPE

See Also

MCdicom Structure
MCdicom Members


DETECTOR_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_VECTOR Field
MCdicom Structure See Also Send Feedback
Detector Vector (0054,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_VECTOR
Visual Basic
Public Const DETECTOR_VECTOR As UInteger
Visual C++
public:
literal unsigned int DETECTOR_VECTOR

See Also

MCdicom Structure
MCdicom Members


DETECTOR_X_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_X_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Detector X Position to Isocenter (0018,9552)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_X_POSITION_TO_ISOCENTER
Visual Basic
Public Const DETECTOR_X_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int DETECTOR_X_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


DETECTOR_Y_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_Y_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Detector Y Position to Isocenter (0018,9553)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_Y_POSITION_TO_ISOCENTER
Visual Basic
Public Const DETECTOR_Y_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int DETECTOR_Y_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


DETECTOR_Z_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DETECTOR_Z_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Detector Z Position to Isocenter (0018,9554)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DETECTOR_Z_POSITION_TO_ISOCENTER
Visual Basic
Public Const DETECTOR_Z_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int DETECTOR_Z_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


DEVIATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVIATION_INDEX Field
MCdicom Structure See Also Send Feedback
Deviation Index (0018,1413)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVIATION_INDEX
Visual Basic
Public Const DEVIATION_INDEX As UInteger
Visual C++
public:
literal unsigned int DEVIATION_INDEX

See Also

MCdicom Structure
MCdicom Members


DEVICE_ALTERNATE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_ALTERNATE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Device Alternate Identifier (3010,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_ALTERNATE_IDENTIFIER
Visual Basic
Public Const DEVICE_ALTERNATE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int DEVICE_ALTERNATE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


DEVICE_ALTERNATE_IDENTIFIER_FORMAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_ALTERNATE_IDENTIFIER_FORMAT Field
MCdicom Structure See Also Send Feedback
Device Alternate Identifier Format (3010,001D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_ALTERNATE_IDENTIFIER_FORMAT
Visual Basic
Public Const DEVICE_ALTERNATE_IDENTIFIER_FORMAT As UInteger
Visual C++
public:
literal unsigned int DEVICE_ALTERNATE_IDENTIFIER_FORMAT

See Also

MCdicom Structure
MCdicom Members


DEVICE_ALTERNATE_IDENTIFIER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_ALTERNATE_IDENTIFIER_TYPE Field
MCdicom Structure See Also Send Feedback
Device Alternate Identifier Type (3010,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_ALTERNATE_IDENTIFIER_TYPE
Visual Basic
Public Const DEVICE_ALTERNATE_IDENTIFIER_TYPE As UInteger
Visual C++
public:
literal unsigned int DEVICE_ALTERNATE_IDENTIFIER_TYPE

See Also

MCdicom Structure
MCdicom Members


DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Device Description (0050,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_DESCRIPTION
Visual Basic
Public Const DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DEVICE_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_DIAMETER Field
MCdicom Structure See Also Send Feedback
Device Diameter (0050,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_DIAMETER
Visual Basic
Public Const DEVICE_DIAMETER As UInteger
Visual C++
public:
literal unsigned int DEVICE_DIAMETER

See Also

MCdicom Structure
MCdicom Members


DEVICE_DIAMETER_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_DIAMETER_UNITS Field
MCdicom Structure See Also Send Feedback
Device Diameter Units (0050,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_DIAMETER_UNITS
Visual Basic
Public Const DEVICE_DIAMETER_UNITS As UInteger
Visual C++
public:
literal unsigned int DEVICE_DIAMETER_UNITS

See Also

MCdicom Structure
MCdicom Members


DEVICE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_ID Field
MCdicom Structure See Also Send Feedback
Device ID (0018,1003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_ID
Visual Basic
Public Const DEVICE_ID As UInteger
Visual C++
public:
literal unsigned int DEVICE_ID

See Also

MCdicom Structure
MCdicom Members


DEVICE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_INDEX Field
MCdicom Structure See Also Send Feedback
Device Index (3010,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_INDEX
Visual Basic
Public Const DEVICE_INDEX As UInteger
Visual C++
public:
literal unsigned int DEVICE_INDEX

See Also

MCdicom Structure
MCdicom Members


DEVICE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_LABEL Field
MCdicom Structure See Also Send Feedback
Device Label (3010,002D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_LABEL
Visual Basic
Public Const DEVICE_LABEL As UInteger
Visual C++
public:
literal unsigned int DEVICE_LABEL

See Also

MCdicom Structure
MCdicom Members


DEVICE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_LENGTH Field
MCdicom Structure See Also Send Feedback
Device Length (0050,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_LENGTH
Visual Basic
Public Const DEVICE_LENGTH As UInteger
Visual C++
public:
literal unsigned int DEVICE_LENGTH

See Also

MCdicom Structure
MCdicom Members


DEVICE_MOTION_CONTROL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_MOTION_CONTROL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device Motion Control Sequence (300A,0450)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_MOTION_CONTROL_SEQUENCE
Visual Basic
Public Const DEVICE_MOTION_CONTROL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_MOTION_CONTROL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_MOTION_EXECUTION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_MOTION_EXECUTION_MODE Field
MCdicom Structure See Also Send Feedback
Device Motion Execution Mode (300A,0451)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_MOTION_EXECUTION_MODE
Visual Basic
Public Const DEVICE_MOTION_EXECUTION_MODE As UInteger
Visual C++
public:
literal unsigned int DEVICE_MOTION_EXECUTION_MODE

See Also

MCdicom Structure
MCdicom Members


DEVICE_MOTION_OBSERVATION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_MOTION_OBSERVATION_MODE Field
MCdicom Structure See Also Send Feedback
Device Motion Observation Mode (300A,0452)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_MOTION_OBSERVATION_MODE
Visual Basic
Public Const DEVICE_MOTION_OBSERVATION_MODE As UInteger
Visual C++
public:
literal unsigned int DEVICE_MOTION_OBSERVATION_MODE

See Also

MCdicom Structure
MCdicom Members


DEVICE_MOTION_PARAMETER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_MOTION_PARAMETER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device Motion Parameter Code Sequence (300A,0453)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_MOTION_PARAMETER_CODE_SEQUENCE
Visual Basic
Public Const DEVICE_MOTION_PARAMETER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_MOTION_PARAMETER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Device Order Index (300A,065E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_ORDER_INDEX
Visual Basic
Public Const DEVICE_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int DEVICE_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


DEVICE_POSITION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_POSITION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device Position Parameter Sequence (3002,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_POSITION_PARAMETER_SEQUENCE
Visual Basic
Public Const DEVICE_POSITION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_POSITION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX Field
MCdicom Structure See Also Send Feedback
Device Position to Equipment Mapping Matrix (3002,010F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX
Visual Basic
Public Const DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX As UInteger
Visual C++
public:
literal unsigned int DEVICE_POSITION_TO_EQUIPMENT_MAPPING_MATRIX

See Also

MCdicom Structure
MCdicom Members


DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device Sequence (0050,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_SEQUENCE
Visual Basic
Public Const DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_SERIAL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_SERIAL_NUMBER Field
MCdicom Structure See Also Send Feedback
Device Serial Number (0018,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_SERIAL_NUMBER
Visual Basic
Public Const DEVICE_SERIAL_NUMBER As UInteger
Visual C++
public:
literal unsigned int DEVICE_SERIAL_NUMBER

See Also

MCdicom Structure
MCdicom Members


DEVICE_SETTING_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_SETTING_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Device Setting Description (0016,004B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_SETTING_DESCRIPTION
Visual Basic
Public Const DEVICE_SETTING_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DEVICE_SETTING_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device-Specific Acquisition Parameter Sequence (3002,0131)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE
Visual Basic
Public Const DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_SPECIFIC_ACQUISITION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Device Type Code Sequence (3010,002E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const DEVICE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DEVICE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DEVICE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_UID Field
MCdicom Structure See Also Send Feedback
Device UID (0018,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_UID
Visual Basic
Public Const DEVICE_UID As UInteger
Visual C++
public:
literal unsigned int DEVICE_UID

See Also

MCdicom Structure
MCdicom Members


DEVICE_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DEVICE_VOLUME Field
MCdicom Structure See Also Send Feedback
Device Volume (0050,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DEVICE_VOLUME
Visual Basic
Public Const DEVICE_VOLUME As UInteger
Visual C++
public:
literal unsigned int DEVICE_VOLUME

See Also

MCdicom Structure
MCdicom Members


DIALOG_RECEIVER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIALOG_RECEIVER_RETIRED Field
MCdicom Structure See Also Send Feedback
Dialog Receiver RETIRED (0000,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIALOG_RECEIVER_RETIRED
Visual Basic
Public Const DIALOG_RECEIVER_RETIRED As UInteger
Visual C++
public:
literal unsigned int DIALOG_RECEIVER_RETIRED

See Also

MCdicom Structure
MCdicom Members


DIAMETER_OF_CIRCULAR_OUTLINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIAMETER_OF_CIRCULAR_OUTLINE Field
MCdicom Structure See Also Send Feedback
Diameter of Circular Outline (0018,1636)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIAMETER_OF_CIRCULAR_OUTLINE
Visual Basic
Public Const DIAMETER_OF_CIRCULAR_OUTLINE As UInteger
Visual C++
public:
literal unsigned int DIAMETER_OF_CIRCULAR_OUTLINE

See Also

MCdicom Structure
MCdicom Members


DIAMETER_OF_VISIBILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIAMETER_OF_VISIBILITY Field
MCdicom Structure See Also Send Feedback
Diameter of Visibility (0070,0262)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIAMETER_OF_VISIBILITY
Visual Basic
Public Const DIAMETER_OF_VISIBILITY As UInteger
Visual C++
public:
literal unsigned int DIAMETER_OF_VISIBILITY

See Also

MCdicom Structure
MCdicom Members


DIAPHRAGM_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIAPHRAGM_POSITION Field
MCdicom Structure See Also Send Feedback
Diaphragm Position (3002,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIAPHRAGM_POSITION
Visual Basic
Public Const DIAPHRAGM_POSITION As UInteger
Visual C++
public:
literal unsigned int DIAPHRAGM_POSITION

See Also

MCdicom Structure
MCdicom Members


DICOM_MEDIA_RETRIEVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DICOM_MEDIA_RETRIEVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DICOM Media Retrieval Sequence (0040,E022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DICOM_MEDIA_RETRIEVAL_SEQUENCE
Visual Basic
Public Const DICOM_MEDIA_RETRIEVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DICOM_MEDIA_RETRIEVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DICOM_RETRIEVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DICOM_RETRIEVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DICOM Retrieval Sequence (0040,E021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DICOM_RETRIEVAL_SEQUENCE
Visual Basic
Public Const DICOM_RETRIEVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DICOM_RETRIEVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DICOM_STORAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DICOM_STORAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DICOM Storage Sequence (0040,4071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DICOM_STORAGE_SEQUENCE
Visual Basic
Public Const DICOM_STORAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DICOM_STORAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DICOS_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DICOS_VERSION Field
MCdicom Structure See Also Send Feedback
DICOS Version (4010,103A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DICOS_VERSION
Visual Basic
Public Const DICOS_VERSION As UInteger
Visual C++
public:
literal unsigned int DICOS_VERSION

See Also

MCdicom Structure
MCdicom Members


DIFFUSE_REFLECTION_INTENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSE_REFLECTION_INTENSITY Field
MCdicom Structure See Also Send Feedback
Diffuse Reflection Intensity (0070,1704)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSE_REFLECTION_INTENSITY
Visual Basic
Public Const DIFFUSE_REFLECTION_INTENSITY As UInteger
Visual C++
public:
literal unsigned int DIFFUSE_REFLECTION_INTENSITY

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_ACQUISITION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_ACQUISITION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Diffusion Acquisition Code Sequence (0066,0133)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_ACQUISITION_CODE_SEQUENCE
Visual Basic
Public Const DIFFUSION_ACQUISITION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_ACQUISITION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_ANISOTROPY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_ANISOTROPY_TYPE Field
MCdicom Structure See Also Send Feedback
Diffusion Anisotropy Type (0018,9147)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_ANISOTROPY_TYPE
Visual Basic
Public Const DIFFUSION_ANISOTROPY_TYPE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_ANISOTROPY_TYPE

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_MATRIX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_MATRIX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Diffusion b-matrix Sequence (0018,9601)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_MATRIX_SEQUENCE
Visual Basic
Public Const DIFFUSION_B_MATRIX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_MATRIX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE Field
MCdicom Structure See Also Send Feedback
Diffusion b-value (0018,9087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE
Visual Basic
Public Const DIFFUSION_B_VALUE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_XX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_XX Field
MCdicom Structure See Also Send Feedback
Diffusion b-value XX (0018,9602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_XX
Visual Basic
Public Const DIFFUSION_B_VALUE_XX As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_XX

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_XY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_XY Field
MCdicom Structure See Also Send Feedback
Diffusion b-value XY (0018,9603)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_XY
Visual Basic
Public Const DIFFUSION_B_VALUE_XY As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_XY

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_XZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_XZ Field
MCdicom Structure See Also Send Feedback
Diffusion b-value XZ (0018,9604)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_XZ
Visual Basic
Public Const DIFFUSION_B_VALUE_XZ As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_XZ

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_YY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_YY Field
MCdicom Structure See Also Send Feedback
Diffusion b-value YY (0018,9605)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_YY
Visual Basic
Public Const DIFFUSION_B_VALUE_YY As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_YY

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_YZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_YZ Field
MCdicom Structure See Also Send Feedback
Diffusion b-value YZ (0018,9606)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_YZ
Visual Basic
Public Const DIFFUSION_B_VALUE_YZ As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_YZ

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_B_VALUE_ZZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_B_VALUE_ZZ Field
MCdicom Structure See Also Send Feedback
Diffusion b-value ZZ (0018,9607)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_B_VALUE_ZZ
Visual Basic
Public Const DIFFUSION_B_VALUE_ZZ As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_B_VALUE_ZZ

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_DIRECTIONALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_DIRECTIONALITY Field
MCdicom Structure See Also Send Feedback
Diffusion Directionality (0018,9075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_DIRECTIONALITY
Visual Basic
Public Const DIFFUSION_DIRECTIONALITY As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_DIRECTIONALITY

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_GRADIENT_DIRECTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_GRADIENT_DIRECTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Diffusion Gradient Direction Sequence (0018,9076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_GRADIENT_DIRECTION_SEQUENCE
Visual Basic
Public Const DIFFUSION_GRADIENT_DIRECTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_GRADIENT_DIRECTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_GRADIENT_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_GRADIENT_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Diffusion Gradient Orientation (0018,9089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_GRADIENT_ORIENTATION
Visual Basic
Public Const DIFFUSION_GRADIENT_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_GRADIENT_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


DIFFUSION_MODEL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIFFUSION_MODEL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Diffusion Model Code Sequence (0066,0134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIFFUSION_MODEL_CODE_SEQUENCE
Visual Basic
Public Const DIFFUSION_MODEL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIFFUSION_MODEL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Digital Filter Characteristics Sequence (003A,0326)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIGITAL_FILTER_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIGITAL_FILTER_ORDER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_FILTER_ORDER Field
MCdicom Structure See Also Send Feedback
Digital Filter Order (003A,0327)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_FILTER_ORDER
Visual Basic
Public Const DIGITAL_FILTER_ORDER As UInteger
Visual C++
public:
literal unsigned int DIGITAL_FILTER_ORDER

See Also

MCdicom Structure
MCdicom Members


DIGITAL_FILTER_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_FILTER_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Digital Filter Type Code Sequence (003A,0328)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_FILTER_TYPE_CODE_SEQUENCE
Visual Basic
Public Const DIGITAL_FILTER_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIGITAL_FILTER_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIGITAL_IMAGE_FORMAT_ACQUIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_IMAGE_FORMAT_ACQUIRED Field
MCdicom Structure See Also Send Feedback
Digital Image Format Acquired (0018,1023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_IMAGE_FORMAT_ACQUIRED
Visual Basic
Public Const DIGITAL_IMAGE_FORMAT_ACQUIRED As UInteger
Visual C++
public:
literal unsigned int DIGITAL_IMAGE_FORMAT_ACQUIRED

See Also

MCdicom Structure
MCdicom Members


DIGITAL_SIGNATURE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_SIGNATURE_DATETIME Field
MCdicom Structure See Also Send Feedback
Digital Signature DateTime (0400,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_SIGNATURE_DATETIME
Visual Basic
Public Const DIGITAL_SIGNATURE_DATETIME As UInteger
Visual C++
public:
literal unsigned int DIGITAL_SIGNATURE_DATETIME

See Also

MCdicom Structure
MCdicom Members


DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Digital Signature Purpose Code Sequence (0400,0401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE
Visual Basic
Public Const DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIGITAL_SIGNATURE_PURPOSE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIGITAL_SIGNATURE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_SIGNATURE_UID Field
MCdicom Structure See Also Send Feedback
Digital Signature UID (0400,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_SIGNATURE_UID
Visual Basic
Public Const DIGITAL_SIGNATURE_UID As UInteger
Visual C++
public:
literal unsigned int DIGITAL_SIGNATURE_UID

See Also

MCdicom Structure
MCdicom Members


DIGITAL_SIGNATURES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_SIGNATURES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Digital Signatures Sequence (FFFA,FFFA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_SIGNATURES_SEQUENCE
Visual Basic
Public Const DIGITAL_SIGNATURES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIGITAL_SIGNATURES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIGITAL_ZOOM_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITAL_ZOOM_RATIO Field
MCdicom Structure See Also Send Feedback
Digital Zoom Ratio (0016,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITAL_ZOOM_RATIO
Visual Basic
Public Const DIGITAL_ZOOM_RATIO As UInteger
Visual C++
public:
literal unsigned int DIGITAL_ZOOM_RATIO

See Also

MCdicom Structure
MCdicom Members


DIGITIZING_DEVICE_TRANSPORT_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIGITIZING_DEVICE_TRANSPORT_DIRECTION Field
MCdicom Structure See Also Send Feedback
Digitizing Device Transport Direction (0018,2020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIGITIZING_DEVICE_TRANSPORT_DIRECTION
Visual Basic
Public Const DIGITIZING_DEVICE_TRANSPORT_DIRECTION As UInteger
Visual C++
public:
literal unsigned int DIGITIZING_DEVICE_TRANSPORT_DIRECTION

See Also

MCdicom Structure
MCdicom Members


DIMENSION_DESCRIPTION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_DESCRIPTION_LABEL Field
MCdicom Structure See Also Send Feedback
Dimension Description Label (0020,9421)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_DESCRIPTION_LABEL
Visual Basic
Public Const DIMENSION_DESCRIPTION_LABEL As UInteger
Visual C++
public:
literal unsigned int DIMENSION_DESCRIPTION_LABEL

See Also

MCdicom Structure
MCdicom Members


DIMENSION_INDEX_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_INDEX_POINTER Field
MCdicom Structure See Also Send Feedback
Dimension Index Pointer (0020,9165)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_INDEX_POINTER
Visual Basic
Public Const DIMENSION_INDEX_POINTER As UInteger
Visual C++
public:
literal unsigned int DIMENSION_INDEX_POINTER

See Also

MCdicom Structure
MCdicom Members


DIMENSION_INDEX_PRIVATE_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_INDEX_PRIVATE_CREATOR Field
MCdicom Structure See Also Send Feedback
Dimension Index Private Creator (0020,9213)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_INDEX_PRIVATE_CREATOR
Visual Basic
Public Const DIMENSION_INDEX_PRIVATE_CREATOR As UInteger
Visual C++
public:
literal unsigned int DIMENSION_INDEX_PRIVATE_CREATOR

See Also

MCdicom Structure
MCdicom Members


DIMENSION_INDEX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_INDEX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dimension Index Sequence (0020,9222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_INDEX_SEQUENCE
Visual Basic
Public Const DIMENSION_INDEX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIMENSION_INDEX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIMENSION_INDEX_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_INDEX_VALUES Field
MCdicom Structure See Also Send Feedback
Dimension Index Values (0020,9157)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_INDEX_VALUES
Visual Basic
Public Const DIMENSION_INDEX_VALUES As UInteger
Visual C++
public:
literal unsigned int DIMENSION_INDEX_VALUES

See Also

MCdicom Structure
MCdicom Members


DIMENSION_ORGANIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_ORGANIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dimension Organization Sequence (0020,9221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_ORGANIZATION_SEQUENCE
Visual Basic
Public Const DIMENSION_ORGANIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIMENSION_ORGANIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIMENSION_ORGANIZATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_ORGANIZATION_TYPE Field
MCdicom Structure See Also Send Feedback
Dimension Organization Type (0020,9311)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_ORGANIZATION_TYPE
Visual Basic
Public Const DIMENSION_ORGANIZATION_TYPE As UInteger
Visual C++
public:
literal unsigned int DIMENSION_ORGANIZATION_TYPE

See Also

MCdicom Structure
MCdicom Members


DIMENSION_ORGANIZATION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIMENSION_ORGANIZATION_UID Field
MCdicom Structure See Also Send Feedback
Dimension Organization UID (0020,9164)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIMENSION_ORGANIZATION_UID
Visual Basic
Public Const DIMENSION_ORGANIZATION_UID As UInteger
Visual C++
public:
literal unsigned int DIMENSION_ORGANIZATION_UID

See Also

MCdicom Structure
MCdicom Members


DIRECT_SEGMENT_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIRECT_SEGMENT_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Direct Segment Reference Sequence (3010,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIRECT_SEGMENT_REFERENCE_SEQUENCE
Visual Basic
Public Const DIRECT_SEGMENT_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIRECT_SEGMENT_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIRECTORY_RECORD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIRECTORY_RECORD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Directory Record Sequence (0004,1220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIRECTORY_RECORD_SEQUENCE
Visual Basic
Public Const DIRECTORY_RECORD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DIRECTORY_RECORD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DIRECTORY_RECORD_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DIRECTORY_RECORD_TYPE Field
MCdicom Structure See Also Send Feedback
Directory Record Type (0004,1430)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DIRECTORY_RECORD_TYPE
Visual Basic
Public Const DIRECTORY_RECORD_TYPE As UInteger
Visual C++
public:
literal unsigned int DIRECTORY_RECORD_TYPE

See Also

MCdicom Structure
MCdicom Members


DISCHARGE_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISCHARGE_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Discharge Date RETIRED (0038,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISCHARGE_DATE_RETIRED
Visual Basic
Public Const DISCHARGE_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISCHARGE_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Discharge Diagnosis Code Sequence RETIRED (0038,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISCHARGE_DIAGNOSIS_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Discharge Diagnosis Description RETIRED (0038,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED
Visual Basic
Public Const DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISCHARGE_DIAGNOSIS_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISCHARGE_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISCHARGE_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Discharge Time RETIRED (0038,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISCHARGE_TIME_RETIRED
Visual Basic
Public Const DISCHARGE_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISCHARGE_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISPLACEMENT_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLACEMENT_MATRIX Field
MCdicom Structure See Also Send Feedback
Displacement Matrix (300A,079B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLACEMENT_MATRIX
Visual Basic
Public Const DISPLACEMENT_MATRIX As UInteger
Visual C++
public:
literal unsigned int DISPLACEMENT_MATRIX

See Also

MCdicom Structure
MCdicom Members


DISPLACEMENT_REFERENCE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLACEMENT_REFERENCE_LABEL Field
MCdicom Structure See Also Send Feedback
Displacement Reference Label (300A,079A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLACEMENT_REFERENCE_LABEL
Visual Basic
Public Const DISPLACEMENT_REFERENCE_LABEL As UInteger
Visual C++
public:
literal unsigned int DISPLACEMENT_REFERENCE_LABEL

See Also

MCdicom Structure
MCdicom Members


DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Displacement Reference Location Code Sequence (300A,079D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE
Visual Basic
Public Const DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLACEMENT_REFERENCE_LOCATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_CALIBRATION_RESULT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_CALIBRATION_RESULT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Calibration Result Sequence (0028,7016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_CALIBRATION_RESULT_SEQUENCE
Visual Basic
Public Const DISPLAY_CALIBRATION_RESULT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_CALIBRATION_RESULT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_DEVICE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_DEVICE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Device Type Code Sequence (0028,7022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_DEVICE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const DISPLAY_DEVICE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_DEVICE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_ENVIRONMENT_SPATIAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_ENVIRONMENT_SPATIAL_POSITION Field
MCdicom Structure See Also Send Feedback
Display Environment Spatial Position (0072,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_ENVIRONMENT_SPATIAL_POSITION
Visual Basic
Public Const DISPLAY_ENVIRONMENT_SPATIAL_POSITION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_ENVIRONMENT_SPATIAL_POSITION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_FILTER_PERCENTAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_FILTER_PERCENTAGE Field
MCdicom Structure See Also Send Feedback
Display Filter Percentage (0028,9411)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_FILTER_PERCENTAGE
Visual Basic
Public Const DISPLAY_FILTER_PERCENTAGE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_FILTER_PERCENTAGE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
Display Format RETIRED (0000,5110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_FORMAT_RETIRED
Visual Basic
Public Const DISPLAY_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISPLAY_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISPLAY_FUNCTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_FUNCTION_TYPE Field
MCdicom Structure See Also Send Feedback
Display Function Type (0028,7019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_FUNCTION_TYPE
Visual Basic
Public Const DISPLAY_FUNCTION_TYPE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_FUNCTION_TYPE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_HORIZONTAL_JUSTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_HORIZONTAL_JUSTIFICATION Field
MCdicom Structure See Also Send Feedback
Display Set Horizontal Justification (0072,0717)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_HORIZONTAL_JUSTIFICATION
Visual Basic
Public Const DISPLAY_SET_HORIZONTAL_JUSTIFICATION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_HORIZONTAL_JUSTIFICATION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_LABEL Field
MCdicom Structure See Also Send Feedback
Display Set Label (0072,0203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_LABEL
Visual Basic
Public Const DISPLAY_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_NUMBER Field
MCdicom Structure See Also Send Feedback
Display Set Number (0072,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_NUMBER
Visual Basic
Public Const DISPLAY_SET_NUMBER As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_NUMBER

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_PATIENT_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_PATIENT_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Display Set Patient Orientation (0072,0700)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_PATIENT_ORIENTATION
Visual Basic
Public Const DISPLAY_SET_PATIENT_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_PATIENT_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_PRESENTATION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_PRESENTATION_GROUP Field
MCdicom Structure See Also Send Feedback
Display Set Presentation Group (0072,0204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_PRESENTATION_GROUP
Visual Basic
Public Const DISPLAY_SET_PRESENTATION_GROUP As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_PRESENTATION_GROUP

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Display Set Presentation Group Description (0072,0206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION
Visual Basic
Public Const DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_PRESENTATION_GROUP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_SCROLLING_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_SCROLLING_GROUP Field
MCdicom Structure See Also Send Feedback
Display Set Scrolling Group (0072,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_SCROLLING_GROUP
Visual Basic
Public Const DISPLAY_SET_SCROLLING_GROUP As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_SCROLLING_GROUP

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SET_VERTICAL_JUSTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SET_VERTICAL_JUSTIFICATION Field
MCdicom Structure See Also Send Feedback
Display Set Vertical Justification (0072,0718)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SET_VERTICAL_JUSTIFICATION
Visual Basic
Public Const DISPLAY_SET_VERTICAL_JUSTIFICATION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SET_VERTICAL_JUSTIFICATION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SETS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SETS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Sets Sequence (0072,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SETS_SEQUENCE
Visual Basic
Public Const DISPLAY_SETS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SETS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SHADING_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SHADING_FLAG Field
MCdicom Structure See Also Send Feedback
Display Shading Flag (003A,0246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SHADING_FLAG
Visual Basic
Public Const DISPLAY_SHADING_FLAG As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SHADING_FLAG

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Subsystem Configuration Sequence (0028,700A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE
Visual Basic
Public Const DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_CONFIGURATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Display Subsystem Description (0028,7005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_DESCRIPTION
Visual Basic
Public Const DISPLAY_SUBSYSTEM_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_ID Field
MCdicom Structure See Also Send Feedback
Display Subsystem ID (0028,7003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_ID
Visual Basic
Public Const DISPLAY_SUBSYSTEM_ID As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_ID

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_NAME Field
MCdicom Structure See Also Send Feedback
Display Subsystem Name (0028,7004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_NAME
Visual Basic
Public Const DISPLAY_SUBSYSTEM_NAME As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_NAME

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Subsystem QA Results Sequence (0028,7010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE
Visual Basic
Public Const DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_QA_RESULTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_SUBSYSTEM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_SUBSYSTEM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Display Subsystem Sequence (0028,7023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_SUBSYSTEM_SEQUENCE
Visual Basic
Public Const DISPLAY_SUBSYSTEM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAY_SUBSYSTEM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAY_WINDOW_LABEL_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAY_WINDOW_LABEL_VECTOR Field
MCdicom Structure See Also Send Feedback
Display Window Label Vector (0018,2006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAY_WINDOW_LABEL_VECTOR
Visual Basic
Public Const DISPLAY_WINDOW_LABEL_VECTOR As UInteger
Visual C++
public:
literal unsigned int DISPLAY_WINDOW_LABEL_VECTOR

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Displayed Area Bottom Right Hand Corner (0070,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER
Visual Basic
Public Const DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Displayed Area Bottom Right Hand Corner (Trial) RETIRED (0070,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED
Visual Basic
Public Const DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_AREA_BOTTOM_RIGHT_HAND_CORNER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_AREA_SELECTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_AREA_SELECTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Displayed Area Selection Sequence (0070,005A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_AREA_SELECTION_SEQUENCE
Visual Basic
Public Const DISPLAYED_AREA_SELECTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_AREA_SELECTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_AREA_TOP_LEFT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_AREA_TOP_LEFT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Displayed Area Top Left Hand Corner (0070,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_AREA_TOP_LEFT_HAND_CORNER
Visual Basic
Public Const DISPLAYED_AREA_TOP_LEFT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_AREA_TOP_LEFT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Displayed Area Top Left Hand Corner (Trial) RETIRED (0070,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED
Visual Basic
Public Const DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_AREA_TOP_LEFT_HAND_CORNER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISPLAYED_Z_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISPLAYED_Z_VALUE Field
MCdicom Structure See Also Send Feedback
Displayed Z Value (0018,2046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISPLAYED_Z_VALUE
Visual Basic
Public Const DISPLAYED_Z_VALUE As UInteger
Visual C++
public:
literal unsigned int DISPLAYED_Z_VALUE

See Also

MCdicom Structure
MCdicom Members


DISTAL_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTAL_DEPTH Field
MCdicom Structure See Also Send Feedback
Distal Depth (300A,0502)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTAL_DEPTH
Visual Basic
Public Const DISTAL_DEPTH As UInteger
Visual C++
public:
literal unsigned int DISTAL_DEPTH

See Also

MCdicom Structure
MCdicom Members


DISTAL_DEPTH_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTAL_DEPTH_FRACTION Field
MCdicom Structure See Also Send Feedback
Distal Depth Fraction (300A,0501)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTAL_DEPTH_FRACTION
Visual Basic
Public Const DISTAL_DEPTH_FRACTION As UInteger
Visual C++
public:
literal unsigned int DISTAL_DEPTH_FRACTION

See Also

MCdicom Structure
MCdicom Members


DISTANCE_BETWEEN_B_SCAN_SLABS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_BETWEEN_B_SCAN_SLABS Field
MCdicom Structure See Also Send Feedback
Distance Between B-scan Slabs (0022,1644)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_BETWEEN_B_SCAN_SLABS
Visual Basic
Public Const DISTANCE_BETWEEN_B_SCAN_SLABS As UInteger
Visual C++
public:
literal unsigned int DISTANCE_BETWEEN_B_SCAN_SLABS

See Also

MCdicom Structure
MCdicom Members


DISTANCE_BETWEEN_FOCAL_PLANES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_BETWEEN_FOCAL_PLANES Field
MCdicom Structure See Also Send Feedback
Distance Between Focal Planes (0048,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_BETWEEN_FOCAL_PLANES
Visual Basic
Public Const DISTANCE_BETWEEN_FOCAL_PLANES As UInteger
Visual C++
public:
literal unsigned int DISTANCE_BETWEEN_FOCAL_PLANES

See Also

MCdicom Structure
MCdicom Members


DISTANCE_OBJECT_TO_TABLE_TOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_OBJECT_TO_TABLE_TOP Field
MCdicom Structure See Also Send Feedback
Distance Object to Table Top (0018,9403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_OBJECT_TO_TABLE_TOP
Visual Basic
Public Const DISTANCE_OBJECT_TO_TABLE_TOP As UInteger
Visual C++
public:
literal unsigned int DISTANCE_OBJECT_TO_TABLE_TOP

See Also

MCdicom Structure
MCdicom Members


DISTANCE_PUPILLARY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_PUPILLARY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Distance Pupillary Distance (0046,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_PUPILLARY_DISTANCE
Visual Basic
Public Const DISTANCE_PUPILLARY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int DISTANCE_PUPILLARY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING Field
MCdicom Structure See Also Send Feedback
Distance Receptor Plane to Detector Housing (0018,9426)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING
Visual Basic
Public Const DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING As UInteger
Visual C++
public:
literal unsigned int DISTANCE_RECEPTOR_PLANE_TO_DETECTOR_HOUSING

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER Field
MCdicom Structure See Also Send Feedback
Distance Source to Data Collection Center (0018,9335)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER
Visual Basic
Public Const DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_DATA_COLLECTION_CENTER

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_DETECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_DETECTOR Field
MCdicom Structure See Also Send Feedback
Distance Source to Detector (0018,1110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_DETECTOR
Visual Basic
Public Const DISTANCE_SOURCE_TO_DETECTOR As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_DETECTOR

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_ENTRANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_ENTRANCE Field
MCdicom Structure See Also Send Feedback
Distance Source to Entrance (0040,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_ENTRANCE
Visual Basic
Public Const DISTANCE_SOURCE_TO_ENTRANCE As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_ENTRANCE

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Distance Source to Isocenter (0018,9402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_ISOCENTER
Visual Basic
Public Const DISTANCE_SOURCE_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_PATIENT Field
MCdicom Structure See Also Send Feedback
Distance Source to Patient (0018,1111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_PATIENT
Visual Basic
Public Const DISTANCE_SOURCE_TO_PATIENT As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_PATIENT

See Also

MCdicom Structure
MCdicom Members


DISTANCE_SOURCE_TO_SUPPORT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTANCE_SOURCE_TO_SUPPORT_RETIRED Field
MCdicom Structure See Also Send Feedback
Distance Source to Support RETIRED (0040,0307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTANCE_SOURCE_TO_SUPPORT_RETIRED
Visual Basic
Public Const DISTANCE_SOURCE_TO_SUPPORT_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISTANCE_SOURCE_TO_SUPPORT_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISTRIBUTION_ADDRESS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTRIBUTION_ADDRESS_RETIRED Field
MCdicom Structure See Also Send Feedback
Distribution Address RETIRED (4008,011A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTRIBUTION_ADDRESS_RETIRED
Visual Basic
Public Const DISTRIBUTION_ADDRESS_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISTRIBUTION_ADDRESS_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISTRIBUTION_NAME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTRIBUTION_NAME_RETIRED Field
MCdicom Structure See Also Send Feedback
Distribution Name RETIRED (4008,0119)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTRIBUTION_NAME_RETIRED
Visual Basic
Public Const DISTRIBUTION_NAME_RETIRED As UInteger
Visual C++
public:
literal unsigned int DISTRIBUTION_NAME_RETIRED

See Also

MCdicom Structure
MCdicom Members


DISTRIBUTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DISTRIBUTION_TYPE Field
MCdicom Structure See Also Send Feedback
Distribution Type (0012,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DISTRIBUTION_TYPE
Visual Basic
Public Const DISTRIBUTION_TYPE As UInteger
Visual C++
public:
literal unsigned int DISTRIBUTION_TYPE

See Also

MCdicom Structure
MCdicom Members


DLP_NOTIFICATION_TRIGGER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DLP_NOTIFICATION_TRIGGER Field
MCdicom Structure See Also Send Feedback
DLP Notification Trigger (0018,9943)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DLP_NOTIFICATION_TRIGGER
Visual Basic
Public Const DLP_NOTIFICATION_TRIGGER As UInteger
Visual C++
public:
literal unsigned int DLP_NOTIFICATION_TRIGGER

See Also

MCdicom Structure
MCdicom Members


DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Document Author Identifier Code Sequence (Trial) RETIRED (0040,A068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOCUMENT_AUTHOR_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOCUMENT_AUTHOR_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENT_AUTHOR_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Document Author (Trial) RETIRED (0040,A067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENT_AUTHOR_TRIAL_RETIRED
Visual Basic
Public Const DOCUMENT_AUTHOR_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOCUMENT_AUTHOR_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOCUMENT_CLASS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENT_CLASS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Document Class Code Sequence (0040,E008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENT_CLASS_CODE_SEQUENCE
Visual Basic
Public Const DOCUMENT_CLASS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOCUMENT_CLASS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Document Identifier Code Sequence (Trial) RETIRED (0040,A066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOCUMENT_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOCUMENT_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENT_TITLE Field
MCdicom Structure See Also Send Feedback
Document Title (0042,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENT_TITLE
Visual Basic
Public Const DOCUMENT_TITLE As UInteger
Visual C++
public:
literal unsigned int DOCUMENT_TITLE

See Also

MCdicom Structure
MCdicom Members


DOCUMENTING_OBSERVER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENTING_OBSERVER Field
MCdicom Structure See Also Send Feedback
Alias for tag VERIFYING_OBSERVER_NAME (0040,A075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENTING_OBSERVER
Visual Basic
Public Const DOCUMENTING_OBSERVER As UInteger
Visual C++
public:
literal unsigned int DOCUMENTING_OBSERVER

See Also

MCdicom Structure
MCdicom Members


DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Documenting Observer Identifier Code Sequence (Trial) RETIRED (0040,A076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOCUMENTING_OBSERVER_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOCUMENTING_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENTING_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Alias for tag VERIFYING_ORGANIZATION 0040,A027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENTING_ORGANIZATION
Visual Basic
Public Const DOCUMENTING_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int DOCUMENTING_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Documenting Organization Identifier Code Sequence (Trial) RETIRED (0040,A028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOCUMENTING_ORGANIZATION_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOPPLER_CORRECTION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOPPLER_CORRECTION_ANGLE Field
MCdicom Structure See Also Send Feedback
Doppler Correction Angle (0018,6034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOPPLER_CORRECTION_ANGLE
Visual Basic
Public Const DOPPLER_CORRECTION_ANGLE As UInteger
Visual C++
public:
literal unsigned int DOPPLER_CORRECTION_ANGLE

See Also

MCdicom Structure
MCdicom Members


DOPPLER_SAMPLE_VOLUME_X_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOPPLER_SAMPLE_VOLUME_X_POSITION Field
MCdicom Structure See Also Send Feedback
Doppler Sample Volume X Position (0018,6039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOPPLER_SAMPLE_VOLUME_X_POSITION
Visual Basic
Public Const DOPPLER_SAMPLE_VOLUME_X_POSITION As UInteger
Visual C++
public:
literal unsigned int DOPPLER_SAMPLE_VOLUME_X_POSITION

See Also

MCdicom Structure
MCdicom Members


DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED Field
MCdicom Structure See Also Send Feedback
Doppler Sample Volume X Position (Retired) (0018,6038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED
Visual Basic
Public Const DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOPPLER_SAMPLE_VOLUME_X_POSITION_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOPPLER_SAMPLE_VOLUME_Y_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOPPLER_SAMPLE_VOLUME_Y_POSITION Field
MCdicom Structure See Also Send Feedback
Doppler Sample Volume Y Position (0018,603B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOPPLER_SAMPLE_VOLUME_Y_POSITION
Visual Basic
Public Const DOPPLER_SAMPLE_VOLUME_Y_POSITION As UInteger
Visual C++
public:
literal unsigned int DOPPLER_SAMPLE_VOLUME_Y_POSITION

See Also

MCdicom Structure
MCdicom Members


DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED Field
MCdicom Structure See Also Send Feedback
Doppler Sample Volume Y Position (Retired) (0018,603A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED
Visual Basic
Public Const DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOPPLER_SAMPLE_VOLUME_Y_POSITION_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOSE_CALIBRATION_CONDITIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_CALIBRATION_CONDITIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dose Calibration Conditions Sequence (300C,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_CALIBRATION_CONDITIONS_SEQUENCE
Visual Basic
Public Const DOSE_CALIBRATION_CONDITIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSE_CALIBRATION_CONDITIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG Field
MCdicom Structure See Also Send Feedback
Dose Calibration Conditions Verified Flag (300C,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG
Visual Basic
Public Const DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG As UInteger
Visual C++
public:
literal unsigned int DOSE_CALIBRATION_CONDITIONS_VERIFIED_FLAG

See Also

MCdicom Structure
MCdicom Members


DOSE_CALIBRATION_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_CALIBRATION_FACTOR Field
MCdicom Structure See Also Send Feedback
Dose Calibration Factor (0054,1322)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_CALIBRATION_FACTOR
Visual Basic
Public Const DOSE_CALIBRATION_FACTOR As UInteger
Visual C++
public:
literal unsigned int DOSE_CALIBRATION_FACTOR

See Also

MCdicom Structure
MCdicom Members


DOSE_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_COMMENT Field
MCdicom Structure See Also Send Feedback
Dose Comment (3004,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_COMMENT
Visual Basic
Public Const DOSE_COMMENT As UInteger
Visual C++
public:
literal unsigned int DOSE_COMMENT

See Also

MCdicom Structure
MCdicom Members


DOSE_GRID_SCALING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_GRID_SCALING Field
MCdicom Structure See Also Send Feedback
Dose Grid Scaling (3004,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_GRID_SCALING
Visual Basic
Public Const DOSE_GRID_SCALING As UInteger
Visual C++
public:
literal unsigned int DOSE_GRID_SCALING

See Also

MCdicom Structure
MCdicom Members


DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dose Measurement Device Code Sequence (300A,0774)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE
Visual Basic
Public Const DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSE_MEASUREMENT_DEVICE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSE_MODE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_MODE_NAME Field
MCdicom Structure See Also Send Feedback
Dose Mode Name (0018,11B1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_MODE_NAME
Visual Basic
Public Const DOSE_MODE_NAME As UInteger
Visual C++
public:
literal unsigned int DOSE_MODE_NAME

See Also

MCdicom Structure
MCdicom Members


DOSE_RATE_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_RATE_DELIVERED Field
MCdicom Structure See Also Send Feedback
Dose Rate Delivered (3008,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_RATE_DELIVERED
Visual Basic
Public Const DOSE_RATE_DELIVERED As UInteger
Visual C++
public:
literal unsigned int DOSE_RATE_DELIVERED

See Also

MCdicom Structure
MCdicom Members


DOSE_RATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_RATE_SET Field
MCdicom Structure See Also Send Feedback
Dose Rate Set (300A,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_RATE_SET
Visual Basic
Public Const DOSE_RATE_SET As UInteger
Visual C++
public:
literal unsigned int DOSE_RATE_SET

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Dose Reference Description (300A,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_DESCRIPTION
Visual Basic
Public Const DOSE_REFERENCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Dose Reference Number (300A,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_NUMBER
Visual Basic
Public Const DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_POINT_COORDINATES Field
MCdicom Structure See Also Send Feedback
Dose Reference Point Coordinates (300A,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_POINT_COORDINATES
Visual Basic
Public Const DOSE_REFERENCE_POINT_COORDINATES As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_POINT_COORDINATES

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dose Reference Sequence (300A,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_STRUCTURE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_STRUCTURE_TYPE Field
MCdicom Structure See Also Send Feedback
Dose Reference Structure Type (300A,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_STRUCTURE_TYPE
Visual Basic
Public Const DOSE_REFERENCE_STRUCTURE_TYPE As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_STRUCTURE_TYPE

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_TYPE Field
MCdicom Structure See Also Send Feedback
Dose Reference Type (300A,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_TYPE
Visual Basic
Public Const DOSE_REFERENCE_TYPE As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_TYPE

See Also

MCdicom Structure
MCdicom Members


DOSE_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Dose Reference UID (300A,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_REFERENCE_UID
Visual Basic
Public Const DOSE_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int DOSE_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


DOSE_SUMMATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_SUMMATION_TYPE Field
MCdicom Structure See Also Send Feedback
Dose Summation Type (3004,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_SUMMATION_TYPE
Visual Basic
Public Const DOSE_SUMMATION_TYPE As UInteger
Visual C++
public:
literal unsigned int DOSE_SUMMATION_TYPE

See Also

MCdicom Structure
MCdicom Members


DOSE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_TYPE Field
MCdicom Structure See Also Send Feedback
Dose Type (3004,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_TYPE
Visual Basic
Public Const DOSE_TYPE As UInteger
Visual C++
public:
literal unsigned int DOSE_TYPE

See Also

MCdicom Structure
MCdicom Members


DOSE_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_UNITS Field
MCdicom Structure See Also Send Feedback
Dose Units (3004,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_UNITS
Visual Basic
Public Const DOSE_UNITS As UInteger
Visual C++
public:
literal unsigned int DOSE_UNITS

See Also

MCdicom Structure
MCdicom Members


DOSE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_VALUE Field
MCdicom Structure See Also Send Feedback
Dose Value RETIRED (3004,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_VALUE
Visual Basic
Public Const DOSE_VALUE As UInteger
Visual C++
public:
literal unsigned int DOSE_VALUE

See Also

MCdicom Structure
MCdicom Members


DOSE_VALUE_PURPOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_VALUE_PURPOSE Field
MCdicom Structure See Also Send Feedback
Dose Value Purpose (300A,061D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_VALUE_PURPOSE
Visual Basic
Public Const DOSE_VALUE_PURPOSE As UInteger
Visual C++
public:
literal unsigned int DOSE_VALUE_PURPOSE

See Also

MCdicom Structure
MCdicom Members


DOSE_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Dose Value RETIRED (3004,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_VALUE_RETIRED
Visual Basic
Public Const DOSE_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOSE_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOSE_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSE_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dose Values Sequence (300A,061C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSE_VALUES_SEQUENCE
Visual Basic
Public Const DOSE_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSE_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Evaluation Scope (3010,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_EVALUATION_SCOPE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Parameter Sequence (3010,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_PURPOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_PURPOSE Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Purpose (3010,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_PURPOSE
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_PURPOSE As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_PURPOSE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Sequence (3010,006C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_SEQUENCE
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Type Code Sequence (3010,006D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_UID Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective UID (3010,006E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_UID
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_UID As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_UID

See Also

MCdicom Structure
MCdicom Members


DOSIMETRIC_OBJECTIVE_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOSIMETRIC_OBJECTIVE_WEIGHT Field
MCdicom Structure See Also Send Feedback
Dosimetric Objective Weight (3010,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOSIMETRIC_OBJECTIVE_WEIGHT
Visual Basic
Public Const DOSIMETRIC_OBJECTIVE_WEIGHT As UInteger
Visual C++
public:
literal unsigned int DOSIMETRIC_OBJECTIVE_WEIGHT

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_FIELD_DELTA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_FIELD_DELTA Field
MCdicom Structure See Also Send Feedback
Double Exposure Field Delta (0074,133A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_FIELD_DELTA
Visual Basic
Public Const DOUBLE_EXPOSURE_FIELD_DELTA As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_FIELD_DELTA

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Double Exposure Field Delta (Trial) RETIRED (0074,103A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED
Visual Basic
Public Const DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_FIELD_DELTA_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_FLAG Field
MCdicom Structure See Also Send Feedback
Double Exposure Flag (0074,1034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_FLAG
Visual Basic
Public Const DOUBLE_EXPOSURE_FLAG As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_FLAG

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_METERSET Field
MCdicom Structure See Also Send Feedback
Double Exposure Meterset (0074,1338)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_METERSET
Visual Basic
Public Const DOUBLE_EXPOSURE_METERSET As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_METERSET

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Double Exposure Meterset (Trial) RETIRED (0074,1038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED
Visual Basic
Public Const DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_METERSET_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


DOUBLE_EXPOSURE_ORDERING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_EXPOSURE_ORDERING Field
MCdicom Structure See Also Send Feedback
Double Exposure Ordering (0074,1036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_EXPOSURE_ORDERING
Visual Basic
Public Const DOUBLE_EXPOSURE_ORDERING As UInteger
Visual C++
public:
literal unsigned int DOUBLE_EXPOSURE_ORDERING

See Also

MCdicom Structure
MCdicom Members


DOUBLE_FLOAT_PIXEL_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_FLOAT_PIXEL_DATA Field
MCdicom Structure See Also Send Feedback
Double Float Pixel Data (7FE0,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_FLOAT_PIXEL_DATA
Visual Basic
Public Const DOUBLE_FLOAT_PIXEL_DATA As UInteger
Visual C++
public:
literal unsigned int DOUBLE_FLOAT_PIXEL_DATA

See Also

MCdicom Structure
MCdicom Members


DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT Field
MCdicom Structure See Also Send Feedback
Double Float Pixel Padding Range Limit (0028,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT
Visual Basic
Public Const DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT As UInteger
Visual C++
public:
literal unsigned int DOUBLE_FLOAT_PIXEL_PADDING_RANGE_LIMIT

See Also

MCdicom Structure
MCdicom Members


DOUBLE_FLOAT_PIXEL_PADDING_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_FLOAT_PIXEL_PADDING_VALUE Field
MCdicom Structure See Also Send Feedback
Double Float Pixel Padding Value (0028,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_FLOAT_PIXEL_PADDING_VALUE
Visual Basic
Public Const DOUBLE_FLOAT_PIXEL_PADDING_VALUE As UInteger
Visual C++
public:
literal unsigned int DOUBLE_FLOAT_PIXEL_PADDING_VALUE

See Also

MCdicom Structure
MCdicom Members


DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Double Float Real World Value First Value Mapped (0040,9214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED
Visual Basic
Public Const DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int DOUBLE_FLOAT_REAL_WORLD_VALUE_FIRST_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Double Float Real World Value Last Value Mapped (0040,9213)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED
Visual Basic
Public Const DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int DOUBLE_FLOAT_REAL_WORLD_VALUE_LAST_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


DOUBLE_POINT_COORDINATES_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DOUBLE_POINT_COORDINATES_DATA Field
MCdicom Structure See Also Send Feedback
Double Point Coordinates Data (0066,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DOUBLE_POINT_COORDINATES_DATA
Visual Basic
Public Const DOUBLE_POINT_COORDINATES_DATA As UInteger
Visual C++
public:
literal unsigned int DOUBLE_POINT_COORDINATES_DATA

See Also

MCdicom Structure
MCdicom Members


DVH_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_DATA Field
MCdicom Structure See Also Send Feedback
DVH Data (3004,0058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_DATA
Visual Basic
Public Const DVH_DATA As UInteger
Visual C++
public:
literal unsigned int DVH_DATA

See Also

MCdicom Structure
MCdicom Members


DVH_DOSE_SCALING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_DOSE_SCALING Field
MCdicom Structure See Also Send Feedback
DVH Dose Scaling (3004,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_DOSE_SCALING
Visual Basic
Public Const DVH_DOSE_SCALING As UInteger
Visual C++
public:
literal unsigned int DVH_DOSE_SCALING

See Also

MCdicom Structure
MCdicom Members


DVH_MAXIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_MAXIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
DVH Maximum Dose (3004,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_MAXIMUM_DOSE
Visual Basic
Public Const DVH_MAXIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int DVH_MAXIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


DVH_MEAN_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_MEAN_DOSE Field
MCdicom Structure See Also Send Feedback
DVH Mean Dose (3004,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_MEAN_DOSE
Visual Basic
Public Const DVH_MEAN_DOSE As UInteger
Visual C++
public:
literal unsigned int DVH_MEAN_DOSE

See Also

MCdicom Structure
MCdicom Members


DVH_MINIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_MINIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
DVH Minimum Dose (3004,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_MINIMUM_DOSE
Visual Basic
Public Const DVH_MINIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int DVH_MINIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


DVH_NORMALIZATION_DOSE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_NORMALIZATION_DOSE_VALUE Field
MCdicom Structure See Also Send Feedback
DVH Normalization Dose Value (3004,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_NORMALIZATION_DOSE_VALUE
Visual Basic
Public Const DVH_NORMALIZATION_DOSE_VALUE As UInteger
Visual C++
public:
literal unsigned int DVH_NORMALIZATION_DOSE_VALUE

See Also

MCdicom Structure
MCdicom Members


DVH_NORMALIZATION_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_NORMALIZATION_POINT Field
MCdicom Structure See Also Send Feedback
DVH Normalization Point (3004,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_NORMALIZATION_POINT
Visual Basic
Public Const DVH_NORMALIZATION_POINT As UInteger
Visual C++
public:
literal unsigned int DVH_NORMALIZATION_POINT

See Also

MCdicom Structure
MCdicom Members


DVH_NUMBER_OF_BINS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_NUMBER_OF_BINS Field
MCdicom Structure See Also Send Feedback
DVH Number of Bins (3004,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_NUMBER_OF_BINS
Visual Basic
Public Const DVH_NUMBER_OF_BINS As UInteger
Visual C++
public:
literal unsigned int DVH_NUMBER_OF_BINS

See Also

MCdicom Structure
MCdicom Members


DVH_REFERENCED_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_REFERENCED_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DVH Referenced ROI Sequence (3004,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_REFERENCED_ROI_SEQUENCE
Visual Basic
Public Const DVH_REFERENCED_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DVH_REFERENCED_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DVH_ROI_CONTRIBUTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_ROI_CONTRIBUTION_TYPE Field
MCdicom Structure See Also Send Feedback
DVH ROI Contribution Type (3004,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_ROI_CONTRIBUTION_TYPE
Visual Basic
Public Const DVH_ROI_CONTRIBUTION_TYPE As UInteger
Visual C++
public:
literal unsigned int DVH_ROI_CONTRIBUTION_TYPE

See Also

MCdicom Structure
MCdicom Members


DVH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
DVH Sequence (3004,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_SEQUENCE
Visual Basic
Public Const DVH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int DVH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


DVH_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_TYPE Field
MCdicom Structure See Also Send Feedback
DVH Type (3004,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_TYPE
Visual Basic
Public Const DVH_TYPE As UInteger
Visual C++
public:
literal unsigned int DVH_TYPE

See Also

MCdicom Structure
MCdicom Members


DVH_VOLUME_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DVH_VOLUME_UNITS Field
MCdicom Structure See Also Send Feedback
DVH Volume Units (3004,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DVH_VOLUME_UNITS
Visual Basic
Public Const DVH_VOLUME_UNITS As UInteger
Visual C++
public:
literal unsigned int DVH_VOLUME_UNITS

See Also

MCdicom Structure
MCdicom Members


DYNAMIC_RANGE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..DYNAMIC_RANGE_RETIRED Field
MCdicom Structure See Also Send Feedback
Dynamic Range RETIRED (0018,5030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint DYNAMIC_RANGE_RETIRED
Visual Basic
Public Const DYNAMIC_RANGE_RETIRED As UInteger
Visual C++
public:
literal unsigned int DYNAMIC_RANGE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ECHO_NUMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_NUMBERS Field
MCdicom Structure See Also Send Feedback
Echo Number(s) (0018,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_NUMBERS
Visual Basic
Public Const ECHO_NUMBERS As UInteger
Visual C++
public:
literal unsigned int ECHO_NUMBERS

See Also

MCdicom Structure
MCdicom Members


ECHO_PEAK_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_PEAK_POSITION Field
MCdicom Structure See Also Send Feedback
Echo Peak Position (0018,9298)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_PEAK_POSITION
Visual Basic
Public Const ECHO_PEAK_POSITION As UInteger
Visual C++
public:
literal unsigned int ECHO_PEAK_POSITION

See Also

MCdicom Structure
MCdicom Members


ECHO_PLANAR_PULSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_PLANAR_PULSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Echo Planar Pulse Sequence (0018,9018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_PLANAR_PULSE_SEQUENCE
Visual Basic
Public Const ECHO_PLANAR_PULSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ECHO_PLANAR_PULSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ECHO_PULSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_PULSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Echo Pulse Sequence (0018,9008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_PULSE_SEQUENCE
Visual Basic
Public Const ECHO_PULSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ECHO_PULSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ECHO_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_TIME Field
MCdicom Structure See Also Send Feedback
Echo Time (0018,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_TIME
Visual Basic
Public Const ECHO_TIME As UInteger
Visual C++
public:
literal unsigned int ECHO_TIME

See Also

MCdicom Structure
MCdicom Members


ECHO_TRAIN_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ECHO_TRAIN_LENGTH Field
MCdicom Structure See Also Send Feedback
Echo Train Length (0018,0091)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ECHO_TRAIN_LENGTH
Visual Basic
Public Const ECHO_TRAIN_LENGTH As UInteger
Visual C++
public:
literal unsigned int ECHO_TRAIN_LENGTH

See Also

MCdicom Structure
MCdicom Members


EDGE_POINT_INDEX_LIST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EDGE_POINT_INDEX_LIST_RETIRED Field
MCdicom Structure See Also Send Feedback
Edge Point Index List RETIRED (0066,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EDGE_POINT_INDEX_LIST_RETIRED
Visual Basic
Public Const EDGE_POINT_INDEX_LIST_RETIRED As UInteger
Visual C++
public:
literal unsigned int EDGE_POINT_INDEX_LIST_RETIRED

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_BIN_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_BIN_ENERGY Field
MCdicom Structure See Also Send Feedback
Effective Bin Energy (0018,936E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_BIN_ENERGY
Visual Basic
Public Const EFFECTIVE_BIN_ENERGY As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_BIN_ENERGY

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_DATETIME Field
MCdicom Structure See Also Send Feedback
Effective DateTime (0068,6226)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_DATETIME
Visual Basic
Public Const EFFECTIVE_DATETIME As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_DATETIME

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Effective Dose Calculation Method Category Code Sequence (3010,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Effective Dose Calculation Method Code Sequence (3010,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_DOSE_CALCULATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Effective Dose Calculation Method Description (3010,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION
Visual Basic
Public Const EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_DOSE_CALCULATION_METHOD_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_DURATION Field
MCdicom Structure See Also Send Feedback
Effective Duration (0018,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_DURATION
Visual Basic
Public Const EFFECTIVE_DURATION As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_DURATION

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_ECHO_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_ECHO_TIME Field
MCdicom Structure See Also Send Feedback
Effective Echo Time (0018,9082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_ECHO_TIME
Visual Basic
Public Const EFFECTIVE_ECHO_TIME As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_ECHO_TIME

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_REFRACTIVE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_REFRACTIVE_INDEX Field
MCdicom Structure See Also Send Feedback
Effective Refractive Index (0052,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_REFRACTIVE_INDEX
Visual Basic
Public Const EFFECTIVE_REFRACTIVE_INDEX As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_REFRACTIVE_INDEX

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_SERIES_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_SERIES_DURATION Field
MCdicom Structure See Also Send Feedback
Alias for tag EFFECTIVE_DURATION (0018,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_SERIES_DURATION
Visual Basic
Public Const EFFECTIVE_SERIES_DURATION As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_SERIES_DURATION

See Also

MCdicom Structure
MCdicom Members


EFFECTIVE_WEDGE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EFFECTIVE_WEDGE_ANGLE Field
MCdicom Structure See Also Send Feedback
Effective Wedge Angle (300A,00DE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EFFECTIVE_WEDGE_ANGLE
Visual Basic
Public Const EFFECTIVE_WEDGE_ANGLE As UInteger
Visual C++
public:
literal unsigned int EFFECTIVE_WEDGE_ANGLE

See Also

MCdicom Structure
MCdicom Members


ELEMENT_DIMENSION_A Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ELEMENT_DIMENSION_A Field
MCdicom Structure See Also Send Feedback
Element Dimension A (0014,4014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ELEMENT_DIMENSION_A
Visual Basic
Public Const ELEMENT_DIMENSION_A As UInteger
Visual C++
public:
literal unsigned int ELEMENT_DIMENSION_A

See Also

MCdicom Structure
MCdicom Members


ELEMENT_DIMENSION_B Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ELEMENT_DIMENSION_B Field
MCdicom Structure See Also Send Feedback
Element Dimension B (0014,4015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ELEMENT_DIMENSION_B
Visual Basic
Public Const ELEMENT_DIMENSION_B As UInteger
Visual C++
public:
literal unsigned int ELEMENT_DIMENSION_B

See Also

MCdicom Structure
MCdicom Members


ELEMENT_PITCH_A Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ELEMENT_PITCH_A Field
MCdicom Structure See Also Send Feedback
Element Pitch A (0014,4016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ELEMENT_PITCH_A
Visual Basic
Public Const ELEMENT_PITCH_A As UInteger
Visual C++
public:
literal unsigned int ELEMENT_PITCH_A

See Also

MCdicom Structure
MCdicom Members


ELEMENT_PITCH_B Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ELEMENT_PITCH_B Field
MCdicom Structure See Also Send Feedback
Element Pitch B (0014,401D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ELEMENT_PITCH_B
Visual Basic
Public Const ELEMENT_PITCH_B As UInteger
Visual C++
public:
literal unsigned int ELEMENT_PITCH_B

See Also

MCdicom Structure
MCdicom Members


ELEMENT_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ELEMENT_SHAPE Field
MCdicom Structure See Also Send Feedback
Element Shape (0014,4013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ELEMENT_SHAPE
Visual Basic
Public Const ELEMENT_SHAPE As UInteger
Visual C++
public:
literal unsigned int ELEMENT_SHAPE

See Also

MCdicom Structure
MCdicom Members


EMITTER_COLOR_TEMPERATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EMITTER_COLOR_TEMPERATURE Field
MCdicom Structure See Also Send Feedback
Emitter Color Temperature (0016,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EMITTER_COLOR_TEMPERATURE
Visual Basic
Public Const EMITTER_COLOR_TEMPERATURE As UInteger
Visual C++
public:
literal unsigned int EMITTER_COLOR_TEMPERATURE

See Also

MCdicom Structure
MCdicom Members


EMMETROPIC_MAGNIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EMMETROPIC_MAGNIFICATION Field
MCdicom Structure See Also Send Feedback
Emmetropic Magnification (0022,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EMMETROPIC_MAGNIFICATION
Visual Basic
Public Const EMMETROPIC_MAGNIFICATION As UInteger
Visual C++
public:
literal unsigned int EMMETROPIC_MAGNIFICATION

See Also

MCdicom Structure
MCdicom Members


EMPTY_IMAGE_BOX_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EMPTY_IMAGE_BOX_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Empty Image Box CIELab Value (0072,0421)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EMPTY_IMAGE_BOX_CIELAB_VALUE
Visual Basic
Public Const EMPTY_IMAGE_BOX_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int EMPTY_IMAGE_BOX_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


EMPTY_IMAGE_DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EMPTY_IMAGE_DENSITY Field
MCdicom Structure See Also Send Feedback
Empty Image Density (2010,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EMPTY_IMAGE_DENSITY
Visual Basic
Public Const EMPTY_IMAGE_DENSITY As UInteger
Visual C++
public:
literal unsigned int EMPTY_IMAGE_DENSITY

See Also

MCdicom Structure
MCdicom Members


EMPTY_VALUE_MATCHING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EMPTY_VALUE_MATCHING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Empty Value Matching Sequence (0008,0412)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EMPTY_VALUE_MATCHING_SEQUENCE
Visual Basic
Public Const EMPTY_VALUE_MATCHING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EMPTY_VALUE_MATCHING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENCAPSULATED_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCAPSULATED_DOCUMENT Field
MCdicom Structure See Also Send Feedback
Encapsulated Document (0042,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCAPSULATED_DOCUMENT
Visual Basic
Public Const ENCAPSULATED_DOCUMENT As UInteger
Visual C++
public:
literal unsigned int ENCAPSULATED_DOCUMENT

See Also

MCdicom Structure
MCdicom Members


ENCAPSULATED_DOCUMENT_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCAPSULATED_DOCUMENT_LENGTH Field
MCdicom Structure See Also Send Feedback
Encapsulated Document Length (0042,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCAPSULATED_DOCUMENT_LENGTH
Visual Basic
Public Const ENCAPSULATED_DOCUMENT_LENGTH As UInteger
Visual C++
public:
literal unsigned int ENCAPSULATED_DOCUMENT_LENGTH

See Also

MCdicom Structure
MCdicom Members


ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH Field
MCdicom Structure See Also Send Feedback
Encapsulated Pixel Data Value Total Length (7FE0,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH
Visual Basic
Public Const ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH As UInteger
Visual C++
public:
literal unsigned int ENCAPSULATED_PIXEL_DATA_VALUE_TOTAL_LENGTH

See Also

MCdicom Structure
MCdicom Members


ENCRYPTED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCRYPTED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Encrypted Attributes Sequence (0400,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCRYPTED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const ENCRYPTED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENCRYPTED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENCRYPTED_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCRYPTED_CONTENT Field
MCdicom Structure See Also Send Feedback
Encrypted Content (0400,0520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCRYPTED_CONTENT
Visual Basic
Public Const ENCRYPTED_CONTENT As UInteger
Visual C++
public:
literal unsigned int ENCRYPTED_CONTENT

See Also

MCdicom Structure
MCdicom Members


ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
Encrypted Content Transfer Syntax UID (0400,0510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID
Visual Basic
Public Const ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int ENCRYPTED_CONTENT_TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


END_ACQUISITION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..END_ACQUISITION_DATETIME Field
MCdicom Structure See Also Send Feedback
End Acquisition DateTime (0018,9517)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint END_ACQUISITION_DATETIME
Visual Basic
Public Const END_ACQUISITION_DATETIME As UInteger
Visual C++
public:
literal unsigned int END_ACQUISITION_DATETIME

See Also

MCdicom Structure
MCdicom Members


END_CUMULATIVE_METERSET_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..END_CUMULATIVE_METERSET_WEIGHT Field
MCdicom Structure See Also Send Feedback
End Cumulative Meterset Weight (300C,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint END_CUMULATIVE_METERSET_WEIGHT
Visual Basic
Public Const END_CUMULATIVE_METERSET_WEIGHT As UInteger
Visual C++
public:
literal unsigned int END_CUMULATIVE_METERSET_WEIGHT

See Also

MCdicom Structure
MCdicom Members


END_CUMULATIVE_TIME_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..END_CUMULATIVE_TIME_WEIGHT Field
MCdicom Structure See Also Send Feedback
End Cumulative Time Weight (0074,1408)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint END_CUMULATIVE_TIME_WEIGHT
Visual Basic
Public Const END_CUMULATIVE_TIME_WEIGHT As UInteger
Visual C++
public:
literal unsigned int END_CUMULATIVE_TIME_WEIGHT

See Also

MCdicom Structure
MCdicom Members


END_MESSAGE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..END_MESSAGE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
End Message ID RETIRED (0000,5020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint END_MESSAGE_ID_RETIRED
Visual Basic
Public Const END_MESSAGE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int END_MESSAGE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


END_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..END_METERSET Field
MCdicom Structure See Also Send Feedback
End Meterset (3008,007A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint END_METERSET
Visual Basic
Public Const END_METERSET As UInteger
Visual C++
public:
literal unsigned int END_METERSET

See Also

MCdicom Structure
MCdicom Members


ENDING_RESPIRATORY_AMPLITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENDING_RESPIRATORY_AMPLITUDE Field
MCdicom Structure See Also Send Feedback
Ending Respiratory Amplitude (0020,9248)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENDING_RESPIRATORY_AMPLITUDE
Visual Basic
Public Const ENDING_RESPIRATORY_AMPLITUDE As UInteger
Visual C++
public:
literal unsigned int ENDING_RESPIRATORY_AMPLITUDE

See Also

MCdicom Structure
MCdicom Members


ENDING_RESPIRATORY_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENDING_RESPIRATORY_PHASE Field
MCdicom Structure See Also Send Feedback
Ending Respiratory Phase (0020,9249)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENDING_RESPIRATORY_PHASE
Visual Basic
Public Const ENDING_RESPIRATORY_PHASE As UInteger
Visual C++
public:
literal unsigned int ENDING_RESPIRATORY_PHASE

See Also

MCdicom Structure
MCdicom Members


ENERGY_DERIVATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_DERIVATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Energy Derivation Code Sequence (3002,0133)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_DERIVATION_CODE_SEQUENCE
Visual Basic
Public Const ENERGY_DERIVATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENERGY_DERIVATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENERGY_UNIT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_UNIT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Energy Unit Code Sequence (300A,0684)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_UNIT_CODE_SEQUENCE
Visual Basic
Public Const ENERGY_UNIT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENERGY_UNIT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENERGY_WEIGHTING_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WEIGHTING_FACTOR Field
MCdicom Structure See Also Send Feedback
Energy Weighting Factor (0018,9353)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WEIGHTING_FACTOR
Visual Basic
Public Const ENERGY_WEIGHTING_FACTOR As UInteger
Visual C++
public:
literal unsigned int ENERGY_WEIGHTING_FACTOR

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_CENTERLINE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_CENTERLINE_RETIRED Field
MCdicom Structure See Also Send Feedback
Energy Window Centerline RETIRED (0018,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_CENTERLINE_RETIRED
Visual Basic
Public Const ENERGY_WINDOW_CENTERLINE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_CENTERLINE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Energy Window Information Sequence (0054,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_INFORMATION_SEQUENCE
Visual Basic
Public Const ENERGY_WINDOW_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_LOWER_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_LOWER_LIMIT Field
MCdicom Structure See Also Send Feedback
Energy Window Lower Limit (0054,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_LOWER_LIMIT
Visual Basic
Public Const ENERGY_WINDOW_LOWER_LIMIT As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_LOWER_LIMIT

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_NAME Field
MCdicom Structure See Also Send Feedback
Energy Window Name (0054,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_NAME
Visual Basic
Public Const ENERGY_WINDOW_NAME As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_NAME

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_NUMBER Field
MCdicom Structure See Also Send Feedback
Energy Window Number (0054,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_NUMBER
Visual Basic
Public Const ENERGY_WINDOW_NUMBER As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_NUMBER

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_RANGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_RANGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Energy Window Range Sequence (0054,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_RANGE_SEQUENCE
Visual Basic
Public Const ENERGY_WINDOW_RANGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_RANGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_TOTAL_WIDTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_TOTAL_WIDTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Energy Window Total Width RETIRED (0018,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_TOTAL_WIDTH_RETIRED
Visual Basic
Public Const ENERGY_WINDOW_TOTAL_WIDTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_TOTAL_WIDTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_UPPER_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_UPPER_LIMIT Field
MCdicom Structure See Also Send Feedback
Energy Window Upper Limit (0054,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_UPPER_LIMIT
Visual Basic
Public Const ENERGY_WINDOW_UPPER_LIMIT As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_UPPER_LIMIT

See Also

MCdicom Structure
MCdicom Members


ENERGY_WINDOW_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENERGY_WINDOW_VECTOR Field
MCdicom Structure See Also Send Feedback
Energy Window Vector (0054,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENERGY_WINDOW_VECTOR
Visual Basic
Public Const ENERGY_WINDOW_VECTOR As UInteger
Visual C++
public:
literal unsigned int ENERGY_WINDOW_VECTOR

See Also

MCdicom Structure
MCdicom Members


ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Enhanced Palette Color Lookup Table Sequence (0028,140B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE
Visual Basic
Public Const ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENHANCED_PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG Field
MCdicom Structure See Also Send Feedback
Enhanced RT Beam Limiting Device Definition Flag (3008,00A3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG
Visual Basic
Public Const ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG As UInteger
Visual C++
public:
literal unsigned int ENHANCED_RT_BEAM_LIMITING_DEVICE_DEFINITION_FLAG

See Also

MCdicom Structure
MCdicom Members


ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Enhanced RT Beam Limiting Device Sequence (3008,00A1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE
Visual Basic
Public Const ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENHANCED_RT_BEAM_LIMITING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Enhanced RT Beam Limiting Opening Sequence (3008,00A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE
Visual Basic
Public Const ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ENHANCED_RT_BEAM_LIMITING_OPENING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ENTITY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTITY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Entity Description (3010,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTITY_DESCRIPTION
Visual Basic
Public Const ENTITY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ENTITY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ENTITY_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTITY_LABEL Field
MCdicom Structure See Also Send Feedback
Entity Label (3010,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTITY_LABEL
Visual Basic
Public Const ENTITY_LABEL As UInteger
Visual C++
public:
literal unsigned int ENTITY_LABEL

See Also

MCdicom Structure
MCdicom Members


ENTITY_LONG_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTITY_LONG_LABEL Field
MCdicom Structure See Also Send Feedback
Entity Long Label (3010,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTITY_LONG_LABEL
Visual Basic
Public Const ENTITY_LONG_LABEL As UInteger
Visual C++
public:
literal unsigned int ENTITY_LONG_LABEL

See Also

MCdicom Structure
MCdicom Members


ENTITY_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTITY_NAME Field
MCdicom Structure See Also Send Feedback
Entity Name (3010,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTITY_NAME
Visual Basic
Public Const ENTITY_NAME As UInteger
Visual C++
public:
literal unsigned int ENTITY_NAME

See Also

MCdicom Structure
MCdicom Members


ENTRANCE_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTRANCE_DOSE Field
MCdicom Structure See Also Send Feedback
Entrance Dose (0040,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTRANCE_DOSE
Visual Basic
Public Const ENTRANCE_DOSE As UInteger
Visual C++
public:
literal unsigned int ENTRANCE_DOSE

See Also

MCdicom Structure
MCdicom Members


ENTRANCE_DOSE_DERIVATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTRANCE_DOSE_DERIVATION Field
MCdicom Structure See Also Send Feedback
Entrance Dose Derivation (0040,8303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTRANCE_DOSE_DERIVATION
Visual Basic
Public Const ENTRANCE_DOSE_DERIVATION As UInteger
Visual C++
public:
literal unsigned int ENTRANCE_DOSE_DERIVATION

See Also

MCdicom Structure
MCdicom Members


ENTRANCE_DOSE_IN_MGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENTRANCE_DOSE_IN_MGY Field
MCdicom Structure See Also Send Feedback
Entrance Dose in mGy (0040,8302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENTRANCE_DOSE_IN_MGY
Visual Basic
Public Const ENTRANCE_DOSE_IN_MGY As UInteger
Visual C++
public:
literal unsigned int ENTRANCE_DOSE_IN_MGY

See Also

MCdicom Structure
MCdicom Members


ENVIRONMENTAL_CONDITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ENVIRONMENTAL_CONDITIONS Field
MCdicom Structure See Also Send Feedback
Environmental Conditions (0014,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ENVIRONMENTAL_CONDITIONS
Visual Basic
Public Const ENVIRONMENTAL_CONDITIONS As UInteger
Visual C++
public:
literal unsigned int ENVIRONMENTAL_CONDITIONS

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_ADMINISTRATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_ADMINISTRATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equipment Administrator Sequence (0028,7000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_ADMINISTRATOR_SEQUENCE
Visual Basic
Public Const EQUIPMENT_ADMINISTRATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_ADMINISTRATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION Field
MCdicom Structure See Also Send Feedback
Equipment Coordinate System Identification (0028,9537)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION
Visual Basic
Public Const EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_COORDINATE_SYSTEM_IDENTIFICATION

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Equipment Frame of Reference Description (300A,0676)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION
Visual Basic
Public Const EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_FRAME_OF_REFERENCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Equipment Frame of Reference UID (300A,0675)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const EQUIPMENT_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_MODALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_MODALITY Field
MCdicom Structure See Also Send Feedback
Equipment Modality (0008,0221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_MODALITY
Visual Basic
Public Const EQUIPMENT_MODALITY As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_MODALITY

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equipment Reference Point Code Sequence (300A,0678)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE
Visual Basic
Public Const EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_REFERENCE_POINT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equipment Reference Point Coordinates Sequence (300A,0677)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE
Visual Basic
Public Const EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIPMENT_REFERENCE_POINT_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Equivalent CDA Document Sequence RETIRED (0040,A090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED
Visual Basic
Public Const EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int EQUIVALENT_CDA_DOCUMENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


EQUIVALENT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIVALENT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equivalent Code Sequence (0008,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIVALENT_CODE_SEQUENCE
Visual Basic
Public Const EQUIVALENT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIVALENT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equivalent Conceptual Volume Instance Reference Sequence (3010,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE
Visual Basic
Public Const EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIVALENT_CONCEPTUAL_VOLUME_INSTANCE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Equivalent Conceptual Volumes Sequence (3010,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE
Visual Basic
Public Const EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EQUIVALENT_CONCEPTUAL_VOLUMES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EQUIVALENT_PUPIL_RADIUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EQUIVALENT_PUPIL_RADIUS Field
MCdicom Structure See Also Send Feedback
Equivalent Pupil Radius (0046,0205)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EQUIVALENT_PUPIL_RADIUS
Visual Basic
Public Const EQUIVALENT_PUPIL_RADIUS As UInteger
Visual C++
public:
literal unsigned int EQUIVALENT_PUPIL_RADIUS

See Also

MCdicom Structure
MCdicom Members


ERASE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ERASE_RETIRED Field
MCdicom Structure See Also Send Feedback
Erase RETIRED (0000,5190)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ERASE_RETIRED
Visual Basic
Public Const ERASE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ERASE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ERROR_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ERROR_COMMENT Field
MCdicom Structure See Also Send Feedback
Error Comment (0000,0902)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ERROR_COMMENT
Visual Basic
Public Const ERROR_COMMENT As UInteger
Visual C++
public:
literal unsigned int ERROR_COMMENT

See Also

MCdicom Structure
MCdicom Members


ERROR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ERROR_ID Field
MCdicom Structure See Also Send Feedback
Error ID (0000,0903)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ERROR_ID
Visual Basic
Public Const ERROR_ID As UInteger
Visual C++
public:
literal unsigned int ERROR_ID

See Also

MCdicom Structure
MCdicom Members


ESTIMATED_DOSE_SAVING_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ESTIMATED_DOSE_SAVING_RETIRED Field
MCdicom Structure See Also Send Feedback
Estimated Dose Saving RETIRED (0018,9324)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ESTIMATED_DOSE_SAVING_RETIRED
Visual Basic
Public Const ESTIMATED_DOSE_SAVING_RETIRED As UInteger
Visual C++
public:
literal unsigned int ESTIMATED_DOSE_SAVING_RETIRED

See Also

MCdicom Structure
MCdicom Members


ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR Field
MCdicom Structure See Also Send Feedback
Estimated Radiographic Magnification Factor (0018,1114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR
Visual Basic
Public Const ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR As UInteger
Visual C++
public:
literal unsigned int ESTIMATED_RADIOGRAPHIC_MAGNIFICATION_FACTOR

See Also

MCdicom Structure
MCdicom Members


ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE Field
MCdicom Structure See Also Send Feedback
Ethics Committee Approval Effectiveness End Date (0012,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE
Visual Basic
Public Const ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE As UInteger
Visual C++
public:
literal unsigned int ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_END_DATE

See Also

MCdicom Structure
MCdicom Members


ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE Field
MCdicom Structure See Also Send Feedback
Ethics Committee Approval Effectiveness Start Date (0012,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE
Visual Basic
Public Const ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE As UInteger
Visual C++
public:
literal unsigned int ETHICS_COMMITTEE_APPROVAL_EFFECTIVENESS_START_DATE

See Also

MCdicom Structure
MCdicom Members


ETHNIC_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ETHNIC_GROUP Field
MCdicom Structure See Also Send Feedback
Ethnic Group (0010,2160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ETHNIC_GROUP
Visual Basic
Public Const ETHNIC_GROUP As UInteger
Visual C++
public:
literal unsigned int ETHNIC_GROUP

See Also

MCdicom Structure
MCdicom Members


EVALUATION_ATTEMPT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVALUATION_ATTEMPT Field
MCdicom Structure See Also Send Feedback
Evaluation Attempt (0014,2008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVALUATION_ATTEMPT
Visual Basic
Public Const EVALUATION_ATTEMPT As UInteger
Visual C++
public:
literal unsigned int EVALUATION_ATTEMPT

See Also

MCdicom Structure
MCdicom Members


EVALUATOR_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVALUATOR_NAME Field
MCdicom Structure See Also Send Feedback
Evaluator Name (0014,2006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVALUATOR_NAME
Visual Basic
Public Const EVALUATOR_NAME As UInteger
Visual C++
public:
literal unsigned int EVALUATOR_NAME

See Also

MCdicom Structure
MCdicom Members


EVALUATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVALUATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Evaluator Number (0014,2004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVALUATOR_NUMBER
Visual Basic
Public Const EVALUATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int EVALUATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


EVALUATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVALUATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Evaluator Sequence (0014,2002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVALUATOR_SEQUENCE
Visual Basic
Public Const EVALUATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EVALUATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EVENT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Event Code Sequence (0008,2135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_CODE_SEQUENCE
Visual Basic
Public Const EVENT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EVENT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EVENT_ELAPSED_TIMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_ELAPSED_TIMES Field
MCdicom Structure See Also Send Feedback
Event Elapsed Time(s) (0008,2130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_ELAPSED_TIMES
Visual Basic
Public Const EVENT_ELAPSED_TIMES As UInteger
Visual C++
public:
literal unsigned int EVENT_ELAPSED_TIMES

See Also

MCdicom Structure
MCdicom Members


EVENT_TIME_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_TIME_OFFSET Field
MCdicom Structure See Also Send Feedback
Event Time Offset (0008,2134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_TIME_OFFSET
Visual Basic
Public Const EVENT_TIME_OFFSET As UInteger
Visual C++
public:
literal unsigned int EVENT_TIME_OFFSET

See Also

MCdicom Structure
MCdicom Members


EVENT_TIMER_NAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_TIMER_NAMES Field
MCdicom Structure See Also Send Feedback
Event Timer Name(s) (0008,2132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_TIMER_NAMES
Visual Basic
Public Const EVENT_TIMER_NAMES As UInteger
Visual C++
public:
literal unsigned int EVENT_TIMER_NAMES

See Also

MCdicom Structure
MCdicom Members


EVENT_TIMER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_TIMER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Event Timer Sequence (0008,2133)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_TIMER_SEQUENCE
Visual Basic
Public Const EVENT_TIMER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EVENT_TIMER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EVENT_TYPE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EVENT_TYPE_ID Field
MCdicom Structure See Also Send Feedback
Event Type ID (0000,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EVENT_TYPE_ID
Visual Basic
Public Const EVENT_TYPE_ID As UInteger
Visual C++
public:
literal unsigned int EVENT_TYPE_ID

See Also

MCdicom Structure
MCdicom Members


EXAMINED_BODY_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXAMINED_BODY_THICKNESS Field
MCdicom Structure See Also Send Feedback
Examined Body Thickness (0010,9431)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXAMINED_BODY_THICKNESS
Visual Basic
Public Const EXAMINED_BODY_THICKNESS As UInteger
Visual C++
public:
literal unsigned int EXAMINED_BODY_THICKNESS

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FALSE_NEGATIVES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FALSE_NEGATIVES Field
MCdicom Structure See Also Send Feedback
Excessive False Negatives (0024,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FALSE_NEGATIVES
Visual Basic
Public Const EXCESSIVE_FALSE_NEGATIVES As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FALSE_NEGATIVES

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Excessive False Negatives Data Flag (0024,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG
Visual Basic
Public Const EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FALSE_NEGATIVES_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FALSE_POSITIVES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FALSE_POSITIVES Field
MCdicom Structure See Also Send Feedback
Excessive False Positives (0024,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FALSE_POSITIVES
Visual Basic
Public Const EXCESSIVE_FALSE_POSITIVES As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FALSE_POSITIVES

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FALSE_POSITIVES_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FALSE_POSITIVES_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Excessive False Positives Data Flag (0024,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FALSE_POSITIVES_DATA_FLAG
Visual Basic
Public Const EXCESSIVE_FALSE_POSITIVES_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FALSE_POSITIVES_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FIXATION_LOSSES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FIXATION_LOSSES Field
MCdicom Structure See Also Send Feedback
Excessive Fixation Losses (0024,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FIXATION_LOSSES
Visual Basic
Public Const EXCESSIVE_FIXATION_LOSSES As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FIXATION_LOSSES

See Also

MCdicom Structure
MCdicom Members


EXCESSIVE_FIXATION_LOSSES_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCESSIVE_FIXATION_LOSSES_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Excessive Fixation Losses Data Flag (0024,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCESSIVE_FIXATION_LOSSES_DATA_FLAG
Visual Basic
Public Const EXCESSIVE_FIXATION_LOSSES_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int EXCESSIVE_FIXATION_LOSSES_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


EXCITATION_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_ENERGY Field
MCdicom Structure See Also Send Feedback
Excitation Energy (0018,9823)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_ENERGY
Visual Basic
Public Const EXCITATION_ENERGY As UInteger
Visual C++
public:
literal unsigned int EXCITATION_ENERGY

See Also

MCdicom Structure
MCdicom Members


EXCITATION_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Excitation Frequency (0014,4024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_FREQUENCY
Visual Basic
Public Const EXCITATION_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int EXCITATION_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


EXCITATION_PULSE_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_PULSE_DURATION Field
MCdicom Structure See Also Send Feedback
Excitation Pulse Duration (0018,9824)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_PULSE_DURATION
Visual Basic
Public Const EXCITATION_PULSE_DURATION As UInteger
Visual C++
public:
literal unsigned int EXCITATION_PULSE_DURATION

See Also

MCdicom Structure
MCdicom Members


EXCITATION_SPECTRAL_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_SPECTRAL_WIDTH Field
MCdicom Structure See Also Send Feedback
Excitation Spectral Width (0018,9822)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_SPECTRAL_WIDTH
Visual Basic
Public Const EXCITATION_SPECTRAL_WIDTH As UInteger
Visual C++
public:
literal unsigned int EXCITATION_SPECTRAL_WIDTH

See Also

MCdicom Structure
MCdicom Members


EXCITATION_WAVELENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_WAVELENGTH Field
MCdicom Structure See Also Send Feedback
Excitation Wavelength (0018,9826)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_WAVELENGTH
Visual Basic
Public Const EXCITATION_WAVELENGTH As UInteger
Visual C++
public:
literal unsigned int EXCITATION_WAVELENGTH

See Also

MCdicom Structure
MCdicom Members


EXCITATION_WAVELENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCITATION_WAVELENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Excitation Wavelength Sequence (0018,9825)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCITATION_WAVELENGTH_SEQUENCE
Visual Basic
Public Const EXCITATION_WAVELENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EXCITATION_WAVELENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EXCLUDED_INTERVALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCLUDED_INTERVALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Excluded Intervals Sequence (0018,9803)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCLUDED_INTERVALS_SEQUENCE
Visual Basic
Public Const EXCLUDED_INTERVALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EXCLUDED_INTERVALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EXCLUSION_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCLUSION_DURATION Field
MCdicom Structure See Also Send Feedback
Exclusion Duration (0018,9805)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCLUSION_DURATION
Visual Basic
Public Const EXCLUSION_DURATION As UInteger
Visual C++
public:
literal unsigned int EXCLUSION_DURATION

See Also

MCdicom Structure
MCdicom Members


EXCLUSION_START_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCLUSION_START_DATETIME Field
MCdicom Structure See Also Send Feedback
Exclusion Start DateTime (0018,9804)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCLUSION_START_DATETIME
Visual Basic
Public Const EXCLUSION_START_DATETIME As UInteger
Visual C++
public:
literal unsigned int EXCLUSION_START_DATETIME

See Also

MCdicom Structure
MCdicom Members


EXCLUSIVE_COMPONENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXCLUSIVE_COMPONENT_TYPE Field
MCdicom Structure See Also Send Feedback
Exclusive Component Type (0076,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXCLUSIVE_COMPONENT_TYPE
Visual Basic
Public Const EXCLUSIVE_COMPONENT_TYPE As UInteger
Visual C++
public:
literal unsigned int EXCLUSIVE_COMPONENT_TYPE

See Also

MCdicom Structure
MCdicom Members


EXECUTION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXECUTION_STATUS Field
MCdicom Structure See Also Send Feedback
Execution Status (2100,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXECUTION_STATUS
Visual Basic
Public Const EXECUTION_STATUS As UInteger
Visual C++
public:
literal unsigned int EXECUTION_STATUS

See Also

MCdicom Structure
MCdicom Members


EXECUTION_STATUS_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXECUTION_STATUS_INFO Field
MCdicom Structure See Also Send Feedback
Execution Status Info (2100,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXECUTION_STATUS_INFO
Visual Basic
Public Const EXECUTION_STATUS_INFO As UInteger
Visual C++
public:
literal unsigned int EXECUTION_STATUS_INFO

See Also

MCdicom Structure
MCdicom Members


EXIF_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXIF_VERSION Field
MCdicom Structure See Also Send Feedback
EXIF Version (0016,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXIF_VERSION
Visual Basic
Public Const EXIF_VERSION As UInteger
Visual C++
public:
literal unsigned int EXIF_VERSION

See Also

MCdicom Structure
MCdicom Members


EXPECTED_COMPLETION_DATE_AND_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPECTED_COMPLETION_DATE_AND_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPECTED_COMPLETION_DATE_AND_TIME
Visual Basic
Public Const EXPECTED_COMPLETION_DATE_AND_TIME As UInteger
Visual C++
public:
literal unsigned int EXPECTED_COMPLETION_DATE_AND_TIME

See Also

MCdicom Structure
MCdicom Members


EXPECTED_COMPLETION_DATE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPECTED_COMPLETION_DATE_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag EXPECTED_COMPLETION_DATETIME (0040,4011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPECTED_COMPLETION_DATE_TIME
Visual Basic
Public Const EXPECTED_COMPLETION_DATE_TIME As UInteger
Visual C++
public:
literal unsigned int EXPECTED_COMPLETION_DATE_TIME

See Also

MCdicom Structure
MCdicom Members


EXPECTED_COMPLETION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPECTED_COMPLETION_DATETIME Field
MCdicom Structure See Also Send Feedback
Expected Completion DateTime (0040,4011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPECTED_COMPLETION_DATETIME
Visual Basic
Public Const EXPECTED_COMPLETION_DATETIME As UInteger
Visual C++
public:
literal unsigned int EXPECTED_COMPLETION_DATETIME

See Also

MCdicom Structure
MCdicom Members


EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX Field
MCdicom Structure See Also Send Feedback
Expected In-Vivo Measurement Value Index (300A,0622)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX
Visual Basic
Public Const EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX As UInteger
Visual C++
public:
literal unsigned int EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX

See Also

MCdicom Structure
MCdicom Members


EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Expected In-Vivo Measurement Values Sequence (300A,0621)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE
Visual Basic
Public Const EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EXPECTED_IN_VIVO_MEASUREMENT_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EXPIRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPIRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Expiration DateTime (0008,0416)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPIRATION_DATETIME
Visual Basic
Public Const EXPIRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int EXPIRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


EXPIRY_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPIRY_DATE Field
MCdicom Structure See Also Send Feedback
Expiry Date (0014,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPIRY_DATE
Visual Basic
Public Const EXPIRY_DATE As UInteger
Visual C++
public:
literal unsigned int EXPIRY_DATE

See Also

MCdicom Structure
MCdicom Members


EXPOSED_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSED_AREA Field
MCdicom Structure See Also Send Feedback
Exposed Area (0040,0303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSED_AREA
Visual Basic
Public Const EXPOSED_AREA As UInteger
Visual C++
public:
literal unsigned int EXPOSED_AREA

See Also

MCdicom Structure
MCdicom Members


EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE Field
MCdicom Structure See Also Send Feedback
Exposure (0018,1152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE
Visual Basic
Public Const EXPOSURE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_BIAS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_BIAS_VALUE Field
MCdicom Structure See Also Send Feedback
Exposure Bias Value (0016,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_BIAS_VALUE
Visual Basic
Public Const EXPOSURE_BIAS_VALUE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_BIAS_VALUE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_MODE Field
MCdicom Structure See Also Send Feedback
Exposure Control Mode (0018,7060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_MODE
Visual Basic
Public Const EXPOSURE_CONTROL_MODE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_MODE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_MODE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_MODE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Exposure Control Mode Description (0018,7062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_MODE_DESCRIPTION
Visual Basic
Public Const EXPOSURE_CONTROL_MODE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_MODE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Region Left Vertical Edge (0018,9436)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGION_LEFT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Region Lower Horizontal Edge (0018,9439)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGION_LOWER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Region Right Vertical Edge (0018,9437)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGION_RIGHT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGION_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGION_SHAPE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Region Shape (0018,9435)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGION_SHAPE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGION_SHAPE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGION_SHAPE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Region Upper Horizontal Edge (0018,9438)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGION_UPPER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Exposure Control Sensing Regions Sequence (0018,9434)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE
Visual Basic
Public Const EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_CONTROL_SENSING_REGIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_DOSE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_DOSE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Exposure Dose Sequence RETIRED (0040,030E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_DOSE_SEQUENCE_RETIRED
Visual Basic
Public Const EXPOSURE_DOSE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_DOSE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_IN_MAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_IN_MAS Field
MCdicom Structure See Also Send Feedback
Exposure in mAs (0018,9332)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_IN_MAS
Visual Basic
Public Const EXPOSURE_IN_MAS As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_IN_MAS

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_IN_UAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_IN_UAS Field
MCdicom Structure See Also Send Feedback
Exposure in uAs (0018,1153)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_IN_UAS
Visual Basic
Public Const EXPOSURE_IN_UAS As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_IN_UAS

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_INDEX Field
MCdicom Structure See Also Send Feedback
Exposure Index (0018,1411)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_INDEX
Visual Basic
Public Const EXPOSURE_INDEX As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_INDEX

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_MODE Field
MCdicom Structure See Also Send Feedback
Exposure Mode (0016,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_MODE
Visual Basic
Public Const EXPOSURE_MODE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_MODE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_MODULATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_MODULATION_TYPE Field
MCdicom Structure See Also Send Feedback
Exposure Modulation Type (0018,9323)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_MODULATION_TYPE
Visual Basic
Public Const EXPOSURE_MODULATION_TYPE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_MODULATION_TYPE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_PROGRAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_PROGRAM Field
MCdicom Structure See Also Send Feedback
Exposure Program (0016,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_PROGRAM
Visual Basic
Public Const EXPOSURE_PROGRAM As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_PROGRAM

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Exposure Sequence (3002,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_SEQUENCE
Visual Basic
Public Const EXPOSURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_STATUS Field
MCdicom Structure See Also Send Feedback
Exposure Status (0018,7064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_STATUS
Visual Basic
Public Const EXPOSURE_STATUS As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_STATUS

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_TIME Field
MCdicom Structure See Also Send Feedback
Exposure Time (0018,1150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_TIME
Visual Basic
Public Const EXPOSURE_TIME As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_TIME

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_TIME_IN_MS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_TIME_IN_MS Field
MCdicom Structure See Also Send Feedback
Exposure Time in ms (0018,9328)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_TIME_IN_MS
Visual Basic
Public Const EXPOSURE_TIME_IN_MS As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_TIME_IN_MS

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_TIME_IN_SECONDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_TIME_IN_SECONDS Field
MCdicom Structure See Also Send Feedback
Exposure Time in Seconds (0016,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_TIME_IN_SECONDS
Visual Basic
Public Const EXPOSURE_TIME_IN_SECONDS As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_TIME_IN_SECONDS

See Also

MCdicom Structure
MCdicom Members


EXPOSURE_TIME_IN_US Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURE_TIME_IN_US Field
MCdicom Structure See Also Send Feedback
Exposure Time in uS (0018,8150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURE_TIME_IN_US
Visual Basic
Public Const EXPOSURE_TIME_IN_US As UInteger
Visual C++
public:
literal unsigned int EXPOSURE_TIME_IN_US

See Also

MCdicom Structure
MCdicom Members


EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Exposures on Detector Since Last Calibration (0018,7010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION
Visual Basic
Public Const EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int EXPOSURES_ON_DETECTOR_SINCE_LAST_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED Field
MCdicom Structure See Also Send Feedback
Exposures on Detector Since Manufactured (0018,7011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED
Visual Basic
Public Const EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED As UInteger
Visual C++
public:
literal unsigned int EXPOSURES_ON_DETECTOR_SINCE_MANUFACTURED

See Also

MCdicom Structure
MCdicom Members


EXPOSURES_ON_PLATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXPOSURES_ON_PLATE Field
MCdicom Structure See Also Send Feedback
Exposures on Plate (0018,1404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXPOSURES_ON_PLATE
Visual Basic
Public Const EXPOSURES_ON_PLATE As UInteger
Visual C++
public:
literal unsigned int EXPOSURES_ON_PLATE

See Also

MCdicom Structure
MCdicom Members


EXTENDED_DEPTH_OF_FIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXTENDED_DEPTH_OF_FIELD Field
MCdicom Structure See Also Send Feedback
Extended Depth of Field (0048,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXTENDED_DEPTH_OF_FIELD
Visual Basic
Public Const EXTENDED_DEPTH_OF_FIELD As UInteger
Visual C++
public:
literal unsigned int EXTENDED_DEPTH_OF_FIELD

See Also

MCdicom Structure
MCdicom Members


EXTENDED_MATCHING_MECHANISMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXTENDED_MATCHING_MECHANISMS Field
MCdicom Structure See Also Send Feedback
Extended Matching Mechanisms (0008,040F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXTENDED_MATCHING_MECHANISMS
Visual Basic
Public Const EXTENDED_MATCHING_MECHANISMS As UInteger
Visual C++
public:
literal unsigned int EXTENDED_MATCHING_MECHANISMS

See Also

MCdicom Structure
MCdicom Members


EXTENDED_OFFSET_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXTENDED_OFFSET_TABLE Field
MCdicom Structure See Also Send Feedback
Extended Offset Table (7FE0,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXTENDED_OFFSET_TABLE
Visual Basic
Public Const EXTENDED_OFFSET_TABLE As UInteger
Visual C++
public:
literal unsigned int EXTENDED_OFFSET_TABLE

See Also

MCdicom Structure
MCdicom Members


EXTENDED_OFFSET_TABLE_LENGTHS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXTENDED_OFFSET_TABLE_LENGTHS Field
MCdicom Structure See Also Send Feedback
Extended Offset Table Lengths (7FE0,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXTENDED_OFFSET_TABLE_LENGTHS
Visual Basic
Public Const EXTENDED_OFFSET_TABLE_LENGTHS As UInteger
Visual C++
public:
literal unsigned int EXTENDED_OFFSET_TABLE_LENGTHS

See Also

MCdicom Structure
MCdicom Members


EXTERNAL_CONTOUR_ENTRY_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..EXTERNAL_CONTOUR_ENTRY_POINT Field
MCdicom Structure See Also Send Feedback
External Contour Entry Point (300A,0133)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint EXTERNAL_CONTOUR_ENTRY_POINT
Visual Basic
Public Const EXTERNAL_CONTOUR_ENTRY_POINT As UInteger
Visual C++
public:
literal unsigned int EXTERNAL_CONTOUR_ENTRY_POINT

See Also

MCdicom Structure
MCdicom Members


F_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..F_NUMBER Field
MCdicom Structure See Also Send Feedback
F-Number (0016,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint F_NUMBER
Visual Basic
Public Const F_NUMBER As UInteger
Visual C++
public:
literal unsigned int F_NUMBER

See Also

MCdicom Structure
MCdicom Members


FACET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FACET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Facet Sequence (0066,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FACET_SEQUENCE
Visual Basic
Public Const FACET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FACET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FAILED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FAILED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Failed Attributes Sequence (0074,1048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FAILED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const FAILED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FAILED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FAILED_SOP_INSTANCE_UID_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FAILED_SOP_INSTANCE_UID_LIST Field
MCdicom Structure See Also Send Feedback
Failed SOP Instance UID List (0008,0058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FAILED_SOP_INSTANCE_UID_LIST
Visual Basic
Public Const FAILED_SOP_INSTANCE_UID_LIST As UInteger
Visual C++
public:
literal unsigned int FAILED_SOP_INSTANCE_UID_LIST

See Also

MCdicom Structure
MCdicom Members


FAILED_SOP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FAILED_SOP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Failed SOP Sequence (0008,1198)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FAILED_SOP_SEQUENCE
Visual Basic
Public Const FAILED_SOP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FAILED_SOP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FAILURE_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FAILURE_ATTRIBUTES Field
MCdicom Structure See Also Send Feedback
Failure Attributes (2200,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FAILURE_ATTRIBUTES
Visual Basic
Public Const FAILURE_ATTRIBUTES As UInteger
Visual C++
public:
literal unsigned int FAILURE_ATTRIBUTES

See Also

MCdicom Structure
MCdicom Members


FAILURE_REASON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FAILURE_REASON Field
MCdicom Structure See Also Send Feedback
Failure Reason (0008,1197)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FAILURE_REASON
Visual Basic
Public Const FAILURE_REASON As UInteger
Visual C++
public:
literal unsigned int FAILURE_REASON

See Also

MCdicom Structure
MCdicom Members


FALSE_NEGATIVES_ESTIMATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_NEGATIVES_ESTIMATE Field
MCdicom Structure See Also Send Feedback
False Negatives Estimate (0024,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_NEGATIVES_ESTIMATE
Visual Basic
Public Const FALSE_NEGATIVES_ESTIMATE As UInteger
Visual C++
public:
literal unsigned int FALSE_NEGATIVES_ESTIMATE

See Also

MCdicom Structure
MCdicom Members


FALSE_NEGATIVES_ESTIMATE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_NEGATIVES_ESTIMATE_FLAG Field
MCdicom Structure See Also Send Feedback
False Negatives Estimate Flag (0024,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_NEGATIVES_ESTIMATE_FLAG
Visual Basic
Public Const FALSE_NEGATIVES_ESTIMATE_FLAG As UInteger
Visual C++
public:
literal unsigned int FALSE_NEGATIVES_ESTIMATE_FLAG

See Also

MCdicom Structure
MCdicom Members


FALSE_NEGATIVES_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_NEGATIVES_QUANTITY Field
MCdicom Structure See Also Send Feedback
False Negatives Quantity (0024,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_NEGATIVES_QUANTITY
Visual Basic
Public Const FALSE_NEGATIVES_QUANTITY As UInteger
Visual C++
public:
literal unsigned int FALSE_NEGATIVES_QUANTITY

See Also

MCdicom Structure
MCdicom Members


FALSE_POSITIVES_ESTIMATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_POSITIVES_ESTIMATE Field
MCdicom Structure See Also Send Feedback
False Positives Estimate (0024,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_POSITIVES_ESTIMATE
Visual Basic
Public Const FALSE_POSITIVES_ESTIMATE As UInteger
Visual C++
public:
literal unsigned int FALSE_POSITIVES_ESTIMATE

See Also

MCdicom Structure
MCdicom Members


FALSE_POSITIVES_ESTIMATE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_POSITIVES_ESTIMATE_FLAG Field
MCdicom Structure See Also Send Feedback
False Positives Estimate Flag (0024,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_POSITIVES_ESTIMATE_FLAG
Visual Basic
Public Const FALSE_POSITIVES_ESTIMATE_FLAG As UInteger
Visual C++
public:
literal unsigned int FALSE_POSITIVES_ESTIMATE_FLAG

See Also

MCdicom Structure
MCdicom Members


FALSE_POSITIVES_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FALSE_POSITIVES_QUANTITY Field
MCdicom Structure See Also Send Feedback
False Positives Quantity (0024,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FALSE_POSITIVES_QUANTITY
Visual Basic
Public Const FALSE_POSITIVES_QUANTITY As UInteger
Visual C++
public:
literal unsigned int FALSE_POSITIVES_QUANTITY

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Fiducial Description (0070,030F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_DESCRIPTION
Visual Basic
Public Const FIDUCIAL_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Fiducial Identifier (0070,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_IDENTIFIER
Visual Basic
Public Const FIDUCIAL_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_IDENTIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_IDENTIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fiducial Identifier Code Sequence (0070,0311)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_IDENTIFIER_CODE_SEQUENCE
Visual Basic
Public Const FIDUCIAL_IDENTIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_IDENTIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fiducial Sequence (0070,031E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_SEQUENCE
Visual Basic
Public Const FIDUCIAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fiducial Set Sequence (0070,031C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_SET_SEQUENCE
Visual Basic
Public Const FIDUCIAL_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIDUCIAL_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIAL_UID Field
MCdicom Structure See Also Send Feedback
Fiducial UID (0070,031A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIAL_UID
Visual Basic
Public Const FIDUCIAL_UID As UInteger
Visual C++
public:
literal unsigned int FIDUCIAL_UID

See Also

MCdicom Structure
MCdicom Members


FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fiducials Property Category Code Sequence (0070,031F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIDUCIALS_PROPERTY_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Field of View Description (0018,9433)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_DESCRIPTION
Visual Basic
Public Const FIELD_OF_VIEW_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_DIMENSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_DIMENSIONS Field
MCdicom Structure See Also Send Feedback
Field of View Dimension(s) (0018,1149)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_DIMENSIONS
Visual Basic
Public Const FIELD_OF_VIEW_DIMENSIONS As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_DIMENSIONS

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT Field
MCdicom Structure See Also Send Feedback
Field of View Dimension(s) in Float (0018,9461)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT
Visual Basic
Public Const FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_DIMENSIONS_IN_FLOAT

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_HORIZONTAL_FLIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_HORIZONTAL_FLIP Field
MCdicom Structure See Also Send Feedback
Field of View Horizontal Flip (0018,7034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_HORIZONTAL_FLIP
Visual Basic
Public Const FIELD_OF_VIEW_HORIZONTAL_FLIP As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_HORIZONTAL_FLIP

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_ORIGIN Field
MCdicom Structure See Also Send Feedback
Field of View Origin (0018,7030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_ORIGIN
Visual Basic
Public Const FIELD_OF_VIEW_ORIGIN As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_ORIGIN

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_ROTATION Field
MCdicom Structure See Also Send Feedback
Field of View Rotation (0018,7032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_ROTATION
Visual Basic
Public Const FIELD_OF_VIEW_ROTATION As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_ROTATION

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Field of View Sequence (0018,9432)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_SEQUENCE
Visual Basic
Public Const FIELD_OF_VIEW_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIELD_OF_VIEW_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIELD_OF_VIEW_SHAPE Field
MCdicom Structure See Also Send Feedback
Field of View Shape (0018,1147)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIELD_OF_VIEW_SHAPE
Visual Basic
Public Const FIELD_OF_VIEW_SHAPE As UInteger
Visual C++
public:
literal unsigned int FIELD_OF_VIEW_SHAPE

See Also

MCdicom Structure
MCdicom Members


FILE_ACCESS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_ACCESS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
File Access Sequence (0008,041A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_ACCESS_SEQUENCE
Visual Basic
Public Const FILE_ACCESS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILE_ACCESS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILE_ACCESS_URI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_ACCESS_URI Field
MCdicom Structure See Also Send Feedback
File Access URI (0008,0409)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_ACCESS_URI
Visual Basic
Public Const FILE_ACCESS_URI As UInteger
Visual C++
public:
literal unsigned int FILE_ACCESS_URI

See Also

MCdicom Structure
MCdicom Members


FILE_LENGTH_IN_CONTAINER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_LENGTH_IN_CONTAINER Field
MCdicom Structure See Also Send Feedback
File Length in Container (0008,040D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_LENGTH_IN_CONTAINER
Visual Basic
Public Const FILE_LENGTH_IN_CONTAINER As UInteger
Visual C++
public:
literal unsigned int FILE_LENGTH_IN_CONTAINER

See Also

MCdicom Structure
MCdicom Members


FILE_META_INFORMATION_GROUP_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_META_INFORMATION_GROUP_LENGTH Field
MCdicom Structure See Also Send Feedback
File Meta Information Group Length (0002,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_META_INFORMATION_GROUP_LENGTH
Visual Basic
Public Const FILE_META_INFORMATION_GROUP_LENGTH As UInteger
Visual C++
public:
literal unsigned int FILE_META_INFORMATION_GROUP_LENGTH

See Also

MCdicom Structure
MCdicom Members


FILE_META_INFORMATION_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_META_INFORMATION_VERSION Field
MCdicom Structure See Also Send Feedback
File Meta Information Version (0002,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_META_INFORMATION_VERSION
Visual Basic
Public Const FILE_META_INFORMATION_VERSION As UInteger
Visual C++
public:
literal unsigned int FILE_META_INFORMATION_VERSION

See Also

MCdicom Structure
MCdicom Members


FILE_OFFSET_IN_CONTAINER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_OFFSET_IN_CONTAINER Field
MCdicom Structure See Also Send Feedback
File Offset in Container (0008,040C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_OFFSET_IN_CONTAINER
Visual Basic
Public Const FILE_OFFSET_IN_CONTAINER As UInteger
Visual C++
public:
literal unsigned int FILE_OFFSET_IN_CONTAINER

See Also

MCdicom Structure
MCdicom Members


FILE_SET_ACCESS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_SET_ACCESS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
File Set Access Sequence (0008,0419)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_SET_ACCESS_SEQUENCE
Visual Basic
Public Const FILE_SET_ACCESS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILE_SET_ACCESS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILE_SET_CONSISTENCY_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_SET_CONSISTENCY_FLAG Field
MCdicom Structure See Also Send Feedback
File-set Consistency Flag (0004,1212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_SET_CONSISTENCY_FLAG
Visual Basic
Public Const FILE_SET_CONSISTENCY_FLAG As UInteger
Visual C++
public:
literal unsigned int FILE_SET_CONSISTENCY_FLAG

See Also

MCdicom Structure
MCdicom Members


FILE_SET_DESCRIPTOR_FILE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_SET_DESCRIPTOR_FILE_ID Field
MCdicom Structure See Also Send Feedback
File-set Descriptor File ID (0004,1141)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_SET_DESCRIPTOR_FILE_ID
Visual Basic
Public Const FILE_SET_DESCRIPTOR_FILE_ID As UInteger
Visual C++
public:
literal unsigned int FILE_SET_DESCRIPTOR_FILE_ID

See Also

MCdicom Structure
MCdicom Members


FILE_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_SET_ID Field
MCdicom Structure See Also Send Feedback
File-set ID (0004,1130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_SET_ID
Visual Basic
Public Const FILE_SET_ID As UInteger
Visual C++
public:
literal unsigned int FILE_SET_ID

See Also

MCdicom Structure
MCdicom Members


FILE_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILE_SOURCE Field
MCdicom Structure See Also Send Feedback
File Source (0016,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILE_SOURCE
Visual Basic
Public Const FILE_SOURCE As UInteger
Visual C++
public:
literal unsigned int FILE_SOURCE

See Also

MCdicom Structure
MCdicom Members


FILENAME_IN_CONTAINER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILENAME_IN_CONTAINER Field
MCdicom Structure See Also Send Feedback
Filename in Container (0008,040B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILENAME_IN_CONTAINER
Visual Basic
Public Const FILENAME_IN_CONTAINER As UInteger
Visual C++
public:
literal unsigned int FILENAME_IN_CONTAINER

See Also

MCdicom Structure
MCdicom Members


FILL_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILL_MODE Field
MCdicom Structure See Also Send Feedback
Fill Mode (0070,0257)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILL_MODE
Visual Basic
Public Const FILL_MODE As UInteger
Visual C++
public:
literal unsigned int FILL_MODE

See Also

MCdicom Structure
MCdicom Members


FILL_PATTERN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILL_PATTERN Field
MCdicom Structure See Also Send Feedback
Fill Pattern (0070,0256)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILL_PATTERN
Visual Basic
Public Const FILL_PATTERN As UInteger
Visual C++
public:
literal unsigned int FILL_PATTERN

See Also

MCdicom Structure
MCdicom Members


FILL_STYLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILL_STYLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fill Style Sequence (0070,0233)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILL_STYLE_SEQUENCE
Visual Basic
Public Const FILL_STYLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILL_STYLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST Field
MCdicom Structure See Also Send Feedback
Filler Order Number / Imaging Service Request (0040,2017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST
Visual Basic
Public Const FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST As UInteger
Visual C++
public:
literal unsigned int FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST

See Also

MCdicom Structure
MCdicom Members


FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED Field
MCdicom Structure See Also Send Feedback
Filler Order Number Imaging Service Request (Retired) (0040,2007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED
Visual Basic
Public Const FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED As UInteger
Visual C++
public:
literal unsigned int FILLER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED

See Also

MCdicom Structure
MCdicom Members


FILLER_ORDER_NUMBER_PROCEDURE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILLER_ORDER_NUMBER_PROCEDURE_RETIRED Field
MCdicom Structure See Also Send Feedback
Filler Order Number / Procedure RETIRED (0040,1007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILLER_ORDER_NUMBER_PROCEDURE_RETIRED
Visual Basic
Public Const FILLER_ORDER_NUMBER_PROCEDURE_RETIRED As UInteger
Visual C++
public:
literal unsigned int FILLER_ORDER_NUMBER_PROCEDURE_RETIRED

See Also

MCdicom Structure
MCdicom Members


FILM_BOX_CONTENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_BOX_CONTENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Film Box Content Sequence RETIRED (2130,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_BOX_CONTENT_SEQUENCE_RETIRED
Visual Basic
Public Const FILM_BOX_CONTENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int FILM_BOX_CONTENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


FILM_CONSUMPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_CONSUMPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Film Consumption Sequence (0040,0321)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_CONSUMPTION_SEQUENCE
Visual Basic
Public Const FILM_CONSUMPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILM_CONSUMPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILM_DESTINATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_DESTINATION Field
MCdicom Structure See Also Send Feedback
Film Destination (2000,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_DESTINATION
Visual Basic
Public Const FILM_DESTINATION As UInteger
Visual C++
public:
literal unsigned int FILM_DESTINATION

See Also

MCdicom Structure
MCdicom Members


FILM_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Film Orientation (2010,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_ORIENTATION
Visual Basic
Public Const FILM_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int FILM_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


FILM_SESSION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_SESSION_LABEL Field
MCdicom Structure See Also Send Feedback
Film Session Label (2000,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_SESSION_LABEL
Visual Basic
Public Const FILM_SESSION_LABEL As UInteger
Visual C++
public:
literal unsigned int FILM_SESSION_LABEL

See Also

MCdicom Structure
MCdicom Members


FILM_SIZE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILM_SIZE_ID Field
MCdicom Structure See Also Send Feedback
Film Size ID (2010,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILM_SIZE_ID
Visual Basic
Public Const FILM_SIZE_ID As UInteger
Visual C++
public:
literal unsigned int FILM_SIZE_ID

See Also

MCdicom Structure
MCdicom Members


FILTER_BEAM_PATH_LENGTH_MAXIMUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_BEAM_PATH_LENGTH_MAXIMUM Field
MCdicom Structure See Also Send Feedback
Filter Beam Path Length Maximum (0018,7058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_BEAM_PATH_LENGTH_MAXIMUM
Visual Basic
Public Const FILTER_BEAM_PATH_LENGTH_MAXIMUM As UInteger
Visual C++
public:
literal unsigned int FILTER_BEAM_PATH_LENGTH_MAXIMUM

See Also

MCdicom Structure
MCdicom Members


FILTER_BEAM_PATH_LENGTH_MINIMUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_BEAM_PATH_LENGTH_MINIMUM Field
MCdicom Structure See Also Send Feedback
Filter Beam Path Length Minimum (0018,7056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_BEAM_PATH_LENGTH_MINIMUM
Visual Basic
Public Const FILTER_BEAM_PATH_LENGTH_MINIMUM As UInteger
Visual C++
public:
literal unsigned int FILTER_BEAM_PATH_LENGTH_MINIMUM

See Also

MCdicom Structure
MCdicom Members


FILTER_BY_ATTRIBUTE_PRESENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_BY_ATTRIBUTE_PRESENCE Field
MCdicom Structure See Also Send Feedback
Filter-by Attribute Presence (0072,0404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_BY_ATTRIBUTE_PRESENCE
Visual Basic
Public Const FILTER_BY_ATTRIBUTE_PRESENCE As UInteger
Visual C++
public:
literal unsigned int FILTER_BY_ATTRIBUTE_PRESENCE

See Also

MCdicom Structure
MCdicom Members


FILTER_BY_CATEGORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_BY_CATEGORY Field
MCdicom Structure See Also Send Feedback
Filter-by Category (0072,0402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_BY_CATEGORY
Visual Basic
Public Const FILTER_BY_CATEGORY As UInteger
Visual C++
public:
literal unsigned int FILTER_BY_CATEGORY

See Also

MCdicom Structure
MCdicom Members


FILTER_BY_OPERATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_BY_OPERATOR Field
MCdicom Structure See Also Send Feedback
Filter-by Operator (0072,0406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_BY_OPERATOR
Visual Basic
Public Const FILTER_BY_OPERATOR As UInteger
Visual C++
public:
literal unsigned int FILTER_BY_OPERATOR

See Also

MCdicom Structure
MCdicom Members


FILTER_HIGH_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_HIGH_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Filter High Frequency (003A,0221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_HIGH_FREQUENCY
Visual Basic
Public Const FILTER_HIGH_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int FILTER_HIGH_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Filter High Frequency Characteristics Sequence (003A,0319)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILTER_HIGH_FREQUENCY_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILTER_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Filter Lookup Table Data (003A,032E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_LOOKUP_TABLE_DATA
Visual Basic
Public Const FILTER_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int FILTER_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


FILTER_LOOKUP_TABLE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_LOOKUP_TABLE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Filter Lookup Table Description (003A,032B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_LOOKUP_TABLE_DESCRIPTION
Visual Basic
Public Const FILTER_LOOKUP_TABLE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FILTER_LOOKUP_TABLE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FILTER_LOOKUP_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_LOOKUP_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Filter Lookup Table Sequence (003A,032A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_LOOKUP_TABLE_SEQUENCE
Visual Basic
Public Const FILTER_LOOKUP_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILTER_LOOKUP_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILTER_LOW_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_LOW_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Filter Low Frequency (003A,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_LOW_FREQUENCY
Visual Basic
Public Const FILTER_LOW_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int FILTER_LOW_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Filter Low Frequency Characteristics Sequence (003A,0318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILTER_LOW_FREQUENCY_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILTER_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_MATERIAL Field
MCdicom Structure See Also Send Feedback
Filter Material (0018,7050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_MATERIAL
Visual Basic
Public Const FILTER_MATERIAL As UInteger
Visual C++
public:
literal unsigned int FILTER_MATERIAL

See Also

MCdicom Structure
MCdicom Members


FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Filter Material Used in Gain Calibration (0014,3074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION
Visual Basic
Public Const FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int FILTER_MATERIAL_USED_IN_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


FILTER_OPERATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_OPERATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Filter Operations Sequence (0072,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_OPERATIONS_SEQUENCE
Visual Basic
Public Const FILTER_OPERATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FILTER_OPERATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FILTER_THICKNESS_MAXIMUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_THICKNESS_MAXIMUM Field
MCdicom Structure See Also Send Feedback
Filter Thickness Maximum (0018,7054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_THICKNESS_MAXIMUM
Visual Basic
Public Const FILTER_THICKNESS_MAXIMUM As UInteger
Visual C++
public:
literal unsigned int FILTER_THICKNESS_MAXIMUM

See Also

MCdicom Structure
MCdicom Members


FILTER_THICKNESS_MINIMUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_THICKNESS_MINIMUM Field
MCdicom Structure See Also Send Feedback
Filter Thickness Minimum (0018,7052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_THICKNESS_MINIMUM
Visual Basic
Public Const FILTER_THICKNESS_MINIMUM As UInteger
Visual C++
public:
literal unsigned int FILTER_THICKNESS_MINIMUM

See Also

MCdicom Structure
MCdicom Members


FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Filter Thickness Used in Gain Calibration (0014,3075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION
Visual Basic
Public Const FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int FILTER_THICKNESS_USED_IN_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


FILTER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FILTER_TYPE Field
MCdicom Structure See Also Send Feedback
Filter Type (0018,1160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FILTER_TYPE
Visual Basic
Public Const FILTER_TYPE As UInteger
Visual C++
public:
literal unsigned int FILTER_TYPE

See Also

MCdicom Structure
MCdicom Members


FINAL_CUMULATIVE_METERSET_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINAL_CUMULATIVE_METERSET_WEIGHT Field
MCdicom Structure See Also Send Feedback
Final Cumulative Meterset Weight (300A,010E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINAL_CUMULATIVE_METERSET_WEIGHT
Visual Basic
Public Const FINAL_CUMULATIVE_METERSET_WEIGHT As UInteger
Visual C++
public:
literal unsigned int FINAL_CUMULATIVE_METERSET_WEIGHT

See Also

MCdicom Structure
MCdicom Members


FINAL_CUMULATIVE_TIME_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINAL_CUMULATIVE_TIME_WEIGHT Field
MCdicom Structure See Also Send Feedback
Final Cumulative Time Weight (300A,02C8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINAL_CUMULATIVE_TIME_WEIGHT
Visual Basic
Public Const FINAL_CUMULATIVE_TIME_WEIGHT As UInteger
Visual C++
public:
literal unsigned int FINAL_CUMULATIVE_TIME_WEIGHT

See Also

MCdicom Structure
MCdicom Members


FIND_LOCATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIND_LOCATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Find Location RETIRED (0000,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIND_LOCATION_RETIRED
Visual Basic
Public Const FIND_LOCATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int FIND_LOCATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_FLAG_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_FLAG_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Flag (Trial) RETIRED (0040,A007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_FLAG_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_FLAG_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_FLAG_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Group Recording Date (Trial) RETIRED (0040,A023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_GROUP_RECORDING_DATE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Group Recording Time (Trial) RETIRED (0040,A024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_GROUP_RECORDING_TIME_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_GROUP_UID_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_GROUP_UID_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Group UID (Trial) RETIRED (0040,A021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_GROUP_UID_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_GROUP_UID_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_GROUP_UID_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Sequence (Trial) RETIRED (0040,A020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Findings Source Category Code Sequence (Trial) RETIRED (0040,A026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int FINDINGS_SOURCE_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


FINITE_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FINITE_VOLUME Field
MCdicom Structure See Also Send Feedback
Finite Volume (0066,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FINITE_VOLUME
Visual Basic
Public Const FINITE_VOLUME As UInteger
Visual C++
public:
literal unsigned int FINITE_VOLUME

See Also

MCdicom Structure
MCdicom Members


FIRST_A_LINE_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIRST_A_LINE_LOCATION Field
MCdicom Structure See Also Send Feedback
First A-line Location (0052,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIRST_A_LINE_LOCATION
Visual Basic
Public Const FIRST_A_LINE_LOCATION As UInteger
Visual C++
public:
literal unsigned int FIRST_A_LINE_LOCATION

See Also

MCdicom Structure
MCdicom Members


FIRST_ORDER_PHASE_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIRST_ORDER_PHASE_CORRECTION Field
MCdicom Structure See Also Send Feedback
First Order Phase Correction (0018,9198)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIRST_ORDER_PHASE_CORRECTION
Visual Basic
Public Const FIRST_ORDER_PHASE_CORRECTION As UInteger
Visual C++
public:
literal unsigned int FIRST_ORDER_PHASE_CORRECTION

See Also

MCdicom Structure
MCdicom Members


FIRST_ORDER_PHASE_CORRECTION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIRST_ORDER_PHASE_CORRECTION_ANGLE Field
MCdicom Structure See Also Send Feedback
First Order Phase Correction Angle (5600,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIRST_ORDER_PHASE_CORRECTION_ANGLE
Visual Basic
Public Const FIRST_ORDER_PHASE_CORRECTION_ANGLE As UInteger
Visual C++
public:
literal unsigned int FIRST_ORDER_PHASE_CORRECTION_ANGLE

See Also

MCdicom Structure
MCdicom Members


FIRST_TREATMENT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIRST_TREATMENT_DATE Field
MCdicom Structure See Also Send Feedback
First Treatment Date (3008,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIRST_TREATMENT_DATE
Visual Basic
Public Const FIRST_TREATMENT_DATE As UInteger
Visual C++
public:
literal unsigned int FIRST_TREATMENT_DATE

See Also

MCdicom Structure
MCdicom Members


FIXATION_CHECKED_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_CHECKED_QUANTITY Field
MCdicom Structure See Also Send Feedback
Fixation Checked Quantity (0024,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_CHECKED_QUANTITY
Visual Basic
Public Const FIXATION_CHECKED_QUANTITY As UInteger
Visual C++
public:
literal unsigned int FIXATION_CHECKED_QUANTITY

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Fixation Device Description (300A,0196)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_DESCRIPTION
Visual Basic
Public Const FIXATION_DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_LABEL Field
MCdicom Structure See Also Send Feedback
Fixation Device Label (300A,0194)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_LABEL
Visual Basic
Public Const FIXATION_DEVICE_LABEL As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_LABEL

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_PITCH_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_PITCH_ANGLE Field
MCdicom Structure See Also Send Feedback
Fixation Device Pitch Angle (300A,0199)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_PITCH_ANGLE
Visual Basic
Public Const FIXATION_DEVICE_PITCH_ANGLE As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_PITCH_ANGLE

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_POSITION Field
MCdicom Structure See Also Send Feedback
Fixation Device Position (300A,0198)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_POSITION
Visual Basic
Public Const FIXATION_DEVICE_POSITION As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_POSITION

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_ROLL_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_ROLL_ANGLE Field
MCdicom Structure See Also Send Feedback
Fixation Device Roll Angle (300A,019A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_ROLL_ANGLE
Visual Basic
Public Const FIXATION_DEVICE_ROLL_ANGLE As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_ROLL_ANGLE

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fixation Device Sequence (300A,0190)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_SEQUENCE
Visual Basic
Public Const FIXATION_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIXATION_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Fixation Device Type (300A,0192)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_DEVICE_TYPE
Visual Basic
Public Const FIXATION_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int FIXATION_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


FIXATION_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_EYE Field
MCdicom Structure See Also Send Feedback
Fixation Eye (300A,0150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_EYE
Visual Basic
Public Const FIXATION_EYE As UInteger
Visual C++
public:
literal unsigned int FIXATION_EYE

See Also

MCdicom Structure
MCdicom Members


FIXATION_LIGHT_AZIMUTHAL_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_LIGHT_AZIMUTHAL_ANGLE Field
MCdicom Structure See Also Send Feedback
Fixation Light Azimuthal Angle (300A,0356)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_LIGHT_AZIMUTHAL_ANGLE
Visual Basic
Public Const FIXATION_LIGHT_AZIMUTHAL_ANGLE As UInteger
Visual C++
public:
literal unsigned int FIXATION_LIGHT_AZIMUTHAL_ANGLE

See Also

MCdicom Structure
MCdicom Members


FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Fixation Light Azimuthal Angle Tolerance (300A,0154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE
Visual Basic
Public Const FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_LIGHT_AZIMUTHAL_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


FIXATION_LIGHT_POLAR_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_LIGHT_POLAR_ANGLE Field
MCdicom Structure See Also Send Feedback
Fixation Light Polar Angle (300A,0358)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_LIGHT_POLAR_ANGLE
Visual Basic
Public Const FIXATION_LIGHT_POLAR_ANGLE As UInteger
Visual C++
public:
literal unsigned int FIXATION_LIGHT_POLAR_ANGLE

See Also

MCdicom Structure
MCdicom Members


FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Fixation Light Polar Angle Tolerance (300A,0155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE
Visual Basic
Public Const FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_LIGHT_POLAR_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


FIXATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fixation Method Code Sequence (0068,63AC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const FIXATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIXATION_MONITORING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_MONITORING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fixation Monitoring Code Sequence (0024,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_MONITORING_CODE_SEQUENCE
Visual Basic
Public Const FIXATION_MONITORING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_MONITORING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIXATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fixation Sequence (0024,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXATION_SEQUENCE
Visual Basic
Public Const FIXATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIXATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fixed RT Beam Delimiter Device Sequence (300A,0646)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE
Visual Basic
Public Const FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FIXED_RT_BEAM_DELIMITER_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FLASH_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_ENERGY Field
MCdicom Structure See Also Send Feedback
Flash Energy (0016,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_ENERGY
Visual Basic
Public Const FLASH_ENERGY As UInteger
Visual C++
public:
literal unsigned int FLASH_ENERGY

See Also

MCdicom Structure
MCdicom Members


FLASH_FIRING_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_FIRING_STATUS Field
MCdicom Structure See Also Send Feedback
Flash Firing Status (0016,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_FIRING_STATUS
Visual Basic
Public Const FLASH_FIRING_STATUS As UInteger
Visual C++
public:
literal unsigned int FLASH_FIRING_STATUS

See Also

MCdicom Structure
MCdicom Members


FLASH_FUNCTION_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_FUNCTION_PRESENT Field
MCdicom Structure See Also Send Feedback
Flash Function Present (0016,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_FUNCTION_PRESENT
Visual Basic
Public Const FLASH_FUNCTION_PRESENT As UInteger
Visual C++
public:
literal unsigned int FLASH_FUNCTION_PRESENT

See Also

MCdicom Structure
MCdicom Members


FLASH_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_MODE Field
MCdicom Structure See Also Send Feedback
Flash Mode (0016,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_MODE
Visual Basic
Public Const FLASH_MODE As UInteger
Visual C++
public:
literal unsigned int FLASH_MODE

See Also

MCdicom Structure
MCdicom Members


FLASH_RED_EYE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_RED_EYE_MODE Field
MCdicom Structure See Also Send Feedback
Flash Red Eye Mode (0016,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_RED_EYE_MODE
Visual Basic
Public Const FLASH_RED_EYE_MODE As UInteger
Visual C++
public:
literal unsigned int FLASH_RED_EYE_MODE

See Also

MCdicom Structure
MCdicom Members


FLASH_RETURN_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLASH_RETURN_STATUS Field
MCdicom Structure See Also Send Feedback
Flash Return Status (0016,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLASH_RETURN_STATUS
Visual Basic
Public Const FLASH_RETURN_STATUS As UInteger
Visual C++
public:
literal unsigned int FLASH_RETURN_STATUS

See Also

MCdicom Structure
MCdicom Members


FLAT_CORNEAL_AXIS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLAT_CORNEAL_AXIS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Flat Corneal Axis Sequence (0046,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLAT_CORNEAL_AXIS_SEQUENCE
Visual Basic
Public Const FLAT_CORNEAL_AXIS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FLAT_CORNEAL_AXIS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FLAT_KERATOMETRIC_AXIS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLAT_KERATOMETRIC_AXIS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Flat Keratometric Axis Sequence (0046,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLAT_KERATOMETRIC_AXIS_SEQUENCE
Visual Basic
Public Const FLAT_KERATOMETRIC_AXIS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FLAT_KERATOMETRIC_AXIS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FLIP_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLIP_ANGLE Field
MCdicom Structure See Also Send Feedback
Flip Angle (0018,1314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLIP_ANGLE
Visual Basic
Public Const FLIP_ANGLE As UInteger
Visual C++
public:
literal unsigned int FLIP_ANGLE

See Also

MCdicom Structure
MCdicom Members


FLOAT_PIXEL_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOAT_PIXEL_DATA Field
MCdicom Structure See Also Send Feedback
Float Pixel Data (7FE0,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOAT_PIXEL_DATA
Visual Basic
Public Const FLOAT_PIXEL_DATA As UInteger
Visual C++
public:
literal unsigned int FLOAT_PIXEL_DATA

See Also

MCdicom Structure
MCdicom Members


FLOAT_PIXEL_PADDING_RANGE_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOAT_PIXEL_PADDING_RANGE_LIMIT Field
MCdicom Structure See Also Send Feedback
Float Pixel Padding Range Limit (0028,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOAT_PIXEL_PADDING_RANGE_LIMIT
Visual Basic
Public Const FLOAT_PIXEL_PADDING_RANGE_LIMIT As UInteger
Visual C++
public:
literal unsigned int FLOAT_PIXEL_PADDING_RANGE_LIMIT

See Also

MCdicom Structure
MCdicom Members


FLOAT_PIXEL_PADDING_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOAT_PIXEL_PADDING_VALUE Field
MCdicom Structure See Also Send Feedback
Float Pixel Padding Value (0028,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOAT_PIXEL_PADDING_VALUE
Visual Basic
Public Const FLOAT_PIXEL_PADDING_VALUE As UInteger
Visual C++
public:
literal unsigned int FLOAT_PIXEL_PADDING_VALUE

See Also

MCdicom Structure
MCdicom Members


FLOATING_POINT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOATING_POINT_VALUE Field
MCdicom Structure See Also Send Feedback
Floating Point Value (0040,A161)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOATING_POINT_VALUE
Visual Basic
Public Const FLOATING_POINT_VALUE As UInteger
Visual C++
public:
literal unsigned int FLOATING_POINT_VALUE

See Also

MCdicom Structure
MCdicom Members


FLOATING_POINT_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOATING_POINT_VALUES Field
MCdicom Structure See Also Send Feedback
Floating Point Values (0066,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOATING_POINT_VALUES
Visual Basic
Public Const FLOATING_POINT_VALUES As UInteger
Visual C++
public:
literal unsigned int FLOATING_POINT_VALUES

See Also

MCdicom Structure
MCdicom Members


FLOW_COMPENSATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_COMPENSATION Field
MCdicom Structure See Also Send Feedback
Flow Compensation (0018,9010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_COMPENSATION
Visual Basic
Public Const FLOW_COMPENSATION As UInteger
Visual C++
public:
literal unsigned int FLOW_COMPENSATION

See Also

MCdicom Structure
MCdicom Members


FLOW_COMPENSATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_COMPENSATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Flow Compensation Direction (0018,9183)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_COMPENSATION_DIRECTION
Visual Basic
Public Const FLOW_COMPENSATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int FLOW_COMPENSATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


FLOW_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Flow Identifier (0034,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_IDENTIFIER
Visual Basic
Public Const FLOW_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int FLOW_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


FLOW_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Flow Identifier Sequence (0034,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_IDENTIFIER_SEQUENCE
Visual Basic
Public Const FLOW_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FLOW_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FLOW_RTP_SAMPLING_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_RTP_SAMPLING_RATE Field
MCdicom Structure See Also Send Feedback
Flow RTP Sampling Rate (0034,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_RTP_SAMPLING_RATE
Visual Basic
Public Const FLOW_RTP_SAMPLING_RATE As UInteger
Visual C++
public:
literal unsigned int FLOW_RTP_SAMPLING_RATE

See Also

MCdicom Structure
MCdicom Members


FLOW_TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLOW_TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
Flow Transfer Syntax UID (0034,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLOW_TRANSFER_SYNTAX_UID
Visual Basic
Public Const FLOW_TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int FLOW_TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


FLUENCE_DATA_SCALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUENCE_DATA_SCALE Field
MCdicom Structure See Also Send Feedback
Fluence Data Scale (3002,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUENCE_DATA_SCALE
Visual Basic
Public Const FLUENCE_DATA_SCALE As UInteger
Visual C++
public:
literal unsigned int FLUENCE_DATA_SCALE

See Also

MCdicom Structure
MCdicom Members


FLUENCE_DATA_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUENCE_DATA_SOURCE Field
MCdicom Structure See Also Send Feedback
Fluence Data Source (3002,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUENCE_DATA_SOURCE
Visual Basic
Public Const FLUENCE_DATA_SOURCE As UInteger
Visual C++
public:
literal unsigned int FLUENCE_DATA_SOURCE

See Also

MCdicom Structure
MCdicom Members


FLUENCE_MAP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUENCE_MAP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fluence Map Sequence (3002,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUENCE_MAP_SEQUENCE
Visual Basic
Public Const FLUENCE_MAP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FLUENCE_MAP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FLUENCE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUENCE_MODE Field
MCdicom Structure See Also Send Feedback
Fluence Mode (3002,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUENCE_MODE
Visual Basic
Public Const FLUENCE_MODE As UInteger
Visual C++
public:
literal unsigned int FLUENCE_MODE

See Also

MCdicom Structure
MCdicom Members


FLUENCE_MODE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUENCE_MODE_ID Field
MCdicom Structure See Also Send Feedback
Fluence Mode ID (3002,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUENCE_MODE_ID
Visual Basic
Public Const FLUENCE_MODE_ID As UInteger
Visual C++
public:
literal unsigned int FLUENCE_MODE_ID

See Also

MCdicom Structure
MCdicom Members


FLUOROSCOPY_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUOROSCOPY_FLAG Field
MCdicom Structure See Also Send Feedback
Fluoroscopy Flag (0018,9334)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUOROSCOPY_FLAG
Visual Basic
Public Const FLUOROSCOPY_FLAG As UInteger
Visual C++
public:
literal unsigned int FLUOROSCOPY_FLAG

See Also

MCdicom Structure
MCdicom Members


FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG Field
MCdicom Structure See Also Send Feedback
Fluoroscopy Last Image Hold Persistence Flag (0018,11B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG
Visual Basic
Public Const FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int FLUOROSCOPY_LAST_IMAGE_HOLD_PERSISTENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


FLUOROSCOPY_PERSISTENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FLUOROSCOPY_PERSISTENCE_FLAG Field
MCdicom Structure See Also Send Feedback
Fluoroscopy Persistence Flag (0018,11B3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FLUOROSCOPY_PERSISTENCE_FLAG
Visual Basic
Public Const FLUOROSCOPY_PERSISTENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int FLUOROSCOPY_PERSISTENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


FOCAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
Focal Distance (0018,1182)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCAL_DISTANCE
Visual Basic
Public Const FOCAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int FOCAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


FOCAL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCAL_LENGTH Field
MCdicom Structure See Also Send Feedback
Focal Length (0016,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCAL_LENGTH
Visual Basic
Public Const FOCAL_LENGTH As UInteger
Visual C++
public:
literal unsigned int FOCAL_LENGTH

See Also

MCdicom Structure
MCdicom Members


FOCAL_LENGTH_IN_35MM_FILM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCAL_LENGTH_IN_35MM_FILM Field
MCdicom Structure See Also Send Feedback
Focal Length In 35mm Film (0016,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCAL_LENGTH_IN_35MM_FILM
Visual Basic
Public Const FOCAL_LENGTH_IN_35MM_FILM As UInteger
Visual C++
public:
literal unsigned int FOCAL_LENGTH_IN_35MM_FILM

See Also

MCdicom Structure
MCdicom Members


FOCAL_SPOTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCAL_SPOTS Field
MCdicom Structure See Also Send Feedback
Focal Spot(s) (0018,1190)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCAL_SPOTS
Visual Basic
Public Const FOCAL_SPOTS As UInteger
Visual C++
public:
literal unsigned int FOCAL_SPOTS

See Also

MCdicom Structure
MCdicom Members


FOCUS_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCUS_DEPTH Field
MCdicom Structure See Also Send Feedback
Focus Depth (0018,5012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCUS_DEPTH
Visual Basic
Public Const FOCUS_DEPTH As UInteger
Visual C++
public:
literal unsigned int FOCUS_DEPTH

See Also

MCdicom Structure
MCdicom Members


FOCUS_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOCUS_METHOD Field
MCdicom Structure See Also Send Feedback
Focus Method (0048,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOCUS_METHOD
Visual Basic
Public Const FOCUS_METHOD As UInteger
Visual C++
public:
literal unsigned int FOCUS_METHOD

See Also

MCdicom Structure
MCdicom Members


FOLDER_ACCESS_URI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOLDER_ACCESS_URI Field
MCdicom Structure See Also Send Feedback
Folder Access URI (0008,0408)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOLDER_ACCESS_URI
Visual Basic
Public Const FOLDER_ACCESS_URI As UInteger
Visual C++
public:
literal unsigned int FOLDER_ACCESS_URI

See Also

MCdicom Structure
MCdicom Members


FONT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FONT_NAME Field
MCdicom Structure See Also Send Feedback
Font Name (0070,0227)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FONT_NAME
Visual Basic
Public Const FONT_NAME As UInteger
Visual C++
public:
literal unsigned int FONT_NAME

See Also

MCdicom Structure
MCdicom Members


FONT_NAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FONT_NAME_TYPE Field
MCdicom Structure See Also Send Feedback
Font Name Type (0070,0228)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FONT_NAME_TYPE
Visual Basic
Public Const FONT_NAME_TYPE As UInteger
Visual C++
public:
literal unsigned int FONT_NAME_TYPE

See Also

MCdicom Structure
MCdicom Members


FOVEAL_POINT_NORMATIVE_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOVEAL_POINT_NORMATIVE_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Foveal Point Normative Data Flag (0024,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOVEAL_POINT_NORMATIVE_DATA_FLAG
Visual Basic
Public Const FOVEAL_POINT_NORMATIVE_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int FOVEAL_POINT_NORMATIVE_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


FOVEAL_POINT_PROBABILITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOVEAL_POINT_PROBABILITY_VALUE Field
MCdicom Structure See Also Send Feedback
Foveal Point Probability Value (0024,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOVEAL_POINT_PROBABILITY_VALUE
Visual Basic
Public Const FOVEAL_POINT_PROBABILITY_VALUE As UInteger
Visual C++
public:
literal unsigned int FOVEAL_POINT_PROBABILITY_VALUE

See Also

MCdicom Structure
MCdicom Members


FOVEAL_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOVEAL_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Foveal Sensitivity (0024,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOVEAL_SENSITIVITY
Visual Basic
Public Const FOVEAL_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int FOVEAL_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


FOVEAL_SENSITIVITY_MEASURED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FOVEAL_SENSITIVITY_MEASURED Field
MCdicom Structure See Also Send Feedback
Foveal Sensitivity Measured (0024,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FOVEAL_SENSITIVITY_MEASURED
Visual Basic
Public Const FOVEAL_SENSITIVITY_MEASURED As UInteger
Visual C++
public:
literal unsigned int FOVEAL_SENSITIVITY_MEASURED

See Also

MCdicom Structure
MCdicom Members


FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR Field
MCdicom Structure See Also Send Feedback
Fraction-Based Relationship Interval Anchor (3010,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR
Visual Basic
Public Const FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR As UInteger
Visual C++
public:
literal unsigned int FRACTION_BASED_RELATIONSHIP_INTERVAL_ANCHOR

See Also

MCdicom Structure
MCdicom Members


FRACTION_BASED_RELATIONSHIP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_BASED_RELATIONSHIP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fraction-Based Relationship Sequence (3010,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_BASED_RELATIONSHIP_SEQUENCE
Visual Basic
Public Const FRACTION_BASED_RELATIONSHIP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRACTION_BASED_RELATIONSHIP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRACTION_GROUP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_GROUP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Fraction Group Description (300A,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_GROUP_DESCRIPTION
Visual Basic
Public Const FRACTION_GROUP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FRACTION_GROUP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FRACTION_GROUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_GROUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Fraction Group Number (300A,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_GROUP_NUMBER
Visual Basic
Public Const FRACTION_GROUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int FRACTION_GROUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


FRACTION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fraction Group Sequence (300A,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_GROUP_SEQUENCE
Visual Basic
Public Const FRACTION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRACTION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRACTION_GROUP_SUMMARY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_GROUP_SUMMARY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fraction Group Summary Sequence (3008,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_GROUP_SUMMARY_SEQUENCE
Visual Basic
Public Const FRACTION_GROUP_SUMMARY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRACTION_GROUP_SUMMARY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRACTION_GROUP_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_GROUP_TYPE Field
MCdicom Structure See Also Send Feedback
Fraction Group Type (3008,0224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_GROUP_TYPE
Visual Basic
Public Const FRACTION_GROUP_TYPE As UInteger
Visual C++
public:
literal unsigned int FRACTION_GROUP_TYPE

See Also

MCdicom Structure
MCdicom Members


FRACTION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_NUMBER Field
MCdicom Structure See Also Send Feedback
Fraction Number (3002,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_NUMBER
Visual Basic
Public Const FRACTION_NUMBER As UInteger
Visual C++
public:
literal unsigned int FRACTION_NUMBER

See Also

MCdicom Structure
MCdicom Members


FRACTION_PATTERN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_PATTERN Field
MCdicom Structure See Also Send Feedback
Fraction Pattern (300A,007B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_PATTERN
Visual Basic
Public Const FRACTION_PATTERN As UInteger
Visual C++
public:
literal unsigned int FRACTION_PATTERN

See Also

MCdicom Structure
MCdicom Members


FRACTION_PATTERN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_PATTERN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fraction Pattern Sequence (3010,0079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_PATTERN_SEQUENCE
Visual Basic
Public Const FRACTION_PATTERN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRACTION_PATTERN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRACTION_STATUS_SUMMARY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTION_STATUS_SUMMARY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Fraction Status Summary Sequence (3008,0240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTION_STATUS_SUMMARY_SEQUENCE
Visual Basic
Public Const FRACTION_STATUS_SUMMARY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRACTION_STATUS_SUMMARY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRACTIONAL_BANDWIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTIONAL_BANDWIDTH Field
MCdicom Structure See Also Send Feedback
Fractional Bandwidth (0018,982E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTIONAL_BANDWIDTH
Visual Basic
Public Const FRACTIONAL_BANDWIDTH As UInteger
Visual C++
public:
literal unsigned int FRACTIONAL_BANDWIDTH

See Also

MCdicom Structure
MCdicom Members


FRACTIONAL_CHANNEL_DISPLAY_SCALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTIONAL_CHANNEL_DISPLAY_SCALE Field
MCdicom Structure See Also Send Feedback
Fractional Channel Display Scale (003A,0247)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTIONAL_CHANNEL_DISPLAY_SCALE
Visual Basic
Public Const FRACTIONAL_CHANNEL_DISPLAY_SCALE As UInteger
Visual C++
public:
literal unsigned int FRACTIONAL_CHANNEL_DISPLAY_SCALE

See Also

MCdicom Structure
MCdicom Members


FRACTIONATION_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRACTIONATION_NOTES Field
MCdicom Structure See Also Send Feedback
Fractionation Notes (3010,007F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRACTIONATION_NOTES
Visual Basic
Public Const FRACTIONATION_NOTES As UInteger
Visual C++
public:
literal unsigned int FRACTIONATION_NOTES

See Also

MCdicom Structure
MCdicom Members


FRAME_ACQUISITION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ACQUISITION_DATETIME Field
MCdicom Structure See Also Send Feedback
Frame Acquisition DateTime (0018,9074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ACQUISITION_DATETIME
Visual Basic
Public Const FRAME_ACQUISITION_DATETIME As UInteger
Visual C++
public:
literal unsigned int FRAME_ACQUISITION_DATETIME

See Also

MCdicom Structure
MCdicom Members


FRAME_ACQUISITION_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ACQUISITION_DURATION Field
MCdicom Structure See Also Send Feedback
Frame Acquisition Duration (0018,9220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ACQUISITION_DURATION
Visual Basic
Public Const FRAME_ACQUISITION_DURATION As UInteger
Visual C++
public:
literal unsigned int FRAME_ACQUISITION_DURATION

See Also

MCdicom Structure
MCdicom Members


FRAME_ACQUISITION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ACQUISITION_NUMBER Field
MCdicom Structure See Also Send Feedback
Frame Acquisition Number (0020,9156)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ACQUISITION_NUMBER
Visual Basic
Public Const FRAME_ACQUISITION_NUMBER As UInteger
Visual C++
public:
literal unsigned int FRAME_ACQUISITION_NUMBER

See Also

MCdicom Structure
MCdicom Members


FRAME_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Acquisition Sequence (0018,9417)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ACQUISITION_SEQUENCE
Visual Basic
Public Const FRAME_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_ANATOMY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ANATOMY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Anatomy Sequence (0020,9071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ANATOMY_SEQUENCE
Visual Basic
Public Const FRAME_ANATOMY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_ANATOMY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_COMMENTS Field
MCdicom Structure See Also Send Feedback
Frame Comments (0020,9158)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_COMMENTS
Visual Basic
Public Const FRAME_COMMENTS As UInteger
Visual C++
public:
literal unsigned int FRAME_COMMENTS

See Also

MCdicom Structure
MCdicom Members


FRAME_CONTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_CONTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Content Sequence (0020,9111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_CONTENT_SEQUENCE
Visual Basic
Public Const FRAME_CONTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_CONTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_DELAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_DELAY Field
MCdicom Structure See Also Send Feedback
Frame Delay (0018,1066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_DELAY
Visual Basic
Public Const FRAME_DELAY As UInteger
Visual C++
public:
literal unsigned int FRAME_DELAY

See Also

MCdicom Structure
MCdicom Members


FRAME_DETECTOR_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_DETECTOR_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Detector Parameters Sequence (0018,9451)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_DETECTOR_PARAMETERS_SEQUENCE
Visual Basic
Public Const FRAME_DETECTOR_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_DETECTOR_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_DIMENSION_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_DIMENSION_POINTER Field
MCdicom Structure See Also Send Feedback
Frame Dimension Pointer (0028,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_DIMENSION_POINTER
Visual Basic
Public Const FRAME_DIMENSION_POINTER As UInteger
Visual C++
public:
literal unsigned int FRAME_DIMENSION_POINTER

See Also

MCdicom Structure
MCdicom Members


FRAME_DISPLAY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_DISPLAY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Display Sequence (0008,9458)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_DISPLAY_SEQUENCE
Visual Basic
Public Const FRAME_DISPLAY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_DISPLAY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_DISPLAY_SHUTTER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_DISPLAY_SHUTTER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Display Shutter Sequence (0018,9472)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_DISPLAY_SHUTTER_SEQUENCE
Visual Basic
Public Const FRAME_DISPLAY_SHUTTER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_DISPLAY_SHUTTER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_EXTRACTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_EXTRACTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Extraction Sequence (0008,1164)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_EXTRACTION_SEQUENCE
Visual Basic
Public Const FRAME_EXTRACTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_EXTRACTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_INCREMENT_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_INCREMENT_POINTER Field
MCdicom Structure See Also Send Feedback
Frame Increment Pointer (0028,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_INCREMENT_POINTER
Visual Basic
Public Const FRAME_INCREMENT_POINTER As UInteger
Visual C++
public:
literal unsigned int FRAME_INCREMENT_POINTER

See Also

MCdicom Structure
MCdicom Members


FRAME_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_LABEL Field
MCdicom Structure See Also Send Feedback
Frame Label (0020,9453)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_LABEL
Visual Basic
Public Const FRAME_LABEL As UInteger
Visual C++
public:
literal unsigned int FRAME_LABEL

See Also

MCdicom Structure
MCdicom Members


FRAME_LABEL_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_LABEL_VECTOR Field
MCdicom Structure See Also Send Feedback
Frame Label Vector (0018,2002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_LABEL_VECTOR
Visual Basic
Public Const FRAME_LABEL_VECTOR As UInteger
Visual C++
public:
literal unsigned int FRAME_LABEL_VECTOR

See Also

MCdicom Structure
MCdicom Members


FRAME_LATERALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_LATERALITY Field
MCdicom Structure See Also Send Feedback
Frame Laterality (0020,9072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_LATERALITY
Visual Basic
Public Const FRAME_LATERALITY As UInteger
Visual C++
public:
literal unsigned int FRAME_LATERALITY

See Also

MCdicom Structure
MCdicom Members


FRAME_NUMBERS_OF_INTEREST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_NUMBERS_OF_INTEREST Field
MCdicom Structure See Also Send Feedback
Frame Numbers of Interest (0028,6020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_NUMBERS_OF_INTEREST
Visual Basic
Public Const FRAME_NUMBERS_OF_INTEREST As UInteger
Visual C++
public:
literal unsigned int FRAME_NUMBERS_OF_INTEREST

See Also

MCdicom Structure
MCdicom Members


FRAME_NUMBERS_OF_INTEREST_FOI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_NUMBERS_OF_INTEREST_FOI Field
MCdicom Structure See Also Send Feedback
Alias for tag FRAME_NUMBERS_OF_INTEREST (0028,6020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_NUMBERS_OF_INTEREST_FOI
Visual Basic
Public Const FRAME_NUMBERS_OF_INTEREST_FOI As UInteger
Visual C++
public:
literal unsigned int FRAME_NUMBERS_OF_INTEREST_FOI

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_INTEREST_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_INTEREST_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Frame of Interest Description (0028,6022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_INTEREST_DESCRIPTION
Visual Basic
Public Const FRAME_OF_INTEREST_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_INTEREST_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_INTEREST_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_INTEREST_TYPE Field
MCdicom Structure See Also Send Feedback
Frame of Interest Type (0028,6023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_INTEREST_TYPE
Visual Basic
Public Const FRAME_OF_INTEREST_TYPE As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_INTEREST_TYPE

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Frame of Reference Relationship Sequence RETIRED (3006,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED
Visual Basic
Public Const FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_RELATIONSHIP_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX Field
MCdicom Structure See Also Send Feedback
Frame of Reference to Displayed Coordinate System Transformation Matrix (0070,030B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX
Visual Basic
Public Const FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_TO_DISPLAYED_COORDINATE_SYSTEM_TRANSFORMATION_MATRIX

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT Field
MCdicom Structure See Also Send Feedback
Frame of Reference Transformation Comment (3006,00C8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT
Visual Basic
Public Const FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_TRANSFORMATION_COMMENT

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX Field
MCdicom Structure See Also Send Feedback
Frame of Reference Transformation Matrix (3006,00C6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX
Visual Basic
Public Const FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE Field
MCdicom Structure See Also Send Feedback
Frame of Reference Transformation Matrix Type (0070,030C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE
Visual Basic
Public Const FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_TRANSFORMATION_MATRIX_TYPE

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Frame of Reference Transformation Type RETIRED (3006,00C4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED
Visual Basic
Public Const FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_TRANSFORMATION_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Frame of Reference UID (0020,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_OF_REFERENCE_UID
Visual Basic
Public Const FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


FRAME_ORIGIN_TIMESTAMP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_ORIGIN_TIMESTAMP Field
MCdicom Structure See Also Send Feedback
Frame Origin Timestamp (0034,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_ORIGIN_TIMESTAMP
Visual Basic
Public Const FRAME_ORIGIN_TIMESTAMP As UInteger
Visual C++
public:
literal unsigned int FRAME_ORIGIN_TIMESTAMP

See Also

MCdicom Structure
MCdicom Members


FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Pixel Data Properties Sequence (0028,9443)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE
Visual Basic
Public Const FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_PIXEL_DATA_PROPERTIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_PIXEL_SHIFT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_PIXEL_SHIFT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Pixel Shift Sequence (0028,9415)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_PIXEL_SHIFT_SEQUENCE
Visual Basic
Public Const FRAME_PIXEL_SHIFT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_PIXEL_SHIFT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_PRIMARY_ANGLE_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_PRIMARY_ANGLE_VECTOR Field
MCdicom Structure See Also Send Feedback
Frame Primary Angle Vector (0018,2003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_PRIMARY_ANGLE_VECTOR
Visual Basic
Public Const FRAME_PRIMARY_ANGLE_VECTOR As UInteger
Visual C++
public:
literal unsigned int FRAME_PRIMARY_ANGLE_VECTOR

See Also

MCdicom Structure
MCdicom Members


FRAME_REFERENCE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_REFERENCE_DATETIME Field
MCdicom Structure See Also Send Feedback
Frame Reference DateTime (0018,9151)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_REFERENCE_DATETIME
Visual Basic
Public Const FRAME_REFERENCE_DATETIME As UInteger
Visual C++
public:
literal unsigned int FRAME_REFERENCE_DATETIME

See Also

MCdicom Structure
MCdicom Members


FRAME_REFERENCE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_REFERENCE_TIME Field
MCdicom Structure See Also Send Feedback
Frame Reference Time (0054,1300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_REFERENCE_TIME
Visual Basic
Public Const FRAME_REFERENCE_TIME As UInteger
Visual C++
public:
literal unsigned int FRAME_REFERENCE_TIME

See Also

MCdicom Structure
MCdicom Members


FRAME_SECONDARY_ANGLE_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_SECONDARY_ANGLE_VECTOR Field
MCdicom Structure See Also Send Feedback
Frame Secondary Angle Vector (0018,2004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_SECONDARY_ANGLE_VECTOR
Visual Basic
Public Const FRAME_SECONDARY_ANGLE_VECTOR As UInteger
Visual C++
public:
literal unsigned int FRAME_SECONDARY_ANGLE_VECTOR

See Also

MCdicom Structure
MCdicom Members


FRAME_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_TIME Field
MCdicom Structure See Also Send Feedback
Frame Time (0018,1063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_TIME
Visual Basic
Public Const FRAME_TIME As UInteger
Visual C++
public:
literal unsigned int FRAME_TIME

See Also

MCdicom Structure
MCdicom Members


FRAME_TIME_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_TIME_VECTOR Field
MCdicom Structure See Also Send Feedback
Frame Time Vector (0018,1065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_TIME_VECTOR
Visual Basic
Public Const FRAME_TIME_VECTOR As UInteger
Visual C++
public:
literal unsigned int FRAME_TIME_VECTOR

See Also

MCdicom Structure
MCdicom Members


FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_TYPE Field
MCdicom Structure See Also Send Feedback
Frame Type (0008,9007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_TYPE
Visual Basic
Public Const FRAME_TYPE As UInteger
Visual C++
public:
literal unsigned int FRAME_TYPE

See Also

MCdicom Structure
MCdicom Members


FRAME_USEFULNESS_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_USEFULNESS_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame Usefulness Group Sequence (0034,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_USEFULNESS_GROUP_SEQUENCE
Visual Basic
Public Const FRAME_USEFULNESS_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_USEFULNESS_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAME_VOI_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAME_VOI_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frame VOI LUT Sequence (0028,9132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAME_VOI_LUT_SEQUENCE
Visual Basic
Public Const FRAME_VOI_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FRAME_VOI_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FRAMES_OF_INTEREST_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAMES_OF_INTEREST_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Alias for tag FRAME_OF_INTEREST_DESCRIPTION (0028,6022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAMES_OF_INTEREST_DESCRIPTION
Visual Basic
Public Const FRAMES_OF_INTEREST_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int FRAMES_OF_INTEREST_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


FRAMING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FRAMING_TYPE Field
MCdicom Structure See Also Send Feedback
Alias for tag CARDIAC_FRAMING_TYPE (0018,1064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FRAMING_TYPE
Visual Basic
Public Const FRAMING_TYPE As UInteger
Visual C++
public:
literal unsigned int FRAMING_TYPE

See Also

MCdicom Structure
MCdicom Members


FREQUENCY_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FREQUENCY_CORRECTION Field
MCdicom Structure See Also Send Feedback
Frequency Correction (0018,9101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FREQUENCY_CORRECTION
Visual Basic
Public Const FREQUENCY_CORRECTION As UInteger
Visual C++
public:
literal unsigned int FREQUENCY_CORRECTION

See Also

MCdicom Structure
MCdicom Members


FREQUENCY_ENCODING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FREQUENCY_ENCODING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Frequency Encoding Code Sequence (003A,032C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FREQUENCY_ENCODING_CODE_SEQUENCE
Visual Basic
Public Const FREQUENCY_ENCODING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FREQUENCY_ENCODING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FUNCTIONAL_GROUP_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FUNCTIONAL_GROUP_POINTER Field
MCdicom Structure See Also Send Feedback
Functional Group Pointer (0020,9167)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FUNCTIONAL_GROUP_POINTER
Visual Basic
Public Const FUNCTIONAL_GROUP_POINTER As UInteger
Visual C++
public:
literal unsigned int FUNCTIONAL_GROUP_POINTER

See Also

MCdicom Structure
MCdicom Members


FUNCTIONAL_GROUP_PRIVATE_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FUNCTIONAL_GROUP_PRIVATE_CREATOR Field
MCdicom Structure See Also Send Feedback
Functional Group Private Creator (0020,9238)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FUNCTIONAL_GROUP_PRIVATE_CREATOR
Visual Basic
Public Const FUNCTIONAL_GROUP_PRIVATE_CREATOR As UInteger
Visual C++
public:
literal unsigned int FUNCTIONAL_GROUP_PRIVATE_CREATOR

See Also

MCdicom Structure
MCdicom Members


FUNCTIONAL_MR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FUNCTIONAL_MR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Functional MR Sequence (0018,9621)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FUNCTIONAL_MR_SEQUENCE
Visual Basic
Public Const FUNCTIONAL_MR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int FUNCTIONAL_MR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT Field
MCdicom Structure See Also Send Feedback
Functional Settling Phase Frames Present (0018,9622)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT
Visual Basic
Public Const FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT As UInteger
Visual C++
public:
literal unsigned int FUNCTIONAL_SETTLING_PHASE_FRAMES_PRESENT

See Also

MCdicom Structure
MCdicom Members


FUNCTIONAL_SYNC_PULSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..FUNCTIONAL_SYNC_PULSE Field
MCdicom Structure See Also Send Feedback
Functional Sync Pulse (0018,9623)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint FUNCTIONAL_SYNC_PULSE
Visual Basic
Public Const FUNCTIONAL_SYNC_PULSE As UInteger
Visual C++
public:
literal unsigned int FUNCTIONAL_SYNC_PULSE

See Also

MCdicom Structure
MCdicom Members


GAIN_CONTROL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GAIN_CONTROL Field
MCdicom Structure See Also Send Feedback
Gain Control (0016,0047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GAIN_CONTROL
Visual Basic
Public Const GAIN_CONTROL As UInteger
Visual C++
public:
literal unsigned int GAIN_CONTROL

See Also

MCdicom Structure
MCdicom Members


GAIN_CORRECTION_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GAIN_CORRECTION_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Gain Correction Reference Sequence (0014,3060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GAIN_CORRECTION_REFERENCE_SEQUENCE
Visual Basic
Public Const GAIN_CORRECTION_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GAIN_CORRECTION_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GAMMA_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GAMMA_VALUE Field
MCdicom Structure See Also Send Feedback
Gamma Value (0028,701A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GAMMA_VALUE
Visual Basic
Public Const GAMMA_VALUE As UInteger
Visual C++
public:
literal unsigned int GAMMA_VALUE

See Also

MCdicom Structure
MCdicom Members


GANTRY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_ANGLE Field
MCdicom Structure See Also Send Feedback
Gantry Angle (300A,011E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_ANGLE
Visual Basic
Public Const GANTRY_ANGLE As UInteger
Visual C++
public:
literal unsigned int GANTRY_ANGLE

See Also

MCdicom Structure
MCdicom Members


GANTRY_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Gantry Angle Tolerance (300A,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_ANGLE_TOLERANCE
Visual Basic
Public Const GANTRY_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int GANTRY_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


GANTRY_DETECTOR_SLEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_DETECTOR_SLEW Field
MCdicom Structure See Also Send Feedback
Gantry/Detector Slew (0018,1121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_DETECTOR_SLEW
Visual Basic
Public Const GANTRY_DETECTOR_SLEW As UInteger
Visual C++
public:
literal unsigned int GANTRY_DETECTOR_SLEW

See Also

MCdicom Structure
MCdicom Members


GANTRY_DETECTOR_TILT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_DETECTOR_TILT Field
MCdicom Structure See Also Send Feedback
Gantry/Detector Tilt (0018,1120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_DETECTOR_TILT
Visual Basic
Public Const GANTRY_DETECTOR_TILT As UInteger
Visual C++
public:
literal unsigned int GANTRY_DETECTOR_TILT

See Also

MCdicom Structure
MCdicom Members


GANTRY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_ID Field
MCdicom Structure See Also Send Feedback
Gantry ID (0018,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_ID
Visual Basic
Public Const GANTRY_ID As UInteger
Visual C++
public:
literal unsigned int GANTRY_ID

See Also

MCdicom Structure
MCdicom Members


GANTRY_MOTION_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_MOTION_CORRECTED Field
MCdicom Structure See Also Send Feedback
Gantry Motion Corrected (0018,9762)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_MOTION_CORRECTED
Visual Basic
Public Const GANTRY_MOTION_CORRECTED As UInteger
Visual C++
public:
literal unsigned int GANTRY_MOTION_CORRECTED

See Also

MCdicom Structure
MCdicom Members


GANTRY_PITCH_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_PITCH_ANGLE Field
MCdicom Structure See Also Send Feedback
Gantry Pitch Angle (300A,014A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_PITCH_ANGLE
Visual Basic
Public Const GANTRY_PITCH_ANGLE As UInteger
Visual C++
public:
literal unsigned int GANTRY_PITCH_ANGLE

See Also

MCdicom Structure
MCdicom Members


GANTRY_PITCH_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_PITCH_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Gantry Pitch Angle Tolerance (300A,014E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_PITCH_ANGLE_TOLERANCE
Visual Basic
Public Const GANTRY_PITCH_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int GANTRY_PITCH_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


GANTRY_PITCH_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_PITCH_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Gantry Pitch Rotation Direction (300A,014C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_PITCH_ROTATION_DIRECTION
Visual Basic
Public Const GANTRY_PITCH_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int GANTRY_PITCH_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


GANTRY_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Gantry Rotation Direction (300A,011F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_ROTATION_DIRECTION
Visual Basic
Public Const GANTRY_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int GANTRY_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


GANTRY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GANTRY_TYPE Field
MCdicom Structure See Also Send Feedback
Gantry Type (4010,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GANTRY_TYPE
Visual Basic
Public Const GANTRY_TYPE As UInteger
Visual C++
public:
literal unsigned int GANTRY_TYPE

See Also

MCdicom Structure
MCdicom Members


GAP_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GAP_LENGTH Field
MCdicom Structure See Also Send Feedback
Gap Length (0070,0261)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GAP_LENGTH
Visual Basic
Public Const GAP_LENGTH As UInteger
Visual C++
public:
literal unsigned int GAP_LENGTH

See Also

MCdicom Structure
MCdicom Members


GATE_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GATE_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Gate Settings Sequence (0014,4060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GATE_SETTINGS_SEQUENCE
Visual Basic
Public Const GATE_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GATE_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GATE_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GATE_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Gate Threshold (0014,4062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GATE_THRESHOLD
Visual Basic
Public Const GATE_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int GATE_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


GATED_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GATED_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Gated Information Sequence (0054,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GATED_INFORMATION_SEQUENCE
Visual Basic
Public Const GATED_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GATED_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GATING_BEAM_HOLD_TRANSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GATING_BEAM_HOLD_TRANSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Gating Beam Hold Transition Sequence (300C,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GATING_BEAM_HOLD_TRANSITION_SEQUENCE
Visual Basic
Public Const GATING_BEAM_HOLD_TRANSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GATING_BEAM_HOLD_TRANSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
General Accessory Definition Sequence (300A,0671)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_DEFINITION_SEQUENCE
Visual Basic
Public Const GENERAL_ACCESSORY_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
General Accessory Description (300A,0422)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_DESCRIPTION
Visual Basic
Public Const GENERAL_ACCESSORY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_ID Field
MCdicom Structure See Also Send Feedback
General Accessory ID (300A,0421)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_ID
Visual Basic
Public Const GENERAL_ACCESSORY_ID As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_ID

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_NUMBER Field
MCdicom Structure See Also Send Feedback
General Accessory Number (300A,0424)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_NUMBER
Visual Basic
Public Const GENERAL_ACCESSORY_NUMBER As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_NUMBER

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
General Accessory Sequence (300A,0420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_SEQUENCE
Visual Basic
Public Const GENERAL_ACCESSORY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERAL_ACCESSORY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_ACCESSORY_TYPE Field
MCdicom Structure See Also Send Feedback
General Accessory Type (300A,0423)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_ACCESSORY_TYPE
Visual Basic
Public Const GENERAL_ACCESSORY_TYPE As UInteger
Visual C++
public:
literal unsigned int GENERAL_ACCESSORY_TYPE

See Also

MCdicom Structure
MCdicom Members


GENERAL_MACHINE_VERIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_MACHINE_VERIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
General Machine Verification Sequence (0074,1042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_MACHINE_VERIFICATION_SEQUENCE
Visual Basic
Public Const GENERAL_MACHINE_VERIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENERAL_MACHINE_VERIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERAL_MATCHING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_MATCHING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
General Matching Sequence (0008,0413)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_MATCHING_SEQUENCE
Visual Basic
Public Const GENERAL_MATCHING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENERAL_MATCHING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED Field
MCdicom Structure See Also Send Feedback
General Purpose Performed Procedure Step Status RETIRED (0040,4002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED
Visual Basic
Public Const GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED As UInteger
Visual C++
public:
literal unsigned int GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEP_STATUS_RETIRED

See Also

MCdicom Structure
MCdicom Members


GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED Field
MCdicom Structure See Also Send Feedback
General Purpose Scheduled Procedure Step Priority RETIRED (0040,4003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED
Visual Basic
Public Const GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED As UInteger
Visual C++
public:
literal unsigned int GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_PRIORITY_RETIRED

See Also

MCdicom Structure
MCdicom Members


GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED Field
MCdicom Structure See Also Send Feedback
General Purpose Scheduled Procedure Step Status RETIRED (0040,4001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED
Visual Basic
Public Const GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED As UInteger
Visual C++
public:
literal unsigned int GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_STATUS_RETIRED

See Also

MCdicom Structure
MCdicom Members


GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG Field
MCdicom Structure See Also Send Feedback
Generalized Defect Corrected Sensitivity Deviation Flag (0024,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG
Visual Basic
Public Const GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG As UInteger
Visual C++
public:
literal unsigned int GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_FLAG

See Also

MCdicom Structure
MCdicom Members


GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE Field
MCdicom Structure See Also Send Feedback
Generalized Defect Corrected Sensitivity Deviation Probability Value (0024,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE
Visual Basic
Public Const GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE As UInteger
Visual C++
public:
literal unsigned int GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_PROBABILITY_VALUE

See Also

MCdicom Structure
MCdicom Members


GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE Field
MCdicom Structure See Also Send Feedback
Generalized Defect Corrected Sensitivity Deviation Value (0024,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE
Visual Basic
Public Const GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE As UInteger
Visual C++
public:
literal unsigned int GENERALIZED_DEFECT_CORRECTED_SENSITIVITY_DEVIATION_VALUE

See Also

MCdicom Structure
MCdicom Members


GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Generalized Defect Sensitivity Deviation Algorithm Sequence (0024,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE
Visual Basic
Public Const GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENERATOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERATOR_ID Field
MCdicom Structure See Also Send Feedback
Generator ID (0018,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERATOR_ID
Visual Basic
Public Const GENERATOR_ID As UInteger
Visual C++
public:
literal unsigned int GENERATOR_ID

See Also

MCdicom Structure
MCdicom Members


GENERATOR_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENERATOR_POWER Field
MCdicom Structure See Also Send Feedback
Generator Power (0018,1170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENERATOR_POWER
Visual Basic
Public Const GENERATOR_POWER As UInteger
Visual C++
public:
literal unsigned int GENERATOR_POWER

See Also

MCdicom Structure
MCdicom Members


GENETIC_MODIFICATIONS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENETIC_MODIFICATIONS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Genetic Modifications Code Sequence (0010,0229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENETIC_MODIFICATIONS_CODE_SEQUENCE
Visual Basic
Public Const GENETIC_MODIFICATIONS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENETIC_MODIFICATIONS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GENETIC_MODIFICATIONS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENETIC_MODIFICATIONS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Genetic Modifications Description (0010,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENETIC_MODIFICATIONS_DESCRIPTION
Visual Basic
Public Const GENETIC_MODIFICATIONS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int GENETIC_MODIFICATIONS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


GENETIC_MODIFICATIONS_NOMENCLATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENETIC_MODIFICATIONS_NOMENCLATURE Field
MCdicom Structure See Also Send Feedback
Genetic Modifications Nomenclature (0010,0223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENETIC_MODIFICATIONS_NOMENCLATURE
Visual Basic
Public Const GENETIC_MODIFICATIONS_NOMENCLATURE As UInteger
Visual C++
public:
literal unsigned int GENETIC_MODIFICATIONS_NOMENCLATURE

See Also

MCdicom Structure
MCdicom Members


GENETIC_MODIFICATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GENETIC_MODIFICATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Genetic Modifications Sequence (0010,0221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GENETIC_MODIFICATIONS_SEQUENCE
Visual Basic
Public Const GENETIC_MODIFICATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GENETIC_MODIFICATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GEOMETRIC_MAXIMUM_DISTORTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GEOMETRIC_MAXIMUM_DISTORTION Field
MCdicom Structure See Also Send Feedback
Geometric Maximum Distortion (0028,9445)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GEOMETRIC_MAXIMUM_DISTORTION
Visual Basic
Public Const GEOMETRIC_MAXIMUM_DISTORTION As UInteger
Visual C++
public:
literal unsigned int GEOMETRIC_MAXIMUM_DISTORTION

See Also

MCdicom Structure
MCdicom Members


GEOMETRICAL_PROPERTIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GEOMETRICAL_PROPERTIES Field
MCdicom Structure See Also Send Feedback
Geometrical Properties (0028,9444)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GEOMETRICAL_PROPERTIES
Visual Basic
Public Const GEOMETRICAL_PROPERTIES As UInteger
Visual C++
public:
literal unsigned int GEOMETRICAL_PROPERTIES

See Also

MCdicom Structure
MCdicom Members


GEOMETRY_FOR_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GEOMETRY_FOR_DISPLAY Field
MCdicom Structure See Also Send Feedback
Geometry for Display (0070,1B08)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GEOMETRY_FOR_DISPLAY
Visual Basic
Public Const GEOMETRY_FOR_DISPLAY As UInteger
Visual C++
public:
literal unsigned int GEOMETRY_FOR_DISPLAY

See Also

MCdicom Structure
MCdicom Members


GEOMETRY_OF_K_SPACE_TRAVERSAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GEOMETRY_OF_K_SPACE_TRAVERSAL Field
MCdicom Structure See Also Send Feedback
Geometry of k-Space Traversal (0018,9032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GEOMETRY_OF_K_SPACE_TRAVERSAL
Visual Basic
Public Const GEOMETRY_OF_K_SPACE_TRAVERSAL As UInteger
Visual C++
public:
literal unsigned int GEOMETRY_OF_K_SPACE_TRAVERSAL

See Also

MCdicom Structure
MCdicom Members


GLOBAL_CROP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_CROP Field
MCdicom Structure See Also Send Feedback
Global Crop (0070,120B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_CROP
Visual Basic
Public Const GLOBAL_CROP As UInteger
Visual C++
public:
literal unsigned int GLOBAL_CROP

See Also

MCdicom Structure
MCdicom Members


GLOBAL_CROPPING_SPECIFICATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_CROPPING_SPECIFICATION_INDEX Field
MCdicom Structure See Also Send Feedback
Global Cropping Specification Index (0070,120C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_CROPPING_SPECIFICATION_INDEX
Visual Basic
Public Const GLOBAL_CROPPING_SPECIFICATION_INDEX As UInteger
Visual C++
public:
literal unsigned int GLOBAL_CROPPING_SPECIFICATION_INDEX

See Also

MCdicom Structure
MCdicom Members


GLOBAL_DEVIATION_FROM_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_DEVIATION_FROM_NORMAL Field
MCdicom Structure See Also Send Feedback
Global Deviation From Normal (0024,0066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_DEVIATION_FROM_NORMAL
Visual Basic
Public Const GLOBAL_DEVIATION_FROM_NORMAL As UInteger
Visual C++
public:
literal unsigned int GLOBAL_DEVIATION_FROM_NORMAL

See Also

MCdicom Structure
MCdicom Members


GLOBAL_DEVIATION_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_DEVIATION_PROBABILITY Field
MCdicom Structure See Also Send Feedback
Global Deviation Probability (0024,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_DEVIATION_PROBABILITY
Visual Basic
Public Const GLOBAL_DEVIATION_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int GLOBAL_DEVIATION_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG Field
MCdicom Structure See Also Send Feedback
Global Deviation Probability Normals Flag (0024,0059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG
Visual Basic
Public Const GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG As UInteger
Visual C++
public:
literal unsigned int GLOBAL_DEVIATION_PROBABILITY_NORMALS_FLAG

See Also

MCdicom Structure
MCdicom Members


GLOBAL_DEVIATION_PROBABILITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GLOBAL_DEVIATION_PROBABILITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Global Deviation Probability Sequence (0024,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GLOBAL_DEVIATION_PROBABILITY_SEQUENCE
Visual Basic
Public Const GLOBAL_DEVIATION_PROBABILITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GLOBAL_DEVIATION_PROBABILITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GPS_ALTITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_ALTITUDE Field
MCdicom Structure See Also Send Feedback
GPS Altitude (0016,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_ALTITUDE
Visual Basic
Public Const GPS_ALTITUDE As UInteger
Visual C++
public:
literal unsigned int GPS_ALTITUDE

See Also

MCdicom Structure
MCdicom Members


GPS_ALTITUDE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_ALTITUDE_REF Field
MCdicom Structure See Also Send Feedback
GPS Altitude Ref (0016,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_ALTITUDE_REF
Visual Basic
Public Const GPS_ALTITUDE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_ALTITUDE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_AREA_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_AREA_INFORMATION Field
MCdicom Structure See Also Send Feedback
GPS Area Information (0016,008C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_AREA_INFORMATION
Visual Basic
Public Const GPS_AREA_INFORMATION As UInteger
Visual C++
public:
literal unsigned int GPS_AREA_INFORMATION

See Also

MCdicom Structure
MCdicom Members


GPS_DATE_STAMP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DATE_STAMP Field
MCdicom Structure See Also Send Feedback
GPS Date Stamp (0016,008D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DATE_STAMP
Visual Basic
Public Const GPS_DATE_STAMP As UInteger
Visual C++
public:
literal unsigned int GPS_DATE_STAMP

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_BEARING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_BEARING Field
MCdicom Structure See Also Send Feedback
GPS Dest Bearing (0016,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_BEARING
Visual Basic
Public Const GPS_DEST_BEARING As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_BEARING

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_BEARING_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_BEARING_REF Field
MCdicom Structure See Also Send Feedback
GPS Dest Bearing Ref (0016,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_BEARING_REF
Visual Basic
Public Const GPS_DEST_BEARING_REF As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_BEARING_REF

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_DISTANCE Field
MCdicom Structure See Also Send Feedback
GPS Dest Distance (0016,008A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_DISTANCE
Visual Basic
Public Const GPS_DEST_DISTANCE As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_DISTANCE

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_DISTANCE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_DISTANCE_REF Field
MCdicom Structure See Also Send Feedback
GPS Dest Distance Ref (0016,0089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_DISTANCE_REF
Visual Basic
Public Const GPS_DEST_DISTANCE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_DISTANCE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_LATITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_LATITUDE Field
MCdicom Structure See Also Send Feedback
GPS Dest Latitude (0016,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_LATITUDE
Visual Basic
Public Const GPS_DEST_LATITUDE As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_LATITUDE

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_LATITUDE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_LATITUDE_REF Field
MCdicom Structure See Also Send Feedback
GPS Dest Latitude Ref (0016,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_LATITUDE_REF
Visual Basic
Public Const GPS_DEST_LATITUDE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_LATITUDE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_LONGITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_LONGITUDE Field
MCdicom Structure See Also Send Feedback
GPS Dest Longitude (0016,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_LONGITUDE
Visual Basic
Public Const GPS_DEST_LONGITUDE As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_LONGITUDE

See Also

MCdicom Structure
MCdicom Members


GPS_DEST_LONGITUDE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DEST_LONGITUDE_REF Field
MCdicom Structure See Also Send Feedback
GPS Dest Longitude Ref (0016,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DEST_LONGITUDE_REF
Visual Basic
Public Const GPS_DEST_LONGITUDE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_DEST_LONGITUDE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_DIFFERENTIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DIFFERENTIAL Field
MCdicom Structure See Also Send Feedback
GPS Differential (0016,008E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DIFFERENTIAL
Visual Basic
Public Const GPS_DIFFERENTIAL As UInteger
Visual C++
public:
literal unsigned int GPS_DIFFERENTIAL

See Also

MCdicom Structure
MCdicom Members


GPS_DOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_DOP Field
MCdicom Structure See Also Send Feedback
GPS DOP (0016,007B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_DOP
Visual Basic
Public Const GPS_DOP As UInteger
Visual C++
public:
literal unsigned int GPS_DOP

See Also

MCdicom Structure
MCdicom Members


GPS_IMG_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_IMG_DIRECTION Field
MCdicom Structure See Also Send Feedback
GPS Img Direction (0016,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_IMG_DIRECTION
Visual Basic
Public Const GPS_IMG_DIRECTION As UInteger
Visual C++
public:
literal unsigned int GPS_IMG_DIRECTION

See Also

MCdicom Structure
MCdicom Members


GPS_IMG_DIRECTION_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_IMG_DIRECTION_REF Field
MCdicom Structure See Also Send Feedback
GPS Img Direction Ref (0016,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_IMG_DIRECTION_REF
Visual Basic
Public Const GPS_IMG_DIRECTION_REF As UInteger
Visual C++
public:
literal unsigned int GPS_IMG_DIRECTION_REF

See Also

MCdicom Structure
MCdicom Members


GPS_LATITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_LATITUDE Field
MCdicom Structure See Also Send Feedback
GPS Latitude (0016,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_LATITUDE
Visual Basic
Public Const GPS_LATITUDE As UInteger
Visual C++
public:
literal unsigned int GPS_LATITUDE

See Also

MCdicom Structure
MCdicom Members


GPS_LATITUDE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_LATITUDE_REF Field
MCdicom Structure See Also Send Feedback
GPS Latitude Ref (0016,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_LATITUDE_REF
Visual Basic
Public Const GPS_LATITUDE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_LATITUDE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_LONGITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_LONGITUDE Field
MCdicom Structure See Also Send Feedback
GPS Longitude (0016,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_LONGITUDE
Visual Basic
Public Const GPS_LONGITUDE As UInteger
Visual C++
public:
literal unsigned int GPS_LONGITUDE

See Also

MCdicom Structure
MCdicom Members


GPS_LONGITUDE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_LONGITUDE_REF Field
MCdicom Structure See Also Send Feedback
GPS Longitude Ref (0016,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_LONGITUDE_REF
Visual Basic
Public Const GPS_LONGITUDE_REF As UInteger
Visual C++
public:
literal unsigned int GPS_LONGITUDE_REF

See Also

MCdicom Structure
MCdicom Members


GPS_MAP_DATUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_MAP_DATUM Field
MCdicom Structure See Also Send Feedback
GPS Map Datum (0016,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_MAP_DATUM
Visual Basic
Public Const GPS_MAP_DATUM As UInteger
Visual C++
public:
literal unsigned int GPS_MAP_DATUM

See Also

MCdicom Structure
MCdicom Members


GPS_MEASURE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_MEASURE_MODE Field
MCdicom Structure See Also Send Feedback
GPS Measure Mode (0016,007A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_MEASURE_MODE
Visual Basic
Public Const GPS_MEASURE_MODE As UInteger
Visual C++
public:
literal unsigned int GPS_MEASURE_MODE

See Also

MCdicom Structure
MCdicom Members


GPS_PROCESSING_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_PROCESSING_METHOD Field
MCdicom Structure See Also Send Feedback
GPS Processing Method (0016,008B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_PROCESSING_METHOD
Visual Basic
Public Const GPS_PROCESSING_METHOD As UInteger
Visual C++
public:
literal unsigned int GPS_PROCESSING_METHOD

See Also

MCdicom Structure
MCdicom Members


GPS_SATELLITES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_SATELLITES Field
MCdicom Structure See Also Send Feedback
GPS Satellites (0016,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_SATELLITES
Visual Basic
Public Const GPS_SATELLITES As UInteger
Visual C++
public:
literal unsigned int GPS_SATELLITES

See Also

MCdicom Structure
MCdicom Members


GPS_SPEED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_SPEED Field
MCdicom Structure See Also Send Feedback
GPS Speed (0016,007D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_SPEED
Visual Basic
Public Const GPS_SPEED As UInteger
Visual C++
public:
literal unsigned int GPS_SPEED

See Also

MCdicom Structure
MCdicom Members


GPS_SPEED_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_SPEED_REF Field
MCdicom Structure See Also Send Feedback
GPS Speed Ref (0016,007C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_SPEED_REF
Visual Basic
Public Const GPS_SPEED_REF As UInteger
Visual C++
public:
literal unsigned int GPS_SPEED_REF

See Also

MCdicom Structure
MCdicom Members


GPS_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_STATUS Field
MCdicom Structure See Also Send Feedback
GPS Status (0016,0079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_STATUS
Visual Basic
Public Const GPS_STATUS As UInteger
Visual C++
public:
literal unsigned int GPS_STATUS

See Also

MCdicom Structure
MCdicom Members


GPS_TIME_STAMP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_TIME_STAMP Field
MCdicom Structure See Also Send Feedback
GPS Time Stamp (0016,0077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_TIME_STAMP
Visual Basic
Public Const GPS_TIME_STAMP As UInteger
Visual C++
public:
literal unsigned int GPS_TIME_STAMP

See Also

MCdicom Structure
MCdicom Members


GPS_TRACK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_TRACK Field
MCdicom Structure See Also Send Feedback
GPS Track (0016,007F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_TRACK
Visual Basic
Public Const GPS_TRACK As UInteger
Visual C++
public:
literal unsigned int GPS_TRACK

See Also

MCdicom Structure
MCdicom Members


GPS_TRACK_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_TRACK_REF Field
MCdicom Structure See Also Send Feedback
GPS Track Ref (0016,007E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_TRACK_REF
Visual Basic
Public Const GPS_TRACK_REF As UInteger
Visual C++
public:
literal unsigned int GPS_TRACK_REF

See Also

MCdicom Structure
MCdicom Members


GPS_VERSION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GPS_VERSION_ID Field
MCdicom Structure See Also Send Feedback
GPS Version ID (0016,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GPS_VERSION_ID
Visual Basic
Public Const GPS_VERSION_ID As UInteger
Visual C++
public:
literal unsigned int GPS_VERSION_ID

See Also

MCdicom Structure
MCdicom Members


GRADIENT_ECHO_TRAIN_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRADIENT_ECHO_TRAIN_LENGTH Field
MCdicom Structure See Also Send Feedback
Gradient Echo Train Length (0018,9241)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRADIENT_ECHO_TRAIN_LENGTH
Visual Basic
Public Const GRADIENT_ECHO_TRAIN_LENGTH As UInteger
Visual C++
public:
literal unsigned int GRADIENT_ECHO_TRAIN_LENGTH

See Also

MCdicom Structure
MCdicom Members


GRADIENT_OUTPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRADIENT_OUTPUT Field
MCdicom Structure See Also Send Feedback
Gradient Output (0018,9182)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRADIENT_OUTPUT
Visual Basic
Public Const GRADIENT_OUTPUT As UInteger
Visual C++
public:
literal unsigned int GRADIENT_OUTPUT

See Also

MCdicom Structure
MCdicom Members


GRADIENT_OUTPUT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRADIENT_OUTPUT_TYPE Field
MCdicom Structure See Also Send Feedback
Gradient Output Type (0018,9180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRADIENT_OUTPUT_TYPE
Visual Basic
Public Const GRADIENT_OUTPUT_TYPE As UInteger
Visual C++
public:
literal unsigned int GRADIENT_OUTPUT_TYPE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Graphic Annotation Sequence (0070,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_ANNOTATION_SEQUENCE
Visual Basic
Public Const GRAPHIC_ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_ANNOTATION_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_ANNOTATION_UNITS Field
MCdicom Structure See Also Send Feedback
Graphic Annotation Units (0070,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_ANNOTATION_UNITS
Visual Basic
Public Const GRAPHIC_ANNOTATION_UNITS As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_ANNOTATION_UNITS

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_COORDINATES_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_COORDINATES_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Graphic Coordinates Data Sequence (0070,0318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_COORDINATES_DATA_SEQUENCE
Visual Basic
Public Const GRAPHIC_COORDINATES_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_COORDINATES_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_DATA Field
MCdicom Structure See Also Send Feedback
Graphic Data (0070,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_DATA
Visual Basic
Public Const GRAPHIC_DATA As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_DATA

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_DIMENSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_DIMENSIONS Field
MCdicom Structure See Also Send Feedback
Graphic Dimensions (0070,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_DIMENSIONS
Visual Basic
Public Const GRAPHIC_DIMENSIONS As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_DIMENSIONS

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_FILLED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_FILLED Field
MCdicom Structure See Also Send Feedback
Graphic Filled (0070,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_FILLED
Visual Basic
Public Const GRAPHIC_FILLED As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_FILLED

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_GROUP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_GROUP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Graphic Group Description (0070,0208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_GROUP_DESCRIPTION
Visual Basic
Public Const GRAPHIC_GROUP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_GROUP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_GROUP_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_GROUP_ID Field
MCdicom Structure See Also Send Feedback
Graphic Group ID (0070,0295)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_GROUP_ID
Visual Basic
Public Const GRAPHIC_GROUP_ID As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_GROUP_ID

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_GROUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_GROUP_LABEL Field
MCdicom Structure See Also Send Feedback
Graphic Group Label (0070,0207)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_GROUP_LABEL
Visual Basic
Public Const GRAPHIC_GROUP_LABEL As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_GROUP_LABEL

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Graphic Group Sequence (0070,0234)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_GROUP_SEQUENCE
Visual Basic
Public Const GRAPHIC_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER Field
MCdicom Structure See Also Send Feedback
Graphic Layer (0070,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER
Visual Basic
Public Const GRAPHIC_LAYER As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Graphic Layer Description (0070,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_DESCRIPTION
Visual Basic
Public Const GRAPHIC_LAYER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_ORDER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_ORDER Field
MCdicom Structure See Also Send Feedback
Graphic Layer Order (0070,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_ORDER
Visual Basic
Public Const GRAPHIC_LAYER_ORDER As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_ORDER

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Graphic Layer Recommended Display CIELab Value (0070,0401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE
Visual Basic
Public Const GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_RECOMMENDED_DISPLAY_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE Field
MCdicom Structure See Also Send Feedback
Graphic Layer Recommended Display Grayscale Value (0070,0066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE
Visual Basic
Public Const GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_RECOMMENDED_DISPLAY_GRAYSCALE_VALUE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Graphic Layer Recommended Display RGB Value RETIRED (0070,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED
Visual Basic
Public Const GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_RECOMMENDED_DISPLAY_RGB_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_LAYER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_LAYER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Graphic Layer Sequence (0070,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_LAYER_SEQUENCE
Visual Basic
Public Const GRAPHIC_LAYER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_LAYER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_OBJECT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_OBJECT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Graphic Object Sequence (0070,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_OBJECT_SEQUENCE
Visual Basic
Public Const GRAPHIC_OBJECT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_OBJECT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


GRAPHIC_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAPHIC_TYPE Field
MCdicom Structure See Also Send Feedback
Graphic Type (0070,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAPHIC_TYPE
Visual Basic
Public Const GRAPHIC_TYPE As UInteger
Visual C++
public:
literal unsigned int GRAPHIC_TYPE

See Also

MCdicom Structure
MCdicom Members


GRAY_LOOKUP_TABLE_DATA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAY_LOOKUP_TABLE_DATA_RETIRED Field
MCdicom Structure See Also Send Feedback
Gray Lookup Table Data RETIRED (0028,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAY_LOOKUP_TABLE_DATA_RETIRED
Visual Basic
Public Const GRAY_LOOKUP_TABLE_DATA_RETIRED As UInteger
Visual C++
public:
literal unsigned int GRAY_LOOKUP_TABLE_DATA_RETIRED

See Also

MCdicom Structure
MCdicom Members


GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Gray Lookup Table Descriptor RETIRED (0028,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED
Visual Basic
Public Const GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int GRAY_LOOKUP_TABLE_DESCRIPTOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


GRAY_SCALE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRAY_SCALE_RETIRED Field
MCdicom Structure See Also Send Feedback
Gray Scale RETIRED (0028,1080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRAY_SCALE_RETIRED
Visual Basic
Public Const GRAY_SCALE_RETIRED As UInteger
Visual C++
public:
literal unsigned int GRAY_SCALE_RETIRED

See Also

MCdicom Structure
MCdicom Members


GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Green Palette Color Lookup Table Data (0028,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Green Palette Color Lookup Table Descriptor (0028,1102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int GREEN_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


GRID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID Field
MCdicom Structure See Also Send Feedback
Grid (0018,1166)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID
Visual Basic
Public Const GRID As UInteger
Visual C++
public:
literal unsigned int GRID

See Also

MCdicom Structure
MCdicom Members


GRID_ABSORBING_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_ABSORBING_MATERIAL Field
MCdicom Structure See Also Send Feedback
Grid Absorbing Material (0018,7040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_ABSORBING_MATERIAL
Visual Basic
Public Const GRID_ABSORBING_MATERIAL As UInteger
Visual C++
public:
literal unsigned int GRID_ABSORBING_MATERIAL

See Also

MCdicom Structure
MCdicom Members


GRID_ASPECT_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_ASPECT_RATIO Field
MCdicom Structure See Also Send Feedback
Grid Aspect Ratio (0018,7046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_ASPECT_RATIO
Visual Basic
Public Const GRID_ASPECT_RATIO As UInteger
Visual C++
public:
literal unsigned int GRID_ASPECT_RATIO

See Also

MCdicom Structure
MCdicom Members


GRID_DIMENSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_DIMENSIONS Field
MCdicom Structure See Also Send Feedback
Grid Dimensions (0064,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_DIMENSIONS
Visual Basic
Public Const GRID_DIMENSIONS As UInteger
Visual C++
public:
literal unsigned int GRID_DIMENSIONS

See Also

MCdicom Structure
MCdicom Members


GRID_FOCAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_FOCAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
Grid Focal Distance (0018,704C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_FOCAL_DISTANCE
Visual Basic
Public Const GRID_FOCAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int GRID_FOCAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


GRID_FRAME_OFFSET_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_FRAME_OFFSET_VECTOR Field
MCdicom Structure See Also Send Feedback
Grid Frame Offset Vector (3004,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_FRAME_OFFSET_VECTOR
Visual Basic
Public Const GRID_FRAME_OFFSET_VECTOR As UInteger
Visual C++
public:
literal unsigned int GRID_FRAME_OFFSET_VECTOR

See Also

MCdicom Structure
MCdicom Members


GRID_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_ID Field
MCdicom Structure See Also Send Feedback
Grid ID (0018,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_ID
Visual Basic
Public Const GRID_ID As UInteger
Visual C++
public:
literal unsigned int GRID_ID

See Also

MCdicom Structure
MCdicom Members


GRID_PERIOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_PERIOD Field
MCdicom Structure See Also Send Feedback
Grid Period (0018,7048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_PERIOD
Visual Basic
Public Const GRID_PERIOD As UInteger
Visual C++
public:
literal unsigned int GRID_PERIOD

See Also

MCdicom Structure
MCdicom Members


GRID_PITCH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_PITCH Field
MCdicom Structure See Also Send Feedback
Grid Pitch (0018,7044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_PITCH
Visual Basic
Public Const GRID_PITCH As UInteger
Visual C++
public:
literal unsigned int GRID_PITCH

See Also

MCdicom Structure
MCdicom Members


GRID_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Grid Resolution (0064,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_RESOLUTION
Visual Basic
Public Const GRID_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int GRID_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


GRID_SPACING_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_SPACING_MATERIAL Field
MCdicom Structure See Also Send Feedback
Grid Spacing Material (0018,7041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_SPACING_MATERIAL
Visual Basic
Public Const GRID_SPACING_MATERIAL As UInteger
Visual C++
public:
literal unsigned int GRID_SPACING_MATERIAL

See Also

MCdicom Structure
MCdicom Members


GRID_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GRID_THICKNESS Field
MCdicom Structure See Also Send Feedback
Grid Thickness (0018,7042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GRID_THICKNESS
Visual Basic
Public Const GRID_THICKNESS As UInteger
Visual C++
public:
literal unsigned int GRID_THICKNESS

See Also

MCdicom Structure
MCdicom Members


GROUP_0000_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0000_LENGTH Field
MCdicom Structure See Also Send Feedback
Alias for tag COMMAND_GROUP_LENGTH (0000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0000_LENGTH
Visual Basic
Public Const GROUP_0000_LENGTH As UInteger
Visual C++
public:
literal unsigned int GROUP_0000_LENGTH

See Also

MCdicom Structure
MCdicom Members


GROUP_0002_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0002_LENGTH Field
MCdicom Structure See Also Send Feedback
Alias for tag FILE_META_INFORMATION_GROUP_LENGTH (0002,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0002_LENGTH
Visual Basic
Public Const GROUP_0002_LENGTH As UInteger
Visual C++
public:
literal unsigned int GROUP_0002_LENGTH

See Also

MCdicom Structure
MCdicom Members


GROUP_0008_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0008_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0008 Length RETIRED (0008,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0008_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0008_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0008_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0010_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0010_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0010 Length RETIRED (0010,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0010_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0010_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0010_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0012_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0012_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0012 Length RETIRED (0012,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0012_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0012_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0012_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0018_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0018_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0018 Length RETIRED (0018,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0018_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0018_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0018_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0020_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0020_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0020 Length RETIRED (0020,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0020_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0020_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0020_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0022_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0022_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0022 Length RETIRED (0022,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0022_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0022_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0022_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0028_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0028_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0028 Length RETIRED (0028,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0028_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0028_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0028_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0032_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0032_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0032 Length RETIRED (0032,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0032_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0032_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0032_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0038_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0038_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0038 Length RETIRED (0038,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0038_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0038_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0038_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_003A_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_003A_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 003A Length RETIRED (003A,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_003A_LENGTH_RETIRED
Visual Basic
Public Const GROUP_003A_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_003A_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0040_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0040_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0040 Length RETIRED (0040,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0040_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0040_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0040_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0042_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0042_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0042 Length RETIRED (0042,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0042_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0042_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0042_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0044_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0044_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0044 Length RETIRED (0044,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0044_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0044_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0044_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0050_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0050_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0050 Length RETIRED (0050,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0050_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0050_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0050_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0054_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0054_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0054 Length RETIRED (0054,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0054_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0054_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0054_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0060_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0060_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0060 Length RETIRED (0060,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0060_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0060_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0060_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0062_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0062_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0062 Length RETIRED (0062,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0062_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0062_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0062_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0064_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0064_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0064 Length RETIRED (0064,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0064_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0064_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0064_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0070_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0070_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0070 Length RETIRED (0070,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0070_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0070_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0070_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0072_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0072_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0072 Length RETIRED (0072,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0072_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0072_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0072_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0088_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0088_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0088 Length RETIRED (0088,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0088_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0088_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0088_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0100_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0100_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0100 Length RETIRED (0100,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0100_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0100_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0100_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_0400_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_0400_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 0400 Length RETIRED (0400,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_0400_LENGTH_RETIRED
Visual Basic
Public Const GROUP_0400_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_0400_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2000_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2000_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2000 Length RETIRED (2000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2000_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2000_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2000_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2010_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2010_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2010 Length RETIRED (2010,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2010_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2010_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2010_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2020_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2020_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2020 Length RETIRED (2020,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2020_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2020_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2020_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2030_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2030_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2030 Length RETIRED (2030,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2030_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2030_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2030_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2040_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2040_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2040 Length RETIRED (2040,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2040_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2040_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2040_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2050_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2050_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2050 Length RETIRED (2050,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2050_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2050_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2050_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2100_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2100_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2100 Length RETIRED (2100,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2100_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2100_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2100_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2110_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2110_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2110 Length RETIRED (2110,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2110_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2110_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2110_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2120_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2120_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2120 Length RETIRED (2120,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2120_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2120_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2120_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2130_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2130_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2130 Length RETIRED (2130,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2130_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2130_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2130_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_2200_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_2200_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 2200 Length RETIRED (2200,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_2200_LENGTH_RETIRED
Visual Basic
Public Const GROUP_2200_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_2200_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_3002_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_3002_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 3002 Length RETIRED (3002,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_3002_LENGTH_RETIRED
Visual Basic
Public Const GROUP_3002_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_3002_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_3004_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_3004_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 3004 Length RETIRED (3004,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_3004_LENGTH_RETIRED
Visual Basic
Public Const GROUP_3004_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_3004_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_3006_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_3006_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 3006 Length RETIRED (3006,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_3006_LENGTH_RETIRED
Visual Basic
Public Const GROUP_3006_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_3006_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_3008_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_3008_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 3008 Length RETIRED (3008,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_3008_LENGTH_RETIRED
Visual Basic
Public Const GROUP_3008_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_3008_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_300A_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_300A_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 300A Length RETIRED (300A,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_300A_LENGTH_RETIRED
Visual Basic
Public Const GROUP_300A_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_300A_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_300C_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_300C_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 300C Length RETIRED (300C,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_300C_LENGTH_RETIRED
Visual Basic
Public Const GROUP_300C_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_300C_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_300E_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_300E_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 300E Length RETIRED (300E,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_300E_LENGTH_RETIRED
Visual Basic
Public Const GROUP_300E_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_300E_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_4000_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_4000_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 4000 Length RETIRED (4000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_4000_LENGTH_RETIRED
Visual Basic
Public Const GROUP_4000_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_4000_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_4008_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_4008_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 4008 Length RETIRED (4008,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_4008_LENGTH_RETIRED
Visual Basic
Public Const GROUP_4008_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_4008_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_4FFE_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_4FFE_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 4FFE Length RETIRED (4FFE,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_4FFE_LENGTH_RETIRED
Visual Basic
Public Const GROUP_4FFE_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_4FFE_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_5000_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_5000_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 5000 Length RETIRED (5000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_5000_LENGTH_RETIRED
Visual Basic
Public Const GROUP_5000_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_5000_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_5200_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_5200_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 5200 Length RETIRED (5200,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_5200_LENGTH_RETIRED
Visual Basic
Public Const GROUP_5200_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_5200_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_5400_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_5400_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 5400 Length RETIRED (5400,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_5400_LENGTH_RETIRED
Visual Basic
Public Const GROUP_5400_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_5400_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_5600_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_5600_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 5600 Length RETIRED (5600,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_5600_LENGTH_RETIRED
Visual Basic
Public Const GROUP_5600_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_5600_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_6000_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_6000_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 6000 Length RETIRED (6000,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_6000_LENGTH_RETIRED
Visual Basic
Public Const GROUP_6000_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_6000_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_7FE0_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_7FE0_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group 7FE0 Length RETIRED (7FE0,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_7FE0_LENGTH_RETIRED
Visual Basic
Public Const GROUP_7FE0_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_7FE0_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_FFFA_LENGTH_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_FFFA_LENGTH_RETIRED Field
MCdicom Structure See Also Send Feedback
Group FFFA Length RETIRED (FFFA,0000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_FFFA_LENGTH_RETIRED
Visual Basic
Public Const GROUP_FFFA_LENGTH_RETIRED As UInteger
Visual C++
public:
literal unsigned int GROUP_FFFA_LENGTH_RETIRED

See Also

MCdicom Structure
MCdicom Members


GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Group of Patients Identification Sequence (0010,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int GROUP_OF_PATIENTS_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HALF_VALUE_LAYER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HALF_VALUE_LAYER Field
MCdicom Structure See Also Send Feedback
Half Value Layer (0040,0314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HALF_VALUE_LAYER
Visual Basic
Public Const HALF_VALUE_LAYER As UInteger
Visual C++
public:
literal unsigned int HALF_VALUE_LAYER

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_CREATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_CREATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Creation DateTime (0072,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_CREATION_DATETIME
Visual Basic
Public Const HANGING_PROTOCOL_CREATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_CREATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_CREATOR Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Creator (0072,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_CREATOR
Visual Basic
Public Const HANGING_PROTOCOL_CREATOR As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_CREATOR

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Definition Sequence (0072,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_DEFINITION_SEQUENCE
Visual Basic
Public Const HANGING_PROTOCOL_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Description (0072,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_DESCRIPTION
Visual Basic
Public Const HANGING_PROTOCOL_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_LEVEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_LEVEL Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Level (0072,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_LEVEL
Visual Basic
Public Const HANGING_PROTOCOL_LEVEL As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_LEVEL

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_NAME Field
MCdicom Structure See Also Send Feedback
Hanging Protocol Name (0072,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_NAME
Visual Basic
Public Const HANGING_PROTOCOL_NAME As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_NAME

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_USER_GROUP_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_USER_GROUP_NAME Field
MCdicom Structure See Also Send Feedback
Hanging Protocol User Group Name (0072,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_USER_GROUP_NAME
Visual Basic
Public Const HANGING_PROTOCOL_USER_GROUP_NAME As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_USER_GROUP_NAME

See Also

MCdicom Structure
MCdicom Members


HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Hanging Protocol User Identification Code Sequence (0072,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HANGING_PROTOCOL_USER_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HARCOPY_DEVICE_SOFTWARE_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HARCOPY_DEVICE_SOFTWARE_VERSION Field
MCdicom Structure See Also Send Feedback
Alias for tag HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED (0018,101A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HARCOPY_DEVICE_SOFTWARE_VERSION
Visual Basic
Public Const HARCOPY_DEVICE_SOFTWARE_VERSION As UInteger
Visual C++
public:
literal unsigned int HARCOPY_DEVICE_SOFTWARE_VERSION

See Also

MCdicom Structure
MCdicom Members


HARDCOPY_CREATION_DEVICE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HARDCOPY_CREATION_DEVICE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Hardcopy Creation Device ID RETIRED (0018,1011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HARDCOPY_CREATION_DEVICE_ID_RETIRED
Visual Basic
Public Const HARDCOPY_CREATION_DEVICE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int HARDCOPY_CREATION_DEVICE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


HARDCOPY_DEVICE_MANUFACTURER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HARDCOPY_DEVICE_MANUFACTURER_RETIRED Field
MCdicom Structure See Also Send Feedback
Hardcopy Device Manufacturer RETIRED (0018,1017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HARDCOPY_DEVICE_MANUFACTURER_RETIRED
Visual Basic
Public Const HARDCOPY_DEVICE_MANUFACTURER_RETIRED As UInteger
Visual C++
public:
literal unsigned int HARDCOPY_DEVICE_MANUFACTURER_RETIRED

See Also

MCdicom Structure
MCdicom Members


HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED Field
MCdicom Structure See Also Send Feedback
Hardcopy Device Manufacturer's Model Name RETIRED (0018,101B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED
Visual Basic
Public Const HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED As UInteger
Visual C++
public:
literal unsigned int HARDCOPY_DEVICE_MANUFACTURERS_MODEL_NAME_RETIRED

See Also

MCdicom Structure
MCdicom Members


HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED Field
MCdicom Structure See Also Send Feedback
Hardcopy Device Software Version RETIRED (0018,101A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED
Visual Basic
Public Const HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED As UInteger
Visual C++
public:
literal unsigned int HARDCOPY_DEVICE_SOFTWARE_VERSION_RETIRED

See Also

MCdicom Structure
MCdicom Members


HEAD_FIXATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HEAD_FIXATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Head Fixation Angle (300A,0148)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HEAD_FIXATION_ANGLE
Visual Basic
Public Const HEAD_FIXATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int HEAD_FIXATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


HEAD_FIXATION_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HEAD_FIXATION_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Head Fixation Angle Tolerance (300A,0152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HEAD_FIXATION_ANGLE_TOLERANCE
Visual Basic
Public Const HEAD_FIXATION_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int HEAD_FIXATION_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


HEART_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HEART_RATE Field
MCdicom Structure See Also Send Feedback
Heart Rate (0018,1088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HEART_RATE
Visual Basic
Public Const HEART_RATE As UInteger
Visual C++
public:
literal unsigned int HEART_RATE

See Also

MCdicom Structure
MCdicom Members


HIGH_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HIGH_BIT Field
MCdicom Structure See Also Send Feedback
High Bit (0028,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HIGH_BIT
Visual Basic
Public Const HIGH_BIT As UInteger
Visual C++
public:
literal unsigned int HIGH_BIT

See Also

MCdicom Structure
MCdicom Members


HIGH_DOSE_TECHNIQUE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HIGH_DOSE_TECHNIQUE_TYPE Field
MCdicom Structure See Also Send Feedback
High-Dose Technique Type (300A,00C7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HIGH_DOSE_TECHNIQUE_TYPE
Visual Basic
Public Const HIGH_DOSE_TECHNIQUE_TYPE As UInteger
Visual C++
public:
literal unsigned int HIGH_DOSE_TECHNIQUE_TYPE

See Also

MCdicom Structure
MCdicom Members


HIGH_ENERGY_DETECTORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HIGH_ENERGY_DETECTORS Field
MCdicom Structure See Also Send Feedback
High Energy Detectors (4010,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HIGH_ENERGY_DETECTORS
Visual Basic
Public Const HIGH_ENERGY_DETECTORS As UInteger
Visual C++
public:
literal unsigned int HIGH_ENERGY_DETECTORS

See Also

MCdicom Structure
MCdicom Members


HIGH_R_R_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HIGH_R_R_VALUE Field
MCdicom Structure See Also Send Feedback
High R-R Value (0018,1082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HIGH_R_R_VALUE
Visual Basic
Public Const HIGH_R_R_VALUE As UInteger
Visual C++
public:
literal unsigned int HIGH_R_R_VALUE

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_BIN_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_BIN_WIDTH Field
MCdicom Structure See Also Send Feedback
Histogram Bin Width (0060,3008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_BIN_WIDTH
Visual Basic
Public Const HISTOGRAM_BIN_WIDTH As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_BIN_WIDTH

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_DATA Field
MCdicom Structure See Also Send Feedback
Histogram Data (0060,3020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_DATA
Visual Basic
Public Const HISTOGRAM_DATA As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_DATA

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_EXPLANATION Field
MCdicom Structure See Also Send Feedback
Histogram Explanation (0060,3010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_EXPLANATION
Visual Basic
Public Const HISTOGRAM_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_FIRST_BIN_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_FIRST_BIN_VALUE Field
MCdicom Structure See Also Send Feedback
Histogram First Bin Value (0060,3004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_FIRST_BIN_VALUE
Visual Basic
Public Const HISTOGRAM_FIRST_BIN_VALUE As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_FIRST_BIN_VALUE

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_LAST_BIN_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_LAST_BIN_VALUE Field
MCdicom Structure See Also Send Feedback
Histogram Last Bin Value (0060,3006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_LAST_BIN_VALUE
Visual Basic
Public Const HISTOGRAM_LAST_BIN_VALUE As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_LAST_BIN_VALUE

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_NUMBER_OF_BINS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_NUMBER_OF_BINS Field
MCdicom Structure See Also Send Feedback
Histogram Number of Bins (0060,3002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_NUMBER_OF_BINS
Visual Basic
Public Const HISTOGRAM_NUMBER_OF_BINS As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_NUMBER_OF_BINS

See Also

MCdicom Structure
MCdicom Members


HISTOGRAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HISTOGRAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Histogram Sequence (0060,3000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HISTOGRAM_SEQUENCE
Visual Basic
Public Const HISTOGRAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HISTOGRAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HL7_DOCUMENT_EFFECTIVE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HL7_DOCUMENT_EFFECTIVE_TIME Field
MCdicom Structure See Also Send Feedback
HL7 Document Effective Time (0040,E004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HL7_DOCUMENT_EFFECTIVE_TIME
Visual Basic
Public Const HL7_DOCUMENT_EFFECTIVE_TIME As UInteger
Visual C++
public:
literal unsigned int HL7_DOCUMENT_EFFECTIVE_TIME

See Also

MCdicom Structure
MCdicom Members


HL7_DOCUMENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HL7_DOCUMENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
HL7 Document Type Code Sequence (0040,E006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HL7_DOCUMENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const HL7_DOCUMENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HL7_DOCUMENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HL7_INSTANCE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HL7_INSTANCE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
HL7 Instance Identifier (0040,E001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HL7_INSTANCE_IDENTIFIER
Visual Basic
Public Const HL7_INSTANCE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int HL7_INSTANCE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
HL7 Structured Document Reference Sequence (0040,A390)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE
Visual Basic
Public Const HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HL7_STRUCTURED_DOCUMENT_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HOME_COMMUNITY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HOME_COMMUNITY_ID Field
MCdicom Structure See Also Send Feedback
Home Community ID (0040,E031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HOME_COMMUNITY_ID
Visual Basic
Public Const HOME_COMMUNITY_ID As UInteger
Visual C++
public:
literal unsigned int HOME_COMMUNITY_ID

See Also

MCdicom Structure
MCdicom Members


HORIZONTAL_ALIGNMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HORIZONTAL_ALIGNMENT Field
MCdicom Structure See Also Send Feedback
Horizontal Alignment (0070,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HORIZONTAL_ALIGNMENT
Visual Basic
Public Const HORIZONTAL_ALIGNMENT As UInteger
Visual C++
public:
literal unsigned int HORIZONTAL_ALIGNMENT

See Also

MCdicom Structure
MCdicom Members


HORIZONTAL_FIELD_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HORIZONTAL_FIELD_OF_VIEW Field
MCdicom Structure See Also Send Feedback
Horizontal Field of View (0022,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HORIZONTAL_FIELD_OF_VIEW
Visual Basic
Public Const HORIZONTAL_FIELD_OF_VIEW As UInteger
Visual C++
public:
literal unsigned int HORIZONTAL_FIELD_OF_VIEW

See Also

MCdicom Structure
MCdicom Members


HORIZONTAL_OFFSET_OF_SENSOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HORIZONTAL_OFFSET_OF_SENSOR Field
MCdicom Structure See Also Send Feedback
Horizontal Offset of Sensor (0014,3024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HORIZONTAL_OFFSET_OF_SENSOR
Visual Basic
Public Const HORIZONTAL_OFFSET_OF_SENSOR As UInteger
Visual C++
public:
literal unsigned int HORIZONTAL_OFFSET_OF_SENSOR

See Also

MCdicom Structure
MCdicom Members


HORIZONTAL_PRISM_BASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HORIZONTAL_PRISM_BASE Field
MCdicom Structure See Also Send Feedback
Horizontal Prism Base (0046,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HORIZONTAL_PRISM_BASE
Visual Basic
Public Const HORIZONTAL_PRISM_BASE As UInteger
Visual C++
public:
literal unsigned int HORIZONTAL_PRISM_BASE

See Also

MCdicom Structure
MCdicom Members


HORIZONTAL_PRISM_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HORIZONTAL_PRISM_POWER Field
MCdicom Structure See Also Send Feedback
Horizontal Prism Power (0046,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HORIZONTAL_PRISM_POWER
Visual Basic
Public Const HORIZONTAL_PRISM_POWER As UInteger
Visual C++
public:
literal unsigned int HORIZONTAL_PRISM_POWER

See Also

MCdicom Structure
MCdicom Members


HPGL_CONTOUR_PEN_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_CONTOUR_PEN_NUMBER Field
MCdicom Structure See Also Send Feedback
HPGL Contour Pen Number (0068,6310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_CONTOUR_PEN_NUMBER
Visual Basic
Public Const HPGL_CONTOUR_PEN_NUMBER As UInteger
Visual C++
public:
literal unsigned int HPGL_CONTOUR_PEN_NUMBER

See Also

MCdicom Structure
MCdicom Members


HPGL_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_DOCUMENT Field
MCdicom Structure See Also Send Feedback
HPGL Document (0068,6300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_DOCUMENT
Visual Basic
Public Const HPGL_DOCUMENT As UInteger
Visual C++
public:
literal unsigned int HPGL_DOCUMENT

See Also

MCdicom Structure
MCdicom Members


HPGL_DOCUMENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_DOCUMENT_ID Field
MCdicom Structure See Also Send Feedback
HPGL Document ID (0068,62D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_DOCUMENT_ID
Visual Basic
Public Const HPGL_DOCUMENT_ID As UInteger
Visual C++
public:
literal unsigned int HPGL_DOCUMENT_ID

See Also

MCdicom Structure
MCdicom Members


HPGL_DOCUMENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_DOCUMENT_LABEL Field
MCdicom Structure See Also Send Feedback
HPGL Document Label (0068,62D5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_DOCUMENT_LABEL
Visual Basic
Public Const HPGL_DOCUMENT_LABEL As UInteger
Visual C++
public:
literal unsigned int HPGL_DOCUMENT_LABEL

See Also

MCdicom Structure
MCdicom Members


HPGL_DOCUMENT_SCALING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_DOCUMENT_SCALING Field
MCdicom Structure See Also Send Feedback
HPGL Document Scaling (0068,62F2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_DOCUMENT_SCALING
Visual Basic
Public Const HPGL_DOCUMENT_SCALING As UInteger
Visual C++
public:
literal unsigned int HPGL_DOCUMENT_SCALING

See Also

MCdicom Structure
MCdicom Members


HPGL_DOCUMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_DOCUMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
HPGL Document Sequence (0068,62C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_DOCUMENT_SEQUENCE
Visual Basic
Public Const HPGL_DOCUMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HPGL_DOCUMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HPGL_PEN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_PEN_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
HPGL Pen Description (0068,6345)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_PEN_DESCRIPTION
Visual Basic
Public Const HPGL_PEN_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int HPGL_PEN_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


HPGL_PEN_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_PEN_LABEL Field
MCdicom Structure See Also Send Feedback
HPGL Pen Label (0068,6340)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_PEN_LABEL
Visual Basic
Public Const HPGL_PEN_LABEL As UInteger
Visual C++
public:
literal unsigned int HPGL_PEN_LABEL

See Also

MCdicom Structure
MCdicom Members


HPGL_PEN_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_PEN_NUMBER Field
MCdicom Structure See Also Send Feedback
HPGL Pen Number (0068,6330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_PEN_NUMBER
Visual Basic
Public Const HPGL_PEN_NUMBER As UInteger
Visual C++
public:
literal unsigned int HPGL_PEN_NUMBER

See Also

MCdicom Structure
MCdicom Members


HPGL_PEN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HPGL_PEN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
HPGL Pen Sequence (0068,6320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HPGL_PEN_SEQUENCE
Visual Basic
Public Const HPGL_PEN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HPGL_PEN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HUMAN_PERFORMER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HUMAN_PERFORMER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Human Performer Code Sequence (0040,4009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HUMAN_PERFORMER_CODE_SEQUENCE
Visual Basic
Public Const HUMAN_PERFORMER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int HUMAN_PERFORMER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


HUMAN_PERFORMERS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HUMAN_PERFORMERS_NAME Field
MCdicom Structure See Also Send Feedback
Human Performer's Name (0040,4037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HUMAN_PERFORMERS_NAME
Visual Basic
Public Const HUMAN_PERFORMERS_NAME As UInteger
Visual C++
public:
literal unsigned int HUMAN_PERFORMERS_NAME

See Also

MCdicom Structure
MCdicom Members


HUMAN_PERFORMERS_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HUMAN_PERFORMERS_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Human Performer's Organization (0040,4036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HUMAN_PERFORMERS_ORGANIZATION
Visual Basic
Public Const HUMAN_PERFORMERS_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int HUMAN_PERFORMERS_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


HUMIDITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..HUMIDITY Field
MCdicom Structure See Also Send Feedback
Humidity (0016,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint HUMIDITY
Visual Basic
Public Const HUMIDITY As UInteger
Visual C++
public:
literal unsigned int HUMIDITY

See Also

MCdicom Structure
MCdicom Members


ICC_PROFILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ICC_PROFILE Field
MCdicom Structure See Also Send Feedback
ICC Profile (0028,2000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ICC_PROFILE
Visual Basic
Public Const ICC_PROFILE As UInteger
Visual C++
public:
literal unsigned int ICC_PROFILE

See Also

MCdicom Structure
MCdicom Members


ICON_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ICON_IMAGE Field
MCdicom Structure See Also Send Feedback
Alias for tag ICON_IMAGE_SEQUENCE (0088,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ICON_IMAGE
Visual Basic
Public Const ICON_IMAGE As UInteger
Visual C++
public:
literal unsigned int ICON_IMAGE

See Also

MCdicom Structure
MCdicom Members


ICON_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ICON_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Icon Image Sequence (0088,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ICON_IMAGE_SEQUENCE
Visual Basic
Public Const ICON_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ICON_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IDENTICAL_DOCUMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTICAL_DOCUMENTS Field
MCdicom Structure See Also Send Feedback
Alias for tag IDENTICAL_DOCUMENTS_SEQUENCE (0040,A525)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTICAL_DOCUMENTS
Visual Basic
Public Const IDENTICAL_DOCUMENTS As UInteger
Visual C++
public:
literal unsigned int IDENTICAL_DOCUMENTS

See Also

MCdicom Structure
MCdicom Members


IDENTICAL_DOCUMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTICAL_DOCUMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Identical Documents Sequence (0040,A525)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTICAL_DOCUMENTS_SEQUENCE
Visual Basic
Public Const IDENTICAL_DOCUMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IDENTICAL_DOCUMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Identification Description (Trial) RETIRED (0040,A224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int IDENTIFICATION_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Identifier Code Sequence (Trial) RETIRED (0040,A070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


IDENTIFIER_TYPE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTIFIER_TYPE_CODE Field
MCdicom Structure See Also Send Feedback
Identifier Type Code (0040,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTIFIER_TYPE_CODE
Visual Basic
Public Const IDENTIFIER_TYPE_CODE As UInteger
Visual C++
public:
literal unsigned int IDENTIFIER_TYPE_CODE

See Also

MCdicom Structure
MCdicom Members


IDENTIFYING_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTIFYING_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Identifying Comments RETIRED (0008,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTIFYING_COMMENTS_RETIRED
Visual Basic
Public Const IDENTIFYING_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int IDENTIFYING_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


IDENTIFYING_PRIVATE_ELEMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IDENTIFYING_PRIVATE_ELEMENTS Field
MCdicom Structure See Also Send Feedback
Identifying Private Elements (0008,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IDENTIFYING_PRIVATE_ELEMENTS
Visual Basic
Public Const IDENTIFYING_PRIVATE_ELEMENTS As UInteger
Visual C++
public:
literal unsigned int IDENTIFYING_PRIVATE_ELEMENTS

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION Field
MCdicom Structure See Also Send Feedback
Illumination (2010,015E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION
Visual Basic
Public Const ILLUMINATION As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_BANDWIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_BANDWIDTH Field
MCdicom Structure See Also Send Feedback
Illumination Bandwidth (0022,0057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_BANDWIDTH
Visual Basic
Public Const ILLUMINATION_BANDWIDTH As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_BANDWIDTH

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_COLOR_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_COLOR_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Illumination Color Code Sequence (0048,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_COLOR_CODE_SEQUENCE
Visual Basic
Public Const ILLUMINATION_COLOR_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_COLOR_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_POWER Field
MCdicom Structure See Also Send Feedback
Illumination Power (0022,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_POWER
Visual Basic
Public Const ILLUMINATION_POWER As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_POWER

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_TRANSLATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_TRANSLATION_FLAG Field
MCdicom Structure See Also Send Feedback
Illumination Translation Flag (0018,9828)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_TRANSLATION_FLAG
Visual Basic
Public Const ILLUMINATION_TRANSLATION_FLAG As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_TRANSLATION_FLAG

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Illumination Type Code Sequence (0022,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ILLUMINATION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ILLUMINATION_WAVE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATION_WAVE_LENGTH Field
MCdicom Structure See Also Send Feedback
Illumination Wave Length (0022,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATION_WAVE_LENGTH
Visual Basic
Public Const ILLUMINATION_WAVE_LENGTH As UInteger
Visual C++
public:
literal unsigned int ILLUMINATION_WAVE_LENGTH

See Also

MCdicom Structure
MCdicom Members


ILLUMINATOR_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ILLUMINATOR_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Illuminator Type Code Sequence (0048,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ILLUMINATOR_TYPE_CODE_SEQUENCE
Visual Basic
Public Const ILLUMINATOR_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ILLUMINATOR_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT Field
MCdicom Structure See Also Send Feedback
Image and Fluoroscopy Area Dose Product (0018,115E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT
Visual Basic
Public Const IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT As UInteger
Visual C++
public:
literal unsigned int IMAGE_AND_FLUOROSCOPY_AREA_DOSE_PRODUCT

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_CONTENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_CONTENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Box Content Sequence RETIRED (2130,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_CONTENT_SEQUENCE_RETIRED
Visual Basic
Public Const IMAGE_BOX_CONTENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_CONTENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_LARGE_SCROLL_AMOUNT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_LARGE_SCROLL_AMOUNT Field
MCdicom Structure See Also Send Feedback
Image Box Large Scroll Amount (0072,0318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_LARGE_SCROLL_AMOUNT
Visual Basic
Public Const IMAGE_BOX_LARGE_SCROLL_AMOUNT As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_LARGE_SCROLL_AMOUNT

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_LARGE_SCROLL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_LARGE_SCROLL_TYPE Field
MCdicom Structure See Also Send Feedback
Image Box Large Scroll Type (0072,0316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_LARGE_SCROLL_TYPE
Visual Basic
Public Const IMAGE_BOX_LARGE_SCROLL_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_LARGE_SCROLL_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_LAYOUT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_LAYOUT_TYPE Field
MCdicom Structure See Also Send Feedback
Image Box Layout Type (0072,0304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_LAYOUT_TYPE
Visual Basic
Public Const IMAGE_BOX_LAYOUT_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_LAYOUT_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_NUMBER Field
MCdicom Structure See Also Send Feedback
Image Box Number (0072,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_NUMBER
Visual Basic
Public Const IMAGE_BOX_NUMBER As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_NUMBER

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_OVERLAP_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_OVERLAP_PRIORITY Field
MCdicom Structure See Also Send Feedback
Image Box Overlap Priority (0072,0320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_OVERLAP_PRIORITY
Visual Basic
Public Const IMAGE_BOX_OVERLAP_PRIORITY As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_OVERLAP_PRIORITY

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_POSITION Field
MCdicom Structure See Also Send Feedback
Image Box Position (2020,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_POSITION
Visual Basic
Public Const IMAGE_BOX_POSITION As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_POSITION

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Box Presentation LUT Flag RETIRED (2000,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED
Visual Basic
Public Const IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_PRESENTATION_LUT_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_SCROLL_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_SCROLL_DIRECTION Field
MCdicom Structure See Also Send Feedback
Image Box Scroll Direction (0072,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_SCROLL_DIRECTION
Visual Basic
Public Const IMAGE_BOX_SCROLL_DIRECTION As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_SCROLL_DIRECTION

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_SMALL_SCROLL_AMOUNT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_SMALL_SCROLL_AMOUNT Field
MCdicom Structure See Also Send Feedback
Image Box Small Scroll Amount (0072,0314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_SMALL_SCROLL_AMOUNT
Visual Basic
Public Const IMAGE_BOX_SMALL_SCROLL_AMOUNT As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_SMALL_SCROLL_AMOUNT

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_SMALL_SCROLL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_SMALL_SCROLL_TYPE Field
MCdicom Structure See Also Send Feedback
Image Box Small Scroll Type (0072,0312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_SMALL_SCROLL_TYPE
Visual Basic
Public Const IMAGE_BOX_SMALL_SCROLL_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_SMALL_SCROLL_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_SYNCHRONIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_SYNCHRONIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Box Synchronization Sequence (0072,0430)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_SYNCHRONIZATION_SEQUENCE
Visual Basic
Public Const IMAGE_BOX_SYNCHRONIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_SYNCHRONIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_TILE_HORIZONTAL_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_TILE_HORIZONTAL_DIMENSION Field
MCdicom Structure See Also Send Feedback
Image Box Tile Horizontal Dimension (0072,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_TILE_HORIZONTAL_DIMENSION
Visual Basic
Public Const IMAGE_BOX_TILE_HORIZONTAL_DIMENSION As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_TILE_HORIZONTAL_DIMENSION

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOX_TILE_VERTICAL_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOX_TILE_VERTICAL_DIMENSION Field
MCdicom Structure See Also Send Feedback
Image Box Tile Vertical Dimension (0072,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOX_TILE_VERTICAL_DIMENSION
Visual Basic
Public Const IMAGE_BOX_TILE_VERTICAL_DIMENSION As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOX_TILE_VERTICAL_DIMENSION

See Also

MCdicom Structure
MCdicom Members


IMAGE_BOXES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_BOXES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Boxes Sequence (0072,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_BOXES_SEQUENCE
Visual Basic
Public Const IMAGE_BOXES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_BOXES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_CENTER_POINT_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_CENTER_POINT_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Center Point Coordinates Sequence (0040,071A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_CENTER_POINT_COORDINATES_SEQUENCE
Visual Basic
Public Const IMAGE_CENTER_POINT_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_CENTER_POINT_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_COMMENTS Field
MCdicom Structure See Also Send Feedback
Image Comments (0020,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_COMMENTS
Visual Basic
Public Const IMAGE_COMMENTS As UInteger
Visual C++
public:
literal unsigned int IMAGE_COMMENTS

See Also

MCdicom Structure
MCdicom Members


IMAGE_DATA_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_DATA_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Data Type Code Sequence (0018,9836)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_DATA_TYPE_CODE_SEQUENCE
Visual Basic
Public Const IMAGE_DATA_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_DATA_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_DATA_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_DATA_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Data Type Sequence (0018,9807)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_DATA_TYPE_SEQUENCE
Visual Basic
Public Const IMAGE_DATA_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_DATA_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_DATE Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_DATE (0008,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_DATE
Visual Basic
Public Const IMAGE_DATE As UInteger
Visual C++
public:
literal unsigned int IMAGE_DATE

See Also

MCdicom Structure
MCdicom Members


IMAGE_DIMENSIONS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_DIMENSIONS_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Dimensions RETIRED (0028,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_DIMENSIONS_RETIRED
Visual Basic
Public Const IMAGE_DIMENSIONS_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_DIMENSIONS_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_DISPLAY_FORMAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_DISPLAY_FORMAT Field
MCdicom Structure See Also Send Feedback
Image Display Format (2010,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_DISPLAY_FORMAT
Visual Basic
Public Const IMAGE_DISPLAY_FORMAT As UInteger
Visual C++
public:
literal unsigned int IMAGE_DISPLAY_FORMAT

See Also

MCdicom Structure
MCdicom Members


IMAGE_FILTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_FILTER Field
MCdicom Structure See Also Send Feedback
Image Filter (0018,9320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_FILTER
Visual Basic
Public Const IMAGE_FILTER As UInteger
Visual C++
public:
literal unsigned int IMAGE_FILTER

See Also

MCdicom Structure
MCdicom Members


IMAGE_FILTER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_FILTER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Image Filter Description (0018,9941)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_FILTER_DESCRIPTION
Visual Basic
Public Const IMAGE_FILTER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int IMAGE_FILTER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


IMAGE_FILTER_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_FILTER_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Filter Details Sequence (0018,11BF)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_FILTER_DETAILS_SEQUENCE
Visual Basic
Public Const IMAGE_FILTER_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_FILTER_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Format RETIRED (0028,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_FORMAT_RETIRED
Visual Basic
Public Const IMAGE_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_FRAME_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_FRAME_ORIGIN Field
MCdicom Structure See Also Send Feedback
Image Frame Origin (6000,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_FRAME_ORIGIN
Visual Basic
Public Const IMAGE_FRAME_ORIGIN As UInteger
Visual C++
public:
literal unsigned int IMAGE_FRAME_ORIGIN

See Also

MCdicom Structure
MCdicom Members


IMAGE_GEOMETRY_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_GEOMETRY_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Geometry Type RETIRED (0020,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_GEOMETRY_TYPE_RETIRED
Visual Basic
Public Const IMAGE_GEOMETRY_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_GEOMETRY_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_HORIZONTAL_FLIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_HORIZONTAL_FLIP Field
MCdicom Structure See Also Send Feedback
Image Horizontal Flip (0070,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_HORIZONTAL_FLIP
Visual Basic
Public Const IMAGE_HORIZONTAL_FLIP As UInteger
Visual C++
public:
literal unsigned int IMAGE_HORIZONTAL_FLIP

See Also

MCdicom Structure
MCdicom Members


IMAGE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ID Field
MCdicom Structure See Also Send Feedback
Image ID (0054,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ID
Visual Basic
Public Const IMAGE_ID As UInteger
Visual C++
public:
literal unsigned int IMAGE_ID

See Also

MCdicom Structure
MCdicom Members


IMAGE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_INDEX Field
MCdicom Structure See Also Send Feedback
Image Index (0054,1330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_INDEX
Visual Basic
Public Const IMAGE_INDEX As UInteger
Visual C++
public:
literal unsigned int IMAGE_INDEX

See Also

MCdicom Structure
MCdicom Members


IMAGE_LATERALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_LATERALITY Field
MCdicom Structure See Also Send Feedback
Image Laterality (0020,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_LATERALITY
Visual Basic
Public Const IMAGE_LATERALITY As UInteger
Visual C++
public:
literal unsigned int IMAGE_LATERALITY

See Also

MCdicom Structure
MCdicom Members


IMAGE_LOCATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_LOCATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Location RETIRED (0028,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_LOCATION_RETIRED
Visual Basic
Public Const IMAGE_LOCATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_LOCATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Alias for tag INSTANCE_NUMBER (0020,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_NUMBER
Visual Basic
Public Const IMAGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int IMAGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


IMAGE_ORIENTATION_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ORIENTATION_PATIENT Field
MCdicom Structure See Also Send Feedback
Image Orientation (Patient) (0020,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ORIENTATION_PATIENT
Visual Basic
Public Const IMAGE_ORIENTATION_PATIENT As UInteger
Visual C++
public:
literal unsigned int IMAGE_ORIENTATION_PATIENT

See Also

MCdicom Structure
MCdicom Members


IMAGE_ORIENTATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ORIENTATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Orientation RETIRED (0020,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ORIENTATION_RETIRED
Visual Basic
Public Const IMAGE_ORIENTATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_ORIENTATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_ORIENTATION_SLIDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ORIENTATION_SLIDE Field
MCdicom Structure See Also Send Feedback
Image Orientation (Slide) (0048,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ORIENTATION_SLIDE
Visual Basic
Public Const IMAGE_ORIENTATION_SLIDE As UInteger
Visual C++
public:
literal unsigned int IMAGE_ORIENTATION_SLIDE

See Also

MCdicom Structure
MCdicom Members


IMAGE_ORIENTATION_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ORIENTATION_VOLUME Field
MCdicom Structure See Also Send Feedback
Image Orientation (Volume) (0020,9302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ORIENTATION_VOLUME
Visual Basic
Public Const IMAGE_ORIENTATION_VOLUME As UInteger
Visual C++
public:
literal unsigned int IMAGE_ORIENTATION_VOLUME

See Also

MCdicom Structure
MCdicom Members


IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Overlay Box Content Sequence RETIRED (2130,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED
Visual Basic
Public Const IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_OVERLAY_BOX_CONTENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_OVERLAY_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_OVERLAY_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Overlay Flag RETIRED (2000,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_OVERLAY_FLAG_RETIRED
Visual Basic
Public Const IMAGE_OVERLAY_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_OVERLAY_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_PATH_FILTER_PASS_BAND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PATH_FILTER_PASS_BAND Field
MCdicom Structure See Also Send Feedback
Image Path Filter Pass Band (0022,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PATH_FILTER_PASS_BAND
Visual Basic
Public Const IMAGE_PATH_FILTER_PASS_BAND As UInteger
Visual C++
public:
literal unsigned int IMAGE_PATH_FILTER_PASS_BAND

See Also

MCdicom Structure
MCdicom Members


IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH Field
MCdicom Structure See Also Send Feedback
Image Path Filter Pass-Through Wavelength (0022,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH
Visual Basic
Public Const IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH As UInteger
Visual C++
public:
literal unsigned int IMAGE_PATH_FILTER_PASS_THROUGH_WAVELENGTH

See Also

MCdicom Structure
MCdicom Members


IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Path Filter Type Stack Code Sequence (0022,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE
Visual Basic
Public Const IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_PLANE_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PLANE_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Image Plane Pixel Spacing (3002,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PLANE_PIXEL_SPACING
Visual Basic
Public Const IMAGE_PLANE_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int IMAGE_PLANE_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


IMAGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_POSITION Field
MCdicom Structure See Also Send Feedback
Alias for tag IMAGE_BOX_POSITION (2020,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_POSITION
Visual Basic
Public Const IMAGE_POSITION As UInteger
Visual C++
public:
literal unsigned int IMAGE_POSITION

See Also

MCdicom Structure
MCdicom Members


IMAGE_POSITION_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_POSITION_PATIENT Field
MCdicom Structure See Also Send Feedback
Image Position (Patient) (0020,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_POSITION_PATIENT
Visual Basic
Public Const IMAGE_POSITION_PATIENT As UInteger
Visual C++
public:
literal unsigned int IMAGE_POSITION_PATIENT

See Also

MCdicom Structure
MCdicom Members


IMAGE_POSITION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_POSITION_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Position RETIRED (0020,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_POSITION_RETIRED
Visual Basic
Public Const IMAGE_POSITION_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_POSITION_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_POSITION_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_POSITION_VOLUME Field
MCdicom Structure See Also Send Feedback
Image Position (Volume) (0020,9301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_POSITION_VOLUME
Visual Basic
Public Const IMAGE_POSITION_VOLUME As UInteger
Visual C++
public:
literal unsigned int IMAGE_POSITION_VOLUME

See Also

MCdicom Structure
MCdicom Members


IMAGE_PRESENTATION_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PRESENTATION_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Presentation Comments RETIRED (0028,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PRESENTATION_COMMENTS_RETIRED
Visual Basic
Public Const IMAGE_PRESENTATION_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_PRESENTATION_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_PROCESSING_APPLIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_PROCESSING_APPLIED Field
MCdicom Structure See Also Send Feedback
Image Processing Applied (0028,9446)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_PROCESSING_APPLIED
Visual Basic
Public Const IMAGE_PROCESSING_APPLIED As UInteger
Visual C++
public:
literal unsigned int IMAGE_PROCESSING_APPLIED

See Also

MCdicom Structure
MCdicom Members


IMAGE_RECEPTOR_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_RECEPTOR_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Receptor Position Sequence (3002,010E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_RECEPTOR_POSITION_SEQUENCE
Visual Basic
Public Const IMAGE_RECEPTOR_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_RECEPTOR_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ROTATION Field
MCdicom Structure See Also Send Feedback
Image Rotation (0070,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ROTATION
Visual Basic
Public Const IMAGE_ROTATION As UInteger
Visual C++
public:
literal unsigned int IMAGE_ROTATION

See Also

MCdicom Structure
MCdicom Members


IMAGE_ROTATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_ROTATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Rotation (Retired) (0070,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_ROTATION_RETIRED
Visual Basic
Public Const IMAGE_ROTATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_ROTATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SET_LABEL Field
MCdicom Structure See Also Send Feedback
Image Set Label (0072,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SET_LABEL
Visual Basic
Public Const IMAGE_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int IMAGE_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


IMAGE_SET_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SET_NUMBER Field
MCdicom Structure See Also Send Feedback
Image Set Number (0072,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SET_NUMBER
Visual Basic
Public Const IMAGE_SET_NUMBER As UInteger
Visual C++
public:
literal unsigned int IMAGE_SET_NUMBER

See Also

MCdicom Structure
MCdicom Members


IMAGE_SET_SELECTOR_CATEGORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SET_SELECTOR_CATEGORY Field
MCdicom Structure See Also Send Feedback
Image Set Selector Category (0072,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SET_SELECTOR_CATEGORY
Visual Basic
Public Const IMAGE_SET_SELECTOR_CATEGORY As UInteger
Visual C++
public:
literal unsigned int IMAGE_SET_SELECTOR_CATEGORY

See Also

MCdicom Structure
MCdicom Members


IMAGE_SET_SELECTOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SET_SELECTOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Set Selector Sequence (0072,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SET_SELECTOR_SEQUENCE
Visual Basic
Public Const IMAGE_SET_SELECTOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_SET_SELECTOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_SET_SELECTOR_USAGE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SET_SELECTOR_USAGE_FLAG Field
MCdicom Structure See Also Send Feedback
Image Set Selector Usage Flag (0072,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SET_SELECTOR_USAGE_FLAG
Visual Basic
Public Const IMAGE_SET_SELECTOR_USAGE_FLAG As UInteger
Visual C++
public:
literal unsigned int IMAGE_SET_SELECTOR_USAGE_FLAG

See Also

MCdicom Structure
MCdicom Members


IMAGE_SETS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_SETS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Image Sets Sequence (0072,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_SETS_SEQUENCE
Visual Basic
Public Const IMAGE_SETS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGE_SETS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_TIME (0008,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TIME
Visual Basic
Public Const IMAGE_TIME As UInteger
Visual C++
public:
literal unsigned int IMAGE_TIME

See Also

MCdicom Structure
MCdicom Members


IMAGE_TO_EQUIPMENT_MAPPING_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TO_EQUIPMENT_MAPPING_MATRIX Field
MCdicom Structure See Also Send Feedback
Image to Equipment Mapping Matrix (0028,9520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TO_EQUIPMENT_MAPPING_MATRIX
Visual Basic
Public Const IMAGE_TO_EQUIPMENT_MAPPING_MATRIX As UInteger
Visual C++
public:
literal unsigned int IMAGE_TO_EQUIPMENT_MAPPING_MATRIX

See Also

MCdicom Structure
MCdicom Members


IMAGE_TRANSFORMATION_MATRIX_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TRANSFORMATION_MATRIX_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Transformation Matrix RETIRED (0018,5210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TRANSFORMATION_MATRIX_RETIRED
Visual Basic
Public Const IMAGE_TRANSFORMATION_MATRIX_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_TRANSFORMATION_MATRIX_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_TRANSLATION_VECTOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TRANSLATION_VECTOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Image Translation Vector RETIRED (0018,5212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TRANSLATION_VECTOR_RETIRED
Visual Basic
Public Const IMAGE_TRANSLATION_VECTOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMAGE_TRANSLATION_VECTOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


IMAGE_TRIGGER_DELAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TRIGGER_DELAY Field
MCdicom Structure See Also Send Feedback
Image Trigger Delay (0018,1067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TRIGGER_DELAY
Visual Basic
Public Const IMAGE_TRIGGER_DELAY As UInteger
Visual C++
public:
literal unsigned int IMAGE_TRIGGER_DELAY

See Also

MCdicom Structure
MCdicom Members


IMAGE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_TYPE Field
MCdicom Structure See Also Send Feedback
Image Type (0008,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_TYPE
Visual Basic
Public Const IMAGE_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGE_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGE_VOLUME_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGE_VOLUME_GEOMETRY Field
MCdicom Structure See Also Send Feedback
Image Volume Geometry (0070,1208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGE_VOLUME_GEOMETRY
Visual Basic
Public Const IMAGE_VOLUME_GEOMETRY As UInteger
Visual C++
public:
literal unsigned int IMAGE_VOLUME_GEOMETRY

See Also

MCdicom Structure
MCdicom Members


IMAGED_NUCLEUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGED_NUCLEUS Field
MCdicom Structure See Also Send Feedback
Imaged Nucleus (0018,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGED_NUCLEUS
Visual Basic
Public Const IMAGED_NUCLEUS As UInteger
Visual C++
public:
literal unsigned int IMAGED_NUCLEUS

See Also

MCdicom Structure
MCdicom Members


IMAGED_VOLUME_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGED_VOLUME_DEPTH Field
MCdicom Structure See Also Send Feedback
Imaged Volume Depth (0048,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGED_VOLUME_DEPTH
Visual Basic
Public Const IMAGED_VOLUME_DEPTH As UInteger
Visual C++
public:
literal unsigned int IMAGED_VOLUME_DEPTH

See Also

MCdicom Structure
MCdicom Members


IMAGED_VOLUME_HEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGED_VOLUME_HEIGHT Field
MCdicom Structure See Also Send Feedback
Imaged Volume Height (0048,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGED_VOLUME_HEIGHT
Visual Basic
Public Const IMAGED_VOLUME_HEIGHT As UInteger
Visual C++
public:
literal unsigned int IMAGED_VOLUME_HEIGHT

See Also

MCdicom Structure
MCdicom Members


IMAGED_VOLUME_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGED_VOLUME_WIDTH Field
MCdicom Structure See Also Send Feedback
Imaged Volume Width (0048,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGED_VOLUME_WIDTH
Visual Basic
Public Const IMAGED_VOLUME_WIDTH As UInteger
Visual C++
public:
literal unsigned int IMAGED_VOLUME_WIDTH

See Also

MCdicom Structure
MCdicom Members


IMAGER_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGER_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Imager Pixel Spacing (0018,1164)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGER_PIXEL_SPACING
Visual Basic
Public Const IMAGER_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int IMAGER_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


IMAGES_IN_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGES_IN_ACQUISITION Field
MCdicom Structure See Also Send Feedback
Images in Acquisition (0020,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGES_IN_ACQUISITION
Visual Basic
Public Const IMAGES_IN_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int IMAGES_IN_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


IMAGING_APERTURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_APERTURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Imaging Aperture Sequence (3002,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_APERTURE_SEQUENCE
Visual Basic
Public Const IMAGING_APERTURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGING_APERTURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGING_APERTURE_SPECIFICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_APERTURE_SPECIFICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Imaging Aperture Specification Type (3002,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_APERTURE_SPECIFICATION_TYPE
Visual Basic
Public Const IMAGING_APERTURE_SPECIFICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGING_APERTURE_SPECIFICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Imaging Device Location Matrix Sequence (3002,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE
Visual Basic
Public Const IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGING_DEVICE_LOCATION_MATRIX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Imaging Device Location Parameter Sequence (3002,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE
Visual Basic
Public Const IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGING_DEVICE_LOCATION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS Field
MCdicom Structure See Also Send Feedback
Imaging Device-Specific Acquisition Parameters (300A,00CC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS
Visual Basic
Public Const IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS As UInteger
Visual C++
public:
literal unsigned int IMAGING_DEVICE_SPECIFIC_ACQUISITION_PARAMETERS

See Also

MCdicom Structure
MCdicom Members


IMAGING_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Imaging Frequency (0018,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_FREQUENCY
Visual Basic
Public Const IMAGING_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int IMAGING_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


IMAGING_SERVICE_REQUEST_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_SERVICE_REQUEST_COMMENTS Field
MCdicom Structure See Also Send Feedback
Imaging Service Request Comments (0040,2400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_SERVICE_REQUEST_COMMENTS
Visual Basic
Public Const IMAGING_SERVICE_REQUEST_COMMENTS As UInteger
Visual C++
public:
literal unsigned int IMAGING_SERVICE_REQUEST_COMMENTS

See Also

MCdicom Structure
MCdicom Members


IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Imaging Source Location Specification Type (3002,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE
Visual Basic
Public Const IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int IMAGING_SOURCE_LOCATION_SPECIFICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


IMAGING_SOURCE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_SOURCE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Imaging Source Position Sequence (3002,010D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_SOURCE_POSITION_SEQUENCE
Visual Basic
Public Const IMAGING_SOURCE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMAGING_SOURCE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Imaging Source to Beam Modifier Definition Plane Distance (3002,012D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE
Visual Basic
Public Const IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int IMAGING_SOURCE_TO_BEAM_MODIFIER_DEFINITION_PLANE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


IMMERSION_MEDIA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMMERSION_MEDIA Field
MCdicom Structure See Also Send Feedback
Immersion Media (0016,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMMERSION_MEDIA
Visual Basic
Public Const IMMERSION_MEDIA As UInteger
Visual C++
public:
literal unsigned int IMMERSION_MEDIA

See Also

MCdicom Structure
MCdicom Members


IMPEDANCE_MEASUREMENT_CURRENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPEDANCE_MEASUREMENT_CURRENT_TYPE Field
MCdicom Structure See Also Send Feedback
Impedance Measurement Current Type (003A,0316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPEDANCE_MEASUREMENT_CURRENT_TYPE
Visual Basic
Public Const IMPEDANCE_MEASUREMENT_CURRENT_TYPE As UInteger
Visual C++
public:
literal unsigned int IMPEDANCE_MEASUREMENT_CURRENT_TYPE

See Also

MCdicom Structure
MCdicom Members


IMPEDANCE_MEASUREMENT_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPEDANCE_MEASUREMENT_DATETIME Field
MCdicom Structure See Also Send Feedback
Impedance Measurement DateTime (003A,0314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPEDANCE_MEASUREMENT_DATETIME
Visual Basic
Public Const IMPEDANCE_MEASUREMENT_DATETIME As UInteger
Visual C++
public:
literal unsigned int IMPEDANCE_MEASUREMENT_DATETIME

See Also

MCdicom Structure
MCdicom Members


IMPEDANCE_MEASUREMENT_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPEDANCE_MEASUREMENT_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Impedance Measurement Frequency (003A,0315)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPEDANCE_MEASUREMENT_FREQUENCY
Visual Basic
Public Const IMPEDANCE_MEASUREMENT_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int IMPEDANCE_MEASUREMENT_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


IMPEDANCE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPEDANCE_VALUE Field
MCdicom Structure See Also Send Feedback
Impedance Value (003A,0313)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPEDANCE_VALUE
Visual Basic
Public Const IMPEDANCE_VALUE As UInteger
Visual C++
public:
literal unsigned int IMPEDANCE_VALUE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_ASSEMBLY_TEMPLATE_ISSUER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_ASSEMBLY_TEMPLATE_ISSUER Field
MCdicom Structure See Also Send Feedback
Implant Assembly Template Issuer (0076,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_ASSEMBLY_TEMPLATE_ISSUER
Visual Basic
Public Const IMPLANT_ASSEMBLY_TEMPLATE_ISSUER As UInteger
Visual C++
public:
literal unsigned int IMPLANT_ASSEMBLY_TEMPLATE_ISSUER

See Also

MCdicom Structure
MCdicom Members


IMPLANT_ASSEMBLY_TEMPLATE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_ASSEMBLY_TEMPLATE_NAME Field
MCdicom Structure See Also Send Feedback
Implant Assembly Template Name (0076,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_ASSEMBLY_TEMPLATE_NAME
Visual Basic
Public Const IMPLANT_ASSEMBLY_TEMPLATE_NAME As UInteger
Visual C++
public:
literal unsigned int IMPLANT_ASSEMBLY_TEMPLATE_NAME

See Also

MCdicom Structure
MCdicom Members


IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Assembly Template Target Anatomy Sequence (0076,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE
Visual Basic
Public Const IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_ASSEMBLY_TEMPLATE_TARGET_ANATOMY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_ASSEMBLY_TEMPLATE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_ASSEMBLY_TEMPLATE_TYPE Field
MCdicom Structure See Also Send Feedback
Implant Assembly Template Type (0076,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_ASSEMBLY_TEMPLATE_TYPE
Visual Basic
Public Const IMPLANT_ASSEMBLY_TEMPLATE_TYPE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_ASSEMBLY_TEMPLATE_TYPE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_ASSEMBLY_TEMPLATE_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_ASSEMBLY_TEMPLATE_VERSION Field
MCdicom Structure See Also Send Feedback
Implant Assembly Template Version (0076,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_ASSEMBLY_TEMPLATE_VERSION
Visual Basic
Public Const IMPLANT_ASSEMBLY_TEMPLATE_VERSION As UInteger
Visual C++
public:
literal unsigned int IMPLANT_ASSEMBLY_TEMPLATE_VERSION

See Also

MCdicom Structure
MCdicom Members


IMPLANT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_NAME Field
MCdicom Structure See Also Send Feedback
Implant Name (0022,1095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_NAME
Visual Basic
Public Const IMPLANT_NAME As UInteger
Visual C++
public:
literal unsigned int IMPLANT_NAME

See Also

MCdicom Structure
MCdicom Members


IMPLANT_PART_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_PART_NUMBER Field
MCdicom Structure See Also Send Feedback
Implant Part Number (0022,1097)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_PART_NUMBER
Visual Basic
Public Const IMPLANT_PART_NUMBER As UInteger
Visual C++
public:
literal unsigned int IMPLANT_PART_NUMBER

See Also

MCdicom Structure
MCdicom Members


IMPLANT_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_PRESENT Field
MCdicom Structure See Also Send Feedback
Alias for tag BREAST_IMPLANT_PRESENT (0028,1300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_PRESENT
Visual Basic
Public Const IMPLANT_PRESENT As UInteger
Visual C++
public:
literal unsigned int IMPLANT_PRESENT

See Also

MCdicom Structure
MCdicom Members


IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Regulatory Disapproval Code Sequence (0068,62A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE
Visual Basic
Public Const IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_REGULATORY_DISAPPROVAL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_SIZE Field
MCdicom Structure See Also Send Feedback
Implant Size (0068,6210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_SIZE
Visual Basic
Public Const IMPLANT_SIZE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_SIZE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TARGET_ANATOMY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TARGET_ANATOMY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Target Anatomy Sequence (0068,6230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TARGET_ANATOMY_SEQUENCE
Visual Basic
Public Const IMPLANT_TARGET_ANATOMY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TARGET_ANATOMY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER Field
MCdicom Structure See Also Send Feedback
Implant Template 3D Model Surface Number (0068,6350)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER
Visual Basic
Public Const IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_3D_MODEL_SURFACE_NUMBER

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Implant Template Group Description (0078,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_DESCRIPTION
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_ISSUER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_ISSUER Field
MCdicom Structure See Also Send Feedback
Implant Template Group Issuer (0078,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_ISSUER
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_ISSUER As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_ISSUER

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_MEMBER_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_MEMBER_ID Field
MCdicom Structure See Also Send Feedback
Implant Template Group Member ID (0078,002E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_MEMBER_ID
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_MEMBER_ID As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_MEMBER_ID

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Template Group Member Matching 2D Coordinates Sequence (0078,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_2D_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Template Group Members Sequence (0078,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_MEMBERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_NAME Field
MCdicom Structure See Also Send Feedback
Implant Template Group Name (0078,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_NAME
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_NAME As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_NAME

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Template Group Target Anatomy Sequence (0078,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_TARGET_ANATOMY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME Field
MCdicom Structure See Also Send Feedback
Implant Template Group Variation Dimension Name (0078,00B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_NAME

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK Field
MCdicom Structure See Also Send Feedback
Implant Template Group Variation Dimension Rank (0078,00B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Template Group Variation Dimension Rank Sequence (0078,00B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_RANK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Template Group Variation Dimension Sequence (0078,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_VARIATION_DIMENSION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_GROUP_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_GROUP_VERSION Field
MCdicom Structure See Also Send Feedback
Implant Template Group Version (0078,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_GROUP_VERSION
Visual Basic
Public Const IMPLANT_TEMPLATE_GROUP_VERSION As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_GROUP_VERSION

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TEMPLATE_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TEMPLATE_VERSION Field
MCdicom Structure See Also Send Feedback
Implant Template Version (0068,6221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TEMPLATE_VERSION
Visual Basic
Public Const IMPLANT_TEMPLATE_VERSION As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TEMPLATE_VERSION

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TYPE Field
MCdicom Structure See Also Send Feedback
Implant Type (0068,6223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TYPE
Visual Basic
Public Const IMPLANT_TYPE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TYPE

See Also

MCdicom Structure
MCdicom Members


IMPLANT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLANT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Implant Type Code Sequence (0068,63A8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLANT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const IMPLANT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IMPLANT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IMPLEMENTATION_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLEMENTATION_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Implementation Class UID (0002,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLEMENTATION_CLASS_UID
Visual Basic
Public Const IMPLEMENTATION_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int IMPLEMENTATION_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


IMPLEMENTATION_VERSION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPLEMENTATION_VERSION_NAME Field
MCdicom Structure See Also Send Feedback
Implementation Version Name (0002,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPLEMENTATION_VERSION_NAME
Visual Basic
Public Const IMPLEMENTATION_VERSION_NAME As UInteger
Visual C++
public:
literal unsigned int IMPLEMENTATION_VERSION_NAME

See Also

MCdicom Structure
MCdicom Members


IMPRESSIONS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IMPRESSIONS_RETIRED Field
MCdicom Structure See Also Send Feedback
Impressions RETIRED (4008,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IMPRESSIONS_RETIRED
Visual Basic
Public Const IMPRESSIONS_RETIRED As UInteger
Visual C++
public:
literal unsigned int IMPRESSIONS_RETIRED

See Also

MCdicom Structure
MCdicom Members


IN_CONCATENATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IN_CONCATENATION_NUMBER Field
MCdicom Structure See Also Send Feedback
In-concatenation Number (0020,9162)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IN_CONCATENATION_NUMBER
Visual Basic
Public Const IN_CONCATENATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int IN_CONCATENATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


IN_CONCATENATION_TOTAL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IN_CONCATENATION_TOTAL_NUMBER Field
MCdicom Structure See Also Send Feedback
In-concatenation Total Number (0020,9163)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IN_CONCATENATION_TOTAL_NUMBER
Visual Basic
Public Const IN_CONCATENATION_TOTAL_NUMBER As UInteger
Visual C++
public:
literal unsigned int IN_CONCATENATION_TOTAL_NUMBER

See Also

MCdicom Structure
MCdicom Members


IN_PLANE_PHASE_ENCODING_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IN_PLANE_PHASE_ENCODING_DIRECTION Field
MCdicom Structure See Also Send Feedback
In-plane Phase Encoding Direction (0018,1312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IN_PLANE_PHASE_ENCODING_DIRECTION
Visual Basic
Public Const IN_PLANE_PHASE_ENCODING_DIRECTION As UInteger
Visual C++
public:
literal unsigned int IN_PLANE_PHASE_ENCODING_DIRECTION

See Also

MCdicom Structure
MCdicom Members


IN_STACK_POSITION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IN_STACK_POSITION_NUMBER Field
MCdicom Structure See Also Send Feedback
In-Stack Position Number (0020,9057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IN_STACK_POSITION_NUMBER
Visual Basic
Public Const IN_STACK_POSITION_NUMBER As UInteger
Visual C++
public:
literal unsigned int IN_STACK_POSITION_NUMBER

See Also

MCdicom Structure
MCdicom Members


INBOUND_ARRIVAL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INBOUND_ARRIVAL_TYPE Field
MCdicom Structure See Also Send Feedback
Inbound Arrival Type (4010,1056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INBOUND_ARRIVAL_TYPE
Visual Basic
Public Const INBOUND_ARRIVAL_TYPE As UInteger
Visual C++
public:
literal unsigned int INBOUND_ARRIVAL_TYPE

See Also

MCdicom Structure
MCdicom Members


INCIDENT_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCIDENT_ANGLE Field
MCdicom Structure See Also Send Feedback
Incident Angle (0014,4052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCIDENT_ANGLE
Visual Basic
Public Const INCIDENT_ANGLE As UInteger
Visual C++
public:
literal unsigned int INCIDENT_ANGLE

See Also

MCdicom Structure
MCdicom Members


INCLUDE_DISPLAY_APPLICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCLUDE_DISPLAY_APPLICATION Field
MCdicom Structure See Also Send Feedback
Include Display Application (2200,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCLUDE_DISPLAY_APPLICATION
Visual Basic
Public Const INCLUDE_DISPLAY_APPLICATION As UInteger
Visual C++
public:
literal unsigned int INCLUDE_DISPLAY_APPLICATION

See Also

MCdicom Structure
MCdicom Members


INCLUDE_NON_DICOM_OBJECTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCLUDE_NON_DICOM_OBJECTS Field
MCdicom Structure See Also Send Feedback
Include Non-DICOM Objects (2200,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCLUDE_NON_DICOM_OBJECTS
Visual Basic
Public Const INCLUDE_NON_DICOM_OBJECTS As UInteger
Visual C++
public:
literal unsigned int INCLUDE_NON_DICOM_OBJECTS

See Also

MCdicom Structure
MCdicom Members


INCLUDES_IMAGING_SUBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCLUDES_IMAGING_SUBJECT Field
MCdicom Structure See Also Send Feedback
Includes Imaging Subject (0034,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCLUDES_IMAGING_SUBJECT
Visual Basic
Public Const INCLUDES_IMAGING_SUBJECT As UInteger
Visual C++
public:
literal unsigned int INCLUDES_IMAGING_SUBJECT

See Also

MCdicom Structure
MCdicom Members


INCLUDES_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCLUDES_INFORMATION Field
MCdicom Structure See Also Send Feedback
Includes Information (0034,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCLUDES_INFORMATION
Visual Basic
Public Const INCLUDES_INFORMATION As UInteger
Visual C++
public:
literal unsigned int INCLUDES_INFORMATION

See Also

MCdicom Structure
MCdicom Members


INCORPORATED_INVENTORY_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INCORPORATED_INVENTORY_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Incorporated Inventory Instance Sequence (0008,0422)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INCORPORATED_INVENTORY_INSTANCE_SEQUENCE
Visual Basic
Public Const INCORPORATED_INVENTORY_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INCORPORATED_INVENTORY_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INDEX_NORMALS_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDEX_NORMALS_FLAG Field
MCdicom Structure See Also Send Feedback
Index Normals Flag (0024,0338)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDEX_NORMALS_FLAG
Visual Basic
Public Const INDEX_NORMALS_FLAG As UInteger
Visual C++
public:
literal unsigned int INDEX_NORMALS_FLAG

See Also

MCdicom Structure
MCdicom Members


INDEX_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDEX_PROBABILITY Field
MCdicom Structure See Also Send Feedback
Index Probability (0024,0341)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDEX_PROBABILITY
Visual Basic
Public Const INDEX_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int INDEX_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


INDEX_PROBABILITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDEX_PROBABILITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Index Probability Sequence (0024,0344)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDEX_PROBABILITY_SEQUENCE
Visual Basic
Public Const INDEX_PROBABILITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INDEX_PROBABILITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INDICATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Indication Description (0014,2018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_DESCRIPTION
Visual Basic
Public Const INDICATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INDICATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INDICATION_DISPOSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_DISPOSITION Field
MCdicom Structure See Also Send Feedback
Indication Disposition (0014,201C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_DISPOSITION
Visual Basic
Public Const INDICATION_DISPOSITION As UInteger
Visual C++
public:
literal unsigned int INDICATION_DISPOSITION

See Also

MCdicom Structure
MCdicom Members


INDICATION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_LABEL Field
MCdicom Structure See Also Send Feedback
Indication Label (0014,2016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_LABEL
Visual Basic
Public Const INDICATION_LABEL As UInteger
Visual C++
public:
literal unsigned int INDICATION_LABEL

See Also

MCdicom Structure
MCdicom Members


INDICATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_NUMBER Field
MCdicom Structure See Also Send Feedback
Indication Number (0014,2014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_NUMBER
Visual Basic
Public Const INDICATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int INDICATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


INDICATION_PHYSICAL_PROPERTY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_PHYSICAL_PROPERTY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Indication Physical Property Sequence (0014,2030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_PHYSICAL_PROPERTY_SEQUENCE
Visual Basic
Public Const INDICATION_PHYSICAL_PROPERTY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INDICATION_PHYSICAL_PROPERTY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INDICATION_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Indication ROI Sequence (0014,201E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_ROI_SEQUENCE
Visual Basic
Public Const INDICATION_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INDICATION_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INDICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Indication Sequence (0014,2012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_SEQUENCE
Visual Basic
Public Const INDICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INDICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INDICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INDICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Indication Type (0014,201A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INDICATION_TYPE
Visual Basic
Public Const INDICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int INDICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


INFORMATION_FROM_MANUFACTURER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INFORMATION_FROM_MANUFACTURER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Information From Manufacturer Sequence (0068,6260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INFORMATION_FROM_MANUFACTURER_SEQUENCE
Visual Basic
Public Const INFORMATION_FROM_MANUFACTURER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INFORMATION_FROM_MANUFACTURER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INFORMATION_ISSUE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INFORMATION_ISSUE_DATETIME Field
MCdicom Structure See Also Send Feedback
Information Issue DateTime (0068,6270)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INFORMATION_ISSUE_DATETIME
Visual Basic
Public Const INFORMATION_ISSUE_DATETIME As UInteger
Visual C++
public:
literal unsigned int INFORMATION_ISSUE_DATETIME

See Also

MCdicom Structure
MCdicom Members


INFORMATION_SUMMARY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INFORMATION_SUMMARY Field
MCdicom Structure See Also Send Feedback
Information Summary (0068,6280)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INFORMATION_SUMMARY
Visual Basic
Public Const INFORMATION_SUMMARY As UInteger
Visual C++
public:
literal unsigned int INFORMATION_SUMMARY

See Also

MCdicom Structure
MCdicom Members


INITIAL_CINE_RUN_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INITIAL_CINE_RUN_STATE Field
MCdicom Structure See Also Send Feedback
Initial Cine Run State (0018,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INITIAL_CINE_RUN_STATE
Visual Basic
Public Const INITIAL_CINE_RUN_STATE As UInteger
Visual C++
public:
literal unsigned int INITIAL_CINE_RUN_STATE

See Also

MCdicom Structure
MCdicom Members


INITIATOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INITIATOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Initiator RETIRED (0000,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INITIATOR_RETIRED
Visual Basic
Public Const INITIATOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int INITIATOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


INNER_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INNER_DIAMETER Field
MCdicom Structure See Also Send Feedback
Inner Diameter (0014,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INNER_DIAMETER
Visual Basic
Public Const INNER_DIAMETER As UInteger
Visual C++
public:
literal unsigned int INNER_DIAMETER

See Also

MCdicom Structure
MCdicom Members


INPUT_AVAILABILITY_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INPUT_AVAILABILITY_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Input Availability Flag RETIRED (0040,4020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INPUT_AVAILABILITY_FLAG_RETIRED
Visual Basic
Public Const INPUT_AVAILABILITY_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int INPUT_AVAILABILITY_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


INPUT_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INPUT_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Input Information Sequence (0040,4021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INPUT_INFORMATION_SEQUENCE
Visual Basic
Public Const INPUT_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INPUT_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INPUT_READINESS_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INPUT_READINESS_STATE Field
MCdicom Structure See Also Send Feedback
Input Readiness State (0040,4041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INPUT_READINESS_STATE
Visual Basic
Public Const INPUT_READINESS_STATE As UInteger
Visual C++
public:
literal unsigned int INPUT_READINESS_STATE

See Also

MCdicom Structure
MCdicom Members


INPUT_SEQUENCE_POSITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INPUT_SEQUENCE_POSITION_INDEX Field
MCdicom Structure See Also Send Feedback
Input Sequence Position Index (0070,1203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INPUT_SEQUENCE_POSITION_INDEX
Visual Basic
Public Const INPUT_SEQUENCE_POSITION_INDEX As UInteger
Visual C++
public:
literal unsigned int INPUT_SEQUENCE_POSITION_INDEX

See Also

MCdicom Structure
MCdicom Members


INSTANCE_AVAILABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_AVAILABILITY Field
MCdicom Structure See Also Send Feedback
Instance Availability (0008,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_AVAILABILITY
Visual Basic
Public Const INSTANCE_AVAILABILITY As UInteger
Visual C++
public:
literal unsigned int INSTANCE_AVAILABILITY

See Also

MCdicom Structure
MCdicom Members


INSTANCE_COERCION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_COERCION_DATETIME Field
MCdicom Structure See Also Send Feedback
Instance Coercion DateTime (0008,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_COERCION_DATETIME
Visual Basic
Public Const INSTANCE_COERCION_DATETIME As UInteger
Visual C++
public:
literal unsigned int INSTANCE_COERCION_DATETIME

See Also

MCdicom Structure
MCdicom Members


INSTANCE_CREATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_CREATION_DATE Field
MCdicom Structure See Also Send Feedback
Instance Creation Date (0008,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_CREATION_DATE
Visual Basic
Public Const INSTANCE_CREATION_DATE As UInteger
Visual C++
public:
literal unsigned int INSTANCE_CREATION_DATE

See Also

MCdicom Structure
MCdicom Members


INSTANCE_CREATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_CREATION_TIME Field
MCdicom Structure See Also Send Feedback
Instance Creation Time (0008,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_CREATION_TIME
Visual Basic
Public Const INSTANCE_CREATION_TIME As UInteger
Visual C++
public:
literal unsigned int INSTANCE_CREATION_TIME

See Also

MCdicom Structure
MCdicom Members


INSTANCE_CREATOR_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_CREATOR_UID Field
MCdicom Structure See Also Send Feedback
Instance Creator UID (0008,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_CREATOR_UID
Visual Basic
Public Const INSTANCE_CREATOR_UID As UInteger
Visual C++
public:
literal unsigned int INSTANCE_CREATOR_UID

See Also

MCdicom Structure
MCdicom Members


INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Instance-Level Referenced Performed Procedure Step Sequence (3010,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE
Visual Basic
Public Const INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INSTANCE_LEVEL_REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INSTANCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Instance Number (0020,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_NUMBER
Visual Basic
Public Const INSTANCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int INSTANCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


INSTANCE_ORIGIN_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTANCE_ORIGIN_STATUS Field
MCdicom Structure See Also Send Feedback
Instance Origin Status (0400,0600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTANCE_ORIGIN_STATUS
Visual Basic
Public Const INSTANCE_ORIGIN_STATUS As UInteger
Visual C++
public:
literal unsigned int INSTANCE_ORIGIN_STATUS

See Also

MCdicom Structure
MCdicom Members


INSTITUTION_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTITUTION_ADDRESS Field
MCdicom Structure See Also Send Feedback
Institution Address (0008,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTITUTION_ADDRESS
Visual Basic
Public Const INSTITUTION_ADDRESS As UInteger
Visual C++
public:
literal unsigned int INSTITUTION_ADDRESS

See Also

MCdicom Structure
MCdicom Members


INSTITUTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTITUTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Institution Code Sequence (0008,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTITUTION_CODE_SEQUENCE
Visual Basic
Public Const INSTITUTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INSTITUTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INSTITUTION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTITUTION_NAME Field
MCdicom Structure See Also Send Feedback
Institution Name (0008,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTITUTION_NAME
Visual Basic
Public Const INSTITUTION_NAME As UInteger
Visual C++
public:
literal unsigned int INSTITUTION_NAME

See Also

MCdicom Structure
MCdicom Members


INSTITUTIONAL_DEPARTMENT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTITUTIONAL_DEPARTMENT_NAME Field
MCdicom Structure See Also Send Feedback
Institutional Department Name (0008,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTITUTIONAL_DEPARTMENT_NAME
Visual Basic
Public Const INSTITUTIONAL_DEPARTMENT_NAME As UInteger
Visual C++
public:
literal unsigned int INSTITUTIONAL_DEPARTMENT_NAME

See Also

MCdicom Structure
MCdicom Members


INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Institutional Department Type Code Sequence (0008,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INSTITUTIONAL_DEPARTMENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Instruction Description (0018,9917)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_DESCRIPTION
Visual Basic
Public Const INSTRUCTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_INDEX Field
MCdicom Structure See Also Send Feedback
Instruction Index (0018,9915)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_INDEX
Visual Basic
Public Const INSTRUCTION_INDEX As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_INDEX

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_PERFORMANCE_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_PERFORMANCE_COMMENT Field
MCdicom Structure See Also Send Feedback
Instruction Performance Comment (0018,991A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_PERFORMANCE_COMMENT
Visual Basic
Public Const INSTRUCTION_PERFORMANCE_COMMENT As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_PERFORMANCE_COMMENT

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_PERFORMED_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_PERFORMED_DATETIME Field
MCdicom Structure See Also Send Feedback
Instruction Performed DateTime (0018,9919)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_PERFORMED_DATETIME
Visual Basic
Public Const INSTRUCTION_PERFORMED_DATETIME As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_PERFORMED_DATETIME

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_PERFORMED_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_PERFORMED_FLAG Field
MCdicom Structure See Also Send Feedback
Instruction Performed Flag (0018,9918)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_PERFORMED_FLAG
Visual Basic
Public Const INSTRUCTION_PERFORMED_FLAG As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_PERFORMED_FLAG

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Instruction Sequence (0018,9914)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_SEQUENCE
Visual Basic
Public Const INSTRUCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INSTRUCTION_TEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSTRUCTION_TEXT Field
MCdicom Structure See Also Send Feedback
Instruction Text (0018,9916)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSTRUCTION_TEXT
Visual Basic
Public Const INSTRUCTION_TEXT As UInteger
Visual C++
public:
literal unsigned int INSTRUCTION_TEXT

See Also

MCdicom Structure
MCdicom Members


INSURANCE_PLAN_IDENTIFICATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INSURANCE_PLAN_IDENTIFICATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Insurance Plan Identification RETIRED (0010,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INSURANCE_PLAN_IDENTIFICATION_RETIRED
Visual Basic
Public Const INSURANCE_PLAN_IDENTIFICATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int INSURANCE_PLAN_IDENTIFICATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTENDED_DELIVERY_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_DELIVERY_DURATION Field
MCdicom Structure See Also Send Feedback
Intended Delivery Duration (3010,007E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_DELIVERY_DURATION
Visual Basic
Public Const INTENDED_DELIVERY_DURATION As UInteger
Visual C++
public:
literal unsigned int INTENDED_DELIVERY_DURATION

See Also

MCdicom Structure
MCdicom Members


INTENDED_FRACTION_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_FRACTION_START_TIME Field
MCdicom Structure See Also Send Feedback
Intended Fraction Start Time (3010,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_FRACTION_START_TIME
Visual Basic
Public Const INTENDED_FRACTION_START_TIME As UInteger
Visual C++
public:
literal unsigned int INTENDED_FRACTION_START_TIME

See Also

MCdicom Structure
MCdicom Members


INTENDED_NUMBER_OF_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_NUMBER_OF_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Intended Number of Fractions (300A,0636)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_NUMBER_OF_FRACTIONS
Visual Basic
Public Const INTENDED_NUMBER_OF_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int INTENDED_NUMBER_OF_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


INTENDED_PHASE_END_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_PHASE_END_DATE Field
MCdicom Structure See Also Send Feedback
Intended Phase End Date (3010,004D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_PHASE_END_DATE
Visual Basic
Public Const INTENDED_PHASE_END_DATE As UInteger
Visual C++
public:
literal unsigned int INTENDED_PHASE_END_DATE

See Also

MCdicom Structure
MCdicom Members


INTENDED_PHASE_START_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_PHASE_START_DATE Field
MCdicom Structure See Also Send Feedback
Intended Phase Start Date (3010,004C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_PHASE_START_DATE
Visual Basic
Public Const INTENDED_PHASE_START_DATE As UInteger
Visual C++
public:
literal unsigned int INTENDED_PHASE_START_DATE

See Also

MCdicom Structure
MCdicom Members


INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intended Recipients of Results Identification Sequence (0040,1011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag INTENDED_RECIPIENTS_OF_RESULTS_IDENTIFICATION_SEQUENCE (0040,1011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTENDED_RECP_OF_RESULTS_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTENDED_RT_TREATMENT_PHASE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_RT_TREATMENT_PHASE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intended RT Treatment Phase Sequence (3010,004B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_RT_TREATMENT_PHASE_SEQUENCE
Visual Basic
Public Const INTENDED_RT_TREATMENT_PHASE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTENDED_RT_TREATMENT_PHASE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTENDED_START_DAY_OF_WEEK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENDED_START_DAY_OF_WEEK Field
MCdicom Structure See Also Send Feedback
Intended Start Day of Week (3010,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENDED_START_DAY_OF_WEEK
Visual Basic
Public Const INTENDED_START_DAY_OF_WEEK As UInteger
Visual C++
public:
literal unsigned int INTENDED_START_DAY_OF_WEEK

See Also

MCdicom Structure
MCdicom Members


INTENSIFIER_ACTIVE_DIMENSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENSIFIER_ACTIVE_DIMENSIONS Field
MCdicom Structure See Also Send Feedback
Intensifier Active Dimension(s) (0018,9428)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENSIFIER_ACTIVE_DIMENSIONS
Visual Basic
Public Const INTENSIFIER_ACTIVE_DIMENSIONS As UInteger
Visual C++
public:
literal unsigned int INTENSIFIER_ACTIVE_DIMENSIONS

See Also

MCdicom Structure
MCdicom Members


INTENSIFIER_ACTIVE_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENSIFIER_ACTIVE_SHAPE Field
MCdicom Structure See Also Send Feedback
Intensifier Active Shape (0018,9427)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENSIFIER_ACTIVE_SHAPE
Visual Basic
Public Const INTENSIFIER_ACTIVE_SHAPE As UInteger
Visual C++
public:
literal unsigned int INTENSIFIER_ACTIVE_SHAPE

See Also

MCdicom Structure
MCdicom Members


INTENSIFIER_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTENSIFIER_SIZE Field
MCdicom Structure See Also Send Feedback
Intensifier Size (0018,1162)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTENSIFIER_SIZE
Visual Basic
Public Const INTENSIFIER_SIZE As UInteger
Visual C++
public:
literal unsigned int INTENSIFIER_SIZE

See Also

MCdicom Structure
MCdicom Members


INTER_MARKER_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTER_MARKER_DISTANCE Field
MCdicom Structure See Also Send Feedback
Inter-Marker Distance (0050,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTER_MARKER_DISTANCE
Visual Basic
Public Const INTER_MARKER_DISTANCE As UInteger
Visual C++
public:
literal unsigned int INTER_MARKER_DISTANCE

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Interlock Code Sequence (300A,0744)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_CODE_SEQUENCE
Visual Basic
Public Const INTERLOCK_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_DATETIME Field
MCdicom Structure See Also Send Feedback
Interlock DateTime (300A,0741)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_DATETIME
Visual Basic
Public Const INTERLOCK_DATETIME As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_DATETIME

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Interlock Description (300A,0742)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_DESCRIPTION
Visual Basic
Public Const INTERLOCK_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_ORIGIN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_ORIGIN_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Interlock Origin Description (300A,0783)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_ORIGIN_DESCRIPTION
Visual Basic
Public Const INTERLOCK_ORIGIN_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_ORIGIN_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_ORIGINATING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_ORIGINATING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Interlock Originating Device Sequence (300A,0743)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_ORIGINATING_DEVICE_SEQUENCE
Visual Basic
Public Const INTERLOCK_ORIGINATING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_ORIGINATING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_RESOLUTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_RESOLUTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Interlock Resolution Code Sequence (300A,0745)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_RESOLUTION_CODE_SEQUENCE
Visual Basic
Public Const INTERLOCK_RESOLUTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_RESOLUTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_RESOLUTION_USER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_RESOLUTION_USER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Interlock Resolution User Sequence (300A,0746)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_RESOLUTION_USER_SEQUENCE
Visual Basic
Public Const INTERLOCK_RESOLUTION_USER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_RESOLUTION_USER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERLOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERLOCK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Interlock Sequence (300A,0740)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERLOCK_SEQUENCE
Visual Basic
Public Const INTERLOCK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERLOCK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERMEDIATE_PUPILLARY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERMEDIATE_PUPILLARY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Intermediate Pupillary Distance (0046,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERMEDIATE_PUPILLARY_DISTANCE
Visual Basic
Public Const INTERMEDIATE_PUPILLARY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int INTERMEDIATE_PUPILLARY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


INTERNAL_DETECTOR_FRAME_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERNAL_DETECTOR_FRAME_TIME Field
MCdicom Structure See Also Send Feedback
Internal Detector Frame Time (0014,3011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERNAL_DETECTOR_FRAME_TIME
Visual Basic
Public Const INTERNAL_DETECTOR_FRAME_TIME As UInteger
Visual C++
public:
literal unsigned int INTERNAL_DETECTOR_FRAME_TIME

See Also

MCdicom Structure
MCdicom Members


INTERNATIONAL_ROUTE_SEGMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERNATIONAL_ROUTE_SEGMENT Field
MCdicom Structure See Also Send Feedback
International Route Segment (4010,1028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERNATIONAL_ROUTE_SEGMENT
Visual Basic
Public Const INTERNATIONAL_ROUTE_SEGMENT As UInteger
Visual C++
public:
literal unsigned int INTERNATIONAL_ROUTE_SEGMENT

See Also

MCdicom Structure
MCdicom Members


INTEROPERABILITY_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTEROPERABILITY_INDEX Field
MCdicom Structure See Also Send Feedback
Interoperability Index (0016,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTEROPERABILITY_INDEX
Visual Basic
Public Const INTEROPERABILITY_INDEX As UInteger
Visual C++
public:
literal unsigned int INTEROPERABILITY_INDEX

See Also

MCdicom Structure
MCdicom Members


INTEROPERABILITY_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTEROPERABILITY_VERSION Field
MCdicom Structure See Also Send Feedback
Interoperability Version (0016,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTEROPERABILITY_VERSION
Visual Basic
Public Const INTEROPERABILITY_VERSION As UInteger
Visual C++
public:
literal unsigned int INTEROPERABILITY_VERSION

See Also

MCdicom Structure
MCdicom Members


INTERPOLATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPOLATION_TYPE Field
MCdicom Structure See Also Send Feedback
Interpolation Type (0052,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPOLATION_TYPE
Visual Basic
Public Const INTERPOLATION_TYPE As UInteger
Visual C++
public:
literal unsigned int INTERPOLATION_TYPE

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_APPROVAL_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_APPROVAL_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Approval Date RETIRED (4008,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_APPROVAL_DATE_RETIRED
Visual Basic
Public Const INTERPRETATION_APPROVAL_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_APPROVAL_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_APPROVAL_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_APPROVAL_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Approval Time RETIRED (4008,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_APPROVAL_TIME_RETIRED
Visual Basic
Public Const INTERPRETATION_APPROVAL_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_APPROVAL_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_APPROVER_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_APPROVER_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Approver Sequence RETIRED (4008,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_APPROVER_SEQUENCE_RETIRED
Visual Basic
Public Const INTERPRETATION_APPROVER_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_APPROVER_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_AUTHOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_AUTHOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Author RETIRED (4008,010C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_AUTHOR_RETIRED
Visual Basic
Public Const INTERPRETATION_AUTHOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_AUTHOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Diagnosis Code Sequence RETIRED (4008,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_DIAGNOSIS_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Diagnosis Description RETIRED (4008,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED
Visual Basic
Public Const INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_DIAGNOSIS_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_ID_ISSUER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_ID_ISSUER_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation ID Issuer RETIRED (4008,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_ID_ISSUER_RETIRED
Visual Basic
Public Const INTERPRETATION_ID_ISSUER_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_ID_ISSUER_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation ID RETIRED (4008,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_ID_RETIRED
Visual Basic
Public Const INTERPRETATION_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_RECORDED_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_RECORDED_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Recorded Date RETIRED (4008,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_RECORDED_DATE_RETIRED
Visual Basic
Public Const INTERPRETATION_RECORDED_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_RECORDED_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_RECORDED_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_RECORDED_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Recorded Time RETIRED (4008,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_RECORDED_TIME_RETIRED
Visual Basic
Public Const INTERPRETATION_RECORDED_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_RECORDED_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_RECORDER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_RECORDER_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Recorder RETIRED (4008,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_RECORDER_RETIRED
Visual Basic
Public Const INTERPRETATION_RECORDER_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_RECORDER_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_STATUS_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_STATUS_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Status ID RETIRED (4008,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_STATUS_ID_RETIRED
Visual Basic
Public Const INTERPRETATION_STATUS_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_STATUS_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_TEXT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_TEXT_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Text RETIRED (4008,010B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_TEXT_RETIRED
Visual Basic
Public Const INTERPRETATION_TEXT_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_TEXT_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_TRANSCRIBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_TRANSCRIBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Transcriber RETIRED (4008,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_TRANSCRIBER_RETIRED
Visual Basic
Public Const INTERPRETATION_TRANSCRIBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_TRANSCRIBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_TRANSCRIPTION_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_TRANSCRIPTION_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Transcription Date RETIRED (4008,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_TRANSCRIPTION_DATE_RETIRED
Visual Basic
Public Const INTERPRETATION_TRANSCRIPTION_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_TRANSCRIPTION_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_TRANSCRIPTION_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_TRANSCRIPTION_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Transcription Time RETIRED (4008,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_TRANSCRIPTION_TIME_RETIRED
Visual Basic
Public Const INTERPRETATION_TRANSCRIPTION_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_TRANSCRIPTION_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERPRETATION_TYPE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERPRETATION_TYPE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Interpretation Type ID RETIRED (4008,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERPRETATION_TYPE_ID_RETIRED
Visual Basic
Public Const INTERPRETATION_TYPE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERPRETATION_TYPE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERVAL_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVAL_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Interval Number RETIRED (0020,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVAL_NUMBER_RETIRED
Visual Basic
Public Const INTERVAL_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int INTERVAL_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


INTERVALS_ACQUIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVALS_ACQUIRED Field
MCdicom Structure See Also Send Feedback
Intervals Acquired (0018,1083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVALS_ACQUIRED
Visual Basic
Public Const INTERVALS_ACQUIRED As UInteger
Visual C++
public:
literal unsigned int INTERVALS_ACQUIRED

See Also

MCdicom Structure
MCdicom Members


INTERVALS_REJECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVALS_REJECTED Field
MCdicom Structure See Also Send Feedback
Intervals Rejected (0018,1084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVALS_REJECTED
Visual Basic
Public Const INTERVALS_REJECTED As UInteger
Visual C++
public:
literal unsigned int INTERVALS_REJECTED

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Intervention Description (0018,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DESCRIPTION
Visual Basic
Public Const INTERVENTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intervention Drug Code Sequence (0018,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_CODE_SEQUENCE
Visual Basic
Public Const INTERVENTION_DRUG_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_DOSE Field
MCdicom Structure See Also Send Feedback
Intervention Drug Dose (0018,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_DOSE
Visual Basic
Public Const INTERVENTION_DRUG_DOSE As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_DOSE

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intervention Drug Information Sequence (0018,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_INFORMATION_SEQUENCE
Visual Basic
Public Const INTERVENTION_DRUG_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_NAME Field
MCdicom Structure See Also Send Feedback
Intervention Drug Name (0018,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_NAME
Visual Basic
Public Const INTERVENTION_DRUG_NAME As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_NAME

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_SEQUENCE
Visual Basic
Public Const INTERVENTION_DRUG_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_START_TIME Field
MCdicom Structure See Also Send Feedback
Intervention Drug Start Time (0018,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_START_TIME
Visual Basic
Public Const INTERVENTION_DRUG_START_TIME As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_START_TIME

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_DRUG_STOP_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_DRUG_STOP_TIME Field
MCdicom Structure See Also Send Feedback
Intervention Drug Stop Time (0018,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_DRUG_STOP_TIME
Visual Basic
Public Const INTERVENTION_DRUG_STOP_TIME As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_DRUG_STOP_TIME

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intervention Sequence (0018,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_SEQUENCE
Visual Basic
Public Const INTERVENTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERVENTION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTION_STATUS Field
MCdicom Structure See Also Send Feedback
Intervention Status (0018,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTION_STATUS
Visual Basic
Public Const INTERVENTION_STATUS As UInteger
Visual C++
public:
literal unsigned int INTERVENTION_STATUS

See Also

MCdicom Structure
MCdicom Members


INTERVENTIONAL_DRUG_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTIONAL_DRUG_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag INTERVENTION_DRUG_CODE_SEQUENCE (0018,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTIONAL_DRUG_CODE_SEQUENCE
Visual Basic
Public Const INTERVENTIONAL_DRUG_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTIONAL_DRUG_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTERVENTIONAL_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTIONAL_STATUS Field
MCdicom Structure See Also Send Feedback
Alias for tag INTERVENTION_STATUS (0018,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTIONAL_STATUS
Visual Basic
Public Const INTERVENTIONAL_STATUS As UInteger
Visual C++
public:
literal unsigned int INTERVENTIONAL_STATUS

See Also

MCdicom Structure
MCdicom Members


INTERVENTIONAL_THERAPY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTERVENTIONAL_THERAPY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag INTERVENTION_SEQUENCE (0018,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTERVENTIONAL_THERAPY_SEQUENCE
Visual Basic
Public Const INTERVENTIONAL_THERAPY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTERVENTIONAL_THERAPY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTRA_OCULAR_PRESSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRA_OCULAR_PRESSURE Field
MCdicom Structure See Also Send Feedback
Intra Ocular Pressure (0022,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRA_OCULAR_PRESSURE
Visual Basic
Public Const INTRA_OCULAR_PRESSURE As UInteger
Visual C++
public:
literal unsigned int INTRA_OCULAR_PRESSURE

See Also

MCdicom Structure
MCdicom Members


INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intraocular Lens Calculations Left Eye Sequence (0022,1310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE
Visual Basic
Public Const INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTRAOCULAR_LENS_CALCULATIONS_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intraocular Lens Calculations Right Eye Sequence (0022,1300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTRAOCULAR_LENS_CALCULATIONS_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTRAVASCULAR_FRAME_CONTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAVASCULAR_FRAME_CONTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intravascular Frame Content Sequence (0052,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAVASCULAR_FRAME_CONTENT_SEQUENCE
Visual Basic
Public Const INTRAVASCULAR_FRAME_CONTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTRAVASCULAR_FRAME_CONTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTRAVASCULAR_LONGITUDINAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAVASCULAR_LONGITUDINAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
Intravascular Longitudinal Distance (0052,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAVASCULAR_LONGITUDINAL_DISTANCE
Visual Basic
Public Const INTRAVASCULAR_LONGITUDINAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int INTRAVASCULAR_LONGITUDINAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intravascular OCT Frame Content Sequence (0052,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE
Visual Basic
Public Const INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTRAVASCULAR_OCT_FRAME_CONTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Intravascular OCT Frame Type Sequence (0052,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INTRAVASCULAR_OCT_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INVENTORIED_INSTANCES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORIED_INSTANCES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Inventoried Instances Sequence (0008,0425)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORIED_INSTANCES_SEQUENCE
Visual Basic
Public Const INVENTORIED_INSTANCES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INVENTORIED_INSTANCES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INVENTORIED_SERIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORIED_SERIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Inventoried Series Sequence (0008,0424)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORIED_SERIES_SEQUENCE
Visual Basic
Public Const INVENTORIED_SERIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INVENTORIED_SERIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INVENTORIED_STUDIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORIED_STUDIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Inventoried Studies Sequence (0008,0423)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORIED_STUDIES_SEQUENCE
Visual Basic
Public Const INVENTORIED_STUDIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INVENTORIED_STUDIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INVENTORY_ACCESS_END_POINTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORY_ACCESS_END_POINTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Inventory Access End Points Sequence (0008,0420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORY_ACCESS_END_POINTS_SEQUENCE
Visual Basic
Public Const INVENTORY_ACCESS_END_POINTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int INVENTORY_ACCESS_END_POINTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


INVENTORY_COMPLETION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORY_COMPLETION_STATUS Field
MCdicom Structure See Also Send Feedback
Inventory Completion Status (0008,0426)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORY_COMPLETION_STATUS
Visual Basic
Public Const INVENTORY_COMPLETION_STATUS As UInteger
Visual C++
public:
literal unsigned int INVENTORY_COMPLETION_STATUS

See Also

MCdicom Structure
MCdicom Members


INVENTORY_INSTANCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORY_INSTANCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Inventory Instance Description (0008,0402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORY_INSTANCE_DESCRIPTION
Visual Basic
Public Const INVENTORY_INSTANCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int INVENTORY_INSTANCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


INVENTORY_LEVEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORY_LEVEL Field
MCdicom Structure See Also Send Feedback
Inventory Level (0008,0403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORY_LEVEL
Visual Basic
Public Const INVENTORY_LEVEL As UInteger
Visual C++
public:
literal unsigned int INVENTORY_LEVEL

See Also

MCdicom Structure
MCdicom Members


INVENTORY_PURPOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVENTORY_PURPOSE Field
MCdicom Structure See Also Send Feedback
Inventory Purpose (0008,0401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVENTORY_PURPOSE
Visual Basic
Public Const INVENTORY_PURPOSE As UInteger
Visual C++
public:
literal unsigned int INVENTORY_PURPOSE

See Also

MCdicom Structure
MCdicom Members


INVERSION_RECOVERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVERSION_RECOVERY Field
MCdicom Structure See Also Send Feedback
Inversion Recovery (0018,9009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVERSION_RECOVERY
Visual Basic
Public Const INVERSION_RECOVERY As UInteger
Visual C++
public:
literal unsigned int INVERSION_RECOVERY

See Also

MCdicom Structure
MCdicom Members


INVERSION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVERSION_TIME Field
MCdicom Structure See Also Send Feedback
Inversion Time (0018,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVERSION_TIME
Visual Basic
Public Const INVERSION_TIME As UInteger
Visual C++
public:
literal unsigned int INVERSION_TIME

See Also

MCdicom Structure
MCdicom Members


INVERSION_TIMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..INVERSION_TIMES Field
MCdicom Structure See Also Send Feedback
Inversion Times (0018,9079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint INVERSION_TIMES
Visual Basic
Public Const INVERSION_TIMES As UInteger
Visual C++
public:
literal unsigned int INVERSION_TIMES

See Also

MCdicom Structure
MCdicom Members


IOL_FORMULA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_FORMULA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
IOL Formula Code Sequence (0022,1028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_FORMULA_CODE_SEQUENCE
Visual Basic
Public Const IOL_FORMULA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IOL_FORMULA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IOL_FORMULA_DETAIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_FORMULA_DETAIL Field
MCdicom Structure See Also Send Feedback
IOL Formula Detail (0022,1029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_FORMULA_DETAIL
Visual Basic
Public Const IOL_FORMULA_DETAIL As UInteger
Visual C++
public:
literal unsigned int IOL_FORMULA_DETAIL

See Also

MCdicom Structure
MCdicom Members


IOL_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
IOL Manufacturer (0022,1093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_MANUFACTURER
Visual Basic
Public Const IOL_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int IOL_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


IOL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_POWER Field
MCdicom Structure See Also Send Feedback
IOL Power (0022,1053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_POWER
Visual Basic
Public Const IOL_POWER As UInteger
Visual C++
public:
literal unsigned int IOL_POWER

See Also

MCdicom Structure
MCdicom Members


IOL_POWER_FOR_EXACT_EMMETROPIA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_POWER_FOR_EXACT_EMMETROPIA Field
MCdicom Structure See Also Send Feedback
IOL Power For Exact Emmetropia (0022,1121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_POWER_FOR_EXACT_EMMETROPIA
Visual Basic
Public Const IOL_POWER_FOR_EXACT_EMMETROPIA As UInteger
Visual C++
public:
literal unsigned int IOL_POWER_FOR_EXACT_EMMETROPIA

See Also

MCdicom Structure
MCdicom Members


IOL_POWER_FOR_EXACT_TARGET_REFRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_POWER_FOR_EXACT_TARGET_REFRACTION Field
MCdicom Structure See Also Send Feedback
IOL Power For Exact Target Refraction (0022,1122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_POWER_FOR_EXACT_TARGET_REFRACTION
Visual Basic
Public Const IOL_POWER_FOR_EXACT_TARGET_REFRACTION As UInteger
Visual C++
public:
literal unsigned int IOL_POWER_FOR_EXACT_TARGET_REFRACTION

See Also

MCdicom Structure
MCdicom Members


IOL_POWER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IOL_POWER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
IOL Power Sequence (0022,1090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IOL_POWER_SEQUENCE
Visual Basic
Public Const IOL_POWER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IOL_POWER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_BEAM_LIMITING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_BEAM_LIMITING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Beam Limiting Device Sequence (300A,03A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_BEAM_LIMITING_DEVICE_SEQUENCE
Visual Basic
Public Const ION_BEAM_LIMITING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_BEAM_LIMITING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_BEAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_BEAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Beam Sequence (300A,03A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_BEAM_SEQUENCE
Visual Basic
Public Const ION_BEAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_BEAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_BLOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_BLOCK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Block Sequence (300A,03A6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_BLOCK_SEQUENCE
Visual Basic
Public Const ION_BLOCK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_BLOCK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_CONTROL_POINT_DELIVERY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_CONTROL_POINT_DELIVERY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Control Point Delivery Sequence (3008,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_CONTROL_POINT_DELIVERY_SEQUENCE
Visual Basic
Public Const ION_CONTROL_POINT_DELIVERY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_CONTROL_POINT_DELIVERY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Control Point Sequence (300A,03A8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const ION_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_CONTROL_POINT_VERIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_CONTROL_POINT_VERIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Control Point Verification Sequence (0074,104E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_CONTROL_POINT_VERIFICATION_SEQUENCE
Visual Basic
Public Const ION_CONTROL_POINT_VERIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_CONTROL_POINT_VERIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_MACHINE_VERIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_MACHINE_VERIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Machine Verification Sequence (0074,1046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_MACHINE_VERIFICATION_SEQUENCE
Visual Basic
Public Const ION_MACHINE_VERIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_MACHINE_VERIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_RANGE_COMPENSATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_RANGE_COMPENSATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Range Compensator Sequence (300A,02EA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_RANGE_COMPENSATOR_SEQUENCE
Visual Basic
Public Const ION_RANGE_COMPENSATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_RANGE_COMPENSATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_TOLERANCE_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_TOLERANCE_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Tolerance Table Sequence (300A,03A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_TOLERANCE_TABLE_SEQUENCE
Visual Basic
Public Const ION_TOLERANCE_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_TOLERANCE_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_WEDGE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_WEDGE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Wedge Position Sequence (300A,03AC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_WEDGE_POSITION_SEQUENCE
Visual Basic
Public Const ION_WEDGE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_WEDGE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ION_WEDGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ION_WEDGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ion Wedge Sequence (300A,03AA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ION_WEDGE_SEQUENCE
Visual Basic
Public Const ION_WEDGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ION_WEDGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Irradiation Event Identification Sequence (0018,9477)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int IRRADIATION_EVENT_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


IRRADIATION_EVENT_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IRRADIATION_EVENT_UID Field
MCdicom Structure See Also Send Feedback
Irradiation Event UID (0008,3010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IRRADIATION_EVENT_UID
Visual Basic
Public Const IRRADIATION_EVENT_UID As UInteger
Visual C++
public:
literal unsigned int IRRADIATION_EVENT_UID

See Also

MCdicom Structure
MCdicom Members


ISO_SPEED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISO_SPEED Field
MCdicom Structure See Also Send Feedback
ISO Speed (0016,001D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISO_SPEED
Visual Basic
Public Const ISO_SPEED As UInteger
Visual C++
public:
literal unsigned int ISO_SPEED

See Also

MCdicom Structure
MCdicom Members


ISO_SPEED_LATITUDE_YYY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISO_SPEED_LATITUDE_YYY Field
MCdicom Structure See Also Send Feedback
ISO Speed Latitude yyy (0016,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISO_SPEED_LATITUDE_YYY
Visual Basic
Public Const ISO_SPEED_LATITUDE_YYY As UInteger
Visual C++
public:
literal unsigned int ISO_SPEED_LATITUDE_YYY

See Also

MCdicom Structure
MCdicom Members


ISO_SPEED_LATITUDE_ZZZ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISO_SPEED_LATITUDE_ZZZ Field
MCdicom Structure See Also Send Feedback
ISO Speed Latitude zzz (0016,001F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISO_SPEED_LATITUDE_ZZZ
Visual Basic
Public Const ISO_SPEED_LATITUDE_ZZZ As UInteger
Visual C++
public:
literal unsigned int ISO_SPEED_LATITUDE_ZZZ

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_POSITION Field
MCdicom Structure See Also Send Feedback
Isocenter Position (300A,012C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_POSITION
Visual Basic
Public Const ISOCENTER_POSITION As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_POSITION

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_REFERENCE_SYSTEM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_REFERENCE_SYSTEM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Isocenter Reference System Sequence (0018,9462)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_REFERENCE_SYSTEM_SEQUENCE
Visual Basic
Public Const ISOCENTER_REFERENCE_SYSTEM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_REFERENCE_SYSTEM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Beam Limiting Device Distance (300A,00BB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_BEAM_LIMITING_DEVICE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_BLOCK_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_BLOCK_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Block Tray Distance (300A,00F7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_BLOCK_TRAY_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_BLOCK_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_BLOCK_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_COMPENSATOR_DISTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_COMPENSATOR_DISTANCES Field
MCdicom Structure See Also Send Feedback
Isocenter to Compensator Distances (300A,02E6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_COMPENSATOR_DISTANCES
Visual Basic
Public Const ISOCENTER_TO_COMPENSATOR_DISTANCES As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_COMPENSATOR_DISTANCES

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Compensator Tray Distance (300A,02E4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_COMPENSATOR_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to General Accessory Distance (300A,0426)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_GENERAL_ACCESSORY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Lateral Spreading Device Distance (300A,0374)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_LATERAL_SPREADING_DEVICE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_RANGE_MODULATOR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_RANGE_MODULATOR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Range Modulator Distance (300A,038A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_RANGE_MODULATOR_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_RANGE_MODULATOR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_RANGE_MODULATOR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_RANGE_SHIFTER_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_RANGE_SHIFTER_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Range Shifter Distance (300A,0364)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_RANGE_SHIFTER_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_RANGE_SHIFTER_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_RANGE_SHIFTER_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOCENTER_TO_WEDGE_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOCENTER_TO_WEDGE_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Isocenter to Wedge Tray Distance (300A,00D9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOCENTER_TO_WEDGE_TRAY_DISTANCE
Visual Basic
Public Const ISOCENTER_TO_WEDGE_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int ISOCENTER_TO_WEDGE_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


ISOTOPE_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISOTOPE_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Isotope Number RETIRED (0020,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISOTOPE_NUMBER_RETIRED
Visual Basic
Public Const ISOTOPE_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int ISOTOPE_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST Field
MCdicom Structure See Also Send Feedback
Issue Date of Imaging Service Request (0040,2004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST
Visual Basic
Public Const ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST As UInteger
Visual C++
public:
literal unsigned int ISSUE_DATE_OF_IMAGING_SERVICE_REQUEST

See Also

MCdicom Structure
MCdicom Members


ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST Field
MCdicom Structure See Also Send Feedback
Issue Time of Imaging Service Request (0040,2005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST
Visual Basic
Public Const ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST As UInteger
Visual C++
public:
literal unsigned int ISSUE_TIME_OF_IMAGING_SERVICE_REQUEST

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_ACCESSION_NUMBER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_ACCESSION_NUMBER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of Accession Number Sequence (0008,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_ACCESSION_NUMBER_SEQUENCE
Visual Basic
Public Const ISSUER_OF_ACCESSION_NUMBER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_ACCESSION_NUMBER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_ADMISSION_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_ADMISSION_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Issuer of Admission ID RETIRED (0038,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_ADMISSION_ID_RETIRED
Visual Basic
Public Const ISSUER_OF_ADMISSION_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_ADMISSION_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_ADMISSION_ID_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_ADMISSION_ID_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of Admission ID Sequence (0038,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_ADMISSION_ID_SEQUENCE
Visual Basic
Public Const ISSUER_OF_ADMISSION_ID_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_ADMISSION_ID_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_PATIENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_PATIENT_ID Field
MCdicom Structure See Also Send Feedback
Issuer of Patient ID (0010,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_PATIENT_ID
Visual Basic
Public Const ISSUER_OF_PATIENT_ID As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_PATIENT_ID

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of Patient ID Qualifiers Sequence (0010,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE
Visual Basic
Public Const ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_PATIENT_ID_QUALIFIERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_SERVICE_EPISODE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_SERVICE_EPISODE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Issuer of Service Episode ID RETIRED (0038,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_SERVICE_EPISODE_ID_RETIRED
Visual Basic
Public Const ISSUER_OF_SERVICE_EPISODE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_SERVICE_EPISODE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of Service Episode ID Sequence (0038,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE
Visual Basic
Public Const ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_SERVICE_EPISODE_ID_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of the Container Identifier Sequence (0040,0513)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE
Visual Basic
Public Const ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_THE_CONTAINER_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Issuer of the Specimen Identifier Sequence (0040,0562)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE
Visual Basic
Public Const ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ISSUER_OF_THE_SPECIMEN_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ITALIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITALIC Field
MCdicom Structure See Also Send Feedback
Italic (0070,0250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITALIC
Visual Basic
Public Const ITALIC As UInteger
Visual C++
public:
literal unsigned int ITALIC

See Also

MCdicom Structure
MCdicom Members


ITEM_INVENTORY_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITEM_INVENTORY_DATETIME Field
MCdicom Structure See Also Send Feedback
Item Inventory DateTime (0008,0404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITEM_INVENTORY_DATETIME
Visual Basic
Public Const ITEM_INVENTORY_DATETIME As UInteger
Visual C++
public:
literal unsigned int ITEM_INVENTORY_DATETIME

See Also

MCdicom Structure
MCdicom Members


ITEM_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITEM_NUMBER Field
MCdicom Structure See Also Send Feedback
Item Number (0020,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITEM_NUMBER
Visual Basic
Public Const ITEM_NUMBER As UInteger
Visual C++
public:
literal unsigned int ITEM_NUMBER

See Also

MCdicom Structure
MCdicom Members


ITERATIVE_RECONSTRUCTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITERATIVE_RECONSTRUCTION_METHOD Field
MCdicom Structure See Also Send Feedback
Iterative Reconstruction Method (0018,9769)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITERATIVE_RECONSTRUCTION_METHOD
Visual Basic
Public Const ITERATIVE_RECONSTRUCTION_METHOD As UInteger
Visual C++
public:
literal unsigned int ITERATIVE_RECONSTRUCTION_METHOD

See Also

MCdicom Structure
MCdicom Members


ITINERARY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITINERARY_ID Field
MCdicom Structure See Also Send Feedback
Itinerary ID (4010,1051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITINERARY_ID
Visual Basic
Public Const ITINERARY_ID As UInteger
Visual C++
public:
literal unsigned int ITINERARY_ID

See Also

MCdicom Structure
MCdicom Members


ITINERARY_ID_ASSIGNING_AUTHORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITINERARY_ID_ASSIGNING_AUTHORITY Field
MCdicom Structure See Also Send Feedback
Itinerary ID Assigning Authority (4010,1053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITINERARY_ID_ASSIGNING_AUTHORITY
Visual Basic
Public Const ITINERARY_ID_ASSIGNING_AUTHORITY As UInteger
Visual C++
public:
literal unsigned int ITINERARY_ID_ASSIGNING_AUTHORITY

See Also

MCdicom Structure
MCdicom Members


ITINERARY_ID_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ITINERARY_ID_TYPE Field
MCdicom Structure See Also Send Feedback
Itinerary ID Type (4010,1052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ITINERARY_ID_TYPE
Visual Basic
Public Const ITINERARY_ID_TYPE As UInteger
Visual C++
public:
literal unsigned int ITINERARY_ID_TYPE

See Also

MCdicom Structure
MCdicom Members


IVUS_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IVUS_ACQUISITION Field
MCdicom Structure See Also Send Feedback
IVUS Acquisition (0018,3100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IVUS_ACQUISITION
Visual Basic
Public Const IVUS_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int IVUS_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


IVUS_GATED_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IVUS_GATED_RATE Field
MCdicom Structure See Also Send Feedback
IVUS Gated Rate (0018,3102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IVUS_GATED_RATE
Visual Basic
Public Const IVUS_GATED_RATE As UInteger
Visual C++
public:
literal unsigned int IVUS_GATED_RATE

See Also

MCdicom Structure
MCdicom Members


IVUS_PULLBACK_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IVUS_PULLBACK_RATE Field
MCdicom Structure See Also Send Feedback
IVUS Pullback Rate (0018,3101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IVUS_PULLBACK_RATE
Visual Basic
Public Const IVUS_PULLBACK_RATE As UInteger
Visual C++
public:
literal unsigned int IVUS_PULLBACK_RATE

See Also

MCdicom Structure
MCdicom Members


IVUS_PULLBACK_START_FRAME_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IVUS_PULLBACK_START_FRAME_NUMBER Field
MCdicom Structure See Also Send Feedback
IVUS Pullback Start Frame Number (0018,3103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IVUS_PULLBACK_START_FRAME_NUMBER
Visual Basic
Public Const IVUS_PULLBACK_START_FRAME_NUMBER As UInteger
Visual C++
public:
literal unsigned int IVUS_PULLBACK_START_FRAME_NUMBER

See Also

MCdicom Structure
MCdicom Members


IVUS_PULLBACK_STOP_FRAME_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..IVUS_PULLBACK_STOP_FRAME_NUMBER Field
MCdicom Structure See Also Send Feedback
IVUS Pullback Stop Frame Number (0018,3104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint IVUS_PULLBACK_STOP_FRAME_NUMBER
Visual Basic
Public Const IVUS_PULLBACK_STOP_FRAME_NUMBER As UInteger
Visual C++
public:
literal unsigned int IVUS_PULLBACK_STOP_FRAME_NUMBER

See Also

MCdicom Structure
MCdicom Members


K_SPACE_FILTERING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..K_SPACE_FILTERING Field
MCdicom Structure See Also Send Feedback
k-space Filtering (0018,9064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint K_SPACE_FILTERING
Visual Basic
Public Const K_SPACE_FILTERING As UInteger
Visual C++
public:
literal unsigned int K_SPACE_FILTERING

See Also

MCdicom Structure
MCdicom Members


KERATOCONUS_PREDICTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOCONUS_PREDICTION_INDEX Field
MCdicom Structure See Also Send Feedback
Keratoconus Prediction Index (0046,0236)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOCONUS_PREDICTION_INDEX
Visual Basic
Public Const KERATOCONUS_PREDICTION_INDEX As UInteger
Visual C++
public:
literal unsigned int KERATOCONUS_PREDICTION_INDEX

See Also

MCdicom Structure
MCdicom Members


KERATOMETER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETER_INDEX Field
MCdicom Structure See Also Send Feedback
Keratometer Index (0022,1033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETER_INDEX
Visual Basic
Public Const KERATOMETER_INDEX As UInteger
Visual C++
public:
literal unsigned int KERATOMETER_INDEX

See Also

MCdicom Structure
MCdicom Members


KERATOMETRIC_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETRIC_AXIS Field
MCdicom Structure See Also Send Feedback
Keratometric Axis (0046,0077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETRIC_AXIS
Visual Basic
Public Const KERATOMETRIC_AXIS As UInteger
Visual C++
public:
literal unsigned int KERATOMETRIC_AXIS

See Also

MCdicom Structure
MCdicom Members


KERATOMETRIC_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETRIC_POWER Field
MCdicom Structure See Also Send Feedback
Keratometric Power (0046,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETRIC_POWER
Visual Basic
Public Const KERATOMETRIC_POWER As UInteger
Visual C++
public:
literal unsigned int KERATOMETRIC_POWER

See Also

MCdicom Structure
MCdicom Members


KERATOMETRY_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETRY_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Keratometry Left Eye Sequence (0046,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETRY_LEFT_EYE_SEQUENCE
Visual Basic
Public Const KERATOMETRY_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int KERATOMETRY_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Keratometry Measurement Type Code Sequence (0022,1096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int KERATOMETRY_MEASUREMENT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


KERATOMETRY_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KERATOMETRY_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Keratometry Right Eye Sequence (0046,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KERATOMETRY_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const KERATOMETRY_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int KERATOMETRY_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
KV Imaging Generation Parameters Sequence (3002,0127)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE
Visual Basic
Public Const KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int KV_IMAGING_GENERATION_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


KV_USED_IN_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KV_USED_IN_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
KV Used in Gain Calibration (0014,3071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KV_USED_IN_GAIN_CALIBRATION
Visual Basic
Public Const KV_USED_IN_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int KV_USED_IN_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


KVP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..KVP Field
MCdicom Structure See Also Send Feedback
KVP (0018,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint KVP
Visual Basic
Public Const KVP As UInteger
Visual C++
public:
literal unsigned int KVP

See Also

MCdicom Structure
MCdicom Members


LABEL_STYLE_SELECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LABEL_STYLE_SELECTION Field
MCdicom Structure See Also Send Feedback
Label Style Selection (2200,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LABEL_STYLE_SELECTION
Visual Basic
Public Const LABEL_STYLE_SELECTION As UInteger
Visual C++
public:
literal unsigned int LABEL_STYLE_SELECTION

See Also

MCdicom Structure
MCdicom Members


LABEL_TEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LABEL_TEXT Field
MCdicom Structure See Also Send Feedback
Label Text (2200,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LABEL_TEXT
Visual Basic
Public Const LABEL_TEXT As UInteger
Visual C++
public:
literal unsigned int LABEL_TEXT

See Also

MCdicom Structure
MCdicom Members


LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES Field
MCdicom Structure See Also Send Feedback
Label Using Information Extracted From Instances (2200,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES
Visual Basic
Public Const LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES As UInteger
Visual C++
public:
literal unsigned int LABEL_USING_INFORMATION_EXTRACTED_FROM_INSTANCES

See Also

MCdicom Structure
MCdicom Members


LANGUAGE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LANGUAGE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Language Code Sequence (0008,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LANGUAGE_CODE_SEQUENCE
Visual Basic
Public Const LANGUAGE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LANGUAGE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Language Code Sequence (Trial) RETIRED (0040,A744)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int LANGUAGE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


LARGEST_IMAGE_PIXEL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_IMAGE_PIXEL_VALUE Field
MCdicom Structure See Also Send Feedback
Largest Image Pixel Value (0028,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_IMAGE_PIXEL_VALUE
Visual Basic
Public Const LARGEST_IMAGE_PIXEL_VALUE As UInteger
Visual C++
public:
literal unsigned int LARGEST_IMAGE_PIXEL_VALUE

See Also

MCdicom Structure
MCdicom Members


LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED Field
MCdicom Structure See Also Send Feedback
Largest Image Pixel Value in Plane RETIRED (0028,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED
Visual Basic
Public Const LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED As UInteger
Visual C++
public:
literal unsigned int LARGEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED

See Also

MCdicom Structure
MCdicom Members


LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Largest Monochrome Pixel Value RETIRED (0028,9099)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED
Visual Basic
Public Const LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int LARGEST_MONOCHROME_PIXEL_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


LARGEST_PIXEL_VALUE_IN_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_PIXEL_VALUE_IN_SERIES Field
MCdicom Structure See Also Send Feedback
Largest Pixel Value in Series (0028,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_PIXEL_VALUE_IN_SERIES
Visual Basic
Public Const LARGEST_PIXEL_VALUE_IN_SERIES As UInteger
Visual C++
public:
literal unsigned int LARGEST_PIXEL_VALUE_IN_SERIES

See Also

MCdicom Structure
MCdicom Members


LARGEST_PIXEL_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_PIXEL_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Alias for tag LARGEST_VALID_PIXEL_VALUE_RETIRED (0028,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_PIXEL_VALUE_RETIRED
Visual Basic
Public Const LARGEST_PIXEL_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int LARGEST_PIXEL_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


LARGEST_VALID_PIXEL_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LARGEST_VALID_PIXEL_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Largest Valid Pixel Value RETIRED (0028,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LARGEST_VALID_PIXEL_VALUE_RETIRED
Visual Basic
Public Const LARGEST_VALID_PIXEL_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int LARGEST_VALID_PIXEL_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


LAST_MENSTRUAL_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LAST_MENSTRUAL_DATE Field
MCdicom Structure See Also Send Feedback
Last Menstrual Date (0010,21D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LAST_MENSTRUAL_DATE
Visual Basic
Public Const LAST_MENSTRUAL_DATE As UInteger
Visual C++
public:
literal unsigned int LAST_MENSTRUAL_DATE

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Description (300A,033A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_DESCRIPTION
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_ID Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device ID (300A,0336)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_ID
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_ID As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_ID

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_NUMBER Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Number (300A,0334)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_NUMBER
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_NUMBER As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_NUMBER

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Sequence (300A,0332)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_SEQUENCE
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_SETTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_SETTING Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Setting (300A,0372)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_SETTING
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_SETTING As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_SETTING

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Settings Sequence (300A,0370)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Type (300A,0338)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_TYPE
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Lateral Spreading Device Water Equivalent Thickness (300A,033C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int LATERAL_SPREADING_DEVICE_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


LATERALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LATERALITY Field
MCdicom Structure See Also Send Feedback
Laterality (0020,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LATERALITY
Visual Basic
Public Const LATERALITY As UInteger
Visual C++
public:
literal unsigned int LATERALITY

See Also

MCdicom Structure
MCdicom Members


LEAF_JAW_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LEAF_JAW_POSITIONS Field
MCdicom Structure See Also Send Feedback
Leaf/Jaw Positions (300A,011C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LEAF_JAW_POSITIONS
Visual Basic
Public Const LEAF_JAW_POSITIONS As UInteger
Visual C++
public:
literal unsigned int LEAF_JAW_POSITIONS

See Also

MCdicom Structure
MCdicom Members


LEAF_POSITION_BOUNDARIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LEAF_POSITION_BOUNDARIES Field
MCdicom Structure See Also Send Feedback
Leaf Position Boundaries (300A,00BE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LEAF_POSITION_BOUNDARIES
Visual Basic
Public Const LEAF_POSITION_BOUNDARIES As UInteger
Visual C++
public:
literal unsigned int LEAF_POSITION_BOUNDARIES

See Also

MCdicom Structure
MCdicom Members


LEFT_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LEFT_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Left Image Sequence (0022,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LEFT_IMAGE_SEQUENCE
Visual Basic
Public Const LEFT_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LEFT_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LEFT_LENS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LEFT_LENS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Left Lens Sequence (0046,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LEFT_LENS_SEQUENCE
Visual Basic
Public Const LEFT_LENS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LEFT_LENS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LENGTH_TO_END_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENGTH_TO_END_RETIRED Field
MCdicom Structure See Also Send Feedback
Length to End RETIRED (0008,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENGTH_TO_END_RETIRED
Visual Basic
Public Const LENGTH_TO_END_RETIRED As UInteger
Visual C++
public:
literal unsigned int LENGTH_TO_END_RETIRED

See Also

MCdicom Structure
MCdicom Members


LENS_CONSTANT_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_CONSTANT_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Lens Constant Description RETIRED (0022,1094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_CONSTANT_DESCRIPTION_RETIRED
Visual Basic
Public Const LENS_CONSTANT_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int LENS_CONSTANT_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


LENS_CONSTANT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_CONSTANT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lens Constant Sequence (0022,1092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_CONSTANT_SEQUENCE
Visual Basic
Public Const LENS_CONSTANT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LENS_CONSTANT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LENS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Lens Description (0046,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_DESCRIPTION
Visual Basic
Public Const LENS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int LENS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


LENS_MAKE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_MAKE Field
MCdicom Structure See Also Send Feedback
Lens Make (0016,004F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_MAKE
Visual Basic
Public Const LENS_MAKE As UInteger
Visual C++
public:
literal unsigned int LENS_MAKE

See Also

MCdicom Structure
MCdicom Members


LENS_MODEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_MODEL Field
MCdicom Structure See Also Send Feedback
Lens Model (0016,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_MODEL
Visual Basic
Public Const LENS_MODEL As UInteger
Visual C++
public:
literal unsigned int LENS_MODEL

See Also

MCdicom Structure
MCdicom Members


LENS_SEGMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_SEGMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Lens Segment Type (0046,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_SEGMENT_TYPE
Visual Basic
Public Const LENS_SEGMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int LENS_SEGMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


LENS_SERIAL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_SERIAL_NUMBER Field
MCdicom Structure See Also Send Feedback
Lens Serial Number (0016,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_SERIAL_NUMBER
Visual Basic
Public Const LENS_SERIAL_NUMBER As UInteger
Visual C++
public:
literal unsigned int LENS_SERIAL_NUMBER

See Also

MCdicom Structure
MCdicom Members


LENS_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_SPECIFICATION Field
MCdicom Structure See Also Send Feedback
Lens Specification (0016,004E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_SPECIFICATION
Visual Basic
Public Const LENS_SPECIFICATION As UInteger
Visual C++
public:
literal unsigned int LENS_SPECIFICATION

See Also

MCdicom Structure
MCdicom Members


LENS_STATUS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_STATUS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lens Status Code Sequence (0022,1024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_STATUS_CODE_SEQUENCE
Visual Basic
Public Const LENS_STATUS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LENS_STATUS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LENS_STATUS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_STATUS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Lens Status Description (0022,1065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_STATUS_DESCRIPTION
Visual Basic
Public Const LENS_STATUS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int LENS_STATUS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


LENS_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_THICKNESS Field
MCdicom Structure See Also Send Feedback
Lens Thickness (0022,1130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_THICKNESS
Visual Basic
Public Const LENS_THICKNESS As UInteger
Visual C++
public:
literal unsigned int LENS_THICKNESS

See Also

MCdicom Structure
MCdicom Members


LENS_THICKNESS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENS_THICKNESS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lens Thickness Sequence (0022,1127)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENS_THICKNESS_SEQUENCE
Visual Basic
Public Const LENS_THICKNESS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LENS_THICKNESS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LENSES_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LENSES_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Lenses Code Sequence (0022,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LENSES_CODE_SEQUENCE
Visual Basic
Public Const LENSES_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LENSES_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LESION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LESION_NUMBER Field
MCdicom Structure See Also Send Feedback
Lesion Number (0018,3105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LESION_NUMBER
Visual Basic
Public Const LESION_NUMBER As UInteger
Visual C++
public:
literal unsigned int LESION_NUMBER

See Also

MCdicom Structure
MCdicom Members


LIGHT_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_DIRECTION Field
MCdicom Structure See Also Send Feedback
Light Direction (0070,1703)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_DIRECTION
Visual Basic
Public Const LIGHT_DIRECTION As UInteger
Visual C++
public:
literal unsigned int LIGHT_DIRECTION

See Also

MCdicom Structure
MCdicom Members


LIGHT_PATH_FILTER_PASS_BAND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_PATH_FILTER_PASS_BAND Field
MCdicom Structure See Also Send Feedback
Light Path Filter Pass Band (0022,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_PATH_FILTER_PASS_BAND
Visual Basic
Public Const LIGHT_PATH_FILTER_PASS_BAND As UInteger
Visual C++
public:
literal unsigned int LIGHT_PATH_FILTER_PASS_BAND

See Also

MCdicom Structure
MCdicom Members


LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH Field
MCdicom Structure See Also Send Feedback
Light Path Filter Pass-Through Wavelength (0022,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH
Visual Basic
Public Const LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH As UInteger
Visual C++
public:
literal unsigned int LIGHT_PATH_FILTER_PASS_THROUGH_WAVELENGTH

See Also

MCdicom Structure
MCdicom Members


LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Light Path Filter Type Stack Code Sequence (0022,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE
Visual Basic
Public Const LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LIGHT_PATH_FILTER_TYPE_STACK_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LIGHT_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_SOURCE Field
MCdicom Structure See Also Send Feedback
Light Source (0016,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_SOURCE
Visual Basic
Public Const LIGHT_SOURCE As UInteger
Visual C++
public:
literal unsigned int LIGHT_SOURCE

See Also

MCdicom Structure
MCdicom Members


LIGHT_SOURCE_POLARIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIGHT_SOURCE_POLARIZATION Field
MCdicom Structure See Also Send Feedback
Light Source Polarization (0016,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIGHT_SOURCE_POLARIZATION
Visual Basic
Public Const LIGHT_SOURCE_POLARIZATION As UInteger
Visual C++
public:
literal unsigned int LIGHT_SOURCE_POLARIZATION

See Also

MCdicom Structure
MCdicom Members


LINAC_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINAC_ENERGY Field
MCdicom Structure See Also Send Feedback
LINAC Energy (0014,5002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINAC_ENERGY
Visual Basic
Public Const LINAC_ENERGY As UInteger
Visual C++
public:
literal unsigned int LINAC_ENERGY

See Also

MCdicom Structure
MCdicom Members


LINAC_OUTPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINAC_OUTPUT Field
MCdicom Structure See Also Send Feedback
LINAC Output (0014,5004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINAC_OUTPUT
Visual Basic
Public Const LINAC_OUTPUT As UInteger
Visual C++
public:
literal unsigned int LINAC_OUTPUT

See Also

MCdicom Structure
MCdicom Members


LINE_DASHING_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINE_DASHING_STYLE Field
MCdicom Structure See Also Send Feedback
Line Dashing Style (0070,0254)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINE_DASHING_STYLE
Visual Basic
Public Const LINE_DASHING_STYLE As UInteger
Visual C++
public:
literal unsigned int LINE_DASHING_STYLE

See Also

MCdicom Structure
MCdicom Members


LINE_PATTERN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINE_PATTERN Field
MCdicom Structure See Also Send Feedback
Line Pattern (0070,0255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINE_PATTERN
Visual Basic
Public Const LINE_PATTERN As UInteger
Visual C++
public:
literal unsigned int LINE_PATTERN

See Also

MCdicom Structure
MCdicom Members


LINE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Line Sequence (0066,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINE_SEQUENCE
Visual Basic
Public Const LINE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LINE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LINE_STYLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINE_STYLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Line Style Sequence (0070,0232)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINE_STYLE_SEQUENCE
Visual Basic
Public Const LINE_STYLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LINE_STYLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LINE_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LINE_THICKNESS Field
MCdicom Structure See Also Send Feedback
Line Thickness (0070,0253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LINE_THICKNESS
Visual Basic
Public Const LINE_THICKNESS As UInteger
Visual C++
public:
literal unsigned int LINE_THICKNESS

See Also

MCdicom Structure
MCdicom Members


LIST_OF_MIME_TYPES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIST_OF_MIME_TYPES Field
MCdicom Structure See Also Send Feedback
List of MIME Types (0042,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIST_OF_MIME_TYPES
Visual Basic
Public Const LIST_OF_MIME_TYPES As UInteger
Visual C++
public:
literal unsigned int LIST_OF_MIME_TYPES

See Also

MCdicom Structure
MCdicom Members


LIST_OF_UID_MATCHING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LIST_OF_UID_MATCHING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
List of UID Matching Sequence (0008,0411)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LIST_OF_UID_MATCHING_SEQUENCE
Visual Basic
Public Const LIST_OF_UID_MATCHING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LIST_OF_UID_MATCHING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG Field
MCdicom Structure See Also Send Feedback
Local Deviation Probability Normals Flag (0024,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG
Visual Basic
Public Const LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG As UInteger
Visual C++
public:
literal unsigned int LOCAL_DEVIATION_PROBABILITY_NORMALS_FLAG

See Also

MCdicom Structure
MCdicom Members


LOCAL_NAMESPACE_ENTITY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCAL_NAMESPACE_ENTITY_ID Field
MCdicom Structure See Also Send Feedback
Local Namespace Entity ID (0040,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCAL_NAMESPACE_ENTITY_ID
Visual Basic
Public Const LOCAL_NAMESPACE_ENTITY_ID As UInteger
Visual C++
public:
literal unsigned int LOCAL_NAMESPACE_ENTITY_ID

See Also

MCdicom Structure
MCdicom Members


LOCALIZED_DEVIATION_FROM_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCALIZED_DEVIATION_FROM_NORMAL Field
MCdicom Structure See Also Send Feedback
Localized Deviation From Normal (0024,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCALIZED_DEVIATION_FROM_NORMAL
Visual Basic
Public Const LOCALIZED_DEVIATION_FROM_NORMAL As UInteger
Visual C++
public:
literal unsigned int LOCALIZED_DEVIATION_FROM_NORMAL

See Also

MCdicom Structure
MCdicom Members


LOCALIZED_DEVIATION_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCALIZED_DEVIATION_PROBABILITY Field
MCdicom Structure See Also Send Feedback
Localized Deviation Probability (0024,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCALIZED_DEVIATION_PROBABILITY
Visual Basic
Public Const LOCALIZED_DEVIATION_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int LOCALIZED_DEVIATION_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Localized Deviation Probability Sequence (0024,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE
Visual Basic
Public Const LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LOCALIZED_DEVIATION_PROBABILITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LOCALIZING_CURSOR_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCALIZING_CURSOR_POSITION Field
MCdicom Structure See Also Send Feedback
Localizing Cursor Position (0018,2043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCALIZING_CURSOR_POSITION
Visual Basic
Public Const LOCALIZING_CURSOR_POSITION As UInteger
Visual C++
public:
literal unsigned int LOCALIZING_CURSOR_POSITION

See Also

MCdicom Structure
MCdicom Members


LOCATION_OF_MEASURED_BEAM_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCATION_OF_MEASURED_BEAM_DIAMETER Field
MCdicom Structure See Also Send Feedback
Location of Measured Beam Diameter (0014,4019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCATION_OF_MEASURED_BEAM_DIAMETER
Visual Basic
Public Const LOCATION_OF_MEASURED_BEAM_DIAMETER As UInteger
Visual C++
public:
literal unsigned int LOCATION_OF_MEASURED_BEAM_DIAMETER

See Also

MCdicom Structure
MCdicom Members


LOCATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOCATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Location RETIRED (0020,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOCATION_RETIRED
Visual Basic
Public Const LOCATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int LOCATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


LONG_CODE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_CODE_VALUE Field
MCdicom Structure See Also Send Feedback
Long Code Value (0008,0119)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_CODE_VALUE
Visual Basic
Public Const LONG_CODE_VALUE As UInteger
Visual C++
public:
literal unsigned int LONG_CODE_VALUE

See Also

MCdicom Structure
MCdicom Members


LONG_DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Long Device Description (0050,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_DEVICE_DESCRIPTION
Visual Basic
Public Const LONG_DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int LONG_DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


LONG_EDGE_POINT_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_EDGE_POINT_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Long Edge Point Index List (0066,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_EDGE_POINT_INDEX_LIST
Visual Basic
Public Const LONG_EDGE_POINT_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int LONG_EDGE_POINT_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


LONG_PRIMITIVE_POINT_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_PRIMITIVE_POINT_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Long Primitive Point Index List (0066,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_PRIMITIVE_POINT_INDEX_LIST
Visual Basic
Public Const LONG_PRIMITIVE_POINT_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int LONG_PRIMITIVE_POINT_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


LONG_TRIANGLE_POINT_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_TRIANGLE_POINT_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Long Triangle Point Index List (0066,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_TRIANGLE_POINT_INDEX_LIST
Visual Basic
Public Const LONG_TRIANGLE_POINT_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int LONG_TRIANGLE_POINT_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


LONG_VERTEX_POINT_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONG_VERTEX_POINT_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Long Vertex Point Index List (0066,0043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONG_VERTEX_POINT_INDEX_LIST
Visual Basic
Public Const LONG_VERTEX_POINT_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int LONG_VERTEX_POINT_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


LONGITUDINAL_TEMPORAL_EVENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONGITUDINAL_TEMPORAL_EVENT_TYPE Field
MCdicom Structure See Also Send Feedback
Longitudinal Temporal Event Type (0012,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONGITUDINAL_TEMPORAL_EVENT_TYPE
Visual Basic
Public Const LONGITUDINAL_TEMPORAL_EVENT_TYPE As UInteger
Visual C++
public:
literal unsigned int LONGITUDINAL_TEMPORAL_EVENT_TYPE

See Also

MCdicom Structure
MCdicom Members


LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED Field
MCdicom Structure See Also Send Feedback
Longitudinal Temporal Information Modified (0028,0303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED
Visual Basic
Public Const LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED As UInteger
Visual C++
public:
literal unsigned int LONGITUDINAL_TEMPORAL_INFORMATION_MODIFIED

See Also

MCdicom Structure
MCdicom Members


LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT Field
MCdicom Structure See Also Send Feedback
Longitudinal Temporal Offset from Event (0012,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT
Visual Basic
Public Const LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT As UInteger
Visual C++
public:
literal unsigned int LONGITUDINAL_TEMPORAL_OFFSET_FROM_EVENT

See Also

MCdicom Structure
MCdicom Members


LOOKUP_TABLE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOOKUP_TABLE_NUMBER Field
MCdicom Structure See Also Send Feedback
Alias for tag LUT_NUMBER_RETIRED (0020,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOOKUP_TABLE_NUMBER
Visual Basic
Public Const LOOKUP_TABLE_NUMBER As UInteger
Visual C++
public:
literal unsigned int LOOKUP_TABLE_NUMBER

See Also

MCdicom Structure
MCdicom Members


LOSSY_IMAGE_COMPRESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOSSY_IMAGE_COMPRESSION Field
MCdicom Structure See Also Send Feedback
Lossy Image Compression (0028,2110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOSSY_IMAGE_COMPRESSION
Visual Basic
Public Const LOSSY_IMAGE_COMPRESSION As UInteger
Visual C++
public:
literal unsigned int LOSSY_IMAGE_COMPRESSION

See Also

MCdicom Structure
MCdicom Members


LOSSY_IMAGE_COMPRESSION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOSSY_IMAGE_COMPRESSION_METHOD Field
MCdicom Structure See Also Send Feedback
Lossy Image Compression Method (0028,2114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOSSY_IMAGE_COMPRESSION_METHOD
Visual Basic
Public Const LOSSY_IMAGE_COMPRESSION_METHOD As UInteger
Visual C++
public:
literal unsigned int LOSSY_IMAGE_COMPRESSION_METHOD

See Also

MCdicom Structure
MCdicom Members


LOSSY_IMAGE_COMPRESSION_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOSSY_IMAGE_COMPRESSION_RATIO Field
MCdicom Structure See Also Send Feedback
Lossy Image Compression Ratio (0028,2112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOSSY_IMAGE_COMPRESSION_RATIO
Visual Basic
Public Const LOSSY_IMAGE_COMPRESSION_RATIO As UInteger
Visual C++
public:
literal unsigned int LOSSY_IMAGE_COMPRESSION_RATIO

See Also

MCdicom Structure
MCdicom Members


LOSSY_IMAGE_COMPRESSION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOSSY_IMAGE_COMPRESSION_RETIRED Field
MCdicom Structure See Also Send Feedback
Lossy Image Compression (Retired) (0008,2110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOSSY_IMAGE_COMPRESSION_RETIRED
Visual Basic
Public Const LOSSY_IMAGE_COMPRESSION_RETIRED As UInteger
Visual C++
public:
literal unsigned int LOSSY_IMAGE_COMPRESSION_RETIRED

See Also

MCdicom Structure
MCdicom Members


LOW_ENERGY_DETECTORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOW_ENERGY_DETECTORS Field
MCdicom Structure See Also Send Feedback
Low Energy Detectors (4010,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOW_ENERGY_DETECTORS
Visual Basic
Public Const LOW_ENERGY_DETECTORS As UInteger
Visual C++
public:
literal unsigned int LOW_ENERGY_DETECTORS

See Also

MCdicom Structure
MCdicom Members


LOW_R_R_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOW_R_R_VALUE Field
MCdicom Structure See Also Send Feedback
Low R-R Value (0018,1081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOW_R_R_VALUE
Visual Basic
Public Const LOW_R_R_VALUE As UInteger
Visual C++
public:
literal unsigned int LOW_R_R_VALUE

See Also

MCdicom Structure
MCdicom Members


LOWER_CUTOFF_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LOWER_CUTOFF_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Lower Cutoff Frequency (0018,982F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LOWER_CUTOFF_FREQUENCY
Visual Basic
Public Const LOWER_CUTOFF_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int LOWER_CUTOFF_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_CHARACTERISTICS_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_CHARACTERISTICS_ID Field
MCdicom Structure See Also Send Feedback
Luminance Characteristics ID (0028,7009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_CHARACTERISTICS_ID
Visual Basic
Public Const LUMINANCE_CHARACTERISTICS_ID As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_CHARACTERISTICS_ID

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_RESPONSE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_RESPONSE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Luminance Response Description (0028,7020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_RESPONSE_DESCRIPTION
Visual Basic
Public Const LUMINANCE_RESPONSE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_RESPONSE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_RESPONSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_RESPONSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Luminance Response Sequence (0028,701C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_RESPONSE_SEQUENCE
Visual Basic
Public Const LUMINANCE_RESPONSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_RESPONSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_RESULT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_RESULT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Luminance Result Sequence (0028,7024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_RESULT_SEQUENCE
Visual Basic
Public Const LUMINANCE_RESULT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_RESULT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_UNIFORMITY_RESULT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_UNIFORMITY_RESULT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Luminance Uniformity Result Sequence (0028,7027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_UNIFORMITY_RESULT_SEQUENCE
Visual Basic
Public Const LUMINANCE_UNIFORMITY_RESULT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_UNIFORMITY_RESULT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


LUMINANCE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUMINANCE_VALUE Field
MCdicom Structure See Also Send Feedback
Luminance Value (0028,701F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUMINANCE_VALUE
Visual Basic
Public Const LUMINANCE_VALUE As UInteger
Visual C++
public:
literal unsigned int LUMINANCE_VALUE

See Also

MCdicom Structure
MCdicom Members


LUT_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_DATA Field
MCdicom Structure See Also Send Feedback
LUT Data (0028,3006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_DATA
Visual Basic
Public Const LUT_DATA As UInteger
Visual C++
public:
literal unsigned int LUT_DATA

See Also

MCdicom Structure
MCdicom Members


LUT_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
LUT Descriptor (0028,3002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_DESCRIPTOR
Visual Basic
Public Const LUT_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int LUT_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


LUT_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_EXPLANATION Field
MCdicom Structure See Also Send Feedback
LUT Explanation (0028,3003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_EXPLANATION
Visual Basic
Public Const LUT_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int LUT_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


LUT_FRAME_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_FRAME_RANGE Field
MCdicom Structure See Also Send Feedback
LUT Frame Range (0028,9507)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_FRAME_RANGE
Visual Basic
Public Const LUT_FRAME_RANGE As UInteger
Visual C++
public:
literal unsigned int LUT_FRAME_RANGE

See Also

MCdicom Structure
MCdicom Members


LUT_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_FUNCTION Field
MCdicom Structure See Also Send Feedback
LUT Function (0028,9474)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_FUNCTION
Visual Basic
Public Const LUT_FUNCTION As UInteger
Visual C++
public:
literal unsigned int LUT_FUNCTION

See Also

MCdicom Structure
MCdicom Members


LUT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_LABEL Field
MCdicom Structure See Also Send Feedback
LUT Label (0040,9210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_LABEL
Visual Basic
Public Const LUT_LABEL As UInteger
Visual C++
public:
literal unsigned int LUT_LABEL

See Also

MCdicom Structure
MCdicom Members


LUT_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..LUT_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
LUT Number RETIRED (0020,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint LUT_NUMBER_RETIRED
Visual Basic
Public Const LUT_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int LUT_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


MA_USED_IN_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MA_USED_IN_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
MA Used in Gain Calibration (0014,3072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MA_USED_IN_GAIN_CALIBRATION
Visual Basic
Public Const MA_USED_IN_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int MA_USED_IN_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


MAC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAC Field
MCdicom Structure See Also Send Feedback
MAC (0400,0404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAC
Visual Basic
Public Const MAC As UInteger
Visual C++
public:
literal unsigned int MAC

See Also

MCdicom Structure
MCdicom Members


MAC_ALGORITHM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAC_ALGORITHM Field
MCdicom Structure See Also Send Feedback
MAC Algorithm (0400,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAC_ALGORITHM
Visual Basic
Public Const MAC_ALGORITHM As UInteger
Visual C++
public:
literal unsigned int MAC_ALGORITHM

See Also

MCdicom Structure
MCdicom Members


MAC_CALCULATION_TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAC_CALCULATION_TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
MAC Calculation Transfer Syntax UID (0400,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAC_CALCULATION_TRANSFER_SYNTAX_UID
Visual Basic
Public Const MAC_CALCULATION_TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int MAC_CALCULATION_TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


MAC_ID_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAC_ID_NUMBER Field
MCdicom Structure See Also Send Feedback
MAC ID Number (0400,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAC_ID_NUMBER
Visual Basic
Public Const MAC_ID_NUMBER As UInteger
Visual C++
public:
literal unsigned int MAC_ID_NUMBER

See Also

MCdicom Structure
MCdicom Members


MAC_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAC_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MAC Parameters Sequence (4FFE,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAC_PARAMETERS_SEQUENCE
Visual Basic
Public Const MAC_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MAC_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Machine-Specific Treatment Termination Code Sequence (300A,0716)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE
Visual Basic
Public Const MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MACHINE_SPECIFIC_TREATMENT_TERMINATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAGNETIC_FIELD_STRENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAGNETIC_FIELD_STRENGTH Field
MCdicom Structure See Also Send Feedback
Magnetic Field Strength (0018,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAGNETIC_FIELD_STRENGTH
Visual Basic
Public Const MAGNETIC_FIELD_STRENGTH As UInteger
Visual C++
public:
literal unsigned int MAGNETIC_FIELD_STRENGTH

See Also

MCdicom Structure
MCdicom Members


MAGNETIZATION_TRANSFER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAGNETIZATION_TRANSFER Field
MCdicom Structure See Also Send Feedback
Magnetization Transfer (0018,9020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAGNETIZATION_TRANSFER
Visual Basic
Public Const MAGNETIZATION_TRANSFER As UInteger
Visual C++
public:
literal unsigned int MAGNETIZATION_TRANSFER

See Also

MCdicom Structure
MCdicom Members


MAGNIFICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAGNIFICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Magnification Type (2010,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAGNIFICATION_TYPE
Visual Basic
Public Const MAGNIFICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int MAGNIFICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED Field
MCdicom Structure See Also Send Feedback
Magnify to Number of Columns RETIRED (2040,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED
Visual Basic
Public Const MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED As UInteger
Visual C++
public:
literal unsigned int MAGNIFY_TO_NUMBER_OF_COLUMNS_RETIRED

See Also

MCdicom Structure
MCdicom Members


MAGNITUDE_ENCODING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAGNITUDE_ENCODING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Magnitude Encoding Code Sequence (003A,032D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAGNITUDE_ENCODING_CODE_SEQUENCE
Visual Basic
Public Const MAGNITUDE_ENCODING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MAGNITUDE_ENCODING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAJOR_TICKS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAJOR_TICKS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Major Ticks Sequence (0070,0287)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAJOR_TICKS_SEQUENCE
Visual Basic
Public Const MAJOR_TICKS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MAJOR_TICKS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAKER_NOTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAKER_NOTE Field
MCdicom Structure See Also Send Feedback
Maker Note (0016,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAKER_NOTE
Visual Basic
Public Const MAKER_NOTE As UInteger
Visual C++
public:
literal unsigned int MAKER_NOTE

See Also

MCdicom Structure
MCdicom Members


MANDATORY_COMPONENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANDATORY_COMPONENT_TYPE Field
MCdicom Structure See Also Send Feedback
Mandatory Component Type (0076,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANDATORY_COMPONENT_TYPE
Visual Basic
Public Const MANDATORY_COMPONENT_TYPE As UInteger
Visual C++
public:
literal unsigned int MANDATORY_COMPONENT_TYPE

See Also

MCdicom Structure
MCdicom Members


MANIFOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANIFOLD Field
MCdicom Structure See Also Send Feedback
Manifold (0066,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANIFOLD
Visual Basic
Public Const MANIFOLD As UInteger
Visual C++
public:
literal unsigned int MANIFOLD

See Also

MCdicom Structure
MCdicom Members


MANIPULATED_IMAGE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANIPULATED_IMAGE_RETIRED Field
MCdicom Structure See Also Send Feedback
Manipulated Image RETIRED (0028,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANIPULATED_IMAGE_RETIRED
Visual Basic
Public Const MANIPULATED_IMAGE_RETIRED As UInteger
Visual C++
public:
literal unsigned int MANIPULATED_IMAGE_RETIRED

See Also

MCdicom Structure
MCdicom Members


MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Manufacturer (0008,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURER
Visual Basic
Public Const MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


MANUFACTURERS_DEVICE_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURERS_DEVICE_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Manufacturer's Device Class UID (0018,100B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURERS_DEVICE_CLASS_UID
Visual Basic
Public Const MANUFACTURERS_DEVICE_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int MANUFACTURERS_DEVICE_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


MANUFACTURERS_DEVICE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURERS_DEVICE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Manufacturer's Device Identifier (3010,0043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURERS_DEVICE_IDENTIFIER
Visual Basic
Public Const MANUFACTURERS_DEVICE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int MANUFACTURERS_DEVICE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


MANUFACTURERS_MODEL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURERS_MODEL_NAME Field
MCdicom Structure See Also Send Feedback
Manufacturer's Model Name (0008,1090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURERS_MODEL_NAME
Visual Basic
Public Const MANUFACTURERS_MODEL_NAME As UInteger
Visual C++
public:
literal unsigned int MANUFACTURERS_MODEL_NAME

See Also

MCdicom Structure
MCdicom Members


MANUFACTURERS_MODEL_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURERS_MODEL_VERSION Field
MCdicom Structure See Also Send Feedback
Manufacturer's Model Version (3010,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURERS_MODEL_VERSION
Visual Basic
Public Const MANUFACTURERS_MODEL_VERSION As UInteger
Visual C++
public:
literal unsigned int MANUFACTURERS_MODEL_VERSION

See Also

MCdicom Structure
MCdicom Members


MANUFACTURERS_RELATED_MODEL_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MANUFACTURERS_RELATED_MODEL_GROUP Field
MCdicom Structure See Also Send Feedback
Manufacturer's Related Model Group (0008,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MANUFACTURERS_RELATED_MODEL_GROUP
Visual Basic
Public Const MANUFACTURERS_RELATED_MODEL_GROUP As UInteger
Visual C++
public:
literal unsigned int MANUFACTURERS_RELATED_MODEL_GROUP

See Also

MCdicom Structure
MCdicom Members


MAPPED_PIXEL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAPPED_PIXEL_VALUE Field
MCdicom Structure See Also Send Feedback
Mapped Pixel Value (0022,1452)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAPPED_PIXEL_VALUE
Visual Basic
Public Const MAPPED_PIXEL_VALUE As UInteger
Visual C++
public:
literal unsigned int MAPPED_PIXEL_VALUE

See Also

MCdicom Structure
MCdicom Members


MAPPING_RESOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAPPING_RESOURCE Field
MCdicom Structure See Also Send Feedback
Mapping Resource (0008,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAPPING_RESOURCE
Visual Basic
Public Const MAPPING_RESOURCE As UInteger
Visual C++
public:
literal unsigned int MAPPING_RESOURCE

See Also

MCdicom Structure
MCdicom Members


MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mapping Resource Identification Sequence (0008,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MAPPING_RESOURCE_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAPPING_RESOURCE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAPPING_RESOURCE_NAME Field
MCdicom Structure See Also Send Feedback
Mapping Resource Name (0008,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAPPING_RESOURCE_NAME
Visual Basic
Public Const MAPPING_RESOURCE_NAME As UInteger
Visual C++
public:
literal unsigned int MAPPING_RESOURCE_NAME

See Also

MCdicom Structure
MCdicom Members


MAPPING_RESOURCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAPPING_RESOURCE_UID Field
MCdicom Structure See Also Send Feedback
Mapping Resource UID (0008,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAPPING_RESOURCE_UID
Visual Basic
Public Const MAPPING_RESOURCE_UID As UInteger
Visual C++
public:
literal unsigned int MAPPING_RESOURCE_UID

See Also

MCdicom Structure
MCdicom Members


MASK_FRAME_NUMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_FRAME_NUMBERS Field
MCdicom Structure See Also Send Feedback
Mask Frame Numbers (0028,6110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_FRAME_NUMBERS
Visual Basic
Public Const MASK_FRAME_NUMBERS As UInteger
Visual C++
public:
literal unsigned int MASK_FRAME_NUMBERS

See Also

MCdicom Structure
MCdicom Members


MASK_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_OPERATION Field
MCdicom Structure See Also Send Feedback
Mask Operation (0028,6101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_OPERATION
Visual Basic
Public Const MASK_OPERATION As UInteger
Visual C++
public:
literal unsigned int MASK_OPERATION

See Also

MCdicom Structure
MCdicom Members


MASK_OPERATION_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_OPERATION_EXPLANATION Field
MCdicom Structure See Also Send Feedback
Mask Operation Explanation (0028,6190)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_OPERATION_EXPLANATION
Visual Basic
Public Const MASK_OPERATION_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int MASK_OPERATION_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


MASK_POINTERS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_POINTERS_RETIRED Field
MCdicom Structure See Also Send Feedback
Mask Pointer(s) RETIRED (0028,6030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_POINTERS_RETIRED
Visual Basic
Public Const MASK_POINTERS_RETIRED As UInteger
Visual C++
public:
literal unsigned int MASK_POINTERS_RETIRED

See Also

MCdicom Structure
MCdicom Members


MASK_SELECTION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_SELECTION_MODE Field
MCdicom Structure See Also Send Feedback
Mask Selection Mode (0028,9454)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_SELECTION_MODE
Visual Basic
Public Const MASK_SELECTION_MODE As UInteger
Visual C++
public:
literal unsigned int MASK_SELECTION_MODE

See Also

MCdicom Structure
MCdicom Members


MASK_SUB_PIXEL_SHIFT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_SUB_PIXEL_SHIFT Field
MCdicom Structure See Also Send Feedback
Mask Sub-pixel Shift (0028,6114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_SUB_PIXEL_SHIFT
Visual Basic
Public Const MASK_SUB_PIXEL_SHIFT As UInteger
Visual C++
public:
literal unsigned int MASK_SUB_PIXEL_SHIFT

See Also

MCdicom Structure
MCdicom Members


MASK_SUBTRACTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_SUBTRACTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mask Subtraction Sequence (0028,6100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_SUBTRACTION_SEQUENCE
Visual Basic
Public Const MASK_SUBTRACTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MASK_SUBTRACTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MASK_VISIBILITY_PERCENTAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASK_VISIBILITY_PERCENTAGE Field
MCdicom Structure See Also Send Feedback
Mask Visibility Percentage (0028,9478)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASK_VISIBILITY_PERCENTAGE
Visual Basic
Public Const MASK_VISIBILITY_PERCENTAGE As UInteger
Visual C++
public:
literal unsigned int MASK_VISIBILITY_PERCENTAGE

See Also

MCdicom Structure
MCdicom Members


MASKING_IMAGE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASKING_IMAGE_RETIRED Field
MCdicom Structure See Also Send Feedback
Masking Image RETIRED (0020,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASKING_IMAGE_RETIRED
Visual Basic
Public Const MASKING_IMAGE_RETIRED As UInteger
Visual C++
public:
literal unsigned int MASKING_IMAGE_RETIRED

See Also

MCdicom Structure
MCdicom Members


MASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MASS Field
MCdicom Structure See Also Send Feedback
Mass (4010,1017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MASS
Visual Basic
Public Const MASS As UInteger
Visual C++
public:
literal unsigned int MASS

See Also

MCdicom Structure
MCdicom Members


MATERIAL_ATTENUATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_ATTENUATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Material Attenuation Sequence (0018,9382)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_ATTENUATION_SEQUENCE
Visual Basic
Public Const MATERIAL_ATTENUATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATERIAL_ATTENUATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATERIAL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Material Code Sequence (0018,937D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_CODE_SEQUENCE
Visual Basic
Public Const MATERIAL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATERIAL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATERIAL_GRADE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_GRADE Field
MCdicom Structure See Also Send Feedback
Material Grade (0014,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_GRADE
Visual Basic
Public Const MATERIAL_GRADE As UInteger
Visual C++
public:
literal unsigned int MATERIAL_GRADE

See Also

MCdicom Structure
MCdicom Members


MATERIAL_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_ID Field
MCdicom Structure See Also Send Feedback
Material ID (300A,00E1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_ID
Visual Basic
Public Const MATERIAL_ID As UInteger
Visual C++
public:
literal unsigned int MATERIAL_ID

See Also

MCdicom Structure
MCdicom Members


MATERIAL_ISOLATION_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_ISOLATION_DIAMETER Field
MCdicom Structure See Also Send Feedback
Material Isolation Diameter (0014,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_ISOLATION_DIAMETER
Visual Basic
Public Const MATERIAL_ISOLATION_DIAMETER As UInteger
Visual C++
public:
literal unsigned int MATERIAL_ISOLATION_DIAMETER

See Also

MCdicom Structure
MCdicom Members


MATERIAL_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_NOTES Field
MCdicom Structure See Also Send Feedback
Material Notes (0014,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_NOTES
Visual Basic
Public Const MATERIAL_NOTES As UInteger
Visual C++
public:
literal unsigned int MATERIAL_NOTES

See Also

MCdicom Structure
MCdicom Members


MATERIAL_PIPE_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_PIPE_DIAMETER Field
MCdicom Structure See Also Send Feedback
Material Pipe Diameter (0014,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_PIPE_DIAMETER
Visual Basic
Public Const MATERIAL_PIPE_DIAMETER As UInteger
Visual C++
public:
literal unsigned int MATERIAL_PIPE_DIAMETER

See Also

MCdicom Structure
MCdicom Members


MATERIAL_PROPERTIES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_PROPERTIES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Material Properties Description (0014,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_PROPERTIES_DESCRIPTION
Visual Basic
Public Const MATERIAL_PROPERTIES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int MATERIAL_PROPERTIES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
Material Properties File Format (Retired) (0014,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED
Visual Basic
Public Const MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int MATERIAL_PROPERTIES_FILE_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


MATERIAL_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIAL_THICKNESS Field
MCdicom Structure See Also Send Feedback
Material Thickness (0014,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIAL_THICKNESS
Visual Basic
Public Const MATERIAL_THICKNESS As UInteger
Visual C++
public:
literal unsigned int MATERIAL_THICKNESS

See Also

MCdicom Structure
MCdicom Members


MATERIALS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATERIALS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Materials Code Sequence (0068,63A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATERIALS_CODE_SEQUENCE
Visual Basic
Public Const MATERIALS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATERIALS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mating Feature Degree of Freedom Sequence (0068,6400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE
Visual Basic
Public Const MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_DEGREE_OF_FREEDOM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_ID Field
MCdicom Structure See Also Send Feedback
Mating Feature ID (0068,63F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_ID
Visual Basic
Public Const MATING_FEATURE_ID As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_ID

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mating Feature Sequence (0068,63E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_SEQUENCE
Visual Basic
Public Const MATING_FEATURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_SET_ID Field
MCdicom Structure See Also Send Feedback
Mating Feature Set ID (0068,63C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_SET_ID
Visual Basic
Public Const MATING_FEATURE_SET_ID As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_SET_ID

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_SET_LABEL Field
MCdicom Structure See Also Send Feedback
Mating Feature Set Label (0068,63D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_SET_LABEL
Visual Basic
Public Const MATING_FEATURE_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


MATING_FEATURE_SETS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATING_FEATURE_SETS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mating Feature Sets Sequence (0068,63B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATING_FEATURE_SETS_SEQUENCE
Visual Basic
Public Const MATING_FEATURE_SETS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATING_FEATURE_SETS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATRIX_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATRIX_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Matrix Registration Sequence (0070,0309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATRIX_REGISTRATION_SEQUENCE
Visual Basic
Public Const MATRIX_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATRIX_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MATRIX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MATRIX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Matrix Sequence (0070,030A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MATRIX_SEQUENCE
Visual Basic
Public Const MATRIX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MATRIX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAX_APERTURE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAX_APERTURE_VALUE Field
MCdicom Structure See Also Send Feedback
Max Aperture Value (0016,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAX_APERTURE_VALUE
Visual Basic
Public Const MAX_APERTURE_VALUE As UInteger
Visual C++
public:
literal unsigned int MAX_APERTURE_VALUE

See Also

MCdicom Structure
MCdicom Members


MAX_DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAX_DENSITY Field
MCdicom Structure See Also Send Feedback
Max Density (2010,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAX_DENSITY
Visual Basic
Public Const MAX_DENSITY As UInteger
Visual C++
public:
literal unsigned int MAX_DENSITY

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_ACROSS_SCAN_DISTORTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_ACROSS_SCAN_DISTORTION Field
MCdicom Structure See Also Send Feedback
Maximum Across-scan Distortion (0022,0049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_ACROSS_SCAN_DISTORTION
Visual Basic
Public Const MAXIMUM_ACROSS_SCAN_DISTORTION As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_ACROSS_SCAN_DISTORTION

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_ALONG_SCAN_DISTORTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_ALONG_SCAN_DISTORTION Field
MCdicom Structure See Also Send Feedback
Maximum Along-scan Distortion (0022,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_ALONG_SCAN_DISTORTION
Visual Basic
Public Const MAXIMUM_ALONG_SCAN_DISTORTION As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_ALONG_SCAN_DISTORTION

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_COLLATED_FILMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_COLLATED_FILMS Field
MCdicom Structure See Also Send Feedback
Maximum Collated Films (2010,0154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_COLLATED_FILMS
Visual Basic
Public Const MAXIMUM_COLLATED_FILMS As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_COLLATED_FILMS

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_COORDINATE_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_COORDINATE_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Maximum Coordinate Value RETIRED (5000,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_COORDINATE_VALUE_RETIRED
Visual Basic
Public Const MAXIMUM_COORDINATE_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_COORDINATE_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_CORNEAL_CURVATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_CORNEAL_CURVATURE Field
MCdicom Structure See Also Send Feedback
Maximum Corneal Curvature (0046,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_CORNEAL_CURVATURE
Visual Basic
Public Const MAXIMUM_CORNEAL_CURVATURE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_CORNEAL_CURVATURE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_CORNEAL_CURVATURE_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_CORNEAL_CURVATURE_LOCATION Field
MCdicom Structure See Also Send Feedback
Maximum Corneal Curvature Location (0046,0213)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_CORNEAL_CURVATURE_LOCATION
Visual Basic
Public Const MAXIMUM_CORNEAL_CURVATURE_LOCATION As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_CORNEAL_CURVATURE_LOCATION

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_CORNEAL_CURVATURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_CORNEAL_CURVATURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Maximum Corneal Curvature Sequence (0046,0211)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_CORNEAL_CURVATURE_SEQUENCE
Visual Basic
Public Const MAXIMUM_CORNEAL_CURVATURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_CORNEAL_CURVATURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_CUMULATIVE_METERSET_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_CUMULATIVE_METERSET_EXPOSURE Field
MCdicom Structure See Also Send Feedback
Maximum Cumulative Meterset Exposure (3002,0134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_CUMULATIVE_METERSET_EXPOSURE
Visual Basic
Public Const MAXIMUM_CUMULATIVE_METERSET_EXPOSURE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_CUMULATIVE_METERSET_EXPOSURE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_DEPTH_DISTORTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_DEPTH_DISTORTION Field
MCdicom Structure See Also Send Feedback
Maximum Depth Distortion (0022,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_DEPTH_DISTORTION
Visual Basic
Public Const MAXIMUM_DEPTH_DISTORTION As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_DEPTH_DISTORTION

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_FRACTIONAL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_FRACTIONAL_VALUE Field
MCdicom Structure See Also Send Feedback
Maximum Fractional Value (0062,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_FRACTIONAL_VALUE
Visual Basic
Public Const MAXIMUM_FRACTIONAL_VALUE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_FRACTIONAL_VALUE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_MEMORY_ALLOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_MEMORY_ALLOCATION Field
MCdicom Structure See Also Send Feedback
Maximum Memory Allocation (2000,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_MEMORY_ALLOCATION
Visual Basic
Public Const MAXIMUM_MEMORY_ALLOCATION As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_MEMORY_ALLOCATION

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_NOMINAL_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_NOMINAL_ENERGY Field
MCdicom Structure See Also Send Feedback
Maximum Nominal Energy (300A,0682)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_NOMINAL_ENERGY
Visual Basic
Public Const MAXIMUM_NOMINAL_ENERGY As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_NOMINAL_ENERGY

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_NUMBER_OF_INTERVAL_DAYS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_NUMBER_OF_INTERVAL_DAYS Field
MCdicom Structure See Also Send Feedback
Maximum Number of Interval Days (3010,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_NUMBER_OF_INTERVAL_DAYS
Visual Basic
Public Const MAXIMUM_NUMBER_OF_INTERVAL_DAYS As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_NUMBER_OF_INTERVAL_DAYS

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_NUMBER_OF_RECORDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_NUMBER_OF_RECORDS Field
MCdicom Structure See Also Send Feedback
Maximum Number of Records (0008,0429)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_NUMBER_OF_RECORDS
Visual Basic
Public Const MAXIMUM_NUMBER_OF_RECORDS As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_NUMBER_OF_RECORDS

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_POINT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_POINT_DISTANCE Field
MCdicom Structure See Also Send Feedback
Maximum Point Distance (0066,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_POINT_DISTANCE
Visual Basic
Public Const MAXIMUM_POINT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_POINT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_STIMULUS_LUMINANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_STIMULUS_LUMINANCE Field
MCdicom Structure See Also Send Feedback
Maximum Stimulus Luminance (0024,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_STIMULUS_LUMINANCE
Visual Basic
Public Const MAXIMUM_STIMULUS_LUMINANCE As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_STIMULUS_LUMINANCE

See Also

MCdicom Structure
MCdicom Members


MAXIMUM_STORED_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MAXIMUM_STORED_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Maximum Stored Value Mapped (0028,1232)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MAXIMUM_STORED_VALUE_MAPPED
Visual Basic
Public Const MAXIMUM_STORED_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int MAXIMUM_STORED_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


MEAN_POINT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEAN_POINT_DISTANCE Field
MCdicom Structure See Also Send Feedback
Mean Point Distance (0066,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEAN_POINT_DISTANCE
Visual Basic
Public Const MEAN_POINT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int MEAN_POINT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


MEASURED_AP_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_AP_DIMENSION Field
MCdicom Structure See Also Send Feedback
Measured AP Dimension (0010,1023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_AP_DIMENSION
Visual Basic
Public Const MEASURED_AP_DIMENSION As UInteger
Visual C++
public:
literal unsigned int MEASURED_AP_DIMENSION

See Also

MCdicom Structure
MCdicom Members


MEASURED_BANDWIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_BANDWIDTH Field
MCdicom Structure See Also Send Feedback
Measured Bandwidth (0014,401C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_BANDWIDTH
Visual Basic
Public Const MEASURED_BANDWIDTH As UInteger
Visual C++
public:
literal unsigned int MEASURED_BANDWIDTH

See Also

MCdicom Structure
MCdicom Members


MEASURED_BEAM_DIMENSION_A Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_BEAM_DIMENSION_A Field
MCdicom Structure See Also Send Feedback
Measured Beam Dimension A (0014,4017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_BEAM_DIMENSION_A
Visual Basic
Public Const MEASURED_BEAM_DIMENSION_A As UInteger
Visual C++
public:
literal unsigned int MEASURED_BEAM_DIMENSION_A

See Also

MCdicom Structure
MCdicom Members


MEASURED_BEAM_DIMENSION_B Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_BEAM_DIMENSION_B Field
MCdicom Structure See Also Send Feedback
Measured Beam Dimension B (0014,4018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_BEAM_DIMENSION_B
Visual Basic
Public Const MEASURED_BEAM_DIMENSION_B As UInteger
Visual C++
public:
literal unsigned int MEASURED_BEAM_DIMENSION_B

See Also

MCdicom Structure
MCdicom Members


MEASURED_CENTER_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_CENTER_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Measured Center Frequency (0014,401B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_CENTER_FREQUENCY
Visual Basic
Public Const MEASURED_CENTER_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int MEASURED_CENTER_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


MEASURED_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_CHARACTERISTICS Field
MCdicom Structure See Also Send Feedback
Measured Characteristics (0028,7026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_CHARACTERISTICS
Visual Basic
Public Const MEASURED_CHARACTERISTICS As UInteger
Visual C++
public:
literal unsigned int MEASURED_CHARACTERISTICS

See Also

MCdicom Structure
MCdicom Members


MEASURED_DOSE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_DOSE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Measured Dose Description (3008,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_DOSE_DESCRIPTION
Visual Basic
Public Const MEASURED_DOSE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int MEASURED_DOSE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


MEASURED_DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Measured Dose Reference Number (3008,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_DOSE_REFERENCE_NUMBER
Visual Basic
Public Const MEASURED_DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int MEASURED_DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


MEASURED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measured Dose Reference Sequence (3008,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const MEASURED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASURED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASURED_DOSE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_DOSE_TYPE Field
MCdicom Structure See Also Send Feedback
Measured Dose Type (3008,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_DOSE_TYPE
Visual Basic
Public Const MEASURED_DOSE_TYPE As UInteger
Visual C++
public:
literal unsigned int MEASURED_DOSE_TYPE

See Also

MCdicom Structure
MCdicom Members


MEASURED_DOSE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_DOSE_VALUE Field
MCdicom Structure See Also Send Feedback
Measured Dose Value (3008,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_DOSE_VALUE
Visual Basic
Public Const MEASURED_DOSE_VALUE As UInteger
Visual C++
public:
literal unsigned int MEASURED_DOSE_VALUE

See Also

MCdicom Structure
MCdicom Members


MEASURED_LATERAL_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_LATERAL_DIMENSION Field
MCdicom Structure See Also Send Feedback
Measured Lateral Dimension (0010,1024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_LATERAL_DIMENSION
Visual Basic
Public Const MEASURED_LATERAL_DIMENSION As UInteger
Visual C++
public:
literal unsigned int MEASURED_LATERAL_DIMENSION

See Also

MCdicom Structure
MCdicom Members


MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measured Meterset to Dose Mapping Sequence (300A,0772)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE
Visual Basic
Public Const MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASURED_METERSET_TO_DOSE_MAPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASURED_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURED_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measured Value Sequence (0040,A300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURED_VALUE_SEQUENCE
Visual Basic
Public Const MEASURED_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASURED_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_AUTOMATION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_AUTOMATION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Measurement Automation (Trial) RETIRED (0040,A194)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_AUTOMATION_TRIAL_RETIRED
Visual Basic
Public Const MEASUREMENT_AUTOMATION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_AUTOMATION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_EQUIPMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_EQUIPMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measurement Equipment Sequence (0028,7012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_EQUIPMENT_SEQUENCE
Visual Basic
Public Const MEASUREMENT_EQUIPMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_EQUIPMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_EQUIPMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_EQUIPMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Measurement Equipment Type (0028,7014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_EQUIPMENT_TYPE
Visual Basic
Public Const MEASUREMENT_EQUIPMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_EQUIPMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_FUNCTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_FUNCTIONS Field
MCdicom Structure See Also Send Feedback
Measurement Functions (0028,7013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_FUNCTIONS
Visual Basic
Public Const MEASUREMENT_FUNCTIONS As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_FUNCTIONS

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_LATERALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_LATERALITY Field
MCdicom Structure See Also Send Feedback
Measurement Laterality (0024,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_LATERALITY
Visual Basic
Public Const MEASUREMENT_LATERALITY As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_LATERALITY

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_PATTERN_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_PATTERN_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measurement Pattern Code Sequence (0028,702D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_PATTERN_CODE_SEQUENCE
Visual Basic
Public Const MEASUREMENT_PATTERN_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_PATTERN_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Measurement Precision Description (Trial) RETIRED (0040,A047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_PRECISION_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_UNITS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_UNITS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measurement Units Code Sequence (0040,08EA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_UNITS_CODE_SEQUENCE
Visual Basic
Public Const MEASUREMENT_UNITS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_UNITS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENT_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENT_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measurement Values Sequence (0066,0132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENT_VALUES_SEQUENCE
Visual Basic
Public Const MEASUREMENT_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENT_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measurements Sequence (0066,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASUREMENTS_SEQUENCE
Visual Basic
Public Const MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEASURING_UNITS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEASURING_UNITS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Measuring Units Sequence (0040,0295)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEASURING_UNITS_SEQUENCE
Visual Basic
Public Const MEASURING_UNITS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEASURING_UNITS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MECHANICAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MECHANICAL_INDEX Field
MCdicom Structure See Also Send Feedback
Mechanical Index (0018,5022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MECHANICAL_INDEX
Visual Basic
Public Const MECHANICAL_INDEX As UInteger
Visual C++
public:
literal unsigned int MECHANICAL_INDEX

See Also

MCdicom Structure
MCdicom Members


MEDIA_DISPOSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDIA_DISPOSITION Field
MCdicom Structure See Also Send Feedback
Media Disposition (2200,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDIA_DISPOSITION
Visual Basic
Public Const MEDIA_DISPOSITION As UInteger
Visual C++
public:
literal unsigned int MEDIA_DISPOSITION

See Also

MCdicom Structure
MCdicom Members


MEDIA_INSTALLED_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDIA_INSTALLED_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Media Installed Sequence (2000,00A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDIA_INSTALLED_SEQUENCE
Visual Basic
Public Const MEDIA_INSTALLED_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MEDIA_INSTALLED_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MEDIA_STORAGE_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDIA_STORAGE_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Media Storage SOP Class UID (0002,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDIA_STORAGE_SOP_CLASS_UID
Visual Basic
Public Const MEDIA_STORAGE_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int MEDIA_STORAGE_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


MEDIA_STORAGE_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDIA_STORAGE_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Media Storage SOP Instance UID (0002,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDIA_STORAGE_SOP_INSTANCE_UID
Visual Basic
Public Const MEDIA_STORAGE_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int MEDIA_STORAGE_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


MEDICAL_ALERTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDICAL_ALERTS Field
MCdicom Structure See Also Send Feedback
Medical Alerts (0010,2000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDICAL_ALERTS
Visual Basic
Public Const MEDICAL_ALERTS As UInteger
Visual C++
public:
literal unsigned int MEDICAL_ALERTS

See Also

MCdicom Structure
MCdicom Members


MEDICAL_RECORD_LOCATOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDICAL_RECORD_LOCATOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Medical Record Locator RETIRED (0010,1090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDICAL_RECORD_LOCATOR_RETIRED
Visual Basic
Public Const MEDICAL_RECORD_LOCATOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int MEDICAL_RECORD_LOCATOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


MEDIUM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEDIUM_TYPE Field
MCdicom Structure See Also Send Feedback
Medium Type (2000,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEDIUM_TYPE
Visual Basic
Public Const MEDIUM_TYPE As UInteger
Visual C++
public:
literal unsigned int MEDIUM_TYPE

See Also

MCdicom Structure
MCdicom Members


MEMORY_ALLOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEMORY_ALLOCATION Field
MCdicom Structure See Also Send Feedback
Memory Allocation (2000,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEMORY_ALLOCATION
Visual Basic
Public Const MEMORY_ALLOCATION As UInteger
Visual C++
public:
literal unsigned int MEMORY_ALLOCATION

See Also

MCdicom Structure
MCdicom Members


MEMORY_BIT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MEMORY_BIT_DEPTH Field
MCdicom Structure See Also Send Feedback
Memory Bit Depth (2000,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MEMORY_BIT_DEPTH
Visual Basic
Public Const MEMORY_BIT_DEPTH As UInteger
Visual C++
public:
literal unsigned int MEMORY_BIT_DEPTH

See Also

MCdicom Structure
MCdicom Members


MESSAGE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MESSAGE_ID Field
MCdicom Structure See Also Send Feedback
Message ID (0000,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MESSAGE_ID
Visual Basic
Public Const MESSAGE_ID As UInteger
Visual C++
public:
literal unsigned int MESSAGE_ID

See Also

MCdicom Structure
MCdicom Members


MESSAGE_ID_BEING_RESPONDED_TO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MESSAGE_ID_BEING_RESPONDED_TO Field
MCdicom Structure See Also Send Feedback
Message ID Being Responded To (0000,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MESSAGE_ID_BEING_RESPONDED_TO
Visual Basic
Public Const MESSAGE_ID_BEING_RESPONDED_TO As UInteger
Visual C++
public:
literal unsigned int MESSAGE_ID_BEING_RESPONDED_TO

See Also

MCdicom Structure
MCdicom Members


MESSAGE_SET_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MESSAGE_SET_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Message Set ID RETIRED (0000,5010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MESSAGE_SET_ID_RETIRED
Visual Basic
Public Const MESSAGE_SET_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int MESSAGE_SET_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


METABOLITE_MAP_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METABOLITE_MAP_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Metabolite Map Code Sequence (0018,9083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METABOLITE_MAP_CODE_SEQUENCE
Visual Basic
Public Const METABOLITE_MAP_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int METABOLITE_MAP_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


METABOLITE_MAP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METABOLITE_MAP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Metabolite Map Description (0018,9080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METABOLITE_MAP_DESCRIPTION
Visual Basic
Public Const METABOLITE_MAP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int METABOLITE_MAP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


METADATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METADATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Metadata Sequence (0008,041D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METADATA_SEQUENCE
Visual Basic
Public Const METADATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int METADATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


METERING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERING_MODE Field
MCdicom Structure See Also Send Feedback
Metering Mode (0016,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERING_MODE
Visual Basic
Public Const METERING_MODE As UInteger
Visual C++
public:
literal unsigned int METERING_MODE

See Also

MCdicom Structure
MCdicom Members


METERSET_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERSET_EXPOSURE Field
MCdicom Structure See Also Send Feedback
Meterset Exposure (3002,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERSET_EXPOSURE
Visual Basic
Public Const METERSET_EXPOSURE As UInteger
Visual C++
public:
literal unsigned int METERSET_EXPOSURE

See Also

MCdicom Structure
MCdicom Members


METERSET_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERSET_RATE Field
MCdicom Structure See Also Send Feedback
Meterset Rate (300A,035A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERSET_RATE
Visual Basic
Public Const METERSET_RATE As UInteger
Visual C++
public:
literal unsigned int METERSET_RATE

See Also

MCdicom Structure
MCdicom Members


METERSET_RATE_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERSET_RATE_DELIVERED Field
MCdicom Structure See Also Send Feedback
Meterset Rate Delivered (3008,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERSET_RATE_DELIVERED
Visual Basic
Public Const METERSET_RATE_DELIVERED As UInteger
Visual C++
public:
literal unsigned int METERSET_RATE_DELIVERED

See Also

MCdicom Structure
MCdicom Members


METERSET_RATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERSET_RATE_SET Field
MCdicom Structure See Also Send Feedback
Meterset Rate Set (3008,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERSET_RATE_SET
Visual Basic
Public Const METERSET_RATE_SET As UInteger
Visual C++
public:
literal unsigned int METERSET_RATE_SET

See Also

MCdicom Structure
MCdicom Members


METERSET_TO_DOSE_MAPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..METERSET_TO_DOSE_MAPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Meterset to Dose Mapping Sequence (300A,0620)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint METERSET_TO_DOSE_MAPPING_SEQUENCE
Visual Basic
Public Const METERSET_TO_DOSE_MAPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int METERSET_TO_DOSE_MAPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MID_SLAB_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MID_SLAB_POSITION Field
MCdicom Structure See Also Send Feedback
Mid Slab Position (0018,9106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MID_SLAB_POSITION
Visual Basic
Public Const MID_SLAB_POSITION As UInteger
Visual C++
public:
literal unsigned int MID_SLAB_POSITION

See Also

MCdicom Structure
MCdicom Members


MILITARY_RANK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MILITARY_RANK Field
MCdicom Structure See Also Send Feedback
Military Rank (0010,1080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MILITARY_RANK
Visual Basic
Public Const MILITARY_RANK As UInteger
Visual C++
public:
literal unsigned int MILITARY_RANK

See Also

MCdicom Structure
MCdicom Members


MIME_TYPE_OF_ENCAPSULATED_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MIME_TYPE_OF_ENCAPSULATED_DOCUMENT Field
MCdicom Structure See Also Send Feedback
MIME Type of Encapsulated Document (0042,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MIME_TYPE_OF_ENCAPSULATED_DOCUMENT
Visual Basic
Public Const MIME_TYPE_OF_ENCAPSULATED_DOCUMENT As UInteger
Visual C++
public:
literal unsigned int MIME_TYPE_OF_ENCAPSULATED_DOCUMENT

See Also

MCdicom Structure
MCdicom Members


MIN_DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MIN_DENSITY Field
MCdicom Structure See Also Send Feedback
Min Density (2010,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MIN_DENSITY
Visual Basic
Public Const MIN_DENSITY As UInteger
Visual C++
public:
literal unsigned int MIN_DENSITY

See Also

MCdicom Structure
MCdicom Members


MINIMUM_COORDINATE_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_COORDINATE_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Minimum Coordinate Value RETIRED (5000,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_COORDINATE_VALUE_RETIRED
Visual Basic
Public Const MINIMUM_COORDINATE_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int MINIMUM_COORDINATE_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


MINIMUM_HOURS_BETWEEN_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_HOURS_BETWEEN_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Minimum Hours between Fractions (3010,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_HOURS_BETWEEN_FRACTIONS
Visual Basic
Public Const MINIMUM_HOURS_BETWEEN_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int MINIMUM_HOURS_BETWEEN_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


MINIMUM_KERATOMETRIC_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_KERATOMETRIC_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Minimum Keratometric Sequence (0046,0215)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_KERATOMETRIC_SEQUENCE
Visual Basic
Public Const MINIMUM_KERATOMETRIC_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MINIMUM_KERATOMETRIC_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MINIMUM_NOMINAL_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_NOMINAL_ENERGY Field
MCdicom Structure See Also Send Feedback
Minimum Nominal Energy (300A,0681)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_NOMINAL_ENERGY
Visual Basic
Public Const MINIMUM_NOMINAL_ENERGY As UInteger
Visual C++
public:
literal unsigned int MINIMUM_NOMINAL_ENERGY

See Also

MCdicom Structure
MCdicom Members


MINIMUM_NUMBER_OF_INTERVAL_DAYS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_NUMBER_OF_INTERVAL_DAYS Field
MCdicom Structure See Also Send Feedback
Minimum Number of Interval Days (3010,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_NUMBER_OF_INTERVAL_DAYS
Visual Basic
Public Const MINIMUM_NUMBER_OF_INTERVAL_DAYS As UInteger
Visual C++
public:
literal unsigned int MINIMUM_NUMBER_OF_INTERVAL_DAYS

See Also

MCdicom Structure
MCdicom Members


MINIMUM_SENSITIVITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_SENSITIVITY_VALUE Field
MCdicom Structure See Also Send Feedback
Minimum Sensitivity Value (0024,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_SENSITIVITY_VALUE
Visual Basic
Public Const MINIMUM_SENSITIVITY_VALUE As UInteger
Visual C++
public:
literal unsigned int MINIMUM_SENSITIVITY_VALUE

See Also

MCdicom Structure
MCdicom Members


MINIMUM_STORED_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MINIMUM_STORED_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Minimum Stored Value Mapped (0028,1231)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MINIMUM_STORED_VALUE_MAPPED
Visual Basic
Public Const MINIMUM_STORED_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int MINIMUM_STORED_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


MODALITIES_IN_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODALITIES_IN_STUDY Field
MCdicom Structure See Also Send Feedback
Modalities in Study (0008,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODALITIES_IN_STUDY
Visual Basic
Public Const MODALITIES_IN_STUDY As UInteger
Visual C++
public:
literal unsigned int MODALITIES_IN_STUDY

See Also

MCdicom Structure
MCdicom Members


MODALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODALITY Field
MCdicom Structure See Also Send Feedback
Modality (0008,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODALITY
Visual Basic
Public Const MODALITY As UInteger
Visual C++
public:
literal unsigned int MODALITY

See Also

MCdicom Structure
MCdicom Members


MODALITY_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODALITY_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Modality LUT Sequence (0028,3000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODALITY_LUT_SEQUENCE
Visual Basic
Public Const MODALITY_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODALITY_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODALITY_LUT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODALITY_LUT_TYPE Field
MCdicom Structure See Also Send Feedback
Modality LUT Type (0028,3004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODALITY_LUT_TYPE
Visual Basic
Public Const MODALITY_LUT_TYPE As UInteger
Visual C++
public:
literal unsigned int MODALITY_LUT_TYPE

See Also

MCdicom Structure
MCdicom Members


MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mode of Percutaneous Access Sequence (0052,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE
Visual Basic
Public Const MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODE_OF_PERCUTANEOUS_ACCESS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODEL_GROUP_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODEL_GROUP_UID Field
MCdicom Structure See Also Send Feedback
Model Group UID (0068,7004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODEL_GROUP_UID
Visual Basic
Public Const MODEL_GROUP_UID As UInteger
Visual C++
public:
literal unsigned int MODEL_GROUP_UID

See Also

MCdicom Structure
MCdicom Members


MODEL_MIRRORING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODEL_MIRRORING Field
MCdicom Structure See Also Send Feedback
Model Mirroring (0068,7002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODEL_MIRRORING
Visual Basic
Public Const MODEL_MIRRORING As UInteger
Visual C++
public:
literal unsigned int MODEL_MIRRORING

See Also

MCdicom Structure
MCdicom Members


MODEL_MODIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODEL_MODIFICATION Field
MCdicom Structure See Also Send Feedback
Model Modification (0068,7001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODEL_MODIFICATION
Visual Basic
Public Const MODEL_MODIFICATION As UInteger
Visual C++
public:
literal unsigned int MODEL_MODIFICATION

See Also

MCdicom Structure
MCdicom Members


MODEL_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODEL_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Model Specification Sequence (0018,9912)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODEL_SPECIFICATION_SEQUENCE
Visual Basic
Public Const MODEL_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODEL_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODEL_USAGE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODEL_USAGE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Model Usage Code Sequence (0068,7003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODEL_USAGE_CODE_SEQUENCE
Visual Basic
Public Const MODEL_USAGE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODEL_USAGE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODIFIABLE_CONSTRAINT_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIABLE_CONSTRAINT_FLAG Field
MCdicom Structure See Also Send Feedback
Modifiable Constraint Flag (0082,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIABLE_CONSTRAINT_FLAG
Visual Basic
Public Const MODIFIABLE_CONSTRAINT_FLAG As UInteger
Visual C++
public:
literal unsigned int MODIFIABLE_CONSTRAINT_FLAG

See Also

MCdicom Structure
MCdicom Members


MODIFIED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Modified Attributes Sequence (0400,0550)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const MODIFIED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODIFIED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODIFIED_IMAGE_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIED_IMAGE_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Modified Image Date RETIRED (0020,3403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIED_IMAGE_DATE_RETIRED
Visual Basic
Public Const MODIFIED_IMAGE_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFIED_IMAGE_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFIED_IMAGE_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIED_IMAGE_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Modified Image Description RETIRED (0020,3406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIED_IMAGE_DESCRIPTION_RETIRED
Visual Basic
Public Const MODIFIED_IMAGE_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFIED_IMAGE_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFIED_IMAGE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIED_IMAGE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Modified Image ID RETIRED (0020,3402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIED_IMAGE_ID_RETIRED
Visual Basic
Public Const MODIFIED_IMAGE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFIED_IMAGE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFIED_IMAGE_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIED_IMAGE_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Modified Image Time RETIRED (0020,3405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIED_IMAGE_TIME_RETIRED
Visual Basic
Public Const MODIFIED_IMAGE_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFIED_IMAGE_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Modifier Code Sequence (0040,A195)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MODIFYING_DEVICE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFYING_DEVICE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Modifying Device ID RETIRED (0020,3401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFYING_DEVICE_ID_RETIRED
Visual Basic
Public Const MODIFYING_DEVICE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFYING_DEVICE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFYING_DEVICE_MANUFACTURER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFYING_DEVICE_MANUFACTURER_RETIRED Field
MCdicom Structure See Also Send Feedback
Modifying Device Manufacturer RETIRED (0020,3404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFYING_DEVICE_MANUFACTURER_RETIRED
Visual Basic
Public Const MODIFYING_DEVICE_MANUFACTURER_RETIRED As UInteger
Visual C++
public:
literal unsigned int MODIFYING_DEVICE_MANUFACTURER_RETIRED

See Also

MCdicom Structure
MCdicom Members


MODIFYING_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODIFYING_SYSTEM Field
MCdicom Structure See Also Send Feedback
Modifying System (0400,0563)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODIFYING_SYSTEM
Visual Basic
Public Const MODIFYING_SYSTEM As UInteger
Visual C++
public:
literal unsigned int MODIFYING_SYSTEM

See Also

MCdicom Structure
MCdicom Members


MODULATED_SCAN_MODE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODULATED_SCAN_MODE_TYPE Field
MCdicom Structure See Also Send Feedback
Modulated Scan Mode Type (300A,0309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODULATED_SCAN_MODE_TYPE
Visual Basic
Public Const MODULATED_SCAN_MODE_TYPE As UInteger
Visual C++
public:
literal unsigned int MODULATED_SCAN_MODE_TYPE

See Also

MCdicom Structure
MCdicom Members


MODULATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MODULATION_TYPE Field
MCdicom Structure See Also Send Feedback
Modulation Type (0014,4026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MODULATION_TYPE
Visual Basic
Public Const MODULATION_TYPE As UInteger
Visual C++
public:
literal unsigned int MODULATION_TYPE

See Also

MCdicom Structure
MCdicom Members


MONOENERGETIC_ENERGY_EQUIVALENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MONOENERGETIC_ENERGY_EQUIVALENT Field
MCdicom Structure See Also Send Feedback
Monoenergetic Energy Equivalent (0018,937C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MONOENERGETIC_ENERGY_EQUIVALENT
Visual Basic
Public Const MONOENERGETIC_ENERGY_EQUIVALENT As UInteger
Visual C++
public:
literal unsigned int MONOENERGETIC_ENERGY_EQUIVALENT

See Also

MCdicom Structure
MCdicom Members


MOST_RECENT_TREATMENT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MOST_RECENT_TREATMENT_DATE Field
MCdicom Structure See Also Send Feedback
Most Recent Treatment Date (3008,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MOST_RECENT_TREATMENT_DATE
Visual Basic
Public Const MOST_RECENT_TREATMENT_DATE As UInteger
Visual C++
public:
literal unsigned int MOST_RECENT_TREATMENT_DATE

See Also

MCdicom Structure
MCdicom Members


MOTION_SYNCHRONIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MOTION_SYNCHRONIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Motion Synchronization Sequence (300A,0410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MOTION_SYNCHRONIZATION_SEQUENCE
Visual Basic
Public Const MOTION_SYNCHRONIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MOTION_SYNCHRONIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MOVE_DESTINATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MOVE_DESTINATION Field
MCdicom Structure See Also Send Feedback
Move Destination (0000,0600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MOVE_DESTINATION
Visual Basic
Public Const MOVE_DESTINATION As UInteger
Visual C++
public:
literal unsigned int MOVE_DESTINATION

See Also

MCdicom Structure
MCdicom Members


MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE Field
MCdicom Structure See Also Send Feedback
Move Originator Application Entity Title (0000,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE
Visual Basic
Public Const MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE As UInteger
Visual C++
public:
literal unsigned int MOVE_ORIGINATOR_APPLICATION_ENTITY_TITLE

See Also

MCdicom Structure
MCdicom Members


MOVE_ORIGINATOR_MESSAGE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MOVE_ORIGINATOR_MESSAGE_ID Field
MCdicom Structure See Also Send Feedback
Move Originator Message ID (0000,1031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MOVE_ORIGINATOR_MESSAGE_ID
Visual Basic
Public Const MOVE_ORIGINATOR_MESSAGE_ID As UInteger
Visual C++
public:
literal unsigned int MOVE_ORIGINATOR_MESSAGE_ID

See Also

MCdicom Structure
MCdicom Members


MPR_SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
MPR Slab Thickness (0070,1503)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_SLAB_THICKNESS
Visual Basic
Public Const MPR_SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int MPR_SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


MPR_THICKNESS_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_THICKNESS_TYPE Field
MCdicom Structure See Also Send Feedback
MPR Thickness Type (0070,1502)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_THICKNESS_TYPE
Visual Basic
Public Const MPR_THICKNESS_TYPE As UInteger
Visual C++
public:
literal unsigned int MPR_THICKNESS_TYPE

See Also

MCdicom Structure
MCdicom Members


MPR_TOP_LEFT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_TOP_LEFT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
MPR Top Left Hand Corner (0070,1505)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_TOP_LEFT_HAND_CORNER
Visual Basic
Public Const MPR_TOP_LEFT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int MPR_TOP_LEFT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


MPR_VIEW_HEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_VIEW_HEIGHT Field
MCdicom Structure See Also Send Feedback
MPR View Height (0070,1512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_VIEW_HEIGHT
Visual Basic
Public Const MPR_VIEW_HEIGHT As UInteger
Visual C++
public:
literal unsigned int MPR_VIEW_HEIGHT

See Also

MCdicom Structure
MCdicom Members


MPR_VIEW_HEIGHT_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_VIEW_HEIGHT_DIRECTION Field
MCdicom Structure See Also Send Feedback
MPR View Height Direction (0070,1511)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_VIEW_HEIGHT_DIRECTION
Visual Basic
Public Const MPR_VIEW_HEIGHT_DIRECTION As UInteger
Visual C++
public:
literal unsigned int MPR_VIEW_HEIGHT_DIRECTION

See Also

MCdicom Structure
MCdicom Members


MPR_VIEW_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_VIEW_WIDTH Field
MCdicom Structure See Also Send Feedback
MPR View Width (0070,1508)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_VIEW_WIDTH
Visual Basic
Public Const MPR_VIEW_WIDTH As UInteger
Visual C++
public:
literal unsigned int MPR_VIEW_WIDTH

See Also

MCdicom Structure
MCdicom Members


MPR_VIEW_WIDTH_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MPR_VIEW_WIDTH_DIRECTION Field
MCdicom Structure See Also Send Feedback
MPR View Width Direction (0070,1507)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MPR_VIEW_WIDTH_DIRECTION
Visual Basic
Public Const MPR_VIEW_WIDTH_DIRECTION As UInteger
Visual C++
public:
literal unsigned int MPR_VIEW_WIDTH_DIRECTION

See Also

MCdicom Structure
MCdicom Members


MR_ACQUISITION_FREQ_ENC_STEPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ACQUISITION_FREQ_ENC_STEPS Field
MCdicom Structure See Also Send Feedback
Alias for tag MR_ACQUISITION_FREQUENCY_ENCODING_STEPS (0018,9058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ACQUISITION_FREQ_ENC_STEPS
Visual Basic
Public Const MR_ACQUISITION_FREQ_ENC_STEPS As UInteger
Visual C++
public:
literal unsigned int MR_ACQUISITION_FREQ_ENC_STEPS

See Also

MCdicom Structure
MCdicom Members


MR_ACQUISITION_FREQUENCY_ENCODING_STEPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ACQUISITION_FREQUENCY_ENCODING_STEPS Field
MCdicom Structure See Also Send Feedback
MR Acquisition Frequency Encoding Steps (0018,9058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ACQUISITION_FREQUENCY_ENCODING_STEPS
Visual Basic
Public Const MR_ACQUISITION_FREQUENCY_ENCODING_STEPS As UInteger
Visual C++
public:
literal unsigned int MR_ACQUISITION_FREQUENCY_ENCODING_STEPS

See Also

MCdicom Structure
MCdicom Members


MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE Field
MCdicom Structure See Also Send Feedback
MR Acquisition Phase Encoding Steps in-plane (0018,9231)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE
Visual Basic
Public Const MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE As UInteger
Visual C++
public:
literal unsigned int MR_ACQUISITION_PHASE_ENCODING_STEPS_IN_PLANE

See Also

MCdicom Structure
MCdicom Members


MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE Field
MCdicom Structure See Also Send Feedback
MR Acquisition Phase Encoding Steps out-of-plane (0018,9232)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE
Visual Basic
Public Const MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE As UInteger
Visual C++
public:
literal unsigned int MR_ACQUISITION_PHASE_ENCODING_STEPS_OUT_OF_PLANE

See Also

MCdicom Structure
MCdicom Members


MR_ACQUISITION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ACQUISITION_TYPE Field
MCdicom Structure See Also Send Feedback
MR Acquisition Type (0018,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ACQUISITION_TYPE
Visual Basic
Public Const MR_ACQUISITION_TYPE As UInteger
Visual C++
public:
literal unsigned int MR_ACQUISITION_TYPE

See Also

MCdicom Structure
MCdicom Members


MR_ARTERIAL_SPIN_LABELING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ARTERIAL_SPIN_LABELING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Arterial Spin Labeling Sequence (0018,9251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ARTERIAL_SPIN_LABELING_SEQUENCE
Visual Basic
Public Const MR_ARTERIAL_SPIN_LABELING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_ARTERIAL_SPIN_LABELING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_AVERAGES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_AVERAGES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Averages Sequence (0018,9119)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_AVERAGES_SEQUENCE
Visual Basic
Public Const MR_AVERAGES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_AVERAGES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_DIFFUSION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_DIFFUSION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Diffusion Sequence (0018,9117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_DIFFUSION_SEQUENCE
Visual Basic
Public Const MR_DIFFUSION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_DIFFUSION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_ECHO_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_ECHO_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Echo Sequence (0018,9114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_ECHO_SEQUENCE
Visual Basic
Public Const MR_ECHO_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_ECHO_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_FOV_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_FOV_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR FOV/Geometry Sequence (0018,9125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_FOV_GEOMETRY_SEQUENCE
Visual Basic
Public Const MR_FOV_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_FOV_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_IMAGE_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_IMAGE_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Image Frame Type Sequence (0018,9226)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_IMAGE_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const MR_IMAGE_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_IMAGE_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_IMAGING_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_IMAGING_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Imaging Modifier Sequence (0018,9006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_IMAGING_MODIFIER_SEQUENCE
Visual Basic
Public Const MR_IMAGING_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_IMAGING_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_METABOLITE_MAP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_METABOLITE_MAP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Metabolite Map Sequence (0018,9152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_METABOLITE_MAP_SEQUENCE
Visual Basic
Public Const MR_METABOLITE_MAP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_METABOLITE_MAP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Modifier Sequence (0018,9115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_MODIFIER_SEQUENCE
Visual Basic
Public Const MR_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_RECEIVE_COIL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_RECEIVE_COIL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Receive Coil Sequence (0018,9042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_RECEIVE_COIL_SEQUENCE
Visual Basic
Public Const MR_RECEIVE_COIL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_RECEIVE_COIL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_SPATIAL_SATURATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_SPATIAL_SATURATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Spatial Saturation Sequence (0018,9107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_SPATIAL_SATURATION_SEQUENCE
Visual Basic
Public Const MR_SPATIAL_SATURATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_SPATIAL_SATURATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_SPECTROSCOPY_ACQUISITION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_SPECTROSCOPY_ACQUISITION_TYPE Field
MCdicom Structure See Also Send Feedback
MR Spectroscopy Acquisition Type (0018,9200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_SPECTROSCOPY_ACQUISITION_TYPE
Visual Basic
Public Const MR_SPECTROSCOPY_ACQUISITION_TYPE As UInteger
Visual C++
public:
literal unsigned int MR_SPECTROSCOPY_ACQUISITION_TYPE

See Also

MCdicom Structure
MCdicom Members


MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Spectroscopy FOV/Geometry Sequence (0018,9103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE
Visual Basic
Public Const MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_SPECTROSCOPY_FOV_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Spectroscopy Frame Type Sequence (0018,9227)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_SPECTROSCOPY_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Timing and Related Parameters Sequence (0018,9112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE
Visual Basic
Public Const MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_TIMING_AND_RELATED_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_TRANSMIT_COIL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_TRANSMIT_COIL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Transmit Coil Sequence (0018,9049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_TRANSMIT_COIL_SEQUENCE
Visual Basic
Public Const MR_TRANSMIT_COIL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_TRANSMIT_COIL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MR_VELOCITY_ENCODING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MR_VELOCITY_ENCODING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MR Velocity Encoding Sequence (0018,9197)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MR_VELOCITY_ENCODING_SEQUENCE
Visual Basic
Public Const MR_VELOCITY_ENCODING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MR_VELOCITY_ENCODING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MRDR_DIRECTORY_RECORD_OFFSET_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MRDR_DIRECTORY_RECORD_OFFSET_RETIRED Field
MCdicom Structure See Also Send Feedback
MRDR Directory Record Offset RETIRED (0004,1504)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MRDR_DIRECTORY_RECORD_OFFSET_RETIRED
Visual Basic
Public Const MRDR_DIRECTORY_RECORD_OFFSET_RETIRED As UInteger
Visual C++
public:
literal unsigned int MRDR_DIRECTORY_RECORD_OFFSET_RETIRED

See Also

MCdicom Structure
MCdicom Members


MULIPLEX_GROUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULIPLEX_GROUP_LABEL Field
MCdicom Structure See Also Send Feedback
Alias for tag MULTIPLEX_GROUP_LABEL (003A,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULIPLEX_GROUP_LABEL
Visual Basic
Public Const MULIPLEX_GROUP_LABEL As UInteger
Visual C++
public:
literal unsigned int MULIPLEX_GROUP_LABEL

See Also

MCdicom Structure
MCdicom Members


MULTI_COIL_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_COIL_CONFIGURATION Field
MCdicom Structure See Also Send Feedback
Multi-Coil Configuration (0018,9046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_COIL_CONFIGURATION
Visual Basic
Public Const MULTI_COIL_CONFIGURATION As UInteger
Visual C++
public:
literal unsigned int MULTI_COIL_CONFIGURATION

See Also

MCdicom Structure
MCdicom Members


MULTI_COIL_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_COIL_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-Coil Definition Sequence (0018,9045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_COIL_DEFINITION_SEQUENCE
Visual Basic
Public Const MULTI_COIL_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_COIL_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_COIL_ELEMENT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_COIL_ELEMENT_NAME Field
MCdicom Structure See Also Send Feedback
Multi-Coil Element Name (0018,9047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_COIL_ELEMENT_NAME
Visual Basic
Public Const MULTI_COIL_ELEMENT_NAME As UInteger
Visual C++
public:
literal unsigned int MULTI_COIL_ELEMENT_NAME

See Also

MCdicom Structure
MCdicom Members


MULTI_COIL_ELEMENT_USED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_COIL_ELEMENT_USED Field
MCdicom Structure See Also Send Feedback
Multi-Coil Element Used (0018,9048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_COIL_ELEMENT_USED
Visual Basic
Public Const MULTI_COIL_ELEMENT_USED As UInteger
Visual C++
public:
literal unsigned int MULTI_COIL_ELEMENT_USED

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_ACQUISITION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_ACQUISITION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Multi-energy Acquisition Description (0018,937B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_ACQUISITION_DESCRIPTION
Visual Basic
Public Const MULTI_ENERGY_ACQUISITION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_ACQUISITION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_ACQUISITION Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Acquisition (0018,9361)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_ACQUISITION
Visual Basic
Public Const MULTI_ENERGY_CT_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Acquisition Sequence (0018,9362)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_ACQUISITION_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Characteristics Sequence (0018,9364)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_PATH_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_PATH_INDEX Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Path Index (0018,937A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_PATH_INDEX
Visual Basic
Public Const MULTI_ENERGY_CT_PATH_INDEX As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_PATH_INDEX

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_PATH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_PATH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Path Sequence (0018,9379)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_PATH_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_PATH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_PATH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_PROCESSING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_PROCESSING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT Processing Sequence (0018,9363)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_PROCESSING_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_PROCESSING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_PROCESSING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT X-Ray Detector Sequence (0018,936F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_X_RAY_DETECTOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-energy CT X-Ray Source Sequence (0018,9365)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE
Visual Basic
Public Const MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_CT_X_RAY_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_DETECTOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_DETECTOR_TYPE Field
MCdicom Structure See Also Send Feedback
Multi-energy Detector Type (0018,9372)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_DETECTOR_TYPE
Visual Basic
Public Const MULTI_ENERGY_DETECTOR_TYPE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_DETECTOR_TYPE

See Also

MCdicom Structure
MCdicom Members


MULTI_ENERGY_SOURCE_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_ENERGY_SOURCE_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Multi-energy Source Technique (0018,9368)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_ENERGY_SOURCE_TECHNIQUE
Visual Basic
Public Const MULTI_ENERGY_SOURCE_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int MULTI_ENERGY_SOURCE_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


MULTI_FRAME_PRESENTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_FRAME_PRESENTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multi-frame Presentation Sequence (0028,9505)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_FRAME_PRESENTATION_SEQUENCE
Visual Basic
Public Const MULTI_FRAME_PRESENTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTI_FRAME_PRESENTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MULTI_FRAME_SOURCE_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_FRAME_SOURCE_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Multi-frame Source SOP Instance UID (0008,1167)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_FRAME_SOURCE_SOP_INSTANCE_UID
Visual Basic
Public Const MULTI_FRAME_SOURCE_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int MULTI_FRAME_SOURCE_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


MULTI_PLANAR_EXCITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_PLANAR_EXCITATION Field
MCdicom Structure See Also Send Feedback
Multi-planar Excitation (0018,9012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_PLANAR_EXCITATION
Visual Basic
Public Const MULTI_PLANAR_EXCITATION As UInteger
Visual C++
public:
literal unsigned int MULTI_PLANAR_EXCITATION

See Also

MCdicom Structure
MCdicom Members


MULTI_PLANAR_RECONSTRUCTION_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTI_PLANAR_RECONSTRUCTION_STYLE Field
MCdicom Structure See Also Send Feedback
Multi-Planar Reconstruction Style (0070,1501)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTI_PLANAR_RECONSTRUCTION_STYLE
Visual Basic
Public Const MULTI_PLANAR_RECONSTRUCTION_STYLE As UInteger
Visual C++
public:
literal unsigned int MULTI_PLANAR_RECONSTRUCTION_STYLE

See Also

MCdicom Structure
MCdicom Members


MULTIPLE_COPIES_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLE_COPIES_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Multiple Copies Flag RETIRED (0040,4006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLE_COPIES_FLAG_RETIRED
Visual Basic
Public Const MULTIPLE_COPIES_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int MULTIPLE_COPIES_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


MULTIPLE_SPIN_ECHO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLE_SPIN_ECHO Field
MCdicom Structure See Also Send Feedback
Multiple Spin Echo (0018,9011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLE_SPIN_ECHO
Visual Basic
Public Const MULTIPLE_SPIN_ECHO As UInteger
Visual C++
public:
literal unsigned int MULTIPLE_SPIN_ECHO

See Also

MCdicom Structure
MCdicom Members


MULTIPLEX_GROUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLEX_GROUP_LABEL Field
MCdicom Structure See Also Send Feedback
Multiplex Group Label (003A,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLEX_GROUP_LABEL
Visual Basic
Public Const MULTIPLEX_GROUP_LABEL As UInteger
Visual C++
public:
literal unsigned int MULTIPLEX_GROUP_LABEL

See Also

MCdicom Structure
MCdicom Members


MULTIPLEX_GROUP_TIME_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLEX_GROUP_TIME_OFFSET Field
MCdicom Structure See Also Send Feedback
Multiplex Group Time Offset (0018,1068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLEX_GROUP_TIME_OFFSET
Visual Basic
Public Const MULTIPLEX_GROUP_TIME_OFFSET As UInteger
Visual C++
public:
literal unsigned int MULTIPLEX_GROUP_TIME_OFFSET

See Also

MCdicom Structure
MCdicom Members


MULTIPLEX_GROUP_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLEX_GROUP_UID Field
MCdicom Structure See Also Send Feedback
Multiplex Group UID (003A,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLEX_GROUP_UID
Visual Basic
Public Const MULTIPLEX_GROUP_UID As UInteger
Visual C++
public:
literal unsigned int MULTIPLEX_GROUP_UID

See Also

MCdicom Structure
MCdicom Members


MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Multiplexed Audio Channels Description Code Sequence (003A,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE
Visual Basic
Public Const MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MULTIPLEXED_AUDIO_CHANNELS_DESCRIPTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
MV Imaging Generation Parameters Sequence (3002,0128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE
Visual Basic
Public Const MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MV_IMAGING_GENERATION_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MYDRIATIC_AGENT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MYDRIATIC_AGENT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mydriatic Agent Code Sequence (0022,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MYDRIATIC_AGENT_CODE_SEQUENCE
Visual Basic
Public Const MYDRIATIC_AGENT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MYDRIATIC_AGENT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MYDRIATIC_AGENT_CONCENTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MYDRIATIC_AGENT_CONCENTRATION Field
MCdicom Structure See Also Send Feedback
Mydriatic Agent Concentration (0022,004E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MYDRIATIC_AGENT_CONCENTRATION
Visual Basic
Public Const MYDRIATIC_AGENT_CONCENTRATION As UInteger
Visual C++
public:
literal unsigned int MYDRIATIC_AGENT_CONCENTRATION

See Also

MCdicom Structure
MCdicom Members


MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mydriatic Agent Concentration Units Sequence (0022,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE
Visual Basic
Public Const MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MYDRIATIC_AGENT_CONCENTRATION_UNITS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


MYDRIATIC_AGENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..MYDRIATIC_AGENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Mydriatic Agent Sequence (0022,0058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint MYDRIATIC_AGENT_SEQUENCE
Visual Basic
Public Const MYDRIATIC_AGENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int MYDRIATIC_AGENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NAME_OF_PHYSICIANS_READING_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NAME_OF_PHYSICIANS_READING_STUDY Field
MCdicom Structure See Also Send Feedback
Name of Physician(s) Reading Study (0008,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NAME_OF_PHYSICIANS_READING_STUDY
Visual Basic
Public Const NAME_OF_PHYSICIANS_READING_STUDY As UInteger
Visual C++
public:
literal unsigned int NAME_OF_PHYSICIANS_READING_STUDY

See Also

MCdicom Structure
MCdicom Members


NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS Field
MCdicom Structure See Also Send Feedback
Names of Intended Recipients of Results (0040,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS
Visual Basic
Public Const NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS As UInteger
Visual C++
public:
literal unsigned int NAMES_OF_INTENDED_RECIPIENTS_OF_RESULTS

See Also

MCdicom Structure
MCdicom Members


NAVIGATION_DISPLAY_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NAVIGATION_DISPLAY_SET Field
MCdicom Structure See Also Send Feedback
Navigation Display Set (0072,0216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NAVIGATION_DISPLAY_SET
Visual Basic
Public Const NAVIGATION_DISPLAY_SET As UInteger
Visual C++
public:
literal unsigned int NAVIGATION_DISPLAY_SET

See Also

MCdicom Structure
MCdicom Members


NAVIGATION_INDICATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NAVIGATION_INDICATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Navigation Indicator Sequence (0072,0214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NAVIGATION_INDICATOR_SEQUENCE
Visual Basic
Public Const NAVIGATION_INDICATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NAVIGATION_INDICATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NEAR_PUPILLARY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NEAR_PUPILLARY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Near Pupillary Distance (0046,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NEAR_PUPILLARY_DISTANCE
Visual Basic
Public Const NEAR_PUPILLARY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int NEAR_PUPILLARY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


NEGATIVE_CATCH_TRIALS_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NEGATIVE_CATCH_TRIALS_QUANTITY Field
MCdicom Structure See Also Send Feedback
Negative Catch Trials Quantity (0024,0048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NEGATIVE_CATCH_TRIALS_QUANTITY
Visual Basic
Public Const NEGATIVE_CATCH_TRIALS_QUANTITY As UInteger
Visual C++
public:
literal unsigned int NEGATIVE_CATCH_TRIALS_QUANTITY

See Also

MCdicom Structure
MCdicom Members


NETWORK_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NETWORK_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Network ID RETIRED (0008,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NETWORK_ID_RETIRED
Visual Basic
Public Const NETWORK_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int NETWORK_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


NOMINAL_BEAM_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_BEAM_ENERGY Field
MCdicom Structure See Also Send Feedback
Nominal Beam Energy (300A,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_BEAM_ENERGY
Visual Basic
Public Const NOMINAL_BEAM_ENERGY As UInteger
Visual C++
public:
literal unsigned int NOMINAL_BEAM_ENERGY

See Also

MCdicom Structure
MCdicom Members


NOMINAL_BEAM_ENERGY_UNIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_BEAM_ENERGY_UNIT Field
MCdicom Structure See Also Send Feedback
Nominal Beam Energy Unit (300A,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_BEAM_ENERGY_UNIT
Visual Basic
Public Const NOMINAL_BEAM_ENERGY_UNIT As UInteger
Visual C++
public:
literal unsigned int NOMINAL_BEAM_ENERGY_UNIT

See Also

MCdicom Structure
MCdicom Members


NOMINAL_CARDIAC_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_CARDIAC_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Nominal Cardiac Trigger Delay Time (0020,9153)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_CARDIAC_TRIGGER_DELAY_TIME
Visual Basic
Public Const NOMINAL_CARDIAC_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int NOMINAL_CARDIAC_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK Field
MCdicom Structure See Also Send Feedback
Nominal Cardiac Trigger Time Prior To R-Peak (0020,9154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK
Visual Basic
Public Const NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK As UInteger
Visual C++
public:
literal unsigned int NOMINAL_CARDIAC_TRIGGER_TIME_PRIOR_TO_R_PEAK

See Also

MCdicom Structure
MCdicom Members


NOMINAL_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_ENERGY Field
MCdicom Structure See Also Send Feedback
Nominal Energy (300A,0680)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_ENERGY
Visual Basic
Public Const NOMINAL_ENERGY As UInteger
Visual C++
public:
literal unsigned int NOMINAL_ENERGY

See Also

MCdicom Structure
MCdicom Members


NOMINAL_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Nominal Frequency (0014,401A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_FREQUENCY
Visual Basic
Public Const NOMINAL_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int NOMINAL_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


NOMINAL_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_INTERVAL Field
MCdicom Structure See Also Send Feedback
Nominal Interval (0018,1062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_INTERVAL
Visual Basic
Public Const NOMINAL_INTERVAL As UInteger
Visual C++
public:
literal unsigned int NOMINAL_INTERVAL

See Also

MCdicom Structure
MCdicom Members


NOMINAL_MAX_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_MAX_ENERGY Field
MCdicom Structure See Also Send Feedback
Nominal Max Energy (0018,9374)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_MAX_ENERGY
Visual Basic
Public Const NOMINAL_MAX_ENERGY As UInteger
Visual C++
public:
literal unsigned int NOMINAL_MAX_ENERGY

See Also

MCdicom Structure
MCdicom Members


NOMINAL_MIN_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_MIN_ENERGY Field
MCdicom Structure See Also Send Feedback
Nominal Min Energy (0018,9375)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_MIN_ENERGY
Visual Basic
Public Const NOMINAL_MIN_ENERGY As UInteger
Visual C++
public:
literal unsigned int NOMINAL_MIN_ENERGY

See Also

MCdicom Structure
MCdicom Members


NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE Field
MCdicom Structure See Also Send Feedback
Nominal Percentage of Cardiac Phase (0020,9241)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE
Visual Basic
Public Const NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE As UInteger
Visual C++
public:
literal unsigned int NOMINAL_PERCENTAGE_OF_CARDIAC_PHASE

See Also

MCdicom Structure
MCdicom Members


NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE Field
MCdicom Structure See Also Send Feedback
Nominal Percentage of Respiratory Phase (0020,9245)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE
Visual Basic
Public Const NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE As UInteger
Visual C++
public:
literal unsigned int NOMINAL_PERCENTAGE_OF_RESPIRATORY_PHASE

See Also

MCdicom Structure
MCdicom Members


NOMINAL_PRIOR_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_PRIOR_DOSE Field
MCdicom Structure See Also Send Feedback
Nominal Prior Dose (300A,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_PRIOR_DOSE
Visual Basic
Public Const NOMINAL_PRIOR_DOSE As UInteger
Visual C++
public:
literal unsigned int NOMINAL_PRIOR_DOSE

See Also

MCdicom Structure
MCdicom Members


NOMINAL_RANGE_MODULATED_REGION_DEPTHS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_RANGE_MODULATED_REGION_DEPTHS Field
MCdicom Structure See Also Send Feedback
Nominal Range Modulated Region Depths (300A,0504)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_RANGE_MODULATED_REGION_DEPTHS
Visual Basic
Public Const NOMINAL_RANGE_MODULATED_REGION_DEPTHS As UInteger
Visual C++
public:
literal unsigned int NOMINAL_RANGE_MODULATED_REGION_DEPTHS

See Also

MCdicom Structure
MCdicom Members


NOMINAL_RANGE_MODULATION_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_RANGE_MODULATION_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Nominal Range Modulation Fractions (300A,0503)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_RANGE_MODULATION_FRACTIONS
Visual Basic
Public Const NOMINAL_RANGE_MODULATION_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int NOMINAL_RANGE_MODULATION_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Nominal Respiratory Trigger Delay Time (0020,9255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME
Visual Basic
Public Const NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


NOMINAL_SCANNED_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_SCANNED_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Nominal Scanned Pixel Spacing (0018,2010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_SCANNED_PIXEL_SPACING
Visual Basic
Public Const NOMINAL_SCANNED_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int NOMINAL_SCANNED_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


NOMINAL_SCREEN_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOMINAL_SCREEN_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Nominal Screen Definition Sequence (0072,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOMINAL_SCREEN_DEFINITION_SEQUENCE
Visual Basic
Public Const NOMINAL_SCREEN_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NOMINAL_SCREEN_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Non-DICOM Output Code Sequence RETIRED (0040,4032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int NON_DICOM_OUTPUT_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


NON_UNIFORM_RADIAL_SAMPLING_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NON_UNIFORM_RADIAL_SAMPLING_CORRECTED Field
MCdicom Structure See Also Send Feedback
Non-uniform Radial Sampling Corrected (0018,9766)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NON_UNIFORM_RADIAL_SAMPLING_CORRECTED
Visual Basic
Public Const NON_UNIFORM_RADIAL_SAMPLING_CORRECTED As UInteger
Visual C++
public:
literal unsigned int NON_UNIFORM_RADIAL_SAMPLING_CORRECTED

See Also

MCdicom Structure
MCdicom Members


NONCONFORMING_DATA_ELEMENT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NONCONFORMING_DATA_ELEMENT_VALUE Field
MCdicom Structure See Also Send Feedback
Nonconforming Data Element Value (0400,0552)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NONCONFORMING_DATA_ELEMENT_VALUE
Visual Basic
Public Const NONCONFORMING_DATA_ELEMENT_VALUE As UInteger
Visual C++
public:
literal unsigned int NONCONFORMING_DATA_ELEMENT_VALUE

See Also

MCdicom Structure
MCdicom Members


NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Nonconforming Modified Attributes Sequence (0400,0551)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NONCONFORMING_MODIFIED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NONIDENTIFYING_PRIVATE_ELEMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NONIDENTIFYING_PRIVATE_ELEMENTS Field
MCdicom Structure See Also Send Feedback
Nonidentifying Private Elements (0008,0304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NONIDENTIFYING_PRIVATE_ELEMENTS
Visual Basic
Public Const NONIDENTIFYING_PRIVATE_ELEMENTS As UInteger
Visual C++
public:
literal unsigned int NONIDENTIFYING_PRIVATE_ELEMENTS

See Also

MCdicom Structure
MCdicom Members


NORMAL_REVERSE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NORMAL_REVERSE_RETIRED Field
MCdicom Structure See Also Send Feedback
Normal/Reverse RETIRED (0000,5140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NORMAL_REVERSE_RETIRED
Visual Basic
Public Const NORMAL_REVERSE_RETIRED As UInteger
Visual C++
public:
literal unsigned int NORMAL_REVERSE_RETIRED

See Also

MCdicom Structure
MCdicom Members


NORMALIZATION_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NORMALIZATION_POINT Field
MCdicom Structure See Also Send Feedback
Normalization Point (3004,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NORMALIZATION_POINT
Visual Basic
Public Const NORMALIZATION_POINT As UInteger
Visual C++
public:
literal unsigned int NORMALIZATION_POINT

See Also

MCdicom Structure
MCdicom Members


NOTCH_FILTER_BANDWIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOTCH_FILTER_BANDWIDTH Field
MCdicom Structure See Also Send Feedback
Notch Filter Bandwidth (003A,0223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOTCH_FILTER_BANDWIDTH
Visual Basic
Public Const NOTCH_FILTER_BANDWIDTH As UInteger
Visual C++
public:
literal unsigned int NOTCH_FILTER_BANDWIDTH

See Also

MCdicom Structure
MCdicom Members


NOTCH_FILTER_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOTCH_FILTER_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Notch Filter Characteristics Sequence (003A,0321)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOTCH_FILTER_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const NOTCH_FILTER_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NOTCH_FILTER_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NOTCH_FILTER_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOTCH_FILTER_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Notch Filter Frequency (003A,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOTCH_FILTER_FREQUENCY
Visual Basic
Public Const NOTCH_FILTER_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int NOTCH_FILTER_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


NOTIFICATION_FROM_MANUFACTURER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NOTIFICATION_FROM_MANUFACTURER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Notification From Manufacturer Sequence (0068,6265)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NOTIFICATION_FROM_MANUFACTURER_SEQUENCE
Visual Basic
Public Const NOTIFICATION_FROM_MANUFACTURER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NOTIFICATION_FROM_MANUFACTURER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


NTP_SOURCE_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NTP_SOURCE_ADDRESS Field
MCdicom Structure See Also Send Feedback
NTP Source Address (0018,1803)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NTP_SOURCE_ADDRESS
Visual Basic
Public Const NTP_SOURCE_ADDRESS As UInteger
Visual C++
public:
literal unsigned int NTP_SOURCE_ADDRESS

See Also

MCdicom Structure
MCdicom Members


NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Nuclear Medicine Series Type RETIRED (0008,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED
Visual Basic
Public Const NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUCLEAR_MEDICINE_SERIES_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ACQUISITION_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ACQUISITION_DEVICES Field
MCdicom Structure See Also Send Feedback
Number of Acquisition Devices (3002,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ACQUISITION_DEVICES
Visual Basic
Public Const NUMBER_OF_ACQUISITION_DEVICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ACQUISITION_DEVICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ALARM_OBJECTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ALARM_OBJECTS Field
MCdicom Structure See Also Send Feedback
Number of Alarm Objects (4010,1034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ALARM_OBJECTS
Visual Basic
Public Const NUMBER_OF_ALARM_OBJECTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ALARM_OBJECTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ANNOTATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ANNOTATIONS Field
MCdicom Structure See Also Send Feedback
Number of Annotations (006A,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ANNOTATIONS
Visual Basic
Public Const NUMBER_OF_ANNOTATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ANNOTATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ASSESSMENT_OBSERVATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ASSESSMENT_OBSERVATIONS Field
MCdicom Structure See Also Send Feedback
Number of Assessment Observations (0082,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ASSESSMENT_OBSERVATIONS
Visual Basic
Public Const NUMBER_OF_ASSESSMENT_OBSERVATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ASSESSMENT_OBSERVATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_AVERAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_AVERAGES Field
MCdicom Structure See Also Send Feedback
Number of Averages (0018,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_AVERAGES
Visual Basic
Public Const NUMBER_OF_AVERAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_AVERAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_B_SCANS_PER_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_B_SCANS_PER_FRAME Field
MCdicom Structure See Also Send Feedback
Number of B-scans Per Frame (0022,1642)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_B_SCANS_PER_FRAME
Visual Basic
Public Const NUMBER_OF_B_SCANS_PER_FRAME As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_B_SCANS_PER_FRAME

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BEAMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BEAMS Field
MCdicom Structure See Also Send Feedback
Number of Beams (300A,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BEAMS
Visual Basic
Public Const NUMBER_OF_BEAMS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BEAMS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BLOCK_SLAB_ITEMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BLOCK_SLAB_ITEMS Field
MCdicom Structure See Also Send Feedback
Number of Block Slab Items (300A,0440)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BLOCK_SLAB_ITEMS
Visual Basic
Public Const NUMBER_OF_BLOCK_SLAB_ITEMS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BLOCK_SLAB_ITEMS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BLOCKS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BLOCKS Field
MCdicom Structure See Also Send Feedback
Number of Blocks (300A,00F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BLOCKS
Visual Basic
Public Const NUMBER_OF_BLOCKS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BLOCKS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BOLI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BOLI Field
MCdicom Structure See Also Send Feedback
Number of Boli (300A,00ED)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BOLI
Visual Basic
Public Const NUMBER_OF_BOLI As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BOLI

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BOLUSES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BOLUSES Field
MCdicom Structure See Also Send Feedback
Number of Boluses (300A,0674)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BOLUSES
Visual Basic
Public Const NUMBER_OF_BOLUSES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BOLUSES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_BRACHY_APPLICATION_SETUPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_BRACHY_APPLICATION_SETUPS Field
MCdicom Structure See Also Send Feedback
Number of Brachy Application Setups (300A,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_BRACHY_APPLICATION_SETUPS
Visual Basic
Public Const NUMBER_OF_BRACHY_APPLICATION_SETUPS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_BRACHY_APPLICATION_SETUPS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_CHANNELS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_CHANNELS_RETIRED Field
MCdicom Structure See Also Send Feedback
Number of Channels RETIRED (5000,2004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_CHANNELS_RETIRED
Visual Basic
Public Const NUMBER_OF_CHANNELS_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_CHANNELS_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_COMPENSATORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_COMPENSATORS Field
MCdicom Structure See Also Send Feedback
Number of Compensators (300A,00E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_COMPENSATORS
Visual Basic
Public Const NUMBER_OF_COMPENSATORS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_COMPENSATORS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_COMPLETED_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_COMPLETED_SUB_OPERATIONS Field
MCdicom Structure See Also Send Feedback
Number of Completed Sub-operations (0000,1021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_COMPLETED_SUB_OPERATIONS
Visual Basic
Public Const NUMBER_OF_COMPLETED_SUB_OPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_COMPLETED_SUB_OPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_COMPLETED_SUBOPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_COMPLETED_SUBOPERATIONS Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_COMPLETED_SUB_OPERATIONS (0000,1021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_COMPLETED_SUBOPERATIONS
Visual Basic
Public Const NUMBER_OF_COMPLETED_SUBOPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_COMPLETED_SUBOPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_CONTOUR_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_CONTOUR_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Contour Points (3006,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_CONTOUR_POINTS
Visual Basic
Public Const NUMBER_OF_CONTOUR_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_CONTOUR_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_CONTROL_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_CONTROL_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Control Points (300A,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_CONTROL_POINTS
Visual Basic
Public Const NUMBER_OF_CONTROL_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_CONTROL_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_COPIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_COPIES Field
MCdicom Structure See Also Send Feedback
Number of Copies (2000,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_COPIES
Visual Basic
Public Const NUMBER_OF_COPIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_COPIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_DETECTORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_DETECTORS Field
MCdicom Structure See Also Send Feedback
Number of Detectors (0054,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_DETECTORS
Visual Basic
Public Const NUMBER_OF_DETECTORS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_DETECTORS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_DISPLAY_SUBSYSTEMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_DISPLAY_SUBSYSTEMS Field
MCdicom Structure See Also Send Feedback
Number of Display Subsystems (0028,7001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_DISPLAY_SUBSYSTEMS
Visual Basic
Public Const NUMBER_OF_DISPLAY_SUBSYSTEMS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_DISPLAY_SUBSYSTEMS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ELEMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ELEMENTS Field
MCdicom Structure See Also Send Feedback
Number of Elements (0014,4012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ELEMENTS
Visual Basic
Public Const NUMBER_OF_ELEMENTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ELEMENTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ENERGY_WINDOWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ENERGY_WINDOWS Field
MCdicom Structure See Also Send Feedback
Number of Energy Windows (0054,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ENERGY_WINDOWS
Visual Basic
Public Const NUMBER_OF_ENERGY_WINDOWS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ENERGY_WINDOWS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_EVENT_TIMERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_EVENT_TIMERS Field
MCdicom Structure See Also Send Feedback
Number of Event Timers (0008,2129)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_EVENT_TIMERS
Visual Basic
Public Const NUMBER_OF_EVENT_TIMERS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_EVENT_TIMERS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FAILED_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FAILED_SUB_OPERATIONS Field
MCdicom Structure See Also Send Feedback
Number of Failed Sub-operations (0000,1022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FAILED_SUB_OPERATIONS
Visual Basic
Public Const NUMBER_OF_FAILED_SUB_OPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FAILED_SUB_OPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FAILED_SUBOPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FAILED_SUBOPERATIONS Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_FAILED_SUB_OPERATIONS (0000,1022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FAILED_SUBOPERATIONS
Visual Basic
Public Const NUMBER_OF_FAILED_SUBOPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FAILED_SUBOPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FILMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FILMS Field
MCdicom Structure See Also Send Feedback
Number of Films (2100,0170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FILMS
Visual Basic
Public Const NUMBER_OF_FILMS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FILMS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FOCAL_PLANES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FOCAL_PLANES Field
MCdicom Structure See Also Send Feedback
Number of Focal Planes (0048,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FOCAL_PLANES
Visual Basic
Public Const NUMBER_OF_FOCAL_PLANES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FOCAL_PLANES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY Field
MCdicom Structure See Also Send Feedback
Number of Fraction Pattern Digits Per Day (300A,0079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY
Visual Basic
Public Const NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Number of Fractions (3010,007D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTIONS
Visual Basic
Public Const NUMBER_OF_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTIONS_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTIONS_DELIVERED Field
MCdicom Structure See Also Send Feedback
Number of Fractions Delivered (3008,005A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTIONS_DELIVERED
Visual Basic
Public Const NUMBER_OF_FRACTIONS_DELIVERED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTIONS_DELIVERED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTIONS_INCLUDED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTIONS_INCLUDED Field
MCdicom Structure See Also Send Feedback
Number of Fractions Included (300C,0119)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTIONS_INCLUDED
Visual Basic
Public Const NUMBER_OF_FRACTIONS_INCLUDED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTIONS_INCLUDED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTIONS_PER_DAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTIONS_PER_DAY Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_FRACTION_PATTERN_DIGITS_PER_DAY (300A,0079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTIONS_PER_DAY
Visual Basic
Public Const NUMBER_OF_FRACTIONS_PER_DAY As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTIONS_PER_DAY

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRACTIONS_PLANNED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRACTIONS_PLANNED Field
MCdicom Structure See Also Send Feedback
Number of Fractions Planned (300A,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRACTIONS_PLANNED
Visual Basic
Public Const NUMBER_OF_FRACTIONS_PLANNED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRACTIONS_PLANNED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES Field
MCdicom Structure See Also Send Feedback
Number of Frames (0028,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES
Visual Basic
Public Const NUMBER_OF_FRAMES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES_IN_OVERLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES_IN_OVERLAY Field
MCdicom Structure See Also Send Feedback
Number of Frames in Overlay (6000,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES_IN_OVERLAY
Visual Basic
Public Const NUMBER_OF_FRAMES_IN_OVERLAY As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES_IN_OVERLAY

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES_IN_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES_IN_PHASE Field
MCdicom Structure See Also Send Feedback
Number of Frames in Phase (0054,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES_IN_PHASE
Visual Basic
Public Const NUMBER_OF_FRAMES_IN_PHASE As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES_IN_PHASE

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES_IN_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES_IN_ROTATION Field
MCdicom Structure See Also Send Feedback
Number of Frames in Rotation (0054,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES_IN_ROTATION
Visual Basic
Public Const NUMBER_OF_FRAMES_IN_ROTATION As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES_IN_ROTATION

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES_INTEGRATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES_INTEGRATED Field
MCdicom Structure See Also Send Feedback
Number of Frames Integrated (0014,3012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES_INTEGRATED
Visual Basic
Public Const NUMBER_OF_FRAMES_INTEGRATED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES_INTEGRATED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_FRAMES_USED_FOR_INTEGRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_FRAMES_USED_FOR_INTEGRATION Field
MCdicom Structure See Also Send Feedback
Number of Frames Used for Integration (0014,3073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_FRAMES_USED_FOR_INTEGRATION
Visual Basic
Public Const NUMBER_OF_FRAMES_USED_FOR_INTEGRATION As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_FRAMES_USED_FOR_INTEGRATION

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_GENERAL_ACCESSORIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_GENERAL_ACCESSORIES Field
MCdicom Structure See Also Send Feedback
Number of General Accessories (300A,0672)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_GENERAL_ACCESSORIES
Visual Basic
Public Const NUMBER_OF_GENERAL_ACCESSORIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_GENERAL_ACCESSORIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_GRAPHIC_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_GRAPHIC_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Graphic Points (0070,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_GRAPHIC_POINTS
Visual Basic
Public Const NUMBER_OF_GRAPHIC_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_GRAPHIC_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_HORIZONTAL_PIXELS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_HORIZONTAL_PIXELS Field
MCdicom Structure See Also Send Feedback
Number of Horizontal Pixels (0072,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_HORIZONTAL_PIXELS
Visual Basic
Public Const NUMBER_OF_HORIZONTAL_PIXELS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_HORIZONTAL_PIXELS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_INTERVAL_FRACTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_INTERVAL_FRACTIONS Field
MCdicom Structure See Also Send Feedback
Number of Interval Fractions (3010,007C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_INTERVAL_FRACTIONS
Visual Basic
Public Const NUMBER_OF_INTERVAL_FRACTIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_INTERVAL_FRACTIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ITERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ITERATIONS Field
MCdicom Structure See Also Send Feedback
Number of Iterations (0018,9739)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ITERATIONS
Visual Basic
Public Const NUMBER_OF_ITERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ITERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_K_SPACE_TRAJECTORIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_K_SPACE_TRAJECTORIES Field
MCdicom Structure See Also Send Feedback
Number of k-Space Trajectories (0018,9093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_K_SPACE_TRAJECTORIES
Visual Basic
Public Const NUMBER_OF_K_SPACE_TRAJECTORIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_K_SPACE_TRAJECTORIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_LATERAL_SPREADING_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_LATERAL_SPREADING_DEVICES Field
MCdicom Structure See Also Send Feedback
Number of Lateral Spreading Devices (300A,0330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_LATERAL_SPREADING_DEVICES
Visual Basic
Public Const NUMBER_OF_LATERAL_SPREADING_DEVICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_LATERAL_SPREADING_DEVICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_LEAF_JAW_PAIRS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_LEAF_JAW_PAIRS Field
MCdicom Structure See Also Send Feedback
Number of Leaf/Jaw Pairs (300A,00BC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_LEAF_JAW_PAIRS
Visual Basic
Public Const NUMBER_OF_LEAF_JAW_PAIRS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_LEAF_JAW_PAIRS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_LUMINANCE_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_LUMINANCE_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Luminance Points (0028,701B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_LUMINANCE_POINTS
Visual Basic
Public Const NUMBER_OF_LUMINANCE_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_LUMINANCE_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_MAP_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_MAP_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Map Points (0022,1530)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_MAP_POINTS
Visual Basic
Public Const NUMBER_OF_MAP_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_MAP_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_MATCHES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_MATCHES_RETIRED Field
MCdicom Structure See Also Send Feedback
Number of Matches RETIRED (0000,0850)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_MATCHES_RETIRED
Visual Basic
Public Const NUMBER_OF_MATCHES_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_MATCHES_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_OPTICAL_PATHS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_OPTICAL_PATHS Field
MCdicom Structure See Also Send Feedback
Number of Optical Paths (0048,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_OPTICAL_PATHS
Visual Basic
Public Const NUMBER_OF_OPTICAL_PATHS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_OPTICAL_PATHS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PADDED_A_LINES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PADDED_A_LINES Field
MCdicom Structure See Also Send Feedback
Number of Padded A-lines (0052,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PADDED_A_LINES
Visual Basic
Public Const NUMBER_OF_PADDED_A_LINES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PADDED_A_LINES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PAINTINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PAINTINGS Field
MCdicom Structure See Also Send Feedback
Number of Paintings (300A,039A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PAINTINGS
Visual Basic
Public Const NUMBER_OF_PAINTINGS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PAINTINGS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS Field
MCdicom Structure See Also Send Feedback
Number of Parallel RT Beam Delimiters (300A,0648)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS
Visual Basic
Public Const NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PARALLEL_RT_BEAM_DELIMITERS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PATIENT_RELATED_IMAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PATIENT_RELATED_IMAGES Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_PATIENT_RELATED_INSTANCES (0020,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PATIENT_RELATED_IMAGES
Visual Basic
Public Const NUMBER_OF_PATIENT_RELATED_IMAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PATIENT_RELATED_IMAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PATIENT_RELATED_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PATIENT_RELATED_INSTANCES Field
MCdicom Structure See Also Send Feedback
Number of Patient Related Instances (0020,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PATIENT_RELATED_INSTANCES
Visual Basic
Public Const NUMBER_OF_PATIENT_RELATED_INSTANCES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PATIENT_RELATED_INSTANCES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PATIENT_RELATED_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PATIENT_RELATED_SERIES Field
MCdicom Structure See Also Send Feedback
Number of Patient Related Series (0020,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PATIENT_RELATED_SERIES
Visual Basic
Public Const NUMBER_OF_PATIENT_RELATED_SERIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PATIENT_RELATED_SERIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PATIENT_RELATED_STUDIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PATIENT_RELATED_STUDIES Field
MCdicom Structure See Also Send Feedback
Number of Patient Related Studies (0020,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PATIENT_RELATED_STUDIES
Visual Basic
Public Const NUMBER_OF_PATIENT_RELATED_STUDIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PATIENT_RELATED_STUDIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PATIENT_SUPPORT_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PATIENT_SUPPORT_DEVICES Field
MCdicom Structure See Also Send Feedback
Number of Patient Support Devices (300A,0687)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PATIENT_SUPPORT_DEVICES
Visual Basic
Public Const NUMBER_OF_PATIENT_SUPPORT_DEVICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PATIENT_SUPPORT_DEVICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PHASE_ENCODING_STEPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PHASE_ENCODING_STEPS Field
MCdicom Structure See Also Send Feedback
Number of Phase Encoding Steps (0018,0089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PHASE_ENCODING_STEPS
Visual Basic
Public Const NUMBER_OF_PHASE_ENCODING_STEPS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PHASE_ENCODING_STEPS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PHASES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PHASES Field
MCdicom Structure See Also Send Feedback
Number of Phases (0054,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PHASES
Visual Basic
Public Const NUMBER_OF_PHASES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PHASES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_POINTS Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_SURFACE_POINTS (0066,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_POINTS
Visual Basic
Public Const NUMBER_OF_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_POINTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_POINTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Number of Points RETIRED (5000,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_POINTS_RETIRED
Visual Basic
Public Const NUMBER_OF_POINTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_POINTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_POLYGONAL_VERTICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_POLYGONAL_VERTICES Field
MCdicom Structure See Also Send Feedback
Number of Polygonal Vertices (0018,1637)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_POLYGONAL_VERTICES
Visual Basic
Public Const NUMBER_OF_POLYGONAL_VERTICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_POLYGONAL_VERTICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PRIORS_REFERENCED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PRIORS_REFERENCED Field
MCdicom Structure See Also Send Feedback
Number of Priors Referenced (0072,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PRIORS_REFERENCED
Visual Basic
Public Const NUMBER_OF_PRIORS_REFERENCED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PRIORS_REFERENCED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_PULSES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_PULSES Field
MCdicom Structure See Also Send Feedback
Number of Pulses (300A,028A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_PULSES
Visual Basic
Public Const NUMBER_OF_PULSES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_PULSES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_R_R_INTERVALS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_R_R_INTERVALS Field
MCdicom Structure See Also Send Feedback
Number of R-R Intervals (0054,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_R_R_INTERVALS
Visual Basic
Public Const NUMBER_OF_R_R_INTERVALS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_R_R_INTERVALS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RADIATION_GENERATION_MODES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RADIATION_GENERATION_MODES Field
MCdicom Structure See Also Send Feedback
Number of Radiation Generation Modes (300A,0685)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RADIATION_GENERATION_MODES
Visual Basic
Public Const NUMBER_OF_RADIATION_GENERATION_MODES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RADIATION_GENERATION_MODES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RANGE_MODULATORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RANGE_MODULATORS Field
MCdicom Structure See Also Send Feedback
Number of Range Modulators (300A,0340)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RANGE_MODULATORS
Visual Basic
Public Const NUMBER_OF_RANGE_MODULATORS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RANGE_MODULATORS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RANGE_SHIFTERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RANGE_SHIFTERS Field
MCdicom Structure See Also Send Feedback
Number of Range Shifters (300A,0312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RANGE_SHIFTERS
Visual Basic
Public Const NUMBER_OF_RANGE_SHIFTERS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RANGE_SHIFTERS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_REFERENCES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_REFERENCES_RETIRED Field
MCdicom Structure See Also Send Feedback
Number of References RETIRED (0004,1600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_REFERENCES_RETIRED
Visual Basic
Public Const NUMBER_OF_REFERENCES_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_REFERENCES_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_REMAINING_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_REMAINING_SUB_OPERATIONS Field
MCdicom Structure See Also Send Feedback
Number of Remaining Sub-operations (0000,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_REMAINING_SUB_OPERATIONS
Visual Basic
Public Const NUMBER_OF_REMAINING_SUB_OPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_REMAINING_SUB_OPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_REMAINING_SUBOPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_REMAINING_SUBOPERATIONS Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_REMAINING_SUB_OPERATIONS (0000,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_REMAINING_SUBOPERATIONS
Visual Basic
Public Const NUMBER_OF_REMAINING_SUBOPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_REMAINING_SUBOPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ROTATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ROTATIONS Field
MCdicom Structure See Also Send Feedback
Number of Rotations (0054,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ROTATIONS
Visual Basic
Public Const NUMBER_OF_ROTATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ROTATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RT_ACCESSORY_HOLDERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RT_ACCESSORY_HOLDERS Field
MCdicom Structure See Also Send Feedback
Number of RT Accessory Holders (300A,0670)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RT_ACCESSORY_HOLDERS
Visual Basic
Public Const NUMBER_OF_RT_ACCESSORY_HOLDERS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RT_ACCESSORY_HOLDERS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS Field
MCdicom Structure See Also Send Feedback
Number of RT Beam Limiting Device Openings (300A,0657)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS
Visual Basic
Public Const NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RT_BEAM_LIMITING_DEVICE_OPENINGS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RT_BEAM_LIMITING_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RT_BEAM_LIMITING_DEVICES Field
MCdicom Structure See Also Send Feedback
Number of RT Beam Limiting Devices (300A,0641)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RT_BEAM_LIMITING_DEVICES
Visual Basic
Public Const NUMBER_OF_RT_BEAM_LIMITING_DEVICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RT_BEAM_LIMITING_DEVICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_RT_CONTROL_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_RT_CONTROL_POINTS Field
MCdicom Structure See Also Send Feedback
Number of RT Control Points (300A,0604)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_RT_CONTROL_POINTS
Visual Basic
Public Const NUMBER_OF_RT_CONTROL_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_RT_CONTROL_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SAMPLES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SAMPLES_RETIRED Field
MCdicom Structure See Also Send Feedback
Number of Samples RETIRED (5000,2006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SAMPLES_RETIRED
Visual Basic
Public Const NUMBER_OF_SAMPLES_RETIRED As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SAMPLES_RETIRED

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SCAN_SPOT_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SCAN_SPOT_POSITIONS Field
MCdicom Structure See Also Send Feedback
Number of Scan Spot Positions (300A,0392)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SCAN_SPOT_POSITIONS
Visual Basic
Public Const NUMBER_OF_SCAN_SPOT_POSITIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SCAN_SPOT_POSITIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SCREENS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SCREENS Field
MCdicom Structure See Also Send Feedback
Number of Screens (0072,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SCREENS
Visual Basic
Public Const NUMBER_OF_SCREENS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SCREENS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SERIES_RELATED_IMAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SERIES_RELATED_IMAGES Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_SERIES_RELATED_INSTANCES (0020,1209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SERIES_RELATED_IMAGES
Visual Basic
Public Const NUMBER_OF_SERIES_RELATED_IMAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SERIES_RELATED_IMAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SERIES_RELATED_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SERIES_RELATED_INSTANCES Field
MCdicom Structure See Also Send Feedback
Number of Series Related Instances (0020,1209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SERIES_RELATED_INSTANCES
Visual Basic
Public Const NUMBER_OF_SERIES_RELATED_INSTANCES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SERIES_RELATED_INSTANCES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SLICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SLICES Field
MCdicom Structure See Also Send Feedback
Number of Slices (0054,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SLICES
Visual Basic
Public Const NUMBER_OF_SLICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SLICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_STAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_STAGES Field
MCdicom Structure See Also Send Feedback
Number of Stages (0008,2124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_STAGES
Visual Basic
Public Const NUMBER_OF_STAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_STAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_STUDY_RECORDS_IN_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_STUDY_RECORDS_IN_INSTANCE Field
MCdicom Structure See Also Send Feedback
Number of Study Records in Instance (0008,0427)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_STUDY_RECORDS_IN_INSTANCE
Visual Basic
Public Const NUMBER_OF_STUDY_RECORDS_IN_INSTANCE As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_STUDY_RECORDS_IN_INSTANCE

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_STUDY_RELATED_IMAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_STUDY_RELATED_IMAGES Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_STUDY_RELATED_INSTANCES (0020,1208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_STUDY_RELATED_IMAGES
Visual Basic
Public Const NUMBER_OF_STUDY_RELATED_IMAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_STUDY_RELATED_IMAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_STUDY_RELATED_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_STUDY_RELATED_INSTANCES Field
MCdicom Structure See Also Send Feedback
Number of Study Related Instances (0020,1208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_STUDY_RELATED_INSTANCES
Visual Basic
Public Const NUMBER_OF_STUDY_RELATED_INSTANCES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_STUDY_RELATED_INSTANCES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_STUDY_RELATED_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_STUDY_RELATED_SERIES Field
MCdicom Structure See Also Send Feedback
Number of Study Related Series (0020,1206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_STUDY_RELATED_SERIES
Visual Basic
Public Const NUMBER_OF_STUDY_RELATED_SERIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_STUDY_RELATED_SERIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SUBSETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SUBSETS Field
MCdicom Structure See Also Send Feedback
Number of Subsets (0018,9740)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SUBSETS
Visual Basic
Public Const NUMBER_OF_SUBSETS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SUBSETS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SURFACE_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SURFACE_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Surface Points (0066,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SURFACE_POINTS
Visual Basic
Public Const NUMBER_OF_SURFACE_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SURFACE_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_SURFACES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_SURFACES Field
MCdicom Structure See Also Send Feedback
Number of Surfaces (0066,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_SURFACES
Visual Basic
Public Const NUMBER_OF_SURFACES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_SURFACES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TABLE_BREAK_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TABLE_BREAK_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Table Break Points (0018,6050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TABLE_BREAK_POINTS
Visual Basic
Public Const NUMBER_OF_TABLE_BREAK_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TABLE_BREAK_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TABLE_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TABLE_COLUMNS Field
MCdicom Structure See Also Send Feedback
Number of Table Columns (0040,A803)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TABLE_COLUMNS
Visual Basic
Public Const NUMBER_OF_TABLE_COLUMNS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TABLE_COLUMNS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TABLE_ENTRIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TABLE_ENTRIES Field
MCdicom Structure See Also Send Feedback
Number of Table Entries (0018,6056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TABLE_ENTRIES
Visual Basic
Public Const NUMBER_OF_TABLE_ENTRIES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TABLE_ENTRIES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TABLE_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TABLE_ROWS Field
MCdicom Structure See Also Send Feedback
Number of Table Rows (0040,A802)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TABLE_ROWS
Visual Basic
Public Const NUMBER_OF_TABLE_ROWS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TABLE_ROWS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TEMPORAL_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TEMPORAL_POSITIONS Field
MCdicom Structure See Also Send Feedback
Number of Temporal Positions (0020,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TEMPORAL_POSITIONS
Visual Basic
Public Const NUMBER_OF_TEMPORAL_POSITIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TEMPORAL_POSITIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TIME_SLICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TIME_SLICES Field
MCdicom Structure See Also Send Feedback
Number of Time Slices (0054,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TIME_SLICES
Visual Basic
Public Const NUMBER_OF_TIME_SLICES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TIME_SLICES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TIME_SLOTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TIME_SLOTS Field
MCdicom Structure See Also Send Feedback
Number of Time Slots (0054,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TIME_SLOTS
Visual Basic
Public Const NUMBER_OF_TIME_SLOTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TIME_SLOTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES Field
MCdicom Structure See Also Send Feedback
Number of Tomosynthesis Source Images (0018,1495)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES
Visual Basic
Public Const NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TOMOSYNTHESIS_SOURCE_IMAGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TOTAL_OBJECTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TOTAL_OBJECTS Field
MCdicom Structure See Also Send Feedback
Number of Total Objects (4010,1033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TOTAL_OBJECTS
Visual Basic
Public Const NUMBER_OF_TOTAL_OBJECTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TOTAL_OBJECTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_TRIGGERS_IN_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_TRIGGERS_IN_PHASE Field
MCdicom Structure See Also Send Feedback
Number of Triggers in Phase (0054,0211)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_TRIGGERS_IN_PHASE
Visual Basic
Public Const NUMBER_OF_TRIGGERS_IN_PHASE As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_TRIGGERS_IN_PHASE

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_VECTORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_VECTORS Field
MCdicom Structure See Also Send Feedback
Number of Vectors (0066,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_VECTORS
Visual Basic
Public Const NUMBER_OF_VECTORS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_VECTORS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_VERTICAL_PIXELS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_VERTICAL_PIXELS Field
MCdicom Structure See Also Send Feedback
Number of Vertical Pixels (0072,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_VERTICAL_PIXELS
Visual Basic
Public Const NUMBER_OF_VERTICAL_PIXELS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_VERTICAL_PIXELS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_VIEWS_IN_STAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_VIEWS_IN_STAGE Field
MCdicom Structure See Also Send Feedback
Number of Views in Stage (0008,212A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_VIEWS_IN_STAGE
Visual Basic
Public Const NUMBER_OF_VIEWS_IN_STAGE As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_VIEWS_IN_STAGE

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_VISUAL_STIMULI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_VISUAL_STIMULI Field
MCdicom Structure See Also Send Feedback
Number of Visual Stimuli (0024,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_VISUAL_STIMULI
Visual Basic
Public Const NUMBER_OF_VISUAL_STIMULI As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_VISUAL_STIMULI

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_VOLUMETRIC_CURVE_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_VOLUMETRIC_CURVE_POINTS Field
MCdicom Structure See Also Send Feedback
Number of Volumetric Curve Points (0070,150C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_VOLUMETRIC_CURVE_POINTS
Visual Basic
Public Const NUMBER_OF_VOLUMETRIC_CURVE_POINTS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_VOLUMETRIC_CURVE_POINTS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WARNING_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WARNING_SUB_OPERATIONS Field
MCdicom Structure See Also Send Feedback
Number of Warning Sub-operations (0000,1023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WARNING_SUB_OPERATIONS
Visual Basic
Public Const NUMBER_OF_WARNING_SUB_OPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WARNING_SUB_OPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WARNING_SUBOPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WARNING_SUBOPERATIONS Field
MCdicom Structure See Also Send Feedback
Alias for tag NUMBER_OF_WARNING_SUB_OPERATIONS (0000,1023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WARNING_SUBOPERATIONS
Visual Basic
Public Const NUMBER_OF_WARNING_SUBOPERATIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WARNING_SUBOPERATIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WAVEFORM_CHANNELS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WAVEFORM_CHANNELS Field
MCdicom Structure See Also Send Feedback
Number of Waveform Channels (003A,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WAVEFORM_CHANNELS
Visual Basic
Public Const NUMBER_OF_WAVEFORM_CHANNELS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WAVEFORM_CHANNELS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WAVEFORM_SAMPLES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WAVEFORM_SAMPLES Field
MCdicom Structure See Also Send Feedback
Number of Waveform Samples (003A,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WAVEFORM_SAMPLES
Visual Basic
Public Const NUMBER_OF_WAVEFORM_SAMPLES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WAVEFORM_SAMPLES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WEDGE_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WEDGE_POSITIONS Field
MCdicom Structure See Also Send Feedback
Number of Wedge Positions (300A,0655)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WEDGE_POSITIONS
Visual Basic
Public Const NUMBER_OF_WEDGE_POSITIONS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WEDGE_POSITIONS

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_WEDGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_WEDGES Field
MCdicom Structure See Also Send Feedback
Number of Wedges (300A,00D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_WEDGES
Visual Basic
Public Const NUMBER_OF_WEDGES As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_WEDGES

See Also

MCdicom Structure
MCdicom Members


NUMBER_OF_ZERO_FILLS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMBER_OF_ZERO_FILLS Field
MCdicom Structure See Also Send Feedback
Number of Zero Fills (0018,9066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMBER_OF_ZERO_FILLS
Visual Basic
Public Const NUMBER_OF_ZERO_FILLS As UInteger
Visual C++
public:
literal unsigned int NUMBER_OF_ZERO_FILLS

See Also

MCdicom Structure
MCdicom Members


NUMERIC_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMERIC_VALUE Field
MCdicom Structure See Also Send Feedback
Numeric Value (0040,A30A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMERIC_VALUE
Visual Basic
Public Const NUMERIC_VALUE As UInteger
Visual C++
public:
literal unsigned int NUMERIC_VALUE

See Also

MCdicom Structure
MCdicom Members


NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Numeric Value Qualifier Code Sequence (0040,A301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE
Visual Basic
Public Const NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int NUMERIC_VALUE_QUALIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Object Binary Identifier (Trial) RETIRED (0040,A074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED
Visual Basic
Public Const OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBJECT_BINARY_IDENTIFIER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Object Directory Binary Identifier (Trial) RETIRED (0040,A089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED
Visual Basic
Public Const OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBJECT_DIRECTORY_BINARY_IDENTIFIER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM Field
MCdicom Structure See Also Send Feedback
Object Pixel Spacing in Center of Beam (0018,9404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM
Visual Basic
Public Const OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM As UInteger
Visual C++
public:
literal unsigned int OBJECT_PIXEL_SPACING_IN_CENTER_OF_BEAM

See Also

MCdicom Structure
MCdicom Members


OBJECT_SOUND_SPEED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECT_SOUND_SPEED Field
MCdicom Structure See Also Send Feedback
Object Sound Speed (0018,9833)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECT_SOUND_SPEED
Visual Basic
Public Const OBJECT_SOUND_SPEED As UInteger
Visual C++
public:
literal unsigned int OBJECT_SOUND_SPEED

See Also

MCdicom Structure
MCdicom Members


OBJECT_THICKNESS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECT_THICKNESS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Object Thickness Sequence (0018,9456)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECT_THICKNESS_SEQUENCE
Visual Basic
Public Const OBJECT_THICKNESS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OBJECT_THICKNESS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OBJECTIVE_LENS_NUMERICAL_APERTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECTIVE_LENS_NUMERICAL_APERTURE Field
MCdicom Structure See Also Send Feedback
Objective Lens Numerical Aperture (0048,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECTIVE_LENS_NUMERICAL_APERTURE
Visual Basic
Public Const OBJECTIVE_LENS_NUMERICAL_APERTURE As UInteger
Visual C++
public:
literal unsigned int OBJECTIVE_LENS_NUMERICAL_APERTURE

See Also

MCdicom Structure
MCdicom Members


OBJECTIVE_LENS_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBJECTIVE_LENS_POWER Field
MCdicom Structure See Also Send Feedback
Objective Lens Power (0048,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBJECTIVE_LENS_POWER
Visual Basic
Public Const OBJECTIVE_LENS_POWER As UInteger
Visual C++
public:
literal unsigned int OBJECTIVE_LENS_POWER

See Also

MCdicom Structure
MCdicom Members


OBLIQUE_CROPPING_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBLIQUE_CROPPING_PLANE Field
MCdicom Structure See Also Send Feedback
Alias for tag PLANE (0070,1305)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBLIQUE_CROPPING_PLANE
Visual Basic
Public Const OBLIQUE_CROPPING_PLANE As UInteger
Visual C++
public:
literal unsigned int OBLIQUE_CROPPING_PLANE

See Also

MCdicom Structure
MCdicom Members


OBLIQUE_CROPPING_PLANE_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBLIQUE_CROPPING_PLANE_NORMAL Field
MCdicom Structure See Also Send Feedback
Alias for tag PLANE_NORMAL (0070,1306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBLIQUE_CROPPING_PLANE_NORMAL
Visual Basic
Public Const OBLIQUE_CROPPING_PLANE_NORMAL As UInteger
Visual C++
public:
literal unsigned int OBLIQUE_CROPPING_PLANE_NORMAL

See Also

MCdicom Structure
MCdicom Members


OBLIQUE_CROPPING_PLANE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBLIQUE_CROPPING_PLANE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Oblique Cropping Plane Sequence (0070,1304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBLIQUE_CROPPING_PLANE_SEQUENCE
Visual Basic
Public Const OBLIQUE_CROPPING_PLANE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OBLIQUE_CROPPING_PLANE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_BASIS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_BASIS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Observation Basis Code Sequence (0082,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_BASIS_CODE_SEQUENCE
Visual Basic
Public Const OBSERVATION_BASIS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_BASIS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Category Code Sequence (Trial) RETIRED (0040,A167)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_CATEGORY_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_DATE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_DATE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Date (Trial) RETIRED (0040,A192)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_DATE_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_DATE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_DATE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Observation DateTime (0040,A032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_DATETIME
Visual Basic
Public Const OBSERVATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Observation Description (0082,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_DESCRIPTION
Visual Basic
Public Const OBSERVATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_NUMBER Field
MCdicom Structure See Also Send Feedback
Observation Number (3006,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_NUMBER
Visual Basic
Public Const OBSERVATION_NUMBER As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_NUMBER

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_SIGNIFICANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_SIGNIFICANCE Field
MCdicom Structure See Also Send Feedback
Observation Significance (0082,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_SIGNIFICANCE
Visual Basic
Public Const OBSERVATION_SIGNIFICANCE As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_SIGNIFICANCE

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_START_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_START_DATETIME Field
MCdicom Structure See Also Send Feedback
Observation Start DateTime (0040,A033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_START_DATETIME
Visual Basic
Public Const OBSERVATION_START_DATETIME As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_START_DATETIME

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Subject Class (Trial) RETIRED (0040,A403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_SUBJECT_CLASS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Subject Context Flag (Trial) RETIRED (0040,A600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_SUBJECT_CONTEXT_FLAG_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Subject Type Code Sequence (Trial) RETIRED (0040,A404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_SUBJECT_TYPE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_SUBJECT_UID_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_SUBJECT_UID_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Subject UID (Trial) RETIRED (0040,A402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_SUBJECT_UID_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_SUBJECT_UID_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_SUBJECT_UID_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_TIME_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_TIME_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observation Time (Trial) RETIRED (0040,A193)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_TIME_TRIAL_RETIRED
Visual Basic
Public Const OBSERVATION_TIME_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_TIME_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVATION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATION_UID Field
MCdicom Structure See Also Send Feedback
Observation UID (0040,A171)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATION_UID
Visual Basic
Public Const OBSERVATION_UID As UInteger
Visual C++
public:
literal unsigned int OBSERVATION_UID

See Also

MCdicom Structure
MCdicom Members


OBSERVATIONS_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVATIONS_NUMBER Field
MCdicom Structure See Also Send Feedback
Alias for tag OBSERVATION_NUMBER (3006,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVATIONS_NUMBER
Visual Basic
Public Const OBSERVATIONS_NUMBER As UInteger
Visual C++
public:
literal unsigned int OBSERVATIONS_NUMBER

See Also

MCdicom Structure
MCdicom Members


OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Observer Context Flag (Trial) RETIRED (0040,A601)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED
Visual Basic
Public Const OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int OBSERVER_CONTEXT_FLAG_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OBSERVER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OBSERVER_TYPE Field
MCdicom Structure See Also Send Feedback
Observer Type (0040,A084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OBSERVER_TYPE
Visual Basic
Public Const OBSERVER_TYPE As UInteger
Visual C++
public:
literal unsigned int OBSERVER_TYPE

See Also

MCdicom Structure
MCdicom Members


OCCUPATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCCUPATION Field
MCdicom Structure See Also Send Feedback
Occupation (0010,2180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCCUPATION
Visual Basic
Public Const OCCUPATION As UInteger
Visual C++
public:
literal unsigned int OCCUPATION

See Also

MCdicom Structure
MCdicom Members


OCT_ACQUISITION_DOMAIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_ACQUISITION_DOMAIN Field
MCdicom Structure See Also Send Feedback
OCT Acquisition Domain (0052,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_ACQUISITION_DOMAIN
Visual Basic
Public Const OCT_ACQUISITION_DOMAIN As UInteger
Visual C++
public:
literal unsigned int OCT_ACQUISITION_DOMAIN

See Also

MCdicom Structure
MCdicom Members


OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
OCT B-scan Analysis Acquisition Parameters Sequence (0022,1640)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE
Visual Basic
Public Const OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OCT_B_SCAN_ANALYSIS_ACQUISITION_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OCT_FOCAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_FOCAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
OCT Focal Distance (0052,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_FOCAL_DISTANCE
Visual Basic
Public Const OCT_FOCAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int OCT_FOCAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


OCT_OPTICAL_CENTER_WAVELENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_OPTICAL_CENTER_WAVELENGTH Field
MCdicom Structure See Also Send Feedback
OCT Optical Center Wavelength (0052,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_OPTICAL_CENTER_WAVELENGTH
Visual Basic
Public Const OCT_OPTICAL_CENTER_WAVELENGTH As UInteger
Visual C++
public:
literal unsigned int OCT_OPTICAL_CENTER_WAVELENGTH

See Also

MCdicom Structure
MCdicom Members


OCT_Z_OFFSET_APPLIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_Z_OFFSET_APPLIED Field
MCdicom Structure See Also Send Feedback
OCT Z Offset Applied (0052,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_Z_OFFSET_APPLIED
Visual Basic
Public Const OCT_Z_OFFSET_APPLIED As UInteger
Visual C++
public:
literal unsigned int OCT_Z_OFFSET_APPLIED

See Also

MCdicom Structure
MCdicom Members


OCT_Z_OFFSET_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OCT_Z_OFFSET_CORRECTION Field
MCdicom Structure See Also Send Feedback
OCT Z Offset Correction (0052,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OCT_Z_OFFSET_CORRECTION
Visual Basic
Public Const OCT_Z_OFFSET_CORRECTION As UInteger
Visual C++
public:
literal unsigned int OCT_Z_OFFSET_CORRECTION

See Also

MCdicom Structure
MCdicom Members


OECF_COLUMN_NAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OECF_COLUMN_NAMES Field
MCdicom Structure See Also Send Feedback
OECF Column Names (0016,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OECF_COLUMN_NAMES
Visual Basic
Public Const OECF_COLUMN_NAMES As UInteger
Visual C++
public:
literal unsigned int OECF_COLUMN_NAMES

See Also

MCdicom Structure
MCdicom Members


OECF_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OECF_COLUMNS Field
MCdicom Structure See Also Send Feedback
OECF Columns (0016,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OECF_COLUMNS
Visual Basic
Public Const OECF_COLUMNS As UInteger
Visual C++
public:
literal unsigned int OECF_COLUMNS

See Also

MCdicom Structure
MCdicom Members


OECF_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OECF_ROWS Field
MCdicom Structure See Also Send Feedback
OECF Rows (0016,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OECF_ROWS
Visual Basic
Public Const OECF_ROWS As UInteger
Visual C++
public:
literal unsigned int OECF_ROWS

See Also

MCdicom Structure
MCdicom Members


OECF_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OECF_VALUES Field
MCdicom Structure See Also Send Feedback
OECF Values (0016,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OECF_VALUES
Visual Basic
Public Const OECF_VALUES As UInteger
Visual C++
public:
literal unsigned int OECF_VALUES

See Also

MCdicom Structure
MCdicom Members


OFFENDING_ELEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFENDING_ELEMENT Field
MCdicom Structure See Also Send Feedback
Offending Element (0000,0901)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFENDING_ELEMENT
Visual Basic
Public Const OFFENDING_ELEMENT As UInteger
Visual C++
public:
literal unsigned int OFFENDING_ELEMENT

See Also

MCdicom Structure
MCdicom Members


OFFSET_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_DIRECTION Field
MCdicom Structure See Also Send Feedback
Offset Direction (0018,9905)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_DIRECTION
Visual Basic
Public Const OFFSET_DIRECTION As UInteger
Visual C++
public:
literal unsigned int OFFSET_DIRECTION

See Also

MCdicom Structure
MCdicom Members


OFFSET_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_DISTANCE Field
MCdicom Structure See Also Send Feedback
Offset Distance (0018,9904)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_DISTANCE
Visual Basic
Public Const OFFSET_DISTANCE As UInteger
Visual C++
public:
literal unsigned int OFFSET_DISTANCE

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY Field
MCdicom Structure See Also Send Feedback
Alias for tag OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY
Visual Basic
Public Const OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_FIRST_DIR_REC_OF_THE_ROOT_DIR_ENTITY

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY Field
MCdicom Structure See Also Send Feedback
Alias for tag OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY (0004,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY
Visual Basic
Public Const OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_LAST_DIR_REC_OF_THE_ROOT_DIR_ENTITY

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY Field
MCdicom Structure See Also Send Feedback
Offset of Referenced Lower-Level Directory Entity (0004,1420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY
Visual Basic
Public Const OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_REFERENCED_LOWER_LEVEL_DIRECTORY_ENTITY

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY Field
MCdicom Structure See Also Send Feedback
Offset of the First Directory Record of the Root Directory Entity (0004,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY
Visual Basic
Public Const OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_THE_FIRST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY Field
MCdicom Structure See Also Send Feedback
Offset of the Last Directory Record of the Root Directory Entity (0004,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY
Visual Basic
Public Const OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_THE_LAST_DIRECTORY_RECORD_OF_THE_ROOT_DIRECTORY_ENTITY

See Also

MCdicom Structure
MCdicom Members


OFFSET_OF_THE_NEXT_DIRECTORY_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OFFSET_OF_THE_NEXT_DIRECTORY_RECORD Field
MCdicom Structure See Also Send Feedback
Offset of the Next Directory Record (0004,1400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OFFSET_OF_THE_NEXT_DIRECTORY_RECORD
Visual Basic
Public Const OFFSET_OF_THE_NEXT_DIRECTORY_RECORD As UInteger
Visual C++
public:
literal unsigned int OFFSET_OF_THE_NEXT_DIRECTORY_RECORD

See Also

MCdicom Structure
MCdicom Members


OMITTED_APPLICATION_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OMITTED_APPLICATION_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Omitted Application Setup Sequence (0074,140E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OMITTED_APPLICATION_SETUP_SEQUENCE
Visual Basic
Public Const OMITTED_APPLICATION_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OMITTED_APPLICATION_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OMITTED_BEAM_TASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OMITTED_BEAM_TASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Omitted Beam Task Sequence (300C,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OMITTED_BEAM_TASK_SEQUENCE
Visual Basic
Public Const OMITTED_BEAM_TASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OMITTED_BEAM_TASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OMITTED_CHANNEL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OMITTED_CHANNEL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Omitted Channel Sequence (0074,1409)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OMITTED_CHANNEL_SEQUENCE
Visual Basic
Public Const OMITTED_CHANNEL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OMITTED_CHANNEL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OMITTED_RADIATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OMITTED_RADIATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Omitted Radiation Sequence (300A,0787)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OMITTED_RADIATION_SEQUENCE
Visual Basic
Public Const OMITTED_RADIATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OMITTED_RADIATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
On Axis Background Anatomic Structure Code Sequence (Trial) RETIRED (0008,225C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ON_AXIS_BACKGROUND_ANATOMIC_STRUCTURE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


OOI_OWNER_CREATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_OWNER_CREATION_TIME Field
MCdicom Structure See Also Send Feedback
OOI Owner Creation Time (4010,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_OWNER_CREATION_TIME
Visual Basic
Public Const OOI_OWNER_CREATION_TIME As UInteger
Visual C++
public:
literal unsigned int OOI_OWNER_CREATION_TIME

See Also

MCdicom Structure
MCdicom Members


OOI_OWNER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_OWNER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
OOI Owner Sequence (4010,1047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_OWNER_SEQUENCE
Visual Basic
Public Const OOI_OWNER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OOI_OWNER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OOI_OWNER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_OWNER_TYPE Field
MCdicom Structure See Also Send Feedback
OOI Owner Type (4010,1009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_OWNER_TYPE
Visual Basic
Public Const OOI_OWNER_TYPE As UInteger
Visual C++
public:
literal unsigned int OOI_OWNER_TYPE

See Also

MCdicom Structure
MCdicom Members


OOI_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_SIZE Field
MCdicom Structure See Also Send Feedback
OOI Size (4010,1043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_SIZE
Visual Basic
Public Const OOI_SIZE As UInteger
Visual C++
public:
literal unsigned int OOI_SIZE

See Also

MCdicom Structure
MCdicom Members


OOI_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_TYPE Field
MCdicom Structure See Also Send Feedback
OOI Type (4010,1042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_TYPE
Visual Basic
Public Const OOI_TYPE As UInteger
Visual C++
public:
literal unsigned int OOI_TYPE

See Also

MCdicom Structure
MCdicom Members


OOI_TYPE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OOI_TYPE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
OOI Type Descriptor (4010,1068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OOI_TYPE_DESCRIPTOR
Visual Basic
Public Const OOI_TYPE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int OOI_TYPE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


OPERATING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPERATING_MODE Field
MCdicom Structure See Also Send Feedback
Operating Mode (0018,9178)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPERATING_MODE
Visual Basic
Public Const OPERATING_MODE As UInteger
Visual C++
public:
literal unsigned int OPERATING_MODE

See Also

MCdicom Structure
MCdicom Members


OPERATING_MODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPERATING_MODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Operating Mode Sequence (0018,9176)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPERATING_MODE_SEQUENCE
Visual Basic
Public Const OPERATING_MODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPERATING_MODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPERATING_MODE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPERATING_MODE_TYPE Field
MCdicom Structure See Also Send Feedback
Operating Mode Type (0018,9177)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPERATING_MODE_TYPE
Visual Basic
Public Const OPERATING_MODE_TYPE As UInteger
Visual C++
public:
literal unsigned int OPERATING_MODE_TYPE

See Also

MCdicom Structure
MCdicom Members


OPERATOR_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPERATOR_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Operator Identification Sequence (0008,1072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPERATOR_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const OPERATOR_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPERATOR_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPERATORS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPERATORS_NAME Field
MCdicom Structure See Also Send Feedback
Operators' Name (0008,1070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPERATORS_NAME
Visual Basic
Public Const OPERATORS_NAME As UInteger
Visual C++
public:
literal unsigned int OPERATORS_NAME

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Anatomic Reference Point X-Coordinate (0022,1624)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE
Visual Basic
Public Const OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_ANATOMIC_REFERENCE_POINT_X_COORDINATE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Anatomic Reference Point Y-Coordinate (0022,1626)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE
Visual Basic
Public Const OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_ANATOMIC_REFERENCE_POINT_Y_COORDINATE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length (0022,1019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Acquisition Method Code Sequence RETIRED (0022,1153)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_ACQUISITION_METHOD_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Data Source Code Sequence (0022,1150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Data Source Description (0022,1159)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_DATA_SOURCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurement Modified (0022,1140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_MODIFIED

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Length Summation Sequence (0022,1212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_LENGTH_SUMMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Segment Name Code Sequence (0022,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENT_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Segmental Length Sequence (0022,1211)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEGMENTAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Sequence (0022,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Total Length Sequence (0022,1210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TOTAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Measurements Type (0022,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_TYPE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_METHOD Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Method (0022,1515)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_METHOD
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_METHOD As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_METHOD

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Quality Metric Sequence (0022,1262)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Quality Metric Type Code Sequence RETIRED (0022,1265)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Quality Metric Type Description RETIRED (0022,1273)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_QUALITY_METRIC_TYPE_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Selection Method Code Sequence (0022,1250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_SELECTION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Sequence (0022,1012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_LENGTH_VELOCITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_LENGTH_VELOCITY Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Length Velocity (0022,1059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_LENGTH_VELOCITY
Visual Basic
Public Const OPHTHALMIC_AXIAL_LENGTH_VELOCITY As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_LENGTH_VELOCITY

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Measurements Device Type (0022,1009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE
Visual Basic
Public Const OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_MEASUREMENTS_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Measurements Left Eye Sequence (0022,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_MEASUREMENTS_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Axial Measurements Right Eye Sequence (0022,1007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_AXIAL_MEASUREMENTS_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic En Face Image Quality Rating Sequence (0022,1628)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_FOV Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_FOV Field
MCdicom Structure See Also Send Feedback
Ophthalmic FOV (0022,1517)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_FOV
Visual Basic
Public Const OPHTHALMIC_FOV As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_FOV

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_FRAME_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_FRAME_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Frame Location Sequence (0022,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_FRAME_LOCATION_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_FRAME_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_FRAME_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_IMAGE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_IMAGE_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Ophthalmic Image Orientation (0022,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_IMAGE_ORIENTATION
Visual Basic
Public Const OPHTHALMIC_IMAGE_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_IMAGE_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Image Type Code Sequence (0022,1615)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_IMAGE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_IMAGE_TYPE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_IMAGE_TYPE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Ophthalmic Image Type Description (0022,1616)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_IMAGE_TYPE_DESCRIPTION
Visual Basic
Public Const OPHTHALMIC_IMAGE_TYPE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_IMAGE_TYPE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_MAPPING_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_MAPPING_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Mapping Device Type (0022,1415)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_MAPPING_DEVICE_TYPE
Visual Basic
Public Const OPHTHALMIC_MAPPING_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_MAPPING_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Patient Clinical Information Left Eye Sequence (0024,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Patient Clinical Information Right Eye Sequence (0024,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_PATIENT_CLINICAL_INFORMATION_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Thickness Map Quality Rating Sequence (0022,1470)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_THICKNESS_MAP_QUALITY_RATING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Thickness Map Quality Threshold Sequence (0022,1458)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_THICKNESS_MAP_QUALITY_THRESHOLD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING Field
MCdicom Structure See Also Send Feedback
Ophthalmic Thickness Map Threshold Quality Rating (0022,1460)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING
Visual Basic
Public Const OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_THICKNESS_MAP_THRESHOLD_QUALITY_RATING

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Thickness Map Type Code Sequence (0022,1436)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_THICKNESS_MAP_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Thickness Mapping Normals Sequence (0022,1443)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_THICKNESS_MAPPING_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE (0022,1044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_ULTRASOUND_AXIAL_MEASUREMENTS_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ophthalmic Ultrasound Method Code Sequence (0022,1044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE
Visual Basic
Public Const OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_ULTRASOUND_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG Field
MCdicom Structure See Also Send Feedback
Ophthalmic Volumetric Properties Flag (0022,1622)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG
Visual Basic
Public Const OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG As UInteger
Visual C++
public:
literal unsigned int OPHTHALMIC_VOLUMETRIC_PROPERTIES_FLAG

See Also

MCdicom Structure
MCdicom Members


OPTICAL_MAGNIFICATION_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_MAGNIFICATION_FACTOR Field
MCdicom Structure See Also Send Feedback
Optical Magnification Factor (0016,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_MAGNIFICATION_FACTOR
Visual Basic
Public Const OPTICAL_MAGNIFICATION_FACTOR As UInteger
Visual C++
public:
literal unsigned int OPTICAL_MAGNIFICATION_FACTOR

See Also

MCdicom Structure
MCdicom Members


OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Optical Ophthalmic Axial Length Measurements Sequence (0022,1225)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPTICAL_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPTICAL_PATH_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_PATH_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Optical Path Description (0048,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_PATH_DESCRIPTION
Visual Basic
Public Const OPTICAL_PATH_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int OPTICAL_PATH_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


OPTICAL_PATH_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_PATH_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Optical Path Identification Sequence (0048,0207)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_PATH_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const OPTICAL_PATH_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPTICAL_PATH_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPTICAL_PATH_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_PATH_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Optical Path Identifier (0048,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_PATH_IDENTIFIER
Visual Basic
Public Const OPTICAL_PATH_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int OPTICAL_PATH_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


OPTICAL_PATH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_PATH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Optical Path Sequence (0048,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_PATH_SEQUENCE
Visual Basic
Public Const OPTICAL_PATH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPTICAL_PATH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Optical Selected Ophthalmic Axial Length Sequence (0022,1255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE
Visual Basic
Public Const OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OPTICAL_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OPTICAL_TRANSMITTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTICAL_TRANSMITTANCE Field
MCdicom Structure See Also Send Feedback
Optical Transmittance (0046,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTICAL_TRANSMITTANCE
Visual Basic
Public Const OPTICAL_TRANSMITTANCE As UInteger
Visual C++
public:
literal unsigned int OPTICAL_TRANSMITTANCE

See Also

MCdicom Structure
MCdicom Members


OPTOTYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTOTYPE Field
MCdicom Structure See Also Send Feedback
Optotype (0046,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTOTYPE
Visual Basic
Public Const OPTOTYPE As UInteger
Visual C++
public:
literal unsigned int OPTOTYPE

See Also

MCdicom Structure
MCdicom Members


OPTOTYPE_DETAILED_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTOTYPE_DETAILED_DEFINITION Field
MCdicom Structure See Also Send Feedback
Optotype Detailed Definition (0046,0139)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTOTYPE_DETAILED_DEFINITION
Visual Basic
Public Const OPTOTYPE_DETAILED_DEFINITION As UInteger
Visual C++
public:
literal unsigned int OPTOTYPE_DETAILED_DEFINITION

See Also

MCdicom Structure
MCdicom Members


OPTOTYPE_PRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OPTOTYPE_PRESENTATION Field
MCdicom Structure See Also Send Feedback
Optotype Presentation (0046,0095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OPTOTYPE_PRESENTATION
Visual Basic
Public Const OPTOTYPE_PRESENTATION As UInteger
Visual C++
public:
literal unsigned int OPTOTYPE_PRESENTATION

See Also

MCdicom Structure
MCdicom Members


ORDER_CALLBACK_PHONE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_CALLBACK_PHONE_NUMBER Field
MCdicom Structure See Also Send Feedback
Order Callback Phone Number (0040,2010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_CALLBACK_PHONE_NUMBER
Visual Basic
Public Const ORDER_CALLBACK_PHONE_NUMBER As UInteger
Visual C++
public:
literal unsigned int ORDER_CALLBACK_PHONE_NUMBER

See Also

MCdicom Structure
MCdicom Members


ORDER_CALLBACK_TELECOM_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_CALLBACK_TELECOM_INFORMATION Field
MCdicom Structure See Also Send Feedback
Order Callback Telecom Information (0040,2011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_CALLBACK_TELECOM_INFORMATION
Visual Basic
Public Const ORDER_CALLBACK_TELECOM_INFORMATION As UInteger
Visual C++
public:
literal unsigned int ORDER_CALLBACK_TELECOM_INFORMATION

See Also

MCdicom Structure
MCdicom Members


ORDER_ENTERED_BY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_ENTERED_BY Field
MCdicom Structure See Also Send Feedback
Order Entered By (0040,2008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_ENTERED_BY
Visual Basic
Public Const ORDER_ENTERED_BY As UInteger
Visual C++
public:
literal unsigned int ORDER_ENTERED_BY

See Also

MCdicom Structure
MCdicom Members


ORDER_ENTERERS_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_ENTERERS_LOCATION Field
MCdicom Structure See Also Send Feedback
Order Enterer's Location (0040,2009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_ENTERERS_LOCATION
Visual Basic
Public Const ORDER_ENTERERS_LOCATION As UInteger
Visual C++
public:
literal unsigned int ORDER_ENTERERS_LOCATION

See Also

MCdicom Structure
MCdicom Members


ORDER_FILLER_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_FILLER_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Order Filler Identifier Sequence (0040,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_FILLER_IDENTIFIER_SEQUENCE
Visual Basic
Public Const ORDER_FILLER_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORDER_FILLER_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORDER_PLACER_IDENTIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORDER_PLACER_IDENTIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Order Placer Identifier Sequence (0040,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORDER_PLACER_IDENTIFIER_SEQUENCE
Visual Basic
Public Const ORDER_PLACER_IDENTIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORDER_PLACER_IDENTIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORGAN_AT_RISK_FULL_VOLUME_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_AT_RISK_FULL_VOLUME_DOSE Field
MCdicom Structure See Also Send Feedback
Organ at Risk Full-volume Dose (300A,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_AT_RISK_FULL_VOLUME_DOSE
Visual Basic
Public Const ORGAN_AT_RISK_FULL_VOLUME_DOSE As UInteger
Visual C++
public:
literal unsigned int ORGAN_AT_RISK_FULL_VOLUME_DOSE

See Also

MCdicom Structure
MCdicom Members


ORGAN_AT_RISK_LIMIT_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_AT_RISK_LIMIT_DOSE Field
MCdicom Structure See Also Send Feedback
Organ at Risk Limit Dose (300A,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_AT_RISK_LIMIT_DOSE
Visual Basic
Public Const ORGAN_AT_RISK_LIMIT_DOSE As UInteger
Visual C++
public:
literal unsigned int ORGAN_AT_RISK_LIMIT_DOSE

See Also

MCdicom Structure
MCdicom Members


ORGAN_AT_RISK_MAXIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_AT_RISK_MAXIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
Organ at Risk Maximum Dose (300A,002C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_AT_RISK_MAXIMUM_DOSE
Visual Basic
Public Const ORGAN_AT_RISK_MAXIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int ORGAN_AT_RISK_MAXIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION Field
MCdicom Structure See Also Send Feedback
Organ at Risk Overdose Volume Fraction (300A,002D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION
Visual Basic
Public Const ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION As UInteger
Visual C++
public:
literal unsigned int ORGAN_AT_RISK_OVERDOSE_VOLUME_FRACTION

See Also

MCdicom Structure
MCdicom Members


ORGAN_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_DOSE Field
MCdicom Structure See Also Send Feedback
Organ Dose (0040,0316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_DOSE
Visual Basic
Public Const ORGAN_DOSE As UInteger
Visual C++
public:
literal unsigned int ORGAN_DOSE

See Also

MCdicom Structure
MCdicom Members


ORGAN_EXPOSED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGAN_EXPOSED Field
MCdicom Structure See Also Send Feedback
Organ Exposed (0040,0318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGAN_EXPOSED
Visual Basic
Public Const ORGAN_EXPOSED As UInteger
Visual C++
public:
literal unsigned int ORGAN_EXPOSED

See Also

MCdicom Structure
MCdicom Members


ORGANIZATIONAL_ROLE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORGANIZATIONAL_ROLE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Organizational Role Code Sequence (0044,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORGANIZATIONAL_ROLE_CODE_SEQUENCE
Visual Basic
Public Const ORGANIZATIONAL_ROLE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORGANIZATIONAL_ROLE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGIN Field
MCdicom Structure See Also Send Feedback
Alias for tag OVERLAY_ORIGIN (6000,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGIN
Visual Basic
Public Const ORIGIN As UInteger
Visual C++
public:
literal unsigned int ORIGIN

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Original Attributes Sequence (0400,0561)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const ORIGINAL_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED Field
MCdicom Structure See Also Send Feedback
Original Image Identification Nomenclature RETIRED (0020,5002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED
Visual Basic
Public Const ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_IMAGE_IDENTIFICATION_NOMENCLATURE_RETIRED

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_IMAGE_IDENTIFICATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_IMAGE_IDENTIFICATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Original Image Identification RETIRED (0020,5000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_IMAGE_IDENTIFICATION_RETIRED
Visual Basic
Public Const ORIGINAL_IMAGE_IDENTIFICATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_IMAGE_IDENTIFICATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Original Image Sequence (2130,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_IMAGE_SEQUENCE
Visual Basic
Public Const ORIGINAL_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Original Implant Assembly Template Sequence (0076,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE
Visual Basic
Public Const ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Original Implant Template Sequence (0068,6225)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE
Visual Basic
Public Const ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_IMPLANT_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGINAL_SPECIALIZED_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINAL_SPECIALIZED_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Original Specialized SOP Class UID (0008,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINAL_SPECIALIZED_SOP_CLASS_UID
Visual Basic
Public Const ORIGINAL_SPECIALIZED_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int ORIGINAL_SPECIALIZED_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Originating SOP Instance Reference Sequence (3010,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE
Visual Basic
Public Const ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ORIGINATING_SOP_INSTANCE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ORIGINATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ORIGINATOR Field
MCdicom Structure See Also Send Feedback
Originator (2100,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ORIGINATOR
Visual Basic
Public Const ORIGINATOR As UInteger
Visual C++
public:
literal unsigned int ORIGINATOR

See Also

MCdicom Structure
MCdicom Members


OTHER_FAILURES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_FAILURES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Other Failures Sequence (0008,119A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_FAILURES_SEQUENCE
Visual Basic
Public Const OTHER_FAILURES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OTHER_FAILURES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OTHER_MAGNIFICATION_TYPES_AVAILABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_MAGNIFICATION_TYPES_AVAILABLE Field
MCdicom Structure See Also Send Feedback
Other Magnification Types Available (2010,00A7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_MAGNIFICATION_TYPES_AVAILABLE
Visual Basic
Public Const OTHER_MAGNIFICATION_TYPES_AVAILABLE As UInteger
Visual C++
public:
literal unsigned int OTHER_MAGNIFICATION_TYPES_AVAILABLE

See Also

MCdicom Structure
MCdicom Members


OTHER_MEDIA_AVAILABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_MEDIA_AVAILABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Other Media Available Sequence (2000,00A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_MEDIA_AVAILABLE_SEQUENCE
Visual Basic
Public Const OTHER_MEDIA_AVAILABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OTHER_MEDIA_AVAILABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OTHER_PATIENT_IDS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_PATIENT_IDS_RETIRED Field
MCdicom Structure See Also Send Feedback
Other Patient IDs RETIRED (0010,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_PATIENT_IDS_RETIRED
Visual Basic
Public Const OTHER_PATIENT_IDS_RETIRED As UInteger
Visual C++
public:
literal unsigned int OTHER_PATIENT_IDS_RETIRED

See Also

MCdicom Structure
MCdicom Members


OTHER_PATIENT_IDS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_PATIENT_IDS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Other Patient IDs Sequence (0010,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_PATIENT_IDS_SEQUENCE
Visual Basic
Public Const OTHER_PATIENT_IDS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OTHER_PATIENT_IDS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OTHER_PATIENT_NAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_PATIENT_NAMES Field
MCdicom Structure See Also Send Feedback
Other Patient Names (0010,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_PATIENT_NAMES
Visual Basic
Public Const OTHER_PATIENT_NAMES As UInteger
Visual C++
public:
literal unsigned int OTHER_PATIENT_NAMES

See Also

MCdicom Structure
MCdicom Members


OTHER_PUPILLARY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_PUPILLARY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Other Pupillary Distance (0046,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_PUPILLARY_DISTANCE
Visual Basic
Public Const OTHER_PUPILLARY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int OTHER_PUPILLARY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


OTHER_SMOOTHING_TYPES_AVAILABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_SMOOTHING_TYPES_AVAILABLE Field
MCdicom Structure See Also Send Feedback
Other Smoothing Types Available (2010,00A9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_SMOOTHING_TYPES_AVAILABLE
Visual Basic
Public Const OTHER_SMOOTHING_TYPES_AVAILABLE As UInteger
Visual C++
public:
literal unsigned int OTHER_SMOOTHING_TYPES_AVAILABLE

See Also

MCdicom Structure
MCdicom Members


OTHER_STUDY_NUMBERS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OTHER_STUDY_NUMBERS_RETIRED Field
MCdicom Structure See Also Send Feedback
Other Study Numbers RETIRED (0020,1070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OTHER_STUDY_NUMBERS_RETIRED
Visual Basic
Public Const OTHER_STUDY_NUMBERS_RETIRED As UInteger
Visual C++
public:
literal unsigned int OTHER_STUDY_NUMBERS_RETIRED

See Also

MCdicom Structure
MCdicom Members


OUTER_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTER_DIAMETER Field
MCdicom Structure See Also Send Feedback
Outer Diameter (0014,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTER_DIAMETER
Visual Basic
Public Const OUTER_DIAMETER As UInteger
Visual C++
public:
literal unsigned int OUTER_DIAMETER

See Also

MCdicom Structure
MCdicom Members


OUTLINE_LEFT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTLINE_LEFT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Outline Left Vertical Edge (0018,1631)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTLINE_LEFT_VERTICAL_EDGE
Visual Basic
Public Const OUTLINE_LEFT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int OUTLINE_LEFT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


OUTLINE_LOWER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTLINE_LOWER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Outline Lower Horizontal Edge (0018,1634)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTLINE_LOWER_HORIZONTAL_EDGE
Visual Basic
Public Const OUTLINE_LOWER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int OUTLINE_LOWER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


OUTLINE_RIGHT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTLINE_RIGHT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Outline Right Vertical Edge (0018,1632)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTLINE_RIGHT_VERTICAL_EDGE
Visual Basic
Public Const OUTLINE_RIGHT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int OUTLINE_RIGHT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


OUTLINE_SHAPE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTLINE_SHAPE_TYPE Field
MCdicom Structure See Also Send Feedback
Outline Shape Type (0018,1630)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTLINE_SHAPE_TYPE
Visual Basic
Public Const OUTLINE_SHAPE_TYPE As UInteger
Visual C++
public:
literal unsigned int OUTLINE_SHAPE_TYPE

See Also

MCdicom Structure
MCdicom Members


OUTLINE_UPPER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTLINE_UPPER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Outline Upper Horizontal Edge (0018,1633)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTLINE_UPPER_HORIZONTAL_EDGE
Visual Basic
Public Const OUTLINE_UPPER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int OUTLINE_UPPER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


OUTPUT_DESTINATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTPUT_DESTINATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Output Destination Sequence (0040,4070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTPUT_DESTINATION_SEQUENCE
Visual Basic
Public Const OUTPUT_DESTINATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OUTPUT_DESTINATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OUTPUT_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTPUT_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Output Information Sequence (0040,4033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTPUT_INFORMATION_SEQUENCE
Visual Basic
Public Const OUTPUT_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OUTPUT_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OUTPUT_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OUTPUT_POWER Field
MCdicom Structure See Also Send Feedback
Output Power (0018,5000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OUTPUT_POWER
Visual Basic
Public Const OUTPUT_POWER As UInteger
Visual C++
public:
literal unsigned int OUTPUT_POWER

See Also

MCdicom Structure
MCdicom Members


OVERALL_TEMPLATE_SPATIAL_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERALL_TEMPLATE_SPATIAL_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Overall Template Spatial Tolerance (0068,62A5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERALL_TEMPLATE_SPATIAL_TOLERANCE
Visual Basic
Public Const OVERALL_TEMPLATE_SPATIAL_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int OVERALL_TEMPLATE_SPATIAL_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


OVERLAY_ACTIVATION_LAYER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_ACTIVATION_LAYER Field
MCdicom Structure See Also Send Feedback
Overlay Activation Layer (6000,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_ACTIVATION_LAYER
Visual Basic
Public Const OVERLAY_ACTIVATION_LAYER As UInteger
Visual C++
public:
literal unsigned int OVERLAY_ACTIVATION_LAYER

See Also

MCdicom Structure
MCdicom Members


OVERLAY_BACKGROUND_DENSITY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_BACKGROUND_DENSITY_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Background Density RETIRED (2040,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_BACKGROUND_DENSITY_RETIRED
Visual Basic
Public Const OVERLAY_BACKGROUND_DENSITY_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_BACKGROUND_DENSITY_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_BIT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_BIT_POSITION Field
MCdicom Structure See Also Send Feedback
Overlay Bit Position (6000,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_BIT_POSITION
Visual Basic
Public Const OVERLAY_BIT_POSITION As UInteger
Visual C++
public:
literal unsigned int OVERLAY_BIT_POSITION

See Also

MCdicom Structure
MCdicom Members


OVERLAY_BITS_ALLOCATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_BITS_ALLOCATED Field
MCdicom Structure See Also Send Feedback
Overlay Bits Allocated (6000,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_BITS_ALLOCATED
Visual Basic
Public Const OVERLAY_BITS_ALLOCATED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_BITS_ALLOCATED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_COLUMNS Field
MCdicom Structure See Also Send Feedback
Overlay Columns (6000,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_COLUMNS
Visual Basic
Public Const OVERLAY_COLUMNS As UInteger
Visual C++
public:
literal unsigned int OVERLAY_COLUMNS

See Also

MCdicom Structure
MCdicom Members


OVERLAY_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Comments RETIRED (6000,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_COMMENTS_RETIRED
Visual Basic
Public Const OVERLAY_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_COMPRESSION_CODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_COMPRESSION_CODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Compression Code RETIRED (6000,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_COMPRESSION_CODE_RETIRED
Visual Basic
Public Const OVERLAY_COMPRESSION_CODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_COMPRESSION_CODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DATA Field
MCdicom Structure See Also Send Feedback
Overlay Data (6000,3000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DATA
Visual Basic
Public Const OVERLAY_DATA As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DATA

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Date RETIRED (0008,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DATE_RETIRED
Visual Basic
Public Const OVERLAY_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Overlay Description (6000,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DESCRIPTION
Visual Basic
Public Const OVERLAY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DESCRIPTOR_BLUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DESCRIPTOR_BLUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Descriptor - Blue RETIRED (6000,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DESCRIPTOR_BLUE_RETIRED
Visual Basic
Public Const OVERLAY_DESCRIPTOR_BLUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DESCRIPTOR_BLUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DESCRIPTOR_GRAY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DESCRIPTOR_GRAY_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Descriptor - Gray RETIRED (6000,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DESCRIPTOR_GRAY_RETIRED
Visual Basic
Public Const OVERLAY_DESCRIPTOR_GRAY_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DESCRIPTOR_GRAY_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DESCRIPTOR_GREEN_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DESCRIPTOR_GREEN_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Descriptor - Green RETIRED (6000,1102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DESCRIPTOR_GREEN_RETIRED
Visual Basic
Public Const OVERLAY_DESCRIPTOR_GREEN_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DESCRIPTOR_GREEN_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_DESCRIPTOR_RED_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_DESCRIPTOR_RED_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Descriptor - Red RETIRED (6000,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_DESCRIPTOR_RED_RETIRED
Visual Basic
Public Const OVERLAY_DESCRIPTOR_RED_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_DESCRIPTOR_RED_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_FOREGROUND_DENSITY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_FOREGROUND_DENSITY_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Foreground Density RETIRED (2040,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_FOREGROUND_DENSITY_RETIRED
Visual Basic
Public Const OVERLAY_FOREGROUND_DENSITY_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_FOREGROUND_DENSITY_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_FORMAT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_FORMAT_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Format RETIRED (6000,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_FORMAT_RETIRED
Visual Basic
Public Const OVERLAY_FORMAT_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_FORMAT_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_LABEL Field
MCdicom Structure See Also Send Feedback
Overlay Label (6000,1500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_LABEL
Visual Basic
Public Const OVERLAY_LABEL As UInteger
Visual C++
public:
literal unsigned int OVERLAY_LABEL

See Also

MCdicom Structure
MCdicom Members


OVERLAY_LOCATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_LOCATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Location RETIRED (6000,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_LOCATION_RETIRED
Visual Basic
Public Const OVERLAY_LOCATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_LOCATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_MAGNIFICATION_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_MAGNIFICATION_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Magnification Type RETIRED (2040,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_MAGNIFICATION_TYPE_RETIRED
Visual Basic
Public Const OVERLAY_MAGNIFICATION_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_MAGNIFICATION_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_MODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_MODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Mode RETIRED (2040,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_MODE_RETIRED
Visual Basic
Public Const OVERLAY_MODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_MODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Number RETIRED (0020,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_NUMBER_RETIRED
Visual Basic
Public Const OVERLAY_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay or Image Magnification RETIRED (2040,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED
Visual Basic
Public Const OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_OR_IMAGE_MAGNIFICATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_ORIGIN Field
MCdicom Structure See Also Send Feedback
Overlay Origin (6000,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_ORIGIN
Visual Basic
Public Const OVERLAY_ORIGIN As UInteger
Visual C++
public:
literal unsigned int OVERLAY_ORIGIN

See Also

MCdicom Structure
MCdicom Members


OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Pixel Data Sequence RETIRED (2040,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED
Visual Basic
Public Const OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_PIXEL_DATA_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_PLANE_ORIGIN_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_PLANE_ORIGIN_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Plane Origin RETIRED (6000,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_PLANE_ORIGIN_RETIRED
Visual Basic
Public Const OVERLAY_PLANE_ORIGIN_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_PLANE_ORIGIN_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_PLANES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_PLANES_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Planes RETIRED (6000,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_PLANES_RETIRED
Visual Basic
Public Const OVERLAY_PLANES_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_PLANES_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_ROWS Field
MCdicom Structure See Also Send Feedback
Overlay Rows (6000,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_ROWS
Visual Basic
Public Const OVERLAY_ROWS As UInteger
Visual C++
public:
literal unsigned int OVERLAY_ROWS

See Also

MCdicom Structure
MCdicom Members


OVERLAY_SMOOTHING_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_SMOOTHING_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Smoothing Type RETIRED (2040,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_SMOOTHING_TYPE_RETIRED
Visual Basic
Public Const OVERLAY_SMOOTHING_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_SMOOTHING_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_SUBTYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_SUBTYPE Field
MCdicom Structure See Also Send Feedback
Overlay Subtype (6000,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_SUBTYPE
Visual Basic
Public Const OVERLAY_SUBTYPE As UInteger
Visual C++
public:
literal unsigned int OVERLAY_SUBTYPE

See Also

MCdicom Structure
MCdicom Members


OVERLAY_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlay Time RETIRED (0008,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_TIME_RETIRED
Visual Basic
Public Const OVERLAY_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAY_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAY_TYPE Field
MCdicom Structure See Also Send Feedback
Overlay Type (6000,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAY_TYPE
Visual Basic
Public Const OVERLAY_TYPE As UInteger
Visual C++
public:
literal unsigned int OVERLAY_TYPE

See Also

MCdicom Structure
MCdicom Members


OVERLAYS_BLUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAYS_BLUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlays - Blue RETIRED (6000,1203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAYS_BLUE_RETIRED
Visual Basic
Public Const OVERLAYS_BLUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAYS_BLUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAYS_GRAY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAYS_GRAY_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlays - Gray RETIRED (6000,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAYS_GRAY_RETIRED
Visual Basic
Public Const OVERLAYS_GRAY_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAYS_GRAY_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAYS_GREEN_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAYS_GREEN_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlays - Green RETIRED (6000,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAYS_GREEN_RETIRED
Visual Basic
Public Const OVERLAYS_GREEN_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAYS_GREEN_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAYS_RED_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAYS_RED_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlays - Red RETIRED (6000,1201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAYS_RED_RETIRED
Visual Basic
Public Const OVERLAYS_RED_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAYS_RED_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERLAYS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERLAYS_RETIRED Field
MCdicom Structure See Also Send Feedback
Overlays RETIRED (0000,51B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERLAYS_RETIRED
Visual Basic
Public Const OVERLAYS_RETIRED As UInteger
Visual C++
public:
literal unsigned int OVERLAYS_RETIRED

See Also

MCdicom Structure
MCdicom Members


OVERRIDDEN_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERRIDDEN_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Overridden Attributes Sequence (0074,104A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERRIDDEN_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const OVERRIDDEN_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OVERRIDDEN_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OVERRIDE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERRIDE_DATETIME Field
MCdicom Structure See Also Send Feedback
Override DateTime (300A,0760)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERRIDE_DATETIME
Visual Basic
Public Const OVERRIDE_DATETIME As UInteger
Visual C++
public:
literal unsigned int OVERRIDE_DATETIME

See Also

MCdicom Structure
MCdicom Members


OVERRIDE_PARAMETER_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERRIDE_PARAMETER_POINTER Field
MCdicom Structure See Also Send Feedback
Override Parameter Pointer (3008,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERRIDE_PARAMETER_POINTER
Visual Basic
Public Const OVERRIDE_PARAMETER_POINTER As UInteger
Visual C++
public:
literal unsigned int OVERRIDE_PARAMETER_POINTER

See Also

MCdicom Structure
MCdicom Members


OVERRIDE_REASON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERRIDE_REASON Field
MCdicom Structure See Also Send Feedback
Override Reason (3008,0066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERRIDE_REASON
Visual Basic
Public Const OVERRIDE_REASON As UInteger
Visual C++
public:
literal unsigned int OVERRIDE_REASON

See Also

MCdicom Structure
MCdicom Members


OVERRIDE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERRIDE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Override Sequence (3008,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERRIDE_SEQUENCE
Visual Basic
Public Const OVERRIDE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int OVERRIDE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


OVERSAMPLING_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OVERSAMPLING_PHASE Field
MCdicom Structure See Also Send Feedback
Oversampling Phase (0018,9029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OVERSAMPLING_PHASE
Visual Basic
Public Const OVERSAMPLING_PHASE As UInteger
Visual C++
public:
literal unsigned int OVERSAMPLING_PHASE

See Also

MCdicom Structure
MCdicom Members


OWNER_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..OWNER_ID Field
MCdicom Structure See Also Send Feedback
Owner ID (2100,0160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint OWNER_ID
Visual Basic
Public Const OWNER_ID As UInteger
Visual C++
public:
literal unsigned int OWNER_ID

See Also

MCdicom Structure
MCdicom Members


PADDLE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PADDLE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Paddle Description (0018,11A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PADDLE_DESCRIPTION
Visual Basic
Public Const PADDLE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PADDLE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PAGE_NUMBER_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PAGE_NUMBER_VECTOR Field
MCdicom Structure See Also Send Feedback
Page Number Vector (0018,2001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PAGE_NUMBER_VECTOR
Visual Basic
Public Const PAGE_NUMBER_VECTOR As UInteger
Visual C++
public:
literal unsigned int PAGE_NUMBER_VECTOR

See Also

MCdicom Structure
MCdicom Members


PAGE_POSITION_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PAGE_POSITION_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Page Position ID RETIRED (0000,5120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PAGE_POSITION_ID_RETIRED
Visual Basic
Public Const PAGE_POSITION_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int PAGE_POSITION_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Palette Color Lookup Table Sequence (0048,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE
Visual Basic
Public Const PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PALETTE_COLOR_LOOKUP_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PALETTE_COLOR_LOOKUP_TABLE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PALETTE_COLOR_LOOKUP_TABLE_UID Field
MCdicom Structure See Also Send Feedback
Palette Color Lookup Table UID (0028,1199)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PALETTE_COLOR_LOOKUP_TABLE_UID
Visual Basic
Public Const PALETTE_COLOR_LOOKUP_TABLE_UID As UInteger
Visual C++
public:
literal unsigned int PALETTE_COLOR_LOOKUP_TABLE_UID

See Also

MCdicom Structure
MCdicom Members


PARALLEL_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_ACQUISITION Field
MCdicom Structure See Also Send Feedback
Parallel Acquisition (0018,9077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_ACQUISITION
Visual Basic
Public Const PARALLEL_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int PARALLEL_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


PARALLEL_ACQUISITION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_ACQUISITION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Parallel Acquisition Technique (0018,9078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_ACQUISITION_TECHNIQUE
Visual Basic
Public Const PARALLEL_ACQUISITION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_ACQUISITION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_REDUCTION_FACTOR_IN_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_REDUCTION_FACTOR_IN_PLANE Field
MCdicom Structure See Also Send Feedback
Parallel Reduction Factor In-plane (0018,9069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_REDUCTION_FACTOR_IN_PLANE
Visual Basic
Public Const PARALLEL_REDUCTION_FACTOR_IN_PLANE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_REDUCTION_FACTOR_IN_PLANE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED Field
MCdicom Structure See Also Send Feedback
Parallel Reduction Factor In-plane (Retired) (0018,9096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED
Visual Basic
Public Const PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PARALLEL_REDUCTION_FACTOR_IN_PLANE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE Field
MCdicom Structure See Also Send Feedback
Parallel Reduction Factor out-of-plane (0018,9155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE
Visual Basic
Public Const PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_REDUCTION_FACTOR_OUT_OF_PLANE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE Field
MCdicom Structure See Also Send Feedback
Parallel Reduction Factor Second In-plane (0018,9168)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE
Visual Basic
Public Const PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_REDUCTION_FACTOR_SECOND_IN_PLANE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Boundaries (300A,0649)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_BOUNDARIES

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Device Orientation Label Code Sequence (300A,0644)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_DEVICE_ORIENTATION_LABEL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Device Sequence (300A,0647)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Leaf Mounting Side (300A,064F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_LEAF_MOUNTING_SIDE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Opening Extents (3008,00A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_OPENING_EXTENTS

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Opening Mode (300A,064E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_OPENING_MODE

See Also

MCdicom Structure
MCdicom Members


PARALLEL_RT_BEAM_DELIMITER_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARALLEL_RT_BEAM_DELIMITER_POSITIONS Field
MCdicom Structure See Also Send Feedback
Parallel RT Beam Delimiter Positions (300A,064A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARALLEL_RT_BEAM_DELIMITER_POSITIONS
Visual Basic
Public Const PARALLEL_RT_BEAM_DELIMITER_POSITIONS As UInteger
Visual C++
public:
literal unsigned int PARALLEL_RT_BEAM_DELIMITER_POSITIONS

See Also

MCdicom Structure
MCdicom Members


PARAMETER_ITEM_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETER_ITEM_INDEX Field
MCdicom Structure See Also Send Feedback
Parameter Item Index (3008,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETER_ITEM_INDEX
Visual Basic
Public Const PARAMETER_ITEM_INDEX As UInteger
Visual C++
public:
literal unsigned int PARAMETER_ITEM_INDEX

See Also

MCdicom Structure
MCdicom Members


PARAMETER_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETER_POINTER Field
MCdicom Structure See Also Send Feedback
Parameter Pointer (3008,0065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETER_POINTER
Visual Basic
Public Const PARAMETER_POINTER As UInteger
Visual C++
public:
literal unsigned int PARAMETER_POINTER

See Also

MCdicom Structure
MCdicom Members


PARAMETER_SEQUENCE_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETER_SEQUENCE_POINTER Field
MCdicom Structure See Also Send Feedback
Parameter Sequence Pointer (3008,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETER_SEQUENCE_POINTER
Visual Basic
Public Const PARAMETER_SEQUENCE_POINTER As UInteger
Visual C++
public:
literal unsigned int PARAMETER_SEQUENCE_POINTER

See Also

MCdicom Structure
MCdicom Members


PARAMETER_VALUE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETER_VALUE_NUMBER Field
MCdicom Structure See Also Send Feedback
Parameter Value Number (3008,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETER_VALUE_NUMBER
Visual Basic
Public Const PARAMETER_VALUE_NUMBER As UInteger
Visual C++
public:
literal unsigned int PARAMETER_VALUE_NUMBER

See Also

MCdicom Structure
MCdicom Members


PARAMETERS_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETERS_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Parameters Specification Sequence (0018,9913)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETERS_SPECIFICATION_SEQUENCE
Visual Basic
Public Const PARAMETERS_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARAMETERS_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Parametric Map Frame Type Sequence (0040,9092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARAMETRIC_MAP_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARTIAL_DATA_DISPLAY_HANDLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_DATA_DISPLAY_HANDLING Field
MCdicom Structure See Also Send Feedback
Partial Data Display Handling (0072,0208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_DATA_DISPLAY_HANDLING
Visual Basic
Public Const PARTIAL_DATA_DISPLAY_HANDLING As UInteger
Visual C++
public:
literal unsigned int PARTIAL_DATA_DISPLAY_HANDLING

See Also

MCdicom Structure
MCdicom Members


PARTIAL_FOURIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_FOURIER Field
MCdicom Structure See Also Send Feedback
Partial Fourier (0018,9081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_FOURIER
Visual Basic
Public Const PARTIAL_FOURIER As UInteger
Visual C++
public:
literal unsigned int PARTIAL_FOURIER

See Also

MCdicom Structure
MCdicom Members


PARTIAL_FOURIER_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_FOURIER_DIRECTION Field
MCdicom Structure See Also Send Feedback
Partial Fourier Direction (0018,9036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_FOURIER_DIRECTION
Visual Basic
Public Const PARTIAL_FOURIER_DIRECTION As UInteger
Visual C++
public:
literal unsigned int PARTIAL_FOURIER_DIRECTION

See Also

MCdicom Structure
MCdicom Members


PARTIAL_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_VIEW Field
MCdicom Structure See Also Send Feedback
Partial View (0028,1350)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_VIEW
Visual Basic
Public Const PARTIAL_VIEW As UInteger
Visual C++
public:
literal unsigned int PARTIAL_VIEW

See Also

MCdicom Structure
MCdicom Members


PARTIAL_VIEW_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_VIEW_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Partial View Code Sequence (0028,1352)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_VIEW_CODE_SEQUENCE
Visual Basic
Public Const PARTIAL_VIEW_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARTIAL_VIEW_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARTIAL_VIEW_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTIAL_VIEW_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Partial View Description (0028,1351)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTIAL_VIEW_DESCRIPTION
Visual Basic
Public Const PARTIAL_VIEW_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PARTIAL_VIEW_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PARTICIPANT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTICIPANT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Participant Sequence (0040,A07A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTICIPANT_SEQUENCE
Visual Basic
Public Const PARTICIPANT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PARTICIPANT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PARTICIPATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTICIPATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Participation DateTime (0040,A082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTICIPATION_DATETIME
Visual Basic
Public Const PARTICIPATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int PARTICIPATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


PARTICIPATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PARTICIPATION_TYPE Field
MCdicom Structure See Also Send Feedback
Participation Type (0040,A080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PARTICIPATION_TYPE
Visual Basic
Public Const PARTICIPATION_TYPE As UInteger
Visual C++
public:
literal unsigned int PARTICIPATION_TYPE

See Also

MCdicom Structure
MCdicom Members


PATIENT_ADDITIONAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ADDITIONAL_POSITION Field
MCdicom Structure See Also Send Feedback
Patient Additional Position (300A,0184)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ADDITIONAL_POSITION
Visual Basic
Public Const PATIENT_ADDITIONAL_POSITION As UInteger
Visual C++
public:
literal unsigned int PATIENT_ADDITIONAL_POSITION

See Also

MCdicom Structure
MCdicom Members


PATIENT_BREED_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_BREED_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Breed Code Sequence (0010,2293)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_BREED_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_BREED_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_BREED_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_BREED_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_BREED_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Patient Breed Description (0010,2292)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_BREED_DESCRIPTION
Visual Basic
Public Const PATIENT_BREED_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_BREED_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Clinical Trial Participation Sequence (0038,0502)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE
Visual Basic
Public Const PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_CLINICAL_TRIAL_PARTICIPATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_COMMENTS Field
MCdicom Structure See Also Send Feedback
Patient Comments (0010,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_COMMENTS
Visual Basic
Public Const PATIENT_COMMENTS As UInteger
Visual C++
public:
literal unsigned int PATIENT_COMMENTS

See Also

MCdicom Structure
MCdicom Members


PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Equipment Relationship Code Sequence (3010,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_EQUIPMENT_RELATIONSHIP_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Eye Movement Command Code Sequence (0022,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_EYE_MOVEMENT_COMMAND_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_EYE_MOVEMENT_COMMANDED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_EYE_MOVEMENT_COMMANDED Field
MCdicom Structure See Also Send Feedback
Patient Eye Movement Commanded (0022,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_EYE_MOVEMENT_COMMANDED
Visual Basic
Public Const PATIENT_EYE_MOVEMENT_COMMANDED As UInteger
Visual C++
public:
literal unsigned int PATIENT_EYE_MOVEMENT_COMMANDED

See Also

MCdicom Structure
MCdicom Members


PATIENT_FRAME_OF_REFERENCE_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_FRAME_OF_REFERENCE_SOURCE Field
MCdicom Structure See Also Send Feedback
Patient Frame of Reference Source (0020,930C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_FRAME_OF_REFERENCE_SOURCE
Visual Basic
Public Const PATIENT_FRAME_OF_REFERENCE_SOURCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_FRAME_OF_REFERENCE_SOURCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Gantry Relationship Code Sequence (0054,0414)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_GANTRY_RELATIONSHIP_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ID Field
MCdicom Structure See Also Send Feedback
Patient ID (0010,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ID
Visual Basic
Public Const PATIENT_ID As UInteger
Visual C++
public:
literal unsigned int PATIENT_ID

See Also

MCdicom Structure
MCdicom Members


PATIENT_IDENTITY_REMOVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_IDENTITY_REMOVED Field
MCdicom Structure See Also Send Feedback
Patient Identity Removed (0012,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_IDENTITY_REMOVED
Visual Basic
Public Const PATIENT_IDENTITY_REMOVED As UInteger
Visual C++
public:
literal unsigned int PATIENT_IDENTITY_REMOVED

See Also

MCdicom Structure
MCdicom Members


PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Location Coordinates Code Sequence (3006,00CA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_LOCATION_COORDINATES_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_LOCATION_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_LOCATION_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Location Coordinates Sequence (3006,00C9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_LOCATION_COORDINATES_SEQUENCE
Visual Basic
Public Const PATIENT_LOCATION_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_LOCATION_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_MOTION_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_MOTION_CORRECTED Field
MCdicom Structure See Also Send Feedback
Patient Motion Corrected (0018,9763)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_MOTION_CORRECTED
Visual Basic
Public Const PATIENT_MOTION_CORRECTED As UInteger
Visual C++
public:
literal unsigned int PATIENT_MOTION_CORRECTED

See Also

MCdicom Structure
MCdicom Members


PATIENT_NOT_PROPERLY_FIXATED_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_NOT_PROPERLY_FIXATED_QUANTITY Field
MCdicom Structure See Also Send Feedback
Patient Not Properly Fixated Quantity (0024,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_NOT_PROPERLY_FIXATED_QUANTITY
Visual Basic
Public Const PATIENT_NOT_PROPERLY_FIXATED_QUANTITY As UInteger
Visual C++
public:
literal unsigned int PATIENT_NOT_PROPERLY_FIXATED_QUANTITY

See Also

MCdicom Structure
MCdicom Members


PATIENT_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Patient Orientation (0020,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ORIENTATION
Visual Basic
Public Const PATIENT_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int PATIENT_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


PATIENT_ORIENTATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ORIENTATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Orientation Code Sequence (0054,0410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ORIENTATION_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_ORIENTATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_ORIENTATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_ORIENTATION_IN_FRAME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ORIENTATION_IN_FRAME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Orientation in Frame Sequence (0020,9450)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ORIENTATION_IN_FRAME_SEQUENCE
Visual Basic
Public Const PATIENT_ORIENTATION_IN_FRAME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_ORIENTATION_IN_FRAME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Orientation Modifier Code Sequence (0054,0412)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_ORIENTATION_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Physiological State Code Sequence (0018,9772)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_PHYSIOLOGICAL_STATE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Physiological State Sequence (0018,9771)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE
Visual Basic
Public Const PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_PHYSIOLOGICAL_STATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_POSITION Field
MCdicom Structure See Also Send Feedback
Patient Position (0018,5100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_POSITION
Visual Basic
Public Const PATIENT_POSITION As UInteger
Visual C++
public:
literal unsigned int PATIENT_POSITION

See Also

MCdicom Structure
MCdicom Members


PATIENT_POSITIONING_INSTRUCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_POSITIONING_INSTRUCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Positioning Instruction Sequence (0018,991B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_POSITIONING_INSTRUCTION_SEQUENCE
Visual Basic
Public Const PATIENT_POSITIONING_INSTRUCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_POSITIONING_INSTRUCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_RELIABILITY_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_RELIABILITY_INDICATOR Field
MCdicom Structure See Also Send Feedback
Patient Reliability Indicator (0024,0069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_RELIABILITY_INDICATOR
Visual Basic
Public Const PATIENT_RELIABILITY_INDICATOR As UInteger
Visual C++
public:
literal unsigned int PATIENT_RELIABILITY_INDICATOR

See Also

MCdicom Structure
MCdicom Members


PATIENT_SETUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SETUP_LABEL Field
MCdicom Structure See Also Send Feedback
Patient Setup Label (300A,0183)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SETUP_LABEL
Visual Basic
Public Const PATIENT_SETUP_LABEL As UInteger
Visual C++
public:
literal unsigned int PATIENT_SETUP_LABEL

See Also

MCdicom Structure
MCdicom Members


PATIENT_SETUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SETUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Patient Setup Number (300A,0182)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SETUP_NUMBER
Visual Basic
Public Const PATIENT_SETUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int PATIENT_SETUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


PATIENT_SETUP_PHOTO_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SETUP_PHOTO_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Patient Setup Photo Description (300A,0794)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SETUP_PHOTO_DESCRIPTION
Visual Basic
Public Const PATIENT_SETUP_PHOTO_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_SETUP_PHOTO_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Setup Sequence (300A,0180)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SETUP_SEQUENCE
Visual Basic
Public Const PATIENT_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SETUP_UID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SETUP_UID_RETIRED Field
MCdicom Structure See Also Send Feedback
Patient Setup UID RETIRED (300A,0650)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SETUP_UID_RETIRED
Visual Basic
Public Const PATIENT_SETUP_UID_RETIRED As UInteger
Visual C++
public:
literal unsigned int PATIENT_SETUP_UID_RETIRED

See Also

MCdicom Structure
MCdicom Members


PATIENT_SPECIES_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SPECIES_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Species Code Sequence (0010,2202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SPECIES_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_SPECIES_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SPECIES_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SPECIES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SPECIES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Patient Species Description (0010,2201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SPECIES_DESCRIPTION
Visual Basic
Public Const PATIENT_SPECIES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_SPECIES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Specification Sequence (0018,9911)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SPECIFICATION_SEQUENCE
Visual Basic
Public Const PATIENT_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_STATE Field
MCdicom Structure See Also Send Feedback
Patient State (0038,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_STATE
Visual Basic
Public Const PATIENT_STATE As UInteger
Visual C++
public:
literal unsigned int PATIENT_STATE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ACCESSORY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ACCESSORY_CODE Field
MCdicom Structure See Also Send Feedback
Patient Support Accessory Code (300A,0354)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ACCESSORY_CODE
Visual Basic
Public Const PATIENT_SUPPORT_ACCESSORY_CODE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ACCESSORY_CODE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ADJUSTED_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ADJUSTED_ANGLE Field
MCdicom Structure See Also Send Feedback
Patient Support Adjusted Angle (0074,102A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ADJUSTED_ANGLE
Visual Basic
Public Const PATIENT_SUPPORT_ADJUSTED_ANGLE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ADJUSTED_ANGLE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ANGLE Field
MCdicom Structure See Also Send Feedback
Patient Support Angle (300A,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ANGLE
Visual Basic
Public Const PATIENT_SUPPORT_ANGLE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ANGLE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Patient Support Angle Tolerance (300A,004C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ANGLE_TOLERANCE
Visual Basic
Public Const PATIENT_SUPPORT_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_DEVICES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_DEVICES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Devices Sequence (300A,0686)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_DEVICES_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_DEVICES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_DEVICES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Displacement Sequence (300A,079C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_DISPLACEMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ID Field
MCdicom Structure See Also Send Feedback
Patient Support ID (300A,0352)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ID
Visual Basic
Public Const PATIENT_SUPPORT_ID As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ID

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Position Device Parameter Sequence (300A,065D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Position Device Tolerance Sequence (300A,0660)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Patient Support Position Parameter Order Index (300A,065F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_PARAMETER_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Position Parameter Sequence (300A,065B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Position Sequence (3006,00CB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD Field
MCdicom Structure See Also Send Feedback
Patient Support Position Specification Method (300A,065C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_SPECIFICATION_METHOD

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Patient Support Position Tolerance Order Index (300A,0661)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_TOLERANCE_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Support Position Tolerance Sequence (300A,062D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE
Visual Basic
Public Const PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_POSITION_TOLERANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Patient Support Rotation Direction (300A,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_ROTATION_DIRECTION
Visual Basic
Public Const PATIENT_SUPPORT_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_SUPPORT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_SUPPORT_TYPE Field
MCdicom Structure See Also Send Feedback
Patient Support Type (300A,0350)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_SUPPORT_TYPE
Visual Basic
Public Const PATIENT_SUPPORT_TYPE As UInteger
Visual C++
public:
literal unsigned int PATIENT_SUPPORT_TYPE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TRANSPORT_ARRANGEMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TRANSPORT_ARRANGEMENTS Field
MCdicom Structure See Also Send Feedback
Patient Transport Arrangements (0040,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TRANSPORT_ARRANGEMENTS
Visual Basic
Public Const PATIENT_TRANSPORT_ARRANGEMENTS As UInteger
Visual C++
public:
literal unsigned int PATIENT_TRANSPORT_ARRANGEMENTS

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_ORIENTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_ORIENTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Orientation Sequence (3010,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_ORIENTATION_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_ORIENTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_ORIENTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Device Sequence (300A,078F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Method Code Sequence (300A,078D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Method Description (300A,0792)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_METHOD_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Procedure Code Sequence (300A,0791)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Procedure Index (300A,0795)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_PROCEDURE_INDEX

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Procedure Parameter Description (300A,078E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Procedure Parameter Sequence (300A,0793)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_PROCEDURE_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient Treatment Preparation Procedure Sequence (300A,0790)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE
Visual Basic
Public Const PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENT_TREATMENT_PREPARATION_PROCEDURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_ADDRESS Field
MCdicom Structure See Also Send Feedback
Patient's Address (0010,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_ADDRESS
Visual Basic
Public Const PATIENTS_ADDRESS As UInteger
Visual C++
public:
literal unsigned int PATIENTS_ADDRESS

See Also

MCdicom Structure
MCdicom Members


PATIENTS_AGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_AGE Field
MCdicom Structure See Also Send Feedback
Patient's Age (0010,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_AGE
Visual Basic
Public Const PATIENTS_AGE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_AGE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_ALTERNATIVE_CALENDAR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_ALTERNATIVE_CALENDAR Field
MCdicom Structure See Also Send Feedback
Patient's Alternative Calendar (0010,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_ALTERNATIVE_CALENDAR
Visual Basic
Public Const PATIENTS_ALTERNATIVE_CALENDAR As UInteger
Visual C++
public:
literal unsigned int PATIENTS_ALTERNATIVE_CALENDAR

See Also

MCdicom Structure
MCdicom Members


PATIENTS_BIRTH_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_BIRTH_DATE Field
MCdicom Structure See Also Send Feedback
Patient's Birth Date (0010,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_BIRTH_DATE
Visual Basic
Public Const PATIENTS_BIRTH_DATE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_BIRTH_DATE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR Field
MCdicom Structure See Also Send Feedback
Patient's Birth Date in Alternative Calendar (0010,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR
Visual Basic
Public Const PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR As UInteger
Visual C++
public:
literal unsigned int PATIENTS_BIRTH_DATE_IN_ALTERNATIVE_CALENDAR

See Also

MCdicom Structure
MCdicom Members


PATIENTS_BIRTH_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_BIRTH_NAME Field
MCdicom Structure See Also Send Feedback
Patient's Birth Name (0010,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_BIRTH_NAME
Visual Basic
Public Const PATIENTS_BIRTH_NAME As UInteger
Visual C++
public:
literal unsigned int PATIENTS_BIRTH_NAME

See Also

MCdicom Structure
MCdicom Members


PATIENTS_BIRTH_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_BIRTH_TIME Field
MCdicom Structure See Also Send Feedback
Patient's Birth Time (0010,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_BIRTH_TIME
Visual Basic
Public Const PATIENTS_BIRTH_TIME As UInteger
Visual C++
public:
literal unsigned int PATIENTS_BIRTH_TIME

See Also

MCdicom Structure
MCdicom Members


PATIENTS_BODY_MASS_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_BODY_MASS_INDEX Field
MCdicom Structure See Also Send Feedback
Patient's Body Mass Index (0010,1022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_BODY_MASS_INDEX
Visual Basic
Public Const PATIENTS_BODY_MASS_INDEX As UInteger
Visual C++
public:
literal unsigned int PATIENTS_BODY_MASS_INDEX

See Also

MCdicom Structure
MCdicom Members


PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR Field
MCdicom Structure See Also Send Feedback
Patient's Death Date in Alternative Calendar (0010,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR
Visual Basic
Public Const PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR As UInteger
Visual C++
public:
literal unsigned int PATIENTS_DEATH_DATE_IN_ALTERNATIVE_CALENDAR

See Also

MCdicom Structure
MCdicom Members


PATIENTS_INSTITUTION_RESIDENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_INSTITUTION_RESIDENCE Field
MCdicom Structure See Also Send Feedback
Patient's Institution Residence (0038,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_INSTITUTION_RESIDENCE
Visual Basic
Public Const PATIENTS_INSTITUTION_RESIDENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_INSTITUTION_RESIDENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient's Insurance Plan Code Sequence (0010,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE
Visual Basic
Public Const PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_INSURANCE_PLAN_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_MOTHERS_BIRTH_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_MOTHERS_BIRTH_NAME Field
MCdicom Structure See Also Send Feedback
Patient's Mother's Birth Name (0010,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_MOTHERS_BIRTH_NAME
Visual Basic
Public Const PATIENTS_MOTHERS_BIRTH_NAME As UInteger
Visual C++
public:
literal unsigned int PATIENTS_MOTHERS_BIRTH_NAME

See Also

MCdicom Structure
MCdicom Members


PATIENTS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_NAME Field
MCdicom Structure See Also Send Feedback
Patient's Name (0010,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_NAME
Visual Basic
Public Const PATIENTS_NAME As UInteger
Visual C++
public:
literal unsigned int PATIENTS_NAME

See Also

MCdicom Structure
MCdicom Members


PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient's Primary Language Code Sequence (0010,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE
Visual Basic
Public Const PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient's Primary Language Modifier Code Sequence (0010,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_RELIGIOUS_PREFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_RELIGIOUS_PREFERENCE Field
MCdicom Structure See Also Send Feedback
Patient's Religious Preference (0010,21F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_RELIGIOUS_PREFERENCE
Visual Basic
Public Const PATIENTS_RELIGIOUS_PREFERENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_RELIGIOUS_PREFERENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_SEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_SEX Field
MCdicom Structure See Also Send Feedback
Patient's Sex (0010,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_SEX
Visual Basic
Public Const PATIENTS_SEX As UInteger
Visual C++
public:
literal unsigned int PATIENTS_SEX

See Also

MCdicom Structure
MCdicom Members


PATIENTS_SEX_NEUTERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_SEX_NEUTERED Field
MCdicom Structure See Also Send Feedback
Patient's Sex Neutered (0010,2203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_SEX_NEUTERED
Visual Basic
Public Const PATIENTS_SEX_NEUTERED As UInteger
Visual C++
public:
literal unsigned int PATIENTS_SEX_NEUTERED

See Also

MCdicom Structure
MCdicom Members


PATIENTS_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_SIZE Field
MCdicom Structure See Also Send Feedback
Patient's Size (0010,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_SIZE
Visual Basic
Public Const PATIENTS_SIZE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_SIZE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_SIZE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_SIZE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Patient's Size Code Sequence (0010,1021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_SIZE_CODE_SEQUENCE
Visual Basic
Public Const PATIENTS_SIZE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PATIENTS_SIZE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PATIENTS_TELECOM_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_TELECOM_INFORMATION Field
MCdicom Structure See Also Send Feedback
Patient's Telecom Information (0010,2155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_TELECOM_INFORMATION
Visual Basic
Public Const PATIENTS_TELECOM_INFORMATION As UInteger
Visual C++
public:
literal unsigned int PATIENTS_TELECOM_INFORMATION

See Also

MCdicom Structure
MCdicom Members


PATIENTS_TELEPHONE_NUMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_TELEPHONE_NUMBERS Field
MCdicom Structure See Also Send Feedback
Patient's Telephone Numbers (0010,2154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_TELEPHONE_NUMBERS
Visual Basic
Public Const PATIENTS_TELEPHONE_NUMBERS As UInteger
Visual C++
public:
literal unsigned int PATIENTS_TELEPHONE_NUMBERS

See Also

MCdicom Structure
MCdicom Members


PATIENTS_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATIENTS_WEIGHT Field
MCdicom Structure See Also Send Feedback
Patient's Weight (0010,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATIENTS_WEIGHT
Visual Basic
Public Const PATIENTS_WEIGHT As UInteger
Visual C++
public:
literal unsigned int PATIENTS_WEIGHT

See Also

MCdicom Structure
MCdicom Members


PATTERN_OFF_COLOR_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATTERN_OFF_COLOR_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Pattern Off Color CIELab Value (0070,0252)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATTERN_OFF_COLOR_CIELAB_VALUE
Visual Basic
Public Const PATTERN_OFF_COLOR_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int PATTERN_OFF_COLOR_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


PATTERN_OFF_OPACITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATTERN_OFF_OPACITY Field
MCdicom Structure See Also Send Feedback
Pattern Off Opacity (0070,0285)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATTERN_OFF_OPACITY
Visual Basic
Public Const PATTERN_OFF_OPACITY As UInteger
Visual C++
public:
literal unsigned int PATTERN_OFF_OPACITY

See Also

MCdicom Structure
MCdicom Members


PATTERN_ON_COLOR_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATTERN_ON_COLOR_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Pattern On Color CIELab Value (0070,0251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATTERN_ON_COLOR_CIELAB_VALUE
Visual Basic
Public Const PATTERN_ON_COLOR_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int PATTERN_ON_COLOR_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


PATTERN_ON_OPACITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PATTERN_ON_OPACITY Field
MCdicom Structure See Also Send Feedback
Pattern On Opacity (0070,0284)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PATTERN_ON_OPACITY
Visual Basic
Public Const PATTERN_ON_OPACITY As UInteger
Visual C++
public:
literal unsigned int PATTERN_ON_OPACITY

See Also

MCdicom Structure
MCdicom Members


PAUSE_BETWEEN_FRAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PAUSE_BETWEEN_FRAMES Field
MCdicom Structure See Also Send Feedback
Pause Between Frames (0054,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PAUSE_BETWEEN_FRAMES
Visual Basic
Public Const PAUSE_BETWEEN_FRAMES As UInteger
Visual C++
public:
literal unsigned int PAUSE_BETWEEN_FRAMES

See Also

MCdicom Structure
MCdicom Members


PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Per-frame Functional Groups Sequence (5200,9230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE
Visual Basic
Public Const PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PER_FRAME_FUNCTIONAL_GROUPS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PER_PROJECTION_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PER_PROJECTION_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Per Projection Acquisition Sequence (0018,9538)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PER_PROJECTION_ACQUISITION_SEQUENCE
Visual Basic
Public Const PER_PROJECTION_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PER_PROJECTION_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERCENT_PHASE_FIELD_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERCENT_PHASE_FIELD_OF_VIEW Field
MCdicom Structure See Also Send Feedback
Percent Phase Field of View (0018,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERCENT_PHASE_FIELD_OF_VIEW
Visual Basic
Public Const PERCENT_PHASE_FIELD_OF_VIEW As UInteger
Visual C++
public:
literal unsigned int PERCENT_PHASE_FIELD_OF_VIEW

See Also

MCdicom Structure
MCdicom Members


PERCENT_SAMPLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERCENT_SAMPLING Field
MCdicom Structure See Also Send Feedback
Percent Sampling (0018,0093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERCENT_SAMPLING
Visual Basic
Public Const PERCENT_SAMPLING As UInteger
Visual C++
public:
literal unsigned int PERCENT_SAMPLING

See Also

MCdicom Structure
MCdicom Members


PERFORMED_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_LOCATION Field
MCdicom Structure See Also Send Feedback
Performed Location (0040,0243)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_LOCATION
Visual Basic
Public Const PERFORMED_LOCATION As UInteger
Visual C++
public:
literal unsigned int PERFORMED_LOCATION

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Procedure Code Sequence (0040,A372)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Description (0040,0254)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_DESCRIPTION
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Discontinuation Reason Code Sequence (0040,0281)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_END_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_END_DATE Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step End Date (0040,0250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_END_DATE
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_END_DATE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_END_DATE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_END_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_END_DATETIME Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step End DateTime (0040,4051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_END_DATETIME
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_END_DATETIME As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_END_DATETIME

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_END_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_END_TIME Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step End Time (0040,0251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_END_TIME
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_END_TIME As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_END_TIME

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_ID Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step ID (0040,0253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_ID
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_ID As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_ID

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_START_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_START_DATE Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Start Date (0040,0244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_START_DATE
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_START_DATE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_START_DATE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_START_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_START_DATETIME Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Start DateTime (0040,4050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_START_DATETIME
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_START_DATETIME As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_START_DATETIME

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_START_TIME Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Start Time (0040,0245)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_START_TIME
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_START_TIME As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_START_TIME

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_STEP_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_STEP_STATUS Field
MCdicom Structure See Also Send Feedback
Performed Procedure Step Status (0040,0252)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_STEP_STATUS
Visual Basic
Public Const PERFORMED_PROCEDURE_STEP_STATUS As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_STEP_STATUS

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCEDURE_TYPE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCEDURE_TYPE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Performed Procedure Type Description (0040,0255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCEDURE_TYPE_DESCRIPTION
Visual Basic
Public Const PERFORMED_PROCEDURE_TYPE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCEDURE_TYPE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Performed Processing Applications Code Sequence RETIRED (0040,4007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROCESSING_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROCESSING_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Processing Parameters Sequence (0074,1212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROCESSING_PARAMETERS_SEQUENCE
Visual Basic
Public Const PERFORMED_PROCESSING_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROCESSING_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROTOCOL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROTOCOL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Protocol Code Sequence (0040,0260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROTOCOL_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_PROTOCOL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROTOCOL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_PROTOCOL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_PROTOCOL_TYPE Field
MCdicom Structure See Also Send Feedback
Performed Protocol Type (0040,0261)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_PROTOCOL_TYPE
Visual Basic
Public Const PERFORMED_PROTOCOL_TYPE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_PROTOCOL_TYPE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_SERIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_SERIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Series Sequence (0040,0340)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_SERIES_SEQUENCE
Visual Basic
Public Const PERFORMED_SERIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_SERIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_STATION_AE_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_STATION_AE_TITLE Field
MCdicom Structure See Also Send Feedback
Performed Station AE Title (0040,0241)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_STATION_AE_TITLE
Visual Basic
Public Const PERFORMED_STATION_AE_TITLE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_STATION_AE_TITLE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_STATION_CLASS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_STATION_CLASS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Station Class Code Sequence (0040,4029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_STATION_CLASS_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_STATION_CLASS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_STATION_CLASS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Station Geographic Location Code Sequence (0040,4030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_STATION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_STATION_NAME Field
MCdicom Structure See Also Send Feedback
Performed Station Name (0040,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_STATION_NAME
Visual Basic
Public Const PERFORMED_STATION_NAME As UInteger
Visual C++
public:
literal unsigned int PERFORMED_STATION_NAME

See Also

MCdicom Structure
MCdicom Members


PERFORMED_STATION_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_STATION_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Station Name Code Sequence (0040,4028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_STATION_NAME_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_STATION_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_STATION_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMED_WORKITEM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMED_WORKITEM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performed Workitem Code Sequence (0040,4019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMED_WORKITEM_CODE_SEQUENCE
Visual Basic
Public Const PERFORMED_WORKITEM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMED_WORKITEM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Performing Physician Identification Sequence (0008,1052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERFORMING_PHYSICIANS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERFORMING_PHYSICIANS_NAME Field
MCdicom Structure See Also Send Feedback
Performing Physician's Name (0008,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERFORMING_PHYSICIANS_NAME
Visual Basic
Public Const PERFORMING_PHYSICIANS_NAME As UInteger
Visual C++
public:
literal unsigned int PERFORMING_PHYSICIANS_NAME

See Also

MCdicom Structure
MCdicom Members


PERSON_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERSON_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Person Identification Code Sequence (0040,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERSON_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const PERSON_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERSON_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERSON_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERSON_NAME Field
MCdicom Structure See Also Send Feedback
Person Name (0040,A123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERSON_NAME
Visual Basic
Public Const PERSON_NAME As UInteger
Visual C++
public:
literal unsigned int PERSON_NAME

See Also

MCdicom Structure
MCdicom Members


PERSONS_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERSONS_ADDRESS Field
MCdicom Structure See Also Send Feedback
Person's Address (0040,1102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERSONS_ADDRESS
Visual Basic
Public Const PERSONS_ADDRESS As UInteger
Visual C++
public:
literal unsigned int PERSONS_ADDRESS

See Also

MCdicom Structure
MCdicom Members


PERSONS_TELECOM_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERSONS_TELECOM_INFORMATION Field
MCdicom Structure See Also Send Feedback
Person's Telecom Information (0040,1104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERSONS_TELECOM_INFORMATION
Visual Basic
Public Const PERSONS_TELECOM_INFORMATION As UInteger
Visual C++
public:
literal unsigned int PERSONS_TELECOM_INFORMATION

See Also

MCdicom Structure
MCdicom Members


PERSONS_TELEPHONE_NUMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERSONS_TELEPHONE_NUMBERS Field
MCdicom Structure See Also Send Feedback
Person's Telephone Numbers (0040,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERSONS_TELEPHONE_NUMBERS
Visual Basic
Public Const PERSONS_TELEPHONE_NUMBERS As UInteger
Visual C++
public:
literal unsigned int PERSONS_TELEPHONE_NUMBERS

See Also

MCdicom Structure
MCdicom Members


PERTINENT_DOCUMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_DOCUMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pertinent Documents Sequence (0038,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_DOCUMENTS_SEQUENCE
Visual Basic
Public Const PERTINENT_DOCUMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERTINENT_DOCUMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERTINENT_OTHER_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_OTHER_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pertinent Other Evidence Sequence (0040,A385)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_OTHER_EVIDENCE_SEQUENCE
Visual Basic
Public Const PERTINENT_OTHER_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERTINENT_OTHER_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERTINENT_PRIOR_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_PRIOR_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag CURRENT_REQUESTED_PROCEDURE_EVIDENCE_SEQUENCE (0040,A385)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_PRIOR_EVIDENCE_SEQUENCE
Visual Basic
Public Const PERTINENT_PRIOR_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERTINENT_PRIOR_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERTINENT_RESOURCES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_RESOURCES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pertinent Resources Sequence (0038,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_RESOURCES_SEQUENCE
Visual Basic
Public Const PERTINENT_RESOURCES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PERTINENT_RESOURCES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PERTINENT_SOP_CLASSES_IN_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_SOP_CLASSES_IN_SERIES Field
MCdicom Structure See Also Send Feedback
Pertinent SOP Classes in Series (3010,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_SOP_CLASSES_IN_SERIES
Visual Basic
Public Const PERTINENT_SOP_CLASSES_IN_SERIES As UInteger
Visual C++
public:
literal unsigned int PERTINENT_SOP_CLASSES_IN_SERIES

See Also

MCdicom Structure
MCdicom Members


PERTINENT_SOP_CLASSES_IN_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PERTINENT_SOP_CLASSES_IN_STUDY Field
MCdicom Structure See Also Send Feedback
Pertinent SOP Classes in Study (3010,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PERTINENT_SOP_CLASSES_IN_STUDY
Visual Basic
Public Const PERTINENT_SOP_CLASSES_IN_STUDY As UInteger
Visual C++
public:
literal unsigned int PERTINENT_SOP_CLASSES_IN_STUDY

See Also

MCdicom Structure
MCdicom Members


PET_DETECTOR_MOTION_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_DETECTOR_MOTION_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Detector Motion Details Sequence (0018,9733)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_DETECTOR_MOTION_DETAILS_SEQUENCE
Visual Basic
Public Const PET_DETECTOR_MOTION_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_DETECTOR_MOTION_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_FRAME_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_FRAME_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Frame Acquisition Sequence (0018,9732)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_FRAME_ACQUISITION_SEQUENCE
Visual Basic
Public Const PET_FRAME_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_FRAME_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_FRAME_CORRECTION_FACTORS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_FRAME_CORRECTION_FACTORS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Frame Correction Factors Sequence (0018,9736)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_FRAME_CORRECTION_FACTORS_SEQUENCE
Visual Basic
Public Const PET_FRAME_CORRECTION_FACTORS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_FRAME_CORRECTION_FACTORS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Frame Type Sequence (0018,9751)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const PET_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Position Sequence (0018,9735)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_POSITION_SEQUENCE
Visual Basic
Public Const PET_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_RECONSTRUCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_RECONSTRUCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Reconstruction Sequence (0018,9749)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_RECONSTRUCTION_SEQUENCE
Visual Basic
Public Const PET_RECONSTRUCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_RECONSTRUCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PET_TABLE_DYNAMICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PET_TABLE_DYNAMICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PET Table Dynamics Sequence (0018,9734)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PET_TABLE_DYNAMICS_SEQUENCE
Visual Basic
Public Const PET_TABLE_DYNAMICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PET_TABLE_DYNAMICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PHANTOM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHANTOM_TYPE Field
MCdicom Structure See Also Send Feedback
Phantom Type (4010,1046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHANTOM_TYPE
Visual Basic
Public Const PHANTOM_TYPE As UInteger
Visual C++
public:
literal unsigned int PHANTOM_TYPE

See Also

MCdicom Structure
MCdicom Members


PHASE_CONTRAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_CONTRAST Field
MCdicom Structure See Also Send Feedback
Phase Contrast (0018,9014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_CONTRAST
Visual Basic
Public Const PHASE_CONTRAST As UInteger
Visual C++
public:
literal unsigned int PHASE_CONTRAST

See Also

MCdicom Structure
MCdicom Members


PHASE_DELAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_DELAY Field
MCdicom Structure See Also Send Feedback
Phase Delay (0054,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_DELAY
Visual Basic
Public Const PHASE_DELAY As UInteger
Visual C++
public:
literal unsigned int PHASE_DELAY

See Also

MCdicom Structure
MCdicom Members


PHASE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Phase Description (0054,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_DESCRIPTION
Visual Basic
Public Const PHASE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PHASE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PHASE_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Phase Information Sequence (0054,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_INFORMATION_SEQUENCE
Visual Basic
Public Const PHASE_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PHASE_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PHASE_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Phase Number RETIRED (0020,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_NUMBER_RETIRED
Visual Basic
Public Const PHASE_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int PHASE_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


PHASE_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHASE_VECTOR Field
MCdicom Structure See Also Send Feedback
Phase Vector (0054,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHASE_VECTOR
Visual Basic
Public Const PHASE_VECTOR As UInteger
Visual C++
public:
literal unsigned int PHASE_VECTOR

See Also

MCdicom Structure
MCdicom Members


PHOSPHOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOSPHOR_TYPE Field
MCdicom Structure See Also Send Feedback
Phosphor Type (0018,1261)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOSPHOR_TYPE
Visual Basic
Public Const PHOSPHOR_TYPE As UInteger
Visual C++
public:
literal unsigned int PHOSPHOR_TYPE

See Also

MCdicom Structure
MCdicom Members


PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Photoacoustic Excitation Characteristics Sequence (0018,9821)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Photoacoustic Image Frame Type Sequence (0018,9835)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PHOTOACOUSTIC_IMAGE_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PHOTOGRAPHIC_EXPOSURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOGRAPHIC_EXPOSURE_INDEX Field
MCdicom Structure See Also Send Feedback
Photographic Exposure Index (0016,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOGRAPHIC_EXPOSURE_INDEX
Visual Basic
Public Const PHOTOGRAPHIC_EXPOSURE_INDEX As UInteger
Visual C++
public:
literal unsigned int PHOTOGRAPHIC_EXPOSURE_INDEX

See Also

MCdicom Structure
MCdicom Members


PHOTOGRAPHIC_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOGRAPHIC_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Photographic Sensitivity (0016,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOGRAPHIC_SENSITIVITY
Visual Basic
Public Const PHOTOGRAPHIC_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int PHOTOGRAPHIC_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


PHOTOMETRIC_INTERPRETATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOMETRIC_INTERPRETATION Field
MCdicom Structure See Also Send Feedback
Photometric Interpretation (0028,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOMETRIC_INTERPRETATION
Visual Basic
Public Const PHOTOMETRIC_INTERPRETATION As UInteger
Visual C++
public:
literal unsigned int PHOTOMETRIC_INTERPRETATION

See Also

MCdicom Structure
MCdicom Members


PHOTON_ENERGY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTON_ENERGY Field
MCdicom Structure See Also Send Feedback
Photon Energy (0018,9383)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTON_ENERGY
Visual Basic
Public Const PHOTON_ENERGY As UInteger
Visual C++
public:
literal unsigned int PHOTON_ENERGY

See Also

MCdicom Structure
MCdicom Members


PHOTOTIMER_SETTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHOTOTIMER_SETTING Field
MCdicom Structure See Also Send Feedback
Phototimer Setting (0018,7065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHOTOTIMER_SETTING
Visual Basic
Public Const PHOTOTIMER_SETTING As UInteger
Visual C++
public:
literal unsigned int PHOTOTIMER_SETTING

See Also

MCdicom Structure
MCdicom Members


PHYSICAL_DELTA_X Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICAL_DELTA_X Field
MCdicom Structure See Also Send Feedback
Physical Delta X (0018,602C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICAL_DELTA_X
Visual Basic
Public Const PHYSICAL_DELTA_X As UInteger
Visual C++
public:
literal unsigned int PHYSICAL_DELTA_X

See Also

MCdicom Structure
MCdicom Members


PHYSICAL_DELTA_Y Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICAL_DELTA_Y Field
MCdicom Structure See Also Send Feedback
Physical Delta Y (0018,602E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICAL_DELTA_Y
Visual Basic
Public Const PHYSICAL_DELTA_Y As UInteger
Visual C++
public:
literal unsigned int PHYSICAL_DELTA_Y

See Also

MCdicom Structure
MCdicom Members


PHYSICAL_DETECTOR_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICAL_DETECTOR_SIZE Field
MCdicom Structure See Also Send Feedback
Physical Detector Size (0018,9429)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICAL_DETECTOR_SIZE
Visual Basic
Public Const PHYSICAL_DETECTOR_SIZE As UInteger
Visual C++
public:
literal unsigned int PHYSICAL_DETECTOR_SIZE

See Also

MCdicom Structure
MCdicom Members


PHYSICAL_UNITS_X_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICAL_UNITS_X_DIRECTION Field
MCdicom Structure See Also Send Feedback
Physical Units X Direction (0018,6024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICAL_UNITS_X_DIRECTION
Visual Basic
Public Const PHYSICAL_UNITS_X_DIRECTION As UInteger
Visual C++
public:
literal unsigned int PHYSICAL_UNITS_X_DIRECTION

See Also

MCdicom Structure
MCdicom Members


PHYSICAL_UNITS_Y_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICAL_UNITS_Y_DIRECTION Field
MCdicom Structure See Also Send Feedback
Physical Units Y Direction (0018,6026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICAL_UNITS_Y_DIRECTION
Visual Basic
Public Const PHYSICAL_UNITS_Y_DIRECTION As UInteger
Visual C++
public:
literal unsigned int PHYSICAL_UNITS_Y_DIRECTION

See Also

MCdicom Structure
MCdicom Members


PHYSICIAN_APPROVING_INTERPRETATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICIAN_APPROVING_INTERPRETATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Physician Approving Interpretation RETIRED (4008,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICIAN_APPROVING_INTERPRETATION_RETIRED
Visual Basic
Public Const PHYSICIAN_APPROVING_INTERPRETATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int PHYSICIAN_APPROVING_INTERPRETATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


PHYSICIANS_OF_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICIANS_OF_RECORD Field
MCdicom Structure See Also Send Feedback
Physician(s) of Record (0008,1048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICIANS_OF_RECORD
Visual Basic
Public Const PHYSICIANS_OF_RECORD As UInteger
Visual C++
public:
literal unsigned int PHYSICIANS_OF_RECORD

See Also

MCdicom Structure
MCdicom Members


PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Physician(s) of Record Identification Sequence (0008,1049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PHYSICIANS_OF_RECORD_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Physician(s) Reading Study Identification Sequence (0008,1062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PHYSICIANS_READING_STUDY_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_ASPECT_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_ASPECT_RATIO Field
MCdicom Structure See Also Send Feedback
Pixel Aspect Ratio (0028,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_ASPECT_RATIO
Visual Basic
Public Const PIXEL_ASPECT_RATIO As UInteger
Visual C++
public:
literal unsigned int PIXEL_ASPECT_RATIO

See Also

MCdicom Structure
MCdicom Members


PIXEL_BANDWIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_BANDWIDTH Field
MCdicom Structure See Also Send Feedback
Pixel Bandwidth (0018,0095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_BANDWIDTH
Visual Basic
Public Const PIXEL_BANDWIDTH As UInteger
Visual C++
public:
literal unsigned int PIXEL_BANDWIDTH

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_DATA_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_DATA_TYPE Field
MCdicom Structure See Also Send Feedback
Pixel Component Data Type (0018,604E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_DATA_TYPE
Visual Basic
Public Const PIXEL_COMPONENT_DATA_TYPE As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_DATA_TYPE

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_MASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_MASK Field
MCdicom Structure See Also Send Feedback
Pixel Component Mask (0018,6046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_MASK
Visual Basic
Public Const PIXEL_COMPONENT_MASK As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_MASK

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Pixel Component Organization (0018,6044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_ORGANIZATION
Visual Basic
Public Const PIXEL_COMPONENT_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_PHYSICAL_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_PHYSICAL_UNITS Field
MCdicom Structure See Also Send Feedback
Pixel Component Physical Units (0018,604C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_PHYSICAL_UNITS
Visual Basic
Public Const PIXEL_COMPONENT_PHYSICAL_UNITS As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_PHYSICAL_UNITS

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_RANGE_START Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_RANGE_START Field
MCdicom Structure See Also Send Feedback
Pixel Component Range Start (0018,6048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_RANGE_START
Visual Basic
Public Const PIXEL_COMPONENT_RANGE_START As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_RANGE_START

See Also

MCdicom Structure
MCdicom Members


PIXEL_COMPONENT_RANGE_STOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COMPONENT_RANGE_STOP Field
MCdicom Structure See Also Send Feedback
Pixel Component Range Stop (0018,604A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COMPONENT_RANGE_STOP
Visual Basic
Public Const PIXEL_COMPONENT_RANGE_STOP As UInteger
Visual C++
public:
literal unsigned int PIXEL_COMPONENT_RANGE_STOP

See Also

MCdicom Structure
MCdicom Members


PIXEL_COORDINATES_SET_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_COORDINATES_SET_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Pixel Coordinates Set (Trial) RETIRED (0040,A29A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_COORDINATES_SET_TRIAL_RETIRED
Visual Basic
Public Const PIXEL_COORDINATES_SET_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int PIXEL_COORDINATES_SET_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


PIXEL_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_DATA Field
MCdicom Structure See Also Send Feedback
Pixel Data (7FE0,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_DATA
Visual Basic
Public Const PIXEL_DATA As UInteger
Visual C++
public:
literal unsigned int PIXEL_DATA

See Also

MCdicom Structure
MCdicom Members


PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV Field
MCdicom Structure See Also Send Feedback
Pixel Data Area Origin Relative To FOV (0018,7036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV
Visual Basic
Public Const PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV As UInteger
Visual C++
public:
literal unsigned int PIXEL_DATA_AREA_ORIGIN_RELATIVE_TO_FOV

See Also

MCdicom Structure
MCdicom Members


PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV Field
MCdicom Structure See Also Send Feedback
Pixel Data Area Rotation Angle Relative To FOV (0018,7038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV
Visual Basic
Public Const PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV As UInteger
Visual C++
public:
literal unsigned int PIXEL_DATA_AREA_ROTATION_ANGLE_RELATIVE_TO_FOV

See Also

MCdicom Structure
MCdicom Members


PIXEL_DATA_PROVIDER_URL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_DATA_PROVIDER_URL Field
MCdicom Structure See Also Send Feedback
Pixel Data Provider URL (0028,7FE0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_DATA_PROVIDER_URL
Visual Basic
Public Const PIXEL_DATA_PROVIDER_URL As UInteger
Visual C++
public:
literal unsigned int PIXEL_DATA_PROVIDER_URL

See Also

MCdicom Structure
MCdicom Members


PIXEL_INTENSITY_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_INTENSITY_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
Pixel Intensity Relationship (0028,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_INTENSITY_RELATIONSHIP
Visual Basic
Public Const PIXEL_INTENSITY_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int PIXEL_INTENSITY_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Intensity Relationship LUT Sequence (0028,9422)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE
Visual Basic
Public Const PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_INTENSITY_RELATIONSHIP_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_INTENSITY_RELATIONSHIP_SIGN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_INTENSITY_RELATIONSHIP_SIGN Field
MCdicom Structure See Also Send Feedback
Pixel Intensity Relationship Sign (0028,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_INTENSITY_RELATIONSHIP_SIGN
Visual Basic
Public Const PIXEL_INTENSITY_RELATIONSHIP_SIGN As UInteger
Visual C++
public:
literal unsigned int PIXEL_INTENSITY_RELATIONSHIP_SIGN

See Also

MCdicom Structure
MCdicom Members


PIXEL_MEASURES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_MEASURES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Measures Sequence (0028,9110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_MEASURES_SEQUENCE
Visual Basic
Public Const PIXEL_MEASURES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_MEASURES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_ORIGIN_INTERPRETATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_ORIGIN_INTERPRETATION Field
MCdicom Structure See Also Send Feedback
Pixel Origin Interpretation (0048,0301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_ORIGIN_INTERPRETATION
Visual Basic
Public Const PIXEL_ORIGIN_INTERPRETATION As UInteger
Visual C++
public:
literal unsigned int PIXEL_ORIGIN_INTERPRETATION

See Also

MCdicom Structure
MCdicom Members


PIXEL_PADDING_RANGE_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_PADDING_RANGE_LIMIT Field
MCdicom Structure See Also Send Feedback
Pixel Padding Range Limit (0028,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_PADDING_RANGE_LIMIT
Visual Basic
Public Const PIXEL_PADDING_RANGE_LIMIT As UInteger
Visual C++
public:
literal unsigned int PIXEL_PADDING_RANGE_LIMIT

See Also

MCdicom Structure
MCdicom Members


PIXEL_PADDING_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_PADDING_VALUE Field
MCdicom Structure See Also Send Feedback
Pixel Padding Value (0028,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_PADDING_VALUE
Visual Basic
Public Const PIXEL_PADDING_VALUE As UInteger
Visual C++
public:
literal unsigned int PIXEL_PADDING_VALUE

See Also

MCdicom Structure
MCdicom Members


PIXEL_PRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_PRESENTATION Field
MCdicom Structure See Also Send Feedback
Pixel Presentation (0008,9205)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_PRESENTATION
Visual Basic
Public Const PIXEL_PRESENTATION As UInteger
Visual C++
public:
literal unsigned int PIXEL_PRESENTATION

See Also

MCdicom Structure
MCdicom Members


PIXEL_REPRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_REPRESENTATION Field
MCdicom Structure See Also Send Feedback
Pixel Representation (0028,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_REPRESENTATION
Visual Basic
Public Const PIXEL_REPRESENTATION As UInteger
Visual C++
public:
literal unsigned int PIXEL_REPRESENTATION

See Also

MCdicom Structure
MCdicom Members


PIXEL_SHIFT_FRAME_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SHIFT_FRAME_RANGE Field
MCdicom Structure See Also Send Feedback
Pixel Shift Frame Range (0028,9506)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SHIFT_FRAME_RANGE
Visual Basic
Public Const PIXEL_SHIFT_FRAME_RANGE As UInteger
Visual C++
public:
literal unsigned int PIXEL_SHIFT_FRAME_RANGE

See Also

MCdicom Structure
MCdicom Members


PIXEL_SHIFT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SHIFT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Shift Sequence (0028,9501)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SHIFT_SEQUENCE
Visual Basic
Public Const PIXEL_SHIFT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_SHIFT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Pixel Spacing (0028,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SPACING
Visual Basic
Public Const PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


PIXEL_SPACING_CALIBRATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SPACING_CALIBRATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Pixel Spacing Calibration Description (0028,0A04)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SPACING_CALIBRATION_DESCRIPTION
Visual Basic
Public Const PIXEL_SPACING_CALIBRATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PIXEL_SPACING_CALIBRATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PIXEL_SPACING_CALIBRATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SPACING_CALIBRATION_TYPE Field
MCdicom Structure See Also Send Feedback
Pixel Spacing Calibration Type (0028,0A02)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SPACING_CALIBRATION_TYPE
Visual Basic
Public Const PIXEL_SPACING_CALIBRATION_TYPE As UInteger
Visual C++
public:
literal unsigned int PIXEL_SPACING_CALIBRATION_TYPE

See Also

MCdicom Structure
MCdicom Members


PIXEL_SPACING_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_SPACING_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Pixel Spacing Sequence RETIRED (0040,08D8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_SPACING_SEQUENCE_RETIRED
Visual Basic
Public Const PIXEL_SPACING_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PIXEL_SPACING_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PIXEL_VALUE_MAPPING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_VALUE_MAPPING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Value Mapping Code Sequence (0040,9098)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_VALUE_MAPPING_CODE_SEQUENCE
Visual Basic
Public Const PIXEL_VALUE_MAPPING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_VALUE_MAPPING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_VALUE_MAPPING_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_VALUE_MAPPING_EXPLANATION Field
MCdicom Structure See Also Send Feedback
Pixel Value Mapping Explanation (0022,1454)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_VALUE_MAPPING_EXPLANATION
Visual Basic
Public Const PIXEL_VALUE_MAPPING_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int PIXEL_VALUE_MAPPING_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Value Mapping to Coded Concept Sequence (0022,1450)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE
Visual Basic
Public Const PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_VALUE_MAPPING_TO_CODED_CONCEPT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PIXEL_VALUE_TRANSFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PIXEL_VALUE_TRANSFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pixel Value Transformation Sequence (0028,9145)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PIXEL_VALUE_TRANSFORMATION_SEQUENCE
Visual Basic
Public Const PIXEL_VALUE_TRANSFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PIXEL_VALUE_TRANSFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST Field
MCdicom Structure See Also Send Feedback
Placer Order Number / Imaging Service Request (0040,2016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST
Visual Basic
Public Const PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST As UInteger
Visual C++
public:
literal unsigned int PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST

See Also

MCdicom Structure
MCdicom Members


PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED Field
MCdicom Structure See Also Send Feedback
Placer Order Number Imaging Service Request (Retired) (0040,2006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED
Visual Basic
Public Const PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED As UInteger
Visual C++
public:
literal unsigned int PLACER_ORDER_NUMBER_IMAGING_SERVICE_REQUEST_RETIRED

See Also

MCdicom Structure
MCdicom Members


PLACER_ORDER_NUMBER_PROCEDURE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLACER_ORDER_NUMBER_PROCEDURE_RETIRED Field
MCdicom Structure See Also Send Feedback
Placer Order Number / Procedure RETIRED (0040,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLACER_ORDER_NUMBER_PROCEDURE_RETIRED
Visual Basic
Public Const PLACER_ORDER_NUMBER_PROCEDURE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PLACER_ORDER_NUMBER_PROCEDURE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PLAN_INTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLAN_INTENT Field
MCdicom Structure See Also Send Feedback
Plan Intent (300A,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLAN_INTENT
Visual Basic
Public Const PLAN_INTENT As UInteger
Visual C++
public:
literal unsigned int PLAN_INTENT

See Also

MCdicom Structure
MCdicom Members


PLAN_OVERVIEW_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLAN_OVERVIEW_INDEX Field
MCdicom Structure See Also Send Feedback
Plan Overview Index (300C,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLAN_OVERVIEW_INDEX
Visual Basic
Public Const PLAN_OVERVIEW_INDEX As UInteger
Visual C++
public:
literal unsigned int PLAN_OVERVIEW_INDEX

See Also

MCdicom Structure
MCdicom Members


PLAN_OVERVIEW_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLAN_OVERVIEW_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plan Overview Sequence (300C,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLAN_OVERVIEW_SEQUENCE
Visual Basic
Public Const PLAN_OVERVIEW_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLAN_OVERVIEW_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANAR_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANAR_CONFIGURATION Field
MCdicom Structure See Also Send Feedback
Planar Configuration (0028,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANAR_CONFIGURATION
Visual Basic
Public Const PLANAR_CONFIGURATION As UInteger
Visual C++
public:
literal unsigned int PLANAR_CONFIGURATION

See Also

MCdicom Structure
MCdicom Members


PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE Field
MCdicom Structure See Also Send Feedback
Plane (0070,1305)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE
Visual Basic
Public Const PLANE As UInteger
Visual C++
public:
literal unsigned int PLANE

See Also

MCdicom Structure
MCdicom Members


PLANE_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_IDENTIFICATION Field
MCdicom Structure See Also Send Feedback
Plane Identification (0018,9457)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_IDENTIFICATION
Visual Basic
Public Const PLANE_IDENTIFICATION As UInteger
Visual C++
public:
literal unsigned int PLANE_IDENTIFICATION

See Also

MCdicom Structure
MCdicom Members


PLANE_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_NORMAL Field
MCdicom Structure See Also Send Feedback
Plane Normal (0070,1306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_NORMAL
Visual Basic
Public Const PLANE_NORMAL As UInteger
Visual C++
public:
literal unsigned int PLANE_NORMAL

See Also

MCdicom Structure
MCdicom Members


PLANE_ORIENTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_ORIENTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plane Orientation Sequence (0020,9116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_ORIENTATION_SEQUENCE
Visual Basic
Public Const PLANE_ORIENTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_ORIENTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANE_ORIENTATION_VOLEME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_ORIENTATION_VOLEME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag PLANE_ORIENTATION_VOLUME_SEQUENCE (0020,930F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_ORIENTATION_VOLEME_SEQUENCE
Visual Basic
Public Const PLANE_ORIENTATION_VOLEME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_ORIENTATION_VOLEME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANE_ORIENTATION_VOLUME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_ORIENTATION_VOLUME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plane Orientation (Volume) Sequence (0020,930F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_ORIENTATION_VOLUME_SEQUENCE
Visual Basic
Public Const PLANE_ORIENTATION_VOLUME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_ORIENTATION_VOLUME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plane Position Sequence (0020,9113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_POSITION_SEQUENCE
Visual Basic
Public Const PLANE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANE_POSITION_SLIDE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_POSITION_SLIDE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plane Position (Slide) Sequence (0048,021A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_POSITION_SLIDE_SEQUENCE
Visual Basic
Public Const PLANE_POSITION_SLIDE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_POSITION_SLIDE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANE_POSITION_VOLUME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANE_POSITION_VOLUME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Plane Position (Volume) Sequence (0020,930E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANE_POSITION_VOLUME_SEQUENCE
Visual Basic
Public Const PLANE_POSITION_VOLUME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANE_POSITION_VOLUME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANES_IN_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANES_IN_ACQUISITION Field
MCdicom Structure See Also Send Feedback
Planes in Acquisition (0018,9410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANES_IN_ACQUISITION
Visual Basic
Public Const PLANES_IN_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int PLANES_IN_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


PLANES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANES_RETIRED Field
MCdicom Structure See Also Send Feedback
Planes RETIRED (0028,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANES_RETIRED
Visual Basic
Public Const PLANES_RETIRED As UInteger
Visual C++
public:
literal unsigned int PLANES_RETIRED

See Also

MCdicom Structure
MCdicom Members


PLANNED_VERIFICATION_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNED_VERIFICATION_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planned Verification Image Sequence (300A,00CA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNED_VERIFICATION_IMAGE_SEQUENCE
Visual Basic
Public Const PLANNED_VERIFICATION_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNED_VERIFICATION_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANNING_INPUT_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_INPUT_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planning Input Information Sequence (3010,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_INPUT_INFORMATION_SEQUENCE
Visual Basic
Public Const PLANNING_INPUT_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNING_INPUT_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Planning Landmark Description (0068,6540)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_DESCRIPTION
Visual Basic
Public Const PLANNING_LANDMARK_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_ID Field
MCdicom Structure See Also Send Feedback
Planning Landmark ID (0068,6530)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_ID
Visual Basic
Public Const PLANNING_LANDMARK_ID As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_ID

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planning Landmark Identification Code Sequence (0068,6545)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_LINE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_LINE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planning Landmark Line Sequence (0068,6510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_LINE_SEQUENCE
Visual Basic
Public Const PLANNING_LANDMARK_LINE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_LINE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_PLANE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_PLANE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planning Landmark Plane Sequence (0068,6520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_PLANE_SEQUENCE
Visual Basic
Public Const PLANNING_LANDMARK_PLANE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_PLANE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLANNING_LANDMARK_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLANNING_LANDMARK_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Planning Landmark Point Sequence (0068,6500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLANNING_LANDMARK_POINT_SEQUENCE
Visual Basic
Public Const PLANNING_LANDMARK_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PLANNING_LANDMARK_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PLATE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLATE_ID Field
MCdicom Structure See Also Send Feedback
Plate ID (0018,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLATE_ID
Visual Basic
Public Const PLATE_ID As UInteger
Visual C++
public:
literal unsigned int PLATE_ID

See Also

MCdicom Structure
MCdicom Members


PLATE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PLATE_TYPE Field
MCdicom Structure See Also Send Feedback
Plate Type (0018,1260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PLATE_TYPE
Visual Basic
Public Const PLATE_TYPE As UInteger
Visual C++
public:
literal unsigned int PLATE_TYPE

See Also

MCdicom Structure
MCdicom Members


POINT_COORDINATES_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POINT_COORDINATES_DATA Field
MCdicom Structure See Also Send Feedback
Point Coordinates Data (0066,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POINT_COORDINATES_DATA
Visual Basic
Public Const POINT_COORDINATES_DATA As UInteger
Visual C++
public:
literal unsigned int POINT_COORDINATES_DATA

See Also

MCdicom Structure
MCdicom Members


POINT_POSITION_ACCURACY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POINT_POSITION_ACCURACY Field
MCdicom Structure See Also Send Feedback
Point Position Accuracy (0066,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POINT_POSITION_ACCURACY
Visual Basic
Public Const POINT_POSITION_ACCURACY As UInteger
Visual C++
public:
literal unsigned int POINT_POSITION_ACCURACY

See Also

MCdicom Structure
MCdicom Members


POINTS_BOUNDING_BOX_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POINTS_BOUNDING_BOX_COORDINATES Field
MCdicom Structure See Also Send Feedback
Points Bounding Box Coordinates (0066,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POINTS_BOUNDING_BOX_COORDINATES
Visual Basic
Public Const POINTS_BOUNDING_BOX_COORDINATES As UInteger
Visual C++
public:
literal unsigned int POINTS_BOUNDING_BOX_COORDINATES

See Also

MCdicom Structure
MCdicom Members


POLARITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POLARITY Field
MCdicom Structure See Also Send Feedback
Polarity (2020,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POLARITY
Visual Basic
Public Const POLARITY As UInteger
Visual C++
public:
literal unsigned int POLARITY

See Also

MCdicom Structure
MCdicom Members


POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Position Acquisition Template Code Sequence (3002,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE
Visual Basic
Public Const POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POSITION_ACQUISITION_TEMPLATE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSITION_ACQUISITION_TEMPLATE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_ACQUISITION_TEMPLATE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Position Acquisition Template Description (3002,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_ACQUISITION_TEMPLATE_DESCRIPTION
Visual Basic
Public Const POSITION_ACQUISITION_TEMPLATE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int POSITION_ACQUISITION_TEMPLATE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


POSITION_ACQUISITION_TEMPLATE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_ACQUISITION_TEMPLATE_ID Field
MCdicom Structure See Also Send Feedback
Position Acquisition Template ID (3002,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_ACQUISITION_TEMPLATE_ID
Visual Basic
Public Const POSITION_ACQUISITION_TEMPLATE_ID As UInteger
Visual C++
public:
literal unsigned int POSITION_ACQUISITION_TEMPLATE_ID

See Also

MCdicom Structure
MCdicom Members


POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Position Acquisition Template Identification Sequence (3002,011F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSITION_ACQUISITION_TEMPLATE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_ACQUISITION_TEMPLATE_NAME Field
MCdicom Structure See Also Send Feedback
Position Acquisition Template Name (3002,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_ACQUISITION_TEMPLATE_NAME
Visual Basic
Public Const POSITION_ACQUISITION_TEMPLATE_NAME As UInteger
Visual C++
public:
literal unsigned int POSITION_ACQUISITION_TEMPLATE_NAME

See Also

MCdicom Structure
MCdicom Members


POSITION_MEASURING_DEVICE_USED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_MEASURING_DEVICE_USED Field
MCdicom Structure See Also Send Feedback
Position Measuring Device Used (0018,980C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_MEASURING_DEVICE_USED
Visual Basic
Public Const POSITION_MEASURING_DEVICE_USED As UInteger
Visual C++
public:
literal unsigned int POSITION_MEASURING_DEVICE_USED

See Also

MCdicom Structure
MCdicom Members


POSITION_OF_ISOCENTER_PROJECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_OF_ISOCENTER_PROJECTION Field
MCdicom Structure See Also Send Feedback
Position of Isocenter Projection (0018,9430)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_OF_ISOCENTER_PROJECTION
Visual Basic
Public Const POSITION_OF_ISOCENTER_PROJECTION As UInteger
Visual C++
public:
literal unsigned int POSITION_OF_ISOCENTER_PROJECTION

See Also

MCdicom Structure
MCdicom Members


POSITION_REFERENCE_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITION_REFERENCE_INDICATOR Field
MCdicom Structure See Also Send Feedback
Position Reference Indicator (0020,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITION_REFERENCE_INDICATOR
Visual Basic
Public Const POSITION_REFERENCE_INDICATOR As UInteger
Visual C++
public:
literal unsigned int POSITION_REFERENCE_INDICATOR

See Also

MCdicom Structure
MCdicom Members


POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Positioner Isocenter Detector Rotation Angle (0018,9465)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE
Visual Basic
Public Const POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_ISOCENTER_DETECTOR_ROTATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_ISOCENTER_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_ISOCENTER_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Positioner Isocenter Primary Angle (0018,9463)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_ISOCENTER_PRIMARY_ANGLE
Visual Basic
Public Const POSITIONER_ISOCENTER_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_ISOCENTER_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_ISOCENTER_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_ISOCENTER_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Positioner Isocenter Secondary Angle (0018,9464)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_ISOCENTER_SECONDARY_ANGLE
Visual Basic
Public Const POSITIONER_ISOCENTER_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_ISOCENTER_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_MOTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_MOTION Field
MCdicom Structure See Also Send Feedback
Positioner Motion (0018,1500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_MOTION
Visual Basic
Public Const POSITIONER_MOTION As UInteger
Visual C++
public:
literal unsigned int POSITIONER_MOTION

See Also

MCdicom Structure
MCdicom Members


POSITIONER_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Positioner Position Sequence (0018,9405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_POSITION_SEQUENCE
Visual Basic
Public Const POSITIONER_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Positioner Primary Angle (0018,1510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_PRIMARY_ANGLE
Visual Basic
Public Const POSITIONER_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_PRIMARY_ANGLE_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_PRIMARY_ANGLE_DIRECTION Field
MCdicom Structure See Also Send Feedback
Positioner Primary Angle Direction (0018,9559)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_PRIMARY_ANGLE_DIRECTION
Visual Basic
Public Const POSITIONER_PRIMARY_ANGLE_DIRECTION As UInteger
Visual C++
public:
literal unsigned int POSITIONER_PRIMARY_ANGLE_DIRECTION

See Also

MCdicom Structure
MCdicom Members


POSITIONER_PRIMARY_ANGLE_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_PRIMARY_ANGLE_INCREMENT Field
MCdicom Structure See Also Send Feedback
Positioner Primary Angle Increment (0018,1520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_PRIMARY_ANGLE_INCREMENT
Visual Basic
Public Const POSITIONER_PRIMARY_ANGLE_INCREMENT As UInteger
Visual C++
public:
literal unsigned int POSITIONER_PRIMARY_ANGLE_INCREMENT

See Also

MCdicom Structure
MCdicom Members


POSITIONER_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
Positioner Secondary Angle (0018,1511)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_SECONDARY_ANGLE
Visual Basic
Public Const POSITIONER_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


POSITIONER_SECONDARY_ANGLE_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_SECONDARY_ANGLE_INCREMENT Field
MCdicom Structure See Also Send Feedback
Positioner Secondary Angle Increment (0018,1521)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_SECONDARY_ANGLE_INCREMENT
Visual Basic
Public Const POSITIONER_SECONDARY_ANGLE_INCREMENT As UInteger
Visual C++
public:
literal unsigned int POSITIONER_SECONDARY_ANGLE_INCREMENT

See Also

MCdicom Structure
MCdicom Members


POSITIONER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONER_TYPE Field
MCdicom Structure See Also Send Feedback
Positioner Type (0018,1508)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONER_TYPE
Visual Basic
Public Const POSITIONER_TYPE As UInteger
Visual C++
public:
literal unsigned int POSITIONER_TYPE

See Also

MCdicom Structure
MCdicom Members


POSITIONING_LANDMARK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONING_LANDMARK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Positioning Landmark Sequence (0018,991D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONING_LANDMARK_SEQUENCE
Visual Basic
Public Const POSITIONING_LANDMARK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POSITIONING_LANDMARK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSITIONING_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIONING_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Positioning Method Code Sequence (0018,991C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIONING_METHOD_CODE_SEQUENCE
Visual Basic
Public Const POSITIONING_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POSITIONING_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSITIVE_CATCH_TRIALS_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSITIVE_CATCH_TRIALS_QUANTITY Field
MCdicom Structure See Also Send Feedback
Positive Catch Trials Quantity (0024,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSITIVE_CATCH_TRIALS_QUANTITY
Visual Basic
Public Const POSITIVE_CATCH_TRIALS_QUANTITY As UInteger
Visual C++
public:
literal unsigned int POSITIVE_CATCH_TRIALS_QUANTITY

See Also

MCdicom Structure
MCdicom Members


POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Post Deformation Matrix Registration Sequence (0064,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE
Visual Basic
Public Const POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POST_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POSTPROCESSING_FUNCTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POSTPROCESSING_FUNCTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Postprocessing Function RETIRED (0018,5021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POSTPROCESSING_FUNCTION_RETIRED
Visual Basic
Public Const POSTPROCESSING_FUNCTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int POSTPROCESSING_FUNCTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_DIAGNOSTIC_TASKS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_DIAGNOSTIC_TASKS Field
MCdicom Structure See Also Send Feedback
Potential Diagnostic Tasks (0018,990A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_DIAGNOSTIC_TASKS
Visual Basic
Public Const POTENTIAL_DIAGNOSTIC_TASKS As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_DIAGNOSTIC_TASKS

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_REASONS_FOR_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_REASONS_FOR_PROCEDURE Field
MCdicom Structure See Also Send Feedback
Potential Reasons for Procedure (0018,9908)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_REASONS_FOR_PROCEDURE
Visual Basic
Public Const POTENTIAL_REASONS_FOR_PROCEDURE As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_REASONS_FOR_PROCEDURE

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Potential Reasons for Procedure Code Sequence (0018,9909)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_REASONS_FOR_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Potential Requested Procedure Code Sequence (0018,9907)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_REQUESTED_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Potential Scheduled Protocol Code Sequence (0018,9906)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE
Visual Basic
Public Const POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_SCHEDULED_PROTOCOL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


POTENTIAL_THREAT_OBJECT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POTENTIAL_THREAT_OBJECT_ID Field
MCdicom Structure See Also Send Feedback
Potential Threat Object ID (4010,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POTENTIAL_THREAT_OBJECT_ID
Visual Basic
Public Const POTENTIAL_THREAT_OBJECT_ID As UInteger
Visual C++
public:
literal unsigned int POTENTIAL_THREAT_OBJECT_ID

See Also

MCdicom Structure
MCdicom Members


POWERLINE_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..POWERLINE_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Powerline Frequency (003A,0311)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint POWERLINE_FREQUENCY
Visual Basic
Public Const POWERLINE_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int POWERLINE_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


PPS_DISCONTINUATION_REASON_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PPS_DISCONTINUATION_REASON_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag PERFORMED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0040,0281)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PPS_DISCONTINUATION_REASON_CODE_SEQUENCE
Visual Basic
Public Const PPS_DISCONTINUATION_REASON_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PPS_DISCONTINUATION_REASON_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRE_AMPLIFIER_EQUIPMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_AMPLIFIER_EQUIPMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pre-Amplifier Equipment Sequence (0014,400E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_AMPLIFIER_EQUIPMENT_SEQUENCE
Visual Basic
Public Const PRE_AMPLIFIER_EQUIPMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRE_AMPLIFIER_EQUIPMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRE_AMPLIFIER_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_AMPLIFIER_NOTES Field
MCdicom Structure See Also Send Feedback
Pre-Amplifier Notes (0014,400F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_AMPLIFIER_NOTES
Visual Basic
Public Const PRE_AMPLIFIER_NOTES As UInteger
Visual C++
public:
literal unsigned int PRE_AMPLIFIER_NOTES

See Also

MCdicom Structure
MCdicom Members


PRE_AMPLIFIER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_AMPLIFIER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pre-Amplifier Settings Sequence (0014,4040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_AMPLIFIER_SETTINGS_SEQUENCE
Visual Basic
Public Const PRE_AMPLIFIER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRE_AMPLIFIER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pre Deformation Matrix Registration Sequence (0064,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE
Visual Basic
Public Const PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRE_DEFORMATION_MATRIX_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRE_MEDICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_MEDICATION Field
MCdicom Structure See Also Send Feedback
Pre-Medication (0040,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_MEDICATION
Visual Basic
Public Const PRE_MEDICATION As UInteger
Visual C++
public:
literal unsigned int PRE_MEDICATION

See Also

MCdicom Structure
MCdicom Members


PRE_SELECTED_FOR_IMPLANTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRE_SELECTED_FOR_IMPLANTATION Field
MCdicom Structure See Also Send Feedback
Pre-Selected for Implantation (0022,1049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRE_SELECTED_FOR_IMPLANTATION
Visual Basic
Public Const PRE_SELECTED_FOR_IMPLANTATION As UInteger
Visual C++
public:
literal unsigned int PRE_SELECTED_FOR_IMPLANTATION

See Also

MCdicom Structure
MCdicom Members


PREDECESSOR_DOCUMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREDECESSOR_DOCUMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Predecessor Documents Sequence (0040,A360)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREDECESSOR_DOCUMENTS_SEQUENCE
Visual Basic
Public Const PREDECESSOR_DOCUMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PREDECESSOR_DOCUMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PREDECESSOR_PROTOCOL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREDECESSOR_PROTOCOL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Predecessor Protocol Sequence (0018,990E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREDECESSOR_PROTOCOL_SEQUENCE
Visual Basic
Public Const PREDECESSOR_PROTOCOL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PREDECESSOR_PROTOCOL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PREDECESSOR_STRUCTURE_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREDECESSOR_STRUCTURE_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Predecessor Structure Set Sequence (3006,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREDECESSOR_STRUCTURE_SET_SEQUENCE
Visual Basic
Public Const PREDECESSOR_STRUCTURE_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PREDECESSOR_STRUCTURE_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PREDICTED_REFRACTIVE_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREDICTED_REFRACTIVE_ERROR Field
MCdicom Structure See Also Send Feedback
Predicted Refractive Error (0022,1054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREDICTED_REFRACTIVE_ERROR
Visual Basic
Public Const PREDICTED_REFRACTIVE_ERROR As UInteger
Visual C++
public:
literal unsigned int PREDICTED_REFRACTIVE_ERROR

See Also

MCdicom Structure
MCdicom Members


PREDICTED_TORIC_ERROR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREDICTED_TORIC_ERROR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Predicted Toric Error Sequence (0022,1048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREDICTED_TORIC_ERROR_SEQUENCE
Visual Basic
Public Const PREDICTED_TORIC_ERROR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PREDICTED_TORIC_ERROR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PREFERRED_PLAYBACK_SEQUENCING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREFERRED_PLAYBACK_SEQUENCING Field
MCdicom Structure See Also Send Feedback
Preferred Playback Sequencing (0018,1244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREFERRED_PLAYBACK_SEQUENCING
Visual Basic
Public Const PREFERRED_PLAYBACK_SEQUENCING As UInteger
Visual C++
public:
literal unsigned int PREFERRED_PLAYBACK_SEQUENCING

See Also

MCdicom Structure
MCdicom Members


PREGNANCY_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PREGNANCY_STATUS Field
MCdicom Structure See Also Send Feedback
Pregnancy Status (0010,21C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PREGNANCY_STATUS
Visual Basic
Public Const PREGNANCY_STATUS As UInteger
Visual C++
public:
literal unsigned int PREGNANCY_STATUS

See Also

MCdicom Structure
MCdicom Members


PRELIMINARY_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRELIMINARY_FLAG Field
MCdicom Structure See Also Send Feedback
Preliminary Flag (0040,A496)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRELIMINARY_FLAG
Visual Basic
Public Const PRELIMINARY_FLAG As UInteger
Visual C++
public:
literal unsigned int PRELIMINARY_FLAG

See Also

MCdicom Structure
MCdicom Members


PRESCRIPTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESCRIPTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Prescription Description (300A,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESCRIPTION_DESCRIPTION
Visual Basic
Public Const PRESCRIPTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PRESCRIPTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PRESCRIPTION_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESCRIPTION_NOTES Field
MCdicom Structure See Also Send Feedback
Prescription Notes (3010,007B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESCRIPTION_NOTES
Visual Basic
Public Const PRESCRIPTION_NOTES As UInteger
Visual C++
public:
literal unsigned int PRESCRIPTION_NOTES

See Also

MCdicom Structure
MCdicom Members


PRESCRIPTION_NOTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESCRIPTION_NOTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Prescription Notes Sequence (3010,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESCRIPTION_NOTES_SEQUENCE
Visual Basic
Public Const PRESCRIPTION_NOTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRESCRIPTION_NOTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRESCRIPTION_OVERVIEW_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESCRIPTION_OVERVIEW_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Prescription Overview Sequence (300C,0114)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESCRIPTION_OVERVIEW_SEQUENCE
Visual Basic
Public Const PRESCRIPTION_OVERVIEW_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRESCRIPTION_OVERVIEW_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_ANIMATION_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_ANIMATION_STYLE Field
MCdicom Structure See Also Send Feedback
Presentation Animation Style (0070,1A01)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_ANIMATION_STYLE
Visual Basic
Public Const PRESENTATION_ANIMATION_STYLE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_ANIMATION_STYLE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_CREATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_CREATION_DATE Field
MCdicom Structure See Also Send Feedback
Presentation Creation Date (0070,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_CREATION_DATE
Visual Basic
Public Const PRESENTATION_CREATION_DATE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_CREATION_DATE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_CREATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_CREATION_TIME Field
MCdicom Structure See Also Send Feedback
Presentation Creation Time (0070,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_CREATION_TIME
Visual Basic
Public Const PRESENTATION_CREATION_TIME As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_CREATION_TIME

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_CREATORS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_CREATORS_NAME Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_CREATORS_NAME (0070,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_CREATORS_NAME
Visual Basic
Public Const PRESENTATION_CREATORS_NAME As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_CREATORS_NAME

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_DESCRIPTION (0070,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_DESCRIPTION
Visual Basic
Public Const PRESENTATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_DISPLAY_COLLECTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_DISPLAY_COLLECTION_UID Field
MCdicom Structure See Also Send Feedback
Presentation Display Collection UID (0070,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_DISPLAY_COLLECTION_UID
Visual Basic
Public Const PRESENTATION_DISPLAY_COLLECTION_UID As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_DISPLAY_COLLECTION_UID

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_GROUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_GROUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Presentation Group Number (003A,0241)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_GROUP_NUMBER
Visual Basic
Public Const PRESENTATION_GROUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_GROUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_INPUT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_INPUT_TYPE Field
MCdicom Structure See Also Send Feedback
Presentation Input Type (0070,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_INPUT_TYPE
Visual Basic
Public Const PRESENTATION_INPUT_TYPE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_INPUT_TYPE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_INTENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_INTENT_TYPE Field
MCdicom Structure See Also Send Feedback
Presentation Intent Type (0008,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_INTENT_TYPE
Visual Basic
Public Const PRESENTATION_INTENT_TYPE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_INTENT_TYPE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_LABEL Field
MCdicom Structure See Also Send Feedback
Alias for tag CONTENT_LABEL (0070,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_LABEL
Visual Basic
Public Const PRESENTATION_LABEL As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_LABEL

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Presentation LUT Content Sequence RETIRED (2130,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED
Visual Basic
Public Const PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_LUT_CONTENT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_LUT_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_LUT_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Presentation LUT Flag RETIRED (2000,0069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_LUT_FLAG_RETIRED
Visual Basic
Public Const PRESENTATION_LUT_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_LUT_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Presentation LUT Sequence (2050,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_LUT_SEQUENCE
Visual Basic
Public Const PRESENTATION_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_LUT_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_LUT_SHAPE Field
MCdicom Structure See Also Send Feedback
Presentation LUT Shape (2050,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_LUT_SHAPE
Visual Basic
Public Const PRESENTATION_LUT_SHAPE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_LUT_SHAPE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_PIXEL_ASPECT_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_PIXEL_ASPECT_RATIO Field
MCdicom Structure See Also Send Feedback
Presentation Pixel Aspect Ratio (0070,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_PIXEL_ASPECT_RATIO
Visual Basic
Public Const PRESENTATION_PIXEL_ASPECT_RATIO As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_PIXEL_ASPECT_RATIO

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_PIXEL_MAGNIFICATION_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_PIXEL_MAGNIFICATION_RATIO Field
MCdicom Structure See Also Send Feedback
Presentation Pixel Magnification Ratio (0070,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_PIXEL_MAGNIFICATION_RATIO
Visual Basic
Public Const PRESENTATION_PIXEL_MAGNIFICATION_RATIO As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_PIXEL_MAGNIFICATION_RATIO

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Presentation Pixel Spacing (0070,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_PIXEL_SPACING
Visual Basic
Public Const PRESENTATION_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_SEQUENCE_COLLECTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_SEQUENCE_COLLECTION_UID Field
MCdicom Structure See Also Send Feedback
Presentation Sequence Collection UID (0070,1102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_SEQUENCE_COLLECTION_UID
Visual Basic
Public Const PRESENTATION_SEQUENCE_COLLECTION_UID As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_SEQUENCE_COLLECTION_UID

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_SEQUENCE_POSITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_SEQUENCE_POSITION_INDEX Field
MCdicom Structure See Also Send Feedback
Presentation Sequence Position Index (0070,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_SEQUENCE_POSITION_INDEX
Visual Basic
Public Const PRESENTATION_SEQUENCE_POSITION_INDEX As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_SEQUENCE_POSITION_INDEX

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_SIZE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_SIZE_MODE Field
MCdicom Structure See Also Send Feedback
Presentation Size Mode (0070,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_SIZE_MODE
Visual Basic
Public Const PRESENTATION_SIZE_MODE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_SIZE_MODE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Presentation State Classification Component Sequence (0070,1801)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE
Visual Basic
Public Const PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_STATE_CLASSIFICATION_COMPONENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Presentation State Compositor Component Sequence (0070,1805)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE
Visual Basic
Public Const PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRESENTATION_STATE_COMPOSITOR_COMPONENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRESENTED_VISUAL_STIMULI_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESENTED_VISUAL_STIMULI_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Presented Visual Stimuli Data Flag (0024,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESENTED_VISUAL_STIMULI_DATA_FLAG
Visual Basic
Public Const PRESENTED_VISUAL_STIMULI_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int PRESENTED_VISUAL_STIMULI_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION Field
MCdicom Structure See Also Send Feedback
Preserve Composite Instances After Media Creation (2200,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION
Visual Basic
Public Const PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION As UInteger
Visual C++
public:
literal unsigned int PRESERVE_COMPOSITE_INSTANCES_AFTER_MEDIA_CREATION

See Also

MCdicom Structure
MCdicom Members


PRESSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRESSURE Field
MCdicom Structure See Also Send Feedback
Pressure (0016,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRESSURE
Visual Basic
Public Const PRESSURE As UInteger
Visual C++
public:
literal unsigned int PRESSURE

See Also

MCdicom Structure
MCdicom Members


PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Primary Anatomic Structure Modifier Sequence (0008,2230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE
Visual Basic
Public Const PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIMARY_ANATOMIC_STRUCTURE_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Primary Anatomic Structure Sequence (0008,2228)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE
Visual Basic
Public Const PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIMARY_ANATOMIC_STRUCTURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIMARY_CHROMATICITIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_CHROMATICITIES Field
MCdicom Structure See Also Send Feedback
Primary Chromaticities (0016,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_CHROMATICITIES
Visual Basic
Public Const PRIMARY_CHROMATICITIES As UInteger
Visual C++
public:
literal unsigned int PRIMARY_CHROMATICITIES

See Also

MCdicom Structure
MCdicom Members


PRIMARY_DOSE_VALUE_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_DOSE_VALUE_INDICATOR Field
MCdicom Structure See Also Send Feedback
Primary Dose Value Indicator (300A,061B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_DOSE_VALUE_INDICATOR
Visual Basic
Public Const PRIMARY_DOSE_VALUE_INDICATOR As UInteger
Visual C++
public:
literal unsigned int PRIMARY_DOSE_VALUE_INDICATOR

See Also

MCdicom Structure
MCdicom Members


PRIMARY_DOSIMETER_UNIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_DOSIMETER_UNIT Field
MCdicom Structure See Also Send Feedback
Primary Dosimeter Unit (300A,00B3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_DOSIMETER_UNIT
Visual Basic
Public Const PRIMARY_DOSIMETER_UNIT As UInteger
Visual C++
public:
literal unsigned int PRIMARY_DOSIMETER_UNIT

See Also

MCdicom Structure
MCdicom Members


PRIMARY_FLUENCE_MODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_FLUENCE_MODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Primary Fluence Mode Sequence (3002,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_FLUENCE_MODE_SEQUENCE
Visual Basic
Public Const PRIMARY_FLUENCE_MODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIMARY_FLUENCE_MODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIMARY_POSITIONER_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_POSITIONER_INCREMENT Field
MCdicom Structure See Also Send Feedback
Primary Positioner Increment (0018,9514)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_POSITIONER_INCREMENT
Visual Basic
Public Const PRIMARY_POSITIONER_INCREMENT As UInteger
Visual C++
public:
literal unsigned int PRIMARY_POSITIONER_INCREMENT

See Also

MCdicom Structure
MCdicom Members


PRIMARY_POSITIONER_INCREMENT_SIGN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_POSITIONER_INCREMENT_SIGN Field
MCdicom Structure See Also Send Feedback
Primary Positioner Increment Sign (0018,9518)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_POSITIONER_INCREMENT_SIGN
Visual Basic
Public Const PRIMARY_POSITIONER_INCREMENT_SIGN As UInteger
Visual C++
public:
literal unsigned int PRIMARY_POSITIONER_INCREMENT_SIGN

See Also

MCdicom Structure
MCdicom Members


PRIMARY_POSITIONER_SCAN_ARC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_POSITIONER_SCAN_ARC Field
MCdicom Structure See Also Send Feedback
Primary Positioner Scan Arc (0018,9508)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_POSITIONER_SCAN_ARC
Visual Basic
Public Const PRIMARY_POSITIONER_SCAN_ARC As UInteger
Visual C++
public:
literal unsigned int PRIMARY_POSITIONER_SCAN_ARC

See Also

MCdicom Structure
MCdicom Members


PRIMARY_POSITIONER_SCAN_START_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_POSITIONER_SCAN_START_ANGLE Field
MCdicom Structure See Also Send Feedback
Primary Positioner Scan Start Angle (0018,9510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_POSITIONER_SCAN_START_ANGLE
Visual Basic
Public Const PRIMARY_POSITIONER_SCAN_START_ANGLE As UInteger
Visual C++
public:
literal unsigned int PRIMARY_POSITIONER_SCAN_START_ANGLE

See Also

MCdicom Structure
MCdicom Members


PRIMARY_PROMPTS_COUNTS_ACCUMULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMARY_PROMPTS_COUNTS_ACCUMULATED Field
MCdicom Structure See Also Send Feedback
Primary (Prompts) Counts Accumulated (0054,1310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMARY_PROMPTS_COUNTS_ACCUMULATED
Visual Basic
Public Const PRIMARY_PROMPTS_COUNTS_ACCUMULATED As UInteger
Visual C++
public:
literal unsigned int PRIMARY_PROMPTS_COUNTS_ACCUMULATED

See Also

MCdicom Structure
MCdicom Members


PRIMITIVE_POINT_INDEX_LIST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIMITIVE_POINT_INDEX_LIST_RETIRED Field
MCdicom Structure See Also Send Feedback
Primitive Point Index List RETIRED (0066,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIMITIVE_POINT_INDEX_LIST_RETIRED
Visual Basic
Public Const PRIMITIVE_POINT_INDEX_LIST_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRIMITIVE_POINT_INDEX_LIST_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Print Job Description Sequence RETIRED (2120,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED
Visual Basic
Public Const PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINT_JOB_DESCRIPTION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINT_JOB_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_JOB_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Print Job ID RETIRED (2100,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_JOB_ID_RETIRED
Visual Basic
Public Const PRINT_JOB_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINT_JOB_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Print Management Capabilities Sequence RETIRED (2130,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED
Visual Basic
Public Const PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINT_MANAGEMENT_CAPABILITIES_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINT_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_PRIORITY Field
MCdicom Structure See Also Send Feedback
Print Priority (2000,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_PRIORITY
Visual Basic
Public Const PRINT_PRIORITY As UInteger
Visual C++
public:
literal unsigned int PRINT_PRIORITY

See Also

MCdicom Structure
MCdicom Members


PRINT_QUEUE_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_QUEUE_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Print Queue ID RETIRED (2110,0099)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_QUEUE_ID_RETIRED
Visual Basic
Public Const PRINT_QUEUE_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINT_QUEUE_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINT_RETIRED Field
MCdicom Structure See Also Send Feedback
Print RETIRED (0000,51A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINT_RETIRED
Visual Basic
Public Const PRINT_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINT_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Printer Characteristics Sequence RETIRED (2130,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED
Visual Basic
Public Const PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PRINTER_CHARACTERISTICS_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PRINTER_CONFIGURATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_CONFIGURATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Printer Configuration Sequence (2000,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_CONFIGURATION_SEQUENCE
Visual Basic
Public Const PRINTER_CONFIGURATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRINTER_CONFIGURATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRINTER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_NAME Field
MCdicom Structure See Also Send Feedback
Printer Name (2110,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_NAME
Visual Basic
Public Const PRINTER_NAME As UInteger
Visual C++
public:
literal unsigned int PRINTER_NAME

See Also

MCdicom Structure
MCdicom Members


PRINTER_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Printer Pixel Spacing (2010,0376)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_PIXEL_SPACING
Visual Basic
Public Const PRINTER_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int PRINTER_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


PRINTER_RESOLUTION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_RESOLUTION_ID Field
MCdicom Structure See Also Send Feedback
Printer Resolution ID (2010,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_RESOLUTION_ID
Visual Basic
Public Const PRINTER_RESOLUTION_ID As UInteger
Visual C++
public:
literal unsigned int PRINTER_RESOLUTION_ID

See Also

MCdicom Structure
MCdicom Members


PRINTER_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_STATUS Field
MCdicom Structure See Also Send Feedback
Printer Status (2110,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_STATUS
Visual Basic
Public Const PRINTER_STATUS As UInteger
Visual C++
public:
literal unsigned int PRINTER_STATUS

See Also

MCdicom Structure
MCdicom Members


PRINTER_STATUS_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTER_STATUS_INFO Field
MCdicom Structure See Also Send Feedback
Printer Status Info (2110,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTER_STATUS_INFO
Visual Basic
Public Const PRINTER_STATUS_INFO As UInteger
Visual C++
public:
literal unsigned int PRINTER_STATUS_INFO

See Also

MCdicom Structure
MCdicom Members


PRINTING_BIT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRINTING_BIT_DEPTH Field
MCdicom Structure See Also Send Feedback
Printing Bit Depth (2000,00A1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRINTING_BIT_DEPTH
Visual Basic
Public Const PRINTING_BIT_DEPTH As UInteger
Visual C++
public:
literal unsigned int PRINTING_BIT_DEPTH

See Also

MCdicom Structure
MCdicom Members


PRIOR_RECORD_KEY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIOR_RECORD_KEY Field
MCdicom Structure See Also Send Feedback
Prior Record Key (0008,041C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIOR_RECORD_KEY
Visual Basic
Public Const PRIOR_RECORD_KEY As UInteger
Visual C++
public:
literal unsigned int PRIOR_RECORD_KEY

See Also

MCdicom Structure
MCdicom Members


PRIOR_TREATMENT_DOSE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIOR_TREATMENT_DOSE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Prior Treatment Dose Description (3010,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIOR_TREATMENT_DOSE_DESCRIPTION
Visual Basic
Public Const PRIOR_TREATMENT_DOSE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PRIOR_TREATMENT_DOSE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PRIOR_TREATMENT_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIOR_TREATMENT_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Prior Treatment Reference Sequence (3010,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIOR_TREATMENT_REFERENCE_SEQUENCE
Visual Basic
Public Const PRIOR_TREATMENT_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIOR_TREATMENT_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIORITY Field
MCdicom Structure See Also Send Feedback
Priority (0000,0700)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIORITY
Visual Basic
Public Const PRIORITY As UInteger
Visual C++
public:
literal unsigned int PRIORITY

See Also

MCdicom Structure
MCdicom Members


PRISM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRISM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Prism Sequence (0046,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRISM_SEQUENCE
Visual Basic
Public Const PRISM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRISM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIVATE_CREATOR_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_CREATOR_REFERENCE Field
MCdicom Structure See Also Send Feedback
Private Creator Reference (0008,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_CREATOR_REFERENCE
Visual Basic
Public Const PRIVATE_CREATOR_REFERENCE As UInteger
Visual C++
public:
literal unsigned int PRIVATE_CREATOR_REFERENCE

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT Field
MCdicom Structure See Also Send Feedback
Private Data Element (0008,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT
Visual Basic
Public Const PRIVATE_DATA_ELEMENT As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Private Data Element Characteristics Sequence (0008,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Private Data Element Definition Sequence (0008,0310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Private Data Element Description (0008,030E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_DESCRIPTION
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_ENCODING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_ENCODING Field
MCdicom Structure See Also Send Feedback
Private Data Element Encoding (0008,030F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_ENCODING
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_ENCODING As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_ENCODING

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_KEYWORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_KEYWORD Field
MCdicom Structure See Also Send Feedback
Private Data Element Keyword (0008,030D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_KEYWORD
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_KEYWORD As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_KEYWORD

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_NAME Field
MCdicom Structure See Also Send Feedback
Private Data Element Name (0008,030C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_NAME
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_NAME As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_NAME

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS Field
MCdicom Structure See Also Send Feedback
Private Data Element Number of Items (0008,030B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_NUMBER_OF_ITEMS

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY Field
MCdicom Structure See Also Send Feedback
Private Data Element Value Multiplicity (0008,0309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_VALUE_MULTIPLICITY

See Also

MCdicom Structure
MCdicom Members


PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION Field
MCdicom Structure See Also Send Feedback
Private Data Element Value Representation (0008,030A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION
Visual Basic
Public Const PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION As UInteger
Visual C++
public:
literal unsigned int PRIVATE_DATA_ELEMENT_VALUE_REPRESENTATION

See Also

MCdicom Structure
MCdicom Members


PRIVATE_GROUP_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_GROUP_REFERENCE Field
MCdicom Structure See Also Send Feedback
Private Group Reference (0008,0301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_GROUP_REFERENCE
Visual Basic
Public Const PRIVATE_GROUP_REFERENCE As UInteger
Visual C++
public:
literal unsigned int PRIVATE_GROUP_REFERENCE

See Also

MCdicom Structure
MCdicom Members


PRIVATE_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_INFORMATION Field
MCdicom Structure See Also Send Feedback
Private Information (0002,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_INFORMATION
Visual Basic
Public Const PRIVATE_INFORMATION As UInteger
Visual C++
public:
literal unsigned int PRIVATE_INFORMATION

See Also

MCdicom Structure
MCdicom Members


PRIVATE_INFORMATION_CREATOR_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_INFORMATION_CREATOR_UID Field
MCdicom Structure See Also Send Feedback
Private Information Creator UID (0002,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_INFORMATION_CREATOR_UID
Visual Basic
Public Const PRIVATE_INFORMATION_CREATOR_UID As UInteger
Visual C++
public:
literal unsigned int PRIVATE_INFORMATION_CREATOR_UID

See Also

MCdicom Structure
MCdicom Members


PRIVATE_RECORD_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRIVATE_RECORD_UID Field
MCdicom Structure See Also Send Feedback
Private Record UID (0004,1432)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRIVATE_RECORD_UID
Visual Basic
Public Const PRIVATE_RECORD_UID As UInteger
Visual C++
public:
literal unsigned int PRIVATE_RECORD_UID

See Also

MCdicom Structure
MCdicom Members


PROBE_CENTER_LOCATION_X Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROBE_CENTER_LOCATION_X Field
MCdicom Structure See Also Send Feedback
Probe Center Location X (0014,4058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROBE_CENTER_LOCATION_X
Visual Basic
Public Const PROBE_CENTER_LOCATION_X As UInteger
Visual C++
public:
literal unsigned int PROBE_CENTER_LOCATION_X

See Also

MCdicom Structure
MCdicom Members


PROBE_CENTER_LOCATION_Z Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROBE_CENTER_LOCATION_Z Field
MCdicom Structure See Also Send Feedback
Probe Center Location Z (0014,4059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROBE_CENTER_LOCATION_Z
Visual Basic
Public Const PROBE_CENTER_LOCATION_Z As UInteger
Visual C++
public:
literal unsigned int PROBE_CENTER_LOCATION_Z

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Code Sequence (0008,1032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Procedure Context Flag (Trial) RETIRED (0040,A603)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED
Visual Basic
Public Const PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_CONTEXT_FLAG_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Procedure Context Sequence (Trial) RETIRED (0040,A340)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_CONTEXT_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_CREATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_CREATION_DATE Field
MCdicom Structure See Also Send Feedback
Procedure Creation Date (0014,4076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_CREATION_DATE
Visual Basic
Public Const PROCEDURE_CREATION_DATE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_CREATION_DATE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_EXPIRATION_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_EXPIRATION_DATE Field
MCdicom Structure See Also Send Feedback
Procedure Expiration Date (0014,4078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_EXPIRATION_DATE
Visual Basic
Public Const PROCEDURE_EXPIRATION_DATE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_EXPIRATION_DATE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Procedure Identifier Code Sequence (Trial) RETIRED (0040,A085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_LAST_MODIFIED_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_LAST_MODIFIED_DATE Field
MCdicom Structure See Also Send Feedback
Procedure Last Modified Date (0014,407A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_LAST_MODIFIED_DATE
Visual Basic
Public Const PROCEDURE_LAST_MODIFIED_DATE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_LAST_MODIFIED_DATE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_CANCELLATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_CANCELLATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Procedure Step Cancellation DateTime (0040,4052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_CANCELLATION_DATETIME
Visual Basic
Public Const PROCEDURE_STEP_CANCELLATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_CANCELLATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Step Communications URI Sequence (0074,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE
Visual Basic
Public Const PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Step Discontinuation Reason Code Sequence (0074,100E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE
Visual Basic
Public Const PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_LABEL Field
MCdicom Structure See Also Send Feedback
Procedure Step Label (0074,1204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_LABEL
Visual Basic
Public Const PROCEDURE_STEP_LABEL As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_LABEL

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_PROGRESS Field
MCdicom Structure See Also Send Feedback
Procedure Step Progress (0074,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_PROGRESS
Visual Basic
Public Const PROCEDURE_STEP_PROGRESS As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_PROGRESS

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_PROGRESS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_PROGRESS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Procedure Step Progress Description (0074,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_PROGRESS_DESCRIPTION
Visual Basic
Public Const PROCEDURE_STEP_PROGRESS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_PROGRESS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Step Progress Information Sequence (0074,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE
Visual Basic
Public Const PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Step Progress Parameters Sequence (0074,1007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE
Visual Basic
Public Const PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_PROGRESS_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Procedure Step Relationship Type RETIRED (0074,1222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED
Visual Basic
Public Const PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_RELATIONSHIP_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_STEP_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_STEP_STATE Field
MCdicom Structure See Also Send Feedback
Procedure Step State (0074,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_STEP_STATE
Visual Basic
Public Const PROCEDURE_STEP_STATE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_STEP_STATE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Procedure Type Code Sequence (0076,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const PROCEDURE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROCEDURE_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCEDURE_VERSION Field
MCdicom Structure See Also Send Feedback
Procedure Version (0014,4074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCEDURE_VERSION
Visual Basic
Public Const PROCEDURE_VERSION As UInteger
Visual C++
public:
literal unsigned int PROCEDURE_VERSION

See Also

MCdicom Structure
MCdicom Members


PROCESSING_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROCESSING_FUNCTION Field
MCdicom Structure See Also Send Feedback
Processing Function (0018,5020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROCESSING_FUNCTION
Visual Basic
Public Const PROCESSING_FUNCTION As UInteger
Visual C++
public:
literal unsigned int PROCESSING_FUNCTION

See Also

MCdicom Structure
MCdicom Members


PRODUCT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Product Description (0044,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_DESCRIPTION
Visual Basic
Public Const PRODUCT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PRODUCT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PRODUCT_EXPIRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_EXPIRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Product Expiration DateTime (0044,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_EXPIRATION_DATETIME
Visual Basic
Public Const PRODUCT_EXPIRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int PRODUCT_EXPIRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


PRODUCT_LOT_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_LOT_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Product Lot Identifier (0044,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_LOT_IDENTIFIER
Visual Basic
Public Const PRODUCT_LOT_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int PRODUCT_LOT_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


PRODUCT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_NAME Field
MCdicom Structure See Also Send Feedback
Product Name (0044,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_NAME
Visual Basic
Public Const PRODUCT_NAME As UInteger
Visual C++
public:
literal unsigned int PRODUCT_NAME

See Also

MCdicom Structure
MCdicom Members


PRODUCT_PACKAGE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_PACKAGE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Product Package Identifier (0044,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_PACKAGE_IDENTIFIER
Visual Basic
Public Const PRODUCT_PACKAGE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int PRODUCT_PACKAGE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


PRODUCT_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Product Parameter Sequence (0044,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_PARAMETER_SEQUENCE
Visual Basic
Public Const PRODUCT_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRODUCT_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PRODUCT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PRODUCT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Product Type Code Sequence (0044,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PRODUCT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const PRODUCT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PRODUCT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Projection Eponymous Name Code Sequence (0018,5104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE
Visual Basic
Public Const PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROJECTION_EPONYMOUS_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Projection Imaging Acquisition Parameter Sequence (3002,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE
Visual Basic
Public Const PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROJECTION_IMAGING_ACQUISITION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROJECTION_PIXEL_CALIBRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROJECTION_PIXEL_CALIBRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Projection Pixel Calibration Sequence (0018,9401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROJECTION_PIXEL_CALIBRATION_SEQUENCE
Visual Basic
Public Const PROJECTION_PIXEL_CALIBRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROJECTION_PIXEL_CALIBRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROPERTY_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROPERTY_LABEL Field
MCdicom Structure See Also Send Feedback
Property Label (0014,2032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROPERTY_LABEL
Visual Basic
Public Const PROPERTY_LABEL As UInteger
Visual C++
public:
literal unsigned int PROPERTY_LABEL

See Also

MCdicom Structure
MCdicom Members


PROPOSED_STUDY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROPOSED_STUDY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Proposed Study Sequence (2130,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROPOSED_STUDY_SEQUENCE
Visual Basic
Public Const PROPOSED_STUDY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROPOSED_STUDY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_CONTEXT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_CONTEXT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Protocol Context Sequence (0040,0440)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_CONTEXT_SEQUENCE
Visual Basic
Public Const PROTOCOL_CONTEXT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_CONTEXT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_DEFINED_PATIENT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_DEFINED_PATIENT_POSITION Field
MCdicom Structure See Also Send Feedback
Protocol Defined Patient Position (0018,9947)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_DEFINED_PATIENT_POSITION
Visual Basic
Public Const PROTOCOL_DEFINED_PATIENT_POSITION As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_DEFINED_PATIENT_POSITION

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_DESIGN_RATIONALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_DESIGN_RATIONALE Field
MCdicom Structure See Also Send Feedback
Protocol Design Rationale (0018,9910)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_DESIGN_RATIONALE
Visual Basic
Public Const PROTOCOL_DESIGN_RATIONALE As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_DESIGN_RATIONALE

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY Field
MCdicom Structure See Also Send Feedback
Protocol Element Characteristics Summary (0018,9923)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY
Visual Basic
Public Const PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_ELEMENT_CHARACTERISTICS_SUMMARY

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_ELEMENT_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_ELEMENT_NAME Field
MCdicom Structure See Also Send Feedback
Protocol Element Name (0018,9922)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_ELEMENT_NAME
Visual Basic
Public Const PROTOCOL_ELEMENT_NAME As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_ELEMENT_NAME

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_ELEMENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_ELEMENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Protocol Element Number (0018,9921)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_ELEMENT_NUMBER
Visual Basic
Public Const PROTOCOL_ELEMENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_ELEMENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_ELEMENT_PURPOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_ELEMENT_PURPOSE Field
MCdicom Structure See Also Send Feedback
Protocol Element Purpose (0018,9924)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_ELEMENT_PURPOSE
Visual Basic
Public Const PROTOCOL_ELEMENT_PURPOSE As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_ELEMENT_PURPOSE

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_NAME Field
MCdicom Structure See Also Send Feedback
Protocol Name (0018,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_NAME
Visual Basic
Public Const PROTOCOL_NAME As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_NAME

See Also

MCdicom Structure
MCdicom Members


PROTOCOL_PLANNING_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PROTOCOL_PLANNING_INFORMATION Field
MCdicom Structure See Also Send Feedback
Protocol Planning Information (0018,990F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PROTOCOL_PLANNING_INFORMATION
Visual Basic
Public Const PROTOCOL_PLANNING_INFORMATION As UInteger
Visual C++
public:
literal unsigned int PROTOCOL_PLANNING_INFORMATION

See Also

MCdicom Structure
MCdicom Members


PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pseudo-Color Palette Instance Reference Sequence (0072,0705)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE
Visual Basic
Public Const PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PSEUDO_COLOR_PALETTE_INSTANCE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PSEUDO_COLOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PSEUDO_COLOR_TYPE Field
MCdicom Structure See Also Send Feedback
Pseudo-Color Type (0072,0704)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PSEUDO_COLOR_TYPE
Visual Basic
Public Const PSEUDO_COLOR_TYPE As UInteger
Visual C++
public:
literal unsigned int PSEUDO_COLOR_TYPE

See Also

MCdicom Structure
MCdicom Members


PTO_REPRESENTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PTO_REPRESENTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
PTO Representation Sequence (4010,1037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PTO_REPRESENTATION_SEQUENCE
Visual Basic
Public Const PTO_REPRESENTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PTO_REPRESENTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PULSE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_NUMBER Field
MCdicom Structure See Also Send Feedback
Pulse Number (3008,0172)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_NUMBER
Visual Basic
Public Const PULSE_NUMBER As UInteger
Visual C++
public:
literal unsigned int PULSE_NUMBER

See Also

MCdicom Structure
MCdicom Members


PULSE_REPETITION_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_REPETITION_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Pulse Repetition Frequency (0018,6032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_REPETITION_FREQUENCY
Visual Basic
Public Const PULSE_REPETITION_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int PULSE_REPETITION_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


PULSE_REPETITION_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_REPETITION_INTERVAL Field
MCdicom Structure See Also Send Feedback
Pulse Repetition Interval (300A,028C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_REPETITION_INTERVAL
Visual Basic
Public Const PULSE_REPETITION_INTERVAL As UInteger
Visual C++
public:
literal unsigned int PULSE_REPETITION_INTERVAL

See Also

MCdicom Structure
MCdicom Members


PULSE_SEQUENCE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_SEQUENCE_NAME Field
MCdicom Structure See Also Send Feedback
Pulse Sequence Name (0018,9005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_SEQUENCE_NAME
Visual Basic
Public Const PULSE_SEQUENCE_NAME As UInteger
Visual C++
public:
literal unsigned int PULSE_SEQUENCE_NAME

See Also

MCdicom Structure
MCdicom Members


PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pulse Specific Brachy Control Point Delivered Sequence (3008,0171)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE
Visual Basic
Public Const PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PULSE_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSE_WIDTH Field
MCdicom Structure See Also Send Feedback
Pulse Width (0014,4022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSE_WIDTH
Visual Basic
Public Const PULSE_WIDTH As UInteger
Visual C++
public:
literal unsigned int PULSE_WIDTH

See Also

MCdicom Structure
MCdicom Members


PULSER_EQUIPMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSER_EQUIPMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pulser Equipment Sequence (0014,4002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSER_EQUIPMENT_SEQUENCE
Visual Basic
Public Const PULSER_EQUIPMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PULSER_EQUIPMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PULSER_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSER_NOTES Field
MCdicom Structure See Also Send Feedback
Pulser Notes (0014,4006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSER_NOTES
Visual Basic
Public Const PULSER_NOTES As UInteger
Visual C++
public:
literal unsigned int PULSER_NOTES

See Also

MCdicom Structure
MCdicom Members


PULSER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Pulser Settings Sequence (0014,4020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSER_SETTINGS_SEQUENCE
Visual Basic
Public Const PULSER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PULSER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PULSER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PULSER_TYPE Field
MCdicom Structure See Also Send Feedback
Pulser Type (0014,4004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PULSER_TYPE
Visual Basic
Public Const PULSER_TYPE As UInteger
Visual C++
public:
literal unsigned int PULSER_TYPE

See Also

MCdicom Structure
MCdicom Members


PUPIL_CENTROID_X_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PUPIL_CENTROID_X_COORDINATE Field
MCdicom Structure See Also Send Feedback
Pupil Centroid X-Coordinate (0046,0203)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PUPIL_CENTROID_X_COORDINATE
Visual Basic
Public Const PUPIL_CENTROID_X_COORDINATE As UInteger
Visual C++
public:
literal unsigned int PUPIL_CENTROID_X_COORDINATE

See Also

MCdicom Structure
MCdicom Members


PUPIL_CENTROID_Y_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PUPIL_CENTROID_Y_COORDINATE Field
MCdicom Structure See Also Send Feedback
Pupil Centroid Y-Coordinate (0046,0204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PUPIL_CENTROID_Y_COORDINATE
Visual Basic
Public Const PUPIL_CENTROID_Y_COORDINATE As UInteger
Visual C++
public:
literal unsigned int PUPIL_CENTROID_Y_COORDINATE

See Also

MCdicom Structure
MCdicom Members


PUPIL_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PUPIL_DIAMETER Field
MCdicom Structure See Also Send Feedback
Alias for tag EMMETROPIC_MAGNIFICATION (0022,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PUPIL_DIAMETER
Visual Basic
Public Const PUPIL_DIAMETER As UInteger
Visual C++
public:
literal unsigned int PUPIL_DIAMETER

See Also

MCdicom Structure
MCdicom Members


PUPIL_DILATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PUPIL_DILATED Field
MCdicom Structure See Also Send Feedback
Pupil Dilated (0022,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PUPIL_DILATED
Visual Basic
Public Const PUPIL_DILATED As UInteger
Visual C++
public:
literal unsigned int PUPIL_DILATED

See Also

MCdicom Structure
MCdicom Members


PUPIL_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PUPIL_SIZE Field
MCdicom Structure See Also Send Feedback
Pupil Size (0046,0044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PUPIL_SIZE
Visual Basic
Public Const PUPIL_SIZE As UInteger
Visual C++
public:
literal unsigned int PUPIL_SIZE

See Also

MCdicom Structure
MCdicom Members


PURPOSE_OF_REFERENCE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PURPOSE_OF_REFERENCE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Purpose of Reference Code Sequence (0040,A170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PURPOSE_OF_REFERENCE_CODE_SEQUENCE
Visual Basic
Public Const PURPOSE_OF_REFERENCE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int PURPOSE_OF_REFERENCE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


PVC_REJECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PVC_REJECTION Field
MCdicom Structure See Also Send Feedback
PVC Rejection (0018,1085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PVC_REJECTION
Visual Basic
Public Const PVC_REJECTION As UInteger
Visual C++
public:
literal unsigned int PVC_REJECTION

See Also

MCdicom Structure
MCdicom Members


PYRAMID_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PYRAMID_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Pyramid Description (0008,1088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PYRAMID_DESCRIPTION
Visual Basic
Public Const PYRAMID_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int PYRAMID_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


PYRAMID_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PYRAMID_LABEL Field
MCdicom Structure See Also Send Feedback
Pyramid Label (0020,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PYRAMID_LABEL
Visual Basic
Public Const PYRAMID_LABEL As UInteger
Visual C++
public:
literal unsigned int PYRAMID_LABEL

See Also

MCdicom Structure
MCdicom Members


PYRAMID_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..PYRAMID_UID Field
MCdicom Structure See Also Send Feedback
Pyramid UID (0008,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint PYRAMID_UID
Visual Basic
Public Const PYRAMID_UID As UInteger
Visual C++
public:
literal unsigned int PYRAMID_UID

See Also

MCdicom Structure
MCdicom Members


QA_RESULTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QA_RESULTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
QA Results Sequence (0028,700F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QA_RESULTS_SEQUENCE
Visual Basic
Public Const QA_RESULTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int QA_RESULTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


QUADRATURE_RECEIVE_COIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUADRATURE_RECEIVE_COIL Field
MCdicom Structure See Also Send Feedback
Quadrature Receive Coil (0018,9044)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUADRATURE_RECEIVE_COIL
Visual Basic
Public Const QUADRATURE_RECEIVE_COIL As UInteger
Visual C++
public:
literal unsigned int QUADRATURE_RECEIVE_COIL

See Also

MCdicom Structure
MCdicom Members


QUALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY Field
MCdicom Structure See Also Send Feedback
Alias for tag QUANTITY (0040,0294)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY
Visual Basic
Public Const QUALITY As UInteger
Visual C++
public:
literal unsigned int QUALITY

See Also

MCdicom Structure
MCdicom Members


QUALITY_CONTROL_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY_CONTROL_IMAGE Field
MCdicom Structure See Also Send Feedback
Quality Control Image (0028,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY_CONTROL_IMAGE
Visual Basic
Public Const QUALITY_CONTROL_IMAGE As UInteger
Visual C++
public:
literal unsigned int QUALITY_CONTROL_IMAGE

See Also

MCdicom Structure
MCdicom Members


QUALITY_CONTROL_SUBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY_CONTROL_SUBJECT Field
MCdicom Structure See Also Send Feedback
Quality Control Subject (0010,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY_CONTROL_SUBJECT
Visual Basic
Public Const QUALITY_CONTROL_SUBJECT As UInteger
Visual C++
public:
literal unsigned int QUALITY_CONTROL_SUBJECT

See Also

MCdicom Structure
MCdicom Members


QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Quality Control Subject Type Code Sequence (0010,0201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE
Visual Basic
Public Const QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int QUALITY_CONTROL_SUBJECT_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


QUALITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag QUANTITY_SEQUENCE (0040,0293)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY_SEQUENCE
Visual Basic
Public Const QUALITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int QUALITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


QUALITY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUALITY_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Quality Threshold (0022,1630)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUALITY_THRESHOLD
Visual Basic
Public Const QUALITY_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int QUALITY_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


QUANTIFIED_DEFECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUANTIFIED_DEFECT Field
MCdicom Structure See Also Send Feedback
Quantified Defect (0024,0098)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUANTIFIED_DEFECT
Visual Basic
Public Const QUANTIFIED_DEFECT As UInteger
Visual C++
public:
literal unsigned int QUANTIFIED_DEFECT

See Also

MCdicom Structure
MCdicom Members


QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUANTITY Field
MCdicom Structure See Also Send Feedback
Quantity (0040,0294)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUANTITY
Visual Basic
Public Const QUANTITY As UInteger
Visual C++
public:
literal unsigned int QUANTITY

See Also

MCdicom Structure
MCdicom Members


QUANTITY_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUANTITY_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Quantity Definition Sequence (0040,9220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUANTITY_DEFINITION_SEQUENCE
Visual Basic
Public Const QUANTITY_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int QUANTITY_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


QUANTITY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUANTITY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Quantity Sequence (0040,0293)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUANTITY_SEQUENCE
Visual Basic
Public Const QUANTITY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int QUANTITY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


QUERY_RETRIEVE_LEVEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUERY_RETRIEVE_LEVEL Field
MCdicom Structure See Also Send Feedback
Query/Retrieve Level (0008,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUERY_RETRIEVE_LEVEL
Visual Basic
Public Const QUERY_RETRIEVE_LEVEL As UInteger
Visual C++
public:
literal unsigned int QUERY_RETRIEVE_LEVEL

See Also

MCdicom Structure
MCdicom Members


QUERY_RETRIEVE_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUERY_RETRIEVE_VIEW Field
MCdicom Structure See Also Send Feedback
Query/Retrieve View (0008,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUERY_RETRIEVE_VIEW
Visual Basic
Public Const QUERY_RETRIEVE_VIEW As UInteger
Visual C++
public:
literal unsigned int QUERY_RETRIEVE_VIEW

See Also

MCdicom Structure
MCdicom Members


QUEUE_STATUS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..QUEUE_STATUS_RETIRED Field
MCdicom Structure See Also Send Feedback
Queue Status RETIRED (2120,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint QUEUE_STATUS_RETIRED
Visual Basic
Public Const QUEUE_STATUS_RETIRED As UInteger
Visual C++
public:
literal unsigned int QUEUE_STATUS_RETIRED

See Also

MCdicom Structure
MCdicom Members


R_R_INTERVAL_TIME_MEASURED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..R_R_INTERVAL_TIME_MEASURED Field
MCdicom Structure See Also Send Feedback
Alias for tag R_R_INTERVAL_TIME_NOMINAL (0020,9251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint R_R_INTERVAL_TIME_MEASURED
Visual Basic
Public Const R_R_INTERVAL_TIME_MEASURED As UInteger
Visual C++
public:
literal unsigned int R_R_INTERVAL_TIME_MEASURED

See Also

MCdicom Structure
MCdicom Members


R_R_INTERVAL_TIME_NOMINAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..R_R_INTERVAL_TIME_NOMINAL Field
MCdicom Structure See Also Send Feedback
R-R Interval Time Nominal (0020,9251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint R_R_INTERVAL_TIME_NOMINAL
Visual Basic
Public Const R_R_INTERVAL_TIME_NOMINAL As UInteger
Visual C++
public:
literal unsigned int R_R_INTERVAL_TIME_NOMINAL

See Also

MCdicom Structure
MCdicom Members


R_R_INTERVAL_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..R_R_INTERVAL_VECTOR Field
MCdicom Structure See Also Send Feedback
R-R Interval Vector (0054,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint R_R_INTERVAL_VECTOR
Visual Basic
Public Const R_R_INTERVAL_VECTOR As UInteger
Visual C++
public:
literal unsigned int R_R_INTERVAL_VECTOR

See Also

MCdicom Structure
MCdicom Members


R_WAVE_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..R_WAVE_POINTER Field
MCdicom Structure See Also Send Feedback
R Wave Pointer (0028,6040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint R_WAVE_POINTER
Visual Basic
Public Const R_WAVE_POINTER As UInteger
Visual C++
public:
literal unsigned int R_WAVE_POINTER

See Also

MCdicom Structure
MCdicom Members


R_WAVE_TIME_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..R_WAVE_TIME_VECTOR Field
MCdicom Structure See Also Send Feedback
R Wave Time Vector (0018,6060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint R_WAVE_TIME_VECTOR
Visual Basic
Public Const R_WAVE_TIME_VECTOR As UInteger
Visual C++
public:
literal unsigned int R_WAVE_TIME_VECTOR

See Also

MCdicom Structure
MCdicom Members


RADIAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIAL_POSITION Field
MCdicom Structure See Also Send Feedback
Radial Position (0018,1142)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIAL_POSITION
Visual Basic
Public Const RADIAL_POSITION As UInteger
Visual C++
public:
literal unsigned int RADIAL_POSITION

See Also

MCdicom Structure
MCdicom Members


RADIATION_ATOMIC_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_ATOMIC_NUMBER Field
MCdicom Structure See Also Send Feedback
Radiation Atomic Number (300A,0304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_ATOMIC_NUMBER
Visual Basic
Public Const RADIATION_ATOMIC_NUMBER As UInteger
Visual C++
public:
literal unsigned int RADIATION_ATOMIC_NUMBER

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_BLOCK_SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_BLOCK_SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
Radiation Beam Block Slab Thickness (300A,066E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_BLOCK_SLAB_THICKNESS
Visual Basic
Public Const RADIATION_BEAM_BLOCK_SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_BLOCK_SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_BLOCK_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_BLOCK_THICKNESS Field
MCdicom Structure See Also Send Feedback
Radiation Beam Block Thickness (300A,066D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_BLOCK_THICKNESS
Visual Basic
Public Const RADIATION_BEAM_BLOCK_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_BLOCK_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER Field
MCdicom Structure See Also Send Feedback
Radiation Beam Compensator Milling Tool Diameter (300A,0669)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER
Visual Basic
Public Const RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_COMPENSATOR_MILLING_TOOL_DIAMETER

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE Field
MCdicom Structure See Also Send Feedback
Radiation Beam Effective Wedge Angle (300A,0654)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE
Visual Basic
Public Const RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_EFFECTIVE_WEDGE_ANGLE

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_WEDGE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_WEDGE_ANGLE Field
MCdicom Structure See Also Send Feedback
Radiation Beam Wedge Angle (300A,0652)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_WEDGE_ANGLE
Visual Basic
Public Const RADIATION_BEAM_WEDGE_ANGLE As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_WEDGE_ANGLE

See Also

MCdicom Structure
MCdicom Members


RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Radiation Beam Wedge Thin Edge Distance (300A,0653)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE
Visual Basic
Public Const RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_BEAM_WEDGE_THIN_EDGE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_CHARGE_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_CHARGE_STATE Field
MCdicom Structure See Also Send Feedback
Radiation Charge State (300A,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_CHARGE_STATE
Visual Basic
Public Const RADIATION_CHARGE_STATE As UInteger
Visual C++
public:
literal unsigned int RADIATION_CHARGE_STATE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Device Configuration and Commissioning Key Sequence (300A,065A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE
Visual Basic
Public Const RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DEVICE_CONFIGURATION_AND_COMMISSIONING_KEY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT Field
MCdicom Structure See Also Send Feedback
Radiation Dose Central Axis Displacement (300A,0624)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT
Visual Basic
Public Const RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_CENTRAL_AXIS_DISPLACEMENT

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_IDENTIFICATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_IDENTIFICATION_INDEX Field
MCdicom Structure See Also Send Feedback
Radiation Dose Identification Index (300A,0603)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_IDENTIFICATION_INDEX
Visual Basic
Public Const RADIATION_DOSE_IDENTIFICATION_INDEX As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_IDENTIFICATION_INDEX

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_IDENTIFICATION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_IDENTIFICATION_LABEL Field
MCdicom Structure See Also Send Feedback
Radiation Dose Identification Label (300A,0619)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_IDENTIFICATION_LABEL
Visual Basic
Public Const RADIATION_DOSE_IDENTIFICATION_LABEL As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_IDENTIFICATION_LABEL

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Identification Sequence (300A,0618)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const RADIATION_DOSE_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL Field
MCdicom Structure See Also Send Feedback
Radiation Dose In-Vivo Measurement Label (300A,0623)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL
Visual Basic
Public Const RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_IN_VIVO_MEASUREMENT_LABEL

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES Field
MCdicom Structure See Also Send Feedback
Radiation Dose Measurement Point Coordinates (300A,0627)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES
Visual Basic
Public Const RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_MEASUREMENT_POINT_COORDINATES

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Sequence (300A,0617)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_SEQUENCE
Visual Basic
Public Const RADIATION_DOSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Source to External Contour Distance (300A,0628)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE
Visual Basic
Public Const RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Source to Skin Distance (300A,0626)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE
Visual Basic
Public Const RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_SOURCE_TO_SKIN_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_VALUE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Value (300A,0625)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_VALUE
Visual Basic
Public Const RADIATION_DOSE_VALUE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_VALUE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Dose Values Parameters Sequence (300A,061F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE
Visual Basic
Public Const RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSE_VALUES_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_DOSIMETER_UNIT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_DOSIMETER_UNIT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Dosimeter Unit Sequence (300A,0658)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_DOSIMETER_UNIT_SEQUENCE
Visual Basic
Public Const RADIATION_DOSIMETER_UNIT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_DOSIMETER_UNIT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Fluence Modifier Code Sequence (300A,0683)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_FLUENCE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_GENERATION_MODE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_GENERATION_MODE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Radiation Generation Mode Description (300A,067D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_GENERATION_MODE_DESCRIPTION
Visual Basic
Public Const RADIATION_GENERATION_MODE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RADIATION_GENERATION_MODE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RADIATION_GENERATION_MODE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_GENERATION_MODE_INDEX Field
MCdicom Structure See Also Send Feedback
Radiation Generation Mode Index (300A,0601)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_GENERATION_MODE_INDEX
Visual Basic
Public Const RADIATION_GENERATION_MODE_INDEX As UInteger
Visual C++
public:
literal unsigned int RADIATION_GENERATION_MODE_INDEX

See Also

MCdicom Structure
MCdicom Members


RADIATION_GENERATION_MODE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_GENERATION_MODE_LABEL Field
MCdicom Structure See Also Send Feedback
Radiation Generation Mode Label (300A,067C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_GENERATION_MODE_LABEL
Visual Basic
Public Const RADIATION_GENERATION_MODE_LABEL As UInteger
Visual C++
public:
literal unsigned int RADIATION_GENERATION_MODE_LABEL

See Also

MCdicom Structure
MCdicom Members


RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Generation Mode Machine Code Sequence (300A,067E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE
Visual Basic
Public Const RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_GENERATION_MODE_MACHINE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_GENERATION_MODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_GENERATION_MODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Generation Mode Sequence (300A,067B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_GENERATION_MODE_SEQUENCE
Visual Basic
Public Const RADIATION_GENERATION_MODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_GENERATION_MODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_MACHINE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_MACHINE_NAME Field
MCdicom Structure See Also Send Feedback
Radiation Machine Name (3002,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_MACHINE_NAME
Visual Basic
Public Const RADIATION_MACHINE_NAME As UInteger
Visual C++
public:
literal unsigned int RADIATION_MACHINE_NAME

See Also

MCdicom Structure
MCdicom Members


RADIATION_MACHINE_SAD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_MACHINE_SAD Field
MCdicom Structure See Also Send Feedback
Radiation Machine SAD (3002,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_MACHINE_SAD
Visual Basic
Public Const RADIATION_MACHINE_SAD As UInteger
Visual C++
public:
literal unsigned int RADIATION_MACHINE_SAD

See Also

MCdicom Structure
MCdicom Members


RADIATION_MACHINE_SSD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_MACHINE_SSD Field
MCdicom Structure See Also Send Feedback
Radiation Machine SSD (3002,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_MACHINE_SSD
Visual Basic
Public Const RADIATION_MACHINE_SSD As UInteger
Visual C++
public:
literal unsigned int RADIATION_MACHINE_SSD

See Also

MCdicom Structure
MCdicom Members


RADIATION_MASS_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_MASS_NUMBER Field
MCdicom Structure See Also Send Feedback
Radiation Mass Number (300A,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_MASS_NUMBER
Visual Basic
Public Const RADIATION_MASS_NUMBER As UInteger
Visual C++
public:
literal unsigned int RADIATION_MASS_NUMBER

See Also

MCdicom Structure
MCdicom Members


RADIATION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_MODE Field
MCdicom Structure See Also Send Feedback
Radiation Mode (0018,115A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_MODE
Visual Basic
Public Const RADIATION_MODE As UInteger
Visual C++
public:
literal unsigned int RADIATION_MODE

See Also

MCdicom Structure
MCdicom Members


RADIATION_ORDER_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_ORDER_INDEX Field
MCdicom Structure See Also Send Feedback
Radiation Order Index (300A,0786)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_ORDER_INDEX
Visual Basic
Public Const RADIATION_ORDER_INDEX As UInteger
Visual C++
public:
literal unsigned int RADIATION_ORDER_INDEX

See Also

MCdicom Structure
MCdicom Members


RADIATION_SETTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_SETTING Field
MCdicom Structure See Also Send Feedback
Radiation Setting (0018,1155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_SETTING
Visual Basic
Public Const RADIATION_SETTING As UInteger
Visual C++
public:
literal unsigned int RADIATION_SETTING

See Also

MCdicom Structure
MCdicom Members


RADIATION_SOURCE_AXIS_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_SOURCE_AXIS_DISTANCE Field
MCdicom Structure See Also Send Feedback
Radiation Source-Axis Distance (300A,0640)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_SOURCE_AXIS_DISTANCE
Visual Basic
Public Const RADIATION_SOURCE_AXIS_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_SOURCE_AXIS_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE Field
MCdicom Structure See Also Send Feedback
Radiation Source Coordinate System Pitch Angle (3010,0096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE
Visual Basic
Public Const RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE As UInteger
Visual C++
public:
literal unsigned int RADIATION_SOURCE_COORDINATE_SYSTEM_PITCH_ANGLE

See Also

MCdicom Structure
MCdicom Members


RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE Field
MCdicom Structure See Also Send Feedback
Radiation Source Coordinate System Roll Angle (3010,0095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE
Visual Basic
Public Const RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE As UInteger
Visual C++
public:
literal unsigned int RADIATION_SOURCE_COORDINATE_SYSTEM_ROLL_ANGLE

See Also

MCdicom Structure
MCdicom Members


RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE Field
MCdicom Structure See Also Send Feedback
Radiation Source Coordinate System Yaw Angle (3010,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE
Visual Basic
Public Const RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE As UInteger
Visual C++
public:
literal unsigned int RADIATION_SOURCE_COORDINATE_SYSTEM_YAW_ANGLE

See Also

MCdicom Structure
MCdicom Members


RADIATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_TYPE Field
MCdicom Structure See Also Send Feedback
Radiation Type (300A,00C6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_TYPE
Visual Basic
Public Const RADIATION_TYPE As UInteger
Visual C++
public:
literal unsigned int RADIATION_TYPE

See Also

MCdicom Structure
MCdicom Members


RADIATION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIATION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiation Type Code Sequence (300A,067F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIATION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const RADIATION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIATION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIOBIOLOGICAL_DOSE_EFFECT_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOBIOLOGICAL_DOSE_EFFECT_FLAG Field
MCdicom Structure See Also Send Feedback
Radiobiological Dose Effect Flag (3010,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOBIOLOGICAL_DOSE_EFFECT_FLAG
Visual Basic
Public Const RADIOBIOLOGICAL_DOSE_EFFECT_FLAG As UInteger
Visual C++
public:
literal unsigned int RADIOBIOLOGICAL_DOSE_EFFECT_FLAG

See Also

MCdicom Structure
MCdicom Members


RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiobiological Dose Effect Sequence (3010,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE
Visual Basic
Public Const RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIOBIOLOGICAL_DOSE_EFFECT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIONUCLIDE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIONUCLIDE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radionuclide Code Sequence (0054,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIONUCLIDE_CODE_SEQUENCE
Visual Basic
Public Const RADIONUCLIDE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIONUCLIDE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIONUCLIDE_HALF_LIFE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIONUCLIDE_HALF_LIFE Field
MCdicom Structure See Also Send Feedback
Radionuclide Half Life (0018,1075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIONUCLIDE_HALF_LIFE
Visual Basic
Public Const RADIONUCLIDE_HALF_LIFE As UInteger
Visual C++
public:
literal unsigned int RADIONUCLIDE_HALF_LIFE

See Also

MCdicom Structure
MCdicom Members


RADIONUCLIDE_POSITRON_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIONUCLIDE_POSITRON_FRACTION Field
MCdicom Structure See Also Send Feedback
Radionuclide Positron Fraction (0018,1076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIONUCLIDE_POSITRON_FRACTION
Visual Basic
Public Const RADIONUCLIDE_POSITRON_FRACTION As UInteger
Visual C++
public:
literal unsigned int RADIONUCLIDE_POSITRON_FRACTION

See Also

MCdicom Structure
MCdicom Members


RADIONUCLIDE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIONUCLIDE_RETIRED Field
MCdicom Structure See Also Send Feedback
Radionuclide RETIRED (0018,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIONUCLIDE_RETIRED
Visual Basic
Public Const RADIONUCLIDE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RADIONUCLIDE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RADIONUCLIDE_TOTAL_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIONUCLIDE_TOTAL_DOSE Field
MCdicom Structure See Also Send Feedback
Radionuclide Total Dose (0018,1074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIONUCLIDE_TOTAL_DOSE
Visual Basic
Public Const RADIONUCLIDE_TOTAL_DOSE As UInteger
Visual C++
public:
literal unsigned int RADIONUCLIDE_TOTAL_DOSE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical (0018,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL
Visual Basic
Public Const RADIOPHARMACEUTICAL As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Administration Event UID (0008,3012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID
Visual Basic
Public Const RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_ADMINISTRATION_EVENT_UID

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_AGENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_AGENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Agent Number (0018,9729)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_AGENT_NUMBER
Visual Basic
Public Const RADIOPHARMACEUTICAL_AGENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_AGENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Code Sequence (0054,0304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_CODE_SEQUENCE
Visual Basic
Public Const RADIOPHARMACEUTICAL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Information Sequence (0054,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE
Visual Basic
Public Const RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_ROUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_ROUTE Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Route (0018,1070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_ROUTE
Visual Basic
Public Const RADIOPHARMACEUTICAL_ROUTE As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_ROUTE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag ADMINISTRATION_ROUTE_CODE_SEQUENCE (0054,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE
Visual Basic
Public Const RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_ROUTE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Specific Activity (0018,1077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY
Visual Basic
Public Const RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_SPECIFIC_ACTIVITY

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_START_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_START_DATETIME Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Start DateTime (0018,1078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_START_DATETIME
Visual Basic
Public Const RADIOPHARMACEUTICAL_START_DATETIME As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_START_DATETIME

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_START_TIME Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Start Time (0018,1072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_START_TIME
Visual Basic
Public Const RADIOPHARMACEUTICAL_START_TIME As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_START_TIME

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_STOP_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_STOP_DATETIME Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Stop DateTime (0018,1079)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_STOP_DATETIME
Visual Basic
Public Const RADIOPHARMACEUTICAL_STOP_DATETIME As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_STOP_DATETIME

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_STOP_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_STOP_TIME Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Stop Time (0018,1073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_STOP_TIME
Visual Basic
Public Const RADIOPHARMACEUTICAL_STOP_TIME As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_STOP_TIME

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_USAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_USAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Usage Sequence (0018,9737)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_USAGE_SEQUENCE
Visual Basic
Public Const RADIOPHARMACEUTICAL_USAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_USAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RADIOPHARMACEUTICAL_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOPHARMACEUTICAL_VOLUME Field
MCdicom Structure See Also Send Feedback
Radiopharmaceutical Volume (0018,1071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOPHARMACEUTICAL_VOLUME
Visual Basic
Public Const RADIOPHARMACEUTICAL_VOLUME As UInteger
Visual C++
public:
literal unsigned int RADIOPHARMACEUTICAL_VOLUME

See Also

MCdicom Structure
MCdicom Members


RADIOTHERAPY_TREATMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIOTHERAPY_TREATMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Radiotherapy Treatment Type (3010,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIOTHERAPY_TREATMENT_TYPE
Visual Basic
Public Const RADIOTHERAPY_TREATMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int RADIOTHERAPY_TREATMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


RADIUS_OF_CIRCULAR_COLLIMATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIUS_OF_CIRCULAR_COLLIMATOR Field
MCdicom Structure See Also Send Feedback
Radius of Circular Collimator (0018,1712)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIUS_OF_CIRCULAR_COLLIMATOR
Visual Basic
Public Const RADIUS_OF_CIRCULAR_COLLIMATOR As UInteger
Visual C++
public:
literal unsigned int RADIUS_OF_CIRCULAR_COLLIMATOR

See Also

MCdicom Structure
MCdicom Members


RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION Field
MCdicom Structure See Also Send Feedback
Radius of Circular Exposure Control Sensing Region (0018,9441)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION
Visual Basic
Public Const RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION As UInteger
Visual C++
public:
literal unsigned int RADIUS_OF_CIRCULAR_EXPOSURE_CONTROL_SENSING_REGION

See Also

MCdicom Structure
MCdicom Members


RADIUS_OF_CIRCULAR_SHUTTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIUS_OF_CIRCULAR_SHUTTER Field
MCdicom Structure See Also Send Feedback
Radius of Circular Shutter (0018,1612)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIUS_OF_CIRCULAR_SHUTTER
Visual Basic
Public Const RADIUS_OF_CIRCULAR_SHUTTER As UInteger
Visual C++
public:
literal unsigned int RADIUS_OF_CIRCULAR_SHUTTER

See Also

MCdicom Structure
MCdicom Members


RADIUS_OF_CURVATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RADIUS_OF_CURVATURE Field
MCdicom Structure See Also Send Feedback
Radius of Curvature (0046,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RADIUS_OF_CURVATURE
Visual Basic
Public Const RADIUS_OF_CURVATURE As UInteger
Visual C++
public:
literal unsigned int RADIUS_OF_CURVATURE

See Also

MCdicom Structure
MCdicom Members


RANDOMS_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANDOMS_CORRECTED Field
MCdicom Structure See Also Send Feedback
Randoms Corrected (0018,9765)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANDOMS_CORRECTED
Visual Basic
Public Const RANDOMS_CORRECTED As UInteger
Visual C++
public:
literal unsigned int RANDOMS_CORRECTED

See Also

MCdicom Structure
MCdicom Members


RANDOMS_CORRECTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANDOMS_CORRECTION_METHOD Field
MCdicom Structure See Also Send Feedback
Randoms Correction Method (0054,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANDOMS_CORRECTION_METHOD
Visual Basic
Public Const RANDOMS_CORRECTION_METHOD As UInteger
Visual C++
public:
literal unsigned int RANDOMS_CORRECTION_METHOD

See Also

MCdicom Structure
MCdicom Members


RANGE_MATCHING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MATCHING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Range Matching Sequence (0008,0410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MATCHING_SEQUENCE
Visual Basic
Public Const RANGE_MATCHING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RANGE_MATCHING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Range Modulator Description (300A,034A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_DESCRIPTION
Visual Basic
Public Const RANGE_MODULATOR_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_GATING_START_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_GATING_START_VALUE Field
MCdicom Structure See Also Send Feedback
Range Modulator Gating Start Value (300A,0382)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_GATING_START_VALUE
Visual Basic
Public Const RANGE_MODULATOR_GATING_START_VALUE As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_GATING_START_VALUE

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Range Modulator Gating Start Water Equivalent Thickness (300A,0386)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_GATING_START_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_GATING_STOP_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_GATING_STOP_VALUE Field
MCdicom Structure See Also Send Feedback
Range Modulator Gating Stop Value (300A,0384)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_GATING_STOP_VALUE
Visual Basic
Public Const RANGE_MODULATOR_GATING_STOP_VALUE As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_GATING_STOP_VALUE

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Range Modulator Gating Stop Water Equivalent Thickness (300A,0388)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_GATING_STOP_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_ID Field
MCdicom Structure See Also Send Feedback
Range Modulator ID (300A,0346)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_ID
Visual Basic
Public Const RANGE_MODULATOR_ID As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_ID

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Range Modulator Number (300A,0344)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_NUMBER
Visual Basic
Public Const RANGE_MODULATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Range Modulator Sequence (300A,0342)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_SEQUENCE
Visual Basic
Public Const RANGE_MODULATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Range Modulator Settings Sequence (300A,0380)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_SETTINGS_SEQUENCE
Visual Basic
Public Const RANGE_MODULATOR_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RANGE_MODULATOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_MODULATOR_TYPE Field
MCdicom Structure See Also Send Feedback
Range Modulator Type (300A,0348)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_MODULATOR_TYPE
Visual Basic
Public Const RANGE_MODULATOR_TYPE As UInteger
Visual C++
public:
literal unsigned int RANGE_MODULATOR_TYPE

See Also

MCdicom Structure
MCdicom Members


RANGE_OF_FREEDOM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_OF_FREEDOM Field
MCdicom Structure See Also Send Feedback
Range of Freedom (0068,64A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_OF_FREEDOM
Visual Basic
Public Const RANGE_OF_FREEDOM As UInteger
Visual C++
public:
literal unsigned int RANGE_OF_FREEDOM

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Range Shifter Description (300A,0322)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_DESCRIPTION
Visual Basic
Public Const RANGE_SHIFTER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_ID Field
MCdicom Structure See Also Send Feedback
Range Shifter ID (300A,0318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_ID
Visual Basic
Public Const RANGE_SHIFTER_ID As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_ID

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_NUMBER Field
MCdicom Structure See Also Send Feedback
Range Shifter Number (300A,0316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_NUMBER
Visual Basic
Public Const RANGE_SHIFTER_NUMBER As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_NUMBER

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Range Shifter Sequence (300A,0314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_SEQUENCE
Visual Basic
Public Const RANGE_SHIFTER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_SETTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_SETTING Field
MCdicom Structure See Also Send Feedback
Range Shifter Setting (300A,0362)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_SETTING
Visual Basic
Public Const RANGE_SHIFTER_SETTING As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_SETTING

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Range Shifter Settings Sequence (300A,0360)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_SETTINGS_SEQUENCE
Visual Basic
Public Const RANGE_SHIFTER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_TYPE Field
MCdicom Structure See Also Send Feedback
Range Shifter Type (300A,0320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_TYPE
Visual Basic
Public Const RANGE_SHIFTER_TYPE As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_TYPE

See Also

MCdicom Structure
MCdicom Members


RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Range Shifter Water Equivalent Thickness (300A,0366)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RANGE_SHIFTER_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RANGING_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RANGING_DEPTH Field
MCdicom Structure See Also Send Feedback
Ranging Depth (0052,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RANGING_DEPTH
Visual Basic
Public Const RANGING_DEPTH As UInteger
Visual C++
public:
literal unsigned int RANGING_DEPTH

See Also

MCdicom Structure
MCdicom Members


RATIONAL_DENOMINATOR_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RATIONAL_DENOMINATOR_VALUE Field
MCdicom Structure See Also Send Feedback
Rational Denominator Value (0040,A163)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RATIONAL_DENOMINATOR_VALUE
Visual Basic
Public Const RATIONAL_DENOMINATOR_VALUE As UInteger
Visual C++
public:
literal unsigned int RATIONAL_DENOMINATOR_VALUE

See Also

MCdicom Structure
MCdicom Members


RATIONAL_NUMERATOR_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RATIONAL_NUMERATOR_VALUE Field
MCdicom Structure See Also Send Feedback
Rational Numerator Value (0040,A162)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RATIONAL_NUMERATOR_VALUE
Visual Basic
Public Const RATIONAL_NUMERATOR_VALUE As UInteger
Visual C++
public:
literal unsigned int RATIONAL_NUMERATOR_VALUE

See Also

MCdicom Structure
MCdicom Members


RAW_DATA_HANDLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RAW_DATA_HANDLING Field
MCdicom Structure See Also Send Feedback
Raw Data Handling (0040,4040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RAW_DATA_HANDLING
Visual Basic
Public Const RAW_DATA_HANDLING As UInteger
Visual C++
public:
literal unsigned int RAW_DATA_HANDLING

See Also

MCdicom Structure
MCdicom Members


REAL_TIME_BULK_DATA_FLOW_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_TIME_BULK_DATA_FLOW_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Real-Time Bulk Data Flow Sequence (0034,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_TIME_BULK_DATA_FLOW_SEQUENCE
Visual Basic
Public Const REAL_TIME_BULK_DATA_FLOW_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REAL_TIME_BULK_DATA_FLOW_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_FIRST_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_FIRST_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Real World Value First Value Mapped (0040,9216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_FIRST_VALUE_MAPPED
Visual Basic
Public Const REAL_WORLD_VALUE_FIRST_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_FIRST_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_INTERCEPT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_INTERCEPT Field
MCdicom Structure See Also Send Feedback
Real World Value Intercept (0040,9224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_INTERCEPT
Visual Basic
Public Const REAL_WORLD_VALUE_INTERCEPT As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_INTERCEPT

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_LAST_VALUE_MAPPED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_LAST_VALUE_MAPPED Field
MCdicom Structure See Also Send Feedback
Real World Value Last Value Mapped (0040,9211)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_LAST_VALUE_MAPPED
Visual Basic
Public Const REAL_WORLD_VALUE_LAST_VALUE_MAPPED As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_LAST_VALUE_MAPPED

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_LUT_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_LUT_DATA Field
MCdicom Structure See Also Send Feedback
Real World Value LUT Data (0040,9212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_LUT_DATA
Visual Basic
Public Const REAL_WORLD_VALUE_LUT_DATA As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_LUT_DATA

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_MAPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_MAPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Real World Value Mapping Sequence (0040,9096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_MAPPING_SEQUENCE
Visual Basic
Public Const REAL_WORLD_VALUE_MAPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_MAPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REAL_WORLD_VALUE_SLOPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REAL_WORLD_VALUE_SLOPE Field
MCdicom Structure See Also Send Feedback
Real World Value Slope (0040,9225)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REAL_WORLD_VALUE_SLOPE
Visual Basic
Public Const REAL_WORLD_VALUE_SLOPE As UInteger
Visual C++
public:
literal unsigned int REAL_WORLD_VALUE_SLOPE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_CANCELLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_CANCELLATION Field
MCdicom Structure See Also Send Feedback
Reason for Cancellation (0074,1238)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_CANCELLATION
Visual Basic
Public Const REASON_FOR_CANCELLATION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_CANCELLATION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_CHANNEL_OMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_CHANNEL_OMISSION Field
MCdicom Structure See Also Send Feedback
Reason for Channel Omission (0074,140A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_CHANNEL_OMISSION
Visual Basic
Public Const REASON_FOR_CHANNEL_OMISSION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_CHANNEL_OMISSION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_CHANNEL_OMISSION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_CHANNEL_OMISSION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Reason for Channel Omission Description (0074,140B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_CHANNEL_OMISSION_DESCRIPTION
Visual Basic
Public Const REASON_FOR_CHANNEL_OMISSION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_CHANNEL_OMISSION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_OMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_OMISSION Field
MCdicom Structure See Also Send Feedback
Reason for Omission (300C,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_OMISSION
Visual Basic
Public Const REASON_FOR_OMISSION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_OMISSION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_OMISSION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_OMISSION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reason for Omission Code Sequence (300A,0788)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_OMISSION_CODE_SEQUENCE
Visual Basic
Public Const REASON_FOR_OMISSION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_OMISSION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_OMISSION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_OMISSION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Reason for Omission Description (300C,0113)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_OMISSION_DESCRIPTION
Visual Basic
Public Const REASON_FOR_OMISSION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_OMISSION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reason For Performed Procedure Code Sequence (0040,1012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_PERFORMED_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_REMOVAL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_REMOVAL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reason for Removal Code Sequence (0008,0406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_REMOVAL_CODE_SEQUENCE
Visual Basic
Public Const REASON_FOR_REMOVAL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_REMOVAL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reason for Requested Procedure Code Sequence (0040,100A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_REQUESTED_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_STUDY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_STUDY_RETIRED Field
MCdicom Structure See Also Send Feedback
Reason for Study RETIRED (0032,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_STUDY_RETIRED
Visual Basic
Public Const REASON_FOR_STUDY_RETIRED As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_STUDY_RETIRED

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_SUPERSEDING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_SUPERSEDING Field
MCdicom Structure See Also Send Feedback
Reason for Superseding (3010,005C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_SUPERSEDING
Visual Basic
Public Const REASON_FOR_SUPERSEDING As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_SUPERSEDING

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_THE_ATTRIBUTE_MODIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_THE_ATTRIBUTE_MODIFICATION Field
MCdicom Structure See Also Send Feedback
Reason for the Attribute Modification (0400,0565)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_THE_ATTRIBUTE_MODIFICATION
Visual Basic
Public Const REASON_FOR_THE_ATTRIBUTE_MODIFICATION As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_THE_ATTRIBUTE_MODIFICATION

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED Field
MCdicom Structure See Also Send Feedback
Reason for the Imaging Service Request RETIRED (0040,2001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED
Visual Basic
Public Const REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_THE_IMAGING_SERVICE_REQUEST_RETIRED

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_THE_REQUESTED_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_THE_REQUESTED_PROCEDURE Field
MCdicom Structure See Also Send Feedback
Reason for the Requested Procedure (0040,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_THE_REQUESTED_PROCEDURE
Visual Basic
Public Const REASON_FOR_THE_REQUESTED_PROCEDURE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_THE_REQUESTED_PROCEDURE

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_VISIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_VISIT Field
MCdicom Structure See Also Send Feedback
Reason for Visit (0032,1066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_VISIT
Visual Basic
Public Const REASON_FOR_VISIT As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_VISIT

See Also

MCdicom Structure
MCdicom Members


REASON_FOR_VISIT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REASON_FOR_VISIT_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reason for Visit Code Sequence (0032,1067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REASON_FOR_VISIT_CODE_SEQUENCE
Visual Basic
Public Const REASON_FOR_VISIT_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REASON_FOR_VISIT_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECEIVE_COIL_MANUFACTURER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVE_COIL_MANUFACTURER_NAME Field
MCdicom Structure See Also Send Feedback
Receive Coil Manufacturer Name (0018,9041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVE_COIL_MANUFACTURER_NAME
Visual Basic
Public Const RECEIVE_COIL_MANUFACTURER_NAME As UInteger
Visual C++
public:
literal unsigned int RECEIVE_COIL_MANUFACTURER_NAME

See Also

MCdicom Structure
MCdicom Members


RECEIVE_COIL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVE_COIL_NAME Field
MCdicom Structure See Also Send Feedback
Receive Coil Name (0018,1250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVE_COIL_NAME
Visual Basic
Public Const RECEIVE_COIL_NAME As UInteger
Visual C++
public:
literal unsigned int RECEIVE_COIL_NAME

See Also

MCdicom Structure
MCdicom Members


RECEIVE_COIL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVE_COIL_TYPE Field
MCdicom Structure See Also Send Feedback
Receive Coil Type (0018,9043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVE_COIL_TYPE
Visual Basic
Public Const RECEIVE_COIL_TYPE As UInteger
Visual C++
public:
literal unsigned int RECEIVE_COIL_TYPE

See Also

MCdicom Structure
MCdicom Members


RECEIVE_TRANSDUCER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVE_TRANSDUCER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Receive Transducer Sequence (0014,4011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVE_TRANSDUCER_SEQUENCE
Visual Basic
Public Const RECEIVE_TRANSDUCER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECEIVE_TRANSDUCER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Receive Transducer Settings Sequence (0014,4051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE
Visual Basic
Public Const RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECEIVE_TRANSDUCER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECEIVER_EQUIPMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVER_EQUIPMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Receiver Equipment Sequence (0014,4008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVER_EQUIPMENT_SEQUENCE
Visual Basic
Public Const RECEIVER_EQUIPMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECEIVER_EQUIPMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECEIVER_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVER_NOTES Field
MCdicom Structure See Also Send Feedback
Receiver Notes (0014,400C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVER_NOTES
Visual Basic
Public Const RECEIVER_NOTES As UInteger
Visual C++
public:
literal unsigned int RECEIVER_NOTES

See Also

MCdicom Structure
MCdicom Members


RECEIVER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVER_RETIRED Field
MCdicom Structure See Also Send Feedback
Receiver RETIRED (0000,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVER_RETIRED
Visual Basic
Public Const RECEIVER_RETIRED As UInteger
Visual C++
public:
literal unsigned int RECEIVER_RETIRED

See Also

MCdicom Structure
MCdicom Members


RECEIVER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Receiver Settings Sequence (0014,4030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVER_SETTINGS_SEQUENCE
Visual Basic
Public Const RECEIVER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECEIVER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECEIVING_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVING_AE Field
MCdicom Structure See Also Send Feedback
Receiving AE (0074,1234)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVING_AE
Visual Basic
Public Const RECEIVING_AE As UInteger
Visual C++
public:
literal unsigned int RECEIVING_AE

See Also

MCdicom Structure
MCdicom Members


RECEIVING_APPLICATION_ENTITY_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVING_APPLICATION_ENTITY_TITLE Field
MCdicom Structure See Also Send Feedback
Receiving Application Entity Title (0002,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVING_APPLICATION_ENTITY_TITLE
Visual Basic
Public Const RECEIVING_APPLICATION_ENTITY_TITLE As UInteger
Visual C++
public:
literal unsigned int RECEIVING_APPLICATION_ENTITY_TITLE

See Also

MCdicom Structure
MCdicom Members


RECEIVING_COIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVING_COIL Field
MCdicom Structure See Also Send Feedback
Alias for tag RECEIVE_COIL_NAME (0018,1250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVING_COIL
Visual Basic
Public Const RECEIVING_COIL As UInteger
Visual C++
public:
literal unsigned int RECEIVING_COIL

See Also

MCdicom Structure
MCdicom Members


RECEIVING_PRESENTATION_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECEIVING_PRESENTATION_ADDRESS Field
MCdicom Structure See Also Send Feedback
Receiving Presentation Address (0002,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECEIVING_PRESENTATION_ADDRESS
Visual Basic
Public Const RECEIVING_PRESENTATION_ADDRESS As UInteger
Visual C++
public:
literal unsigned int RECEIVING_PRESENTATION_ADDRESS

See Also

MCdicom Structure
MCdicom Members


RECOGNITION_CODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOGNITION_CODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Recognition Code RETIRED (0008,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOGNITION_CODE_RETIRED
Visual Basic
Public Const RECOGNITION_CODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RECOGNITION_CODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RECOGNIZABLE_VISUAL_FEATURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOGNIZABLE_VISUAL_FEATURES Field
MCdicom Structure See Also Send Feedback
Recognizable Visual Features (0028,0302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOGNIZABLE_VISUAL_FEATURES
Visual Basic
Public Const RECOGNIZABLE_VISUAL_FEATURES As UInteger
Visual C++
public:
literal unsigned int RECOGNIZABLE_VISUAL_FEATURES

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Recommended Absent Pixel CIELab Value (0048,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE
Visual Basic
Public Const RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_ABSENT_PIXEL_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_ANIMATION_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_ANIMATION_RATE Field
MCdicom Structure See Also Send Feedback
Recommended Animation Rate (0070,1A03)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_ANIMATION_RATE
Visual Basic
Public Const RECOMMENDED_ANIMATION_RATE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_ANIMATION_RATE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DEFAULT_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DEFAULT_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recommended Default Value Sequence (0082,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DEFAULT_VALUE_SEQUENCE
Visual Basic
Public Const RECOMMENDED_DEFAULT_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DEFAULT_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DISPLAY_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DISPLAY_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Recommended Display CIELab Value (0062,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DISPLAY_CIELAB_VALUE
Visual Basic
Public Const RECOMMENDED_DISPLAY_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DISPLAY_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST Field
MCdicom Structure See Also Send Feedback
Recommended Display CIELab Value List (0066,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST
Visual Basic
Public Const RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DISPLAY_CIELAB_VALUE_LIST

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DISPLAY_FRAME_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DISPLAY_FRAME_RATE Field
MCdicom Structure See Also Send Feedback
Recommended Display Frame Rate (0008,2144)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DISPLAY_FRAME_RATE
Visual Basic
Public Const RECOMMENDED_DISPLAY_FRAME_RATE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DISPLAY_FRAME_RATE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT Field
MCdicom Structure See Also Send Feedback
Recommended Display Frame Rate in Float (0008,9459)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT
Visual Basic
Public Const RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DISPLAY_FRAME_RATE_IN_FLOAT

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_DISPLAY_GRAYSCALE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_DISPLAY_GRAYSCALE_VALUE Field
MCdicom Structure See Also Send Feedback
Recommended Display Grayscale Value (0062,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_DISPLAY_GRAYSCALE_VALUE
Visual Basic
Public Const RECOMMENDED_DISPLAY_GRAYSCALE_VALUE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_DISPLAY_GRAYSCALE_VALUE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_EXPOSURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_EXPOSURE_INDEX Field
MCdicom Structure See Also Send Feedback
Recommended Exposure Index (0016,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_EXPOSURE_INDEX
Visual Basic
Public Const RECOMMENDED_EXPOSURE_INDEX As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_EXPOSURE_INDEX

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_LINE_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_LINE_THICKNESS Field
MCdicom Structure See Also Send Feedback
Recommended Line Thickness (0066,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_LINE_THICKNESS
Visual Basic
Public Const RECOMMENDED_LINE_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_LINE_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_POINT_RADIUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_POINT_RADIUS Field
MCdicom Structure See Also Send Feedback
Recommended Point Radius (0066,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_POINT_RADIUS
Visual Basic
Public Const RECOMMENDED_POINT_RADIUS As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_POINT_RADIUS

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_PRESENTATION_OPACITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_PRESENTATION_OPACITY Field
MCdicom Structure See Also Send Feedback
Recommended Presentation Opacity (0066,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_PRESENTATION_OPACITY
Visual Basic
Public Const RECOMMENDED_PRESENTATION_OPACITY As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_PRESENTATION_OPACITY

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_PRESENTATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_PRESENTATION_TYPE Field
MCdicom Structure See Also Send Feedback
Recommended Presentation Type (0066,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_PRESENTATION_TYPE
Visual Basic
Public Const RECOMMENDED_PRESENTATION_TYPE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_PRESENTATION_TYPE

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_ROTATION_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_ROTATION_POINT Field
MCdicom Structure See Also Send Feedback
Recommended Rotation Point (0068,6346)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_ROTATION_POINT
Visual Basic
Public Const RECOMMENDED_ROTATION_POINT As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_ROTATION_POINT

See Also

MCdicom Structure
MCdicom Members


RECOMMENDED_VIEWING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECOMMENDED_VIEWING_MODE Field
MCdicom Structure See Also Send Feedback
Recommended Viewing Mode (0028,1090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECOMMENDED_VIEWING_MODE
Visual Basic
Public Const RECOMMENDED_VIEWING_MODE As UInteger
Visual C++
public:
literal unsigned int RECOMMENDED_VIEWING_MODE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_ALGORITHM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_ALGORITHM Field
MCdicom Structure See Also Send Feedback
Reconstruction Algorithm (0018,9315)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_ALGORITHM
Visual Basic
Public Const RECONSTRUCTION_ALGORITHM As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_ALGORITHM

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction Algorithm Sequence (0018,993D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_ALGORITHM_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_ANGLE Field
MCdicom Structure See Also Send Feedback
Reconstruction Angle (0018,9319)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_ANGLE
Visual Basic
Public Const RECONSTRUCTION_ANGLE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_ANGLE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Reconstruction Description (0018,9531)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_DESCRIPTION
Visual Basic
Public Const RECONSTRUCTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_DIAMETER Field
MCdicom Structure See Also Send Feedback
Reconstruction Diameter (0018,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_DIAMETER
Visual Basic
Public Const RECONSTRUCTION_DIAMETER As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_DIAMETER

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_END_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_END_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction End Location Sequence (0018,993C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_END_LOCATION_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_END_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_END_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_FIELD_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_FIELD_OF_VIEW Field
MCdicom Structure See Also Send Feedback
Reconstruction Field of View (0018,9317)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_FIELD_OF_VIEW
Visual Basic
Public Const RECONSTRUCTION_FIELD_OF_VIEW As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_FIELD_OF_VIEW

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_INDEX Field
MCdicom Structure See Also Send Feedback
Reconstruction Index (0020,9536)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_INDEX
Visual Basic
Public Const RECONSTRUCTION_INDEX As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_INDEX

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_METHOD Field
MCdicom Structure See Also Send Feedback
Reconstruction Method (0054,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_METHOD
Visual Basic
Public Const RECONSTRUCTION_METHOD As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_METHOD

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_PIPELINE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_PIPELINE_TYPE Field
MCdicom Structure See Also Send Feedback
Reconstruction Pipeline Type (0018,11BE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_PIPELINE_TYPE
Visual Basic
Public Const RECONSTRUCTION_PIPELINE_TYPE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_PIPELINE_TYPE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_PIXEL_SPACING Field
MCdicom Structure See Also Send Feedback
Reconstruction Pixel Spacing (0018,9322)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_PIXEL_SPACING
Visual Basic
Public Const RECONSTRUCTION_PIXEL_SPACING As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_PIXEL_SPACING

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction Protocol Element Sequence (0018,9934)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_PROTOCOL_ELEMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction Protocol Element Specification Sequence (0018,9933)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_START_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_START_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction Start Location Sequence (0018,993B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_START_LOCATION_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_START_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_START_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reconstruction Target Center Location Sequence (0018,993E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE
Visual Basic
Public Const RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_TARGET_CENTER_LOCATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_TARGET_CENTER_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_TARGET_CENTER_PATIENT Field
MCdicom Structure See Also Send Feedback
Reconstruction Target Center (Patient) (0018,9318)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_TARGET_CENTER_PATIENT
Visual Basic
Public Const RECONSTRUCTION_TARGET_CENTER_PATIENT As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_TARGET_CENTER_PATIENT

See Also

MCdicom Structure
MCdicom Members


RECONSTRUCTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECONSTRUCTION_TYPE Field
MCdicom Structure See Also Send Feedback
Reconstruction Type (0018,9756)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECONSTRUCTION_TYPE
Visual Basic
Public Const RECONSTRUCTION_TYPE As UInteger
Visual C++
public:
literal unsigned int RECONSTRUCTION_TYPE

See Also

MCdicom Structure
MCdicom Members


RECORD_IN_USE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORD_IN_USE_FLAG Field
MCdicom Structure See Also Send Feedback
Record In-use Flag (0004,1410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORD_IN_USE_FLAG
Visual Basic
Public Const RECORD_IN_USE_FLAG As UInteger
Visual C++
public:
literal unsigned int RECORD_IN_USE_FLAG

See Also

MCdicom Structure
MCdicom Members


RECORD_KEY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORD_KEY Field
MCdicom Structure See Also Send Feedback
Record Key (0008,041B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORD_KEY
Visual Basic
Public Const RECORD_KEY As UInteger
Visual C++
public:
literal unsigned int RECORD_KEY

See Also

MCdicom Structure
MCdicom Members


RECORDED_BLOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_BLOCK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Block Sequence (3008,00D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_BLOCK_SEQUENCE
Visual Basic
Public Const RECORDED_BLOCK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_BLOCK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_BLOCK_SLAB_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_BLOCK_SLAB_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Block Slab Sequence (3008,00D1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_BLOCK_SLAB_SEQUENCE
Visual Basic
Public Const RECORDED_BLOCK_SLAB_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_BLOCK_SLAB_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Brachy Accessory Device Sequence (3008,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE
Visual Basic
Public Const RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_BRACHY_ACCESSORY_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_CHANNEL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_CHANNEL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Channel Sequence (3008,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_CHANNEL_SEQUENCE
Visual Basic
Public Const RECORDED_CHANNEL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_CHANNEL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_CHANNEL_SHIELD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_CHANNEL_SHIELD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Channel Shield Sequence (3008,0150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_CHANNEL_SHIELD_SEQUENCE
Visual Basic
Public Const RECORDED_CHANNEL_SHIELD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_CHANNEL_SHIELD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_CHANNEL_SHIELD_SEQUNCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_CHANNEL_SHIELD_SEQUNCE Field
MCdicom Structure See Also Send Feedback
Alias for tag RECORDED_CHANNEL_SHIELD_SEQUENCE (3008,0150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_CHANNEL_SHIELD_SEQUNCE
Visual Basic
Public Const RECORDED_CHANNEL_SHIELD_SEQUNCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_CHANNEL_SHIELD_SEQUNCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_COMPENSATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_COMPENSATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Compensator Sequence (3008,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_COMPENSATOR_SEQUENCE
Visual Basic
Public Const RECORDED_COMPENSATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_COMPENSATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Lateral Spreading Device Sequence (3008,00F4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE
Visual Basic
Public Const RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_LATERAL_SPREADING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_RANGE_MODULATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_RANGE_MODULATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Range Modulator Sequence (3008,00F6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_RANGE_MODULATOR_SEQUENCE
Visual Basic
Public Const RECORDED_RANGE_MODULATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_RANGE_MODULATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_RANGE_SHIFTER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_RANGE_SHIFTER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Range Shifter Sequence (3008,00F2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_RANGE_SHIFTER_SEQUENCE
Visual Basic
Public Const RECORDED_RANGE_SHIFTER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_RANGE_SHIFTER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_RT_CONTROL_POINT_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_RT_CONTROL_POINT_DATETIME Field
MCdicom Structure See Also Send Feedback
Recorded RT Control Point DateTime (300A,073A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_RT_CONTROL_POINT_DATETIME
Visual Basic
Public Const RECORDED_RT_CONTROL_POINT_DATETIME As UInteger
Visual C++
public:
literal unsigned int RECORDED_RT_CONTROL_POINT_DATETIME

See Also

MCdicom Structure
MCdicom Members


RECORDED_SNOUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_SNOUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Snout Sequence (3008,00F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_SNOUT_SEQUENCE
Visual Basic
Public Const RECORDED_SNOUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_SNOUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_SOURCE_APPLICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_SOURCE_APPLICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag RECORDED_SOURCE_APPLICATOR_SEQUENCE (3008,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_SOURCE_APPLICATION_SEQUENCE
Visual Basic
Public Const RECORDED_SOURCE_APPLICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_SOURCE_APPLICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_SOURCE_APPLICATOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_SOURCE_APPLICATOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Source Applicator Sequence (3008,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_SOURCE_APPLICATOR_SEQUENCE
Visual Basic
Public Const RECORDED_SOURCE_APPLICATOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_SOURCE_APPLICATOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Source Sequence (3008,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_SOURCE_SEQUENCE
Visual Basic
Public Const RECORDED_SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECORDED_WEDGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECORDED_WEDGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Recorded Wedge Sequence (3008,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECORDED_WEDGE_SEQUENCE
Visual Basic
Public Const RECORDED_WEDGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RECORDED_WEDGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RECTIFICATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECTIFICATION_TYPE Field
MCdicom Structure See Also Send Feedback
Rectification Type (0018,1156)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECTIFICATION_TYPE
Visual Basic
Public Const RECTIFICATION_TYPE As UInteger
Visual C++
public:
literal unsigned int RECTIFICATION_TYPE

See Also

MCdicom Structure
MCdicom Members


RECTIFIER_SMOOTHING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECTIFIER_SMOOTHING Field
MCdicom Structure See Also Send Feedback
Rectifier Smoothing (0014,4034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECTIFIER_SMOOTHING
Visual Basic
Public Const RECTIFIER_SMOOTHING As UInteger
Visual C++
public:
literal unsigned int RECTIFIER_SMOOTHING

See Also

MCdicom Structure
MCdicom Members


RECTILINEAR_PHASE_ENCODE_REORDERING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RECTILINEAR_PHASE_ENCODE_REORDERING Field
MCdicom Structure See Also Send Feedback
Rectilinear Phase Encode Reordering (0018,9034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RECTILINEAR_PHASE_ENCODE_REORDERING
Visual Basic
Public Const RECTILINEAR_PHASE_ENCODE_REORDERING As UInteger
Visual C++
public:
literal unsigned int RECTILINEAR_PHASE_ENCODE_REORDERING

See Also

MCdicom Structure
MCdicom Members


RED_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RED_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Red Palette Color Lookup Table Data (0028,1201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RED_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const RED_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int RED_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Red Palette Color Lookup Table Descriptor (0028,1101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int RED_PALETTE_COLOR_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


REFERENCE_AIR_KERMA_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_AIR_KERMA_RATE Field
MCdicom Structure See Also Send Feedback
Reference Air Kerma Rate (300A,022A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_AIR_KERMA_RATE
Visual Basic
Public Const REFERENCE_AIR_KERMA_RATE As UInteger
Visual C++
public:
literal unsigned int REFERENCE_AIR_KERMA_RATE

See Also

MCdicom Structure
MCdicom Members


REFERENCE_BASIS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_BASIS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reference Basis Code Sequence (0018,9902)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_BASIS_CODE_SEQUENCE
Visual Basic
Public Const REFERENCE_BASIS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCE_BASIS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_COORDINATES Field
MCdicom Structure See Also Send Feedback
Reference Coordinates (0022,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_COORDINATES
Visual Basic
Public Const REFERENCE_COORDINATES As UInteger
Visual C++
public:
literal unsigned int REFERENCE_COORDINATES

See Also

MCdicom Structure
MCdicom Members


REFERENCE_DISPLAY_SETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_DISPLAY_SETS Field
MCdicom Structure See Also Send Feedback
Reference Display Sets (0072,0218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_DISPLAY_SETS
Visual Basic
Public Const REFERENCE_DISPLAY_SETS As UInteger
Visual C++
public:
literal unsigned int REFERENCE_DISPLAY_SETS

See Also

MCdicom Structure
MCdicom Members


REFERENCE_DOSE_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_DOSE_DEFINITION Field
MCdicom Structure See Also Send Feedback
Reference Dose Definition (300A,0512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_DOSE_DEFINITION
Visual Basic
Public Const REFERENCE_DOSE_DEFINITION As UInteger
Visual C++
public:
literal unsigned int REFERENCE_DOSE_DEFINITION

See Also

MCdicom Structure
MCdicom Members


REFERENCE_DOSE_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_DOSE_POINT_COORDINATES Field
MCdicom Structure See Also Send Feedback
Reference Dose Point Coordinates (300A,061E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_DOSE_POINT_COORDINATES
Visual Basic
Public Const REFERENCE_DOSE_POINT_COORDINATES As UInteger
Visual C++
public:
literal unsigned int REFERENCE_DOSE_POINT_COORDINATES

See Also

MCdicom Structure
MCdicom Members


REFERENCE_DOSE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_DOSE_TYPE Field
MCdicom Structure See Also Send Feedback
Reference Dose Type (300A,061A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_DOSE_TYPE
Visual Basic
Public Const REFERENCE_DOSE_TYPE As UInteger
Visual C++
public:
literal unsigned int REFERENCE_DOSE_TYPE

See Also

MCdicom Structure
MCdicom Members


REFERENCE_GEOMETRY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_GEOMETRY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Reference Geometry Code Sequence (0018,9903)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_GEOMETRY_CODE_SEQUENCE
Visual Basic
Public Const REFERENCE_GEOMETRY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCE_GEOMETRY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCE_IMAGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_IMAGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Reference Image Number (300A,00C8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_IMAGE_NUMBER
Visual Basic
Public Const REFERENCE_IMAGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCE_IMAGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCE_LOCATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_LOCATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Reference Location Description (0018,9901)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_LOCATION_DESCRIPTION
Visual Basic
Public Const REFERENCE_LOCATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int REFERENCE_LOCATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


REFERENCE_LOCATION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_LOCATION_LABEL Field
MCdicom Structure See Also Send Feedback
Reference Location Label (0018,9900)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_LOCATION_LABEL
Visual Basic
Public Const REFERENCE_LOCATION_LABEL As UInteger
Visual C++
public:
literal unsigned int REFERENCE_LOCATION_LABEL

See Also

MCdicom Structure
MCdicom Members


REFERENCE_PIXEL_PHYSICAL_VALUE_X Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_PIXEL_PHYSICAL_VALUE_X Field
MCdicom Structure See Also Send Feedback
Reference Pixel Physical Value X (0018,6028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_PIXEL_PHYSICAL_VALUE_X
Visual Basic
Public Const REFERENCE_PIXEL_PHYSICAL_VALUE_X As UInteger
Visual C++
public:
literal unsigned int REFERENCE_PIXEL_PHYSICAL_VALUE_X

See Also

MCdicom Structure
MCdicom Members


REFERENCE_PIXEL_PHYSICAL_VALUE_Y Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_PIXEL_PHYSICAL_VALUE_Y Field
MCdicom Structure See Also Send Feedback
Reference Pixel Physical Value Y (0018,602A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_PIXEL_PHYSICAL_VALUE_Y
Visual Basic
Public Const REFERENCE_PIXEL_PHYSICAL_VALUE_Y As UInteger
Visual C++
public:
literal unsigned int REFERENCE_PIXEL_PHYSICAL_VALUE_Y

See Also

MCdicom Structure
MCdicom Members


REFERENCE_PIXEL_X0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_PIXEL_X0 Field
MCdicom Structure See Also Send Feedback
Reference Pixel X0 (0018,6020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_PIXEL_X0
Visual Basic
Public Const REFERENCE_PIXEL_X0 As UInteger
Visual C++
public:
literal unsigned int REFERENCE_PIXEL_X0

See Also

MCdicom Structure
MCdicom Members


REFERENCE_PIXEL_Y0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_PIXEL_Y0 Field
MCdicom Structure See Also Send Feedback
Reference Pixel Y0 (0018,6022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_PIXEL_Y0
Visual Basic
Public Const REFERENCE_PIXEL_Y0 As UInteger
Visual C++
public:
literal unsigned int REFERENCE_PIXEL_Y0

See Also

MCdicom Structure
MCdicom Members


REFERENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Reference RETIRED (0020,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_RETIRED
Visual Basic
Public Const REFERENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCE_TO_RECORDED_SOUND_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCE_TO_RECORDED_SOUND_RETIRED Field
MCdicom Structure See Also Send Feedback
Reference to Recorded Sound RETIRED (4008,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCE_TO_RECORDED_SOUND_RETIRED
Visual Basic
Public Const REFERENCE_TO_RECORDED_SOUND_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCE_TO_RECORDED_SOUND_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Accession Sequence (Trial) RETIRED (0040,A313)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_ACCESSION_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_ASSERTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_ASSERTION_UID Field
MCdicom Structure See Also Send Feedback
Referenced Assertion UID (0044,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_ASSERTION_UID
Visual Basic
Public Const REFERENCED_ASSERTION_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_ASSERTION_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Baseline Parameters RT Radiation Instance Sequence (3002,011E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Basic Annotation Box Sequence (2010,0520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE
Visual Basic
Public Const REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BASIC_ANNOTATION_BOX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BEAM_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BEAM_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Beam Number (300C,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BEAM_NUMBER
Visual Basic
Public Const REFERENCED_BEAM_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BEAM_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BEAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BEAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Beam Sequence (300C,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BEAM_SEQUENCE
Visual Basic
Public Const REFERENCED_BEAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BEAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BLOCK_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BLOCK_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Block Number (300C,00E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BLOCK_NUMBER
Visual Basic
Public Const REFERENCED_BLOCK_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BLOCK_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BOLUS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BOLUS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Bolus Sequence (300C,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BOLUS_SEQUENCE
Visual Basic
Public Const REFERENCED_BOLUS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BOLUS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Brachy Accessory Device Number (3008,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER
Visual Basic
Public Const REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BRACHY_ACCESSORY_DEVICE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Brachy Application Setup Number (300C,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER
Visual Basic
Public Const REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BRACHY_APPLICATION_SETUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Brachy Application Setup Sequence (300C,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE
Visual Basic
Public Const REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_BRACHY_APPLICATION_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Calculated Dose Reference Number (3008,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER
Visual Basic
Public Const REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CALCULATED_DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Calculated Dose Reference Sequence (3008,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CALCULATED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CHANNEL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CHANNEL_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Channel Number (0074,1406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CHANNEL_NUMBER
Visual Basic
Public Const REFERENCED_CHANNEL_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CHANNEL_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CHANNEL_SHIELD_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CHANNEL_SHIELD_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Channel Shield Number (3008,0152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CHANNEL_SHIELD_NUMBER
Visual Basic
Public Const REFERENCED_CHANNEL_SHIELD_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CHANNEL_SHIELD_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_COLOR_PALETTE_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_COLOR_PALETTE_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Referenced Color Palette Instance UID (0028,0304)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_COLOR_PALETTE_INSTANCE_UID
Visual Basic
Public Const REFERENCED_COLOR_PALETTE_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_COLOR_PALETTE_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Comparison SOP Instance Sequence (0082,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_COMPARISON_SOP_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_COMPENSATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_COMPENSATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Compensator Number (300C,00D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_COMPENSATOR_NUMBER
Visual Basic
Public Const REFERENCED_COMPENSATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_COMPENSATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONCEPTUAL_VOLUME_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONCEPTUAL_VOLUME_UID Field
MCdicom Structure See Also Send Feedback
Referenced Conceptual Volume UID (3010,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONCEPTUAL_VOLUME_UID
Visual Basic
Public Const REFERENCED_CONCEPTUAL_VOLUME_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONCEPTUAL_VOLUME_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONTENT_ITEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONTENT_ITEM Field
MCdicom Structure See Also Send Feedback
Referenced Content Item (0070,1904)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONTENT_ITEM
Visual Basic
Public Const REFERENCED_CONTENT_ITEM As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONTENT_ITEM

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONTENT_ITEM_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONTENT_ITEM_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Referenced Content Item Identifier (0040,DB73)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONTENT_ITEM_IDENTIFIER
Visual Basic
Public Const REFERENCED_CONTENT_ITEM_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONTENT_ITEM_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONTROL_POINT Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_CONTROL_POINT_INDEX (300C,00F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONTROL_POINT
Visual Basic
Public Const REFERENCED_CONTROL_POINT As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONTROL_POINT

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Control Point Index (300C,00F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONTROL_POINT_INDEX
Visual Basic
Public Const REFERENCED_CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Control Point Sequence (300C,00F2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const REFERENCED_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_CURVE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_CURVE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Curve Sequence RETIRED (0008,1145)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_CURVE_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_CURVE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_CURVE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DATETIME Field
MCdicom Structure See Also Send Feedback
Referenced DateTime (0040,A13A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DATETIME
Visual Basic
Public Const REFERENCED_DATETIME As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DATETIME

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DEFINED_DEVICE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DEFINED_DEVICE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Defined Device Index (300A,0602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DEFINED_DEVICE_INDEX
Visual Basic
Public Const REFERENCED_DEFINED_DEVICE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DEFINED_DEVICE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DEFINED_PROTOCOL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DEFINED_PROTOCOL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Defined Protocol Sequence (0018,990C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DEFINED_PROTOCOL_SEQUENCE
Visual Basic
Public Const REFERENCED_DEFINED_PROTOCOL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DEFINED_PROTOCOL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DEVICE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DEVICE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Device Index (300A,0607)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DEVICE_INDEX
Visual Basic
Public Const REFERENCED_DEVICE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DEVICE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DIGITAL_SIGNATURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DIGITAL_SIGNATURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Digital Signature Sequence (0400,0402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DIGITAL_SIGNATURE_SEQUENCE
Visual Basic
Public Const REFERENCED_DIGITAL_SIGNATURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DIGITAL_SIGNATURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Direct Segment Instance Sequence (3010,004A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DIRECT_SEGMENT_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Dose Reference Number (300C,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSE_REFERENCE_NUMBER
Visual Basic
Public Const REFERENCED_DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Dose Reference Sequence (300C,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const REFERENCED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSE_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSE_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Referenced Dose Reference UID (300A,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSE_REFERENCE_UID
Visual Basic
Public Const REFERENCED_DOSE_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSE_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Dose Sequence (300C,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSE_SEQUENCE
Visual Basic
Public Const REFERENCED_DOSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSIMETRIC_OBJECTIVE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSIMETRIC_OBJECTIVE_UID Field
MCdicom Structure See Also Send Feedback
Referenced Dosimetric Objective UID (3010,006F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSIMETRIC_OBJECTIVE_UID
Visual Basic
Public Const REFERENCED_DOSIMETRIC_OBJECTIVE_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSIMETRIC_OBJECTIVE_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Dosimetric Objectives Sequence (3010,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE
Visual Basic
Public Const REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_DOSIMETRIC_OBJECTIVES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Expected In-Vivo Measurement Value Index (300A,0773)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX
Visual Basic
Public Const REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_EXPECTED_IN_VIVO_MEASUREMENT_VALUE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FIDUCIAL_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FIDUCIAL_UID Field
MCdicom Structure See Also Send Feedback
Referenced Fiducial UID (0070,031B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FIDUCIAL_UID
Visual Basic
Public Const REFERENCED_FIDUCIAL_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FIDUCIAL_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FIDUCIALS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FIDUCIALS_UID Field
MCdicom Structure See Also Send Feedback
Referenced Fiducials UID (3010,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FIDUCIALS_UID
Visual Basic
Public Const REFERENCED_FIDUCIALS_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FIDUCIALS_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FILE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FILE_ID Field
MCdicom Structure See Also Send Feedback
Referenced File ID (0004,1500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FILE_ID
Visual Basic
Public Const REFERENCED_FILE_ID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FILE_ID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FILM_BOX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FILM_BOX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Film Box Sequence (2000,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FILM_BOX_SEQUENCE
Visual Basic
Public Const REFERENCED_FILM_BOX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FILM_BOX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FILM_SESSION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FILM_SESSION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Film Session Sequence (2010,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FILM_SESSION_SEQUENCE
Visual Basic
Public Const REFERENCED_FILM_SESSION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FILM_SESSION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Findings Group UID (Trial) RETIRED (0040,A022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED
Visual Basic
Public Const REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FINDINGS_GROUP_UID_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FIRST_FRAME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FIRST_FRAME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced First Frame Sequence (0072,0427)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FIRST_FRAME_SEQUENCE
Visual Basic
Public Const REFERENCED_FIRST_FRAME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FIRST_FRAME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRACTION_GROUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRACTION_GROUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Fraction Group Number (300C,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRACTION_GROUP_NUMBER
Visual Basic
Public Const REFERENCED_FRACTION_GROUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRACTION_GROUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRACTION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRACTION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Fraction Group Sequence (300C,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRACTION_GROUP_SEQUENCE
Visual Basic
Public Const REFERENCED_FRACTION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRACTION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRACTION_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRACTION_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Fraction Number (3008,0223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRACTION_NUMBER
Visual Basic
Public Const REFERENCED_FRACTION_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRACTION_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRAME_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRAME_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Frame Number (0008,1160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRAME_NUMBER
Visual Basic
Public Const REFERENCED_FRAME_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRAME_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRAME_NUMBERS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRAME_NUMBERS_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Frame Numbers RETIRED (0040,A136)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRAME_NUMBERS_RETIRED
Visual Basic
Public Const REFERENCED_FRAME_NUMBERS_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRAME_NUMBERS_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRAME_OF_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRAME_OF_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Frame of Reference Sequence (3006,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRAME_OF_REFERENCE_SEQUENCE
Visual Basic
Public Const REFERENCED_FRAME_OF_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRAME_OF_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Referenced Frame of Reference UID (3006,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const REFERENCED_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced General Purpose Scheduled Procedure Step Sequence RETIRED (0040,4016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced General Purpose Scheduled Procedure Step Transaction UID RETIRED (0040,4023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED
Visual Basic
Public Const REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION
Visual Basic
Public Const REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION As UInteger
Visual C++
public:
literal unsigned int REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION

See Also

MCdicom Structure
MCdicom Members


REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_GENERAL_PURPOSE_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID_RETIRED (0040,4023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID
Visual Basic
Public Const REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_GP_SCHEDULED_PROCEDURE_STEP_TRANSACTION_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE (0008,9237)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE
Visual Basic
Public Const REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_GRAYSCALE_PRESENTATION_STATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_HPGL_DOCUMENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_HPGL_DOCUMENT_ID Field
MCdicom Structure See Also Send Feedback
Referenced HPGL Document ID (0068,6440)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_HPGL_DOCUMENT_ID
Visual Basic
Public Const REFERENCED_HPGL_DOCUMENT_ID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_HPGL_DOCUMENT_ID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_BOX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_BOX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Image Box Sequence (2010,0510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_BOX_SEQUENCE
Visual Basic
Public Const REFERENCED_IMAGE_BOX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_BOX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Image Box Sequence (Retired) (2040,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_BOX_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Image Evidence Sequence (0008,9092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_EVIDENCE_SEQUENCE
Visual Basic
Public Const REFERENCED_IMAGE_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Image Navigation Sequence RETIRED (0048,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_NAVIGATION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Image Overlay Box Sequence RETIRED (2020,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_OVERLAY_BOX_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Image Real World Value Mapping Sequence (0040,9094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE
Visual Basic
Public Const REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_REAL_WORLD_VALUE_MAPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Image Sequence (0008,1140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMAGE_SEQUENCE
Visual Basic
Public Const REFERENCED_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID Field
MCdicom Structure See Also Send Feedback
Referenced Implant Template Group Member ID (0078,00B6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID
Visual Basic
Public Const REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_IMPLANT_TEMPLATE_GROUP_MEMBER_ID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Instance Sequence (0008,114A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_INTERPRETATION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_INTERPRETATION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Interpretation Sequence RETIRED (4008,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_INTERPRETATION_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_INTERPRETATION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_INTERPRETATION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Lateral Spreading Device Number (300C,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER
Visual Basic
Public Const REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_LATERAL_SPREADING_DEVICE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Measured Dose Reference Number (3008,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER
Visual Basic
Public Const REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_MEASURED_DOSE_REFERENCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Measured Dose Reference Sequence (3008,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_MEASURED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Non-Image Composite SOP Instance Sequence (0040,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Object Observation Class (Trial) RETIRED (0040,A174)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED
Visual Basic
Public Const REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OBJECT_OBSERVATION_CLASS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Observation Class (Trial) RETIRED (0040,A173)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED
Visual Basic
Public Const REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OBSERVATION_CLASS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OBSERVATION_UID_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OBSERVATION_UID_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Observation UID (Trial) RETIRED (0040,A172)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OBSERVATION_UID_TRIAL_RETIRED
Visual Basic
Public Const REFERENCED_OBSERVATION_UID_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OBSERVATION_UID_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Ophthalmic Axial Length Measurement QC Image Sequence (0022,1330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE
Visual Basic
Public Const REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENT_QC_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Ophthalmic Axial Measurements Sequence (0022,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OPHTHALMIC_AXIAL_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OPTICAL_PATH_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OPTICAL_PATH_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Referenced Optical Path Identifier (006A,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OPTICAL_PATH_IDENTIFIER
Visual Basic
Public Const REFERENCED_OPTICAL_PATH_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OPTICAL_PATH_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OTHER_PLANE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OTHER_PLANE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Other Plane Sequence (0008,9410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OTHER_PLANE_SEQUENCE
Visual Basic
Public Const REFERENCED_OTHER_PLANE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OTHER_PLANE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Overlay Plane Groups RETIRED (2040,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED
Visual Basic
Public Const REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OVERLAY_PLANE_GROUPS_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Overlay Plane Sequence RETIRED (2040,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OVERLAY_PLANE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_OVERLAY_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_OVERLAY_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Overlay Sequence RETIRED (0008,1130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_OVERLAY_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_OVERLAY_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_OVERLAY_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PARENT_RT_PRESCRIPTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PARENT_RT_PRESCRIPTION_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Parent RT Prescription Index (3010,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PARENT_RT_PRESCRIPTION_INDEX
Visual Basic
Public Const REFERENCED_PARENT_RT_PRESCRIPTION_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PARENT_RT_PRESCRIPTION_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATH_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATH_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Path Index (0018,9378)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATH_INDEX
Visual Basic
Public Const REFERENCED_PATH_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATH_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_ALIAS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_ALIAS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Patient Alias Sequence (0038,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_ALIAS_SEQUENCE
Visual Basic
Public Const REFERENCED_PATIENT_ALIAS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_ALIAS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_PHOTO_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_PHOTO_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Patient Photo Sequence (0010,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_PHOTO_SEQUENCE
Visual Basic
Public Const REFERENCED_PATIENT_PHOTO_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_PHOTO_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Patient Sequence (0008,1120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_SEQUENCE
Visual Basic
Public Const REFERENCED_PATIENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_SETUP_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_SETUP_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Patient Setup Number (300C,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_SETUP_NUMBER
Visual Basic
Public Const REFERENCED_PATIENT_SETUP_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_SETUP_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Patient Setup Photo Sequence (300A,078C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE
Visual Basic
Public Const REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_SETUP_PHOTO_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Patient Setup Procedure Index (300A,0796)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX
Visual Basic
Public Const REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PATIENT_SETUP_PROCEDURE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Performed Procedure Step Sequence (0008,1111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE
Visual Basic
Public Const REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PERFORMED_PROTOCOL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PERFORMED_PROTOCOL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Performed Protocol Sequence (0018,990D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PERFORMED_PROTOCOL_SEQUENCE
Visual Basic
Public Const REFERENCED_PERFORMED_PROTOCOL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PERFORMED_PROTOCOL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PLAN_OVERVIEW_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PLAN_OVERVIEW_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Plan Overview Index (300C,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PLAN_OVERVIEW_INDEX
Visual Basic
Public Const REFERENCED_PLAN_OVERVIEW_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PLAN_OVERVIEW_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Position Reference Instance Sequence (3002,0132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_POSITION_REFERENCE_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PRESENTATION_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PRESENTATION_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Presentation LUT Sequence (2050,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PRESENTATION_LUT_SEQUENCE
Visual Basic
Public Const REFERENCED_PRESENTATION_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PRESENTATION_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PRESENTATION_STATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PRESENTATION_STATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Presentation State Sequence (0008,9237)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PRESENTATION_STATE_SEQUENCE
Visual Basic
Public Const REFERENCED_PRESENTATION_STATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PRESENTATION_STATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Print Job Sequence (Pull Stored Print) RETIRED (2100,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED
Visual Basic
Public Const REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PRINT_JOB_SEQUENCE_PULL_STORED_PRINT_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PRINT_JOB_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PRINT_JOB_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Print Job Sequence RETIRED (2120,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PRINT_JOB_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_PRINT_JOB_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PRINT_JOB_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Procedure Step Sequence RETIRED (0040,0330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_PROCEDURE_STEP_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Radiation Dose Identification Index (300A,060C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX
Visual Basic
Public Const REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RADIATION_DOSE_IDENTIFICATION_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RADIATION_GENERATION_MODE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RADIATION_GENERATION_MODE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Radiation Generation Mode Index (300A,0605)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RADIATION_GENERATION_MODE_INDEX
Visual Basic
Public Const REFERENCED_RADIATION_GENERATION_MODE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RADIATION_GENERATION_MODE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Radiation RT Control Point Index (300A,073B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX
Visual Basic
Public Const REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RADIATION_RT_CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RANGE_MODULATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RANGE_MODULATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Range Modulator Number (300C,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RANGE_MODULATOR_NUMBER
Visual Basic
Public Const REFERENCED_RANGE_MODULATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RANGE_MODULATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RANGE_SHIFTER_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RANGE_SHIFTER_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Range Shifter Number (300C,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RANGE_SHIFTER_NUMBER
Visual Basic
Public Const REFERENCED_RANGE_SHIFTER_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RANGE_SHIFTER_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RAW_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RAW_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Raw Data Sequence (0008,9121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RAW_DATA_SEQUENCE
Visual Basic
Public Const REFERENCED_RAW_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RAW_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Real World Value Mapping Instance Sequence (0008,114B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_REAL_WORLD_VALUE_MAPPING_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_REFERENCE_IMAGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_REFERENCE_IMAGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Reference Image Number (300C,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_REFERENCE_IMAGE_NUMBER
Visual Basic
Public Const REFERENCED_REFERENCE_IMAGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_REFERENCE_IMAGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_REFERENCE_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_REFERENCE_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Reference Image Sequence (300C,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_REFERENCE_IMAGE_SEQUENCE
Visual Basic
Public Const REFERENCED_REFERENCE_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_REFERENCE_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Refractive Measurements Sequence (0046,0145)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_REFRACTIVE_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE Field
MCdicom Structure See Also Send Feedback
Referenced Related General SOP Class UID in File (0004,151A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE
Visual Basic
Public Const REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RELATED_GENERAL_SOP_CLASS_UID_IN_FILE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_REQUEST_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_REQUEST_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Request Sequence (0040,A370)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_REQUEST_SEQUENCE
Visual Basic
Public Const REFERENCED_REQUEST_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_REQUEST_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RESULTS_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RESULTS_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Results Sequence RETIRED (0008,1100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RESULTS_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_RESULTS_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RESULTS_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_ROI_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_ROI_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced ROI Number (3006,0084)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_ROI_NUMBER
Visual Basic
Public Const REFERENCED_ROI_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_ROI_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced RT Accessory Holder Device Index (300A,060E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX
Visual Basic
Public Const REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_ACCESSORY_HOLDER_DEVICE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Instance Sequence (300A,0631)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced RT Patient Setup Sequence RETIRED (300A,0632)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PATIENT_SETUP_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PHYSICIAN_INTENT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PHYSICIAN_INTENT_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced RT Physician Intent Index (3010,005E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PHYSICIAN_INTENT_INDEX
Visual Basic
Public Const REFERENCED_RT_PHYSICIAN_INTENT_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PHYSICIAN_INTENT_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Physician Intent Sequence (300A,063B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PHYSICIAN_INTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PLAN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PLAN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Plan Sequence (300C,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PLAN_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_PLAN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PLAN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PRESCRIPTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PRESCRIPTION_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced RT Prescription Index (3010,0041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PRESCRIPTION_INDEX
Visual Basic
Public Const REFERENCED_RT_PRESCRIPTION_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PRESCRIPTION_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_PRESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_PRESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Prescription Sequence (300A,068A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_PRESCRIPTION_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_PRESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_PRESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_RADIATION_RECORD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_RADIATION_RECORD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Radiation Record Sequence (300A,0703)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_RADIATION_RECORD_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_RADIATION_RECORD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_RADIATION_RECORD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_RADIATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_RADIATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Radiation Sequence (300A,0630)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_RADIATION_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_RADIATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_RADIATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_RADIATION_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_RADIATION_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Radiation Set Sequence (300A,0702)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_RADIATION_SET_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_RADIATION_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_RADIATION_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_TREATMENT_PHASE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_TREATMENT_PHASE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced RT Treatment Phase Index (3010,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_TREATMENT_PHASE_INDEX
Visual Basic
Public Const REFERENCED_RT_TREATMENT_PHASE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_TREATMENT_PHASE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_TREATMENT_PHASE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_TREATMENT_PHASE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Treatment Phase Sequence (3010,0049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_TREATMENT_PHASE_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_TREATMENT_PHASE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_TREATMENT_PHASE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced RT Treatment Preparation Sequence (300A,078B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE
Visual Basic
Public Const REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_RT_TREATMENT_PREPARATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SAMPLE_POSITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SAMPLE_POSITIONS Field
MCdicom Structure See Also Send Feedback
Referenced Sample Positions (0040,A132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SAMPLE_POSITIONS
Visual Basic
Public Const REFERENCED_SAMPLE_POSITIONS As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SAMPLE_POSITIONS

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SEGMENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SEGMENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Segment Number (0062,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SEGMENT_NUMBER
Visual Basic
Public Const REFERENCED_SEGMENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SEGMENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SEGMENT_REFERENCE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SEGMENT_REFERENCE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Segment Reference Index (3010,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SEGMENT_REFERENCE_INDEX
Visual Basic
Public Const REFERENCED_SEGMENT_REFERENCE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SEGMENT_REFERENCE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SERIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SERIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Series Sequence (0008,1115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SERIES_SEQUENCE
Visual Basic
Public Const REFERENCED_SERIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SERIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SETUP_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SETUP_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Setup Image Sequence (300A,0401)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SETUP_IMAGE_SEQUENCE
Visual Basic
Public Const REFERENCED_SETUP_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SETUP_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Referenced SOP Class UID (0008,1150)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_CLASS_UID
Visual Basic
Public Const REFERENCED_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_CLASS_UID_IN_FILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_CLASS_UID_IN_FILE Field
MCdicom Structure See Also Send Feedback
Referenced SOP Class UID in File (0004,1510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_CLASS_UID_IN_FILE
Visual Basic
Public Const REFERENCED_SOP_CLASS_UID_IN_FILE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_CLASS_UID_IN_FILE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_INSTANCE_MAC_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_INSTANCE_MAC_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced SOP Instance MAC Sequence (0400,0403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_INSTANCE_MAC_SEQUENCE
Visual Basic
Public Const REFERENCED_SOP_INSTANCE_MAC_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_INSTANCE_MAC_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Referenced SOP Instance UID (0008,1155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_INSTANCE_UID
Visual Basic
Public Const REFERENCED_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_INSTANCE_UID_IN_FILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_INSTANCE_UID_IN_FILE Field
MCdicom Structure See Also Send Feedback
Referenced SOP Instance UID in File (0004,1511)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_INSTANCE_UID_IN_FILE
Visual Basic
Public Const REFERENCED_SOP_INSTANCE_UID_IN_FILE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_INSTANCE_UID_IN_FILE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced SOP Sequence (0008,1199)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOP_SEQUENCE
Visual Basic
Public Const REFERENCED_SOP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOURCE_APPLICATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOURCE_APPLICATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Source Applicator Number (3008,0142)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOURCE_APPLICATOR_NUMBER
Visual Basic
Public Const REFERENCED_SOURCE_APPLICATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOURCE_APPLICATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SOURCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SOURCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Source Number (300C,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SOURCE_NUMBER
Visual Basic
Public Const REFERENCED_SOURCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SOURCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SPATIAL_REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SPATIAL_REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Spatial Registration Sequence (0070,0404)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SPATIAL_REGISTRATION_SEQUENCE
Visual Basic
Public Const REFERENCED_SPATIAL_REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SPATIAL_REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_NON_IMAGE_COMPOSITE_SOP_INSTANCE_SEQUENCE (0040,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STANDALONE_SOP_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_START_CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_START_CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Start Control Point Index (300C,00F4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_START_CONTROL_POINT_INDEX
Visual Basic
Public Const REFERENCED_START_CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_START_CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Stereometric Instance Sequence (0008,1134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE
Visual Basic
Public Const REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STEREOMETRIC_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STOP_CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STOP_CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Stop Control Point Index (300C,00F6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STOP_CONTROL_POINT_INDEX
Visual Basic
Public Const REFERENCED_STOP_CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STOP_CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STORAGE_MEDIA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STORAGE_MEDIA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Storage Media Sequence (2200,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STORAGE_MEDIA_SEQUENCE
Visual Basic
Public Const REFERENCED_STORAGE_MEDIA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STORAGE_MEDIA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STORED_PRINT_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STORED_PRINT_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced Stored Print Sequence RETIRED (2000,0510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STORED_PRINT_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_STORED_PRINT_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STORED_PRINT_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STRUCTURE_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STRUCTURE_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Structure Set Sequence (300C,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STRUCTURE_SET_SEQUENCE
Visual Basic
Public Const REFERENCED_STRUCTURE_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STRUCTURE_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STRUCTURED_CONTEXT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STRUCTURED_CONTEXT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Structured Context Sequence (0070,1903)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STRUCTURED_CONTEXT_SEQUENCE
Visual Basic
Public Const REFERENCED_STRUCTURED_CONTEXT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STRUCTURED_CONTEXT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STUDY_COMPONENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STUDY_COMPONENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag REFERENCED_PERFORMED_PROCEDURE_STEP_SEQUENCE (0008,1111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STUDY_COMPONENT_SEQUENCE
Visual Basic
Public Const REFERENCED_STUDY_COMPONENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STUDY_COMPONENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_STUDY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_STUDY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Study Sequence (0008,1110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_STUDY_SEQUENCE
Visual Basic
Public Const REFERENCED_STUDY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_STUDY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SURFACE_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SURFACE_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Surface Data Sequence (0080,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SURFACE_DATA_SEQUENCE
Visual Basic
Public Const REFERENCED_SURFACE_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SURFACE_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Surface Mesh Identification Sequence (0022,1620)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SURFACE_MESH_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SURFACE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SURFACE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Surface Number (0066,002C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SURFACE_NUMBER
Visual Basic
Public Const REFERENCED_SURFACE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SURFACE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_SURFACE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_SURFACE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Surface Sequence (0066,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_SURFACE_SEQUENCE
Visual Basic
Public Const REFERENCED_SURFACE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_SURFACE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID Field
MCdicom Structure See Also Send Feedback
Referenced Target Luminance Characteristics ID (0028,700E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID
Visual Basic
Public Const REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TARGET_LUMINANCE_CHARACTERISTICS_ID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TEXTURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TEXTURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Texture Sequence (0080,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TEXTURE_SEQUENCE
Visual Basic
Public Const REFERENCED_TEXTURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TEXTURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TIME_OFFSETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TIME_OFFSETS Field
MCdicom Structure See Also Send Feedback
Referenced Time Offsets (0040,A138)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TIME_OFFSETS
Visual Basic
Public Const REFERENCED_TIME_OFFSETS As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TIME_OFFSETS

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TOLERANCE_TABLE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TOLERANCE_TABLE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Tolerance Table Number (300C,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TOLERANCE_TABLE_NUMBER
Visual Basic
Public Const REFERENCED_TOLERANCE_TABLE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TOLERANCE_TABLE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE Field
MCdicom Structure See Also Send Feedback
Referenced Transfer Syntax UID in File (0004,1512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE
Visual Basic
Public Const REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TRANSFER_SYNTAX_UID_IN_FILE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TREATMENT_POSITION_GROUP_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TREATMENT_POSITION_GROUP_UID Field
MCdicom Structure See Also Send Feedback
Referenced Treatment Position Group UID (300A,0785)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TREATMENT_POSITION_GROUP_UID
Visual Basic
Public Const REFERENCED_TREATMENT_POSITION_GROUP_UID As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TREATMENT_POSITION_GROUP_UID

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TREATMENT_POSITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TREATMENT_POSITION_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced Treatment Position Index (300A,060B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TREATMENT_POSITION_INDEX
Visual Basic
Public Const REFERENCED_TREATMENT_POSITION_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TREATMENT_POSITION_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_TREATMENT_RECORD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_TREATMENT_RECORD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Treatment Record Sequence (3008,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_TREATMENT_RECORD_SEQUENCE
Visual Basic
Public Const REFERENCED_TREATMENT_RECORD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_TREATMENT_RECORD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_VERIFICATION_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_VERIFICATION_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Verification Image Sequence (300C,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_VERIFICATION_IMAGE_SEQUENCE
Visual Basic
Public Const REFERENCED_VERIFICATION_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_VERIFICATION_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_VISIT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_VISIT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Visit Sequence (0008,1125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_VISIT_SEQUENCE
Visual Basic
Public Const REFERENCED_VISIT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_VISIT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Referenced VOI LUT Box Sequence RETIRED (2020,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED
Visual Basic
Public Const REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REFERENCED_VOI_LUT_BOX_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REFERENCED_WAVEFORM_CHANNELS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_WAVEFORM_CHANNELS Field
MCdicom Structure See Also Send Feedback
Referenced Waveform Channels (0040,A0B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_WAVEFORM_CHANNELS
Visual Basic
Public Const REFERENCED_WAVEFORM_CHANNELS As UInteger
Visual C++
public:
literal unsigned int REFERENCED_WAVEFORM_CHANNELS

See Also

MCdicom Structure
MCdicom Members


REFERENCED_WAVEFORM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_WAVEFORM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referenced Waveform Sequence (0008,113A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_WAVEFORM_SEQUENCE
Visual Basic
Public Const REFERENCED_WAVEFORM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERENCED_WAVEFORM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERENCED_WEDGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_WEDGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Referenced Wedge Number (300C,00C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_WEDGE_NUMBER
Visual Basic
Public Const REFERENCED_WEDGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int REFERENCED_WEDGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


REFERENCED_X_RAY_DETECTOR_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_X_RAY_DETECTOR_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced X-Ray Detector Index (0018,9376)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_X_RAY_DETECTOR_INDEX
Visual Basic
Public Const REFERENCED_X_RAY_DETECTOR_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_X_RAY_DETECTOR_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERENCED_X_RAY_SOURCE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERENCED_X_RAY_SOURCE_INDEX Field
MCdicom Structure See Also Send Feedback
Referenced X-Ray Source Index (0018,9377)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERENCED_X_RAY_SOURCE_INDEX
Visual Basic
Public Const REFERENCED_X_RAY_SOURCE_INDEX As UInteger
Visual C++
public:
literal unsigned int REFERENCED_X_RAY_SOURCE_INDEX

See Also

MCdicom Structure
MCdicom Members


REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Referring Physician Identification Sequence (0008,0096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFERRING_PHYSICIAN_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFERRING_PHYSICIANS_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERRING_PHYSICIANS_ADDRESS Field
MCdicom Structure See Also Send Feedback
Referring Physician's Address (0008,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERRING_PHYSICIANS_ADDRESS
Visual Basic
Public Const REFERRING_PHYSICIANS_ADDRESS As UInteger
Visual C++
public:
literal unsigned int REFERRING_PHYSICIANS_ADDRESS

See Also

MCdicom Structure
MCdicom Members


REFERRING_PHYSICIANS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERRING_PHYSICIANS_NAME Field
MCdicom Structure See Also Send Feedback
Referring Physician's Name (0008,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERRING_PHYSICIANS_NAME
Visual Basic
Public Const REFERRING_PHYSICIANS_NAME As UInteger
Visual C++
public:
literal unsigned int REFERRING_PHYSICIANS_NAME

See Also

MCdicom Structure
MCdicom Members


REFERRING_PHYSICIANS_TELEPHONE_NUMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFERRING_PHYSICIANS_TELEPHONE_NUMBERS Field
MCdicom Structure See Also Send Feedback
Referring Physician's Telephone Numbers (0008,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFERRING_PHYSICIANS_TELEPHONE_NUMBERS
Visual Basic
Public Const REFERRING_PHYSICIANS_TELEPHONE_NUMBERS As UInteger
Visual C++
public:
literal unsigned int REFERRING_PHYSICIANS_TELEPHONE_NUMBERS

See Also

MCdicom Structure
MCdicom Members


REFLECTED_AMBIENT_LIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFLECTED_AMBIENT_LIGHT Field
MCdicom Structure See Also Send Feedback
Reflected Ambient Light (2010,0160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFLECTED_AMBIENT_LIGHT
Visual Basic
Public Const REFLECTED_AMBIENT_LIGHT As UInteger
Visual C++
public:
literal unsigned int REFLECTED_AMBIENT_LIGHT

See Also

MCdicom Structure
MCdicom Members


REFORMATTING_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFORMATTING_INTERVAL Field
MCdicom Structure See Also Send Feedback
Reformatting Interval (0072,0514)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFORMATTING_INTERVAL
Visual Basic
Public Const REFORMATTING_INTERVAL As UInteger
Visual C++
public:
literal unsigned int REFORMATTING_INTERVAL

See Also

MCdicom Structure
MCdicom Members


REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION Field
MCdicom Structure See Also Send Feedback
Reformatting Operation Initial View Direction (0072,0516)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION
Visual Basic
Public Const REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION As UInteger
Visual C++
public:
literal unsigned int REFORMATTING_OPERATION_INITIAL_VIEW_DIRECTION

See Also

MCdicom Structure
MCdicom Members


REFORMATTING_OPERATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFORMATTING_OPERATION_TYPE Field
MCdicom Structure See Also Send Feedback
Reformatting Operation Type (0072,0510)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFORMATTING_OPERATION_TYPE
Visual Basic
Public Const REFORMATTING_OPERATION_TYPE As UInteger
Visual C++
public:
literal unsigned int REFORMATTING_OPERATION_TYPE

See Also

MCdicom Structure
MCdicom Members


REFORMATTING_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFORMATTING_THICKNESS Field
MCdicom Structure See Also Send Feedback
Reformatting Thickness (0072,0512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFORMATTING_THICKNESS
Visual Basic
Public Const REFORMATTING_THICKNESS As UInteger
Visual C++
public:
literal unsigned int REFORMATTING_THICKNESS

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Refractive Error Before Refractive Surgery Code Sequence (0022,1103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE
Visual Basic
Public Const REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_ERROR_BEFORE_REFRACTIVE_SURGERY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_INDEX_APPLIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_INDEX_APPLIED Field
MCdicom Structure See Also Send Feedback
Refractive Index Applied (0052,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_INDEX_APPLIED
Visual Basic
Public Const REFRACTIVE_INDEX_APPLIED As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_INDEX_APPLIED

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR Field
MCdicom Structure See Also Send Feedback
Refractive Index of Aqueous Humor (0046,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR
Visual Basic
Public Const REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_INDEX_OF_AQUEOUS_HUMOR

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_INDEX_OF_CORNEA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_INDEX_OF_CORNEA Field
MCdicom Structure See Also Send Feedback
Refractive Index of Cornea (0046,0117)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_INDEX_OF_CORNEA
Visual Basic
Public Const REFRACTIVE_INDEX_OF_CORNEA As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_INDEX_OF_CORNEA

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Refractive Parameters Used on Patient Sequence (0024,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE
Visual Basic
Public Const REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_PARAMETERS_USED_ON_PATIENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_POWER Field
MCdicom Structure See Also Send Feedback
Refractive Power (0046,0251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_POWER
Visual Basic
Public Const REFRACTIVE_POWER As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_POWER

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_PROCEDURE_OCCURRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_PROCEDURE_OCCURRED Field
MCdicom Structure See Also Send Feedback
Refractive Procedure Occurred (0022,1039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_PROCEDURE_OCCURRED
Visual Basic
Public Const REFRACTIVE_PROCEDURE_OCCURRED As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_PROCEDURE_OCCURRED

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_STATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_STATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Refractive State Sequence (0022,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_STATE_SEQUENCE
Visual Basic
Public Const REFRACTIVE_STATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_STATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Refractive Surgery Type Code Sequence (0022,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE
Visual Basic
Public Const REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REFRACTIVE_SURGERY_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REGION_DATA_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_DATA_TYPE Field
MCdicom Structure See Also Send Feedback
Region Data Type (0018,6014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_DATA_TYPE
Visual Basic
Public Const REGION_DATA_TYPE As UInteger
Visual C++
public:
literal unsigned int REGION_DATA_TYPE

See Also

MCdicom Structure
MCdicom Members


REGION_FLAGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_FLAGS Field
MCdicom Structure See Also Send Feedback
Region Flags (0018,6016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_FLAGS
Visual Basic
Public Const REGION_FLAGS As UInteger
Visual C++
public:
literal unsigned int REGION_FLAGS

See Also

MCdicom Structure
MCdicom Members


REGION_LOCATION_MAX_X1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_LOCATION_MAX_X1 Field
MCdicom Structure See Also Send Feedback
Region Location Max X1 (0018,601C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_LOCATION_MAX_X1
Visual Basic
Public Const REGION_LOCATION_MAX_X1 As UInteger
Visual C++
public:
literal unsigned int REGION_LOCATION_MAX_X1

See Also

MCdicom Structure
MCdicom Members


REGION_LOCATION_MAX_Y1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_LOCATION_MAX_Y1 Field
MCdicom Structure See Also Send Feedback
Region Location Max Y1 (0018,601E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_LOCATION_MAX_Y1
Visual Basic
Public Const REGION_LOCATION_MAX_Y1 As UInteger
Visual C++
public:
literal unsigned int REGION_LOCATION_MAX_Y1

See Also

MCdicom Structure
MCdicom Members


REGION_LOCATION_MIN_X0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_LOCATION_MIN_X0 Field
MCdicom Structure See Also Send Feedback
Region Location Min X0 (0018,6018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_LOCATION_MIN_X0
Visual Basic
Public Const REGION_LOCATION_MIN_X0 As UInteger
Visual C++
public:
literal unsigned int REGION_LOCATION_MIN_X0

See Also

MCdicom Structure
MCdicom Members


REGION_LOCATION_MIN_Y0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_LOCATION_MIN_Y0 Field
MCdicom Structure See Also Send Feedback
Region Location Min Y0 (0018,601A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_LOCATION_MIN_Y0
Visual Basic
Public Const REGION_LOCATION_MIN_Y0 As UInteger
Visual C++
public:
literal unsigned int REGION_LOCATION_MIN_Y0

See Also

MCdicom Structure
MCdicom Members


REGION_OF_RESIDENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_OF_RESIDENCE Field
MCdicom Structure See Also Send Feedback
Region of Residence (0010,2152)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_OF_RESIDENCE
Visual Basic
Public Const REGION_OF_RESIDENCE As UInteger
Visual C++
public:
literal unsigned int REGION_OF_RESIDENCE

See Also

MCdicom Structure
MCdicom Members


REGION_PIXEL_SHIFT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_PIXEL_SHIFT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Region Pixel Shift Sequence (0028,9502)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_PIXEL_SHIFT_SEQUENCE
Visual Basic
Public Const REGION_PIXEL_SHIFT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REGION_PIXEL_SHIFT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REGION_SPATIAL_FORMAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGION_SPATIAL_FORMAT Field
MCdicom Structure See Also Send Feedback
Region Spatial Format (0018,6012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGION_SPATIAL_FORMAT
Visual Basic
Public Const REGION_SPATIAL_FORMAT As UInteger
Visual C++
public:
literal unsigned int REGION_SPATIAL_FORMAT

See Also

MCdicom Structure
MCdicom Members


REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Registered Localizer Bottom Right Hand Corner (0022,1468)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER
Visual Basic
Public Const REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int REGISTERED_LOCALIZER_BOTTOM_RIGHT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER Field
MCdicom Structure See Also Send Feedback
Registered Localizer Top Left Hand Corner (0022,1467)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER
Visual Basic
Public Const REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER As UInteger
Visual C++
public:
literal unsigned int REGISTERED_LOCALIZER_TOP_LEFT_HAND_CORNER

See Also

MCdicom Structure
MCdicom Members


REGISTERED_LOCALIZER_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTERED_LOCALIZER_UNITS Field
MCdicom Structure See Also Send Feedback
Registered Localizer Units (0022,1466)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTERED_LOCALIZER_UNITS
Visual Basic
Public Const REGISTERED_LOCALIZER_UNITS As UInteger
Visual C++
public:
literal unsigned int REGISTERED_LOCALIZER_UNITS

See Also

MCdicom Structure
MCdicom Members


REGISTRATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTRATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Registration Method Code Sequence (0080,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTRATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const REGISTRATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REGISTRATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REGISTRATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTRATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Registration Sequence (0070,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTRATION_SEQUENCE
Visual Basic
Public Const REGISTRATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REGISTRATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REGISTRATION_TO_LOCALIZER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTRATION_TO_LOCALIZER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Registration to Localizer Sequence (0022,1465)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTRATION_TO_LOCALIZER_SEQUENCE
Visual Basic
Public Const REGISTRATION_TO_LOCALIZER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REGISTRATION_TO_LOCALIZER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REGISTRATION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REGISTRATION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Registration Type Code Sequence (0070,030D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REGISTRATION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const REGISTRATION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REGISTRATION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATED_ASSERTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_ASSERTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Related Assertion Sequence (0044,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_ASSERTION_SEQUENCE
Visual Basic
Public Const RELATED_ASSERTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATED_ASSERTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATED_FRAME_OF_REFERENCE_UID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_FRAME_OF_REFERENCE_UID_RETIRED Field
MCdicom Structure See Also Send Feedback
Related Frame of Reference UID RETIRED (3006,00C2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_FRAME_OF_REFERENCE_UID_RETIRED
Visual Basic
Public Const RELATED_FRAME_OF_REFERENCE_UID_RETIRED As UInteger
Visual C++
public:
literal unsigned int RELATED_FRAME_OF_REFERENCE_UID_RETIRED

See Also

MCdicom Structure
MCdicom Members


RELATED_GENERAL_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_GENERAL_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Related General SOP Class UID (0008,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_GENERAL_SOP_CLASS_UID
Visual Basic
Public Const RELATED_GENERAL_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int RELATED_GENERAL_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Related Procedure Step Sequence RETIRED (0074,1220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED
Visual Basic
Public Const RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RELATED_PROCEDURE_STEP_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RELATED_REFERENCE_RT_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_REFERENCE_RT_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Related Reference RT Image Sequence (0074,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_REFERENCE_RT_IMAGE_SEQUENCE
Visual Basic
Public Const RELATED_REFERENCE_RT_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATED_REFERENCE_RT_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATED_RT_ROI_OBSERVATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_RT_ROI_OBSERVATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Related RT ROI Observations Sequence (3006,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_RT_ROI_OBSERVATIONS_SEQUENCE
Visual Basic
Public Const RELATED_RT_ROI_OBSERVATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATED_RT_ROI_OBSERVATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATED_RT_TREATMENT_PHASE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_RT_TREATMENT_PHASE_INDEX Field
MCdicom Structure See Also Send Feedback
Related RT Treatment Phase Index (3010,003F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_RT_TREATMENT_PHASE_INDEX
Visual Basic
Public Const RELATED_RT_TREATMENT_PHASE_INDEX As UInteger
Visual C++
public:
literal unsigned int RELATED_RT_TREATMENT_PHASE_INDEX

See Also

MCdicom Structure
MCdicom Members


RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Related Segment Characteristics Sequence (3010,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATED_SEGMENT_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATED_SERIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATED_SERIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Related Series Sequence (0008,1250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATED_SERIES_SEQUENCE
Visual Basic
Public Const RELATED_SERIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATED_SERIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATIONSHIP_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIONSHIP_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Relationship Sequence (Trial) RETIRED (0040,A731)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIONSHIP_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const RELATIONSHIP_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int RELATIONSHIP_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


RELATIONSHIP_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIONSHIP_TYPE Field
MCdicom Structure See Also Send Feedback
Relationship Type (0040,A010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIONSHIP_TYPE
Visual Basic
Public Const RELATIONSHIP_TYPE As UInteger
Visual C++
public:
literal unsigned int RELATIONSHIP_TYPE

See Also

MCdicom Structure
MCdicom Members


RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Relationship Type Code Sequence (Trial) RETIRED (0040,A732)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int RELATIONSHIP_TYPE_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


RELATIVE_ELEVATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_ELEVATION Field
MCdicom Structure See Also Send Feedback
Relative Elevation (0046,0252)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_ELEVATION
Visual Basic
Public Const RELATIVE_ELEVATION As UInteger
Visual C++
public:
literal unsigned int RELATIVE_ELEVATION

See Also

MCdicom Structure
MCdicom Members


RELATIVE_IMAGE_POSITION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_IMAGE_POSITION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Relative Image Position Code Sequence (0022,001D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_IMAGE_POSITION_CODE_SEQUENCE
Visual Basic
Public Const RELATIVE_IMAGE_POSITION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELATIVE_IMAGE_POSITION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RELATIVE_OPACITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_OPACITY Field
MCdicom Structure See Also Send Feedback
Relative Opacity (0070,0403)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_OPACITY
Visual Basic
Public Const RELATIVE_OPACITY As UInteger
Visual C++
public:
literal unsigned int RELATIVE_OPACITY

See Also

MCdicom Structure
MCdicom Members


RELATIVE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_TIME Field
MCdicom Structure See Also Send Feedback
Relative Time (0072,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_TIME
Visual Basic
Public Const RELATIVE_TIME As UInteger
Visual C++
public:
literal unsigned int RELATIVE_TIME

See Also

MCdicom Structure
MCdicom Members


RELATIVE_TIME_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_TIME_UNITS Field
MCdicom Structure See Also Send Feedback
Relative Time Units (0072,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_TIME_UNITS
Visual Basic
Public Const RELATIVE_TIME_UNITS As UInteger
Visual C++
public:
literal unsigned int RELATIVE_TIME_UNITS

See Also

MCdicom Structure
MCdicom Members


RELATIVE_X_RAY_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELATIVE_X_RAY_EXPOSURE Field
MCdicom Structure See Also Send Feedback
Relative X-Ray Exposure (0018,1405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELATIVE_X_RAY_EXPOSURE
Visual Basic
Public Const RELATIVE_X_RAY_EXPOSURE As UInteger
Visual C++
public:
literal unsigned int RELATIVE_X_RAY_EXPOSURE

See Also

MCdicom Structure
MCdicom Members


RELEVANT_INFORMATION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELEVANT_INFORMATION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Relevant Information Sequence RETIRED (0040,4022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELEVANT_INFORMATION_SEQUENCE_RETIRED
Visual Basic
Public Const RELEVANT_INFORMATION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RELEVANT_INFORMATION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RELEVANT_OPT_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RELEVANT_OPT_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Relevant OPT Attributes Sequence (0022,1472)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RELEVANT_OPT_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const RELEVANT_OPT_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RELEVANT_OPT_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REMOVED_FROM_OPERATIONAL_USE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REMOVED_FROM_OPERATIONAL_USE Field
MCdicom Structure See Also Send Feedback
Removed from Operational Use (0008,0405)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REMOVED_FROM_OPERATIONAL_USE
Visual Basic
Public Const REMOVED_FROM_OPERATIONAL_USE As UInteger
Visual C++
public:
literal unsigned int REMOVED_FROM_OPERATIONAL_USE

See Also

MCdicom Structure
MCdicom Members


RENDER_FIELD_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RENDER_FIELD_OF_VIEW Field
MCdicom Structure See Also Send Feedback
Render Field of View (0070,1606)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RENDER_FIELD_OF_VIEW
Visual Basic
Public Const RENDER_FIELD_OF_VIEW As UInteger
Visual C++
public:
literal unsigned int RENDER_FIELD_OF_VIEW

See Also

MCdicom Structure
MCdicom Members


RENDER_PROJECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RENDER_PROJECTION Field
MCdicom Structure See Also Send Feedback
Render Projection (0070,1602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RENDER_PROJECTION
Visual Basic
Public Const RENDER_PROJECTION As UInteger
Visual C++
public:
literal unsigned int RENDER_PROJECTION

See Also

MCdicom Structure
MCdicom Members


RENDERED_IMAGE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RENDERED_IMAGE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Rendered Image Reference Sequence (0070,1104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RENDERED_IMAGE_REFERENCE_SEQUENCE
Visual Basic
Public Const RENDERED_IMAGE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RENDERED_IMAGE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RENDERING_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RENDERING_METHOD Field
MCdicom Structure See Also Send Feedback
Rendering Method (0070,120D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RENDERING_METHOD
Visual Basic
Public Const RENDERING_METHOD As UInteger
Visual C++
public:
literal unsigned int RENDERING_METHOD

See Also

MCdicom Structure
MCdicom Members


REPEAT_FRACTION_CYCLE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPEAT_FRACTION_CYCLE_LENGTH Field
MCdicom Structure See Also Send Feedback
Repeat Fraction Cycle Length (300A,007A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPEAT_FRACTION_CYCLE_LENGTH
Visual Basic
Public Const REPEAT_FRACTION_CYCLE_LENGTH As UInteger
Visual C++
public:
literal unsigned int REPEAT_FRACTION_CYCLE_LENGTH

See Also

MCdicom Structure
MCdicom Members


REPETITION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPETITION_TIME Field
MCdicom Structure See Also Send Feedback
Repetition Time (0018,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPETITION_TIME
Visual Basic
Public Const REPETITION_TIME As UInteger
Visual C++
public:
literal unsigned int REPETITION_TIME

See Also

MCdicom Structure
MCdicom Members


REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Replaced Implant Assembly Template Sequence (0076,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE
Visual Basic
Public Const REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REPLACED_IMPLANT_ASSEMBLY_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Replaced Implant Template Group Sequence (0078,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE
Visual Basic
Public Const REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REPLACED_IMPLANT_TEMPLATE_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REPLACED_IMPLANT_TEMPLATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPLACED_IMPLANT_TEMPLATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Replaced Implant Template Sequence (0068,6222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPLACED_IMPLANT_TEMPLATE_SEQUENCE
Visual Basic
Public Const REPLACED_IMPLANT_TEMPLATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REPLACED_IMPLANT_TEMPLATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REPLACED_PROCEDURE_STEP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPLACED_PROCEDURE_STEP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Replaced Procedure Step Sequence (0074,1224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPLACED_PROCEDURE_STEP_SEQUENCE
Visual Basic
Public Const REPLACED_PROCEDURE_STEP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REPLACED_PROCEDURE_STEP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Report Detail Sequence (Trial) RETIRED (0040,A380)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REPORT_DETAIL_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REPORT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORT_NUMBER Field
MCdicom Structure See Also Send Feedback
Report Number (0020,00AA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORT_NUMBER
Visual Basic
Public Const REPORT_NUMBER As UInteger
Visual C++
public:
literal unsigned int REPORT_NUMBER

See Also

MCdicom Structure
MCdicom Members


REPORT_PRODUCTION_STATUS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORT_PRODUCTION_STATUS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Report Production Status (Trial) RETIRED (4008,00FF)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORT_PRODUCTION_STATUS_TRIAL_RETIRED
Visual Basic
Public Const REPORT_PRODUCTION_STATUS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REPORT_PRODUCTION_STATUS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REPORT_STATUS_COMMENT_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORT_STATUS_COMMENT_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Report Status Comment (Trial) RETIRED (0040,A33A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORT_STATUS_COMMENT_TRIAL_RETIRED
Visual Basic
Public Const REPORT_STATUS_COMMENT_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REPORT_STATUS_COMMENT_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REPORT_STATUS_ID_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORT_STATUS_ID_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Report Status ID (Trial) RETIRED (0040,A125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORT_STATUS_ID_TRIAL_RETIRED
Visual Basic
Public Const REPORT_STATUS_ID_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REPORT_STATUS_ID_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REPORTED_VALUES_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORTED_VALUES_ORIGIN Field
MCdicom Structure See Also Send Feedback
Reported Values Origin (3002,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORTED_VALUES_ORIGIN
Visual Basic
Public Const REPORTED_VALUES_ORIGIN As UInteger
Visual C++
public:
literal unsigned int REPORTED_VALUES_ORIGIN

See Also

MCdicom Structure
MCdicom Members


REPORTING_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPORTING_PRIORITY Field
MCdicom Structure See Also Send Feedback
Reporting Priority (0040,1009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPORTING_PRIORITY
Visual Basic
Public Const REPORTING_PRIORITY As UInteger
Visual C++
public:
literal unsigned int REPORTING_PRIORITY

See Also

MCdicom Structure
MCdicom Members


REPOSITORY_UNIQUE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPOSITORY_UNIQUE_ID Field
MCdicom Structure See Also Send Feedback
Repository Unique ID (0040,E030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPOSITORY_UNIQUE_ID
Visual Basic
Public Const REPOSITORY_UNIQUE_ID As UInteger
Visual C++
public:
literal unsigned int REPOSITORY_UNIQUE_ID

See Also

MCdicom Structure
MCdicom Members


REPRESENTATIVE_FRAME_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPRESENTATIVE_FRAME_NUMBER Field
MCdicom Structure See Also Send Feedback
Representative Frame Number (0028,6010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPRESENTATIVE_FRAME_NUMBER
Visual Basic
Public Const REPRESENTATIVE_FRAME_NUMBER As UInteger
Visual C++
public:
literal unsigned int REPRESENTATIVE_FRAME_NUMBER

See Also

MCdicom Structure
MCdicom Members


REPROJECTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REPROJECTION_METHOD Field
MCdicom Structure See Also Send Feedback
Reprojection Method (0054,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REPROJECTION_METHOD
Visual Basic
Public Const REPROJECTION_METHOD As UInteger
Visual C++
public:
literal unsigned int REPROJECTION_METHOD

See Also

MCdicom Structure
MCdicom Members


REQUEST_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUEST_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Request Attributes Sequence (0040,0275)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUEST_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const REQUEST_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUEST_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REQUEST_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUEST_PRIORITY Field
MCdicom Structure See Also Send Feedback
Request Priority (2200,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUEST_PRIORITY
Visual Basic
Public Const REQUEST_PRIORITY As UInteger
Visual C++
public:
literal unsigned int REQUEST_PRIORITY

See Also

MCdicom Structure
MCdicom Members


REQUESTED_CONTRAST_AGENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_CONTRAST_AGENT Field
MCdicom Structure See Also Send Feedback
Requested Contrast Agent (0032,1070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_CONTRAST_AGENT
Visual Basic
Public Const REQUESTED_CONTRAST_AGENT As UInteger
Visual C++
public:
literal unsigned int REQUESTED_CONTRAST_AGENT

See Also

MCdicom Structure
MCdicom Members


REQUESTED_DECIMATE_CROP_BEHAVIOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_DECIMATE_CROP_BEHAVIOR Field
MCdicom Structure See Also Send Feedback
Requested Decimate/Crop Behavior (2020,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_DECIMATE_CROP_BEHAVIOR
Visual Basic
Public Const REQUESTED_DECIMATE_CROP_BEHAVIOR As UInteger
Visual C++
public:
literal unsigned int REQUESTED_DECIMATE_CROP_BEHAVIOR

See Also

MCdicom Structure
MCdicom Members


REQUESTED_IMAGE_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_IMAGE_SIZE Field
MCdicom Structure See Also Send Feedback
Requested Image Size (2020,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_IMAGE_SIZE
Visual Basic
Public Const REQUESTED_IMAGE_SIZE As UInteger
Visual C++
public:
literal unsigned int REQUESTED_IMAGE_SIZE

See Also

MCdicom Structure
MCdicom Members


REQUESTED_IMAGE_SIZE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_IMAGE_SIZE_FLAG Field
MCdicom Structure See Also Send Feedback
Requested Image Size Flag (2020,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_IMAGE_SIZE_FLAG
Visual Basic
Public Const REQUESTED_IMAGE_SIZE_FLAG As UInteger
Visual C++
public:
literal unsigned int REQUESTED_IMAGE_SIZE_FLAG

See Also

MCdicom Structure
MCdicom Members


REQUESTED_LATERALITY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_LATERALITY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Requested Laterality Code Sequence (0032,1065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_LATERALITY_CODE_SEQUENCE
Visual Basic
Public Const REQUESTED_LATERALITY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUESTED_LATERALITY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REQUESTED_MEDIA_APPLICATION_PROFILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_MEDIA_APPLICATION_PROFILE Field
MCdicom Structure See Also Send Feedback
Requested Media Application Profile (2200,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_MEDIA_APPLICATION_PROFILE
Visual Basic
Public Const REQUESTED_MEDIA_APPLICATION_PROFILE As UInteger
Visual C++
public:
literal unsigned int REQUESTED_MEDIA_APPLICATION_PROFILE

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Requested Procedure Code Sequence (0032,1064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_CODE_SEQUENCE
Visual Basic
Public Const REQUESTED_PROCEDURE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_COMMENTS Field
MCdicom Structure See Also Send Feedback
Requested Procedure Comments (0040,1400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_COMMENTS
Visual Basic
Public Const REQUESTED_PROCEDURE_COMMENTS As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_COMMENTS

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Requested Procedure Description (0032,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_DESCRIPTION
Visual Basic
Public Const REQUESTED_PROCEDURE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Requested Procedure Description (Trial) RETIRED (0040,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_ID Field
MCdicom Structure See Also Send Feedback
Requested Procedure ID (0040,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_ID
Visual Basic
Public Const REQUESTED_PROCEDURE_ID As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_ID

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_LOCATION Field
MCdicom Structure See Also Send Feedback
Requested Procedure Location (0040,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_LOCATION
Visual Basic
Public Const REQUESTED_PROCEDURE_LOCATION As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_LOCATION

See Also

MCdicom Structure
MCdicom Members


REQUESTED_PROCEDURE_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_PROCEDURE_PRIORITY Field
MCdicom Structure See Also Send Feedback
Requested Procedure Priority (0040,1003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_PROCEDURE_PRIORITY
Visual Basic
Public Const REQUESTED_PROCEDURE_PRIORITY As UInteger
Visual C++
public:
literal unsigned int REQUESTED_PROCEDURE_PRIORITY

See Also

MCdicom Structure
MCdicom Members


REQUESTED_RESOLUTION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_RESOLUTION_ID Field
MCdicom Structure See Also Send Feedback
Requested Resolution ID (2020,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_RESOLUTION_ID
Visual Basic
Public Const REQUESTED_RESOLUTION_ID As UInteger
Visual C++
public:
literal unsigned int REQUESTED_RESOLUTION_ID

See Also

MCdicom Structure
MCdicom Members


REQUESTED_SERIES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_SERIES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Requested Series Description (0018,9937)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_SERIES_DESCRIPTION
Visual Basic
Public Const REQUESTED_SERIES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int REQUESTED_SERIES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Requested Series Description Code Sequence (0018,11C1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE
Visual Basic
Public Const REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUESTED_SERIES_DESCRIPTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REQUESTED_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
Requested SOP Class UID (0000,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_SOP_CLASS_UID
Visual Basic
Public Const REQUESTED_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int REQUESTED_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


REQUESTED_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Requested SOP Instance UID (0000,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_SOP_INSTANCE_UID
Visual Basic
Public Const REQUESTED_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int REQUESTED_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


REQUESTED_STATUS_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_STATUS_INTERVAL Field
MCdicom Structure See Also Send Feedback
Requested Status Interval (0008,0414)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_STATUS_INTERVAL
Visual Basic
Public Const REQUESTED_STATUS_INTERVAL As UInteger
Visual C++
public:
literal unsigned int REQUESTED_STATUS_INTERVAL

See Also

MCdicom Structure
MCdicom Members


REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Requested Subsequent Workitem Code Sequence RETIRED (0040,4031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int REQUESTED_SUBSEQUENT_WORKITEM_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


REQUESTING_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTING_AE Field
MCdicom Structure See Also Send Feedback
Requesting AE (0074,1236)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTING_AE
Visual Basic
Public Const REQUESTING_AE As UInteger
Visual C++
public:
literal unsigned int REQUESTING_AE

See Also

MCdicom Structure
MCdicom Members


REQUESTING_PHYSICIAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTING_PHYSICIAN Field
MCdicom Structure See Also Send Feedback
Requesting Physician (0032,1032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTING_PHYSICIAN
Visual Basic
Public Const REQUESTING_PHYSICIAN As UInteger
Visual C++
public:
literal unsigned int REQUESTING_PHYSICIAN

See Also

MCdicom Structure
MCdicom Members


REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Requesting Physician Identification Sequence (0032,1031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUESTING_PHYSICIAN_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


REQUESTING_SERVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTING_SERVICE Field
MCdicom Structure See Also Send Feedback
Requesting Service (0032,1033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTING_SERVICE
Visual Basic
Public Const REQUESTING_SERVICE As UInteger
Visual C++
public:
literal unsigned int REQUESTING_SERVICE

See Also

MCdicom Structure
MCdicom Members


REQUESTING_SERVICE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REQUESTING_SERVICE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Requesting Service Code Sequence (0032,1034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REQUESTING_SERVICE_CODE_SEQUENCE
Visual Basic
Public Const REQUESTING_SERVICE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int REQUESTING_SERVICE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RESCALE_INTERCEPT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESCALE_INTERCEPT Field
MCdicom Structure See Also Send Feedback
Rescale Intercept (0028,1052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESCALE_INTERCEPT
Visual Basic
Public Const RESCALE_INTERCEPT As UInteger
Visual C++
public:
literal unsigned int RESCALE_INTERCEPT

See Also

MCdicom Structure
MCdicom Members


RESCALE_SLOPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESCALE_SLOPE Field
MCdicom Structure See Also Send Feedback
Rescale Slope (0028,1053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESCALE_SLOPE
Visual Basic
Public Const RESCALE_SLOPE As UInteger
Visual C++
public:
literal unsigned int RESCALE_SLOPE

See Also

MCdicom Structure
MCdicom Members


RESCALE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESCALE_TYPE Field
MCdicom Structure See Also Send Feedback
Rescale Type (0028,1054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESCALE_TYPE
Visual Basic
Public Const RESCALE_TYPE As UInteger
Visual C++
public:
literal unsigned int RESCALE_TYPE

See Also

MCdicom Structure
MCdicom Members


RESIDUAL_SYRINGE_COUNTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESIDUAL_SYRINGE_COUNTS Field
MCdicom Structure See Also Send Feedback
Residual Syringe Counts (0054,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESIDUAL_SYRINGE_COUNTS
Visual Basic
Public Const RESIDUAL_SYRINGE_COUNTS As UInteger
Visual C++
public:
literal unsigned int RESIDUAL_SYRINGE_COUNTS

See Also

MCdicom Structure
MCdicom Members


RESONANT_NUCLEUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESONANT_NUCLEUS Field
MCdicom Structure See Also Send Feedback
Resonant Nucleus (0018,9100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESONANT_NUCLEUS
Visual Basic
Public Const RESONANT_NUCLEUS As UInteger
Visual C++
public:
literal unsigned int RESONANT_NUCLEUS

See Also

MCdicom Structure
MCdicom Members


RESOURCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESOURCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Resource Description (0038,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESOURCE_DESCRIPTION
Visual Basic
Public Const RESOURCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RESOURCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_CYCLE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_CYCLE_POSITION Field
MCdicom Structure See Also Send Feedback
Respiratory Cycle Position (0018,9214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_CYCLE_POSITION
Visual Basic
Public Const RESPIRATORY_CYCLE_POSITION As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_CYCLE_POSITION

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_INTERVAL_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_INTERVAL_TIME Field
MCdicom Structure See Also Send Feedback
Respiratory Interval Time (0020,9254)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_INTERVAL_TIME
Visual Basic
Public Const RESPIRATORY_INTERVAL_TIME As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_INTERVAL_TIME

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Respiratory Motion Compensation Technique (0018,9170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE
Visual Basic
Public Const RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Respiratory Motion Compensation Technique Description (0018,9185)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION
Visual Basic
Public Const RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_MOTION_COMPENSATION_TECHNIQUE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_SIGNAL_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_SIGNAL_SOURCE Field
MCdicom Structure See Also Send Feedback
Respiratory Signal Source (0018,9171)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_SIGNAL_SOURCE
Visual Basic
Public Const RESPIRATORY_SIGNAL_SOURCE As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_SIGNAL_SOURCE

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_SIGNAL_SOURCE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_SIGNAL_SOURCE_ID Field
MCdicom Structure See Also Send Feedback
Respiratory Signal Source ID (0018,9186)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_SIGNAL_SOURCE_ID
Visual Basic
Public Const RESPIRATORY_SIGNAL_SOURCE_ID As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_SIGNAL_SOURCE_ID

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_SYNCHRONIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_SYNCHRONIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Respiratory Synchronization Sequence (0020,9253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_SYNCHRONIZATION_SEQUENCE
Visual Basic
Public Const RESPIRATORY_SYNCHRONIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_SYNCHRONIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_TRIGGER_DELAY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_TRIGGER_DELAY_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Respiratory Trigger Delay Threshold (0020,9256)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_TRIGGER_DELAY_THRESHOLD
Visual Basic
Public Const RESPIRATORY_TRIGGER_DELAY_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_TRIGGER_DELAY_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


RESPIRATORY_TRIGGER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPIRATORY_TRIGGER_TYPE Field
MCdicom Structure See Also Send Feedback
Respiratory Trigger Type (0020,9250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPIRATORY_TRIGGER_TYPE
Visual Basic
Public Const RESPIRATORY_TRIGGER_TYPE As UInteger
Visual C++
public:
literal unsigned int RESPIRATORY_TRIGGER_TYPE

See Also

MCdicom Structure
MCdicom Members


RESPITORY_TRIGGER_DELAY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPITORY_TRIGGER_DELAY_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag NOMINAL_RESPIRATORY_TRIGGER_DELAY_TIME (0020,9255)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPITORY_TRIGGER_DELAY_TIME
Visual Basic
Public Const RESPITORY_TRIGGER_DELAY_TIME As UInteger
Visual C++
public:
literal unsigned int RESPITORY_TRIGGER_DELAY_TIME

See Also

MCdicom Structure
MCdicom Members


RESPITORY_TRIGGER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPITORY_TRIGGER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag RESPIRATORY_SYNCHRONIZATION_SEQUENCE (0020,9253)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPITORY_TRIGGER_SEQUENCE
Visual Basic
Public Const RESPITORY_TRIGGER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RESPITORY_TRIGGER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RESPONSE_SEQUENCE_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPONSE_SEQUENCE_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Response Sequence Number RETIRED (0000,0860)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPONSE_SEQUENCE_NUMBER_RETIRED
Visual Basic
Public Const RESPONSE_SEQUENCE_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESPONSE_SEQUENCE_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESPONSIBLE_GROUP_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPONSIBLE_GROUP_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Responsible Group Code Sequence (0008,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPONSIBLE_GROUP_CODE_SEQUENCE
Visual Basic
Public Const RESPONSIBLE_GROUP_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RESPONSIBLE_GROUP_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RESPONSIBLE_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPONSIBLE_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Responsible Organization (0010,2299)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPONSIBLE_ORGANIZATION
Visual Basic
Public Const RESPONSIBLE_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int RESPONSIBLE_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


RESPONSIBLE_PERSON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPONSIBLE_PERSON Field
MCdicom Structure See Also Send Feedback
Responsible Person (0010,2297)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPONSIBLE_PERSON
Visual Basic
Public Const RESPONSIBLE_PERSON As UInteger
Visual C++
public:
literal unsigned int RESPONSIBLE_PERSON

See Also

MCdicom Structure
MCdicom Members


RESPONSIBLE_PERSON_ROLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESPONSIBLE_PERSON_ROLE Field
MCdicom Structure See Also Send Feedback
Responsible Person Role (0010,2298)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESPONSIBLE_PERSON_ROLE
Visual Basic
Public Const RESPONSIBLE_PERSON_ROLE As UInteger
Visual C++
public:
literal unsigned int RESPONSIBLE_PERSON_ROLE

See Also

MCdicom Structure
MCdicom Members


RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Resulting General Purpose Performed Procedure Steps Sequence RETIRED (0040,4015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED
Visual Basic
Public Const RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESULTING_GENERAL_PURPOSE_PERFORMED_PROCEDURE_STEPS_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESULTS_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTS_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Results Comments RETIRED (4008,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTS_COMMENTS_RETIRED
Visual Basic
Public Const RESULTS_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESULTS_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Results Distribution List Sequence RETIRED (4008,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED
Visual Basic
Public Const RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESULTS_DISTRIBUTION_LIST_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESULTS_ID_ISSUER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTS_ID_ISSUER_RETIRED Field
MCdicom Structure See Also Send Feedback
Results ID Issuer RETIRED (4008,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTS_ID_ISSUER_RETIRED
Visual Basic
Public Const RESULTS_ID_ISSUER_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESULTS_ID_ISSUER_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESULTS_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTS_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Results ID RETIRED (4008,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTS_ID_RETIRED
Visual Basic
Public Const RESULTS_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int RESULTS_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


RESULTS_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RESULTS_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Results Normals Sequence (0024,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RESULTS_NORMALS_SEQUENCE
Visual Basic
Public Const RESULTS_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RESULTS_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RETAIN_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETAIN_INSTANCES Field
MCdicom Structure See Also Send Feedback
Retain Instances (0008,0415)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETAIN_INSTANCES
Visual Basic
Public Const RETAIN_INSTANCES As UInteger
Visual C++
public:
literal unsigned int RETAIN_INSTANCES

See Also

MCdicom Structure
MCdicom Members


RETAIN_RAW_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETAIN_RAW_DATA Field
MCdicom Structure See Also Send Feedback
Alias for tag RAW_DATA_HANDLING (0040,4040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETAIN_RAW_DATA
Visual Basic
Public Const RETAIN_RAW_DATA As UInteger
Visual C++
public:
literal unsigned int RETAIN_RAW_DATA

See Also

MCdicom Structure
MCdicom Members


RETEST_SENSITIVITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETEST_SENSITIVITY_VALUE Field
MCdicom Structure See Also Send Feedback
Retest Sensitivity Value (0024,0096)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETEST_SENSITIVITY_VALUE
Visual Basic
Public Const RETEST_SENSITIVITY_VALUE As UInteger
Visual C++
public:
literal unsigned int RETEST_SENSITIVITY_VALUE

See Also

MCdicom Structure
MCdicom Members


RETEST_STIMULUS_SEEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETEST_STIMULUS_SEEN Field
MCdicom Structure See Also Send Feedback
Retest Stimulus Seen (0024,0095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETEST_STIMULUS_SEEN
Visual Basic
Public Const RETEST_STIMULUS_SEEN As UInteger
Visual C++
public:
literal unsigned int RETEST_STIMULUS_SEEN

See Also

MCdicom Structure
MCdicom Members


RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Retinal Thickness Definition Code Sequence (0022,1445)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE
Visual Basic
Public Const RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RETINAL_THICKNESS_DEFINITION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RETRIEVE_AE_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETRIEVE_AE_TITLE Field
MCdicom Structure See Also Send Feedback
Retrieve AE Title (0008,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETRIEVE_AE_TITLE
Visual Basic
Public Const RETRIEVE_AE_TITLE As UInteger
Visual C++
public:
literal unsigned int RETRIEVE_AE_TITLE

See Also

MCdicom Structure
MCdicom Members


RETRIEVE_LOCATION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETRIEVE_LOCATION_UID Field
MCdicom Structure See Also Send Feedback
Retrieve Location UID (0040,E011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETRIEVE_LOCATION_UID
Visual Basic
Public Const RETRIEVE_LOCATION_UID As UInteger
Visual C++
public:
literal unsigned int RETRIEVE_LOCATION_UID

See Also

MCdicom Structure
MCdicom Members


RETRIEVE_URI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETRIEVE_URI Field
MCdicom Structure See Also Send Feedback
Retrieve URI (0040,E010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETRIEVE_URI
Visual Basic
Public Const RETRIEVE_URI As UInteger
Visual C++
public:
literal unsigned int RETRIEVE_URI

See Also

MCdicom Structure
MCdicom Members


RETRIEVE_URL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RETRIEVE_URL Field
MCdicom Structure See Also Send Feedback
Retrieve URL (0008,1190)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RETRIEVE_URL
Visual Basic
Public Const RETRIEVE_URL As UInteger
Visual C++
public:
literal unsigned int RETRIEVE_URL

See Also

MCdicom Structure
MCdicom Members


REVIEW_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REVIEW_DATE Field
MCdicom Structure See Also Send Feedback
Review Date (300E,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REVIEW_DATE
Visual Basic
Public Const REVIEW_DATE As UInteger
Visual C++
public:
literal unsigned int REVIEW_DATE

See Also

MCdicom Structure
MCdicom Members


REVIEW_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REVIEW_TIME Field
MCdicom Structure See Also Send Feedback
Review Time (300E,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REVIEW_TIME
Visual Basic
Public Const REVIEW_TIME As UInteger
Visual C++
public:
literal unsigned int REVIEW_TIME

See Also

MCdicom Structure
MCdicom Members


REVIEWER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REVIEWER_NAME Field
MCdicom Structure See Also Send Feedback
Reviewer Name (300E,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REVIEWER_NAME
Visual Basic
Public Const REVIEWER_NAME As UInteger
Visual C++
public:
literal unsigned int REVIEWER_NAME

See Also

MCdicom Structure
MCdicom Members


REVOLUTION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..REVOLUTION_TIME Field
MCdicom Structure See Also Send Feedback
Revolution Time (0018,9305)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint REVOLUTION_TIME
Visual Basic
Public Const REVOLUTION_TIME As UInteger
Visual C++
public:
literal unsigned int REVOLUTION_TIME

See Also

MCdicom Structure
MCdicom Members


RF_ECHO_TRAIN_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RF_ECHO_TRAIN_LENGTH Field
MCdicom Structure See Also Send Feedback
RF Echo Train Length (0018,9240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RF_ECHO_TRAIN_LENGTH
Visual Basic
Public Const RF_ECHO_TRAIN_LENGTH As UInteger
Visual C++
public:
literal unsigned int RF_ECHO_TRAIN_LENGTH

See Also

MCdicom Structure
MCdicom Members


RGB_LUT_TRANSFER_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RGB_LUT_TRANSFER_FUNCTION Field
MCdicom Structure See Also Send Feedback
RGB LUT Transfer Function (0028,140F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RGB_LUT_TRANSFER_FUNCTION
Visual Basic
Public Const RGB_LUT_TRANSFER_FUNCTION As UInteger
Visual C++
public:
literal unsigned int RGB_LUT_TRANSFER_FUNCTION

See Also

MCdicom Structure
MCdicom Members


RGBA_TRANSFER_FUNCTION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RGBA_TRANSFER_FUNCTION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
RGBA Transfer Function Description (0070,1A09)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RGBA_TRANSFER_FUNCTION_DESCRIPTION
Visual Basic
Public Const RGBA_TRANSFER_FUNCTION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RGBA_TRANSFER_FUNCTION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RIGHT_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RIGHT_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Right Image Sequence (0022,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RIGHT_IMAGE_SEQUENCE
Visual Basic
Public Const RIGHT_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RIGHT_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RIGHT_LENS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RIGHT_LENS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Right Lens Sequence (0046,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RIGHT_LENS_SEQUENCE
Visual Basic
Public Const RIGHT_LENS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RIGHT_LENS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROBOTIC_BASE_LOCATION_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROBOTIC_BASE_LOCATION_INDICATOR Field
MCdicom Structure See Also Send Feedback
Alias for tag ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED (3010,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROBOTIC_BASE_LOCATION_INDICATOR
Visual Basic
Public Const ROBOTIC_BASE_LOCATION_INDICATOR As UInteger
Visual C++
public:
literal unsigned int ROBOTIC_BASE_LOCATION_INDICATOR

See Also

MCdicom Structure
MCdicom Members


ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Robotic Base Location Indicator RETIRED (3010,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED
Visual Basic
Public Const ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int ROBOTIC_BASE_LOCATION_INDICATOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


ROBOTIC_NODE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROBOTIC_NODE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Robotic Node Identifier (3010,0092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROBOTIC_NODE_IDENTIFIER
Visual Basic
Public Const ROBOTIC_NODE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int ROBOTIC_NODE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


ROBOTIC_PATH_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROBOTIC_PATH_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Robotic Path Control Point Sequence (3010,0097)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROBOTIC_PATH_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const ROBOTIC_PATH_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROBOTIC_PATH_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Robotic Path Node Set Code Sequence (3010,0091)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE
Visual Basic
Public Const ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROBOTIC_PATH_NODE_SET_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROI_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_AREA Field
MCdicom Structure See Also Send Feedback
ROI Area (6000,1301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_AREA
Visual Basic
Public Const ROI_AREA As UInteger
Visual C++
public:
literal unsigned int ROI_AREA

See Also

MCdicom Structure
MCdicom Members


ROI_CONTOUR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_CONTOUR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ROI Contour Sequence (3006,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_CONTOUR_SEQUENCE
Visual Basic
Public Const ROI_CONTOUR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROI_CONTOUR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ROI Derivation Algorithm Identification Sequence (3006,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROI_DERIVATION_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROI_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
ROI Description (3006,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_DESCRIPTION
Visual Basic
Public Const ROI_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ROI_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ROI_DISPLAY_COLOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_DISPLAY_COLOR Field
MCdicom Structure See Also Send Feedback
ROI Display Color (3006,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_DISPLAY_COLOR
Visual Basic
Public Const ROI_DISPLAY_COLOR As UInteger
Visual C++
public:
literal unsigned int ROI_DISPLAY_COLOR

See Also

MCdicom Structure
MCdicom Members


ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION Field
MCdicom Structure See Also Send Feedback
ROI Elemental Composition Atomic Mass Fraction (3006,00B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION
Visual Basic
Public Const ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION As UInteger
Visual C++
public:
literal unsigned int ROI_ELEMENTAL_COMPOSITION_ATOMIC_MASS_FRACTION

See Also

MCdicom Structure
MCdicom Members


ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER Field
MCdicom Structure See Also Send Feedback
ROI Elemental Composition Atomic Number (3006,00B7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER
Visual Basic
Public Const ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER As UInteger
Visual C++
public:
literal unsigned int ROI_ELEMENTAL_COMPOSITION_ATOMIC_NUMBER

See Also

MCdicom Structure
MCdicom Members


ROI_ELEMENTAL_COMPOSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_ELEMENTAL_COMPOSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ROI Elemental Composition Sequence (3006,00B6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_ELEMENTAL_COMPOSITION_SEQUENCE
Visual Basic
Public Const ROI_ELEMENTAL_COMPOSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROI_ELEMENTAL_COMPOSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROI_GENERATION_ALGORITHM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_GENERATION_ALGORITHM Field
MCdicom Structure See Also Send Feedback
ROI Generation Algorithm (3006,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_GENERATION_ALGORITHM
Visual Basic
Public Const ROI_GENERATION_ALGORITHM As UInteger
Visual C++
public:
literal unsigned int ROI_GENERATION_ALGORITHM

See Also

MCdicom Structure
MCdicom Members


ROI_GENERATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_GENERATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
ROI Generation Description (3006,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_GENERATION_DESCRIPTION
Visual Basic
Public Const ROI_GENERATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int ROI_GENERATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


ROI_INTERPRETED_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_INTERPRETED_TYPE Field
MCdicom Structure See Also Send Feedback
Alias for tag RT_ROI_INTERPRETED_TYPE (3006,00A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_INTERPRETED_TYPE
Visual Basic
Public Const ROI_INTERPRETED_TYPE As UInteger
Visual C++
public:
literal unsigned int ROI_INTERPRETED_TYPE

See Also

MCdicom Structure
MCdicom Members


ROI_INTERPRETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_INTERPRETER Field
MCdicom Structure See Also Send Feedback
ROI Interpreter (3006,00A6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_INTERPRETER
Visual Basic
Public Const ROI_INTERPRETER As UInteger
Visual C++
public:
literal unsigned int ROI_INTERPRETER

See Also

MCdicom Structure
MCdicom Members


ROI_MEAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_MEAN Field
MCdicom Structure See Also Send Feedback
ROI Mean (6000,1302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_MEAN
Visual Basic
Public Const ROI_MEAN As UInteger
Visual C++
public:
literal unsigned int ROI_MEAN

See Also

MCdicom Structure
MCdicom Members


ROI_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_NAME Field
MCdicom Structure See Also Send Feedback
ROI Name (3006,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_NAME
Visual Basic
Public Const ROI_NAME As UInteger
Visual C++
public:
literal unsigned int ROI_NAME

See Also

MCdicom Structure
MCdicom Members


ROI_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_NUMBER Field
MCdicom Structure See Also Send Feedback
ROI Number (3006,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_NUMBER
Visual Basic
Public Const ROI_NUMBER As UInteger
Visual C++
public:
literal unsigned int ROI_NUMBER

See Also

MCdicom Structure
MCdicom Members


ROI_OBSERVATION_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_OBSERVATION_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
ROI Observation Description RETIRED (3006,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_OBSERVATION_DESCRIPTION_RETIRED
Visual Basic
Public Const ROI_OBSERVATION_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int ROI_OBSERVATION_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


ROI_OBSERVATION_LABEL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_OBSERVATION_LABEL_RETIRED Field
MCdicom Structure See Also Send Feedback
ROI Observation Label RETIRED (3006,0085)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_OBSERVATION_LABEL_RETIRED
Visual Basic
Public Const ROI_OBSERVATION_LABEL_RETIRED As UInteger
Visual C++
public:
literal unsigned int ROI_OBSERVATION_LABEL_RETIRED

See Also

MCdicom Structure
MCdicom Members


ROI_PHYSICAL_PROPERTIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_PHYSICAL_PROPERTIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
ROI Physical Properties Sequence (3006,00B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_PHYSICAL_PROPERTIES_SEQUENCE
Visual Basic
Public Const ROI_PHYSICAL_PROPERTIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROI_PHYSICAL_PROPERTIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROI_PHYSICAL_PROPERTY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_PHYSICAL_PROPERTY Field
MCdicom Structure See Also Send Feedback
ROI Physical Property (3006,00B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_PHYSICAL_PROPERTY
Visual Basic
Public Const ROI_PHYSICAL_PROPERTY As UInteger
Visual C++
public:
literal unsigned int ROI_PHYSICAL_PROPERTY

See Also

MCdicom Structure
MCdicom Members


ROI_PHYSICAL_PROPERTY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_PHYSICAL_PROPERTY_VALUE Field
MCdicom Structure See Also Send Feedback
ROI Physical Property Value (3006,00B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_PHYSICAL_PROPERTY_VALUE
Visual Basic
Public Const ROI_PHYSICAL_PROPERTY_VALUE As UInteger
Visual C++
public:
literal unsigned int ROI_PHYSICAL_PROPERTY_VALUE

See Also

MCdicom Structure
MCdicom Members


ROI_STANDARD_DEVIATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_STANDARD_DEVIATION Field
MCdicom Structure See Also Send Feedback
ROI Standard Deviation (6000,1303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_STANDARD_DEVIATION
Visual Basic
Public Const ROI_STANDARD_DEVIATION As UInteger
Visual C++
public:
literal unsigned int ROI_STANDARD_DEVIATION

See Also

MCdicom Structure
MCdicom Members


ROI_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROI_VOLUME Field
MCdicom Structure See Also Send Feedback
ROI Volume (3006,002C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROI_VOLUME
Visual Basic
Public Const ROI_VOLUME As UInteger
Visual C++
public:
literal unsigned int ROI_VOLUME

See Also

MCdicom Structure
MCdicom Members


ROTATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Rotation Angle (0070,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_ANGLE
Visual Basic
Public Const ROTATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int ROTATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Rotation Direction (0018,1140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_DIRECTION
Visual Basic
Public Const ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


ROTATION_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Rotation Information Sequence (0054,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_INFORMATION_SEQUENCE
Visual Basic
Public Const ROTATION_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROTATION_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROTATION_OF_SCANNED_FILM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_OF_SCANNED_FILM Field
MCdicom Structure See Also Send Feedback
Rotation of Scanned Film (0018,2030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_OF_SCANNED_FILM
Visual Basic
Public Const ROTATION_OF_SCANNED_FILM As UInteger
Visual C++
public:
literal unsigned int ROTATION_OF_SCANNED_FILM

See Also

MCdicom Structure
MCdicom Members


ROTATION_OFFSET_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_OFFSET_RETIRED Field
MCdicom Structure See Also Send Feedback
Rotation Offset RETIRED (0018,1146)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_OFFSET_RETIRED
Visual Basic
Public Const ROTATION_OFFSET_RETIRED As UInteger
Visual C++
public:
literal unsigned int ROTATION_OFFSET_RETIRED

See Also

MCdicom Structure
MCdicom Members


ROTATION_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_POINT Field
MCdicom Structure See Also Send Feedback
Rotation Point (0070,0273)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_POINT
Visual Basic
Public Const ROTATION_POINT As UInteger
Visual C++
public:
literal unsigned int ROTATION_POINT

See Also

MCdicom Structure
MCdicom Members


ROTATION_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROTATION_VECTOR Field
MCdicom Structure See Also Send Feedback
Rotation Vector (0054,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROTATION_VECTOR
Visual Basic
Public Const ROTATION_VECTOR As UInteger
Visual C++
public:
literal unsigned int ROTATION_VECTOR

See Also

MCdicom Structure
MCdicom Members


ROUTE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_ID Field
MCdicom Structure See Also Send Feedback
Route ID (4010,1054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_ID
Visual Basic
Public Const ROUTE_ID As UInteger
Visual C++
public:
literal unsigned int ROUTE_ID

See Also

MCdicom Structure
MCdicom Members


ROUTE_ID_ASSIGNING_AUTHORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_ID_ASSIGNING_AUTHORITY Field
MCdicom Structure See Also Send Feedback
Route ID Assigning Authority (4010,1055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_ID_ASSIGNING_AUTHORITY
Visual Basic
Public Const ROUTE_ID_ASSIGNING_AUTHORITY As UInteger
Visual C++
public:
literal unsigned int ROUTE_ID_ASSIGNING_AUTHORITY

See Also

MCdicom Structure
MCdicom Members


ROUTE_OF_ADMISSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_OF_ADMISSIONS Field
MCdicom Structure See Also Send Feedback
Route of Admissions (0038,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_OF_ADMISSIONS
Visual Basic
Public Const ROUTE_OF_ADMISSIONS As UInteger
Visual C++
public:
literal unsigned int ROUTE_OF_ADMISSIONS

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_END_LOCATION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_END_LOCATION_ID Field
MCdicom Structure See Also Send Feedback
Route Segment End Location ID (4010,101F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_END_LOCATION_ID
Visual Basic
Public Const ROUTE_SEGMENT_END_LOCATION_ID As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_END_LOCATION_ID

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_END_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_END_TIME Field
MCdicom Structure See Also Send Feedback
Route Segment End Time (4010,1026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_END_TIME
Visual Basic
Public Const ROUTE_SEGMENT_END_TIME As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_END_TIME

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_ID Field
MCdicom Structure See Also Send Feedback
Route Segment ID (4010,1007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_ID
Visual Basic
Public Const ROUTE_SEGMENT_ID As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_ID

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_LOCATION_ID_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_LOCATION_ID_TYPE Field
MCdicom Structure See Also Send Feedback
Route Segment Location ID Type (4010,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_LOCATION_ID_TYPE
Visual Basic
Public Const ROUTE_SEGMENT_LOCATION_ID_TYPE As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_LOCATION_ID_TYPE

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Route Segment Sequence (4010,100A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_SEQUENCE
Visual Basic
Public Const ROUTE_SEGMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_START_LOCATION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_START_LOCATION_ID Field
MCdicom Structure See Also Send Feedback
Route Segment Start Location ID (4010,101E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_START_LOCATION_ID
Visual Basic
Public Const ROUTE_SEGMENT_START_LOCATION_ID As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_START_LOCATION_ID

See Also

MCdicom Structure
MCdicom Members


ROUTE_SEGMENT_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROUTE_SEGMENT_START_TIME Field
MCdicom Structure See Also Send Feedback
Route Segment Start Time (4010,1025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROUTE_SEGMENT_START_TIME
Visual Basic
Public Const ROUTE_SEGMENT_START_TIME As UInteger
Visual C++
public:
literal unsigned int ROUTE_SEGMENT_START_TIME

See Also

MCdicom Structure
MCdicom Members


ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX Field
MCdicom Structure See Also Send Feedback
Row Position In Total Image Pixel Matrix (0048,021F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX
Visual Basic
Public Const ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX As UInteger
Visual C++
public:
literal unsigned int ROW_POSITION_IN_TOTAL_IMAGE_PIXEL_MATRIX

See Also

MCdicom Structure
MCdicom Members


ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ROWS Field
MCdicom Structure See Also Send Feedback
Rows (0028,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ROWS
Visual Basic
Public Const ROWS As UInteger
Visual C++
public:
literal unsigned int ROWS

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_DEVICE_SLOT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_DEVICE_SLOT_ID Field
MCdicom Structure See Also Send Feedback
RT Accessory Device Slot ID (300A,0615)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_DEVICE_SLOT_ID
Visual Basic
Public Const RT_ACCESSORY_DEVICE_SLOT_ID As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_DEVICE_SLOT_ID

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Definition Sequence (300A,0614)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE
Visual Basic
Public Const RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_SLOT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_SLOT_DISTANCE Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Slot Distance (300A,0612)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_SLOT_DISTANCE
Visual Basic
Public Const RT_ACCESSORY_HOLDER_SLOT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_SLOT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Slot Existence Flag (300A,060F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG
Visual Basic
Public Const RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_SLOT_EXISTENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_SLOT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_SLOT_ID Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Slot ID (300A,0611)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_SLOT_ID
Visual Basic
Public Const RT_ACCESSORY_HOLDER_SLOT_ID As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_SLOT_ID

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_SLOT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_SLOT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Slot Sequence (300A,0610)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_SLOT_SEQUENCE
Visual Basic
Public Const RT_ACCESSORY_HOLDER_SLOT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_SLOT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
RT Accessory Holder Water-Equivalent Thickness (300A,060D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_HOLDER_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


RT_ACCESSORY_SLOT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACCESSORY_SLOT_DISTANCE Field
MCdicom Structure See Also Send Feedback
RT Accessory Slot Distance (300A,0613)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACCESSORY_SLOT_DISTANCE
Visual Basic
Public Const RT_ACCESSORY_SLOT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RT_ACCESSORY_SLOT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RT_ACQUISITION_PATIENT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ACQUISITION_PATIENT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Acquisition Patient Position Sequence (3002,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ACQUISITION_PATIENT_POSITION_SEQUENCE
Visual Basic
Public Const RT_ACQUISITION_PATIENT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ACQUISITION_PATIENT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ANATOMIC_PRESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ANATOMIC_PRESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Anatomic Prescription Sequence (3010,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ANATOMIC_PRESCRIPTION_SEQUENCE
Visual Basic
Public Const RT_ANATOMIC_PRESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ANATOMIC_PRESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Beam Delimiter Geometry Sequence (300A,064C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE
Visual Basic
Public Const RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_DELIMITER_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_ANGLE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Angle (300A,0679)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_ANGLE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_ANGLE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_ANGLE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Definition Sequence (300A,064D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Distal Distance (300A,0643)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_DISTAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_OFFSET Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Offset (300A,064B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_OFFSET
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_OFFSET As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_OFFSET

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Opening Sequence (300A,0656)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Proximal Distance (300A,0642)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_PROXIMAL_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_LIMITING_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_LIMITING_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
RT Beam Limiting Device Type (300A,00B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_LIMITING_DEVICE_TYPE
Visual Basic
Public Const RT_BEAM_LIMITING_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_LIMITING_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


RT_BEAM_MODIFIER_DEFINITION_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_BEAM_MODIFIER_DEFINITION_DISTANCE Field
MCdicom Structure See Also Send Feedback
RT Beam Modifier Definition Distance (300A,0688)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_BEAM_MODIFIER_DEFINITION_DISTANCE
Visual Basic
Public Const RT_BEAM_MODIFIER_DEFINITION_DISTANCE As UInteger
Visual C++
public:
literal unsigned int RT_BEAM_MODIFIER_DEFINITION_DISTANCE

See Also

MCdicom Structure
MCdicom Members


RT_CONTROL_POINT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_CONTROL_POINT_INDEX Field
MCdicom Structure See Also Send Feedback
RT Control Point Index (300A,0600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_CONTROL_POINT_INDEX
Visual Basic
Public Const RT_CONTROL_POINT_INDEX As UInteger
Visual C++
public:
literal unsigned int RT_CONTROL_POINT_INDEX

See Also

MCdicom Structure
MCdicom Members


RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Delivery Start Patient Position Sequence (300A,0789)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE
Visual Basic
Public Const RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_DELIVERY_START_PATIENT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Device Distance Reference Location Code Sequence (300A,0659)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE
Visual Basic
Public Const RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_DEVICE_DISTANCE_REFERENCE_LOCATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_DIAGNOSIS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_DIAGNOSIS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Diagnosis Code Sequence (3010,005D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_DIAGNOSIS_CODE_SEQUENCE
Visual Basic
Public Const RT_DIAGNOSIS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_DIAGNOSIS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_DOSE_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_DOSE_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Dose ROI Sequence RETIRED (3004,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_DOSE_ROI_SEQUENCE
Visual Basic
Public Const RT_DOSE_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_DOSE_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_DOSE_ROI_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_DOSE_ROI_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
RT Dose ROI Sequence RETIRED (3004,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_DOSE_ROI_SEQUENCE_RETIRED
Visual Basic
Public Const RT_DOSE_ROI_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int RT_DOSE_ROI_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
RT Image Description (3002,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_DESCRIPTION
Visual Basic
Public Const RT_IMAGE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_CONTEXT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_CONTEXT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame Context Sequence (3002,0103)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_CONTEXT_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_CONTEXT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_CONTEXT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame General Content Sequence (3002,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_GENERAL_CONTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame Imaging Device Position Sequence (3002,0109)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_IMAGING_DEVICE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame kV Radiation Acquisition Sequence (3002,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_KV_RADIATION_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame MV Radiation Acquisition Sequence (3002,010B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_MV_RADIATION_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Frame Radiation Acquisition Sequence (3002,010C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE
Visual Basic
Public Const RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_FRAME_RADIATION_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_LABEL Field
MCdicom Structure See Also Send Feedback
RT Image Label (3002,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_LABEL
Visual Basic
Public Const RT_IMAGE_LABEL As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_LABEL

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_NAME Field
MCdicom Structure See Also Send Feedback
RT Image Name (3002,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_NAME
Visual Basic
Public Const RT_IMAGE_NAME As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_NAME

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_ORIENTATION Field
MCdicom Structure See Also Send Feedback
RT Image Orientation (3002,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_ORIENTATION
Visual Basic
Public Const RT_IMAGE_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_PLANE Field
MCdicom Structure See Also Send Feedback
RT Image Plane (3002,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_PLANE
Visual Basic
Public Const RT_IMAGE_PLANE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_PLANE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_POSITION Field
MCdicom Structure See Also Send Feedback
RT Image Position (3002,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_POSITION
Visual Basic
Public Const RT_IMAGE_POSITION As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_POSITION

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_SCOPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_SCOPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Image Scope Sequence (3002,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_SCOPE_SEQUENCE
Visual Basic
Public Const RT_IMAGE_SCOPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_SCOPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_IMAGE_SID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_IMAGE_SID Field
MCdicom Structure See Also Send Feedback
RT Image SID (3002,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_IMAGE_SID
Visual Basic
Public Const RT_IMAGE_SID As UInteger
Visual C++
public:
literal unsigned int RT_IMAGE_SID

See Also

MCdicom Structure
MCdicom Members


RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Patient Position Displacement Sequence (300A,0798)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE
Visual Basic
Public Const RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PATIENT_POSITION_DISPLACEMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PATIENT_POSITION_SCOPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PATIENT_POSITION_SCOPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Patient Position Scope Sequence (300A,0784)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PATIENT_POSITION_SCOPE_SEQUENCE
Visual Basic
Public Const RT_PATIENT_POSITION_SCOPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PATIENT_POSITION_SCOPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PATIENT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PATIENT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Patient Position Sequence (300A,0799)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PATIENT_POSITION_SEQUENCE
Visual Basic
Public Const RT_PATIENT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PATIENT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PHYSICIAN_INTENT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PHYSICIAN_INTENT_INDEX Field
MCdicom Structure See Also Send Feedback
RT Physician Intent Index (3010,0058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PHYSICIAN_INTENT_INDEX
Visual Basic
Public Const RT_PHYSICIAN_INTENT_INDEX As UInteger
Visual C++
public:
literal unsigned int RT_PHYSICIAN_INTENT_INDEX

See Also

MCdicom Structure
MCdicom Members


RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Physician Intent Input Instance Sequence (3010,005F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE
Visual Basic
Public Const RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PHYSICIAN_INTENT_INPUT_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PHYSICIAN_INTENT_NARRATIVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PHYSICIAN_INTENT_NARRATIVE Field
MCdicom Structure See Also Send Feedback
RT Physician Intent Narrative (3010,005A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PHYSICIAN_INTENT_NARRATIVE
Visual Basic
Public Const RT_PHYSICIAN_INTENT_NARRATIVE As UInteger
Visual C++
public:
literal unsigned int RT_PHYSICIAN_INTENT_NARRATIVE

See Also

MCdicom Structure
MCdicom Members


RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Physician Intent Predecessor Sequence (3010,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE
Visual Basic
Public Const RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PHYSICIAN_INTENT_PREDECESSOR_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PHYSICIAN_INTENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PHYSICIAN_INTENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Physician Intent Sequence (3010,0057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PHYSICIAN_INTENT_SEQUENCE
Visual Basic
Public Const RT_PHYSICIAN_INTENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PHYSICIAN_INTENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_DATE Field
MCdicom Structure See Also Send Feedback
RT Plan Date (300A,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_DATE
Visual Basic
Public Const RT_PLAN_DATE As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_DATE

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
RT Plan Description (300A,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_DESCRIPTION
Visual Basic
Public Const RT_PLAN_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_GEOMETRY Field
MCdicom Structure See Also Send Feedback
RT Plan Geometry (300A,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_GEOMETRY
Visual Basic
Public Const RT_PLAN_GEOMETRY As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_GEOMETRY

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_LABEL Field
MCdicom Structure See Also Send Feedback
RT Plan Label (300A,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_LABEL
Visual Basic
Public Const RT_PLAN_LABEL As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_LABEL

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_NAME Field
MCdicom Structure See Also Send Feedback
RT Plan Name (300A,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_NAME
Visual Basic
Public Const RT_PLAN_NAME As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_NAME

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
RT Plan Relationship (300A,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_RELATIONSHIP
Visual Basic
Public Const RT_PLAN_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


RT_PLAN_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PLAN_TIME Field
MCdicom Structure See Also Send Feedback
RT Plan Time (300A,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PLAN_TIME
Visual Basic
Public Const RT_PLAN_TIME As UInteger
Visual C++
public:
literal unsigned int RT_PLAN_TIME

See Also

MCdicom Structure
MCdicom Members


RT_PRESCRIPTION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PRESCRIPTION_INDEX Field
MCdicom Structure See Also Send Feedback
RT Prescription Index (3010,003C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PRESCRIPTION_INDEX
Visual Basic
Public Const RT_PRESCRIPTION_INDEX As UInteger
Visual C++
public:
literal unsigned int RT_PRESCRIPTION_INDEX

See Also

MCdicom Structure
MCdicom Members


RT_PRESCRIPTION_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PRESCRIPTION_LABEL Field
MCdicom Structure See Also Send Feedback
RT Prescription Label (3010,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PRESCRIPTION_LABEL
Visual Basic
Public Const RT_PRESCRIPTION_LABEL As UInteger
Visual C++
public:
literal unsigned int RT_PRESCRIPTION_LABEL

See Also

MCdicom Structure
MCdicom Members


RT_PRESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PRESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Prescription Sequence (3010,006B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PRESCRIPTION_SEQUENCE
Visual Basic
Public Const RT_PRESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PRESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_PROTOCOL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_PROTOCOL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Protocol Code Sequence (3010,005B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_PROTOCOL_CODE_SEQUENCE
Visual Basic
Public Const RT_PROTOCOL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_PROTOCOL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG Field
MCdicom Structure See Also Send Feedback
RT Radiation Physical and Geometric Content Detail Flag (300A,0638)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG
Visual Basic
Public Const RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_PHYSICAL_AND_GEOMETRIC_CONTENT_DETAIL_FLAG

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Radiation Salvage Record Control Point Sequence (300A,0722)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Radiation Sequence (300A,0616)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SEQUENCE
Visual Basic
Public Const RT_RADIATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SET_DELIVERY_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SET_DELIVERY_NUMBER Field
MCdicom Structure See Also Send Feedback
RT Radiation Set Delivery Number (300A,0704)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SET_DELIVERY_NUMBER
Visual Basic
Public Const RT_RADIATION_SET_DELIVERY_NUMBER As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SET_DELIVERY_NUMBER

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SET_DELIVERY_USAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SET_DELIVERY_USAGE Field
MCdicom Structure See Also Send Feedback
RT Radiation Set Delivery Usage (300A,079E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SET_DELIVERY_USAGE
Visual Basic
Public Const RT_RADIATION_SET_DELIVERY_USAGE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SET_DELIVERY_USAGE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SET_INTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SET_INTENT Field
MCdicom Structure See Also Send Feedback
RT Radiation Set Intent (300A,0637)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SET_INTENT
Visual Basic
Public Const RT_RADIATION_SET_INTENT As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SET_INTENT

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_SET_USAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_SET_USAGE Field
MCdicom Structure See Also Send Feedback
RT Radiation Set Usage (300A,0707)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_SET_USAGE
Visual Basic
Public Const RT_RADIATION_SET_USAGE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_SET_USAGE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_TASK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_TASK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Radiation Task Sequence (300A,0797)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_TASK_SEQUENCE
Visual Basic
Public Const RT_RADIATION_TASK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_TASK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_RADIATION_USAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RADIATION_USAGE Field
MCdicom Structure See Also Send Feedback
RT Radiation Usage (300A,0701)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RADIATION_USAGE
Visual Basic
Public Const RT_RADIATION_USAGE As UInteger
Visual C++
public:
literal unsigned int RT_RADIATION_USAGE

See Also

MCdicom Structure
MCdicom Members


RT_RECORD_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RECORD_FLAG Field
MCdicom Structure See Also Send Feedback
RT Record Flag (300A,0639)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RECORD_FLAG
Visual Basic
Public Const RT_RECORD_FLAG As UInteger
Visual C++
public:
literal unsigned int RT_RECORD_FLAG

See Also

MCdicom Structure
MCdicom Members


RT_REFERENCED_SERIES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_REFERENCED_SERIES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Referenced Series Sequence (3006,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_REFERENCED_SERIES_SEQUENCE
Visual Basic
Public Const RT_REFERENCED_SERIES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_REFERENCED_SERIES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_REFERENCED_STUDY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_REFERENCED_STUDY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Referenced Study Sequence (3006,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_REFERENCED_STUDY_SEQUENCE
Visual Basic
Public Const RT_REFERENCED_STUDY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_REFERENCED_STUDY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_RELATED_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_RELATED_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Related ROI Sequence (3006,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_RELATED_ROI_SEQUENCE
Visual Basic
Public Const RT_RELATED_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_RELATED_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ROI_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ROI_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT ROI Identification Code Sequence (3006,0086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ROI_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const RT_ROI_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ROI_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ROI_INTERPRETED_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ROI_INTERPRETED_TYPE Field
MCdicom Structure See Also Send Feedback
RT ROI Interpreted Type (3006,00A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ROI_INTERPRETED_TYPE
Visual Basic
Public Const RT_ROI_INTERPRETED_TYPE As UInteger
Visual C++
public:
literal unsigned int RT_ROI_INTERPRETED_TYPE

See Also

MCdicom Structure
MCdicom Members


RT_ROI_OBERVATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ROI_OBERVATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag RT_ROI_OBSERVATIONS_SEQUENCE (3006,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ROI_OBERVATIONS_SEQUENCE
Visual Basic
Public Const RT_ROI_OBERVATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ROI_OBERVATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ROI_OBSERVATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ROI_OBSERVATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT ROI Observations Sequence (3006,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ROI_OBSERVATIONS_SEQUENCE
Visual Basic
Public Const RT_ROI_OBSERVATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_ROI_OBSERVATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_ROI_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_ROI_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
RT ROI Relationship (3006,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_ROI_RELATIONSHIP
Visual Basic
Public Const RT_ROI_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int RT_ROI_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


RT_SEGMENT_ANNOTATION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_SEGMENT_ANNOTATION_INDEX Field
MCdicom Structure See Also Send Feedback
RT Segment Annotation Index (3010,003D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_SEGMENT_ANNOTATION_INDEX
Visual Basic
Public Const RT_SEGMENT_ANNOTATION_INDEX As UInteger
Visual C++
public:
literal unsigned int RT_SEGMENT_ANNOTATION_INDEX

See Also

MCdicom Structure
MCdicom Members


RT_SEGMENT_ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_SEGMENT_ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Segment Annotation Sequence (3010,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_SEGMENT_ANNOTATION_SEQUENCE
Visual Basic
Public Const RT_SEGMENT_ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_SEGMENT_ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TOLERANCE_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TOLERANCE_SET_LABEL Field
MCdicom Structure See Also Send Feedback
RT Tolerance Set Label (300A,062A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TOLERANCE_SET_LABEL
Visual Basic
Public Const RT_TOLERANCE_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int RT_TOLERANCE_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


RT_TOLERANCE_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TOLERANCE_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Tolerance Set Sequence (300A,0629)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TOLERANCE_SET_SEQUENCE
Visual Basic
Public Const RT_TOLERANCE_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_TOLERANCE_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_APPROACH_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_APPROACH_LABEL Field
MCdicom Structure See Also Send Feedback
RT Treatment Approach Label (3010,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_APPROACH_LABEL
Visual Basic
Public Const RT_TREATMENT_APPROACH_LABEL As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_APPROACH_LABEL

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_FRACTION_COMPLETION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_FRACTION_COMPLETION_STATUS Field
MCdicom Structure See Also Send Feedback
RT Treatment Fraction Completion Status (300A,0706)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_FRACTION_COMPLETION_STATUS
Visual Basic
Public Const RT_TREATMENT_FRACTION_COMPLETION_STATUS As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_FRACTION_COMPLETION_STATUS

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_INTENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_INTENT_TYPE Field
MCdicom Structure See Also Send Feedback
RT Treatment Intent Type (3010,0059)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_INTENT_TYPE
Visual Basic
Public Const RT_TREATMENT_INTENT_TYPE As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_INTENT_TYPE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_PHASE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_PHASE_INDEX Field
MCdicom Structure See Also Send Feedback
RT Treatment Phase Index (3010,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_PHASE_INDEX
Visual Basic
Public Const RT_TREATMENT_PHASE_INDEX As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_PHASE_INDEX

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG Field
MCdicom Structure See Also Send Feedback
RT Treatment Phase Intent Presence Flag (3010,0045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG
Visual Basic
Public Const RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_PHASE_INTENT_PRESENCE_FLAG

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_PHASE_INTERVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_PHASE_INTERVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Treatment Phase Interval Sequence (3010,004E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_PHASE_INTERVAL_SEQUENCE
Visual Basic
Public Const RT_TREATMENT_PHASE_INTERVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_PHASE_INTERVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_PHASE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_PHASE_UID Field
MCdicom Structure See Also Send Feedback
RT Treatment Phase UID (3010,003B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_PHASE_UID
Visual Basic
Public Const RT_TREATMENT_PHASE_UID As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_PHASE_UID

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Treatment Preparation Patient Position Sequence (300A,078A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE
Visual Basic
Public Const RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_PREPARATION_PATIENT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_SOURCE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_SOURCE_COORDINATES Field
MCdicom Structure See Also Send Feedback
RT Treatment Source Coordinates (3010,0093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_SOURCE_COORDINATES
Visual Basic
Public Const RT_TREATMENT_SOURCE_COORDINATES As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_SOURCE_COORDINATES

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Treatment Technique Code Sequence (3010,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE
Visual Basic
Public Const RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_TECHNIQUE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
RT Treatment Termination Reason Code Sequence (300A,0715)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE
Visual Basic
Public Const RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_TERMINATION_REASON_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


RT_TREATMENT_TERMINATION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RT_TREATMENT_TERMINATION_STATUS Field
MCdicom Structure See Also Send Feedback
RT Treatment Termination Status (300A,0714)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RT_TREATMENT_TERMINATION_STATUS
Visual Basic
Public Const RT_TREATMENT_TERMINATION_STATUS As UInteger
Visual C++
public:
literal unsigned int RT_TREATMENT_TERMINATION_STATUS

See Also

MCdicom Structure
MCdicom Members


RTV_COMMUNICATION_SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_COMMUNICATION_SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
RTV Communication SOP Class UID (0002,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_COMMUNICATION_SOP_CLASS_UID
Visual Basic
Public Const RTV_COMMUNICATION_SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int RTV_COMMUNICATION_SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


RTV_COMMUNICATION_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_COMMUNICATION_SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
RTV Communication SOP Instance UID (0002,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_COMMUNICATION_SOP_INSTANCE_UID
Visual Basic
Public Const RTV_COMMUNICATION_SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int RTV_COMMUNICATION_SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


RTV_FLOW_ACTUAL_FRAME_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_FLOW_ACTUAL_FRAME_DURATION Field
MCdicom Structure See Also Send Feedback
RTV Flow Actual Frame Duration (0002,0038)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_FLOW_ACTUAL_FRAME_DURATION
Visual Basic
Public Const RTV_FLOW_ACTUAL_FRAME_DURATION As UInteger
Visual C++
public:
literal unsigned int RTV_FLOW_ACTUAL_FRAME_DURATION

See Also

MCdicom Structure
MCdicom Members


RTV_FLOW_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_FLOW_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
RTV Flow Identifier (0002,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_FLOW_IDENTIFIER
Visual Basic
Public Const RTV_FLOW_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int RTV_FLOW_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


RTV_FLOW_RTP_SAMPLING_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_FLOW_RTP_SAMPLING_RATE Field
MCdicom Structure See Also Send Feedback
RTV Flow RTP Sampling Rate (0002,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_FLOW_RTP_SAMPLING_RATE
Visual Basic
Public Const RTV_FLOW_RTP_SAMPLING_RATE As UInteger
Visual C++
public:
literal unsigned int RTV_FLOW_RTP_SAMPLING_RATE

See Also

MCdicom Structure
MCdicom Members


RTV_META_INFORMATION_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_META_INFORMATION_VERSION Field
MCdicom Structure See Also Send Feedback
RTV Meta Information Version (0002,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_META_INFORMATION_VERSION
Visual Basic
Public Const RTV_META_INFORMATION_VERSION As UInteger
Visual C++
public:
literal unsigned int RTV_META_INFORMATION_VERSION

See Also

MCdicom Structure
MCdicom Members


RTV_SOURCE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..RTV_SOURCE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
RTV Source Identifier (0002,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint RTV_SOURCE_IDENTIFIER
Visual Basic
Public Const RTV_SOURCE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int RTV_SOURCE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


SAFE_POSITION_EXIT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAFE_POSITION_EXIT_DATE Field
MCdicom Structure See Also Send Feedback
Safe Position Exit Date (3008,0162)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAFE_POSITION_EXIT_DATE
Visual Basic
Public Const SAFE_POSITION_EXIT_DATE As UInteger
Visual C++
public:
literal unsigned int SAFE_POSITION_EXIT_DATE

See Also

MCdicom Structure
MCdicom Members


SAFE_POSITION_EXIT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAFE_POSITION_EXIT_TIME Field
MCdicom Structure See Also Send Feedback
Safe Position Exit Time (3008,0164)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAFE_POSITION_EXIT_TIME
Visual Basic
Public Const SAFE_POSITION_EXIT_TIME As UInteger
Visual C++
public:
literal unsigned int SAFE_POSITION_EXIT_TIME

See Also

MCdicom Structure
MCdicom Members


SAFE_POSITION_RETURN_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAFE_POSITION_RETURN_DATE Field
MCdicom Structure See Also Send Feedback
Safe Position Return Date (3008,0166)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAFE_POSITION_RETURN_DATE
Visual Basic
Public Const SAFE_POSITION_RETURN_DATE As UInteger
Visual C++
public:
literal unsigned int SAFE_POSITION_RETURN_DATE

See Also

MCdicom Structure
MCdicom Members


SAFE_POSITION_RETURN_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAFE_POSITION_RETURN_TIME Field
MCdicom Structure See Also Send Feedback
Safe Position Return Time (3008,0168)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAFE_POSITION_RETURN_TIME
Visual Basic
Public Const SAFE_POSITION_RETURN_TIME As UInteger
Visual C++
public:
literal unsigned int SAFE_POSITION_RETURN_TIME

See Also

MCdicom Structure
MCdicom Members


SAMPLE_RATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAMPLE_RATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Sample Rate RETIRED (5000,2008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAMPLE_RATE_RETIRED
Visual Basic
Public Const SAMPLE_RATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SAMPLE_RATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SAMPLES_PER_PIXEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAMPLES_PER_PIXEL Field
MCdicom Structure See Also Send Feedback
Samples per Pixel (0028,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAMPLES_PER_PIXEL
Visual Basic
Public Const SAMPLES_PER_PIXEL As UInteger
Visual C++
public:
literal unsigned int SAMPLES_PER_PIXEL

See Also

MCdicom Structure
MCdicom Members


SAMPLES_PER_PIXEL_USED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAMPLES_PER_PIXEL_USED Field
MCdicom Structure See Also Send Feedback
Samples per Pixel Used (0028,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAMPLES_PER_PIXEL_USED
Visual Basic
Public Const SAMPLES_PER_PIXEL_USED As UInteger
Visual C++
public:
literal unsigned int SAMPLES_PER_PIXEL_USED

See Also

MCdicom Structure
MCdicom Members


SAMPLING_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAMPLING_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Sampling Frequency (003A,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAMPLING_FREQUENCY
Visual Basic
Public Const SAMPLING_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int SAMPLING_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


SAMPLING_STEP_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAMPLING_STEP_SIZE Field
MCdicom Structure See Also Send Feedback
Sampling Step Size (0070,1607)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAMPLING_STEP_SIZE
Visual Basic
Public Const SAMPLING_STEP_SIZE As UInteger
Visual C++
public:
literal unsigned int SAMPLING_STEP_SIZE

See Also

MCdicom Structure
MCdicom Members


SAR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SAR Field
MCdicom Structure See Also Send Feedback
SAR (0018,1316)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SAR
Visual Basic
Public Const SAR As UInteger
Visual C++
public:
literal unsigned int SAR

See Also

MCdicom Structure
MCdicom Members


SATURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SATURATION Field
MCdicom Structure See Also Send Feedback
Saturation (0016,0049)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SATURATION
Visual Basic
Public Const SATURATION As UInteger
Visual C++
public:
literal unsigned int SATURATION

See Also

MCdicom Structure
MCdicom Members


SATURATION_RECOVERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SATURATION_RECOVERY Field
MCdicom Structure See Also Send Feedback
Saturation Recovery (0018,9024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SATURATION_RECOVERY
Visual Basic
Public Const SATURATION_RECOVERY As UInteger
Visual C++
public:
literal unsigned int SATURATION_RECOVERY

See Also

MCdicom Structure
MCdicom Members


SCAN_ARC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_ARC Field
MCdicom Structure See Also Send Feedback
Scan Arc (0018,1143)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_ARC
Visual Basic
Public Const SCAN_ARC As UInteger
Visual C++
public:
literal unsigned int SCAN_ARC

See Also

MCdicom Structure
MCdicom Members


SCAN_ARC_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_ARC_TYPE Field
MCdicom Structure See Also Send Feedback
Scan Arc Type (3002,012E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_ARC_TYPE
Visual Basic
Public Const SCAN_ARC_TYPE As UInteger
Visual C++
public:
literal unsigned int SCAN_ARC_TYPE

See Also

MCdicom Structure
MCdicom Members


SCAN_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_LENGTH Field
MCdicom Structure See Also Send Feedback
Scan Length (0018,1302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_LENGTH
Visual Basic
Public Const SCAN_LENGTH As UInteger
Visual C++
public:
literal unsigned int SCAN_LENGTH

See Also

MCdicom Structure
MCdicom Members


SCAN_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_MODE Field
MCdicom Structure See Also Send Feedback
Scan Mode (300A,0308)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_MODE
Visual Basic
Public Const SCAN_MODE As UInteger
Visual C++
public:
literal unsigned int SCAN_MODE

See Also

MCdicom Structure
MCdicom Members


SCAN_OPTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_OPTIONS Field
MCdicom Structure See Also Send Feedback
Scan Options (0018,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_OPTIONS
Visual Basic
Public Const SCAN_OPTIONS As UInteger
Visual C++
public:
literal unsigned int SCAN_OPTIONS

See Also

MCdicom Structure
MCdicom Members


SCAN_PATTERN_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_PATTERN_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scan Pattern Type Code Sequence (0022,1618)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_PATTERN_TYPE_CODE_SEQUENCE
Visual Basic
Public Const SCAN_PATTERN_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCAN_PATTERN_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCAN_PROGRESSION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_PROGRESSION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Scan Progression Direction (0054,0501)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_PROGRESSION_DIRECTION
Visual Basic
Public Const SCAN_PROGRESSION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int SCAN_PROGRESSION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_METERSET_WEIGHTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_METERSET_WEIGHTS Field
MCdicom Structure See Also Send Feedback
Scan Spot Meterset Weights (300A,0396)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_METERSET_WEIGHTS
Visual Basic
Public Const SCAN_SPOT_METERSET_WEIGHTS As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_METERSET_WEIGHTS

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_METERSETS_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_METERSETS_DELIVERED Field
MCdicom Structure See Also Send Feedback
Scan Spot Metersets Delivered (3008,0047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_METERSETS_DELIVERED
Visual Basic
Public Const SCAN_SPOT_METERSETS_DELIVERED As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_METERSETS_DELIVERED

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_POSITION_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_POSITION_MAP Field
MCdicom Structure See Also Send Feedback
Scan Spot Position Map (300A,0394)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_POSITION_MAP
Visual Basic
Public Const SCAN_SPOT_POSITION_MAP As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_POSITION_MAP

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_PRESCRIBED_INDICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_PRESCRIBED_INDICES Field
MCdicom Structure See Also Send Feedback
Scan Spot Prescribed Indices (300A,0391)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_PRESCRIBED_INDICES
Visual Basic
Public Const SCAN_SPOT_PRESCRIBED_INDICES As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_PRESCRIBED_INDICES

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_REORDERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_REORDERED Field
MCdicom Structure See Also Send Feedback
Scan Spot Reordered (300A,0393)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_REORDERED
Visual Basic
Public Const SCAN_SPOT_REORDERED As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_REORDERED

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_REORDERING_ALLOWED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_REORDERING_ALLOWED Field
MCdicom Structure See Also Send Feedback
Scan Spot Reordering Allowed (300A,0395)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_REORDERING_ALLOWED
Visual Basic
Public Const SCAN_SPOT_REORDERING_ALLOWED As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_REORDERING_ALLOWED

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_SIZES_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_SIZES_DELIVERED Field
MCdicom Structure See Also Send Feedback
Scan Spot Sizes Delivered (300A,0399)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_SIZES_DELIVERED
Visual Basic
Public Const SCAN_SPOT_SIZES_DELIVERED As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_SIZES_DELIVERED

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_TIME_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_TIME_OFFSET Field
MCdicom Structure See Also Send Feedback
Scan Spot Time Offset (300A,038F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_TIME_OFFSET
Visual Basic
Public Const SCAN_SPOT_TIME_OFFSET As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_TIME_OFFSET

See Also

MCdicom Structure
MCdicom Members


SCAN_SPOT_TUNE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_SPOT_TUNE_ID Field
MCdicom Structure See Also Send Feedback
Scan Spot Tune ID (300A,0390)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_SPOT_TUNE_ID
Visual Basic
Public Const SCAN_SPOT_TUNE_ID As UInteger
Visual C++
public:
literal unsigned int SCAN_SPOT_TUNE_ID

See Also

MCdicom Structure
MCdicom Members


SCAN_START_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_START_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scan Start Position Sequence (3002,012B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_START_POSITION_SEQUENCE
Visual Basic
Public Const SCAN_START_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCAN_START_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCAN_STOP_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_STOP_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scan Stop Position Sequence (3002,012C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_STOP_POSITION_SEQUENCE
Visual Basic
Public Const SCAN_STOP_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCAN_STOP_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCAN_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_TYPE Field
MCdicom Structure See Also Send Feedback
Scan Type (4010,1048)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_TYPE
Visual Basic
Public Const SCAN_TYPE As UInteger
Visual C++
public:
literal unsigned int SCAN_TYPE

See Also

MCdicom Structure
MCdicom Members


SCAN_VELOCITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCAN_VELOCITY Field
MCdicom Structure See Also Send Feedback
Scan Velocity (0018,1300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCAN_VELOCITY
Visual Basic
Public Const SCAN_VELOCITY As UInteger
Visual C++
public:
literal unsigned int SCAN_VELOCITY

See Also

MCdicom Structure
MCdicom Members


SCANNING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCANNING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scanning Sequence (0018,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCANNING_SEQUENCE
Visual Basic
Public Const SCANNING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCANNING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCANNING_SPOT_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCANNING_SPOT_SIZE Field
MCdicom Structure See Also Send Feedback
Scanning Spot Size (300A,0398)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCANNING_SPOT_SIZE
Visual Basic
Public Const SCANNING_SPOT_SIZE As UInteger
Visual C++
public:
literal unsigned int SCANNING_SPOT_SIZE

See Also

MCdicom Structure
MCdicom Members


SCATTER_CORRECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCATTER_CORRECTED Field
MCdicom Structure See Also Send Feedback
Scatter Corrected (0018,9760)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCATTER_CORRECTED
Visual Basic
Public Const SCATTER_CORRECTED As UInteger
Visual C++
public:
literal unsigned int SCATTER_CORRECTED

See Also

MCdicom Structure
MCdicom Members


SCATTER_CORRECTION_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCATTER_CORRECTION_METHOD Field
MCdicom Structure See Also Send Feedback
Scatter Correction Method (0054,1105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCATTER_CORRECTION_METHOD
Visual Basic
Public Const SCATTER_CORRECTION_METHOD As UInteger
Visual C++
public:
literal unsigned int SCATTER_CORRECTION_METHOD

See Also

MCdicom Structure
MCdicom Members


SCATTER_FRACTION_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCATTER_FRACTION_FACTOR Field
MCdicom Structure See Also Send Feedback
Scatter Fraction Factor (0054,1323)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCATTER_FRACTION_FACTOR
Visual Basic
Public Const SCATTER_FRACTION_FACTOR As UInteger
Visual C++
public:
literal unsigned int SCATTER_FRACTION_FACTOR

See Also

MCdicom Structure
MCdicom Members


SCENE_CAPTURE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCENE_CAPTURE_TYPE Field
MCdicom Structure See Also Send Feedback
Scene Capture Type (0016,0046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCENE_CAPTURE_TYPE
Visual Basic
Public Const SCENE_CAPTURE_TYPE As UInteger
Visual C++
public:
literal unsigned int SCENE_CAPTURE_TYPE

See Also

MCdicom Structure
MCdicom Members


SCENE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCENE_TYPE Field
MCdicom Structure See Also Send Feedback
Scene Type (0016,003B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCENE_TYPE
Visual Basic
Public Const SCENE_TYPE As UInteger
Visual C++
public:
literal unsigned int SCENE_TYPE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_ADMISSION_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_ADMISSION_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Admission Date RETIRED (0038,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_ADMISSION_DATE_RETIRED
Visual Basic
Public Const SCHEDULED_ADMISSION_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_ADMISSION_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_ADMISSION_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_ADMISSION_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Admission Time RETIRED (0038,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_ADMISSION_TIME_RETIRED
Visual Basic
Public Const SCHEDULED_ADMISSION_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_ADMISSION_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_DISCHARGE_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_DISCHARGE_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Discharge Date RETIRED (0038,001C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_DISCHARGE_DATE_RETIRED
Visual Basic
Public Const SCHEDULED_DISCHARGE_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_DISCHARGE_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_DISCHARGE_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_DISCHARGE_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Discharge Time RETIRED (0038,001D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_DISCHARGE_TIME_RETIRED
Visual Basic
Public Const SCHEDULED_DISCHARGE_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_DISCHARGE_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_HUMAN_PERFORMERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_HUMAN_PERFORMERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Human Performers Sequence (0040,4034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_HUMAN_PERFORMERS_SEQUENCE
Visual Basic
Public Const SCHEDULED_HUMAN_PERFORMERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_HUMAN_PERFORMERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Patient Institution Residence RETIRED (0038,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED
Visual Basic
Public Const SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PATIENT_INSTITUTION_RESIDENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE (0040,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PERFORMING_PHYS_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Performing Physician Identification Sequence (0040,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PERFORMING_PHYSICIAN_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PERFORMING_PHYSICIANS_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PERFORMING_PHYSICIANS_NAME Field
MCdicom Structure See Also Send Feedback
Scheduled Performing Physician's Name (0040,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PERFORMING_PHYSICIANS_NAME
Visual Basic
Public Const SCHEDULED_PERFORMING_PHYSICIANS_NAME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PERFORMING_PHYSICIANS_NAME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Description (0040,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_DESCRIPTION
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_END_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_END_DATE Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step End Date (0040,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_END_DATE
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_END_DATE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_END_DATE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_END_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_END_TIME Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step End Time (0040,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_END_TIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_END_TIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_END_TIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Expiration DateTime (0040,4008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_EXPIRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_ID Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step ID (0040,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_ID
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_ID As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_ID

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_LOCATION Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Location (0040,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_LOCATION
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_LOCATION As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_LOCATION

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Modification DateTime (0040,4010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_MODIFICATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_PRIORITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_PRIORITY Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Priority (0074,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_PRIORITY
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_PRIORITY As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_PRIORITY

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Sequence (0040,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_SEQUENCE
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_START_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_START_DATE Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Start Date (0040,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_START_DATE
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_START_DATE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_START_DATE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag SCHEDULED_PROCEDURE_STEP_START_DATETIME (0040,4005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_START_DATE_AND_TIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_START_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_START_DATETIME Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Start DateTime (0040,4005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_START_DATETIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_START_DATETIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_START_DATETIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_START_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_START_TIME Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Start Time (0040,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_START_TIME
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_START_TIME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_START_TIME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCEDURE_STEP_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCEDURE_STEP_STATUS Field
MCdicom Structure See Also Send Feedback
Scheduled Procedure Step Status (0040,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCEDURE_STEP_STATUS
Visual Basic
Public Const SCHEDULED_PROCEDURE_STEP_STATUS As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCEDURE_STEP_STATUS

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Processing Applications Code Sequence RETIRED (0040,4004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED
Visual Basic
Public Const SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCESSING_APPLICATIONS_CODE_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Processing Parameters Sequence (0074,1210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE
Visual Basic
Public Const SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROCESSING_PARAMETERS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_PROTOCOL_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_PROTOCOL_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Protocol Code Sequence (0040,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_PROTOCOL_CODE_SEQUENCE
Visual Basic
Public Const SCHEDULED_PROTOCOL_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_PROTOCOL_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_SPECIMEN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_SPECIMEN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Specimen Sequence (0040,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_SPECIMEN_SEQUENCE
Visual Basic
Public Const SCHEDULED_SPECIMEN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_SPECIMEN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STATION_AE_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STATION_AE_TITLE Field
MCdicom Structure See Also Send Feedback
Scheduled Station AE Title (0040,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STATION_AE_TITLE
Visual Basic
Public Const SCHEDULED_STATION_AE_TITLE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STATION_AE_TITLE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STATION_CLASS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STATION_CLASS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Station Class Code Sequence (0040,4026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STATION_CLASS_CODE_SEQUENCE
Visual Basic
Public Const SCHEDULED_STATION_CLASS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STATION_CLASS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Station Geographic Location Code Sequence (0040,4027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE
Visual Basic
Public Const SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STATION_GEOGRAPHIC_LOCATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STATION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STATION_NAME Field
MCdicom Structure See Also Send Feedback
Scheduled Station Name (0040,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STATION_NAME
Visual Basic
Public Const SCHEDULED_STATION_NAME As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STATION_NAME

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STATION_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STATION_NAME_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Station Name Code Sequence (0040,4025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STATION_NAME_CODE_SEQUENCE
Visual Basic
Public Const SCHEDULED_STATION_NAME_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STATION_NAME_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STEP_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STEP_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Step Attributes Sequence (0040,0270)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STEP_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const SCHEDULED_STEP_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STEP_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Location AE Title RETIRED (0032,1021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_LOCATION_AE_TITLE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_LOCATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_LOCATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Location RETIRED (0032,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_LOCATION_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_LOCATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_LOCATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_START_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_START_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Start Date RETIRED (0032,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_START_DATE_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_START_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_START_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_START_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_START_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Start Time RETIRED (0032,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_START_TIME_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_START_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_START_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_STOP_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_STOP_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Stop Date RETIRED (0032,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_STOP_DATE_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_STOP_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_STOP_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_STUDY_STOP_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_STUDY_STOP_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Scheduled Study Stop Time RETIRED (0032,1011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_STUDY_STOP_TIME_RETIRED
Visual Basic
Public Const SCHEDULED_STUDY_STOP_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_STUDY_STOP_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


SCHEDULED_WORKITEM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCHEDULED_WORKITEM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scheduled Workitem Code Sequence (0040,4018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCHEDULED_WORKITEM_CODE_SEQUENCE
Visual Basic
Public Const SCHEDULED_WORKITEM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCHEDULED_WORKITEM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCOPE_OF_INVENTORY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCOPE_OF_INVENTORY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Scope of Inventory Sequence (0008,0400)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCOPE_OF_INVENTORY_SEQUENCE
Visual Basic
Public Const SCOPE_OF_INVENTORY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCOPE_OF_INVENTORY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCP_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCP_STATUS Field
MCdicom Structure See Also Send Feedback
SCP Status (0074,1242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCP_STATUS
Visual Basic
Public Const SCP_STATUS As UInteger
Visual C++
public:
literal unsigned int SCP_STATUS

See Also

MCdicom Structure
MCdicom Members


SCREEN_MINIMUM_COLOR_BIT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREEN_MINIMUM_COLOR_BIT_DEPTH Field
MCdicom Structure See Also Send Feedback
Screen Minimum Color Bit Depth (0072,010C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREEN_MINIMUM_COLOR_BIT_DEPTH
Visual Basic
Public Const SCREEN_MINIMUM_COLOR_BIT_DEPTH As UInteger
Visual C++
public:
literal unsigned int SCREEN_MINIMUM_COLOR_BIT_DEPTH

See Also

MCdicom Structure
MCdicom Members


SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH Field
MCdicom Structure See Also Send Feedback
Screen Minimum Grayscale Bit Depth (0072,010A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH
Visual Basic
Public Const SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH As UInteger
Visual C++
public:
literal unsigned int SCREEN_MINIMUM_GRAYSCALE_BIT_DEPTH

See Also

MCdicom Structure
MCdicom Members


SCREENING_BASELINE_MEASURED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREENING_BASELINE_MEASURED Field
MCdicom Structure See Also Send Feedback
Screening Baseline Measured (0024,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREENING_BASELINE_MEASURED
Visual Basic
Public Const SCREENING_BASELINE_MEASURED As UInteger
Visual C++
public:
literal unsigned int SCREENING_BASELINE_MEASURED

See Also

MCdicom Structure
MCdicom Members


SCREENING_BASELINE_MEASURED_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREENING_BASELINE_MEASURED_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Screening Baseline Measured Sequence (0024,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREENING_BASELINE_MEASURED_SEQUENCE
Visual Basic
Public Const SCREENING_BASELINE_MEASURED_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCREENING_BASELINE_MEASURED_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SCREENING_BASELINE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREENING_BASELINE_TYPE Field
MCdicom Structure See Also Send Feedback
Screening Baseline Type (0024,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREENING_BASELINE_TYPE
Visual Basic
Public Const SCREENING_BASELINE_TYPE As UInteger
Visual C++
public:
literal unsigned int SCREENING_BASELINE_TYPE

See Also

MCdicom Structure
MCdicom Members


SCREENING_BASELINE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREENING_BASELINE_VALUE Field
MCdicom Structure See Also Send Feedback
Screening Baseline Value (0024,0126)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREENING_BASELINE_VALUE
Visual Basic
Public Const SCREENING_BASELINE_VALUE As UInteger
Visual C++
public:
literal unsigned int SCREENING_BASELINE_VALUE

See Also

MCdicom Structure
MCdicom Members


SCREENING_TEST_MODE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SCREENING_TEST_MODE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Screening Test Mode Code Sequence (0024,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SCREENING_TEST_MODE_CODE_SEQUENCE
Visual Basic
Public Const SCREENING_TEST_MODE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SCREENING_TEST_MODE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEAM_LINE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEAM_LINE_INDEX Field
MCdicom Structure See Also Send Feedback
Seam Line Index (0052,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEAM_LINE_INDEX
Visual Basic
Public Const SEAM_LINE_INDEX As UInteger
Visual C++
public:
literal unsigned int SEAM_LINE_INDEX

See Also

MCdicom Structure
MCdicom Members


SEAM_LINE_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEAM_LINE_LOCATION Field
MCdicom Structure See Also Send Feedback
Seam Line Location (0052,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEAM_LINE_LOCATION
Visual Basic
Public Const SEAM_LINE_LOCATION As UInteger
Visual C++
public:
literal unsigned int SEAM_LINE_LOCATION

See Also

MCdicom Structure
MCdicom Members


SECONDARY_CAPTURE_DEVICE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_CAPTURE_DEVICE_ID Field
MCdicom Structure See Also Send Feedback
Secondary Capture Device ID (0018,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_CAPTURE_DEVICE_ID
Visual Basic
Public Const SECONDARY_CAPTURE_DEVICE_ID As UInteger
Visual C++
public:
literal unsigned int SECONDARY_CAPTURE_DEVICE_ID

See Also

MCdicom Structure
MCdicom Members


SECONDARY_CAPTURE_DEVICE_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_CAPTURE_DEVICE_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Secondary Capture Device Manufacturer (0018,1016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_CAPTURE_DEVICE_MANUFACTURER
Visual Basic
Public Const SECONDARY_CAPTURE_DEVICE_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int SECONDARY_CAPTURE_DEVICE_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME Field
MCdicom Structure See Also Send Feedback
Secondary Capture Device Manufacturer's Model Name (0018,1018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME
Visual Basic
Public Const SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME As UInteger
Visual C++
public:
literal unsigned int SECONDARY_CAPTURE_DEVICE_MANUFACTURERS_MODEL_NAME

See Also

MCdicom Structure
MCdicom Members


SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS Field
MCdicom Structure See Also Send Feedback
Secondary Capture Device Software Versions (0018,1019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS
Visual Basic
Public Const SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS As UInteger
Visual C++
public:
literal unsigned int SECONDARY_CAPTURE_DEVICE_SOFTWARE_VERSIONS

See Also

MCdicom Structure
MCdicom Members


SECONDARY_COUNTS_ACCUMULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_COUNTS_ACCUMULATED Field
MCdicom Structure See Also Send Feedback
Secondary Counts Accumulated (0054,1311)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_COUNTS_ACCUMULATED
Visual Basic
Public Const SECONDARY_COUNTS_ACCUMULATED As UInteger
Visual C++
public:
literal unsigned int SECONDARY_COUNTS_ACCUMULATED

See Also

MCdicom Structure
MCdicom Members


SECONDARY_COUNTS_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_COUNTS_TYPE Field
MCdicom Structure See Also Send Feedback
Secondary Counts Type (0054,1220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_COUNTS_TYPE
Visual Basic
Public Const SECONDARY_COUNTS_TYPE As UInteger
Visual C++
public:
literal unsigned int SECONDARY_COUNTS_TYPE

See Also

MCdicom Structure
MCdicom Members


SECONDARY_POSITIONER_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_POSITIONER_INCREMENT Field
MCdicom Structure See Also Send Feedback
Secondary Positioner Increment (0018,9515)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_POSITIONER_INCREMENT
Visual Basic
Public Const SECONDARY_POSITIONER_INCREMENT As UInteger
Visual C++
public:
literal unsigned int SECONDARY_POSITIONER_INCREMENT

See Also

MCdicom Structure
MCdicom Members


SECONDARY_POSITIONER_INCREMENT_SIGN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_POSITIONER_INCREMENT_SIGN Field
MCdicom Structure See Also Send Feedback
Secondary Positioner Increment Sign (0018,9519)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_POSITIONER_INCREMENT_SIGN
Visual Basic
Public Const SECONDARY_POSITIONER_INCREMENT_SIGN As UInteger
Visual C++
public:
literal unsigned int SECONDARY_POSITIONER_INCREMENT_SIGN

See Also

MCdicom Structure
MCdicom Members


SECONDARY_POSITIONER_SCAN_ARC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_POSITIONER_SCAN_ARC Field
MCdicom Structure See Also Send Feedback
Secondary Positioner Scan Arc (0018,9509)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_POSITIONER_SCAN_ARC
Visual Basic
Public Const SECONDARY_POSITIONER_SCAN_ARC As UInteger
Visual C++
public:
literal unsigned int SECONDARY_POSITIONER_SCAN_ARC

See Also

MCdicom Structure
MCdicom Members


SECONDARY_POSITIONER_SCAN_START_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SECONDARY_POSITIONER_SCAN_START_ANGLE Field
MCdicom Structure See Also Send Feedback
Secondary Positioner Scan Start Angle (0018,9511)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SECONDARY_POSITIONER_SCAN_START_ANGLE
Visual Basic
Public Const SECONDARY_POSITIONER_SCAN_START_ANGLE As UInteger
Visual C++
public:
literal unsigned int SECONDARY_POSITIONER_SCAN_START_ANGLE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_ALGORITHM_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_ALGORITHM_NAME Field
MCdicom Structure See Also Send Feedback
Segment Algorithm Name (0062,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_ALGORITHM_NAME
Visual Basic
Public Const SEGMENT_ALGORITHM_NAME As UInteger
Visual C++
public:
literal unsigned int SEGMENT_ALGORITHM_NAME

See Also

MCdicom Structure
MCdicom Members


SEGMENT_ALGORITHM_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_ALGORITHM_TYPE Field
MCdicom Structure See Also Send Feedback
Segment Algorithm Type (0062,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_ALGORITHM_TYPE
Visual Basic
Public Const SEGMENT_ALGORITHM_TYPE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_ALGORITHM_TYPE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Annotation Category Code Sequence (3010,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_ANNOTATION_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Annotation Type Code Sequence (3010,002C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_ANNOTATION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Annotation Type Modifier Code Sequence (3010,002F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_ANNOTATION_TYPE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_CHARACTERISTICS_PRECEDENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_CHARACTERISTICS_PRECEDENCE Field
MCdicom Structure See Also Send Feedback
Segment Characteristics Precedence (3010,0029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_CHARACTERISTICS_PRECEDENCE
Visual Basic
Public Const SEGMENT_CHARACTERISTICS_PRECEDENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_CHARACTERISTICS_PRECEDENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Characteristics Sequence (3010,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const SEGMENT_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Segment Description (0062,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_DESCRIPTION
Visual Basic
Public Const SEGMENT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SEGMENT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SEGMENT_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Identification Sequence (0062,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SEGMENT_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_LABEL Field
MCdicom Structure See Also Send Feedback
Segment Label (0062,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_LABEL
Visual Basic
Public Const SEGMENT_LABEL As UInteger
Visual C++
public:
literal unsigned int SEGMENT_LABEL

See Also

MCdicom Structure
MCdicom Members


SEGMENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Segment Number (0062,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_NUMBER
Visual Basic
Public Const SEGMENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int SEGMENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


SEGMENT_REFERENCE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_REFERENCE_INDEX Field
MCdicom Structure See Also Send Feedback
Segment Reference Index (3010,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_REFERENCE_INDEX
Visual Basic
Public Const SEGMENT_REFERENCE_INDEX As UInteger
Visual C++
public:
literal unsigned int SEGMENT_REFERENCE_INDEX

See Also

MCdicom Structure
MCdicom Members


SEGMENT_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Reference Sequence (3010,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_REFERENCE_SEQUENCE
Visual Basic
Public Const SEGMENT_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Sequence (0062,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_SEQUENCE
Visual Basic
Public Const SEGMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Surface Generation Algorithm Identification Sequence (0066,002D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_SURFACE_GENERATION_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segment Surface Source Instance Sequence (0066,002E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE
Visual Basic
Public Const SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENT_SURFACE_SOURCE_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segmentation Algorithm Identification Sequence (0062,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENTATION_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTATION_CREATION_TEMPLATE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTATION_CREATION_TEMPLATE_LABEL Field
MCdicom Structure See Also Send Feedback
Segmentation Creation Template Label (3010,001E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTATION_CREATION_TEMPLATE_LABEL
Visual Basic
Public Const SEGMENTATION_CREATION_TEMPLATE_LABEL As UInteger
Visual C++
public:
literal unsigned int SEGMENTATION_CREATION_TEMPLATE_LABEL

See Also

MCdicom Structure
MCdicom Members


SEGMENTATION_FRACTIONAL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTATION_FRACTIONAL_TYPE Field
MCdicom Structure See Also Send Feedback
Segmentation Fractional Type (0062,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTATION_FRACTIONAL_TYPE
Visual Basic
Public Const SEGMENTATION_FRACTIONAL_TYPE As UInteger
Visual C++
public:
literal unsigned int SEGMENTATION_FRACTIONAL_TYPE

See Also

MCdicom Structure
MCdicom Members


SEGMENTATION_TEMPLATE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTATION_TEMPLATE_UID Field
MCdicom Structure See Also Send Feedback
Segmentation Template UID (3010,001F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTATION_TEMPLATE_UID
Visual Basic
Public Const SEGMENTATION_TEMPLATE_UID As UInteger
Visual C++
public:
literal unsigned int SEGMENTATION_TEMPLATE_UID

See Also

MCdicom Structure
MCdicom Members


SEGMENTATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTATION_TYPE Field
MCdicom Structure See Also Send Feedback
Segmentation Type (0062,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTATION_TYPE
Visual Basic
Public Const SEGMENTATION_TYPE As UInteger
Visual C++
public:
literal unsigned int SEGMENTATION_TYPE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Segmented Alpha Palette Color Lookup Table Data (0028,1224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_ALPHA_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE Field
MCdicom Structure See Also Send Feedback
Alias for tag SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE
Visual Basic
Public Const SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Segmented Blue Palette Color Lookup Table Data (0028,1223)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_BLUE_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE Field
MCdicom Structure See Also Send Feedback
Alias for tag SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE
Visual Basic
Public Const SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Segmented Green Palette Color Lookup Table Data (0028,1222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_GREEN_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_K_SPACE_TRAVERSAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_K_SPACE_TRAVERSAL Field
MCdicom Structure See Also Send Feedback
Segmented k-Space Traversal (0018,9033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_K_SPACE_TRAVERSAL
Visual Basic
Public Const SEGMENTED_K_SPACE_TRAVERSAL As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_K_SPACE_TRAVERSAL

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segmented Property Category Code Sequence (0062,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_PROPERTY_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segmented Property Type Code Sequence (0062,000F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE
Visual Basic
Public Const SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_PROPERTY_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segmented Property Type Modifier Code Sequence (0062,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_PROPERTY_TYPE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE Field
MCdicom Structure See Also Send Feedback
Alias for tag SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA (0028,1221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE
Visual Basic
Public Const SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Segmented Red Palette Color Lookup Table Data (0028,1221)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA
Visual Basic
Public Const SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_RED_PALETTE_COLOR_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Segmented RT Accessory Device Sequence (3010,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE
Visual Basic
Public Const SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SEGMENTED_RT_ACCESSORY_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SEGMENTS_OVERLAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEGMENTS_OVERLAP Field
MCdicom Structure See Also Send Feedback
Segments Overlap (0062,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEGMENTS_OVERLAP
Visual Basic
Public Const SEGMENTS_OVERLAP As UInteger
Visual C++
public:
literal unsigned int SEGMENTS_OVERLAP

See Also

MCdicom Structure
MCdicom Members


SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Selected Frame Functional Groups Sequence (3002,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE
Visual Basic
Public Const SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SELECTED_FRAME_FUNCTIONAL_GROUPS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SELECTED_FRAME_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTED_FRAME_NUMBER Field
MCdicom Structure See Also Send Feedback
Selected Frame Number (3002,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTED_FRAME_NUMBER
Visual Basic
Public Const SELECTED_FRAME_NUMBER As UInteger
Visual C++
public:
literal unsigned int SELECTED_FRAME_NUMBER

See Also

MCdicom Structure
MCdicom Members


SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Selected Segmental Ophthalmic Axial Length Sequence (0022,1257)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE
Visual Basic
Public Const SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SELECTED_SEGMENTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Selected Total Ophthalmic Axial Length Sequence (0022,1260)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE
Visual Basic
Public Const SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SELECTED_TOTAL_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_AE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_AE_VALUE Field
MCdicom Structure See Also Send Feedback
Selector AE Value (0072,005E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_AE_VALUE
Visual Basic
Public Const SELECTOR_AE_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_AE_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_AS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_AS_VALUE Field
MCdicom Structure See Also Send Feedback
Selector AS Value (0072,005F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_AS_VALUE
Visual Basic
Public Const SELECTOR_AS_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_AS_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_AT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_AT_VALUE Field
MCdicom Structure See Also Send Feedback
Selector AT Value (0072,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_AT_VALUE
Visual Basic
Public Const SELECTOR_AT_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_AT_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ATTRIBUTE Field
MCdicom Structure See Also Send Feedback
Selector Attribute (0072,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ATTRIBUTE
Visual Basic
Public Const SELECTOR_ATTRIBUTE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ATTRIBUTE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ATTRIBUTE_KEYWORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ATTRIBUTE_KEYWORD Field
MCdicom Structure See Also Send Feedback
Selector Attribute Keyword (0082,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ATTRIBUTE_KEYWORD
Visual Basic
Public Const SELECTOR_ATTRIBUTE_KEYWORD As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ATTRIBUTE_KEYWORD

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ATTRIBUTE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ATTRIBUTE_NAME Field
MCdicom Structure See Also Send Feedback
Selector Attribute Name (0082,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ATTRIBUTE_NAME
Visual Basic
Public Const SELECTOR_ATTRIBUTE_NAME As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ATTRIBUTE_NAME

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ATTRIBUTE_PRIVATE_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ATTRIBUTE_PRIVATE_CREATOR Field
MCdicom Structure See Also Send Feedback
Selector Attribute Private Creator (0072,0056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ATTRIBUTE_PRIVATE_CREATOR
Visual Basic
Public Const SELECTOR_ATTRIBUTE_PRIVATE_CREATOR As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ATTRIBUTE_PRIVATE_CREATOR

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ATTRIBUTE_VR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ATTRIBUTE_VR Field
MCdicom Structure See Also Send Feedback
Selector Attribute VR (0072,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ATTRIBUTE_VR
Visual Basic
Public Const SELECTOR_ATTRIBUTE_VR As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ATTRIBUTE_VR

See Also

MCdicom Structure
MCdicom Members


SELECTOR_CODE_SEQUENCE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_CODE_SEQUENCE_VALUE Field
MCdicom Structure See Also Send Feedback
Selector Code Sequence Value (0072,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_CODE_SEQUENCE_VALUE
Visual Basic
Public Const SELECTOR_CODE_SEQUENCE_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_CODE_SEQUENCE_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_CS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_CS_VALUE Field
MCdicom Structure See Also Send Feedback
Selector CS Value (0072,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_CS_VALUE
Visual Basic
Public Const SELECTOR_CS_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_CS_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_DA_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_DA_VALUE Field
MCdicom Structure See Also Send Feedback
Selector DA Value (0072,0061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_DA_VALUE
Visual Basic
Public Const SELECTOR_DA_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_DA_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_DS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_DS_VALUE Field
MCdicom Structure See Also Send Feedback
Selector DS Value (0072,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_DS_VALUE
Visual Basic
Public Const SELECTOR_DS_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_DS_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_DT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_DT_VALUE Field
MCdicom Structure See Also Send Feedback
Selector DT Value (0072,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_DT_VALUE
Visual Basic
Public Const SELECTOR_DT_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_DT_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_FD_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_FD_VALUE Field
MCdicom Structure See Also Send Feedback
Selector FD Value (0072,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_FD_VALUE
Visual Basic
Public Const SELECTOR_FD_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_FD_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_FL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_FL_VALUE Field
MCdicom Structure See Also Send Feedback
Selector FL Value (0072,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_FL_VALUE
Visual Basic
Public Const SELECTOR_FL_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_FL_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_IS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_IS_VALUE Field
MCdicom Structure See Also Send Feedback
Selector IS Value (0072,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_IS_VALUE
Visual Basic
Public Const SELECTOR_IS_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_IS_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_LO_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_LO_VALUE Field
MCdicom Structure See Also Send Feedback
Selector LO Value (0072,0066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_LO_VALUE
Visual Basic
Public Const SELECTOR_LO_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_LO_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_LT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_LT_VALUE Field
MCdicom Structure See Also Send Feedback
Selector LT Value (0072,0068)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_LT_VALUE
Visual Basic
Public Const SELECTOR_LT_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_LT_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OB_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OB Value (0072,0065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OB_VALUE
Visual Basic
Public Const SELECTOR_OB_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OB_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OD_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OD_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OD Value (0072,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OD_VALUE
Visual Basic
Public Const SELECTOR_OD_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OD_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OF_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OF_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OF Value (0072,0067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OF_VALUE
Visual Basic
Public Const SELECTOR_OF_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OF_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OL_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OL Value (0072,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OL_VALUE
Visual Basic
Public Const SELECTOR_OL_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OL_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OV_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OV_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OV Value (0072,0081)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OV_VALUE
Visual Basic
Public Const SELECTOR_OV_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OV_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_OW_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_OW_VALUE Field
MCdicom Structure See Also Send Feedback
Selector OW Value (0072,0069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_OW_VALUE
Visual Basic
Public Const SELECTOR_OW_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_OW_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_PN_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_PN_VALUE Field
MCdicom Structure See Also Send Feedback
Selector PN Value (0072,006A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_PN_VALUE
Visual Basic
Public Const SELECTOR_PN_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_PN_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SEQUENCE_POINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SEQUENCE_POINTER Field
MCdicom Structure See Also Send Feedback
Selector Sequence Pointer (0072,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SEQUENCE_POINTER
Visual Basic
Public Const SELECTOR_SEQUENCE_POINTER As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SEQUENCE_POINTER

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SEQUENCE_POINTER_ITEMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SEQUENCE_POINTER_ITEMS Field
MCdicom Structure See Also Send Feedback
Selector Sequence Pointer Items (0074,1057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SEQUENCE_POINTER_ITEMS
Visual Basic
Public Const SELECTOR_SEQUENCE_POINTER_ITEMS As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SEQUENCE_POINTER_ITEMS

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR Field
MCdicom Structure See Also Send Feedback
Selector Sequence Pointer Private Creator (0072,0054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR
Visual Basic
Public Const SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SEQUENCE_POINTER_PRIVATE_CREATOR

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SH_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SH_VALUE Field
MCdicom Structure See Also Send Feedback
Selector SH Value (0072,006C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SH_VALUE
Visual Basic
Public Const SELECTOR_SH_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SH_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SL_VALUE Field
MCdicom Structure See Also Send Feedback
Selector SL Value (0072,007C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SL_VALUE
Visual Basic
Public Const SELECTOR_SL_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SL_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SS_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SS_VALUE Field
MCdicom Structure See Also Send Feedback
Selector SS Value (0072,007E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SS_VALUE
Visual Basic
Public Const SELECTOR_SS_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SS_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_ST_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_ST_VALUE Field
MCdicom Structure See Also Send Feedback
Selector ST Value (0072,006E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_ST_VALUE
Visual Basic
Public Const SELECTOR_ST_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_ST_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_SV_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_SV_VALUE Field
MCdicom Structure See Also Send Feedback
Selector SV Value (0072,0082)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_SV_VALUE
Visual Basic
Public Const SELECTOR_SV_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_SV_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_TM_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_TM_VALUE Field
MCdicom Structure See Also Send Feedback
Selector TM Value (0072,006B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_TM_VALUE
Visual Basic
Public Const SELECTOR_TM_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_TM_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UC_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UC_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UC Value (0072,006F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UC_VALUE
Visual Basic
Public Const SELECTOR_UC_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UC_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UI_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UI_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UI Value (0072,007F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UI_VALUE
Visual Basic
Public Const SELECTOR_UI_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UI_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UL_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UL Value (0072,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UL_VALUE
Visual Basic
Public Const SELECTOR_UL_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UL_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UN_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UN_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UN Value (0072,006D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UN_VALUE
Visual Basic
Public Const SELECTOR_UN_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UN_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UR_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UR_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UR Value (0072,0071)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UR_VALUE
Visual Basic
Public Const SELECTOR_UR_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UR_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_US_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_US_VALUE Field
MCdicom Structure See Also Send Feedback
Selector US Value (0072,007A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_US_VALUE
Visual Basic
Public Const SELECTOR_US_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_US_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UT_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UT Value (0072,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UT_VALUE
Visual Basic
Public Const SELECTOR_UT_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UT_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_UV_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_UV_VALUE Field
MCdicom Structure See Also Send Feedback
Selector UV Value (0072,0083)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_UV_VALUE
Visual Basic
Public Const SELECTOR_UV_VALUE As UInteger
Visual C++
public:
literal unsigned int SELECTOR_UV_VALUE

See Also

MCdicom Structure
MCdicom Members


SELECTOR_VALUE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELECTOR_VALUE_NUMBER Field
MCdicom Structure See Also Send Feedback
Selector Value Number (0072,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELECTOR_VALUE_NUMBER
Visual Basic
Public Const SELECTOR_VALUE_NUMBER As UInteger
Visual C++
public:
literal unsigned int SELECTOR_VALUE_NUMBER

See Also

MCdicom Structure
MCdicom Members


SELF_TIMER_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SELF_TIMER_MODE Field
MCdicom Structure See Also Send Feedback
Self Timer Mode (0016,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SELF_TIMER_MODE
Visual Basic
Public Const SELF_TIMER_MODE As UInteger
Visual C++
public:
literal unsigned int SELF_TIMER_MODE

See Also

MCdicom Structure
MCdicom Members


SENDING_APPLICATION_ENTITY_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENDING_APPLICATION_ENTITY_TITLE Field
MCdicom Structure See Also Send Feedback
Sending Application Entity Title (0002,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENDING_APPLICATION_ENTITY_TITLE
Visual Basic
Public Const SENDING_APPLICATION_ENTITY_TITLE As UInteger
Visual C++
public:
literal unsigned int SENDING_APPLICATION_ENTITY_TITLE

See Also

MCdicom Structure
MCdicom Members


SENDING_PRESENTATION_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENDING_PRESENTATION_ADDRESS Field
MCdicom Structure See Also Send Feedback
Sending Presentation Address (0002,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENDING_PRESENTATION_ADDRESS
Visual Basic
Public Const SENDING_PRESENTATION_ADDRESS As UInteger
Visual C++
public:
literal unsigned int SENDING_PRESENTATION_ADDRESS

See Also

MCdicom Structure
MCdicom Members


SENSING_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSING_METHOD Field
MCdicom Structure See Also Send Feedback
Sensing Method (0016,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSING_METHOD
Visual Basic
Public Const SENSING_METHOD As UInteger
Visual C++
public:
literal unsigned int SENSING_METHOD

See Also

MCdicom Structure
MCdicom Members


SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Sensitivity (0018,6000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSITIVITY
Visual Basic
Public Const SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


SENSITIVITY_CALIBRATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSITIVITY_CALIBRATED Field
MCdicom Structure See Also Send Feedback
Sensitivity Calibrated (0018,9767)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSITIVITY_CALIBRATED
Visual Basic
Public Const SENSITIVITY_CALIBRATED As UInteger
Visual C++
public:
literal unsigned int SENSITIVITY_CALIBRATED

See Also

MCdicom Structure
MCdicom Members


SENSITIVITY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSITIVITY_TYPE Field
MCdicom Structure See Also Send Feedback
Sensitivity Type (0016,001A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSITIVITY_TYPE
Visual Basic
Public Const SENSITIVITY_TYPE As UInteger
Visual C++
public:
literal unsigned int SENSITIVITY_TYPE

See Also

MCdicom Structure
MCdicom Members


SENSITIVITY_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSITIVITY_VALUE Field
MCdicom Structure See Also Send Feedback
Sensitivity Value (0024,0094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSITIVITY_VALUE
Visual Basic
Public Const SENSITIVITY_VALUE As UInteger
Visual C++
public:
literal unsigned int SENSITIVITY_VALUE

See Also

MCdicom Structure
MCdicom Members


SENSOR_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSOR_NAME Field
MCdicom Structure See Also Send Feedback
Sensor Name (0014,3022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSOR_NAME
Visual Basic
Public Const SENSOR_NAME As UInteger
Visual C++
public:
literal unsigned int SENSOR_NAME

See Also

MCdicom Structure
MCdicom Members


SENSOR_TEMPERATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SENSOR_TEMPERATURE Field
MCdicom Structure See Also Send Feedback
Sensor Temperature (0014,3028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SENSOR_TEMPERATURE
Visual Basic
Public Const SENSOR_TEMPERATURE As UInteger
Visual C++
public:
literal unsigned int SENSOR_TEMPERATURE

See Also

MCdicom Structure
MCdicom Members


SEQUENCE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEQUENCE_NAME Field
MCdicom Structure See Also Send Feedback
Sequence Name (0018,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEQUENCE_NAME
Visual Basic
Public Const SEQUENCE_NAME As UInteger
Visual C++
public:
literal unsigned int SEQUENCE_NAME

See Also

MCdicom Structure
MCdicom Members


SEQUENCE_OF_ULTRASOUND_REGIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEQUENCE_OF_ULTRASOUND_REGIONS Field
MCdicom Structure See Also Send Feedback
Sequence of Ultrasound Regions (0018,6011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEQUENCE_OF_ULTRASOUND_REGIONS
Visual Basic
Public Const SEQUENCE_OF_ULTRASOUND_REGIONS As UInteger
Visual C++
public:
literal unsigned int SEQUENCE_OF_ULTRASOUND_REGIONS

See Also

MCdicom Structure
MCdicom Members


SEQUENCE_VARIANT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEQUENCE_VARIANT Field
MCdicom Structure See Also Send Feedback
Sequence Variant (0018,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEQUENCE_VARIANT
Visual Basic
Public Const SEQUENCE_VARIANT As UInteger
Visual C++
public:
literal unsigned int SEQUENCE_VARIANT

See Also

MCdicom Structure
MCdicom Members


SEQUENCING_INDICATOR_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SEQUENCING_INDICATOR_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Sequencing Indicator (Trial) RETIRED (0040,A060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SEQUENCING_INDICATOR_TRIAL_RETIRED
Visual Basic
Public Const SEQUENCING_INDICATOR_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int SEQUENCING_INDICATOR_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


SERIES_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_DATE Field
MCdicom Structure See Also Send Feedback
Series Date (0008,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_DATE
Visual Basic
Public Const SERIES_DATE As UInteger
Visual C++
public:
literal unsigned int SERIES_DATE

See Also

MCdicom Structure
MCdicom Members


SERIES_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Series Description (0008,103E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_DESCRIPTION
Visual Basic
Public Const SERIES_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SERIES_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SERIES_DESCRIPTION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_DESCRIPTION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Series Description Code Sequence (0008,103F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_DESCRIPTION_CODE_SEQUENCE
Visual Basic
Public Const SERIES_DESCRIPTION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SERIES_DESCRIPTION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SERIES_IN_STUDY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_IN_STUDY_RETIRED Field
MCdicom Structure See Also Send Feedback
Series in Study RETIRED (0020,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_IN_STUDY_RETIRED
Visual Basic
Public Const SERIES_IN_STUDY_RETIRED As UInteger
Visual C++
public:
literal unsigned int SERIES_IN_STUDY_RETIRED

See Also

MCdicom Structure
MCdicom Members


SERIES_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Series Instance UID (0020,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_INSTANCE_UID
Visual Basic
Public Const SERIES_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int SERIES_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


SERIES_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_NUMBER Field
MCdicom Structure See Also Send Feedback
Series Number (0020,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_NUMBER
Visual Basic
Public Const SERIES_NUMBER As UInteger
Visual C++
public:
literal unsigned int SERIES_NUMBER

See Also

MCdicom Structure
MCdicom Members


SERIES_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_TIME Field
MCdicom Structure See Also Send Feedback
Series Time (0008,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_TIME
Visual Basic
Public Const SERIES_TIME As UInteger
Visual C++
public:
literal unsigned int SERIES_TIME

See Also

MCdicom Structure
MCdicom Members


SERIES_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERIES_TYPE Field
MCdicom Structure See Also Send Feedback
Series Type (0054,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERIES_TYPE
Visual Basic
Public Const SERIES_TYPE As UInteger
Visual C++
public:
literal unsigned int SERIES_TYPE

See Also

MCdicom Structure
MCdicom Members


SERVICE_EPISODE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERVICE_EPISODE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Service Episode Description (0038,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERVICE_EPISODE_DESCRIPTION
Visual Basic
Public Const SERVICE_EPISODE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SERVICE_EPISODE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SERVICE_EPISODE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SERVICE_EPISODE_ID Field
MCdicom Structure See Also Send Feedback
Service Episode ID (0038,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SERVICE_EPISODE_ID
Visual Basic
Public Const SERVICE_EPISODE_ID As UInteger
Visual C++
public:
literal unsigned int SERVICE_EPISODE_ID

See Also

MCdicom Structure
MCdicom Members


SETTLING_PHASE_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETTLING_PHASE_FRAME Field
MCdicom Structure See Also Send Feedback
Settling Phase Frame (0018,9624)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETTLING_PHASE_FRAME
Visual Basic
Public Const SETTLING_PHASE_FRAME As UInteger
Visual C++
public:
literal unsigned int SETTLING_PHASE_FRAME

See Also

MCdicom Structure
MCdicom Members


SETUP_DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Setup Device Description (300A,01BA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_DEVICE_DESCRIPTION
Visual Basic
Public Const SETUP_DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SETUP_DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SETUP_DEVICE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_DEVICE_LABEL Field
MCdicom Structure See Also Send Feedback
Setup Device Label (300A,01B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_DEVICE_LABEL
Visual Basic
Public Const SETUP_DEVICE_LABEL As UInteger
Visual C++
public:
literal unsigned int SETUP_DEVICE_LABEL

See Also

MCdicom Structure
MCdicom Members


SETUP_DEVICE_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_DEVICE_PARAMETER Field
MCdicom Structure See Also Send Feedback
Setup Device Parameter (300A,01BC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_DEVICE_PARAMETER
Visual Basic
Public Const SETUP_DEVICE_PARAMETER As UInteger
Visual C++
public:
literal unsigned int SETUP_DEVICE_PARAMETER

See Also

MCdicom Structure
MCdicom Members


SETUP_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Setup Device Sequence (300A,01B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_DEVICE_SEQUENCE
Visual Basic
Public Const SETUP_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SETUP_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SETUP_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Setup Device Type (300A,01B6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_DEVICE_TYPE
Visual Basic
Public Const SETUP_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int SETUP_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


SETUP_IMAGE_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_IMAGE_COMMENT Field
MCdicom Structure See Also Send Feedback
Setup Image Comment (300A,0402)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_IMAGE_COMMENT
Visual Basic
Public Const SETUP_IMAGE_COMMENT As UInteger
Visual C++
public:
literal unsigned int SETUP_IMAGE_COMMENT

See Also

MCdicom Structure
MCdicom Members


SETUP_REFERENCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_REFERENCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Setup Reference Description (300A,01D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_REFERENCE_DESCRIPTION
Visual Basic
Public Const SETUP_REFERENCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SETUP_REFERENCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SETUP_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Setup Technique (300A,01B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_TECHNIQUE
Visual Basic
Public Const SETUP_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int SETUP_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


SETUP_TECHNIQUE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SETUP_TECHNIQUE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Setup Technique Description (300A,01B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SETUP_TECHNIQUE_DESCRIPTION
Visual Basic
Public Const SETUP_TECHNIQUE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SETUP_TECHNIQUE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SHADING_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADING_STYLE Field
MCdicom Structure See Also Send Feedback
Shading Style (0070,1701)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADING_STYLE
Visual Basic
Public Const SHADING_STYLE As UInteger
Visual C++
public:
literal unsigned int SHADING_STYLE

See Also

MCdicom Structure
MCdicom Members


SHADOW_COLOR_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADOW_COLOR_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Shadow Color CIELab Value (0070,0247)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADOW_COLOR_CIELAB_VALUE
Visual Basic
Public Const SHADOW_COLOR_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int SHADOW_COLOR_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


SHADOW_OFFSET_X Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADOW_OFFSET_X Field
MCdicom Structure See Also Send Feedback
Shadow Offset X (0070,0245)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADOW_OFFSET_X
Visual Basic
Public Const SHADOW_OFFSET_X As UInteger
Visual C++
public:
literal unsigned int SHADOW_OFFSET_X

See Also

MCdicom Structure
MCdicom Members


SHADOW_OFFSET_Y Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADOW_OFFSET_Y Field
MCdicom Structure See Also Send Feedback
Shadow Offset Y (0070,0246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADOW_OFFSET_Y
Visual Basic
Public Const SHADOW_OFFSET_Y As UInteger
Visual C++
public:
literal unsigned int SHADOW_OFFSET_Y

See Also

MCdicom Structure
MCdicom Members


SHADOW_OPACITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADOW_OPACITY Field
MCdicom Structure See Also Send Feedback
Shadow Opacity (0070,0258)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADOW_OPACITY
Visual Basic
Public Const SHADOW_OPACITY As UInteger
Visual C++
public:
literal unsigned int SHADOW_OPACITY

See Also

MCdicom Structure
MCdicom Members


SHADOW_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHADOW_STYLE Field
MCdicom Structure See Also Send Feedback
Shadow Style (0070,0244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHADOW_STYLE
Visual Basic
Public Const SHADOW_STYLE As UInteger
Visual C++
public:
literal unsigned int SHADOW_STYLE

See Also

MCdicom Structure
MCdicom Members


SHAPE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHAPE_TYPE Field
MCdicom Structure See Also Send Feedback
Shape Type (0070,0306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHAPE_TYPE
Visual Basic
Public Const SHAPE_TYPE As UInteger
Visual C++
public:
literal unsigned int SHAPE_TYPE

See Also

MCdicom Structure
MCdicom Members


SHARED_FUNCTIONAL_GROUPS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHARED_FUNCTIONAL_GROUPS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Shared Functional Groups Sequence (5200,9229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHARED_FUNCTIONAL_GROUPS_SEQUENCE
Visual Basic
Public Const SHARED_FUNCTIONAL_GROUPS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SHARED_FUNCTIONAL_GROUPS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SHARPNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHARPNESS Field
MCdicom Structure See Also Send Feedback
Sharpness (0016,004A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHARPNESS
Visual Basic
Public Const SHARPNESS As UInteger
Visual C++
public:
literal unsigned int SHARPNESS

See Also

MCdicom Structure
MCdicom Members


SHIELDING_DEVICE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHIELDING_DEVICE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Shielding Device Description (300A,01A6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHIELDING_DEVICE_DESCRIPTION
Visual Basic
Public Const SHIELDING_DEVICE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SHIELDING_DEVICE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SHIELDING_DEVICE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHIELDING_DEVICE_LABEL Field
MCdicom Structure See Also Send Feedback
Shielding Device Label (300A,01A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHIELDING_DEVICE_LABEL
Visual Basic
Public Const SHIELDING_DEVICE_LABEL As UInteger
Visual C++
public:
literal unsigned int SHIELDING_DEVICE_LABEL

See Also

MCdicom Structure
MCdicom Members


SHIELDING_DEVICE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHIELDING_DEVICE_POSITION Field
MCdicom Structure See Also Send Feedback
Shielding Device Position (300A,01A8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHIELDING_DEVICE_POSITION
Visual Basic
Public Const SHIELDING_DEVICE_POSITION As UInteger
Visual C++
public:
literal unsigned int SHIELDING_DEVICE_POSITION

See Also

MCdicom Structure
MCdicom Members


SHIELDING_DEVICE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHIELDING_DEVICE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Shielding Device Sequence (300A,01A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHIELDING_DEVICE_SEQUENCE
Visual Basic
Public Const SHIELDING_DEVICE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SHIELDING_DEVICE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SHIELDING_DEVICE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHIELDING_DEVICE_TYPE Field
MCdicom Structure See Also Send Feedback
Shielding Device Type (300A,01A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHIELDING_DEVICE_TYPE
Visual Basic
Public Const SHIELDING_DEVICE_TYPE As UInteger
Visual C++
public:
literal unsigned int SHIELDING_DEVICE_TYPE

See Also

MCdicom Structure
MCdicom Members


SHININESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHININESS Field
MCdicom Structure See Also Send Feedback
Shininess (0070,1706)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHININESS
Visual Basic
Public Const SHININESS As UInteger
Visual C++
public:
literal unsigned int SHININESS

See Also

MCdicom Structure
MCdicom Members


SHORT_TERM_FLUCTUATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHORT_TERM_FLUCTUATION Field
MCdicom Structure See Also Send Feedback
Short Term Fluctuation (0024,0075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHORT_TERM_FLUCTUATION
Visual Basic
Public Const SHORT_TERM_FLUCTUATION As UInteger
Visual C++
public:
literal unsigned int SHORT_TERM_FLUCTUATION

See Also

MCdicom Structure
MCdicom Members


SHORT_TERM_FLUCTUATION_CALCULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHORT_TERM_FLUCTUATION_CALCULATED Field
MCdicom Structure See Also Send Feedback
Short Term Fluctuation Calculated (0024,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHORT_TERM_FLUCTUATION_CALCULATED
Visual Basic
Public Const SHORT_TERM_FLUCTUATION_CALCULATED As UInteger
Visual C++
public:
literal unsigned int SHORT_TERM_FLUCTUATION_CALCULATED

See Also

MCdicom Structure
MCdicom Members


SHORT_TERM_FLUCTUATION_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHORT_TERM_FLUCTUATION_PROBABILITY Field
MCdicom Structure See Also Send Feedback
Short Term Fluctuation Probability (0024,0077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHORT_TERM_FLUCTUATION_PROBABILITY
Visual Basic
Public Const SHORT_TERM_FLUCTUATION_PROBABILITY As UInteger
Visual C++
public:
literal unsigned int SHORT_TERM_FLUCTUATION_PROBABILITY

See Also

MCdicom Structure
MCdicom Members


SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED Field
MCdicom Structure See Also Send Feedback
Short Term Fluctuation Probability Calculated (0024,0076)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED
Visual Basic
Public Const SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED As UInteger
Visual C++
public:
literal unsigned int SHORT_TERM_FLUCTUATION_PROBABILITY_CALCULATED

See Also

MCdicom Structure
MCdicom Members


SHOT_DURATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOT_DURATION_TIME Field
MCdicom Structure See Also Send Feedback
Shot Duration Time (0080,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOT_DURATION_TIME
Visual Basic
Public Const SHOT_DURATION_TIME As UInteger
Visual C++
public:
literal unsigned int SHOT_DURATION_TIME

See Also

MCdicom Structure
MCdicom Members


SHOT_OFFSET_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOT_OFFSET_TIME Field
MCdicom Structure See Also Send Feedback
Shot Offset Time (0080,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOT_OFFSET_TIME
Visual Basic
Public Const SHOT_OFFSET_TIME As UInteger
Visual C++
public:
literal unsigned int SHOT_OFFSET_TIME

See Also

MCdicom Structure
MCdicom Members


SHOW_ACQUISITION_TECHNIQUES_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_ACQUISITION_TECHNIQUES_FLAG Field
MCdicom Structure See Also Send Feedback
Show Acquisition Techniques Flag (0072,0716)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_ACQUISITION_TECHNIQUES_FLAG
Visual Basic
Public Const SHOW_ACQUISITION_TECHNIQUES_FLAG As UInteger
Visual C++
public:
literal unsigned int SHOW_ACQUISITION_TECHNIQUES_FLAG

See Also

MCdicom Structure
MCdicom Members


SHOW_GRAPHIC_ANNOTATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_GRAPHIC_ANNOTATION_FLAG Field
MCdicom Structure See Also Send Feedback
Show Graphic Annotation Flag (0072,0712)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_GRAPHIC_ANNOTATION_FLAG
Visual Basic
Public Const SHOW_GRAPHIC_ANNOTATION_FLAG As UInteger
Visual C++
public:
literal unsigned int SHOW_GRAPHIC_ANNOTATION_FLAG

See Also

MCdicom Structure
MCdicom Members


SHOW_GRAYSCALE_INVERTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_GRAYSCALE_INVERTED Field
MCdicom Structure See Also Send Feedback
Show Grayscale Inverted (0072,0706)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_GRAYSCALE_INVERTED
Visual Basic
Public Const SHOW_GRAYSCALE_INVERTED As UInteger
Visual C++
public:
literal unsigned int SHOW_GRAYSCALE_INVERTED

See Also

MCdicom Structure
MCdicom Members


SHOW_IMAGE_TRUE_SIZE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_IMAGE_TRUE_SIZE_FLAG Field
MCdicom Structure See Also Send Feedback
Show Image True Size Flag (0072,0710)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_IMAGE_TRUE_SIZE_FLAG
Visual Basic
Public Const SHOW_IMAGE_TRUE_SIZE_FLAG As UInteger
Visual C++
public:
literal unsigned int SHOW_IMAGE_TRUE_SIZE_FLAG

See Also

MCdicom Structure
MCdicom Members


SHOW_PATIENT_DEMOGRAPHICS_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_PATIENT_DEMOGRAPHICS_FLAG Field
MCdicom Structure See Also Send Feedback
Show Patient Demographics Flag (0072,0714)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_PATIENT_DEMOGRAPHICS_FLAG
Visual Basic
Public Const SHOW_PATIENT_DEMOGRAPHICS_FLAG As UInteger
Visual C++
public:
literal unsigned int SHOW_PATIENT_DEMOGRAPHICS_FLAG

See Also

MCdicom Structure
MCdicom Members


SHOW_TICK_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHOW_TICK_LABEL Field
MCdicom Structure See Also Send Feedback
Show Tick Label (0070,0278)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHOW_TICK_LABEL
Visual Basic
Public Const SHOW_TICK_LABEL As UInteger
Visual C++
public:
literal unsigned int SHOW_TICK_LABEL

See Also

MCdicom Structure
MCdicom Members


SHUTTER_LEFT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_LEFT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Shutter Left Vertical Edge (0018,1602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_LEFT_VERTICAL_EDGE
Visual Basic
Public Const SHUTTER_LEFT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_LEFT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_LOWER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_LOWER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Shutter Lower Horizontal Edge (0018,1608)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_LOWER_HORIZONTAL_EDGE
Visual Basic
Public Const SHUTTER_LOWER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_LOWER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_OVERLAY_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_OVERLAY_GROUP Field
MCdicom Structure See Also Send Feedback
Shutter Overlay Group (0018,1623)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_OVERLAY_GROUP
Visual Basic
Public Const SHUTTER_OVERLAY_GROUP As UInteger
Visual C++
public:
literal unsigned int SHUTTER_OVERLAY_GROUP

See Also

MCdicom Structure
MCdicom Members


SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Shutter Presentation Color CIELab Value (0018,1624)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE
Visual Basic
Public Const SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_PRESENTATION_COLOR_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_PRESENTATION_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_PRESENTATION_VALUE Field
MCdicom Structure See Also Send Feedback
Shutter Presentation Value (0018,1622)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_PRESENTATION_VALUE
Visual Basic
Public Const SHUTTER_PRESENTATION_VALUE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_PRESENTATION_VALUE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_RIGHT_VERTICAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_RIGHT_VERTICAL_EDGE Field
MCdicom Structure See Also Send Feedback
Shutter Right Vertical Edge (0018,1604)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_RIGHT_VERTICAL_EDGE
Visual Basic
Public Const SHUTTER_RIGHT_VERTICAL_EDGE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_RIGHT_VERTICAL_EDGE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_SHAPE Field
MCdicom Structure See Also Send Feedback
Shutter Shape (0018,1600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_SHAPE
Visual Basic
Public Const SHUTTER_SHAPE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_SHAPE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_SPEED_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_SPEED_VALUE Field
MCdicom Structure See Also Send Feedback
Shutter Speed Value (0016,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_SPEED_VALUE
Visual Basic
Public Const SHUTTER_SPEED_VALUE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_SPEED_VALUE

See Also

MCdicom Structure
MCdicom Members


SHUTTER_UPPER_HORIZONTAL_EDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SHUTTER_UPPER_HORIZONTAL_EDGE Field
MCdicom Structure See Also Send Feedback
Shutter Upper Horizontal Edge (0018,1606)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SHUTTER_UPPER_HORIZONTAL_EDGE
Visual Basic
Public Const SHUTTER_UPPER_HORIZONTAL_EDGE As UInteger
Visual C++
public:
literal unsigned int SHUTTER_UPPER_HORIZONTAL_EDGE

See Also

MCdicom Structure
MCdicom Members


SIGNAL_DOMAIN_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIGNAL_DOMAIN_COLUMNS Field
MCdicom Structure See Also Send Feedback
Signal Domain Columns (0028,9003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIGNAL_DOMAIN_COLUMNS
Visual Basic
Public Const SIGNAL_DOMAIN_COLUMNS As UInteger
Visual C++
public:
literal unsigned int SIGNAL_DOMAIN_COLUMNS

See Also

MCdicom Structure
MCdicom Members


SIGNAL_DOMAIN_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIGNAL_DOMAIN_ROWS Field
MCdicom Structure See Also Send Feedback
Signal Domain Rows (0028,9235)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIGNAL_DOMAIN_ROWS
Visual Basic
Public Const SIGNAL_DOMAIN_ROWS As UInteger
Visual C++
public:
literal unsigned int SIGNAL_DOMAIN_ROWS

See Also

MCdicom Structure
MCdicom Members


SIGNAL_TO_NOISE_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIGNAL_TO_NOISE_RATIO Field
MCdicom Structure See Also Send Feedback
Signal to Noise Ratio (0022,1155)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIGNAL_TO_NOISE_RATIO
Visual Basic
Public Const SIGNAL_TO_NOISE_RATIO As UInteger
Visual C++
public:
literal unsigned int SIGNAL_TO_NOISE_RATIO

See Also

MCdicom Structure
MCdicom Members


SIGNATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIGNATURE Field
MCdicom Structure See Also Send Feedback
Signature (0400,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIGNATURE
Visual Basic
Public Const SIGNATURE As UInteger
Visual C++
public:
literal unsigned int SIGNATURE

See Also

MCdicom Structure
MCdicom Members


SIMPLE_FRAME_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIMPLE_FRAME_LIST Field
MCdicom Structure See Also Send Feedback
Simple Frame List (0008,1161)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIMPLE_FRAME_LIST
Visual Basic
Public Const SIMPLE_FRAME_LIST As UInteger
Visual C++
public:
literal unsigned int SIMPLE_FRAME_LIST

See Also

MCdicom Structure
MCdicom Members


SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Simulated Keratometric Cylinder Sequence (0046,0218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE
Visual Basic
Public Const SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SIMULATED_KERATOMETRIC_CYLINDER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SINGLE_COLLIMATION_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SINGLE_COLLIMATION_WIDTH Field
MCdicom Structure See Also Send Feedback
Single Collimation Width (0018,9306)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SINGLE_COLLIMATION_WIDTH
Visual Basic
Public Const SINGLE_COLLIMATION_WIDTH As UInteger
Visual C++
public:
literal unsigned int SINGLE_COLLIMATION_WIDTH

See Also

MCdicom Structure
MCdicom Members


SKIP_BEATS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SKIP_BEATS Field
MCdicom Structure See Also Send Feedback
Skip Beats (0018,1086)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SKIP_BEATS
Visual Basic
Public Const SKIP_BEATS As UInteger
Visual C++
public:
literal unsigned int SKIP_BEATS

See Also

MCdicom Structure
MCdicom Members


SKIP_FRAME_RANGE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SKIP_FRAME_RANGE_FLAG Field
MCdicom Structure See Also Send Feedback
Skip Frame Range Flag (0008,9460)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SKIP_FRAME_RANGE_FLAG
Visual Basic
Public Const SKIP_FRAME_RANGE_FLAG As UInteger
Visual C++
public:
literal unsigned int SKIP_FRAME_RANGE_FLAG

See Also

MCdicom Structure
MCdicom Members


SLAB_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLAB_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Slab Orientation (0018,9105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLAB_ORIENTATION
Visual Basic
Public Const SLAB_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int SLAB_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


SLAB_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLAB_THICKNESS Field
MCdicom Structure See Also Send Feedback
Slab Thickness (0018,9104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLAB_THICKNESS
Visual Basic
Public Const SLAB_THICKNESS As UInteger
Visual C++
public:
literal unsigned int SLAB_THICKNESS

See Also

MCdicom Structure
MCdicom Members


SLICE_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_LOCATION Field
MCdicom Structure See Also Send Feedback
Slice Location (0020,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_LOCATION
Visual Basic
Public Const SLICE_LOCATION As UInteger
Visual C++
public:
literal unsigned int SLICE_LOCATION

See Also

MCdicom Structure
MCdicom Members


SLICE_LOCATION_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_LOCATION_VECTOR Field
MCdicom Structure See Also Send Feedback
Slice Location Vector (0018,2005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_LOCATION_VECTOR
Visual Basic
Public Const SLICE_LOCATION_VECTOR As UInteger
Visual C++
public:
literal unsigned int SLICE_LOCATION_VECTOR

See Also

MCdicom Structure
MCdicom Members


SLICE_PROGRESS_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_PROGRESS_DIRECTION Field
MCdicom Structure See Also Send Feedback
Alias for tag SLICE_PROGRESSION_DIRECTION (0054,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_PROGRESS_DIRECTION
Visual Basic
Public Const SLICE_PROGRESS_DIRECTION As UInteger
Visual C++
public:
literal unsigned int SLICE_PROGRESS_DIRECTION

See Also

MCdicom Structure
MCdicom Members


SLICE_PROGRESSION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_PROGRESSION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Slice Progression Direction (0054,0500)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_PROGRESSION_DIRECTION
Visual Basic
Public Const SLICE_PROGRESSION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int SLICE_PROGRESSION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


SLICE_SENSITIVITY_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_SENSITIVITY_FACTOR Field
MCdicom Structure See Also Send Feedback
Slice Sensitivity Factor (0054,1320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_SENSITIVITY_FACTOR
Visual Basic
Public Const SLICE_SENSITIVITY_FACTOR As UInteger
Visual C++
public:
literal unsigned int SLICE_SENSITIVITY_FACTOR

See Also

MCdicom Structure
MCdicom Members


SLICE_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_THICKNESS Field
MCdicom Structure See Also Send Feedback
Slice Thickness (0018,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_THICKNESS
Visual Basic
Public Const SLICE_THICKNESS As UInteger
Visual C++
public:
literal unsigned int SLICE_THICKNESS

See Also

MCdicom Structure
MCdicom Members


SLICE_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLICE_VECTOR Field
MCdicom Structure See Also Send Feedback
Slice Vector (0054,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLICE_VECTOR
Visual Basic
Public Const SLICE_VECTOR As UInteger
Visual C++
public:
literal unsigned int SLICE_VECTOR

See Also

MCdicom Structure
MCdicom Members


SLIDE_IDENTIFIER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SLIDE_IDENTIFIER_RETIRED Field
MCdicom Structure See Also Send Feedback
Slide Identifier RETIRED (0040,06FA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SLIDE_IDENTIFIER_RETIRED
Visual Basic
Public Const SLIDE_IDENTIFIER_RETIRED As UInteger
Visual C++
public:
literal unsigned int SLIDE_IDENTIFIER_RETIRED

See Also

MCdicom Structure
MCdicom Members


SMALLEST_IMAGE_PIXEL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMALLEST_IMAGE_PIXEL_VALUE Field
MCdicom Structure See Also Send Feedback
Smallest Image Pixel Value (0028,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMALLEST_IMAGE_PIXEL_VALUE
Visual Basic
Public Const SMALLEST_IMAGE_PIXEL_VALUE As UInteger
Visual C++
public:
literal unsigned int SMALLEST_IMAGE_PIXEL_VALUE

See Also

MCdicom Structure
MCdicom Members


SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED Field
MCdicom Structure See Also Send Feedback
Smallest Image Pixel Value in Plane RETIRED (0028,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED
Visual Basic
Public Const SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SMALLEST_IMAGE_PIXEL_VALUE_IN_PLANE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SMALLEST_PIXEL_VALUE_IN_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMALLEST_PIXEL_VALUE_IN_SERIES Field
MCdicom Structure See Also Send Feedback
Smallest Pixel Value in Series (0028,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMALLEST_PIXEL_VALUE_IN_SERIES
Visual Basic
Public Const SMALLEST_PIXEL_VALUE_IN_SERIES As UInteger
Visual C++
public:
literal unsigned int SMALLEST_PIXEL_VALUE_IN_SERIES

See Also

MCdicom Structure
MCdicom Members


SMALLEST_PIXEL_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMALLEST_PIXEL_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Alias for tag SMALLEST_VALID_PIXEL_VALUE_RETIRED (0028,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMALLEST_PIXEL_VALUE_RETIRED
Visual Basic
Public Const SMALLEST_PIXEL_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SMALLEST_PIXEL_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SMALLEST_VALID_PIXEL_VALUE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMALLEST_VALID_PIXEL_VALUE_RETIRED Field
MCdicom Structure See Also Send Feedback
Smallest Valid Pixel Value RETIRED (0028,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMALLEST_VALID_PIXEL_VALUE_RETIRED
Visual Basic
Public Const SMALLEST_VALID_PIXEL_VALUE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SMALLEST_VALID_PIXEL_VALUE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SMOKING_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMOKING_STATUS Field
MCdicom Structure See Also Send Feedback
Smoking Status (0010,21A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMOKING_STATUS
Visual Basic
Public Const SMOKING_STATUS As UInteger
Visual C++
public:
literal unsigned int SMOKING_STATUS

See Also

MCdicom Structure
MCdicom Members


SMOOTHING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SMOOTHING_TYPE Field
MCdicom Structure See Also Send Feedback
Smoothing Type (2010,0080)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SMOOTHING_TYPE
Visual Basic
Public Const SMOOTHING_TYPE As UInteger
Visual C++
public:
literal unsigned int SMOOTHING_TYPE

See Also

MCdicom Structure
MCdicom Members


SNOUT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SNOUT_ID Field
MCdicom Structure See Also Send Feedback
Snout ID (300A,030F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SNOUT_ID
Visual Basic
Public Const SNOUT_ID As UInteger
Visual C++
public:
literal unsigned int SNOUT_ID

See Also

MCdicom Structure
MCdicom Members


SNOUT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SNOUT_POSITION Field
MCdicom Structure See Also Send Feedback
Snout Position (300A,030D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SNOUT_POSITION
Visual Basic
Public Const SNOUT_POSITION As UInteger
Visual C++
public:
literal unsigned int SNOUT_POSITION

See Also

MCdicom Structure
MCdicom Members


SNOUT_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SNOUT_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Snout Position Tolerance (300A,004B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SNOUT_POSITION_TOLERANCE
Visual Basic
Public Const SNOUT_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int SNOUT_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


SNOUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SNOUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Snout Sequence (300A,030C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SNOUT_SEQUENCE
Visual Basic
Public Const SNOUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SNOUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOFT_TISSUE_FOCUS_THERMAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOFT_TISSUE_FOCUS_THERMAL_INDEX Field
MCdicom Structure See Also Send Feedback
Soft Tissue-focus Thermal Index (0018,5028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOFT_TISSUE_FOCUS_THERMAL_INDEX
Visual Basic
Public Const SOFT_TISSUE_FOCUS_THERMAL_INDEX As UInteger
Visual C++
public:
literal unsigned int SOFT_TISSUE_FOCUS_THERMAL_INDEX

See Also

MCdicom Structure
MCdicom Members


SOFT_TISSUE_SURFACE_THERMAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOFT_TISSUE_SURFACE_THERMAL_INDEX Field
MCdicom Structure See Also Send Feedback
Soft Tissue-surface Thermal Index (0018,5029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOFT_TISSUE_SURFACE_THERMAL_INDEX
Visual Basic
Public Const SOFT_TISSUE_SURFACE_THERMAL_INDEX As UInteger
Visual C++
public:
literal unsigned int SOFT_TISSUE_SURFACE_THERMAL_INDEX

See Also

MCdicom Structure
MCdicom Members


SOFT_TISSUE_THERMAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOFT_TISSUE_THERMAL_INDEX Field
MCdicom Structure See Also Send Feedback
Soft Tissue Thermal Index (0018,5027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOFT_TISSUE_THERMAL_INDEX
Visual Basic
Public Const SOFT_TISSUE_THERMAL_INDEX As UInteger
Visual C++
public:
literal unsigned int SOFT_TISSUE_THERMAL_INDEX

See Also

MCdicom Structure
MCdicom Members


SOFTCOPY_VOI_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOFTCOPY_VOI_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Softcopy VOI LUT Sequence (0028,3110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOFTCOPY_VOI_LUT_SEQUENCE
Visual Basic
Public Const SOFTCOPY_VOI_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOFTCOPY_VOI_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOFTWARE_VERSIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOFTWARE_VERSIONS Field
MCdicom Structure See Also Send Feedback
Software Version(s) (0018,1020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOFTWARE_VERSIONS
Visual Basic
Public Const SOFTWARE_VERSIONS As UInteger
Visual C++
public:
literal unsigned int SOFTWARE_VERSIONS

See Also

MCdicom Structure
MCdicom Members


SOP_AUTHORIZATION_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_AUTHORIZATION_COMMENT Field
MCdicom Structure See Also Send Feedback
SOP Authorization Comment (0100,0424)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_AUTHORIZATION_COMMENT
Visual Basic
Public Const SOP_AUTHORIZATION_COMMENT As UInteger
Visual C++
public:
literal unsigned int SOP_AUTHORIZATION_COMMENT

See Also

MCdicom Structure
MCdicom Members


SOP_AUTHORIZATION_DATE_AND_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_AUTHORIZATION_DATE_AND_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag SOP_AUTHORIZATION_DATETIME (0100,0420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_AUTHORIZATION_DATE_AND_TIME
Visual Basic
Public Const SOP_AUTHORIZATION_DATE_AND_TIME As UInteger
Visual C++
public:
literal unsigned int SOP_AUTHORIZATION_DATE_AND_TIME

See Also

MCdicom Structure
MCdicom Members


SOP_AUTHORIZATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_AUTHORIZATION_DATETIME Field
MCdicom Structure See Also Send Feedback
SOP Authorization DateTime (0100,0420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_AUTHORIZATION_DATETIME
Visual Basic
Public Const SOP_AUTHORIZATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int SOP_AUTHORIZATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


SOP_CLASS_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_CLASS_UID Field
MCdicom Structure See Also Send Feedback
SOP Class UID (0008,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_CLASS_UID
Visual Basic
Public Const SOP_CLASS_UID As UInteger
Visual C++
public:
literal unsigned int SOP_CLASS_UID

See Also

MCdicom Structure
MCdicom Members


SOP_CLASSES_IN_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_CLASSES_IN_STUDY Field
MCdicom Structure See Also Send Feedback
SOP Classes in Study (0008,0062)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_CLASSES_IN_STUDY
Visual Basic
Public Const SOP_CLASSES_IN_STUDY As UInteger
Visual C++
public:
literal unsigned int SOP_CLASSES_IN_STUDY

See Also

MCdicom Structure
MCdicom Members


SOP_CLASSES_SUPPORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_CLASSES_SUPPORTED Field
MCdicom Structure See Also Send Feedback
SOP Classes Supported (0008,115A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_CLASSES_SUPPORTED
Visual Basic
Public Const SOP_CLASSES_SUPPORTED As UInteger
Visual C++
public:
literal unsigned int SOP_CLASSES_SUPPORTED

See Also

MCdicom Structure
MCdicom Members


SOP_INSTANCE_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_INSTANCE_STATUS Field
MCdicom Structure See Also Send Feedback
SOP Instance Status (0100,0410)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_INSTANCE_STATUS
Visual Basic
Public Const SOP_INSTANCE_STATUS As UInteger
Visual C++
public:
literal unsigned int SOP_INSTANCE_STATUS

See Also

MCdicom Structure
MCdicom Members


SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
SOP Instance UID (0008,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_INSTANCE_UID
Visual Basic
Public Const SOP_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int SOP_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


SOP_INSTANCE_UID_CONCATENATION_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_INSTANCE_UID_CONCATENATION_SOURCE Field
MCdicom Structure See Also Send Feedback
Alias for tag SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE (0020,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_INSTANCE_UID_CONCATENATION_SOURCE
Visual Basic
Public Const SOP_INSTANCE_UID_CONCATENATION_SOURCE As UInteger
Visual C++
public:
literal unsigned int SOP_INSTANCE_UID_CONCATENATION_SOURCE

See Also

MCdicom Structure
MCdicom Members


SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE Field
MCdicom Structure See Also Send Feedback
SOP Instance UID of Concatenation Source (0020,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE
Visual Basic
Public Const SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE As UInteger
Visual C++
public:
literal unsigned int SOP_INSTANCE_UID_OF_CONCATENATION_SOURCE

See Also

MCdicom Structure
MCdicom Members


SORT_BY_CATEGORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SORT_BY_CATEGORY Field
MCdicom Structure See Also Send Feedback
Sort-by Category (0072,0602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SORT_BY_CATEGORY
Visual Basic
Public Const SORT_BY_CATEGORY As UInteger
Visual C++
public:
literal unsigned int SORT_BY_CATEGORY

See Also

MCdicom Structure
MCdicom Members


SORTING_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SORTING_DIRECTION Field
MCdicom Structure See Also Send Feedback
Sorting Direction (0072,0604)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SORTING_DIRECTION
Visual Basic
Public Const SORTING_DIRECTION As UInteger
Visual C++
public:
literal unsigned int SORTING_DIRECTION

See Also

MCdicom Structure
MCdicom Members


SORTING_OPERATIONS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SORTING_OPERATIONS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Sorting Operations Sequence (0072,0600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SORTING_OPERATIONS_SEQUENCE
Visual Basic
Public Const SORTING_OPERATIONS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SORTING_OPERATIONS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOUND_PATH_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOUND_PATH_LENGTH Field
MCdicom Structure See Also Send Feedback
Sound Path Length (0014,405A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOUND_PATH_LENGTH
Visual Basic
Public Const SOUND_PATH_LENGTH As UInteger
Visual C++
public:
literal unsigned int SOUND_PATH_LENGTH

See Also

MCdicom Structure
MCdicom Members


SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Sound Speed Correction Mechanism Code Sequence (0018,9832)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE
Visual Basic
Public Const SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOUND_SPEED_CORRECTION_MECHANISM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_ACQUISITION_BEAM_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ACQUISITION_BEAM_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Acquisition Beam Number (0018,9939)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ACQUISITION_BEAM_NUMBER
Visual Basic
Public Const SOURCE_ACQUISITION_BEAM_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_ACQUISITION_BEAM_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Acquisition Protocol Element Number (0018,9938)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER
Visual Basic
Public Const SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_ACQUISITION_PROTOCOL_ELEMENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATION_ENTITY_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATION_ENTITY_TITLE Field
MCdicom Structure See Also Send Feedback
Source Application Entity Title (0002,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATION_ENTITY_TITLE
Visual Basic
Public Const SOURCE_APPLICATION_ENTITY_TITLE As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATION_ENTITY_TITLE

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_ID Field
MCdicom Structure See Also Send Feedback
Source Applicator ID (300A,0291)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_ID
Visual Basic
Public Const SOURCE_APPLICATOR_ID As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_ID

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_LENGTH Field
MCdicom Structure See Also Send Feedback
Source Applicator Length (300A,0296)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_LENGTH
Visual Basic
Public Const SOURCE_APPLICATOR_LENGTH As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_LENGTH

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Source Applicator Manufacturer (300A,0298)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_MANUFACTURER
Visual Basic
Public Const SOURCE_APPLICATOR_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_NAME Field
MCdicom Structure See Also Send Feedback
Source Applicator Name (300A,0294)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_NAME
Visual Basic
Public Const SOURCE_APPLICATOR_NAME As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_NAME

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Applicator Number (300A,0290)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_NUMBER
Visual Basic
Public Const SOURCE_APPLICATOR_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_STEP_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_STEP_SIZE Field
MCdicom Structure See Also Send Feedback
Source Applicator Step Size (300A,02A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_STEP_SIZE
Visual Basic
Public Const SOURCE_APPLICATOR_STEP_SIZE As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_STEP_SIZE

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_TIP_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_TIP_LENGTH Field
MCdicom Structure See Also Send Feedback
Source Applicator Tip Length (300A,0274)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_TIP_LENGTH
Visual Basic
Public Const SOURCE_APPLICATOR_TIP_LENGTH As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_TIP_LENGTH

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_TYPE Field
MCdicom Structure See Also Send Feedback
Source Applicator Type (300A,0292)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_TYPE
Visual Basic
Public Const SOURCE_APPLICATOR_TYPE As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_TYPE

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS Field
MCdicom Structure See Also Send Feedback
Source Applicator Wall Nominal Thickness (300A,029C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS
Visual Basic
Public Const SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_WALL_NOMINAL_THICKNESS

See Also

MCdicom Structure
MCdicom Members


SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION Field
MCdicom Structure See Also Send Feedback
Source Applicator Wall Nominal Transmission (300A,029E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION
Visual Basic
Public Const SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION As UInteger
Visual C++
public:
literal unsigned int SOURCE_APPLICATOR_WALL_NOMINAL_TRANSMISSION

See Also

MCdicom Structure
MCdicom Members


SOURCE_AXIS_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_AXIS_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source-Axis Distance (300A,00B4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_AXIS_DISTANCE
Visual Basic
Public Const SOURCE_AXIS_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_AXIS_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_CONCEPTUAL_VOLUME_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_CONCEPTUAL_VOLUME_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Conceptual Volume Sequence (3010,0018)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_CONCEPTUAL_VOLUME_SEQUENCE
Visual Basic
Public Const SOURCE_CONCEPTUAL_VOLUME_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_CONCEPTUAL_VOLUME_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_CONCEPTUAL_VOLUME_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_CONCEPTUAL_VOLUME_UID Field
MCdicom Structure See Also Send Feedback
Source Conceptual Volume UID (3010,0015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_CONCEPTUAL_VOLUME_UID
Visual Basic
Public Const SOURCE_CONCEPTUAL_VOLUME_UID As UInteger
Visual C++
public:
literal unsigned int SOURCE_CONCEPTUAL_VOLUME_UID

See Also

MCdicom Structure
MCdicom Members


SOURCE_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Source Description (300A,021C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_DESCRIPTION
Visual Basic
Public Const SOURCE_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SOURCE_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SOURCE_ENCAPSULATION_NOMINAL_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ENCAPSULATION_NOMINAL_THICKNESS Field
MCdicom Structure See Also Send Feedback
Source Encapsulation Nominal Thickness (300A,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ENCAPSULATION_NOMINAL_THICKNESS
Visual Basic
Public Const SOURCE_ENCAPSULATION_NOMINAL_THICKNESS As UInteger
Visual C++
public:
literal unsigned int SOURCE_ENCAPSULATION_NOMINAL_THICKNESS

See Also

MCdicom Structure
MCdicom Members


SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION Field
MCdicom Structure See Also Send Feedback
Source Encapsulation Nominal Transmission (300A,0224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION
Visual Basic
Public Const SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION As UInteger
Visual C++
public:
literal unsigned int SOURCE_ENCAPSULATION_NOMINAL_TRANSMISSION

See Also

MCdicom Structure
MCdicom Members


SOURCE_END_DATE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_END_DATE_TIME Field
MCdicom Structure See Also Send Feedback
Source End Date Time (0018,936A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_END_DATE_TIME
Visual Basic
Public Const SOURCE_END_DATE_TIME As UInteger
Visual C++
public:
literal unsigned int SOURCE_END_DATE_TIME

See Also

MCdicom Structure
MCdicom Members


SOURCE_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Source Frame of Reference UID (0064,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const SOURCE_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int SOURCE_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


SOURCE_HANGING_PROTOCOL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_HANGING_PROTOCOL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Hanging Protocol Sequence (0072,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_HANGING_PROTOCOL_SEQUENCE
Visual Basic
Public Const SOURCE_HANGING_PROTOCOL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_HANGING_PROTOCOL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Source Identifier (0034,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IDENTIFIER
Visual Basic
Public Const SOURCE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int SOURCE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Image Corneal Processed Data Sequence (0046,0244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE
Visual Basic
Public Const SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_IMAGE_CORNEAL_PROCESSED_DATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_IMAGE_EVIDENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IMAGE_EVIDENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Image Evidence Sequence (0008,9154)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IMAGE_EVIDENCE_SEQUENCE
Visual Basic
Public Const SOURCE_IMAGE_EVIDENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_IMAGE_EVIDENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_IMAGE_IDS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IMAGE_IDS_RETIRED Field
MCdicom Structure See Also Send Feedback
Source Image IDs RETIRED (0020,3100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IMAGE_IDS_RETIRED
Visual Basic
Public Const SOURCE_IMAGE_IDS_RETIRED As UInteger
Visual C++
public:
literal unsigned int SOURCE_IMAGE_IDS_RETIRED

See Also

MCdicom Structure
MCdicom Members


SOURCE_IMAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IMAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Image Sequence (0008,2112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IMAGE_SEQUENCE
Visual Basic
Public Const SOURCE_IMAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_IMAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_INSTANCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_INSTANCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Instance Sequence (0042,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_INSTANCE_SEQUENCE
Visual Basic
Public Const SOURCE_INSTANCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_INSTANCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_IRRADIATION_EVENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_IRRADIATION_EVENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Irradiation Event Sequence (0008,3011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_IRRADIATION_EVENT_SEQUENCE
Visual Basic
Public Const SOURCE_IRRADIATION_EVENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_IRRADIATION_EVENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_ISOTOPE_HALF_LIFE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ISOTOPE_HALF_LIFE Field
MCdicom Structure See Also Send Feedback
Source Isotope Half Life (300A,0228)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ISOTOPE_HALF_LIFE
Visual Basic
Public Const SOURCE_ISOTOPE_HALF_LIFE As UInteger
Visual C++
public:
literal unsigned int SOURCE_ISOTOPE_HALF_LIFE

See Also

MCdicom Structure
MCdicom Members


SOURCE_ISOTOPE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ISOTOPE_NAME Field
MCdicom Structure See Also Send Feedback
Source Isotope Name (300A,0226)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ISOTOPE_NAME
Visual Basic
Public Const SOURCE_ISOTOPE_NAME As UInteger
Visual C++
public:
literal unsigned int SOURCE_ISOTOPE_NAME

See Also

MCdicom Structure
MCdicom Members


SOURCE_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_MANUFACTURER Field
MCdicom Structure See Also Send Feedback
Source Manufacturer (300A,0216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_MANUFACTURER
Visual Basic
Public Const SOURCE_MANUFACTURER As UInteger
Visual C++
public:
literal unsigned int SOURCE_MANUFACTURER

See Also

MCdicom Structure
MCdicom Members


SOURCE_MODEL_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_MODEL_ID Field
MCdicom Structure See Also Send Feedback
Source Model ID (300A,021B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_MODEL_ID
Visual Basic
Public Const SOURCE_MODEL_ID As UInteger
Visual C++
public:
literal unsigned int SOURCE_MODEL_ID

See Also

MCdicom Structure
MCdicom Members


SOURCE_MOVEMENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_MOVEMENT_TYPE Field
MCdicom Structure See Also Send Feedback
Source Movement Type (300A,0288)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_MOVEMENT_TYPE
Visual Basic
Public Const SOURCE_MOVEMENT_TYPE As UInteger
Visual C++
public:
literal unsigned int SOURCE_MOVEMENT_TYPE

See Also

MCdicom Structure
MCdicom Members


SOURCE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Number (300A,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_NUMBER
Visual Basic
Public Const SOURCE_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Anterior Chamber Depth Data Code Sequence (0022,1133)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_ANTERIOR_CHAMBER_DEPTH_DATA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Cornea Measurement Data Code Sequence (0046,0111)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_CORNEA_MEASUREMENT_DATA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Corneal Size Data Code Sequence (0022,1036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_CORNEAL_SIZE_DATA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Lens Thickness Data Code Sequence (0022,1132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_LENS_THICKNESS_DATA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Ophthalmic Axial Length Code Sequence (0022,1035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_OPHTHALMIC_AXIAL_LENGTH_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_PREVIOUS_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_PREVIOUS_VALUES Field
MCdicom Structure See Also Send Feedback
Source of Previous Values (0400,0564)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_PREVIOUS_VALUES
Visual Basic
Public Const SOURCE_OF_PREVIOUS_VALUES As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_PREVIOUS_VALUES

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_REFERENCE_OBJECT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_REFERENCE_OBJECT_DISTANCE Field
MCdicom Structure See Also Send Feedback
Alias for tag SOURCE_TO_REFERENCE_OBJECT_DISTANCE (3002,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_REFERENCE_OBJECT_DISTANCE
Visual Basic
Public Const SOURCE_OF_REFERENCE_OBJECT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_REFERENCE_OBJECT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE (0022,1135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_REFRACTIVE_ERROR_DATA_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Refractive Measurements Code Sequence (0022,1135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE
Visual Basic
Public Const SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_REFRACTIVE_MEASUREMENTS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source of Refractive Measurements Sequence (0022,1134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_OF_REFRACTIVE_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Source Orientation (4010,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ORIENTATION
Visual Basic
Public Const SOURCE_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int SOURCE_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Patient Group Identification Sequence (0010,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_PATIENT_GROUP_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Pixel Planes Characteristics Sequence (3006,004A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_PIXEL_PLANES_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_POSITION Field
MCdicom Structure See Also Send Feedback
Source Position (4010,1061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_POSITION
Visual Basic
Public Const SOURCE_POSITION As UInteger
Visual C++
public:
literal unsigned int SOURCE_POSITION

See Also

MCdicom Structure
MCdicom Members


SOURCE_PRESENTATION_ADDRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_PRESENTATION_ADDRESS Field
MCdicom Structure See Also Send Feedback
Source Presentation Address (0002,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_PRESENTATION_ADDRESS
Visual Basic
Public Const SOURCE_PRESENTATION_ADDRESS As UInteger
Visual C++
public:
literal unsigned int SOURCE_PRESENTATION_ADDRESS

See Also

MCdicom Structure
MCdicom Members


SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Reconstruction Protocol Element Number (0018,993A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER
Visual Basic
Public Const SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_RECONSTRUCTION_PROTOCOL_ELEMENT_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_ROLL_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_ROLL_ANGLE Field
MCdicom Structure See Also Send Feedback
Source Roll Angle (300A,067A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_ROLL_ANGLE
Visual Basic
Public Const SOURCE_ROLL_ANGLE As UInteger
Visual C++
public:
literal unsigned int SOURCE_ROLL_ANGLE

See Also

MCdicom Structure
MCdicom Members


SOURCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Sequence (300A,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_SEQUENCE
Visual Basic
Public Const SOURCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_SERIAL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_SERIAL_NUMBER Field
MCdicom Structure See Also Send Feedback
Source Serial Number (3008,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_SERIAL_NUMBER
Visual Basic
Public Const SOURCE_SERIAL_NUMBER As UInteger
Visual C++
public:
literal unsigned int SOURCE_SERIAL_NUMBER

See Also

MCdicom Structure
MCdicom Members


SOURCE_START_DATE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_START_DATE_TIME Field
MCdicom Structure See Also Send Feedback
Source Start Date Time (0018,9369)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_START_DATE_TIME
Visual Basic
Public Const SOURCE_START_DATE_TIME As UInteger
Visual C++
public:
literal unsigned int SOURCE_START_DATE_TIME

See Also

MCdicom Structure
MCdicom Members


SOURCE_STRENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_STRENGTH Field
MCdicom Structure See Also Send Feedback
Source Strength (300A,022B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_STRENGTH
Visual Basic
Public Const SOURCE_STRENGTH As UInteger
Visual C++
public:
literal unsigned int SOURCE_STRENGTH

See Also

MCdicom Structure
MCdicom Members


SOURCE_STRENGTH_REFERENCE_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_STRENGTH_REFERENCE_DATE Field
MCdicom Structure See Also Send Feedback
Source Strength Reference Date (300A,022C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_STRENGTH_REFERENCE_DATE
Visual Basic
Public Const SOURCE_STRENGTH_REFERENCE_DATE As UInteger
Visual C++
public:
literal unsigned int SOURCE_STRENGTH_REFERENCE_DATE

See Also

MCdicom Structure
MCdicom Members


SOURCE_STRENGTH_REFERENCE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_STRENGTH_REFERENCE_TIME Field
MCdicom Structure See Also Send Feedback
Source Strength Reference Time (300A,022E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_STRENGTH_REFERENCE_TIME
Visual Basic
Public Const SOURCE_STRENGTH_REFERENCE_TIME As UInteger
Visual C++
public:
literal unsigned int SOURCE_STRENGTH_REFERENCE_TIME

See Also

MCdicom Structure
MCdicom Members


SOURCE_STRENGTH_UNIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_STRENGTH_UNIT Field
MCdicom Structure See Also Send Feedback
Alias for tag SOURCE_STRENGTH_UNITS (300A,0229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_STRENGTH_UNIT
Visual Basic
Public Const SOURCE_STRENGTH_UNIT As UInteger
Visual C++
public:
literal unsigned int SOURCE_STRENGTH_UNIT

See Also

MCdicom Structure
MCdicom Members


SOURCE_STRENGTH_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_STRENGTH_UNITS Field
MCdicom Structure See Also Send Feedback
Source Strength Units (300A,0229)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_STRENGTH_UNITS
Visual Basic
Public Const SOURCE_STRENGTH_UNITS As UInteger
Visual C++
public:
literal unsigned int SOURCE_STRENGTH_UNITS

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Applicator Mounting Position Distance (300A,0436)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE
Visual Basic
Public Const SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_APPLICATOR_MOUNTING_POSITION_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Beam Limiting Device Distance (300A,00BA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE
Visual Basic
Public Const SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_BEAM_LIMITING_DEVICE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_BLOCK_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_BLOCK_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Block Tray Distance (300A,00F6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_BLOCK_TRAY_DISTANCE
Visual Basic
Public Const SOURCE_TO_BLOCK_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_BLOCK_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_COMPENSATOR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_COMPENSATOR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Compensator Distance (300A,02E2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_COMPENSATOR_DISTANCE
Visual Basic
Public Const SOURCE_TO_COMPENSATOR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_COMPENSATOR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_COMPENSATOR_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_COMPENSATOR_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Compensator Tray Distance (300A,00E6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_COMPENSATOR_TRAY_DISTANCE
Visual Basic
Public Const SOURCE_TO_COMPENSATOR_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_COMPENSATOR_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to External Contour Distance (300A,0132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE
Visual Basic
Public Const SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_EXTERNAL_CONTOUR_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_GENERAL_ACCESSORY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_GENERAL_ACCESSORY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to General Accessory Distance (300A,0425)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_GENERAL_ACCESSORY_DISTANCE
Visual Basic
Public Const SOURCE_TO_GENERAL_ACCESSORY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_GENERAL_ACCESSORY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_PATIENT_SURFACE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_PATIENT_SURFACE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Patient Surface Distance (300A,0634)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_PATIENT_SURFACE_DISTANCE
Visual Basic
Public Const SOURCE_TO_PATIENT_SURFACE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_PATIENT_SURFACE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_REFERENCE_OBJECT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_REFERENCE_OBJECT_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Reference Object Distance (3002,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_REFERENCE_OBJECT_DISTANCE
Visual Basic
Public Const SOURCE_TO_REFERENCE_OBJECT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_REFERENCE_OBJECT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_SURFACE_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_SURFACE_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Surface Distance (300A,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_SURFACE_DISTANCE
Visual Basic
Public Const SOURCE_TO_SURFACE_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_SURFACE_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TO_WEDGE_TRAY_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TO_WEDGE_TRAY_DISTANCE Field
MCdicom Structure See Also Send Feedback
Source to Wedge Tray Distance (300A,00DA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TO_WEDGE_TRAY_DISTANCE
Visual Basic
Public Const SOURCE_TO_WEDGE_TRAY_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TO_WEDGE_TRAY_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SOURCE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_TYPE Field
MCdicom Structure See Also Send Feedback
Source Type (300A,0214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_TYPE
Visual Basic
Public Const SOURCE_TYPE As UInteger
Visual C++
public:
literal unsigned int SOURCE_TYPE

See Also

MCdicom Structure
MCdicom Members


SOURCE_WAVEFORM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SOURCE_WAVEFORM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Source Waveform Sequence (003A,020A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SOURCE_WAVEFORM_SEQUENCE
Visual Basic
Public Const SOURCE_WAVEFORM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SOURCE_WAVEFORM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPACING_BETWEEN_SLICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPACING_BETWEEN_SLICES Field
MCdicom Structure See Also Send Feedback
Spacing Between Slices (0018,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPACING_BETWEEN_SLICES
Visual Basic
Public Const SPACING_BETWEEN_SLICES As UInteger
Visual C++
public:
literal unsigned int SPACING_BETWEEN_SLICES

See Also

MCdicom Structure
MCdicom Members


SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES Field
MCdicom Structure See Also Send Feedback
Spatial Frequency Response Column Names (0016,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES
Visual Basic
Public Const SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES As UInteger
Visual C++
public:
literal unsigned int SPATIAL_FREQUENCY_RESPONSE_COLUMN_NAMES

See Also

MCdicom Structure
MCdicom Members


SPATIAL_FREQUENCY_RESPONSE_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_FREQUENCY_RESPONSE_COLUMNS Field
MCdicom Structure See Also Send Feedback
Spatial Frequency Response Columns (0016,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_FREQUENCY_RESPONSE_COLUMNS
Visual Basic
Public Const SPATIAL_FREQUENCY_RESPONSE_COLUMNS As UInteger
Visual C++
public:
literal unsigned int SPATIAL_FREQUENCY_RESPONSE_COLUMNS

See Also

MCdicom Structure
MCdicom Members


SPATIAL_FREQUENCY_RESPONSE_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_FREQUENCY_RESPONSE_ROWS Field
MCdicom Structure See Also Send Feedback
Spatial Frequency Response Rows (0016,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_FREQUENCY_RESPONSE_ROWS
Visual Basic
Public Const SPATIAL_FREQUENCY_RESPONSE_ROWS As UInteger
Visual C++
public:
literal unsigned int SPATIAL_FREQUENCY_RESPONSE_ROWS

See Also

MCdicom Structure
MCdicom Members


SPATIAL_FREQUENCY_RESPONSE_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_FREQUENCY_RESPONSE_VALUES Field
MCdicom Structure See Also Send Feedback
Spatial Frequency Response Values (0016,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_FREQUENCY_RESPONSE_VALUES
Visual Basic
Public Const SPATIAL_FREQUENCY_RESPONSE_VALUES As UInteger
Visual C++
public:
literal unsigned int SPATIAL_FREQUENCY_RESPONSE_VALUES

See Also

MCdicom Structure
MCdicom Members


SPATIAL_LOCATIONS_PRESERVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_LOCATIONS_PRESERVED Field
MCdicom Structure See Also Send Feedback
Spatial Locations Preserved (0028,135A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_LOCATIONS_PRESERVED
Visual Basic
Public Const SPATIAL_LOCATIONS_PRESERVED As UInteger
Visual C++
public:
literal unsigned int SPATIAL_LOCATIONS_PRESERVED

See Also

MCdicom Structure
MCdicom Members


SPATIAL_PRE_SATURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_PRE_SATURATION Field
MCdicom Structure See Also Send Feedback
Spatial Pre-saturation (0018,9027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_PRE_SATURATION
Visual Basic
Public Const SPATIAL_PRE_SATURATION As UInteger
Visual C++
public:
literal unsigned int SPATIAL_PRE_SATURATION

See Also

MCdicom Structure
MCdicom Members


SPATIAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Spatial Resolution (0018,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_RESOLUTION
Visual Basic
Public Const SPATIAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int SPATIAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


SPATIAL_TRANSFORM_OF_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPATIAL_TRANSFORM_OF_DOSE Field
MCdicom Structure See Also Send Feedback
Spatial Transform of Dose (3004,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPATIAL_TRANSFORM_OF_DOSE
Visual Basic
Public Const SPATIAL_TRANSFORM_OF_DOSE As UInteger
Visual C++
public:
literal unsigned int SPATIAL_TRANSFORM_OF_DOSE

See Also

MCdicom Structure
MCdicom Members


SPECIAL_NEEDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIAL_NEEDS Field
MCdicom Structure See Also Send Feedback
Special Needs (0038,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIAL_NEEDS
Visual Basic
Public Const SPECIAL_NEEDS As UInteger
Visual C++
public:
literal unsigned int SPECIAL_NEEDS

See Also

MCdicom Structure
MCdicom Members


SPECIFIC_ABSORPTION_RATE_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIC_ABSORPTION_RATE_DEFINITION Field
MCdicom Structure See Also Send Feedback
Specific Absorption Rate Definition (0018,9179)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIC_ABSORPTION_RATE_DEFINITION
Visual Basic
Public Const SPECIFIC_ABSORPTION_RATE_DEFINITION As UInteger
Visual C++
public:
literal unsigned int SPECIFIC_ABSORPTION_RATE_DEFINITION

See Also

MCdicom Structure
MCdicom Members


SPECIFIC_ABSORPTION_RATE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIC_ABSORPTION_RATE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specific Absorption Rate Sequence (0018,9239)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIC_ABSORPTION_RATE_SEQUENCE
Visual Basic
Public Const SPECIFIC_ABSORPTION_RATE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIFIC_ABSORPTION_RATE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIFIC_ABSORPTION_RATE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIC_ABSORPTION_RATE_VALUE Field
MCdicom Structure See Also Send Feedback
Specific Absorption Rate Value (0018,9181)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIC_ABSORPTION_RATE_VALUE
Visual Basic
Public Const SPECIFIC_ABSORPTION_RATE_VALUE As UInteger
Visual C++
public:
literal unsigned int SPECIFIC_ABSORPTION_RATE_VALUE

See Also

MCdicom Structure
MCdicom Members


SPECIFIC_CHARACTER_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIC_CHARACTER_SET Field
MCdicom Structure See Also Send Feedback
Specific Character Set (0008,0005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIC_CHARACTER_SET
Visual Basic
Public Const SPECIFIC_CHARACTER_SET As UInteger
Visual C++
public:
literal unsigned int SPECIFIC_CHARACTER_SET

See Also

MCdicom Structure
MCdicom Members


SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE Field
MCdicom Structure See Also Send Feedback
Specific Character Set of File-set Descriptor File (0004,1142)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE
Visual Basic
Public Const SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE As UInteger
Visual C++
public:
literal unsigned int SPECIFIC_CHARACTER_SET_OF_FILE_SET_DESCRIPTOR_FILE

See Also

MCdicom Structure
MCdicom Members


SPECIFICATION_SELECTION_GUIDANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFICATION_SELECTION_GUIDANCE Field
MCdicom Structure See Also Send Feedback
Specification Selection Guidance (0082,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFICATION_SELECTION_GUIDANCE
Visual Basic
Public Const SPECIFICATION_SELECTION_GUIDANCE As UInteger
Visual C++
public:
literal unsigned int SPECIFICATION_SELECTION_GUIDANCE

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_CHANNEL_TOTAL_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_CHANNEL_TOTAL_TIME Field
MCdicom Structure See Also Send Feedback
Specified Channel Total Time (3008,0132)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_CHANNEL_TOTAL_TIME
Visual Basic
Public Const SPECIFIED_CHANNEL_TOTAL_TIME As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_CHANNEL_TOTAL_TIME

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_METERSET Field
MCdicom Structure See Also Send Feedback
Specified Meterset (3008,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_METERSET
Visual Basic
Public Const SPECIFIED_METERSET As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_METERSET

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_NUMBER_OF_PULSES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_NUMBER_OF_PULSES Field
MCdicom Structure See Also Send Feedback
Specified Number of Pulses (3008,0136)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_NUMBER_OF_PULSES
Visual Basic
Public Const SPECIFIED_NUMBER_OF_PULSES As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_NUMBER_OF_PULSES

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_PRIMARY_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_PRIMARY_METERSET Field
MCdicom Structure See Also Send Feedback
Specified Primary Meterset (3008,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_PRIMARY_METERSET
Visual Basic
Public Const SPECIFIED_PRIMARY_METERSET As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_PRIMARY_METERSET

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_PULSE_REPETITION_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_PULSE_REPETITION_INTERVAL Field
MCdicom Structure See Also Send Feedback
Specified Pulse Repetition Interval (3008,013A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_PULSE_REPETITION_INTERVAL
Visual Basic
Public Const SPECIFIED_PULSE_REPETITION_INTERVAL As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_PULSE_REPETITION_INTERVAL

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_SECONDARY_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_SECONDARY_METERSET Field
MCdicom Structure See Also Send Feedback
Specified Secondary Meterset (3008,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_SECONDARY_METERSET
Visual Basic
Public Const SPECIFIED_SECONDARY_METERSET As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_SECONDARY_METERSET

See Also

MCdicom Structure
MCdicom Members


SPECIFIED_TREATMENT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIFIED_TREATMENT_TIME Field
MCdicom Structure See Also Send Feedback
Specified Treatment Time (3008,003A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIFIED_TREATMENT_TIME
Visual Basic
Public Const SPECIFIED_TREATMENT_TIME As UInteger
Visual C++
public:
literal unsigned int SPECIFIED_TREATMENT_TIME

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_ACCESSION_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_ACCESSION_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Specimen Accession Number RETIRED (0040,050A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_ACCESSION_NUMBER_RETIRED
Visual Basic
Public Const SPECIMEN_ACCESSION_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_ACCESSION_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_DESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_DESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Description Sequence (0040,0560)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_DESCRIPTION_SEQUENCE
Visual Basic
Public Const SPECIMEN_DESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_DESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Specimen Description Sequence (Trial) RETIRED (0040,0552)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_DESCRIPTION_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_DESCRIPTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_DESCRIPTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Specimen Description (Trial) RETIRED (0040,0553)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_DESCRIPTION_TRIAL_RETIRED
Visual Basic
Public Const SPECIMEN_DESCRIPTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_DESCRIPTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_DETAILED_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_DETAILED_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Specimen Detailed Description (0040,0602)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_DETAILED_DESCRIPTION
Visual Basic
Public Const SPECIMEN_DETAILED_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_DETAILED_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Specimen Identifier (0040,0551)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_IDENTIFIER
Visual Basic
Public Const SPECIMEN_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_LABEL_IN_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_LABEL_IN_IMAGE Field
MCdicom Structure See Also Send Feedback
Specimen Label in Image (0048,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_LABEL_IN_IMAGE
Visual Basic
Public Const SPECIMEN_LABEL_IN_IMAGE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_LABEL_IN_IMAGE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Localization Content Item Sequence (0040,0620)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE
Visual Basic
Public Const SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_LOCALIZATION_CONTENT_ITEM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_PREPARATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_PREPARATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Preparation Sequence (0040,0610)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_PREPARATION_SEQUENCE
Visual Basic
Public Const SPECIMEN_PREPARATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_PREPARATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Preparation Step Content Item Sequence (0040,0612)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE
Visual Basic
Public Const SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_PREPARATION_STEP_CONTENT_ITEM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Reference Sequence (0048,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_REFERENCE_SEQUENCE
Visual Basic
Public Const SPECIMEN_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Specimen Sequence RETIRED (0040,0550)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_SEQUENCE_RETIRED
Visual Basic
Public Const SPECIMEN_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_SHORT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_SHORT_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Specimen Short Description (0040,0600)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_SHORT_DESCRIPTION
Visual Basic
Public Const SPECIMEN_SHORT_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_SHORT_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Specimen Type Code Sequence (0040,059A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_TYPE_CODE_SEQUENCE
Visual Basic
Public Const SPECIMEN_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SPECIMEN_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECIMEN_UID Field
MCdicom Structure See Also Send Feedback
Specimen UID (0040,0554)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECIMEN_UID
Visual Basic
Public Const SPECIMEN_UID As UInteger
Visual C++
public:
literal unsigned int SPECIMEN_UID

See Also

MCdicom Structure
MCdicom Members


SPECTRAL_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTRAL_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Spectral Sensitivity (0016,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTRAL_SENSITIVITY
Visual Basic
Public Const SPECTRAL_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int SPECTRAL_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


SPECTRAL_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTRAL_WIDTH Field
MCdicom Structure See Also Send Feedback
Spectral Width (0018,9052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTRAL_WIDTH
Visual Basic
Public Const SPECTRAL_WIDTH As UInteger
Visual C++
public:
literal unsigned int SPECTRAL_WIDTH

See Also

MCdicom Structure
MCdicom Members


SPECTRALLY_SELECTED_EXCITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTRALLY_SELECTED_EXCITATION Field
MCdicom Structure See Also Send Feedback
Spectrally Selected Excitation (0018,9026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTRALLY_SELECTED_EXCITATION
Visual Basic
Public Const SPECTRALLY_SELECTED_EXCITATION As UInteger
Visual C++
public:
literal unsigned int SPECTRALLY_SELECTED_EXCITATION

See Also

MCdicom Structure
MCdicom Members


SPECTRALLY_SELECTED_SUPPRESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTRALLY_SELECTED_SUPPRESSION Field
MCdicom Structure See Also Send Feedback
Spectrally Selected Suppression (0018,9025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTRALLY_SELECTED_SUPPRESSION
Visual Basic
Public Const SPECTRALLY_SELECTED_SUPPRESSION As UInteger
Visual C++
public:
literal unsigned int SPECTRALLY_SELECTED_SUPPRESSION

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_ACQUISITION_DATA_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_ACQUISITION_DATA_COLUMNS Field
MCdicom Structure See Also Send Feedback
Spectroscopy Acquisition Data Columns (0018,9127)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_ACQUISITION_DATA_COLUMNS
Visual Basic
Public Const SPECTROSCOPY_ACQUISITION_DATA_COLUMNS As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_ACQUISITION_DATA_COLUMNS

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS Field
MCdicom Structure See Also Send Feedback
Spectroscopy Acquisition Out-of-plane Phase Steps (0018,9159)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS
Visual Basic
Public Const SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS Field
MCdicom Structure See Also Send Feedback
Alias for tag SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_PHASE_STEPS (0018,9159)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS
Visual Basic
Public Const SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_ACQUISITION_OUT_OF_PLANE_STEPS

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS Field
MCdicom Structure See Also Send Feedback
Spectroscopy Acquisition Phase Columns (0018,9234)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS
Visual Basic
Public Const SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_ACQUISITION_PHASE_COLUMNS

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_ACQUISITION_PHASE_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_ACQUISITION_PHASE_ROWS Field
MCdicom Structure See Also Send Feedback
Spectroscopy Acquisition Phase Rows (0018,9095)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_ACQUISITION_PHASE_ROWS
Visual Basic
Public Const SPECTROSCOPY_ACQUISITION_PHASE_ROWS As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_ACQUISITION_PHASE_ROWS

See Also

MCdicom Structure
MCdicom Members


SPECTROSCOPY_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECTROSCOPY_DATA Field
MCdicom Structure See Also Send Feedback
Spectroscopy Data (5600,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECTROSCOPY_DATA
Visual Basic
Public Const SPECTROSCOPY_DATA As UInteger
Visual C++
public:
literal unsigned int SPECTROSCOPY_DATA

See Also

MCdicom Structure
MCdicom Members


SPECULAR_REFLECTION_INTENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPECULAR_REFLECTION_INTENSITY Field
MCdicom Structure See Also Send Feedback
Specular Reflection Intensity (0070,1705)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPECULAR_REFLECTION_INTENSITY
Visual Basic
Public Const SPECULAR_REFLECTION_INTENSITY As UInteger
Visual C++
public:
literal unsigned int SPECULAR_REFLECTION_INTENSITY

See Also

MCdicom Structure
MCdicom Members


SPHERE_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPHERE_POWER Field
MCdicom Structure See Also Send Feedback
Sphere Power (0046,0146)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPHERE_POWER
Visual Basic
Public Const SPHERE_POWER As UInteger
Visual C++
public:
literal unsigned int SPHERE_POWER

See Also

MCdicom Structure
MCdicom Members


SPHERICAL_LENS_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPHERICAL_LENS_POWER Field
MCdicom Structure See Also Send Feedback
Spherical Lens Power (0022,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPHERICAL_LENS_POWER
Visual Basic
Public Const SPHERICAL_LENS_POWER As UInteger
Visual C++
public:
literal unsigned int SPHERICAL_LENS_POWER

See Also

MCdicom Structure
MCdicom Members


SPIRAL_PITCH_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPIRAL_PITCH_FACTOR Field
MCdicom Structure See Also Send Feedback
Spiral Pitch Factor (0018,9311)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPIRAL_PITCH_FACTOR
Visual Basic
Public Const SPIRAL_PITCH_FACTOR As UInteger
Visual C++
public:
literal unsigned int SPIRAL_PITCH_FACTOR

See Also

MCdicom Structure
MCdicom Members


SPOILING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SPOILING Field
MCdicom Structure See Also Send Feedback
Spoiling (0018,9016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SPOILING
Visual Basic
Public Const SPOILING As UInteger
Visual C++
public:
literal unsigned int SPOILING

See Also

MCdicom Structure
MCdicom Members


STACK_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STACK_ID Field
MCdicom Structure See Also Send Feedback
Stack ID (0020,9056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STACK_ID
Visual Basic
Public Const STACK_ID As UInteger
Visual C++
public:
literal unsigned int STACK_ID

See Also

MCdicom Structure
MCdicom Members


STAGE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STAGE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Stage Code Sequence (0040,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STAGE_CODE_SEQUENCE
Visual Basic
Public Const STAGE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STAGE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STAGE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STAGE_NAME Field
MCdicom Structure See Also Send Feedback
Stage Name (0008,2120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STAGE_NAME
Visual Basic
Public Const STAGE_NAME As UInteger
Visual C++
public:
literal unsigned int STAGE_NAME

See Also

MCdicom Structure
MCdicom Members


STAGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STAGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Stage Number (0008,2122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STAGE_NUMBER
Visual Basic
Public Const STAGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int STAGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


STANDARD_OUTPUT_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STANDARD_OUTPUT_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Standard Output Sensitivity (0016,001B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STANDARD_OUTPUT_SENSITIVITY
Visual Basic
Public Const STANDARD_OUTPUT_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int STANDARD_OUTPUT_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


START_ACQUISITION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_ACQUISITION_DATETIME Field
MCdicom Structure See Also Send Feedback
Start Acquisition DateTime (0018,9516)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_ACQUISITION_DATETIME
Visual Basic
Public Const START_ACQUISITION_DATETIME As UInteger
Visual C++
public:
literal unsigned int START_ACQUISITION_DATETIME

See Also

MCdicom Structure
MCdicom Members


START_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_ANGLE Field
MCdicom Structure See Also Send Feedback
Start Angle (0054,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_ANGLE
Visual Basic
Public Const START_ANGLE As UInteger
Visual C++
public:
literal unsigned int START_ANGLE

See Also

MCdicom Structure
MCdicom Members


START_CARDIAC_TRIGGER_COUNT_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_CARDIAC_TRIGGER_COUNT_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Start Cardiac Trigger Count Threshold (0018,9717)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_CARDIAC_TRIGGER_COUNT_THRESHOLD
Visual Basic
Public Const START_CARDIAC_TRIGGER_COUNT_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int START_CARDIAC_TRIGGER_COUNT_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


START_CUMULATIVE_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_CUMULATIVE_METERSET Field
MCdicom Structure See Also Send Feedback
Start Cumulative Meterset (3002,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_CUMULATIVE_METERSET
Visual Basic
Public Const START_CUMULATIVE_METERSET As UInteger
Visual C++
public:
literal unsigned int START_CUMULATIVE_METERSET

See Also

MCdicom Structure
MCdicom Members


START_CUMULATIVE_METERSET_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_CUMULATIVE_METERSET_WEIGHT Field
MCdicom Structure See Also Send Feedback
Start Cumulative Meterset Weight (300C,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_CUMULATIVE_METERSET_WEIGHT
Visual Basic
Public Const START_CUMULATIVE_METERSET_WEIGHT As UInteger
Visual C++
public:
literal unsigned int START_CUMULATIVE_METERSET_WEIGHT

See Also

MCdicom Structure
MCdicom Members


START_CUMULATIVE_TIME_WEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_CUMULATIVE_TIME_WEIGHT Field
MCdicom Structure See Also Send Feedback
Start Cumulative Time Weight (0074,1407)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_CUMULATIVE_TIME_WEIGHT
Visual Basic
Public Const START_CUMULATIVE_TIME_WEIGHT As UInteger
Visual C++
public:
literal unsigned int START_CUMULATIVE_TIME_WEIGHT

See Also

MCdicom Structure
MCdicom Members


START_DENSITY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_DENSITY_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Start Density Threshold (0018,9715)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_DENSITY_THRESHOLD
Visual Basic
Public Const START_DENSITY_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int START_DENSITY_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


START_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_METERSET Field
MCdicom Structure See Also Send Feedback
Start Meterset (3008,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_METERSET
Visual Basic
Public Const START_METERSET As UInteger
Visual C++
public:
literal unsigned int START_METERSET

See Also

MCdicom Structure
MCdicom Members


START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Start Relative Density Difference Threshold (0018,9716)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD
Visual Basic
Public Const START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int START_RELATIVE_DENSITY_DIFFERENCE_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Start Respiratory Trigger Count Threshold (0018,9718)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD
Visual Basic
Public Const START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int START_RESPIRATORY_TRIGGER_COUNT_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


START_TRIM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..START_TRIM Field
MCdicom Structure See Also Send Feedback
Start Trim (0008,2142)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint START_TRIM
Visual Basic
Public Const START_TRIM As UInteger
Visual C++
public:
literal unsigned int START_TRIM

See Also

MCdicom Structure
MCdicom Members


STARTING_METERSET_VALUE_KNOWN_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STARTING_METERSET_VALUE_KNOWN_FLAG Field
MCdicom Structure See Also Send Feedback
Starting Meterset Value Known Flag (300A,0723)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STARTING_METERSET_VALUE_KNOWN_FLAG
Visual Basic
Public Const STARTING_METERSET_VALUE_KNOWN_FLAG As UInteger
Visual C++
public:
literal unsigned int STARTING_METERSET_VALUE_KNOWN_FLAG

See Also

MCdicom Structure
MCdicom Members


STARTING_RESPIRATORY_AMPLITUDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STARTING_RESPIRATORY_AMPLITUDE Field
MCdicom Structure See Also Send Feedback
Starting Respiratory Amplitude (0020,9246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STARTING_RESPIRATORY_AMPLITUDE
Visual Basic
Public Const STARTING_RESPIRATORY_AMPLITUDE As UInteger
Visual C++
public:
literal unsigned int STARTING_RESPIRATORY_AMPLITUDE

See Also

MCdicom Structure
MCdicom Members


STARTING_RESPIRATORY_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STARTING_RESPIRATORY_PHASE Field
MCdicom Structure See Also Send Feedback
Starting Respiratory Phase (0020,9247)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STARTING_RESPIRATORY_PHASE
Visual Basic
Public Const STARTING_RESPIRATORY_PHASE As UInteger
Visual C++
public:
literal unsigned int STARTING_RESPIRATORY_PHASE

See Also

MCdicom Structure
MCdicom Members


STATION_AE_TITLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STATION_AE_TITLE Field
MCdicom Structure See Also Send Feedback
Station AE Title (0008,0055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STATION_AE_TITLE
Visual Basic
Public Const STATION_AE_TITLE As UInteger
Visual C++
public:
literal unsigned int STATION_AE_TITLE

See Also

MCdicom Structure
MCdicom Members


STATION_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STATION_NAME Field
MCdicom Structure See Also Send Feedback
Station Name (0008,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STATION_NAME
Visual Basic
Public Const STATION_NAME As UInteger
Visual C++
public:
literal unsigned int STATION_NAME

See Also

MCdicom Structure
MCdicom Members


STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STATUS Field
MCdicom Structure See Also Send Feedback
Status (0000,0900)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STATUS
Visual Basic
Public Const STATUS As UInteger
Visual C++
public:
literal unsigned int STATUS

See Also

MCdicom Structure
MCdicom Members


STEADY_STATE_PULSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEADY_STATE_PULSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Steady State Pulse Sequence (0018,9017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEADY_STATE_PULSE_SEQUENCE
Visual Basic
Public Const STEADY_STATE_PULSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STEADY_STATE_PULSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STEEP_CORNEAL_AXIS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEEP_CORNEAL_AXIS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Steep Corneal Axis Sequence (0046,0112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEEP_CORNEAL_AXIS_SEQUENCE
Visual Basic
Public Const STEEP_CORNEAL_AXIS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STEEP_CORNEAL_AXIS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STEEP_KERATOMETRIC_AXIS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEEP_KERATOMETRIC_AXIS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Steep Keratometric Axis Sequence (0046,0074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEEP_KERATOMETRIC_AXIS_SEQUENCE
Visual Basic
Public Const STEEP_KERATOMETRIC_AXIS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STEEP_KERATOMETRIC_AXIS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STEERING_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEERING_ANGLE Field
MCdicom Structure See Also Send Feedback
Steering Angle (0018,6036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEERING_ANGLE
Visual Basic
Public Const STEERING_ANGLE As UInteger
Visual C++
public:
literal unsigned int STEERING_ANGLE

See Also

MCdicom Structure
MCdicom Members


STEREO_BASELINE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_BASELINE_ANGLE Field
MCdicom Structure See Also Send Feedback
Stereo Baseline Angle (0022,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_BASELINE_ANGLE
Visual Basic
Public Const STEREO_BASELINE_ANGLE As UInteger
Visual C++
public:
literal unsigned int STEREO_BASELINE_ANGLE

See Also

MCdicom Structure
MCdicom Members


STEREO_BASELINE_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_BASELINE_DISPLACEMENT Field
MCdicom Structure See Also Send Feedback
Stereo Baseline Displacement (0022,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_BASELINE_DISPLACEMENT
Visual Basic
Public Const STEREO_BASELINE_DISPLACEMENT As UInteger
Visual C++
public:
literal unsigned int STEREO_BASELINE_DISPLACEMENT

See Also

MCdicom Structure
MCdicom Members


STEREO_HORIZONTAL_PIXEL_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_HORIZONTAL_PIXEL_OFFSET Field
MCdicom Structure See Also Send Feedback
Stereo Horizontal Pixel Offset (0022,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_HORIZONTAL_PIXEL_OFFSET
Visual Basic
Public Const STEREO_HORIZONTAL_PIXEL_OFFSET As UInteger
Visual C++
public:
literal unsigned int STEREO_HORIZONTAL_PIXEL_OFFSET

See Also

MCdicom Structure
MCdicom Members


STEREO_PAIRS_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_PAIRS_PRESENT Field
MCdicom Structure See Also Send Feedback
Stereo Pairs Present (0022,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_PAIRS_PRESENT
Visual Basic
Public Const STEREO_PAIRS_PRESENT As UInteger
Visual C++
public:
literal unsigned int STEREO_PAIRS_PRESENT

See Also

MCdicom Structure
MCdicom Members


STEREO_PAIRS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_PAIRS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Stereo Pairs Sequence (0022,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_PAIRS_SEQUENCE
Visual Basic
Public Const STEREO_PAIRS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STEREO_PAIRS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STEREO_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_ROTATION Field
MCdicom Structure See Also Send Feedback
Stereo Rotation (0022,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_ROTATION
Visual Basic
Public Const STEREO_ROTATION As UInteger
Visual C++
public:
literal unsigned int STEREO_ROTATION

See Also

MCdicom Structure
MCdicom Members


STEREO_VERTICAL_PIXEL_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STEREO_VERTICAL_PIXEL_OFFSET Field
MCdicom Structure See Also Send Feedback
Stereo Vertical Pixel Offset (0022,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STEREO_VERTICAL_PIXEL_OFFSET
Visual Basic
Public Const STEREO_VERTICAL_PIXEL_OFFSET As UInteger
Visual C++
public:
literal unsigned int STEREO_VERTICAL_PIXEL_OFFSET

See Also

MCdicom Structure
MCdicom Members


STIMULI_RETESTING_QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STIMULI_RETESTING_QUANTITY Field
MCdicom Structure See Also Send Feedback
Stimuli Retesting Quantity (0024,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STIMULI_RETESTING_QUANTITY
Visual Basic
Public Const STIMULI_RETESTING_QUANTITY As UInteger
Visual C++
public:
literal unsigned int STIMULI_RETESTING_QUANTITY

See Also

MCdicom Structure
MCdicom Members


STIMULUS_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STIMULUS_AREA Field
MCdicom Structure See Also Send Feedback
Stimulus Area (0024,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STIMULUS_AREA
Visual Basic
Public Const STIMULUS_AREA As UInteger
Visual C++
public:
literal unsigned int STIMULUS_AREA

See Also

MCdicom Structure
MCdicom Members


STIMULUS_COLOR_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STIMULUS_COLOR_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Stimulus Color Code Sequence (0024,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STIMULUS_COLOR_CODE_SEQUENCE
Visual Basic
Public Const STIMULUS_COLOR_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STIMULUS_COLOR_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STIMULUS_PRESENTATION_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STIMULUS_PRESENTATION_TIME Field
MCdicom Structure See Also Send Feedback
Stimulus Presentation Time (0024,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STIMULUS_PRESENTATION_TIME
Visual Basic
Public Const STIMULUS_PRESENTATION_TIME As UInteger
Visual C++
public:
literal unsigned int STIMULUS_PRESENTATION_TIME

See Also

MCdicom Structure
MCdicom Members


STIMULUS_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STIMULUS_RESULTS Field
MCdicom Structure See Also Send Feedback
Stimulus Results (0024,0093)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STIMULUS_RESULTS
Visual Basic
Public Const STIMULUS_RESULTS As UInteger
Visual C++
public:
literal unsigned int STIMULUS_RESULTS

See Also

MCdicom Structure
MCdicom Members


STOP_CUMULATIVE_METERSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STOP_CUMULATIVE_METERSET Field
MCdicom Structure See Also Send Feedback
Stop Cumulative Meterset (3002,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STOP_CUMULATIVE_METERSET
Visual Basic
Public Const STOP_CUMULATIVE_METERSET As UInteger
Visual C++
public:
literal unsigned int STOP_CUMULATIVE_METERSET

See Also

MCdicom Structure
MCdicom Members


STOP_TRIM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STOP_TRIM Field
MCdicom Structure See Also Send Feedback
Stop Trim (0008,2143)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STOP_TRIM
Visual Basic
Public Const STOP_TRIM As UInteger
Visual C++
public:
literal unsigned int STOP_TRIM

See Also

MCdicom Structure
MCdicom Members


STORAGE_MEDIA_FILE_SET_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORAGE_MEDIA_FILE_SET_ID Field
MCdicom Structure See Also Send Feedback
Storage Media File-set ID (0088,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORAGE_MEDIA_FILE_SET_ID
Visual Basic
Public Const STORAGE_MEDIA_FILE_SET_ID As UInteger
Visual C++
public:
literal unsigned int STORAGE_MEDIA_FILE_SET_ID

See Also

MCdicom Structure
MCdicom Members


STORAGE_MEDIA_FILE_SET_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORAGE_MEDIA_FILE_SET_UID Field
MCdicom Structure See Also Send Feedback
Storage Media File-set UID (0088,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORAGE_MEDIA_FILE_SET_UID
Visual Basic
Public Const STORAGE_MEDIA_FILE_SET_UID As UInteger
Visual C++
public:
literal unsigned int STORAGE_MEDIA_FILE_SET_UID

See Also

MCdicom Structure
MCdicom Members


STORAGE_PROTOCOL_ELEMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORAGE_PROTOCOL_ELEMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Storage Protocol Element Sequence (0018,9936)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORAGE_PROTOCOL_ELEMENT_SEQUENCE
Visual Basic
Public Const STORAGE_PROTOCOL_ELEMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STORAGE_PROTOCOL_ELEMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Storage Protocol Element Specification Sequence (0018,9935)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE
Visual Basic
Public Const STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STORAGE_PROTOCOL_ELEMENT_SPECIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STORAGE_URL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORAGE_URL Field
MCdicom Structure See Also Send Feedback
Storage URL (0040,4073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORAGE_URL
Visual Basic
Public Const STORAGE_URL As UInteger
Visual C++
public:
literal unsigned int STORAGE_URL

See Also

MCdicom Structure
MCdicom Members


STORED_INSTANCE_BASE_URI Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORED_INSTANCE_BASE_URI Field
MCdicom Structure See Also Send Feedback
Stored Instance Base URI (0008,0407)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORED_INSTANCE_BASE_URI
Visual Basic
Public Const STORED_INSTANCE_BASE_URI As UInteger
Visual C++
public:
literal unsigned int STORED_INSTANCE_BASE_URI

See Also

MCdicom Structure
MCdicom Members


STORED_INSTANCE_TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORED_INSTANCE_TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
Stored Instance Transfer Syntax UID (0008,040E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORED_INSTANCE_TRANSFER_SYNTAX_UID
Visual Basic
Public Const STORED_INSTANCE_TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int STORED_INSTANCE_TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


STORED_VALUE_COLOR_RANGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STORED_VALUE_COLOR_RANGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Stored Value Color Range Sequence (0028,1230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STORED_VALUE_COLOR_RANGE_SEQUENCE
Visual Basic
Public Const STORED_VALUE_COLOR_RANGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STORED_VALUE_COLOR_RANGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STOW_RS_STORAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STOW_RS_STORAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
STOW-RS Storage Sequence (0040,4072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STOW_RS_STORAGE_SEQUENCE
Visual Basic
Public Const STOW_RS_STORAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STOW_RS_STORAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRAIN_ADDITIONAL_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_ADDITIONAL_INFORMATION Field
MCdicom Structure See Also Send Feedback
Strain Additional Information (0010,0218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_ADDITIONAL_INFORMATION
Visual Basic
Public Const STRAIN_ADDITIONAL_INFORMATION As UInteger
Visual C++
public:
literal unsigned int STRAIN_ADDITIONAL_INFORMATION

See Also

MCdicom Structure
MCdicom Members


STRAIN_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Strain Code Sequence (0010,0219)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_CODE_SEQUENCE
Visual Basic
Public Const STRAIN_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRAIN_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRAIN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Strain Description (0010,0212)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_DESCRIPTION
Visual Basic
Public Const STRAIN_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int STRAIN_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


STRAIN_NOMENCLATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_NOMENCLATURE Field
MCdicom Structure See Also Send Feedback
Strain Nomenclature (0010,0213)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_NOMENCLATURE
Visual Basic
Public Const STRAIN_NOMENCLATURE As UInteger
Visual C++
public:
literal unsigned int STRAIN_NOMENCLATURE

See Also

MCdicom Structure
MCdicom Members


STRAIN_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_SOURCE Field
MCdicom Structure See Also Send Feedback
Strain Source (0010,0217)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_SOURCE
Visual Basic
Public Const STRAIN_SOURCE As UInteger
Visual C++
public:
literal unsigned int STRAIN_SOURCE

See Also

MCdicom Structure
MCdicom Members


STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Strain Source Registry Code Sequence (0010,0215)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE
Visual Basic
Public Const STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRAIN_SOURCE_REGISTRY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRAIN_STOCK_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_STOCK_NUMBER Field
MCdicom Structure See Also Send Feedback
Strain Stock Number (0010,0214)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_STOCK_NUMBER
Visual Basic
Public Const STRAIN_STOCK_NUMBER As UInteger
Visual C++
public:
literal unsigned int STRAIN_STOCK_NUMBER

See Also

MCdicom Structure
MCdicom Members


STRAIN_STOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRAIN_STOCK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Strain Stock Sequence (0010,0216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRAIN_STOCK_SEQUENCE
Visual Basic
Public Const STRAIN_STOCK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRAIN_STOCK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_DATE Field
MCdicom Structure See Also Send Feedback
Structure Set Date (3006,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_DATE
Visual Basic
Public Const STRUCTURE_SET_DATE As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_DATE

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Structure Set Description (3006,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_DESCRIPTION
Visual Basic
Public Const STRUCTURE_SET_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_LABEL Field
MCdicom Structure See Also Send Feedback
Structure Set Label (3006,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_LABEL
Visual Basic
Public Const STRUCTURE_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_NAME Field
MCdicom Structure See Also Send Feedback
Structure Set Name (3006,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_NAME
Visual Basic
Public Const STRUCTURE_SET_NAME As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_NAME

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Structure Set ROI Sequence (3006,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_ROI_SEQUENCE
Visual Basic
Public Const STRUCTURE_SET_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRUCTURE_SET_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURE_SET_TIME Field
MCdicom Structure See Also Send Feedback
Structure Set Time (3006,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURE_SET_TIME
Visual Basic
Public Const STRUCTURE_SET_TIME As UInteger
Visual C++
public:
literal unsigned int STRUCTURE_SET_TIME

See Also

MCdicom Structure
MCdicom Members


STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Structured Constraint Observation Sequence (0082,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE
Visual Basic
Public Const STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRUCTURED_CONSTRAINT_OBSERVATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Structured Display Background CIELab Value (0072,0420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE
Visual Basic
Public Const STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int STRUCTURED_DISPLAY_BACKGROUND_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Structured Display Image Box Sequence (0072,0422)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE
Visual Basic
Public Const STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRUCTURED_DISPLAY_IMAGE_BOX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Structured Display Text Box Sequence (0072,0424)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE
Visual Basic
Public Const STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STRUCTURED_DISPLAY_TEXT_BOX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Studies Containing Other Referenced Instances Sequence (0008,1200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE
Visual Basic
Public Const STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STUDIES_CONTAINING_OTHER_REFERENCED_INSTANCES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STUDY_ACCESS_END_POINTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_ACCESS_END_POINTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Study Access End Points Sequence (0008,0421)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_ACCESS_END_POINTS_SEQUENCE
Visual Basic
Public Const STUDY_ACCESS_END_POINTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int STUDY_ACCESS_END_POINTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


STUDY_ARRIVAL_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_ARRIVAL_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Arrival Date RETIRED (0032,1040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_ARRIVAL_DATE_RETIRED
Visual Basic
Public Const STUDY_ARRIVAL_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_ARRIVAL_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_ARRIVAL_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_ARRIVAL_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Arrival Time RETIRED (0032,1041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_ARRIVAL_TIME_RETIRED
Visual Basic
Public Const STUDY_ARRIVAL_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_ARRIVAL_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Comments RETIRED (0032,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_COMMENTS_RETIRED
Visual Basic
Public Const STUDY_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_COMPLETION_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_COMPLETION_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Completion Date RETIRED (0032,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_COMPLETION_DATE_RETIRED
Visual Basic
Public Const STUDY_COMPLETION_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_COMPLETION_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_COMPLETION_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_COMPLETION_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Completion Time RETIRED (0032,1051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_COMPLETION_TIME_RETIRED
Visual Basic
Public Const STUDY_COMPLETION_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_COMPLETION_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_COMPONENT_STATUS_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_COMPONENT_STATUS_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Component Status ID RETIRED (0032,1055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_COMPONENT_STATUS_ID_RETIRED
Visual Basic
Public Const STUDY_COMPONENT_STATUS_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_COMPONENT_STATUS_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_DATE Field
MCdicom Structure See Also Send Feedback
Study Date (0008,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_DATE
Visual Basic
Public Const STUDY_DATE As UInteger
Visual C++
public:
literal unsigned int STUDY_DATE

See Also

MCdicom Structure
MCdicom Members


STUDY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Study Description (0008,1030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_DESCRIPTION
Visual Basic
Public Const STUDY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int STUDY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


STUDY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_ID Field
MCdicom Structure See Also Send Feedback
Study ID (0020,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_ID
Visual Basic
Public Const STUDY_ID As UInteger
Visual C++
public:
literal unsigned int STUDY_ID

See Also

MCdicom Structure
MCdicom Members


STUDY_ID_ISSUER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_ID_ISSUER_RETIRED Field
MCdicom Structure See Also Send Feedback
Study ID Issuer RETIRED (0032,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_ID_ISSUER_RETIRED
Visual Basic
Public Const STUDY_ID_ISSUER_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_ID_ISSUER_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_INSTANCE_UID Field
MCdicom Structure See Also Send Feedback
Study Instance UID (0020,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_INSTANCE_UID
Visual Basic
Public Const STUDY_INSTANCE_UID As UInteger
Visual C++
public:
literal unsigned int STUDY_INSTANCE_UID

See Also

MCdicom Structure
MCdicom Members


STUDY_PRIORITY_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_PRIORITY_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Priority ID RETIRED (0032,000C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_PRIORITY_ID_RETIRED
Visual Basic
Public Const STUDY_PRIORITY_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_PRIORITY_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_READ_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_READ_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Read Date RETIRED (0032,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_READ_DATE_RETIRED
Visual Basic
Public Const STUDY_READ_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_READ_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_READ_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_READ_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Read Time RETIRED (0032,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_READ_TIME_RETIRED
Visual Basic
Public Const STUDY_READ_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_READ_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_STATUS_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_STATUS_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Status ID RETIRED (0032,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_STATUS_ID_RETIRED
Visual Basic
Public Const STUDY_STATUS_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_STATUS_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_TIME Field
MCdicom Structure See Also Send Feedback
Study Time (0008,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_TIME
Visual Basic
Public Const STUDY_TIME As UInteger
Visual C++
public:
literal unsigned int STUDY_TIME

See Also

MCdicom Structure
MCdicom Members


STUDY_UPDATE_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_UPDATE_DATETIME Field
MCdicom Structure See Also Send Feedback
Study Update DateTime (0008,041F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_UPDATE_DATETIME
Visual Basic
Public Const STUDY_UPDATE_DATETIME As UInteger
Visual C++
public:
literal unsigned int STUDY_UPDATE_DATETIME

See Also

MCdicom Structure
MCdicom Members


STUDY_VERIFIED_DATE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_VERIFIED_DATE_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Verified Date RETIRED (0032,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_VERIFIED_DATE_RETIRED
Visual Basic
Public Const STUDY_VERIFIED_DATE_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_VERIFIED_DATE_RETIRED

See Also

MCdicom Structure
MCdicom Members


STUDY_VERIFIED_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..STUDY_VERIFIED_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Study Verified Time RETIRED (0032,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint STUDY_VERIFIED_TIME_RETIRED
Visual Basic
Public Const STUDY_VERIFIED_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int STUDY_VERIFIED_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


SUBJECT_AREA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECT_AREA Field
MCdicom Structure See Also Send Feedback
Subject Area (0016,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECT_AREA
Visual Basic
Public Const SUBJECT_AREA As UInteger
Visual C++
public:
literal unsigned int SUBJECT_AREA

See Also

MCdicom Structure
MCdicom Members


SUBJECT_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECT_DISTANCE Field
MCdicom Structure See Also Send Feedback
Subject Distance (0016,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECT_DISTANCE
Visual Basic
Public Const SUBJECT_DISTANCE As UInteger
Visual C++
public:
literal unsigned int SUBJECT_DISTANCE

See Also

MCdicom Structure
MCdicom Members


SUBJECT_DISTANCE_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECT_DISTANCE_RANGE Field
MCdicom Structure See Also Send Feedback
Subject Distance Range (0016,004C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECT_DISTANCE_RANGE
Visual Basic
Public Const SUBJECT_DISTANCE_RANGE As UInteger
Visual C++
public:
literal unsigned int SUBJECT_DISTANCE_RANGE

See Also

MCdicom Structure
MCdicom Members


SUBJECT_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECT_LOCATION Field
MCdicom Structure See Also Send Feedback
Subject Location (0016,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECT_LOCATION
Visual Basic
Public Const SUBJECT_LOCATION As UInteger
Visual C++
public:
literal unsigned int SUBJECT_LOCATION

See Also

MCdicom Structure
MCdicom Members


SUBJECT_RELATIVE_POSITION_IN_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECT_RELATIVE_POSITION_IN_IMAGE Field
MCdicom Structure See Also Send Feedback
Subject Relative Position in Image (0010,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECT_RELATIVE_POSITION_IN_IMAGE
Visual Basic
Public Const SUBJECT_RELATIVE_POSITION_IN_IMAGE As UInteger
Visual C++
public:
literal unsigned int SUBJECT_RELATIVE_POSITION_IN_IMAGE

See Also

MCdicom Structure
MCdicom Members


SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Subjective Refraction Left Eye Sequence (0046,0098)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE
Visual Basic
Public Const SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUBJECTIVE_REFRACTION_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Subjective Refraction Right Eye Sequence (0046,0097)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUBJECTIVE_REFRACTION_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUBSCRIPTION_LIST_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSCRIPTION_LIST_STATUS Field
MCdicom Structure See Also Send Feedback
Subscription List Status (0074,1244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSCRIPTION_LIST_STATUS
Visual Basic
Public Const SUBSCRIPTION_LIST_STATUS As UInteger
Visual C++
public:
literal unsigned int SUBSCRIPTION_LIST_STATUS

See Also

MCdicom Structure
MCdicom Members


SUBSTANCE_ADMINISTRATION_APPROVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSTANCE_ADMINISTRATION_APPROVAL Field
MCdicom Structure See Also Send Feedback
Substance Administration Approval (0044,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSTANCE_ADMINISTRATION_APPROVAL
Visual Basic
Public Const SUBSTANCE_ADMINISTRATION_APPROVAL As UInteger
Visual C++
public:
literal unsigned int SUBSTANCE_ADMINISTRATION_APPROVAL

See Also

MCdicom Structure
MCdicom Members


SUBSTANCE_ADMINISTRATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSTANCE_ADMINISTRATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Substance Administration DateTime (0044,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSTANCE_ADMINISTRATION_DATETIME
Visual Basic
Public Const SUBSTANCE_ADMINISTRATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int SUBSTANCE_ADMINISTRATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


SUBSTANCE_ADMINISTRATION_DEVICE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSTANCE_ADMINISTRATION_DEVICE_ID Field
MCdicom Structure See Also Send Feedback
Substance Administration Device ID (0044,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSTANCE_ADMINISTRATION_DEVICE_ID
Visual Basic
Public Const SUBSTANCE_ADMINISTRATION_DEVICE_ID As UInteger
Visual C++
public:
literal unsigned int SUBSTANCE_ADMINISTRATION_DEVICE_ID

See Also

MCdicom Structure
MCdicom Members


SUBSTANCE_ADMINISTRATION_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSTANCE_ADMINISTRATION_NOTES Field
MCdicom Structure See Also Send Feedback
Substance Administration Notes (0044,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSTANCE_ADMINISTRATION_NOTES
Visual Basic
Public Const SUBSTANCE_ADMINISTRATION_NOTES As UInteger
Visual C++
public:
literal unsigned int SUBSTANCE_ADMINISTRATION_NOTES

See Also

MCdicom Structure
MCdicom Members


SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Substance Administration Parameter Sequence (0044,0019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE
Visual Basic
Public Const SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUBSTANCE_ADMINISTRATION_PARAMETER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUBTASK_WORKITEM_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBTASK_WORKITEM_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Subtask Workitem Code Sequence (3002,011B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBTASK_WORKITEM_CODE_SEQUENCE
Visual Basic
Public Const SUBTASK_WORKITEM_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUBTASK_WORKITEM_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUBTRACTION_ITEM_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUBTRACTION_ITEM_ID Field
MCdicom Structure See Also Send Feedback
Subtraction Item ID (0028,9416)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUBTRACTION_ITEM_ID
Visual Basic
Public Const SUBTRACTION_ITEM_ID As UInteger
Visual C++
public:
literal unsigned int SUBTRACTION_ITEM_ID

See Also

MCdicom Structure
MCdicom Members


SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Summarized Filter Lookup Table Sequence (003A,0320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE
Visual Basic
Public Const SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUMMARIZED_FILTER_LOOKUP_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Supported Image Display Formats Sequence (2000,00A8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE
Visual Basic
Public Const SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SUPPORTED_IMAGE_DISPLAY_FORMATS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_ASYMMETRY_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_ASYMMETRY_INDEX Field
MCdicom Structure See Also Send Feedback
Surface Asymmetry Index (0046,0232)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_ASYMMETRY_INDEX
Visual Basic
Public Const SURFACE_ASYMMETRY_INDEX As UInteger
Visual C++
public:
literal unsigned int SURFACE_ASYMMETRY_INDEX

See Also

MCdicom Structure
MCdicom Members


SURFACE_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_COMMENTS Field
MCdicom Structure See Also Send Feedback
Surface Comments (0066,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_COMMENTS
Visual Basic
Public Const SURFACE_COMMENTS As UInteger
Visual C++
public:
literal unsigned int SURFACE_COMMENTS

See Also

MCdicom Structure
MCdicom Members


SURFACE_COUNT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_COUNT Field
MCdicom Structure See Also Send Feedback
Surface Count (0066,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_COUNT
Visual Basic
Public Const SURFACE_COUNT As UInteger
Visual C++
public:
literal unsigned int SURFACE_COUNT

See Also

MCdicom Structure
MCdicom Members


SURFACE_ENTRY_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_ENTRY_POINT Field
MCdicom Structure See Also Send Feedback
Surface Entry Point (300A,012E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_ENTRY_POINT
Visual Basic
Public Const SURFACE_ENTRY_POINT As UInteger
Visual C++
public:
literal unsigned int SURFACE_ENTRY_POINT

See Also

MCdicom Structure
MCdicom Members


SURFACE_MESH_PRIMITIVES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_MESH_PRIMITIVES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Mesh Primitives Sequence (0066,0013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_MESH_PRIMITIVES_SEQUENCE
Visual Basic
Public Const SURFACE_MESH_PRIMITIVES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_MESH_PRIMITIVES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_MESH_Z_PIXEL_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_MESH_Z_PIXEL_OFFSET Field
MCdicom Structure See Also Send Feedback
Surface Mesh Z-Pixel Offset (0022,1658)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_MESH_Z_PIXEL_OFFSET
Visual Basic
Public Const SURFACE_MESH_Z_PIXEL_OFFSET As UInteger
Visual C++
public:
literal unsigned int SURFACE_MESH_Z_PIXEL_OFFSET

See Also

MCdicom Structure
MCdicom Members


SURFACE_MODEL_DESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_MODEL_DESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Model Description Sequence (0068,6360)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_MODEL_DESCRIPTION_SEQUENCE
Visual Basic
Public Const SURFACE_MODEL_DESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_MODEL_DESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_MODEL_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_MODEL_LABEL Field
MCdicom Structure See Also Send Feedback
Surface Model Label (0068,6380)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_MODEL_LABEL
Visual Basic
Public Const SURFACE_MODEL_LABEL As UInteger
Visual C++
public:
literal unsigned int SURFACE_MODEL_LABEL

See Also

MCdicom Structure
MCdicom Members


SURFACE_MODEL_SCALING_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_MODEL_SCALING_FACTOR Field
MCdicom Structure See Also Send Feedback
Surface Model Scaling Factor (0068,6390)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_MODEL_SCALING_FACTOR
Visual Basic
Public Const SURFACE_MODEL_SCALING_FACTOR As UInteger
Visual C++
public:
literal unsigned int SURFACE_MODEL_SCALING_FACTOR

See Also

MCdicom Structure
MCdicom Members


SURFACE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_NUMBER Field
MCdicom Structure See Also Send Feedback
Surface Number (0066,0003)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_NUMBER
Visual Basic
Public Const SURFACE_NUMBER As UInteger
Visual C++
public:
literal unsigned int SURFACE_NUMBER

See Also

MCdicom Structure
MCdicom Members


SURFACE_POINT_COLOR_CIELAB_VALUE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_POINT_COLOR_CIELAB_VALUE_DATA Field
MCdicom Structure See Also Send Feedback
Surface Point Color CIELab Value Data (0080,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_POINT_COLOR_CIELAB_VALUE_DATA
Visual Basic
Public Const SURFACE_POINT_COLOR_CIELAB_VALUE_DATA As UInteger
Visual C++
public:
literal unsigned int SURFACE_POINT_COLOR_CIELAB_VALUE_DATA

See Also

MCdicom Structure
MCdicom Members


SURFACE_POINT_PRESENTATION_VALUE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_POINT_PRESENTATION_VALUE_DATA Field
MCdicom Structure See Also Send Feedback
Surface Point Presentation Value Data (0080,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_POINT_PRESENTATION_VALUE_DATA
Visual Basic
Public Const SURFACE_POINT_PRESENTATION_VALUE_DATA As UInteger
Visual C++
public:
literal unsigned int SURFACE_POINT_PRESENTATION_VALUE_DATA

See Also

MCdicom Structure
MCdicom Members


SURFACE_POINTS_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_POINTS_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Points Normals Sequence (0066,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_POINTS_NORMALS_SEQUENCE
Visual Basic
Public Const SURFACE_POINTS_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_POINTS_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_POINTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_POINTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Points Sequence (0066,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_POINTS_SEQUENCE
Visual Basic
Public Const SURFACE_POINTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_POINTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_PROCESSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_PROCESSING Field
MCdicom Structure See Also Send Feedback
Surface Processing (0066,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_PROCESSING
Visual Basic
Public Const SURFACE_PROCESSING As UInteger
Visual C++
public:
literal unsigned int SURFACE_PROCESSING

See Also

MCdicom Structure
MCdicom Members


SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Processing Algorithm Identification Sequence (0066,0035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_PROCESSING_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_PROCESSING_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_PROCESSING_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Surface Processing Description (0066,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_PROCESSING_DESCRIPTION
Visual Basic
Public Const SURFACE_PROCESSING_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int SURFACE_PROCESSING_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


SURFACE_PROCESSING_RATIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_PROCESSING_RATIO Field
MCdicom Structure See Also Send Feedback
Surface Processing Ratio (0066,000A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_PROCESSING_RATIO
Visual Basic
Public Const SURFACE_PROCESSING_RATIO As UInteger
Visual C++
public:
literal unsigned int SURFACE_PROCESSING_RATIO

See Also

MCdicom Structure
MCdicom Members


SURFACE_REGULARITY_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_REGULARITY_INDEX Field
MCdicom Structure See Also Send Feedback
Surface Regularity Index (0046,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_REGULARITY_INDEX
Visual Basic
Public Const SURFACE_REGULARITY_INDEX As UInteger
Visual C++
public:
literal unsigned int SURFACE_REGULARITY_INDEX

See Also

MCdicom Structure
MCdicom Members


SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Scan Acquisition Type Code Sequence (0080,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_SCAN_ACQUISITION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_SCAN_MODE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_SCAN_MODE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Scan Mode Code Sequence (0080,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_SCAN_MODE_CODE_SEQUENCE
Visual Basic
Public Const SURFACE_SCAN_MODE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_SCAN_MODE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURFACE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURFACE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surface Sequence (0066,0002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURFACE_SEQUENCE
Visual Basic
Public Const SURFACE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURFACE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SURGICAL_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURGICAL_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Surgical Technique (0076,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURGICAL_TECHNIQUE
Visual Basic
Public Const SURGICAL_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int SURGICAL_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Surgically Induced Astigmatism Sequence (0022,1045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE
Visual Basic
Public Const SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SURGICALLY_INDUCED_ASTIGMATISM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SUV_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SUV_TYPE Field
MCdicom Structure See Also Send Feedback
SUV Type (0054,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SUV_TYPE
Visual Basic
Public Const SUV_TYPE As UInteger
Visual C++
public:
literal unsigned int SUV_TYPE

See Also

MCdicom Structure
MCdicom Members


SWITCHING_PHASE_NOMINAL_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SWITCHING_PHASE_NOMINAL_DURATION Field
MCdicom Structure See Also Send Feedback
Switching Phase Nominal Duration (0018,936C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SWITCHING_PHASE_NOMINAL_DURATION
Visual Basic
Public Const SWITCHING_PHASE_NOMINAL_DURATION As UInteger
Visual C++
public:
literal unsigned int SWITCHING_PHASE_NOMINAL_DURATION

See Also

MCdicom Structure
MCdicom Members


SWITCHING_PHASE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SWITCHING_PHASE_NUMBER Field
MCdicom Structure See Also Send Feedback
Switching Phase Number (0018,936B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SWITCHING_PHASE_NUMBER
Visual Basic
Public Const SWITCHING_PHASE_NUMBER As UInteger
Visual C++
public:
literal unsigned int SWITCHING_PHASE_NUMBER

See Also

MCdicom Structure
MCdicom Members


SWITCHING_PHASE_TRANSITION_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SWITCHING_PHASE_TRANSITION_DURATION Field
MCdicom Structure See Also Send Feedback
Switching Phase Transition Duration (0018,936D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SWITCHING_PHASE_TRANSITION_DURATION
Visual Basic
Public Const SWITCHING_PHASE_TRANSITION_DURATION As UInteger
Visual C++
public:
literal unsigned int SWITCHING_PHASE_TRANSITION_DURATION

See Also

MCdicom Structure
MCdicom Members


SWIVEL_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SWIVEL_RANGE Field
MCdicom Structure See Also Send Feedback
Swivel Range (0070,1A06)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SWIVEL_RANGE
Visual Basic
Public Const SWIVEL_RANGE As UInteger
Visual C++
public:
literal unsigned int SWIVEL_RANGE

See Also

MCdicom Structure
MCdicom Members


SYNCHRONIZATION_CHANNEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYNCHRONIZATION_CHANNEL Field
MCdicom Structure See Also Send Feedback
Synchronization Channel (0018,106C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYNCHRONIZATION_CHANNEL
Visual Basic
Public Const SYNCHRONIZATION_CHANNEL As UInteger
Visual C++
public:
literal unsigned int SYNCHRONIZATION_CHANNEL

See Also

MCdicom Structure
MCdicom Members


SYNCHRONIZATION_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYNCHRONIZATION_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Synchronization Frame of Reference UID (0020,0200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYNCHRONIZATION_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const SYNCHRONIZATION_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int SYNCHRONIZATION_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


SYNCHRONIZATION_TRIGGER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYNCHRONIZATION_TRIGGER Field
MCdicom Structure See Also Send Feedback
Synchronization Trigger (0018,106A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYNCHRONIZATION_TRIGGER
Visual Basic
Public Const SYNCHRONIZATION_TRIGGER As UInteger
Visual C++
public:
literal unsigned int SYNCHRONIZATION_TRIGGER

See Also

MCdicom Structure
MCdicom Members


SYNCHRONIZED_IMAGE_BOX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYNCHRONIZED_IMAGE_BOX_LIST Field
MCdicom Structure See Also Send Feedback
Synchronized Image Box List (0072,0432)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYNCHRONIZED_IMAGE_BOX_LIST
Visual Basic
Public Const SYNCHRONIZED_IMAGE_BOX_LIST As UInteger
Visual C++
public:
literal unsigned int SYNCHRONIZED_IMAGE_BOX_LIST

See Also

MCdicom Structure
MCdicom Members


SYNCHRONIZED_SCROLLING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYNCHRONIZED_SCROLLING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Synchronized Scrolling Sequence (0072,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYNCHRONIZED_SCROLLING_SEQUENCE
Visual Basic
Public Const SYNCHRONIZED_SCROLLING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int SYNCHRONIZED_SCROLLING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


SYRINGE_COUNTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYRINGE_COUNTS Field
MCdicom Structure See Also Send Feedback
Syringe Counts (0018,1045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYRINGE_COUNTS
Visual Basic
Public Const SYRINGE_COUNTS As UInteger
Visual C++
public:
literal unsigned int SYRINGE_COUNTS

See Also

MCdicom Structure
MCdicom Members


SYSTEM_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYSTEM_STATUS Field
MCdicom Structure See Also Send Feedback
System Status (0028,7006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYSTEM_STATUS
Visual Basic
Public Const SYSTEM_STATUS As UInteger
Visual C++
public:
literal unsigned int SYSTEM_STATUS

See Also

MCdicom Structure
MCdicom Members


SYSTEM_STATUS_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..SYSTEM_STATUS_COMMENT Field
MCdicom Structure See Also Send Feedback
System Status Comment (0028,7007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint SYSTEM_STATUS_COMMENT
Visual Basic
Public Const SYSTEM_STATUS_COMMENT As UInteger
Visual C++
public:
literal unsigned int SYSTEM_STATUS_COMMENT

See Also

MCdicom Structure
MCdicom Members


T2_PREPARATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..T2_PREPARATION Field
MCdicom Structure See Also Send Feedback
T2 Preparation (0018,9021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint T2_PREPARATION
Visual Basic
Public Const T2_PREPARATION As UInteger
Visual C++
public:
literal unsigned int T2_PREPARATION

See Also

MCdicom Structure
MCdicom Members


TABLE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Angle (0018,1138)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_ANGLE
Visual Basic
Public Const TABLE_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_COLUMN_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_COLUMN_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Table Column Definition Sequence (0040,A807)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_COLUMN_DEFINITION_SEQUENCE
Visual Basic
Public Const TABLE_COLUMN_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TABLE_COLUMN_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TABLE_COLUMN_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_COLUMN_NUMBER Field
MCdicom Structure See Also Send Feedback
Table Column Number (0040,A805)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_COLUMN_NUMBER
Visual Basic
Public Const TABLE_COLUMN_NUMBER As UInteger
Visual C++
public:
literal unsigned int TABLE_COLUMN_NUMBER

See Also

MCdicom Structure
MCdicom Members


TABLE_CRADLE_TILT_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_CRADLE_TILT_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Cradle Tilt Angle (0018,9471)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_CRADLE_TILT_ANGLE
Visual Basic
Public Const TABLE_CRADLE_TILT_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_CRADLE_TILT_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_FEED_PER_ROTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_FEED_PER_ROTATION Field
MCdicom Structure See Also Send Feedback
Table Feed per Rotation (0018,9310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_FEED_PER_ROTATION
Visual Basic
Public Const TABLE_FEED_PER_ROTATION As UInteger
Visual C++
public:
literal unsigned int TABLE_FEED_PER_ROTATION

See Also

MCdicom Structure
MCdicom Members


TABLE_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Table Frame of Reference UID (0020,9313)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const TABLE_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int TABLE_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


TABLE_HEAD_TILT_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_HEAD_TILT_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Head Tilt Angle (0018,9470)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_HEAD_TILT_ANGLE
Visual Basic
Public Const TABLE_HEAD_TILT_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_HEAD_TILT_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_HEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_HEIGHT Field
MCdicom Structure See Also Send Feedback
Table Height (0018,1130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_HEIGHT
Visual Basic
Public Const TABLE_HEIGHT As UInteger
Visual C++
public:
literal unsigned int TABLE_HEIGHT

See Also

MCdicom Structure
MCdicom Members


TABLE_HORIZONTAL_ROTATION_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_HORIZONTAL_ROTATION_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Horizontal Rotation Angle (0018,9469)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_HORIZONTAL_ROTATION_ANGLE
Visual Basic
Public Const TABLE_HORIZONTAL_ROTATION_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_HORIZONTAL_ROTATION_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_LATERAL_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_LATERAL_INCREMENT Field
MCdicom Structure See Also Send Feedback
Table Lateral Increment (0018,1136)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_LATERAL_INCREMENT
Visual Basic
Public Const TABLE_LATERAL_INCREMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_LATERAL_INCREMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_LONGITUDINAL_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_LONGITUDINAL_INCREMENT Field
MCdicom Structure See Also Send Feedback
Table Longitudinal Increment (0018,1137)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_LONGITUDINAL_INCREMENT
Visual Basic
Public Const TABLE_LONGITUDINAL_INCREMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_LONGITUDINAL_INCREMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_MOTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_MOTION Field
MCdicom Structure See Also Send Feedback
Table Motion (0018,1134)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_MOTION
Visual Basic
Public Const TABLE_MOTION As UInteger
Visual C++
public:
literal unsigned int TABLE_MOTION

See Also

MCdicom Structure
MCdicom Members


TABLE_OF_PARAMETER_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_OF_PARAMETER_VALUES Field
MCdicom Structure See Also Send Feedback
Table of Parameter Values (0018,605A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_OF_PARAMETER_VALUES
Visual Basic
Public Const TABLE_OF_PARAMETER_VALUES As UInteger
Visual C++
public:
literal unsigned int TABLE_OF_PARAMETER_VALUES

See Also

MCdicom Structure
MCdicom Members


TABLE_OF_PIXEL_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_OF_PIXEL_VALUES Field
MCdicom Structure See Also Send Feedback
Table of Pixel Values (0018,6058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_OF_PIXEL_VALUES
Visual Basic
Public Const TABLE_OF_PIXEL_VALUES As UInteger
Visual C++
public:
literal unsigned int TABLE_OF_PIXEL_VALUES

See Also

MCdicom Structure
MCdicom Members


TABLE_OF_X_BREAK_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_OF_X_BREAK_POINTS Field
MCdicom Structure See Also Send Feedback
Table of X Break Points (0018,6052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_OF_X_BREAK_POINTS
Visual Basic
Public Const TABLE_OF_X_BREAK_POINTS As UInteger
Visual C++
public:
literal unsigned int TABLE_OF_X_BREAK_POINTS

See Also

MCdicom Structure
MCdicom Members


TABLE_OF_Y_BREAK_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_OF_Y_BREAK_POINTS Field
MCdicom Structure See Also Send Feedback
Table of Y Break Points (0018,6054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_OF_Y_BREAK_POINTS
Visual Basic
Public Const TABLE_OF_Y_BREAK_POINTS As UInteger
Visual C++
public:
literal unsigned int TABLE_OF_Y_BREAK_POINTS

See Also

MCdicom Structure
MCdicom Members


TABLE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_POSITION Field
MCdicom Structure See Also Send Feedback
Table Position (0018,9327)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_POSITION
Visual Basic
Public Const TABLE_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Table Position Sequence (0018,9406)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_POSITION_SEQUENCE
Visual Basic
Public Const TABLE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TABLE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TABLE_ROW_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_ROW_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Table Row Definition Sequence (0040,A806)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_ROW_DEFINITION_SEQUENCE
Visual Basic
Public Const TABLE_ROW_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TABLE_ROW_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TABLE_ROW_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_ROW_NUMBER Field
MCdicom Structure See Also Send Feedback
Table Row Number (0040,A804)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_ROW_NUMBER
Visual Basic
Public Const TABLE_ROW_NUMBER As UInteger
Visual C++
public:
literal unsigned int TABLE_ROW_NUMBER

See Also

MCdicom Structure
MCdicom Members


TABLE_SPEED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_SPEED Field
MCdicom Structure See Also Send Feedback
Table Speed (0018,9309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_SPEED
Visual Basic
Public Const TABLE_SPEED As UInteger
Visual C++
public:
literal unsigned int TABLE_SPEED

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Eccentric Adjusted Angle (0074,102B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE
Visual Basic
Public Const TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ECCENTRIC_ADJUSTED_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ECCENTRIC_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ECCENTRIC_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Eccentric Angle (300A,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ECCENTRIC_ANGLE
Visual Basic
Public Const TABLE_TOP_ECCENTRIC_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ECCENTRIC_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Eccentric Angle Tolerance (300A,004E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE
Visual Basic
Public Const TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ECCENTRIC_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ECCENTRIC_AXIS_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ECCENTRIC_AXIS_DISTANCE Field
MCdicom Structure See Also Send Feedback
Table Top Eccentric Axis Distance (300A,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ECCENTRIC_AXIS_DISTANCE
Visual Basic
Public Const TABLE_TOP_ECCENTRIC_AXIS_DISTANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ECCENTRIC_AXIS_DISTANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Table Top Eccentric Rotation Direction (300A,0126)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION
Visual Basic
Public Const TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ECCENTRIC_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LATERAL_ADJUSTED_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LATERAL_ADJUSTED_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Lateral Adjusted Position (0074,1028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LATERAL_ADJUSTED_POSITION
Visual Basic
Public Const TABLE_TOP_LATERAL_ADJUSTED_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LATERAL_ADJUSTED_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LATERAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LATERAL_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Lateral Position (300A,012A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LATERAL_POSITION
Visual Basic
Public Const TABLE_TOP_LATERAL_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LATERAL_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LATERAL_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LATERAL_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Lateral Position Tolerance (300A,0053)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LATERAL_POSITION_TOLERANCE
Visual Basic
Public Const TABLE_TOP_LATERAL_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LATERAL_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LATERAL_SETUP_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LATERAL_SETUP_DISPLACEMENT Field
MCdicom Structure See Also Send Feedback
Table Top Lateral Setup Displacement (300A,01D6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LATERAL_SETUP_DISPLACEMENT
Visual Basic
Public Const TABLE_TOP_LATERAL_SETUP_DISPLACEMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LATERAL_SETUP_DISPLACEMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Longitudinal Adjusted Position (0074,1027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION
Visual Basic
Public Const TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LONGITUDINAL_ADJUSTED_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LONGITUDINAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LONGITUDINAL_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Longitudinal Position (300A,0129)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LONGITUDINAL_POSITION
Visual Basic
Public Const TABLE_TOP_LONGITUDINAL_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LONGITUDINAL_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Longitudinal Position Tolerance (300A,0052)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE
Visual Basic
Public Const TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LONGITUDINAL_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT Field
MCdicom Structure See Also Send Feedback
Table Top Longitudinal Setup Displacement (300A,01D4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT
Visual Basic
Public Const TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_LONGITUDINAL_SETUP_DISPLACEMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_PITCH_ADJUSTED_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_PITCH_ADJUSTED_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Pitch Adjusted Angle (0074,102C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_PITCH_ADJUSTED_ANGLE
Visual Basic
Public Const TABLE_TOP_PITCH_ADJUSTED_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_PITCH_ADJUSTED_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_PITCH_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_PITCH_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Pitch Angle (300A,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_PITCH_ANGLE
Visual Basic
Public Const TABLE_TOP_PITCH_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_PITCH_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_PITCH_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_PITCH_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Pitch Angle Tolerance (300A,004F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_PITCH_ANGLE_TOLERANCE
Visual Basic
Public Const TABLE_TOP_PITCH_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_PITCH_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_PITCH_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_PITCH_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Table Top Pitch Rotation Direction (300A,0142)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_PITCH_ROTATION_DIRECTION
Visual Basic
Public Const TABLE_TOP_PITCH_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_PITCH_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ROLL_ADJUSTED_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ROLL_ADJUSTED_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Roll Adjusted Angle (0074,102D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ROLL_ADJUSTED_ANGLE
Visual Basic
Public Const TABLE_TOP_ROLL_ADJUSTED_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ROLL_ADJUSTED_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ROLL_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ROLL_ANGLE Field
MCdicom Structure See Also Send Feedback
Table Top Roll Angle (300A,0144)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ROLL_ANGLE
Visual Basic
Public Const TABLE_TOP_ROLL_ANGLE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ROLL_ANGLE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ROLL_ANGLE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ROLL_ANGLE_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Roll Angle Tolerance (300A,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ROLL_ANGLE_TOLERANCE
Visual Basic
Public Const TABLE_TOP_ROLL_ANGLE_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ROLL_ANGLE_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_ROLL_ROTATION_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_ROLL_ROTATION_DIRECTION Field
MCdicom Structure See Also Send Feedback
Table Top Roll Rotation Direction (300A,0146)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_ROLL_ROTATION_DIRECTION
Visual Basic
Public Const TABLE_TOP_ROLL_ROTATION_DIRECTION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_ROLL_ROTATION_DIRECTION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_VERTICAL_ADJUSTED_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_VERTICAL_ADJUSTED_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Vertical Adjusted Position (0074,1026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_VERTICAL_ADJUSTED_POSITION
Visual Basic
Public Const TABLE_TOP_VERTICAL_ADJUSTED_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_VERTICAL_ADJUSTED_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_VERTICAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_VERTICAL_POSITION Field
MCdicom Structure See Also Send Feedback
Table Top Vertical Position (300A,0128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_VERTICAL_POSITION
Visual Basic
Public Const TABLE_TOP_VERTICAL_POSITION As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_VERTICAL_POSITION

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_VERTICAL_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_VERTICAL_POSITION_TOLERANCE Field
MCdicom Structure See Also Send Feedback
Table Top Vertical Position Tolerance (300A,0051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_VERTICAL_POSITION_TOLERANCE
Visual Basic
Public Const TABLE_TOP_VERTICAL_POSITION_TOLERANCE As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_VERTICAL_POSITION_TOLERANCE

See Also

MCdicom Structure
MCdicom Members


TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT Field
MCdicom Structure See Also Send Feedback
Table Top Vertical Setup Displacement (300A,01D2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT
Visual Basic
Public Const TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_TOP_VERTICAL_SETUP_DISPLACEMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_TRAVERSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TRAVERSE Field
MCdicom Structure See Also Send Feedback
Table Traverse (0018,1131)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TRAVERSE
Visual Basic
Public Const TABLE_TRAVERSE As UInteger
Visual C++
public:
literal unsigned int TABLE_TRAVERSE

See Also

MCdicom Structure
MCdicom Members


TABLE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_TYPE Field
MCdicom Structure See Also Send Feedback
Table Type (0018,113A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_TYPE
Visual Basic
Public Const TABLE_TYPE As UInteger
Visual C++
public:
literal unsigned int TABLE_TYPE

See Also

MCdicom Structure
MCdicom Members


TABLE_VERTICAL_INCREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_VERTICAL_INCREMENT Field
MCdicom Structure See Also Send Feedback
Table Vertical Increment (0018,1135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_VERTICAL_INCREMENT
Visual Basic
Public Const TABLE_VERTICAL_INCREMENT As UInteger
Visual C++
public:
literal unsigned int TABLE_VERTICAL_INCREMENT

See Also

MCdicom Structure
MCdicom Members


TABLE_X_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_X_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Table X Position to Isocenter (0018,9466)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_X_POSITION_TO_ISOCENTER
Visual Basic
Public Const TABLE_X_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int TABLE_X_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


TABLE_Y_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_Y_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Table Y Position to Isocenter (0018,9467)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_Y_POSITION_TO_ISOCENTER
Visual Basic
Public Const TABLE_Y_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int TABLE_Y_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


TABLE_Z_POSITION_TO_ISOCENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABLE_Z_POSITION_TO_ISOCENTER Field
MCdicom Structure See Also Send Feedback
Table Z Position to Isocenter (0018,9468)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABLE_Z_POSITION_TO_ISOCENTER
Visual Basic
Public Const TABLE_Z_POSITION_TO_ISOCENTER As UInteger
Visual C++
public:
literal unsigned int TABLE_Z_POSITION_TO_ISOCENTER

See Also

MCdicom Structure
MCdicom Members


TABULATED_VALUES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TABULATED_VALUES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Tabulated Values Sequence (0040,A801)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TABULATED_VALUES_SEQUENCE
Visual Basic
Public Const TABULATED_VALUES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TABULATED_VALUES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_2D_DEGREE_OF_FREEDOM_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_DEGREE_OF_FREEDOM_AXIS Field
MCdicom Structure See Also Send Feedback
2D Degree of Freedom Axis (0068,64F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_DEGREE_OF_FREEDOM_AXIS
Visual Basic
Public Const TAG_2D_DEGREE_OF_FREEDOM_AXIS As UInteger
Visual C++
public:
literal unsigned int TAG_2D_DEGREE_OF_FREEDOM_AXIS

See Also

MCdicom Structure
MCdicom Members


TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
2D Degree of Freedom Sequence (0068,6470)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE
Visual Basic
Public Const TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TAG_2D_DEGREE_OF_FREEDOM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES Field
MCdicom Structure See Also Send Feedback
2D Implant Template Group Member Matching Axes (0078,00A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES
Visual Basic
Public Const TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES As UInteger
Visual C++
public:
literal unsigned int TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES

See Also

MCdicom Structure
MCdicom Members


TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT Field
MCdicom Structure See Also Send Feedback
2D Implant Template Group Member Matching Point (0078,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT
Visual Basic
Public Const TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT As UInteger
Visual C++
public:
literal unsigned int TAG_2D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT

See Also

MCdicom Structure
MCdicom Members


TAG_2D_LINE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_LINE_COORDINATES Field
MCdicom Structure See Also Send Feedback
2D Line Coordinates (0068,65B0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_LINE_COORDINATES
Visual Basic
Public Const TAG_2D_LINE_COORDINATES As UInteger
Visual C++
public:
literal unsigned int TAG_2D_LINE_COORDINATES

See Also

MCdicom Structure
MCdicom Members


TAG_2D_LINE_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_LINE_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
2D Line Coordinates Sequence (0068,65A0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_LINE_COORDINATES_SEQUENCE
Visual Basic
Public Const TAG_2D_LINE_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TAG_2D_LINE_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_2D_MATING_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_MATING_AXES Field
MCdicom Structure See Also Send Feedback
2D Mating Axes (0068,6460)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_MATING_AXES
Visual Basic
Public Const TAG_2D_MATING_AXES As UInteger
Visual C++
public:
literal unsigned int TAG_2D_MATING_AXES

See Also

MCdicom Structure
MCdicom Members


TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
2D Mating Feature Coordinates Sequence (0068,6430)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE
Visual Basic
Public Const TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TAG_2D_MATING_FEATURE_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_2D_MATING_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_MATING_POINT Field
MCdicom Structure See Also Send Feedback
2D Mating Point (0068,6450)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_MATING_POINT
Visual Basic
Public Const TAG_2D_MATING_POINT As UInteger
Visual C++
public:
literal unsigned int TAG_2D_MATING_POINT

See Also

MCdicom Structure
MCdicom Members


TAG_2D_PLANE_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_PLANE_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
2D Plane Coordinates Sequence (0068,65E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_PLANE_COORDINATES_SEQUENCE
Visual Basic
Public Const TAG_2D_PLANE_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TAG_2D_PLANE_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_2D_PLANE_INTERSECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_PLANE_INTERSECTION Field
MCdicom Structure See Also Send Feedback
2D Plane Intersection (0068,65F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_PLANE_INTERSECTION
Visual Basic
Public Const TAG_2D_PLANE_INTERSECTION As UInteger
Visual C++
public:
literal unsigned int TAG_2D_PLANE_INTERSECTION

See Also

MCdicom Structure
MCdicom Members


TAG_2D_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_POINT_COORDINATES Field
MCdicom Structure See Also Send Feedback
2D Point Coordinates (0068,6560)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_POINT_COORDINATES
Visual Basic
Public Const TAG_2D_POINT_COORDINATES As UInteger
Visual C++
public:
literal unsigned int TAG_2D_POINT_COORDINATES

See Also

MCdicom Structure
MCdicom Members


TAG_2D_POINT_COORDINATES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_2D_POINT_COORDINATES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
2D Point Coordinates Sequence (0068,6550)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_2D_POINT_COORDINATES_SEQUENCE
Visual Basic
Public Const TAG_2D_POINT_COORDINATES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TAG_2D_POINT_COORDINATES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TAG_3D_DEGREE_OF_FREEDOM_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_DEGREE_OF_FREEDOM_AXIS Field
MCdicom Structure See Also Send Feedback
3D Degree of Freedom Axis (0068,6490)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_DEGREE_OF_FREEDOM_AXIS
Visual Basic
Public Const TAG_3D_DEGREE_OF_FREEDOM_AXIS As UInteger
Visual C++
public:
literal unsigned int TAG_3D_DEGREE_OF_FREEDOM_AXIS

See Also

MCdicom Structure
MCdicom Members


TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES Field
MCdicom Structure See Also Send Feedback
3D Implant Template Group Member Matching Axes (0078,0060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES
Visual Basic
Public Const TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES As UInteger
Visual C++
public:
literal unsigned int TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_AXES

See Also

MCdicom Structure
MCdicom Members


TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT Field
MCdicom Structure See Also Send Feedback
3D Implant Template Group Member Matching Point (0078,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT
Visual Basic
Public Const TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT As UInteger
Visual C++
public:
literal unsigned int TAG_3D_IMPLANT_TEMPLATE_GROUP_MEMBER_MATCHING_POINT

See Also

MCdicom Structure
MCdicom Members


TAG_3D_LINE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_LINE_COORDINATES Field
MCdicom Structure See Also Send Feedback
3D Line Coordinates (0068,65D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_LINE_COORDINATES
Visual Basic
Public Const TAG_3D_LINE_COORDINATES As UInteger
Visual C++
public:
literal unsigned int TAG_3D_LINE_COORDINATES

See Also

MCdicom Structure
MCdicom Members


TAG_3D_MATING_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_MATING_AXES Field
MCdicom Structure See Also Send Feedback
3D Mating Axes (0068,64D0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_MATING_AXES
Visual Basic
Public Const TAG_3D_MATING_AXES As UInteger
Visual C++
public:
literal unsigned int TAG_3D_MATING_AXES

See Also

MCdicom Structure
MCdicom Members


TAG_3D_MATING_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_MATING_POINT Field
MCdicom Structure See Also Send Feedback
3D Mating Point (0068,64C0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_MATING_POINT
Visual Basic
Public Const TAG_3D_MATING_POINT As UInteger
Visual C++
public:
literal unsigned int TAG_3D_MATING_POINT

See Also

MCdicom Structure
MCdicom Members


TAG_3D_PLANE_NORMAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_PLANE_NORMAL Field
MCdicom Structure See Also Send Feedback
3D Plane Normal (0068,6620)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_PLANE_NORMAL
Visual Basic
Public Const TAG_3D_PLANE_NORMAL As UInteger
Visual C++
public:
literal unsigned int TAG_3D_PLANE_NORMAL

See Also

MCdicom Structure
MCdicom Members


TAG_3D_PLANE_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_PLANE_ORIGIN Field
MCdicom Structure See Also Send Feedback
3D Plane Origin (0068,6610)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_PLANE_ORIGIN
Visual Basic
Public Const TAG_3D_PLANE_ORIGIN As UInteger
Visual C++
public:
literal unsigned int TAG_3D_PLANE_ORIGIN

See Also

MCdicom Structure
MCdicom Members


TAG_3D_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_POINT_COORDINATES Field
MCdicom Structure See Also Send Feedback
3D Point Coordinates (0068,6590)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_POINT_COORDINATES
Visual Basic
Public Const TAG_3D_POINT_COORDINATES As UInteger
Visual C++
public:
literal unsigned int TAG_3D_POINT_COORDINATES

See Also

MCdicom Structure
MCdicom Members


TAG_3D_RENDERING_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_3D_RENDERING_TYPE Field
MCdicom Structure See Also Send Feedback
3D Rendering Type (0072,0520)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_3D_RENDERING_TYPE
Visual Basic
Public Const TAG_3D_RENDERING_TYPE As UInteger
Visual C++
public:
literal unsigned int TAG_3D_RENDERING_TYPE

See Also

MCdicom Structure
MCdicom Members


TAG_ANGLE_FIRST_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_ANGLE_FIRST_AXIS Field
MCdicom Structure See Also Send Feedback
Tag Angle First Axis (0018,9019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_ANGLE_FIRST_AXIS
Visual Basic
Public Const TAG_ANGLE_FIRST_AXIS As UInteger
Visual C++
public:
literal unsigned int TAG_ANGLE_FIRST_AXIS

See Also

MCdicom Structure
MCdicom Members


TAG_ANGLE_SECOND_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_ANGLE_SECOND_AXIS Field
MCdicom Structure See Also Send Feedback
Tag Angle Second Axis (0018,9219)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_ANGLE_SECOND_AXIS
Visual Basic
Public Const TAG_ANGLE_SECOND_AXIS As UInteger
Visual C++
public:
literal unsigned int TAG_ANGLE_SECOND_AXIS

See Also

MCdicom Structure
MCdicom Members


TAG_SPACING_FIRST_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_SPACING_FIRST_DIMENSION Field
MCdicom Structure See Also Send Feedback
Tag Spacing First Dimension (0018,9030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_SPACING_FIRST_DIMENSION
Visual Basic
Public Const TAG_SPACING_FIRST_DIMENSION As UInteger
Visual C++
public:
literal unsigned int TAG_SPACING_FIRST_DIMENSION

See Also

MCdicom Structure
MCdicom Members


TAG_SPACING_SECOND_DIMENSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_SPACING_SECOND_DIMENSION Field
MCdicom Structure See Also Send Feedback
Tag Spacing Second Dimension (0018,9218)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_SPACING_SECOND_DIMENSION
Visual Basic
Public Const TAG_SPACING_SECOND_DIMENSION As UInteger
Visual C++
public:
literal unsigned int TAG_SPACING_SECOND_DIMENSION

See Also

MCdicom Structure
MCdicom Members


TAG_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAG_THICKNESS Field
MCdicom Structure See Also Send Feedback
Tag Thickness (0018,9035)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAG_THICKNESS
Visual Basic
Public Const TAG_THICKNESS As UInteger
Visual C++
public:
literal unsigned int TAG_THICKNESS

See Also

MCdicom Structure
MCdicom Members


TAGGING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAGGING Field
MCdicom Structure See Also Send Feedback
Tagging (0018,9028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAGGING
Visual Basic
Public Const TAGGING As UInteger
Visual C++
public:
literal unsigned int TAGGING

See Also

MCdicom Structure
MCdicom Members


TAGGING_DELAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TAGGING_DELAY Field
MCdicom Structure See Also Send Feedback
Tagging Delay (0018,9184)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TAGGING_DELAY
Visual Basic
Public Const TAGGING_DELAY As UInteger
Visual C++
public:
literal unsigned int TAGGING_DELAY

See Also

MCdicom Structure
MCdicom Members


TANGENTIAL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TANGENTIAL_POWER Field
MCdicom Structure See Also Send Feedback
Tangential Power (0046,0250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TANGENTIAL_POWER
Visual Basic
Public Const TANGENTIAL_POWER As UInteger
Visual C++
public:
literal unsigned int TANGENTIAL_POWER

See Also

MCdicom Structure
MCdicom Members


TARGET_EXPOSURE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_EXPOSURE_INDEX Field
MCdicom Structure See Also Send Feedback
Target Exposure Index (0018,1412)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_EXPOSURE_INDEX
Visual Basic
Public Const TARGET_EXPOSURE_INDEX As UInteger
Visual C++
public:
literal unsigned int TARGET_EXPOSURE_INDEX

See Also

MCdicom Structure
MCdicom Members


TARGET_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Target Frame of Reference UID (0018,991E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const TARGET_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int TARGET_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


TARGET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_LABEL Field
MCdicom Structure See Also Send Feedback
Target Label (0018,2045)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_LABEL
Visual Basic
Public Const TARGET_LABEL As UInteger
Visual C++
public:
literal unsigned int TARGET_LABEL

See Also

MCdicom Structure
MCdicom Members


TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Target Luminance Characteristics Sequence (0028,7008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TARGET_LUMINANCE_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TARGET_MAXIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_MAXIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
Target Maximum Dose (300A,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_MAXIMUM_DOSE
Visual Basic
Public Const TARGET_MAXIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int TARGET_MAXIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


TARGET_MAXIMUM_LUMINANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_MAXIMUM_LUMINANCE Field
MCdicom Structure See Also Send Feedback
Target Maximum Luminance (0028,701E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_MAXIMUM_LUMINANCE
Visual Basic
Public Const TARGET_MAXIMUM_LUMINANCE As UInteger
Visual C++
public:
literal unsigned int TARGET_MAXIMUM_LUMINANCE

See Also

MCdicom Structure
MCdicom Members


TARGET_MINIMUM_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_MINIMUM_DOSE Field
MCdicom Structure See Also Send Feedback
Target Minimum Dose (300A,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_MINIMUM_DOSE
Visual Basic
Public Const TARGET_MINIMUM_DOSE As UInteger
Visual C++
public:
literal unsigned int TARGET_MINIMUM_DOSE

See Also

MCdicom Structure
MCdicom Members


TARGET_MINIMUM_LUMINANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_MINIMUM_LUMINANCE Field
MCdicom Structure See Also Send Feedback
Target Minimum Luminance (0028,701D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_MINIMUM_LUMINANCE
Visual Basic
Public Const TARGET_MINIMUM_LUMINANCE As UInteger
Visual C++
public:
literal unsigned int TARGET_MINIMUM_LUMINANCE

See Also

MCdicom Structure
MCdicom Members


TARGET_POSITION_REFERENCE_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_POSITION_REFERENCE_INDICATOR Field
MCdicom Structure See Also Send Feedback
Target Position Reference Indicator (0020,103F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_POSITION_REFERENCE_INDICATOR
Visual Basic
Public Const TARGET_POSITION_REFERENCE_INDICATOR As UInteger
Visual C++
public:
literal unsigned int TARGET_POSITION_REFERENCE_INDICATOR

See Also

MCdicom Structure
MCdicom Members


TARGET_PRESCIPTION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_PRESCIPTION_DOSE Field
MCdicom Structure See Also Send Feedback
Alias for tag TARGET_PRESCRIPTION_DOSE (300A,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_PRESCIPTION_DOSE
Visual Basic
Public Const TARGET_PRESCIPTION_DOSE As UInteger
Visual C++
public:
literal unsigned int TARGET_PRESCIPTION_DOSE

See Also

MCdicom Structure
MCdicom Members


TARGET_PRESCRIPTION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_PRESCRIPTION_DOSE Field
MCdicom Structure See Also Send Feedback
Target Prescription Dose (300A,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_PRESCRIPTION_DOSE
Visual Basic
Public Const TARGET_PRESCRIPTION_DOSE As UInteger
Visual C++
public:
literal unsigned int TARGET_PRESCRIPTION_DOSE

See Also

MCdicom Structure
MCdicom Members


TARGET_REFRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_REFRACTION Field
MCdicom Structure See Also Send Feedback
Target Refraction (0022,1037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_REFRACTION
Visual Basic
Public Const TARGET_REFRACTION As UInteger
Visual C++
public:
literal unsigned int TARGET_REFRACTION

See Also

MCdicom Structure
MCdicom Members


TARGET_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_UID Field
MCdicom Structure See Also Send Feedback
Target UID (0018,2042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_UID
Visual Basic
Public Const TARGET_UID As UInteger
Visual C++
public:
literal unsigned int TARGET_UID

See Also

MCdicom Structure
MCdicom Members


TARGET_UNDERDOSE_VOLUME_FRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TARGET_UNDERDOSE_VOLUME_FRACTION Field
MCdicom Structure See Also Send Feedback
Target Underdose Volume Fraction (300A,0028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TARGET_UNDERDOSE_VOLUME_FRACTION
Visual Basic
Public Const TARGET_UNDERDOSE_VOLUME_FRACTION As UInteger
Visual C++
public:
literal unsigned int TARGET_UNDERDOSE_VOLUME_FRACTION

See Also

MCdicom Structure
MCdicom Members


TDR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TDR_TYPE Field
MCdicom Structure See Also Send Feedback
TDR Type (4010,1027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TDR_TYPE
Visual Basic
Public Const TDR_TYPE As UInteger
Visual C++
public:
literal unsigned int TDR_TYPE

See Also

MCdicom Structure
MCdicom Members


TELEPHONE_NUMBER_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TELEPHONE_NUMBER_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Telephone Number (Trial) RETIRED (0040,A354)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TELEPHONE_NUMBER_TRIAL_RETIRED
Visual Basic
Public Const TELEPHONE_NUMBER_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int TELEPHONE_NUMBER_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


TELETHERAPY_RADIATION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TELETHERAPY_RADIATION_TYPE Field
MCdicom Structure See Also Send Feedback
Teletherapy Radiation Type (3010,0047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TELETHERAPY_RADIATION_TYPE
Visual Basic
Public Const TELETHERAPY_RADIATION_TYPE As UInteger
Visual C++
public:
literal unsigned int TELETHERAPY_RADIATION_TYPE

See Also

MCdicom Structure
MCdicom Members


TEMPERATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPERATURE Field
MCdicom Structure See Also Send Feedback
Temperature (0016,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPERATURE
Visual Basic
Public Const TEMPERATURE As UInteger
Visual C++
public:
literal unsigned int TEMPERATURE

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_EXTENSION_CREATOR_UID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_EXTENSION_CREATOR_UID_RETIRED Field
MCdicom Structure See Also Send Feedback
Template Extension Creator UID RETIRED (0040,DB0D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_EXTENSION_CREATOR_UID_RETIRED
Visual Basic
Public Const TEMPLATE_EXTENSION_CREATOR_UID_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_EXTENSION_CREATOR_UID_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_EXTENSION_FLAG_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_EXTENSION_FLAG_RETIRED Field
MCdicom Structure See Also Send Feedback
Template Extension Flag RETIRED (0040,DB0B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_EXTENSION_FLAG_RETIRED
Visual Basic
Public Const TEMPLATE_EXTENSION_FLAG_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_EXTENSION_FLAG_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED Field
MCdicom Structure See Also Send Feedback
Template Extension Organization UID RETIRED (0040,DB0C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED
Visual Basic
Public Const TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_EXTENSION_ORGANIZATION_UID_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Template Identifier (0040,DB00)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_IDENTIFIER
Visual Basic
Public Const TEMPLATE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_LOCAL_VERSION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_LOCAL_VERSION_RETIRED Field
MCdicom Structure See Also Send Feedback
Template Local Version RETIRED (0040,DB07)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_LOCAL_VERSION_RETIRED
Visual Basic
Public Const TEMPLATE_LOCAL_VERSION_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_LOCAL_VERSION_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_NAME Field
MCdicom Structure See Also Send Feedback
Template Name (300A,0244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_NAME
Visual Basic
Public Const TEMPLATE_NAME As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_NAME

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_NUMBER Field
MCdicom Structure See Also Send Feedback
Template Number (300A,0240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_NUMBER
Visual Basic
Public Const TEMPLATE_NUMBER As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_NUMBER

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_TYPE Field
MCdicom Structure See Also Send Feedback
Template Type (300A,0242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_TYPE
Visual Basic
Public Const TEMPLATE_TYPE As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_TYPE

See Also

MCdicom Structure
MCdicom Members


TEMPLATE_VERSION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPLATE_VERSION_RETIRED Field
MCdicom Structure See Also Send Feedback
Template Version RETIRED (0040,DB06)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPLATE_VERSION_RETIRED
Visual Basic
Public Const TEMPLATE_VERSION_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEMPLATE_VERSION_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_POSITION_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_POSITION_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Temporal Position Identifier (0020,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_POSITION_IDENTIFIER
Visual Basic
Public Const TEMPORAL_POSITION_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_POSITION_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_POSITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_POSITION_INDEX Field
MCdicom Structure See Also Send Feedback
Temporal Position Index (0020,9128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_POSITION_INDEX
Visual Basic
Public Const TEMPORAL_POSITION_INDEX As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_POSITION_INDEX

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Temporal Position Sequence (0020,9310)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_POSITION_SEQUENCE
Visual Basic
Public Const TEMPORAL_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_POSITION_TIME_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_POSITION_TIME_OFFSET Field
MCdicom Structure See Also Send Feedback
Temporal Position Time Offset (0020,930D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_POSITION_TIME_OFFSET
Visual Basic
Public Const TEMPORAL_POSITION_TIME_OFFSET As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_POSITION_TIME_OFFSET

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_RANGE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_RANGE_TYPE Field
MCdicom Structure See Also Send Feedback
Temporal Range Type (0040,A130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_RANGE_TYPE
Visual Basic
Public Const TEMPORAL_RANGE_TYPE As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_RANGE_TYPE

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR Field
MCdicom Structure See Also Send Feedback
Temporal Relationship Interval Anchor (3010,004F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR
Visual Basic
Public Const TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_RELATIONSHIP_INTERVAL_ANCHOR

See Also

MCdicom Structure
MCdicom Members


TEMPORAL_RESOLUTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEMPORAL_RESOLUTION Field
MCdicom Structure See Also Send Feedback
Temporal Resolution (0020,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEMPORAL_RESOLUTION
Visual Basic
Public Const TEMPORAL_RESOLUTION As UInteger
Visual C++
public:
literal unsigned int TEMPORAL_RESOLUTION

See Also

MCdicom Structure
MCdicom Members


TERMINAL_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINAL_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Terminal Type RETIRED (0000,4010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINAL_TYPE_RETIRED
Visual Basic
Public Const TERMINAL_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TERMINAL_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Cardiac Trigger Count Threshold (0018,9723)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD
Visual Basic
Public Const TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_CARDIAC_TRIGGER_COUNT_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TERMINATION_COUNTS_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_COUNTS_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Counts Threshold (0018,9719)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_COUNTS_THRESHOLD
Visual Basic
Public Const TERMINATION_COUNTS_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_COUNTS_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TERMINATION_DENSITY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_DENSITY_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Density Threshold (0018,9720)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_DENSITY_THRESHOLD
Visual Basic
Public Const TERMINATION_DENSITY_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_DENSITY_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TERMINATION_RELATIVE_DENSITY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_RELATIVE_DENSITY_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Relative Density Threshold (0018,9721)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_RELATIVE_DENSITY_THRESHOLD
Visual Basic
Public Const TERMINATION_RELATIVE_DENSITY_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_RELATIVE_DENSITY_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Respiratory Trigger Count Threshold (0018,9724)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD
Visual Basic
Public Const TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_RESPIRATORY_TRIGGER_COUNT_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TERMINATION_TIME_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TERMINATION_TIME_THRESHOLD Field
MCdicom Structure See Also Send Feedback
Termination Time Threshold (0018,9722)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TERMINATION_TIME_THRESHOLD
Visual Basic
Public Const TERMINATION_TIME_THRESHOLD As UInteger
Visual C++
public:
literal unsigned int TERMINATION_TIME_THRESHOLD

See Also

MCdicom Structure
MCdicom Members


TEST_IMAGE_VALIDATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_IMAGE_VALIDATION Field
MCdicom Structure See Also Send Feedback
Test Image Validation (0028,702B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_IMAGE_VALIDATION
Visual Basic
Public Const TEST_IMAGE_VALIDATION As UInteger
Visual C++
public:
literal unsigned int TEST_IMAGE_VALIDATION

See Also

MCdicom Structure
MCdicom Members


TEST_PATTERN_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_PATTERN_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Test Pattern Code Sequence (0028,702C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_PATTERN_CODE_SEQUENCE
Visual Basic
Public Const TEST_PATTERN_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TEST_PATTERN_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TEST_POINT_NORMALS_DATA_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_POINT_NORMALS_DATA_FLAG Field
MCdicom Structure See Also Send Feedback
Test Point Normals Data Flag (0024,0057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_POINT_NORMALS_DATA_FLAG
Visual Basic
Public Const TEST_POINT_NORMALS_DATA_FLAG As UInteger
Visual C++
public:
literal unsigned int TEST_POINT_NORMALS_DATA_FLAG

See Also

MCdicom Structure
MCdicom Members


TEST_POINT_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_POINT_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Test Point Normals Sequence (0024,0058)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_POINT_NORMALS_SEQUENCE
Visual Basic
Public Const TEST_POINT_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TEST_POINT_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TEST_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_RESULT Field
MCdicom Structure See Also Send Feedback
Test Result (0028,7029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_RESULT
Visual Basic
Public Const TEST_RESULT As UInteger
Visual C++
public:
literal unsigned int TEST_RESULT

See Also

MCdicom Structure
MCdicom Members


TEST_RESULT_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEST_RESULT_COMMENT Field
MCdicom Structure See Also Send Feedback
Test Result Comment (0028,702A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEST_RESULT_COMMENT
Visual Basic
Public Const TEST_RESULT_COMMENT As UInteger
Visual C++
public:
literal unsigned int TEST_RESULT_COMMENT

See Also

MCdicom Structure
MCdicom Members


TEXT_COLOR_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_COLOR_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Text Color CIELab Value (0070,0241)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_COLOR_CIELAB_VALUE
Visual Basic
Public Const TEXT_COLOR_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int TEXT_COLOR_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


TEXT_COMMENTS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_COMMENTS_RETIRED Field
MCdicom Structure See Also Send Feedback
Text Comments RETIRED (4000,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_COMMENTS_RETIRED
Visual Basic
Public Const TEXT_COMMENTS_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEXT_COMMENTS_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEXT_FORMAT_ID_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_FORMAT_ID_RETIRED Field
MCdicom Structure See Also Send Feedback
Text Format ID RETIRED (0000,5130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_FORMAT_ID_RETIRED
Visual Basic
Public Const TEXT_FORMAT_ID_RETIRED As UInteger
Visual C++
public:
literal unsigned int TEXT_FORMAT_ID_RETIRED

See Also

MCdicom Structure
MCdicom Members


TEXT_OBJECT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_OBJECT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Text Object Sequence (0070,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_OBJECT_SEQUENCE
Visual Basic
Public Const TEXT_OBJECT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TEXT_OBJECT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TEXT_STRING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_STRING Field
MCdicom Structure See Also Send Feedback
Text String (2030,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_STRING
Visual Basic
Public Const TEXT_STRING As UInteger
Visual C++
public:
literal unsigned int TEXT_STRING

See Also

MCdicom Structure
MCdicom Members


TEXT_STYLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_STYLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Text Style Sequence (0070,0231)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_STYLE_SEQUENCE
Visual Basic
Public Const TEXT_STYLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TEXT_STYLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TEXT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXT_VALUE Field
MCdicom Structure See Also Send Feedback
Text Value (0040,A160)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXT_VALUE
Visual Basic
Public Const TEXT_VALUE As UInteger
Visual C++
public:
literal unsigned int TEXT_VALUE

See Also

MCdicom Structure
MCdicom Members


TEXTURE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TEXTURE_LABEL Field
MCdicom Structure See Also Send Feedback
Texture Label (0080,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TEXTURE_LABEL
Visual Basic
Public Const TEXTURE_LABEL As UInteger
Visual C++
public:
literal unsigned int TEXTURE_LABEL

See Also

MCdicom Structure
MCdicom Members


THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Therapeutic Role Category Code Sequence (3010,0064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE
Visual Basic
Public Const THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THERAPEUTIC_ROLE_CATEGORY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Therapeutic Role Type Code Sequence (3010,0065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE
Visual Basic
Public Const THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THERAPEUTIC_ROLE_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


THERAPY_DESCRIPTION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THERAPY_DESCRIPTION_RETIRED Field
MCdicom Structure See Also Send Feedback
Therapy Description RETIRED (0018,0039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THERAPY_DESCRIPTION_RETIRED
Visual Basic
Public Const THERAPY_DESCRIPTION_RETIRED As UInteger
Visual C++
public:
literal unsigned int THERAPY_DESCRIPTION_RETIRED

See Also

MCdicom Structure
MCdicom Members


THERAPY_TYPE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THERAPY_TYPE_RETIRED Field
MCdicom Structure See Also Send Feedback
Therapy Type RETIRED (0018,0037)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THERAPY_TYPE_RETIRED
Visual Basic
Public Const THERAPY_TYPE_RETIRED As UInteger
Visual C++
public:
literal unsigned int THERAPY_TYPE_RETIRED

See Also

MCdicom Structure
MCdicom Members


THREAT_CATEGORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_CATEGORY Field
MCdicom Structure See Also Send Feedback
Threat Category (4010,1012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_CATEGORY
Visual Basic
Public Const THREAT_CATEGORY As UInteger
Visual C++
public:
literal unsigned int THREAT_CATEGORY

See Also

MCdicom Structure
MCdicom Members


THREAT_CATEGORY_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_CATEGORY_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Threat Category Description (4010,1013)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_CATEGORY_DESCRIPTION
Visual Basic
Public Const THREAT_CATEGORY_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int THREAT_CATEGORY_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


THREAT_DETECTION_ALGORITHM_AND_VERSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_DETECTION_ALGORITHM_AND_VERSION Field
MCdicom Structure See Also Send Feedback
Threat Detection Algorithm and Version (4010,1029)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_DETECTION_ALGORITHM_AND_VERSION
Visual Basic
Public Const THREAT_DETECTION_ALGORITHM_AND_VERSION As UInteger
Visual C++
public:
literal unsigned int THREAT_DETECTION_ALGORITHM_AND_VERSION

See Also

MCdicom Structure
MCdicom Members


THREAT_ROI_BASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_ROI_BASE Field
MCdicom Structure See Also Send Feedback
Threat ROI Base (4010,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_ROI_BASE
Visual Basic
Public Const THREAT_ROI_BASE As UInteger
Visual C++
public:
literal unsigned int THREAT_ROI_BASE

See Also

MCdicom Structure
MCdicom Members


THREAT_ROI_BITMAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_ROI_BITMAP Field
MCdicom Structure See Also Send Feedback
Threat ROI Bitmap (4010,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_ROI_BITMAP
Visual Basic
Public Const THREAT_ROI_BITMAP As UInteger
Visual C++
public:
literal unsigned int THREAT_ROI_BITMAP

See Also

MCdicom Structure
MCdicom Members


THREAT_ROI_EXTENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_ROI_EXTENTS Field
MCdicom Structure See Also Send Feedback
Threat ROI Extents (4010,1005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_ROI_EXTENTS
Visual Basic
Public Const THREAT_ROI_EXTENTS As UInteger
Visual C++
public:
literal unsigned int THREAT_ROI_EXTENTS

See Also

MCdicom Structure
MCdicom Members


THREAT_ROI_VOXEL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_ROI_VOXEL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Threat ROI Voxel Sequence (4010,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_ROI_VOXEL_SEQUENCE
Visual Basic
Public Const THREAT_ROI_VOXEL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THREAT_ROI_VOXEL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


THREAT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THREAT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Threat Sequence (4010,1011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THREAT_SEQUENCE
Visual Basic
Public Const THREAT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THREAT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


THRESHOLD_DENSITY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THRESHOLD_DENSITY_RETIRED Field
MCdicom Structure See Also Send Feedback
Threshold Density RETIRED (2040,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THRESHOLD_DENSITY_RETIRED
Visual Basic
Public Const THRESHOLD_DENSITY_RETIRED As UInteger
Visual C++
public:
literal unsigned int THRESHOLD_DENSITY_RETIRED

See Also

MCdicom Structure
MCdicom Members


THRESHOLD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THRESHOLD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Threshold Sequence (0070,1B11)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THRESHOLD_SEQUENCE
Visual Basic
Public Const THRESHOLD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THRESHOLD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


THRESHOLD_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THRESHOLD_TYPE Field
MCdicom Structure See Also Send Feedback
Threshold Type (0070,1B13)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THRESHOLD_TYPE
Visual Basic
Public Const THRESHOLD_TYPE As UInteger
Visual C++
public:
literal unsigned int THRESHOLD_TYPE

See Also

MCdicom Structure
MCdicom Members


THRESHOLD_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THRESHOLD_VALUE Field
MCdicom Structure See Also Send Feedback
Threshold Value (0070,1B14)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THRESHOLD_VALUE
Visual Basic
Public Const THRESHOLD_VALUE As UInteger
Visual C++
public:
literal unsigned int THRESHOLD_VALUE

See Also

MCdicom Structure
MCdicom Members


THRESHOLD_VALUE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..THRESHOLD_VALUE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Threshold Value Sequence (0070,1B12)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint THRESHOLD_VALUE_SEQUENCE
Visual Basic
Public Const THRESHOLD_VALUE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int THRESHOLD_VALUE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TICK_ALIGNMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TICK_ALIGNMENT Field
MCdicom Structure See Also Send Feedback
Tick Alignment (0070,0274)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TICK_ALIGNMENT
Visual Basic
Public Const TICK_ALIGNMENT As UInteger
Visual C++
public:
literal unsigned int TICK_ALIGNMENT

See Also

MCdicom Structure
MCdicom Members


TICK_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TICK_LABEL Field
MCdicom Structure See Also Send Feedback
Tick Label (0070,0289)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TICK_LABEL
Visual Basic
Public Const TICK_LABEL As UInteger
Visual C++
public:
literal unsigned int TICK_LABEL

See Also

MCdicom Structure
MCdicom Members


TICK_LABEL_ALIGNMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TICK_LABEL_ALIGNMENT Field
MCdicom Structure See Also Send Feedback
Tick Label Alignment (0070,0279)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TICK_LABEL_ALIGNMENT
Visual Basic
Public Const TICK_LABEL_ALIGNMENT As UInteger
Visual C++
public:
literal unsigned int TICK_LABEL_ALIGNMENT

See Also

MCdicom Structure
MCdicom Members


TICK_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TICK_POSITION Field
MCdicom Structure See Also Send Feedback
Tick Position (0070,0288)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TICK_POSITION
Visual Basic
Public Const TICK_POSITION As UInteger
Visual C++
public:
literal unsigned int TICK_POSITION

See Also

MCdicom Structure
MCdicom Members


TID_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TID_OFFSET Field
MCdicom Structure See Also Send Feedback
TID Offset (0028,6120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TID_OFFSET
Visual Basic
Public Const TID_OFFSET As UInteger
Visual C++
public:
literal unsigned int TID_OFFSET

See Also

MCdicom Structure
MCdicom Members


TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME Field
MCdicom Structure See Also Send Feedback
Time (0040,A122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME
Visual Basic
Public Const TIME As UInteger
Visual C++
public:
literal unsigned int TIME

See Also

MCdicom Structure
MCdicom Members


TIME_BASED_IMAGE_SETS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_BASED_IMAGE_SETS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Time Based Image Sets Sequence (0072,0030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_BASED_IMAGE_SETS_SEQUENCE
Visual Basic
Public Const TIME_BASED_IMAGE_SETS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TIME_BASED_IMAGE_SETS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TIME_DISTRIBUTION_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_DISTRIBUTION_PROTOCOL Field
MCdicom Structure See Also Send Feedback
Time Distribution Protocol (0018,1802)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_DISTRIBUTION_PROTOCOL
Visual Basic
Public Const TIME_DISTRIBUTION_PROTOCOL As UInteger
Visual C++
public:
literal unsigned int TIME_DISTRIBUTION_PROTOCOL

See Also

MCdicom Structure
MCdicom Members


TIME_DOMAIN_FILTERING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_DOMAIN_FILTERING Field
MCdicom Structure See Also Send Feedback
Time Domain Filtering (0018,9065)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_DOMAIN_FILTERING
Visual Basic
Public Const TIME_DOMAIN_FILTERING As UInteger
Visual C++
public:
literal unsigned int TIME_DOMAIN_FILTERING

See Also

MCdicom Structure
MCdicom Members


TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Time of Document Creation or Verbal Transaction (Trial) RETIRED (0040,A112)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED
Visual Basic
Public Const TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int TIME_OF_DOCUMENT_CREATION_OR_VERBAL_TRANSACTION_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


TIME_OF_FLIGHT_CONTRAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_FLIGHT_CONTRAST Field
MCdicom Structure See Also Send Feedback
Time of Flight Contrast (0018,9015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_FLIGHT_CONTRAST
Visual Basic
Public Const TIME_OF_FLIGHT_CONTRAST As UInteger
Visual C++
public:
literal unsigned int TIME_OF_FLIGHT_CONTRAST

See Also

MCdicom Structure
MCdicom Members


TIME_OF_FLIGHT_INFORMATION_USED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_FLIGHT_INFORMATION_USED Field
MCdicom Structure See Also Send Feedback
Time of Flight Information Used (0018,9755)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_FLIGHT_INFORMATION_USED
Visual Basic
Public Const TIME_OF_FLIGHT_INFORMATION_USED As UInteger
Visual C++
public:
literal unsigned int TIME_OF_FLIGHT_INFORMATION_USED

See Also

MCdicom Structure
MCdicom Members


TIME_OF_FRAME_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_FRAME_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Time of Frame Group Sequence (0034,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_FRAME_GROUP_SEQUENCE
Visual Basic
Public Const TIME_OF_FRAME_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TIME_OF_FRAME_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TIME_OF_GAIN_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_GAIN_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Time of Gain Calibration (0014,3077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_GAIN_CALIBRATION
Visual Basic
Public Const TIME_OF_GAIN_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int TIME_OF_GAIN_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


TIME_OF_LAST_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_LAST_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Time of Last Calibration (0018,1201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_LAST_CALIBRATION
Visual Basic
Public Const TIME_OF_LAST_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int TIME_OF_LAST_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


TIME_OF_LAST_DETECTOR_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_LAST_DETECTOR_CALIBRATION Field
MCdicom Structure See Also Send Feedback
Time of Last Detector Calibration (0018,700E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_LAST_DETECTOR_CALIBRATION
Visual Basic
Public Const TIME_OF_LAST_DETECTOR_CALIBRATION As UInteger
Visual C++
public:
literal unsigned int TIME_OF_LAST_DETECTOR_CALIBRATION

See Also

MCdicom Structure
MCdicom Members


TIME_OF_SECONDARY_CAPTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_OF_SECONDARY_CAPTURE Field
MCdicom Structure See Also Send Feedback
Time of Secondary Capture (0018,1014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_OF_SECONDARY_CAPTURE
Visual Basic
Public Const TIME_OF_SECONDARY_CAPTURE As UInteger
Visual C++
public:
literal unsigned int TIME_OF_SECONDARY_CAPTURE

See Also

MCdicom Structure
MCdicom Members


TIME_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_RANGE Field
MCdicom Structure See Also Send Feedback
Time Range (0008,1163)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_RANGE
Visual Basic
Public Const TIME_RANGE As UInteger
Visual C++
public:
literal unsigned int TIME_RANGE

See Also

MCdicom Structure
MCdicom Members


TIME_SERIES_BLENDING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SERIES_BLENDING Field
MCdicom Structure See Also Send Feedback
Time Series Blending (0070,1B07)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SERIES_BLENDING
Visual Basic
Public Const TIME_SERIES_BLENDING As UInteger
Visual C++
public:
literal unsigned int TIME_SERIES_BLENDING

See Also

MCdicom Structure
MCdicom Members


TIME_SLICE_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SLICE_VECTOR Field
MCdicom Structure See Also Send Feedback
Time Slice Vector (0054,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SLICE_VECTOR
Visual Basic
Public Const TIME_SLICE_VECTOR As UInteger
Visual C++
public:
literal unsigned int TIME_SLICE_VECTOR

See Also

MCdicom Structure
MCdicom Members


TIME_SLOT_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SLOT_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Time Slot Information Sequence (0054,0072)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SLOT_INFORMATION_SEQUENCE
Visual Basic
Public Const TIME_SLOT_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TIME_SLOT_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TIME_SLOT_NUMBER_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SLOT_NUMBER_RETIRED Field
MCdicom Structure See Also Send Feedback
Time Slot Number RETIRED (0020,0017)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SLOT_NUMBER_RETIRED
Visual Basic
Public Const TIME_SLOT_NUMBER_RETIRED As UInteger
Visual C++
public:
literal unsigned int TIME_SLOT_NUMBER_RETIRED

See Also

MCdicom Structure
MCdicom Members


TIME_SLOT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SLOT_TIME Field
MCdicom Structure See Also Send Feedback
Time Slot Time (0054,0073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SLOT_TIME
Visual Basic
Public Const TIME_SLOT_TIME As UInteger
Visual C++
public:
literal unsigned int TIME_SLOT_TIME

See Also

MCdicom Structure
MCdicom Members


TIME_SLOT_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SLOT_VECTOR Field
MCdicom Structure See Also Send Feedback
Time Slot Vector (0054,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SLOT_VECTOR
Visual Basic
Public Const TIME_SLOT_VECTOR As UInteger
Visual C++
public:
literal unsigned int TIME_SLOT_VECTOR

See Also

MCdicom Structure
MCdicom Members


TIME_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIME_SOURCE Field
MCdicom Structure See Also Send Feedback
Time Source (0018,1801)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIME_SOURCE
Visual Basic
Public Const TIME_SOURCE As UInteger
Visual C++
public:
literal unsigned int TIME_SOURCE

See Also

MCdicom Structure
MCdicom Members


TIMEZONE_OFFSET_FROM_UTC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIMEZONE_OFFSET_FROM_UTC Field
MCdicom Structure See Also Send Feedback
Timezone Offset From UTC (0008,0201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIMEZONE_OFFSET_FROM_UTC
Visual Basic
Public Const TIMEZONE_OFFSET_FROM_UTC As UInteger
Visual C++
public:
literal unsigned int TIMEZONE_OFFSET_FROM_UTC

See Also

MCdicom Structure
MCdicom Members


TIP_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TIP_TYPE Field
MCdicom Structure See Also Send Feedback
TIP Type (4010,1039)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TIP_TYPE
Visual Basic
Public Const TIP_TYPE As UInteger
Visual C++
public:
literal unsigned int TIP_TYPE

See Also

MCdicom Structure
MCdicom Members


TISSUE_HETEROGENEITY_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TISSUE_HETEROGENEITY_CORRECTION Field
MCdicom Structure See Also Send Feedback
Tissue Heterogeneity Correction (3004,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TISSUE_HETEROGENEITY_CORRECTION
Visual Basic
Public Const TISSUE_HETEROGENEITY_CORRECTION As UInteger
Visual C++
public:
literal unsigned int TISSUE_HETEROGENEITY_CORRECTION

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_X0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_X0 Field
MCdicom Structure See Also Send Feedback
TM-Line Position X0 (0018,603D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_X0
Visual Basic
Public Const TM_LINE_POSITION_X0 As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_X0

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_X0_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_X0_RETIRED Field
MCdicom Structure See Also Send Feedback
TM-Line Position X0 (Retired) (0018,603C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_X0_RETIRED
Visual Basic
Public Const TM_LINE_POSITION_X0_RETIRED As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_X0_RETIRED

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_X1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_X1 Field
MCdicom Structure See Also Send Feedback
TM-Line Position X1 (0018,6041)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_X1
Visual Basic
Public Const TM_LINE_POSITION_X1 As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_X1

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_X1_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_X1_RETIRED Field
MCdicom Structure See Also Send Feedback
TM-Line Position X1 (Retired) (0018,6040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_X1_RETIRED
Visual Basic
Public Const TM_LINE_POSITION_X1_RETIRED As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_X1_RETIRED

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_Y0 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_Y0 Field
MCdicom Structure See Also Send Feedback
TM-Line Position Y0 (0018,603F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_Y0
Visual Basic
Public Const TM_LINE_POSITION_Y0 As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_Y0

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_Y0_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_Y0_RETIRED Field
MCdicom Structure See Also Send Feedback
TM-Line Position Y0 (Retired) (0018,603E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_Y0_RETIRED
Visual Basic
Public Const TM_LINE_POSITION_Y0_RETIRED As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_Y0_RETIRED

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_Y1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_Y1 Field
MCdicom Structure See Also Send Feedback
TM-Line Position Y1 (0018,6043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_Y1
Visual Basic
Public Const TM_LINE_POSITION_Y1 As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_Y1

See Also

MCdicom Structure
MCdicom Members


TM_LINE_POSITION_Y1_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TM_LINE_POSITION_Y1_RETIRED Field
MCdicom Structure See Also Send Feedback
TM-Line Position Y1 (Retired) (0018,6042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TM_LINE_POSITION_Y1_RETIRED
Visual Basic
Public Const TM_LINE_POSITION_Y1_RETIRED As UInteger
Visual C++
public:
literal unsigned int TM_LINE_POSITION_Y1_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOLERANCE_TABLE_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOLERANCE_TABLE_LABEL Field
MCdicom Structure See Also Send Feedback
Tolerance Table Label (300A,0043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOLERANCE_TABLE_LABEL
Visual Basic
Public Const TOLERANCE_TABLE_LABEL As UInteger
Visual C++
public:
literal unsigned int TOLERANCE_TABLE_LABEL

See Also

MCdicom Structure
MCdicom Members


TOLERANCE_TABLE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOLERANCE_TABLE_NUMBER Field
MCdicom Structure See Also Send Feedback
Tolerance Table Number (300A,0042)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOLERANCE_TABLE_NUMBER
Visual Basic
Public Const TOLERANCE_TABLE_NUMBER As UInteger
Visual C++
public:
literal unsigned int TOLERANCE_TABLE_NUMBER

See Also

MCdicom Structure
MCdicom Members


TOLERANCE_TABLE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOLERANCE_TABLE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Tolerance Table Sequence (300A,0040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOLERANCE_TABLE_SEQUENCE
Visual Basic
Public Const TOLERANCE_TABLE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TOLERANCE_TABLE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TOLERANCE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOLERANCE_VALUE Field
MCdicom Structure See Also Send Feedback
Tolerance Value (300A,062C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOLERANCE_VALUE
Visual Basic
Public Const TOLERANCE_VALUE As UInteger
Visual C++
public:
literal unsigned int TOLERANCE_VALUE

See Also

MCdicom Structure
MCdicom Members


TOMO_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMO_ANGLE Field
MCdicom Structure See Also Send Feedback
Tomo Angle (0018,1470)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMO_ANGLE
Visual Basic
Public Const TOMO_ANGLE As UInteger
Visual C++
public:
literal unsigned int TOMO_ANGLE

See Also

MCdicom Structure
MCdicom Members


TOMO_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMO_CLASS Field
MCdicom Structure See Also Send Feedback
Tomo Class (0018,1491)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMO_CLASS
Visual Basic
Public Const TOMO_CLASS As UInteger
Visual C++
public:
literal unsigned int TOMO_CLASS

See Also

MCdicom Structure
MCdicom Members


TOMO_LAYER_HEIGHT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMO_LAYER_HEIGHT Field
MCdicom Structure See Also Send Feedback
Tomo Layer Height (0018,1460)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMO_LAYER_HEIGHT
Visual Basic
Public Const TOMO_LAYER_HEIGHT As UInteger
Visual C++
public:
literal unsigned int TOMO_LAYER_HEIGHT

See Also

MCdicom Structure
MCdicom Members


TOMO_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMO_TIME Field
MCdicom Structure See Also Send Feedback
Tomo Time (0018,1480)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMO_TIME
Visual Basic
Public Const TOMO_TIME As UInteger
Visual C++
public:
literal unsigned int TOMO_TIME

See Also

MCdicom Structure
MCdicom Members


TOMO_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMO_TYPE Field
MCdicom Structure See Also Send Feedback
Tomo Type (0018,1490)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMO_TYPE
Visual Basic
Public Const TOMO_TYPE As UInteger
Visual C++
public:
literal unsigned int TOMO_TYPE

See Also

MCdicom Structure
MCdicom Members


TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Tomotherapeutic Control Point Sequence (3010,0098)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE
Visual Basic
Public Const TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TOMOTHERAPEUTIC_CONTROL_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS Field
MCdicom Structure See Also Send Feedback
Tomotherapeutic Leaf Initial Closed Durations (3010,009A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS
Visual Basic
Public Const TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS As UInteger
Visual C++
public:
literal unsigned int TOMOTHERAPEUTIC_LEAF_INITIAL_CLOSED_DURATIONS

See Also

MCdicom Structure
MCdicom Members


TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS Field
MCdicom Structure See Also Send Feedback
Tomotherapeutic Leaf Open Durations (3010,0099)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS
Visual Basic
Public Const TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS As UInteger
Visual C++
public:
literal unsigned int TOMOTHERAPEUTIC_LEAF_OPEN_DURATIONS

See Also

MCdicom Structure
MCdicom Members


TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED Field
MCdicom Structure See Also Send Feedback
Top Left Hand Corner of Localizer Area RETIRED (0048,0201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED
Visual Basic
Public Const TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOP_LEFT_HAND_CORNER_OF_LOCALIZER_AREA_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOPIC_AUTHOR_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOPIC_AUTHOR_RETIRED Field
MCdicom Structure See Also Send Feedback
Topic Author RETIRED (0088,0910)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOPIC_AUTHOR_RETIRED
Visual Basic
Public Const TOPIC_AUTHOR_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOPIC_AUTHOR_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOPIC_KEYWORDS_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOPIC_KEYWORDS_RETIRED Field
MCdicom Structure See Also Send Feedback
Topic Keywords RETIRED (0088,0912)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOPIC_KEYWORDS_RETIRED
Visual Basic
Public Const TOPIC_KEYWORDS_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOPIC_KEYWORDS_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOPIC_SUBJECT_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOPIC_SUBJECT_RETIRED Field
MCdicom Structure See Also Send Feedback
Topic Subject RETIRED (0088,0906)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOPIC_SUBJECT_RETIRED
Visual Basic
Public Const TOPIC_SUBJECT_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOPIC_SUBJECT_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOPIC_TITLE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOPIC_TITLE_RETIRED Field
MCdicom Structure See Also Send Feedback
Topic Title RETIRED (0088,0904)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOPIC_TITLE_RETIRED
Visual Basic
Public Const TOPIC_TITLE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOPIC_TITLE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Toric IOL Power for Exact Emmetropia Sequence (0022,104A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE
Visual Basic
Public Const TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TORIC_IOL_POWER_FOR_EXACT_EMMETROPIA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Toric IOL Power for Exact Target Refraction Sequence (0022,104B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE
Visual Basic
Public Const TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TORIC_IOL_POWER_FOR_EXACT_TARGET_REFRACTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TORIC_IOL_POWER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TORIC_IOL_POWER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Toric IOL Power Sequence (0022,1047)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TORIC_IOL_POWER_SEQUENCE
Visual Basic
Public Const TORIC_IOL_POWER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TORIC_IOL_POWER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TOTAL_BLOCK_TRAY_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_BLOCK_TRAY_FACTOR Field
MCdicom Structure See Also Send Feedback
Total Block Tray Factor (300A,00F2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_BLOCK_TRAY_FACTOR
Visual Basic
Public Const TOTAL_BLOCK_TRAY_FACTOR As UInteger
Visual C++
public:
literal unsigned int TOTAL_BLOCK_TRAY_FACTOR

See Also

MCdicom Structure
MCdicom Members


TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Total Block Tray Water-Equivalent Thickness (300A,00F3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int TOTAL_BLOCK_TRAY_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


TOTAL_COLLIMATION_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_COLLIMATION_WIDTH Field
MCdicom Structure See Also Send Feedback
Total Collimation Width (0018,9307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_COLLIMATION_WIDTH
Visual Basic
Public Const TOTAL_COLLIMATION_WIDTH As UInteger
Visual C++
public:
literal unsigned int TOTAL_COLLIMATION_WIDTH

See Also

MCdicom Structure
MCdicom Members


TOTAL_COMPENSATOR_TRAY_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_COMPENSATOR_TRAY_FACTOR Field
MCdicom Structure See Also Send Feedback
Total Compensator Tray Factor (300A,00E2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_COMPENSATOR_TRAY_FACTOR
Visual Basic
Public Const TOTAL_COMPENSATOR_TRAY_FACTOR As UInteger
Visual C++
public:
literal unsigned int TOTAL_COMPENSATOR_TRAY_FACTOR

See Also

MCdicom Structure
MCdicom Members


TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Total Compensator Tray Water-Equivalent Thickness (300A,02E3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int TOTAL_COMPENSATOR_TRAY_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


TOTAL_GAIN_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_GAIN_RETIRED Field
MCdicom Structure See Also Send Feedback
Total Gain RETIRED (0018,5040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_GAIN_RETIRED
Visual Basic
Public Const TOTAL_GAIN_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOTAL_GAIN_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOTAL_NUMBER_OF_EXPOSURES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_NUMBER_OF_EXPOSURES_RETIRED Field
MCdicom Structure See Also Send Feedback
Total Number of Exposures RETIRED (0040,0301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_NUMBER_OF_EXPOSURES_RETIRED
Visual Basic
Public Const TOTAL_NUMBER_OF_EXPOSURES_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOTAL_NUMBER_OF_EXPOSURES_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED Field
MCdicom Structure See Also Send Feedback
Total Number of Pieces of Media Created (2200,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED
Visual Basic
Public Const TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED As UInteger
Visual C++
public:
literal unsigned int TOTAL_NUMBER_OF_PIECES_OF_MEDIA_CREATED

See Also

MCdicom Structure
MCdicom Members


TOTAL_NUMBER_OF_STUDY_RECORDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_NUMBER_OF_STUDY_RECORDS Field
MCdicom Structure See Also Send Feedback
Total Number of Study Records (0008,0428)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_NUMBER_OF_STUDY_RECORDS
Visual Basic
Public Const TOTAL_NUMBER_OF_STUDY_RECORDS As UInteger
Visual C++
public:
literal unsigned int TOTAL_NUMBER_OF_STUDY_RECORDS

See Also

MCdicom Structure
MCdicom Members


TOTAL_PIXEL_MATRIX_COLUMNS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PIXEL_MATRIX_COLUMNS Field
MCdicom Structure See Also Send Feedback
Total Pixel Matrix Columns (0048,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PIXEL_MATRIX_COLUMNS
Visual Basic
Public Const TOTAL_PIXEL_MATRIX_COLUMNS As UInteger
Visual C++
public:
literal unsigned int TOTAL_PIXEL_MATRIX_COLUMNS

See Also

MCdicom Structure
MCdicom Members


TOTAL_PIXEL_MATRIX_FOCAL_PLANES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PIXEL_MATRIX_FOCAL_PLANES Field
MCdicom Structure See Also Send Feedback
Total Pixel Matrix Focal Planes (0048,0303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PIXEL_MATRIX_FOCAL_PLANES
Visual Basic
Public Const TOTAL_PIXEL_MATRIX_FOCAL_PLANES As UInteger
Visual C++
public:
literal unsigned int TOTAL_PIXEL_MATRIX_FOCAL_PLANES

See Also

MCdicom Structure
MCdicom Members


TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Total Pixel Matrix Origin Sequence (0048,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE
Visual Basic
Public Const TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TOTAL_PIXEL_MATRIX_ORIGIN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TOTAL_PIXEL_MATRIX_ROWS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PIXEL_MATRIX_ROWS Field
MCdicom Structure See Also Send Feedback
Total Pixel Matrix Rows (0048,0007)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PIXEL_MATRIX_ROWS
Visual Basic
Public Const TOTAL_PIXEL_MATRIX_ROWS As UInteger
Visual C++
public:
literal unsigned int TOTAL_PIXEL_MATRIX_ROWS

See Also

MCdicom Structure
MCdicom Members


TOTAL_PRESCRIPTION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PRESCRIPTION_DOSE Field
MCdicom Structure See Also Send Feedback
Total Prescription Dose (300C,0115)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PRESCRIPTION_DOSE
Visual Basic
Public Const TOTAL_PRESCRIPTION_DOSE As UInteger
Visual C++
public:
literal unsigned int TOTAL_PRESCRIPTION_DOSE

See Also

MCdicom Structure
MCdicom Members


TOTAL_PROCESSING_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_PROCESSING_TIME Field
MCdicom Structure See Also Send Feedback
Total Processing Time (4010,1069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_PROCESSING_TIME
Visual Basic
Public Const TOTAL_PROCESSING_TIME As UInteger
Visual C++
public:
literal unsigned int TOTAL_PROCESSING_TIME

See Also

MCdicom Structure
MCdicom Members


TOTAL_REFERENCE_AIR_KERMA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_REFERENCE_AIR_KERMA Field
MCdicom Structure See Also Send Feedback
Total Reference Air Kerma (300A,0250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_REFERENCE_AIR_KERMA
Visual Basic
Public Const TOTAL_REFERENCE_AIR_KERMA As UInteger
Visual C++
public:
literal unsigned int TOTAL_REFERENCE_AIR_KERMA

See Also

MCdicom Structure
MCdicom Members


TOTAL_TIME_OF_FLUOROSCOPY_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_TIME_OF_FLUOROSCOPY_RETIRED Field
MCdicom Structure See Also Send Feedback
Total Time of Fluoroscopy RETIRED (0040,0300)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_TIME_OF_FLUOROSCOPY_RETIRED
Visual Basic
Public Const TOTAL_TIME_OF_FLUOROSCOPY_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOTAL_TIME_OF_FLUOROSCOPY_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOTAL_TIME_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_TIME_RETIRED Field
MCdicom Structure See Also Send Feedback
Total Time RETIRED (5000,200A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_TIME_RETIRED
Visual Basic
Public Const TOTAL_TIME_RETIRED As UInteger
Visual C++
public:
literal unsigned int TOTAL_TIME_RETIRED

See Also

MCdicom Structure
MCdicom Members


TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS Field
MCdicom Structure See Also Send Feedback
Total Wedge Tray Water-Equivalent Thickness (300A,00D7)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS
Visual Basic
Public Const TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS As UInteger
Visual C++
public:
literal unsigned int TOTAL_WEDGE_TRAY_WATER_EQUIVALENT_THICKNESS

See Also

MCdicom Structure
MCdicom Members


TRACK_POINT_INDEX_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_POINT_INDEX_LIST Field
MCdicom Structure See Also Send Feedback
Track Point Index List (0066,0129)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_POINT_INDEX_LIST
Visual Basic
Public Const TRACK_POINT_INDEX_LIST As UInteger
Visual C++
public:
literal unsigned int TRACK_POINT_INDEX_LIST

See Also

MCdicom Structure
MCdicom Members


TRACK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Track Sequence (0066,0102)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SEQUENCE
Visual Basic
Public Const TRACK_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACK_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Track Set Anatomical Type Code Sequence (0066,0108)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE
Visual Basic
Public Const TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_ANATOMICAL_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Track Set Description (0066,0107)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_DESCRIPTION
Visual Basic
Public Const TRACK_SET_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_LABEL Field
MCdicom Structure See Also Send Feedback
Track Set Label (0066,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_LABEL
Visual Basic
Public Const TRACK_SET_LABEL As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_LABEL

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_NUMBER Field
MCdicom Structure See Also Send Feedback
Track Set Number (0066,0105)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_NUMBER
Visual Basic
Public Const TRACK_SET_NUMBER As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_NUMBER

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Track Set Sequence (0066,0101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_SEQUENCE
Visual Basic
Public Const TRACK_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACK_SET_STATISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_SET_STATISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Track Set Statistics Sequence (0066,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_SET_STATISTICS_SEQUENCE
Visual Basic
Public Const TRACK_SET_STATISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACK_SET_STATISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACK_STATISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACK_STATISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Track Statistics Sequence (0066,0130)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACK_STATISTICS_SEQUENCE
Visual Basic
Public Const TRACK_STATISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACK_STATISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Tracking Algorithm Identification Sequence (0066,0104)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRACKING_ALGORITHM_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRACKING_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACKING_ID Field
MCdicom Structure See Also Send Feedback
Tracking ID (0062,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACKING_ID
Visual Basic
Public Const TRACKING_ID As UInteger
Visual C++
public:
literal unsigned int TRACKING_ID

See Also

MCdicom Structure
MCdicom Members


TRACKING_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRACKING_UID Field
MCdicom Structure See Also Send Feedback
Tracking UID (0062,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRACKING_UID
Visual Basic
Public Const TRACKING_UID As UInteger
Visual C++
public:
literal unsigned int TRACKING_UID

See Also

MCdicom Structure
MCdicom Members


TRANSACTION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSACTION_STATUS Field
MCdicom Structure See Also Send Feedback
Transaction Status (0008,0417)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSACTION_STATUS
Visual Basic
Public Const TRANSACTION_STATUS As UInteger
Visual C++
public:
literal unsigned int TRANSACTION_STATUS

See Also

MCdicom Structure
MCdicom Members


TRANSACTION_STATUS_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSACTION_STATUS_COMMENT Field
MCdicom Structure See Also Send Feedback
Transaction Status Comment (0008,0418)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSACTION_STATUS_COMMENT
Visual Basic
Public Const TRANSACTION_STATUS_COMMENT As UInteger
Visual C++
public:
literal unsigned int TRANSACTION_STATUS_COMMENT

See Also

MCdicom Structure
MCdicom Members


TRANSACTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSACTION_UID Field
MCdicom Structure See Also Send Feedback
Transaction UID (0008,1195)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSACTION_UID
Visual Basic
Public Const TRANSACTION_UID As UInteger
Visual C++
public:
literal unsigned int TRANSACTION_UID

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_APPLICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_APPLICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Application Code Sequence (0018,980F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_APPLICATION_CODE_SEQUENCE
Visual Basic
Public Const TRANSDUCER_APPLICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_APPLICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Beam Steering Code Sequence (0018,980E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE
Visual Basic
Public Const TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_BEAM_STEERING_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_DATA Field
MCdicom Structure See Also Send Feedback
Transducer Data (0018,5010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_DATA
Visual Basic
Public Const TRANSDUCER_DATA As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_DATA

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Transducer Frequency (0018,6030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_FREQUENCY
Visual Basic
Public Const TRANSDUCER_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_GEOMETRY_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_GEOMETRY_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Geometry Code Sequence (0018,980D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_GEOMETRY_CODE_SEQUENCE
Visual Basic
Public Const TRANSDUCER_GEOMETRY_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_GEOMETRY_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Identification Sequence (0018,5011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const TRANSDUCER_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Orientation Modifier Sequence RETIRED (0008,2246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED
Visual Basic
Public Const TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_ORIENTATION_MODIFIER_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_ORIENTATION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_ORIENTATION_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Orientation RETIRED (0008,2204)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_ORIENTATION_RETIRED
Visual Basic
Public Const TRANSDUCER_ORIENTATION_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_ORIENTATION_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Orientation Sequence RETIRED (0008,2244)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED
Visual Basic
Public Const TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_ORIENTATION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Position Modifier Sequence RETIRED (0008,2242)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED
Visual Basic
Public Const TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_POSITION_MODIFIER_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_POSITION_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_POSITION_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Position RETIRED (0008,2200)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_POSITION_RETIRED
Visual Basic
Public Const TRANSDUCER_POSITION_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_POSITION_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_POSITION_SEQUENCE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_POSITION_SEQUENCE_RETIRED Field
MCdicom Structure See Also Send Feedback
Transducer Position Sequence RETIRED (0008,2240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_POSITION_SEQUENCE_RETIRED
Visual Basic
Public Const TRANSDUCER_POSITION_SEQUENCE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_POSITION_SEQUENCE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_RESPONSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_RESPONSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Response Sequence (0018,982C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_RESPONSE_SEQUENCE
Visual Basic
Public Const TRANSDUCER_RESPONSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_RESPONSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Scan Pattern Code Sequence (0018,9809)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE
Visual Basic
Public Const TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_SCAN_PATTERN_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_TECHNOLOGY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_TECHNOLOGY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transducer Technology Sequence (0018,9831)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_TECHNOLOGY_SEQUENCE
Visual Basic
Public Const TRANSDUCER_TECHNOLOGY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_TECHNOLOGY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSDUCER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSDUCER_TYPE Field
MCdicom Structure See Also Send Feedback
Transducer Type (0018,6031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSDUCER_TYPE
Visual Basic
Public Const TRANSDUCER_TYPE As UInteger
Visual C++
public:
literal unsigned int TRANSDUCER_TYPE

See Also

MCdicom Structure
MCdicom Members


TRANSFER_SYNTAX_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFER_SYNTAX_UID Field
MCdicom Structure See Also Send Feedback
Transfer Syntax UID (0002,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFER_SYNTAX_UID
Visual Basic
Public Const TRANSFER_SYNTAX_UID As UInteger
Visual C++
public:
literal unsigned int TRANSFER_SYNTAX_UID

See Also

MCdicom Structure
MCdicom Members


TRANSFER_TUBE_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFER_TUBE_LENGTH Field
MCdicom Structure See Also Send Feedback
Transfer Tube Length (300A,02A4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFER_TUBE_LENGTH
Visual Basic
Public Const TRANSFER_TUBE_LENGTH As UInteger
Visual C++
public:
literal unsigned int TRANSFER_TUBE_LENGTH

See Also

MCdicom Structure
MCdicom Members


TRANSFER_TUBE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFER_TUBE_NUMBER Field
MCdicom Structure See Also Send Feedback
Transfer Tube Number (300A,02A2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFER_TUBE_NUMBER
Visual Basic
Public Const TRANSFER_TUBE_NUMBER As UInteger
Visual C++
public:
literal unsigned int TRANSFER_TUBE_NUMBER

See Also

MCdicom Structure
MCdicom Members


TRANSFORM_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORM_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Transform Description (0014,2222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORM_DESCRIPTION
Visual Basic
Public Const TRANSFORM_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int TRANSFORM_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


TRANSFORM_NUMBER_OF_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORM_NUMBER_OF_AXES Field
MCdicom Structure See Also Send Feedback
Transform Number of Axes (0014,2224)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORM_NUMBER_OF_AXES
Visual Basic
Public Const TRANSFORM_NUMBER_OF_AXES As UInteger
Visual C++
public:
literal unsigned int TRANSFORM_NUMBER_OF_AXES

See Also

MCdicom Structure
MCdicom Members


TRANSFORM_ORDER_OF_AXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORM_ORDER_OF_AXES Field
MCdicom Structure See Also Send Feedback
Transform Order of Axes (0014,2226)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORM_ORDER_OF_AXES
Visual Basic
Public Const TRANSFORM_ORDER_OF_AXES As UInteger
Visual C++
public:
literal unsigned int TRANSFORM_ORDER_OF_AXES

See Also

MCdicom Structure
MCdicom Members


TRANSFORMATION_ALGORITHM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORMATION_ALGORITHM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transformation Algorithm Sequence (0022,1513)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORMATION_ALGORITHM_SEQUENCE
Visual Basic
Public Const TRANSFORMATION_ALGORITHM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSFORMATION_ALGORITHM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSFORMATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORMATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transformation Method Code Sequence (0022,1512)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORMATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const TRANSFORMATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSFORMATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSFORMED_AXIS_UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSFORMED_AXIS_UNITS Field
MCdicom Structure See Also Send Feedback
Transformed Axis Units (0014,2228)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSFORMED_AXIS_UNITS
Visual Basic
Public Const TRANSFORMED_AXIS_UNITS As UInteger
Visual C++
public:
literal unsigned int TRANSFORMED_AXIS_UNITS

See Also

MCdicom Structure
MCdicom Members


TRANSMIT_COIL_MANUFACTURER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMIT_COIL_MANUFACTURER_NAME Field
MCdicom Structure See Also Send Feedback
Transmit Coil Manufacturer Name (0018,9050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMIT_COIL_MANUFACTURER_NAME
Visual Basic
Public Const TRANSMIT_COIL_MANUFACTURER_NAME As UInteger
Visual C++
public:
literal unsigned int TRANSMIT_COIL_MANUFACTURER_NAME

See Also

MCdicom Structure
MCdicom Members


TRANSMIT_COIL_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMIT_COIL_NAME Field
MCdicom Structure See Also Send Feedback
Transmit Coil Name (0018,1251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMIT_COIL_NAME
Visual Basic
Public Const TRANSMIT_COIL_NAME As UInteger
Visual C++
public:
literal unsigned int TRANSMIT_COIL_NAME

See Also

MCdicom Structure
MCdicom Members


TRANSMIT_COIL_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMIT_COIL_TYPE Field
MCdicom Structure See Also Send Feedback
Transmit Coil Type (0018,9051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMIT_COIL_TYPE
Visual Basic
Public Const TRANSMIT_COIL_TYPE As UInteger
Visual C++
public:
literal unsigned int TRANSMIT_COIL_TYPE

See Also

MCdicom Structure
MCdicom Members


TRANSMIT_TRANSDUCER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMIT_TRANSDUCER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transmit Transducer Sequence (0014,4010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMIT_TRANSDUCER_SEQUENCE
Visual Basic
Public Const TRANSMIT_TRANSDUCER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSMIT_TRANSDUCER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Transmit Transducer Settings Sequence (0014,4050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE
Visual Basic
Public Const TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRANSMIT_TRANSDUCER_SETTINGS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRANSMITTER_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMITTER_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Transmitter Frequency (0018,9098)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMITTER_FREQUENCY
Visual Basic
Public Const TRANSMITTER_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int TRANSMITTER_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


TRANSMITTING_COIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSMITTING_COIL Field
MCdicom Structure See Also Send Feedback
Alias for tag TRANSMIT_COIL_NAME (0018,1251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSMITTING_COIL
Visual Basic
Public Const TRANSMITTING_COIL As UInteger
Visual C++
public:
literal unsigned int TRANSMITTING_COIL

See Also

MCdicom Structure
MCdicom Members


TRANSPORT_CLASSIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSPORT_CLASSIFICATION Field
MCdicom Structure See Also Send Feedback
Transport Classification (4010,1067)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSPORT_CLASSIFICATION
Visual Basic
Public Const TRANSPORT_CLASSIFICATION As UInteger
Visual C++
public:
literal unsigned int TRANSPORT_CLASSIFICATION

See Also

MCdicom Structure
MCdicom Members


TRANSVERSE_DETECTOR_SEPARATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSVERSE_DETECTOR_SEPARATION Field
MCdicom Structure See Also Send Feedback
Transverse Detector Separation (0018,9726)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSVERSE_DETECTOR_SEPARATION
Visual Basic
Public Const TRANSVERSE_DETECTOR_SEPARATION As UInteger
Visual C++
public:
literal unsigned int TRANSVERSE_DETECTOR_SEPARATION

See Also

MCdicom Structure
MCdicom Members


TRANSVERSE_MASH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRANSVERSE_MASH Field
MCdicom Structure See Also Send Feedback
Transverse Mash (0054,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRANSVERSE_MASH
Visual Basic
Public Const TRANSVERSE_MASH As UInteger
Visual C++
public:
literal unsigned int TRANSVERSE_MASH

See Also

MCdicom Structure
MCdicom Members


TRAY_ACCESSORY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRAY_ACCESSORY_CODE Field
MCdicom Structure See Also Send Feedback
Tray Accessory Code (300A,0355)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRAY_ACCESSORY_CODE
Visual Basic
Public Const TRAY_ACCESSORY_CODE As UInteger
Visual C++
public:
literal unsigned int TRAY_ACCESSORY_CODE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_CONTROL_POINT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_CONTROL_POINT_DATE Field
MCdicom Structure See Also Send Feedback
Treatment Control Point Date (3008,0024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_CONTROL_POINT_DATE
Visual Basic
Public Const TREATMENT_CONTROL_POINT_DATE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_CONTROL_POINT_DATE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_CONTROL_POINT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_CONTROL_POINT_TIME Field
MCdicom Structure See Also Send Feedback
Treatment Control Point Time (3008,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_CONTROL_POINT_TIME
Visual Basic
Public Const TREATMENT_CONTROL_POINT_TIME As UInteger
Visual C++
public:
literal unsigned int TREATMENT_CONTROL_POINT_TIME

See Also

MCdicom Structure
MCdicom Members


TREATMENT_DATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_DATE Field
MCdicom Structure See Also Send Feedback
Treatment Date (3008,0250)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_DATE
Visual Basic
Public Const TREATMENT_DATE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_DATE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_DELIVERY_CONTINUATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_DELIVERY_CONTINUATION_FLAG Field
MCdicom Structure See Also Send Feedback
Treatment Delivery Continuation Flag (300A,0708)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_DELIVERY_CONTINUATION_FLAG
Visual Basic
Public Const TREATMENT_DELIVERY_CONTINUATION_FLAG As UInteger
Visual C++
public:
literal unsigned int TREATMENT_DELIVERY_CONTINUATION_FLAG

See Also

MCdicom Structure
MCdicom Members


TREATMENT_DELIVERY_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_DELIVERY_TYPE Field
MCdicom Structure See Also Send Feedback
Treatment Delivery Type (300A,00CE)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_DELIVERY_TYPE
Visual Basic
Public Const TREATMENT_DELIVERY_TYPE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_DELIVERY_TYPE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Device Identification Sequence (300A,063A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE
Visual Basic
Public Const TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_DEVICE_IDENTIFICATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_MACHINE_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_MACHINE_NAME Field
MCdicom Structure See Also Send Feedback
Treatment Machine Name (300A,00B2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_MACHINE_NAME
Visual Basic
Public Const TREATMENT_MACHINE_NAME As UInteger
Visual C++
public:
literal unsigned int TREATMENT_MACHINE_NAME

See Also

MCdicom Structure
MCdicom Members


TREATMENT_MACHINE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_MACHINE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Machine Sequence (300A,0206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_MACHINE_SEQUENCE
Visual Basic
Public Const TREATMENT_MACHINE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_MACHINE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Machine Special Mode Code Sequence (300A,0635)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE
Visual Basic
Public Const TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_MACHINE_SPECIAL_MODE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_POSITION_GROUP_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_POSITION_GROUP_LABEL Field
MCdicom Structure See Also Send Feedback
Treatment Position Group Label (300A,0608)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_POSITION_GROUP_LABEL
Visual Basic
Public Const TREATMENT_POSITION_GROUP_LABEL As UInteger
Visual C++
public:
literal unsigned int TREATMENT_POSITION_GROUP_LABEL

See Also

MCdicom Structure
MCdicom Members


TREATMENT_POSITION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_POSITION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Position Group Sequence (300A,060A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_POSITION_GROUP_SEQUENCE
Visual Basic
Public Const TREATMENT_POSITION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_POSITION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_POSITION_GROUP_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_POSITION_GROUP_UID Field
MCdicom Structure See Also Send Feedback
Treatment Position Group UID (300A,0609)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_POSITION_GROUP_UID
Visual Basic
Public Const TREATMENT_POSITION_GROUP_UID As UInteger
Visual C++
public:
literal unsigned int TREATMENT_POSITION_GROUP_UID

See Also

MCdicom Structure
MCdicom Members


TREATMENT_POSITION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_POSITION_INDEX Field
MCdicom Structure See Also Send Feedback
Treatment Position Index (300A,0606)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_POSITION_INDEX
Visual Basic
Public Const TREATMENT_POSITION_INDEX As UInteger
Visual C++
public:
literal unsigned int TREATMENT_POSITION_INDEX

See Also

MCdicom Structure
MCdicom Members


TREATMENT_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Position Sequence (300A,063F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_POSITION_SEQUENCE
Visual Basic
Public Const TREATMENT_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_PROTOCOLS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_PROTOCOLS Field
MCdicom Structure See Also Send Feedback
Treatment Protocols (300A,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_PROTOCOLS
Visual Basic
Public Const TREATMENT_PROTOCOLS As UInteger
Visual C++
public:
literal unsigned int TREATMENT_PROTOCOLS

See Also

MCdicom Structure
MCdicom Members


TREATMENT_RECORD_CONTENT_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_RECORD_CONTENT_ORIGIN Field
MCdicom Structure See Also Send Feedback
Treatment Record Content Origin (300A,0709)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_RECORD_CONTENT_ORIGIN
Visual Basic
Public Const TREATMENT_RECORD_CONTENT_ORIGIN As UInteger
Visual C++
public:
literal unsigned int TREATMENT_RECORD_CONTENT_ORIGIN

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Session Application Setup Sequence (3008,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE
Visual Basic
Public Const TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SESSION_APPLICATION_SETUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SESSION_BEAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SESSION_BEAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Session Beam Sequence (3008,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SESSION_BEAM_SEQUENCE
Visual Basic
Public Const TREATMENT_SESSION_BEAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SESSION_BEAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SESSION_ION_BEAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SESSION_ION_BEAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Session Ion Beam Sequence (3008,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SESSION_ION_BEAM_SEQUENCE
Visual Basic
Public Const TREATMENT_SESSION_ION_BEAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SESSION_ION_BEAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SESSION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SESSION_UID Field
MCdicom Structure See Also Send Feedback
Treatment Session UID (300A,0700)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SESSION_UID
Visual Basic
Public Const TREATMENT_SESSION_UID As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SESSION_UID

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SITE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SITE Field
MCdicom Structure See Also Send Feedback
Treatment Site (3010,0077)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SITE
Visual Basic
Public Const TREATMENT_SITE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SITE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SITE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SITE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Site Code Sequence (3010,0078)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SITE_CODE_SEQUENCE
Visual Basic
Public Const TREATMENT_SITE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SITE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SITE_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SITE_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Site Modifier Code Sequence (3010,0089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SITE_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const TREATMENT_SITE_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SITE_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SITES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SITES_RETIRED Field
MCdicom Structure See Also Send Feedback
Treatment Sites RETIRED (300A,000B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SITES_RETIRED
Visual Basic
Public Const TREATMENT_SITES_RETIRED As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SITES_RETIRED

See Also

MCdicom Structure
MCdicom Members


TREATMENT_STATUS_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_STATUS_COMMENT Field
MCdicom Structure See Also Send Feedback
Treatment Status Comment (3008,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_STATUS_COMMENT
Visual Basic
Public Const TREATMENT_STATUS_COMMENT As UInteger
Visual C++
public:
literal unsigned int TREATMENT_STATUS_COMMENT

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Summary Calculated Dose Reference Sequence (3008,0050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SUMMARY_CALCULATED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Summary Measured Dose Reference Sequence (3008,00E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag TREATMENT_SUMMARY_MEASURED_DOSE_REFERENCE_SEQUENCE (3008,00E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE
Visual Basic
Public Const TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_SUMMARY_MESURED_DOSE_REFERENCE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TECHNIQUE_NOTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TECHNIQUE_NOTES Field
MCdicom Structure See Also Send Feedback
Treatment Technique Notes (3010,007A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TECHNIQUE_NOTES
Visual Basic
Public Const TREATMENT_TECHNIQUE_NOTES As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TECHNIQUE_NOTES

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TERMINATION_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TERMINATION_CODE Field
MCdicom Structure See Also Send Feedback
Alias for tag Treatment Termination Code RETIRED (3008,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TERMINATION_CODE
Visual Basic
Public Const TREATMENT_TERMINATION_CODE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TERMINATION_CODE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TERMINATION_CODE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TERMINATION_CODE_RETIRED Field
MCdicom Structure See Also Send Feedback
Treatment Termination Code RETIRED (3008,002B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TERMINATION_CODE_RETIRED
Visual Basic
Public Const TREATMENT_TERMINATION_CODE_RETIRED As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TERMINATION_CODE_RETIRED

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TERMINATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TERMINATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Treatment Termination Description (300A,0730)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TERMINATION_DESCRIPTION
Visual Basic
Public Const TREATMENT_TERMINATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TERMINATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TERMINATION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TERMINATION_STATUS Field
MCdicom Structure See Also Send Feedback
Treatment Termination Status (3008,002A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TERMINATION_STATUS
Visual Basic
Public Const TREATMENT_TERMINATION_STATUS As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TERMINATION_STATUS

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TIME Field
MCdicom Structure See Also Send Feedback
Treatment Time (3008,0251)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TIME
Visual Basic
Public Const TREATMENT_TIME As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TIME

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TIME_LIMIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TIME_LIMIT Field
MCdicom Structure See Also Send Feedback
Treatment Time Limit (300A,062E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TIME_LIMIT
Visual Basic
Public Const TREATMENT_TIME_LIMIT As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TIME_LIMIT

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Attribute Sequence (300A,0733)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_ATTRIBUTE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_CATEGORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_CATEGORY Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Category (300A,0732)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_CATEGORY
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_CATEGORY As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_CATEGORY

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Cause Code Sequence (300A,0762)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_CAUSE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation DateTime (300A,0736)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_DATETIME
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Description (300A,0734)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Identification (300A,0735)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_IDENTIFICATION

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Sequence (300A,0731)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_SEQUENCE
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Treatment Tolerance Violation Type Code Sequence (300A,0761)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE
Visual Basic
Public Const TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TREATMENT_TOLERANCE_VIOLATION_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TREATMENT_VERIFICATION_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TREATMENT_VERIFICATION_STATUS Field
MCdicom Structure See Also Send Feedback
Treatment Verification Status (3008,002C)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TREATMENT_VERIFICATION_STATUS
Visual Basic
Public Const TREATMENT_VERIFICATION_STATUS As UInteger
Visual C++
public:
literal unsigned int TREATMENT_VERIFICATION_STATUS

See Also

MCdicom Structure
MCdicom Members


TRIANGLE_FAN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIANGLE_FAN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Triangle Fan Sequence (0066,0027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIANGLE_FAN_SEQUENCE
Visual Basic
Public Const TRIANGLE_FAN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRIANGLE_FAN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRIANGLE_POINT_INDEX_LIST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIANGLE_POINT_INDEX_LIST_RETIRED Field
MCdicom Structure See Also Send Feedback
Triangle Point Index List RETIRED (0066,0023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIANGLE_POINT_INDEX_LIST_RETIRED
Visual Basic
Public Const TRIANGLE_POINT_INDEX_LIST_RETIRED As UInteger
Visual C++
public:
literal unsigned int TRIANGLE_POINT_INDEX_LIST_RETIRED

See Also

MCdicom Structure
MCdicom Members


TRIANGLE_STRIP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIANGLE_STRIP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Triangle Strip Sequence (0066,0026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIANGLE_STRIP_SEQUENCE
Visual Basic
Public Const TRIANGLE_STRIP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TRIANGLE_STRIP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TRIGGER_SAMPLE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_SAMPLE_POSITION Field
MCdicom Structure See Also Send Feedback
Trigger Sample Position (0018,106E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_SAMPLE_POSITION
Visual Basic
Public Const TRIGGER_SAMPLE_POSITION As UInteger
Visual C++
public:
literal unsigned int TRIGGER_SAMPLE_POSITION

See Also

MCdicom Structure
MCdicom Members


TRIGGER_SOURCE_OR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_SOURCE_OR_TYPE Field
MCdicom Structure See Also Send Feedback
Trigger Source or Type (0018,1061)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_SOURCE_OR_TYPE
Visual Basic
Public Const TRIGGER_SOURCE_OR_TYPE As UInteger
Visual C++
public:
literal unsigned int TRIGGER_SOURCE_OR_TYPE

See Also

MCdicom Structure
MCdicom Members


TRIGGER_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_TIME Field
MCdicom Structure See Also Send Feedback
Trigger Time (0018,1060)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_TIME
Visual Basic
Public Const TRIGGER_TIME As UInteger
Visual C++
public:
literal unsigned int TRIGGER_TIME

See Also

MCdicom Structure
MCdicom Members


TRIGGER_TIME_OFFSET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_TIME_OFFSET Field
MCdicom Structure See Also Send Feedback
Trigger Time Offset (0018,1069)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_TIME_OFFSET
Visual Basic
Public Const TRIGGER_TIME_OFFSET As UInteger
Visual C++
public:
literal unsigned int TRIGGER_TIME_OFFSET

See Also

MCdicom Structure
MCdicom Members


TRIGGER_VECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_VECTOR Field
MCdicom Structure See Also Send Feedback
Trigger Vector (0054,0210)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_VECTOR
Visual Basic
Public Const TRIGGER_VECTOR As UInteger
Visual C++
public:
literal unsigned int TRIGGER_VECTOR

See Also

MCdicom Structure
MCdicom Members


TRIGGER_WINDOW Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIGGER_WINDOW Field
MCdicom Structure See Also Send Feedback
Trigger Window (0018,1094)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIGGER_WINDOW
Visual Basic
Public Const TRIGGER_WINDOW As UInteger
Visual C++
public:
literal unsigned int TRIGGER_WINDOW

See Also

MCdicom Structure
MCdicom Members


TRIM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TRIM Field
MCdicom Structure See Also Send Feedback
Trim (2010,0140)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TRIM
Visual Basic
Public Const TRIM As UInteger
Visual C++
public:
literal unsigned int TRIM

See Also

MCdicom Structure
MCdicom Members


TUBE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TUBE_ANGLE Field
MCdicom Structure See Also Send Feedback
Tube Angle (0018,9303)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TUBE_ANGLE
Visual Basic
Public Const TUBE_ANGLE As UInteger
Visual C++
public:
literal unsigned int TUBE_ANGLE

See Also

MCdicom Structure
MCdicom Members


TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA Field
MCdicom Structure See Also Send Feedback
Two Dimensional to Three Dimensional Map Data (0022,1531)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA
Visual Basic
Public Const TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA As UInteger
Visual C++
public:
literal unsigned int TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_DATA

See Also

MCdicom Structure
MCdicom Members


TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Two Dimensional to Three Dimensional Map Sequence (0022,1518)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE
Visual Basic
Public Const TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int TWO_DIMENSIONAL_TO_THREE_DIMENSIONAL_MAP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_DATA_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_DATA_RETIRED Field
MCdicom Structure See Also Send Feedback
Type of Data RETIRED (5000,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_DATA_RETIRED
Visual Basic
Public Const TYPE_OF_DATA_RETIRED As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_DATA_RETIRED

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_DETECTOR_MOTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_DETECTOR_MOTION Field
MCdicom Structure See Also Send Feedback
Type of Detector Motion (0054,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_DETECTOR_MOTION
Visual Basic
Public Const TYPE_OF_DETECTOR_MOTION As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_DETECTOR_MOTION

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_FILTERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_FILTERS Field
MCdicom Structure See Also Send Feedback
Type of Filters (0018,1161)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_FILTERS
Visual Basic
Public Const TYPE_OF_FILTERS As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_FILTERS

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_INSTANCES Field
MCdicom Structure See Also Send Feedback
Type of Instances (0040,E020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_INSTANCES
Visual Basic
Public Const TYPE_OF_INSTANCES As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_INSTANCES

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_OPTICAL_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_OPTICAL_CORRECTION Field
MCdicom Structure See Also Send Feedback
Type of Optical Correction (0022,1046)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_OPTICAL_CORRECTION
Visual Basic
Public Const TYPE_OF_OPTICAL_CORRECTION As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_OPTICAL_CORRECTION

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_PATIENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_PATIENT_ID Field
MCdicom Structure See Also Send Feedback
Type of Patient ID (0010,0022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_PATIENT_ID
Visual Basic
Public Const TYPE_OF_PATIENT_ID As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_PATIENT_ID

See Also

MCdicom Structure
MCdicom Members


TYPE_OF_SYNCHRONIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..TYPE_OF_SYNCHRONIZATION Field
MCdicom Structure See Also Send Feedback
Type of Synchronization (0072,0434)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint TYPE_OF_SYNCHRONIZATION
Visual Basic
Public Const TYPE_OF_SYNCHRONIZATION As UInteger
Visual C++
public:
literal unsigned int TYPE_OF_SYNCHRONIZATION

See Also

MCdicom Structure
MCdicom Members


U_VALUE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..U_VALUE_DATA Field
MCdicom Structure See Also Send Feedback
U Value Data (0080,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint U_VALUE_DATA
Visual Basic
Public Const U_VALUE_DATA As UInteger
Visual C++
public:
literal unsigned int U_VALUE_DATA

See Also

MCdicom Structure
MCdicom Members


UDI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UDI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
UDI Sequence (0018,100A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UDI_SEQUENCE
Visual Basic
Public Const UDI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UDI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UID Field
MCdicom Structure See Also Send Feedback
UID (0040,A124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UID
Visual Basic
Public Const UID As UInteger
Visual C++
public:
literal unsigned int UID

See Also

MCdicom Structure
MCdicom Members


ULTRASOUND_ACQUISITION_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ULTRASOUND_ACQUISITION_GEOMETRY Field
MCdicom Structure See Also Send Feedback
Ultrasound Acquisition Geometry (0020,9307)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ULTRASOUND_ACQUISITION_GEOMETRY
Visual Basic
Public Const ULTRASOUND_ACQUISITION_GEOMETRY As UInteger
Visual C++
public:
literal unsigned int ULTRASOUND_ACQUISITION_GEOMETRY

See Also

MCdicom Structure
MCdicom Members


ULTRASOUND_COLOR_DATA_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ULTRASOUND_COLOR_DATA_PRESENT Field
MCdicom Structure See Also Send Feedback
Ultrasound Color Data Present (0028,0014)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ULTRASOUND_COLOR_DATA_PRESENT
Visual Basic
Public Const ULTRASOUND_COLOR_DATA_PRESENT As UInteger
Visual C++
public:
literal unsigned int ULTRASOUND_COLOR_DATA_PRESENT

See Also

MCdicom Structure
MCdicom Members


ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ultrasound Ophthalmic Axial Length Measurements Sequence (0022,1220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE
Visual Basic
Public Const ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ULTRASOUND_OPHTHALMIC_AXIAL_LENGTH_MEASUREMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Ultrasound Selected Ophthalmic Axial Length Sequence (0022,1230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE
Visual Basic
Public Const ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int ULTRASOUND_SELECTED_OPHTHALMIC_AXIAL_LENGTH_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Unassigned Per-Frame Converted Attributes Sequence (0020,9171)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNASSIGNED_PER_FRAME_CONVERTED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Unassigned Shared Converted Attributes Sequence (0020,9170)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE
Visual Basic
Public Const UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNASSIGNED_SHARED_CONVERTED_ATTRIBUTES_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNDERLINED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNDERLINED Field
MCdicom Structure See Also Send Feedback
Underlined (0070,0248)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNDERLINED
Visual Basic
Public Const UNDERLINED As UInteger
Visual C++
public:
literal unsigned int UNDERLINED

See Also

MCdicom Structure
MCdicom Members


UNFORMATTED_TEXT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNFORMATTED_TEXT_VALUE Field
MCdicom Structure See Also Send Feedback
Unformatted Text Value (0070,0006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNFORMATTED_TEXT_VALUE
Visual Basic
Public Const UNFORMATTED_TEXT_VALUE As UInteger
Visual C++
public:
literal unsigned int UNFORMATTED_TEXT_VALUE

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE (0074,1008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_COMMUNICATIONS_URI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE (0074,100E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_DISCONTINUATION_REASON_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_LIST_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_LIST_STATUS Field
MCdicom Structure See Also Send Feedback
Unified Procedure Step List Status (0074,1246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_LIST_STATUS
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_LIST_STATUS As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_LIST_STATUS

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Unified Procedure Step Performed Procedure Sequence (0074,1216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_PROGRESS Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_PROGRESS (0074,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_PROGRESS
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_PROGRESS As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_PROGRESS

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_PROGRESS_DESCRIPTION (0074,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_PROGRESS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UNIFIED_PROCEDURE_STEP_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFIED_PROCEDURE_STEP_STATE Field
MCdicom Structure See Also Send Feedback
Alias for tag PROCEDURE_STEP_STATE (0074,1000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFIED_PROCEDURE_STEP_STATE
Visual Basic
Public Const UNIFIED_PROCEDURE_STEP_STATE As UInteger
Visual C++
public:
literal unsigned int UNIFIED_PROCEDURE_STEP_STATE

See Also

MCdicom Structure
MCdicom Members


UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Uniform Resource Locator (Trial) RETIRED (0040,A992)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED
Visual Basic
Public Const UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int UNIFORM_RESOURCE_LOCATOR_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


UNIQUE_DEVICE_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIQUE_DEVICE_IDENTIFIER Field
MCdicom Structure See Also Send Feedback
Unique Device Identifier (0018,1009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIQUE_DEVICE_IDENTIFIER
Visual Basic
Public Const UNIQUE_DEVICE_IDENTIFIER As UInteger
Visual C++
public:
literal unsigned int UNIQUE_DEVICE_IDENTIFIER

See Also

MCdicom Structure
MCdicom Members


UNITS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNITS Field
MCdicom Structure See Also Send Feedback
Units (0054,1001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNITS
Visual Basic
Public Const UNITS As UInteger
Visual C++
public:
literal unsigned int UNITS

See Also

MCdicom Structure
MCdicom Members


UNIVERSAL_ENTITY_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIVERSAL_ENTITY_ID Field
MCdicom Structure See Also Send Feedback
Universal Entity ID (0040,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIVERSAL_ENTITY_ID
Visual Basic
Public Const UNIVERSAL_ENTITY_ID As UInteger
Visual C++
public:
literal unsigned int UNIVERSAL_ENTITY_ID

See Also

MCdicom Structure
MCdicom Members


UNIVERSAL_ENTITY_ID_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNIVERSAL_ENTITY_ID_TYPE Field
MCdicom Structure See Also Send Feedback
Universal Entity ID Type (0040,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNIVERSAL_ENTITY_ID_TYPE
Visual Basic
Public Const UNIVERSAL_ENTITY_ID_TYPE As UInteger
Visual C++
public:
literal unsigned int UNIVERSAL_ENTITY_ID_TYPE

See Also

MCdicom Structure
MCdicom Members


UNSPECIFIED_LATERALITY_LENS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UNSPECIFIED_LATERALITY_LENS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Unspecified Laterality Lens Sequence (0046,0016)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UNSPECIFIED_LATERALITY_LENS_SEQUENCE
Visual Basic
Public Const UNSPECIFIED_LATERALITY_LENS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UNSPECIFIED_LATERALITY_LENS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UPDATED_METADATA_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPDATED_METADATA_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Updated Metadata Sequence (0008,041E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPDATED_METADATA_SEQUENCE
Visual Basic
Public Const UPDATED_METADATA_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UPDATED_METADATA_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UPPER_CUTOFF_FREQUENCY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPPER_CUTOFF_FREQUENCY Field
MCdicom Structure See Also Send Feedback
Upper Cutoff Frequency (0018,9830)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPPER_CUTOFF_FREQUENCY
Visual Basic
Public Const UPPER_CUTOFF_FREQUENCY As UInteger
Visual C++
public:
literal unsigned int UPPER_CUTOFF_FREQUENCY

See Also

MCdicom Structure
MCdicom Members


UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES Field
MCdicom Structure See Also Send Feedback
Upper Limit Number Of Persistent Fluoroscopy Frames (0018,11B5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES
Visual Basic
Public Const UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES As UInteger
Visual C++
public:
literal unsigned int UPPER_LIMIT_NUMBER_OF_PERSISTENT_FLUOROSCOPY_FRAMES

See Also

MCdicom Structure
MCdicom Members


UPPER_LOWER_PIXEL_VALUES_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPPER_LOWER_PIXEL_VALUES_RETIRED Field
MCdicom Structure See Also Send Feedback
Upper/Lower Pixel Values RETIRED (0018,1240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPPER_LOWER_PIXEL_VALUES_RETIRED
Visual Basic
Public Const UPPER_LOWER_PIXEL_VALUES_RETIRED As UInteger
Visual C++
public:
literal unsigned int UPPER_LOWER_PIXEL_VALUES_RETIRED

See Also

MCdicom Structure
MCdicom Members


UPS_LIST_STATUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPS_LIST_STATUS Field
MCdicom Structure See Also Send Feedback
Alias for tag UNIFIED_PROCEDURE_STEP_LIST_STATUS (0074,1246)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPS_LIST_STATUS
Visual Basic
Public Const UPS_LIST_STATUS As UInteger
Visual C++
public:
literal unsigned int UPS_LIST_STATUS

See Also

MCdicom Structure
MCdicom Members


UPS_PERFORMED_PROCEDURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPS_PERFORMED_PROCEDURE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag UNIFIED_PROCEDURE_STEP_PERFORMED_PROCEDURE_SEQUENCE (0074,1216)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPS_PERFORMED_PROCEDURE_SEQUENCE
Visual Basic
Public Const UPS_PERFORMED_PROCEDURE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UPS_PERFORMED_PROCEDURE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


UPS_PROGRESS_INFORMATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UPS_PROGRESS_INFORMATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag UNIFIED_PROCEDURE_STEP_PROGRESS_INFORMATION_SEQUENCE (0074,1002)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UPS_PROGRESS_INFORMATION_SEQUENCE
Visual Basic
Public Const UPS_PROGRESS_INFORMATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UPS_PROGRESS_INFORMATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Urgency or Priority Alerts (Trial) RETIRED (0040,A057)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED
Visual Basic
Public Const URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int URGENCY_OR_PRIORITY_ALERTS_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


URI_WITHIN_ENCAPSULATED_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..URI_WITHIN_ENCAPSULATED_DOCUMENT Field
MCdicom Structure See Also Send Feedback
URI Within Encapsulated Document (0068,7005)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint URI_WITHIN_ENCAPSULATED_DOCUMENT
Visual Basic
Public Const URI_WITHIN_ENCAPSULATED_DOCUMENT As UInteger
Visual C++
public:
literal unsigned int URI_WITHIN_ENCAPSULATED_DOCUMENT

See Also

MCdicom Structure
MCdicom Members


URN_CODE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..URN_CODE_VALUE Field
MCdicom Structure See Also Send Feedback
URN Code Value (0008,0120)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint URN_CODE_VALUE
Visual Basic
Public Const URN_CODE_VALUE As UInteger
Visual C++
public:
literal unsigned int URN_CODE_VALUE

See Also

MCdicom Structure
MCdicom Members


US_IMAGE_DESCRIPTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..US_IMAGE_DESCRIPTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
US Image Description Sequence (0018,9806)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint US_IMAGE_DESCRIPTION_SEQUENCE
Visual Basic
Public Const US_IMAGE_DESCRIPTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int US_IMAGE_DESCRIPTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


USED_FIDUCIALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..USED_FIDUCIALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Used Fiducials Sequence (0070,0314)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint USED_FIDUCIALS_SEQUENCE
Visual Basic
Public Const USED_FIDUCIALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int USED_FIDUCIALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


USED_RT_STRUCTURE_SET_ROI_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..USED_RT_STRUCTURE_SET_ROI_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Used RT Structure Set ROI Sequence (0070,0315)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint USED_RT_STRUCTURE_SET_ROI_SEQUENCE
Visual Basic
Public Const USED_RT_STRUCTURE_SET_ROI_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int USED_RT_STRUCTURE_SET_ROI_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


USED_SEGMENTS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..USED_SEGMENTS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Used Segments Sequence (0062,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint USED_SEGMENTS_SEQUENCE
Visual Basic
Public Const USED_SEGMENTS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int USED_SEGMENTS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


USER_CONTENT_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..USER_CONTENT_LABEL Field
MCdicom Structure See Also Send Feedback
User Content Label (3010,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint USER_CONTENT_LABEL
Visual Basic
Public Const USER_CONTENT_LABEL As UInteger
Visual C++
public:
literal unsigned int USER_CONTENT_LABEL

See Also

MCdicom Structure
MCdicom Members


USER_CONTENT_LONG_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..USER_CONTENT_LONG_LABEL Field
MCdicom Structure See Also Send Feedback
User Content Long Label (3010,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint USER_CONTENT_LONG_LABEL
Visual Basic
Public Const USER_CONTENT_LONG_LABEL As UInteger
Visual C++
public:
literal unsigned int USER_CONTENT_LONG_LABEL

See Also

MCdicom Structure
MCdicom Members


UV_MAPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..UV_MAPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
UV Mapping Sequence (0080,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint UV_MAPPING_SEQUENCE
Visual Basic
Public Const UV_MAPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int UV_MAPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


V_VALUE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..V_VALUE_DATA Field
MCdicom Structure See Also Send Feedback
V Value Data (0080,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint V_VALUE_DATA
Visual Basic
Public Const V_VALUE_DATA As UInteger
Visual C++
public:
literal unsigned int V_VALUE_DATA

See Also

MCdicom Structure
MCdicom Members


VALUE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VALUE_TYPE Field
MCdicom Structure See Also Send Feedback
Value Type (0040,A040)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VALUE_TYPE
Visual Basic
Public Const VALUE_TYPE As UInteger
Visual C++
public:
literal unsigned int VALUE_TYPE

See Also

MCdicom Structure
MCdicom Members


VARIABLE_FLIP_ANGLE_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VARIABLE_FLIP_ANGLE_FLAG Field
MCdicom Structure See Also Send Feedback
Variable Flip Angle Flag (0018,1315)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VARIABLE_FLIP_ANGLE_FLAG
Visual Basic
Public Const VARIABLE_FLIP_ANGLE_FLAG As UInteger
Visual C++
public:
literal unsigned int VARIABLE_FLIP_ANGLE_FLAG

See Also

MCdicom Structure
MCdicom Members


VARIABLE_MODALITY_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VARIABLE_MODALITY_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Variable Modality LUT Sequence (0028,3001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VARIABLE_MODALITY_LUT_SEQUENCE
Visual Basic
Public Const VARIABLE_MODALITY_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VARIABLE_MODALITY_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VECTOR_ACCURACY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VECTOR_ACCURACY Field
MCdicom Structure See Also Send Feedback
Vector Accuracy (0066,0020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VECTOR_ACCURACY
Visual Basic
Public Const VECTOR_ACCURACY As UInteger
Visual C++
public:
literal unsigned int VECTOR_ACCURACY

See Also

MCdicom Structure
MCdicom Members


VECTOR_COORDINATE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VECTOR_COORDINATE_DATA Field
MCdicom Structure See Also Send Feedback
Vector Coordinate Data (0066,0021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VECTOR_COORDINATE_DATA
Visual Basic
Public Const VECTOR_COORDINATE_DATA As UInteger
Visual C++
public:
literal unsigned int VECTOR_COORDINATE_DATA

See Also

MCdicom Structure
MCdicom Members


VECTOR_DIMENSIONALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VECTOR_DIMENSIONALITY Field
MCdicom Structure See Also Send Feedback
Vector Dimensionality (0066,001F)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VECTOR_DIMENSIONALITY
Visual Basic
Public Const VECTOR_DIMENSIONALITY As UInteger
Visual C++
public:
literal unsigned int VECTOR_DIMENSIONALITY

See Also

MCdicom Structure
MCdicom Members


VECTOR_GRID_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VECTOR_GRID_DATA Field
MCdicom Structure See Also Send Feedback
Vector Grid Data (0064,0009)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VECTOR_GRID_DATA
Visual Basic
Public Const VECTOR_GRID_DATA As UInteger
Visual C++
public:
literal unsigned int VECTOR_GRID_DATA

See Also

MCdicom Structure
MCdicom Members


VELOCITY_ENCODING_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VELOCITY_ENCODING_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Velocity Encoding Acquisition Sequence (0018,9092)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VELOCITY_ENCODING_ACQUISITION_SEQUENCE
Visual Basic
Public Const VELOCITY_ENCODING_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VELOCITY_ENCODING_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VELOCITY_ENCODING_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VELOCITY_ENCODING_DIRECTION Field
MCdicom Structure See Also Send Feedback
Velocity Encoding Direction (0018,9090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VELOCITY_ENCODING_DIRECTION
Visual Basic
Public Const VELOCITY_ENCODING_DIRECTION As UInteger
Visual C++
public:
literal unsigned int VELOCITY_ENCODING_DIRECTION

See Also

MCdicom Structure
MCdicom Members


VELOCITY_ENCODING_MAXIMUM_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VELOCITY_ENCODING_MAXIMUM_VALUE Field
MCdicom Structure See Also Send Feedback
Velocity Encoding Maximum Value (0018,9217)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VELOCITY_ENCODING_MAXIMUM_VALUE
Visual Basic
Public Const VELOCITY_ENCODING_MAXIMUM_VALUE As UInteger
Visual C++
public:
literal unsigned int VELOCITY_ENCODING_MAXIMUM_VALUE

See Also

MCdicom Structure
MCdicom Members


VELOCITY_ENCODING_MINIMUM_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VELOCITY_ENCODING_MINIMUM_VALUE Field
MCdicom Structure See Also Send Feedback
Velocity Encoding Minimum Value (0018,9091)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VELOCITY_ENCODING_MINIMUM_VALUE
Visual Basic
Public Const VELOCITY_ENCODING_MINIMUM_VALUE As UInteger
Visual C++
public:
literal unsigned int VELOCITY_ENCODING_MINIMUM_VALUE

See Also

MCdicom Structure
MCdicom Members


VELOCITY_OF_SOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VELOCITY_OF_SOUND Field
MCdicom Structure See Also Send Feedback
Velocity of Sound (0014,4064)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VELOCITY_OF_SOUND
Visual Basic
Public Const VELOCITY_OF_SOUND As UInteger
Visual C++
public:
literal unsigned int VELOCITY_OF_SOUND

See Also

MCdicom Structure
MCdicom Members


VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Verbal Source Identifier Code Sequence (Trial) RETIRED (0040,A358)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int VERBAL_SOURCE_IDENTIFIER_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


VERBAL_SOURCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERBAL_SOURCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Verbal Source (Trial) RETIRED (0040,A352)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERBAL_SOURCE_TRIAL_RETIRED
Visual Basic
Public Const VERBAL_SOURCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int VERBAL_SOURCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


VERIFICATION_DATE_TIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFICATION_DATE_TIME Field
MCdicom Structure See Also Send Feedback
Alias for tag VERIFICATION_DATETIME (0040,A030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFICATION_DATE_TIME
Visual Basic
Public Const VERIFICATION_DATE_TIME As UInteger
Visual C++
public:
literal unsigned int VERIFICATION_DATE_TIME

See Also

MCdicom Structure
MCdicom Members


VERIFICATION_DATETIME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFICATION_DATETIME Field
MCdicom Structure See Also Send Feedback
Verification DateTime (0040,A030)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFICATION_DATETIME
Visual Basic
Public Const VERIFICATION_DATETIME As UInteger
Visual C++
public:
literal unsigned int VERIFICATION_DATETIME

See Also

MCdicom Structure
MCdicom Members


VERIFICATION_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFICATION_FLAG Field
MCdicom Structure See Also Send Feedback
Verification Flag (0040,A493)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFICATION_FLAG
Visual Basic
Public Const VERIFICATION_FLAG As UInteger
Visual C++
public:
literal unsigned int VERIFICATION_FLAG

See Also

MCdicom Structure
MCdicom Members


VERIFICATION_IMAGE_TIMING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFICATION_IMAGE_TIMING Field
MCdicom Structure See Also Send Feedback
Verification Image Timing (0074,1032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFICATION_IMAGE_TIMING
Visual Basic
Public Const VERIFICATION_IMAGE_TIMING As UInteger
Visual C++
public:
literal unsigned int VERIFICATION_IMAGE_TIMING

See Also

MCdicom Structure
MCdicom Members


VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Verifying Observer Identification Code Sequence (0040,A088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE
Visual Basic
Public Const VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VERIFYING_OBSERVER_IDENTIFICATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VERIFYING_OBSERVER_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFYING_OBSERVER_NAME Field
MCdicom Structure See Also Send Feedback
Verifying Observer Name (0040,A075)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFYING_OBSERVER_NAME
Visual Basic
Public Const VERIFYING_OBSERVER_NAME As UInteger
Visual C++
public:
literal unsigned int VERIFYING_OBSERVER_NAME

See Also

MCdicom Structure
MCdicom Members


VERIFYING_OBSERVER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFYING_OBSERVER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Verifying Observer Sequence (0040,A073)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFYING_OBSERVER_SEQUENCE
Visual Basic
Public Const VERIFYING_OBSERVER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VERIFYING_OBSERVER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VERIFYING_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERIFYING_ORGANIZATION Field
MCdicom Structure See Also Send Feedback
Verifying Organization (0040,A027)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERIFYING_ORGANIZATION
Visual Basic
Public Const VERIFYING_ORGANIZATION As UInteger
Visual C++
public:
literal unsigned int VERIFYING_ORGANIZATION

See Also

MCdicom Structure
MCdicom Members


VERTEX_POINT_INDEX_LIST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTEX_POINT_INDEX_LIST_RETIRED Field
MCdicom Structure See Also Send Feedback
Vertex Point Index List RETIRED (0066,0025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTEX_POINT_INDEX_LIST_RETIRED
Visual Basic
Public Const VERTEX_POINT_INDEX_LIST_RETIRED As UInteger
Visual C++
public:
literal unsigned int VERTEX_POINT_INDEX_LIST_RETIRED

See Also

MCdicom Structure
MCdicom Members


VERTICAL_ALIGNMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICAL_ALIGNMENT Field
MCdicom Structure See Also Send Feedback
Vertical Alignment (0070,0243)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICAL_ALIGNMENT
Visual Basic
Public Const VERTICAL_ALIGNMENT As UInteger
Visual C++
public:
literal unsigned int VERTICAL_ALIGNMENT

See Also

MCdicom Structure
MCdicom Members


VERTICAL_OFFSET_OF_SENSOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICAL_OFFSET_OF_SENSOR Field
MCdicom Structure See Also Send Feedback
Vertical Offset of Sensor (0014,3026)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICAL_OFFSET_OF_SENSOR
Visual Basic
Public Const VERTICAL_OFFSET_OF_SENSOR As UInteger
Visual C++
public:
literal unsigned int VERTICAL_OFFSET_OF_SENSOR

See Also

MCdicom Structure
MCdicom Members


VERTICAL_PRISM_BASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICAL_PRISM_BASE Field
MCdicom Structure See Also Send Feedback
Vertical Prism Base (0046,0036)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICAL_PRISM_BASE
Visual Basic
Public Const VERTICAL_PRISM_BASE As UInteger
Visual C++
public:
literal unsigned int VERTICAL_PRISM_BASE

See Also

MCdicom Structure
MCdicom Members


VERTICAL_PRISM_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICAL_PRISM_POWER Field
MCdicom Structure See Also Send Feedback
Vertical Prism Power (0046,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICAL_PRISM_POWER
Visual Basic
Public Const VERTICAL_PRISM_POWER As UInteger
Visual C++
public:
literal unsigned int VERTICAL_PRISM_POWER

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_OUTLINE_OF_PUPIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_OUTLINE_OF_PUPIL Field
MCdicom Structure See Also Send Feedback
Vertices of the Outline of Pupil (0046,0208)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_OUTLINE_OF_PUPIL
Visual Basic
Public Const VERTICES_OF_THE_OUTLINE_OF_PUPIL As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_OUTLINE_OF_PUPIL

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_POLYGONAL_COLLIMATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_POLYGONAL_COLLIMATOR Field
MCdicom Structure See Also Send Feedback
Vertices of the Polygonal Collimator (0018,1720)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_POLYGONAL_COLLIMATOR
Visual Basic
Public Const VERTICES_OF_THE_POLYGONAL_COLLIMATOR As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_POLYGONAL_COLLIMATOR

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION Field
MCdicom Structure See Also Send Feedback
Vertices of the Polygonal Exposure Control Sensing Region (0018,9442)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION
Visual Basic
Public Const VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_POLYGONAL_EXPOSURE_CONTROL_SENSING_REGION

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_POLYGONAL_OUTLINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_POLYGONAL_OUTLINE Field
MCdicom Structure See Also Send Feedback
Vertices of the Polygonal Outline (0018,1638)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_POLYGONAL_OUTLINE
Visual Basic
Public Const VERTICES_OF_THE_POLYGONAL_OUTLINE As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_POLYGONAL_OUTLINE

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_POLYGONAL_SHUTTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_POLYGONAL_SHUTTER Field
MCdicom Structure See Also Send Feedback
Vertices of the Polygonal Shutter (0018,1620)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_POLYGONAL_SHUTTER
Visual Basic
Public Const VERTICES_OF_THE_POLYGONAL_SHUTTER As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_POLYGONAL_SHUTTER

See Also

MCdicom Structure
MCdicom Members


VERTICES_OF_THE_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VERTICES_OF_THE_REGION Field
MCdicom Structure See Also Send Feedback
Vertices of the Region (0028,9503)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VERTICES_OF_THE_REGION
Visual Basic
Public Const VERTICES_OF_THE_REGION As UInteger
Visual C++
public:
literal unsigned int VERTICES_OF_THE_REGION

See Also

MCdicom Structure
MCdicom Members


VIDEO_IMAGE_FORMAT_ACQUIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIDEO_IMAGE_FORMAT_ACQUIRED Field
MCdicom Structure See Also Send Feedback
Video Image Format Acquired (0018,1022)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIDEO_IMAGE_FORMAT_ACQUIRED
Visual Basic
Public Const VIDEO_IMAGE_FORMAT_ACQUIRED As UInteger
Visual C++
public:
literal unsigned int VIDEO_IMAGE_FORMAT_ACQUIRED

See Also

MCdicom Structure
MCdicom Members


VIEW_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
View Code Sequence (0054,0220)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_CODE_SEQUENCE
Visual Basic
Public Const VIEW_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VIEW_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VIEW_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
View Modifier Code Sequence (0054,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const VIEW_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VIEW_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VIEW_MODIFIER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_MODIFIER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Alias for tag VIEW_MODIFIER_CODE_SEQUENCE (0054,0222)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_MODIFIER_SEQUENCE
Visual Basic
Public Const VIEW_MODIFIER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VIEW_MODIFIER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VIEW_NAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_NAME Field
MCdicom Structure See Also Send Feedback
View Name (0008,2127)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_NAME
Visual Basic
Public Const VIEW_NAME As UInteger
Visual C++
public:
literal unsigned int VIEW_NAME

See Also

MCdicom Structure
MCdicom Members


VIEW_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_NUMBER Field
MCdicom Structure See Also Send Feedback
View Number (0008,2128)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_NUMBER
Visual Basic
Public Const VIEW_NUMBER As UInteger
Visual C++
public:
literal unsigned int VIEW_NUMBER

See Also

MCdicom Structure
MCdicom Members


VIEW_ORIENTATION_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_ORIENTATION_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
View Orientation Code Sequence (0068,62E0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_ORIENTATION_CODE_SEQUENCE
Visual Basic
Public Const VIEW_ORIENTATION_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VIEW_ORIENTATION_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VIEW_ORIENTATION_MODIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_ORIENTATION_MODIFIER Field
MCdicom Structure See Also Send Feedback
Alias for tag VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE (0068,62F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_ORIENTATION_MODIFIER
Visual Basic
Public Const VIEW_ORIENTATION_MODIFIER As UInteger
Visual C++
public:
literal unsigned int VIEW_ORIENTATION_MODIFIER

See Also

MCdicom Structure
MCdicom Members


VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
View Orientation Modifier Code Sequence (0068,62F0)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE
Visual Basic
Public Const VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VIEW_ORIENTATION_MODIFIER_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VIEW_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEW_POSITION Field
MCdicom Structure See Also Send Feedback
View Position (0018,5101)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEW_POSITION
Visual Basic
Public Const VIEW_POSITION As UInteger
Visual C++
public:
literal unsigned int VIEW_POSITION

See Also

MCdicom Structure
MCdicom Members


VIEWING_DISTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEWING_DISTANCE Field
MCdicom Structure See Also Send Feedback
Viewing Distance (0046,0106)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEWING_DISTANCE
Visual Basic
Public Const VIEWING_DISTANCE As UInteger
Visual C++
public:
literal unsigned int VIEWING_DISTANCE

See Also

MCdicom Structure
MCdicom Members


VIEWING_DISTANCE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEWING_DISTANCE_TYPE Field
MCdicom Structure See Also Send Feedback
Viewing Distance Type (0046,0125)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEWING_DISTANCE_TYPE
Visual Basic
Public Const VIEWING_DISTANCE_TYPE As UInteger
Visual C++
public:
literal unsigned int VIEWING_DISTANCE_TYPE

See Also

MCdicom Structure
MCdicom Members


VIEWPOINT_LOOKAT_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEWPOINT_LOOKAT_POINT Field
MCdicom Structure See Also Send Feedback
Viewpoint LookAt Point (0070,1604)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEWPOINT_LOOKAT_POINT
Visual Basic
Public Const VIEWPOINT_LOOKAT_POINT As UInteger
Visual C++
public:
literal unsigned int VIEWPOINT_LOOKAT_POINT

See Also

MCdicom Structure
MCdicom Members


VIEWPOINT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEWPOINT_POSITION Field
MCdicom Structure See Also Send Feedback
Viewpoint Position (0070,1603)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEWPOINT_POSITION
Visual Basic
Public Const VIEWPOINT_POSITION As UInteger
Visual C++
public:
literal unsigned int VIEWPOINT_POSITION

See Also

MCdicom Structure
MCdicom Members


VIEWPOINT_UP_DIRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIEWPOINT_UP_DIRECTION Field
MCdicom Structure See Also Send Feedback
Viewpoint Up Direction (0070,1605)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIEWPOINT_UP_DIRECTION
Visual Basic
Public Const VIEWPOINT_UP_DIRECTION As UInteger
Visual C++
public:
literal unsigned int VIEWPOINT_UP_DIRECTION

See Also

MCdicom Structure
MCdicom Members


VIRTUAL_SOURCE_AXIS_DISTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VIRTUAL_SOURCE_AXIS_DISTANCES Field
MCdicom Structure See Also Send Feedback
Virtual Source-Axis Distances (300A,030A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VIRTUAL_SOURCE_AXIS_DISTANCES
Visual Basic
Public Const VIRTUAL_SOURCE_AXIS_DISTANCES As UInteger
Visual C++
public:
literal unsigned int VIRTUAL_SOURCE_AXIS_DISTANCES

See Also

MCdicom Structure
MCdicom Members


VISIT_COMMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISIT_COMMENTS Field
MCdicom Structure See Also Send Feedback
Visit Comments (0038,4000)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISIT_COMMENTS
Visual Basic
Public Const VISIT_COMMENTS As UInteger
Visual C++
public:
literal unsigned int VISIT_COMMENTS

See Also

MCdicom Structure
MCdicom Members


VISIT_STATUS_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISIT_STATUS_ID Field
MCdicom Structure See Also Send Feedback
Visit Status ID (0038,0008)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISIT_STATUS_ID
Visual Basic
Public Const VISIT_STATUS_ID As UInteger
Visual C++
public:
literal unsigned int VISIT_STATUS_ID

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Acuity Both Eyes Open Sequence (0046,0124)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE
Visual Basic
Public Const VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_BOTH_EYES_OPEN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_LEFT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_LEFT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Acuity Left Eye Sequence (0046,0123)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_LEFT_EYE_SEQUENCE
Visual Basic
Public Const VISUAL_ACUITY_LEFT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_LEFT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_MEASUREMENT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_MEASUREMENT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Acuity Measurement Sequence (0024,0110)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_MEASUREMENT_SEQUENCE
Visual Basic
Public Const VISUAL_ACUITY_MEASUREMENT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_MEASUREMENT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_MODIFIERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_MODIFIERS Field
MCdicom Structure See Also Send Feedback
Visual Acuity Modifiers (0046,0135)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_MODIFIERS
Visual Basic
Public Const VISUAL_ACUITY_MODIFIERS As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_MODIFIERS

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_RIGHT_EYE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_RIGHT_EYE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Acuity Right Eye Sequence (0046,0122)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_RIGHT_EYE_SEQUENCE
Visual Basic
Public Const VISUAL_ACUITY_RIGHT_EYE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_RIGHT_EYE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_ACUITY_TYPE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_ACUITY_TYPE_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Acuity Type Code Sequence (0046,0121)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_ACUITY_TYPE_CODE_SEQUENCE
Visual Basic
Public Const VISUAL_ACUITY_TYPE_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_ACUITY_TYPE_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_EVALUATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_EVALUATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Evaluation Method Code Sequence (0028,702E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_EVALUATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const VISUAL_EVALUATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_EVALUATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_EVALUATION_RESULT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_EVALUATION_RESULT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Evaluation Result Sequence (0028,7015)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_EVALUATION_RESULT_SEQUENCE
Visual Basic
Public Const VISUAL_EVALUATION_RESULT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_EVALUATION_RESULT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_EVALUATION_TEST_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_EVALUATION_TEST_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Evaluation Test Sequence (0028,7028)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_EVALUATION_TEST_SEQUENCE
Visual Basic
Public Const VISUAL_EVALUATION_TEST_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_EVALUATION_TEST_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_CATCH_TRIAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_CATCH_TRIAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Field Catch Trial Sequence (0024,0034)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_CATCH_TRIAL_SEQUENCE
Visual Basic
Public Const VISUAL_FIELD_CATCH_TRIAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_CATCH_TRIAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Field Global Results Index Sequence (0024,0320)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE
Visual Basic
Public Const VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_GLOBAL_RESULTS_INDEX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_HORIZONTAL_EXTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_HORIZONTAL_EXTENT Field
MCdicom Structure See Also Send Feedback
Visual Field Horizontal Extent (0024,0010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_HORIZONTAL_EXTENT
Visual Basic
Public Const VISUAL_FIELD_HORIZONTAL_EXTENT As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_HORIZONTAL_EXTENT

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_MEAN_SENSITIVITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_MEAN_SENSITIVITY Field
MCdicom Structure See Also Send Feedback
Visual Field Mean Sensitivity (0024,0070)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_MEAN_SENSITIVITY
Visual Basic
Public Const VISUAL_FIELD_MEAN_SENSITIVITY As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_MEAN_SENSITIVITY

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_SHAPE Field
MCdicom Structure See Also Send Feedback
Visual Field Shape (0024,0012)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_SHAPE
Visual Basic
Public Const VISUAL_FIELD_SHAPE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_SHAPE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_DURATION Field
MCdicom Structure See Also Send Feedback
Visual Field Test Duration (0024,0088)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_DURATION
Visual Basic
Public Const VISUAL_FIELD_TEST_DURATION As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_DURATION

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_NORMALS_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_NORMALS_FLAG Field
MCdicom Structure See Also Send Feedback
Visual Field Test Normals Flag (0024,0063)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_NORMALS_FLAG
Visual Basic
Public Const VISUAL_FIELD_TEST_NORMALS_FLAG As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_NORMALS_FLAG

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Field Test Point Normals Sequence (0024,0097)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE
Visual Basic
Public Const VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_POINT_NORMALS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_POINT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_POINT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Field Test Point Sequence (0024,0089)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_POINT_SEQUENCE
Visual Basic
Public Const VISUAL_FIELD_TEST_POINT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_POINT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_POINT_X_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_POINT_X_COORDINATE Field
MCdicom Structure See Also Send Feedback
Visual Field Test Point X-Coordinate (0024,0090)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_POINT_X_COORDINATE
Visual Basic
Public Const VISUAL_FIELD_TEST_POINT_X_COORDINATE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_POINT_X_COORDINATE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_POINT_Y_COORDINATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_POINT_Y_COORDINATE Field
MCdicom Structure See Also Send Feedback
Visual Field Test Point Y-Coordinate (0024,0091)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_POINT_Y_COORDINATE
Visual Basic
Public Const VISUAL_FIELD_TEST_POINT_Y_COORDINATE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_POINT_Y_COORDINATE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Visual Field Test Reliability Global Index Sequence (0024,0317)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE
Visual Basic
Public Const VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_TEST_RELIABILITY_GLOBAL_INDEX_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VISUAL_FIELD_VERTICAL_EXTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VISUAL_FIELD_VERTICAL_EXTENT Field
MCdicom Structure See Also Send Feedback
Visual Field Vertical Extent (0024,0011)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VISUAL_FIELD_VERTICAL_EXTENT
Visual Basic
Public Const VISUAL_FIELD_VERTICAL_EXTENT As UInteger
Visual C++
public:
literal unsigned int VISUAL_FIELD_VERTICAL_EXTENT

See Also

MCdicom Structure
MCdicom Members


VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED Field
MCdicom Structure See Also Send Feedback
Vital Stain Code Sequence (Trial) RETIRED (0040,09F8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED
Visual Basic
Public Const VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED As UInteger
Visual C++
public:
literal unsigned int VITAL_STAIN_CODE_SEQUENCE_TRIAL_RETIRED

See Also

MCdicom Structure
MCdicom Members


VITREOUS_STATUS_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VITREOUS_STATUS_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Vitreous Status Code Sequence (0022,1025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VITREOUS_STATUS_CODE_SEQUENCE
Visual Basic
Public Const VITREOUS_STATUS_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VITREOUS_STATUS_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VITREOUS_STATUS_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VITREOUS_STATUS_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Vitreous Status Description (0022,1066)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VITREOUS_STATUS_DESCRIPTION
Visual Basic
Public Const VITREOUS_STATUS_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int VITREOUS_STATUS_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


VOI_LUT_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOI_LUT_FUNCTION Field
MCdicom Structure See Also Send Feedback
VOI LUT Function (0028,1056)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOI_LUT_FUNCTION
Visual Basic
Public Const VOI_LUT_FUNCTION As UInteger
Visual C++
public:
literal unsigned int VOI_LUT_FUNCTION

See Also

MCdicom Structure
MCdicom Members


VOI_LUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOI_LUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
VOI LUT Sequence (0028,3010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOI_LUT_SEQUENCE
Visual Basic
Public Const VOI_LUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOI_LUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOI_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOI_TYPE Field
MCdicom Structure See Also Send Feedback
VOI Type (0072,0702)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOI_TYPE
Visual Basic
Public Const VOI_TYPE As UInteger
Visual C++
public:
literal unsigned int VOI_TYPE

See Also

MCdicom Structure
MCdicom Members


VOLUME_BASED_CALCULATION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_BASED_CALCULATION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Volume Based Calculation Technique (0008,9207)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_BASED_CALCULATION_TECHNIQUE
Visual Basic
Public Const VOLUME_BASED_CALCULATION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int VOLUME_BASED_CALCULATION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


VOLUME_CROPPING_METHOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_CROPPING_METHOD Field
MCdicom Structure See Also Send Feedback
Volume Cropping Method (0070,1302)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_CROPPING_METHOD
Visual Basic
Public Const VOLUME_CROPPING_METHOD As UInteger
Visual C++
public:
literal unsigned int VOLUME_CROPPING_METHOD

See Also

MCdicom Structure
MCdicom Members


VOLUME_CROPPING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_CROPPING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volume Cropping Sequence (0070,1301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_CROPPING_SEQUENCE
Visual Basic
Public Const VOLUME_CROPPING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUME_CROPPING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUME_FRAME_OF_REFERENCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_FRAME_OF_REFERENCE_UID Field
MCdicom Structure See Also Send Feedback
Volume Frame of Reference UID (0020,9312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_FRAME_OF_REFERENCE_UID
Visual Basic
Public Const VOLUME_FRAME_OF_REFERENCE_UID As UInteger
Visual C++
public:
literal unsigned int VOLUME_FRAME_OF_REFERENCE_UID

See Also

MCdicom Structure
MCdicom Members


VOLUME_LOCALIZATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_LOCALIZATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volume Localization Sequence (0018,9126)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_LOCALIZATION_SEQUENCE
Visual Basic
Public Const VOLUME_LOCALIZATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUME_LOCALIZATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUME_LOCALIZATION_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_LOCALIZATION_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Volume Localization Technique (0018,9054)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_LOCALIZATION_TECHNIQUE
Visual Basic
Public Const VOLUME_LOCALIZATION_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int VOLUME_LOCALIZATION_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


VOLUME_OF_PTO Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_OF_PTO Field
MCdicom Structure See Also Send Feedback
Volume of PTO (4010,1023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_OF_PTO
Visual Basic
Public Const VOLUME_OF_PTO As UInteger
Visual C++
public:
literal unsigned int VOLUME_OF_PTO

See Also

MCdicom Structure
MCdicom Members


VOLUME_STREAM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_STREAM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volume Stream Sequence (0070,1A08)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_STREAM_SEQUENCE
Visual Basic
Public Const VOLUME_STREAM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUME_STREAM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUME_TO_TABLE_MAPPING_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_TO_TABLE_MAPPING_MATRIX Field
MCdicom Structure See Also Send Feedback
Volume to Table Mapping Matrix (0020,930A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_TO_TABLE_MAPPING_MATRIX
Visual Basic
Public Const VOLUME_TO_TABLE_MAPPING_MATRIX As UInteger
Visual C++
public:
literal unsigned int VOLUME_TO_TABLE_MAPPING_MATRIX

See Also

MCdicom Structure
MCdicom Members


VOLUME_TO_TRANSDUCER_MAPPING_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_TO_TRANSDUCER_MAPPING_MATRIX Field
MCdicom Structure See Also Send Feedback
Volume to Transducer Mapping Matrix (0020,9309)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_TO_TRANSDUCER_MAPPING_MATRIX
Visual Basic
Public Const VOLUME_TO_TRANSDUCER_MAPPING_MATRIX As UInteger
Visual C++
public:
literal unsigned int VOLUME_TO_TRANSDUCER_MAPPING_MATRIX

See Also

MCdicom Structure
MCdicom Members


VOLUME_TO_TRANSDUCER_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUME_TO_TRANSDUCER_RELATIONSHIP Field
MCdicom Structure See Also Send Feedback
Volume to Transducer Relationship (0020,930B)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUME_TO_TRANSDUCER_RELATIONSHIP
Visual Basic
Public Const VOLUME_TO_TRANSDUCER_RELATIONSHIP As UInteger
Visual C++
public:
literal unsigned int VOLUME_TO_TRANSDUCER_RELATIONSHIP

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volumetric Annotation Sequence (0070,1901)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_ANNOTATION_SEQUENCE
Visual Basic
Public Const VOLUMETRIC_ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_CURVE_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_CURVE_POINTS Field
MCdicom Structure See Also Send Feedback
Volumetric Curve Points (0070,150D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_CURVE_POINTS
Visual Basic
Public Const VOLUMETRIC_CURVE_POINTS As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_CURVE_POINTS

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_CURVE_UP_DIRECTIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_CURVE_UP_DIRECTIONS Field
MCdicom Structure See Also Send Feedback
Volumetric Curve Up Directions (0070,1A07)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_CURVE_UP_DIRECTIONS
Visual Basic
Public Const VOLUMETRIC_CURVE_UP_DIRECTIONS As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_CURVE_UP_DIRECTIONS

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation Input Annotation Sequence (0070,1905)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_INPUT_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_INPUT_INDEX Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation Input Index (0070,1804)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_INPUT_INDEX
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_INPUT_INDEX As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_INPUT_INDEX

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_INPUT_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_INPUT_NUMBER Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation Input Number (0070,1207)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_INPUT_NUMBER
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_INPUT_NUMBER As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_INPUT_NUMBER

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation Input Set Sequence (0070,120A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_INPUT_SET_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_INPUT_SET_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_INPUT_SET_UID Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation Input Set UID (0070,1209)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_INPUT_SET_UID
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_INPUT_SET_UID As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_INPUT_SET_UID

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Volumetric Presentation State Input Sequence (0070,1201)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE
Visual Basic
Public Const VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PRESENTATION_STATE_INPUT_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


VOLUMETRIC_PROPERTIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..VOLUMETRIC_PROPERTIES Field
MCdicom Structure See Also Send Feedback
Volumetric Properties (0008,9206)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint VOLUMETRIC_PROPERTIES
Visual Basic
Public Const VOLUMETRIC_PROPERTIES As UInteger
Visual C++
public:
literal unsigned int VOLUMETRIC_PROPERTIES

See Also

MCdicom Structure
MCdicom Members


WADO_RETRIEVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WADO_RETRIEVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
WADO Retrieval Sequence (0040,E023)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WADO_RETRIEVAL_SEQUENCE
Visual Basic
Public Const WADO_RETRIEVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WADO_RETRIEVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WADO_RS_RETRIEVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WADO_RS_RETRIEVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
WADO-RS Retrieval Sequence (0040,E025)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WADO_RS_RETRIEVAL_SEQUENCE
Visual Basic
Public Const WADO_RS_RETRIEVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WADO_RS_RETRIEVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WARNING_REASON Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WARNING_REASON Field
MCdicom Structure See Also Send Feedback
Warning Reason (0008,1196)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WARNING_REASON
Visual Basic
Public Const WARNING_REASON As UInteger
Visual C++
public:
literal unsigned int WARNING_REASON

See Also

MCdicom Structure
MCdicom Members


WATER_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WATER_DEPTH Field
MCdicom Structure See Also Send Feedback
Water Depth (0016,0033)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WATER_DEPTH
Visual Basic
Public Const WATER_DEPTH As UInteger
Visual C++
public:
literal unsigned int WATER_DEPTH

See Also

MCdicom Structure
MCdicom Members


WATER_EQUIVALENT_DIAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WATER_EQUIVALENT_DIAMETER Field
MCdicom Structure See Also Send Feedback
Water Equivalent Diameter (0018,1271)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WATER_EQUIVALENT_DIAMETER
Visual Basic
Public Const WATER_EQUIVALENT_DIAMETER As UInteger
Visual C++
public:
literal unsigned int WATER_EQUIVALENT_DIAMETER

See Also

MCdicom Structure
MCdicom Members


WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Water Equivalent Diameter Calculation Method Code Sequence (0018,1272)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE
Visual Basic
Public Const WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WATER_EQUIVALENT_DIAMETER_CALCULATION_METHOD_CODE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WATER_REFERENCE_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WATER_REFERENCE_ACQUISITION Field
MCdicom Structure See Also Send Feedback
Water Reference Acquisition (0018,9297)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WATER_REFERENCE_ACQUISITION
Visual Basic
Public Const WATER_REFERENCE_ACQUISITION As UInteger
Visual C++
public:
literal unsigned int WATER_REFERENCE_ACQUISITION

See Also

MCdicom Structure
MCdicom Members


WATER_REFERENCED_PHASE_CORRECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WATER_REFERENCED_PHASE_CORRECTION Field
MCdicom Structure See Also Send Feedback
Water Referenced Phase Correction (0018,9199)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WATER_REFERENCED_PHASE_CORRECTION
Visual Basic
Public Const WATER_REFERENCED_PHASE_CORRECTION As UInteger
Visual C++
public:
literal unsigned int WATER_REFERENCED_PHASE_CORRECTION

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_AMPLIFIER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_AMPLIFIER_TYPE Field
MCdicom Structure See Also Send Feedback
Waveform Amplifier Type (003A,0317)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_AMPLIFIER_TYPE
Visual Basic
Public Const WAVEFORM_AMPLIFIER_TYPE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_AMPLIFIER_TYPE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_ANNOTATION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_ANNOTATION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Waveform Annotation Sequence (0040,B020)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_ANNOTATION_SEQUENCE
Visual Basic
Public Const WAVEFORM_ANNOTATION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_ANNOTATION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_BITS_ALLOCATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_BITS_ALLOCATED Field
MCdicom Structure See Also Send Feedback
Waveform Bits Allocated (5400,1004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_BITS_ALLOCATED
Visual Basic
Public Const WAVEFORM_BITS_ALLOCATED As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_BITS_ALLOCATED

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_BITS_STORED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_BITS_STORED Field
MCdicom Structure See Also Send Feedback
Waveform Bits Stored (003A,021A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_BITS_STORED
Visual Basic
Public Const WAVEFORM_BITS_STORED As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_BITS_STORED

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_CHANNEL_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_CHANNEL_NUMBER Field
MCdicom Structure See Also Send Feedback
Waveform Channel Number (003A,0202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_CHANNEL_NUMBER
Visual Basic
Public Const WAVEFORM_CHANNEL_NUMBER As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_CHANNEL_NUMBER

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_DATA Field
MCdicom Structure See Also Send Feedback
Waveform Data (5400,1010)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_DATA
Visual Basic
Public Const WAVEFORM_DATA As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_DATA

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_DATA_DISPLAY_SCALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_DATA_DISPLAY_SCALE Field
MCdicom Structure See Also Send Feedback
Waveform Data Display Scale (003A,0230)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_DATA_DISPLAY_SCALE
Visual Basic
Public Const WAVEFORM_DATA_DISPLAY_SCALE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_DATA_DISPLAY_SCALE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE Field
MCdicom Structure See Also Send Feedback
Waveform Display Background CIELab Value (003A,0231)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE
Visual Basic
Public Const WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_DISPLAY_BACKGROUND_CIELAB_VALUE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_FILTER_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_FILTER_DESCRIPTION Field
MCdicom Structure See Also Send Feedback
Waveform Filter Description (003A,0329)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_FILTER_DESCRIPTION
Visual Basic
Public Const WAVEFORM_FILTER_DESCRIPTION As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_FILTER_DESCRIPTION

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_FILTER_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_FILTER_TYPE Field
MCdicom Structure See Also Send Feedback
Waveform Filter Type (003A,0322)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_FILTER_TYPE
Visual Basic
Public Const WAVEFORM_FILTER_TYPE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_FILTER_TYPE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_ORIGINALITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_ORIGINALITY Field
MCdicom Structure See Also Send Feedback
Waveform Originality (003A,0004)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_ORIGINALITY
Visual Basic
Public Const WAVEFORM_ORIGINALITY As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_ORIGINALITY

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_PADDING_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_PADDING_VALUE Field
MCdicom Structure See Also Send Feedback
Waveform Padding Value (5400,100A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_PADDING_VALUE
Visual Basic
Public Const WAVEFORM_PADDING_VALUE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_PADDING_VALUE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_PRESENTATION_GROUP_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_PRESENTATION_GROUP_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Waveform Presentation Group Sequence (003A,0240)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_PRESENTATION_GROUP_SEQUENCE
Visual Basic
Public Const WAVEFORM_PRESENTATION_GROUP_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_PRESENTATION_GROUP_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_SAMPLE_INTERPRETATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_SAMPLE_INTERPRETATION Field
MCdicom Structure See Also Send Feedback
Waveform Sample Interpretation (5400,1006)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_SAMPLE_INTERPRETATION
Visual Basic
Public Const WAVEFORM_SAMPLE_INTERPRETATION As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_SAMPLE_INTERPRETATION

See Also

MCdicom Structure
MCdicom Members


WAVEFORM_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WAVEFORM_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Waveform Sequence (5400,0100)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WAVEFORM_SEQUENCE
Visual Basic
Public Const WAVEFORM_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WAVEFORM_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WEDGE_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_ANGLE Field
MCdicom Structure See Also Send Feedback
Wedge Angle (300A,00D5)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_ANGLE
Visual Basic
Public Const WEDGE_ANGLE As UInteger
Visual C++
public:
literal unsigned int WEDGE_ANGLE

See Also

MCdicom Structure
MCdicom Members


WEDGE_DEFINITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_DEFINITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Wedge Definition Sequence (300A,0651)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_DEFINITION_SEQUENCE
Visual Basic
Public Const WEDGE_DEFINITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WEDGE_DEFINITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WEDGE_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_FACTOR Field
MCdicom Structure See Also Send Feedback
Wedge Factor (300A,00D6)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_FACTOR
Visual Basic
Public Const WEDGE_FACTOR As UInteger
Visual C++
public:
literal unsigned int WEDGE_FACTOR

See Also

MCdicom Structure
MCdicom Members


WEDGE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_ID Field
MCdicom Structure See Also Send Feedback
Wedge ID (300A,00D4)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_ID
Visual Basic
Public Const WEDGE_ID As UInteger
Visual C++
public:
literal unsigned int WEDGE_ID

See Also

MCdicom Structure
MCdicom Members


WEDGE_NUMBER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_NUMBER Field
MCdicom Structure See Also Send Feedback
Wedge Number (300A,00D2)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_NUMBER
Visual Basic
Public Const WEDGE_NUMBER As UInteger
Visual C++
public:
literal unsigned int WEDGE_NUMBER

See Also

MCdicom Structure
MCdicom Members


WEDGE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_ORIENTATION Field
MCdicom Structure See Also Send Feedback
Wedge Orientation (300A,00D8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_ORIENTATION
Visual Basic
Public Const WEDGE_ORIENTATION As UInteger
Visual C++
public:
literal unsigned int WEDGE_ORIENTATION

See Also

MCdicom Structure
MCdicom Members


WEDGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_POSITION Field
MCdicom Structure See Also Send Feedback
Wedge Position (300A,0118)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_POSITION
Visual Basic
Public Const WEDGE_POSITION As UInteger
Visual C++
public:
literal unsigned int WEDGE_POSITION

See Also

MCdicom Structure
MCdicom Members


WEDGE_POSITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_POSITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Wedge Position Sequence (300A,0116)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_POSITION_SEQUENCE
Visual Basic
Public Const WEDGE_POSITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WEDGE_POSITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WEDGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Wedge Sequence (300A,00D1)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_SEQUENCE
Visual Basic
Public Const WEDGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WEDGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WEDGE_THIN_EDGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_THIN_EDGE_POSITION Field
MCdicom Structure See Also Send Feedback
Wedge Thin Edge Position (300A,00DB)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_THIN_EDGE_POSITION
Visual Basic
Public Const WEDGE_THIN_EDGE_POSITION As UInteger
Visual C++
public:
literal unsigned int WEDGE_THIN_EDGE_POSITION

See Also

MCdicom Structure
MCdicom Members


WEDGE_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEDGE_TYPE Field
MCdicom Structure See Also Send Feedback
Wedge Type (300A,00D3)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEDGE_TYPE
Visual Basic
Public Const WEDGE_TYPE As UInteger
Visual C++
public:
literal unsigned int WEDGE_TYPE

See Also

MCdicom Structure
MCdicom Members


WEEKDAY_FRACTION_PATTERN_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEEKDAY_FRACTION_PATTERN_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Weekday Fraction Pattern Sequence (3010,0087)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEEKDAY_FRACTION_PATTERN_SEQUENCE
Visual Basic
Public Const WEEKDAY_FRACTION_PATTERN_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WEEKDAY_FRACTION_PATTERN_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WEIGHTING_LOOKUP_TABLE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEIGHTING_LOOKUP_TABLE_DATA Field
MCdicom Structure See Also Send Feedback
Weighting Lookup Table Data (0070,1808)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEIGHTING_LOOKUP_TABLE_DATA
Visual Basic
Public Const WEIGHTING_LOOKUP_TABLE_DATA As UInteger
Visual C++
public:
literal unsigned int WEIGHTING_LOOKUP_TABLE_DATA

See Also

MCdicom Structure
MCdicom Members


WEIGHTING_LOOKUP_TABLE_DESCRIPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEIGHTING_LOOKUP_TABLE_DESCRIPTOR Field
MCdicom Structure See Also Send Feedback
Weighting Lookup Table Descriptor (0070,1807)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEIGHTING_LOOKUP_TABLE_DESCRIPTOR
Visual Basic
Public Const WEIGHTING_LOOKUP_TABLE_DESCRIPTOR As UInteger
Visual C++
public:
literal unsigned int WEIGHTING_LOOKUP_TABLE_DESCRIPTOR

See Also

MCdicom Structure
MCdicom Members


WEIGHTING_TRANSFER_FUNCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WEIGHTING_TRANSFER_FUNCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Weighting Transfer Function Sequence (0070,1806)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WEIGHTING_TRANSFER_FUNCTION_SEQUENCE
Visual Basic
Public Const WEIGHTING_TRANSFER_FUNCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WEIGHTING_TRANSFER_FUNCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WHITE_BALANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WHITE_BALANCE Field
MCdicom Structure See Also Send Feedback
White Balance (0016,0043)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WHITE_BALANCE
Visual Basic
Public Const WHITE_BALANCE As UInteger
Visual C++
public:
literal unsigned int WHITE_BALANCE

See Also

MCdicom Structure
MCdicom Members


WHITE_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WHITE_POINT Field
MCdicom Structure See Also Send Feedback
White Point (0016,0001)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WHITE_POINT
Visual Basic
Public Const WHITE_POINT As UInteger
Visual C++
public:
literal unsigned int WHITE_POINT

See Also

MCdicom Structure
MCdicom Members


WHITE_POINT_FLAG Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WHITE_POINT_FLAG Field
MCdicom Structure See Also Send Feedback
White Point Flag (0028,7021)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WHITE_POINT_FLAG
Visual Basic
Public Const WHITE_POINT_FLAG As UInteger
Visual C++
public:
literal unsigned int WHITE_POINT_FLAG

See Also

MCdicom Structure
MCdicom Members


WHOLE_BODY_TECHNIQUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WHOLE_BODY_TECHNIQUE Field
MCdicom Structure See Also Send Feedback
Whole Body Technique (0018,1301)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WHOLE_BODY_TECHNIQUE
Visual Basic
Public Const WHOLE_BODY_TECHNIQUE As UInteger
Visual C++
public:
literal unsigned int WHOLE_BODY_TECHNIQUE

See Also

MCdicom Structure
MCdicom Members


WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Whole Slide Microscopy Image Frame Type Sequence (0040,0710)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Wide Field Ophthalmic Photography Quality Rating Sequence (0022,1525)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE
Visual Basic
Public Const WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_RATING_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE Field
MCdicom Structure See Also Send Feedback
Wide Field Ophthalmic Photography Quality Threshold Sequence (0022,1526)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE
Visual Basic
Public Const WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_QUALITY_THRESHOLD_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING Field
MCdicom Structure See Also Send Feedback
Wide Field Ophthalmic Photography Threshold Quality Rating (0022,1527)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING
Visual Basic
Public Const WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING As UInteger
Visual C++
public:
literal unsigned int WIDE_FIELD_OPHTHALMIC_PHOTOGRAPHY_THRESHOLD_QUALITY_RATING

See Also

MCdicom Structure
MCdicom Members


WINDOW_CENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WINDOW_CENTER Field
MCdicom Structure See Also Send Feedback
Window Center (0028,1050)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WINDOW_CENTER
Visual Basic
Public Const WINDOW_CENTER As UInteger
Visual C++
public:
literal unsigned int WINDOW_CENTER

See Also

MCdicom Structure
MCdicom Members


WINDOW_CENTER_AND_WIDTH_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WINDOW_CENTER_AND_WIDTH_EXPLANATION Field
MCdicom Structure See Also Send Feedback
Alias for tag WINDOW_CENTER_WIDTH_EXPLANATION (0028,1055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WINDOW_CENTER_AND_WIDTH_EXPLANATION
Visual Basic
Public Const WINDOW_CENTER_AND_WIDTH_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int WINDOW_CENTER_AND_WIDTH_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


WINDOW_CENTER_WIDTH_EXPLANATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WINDOW_CENTER_WIDTH_EXPLANATION Field
MCdicom Structure See Also Send Feedback
Window Center Width Explanation (0028,1055)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WINDOW_CENTER_WIDTH_EXPLANATION
Visual Basic
Public Const WINDOW_CENTER_WIDTH_EXPLANATION As UInteger
Visual C++
public:
literal unsigned int WINDOW_CENTER_WIDTH_EXPLANATION

See Also

MCdicom Structure
MCdicom Members


WINDOW_WIDTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WINDOW_WIDTH Field
MCdicom Structure See Also Send Feedback
Window Width (0028,1051)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WINDOW_WIDTH
Visual Basic
Public Const WINDOW_WIDTH As UInteger
Visual C++
public:
literal unsigned int WINDOW_WIDTH

See Also

MCdicom Structure
MCdicom Members


WORKLIST_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..WORKLIST_LABEL Field
MCdicom Structure See Also Send Feedback
Worklist Label (0074,1202)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint WORKLIST_LABEL
Visual Basic
Public Const WORKLIST_LABEL As UInteger
Visual C++
public:
literal unsigned int WORKLIST_LABEL

See Also

MCdicom Structure
MCdicom Members


X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE Field
MCdicom Structure See Also Send Feedback
X Coordinates Center Pixel View Angle (0022,1528)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE
Visual Basic
Public Const X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE As UInteger
Visual C++
public:
literal unsigned int X_COORDINATES_CENTER_PIXEL_VIEW_ANGLE

See Also

MCdicom Structure
MCdicom Members


X_FOCUS_CENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_FOCUS_CENTER Field
MCdicom Structure See Also Send Feedback
X Focus Center (0018,1183)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_FOCUS_CENTER
Visual Basic
Public Const X_FOCUS_CENTER As UInteger
Visual C++
public:
literal unsigned int X_FOCUS_CENTER

See Also

MCdicom Structure
MCdicom Members


X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field
MCdicom Structure See Also Send Feedback
X Offset in Slide Coordinate System (0040,072A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM
Visual Basic
Public Const X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM As UInteger
Visual C++
public:
literal unsigned int X_OFFSET_IN_SLIDE_COORDINATE_SYSTEM

See Also

MCdicom Structure
MCdicom Members


X_RAY_3D_ACQUISITION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_3D_ACQUISITION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray 3D Acquisition Sequence (0018,9507)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_3D_ACQUISITION_SEQUENCE
Visual Basic
Public Const X_RAY_3D_ACQUISITION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_3D_ACQUISITION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_3D_FRAME_TYPE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_3D_FRAME_TYPE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray 3D Frame Type Sequence (0018,9504)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_3D_FRAME_TYPE_SEQUENCE
Visual Basic
Public Const X_RAY_3D_FRAME_TYPE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_3D_FRAME_TYPE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_3D_RECONSTRUCTION_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_3D_RECONSTRUCTION_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray 3D Reconstruction Sequence (0018,9530)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_3D_RECONSTRUCTION_SEQUENCE
Visual Basic
Public Const X_RAY_3D_RECONSTRUCTION_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_3D_RECONSTRUCTION_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_ACQUISITION_DOSE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_ACQUISITION_DOSE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray Acquisition Dose Sequence (0018,9542)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_ACQUISITION_DOSE_SEQUENCE
Visual Basic
Public Const X_RAY_ACQUISITION_DOSE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_ACQUISITION_DOSE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_DETECTOR_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_DETECTOR_ID Field
MCdicom Structure See Also Send Feedback
X-Ray Detector ID (0018,9371)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_DETECTOR_ID
Visual Basic
Public Const X_RAY_DETECTOR_ID As UInteger
Visual C++
public:
literal unsigned int X_RAY_DETECTOR_ID

See Also

MCdicom Structure
MCdicom Members


X_RAY_DETECTOR_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_DETECTOR_INDEX Field
MCdicom Structure See Also Send Feedback
X-Ray Detector Index (0018,9370)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_DETECTOR_INDEX
Visual Basic
Public Const X_RAY_DETECTOR_INDEX As UInteger
Visual C++
public:
literal unsigned int X_RAY_DETECTOR_INDEX

See Also

MCdicom Structure
MCdicom Members


X_RAY_DETECTOR_LABEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_DETECTOR_LABEL Field
MCdicom Structure See Also Send Feedback
X-Ray Detector Label (0018,9373)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_DETECTOR_LABEL
Visual Basic
Public Const X_RAY_DETECTOR_LABEL As UInteger
Visual C++
public:
literal unsigned int X_RAY_DETECTOR_LABEL

See Also

MCdicom Structure
MCdicom Members


X_RAY_FILTER_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_FILTER_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray Filter Details Sequence (0018,11BC)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_FILTER_DETAILS_SEQUENCE
Visual Basic
Public Const X_RAY_FILTER_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_FILTER_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_FILTER_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_FILTER_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray Filter Sequence (0018,9556)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_FILTER_SEQUENCE
Visual Basic
Public Const X_RAY_FILTER_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_FILTER_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_GEOMETRY_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_GEOMETRY_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray Geometry Sequence (0018,9476)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_GEOMETRY_SEQUENCE
Visual Basic
Public Const X_RAY_GEOMETRY_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_GEOMETRY_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_GRID_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_GRID_SEQUENCE Field
MCdicom Structure See Also Send Feedback
X-Ray Grid Sequence (0018,9555)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_GRID_SEQUENCE
Visual Basic
Public Const X_RAY_GRID_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int X_RAY_GRID_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


X_RAY_IMAGE_RECEPTOR_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_IMAGE_RECEPTOR_ANGLE Field
MCdicom Structure See Also Send Feedback
X-Ray Image Receptor Angle (3002,000E)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_IMAGE_RECEPTOR_ANGLE
Visual Basic
Public Const X_RAY_IMAGE_RECEPTOR_ANGLE As UInteger
Visual C++
public:
literal unsigned int X_RAY_IMAGE_RECEPTOR_ANGLE

See Also

MCdicom Structure
MCdicom Members


X_RAY_IMAGE_RECEPTOR_TRANSLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_IMAGE_RECEPTOR_TRANSLATION Field
MCdicom Structure See Also Send Feedback
X-Ray Image Receptor Translation (3002,000D)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_IMAGE_RECEPTOR_TRANSLATION
Visual Basic
Public Const X_RAY_IMAGE_RECEPTOR_TRANSLATION As UInteger
Visual C++
public:
literal unsigned int X_RAY_IMAGE_RECEPTOR_TRANSLATION

See Also

MCdicom Structure
MCdicom Members


X_RAY_MASS_ATTENUATION_COEFFICIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_MASS_ATTENUATION_COEFFICIENT Field
MCdicom Structure See Also Send Feedback
X-Ray Mass Attenuation Coefficient (0018,9384)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_MASS_ATTENUATION_COEFFICIENT
Visual Basic
Public Const X_RAY_MASS_ATTENUATION_COEFFICIENT As UInteger
Visual C++
public:
literal unsigned int X_RAY_MASS_ATTENUATION_COEFFICIENT

See Also

MCdicom Structure
MCdicom Members


X_RAY_OUTPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_OUTPUT Field
MCdicom Structure See Also Send Feedback
X-Ray Output (0040,0312)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_OUTPUT
Visual Basic
Public Const X_RAY_OUTPUT As UInteger
Visual C++
public:
literal unsigned int X_RAY_OUTPUT

See Also

MCdicom Structure
MCdicom Members


X_RAY_RECEPTOR_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_RECEPTOR_TYPE Field
MCdicom Structure See Also Send Feedback
X-Ray Receptor Type (0018,9420)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_RECEPTOR_TYPE
Visual Basic
Public Const X_RAY_RECEPTOR_TYPE As UInteger
Visual C++
public:
literal unsigned int X_RAY_RECEPTOR_TYPE

See Also

MCdicom Structure
MCdicom Members


X_RAY_SOURCE_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_SOURCE_ID Field
MCdicom Structure See Also Send Feedback
X-Ray Source ID (0018,9367)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_SOURCE_ID
Visual Basic
Public Const X_RAY_SOURCE_ID As UInteger
Visual C++
public:
literal unsigned int X_RAY_SOURCE_ID

See Also

MCdicom Structure
MCdicom Members


X_RAY_SOURCE_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_SOURCE_INDEX Field
MCdicom Structure See Also Send Feedback
X-Ray Source Index (0018,9366)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_SOURCE_INDEX
Visual Basic
Public Const X_RAY_SOURCE_INDEX As UInteger
Visual C++
public:
literal unsigned int X_RAY_SOURCE_INDEX

See Also

MCdicom Structure
MCdicom Members


X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE Field
MCdicom Structure See Also Send Feedback
X-Ray Source Isocenter Primary Angle (0018,9543)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE
Visual Basic
Public Const X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int X_RAY_SOURCE_ISOCENTER_PRIMARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE Field
MCdicom Structure See Also Send Feedback
X-Ray Source Isocenter Secondary Angle (0018,9544)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE
Visual Basic
Public Const X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE As UInteger
Visual C++
public:
literal unsigned int X_RAY_SOURCE_ISOCENTER_SECONDARY_ANGLE

See Also

MCdicom Structure
MCdicom Members


X_RAY_TUBE_CURRENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_TUBE_CURRENT Field
MCdicom Structure See Also Send Feedback
X-Ray Tube Current (0018,1151)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_TUBE_CURRENT
Visual Basic
Public Const X_RAY_TUBE_CURRENT As UInteger
Visual C++
public:
literal unsigned int X_RAY_TUBE_CURRENT

See Also

MCdicom Structure
MCdicom Members


X_RAY_TUBE_CURRENT_IN_MA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_TUBE_CURRENT_IN_MA Field
MCdicom Structure See Also Send Feedback
X-Ray Tube Current in mA (0018,9330)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_TUBE_CURRENT_IN_MA
Visual Basic
Public Const X_RAY_TUBE_CURRENT_IN_MA As UInteger
Visual C++
public:
literal unsigned int X_RAY_TUBE_CURRENT_IN_MA

See Also

MCdicom Structure
MCdicom Members


X_RAY_TUBE_CURRENT_IN_UA Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..X_RAY_TUBE_CURRENT_IN_UA Field
MCdicom Structure See Also Send Feedback
X-Ray Tube Current in uA (0018,8151)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint X_RAY_TUBE_CURRENT_IN_UA
Visual Basic
Public Const X_RAY_TUBE_CURRENT_IN_UA As UInteger
Visual C++
public:
literal unsigned int X_RAY_TUBE_CURRENT_IN_UA

See Also

MCdicom Structure
MCdicom Members


XA_ACQUISITION_DURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XA_ACQUISITION_DURATION Field
MCdicom Structure See Also Send Feedback
XA Acquisition Duration (0018,11BD)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XA_ACQUISITION_DURATION
Visual Basic
Public Const XA_ACQUISITION_DURATION As UInteger
Visual C++
public:
literal unsigned int XA_ACQUISITION_DURATION

See Also

MCdicom Structure
MCdicom Members


XA_ACQUISITION_FRAME_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XA_ACQUISITION_FRAME_RATE Field
MCdicom Structure See Also Send Feedback
XA Acquisition Frame Rate (0018,11B9)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XA_ACQUISITION_FRAME_RATE
Visual Basic
Public Const XA_ACQUISITION_FRAME_RATE As UInteger
Visual C++
public:
literal unsigned int XA_ACQUISITION_FRAME_RATE

See Also

MCdicom Structure
MCdicom Members


XA_ACQUISITION_PHASE_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XA_ACQUISITION_PHASE_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
XA Acquisition Phase Details Sequence (0018,11B8)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XA_ACQUISITION_PHASE_DETAILS_SEQUENCE
Visual Basic
Public Const XA_ACQUISITION_PHASE_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int XA_ACQUISITION_PHASE_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


XA_PLANE_DETAILS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XA_PLANE_DETAILS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
XA Plane Details Sequence (0018,11BA)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XA_PLANE_DETAILS_SEQUENCE
Visual Basic
Public Const XA_PLANE_DETAILS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int XA_PLANE_DETAILS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE Field
MCdicom Structure See Also Send Feedback
XA/XRF Frame Characteristics Sequence (0018,9412)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE
Visual Basic
Public Const XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int XA_XRF_FRAME_CHARACTERISTICS_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


XDS_RETRIEVAL_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XDS_RETRIEVAL_SEQUENCE Field
MCdicom Structure See Also Send Feedback
XDS Retrieval Sequence (0040,E024)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XDS_RETRIEVAL_SEQUENCE
Visual Basic
Public Const XDS_RETRIEVAL_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int XDS_RETRIEVAL_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


XDS_STORAGE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..XDS_STORAGE_SEQUENCE Field
MCdicom Structure See Also Send Feedback
XDS Storage Sequence (0040,4074)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint XDS_STORAGE_SEQUENCE
Visual Basic
Public Const XDS_STORAGE_SEQUENCE As UInteger
Visual C++
public:
literal unsigned int XDS_STORAGE_SEQUENCE

See Also

MCdicom Structure
MCdicom Members


Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE Field
MCdicom Structure See Also Send Feedback
Y Coordinates Center Pixel View Angle (0022,1529)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE
Visual Basic
Public Const Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE As UInteger
Visual C++
public:
literal unsigned int Y_COORDINATES_CENTER_PIXEL_VIEW_ANGLE

See Also

MCdicom Structure
MCdicom Members


Y_FOCUS_CENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..Y_FOCUS_CENTER Field
MCdicom Structure See Also Send Feedback
Y Focus Center (0018,1184)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint Y_FOCUS_CENTER
Visual Basic
Public Const Y_FOCUS_CENTER As UInteger
Visual C++
public:
literal unsigned int Y_FOCUS_CENTER

See Also

MCdicom Structure
MCdicom Members


Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field
MCdicom Structure See Also Send Feedback
Y Offset in Slide Coordinate System (0040,073A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM
Visual Basic
Public Const Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM As UInteger
Visual C++
public:
literal unsigned int Y_OFFSET_IN_SLIDE_COORDINATE_SYSTEM

See Also

MCdicom Structure
MCdicom Members


Z_EFFECTIVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..Z_EFFECTIVE Field
MCdicom Structure See Also Send Feedback
Z Effective (4010,1019)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint Z_EFFECTIVE
Visual Basic
Public Const Z_EFFECTIVE As UInteger
Visual C++
public:
literal unsigned int Z_EFFECTIVE

See Also

MCdicom Structure
MCdicom Members


Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM Field
MCdicom Structure See Also Send Feedback
Z Offset in Slide Coordinate System (0040,074A)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM
Visual Basic
Public Const Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM As UInteger
Visual C++
public:
literal unsigned int Z_OFFSET_IN_SLIDE_COORDINATE_SYSTEM

See Also

MCdicom Structure
MCdicom Members


ZERO_VELOCITY_PIXEL_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ZERO_VELOCITY_PIXEL_VALUE Field
MCdicom Structure See Also Send Feedback
Zero Velocity Pixel Value (0018,9810)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ZERO_VELOCITY_PIXEL_VALUE
Visual Basic
Public Const ZERO_VELOCITY_PIXEL_VALUE As UInteger
Visual C++
public:
literal unsigned int ZERO_VELOCITY_PIXEL_VALUE

See Also

MCdicom Structure
MCdicom Members


ZOOM_CENTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ZOOM_CENTER Field
MCdicom Structure See Also Send Feedback
Zoom Center (0028,0032)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ZOOM_CENTER
Visual Basic
Public Const ZOOM_CENTER As UInteger
Visual C++
public:
literal unsigned int ZOOM_CENTER

See Also

MCdicom Structure
MCdicom Members


ZOOM_FACTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdicom..::..ZOOM_FACTOR Field
MCdicom Structure See Also Send Feedback
Zoom Factor (0028,0031)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const uint ZOOM_FACTOR
Visual Basic
Public Const ZOOM_FACTOR As UInteger
Visual C++
public:
literal unsigned int ZOOM_FACTOR

See Also

MCdicom Structure
MCdicom Members


MCdicom Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicom Methods
MCdicom Structure See Also Send Feedback

The MCdicom type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

MCdicom Structure


MCdimseMessage Class

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Class
Members See Also Send Feedback
Encapsulates a DICOM message used by the DICOM Message Service Element (DIMSE) protocol.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdimseMessage : MCabstractMessage
Visual Basic
Public Class MCdimseMessage _
    Inherits MCabstractMessage
Visual C++
public ref class MCdimseMessage : public MCabstractMessage

Remarks

DICOM provides for two kinds of DIMSE service messages: request messages sent by Service Class User (SCU) applications to Service Class Provider (SCP) applications, and response messages sent by SCP applications in reply to received request messages. In either case, MCdimseMessage objects are used to send messages to the remote application.

In some cases, the Merge DICOM toolkit classes create the MCdimseMessage instances. For example, the sendStoreRequest method of the MCstorageService class constructs the MCdimseMessage object and returns a reference to it. Another example is the read method of the MCassociation class which returns a MCdimseMessage object containing the message just read.

DIMSE messages contain a command set (MCcommandSet object) and may also contain a data set (MCdataSet object). The exact contents of the command set and data set depend on the service class defined by the DICOM standard. The MCcommandSet and MCdataSet objects are automatically constructed when the MCdimseMessage is constructed.

The Merge DICOM toolkit concatenates the contents of the command set and the data set when streaming the message. Note that in many cases, the service class does not require any attributes be added to the data set.

This class provides methods to retrieve or set information in the command set. The CommandSet property returns the contained command set and the he DataSet property returns the contained data set.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCabstractMessage
Mergecom..::..MCdimseMessage

See Also

MCdimseMessage Members


MCdimseMessage Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Members
MCdimseMessage Class Constructors Methods Properties See Also Send Feedback

The MCdimseMessage type exposes the following members.

Constructors

 | Name | Description
Public method | MCdimseMessage()()()() | Constructs an "empty" DIMSE message with no pre-assigned attributes in the data set.
Public method | MCdimseMessage(MCdataSet) | Constructs a DIMSE message based on an existing data set.
Public method | MCdimseMessage(MCfile) | Creates a new DIMSE message based on the data set of a DICOM file object.
Public method | MCdimseMessage(UInt16, String) | Constructs a DIMSE message providing both command code and service name.

Methods

 | Name | Description
Public method | cleanup | This method is deprecated.
Public method | dispose | Releases all resources used by this message.
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the command set and data set contained in this message to the standard output stream Out.
Public method | list(TextWriter) | Lists the contents of the command set and data set contained in this message to a TextWriter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | putAttributeIdentifier | Adds a tag number to the values in the Attribute Identifier List attribute (0000,1005).
Public method | putOffendingElement | Adds a value to the Offending Elements attribute (0000,0901).
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeMessageValues | Empties the values of all attributes in the contained data set and command set.
Public method | setServiceCommand | Sets the service name and command associated with the contained data set.
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.
Public method | streamLength | Calculates the number of bytes it would take to stream out this message.
Public method | streamOut(MCtransferSyntax, MCdataSink) | Creates a DICOM message stream from the command set and data set contained within this message.
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Creates a DICOM encoded stream from a portion of the command set and/or data set contained within this message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

Properties

 | Name | Description
Public property | ActionTypeId | Represents the Action Type ID attribute value from the message's command set.
Public property | AffectedSopClassUid | Represents the Affected SOP Class UID from the message's command set.
Public property | AffectedSopInstanceUid | Represents the Affected SOP Instance UID from the message's command set.
Public property | Association | The association over which this message was received.
Public property | AttributeIdentifiers | Represents the Attribute Identifier List from the message's command set.
Public property | Command | Represents the DIMSE Command for this messages.
Public property | CommandSet | Represents the command set for this message.
Public property | CompletedSubOperations | Represents the Number of C-STORE Sub-operations Completed attribute in the command set.
Public property | DataSet | Represents the data set for this message.
Public property | ErrorComment | Represents the Error Comment attribute in this message's command set.
Public property | ErrorId | Represents the Error ID attribute value from this message's command set.
Public property | EventTypeId | Represents the Event Type ID attribute of this message's command set.
Public property | FailedSubOperations | Represents the Number of Failed C-STORE Sub-operations attribute of this message's command set.
Public property | IsRequestMessage | Tells whether this message is a request message.
Public property | MessageId | Represents the Message ID attribute of this message's command set.
Public property | MessageIdBeingRespondedTo | Represents the Message ID Being Responded To attribute.
Public property | MessagePriority | Represents the Message Priority attribute in this message's command set.
Public property | MoveDestination | Represents the Move Destination attribute in this message's command set.
Public property | MoveOriginator | Representd the Move Originator AE Title attribute in this message's command set.
Public property | MoveOriginatorMessageId | Represents the Move Originator Message ID attribute in this message's command set.
Public property | OffendingElements | Represents the Offending Element attribute in this message's command set.
Public property | RemainingSubOperations | Represents the Number of Remaining Sub-operations attribute in this message's command set.
Public property | RequestedSopClassUid | Represents the Requested SOP Class UID attribute in this message's command set.
Public property | RequestedSopInstanceUid | Represents the Requested SOP Instance UID attribute in this message's command set.
Public property | ResponseStatus | Represents the response Status attribute in this message's command set.
Public property | ServiceName | Represents the name of the service associated with this DIMSE message.
Public property | TransferSyntax | Represents the transfer syntax of this message.
Public property | WarningSubOperations | Represents the Number of Warning Sub-operations attribute in this command set.

See Also

MCdimseMessage Class


MCdimseMessage Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Constructor
MCdimseMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdimseMessage()()()() | Constructs an "empty" DIMSE message with no pre-assigned attributes in the data set.
Public method | MCdimseMessage(MCdataSet) | Constructs a DIMSE message based on an existing data set.
Public method | MCdimseMessage(MCfile) | Creates a new DIMSE message based on the data set of a DICOM file object.
Public method | MCdimseMessage(UInt16, String) | Constructs a DIMSE message providing both command code and service name.

See Also

MCdimseMessage Class
MCdimseMessage Members


MCdimseMessage Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Constructor
MCdimseMessage Class See Also Send Feedback
Constructs an "empty" DIMSE message with no pre-assigned attributes in the data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage()
Visual Basic
Public Sub New
Visual C++
public:
MCdimseMessage()

Remarks

The message object is not associated with any particular DICOM service or command.

This form of the constructor is used if the service and command are not yet known, or if there is no need to validate the message.

If the object is to be used to send a message to a network partner, or if the MCabstractMessage.validate(MCvalidationLevel) method is to be called, the setServiceCommand(String, UInt16) method must be called first to associate this message object with a given DICOM service and command.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
MCdimseMessage Overload


MCdimseMessage Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Constructor (MCdataSet)
MCdimseMessage Class See Also Send Feedback
Constructs a DIMSE message based on an existing data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage(
    MCdataSet set
)
Visual Basic
Public Sub New ( _
    set As MCdataSet _
)
Visual C++
public:
MCdimseMessage(
    MCdataSet^ set
)

Parameters

set
Type: Mergecom..::..MCdataSet
The MCdataSet instance to use for the dimse message.

Remarks

This form of the constructor creates a new instance that references a specific MCdataSet instance for its data set and a newly created MCcommandSet object.

If the object is to be used to send a message to a network partner, or if the MCabstractMessage.validate(MCvalidationLevel) method is to be called, the setServiceCommand(String, UInt16) method must be called first to associate this message object with a given DICOM service and command.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
MCdimseMessage Overload


MCdimseMessage Constructor (MCfile)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Constructor (MCfile)
MCdimseMessage Class See Also Send Feedback
Creates a new DIMSE message based on the data set of a DICOM file object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage(
    MCfile file
)
Visual Basic
Public Sub New ( _
    file As MCfile _
)
Visual C++
public:
MCdimseMessage(
    MCfile^ file
)

Parameters

file
Type: Mergecom..::..MCfile
A reference to a MCfile object.

Remarks

This form of the constructor creates a new message object that shares the same MCdataSet object as that contained in the specified file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
MCdimseMessage Overload


MCdimseMessage Constructor (UInt16, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Constructor (UInt16, String)
MCdimseMessage Class See Also Send Feedback
Constructs a DIMSE message providing both command code and service name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage(
    ushort command,
    string serviceName
)
Visual Basic
Public Sub New ( _
    command As UShort, _
    serviceName As String _
)
Visual C++
public:
MCdimseMessage(
    unsigned short command,
    String^ serviceName
)

Parameters

command
Type: System..::..UInt16
One of the DIMSE command codes.
serviceName
Type: System..::..String
A non-null name of a DICOM service.

Remarks

This form of the constructor creates a message with a data set and a command set containing all the attributes of a DICOM message that will be used for the given service and command.

The service name and command are used to access configuration information that describes the attributes of the message. If such configuration information is not available, an empty message object is created, and a warning is logged.

The command code must be one of the values defined by the MCdimseService class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
MCdimseMessage Overload


MCdimseMessage Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Methods
MCdimseMessage Class See Also Send Feedback

The MCdimseMessage type exposes the following members.

Methods

 | Name | Description
Public method | cleanup | This method is deprecated.
Public method | dispose | Releases all resources used by this message.
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the command set and data set contained in this message to the standard output stream Out.
Public method | list(TextWriter) | Lists the contents of the command set and data set contained in this message to a TextWriter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | putAttributeIdentifier | Adds a tag number to the values in the Attribute Identifier List attribute (0000,1005).
Public method | putOffendingElement | Adds a value to the Offending Elements attribute (0000,0901).
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeMessageValues | Empties the values of all attributes in the contained data set and command set.
Public method | setServiceCommand | Sets the service name and command associated with the contained data set.
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.
Public method | streamLength | Calculates the number of bytes it would take to stream out this message.
Public method | streamOut(MCtransferSyntax, MCdataSink) | Creates a DICOM message stream from the command set and data set contained within this message.
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Creates a DICOM encoded stream from a portion of the command set and/or data set contained within this message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

See Also

MCdimseMessage Class


cleanup Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..cleanup Method
MCdimseMessage Class See Also Send Feedback
This method is deprecated.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void cleanup(
    bool cleanupDataSet
)
Visual Basic
Public Overridable Sub cleanup ( _
    cleanupDataSet As Boolean _
)
Visual C++
public:
virtual void cleanup(
    bool cleanupDataSet
)

Parameters

cleanupDataSet
Type: System..::..Boolean
.

See Also

MCdimseMessage Class
MCdimseMessage Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..dispose Method
MCdimseMessage Class See Also Send Feedback
Releases all resources used by this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void dispose()
Visual Basic
Public Overridable Sub dispose
Visual C++
public:
virtual void dispose()

See Also

MCdimseMessage Class
MCdimseMessage Members


list Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..list Method
MCdimseMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | list()()()() | Lists the contents of the command set and data set contained in this message to the standard output stream Out.
Public method | list(TextWriter) | Lists the contents of the command set and data set contained in this message to a TextWriter.

See Also

MCdimseMessage Class
MCdimseMessage Members


list Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..list Method
MCdimseMessage Class See Also Send Feedback
Lists the contents of the command set and data set contained in this message to the standard output stream Out.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list()
Visual Basic
Public Overridable Sub list
Visual C++
public:
virtual void list()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.

See Also

MCdimseMessage Class
MCdimseMessage Members
list Overload


list Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..list Method (TextWriter)
MCdimseMessage Class See Also Send Feedback
Lists the contents of the command set and data set contained in this message to a TextWriter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list(
    TextWriter destination
)
Visual Basic
Public Overridable Sub list ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void list(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
TextWriter object defining the output.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The destination is null.
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.

See Also

MCdimseMessage Class
MCdimseMessage Members
list Overload


putAttributeIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..putAttributeIdentifier Method
MCdimseMessage Class See Also Send Feedback
Adds a tag number to the values in the Attribute Identifier List attribute (0000,1005).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void putAttributeIdentifier(
    int tagNumber
)
Visual Basic
Public Overridable Sub putAttributeIdentifier ( _
    tagNumber As Integer _
)
Visual C++
public:
virtual void putAttributeIdentifier(
    int tagNumber
)

Parameters

tagNumber
Type: System..::..Int32
The tag number to add.

Remarks

DIMSE services using N-GET operations use this command set attribute to provide an attribute tag for each of the attributes applicable to the N-GET operation.

If the attribute is not already in the message, it is added. The value provided is appended to any existing values for the attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The Attribute Identifier List attribute is not valid for this message.

See Also

MCdimseMessage Class
MCdimseMessage Members


putOffendingElement Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..putOffendingElement Method
MCdimseMessage Class See Also Send Feedback
Adds a value to the Offending Elements attribute (0000,0901).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void putOffendingElement(
    int tagNumber
)
Visual Basic
Public Overridable Sub putOffendingElement ( _
    tagNumber As Integer _
)
Visual C++
public:
virtual void putOffendingElement(
    int tagNumber
)

Parameters

tagNumber
Type: System..::..Int32
The tag number of the offending data element

Remarks

The Offending Element attribute is often used in error response message. If the attribute is not already in the message, it is added. The value provided is appended to any existing values for the attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The Offending Elements attribute is not valid for this message.

See Also

MCdimseMessage Class
MCdimseMessage Members


removeMessageValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..removeMessageValues Method
MCdimseMessage Class See Also Send Feedback
Empties the values of all attributes in the contained data set and command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMessageValues()
Visual Basic
Public Overridable Sub removeMessageValues
Visual C++
public:
virtual void removeMessageValues()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.

See Also

MCdimseMessage Class
MCdimseMessage Members


setServiceCommand Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..setServiceCommand Method
MCdimseMessage Class See Also Send Feedback
Sets the service name and command associated with the contained data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void setServiceCommand(
    string serviceName,
    ushort command
)
Visual Basic
Public Overridable Sub setServiceCommand ( _
    serviceName As String, _
    command As UShort _
)
Visual C++
public:
virtual void setServiceCommand(
    String^ serviceName,
    unsigned short command
)

Parameters

serviceName
Type: System..::..String
The service name to be associated with this message. This value must be a valid service name defined in the MergeCOM service profile file
command
Type: System..::..UInt16
A DICOM command associated with this message. See Command property for accepted values.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members


streamIn Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamIn Method
MCdimseMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.

See Also

MCdimseMessage Class
MCdimseMessage Members


streamIn Method (MCtransferSyntax, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamIn Method (MCtransferSyntax, MCdataSource)
MCdimseMessage Class See Also Send Feedback
Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint streamIn(
    MCtransferSyntax transferSyntax,
    MCdataSource stream
)
Visual Basic
Public Overridable Function streamIn ( _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSource _
) As UInteger
Visual C++
public:
virtual unsigned int streamIn(
    MCtransferSyntax^ transferSyntax,
    MCdataSource^ stream
)

Parameters

transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the encoded stream.
stream
Type: Mergecom..::..MCdataSource
The source of the encoded stream.

Return Value

The byte offset in the source stream where the decoding stopped.

Remarks

All attributes within the stream are to be placed into this message.

If the stream contains any attributes with a value representation of SQ (i.e. the stream contains one or more sequences of items), an MCitem object is automatically created for each item in the stream. An MCitem object is used as the value for each item in each sequence attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCinvalidEncodingException | A tag was found in the stream that was not in ascending order or an invalid DICOM tag was detected in the stream or the stream ended without passing the entire value for an attribute or too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
streamIn Overload


streamIn Method (UInt32, UInt32, MCtransferSyntax, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamIn Method (UInt32, UInt32, MCtransferSyntax, MCdataSource)
MCdimseMessage Class See Also Send Feedback
Requests the contents of a "streamed message" (a message in the form defined by the DICOM standard) be converted and placed in this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint streamIn(
    uint startTag,
    uint stopTag,
    MCtransferSyntax transferSyntax,
    MCdataSource stream
)
Visual Basic
Public Overridable Function streamIn ( _
    startTag As UInteger, _
    stopTag As UInteger, _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSource _
) As UInteger
Visual C++
public:
virtual unsigned int streamIn(
    unsigned int startTag,
    unsigned int stopTag,
    MCtransferSyntax^ transferSyntax,
    MCdataSource^ stream
)

Parameters

startTag
Type: System..::..UInt32
The tag number of the first attribute to decode.
stopTag
Type: System..::..UInt32
The tag number of the last attribute to decode.
transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the encoded stream.
stream
Type: Mergecom..::..MCdataSource
The source of the encoded stream.

Return Value

The byte offset in the stream where the decoding stopped.

Remarks

Any attributes in the stream with tags less than startTag or greater than stopTag will be ignored. Neither startTag nor stopTag need to be in the stream.

If the stream contains any attributes with a value representation of SQ (i.e. the stream contains one or more sequences of items), an MCitem object is automatically created for each item in the stream. An MCitem object is used as the value for each item in each sequence attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCinvalidEncodingException | A tag was found in the stream that was not in ascending order or an invalid DICOM tag was detected in the stream or the stream ended without passing the entire value for an attribute or too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdimseMessage Class
MCdimseMessage Members
streamIn Overload


streamLength Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamLength Method
MCdimseMessage Class See Also Send Feedback
Calculates the number of bytes it would take to stream out this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint streamLength(
    uint startTag,
    uint stopTag,
    MCtransferSyntax transferSyntax
)
Visual Basic
Public Overridable Function streamLength ( _
    startTag As UInteger, _
    stopTag As UInteger, _
    transferSyntax As MCtransferSyntax _
) As UInteger
Visual C++
public:
virtual unsigned int streamLength(
    unsigned int startTag,
    unsigned int stopTag,
    MCtransferSyntax^ transferSyntax
)

Parameters

startTag
Type: System..::..UInt32
The tag number of the first attribute which would be streamed.
stopTag
Type: System..::..UInt32
The tag number of the first attribute which would be streamed.
transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the encoded stream.

Return Value

The calculated length of a stream containing the specified attributes.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to the method. See the Exceptions message for futher details.
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCdimseMessage Class
MCdimseMessage Members


streamOut Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamOut Method
MCdimseMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | streamOut(MCtransferSyntax, MCdataSink) | Creates a DICOM message stream from the command set and data set contained within this message.
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Creates a DICOM encoded stream from a portion of the command set and/or data set contained within this message.

See Also

MCdimseMessage Class
MCdimseMessage Members


streamOut Method (MCtransferSyntax, MCdataSink)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamOut Method (MCtransferSyntax, MCdataSink)
MCdimseMessage Class See Also Send Feedback
Creates a DICOM message stream from the command set and data set contained within this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void streamOut(
    MCtransferSyntax transferSyntax,
    MCdataSink stream
)
Visual Basic
Public Overridable Sub streamOut ( _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSink _
)
Visual C++
public:
virtual void streamOut(
    MCtransferSyntax^ transferSyntax,
    MCdataSink^ stream
)

Parameters

transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax for the output stream.
stream
Type: Mergecom..::..MCdataSink
The destination for the encoded data.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to the method. See the message in the exception for futher details.
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | A problem happened while writing the stream. See the content of the exception object for further details.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCdimseMessage Class
MCdimseMessage Members
streamOut Overload


streamOut Method (UInt32, UInt32, MCtransferSyntax, MCdataSink)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..streamOut Method (UInt32, UInt32, MCtransferSyntax, MCdataSink)
MCdimseMessage Class See Also Send Feedback
Creates a DICOM encoded stream from a portion of the command set and/or data set contained within this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void streamOut(
    uint startTag,
    uint stopTag,
    MCtransferSyntax transferSyntax,
    MCdataSink stream
)
Visual Basic
Public Overridable Sub streamOut ( _
    startTag As UInteger, _
    stopTag As UInteger, _
    transferSyntax As MCtransferSyntax, _
    stream As MCdataSink _
)
Visual C++
public:
virtual void streamOut(
    unsigned int startTag,
    unsigned int stopTag,
    MCtransferSyntax^ transferSyntax,
    MCdataSink^ stream
)

Parameters

startTag
Type: System..::..UInt32
The tag number of the first attribute to be streamed.
stopTag
Type: System..::..UInt32
The tag number of the last attribute to be streamed.
transferSyntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax for the output stream.
stream
Type: Mergecom..::..MCdataSink
The destination for the encoded data.

Remarks

The streamed message is passed to the destination stream in blocks by calling MCdataSink.receiveData until the entire message has been transferred.

startTag and stopTag specify which attributes in the message are to be placed in the stream. Any attributes in the message with tags less than startTag or greater than stopTag will be ignored. Neither startTag nor stopTag need to be in the message.

The transfer syntax specifies the byte order used in the streamed message, whether or not each attribute's value representation is explicitly encoded in the stream, and how the pixel data is encoded in the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The stream returned an exception. See the inner exception for details.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCdimseMessage Class
MCdimseMessage Members
streamOut Overload


MCdimseMessage Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage Properties
MCdimseMessage Class See Also Send Feedback

The MCdimseMessage type exposes the following members.

Properties

 | Name | Description
Public property | ActionTypeId | Represents the Action Type ID attribute value from the message's command set.
Public property | AffectedSopClassUid | Represents the Affected SOP Class UID from the message's command set.
Public property | AffectedSopInstanceUid | Represents the Affected SOP Instance UID from the message's command set.
Public property | Association | The association over which this message was received.
Public property | AttributeIdentifiers | Represents the Attribute Identifier List from the message's command set.
Public property | Command | Represents the DIMSE Command for this messages.
Public property | CommandSet | Represents the command set for this message.
Public property | CompletedSubOperations | Represents the Number of C-STORE Sub-operations Completed attribute in the command set.
Public property | DataSet | Represents the data set for this message.
Public property | ErrorComment | Represents the Error Comment attribute in this message's command set.
Public property | ErrorId | Represents the Error ID attribute value from this message's command set.
Public property | EventTypeId | Represents the Event Type ID attribute of this message's command set.
Public property | FailedSubOperations | Represents the Number of Failed C-STORE Sub-operations attribute of this message's command set.
Public property | IsRequestMessage | Tells whether this message is a request message.
Public property | MessageId | Represents the Message ID attribute of this message's command set.
Public property | MessageIdBeingRespondedTo | Represents the Message ID Being Responded To attribute.
Public property | MessagePriority | Represents the Message Priority attribute in this message's command set.
Public property | MoveDestination | Represents the Move Destination attribute in this message's command set.
Public property | MoveOriginator | Representd the Move Originator AE Title attribute in this message's command set.
Public property | MoveOriginatorMessageId | Represents the Move Originator Message ID attribute in this message's command set.
Public property | OffendingElements | Represents the Offending Element attribute in this message's command set.
Public property | RemainingSubOperations | Represents the Number of Remaining Sub-operations attribute in this message's command set.
Public property | RequestedSopClassUid | Represents the Requested SOP Class UID attribute in this message's command set.
Public property | RequestedSopInstanceUid | Represents the Requested SOP Instance UID attribute in this message's command set.
Public property | ResponseStatus | Represents the response Status attribute in this message's command set.
Public property | ServiceName | Represents the name of the service associated with this DIMSE message.
Public property | TransferSyntax | Represents the transfer syntax of this message.
Public property | WarningSubOperations | Represents the Number of Warning Sub-operations attribute in this command set.

See Also

MCdimseMessage Class


ActionTypeId Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..ActionTypeId Property
MCdimseMessage Class See Also Send Feedback
Represents the Action Type ID attribute value from the message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort ActionTypeId { get; set; }
Visual Basic
Public Overridable Property ActionTypeId As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short ActionTypeId {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Action Type ID attribute.

Remarks

This property sets or gets the attribute Action Type Id (0000,1008) in the command set.

Normalized DICOM service classes make use of the N-ACTION DIMSE operation requesting that a specific action be performed by the peer DIMSE service user. Each SOP class using the N-ACTION service defines Action Type IDs that identify a specific service.

The attribute is added to the message, if necessary and any existing value is replaced by the one provided.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


AffectedSopClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..AffectedSopClassUid Property
MCdimseMessage Class See Also Send Feedback
Represents the Affected SOP Class UID from the message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AffectedSopClassUid { get; set; }
Visual Basic
Public Overridable Property AffectedSopClassUid As String
    Get
    Set
Visual C++
public:
virtual property String^ AffectedSopClassUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Affected SOP Class UID attribute.

Remarks

This property sets/gets the attribute Affected SOP Class UID ((0000,0002) in the command set of this message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


AffectedSopInstanceUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..AffectedSopInstanceUid Property
MCdimseMessage Class See Also Send Feedback
Represents the Affected SOP Instance UID from the message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AffectedSopInstanceUid { get; set; }
Visual Basic
Public Overridable Property AffectedSopInstanceUid As String
    Get
    Set
Visual C++
public:
virtual property String^ AffectedSopInstanceUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Affected SOP Instance UID attribute.

Remarks

This property sets or gets the attribute Affected SOP Instance UID (0000,1000) in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


Association Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..Association Property
MCdimseMessage Class See Also Send Feedback
The association over which this message was received.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCassociation Association { get; set; }
Visual Basic
Public Overridable Property Association As MCassociation
    Get
    Set
Visual C++
public:
virtual property MCassociation^ Association {
    MCassociation^ get ();
    void set (MCassociation^ value);
}

Field Value

The MCassociation instance over which this message was received or null if the association is not known at this time.

See Also

MCdimseMessage Class
MCdimseMessage Members


AttributeIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..AttributeIdentifiers Property
MCdimseMessage Class See Also Send Feedback
Represents the Attribute Identifier List from the message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint[] AttributeIdentifiers { get; set; }
Visual Basic
Public Overridable Property AttributeIdentifiers As UInteger()
    Get
    Set
Visual C++
public:
virtual property array<unsigned int>^ AttributeIdentifiers {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Field Value

An array of uint values representing the value of the Attribute Identifier List attribute.

Remarks

This property sets or gets the attribute Attribute Identifier list (0000,1005) in the command set.

When setting, the previous value for the attribute is replaced by the value being set.

DIMSE services using N-GET operations use this command set field to provide an attribute tag for each of the attributes applicable to the N-GET operation. Each of the tag numbers in the array provided are added to the Attribute Identifier List attribute.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


Command Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..Command Property
MCdimseMessage Class See Also Send Feedback
Represents the DIMSE Command for this messages.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort Command { get; }
Visual Basic
Public Overridable ReadOnly Property Command As UShort
    Get
Visual C++
public:
virtual property unsigned short Command {
    unsigned short get ();
}

Field Value

An ushort value representing this message's command.

Remarks

This property gets the DIMSE Command associated with this message.

The value returned will be one of the command codes defined by MCdimseService class:

  • Composite Store Service Request and Reply: C_STORE_RQ, C_STORE_RSP
  • Composite Get Service Request, Reply and Cancel: C_GET_RQ, C_GET_RSP, C_CANCEL_GET_RQ
  • Composite Find Service Request, Reply and Cancel: C_FIND_RQ, C_FIND_RSP, C_CANCEL_FIND_RQ
  • Composite Move Service Request, Reply and Cancel: C_MOVE_RQ, C_MOVE_RSP, C_CANCEL_MOVE_RQ
  • Verification Service Request and Reply: C_ECHO_RQ, C_ECHO_RSP
  • Normalized Report Service Request and Reply: N_EVENT_REPORT_RQ, N_EVENT_REPORT_RSP
  • Normalized Get Service Request and Reply: N_GET_RQ, N_GET_RSP
  • Normalized Set Service Request and Reply: N_SET_RQ, N_SET_RSP
  • Normalized Action Service Request and Reply: N_ACTION_RQ, N_ACTION_RSP
  • Normalized Create Service Request and Reply: N_CREATE_RQ, N_CREATE_RSP
  • Normalized Delete Service Request and Reply: N_DELETE_RQ, N_DELETE_RSP

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.

See Also

MCdimseMessage Class
MCdimseMessage Members


CommandSet Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..CommandSet Property
MCdimseMessage Class See Also Send Feedback
Represents the command set for this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcommandSet CommandSet { get; }
Visual Basic
Public Overridable ReadOnly Property CommandSet As MCcommandSet
    Get
Visual C++
public:
virtual property MCcommandSet^ CommandSet {
    MCcommandSet^ get ();
}

Field Value

An MCcommandSet associated with this message.

Remarks

The command set contains attributes used by the DIMSE service layer of the Merge DICOM toolkit to process DIMSE requests or responses.

See Also

MCdimseMessage Class
MCdimseMessage Members


CompletedSubOperations Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..CompletedSubOperations Property
MCdimseMessage Class See Also Send Feedback
Represents the Number of C-STORE Sub-operations Completed attribute in the command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort CompletedSubOperations { get; set; }
Visual Basic
Public Overridable Property CompletedSubOperations As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short CompletedSubOperations {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Number of C-STORE Sub-operations Completed attribute.

Remarks

This property sets or gets the attribute C-STORE sub-operations completed (0000,1021) in the command set. The attribute is added to the message, if necessary and any existing value is replaced by the one provided.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


DataSet Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..DataSet Property
MCdimseMessage Class See Also Send Feedback
Represents the data set for this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet DataSet { get; }
Visual Basic
Public Overridable ReadOnly Property DataSet As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ DataSet {
    MCdataSet^ get ();
}

Field Value

An MCdataSet associated with this message.

Remarks

The data set contains the attributes provided by the user of the DIMSE service.

See Also

MCdimseMessage Class
MCdimseMessage Members


ErrorComment Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..ErrorComment Property
MCdimseMessage Class See Also Send Feedback
Represents the Error Comment attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ErrorComment { get; set; }
Visual Basic
Public Overridable Property ErrorComment As String
    Get
    Set
Visual C++
public:
virtual property String^ ErrorComment {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Error Comment attribute.

Remarks

The Error Comment attribute (0000,0902) is often used in response messages.

Many DIMSE services provide for an attribute to be returned in response messages that describes an error that has occurred while servicing the DIMSE request. This property issued to set or get that comment value.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


ErrorId Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..ErrorId Property
MCdimseMessage Class See Also Send Feedback
Represents the Error ID attribute value from this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort ErrorId { get; set; }
Visual Basic
Public Overridable Property ErrorId As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short ErrorId {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Error ID attribute.

Remarks

This property represents the value of the Error ID attribute (0000,0903).

Certain DIMSE services provide for sending an application-specific error code in response messages. This property is used to set or get such a code.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


EventTypeId Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..EventTypeId Property
MCdimseMessage Class See Also Send Feedback
Represents the Event Type ID attribute of this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort EventTypeId { get; set; }
Visual Basic
Public Overridable Property EventTypeId As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short EventTypeId {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Event Type ID attribute.

Remarks

The Event Type ID attribute (0000,1002) Represents an application-specific Event Type code. Normalized DICOM service classes reference events that are identified by application-specific event IDs.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


FailedSubOperations Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..FailedSubOperations Property
MCdimseMessage Class See Also Send Feedback
Represents the Number of Failed C-STORE Sub-operations attribute of this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort FailedSubOperations { get; set; }
Visual Basic
Public Overridable Property FailedSubOperations As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short FailedSubOperations {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Number of Failed Sub-operations attribute.

Remarks

This property sets or gets the number of C-STORE sub-operations that generated failures (0000,1022). The attribute is added to the message, if necessary and any existing value is replaced by the one provided.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was being set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


IsRequestMessage Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..IsRequestMessage Property
MCdimseMessage Class See Also Send Feedback
Tells whether this message is a request message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsRequestMessage { get; }
Visual Basic
Public Overridable ReadOnly Property IsRequestMessage As Boolean
    Get
Visual C++
public:
virtual property bool IsRequestMessage {
    bool get ();
}

Field Value

true if this message is a request message; otherwise false.

Remarks

DIMSE request messages have command code values less than 0x8000, while DIMSE response messages all have command code values greater than 0x8000.

See Also

MCdimseMessage Class
MCdimseMessage Members


MessageId Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MessageId Property
MCdimseMessage Class See Also Send Feedback
Represents the Message ID attribute of this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MessageId { get; }
Visual Basic
Public Overridable ReadOnly Property MessageId As UShort
    Get
Visual C++
public:
virtual property unsigned short MessageId {
    unsigned short get ();
}

Field Value

An ushort representing the value of the Message ID attribute.

Remarks

This property gets the Message ID of this message from attribute (0000,0110).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.

See Also

MCdimseMessage Class
MCdimseMessage Members


MessageIdBeingRespondedTo Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MessageIdBeingRespondedTo Property
MCdimseMessage Class See Also Send Feedback
Represents the Message ID Being Responded To attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MessageIdBeingRespondedTo { get; }
Visual Basic
Public Overridable ReadOnly Property MessageIdBeingRespondedTo As UShort
    Get
Visual C++
public:
virtual property unsigned short MessageIdBeingRespondedTo {
    unsigned short get ();
}

Field Value

An ushort representing the value of the Message ID Being Responded To attribute.

Remarks

This property gets the ID of the request message related to this response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.

See Also

MCdimseMessage Class
MCdimseMessage Members


MessagePriority Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MessagePriority Property
MCdimseMessage Class See Also Send Feedback
Represents the Message Priority attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MessagePriority { get; set; }
Visual Basic
Public Overridable Property MessagePriority As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short MessagePriority {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Message Priority attribute.

Remarks

This property sets or gets the value of the Message Priority attribute (0000,0700) in the command set of this message. The attribute is added to the message, if necessary and any existing value is replaced by the one provided.

The value must be one of the values defined in MCdimseService class:

  • MCdimseService.LOW_PRIORITY_MESSAGE - low priority
  • MCdimseService.MEDIUM_PRIORITY_MESSAGE - medium priority
  • MCdimseService.HIGH_PRIORITY_MESSAGE - high priority

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


MoveDestination Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MoveDestination Property
MCdimseMessage Class See Also Send Feedback
Represents the Move Destination attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MoveDestination { get; set; }
Visual Basic
Public Overridable Property MoveDestination As String
    Get
    Set
Visual C++
public:
virtual property String^ MoveDestination {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Move Destination attribute.

Remarks

This property represents the value of the Move Destination attribute (0000,0600) which is the AE Title of the destination for which C-STORE sub-operations are being performed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


MoveOriginator Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MoveOriginator Property
MCdimseMessage Class See Also Send Feedback
Representd the Move Originator AE Title attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MoveOriginator { get; set; }
Visual Basic
Public Overridable Property MoveOriginator As String
    Get
    Set
Visual C++
public:
virtual property String^ MoveOriginator {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Move Originator AE Title attribute.

Remarks

This property represents the value of the Move Originator AE Title attribute (0000,1030) which is the DICOM AE Title of the originator of the C-MOVE operation.

C-STORE request messages contain an attribute that provides the DICOM title of the Application Entity which invoked the C-MOVE operation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


MoveOriginatorMessageId Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..MoveOriginatorMessageId Property
MCdimseMessage Class See Also Send Feedback
Represents the Move Originator Message ID attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MoveOriginatorMessageId { get; set; }
Visual Basic
Public Overridable Property MoveOriginatorMessageId As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short MoveOriginatorMessageId {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Move Originator Message ID attribute.

Remarks

This property sets or gets the value of the Move Originator Message ID attribute (0000,1030).

C-STORE request messages contain an attribute that provides the Message ID of the C-MOVE request message for which a C-STORE sub-operation is being performed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


OffendingElements Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..OffendingElements Property
MCdimseMessage Class See Also Send Feedback
Represents the Offending Element attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint[] OffendingElements { get; set; }
Visual Basic
Public Overridable Property OffendingElements As UInteger()
    Get
    Set
Visual C++
public:
virtual property array<unsigned int>^ OffendingElements {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Field Value

An array of uint values representing the values of the Offending Element attribute.

Remarks

This property gets or sets the Offending Element attribute (0000,0901). Any existing values for this attribute are first removed.

Error messages often use this attribute to provide a list tags of data elements involved in an error.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


RemainingSubOperations Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..RemainingSubOperations Property
MCdimseMessage Class See Also Send Feedback
Represents the Number of Remaining Sub-operations attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort RemainingSubOperations { get; set; }
Visual Basic
Public Overridable Property RemainingSubOperations As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short RemainingSubOperations {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Number of Remaining Sub-operations attribute.

Remarks

This property sets or gets the Number of Remaining Sub-operations attribute (0000,1020) in a C-STORE pending response.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


RequestedSopClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..RequestedSopClassUid Property
MCdimseMessage Class See Also Send Feedback
Represents the Requested SOP Class UID attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedSopClassUid { get; set; }
Visual Basic
Public Overridable Property RequestedSopClassUid As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedSopClassUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Requested SOP Class UID attribute.

Remarks

This property sets or gets the value of Requested SOP Class UID attribute (0000,0003).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


RequestedSopInstanceUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..RequestedSopInstanceUid Property
MCdimseMessage Class See Also Send Feedback
Represents the Requested SOP Instance UID attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedSopInstanceUid { get; set; }
Visual Basic
Public Overridable Property RequestedSopInstanceUid As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedSopInstanceUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the value of the Requested SOP Instance UID attribute.

Remarks

This property sets or gets the value of Requested SOP Instance UID attribute (0000,0003).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


ResponseStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..ResponseStatus Property
MCdimseMessage Class See Also Send Feedback
Represents the response Status attribute in this message's command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort ResponseStatus { get; }
Visual Basic
Public Overridable ReadOnly Property ResponseStatus As UShort
    Get
Visual C++
public:
virtual property unsigned short ResponseStatus {
    unsigned short get ();
}

Field Value

An ushort representing the value of the Status attribute.

Remarks

This property gets the response Status attribute (0000,0900).

Each DICOM service uses a specific set of response status codes. Refer to the DICOM Standard Documentation for details.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


ServiceName Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..ServiceName Property
MCdimseMessage Class See Also Send Feedback
Represents the name of the service associated with this DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceName { get; }
Visual Basic
Public Overridable ReadOnly Property ServiceName As String
    Get
Visual C++
public:
virtual property String^ ServiceName {
    String^ get ();
}

Field Value

A String representing the service name.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.

See Also

MCdimseMessage Class
MCdimseMessage Members


TransferSyntax Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..TransferSyntax Property
MCdimseMessage Class See Also Send Feedback
Represents the transfer syntax of this message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax TransferSyntax { get; set; }
Visual Basic
Public Overridable Property TransferSyntax As MCtransferSyntax
    Get
    Set
Visual C++
public:
virtual property MCtransferSyntax^ TransferSyntax {
    MCtransferSyntax^ get ();
    void set (MCtransferSyntax^ value);
}

Field Value

The MCtransferSyntax object representing the transfer syntax of this message or null if the transfer syntax was not set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


WarningSubOperations Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseMessage..::..WarningSubOperations Property
MCdimseMessage Class See Also Send Feedback
Represents the Number of Warning Sub-operations attribute in this command set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort WarningSubOperations { get; set; }
Visual Basic
Public Overridable Property WarningSubOperations As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short WarningSubOperations {
    unsigned short get ();
    void set (unsigned short value);
}

Field Value

An ushort representing the value of the Number of Warning Sub-operations attribute.

Remarks

This property sets/gets the number of C-STORE sub-operations that generated warnings (0000,1022). The attribute is added to the message, if necessary and any existing value is replaced by the one provided.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute was not found when getting this property.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute has no values.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid value was set for this property.

See Also

MCdimseMessage Class
MCdimseMessage Members


MCdimseService Class

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService Class
Members See Also Send Feedback
Implements basic functionality for DIMSE services. Sub-classes provide methods particular to specific DICOM DIMSE services.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdimseService
Visual Basic
Public Class MCdimseService
Visual C++
public ref class MCdimseService

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCbasicWorklistManagementService
Mergecom..::..MCpatientManagementService
Mergecom..::..MCprintManagementService
Mergecom..::..MCqueryRetrieveService
Mergecom..::..MCqueueManagementService
Mergecom..::..MCresultsManagementService
Mergecom..::..MCstorageCommitmentService
Mergecom..::..MCstorageService
Mergecom..::..MCstudyContentNotificationService
Mergecom..::..MCstudyManagementService
Mergecom..::..MCunifiedProcedureStepService
Mergecom..::..MCverificationService

See Also

MCdimseService Members


MCdimseService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService Members
MCdimseService Class Constructors Methods Fields Properties See Also Send Feedback

The MCdimseService type exposes the following members.

Constructors

 | Name | Description
Public method | MCdimseService | Initializes a new instance of this class for an association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503.
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107.
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000.
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111.
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115.
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007.
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117.
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501.
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120.
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123.
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114.
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105.
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113.
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112.
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001.
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00.
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00.
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01.
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506.
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700.
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner.
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213.
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000.
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000.
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505.
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211.
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object.
 | C_CANCEL_FIND_RQ | Cancel DICOM Composite Find Service Request command.
 | C_CANCEL_FIND_RQ_BIT | DIMSE command control bit for C_CANCEL_FIND_RQ.
 | C_CANCEL_GET_RQ | Cancel DICOM Composite Get Service Request command.
 | C_CANCEL_GET_RQ_BIT | DIMSE command control bit for C_CANCEL_GET_RQ.
 | C_CANCEL_MOVE_RQ | Cancel DICOM Composite Move Service Request command.
 | C_CANCEL_MOVE_RQ_BIT | DIMSE command control bit for C_CANCEL_MOVE_RQ.
 | C_CANCEL_RQ | Cancel DICOM Composite Service Request command.
 | C_CANCEL_RQ_BIT | DIMSE command control bit for C_CANCEL_RQ.
 | C_ECHO_RQ | DICOM Verification Service Request command.
 | C_ECHO_RQ_BIT | DIMSE command control bit for C_ECHO_RQ.
 | C_ECHO_RSP | DICOM Verification Service Response command.
 | C_ECHO_RSP_BIT | DIMSE command control bit for C_ECHO_RSP.
 | C_ECHO_SUCCESS | Verification Service Class C_ECHO_RSP success code.
 | C_FIND_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_FIND_RSP code for cancelled request status.
 | C_FIND_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_FIND_RSP code for "INVALID DATASET" failure status.
 | C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND | Query/Retrieve Service Class C_FIND_RSP code for "MORE THAN ONE MATCH FOUND" failure status.
 | C_FIND_FAILURE_REFUSED_NO_RESOURCES | Query/Retrieve Service Class C_FIND_RSP code for "NO RESOURCES" failure status.
 | C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_FIND_RSP code for "RPI UNABLE TO PROCESS" failure status.
 | C_FIND_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO PROCESS" failure status.
 | C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE | Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO SUPPORT REQUESTED TEMPLATE" failure status.
 | C_FIND_PENDING | Query/Retrieve Service Class C_FIND_RSP code for pending result.
 | C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT | Query/Retrieve Service Class C_FIND_RSP code for pending with no optional key support.
 | C_FIND_RQ | DICOM Composite Find Service Request command.
 | C_FIND_RQ_BIT | DIMSE command control bit for C_FIND_RQ.
 | C_FIND_RSP | DICOM Composite Find Service Response command.
 | C_FIND_RSP_BIT | DIMSE command control bit for C_FIND_RSP.
 | C_FIND_SUCCESS | Query/Retrieve Service Class C_FIND_RSP success code.
 | C_GET_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_GET_RSP code for cancelled request status.
 | C_GET_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_GET_RSP code for "INVALID DATASET" failure code.
 | C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES | Query/Retrieve Service Class C_GET_RSP code for "CAN'T CALCULATE MATCHES" failure code.
 | C_GET_FAILURE_REFUSED_CANT_PERFORM | Query/Retrieve Service Class C_GET_RSP code for "CAN'T PERFORM" failure code.
 | C_GET_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_GET_RSP code for "UNABLE TO PROCESS" failure code.
 | C_GET_PENDING_MORE_SUB_OPERATIONS | Query/Retrieve Service Class C_GET_RSP pending code.
 | C_GET_RQ | DICOM Composite Get Service Request command.
 | C_GET_RQ_BIT | DIMSE command control bit for C_GET_RQ.
 | C_GET_RSP | DICOM Composite Get Service Response command.
 | C_GET_RSP_BIT | DIMSE command control bit for C_GET_RSP.
 | C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS | Query/Retrieve Service Class C_GET_RSP success code.
 | C_GET_WARNING_SOME_FAILURES_WARNINGS | Query/Retrieve Service Class C_GET_RSP warning code.
 | C_MOVE_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_MOVE_RSP code for cancelled request status.
 | C_MOVE_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_MOVE_RSP code for "INVALID DATASET" failure code.
 | C_MOVE_FAILURE_REFUSED_CANT_CALCULATE | Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T CALCULATE" failure code.
 | C_MOVE_FAILURE_REFUSED_CANT_PERFORM | Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T PERFORM" failure code.
 | C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN | Query/Retrieve Service Class C_MOVE_RSP code for "DESTINATION UNKNOWN" failure code.
 | C_MOVE_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_MOVE_RSP code for "UNABLE TO PROCESS" failure code.
 | C_MOVE_PENDING_MORE_SUB_OPERATIONS | Query/Retrieve Service Class C_MOVE_RSP pending result code.
 | C_MOVE_RQ | DICOM Composite Move Service Request command.
 | C_MOVE_RQ_BIT | DIMSE command control bit for C_MOVE_RQ.
 | C_MOVE_RSP | DICOM Composite Move Service Response command.
 | C_MOVE_RSP_BIT | DIMSE command control bit for C_MOVE_RSP.
 | C_MOVE_SUCCESS_NO_FAILURES | Query/Retrieve Service Class C_MOVE_RSP success code.
 | C_MOVE_WARNING_ONE_OR_MORE_FAILURES | Query/Retrieve Service Class C_MOVE_RSP warning code.
 | C_STORE_FAILED_OPERATION | Study Content NotificationService Class C_STORE_RSP code for "FAILED OPERATION" status.
 | C_STORE_FAILURE_CANNOT_UNDERSTAND | Storage Service Class C_STORE_RSP Code for "CANNOT UNDERSTAND" failure status.
 | C_STORE_FAILURE_INVALID_DATASET | Storage Service Class C_STORE_RSP Code for "NVALID DATASET" failure status.
 | C_STORE_FAILURE_PROCESSING_FAILURE | Storage Service Class C_STORE_RSP Code for "PROCESSING FAILURE" failure status.
 | C_STORE_FAILURE_REFUSED_NO_RESOURCES | Storage Service Class C_STORE_RSP Code for "NO RESOURCES" failure status.
 | C_STORE_RQ | DICOM Composite Store Service Request command.
 | C_STORE_RQ_BIT | DIMSE command control bit for C_STORE_RQ.
 | C_STORE_RSP | DICOM Composite Store Service Response command.
 | C_STORE_RSP_BIT | DIMSE command control bit for C_STORE_RSP.
 | C_STORE_SUCCESS | Storage Service Class C_STORE_RSP Code for success status.
 | C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS | Study Content NotificationService Class C_STORE_RSP code for "COMPLETE STUDY EXISTS" status.
 | C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS | Study Content NotificationService Class C_STORE_RSP code for "PARTIAL STUDY EXISTS" status.
 | C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST | Study Content NotificationService Class C_STORE_RSP code for "STUDY DOES NOT EXIST" status.
 | C_STORE_SUCCESS_UNKNOWN_EXISTENCE | Study Content NotificationService Class C_STORE_RSP code for "UNKNOWN EXISTENCE" status.
 | C_STORE_WARNING_ELEMENT_COERCION | Storage Service Class C_STORE_RSP Code for "ELEMENT COERCION" warning status.
 | C_STORE_WARNING_ELEMENTS_DISCARDED | Storage Service Class C_STORE_RSP Code for "ELEMENTS DISCARDED" warning status.
 | C_STORE_WARNING_INVALID_DATASET | Storage Service Class C_STORE_RSP Code for "INVALID DATASET" warning status.
 | HIGH_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a high priority DIMSE message.
 | LOW_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a low priority DIMSE message.
 | MEDIUM_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a medium priority DIMSE message.
 | N_ACTION_CANCELLATION_DENIED | Media Creation Management failure code.
 | N_ACTION_CLASS_INSTANCE_CONFLICT | N_ACTION_RSP Response failure code.
 | N_ACTION_DUPLICATE_INVOCATION | N_ACTION_RSP Response failure code.
 | N_ACTION_DUPLICATE_TRANSACTION_UID | N_ACTION_RSP Response failure code.
 | N_ACTION_FAILURE_ANNOTATION_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_BOX_PRINT_Q_FULL | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_EMPTY_PAGE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_POS_COLLISION | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_INSUFFICIENT_MEMORY | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_JOB_IN_PROCESS | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_IMAGE_AT_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRES_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_RETRIEVING_IMAGE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_RETRIEVING_STORED_PRINT | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_SESSION_PRINT_Q_FULL | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE | Pull Print Request N_ACTION_RSP failure code (correct spelling).
 | N_ACTION_INVALID_ARGUMENT_VALUE | N_ACTION_RSP Response failure code.
 | N_ACTION_MEDIA_CREATION_RQ_COMPLETED | Media Creation Management failure code.
 | N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS | Media Creation Management failure code.
 | N_ACTION_MEMORY_ALLOCATION_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_MISTYPED_ARGUMENT | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_ACTION_TYPE | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_ARGUMENT | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_SOP_CLASS | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_SOP_INSTANCE | N_ACTION_RSP Response failure code.
 | N_ACTION_OPERATOR_NOT_AUTHORIZED | Substance Administration Operator not authorized to add entry to Medication Administration Record failure
 | N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED | Substance Administration Patient cannot be identified from Patient ID or Admission ID failure
 | N_ACTION_PROCESSING_FAILURE | N_ACTION_RSP Response failure code.
 | N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED | N_ACTION_RSP Response failure code.
 | N_ACTION_REFUSED_ALREADY_IN_PROGRESS | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_REFUSED_WRONG_TRANSACTION_ID | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_RESOURCE_LIMITATION | N_ACTION_RSP Response failure code.
 | N_ACTION_RQ | DICOM Normalized Action Service Request command.
 | N_ACTION_RQ_BIT | DIMSE command control bit for N_ACTION_RQ.
 | N_ACTION_RSP | DICOM Normalized Action Service Response command.
 | N_ACTION_RSP_BIT | DIMSE command control bit for N_ACTION_RSP.
 | N_ACTION_SUCCESS | N_ACTION_RSP Response success code.
 | N_ACTION_UNRECOGNIZED_OPERATION | N_ACTION_RSP Response failure code.
 | N_ACTION_UPDATE_OF_MAR_FAILED | Substance Update of Medication Administration Record failed
 | N_ACTION_WARNING_ANNOTATION_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_BOX_EMPTY_PAGE | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_NO_COLLATION_SUPPORT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_PRES_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_SESSION_EMPTY_PAGE | Print Management Service Class N_ACTION_RSP warning code.
 | N_CREATE_ATTRIBUTE_LIST_ERROR | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_CLASS_INSTANCE_CONFLICT | N_CREATE_RSP Response failure code.
 | N_CREATE_DUPLICATE_INVOCATION | N_CREATE_RSP Response failure code.
 | N_CREATE_DUPLICATE_SOP_INSTANCE | N_CREATE_RSP Response failure code.
 | N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING | Basic Print Image Overlay Box N_CREATE_RSP failure code.
 | N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV | Media Creation failure codes.
 | N_CREATE_INVALID_ATTRIBUTE_VALUE | N_CREATE_RSP Response failure code.
 | N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_MISSING_ATTRIBUTE | N_CREATE_RSP Response failure code.
 | N_CREATE_MISSING_ATTRIBUTE_VALUE | N_CREATE_RSP Response failure code.
 | N_CREATE_MISTYPED_ARGUMENT | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE | Print Management Service Class N_CREATE_RSP failure code.
 | N_CREATE_NO_SUCH_ATTRIBUTE | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_SUCH_SOP_CLASS | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_SUCH_SOP_INSTANCE | N_CREATE_RSP Response failure code.
 | N_CREATE_PROCESSING_FAILURE | N_CREATE_RSP Response failure code.
 | N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS | Modify GP Performed Procedure Step N_CREATE_RSP refused code.
 | N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID | Modify GP Performed Procedure Step N_CREATE_RSP refused code.
 | N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_RESOURCE_LIMITATION | N_CREATE_RSP Response failure code.
 | N_CREATE_RQ | DICOM Normalized Create Service Request command.
 | N_CREATE_RQ_BIT | DIMSE command control bit for N_CREATE_RQ.
 | N_CREATE_RSP | DICOM Normalized Create Service Response command.
 | N_CREATE_RSP_BIT | DIMSE command control bit for N_CREATE_RSP.
 | N_CREATE_SUCCESS | N_CREATE_RSP Response success code.
 | N_CREATE_TEMPORARILY_NO_MEMORY | Print Management Service Class N_CREATE_RSP failure code.
 | N_CREATE_UNRECOGNIZED_OPERATION | N_CREATE_RSP Response failure code.
 | N_DELETE_CLASS_INSTANCE_CONFLICT | N_DELETE_RSP failure code.
 | N_DELETE_DUPLICATE_INVOCATION | N_DELETE_RSP failure code.
 | N_DELETE_MISTYPED_ARGUMENT | N_DELETE_RSP failure code.
 | N_DELETE_NO_SUCH_SOP_CLASS | N_DELETE_RSP failure code.
 | N_DELETE_NO_SUCH_SOP_INSTANCE | N_DELETE_RSP failure code.
 | N_DELETE_PROCESSING_FAILURE | N_DELETE_RSP failure code.
 | N_DELETE_RESOURCE_LIMITATION | N_DELETE_RSP failure code.
 | N_DELETE_RQ | DICOM Normalized Delete Service Request command.
 | N_DELETE_RQ_BIT | DIMSE command control bit for N_DELETE_RQ.
 | N_DELETE_RSP | DICOM Normalized Delete Service Response command.
 | N_DELETE_RSP_BIT | DIMSE command control bit for N_DELETE_RSP.
 | N_DELETE_SUCCESS | N_DELETE_RSP success code.
 | N_DELETE_UNRECOGNIZED_OPERATION | N_DELETE_RSP failure code.
 | N_EVENT_CLASS_INSTANCE_CONFLICT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_DUPLICATE_INVOCATION | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_INVALID_ARGUMENT_VALUE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_MISTYPED_ARGUMENT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_ACTION_TYPE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_ARGUMENT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_EVENT_TYPE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_SOP_CLASS | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_SOP_INSTANCE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_PROCESSING_FAILURE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_REPORT_RQ | DICOM Normalized Report Service Request command.
 | N_EVENT_REPORT_RQ_BIT | DIMSE command control bit for N_EVENT_REPORT_RQ.
 | N_EVENT_REPORT_RSP | DICOM Normalized Report Service Response command.
 | N_EVENT_REPORT_RSP_BIT | DIMSE command control bit for N_EVENT_REPORT_RSP.
 | N_EVENT_RESOURCE_LIMITATION | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_SUCCESS | N_EVENT_REPORT_RSP Response success code.
 | N_EVENT_UNRECOGNIZED_OPERATION | N_EVENT_REPORT_RSP Response failure code.
 | N_GET_ATTRIBUTE_LIST_ERROR | N_GET_RSP Response warning code.
 | N_GET_CLASS_INSTANCE_CONFLICT | N_GET_RSP Response failure code.
 | N_GET_DUPLICATE_INVOCATION | N_GET_RSP Response failure code.
 | N_GET_MISTYPED_ARGUMENT | N_GET_RSP Response failure code.
 | N_GET_NO_SUCH_SOP_CLASS | N_GET_RSP Response failure code.
 | N_GET_NO_SUCH_SOP_INSTANCE | N_GET_RSP Response failure code.
 | N_GET_PROCESSING_FAILURE | N_GET_RSP Response failure code.
 | N_GET_RESOURCE_LIMITATION | N_GET_RSP Response failure code.
 | N_GET_RQ | DICOM Normalized Get Service Request command.
 | N_GET_RQ_BIT | DIMSE command control bit for N_GET_RQ.
 | N_GET_RSP | DICOM Normalized Get Service Response command.
 | N_GET_RSP_BIT | DIMSE command control bit for N_GET_RSP.
 | N_GET_SUCCESS | N_GET_RSP Response success code.
 | N_GET_UNRECOGNIZED_OPERATION | N_GET_RSP Response failure code.
 | N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED | N_GET_RSP Response warning code.
 | N_SET_ATTRIBUTE_LIST_ERROR | N_SET_RSP Response warning code.
 | N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE | N_SET_RSP Response warning code.
 | N_SET_CLASS_INSTANCE_CONFLICT | N_SET_RSP Response failure code.
 | N_SET_DUPLICATE_INVOCATION | N_SET_RSP Response failure code.
 | N_SET_FAILURE_COMBINED_LARGER_THAN_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_FAILURE_IMAGE_LARGER_THAN_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_INSUFFICIENT_PRINTER_MEMORY | Print Management Service Class N_SET_RSP failure code.
 | N_SET_INVALID_ATTRIBUTE_VALUE | N_SET_RSP Response failure code.
 | N_SET_INVALID_OBJECT_INSTANCE | N_SET_RSP Response failure code.
 | N_SET_MISSING_ATTRIBUTE_VALUE | N_SET_RSP Response failure code.
 | N_SET_MISTYPED_ARGUMENT | N_SET_RSP Response failure code.
 | N_SET_MORE_THAN_ONE_VOID_LUT_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_NO_SUCH_ATTRIBUTE | N_SET_RSP Response failure code.
 | N_SET_NO_SUCH_SOP_CLASS | N_SET_RSP Response failure code.
 | N_SET_NO_SUCH_SOP_INSTANCE | N_SET_RSP Response failure code.
 | N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED | Modality Performed Procedure Step N_SET_RSP failure code.
 | N_SET_PROCESSING_FAILURE | N_SET_RSP Response failure code.
 | N_SET_REFUSED_PPS_NOT_IN_PROGRESS | Modality GP Performed Procedure Step N_SET_RSP refused code.
 | N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE | N_SET_RSP Response warning code.
 | N_SET_RESOURCE_LIMITATION | N_SET_RSP Response failure code.
 | N_SET_RQ | DICOM Normalized Set Service Request command.
 | N_SET_RQ_BIT | DIMSE command control bit for N_SET_RQ.
 | N_SET_RSP | DICOM Normalized Set Service Response command.
 | N_SET_RSP_BIT | DIMSE command control bit for N_SET_RSP.
 | N_SET_SUCCESS | N_SET_RSP Response success code.
 | N_SET_UNRECOGNIZED_OPERATION | N_SET_RSP Response failure code.
 | N_SET_WARNING_IMAGE_CROPPED_TO_FIT | Print Management Service Class N_SET_RSP warning code.
 | N_SET_WARNING_IMAGE_DECIMATED_TO_FIT | Print Management Service Class N_SET_RSP warning code.
 | NULL_COMMAND | Null DIMSE command representing an undefined command.
 | NUMBER_OF_COMMANDS | The total number of DIMSE commands.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running.

See Also

MCdimseService Class


MCdimseService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService Constructor
MCdimseService Class See Also Send Feedback
Initializes a new instance of this class for an association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCdimseService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCdimseService Class
MCdimseService Members


MCdimseService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService Fields
MCdimseService Class See Also Send Feedback

The MCdimseService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object.
 | C_CANCEL_FIND_RQ | Cancel DICOM Composite Find Service Request command.
 | C_CANCEL_FIND_RQ_BIT | DIMSE command control bit for C_CANCEL_FIND_RQ.
 | C_CANCEL_GET_RQ | Cancel DICOM Composite Get Service Request command.
 | C_CANCEL_GET_RQ_BIT | DIMSE command control bit for C_CANCEL_GET_RQ.
 | C_CANCEL_MOVE_RQ | Cancel DICOM Composite Move Service Request command.
 | C_CANCEL_MOVE_RQ_BIT | DIMSE command control bit for C_CANCEL_MOVE_RQ.
 | C_CANCEL_RQ | Cancel DICOM Composite Service Request command.
 | C_CANCEL_RQ_BIT | DIMSE command control bit for C_CANCEL_RQ.
 | C_ECHO_RQ | DICOM Verification Service Request command.
 | C_ECHO_RQ_BIT | DIMSE command control bit for C_ECHO_RQ.
 | C_ECHO_RSP | DICOM Verification Service Response command.
 | C_ECHO_RSP_BIT | DIMSE command control bit for C_ECHO_RSP.
 | C_ECHO_SUCCESS | Verification Service Class C_ECHO_RSP success code.
 | C_FIND_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_FIND_RSP code for cancelled request status.
 | C_FIND_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_FIND_RSP code for "INVALID DATASET" failure status.
 | C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND | Query/Retrieve Service Class C_FIND_RSP code for "MORE THAN ONE MATCH FOUND" failure status.
 | C_FIND_FAILURE_REFUSED_NO_RESOURCES | Query/Retrieve Service Class C_FIND_RSP code for "NO RESOURCES" failure status.
 | C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_FIND_RSP code for "RPI UNABLE TO PROCESS" failure status.
 | C_FIND_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO PROCESS" failure status.
 | C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE | Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO SUPPORT REQUESTED TEMPLATE" failure status.
 | C_FIND_PENDING | Query/Retrieve Service Class C_FIND_RSP code for pending result.
 | C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT | Query/Retrieve Service Class C_FIND_RSP code for pending with no optional key support.
 | C_FIND_RQ | DICOM Composite Find Service Request command.
 | C_FIND_RQ_BIT | DIMSE command control bit for C_FIND_RQ.
 | C_FIND_RSP | DICOM Composite Find Service Response command.
 | C_FIND_RSP_BIT | DIMSE command control bit for C_FIND_RSP.
 | C_FIND_SUCCESS | Query/Retrieve Service Class C_FIND_RSP success code.
 | C_GET_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_GET_RSP code for cancelled request status.
 | C_GET_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_GET_RSP code for "INVALID DATASET" failure code.
 | C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES | Query/Retrieve Service Class C_GET_RSP code for "CAN'T CALCULATE MATCHES" failure code.
 | C_GET_FAILURE_REFUSED_CANT_PERFORM | Query/Retrieve Service Class C_GET_RSP code for "CAN'T PERFORM" failure code.
 | C_GET_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_GET_RSP code for "UNABLE TO PROCESS" failure code.
 | C_GET_PENDING_MORE_SUB_OPERATIONS | Query/Retrieve Service Class C_GET_RSP pending code.
 | C_GET_RQ | DICOM Composite Get Service Request command.
 | C_GET_RQ_BIT | DIMSE command control bit for C_GET_RQ.
 | C_GET_RSP | DICOM Composite Get Service Response command.
 | C_GET_RSP_BIT | DIMSE command control bit for C_GET_RSP.
 | C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS | Query/Retrieve Service Class C_GET_RSP success code.
 | C_GET_WARNING_SOME_FAILURES_WARNINGS | Query/Retrieve Service Class C_GET_RSP warning code.
 | C_MOVE_CANCEL_REQUEST_RECEIVED | Query/Retrieve Service Class C_MOVE_RSP code for cancelled request status.
 | C_MOVE_FAILURE_INVALID_DATASET | Query/Retrieve Service Class C_MOVE_RSP code for "INVALID DATASET" failure code.
 | C_MOVE_FAILURE_REFUSED_CANT_CALCULATE | Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T CALCULATE" failure code.
 | C_MOVE_FAILURE_REFUSED_CANT_PERFORM | Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T PERFORM" failure code.
 | C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN | Query/Retrieve Service Class C_MOVE_RSP code for "DESTINATION UNKNOWN" failure code.
 | C_MOVE_FAILURE_UNABLE_TO_PROCESS | Query/Retrieve Service Class C_MOVE_RSP code for "UNABLE TO PROCESS" failure code.
 | C_MOVE_PENDING_MORE_SUB_OPERATIONS | Query/Retrieve Service Class C_MOVE_RSP pending result code.
 | C_MOVE_RQ | DICOM Composite Move Service Request command.
 | C_MOVE_RQ_BIT | DIMSE command control bit for C_MOVE_RQ.
 | C_MOVE_RSP | DICOM Composite Move Service Response command.
 | C_MOVE_RSP_BIT | DIMSE command control bit for C_MOVE_RSP.
 | C_MOVE_SUCCESS_NO_FAILURES | Query/Retrieve Service Class C_MOVE_RSP success code.
 | C_MOVE_WARNING_ONE_OR_MORE_FAILURES | Query/Retrieve Service Class C_MOVE_RSP warning code.
 | C_STORE_FAILED_OPERATION | Study Content NotificationService Class C_STORE_RSP code for "FAILED OPERATION" status.
 | C_STORE_FAILURE_CANNOT_UNDERSTAND | Storage Service Class C_STORE_RSP Code for "CANNOT UNDERSTAND" failure status.
 | C_STORE_FAILURE_INVALID_DATASET | Storage Service Class C_STORE_RSP Code for "NVALID DATASET" failure status.
 | C_STORE_FAILURE_PROCESSING_FAILURE | Storage Service Class C_STORE_RSP Code for "PROCESSING FAILURE" failure status.
 | C_STORE_FAILURE_REFUSED_NO_RESOURCES | Storage Service Class C_STORE_RSP Code for "NO RESOURCES" failure status.
 | C_STORE_RQ | DICOM Composite Store Service Request command.
 | C_STORE_RQ_BIT | DIMSE command control bit for C_STORE_RQ.
 | C_STORE_RSP | DICOM Composite Store Service Response command.
 | C_STORE_RSP_BIT | DIMSE command control bit for C_STORE_RSP.
 | C_STORE_SUCCESS | Storage Service Class C_STORE_RSP Code for success status.
 | C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS | Study Content NotificationService Class C_STORE_RSP code for "COMPLETE STUDY EXISTS" status.
 | C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS | Study Content NotificationService Class C_STORE_RSP code for "PARTIAL STUDY EXISTS" status.
 | C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST | Study Content NotificationService Class C_STORE_RSP code for "STUDY DOES NOT EXIST" status.
 | C_STORE_SUCCESS_UNKNOWN_EXISTENCE | Study Content NotificationService Class C_STORE_RSP code for "UNKNOWN EXISTENCE" status.
 | C_STORE_WARNING_ELEMENT_COERCION | Storage Service Class C_STORE_RSP Code for "ELEMENT COERCION" warning status.
 | C_STORE_WARNING_ELEMENTS_DISCARDED | Storage Service Class C_STORE_RSP Code for "ELEMENTS DISCARDED" warning status.
 | C_STORE_WARNING_INVALID_DATASET | Storage Service Class C_STORE_RSP Code for "INVALID DATASET" warning status.
 | HIGH_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a high priority DIMSE message.
 | LOW_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a low priority DIMSE message.
 | MEDIUM_PRIORITY_MESSAGE | Defined value for Priority attribute (0000,0700) in a medium priority DIMSE message.
 | N_ACTION_CANCELLATION_DENIED | Media Creation Management failure code.
 | N_ACTION_CLASS_INSTANCE_CONFLICT | N_ACTION_RSP Response failure code.
 | N_ACTION_DUPLICATE_INVOCATION | N_ACTION_RSP Response failure code.
 | N_ACTION_DUPLICATE_TRANSACTION_UID | N_ACTION_RSP Response failure code.
 | N_ACTION_FAILURE_ANNOTATION_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_BOX_PRINT_Q_FULL | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_EMPTY_PAGE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_IMAGE_POS_COLLISION | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_INSUFFICIENT_MEMORY | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_JOB_IN_PROCESS | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_IMAGE_AT_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRES_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED | Print Queue Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_RETRIEVING_IMAGE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_RETRIEVING_STORED_PRINT | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_SESSION_PRINT_Q_FULL | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX | Print Management Service Class N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE | Pull Print Request N_ACTION_RSP failure code.
 | N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE | Pull Print Request N_ACTION_RSP failure code (correct spelling).
 | N_ACTION_INVALID_ARGUMENT_VALUE | N_ACTION_RSP Response failure code.
 | N_ACTION_MEDIA_CREATION_RQ_COMPLETED | Media Creation Management failure code.
 | N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS | Media Creation Management failure code.
 | N_ACTION_MEMORY_ALLOCATION_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_MISTYPED_ARGUMENT | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_ACTION_TYPE | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_ARGUMENT | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_SOP_CLASS | N_ACTION_RSP Response failure code.
 | N_ACTION_NO_SUCH_SOP_INSTANCE | N_ACTION_RSP Response failure code.
 | N_ACTION_OPERATOR_NOT_AUTHORIZED | Substance Administration Operator not authorized to add entry to Medication Administration Record failure
 | N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED | Substance Administration Patient cannot be identified from Patient ID or Admission ID failure
 | N_ACTION_PROCESSING_FAILURE | N_ACTION_RSP Response failure code.
 | N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED | N_ACTION_RSP Response failure code.
 | N_ACTION_REFUSED_ALREADY_IN_PROGRESS | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_REFUSED_WRONG_TRANSACTION_ID | Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.
 | N_ACTION_RESOURCE_LIMITATION | N_ACTION_RSP Response failure code.
 | N_ACTION_RQ | DICOM Normalized Action Service Request command.
 | N_ACTION_RQ_BIT | DIMSE command control bit for N_ACTION_RQ.
 | N_ACTION_RSP | DICOM Normalized Action Service Response command.
 | N_ACTION_RSP_BIT | DIMSE command control bit for N_ACTION_RSP.
 | N_ACTION_SUCCESS | N_ACTION_RSP Response success code.
 | N_ACTION_UNRECOGNIZED_OPERATION | N_ACTION_RSP Response failure code.
 | N_ACTION_UPDATE_OF_MAR_FAILED | Substance Update of Medication Administration Record failed
 | N_ACTION_WARNING_ANNOTATION_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_BOX_EMPTY_PAGE | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_NO_COLLATION_SUPPORT | Print Management Service Class N_ACTION_RSP warning code.
 | N_ACTION_WARNING_PRES_LUT_NOT_SUPP | Pull Print Request N_ACTION_RSP warning code.
 | N_ACTION_WARNING_SESSION_EMPTY_PAGE | Print Management Service Class N_ACTION_RSP warning code.
 | N_CREATE_ATTRIBUTE_LIST_ERROR | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_CLASS_INSTANCE_CONFLICT | N_CREATE_RSP Response failure code.
 | N_CREATE_DUPLICATE_INVOCATION | N_CREATE_RSP Response failure code.
 | N_CREATE_DUPLICATE_SOP_INSTANCE | N_CREATE_RSP Response failure code.
 | N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING | Basic Print Image Overlay Box N_CREATE_RSP failure code.
 | N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV | Media Creation failure codes.
 | N_CREATE_INVALID_ATTRIBUTE_VALUE | N_CREATE_RSP Response failure code.
 | N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_MISSING_ATTRIBUTE | N_CREATE_RSP Response failure code.
 | N_CREATE_MISSING_ATTRIBUTE_VALUE | N_CREATE_RSP Response failure code.
 | N_CREATE_MISTYPED_ARGUMENT | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE | Print Management Service Class N_CREATE_RSP failure code.
 | N_CREATE_NO_SUCH_ATTRIBUTE | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_SUCH_SOP_CLASS | N_CREATE_RSP Response failure code.
 | N_CREATE_NO_SUCH_SOP_INSTANCE | N_CREATE_RSP Response failure code.
 | N_CREATE_PROCESSING_FAILURE | N_CREATE_RSP Response failure code.
 | N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS | Modify GP Performed Procedure Step N_CREATE_RSP refused code.
 | N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID | Modify GP Performed Procedure Step N_CREATE_RSP refused code.
 | N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE | Print Management Service Class N_CREATE_RSP warning code.
 | N_CREATE_RESOURCE_LIMITATION | N_CREATE_RSP Response failure code.
 | N_CREATE_RQ | DICOM Normalized Create Service Request command.
 | N_CREATE_RQ_BIT | DIMSE command control bit for N_CREATE_RQ.
 | N_CREATE_RSP | DICOM Normalized Create Service Response command.
 | N_CREATE_RSP_BIT | DIMSE command control bit for N_CREATE_RSP.
 | N_CREATE_SUCCESS | N_CREATE_RSP Response success code.
 | N_CREATE_TEMPORARILY_NO_MEMORY | Print Management Service Class N_CREATE_RSP failure code.
 | N_CREATE_UNRECOGNIZED_OPERATION | N_CREATE_RSP Response failure code.
 | N_DELETE_CLASS_INSTANCE_CONFLICT | N_DELETE_RSP failure code.
 | N_DELETE_DUPLICATE_INVOCATION | N_DELETE_RSP failure code.
 | N_DELETE_MISTYPED_ARGUMENT | N_DELETE_RSP failure code.
 | N_DELETE_NO_SUCH_SOP_CLASS | N_DELETE_RSP failure code.
 | N_DELETE_NO_SUCH_SOP_INSTANCE | N_DELETE_RSP failure code.
 | N_DELETE_PROCESSING_FAILURE | N_DELETE_RSP failure code.
 | N_DELETE_RESOURCE_LIMITATION | N_DELETE_RSP failure code.
 | N_DELETE_RQ | DICOM Normalized Delete Service Request command.
 | N_DELETE_RQ_BIT | DIMSE command control bit for N_DELETE_RQ.
 | N_DELETE_RSP | DICOM Normalized Delete Service Response command.
 | N_DELETE_RSP_BIT | DIMSE command control bit for N_DELETE_RSP.
 | N_DELETE_SUCCESS | N_DELETE_RSP success code.
 | N_DELETE_UNRECOGNIZED_OPERATION | N_DELETE_RSP failure code.
 | N_EVENT_CLASS_INSTANCE_CONFLICT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_DUPLICATE_INVOCATION | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_INVALID_ARGUMENT_VALUE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_MISTYPED_ARGUMENT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_ACTION_TYPE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_ARGUMENT | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_EVENT_TYPE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_SOP_CLASS | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_NO_SUCH_SOP_INSTANCE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_PROCESSING_FAILURE | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_REPORT_RQ | DICOM Normalized Report Service Request command.
 | N_EVENT_REPORT_RQ_BIT | DIMSE command control bit for N_EVENT_REPORT_RQ.
 | N_EVENT_REPORT_RSP | DICOM Normalized Report Service Response command.
 | N_EVENT_REPORT_RSP_BIT | DIMSE command control bit for N_EVENT_REPORT_RSP.
 | N_EVENT_RESOURCE_LIMITATION | N_EVENT_REPORT_RSP Response failure code.
 | N_EVENT_SUCCESS | N_EVENT_REPORT_RSP Response success code.
 | N_EVENT_UNRECOGNIZED_OPERATION | N_EVENT_REPORT_RSP Response failure code.
 | N_GET_ATTRIBUTE_LIST_ERROR | N_GET_RSP Response warning code.
 | N_GET_CLASS_INSTANCE_CONFLICT | N_GET_RSP Response failure code.
 | N_GET_DUPLICATE_INVOCATION | N_GET_RSP Response failure code.
 | N_GET_MISTYPED_ARGUMENT | N_GET_RSP Response failure code.
 | N_GET_NO_SUCH_SOP_CLASS | N_GET_RSP Response failure code.
 | N_GET_NO_SUCH_SOP_INSTANCE | N_GET_RSP Response failure code.
 | N_GET_PROCESSING_FAILURE | N_GET_RSP Response failure code.
 | N_GET_RESOURCE_LIMITATION | N_GET_RSP Response failure code.
 | N_GET_RQ | DICOM Normalized Get Service Request command.
 | N_GET_RQ_BIT | DIMSE command control bit for N_GET_RQ.
 | N_GET_RSP | DICOM Normalized Get Service Response command.
 | N_GET_RSP_BIT | DIMSE command control bit for N_GET_RSP.
 | N_GET_SUCCESS | N_GET_RSP Response success code.
 | N_GET_UNRECOGNIZED_OPERATION | N_GET_RSP Response failure code.
 | N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED | N_GET_RSP Response warning code.
 | N_SET_ATTRIBUTE_LIST_ERROR | N_SET_RSP Response warning code.
 | N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE | N_SET_RSP Response warning code.
 | N_SET_CLASS_INSTANCE_CONFLICT | N_SET_RSP Response failure code.
 | N_SET_DUPLICATE_INVOCATION | N_SET_RSP Response failure code.
 | N_SET_FAILURE_COMBINED_LARGER_THAN_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_FAILURE_IMAGE_LARGER_THAN_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_INSUFFICIENT_PRINTER_MEMORY | Print Management Service Class N_SET_RSP failure code.
 | N_SET_INVALID_ATTRIBUTE_VALUE | N_SET_RSP Response failure code.
 | N_SET_INVALID_OBJECT_INSTANCE | N_SET_RSP Response failure code.
 | N_SET_MISSING_ATTRIBUTE_VALUE | N_SET_RSP Response failure code.
 | N_SET_MISTYPED_ARGUMENT | N_SET_RSP Response failure code.
 | N_SET_MORE_THAN_ONE_VOID_LUT_BOX | Print Management Service Class N_SET_RSP failure code.
 | N_SET_NO_SUCH_ATTRIBUTE | N_SET_RSP Response failure code.
 | N_SET_NO_SUCH_SOP_CLASS | N_SET_RSP Response failure code.
 | N_SET_NO_SUCH_SOP_INSTANCE | N_SET_RSP Response failure code.
 | N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED | Modality Performed Procedure Step N_SET_RSP failure code.
 | N_SET_PROCESSING_FAILURE | N_SET_RSP Response failure code.
 | N_SET_REFUSED_PPS_NOT_IN_PROGRESS | Modality GP Performed Procedure Step N_SET_RSP refused code.
 | N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE | N_SET_RSP Response warning code.
 | N_SET_RESOURCE_LIMITATION | N_SET_RSP Response failure code.
 | N_SET_RQ | DICOM Normalized Set Service Request command.
 | N_SET_RQ_BIT | DIMSE command control bit for N_SET_RQ.
 | N_SET_RSP | DICOM Normalized Set Service Response command.
 | N_SET_RSP_BIT | DIMSE command control bit for N_SET_RSP.
 | N_SET_SUCCESS | N_SET_RSP Response success code.
 | N_SET_UNRECOGNIZED_OPERATION | N_SET_RSP Response failure code.
 | N_SET_WARNING_IMAGE_CROPPED_TO_FIT | Print Management Service Class N_SET_RSP warning code.
 | N_SET_WARNING_IMAGE_DECIMATED_TO_FIT | Print Management Service Class N_SET_RSP warning code.
 | NULL_COMMAND | Null DIMSE command representing an undefined command.
 | NUMBER_OF_COMMANDS | The total number of DIMSE commands.

See Also

MCdimseService Class


assoc Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..assoc Field
MCdimseService Class See Also Send Feedback
The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected internal MCassociation assoc
Visual Basic
Protected Friend assoc As MCassociation
Visual C++
protected public:
MCassociation^ assoc

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_FIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_FIND_RQ Field
MCdimseService Class See Also Send Feedback
Cancel DICOM Composite Find Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_CANCEL_FIND_RQ
Visual Basic
Public Shared ReadOnly C_CANCEL_FIND_RQ As UShort
Visual C++
public:
static initonly unsigned short C_CANCEL_FIND_RQ

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_FIND_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_FIND_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_CANCEL_FIND_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_CANCEL_FIND_RQ_BIT
Visual Basic
Public Shared ReadOnly C_CANCEL_FIND_RQ_BIT As Integer
Visual C++
public:
static initonly int C_CANCEL_FIND_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_GET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_GET_RQ Field
MCdimseService Class See Also Send Feedback
Cancel DICOM Composite Get Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_CANCEL_GET_RQ
Visual Basic
Public Shared ReadOnly C_CANCEL_GET_RQ As UShort
Visual C++
public:
static initonly unsigned short C_CANCEL_GET_RQ

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_GET_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_GET_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_CANCEL_GET_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_CANCEL_GET_RQ_BIT
Visual Basic
Public Shared ReadOnly C_CANCEL_GET_RQ_BIT As Integer
Visual C++
public:
static initonly int C_CANCEL_GET_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_MOVE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_MOVE_RQ Field
MCdimseService Class See Also Send Feedback
Cancel DICOM Composite Move Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_CANCEL_MOVE_RQ
Visual Basic
Public Shared ReadOnly C_CANCEL_MOVE_RQ As UShort
Visual C++
public:
static initonly unsigned short C_CANCEL_MOVE_RQ

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_MOVE_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_MOVE_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_CANCEL_MOVE_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_CANCEL_MOVE_RQ_BIT
Visual Basic
Public Shared ReadOnly C_CANCEL_MOVE_RQ_BIT As Integer
Visual C++
public:
static initonly int C_CANCEL_MOVE_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_RQ Field
MCdimseService Class See Also Send Feedback
Cancel DICOM Composite Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_CANCEL_RQ
Visual Basic
Public Shared ReadOnly C_CANCEL_RQ As UShort
Visual C++
public:
static initonly unsigned short C_CANCEL_RQ

See Also

MCdimseService Class
MCdimseService Members


C_CANCEL_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_CANCEL_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_CANCEL_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_CANCEL_RQ_BIT
Visual Basic
Public Shared ReadOnly C_CANCEL_RQ_BIT As Integer
Visual C++
public:
static initonly int C_CANCEL_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_ECHO_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_ECHO_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Verification Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_ECHO_RQ
Visual Basic
Public Shared ReadOnly C_ECHO_RQ As UShort
Visual C++
public:
static initonly unsigned short C_ECHO_RQ

See Also

MCdimseService Class
MCdimseService Members


C_ECHO_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_ECHO_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_ECHO_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_ECHO_RQ_BIT
Visual Basic
Public Shared ReadOnly C_ECHO_RQ_BIT As Integer
Visual C++
public:
static initonly int C_ECHO_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_ECHO_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_ECHO_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Verification Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_ECHO_RSP
Visual Basic
Public Shared ReadOnly C_ECHO_RSP As UShort
Visual C++
public:
static initonly unsigned short C_ECHO_RSP

See Also

MCdimseService Class
MCdimseService Members


C_ECHO_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_ECHO_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_ECHO_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_ECHO_RSP_BIT
Visual Basic
Public Shared ReadOnly C_ECHO_RSP_BIT As Integer
Visual C++
public:
static initonly int C_ECHO_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


C_ECHO_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_ECHO_SUCCESS Field
MCdimseService Class See Also Send Feedback
Verification Service Class C_ECHO_RSP success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_ECHO_SUCCESS
Visual Basic
Public Const C_ECHO_SUCCESS As UShort
Visual C++
public:
literal unsigned short C_ECHO_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


C_FIND_CANCEL_REQUEST_RECEIVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_CANCEL_REQUEST_RECEIVED Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for cancelled request status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_CANCEL_REQUEST_RECEIVED
Visual Basic
Public Const C_FIND_CANCEL_REQUEST_RECEIVED As UShort
Visual C++
public:
literal unsigned short C_FIND_CANCEL_REQUEST_RECEIVED

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_INVALID_DATASET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_INVALID_DATASET Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "INVALID DATASET" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_INVALID_DATASET
Visual Basic
Public Const C_FIND_FAILURE_INVALID_DATASET As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_INVALID_DATASET

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "MORE THAN ONE MATCH FOUND" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND
Visual Basic
Public Const C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_MORE_THAN_ONE_MATCH_FOUND

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_REFUSED_NO_RESOURCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_REFUSED_NO_RESOURCES Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "NO RESOURCES" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_REFUSED_NO_RESOURCES
Visual Basic
Public Const C_FIND_FAILURE_REFUSED_NO_RESOURCES As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_REFUSED_NO_RESOURCES

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "RPI UNABLE TO PROCESS" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS
Visual Basic
Public Const C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_RPI_UNABLE_TO_PROCESS

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_UNABLE_TO_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_UNABLE_TO_PROCESS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO PROCESS" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_UNABLE_TO_PROCESS
Visual Basic
Public Const C_FIND_FAILURE_UNABLE_TO_PROCESS As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_UNABLE_TO_PROCESS

See Also

MCdimseService Class
MCdimseService Members


C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for "UNABLE TO SUPPORT REQUESTED TEMPLATE" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE
Visual Basic
Public Const C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE As UShort
Visual C++
public:
literal unsigned short C_FIND_FAILURE_UNABLE_TO_SUPPORT_REQUESTED_TEMPLATE

See Also

MCdimseService Class
MCdimseService Members


C_FIND_PENDING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_PENDING Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for pending result.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_PENDING
Visual Basic
Public Const C_FIND_PENDING As UShort
Visual C++
public:
literal unsigned short C_FIND_PENDING

See Also

MCdimseService Class
MCdimseService Members


C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP code for pending with no optional key support.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT
Visual Basic
Public Const C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT As UShort
Visual C++
public:
literal unsigned short C_FIND_PENDING_NO_OPTIONAL_KEY_SUPPORT

See Also

MCdimseService Class
MCdimseService Members


C_FIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Composite Find Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_FIND_RQ
Visual Basic
Public Shared ReadOnly C_FIND_RQ As UShort
Visual C++
public:
static initonly unsigned short C_FIND_RQ

See Also

MCdimseService Class
MCdimseService Members


C_FIND_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_FIND_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_FIND_RQ_BIT
Visual Basic
Public Shared ReadOnly C_FIND_RQ_BIT As Integer
Visual C++
public:
static initonly int C_FIND_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_FIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Composite Find Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_FIND_RSP
Visual Basic
Public Shared ReadOnly C_FIND_RSP As UShort
Visual C++
public:
static initonly unsigned short C_FIND_RSP

See Also

MCdimseService Class
MCdimseService Members


C_FIND_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_FIND_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_FIND_RSP_BIT
Visual Basic
Public Shared ReadOnly C_FIND_RSP_BIT As Integer
Visual C++
public:
static initonly int C_FIND_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


C_FIND_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_FIND_SUCCESS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_FIND_RSP success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_FIND_SUCCESS
Visual Basic
Public Const C_FIND_SUCCESS As UShort
Visual C++
public:
literal unsigned short C_FIND_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


C_GET_CANCEL_REQUEST_RECEIVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_CANCEL_REQUEST_RECEIVED Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP code for cancelled request status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_CANCEL_REQUEST_RECEIVED
Visual Basic
Public Const C_GET_CANCEL_REQUEST_RECEIVED As UShort
Visual C++
public:
literal unsigned short C_GET_CANCEL_REQUEST_RECEIVED

See Also

MCdimseService Class
MCdimseService Members


C_GET_FAILURE_INVALID_DATASET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_FAILURE_INVALID_DATASET Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP code for "INVALID DATASET" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_FAILURE_INVALID_DATASET
Visual Basic
Public Const C_GET_FAILURE_INVALID_DATASET As UShort
Visual C++
public:
literal unsigned short C_GET_FAILURE_INVALID_DATASET

See Also

MCdimseService Class
MCdimseService Members


C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP code for "CAN'T CALCULATE MATCHES" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES
Visual Basic
Public Const C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES As UShort
Visual C++
public:
literal unsigned short C_GET_FAILURE_REFUSED_CANT_CALC_MATCHES

See Also

MCdimseService Class
MCdimseService Members


C_GET_FAILURE_REFUSED_CANT_PERFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_FAILURE_REFUSED_CANT_PERFORM Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP code for "CAN'T PERFORM" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_FAILURE_REFUSED_CANT_PERFORM
Visual Basic
Public Const C_GET_FAILURE_REFUSED_CANT_PERFORM As UShort
Visual C++
public:
literal unsigned short C_GET_FAILURE_REFUSED_CANT_PERFORM

See Also

MCdimseService Class
MCdimseService Members


C_GET_FAILURE_UNABLE_TO_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_FAILURE_UNABLE_TO_PROCESS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP code for "UNABLE TO PROCESS" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_FAILURE_UNABLE_TO_PROCESS
Visual Basic
Public Const C_GET_FAILURE_UNABLE_TO_PROCESS As UShort
Visual C++
public:
literal unsigned short C_GET_FAILURE_UNABLE_TO_PROCESS

See Also

MCdimseService Class
MCdimseService Members


C_GET_PENDING_MORE_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_PENDING_MORE_SUB_OPERATIONS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP pending code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_PENDING_MORE_SUB_OPERATIONS
Visual Basic
Public Const C_GET_PENDING_MORE_SUB_OPERATIONS As UShort
Visual C++
public:
literal unsigned short C_GET_PENDING_MORE_SUB_OPERATIONS

See Also

MCdimseService Class
MCdimseService Members


C_GET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Composite Get Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_GET_RQ
Visual Basic
Public Shared ReadOnly C_GET_RQ As UShort
Visual C++
public:
static initonly unsigned short C_GET_RQ

See Also

MCdimseService Class
MCdimseService Members


C_GET_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_GET_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_GET_RQ_BIT
Visual Basic
Public Shared ReadOnly C_GET_RQ_BIT As Integer
Visual C++
public:
static initonly int C_GET_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_GET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Composite Get Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_GET_RSP
Visual Basic
Public Shared ReadOnly C_GET_RSP As UShort
Visual C++
public:
static initonly unsigned short C_GET_RSP

See Also

MCdimseService Class
MCdimseService Members


C_GET_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_GET_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_GET_RSP_BIT
Visual Basic
Public Shared ReadOnly C_GET_RSP_BIT As Integer
Visual C++
public:
static initonly int C_GET_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS
Visual Basic
Public Const C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS As UShort
Visual C++
public:
literal unsigned short C_GET_SUCCESS_NO_FAILURES_OR_WARNINGS

See Also

MCdimseService Class
MCdimseService Members


C_GET_WARNING_SOME_FAILURES_WARNINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_GET_WARNING_SOME_FAILURES_WARNINGS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_GET_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_GET_WARNING_SOME_FAILURES_WARNINGS
Visual Basic
Public Const C_GET_WARNING_SOME_FAILURES_WARNINGS As UShort
Visual C++
public:
literal unsigned short C_GET_WARNING_SOME_FAILURES_WARNINGS

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_CANCEL_REQUEST_RECEIVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_CANCEL_REQUEST_RECEIVED Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for cancelled request status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_CANCEL_REQUEST_RECEIVED
Visual Basic
Public Const C_MOVE_CANCEL_REQUEST_RECEIVED As UShort
Visual C++
public:
literal unsigned short C_MOVE_CANCEL_REQUEST_RECEIVED

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_FAILURE_INVALID_DATASET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_FAILURE_INVALID_DATASET Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for "INVALID DATASET" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_FAILURE_INVALID_DATASET
Visual Basic
Public Const C_MOVE_FAILURE_INVALID_DATASET As UShort
Visual C++
public:
literal unsigned short C_MOVE_FAILURE_INVALID_DATASET

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_FAILURE_REFUSED_CANT_CALCULATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_FAILURE_REFUSED_CANT_CALCULATE Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T CALCULATE" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_FAILURE_REFUSED_CANT_CALCULATE
Visual Basic
Public Const C_MOVE_FAILURE_REFUSED_CANT_CALCULATE As UShort
Visual C++
public:
literal unsigned short C_MOVE_FAILURE_REFUSED_CANT_CALCULATE

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_FAILURE_REFUSED_CANT_PERFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_FAILURE_REFUSED_CANT_PERFORM Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for "CAN'T PERFORM" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_FAILURE_REFUSED_CANT_PERFORM
Visual Basic
Public Const C_MOVE_FAILURE_REFUSED_CANT_PERFORM As UShort
Visual C++
public:
literal unsigned short C_MOVE_FAILURE_REFUSED_CANT_PERFORM

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for "DESTINATION UNKNOWN" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN
Visual Basic
Public Const C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN As UShort
Visual C++
public:
literal unsigned short C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_FAILURE_UNABLE_TO_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_FAILURE_UNABLE_TO_PROCESS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP code for "UNABLE TO PROCESS" failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_FAILURE_UNABLE_TO_PROCESS
Visual Basic
Public Const C_MOVE_FAILURE_UNABLE_TO_PROCESS As UShort
Visual C++
public:
literal unsigned short C_MOVE_FAILURE_UNABLE_TO_PROCESS

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_PENDING_MORE_SUB_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_PENDING_MORE_SUB_OPERATIONS Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP pending result code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_PENDING_MORE_SUB_OPERATIONS
Visual Basic
Public Const C_MOVE_PENDING_MORE_SUB_OPERATIONS As UShort
Visual C++
public:
literal unsigned short C_MOVE_PENDING_MORE_SUB_OPERATIONS

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Composite Move Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_MOVE_RQ
Visual Basic
Public Shared ReadOnly C_MOVE_RQ As UShort
Visual C++
public:
static initonly unsigned short C_MOVE_RQ

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_MOVE_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_MOVE_RQ_BIT
Visual Basic
Public Shared ReadOnly C_MOVE_RQ_BIT As Integer
Visual C++
public:
static initonly int C_MOVE_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Composite Move Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_MOVE_RSP
Visual Basic
Public Shared ReadOnly C_MOVE_RSP As UShort
Visual C++
public:
static initonly unsigned short C_MOVE_RSP

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_MOVE_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_MOVE_RSP_BIT
Visual Basic
Public Shared ReadOnly C_MOVE_RSP_BIT As Integer
Visual C++
public:
static initonly int C_MOVE_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_SUCCESS_NO_FAILURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_SUCCESS_NO_FAILURES Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_SUCCESS_NO_FAILURES
Visual Basic
Public Const C_MOVE_SUCCESS_NO_FAILURES As UShort
Visual C++
public:
literal unsigned short C_MOVE_SUCCESS_NO_FAILURES

See Also

MCdimseService Class
MCdimseService Members


C_MOVE_WARNING_ONE_OR_MORE_FAILURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_MOVE_WARNING_ONE_OR_MORE_FAILURES Field
MCdimseService Class See Also Send Feedback
Query/Retrieve Service Class C_MOVE_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_MOVE_WARNING_ONE_OR_MORE_FAILURES
Visual Basic
Public Const C_MOVE_WARNING_ONE_OR_MORE_FAILURES As UShort
Visual C++
public:
literal unsigned short C_MOVE_WARNING_ONE_OR_MORE_FAILURES

See Also

MCdimseService Class
MCdimseService Members


C_STORE_FAILED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_FAILED_OPERATION Field
MCdimseService Class See Also Send Feedback
Study Content NotificationService Class C_STORE_RSP code for "FAILED OPERATION" status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_FAILED_OPERATION
Visual Basic
Public Const C_STORE_FAILED_OPERATION As UShort
Visual C++
public:
literal unsigned short C_STORE_FAILED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


C_STORE_FAILURE_CANNOT_UNDERSTAND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_FAILURE_CANNOT_UNDERSTAND Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "CANNOT UNDERSTAND" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_FAILURE_CANNOT_UNDERSTAND
Visual Basic
Public Const C_STORE_FAILURE_CANNOT_UNDERSTAND As UShort
Visual C++
public:
literal unsigned short C_STORE_FAILURE_CANNOT_UNDERSTAND

See Also

MCdimseService Class
MCdimseService Members


C_STORE_FAILURE_INVALID_DATASET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_FAILURE_INVALID_DATASET Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "NVALID DATASET" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_FAILURE_INVALID_DATASET
Visual Basic
Public Const C_STORE_FAILURE_INVALID_DATASET As UShort
Visual C++
public:
literal unsigned short C_STORE_FAILURE_INVALID_DATASET

See Also

MCdimseService Class
MCdimseService Members


C_STORE_FAILURE_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_FAILURE_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "PROCESSING FAILURE" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_FAILURE_PROCESSING_FAILURE
Visual Basic
Public Const C_STORE_FAILURE_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short C_STORE_FAILURE_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


C_STORE_FAILURE_REFUSED_NO_RESOURCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_FAILURE_REFUSED_NO_RESOURCES Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "NO RESOURCES" failure status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_FAILURE_REFUSED_NO_RESOURCES
Visual Basic
Public Const C_STORE_FAILURE_REFUSED_NO_RESOURCES As UShort
Visual C++
public:
literal unsigned short C_STORE_FAILURE_REFUSED_NO_RESOURCES

See Also

MCdimseService Class
MCdimseService Members


C_STORE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Composite Store Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_STORE_RQ
Visual Basic
Public Shared ReadOnly C_STORE_RQ As UShort
Visual C++
public:
static initonly unsigned short C_STORE_RQ

See Also

MCdimseService Class
MCdimseService Members


C_STORE_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_STORE_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_STORE_RQ_BIT
Visual Basic
Public Shared ReadOnly C_STORE_RQ_BIT As Integer
Visual C++
public:
static initonly int C_STORE_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


C_STORE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Composite Store Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort C_STORE_RSP
Visual Basic
Public Shared ReadOnly C_STORE_RSP As UShort
Visual C++
public:
static initonly unsigned short C_STORE_RSP

See Also

MCdimseService Class
MCdimseService Members


C_STORE_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for C_STORE_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int C_STORE_RSP_BIT
Visual Basic
Public Shared ReadOnly C_STORE_RSP_BIT As Integer
Visual C++
public:
static initonly int C_STORE_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


C_STORE_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_SUCCESS Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for success status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_SUCCESS
Visual Basic
Public Const C_STORE_SUCCESS As UShort
Visual C++
public:
literal unsigned short C_STORE_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS Field
MCdimseService Class See Also Send Feedback
Study Content NotificationService Class C_STORE_RSP code for "COMPLETE STUDY EXISTS" status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS
Visual Basic
Public Const C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS As UShort
Visual C++
public:
literal unsigned short C_STORE_SUCCESS_COMPLETE_STUDY_EXISTS

See Also

MCdimseService Class
MCdimseService Members


C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS Field
MCdimseService Class See Also Send Feedback
Study Content NotificationService Class C_STORE_RSP code for "PARTIAL STUDY EXISTS" status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS
Visual Basic
Public Const C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS As UShort
Visual C++
public:
literal unsigned short C_STORE_SUCCESS_PARTIAL_STUDY_EXISTS

See Also

MCdimseService Class
MCdimseService Members


C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST Field
MCdimseService Class See Also Send Feedback
Study Content NotificationService Class C_STORE_RSP code for "STUDY DOES NOT EXIST" status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST
Visual Basic
Public Const C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST As UShort
Visual C++
public:
literal unsigned short C_STORE_SUCCESS_STUDY_DOES_NOT_EXIST

See Also

MCdimseService Class
MCdimseService Members


C_STORE_SUCCESS_UNKNOWN_EXISTENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_SUCCESS_UNKNOWN_EXISTENCE Field
MCdimseService Class See Also Send Feedback
Study Content NotificationService Class C_STORE_RSP code for "UNKNOWN EXISTENCE" status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_SUCCESS_UNKNOWN_EXISTENCE
Visual Basic
Public Const C_STORE_SUCCESS_UNKNOWN_EXISTENCE As UShort
Visual C++
public:
literal unsigned short C_STORE_SUCCESS_UNKNOWN_EXISTENCE

See Also

MCdimseService Class
MCdimseService Members


C_STORE_WARNING_ELEMENT_COERCION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_WARNING_ELEMENT_COERCION Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "ELEMENT COERCION" warning status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_WARNING_ELEMENT_COERCION
Visual Basic
Public Const C_STORE_WARNING_ELEMENT_COERCION As UShort
Visual C++
public:
literal unsigned short C_STORE_WARNING_ELEMENT_COERCION

See Also

MCdimseService Class
MCdimseService Members


C_STORE_WARNING_ELEMENTS_DISCARDED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_WARNING_ELEMENTS_DISCARDED Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "ELEMENTS DISCARDED" warning status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_WARNING_ELEMENTS_DISCARDED
Visual Basic
Public Const C_STORE_WARNING_ELEMENTS_DISCARDED As UShort
Visual C++
public:
literal unsigned short C_STORE_WARNING_ELEMENTS_DISCARDED

See Also

MCdimseService Class
MCdimseService Members


C_STORE_WARNING_INVALID_DATASET Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..C_STORE_WARNING_INVALID_DATASET Field
MCdimseService Class See Also Send Feedback
Storage Service Class C_STORE_RSP Code for "INVALID DATASET" warning status.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort C_STORE_WARNING_INVALID_DATASET
Visual Basic
Public Const C_STORE_WARNING_INVALID_DATASET As UShort
Visual C++
public:
literal unsigned short C_STORE_WARNING_INVALID_DATASET

See Also

MCdimseService Class
MCdimseService Members


HIGH_PRIORITY_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..HIGH_PRIORITY_MESSAGE Field
MCdimseService Class See Also Send Feedback
Defined value for Priority attribute (0000,0700) in a high priority DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort HIGH_PRIORITY_MESSAGE
Visual Basic
Public Shared ReadOnly HIGH_PRIORITY_MESSAGE As UShort
Visual C++
public:
static initonly unsigned short HIGH_PRIORITY_MESSAGE

See Also

MCdimseService Class
MCdimseService Members


LOW_PRIORITY_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..LOW_PRIORITY_MESSAGE Field
MCdimseService Class See Also Send Feedback
Defined value for Priority attribute (0000,0700) in a low priority DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort LOW_PRIORITY_MESSAGE
Visual Basic
Public Shared ReadOnly LOW_PRIORITY_MESSAGE As UShort
Visual C++
public:
static initonly unsigned short LOW_PRIORITY_MESSAGE

See Also

MCdimseService Class
MCdimseService Members


MEDIUM_PRIORITY_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..MEDIUM_PRIORITY_MESSAGE Field
MCdimseService Class See Also Send Feedback
Defined value for Priority attribute (0000,0700) in a medium priority DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort MEDIUM_PRIORITY_MESSAGE
Visual Basic
Public Shared ReadOnly MEDIUM_PRIORITY_MESSAGE As UShort
Visual C++
public:
static initonly unsigned short MEDIUM_PRIORITY_MESSAGE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_CANCELLATION_DENIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_CANCELLATION_DENIED Field
MCdimseService Class See Also Send Feedback
Media Creation Management failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_CANCELLATION_DENIED
Visual Basic
Public Const N_ACTION_CANCELLATION_DENIED As UShort
Visual C++
public:
literal unsigned short N_ACTION_CANCELLATION_DENIED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_ACTION_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_ACTION_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_DUPLICATE_INVOCATION
Visual Basic
Public Const N_ACTION_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_ACTION_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_DUPLICATE_TRANSACTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_DUPLICATE_TRANSACTION_UID Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_DUPLICATE_TRANSACTION_UID
Visual Basic
Public Const N_ACTION_DUPLICATE_TRANSACTION_UID As UShort
Visual C++
public:
literal unsigned short N_ACTION_DUPLICATE_TRANSACTION_UID

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_ANNOTATION_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_ANNOTATION_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_ANNOTATION_NOT_SUPP
Visual Basic
Public Const N_ACTION_FAILURE_ANNOTATION_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_ANNOTATION_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_BOX_PRINT_Q_FULL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_BOX_PRINT_Q_FULL Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_BOX_PRINT_Q_FULL
Visual Basic
Public Const N_ACTION_FAILURE_BOX_PRINT_Q_FULL As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_BOX_PRINT_Q_FULL

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX
Visual Basic
Public Const N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_COMBINED_SIZE_LARGER_THAN_BOX

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_EMPTY_PAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_EMPTY_PAGE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_EMPTY_PAGE
Visual Basic
Public Const N_ACTION_FAILURE_EMPTY_PAGE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_EMPTY_PAGE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP
Visual Basic
Public Const N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_IMAGE_BOX_LUT_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP
Visual Basic
Public Const N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_IMAGE_OVERLAY_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_IMAGE_POS_COLLISION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_IMAGE_POS_COLLISION Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_IMAGE_POS_COLLISION
Visual Basic
Public Const N_ACTION_FAILURE_IMAGE_POS_COLLISION As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_IMAGE_POS_COLLISION

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_INSUFFICIENT_MEMORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_INSUFFICIENT_MEMORY Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_INSUFFICIENT_MEMORY
Visual Basic
Public Const N_ACTION_FAILURE_INSUFFICIENT_MEMORY As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_INSUFFICIENT_MEMORY

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_JOB_IN_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_JOB_IN_PROCESS Field
MCdimseService Class See Also Send Feedback
Print Queue Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_JOB_IN_PROCESS
Visual Basic
Public Const N_ACTION_FAILURE_JOB_IN_PROCESS As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_JOB_IN_PROCESS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS Field
MCdimseService Class See Also Send Feedback
Print Queue Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS
Visual Basic
Public Const N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_MISMATCH_OF_OWNER_IDS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES
Visual Basic
Public Const N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_NO_FILM_SOP_INSTANCES

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_NO_IMAGE_AT_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_NO_IMAGE_AT_AE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_NO_IMAGE_AT_AE
Visual Basic
Public Const N_ACTION_FAILURE_NO_IMAGE_AT_AE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_NO_IMAGE_AT_AE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE
Visual Basic
Public Const N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_NO_STORED_PRINT_AT_AE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_PRES_LUT_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_PRES_LUT_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_PRES_LUT_NOT_SUPP
Visual Basic
Public Const N_ACTION_FAILURE_PRES_LUT_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_PRES_LUT_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED Field
MCdimseService Class See Also Send Feedback
Print Queue Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED
Visual Basic
Public Const N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_PRINT_QUEUE_IS_HALTED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR
Visual Basic
Public Const N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_PRINTER_CANNOT_ACCEPT_COLOR

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_RETRIEVING_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_RETRIEVING_IMAGE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_RETRIEVING_IMAGE
Visual Basic
Public Const N_ACTION_FAILURE_RETRIEVING_IMAGE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_RETRIEVING_IMAGE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_RETRIEVING_STORED_PRINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_RETRIEVING_STORED_PRINT Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_RETRIEVING_STORED_PRINT
Visual Basic
Public Const N_ACTION_FAILURE_RETRIEVING_STORED_PRINT As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_RETRIEVING_STORED_PRINT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_SESSION_PRINT_Q_FULL Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_SESSION_PRINT_Q_FULL Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_SESSION_PRINT_Q_FULL
Visual Basic
Public Const N_ACTION_FAILURE_SESSION_PRINT_Q_FULL As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_SESSION_PRINT_Q_FULL

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX
Visual Basic
Public Const N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_SIZE_LARGER_THAN_BOX

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC
Visual Basic
Public Const N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_UNABLE_TO_OPEN_ASSOC

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE
Visual Basic
Public Const N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_UNKNOWN_RETREIVE_AE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP failure code (correct spelling).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE
Visual Basic
Public Const N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE As UShort
Visual C++
public:
literal unsigned short N_ACTION_FAILURE_UNKNOWN_RETRIEVE_AE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_INVALID_ARGUMENT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_INVALID_ARGUMENT_VALUE Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_INVALID_ARGUMENT_VALUE
Visual Basic
Public Const N_ACTION_INVALID_ARGUMENT_VALUE As UShort
Visual C++
public:
literal unsigned short N_ACTION_INVALID_ARGUMENT_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_MEDIA_CREATION_RQ_COMPLETED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_MEDIA_CREATION_RQ_COMPLETED Field
MCdimseService Class See Also Send Feedback
Media Creation Management failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_MEDIA_CREATION_RQ_COMPLETED
Visual Basic
Public Const N_ACTION_MEDIA_CREATION_RQ_COMPLETED As UShort
Visual C++
public:
literal unsigned short N_ACTION_MEDIA_CREATION_RQ_COMPLETED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS Field
MCdimseService Class See Also Send Feedback
Media Creation Management failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS
Visual Basic
Public Const N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS As UShort
Visual C++
public:
literal unsigned short N_ACTION_MEDIA_CREATION_RQ_IN_PROGRESS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_MEMORY_ALLOCATION_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_MEMORY_ALLOCATION_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_MEMORY_ALLOCATION_NOT_SUPP
Visual Basic
Public Const N_ACTION_MEMORY_ALLOCATION_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_MEMORY_ALLOCATION_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_MISTYPED_ARGUMENT
Visual Basic
Public Const N_ACTION_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_ACTION_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_NO_SUCH_ACTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_NO_SUCH_ACTION_TYPE Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_NO_SUCH_ACTION_TYPE
Visual Basic
Public Const N_ACTION_NO_SUCH_ACTION_TYPE As UShort
Visual C++
public:
literal unsigned short N_ACTION_NO_SUCH_ACTION_TYPE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_NO_SUCH_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_NO_SUCH_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_NO_SUCH_ARGUMENT
Visual Basic
Public Const N_ACTION_NO_SUCH_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_ACTION_NO_SUCH_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_ACTION_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_ACTION_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_ACTION_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_ACTION_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_OPERATOR_NOT_AUTHORIZED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_OPERATOR_NOT_AUTHORIZED Field
MCdimseService Class See Also Send Feedback
Substance Administration Operator not authorized to add entry to Medication Administration Record failure

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_OPERATOR_NOT_AUTHORIZED
Visual Basic
Public Const N_ACTION_OPERATOR_NOT_AUTHORIZED As UShort
Visual C++
public:
literal unsigned short N_ACTION_OPERATOR_NOT_AUTHORIZED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED Field
MCdimseService Class See Also Send Feedback
Substance Administration Patient cannot be identified from Patient ID or Admission ID failure

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED
Visual Basic
Public Const N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED As UShort
Visual C++
public:
literal unsigned short N_ACTION_PATIENT_CANNOT_BE_IDENTIFIED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_PROCESSING_FAILURE
Visual Basic
Public Const N_ACTION_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_ACTION_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED
Visual Basic
Public Const N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED As UShort
Visual C++
public:
literal unsigned short N_ACTION_REFERENCED_SOP_CLASS_NOT_SUPPORTED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_REFUSED_ALREADY_IN_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_REFUSED_ALREADY_IN_PROGRESS Field
MCdimseService Class See Also Send Feedback
Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_REFUSED_ALREADY_IN_PROGRESS
Visual Basic
Public Const N_ACTION_REFUSED_ALREADY_IN_PROGRESS As UShort
Visual C++
public:
literal unsigned short N_ACTION_REFUSED_ALREADY_IN_PROGRESS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED Field
MCdimseService Class See Also Send Feedback
Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED
Visual Basic
Public Const N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED As UShort
Visual C++
public:
literal unsigned short N_ACTION_REFUSED_MAY_NO_LONGER_BE_UPDATED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_REFUSED_WRONG_TRANSACTION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_REFUSED_WRONG_TRANSACTION_ID Field
MCdimseService Class See Also Send Feedback
Modify GP Scheduled Procedure Step N_ACTION_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_REFUSED_WRONG_TRANSACTION_ID
Visual Basic
Public Const N_ACTION_REFUSED_WRONG_TRANSACTION_ID As UShort
Visual C++
public:
literal unsigned short N_ACTION_REFUSED_WRONG_TRANSACTION_ID

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_RESOURCE_LIMITATION
Visual Basic
Public Const N_ACTION_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_ACTION_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Action Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_ACTION_RQ
Visual Basic
Public Shared ReadOnly N_ACTION_RQ As UShort
Visual C++
public:
static initonly unsigned short N_ACTION_RQ

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_ACTION_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_ACTION_RQ_BIT
Visual Basic
Public Shared ReadOnly N_ACTION_RQ_BIT As Integer
Visual C++
public:
static initonly int N_ACTION_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Action Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_ACTION_RSP
Visual Basic
Public Shared ReadOnly N_ACTION_RSP As UShort
Visual C++
public:
static initonly unsigned short N_ACTION_RSP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_ACTION_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_ACTION_RSP_BIT
Visual Basic
Public Shared ReadOnly N_ACTION_RSP_BIT As Integer
Visual C++
public:
static initonly int N_ACTION_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_SUCCESS
Visual Basic
Public Const N_ACTION_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_ACTION_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_ACTION_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_ACTION_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_ACTION_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_UPDATE_OF_MAR_FAILED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_UPDATE_OF_MAR_FAILED Field
MCdimseService Class See Also Send Feedback
Substance Update of Medication Administration Record failed

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_UPDATE_OF_MAR_FAILED
Visual Basic
Public Const N_ACTION_UPDATE_OF_MAR_FAILED As UShort
Visual C++
public:
literal unsigned short N_ACTION_UPDATE_OF_MAR_FAILED

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_ANNOTATION_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_ANNOTATION_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_ANNOTATION_NOT_SUPP
Visual Basic
Public Const N_ACTION_WARNING_ANNOTATION_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_ANNOTATION_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_BOX_EMPTY_PAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_BOX_EMPTY_PAGE Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_BOX_EMPTY_PAGE
Visual Basic
Public Const N_ACTION_WARNING_BOX_EMPTY_PAGE As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_BOX_EMPTY_PAGE

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP
Visual Basic
Public Const N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_IMAGE_BOX_LUT_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT
Visual Basic
Public Const N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_IMAGE_CROPPED_TO_FIT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT
Visual Basic
Public Const N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_IMAGE_DECIMATED_TO_FIT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP
Visual Basic
Public Const N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_IMAGE_OVERLAY_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_NO_COLLATION_SUPPORT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_NO_COLLATION_SUPPORT Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_NO_COLLATION_SUPPORT
Visual Basic
Public Const N_ACTION_WARNING_NO_COLLATION_SUPPORT As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_NO_COLLATION_SUPPORT

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_PRES_LUT_NOT_SUPP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_PRES_LUT_NOT_SUPP Field
MCdimseService Class See Also Send Feedback
Pull Print Request N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_PRES_LUT_NOT_SUPP
Visual Basic
Public Const N_ACTION_WARNING_PRES_LUT_NOT_SUPP As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_PRES_LUT_NOT_SUPP

See Also

MCdimseService Class
MCdimseService Members


N_ACTION_WARNING_SESSION_EMPTY_PAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_ACTION_WARNING_SESSION_EMPTY_PAGE Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_ACTION_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_ACTION_WARNING_SESSION_EMPTY_PAGE
Visual Basic
Public Const N_ACTION_WARNING_SESSION_EMPTY_PAGE As UShort
Visual C++
public:
literal unsigned short N_ACTION_WARNING_SESSION_EMPTY_PAGE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_ATTRIBUTE_LIST_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_ATTRIBUTE_LIST_ERROR Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_ATTRIBUTE_LIST_ERROR
Visual Basic
Public Const N_CREATE_ATTRIBUTE_LIST_ERROR As UShort
Visual C++
public:
literal unsigned short N_CREATE_ATTRIBUTE_LIST_ERROR

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE
Visual Basic
Public Const N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE As UShort
Visual C++
public:
literal unsigned short N_CREATE_ATTRIBUTE_VALUE_OUT_OF_RANGE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_CREATE_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_CREATE_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_DUPLICATE_INVOCATION
Visual Basic
Public Const N_CREATE_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_CREATE_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_DUPLICATE_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_DUPLICATE_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_DUPLICATE_SOP_INSTANCE
Visual Basic
Public Const N_CREATE_DUPLICATE_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_CREATE_DUPLICATE_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING Field
MCdimseService Class See Also Send Feedback
Basic Print Image Overlay Box N_CREATE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING
Visual Basic
Public Const N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING As UShort
Visual C++
public:
literal unsigned short N_CREATE_FAILURE_COMBINED_REQUIRES_CROPPING

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV Field
MCdimseService Class See Also Send Feedback
Media Creation failure codes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV
Visual Basic
Public Const N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV As UShort
Visual C++
public:
literal unsigned short N_CREATE_FAILURE_MEDIA_CREATION_ALREADY_RCV

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_INVALID_ATTRIBUTE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_INVALID_ATTRIBUTE_VALUE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_INVALID_ATTRIBUTE_VALUE
Visual Basic
Public Const N_CREATE_INVALID_ATTRIBUTE_VALUE As UShort
Visual C++
public:
literal unsigned short N_CREATE_INVALID_ATTRIBUTE_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED
Visual Basic
Public Const N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED As UShort
Visual C++
public:
literal unsigned short N_CREATE_MEMORY_ALLOCATION_NOT_SUPPORTED

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_MISSING_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_MISSING_ATTRIBUTE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_MISSING_ATTRIBUTE
Visual Basic
Public Const N_CREATE_MISSING_ATTRIBUTE As UShort
Visual C++
public:
literal unsigned short N_CREATE_MISSING_ATTRIBUTE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_MISSING_ATTRIBUTE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_MISSING_ATTRIBUTE_VALUE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_MISSING_ATTRIBUTE_VALUE
Visual Basic
Public Const N_CREATE_MISSING_ATTRIBUTE_VALUE As UShort
Visual C++
public:
literal unsigned short N_CREATE_MISSING_ATTRIBUTE_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_MISTYPED_ARGUMENT
Visual Basic
Public Const N_CREATE_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_CREATE_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE
Visual Basic
Public Const N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE As UShort
Visual C++
public:
literal unsigned short N_CREATE_NO_MEMORY_ALLOCATION_POSSIBLE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_NO_SUCH_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_NO_SUCH_ATTRIBUTE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_NO_SUCH_ATTRIBUTE
Visual Basic
Public Const N_CREATE_NO_SUCH_ATTRIBUTE As UShort
Visual C++
public:
literal unsigned short N_CREATE_NO_SUCH_ATTRIBUTE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_CREATE_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_CREATE_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_CREATE_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_CREATE_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_PROCESSING_FAILURE
Visual Basic
Public Const N_CREATE_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_CREATE_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS Field
MCdimseService Class See Also Send Feedback
Modify GP Performed Procedure Step N_CREATE_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS
Visual Basic
Public Const N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS As UShort
Visual C++
public:
literal unsigned short N_CREATE_REFUSED_SPS_NOT_IN_PROGRESS

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID Field
MCdimseService Class See Also Send Feedback
Modify GP Performed Procedure Step N_CREATE_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID
Visual Basic
Public Const N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID As UShort
Visual C++
public:
literal unsigned short N_CREATE_REFUSED_UNMATCHED_TRANSACTION_ID

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE
Visual Basic
Public Const N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE As UShort
Visual C++
public:
literal unsigned short N_CREATE_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_RESOURCE_LIMITATION
Visual Basic
Public Const N_CREATE_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_CREATE_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Create Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_CREATE_RQ
Visual Basic
Public Shared ReadOnly N_CREATE_RQ As UShort
Visual C++
public:
static initonly unsigned short N_CREATE_RQ

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_CREATE_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_CREATE_RQ_BIT
Visual Basic
Public Shared ReadOnly N_CREATE_RQ_BIT As Integer
Visual C++
public:
static initonly int N_CREATE_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Create Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_CREATE_RSP
Visual Basic
Public Shared ReadOnly N_CREATE_RSP As UShort
Visual C++
public:
static initonly unsigned short N_CREATE_RSP

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_CREATE_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_CREATE_RSP_BIT
Visual Basic
Public Shared ReadOnly N_CREATE_RSP_BIT As Integer
Visual C++
public:
static initonly int N_CREATE_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_SUCCESS
Visual Basic
Public Const N_CREATE_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_CREATE_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_TEMPORARILY_NO_MEMORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_TEMPORARILY_NO_MEMORY Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_CREATE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_TEMPORARILY_NO_MEMORY
Visual Basic
Public Const N_CREATE_TEMPORARILY_NO_MEMORY As UShort
Visual C++
public:
literal unsigned short N_CREATE_TEMPORARILY_NO_MEMORY

See Also

MCdimseService Class
MCdimseService Members


N_CREATE_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_CREATE_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_CREATE_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_CREATE_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_CREATE_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_CREATE_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_DELETE_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_DELETE_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_DUPLICATE_INVOCATION
Visual Basic
Public Const N_DELETE_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_DELETE_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_MISTYPED_ARGUMENT
Visual Basic
Public Const N_DELETE_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_DELETE_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_DELETE_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_DELETE_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_DELETE_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_DELETE_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_PROCESSING_FAILURE
Visual Basic
Public Const N_DELETE_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_DELETE_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_RESOURCE_LIMITATION
Visual Basic
Public Const N_DELETE_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_DELETE_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Delete Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_DELETE_RQ
Visual Basic
Public Shared ReadOnly N_DELETE_RQ As UShort
Visual C++
public:
static initonly unsigned short N_DELETE_RQ

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_DELETE_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_DELETE_RQ_BIT
Visual Basic
Public Shared ReadOnly N_DELETE_RQ_BIT As Integer
Visual C++
public:
static initonly int N_DELETE_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Delete Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_DELETE_RSP
Visual Basic
Public Shared ReadOnly N_DELETE_RSP As UShort
Visual C++
public:
static initonly unsigned short N_DELETE_RSP

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_DELETE_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_DELETE_RSP_BIT
Visual Basic
Public Shared ReadOnly N_DELETE_RSP_BIT As Integer
Visual C++
public:
static initonly int N_DELETE_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_SUCCESS
Visual Basic
Public Const N_DELETE_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_DELETE_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_DELETE_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_DELETE_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_DELETE_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_DELETE_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_DELETE_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_DELETE_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_EVENT_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_EVENT_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_DUPLICATE_INVOCATION
Visual Basic
Public Const N_EVENT_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_EVENT_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_INVALID_ARGUMENT_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_INVALID_ARGUMENT_VALUE Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_INVALID_ARGUMENT_VALUE
Visual Basic
Public Const N_EVENT_INVALID_ARGUMENT_VALUE As UShort
Visual C++
public:
literal unsigned short N_EVENT_INVALID_ARGUMENT_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_MISTYPED_ARGUMENT
Visual Basic
Public Const N_EVENT_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_EVENT_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_NO_SUCH_ACTION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_NO_SUCH_ACTION_TYPE Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_NO_SUCH_ACTION_TYPE
Visual Basic
Public Const N_EVENT_NO_SUCH_ACTION_TYPE As UShort
Visual C++
public:
literal unsigned short N_EVENT_NO_SUCH_ACTION_TYPE

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_NO_SUCH_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_NO_SUCH_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_NO_SUCH_ARGUMENT
Visual Basic
Public Const N_EVENT_NO_SUCH_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_EVENT_NO_SUCH_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_NO_SUCH_EVENT_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_NO_SUCH_EVENT_TYPE Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_NO_SUCH_EVENT_TYPE
Visual Basic
Public Const N_EVENT_NO_SUCH_EVENT_TYPE As UShort
Visual C++
public:
literal unsigned short N_EVENT_NO_SUCH_EVENT_TYPE

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_EVENT_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_EVENT_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_EVENT_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_EVENT_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_PROCESSING_FAILURE
Visual Basic
Public Const N_EVENT_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_EVENT_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_REPORT_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_REPORT_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Report Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_EVENT_REPORT_RQ
Visual Basic
Public Shared ReadOnly N_EVENT_REPORT_RQ As UShort
Visual C++
public:
static initonly unsigned short N_EVENT_REPORT_RQ

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_REPORT_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_REPORT_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_EVENT_REPORT_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_EVENT_REPORT_RQ_BIT
Visual Basic
Public Shared ReadOnly N_EVENT_REPORT_RQ_BIT As Integer
Visual C++
public:
static initonly int N_EVENT_REPORT_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_REPORT_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_REPORT_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Report Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_EVENT_REPORT_RSP
Visual Basic
Public Shared ReadOnly N_EVENT_REPORT_RSP As UShort
Visual C++
public:
static initonly unsigned short N_EVENT_REPORT_RSP

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_REPORT_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_REPORT_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_EVENT_REPORT_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_EVENT_REPORT_RSP_BIT
Visual Basic
Public Shared ReadOnly N_EVENT_REPORT_RSP_BIT As Integer
Visual C++
public:
static initonly int N_EVENT_REPORT_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_RESOURCE_LIMITATION
Visual Basic
Public Const N_EVENT_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_EVENT_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_SUCCESS
Visual Basic
Public Const N_EVENT_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_EVENT_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_EVENT_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_EVENT_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_EVENT_REPORT_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_EVENT_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_EVENT_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_EVENT_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_GET_ATTRIBUTE_LIST_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_ATTRIBUTE_LIST_ERROR Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_ATTRIBUTE_LIST_ERROR
Visual Basic
Public Const N_GET_ATTRIBUTE_LIST_ERROR As UShort
Visual C++
public:
literal unsigned short N_GET_ATTRIBUTE_LIST_ERROR

See Also

MCdimseService Class
MCdimseService Members


N_GET_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_GET_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_GET_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_GET_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_DUPLICATE_INVOCATION
Visual Basic
Public Const N_GET_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_GET_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_GET_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_MISTYPED_ARGUMENT
Visual Basic
Public Const N_GET_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_GET_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_GET_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_GET_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_GET_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_GET_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_GET_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_GET_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_GET_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_PROCESSING_FAILURE
Visual Basic
Public Const N_GET_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_GET_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_GET_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_RESOURCE_LIMITATION
Visual Basic
Public Const N_GET_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_GET_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_GET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Get Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_GET_RQ
Visual Basic
Public Shared ReadOnly N_GET_RQ As UShort
Visual C++
public:
static initonly unsigned short N_GET_RQ

See Also

MCdimseService Class
MCdimseService Members


N_GET_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_GET_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_GET_RQ_BIT
Visual Basic
Public Shared ReadOnly N_GET_RQ_BIT As Integer
Visual C++
public:
static initonly int N_GET_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_GET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Get Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_GET_RSP
Visual Basic
Public Shared ReadOnly N_GET_RSP As UShort
Visual C++
public:
static initonly unsigned short N_GET_RSP

See Also

MCdimseService Class
MCdimseService Members


N_GET_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_GET_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_GET_RSP_BIT
Visual Basic
Public Shared ReadOnly N_GET_RSP_BIT As Integer
Visual C++
public:
static initonly int N_GET_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_GET_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_SUCCESS
Visual Basic
Public Const N_GET_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_GET_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_GET_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_GET_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_GET_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED Field
MCdimseService Class See Also Send Feedback
N_GET_RSP Response warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED
Visual Basic
Public Const N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED As UShort
Visual C++
public:
literal unsigned short N_GET_WARNING_OPT_ATTRIB_UNSUPPORTED

See Also

MCdimseService Class
MCdimseService Members


N_SET_ATTRIBUTE_LIST_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_ATTRIBUTE_LIST_ERROR Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_ATTRIBUTE_LIST_ERROR
Visual Basic
Public Const N_SET_ATTRIBUTE_LIST_ERROR As UShort
Visual C++
public:
literal unsigned short N_SET_ATTRIBUTE_LIST_ERROR

See Also

MCdimseService Class
MCdimseService Members


N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE
Visual Basic
Public Const N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE As UShort
Visual C++
public:
literal unsigned short N_SET_ATTRIBUTE_VALUE_OUT_OF_RANGE

See Also

MCdimseService Class
MCdimseService Members


N_SET_CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_CLASS_INSTANCE_CONFLICT Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const N_SET_CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short N_SET_CLASS_INSTANCE_CONFLICT

See Also

MCdimseService Class
MCdimseService Members


N_SET_DUPLICATE_INVOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_DUPLICATE_INVOCATION Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_DUPLICATE_INVOCATION
Visual Basic
Public Const N_SET_DUPLICATE_INVOCATION As UShort
Visual C++
public:
literal unsigned short N_SET_DUPLICATE_INVOCATION

See Also

MCdimseService Class
MCdimseService Members


N_SET_FAILURE_COMBINED_LARGER_THAN_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_FAILURE_COMBINED_LARGER_THAN_BOX Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_FAILURE_COMBINED_LARGER_THAN_BOX
Visual Basic
Public Const N_SET_FAILURE_COMBINED_LARGER_THAN_BOX As UShort
Visual C++
public:
literal unsigned short N_SET_FAILURE_COMBINED_LARGER_THAN_BOX

See Also

MCdimseService Class
MCdimseService Members


N_SET_FAILURE_IMAGE_LARGER_THAN_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_FAILURE_IMAGE_LARGER_THAN_BOX Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_FAILURE_IMAGE_LARGER_THAN_BOX
Visual Basic
Public Const N_SET_FAILURE_IMAGE_LARGER_THAN_BOX As UShort
Visual C++
public:
literal unsigned short N_SET_FAILURE_IMAGE_LARGER_THAN_BOX

See Also

MCdimseService Class
MCdimseService Members


N_SET_INSUFFICIENT_PRINTER_MEMORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_INSUFFICIENT_PRINTER_MEMORY Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_INSUFFICIENT_PRINTER_MEMORY
Visual Basic
Public Const N_SET_INSUFFICIENT_PRINTER_MEMORY As UShort
Visual C++
public:
literal unsigned short N_SET_INSUFFICIENT_PRINTER_MEMORY

See Also

MCdimseService Class
MCdimseService Members


N_SET_INVALID_ATTRIBUTE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_INVALID_ATTRIBUTE_VALUE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_INVALID_ATTRIBUTE_VALUE
Visual Basic
Public Const N_SET_INVALID_ATTRIBUTE_VALUE As UShort
Visual C++
public:
literal unsigned short N_SET_INVALID_ATTRIBUTE_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_SET_INVALID_OBJECT_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_INVALID_OBJECT_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_INVALID_OBJECT_INSTANCE
Visual Basic
Public Const N_SET_INVALID_OBJECT_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_SET_INVALID_OBJECT_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_SET_MISSING_ATTRIBUTE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_MISSING_ATTRIBUTE_VALUE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_MISSING_ATTRIBUTE_VALUE
Visual Basic
Public Const N_SET_MISSING_ATTRIBUTE_VALUE As UShort
Visual C++
public:
literal unsigned short N_SET_MISSING_ATTRIBUTE_VALUE

See Also

MCdimseService Class
MCdimseService Members


N_SET_MISTYPED_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_MISTYPED_ARGUMENT Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_MISTYPED_ARGUMENT
Visual Basic
Public Const N_SET_MISTYPED_ARGUMENT As UShort
Visual C++
public:
literal unsigned short N_SET_MISTYPED_ARGUMENT

See Also

MCdimseService Class
MCdimseService Members


N_SET_MORE_THAN_ONE_VOID_LUT_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_MORE_THAN_ONE_VOID_LUT_BOX Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_MORE_THAN_ONE_VOID_LUT_BOX
Visual Basic
Public Const N_SET_MORE_THAN_ONE_VOID_LUT_BOX As UShort
Visual C++
public:
literal unsigned short N_SET_MORE_THAN_ONE_VOID_LUT_BOX

See Also

MCdimseService Class
MCdimseService Members


N_SET_NO_SUCH_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_NO_SUCH_ATTRIBUTE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_NO_SUCH_ATTRIBUTE
Visual Basic
Public Const N_SET_NO_SUCH_ATTRIBUTE As UShort
Visual C++
public:
literal unsigned short N_SET_NO_SUCH_ATTRIBUTE

See Also

MCdimseService Class
MCdimseService Members


N_SET_NO_SUCH_SOP_CLASS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_NO_SUCH_SOP_CLASS Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_NO_SUCH_SOP_CLASS
Visual Basic
Public Const N_SET_NO_SUCH_SOP_CLASS As UShort
Visual C++
public:
literal unsigned short N_SET_NO_SUCH_SOP_CLASS

See Also

MCdimseService Class
MCdimseService Members


N_SET_NO_SUCH_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_NO_SUCH_SOP_INSTANCE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_NO_SUCH_SOP_INSTANCE
Visual Basic
Public Const N_SET_NO_SUCH_SOP_INSTANCE As UShort
Visual C++
public:
literal unsigned short N_SET_NO_SUCH_SOP_INSTANCE

See Also

MCdimseService Class
MCdimseService Members


N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED Field
MCdimseService Class See Also Send Feedback
Modality Performed Procedure Step N_SET_RSP failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED
Visual Basic
Public Const N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED As UShort
Visual C++
public:
literal unsigned short N_SET_OBJECT_MAY_NO_LONGER_BE_UPDATED

See Also

MCdimseService Class
MCdimseService Members


N_SET_PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_PROCESSING_FAILURE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_PROCESSING_FAILURE
Visual Basic
Public Const N_SET_PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short N_SET_PROCESSING_FAILURE

See Also

MCdimseService Class
MCdimseService Members


N_SET_REFUSED_PPS_NOT_IN_PROGRESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_REFUSED_PPS_NOT_IN_PROGRESS Field
MCdimseService Class See Also Send Feedback
Modality GP Performed Procedure Step N_SET_RSP refused code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_REFUSED_PPS_NOT_IN_PROGRESS
Visual Basic
Public Const N_SET_REFUSED_PPS_NOT_IN_PROGRESS As UShort
Visual C++
public:
literal unsigned short N_SET_REFUSED_PPS_NOT_IN_PROGRESS

See Also

MCdimseService Class
MCdimseService Members


N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE
Visual Basic
Public Const N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE As UShort
Visual C++
public:
literal unsigned short N_SET_REQUESTED_MIN_OR_MAX_DENSITY_OUTSIDE_RANGE

See Also

MCdimseService Class
MCdimseService Members


N_SET_RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_RESOURCE_LIMITATION Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_RESOURCE_LIMITATION
Visual Basic
Public Const N_SET_RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short N_SET_RESOURCE_LIMITATION

See Also

MCdimseService Class
MCdimseService Members


N_SET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_RQ Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Set Service Request command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_SET_RQ
Visual Basic
Public Shared ReadOnly N_SET_RQ As UShort
Visual C++
public:
static initonly unsigned short N_SET_RQ

See Also

MCdimseService Class
MCdimseService Members


N_SET_RQ_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_RQ_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_SET_RQ.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_SET_RQ_BIT
Visual Basic
Public Shared ReadOnly N_SET_RQ_BIT As Integer
Visual C++
public:
static initonly int N_SET_RQ_BIT

See Also

MCdimseService Class
MCdimseService Members


N_SET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_RSP Field
MCdimseService Class See Also Send Feedback
DICOM Normalized Set Service Response command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort N_SET_RSP
Visual Basic
Public Shared ReadOnly N_SET_RSP As UShort
Visual C++
public:
static initonly unsigned short N_SET_RSP

See Also

MCdimseService Class
MCdimseService Members


N_SET_RSP_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_RSP_BIT Field
MCdimseService Class See Also Send Feedback
DIMSE command control bit for N_SET_RSP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int N_SET_RSP_BIT
Visual Basic
Public Shared ReadOnly N_SET_RSP_BIT As Integer
Visual C++
public:
static initonly int N_SET_RSP_BIT

See Also

MCdimseService Class
MCdimseService Members


N_SET_SUCCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_SUCCESS Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response success code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_SUCCESS
Visual Basic
Public Const N_SET_SUCCESS As UShort
Visual C++
public:
literal unsigned short N_SET_SUCCESS

See Also

MCdimseService Class
MCdimseService Members


N_SET_UNRECOGNIZED_OPERATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_UNRECOGNIZED_OPERATION Field
MCdimseService Class See Also Send Feedback
N_SET_RSP Response failure code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_UNRECOGNIZED_OPERATION
Visual Basic
Public Const N_SET_UNRECOGNIZED_OPERATION As UShort
Visual C++
public:
literal unsigned short N_SET_UNRECOGNIZED_OPERATION

See Also

MCdimseService Class
MCdimseService Members


N_SET_WARNING_IMAGE_CROPPED_TO_FIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_WARNING_IMAGE_CROPPED_TO_FIT Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_WARNING_IMAGE_CROPPED_TO_FIT
Visual Basic
Public Const N_SET_WARNING_IMAGE_CROPPED_TO_FIT As UShort
Visual C++
public:
literal unsigned short N_SET_WARNING_IMAGE_CROPPED_TO_FIT

See Also

MCdimseService Class
MCdimseService Members


N_SET_WARNING_IMAGE_DECIMATED_TO_FIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..N_SET_WARNING_IMAGE_DECIMATED_TO_FIT Field
MCdimseService Class See Also Send Feedback
Print Management Service Class N_SET_RSP warning code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort N_SET_WARNING_IMAGE_DECIMATED_TO_FIT
Visual Basic
Public Const N_SET_WARNING_IMAGE_DECIMATED_TO_FIT As UShort
Visual C++
public:
literal unsigned short N_SET_WARNING_IMAGE_DECIMATED_TO_FIT

See Also

MCdimseService Class
MCdimseService Members


NULL_COMMAND Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..NULL_COMMAND Field
MCdimseService Class See Also Send Feedback
Null DIMSE command representing an undefined command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly ushort NULL_COMMAND
Visual Basic
Public Shared ReadOnly NULL_COMMAND As UShort
Visual C++
public:
static initonly unsigned short NULL_COMMAND

See Also

MCdimseService Class
MCdimseService Members


NUMBER_OF_COMMANDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..NUMBER_OF_COMMANDS Field
MCdimseService Class See Also Send Feedback
The total number of DIMSE commands.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly int NUMBER_OF_COMMANDS
Visual Basic
Public Shared ReadOnly NUMBER_OF_COMMANDS As Integer
Visual C++
public:
static initonly int NUMBER_OF_COMMANDS

See Also

MCdimseService Class
MCdimseService Members


MCdimseService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService Methods
MCdimseService Class See Also Send Feedback

The MCdimseService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503.
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107.
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000.
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111.
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115.
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007.
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117.
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501.
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120.
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123.
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114.
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105.
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113.
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112.
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001.
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00.
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00.
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01.
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506.
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700.
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner.
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213.
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000.
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000.
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505.
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211.
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdimseService Class


sendAlreadyInProgressResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendAlreadyInProgressResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA503.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendAlreadyInProgressResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendAlreadyInProgressResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendAlreadyInProgressResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status conveys that the action is refused because the General Purpose Scheduled Procedure Step SOP Instance is already in the "IN PROGRESS" state.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | - This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendAttributeListErrorResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendAttributeListErrorResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0107.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendAttributeListErrorResponse(
    MCdimseMessage requestMsg,
    MCdataSet attributeList,
    uint[] unrecognizedAttributes
)
Visual Basic
Public Overridable Sub sendAttributeListErrorResponse ( _
    requestMsg As MCdimseMessage, _
    attributeList As MCdataSet, _
    unrecognizedAttributes As UInteger() _
)
Visual C++
public:
virtual void sendAttributeListErrorResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ attributeList,
    array<unsigned int>^ unrecognizedAttributes
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The DIMSE message being responded to.
attributeList
Type: Mergecom..::..MCdataSet
A data set containing attribute values that could be read, or null if the attributes that could be read should not be included in the response.
unrecognizedAttributes
Type: array<System..::..UInt32>[]()[][]
A list of attribute tags identifying attributes that were not recognized or null if the list should not be included in the response.

Remarks

This response is used when one or more attribute values were not read because the specified attribute was not recognized. The attribute values that could be read are returned, however.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | The operation is not allowed in the current context.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted.
Mergecom.Exceptions..::..MCunacceptableServiceException | The current service does not support this message.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendCancelledResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendCancelledResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00.

See Also

MCdimseService Class
MCdimseService Members


sendCancelledResponse Method (MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendCancelledResponse Method (MCdimseMessage)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFE00.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCancelledResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendCancelledResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendCancelledResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This method sends a response message indicating that a C-CANCEL request was received for the C-FIND, C-GET or C_MOVE operation contained in requestMsg.

The first form of the call is used for C-FIND operations and for C-GET or C-MOVE operations that have experienced no failures and that will not supply any sub-operation counters.

The second and third forms of the call may only be used when responding to a C-GET or a C-MOVE request. Each of the last four arguments are optional and may be null. If not null, remainingSubOperations will be encoded in attribute (0000,1020), completedSubOperations will be encoded in attribute (0000,1021), failedSubOperations will be encoded in attribute (0000,1022), and warningSubOperations will be encoded in attribute (0000,1023).

The third form of the call must be used when responding to a C-GET or a C-MOVE request when the C-STORE sub-operation for one or more SOP instances failed. In that case, the identifier must contain the Failed SOP Instance UID List (0008,0048) attribute that specifies a list of UIDs of the C-STORE sub-operation SOP Instances for which the C-GET or C-MOVE operation has failed. If there were no sub-operation failures, there is no need for an identifier data set.

The status attribute (0000,0900) will be set to 0xFE00 (cancelled).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for specified message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with the specified message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendCancelledResponse Overload


sendCancelledResponse Method (MCdimseMessage, UInt16, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendCancelledResponse Method (MCdimseMessage, UInt16, UInt16, UInt16, UInt16)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFE00.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCancelledResponse(
    MCdimseMessage requestMsg,
    ushort remainingSubOperations,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendCancelledResponse ( _
    requestMsg As MCdimseMessage, _
    remainingSubOperations As UShort, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendCancelledResponse(
    MCdimseMessage^ requestMsg,
    unsigned short remainingSubOperations,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
remainingSubOperations
Type: System..::..UInt16
Remaining sub-operation count.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This method sends a response message indicating that a C-CANCEL request was received for the C-FIND, C-GET or C_MOVE operation contained in requestMsg.

The first form of the call is used for C-FIND operations and for C-GET or C-MOVE operations that have experienced no failures and that will not supply any sub-operation counters.

The second and third forms of the call may only be used when responding to a C-GET or a C-MOVE request. Each of the last four arguments are optional and may be null. If not null, remainingSubOperations will be encoded in attribute (0000,1020), completedSubOperations will be encoded in attribute (0000,1021), failedSubOperations will be encoded in attribute (0000,1022), and warningSubOperations will be encoded in attribute (0000,1023).

The third form of the call must be used when responding to a C-GET or a C-MOVE request when the C-STORE sub-operation for one or more SOP instances failed. In that case, the identifier must contain the Failed SOP Instance UID List (0008,0048) attribute that specifies a list of UIDs of the C-STORE sub-operation SOP Instances for which the C-GET or C-MOVE operation has failed. If there were no sub-operation failures, there is no need for an identifier data set.

The status attribute (0000,0900) will be set to 0xFE00 (cancelled).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendCancelledResponse Overload


sendCancelledResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendCancelledResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFE00.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCancelledResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    ushort remainingSubOperations,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendCancelledResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    remainingSubOperations As UShort, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendCancelledResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    unsigned short remainingSubOperations,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
A possibly-null handle to a MCdataSet object. The object is used to encode the Failed SOP Instance UID List attribute, when appropriate.
remainingSubOperations
Type: System..::..UInt16
Remaining sub-operation count.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This method sends a response message indicating that a C-CANCEL request was received for the C-FIND, C-GET or C_MOVE operation contained in requestMsg.

The first form of the call is used for C-FIND operations and for C-GET or C-MOVE operations that have experienced no failures and that will not supply any sub-operation counters.

The second and third forms of the call may only be used when responding to a C-GET or a C-MOVE request. Each of the last four arguments are optional and may be null. If not null, remainingSubOperations will be encoded in attribute (0000,1020), completedSubOperations will be encoded in attribute (0000,1021), failedSubOperations will be encoded in attribute (0000,1022), and warningSubOperations will be encoded in attribute (0000,1023).

The third form of the call must be used when responding to a C-GET or a C-MOVE request when the C-STORE sub-operation for one or more SOP instances failed. In that case, the identifier must contain the Failed SOP Instance UID List (0008,0048) attribute that specifies a list of UIDs of the C-STORE sub-operation SOP Instances for which the C-GET or C-MOVE operation has failed. If there were no sub-operation failures, there is no need for an identifier data set.

The status attribute (0000,0900) will be set to 0xFE00 (cancelled).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendCancelledResponse Overload


sendCannotUnderstandResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendCannotUnderstandResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xC000.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCannotUnderstandResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendCannotUnderstandResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendCannotUnderstandResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
Non-null Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null array of elements involved in the error.
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

This indicates that the peer DIMSE-service-user was unable to store the composite SOP Instance because it cannot understand certain Data Elements.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendClassInstanceConflictResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendClassInstanceConflictResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0119.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendClassInstanceConflictResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendClassInstanceConflictResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendClassInstanceConflictResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The DIMSE message being responded to.

Remarks

This response is sent when the specified SOP instance is not a member of the specified SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendDuplicateSopInstanceResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendDuplicateSopInstanceResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111.
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111.

See Also

MCdimseService Class
MCdimseService Members


sendDuplicateSopInstanceResponse Method (MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendDuplicateSopInstanceResponse Method (MCdimseMessage, String)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0111.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendDuplicateSopInstanceResponse(
    MCdimseMessage requestMsg,
    string alreadyAllocatedInstanceUid
)
Visual Basic
Public Overridable Sub sendDuplicateSopInstanceResponse ( _
    requestMsg As MCdimseMessage, _
    alreadyAllocatedInstanceUid As String _
)
Visual C++
public:
virtual void sendDuplicateSopInstanceResponse(
    MCdimseMessage^ requestMsg,
    String^ alreadyAllocatedInstanceUid
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The DIMSE message being responded to.
alreadyAllocatedInstanceUid
Type: System..::..String
Possibly null UID that was already allocated to another SOP instance.

Remarks

This response is used when the new managed SOP Instance Value supplied by the invoking DIMSE-service-user was already registered for a managed SOP Instance of the specified SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendDuplicateSopInstanceResponse Overload


sendDuplicateSopInstanceResponse Method (String, UInt16, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendDuplicateSopInstanceResponse Method (String, UInt16, String)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0111.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendDuplicateSopInstanceResponse(
    string reqServiceName,
    ushort reqCommand,
    string alreadyAllocatedInstanceUid
)
Visual Basic
Public Overridable Sub sendDuplicateSopInstanceResponse ( _
    reqServiceName As String, _
    reqCommand As UShort, _
    alreadyAllocatedInstanceUid As String _
)
Visual C++
public:
virtual void sendDuplicateSopInstanceResponse(
    String^ reqServiceName,
    unsigned short reqCommand,
    String^ alreadyAllocatedInstanceUid
)

Parameters

reqServiceName
Type: System..::..String
The DIMSE message service being responded to.
reqCommand
Type: System..::..UInt16
The DIMSE message command being responded to.
alreadyAllocatedInstanceUid
Type: System..::..String
Possibly null UID that was already allocated to another SOP instance.

Remarks

This response is used when the new managed SOP Instance Value supplied by the invoking DIMSE-service-user was already registered for a managed SOP Instance of the specified SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for reqServiceName.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service denoted by reqServiceName is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendDuplicateSopInstanceResponse Overload


sendInvalidArgumentValueResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidArgumentValueResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0115.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidArgumentValueResponse(
    MCdimseMessage requestMsg,
    MCinstanceUid affectedInstance,
    MCdataSet invalidArgumentValues
)
Visual Basic
Public Overridable Sub sendInvalidArgumentValueResponse ( _
    requestMsg As MCdimseMessage, _
    affectedInstance As MCinstanceUid, _
    invalidArgumentValues As MCdataSet _
)
Visual C++
public:
virtual void sendInvalidArgumentValueResponse(
    MCdimseMessage^ requestMsg,
    MCinstanceUid^ affectedInstance,
    MCdataSet^ invalidArgumentValues
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
affectedInstance
Type: Mergecom..::..MCinstanceUid
Optional, identifies instance for which the argument value was in error.
invalidArgumentValues
Type: Mergecom..::..MCdataSet
Optional data set that contains the invalid value or values contained in the request message.

Remarks

This status is sent when the event or action information value specified was out of range or otherwise inappropriate.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendInvalidAttributeValueResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidAttributeValueResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0106

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidAttributeValueResponse(
    MCdimseMessage requestMsg,
    MCdataSet modificationList
)
Visual Basic
Public Overridable Sub sendInvalidAttributeValueResponse ( _
    requestMsg As MCdimseMessage, _
    modificationList As MCdataSet _
)
Visual C++
public:
virtual void sendInvalidAttributeValueResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ modificationList
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The DIMSE message being responded to.
modificationList
Type: Mergecom..::..MCdataSet
Possibly null data set containing only the invalid attribute values conveyed in the original modification list sent by the SCU in its request message.

Remarks

This response is sent when an attribute value is not valid or recognized.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendInvalidDatasetFailureResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidDatasetFailureResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900.

See Also

MCdimseService Class
MCdimseService Members


sendInvalidDatasetFailureResponse Method (MCdimseMessage, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidDatasetFailureResponse Method (MCdimseMessage, array<UInt32>[]()[][], String)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA900.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidDatasetFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendInvalidDatasetFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendInvalidDatasetFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
Non-null Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null array of elements involved in the error.
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

This Failure status indicates that the peer DIMSE-service-user was unable to store the composite SOP Instance because the Data Set does not match the SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendInvalidDatasetFailureResponse Overload


sendInvalidDatasetFailureResponse Method (MCdimseMessage, MCdataSet, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidDatasetFailureResponse Method (MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA900.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidDatasetFailureResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendInvalidDatasetFailureResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendInvalidDatasetFailureResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
Contains Failed SOP Instance UID List.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Elements involved with the error.
errorComment
Type: System..::..String
Error description.

Remarks

This Failure status indicates that the peer DIMSE-service-user was unable to store the composite SOP Instance because the Data Set does not match the SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendInvalidDatasetFailureResponse Overload


sendInvalidDatasetWarningResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidDatasetWarningResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xB007.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidDatasetWarningResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendInvalidDatasetWarningResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendInvalidDatasetWarningResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null array of elements involved in the error.
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

This Warning indicates that the peer DIMSE-service-user was unable to store the composite SOP Instance because the Data Set does not match the SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendInvalidSopInstanceResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendInvalidSopInstanceResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0117.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendInvalidSopInstanceResponse(
    MCdimseMessage requestMsg,
    string affectedInstanceUid
)
Visual Basic
Public Overridable Sub sendInvalidSopInstanceResponse ( _
    requestMsg As MCdimseMessage, _
    affectedInstanceUid As String _
)
Visual C++
public:
virtual void sendInvalidSopInstanceResponse(
    MCdimseMessage^ requestMsg,
    String^ affectedInstanceUid
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
affectedInstanceUid
Type: System..::..String
Optional UID of the instance involved.

Remarks

This response is sent when the SOP Instance UID specified implied a violation of the UID construction rules.

May be sent in response to: N-ACTION or N-GET or N-SET or N-EVENT-REPORT requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendMayNoLongerBeUpdatedResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendMayNoLongerBeUpdatedResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA501.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendMayNoLongerBeUpdatedResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendMayNoLongerBeUpdatedResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendMayNoLongerBeUpdatedResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.

Remarks

This status conveys that the action is refused because General Purpose Scheduled Procedure Step Object may no longer be updated.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendMissingAttributeResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendMissingAttributeResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0120.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendMissingAttributeResponse(
    MCdimseMessage requestMsg,
    uint[] missingAttributes
)
Visual Basic
Public Overridable Sub sendMissingAttributeResponse ( _
    requestMsg As MCdimseMessage, _
    missingAttributes As UInteger() _
)
Visual C++
public:
virtual void sendMissingAttributeResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ missingAttributes
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to
missingAttributes
Type: array<System..::..UInt32>[]()[][]
Possibly null list of attribute tags identifying attributes that were not supplied.

Remarks

This response is used when a required attribute was not supplied.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendMissingAttributeValueResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendMissingAttributeValueResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0121

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendMissingAttributeValueResponse(
    MCdimseMessage requestMsg,
    MCdataSet missingList
)
Visual Basic
Public Overridable Sub sendMissingAttributeValueResponse ( _
    requestMsg As MCdimseMessage, _
    missingList As MCdataSet _
)
Visual C++
public:
virtual void sendMissingAttributeValueResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ missingList
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
missingList
Type: Mergecom..::..MCdataSet
Possibly null data set containing only the attributes whose values were missing.

Remarks

This response is sent when a required Attribute Value was not supplied and a default value was not available.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendMistypedArgumentResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendMistypedArgumentResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0212.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendMistypedArgumentResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendMistypedArgumentResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendMistypedArgumentResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.

Remarks

This status conveys that one of the parameters supplied has not been agreed for use on the Association between the DIMSE-service-users.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendNoSuchActionTypeResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendNoSuchActionTypeResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0123.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoSuchActionTypeResponse(
    MCdimseMessage requestMsg,
    string affectedSopClassUid,
    ushort actionType
)
Visual Basic
Public Overridable Sub sendNoSuchActionTypeResponse ( _
    requestMsg As MCdimseMessage, _
    affectedSopClassUid As String, _
    actionType As UShort _
)
Visual C++
public:
virtual void sendNoSuchActionTypeResponse(
    MCdimseMessage^ requestMsg,
    String^ affectedSopClassUid,
    unsigned short actionType
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
affectedSopClassUid
Type: System..::..String
Optional affected SOP Class Uid.
actionType
Type: System..::..UInt16
Optional action type ID.

Remarks

This response is sent when the action type specified does not exist.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendNoSuchArgumentResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendNoSuchArgumentResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0114.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoSuchArgumentResponse(
    MCdimseMessage requestMsg,
    ushort eventOrActionType
)
Visual Basic
Public Overridable Sub sendNoSuchArgumentResponse ( _
    requestMsg As MCdimseMessage, _
    eventOrActionType As UShort _
)
Visual C++
public:
virtual void sendNoSuchArgumentResponse(
    MCdimseMessage^ requestMsg,
    unsigned short eventOrActionType
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
eventOrActionType
Type: System..::..UInt16
Optional event type Id or action type id.

Remarks

This response is sent when information sent with the request was not recognized.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendNoSuchAttributeResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendNoSuchAttributeResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0105.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoSuchAttributeResponse(
    MCdimseMessage requestMsg,
    uint[] attributeIdList
)
Visual Basic
Public Overridable Sub sendNoSuchAttributeResponse ( _
    requestMsg As MCdimseMessage, _
    attributeIdList As UInteger() _
)
Visual C++
public:
virtual void sendNoSuchAttributeResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ attributeIdList
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The DIMSE message being responded to.
attributeIdList
Type: array<System..::..UInt32>[]()[][]
A possibly-null array containing the tag numbers of the attribute(s) that were unknown.

Remarks

This response is sent when one or more of the requested attributes were unknown to the SCP. The attributes that could be modified, however, were modified.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendNoSuchEventTypeResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendNoSuchEventTypeResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0113.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoSuchEventTypeResponse(
    MCdimseMessage requestMsg,
    string affectedSopClassUid,
    ushort eventType
)
Visual Basic
Public Overridable Sub sendNoSuchEventTypeResponse ( _
    requestMsg As MCdimseMessage, _
    affectedSopClassUid As String, _
    eventType As UShort _
)
Visual C++
public:
virtual void sendNoSuchEventTypeResponse(
    MCdimseMessage^ requestMsg,
    String^ affectedSopClassUid,
    unsigned short eventType
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
affectedSopClassUid
Type: System..::..String
Optional affected SOP Class Uid.
eventType
Type: System..::..UInt16
Optional event type ID.

Remarks

This response is sent when the event type specified does not exist.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendNoSuchSopInstanceResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendNoSuchSopInstanceResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0112.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoSuchSopInstanceResponse(
    MCdimseMessage requestMsg,
    string affectedInstanceUid
)
Visual Basic
Public Overridable Sub sendNoSuchSopInstanceResponse ( _
    requestMsg As MCdimseMessage, _
    affectedInstanceUid As String _
)
Visual C++
public:
virtual void sendNoSuchSopInstanceResponse(
    MCdimseMessage^ requestMsg,
    String^ affectedInstanceUid
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.
affectedInstanceUid
Type: System..::..String
Optional UID of the instance involved.

Remarks

This response is sent when the SOP instance was not recognized. May be sent in response to: N-GET or N-SET or N-EVENT-REPORT requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendOptionalAttributesUnsupportedResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendOptionalAttributesUnsupportedResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0001.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendOptionalAttributesUnsupportedResponse(
    MCdimseMessage requestMsg,
    MCdataSet dataSet
)
Visual Basic
Public Overridable Sub sendOptionalAttributesUnsupportedResponse ( _
    requestMsg As MCdimseMessage, _
    dataSet As MCdataSet _
)
Visual C++
public:
virtual void sendOptionalAttributesUnsupportedResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ dataSet
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
dataSet
Type: Mergecom..::..MCdataSet
Optional dataset to set with the response.

Remarks

This status conveys that one or more optional attributes were unsupported. This is a Warning response.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendPendingResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendPendingResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00.
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00.

See Also

MCdimseService Class
MCdimseService Members


sendPendingResponse Method (MCdimseMessage, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendPendingResponse Method (MCdimseMessage, MCdataSet)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFF00.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendPendingResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier
)
Visual Basic
Public Overridable Sub sendPendingResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet _
)
Visual C++
public:
virtual void sendPendingResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
Contains the current matching values.

Remarks

This response is used to convey that the operation/notification is continuing and additional statuses are expected.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendPendingResponse Overload


sendPendingResponse Method (MCdimseMessage, UInt16, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendPendingResponse Method (MCdimseMessage, UInt16, UInt16, UInt16, UInt16)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFF00.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendPendingResponse(
    MCdimseMessage requestMsg,
    ushort remainingSubOperations,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendPendingResponse ( _
    requestMsg As MCdimseMessage, _
    remainingSubOperations As UShort, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendPendingResponse(
    MCdimseMessage^ requestMsg,
    unsigned short remainingSubOperations,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
remainingSubOperations
Type: System..::..UInt16
Remaining sub-operation count.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This response is used to convey that the operation/notification is continuing and additional statuses are expected.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendPendingResponse Overload


sendPendingResponseWithOptionalKeyWarning Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendPendingResponseWithOptionalKeyWarning Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xFF01.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendPendingResponseWithOptionalKeyWarning(
    MCdimseMessage requestMsg,
    MCdataSet identifier
)
Visual Basic
Public Overridable Sub sendPendingResponseWithOptionalKeyWarning ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet _
)
Visual C++
public:
virtual void sendPendingResponseWithOptionalKeyWarning(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
Contains the current matching values.

Remarks

This response is used to convey that the operation/notification is continuing and additional statuses are expected, but one or more optional keys were not supported.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendPPSnotInProgressResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendPPSnotInProgressResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA506.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendPPSnotInProgressResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendPPSnotInProgressResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendPPSnotInProgressResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The message being responded to.

Remarks

This status conveys that the action is refused because the related General Purpose Performed Procedure Step SOP Instance is not in the "IN PROGRESS" state.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendProcessingFailureResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendProcessingFailureResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110.

See Also

MCdimseService Class
MCdimseService Members


sendProcessingFailureResponse Method (MCdimseMessage, UInt32[], String, MCinstanceUid)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendProcessingFailureResponse Method (MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0110.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment,
    MCinstanceUid affectedInstance
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String, _
    affectedInstance As MCinstanceUid _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment,
    MCinstanceUid^ affectedInstance
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null elements involved with the error.
errorComment
Type: System..::..String
Possibly null error description.
affectedInstance
Type: Mergecom..::..MCinstanceUid
SOP Instance UID of the affected instance. Cannot be null.

Remarks

This response is sent when a general failure in processing the operation was encountered.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendProcessingFailureResponse Overload


sendProcessingFailureResponse Method (String, UInt16, UInt32[], String, MCinstanceUid)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendProcessingFailureResponse Method (String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0110.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    string reqServiceName,
    ushort reqCommand,
    uint[] offendingElements,
    string errorComment,
    MCinstanceUid affectedInstance
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    reqServiceName As String, _
    reqCommand As UShort, _
    offendingElements As UInteger(), _
    errorComment As String, _
    affectedInstance As MCinstanceUid _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    String^ reqServiceName,
    unsigned short reqCommand,
    array<unsigned int>^ offendingElements,
    String^ errorComment,
    MCinstanceUid^ affectedInstance
)

Parameters

reqServiceName
Type: System..::..String
The request message service being responded to.
reqCommand
Type: System..::..UInt16
The request message command being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null elements involved with the error.
errorComment
Type: System..::..String
Possibly null error description.
affectedInstance
Type: Mergecom..::..MCinstanceUid
SOP Instance UID of the affected instance. Cannot be null.

Remarks

This response is sent when a general failure in processing the operation was encountered.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for reqServiceName.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service denoted by reqServiceName is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members
sendProcessingFailureResponse Overload


sendProcessingFailureResponse Method (MCdimseMessage, UInt16, UInt32[], String, MCinstanceUid)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendProcessingFailureResponse Method (MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0110.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    ushort errorId,
    uint[] offendingElements,
    string errorComment,
    MCinstanceUid affectedInstance
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    errorId As UShort, _
    offendingElements As UInteger(), _
    errorComment As String, _
    affectedInstance As MCinstanceUid _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    unsigned short errorId,
    array<unsigned int>^ offendingElements,
    String^ errorComment,
    MCinstanceUid^ affectedInstance
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
errorId
Type: System..::..UInt16
Error identification number.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Possibly null list of elements involved with the error.
errorComment
Type: System..::..String
Possibly null error description.
affectedInstance
Type: Mergecom..::..MCinstanceUid
SOP Instance UID of the affected instance. Cannot be null.

Remarks

This response is sent when a general failure in processing the operation was encountered.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid, the message was null or the error identification number was not greater than zero.

See Also

MCdimseService Class
MCdimseService Members
sendProcessingFailureResponse Overload


sendRefusedOutOfResourcesResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRefusedOutOfResourcesResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA700.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRefusedOutOfResourcesResponse(
    MCdimseMessage requestMsg,
    string errorComment
)
Visual Basic
Public Overridable Sub sendRefusedOutOfResourcesResponse ( _
    requestMsg As MCdimseMessage, _
    errorComment As String _
)
Visual C++
public:
virtual void sendRefusedOutOfResourcesResponse(
    MCdimseMessage^ requestMsg,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
errorComment
Type: System..::..String
Error description.

Remarks

This message is sent to indicate the operation could not be performed due to lack of resources.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendRequestMessage Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner.
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner.

See Also

MCdimseService Class
MCdimseService Members


sendRequestMessage Method (MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method (MCdimseMessage)
MCdimseService Class See Also Send Feedback
Sends a DIMSE request message to the association partner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRequestMessage(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Sub sendRequestMessage ( _
    msg As MCdimseMessage _
)
Visual C++
public:
virtual void sendRequestMessage(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The message to be sent.

Remarks

This method sends a request message to the remote application. The message must have its service and command set, and the msg command must be a valid DIMSE request command. The message will be sent across the association declared when this MCdimseService was constructed.

NOTE: This method (and the sendResponseMessage(MCdimseMessage, UInt16) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Message ID attribute (0000,0110) value is set to a unique number for this association.
  • If the message command requires it, the Priority attribute (0000,0700) value is set to "medium" priority (i.e. zero).
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

The affectedSopInstanceUID parameter for some variations of this method is optional. If it is null or if it is an empty string, it will be ignored. Not all DICOM services require this attribute. If it is specified, it will be encoded in the message's command set in attribute (0000,1000).

The metaServiceName parameter included in some variations to this method is also optional. If it is null or it if is an empty string, it will be ignored. Some DICOM services (e.g. the Basic Print Service) allow you to support multiple meta services. Each meta service consists of a set of basic DICOM services. In some cases a DICOM application may support multiple meta services over the same association. When two of the meta services include the same basic service, this metaServiceName parameter is used to tell the Merge DICOM toolkit which meta service to use when sending the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was null.

See Also

MCdimseService Class
MCdimseService Members
sendRequestMessage Overload


sendRequestMessage Method (String, MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method (String, MCdimseMessage)
MCdimseService Class See Also Send Feedback
Sends a DIMSE request message to the association partner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRequestMessage(
    string metaServiceName,
    MCdimseMessage msg
)
Visual Basic
Public Overridable Sub sendRequestMessage ( _
    metaServiceName As String, _
    msg As MCdimseMessage _
)
Visual C++
public:
virtual void sendRequestMessage(
    String^ metaServiceName,
    MCdimseMessage^ msg
)

Parameters

metaServiceName
Type: System..::..String
The meta service name for the message (may be null).
msg
Type: Mergecom..::..MCdimseMessage
The message to be sent.

Remarks

This method sends a request message to the remote application. The msg must have its service and command set, and the msg command must be a valid DIMSE request command. The message will be sent across the association declared when this MCdimseService was constructed.

NOTE: This method (and the sendResponseMessage(MCdimseMessage, UInt16) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Message ID attribute (0000,0110) value is set to a unique number for this association.
  • If the message command requires it, the Priority attribute (0000,0700) value is set to "medium" priority (i.e. zero).
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

The affectedSopInstanceUID parameter for some variations of this method is optional. If it is null or if it is an empty string, it will be ignored. Not all DICOM services require this attribute. If it is specified, it will be encoded in the message's command set in attribute (0000,1000).

The metaServiceName parameter included in some variations to this method is also optional. If it is null or it if is an empty string, it will be ignored. Some DICOM services (e.g. the Basic Print Service) allow you to support multiple meta services. Each meta service consists of a set of basic DICOM services. In some cases a DICOM application may support multiple meta services over the same association. When two of the meta services include the same basic service, this metaServiceName parameter is used to tell the Merge DICOM toolkit which meta service to use when sending the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was null.

See Also

MCdimseService Class
MCdimseService Members
sendRequestMessage Overload


sendRequestMessage Method (MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method (MCdimseMessage, String)
MCdimseService Class See Also Send Feedback
Sends a DIMSE request message to the association partner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRequestMessage(
    MCdimseMessage msg,
    string affectedSopInstanceUID
)
Visual Basic
Public Overridable Sub sendRequestMessage ( _
    msg As MCdimseMessage, _
    affectedSopInstanceUID As String _
)
Visual C++
public:
virtual void sendRequestMessage(
    MCdimseMessage^ msg,
    String^ affectedSopInstanceUID
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The message to send.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID

Remarks

This method sends a request message to the remote application. The msg must have its service and command set, and the msg command must be a valid DIMSE request command. The message will be sent across the association declared when this MCdimseService was constructed.

NOTE: This method (and the sendResponseMessage(MCdimseMessage, UInt16) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Message ID attribute (0000,0110) value is set to a unique number for this association.
  • If the message command requires it, the Priority attribute (0000,0700) value is set to "medium" priority (i.e. zero).
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

The affectedSopInstanceUID parameter for some variations of this method is optional. If it is null or if it is an empty string, it will be ignored. Not all DICOM services require this attribute. If it is specified, it will be encoded in the message's command set in attribute (0000,1000).

The metaServiceName parameter included in some variations to this method is also optional. If it is null or it if is an empty string, it will be ignored. Some DICOM services (e.g. the Basic Print Service) allow you to support multiple meta services. Each meta service consists of a set of basic DICOM services. In some cases a DICOM application may support multiple meta services over the same association. When two of the meta services include the same basic service, this metaServiceName parameter is used to tell the Merge DICOM toolkit which meta service to use when sending the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was null.

See Also

MCdimseService Class
MCdimseService Members
sendRequestMessage Overload


sendRequestMessage Method (String, MCdataSource, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method (String, MCdataSource, String)
MCdimseService Class See Also Send Feedback
Sends a DIMSE request message to the association partner, providing the stream for message data to send

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRequestMessage(
    string metaServiceName,
    MCdataSource dataSource,
    string name
)
Visual Basic
Public Overridable Sub sendRequestMessage ( _
    metaServiceName As String, _
    dataSource As MCdataSource, _
    name As String _
)
Visual C++
public:
virtual void sendRequestMessage(
    String^ metaServiceName,
    MCdataSource^ dataSource,
    String^ name
)

Parameters

metaServiceName
Type: System..::..String
The meta service name for the message (may be null).
dataSource
Type: Mergecom..::..MCdataSource
The data source for the message to send.
name
Type: System..::..String
The name of data source (may be null).

Remarks

This method sends a request message to the remote application. The stream data must be a valid DIMSE message. The message will be sent across the association declared when this MCdimseService was constructed.

NOTE: This method (and the sendResponseMessage(MCdimseMessage, UInt16) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when the data are sent.

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Message ID attribute (0000,0110) value is set to a unique number for this association.
  • If the message command requires it, the Priority attribute (0000,0700) value is set to "medium" priority (i.e. zero).
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

The metaServiceName parameter included in some variations to this method is also optional. If it is null or it if is an empty string, it will be ignored. Some DICOM services (e.g. the Basic Print Service) allow you to support multiple meta services. Each meta service consists of a set of basic DICOM services. In some cases a DICOM application may support multiple meta services over the same association. When two of the meta services include the same basic service, this metaServiceName parameter is used to tell the Merge DICOM toolkit which meta service to use when sending the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was null.

See Also

MCdimseService Class
MCdimseService Members
sendRequestMessage Overload


sendRequestMessage Method (String, MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendRequestMessage Method (String, MCdimseMessage, String)
MCdimseService Class See Also Send Feedback
Sends a DIMSE request message to the association partner.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRequestMessage(
    string metaServiceName,
    MCdimseMessage msg,
    string affectedSopInstanceUID
)
Visual Basic
Public Overridable Sub sendRequestMessage ( _
    metaServiceName As String, _
    msg As MCdimseMessage, _
    affectedSopInstanceUID As String _
)
Visual C++
public:
virtual void sendRequestMessage(
    String^ metaServiceName,
    MCdimseMessage^ msg,
    String^ affectedSopInstanceUID
)

Parameters

metaServiceName
Type: System..::..String
The meta service name for the message (may be null).
msg
Type: Mergecom..::..MCdimseMessage
The message to send.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.

Remarks

This method sends a request message to the remote application. The msg must have its service and command set, and the msg command must be a valid DIMSE request command. The message will be sent across the association declared when this MCdimseService was constructed.

NOTE: This method (and the sendResponseMessage(MCdimseMessage, UInt16) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Message ID attribute (0000,0110) value is set to a unique number for this association.
  • If the message command requires it, the Priority attribute (0000,0700) value is set to "medium" priority (i.e. zero).
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

The affectedSopInstanceUID parameter for some variations of this method is optional. If it is null or if it is an empty string, it will be ignored. Not all DICOM services require this attribute. If it is specified, it will be encoded in the message's command set in attribute (0000,1000).

The metaServiceName parameter included in some variations to this method is also optional. If it is null or it if is an empty string, it will be ignored. Some DICOM services (e.g. the Basic Print Service) allow you to support multiple meta services. Each meta service consists of a set of basic DICOM services. In some cases a DICOM application may support multiple meta services over the same association. When two of the meta services include the same basic service, this metaServiceName parameter is used to tell the Merge DICOM toolkit which meta service to use when sending the message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was null.

See Also

MCdimseService Class
MCdimseService Members
sendRequestMessage Overload


sendResourceLimitationResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResourceLimitationResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0213.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResourceLimitationResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendResourceLimitationResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendResourceLimitationResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status is sent when the operation was not performed due to resource limitation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCdimseService Class
MCdimseService Members


sendResponseMessage Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application.
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application.

See Also

MCdimseService Class
MCdimseService Members


sendResponseMessage Method (MCdimseMessage, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method (MCdimseMessage, UInt16)
MCdimseService Class See Also Send Feedback
Allows the caller to respond to a message received from the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResponseMessage(
    MCdimseMessage requestMsg,
    ushort statusCode
)
Visual Basic
Public Overridable Sub sendResponseMessage ( _
    requestMsg As MCdimseMessage, _
    statusCode As UShort _
)
Visual C++
public:
virtual void sendResponseMessage(
    MCdimseMessage^ requestMsg,
    unsigned short statusCode
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
statusCode
Type: System..::..UInt16
The status code for the response.

Remarks

This method is called after a successful read(Int64) call.

NOTE: This method (and the sendRequestMessage(MCdimseMessage) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

statusCode provides the status of the requested operation and must be a valid response code for the service involved. Response codes are defined in the MCdimseService class. Many DICOM services do not require a response of more than just a status. Others, however, (e.g. C_FIND_RSP) require the setting of several message attributes.

responseMsg, if provided, must have been constructed for the same service as the requestMsg, and for an appropriate command. For example, if responding to a C-STORE request message, the responseMsg would be constructed as follows:

responseMsg = new MCdimseMessage(C_STORE_RSP, requestMsg.ServiceName);

If responseMsg is not provided, the Merge DICOM toolkit will construct one for you.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Response Message ID attribute (0000,0120) value is set to the message ID of the last received Request message for this association.
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the request message was null.

See Also

MCdimseService Class
MCdimseService Members
sendResponseMessage Overload


sendResponseMessage Method (String, MCdimseMessage, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method (String, MCdimseMessage, UInt16)
MCdimseService Class See Also Send Feedback
Allows the caller to respond to a message received from the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResponseMessage(
    string reqServiceName,
    MCdimseMessage responseMsg,
    ushort statusCode
)
Visual Basic
Public Overridable Sub sendResponseMessage ( _
    reqServiceName As String, _
    responseMsg As MCdimseMessage, _
    statusCode As UShort _
)
Visual C++
public:
virtual void sendResponseMessage(
    String^ reqServiceName,
    MCdimseMessage^ responseMsg,
    unsigned short statusCode
)

Parameters

reqServiceName
Type: System..::..String
The service name of the request message
responseMsg
Type: Mergecom..::..MCdimseMessage
The response message
statusCode
Type: System..::..UInt16
The status code for the response.

Remarks

This method is called after a successful read(Int64) call.

NOTE: This method (and the sendRequestMessage(MCdimseMessage) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

statusCode provides the status of the requested operation and must be a valid response code for the service involved. Response codes are defined in the MCdimseService class. Many DICOM services do not require a response of more than just a status. Others, however, (e.g. C_FIND_RSP) require the setting of several message attributes.

responseMsg, if provided, must have been constructed for the same service as the requestMsg, and for an appropriate command. For example, if responding to a C-STORE request message, the responseMsg would be constructed as follows:

responseMsg = new MCdimseMessage(C_STORE_RSP, reqServiceName);

If responseMsg is not provided, the Merge DICOM toolkit will construct one for you.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Response Message ID attribute (0000,0120) value is set to the message ID of the last received Request message for this association.
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for the request message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The reqServiceNameis not one that was negotiated for the association, or is null.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or responseMsg was null.

See Also

MCdimseService Class
MCdimseService Members
sendResponseMessage Overload


sendResponseMessage Method (String, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method (String, UInt16, UInt16)
MCdimseService Class See Also Send Feedback
Allows the caller to respond to a message received from the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResponseMessage(
    string reqServiceName,
    ushort reqCommand,
    ushort statusCode
)
Visual Basic
Public Overridable Sub sendResponseMessage ( _
    reqServiceName As String, _
    reqCommand As UShort, _
    statusCode As UShort _
)
Visual C++
public:
virtual void sendResponseMessage(
    String^ reqServiceName,
    unsigned short reqCommand,
    unsigned short statusCode
)

Parameters

reqServiceName
Type: System..::..String
The service name of the request message
reqCommand
Type: System..::..UInt16
The command of the request message
statusCode
Type: System..::..UInt16
The status code for the response.

Remarks

This method is called after a successful read(Int64) call.

NOTE: This method (and the sendRequestMessage(MCdimseMessage) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

statusCode provides the status of the requested operation and must be a valid response code for the service involved. Response codes are defined in the MCdimseService class. Many DICOM services do not require a response of more than just a status. Others, however, (e.g. C_FIND_RSP) require the setting of several message attributes.

responseMsg, if provided, must have been constructed for the same service as the requestMsg, and for an appropriate command. For example, if responding to a C-STORE request message, the responseMsg would be constructed as follows:

responseMsg = new MCdimseMessage(C_STORE_RSP, requestMsg.ServiceName);

If responseMsg is not provided, the Merge DICOM toolkit will construct one for you.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Response Message ID attribute (0000,0120) value is set to the message ID of the last received Request message for this association.
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for the request message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The reqServiceName is not one that was negotiated for the association, or is null.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid

See Also

MCdimseService Class
MCdimseService Members
sendResponseMessage Overload


sendResponseMessage Method (UInt16, MCdataSource, String)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method (UInt16, MCdataSource, String)
MCdimseService Class See Also Send Feedback
Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResponseMessage(
    ushort statusCode,
    MCdataSource dataSource,
    string name
)
Visual Basic
Public Overridable Sub sendResponseMessage ( _
    statusCode As UShort, _
    dataSource As MCdataSource, _
    name As String _
)
Visual C++
public:
virtual void sendResponseMessage(
    unsigned short statusCode,
    MCdataSource^ dataSource,
    String^ name
)

Parameters

statusCode
Type: System..::..UInt16
The status code for the response.
dataSource
Type: Mergecom..::..MCdataSource
The data source for the message to send.
name
Type: System..::..String
The name of data source (may be null).

Remarks

This method is called after a successful read(Int64) call.

NOTE: This method (and the sendRequestMessage(MCdimseMessage) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

statusCode provides the status of the requested operation and must be a valid response code for the service involved. Response codes are defined in the MCdimseService class. Many DICOM services do not require a response of more than just a status. Others, however, (e.g. C_FIND_RSP) require the setting of several message attributes.

dataSource, if provided, must have the same service as the requestMsg, and for an appropriate command. For example, if responding to a C-STORE request message, the responseMsg must have C_STORE_RSP command. If dataSource is not provided, MCillegalArgumentException will be thrown.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when the stream data are sent. This method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Response Message ID attribute (0000,0120) value is set to the message ID of the last received Request message for this association.
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for the request message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or is null.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or dataSource was null.

See Also

MCdimseService Class
MCdimseService Members
sendResponseMessage Overload


sendResponseMessage Method (MCdimseMessage, MCdimseMessage, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendResponseMessage Method (MCdimseMessage, MCdimseMessage, UInt16)
MCdimseService Class See Also Send Feedback
Allows the caller to respond to a message received from the remote application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendResponseMessage(
    MCdimseMessage requestMsg,
    MCdimseMessage responseMsg,
    ushort statusCode
)
Visual Basic
Public Overridable Sub sendResponseMessage ( _
    requestMsg As MCdimseMessage, _
    responseMsg As MCdimseMessage, _
    statusCode As UShort _
)
Visual C++
public:
virtual void sendResponseMessage(
    MCdimseMessage^ requestMsg,
    MCdimseMessage^ responseMsg,
    unsigned short statusCode
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
responseMsg
Type: Mergecom..::..MCdimseMessage
The response message
statusCode
Type: System..::..UInt16
The status code for the response.

Remarks

This method is called after a successful read(Int64) call.

NOTE: This method (and the sendRequestMessage(MCdimseMessage) method) are normally used by advanced users. Sub-classes of this class provide send message commands that enforce the rules of specific DICOM service classes.

statusCode provides the status of the requested operation and must be a valid response code for the service involved. Response codes are defined in the MCdimseService class. Many DICOM services do not require a response of more than just a status. Others, however, (e.g. C_FIND_RSP) require the setting of several message attributes.

responseMsg, if provided, must have been constructed for the same service as the requestMsg, and for an appropriate command. For example, if responding to a C-STORE request message, the responseMsg would be constructed as follows:

responseMsg = new MCdimseMessage(C_STORE_RSP, requestMsg.ServiceName);

If responseMsg is not provided, the Merge DICOM toolkit will construct one for you.

NOTE: Some DICOM services require that values for certain command set attributes (i.e. group 0 attributes) be set. The Merge DICOM toolkit automatically adds command set attributes when an MCdimseMessage is constructed. With the exceptions listed below, you must set any command set attribute values before sending the message. However, this method will set the following attribute values for you if you have not set them:

  • The group length attribute (0000,0000) value is always set by the Merge DICOM toolkit.
  • If the message command requires it, the Affected SOP Class UID attribute (0000,0002) value is set to the service's abstract syntax UID.
  • The command attribute (0000,0100) value is always set by the Merge DICOM toolkit.
  • The Response Message ID attribute (0000,0120) value is set to the message ID of the last received Request message for this association.
  • The Data Set Type attribute (0000,0800) value is always set by the Merge DICOM toolkit.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or one of the messages was null.

See Also

MCdimseService Class
MCdimseService Members
sendResponseMessage Overload


sendSPSnotInProgressResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendSPSnotInProgressResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA504.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSPSnotInProgressResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendSPSnotInProgressResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendSPSnotInProgressResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status conveys that the action is refused because the related General Purpose Scheduled Procedure Step SOP Instance is not in the "IN PROGRESS" state.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendSuccessResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendSuccessResponse Method
MCdimseService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000.
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000.

See Also

MCdimseService Class
MCdimseService Members


sendSuccessResponse Method (MCdimseMessage, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendSuccessResponse Method (MCdimseMessage, MCdataSet)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0000.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    MCdimseMessage requestMsg,
    MCdataSet dataSet
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    requestMsg As MCdimseMessage, _
    dataSet As MCdataSet _
)
Visual C++
public:
virtual void sendSuccessResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ dataSet
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
dataSet
Type: Mergecom..::..MCdataSet
Optional dataset to send with the response.

Remarks

This status conveys that the operation/notification completed successfully.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members
sendSuccessResponse Overload


sendSuccessResponse Method (String, UInt16, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendSuccessResponse Method (String, UInt16, MCdataSet)
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0000.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    string reqServiceName,
    ushort reqCommand,
    MCdataSet dataSet
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    reqServiceName As String, _
    reqCommand As UShort, _
    dataSet As MCdataSet _
)
Visual C++
public:
virtual void sendSuccessResponse(
    String^ reqServiceName,
    unsigned short reqCommand,
    MCdataSet^ dataSet
)

Parameters

reqServiceName
Type: System..::..String
The service name of the request message
reqCommand
Type: System..::..UInt16
The command of the request message
dataSet
Type: Mergecom..::..MCdataSet
Optional dataset to send with the response.

Remarks

This status conveys that the operation/notification completed successfully.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for the request message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The reqServiceName is not one that was negotiated for the association, or is null
Mergecom.Exceptions..::..MCillegalArgumentException | The reqCommand is invalid.

See Also

MCdimseService Class
MCdimseService Members
sendSuccessResponse Overload


sendUnmatchedTransactionUidResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendUnmatchedTransactionUidResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA505.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendUnmatchedTransactionUidResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendUnmatchedTransactionUidResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendUnmatchedTransactionUidResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status conveys that the action is refused because Referenced General Purpose Scheduled Procedure Step Transaction UID does not match the Transaction UID of the N-ACTION request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendUnrecognizedOperationResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendUnrecognizedOperationResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0x0211.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendUnrecognizedOperationResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendUnrecognizedOperationResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendUnrecognizedOperationResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status is sent when the operation is not one of those agreed between the DIMSE-service-users.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


sendWrongTransactionIdResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..sendWrongTransactionIdResponse Method
MCdimseService Class See Also Send Feedback
Sends a Response message with a status of 0xA502.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendWrongTransactionIdResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendWrongTransactionIdResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendWrongTransactionIdResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This status conveys that the action is refused because the wrong Transaction UID is used.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCdimseService Class
MCdimseService Members


MCdimseService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdimseService Properties
MCdimseService Class See Also Send Feedback

The MCdimseService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running.

See Also

MCdimseService Class


Association Property

[image]

Merge DICOM .NET/C# Toolkit
MCdimseService..::..Association Property
MCdimseService Class See Also Send Feedback
Retrieves the association on which this service is running.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCassociation Association { get; }
Visual Basic
Public Overridable ReadOnly Property Association As MCassociation
    Get
Visual C++
public:
virtual property MCassociation^ Association {
    MCassociation^ get ();
}

Field Value

The associated MCassociation object.

See Also

MCdimseService Class
MCdimseService Members


MCdir Class

[image]

Merge DICOM .NET/C# Toolkit
MCdir Class
Members See Also Send Feedback
Represents a DICOMDIR directory file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdir : MCfile
Visual Basic
Public Class MCdir _
    Inherits MCfile
Visual C++
public ref class MCdir : public MCfile

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCabstractMessage
Mergecom..::..MCfile
Mergecom..::..MCdir

See Also

MCdir Members


MCdir Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdir Members
MCdir Class Constructors Methods Properties See Also Send Feedback

The MCdir type exposes the following members.

Constructors

 | Name | Description
Public method | MCdir()()()() | Initializes a new instance of this class.
Public method | MCdir(String) | Constructs a new MCdir object.

Methods

 | Name | Description
Public method | close | Closes this dicomdir file. (Overrides MCfile..::..close()()()().)
Public method | dispose | Cleans up all native resources used by this file. (Inherited from MCfile.)
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor for the class. (Inherited from MCfile.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the associated DICOMDIR file to the console output. (Overrides MCfile..::..list()()()().)
Public method | list(TextWriter) | Lists the contents of this DICOMDIR file. (Overrides MCfile..::..list(TextWriter).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeFileValues | Empties the values of all the attributes in the contained data set and file meta info set. (Inherited from MCfile.)
Public method | setServiceCommand | Sets the service name and command associated with the contained data set. (Inherited from MCfile.)
Public method | streamLength | Calculates the number of bytes it would take to stream out this file. (Inherited from MCfile.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

Properties

 | Name | Description
Public property | Command | Gets the DIMSE Command for this file. (Inherited from MCfile.)
Public property | DataSet | Gets the data set contained in this file object. (Inherited from MCfile.)
Public property | FileName | Gets or sets the file name associated with this object. (Inherited from MCfile.)
Public property | MetaInfo | Gets the Meta Information for this file. (Inherited from MCfile.)
Public property | Preamble | Sets or gets the file preamble for contained in the meta information of this file. (Inherited from MCfile.)
Public property | Root | Gets the root record for this dicomdir.
Public property | ServiceName | Sets or gets the name of the service associated with this DIMSE message. (Inherited from MCfile.)
Public property | TransferSyntaxUid | Sets or gets the Transfer Syntax UID that the DICOM file is encoded in. (Inherited from MCfile.)

See Also

MCdir Class


MCdir Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdir Constructor
MCdir Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdir()()()() | Initializes a new instance of this class.
Public method | MCdir(String) | Constructs a new MCdir object.

See Also

MCdir Class
MCdir Members


MCdir Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdir Constructor
MCdir Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdir()
Visual Basic
Public Sub New
Visual C++
public:
MCdir()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdir Class
MCdir Members
MCdir Overload


MCdir Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdir Constructor (String)
MCdir Class See Also Send Feedback
Constructs a new MCdir object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdir(
    string fileName
)
Visual Basic
Public Sub New ( _
    fileName As String _
)
Visual C++
public:
MCdir(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The full path to a DICOMDIR file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The file name was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCdir Class
MCdir Members
MCdir Overload


MCdir Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdir Methods
MCdir Class See Also Send Feedback

The MCdir type exposes the following members.

Methods

 | Name | Description
Public method | close | Closes this dicomdir file. (Overrides MCfile..::..close()()()().)
Public method | dispose | Cleans up all native resources used by this file. (Inherited from MCfile.)
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor for the class. (Inherited from MCfile.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the associated DICOMDIR file to the console output. (Overrides MCfile..::..list()()()().)
Public method | list(TextWriter) | Lists the contents of this DICOMDIR file. (Overrides MCfile..::..list(TextWriter).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeFileValues | Empties the values of all the attributes in the contained data set and file meta info set. (Inherited from MCfile.)
Public method | setServiceCommand | Sets the service name and command associated with the contained data set. (Inherited from MCfile.)
Public method | streamLength | Calculates the number of bytes it would take to stream out this file. (Inherited from MCfile.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

See Also

MCdir Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCdir..::..close Method
MCdir Class See Also Send Feedback
Closes this dicomdir file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void close()
Visual Basic
Public Overrides Sub close
Visual C++
public:
virtual void close() override

See Also

MCdir Class
MCdir Members


list Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdir..::..list Method
MCdir Class See Also Send Feedback

Overload List

 | Name | Description
Public method | list()()()() | Lists the contents of the associated DICOMDIR file to the console output. (Overrides MCfile..::..list()()()().)
Public method | list(TextWriter) | Lists the contents of this DICOMDIR file. (Overrides MCfile..::..list(TextWriter).)

See Also

MCdir Class
MCdir Members


list Method

[image]

Merge DICOM .NET/C# Toolkit
MCdir..::..list Method
MCdir Class See Also Send Feedback
Lists the contents of the associated DICOMDIR file to the console output.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void list()
Visual Basic
Public Overrides Sub list
Visual C++
public:
virtual void list() override

See Also

MCdir Class
MCdir Members
list Overload


list Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCdir..::..list Method (TextWriter)
MCdir Class See Also Send Feedback
Lists the contents of this DICOMDIR file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void list(
    TextWriter destination
)
Visual Basic
Public Overrides Sub list ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void list(
    TextWriter^ destination
) override

Parameters

destination
Type: System.IO..::..TextWriter
A TextWriter object that will receive the list output.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The destination was null.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCdir Class
MCdir Members
list Overload


MCdir Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdir Properties
MCdir Class See Also Send Feedback

The MCdir type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the DIMSE Command for this file. (Inherited from MCfile.)
Public property | DataSet | Gets the data set contained in this file object. (Inherited from MCfile.)
Public property | FileName | Gets or sets the file name associated with this object. (Inherited from MCfile.)
Public property | MetaInfo | Gets the Meta Information for this file. (Inherited from MCfile.)
Public property | Preamble | Sets or gets the file preamble for contained in the meta information of this file. (Inherited from MCfile.)
Public property | Root | Gets the root record for this dicomdir.
Public property | ServiceName | Sets or gets the name of the service associated with this DIMSE message. (Inherited from MCfile.)
Public property | TransferSyntaxUid | Sets or gets the Transfer Syntax UID that the DICOM file is encoded in. (Inherited from MCfile.)

See Also

MCdir Class


Root Property

[image]

Merge DICOM .NET/C# Toolkit
MCdir..::..Root Property
MCdir Class See Also Send Feedback
Gets the root record for this dicomdir.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdirRecord Root { get; }
Visual Basic
Public ReadOnly Property Root As MCdirRecord
    Get
Visual C++
public:
property MCdirRecord^ Root {
    MCdirRecord^ get ();
}

Field Value

An MCdirRecord object that can be used to get all top level records in the dicomdir.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdir Class
MCdir Members


MCdirRecord Class

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord Class
Members See Also Send Feedback
Represents a DICOMDIR record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdirRecord
Visual Basic
Public Class MCdirRecord
Visual C++
public ref class MCdirRecord

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdirRecord

See Also

MCdirRecord Members


MCdirRecord Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdirRecord Members
MCdirRecord Class Methods Properties See Also Send Feedback

The MCdirRecord type exposes the following members.

Methods

 | Name | Description
Public method | addChildRecord | Adds a lower level directory record to the current record.
Public method | delete | Deletes this directory record and any entities it references.
Public method | deleteChildren | Deletes all lower level directory records.
Public method | Equals | Determines whether two MCdirRecord instances represent the same dicomdir record. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildCount | Returns the number of child records of the current record.
Public method | getFirstChild | Gets the first lower level record.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getNextChild | Gets the next lower level directory record.
Public method | getReferencedRecordCount | Returns a count of the number of items contained "below" this record.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this record including all child records to the console output.
Public method | list(TextWriter) | Lists the contents of this record including all child records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this record. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Directory | The DICOMDIR object containing this record.
Public property | IsLast | Tells whether this record is the last child of the parent record.
Public property | Parent | The parent of the current directory record.
Public property | RecordItem | Gets the item that contains the attributes of this record.
Public property | RecordName | The name assigned to this record.

See Also

MCdirRecord Class


MCdirRecord Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdirRecord Methods
MCdirRecord Class See Also Send Feedback

The MCdirRecord type exposes the following members.

Methods

 | Name | Description
Public method | addChildRecord | Adds a lower level directory record to the current record.
Public method | delete | Deletes this directory record and any entities it references.
Public method | deleteChildren | Deletes all lower level directory records.
Public method | Equals | Determines whether two MCdirRecord instances represent the same dicomdir record. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getChildCount | Returns the number of child records of the current record.
Public method | getFirstChild | Gets the first lower level record.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getNextChild | Gets the next lower level directory record.
Public method | getReferencedRecordCount | Returns a count of the number of items contained "below" this record.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this record including all child records to the console output.
Public method | list(TextWriter) | Lists the contents of this record including all child records.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this record. (Overrides Object..::..ToString()()()().)

See Also

MCdirRecord Class


addChildRecord Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..addChildRecord Method
MCdirRecord Class See Also Send Feedback
Adds a lower level directory record to the current record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdirRecord addChildRecord(
    string newItemName
)
Visual Basic
Public Function addChildRecord ( _
    newItemName As String _
) As MCdirRecord
Visual C++
public:
MCdirRecord^ addChildRecord(
    String^ newItemName
)

Parameters

newItemName
Type: System..::..String
The name of the record item to be created. See RecordName property for possible values.

Return Value

An MCdirRecord object representing the newly added child record.

Remarks

The name provided is used to access configuration information which describes the attributes of the new directory record. If such configuration information is not available, an empty item object is created, and a warning message is logged.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCinvalidDirRecordTypeException | The directory record type specified is an invalid lower level type for the current directory record.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members


delete Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..delete Method
MCdirRecord Class See Also Send Feedback
Deletes this directory record and any entities it references.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void delete()
Visual Basic
Public Sub delete
Visual C++
public:
void delete()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdirRecord Class
MCdirRecord Members


deleteChildren Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..deleteChildren Method
MCdirRecord Class See Also Send Feedback
Deletes all lower level directory records.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void deleteChildren()
Visual Basic
Public Sub deleteChildren
Visual C++
public:
void deleteChildren()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdirRecord Class
MCdirRecord Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..Equals Method
MCdirRecord Class See Also Send Feedback
Determines whether two MCdirRecord instances represent the same dicomdir record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current record.

Return Value

true if the specified Object is an MCdirRecord and it represents the same record of the same dicomdir object as the current object.

See Also

MCdirRecord Class
MCdirRecord Members


getChildCount Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..getChildCount Method
MCdirRecord Class See Also Send Feedback
Returns the number of child records of the current record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int getChildCount()
Visual Basic
Public Function getChildCount As Integer
Visual C++
public:
int getChildCount()

Return Value

An integer representing the number of child records.

Remarks

The count returned is maintained internally whenever records are added or deleted from a DICOMDIR. Because this count is maintained internally, there is no performance penalty associated with this function call.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members


getFirstChild Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..getFirstChild Method
MCdirRecord Class See Also Send Feedback
Gets the first lower level record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdirRecord getFirstChild()
Visual Basic
Public Function getFirstChild As MCdirRecord
Visual C++
public:
MCdirRecord^ getFirstChild()

Return Value

An MCdirRecord representing the lower level record or null if the current record does not have child records.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..GetHashCode Method
MCdirRecord Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCdirRecord Class
MCdirRecord Members


getNextChild Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..getNextChild Method
MCdirRecord Class See Also Send Feedback
Gets the next lower level directory record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdirRecord getNextChild()
Visual Basic
Public Function getNextChild As MCdirRecord
Visual C++
public:
MCdirRecord^ getNextChild()

Return Value

An MCdirRecord representing the next lower level record or null if the current record does not have more lower level records.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members


getReferencedRecordCount Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..getReferencedRecordCount Method
MCdirRecord Class See Also Send Feedback
Returns a count of the number of items contained "below" this record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int getReferencedRecordCount()
Visual Basic
Public Function getReferencedRecordCount As Integer
Visual C++
public:
int getReferencedRecordCount()

Return Value

An integer representing the number of sub-items.

Remarks

The count returned is computed during this function call. Because this count is generated on the fly, there is a performance penalty associated with this call. During this call, each record referenced by this record is traversed, and the total number of items is generated.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members


list Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..list Method
MCdirRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | list()()()() | Lists the contents of this record including all child records to the console output.
Public method | list(TextWriter) | Lists the contents of this record including all child records.

See Also

MCdirRecord Class
MCdirRecord Members


list Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..list Method
MCdirRecord Class See Also Send Feedback
Lists the contents of this record including all child records to the console output.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list()
Visual Basic
Public Overridable Sub list
Visual C++
public:
virtual void list()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members
list Overload


list Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..list Method (TextWriter)
MCdirRecord Class See Also Send Feedback
Lists the contents of this record including all child records.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list(
    TextWriter destination
)
Visual Basic
Public Overridable Sub list ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void list(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
A TextWriter that will receive the list output.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | The Merge DICOM toolkit found a corrupted record ID in a directory record offset attribute while trying to traverse the DICOMDIR.

See Also

MCdirRecord Class
MCdirRecord Members
list Overload


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..ToString Method
MCdirRecord Class See Also Send Feedback
Returns a string representation of this record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that describes this record.

See Also

MCdirRecord Class
MCdirRecord Members


MCdirRecord Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdirRecord Properties
MCdirRecord Class See Also Send Feedback

The MCdirRecord type exposes the following members.

Properties

 | Name | Description
Public property | Directory | The DICOMDIR object containing this record.
Public property | IsLast | Tells whether this record is the last child of the parent record.
Public property | Parent | The parent of the current directory record.
Public property | RecordItem | Gets the item that contains the attributes of this record.
Public property | RecordName | The name assigned to this record.

See Also

MCdirRecord Class


Directory Property

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..Directory Property
MCdirRecord Class See Also Send Feedback
The DICOMDIR object containing this record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdir Directory { get; }
Visual Basic
Public ReadOnly Property Directory As MCdir
    Get
Visual C++
public:
property MCdir^ Directory {
    MCdir^ get ();
}

Field Value

An MCdir instance to which this record belongs.

See Also

MCdirRecord Class
MCdirRecord Members


IsLast Property

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..IsLast Property
MCdirRecord Class See Also Send Feedback
Tells whether this record is the last child of the parent record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool IsLast { get; }
Visual Basic
Public ReadOnly Property IsLast As Boolean
    Get
Visual C++
public:
property bool IsLast {
    bool get ();
}

See Also

MCdirRecord Class
MCdirRecord Members


Parent Property

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..Parent Property
MCdirRecord Class See Also Send Feedback
The parent of the current directory record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdirRecord Parent { get; }
Visual Basic
Public ReadOnly Property Parent As MCdirRecord
    Get
Visual C++
public:
property MCdirRecord^ Parent {
    MCdirRecord^ get ();
}

Field Value

The parent MCdirRecord instance or null if this is the root record.

See Also

MCdirRecord Class
MCdirRecord Members


RecordItem Property

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..RecordItem Property
MCdirRecord Class See Also Send Feedback
Gets the item that contains the attributes of this record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitem RecordItem { get; }
Visual Basic
Public ReadOnly Property RecordItem As MCitem
    Get
Visual C++
public:
property MCitem^ RecordItem {
    MCitem^ get ();
}

Field Value

An MCitem containing the attributes of this record or null if this is the root record.

See Also

MCdirRecord Class
MCdirRecord Members


RecordName Property

[image]

Merge DICOM .NET/C# Toolkit
MCdirRecord..::..RecordName Property
MCdirRecord Class See Also Send Feedback
The name assigned to this record.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string RecordName { get; }
Visual Basic
Public ReadOnly Property RecordName As String
    Get
Visual C++
public:
property String^ RecordName {
    String^ get ();
}

Field Value

A String object representing the record name.

Remarks

Item names are defined in mergecom.srv configuration file in the 'ITEM_TABLE' section.

See Also

MCdirRecord Class
MCdirRecord Members


MCfailedSopInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo Class
Members See Also Send Feedback
Represents a Failed SOP Sequence item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfailedSopInfo
Visual Basic
Public Class MCfailedSopInfo
Visual C++
public ref class MCfailedSopInfo

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCfailedSopInfo

See Also

MCfailedSopInfo Members


MCfailedSopInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo Members
MCfailedSopInfo Class Constructors Methods Fields See Also Send Feedback

The MCfailedSopInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MCfailedSopInfo | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
 | CLASS_INSTANCE_CONFLICT | Class/Instance conflict reason code. The SOP Class of an element in the Referenced SOP Instance Sequence did not correspond to the SOP class registered for the SOP Instance at the SCP.
 | DUPLICATE_TRANSACTION_UID | Duplicate transaction UID reason code. The Transaction UID of a Storage Commitment Request is already in use.
Public field | failureReason | The failure reason code.
 | NO_SUCH_OBJECT | No such object instance reason code. One or more of the elements in the Referenced SOP Instance Sequence was not available.
 | PROCESSING_FAILURE | Processing failure reason code. A general failure in processing the operation was encountered.
 | REF_SOP_CLASS_NOT_SUPPORTED | Referenced SOP Class not supported reason code. Storage Commitment has been requested for a SOP instance with a SOP Class that is not supported by the SCP.
Public field | refSopClassUid | The unique identifier of the failed SOP Class.
Public field | refSopInstanceUid | The unique identifier of the failed SOP Instance.
 | RESOURCE_LIMITATION | Resoure limitation reason code. The SCP does not currently have enough resources to store the requested SOP instances.

See Also

MCfailedSopInfo Class


MCfailedSopInfo Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo Constructor
MCfailedSopInfo Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfailedSopInfo(
    string refSopClassUid,
    string refSopInstanceUid,
    ushort failureReason
)
Visual Basic
Public Sub New ( _
    refSopClassUid As String, _
    refSopInstanceUid As String, _
    failureReason As UShort _
)
Visual C++
public:
MCfailedSopInfo(
    String^ refSopClassUid,
    String^ refSopInstanceUid,
    unsigned short failureReason
)

Parameters

refSopClassUid
Type: System..::..String
Non-null referenced SOP Class Uid.
refSopInstanceUid
Type: System..::..String
Non-null referenced SOP Instance Uid.
failureReason
Type: System..::..UInt16
Failure reason code.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


MCfailedSopInfo Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo Fields
MCfailedSopInfo Class See Also Send Feedback

The MCfailedSopInfo type exposes the following members.

Fields

 | Name | Description
 | CLASS_INSTANCE_CONFLICT | Class/Instance conflict reason code. The SOP Class of an element in the Referenced SOP Instance Sequence did not correspond to the SOP class registered for the SOP Instance at the SCP.
 | DUPLICATE_TRANSACTION_UID | Duplicate transaction UID reason code. The Transaction UID of a Storage Commitment Request is already in use.
Public field | failureReason | The failure reason code.
 | NO_SUCH_OBJECT | No such object instance reason code. One or more of the elements in the Referenced SOP Instance Sequence was not available.
 | PROCESSING_FAILURE | Processing failure reason code. A general failure in processing the operation was encountered.
 | REF_SOP_CLASS_NOT_SUPPORTED | Referenced SOP Class not supported reason code. Storage Commitment has been requested for a SOP instance with a SOP Class that is not supported by the SCP.
Public field | refSopClassUid | The unique identifier of the failed SOP Class.
Public field | refSopInstanceUid | The unique identifier of the failed SOP Instance.
 | RESOURCE_LIMITATION | Resoure limitation reason code. The SCP does not currently have enough resources to store the requested SOP instances.

See Also

MCfailedSopInfo Class


CLASS_INSTANCE_CONFLICT Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..CLASS_INSTANCE_CONFLICT Field
MCfailedSopInfo Class See Also Send Feedback
Class/Instance conflict reason code. The SOP Class of an element in the Referenced SOP Instance Sequence did not correspond to the SOP class registered for the SOP Instance at the SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort CLASS_INSTANCE_CONFLICT
Visual Basic
Public Const CLASS_INSTANCE_CONFLICT As UShort
Visual C++
public:
literal unsigned short CLASS_INSTANCE_CONFLICT

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


DUPLICATE_TRANSACTION_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..DUPLICATE_TRANSACTION_UID Field
MCfailedSopInfo Class See Also Send Feedback
Duplicate transaction UID reason code. The Transaction UID of a Storage Commitment Request is already in use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort DUPLICATE_TRANSACTION_UID
Visual Basic
Public Const DUPLICATE_TRANSACTION_UID As UShort
Visual C++
public:
literal unsigned short DUPLICATE_TRANSACTION_UID

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


failureReason Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..failureReason Field
MCfailedSopInfo Class See Also Send Feedback
The failure reason code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly ushort failureReason
Visual Basic
Public ReadOnly failureReason As UShort
Visual C++
public:
initonly unsigned short failureReason

Remarks

A code defined by the DICOM standard that identifies why the action performed on the SOP instance failed.

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


NO_SUCH_OBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..NO_SUCH_OBJECT Field
MCfailedSopInfo Class See Also Send Feedback
No such object instance reason code. One or more of the elements in the Referenced SOP Instance Sequence was not available.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort NO_SUCH_OBJECT
Visual Basic
Public Const NO_SUCH_OBJECT As UShort
Visual C++
public:
literal unsigned short NO_SUCH_OBJECT

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


PROCESSING_FAILURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..PROCESSING_FAILURE Field
MCfailedSopInfo Class See Also Send Feedback
Processing failure reason code. A general failure in processing the operation was encountered.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort PROCESSING_FAILURE
Visual Basic
Public Const PROCESSING_FAILURE As UShort
Visual C++
public:
literal unsigned short PROCESSING_FAILURE

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


REF_SOP_CLASS_NOT_SUPPORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..REF_SOP_CLASS_NOT_SUPPORTED Field
MCfailedSopInfo Class See Also Send Feedback
Referenced SOP Class not supported reason code. Storage Commitment has been requested for a SOP instance with a SOP Class that is not supported by the SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort REF_SOP_CLASS_NOT_SUPPORTED
Visual Basic
Public Const REF_SOP_CLASS_NOT_SUPPORTED As UShort
Visual C++
public:
literal unsigned short REF_SOP_CLASS_NOT_SUPPORTED

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


refSopClassUid Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..refSopClassUid Field
MCfailedSopInfo Class See Also Send Feedback
The unique identifier of the failed SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string refSopClassUid
Visual Basic
Public ReadOnly refSopClassUid As String
Visual C++
public:
initonly String^ refSopClassUid

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


refSopInstanceUid Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..refSopInstanceUid Field
MCfailedSopInfo Class See Also Send Feedback
The unique identifier of the failed SOP Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string refSopInstanceUid
Visual Basic
Public ReadOnly refSopInstanceUid As String
Visual C++
public:
initonly String^ refSopInstanceUid

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


RESOURCE_LIMITATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo..::..RESOURCE_LIMITATION Field
MCfailedSopInfo Class See Also Send Feedback
Resoure limitation reason code. The SCP does not currently have enough resources to store the requested SOP instances.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const ushort RESOURCE_LIMITATION
Visual Basic
Public Const RESOURCE_LIMITATION As UShort
Visual C++
public:
literal unsigned short RESOURCE_LIMITATION

See Also

MCfailedSopInfo Class
MCfailedSopInfo Members


MCfailedSopInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfailedSopInfo Methods
MCfailedSopInfo Class See Also Send Feedback

The MCfailedSopInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCfailedSopInfo Class


MCfile Class

[image]

Merge DICOM .NET/C# Toolkit
MCfile Class
Members See Also Send Feedback
Represents a DICOM Media Storage file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfile : MCabstractMessage
Visual Basic
Public Class MCfile _
    Inherits MCabstractMessage
Visual C++
public ref class MCfile : public MCabstractMessage

Remarks

Each instance of this class contains an MCdataSet object and an MCfileMetaInfo object.

An MCfile may be constructed with a pre-populated data set or with an empty data set.

Please refer to the following DICOM Standard documents for detailed information about DICOM media storage:

  • Part 10: Media Storage and File Format for Media Interchange (PS 3.10)
  • Part 11: Media Storage Application Profiles (PS 3.11)
  • Part 12: Media Formats and Physical Media for Media Interchange (PS 3.12)

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCabstractMessage
Mergecom..::..MCfile
Mergecom..::..MCdir

See Also

MCfile Members


MCfile Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfile Members
MCfile Class Constructors Methods Properties See Also Send Feedback

The MCfile type exposes the following members.

Constructors

 | Name | Description
Public method | MCfile()()()() | Creates an "empty" instance of this class with no command or service name specified. The file defaults to a file named "UNSPECIFIED".
Public method | MCfile(String) | Creates an "empty" instance of this class with a specified file name.
Public method | MCfile(UInt16, String) | Creates an MCfile containing the data set for the specified service/command.
Public method | MCfile(MCdimseMessage, String) | Initializes a new instance of this class for a specified file, using the provided DIMSE message for the data set.

Methods

 | Name | Description
Public method | close | Forces a close of the file.
Public method | dispose | Cleans up all native resources used by this file.
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor for the class. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the meta info and data set contained in this file to the standard output stream.
Public method | list(TextWriter) | Lists the contents of the meta info and data set contained in this file to a TextWriter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeFileValues | Empties the values of all the attributes in the contained data set and file meta info set.
Public method | setServiceCommand | Sets the service name and command associated with the contained data set.
Public method | streamLength | Calculates the number of bytes it would take to stream out this file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

Properties

 | Name | Description
Public property | Command | Gets the DIMSE Command for this file.
Public property | DataSet | Gets the data set contained in this file object.
Public property | FileName | Gets or sets the file name associated with this object.
Public property | MetaInfo | Gets the Meta Information for this file.
Public property | Preamble | Sets or gets the file preamble for contained in the meta information of this file.
Public property | ServiceName | Sets or gets the name of the service associated with this DIMSE message.
Public property | TransferSyntaxUid | Sets or gets the Transfer Syntax UID that the DICOM file is encoded in.

See Also

MCfile Class


MCfile Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfile Constructor
MCfile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCfile()()()() | Creates an "empty" instance of this class with no command or service name specified. The file defaults to a file named "UNSPECIFIED".
Public method | MCfile(String) | Creates an "empty" instance of this class with a specified file name.
Public method | MCfile(UInt16, String) | Creates an MCfile containing the data set for the specified service/command.
Public method | MCfile(MCdimseMessage, String) | Initializes a new instance of this class for a specified file, using the provided DIMSE message for the data set.

See Also

MCfile Class
MCfile Members


MCfile Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCfile Constructor
MCfile Class See Also Send Feedback
Creates an "empty" instance of this class with no command or service name specified. The file defaults to a file named "UNSPECIFIED".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfile()
Visual Basic
Public Sub New
Visual C++
public:
MCfile()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCfile Class
MCfile Members
MCfile Overload


MCfile Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCfile Constructor (String)
MCfile Class See Also Send Feedback
Creates an "empty" instance of this class with a specified file name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfile(
    string file
)
Visual Basic
Public Sub New ( _
    file As String _
)
Visual C++
public:
MCfile(
    String^ file
)

Parameters

file
Type: System..::..String
A name for this file.

Remarks

The created MCfile object is not associated with any particular DICOM service or command and it will have an empty MCdataSet object.

This form of the constructor is used if the service and command are not yet known, or if there is no need to validate that values will be set only for attributes assigned to a given service/command pair. If the validate method is to be called, the setServiceCommand(String, UInt16) method must be called first to associate this file object with a given DICOM service and command.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The file name was null.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCfile Class
MCfile Members
MCfile Overload


MCfile Constructor (UInt16, String)

[image]

Merge DICOM .NET/C# Toolkit
MCfile Constructor (UInt16, String)
MCfile Class See Also Send Feedback
Creates an MCfile containing the data set for the specified service/command.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfile(
    ushort command,
    string serviceName
)
Visual Basic
Public Sub New ( _
    command As UShort, _
    serviceName As String _
)
Visual C++
public:
MCfile(
    unsigned short command,
    String^ serviceName
)

Parameters

command
Type: System..::..UInt16
A valid service command.
serviceName
Type: System..::..String
A non-null name of a DICOM service.

Remarks

The file defaults to a file named "UNSPECIFIED".

The service name and command are used to access configuration information that describes the attributes of the file. If such configuration information is not available, an empty message object is created, and a warning is logged.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCfile Class
MCfile Members
MCfile Overload


MCfile Constructor (MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCfile Constructor (MCdimseMessage, String)
MCfile Class See Also Send Feedback
Initializes a new instance of this class for a specified file, using the provided DIMSE message for the data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfile(
    MCdimseMessage msg,
    string fileName
)
Visual Basic
Public Sub New ( _
    msg As MCdimseMessage, _
    fileName As String _
)
Visual C++
public:
MCfile(
    MCdimseMessage^ msg,
    String^ fileName
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
A message object containing the attributes for the new file.
fileName
Type: System..::..String
The name to associate with this file

Remarks

Note: The message will be disposed after it's converted to a file and should not be used afterwards.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | There was a problem with one of the arguments.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.

See Also

MCfile Class
MCfile Members
MCfile Overload


MCfile Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfile Methods
MCfile Class See Also Send Feedback

The MCfile type exposes the following members.

Methods

 | Name | Description
Public method | close | Forces a close of the file.
Public method | dispose | Cleans up all native resources used by this file.
Public method | duplicate | Creates a duplicate copy of a message or a file in the transfer syntax specified by resultSyntax. (Inherited from MCabstractMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor for the class. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNextValidationError | Gets validation error information created by the validate() method. (Inherited from MCabstractMessage.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of the meta info and data set contained in this file to the standard output stream.
Public method | list(TextWriter) | Lists the contents of the meta info and data set contained in this file to a TextWriter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model schema PS3.18) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXML | Converts an XML representation (Merge DICOM Toolkit proprietary schema) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM message or file into a DICOM message. (Inherited from MCabstractMessage.)
Public method | registerCompression | Register compression callbacks for future use of compression/decompression operation (Inherited from MCabstractMessage.)
Public method | removeFileValues | Empties the values of all the attributes in the contained data set and file meta info set.
Public method | setServiceCommand | Sets the service name and command associated with the contained data set.
Public method | streamLength | Calculates the number of bytes it would take to stream out this file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | validate | Checks whether this message meets the DICOM validation criteria. (Inherited from MCabstractMessage.)
Public method | validateAttribute | Validates an attribute in this message's data set. (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its JSON representation (DICOM JSON Model PS3.18). (Inherited from MCabstractMessage.)
Public method | writeToXML | Converts a DICOM message or a DICOM file into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts a DICOM message or a DICOM file into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCabstractMessage.)

See Also

MCfile Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..close Method
MCfile Class See Also Send Feedback
Forces a close of the file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void close()
Visual Basic
Public Overridable Sub close
Visual C++
public:
virtual void close()

See Also

MCfile Class
MCfile Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..dispose Method
MCfile Class See Also Send Feedback
Cleans up all native resources used by this file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCfile Class
MCfile Members


Finalize Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..Finalize Method
MCfile Class See Also Send Feedback
Destructor for the class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

MCfile Class
MCfile Members


list Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfile..::..list Method
MCfile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | list()()()() | Lists the contents of the meta info and data set contained in this file to the standard output stream.
Public method | list(TextWriter) | Lists the contents of the meta info and data set contained in this file to a TextWriter.

See Also

MCfile Class
MCfile Members


list Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..list Method
MCfile Class See Also Send Feedback
Lists the contents of the meta info and data set contained in this file to the standard output stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list()
Visual Basic
Public Overridable Sub list
Visual C++
public:
virtual void list()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members
list Overload


list Method (TextWriter)

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..list Method (TextWriter)
MCfile Class See Also Send Feedback
Lists the contents of the meta info and data set contained in this file to a TextWriter.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void list(
    TextWriter destination
)
Visual Basic
Public Overridable Sub list ( _
    destination As TextWriter _
)
Visual C++
public:
virtual void list(
    TextWriter^ destination
)

Parameters

destination
Type: System.IO..::..TextWriter
TextWriter object defining the output.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The destination was null.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members
list Overload


removeFileValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..removeFileValues Method
MCfile Class See Also Send Feedback
Empties the values of all the attributes in the contained data set and file meta info set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFileValues()
Visual Basic
Public Overridable Sub removeFileValues
Visual C++
public:
virtual void removeFileValues()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members


setServiceCommand Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..setServiceCommand Method
MCfile Class See Also Send Feedback
Sets the service name and command associated with the contained data set.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void setServiceCommand(
    string serviceName,
    ushort command
)
Visual Basic
Public Overridable Sub setServiceCommand ( _
    serviceName As String, _
    command As UShort _
)
Visual C++
public:
virtual void setServiceCommand(
    String^ serviceName,
    unsigned short command
)

Parameters

serviceName
Type: System..::..String
The service name to be associated with this file. This value must be a valid service name defined in the MergeCOM service profile file
command
Type: System..::..UInt16
A DICOM command associated with this file. See Command property for accepted values.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCfile Class
MCfile Members


streamLength Method

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..streamLength Method
MCfile Class See Also Send Feedback
Calculates the number of bytes it would take to stream out this file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint streamLength()
Visual Basic
Public Overridable Function streamLength As UInteger
Visual C++
public:
virtual unsigned int streamLength()

Return Value

The calculated length of a stream containing this file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The message has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCinvalidEncodingException | An attribute had an invalid value.

See Also

MCfile Class
MCfile Members


MCfile Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfile Properties
MCfile Class See Also Send Feedback

The MCfile type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the DIMSE Command for this file.
Public property | DataSet | Gets the data set contained in this file object.
Public property | FileName | Gets or sets the file name associated with this object.
Public property | MetaInfo | Gets the Meta Information for this file.
Public property | Preamble | Sets or gets the file preamble for contained in the meta information of this file.
Public property | ServiceName | Sets or gets the name of the service associated with this DIMSE message.
Public property | TransferSyntaxUid | Sets or gets the Transfer Syntax UID that the DICOM file is encoded in.

See Also

MCfile Class


Command Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..Command Property
MCfile Class See Also Send Feedback
Gets the DIMSE Command for this file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort Command { get; }
Visual Basic
Public Overridable ReadOnly Property Command As UShort
    Get
Visual C++
public:
virtual property unsigned short Command {
    unsigned short get ();
}

Field Value

An unsigned short representing the service command.

Remarks

The command code returned will be one of these defined by the MCdimseService class:
  • Composite Store Service Request and Reply: C_STORE_RQ, C_STORE_RSP
  • Composite Get Service Request, Reply and Cancel: C_GET_RQ, C_GET_RSP, C_CANCEL_GET_RQ
  • Composite Find Service Request, Reply and Cancel: C_FIND_RQ, C_FIND_RSP, C_CANCEL_FIND_RQ
  • Composite Move Service Request, Reply and Cancel: C_MOVE_RQ, C_MOVE_RSP, C_CANCEL_MOVE_RQ
  • Verification Service Request and Reply: C_ECHO_RQ, C_ECHO_RSP
  • Normalized Report Service Request and Reply: N_EVENT_REPORT_RQ, N_EVENT_REPORT_RSP
  • Normalized Get Service Request and Reply: N_GET_RQ, N_GET_RSP
  • Normalized Set Service Request and Reply: N_SET_RQ, N_SET_RSP
  • Normalized Action Service Request and Reply: N_ACTION_RQ, N_ACTION_RSP
  • Normalized Create Service Request and Reply: N_CREATE_RQ, N_CREATE_RSP
  • Normalized Delete Service Request and Reply: N_DELETE_RQ, N_DELETE_RSP

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members


DataSet Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..DataSet Property
MCfile Class See Also Send Feedback
Gets the data set contained in this file object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet DataSet { get; }
Visual Basic
Public Overridable ReadOnly Property DataSet As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ DataSet {
    MCdataSet^ get ();
}

Field Value

An MCdataSet associated with this file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members


FileName Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..FileName Property
MCfile Class See Also Send Feedback
Gets or sets the file name associated with this object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FileName { get; set; }
Visual Basic
Public Overridable Property FileName As String
    Get
    Set
Visual C++
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the file name.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The file name was null.

See Also

MCfile Class
MCfile Members


MetaInfo Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..MetaInfo Property
MCfile Class See Also Send Feedback
Gets the Meta Information for this file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCfileMetaInfo MetaInfo { get; }
Visual Basic
Public Overridable ReadOnly Property MetaInfo As MCfileMetaInfo
    Get
Visual C++
public:
virtual property MCfileMetaInfo^ MetaInfo {
    MCfileMetaInfo^ get ();
}

Field Value

An MCfileMetaInfo object containing the meta information.

See Also

MCfile Class
MCfile Members


Preamble Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..Preamble Property
MCfile Class See Also Send Feedback
Sets or gets the file preamble for contained in the meta information of this file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte[] Preamble { get; set; }
Visual Basic
Public Overridable Property Preamble As Byte()
    Get
    Set
Visual C++
public:
virtual property array<unsigned char>^ Preamble {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

A byte array representing the preamble. The length of the array must be 128.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | The value set was invalid.

See Also

MCfile Class
MCfile Members


ServiceName Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..ServiceName Property
MCfile Class See Also Send Feedback
Sets or gets the name of the service associated with this DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceName { get; }
Visual Basic
Public Overridable ReadOnly Property ServiceName As String
    Get
Visual C++
public:
virtual property String^ ServiceName {
    String^ get ();
}

Field Value

A String representing the service name.

See Also

MCfile Class
MCfile Members


TransferSyntaxUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCfile..::..TransferSyntaxUid Property
MCfile Class See Also Send Feedback
Sets or gets the Transfer Syntax UID that the DICOM file is encoded in.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string TransferSyntaxUid { get; set; }
Visual Basic
Public Overridable Property TransferSyntaxUid As String
    Get
    Set
Visual C++
public:
virtual property String^ TransferSyntaxUid {
    String^ get ();
    void set (String^ value);
}

Field Value

Sets/Gets the Transfer Syntax UID used by this file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.

See Also

MCfile Class
MCfile Members


MCfileDataSink Class

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink Class
Members See Also Send Feedback
Implementation of the MCdataSink interface which writes to a file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfileDataSink : MCdataSink,
    IDisposable
Visual Basic
Public Class MCfileDataSink _
    Implements MCdataSink, IDisposable
Visual C++
public ref class MCfileDataSink : MCdataSink,
    IDisposable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCfileDataSink

See Also

MCfileDataSink Members


MCfileDataSink Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink Members
MCfileDataSink Class Constructors Methods See Also Send Feedback

The MCfileDataSink type exposes the following members.

Constructors

 | Name | Description
Public method | MCfileDataSink | Initializes an instance of this class for writing to a file.

Methods

 | Name | Description
Public method | close | Closes the file being written to. This method is the same with Dispose().
Public method | Dispose | Implements IDisposable. Close the file being written to.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | receiveData | Implementation of the receiveData method as defined in MCdataSink.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCfileDataSink Class


MCfileDataSink Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink Constructor
MCfileDataSink Class See Also Send Feedback
Initializes an instance of this class for writing to a file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfileDataSink(
    string fileName
)
Visual Basic
Public Sub New ( _
    fileName As String _
)
Visual C++
public:
MCfileDataSink(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The path to the file to write to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | There was a problem with the file name provided. Check the message and the inner exception in the exception being thrown.

See Also

MCfileDataSink Class
MCfileDataSink Members


MCfileDataSink Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink Methods
MCfileDataSink Class See Also Send Feedback

The MCfileDataSink type exposes the following members.

Methods

 | Name | Description
Public method | close | Closes the file being written to. This method is the same with Dispose().
Public method | Dispose | Implements IDisposable. Close the file being written to.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | receiveData | Implementation of the receiveData method as defined in MCdataSink.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCfileDataSink Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink..::..close Method
MCfileDataSink Class See Also Send Feedback
Closes the file being written to. This method is the same with Dispose().

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

See Also

MCfileDataSink Class
MCfileDataSink Members


Dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink..::..Dispose Method
MCfileDataSink Class See Also Send Feedback
Implements IDisposable. Close the file being written to.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MCfileDataSink Class
MCfileDataSink Members


receiveData Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSink..::..receiveData Method
MCfileDataSink Class See Also Send Feedback
Implementation of the receiveData method as defined in MCdataSink.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void receiveData(
    MCdata bulk,
    Object origin
)
Visual Basic
Public Sub receiveData ( _
    bulk As MCdata, _
    origin As Object _
)
Visual C++
public:
virtual void receiveData(
    MCdata^ bulk,
    Object^ origin
) sealed

Parameters

bulk
Type: Mergecom..::..MCdata
The data to receive.
origin
Type: System..::..Object
The origin of this call.

Implements

MCdataSink..::..receiveData(MCdata, Object)

See Also

MCfileDataSink Class
MCfileDataSink Members


MCfileDataSource Class

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Class
Members See Also Send Feedback
Implementation of the MCdataSource interface which reads from a file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfileDataSource : MCdataSourceEx,
    MCdataSource, IDisposable
Visual Basic
Public Class MCfileDataSource _
    Implements MCdataSourceEx, MCdataSource, IDisposable
Visual C++
public ref class MCfileDataSource : MCdataSourceEx,
    MCdataSource, IDisposable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCfileDataSource

See Also

MCfileDataSource Members


MCfileDataSource Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Members
MCfileDataSource Class Constructors Methods Properties See Also Send Feedback

The MCfileDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | MCfileDataSource(String) | Initializes a new instance of this class.
Public method | MCfileDataSource(String, UInt32) | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | close | Closes the file and disposes any buffers in use. This method is the same with Dispose()
Public method | Dispose | Implements IDisposable. Closes the file and disposes any buffers in use.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor. Dispose the unmanaged resources. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | setPosition | Sets the current position within the source file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Size | Size of source file in bytes.

See Also

MCfileDataSource Class


MCfileDataSource Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Constructor
MCfileDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCfileDataSource(String) | Initializes a new instance of this class.
Public method | MCfileDataSource(String, UInt32) | Initializes a new instance of this class.

See Also

MCfileDataSource Class
MCfileDataSource Members


MCfileDataSource Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Constructor (String)
MCfileDataSource Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfileDataSource(
    string fileName
)
Visual Basic
Public Sub New ( _
    fileName As String _
)
Visual C++
public:
MCfileDataSource(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The path to the file to read from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The file name parameter was invalid.

See Also

MCfileDataSource Class
MCfileDataSource Members
MCfileDataSource Overload


MCfileDataSource Constructor (String, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Constructor (String, UInt32)
MCfileDataSource Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfileDataSource(
    string fileName,
    uint bufferSize
)
Visual Basic
Public Sub New ( _
    fileName As String, _
    bufferSize As UInteger _
)
Visual C++
public:
MCfileDataSource(
    String^ fileName,
    unsigned int bufferSize
)

Parameters

fileName
Type: System..::..String
The path to the file to read from.
bufferSize
Type: System..::..UInt32
The size of the internal buffer (must be even number).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The file name parameter was invalid.

See Also

MCfileDataSource Class
MCfileDataSource Members
MCfileDataSource Overload


MCfileDataSource Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Methods
MCfileDataSource Class See Also Send Feedback

The MCfileDataSource type exposes the following members.

Methods

 | Name | Description
Public method | close | Closes the file and disposes any buffers in use. This method is the same with Dispose()
Public method | Dispose | Implements IDisposable. Closes the file and disposes any buffers in use.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor. Dispose the unmanaged resources. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | setPosition | Sets the current position within the source file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCfileDataSource Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..close Method
MCfileDataSource Class See Also Send Feedback
Closes the file and disposes any buffers in use. This method is the same with Dispose()

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

See Also

MCfileDataSource Class
MCfileDataSource Members


Dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..Dispose Method
MCfileDataSource Class See Also Send Feedback
Implements IDisposable. Closes the file and disposes any buffers in use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MCfileDataSource Class
MCfileDataSource Members


Finalize Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..Finalize Method
MCfileDataSource Class See Also Send Feedback
Destructor. Dispose the unmanaged resources.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

MCfileDataSource Class
MCfileDataSource Members


provideData Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..provideData Method
MCfileDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSource.

See Also

MCfileDataSource Class
MCfileDataSource Members


provideData Method (Boolean, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..provideData Method (Boolean, Object)
MCfileDataSource Class See Also Send Feedback
Implementation of the provideData method as defined in MCdataSource.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata provideData(
    bool first,
    Object origin
)
Visual Basic
Public Function provideData ( _
    first As Boolean, _
    origin As Object _
) As MCdata
Visual C++
public:
virtual MCdata^ provideData(
    bool first,
    Object^ origin
) sealed

Parameters

first
Type: System..::..Boolean
true if this is the first block being requested.
origin
Type: System..::..Object
The origin of this call.

Return Value

An MCdata instance containing the requested data.

Implements

MCdataSource..::..provideData(Boolean, Object)

See Also

MCfileDataSource Class
MCfileDataSource Members
provideData Overload


provideData Method (Boolean, UInt32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..provideData Method (Boolean, UInt32, Object)
MCfileDataSource Class See Also Send Feedback
Implementation of the provideData method as defined in MCdataSource.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata provideData(
    bool first,
    uint pos,
    Object origin
)
Visual Basic
Public Function provideData ( _
    first As Boolean, _
    pos As UInteger, _
    origin As Object _
) As MCdata
Visual C++
public:
virtual MCdata^ provideData(
    bool first,
    unsigned int pos,
    Object^ origin
) sealed

Parameters

first
Type: System..::..Boolean
true if this is the first block being requested.
pos
Type: System..::..UInt32
An offset from the beginning of the file to seek to.
origin
Type: System..::..Object
The origin of this call.

Return Value

An MCdata instance containing the requested data.

Implements

MCdataSourceEx..::..provideData(Boolean, UInt32, Object)

See Also

MCfileDataSource Class
MCfileDataSource Members
provideData Overload


setPosition Method

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..setPosition Method
MCfileDataSource Class See Also Send Feedback
Sets the current position within the source file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void setPosition(
    uint pos
)
Visual Basic
Public Sub setPosition ( _
    pos As UInteger _
)
Visual C++
public:
void setPosition(
    unsigned int pos
)

Parameters

pos
Type: System..::..UInt32
An offset from the beginning of the file to seek to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The file has been disposed.

See Also

MCfileDataSource Class
MCfileDataSource Members


MCfileDataSource Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource Properties
MCfileDataSource Class See Also Send Feedback

The MCfileDataSource type exposes the following members.

Properties

 | Name | Description
Public property | Size | Size of source file in bytes.

See Also

MCfileDataSource Class


Size Property

[image]

Merge DICOM .NET/C# Toolkit
MCfileDataSource..::..Size Property
MCfileDataSource Class See Also Send Feedback
Size of source file in bytes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public long Size { get; }
Visual Basic
Public ReadOnly Property Size As Long
    Get
Visual C++
public:
property long long Size {
    long long get ();
}

See Also

MCfileDataSource Class
MCfileDataSource Members


MCfileMetaInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCfileMetaInfo Class
Members See Also Send Feedback
Represents the Meta Information for DICOM Media Storage.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfileMetaInfo : MCattributeSet
Visual Basic
Public Class MCfileMetaInfo _
    Inherits MCattributeSet
Visual C++
public ref class MCfileMetaInfo : public MCattributeSet

Remarks

The Meta Information for DICOM Media Storage contains attributes with tag numbers (0002,0000) through (0002,FFFF).

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom..::..MCfileMetaInfo

See Also

MCfileMetaInfo Members


MCfileMetaInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileMetaInfo Members
MCfileMetaInfo Class Methods Properties See Also Send Feedback

The MCfileMetaInfo type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Preamble | Sets or gets the file preamble for this Meta Information.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCfileMetaInfo Class


MCfileMetaInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileMetaInfo Methods
MCfileMetaInfo Class See Also Send Feedback

The MCfileMetaInfo type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

See Also

MCfileMetaInfo Class


MCfileMetaInfo Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfileMetaInfo Properties
MCfileMetaInfo Class See Also Send Feedback

The MCfileMetaInfo type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Preamble | Sets or gets the file preamble for this Meta Information.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCfileMetaInfo Class


Preamble Property

[image]

Merge DICOM .NET/C# Toolkit
MCfileMetaInfo..::..Preamble Property
MCfileMetaInfo Class See Also Send Feedback
Sets or gets the file preamble for this Meta Information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte[] Preamble { get; set; }
Visual Basic
Public Overridable Property Preamble As Byte()
    Get
    Set
Visual C++
public:
virtual property array<unsigned char>^ Preamble {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

A byte array representing the preamble. The length of the array must be 128.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The value set was invalid.

See Also

MCfileMetaInfo Class
MCfileMetaInfo Members


MCinstanceUid Class

[image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid Class
Members See Also Send Feedback
Identifies a unique instance belonging to a unique SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCinstanceUid
Visual Basic
Public Class MCinstanceUid
Visual C++
public ref class MCinstanceUid

Remarks

This class tracks two fields:
  • SOP Class UID
  • SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCinstanceUid

See Also

MCinstanceUid Members


MCinstanceUid Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid Members
MCinstanceUid Class Constructors Methods Fields See Also Send Feedback

The MCinstanceUid type exposes the following members.

Constructors

 | Name | Description
Public method | MCinstanceUid | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | sopClassUid | Unique identifier for the SOP Class.
Public field | sopInstanceUid | The unique identifier of the referenced Instance.

See Also

MCinstanceUid Class


MCinstanceUid Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid Constructor
MCinstanceUid Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinstanceUid(
    MCsopClass sopClass,
    string sopInstanceUid
)
Visual Basic
Public Sub New ( _
    sopClass As MCsopClass, _
    sopInstanceUid As String _
)
Visual C++
public:
MCinstanceUid(
    MCsopClass^ sopClass,
    String^ sopInstanceUid
)

Parameters

sopClass
Type: Mergecom..::..MCsopClass
A non null DICOM UID identifying a SOP class.
sopInstanceUid
Type: System..::..String
A non-null DICOM UID identifying an instance of the class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.

See Also

MCinstanceUid Class
MCinstanceUid Members


MCinstanceUid Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid Fields
MCinstanceUid Class See Also Send Feedback

The MCinstanceUid type exposes the following members.

Fields

 | Name | Description
Public field | sopClassUid | Unique identifier for the SOP Class.
Public field | sopInstanceUid | The unique identifier of the referenced Instance.

See Also

MCinstanceUid Class


sopClassUid Field

[image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid..::..sopClassUid Field
MCinstanceUid Class See Also Send Feedback
Unique identifier for the SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string sopClassUid
Visual Basic
Public ReadOnly sopClassUid As String
Visual C++
public:
initonly String^ sopClassUid

See Also

MCinstanceUid Class
MCinstanceUid Members


sopInstanceUid Field

[image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid..::..sopInstanceUid Field
MCinstanceUid Class See Also Send Feedback
The unique identifier of the referenced Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string sopInstanceUid
Visual Basic
Public ReadOnly sopInstanceUid As String
Visual C++
public:
initonly String^ sopInstanceUid

See Also

MCinstanceUid Class
MCinstanceUid Members


MCinstanceUid Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinstanceUid Methods
MCinstanceUid Class See Also Send Feedback

The MCinstanceUid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCinstanceUid Class


MCitem Class

[image]

Merge DICOM .NET/C# Toolkit
MCitem Class
Members See Also Send Feedback
Represents the attributes of a DICOM item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCitem : MCattributeSet
Visual Basic
Public Class MCitem _
    Inherits MCattributeSet
Visual C++
public ref class MCitem : public MCattributeSet

Remarks

DICOM items are the values stored for attributes with a Sequence of Items (SQ) Value Representation.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom..::..MCitem

See Also

MCitem Members


MCitem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitem Members
MCitem Class Constructors Methods Properties See Also Send Feedback

The MCitem type exposes the following members.

Constructors

 | Name | Description
Public method | MCitem()()()() | Initializes a new instance of this class that contains no data elements.
Public method | MCitem(String) | Initializes a new instance of this class and populates it with configured data elements.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | clone | Create a copy of this item with the same attributes.
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | ItemName | Represents the Merge DICOM toolkit name associated with this item.
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCitem Class


MCitem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitem Constructor
MCitem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCitem()()()() | Initializes a new instance of this class that contains no data elements.
Public method | MCitem(String) | Initializes a new instance of this class and populates it with configured data elements.

See Also

MCitem Class
MCitem Members


MCitem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCitem Constructor
MCitem Class See Also Send Feedback
Initializes a new instance of this class that contains no data elements.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitem()
Visual Basic
Public Sub New
Visual C++
public:
MCitem()

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCitem Class
MCitem Members
MCitem Overload


MCitem Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCitem Constructor (String)
MCitem Class See Also Send Feedback
Initializes a new instance of this class and populates it with configured data elements.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitem(
    string itemName
)
Visual Basic
Public Sub New ( _
    itemName As String _
)
Visual C++
public:
MCitem(
    String^ itemName
)

Parameters

itemName
Type: System..::..String
The "service" used to add attributes to the set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCconfigurationError | An error with the Message Information configuration file. See the log file for more details.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCitem Class
MCitem Members
MCitem Overload


MCitem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitem Methods
MCitem Class See Also Send Feedback

The MCitem type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | clone | Create a copy of this item with the same attributes.
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | dispose | Disposes this attribute set. (Inherited from MCattributeSet.)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

See Also

MCitem Class


clone Method

[image]

Merge DICOM .NET/C# Toolkit
MCitem..::..clone Method
MCitem Class See Also Send Feedback
Create a copy of this item with the same attributes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitem clone()
Visual Basic
Public Function clone As MCitem
Visual C++
public:
MCitem^ clone()

Return Value

A new MCitem instance.

Remarks

See MCattributeSet.copyTo for detail on how the attributes are copied.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The item has been disposed.
Mergecom.Exceptions..::..MCillegalArgumentException | An attribute being copied is not valid.

See Also

MCitem Class
MCitem Members


MCitem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitem Properties
MCitem Class See Also Send Feedback

The MCitem type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | ItemName | Represents the Merge DICOM toolkit name associated with this item.
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCitem Class


ItemName Property

[image]

Merge DICOM .NET/C# Toolkit
MCitem..::..ItemName Property
MCitem Class See Also Send Feedback
Represents the Merge DICOM toolkit name associated with this item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ItemName { get; set; }
Visual Basic
Public Overridable Property ItemName As String
    Get
    Set
Visual C++
public:
virtual property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the name of the item.

See Also

MCitem Class
MCitem Members


MCitems Structure

[image]

Merge DICOM .NET/C# Toolkit
MCitems Structure
Members See Also Send Feedback
MCitems structure contains constant strings representing names for the DICOM sequence items as defined in the mergecom.srv configuration file. It eliminates the need to hard code these names and makes possible compile time checking.

As the standard evolves the structure will be updated in order to remain current. In particular, the following changes can be expected:

  1. New fields will be added as new sequence item types are defined in new Supplements and Change Proposals.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public struct MCitems
Visual Basic
Public Structure MCitems
Visual C++
public value class MCitems

Remarks

For item names starting with a digit, a '_' character will be prepended to the field name. Other characters such as '.' or '-' (illegal in C# identifiers) will be replaced with '_'.

See Also

MCitems Members


MCitems Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitems Members
MCitems Structure Methods Fields See Also Send Feedback

The MCitems type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
_2D_DEGREE_OF_FREEDOM |
_2D_LINE_COORDINATES |
_2D_MATING_FEATURE_COORDINATES |
_2D_PLANE_COORDINATES |
_2D_POINT_COORDINATES |
_2D_TO_3D_MAP |
_3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO |
ACCESS_END_POINTS_MACRO |
ACCESSORY_CODE |
ACQUISITION_CONTEXT |
ACQUISITION_DEVICE |
ACQUISITION_PROTOCOL_ELEMENT_CT |
ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION |
ACQUISITION_PROTOCOL_ELEMENT_XA |
ACQUISITION_SUBTASK |
ACQUISITION_TASK |
ACTUAL_HUMAN_PERFORMER_SCP_MACRO |
ACTUAL_HUMAN_PERFORMERS |
ACTUAL_HUMAN_PERFORMERS_M |
ADD_NEAR_SQ |
ADDITIONAL_PARAMETER_RECORDING_INSTANCE |
ADDITIONAL_RT_ACCESSORY_DEVICE |
ADVANCED_BLENDING |
AGE_CORRECTED_SENSIT_DEV_ALG |
ALGORITHM_IDENT_MACRO |
ALTERNATE_CONTAINER_IDENTIFIER |
ALTERNATE_CONTENT_DESCRIPTION |
ALTERNATE_REPRESENTATION |
ALTERNATE_REPRESENTATION_IN_INVENTORY |
ANALOG_FILTER_CHARACTERISTICS |
ANATOMIC_REGION |
ANATOMIC_REGION_IN_INTRA_ORAL |
ANIMATION_CURVE |
ANNOTATION_CONTENT |
ANNOTATION_GROUP |
ANNOTATION_PROPERTY_TYPE_CODE |
ANTERIOR_CHAMBER_DEPTH |
APPLICATION_SETUP |
APPLICATOR |
APPLICATOR_GEOMETRY |
APPLICATOR_IN_ION |
APPLICATOR_IN_RT_GEN_MACH_VERIF |
APPROVAL |
APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ |
APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP |
ASL_BOLUS_CUT_OFF_TIMING |
ASL_SLAB |
ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ |
ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP |
ASSERTION_MACRO |
ASSESSED_SOP_INSTANCE |
ASSESSMENT_OBSERVATIONS |
ATTRIBUTE_TOLERANCE_VALUES |
ATTRIBUTE_VALUE |
ATTRIBUTE_VALUE_CONSTRAINT |
AUTHOR_OBSERVER |
AUTOREFRACTION_EYE_SQ |
BASIC_CODE_SEQUENCE_MACRO |
BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS |
BEAM_DOSE_VERIF_CONTROL_POINT |
BEAM_IN_RT_IMAGE |
BEAM_ITEM |
BEAM_LIMITING_DEVICE |
BEAM_LIMITING_DEVICE_IN_BEAM |
BEAM_LIMITING_DEVICE_LEAF_PAIRS |
BEAM_LIMITING_DEVICE_POSITION |
BEAM_LIMITING_DEVICE_TOLERANCE |
BEAM_TASK_SQ |
BILLING_SUPPLIES_AND_DEVICES |
BIOPSY_TARGET |
BLENDING_DISPLAY |
BLENDING_DISPLAY_INPUT |
BLENDING_LUT_1 |
BLENDING_LUT_2 |
BLENDING_SEQUENCE |
BLOCK_DEFINITION |
BLOCK_EDGE_DATA |
BLOCK_SEQUENCE |
BLOCK_SLAB |
BLOCK_SLAB_IN_BLOCKS_DEF_MACRO |
BOLUS_DEFINITION |
BRACHY_ACCESSORY_DEVICE |
BRACHY_CONTROL_POINT |
BRACHY_CONTROL_POINT_DELIVERED |
BRACHY_PULSE_CONTROL_POINT_DELIVERED |
BRACHY_REFERENCED_DOSE_REFERENCE |
BRACHY_TASK |
BREAST_XRAY_GEOMETRY |
BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM |
BREAST_XRAY_POSITIONER_POSITION |
BREED_REGISTRATION |
BREED_REGISTRATION_MWL |
C_ARM_PHOTON_ELECTRON_CONTROL_POINT |
CALCULATED_DOSE_REFERENCE |
CALCULATED_TORIC_POWER_MACRO |
CALCULATION_COMMENT |
CALIBRATION |
CALIBRATION_DATA |
CAMERA_POSITION_GROUP |
CARDIAC_TRIGGER |
CELL_VALUES |
CHANNEL |
CHANNEL_DEFINITION |
CHANNEL_DELIVERY_CONTINUATION |
CHANNEL_DELIVERY_ORDER |
CHANNEL_DISPLAY |
CHANNEL_IMPEDANCE |
CHANNEL_SHIELD |
CHEMICAL_SHIFT |
CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ |
CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP |
CODE_SEQUENCE_MACRO |
CODE_SEQUENCE_MWL_CFIND_RQ |
CODE_SEQUENCE_MWL_CFIND_RSP |
CODING_SCHEME_IDENTIFICATION |
CODING_SCHEME_RESOURCES |
COLLIMATOR_SHAPE |
COMBINATION_SEGMENT_REFERENCE |
COMPENSATOR |
COMPENSATOR_DEFINITION |
COMPENSATOR_SHAPE |
COMPONENT |
COMPONENT_ASSEMBLY |
COMPONENT_INPUT |
COMPONENT_TYPES |
COMPOUND_GRAPHIC |
CONCEPT_CODE_SEQUENCE |
CONCEPT_NAME_CODE_SEQUENCE |
CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO |
CONCEPTUAL_VOLUME_CONSTITUENT |
CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE |
CONCEPTUAL_VOLUME_IDENTIFICATION |
CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE |
CONFIGURATION_QA_RESULTS |
CONFIGURATION_QA_RESULTS_SCP |
CONFIGURATION_QA_RESULTS_SCU |
CONSENT_FOR_CLINICAL_TRIAL_USE |
CONTAINER_COMPONENT |
CONTENT |
CONTENT_IN_ENCAP_DOC |
CONTENT_ITEM_MACRO |
CONTENT_ITEM_WITH_MODIFIERS_MACRO |
CONTENT_TEMPLATE |
CONTENT_TEMPLATE_IN_IMAGE |
CONTENT_TEMPLATE_IN_INVENTORY |
CONTEXT_GROUP_IDENTIFICATION |
CONTOUR |
CONTOUR_IMAGE |
CONTRAST_ADMIN_PROFILE |
CONTRAST_BOLUS_ADMIN_ROUTE |
CONTRAST_BOLUS_USAGE |
CONTRIBUTING_EQUIPMENT |
CONTRIBUTING_SOP_INSTANCE_REF |
CONTRIBUTING_SOURCES_ANGIO |
CONTRIBUTING_SOURCES_CRANIO |
CONTRIBUTING_SOURCES_TOMO |
CONTROL_POINT |
CONTROL_POINT_DELIVERY |
CONVENTIONAL_CONTROL_POINT_VERIFICATION |
CONVENTIONAL_MACHINE_VERIFICATION |
CORNEA_MEASUREMENTS |
CORNEAL_SIZE |
CORRECTED_PARAMETERS |
CT_ACQUISITION_DETAILS |
CT_ACQUISITION_TYPE |
CT_ADDITIONAL_XRAY_SOURCE |
CT_ADDITIONAL_XRAY_SOURCE_MACRO |
CT_EXPOSURE |
CT_GEOMETRY |
CT_IMAGE_FRAME_TYPE |
CT_PIXEL_VALUE_TRANSFORMATION |
CT_POSITION |
CT_RECONSTRUCTION |
CT_TABLE_DYNAMICS |
CT_XRAY_DETAILS |
CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ |
CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO |
CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO |
CUSTODIAL_ORGANIZATION |
CYLINDER_SQ |
DATA_FRAME_ASSIGNMENT_SQ |
DATA_INFO |
DATA_OBSERVATION |
DECOMPOSITION_MATERIAL |
DEFINITION_SOURCE |
DEFINITION_SOURCE_IN_RT |
DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE |
DEFORMABLE_REG_GRID |
DEFORMABLE_REGISTRATION |
DEIDENTIFICATION_ACTION |
DELIVERED_DEPTH_DOSE_PARAMETERS |
DELIVERY_VERIF_IMAGE_SQ |
DEPTH_DOSE_PARAMETERS |
DERIVATION_CONCEPTUAL_VOLUME |
DERIVATION_IMAGE |
DETECTOR_INFO |
DETECTOR_POSITION |
DEVICE |
DEVICE_IDENTIFICATION_MACRO |
DEVICE_MOTION_CONTROL |
DICOM_RETRIEVAL |
DICOM_STORAGE |
DICOM_STORAGE_GET |
DIFFUSION_B_MATRIX |
DIFFUSION_GRADIENT |
DIGITAL_FILTER_CHARACTERISTICS |
DIGITAL_SIGNATURES |
DIMENSION_INDEX |
DIMENSION_ORGANIZATION |
DIR_REC_ANNOTATION |
DIR_REC_ASSESSMENT |
DIR_REC_CURVE |
DIR_REC_ENCAP_DOC |
DIR_REC_FIDUCIAL |
DIR_REC_FILM_BOX |
DIR_REC_FILM_SESSION |
DIR_REC_HANGING_PROTOCOL |
DIR_REC_IMAGE |
DIR_REC_IMAGE_BOX |
DIR_REC_IMPLANT |
DIR_REC_IMPLANT_ASSY |
DIR_REC_IMPLANT_GROUP |
DIR_REC_INTERPRETATION |
DIR_REC_INVENTORY |
DIR_REC_KEY_OBJECT_DOC |
DIR_REC_MEASUREMENT |
DIR_REC_MODALITY_LUT |
DIR_REC_MRDR |
DIR_REC_OVERLAY |
DIR_REC_PALETTE |
DIR_REC_PATIENT |
DIR_REC_PLAN |
DIR_REC_PRESENTATION |
DIR_REC_PRINT_QUEUE |
DIR_REC_PRIVATE |
DIR_REC_RADIOTHERAPY |
DIR_REC_RAW_DATA |
DIR_REC_REGISTRATION |
DIR_REC_RESULTS |
DIR_REC_RT_DOSE |
DIR_REC_RT_PLAN |
DIR_REC_RT_STRUCTURE_SET |
DIR_REC_RT_TREAT_RECORD |
DIR_REC_SERIES |
DIR_REC_SPECTROSCOPY |
DIR_REC_SR_DOCUMENT |
DIR_REC_STEREOMETRIC |
DIR_REC_STORED_PRINT |
DIR_REC_STUDY |
DIR_REC_STUDY_COMPONENT |
DIR_REC_SURFACE |
DIR_REC_SURFACE_SCAN |
DIR_REC_TOPIC |
DIR_REC_TRACT |
DIR_REC_VALUE_MAP |
DIR_REC_VISIT |
DIR_REC_VOI_LUT |
DIR_REC_WAVEFORM |
DIRECT_SEGMENT_REFERENCE |
DISPLAY_CALIBRATION_RESULT |
DISPLAY_CALIBRATION_RESULT_SCP |
DISPLAY_CALIBRATION_RESULT_SCU |
DISPLAY_SETS |
DISPLAY_SHUTTER_MACRO |
DISPLAY_SUBSYSTEM |
DISPLAY_SUBSYSTEM_CONFIGURATION |
DISPLAY_SUBSYSTEM_CONFIGURATION_SCP |
DISPLAY_SUBSYSTEM_QA_RESULTS |
DISPLAY_SUBSYSTEM_QA_RESULTS_SCP |
DISPLAY_SUBSYSTEM_QA_RESULTS_SCU |
DISPLAY_SUBSYSTEM_SCP |
DISPLAY_SUBSYSTEM_SCU |
DISPLAYED_AREA_SELECTION |
DOSE_CALIBRATION_CONDITIONS |
DOSE_REFERENCE |
DOSE_VALUES |
DOSIMETRIC_OBJECTIVE |
DOSIMETRIC_OBJECTIVE_PARAMETER |
DVH |
DVH_REF_ROI |
DX_PATIENT_ORIENTATION_CODE |
EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE |
ELECTRON_APPLICATOR |
ENCRYPTED_ATTRIBUTES |
ENERGY_WINDOW_INFO |
ENERGY_WINDOW_RANGE |
ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS |
ENHANCED_CONTRAST_BOLUS_AGENT |
ENHANCED_PALETTE_COLOR_TABLE_SQ |
EQUIPMENT_ADMINISTRATOR |
EQUIPMENT_ADMINISTRATOR_SCP |
EQUIPMENT_ADMINISTRATOR_SCU |
EQUIPMENT_REFERENCE_POINT_COORDINATES |
EQUIVALENT_CDA_DOC |
EQUIVALENT_CODE |
EQUIVALENT_CONCEPTUAL_VOLUMES |
EVENT_TIMER_SQ |
EXCITATION_WAVELENGTH |
EXCLUDED_INTERVALS_SQ |
EXPECTED_IN_VIVO_MEASUREMENT_VALUES |
EXPOSURE_CONTROL_SENSING_REGIONS |
EXPOSURE_DOSE |
EXPOSURE_SEQUENCE |
EXTENDED_SELECTOR_ATTRIBUTE_MACRO |
EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION |
FAILED_ATTRIBUTES_NGET |
FAILED_ATTRIBUTES_SQ |
FAILED_SOP |
FAILED_SOP_MEDIA_CREATION |
FIDUCIAL |
FIDUCIAL_SET |
FIELD_OF_VIEW |
FILE_ACCESS |
FILE_ACCESS_IN_INVENTORY_FIND_RSP |
FILE_ACCESS_IN_REPOSITORY_QUERY |
FILE_SET_ACCESS |
FILE_SET_ACCESS_IN_REPOSITORY_QUERY |
FILL_STYLE |
FILM_BOX_CONTENT |
FILM_CONSUMPTION |
FILTER_OPERATIONS |
FIXATION |
FIXATION_DEVICE |
FIXATION_DEVICE_IN_GEN_MACH_VERI |
FLAT_CORNEAL_AXIS |
FLOW_IDENTIFIER |
FLUENCE_MAP |
FRACTION_BASED_RELATIONSHIP |
FRACTION_GROUP |
FRACTION_GROUP_SUMMARY |
FRACTION_PATTERN |
FRACTION_STATUS_SUMMARY |
FRAME_ACQUISITION |
FRAME_ANATOMY |
FRAME_CONTENT |
FRAME_DETECTOR_PARAMETERS |
FRAME_DISPLAY |
FRAME_DISPLAY_SHUTTER |
FRAME_EXTRACTION |
FRAME_PIXEL_DATA_PROPERTIES |
FRAME_PIXEL_INTENSITY_REL_LUT |
FRAME_PIXEL_SHIFT |
FRAME_USEFULNESS_GROUP |
FRAME_VOI_LUT |
FRAME_VOI_LUT_WITH_LUT |
FUNC_GROUP_BREAST_PROJ_XRAY_FRAME |
FUNC_GROUP_BREAST_PROJ_XRAY_SHARE |
FUNC_GROUP_BREAST_TOMO_FRAME |
FUNC_GROUP_BREAST_TOMO_SHARE |
FUNC_GROUP_ENHANCED_CT_FRAME |
FUNC_GROUP_ENHANCED_CT_SHARE |
FUNC_GROUP_ENHANCED_MR_FRAME |
FUNC_GROUP_ENHANCED_MR_SHARE |
FUNC_GROUP_ENHANCED_PET_FRAME |
FUNC_GROUP_ENHANCED_PET_SHARE |
FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME |
FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE |
FUNC_GROUP_ENHANCED_US_VOL_FRAME |
FUNC_GROUP_ENHANCED_US_VOL_SHARE |
FUNC_GROUP_ENHANCED_XA_FRAME |
FUNC_GROUP_ENHANCED_XA_SHARE |
FUNC_GROUP_ENHANCED_XRF_FRAME |
FUNC_GROUP_ENHANCED_XRF_SHARE |
FUNC_GROUP_IVOCT_FRAME |
FUNC_GROUP_IVOCT_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE |
FUNC_GROUP_MR_SPECTROSCOPY_FRAME |
FUNC_GROUP_MR_SPECTROSCOPY_SHARE |
FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME |
FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE |
FUNC_GROUP_OPHTHALMIC_TOMO_FRAME |
FUNC_GROUP_OPHTHALMIC_TOMO_SHARE |
FUNC_GROUP_PARAMETRIC_MAP_FRAME |
FUNC_GROUP_PARAMETRIC_MAP_SHARE |
FUNC_GROUP_PHOTOACOUSTIC_FRAME |
FUNC_GROUP_PHOTOACOUSTIC_SHARE |
FUNC_GROUP_SECONDARY_CAPTURE |
FUNC_GROUP_SEGMENTATION_FRAME |
FUNC_GROUP_SEGMENTATION_SHARE |
FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE |
FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE |
FUNC_GROUP_VL_WH_SL_MICRO_FRAME |
FUNC_GROUP_VL_WH_SL_MICRO_SHARE |
FUNC_GROUP_XRAY_3D_ANGIO_FRAME |
FUNC_GROUP_XRAY_3D_ANGIO_SHARE |
FUNC_GROUP_XRAY_3D_CRANIO_FRAME |
FUNC_GROUP_XRAY_3D_CRANIO_SHARE |
FUNCTIONAL_MR |
GATED_INFO |
GATING_BEAM_HOLD_TRANSITION |
GENERAL_ACCESSORY |
GENERAL_ACCESSORY_DEFINITION |
GENERAL_ACCESSORY_IN_RT_ION_BEAMS |
GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD |
GENERAL_MACHINE_VERIFICATION |
GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM |
GENETIC_MODIFICATIONS |
GLOBAL_DEVIATION_PROBABILITY |
GRAPHIC_ANNOTATION |
GRAPHIC_COORDINATES_DATA |
GRAPHIC_GROUP |
GRAPHIC_LAYER |
GRAPHIC_OBJECT |
GROUP_OF_PATIENTS_IDENTIFICATION |
HANGING_PROTOCOL_DEFINITION |
HIERARCHICAL_SERIES_REF_MACRO |
HIERARCHICAL_SOP_INST_REF_MACRO |
HISTOGRAM |
HL7_HIERARCHIC_DESIGNATOR_MACRO |
HL7_STRUCT_DOC_REF |
HL7_STRUCT_DOC_REF_MWL |
HPGL_DOCUMENT |
HPGL_PEN |
ICON_IMAGE |
IDENTIFIED_PERSON_DEVICE_MACRO |
IMAGE_BOX_CONTENT |
IMAGE_BOX_SYNCHRONIZATION |
IMAGE_BOXES |
IMAGE_CENTER_POINT_COORDINATES |
IMAGE_DATA_TYPE_SQ |
IMAGE_FILTER_DETAILS |
IMAGE_OVERLAY_BOX_CONTENT |
IMAGE_PIXEL_MACRO |
IMAGE_SEGMENT |
IMAGE_SET_SELECTOR |
IMAGE_SETS |
IMAGE_SOP_INSTANCE_REF_MACRO |
IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC |
IMAGING_DEVICE_LOCATION_PARAMETER |
IMAGING_POSITION |
IMAGING_POSITION_PARAMETERIZED |
IMPLANT_ASSMBLY_TMPL_TARGET_ANAT |
IMPLANT_TARGET_ANATOMY |
IMPLANT_TEMPLATE_GROUP_MEMBERS |
IMPLANT_TEMPLATE_GRP_TARGET_ANAT |
IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK |
IMPLANT_TEMPLATE_GRP_VAR_DIMENS |
IMPLANT_TEMPLATE_GRPMM_2D_COORDS |
INDEX_PROBABILITY |
INFORMATION_FROM_MANUFACTURER |
INSTRUCTION |
INTERLOCK |
INTERPRETATION_APPROVER |
INTERV_DRUG_INFO |
INTERVENTIONAL_THERAPY |
INTRAOCULAR_LENS_CALC_LEFT_EYE |
INTRAOCULAR_LENS_CALC_RIGHT_EYE |
INVENTORIED_INSTANCES |
INVENTORIED_SERIES |
INVENTORIED_STUDIES |
INVENTORY_REFERENCE_MACRO |
IOL_POWER |
ION_BEAM |
ION_BEAM_LIMITING_DEVICE |
ION_BLOCK |
ION_CONTROL_POINT |
ION_CONTROL_POINT_DELIVERY |
ION_CONTROL_POINT_VERIFICATION |
ION_MACHINE_VERIFICATION |
ION_RANGE_COMPENSATOR |
ION_TOLERANCE_TABLE |
ION_WEDGE |
ION_WEDGE_POS_ION_CTL_PT_VERIF |
ION_WEDGE_POSITION |
IRRADIATION_EVENT_ID |
ISOCENTER_REFERENCE_SYSTEM |
ISSUER_PATIENT_ID_QUALIFIERS |
IV_FRAME_CONTENT |
IVOCT_FRAME_CONTENT |
IVOCT_FRAME_TYPE |
KERATOMETRIC_AXIS |
KERATOMETRY_ANY_EYE |
KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO |
LANGUAGE_CODE_RQ |
LANGUAGE_CODE_RSP |
LATERAL_SPREADING_DEVICE |
LATERAL_SPREADING_DEVICE_SETTING |
LENS_CONSTANT |
LENS_SQ |
LENS_THICKNESS |
LIGHT_PATH_FILTER_TYPE_STACK |
LINE_STYLE |
LOCALIZED_DEVIATION_PROBABILITY |
LUMINANCE_RESPONSE |
LUMINANCE_RESPONSE_QA_SCP |
LUMINANCE_RESPONSE_QA_SCU |
LUMINANCE_RESPONSE_SCP |
LUMINANCE_RESPONSE_SCU |
LUMINANCE_RESPONSE1 |
LUMINANCE_RESULT |
LUMINANCE_RESULT_SCP |
LUMINANCE_RESULT_SCU |
LUMINANCE_UNIFORMITY_RESULT |
LUMINANCE_UNIFORMITY_RESULT_SCP |
LUMINANCE_UNIFORMITY_RESULT_SCU |
MAC_PARAMETERS |
MAJOR_TICKS |
MAPPING_RESOURCE_IDENTIFICATION |
MASK_FRAME_PIXEL_SHIFT |
MASK_SUBTRACTION |
MASK_SUBTRACTION_IN_PS |
MATERIAL_ATTENUATION |
MATING_FEATURE |
MATING_FEATURE_DEGREE_OF_FREEDOM |
MATING_FEATURE_SETS |
MATRIX |
MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO |
MATRIX_REGISTRATION |
MAXIMUM_CORNEAL_CURVATURE |
MEASURED_DOSE_REFERENCE |
MEASURED_METERSET_TO_DOSE_MAPPING |
MEASURED_VALUE |
MEASUREMENT_EQUIPMENT |
MEASUREMENT_EQUIPMENT_SCP_MACRO |
MEASUREMENT_EQUIPMENT_SCP_NGET |
MEASUREMENT_VALUES |
MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MEASUREMENTS |
MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MEDIA_INSTALLED |
MEDIA_RETRIEVAL |
METERSET_TO_DOSE_MAPPING |
MINIMUM_KERATOMETRIC |
MODALITY_LUT |
MODEL_SPECIFICATION |
MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ |
MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP |
MODIFIED_ATTRIBUTES |
MR_ARTERIAL_SPIN_LABELING |
MR_AVERAGES |
MR_DIFFUSION |
MR_ECHO |
MR_FOV_GEOMETRY |
MR_IMAGE_DESCRIPTION_MACRO |
MR_IMAGE_FRAME_TYPE |
MR_IMAGING_MODIFIER |
MR_METABOLITE_MAP |
MR_MODIFIER |
MR_RECEIVE_COIL |
MR_SPATIAL_SATURATION |
MR_SPECTROSCOPY_FOV_GEOMETRY_MAC |
MR_SPECTROSCOPY_FRAME_TYPE |
MR_TIMING_RELATED_PARMS |
MR_TRANSMIT_COIL |
MR_VELOCITY_ENCODING |
MULTI_COIL_DEFINITION |
MULTI_ENERGY_CT_ACQUISITION |
MULTI_ENERGY_CT_CHARACTERISTICS |
MULTI_ENERGY_CT_PATH |
MULTI_ENERGY_CT_PROCESSING |
MULTI_ENERGY_CT_XRAY_DETECTOR |
MULTI_ENERGY_CT_XRAY_SOURCE |
MULTI_FRAME_PRESENTATION |
MULTIPLEXED_AUDIO_CHANNELS |
MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO |
MYDRIATIC_AGENT |
NAVIGATION_INDICATOR |
NOMINAL_SCREEN_DEFINITION |
NONCONFORMING_MODIFIED_ATTRIBUTES |
NOTIFICATION_FROM_MANUFACTURER |
OBJECT_THICKNESS |
OBLIQUE_CROPPING_PLANE |
OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS |
OMITTED_APPLICATION_SETUP |
OMITTED_BEAM_TASK |
OMITTED_CHANNEL |
OMITTED_RADIATION |
OPERATING_MODE |
OPERATOR_IDENTIFICATION |
OPHT_AXIAL_LENGTH |
OPHT_AXL_LEN_MEAS_LEN_SUMMATION |
OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN |
OPHT_AXL_LEN_MEAS_TOTAL_LEN |
OPHT_AXL_LEN_MEASUREMENTS |
OPHT_AXL_LEN_QUALITY_METRIC |
OPHT_AXL_MEAS_LEFT_EYE |
OPHT_AXL_MEAS_RIGHT_EYE |
OPHT_PAT_CLINICAL_INFO_LEFT_EYE |
OPHT_PAT_CLINICAL_INFO_RIGHT_EYE |
OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING |
OPHTHALMIC_FRAME_LOCATION |
OPM_THICKNESS_MAP_Q_THRESHOLD |
OPM_THICKNESS_MAP_QR_SEQ |
OPTICAL_OPHT_AXL_LEN_MEAS |
OPTICAL_PATH |
OPTICAL_PATH_IDENTIFICATION |
OPTICAL_SEL_OPHT_AXL_LEN |
ORIGINAL_ATTRIBUTES |
ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP |
ORIGINAL_IMAGE |
OTHER_FAILURES |
OTHER_MEDIA_AVAILABLE |
OTHER_PATIENT_IDS |
OTHER_PATIENT_IDS_IN_INVENTORY |
OTHER_PATIENT_IDS_PAT_ID |
OTHER_PATIENT_IDS_UPS |
OUTLINE_DEFINITION_MACRO |
OUTPUT_DESTINATION |
OUTPUT_DESTINATION_GET |
OUTPUT_INFORMATION |
OVERLAY_PIXEL_DATA |
OVERRIDE |
OVERRIDE_IN_RT_BRACHY_SESS |
OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION |
OVERRIDEN_ATTRIBUTES_NGET |
OVERRIDEN_ATTRIBUTES_SQ |
PALETTE_COLOR_LOOKUP_TABLE |
PARALLEL_RT_BEAM_DELIMITER_DEVICE |
PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO |
PARAMETERS_SPECIFICATION |
PARAMETRIC_MAP_FRAME_TYPE |
PARTICIPANT |
PATIENT_CLINICAL_TRIAL |
PATIENT_LOCATION_COORDINATES |
PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO |
PATIENT_ORIENTATION_CODE |
PATIENT_ORIENTATION_IN_FRAME |
PATIENT_PHYSIOLOGICAL_STATE |
PATIENT_POSITIONING_INSTRUCTION |
PATIENT_SETUP |
PATIENT_SETUP_IN_GEN_MACH_VERIF |
PATIENT_SUPPORT_DEVICES |
PATIENT_SUPPORT_POSITION |
PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER |
PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE |
PATIENT_SUPPORT_POSITION_PARAMETER |
PATIENT_SUPPORT_POSITION_TOLERANCE |
PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO |
PATIENT_TREATMENT_PREPARATION_PROCEDURE |
PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ |
PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP |
PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE |
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ |
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP |
PER_PROJECTION_ACQUISITION_ANGIO |
PER_PROJECTION_ACQUISITION_TOMO |
PERFORMED_PROTOCOL_CODE |
PERFORMED_SERIES |
PERSON_IDENTIFICATION_MACRO |
PERTINENT_DOCUMENTS |
PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO |
PERTINENT_DOCUMENTS_IN_SUBSTANCE |
PERTINENT_DOCUMENTS_MWL_CFIND_RSP |
PERTINENT_RESOURCES |
PET_DETECTOR_MOTION_DETAILS |
PET_FRAME_ACQUISITION |
PET_FRAME_CORRECTION_FACTORS |
PET_FRAME_TYPE |
PET_POSITION |
PET_RECONSTRACTION |
PET_TABLE_DYNAMICS |
PHASE_INFO |
PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS |
PHOTOACOUSTIC_IMAGE_DATA_TYPE |
PHOTOACOUSTIC_IMAGE_FRAME_TYPE |
PIXEL_INTENSITY_RELATIONSHIP_LUT |
PIXEL_MEASURES |
PIXEL_SPACING |
PIXEL_VALUE_MAP_TO_CODED_CONCEPT |
PIXEL_VALUE_TRANSFORM_WITH_EV |
PIXEL_VALUE_TRANSFORMATION |
PLAN_OVERVIEW |
PLANE_ORIENTATION |
PLANE_ORIENTATION_VOLUME |
PLANE_POSITION |
PLANE_POSITION_SLIDE |
PLANE_POSITION_VOLUME |
PLANNED_VERIFICATION_IMAGE |
PLANNING_LANDMARK_LINE |
PLANNING_LANDMARK_PLANE |
PLANNING_LANDMARK_POINT |
POINTS_MACRO |
POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION |
POSITIONER_POSITION |
POST_DEFORMATION_MATRIX_REG |
PRE_DEFORMATION_MATRIX_REG |
PREFORMATTED_COLOR_IMAGE |
PREFORMATTED_GRAYSCALE_IMAGE |
PRESCRIPTION_OVERVIEW |
PRESENTATION_LUT |
PRESENTATION_LUT_CONTENT |
PRESENTATION_STATE_CLASSIFICATION_COMPONENT |
PRESENTATION_STATE_COMPOSITOR_COMPONENT |
PRIMARY_ANATOMIC_STRUCTURE |
PRIMARY_FLUENCE_MODE |
PRIMITIVE_POINT |
PRIMITIVE_POINT_CP1365 |
PRINT_JOB_DESCRIPTION |
PRINT_MANAGEMENT_CAPABILITIES |
PRINTER_CHARACTERISTICS |
PRINTER_CONFIGURATION |
PRISM_SQ |
PRIVATE_DATA_ELEMENT_CHARACTERISTICS |
PRIVATE_DATA_ELEMENT_DEFINITION |
PROCEDURE_STEP_PROGRESS_PARAMETERS |
PROCEDURE_STEP_PROGRESS_PARAMETERS_GET |
PROCEDURE_STEP_PROGRESS_PARAMETERS_SET |
PROCEDURE_TYPE_CODE_QUERY |
PROJECTION_IMAGING_ACQUISITION_PARAMETER |
PROJECTION_PIXEL_CALIBRATION |
PROPOSED_STUDY |
PROTOCOL_CONTEXT |
PROTOCOL_CONTEXT_MWL_CFIND_RSP |
PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED |
PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP |
QA_RESULTS |
QA_RESULTS_SCP |
QA_RESULTS_SCU |
QUANTITY |
RADIATION_DOSE |
RADIATION_DOSE_IDENTIFICATION |
RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_DOSE_VALUES_PARAMETERS |
RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_GENERATION_MODE |
RADIATION_GENERATION_MODE_MACRO |
RADIOBIOLOGICAL_DOSE_EFFECT |
RADIOPHARM_INFO |
RADIOPHARM_INFO_ENH_PET |
RADIOPHARM_INFO_PET |
RADIOPHARM_USAGE |
RANGE_MODULATOR |
RANGE_MODULATOR_SETTINGS |
RANGE_SHIFTER |
RANGE_SHIFTER_SETTINGS |
REAL_TIME_BULK_DATA_FLOW |
REAL_WORLD_VALUE_MAP_MACRO |
REAL_WORLD_VALUE_MAPPING |
RECONSTRUCTION_PROTOCOL_ELEMENT_CT |
RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION |
RECONSTRUCTION_PROTOCOL_ELEMENT_XA |
RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ |
RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ |
RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ |
RECORDED_BLOCK_SLAB |
RECORDED_BRACHY_ACCESSORY_DEVICE |
RECORDED_CHANNEL |
RECORDED_CHANNEL_SHIELD |
RECORDED_COMPENSATOR |
RECORDED_COMPENSATOR_IN_GEN_MV |
RECORDED_COMPENSATOR_IN_ION |
RECORDED_LATERAL_SPREADING_DEV |
RECORDED_RANGE_MODULATOR |
RECORDED_RANGE_SHIFTER |
RECORDED_SNOUT |
RECORDED_SOURCE |
RECORDED_SOURCE_APPLICATOR |
RECORDED_WEDGE |
REF_BASIC_ANNOTATION_BOX |
REF_BEAM |
REF_BEAM_IN_DOSE |
REF_BOLUS |
REF_BOLUS_IN_ION |
REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP |
REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP |
REF_CALCULATED_DOSE_REFERENCE |
REF_COMPOSITE_OBJECT |
REF_CONTROL_POINT |
REF_CURVE |
REF_DEFINED_OR_PERFORMED_PROTOCOL |
REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP |
REF_DIGITAL_SIGNATURE |
REF_DOSE |
REF_DOSE_REFERENCE |
REF_DOSE_REFERENCE_IN_BEAM |
REF_DOSE_REFERENCE_IN_CONTROL_POINT |
REF_DOSE_REFERENCE_IN_ION |
REF_FILM_BOX |
REF_FILM_SESSION |
REF_FRACTION_GROUP |
REF_FRAME_OF_REFERENCE |
REF_G_P_SCHEDULED_PROCEDURE_STEP |
REF_IMAGE |
REF_IMAGE_BOX |
REF_IMAGE_DISPLAY_SYSTEM_SCP |
REF_IMAGE_DISPLAY_SYSTEM_SCU |
REF_IMAGE_F5_23 |
REF_IMAGE_IN_ADVANCED_BLENDING_PS |
REF_IMAGE_IN_IMAGE_BOX |
REF_IMAGE_IN_REF_SERIES |
REF_IMAGE_IN_STORE |
REF_IMAGE_IN_VISUAL_EVAL_RESULT |
REF_IMAGE_IN_XRAY_IMAGE |
REF_IMAGE_OVERLAY_BOX |
REF_IMAGE_OVERLAY_BOX_IN_STORE |
REF_IMAGE_REAL_WORLD_FOR_NM |
REF_IMAGE_REAL_WORLD_VALUE_MAP |
REF_IMAGE_RQ_F_4_3 |
REF_IMAGE_RSP_F_4_2 |
REF_IMAGE_RSP_F_4_3 |
REF_IMAGE_RT |
REF_IMAGE_STRUCT_DISPLAY |
REF_INSTANCE |
REF_INSTANCE_IN_CONTRIB |
REF_INSTANCES_AND_ACCESS_MACRO |
REF_INTERPRETATION |
REF_MEASURED_DOSE_REFERENCE |
REF_OPHT_AXL_LEN_MEAS_QC_IMAGE |
REF_OVERLAY |
REF_OVERLAY_IN_CURVE |
REF_OVERLAY_IN_IMAGE_BOX |
REF_PATIENT |
REF_PATIENT_ALIAS |
REF_PATIENT_CFIND |
REF_PERF_PROC_STEP_INST_AVAIL |
REF_PERFORMED_PROCEDURE_STEP |
REF_PRESENTATION_LUT |
REF_PRESENTATION_LUT_IN_STORE |
REF_PRINT_JOB |
REF_PRINT_JOB_IN_DESCRIPTION |
REF_REAL_WORLD_VALUE_MAPPING |
REF_REFERENCE_IMAGE |
REF_REFERENCE_IMAGE_IN_ION |
REF_RESULTS |
REF_ROI |
REF_RT_PLAN |
REF_RT_PLAN_IN_DOSE |
REF_RT_PLAN_IN_GENERAL_PLAN |
REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO |
REF_RT_SERIES |
REF_RT_STUDY |
REF_SERIES |
REF_SERIES_F5_23 |
REF_SERIES_IN_COMMON_INSTANCE |
REF_SERIES_IN_CONTRIB |
REF_SERIES_IN_PS |
REF_SERIES_IN_RELATED_IES |
REF_SERIES_NOTIFICATION |
REF_SERIES_RQ_F_4_2 |
REF_SERIES_RQ_F_4_3 |
REF_SERIES_RSP_F_4_2 |
REF_SERIES_RSP_F_4_3 |
REF_SETUP_IMAGE |
REF_SOP |
REF_SOP_AE_RQ |
REF_SOP_AE_RSP |
REF_SOP_FOR_IMAGE_REF_MACRO |
REF_SOP_FOR_WAVEFORM_REF_MACRO |
REF_SOP_IN_HS_MACRO |
REF_SOP_IN_STOW_RS_RSP |
REF_SOP_INSTANCE_MAC |
REF_SOP_MEDIA |
REF_SOP_MEDIA_AE |
REF_SOP_MEDIA_CREATION |
REF_SOP_NOTIFICATION |
REF_STORAGE_MEDIA |
REF_STORED_PRINT |
REF_STRUCTURE_SET |
REF_STUDY |
REF_STUDY_CFIND |
REF_STUDY_COMPONENT |
REF_STUDY_IN_RELATED_IES |
REF_TREATMENT_RECORD |
REF_VERIFICATION_IMAGE |
REF_VISIT |
REF_VOI_LUT_BOX |
REFERENCE_LOCATION_MACRO |
REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE |
REFERENCED_DOSIMETRIC_OBJECTIVES |
REFERENCED_IMAGE |
REFERENCED_PATIENT_SETUP_PHOTO |
REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO |
REFERENCED_REQUEST |
REFERENCED_REQUEST_N_CREATE_RQ |
REFERENCED_REQUEST_N_CREATE_RSP |
REFERENCED_REQUEST_N_GET_RQ |
REFERENCED_REQUEST_UPS |
REFERENCED_RT_PHYSICIAN_INTENT |
REFERENCED_RT_PRESCRIPTION |
REFERENCED_RT_RADIATION_SET |
REFERENCED_RT_TREATMENT_PHASE |
REFERENCED_SERIES_10_4 |
REFERENCED_SOP |
REFERENCED_SOP_10_3b |
REFERENCED_STRUCTURED_CONTEXT |
REFERENCED_SURFACE |
REFERENCED_SURFACE_MESH_IDENTIFICATION |
REFRACTIVE_PARAMS_USED_ON_PAT |
REFRACTIVE_STATE |
REFRACTIVE_STATE_IOL |
REGION_PIXEL_SHIFT |
REGISTRATION |
REGISTRATION_TO_LOCALIZER_SEQ |
REL_OPT_ATTRIBUTES_SEQ |
RELATED_ASSERTION |
RELATED_INFORMATION_ENTITIES_MACRO |
RELATED_PROCEDURE_STEP_N_CREATE |
RELATED_PROCEDURE_STEP_N_GET_RSP |
RELATED_PROCEDURE_STEP_SQ |
RELATED_RT_ROI_OBSERVATIONS |
RELATED_SERIES |
REQUEST_ATTRIBUTES |
REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP |
RESPIRATORY_TRIGGER |
RESULTS_DISTRIBUTION_LIST |
RESULTS_NORMALS |
ROBOTIC_PATH_CONTROL_POINT |
ROI_CONTOUR |
ROI_DENSITY |
ROI_ELEMENTAL_COMPOSITION |
ROI_PHYSICAL_PROPERTIES |
ROTATION_INFO |
RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO |
RT_ACCESSORY_HOLDER_DEFINITION |
RT_ACCESSORY_HOLDER_SLOT |
RT_ANATOMIC_PRESCRIPTION |
RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO |
RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO |
RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO |
RT_DOSE_ROI |
RT_IMAGE_FRAME_CONTEXT |
RT_IMAGE_FRAME_GENERAL_CONTENT |
RT_IMAGE_FRAME_RADIATION_ACQUISITION |
RT_MOTION_SYNCHRONIZATION |
RT_PATIENT_POSITION_DISPLACEMENT |
RT_PATIENT_POSITION_MACRO |
RT_PATIENT_POSITION_SCOPE_MACRO |
RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO |
RT_PHYSICIAN_INTENT |
RT_PHYSICIAN_INTENT_INPUT_INSTANCE |
RT_PHYSICIAN_INTENT_PREDECESSOR |
RT_PRESCRIPTION |
RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT |
RT_RADIATION_TASK |
RT_RELATED_ROI |
RT_ROI_IDENTIFICATION_CODE |
RT_ROI_OBSERVATIONS |
RT_SEGMENT_ANNOTATION |
RT_TOLERANCE_SET_MACRO |
RT_TREATMENT_PHASE_INTERVAL |
RT_TREATMENT_PHASE_MACRO |
SCHED_HUMAN_PERFORMERS |
SCHED_HUMAN_PERFORMERS_M |
SCHEDULED_ACTION_ITEM_CODE |
SCHEDULED_PROCEDURE_STEP |
SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ |
SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP |
SCHEDULED_PROTOCOL_CODE |
SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP |
SCHEDULED_SPECIMEN_MWL_CFIND_RQ |
SCHEDULED_SPECIMEN_MWL_CFIND_RSP |
SCHEDULED_STEP_ATTRIBUTE |
SCOPE_OF_INVENTORY |
SCREENING_BASELINE_MEASURED |
SEGMENT |
SEGMENT_ANNOTATION_TYPE_CODE |
SEGMENT_IDENTIFICATION |
SEGMENT_REFERENCE |
SEGMENTED_PROPERTY_TYPE_CODE |
SEGMENTED_RT_ACCESSORY_DEVICE |
SELECTED_FRAME_FUNCTIONAL_GROUPS |
SELECTED_SEGMENTAL_OPHT_AXL_LEN |
SELECTED_TOTAL_OPHT_AXL_LENGTH |
SETUP_DEVICE |
SHIELDING_DEVICE |
SIMULATED_KERATOMETRIC_CYLINDER |
SNOUT |
SOFTCOPY_PRESENTATION_LUT |
SOFTCOPY_VOI_LUT |
SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS |
SOP_INSTANCE_REF_MACRO |
SORTING_OPERATIONS |
SOUND_SPEED_CORRECTION_MECHANISM |
SOURCE |
SOURCE_CONCEPTUAL_VOLUME |
SOURCE_HANGING_PROTOCOL |
SOURCE_IMAGE |
SOURCE_IMAGE_CORNEAL_PROCESSED_DATA |
SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP |
SOURCE_IMAGE_IN_DERIVATION_IMAGE |
SOURCE_IMAGE_IN_ENHANCED_US |
SOURCE_IMAGE_IN_OPHTHALMIC |
SOURCE_INSTANCE |
SOURCE_IRRADIATION_EVENT |
SOURCE_OF_REFRACTIVE_MEASUREMENTS |
SOURCE_PATIENT_GROUP_IDENTIFICATION |
SOURCE_PIXEL_PLANES_CHARACTERISTICS |
SOURCE_WAVEFORM |
SPECIFIC_ABSORPTION_RATE |
SPECIMEN_DESCRIPTION |
SPECIMEN_DESCRIPTION_IN_IMAGE |
SPECIMEN_DESCRIPTION_IN_INVENTORY |
SPECIMEN_DESCRIPTION_MWL_CFIND_RQ |
SPECIMEN_DESCRIPTION_MWL_CFIND_RSP |
SPECIMEN_MACRO |
SPECIMEN_PREPARATION |
SPECIMEN_REFERENCE |
SR_CONTENT |
STEEP_CORNEAL_AXIS |
STEREO_PAIRS |
STORAGE_MACRO |
STORAGE_PROTOCOL_ELEMENT |
STORAGE_PROTOCOL_ELEMENT_SPECIFICATION |
STORED_VALUE_COLOR_RANGE |
STOW_RS_STORAGE |
STOW_RS_STORAGE_GET |
STRAIN_STOCK |
STRUCTURE_SET_ROI |
STRUCTURED_CONSTRAINT_OBSERVATION |
STRUCTURED_DISPLAY_IMAGE_BOX |
STRUCTURED_DISPLAY_TEXT_BOX |
STUDIES_CONTAIN_OTHER_REF_INST |
SUBJECTIVE_REFRACTION_EYE |
SUPPORTED_IMAGE_DISPLAY_FORMATS |
SURFACE |
SURFACE_MESH_PR_MACRO |
SURFACE_MESH_PR_MACRO_CP1365 |
SURFACE_MODEL_DESCRIPTION |
SURFACE_POINTS |
SURGICALLY_INDUCED_ASTIGMATISM |
SYNCHRONIZED_SCROLLING |
TABLE_COLUMN_DEFINITION |
TABLE_POSITION |
TABLE_ROW_DEFINITION |
TABULATED_VALUES |
TARGET_LUMINANCE_CHARACTERISTICS |
TARGET_LUMINANCE_CHARACTERISTICS_SCP |
TARGET_LUMINANCE_CHARACTERISTICS_SCU |
TEMPORAL_POSITION |
TEXT_OBJECT |
TEXT_OBJECT_VOLUMETRIC |
TEXT_STYLE |
THRESHOLD |
THRESHOLD_VALUE |
TIME_BASED_IMAGE_SETS |
TIME_OF_FRAME_GROUP |
TIME_SLOT_INFO |
TOLERANCE_TABLE |
TOMOTHERAPEUTIC_CONTROL_POINT |
TOTAL_PIXEL_MATRIX_ORIGIN |
TRACK |
TRACK_SET |
TRACK_SET_ANATOMICAL_TYPE_CODE |
TRACK_SET_STATISTICS |
TRACK_STATISTICS |
TRANSDUCER_IDENTIFICATION |
TRANSDUCER_ORIENTATION |
TRANSDUCER_POSITION |
TRANSDUCER_RESPONSE |
TREAT_SESSION_APPLICATION_SETUP |
TREAT_SUM_CALCULATED_DOSE_REF |
TREAT_SUM_MEASURED_DOSE_REF |
TREATMENT_DEVICE_IDENTIFICATION |
TREATMENT_MACHINE |
TREATMENT_MACHINE_IN_TREAT |
TREATMENT_POSITION |
TREATMENT_POSITION_GROUP |
TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO |
TREATMENT_SESSION_BEAM |
TREATMENT_SESSION_ION_BEAM |
TREATMENT_SITE_CODE |
TREATMENT_TOLERANCE_VIOLATION |
UDI_MACRO |
ULTRASOUND_OPHT_AXL_LEN_MEAS |
ULTRASOUND_REGION |
ULTRASOUND_SEL_OPHT_AXL_LEN |
UPS_ACTUAL_HUMAN_PERF_GET |
UPS_ACTUAL_HUMAN_PERF_SET_RQ |
UPS_ACTUAL_HUMAN_PERF_SET_RSP |
UPS_CODE_CREATE_SET |
UPS_CODE_GET |
UPS_CODE_GET_RSP |
UPS_COMMUNICATIONS_URI_SET_RQ |
UPS_COMMUNICATIONS_URI_SET_RSP |
UPS_COMMUNICATIONS_URI_SQ |
UPS_CONTENT_ITEM_CREATE_SET |
UPS_CONTENT_ITEM_GET |
UPS_DICOM_RETRIEVAL_GET |
UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE |
UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET |
UPS_ISSUER_OF_PAT_ID_QUAL_CREATE |
UPS_ISSUER_OF_PAT_ID_QUAL_GET |
UPS_MEDIA_RETRIEVAL_GET |
UPS_OTHER_PATIENT_ID_CREATE_SET |
UPS_OTHER_PATIENT_ID_GET |
UPS_PERF_PROC_GET |
UPS_PERF_PROC_SET_RQ |
UPS_PERF_PROC_SET_RSP |
UPS_PERFORMED_PROCEDURE |
UPS_PROGRESS_INFO |
UPS_PROGRESS_INFO_EVENT |
UPS_PROGRESS_INFO_GET |
UPS_PROGRESS_INFO_SET_RQ |
UPS_PROGRESS_INFO_SET_RSP |
UPS_REF_REQUEST_CREATE_RQ |
UPS_REF_REQUEST_CREATE_RSP |
UPS_REF_REQUEST_GET |
UPS_REF_SOP_ACCESS_CREATE_SET |
UPS_REF_SOP_ACCESS_GET |
UPS_REFERENCED_SOP_GET |
UPS_SCHED_HUMAN_PERF_CREATE_SET |
UPS_SCHED_HUMAN_PERF_GET |
UPS_SOP_INSTANCE_REF_GET |
UPS_WADO_RETRIEVAL_CREATE_SET |
UPS_WADO_RETRIEVAL_GET |
UPS_WADO_RS_RETRIEVAL_GET |
UPS_XDS_RETRIEVAL_GET |
US_IMAGE_DESCRIPTION_SQ |
USED_FIDUCIALS |
USED_RT_STRUCTURE_SET_ROI |
USED_SEGMENTS |
UV_MAPPING |
VARIABLE_MODALITY_LUT |
VECTORS_MACRO |
VELOCITY_ENCODING_ACQUISITION |
VERIFYING_OBSERVER |
VIEW_CODE |
VIEW_CODE_BREAST |
VIEW_CODE_OPT_VIEW_SL_PROG_DIR |
VIS_FIELD_GLOBAL_RESULTS_INDEX |
VIS_FIELD_TEST_RELI_GLOBAL_INDEX |
VISUAL_ACUITY_EYE_SQ |
VISUAL_ACUITY_MEASUREMENT |
VISUAL_EVALUATION_RESULT |
VISUAL_EVALUATION_RESULT_SCP |
VISUAL_EVALUATION_RESULT_SCU |
VISUAL_EVALUATION_TEST |
VISUAL_EVALUATION_TEST_SCP |
VISUAL_EVALUATION_TEST_SCU |
VISUAL_FIELD_CATCH_TRIAL |
VISUAL_FIELD_TEST_POINT |
VISUAL_FIELD_TEST_POINT_NORMALS |
VOI_LUT |
VOLUME_CROPPING |
VOLUME_LOCALIZATION |
VOLUME_STREAM |
VOLUMETRIC_ANNOTATION |
VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION |
VOLUMETRIC_PRESENTATION_INPUT_SET |
VOLUMETRIC_PRESENTATION_STATE_INPUT |
WADO_RETRIEVAL |
WADO_RS_RETRIEVAL |
WAVEFORM |
WAVEFORM_ANNOTATION |
WAVEFORM_FILTER_CHARACTERISTICS_MACRO |
WAVEFORM_FILTER_LOOKUP_TABLE_MACRO |
WAVEFORM_PRESENTATION_GROUP |
WEDGE_DEFINITION |
WEDGE_ITEM |
WEDGE_POSITION |
WEDGE_POSITION_IN_WP_MACRO |
WEEKDAY_FRACTION_PATTERN |
WEIGHTING_TRANSFER_FUNCTION |
WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE |
WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING |
WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD |
X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO |
XA_ACQUISITION_PHASE_DETAILS |
XA_PLANE_DETAILS |
XA_XRF_FRAME_CHARACTERISTICS |
XA_XRF_FRAME_DISPLAY_SHUTTER |
XA_XRF_MASK_SUBTRACTION |
XDS_RETRIEVAL |
XDS_STORAGE |
XDS_STORAGE_GET |
XRAY_3D_ACQUISITION_ANGIO |
XRAY_3D_ACQUISITION_CRANIO |
XRAY_3D_ACQUISITION_TOMO |
XRAY_3D_FRAME_TYPE |
XRAY_3D_RECONSTRUCTION |
XRAY_ACQUISITION_DOSE |
XRAY_FILTER |
XRAY_FILTER_DETAILS |
XRAY_GEOMETRY |
XRAY_GRID |

See Also

MCitems Structure


MCitems Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitems Fields
MCitems Structure See Also Send Feedback

The MCitems type exposes the following members.

Fields

Name | Description
_2D_DEGREE_OF_FREEDOM |
_2D_LINE_COORDINATES |
_2D_MATING_FEATURE_COORDINATES |
_2D_PLANE_COORDINATES |
_2D_POINT_COORDINATES |
_2D_TO_3D_MAP |
_3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO |
ACCESS_END_POINTS_MACRO |
ACCESSORY_CODE |
ACQUISITION_CONTEXT |
ACQUISITION_DEVICE |
ACQUISITION_PROTOCOL_ELEMENT_CT |
ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION |
ACQUISITION_PROTOCOL_ELEMENT_XA |
ACQUISITION_SUBTASK |
ACQUISITION_TASK |
ACTUAL_HUMAN_PERFORMER_SCP_MACRO |
ACTUAL_HUMAN_PERFORMERS |
ACTUAL_HUMAN_PERFORMERS_M |
ADD_NEAR_SQ |
ADDITIONAL_PARAMETER_RECORDING_INSTANCE |
ADDITIONAL_RT_ACCESSORY_DEVICE |
ADVANCED_BLENDING |
AGE_CORRECTED_SENSIT_DEV_ALG |
ALGORITHM_IDENT_MACRO |
ALTERNATE_CONTAINER_IDENTIFIER |
ALTERNATE_CONTENT_DESCRIPTION |
ALTERNATE_REPRESENTATION |
ALTERNATE_REPRESENTATION_IN_INVENTORY |
ANALOG_FILTER_CHARACTERISTICS |
ANATOMIC_REGION |
ANATOMIC_REGION_IN_INTRA_ORAL |
ANIMATION_CURVE |
ANNOTATION_CONTENT |
ANNOTATION_GROUP |
ANNOTATION_PROPERTY_TYPE_CODE |
ANTERIOR_CHAMBER_DEPTH |
APPLICATION_SETUP |
APPLICATOR |
APPLICATOR_GEOMETRY |
APPLICATOR_IN_ION |
APPLICATOR_IN_RT_GEN_MACH_VERIF |
APPROVAL |
APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ |
APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP |
ASL_BOLUS_CUT_OFF_TIMING |
ASL_SLAB |
ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ |
ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP |
ASSERTION_MACRO |
ASSESSED_SOP_INSTANCE |
ASSESSMENT_OBSERVATIONS |
ATTRIBUTE_TOLERANCE_VALUES |
ATTRIBUTE_VALUE |
ATTRIBUTE_VALUE_CONSTRAINT |
AUTHOR_OBSERVER |
AUTOREFRACTION_EYE_SQ |
BASIC_CODE_SEQUENCE_MACRO |
BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS |
BEAM_DOSE_VERIF_CONTROL_POINT |
BEAM_IN_RT_IMAGE |
BEAM_ITEM |
BEAM_LIMITING_DEVICE |
BEAM_LIMITING_DEVICE_IN_BEAM |
BEAM_LIMITING_DEVICE_LEAF_PAIRS |
BEAM_LIMITING_DEVICE_POSITION |
BEAM_LIMITING_DEVICE_TOLERANCE |
BEAM_TASK_SQ |
BILLING_SUPPLIES_AND_DEVICES |
BIOPSY_TARGET |
BLENDING_DISPLAY |
BLENDING_DISPLAY_INPUT |
BLENDING_LUT_1 |
BLENDING_LUT_2 |
BLENDING_SEQUENCE |
BLOCK_DEFINITION |
BLOCK_EDGE_DATA |
BLOCK_SEQUENCE |
BLOCK_SLAB |
BLOCK_SLAB_IN_BLOCKS_DEF_MACRO |
BOLUS_DEFINITION |
BRACHY_ACCESSORY_DEVICE |
BRACHY_CONTROL_POINT |
BRACHY_CONTROL_POINT_DELIVERED |
BRACHY_PULSE_CONTROL_POINT_DELIVERED |
BRACHY_REFERENCED_DOSE_REFERENCE |
BRACHY_TASK |
BREAST_XRAY_GEOMETRY |
BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM |
BREAST_XRAY_POSITIONER_POSITION |
BREED_REGISTRATION |
BREED_REGISTRATION_MWL |
C_ARM_PHOTON_ELECTRON_CONTROL_POINT |
CALCULATED_DOSE_REFERENCE |
CALCULATED_TORIC_POWER_MACRO |
CALCULATION_COMMENT |
CALIBRATION |
CALIBRATION_DATA |
CAMERA_POSITION_GROUP |
CARDIAC_TRIGGER |
CELL_VALUES |
CHANNEL |
CHANNEL_DEFINITION |
CHANNEL_DELIVERY_CONTINUATION |
CHANNEL_DELIVERY_ORDER |
CHANNEL_DISPLAY |
CHANNEL_IMPEDANCE |
CHANNEL_SHIELD |
CHEMICAL_SHIFT |
CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ |
CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP |
CODE_SEQUENCE_MACRO |
CODE_SEQUENCE_MWL_CFIND_RQ |
CODE_SEQUENCE_MWL_CFIND_RSP |
CODING_SCHEME_IDENTIFICATION |
CODING_SCHEME_RESOURCES |
COLLIMATOR_SHAPE |
COMBINATION_SEGMENT_REFERENCE |
COMPENSATOR |
COMPENSATOR_DEFINITION |
COMPENSATOR_SHAPE |
COMPONENT |
COMPONENT_ASSEMBLY |
COMPONENT_INPUT |
COMPONENT_TYPES |
COMPOUND_GRAPHIC |
CONCEPT_CODE_SEQUENCE |
CONCEPT_NAME_CODE_SEQUENCE |
CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO |
CONCEPTUAL_VOLUME_CONSTITUENT |
CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE |
CONCEPTUAL_VOLUME_IDENTIFICATION |
CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE |
CONFIGURATION_QA_RESULTS |
CONFIGURATION_QA_RESULTS_SCP |
CONFIGURATION_QA_RESULTS_SCU |
CONSENT_FOR_CLINICAL_TRIAL_USE |
CONTAINER_COMPONENT |
CONTENT |
CONTENT_IN_ENCAP_DOC |
CONTENT_ITEM_MACRO |
CONTENT_ITEM_WITH_MODIFIERS_MACRO |
CONTENT_TEMPLATE |
CONTENT_TEMPLATE_IN_IMAGE |
CONTENT_TEMPLATE_IN_INVENTORY |
CONTEXT_GROUP_IDENTIFICATION |
CONTOUR |
CONTOUR_IMAGE |
CONTRAST_ADMIN_PROFILE |
CONTRAST_BOLUS_ADMIN_ROUTE |
CONTRAST_BOLUS_USAGE |
CONTRIBUTING_EQUIPMENT |
CONTRIBUTING_SOP_INSTANCE_REF |
CONTRIBUTING_SOURCES_ANGIO |
CONTRIBUTING_SOURCES_CRANIO |
CONTRIBUTING_SOURCES_TOMO |
CONTROL_POINT |
CONTROL_POINT_DELIVERY |
CONVENTIONAL_CONTROL_POINT_VERIFICATION |
CONVENTIONAL_MACHINE_VERIFICATION |
CORNEA_MEASUREMENTS |
CORNEAL_SIZE |
CORRECTED_PARAMETERS |
CT_ACQUISITION_DETAILS |
CT_ACQUISITION_TYPE |
CT_ADDITIONAL_XRAY_SOURCE |
CT_ADDITIONAL_XRAY_SOURCE_MACRO |
CT_EXPOSURE |
CT_GEOMETRY |
CT_IMAGE_FRAME_TYPE |
CT_PIXEL_VALUE_TRANSFORMATION |
CT_POSITION |
CT_RECONSTRUCTION |
CT_TABLE_DYNAMICS |
CT_XRAY_DETAILS |
CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ |
CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO |
CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO |
CUSTODIAL_ORGANIZATION |
CYLINDER_SQ |
DATA_FRAME_ASSIGNMENT_SQ |
DATA_INFO |
DATA_OBSERVATION |
DECOMPOSITION_MATERIAL |
DEFINITION_SOURCE |
DEFINITION_SOURCE_IN_RT |
DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE |
DEFORMABLE_REG_GRID |
DEFORMABLE_REGISTRATION |
DEIDENTIFICATION_ACTION |
DELIVERED_DEPTH_DOSE_PARAMETERS |
DELIVERY_VERIF_IMAGE_SQ |
DEPTH_DOSE_PARAMETERS |
DERIVATION_CONCEPTUAL_VOLUME |
DERIVATION_IMAGE |
DETECTOR_INFO |
DETECTOR_POSITION |
DEVICE |
DEVICE_IDENTIFICATION_MACRO |
DEVICE_MOTION_CONTROL |
DICOM_RETRIEVAL |
DICOM_STORAGE |
DICOM_STORAGE_GET |
DIFFUSION_B_MATRIX |
DIFFUSION_GRADIENT |
DIGITAL_FILTER_CHARACTERISTICS |
DIGITAL_SIGNATURES |
DIMENSION_INDEX |
DIMENSION_ORGANIZATION |
DIR_REC_ANNOTATION |
DIR_REC_ASSESSMENT |
DIR_REC_CURVE |
DIR_REC_ENCAP_DOC |
DIR_REC_FIDUCIAL |
DIR_REC_FILM_BOX |
DIR_REC_FILM_SESSION |
DIR_REC_HANGING_PROTOCOL |
DIR_REC_IMAGE |
DIR_REC_IMAGE_BOX |
DIR_REC_IMPLANT |
DIR_REC_IMPLANT_ASSY |
DIR_REC_IMPLANT_GROUP |
DIR_REC_INTERPRETATION |
DIR_REC_INVENTORY |
DIR_REC_KEY_OBJECT_DOC |
DIR_REC_MEASUREMENT |
DIR_REC_MODALITY_LUT |
DIR_REC_MRDR |
DIR_REC_OVERLAY |
DIR_REC_PALETTE |
DIR_REC_PATIENT |
DIR_REC_PLAN |
DIR_REC_PRESENTATION |
DIR_REC_PRINT_QUEUE |
DIR_REC_PRIVATE |
DIR_REC_RADIOTHERAPY |
DIR_REC_RAW_DATA |
DIR_REC_REGISTRATION |
DIR_REC_RESULTS |
DIR_REC_RT_DOSE |
DIR_REC_RT_PLAN |
DIR_REC_RT_STRUCTURE_SET |
DIR_REC_RT_TREAT_RECORD |
DIR_REC_SERIES |
DIR_REC_SPECTROSCOPY |
DIR_REC_SR_DOCUMENT |
DIR_REC_STEREOMETRIC |
DIR_REC_STORED_PRINT |
DIR_REC_STUDY |
DIR_REC_STUDY_COMPONENT |
DIR_REC_SURFACE |
DIR_REC_SURFACE_SCAN |
DIR_REC_TOPIC |
DIR_REC_TRACT |
DIR_REC_VALUE_MAP |
DIR_REC_VISIT |
DIR_REC_VOI_LUT |
DIR_REC_WAVEFORM |
DIRECT_SEGMENT_REFERENCE |
DISPLAY_CALIBRATION_RESULT |
DISPLAY_CALIBRATION_RESULT_SCP |
DISPLAY_CALIBRATION_RESULT_SCU |
DISPLAY_SETS |
DISPLAY_SHUTTER_MACRO |
DISPLAY_SUBSYSTEM |
DISPLAY_SUBSYSTEM_CONFIGURATION |
DISPLAY_SUBSYSTEM_CONFIGURATION_SCP |
DISPLAY_SUBSYSTEM_QA_RESULTS |
DISPLAY_SUBSYSTEM_QA_RESULTS_SCP |
DISPLAY_SUBSYSTEM_QA_RESULTS_SCU |
DISPLAY_SUBSYSTEM_SCP |
DISPLAY_SUBSYSTEM_SCU |
DISPLAYED_AREA_SELECTION |
DOSE_CALIBRATION_CONDITIONS |
DOSE_REFERENCE |
DOSE_VALUES |
DOSIMETRIC_OBJECTIVE |
DOSIMETRIC_OBJECTIVE_PARAMETER |
DVH |
DVH_REF_ROI |
DX_PATIENT_ORIENTATION_CODE |
EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE |
ELECTRON_APPLICATOR |
ENCRYPTED_ATTRIBUTES |
ENERGY_WINDOW_INFO |
ENERGY_WINDOW_RANGE |
ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS |
ENHANCED_CONTRAST_BOLUS_AGENT |
ENHANCED_PALETTE_COLOR_TABLE_SQ |
EQUIPMENT_ADMINISTRATOR |
EQUIPMENT_ADMINISTRATOR_SCP |
EQUIPMENT_ADMINISTRATOR_SCU |
EQUIPMENT_REFERENCE_POINT_COORDINATES |
EQUIVALENT_CDA_DOC |
EQUIVALENT_CODE |
EQUIVALENT_CONCEPTUAL_VOLUMES |
EVENT_TIMER_SQ |
EXCITATION_WAVELENGTH |
EXCLUDED_INTERVALS_SQ |
EXPECTED_IN_VIVO_MEASUREMENT_VALUES |
EXPOSURE_CONTROL_SENSING_REGIONS |
EXPOSURE_DOSE |
EXPOSURE_SEQUENCE |
EXTENDED_SELECTOR_ATTRIBUTE_MACRO |
EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION |
FAILED_ATTRIBUTES_NGET |
FAILED_ATTRIBUTES_SQ |
FAILED_SOP |
FAILED_SOP_MEDIA_CREATION |
FIDUCIAL |
FIDUCIAL_SET |
FIELD_OF_VIEW |
FILE_ACCESS |
FILE_ACCESS_IN_INVENTORY_FIND_RSP |
FILE_ACCESS_IN_REPOSITORY_QUERY |
FILE_SET_ACCESS |
FILE_SET_ACCESS_IN_REPOSITORY_QUERY |
FILL_STYLE |
FILM_BOX_CONTENT |
FILM_CONSUMPTION |
FILTER_OPERATIONS |
FIXATION |
FIXATION_DEVICE |
FIXATION_DEVICE_IN_GEN_MACH_VERI |
FLAT_CORNEAL_AXIS |
FLOW_IDENTIFIER |
FLUENCE_MAP |
FRACTION_BASED_RELATIONSHIP |
FRACTION_GROUP |
FRACTION_GROUP_SUMMARY |
FRACTION_PATTERN |
FRACTION_STATUS_SUMMARY |
FRAME_ACQUISITION |
FRAME_ANATOMY |
FRAME_CONTENT |
FRAME_DETECTOR_PARAMETERS |
FRAME_DISPLAY |
FRAME_DISPLAY_SHUTTER |
FRAME_EXTRACTION |
FRAME_PIXEL_DATA_PROPERTIES |
FRAME_PIXEL_INTENSITY_REL_LUT |
FRAME_PIXEL_SHIFT |
FRAME_USEFULNESS_GROUP |
FRAME_VOI_LUT |
FRAME_VOI_LUT_WITH_LUT |
FUNC_GROUP_BREAST_PROJ_XRAY_FRAME |
FUNC_GROUP_BREAST_PROJ_XRAY_SHARE |
FUNC_GROUP_BREAST_TOMO_FRAME |
FUNC_GROUP_BREAST_TOMO_SHARE |
FUNC_GROUP_ENHANCED_CT_FRAME |
FUNC_GROUP_ENHANCED_CT_SHARE |
FUNC_GROUP_ENHANCED_MR_FRAME |
FUNC_GROUP_ENHANCED_MR_SHARE |
FUNC_GROUP_ENHANCED_PET_FRAME |
FUNC_GROUP_ENHANCED_PET_SHARE |
FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME |
FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE |
FUNC_GROUP_ENHANCED_US_VOL_FRAME |
FUNC_GROUP_ENHANCED_US_VOL_SHARE |
FUNC_GROUP_ENHANCED_XA_FRAME |
FUNC_GROUP_ENHANCED_XA_SHARE |
FUNC_GROUP_ENHANCED_XRF_FRAME |
FUNC_GROUP_ENHANCED_XRF_SHARE |
FUNC_GROUP_IVOCT_FRAME |
FUNC_GROUP_IVOCT_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME |
FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE |
FUNC_GROUP_MR_SPECTROSCOPY_FRAME |
FUNC_GROUP_MR_SPECTROSCOPY_SHARE |
FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME |
FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE |
FUNC_GROUP_OPHTHALMIC_TOMO_FRAME |
FUNC_GROUP_OPHTHALMIC_TOMO_SHARE |
FUNC_GROUP_PARAMETRIC_MAP_FRAME |
FUNC_GROUP_PARAMETRIC_MAP_SHARE |
FUNC_GROUP_PHOTOACOUSTIC_FRAME |
FUNC_GROUP_PHOTOACOUSTIC_SHARE |
FUNC_GROUP_SECONDARY_CAPTURE |
FUNC_GROUP_SEGMENTATION_FRAME |
FUNC_GROUP_SEGMENTATION_SHARE |
FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE |
FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE |
FUNC_GROUP_VL_WH_SL_MICRO_FRAME |
FUNC_GROUP_VL_WH_SL_MICRO_SHARE |
FUNC_GROUP_XRAY_3D_ANGIO_FRAME |
FUNC_GROUP_XRAY_3D_ANGIO_SHARE |
FUNC_GROUP_XRAY_3D_CRANIO_FRAME |
FUNC_GROUP_XRAY_3D_CRANIO_SHARE |
FUNCTIONAL_MR |
GATED_INFO |
GATING_BEAM_HOLD_TRANSITION |
GENERAL_ACCESSORY |
GENERAL_ACCESSORY_DEFINITION |
GENERAL_ACCESSORY_IN_RT_ION_BEAMS |
GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD |
GENERAL_MACHINE_VERIFICATION |
GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM |
GENETIC_MODIFICATIONS |
GLOBAL_DEVIATION_PROBABILITY |
GRAPHIC_ANNOTATION |
GRAPHIC_COORDINATES_DATA |
GRAPHIC_GROUP |
GRAPHIC_LAYER |
GRAPHIC_OBJECT |
GROUP_OF_PATIENTS_IDENTIFICATION |
HANGING_PROTOCOL_DEFINITION |
HIERARCHICAL_SERIES_REF_MACRO |
HIERARCHICAL_SOP_INST_REF_MACRO |
HISTOGRAM |
HL7_HIERARCHIC_DESIGNATOR_MACRO |
HL7_STRUCT_DOC_REF |
HL7_STRUCT_DOC_REF_MWL |
HPGL_DOCUMENT |
HPGL_PEN |
ICON_IMAGE |
IDENTIFIED_PERSON_DEVICE_MACRO |
IMAGE_BOX_CONTENT |
IMAGE_BOX_SYNCHRONIZATION |
IMAGE_BOXES |
IMAGE_CENTER_POINT_COORDINATES |
IMAGE_DATA_TYPE_SQ |
IMAGE_FILTER_DETAILS |
IMAGE_OVERLAY_BOX_CONTENT |
IMAGE_PIXEL_MACRO |
IMAGE_SEGMENT |
IMAGE_SET_SELECTOR |
IMAGE_SETS |
IMAGE_SOP_INSTANCE_REF_MACRO |
IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC |
IMAGING_DEVICE_LOCATION_PARAMETER |
IMAGING_POSITION |
IMAGING_POSITION_PARAMETERIZED |
IMPLANT_ASSMBLY_TMPL_TARGET_ANAT |
IMPLANT_TARGET_ANATOMY |
IMPLANT_TEMPLATE_GROUP_MEMBERS |
IMPLANT_TEMPLATE_GRP_TARGET_ANAT |
IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK |
IMPLANT_TEMPLATE_GRP_VAR_DIMENS |
IMPLANT_TEMPLATE_GRPMM_2D_COORDS |
INDEX_PROBABILITY |
INFORMATION_FROM_MANUFACTURER |
INSTRUCTION |
INTERLOCK |
INTERPRETATION_APPROVER |
INTERV_DRUG_INFO |
INTERVENTIONAL_THERAPY |
INTRAOCULAR_LENS_CALC_LEFT_EYE |
INTRAOCULAR_LENS_CALC_RIGHT_EYE |
INVENTORIED_INSTANCES |
INVENTORIED_SERIES |
INVENTORIED_STUDIES |
INVENTORY_REFERENCE_MACRO |
IOL_POWER |
ION_BEAM |
ION_BEAM_LIMITING_DEVICE |
ION_BLOCK |
ION_CONTROL_POINT |
ION_CONTROL_POINT_DELIVERY |
ION_CONTROL_POINT_VERIFICATION |
ION_MACHINE_VERIFICATION |
ION_RANGE_COMPENSATOR |
ION_TOLERANCE_TABLE |
ION_WEDGE |
ION_WEDGE_POS_ION_CTL_PT_VERIF |
ION_WEDGE_POSITION |
IRRADIATION_EVENT_ID |
ISOCENTER_REFERENCE_SYSTEM |
ISSUER_PATIENT_ID_QUALIFIERS |
IV_FRAME_CONTENT |
IVOCT_FRAME_CONTENT |
IVOCT_FRAME_TYPE |
KERATOMETRIC_AXIS |
KERATOMETRY_ANY_EYE |
KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO |
LANGUAGE_CODE_RQ |
LANGUAGE_CODE_RSP |
LATERAL_SPREADING_DEVICE |
LATERAL_SPREADING_DEVICE_SETTING |
LENS_CONSTANT |
LENS_SQ |
LENS_THICKNESS |
LIGHT_PATH_FILTER_TYPE_STACK |
LINE_STYLE |
LOCALIZED_DEVIATION_PROBABILITY |
LUMINANCE_RESPONSE |
LUMINANCE_RESPONSE_QA_SCP |
LUMINANCE_RESPONSE_QA_SCU |
LUMINANCE_RESPONSE_SCP |
LUMINANCE_RESPONSE_SCU |
LUMINANCE_RESPONSE1 |
LUMINANCE_RESULT |
LUMINANCE_RESULT_SCP |
LUMINANCE_RESULT_SCU |
LUMINANCE_UNIFORMITY_RESULT |
LUMINANCE_UNIFORMITY_RESULT_SCP |
LUMINANCE_UNIFORMITY_RESULT_SCU |
MAC_PARAMETERS |
MAJOR_TICKS |
MAPPING_RESOURCE_IDENTIFICATION |
MASK_FRAME_PIXEL_SHIFT |
MASK_SUBTRACTION |
MASK_SUBTRACTION_IN_PS |
MATERIAL_ATTENUATION |
MATING_FEATURE |
MATING_FEATURE_DEGREE_OF_FREEDOM |
MATING_FEATURE_SETS |
MATRIX |
MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO |
MATRIX_REGISTRATION |
MAXIMUM_CORNEAL_CURVATURE |
MEASURED_DOSE_REFERENCE |
MEASURED_METERSET_TO_DOSE_MAPPING |
MEASURED_VALUE |
MEASUREMENT_EQUIPMENT |
MEASUREMENT_EQUIPMENT_SCP_MACRO |
MEASUREMENT_EQUIPMENT_SCP_NGET |
MEASUREMENT_VALUES |
MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MEASUREMENTS |
MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MEDIA_INSTALLED |
MEDIA_RETRIEVAL |
METERSET_TO_DOSE_MAPPING |
MINIMUM_KERATOMETRIC |
MODALITY_LUT |
MODEL_SPECIFICATION |
MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ |
MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP |
MODIFIED_ATTRIBUTES |
MR_ARTERIAL_SPIN_LABELING |
MR_AVERAGES |
MR_DIFFUSION |
MR_ECHO |
MR_FOV_GEOMETRY |
MR_IMAGE_DESCRIPTION_MACRO |
MR_IMAGE_FRAME_TYPE |
MR_IMAGING_MODIFIER |
MR_METABOLITE_MAP |
MR_MODIFIER |
MR_RECEIVE_COIL |
MR_SPATIAL_SATURATION |
MR_SPECTROSCOPY_FOV_GEOMETRY_MAC |
MR_SPECTROSCOPY_FRAME_TYPE |
MR_TIMING_RELATED_PARMS |
MR_TRANSMIT_COIL |
MR_VELOCITY_ENCODING |
MULTI_COIL_DEFINITION |
MULTI_ENERGY_CT_ACQUISITION |
MULTI_ENERGY_CT_CHARACTERISTICS |
MULTI_ENERGY_CT_PATH |
MULTI_ENERGY_CT_PROCESSING |
MULTI_ENERGY_CT_XRAY_DETECTOR |
MULTI_ENERGY_CT_XRAY_SOURCE |
MULTI_FRAME_PRESENTATION |
MULTIPLEXED_AUDIO_CHANNELS |
MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO |
MYDRIATIC_AGENT |
NAVIGATION_INDICATOR |
NOMINAL_SCREEN_DEFINITION |
NONCONFORMING_MODIFIED_ATTRIBUTES |
NOTIFICATION_FROM_MANUFACTURER |
OBJECT_THICKNESS |
OBLIQUE_CROPPING_PLANE |
OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS |
OMITTED_APPLICATION_SETUP |
OMITTED_BEAM_TASK |
OMITTED_CHANNEL |
OMITTED_RADIATION |
OPERATING_MODE |
OPERATOR_IDENTIFICATION |
OPHT_AXIAL_LENGTH |
OPHT_AXL_LEN_MEAS_LEN_SUMMATION |
OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN |
OPHT_AXL_LEN_MEAS_TOTAL_LEN |
OPHT_AXL_LEN_MEASUREMENTS |
OPHT_AXL_LEN_QUALITY_METRIC |
OPHT_AXL_MEAS_LEFT_EYE |
OPHT_AXL_MEAS_RIGHT_EYE |
OPHT_PAT_CLINICAL_INFO_LEFT_EYE |
OPHT_PAT_CLINICAL_INFO_RIGHT_EYE |
OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING |
OPHTHALMIC_FRAME_LOCATION |
OPM_THICKNESS_MAP_Q_THRESHOLD |
OPM_THICKNESS_MAP_QR_SEQ |
OPTICAL_OPHT_AXL_LEN_MEAS |
OPTICAL_PATH |
OPTICAL_PATH_IDENTIFICATION |
OPTICAL_SEL_OPHT_AXL_LEN |
ORIGINAL_ATTRIBUTES |
ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP |
ORIGINAL_IMAGE |
OTHER_FAILURES |
OTHER_MEDIA_AVAILABLE |
OTHER_PATIENT_IDS |
OTHER_PATIENT_IDS_IN_INVENTORY |
OTHER_PATIENT_IDS_PAT_ID |
OTHER_PATIENT_IDS_UPS |
OUTLINE_DEFINITION_MACRO |
OUTPUT_DESTINATION |
OUTPUT_DESTINATION_GET |
OUTPUT_INFORMATION |
OVERLAY_PIXEL_DATA |
OVERRIDE |
OVERRIDE_IN_RT_BRACHY_SESS |
OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION |
OVERRIDEN_ATTRIBUTES_NGET |
OVERRIDEN_ATTRIBUTES_SQ |
PALETTE_COLOR_LOOKUP_TABLE |
PARALLEL_RT_BEAM_DELIMITER_DEVICE |
PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO |
PARAMETERS_SPECIFICATION |
PARAMETRIC_MAP_FRAME_TYPE |
PARTICIPANT |
PATIENT_CLINICAL_TRIAL |
PATIENT_LOCATION_COORDINATES |
PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO |
PATIENT_ORIENTATION_CODE |
PATIENT_ORIENTATION_IN_FRAME |
PATIENT_PHYSIOLOGICAL_STATE |
PATIENT_POSITIONING_INSTRUCTION |
PATIENT_SETUP |
PATIENT_SETUP_IN_GEN_MACH_VERIF |
PATIENT_SUPPORT_DEVICES |
PATIENT_SUPPORT_POSITION |
PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER |
PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE |
PATIENT_SUPPORT_POSITION_PARAMETER |
PATIENT_SUPPORT_POSITION_TOLERANCE |
PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO |
PATIENT_TREATMENT_PREPARATION_PROCEDURE |
PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ |
PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP |
PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE |
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ |
PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP |
PER_PROJECTION_ACQUISITION_ANGIO |
PER_PROJECTION_ACQUISITION_TOMO |
PERFORMED_PROTOCOL_CODE |
PERFORMED_SERIES |
PERSON_IDENTIFICATION_MACRO |
PERTINENT_DOCUMENTS |
PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO |
PERTINENT_DOCUMENTS_IN_SUBSTANCE |
PERTINENT_DOCUMENTS_MWL_CFIND_RSP |
PERTINENT_RESOURCES |
PET_DETECTOR_MOTION_DETAILS |
PET_FRAME_ACQUISITION |
PET_FRAME_CORRECTION_FACTORS |
PET_FRAME_TYPE |
PET_POSITION |
PET_RECONSTRACTION |
PET_TABLE_DYNAMICS |
PHASE_INFO |
PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS |
PHOTOACOUSTIC_IMAGE_DATA_TYPE |
PHOTOACOUSTIC_IMAGE_FRAME_TYPE |
PIXEL_INTENSITY_RELATIONSHIP_LUT |
PIXEL_MEASURES |
PIXEL_SPACING |
PIXEL_VALUE_MAP_TO_CODED_CONCEPT |
PIXEL_VALUE_TRANSFORM_WITH_EV |
PIXEL_VALUE_TRANSFORMATION |
PLAN_OVERVIEW |
PLANE_ORIENTATION |
PLANE_ORIENTATION_VOLUME |
PLANE_POSITION |
PLANE_POSITION_SLIDE |
PLANE_POSITION_VOLUME |
PLANNED_VERIFICATION_IMAGE |
PLANNING_LANDMARK_LINE |
PLANNING_LANDMARK_PLANE |
PLANNING_LANDMARK_POINT |
POINTS_MACRO |
POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION |
POSITIONER_POSITION |
POST_DEFORMATION_MATRIX_REG |
PRE_DEFORMATION_MATRIX_REG |
PREFORMATTED_COLOR_IMAGE |
PREFORMATTED_GRAYSCALE_IMAGE |
PRESCRIPTION_OVERVIEW |
PRESENTATION_LUT |
PRESENTATION_LUT_CONTENT |
PRESENTATION_STATE_CLASSIFICATION_COMPONENT |
PRESENTATION_STATE_COMPOSITOR_COMPONENT |
PRIMARY_ANATOMIC_STRUCTURE |
PRIMARY_FLUENCE_MODE |
PRIMITIVE_POINT |
PRIMITIVE_POINT_CP1365 |
PRINT_JOB_DESCRIPTION |
PRINT_MANAGEMENT_CAPABILITIES |
PRINTER_CHARACTERISTICS |
PRINTER_CONFIGURATION |
PRISM_SQ |
PRIVATE_DATA_ELEMENT_CHARACTERISTICS |
PRIVATE_DATA_ELEMENT_DEFINITION |
PROCEDURE_STEP_PROGRESS_PARAMETERS |
PROCEDURE_STEP_PROGRESS_PARAMETERS_GET |
PROCEDURE_STEP_PROGRESS_PARAMETERS_SET |
PROCEDURE_TYPE_CODE_QUERY |
PROJECTION_IMAGING_ACQUISITION_PARAMETER |
PROJECTION_PIXEL_CALIBRATION |
PROPOSED_STUDY |
PROTOCOL_CONTEXT |
PROTOCOL_CONTEXT_MWL_CFIND_RSP |
PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED |
PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP |
QA_RESULTS |
QA_RESULTS_SCP |
QA_RESULTS_SCU |
QUANTITY |
RADIATION_DOSE |
RADIATION_DOSE_IDENTIFICATION |
RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_DOSE_VALUES_PARAMETERS |
RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD |
RADIATION_GENERATION_MODE |
RADIATION_GENERATION_MODE_MACRO |
RADIOBIOLOGICAL_DOSE_EFFECT |
RADIOPHARM_INFO |
RADIOPHARM_INFO_ENH_PET |
RADIOPHARM_INFO_PET |
RADIOPHARM_USAGE |
RANGE_MODULATOR |
RANGE_MODULATOR_SETTINGS |
RANGE_SHIFTER |
RANGE_SHIFTER_SETTINGS |
REAL_TIME_BULK_DATA_FLOW |
REAL_WORLD_VALUE_MAP_MACRO |
REAL_WORLD_VALUE_MAPPING |
RECONSTRUCTION_PROTOCOL_ELEMENT_CT |
RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION |
RECONSTRUCTION_PROTOCOL_ELEMENT_XA |
RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ |
RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ |
RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ |
RECORDED_BLOCK_SLAB |
RECORDED_BRACHY_ACCESSORY_DEVICE |
RECORDED_CHANNEL |
RECORDED_CHANNEL_SHIELD |
RECORDED_COMPENSATOR |
RECORDED_COMPENSATOR_IN_GEN_MV |
RECORDED_COMPENSATOR_IN_ION |
RECORDED_LATERAL_SPREADING_DEV |
RECORDED_RANGE_MODULATOR |
RECORDED_RANGE_SHIFTER |
RECORDED_SNOUT |
RECORDED_SOURCE |
RECORDED_SOURCE_APPLICATOR |
RECORDED_WEDGE |
REF_BASIC_ANNOTATION_BOX |
REF_BEAM |
REF_BEAM_IN_DOSE |
REF_BOLUS |
REF_BOLUS_IN_ION |
REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP |
REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP |
REF_CALCULATED_DOSE_REFERENCE |
REF_COMPOSITE_OBJECT |
REF_CONTROL_POINT |
REF_CURVE |
REF_DEFINED_OR_PERFORMED_PROTOCOL |
REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP |
REF_DIGITAL_SIGNATURE |
REF_DOSE |
REF_DOSE_REFERENCE |
REF_DOSE_REFERENCE_IN_BEAM |
REF_DOSE_REFERENCE_IN_CONTROL_POINT |
REF_DOSE_REFERENCE_IN_ION |
REF_FILM_BOX |
REF_FILM_SESSION |
REF_FRACTION_GROUP |
REF_FRAME_OF_REFERENCE |
REF_G_P_SCHEDULED_PROCEDURE_STEP |
REF_IMAGE |
REF_IMAGE_BOX |
REF_IMAGE_DISPLAY_SYSTEM_SCP |
REF_IMAGE_DISPLAY_SYSTEM_SCU |
REF_IMAGE_F5_23 |
REF_IMAGE_IN_ADVANCED_BLENDING_PS |
REF_IMAGE_IN_IMAGE_BOX |
REF_IMAGE_IN_REF_SERIES |
REF_IMAGE_IN_STORE |
REF_IMAGE_IN_VISUAL_EVAL_RESULT |
REF_IMAGE_IN_XRAY_IMAGE |
REF_IMAGE_OVERLAY_BOX |
REF_IMAGE_OVERLAY_BOX_IN_STORE |
REF_IMAGE_REAL_WORLD_FOR_NM |
REF_IMAGE_REAL_WORLD_VALUE_MAP |
REF_IMAGE_RQ_F_4_3 |
REF_IMAGE_RSP_F_4_2 |
REF_IMAGE_RSP_F_4_3 |
REF_IMAGE_RT |
REF_IMAGE_STRUCT_DISPLAY |
REF_INSTANCE |
REF_INSTANCE_IN_CONTRIB |
REF_INSTANCES_AND_ACCESS_MACRO |
REF_INTERPRETATION |
REF_MEASURED_DOSE_REFERENCE |
REF_OPHT_AXL_LEN_MEAS_QC_IMAGE |
REF_OVERLAY |
REF_OVERLAY_IN_CURVE |
REF_OVERLAY_IN_IMAGE_BOX |
REF_PATIENT |
REF_PATIENT_ALIAS |
REF_PATIENT_CFIND |
REF_PERF_PROC_STEP_INST_AVAIL |
REF_PERFORMED_PROCEDURE_STEP |
REF_PRESENTATION_LUT |
REF_PRESENTATION_LUT_IN_STORE |
REF_PRINT_JOB |
REF_PRINT_JOB_IN_DESCRIPTION |
REF_REAL_WORLD_VALUE_MAPPING |
REF_REFERENCE_IMAGE |
REF_REFERENCE_IMAGE_IN_ION |
REF_RESULTS |
REF_ROI |
REF_RT_PLAN |
REF_RT_PLAN_IN_DOSE |
REF_RT_PLAN_IN_GENERAL_PLAN |
REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO |
REF_RT_SERIES |
REF_RT_STUDY |
REF_SERIES |
REF_SERIES_F5_23 |
REF_SERIES_IN_COMMON_INSTANCE |
REF_SERIES_IN_CONTRIB |
REF_SERIES_IN_PS |
REF_SERIES_IN_RELATED_IES |
REF_SERIES_NOTIFICATION |
REF_SERIES_RQ_F_4_2 |
REF_SERIES_RQ_F_4_3 |
REF_SERIES_RSP_F_4_2 |
REF_SERIES_RSP_F_4_3 |
REF_SETUP_IMAGE |
REF_SOP |
REF_SOP_AE_RQ |
REF_SOP_AE_RSP |
REF_SOP_FOR_IMAGE_REF_MACRO |
REF_SOP_FOR_WAVEFORM_REF_MACRO |
REF_SOP_IN_HS_MACRO |
REF_SOP_IN_STOW_RS_RSP |
REF_SOP_INSTANCE_MAC |
REF_SOP_MEDIA |
REF_SOP_MEDIA_AE |
REF_SOP_MEDIA_CREATION |
REF_SOP_NOTIFICATION |
REF_STORAGE_MEDIA |
REF_STORED_PRINT |
REF_STRUCTURE_SET |
REF_STUDY |
REF_STUDY_CFIND |
REF_STUDY_COMPONENT |
REF_STUDY_IN_RELATED_IES |
REF_TREATMENT_RECORD |
REF_VERIFICATION_IMAGE |
REF_VISIT |
REF_VOI_LUT_BOX |
REFERENCE_LOCATION_MACRO |
REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE |
REFERENCED_DOSIMETRIC_OBJECTIVES |
REFERENCED_IMAGE |
REFERENCED_PATIENT_SETUP_PHOTO |
REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO |
REFERENCED_REQUEST |
REFERENCED_REQUEST_N_CREATE_RQ |
REFERENCED_REQUEST_N_CREATE_RSP |
REFERENCED_REQUEST_N_GET_RQ |
REFERENCED_REQUEST_UPS |
REFERENCED_RT_PHYSICIAN_INTENT |
REFERENCED_RT_PRESCRIPTION |
REFERENCED_RT_RADIATION_SET |
REFERENCED_RT_TREATMENT_PHASE |
REFERENCED_SERIES_10_4 |
REFERENCED_SOP |
REFERENCED_SOP_10_3b |
REFERENCED_STRUCTURED_CONTEXT |
REFERENCED_SURFACE |
REFERENCED_SURFACE_MESH_IDENTIFICATION |
REFRACTIVE_PARAMS_USED_ON_PAT |
REFRACTIVE_STATE |
REFRACTIVE_STATE_IOL |
REGION_PIXEL_SHIFT |
REGISTRATION |
REGISTRATION_TO_LOCALIZER_SEQ |
REL_OPT_ATTRIBUTES_SEQ |
RELATED_ASSERTION |
RELATED_INFORMATION_ENTITIES_MACRO |
RELATED_PROCEDURE_STEP_N_CREATE |
RELATED_PROCEDURE_STEP_N_GET_RSP |
RELATED_PROCEDURE_STEP_SQ |
RELATED_RT_ROI_OBSERVATIONS |
RELATED_SERIES |
REQUEST_ATTRIBUTES |
REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP |
RESPIRATORY_TRIGGER |
RESULTS_DISTRIBUTION_LIST |
RESULTS_NORMALS |
ROBOTIC_PATH_CONTROL_POINT |
ROI_CONTOUR |
ROI_DENSITY |
ROI_ELEMENTAL_COMPOSITION |
ROI_PHYSICAL_PROPERTIES |
ROTATION_INFO |
RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO |
RT_ACCESSORY_HOLDER_DEFINITION |
RT_ACCESSORY_HOLDER_SLOT |
RT_ANATOMIC_PRESCRIPTION |
RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO |
RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO |
RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO |
RT_DOSE_ROI |
RT_IMAGE_FRAME_CONTEXT |
RT_IMAGE_FRAME_GENERAL_CONTENT |
RT_IMAGE_FRAME_RADIATION_ACQUISITION |
RT_MOTION_SYNCHRONIZATION |
RT_PATIENT_POSITION_DISPLACEMENT |
RT_PATIENT_POSITION_MACRO |
RT_PATIENT_POSITION_SCOPE_MACRO |
RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO |
RT_PHYSICIAN_INTENT |
RT_PHYSICIAN_INTENT_INPUT_INSTANCE |
RT_PHYSICIAN_INTENT_PREDECESSOR |
RT_PRESCRIPTION |
RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT |
RT_RADIATION_TASK |
RT_RELATED_ROI |
RT_ROI_IDENTIFICATION_CODE |
RT_ROI_OBSERVATIONS |
RT_SEGMENT_ANNOTATION |
RT_TOLERANCE_SET_MACRO |
RT_TREATMENT_PHASE_INTERVAL |
RT_TREATMENT_PHASE_MACRO |
SCHED_HUMAN_PERFORMERS |
SCHED_HUMAN_PERFORMERS_M |
SCHEDULED_ACTION_ITEM_CODE |
SCHEDULED_PROCEDURE_STEP |
SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ |
SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP |
SCHEDULED_PROTOCOL_CODE |
SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP |
SCHEDULED_SPECIMEN_MWL_CFIND_RQ |
SCHEDULED_SPECIMEN_MWL_CFIND_RSP |
SCHEDULED_STEP_ATTRIBUTE |
SCOPE_OF_INVENTORY |
SCREENING_BASELINE_MEASURED |
SEGMENT |
SEGMENT_ANNOTATION_TYPE_CODE |
SEGMENT_IDENTIFICATION |
SEGMENT_REFERENCE |
SEGMENTED_PROPERTY_TYPE_CODE |
SEGMENTED_RT_ACCESSORY_DEVICE |
SELECTED_FRAME_FUNCTIONAL_GROUPS |
SELECTED_SEGMENTAL_OPHT_AXL_LEN |
SELECTED_TOTAL_OPHT_AXL_LENGTH |
SETUP_DEVICE |
SHIELDING_DEVICE |
SIMULATED_KERATOMETRIC_CYLINDER |
SNOUT |
SOFTCOPY_PRESENTATION_LUT |
SOFTCOPY_VOI_LUT |
SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS |
SOP_INSTANCE_REF_MACRO |
SORTING_OPERATIONS |
SOUND_SPEED_CORRECTION_MECHANISM |
SOURCE |
SOURCE_CONCEPTUAL_VOLUME |
SOURCE_HANGING_PROTOCOL |
SOURCE_IMAGE |
SOURCE_IMAGE_CORNEAL_PROCESSED_DATA |
SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP |
SOURCE_IMAGE_IN_DERIVATION_IMAGE |
SOURCE_IMAGE_IN_ENHANCED_US |
SOURCE_IMAGE_IN_OPHTHALMIC |
SOURCE_INSTANCE |
SOURCE_IRRADIATION_EVENT |
SOURCE_OF_REFRACTIVE_MEASUREMENTS |
SOURCE_PATIENT_GROUP_IDENTIFICATION |
SOURCE_PIXEL_PLANES_CHARACTERISTICS |
SOURCE_WAVEFORM |
SPECIFIC_ABSORPTION_RATE |
SPECIMEN_DESCRIPTION |
SPECIMEN_DESCRIPTION_IN_IMAGE |
SPECIMEN_DESCRIPTION_IN_INVENTORY |
SPECIMEN_DESCRIPTION_MWL_CFIND_RQ |
SPECIMEN_DESCRIPTION_MWL_CFIND_RSP |
SPECIMEN_MACRO |
SPECIMEN_PREPARATION |
SPECIMEN_REFERENCE |
SR_CONTENT |
STEEP_CORNEAL_AXIS |
STEREO_PAIRS |
STORAGE_MACRO |
STORAGE_PROTOCOL_ELEMENT |
STORAGE_PROTOCOL_ELEMENT_SPECIFICATION |
STORED_VALUE_COLOR_RANGE |
STOW_RS_STORAGE |
STOW_RS_STORAGE_GET |
STRAIN_STOCK |
STRUCTURE_SET_ROI |
STRUCTURED_CONSTRAINT_OBSERVATION |
STRUCTURED_DISPLAY_IMAGE_BOX |
STRUCTURED_DISPLAY_TEXT_BOX |
STUDIES_CONTAIN_OTHER_REF_INST |
SUBJECTIVE_REFRACTION_EYE |
SUPPORTED_IMAGE_DISPLAY_FORMATS |
SURFACE |
SURFACE_MESH_PR_MACRO |
SURFACE_MESH_PR_MACRO_CP1365 |
SURFACE_MODEL_DESCRIPTION |
SURFACE_POINTS |
SURGICALLY_INDUCED_ASTIGMATISM |
SYNCHRONIZED_SCROLLING |
TABLE_COLUMN_DEFINITION |
TABLE_POSITION |
TABLE_ROW_DEFINITION |
TABULATED_VALUES |
TARGET_LUMINANCE_CHARACTERISTICS |
TARGET_LUMINANCE_CHARACTERISTICS_SCP |
TARGET_LUMINANCE_CHARACTERISTICS_SCU |
TEMPORAL_POSITION |
TEXT_OBJECT |
TEXT_OBJECT_VOLUMETRIC |
TEXT_STYLE |
THRESHOLD |
THRESHOLD_VALUE |
TIME_BASED_IMAGE_SETS |
TIME_OF_FRAME_GROUP |
TIME_SLOT_INFO |
TOLERANCE_TABLE |
TOMOTHERAPEUTIC_CONTROL_POINT |
TOTAL_PIXEL_MATRIX_ORIGIN |
TRACK |
TRACK_SET |
TRACK_SET_ANATOMICAL_TYPE_CODE |
TRACK_SET_STATISTICS |
TRACK_STATISTICS |
TRANSDUCER_IDENTIFICATION |
TRANSDUCER_ORIENTATION |
TRANSDUCER_POSITION |
TRANSDUCER_RESPONSE |
TREAT_SESSION_APPLICATION_SETUP |
TREAT_SUM_CALCULATED_DOSE_REF |
TREAT_SUM_MEASURED_DOSE_REF |
TREATMENT_DEVICE_IDENTIFICATION |
TREATMENT_MACHINE |
TREATMENT_MACHINE_IN_TREAT |
TREATMENT_POSITION |
TREATMENT_POSITION_GROUP |
TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO |
TREATMENT_SESSION_BEAM |
TREATMENT_SESSION_ION_BEAM |
TREATMENT_SITE_CODE |
TREATMENT_TOLERANCE_VIOLATION |
UDI_MACRO |
ULTRASOUND_OPHT_AXL_LEN_MEAS |
ULTRASOUND_REGION |
ULTRASOUND_SEL_OPHT_AXL_LEN |
UPS_ACTUAL_HUMAN_PERF_GET |
UPS_ACTUAL_HUMAN_PERF_SET_RQ |
UPS_ACTUAL_HUMAN_PERF_SET_RSP |
UPS_CODE_CREATE_SET |
UPS_CODE_GET |
UPS_CODE_GET_RSP |
UPS_COMMUNICATIONS_URI_SET_RQ |
UPS_COMMUNICATIONS_URI_SET_RSP |
UPS_COMMUNICATIONS_URI_SQ |
UPS_CONTENT_ITEM_CREATE_SET |
UPS_CONTENT_ITEM_GET |
UPS_DICOM_RETRIEVAL_GET |
UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE |
UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET |
UPS_ISSUER_OF_PAT_ID_QUAL_CREATE |
UPS_ISSUER_OF_PAT_ID_QUAL_GET |
UPS_MEDIA_RETRIEVAL_GET |
UPS_OTHER_PATIENT_ID_CREATE_SET |
UPS_OTHER_PATIENT_ID_GET |
UPS_PERF_PROC_GET |
UPS_PERF_PROC_SET_RQ |
UPS_PERF_PROC_SET_RSP |
UPS_PERFORMED_PROCEDURE |
UPS_PROGRESS_INFO |
UPS_PROGRESS_INFO_EVENT |
UPS_PROGRESS_INFO_GET |
UPS_PROGRESS_INFO_SET_RQ |
UPS_PROGRESS_INFO_SET_RSP |
UPS_REF_REQUEST_CREATE_RQ |
UPS_REF_REQUEST_CREATE_RSP |
UPS_REF_REQUEST_GET |
UPS_REF_SOP_ACCESS_CREATE_SET |
UPS_REF_SOP_ACCESS_GET |
UPS_REFERENCED_SOP_GET |
UPS_SCHED_HUMAN_PERF_CREATE_SET |
UPS_SCHED_HUMAN_PERF_GET |
UPS_SOP_INSTANCE_REF_GET |
UPS_WADO_RETRIEVAL_CREATE_SET |
UPS_WADO_RETRIEVAL_GET |
UPS_WADO_RS_RETRIEVAL_GET |
UPS_XDS_RETRIEVAL_GET |
US_IMAGE_DESCRIPTION_SQ |
USED_FIDUCIALS |
USED_RT_STRUCTURE_SET_ROI |
USED_SEGMENTS |
UV_MAPPING |
VARIABLE_MODALITY_LUT |
VECTORS_MACRO |
VELOCITY_ENCODING_ACQUISITION |
VERIFYING_OBSERVER |
VIEW_CODE |
VIEW_CODE_BREAST |
VIEW_CODE_OPT_VIEW_SL_PROG_DIR |
VIS_FIELD_GLOBAL_RESULTS_INDEX |
VIS_FIELD_TEST_RELI_GLOBAL_INDEX |
VISUAL_ACUITY_EYE_SQ |
VISUAL_ACUITY_MEASUREMENT |
VISUAL_EVALUATION_RESULT |
VISUAL_EVALUATION_RESULT_SCP |
VISUAL_EVALUATION_RESULT_SCU |
VISUAL_EVALUATION_TEST |
VISUAL_EVALUATION_TEST_SCP |
VISUAL_EVALUATION_TEST_SCU |
VISUAL_FIELD_CATCH_TRIAL |
VISUAL_FIELD_TEST_POINT |
VISUAL_FIELD_TEST_POINT_NORMALS |
VOI_LUT |
VOLUME_CROPPING |
VOLUME_LOCALIZATION |
VOLUME_STREAM |
VOLUMETRIC_ANNOTATION |
VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION |
VOLUMETRIC_PRESENTATION_INPUT_SET |
VOLUMETRIC_PRESENTATION_STATE_INPUT |
WADO_RETRIEVAL |
WADO_RS_RETRIEVAL |
WAVEFORM |
WAVEFORM_ANNOTATION |
WAVEFORM_FILTER_CHARACTERISTICS_MACRO |
WAVEFORM_FILTER_LOOKUP_TABLE_MACRO |
WAVEFORM_PRESENTATION_GROUP |
WEDGE_DEFINITION |
WEDGE_ITEM |
WEDGE_POSITION |
WEDGE_POSITION_IN_WP_MACRO |
WEEKDAY_FRACTION_PATTERN |
WEIGHTING_TRANSFER_FUNCTION |
WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE |
WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING |
WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD |
X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO |
XA_ACQUISITION_PHASE_DETAILS |
XA_PLANE_DETAILS |
XA_XRF_FRAME_CHARACTERISTICS |
XA_XRF_FRAME_DISPLAY_SHUTTER |
XA_XRF_MASK_SUBTRACTION |
XDS_RETRIEVAL |
XDS_STORAGE |
XDS_STORAGE_GET |
XRAY_3D_ACQUISITION_ANGIO |
XRAY_3D_ACQUISITION_CRANIO |
XRAY_3D_ACQUISITION_TOMO |
XRAY_3D_FRAME_TYPE |
XRAY_3D_RECONSTRUCTION |
XRAY_ACQUISITION_DOSE |
XRAY_FILTER |
XRAY_FILTER_DETAILS |
XRAY_GEOMETRY |
XRAY_GRID |

See Also

MCitems Structure


_2D_DEGREE_OF_FREEDOM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_DEGREE_OF_FREEDOM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_DEGREE_OF_FREEDOM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_DEGREE_OF_FREEDOM
Visual Basic
Public Shared ReadOnly _2D_DEGREE_OF_FREEDOM As String
Visual C++
public:
static initonly String^ _2D_DEGREE_OF_FREEDOM

See Also

MCitems Structure
MCitems Members


_2D_LINE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_LINE_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_LINE_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_LINE_COORDINATES
Visual Basic
Public Shared ReadOnly _2D_LINE_COORDINATES As String
Visual C++
public:
static initonly String^ _2D_LINE_COORDINATES

See Also

MCitems Structure
MCitems Members


_2D_MATING_FEATURE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_MATING_FEATURE_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_MATING_FEATURE_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_MATING_FEATURE_COORDINATES
Visual Basic
Public Shared ReadOnly _2D_MATING_FEATURE_COORDINATES As String
Visual C++
public:
static initonly String^ _2D_MATING_FEATURE_COORDINATES

See Also

MCitems Structure
MCitems Members


_2D_PLANE_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_PLANE_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_PLANE_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_PLANE_COORDINATES
Visual Basic
Public Shared ReadOnly _2D_PLANE_COORDINATES As String
Visual C++
public:
static initonly String^ _2D_PLANE_COORDINATES

See Also

MCitems Structure
MCitems Members


_2D_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_POINT_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_POINT_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_POINT_COORDINATES
Visual Basic
Public Shared ReadOnly _2D_POINT_COORDINATES As String
Visual C++
public:
static initonly String^ _2D_POINT_COORDINATES

See Also

MCitems Structure
MCitems Members


_2D_TO_3D_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._2D_TO_3D_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._2D_TO_3D_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _2D_TO_3D_MAP
Visual Basic
Public Shared ReadOnly _2D_TO_3D_MAP As String
Visual C++
public:
static initonly String^ _2D_TO_3D_MAP

See Also

MCitems Structure
MCitems Members


_3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::.._3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems._3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string _3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO
Visual Basic
Public Shared ReadOnly _3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO As String
Visual C++
public:
static initonly String^ _3D_RT_CONE_BEAM_IMAGING_GEOMETRY_MACRO

See Also

MCitems Structure
MCitems Members


ACCESS_END_POINTS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACCESS_END_POINTS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACCESS_END_POINTS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACCESS_END_POINTS_MACRO
Visual Basic
Public Shared ReadOnly ACCESS_END_POINTS_MACRO As String
Visual C++
public:
static initonly String^ ACCESS_END_POINTS_MACRO

See Also

MCitems Structure
MCitems Members


ACCESSORY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACCESSORY_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACCESSORY_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACCESSORY_CODE
Visual Basic
Public Shared ReadOnly ACCESSORY_CODE As String
Visual C++
public:
static initonly String^ ACCESSORY_CODE

See Also

MCitems Structure
MCitems Members


ACQUISITION_CONTEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_CONTEXT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_CONTEXT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_CONTEXT
Visual Basic
Public Shared ReadOnly ACQUISITION_CONTEXT As String
Visual C++
public:
static initonly String^ ACQUISITION_CONTEXT

See Also

MCitems Structure
MCitems Members


ACQUISITION_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_DEVICE
Visual Basic
Public Shared ReadOnly ACQUISITION_DEVICE As String
Visual C++
public:
static initonly String^ ACQUISITION_DEVICE

See Also

MCitems Structure
MCitems Members


ACQUISITION_PROTOCOL_ELEMENT_CT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_PROTOCOL_ELEMENT_CT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_PROTOCOL_ELEMENT_CT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_PROTOCOL_ELEMENT_CT
Visual Basic
Public Shared ReadOnly ACQUISITION_PROTOCOL_ELEMENT_CT As String
Visual C++
public:
static initonly String^ ACQUISITION_PROTOCOL_ELEMENT_CT

See Also

MCitems Structure
MCitems Members


ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION
Visual Basic
Public Shared ReadOnly ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION As String
Visual C++
public:
static initonly String^ ACQUISITION_PROTOCOL_ELEMENT_SPECIFICATION

See Also

MCitems Structure
MCitems Members


ACQUISITION_PROTOCOL_ELEMENT_XA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_PROTOCOL_ELEMENT_XA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_PROTOCOL_ELEMENT_XA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_PROTOCOL_ELEMENT_XA
Visual Basic
Public Shared ReadOnly ACQUISITION_PROTOCOL_ELEMENT_XA As String
Visual C++
public:
static initonly String^ ACQUISITION_PROTOCOL_ELEMENT_XA

See Also

MCitems Structure
MCitems Members


ACQUISITION_SUBTASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_SUBTASK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_SUBTASK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_SUBTASK
Visual Basic
Public Shared ReadOnly ACQUISITION_SUBTASK As String
Visual C++
public:
static initonly String^ ACQUISITION_SUBTASK

See Also

MCitems Structure
MCitems Members


ACQUISITION_TASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACQUISITION_TASK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACQUISITION_TASK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_TASK
Visual Basic
Public Shared ReadOnly ACQUISITION_TASK As String
Visual C++
public:
static initonly String^ ACQUISITION_TASK

See Also

MCitems Structure
MCitems Members


ACTUAL_HUMAN_PERFORMER_SCP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACTUAL_HUMAN_PERFORMER_SCP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACTUAL_HUMAN_PERFORMER_SCP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACTUAL_HUMAN_PERFORMER_SCP_MACRO
Visual Basic
Public Shared ReadOnly ACTUAL_HUMAN_PERFORMER_SCP_MACRO As String
Visual C++
public:
static initonly String^ ACTUAL_HUMAN_PERFORMER_SCP_MACRO

See Also

MCitems Structure
MCitems Members


ACTUAL_HUMAN_PERFORMERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACTUAL_HUMAN_PERFORMERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACTUAL_HUMAN_PERFORMERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACTUAL_HUMAN_PERFORMERS
Visual Basic
Public Shared ReadOnly ACTUAL_HUMAN_PERFORMERS As String
Visual C++
public:
static initonly String^ ACTUAL_HUMAN_PERFORMERS

See Also

MCitems Structure
MCitems Members


ACTUAL_HUMAN_PERFORMERS_M Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ACTUAL_HUMAN_PERFORMERS_M Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ACTUAL_HUMAN_PERFORMERS_M"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACTUAL_HUMAN_PERFORMERS_M
Visual Basic
Public Shared ReadOnly ACTUAL_HUMAN_PERFORMERS_M As String
Visual C++
public:
static initonly String^ ACTUAL_HUMAN_PERFORMERS_M

See Also

MCitems Structure
MCitems Members


ADD_NEAR_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ADD_NEAR_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ADD_NEAR_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ADD_NEAR_SQ
Visual Basic
Public Shared ReadOnly ADD_NEAR_SQ As String
Visual C++
public:
static initonly String^ ADD_NEAR_SQ

See Also

MCitems Structure
MCitems Members


ADDITIONAL_PARAMETER_RECORDING_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ADDITIONAL_PARAMETER_RECORDING_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ADDITIONAL_PARAMETER_RECORDING_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ADDITIONAL_PARAMETER_RECORDING_INSTANCE
Visual Basic
Public Shared ReadOnly ADDITIONAL_PARAMETER_RECORDING_INSTANCE As String
Visual C++
public:
static initonly String^ ADDITIONAL_PARAMETER_RECORDING_INSTANCE

See Also

MCitems Structure
MCitems Members


ADDITIONAL_RT_ACCESSORY_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ADDITIONAL_RT_ACCESSORY_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ADDITIONAL_RT_ACCESSORY_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ADDITIONAL_RT_ACCESSORY_DEVICE
Visual Basic
Public Shared ReadOnly ADDITIONAL_RT_ACCESSORY_DEVICE As String
Visual C++
public:
static initonly String^ ADDITIONAL_RT_ACCESSORY_DEVICE

See Also

MCitems Structure
MCitems Members


ADVANCED_BLENDING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ADVANCED_BLENDING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ADVANCED_BLENDING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ADVANCED_BLENDING
Visual Basic
Public Shared ReadOnly ADVANCED_BLENDING As String
Visual C++
public:
static initonly String^ ADVANCED_BLENDING

See Also

MCitems Structure
MCitems Members


AGE_CORRECTED_SENSIT_DEV_ALG Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..AGE_CORRECTED_SENSIT_DEV_ALG Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.AGE_CORRECTED_SENSIT_DEV_ALG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string AGE_CORRECTED_SENSIT_DEV_ALG
Visual Basic
Public Shared ReadOnly AGE_CORRECTED_SENSIT_DEV_ALG As String
Visual C++
public:
static initonly String^ AGE_CORRECTED_SENSIT_DEV_ALG

See Also

MCitems Structure
MCitems Members


ALGORITHM_IDENT_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ALGORITHM_IDENT_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ALGORITHM_IDENT_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ALGORITHM_IDENT_MACRO
Visual Basic
Public Shared ReadOnly ALGORITHM_IDENT_MACRO As String
Visual C++
public:
static initonly String^ ALGORITHM_IDENT_MACRO

See Also

MCitems Structure
MCitems Members


ALTERNATE_CONTAINER_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ALTERNATE_CONTAINER_IDENTIFIER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ALTERNATE_CONTAINER_IDENTIFIER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ALTERNATE_CONTAINER_IDENTIFIER
Visual Basic
Public Shared ReadOnly ALTERNATE_CONTAINER_IDENTIFIER As String
Visual C++
public:
static initonly String^ ALTERNATE_CONTAINER_IDENTIFIER

See Also

MCitems Structure
MCitems Members


ALTERNATE_CONTENT_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ALTERNATE_CONTENT_DESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ALTERNATE_CONTENT_DESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ALTERNATE_CONTENT_DESCRIPTION
Visual Basic
Public Shared ReadOnly ALTERNATE_CONTENT_DESCRIPTION As String
Visual C++
public:
static initonly String^ ALTERNATE_CONTENT_DESCRIPTION

See Also

MCitems Structure
MCitems Members


ALTERNATE_REPRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ALTERNATE_REPRESENTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ALTERNATE_REPRESENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ALTERNATE_REPRESENTATION
Visual Basic
Public Shared ReadOnly ALTERNATE_REPRESENTATION As String
Visual C++
public:
static initonly String^ ALTERNATE_REPRESENTATION

See Also

MCitems Structure
MCitems Members


ALTERNATE_REPRESENTATION_IN_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ALTERNATE_REPRESENTATION_IN_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ALTERNATE_REPRESENTATION_IN_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ALTERNATE_REPRESENTATION_IN_INVENTORY
Visual Basic
Public Shared ReadOnly ALTERNATE_REPRESENTATION_IN_INVENTORY As String
Visual C++
public:
static initonly String^ ALTERNATE_REPRESENTATION_IN_INVENTORY

See Also

MCitems Structure
MCitems Members


ANALOG_FILTER_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANALOG_FILTER_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANALOG_FILTER_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANALOG_FILTER_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly ANALOG_FILTER_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ ANALOG_FILTER_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


ANATOMIC_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANATOMIC_REGION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANATOMIC_REGION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANATOMIC_REGION
Visual Basic
Public Shared ReadOnly ANATOMIC_REGION As String
Visual C++
public:
static initonly String^ ANATOMIC_REGION

See Also

MCitems Structure
MCitems Members


ANATOMIC_REGION_IN_INTRA_ORAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANATOMIC_REGION_IN_INTRA_ORAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANATOMIC_REGION_IN_INTRA_ORAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANATOMIC_REGION_IN_INTRA_ORAL
Visual Basic
Public Shared ReadOnly ANATOMIC_REGION_IN_INTRA_ORAL As String
Visual C++
public:
static initonly String^ ANATOMIC_REGION_IN_INTRA_ORAL

See Also

MCitems Structure
MCitems Members


ANIMATION_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANIMATION_CURVE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANIMATION_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANIMATION_CURVE
Visual Basic
Public Shared ReadOnly ANIMATION_CURVE As String
Visual C++
public:
static initonly String^ ANIMATION_CURVE

See Also

MCitems Structure
MCitems Members


ANNOTATION_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANNOTATION_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANNOTATION_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANNOTATION_CONTENT
Visual Basic
Public Shared ReadOnly ANNOTATION_CONTENT As String
Visual C++
public:
static initonly String^ ANNOTATION_CONTENT

See Also

MCitems Structure
MCitems Members


ANNOTATION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANNOTATION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANNOTATION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANNOTATION_GROUP
Visual Basic
Public Shared ReadOnly ANNOTATION_GROUP As String
Visual C++
public:
static initonly String^ ANNOTATION_GROUP

See Also

MCitems Structure
MCitems Members


ANNOTATION_PROPERTY_TYPE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANNOTATION_PROPERTY_TYPE_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANNOTATION_PROPERTY_TYPE_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANNOTATION_PROPERTY_TYPE_CODE
Visual Basic
Public Shared ReadOnly ANNOTATION_PROPERTY_TYPE_CODE As String
Visual C++
public:
static initonly String^ ANNOTATION_PROPERTY_TYPE_CODE

See Also

MCitems Structure
MCitems Members


ANTERIOR_CHAMBER_DEPTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ANTERIOR_CHAMBER_DEPTH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ANTERIOR_CHAMBER_DEPTH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ANTERIOR_CHAMBER_DEPTH
Visual Basic
Public Shared ReadOnly ANTERIOR_CHAMBER_DEPTH As String
Visual C++
public:
static initonly String^ ANTERIOR_CHAMBER_DEPTH

See Also

MCitems Structure
MCitems Members


APPLICATION_SETUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPLICATION_SETUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPLICATION_SETUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPLICATION_SETUP
Visual Basic
Public Shared ReadOnly APPLICATION_SETUP As String
Visual C++
public:
static initonly String^ APPLICATION_SETUP

See Also

MCitems Structure
MCitems Members


APPLICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPLICATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPLICATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPLICATOR
Visual Basic
Public Shared ReadOnly APPLICATOR As String
Visual C++
public:
static initonly String^ APPLICATOR

See Also

MCitems Structure
MCitems Members


APPLICATOR_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPLICATOR_GEOMETRY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPLICATOR_GEOMETRY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPLICATOR_GEOMETRY
Visual Basic
Public Shared ReadOnly APPLICATOR_GEOMETRY As String
Visual C++
public:
static initonly String^ APPLICATOR_GEOMETRY

See Also

MCitems Structure
MCitems Members


APPLICATOR_IN_ION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPLICATOR_IN_ION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPLICATOR_IN_ION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPLICATOR_IN_ION
Visual Basic
Public Shared ReadOnly APPLICATOR_IN_ION As String
Visual C++
public:
static initonly String^ APPLICATOR_IN_ION

See Also

MCitems Structure
MCitems Members


APPLICATOR_IN_RT_GEN_MACH_VERIF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPLICATOR_IN_RT_GEN_MACH_VERIF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPLICATOR_IN_RT_GEN_MACH_VERIF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPLICATOR_IN_RT_GEN_MACH_VERIF
Visual Basic
Public Shared ReadOnly APPLICATOR_IN_RT_GEN_MACH_VERIF As String
Visual C++
public:
static initonly String^ APPLICATOR_IN_RT_GEN_MACH_VERIF

See Also

MCitems Structure
MCitems Members


APPROVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPROVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPROVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPROVAL
Visual Basic
Public Shared ReadOnly APPROVAL As String
Visual C++
public:
static initonly String^ APPROVAL

See Also

MCitems Structure
MCitems Members


APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ
Visual Basic
Public Shared ReadOnly APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ As String
Visual C++
public:
static initonly String^ APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP
Visual Basic
Public Shared ReadOnly APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP As String
Visual C++
public:
static initonly String^ APPROVAL_IN_PROTOCOL_APPROVAL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


ASL_BOLUS_CUT_OFF_TIMING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASL_BOLUS_CUT_OFF_TIMING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASL_BOLUS_CUT_OFF_TIMING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASL_BOLUS_CUT_OFF_TIMING
Visual Basic
Public Shared ReadOnly ASL_BOLUS_CUT_OFF_TIMING As String
Visual C++
public:
static initonly String^ ASL_BOLUS_CUT_OFF_TIMING

See Also

MCitems Structure
MCitems Members


ASL_SLAB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASL_SLAB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASL_SLAB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASL_SLAB
Visual Basic
Public Shared ReadOnly ASL_SLAB As String
Visual C++
public:
static initonly String^ ASL_SLAB

See Also

MCitems Structure
MCitems Members


ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ
Visual Basic
Public Shared ReadOnly ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ As String
Visual C++
public:
static initonly String^ ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP
Visual Basic
Public Shared ReadOnly ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP As String
Visual C++
public:
static initonly String^ ASSERTER_IDENTIFICATION_IN_PROTOCOL_APPROVAL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


ASSERTION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASSERTION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASSERTION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASSERTION_MACRO
Visual Basic
Public Shared ReadOnly ASSERTION_MACRO As String
Visual C++
public:
static initonly String^ ASSERTION_MACRO

See Also

MCitems Structure
MCitems Members


ASSESSED_SOP_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASSESSED_SOP_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASSESSED_SOP_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASSESSED_SOP_INSTANCE
Visual Basic
Public Shared ReadOnly ASSESSED_SOP_INSTANCE As String
Visual C++
public:
static initonly String^ ASSESSED_SOP_INSTANCE

See Also

MCitems Structure
MCitems Members


ASSESSMENT_OBSERVATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ASSESSMENT_OBSERVATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ASSESSMENT_OBSERVATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ASSESSMENT_OBSERVATIONS
Visual Basic
Public Shared ReadOnly ASSESSMENT_OBSERVATIONS As String
Visual C++
public:
static initonly String^ ASSESSMENT_OBSERVATIONS

See Also

MCitems Structure
MCitems Members


ATTRIBUTE_TOLERANCE_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ATTRIBUTE_TOLERANCE_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ATTRIBUTE_TOLERANCE_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ATTRIBUTE_TOLERANCE_VALUES
Visual Basic
Public Shared ReadOnly ATTRIBUTE_TOLERANCE_VALUES As String
Visual C++
public:
static initonly String^ ATTRIBUTE_TOLERANCE_VALUES

See Also

MCitems Structure
MCitems Members


ATTRIBUTE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ATTRIBUTE_VALUE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ATTRIBUTE_VALUE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ATTRIBUTE_VALUE
Visual Basic
Public Shared ReadOnly ATTRIBUTE_VALUE As String
Visual C++
public:
static initonly String^ ATTRIBUTE_VALUE

See Also

MCitems Structure
MCitems Members


ATTRIBUTE_VALUE_CONSTRAINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ATTRIBUTE_VALUE_CONSTRAINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ATTRIBUTE_VALUE_CONSTRAINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ATTRIBUTE_VALUE_CONSTRAINT
Visual Basic
Public Shared ReadOnly ATTRIBUTE_VALUE_CONSTRAINT As String
Visual C++
public:
static initonly String^ ATTRIBUTE_VALUE_CONSTRAINT

See Also

MCitems Structure
MCitems Members


AUTHOR_OBSERVER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..AUTHOR_OBSERVER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.AUTHOR_OBSERVER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string AUTHOR_OBSERVER
Visual Basic
Public Shared ReadOnly AUTHOR_OBSERVER As String
Visual C++
public:
static initonly String^ AUTHOR_OBSERVER

See Also

MCitems Structure
MCitems Members


AUTOREFRACTION_EYE_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..AUTOREFRACTION_EYE_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.AUTOREFRACTION_EYE_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string AUTOREFRACTION_EYE_SQ
Visual Basic
Public Shared ReadOnly AUTOREFRACTION_EYE_SQ As String
Visual C++
public:
static initonly String^ AUTOREFRACTION_EYE_SQ

See Also

MCitems Structure
MCitems Members


BASIC_CODE_SEQUENCE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BASIC_CODE_SEQUENCE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BASIC_CODE_SEQUENCE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_CODE_SEQUENCE_MACRO
Visual Basic
Public Shared ReadOnly BASIC_CODE_SEQUENCE_MACRO As String
Visual C++
public:
static initonly String^ BASIC_CODE_SEQUENCE_MACRO

See Also

MCitems Structure
MCitems Members


BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS
Visual Basic
Public Shared ReadOnly BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS As String
Visual C++
public:
static initonly String^ BASIC_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS

See Also

MCitems Structure
MCitems Members


BEAM_DOSE_VERIF_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_DOSE_VERIF_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_DOSE_VERIF_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_DOSE_VERIF_CONTROL_POINT
Visual Basic
Public Shared ReadOnly BEAM_DOSE_VERIF_CONTROL_POINT As String
Visual C++
public:
static initonly String^ BEAM_DOSE_VERIF_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


BEAM_IN_RT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_IN_RT_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_IN_RT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_IN_RT_IMAGE
Visual Basic
Public Shared ReadOnly BEAM_IN_RT_IMAGE As String
Visual C++
public:
static initonly String^ BEAM_IN_RT_IMAGE

See Also

MCitems Structure
MCitems Members


BEAM_ITEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_ITEM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_ITEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_ITEM
Visual Basic
Public Shared ReadOnly BEAM_ITEM As String
Visual C++
public:
static initonly String^ BEAM_ITEM

See Also

MCitems Structure
MCitems Members


BEAM_LIMITING_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_LIMITING_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_LIMITING_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_LIMITING_DEVICE
Visual Basic
Public Shared ReadOnly BEAM_LIMITING_DEVICE As String
Visual C++
public:
static initonly String^ BEAM_LIMITING_DEVICE

See Also

MCitems Structure
MCitems Members


BEAM_LIMITING_DEVICE_IN_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_LIMITING_DEVICE_IN_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_LIMITING_DEVICE_IN_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_LIMITING_DEVICE_IN_BEAM
Visual Basic
Public Shared ReadOnly BEAM_LIMITING_DEVICE_IN_BEAM As String
Visual C++
public:
static initonly String^ BEAM_LIMITING_DEVICE_IN_BEAM

See Also

MCitems Structure
MCitems Members


BEAM_LIMITING_DEVICE_LEAF_PAIRS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_LIMITING_DEVICE_LEAF_PAIRS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_LIMITING_DEVICE_LEAF_PAIRS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_LIMITING_DEVICE_LEAF_PAIRS
Visual Basic
Public Shared ReadOnly BEAM_LIMITING_DEVICE_LEAF_PAIRS As String
Visual C++
public:
static initonly String^ BEAM_LIMITING_DEVICE_LEAF_PAIRS

See Also

MCitems Structure
MCitems Members


BEAM_LIMITING_DEVICE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_LIMITING_DEVICE_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_LIMITING_DEVICE_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_LIMITING_DEVICE_POSITION
Visual Basic
Public Shared ReadOnly BEAM_LIMITING_DEVICE_POSITION As String
Visual C++
public:
static initonly String^ BEAM_LIMITING_DEVICE_POSITION

See Also

MCitems Structure
MCitems Members


BEAM_LIMITING_DEVICE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_LIMITING_DEVICE_TOLERANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_LIMITING_DEVICE_TOLERANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_LIMITING_DEVICE_TOLERANCE
Visual Basic
Public Shared ReadOnly BEAM_LIMITING_DEVICE_TOLERANCE As String
Visual C++
public:
static initonly String^ BEAM_LIMITING_DEVICE_TOLERANCE

See Also

MCitems Structure
MCitems Members


BEAM_TASK_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BEAM_TASK_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BEAM_TASK_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BEAM_TASK_SQ
Visual Basic
Public Shared ReadOnly BEAM_TASK_SQ As String
Visual C++
public:
static initonly String^ BEAM_TASK_SQ

See Also

MCitems Structure
MCitems Members


BILLING_SUPPLIES_AND_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BILLING_SUPPLIES_AND_DEVICES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BILLING_SUPPLIES_AND_DEVICES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BILLING_SUPPLIES_AND_DEVICES
Visual Basic
Public Shared ReadOnly BILLING_SUPPLIES_AND_DEVICES As String
Visual C++
public:
static initonly String^ BILLING_SUPPLIES_AND_DEVICES

See Also

MCitems Structure
MCitems Members


BIOPSY_TARGET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BIOPSY_TARGET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BIOPSY_TARGET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BIOPSY_TARGET
Visual Basic
Public Shared ReadOnly BIOPSY_TARGET As String
Visual C++
public:
static initonly String^ BIOPSY_TARGET

See Also

MCitems Structure
MCitems Members


BLENDING_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLENDING_DISPLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLENDING_DISPLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLENDING_DISPLAY
Visual Basic
Public Shared ReadOnly BLENDING_DISPLAY As String
Visual C++
public:
static initonly String^ BLENDING_DISPLAY

See Also

MCitems Structure
MCitems Members


BLENDING_DISPLAY_INPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLENDING_DISPLAY_INPUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLENDING_DISPLAY_INPUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLENDING_DISPLAY_INPUT
Visual Basic
Public Shared ReadOnly BLENDING_DISPLAY_INPUT As String
Visual C++
public:
static initonly String^ BLENDING_DISPLAY_INPUT

See Also

MCitems Structure
MCitems Members


BLENDING_LUT_1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLENDING_LUT_1 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLENDING_LUT_1"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLENDING_LUT_1
Visual Basic
Public Shared ReadOnly BLENDING_LUT_1 As String
Visual C++
public:
static initonly String^ BLENDING_LUT_1

See Also

MCitems Structure
MCitems Members


BLENDING_LUT_2 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLENDING_LUT_2 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLENDING_LUT_2"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLENDING_LUT_2
Visual Basic
Public Shared ReadOnly BLENDING_LUT_2 As String
Visual C++
public:
static initonly String^ BLENDING_LUT_2

See Also

MCitems Structure
MCitems Members


BLENDING_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLENDING_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLENDING_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLENDING_SEQUENCE
Visual Basic
Public Shared ReadOnly BLENDING_SEQUENCE As String
Visual C++
public:
static initonly String^ BLENDING_SEQUENCE

See Also

MCitems Structure
MCitems Members


BLOCK_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLOCK_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLOCK_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLOCK_DEFINITION
Visual Basic
Public Shared ReadOnly BLOCK_DEFINITION As String
Visual C++
public:
static initonly String^ BLOCK_DEFINITION

See Also

MCitems Structure
MCitems Members


BLOCK_EDGE_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLOCK_EDGE_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLOCK_EDGE_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLOCK_EDGE_DATA
Visual Basic
Public Shared ReadOnly BLOCK_EDGE_DATA As String
Visual C++
public:
static initonly String^ BLOCK_EDGE_DATA

See Also

MCitems Structure
MCitems Members


BLOCK_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLOCK_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLOCK_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLOCK_SEQUENCE
Visual Basic
Public Shared ReadOnly BLOCK_SEQUENCE As String
Visual C++
public:
static initonly String^ BLOCK_SEQUENCE

See Also

MCitems Structure
MCitems Members


BLOCK_SLAB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLOCK_SLAB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLOCK_SLAB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLOCK_SLAB
Visual Basic
Public Shared ReadOnly BLOCK_SLAB As String
Visual C++
public:
static initonly String^ BLOCK_SLAB

See Also

MCitems Structure
MCitems Members


BLOCK_SLAB_IN_BLOCKS_DEF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BLOCK_SLAB_IN_BLOCKS_DEF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BLOCK_SLAB_IN_BLOCKS_DEF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BLOCK_SLAB_IN_BLOCKS_DEF_MACRO
Visual Basic
Public Shared ReadOnly BLOCK_SLAB_IN_BLOCKS_DEF_MACRO As String
Visual C++
public:
static initonly String^ BLOCK_SLAB_IN_BLOCKS_DEF_MACRO

See Also

MCitems Structure
MCitems Members


BOLUS_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BOLUS_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BOLUS_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BOLUS_DEFINITION
Visual Basic
Public Shared ReadOnly BOLUS_DEFINITION As String
Visual C++
public:
static initonly String^ BOLUS_DEFINITION

See Also

MCitems Structure
MCitems Members


BRACHY_ACCESSORY_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_ACCESSORY_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_ACCESSORY_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_ACCESSORY_DEVICE
Visual Basic
Public Shared ReadOnly BRACHY_ACCESSORY_DEVICE As String
Visual C++
public:
static initonly String^ BRACHY_ACCESSORY_DEVICE

See Also

MCitems Structure
MCitems Members


BRACHY_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_CONTROL_POINT
Visual Basic
Public Shared ReadOnly BRACHY_CONTROL_POINT As String
Visual C++
public:
static initonly String^ BRACHY_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


BRACHY_CONTROL_POINT_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_CONTROL_POINT_DELIVERED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_CONTROL_POINT_DELIVERED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_CONTROL_POINT_DELIVERED
Visual Basic
Public Shared ReadOnly BRACHY_CONTROL_POINT_DELIVERED As String
Visual C++
public:
static initonly String^ BRACHY_CONTROL_POINT_DELIVERED

See Also

MCitems Structure
MCitems Members


BRACHY_PULSE_CONTROL_POINT_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_PULSE_CONTROL_POINT_DELIVERED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_PULSE_CONTROL_POINT_DELIVERED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_PULSE_CONTROL_POINT_DELIVERED
Visual Basic
Public Shared ReadOnly BRACHY_PULSE_CONTROL_POINT_DELIVERED As String
Visual C++
public:
static initonly String^ BRACHY_PULSE_CONTROL_POINT_DELIVERED

See Also

MCitems Structure
MCitems Members


BRACHY_REFERENCED_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_REFERENCED_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_REFERENCED_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_REFERENCED_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly BRACHY_REFERENCED_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ BRACHY_REFERENCED_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


BRACHY_TASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BRACHY_TASK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BRACHY_TASK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BRACHY_TASK
Visual Basic
Public Shared ReadOnly BRACHY_TASK As String
Visual C++
public:
static initonly String^ BRACHY_TASK

See Also

MCitems Structure
MCitems Members


BREAST_XRAY_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BREAST_XRAY_GEOMETRY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BREAST_XRAY_GEOMETRY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_XRAY_GEOMETRY
Visual Basic
Public Shared ReadOnly BREAST_XRAY_GEOMETRY As String
Visual C++
public:
static initonly String^ BREAST_XRAY_GEOMETRY

See Also

MCitems Structure
MCitems Members


BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM
Visual Basic
Public Shared ReadOnly BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM As String
Visual C++
public:
static initonly String^ BREAST_XRAY_ISOCENTER_REFERENCE_SYSTEM

See Also

MCitems Structure
MCitems Members


BREAST_XRAY_POSITIONER_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BREAST_XRAY_POSITIONER_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BREAST_XRAY_POSITIONER_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_XRAY_POSITIONER_POSITION
Visual Basic
Public Shared ReadOnly BREAST_XRAY_POSITIONER_POSITION As String
Visual C++
public:
static initonly String^ BREAST_XRAY_POSITIONER_POSITION

See Also

MCitems Structure
MCitems Members


BREED_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BREED_REGISTRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BREED_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREED_REGISTRATION
Visual Basic
Public Shared ReadOnly BREED_REGISTRATION As String
Visual C++
public:
static initonly String^ BREED_REGISTRATION

See Also

MCitems Structure
MCitems Members


BREED_REGISTRATION_MWL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..BREED_REGISTRATION_MWL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.BREED_REGISTRATION_MWL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREED_REGISTRATION_MWL
Visual Basic
Public Shared ReadOnly BREED_REGISTRATION_MWL As String
Visual C++
public:
static initonly String^ BREED_REGISTRATION_MWL

See Also

MCitems Structure
MCitems Members


C_ARM_PHOTON_ELECTRON_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..C_ARM_PHOTON_ELECTRON_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.C_ARM_PHOTON_ELECTRON_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string C_ARM_PHOTON_ELECTRON_CONTROL_POINT
Visual Basic
Public Shared ReadOnly C_ARM_PHOTON_ELECTRON_CONTROL_POINT As String
Visual C++
public:
static initonly String^ C_ARM_PHOTON_ELECTRON_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


CALCULATED_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CALCULATED_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CALCULATED_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CALCULATED_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly CALCULATED_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ CALCULATED_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


CALCULATED_TORIC_POWER_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CALCULATED_TORIC_POWER_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CALCULATED_TORIC_POWER_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CALCULATED_TORIC_POWER_MACRO
Visual Basic
Public Shared ReadOnly CALCULATED_TORIC_POWER_MACRO As String
Visual C++
public:
static initonly String^ CALCULATED_TORIC_POWER_MACRO

See Also

MCitems Structure
MCitems Members


CALCULATION_COMMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CALCULATION_COMMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CALCULATION_COMMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CALCULATION_COMMENT
Visual Basic
Public Shared ReadOnly CALCULATION_COMMENT As String
Visual C++
public:
static initonly String^ CALCULATION_COMMENT

See Also

MCitems Structure
MCitems Members


CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CALIBRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CALIBRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CALIBRATION
Visual Basic
Public Shared ReadOnly CALIBRATION As String
Visual C++
public:
static initonly String^ CALIBRATION

See Also

MCitems Structure
MCitems Members


CALIBRATION_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CALIBRATION_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CALIBRATION_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CALIBRATION_DATA
Visual Basic
Public Shared ReadOnly CALIBRATION_DATA As String
Visual C++
public:
static initonly String^ CALIBRATION_DATA

See Also

MCitems Structure
MCitems Members


CAMERA_POSITION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CAMERA_POSITION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CAMERA_POSITION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CAMERA_POSITION_GROUP
Visual Basic
Public Shared ReadOnly CAMERA_POSITION_GROUP As String
Visual C++
public:
static initonly String^ CAMERA_POSITION_GROUP

See Also

MCitems Structure
MCitems Members


CARDIAC_TRIGGER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CARDIAC_TRIGGER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CARDIAC_TRIGGER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CARDIAC_TRIGGER
Visual Basic
Public Shared ReadOnly CARDIAC_TRIGGER As String
Visual C++
public:
static initonly String^ CARDIAC_TRIGGER

See Also

MCitems Structure
MCitems Members


CELL_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CELL_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CELL_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CELL_VALUES
Visual Basic
Public Shared ReadOnly CELL_VALUES As String
Visual C++
public:
static initonly String^ CELL_VALUES

See Also

MCitems Structure
MCitems Members


CHANNEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL
Visual Basic
Public Shared ReadOnly CHANNEL As String
Visual C++
public:
static initonly String^ CHANNEL

See Also

MCitems Structure
MCitems Members


CHANNEL_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_DEFINITION
Visual Basic
Public Shared ReadOnly CHANNEL_DEFINITION As String
Visual C++
public:
static initonly String^ CHANNEL_DEFINITION

See Also

MCitems Structure
MCitems Members


CHANNEL_DELIVERY_CONTINUATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_DELIVERY_CONTINUATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_DELIVERY_CONTINUATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_DELIVERY_CONTINUATION
Visual Basic
Public Shared ReadOnly CHANNEL_DELIVERY_CONTINUATION As String
Visual C++
public:
static initonly String^ CHANNEL_DELIVERY_CONTINUATION

See Also

MCitems Structure
MCitems Members


CHANNEL_DELIVERY_ORDER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_DELIVERY_ORDER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_DELIVERY_ORDER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_DELIVERY_ORDER
Visual Basic
Public Shared ReadOnly CHANNEL_DELIVERY_ORDER As String
Visual C++
public:
static initonly String^ CHANNEL_DELIVERY_ORDER

See Also

MCitems Structure
MCitems Members


CHANNEL_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_DISPLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_DISPLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_DISPLAY
Visual Basic
Public Shared ReadOnly CHANNEL_DISPLAY As String
Visual C++
public:
static initonly String^ CHANNEL_DISPLAY

See Also

MCitems Structure
MCitems Members


CHANNEL_IMPEDANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_IMPEDANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_IMPEDANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_IMPEDANCE
Visual Basic
Public Shared ReadOnly CHANNEL_IMPEDANCE As String
Visual C++
public:
static initonly String^ CHANNEL_IMPEDANCE

See Also

MCitems Structure
MCitems Members


CHANNEL_SHIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHANNEL_SHIELD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHANNEL_SHIELD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHANNEL_SHIELD
Visual Basic
Public Shared ReadOnly CHANNEL_SHIELD As String
Visual C++
public:
static initonly String^ CHANNEL_SHIELD

See Also

MCitems Structure
MCitems Members


CHEMICAL_SHIFT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CHEMICAL_SHIFT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CHEMICAL_SHIFT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHEMICAL_SHIFT
Visual Basic
Public Shared ReadOnly CHEMICAL_SHIFT As String
Visual C++
public:
static initonly String^ CHEMICAL_SHIFT

See Also

MCitems Structure
MCitems Members


CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ
Visual Basic
Public Shared ReadOnly CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ As String
Visual C++
public:
static initonly String^ CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP
Visual Basic
Public Shared ReadOnly CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP As String
Visual C++
public:
static initonly String^ CODE_SEQUENCE_IN_PROTOCOL_APPROVAL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


CODE_SEQUENCE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODE_SEQUENCE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODE_SEQUENCE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODE_SEQUENCE_MACRO
Visual Basic
Public Shared ReadOnly CODE_SEQUENCE_MACRO As String
Visual C++
public:
static initonly String^ CODE_SEQUENCE_MACRO

See Also

MCitems Structure
MCitems Members


CODE_SEQUENCE_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODE_SEQUENCE_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODE_SEQUENCE_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODE_SEQUENCE_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly CODE_SEQUENCE_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ CODE_SEQUENCE_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


CODE_SEQUENCE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODE_SEQUENCE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODE_SEQUENCE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODE_SEQUENCE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly CODE_SEQUENCE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ CODE_SEQUENCE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


CODING_SCHEME_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODING_SCHEME_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODING_SCHEME_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODING_SCHEME_IDENTIFICATION
Visual Basic
Public Shared ReadOnly CODING_SCHEME_IDENTIFICATION As String
Visual C++
public:
static initonly String^ CODING_SCHEME_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


CODING_SCHEME_RESOURCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CODING_SCHEME_RESOURCES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CODING_SCHEME_RESOURCES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CODING_SCHEME_RESOURCES
Visual Basic
Public Shared ReadOnly CODING_SCHEME_RESOURCES As String
Visual C++
public:
static initonly String^ CODING_SCHEME_RESOURCES

See Also

MCitems Structure
MCitems Members


COLLIMATOR_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COLLIMATOR_SHAPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COLLIMATOR_SHAPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLLIMATOR_SHAPE
Visual Basic
Public Shared ReadOnly COLLIMATOR_SHAPE As String
Visual C++
public:
static initonly String^ COLLIMATOR_SHAPE

See Also

MCitems Structure
MCitems Members


COMBINATION_SEGMENT_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMBINATION_SEGMENT_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMBINATION_SEGMENT_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMBINATION_SEGMENT_REFERENCE
Visual Basic
Public Shared ReadOnly COMBINATION_SEGMENT_REFERENCE As String
Visual C++
public:
static initonly String^ COMBINATION_SEGMENT_REFERENCE

See Also

MCitems Structure
MCitems Members


COMPENSATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPENSATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPENSATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPENSATOR
Visual Basic
Public Shared ReadOnly COMPENSATOR As String
Visual C++
public:
static initonly String^ COMPENSATOR

See Also

MCitems Structure
MCitems Members


COMPENSATOR_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPENSATOR_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPENSATOR_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPENSATOR_DEFINITION
Visual Basic
Public Shared ReadOnly COMPENSATOR_DEFINITION As String
Visual C++
public:
static initonly String^ COMPENSATOR_DEFINITION

See Also

MCitems Structure
MCitems Members


COMPENSATOR_SHAPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPENSATOR_SHAPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPENSATOR_SHAPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPENSATOR_SHAPE
Visual Basic
Public Shared ReadOnly COMPENSATOR_SHAPE As String
Visual C++
public:
static initonly String^ COMPENSATOR_SHAPE

See Also

MCitems Structure
MCitems Members


COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPONENT
Visual Basic
Public Shared ReadOnly COMPONENT As String
Visual C++
public:
static initonly String^ COMPONENT

See Also

MCitems Structure
MCitems Members


COMPONENT_ASSEMBLY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPONENT_ASSEMBLY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPONENT_ASSEMBLY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPONENT_ASSEMBLY
Visual Basic
Public Shared ReadOnly COMPONENT_ASSEMBLY As String
Visual C++
public:
static initonly String^ COMPONENT_ASSEMBLY

See Also

MCitems Structure
MCitems Members


COMPONENT_INPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPONENT_INPUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPONENT_INPUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPONENT_INPUT
Visual Basic
Public Shared ReadOnly COMPONENT_INPUT As String
Visual C++
public:
static initonly String^ COMPONENT_INPUT

See Also

MCitems Structure
MCitems Members


COMPONENT_TYPES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPONENT_TYPES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPONENT_TYPES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPONENT_TYPES
Visual Basic
Public Shared ReadOnly COMPONENT_TYPES As String
Visual C++
public:
static initonly String^ COMPONENT_TYPES

See Also

MCitems Structure
MCitems Members


COMPOUND_GRAPHIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..COMPOUND_GRAPHIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.COMPOUND_GRAPHIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPOUND_GRAPHIC
Visual Basic
Public Shared ReadOnly COMPOUND_GRAPHIC As String
Visual C++
public:
static initonly String^ COMPOUND_GRAPHIC

See Also

MCitems Structure
MCitems Members


CONCEPT_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPT_CODE_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPT_CODE_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPT_CODE_SEQUENCE
Visual Basic
Public Shared ReadOnly CONCEPT_CODE_SEQUENCE As String
Visual C++
public:
static initonly String^ CONCEPT_CODE_SEQUENCE

See Also

MCitems Structure
MCitems Members


CONCEPT_NAME_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPT_NAME_CODE_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPT_NAME_CODE_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPT_NAME_CODE_SEQUENCE
Visual Basic
Public Shared ReadOnly CONCEPT_NAME_CODE_SEQUENCE As String
Visual C++
public:
static initonly String^ CONCEPT_NAME_CODE_SEQUENCE

See Also

MCitems Structure
MCitems Members


CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO
Visual Basic
Public Shared ReadOnly CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO As String
Visual C++
public:
static initonly String^ CONCEPTUAL_VOL_SEGMENTATION_REF_AND_COMBINATION_MACRO

See Also

MCitems Structure
MCitems Members


CONCEPTUAL_VOLUME_CONSTITUENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPTUAL_VOLUME_CONSTITUENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPTUAL_VOLUME_CONSTITUENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPTUAL_VOLUME_CONSTITUENT
Visual Basic
Public Shared ReadOnly CONCEPTUAL_VOLUME_CONSTITUENT As String
Visual C++
public:
static initonly String^ CONCEPTUAL_VOLUME_CONSTITUENT

See Also

MCitems Structure
MCitems Members


CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE
Visual Basic
Public Shared ReadOnly CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE As String
Visual C++
public:
static initonly String^ CONCEPTUAL_VOLUME_CONSTITUENT_SEGMENTATION_REFERENCE

See Also

MCitems Structure
MCitems Members


CONCEPTUAL_VOLUME_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPTUAL_VOLUME_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPTUAL_VOLUME_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPTUAL_VOLUME_IDENTIFICATION
Visual Basic
Public Shared ReadOnly CONCEPTUAL_VOLUME_IDENTIFICATION As String
Visual C++
public:
static initonly String^ CONCEPTUAL_VOLUME_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE
Visual Basic
Public Shared ReadOnly CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE As String
Visual C++
public:
static initonly String^ CONCEPTUAL_VOLUME_SEGMENTATION_REFERENCE

See Also

MCitems Structure
MCitems Members


CONFIGURATION_QA_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONFIGURATION_QA_RESULTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONFIGURATION_QA_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONFIGURATION_QA_RESULTS
Visual Basic
Public Shared ReadOnly CONFIGURATION_QA_RESULTS As String
Visual C++
public:
static initonly String^ CONFIGURATION_QA_RESULTS

See Also

MCitems Structure
MCitems Members


CONFIGURATION_QA_RESULTS_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONFIGURATION_QA_RESULTS_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONFIGURATION_QA_RESULTS_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONFIGURATION_QA_RESULTS_SCP
Visual Basic
Public Shared ReadOnly CONFIGURATION_QA_RESULTS_SCP As String
Visual C++
public:
static initonly String^ CONFIGURATION_QA_RESULTS_SCP

See Also

MCitems Structure
MCitems Members


CONFIGURATION_QA_RESULTS_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONFIGURATION_QA_RESULTS_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONFIGURATION_QA_RESULTS_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONFIGURATION_QA_RESULTS_SCU
Visual Basic
Public Shared ReadOnly CONFIGURATION_QA_RESULTS_SCU As String
Visual C++
public:
static initonly String^ CONFIGURATION_QA_RESULTS_SCU

See Also

MCitems Structure
MCitems Members


CONSENT_FOR_CLINICAL_TRIAL_USE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONSENT_FOR_CLINICAL_TRIAL_USE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONSENT_FOR_CLINICAL_TRIAL_USE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONSENT_FOR_CLINICAL_TRIAL_USE
Visual Basic
Public Shared ReadOnly CONSENT_FOR_CLINICAL_TRIAL_USE As String
Visual C++
public:
static initonly String^ CONSENT_FOR_CLINICAL_TRIAL_USE

See Also

MCitems Structure
MCitems Members


CONTAINER_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTAINER_COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTAINER_COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTAINER_COMPONENT
Visual Basic
Public Shared ReadOnly CONTAINER_COMPONENT As String
Visual C++
public:
static initonly String^ CONTAINER_COMPONENT

See Also

MCitems Structure
MCitems Members


CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT
Visual Basic
Public Shared ReadOnly CONTENT As String
Visual C++
public:
static initonly String^ CONTENT

See Also

MCitems Structure
MCitems Members


CONTENT_IN_ENCAP_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_IN_ENCAP_DOC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_IN_ENCAP_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_IN_ENCAP_DOC
Visual Basic
Public Shared ReadOnly CONTENT_IN_ENCAP_DOC As String
Visual C++
public:
static initonly String^ CONTENT_IN_ENCAP_DOC

See Also

MCitems Structure
MCitems Members


CONTENT_ITEM_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_ITEM_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_ITEM_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_ITEM_MACRO
Visual Basic
Public Shared ReadOnly CONTENT_ITEM_MACRO As String
Visual C++
public:
static initonly String^ CONTENT_ITEM_MACRO

See Also

MCitems Structure
MCitems Members


CONTENT_ITEM_WITH_MODIFIERS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_ITEM_WITH_MODIFIERS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_ITEM_WITH_MODIFIERS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_ITEM_WITH_MODIFIERS_MACRO
Visual Basic
Public Shared ReadOnly CONTENT_ITEM_WITH_MODIFIERS_MACRO As String
Visual C++
public:
static initonly String^ CONTENT_ITEM_WITH_MODIFIERS_MACRO

See Also

MCitems Structure
MCitems Members


CONTENT_TEMPLATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_TEMPLATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_TEMPLATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_TEMPLATE
Visual Basic
Public Shared ReadOnly CONTENT_TEMPLATE As String
Visual C++
public:
static initonly String^ CONTENT_TEMPLATE

See Also

MCitems Structure
MCitems Members


CONTENT_TEMPLATE_IN_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_TEMPLATE_IN_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_TEMPLATE_IN_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_TEMPLATE_IN_IMAGE
Visual Basic
Public Shared ReadOnly CONTENT_TEMPLATE_IN_IMAGE As String
Visual C++
public:
static initonly String^ CONTENT_TEMPLATE_IN_IMAGE

See Also

MCitems Structure
MCitems Members


CONTENT_TEMPLATE_IN_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTENT_TEMPLATE_IN_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTENT_TEMPLATE_IN_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_TEMPLATE_IN_INVENTORY
Visual Basic
Public Shared ReadOnly CONTENT_TEMPLATE_IN_INVENTORY As String
Visual C++
public:
static initonly String^ CONTENT_TEMPLATE_IN_INVENTORY

See Also

MCitems Structure
MCitems Members


CONTEXT_GROUP_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTEXT_GROUP_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTEXT_GROUP_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTEXT_GROUP_IDENTIFICATION
Visual Basic
Public Shared ReadOnly CONTEXT_GROUP_IDENTIFICATION As String
Visual C++
public:
static initonly String^ CONTEXT_GROUP_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


CONTOUR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTOUR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTOUR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTOUR
Visual Basic
Public Shared ReadOnly CONTOUR As String
Visual C++
public:
static initonly String^ CONTOUR

See Also

MCitems Structure
MCitems Members


CONTOUR_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTOUR_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTOUR_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTOUR_IMAGE
Visual Basic
Public Shared ReadOnly CONTOUR_IMAGE As String
Visual C++
public:
static initonly String^ CONTOUR_IMAGE

See Also

MCitems Structure
MCitems Members


CONTRAST_ADMIN_PROFILE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRAST_ADMIN_PROFILE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRAST_ADMIN_PROFILE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRAST_ADMIN_PROFILE
Visual Basic
Public Shared ReadOnly CONTRAST_ADMIN_PROFILE As String
Visual C++
public:
static initonly String^ CONTRAST_ADMIN_PROFILE

See Also

MCitems Structure
MCitems Members


CONTRAST_BOLUS_ADMIN_ROUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRAST_BOLUS_ADMIN_ROUTE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRAST_BOLUS_ADMIN_ROUTE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRAST_BOLUS_ADMIN_ROUTE
Visual Basic
Public Shared ReadOnly CONTRAST_BOLUS_ADMIN_ROUTE As String
Visual C++
public:
static initonly String^ CONTRAST_BOLUS_ADMIN_ROUTE

See Also

MCitems Structure
MCitems Members


CONTRAST_BOLUS_USAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRAST_BOLUS_USAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRAST_BOLUS_USAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRAST_BOLUS_USAGE
Visual Basic
Public Shared ReadOnly CONTRAST_BOLUS_USAGE As String
Visual C++
public:
static initonly String^ CONTRAST_BOLUS_USAGE

See Also

MCitems Structure
MCitems Members


CONTRIBUTING_EQUIPMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRIBUTING_EQUIPMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRIBUTING_EQUIPMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRIBUTING_EQUIPMENT
Visual Basic
Public Shared ReadOnly CONTRIBUTING_EQUIPMENT As String
Visual C++
public:
static initonly String^ CONTRIBUTING_EQUIPMENT

See Also

MCitems Structure
MCitems Members


CONTRIBUTING_SOP_INSTANCE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRIBUTING_SOP_INSTANCE_REF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRIBUTING_SOP_INSTANCE_REF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRIBUTING_SOP_INSTANCE_REF
Visual Basic
Public Shared ReadOnly CONTRIBUTING_SOP_INSTANCE_REF As String
Visual C++
public:
static initonly String^ CONTRIBUTING_SOP_INSTANCE_REF

See Also

MCitems Structure
MCitems Members


CONTRIBUTING_SOURCES_ANGIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRIBUTING_SOURCES_ANGIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRIBUTING_SOURCES_ANGIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRIBUTING_SOURCES_ANGIO
Visual Basic
Public Shared ReadOnly CONTRIBUTING_SOURCES_ANGIO As String
Visual C++
public:
static initonly String^ CONTRIBUTING_SOURCES_ANGIO

See Also

MCitems Structure
MCitems Members


CONTRIBUTING_SOURCES_CRANIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRIBUTING_SOURCES_CRANIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRIBUTING_SOURCES_CRANIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRIBUTING_SOURCES_CRANIO
Visual Basic
Public Shared ReadOnly CONTRIBUTING_SOURCES_CRANIO As String
Visual C++
public:
static initonly String^ CONTRIBUTING_SOURCES_CRANIO

See Also

MCitems Structure
MCitems Members


CONTRIBUTING_SOURCES_TOMO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTRIBUTING_SOURCES_TOMO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTRIBUTING_SOURCES_TOMO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTRIBUTING_SOURCES_TOMO
Visual Basic
Public Shared ReadOnly CONTRIBUTING_SOURCES_TOMO As String
Visual C++
public:
static initonly String^ CONTRIBUTING_SOURCES_TOMO

See Also

MCitems Structure
MCitems Members


CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTROL_POINT
Visual Basic
Public Shared ReadOnly CONTROL_POINT As String
Visual C++
public:
static initonly String^ CONTROL_POINT

See Also

MCitems Structure
MCitems Members


CONTROL_POINT_DELIVERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONTROL_POINT_DELIVERY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONTROL_POINT_DELIVERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTROL_POINT_DELIVERY
Visual Basic
Public Shared ReadOnly CONTROL_POINT_DELIVERY As String
Visual C++
public:
static initonly String^ CONTROL_POINT_DELIVERY

See Also

MCitems Structure
MCitems Members


CONVENTIONAL_CONTROL_POINT_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONVENTIONAL_CONTROL_POINT_VERIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONVENTIONAL_CONTROL_POINT_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONVENTIONAL_CONTROL_POINT_VERIFICATION
Visual Basic
Public Shared ReadOnly CONVENTIONAL_CONTROL_POINT_VERIFICATION As String
Visual C++
public:
static initonly String^ CONVENTIONAL_CONTROL_POINT_VERIFICATION

See Also

MCitems Structure
MCitems Members


CONVENTIONAL_MACHINE_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CONVENTIONAL_MACHINE_VERIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CONVENTIONAL_MACHINE_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONVENTIONAL_MACHINE_VERIFICATION
Visual Basic
Public Shared ReadOnly CONVENTIONAL_MACHINE_VERIFICATION As String
Visual C++
public:
static initonly String^ CONVENTIONAL_MACHINE_VERIFICATION

See Also

MCitems Structure
MCitems Members


CORNEA_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CORNEA_MEASUREMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CORNEA_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CORNEA_MEASUREMENTS
Visual Basic
Public Shared ReadOnly CORNEA_MEASUREMENTS As String
Visual C++
public:
static initonly String^ CORNEA_MEASUREMENTS

See Also

MCitems Structure
MCitems Members


CORNEAL_SIZE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CORNEAL_SIZE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CORNEAL_SIZE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CORNEAL_SIZE
Visual Basic
Public Shared ReadOnly CORNEAL_SIZE As String
Visual C++
public:
static initonly String^ CORNEAL_SIZE

See Also

MCitems Structure
MCitems Members


CORRECTED_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CORRECTED_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CORRECTED_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CORRECTED_PARAMETERS
Visual Basic
Public Shared ReadOnly CORRECTED_PARAMETERS As String
Visual C++
public:
static initonly String^ CORRECTED_PARAMETERS

See Also

MCitems Structure
MCitems Members


CT_ACQUISITION_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_ACQUISITION_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_ACQUISITION_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_ACQUISITION_DETAILS
Visual Basic
Public Shared ReadOnly CT_ACQUISITION_DETAILS As String
Visual C++
public:
static initonly String^ CT_ACQUISITION_DETAILS

See Also

MCitems Structure
MCitems Members


CT_ACQUISITION_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_ACQUISITION_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_ACQUISITION_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_ACQUISITION_TYPE
Visual Basic
Public Shared ReadOnly CT_ACQUISITION_TYPE As String
Visual C++
public:
static initonly String^ CT_ACQUISITION_TYPE

See Also

MCitems Structure
MCitems Members


CT_ADDITIONAL_XRAY_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_ADDITIONAL_XRAY_SOURCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_ADDITIONAL_XRAY_SOURCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_ADDITIONAL_XRAY_SOURCE
Visual Basic
Public Shared ReadOnly CT_ADDITIONAL_XRAY_SOURCE As String
Visual C++
public:
static initonly String^ CT_ADDITIONAL_XRAY_SOURCE

See Also

MCitems Structure
MCitems Members


CT_ADDITIONAL_XRAY_SOURCE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_ADDITIONAL_XRAY_SOURCE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_ADDITIONAL_XRAY_SOURCE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_ADDITIONAL_XRAY_SOURCE_MACRO
Visual Basic
Public Shared ReadOnly CT_ADDITIONAL_XRAY_SOURCE_MACRO As String
Visual C++
public:
static initonly String^ CT_ADDITIONAL_XRAY_SOURCE_MACRO

See Also

MCitems Structure
MCitems Members


CT_EXPOSURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_EXPOSURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_EXPOSURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_EXPOSURE
Visual Basic
Public Shared ReadOnly CT_EXPOSURE As String
Visual C++
public:
static initonly String^ CT_EXPOSURE

See Also

MCitems Structure
MCitems Members


CT_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_GEOMETRY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_GEOMETRY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_GEOMETRY
Visual Basic
Public Shared ReadOnly CT_GEOMETRY As String
Visual C++
public:
static initonly String^ CT_GEOMETRY

See Also

MCitems Structure
MCitems Members


CT_IMAGE_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_IMAGE_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_IMAGE_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_IMAGE_FRAME_TYPE
Visual Basic
Public Shared ReadOnly CT_IMAGE_FRAME_TYPE As String
Visual C++
public:
static initonly String^ CT_IMAGE_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


CT_PIXEL_VALUE_TRANSFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_PIXEL_VALUE_TRANSFORMATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_PIXEL_VALUE_TRANSFORMATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_PIXEL_VALUE_TRANSFORMATION
Visual Basic
Public Shared ReadOnly CT_PIXEL_VALUE_TRANSFORMATION As String
Visual C++
public:
static initonly String^ CT_PIXEL_VALUE_TRANSFORMATION

See Also

MCitems Structure
MCitems Members


CT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_POSITION
Visual Basic
Public Shared ReadOnly CT_POSITION As String
Visual C++
public:
static initonly String^ CT_POSITION

See Also

MCitems Structure
MCitems Members


CT_RECONSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_RECONSTRUCTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_RECONSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_RECONSTRUCTION
Visual Basic
Public Shared ReadOnly CT_RECONSTRUCTION As String
Visual C++
public:
static initonly String^ CT_RECONSTRUCTION

See Also

MCitems Structure
MCitems Members


CT_TABLE_DYNAMICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_TABLE_DYNAMICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_TABLE_DYNAMICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_TABLE_DYNAMICS
Visual Basic
Public Shared ReadOnly CT_TABLE_DYNAMICS As String
Visual C++
public:
static initonly String^ CT_TABLE_DYNAMICS

See Also

MCitems Structure
MCitems Members


CT_XRAY_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_XRAY_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_XRAY_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_XRAY_DETAILS
Visual Basic
Public Shared ReadOnly CT_XRAY_DETAILS As String
Visual C++
public:
static initonly String^ CT_XRAY_DETAILS

See Also

MCitems Structure
MCitems Members


CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ
Visual Basic
Public Shared ReadOnly CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ As String
Visual C++
public:
static initonly String^ CT_XRAY_DETAILS_IN_ACQ_PROTOCOL_ELEM_SQ

See Also

MCitems Structure
MCitems Members


CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO
Visual Basic
Public Shared ReadOnly CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO As String
Visual C++
public:
static initonly String^ CURRENT_FRAME_FUNCTIONAL_GROUPS_AUDIO

See Also

MCitems Structure
MCitems Members


CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO
Visual Basic
Public Shared ReadOnly CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO As String
Visual C++
public:
static initonly String^ CURRENT_FRAME_FUNCTIONAL_GROUPS_VIDEO

See Also

MCitems Structure
MCitems Members


CUSTODIAL_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CUSTODIAL_ORGANIZATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CUSTODIAL_ORGANIZATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CUSTODIAL_ORGANIZATION
Visual Basic
Public Shared ReadOnly CUSTODIAL_ORGANIZATION As String
Visual C++
public:
static initonly String^ CUSTODIAL_ORGANIZATION

See Also

MCitems Structure
MCitems Members


CYLINDER_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..CYLINDER_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.CYLINDER_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CYLINDER_SQ
Visual Basic
Public Shared ReadOnly CYLINDER_SQ As String
Visual C++
public:
static initonly String^ CYLINDER_SQ

See Also

MCitems Structure
MCitems Members


DATA_FRAME_ASSIGNMENT_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DATA_FRAME_ASSIGNMENT_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DATA_FRAME_ASSIGNMENT_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DATA_FRAME_ASSIGNMENT_SQ
Visual Basic
Public Shared ReadOnly DATA_FRAME_ASSIGNMENT_SQ As String
Visual C++
public:
static initonly String^ DATA_FRAME_ASSIGNMENT_SQ

See Also

MCitems Structure
MCitems Members


DATA_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DATA_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DATA_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DATA_INFO
Visual Basic
Public Shared ReadOnly DATA_INFO As String
Visual C++
public:
static initonly String^ DATA_INFO

See Also

MCitems Structure
MCitems Members


DATA_OBSERVATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DATA_OBSERVATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DATA_OBSERVATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DATA_OBSERVATION
Visual Basic
Public Shared ReadOnly DATA_OBSERVATION As String
Visual C++
public:
static initonly String^ DATA_OBSERVATION

See Also

MCitems Structure
MCitems Members


DECOMPOSITION_MATERIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DECOMPOSITION_MATERIAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DECOMPOSITION_MATERIAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DECOMPOSITION_MATERIAL
Visual Basic
Public Shared ReadOnly DECOMPOSITION_MATERIAL As String
Visual C++
public:
static initonly String^ DECOMPOSITION_MATERIAL

See Also

MCitems Structure
MCitems Members


DEFINITION_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEFINITION_SOURCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEFINITION_SOURCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINITION_SOURCE
Visual Basic
Public Shared ReadOnly DEFINITION_SOURCE As String
Visual C++
public:
static initonly String^ DEFINITION_SOURCE

See Also

MCitems Structure
MCitems Members


DEFINITION_SOURCE_IN_RT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEFINITION_SOURCE_IN_RT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEFINITION_SOURCE_IN_RT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINITION_SOURCE_IN_RT
Visual Basic
Public Shared ReadOnly DEFINITION_SOURCE_IN_RT As String
Visual C++
public:
static initonly String^ DEFINITION_SOURCE_IN_RT

See Also

MCitems Structure
MCitems Members


DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE
Visual Basic
Public Shared ReadOnly DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE As String
Visual C++
public:
static initonly String^ DEFINITION_SOURCE_IN_STRUCTURE_SET_MODULE

See Also

MCitems Structure
MCitems Members


DEFORMABLE_REG_GRID Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEFORMABLE_REG_GRID Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEFORMABLE_REG_GRID"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFORMABLE_REG_GRID
Visual Basic
Public Shared ReadOnly DEFORMABLE_REG_GRID As String
Visual C++
public:
static initonly String^ DEFORMABLE_REG_GRID

See Also

MCitems Structure
MCitems Members


DEFORMABLE_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEFORMABLE_REGISTRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEFORMABLE_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFORMABLE_REGISTRATION
Visual Basic
Public Shared ReadOnly DEFORMABLE_REGISTRATION As String
Visual C++
public:
static initonly String^ DEFORMABLE_REGISTRATION

See Also

MCitems Structure
MCitems Members


DEIDENTIFICATION_ACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEIDENTIFICATION_ACTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEIDENTIFICATION_ACTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEIDENTIFICATION_ACTION
Visual Basic
Public Shared ReadOnly DEIDENTIFICATION_ACTION As String
Visual C++
public:
static initonly String^ DEIDENTIFICATION_ACTION

See Also

MCitems Structure
MCitems Members


DELIVERED_DEPTH_DOSE_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DELIVERED_DEPTH_DOSE_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DELIVERED_DEPTH_DOSE_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DELIVERED_DEPTH_DOSE_PARAMETERS
Visual Basic
Public Shared ReadOnly DELIVERED_DEPTH_DOSE_PARAMETERS As String
Visual C++
public:
static initonly String^ DELIVERED_DEPTH_DOSE_PARAMETERS

See Also

MCitems Structure
MCitems Members


DELIVERY_VERIF_IMAGE_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DELIVERY_VERIF_IMAGE_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DELIVERY_VERIF_IMAGE_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DELIVERY_VERIF_IMAGE_SQ
Visual Basic
Public Shared ReadOnly DELIVERY_VERIF_IMAGE_SQ As String
Visual C++
public:
static initonly String^ DELIVERY_VERIF_IMAGE_SQ

See Also

MCitems Structure
MCitems Members


DEPTH_DOSE_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEPTH_DOSE_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEPTH_DOSE_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEPTH_DOSE_PARAMETERS
Visual Basic
Public Shared ReadOnly DEPTH_DOSE_PARAMETERS As String
Visual C++
public:
static initonly String^ DEPTH_DOSE_PARAMETERS

See Also

MCitems Structure
MCitems Members


DERIVATION_CONCEPTUAL_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DERIVATION_CONCEPTUAL_VOLUME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DERIVATION_CONCEPTUAL_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DERIVATION_CONCEPTUAL_VOLUME
Visual Basic
Public Shared ReadOnly DERIVATION_CONCEPTUAL_VOLUME As String
Visual C++
public:
static initonly String^ DERIVATION_CONCEPTUAL_VOLUME

See Also

MCitems Structure
MCitems Members


DERIVATION_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DERIVATION_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DERIVATION_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DERIVATION_IMAGE
Visual Basic
Public Shared ReadOnly DERIVATION_IMAGE As String
Visual C++
public:
static initonly String^ DERIVATION_IMAGE

See Also

MCitems Structure
MCitems Members


DETECTOR_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DETECTOR_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DETECTOR_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETECTOR_INFO
Visual Basic
Public Shared ReadOnly DETECTOR_INFO As String
Visual C++
public:
static initonly String^ DETECTOR_INFO

See Also

MCitems Structure
MCitems Members


DETECTOR_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DETECTOR_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DETECTOR_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETECTOR_POSITION
Visual Basic
Public Shared ReadOnly DETECTOR_POSITION As String
Visual C++
public:
static initonly String^ DETECTOR_POSITION

See Also

MCitems Structure
MCitems Members


DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEVICE
Visual Basic
Public Shared ReadOnly DEVICE As String
Visual C++
public:
static initonly String^ DEVICE

See Also

MCitems Structure
MCitems Members


DEVICE_IDENTIFICATION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEVICE_IDENTIFICATION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEVICE_IDENTIFICATION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEVICE_IDENTIFICATION_MACRO
Visual Basic
Public Shared ReadOnly DEVICE_IDENTIFICATION_MACRO As String
Visual C++
public:
static initonly String^ DEVICE_IDENTIFICATION_MACRO

See Also

MCitems Structure
MCitems Members


DEVICE_MOTION_CONTROL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DEVICE_MOTION_CONTROL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DEVICE_MOTION_CONTROL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEVICE_MOTION_CONTROL
Visual Basic
Public Shared ReadOnly DEVICE_MOTION_CONTROL As String
Visual C++
public:
static initonly String^ DEVICE_MOTION_CONTROL

See Also

MCitems Structure
MCitems Members


DICOM_RETRIEVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DICOM_RETRIEVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DICOM_RETRIEVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DICOM_RETRIEVAL
Visual Basic
Public Shared ReadOnly DICOM_RETRIEVAL As String
Visual C++
public:
static initonly String^ DICOM_RETRIEVAL

See Also

MCitems Structure
MCitems Members


DICOM_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DICOM_STORAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DICOM_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DICOM_STORAGE
Visual Basic
Public Shared ReadOnly DICOM_STORAGE As String
Visual C++
public:
static initonly String^ DICOM_STORAGE

See Also

MCitems Structure
MCitems Members


DICOM_STORAGE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DICOM_STORAGE_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DICOM_STORAGE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DICOM_STORAGE_GET
Visual Basic
Public Shared ReadOnly DICOM_STORAGE_GET As String
Visual C++
public:
static initonly String^ DICOM_STORAGE_GET

See Also

MCitems Structure
MCitems Members


DIFFUSION_B_MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIFFUSION_B_MATRIX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIFFUSION_B_MATRIX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIFFUSION_B_MATRIX
Visual Basic
Public Shared ReadOnly DIFFUSION_B_MATRIX As String
Visual C++
public:
static initonly String^ DIFFUSION_B_MATRIX

See Also

MCitems Structure
MCitems Members


DIFFUSION_GRADIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIFFUSION_GRADIENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIFFUSION_GRADIENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIFFUSION_GRADIENT
Visual Basic
Public Shared ReadOnly DIFFUSION_GRADIENT As String
Visual C++
public:
static initonly String^ DIFFUSION_GRADIENT

See Also

MCitems Structure
MCitems Members


DIGITAL_FILTER_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIGITAL_FILTER_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIGITAL_FILTER_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIGITAL_FILTER_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly DIGITAL_FILTER_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ DIGITAL_FILTER_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


DIGITAL_SIGNATURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIGITAL_SIGNATURES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIGITAL_SIGNATURES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIGITAL_SIGNATURES
Visual Basic
Public Shared ReadOnly DIGITAL_SIGNATURES As String
Visual C++
public:
static initonly String^ DIGITAL_SIGNATURES

See Also

MCitems Structure
MCitems Members


DIMENSION_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIMENSION_INDEX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIMENSION_INDEX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIMENSION_INDEX
Visual Basic
Public Shared ReadOnly DIMENSION_INDEX As String
Visual C++
public:
static initonly String^ DIMENSION_INDEX

See Also

MCitems Structure
MCitems Members


DIMENSION_ORGANIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIMENSION_ORGANIZATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIMENSION_ORGANIZATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIMENSION_ORGANIZATION
Visual Basic
Public Shared ReadOnly DIMENSION_ORGANIZATION As String
Visual C++
public:
static initonly String^ DIMENSION_ORGANIZATION

See Also

MCitems Structure
MCitems Members


DIR_REC_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_ANNOTATION
Visual Basic
Public Shared ReadOnly DIR_REC_ANNOTATION As String
Visual C++
public:
static initonly String^ DIR_REC_ANNOTATION

See Also

MCitems Structure
MCitems Members


DIR_REC_ASSESSMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_ASSESSMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_ASSESSMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_ASSESSMENT
Visual Basic
Public Shared ReadOnly DIR_REC_ASSESSMENT As String
Visual C++
public:
static initonly String^ DIR_REC_ASSESSMENT

See Also

MCitems Structure
MCitems Members


DIR_REC_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_CURVE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_CURVE
Visual Basic
Public Shared ReadOnly DIR_REC_CURVE As String
Visual C++
public:
static initonly String^ DIR_REC_CURVE

See Also

MCitems Structure
MCitems Members


DIR_REC_ENCAP_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_ENCAP_DOC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_ENCAP_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_ENCAP_DOC
Visual Basic
Public Shared ReadOnly DIR_REC_ENCAP_DOC As String
Visual C++
public:
static initonly String^ DIR_REC_ENCAP_DOC

See Also

MCitems Structure
MCitems Members


DIR_REC_FIDUCIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_FIDUCIAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_FIDUCIAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_FIDUCIAL
Visual Basic
Public Shared ReadOnly DIR_REC_FIDUCIAL As String
Visual C++
public:
static initonly String^ DIR_REC_FIDUCIAL

See Also

MCitems Structure
MCitems Members


DIR_REC_FILM_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_FILM_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_FILM_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_FILM_BOX
Visual Basic
Public Shared ReadOnly DIR_REC_FILM_BOX As String
Visual C++
public:
static initonly String^ DIR_REC_FILM_BOX

See Also

MCitems Structure
MCitems Members


DIR_REC_FILM_SESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_FILM_SESSION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_FILM_SESSION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_FILM_SESSION
Visual Basic
Public Shared ReadOnly DIR_REC_FILM_SESSION As String
Visual C++
public:
static initonly String^ DIR_REC_FILM_SESSION

See Also

MCitems Structure
MCitems Members


DIR_REC_HANGING_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_HANGING_PROTOCOL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_HANGING_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_HANGING_PROTOCOL
Visual Basic
Public Shared ReadOnly DIR_REC_HANGING_PROTOCOL As String
Visual C++
public:
static initonly String^ DIR_REC_HANGING_PROTOCOL

See Also

MCitems Structure
MCitems Members


DIR_REC_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_IMAGE
Visual Basic
Public Shared ReadOnly DIR_REC_IMAGE As String
Visual C++
public:
static initonly String^ DIR_REC_IMAGE

See Also

MCitems Structure
MCitems Members


DIR_REC_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_IMAGE_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_IMAGE_BOX
Visual Basic
Public Shared ReadOnly DIR_REC_IMAGE_BOX As String
Visual C++
public:
static initonly String^ DIR_REC_IMAGE_BOX

See Also

MCitems Structure
MCitems Members


DIR_REC_IMPLANT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_IMPLANT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_IMPLANT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_IMPLANT
Visual Basic
Public Shared ReadOnly DIR_REC_IMPLANT As String
Visual C++
public:
static initonly String^ DIR_REC_IMPLANT

See Also

MCitems Structure
MCitems Members


DIR_REC_IMPLANT_ASSY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_IMPLANT_ASSY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_IMPLANT_ASSY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_IMPLANT_ASSY
Visual Basic
Public Shared ReadOnly DIR_REC_IMPLANT_ASSY As String
Visual C++
public:
static initonly String^ DIR_REC_IMPLANT_ASSY

See Also

MCitems Structure
MCitems Members


DIR_REC_IMPLANT_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_IMPLANT_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_IMPLANT_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_IMPLANT_GROUP
Visual Basic
Public Shared ReadOnly DIR_REC_IMPLANT_GROUP As String
Visual C++
public:
static initonly String^ DIR_REC_IMPLANT_GROUP

See Also

MCitems Structure
MCitems Members


DIR_REC_INTERPRETATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_INTERPRETATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_INTERPRETATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_INTERPRETATION
Visual Basic
Public Shared ReadOnly DIR_REC_INTERPRETATION As String
Visual C++
public:
static initonly String^ DIR_REC_INTERPRETATION

See Also

MCitems Structure
MCitems Members


DIR_REC_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_INVENTORY
Visual Basic
Public Shared ReadOnly DIR_REC_INVENTORY As String
Visual C++
public:
static initonly String^ DIR_REC_INVENTORY

See Also

MCitems Structure
MCitems Members


DIR_REC_KEY_OBJECT_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_KEY_OBJECT_DOC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_KEY_OBJECT_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_KEY_OBJECT_DOC
Visual Basic
Public Shared ReadOnly DIR_REC_KEY_OBJECT_DOC As String
Visual C++
public:
static initonly String^ DIR_REC_KEY_OBJECT_DOC

See Also

MCitems Structure
MCitems Members


DIR_REC_MEASUREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_MEASUREMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_MEASUREMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_MEASUREMENT
Visual Basic
Public Shared ReadOnly DIR_REC_MEASUREMENT As String
Visual C++
public:
static initonly String^ DIR_REC_MEASUREMENT

See Also

MCitems Structure
MCitems Members


DIR_REC_MODALITY_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_MODALITY_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_MODALITY_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_MODALITY_LUT
Visual Basic
Public Shared ReadOnly DIR_REC_MODALITY_LUT As String
Visual C++
public:
static initonly String^ DIR_REC_MODALITY_LUT

See Also

MCitems Structure
MCitems Members


DIR_REC_MRDR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_MRDR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_MRDR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_MRDR
Visual Basic
Public Shared ReadOnly DIR_REC_MRDR As String
Visual C++
public:
static initonly String^ DIR_REC_MRDR

See Also

MCitems Structure
MCitems Members


DIR_REC_OVERLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_OVERLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_OVERLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_OVERLAY
Visual Basic
Public Shared ReadOnly DIR_REC_OVERLAY As String
Visual C++
public:
static initonly String^ DIR_REC_OVERLAY

See Also

MCitems Structure
MCitems Members


DIR_REC_PALETTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PALETTE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PALETTE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PALETTE
Visual Basic
Public Shared ReadOnly DIR_REC_PALETTE As String
Visual C++
public:
static initonly String^ DIR_REC_PALETTE

See Also

MCitems Structure
MCitems Members


DIR_REC_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PATIENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PATIENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PATIENT
Visual Basic
Public Shared ReadOnly DIR_REC_PATIENT As String
Visual C++
public:
static initonly String^ DIR_REC_PATIENT

See Also

MCitems Structure
MCitems Members


DIR_REC_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PLAN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PLAN
Visual Basic
Public Shared ReadOnly DIR_REC_PLAN As String
Visual C++
public:
static initonly String^ DIR_REC_PLAN

See Also

MCitems Structure
MCitems Members


DIR_REC_PRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PRESENTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PRESENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PRESENTATION
Visual Basic
Public Shared ReadOnly DIR_REC_PRESENTATION As String
Visual C++
public:
static initonly String^ DIR_REC_PRESENTATION

See Also

MCitems Structure
MCitems Members


DIR_REC_PRINT_QUEUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PRINT_QUEUE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PRINT_QUEUE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PRINT_QUEUE
Visual Basic
Public Shared ReadOnly DIR_REC_PRINT_QUEUE As String
Visual C++
public:
static initonly String^ DIR_REC_PRINT_QUEUE

See Also

MCitems Structure
MCitems Members


DIR_REC_PRIVATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_PRIVATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_PRIVATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_PRIVATE
Visual Basic
Public Shared ReadOnly DIR_REC_PRIVATE As String
Visual C++
public:
static initonly String^ DIR_REC_PRIVATE

See Also

MCitems Structure
MCitems Members


DIR_REC_RADIOTHERAPY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RADIOTHERAPY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RADIOTHERAPY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RADIOTHERAPY
Visual Basic
Public Shared ReadOnly DIR_REC_RADIOTHERAPY As String
Visual C++
public:
static initonly String^ DIR_REC_RADIOTHERAPY

See Also

MCitems Structure
MCitems Members


DIR_REC_RAW_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RAW_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RAW_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RAW_DATA
Visual Basic
Public Shared ReadOnly DIR_REC_RAW_DATA As String
Visual C++
public:
static initonly String^ DIR_REC_RAW_DATA

See Also

MCitems Structure
MCitems Members


DIR_REC_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_REGISTRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_REGISTRATION
Visual Basic
Public Shared ReadOnly DIR_REC_REGISTRATION As String
Visual C++
public:
static initonly String^ DIR_REC_REGISTRATION

See Also

MCitems Structure
MCitems Members


DIR_REC_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RESULTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RESULTS
Visual Basic
Public Shared ReadOnly DIR_REC_RESULTS As String
Visual C++
public:
static initonly String^ DIR_REC_RESULTS

See Also

MCitems Structure
MCitems Members


DIR_REC_RT_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RT_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RT_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RT_DOSE
Visual Basic
Public Shared ReadOnly DIR_REC_RT_DOSE As String
Visual C++
public:
static initonly String^ DIR_REC_RT_DOSE

See Also

MCitems Structure
MCitems Members


DIR_REC_RT_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RT_PLAN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RT_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RT_PLAN
Visual Basic
Public Shared ReadOnly DIR_REC_RT_PLAN As String
Visual C++
public:
static initonly String^ DIR_REC_RT_PLAN

See Also

MCitems Structure
MCitems Members


DIR_REC_RT_STRUCTURE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RT_STRUCTURE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RT_STRUCTURE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RT_STRUCTURE_SET
Visual Basic
Public Shared ReadOnly DIR_REC_RT_STRUCTURE_SET As String
Visual C++
public:
static initonly String^ DIR_REC_RT_STRUCTURE_SET

See Also

MCitems Structure
MCitems Members


DIR_REC_RT_TREAT_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_RT_TREAT_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_RT_TREAT_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_RT_TREAT_RECORD
Visual Basic
Public Shared ReadOnly DIR_REC_RT_TREAT_RECORD As String
Visual C++
public:
static initonly String^ DIR_REC_RT_TREAT_RECORD

See Also

MCitems Structure
MCitems Members


DIR_REC_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_SERIES
Visual Basic
Public Shared ReadOnly DIR_REC_SERIES As String
Visual C++
public:
static initonly String^ DIR_REC_SERIES

See Also

MCitems Structure
MCitems Members


DIR_REC_SPECTROSCOPY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_SPECTROSCOPY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_SPECTROSCOPY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_SPECTROSCOPY
Visual Basic
Public Shared ReadOnly DIR_REC_SPECTROSCOPY As String
Visual C++
public:
static initonly String^ DIR_REC_SPECTROSCOPY

See Also

MCitems Structure
MCitems Members


DIR_REC_SR_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_SR_DOCUMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_SR_DOCUMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_SR_DOCUMENT
Visual Basic
Public Shared ReadOnly DIR_REC_SR_DOCUMENT As String
Visual C++
public:
static initonly String^ DIR_REC_SR_DOCUMENT

See Also

MCitems Structure
MCitems Members


DIR_REC_STEREOMETRIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_STEREOMETRIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_STEREOMETRIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_STEREOMETRIC
Visual Basic
Public Shared ReadOnly DIR_REC_STEREOMETRIC As String
Visual C++
public:
static initonly String^ DIR_REC_STEREOMETRIC

See Also

MCitems Structure
MCitems Members


DIR_REC_STORED_PRINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_STORED_PRINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_STORED_PRINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_STORED_PRINT
Visual Basic
Public Shared ReadOnly DIR_REC_STORED_PRINT As String
Visual C++
public:
static initonly String^ DIR_REC_STORED_PRINT

See Also

MCitems Structure
MCitems Members


DIR_REC_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_STUDY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_STUDY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_STUDY
Visual Basic
Public Shared ReadOnly DIR_REC_STUDY As String
Visual C++
public:
static initonly String^ DIR_REC_STUDY

See Also

MCitems Structure
MCitems Members


DIR_REC_STUDY_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_STUDY_COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_STUDY_COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_STUDY_COMPONENT
Visual Basic
Public Shared ReadOnly DIR_REC_STUDY_COMPONENT As String
Visual C++
public:
static initonly String^ DIR_REC_STUDY_COMPONENT

See Also

MCitems Structure
MCitems Members


DIR_REC_SURFACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_SURFACE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_SURFACE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_SURFACE
Visual Basic
Public Shared ReadOnly DIR_REC_SURFACE As String
Visual C++
public:
static initonly String^ DIR_REC_SURFACE

See Also

MCitems Structure
MCitems Members


DIR_REC_SURFACE_SCAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_SURFACE_SCAN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_SURFACE_SCAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_SURFACE_SCAN
Visual Basic
Public Shared ReadOnly DIR_REC_SURFACE_SCAN As String
Visual C++
public:
static initonly String^ DIR_REC_SURFACE_SCAN

See Also

MCitems Structure
MCitems Members


DIR_REC_TOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_TOPIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_TOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_TOPIC
Visual Basic
Public Shared ReadOnly DIR_REC_TOPIC As String
Visual C++
public:
static initonly String^ DIR_REC_TOPIC

See Also

MCitems Structure
MCitems Members


DIR_REC_TRACT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_TRACT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_TRACT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_TRACT
Visual Basic
Public Shared ReadOnly DIR_REC_TRACT As String
Visual C++
public:
static initonly String^ DIR_REC_TRACT

See Also

MCitems Structure
MCitems Members


DIR_REC_VALUE_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_VALUE_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_VALUE_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_VALUE_MAP
Visual Basic
Public Shared ReadOnly DIR_REC_VALUE_MAP As String
Visual C++
public:
static initonly String^ DIR_REC_VALUE_MAP

See Also

MCitems Structure
MCitems Members


DIR_REC_VISIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_VISIT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_VISIT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_VISIT
Visual Basic
Public Shared ReadOnly DIR_REC_VISIT As String
Visual C++
public:
static initonly String^ DIR_REC_VISIT

See Also

MCitems Structure
MCitems Members


DIR_REC_VOI_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_VOI_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_VOI_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_VOI_LUT
Visual Basic
Public Shared ReadOnly DIR_REC_VOI_LUT As String
Visual C++
public:
static initonly String^ DIR_REC_VOI_LUT

See Also

MCitems Structure
MCitems Members


DIR_REC_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIR_REC_WAVEFORM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIR_REC_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIR_REC_WAVEFORM
Visual Basic
Public Shared ReadOnly DIR_REC_WAVEFORM As String
Visual C++
public:
static initonly String^ DIR_REC_WAVEFORM

See Also

MCitems Structure
MCitems Members


DIRECT_SEGMENT_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DIRECT_SEGMENT_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DIRECT_SEGMENT_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DIRECT_SEGMENT_REFERENCE
Visual Basic
Public Shared ReadOnly DIRECT_SEGMENT_REFERENCE As String
Visual C++
public:
static initonly String^ DIRECT_SEGMENT_REFERENCE

See Also

MCitems Structure
MCitems Members


DISPLAY_CALIBRATION_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_CALIBRATION_RESULT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_CALIBRATION_RESULT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_CALIBRATION_RESULT
Visual Basic
Public Shared ReadOnly DISPLAY_CALIBRATION_RESULT As String
Visual C++
public:
static initonly String^ DISPLAY_CALIBRATION_RESULT

See Also

MCitems Structure
MCitems Members


DISPLAY_CALIBRATION_RESULT_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_CALIBRATION_RESULT_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_CALIBRATION_RESULT_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_CALIBRATION_RESULT_SCP
Visual Basic
Public Shared ReadOnly DISPLAY_CALIBRATION_RESULT_SCP As String
Visual C++
public:
static initonly String^ DISPLAY_CALIBRATION_RESULT_SCP

See Also

MCitems Structure
MCitems Members


DISPLAY_CALIBRATION_RESULT_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_CALIBRATION_RESULT_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_CALIBRATION_RESULT_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_CALIBRATION_RESULT_SCU
Visual Basic
Public Shared ReadOnly DISPLAY_CALIBRATION_RESULT_SCU As String
Visual C++
public:
static initonly String^ DISPLAY_CALIBRATION_RESULT_SCU

See Also

MCitems Structure
MCitems Members


DISPLAY_SETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SETS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SETS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SETS
Visual Basic
Public Shared ReadOnly DISPLAY_SETS As String
Visual C++
public:
static initonly String^ DISPLAY_SETS

See Also

MCitems Structure
MCitems Members


DISPLAY_SHUTTER_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SHUTTER_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SHUTTER_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SHUTTER_MACRO
Visual Basic
Public Shared ReadOnly DISPLAY_SHUTTER_MACRO As String
Visual C++
public:
static initonly String^ DISPLAY_SHUTTER_MACRO

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_CONFIGURATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_CONFIGURATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_CONFIGURATION
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_CONFIGURATION As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_CONFIGURATION

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_CONFIGURATION_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_CONFIGURATION_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_CONFIGURATION_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_CONFIGURATION_SCP
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_CONFIGURATION_SCP As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_CONFIGURATION_SCP

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_QA_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_QA_RESULTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_QA_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_QA_RESULTS
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_QA_RESULTS As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_QA_RESULTS

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_QA_RESULTS_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_QA_RESULTS_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_QA_RESULTS_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_QA_RESULTS_SCP
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_QA_RESULTS_SCP As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_QA_RESULTS_SCP

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_QA_RESULTS_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_QA_RESULTS_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_QA_RESULTS_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_QA_RESULTS_SCU
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_QA_RESULTS_SCU As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_QA_RESULTS_SCU

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_SCP
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_SCP As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_SCP

See Also

MCitems Structure
MCitems Members


DISPLAY_SUBSYSTEM_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAY_SUBSYSTEM_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAY_SUBSYSTEM_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SUBSYSTEM_SCU
Visual Basic
Public Shared ReadOnly DISPLAY_SUBSYSTEM_SCU As String
Visual C++
public:
static initonly String^ DISPLAY_SUBSYSTEM_SCU

See Also

MCitems Structure
MCitems Members


DISPLAYED_AREA_SELECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DISPLAYED_AREA_SELECTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DISPLAYED_AREA_SELECTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAYED_AREA_SELECTION
Visual Basic
Public Shared ReadOnly DISPLAYED_AREA_SELECTION As String
Visual C++
public:
static initonly String^ DISPLAYED_AREA_SELECTION

See Also

MCitems Structure
MCitems Members


DOSE_CALIBRATION_CONDITIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DOSE_CALIBRATION_CONDITIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DOSE_CALIBRATION_CONDITIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DOSE_CALIBRATION_CONDITIONS
Visual Basic
Public Shared ReadOnly DOSE_CALIBRATION_CONDITIONS As String
Visual C++
public:
static initonly String^ DOSE_CALIBRATION_CONDITIONS

See Also

MCitems Structure
MCitems Members


DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


DOSE_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DOSE_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DOSE_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DOSE_VALUES
Visual Basic
Public Shared ReadOnly DOSE_VALUES As String
Visual C++
public:
static initonly String^ DOSE_VALUES

See Also

MCitems Structure
MCitems Members


DOSIMETRIC_OBJECTIVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DOSIMETRIC_OBJECTIVE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DOSIMETRIC_OBJECTIVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DOSIMETRIC_OBJECTIVE
Visual Basic
Public Shared ReadOnly DOSIMETRIC_OBJECTIVE As String
Visual C++
public:
static initonly String^ DOSIMETRIC_OBJECTIVE

See Also

MCitems Structure
MCitems Members


DOSIMETRIC_OBJECTIVE_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DOSIMETRIC_OBJECTIVE_PARAMETER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DOSIMETRIC_OBJECTIVE_PARAMETER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DOSIMETRIC_OBJECTIVE_PARAMETER
Visual Basic
Public Shared ReadOnly DOSIMETRIC_OBJECTIVE_PARAMETER As String
Visual C++
public:
static initonly String^ DOSIMETRIC_OBJECTIVE_PARAMETER

See Also

MCitems Structure
MCitems Members


DVH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DVH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DVH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DVH
Visual Basic
Public Shared ReadOnly DVH As String
Visual C++
public:
static initonly String^ DVH

See Also

MCitems Structure
MCitems Members


DVH_REF_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DVH_REF_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DVH_REF_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DVH_REF_ROI
Visual Basic
Public Shared ReadOnly DVH_REF_ROI As String
Visual C++
public:
static initonly String^ DVH_REF_ROI

See Also

MCitems Structure
MCitems Members


DX_PATIENT_ORIENTATION_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..DX_PATIENT_ORIENTATION_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.DX_PATIENT_ORIENTATION_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DX_PATIENT_ORIENTATION_CODE
Visual Basic
Public Shared ReadOnly DX_PATIENT_ORIENTATION_CODE As String
Visual C++
public:
static initonly String^ DX_PATIENT_ORIENTATION_CODE

See Also

MCitems Structure
MCitems Members


EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE
Visual Basic
Public Shared ReadOnly EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE As String
Visual C++
public:
static initonly String^ EFFECTIVE_DOSE_CALCULATION_METHOD_CATEGORY_CODE

See Also

MCitems Structure
MCitems Members


ELECTRON_APPLICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ELECTRON_APPLICATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ELECTRON_APPLICATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ELECTRON_APPLICATOR
Visual Basic
Public Shared ReadOnly ELECTRON_APPLICATOR As String
Visual C++
public:
static initonly String^ ELECTRON_APPLICATOR

See Also

MCitems Structure
MCitems Members


ENCRYPTED_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENCRYPTED_ATTRIBUTES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENCRYPTED_ATTRIBUTES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENCRYPTED_ATTRIBUTES
Visual Basic
Public Shared ReadOnly ENCRYPTED_ATTRIBUTES As String
Visual C++
public:
static initonly String^ ENCRYPTED_ATTRIBUTES

See Also

MCitems Structure
MCitems Members


ENERGY_WINDOW_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENERGY_WINDOW_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENERGY_WINDOW_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENERGY_WINDOW_INFO
Visual Basic
Public Shared ReadOnly ENERGY_WINDOW_INFO As String
Visual C++
public:
static initonly String^ ENERGY_WINDOW_INFO

See Also

MCitems Structure
MCitems Members


ENERGY_WINDOW_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENERGY_WINDOW_RANGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENERGY_WINDOW_RANGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENERGY_WINDOW_RANGE
Visual Basic
Public Shared ReadOnly ENERGY_WINDOW_RANGE As String
Visual C++
public:
static initonly String^ ENERGY_WINDOW_RANGE

See Also

MCitems Structure
MCitems Members


ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS
Visual Basic
Public Shared ReadOnly ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS As String
Visual C++
public:
static initonly String^ ENHANCED_CODE_VALUE_KEYS_MACRO_WITH_OPT_KEYS

See Also

MCitems Structure
MCitems Members


ENHANCED_CONTRAST_BOLUS_AGENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENHANCED_CONTRAST_BOLUS_AGENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENHANCED_CONTRAST_BOLUS_AGENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_CONTRAST_BOLUS_AGENT
Visual Basic
Public Shared ReadOnly ENHANCED_CONTRAST_BOLUS_AGENT As String
Visual C++
public:
static initonly String^ ENHANCED_CONTRAST_BOLUS_AGENT

See Also

MCitems Structure
MCitems Members


ENHANCED_PALETTE_COLOR_TABLE_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ENHANCED_PALETTE_COLOR_TABLE_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ENHANCED_PALETTE_COLOR_TABLE_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_PALETTE_COLOR_TABLE_SQ
Visual Basic
Public Shared ReadOnly ENHANCED_PALETTE_COLOR_TABLE_SQ As String
Visual C++
public:
static initonly String^ ENHANCED_PALETTE_COLOR_TABLE_SQ

See Also

MCitems Structure
MCitems Members


EQUIPMENT_ADMINISTRATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIPMENT_ADMINISTRATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIPMENT_ADMINISTRATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIPMENT_ADMINISTRATOR
Visual Basic
Public Shared ReadOnly EQUIPMENT_ADMINISTRATOR As String
Visual C++
public:
static initonly String^ EQUIPMENT_ADMINISTRATOR

See Also

MCitems Structure
MCitems Members


EQUIPMENT_ADMINISTRATOR_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIPMENT_ADMINISTRATOR_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIPMENT_ADMINISTRATOR_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIPMENT_ADMINISTRATOR_SCP
Visual Basic
Public Shared ReadOnly EQUIPMENT_ADMINISTRATOR_SCP As String
Visual C++
public:
static initonly String^ EQUIPMENT_ADMINISTRATOR_SCP

See Also

MCitems Structure
MCitems Members


EQUIPMENT_ADMINISTRATOR_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIPMENT_ADMINISTRATOR_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIPMENT_ADMINISTRATOR_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIPMENT_ADMINISTRATOR_SCU
Visual Basic
Public Shared ReadOnly EQUIPMENT_ADMINISTRATOR_SCU As String
Visual C++
public:
static initonly String^ EQUIPMENT_ADMINISTRATOR_SCU

See Also

MCitems Structure
MCitems Members


EQUIPMENT_REFERENCE_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIPMENT_REFERENCE_POINT_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIPMENT_REFERENCE_POINT_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIPMENT_REFERENCE_POINT_COORDINATES
Visual Basic
Public Shared ReadOnly EQUIPMENT_REFERENCE_POINT_COORDINATES As String
Visual C++
public:
static initonly String^ EQUIPMENT_REFERENCE_POINT_COORDINATES

See Also

MCitems Structure
MCitems Members


EQUIVALENT_CDA_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIVALENT_CDA_DOC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIVALENT_CDA_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIVALENT_CDA_DOC
Visual Basic
Public Shared ReadOnly EQUIVALENT_CDA_DOC As String
Visual C++
public:
static initonly String^ EQUIVALENT_CDA_DOC

See Also

MCitems Structure
MCitems Members


EQUIVALENT_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIVALENT_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIVALENT_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIVALENT_CODE
Visual Basic
Public Shared ReadOnly EQUIVALENT_CODE As String
Visual C++
public:
static initonly String^ EQUIVALENT_CODE

See Also

MCitems Structure
MCitems Members


EQUIVALENT_CONCEPTUAL_VOLUMES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EQUIVALENT_CONCEPTUAL_VOLUMES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EQUIVALENT_CONCEPTUAL_VOLUMES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EQUIVALENT_CONCEPTUAL_VOLUMES
Visual Basic
Public Shared ReadOnly EQUIVALENT_CONCEPTUAL_VOLUMES As String
Visual C++
public:
static initonly String^ EQUIVALENT_CONCEPTUAL_VOLUMES

See Also

MCitems Structure
MCitems Members


EVENT_TIMER_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EVENT_TIMER_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EVENT_TIMER_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EVENT_TIMER_SQ
Visual Basic
Public Shared ReadOnly EVENT_TIMER_SQ As String
Visual C++
public:
static initonly String^ EVENT_TIMER_SQ

See Also

MCitems Structure
MCitems Members


EXCITATION_WAVELENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXCITATION_WAVELENGTH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXCITATION_WAVELENGTH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXCITATION_WAVELENGTH
Visual Basic
Public Shared ReadOnly EXCITATION_WAVELENGTH As String
Visual C++
public:
static initonly String^ EXCITATION_WAVELENGTH

See Also

MCitems Structure
MCitems Members


EXCLUDED_INTERVALS_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXCLUDED_INTERVALS_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXCLUDED_INTERVALS_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXCLUDED_INTERVALS_SQ
Visual Basic
Public Shared ReadOnly EXCLUDED_INTERVALS_SQ As String
Visual C++
public:
static initonly String^ EXCLUDED_INTERVALS_SQ

See Also

MCitems Structure
MCitems Members


EXPECTED_IN_VIVO_MEASUREMENT_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXPECTED_IN_VIVO_MEASUREMENT_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXPECTED_IN_VIVO_MEASUREMENT_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXPECTED_IN_VIVO_MEASUREMENT_VALUES
Visual Basic
Public Shared ReadOnly EXPECTED_IN_VIVO_MEASUREMENT_VALUES As String
Visual C++
public:
static initonly String^ EXPECTED_IN_VIVO_MEASUREMENT_VALUES

See Also

MCitems Structure
MCitems Members


EXPOSURE_CONTROL_SENSING_REGIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXPOSURE_CONTROL_SENSING_REGIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXPOSURE_CONTROL_SENSING_REGIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXPOSURE_CONTROL_SENSING_REGIONS
Visual Basic
Public Shared ReadOnly EXPOSURE_CONTROL_SENSING_REGIONS As String
Visual C++
public:
static initonly String^ EXPOSURE_CONTROL_SENSING_REGIONS

See Also

MCitems Structure
MCitems Members


EXPOSURE_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXPOSURE_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXPOSURE_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXPOSURE_DOSE
Visual Basic
Public Shared ReadOnly EXPOSURE_DOSE As String
Visual C++
public:
static initonly String^ EXPOSURE_DOSE

See Also

MCitems Structure
MCitems Members


EXPOSURE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXPOSURE_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXPOSURE_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXPOSURE_SEQUENCE
Visual Basic
Public Shared ReadOnly EXPOSURE_SEQUENCE As String
Visual C++
public:
static initonly String^ EXPOSURE_SEQUENCE

See Also

MCitems Structure
MCitems Members


EXTENDED_SELECTOR_ATTRIBUTE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXTENDED_SELECTOR_ATTRIBUTE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXTENDED_SELECTOR_ATTRIBUTE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXTENDED_SELECTOR_ATTRIBUTE_MACRO
Visual Basic
Public Shared ReadOnly EXTENDED_SELECTOR_ATTRIBUTE_MACRO As String
Visual C++
public:
static initonly String^ EXTENDED_SELECTOR_ATTRIBUTE_MACRO

See Also

MCitems Structure
MCitems Members


EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION
Visual Basic
Public Shared ReadOnly EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION As String
Visual C++
public:
static initonly String^ EXTERNALLY_SOURCED_DATA_SET_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


FAILED_ATTRIBUTES_NGET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FAILED_ATTRIBUTES_NGET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FAILED_ATTRIBUTES_NGET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FAILED_ATTRIBUTES_NGET
Visual Basic
Public Shared ReadOnly FAILED_ATTRIBUTES_NGET As String
Visual C++
public:
static initonly String^ FAILED_ATTRIBUTES_NGET

See Also

MCitems Structure
MCitems Members


FAILED_ATTRIBUTES_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FAILED_ATTRIBUTES_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FAILED_ATTRIBUTES_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FAILED_ATTRIBUTES_SQ
Visual Basic
Public Shared ReadOnly FAILED_ATTRIBUTES_SQ As String
Visual C++
public:
static initonly String^ FAILED_ATTRIBUTES_SQ

See Also

MCitems Structure
MCitems Members


FAILED_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FAILED_SOP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FAILED_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FAILED_SOP
Visual Basic
Public Shared ReadOnly FAILED_SOP As String
Visual C++
public:
static initonly String^ FAILED_SOP

See Also

MCitems Structure
MCitems Members


FAILED_SOP_MEDIA_CREATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FAILED_SOP_MEDIA_CREATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FAILED_SOP_MEDIA_CREATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FAILED_SOP_MEDIA_CREATION
Visual Basic
Public Shared ReadOnly FAILED_SOP_MEDIA_CREATION As String
Visual C++
public:
static initonly String^ FAILED_SOP_MEDIA_CREATION

See Also

MCitems Structure
MCitems Members


FIDUCIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIDUCIAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIDUCIAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIDUCIAL
Visual Basic
Public Shared ReadOnly FIDUCIAL As String
Visual C++
public:
static initonly String^ FIDUCIAL

See Also

MCitems Structure
MCitems Members


FIDUCIAL_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIDUCIAL_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIDUCIAL_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIDUCIAL_SET
Visual Basic
Public Shared ReadOnly FIDUCIAL_SET As String
Visual C++
public:
static initonly String^ FIDUCIAL_SET

See Also

MCitems Structure
MCitems Members


FIELD_OF_VIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIELD_OF_VIEW Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIELD_OF_VIEW"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIELD_OF_VIEW
Visual Basic
Public Shared ReadOnly FIELD_OF_VIEW As String
Visual C++
public:
static initonly String^ FIELD_OF_VIEW

See Also

MCitems Structure
MCitems Members


FILE_ACCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILE_ACCESS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILE_ACCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILE_ACCESS
Visual Basic
Public Shared ReadOnly FILE_ACCESS As String
Visual C++
public:
static initonly String^ FILE_ACCESS

See Also

MCitems Structure
MCitems Members


FILE_ACCESS_IN_INVENTORY_FIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILE_ACCESS_IN_INVENTORY_FIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILE_ACCESS_IN_INVENTORY_FIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILE_ACCESS_IN_INVENTORY_FIND_RSP
Visual Basic
Public Shared ReadOnly FILE_ACCESS_IN_INVENTORY_FIND_RSP As String
Visual C++
public:
static initonly String^ FILE_ACCESS_IN_INVENTORY_FIND_RSP

See Also

MCitems Structure
MCitems Members


FILE_ACCESS_IN_REPOSITORY_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILE_ACCESS_IN_REPOSITORY_QUERY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILE_ACCESS_IN_REPOSITORY_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILE_ACCESS_IN_REPOSITORY_QUERY
Visual Basic
Public Shared ReadOnly FILE_ACCESS_IN_REPOSITORY_QUERY As String
Visual C++
public:
static initonly String^ FILE_ACCESS_IN_REPOSITORY_QUERY

See Also

MCitems Structure
MCitems Members


FILE_SET_ACCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILE_SET_ACCESS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILE_SET_ACCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILE_SET_ACCESS
Visual Basic
Public Shared ReadOnly FILE_SET_ACCESS As String
Visual C++
public:
static initonly String^ FILE_SET_ACCESS

See Also

MCitems Structure
MCitems Members


FILE_SET_ACCESS_IN_REPOSITORY_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILE_SET_ACCESS_IN_REPOSITORY_QUERY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILE_SET_ACCESS_IN_REPOSITORY_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILE_SET_ACCESS_IN_REPOSITORY_QUERY
Visual Basic
Public Shared ReadOnly FILE_SET_ACCESS_IN_REPOSITORY_QUERY As String
Visual C++
public:
static initonly String^ FILE_SET_ACCESS_IN_REPOSITORY_QUERY

See Also

MCitems Structure
MCitems Members


FILL_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILL_STYLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILL_STYLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILL_STYLE
Visual Basic
Public Shared ReadOnly FILL_STYLE As String
Visual C++
public:
static initonly String^ FILL_STYLE

See Also

MCitems Structure
MCitems Members


FILM_BOX_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILM_BOX_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILM_BOX_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILM_BOX_CONTENT
Visual Basic
Public Shared ReadOnly FILM_BOX_CONTENT As String
Visual C++
public:
static initonly String^ FILM_BOX_CONTENT

See Also

MCitems Structure
MCitems Members


FILM_CONSUMPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILM_CONSUMPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILM_CONSUMPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILM_CONSUMPTION
Visual Basic
Public Shared ReadOnly FILM_CONSUMPTION As String
Visual C++
public:
static initonly String^ FILM_CONSUMPTION

See Also

MCitems Structure
MCitems Members


FILTER_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FILTER_OPERATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FILTER_OPERATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FILTER_OPERATIONS
Visual Basic
Public Shared ReadOnly FILTER_OPERATIONS As String
Visual C++
public:
static initonly String^ FILTER_OPERATIONS

See Also

MCitems Structure
MCitems Members


FIXATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIXATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIXATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIXATION
Visual Basic
Public Shared ReadOnly FIXATION As String
Visual C++
public:
static initonly String^ FIXATION

See Also

MCitems Structure
MCitems Members


FIXATION_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIXATION_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIXATION_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIXATION_DEVICE
Visual Basic
Public Shared ReadOnly FIXATION_DEVICE As String
Visual C++
public:
static initonly String^ FIXATION_DEVICE

See Also

MCitems Structure
MCitems Members


FIXATION_DEVICE_IN_GEN_MACH_VERI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FIXATION_DEVICE_IN_GEN_MACH_VERI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FIXATION_DEVICE_IN_GEN_MACH_VERI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FIXATION_DEVICE_IN_GEN_MACH_VERI
Visual Basic
Public Shared ReadOnly FIXATION_DEVICE_IN_GEN_MACH_VERI As String
Visual C++
public:
static initonly String^ FIXATION_DEVICE_IN_GEN_MACH_VERI

See Also

MCitems Structure
MCitems Members


FLAT_CORNEAL_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FLAT_CORNEAL_AXIS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FLAT_CORNEAL_AXIS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FLAT_CORNEAL_AXIS
Visual Basic
Public Shared ReadOnly FLAT_CORNEAL_AXIS As String
Visual C++
public:
static initonly String^ FLAT_CORNEAL_AXIS

See Also

MCitems Structure
MCitems Members


FLOW_IDENTIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FLOW_IDENTIFIER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FLOW_IDENTIFIER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FLOW_IDENTIFIER
Visual Basic
Public Shared ReadOnly FLOW_IDENTIFIER As String
Visual C++
public:
static initonly String^ FLOW_IDENTIFIER

See Also

MCitems Structure
MCitems Members


FLUENCE_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FLUENCE_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FLUENCE_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FLUENCE_MAP
Visual Basic
Public Shared ReadOnly FLUENCE_MAP As String
Visual C++
public:
static initonly String^ FLUENCE_MAP

See Also

MCitems Structure
MCitems Members


FRACTION_BASED_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRACTION_BASED_RELATIONSHIP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRACTION_BASED_RELATIONSHIP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRACTION_BASED_RELATIONSHIP
Visual Basic
Public Shared ReadOnly FRACTION_BASED_RELATIONSHIP As String
Visual C++
public:
static initonly String^ FRACTION_BASED_RELATIONSHIP

See Also

MCitems Structure
MCitems Members


FRACTION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRACTION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRACTION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRACTION_GROUP
Visual Basic
Public Shared ReadOnly FRACTION_GROUP As String
Visual C++
public:
static initonly String^ FRACTION_GROUP

See Also

MCitems Structure
MCitems Members


FRACTION_GROUP_SUMMARY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRACTION_GROUP_SUMMARY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRACTION_GROUP_SUMMARY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRACTION_GROUP_SUMMARY
Visual Basic
Public Shared ReadOnly FRACTION_GROUP_SUMMARY As String
Visual C++
public:
static initonly String^ FRACTION_GROUP_SUMMARY

See Also

MCitems Structure
MCitems Members


FRACTION_PATTERN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRACTION_PATTERN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRACTION_PATTERN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRACTION_PATTERN
Visual Basic
Public Shared ReadOnly FRACTION_PATTERN As String
Visual C++
public:
static initonly String^ FRACTION_PATTERN

See Also

MCitems Structure
MCitems Members


FRACTION_STATUS_SUMMARY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRACTION_STATUS_SUMMARY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRACTION_STATUS_SUMMARY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRACTION_STATUS_SUMMARY
Visual Basic
Public Shared ReadOnly FRACTION_STATUS_SUMMARY As String
Visual C++
public:
static initonly String^ FRACTION_STATUS_SUMMARY

See Also

MCitems Structure
MCitems Members


FRAME_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_ACQUISITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_ACQUISITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_ACQUISITION
Visual Basic
Public Shared ReadOnly FRAME_ACQUISITION As String
Visual C++
public:
static initonly String^ FRAME_ACQUISITION

See Also

MCitems Structure
MCitems Members


FRAME_ANATOMY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_ANATOMY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_ANATOMY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_ANATOMY
Visual Basic
Public Shared ReadOnly FRAME_ANATOMY As String
Visual C++
public:
static initonly String^ FRAME_ANATOMY

See Also

MCitems Structure
MCitems Members


FRAME_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_CONTENT
Visual Basic
Public Shared ReadOnly FRAME_CONTENT As String
Visual C++
public:
static initonly String^ FRAME_CONTENT

See Also

MCitems Structure
MCitems Members


FRAME_DETECTOR_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_DETECTOR_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_DETECTOR_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_DETECTOR_PARAMETERS
Visual Basic
Public Shared ReadOnly FRAME_DETECTOR_PARAMETERS As String
Visual C++
public:
static initonly String^ FRAME_DETECTOR_PARAMETERS

See Also

MCitems Structure
MCitems Members


FRAME_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_DISPLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_DISPLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_DISPLAY
Visual Basic
Public Shared ReadOnly FRAME_DISPLAY As String
Visual C++
public:
static initonly String^ FRAME_DISPLAY

See Also

MCitems Structure
MCitems Members


FRAME_DISPLAY_SHUTTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_DISPLAY_SHUTTER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_DISPLAY_SHUTTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_DISPLAY_SHUTTER
Visual Basic
Public Shared ReadOnly FRAME_DISPLAY_SHUTTER As String
Visual C++
public:
static initonly String^ FRAME_DISPLAY_SHUTTER

See Also

MCitems Structure
MCitems Members


FRAME_EXTRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_EXTRACTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_EXTRACTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_EXTRACTION
Visual Basic
Public Shared ReadOnly FRAME_EXTRACTION As String
Visual C++
public:
static initonly String^ FRAME_EXTRACTION

See Also

MCitems Structure
MCitems Members


FRAME_PIXEL_DATA_PROPERTIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_PIXEL_DATA_PROPERTIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_PIXEL_DATA_PROPERTIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_PIXEL_DATA_PROPERTIES
Visual Basic
Public Shared ReadOnly FRAME_PIXEL_DATA_PROPERTIES As String
Visual C++
public:
static initonly String^ FRAME_PIXEL_DATA_PROPERTIES

See Also

MCitems Structure
MCitems Members


FRAME_PIXEL_INTENSITY_REL_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_PIXEL_INTENSITY_REL_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_PIXEL_INTENSITY_REL_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_PIXEL_INTENSITY_REL_LUT
Visual Basic
Public Shared ReadOnly FRAME_PIXEL_INTENSITY_REL_LUT As String
Visual C++
public:
static initonly String^ FRAME_PIXEL_INTENSITY_REL_LUT

See Also

MCitems Structure
MCitems Members


FRAME_PIXEL_SHIFT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_PIXEL_SHIFT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_PIXEL_SHIFT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_PIXEL_SHIFT
Visual Basic
Public Shared ReadOnly FRAME_PIXEL_SHIFT As String
Visual C++
public:
static initonly String^ FRAME_PIXEL_SHIFT

See Also

MCitems Structure
MCitems Members


FRAME_USEFULNESS_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_USEFULNESS_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_USEFULNESS_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_USEFULNESS_GROUP
Visual Basic
Public Shared ReadOnly FRAME_USEFULNESS_GROUP As String
Visual C++
public:
static initonly String^ FRAME_USEFULNESS_GROUP

See Also

MCitems Structure
MCitems Members


FRAME_VOI_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_VOI_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_VOI_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_VOI_LUT
Visual Basic
Public Shared ReadOnly FRAME_VOI_LUT As String
Visual C++
public:
static initonly String^ FRAME_VOI_LUT

See Also

MCitems Structure
MCitems Members


FRAME_VOI_LUT_WITH_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FRAME_VOI_LUT_WITH_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FRAME_VOI_LUT_WITH_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FRAME_VOI_LUT_WITH_LUT
Visual Basic
Public Shared ReadOnly FRAME_VOI_LUT_WITH_LUT As String
Visual C++
public:
static initonly String^ FRAME_VOI_LUT_WITH_LUT

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_BREAST_PROJ_XRAY_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_BREAST_PROJ_XRAY_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_BREAST_PROJ_XRAY_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_BREAST_PROJ_XRAY_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_BREAST_PROJ_XRAY_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_BREAST_PROJ_XRAY_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_BREAST_PROJ_XRAY_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_BREAST_PROJ_XRAY_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_BREAST_PROJ_XRAY_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_BREAST_PROJ_XRAY_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_BREAST_PROJ_XRAY_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_BREAST_PROJ_XRAY_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_BREAST_TOMO_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_BREAST_TOMO_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_BREAST_TOMO_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_BREAST_TOMO_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_BREAST_TOMO_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_BREAST_TOMO_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_BREAST_TOMO_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_BREAST_TOMO_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_BREAST_TOMO_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_BREAST_TOMO_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_BREAST_TOMO_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_BREAST_TOMO_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_CT_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_CT_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_CT_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_CT_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_CT_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_CT_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_CT_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_CT_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_CT_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_CT_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_CT_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_CT_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_MR_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_MR_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_MR_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_MR_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_MR_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_MR_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_MR_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_MR_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_MR_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_MR_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_MR_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_MR_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_PET_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_PET_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_PET_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_PET_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_PET_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_PET_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_PET_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_PET_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_PET_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_PET_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_PET_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_PET_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_RT_IMAGE_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_RT_IMAGE_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_US_VOL_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_US_VOL_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_US_VOL_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_US_VOL_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_US_VOL_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_US_VOL_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_US_VOL_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_US_VOL_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_US_VOL_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_US_VOL_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_US_VOL_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_US_VOL_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_XA_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_XA_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_XA_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_XA_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_XA_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_XA_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_XA_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_XA_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_XA_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_XA_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_XA_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_XA_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_XRF_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_XRF_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_XRF_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_XRF_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_XRF_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_XRF_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_ENHANCED_XRF_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_ENHANCED_XRF_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_ENHANCED_XRF_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_ENHANCED_XRF_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_ENHANCED_XRF_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_ENHANCED_XRF_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_IVOCT_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_IVOCT_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_IVOCT_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_IVOCT_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_IVOCT_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_IVOCT_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_IVOCT_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_IVOCT_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_IVOCT_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_IVOCT_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_IVOCT_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_IVOCT_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_CT_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_MR_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_LEGACY_CONVERTED_ENHANCED_PET_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_MR_SPECTROSCOPY_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_MR_SPECTROSCOPY_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_MR_SPECTROSCOPY_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_MR_SPECTROSCOPY_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_MR_SPECTROSCOPY_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_MR_SPECTROSCOPY_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_MR_SPECTROSCOPY_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_MR_SPECTROSCOPY_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_MR_SPECTROSCOPY_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_MR_SPECTROSCOPY_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_MR_SPECTROSCOPY_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_MR_SPECTROSCOPY_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_OPHTHALMIC_TOMO_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_OPHTHALMIC_TOMO_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_OPHTHALMIC_TOMO_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_OPHTHALMIC_TOMO_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_OPHTHALMIC_TOMO_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_OPHTHALMIC_TOMO_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_OPHTHALMIC_TOMO_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_OPHTHALMIC_TOMO_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_OPHTHALMIC_TOMO_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_OPHTHALMIC_TOMO_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_OPHTHALMIC_TOMO_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_OPHTHALMIC_TOMO_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_PARAMETRIC_MAP_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_PARAMETRIC_MAP_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_PARAMETRIC_MAP_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_PARAMETRIC_MAP_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_PARAMETRIC_MAP_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_PARAMETRIC_MAP_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_PARAMETRIC_MAP_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_PARAMETRIC_MAP_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_PARAMETRIC_MAP_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_PARAMETRIC_MAP_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_PARAMETRIC_MAP_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_PARAMETRIC_MAP_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_PHOTOACOUSTIC_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_PHOTOACOUSTIC_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_PHOTOACOUSTIC_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_PHOTOACOUSTIC_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_PHOTOACOUSTIC_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_PHOTOACOUSTIC_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_PHOTOACOUSTIC_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_PHOTOACOUSTIC_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_PHOTOACOUSTIC_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_PHOTOACOUSTIC_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_PHOTOACOUSTIC_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_PHOTOACOUSTIC_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_SECONDARY_CAPTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_SECONDARY_CAPTURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_SECONDARY_CAPTURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_SECONDARY_CAPTURE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_SECONDARY_CAPTURE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_SECONDARY_CAPTURE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_SEGMENTATION_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_SEGMENTATION_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_SEGMENTATION_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_SEGMENTATION_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_SEGMENTATION_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_SEGMENTATION_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_SEGMENTATION_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_SEGMENTATION_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_SEGMENTATION_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_SEGMENTATION_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_SEGMENTATION_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_SEGMENTATION_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_SPARSE_MULTI_FRAME_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_VIDEO_REAL_TIME_COMMUNICATION_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_VL_WH_SL_MICRO_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_VL_WH_SL_MICRO_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_VL_WH_SL_MICRO_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_VL_WH_SL_MICRO_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_VL_WH_SL_MICRO_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_VL_WH_SL_MICRO_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_VL_WH_SL_MICRO_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_VL_WH_SL_MICRO_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_VL_WH_SL_MICRO_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_VL_WH_SL_MICRO_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_VL_WH_SL_MICRO_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_VL_WH_SL_MICRO_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_XRAY_3D_ANGIO_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_XRAY_3D_ANGIO_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_XRAY_3D_ANGIO_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_XRAY_3D_ANGIO_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_XRAY_3D_ANGIO_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_XRAY_3D_ANGIO_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_XRAY_3D_ANGIO_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_XRAY_3D_ANGIO_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_XRAY_3D_ANGIO_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_XRAY_3D_ANGIO_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_XRAY_3D_ANGIO_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_XRAY_3D_ANGIO_SHARE

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_XRAY_3D_CRANIO_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_XRAY_3D_CRANIO_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_XRAY_3D_CRANIO_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_XRAY_3D_CRANIO_FRAME
Visual Basic
Public Shared ReadOnly FUNC_GROUP_XRAY_3D_CRANIO_FRAME As String
Visual C++
public:
static initonly String^ FUNC_GROUP_XRAY_3D_CRANIO_FRAME

See Also

MCitems Structure
MCitems Members


FUNC_GROUP_XRAY_3D_CRANIO_SHARE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNC_GROUP_XRAY_3D_CRANIO_SHARE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNC_GROUP_XRAY_3D_CRANIO_SHARE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNC_GROUP_XRAY_3D_CRANIO_SHARE
Visual Basic
Public Shared ReadOnly FUNC_GROUP_XRAY_3D_CRANIO_SHARE As String
Visual C++
public:
static initonly String^ FUNC_GROUP_XRAY_3D_CRANIO_SHARE

See Also

MCitems Structure
MCitems Members


FUNCTIONAL_MR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..FUNCTIONAL_MR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.FUNCTIONAL_MR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string FUNCTIONAL_MR
Visual Basic
Public Shared ReadOnly FUNCTIONAL_MR As String
Visual C++
public:
static initonly String^ FUNCTIONAL_MR

See Also

MCitems Structure
MCitems Members


GATED_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GATED_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GATED_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GATED_INFO
Visual Basic
Public Shared ReadOnly GATED_INFO As String
Visual C++
public:
static initonly String^ GATED_INFO

See Also

MCitems Structure
MCitems Members


GATING_BEAM_HOLD_TRANSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GATING_BEAM_HOLD_TRANSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GATING_BEAM_HOLD_TRANSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GATING_BEAM_HOLD_TRANSITION
Visual Basic
Public Shared ReadOnly GATING_BEAM_HOLD_TRANSITION As String
Visual C++
public:
static initonly String^ GATING_BEAM_HOLD_TRANSITION

See Also

MCitems Structure
MCitems Members


GENERAL_ACCESSORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERAL_ACCESSORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERAL_ACCESSORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_ACCESSORY
Visual Basic
Public Shared ReadOnly GENERAL_ACCESSORY As String
Visual C++
public:
static initonly String^ GENERAL_ACCESSORY

See Also

MCitems Structure
MCitems Members


GENERAL_ACCESSORY_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERAL_ACCESSORY_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERAL_ACCESSORY_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_ACCESSORY_DEFINITION
Visual Basic
Public Shared ReadOnly GENERAL_ACCESSORY_DEFINITION As String
Visual C++
public:
static initonly String^ GENERAL_ACCESSORY_DEFINITION

See Also

MCitems Structure
MCitems Members


GENERAL_ACCESSORY_IN_RT_ION_BEAMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERAL_ACCESSORY_IN_RT_ION_BEAMS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERAL_ACCESSORY_IN_RT_ION_BEAMS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_ACCESSORY_IN_RT_ION_BEAMS
Visual Basic
Public Shared ReadOnly GENERAL_ACCESSORY_IN_RT_ION_BEAMS As String
Visual C++
public:
static initonly String^ GENERAL_ACCESSORY_IN_RT_ION_BEAMS

See Also

MCitems Structure
MCitems Members


GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD
Visual Basic
Public Shared ReadOnly GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD As String
Visual C++
public:
static initonly String^ GENERAL_ACCESSORY_IN_RT_ION_BEAMS_SESSION_RECORD

See Also

MCitems Structure
MCitems Members


GENERAL_MACHINE_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERAL_MACHINE_VERIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERAL_MACHINE_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_MACHINE_VERIFICATION
Visual Basic
Public Shared ReadOnly GENERAL_MACHINE_VERIFICATION As String
Visual C++
public:
static initonly String^ GENERAL_MACHINE_VERIFICATION

See Also

MCitems Structure
MCitems Members


GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM
Visual Basic
Public Shared ReadOnly GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM As String
Visual C++
public:
static initonly String^ GENERALIZED_DEFECT_SENSITIVITY_DEVIATION_ALGORITHM

See Also

MCitems Structure
MCitems Members


GENETIC_MODIFICATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GENETIC_MODIFICATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GENETIC_MODIFICATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENETIC_MODIFICATIONS
Visual Basic
Public Shared ReadOnly GENETIC_MODIFICATIONS As String
Visual C++
public:
static initonly String^ GENETIC_MODIFICATIONS

See Also

MCitems Structure
MCitems Members


GLOBAL_DEVIATION_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GLOBAL_DEVIATION_PROBABILITY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GLOBAL_DEVIATION_PROBABILITY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GLOBAL_DEVIATION_PROBABILITY
Visual Basic
Public Shared ReadOnly GLOBAL_DEVIATION_PROBABILITY As String
Visual C++
public:
static initonly String^ GLOBAL_DEVIATION_PROBABILITY

See Also

MCitems Structure
MCitems Members


GRAPHIC_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GRAPHIC_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GRAPHIC_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAPHIC_ANNOTATION
Visual Basic
Public Shared ReadOnly GRAPHIC_ANNOTATION As String
Visual C++
public:
static initonly String^ GRAPHIC_ANNOTATION

See Also

MCitems Structure
MCitems Members


GRAPHIC_COORDINATES_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GRAPHIC_COORDINATES_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GRAPHIC_COORDINATES_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAPHIC_COORDINATES_DATA
Visual Basic
Public Shared ReadOnly GRAPHIC_COORDINATES_DATA As String
Visual C++
public:
static initonly String^ GRAPHIC_COORDINATES_DATA

See Also

MCitems Structure
MCitems Members


GRAPHIC_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GRAPHIC_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GRAPHIC_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAPHIC_GROUP
Visual Basic
Public Shared ReadOnly GRAPHIC_GROUP As String
Visual C++
public:
static initonly String^ GRAPHIC_GROUP

See Also

MCitems Structure
MCitems Members


GRAPHIC_LAYER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GRAPHIC_LAYER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GRAPHIC_LAYER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAPHIC_LAYER
Visual Basic
Public Shared ReadOnly GRAPHIC_LAYER As String
Visual C++
public:
static initonly String^ GRAPHIC_LAYER

See Also

MCitems Structure
MCitems Members


GRAPHIC_OBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GRAPHIC_OBJECT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GRAPHIC_OBJECT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAPHIC_OBJECT
Visual Basic
Public Shared ReadOnly GRAPHIC_OBJECT As String
Visual C++
public:
static initonly String^ GRAPHIC_OBJECT

See Also

MCitems Structure
MCitems Members


GROUP_OF_PATIENTS_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..GROUP_OF_PATIENTS_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.GROUP_OF_PATIENTS_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GROUP_OF_PATIENTS_IDENTIFICATION
Visual Basic
Public Shared ReadOnly GROUP_OF_PATIENTS_IDENTIFICATION As String
Visual C++
public:
static initonly String^ GROUP_OF_PATIENTS_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


HANGING_PROTOCOL_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HANGING_PROTOCOL_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HANGING_PROTOCOL_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HANGING_PROTOCOL_DEFINITION
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOL_DEFINITION As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOL_DEFINITION

See Also

MCitems Structure
MCitems Members


HIERARCHICAL_SERIES_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HIERARCHICAL_SERIES_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HIERARCHICAL_SERIES_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HIERARCHICAL_SERIES_REF_MACRO
Visual Basic
Public Shared ReadOnly HIERARCHICAL_SERIES_REF_MACRO As String
Visual C++
public:
static initonly String^ HIERARCHICAL_SERIES_REF_MACRO

See Also

MCitems Structure
MCitems Members


HIERARCHICAL_SOP_INST_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HIERARCHICAL_SOP_INST_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HIERARCHICAL_SOP_INST_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HIERARCHICAL_SOP_INST_REF_MACRO
Visual Basic
Public Shared ReadOnly HIERARCHICAL_SOP_INST_REF_MACRO As String
Visual C++
public:
static initonly String^ HIERARCHICAL_SOP_INST_REF_MACRO

See Also

MCitems Structure
MCitems Members


HISTOGRAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HISTOGRAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HISTOGRAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HISTOGRAM
Visual Basic
Public Shared ReadOnly HISTOGRAM As String
Visual C++
public:
static initonly String^ HISTOGRAM

See Also

MCitems Structure
MCitems Members


HL7_HIERARCHIC_DESIGNATOR_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HL7_HIERARCHIC_DESIGNATOR_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HL7_HIERARCHIC_DESIGNATOR_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HL7_HIERARCHIC_DESIGNATOR_MACRO
Visual Basic
Public Shared ReadOnly HL7_HIERARCHIC_DESIGNATOR_MACRO As String
Visual C++
public:
static initonly String^ HL7_HIERARCHIC_DESIGNATOR_MACRO

See Also

MCitems Structure
MCitems Members


HL7_STRUCT_DOC_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HL7_STRUCT_DOC_REF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HL7_STRUCT_DOC_REF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HL7_STRUCT_DOC_REF
Visual Basic
Public Shared ReadOnly HL7_STRUCT_DOC_REF As String
Visual C++
public:
static initonly String^ HL7_STRUCT_DOC_REF

See Also

MCitems Structure
MCitems Members


HL7_STRUCT_DOC_REF_MWL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HL7_STRUCT_DOC_REF_MWL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HL7_STRUCT_DOC_REF_MWL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HL7_STRUCT_DOC_REF_MWL
Visual Basic
Public Shared ReadOnly HL7_STRUCT_DOC_REF_MWL As String
Visual C++
public:
static initonly String^ HL7_STRUCT_DOC_REF_MWL

See Also

MCitems Structure
MCitems Members


HPGL_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HPGL_DOCUMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HPGL_DOCUMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HPGL_DOCUMENT
Visual Basic
Public Shared ReadOnly HPGL_DOCUMENT As String
Visual C++
public:
static initonly String^ HPGL_DOCUMENT

See Also

MCitems Structure
MCitems Members


HPGL_PEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..HPGL_PEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.HPGL_PEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HPGL_PEN
Visual Basic
Public Shared ReadOnly HPGL_PEN As String
Visual C++
public:
static initonly String^ HPGL_PEN

See Also

MCitems Structure
MCitems Members


ICON_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ICON_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ICON_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ICON_IMAGE
Visual Basic
Public Shared ReadOnly ICON_IMAGE As String
Visual C++
public:
static initonly String^ ICON_IMAGE

See Also

MCitems Structure
MCitems Members


IDENTIFIED_PERSON_DEVICE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IDENTIFIED_PERSON_DEVICE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IDENTIFIED_PERSON_DEVICE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IDENTIFIED_PERSON_DEVICE_MACRO
Visual Basic
Public Shared ReadOnly IDENTIFIED_PERSON_DEVICE_MACRO As String
Visual C++
public:
static initonly String^ IDENTIFIED_PERSON_DEVICE_MACRO

See Also

MCitems Structure
MCitems Members


IMAGE_BOX_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_BOX_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_BOX_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_BOX_CONTENT
Visual Basic
Public Shared ReadOnly IMAGE_BOX_CONTENT As String
Visual C++
public:
static initonly String^ IMAGE_BOX_CONTENT

See Also

MCitems Structure
MCitems Members


IMAGE_BOX_SYNCHRONIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_BOX_SYNCHRONIZATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_BOX_SYNCHRONIZATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_BOX_SYNCHRONIZATION
Visual Basic
Public Shared ReadOnly IMAGE_BOX_SYNCHRONIZATION As String
Visual C++
public:
static initonly String^ IMAGE_BOX_SYNCHRONIZATION

See Also

MCitems Structure
MCitems Members


IMAGE_BOXES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_BOXES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_BOXES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_BOXES
Visual Basic
Public Shared ReadOnly IMAGE_BOXES As String
Visual C++
public:
static initonly String^ IMAGE_BOXES

See Also

MCitems Structure
MCitems Members


IMAGE_CENTER_POINT_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_CENTER_POINT_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_CENTER_POINT_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_CENTER_POINT_COORDINATES
Visual Basic
Public Shared ReadOnly IMAGE_CENTER_POINT_COORDINATES As String
Visual C++
public:
static initonly String^ IMAGE_CENTER_POINT_COORDINATES

See Also

MCitems Structure
MCitems Members


IMAGE_DATA_TYPE_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_DATA_TYPE_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_DATA_TYPE_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_DATA_TYPE_SQ
Visual Basic
Public Shared ReadOnly IMAGE_DATA_TYPE_SQ As String
Visual C++
public:
static initonly String^ IMAGE_DATA_TYPE_SQ

See Also

MCitems Structure
MCitems Members


IMAGE_FILTER_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_FILTER_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_FILTER_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_FILTER_DETAILS
Visual Basic
Public Shared ReadOnly IMAGE_FILTER_DETAILS As String
Visual C++
public:
static initonly String^ IMAGE_FILTER_DETAILS

See Also

MCitems Structure
MCitems Members


IMAGE_OVERLAY_BOX_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_OVERLAY_BOX_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_OVERLAY_BOX_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_OVERLAY_BOX_CONTENT
Visual Basic
Public Shared ReadOnly IMAGE_OVERLAY_BOX_CONTENT As String
Visual C++
public:
static initonly String^ IMAGE_OVERLAY_BOX_CONTENT

See Also

MCitems Structure
MCitems Members


IMAGE_PIXEL_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_PIXEL_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_PIXEL_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_PIXEL_MACRO
Visual Basic
Public Shared ReadOnly IMAGE_PIXEL_MACRO As String
Visual C++
public:
static initonly String^ IMAGE_PIXEL_MACRO

See Also

MCitems Structure
MCitems Members


IMAGE_SEGMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_SEGMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_SEGMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_SEGMENT
Visual Basic
Public Shared ReadOnly IMAGE_SEGMENT As String
Visual C++
public:
static initonly String^ IMAGE_SEGMENT

See Also

MCitems Structure
MCitems Members


IMAGE_SET_SELECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_SET_SELECTOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_SET_SELECTOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_SET_SELECTOR
Visual Basic
Public Shared ReadOnly IMAGE_SET_SELECTOR As String
Visual C++
public:
static initonly String^ IMAGE_SET_SELECTOR

See Also

MCitems Structure
MCitems Members


IMAGE_SETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_SETS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_SETS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_SETS
Visual Basic
Public Shared ReadOnly IMAGE_SETS As String
Visual C++
public:
static initonly String^ IMAGE_SETS

See Also

MCitems Structure
MCitems Members


IMAGE_SOP_INSTANCE_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_SOP_INSTANCE_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_SOP_INSTANCE_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_SOP_INSTANCE_REF_MACRO
Visual Basic
Public Shared ReadOnly IMAGE_SOP_INSTANCE_REF_MACRO As String
Visual C++
public:
static initonly String^ IMAGE_SOP_INSTANCE_REF_MACRO

See Also

MCitems Structure
MCitems Members


IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC
Visual Basic
Public Shared ReadOnly IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC As String
Visual C++
public:
static initonly String^ IMAGE_SOP_INSTANCE_REF_MACRO_IN_ENCAP_DOC

See Also

MCitems Structure
MCitems Members


IMAGING_DEVICE_LOCATION_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGING_DEVICE_LOCATION_PARAMETER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGING_DEVICE_LOCATION_PARAMETER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGING_DEVICE_LOCATION_PARAMETER
Visual Basic
Public Shared ReadOnly IMAGING_DEVICE_LOCATION_PARAMETER As String
Visual C++
public:
static initonly String^ IMAGING_DEVICE_LOCATION_PARAMETER

See Also

MCitems Structure
MCitems Members


IMAGING_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGING_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGING_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGING_POSITION
Visual Basic
Public Shared ReadOnly IMAGING_POSITION As String
Visual C++
public:
static initonly String^ IMAGING_POSITION

See Also

MCitems Structure
MCitems Members


IMAGING_POSITION_PARAMETERIZED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMAGING_POSITION_PARAMETERIZED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMAGING_POSITION_PARAMETERIZED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGING_POSITION_PARAMETERIZED
Visual Basic
Public Shared ReadOnly IMAGING_POSITION_PARAMETERIZED As String
Visual C++
public:
static initonly String^ IMAGING_POSITION_PARAMETERIZED

See Also

MCitems Structure
MCitems Members


IMPLANT_ASSMBLY_TMPL_TARGET_ANAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_ASSMBLY_TMPL_TARGET_ANAT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_ASSMBLY_TMPL_TARGET_ANAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_ASSMBLY_TMPL_TARGET_ANAT
Visual Basic
Public Shared ReadOnly IMPLANT_ASSMBLY_TMPL_TARGET_ANAT As String
Visual C++
public:
static initonly String^ IMPLANT_ASSMBLY_TMPL_TARGET_ANAT

See Also

MCitems Structure
MCitems Members


IMPLANT_TARGET_ANATOMY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TARGET_ANATOMY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TARGET_ANATOMY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TARGET_ANATOMY
Visual Basic
Public Shared ReadOnly IMPLANT_TARGET_ANATOMY As String
Visual C++
public:
static initonly String^ IMPLANT_TARGET_ANATOMY

See Also

MCitems Structure
MCitems Members


IMPLANT_TEMPLATE_GROUP_MEMBERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TEMPLATE_GROUP_MEMBERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TEMPLATE_GROUP_MEMBERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GROUP_MEMBERS
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GROUP_MEMBERS As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GROUP_MEMBERS

See Also

MCitems Structure
MCitems Members


IMPLANT_TEMPLATE_GRP_TARGET_ANAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TEMPLATE_GRP_TARGET_ANAT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TEMPLATE_GRP_TARGET_ANAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GRP_TARGET_ANAT
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GRP_TARGET_ANAT As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GRP_TARGET_ANAT

See Also

MCitems Structure
MCitems Members


IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GRP_VAR_DIM_RNK

See Also

MCitems Structure
MCitems Members


IMPLANT_TEMPLATE_GRP_VAR_DIMENS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TEMPLATE_GRP_VAR_DIMENS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TEMPLATE_GRP_VAR_DIMENS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GRP_VAR_DIMENS
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GRP_VAR_DIMENS As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GRP_VAR_DIMENS

See Also

MCitems Structure
MCitems Members


IMPLANT_TEMPLATE_GRPMM_2D_COORDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IMPLANT_TEMPLATE_GRPMM_2D_COORDS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IMPLANT_TEMPLATE_GRPMM_2D_COORDS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GRPMM_2D_COORDS
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GRPMM_2D_COORDS As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GRPMM_2D_COORDS

See Also

MCitems Structure
MCitems Members


INDEX_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INDEX_PROBABILITY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INDEX_PROBABILITY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INDEX_PROBABILITY
Visual Basic
Public Shared ReadOnly INDEX_PROBABILITY As String
Visual C++
public:
static initonly String^ INDEX_PROBABILITY

See Also

MCitems Structure
MCitems Members


INFORMATION_FROM_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INFORMATION_FROM_MANUFACTURER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INFORMATION_FROM_MANUFACTURER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INFORMATION_FROM_MANUFACTURER
Visual Basic
Public Shared ReadOnly INFORMATION_FROM_MANUFACTURER As String
Visual C++
public:
static initonly String^ INFORMATION_FROM_MANUFACTURER

See Also

MCitems Structure
MCitems Members


INSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INSTRUCTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INSTRUCTION
Visual Basic
Public Shared ReadOnly INSTRUCTION As String
Visual C++
public:
static initonly String^ INSTRUCTION

See Also

MCitems Structure
MCitems Members


INTERLOCK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTERLOCK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTERLOCK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTERLOCK
Visual Basic
Public Shared ReadOnly INTERLOCK As String
Visual C++
public:
static initonly String^ INTERLOCK

See Also

MCitems Structure
MCitems Members


INTERPRETATION_APPROVER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTERPRETATION_APPROVER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTERPRETATION_APPROVER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTERPRETATION_APPROVER
Visual Basic
Public Shared ReadOnly INTERPRETATION_APPROVER As String
Visual C++
public:
static initonly String^ INTERPRETATION_APPROVER

See Also

MCitems Structure
MCitems Members


INTERV_DRUG_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTERV_DRUG_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTERV_DRUG_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTERV_DRUG_INFO
Visual Basic
Public Shared ReadOnly INTERV_DRUG_INFO As String
Visual C++
public:
static initonly String^ INTERV_DRUG_INFO

See Also

MCitems Structure
MCitems Members


INTERVENTIONAL_THERAPY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTERVENTIONAL_THERAPY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTERVENTIONAL_THERAPY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTERVENTIONAL_THERAPY
Visual Basic
Public Shared ReadOnly INTERVENTIONAL_THERAPY As String
Visual C++
public:
static initonly String^ INTERVENTIONAL_THERAPY

See Also

MCitems Structure
MCitems Members


INTRAOCULAR_LENS_CALC_LEFT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTRAOCULAR_LENS_CALC_LEFT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTRAOCULAR_LENS_CALC_LEFT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTRAOCULAR_LENS_CALC_LEFT_EYE
Visual Basic
Public Shared ReadOnly INTRAOCULAR_LENS_CALC_LEFT_EYE As String
Visual C++
public:
static initonly String^ INTRAOCULAR_LENS_CALC_LEFT_EYE

See Also

MCitems Structure
MCitems Members


INTRAOCULAR_LENS_CALC_RIGHT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INTRAOCULAR_LENS_CALC_RIGHT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INTRAOCULAR_LENS_CALC_RIGHT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTRAOCULAR_LENS_CALC_RIGHT_EYE
Visual Basic
Public Shared ReadOnly INTRAOCULAR_LENS_CALC_RIGHT_EYE As String
Visual C++
public:
static initonly String^ INTRAOCULAR_LENS_CALC_RIGHT_EYE

See Also

MCitems Structure
MCitems Members


INVENTORIED_INSTANCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INVENTORIED_INSTANCES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INVENTORIED_INSTANCES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORIED_INSTANCES
Visual Basic
Public Shared ReadOnly INVENTORIED_INSTANCES As String
Visual C++
public:
static initonly String^ INVENTORIED_INSTANCES

See Also

MCitems Structure
MCitems Members


INVENTORIED_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INVENTORIED_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INVENTORIED_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORIED_SERIES
Visual Basic
Public Shared ReadOnly INVENTORIED_SERIES As String
Visual C++
public:
static initonly String^ INVENTORIED_SERIES

See Also

MCitems Structure
MCitems Members


INVENTORIED_STUDIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INVENTORIED_STUDIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INVENTORIED_STUDIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORIED_STUDIES
Visual Basic
Public Shared ReadOnly INVENTORIED_STUDIES As String
Visual C++
public:
static initonly String^ INVENTORIED_STUDIES

See Also

MCitems Structure
MCitems Members


INVENTORY_REFERENCE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..INVENTORY_REFERENCE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.INVENTORY_REFERENCE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY_REFERENCE_MACRO
Visual Basic
Public Shared ReadOnly INVENTORY_REFERENCE_MACRO As String
Visual C++
public:
static initonly String^ INVENTORY_REFERENCE_MACRO

See Also

MCitems Structure
MCitems Members


IOL_POWER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IOL_POWER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IOL_POWER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IOL_POWER
Visual Basic
Public Shared ReadOnly IOL_POWER As String
Visual C++
public:
static initonly String^ IOL_POWER

See Also

MCitems Structure
MCitems Members


ION_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_BEAM
Visual Basic
Public Shared ReadOnly ION_BEAM As String
Visual C++
public:
static initonly String^ ION_BEAM

See Also

MCitems Structure
MCitems Members


ION_BEAM_LIMITING_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_BEAM_LIMITING_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_BEAM_LIMITING_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_BEAM_LIMITING_DEVICE
Visual Basic
Public Shared ReadOnly ION_BEAM_LIMITING_DEVICE As String
Visual C++
public:
static initonly String^ ION_BEAM_LIMITING_DEVICE

See Also

MCitems Structure
MCitems Members


ION_BLOCK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_BLOCK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_BLOCK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_BLOCK
Visual Basic
Public Shared ReadOnly ION_BLOCK As String
Visual C++
public:
static initonly String^ ION_BLOCK

See Also

MCitems Structure
MCitems Members


ION_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_CONTROL_POINT
Visual Basic
Public Shared ReadOnly ION_CONTROL_POINT As String
Visual C++
public:
static initonly String^ ION_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


ION_CONTROL_POINT_DELIVERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_CONTROL_POINT_DELIVERY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_CONTROL_POINT_DELIVERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_CONTROL_POINT_DELIVERY
Visual Basic
Public Shared ReadOnly ION_CONTROL_POINT_DELIVERY As String
Visual C++
public:
static initonly String^ ION_CONTROL_POINT_DELIVERY

See Also

MCitems Structure
MCitems Members


ION_CONTROL_POINT_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_CONTROL_POINT_VERIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_CONTROL_POINT_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_CONTROL_POINT_VERIFICATION
Visual Basic
Public Shared ReadOnly ION_CONTROL_POINT_VERIFICATION As String
Visual C++
public:
static initonly String^ ION_CONTROL_POINT_VERIFICATION

See Also

MCitems Structure
MCitems Members


ION_MACHINE_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_MACHINE_VERIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_MACHINE_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_MACHINE_VERIFICATION
Visual Basic
Public Shared ReadOnly ION_MACHINE_VERIFICATION As String
Visual C++
public:
static initonly String^ ION_MACHINE_VERIFICATION

See Also

MCitems Structure
MCitems Members


ION_RANGE_COMPENSATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_RANGE_COMPENSATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_RANGE_COMPENSATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_RANGE_COMPENSATOR
Visual Basic
Public Shared ReadOnly ION_RANGE_COMPENSATOR As String
Visual C++
public:
static initonly String^ ION_RANGE_COMPENSATOR

See Also

MCitems Structure
MCitems Members


ION_TOLERANCE_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_TOLERANCE_TABLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_TOLERANCE_TABLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_TOLERANCE_TABLE
Visual Basic
Public Shared ReadOnly ION_TOLERANCE_TABLE As String
Visual C++
public:
static initonly String^ ION_TOLERANCE_TABLE

See Also

MCitems Structure
MCitems Members


ION_WEDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_WEDGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_WEDGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_WEDGE
Visual Basic
Public Shared ReadOnly ION_WEDGE As String
Visual C++
public:
static initonly String^ ION_WEDGE

See Also

MCitems Structure
MCitems Members


ION_WEDGE_POS_ION_CTL_PT_VERIF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_WEDGE_POS_ION_CTL_PT_VERIF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_WEDGE_POS_ION_CTL_PT_VERIF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_WEDGE_POS_ION_CTL_PT_VERIF
Visual Basic
Public Shared ReadOnly ION_WEDGE_POS_ION_CTL_PT_VERIF As String
Visual C++
public:
static initonly String^ ION_WEDGE_POS_ION_CTL_PT_VERIF

See Also

MCitems Structure
MCitems Members


ION_WEDGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ION_WEDGE_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ION_WEDGE_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ION_WEDGE_POSITION
Visual Basic
Public Shared ReadOnly ION_WEDGE_POSITION As String
Visual C++
public:
static initonly String^ ION_WEDGE_POSITION

See Also

MCitems Structure
MCitems Members


IRRADIATION_EVENT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IRRADIATION_EVENT_ID Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IRRADIATION_EVENT_ID"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IRRADIATION_EVENT_ID
Visual Basic
Public Shared ReadOnly IRRADIATION_EVENT_ID As String
Visual C++
public:
static initonly String^ IRRADIATION_EVENT_ID

See Also

MCitems Structure
MCitems Members


ISOCENTER_REFERENCE_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ISOCENTER_REFERENCE_SYSTEM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ISOCENTER_REFERENCE_SYSTEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ISOCENTER_REFERENCE_SYSTEM
Visual Basic
Public Shared ReadOnly ISOCENTER_REFERENCE_SYSTEM As String
Visual C++
public:
static initonly String^ ISOCENTER_REFERENCE_SYSTEM

See Also

MCitems Structure
MCitems Members


ISSUER_PATIENT_ID_QUALIFIERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ISSUER_PATIENT_ID_QUALIFIERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ISSUER_PATIENT_ID_QUALIFIERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ISSUER_PATIENT_ID_QUALIFIERS
Visual Basic
Public Shared ReadOnly ISSUER_PATIENT_ID_QUALIFIERS As String
Visual C++
public:
static initonly String^ ISSUER_PATIENT_ID_QUALIFIERS

See Also

MCitems Structure
MCitems Members


IV_FRAME_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IV_FRAME_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IV_FRAME_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IV_FRAME_CONTENT
Visual Basic
Public Shared ReadOnly IV_FRAME_CONTENT As String
Visual C++
public:
static initonly String^ IV_FRAME_CONTENT

See Also

MCitems Structure
MCitems Members


IVOCT_FRAME_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IVOCT_FRAME_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IVOCT_FRAME_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IVOCT_FRAME_CONTENT
Visual Basic
Public Shared ReadOnly IVOCT_FRAME_CONTENT As String
Visual C++
public:
static initonly String^ IVOCT_FRAME_CONTENT

See Also

MCitems Structure
MCitems Members


IVOCT_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..IVOCT_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.IVOCT_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IVOCT_FRAME_TYPE
Visual Basic
Public Shared ReadOnly IVOCT_FRAME_TYPE As String
Visual C++
public:
static initonly String^ IVOCT_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


KERATOMETRIC_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..KERATOMETRIC_AXIS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.KERATOMETRIC_AXIS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string KERATOMETRIC_AXIS
Visual Basic
Public Shared ReadOnly KERATOMETRIC_AXIS As String
Visual C++
public:
static initonly String^ KERATOMETRIC_AXIS

See Also

MCitems Structure
MCitems Members


KERATOMETRY_ANY_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..KERATOMETRY_ANY_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.KERATOMETRY_ANY_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string KERATOMETRY_ANY_EYE
Visual Basic
Public Shared ReadOnly KERATOMETRY_ANY_EYE As String
Visual C++
public:
static initonly String^ KERATOMETRY_ANY_EYE

See Also

MCitems Structure
MCitems Members


KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO
Visual Basic
Public Shared ReadOnly KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO As String
Visual C++
public:
static initonly String^ KV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO

See Also

MCitems Structure
MCitems Members


LANGUAGE_CODE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LANGUAGE_CODE_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LANGUAGE_CODE_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LANGUAGE_CODE_RQ
Visual Basic
Public Shared ReadOnly LANGUAGE_CODE_RQ As String
Visual C++
public:
static initonly String^ LANGUAGE_CODE_RQ

See Also

MCitems Structure
MCitems Members


LANGUAGE_CODE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LANGUAGE_CODE_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LANGUAGE_CODE_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LANGUAGE_CODE_RSP
Visual Basic
Public Shared ReadOnly LANGUAGE_CODE_RSP As String
Visual C++
public:
static initonly String^ LANGUAGE_CODE_RSP

See Also

MCitems Structure
MCitems Members


LATERAL_SPREADING_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LATERAL_SPREADING_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LATERAL_SPREADING_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LATERAL_SPREADING_DEVICE
Visual Basic
Public Shared ReadOnly LATERAL_SPREADING_DEVICE As String
Visual C++
public:
static initonly String^ LATERAL_SPREADING_DEVICE

See Also

MCitems Structure
MCitems Members


LATERAL_SPREADING_DEVICE_SETTING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LATERAL_SPREADING_DEVICE_SETTING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LATERAL_SPREADING_DEVICE_SETTING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LATERAL_SPREADING_DEVICE_SETTING
Visual Basic
Public Shared ReadOnly LATERAL_SPREADING_DEVICE_SETTING As String
Visual C++
public:
static initonly String^ LATERAL_SPREADING_DEVICE_SETTING

See Also

MCitems Structure
MCitems Members


LENS_CONSTANT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LENS_CONSTANT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LENS_CONSTANT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LENS_CONSTANT
Visual Basic
Public Shared ReadOnly LENS_CONSTANT As String
Visual C++
public:
static initonly String^ LENS_CONSTANT

See Also

MCitems Structure
MCitems Members


LENS_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LENS_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LENS_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LENS_SQ
Visual Basic
Public Shared ReadOnly LENS_SQ As String
Visual C++
public:
static initonly String^ LENS_SQ

See Also

MCitems Structure
MCitems Members


LENS_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LENS_THICKNESS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LENS_THICKNESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LENS_THICKNESS
Visual Basic
Public Shared ReadOnly LENS_THICKNESS As String
Visual C++
public:
static initonly String^ LENS_THICKNESS

See Also

MCitems Structure
MCitems Members


LIGHT_PATH_FILTER_TYPE_STACK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LIGHT_PATH_FILTER_TYPE_STACK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LIGHT_PATH_FILTER_TYPE_STACK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LIGHT_PATH_FILTER_TYPE_STACK
Visual Basic
Public Shared ReadOnly LIGHT_PATH_FILTER_TYPE_STACK As String
Visual C++
public:
static initonly String^ LIGHT_PATH_FILTER_TYPE_STACK

See Also

MCitems Structure
MCitems Members


LINE_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LINE_STYLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LINE_STYLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LINE_STYLE
Visual Basic
Public Shared ReadOnly LINE_STYLE As String
Visual C++
public:
static initonly String^ LINE_STYLE

See Also

MCitems Structure
MCitems Members


LOCALIZED_DEVIATION_PROBABILITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LOCALIZED_DEVIATION_PROBABILITY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LOCALIZED_DEVIATION_PROBABILITY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LOCALIZED_DEVIATION_PROBABILITY
Visual Basic
Public Shared ReadOnly LOCALIZED_DEVIATION_PROBABILITY As String
Visual C++
public:
static initonly String^ LOCALIZED_DEVIATION_PROBABILITY

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE_QA_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE_QA_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE_QA_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE_QA_SCP
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE_QA_SCP As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE_QA_SCP

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE_QA_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE_QA_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE_QA_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE_QA_SCU
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE_QA_SCU As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE_QA_SCU

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE_SCP
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE_SCP As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE_SCP

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE_SCU
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE_SCU As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE_SCU

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESPONSE1 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESPONSE1 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESPONSE1"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESPONSE1
Visual Basic
Public Shared ReadOnly LUMINANCE_RESPONSE1 As String
Visual C++
public:
static initonly String^ LUMINANCE_RESPONSE1

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESULT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESULT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESULT
Visual Basic
Public Shared ReadOnly LUMINANCE_RESULT As String
Visual C++
public:
static initonly String^ LUMINANCE_RESULT

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESULT_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESULT_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESULT_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESULT_SCP
Visual Basic
Public Shared ReadOnly LUMINANCE_RESULT_SCP As String
Visual C++
public:
static initonly String^ LUMINANCE_RESULT_SCP

See Also

MCitems Structure
MCitems Members


LUMINANCE_RESULT_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_RESULT_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_RESULT_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_RESULT_SCU
Visual Basic
Public Shared ReadOnly LUMINANCE_RESULT_SCU As String
Visual C++
public:
static initonly String^ LUMINANCE_RESULT_SCU

See Also

MCitems Structure
MCitems Members


LUMINANCE_UNIFORMITY_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_UNIFORMITY_RESULT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_UNIFORMITY_RESULT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_UNIFORMITY_RESULT
Visual Basic
Public Shared ReadOnly LUMINANCE_UNIFORMITY_RESULT As String
Visual C++
public:
static initonly String^ LUMINANCE_UNIFORMITY_RESULT

See Also

MCitems Structure
MCitems Members


LUMINANCE_UNIFORMITY_RESULT_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_UNIFORMITY_RESULT_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_UNIFORMITY_RESULT_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_UNIFORMITY_RESULT_SCP
Visual Basic
Public Shared ReadOnly LUMINANCE_UNIFORMITY_RESULT_SCP As String
Visual C++
public:
static initonly String^ LUMINANCE_UNIFORMITY_RESULT_SCP

See Also

MCitems Structure
MCitems Members


LUMINANCE_UNIFORMITY_RESULT_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..LUMINANCE_UNIFORMITY_RESULT_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.LUMINANCE_UNIFORMITY_RESULT_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LUMINANCE_UNIFORMITY_RESULT_SCU
Visual Basic
Public Shared ReadOnly LUMINANCE_UNIFORMITY_RESULT_SCU As String
Visual C++
public:
static initonly String^ LUMINANCE_UNIFORMITY_RESULT_SCU

See Also

MCitems Structure
MCitems Members


MAC_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MAC_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MAC_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MAC_PARAMETERS
Visual Basic
Public Shared ReadOnly MAC_PARAMETERS As String
Visual C++
public:
static initonly String^ MAC_PARAMETERS

See Also

MCitems Structure
MCitems Members


MAJOR_TICKS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MAJOR_TICKS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MAJOR_TICKS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MAJOR_TICKS
Visual Basic
Public Shared ReadOnly MAJOR_TICKS As String
Visual C++
public:
static initonly String^ MAJOR_TICKS

See Also

MCitems Structure
MCitems Members


MAPPING_RESOURCE_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MAPPING_RESOURCE_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MAPPING_RESOURCE_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MAPPING_RESOURCE_IDENTIFICATION
Visual Basic
Public Shared ReadOnly MAPPING_RESOURCE_IDENTIFICATION As String
Visual C++
public:
static initonly String^ MAPPING_RESOURCE_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


MASK_FRAME_PIXEL_SHIFT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MASK_FRAME_PIXEL_SHIFT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MASK_FRAME_PIXEL_SHIFT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MASK_FRAME_PIXEL_SHIFT
Visual Basic
Public Shared ReadOnly MASK_FRAME_PIXEL_SHIFT As String
Visual C++
public:
static initonly String^ MASK_FRAME_PIXEL_SHIFT

See Also

MCitems Structure
MCitems Members


MASK_SUBTRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MASK_SUBTRACTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MASK_SUBTRACTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MASK_SUBTRACTION
Visual Basic
Public Shared ReadOnly MASK_SUBTRACTION As String
Visual C++
public:
static initonly String^ MASK_SUBTRACTION

See Also

MCitems Structure
MCitems Members


MASK_SUBTRACTION_IN_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MASK_SUBTRACTION_IN_PS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MASK_SUBTRACTION_IN_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MASK_SUBTRACTION_IN_PS
Visual Basic
Public Shared ReadOnly MASK_SUBTRACTION_IN_PS As String
Visual C++
public:
static initonly String^ MASK_SUBTRACTION_IN_PS

See Also

MCitems Structure
MCitems Members


MATERIAL_ATTENUATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATERIAL_ATTENUATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATERIAL_ATTENUATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATERIAL_ATTENUATION
Visual Basic
Public Shared ReadOnly MATERIAL_ATTENUATION As String
Visual C++
public:
static initonly String^ MATERIAL_ATTENUATION

See Also

MCitems Structure
MCitems Members


MATING_FEATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATING_FEATURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATING_FEATURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATING_FEATURE
Visual Basic
Public Shared ReadOnly MATING_FEATURE As String
Visual C++
public:
static initonly String^ MATING_FEATURE

See Also

MCitems Structure
MCitems Members


MATING_FEATURE_DEGREE_OF_FREEDOM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATING_FEATURE_DEGREE_OF_FREEDOM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATING_FEATURE_DEGREE_OF_FREEDOM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATING_FEATURE_DEGREE_OF_FREEDOM
Visual Basic
Public Shared ReadOnly MATING_FEATURE_DEGREE_OF_FREEDOM As String
Visual C++
public:
static initonly String^ MATING_FEATURE_DEGREE_OF_FREEDOM

See Also

MCitems Structure
MCitems Members


MATING_FEATURE_SETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATING_FEATURE_SETS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATING_FEATURE_SETS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATING_FEATURE_SETS
Visual Basic
Public Shared ReadOnly MATING_FEATURE_SETS As String
Visual C++
public:
static initonly String^ MATING_FEATURE_SETS

See Also

MCitems Structure
MCitems Members


MATRIX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATRIX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATRIX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATRIX
Visual Basic
Public Shared ReadOnly MATRIX As String
Visual C++
public:
static initonly String^ MATRIX

See Also

MCitems Structure
MCitems Members


MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO
Visual Basic
Public Shared ReadOnly MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO As String
Visual C++
public:
static initonly String^ MATRIX_BASED_RT_IMAGING_GEOMETRY_MACRO

See Also

MCitems Structure
MCitems Members


MATRIX_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MATRIX_REGISTRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MATRIX_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MATRIX_REGISTRATION
Visual Basic
Public Shared ReadOnly MATRIX_REGISTRATION As String
Visual C++
public:
static initonly String^ MATRIX_REGISTRATION

See Also

MCitems Structure
MCitems Members


MAXIMUM_CORNEAL_CURVATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MAXIMUM_CORNEAL_CURVATURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MAXIMUM_CORNEAL_CURVATURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MAXIMUM_CORNEAL_CURVATURE
Visual Basic
Public Shared ReadOnly MAXIMUM_CORNEAL_CURVATURE As String
Visual C++
public:
static initonly String^ MAXIMUM_CORNEAL_CURVATURE

See Also

MCitems Structure
MCitems Members


MEASURED_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASURED_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASURED_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASURED_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly MEASURED_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ MEASURED_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


MEASURED_METERSET_TO_DOSE_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASURED_METERSET_TO_DOSE_MAPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASURED_METERSET_TO_DOSE_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASURED_METERSET_TO_DOSE_MAPPING
Visual Basic
Public Shared ReadOnly MEASURED_METERSET_TO_DOSE_MAPPING As String
Visual C++
public:
static initonly String^ MEASURED_METERSET_TO_DOSE_MAPPING

See Also

MCitems Structure
MCitems Members


MEASURED_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASURED_VALUE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASURED_VALUE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASURED_VALUE
Visual Basic
Public Shared ReadOnly MEASURED_VALUE As String
Visual C++
public:
static initonly String^ MEASURED_VALUE

See Also

MCitems Structure
MCitems Members


MEASUREMENT_EQUIPMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENT_EQUIPMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENT_EQUIPMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENT_EQUIPMENT
Visual Basic
Public Shared ReadOnly MEASUREMENT_EQUIPMENT As String
Visual C++
public:
static initonly String^ MEASUREMENT_EQUIPMENT

See Also

MCitems Structure
MCitems Members


MEASUREMENT_EQUIPMENT_SCP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENT_EQUIPMENT_SCP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENT_EQUIPMENT_SCP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENT_EQUIPMENT_SCP_MACRO
Visual Basic
Public Shared ReadOnly MEASUREMENT_EQUIPMENT_SCP_MACRO As String
Visual C++
public:
static initonly String^ MEASUREMENT_EQUIPMENT_SCP_MACRO

See Also

MCitems Structure
MCitems Members


MEASUREMENT_EQUIPMENT_SCP_NGET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENT_EQUIPMENT_SCP_NGET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENT_EQUIPMENT_SCP_NGET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENT_EQUIPMENT_SCP_NGET
Visual Basic
Public Shared ReadOnly MEASUREMENT_EQUIPMENT_SCP_NGET As String
Visual C++
public:
static initonly String^ MEASUREMENT_EQUIPMENT_SCP_NGET

See Also

MCitems Structure
MCitems Members


MEASUREMENT_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENT_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENT_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENT_VALUES
Visual Basic
Public Shared ReadOnly MEASUREMENT_VALUES As String
Visual C++
public:
static initonly String^ MEASUREMENT_VALUES

See Also

MCitems Structure
MCitems Members


MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS
Visual Basic
Public Shared ReadOnly MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS As String
Visual C++
public:
static initonly String^ MEASUREMENT_VALUES_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS

See Also

MCitems Structure
MCitems Members


MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENTS
Visual Basic
Public Shared ReadOnly MEASUREMENTS As String
Visual C++
public:
static initonly String^ MEASUREMENTS

See Also

MCitems Structure
MCitems Members


MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS
Visual Basic
Public Shared ReadOnly MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS As String
Visual C++
public:
static initonly String^ MEASUREMENTS_IN_MICROSCOPY_BULK_SIMPLE_ANNOTATIONS

See Also

MCitems Structure
MCitems Members


MEDIA_INSTALLED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEDIA_INSTALLED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEDIA_INSTALLED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEDIA_INSTALLED
Visual Basic
Public Shared ReadOnly MEDIA_INSTALLED As String
Visual C++
public:
static initonly String^ MEDIA_INSTALLED

See Also

MCitems Structure
MCitems Members


MEDIA_RETRIEVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MEDIA_RETRIEVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MEDIA_RETRIEVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEDIA_RETRIEVAL
Visual Basic
Public Shared ReadOnly MEDIA_RETRIEVAL As String
Visual C++
public:
static initonly String^ MEDIA_RETRIEVAL

See Also

MCitems Structure
MCitems Members


METERSET_TO_DOSE_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..METERSET_TO_DOSE_MAPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.METERSET_TO_DOSE_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string METERSET_TO_DOSE_MAPPING
Visual Basic
Public Shared ReadOnly METERSET_TO_DOSE_MAPPING As String
Visual C++
public:
static initonly String^ METERSET_TO_DOSE_MAPPING

See Also

MCitems Structure
MCitems Members


MINIMUM_KERATOMETRIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MINIMUM_KERATOMETRIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MINIMUM_KERATOMETRIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MINIMUM_KERATOMETRIC
Visual Basic
Public Shared ReadOnly MINIMUM_KERATOMETRIC As String
Visual C++
public:
static initonly String^ MINIMUM_KERATOMETRIC

See Also

MCitems Structure
MCitems Members


MODALITY_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MODALITY_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MODALITY_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODALITY_LUT
Visual Basic
Public Shared ReadOnly MODALITY_LUT As String
Visual C++
public:
static initonly String^ MODALITY_LUT

See Also

MCitems Structure
MCitems Members


MODEL_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MODEL_SPECIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MODEL_SPECIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODEL_SPECIFICATION
Visual Basic
Public Shared ReadOnly MODEL_SPECIFICATION As String
Visual C++
public:
static initonly String^ MODEL_SPECIFICATION

See Also

MCitems Structure
MCitems Members


MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ
Visual Basic
Public Shared ReadOnly MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ As String
Visual C++
public:
static initonly String^ MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP
Visual Basic
Public Shared ReadOnly MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP As String
Visual C++
public:
static initonly String^ MODEL_SPECIFICATION_IN_DEFINED_PROCEDURE_PROTOCOL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


MODIFIED_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MODIFIED_ATTRIBUTES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MODIFIED_ATTRIBUTES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODIFIED_ATTRIBUTES
Visual Basic
Public Shared ReadOnly MODIFIED_ATTRIBUTES As String
Visual C++
public:
static initonly String^ MODIFIED_ATTRIBUTES

See Also

MCitems Structure
MCitems Members


MR_ARTERIAL_SPIN_LABELING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_ARTERIAL_SPIN_LABELING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_ARTERIAL_SPIN_LABELING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_ARTERIAL_SPIN_LABELING
Visual Basic
Public Shared ReadOnly MR_ARTERIAL_SPIN_LABELING As String
Visual C++
public:
static initonly String^ MR_ARTERIAL_SPIN_LABELING

See Also

MCitems Structure
MCitems Members


MR_AVERAGES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_AVERAGES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_AVERAGES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_AVERAGES
Visual Basic
Public Shared ReadOnly MR_AVERAGES As String
Visual C++
public:
static initonly String^ MR_AVERAGES

See Also

MCitems Structure
MCitems Members


MR_DIFFUSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_DIFFUSION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_DIFFUSION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_DIFFUSION
Visual Basic
Public Shared ReadOnly MR_DIFFUSION As String
Visual C++
public:
static initonly String^ MR_DIFFUSION

See Also

MCitems Structure
MCitems Members


MR_ECHO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_ECHO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_ECHO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_ECHO
Visual Basic
Public Shared ReadOnly MR_ECHO As String
Visual C++
public:
static initonly String^ MR_ECHO

See Also

MCitems Structure
MCitems Members


MR_FOV_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_FOV_GEOMETRY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_FOV_GEOMETRY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_FOV_GEOMETRY
Visual Basic
Public Shared ReadOnly MR_FOV_GEOMETRY As String
Visual C++
public:
static initonly String^ MR_FOV_GEOMETRY

See Also

MCitems Structure
MCitems Members


MR_IMAGE_DESCRIPTION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_IMAGE_DESCRIPTION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_IMAGE_DESCRIPTION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_IMAGE_DESCRIPTION_MACRO
Visual Basic
Public Shared ReadOnly MR_IMAGE_DESCRIPTION_MACRO As String
Visual C++
public:
static initonly String^ MR_IMAGE_DESCRIPTION_MACRO

See Also

MCitems Structure
MCitems Members


MR_IMAGE_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_IMAGE_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_IMAGE_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_IMAGE_FRAME_TYPE
Visual Basic
Public Shared ReadOnly MR_IMAGE_FRAME_TYPE As String
Visual C++
public:
static initonly String^ MR_IMAGE_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


MR_IMAGING_MODIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_IMAGING_MODIFIER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_IMAGING_MODIFIER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_IMAGING_MODIFIER
Visual Basic
Public Shared ReadOnly MR_IMAGING_MODIFIER As String
Visual C++
public:
static initonly String^ MR_IMAGING_MODIFIER

See Also

MCitems Structure
MCitems Members


MR_METABOLITE_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_METABOLITE_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_METABOLITE_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_METABOLITE_MAP
Visual Basic
Public Shared ReadOnly MR_METABOLITE_MAP As String
Visual C++
public:
static initonly String^ MR_METABOLITE_MAP

See Also

MCitems Structure
MCitems Members


MR_MODIFIER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_MODIFIER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_MODIFIER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_MODIFIER
Visual Basic
Public Shared ReadOnly MR_MODIFIER As String
Visual C++
public:
static initonly String^ MR_MODIFIER

See Also

MCitems Structure
MCitems Members


MR_RECEIVE_COIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_RECEIVE_COIL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_RECEIVE_COIL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_RECEIVE_COIL
Visual Basic
Public Shared ReadOnly MR_RECEIVE_COIL As String
Visual C++
public:
static initonly String^ MR_RECEIVE_COIL

See Also

MCitems Structure
MCitems Members


MR_SPATIAL_SATURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_SPATIAL_SATURATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_SPATIAL_SATURATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_SPATIAL_SATURATION
Visual Basic
Public Shared ReadOnly MR_SPATIAL_SATURATION As String
Visual C++
public:
static initonly String^ MR_SPATIAL_SATURATION

See Also

MCitems Structure
MCitems Members


MR_SPECTROSCOPY_FOV_GEOMETRY_MAC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_SPECTROSCOPY_FOV_GEOMETRY_MAC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_SPECTROSCOPY_FOV_GEOMETRY_MAC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_SPECTROSCOPY_FOV_GEOMETRY_MAC
Visual Basic
Public Shared ReadOnly MR_SPECTROSCOPY_FOV_GEOMETRY_MAC As String
Visual C++
public:
static initonly String^ MR_SPECTROSCOPY_FOV_GEOMETRY_MAC

See Also

MCitems Structure
MCitems Members


MR_SPECTROSCOPY_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_SPECTROSCOPY_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_SPECTROSCOPY_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_SPECTROSCOPY_FRAME_TYPE
Visual Basic
Public Shared ReadOnly MR_SPECTROSCOPY_FRAME_TYPE As String
Visual C++
public:
static initonly String^ MR_SPECTROSCOPY_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


MR_TIMING_RELATED_PARMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_TIMING_RELATED_PARMS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_TIMING_RELATED_PARMS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_TIMING_RELATED_PARMS
Visual Basic
Public Shared ReadOnly MR_TIMING_RELATED_PARMS As String
Visual C++
public:
static initonly String^ MR_TIMING_RELATED_PARMS

See Also

MCitems Structure
MCitems Members


MR_TRANSMIT_COIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_TRANSMIT_COIL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_TRANSMIT_COIL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_TRANSMIT_COIL
Visual Basic
Public Shared ReadOnly MR_TRANSMIT_COIL As String
Visual C++
public:
static initonly String^ MR_TRANSMIT_COIL

See Also

MCitems Structure
MCitems Members


MR_VELOCITY_ENCODING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MR_VELOCITY_ENCODING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MR_VELOCITY_ENCODING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_VELOCITY_ENCODING
Visual Basic
Public Shared ReadOnly MR_VELOCITY_ENCODING As String
Visual C++
public:
static initonly String^ MR_VELOCITY_ENCODING

See Also

MCitems Structure
MCitems Members


MULTI_COIL_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_COIL_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_COIL_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_COIL_DEFINITION
Visual Basic
Public Shared ReadOnly MULTI_COIL_DEFINITION As String
Visual C++
public:
static initonly String^ MULTI_COIL_DEFINITION

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_ACQUISITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_ACQUISITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_ACQUISITION
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_ACQUISITION As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_ACQUISITION

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_PATH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_PATH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_PATH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_PATH
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_PATH As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_PATH

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_PROCESSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_PROCESSING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_PROCESSING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_PROCESSING
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_PROCESSING As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_PROCESSING

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_XRAY_DETECTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_XRAY_DETECTOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_XRAY_DETECTOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_XRAY_DETECTOR
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_XRAY_DETECTOR As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_XRAY_DETECTOR

See Also

MCitems Structure
MCitems Members


MULTI_ENERGY_CT_XRAY_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_ENERGY_CT_XRAY_SOURCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_ENERGY_CT_XRAY_SOURCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_ENERGY_CT_XRAY_SOURCE
Visual Basic
Public Shared ReadOnly MULTI_ENERGY_CT_XRAY_SOURCE As String
Visual C++
public:
static initonly String^ MULTI_ENERGY_CT_XRAY_SOURCE

See Also

MCitems Structure
MCitems Members


MULTI_FRAME_PRESENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTI_FRAME_PRESENTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTI_FRAME_PRESENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_FRAME_PRESENTATION
Visual Basic
Public Shared ReadOnly MULTI_FRAME_PRESENTATION As String
Visual C++
public:
static initonly String^ MULTI_FRAME_PRESENTATION

See Also

MCitems Structure
MCitems Members


MULTIPLEXED_AUDIO_CHANNELS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MULTIPLEXED_AUDIO_CHANNELS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MULTIPLEXED_AUDIO_CHANNELS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTIPLEXED_AUDIO_CHANNELS
Visual Basic
Public Shared ReadOnly MULTIPLEXED_AUDIO_CHANNELS As String
Visual C++
public:
static initonly String^ MULTIPLEXED_AUDIO_CHANNELS

See Also

MCitems Structure
MCitems Members


MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO
Visual Basic
Public Shared ReadOnly MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO As String
Visual C++
public:
static initonly String^ MV_RADIATION_IMAGE_ACQUISITION_PARAMETERS_MACRO

See Also

MCitems Structure
MCitems Members


MYDRIATIC_AGENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..MYDRIATIC_AGENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.MYDRIATIC_AGENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MYDRIATIC_AGENT
Visual Basic
Public Shared ReadOnly MYDRIATIC_AGENT As String
Visual C++
public:
static initonly String^ MYDRIATIC_AGENT

See Also

MCitems Structure
MCitems Members


NAVIGATION_INDICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..NAVIGATION_INDICATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.NAVIGATION_INDICATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string NAVIGATION_INDICATOR
Visual Basic
Public Shared ReadOnly NAVIGATION_INDICATOR As String
Visual C++
public:
static initonly String^ NAVIGATION_INDICATOR

See Also

MCitems Structure
MCitems Members


NOMINAL_SCREEN_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..NOMINAL_SCREEN_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.NOMINAL_SCREEN_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string NOMINAL_SCREEN_DEFINITION
Visual Basic
Public Shared ReadOnly NOMINAL_SCREEN_DEFINITION As String
Visual C++
public:
static initonly String^ NOMINAL_SCREEN_DEFINITION

See Also

MCitems Structure
MCitems Members


NONCONFORMING_MODIFIED_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..NONCONFORMING_MODIFIED_ATTRIBUTES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.NONCONFORMING_MODIFIED_ATTRIBUTES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string NONCONFORMING_MODIFIED_ATTRIBUTES
Visual Basic
Public Shared ReadOnly NONCONFORMING_MODIFIED_ATTRIBUTES As String
Visual C++
public:
static initonly String^ NONCONFORMING_MODIFIED_ATTRIBUTES

See Also

MCitems Structure
MCitems Members


NOTIFICATION_FROM_MANUFACTURER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..NOTIFICATION_FROM_MANUFACTURER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.NOTIFICATION_FROM_MANUFACTURER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string NOTIFICATION_FROM_MANUFACTURER
Visual Basic
Public Shared ReadOnly NOTIFICATION_FROM_MANUFACTURER As String
Visual C++
public:
static initonly String^ NOTIFICATION_FROM_MANUFACTURER

See Also

MCitems Structure
MCitems Members


OBJECT_THICKNESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OBJECT_THICKNESS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OBJECT_THICKNESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OBJECT_THICKNESS
Visual Basic
Public Shared ReadOnly OBJECT_THICKNESS As String
Visual C++
public:
static initonly String^ OBJECT_THICKNESS

See Also

MCitems Structure
MCitems Members


OBLIQUE_CROPPING_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OBLIQUE_CROPPING_PLANE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OBLIQUE_CROPPING_PLANE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OBLIQUE_CROPPING_PLANE
Visual Basic
Public Shared ReadOnly OBLIQUE_CROPPING_PLANE As String
Visual C++
public:
static initonly String^ OBLIQUE_CROPPING_PLANE

See Also

MCitems Structure
MCitems Members


OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS
Visual Basic
Public Shared ReadOnly OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS As String
Visual C++
public:
static initonly String^ OCT_BSCAN_ANALYSIS_ACQUISITION_PARAMETERS

See Also

MCitems Structure
MCitems Members


OMITTED_APPLICATION_SETUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OMITTED_APPLICATION_SETUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OMITTED_APPLICATION_SETUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OMITTED_APPLICATION_SETUP
Visual Basic
Public Shared ReadOnly OMITTED_APPLICATION_SETUP As String
Visual C++
public:
static initonly String^ OMITTED_APPLICATION_SETUP

See Also

MCitems Structure
MCitems Members


OMITTED_BEAM_TASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OMITTED_BEAM_TASK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OMITTED_BEAM_TASK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OMITTED_BEAM_TASK
Visual Basic
Public Shared ReadOnly OMITTED_BEAM_TASK As String
Visual C++
public:
static initonly String^ OMITTED_BEAM_TASK

See Also

MCitems Structure
MCitems Members


OMITTED_CHANNEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OMITTED_CHANNEL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OMITTED_CHANNEL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OMITTED_CHANNEL
Visual Basic
Public Shared ReadOnly OMITTED_CHANNEL As String
Visual C++
public:
static initonly String^ OMITTED_CHANNEL

See Also

MCitems Structure
MCitems Members


OMITTED_RADIATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OMITTED_RADIATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OMITTED_RADIATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OMITTED_RADIATION
Visual Basic
Public Shared ReadOnly OMITTED_RADIATION As String
Visual C++
public:
static initonly String^ OMITTED_RADIATION

See Also

MCitems Structure
MCitems Members


OPERATING_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPERATING_MODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPERATING_MODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPERATING_MODE
Visual Basic
Public Shared ReadOnly OPERATING_MODE As String
Visual C++
public:
static initonly String^ OPERATING_MODE

See Also

MCitems Structure
MCitems Members


OPERATOR_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPERATOR_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPERATOR_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPERATOR_IDENTIFICATION
Visual Basic
Public Shared ReadOnly OPERATOR_IDENTIFICATION As String
Visual C++
public:
static initonly String^ OPERATOR_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


OPHT_AXIAL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXIAL_LENGTH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXIAL_LENGTH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXIAL_LENGTH
Visual Basic
Public Shared ReadOnly OPHT_AXIAL_LENGTH As String
Visual C++
public:
static initonly String^ OPHT_AXIAL_LENGTH

See Also

MCitems Structure
MCitems Members


OPHT_AXL_LEN_MEAS_LEN_SUMMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_LEN_MEAS_LEN_SUMMATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_LEN_MEAS_LEN_SUMMATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_LEN_MEAS_LEN_SUMMATION
Visual Basic
Public Shared ReadOnly OPHT_AXL_LEN_MEAS_LEN_SUMMATION As String
Visual C++
public:
static initonly String^ OPHT_AXL_LEN_MEAS_LEN_SUMMATION

See Also

MCitems Structure
MCitems Members


OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN
Visual Basic
Public Shared ReadOnly OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN As String
Visual C++
public:
static initonly String^ OPHT_AXL_LEN_MEAS_SEGMENTAL_LEN

See Also

MCitems Structure
MCitems Members


OPHT_AXL_LEN_MEAS_TOTAL_LEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_LEN_MEAS_TOTAL_LEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_LEN_MEAS_TOTAL_LEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_LEN_MEAS_TOTAL_LEN
Visual Basic
Public Shared ReadOnly OPHT_AXL_LEN_MEAS_TOTAL_LEN As String
Visual C++
public:
static initonly String^ OPHT_AXL_LEN_MEAS_TOTAL_LEN

See Also

MCitems Structure
MCitems Members


OPHT_AXL_LEN_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_LEN_MEASUREMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_LEN_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_LEN_MEASUREMENTS
Visual Basic
Public Shared ReadOnly OPHT_AXL_LEN_MEASUREMENTS As String
Visual C++
public:
static initonly String^ OPHT_AXL_LEN_MEASUREMENTS

See Also

MCitems Structure
MCitems Members


OPHT_AXL_LEN_QUALITY_METRIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_LEN_QUALITY_METRIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_LEN_QUALITY_METRIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_LEN_QUALITY_METRIC
Visual Basic
Public Shared ReadOnly OPHT_AXL_LEN_QUALITY_METRIC As String
Visual C++
public:
static initonly String^ OPHT_AXL_LEN_QUALITY_METRIC

See Also

MCitems Structure
MCitems Members


OPHT_AXL_MEAS_LEFT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_MEAS_LEFT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_MEAS_LEFT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_MEAS_LEFT_EYE
Visual Basic
Public Shared ReadOnly OPHT_AXL_MEAS_LEFT_EYE As String
Visual C++
public:
static initonly String^ OPHT_AXL_MEAS_LEFT_EYE

See Also

MCitems Structure
MCitems Members


OPHT_AXL_MEAS_RIGHT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_AXL_MEAS_RIGHT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_AXL_MEAS_RIGHT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_AXL_MEAS_RIGHT_EYE
Visual Basic
Public Shared ReadOnly OPHT_AXL_MEAS_RIGHT_EYE As String
Visual C++
public:
static initonly String^ OPHT_AXL_MEAS_RIGHT_EYE

See Also

MCitems Structure
MCitems Members


OPHT_PAT_CLINICAL_INFO_LEFT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_PAT_CLINICAL_INFO_LEFT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_PAT_CLINICAL_INFO_LEFT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_PAT_CLINICAL_INFO_LEFT_EYE
Visual Basic
Public Shared ReadOnly OPHT_PAT_CLINICAL_INFO_LEFT_EYE As String
Visual C++
public:
static initonly String^ OPHT_PAT_CLINICAL_INFO_LEFT_EYE

See Also

MCitems Structure
MCitems Members


OPHT_PAT_CLINICAL_INFO_RIGHT_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHT_PAT_CLINICAL_INFO_RIGHT_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHT_PAT_CLINICAL_INFO_RIGHT_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_PAT_CLINICAL_INFO_RIGHT_EYE
Visual Basic
Public Shared ReadOnly OPHT_PAT_CLINICAL_INFO_RIGHT_EYE As String
Visual C++
public:
static initonly String^ OPHT_PAT_CLINICAL_INFO_RIGHT_EYE

See Also

MCitems Structure
MCitems Members


OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING
Visual Basic
Public Shared ReadOnly OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING As String
Visual C++
public:
static initonly String^ OPHTHALMIC_EN_FACE_IMAGE_QUALITY_RATING

See Also

MCitems Structure
MCitems Members


OPHTHALMIC_FRAME_LOCATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPHTHALMIC_FRAME_LOCATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPHTHALMIC_FRAME_LOCATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_FRAME_LOCATION
Visual Basic
Public Shared ReadOnly OPHTHALMIC_FRAME_LOCATION As String
Visual C++
public:
static initonly String^ OPHTHALMIC_FRAME_LOCATION

See Also

MCitems Structure
MCitems Members


OPM_THICKNESS_MAP_Q_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPM_THICKNESS_MAP_Q_THRESHOLD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPM_THICKNESS_MAP_Q_THRESHOLD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPM_THICKNESS_MAP_Q_THRESHOLD
Visual Basic
Public Shared ReadOnly OPM_THICKNESS_MAP_Q_THRESHOLD As String
Visual C++
public:
static initonly String^ OPM_THICKNESS_MAP_Q_THRESHOLD

See Also

MCitems Structure
MCitems Members


OPM_THICKNESS_MAP_QR_SEQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPM_THICKNESS_MAP_QR_SEQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPM_THICKNESS_MAP_QR_SEQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPM_THICKNESS_MAP_QR_SEQ
Visual Basic
Public Shared ReadOnly OPM_THICKNESS_MAP_QR_SEQ As String
Visual C++
public:
static initonly String^ OPM_THICKNESS_MAP_QR_SEQ

See Also

MCitems Structure
MCitems Members


OPTICAL_OPHT_AXL_LEN_MEAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPTICAL_OPHT_AXL_LEN_MEAS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPTICAL_OPHT_AXL_LEN_MEAS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPTICAL_OPHT_AXL_LEN_MEAS
Visual Basic
Public Shared ReadOnly OPTICAL_OPHT_AXL_LEN_MEAS As String
Visual C++
public:
static initonly String^ OPTICAL_OPHT_AXL_LEN_MEAS

See Also

MCitems Structure
MCitems Members


OPTICAL_PATH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPTICAL_PATH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPTICAL_PATH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPTICAL_PATH
Visual Basic
Public Shared ReadOnly OPTICAL_PATH As String
Visual C++
public:
static initonly String^ OPTICAL_PATH

See Also

MCitems Structure
MCitems Members


OPTICAL_PATH_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPTICAL_PATH_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPTICAL_PATH_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPTICAL_PATH_IDENTIFICATION
Visual Basic
Public Shared ReadOnly OPTICAL_PATH_IDENTIFICATION As String
Visual C++
public:
static initonly String^ OPTICAL_PATH_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


OPTICAL_SEL_OPHT_AXL_LEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OPTICAL_SEL_OPHT_AXL_LEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OPTICAL_SEL_OPHT_AXL_LEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPTICAL_SEL_OPHT_AXL_LEN
Visual Basic
Public Shared ReadOnly OPTICAL_SEL_OPHT_AXL_LEN As String
Visual C++
public:
static initonly String^ OPTICAL_SEL_OPHT_AXL_LEN

See Also

MCitems Structure
MCitems Members


ORIGINAL_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ORIGINAL_ATTRIBUTES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ORIGINAL_ATTRIBUTES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ORIGINAL_ATTRIBUTES
Visual Basic
Public Shared ReadOnly ORIGINAL_ATTRIBUTES As String
Visual C++
public:
static initonly String^ ORIGINAL_ATTRIBUTES

See Also

MCitems Structure
MCitems Members


ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP
Visual Basic
Public Shared ReadOnly ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP As String
Visual C++
public:
static initonly String^ ORIGINAL_ATTRIBUTES_IN_STOW_RS_RSP

See Also

MCitems Structure
MCitems Members


ORIGINAL_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ORIGINAL_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ORIGINAL_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ORIGINAL_IMAGE
Visual Basic
Public Shared ReadOnly ORIGINAL_IMAGE As String
Visual C++
public:
static initonly String^ ORIGINAL_IMAGE

See Also

MCitems Structure
MCitems Members


OTHER_FAILURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_FAILURES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_FAILURES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_FAILURES
Visual Basic
Public Shared ReadOnly OTHER_FAILURES As String
Visual C++
public:
static initonly String^ OTHER_FAILURES

See Also

MCitems Structure
MCitems Members


OTHER_MEDIA_AVAILABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_MEDIA_AVAILABLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_MEDIA_AVAILABLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_MEDIA_AVAILABLE
Visual Basic
Public Shared ReadOnly OTHER_MEDIA_AVAILABLE As String
Visual C++
public:
static initonly String^ OTHER_MEDIA_AVAILABLE

See Also

MCitems Structure
MCitems Members


OTHER_PATIENT_IDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_PATIENT_IDS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_PATIENT_IDS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_PATIENT_IDS
Visual Basic
Public Shared ReadOnly OTHER_PATIENT_IDS As String
Visual C++
public:
static initonly String^ OTHER_PATIENT_IDS

See Also

MCitems Structure
MCitems Members


OTHER_PATIENT_IDS_IN_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_PATIENT_IDS_IN_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_PATIENT_IDS_IN_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_PATIENT_IDS_IN_INVENTORY
Visual Basic
Public Shared ReadOnly OTHER_PATIENT_IDS_IN_INVENTORY As String
Visual C++
public:
static initonly String^ OTHER_PATIENT_IDS_IN_INVENTORY

See Also

MCitems Structure
MCitems Members


OTHER_PATIENT_IDS_PAT_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_PATIENT_IDS_PAT_ID Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_PATIENT_IDS_PAT_ID"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_PATIENT_IDS_PAT_ID
Visual Basic
Public Shared ReadOnly OTHER_PATIENT_IDS_PAT_ID As String
Visual C++
public:
static initonly String^ OTHER_PATIENT_IDS_PAT_ID

See Also

MCitems Structure
MCitems Members


OTHER_PATIENT_IDS_UPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OTHER_PATIENT_IDS_UPS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OTHER_PATIENT_IDS_UPS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OTHER_PATIENT_IDS_UPS
Visual Basic
Public Shared ReadOnly OTHER_PATIENT_IDS_UPS As String
Visual C++
public:
static initonly String^ OTHER_PATIENT_IDS_UPS

See Also

MCitems Structure
MCitems Members


OUTLINE_DEFINITION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OUTLINE_DEFINITION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OUTLINE_DEFINITION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OUTLINE_DEFINITION_MACRO
Visual Basic
Public Shared ReadOnly OUTLINE_DEFINITION_MACRO As String
Visual C++
public:
static initonly String^ OUTLINE_DEFINITION_MACRO

See Also

MCitems Structure
MCitems Members


OUTPUT_DESTINATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OUTPUT_DESTINATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OUTPUT_DESTINATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OUTPUT_DESTINATION
Visual Basic
Public Shared ReadOnly OUTPUT_DESTINATION As String
Visual C++
public:
static initonly String^ OUTPUT_DESTINATION

See Also

MCitems Structure
MCitems Members


OUTPUT_DESTINATION_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OUTPUT_DESTINATION_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OUTPUT_DESTINATION_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OUTPUT_DESTINATION_GET
Visual Basic
Public Shared ReadOnly OUTPUT_DESTINATION_GET As String
Visual C++
public:
static initonly String^ OUTPUT_DESTINATION_GET

See Also

MCitems Structure
MCitems Members


OUTPUT_INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OUTPUT_INFORMATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OUTPUT_INFORMATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OUTPUT_INFORMATION
Visual Basic
Public Shared ReadOnly OUTPUT_INFORMATION As String
Visual C++
public:
static initonly String^ OUTPUT_INFORMATION

See Also

MCitems Structure
MCitems Members


OVERLAY_PIXEL_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERLAY_PIXEL_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERLAY_PIXEL_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERLAY_PIXEL_DATA
Visual Basic
Public Shared ReadOnly OVERLAY_PIXEL_DATA As String
Visual C++
public:
static initonly String^ OVERLAY_PIXEL_DATA

See Also

MCitems Structure
MCitems Members


OVERRIDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERRIDE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERRIDE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERRIDE
Visual Basic
Public Shared ReadOnly OVERRIDE As String
Visual C++
public:
static initonly String^ OVERRIDE

See Also

MCitems Structure
MCitems Members


OVERRIDE_IN_RT_BRACHY_SESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERRIDE_IN_RT_BRACHY_SESS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERRIDE_IN_RT_BRACHY_SESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERRIDE_IN_RT_BRACHY_SESS
Visual Basic
Public Shared ReadOnly OVERRIDE_IN_RT_BRACHY_SESS As String
Visual C++
public:
static initonly String^ OVERRIDE_IN_RT_BRACHY_SESS

See Also

MCitems Structure
MCitems Members


OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION
Visual Basic
Public Shared ReadOnly OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION As String
Visual C++
public:
static initonly String^ OVERRIDE_IN_TREATMENT_TOLERATION_VIOLATION

See Also

MCitems Structure
MCitems Members


OVERRIDEN_ATTRIBUTES_NGET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERRIDEN_ATTRIBUTES_NGET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERRIDEN_ATTRIBUTES_NGET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERRIDEN_ATTRIBUTES_NGET
Visual Basic
Public Shared ReadOnly OVERRIDEN_ATTRIBUTES_NGET As String
Visual C++
public:
static initonly String^ OVERRIDEN_ATTRIBUTES_NGET

See Also

MCitems Structure
MCitems Members


OVERRIDEN_ATTRIBUTES_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..OVERRIDEN_ATTRIBUTES_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.OVERRIDEN_ATTRIBUTES_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OVERRIDEN_ATTRIBUTES_SQ
Visual Basic
Public Shared ReadOnly OVERRIDEN_ATTRIBUTES_SQ As String
Visual C++
public:
static initonly String^ OVERRIDEN_ATTRIBUTES_SQ

See Also

MCitems Structure
MCitems Members


PALETTE_COLOR_LOOKUP_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PALETTE_COLOR_LOOKUP_TABLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PALETTE_COLOR_LOOKUP_TABLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PALETTE_COLOR_LOOKUP_TABLE
Visual Basic
Public Shared ReadOnly PALETTE_COLOR_LOOKUP_TABLE As String
Visual C++
public:
static initonly String^ PALETTE_COLOR_LOOKUP_TABLE

See Also

MCitems Structure
MCitems Members


PARALLEL_RT_BEAM_DELIMITER_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PARALLEL_RT_BEAM_DELIMITER_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PARALLEL_RT_BEAM_DELIMITER_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARALLEL_RT_BEAM_DELIMITER_DEVICE
Visual Basic
Public Shared ReadOnly PARALLEL_RT_BEAM_DELIMITER_DEVICE As String
Visual C++
public:
static initonly String^ PARALLEL_RT_BEAM_DELIMITER_DEVICE

See Also

MCitems Structure
MCitems Members


PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO
Visual Basic
Public Shared ReadOnly PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO As String
Visual C++
public:
static initonly String^ PARAMETERIZED_RT_IMAGING_GEOMETRY_MACRO

See Also

MCitems Structure
MCitems Members


PARAMETERS_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PARAMETERS_SPECIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PARAMETERS_SPECIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARAMETERS_SPECIFICATION
Visual Basic
Public Shared ReadOnly PARAMETERS_SPECIFICATION As String
Visual C++
public:
static initonly String^ PARAMETERS_SPECIFICATION

See Also

MCitems Structure
MCitems Members


PARAMETRIC_MAP_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PARAMETRIC_MAP_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PARAMETRIC_MAP_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARAMETRIC_MAP_FRAME_TYPE
Visual Basic
Public Shared ReadOnly PARAMETRIC_MAP_FRAME_TYPE As String
Visual C++
public:
static initonly String^ PARAMETRIC_MAP_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


PARTICIPANT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PARTICIPANT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PARTICIPANT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARTICIPANT
Visual Basic
Public Shared ReadOnly PARTICIPANT As String
Visual C++
public:
static initonly String^ PARTICIPANT

See Also

MCitems Structure
MCitems Members


PATIENT_CLINICAL_TRIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_CLINICAL_TRIAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_CLINICAL_TRIAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_CLINICAL_TRIAL
Visual Basic
Public Shared ReadOnly PATIENT_CLINICAL_TRIAL As String
Visual C++
public:
static initonly String^ PATIENT_CLINICAL_TRIAL

See Also

MCitems Structure
MCitems Members


PATIENT_LOCATION_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_LOCATION_COORDINATES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_LOCATION_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_LOCATION_COORDINATES
Visual Basic
Public Shared ReadOnly PATIENT_LOCATION_COORDINATES As String
Visual C++
public:
static initonly String^ PATIENT_LOCATION_COORDINATES

See Also

MCitems Structure
MCitems Members


PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO
Visual Basic
Public Shared ReadOnly PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO As String
Visual C++
public:
static initonly String^ PATIENT_ORIENTATION_AND_EQUIPMENT_RELATIONSHIP_MACRO

See Also

MCitems Structure
MCitems Members


PATIENT_ORIENTATION_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_ORIENTATION_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_ORIENTATION_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ORIENTATION_CODE
Visual Basic
Public Shared ReadOnly PATIENT_ORIENTATION_CODE As String
Visual C++
public:
static initonly String^ PATIENT_ORIENTATION_CODE

See Also

MCitems Structure
MCitems Members


PATIENT_ORIENTATION_IN_FRAME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_ORIENTATION_IN_FRAME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_ORIENTATION_IN_FRAME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ORIENTATION_IN_FRAME
Visual Basic
Public Shared ReadOnly PATIENT_ORIENTATION_IN_FRAME As String
Visual C++
public:
static initonly String^ PATIENT_ORIENTATION_IN_FRAME

See Also

MCitems Structure
MCitems Members


PATIENT_PHYSIOLOGICAL_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_PHYSIOLOGICAL_STATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_PHYSIOLOGICAL_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_PHYSIOLOGICAL_STATE
Visual Basic
Public Shared ReadOnly PATIENT_PHYSIOLOGICAL_STATE As String
Visual C++
public:
static initonly String^ PATIENT_PHYSIOLOGICAL_STATE

See Also

MCitems Structure
MCitems Members


PATIENT_POSITIONING_INSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_POSITIONING_INSTRUCTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_POSITIONING_INSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_POSITIONING_INSTRUCTION
Visual Basic
Public Shared ReadOnly PATIENT_POSITIONING_INSTRUCTION As String
Visual C++
public:
static initonly String^ PATIENT_POSITIONING_INSTRUCTION

See Also

MCitems Structure
MCitems Members


PATIENT_SETUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SETUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SETUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SETUP
Visual Basic
Public Shared ReadOnly PATIENT_SETUP As String
Visual C++
public:
static initonly String^ PATIENT_SETUP

See Also

MCitems Structure
MCitems Members


PATIENT_SETUP_IN_GEN_MACH_VERIF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SETUP_IN_GEN_MACH_VERIF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SETUP_IN_GEN_MACH_VERIF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SETUP_IN_GEN_MACH_VERIF
Visual Basic
Public Shared ReadOnly PATIENT_SETUP_IN_GEN_MACH_VERIF As String
Visual C++
public:
static initonly String^ PATIENT_SETUP_IN_GEN_MACH_VERIF

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_DEVICES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_DEVICES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_DEVICES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_DEVICES
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_DEVICES As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_DEVICES

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_POSITION
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_POSITION As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_POSITION

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_POSITION_DEVICE_PARAMETER

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_POSITION_DEVICE_TOLERANCE

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_POSITION_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_POSITION_PARAMETER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_POSITION_PARAMETER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_POSITION_PARAMETER
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_POSITION_PARAMETER As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_POSITION_PARAMETER

See Also

MCitems Structure
MCitems Members


PATIENT_SUPPORT_POSITION_TOLERANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_SUPPORT_POSITION_TOLERANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_SUPPORT_POSITION_TOLERANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_SUPPORT_POSITION_TOLERANCE
Visual Basic
Public Shared ReadOnly PATIENT_SUPPORT_POSITION_TOLERANCE As String
Visual C++
public:
static initonly String^ PATIENT_SUPPORT_POSITION_TOLERANCE

See Also

MCitems Structure
MCitems Members


PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO
Visual Basic
Public Shared ReadOnly PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO As String
Visual C++
public:
static initonly String^ PATIENT_TO_EQUIPMENT_RELATIONSHIP_MACRO

See Also

MCitems Structure
MCitems Members


PATIENT_TREATMENT_PREPARATION_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENT_TREATMENT_PREPARATION_PROCEDURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENT_TREATMENT_PREPARATION_PROCEDURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_TREATMENT_PREPARATION_PROCEDURE
Visual Basic
Public Shared ReadOnly PATIENT_TREATMENT_PREPARATION_PROCEDURE As String
Visual C++
public:
static initonly String^ PATIENT_TREATMENT_PREPARATION_PROCEDURE

See Also

MCitems Structure
MCitems Members


PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ PATIENTS_PRIMARY_LANGUAGE_CODE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE
Visual Basic
Public Shared ReadOnly PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE As String
Visual C++
public:
static initonly String^ PATIENTS_PRIMARY_LANGUAGE_CODE_SEQUENCE

See Also

MCitems Structure
MCitems Members


PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ PATIENTS_PRIMARY_LANGUAGE_MODIFIER_CODE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


PER_PROJECTION_ACQUISITION_ANGIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PER_PROJECTION_ACQUISITION_ANGIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PER_PROJECTION_ACQUISITION_ANGIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PER_PROJECTION_ACQUISITION_ANGIO
Visual Basic
Public Shared ReadOnly PER_PROJECTION_ACQUISITION_ANGIO As String
Visual C++
public:
static initonly String^ PER_PROJECTION_ACQUISITION_ANGIO

See Also

MCitems Structure
MCitems Members


PER_PROJECTION_ACQUISITION_TOMO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PER_PROJECTION_ACQUISITION_TOMO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PER_PROJECTION_ACQUISITION_TOMO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PER_PROJECTION_ACQUISITION_TOMO
Visual Basic
Public Shared ReadOnly PER_PROJECTION_ACQUISITION_TOMO As String
Visual C++
public:
static initonly String^ PER_PROJECTION_ACQUISITION_TOMO

See Also

MCitems Structure
MCitems Members


PERFORMED_PROTOCOL_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERFORMED_PROTOCOL_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERFORMED_PROTOCOL_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_PROTOCOL_CODE
Visual Basic
Public Shared ReadOnly PERFORMED_PROTOCOL_CODE As String
Visual C++
public:
static initonly String^ PERFORMED_PROTOCOL_CODE

See Also

MCitems Structure
MCitems Members


PERFORMED_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERFORMED_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERFORMED_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_SERIES
Visual Basic
Public Shared ReadOnly PERFORMED_SERIES As String
Visual C++
public:
static initonly String^ PERFORMED_SERIES

See Also

MCitems Structure
MCitems Members


PERSON_IDENTIFICATION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERSON_IDENTIFICATION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERSON_IDENTIFICATION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERSON_IDENTIFICATION_MACRO
Visual Basic
Public Shared ReadOnly PERSON_IDENTIFICATION_MACRO As String
Visual C++
public:
static initonly String^ PERSON_IDENTIFICATION_MACRO

See Also

MCitems Structure
MCitems Members


PERTINENT_DOCUMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERTINENT_DOCUMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERTINENT_DOCUMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERTINENT_DOCUMENTS
Visual Basic
Public Shared ReadOnly PERTINENT_DOCUMENTS As String
Visual C++
public:
static initonly String^ PERTINENT_DOCUMENTS

See Also

MCitems Structure
MCitems Members


PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO
Visual Basic
Public Shared ReadOnly PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO As String
Visual C++
public:
static initonly String^ PERTINENT_DOCUMENTS_IN_ASSERTION_MACRO

See Also

MCitems Structure
MCitems Members


PERTINENT_DOCUMENTS_IN_SUBSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERTINENT_DOCUMENTS_IN_SUBSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERTINENT_DOCUMENTS_IN_SUBSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERTINENT_DOCUMENTS_IN_SUBSTANCE
Visual Basic
Public Shared ReadOnly PERTINENT_DOCUMENTS_IN_SUBSTANCE As String
Visual C++
public:
static initonly String^ PERTINENT_DOCUMENTS_IN_SUBSTANCE

See Also

MCitems Structure
MCitems Members


PERTINENT_DOCUMENTS_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERTINENT_DOCUMENTS_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERTINENT_DOCUMENTS_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERTINENT_DOCUMENTS_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly PERTINENT_DOCUMENTS_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ PERTINENT_DOCUMENTS_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


PERTINENT_RESOURCES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PERTINENT_RESOURCES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PERTINENT_RESOURCES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERTINENT_RESOURCES
Visual Basic
Public Shared ReadOnly PERTINENT_RESOURCES As String
Visual C++
public:
static initonly String^ PERTINENT_RESOURCES

See Also

MCitems Structure
MCitems Members


PET_DETECTOR_MOTION_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_DETECTOR_MOTION_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_DETECTOR_MOTION_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_DETECTOR_MOTION_DETAILS
Visual Basic
Public Shared ReadOnly PET_DETECTOR_MOTION_DETAILS As String
Visual C++
public:
static initonly String^ PET_DETECTOR_MOTION_DETAILS

See Also

MCitems Structure
MCitems Members


PET_FRAME_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_FRAME_ACQUISITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_FRAME_ACQUISITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_FRAME_ACQUISITION
Visual Basic
Public Shared ReadOnly PET_FRAME_ACQUISITION As String
Visual C++
public:
static initonly String^ PET_FRAME_ACQUISITION

See Also

MCitems Structure
MCitems Members


PET_FRAME_CORRECTION_FACTORS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_FRAME_CORRECTION_FACTORS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_FRAME_CORRECTION_FACTORS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_FRAME_CORRECTION_FACTORS
Visual Basic
Public Shared ReadOnly PET_FRAME_CORRECTION_FACTORS As String
Visual C++
public:
static initonly String^ PET_FRAME_CORRECTION_FACTORS

See Also

MCitems Structure
MCitems Members


PET_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_FRAME_TYPE
Visual Basic
Public Shared ReadOnly PET_FRAME_TYPE As String
Visual C++
public:
static initonly String^ PET_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


PET_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_POSITION
Visual Basic
Public Shared ReadOnly PET_POSITION As String
Visual C++
public:
static initonly String^ PET_POSITION

See Also

MCitems Structure
MCitems Members


PET_RECONSTRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_RECONSTRACTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_RECONSTRACTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_RECONSTRACTION
Visual Basic
Public Shared ReadOnly PET_RECONSTRACTION As String
Visual C++
public:
static initonly String^ PET_RECONSTRACTION

See Also

MCitems Structure
MCitems Members


PET_TABLE_DYNAMICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PET_TABLE_DYNAMICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PET_TABLE_DYNAMICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PET_TABLE_DYNAMICS
Visual Basic
Public Shared ReadOnly PET_TABLE_DYNAMICS As String
Visual C++
public:
static initonly String^ PET_TABLE_DYNAMICS

See Also

MCitems Structure
MCitems Members


PHASE_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PHASE_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PHASE_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PHASE_INFO
Visual Basic
Public Shared ReadOnly PHASE_INFO As String
Visual C++
public:
static initonly String^ PHASE_INFO

See Also

MCitems Structure
MCitems Members


PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ PHOTOACOUSTIC_EXCITATION_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


PHOTOACOUSTIC_IMAGE_DATA_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PHOTOACOUSTIC_IMAGE_DATA_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PHOTOACOUSTIC_IMAGE_DATA_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PHOTOACOUSTIC_IMAGE_DATA_TYPE
Visual Basic
Public Shared ReadOnly PHOTOACOUSTIC_IMAGE_DATA_TYPE As String
Visual C++
public:
static initonly String^ PHOTOACOUSTIC_IMAGE_DATA_TYPE

See Also

MCitems Structure
MCitems Members


PHOTOACOUSTIC_IMAGE_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PHOTOACOUSTIC_IMAGE_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PHOTOACOUSTIC_IMAGE_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PHOTOACOUSTIC_IMAGE_FRAME_TYPE
Visual Basic
Public Shared ReadOnly PHOTOACOUSTIC_IMAGE_FRAME_TYPE As String
Visual C++
public:
static initonly String^ PHOTOACOUSTIC_IMAGE_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


PIXEL_INTENSITY_RELATIONSHIP_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_INTENSITY_RELATIONSHIP_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_INTENSITY_RELATIONSHIP_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_INTENSITY_RELATIONSHIP_LUT
Visual Basic
Public Shared ReadOnly PIXEL_INTENSITY_RELATIONSHIP_LUT As String
Visual C++
public:
static initonly String^ PIXEL_INTENSITY_RELATIONSHIP_LUT

See Also

MCitems Structure
MCitems Members


PIXEL_MEASURES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_MEASURES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_MEASURES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_MEASURES
Visual Basic
Public Shared ReadOnly PIXEL_MEASURES As String
Visual C++
public:
static initonly String^ PIXEL_MEASURES

See Also

MCitems Structure
MCitems Members


PIXEL_SPACING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_SPACING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_SPACING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_SPACING
Visual Basic
Public Shared ReadOnly PIXEL_SPACING As String
Visual C++
public:
static initonly String^ PIXEL_SPACING

See Also

MCitems Structure
MCitems Members


PIXEL_VALUE_MAP_TO_CODED_CONCEPT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_VALUE_MAP_TO_CODED_CONCEPT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_VALUE_MAP_TO_CODED_CONCEPT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_VALUE_MAP_TO_CODED_CONCEPT
Visual Basic
Public Shared ReadOnly PIXEL_VALUE_MAP_TO_CODED_CONCEPT As String
Visual C++
public:
static initonly String^ PIXEL_VALUE_MAP_TO_CODED_CONCEPT

See Also

MCitems Structure
MCitems Members


PIXEL_VALUE_TRANSFORM_WITH_EV Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_VALUE_TRANSFORM_WITH_EV Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_VALUE_TRANSFORM_WITH_EV"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_VALUE_TRANSFORM_WITH_EV
Visual Basic
Public Shared ReadOnly PIXEL_VALUE_TRANSFORM_WITH_EV As String
Visual C++
public:
static initonly String^ PIXEL_VALUE_TRANSFORM_WITH_EV

See Also

MCitems Structure
MCitems Members


PIXEL_VALUE_TRANSFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PIXEL_VALUE_TRANSFORMATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PIXEL_VALUE_TRANSFORMATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PIXEL_VALUE_TRANSFORMATION
Visual Basic
Public Shared ReadOnly PIXEL_VALUE_TRANSFORMATION As String
Visual C++
public:
static initonly String^ PIXEL_VALUE_TRANSFORMATION

See Also

MCitems Structure
MCitems Members


PLAN_OVERVIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLAN_OVERVIEW Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLAN_OVERVIEW"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLAN_OVERVIEW
Visual Basic
Public Shared ReadOnly PLAN_OVERVIEW As String
Visual C++
public:
static initonly String^ PLAN_OVERVIEW

See Also

MCitems Structure
MCitems Members


PLANE_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANE_ORIENTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANE_ORIENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANE_ORIENTATION
Visual Basic
Public Shared ReadOnly PLANE_ORIENTATION As String
Visual C++
public:
static initonly String^ PLANE_ORIENTATION

See Also

MCitems Structure
MCitems Members


PLANE_ORIENTATION_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANE_ORIENTATION_VOLUME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANE_ORIENTATION_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANE_ORIENTATION_VOLUME
Visual Basic
Public Shared ReadOnly PLANE_ORIENTATION_VOLUME As String
Visual C++
public:
static initonly String^ PLANE_ORIENTATION_VOLUME

See Also

MCitems Structure
MCitems Members


PLANE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANE_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANE_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANE_POSITION
Visual Basic
Public Shared ReadOnly PLANE_POSITION As String
Visual C++
public:
static initonly String^ PLANE_POSITION

See Also

MCitems Structure
MCitems Members


PLANE_POSITION_SLIDE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANE_POSITION_SLIDE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANE_POSITION_SLIDE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANE_POSITION_SLIDE
Visual Basic
Public Shared ReadOnly PLANE_POSITION_SLIDE As String
Visual C++
public:
static initonly String^ PLANE_POSITION_SLIDE

See Also

MCitems Structure
MCitems Members


PLANE_POSITION_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANE_POSITION_VOLUME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANE_POSITION_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANE_POSITION_VOLUME
Visual Basic
Public Shared ReadOnly PLANE_POSITION_VOLUME As String
Visual C++
public:
static initonly String^ PLANE_POSITION_VOLUME

See Also

MCitems Structure
MCitems Members


PLANNED_VERIFICATION_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANNED_VERIFICATION_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANNED_VERIFICATION_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANNED_VERIFICATION_IMAGE
Visual Basic
Public Shared ReadOnly PLANNED_VERIFICATION_IMAGE As String
Visual C++
public:
static initonly String^ PLANNED_VERIFICATION_IMAGE

See Also

MCitems Structure
MCitems Members


PLANNING_LANDMARK_LINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANNING_LANDMARK_LINE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANNING_LANDMARK_LINE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANNING_LANDMARK_LINE
Visual Basic
Public Shared ReadOnly PLANNING_LANDMARK_LINE As String
Visual C++
public:
static initonly String^ PLANNING_LANDMARK_LINE

See Also

MCitems Structure
MCitems Members


PLANNING_LANDMARK_PLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANNING_LANDMARK_PLANE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANNING_LANDMARK_PLANE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANNING_LANDMARK_PLANE
Visual Basic
Public Shared ReadOnly PLANNING_LANDMARK_PLANE As String
Visual C++
public:
static initonly String^ PLANNING_LANDMARK_PLANE

See Also

MCitems Structure
MCitems Members


PLANNING_LANDMARK_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PLANNING_LANDMARK_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PLANNING_LANDMARK_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANNING_LANDMARK_POINT
Visual Basic
Public Shared ReadOnly PLANNING_LANDMARK_POINT As String
Visual C++
public:
static initonly String^ PLANNING_LANDMARK_POINT

See Also

MCitems Structure
MCitems Members


POINTS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..POINTS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.POINTS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string POINTS_MACRO
Visual Basic
Public Shared ReadOnly POINTS_MACRO As String
Visual C++
public:
static initonly String^ POINTS_MACRO

See Also

MCitems Structure
MCitems Members


POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION
Visual Basic
Public Shared ReadOnly POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION As String
Visual C++
public:
static initonly String^ POSITION_ACQUISITION_TEMPLATE_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


POSITIONER_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..POSITIONER_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.POSITIONER_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string POSITIONER_POSITION
Visual Basic
Public Shared ReadOnly POSITIONER_POSITION As String
Visual C++
public:
static initonly String^ POSITIONER_POSITION

See Also

MCitems Structure
MCitems Members


POST_DEFORMATION_MATRIX_REG Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..POST_DEFORMATION_MATRIX_REG Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.POST_DEFORMATION_MATRIX_REG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string POST_DEFORMATION_MATRIX_REG
Visual Basic
Public Shared ReadOnly POST_DEFORMATION_MATRIX_REG As String
Visual C++
public:
static initonly String^ POST_DEFORMATION_MATRIX_REG

See Also

MCitems Structure
MCitems Members


PRE_DEFORMATION_MATRIX_REG Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRE_DEFORMATION_MATRIX_REG Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRE_DEFORMATION_MATRIX_REG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRE_DEFORMATION_MATRIX_REG
Visual Basic
Public Shared ReadOnly PRE_DEFORMATION_MATRIX_REG As String
Visual C++
public:
static initonly String^ PRE_DEFORMATION_MATRIX_REG

See Also

MCitems Structure
MCitems Members


PREFORMATTED_COLOR_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PREFORMATTED_COLOR_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PREFORMATTED_COLOR_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PREFORMATTED_COLOR_IMAGE
Visual Basic
Public Shared ReadOnly PREFORMATTED_COLOR_IMAGE As String
Visual C++
public:
static initonly String^ PREFORMATTED_COLOR_IMAGE

See Also

MCitems Structure
MCitems Members


PREFORMATTED_GRAYSCALE_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PREFORMATTED_GRAYSCALE_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PREFORMATTED_GRAYSCALE_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PREFORMATTED_GRAYSCALE_IMAGE
Visual Basic
Public Shared ReadOnly PREFORMATTED_GRAYSCALE_IMAGE As String
Visual C++
public:
static initonly String^ PREFORMATTED_GRAYSCALE_IMAGE

See Also

MCitems Structure
MCitems Members


PRESCRIPTION_OVERVIEW Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRESCRIPTION_OVERVIEW Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRESCRIPTION_OVERVIEW"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESCRIPTION_OVERVIEW
Visual Basic
Public Shared ReadOnly PRESCRIPTION_OVERVIEW As String
Visual C++
public:
static initonly String^ PRESCRIPTION_OVERVIEW

See Also

MCitems Structure
MCitems Members


PRESENTATION_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRESENTATION_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRESENTATION_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESENTATION_LUT
Visual Basic
Public Shared ReadOnly PRESENTATION_LUT As String
Visual C++
public:
static initonly String^ PRESENTATION_LUT

See Also

MCitems Structure
MCitems Members


PRESENTATION_LUT_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRESENTATION_LUT_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRESENTATION_LUT_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESENTATION_LUT_CONTENT
Visual Basic
Public Shared ReadOnly PRESENTATION_LUT_CONTENT As String
Visual C++
public:
static initonly String^ PRESENTATION_LUT_CONTENT

See Also

MCitems Structure
MCitems Members


PRESENTATION_STATE_CLASSIFICATION_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRESENTATION_STATE_CLASSIFICATION_COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRESENTATION_STATE_CLASSIFICATION_COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESENTATION_STATE_CLASSIFICATION_COMPONENT
Visual Basic
Public Shared ReadOnly PRESENTATION_STATE_CLASSIFICATION_COMPONENT As String
Visual C++
public:
static initonly String^ PRESENTATION_STATE_CLASSIFICATION_COMPONENT

See Also

MCitems Structure
MCitems Members


PRESENTATION_STATE_COMPOSITOR_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRESENTATION_STATE_COMPOSITOR_COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRESENTATION_STATE_COMPOSITOR_COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESENTATION_STATE_COMPOSITOR_COMPONENT
Visual Basic
Public Shared ReadOnly PRESENTATION_STATE_COMPOSITOR_COMPONENT As String
Visual C++
public:
static initonly String^ PRESENTATION_STATE_COMPOSITOR_COMPONENT

See Also

MCitems Structure
MCitems Members


PRIMARY_ANATOMIC_STRUCTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIMARY_ANATOMIC_STRUCTURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIMARY_ANATOMIC_STRUCTURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIMARY_ANATOMIC_STRUCTURE
Visual Basic
Public Shared ReadOnly PRIMARY_ANATOMIC_STRUCTURE As String
Visual C++
public:
static initonly String^ PRIMARY_ANATOMIC_STRUCTURE

See Also

MCitems Structure
MCitems Members


PRIMARY_FLUENCE_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIMARY_FLUENCE_MODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIMARY_FLUENCE_MODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIMARY_FLUENCE_MODE
Visual Basic
Public Shared ReadOnly PRIMARY_FLUENCE_MODE As String
Visual C++
public:
static initonly String^ PRIMARY_FLUENCE_MODE

See Also

MCitems Structure
MCitems Members


PRIMITIVE_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIMITIVE_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIMITIVE_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIMITIVE_POINT
Visual Basic
Public Shared ReadOnly PRIMITIVE_POINT As String
Visual C++
public:
static initonly String^ PRIMITIVE_POINT

See Also

MCitems Structure
MCitems Members


PRIMITIVE_POINT_CP1365 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIMITIVE_POINT_CP1365 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIMITIVE_POINT_CP1365"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIMITIVE_POINT_CP1365
Visual Basic
Public Shared ReadOnly PRIMITIVE_POINT_CP1365 As String
Visual C++
public:
static initonly String^ PRIMITIVE_POINT_CP1365

See Also

MCitems Structure
MCitems Members


PRINT_JOB_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRINT_JOB_DESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRINT_JOB_DESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINT_JOB_DESCRIPTION
Visual Basic
Public Shared ReadOnly PRINT_JOB_DESCRIPTION As String
Visual C++
public:
static initonly String^ PRINT_JOB_DESCRIPTION

See Also

MCitems Structure
MCitems Members


PRINT_MANAGEMENT_CAPABILITIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRINT_MANAGEMENT_CAPABILITIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRINT_MANAGEMENT_CAPABILITIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINT_MANAGEMENT_CAPABILITIES
Visual Basic
Public Shared ReadOnly PRINT_MANAGEMENT_CAPABILITIES As String
Visual C++
public:
static initonly String^ PRINT_MANAGEMENT_CAPABILITIES

See Also

MCitems Structure
MCitems Members


PRINTER_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRINTER_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRINTER_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINTER_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly PRINTER_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ PRINTER_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


PRINTER_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRINTER_CONFIGURATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRINTER_CONFIGURATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINTER_CONFIGURATION
Visual Basic
Public Shared ReadOnly PRINTER_CONFIGURATION As String
Visual C++
public:
static initonly String^ PRINTER_CONFIGURATION

See Also

MCitems Structure
MCitems Members


PRISM_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRISM_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRISM_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRISM_SQ
Visual Basic
Public Shared ReadOnly PRISM_SQ As String
Visual C++
public:
static initonly String^ PRISM_SQ

See Also

MCitems Structure
MCitems Members


PRIVATE_DATA_ELEMENT_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIVATE_DATA_ELEMENT_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIVATE_DATA_ELEMENT_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIVATE_DATA_ELEMENT_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly PRIVATE_DATA_ELEMENT_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ PRIVATE_DATA_ELEMENT_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


PRIVATE_DATA_ELEMENT_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PRIVATE_DATA_ELEMENT_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PRIVATE_DATA_ELEMENT_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRIVATE_DATA_ELEMENT_DEFINITION
Visual Basic
Public Shared ReadOnly PRIVATE_DATA_ELEMENT_DEFINITION As String
Visual C++
public:
static initonly String^ PRIVATE_DATA_ELEMENT_DEFINITION

See Also

MCitems Structure
MCitems Members


PROCEDURE_STEP_PROGRESS_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROCEDURE_STEP_PROGRESS_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROCEDURE_STEP_PROGRESS_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURE_STEP_PROGRESS_PARAMETERS
Visual Basic
Public Shared ReadOnly PROCEDURE_STEP_PROGRESS_PARAMETERS As String
Visual C++
public:
static initonly String^ PROCEDURE_STEP_PROGRESS_PARAMETERS

See Also

MCitems Structure
MCitems Members


PROCEDURE_STEP_PROGRESS_PARAMETERS_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROCEDURE_STEP_PROGRESS_PARAMETERS_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROCEDURE_STEP_PROGRESS_PARAMETERS_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURE_STEP_PROGRESS_PARAMETERS_GET
Visual Basic
Public Shared ReadOnly PROCEDURE_STEP_PROGRESS_PARAMETERS_GET As String
Visual C++
public:
static initonly String^ PROCEDURE_STEP_PROGRESS_PARAMETERS_GET

See Also

MCitems Structure
MCitems Members


PROCEDURE_STEP_PROGRESS_PARAMETERS_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROCEDURE_STEP_PROGRESS_PARAMETERS_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROCEDURE_STEP_PROGRESS_PARAMETERS_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURE_STEP_PROGRESS_PARAMETERS_SET
Visual Basic
Public Shared ReadOnly PROCEDURE_STEP_PROGRESS_PARAMETERS_SET As String
Visual C++
public:
static initonly String^ PROCEDURE_STEP_PROGRESS_PARAMETERS_SET

See Also

MCitems Structure
MCitems Members


PROCEDURE_TYPE_CODE_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROCEDURE_TYPE_CODE_QUERY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROCEDURE_TYPE_CODE_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURE_TYPE_CODE_QUERY
Visual Basic
Public Shared ReadOnly PROCEDURE_TYPE_CODE_QUERY As String
Visual C++
public:
static initonly String^ PROCEDURE_TYPE_CODE_QUERY

See Also

MCitems Structure
MCitems Members


PROJECTION_IMAGING_ACQUISITION_PARAMETER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROJECTION_IMAGING_ACQUISITION_PARAMETER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROJECTION_IMAGING_ACQUISITION_PARAMETER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROJECTION_IMAGING_ACQUISITION_PARAMETER
Visual Basic
Public Shared ReadOnly PROJECTION_IMAGING_ACQUISITION_PARAMETER As String
Visual C++
public:
static initonly String^ PROJECTION_IMAGING_ACQUISITION_PARAMETER

See Also

MCitems Structure
MCitems Members


PROJECTION_PIXEL_CALIBRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROJECTION_PIXEL_CALIBRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROJECTION_PIXEL_CALIBRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROJECTION_PIXEL_CALIBRATION
Visual Basic
Public Shared ReadOnly PROJECTION_PIXEL_CALIBRATION As String
Visual C++
public:
static initonly String^ PROJECTION_PIXEL_CALIBRATION

See Also

MCitems Structure
MCitems Members


PROPOSED_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROPOSED_STUDY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROPOSED_STUDY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROPOSED_STUDY
Visual Basic
Public Shared ReadOnly PROPOSED_STUDY As String
Visual C++
public:
static initonly String^ PROPOSED_STUDY

See Also

MCitems Structure
MCitems Members


PROTOCOL_CONTEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROTOCOL_CONTEXT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROTOCOL_CONTEXT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_CONTEXT
Visual Basic
Public Shared ReadOnly PROTOCOL_CONTEXT As String
Visual C++
public:
static initonly String^ PROTOCOL_CONTEXT

See Also

MCitems Structure
MCitems Members


PROTOCOL_CONTEXT_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PROTOCOL_CONTEXT_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PROTOCOL_CONTEXT_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_CONTEXT_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly PROTOCOL_CONTEXT_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ PROTOCOL_CONTEXT_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED
Visual Basic
Public Shared ReadOnly PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED As String
Visual C++
public:
static initonly String^ PULSE_SPECIFIC_BRACHY_CONTROL_POINT_DELIVERED

See Also

MCitems Structure
MCitems Members


PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ PURPOSE_OF_REFERENCE_CODE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


QA_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..QA_RESULTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.QA_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string QA_RESULTS
Visual Basic
Public Shared ReadOnly QA_RESULTS As String
Visual C++
public:
static initonly String^ QA_RESULTS

See Also

MCitems Structure
MCitems Members


QA_RESULTS_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..QA_RESULTS_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.QA_RESULTS_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string QA_RESULTS_SCP
Visual Basic
Public Shared ReadOnly QA_RESULTS_SCP As String
Visual C++
public:
static initonly String^ QA_RESULTS_SCP

See Also

MCitems Structure
MCitems Members


QA_RESULTS_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..QA_RESULTS_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.QA_RESULTS_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string QA_RESULTS_SCU
Visual Basic
Public Shared ReadOnly QA_RESULTS_SCU As String
Visual C++
public:
static initonly String^ QA_RESULTS_SCU

See Also

MCitems Structure
MCitems Members


QUANTITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..QUANTITY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.QUANTITY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string QUANTITY
Visual Basic
Public Shared ReadOnly QUANTITY As String
Visual C++
public:
static initonly String^ QUANTITY

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE
Visual Basic
Public Shared ReadOnly RADIATION_DOSE As String
Visual C++
public:
static initonly String^ RADIATION_DOSE

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE_IDENTIFICATION
Visual Basic
Public Shared ReadOnly RADIATION_DOSE_IDENTIFICATION As String
Visual C++
public:
static initonly String^ RADIATION_DOSE_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD
Visual Basic
Public Shared ReadOnly RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD As String
Visual C++
public:
static initonly String^ RADIATION_DOSE_IDENTIFICATION_IN_RT_DOSE_CONTRIB_RECORD

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD
Visual Basic
Public Shared ReadOnly RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD As String
Visual C++
public:
static initonly String^ RADIATION_DOSE_IN_RT_DOSE_CONTRIB_RECORD

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE_VALUES_PARAMETERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE_VALUES_PARAMETERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE_VALUES_PARAMETERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE_VALUES_PARAMETERS
Visual Basic
Public Shared ReadOnly RADIATION_DOSE_VALUES_PARAMETERS As String
Visual C++
public:
static initonly String^ RADIATION_DOSE_VALUES_PARAMETERS

See Also

MCitems Structure
MCitems Members


RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD
Visual Basic
Public Shared ReadOnly RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD As String
Visual C++
public:
static initonly String^ RADIATION_DOSE_VALUES_PARAMS_IN_RT_DOSE_CONTRIB_RECORD

See Also

MCitems Structure
MCitems Members


RADIATION_GENERATION_MODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_GENERATION_MODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_GENERATION_MODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_GENERATION_MODE
Visual Basic
Public Shared ReadOnly RADIATION_GENERATION_MODE As String
Visual C++
public:
static initonly String^ RADIATION_GENERATION_MODE

See Also

MCitems Structure
MCitems Members


RADIATION_GENERATION_MODE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIATION_GENERATION_MODE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIATION_GENERATION_MODE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIATION_GENERATION_MODE_MACRO
Visual Basic
Public Shared ReadOnly RADIATION_GENERATION_MODE_MACRO As String
Visual C++
public:
static initonly String^ RADIATION_GENERATION_MODE_MACRO

See Also

MCitems Structure
MCitems Members


RADIOBIOLOGICAL_DOSE_EFFECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIOBIOLOGICAL_DOSE_EFFECT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIOBIOLOGICAL_DOSE_EFFECT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOBIOLOGICAL_DOSE_EFFECT
Visual Basic
Public Shared ReadOnly RADIOBIOLOGICAL_DOSE_EFFECT As String
Visual C++
public:
static initonly String^ RADIOBIOLOGICAL_DOSE_EFFECT

See Also

MCitems Structure
MCitems Members


RADIOPHARM_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIOPHARM_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIOPHARM_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOPHARM_INFO
Visual Basic
Public Shared ReadOnly RADIOPHARM_INFO As String
Visual C++
public:
static initonly String^ RADIOPHARM_INFO

See Also

MCitems Structure
MCitems Members


RADIOPHARM_INFO_ENH_PET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIOPHARM_INFO_ENH_PET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIOPHARM_INFO_ENH_PET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOPHARM_INFO_ENH_PET
Visual Basic
Public Shared ReadOnly RADIOPHARM_INFO_ENH_PET As String
Visual C++
public:
static initonly String^ RADIOPHARM_INFO_ENH_PET

See Also

MCitems Structure
MCitems Members


RADIOPHARM_INFO_PET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIOPHARM_INFO_PET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIOPHARM_INFO_PET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOPHARM_INFO_PET
Visual Basic
Public Shared ReadOnly RADIOPHARM_INFO_PET As String
Visual C++
public:
static initonly String^ RADIOPHARM_INFO_PET

See Also

MCitems Structure
MCitems Members


RADIOPHARM_USAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RADIOPHARM_USAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RADIOPHARM_USAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOPHARM_USAGE
Visual Basic
Public Shared ReadOnly RADIOPHARM_USAGE As String
Visual C++
public:
static initonly String^ RADIOPHARM_USAGE

See Also

MCitems Structure
MCitems Members


RANGE_MODULATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RANGE_MODULATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RANGE_MODULATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RANGE_MODULATOR
Visual Basic
Public Shared ReadOnly RANGE_MODULATOR As String
Visual C++
public:
static initonly String^ RANGE_MODULATOR

See Also

MCitems Structure
MCitems Members


RANGE_MODULATOR_SETTINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RANGE_MODULATOR_SETTINGS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RANGE_MODULATOR_SETTINGS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RANGE_MODULATOR_SETTINGS
Visual Basic
Public Shared ReadOnly RANGE_MODULATOR_SETTINGS As String
Visual C++
public:
static initonly String^ RANGE_MODULATOR_SETTINGS

See Also

MCitems Structure
MCitems Members


RANGE_SHIFTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RANGE_SHIFTER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RANGE_SHIFTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RANGE_SHIFTER
Visual Basic
Public Shared ReadOnly RANGE_SHIFTER As String
Visual C++
public:
static initonly String^ RANGE_SHIFTER

See Also

MCitems Structure
MCitems Members


RANGE_SHIFTER_SETTINGS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RANGE_SHIFTER_SETTINGS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RANGE_SHIFTER_SETTINGS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RANGE_SHIFTER_SETTINGS
Visual Basic
Public Shared ReadOnly RANGE_SHIFTER_SETTINGS As String
Visual C++
public:
static initonly String^ RANGE_SHIFTER_SETTINGS

See Also

MCitems Structure
MCitems Members


REAL_TIME_BULK_DATA_FLOW Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REAL_TIME_BULK_DATA_FLOW Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REAL_TIME_BULK_DATA_FLOW"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REAL_TIME_BULK_DATA_FLOW
Visual Basic
Public Shared ReadOnly REAL_TIME_BULK_DATA_FLOW As String
Visual C++
public:
static initonly String^ REAL_TIME_BULK_DATA_FLOW

See Also

MCitems Structure
MCitems Members


REAL_WORLD_VALUE_MAP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REAL_WORLD_VALUE_MAP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REAL_WORLD_VALUE_MAP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REAL_WORLD_VALUE_MAP_MACRO
Visual Basic
Public Shared ReadOnly REAL_WORLD_VALUE_MAP_MACRO As String
Visual C++
public:
static initonly String^ REAL_WORLD_VALUE_MAP_MACRO

See Also

MCitems Structure
MCitems Members


REAL_WORLD_VALUE_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REAL_WORLD_VALUE_MAPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REAL_WORLD_VALUE_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REAL_WORLD_VALUE_MAPPING
Visual Basic
Public Shared ReadOnly REAL_WORLD_VALUE_MAPPING As String
Visual C++
public:
static initonly String^ REAL_WORLD_VALUE_MAPPING

See Also

MCitems Structure
MCitems Members


RECONSTRUCTION_PROTOCOL_ELEMENT_CT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECONSTRUCTION_PROTOCOL_ELEMENT_CT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECONSTRUCTION_PROTOCOL_ELEMENT_CT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECONSTRUCTION_PROTOCOL_ELEMENT_CT
Visual Basic
Public Shared ReadOnly RECONSTRUCTION_PROTOCOL_ELEMENT_CT As String
Visual C++
public:
static initonly String^ RECONSTRUCTION_PROTOCOL_ELEMENT_CT

See Also

MCitems Structure
MCitems Members


RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION
Visual Basic
Public Shared ReadOnly RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION As String
Visual C++
public:
static initonly String^ RECONSTRUCTION_PROTOCOL_ELEMENT_SPECIFICATION

See Also

MCitems Structure
MCitems Members


RECONSTRUCTION_PROTOCOL_ELEMENT_XA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECONSTRUCTION_PROTOCOL_ELEMENT_XA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECONSTRUCTION_PROTOCOL_ELEMENT_XA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECONSTRUCTION_PROTOCOL_ELEMENT_XA
Visual Basic
Public Shared ReadOnly RECONSTRUCTION_PROTOCOL_ELEMENT_XA As String
Visual C++
public:
static initonly String^ RECONSTRUCTION_PROTOCOL_ELEMENT_XA

See Also

MCitems Structure
MCitems Members


RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ
Visual Basic
Public Shared ReadOnly RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ As String
Visual C++
public:
static initonly String^ RECORDED_BLOCK_IN_GENERAL_MACHINE_VERIF_SQ

See Also

MCitems Structure
MCitems Members


RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ
Visual Basic
Public Shared ReadOnly RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ As String
Visual C++
public:
static initonly String^ RECORDED_BLOCK_IN_TREATMENT_SESSION_BEAM_SQ

See Also

MCitems Structure
MCitems Members


RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ
Visual Basic
Public Shared ReadOnly RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ As String
Visual C++
public:
static initonly String^ RECORDED_BLOCK_IN_TREATMENT_SESSION_ION_BEAM_SQ

See Also

MCitems Structure
MCitems Members


RECORDED_BLOCK_SLAB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_BLOCK_SLAB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_BLOCK_SLAB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_BLOCK_SLAB
Visual Basic
Public Shared ReadOnly RECORDED_BLOCK_SLAB As String
Visual C++
public:
static initonly String^ RECORDED_BLOCK_SLAB

See Also

MCitems Structure
MCitems Members


RECORDED_BRACHY_ACCESSORY_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_BRACHY_ACCESSORY_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_BRACHY_ACCESSORY_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_BRACHY_ACCESSORY_DEVICE
Visual Basic
Public Shared ReadOnly RECORDED_BRACHY_ACCESSORY_DEVICE As String
Visual C++
public:
static initonly String^ RECORDED_BRACHY_ACCESSORY_DEVICE

See Also

MCitems Structure
MCitems Members


RECORDED_CHANNEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_CHANNEL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_CHANNEL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_CHANNEL
Visual Basic
Public Shared ReadOnly RECORDED_CHANNEL As String
Visual C++
public:
static initonly String^ RECORDED_CHANNEL

See Also

MCitems Structure
MCitems Members


RECORDED_CHANNEL_SHIELD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_CHANNEL_SHIELD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_CHANNEL_SHIELD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_CHANNEL_SHIELD
Visual Basic
Public Shared ReadOnly RECORDED_CHANNEL_SHIELD As String
Visual C++
public:
static initonly String^ RECORDED_CHANNEL_SHIELD

See Also

MCitems Structure
MCitems Members


RECORDED_COMPENSATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_COMPENSATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_COMPENSATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_COMPENSATOR
Visual Basic
Public Shared ReadOnly RECORDED_COMPENSATOR As String
Visual C++
public:
static initonly String^ RECORDED_COMPENSATOR

See Also

MCitems Structure
MCitems Members


RECORDED_COMPENSATOR_IN_GEN_MV Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_COMPENSATOR_IN_GEN_MV Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_COMPENSATOR_IN_GEN_MV"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_COMPENSATOR_IN_GEN_MV
Visual Basic
Public Shared ReadOnly RECORDED_COMPENSATOR_IN_GEN_MV As String
Visual C++
public:
static initonly String^ RECORDED_COMPENSATOR_IN_GEN_MV

See Also

MCitems Structure
MCitems Members


RECORDED_COMPENSATOR_IN_ION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_COMPENSATOR_IN_ION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_COMPENSATOR_IN_ION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_COMPENSATOR_IN_ION
Visual Basic
Public Shared ReadOnly RECORDED_COMPENSATOR_IN_ION As String
Visual C++
public:
static initonly String^ RECORDED_COMPENSATOR_IN_ION

See Also

MCitems Structure
MCitems Members


RECORDED_LATERAL_SPREADING_DEV Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_LATERAL_SPREADING_DEV Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_LATERAL_SPREADING_DEV"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_LATERAL_SPREADING_DEV
Visual Basic
Public Shared ReadOnly RECORDED_LATERAL_SPREADING_DEV As String
Visual C++
public:
static initonly String^ RECORDED_LATERAL_SPREADING_DEV

See Also

MCitems Structure
MCitems Members


RECORDED_RANGE_MODULATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_RANGE_MODULATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_RANGE_MODULATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_RANGE_MODULATOR
Visual Basic
Public Shared ReadOnly RECORDED_RANGE_MODULATOR As String
Visual C++
public:
static initonly String^ RECORDED_RANGE_MODULATOR

See Also

MCitems Structure
MCitems Members


RECORDED_RANGE_SHIFTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_RANGE_SHIFTER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_RANGE_SHIFTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_RANGE_SHIFTER
Visual Basic
Public Shared ReadOnly RECORDED_RANGE_SHIFTER As String
Visual C++
public:
static initonly String^ RECORDED_RANGE_SHIFTER

See Also

MCitems Structure
MCitems Members


RECORDED_SNOUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_SNOUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_SNOUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_SNOUT
Visual Basic
Public Shared ReadOnly RECORDED_SNOUT As String
Visual C++
public:
static initonly String^ RECORDED_SNOUT

See Also

MCitems Structure
MCitems Members


RECORDED_SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_SOURCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_SOURCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_SOURCE
Visual Basic
Public Shared ReadOnly RECORDED_SOURCE As String
Visual C++
public:
static initonly String^ RECORDED_SOURCE

See Also

MCitems Structure
MCitems Members


RECORDED_SOURCE_APPLICATOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_SOURCE_APPLICATOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_SOURCE_APPLICATOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_SOURCE_APPLICATOR
Visual Basic
Public Shared ReadOnly RECORDED_SOURCE_APPLICATOR As String
Visual C++
public:
static initonly String^ RECORDED_SOURCE_APPLICATOR

See Also

MCitems Structure
MCitems Members


RECORDED_WEDGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RECORDED_WEDGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RECORDED_WEDGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RECORDED_WEDGE
Visual Basic
Public Shared ReadOnly RECORDED_WEDGE As String
Visual C++
public:
static initonly String^ RECORDED_WEDGE

See Also

MCitems Structure
MCitems Members


REF_BASIC_ANNOTATION_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BASIC_ANNOTATION_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BASIC_ANNOTATION_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BASIC_ANNOTATION_BOX
Visual Basic
Public Shared ReadOnly REF_BASIC_ANNOTATION_BOX As String
Visual C++
public:
static initonly String^ REF_BASIC_ANNOTATION_BOX

See Also

MCitems Structure
MCitems Members


REF_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BEAM
Visual Basic
Public Shared ReadOnly REF_BEAM As String
Visual C++
public:
static initonly String^ REF_BEAM

See Also

MCitems Structure
MCitems Members


REF_BEAM_IN_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BEAM_IN_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BEAM_IN_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BEAM_IN_DOSE
Visual Basic
Public Shared ReadOnly REF_BEAM_IN_DOSE As String
Visual C++
public:
static initonly String^ REF_BEAM_IN_DOSE

See Also

MCitems Structure
MCitems Members


REF_BOLUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BOLUS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BOLUS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BOLUS
Visual Basic
Public Shared ReadOnly REF_BOLUS As String
Visual C++
public:
static initonly String^ REF_BOLUS

See Also

MCitems Structure
MCitems Members


REF_BOLUS_IN_ION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BOLUS_IN_ION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BOLUS_IN_ION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BOLUS_IN_ION
Visual Basic
Public Shared ReadOnly REF_BOLUS_IN_ION As String
Visual C++
public:
static initonly String^ REF_BOLUS_IN_ION

See Also

MCitems Structure
MCitems Members


REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP
Visual Basic
Public Shared ReadOnly REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP As String
Visual C++
public:
static initonly String^ REF_BRACHY_APPLICATION_SETUP_IN_FRACTION_GROUP

See Also

MCitems Structure
MCitems Members


REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP
Visual Basic
Public Shared ReadOnly REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP As String
Visual C++
public:
static initonly String^ REF_BRACHY_APPLICATION_SETUP_IN_REF_FRACTION_GROUP

See Also

MCitems Structure
MCitems Members


REF_CALCULATED_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_CALCULATED_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_CALCULATED_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_CALCULATED_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly REF_CALCULATED_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ REF_CALCULATED_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


REF_COMPOSITE_OBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_COMPOSITE_OBJECT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_COMPOSITE_OBJECT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_COMPOSITE_OBJECT
Visual Basic
Public Shared ReadOnly REF_COMPOSITE_OBJECT As String
Visual C++
public:
static initonly String^ REF_COMPOSITE_OBJECT

See Also

MCitems Structure
MCitems Members


REF_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_CONTROL_POINT
Visual Basic
Public Shared ReadOnly REF_CONTROL_POINT As String
Visual C++
public:
static initonly String^ REF_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


REF_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_CURVE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_CURVE
Visual Basic
Public Shared ReadOnly REF_CURVE As String
Visual C++
public:
static initonly String^ REF_CURVE

See Also

MCitems Structure
MCitems Members


REF_DEFINED_OR_PERFORMED_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DEFINED_OR_PERFORMED_PROTOCOL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DEFINED_OR_PERFORMED_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DEFINED_OR_PERFORMED_PROTOCOL
Visual Basic
Public Shared ReadOnly REF_DEFINED_OR_PERFORMED_PROTOCOL As String
Visual C++
public:
static initonly String^ REF_DEFINED_OR_PERFORMED_PROTOCOL

See Also

MCitems Structure
MCitems Members


REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ REF_DEFINED_OR_PERFORMED_PROTOCOL_IN_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


REF_DIGITAL_SIGNATURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DIGITAL_SIGNATURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DIGITAL_SIGNATURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DIGITAL_SIGNATURE
Visual Basic
Public Shared ReadOnly REF_DIGITAL_SIGNATURE As String
Visual C++
public:
static initonly String^ REF_DIGITAL_SIGNATURE

See Also

MCitems Structure
MCitems Members


REF_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DOSE
Visual Basic
Public Shared ReadOnly REF_DOSE As String
Visual C++
public:
static initonly String^ REF_DOSE

See Also

MCitems Structure
MCitems Members


REF_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly REF_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ REF_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


REF_DOSE_REFERENCE_IN_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DOSE_REFERENCE_IN_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DOSE_REFERENCE_IN_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DOSE_REFERENCE_IN_BEAM
Visual Basic
Public Shared ReadOnly REF_DOSE_REFERENCE_IN_BEAM As String
Visual C++
public:
static initonly String^ REF_DOSE_REFERENCE_IN_BEAM

See Also

MCitems Structure
MCitems Members


REF_DOSE_REFERENCE_IN_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DOSE_REFERENCE_IN_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DOSE_REFERENCE_IN_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DOSE_REFERENCE_IN_CONTROL_POINT
Visual Basic
Public Shared ReadOnly REF_DOSE_REFERENCE_IN_CONTROL_POINT As String
Visual C++
public:
static initonly String^ REF_DOSE_REFERENCE_IN_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


REF_DOSE_REFERENCE_IN_ION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_DOSE_REFERENCE_IN_ION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_DOSE_REFERENCE_IN_ION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_DOSE_REFERENCE_IN_ION
Visual Basic
Public Shared ReadOnly REF_DOSE_REFERENCE_IN_ION As String
Visual C++
public:
static initonly String^ REF_DOSE_REFERENCE_IN_ION

See Also

MCitems Structure
MCitems Members


REF_FILM_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_FILM_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_FILM_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_FILM_BOX
Visual Basic
Public Shared ReadOnly REF_FILM_BOX As String
Visual C++
public:
static initonly String^ REF_FILM_BOX

See Also

MCitems Structure
MCitems Members


REF_FILM_SESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_FILM_SESSION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_FILM_SESSION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_FILM_SESSION
Visual Basic
Public Shared ReadOnly REF_FILM_SESSION As String
Visual C++
public:
static initonly String^ REF_FILM_SESSION

See Also

MCitems Structure
MCitems Members


REF_FRACTION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_FRACTION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_FRACTION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_FRACTION_GROUP
Visual Basic
Public Shared ReadOnly REF_FRACTION_GROUP As String
Visual C++
public:
static initonly String^ REF_FRACTION_GROUP

See Also

MCitems Structure
MCitems Members


REF_FRAME_OF_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_FRAME_OF_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_FRAME_OF_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_FRAME_OF_REFERENCE
Visual Basic
Public Shared ReadOnly REF_FRAME_OF_REFERENCE As String
Visual C++
public:
static initonly String^ REF_FRAME_OF_REFERENCE

See Also

MCitems Structure
MCitems Members


REF_G_P_SCHEDULED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_G_P_SCHEDULED_PROCEDURE_STEP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_G_P_SCHEDULED_PROCEDURE_STEP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_G_P_SCHEDULED_PROCEDURE_STEP
Visual Basic
Public Shared ReadOnly REF_G_P_SCHEDULED_PROCEDURE_STEP As String
Visual C++
public:
static initonly String^ REF_G_P_SCHEDULED_PROCEDURE_STEP

See Also

MCitems Structure
MCitems Members


REF_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE
Visual Basic
Public Shared ReadOnly REF_IMAGE As String
Visual C++
public:
static initonly String^ REF_IMAGE

See Also

MCitems Structure
MCitems Members


REF_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_BOX
Visual Basic
Public Shared ReadOnly REF_IMAGE_BOX As String
Visual C++
public:
static initonly String^ REF_IMAGE_BOX

See Also

MCitems Structure
MCitems Members


REF_IMAGE_DISPLAY_SYSTEM_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_DISPLAY_SYSTEM_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_DISPLAY_SYSTEM_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_DISPLAY_SYSTEM_SCP
Visual Basic
Public Shared ReadOnly REF_IMAGE_DISPLAY_SYSTEM_SCP As String
Visual C++
public:
static initonly String^ REF_IMAGE_DISPLAY_SYSTEM_SCP

See Also

MCitems Structure
MCitems Members


REF_IMAGE_DISPLAY_SYSTEM_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_DISPLAY_SYSTEM_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_DISPLAY_SYSTEM_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_DISPLAY_SYSTEM_SCU
Visual Basic
Public Shared ReadOnly REF_IMAGE_DISPLAY_SYSTEM_SCU As String
Visual C++
public:
static initonly String^ REF_IMAGE_DISPLAY_SYSTEM_SCU

See Also

MCitems Structure
MCitems Members


REF_IMAGE_F5_23 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_F5_23 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_F5_23"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_F5_23
Visual Basic
Public Shared ReadOnly REF_IMAGE_F5_23 As String
Visual C++
public:
static initonly String^ REF_IMAGE_F5_23

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_ADVANCED_BLENDING_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_ADVANCED_BLENDING_PS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_ADVANCED_BLENDING_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_ADVANCED_BLENDING_PS
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_ADVANCED_BLENDING_PS As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_ADVANCED_BLENDING_PS

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_IMAGE_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_IMAGE_BOX
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_IMAGE_BOX As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_IMAGE_BOX

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_REF_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_REF_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_REF_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_REF_SERIES
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_REF_SERIES As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_REF_SERIES

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_STORE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_STORE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_STORE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_STORE
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_STORE As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_STORE

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_VISUAL_EVAL_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_VISUAL_EVAL_RESULT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_VISUAL_EVAL_RESULT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_VISUAL_EVAL_RESULT
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_VISUAL_EVAL_RESULT As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_VISUAL_EVAL_RESULT

See Also

MCitems Structure
MCitems Members


REF_IMAGE_IN_XRAY_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_IN_XRAY_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_IN_XRAY_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_IN_XRAY_IMAGE
Visual Basic
Public Shared ReadOnly REF_IMAGE_IN_XRAY_IMAGE As String
Visual C++
public:
static initonly String^ REF_IMAGE_IN_XRAY_IMAGE

See Also

MCitems Structure
MCitems Members


REF_IMAGE_OVERLAY_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_OVERLAY_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_OVERLAY_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_OVERLAY_BOX
Visual Basic
Public Shared ReadOnly REF_IMAGE_OVERLAY_BOX As String
Visual C++
public:
static initonly String^ REF_IMAGE_OVERLAY_BOX

See Also

MCitems Structure
MCitems Members


REF_IMAGE_OVERLAY_BOX_IN_STORE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_OVERLAY_BOX_IN_STORE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_OVERLAY_BOX_IN_STORE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_OVERLAY_BOX_IN_STORE
Visual Basic
Public Shared ReadOnly REF_IMAGE_OVERLAY_BOX_IN_STORE As String
Visual C++
public:
static initonly String^ REF_IMAGE_OVERLAY_BOX_IN_STORE

See Also

MCitems Structure
MCitems Members


REF_IMAGE_REAL_WORLD_FOR_NM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_REAL_WORLD_FOR_NM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_REAL_WORLD_FOR_NM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_REAL_WORLD_FOR_NM
Visual Basic
Public Shared ReadOnly REF_IMAGE_REAL_WORLD_FOR_NM As String
Visual C++
public:
static initonly String^ REF_IMAGE_REAL_WORLD_FOR_NM

See Also

MCitems Structure
MCitems Members


REF_IMAGE_REAL_WORLD_VALUE_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_REAL_WORLD_VALUE_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_REAL_WORLD_VALUE_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_REAL_WORLD_VALUE_MAP
Visual Basic
Public Shared ReadOnly REF_IMAGE_REAL_WORLD_VALUE_MAP As String
Visual C++
public:
static initonly String^ REF_IMAGE_REAL_WORLD_VALUE_MAP

See Also

MCitems Structure
MCitems Members


REF_IMAGE_RQ_F_4_3 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_RQ_F_4_3 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_RQ_F_4_3"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_RQ_F_4_3
Visual Basic
Public Shared ReadOnly REF_IMAGE_RQ_F_4_3 As String
Visual C++
public:
static initonly String^ REF_IMAGE_RQ_F_4_3

See Also

MCitems Structure
MCitems Members


REF_IMAGE_RSP_F_4_2 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_RSP_F_4_2 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_RSP_F_4_2"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_RSP_F_4_2
Visual Basic
Public Shared ReadOnly REF_IMAGE_RSP_F_4_2 As String
Visual C++
public:
static initonly String^ REF_IMAGE_RSP_F_4_2

See Also

MCitems Structure
MCitems Members


REF_IMAGE_RSP_F_4_3 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_RSP_F_4_3 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_RSP_F_4_3"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_RSP_F_4_3
Visual Basic
Public Shared ReadOnly REF_IMAGE_RSP_F_4_3 As String
Visual C++
public:
static initonly String^ REF_IMAGE_RSP_F_4_3

See Also

MCitems Structure
MCitems Members


REF_IMAGE_RT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_RT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_RT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_RT
Visual Basic
Public Shared ReadOnly REF_IMAGE_RT As String
Visual C++
public:
static initonly String^ REF_IMAGE_RT

See Also

MCitems Structure
MCitems Members


REF_IMAGE_STRUCT_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_IMAGE_STRUCT_DISPLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_IMAGE_STRUCT_DISPLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_IMAGE_STRUCT_DISPLAY
Visual Basic
Public Shared ReadOnly REF_IMAGE_STRUCT_DISPLAY As String
Visual C++
public:
static initonly String^ REF_IMAGE_STRUCT_DISPLAY

See Also

MCitems Structure
MCitems Members


REF_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_INSTANCE
Visual Basic
Public Shared ReadOnly REF_INSTANCE As String
Visual C++
public:
static initonly String^ REF_INSTANCE

See Also

MCitems Structure
MCitems Members


REF_INSTANCE_IN_CONTRIB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_INSTANCE_IN_CONTRIB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_INSTANCE_IN_CONTRIB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_INSTANCE_IN_CONTRIB
Visual Basic
Public Shared ReadOnly REF_INSTANCE_IN_CONTRIB As String
Visual C++
public:
static initonly String^ REF_INSTANCE_IN_CONTRIB

See Also

MCitems Structure
MCitems Members


REF_INSTANCES_AND_ACCESS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_INSTANCES_AND_ACCESS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_INSTANCES_AND_ACCESS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_INSTANCES_AND_ACCESS_MACRO
Visual Basic
Public Shared ReadOnly REF_INSTANCES_AND_ACCESS_MACRO As String
Visual C++
public:
static initonly String^ REF_INSTANCES_AND_ACCESS_MACRO

See Also

MCitems Structure
MCitems Members


REF_INTERPRETATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_INTERPRETATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_INTERPRETATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_INTERPRETATION
Visual Basic
Public Shared ReadOnly REF_INTERPRETATION As String
Visual C++
public:
static initonly String^ REF_INTERPRETATION

See Also

MCitems Structure
MCitems Members


REF_MEASURED_DOSE_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_MEASURED_DOSE_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_MEASURED_DOSE_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_MEASURED_DOSE_REFERENCE
Visual Basic
Public Shared ReadOnly REF_MEASURED_DOSE_REFERENCE As String
Visual C++
public:
static initonly String^ REF_MEASURED_DOSE_REFERENCE

See Also

MCitems Structure
MCitems Members


REF_OPHT_AXL_LEN_MEAS_QC_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_OPHT_AXL_LEN_MEAS_QC_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_OPHT_AXL_LEN_MEAS_QC_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_OPHT_AXL_LEN_MEAS_QC_IMAGE
Visual Basic
Public Shared ReadOnly REF_OPHT_AXL_LEN_MEAS_QC_IMAGE As String
Visual C++
public:
static initonly String^ REF_OPHT_AXL_LEN_MEAS_QC_IMAGE

See Also

MCitems Structure
MCitems Members


REF_OVERLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_OVERLAY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_OVERLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_OVERLAY
Visual Basic
Public Shared ReadOnly REF_OVERLAY As String
Visual C++
public:
static initonly String^ REF_OVERLAY

See Also

MCitems Structure
MCitems Members


REF_OVERLAY_IN_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_OVERLAY_IN_CURVE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_OVERLAY_IN_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_OVERLAY_IN_CURVE
Visual Basic
Public Shared ReadOnly REF_OVERLAY_IN_CURVE As String
Visual C++
public:
static initonly String^ REF_OVERLAY_IN_CURVE

See Also

MCitems Structure
MCitems Members


REF_OVERLAY_IN_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_OVERLAY_IN_IMAGE_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_OVERLAY_IN_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_OVERLAY_IN_IMAGE_BOX
Visual Basic
Public Shared ReadOnly REF_OVERLAY_IN_IMAGE_BOX As String
Visual C++
public:
static initonly String^ REF_OVERLAY_IN_IMAGE_BOX

See Also

MCitems Structure
MCitems Members


REF_PATIENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PATIENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PATIENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PATIENT
Visual Basic
Public Shared ReadOnly REF_PATIENT As String
Visual C++
public:
static initonly String^ REF_PATIENT

See Also

MCitems Structure
MCitems Members


REF_PATIENT_ALIAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PATIENT_ALIAS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PATIENT_ALIAS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PATIENT_ALIAS
Visual Basic
Public Shared ReadOnly REF_PATIENT_ALIAS As String
Visual C++
public:
static initonly String^ REF_PATIENT_ALIAS

See Also

MCitems Structure
MCitems Members


REF_PATIENT_CFIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PATIENT_CFIND Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PATIENT_CFIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PATIENT_CFIND
Visual Basic
Public Shared ReadOnly REF_PATIENT_CFIND As String
Visual C++
public:
static initonly String^ REF_PATIENT_CFIND

See Also

MCitems Structure
MCitems Members


REF_PERF_PROC_STEP_INST_AVAIL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PERF_PROC_STEP_INST_AVAIL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PERF_PROC_STEP_INST_AVAIL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PERF_PROC_STEP_INST_AVAIL
Visual Basic
Public Shared ReadOnly REF_PERF_PROC_STEP_INST_AVAIL As String
Visual C++
public:
static initonly String^ REF_PERF_PROC_STEP_INST_AVAIL

See Also

MCitems Structure
MCitems Members


REF_PERFORMED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PERFORMED_PROCEDURE_STEP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PERFORMED_PROCEDURE_STEP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PERFORMED_PROCEDURE_STEP
Visual Basic
Public Shared ReadOnly REF_PERFORMED_PROCEDURE_STEP As String
Visual C++
public:
static initonly String^ REF_PERFORMED_PROCEDURE_STEP

See Also

MCitems Structure
MCitems Members


REF_PRESENTATION_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PRESENTATION_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PRESENTATION_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PRESENTATION_LUT
Visual Basic
Public Shared ReadOnly REF_PRESENTATION_LUT As String
Visual C++
public:
static initonly String^ REF_PRESENTATION_LUT

See Also

MCitems Structure
MCitems Members


REF_PRESENTATION_LUT_IN_STORE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PRESENTATION_LUT_IN_STORE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PRESENTATION_LUT_IN_STORE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PRESENTATION_LUT_IN_STORE
Visual Basic
Public Shared ReadOnly REF_PRESENTATION_LUT_IN_STORE As String
Visual C++
public:
static initonly String^ REF_PRESENTATION_LUT_IN_STORE

See Also

MCitems Structure
MCitems Members


REF_PRINT_JOB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PRINT_JOB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PRINT_JOB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PRINT_JOB
Visual Basic
Public Shared ReadOnly REF_PRINT_JOB As String
Visual C++
public:
static initonly String^ REF_PRINT_JOB

See Also

MCitems Structure
MCitems Members


REF_PRINT_JOB_IN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_PRINT_JOB_IN_DESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_PRINT_JOB_IN_DESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_PRINT_JOB_IN_DESCRIPTION
Visual Basic
Public Shared ReadOnly REF_PRINT_JOB_IN_DESCRIPTION As String
Visual C++
public:
static initonly String^ REF_PRINT_JOB_IN_DESCRIPTION

See Also

MCitems Structure
MCitems Members


REF_REAL_WORLD_VALUE_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_REAL_WORLD_VALUE_MAPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_REAL_WORLD_VALUE_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_REAL_WORLD_VALUE_MAPPING
Visual Basic
Public Shared ReadOnly REF_REAL_WORLD_VALUE_MAPPING As String
Visual C++
public:
static initonly String^ REF_REAL_WORLD_VALUE_MAPPING

See Also

MCitems Structure
MCitems Members


REF_REFERENCE_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_REFERENCE_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_REFERENCE_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_REFERENCE_IMAGE
Visual Basic
Public Shared ReadOnly REF_REFERENCE_IMAGE As String
Visual C++
public:
static initonly String^ REF_REFERENCE_IMAGE

See Also

MCitems Structure
MCitems Members


REF_REFERENCE_IMAGE_IN_ION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_REFERENCE_IMAGE_IN_ION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_REFERENCE_IMAGE_IN_ION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_REFERENCE_IMAGE_IN_ION
Visual Basic
Public Shared ReadOnly REF_REFERENCE_IMAGE_IN_ION As String
Visual C++
public:
static initonly String^ REF_REFERENCE_IMAGE_IN_ION

See Also

MCitems Structure
MCitems Members


REF_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RESULTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RESULTS
Visual Basic
Public Shared ReadOnly REF_RESULTS As String
Visual C++
public:
static initonly String^ REF_RESULTS

See Also

MCitems Structure
MCitems Members


REF_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_ROI
Visual Basic
Public Shared ReadOnly REF_ROI As String
Visual C++
public:
static initonly String^ REF_ROI

See Also

MCitems Structure
MCitems Members


REF_RT_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_PLAN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_PLAN
Visual Basic
Public Shared ReadOnly REF_RT_PLAN As String
Visual C++
public:
static initonly String^ REF_RT_PLAN

See Also

MCitems Structure
MCitems Members


REF_RT_PLAN_IN_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_PLAN_IN_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_PLAN_IN_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_PLAN_IN_DOSE
Visual Basic
Public Shared ReadOnly REF_RT_PLAN_IN_DOSE As String
Visual C++
public:
static initonly String^ REF_RT_PLAN_IN_DOSE

See Also

MCitems Structure
MCitems Members


REF_RT_PLAN_IN_GENERAL_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_PLAN_IN_GENERAL_PLAN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_PLAN_IN_GENERAL_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_PLAN_IN_GENERAL_PLAN
Visual Basic
Public Shared ReadOnly REF_RT_PLAN_IN_GENERAL_PLAN As String
Visual C++
public:
static initonly String^ REF_RT_PLAN_IN_GENERAL_PLAN

See Also

MCitems Structure
MCitems Members


REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO
Visual Basic
Public Shared ReadOnly REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO As String
Visual C++
public:
static initonly String^ REF_RT_PLAN_IN_RT_PATIENT_POSITION_SCOPE_MACRO

See Also

MCitems Structure
MCitems Members


REF_RT_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_SERIES
Visual Basic
Public Shared ReadOnly REF_RT_SERIES As String
Visual C++
public:
static initonly String^ REF_RT_SERIES

See Also

MCitems Structure
MCitems Members


REF_RT_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_RT_STUDY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_RT_STUDY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_RT_STUDY
Visual Basic
Public Shared ReadOnly REF_RT_STUDY As String
Visual C++
public:
static initonly String^ REF_RT_STUDY

See Also

MCitems Structure
MCitems Members


REF_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES
Visual Basic
Public Shared ReadOnly REF_SERIES As String
Visual C++
public:
static initonly String^ REF_SERIES

See Also

MCitems Structure
MCitems Members


REF_SERIES_F5_23 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_F5_23 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_F5_23"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_F5_23
Visual Basic
Public Shared ReadOnly REF_SERIES_F5_23 As String
Visual C++
public:
static initonly String^ REF_SERIES_F5_23

See Also

MCitems Structure
MCitems Members


REF_SERIES_IN_COMMON_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_IN_COMMON_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_IN_COMMON_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_IN_COMMON_INSTANCE
Visual Basic
Public Shared ReadOnly REF_SERIES_IN_COMMON_INSTANCE As String
Visual C++
public:
static initonly String^ REF_SERIES_IN_COMMON_INSTANCE

See Also

MCitems Structure
MCitems Members


REF_SERIES_IN_CONTRIB Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_IN_CONTRIB Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_IN_CONTRIB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_IN_CONTRIB
Visual Basic
Public Shared ReadOnly REF_SERIES_IN_CONTRIB As String
Visual C++
public:
static initonly String^ REF_SERIES_IN_CONTRIB

See Also

MCitems Structure
MCitems Members


REF_SERIES_IN_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_IN_PS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_IN_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_IN_PS
Visual Basic
Public Shared ReadOnly REF_SERIES_IN_PS As String
Visual C++
public:
static initonly String^ REF_SERIES_IN_PS

See Also

MCitems Structure
MCitems Members


REF_SERIES_IN_RELATED_IES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_IN_RELATED_IES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_IN_RELATED_IES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_IN_RELATED_IES
Visual Basic
Public Shared ReadOnly REF_SERIES_IN_RELATED_IES As String
Visual C++
public:
static initonly String^ REF_SERIES_IN_RELATED_IES

See Also

MCitems Structure
MCitems Members


REF_SERIES_NOTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_NOTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_NOTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_NOTIFICATION
Visual Basic
Public Shared ReadOnly REF_SERIES_NOTIFICATION As String
Visual C++
public:
static initonly String^ REF_SERIES_NOTIFICATION

See Also

MCitems Structure
MCitems Members


REF_SERIES_RQ_F_4_2 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_RQ_F_4_2 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_RQ_F_4_2"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_RQ_F_4_2
Visual Basic
Public Shared ReadOnly REF_SERIES_RQ_F_4_2 As String
Visual C++
public:
static initonly String^ REF_SERIES_RQ_F_4_2

See Also

MCitems Structure
MCitems Members


REF_SERIES_RQ_F_4_3 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_RQ_F_4_3 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_RQ_F_4_3"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_RQ_F_4_3
Visual Basic
Public Shared ReadOnly REF_SERIES_RQ_F_4_3 As String
Visual C++
public:
static initonly String^ REF_SERIES_RQ_F_4_3

See Also

MCitems Structure
MCitems Members


REF_SERIES_RSP_F_4_2 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_RSP_F_4_2 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_RSP_F_4_2"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_RSP_F_4_2
Visual Basic
Public Shared ReadOnly REF_SERIES_RSP_F_4_2 As String
Visual C++
public:
static initonly String^ REF_SERIES_RSP_F_4_2

See Also

MCitems Structure
MCitems Members


REF_SERIES_RSP_F_4_3 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SERIES_RSP_F_4_3 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SERIES_RSP_F_4_3"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SERIES_RSP_F_4_3
Visual Basic
Public Shared ReadOnly REF_SERIES_RSP_F_4_3 As String
Visual C++
public:
static initonly String^ REF_SERIES_RSP_F_4_3

See Also

MCitems Structure
MCitems Members


REF_SETUP_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SETUP_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SETUP_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SETUP_IMAGE
Visual Basic
Public Shared ReadOnly REF_SETUP_IMAGE As String
Visual C++
public:
static initonly String^ REF_SETUP_IMAGE

See Also

MCitems Structure
MCitems Members


REF_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP
Visual Basic
Public Shared ReadOnly REF_SOP As String
Visual C++
public:
static initonly String^ REF_SOP

See Also

MCitems Structure
MCitems Members


REF_SOP_AE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_AE_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_AE_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_AE_RQ
Visual Basic
Public Shared ReadOnly REF_SOP_AE_RQ As String
Visual C++
public:
static initonly String^ REF_SOP_AE_RQ

See Also

MCitems Structure
MCitems Members


REF_SOP_AE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_AE_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_AE_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_AE_RSP
Visual Basic
Public Shared ReadOnly REF_SOP_AE_RSP As String
Visual C++
public:
static initonly String^ REF_SOP_AE_RSP

See Also

MCitems Structure
MCitems Members


REF_SOP_FOR_IMAGE_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_FOR_IMAGE_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_FOR_IMAGE_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_FOR_IMAGE_REF_MACRO
Visual Basic
Public Shared ReadOnly REF_SOP_FOR_IMAGE_REF_MACRO As String
Visual C++
public:
static initonly String^ REF_SOP_FOR_IMAGE_REF_MACRO

See Also

MCitems Structure
MCitems Members


REF_SOP_FOR_WAVEFORM_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_FOR_WAVEFORM_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_FOR_WAVEFORM_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_FOR_WAVEFORM_REF_MACRO
Visual Basic
Public Shared ReadOnly REF_SOP_FOR_WAVEFORM_REF_MACRO As String
Visual C++
public:
static initonly String^ REF_SOP_FOR_WAVEFORM_REF_MACRO

See Also

MCitems Structure
MCitems Members


REF_SOP_IN_HS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_IN_HS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_IN_HS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_IN_HS_MACRO
Visual Basic
Public Shared ReadOnly REF_SOP_IN_HS_MACRO As String
Visual C++
public:
static initonly String^ REF_SOP_IN_HS_MACRO

See Also

MCitems Structure
MCitems Members


REF_SOP_IN_STOW_RS_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_IN_STOW_RS_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_IN_STOW_RS_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_IN_STOW_RS_RSP
Visual Basic
Public Shared ReadOnly REF_SOP_IN_STOW_RS_RSP As String
Visual C++
public:
static initonly String^ REF_SOP_IN_STOW_RS_RSP

See Also

MCitems Structure
MCitems Members


REF_SOP_INSTANCE_MAC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_INSTANCE_MAC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_INSTANCE_MAC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_INSTANCE_MAC
Visual Basic
Public Shared ReadOnly REF_SOP_INSTANCE_MAC As String
Visual C++
public:
static initonly String^ REF_SOP_INSTANCE_MAC

See Also

MCitems Structure
MCitems Members


REF_SOP_MEDIA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_MEDIA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_MEDIA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_MEDIA
Visual Basic
Public Shared ReadOnly REF_SOP_MEDIA As String
Visual C++
public:
static initonly String^ REF_SOP_MEDIA

See Also

MCitems Structure
MCitems Members


REF_SOP_MEDIA_AE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_MEDIA_AE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_MEDIA_AE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_MEDIA_AE
Visual Basic
Public Shared ReadOnly REF_SOP_MEDIA_AE As String
Visual C++
public:
static initonly String^ REF_SOP_MEDIA_AE

See Also

MCitems Structure
MCitems Members


REF_SOP_MEDIA_CREATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_MEDIA_CREATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_MEDIA_CREATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_MEDIA_CREATION
Visual Basic
Public Shared ReadOnly REF_SOP_MEDIA_CREATION As String
Visual C++
public:
static initonly String^ REF_SOP_MEDIA_CREATION

See Also

MCitems Structure
MCitems Members


REF_SOP_NOTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_SOP_NOTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_SOP_NOTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_SOP_NOTIFICATION
Visual Basic
Public Shared ReadOnly REF_SOP_NOTIFICATION As String
Visual C++
public:
static initonly String^ REF_SOP_NOTIFICATION

See Also

MCitems Structure
MCitems Members


REF_STORAGE_MEDIA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STORAGE_MEDIA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STORAGE_MEDIA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STORAGE_MEDIA
Visual Basic
Public Shared ReadOnly REF_STORAGE_MEDIA As String
Visual C++
public:
static initonly String^ REF_STORAGE_MEDIA

See Also

MCitems Structure
MCitems Members


REF_STORED_PRINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STORED_PRINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STORED_PRINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STORED_PRINT
Visual Basic
Public Shared ReadOnly REF_STORED_PRINT As String
Visual C++
public:
static initonly String^ REF_STORED_PRINT

See Also

MCitems Structure
MCitems Members


REF_STRUCTURE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STRUCTURE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STRUCTURE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STRUCTURE_SET
Visual Basic
Public Shared ReadOnly REF_STRUCTURE_SET As String
Visual C++
public:
static initonly String^ REF_STRUCTURE_SET

See Also

MCitems Structure
MCitems Members


REF_STUDY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STUDY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STUDY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STUDY
Visual Basic
Public Shared ReadOnly REF_STUDY As String
Visual C++
public:
static initonly String^ REF_STUDY

See Also

MCitems Structure
MCitems Members


REF_STUDY_CFIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STUDY_CFIND Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STUDY_CFIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STUDY_CFIND
Visual Basic
Public Shared ReadOnly REF_STUDY_CFIND As String
Visual C++
public:
static initonly String^ REF_STUDY_CFIND

See Also

MCitems Structure
MCitems Members


REF_STUDY_COMPONENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STUDY_COMPONENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STUDY_COMPONENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STUDY_COMPONENT
Visual Basic
Public Shared ReadOnly REF_STUDY_COMPONENT As String
Visual C++
public:
static initonly String^ REF_STUDY_COMPONENT

See Also

MCitems Structure
MCitems Members


REF_STUDY_IN_RELATED_IES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_STUDY_IN_RELATED_IES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_STUDY_IN_RELATED_IES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_STUDY_IN_RELATED_IES
Visual Basic
Public Shared ReadOnly REF_STUDY_IN_RELATED_IES As String
Visual C++
public:
static initonly String^ REF_STUDY_IN_RELATED_IES

See Also

MCitems Structure
MCitems Members


REF_TREATMENT_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_TREATMENT_RECORD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_TREATMENT_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_TREATMENT_RECORD
Visual Basic
Public Shared ReadOnly REF_TREATMENT_RECORD As String
Visual C++
public:
static initonly String^ REF_TREATMENT_RECORD

See Also

MCitems Structure
MCitems Members


REF_VERIFICATION_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_VERIFICATION_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_VERIFICATION_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_VERIFICATION_IMAGE
Visual Basic
Public Shared ReadOnly REF_VERIFICATION_IMAGE As String
Visual C++
public:
static initonly String^ REF_VERIFICATION_IMAGE

See Also

MCitems Structure
MCitems Members


REF_VISIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_VISIT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_VISIT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_VISIT
Visual Basic
Public Shared ReadOnly REF_VISIT As String
Visual C++
public:
static initonly String^ REF_VISIT

See Also

MCitems Structure
MCitems Members


REF_VOI_LUT_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REF_VOI_LUT_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REF_VOI_LUT_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REF_VOI_LUT_BOX
Visual Basic
Public Shared ReadOnly REF_VOI_LUT_BOX As String
Visual C++
public:
static initonly String^ REF_VOI_LUT_BOX

See Also

MCitems Structure
MCitems Members


REFERENCE_LOCATION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCE_LOCATION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCE_LOCATION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCE_LOCATION_MACRO
Visual Basic
Public Shared ReadOnly REFERENCE_LOCATION_MACRO As String
Visual C++
public:
static initonly String^ REFERENCE_LOCATION_MACRO

See Also

MCitems Structure
MCitems Members


REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE
Visual Basic
Public Shared ReadOnly REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE As String
Visual C++
public:
static initonly String^ REFERENCED_BASELINE_PARAMETERS_RT_RADIATION_INSTANCE

See Also

MCitems Structure
MCitems Members


REFERENCED_DOSIMETRIC_OBJECTIVES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_DOSIMETRIC_OBJECTIVES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_DOSIMETRIC_OBJECTIVES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_DOSIMETRIC_OBJECTIVES
Visual Basic
Public Shared ReadOnly REFERENCED_DOSIMETRIC_OBJECTIVES As String
Visual C++
public:
static initonly String^ REFERENCED_DOSIMETRIC_OBJECTIVES

See Also

MCitems Structure
MCitems Members


REFERENCED_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_IMAGE
Visual Basic
Public Shared ReadOnly REFERENCED_IMAGE As String
Visual C++
public:
static initonly String^ REFERENCED_IMAGE

See Also

MCitems Structure
MCitems Members


REFERENCED_PATIENT_SETUP_PHOTO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_PATIENT_SETUP_PHOTO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_PATIENT_SETUP_PHOTO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_PATIENT_SETUP_PHOTO
Visual Basic
Public Shared ReadOnly REFERENCED_PATIENT_SETUP_PHOTO As String
Visual C++
public:
static initonly String^ REFERENCED_PATIENT_SETUP_PHOTO

See Also

MCitems Structure
MCitems Members


REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO
Visual Basic
Public Shared ReadOnly REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO As String
Visual C++
public:
static initonly String^ REFERENCED_PROTOCOL_IN_GENERAL_PROCEDURE_MACRO

See Also

MCitems Structure
MCitems Members


REFERENCED_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_REQUEST Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_REQUEST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_REQUEST
Visual Basic
Public Shared ReadOnly REFERENCED_REQUEST As String
Visual C++
public:
static initonly String^ REFERENCED_REQUEST

See Also

MCitems Structure
MCitems Members


REFERENCED_REQUEST_N_CREATE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_REQUEST_N_CREATE_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_REQUEST_N_CREATE_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_REQUEST_N_CREATE_RQ
Visual Basic
Public Shared ReadOnly REFERENCED_REQUEST_N_CREATE_RQ As String
Visual C++
public:
static initonly String^ REFERENCED_REQUEST_N_CREATE_RQ

See Also

MCitems Structure
MCitems Members


REFERENCED_REQUEST_N_CREATE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_REQUEST_N_CREATE_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_REQUEST_N_CREATE_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_REQUEST_N_CREATE_RSP
Visual Basic
Public Shared ReadOnly REFERENCED_REQUEST_N_CREATE_RSP As String
Visual C++
public:
static initonly String^ REFERENCED_REQUEST_N_CREATE_RSP

See Also

MCitems Structure
MCitems Members


REFERENCED_REQUEST_N_GET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_REQUEST_N_GET_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_REQUEST_N_GET_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_REQUEST_N_GET_RQ
Visual Basic
Public Shared ReadOnly REFERENCED_REQUEST_N_GET_RQ As String
Visual C++
public:
static initonly String^ REFERENCED_REQUEST_N_GET_RQ

See Also

MCitems Structure
MCitems Members


REFERENCED_REQUEST_UPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_REQUEST_UPS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_REQUEST_UPS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_REQUEST_UPS
Visual Basic
Public Shared ReadOnly REFERENCED_REQUEST_UPS As String
Visual C++
public:
static initonly String^ REFERENCED_REQUEST_UPS

See Also

MCitems Structure
MCitems Members


REFERENCED_RT_PHYSICIAN_INTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_RT_PHYSICIAN_INTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_RT_PHYSICIAN_INTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_RT_PHYSICIAN_INTENT
Visual Basic
Public Shared ReadOnly REFERENCED_RT_PHYSICIAN_INTENT As String
Visual C++
public:
static initonly String^ REFERENCED_RT_PHYSICIAN_INTENT

See Also

MCitems Structure
MCitems Members


REFERENCED_RT_PRESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_RT_PRESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_RT_PRESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_RT_PRESCRIPTION
Visual Basic
Public Shared ReadOnly REFERENCED_RT_PRESCRIPTION As String
Visual C++
public:
static initonly String^ REFERENCED_RT_PRESCRIPTION

See Also

MCitems Structure
MCitems Members


REFERENCED_RT_RADIATION_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_RT_RADIATION_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_RT_RADIATION_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_RT_RADIATION_SET
Visual Basic
Public Shared ReadOnly REFERENCED_RT_RADIATION_SET As String
Visual C++
public:
static initonly String^ REFERENCED_RT_RADIATION_SET

See Also

MCitems Structure
MCitems Members


REFERENCED_RT_TREATMENT_PHASE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_RT_TREATMENT_PHASE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_RT_TREATMENT_PHASE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_RT_TREATMENT_PHASE
Visual Basic
Public Shared ReadOnly REFERENCED_RT_TREATMENT_PHASE As String
Visual C++
public:
static initonly String^ REFERENCED_RT_TREATMENT_PHASE

See Also

MCitems Structure
MCitems Members


REFERENCED_SERIES_10_4 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_SERIES_10_4 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_SERIES_10_4"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_SERIES_10_4
Visual Basic
Public Shared ReadOnly REFERENCED_SERIES_10_4 As String
Visual C++
public:
static initonly String^ REFERENCED_SERIES_10_4

See Also

MCitems Structure
MCitems Members


REFERENCED_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_SOP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_SOP
Visual Basic
Public Shared ReadOnly REFERENCED_SOP As String
Visual C++
public:
static initonly String^ REFERENCED_SOP

See Also

MCitems Structure
MCitems Members


REFERENCED_SOP_10_3b Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_SOP_10_3b Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_SOP_10_3b"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_SOP_10_3b
Visual Basic
Public Shared ReadOnly REFERENCED_SOP_10_3b As String
Visual C++
public:
static initonly String^ REFERENCED_SOP_10_3b

See Also

MCitems Structure
MCitems Members


REFERENCED_STRUCTURED_CONTEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_STRUCTURED_CONTEXT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_STRUCTURED_CONTEXT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_STRUCTURED_CONTEXT
Visual Basic
Public Shared ReadOnly REFERENCED_STRUCTURED_CONTEXT As String
Visual C++
public:
static initonly String^ REFERENCED_STRUCTURED_CONTEXT

See Also

MCitems Structure
MCitems Members


REFERENCED_SURFACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_SURFACE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_SURFACE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_SURFACE
Visual Basic
Public Shared ReadOnly REFERENCED_SURFACE As String
Visual C++
public:
static initonly String^ REFERENCED_SURFACE

See Also

MCitems Structure
MCitems Members


REFERENCED_SURFACE_MESH_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFERENCED_SURFACE_MESH_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFERENCED_SURFACE_MESH_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_SURFACE_MESH_IDENTIFICATION
Visual Basic
Public Shared ReadOnly REFERENCED_SURFACE_MESH_IDENTIFICATION As String
Visual C++
public:
static initonly String^ REFERENCED_SURFACE_MESH_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


REFRACTIVE_PARAMS_USED_ON_PAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFRACTIVE_PARAMS_USED_ON_PAT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFRACTIVE_PARAMS_USED_ON_PAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFRACTIVE_PARAMS_USED_ON_PAT
Visual Basic
Public Shared ReadOnly REFRACTIVE_PARAMS_USED_ON_PAT As String
Visual C++
public:
static initonly String^ REFRACTIVE_PARAMS_USED_ON_PAT

See Also

MCitems Structure
MCitems Members


REFRACTIVE_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFRACTIVE_STATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFRACTIVE_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFRACTIVE_STATE
Visual Basic
Public Shared ReadOnly REFRACTIVE_STATE As String
Visual C++
public:
static initonly String^ REFRACTIVE_STATE

See Also

MCitems Structure
MCitems Members


REFRACTIVE_STATE_IOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REFRACTIVE_STATE_IOL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REFRACTIVE_STATE_IOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFRACTIVE_STATE_IOL
Visual Basic
Public Shared ReadOnly REFRACTIVE_STATE_IOL As String
Visual C++
public:
static initonly String^ REFRACTIVE_STATE_IOL

See Also

MCitems Structure
MCitems Members


REGION_PIXEL_SHIFT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REGION_PIXEL_SHIFT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REGION_PIXEL_SHIFT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REGION_PIXEL_SHIFT
Visual Basic
Public Shared ReadOnly REGION_PIXEL_SHIFT As String
Visual C++
public:
static initonly String^ REGION_PIXEL_SHIFT

See Also

MCitems Structure
MCitems Members


REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REGISTRATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REGISTRATION
Visual Basic
Public Shared ReadOnly REGISTRATION As String
Visual C++
public:
static initonly String^ REGISTRATION

See Also

MCitems Structure
MCitems Members


REGISTRATION_TO_LOCALIZER_SEQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REGISTRATION_TO_LOCALIZER_SEQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REGISTRATION_TO_LOCALIZER_SEQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REGISTRATION_TO_LOCALIZER_SEQ
Visual Basic
Public Shared ReadOnly REGISTRATION_TO_LOCALIZER_SEQ As String
Visual C++
public:
static initonly String^ REGISTRATION_TO_LOCALIZER_SEQ

See Also

MCitems Structure
MCitems Members


REL_OPT_ATTRIBUTES_SEQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REL_OPT_ATTRIBUTES_SEQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REL_OPT_ATTRIBUTES_SEQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REL_OPT_ATTRIBUTES_SEQ
Visual Basic
Public Shared ReadOnly REL_OPT_ATTRIBUTES_SEQ As String
Visual C++
public:
static initonly String^ REL_OPT_ATTRIBUTES_SEQ

See Also

MCitems Structure
MCitems Members


RELATED_ASSERTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_ASSERTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_ASSERTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_ASSERTION
Visual Basic
Public Shared ReadOnly RELATED_ASSERTION As String
Visual C++
public:
static initonly String^ RELATED_ASSERTION

See Also

MCitems Structure
MCitems Members


RELATED_INFORMATION_ENTITIES_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_INFORMATION_ENTITIES_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_INFORMATION_ENTITIES_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_INFORMATION_ENTITIES_MACRO
Visual Basic
Public Shared ReadOnly RELATED_INFORMATION_ENTITIES_MACRO As String
Visual C++
public:
static initonly String^ RELATED_INFORMATION_ENTITIES_MACRO

See Also

MCitems Structure
MCitems Members


RELATED_PROCEDURE_STEP_N_CREATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_PROCEDURE_STEP_N_CREATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_PROCEDURE_STEP_N_CREATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_PROCEDURE_STEP_N_CREATE
Visual Basic
Public Shared ReadOnly RELATED_PROCEDURE_STEP_N_CREATE As String
Visual C++
public:
static initonly String^ RELATED_PROCEDURE_STEP_N_CREATE

See Also

MCitems Structure
MCitems Members


RELATED_PROCEDURE_STEP_N_GET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_PROCEDURE_STEP_N_GET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_PROCEDURE_STEP_N_GET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_PROCEDURE_STEP_N_GET_RSP
Visual Basic
Public Shared ReadOnly RELATED_PROCEDURE_STEP_N_GET_RSP As String
Visual C++
public:
static initonly String^ RELATED_PROCEDURE_STEP_N_GET_RSP

See Also

MCitems Structure
MCitems Members


RELATED_PROCEDURE_STEP_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_PROCEDURE_STEP_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_PROCEDURE_STEP_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_PROCEDURE_STEP_SQ
Visual Basic
Public Shared ReadOnly RELATED_PROCEDURE_STEP_SQ As String
Visual C++
public:
static initonly String^ RELATED_PROCEDURE_STEP_SQ

See Also

MCitems Structure
MCitems Members


RELATED_RT_ROI_OBSERVATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_RT_ROI_OBSERVATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_RT_ROI_OBSERVATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_RT_ROI_OBSERVATIONS
Visual Basic
Public Shared ReadOnly RELATED_RT_ROI_OBSERVATIONS As String
Visual C++
public:
static initonly String^ RELATED_RT_ROI_OBSERVATIONS

See Also

MCitems Structure
MCitems Members


RELATED_SERIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RELATED_SERIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RELATED_SERIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RELATED_SERIES
Visual Basic
Public Shared ReadOnly RELATED_SERIES As String
Visual C++
public:
static initonly String^ RELATED_SERIES

See Also

MCitems Structure
MCitems Members


REQUEST_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REQUEST_ATTRIBUTES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REQUEST_ATTRIBUTES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REQUEST_ATTRIBUTES
Visual Basic
Public Shared ReadOnly REQUEST_ATTRIBUTES As String
Visual C++
public:
static initonly String^ REQUEST_ATTRIBUTES

See Also

MCitems Structure
MCitems Members


REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ REQUESTED_PROCEDURE_CODE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


RESPIRATORY_TRIGGER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RESPIRATORY_TRIGGER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RESPIRATORY_TRIGGER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RESPIRATORY_TRIGGER
Visual Basic
Public Shared ReadOnly RESPIRATORY_TRIGGER As String
Visual C++
public:
static initonly String^ RESPIRATORY_TRIGGER

See Also

MCitems Structure
MCitems Members


RESULTS_DISTRIBUTION_LIST Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RESULTS_DISTRIBUTION_LIST Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RESULTS_DISTRIBUTION_LIST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RESULTS_DISTRIBUTION_LIST
Visual Basic
Public Shared ReadOnly RESULTS_DISTRIBUTION_LIST As String
Visual C++
public:
static initonly String^ RESULTS_DISTRIBUTION_LIST

See Also

MCitems Structure
MCitems Members


RESULTS_NORMALS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RESULTS_NORMALS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RESULTS_NORMALS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RESULTS_NORMALS
Visual Basic
Public Shared ReadOnly RESULTS_NORMALS As String
Visual C++
public:
static initonly String^ RESULTS_NORMALS

See Also

MCitems Structure
MCitems Members


ROBOTIC_PATH_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROBOTIC_PATH_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROBOTIC_PATH_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROBOTIC_PATH_CONTROL_POINT
Visual Basic
Public Shared ReadOnly ROBOTIC_PATH_CONTROL_POINT As String
Visual C++
public:
static initonly String^ ROBOTIC_PATH_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


ROI_CONTOUR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROI_CONTOUR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROI_CONTOUR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROI_CONTOUR
Visual Basic
Public Shared ReadOnly ROI_CONTOUR As String
Visual C++
public:
static initonly String^ ROI_CONTOUR

See Also

MCitems Structure
MCitems Members


ROI_DENSITY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROI_DENSITY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROI_DENSITY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROI_DENSITY
Visual Basic
Public Shared ReadOnly ROI_DENSITY As String
Visual C++
public:
static initonly String^ ROI_DENSITY

See Also

MCitems Structure
MCitems Members


ROI_ELEMENTAL_COMPOSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROI_ELEMENTAL_COMPOSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROI_ELEMENTAL_COMPOSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROI_ELEMENTAL_COMPOSITION
Visual Basic
Public Shared ReadOnly ROI_ELEMENTAL_COMPOSITION As String
Visual C++
public:
static initonly String^ ROI_ELEMENTAL_COMPOSITION

See Also

MCitems Structure
MCitems Members


ROI_PHYSICAL_PROPERTIES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROI_PHYSICAL_PROPERTIES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROI_PHYSICAL_PROPERTIES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROI_PHYSICAL_PROPERTIES
Visual Basic
Public Shared ReadOnly ROI_PHYSICAL_PROPERTIES As String
Visual C++
public:
static initonly String^ ROI_PHYSICAL_PROPERTIES

See Also

MCitems Structure
MCitems Members


ROTATION_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ROTATION_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ROTATION_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROTATION_INFO
Visual Basic
Public Shared ReadOnly ROTATION_INFO As String
Visual C++
public:
static initonly String^ ROTATION_INFO

See Also

MCitems Structure
MCitems Members


RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO
Visual Basic
Public Shared ReadOnly RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO As String
Visual C++
public:
static initonly String^ RT_ACCESSORY_DEVICE_IDENTIFICATION_MACRO

See Also

MCitems Structure
MCitems Members


RT_ACCESSORY_HOLDER_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ACCESSORY_HOLDER_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ACCESSORY_HOLDER_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ACCESSORY_HOLDER_DEFINITION
Visual Basic
Public Shared ReadOnly RT_ACCESSORY_HOLDER_DEFINITION As String
Visual C++
public:
static initonly String^ RT_ACCESSORY_HOLDER_DEFINITION

See Also

MCitems Structure
MCitems Members


RT_ACCESSORY_HOLDER_SLOT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ACCESSORY_HOLDER_SLOT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ACCESSORY_HOLDER_SLOT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ACCESSORY_HOLDER_SLOT
Visual Basic
Public Shared ReadOnly RT_ACCESSORY_HOLDER_SLOT As String
Visual C++
public:
static initonly String^ RT_ACCESSORY_HOLDER_SLOT

See Also

MCitems Structure
MCitems Members


RT_ANATOMIC_PRESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ANATOMIC_PRESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ANATOMIC_PRESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ANATOMIC_PRESCRIPTION
Visual Basic
Public Shared ReadOnly RT_ANATOMIC_PRESCRIPTION As String
Visual C++
public:
static initonly String^ RT_ANATOMIC_PRESCRIPTION

See Also

MCitems Structure
MCitems Members


RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO
Visual Basic
Public Shared ReadOnly RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO As String
Visual C++
public:
static initonly String^ RT_BEAM_LIMITING_DEVICE_DEFINITION_MACRO

See Also

MCitems Structure
MCitems Members


RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO
Visual Basic
Public Shared ReadOnly RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO As String
Visual C++
public:
static initonly String^ RT_BEAM_LIMITING_DEVICE_OPENING_DEFINITION_MACRO

See Also

MCitems Structure
MCitems Members


RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO
Visual Basic
Public Shared ReadOnly RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO As String
Visual C++
public:
static initonly String^ RT_BEAM_LIMITING_DEVICE_OPENING_SEQUENCE_MACRO

See Also

MCitems Structure
MCitems Members


RT_DOSE_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_DOSE_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_DOSE_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_DOSE_ROI
Visual Basic
Public Shared ReadOnly RT_DOSE_ROI As String
Visual C++
public:
static initonly String^ RT_DOSE_ROI

See Also

MCitems Structure
MCitems Members


RT_IMAGE_FRAME_CONTEXT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_IMAGE_FRAME_CONTEXT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_IMAGE_FRAME_CONTEXT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_IMAGE_FRAME_CONTEXT
Visual Basic
Public Shared ReadOnly RT_IMAGE_FRAME_CONTEXT As String
Visual C++
public:
static initonly String^ RT_IMAGE_FRAME_CONTEXT

See Also

MCitems Structure
MCitems Members


RT_IMAGE_FRAME_GENERAL_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_IMAGE_FRAME_GENERAL_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_IMAGE_FRAME_GENERAL_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_IMAGE_FRAME_GENERAL_CONTENT
Visual Basic
Public Shared ReadOnly RT_IMAGE_FRAME_GENERAL_CONTENT As String
Visual C++
public:
static initonly String^ RT_IMAGE_FRAME_GENERAL_CONTENT

See Also

MCitems Structure
MCitems Members


RT_IMAGE_FRAME_RADIATION_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_IMAGE_FRAME_RADIATION_ACQUISITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_IMAGE_FRAME_RADIATION_ACQUISITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_IMAGE_FRAME_RADIATION_ACQUISITION
Visual Basic
Public Shared ReadOnly RT_IMAGE_FRAME_RADIATION_ACQUISITION As String
Visual C++
public:
static initonly String^ RT_IMAGE_FRAME_RADIATION_ACQUISITION

See Also

MCitems Structure
MCitems Members


RT_MOTION_SYNCHRONIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_MOTION_SYNCHRONIZATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_MOTION_SYNCHRONIZATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_MOTION_SYNCHRONIZATION
Visual Basic
Public Shared ReadOnly RT_MOTION_SYNCHRONIZATION As String
Visual C++
public:
static initonly String^ RT_MOTION_SYNCHRONIZATION

See Also

MCitems Structure
MCitems Members


RT_PATIENT_POSITION_DISPLACEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PATIENT_POSITION_DISPLACEMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PATIENT_POSITION_DISPLACEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PATIENT_POSITION_DISPLACEMENT
Visual Basic
Public Shared ReadOnly RT_PATIENT_POSITION_DISPLACEMENT As String
Visual C++
public:
static initonly String^ RT_PATIENT_POSITION_DISPLACEMENT

See Also

MCitems Structure
MCitems Members


RT_PATIENT_POSITION_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PATIENT_POSITION_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PATIENT_POSITION_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PATIENT_POSITION_MACRO
Visual Basic
Public Shared ReadOnly RT_PATIENT_POSITION_MACRO As String
Visual C++
public:
static initonly String^ RT_PATIENT_POSITION_MACRO

See Also

MCitems Structure
MCitems Members


RT_PATIENT_POSITION_SCOPE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PATIENT_POSITION_SCOPE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PATIENT_POSITION_SCOPE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PATIENT_POSITION_SCOPE_MACRO
Visual Basic
Public Shared ReadOnly RT_PATIENT_POSITION_SCOPE_MACRO As String
Visual C++
public:
static initonly String^ RT_PATIENT_POSITION_SCOPE_MACRO

See Also

MCitems Structure
MCitems Members


RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO
Visual Basic
Public Shared ReadOnly RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO As String
Visual C++
public:
static initonly String^ RT_PATIENT_POSITION_SCOPE_WITH_LEGACY_SUPPORT_MACRO

See Also

MCitems Structure
MCitems Members


RT_PHYSICIAN_INTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PHYSICIAN_INTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PHYSICIAN_INTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PHYSICIAN_INTENT
Visual Basic
Public Shared ReadOnly RT_PHYSICIAN_INTENT As String
Visual C++
public:
static initonly String^ RT_PHYSICIAN_INTENT

See Also

MCitems Structure
MCitems Members


RT_PHYSICIAN_INTENT_INPUT_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PHYSICIAN_INTENT_INPUT_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PHYSICIAN_INTENT_INPUT_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PHYSICIAN_INTENT_INPUT_INSTANCE
Visual Basic
Public Shared ReadOnly RT_PHYSICIAN_INTENT_INPUT_INSTANCE As String
Visual C++
public:
static initonly String^ RT_PHYSICIAN_INTENT_INPUT_INSTANCE

See Also

MCitems Structure
MCitems Members


RT_PHYSICIAN_INTENT_PREDECESSOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PHYSICIAN_INTENT_PREDECESSOR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PHYSICIAN_INTENT_PREDECESSOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PHYSICIAN_INTENT_PREDECESSOR
Visual Basic
Public Shared ReadOnly RT_PHYSICIAN_INTENT_PREDECESSOR As String
Visual C++
public:
static initonly String^ RT_PHYSICIAN_INTENT_PREDECESSOR

See Also

MCitems Structure
MCitems Members


RT_PRESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_PRESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_PRESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PRESCRIPTION
Visual Basic
Public Shared ReadOnly RT_PRESCRIPTION As String
Visual C++
public:
static initonly String^ RT_PRESCRIPTION

See Also

MCitems Structure
MCitems Members


RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT
Visual Basic
Public Shared ReadOnly RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT As String
Visual C++
public:
static initonly String^ RT_RADIATION_SALVAGE_RECORD_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


RT_RADIATION_TASK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_RADIATION_TASK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_RADIATION_TASK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_TASK
Visual Basic
Public Shared ReadOnly RT_RADIATION_TASK As String
Visual C++
public:
static initonly String^ RT_RADIATION_TASK

See Also

MCitems Structure
MCitems Members


RT_RELATED_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_RELATED_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_RELATED_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RELATED_ROI
Visual Basic
Public Shared ReadOnly RT_RELATED_ROI As String
Visual C++
public:
static initonly String^ RT_RELATED_ROI

See Also

MCitems Structure
MCitems Members


RT_ROI_IDENTIFICATION_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ROI_IDENTIFICATION_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ROI_IDENTIFICATION_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ROI_IDENTIFICATION_CODE
Visual Basic
Public Shared ReadOnly RT_ROI_IDENTIFICATION_CODE As String
Visual C++
public:
static initonly String^ RT_ROI_IDENTIFICATION_CODE

See Also

MCitems Structure
MCitems Members


RT_ROI_OBSERVATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_ROI_OBSERVATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_ROI_OBSERVATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ROI_OBSERVATIONS
Visual Basic
Public Shared ReadOnly RT_ROI_OBSERVATIONS As String
Visual C++
public:
static initonly String^ RT_ROI_OBSERVATIONS

See Also

MCitems Structure
MCitems Members


RT_SEGMENT_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_SEGMENT_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_SEGMENT_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_SEGMENT_ANNOTATION
Visual Basic
Public Shared ReadOnly RT_SEGMENT_ANNOTATION As String
Visual C++
public:
static initonly String^ RT_SEGMENT_ANNOTATION

See Also

MCitems Structure
MCitems Members


RT_TOLERANCE_SET_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_TOLERANCE_SET_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_TOLERANCE_SET_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_TOLERANCE_SET_MACRO
Visual Basic
Public Shared ReadOnly RT_TOLERANCE_SET_MACRO As String
Visual C++
public:
static initonly String^ RT_TOLERANCE_SET_MACRO

See Also

MCitems Structure
MCitems Members


RT_TREATMENT_PHASE_INTERVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_TREATMENT_PHASE_INTERVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_TREATMENT_PHASE_INTERVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_TREATMENT_PHASE_INTERVAL
Visual Basic
Public Shared ReadOnly RT_TREATMENT_PHASE_INTERVAL As String
Visual C++
public:
static initonly String^ RT_TREATMENT_PHASE_INTERVAL

See Also

MCitems Structure
MCitems Members


RT_TREATMENT_PHASE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..RT_TREATMENT_PHASE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.RT_TREATMENT_PHASE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_TREATMENT_PHASE_MACRO
Visual Basic
Public Shared ReadOnly RT_TREATMENT_PHASE_MACRO As String
Visual C++
public:
static initonly String^ RT_TREATMENT_PHASE_MACRO

See Also

MCitems Structure
MCitems Members


SCHED_HUMAN_PERFORMERS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHED_HUMAN_PERFORMERS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHED_HUMAN_PERFORMERS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHED_HUMAN_PERFORMERS
Visual Basic
Public Shared ReadOnly SCHED_HUMAN_PERFORMERS As String
Visual C++
public:
static initonly String^ SCHED_HUMAN_PERFORMERS

See Also

MCitems Structure
MCitems Members


SCHED_HUMAN_PERFORMERS_M Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHED_HUMAN_PERFORMERS_M Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHED_HUMAN_PERFORMERS_M"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHED_HUMAN_PERFORMERS_M
Visual Basic
Public Shared ReadOnly SCHED_HUMAN_PERFORMERS_M As String
Visual C++
public:
static initonly String^ SCHED_HUMAN_PERFORMERS_M

See Also

MCitems Structure
MCitems Members


SCHEDULED_ACTION_ITEM_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_ACTION_ITEM_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_ACTION_ITEM_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_ACTION_ITEM_CODE
Visual Basic
Public Shared ReadOnly SCHEDULED_ACTION_ITEM_CODE As String
Visual C++
public:
static initonly String^ SCHEDULED_ACTION_ITEM_CODE

See Also

MCitems Structure
MCitems Members


SCHEDULED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_PROCEDURE_STEP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_PROCEDURE_STEP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_PROCEDURE_STEP
Visual Basic
Public Shared ReadOnly SCHEDULED_PROCEDURE_STEP As String
Visual C++
public:
static initonly String^ SCHEDULED_PROCEDURE_STEP

See Also

MCitems Structure
MCitems Members


SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ SCHEDULED_PROCEDURE_STEP_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


SCHEDULED_PROTOCOL_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_PROTOCOL_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_PROTOCOL_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_PROTOCOL_CODE
Visual Basic
Public Shared ReadOnly SCHEDULED_PROTOCOL_CODE As String
Visual C++
public:
static initonly String^ SCHEDULED_PROTOCOL_CODE

See Also

MCitems Structure
MCitems Members


SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ SCHEDULED_PROTOCOL_CODE_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


SCHEDULED_SPECIMEN_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_SPECIMEN_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_SPECIMEN_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_SPECIMEN_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly SCHEDULED_SPECIMEN_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ SCHEDULED_SPECIMEN_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


SCHEDULED_SPECIMEN_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_SPECIMEN_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_SPECIMEN_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_SPECIMEN_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly SCHEDULED_SPECIMEN_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ SCHEDULED_SPECIMEN_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


SCHEDULED_STEP_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCHEDULED_STEP_ATTRIBUTE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCHEDULED_STEP_ATTRIBUTE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCHEDULED_STEP_ATTRIBUTE
Visual Basic
Public Shared ReadOnly SCHEDULED_STEP_ATTRIBUTE As String
Visual C++
public:
static initonly String^ SCHEDULED_STEP_ATTRIBUTE

See Also

MCitems Structure
MCitems Members


SCOPE_OF_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCOPE_OF_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCOPE_OF_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCOPE_OF_INVENTORY
Visual Basic
Public Shared ReadOnly SCOPE_OF_INVENTORY As String
Visual C++
public:
static initonly String^ SCOPE_OF_INVENTORY

See Also

MCitems Structure
MCitems Members


SCREENING_BASELINE_MEASURED Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SCREENING_BASELINE_MEASURED Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SCREENING_BASELINE_MEASURED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SCREENING_BASELINE_MEASURED
Visual Basic
Public Shared ReadOnly SCREENING_BASELINE_MEASURED As String
Visual C++
public:
static initonly String^ SCREENING_BASELINE_MEASURED

See Also

MCitems Structure
MCitems Members


SEGMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENT
Visual Basic
Public Shared ReadOnly SEGMENT As String
Visual C++
public:
static initonly String^ SEGMENT

See Also

MCitems Structure
MCitems Members


SEGMENT_ANNOTATION_TYPE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENT_ANNOTATION_TYPE_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENT_ANNOTATION_TYPE_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENT_ANNOTATION_TYPE_CODE
Visual Basic
Public Shared ReadOnly SEGMENT_ANNOTATION_TYPE_CODE As String
Visual C++
public:
static initonly String^ SEGMENT_ANNOTATION_TYPE_CODE

See Also

MCitems Structure
MCitems Members


SEGMENT_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENT_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENT_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENT_IDENTIFICATION
Visual Basic
Public Shared ReadOnly SEGMENT_IDENTIFICATION As String
Visual C++
public:
static initonly String^ SEGMENT_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


SEGMENT_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENT_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENT_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENT_REFERENCE
Visual Basic
Public Shared ReadOnly SEGMENT_REFERENCE As String
Visual C++
public:
static initonly String^ SEGMENT_REFERENCE

See Also

MCitems Structure
MCitems Members


SEGMENTED_PROPERTY_TYPE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENTED_PROPERTY_TYPE_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENTED_PROPERTY_TYPE_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENTED_PROPERTY_TYPE_CODE
Visual Basic
Public Shared ReadOnly SEGMENTED_PROPERTY_TYPE_CODE As String
Visual C++
public:
static initonly String^ SEGMENTED_PROPERTY_TYPE_CODE

See Also

MCitems Structure
MCitems Members


SEGMENTED_RT_ACCESSORY_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SEGMENTED_RT_ACCESSORY_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SEGMENTED_RT_ACCESSORY_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENTED_RT_ACCESSORY_DEVICE
Visual Basic
Public Shared ReadOnly SEGMENTED_RT_ACCESSORY_DEVICE As String
Visual C++
public:
static initonly String^ SEGMENTED_RT_ACCESSORY_DEVICE

See Also

MCitems Structure
MCitems Members


SELECTED_FRAME_FUNCTIONAL_GROUPS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SELECTED_FRAME_FUNCTIONAL_GROUPS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SELECTED_FRAME_FUNCTIONAL_GROUPS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SELECTED_FRAME_FUNCTIONAL_GROUPS
Visual Basic
Public Shared ReadOnly SELECTED_FRAME_FUNCTIONAL_GROUPS As String
Visual C++
public:
static initonly String^ SELECTED_FRAME_FUNCTIONAL_GROUPS

See Also

MCitems Structure
MCitems Members


SELECTED_SEGMENTAL_OPHT_AXL_LEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SELECTED_SEGMENTAL_OPHT_AXL_LEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SELECTED_SEGMENTAL_OPHT_AXL_LEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SELECTED_SEGMENTAL_OPHT_AXL_LEN
Visual Basic
Public Shared ReadOnly SELECTED_SEGMENTAL_OPHT_AXL_LEN As String
Visual C++
public:
static initonly String^ SELECTED_SEGMENTAL_OPHT_AXL_LEN

See Also

MCitems Structure
MCitems Members


SELECTED_TOTAL_OPHT_AXL_LENGTH Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SELECTED_TOTAL_OPHT_AXL_LENGTH Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SELECTED_TOTAL_OPHT_AXL_LENGTH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SELECTED_TOTAL_OPHT_AXL_LENGTH
Visual Basic
Public Shared ReadOnly SELECTED_TOTAL_OPHT_AXL_LENGTH As String
Visual C++
public:
static initonly String^ SELECTED_TOTAL_OPHT_AXL_LENGTH

See Also

MCitems Structure
MCitems Members


SETUP_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SETUP_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SETUP_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SETUP_DEVICE
Visual Basic
Public Shared ReadOnly SETUP_DEVICE As String
Visual C++
public:
static initonly String^ SETUP_DEVICE

See Also

MCitems Structure
MCitems Members


SHIELDING_DEVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SHIELDING_DEVICE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SHIELDING_DEVICE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SHIELDING_DEVICE
Visual Basic
Public Shared ReadOnly SHIELDING_DEVICE As String
Visual C++
public:
static initonly String^ SHIELDING_DEVICE

See Also

MCitems Structure
MCitems Members


SIMULATED_KERATOMETRIC_CYLINDER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SIMULATED_KERATOMETRIC_CYLINDER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SIMULATED_KERATOMETRIC_CYLINDER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SIMULATED_KERATOMETRIC_CYLINDER
Visual Basic
Public Shared ReadOnly SIMULATED_KERATOMETRIC_CYLINDER As String
Visual C++
public:
static initonly String^ SIMULATED_KERATOMETRIC_CYLINDER

See Also

MCitems Structure
MCitems Members


SNOUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SNOUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SNOUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SNOUT
Visual Basic
Public Shared ReadOnly SNOUT As String
Visual C++
public:
static initonly String^ SNOUT

See Also

MCitems Structure
MCitems Members


SOFTCOPY_PRESENTATION_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOFTCOPY_PRESENTATION_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOFTCOPY_PRESENTATION_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOFTCOPY_PRESENTATION_LUT
Visual Basic
Public Shared ReadOnly SOFTCOPY_PRESENTATION_LUT As String
Visual C++
public:
static initonly String^ SOFTCOPY_PRESENTATION_LUT

See Also

MCitems Structure
MCitems Members


SOFTCOPY_VOI_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOFTCOPY_VOI_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOFTCOPY_VOI_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOFTCOPY_VOI_LUT
Visual Basic
Public Shared ReadOnly SOFTCOPY_VOI_LUT As String
Visual C++
public:
static initonly String^ SOFTCOPY_VOI_LUT

See Also

MCitems Structure
MCitems Members


SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS
Visual Basic
Public Shared ReadOnly SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS As String
Visual C++
public:
static initonly String^ SOFTCOPY_VOI_LUT_IN_ADVANCED_BLENDING_PS

See Also

MCitems Structure
MCitems Members


SOP_INSTANCE_REF_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOP_INSTANCE_REF_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOP_INSTANCE_REF_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOP_INSTANCE_REF_MACRO
Visual Basic
Public Shared ReadOnly SOP_INSTANCE_REF_MACRO As String
Visual C++
public:
static initonly String^ SOP_INSTANCE_REF_MACRO

See Also

MCitems Structure
MCitems Members


SORTING_OPERATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SORTING_OPERATIONS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SORTING_OPERATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SORTING_OPERATIONS
Visual Basic
Public Shared ReadOnly SORTING_OPERATIONS As String
Visual C++
public:
static initonly String^ SORTING_OPERATIONS

See Also

MCitems Structure
MCitems Members


SOUND_SPEED_CORRECTION_MECHANISM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOUND_SPEED_CORRECTION_MECHANISM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOUND_SPEED_CORRECTION_MECHANISM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOUND_SPEED_CORRECTION_MECHANISM
Visual Basic
Public Shared ReadOnly SOUND_SPEED_CORRECTION_MECHANISM As String
Visual C++
public:
static initonly String^ SOUND_SPEED_CORRECTION_MECHANISM

See Also

MCitems Structure
MCitems Members


SOURCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE
Visual Basic
Public Shared ReadOnly SOURCE As String
Visual C++
public:
static initonly String^ SOURCE

See Also

MCitems Structure
MCitems Members


SOURCE_CONCEPTUAL_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_CONCEPTUAL_VOLUME Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_CONCEPTUAL_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_CONCEPTUAL_VOLUME
Visual Basic
Public Shared ReadOnly SOURCE_CONCEPTUAL_VOLUME As String
Visual C++
public:
static initonly String^ SOURCE_CONCEPTUAL_VOLUME

See Also

MCitems Structure
MCitems Members


SOURCE_HANGING_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_HANGING_PROTOCOL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_HANGING_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_HANGING_PROTOCOL
Visual Basic
Public Shared ReadOnly SOURCE_HANGING_PROTOCOL As String
Visual C++
public:
static initonly String^ SOURCE_HANGING_PROTOCOL

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE_CORNEAL_PROCESSED_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE_CORNEAL_PROCESSED_DATA Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE_CORNEAL_PROCESSED_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE_CORNEAL_PROCESSED_DATA
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE_CORNEAL_PROCESSED_DATA As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE_CORNEAL_PROCESSED_DATA

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE_IN_CORNEAL_TOPOGRAPHY_MAP

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE_IN_DERIVATION_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE_IN_DERIVATION_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE_IN_DERIVATION_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE_IN_DERIVATION_IMAGE
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE_IN_DERIVATION_IMAGE As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE_IN_DERIVATION_IMAGE

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE_IN_ENHANCED_US Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE_IN_ENHANCED_US Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE_IN_ENHANCED_US"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE_IN_ENHANCED_US
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE_IN_ENHANCED_US As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE_IN_ENHANCED_US

See Also

MCitems Structure
MCitems Members


SOURCE_IMAGE_IN_OPHTHALMIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IMAGE_IN_OPHTHALMIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IMAGE_IN_OPHTHALMIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IMAGE_IN_OPHTHALMIC
Visual Basic
Public Shared ReadOnly SOURCE_IMAGE_IN_OPHTHALMIC As String
Visual C++
public:
static initonly String^ SOURCE_IMAGE_IN_OPHTHALMIC

See Also

MCitems Structure
MCitems Members


SOURCE_INSTANCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_INSTANCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_INSTANCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_INSTANCE
Visual Basic
Public Shared ReadOnly SOURCE_INSTANCE As String
Visual C++
public:
static initonly String^ SOURCE_INSTANCE

See Also

MCitems Structure
MCitems Members


SOURCE_IRRADIATION_EVENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_IRRADIATION_EVENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_IRRADIATION_EVENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_IRRADIATION_EVENT
Visual Basic
Public Shared ReadOnly SOURCE_IRRADIATION_EVENT As String
Visual C++
public:
static initonly String^ SOURCE_IRRADIATION_EVENT

See Also

MCitems Structure
MCitems Members


SOURCE_OF_REFRACTIVE_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_OF_REFRACTIVE_MEASUREMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_OF_REFRACTIVE_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_OF_REFRACTIVE_MEASUREMENTS
Visual Basic
Public Shared ReadOnly SOURCE_OF_REFRACTIVE_MEASUREMENTS As String
Visual C++
public:
static initonly String^ SOURCE_OF_REFRACTIVE_MEASUREMENTS

See Also

MCitems Structure
MCitems Members


SOURCE_PATIENT_GROUP_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_PATIENT_GROUP_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_PATIENT_GROUP_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_PATIENT_GROUP_IDENTIFICATION
Visual Basic
Public Shared ReadOnly SOURCE_PATIENT_GROUP_IDENTIFICATION As String
Visual C++
public:
static initonly String^ SOURCE_PATIENT_GROUP_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


SOURCE_PIXEL_PLANES_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_PIXEL_PLANES_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_PIXEL_PLANES_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_PIXEL_PLANES_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly SOURCE_PIXEL_PLANES_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ SOURCE_PIXEL_PLANES_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


SOURCE_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SOURCE_WAVEFORM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SOURCE_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SOURCE_WAVEFORM
Visual Basic
Public Shared ReadOnly SOURCE_WAVEFORM As String
Visual C++
public:
static initonly String^ SOURCE_WAVEFORM

See Also

MCitems Structure
MCitems Members


SPECIFIC_ABSORPTION_RATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIFIC_ABSORPTION_RATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIFIC_ABSORPTION_RATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIFIC_ABSORPTION_RATE
Visual Basic
Public Shared ReadOnly SPECIFIC_ABSORPTION_RATE As String
Visual C++
public:
static initonly String^ SPECIFIC_ABSORPTION_RATE

See Also

MCitems Structure
MCitems Members


SPECIMEN_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_DESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_DESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_DESCRIPTION
Visual Basic
Public Shared ReadOnly SPECIMEN_DESCRIPTION As String
Visual C++
public:
static initonly String^ SPECIMEN_DESCRIPTION

See Also

MCitems Structure
MCitems Members


SPECIMEN_DESCRIPTION_IN_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_DESCRIPTION_IN_IMAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_DESCRIPTION_IN_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_DESCRIPTION_IN_IMAGE
Visual Basic
Public Shared ReadOnly SPECIMEN_DESCRIPTION_IN_IMAGE As String
Visual C++
public:
static initonly String^ SPECIMEN_DESCRIPTION_IN_IMAGE

See Also

MCitems Structure
MCitems Members


SPECIMEN_DESCRIPTION_IN_INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_DESCRIPTION_IN_INVENTORY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_DESCRIPTION_IN_INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_DESCRIPTION_IN_INVENTORY
Visual Basic
Public Shared ReadOnly SPECIMEN_DESCRIPTION_IN_INVENTORY As String
Visual C++
public:
static initonly String^ SPECIMEN_DESCRIPTION_IN_INVENTORY

See Also

MCitems Structure
MCitems Members


SPECIMEN_DESCRIPTION_MWL_CFIND_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_DESCRIPTION_MWL_CFIND_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_DESCRIPTION_MWL_CFIND_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_DESCRIPTION_MWL_CFIND_RQ
Visual Basic
Public Shared ReadOnly SPECIMEN_DESCRIPTION_MWL_CFIND_RQ As String
Visual C++
public:
static initonly String^ SPECIMEN_DESCRIPTION_MWL_CFIND_RQ

See Also

MCitems Structure
MCitems Members


SPECIMEN_DESCRIPTION_MWL_CFIND_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_DESCRIPTION_MWL_CFIND_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_DESCRIPTION_MWL_CFIND_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_DESCRIPTION_MWL_CFIND_RSP
Visual Basic
Public Shared ReadOnly SPECIMEN_DESCRIPTION_MWL_CFIND_RSP As String
Visual C++
public:
static initonly String^ SPECIMEN_DESCRIPTION_MWL_CFIND_RSP

See Also

MCitems Structure
MCitems Members


SPECIMEN_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_MACRO
Visual Basic
Public Shared ReadOnly SPECIMEN_MACRO As String
Visual C++
public:
static initonly String^ SPECIMEN_MACRO

See Also

MCitems Structure
MCitems Members


SPECIMEN_PREPARATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_PREPARATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_PREPARATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_PREPARATION
Visual Basic
Public Shared ReadOnly SPECIMEN_PREPARATION As String
Visual C++
public:
static initonly String^ SPECIMEN_PREPARATION

See Also

MCitems Structure
MCitems Members


SPECIMEN_REFERENCE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SPECIMEN_REFERENCE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SPECIMEN_REFERENCE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECIMEN_REFERENCE
Visual Basic
Public Shared ReadOnly SPECIMEN_REFERENCE As String
Visual C++
public:
static initonly String^ SPECIMEN_REFERENCE

See Also

MCitems Structure
MCitems Members


SR_CONTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SR_CONTENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SR_CONTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SR_CONTENT
Visual Basic
Public Shared ReadOnly SR_CONTENT As String
Visual C++
public:
static initonly String^ SR_CONTENT

See Also

MCitems Structure
MCitems Members


STEEP_CORNEAL_AXIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STEEP_CORNEAL_AXIS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STEEP_CORNEAL_AXIS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STEEP_CORNEAL_AXIS
Visual Basic
Public Shared ReadOnly STEEP_CORNEAL_AXIS As String
Visual C++
public:
static initonly String^ STEEP_CORNEAL_AXIS

See Also

MCitems Structure
MCitems Members


STEREO_PAIRS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STEREO_PAIRS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STEREO_PAIRS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STEREO_PAIRS
Visual Basic
Public Shared ReadOnly STEREO_PAIRS As String
Visual C++
public:
static initonly String^ STEREO_PAIRS

See Also

MCitems Structure
MCitems Members


STORAGE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STORAGE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STORAGE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORAGE_MACRO
Visual Basic
Public Shared ReadOnly STORAGE_MACRO As String
Visual C++
public:
static initonly String^ STORAGE_MACRO

See Also

MCitems Structure
MCitems Members


STORAGE_PROTOCOL_ELEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STORAGE_PROTOCOL_ELEMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STORAGE_PROTOCOL_ELEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORAGE_PROTOCOL_ELEMENT
Visual Basic
Public Shared ReadOnly STORAGE_PROTOCOL_ELEMENT As String
Visual C++
public:
static initonly String^ STORAGE_PROTOCOL_ELEMENT

See Also

MCitems Structure
MCitems Members


STORAGE_PROTOCOL_ELEMENT_SPECIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STORAGE_PROTOCOL_ELEMENT_SPECIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STORAGE_PROTOCOL_ELEMENT_SPECIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORAGE_PROTOCOL_ELEMENT_SPECIFICATION
Visual Basic
Public Shared ReadOnly STORAGE_PROTOCOL_ELEMENT_SPECIFICATION As String
Visual C++
public:
static initonly String^ STORAGE_PROTOCOL_ELEMENT_SPECIFICATION

See Also

MCitems Structure
MCitems Members


STORED_VALUE_COLOR_RANGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STORED_VALUE_COLOR_RANGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STORED_VALUE_COLOR_RANGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORED_VALUE_COLOR_RANGE
Visual Basic
Public Shared ReadOnly STORED_VALUE_COLOR_RANGE As String
Visual C++
public:
static initonly String^ STORED_VALUE_COLOR_RANGE

See Also

MCitems Structure
MCitems Members


STOW_RS_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STOW_RS_STORAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STOW_RS_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STOW_RS_STORAGE
Visual Basic
Public Shared ReadOnly STOW_RS_STORAGE As String
Visual C++
public:
static initonly String^ STOW_RS_STORAGE

See Also

MCitems Structure
MCitems Members


STOW_RS_STORAGE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STOW_RS_STORAGE_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STOW_RS_STORAGE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STOW_RS_STORAGE_GET
Visual Basic
Public Shared ReadOnly STOW_RS_STORAGE_GET As String
Visual C++
public:
static initonly String^ STOW_RS_STORAGE_GET

See Also

MCitems Structure
MCitems Members


STRAIN_STOCK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STRAIN_STOCK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STRAIN_STOCK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STRAIN_STOCK
Visual Basic
Public Shared ReadOnly STRAIN_STOCK As String
Visual C++
public:
static initonly String^ STRAIN_STOCK

See Also

MCitems Structure
MCitems Members


STRUCTURE_SET_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STRUCTURE_SET_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STRUCTURE_SET_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STRUCTURE_SET_ROI
Visual Basic
Public Shared ReadOnly STRUCTURE_SET_ROI As String
Visual C++
public:
static initonly String^ STRUCTURE_SET_ROI

See Also

MCitems Structure
MCitems Members


STRUCTURED_CONSTRAINT_OBSERVATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STRUCTURED_CONSTRAINT_OBSERVATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STRUCTURED_CONSTRAINT_OBSERVATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STRUCTURED_CONSTRAINT_OBSERVATION
Visual Basic
Public Shared ReadOnly STRUCTURED_CONSTRAINT_OBSERVATION As String
Visual C++
public:
static initonly String^ STRUCTURED_CONSTRAINT_OBSERVATION

See Also

MCitems Structure
MCitems Members


STRUCTURED_DISPLAY_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STRUCTURED_DISPLAY_IMAGE_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STRUCTURED_DISPLAY_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STRUCTURED_DISPLAY_IMAGE_BOX
Visual Basic
Public Shared ReadOnly STRUCTURED_DISPLAY_IMAGE_BOX As String
Visual C++
public:
static initonly String^ STRUCTURED_DISPLAY_IMAGE_BOX

See Also

MCitems Structure
MCitems Members


STRUCTURED_DISPLAY_TEXT_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STRUCTURED_DISPLAY_TEXT_BOX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STRUCTURED_DISPLAY_TEXT_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STRUCTURED_DISPLAY_TEXT_BOX
Visual Basic
Public Shared ReadOnly STRUCTURED_DISPLAY_TEXT_BOX As String
Visual C++
public:
static initonly String^ STRUCTURED_DISPLAY_TEXT_BOX

See Also

MCitems Structure
MCitems Members


STUDIES_CONTAIN_OTHER_REF_INST Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..STUDIES_CONTAIN_OTHER_REF_INST Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.STUDIES_CONTAIN_OTHER_REF_INST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDIES_CONTAIN_OTHER_REF_INST
Visual Basic
Public Shared ReadOnly STUDIES_CONTAIN_OTHER_REF_INST As String
Visual C++
public:
static initonly String^ STUDIES_CONTAIN_OTHER_REF_INST

See Also

MCitems Structure
MCitems Members


SUBJECTIVE_REFRACTION_EYE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SUBJECTIVE_REFRACTION_EYE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SUBJECTIVE_REFRACTION_EYE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SUBJECTIVE_REFRACTION_EYE
Visual Basic
Public Shared ReadOnly SUBJECTIVE_REFRACTION_EYE As String
Visual C++
public:
static initonly String^ SUBJECTIVE_REFRACTION_EYE

See Also

MCitems Structure
MCitems Members


SUPPORTED_IMAGE_DISPLAY_FORMATS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SUPPORTED_IMAGE_DISPLAY_FORMATS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SUPPORTED_IMAGE_DISPLAY_FORMATS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SUPPORTED_IMAGE_DISPLAY_FORMATS
Visual Basic
Public Shared ReadOnly SUPPORTED_IMAGE_DISPLAY_FORMATS As String
Visual C++
public:
static initonly String^ SUPPORTED_IMAGE_DISPLAY_FORMATS

See Also

MCitems Structure
MCitems Members


SURFACE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURFACE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURFACE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE
Visual Basic
Public Shared ReadOnly SURFACE As String
Visual C++
public:
static initonly String^ SURFACE

See Also

MCitems Structure
MCitems Members


SURFACE_MESH_PR_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURFACE_MESH_PR_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURFACE_MESH_PR_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_MESH_PR_MACRO
Visual Basic
Public Shared ReadOnly SURFACE_MESH_PR_MACRO As String
Visual C++
public:
static initonly String^ SURFACE_MESH_PR_MACRO

See Also

MCitems Structure
MCitems Members


SURFACE_MESH_PR_MACRO_CP1365 Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURFACE_MESH_PR_MACRO_CP1365 Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURFACE_MESH_PR_MACRO_CP1365"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_MESH_PR_MACRO_CP1365
Visual Basic
Public Shared ReadOnly SURFACE_MESH_PR_MACRO_CP1365 As String
Visual C++
public:
static initonly String^ SURFACE_MESH_PR_MACRO_CP1365

See Also

MCitems Structure
MCitems Members


SURFACE_MODEL_DESCRIPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURFACE_MODEL_DESCRIPTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURFACE_MODEL_DESCRIPTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_MODEL_DESCRIPTION
Visual Basic
Public Shared ReadOnly SURFACE_MODEL_DESCRIPTION As String
Visual C++
public:
static initonly String^ SURFACE_MODEL_DESCRIPTION

See Also

MCitems Structure
MCitems Members


SURFACE_POINTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURFACE_POINTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURFACE_POINTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_POINTS
Visual Basic
Public Shared ReadOnly SURFACE_POINTS As String
Visual C++
public:
static initonly String^ SURFACE_POINTS

See Also

MCitems Structure
MCitems Members


SURGICALLY_INDUCED_ASTIGMATISM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SURGICALLY_INDUCED_ASTIGMATISM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SURGICALLY_INDUCED_ASTIGMATISM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURGICALLY_INDUCED_ASTIGMATISM
Visual Basic
Public Shared ReadOnly SURGICALLY_INDUCED_ASTIGMATISM As String
Visual C++
public:
static initonly String^ SURGICALLY_INDUCED_ASTIGMATISM

See Also

MCitems Structure
MCitems Members


SYNCHRONIZED_SCROLLING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..SYNCHRONIZED_SCROLLING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.SYNCHRONIZED_SCROLLING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SYNCHRONIZED_SCROLLING
Visual Basic
Public Shared ReadOnly SYNCHRONIZED_SCROLLING As String
Visual C++
public:
static initonly String^ SYNCHRONIZED_SCROLLING

See Also

MCitems Structure
MCitems Members


TABLE_COLUMN_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TABLE_COLUMN_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TABLE_COLUMN_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TABLE_COLUMN_DEFINITION
Visual Basic
Public Shared ReadOnly TABLE_COLUMN_DEFINITION As String
Visual C++
public:
static initonly String^ TABLE_COLUMN_DEFINITION

See Also

MCitems Structure
MCitems Members


TABLE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TABLE_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TABLE_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TABLE_POSITION
Visual Basic
Public Shared ReadOnly TABLE_POSITION As String
Visual C++
public:
static initonly String^ TABLE_POSITION

See Also

MCitems Structure
MCitems Members


TABLE_ROW_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TABLE_ROW_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TABLE_ROW_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TABLE_ROW_DEFINITION
Visual Basic
Public Shared ReadOnly TABLE_ROW_DEFINITION As String
Visual C++
public:
static initonly String^ TABLE_ROW_DEFINITION

See Also

MCitems Structure
MCitems Members


TABULATED_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TABULATED_VALUES Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TABULATED_VALUES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TABULATED_VALUES
Visual Basic
Public Shared ReadOnly TABULATED_VALUES As String
Visual C++
public:
static initonly String^ TABULATED_VALUES

See Also

MCitems Structure
MCitems Members


TARGET_LUMINANCE_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TARGET_LUMINANCE_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TARGET_LUMINANCE_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TARGET_LUMINANCE_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly TARGET_LUMINANCE_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ TARGET_LUMINANCE_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


TARGET_LUMINANCE_CHARACTERISTICS_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TARGET_LUMINANCE_CHARACTERISTICS_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TARGET_LUMINANCE_CHARACTERISTICS_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TARGET_LUMINANCE_CHARACTERISTICS_SCP
Visual Basic
Public Shared ReadOnly TARGET_LUMINANCE_CHARACTERISTICS_SCP As String
Visual C++
public:
static initonly String^ TARGET_LUMINANCE_CHARACTERISTICS_SCP

See Also

MCitems Structure
MCitems Members


TARGET_LUMINANCE_CHARACTERISTICS_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TARGET_LUMINANCE_CHARACTERISTICS_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TARGET_LUMINANCE_CHARACTERISTICS_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TARGET_LUMINANCE_CHARACTERISTICS_SCU
Visual Basic
Public Shared ReadOnly TARGET_LUMINANCE_CHARACTERISTICS_SCU As String
Visual C++
public:
static initonly String^ TARGET_LUMINANCE_CHARACTERISTICS_SCU

See Also

MCitems Structure
MCitems Members


TEMPORAL_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TEMPORAL_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TEMPORAL_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TEMPORAL_POSITION
Visual Basic
Public Shared ReadOnly TEMPORAL_POSITION As String
Visual C++
public:
static initonly String^ TEMPORAL_POSITION

See Also

MCitems Structure
MCitems Members


TEXT_OBJECT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TEXT_OBJECT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TEXT_OBJECT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TEXT_OBJECT
Visual Basic
Public Shared ReadOnly TEXT_OBJECT As String
Visual C++
public:
static initonly String^ TEXT_OBJECT

See Also

MCitems Structure
MCitems Members


TEXT_OBJECT_VOLUMETRIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TEXT_OBJECT_VOLUMETRIC Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TEXT_OBJECT_VOLUMETRIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TEXT_OBJECT_VOLUMETRIC
Visual Basic
Public Shared ReadOnly TEXT_OBJECT_VOLUMETRIC As String
Visual C++
public:
static initonly String^ TEXT_OBJECT_VOLUMETRIC

See Also

MCitems Structure
MCitems Members


TEXT_STYLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TEXT_STYLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TEXT_STYLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TEXT_STYLE
Visual Basic
Public Shared ReadOnly TEXT_STYLE As String
Visual C++
public:
static initonly String^ TEXT_STYLE

See Also

MCitems Structure
MCitems Members


THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..THRESHOLD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.THRESHOLD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string THRESHOLD
Visual Basic
Public Shared ReadOnly THRESHOLD As String
Visual C++
public:
static initonly String^ THRESHOLD

See Also

MCitems Structure
MCitems Members


THRESHOLD_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..THRESHOLD_VALUE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.THRESHOLD_VALUE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string THRESHOLD_VALUE
Visual Basic
Public Shared ReadOnly THRESHOLD_VALUE As String
Visual C++
public:
static initonly String^ THRESHOLD_VALUE

See Also

MCitems Structure
MCitems Members


TIME_BASED_IMAGE_SETS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TIME_BASED_IMAGE_SETS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TIME_BASED_IMAGE_SETS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TIME_BASED_IMAGE_SETS
Visual Basic
Public Shared ReadOnly TIME_BASED_IMAGE_SETS As String
Visual C++
public:
static initonly String^ TIME_BASED_IMAGE_SETS

See Also

MCitems Structure
MCitems Members


TIME_OF_FRAME_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TIME_OF_FRAME_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TIME_OF_FRAME_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TIME_OF_FRAME_GROUP
Visual Basic
Public Shared ReadOnly TIME_OF_FRAME_GROUP As String
Visual C++
public:
static initonly String^ TIME_OF_FRAME_GROUP

See Also

MCitems Structure
MCitems Members


TIME_SLOT_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TIME_SLOT_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TIME_SLOT_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TIME_SLOT_INFO
Visual Basic
Public Shared ReadOnly TIME_SLOT_INFO As String
Visual C++
public:
static initonly String^ TIME_SLOT_INFO

See Also

MCitems Structure
MCitems Members


TOLERANCE_TABLE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TOLERANCE_TABLE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TOLERANCE_TABLE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TOLERANCE_TABLE
Visual Basic
Public Shared ReadOnly TOLERANCE_TABLE As String
Visual C++
public:
static initonly String^ TOLERANCE_TABLE

See Also

MCitems Structure
MCitems Members


TOMOTHERAPEUTIC_CONTROL_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TOMOTHERAPEUTIC_CONTROL_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TOMOTHERAPEUTIC_CONTROL_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TOMOTHERAPEUTIC_CONTROL_POINT
Visual Basic
Public Shared ReadOnly TOMOTHERAPEUTIC_CONTROL_POINT As String
Visual C++
public:
static initonly String^ TOMOTHERAPEUTIC_CONTROL_POINT

See Also

MCitems Structure
MCitems Members


TOTAL_PIXEL_MATRIX_ORIGIN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TOTAL_PIXEL_MATRIX_ORIGIN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TOTAL_PIXEL_MATRIX_ORIGIN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TOTAL_PIXEL_MATRIX_ORIGIN
Visual Basic
Public Shared ReadOnly TOTAL_PIXEL_MATRIX_ORIGIN As String
Visual C++
public:
static initonly String^ TOTAL_PIXEL_MATRIX_ORIGIN

See Also

MCitems Structure
MCitems Members


TRACK Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRACK Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRACK"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACK
Visual Basic
Public Shared ReadOnly TRACK As String
Visual C++
public:
static initonly String^ TRACK

See Also

MCitems Structure
MCitems Members


TRACK_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRACK_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRACK_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACK_SET
Visual Basic
Public Shared ReadOnly TRACK_SET As String
Visual C++
public:
static initonly String^ TRACK_SET

See Also

MCitems Structure
MCitems Members


TRACK_SET_ANATOMICAL_TYPE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRACK_SET_ANATOMICAL_TYPE_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRACK_SET_ANATOMICAL_TYPE_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACK_SET_ANATOMICAL_TYPE_CODE
Visual Basic
Public Shared ReadOnly TRACK_SET_ANATOMICAL_TYPE_CODE As String
Visual C++
public:
static initonly String^ TRACK_SET_ANATOMICAL_TYPE_CODE

See Also

MCitems Structure
MCitems Members


TRACK_SET_STATISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRACK_SET_STATISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRACK_SET_STATISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACK_SET_STATISTICS
Visual Basic
Public Shared ReadOnly TRACK_SET_STATISTICS As String
Visual C++
public:
static initonly String^ TRACK_SET_STATISTICS

See Also

MCitems Structure
MCitems Members


TRACK_STATISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRACK_STATISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRACK_STATISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACK_STATISTICS
Visual Basic
Public Shared ReadOnly TRACK_STATISTICS As String
Visual C++
public:
static initonly String^ TRACK_STATISTICS

See Also

MCitems Structure
MCitems Members


TRANSDUCER_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRANSDUCER_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRANSDUCER_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRANSDUCER_IDENTIFICATION
Visual Basic
Public Shared ReadOnly TRANSDUCER_IDENTIFICATION As String
Visual C++
public:
static initonly String^ TRANSDUCER_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


TRANSDUCER_ORIENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRANSDUCER_ORIENTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRANSDUCER_ORIENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRANSDUCER_ORIENTATION
Visual Basic
Public Shared ReadOnly TRANSDUCER_ORIENTATION As String
Visual C++
public:
static initonly String^ TRANSDUCER_ORIENTATION

See Also

MCitems Structure
MCitems Members


TRANSDUCER_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRANSDUCER_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRANSDUCER_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRANSDUCER_POSITION
Visual Basic
Public Shared ReadOnly TRANSDUCER_POSITION As String
Visual C++
public:
static initonly String^ TRANSDUCER_POSITION

See Also

MCitems Structure
MCitems Members


TRANSDUCER_RESPONSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TRANSDUCER_RESPONSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TRANSDUCER_RESPONSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRANSDUCER_RESPONSE
Visual Basic
Public Shared ReadOnly TRANSDUCER_RESPONSE As String
Visual C++
public:
static initonly String^ TRANSDUCER_RESPONSE

See Also

MCitems Structure
MCitems Members


TREAT_SESSION_APPLICATION_SETUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREAT_SESSION_APPLICATION_SETUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREAT_SESSION_APPLICATION_SETUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREAT_SESSION_APPLICATION_SETUP
Visual Basic
Public Shared ReadOnly TREAT_SESSION_APPLICATION_SETUP As String
Visual C++
public:
static initonly String^ TREAT_SESSION_APPLICATION_SETUP

See Also

MCitems Structure
MCitems Members


TREAT_SUM_CALCULATED_DOSE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREAT_SUM_CALCULATED_DOSE_REF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREAT_SUM_CALCULATED_DOSE_REF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREAT_SUM_CALCULATED_DOSE_REF
Visual Basic
Public Shared ReadOnly TREAT_SUM_CALCULATED_DOSE_REF As String
Visual C++
public:
static initonly String^ TREAT_SUM_CALCULATED_DOSE_REF

See Also

MCitems Structure
MCitems Members


TREAT_SUM_MEASURED_DOSE_REF Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREAT_SUM_MEASURED_DOSE_REF Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREAT_SUM_MEASURED_DOSE_REF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREAT_SUM_MEASURED_DOSE_REF
Visual Basic
Public Shared ReadOnly TREAT_SUM_MEASURED_DOSE_REF As String
Visual C++
public:
static initonly String^ TREAT_SUM_MEASURED_DOSE_REF

See Also

MCitems Structure
MCitems Members


TREATMENT_DEVICE_IDENTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_DEVICE_IDENTIFICATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_DEVICE_IDENTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_DEVICE_IDENTIFICATION
Visual Basic
Public Shared ReadOnly TREATMENT_DEVICE_IDENTIFICATION As String
Visual C++
public:
static initonly String^ TREATMENT_DEVICE_IDENTIFICATION

See Also

MCitems Structure
MCitems Members


TREATMENT_MACHINE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_MACHINE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_MACHINE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_MACHINE
Visual Basic
Public Shared ReadOnly TREATMENT_MACHINE As String
Visual C++
public:
static initonly String^ TREATMENT_MACHINE

See Also

MCitems Structure
MCitems Members


TREATMENT_MACHINE_IN_TREAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_MACHINE_IN_TREAT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_MACHINE_IN_TREAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_MACHINE_IN_TREAT
Visual Basic
Public Shared ReadOnly TREATMENT_MACHINE_IN_TREAT As String
Visual C++
public:
static initonly String^ TREATMENT_MACHINE_IN_TREAT

See Also

MCitems Structure
MCitems Members


TREATMENT_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_POSITION
Visual Basic
Public Shared ReadOnly TREATMENT_POSITION As String
Visual C++
public:
static initonly String^ TREATMENT_POSITION

See Also

MCitems Structure
MCitems Members


TREATMENT_POSITION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_POSITION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_POSITION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_POSITION_GROUP
Visual Basic
Public Shared ReadOnly TREATMENT_POSITION_GROUP As String
Visual C++
public:
static initonly String^ TREATMENT_POSITION_GROUP

See Also

MCitems Structure
MCitems Members


TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO
Visual Basic
Public Shared ReadOnly TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO As String
Visual C++
public:
static initonly String^ TREATMENT_POSITION_GROUP_IN_RT_PATIENT_POSITION_SCOPE_MACRO

See Also

MCitems Structure
MCitems Members


TREATMENT_SESSION_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_SESSION_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_SESSION_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_SESSION_BEAM
Visual Basic
Public Shared ReadOnly TREATMENT_SESSION_BEAM As String
Visual C++
public:
static initonly String^ TREATMENT_SESSION_BEAM

See Also

MCitems Structure
MCitems Members


TREATMENT_SESSION_ION_BEAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_SESSION_ION_BEAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_SESSION_ION_BEAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_SESSION_ION_BEAM
Visual Basic
Public Shared ReadOnly TREATMENT_SESSION_ION_BEAM As String
Visual C++
public:
static initonly String^ TREATMENT_SESSION_ION_BEAM

See Also

MCitems Structure
MCitems Members


TREATMENT_SITE_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_SITE_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_SITE_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_SITE_CODE
Visual Basic
Public Shared ReadOnly TREATMENT_SITE_CODE As String
Visual C++
public:
static initonly String^ TREATMENT_SITE_CODE

See Also

MCitems Structure
MCitems Members


TREATMENT_TOLERANCE_VIOLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..TREATMENT_TOLERANCE_VIOLATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.TREATMENT_TOLERANCE_VIOLATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TREATMENT_TOLERANCE_VIOLATION
Visual Basic
Public Shared ReadOnly TREATMENT_TOLERANCE_VIOLATION As String
Visual C++
public:
static initonly String^ TREATMENT_TOLERANCE_VIOLATION

See Also

MCitems Structure
MCitems Members


UDI_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UDI_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UDI_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UDI_MACRO
Visual Basic
Public Shared ReadOnly UDI_MACRO As String
Visual C++
public:
static initonly String^ UDI_MACRO

See Also

MCitems Structure
MCitems Members


ULTRASOUND_OPHT_AXL_LEN_MEAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ULTRASOUND_OPHT_AXL_LEN_MEAS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ULTRASOUND_OPHT_AXL_LEN_MEAS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ULTRASOUND_OPHT_AXL_LEN_MEAS
Visual Basic
Public Shared ReadOnly ULTRASOUND_OPHT_AXL_LEN_MEAS As String
Visual C++
public:
static initonly String^ ULTRASOUND_OPHT_AXL_LEN_MEAS

See Also

MCitems Structure
MCitems Members


ULTRASOUND_REGION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ULTRASOUND_REGION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ULTRASOUND_REGION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ULTRASOUND_REGION
Visual Basic
Public Shared ReadOnly ULTRASOUND_REGION As String
Visual C++
public:
static initonly String^ ULTRASOUND_REGION

See Also

MCitems Structure
MCitems Members


ULTRASOUND_SEL_OPHT_AXL_LEN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..ULTRASOUND_SEL_OPHT_AXL_LEN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.ULTRASOUND_SEL_OPHT_AXL_LEN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ULTRASOUND_SEL_OPHT_AXL_LEN
Visual Basic
Public Shared ReadOnly ULTRASOUND_SEL_OPHT_AXL_LEN As String
Visual C++
public:
static initonly String^ ULTRASOUND_SEL_OPHT_AXL_LEN

See Also

MCitems Structure
MCitems Members


UPS_ACTUAL_HUMAN_PERF_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_ACTUAL_HUMAN_PERF_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_ACTUAL_HUMAN_PERF_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_ACTUAL_HUMAN_PERF_GET
Visual Basic
Public Shared ReadOnly UPS_ACTUAL_HUMAN_PERF_GET As String
Visual C++
public:
static initonly String^ UPS_ACTUAL_HUMAN_PERF_GET

See Also

MCitems Structure
MCitems Members


UPS_ACTUAL_HUMAN_PERF_SET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_ACTUAL_HUMAN_PERF_SET_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_ACTUAL_HUMAN_PERF_SET_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_ACTUAL_HUMAN_PERF_SET_RQ
Visual Basic
Public Shared ReadOnly UPS_ACTUAL_HUMAN_PERF_SET_RQ As String
Visual C++
public:
static initonly String^ UPS_ACTUAL_HUMAN_PERF_SET_RQ

See Also

MCitems Structure
MCitems Members


UPS_ACTUAL_HUMAN_PERF_SET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_ACTUAL_HUMAN_PERF_SET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_ACTUAL_HUMAN_PERF_SET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_ACTUAL_HUMAN_PERF_SET_RSP
Visual Basic
Public Shared ReadOnly UPS_ACTUAL_HUMAN_PERF_SET_RSP As String
Visual C++
public:
static initonly String^ UPS_ACTUAL_HUMAN_PERF_SET_RSP

See Also

MCitems Structure
MCitems Members


UPS_CODE_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_CODE_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_CODE_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_CODE_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_CODE_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_CODE_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_CODE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_CODE_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_CODE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_CODE_GET
Visual Basic
Public Shared ReadOnly UPS_CODE_GET As String
Visual C++
public:
static initonly String^ UPS_CODE_GET

See Also

MCitems Structure
MCitems Members


UPS_CODE_GET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_CODE_GET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_CODE_GET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_CODE_GET_RSP
Visual Basic
Public Shared ReadOnly UPS_CODE_GET_RSP As String
Visual C++
public:
static initonly String^ UPS_CODE_GET_RSP

See Also

MCitems Structure
MCitems Members


UPS_COMMUNICATIONS_URI_SET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_COMMUNICATIONS_URI_SET_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_COMMUNICATIONS_URI_SET_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_COMMUNICATIONS_URI_SET_RQ
Visual Basic
Public Shared ReadOnly UPS_COMMUNICATIONS_URI_SET_RQ As String
Visual C++
public:
static initonly String^ UPS_COMMUNICATIONS_URI_SET_RQ

See Also

MCitems Structure
MCitems Members


UPS_COMMUNICATIONS_URI_SET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_COMMUNICATIONS_URI_SET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_COMMUNICATIONS_URI_SET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_COMMUNICATIONS_URI_SET_RSP
Visual Basic
Public Shared ReadOnly UPS_COMMUNICATIONS_URI_SET_RSP As String
Visual C++
public:
static initonly String^ UPS_COMMUNICATIONS_URI_SET_RSP

See Also

MCitems Structure
MCitems Members


UPS_COMMUNICATIONS_URI_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_COMMUNICATIONS_URI_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_COMMUNICATIONS_URI_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_COMMUNICATIONS_URI_SQ
Visual Basic
Public Shared ReadOnly UPS_COMMUNICATIONS_URI_SQ As String
Visual C++
public:
static initonly String^ UPS_COMMUNICATIONS_URI_SQ

See Also

MCitems Structure
MCitems Members


UPS_CONTENT_ITEM_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_CONTENT_ITEM_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_CONTENT_ITEM_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_CONTENT_ITEM_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_CONTENT_ITEM_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_CONTENT_ITEM_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_CONTENT_ITEM_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_CONTENT_ITEM_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_CONTENT_ITEM_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_CONTENT_ITEM_GET
Visual Basic
Public Shared ReadOnly UPS_CONTENT_ITEM_GET As String
Visual C++
public:
static initonly String^ UPS_CONTENT_ITEM_GET

See Also

MCitems Structure
MCitems Members


UPS_DICOM_RETRIEVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_DICOM_RETRIEVAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_DICOM_RETRIEVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_DICOM_RETRIEVAL_GET
Visual Basic
Public Shared ReadOnly UPS_DICOM_RETRIEVAL_GET As String
Visual C++
public:
static initonly String^ UPS_DICOM_RETRIEVAL_GET

See Also

MCitems Structure
MCitems Members


UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE
Visual Basic
Public Shared ReadOnly UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE As String
Visual C++
public:
static initonly String^ UPS_HL7V2_HIERARCHIC_DESIGNATOR_CREATE

See Also

MCitems Structure
MCitems Members


UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET
Visual Basic
Public Shared ReadOnly UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET As String
Visual C++
public:
static initonly String^ UPS_HL7V2_HIERARCHIC_DESIGNATOR_GET

See Also

MCitems Structure
MCitems Members


UPS_ISSUER_OF_PAT_ID_QUAL_CREATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_ISSUER_OF_PAT_ID_QUAL_CREATE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_ISSUER_OF_PAT_ID_QUAL_CREATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_ISSUER_OF_PAT_ID_QUAL_CREATE
Visual Basic
Public Shared ReadOnly UPS_ISSUER_OF_PAT_ID_QUAL_CREATE As String
Visual C++
public:
static initonly String^ UPS_ISSUER_OF_PAT_ID_QUAL_CREATE

See Also

MCitems Structure
MCitems Members


UPS_ISSUER_OF_PAT_ID_QUAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_ISSUER_OF_PAT_ID_QUAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_ISSUER_OF_PAT_ID_QUAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_ISSUER_OF_PAT_ID_QUAL_GET
Visual Basic
Public Shared ReadOnly UPS_ISSUER_OF_PAT_ID_QUAL_GET As String
Visual C++
public:
static initonly String^ UPS_ISSUER_OF_PAT_ID_QUAL_GET

See Also

MCitems Structure
MCitems Members


UPS_MEDIA_RETRIEVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_MEDIA_RETRIEVAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_MEDIA_RETRIEVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_MEDIA_RETRIEVAL_GET
Visual Basic
Public Shared ReadOnly UPS_MEDIA_RETRIEVAL_GET As String
Visual C++
public:
static initonly String^ UPS_MEDIA_RETRIEVAL_GET

See Also

MCitems Structure
MCitems Members


UPS_OTHER_PATIENT_ID_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_OTHER_PATIENT_ID_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_OTHER_PATIENT_ID_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_OTHER_PATIENT_ID_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_OTHER_PATIENT_ID_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_OTHER_PATIENT_ID_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_OTHER_PATIENT_ID_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_OTHER_PATIENT_ID_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_OTHER_PATIENT_ID_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_OTHER_PATIENT_ID_GET
Visual Basic
Public Shared ReadOnly UPS_OTHER_PATIENT_ID_GET As String
Visual C++
public:
static initonly String^ UPS_OTHER_PATIENT_ID_GET

See Also

MCitems Structure
MCitems Members


UPS_PERF_PROC_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PERF_PROC_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PERF_PROC_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PERF_PROC_GET
Visual Basic
Public Shared ReadOnly UPS_PERF_PROC_GET As String
Visual C++
public:
static initonly String^ UPS_PERF_PROC_GET

See Also

MCitems Structure
MCitems Members


UPS_PERF_PROC_SET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PERF_PROC_SET_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PERF_PROC_SET_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PERF_PROC_SET_RQ
Visual Basic
Public Shared ReadOnly UPS_PERF_PROC_SET_RQ As String
Visual C++
public:
static initonly String^ UPS_PERF_PROC_SET_RQ

See Also

MCitems Structure
MCitems Members


UPS_PERF_PROC_SET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PERF_PROC_SET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PERF_PROC_SET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PERF_PROC_SET_RSP
Visual Basic
Public Shared ReadOnly UPS_PERF_PROC_SET_RSP As String
Visual C++
public:
static initonly String^ UPS_PERF_PROC_SET_RSP

See Also

MCitems Structure
MCitems Members


UPS_PERFORMED_PROCEDURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PERFORMED_PROCEDURE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PERFORMED_PROCEDURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PERFORMED_PROCEDURE
Visual Basic
Public Shared ReadOnly UPS_PERFORMED_PROCEDURE As String
Visual C++
public:
static initonly String^ UPS_PERFORMED_PROCEDURE

See Also

MCitems Structure
MCitems Members


UPS_PROGRESS_INFO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PROGRESS_INFO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PROGRESS_INFO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PROGRESS_INFO
Visual Basic
Public Shared ReadOnly UPS_PROGRESS_INFO As String
Visual C++
public:
static initonly String^ UPS_PROGRESS_INFO

See Also

MCitems Structure
MCitems Members


UPS_PROGRESS_INFO_EVENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PROGRESS_INFO_EVENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PROGRESS_INFO_EVENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PROGRESS_INFO_EVENT
Visual Basic
Public Shared ReadOnly UPS_PROGRESS_INFO_EVENT As String
Visual C++
public:
static initonly String^ UPS_PROGRESS_INFO_EVENT

See Also

MCitems Structure
MCitems Members


UPS_PROGRESS_INFO_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PROGRESS_INFO_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PROGRESS_INFO_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PROGRESS_INFO_GET
Visual Basic
Public Shared ReadOnly UPS_PROGRESS_INFO_GET As String
Visual C++
public:
static initonly String^ UPS_PROGRESS_INFO_GET

See Also

MCitems Structure
MCitems Members


UPS_PROGRESS_INFO_SET_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PROGRESS_INFO_SET_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PROGRESS_INFO_SET_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PROGRESS_INFO_SET_RQ
Visual Basic
Public Shared ReadOnly UPS_PROGRESS_INFO_SET_RQ As String
Visual C++
public:
static initonly String^ UPS_PROGRESS_INFO_SET_RQ

See Also

MCitems Structure
MCitems Members


UPS_PROGRESS_INFO_SET_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_PROGRESS_INFO_SET_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_PROGRESS_INFO_SET_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PROGRESS_INFO_SET_RSP
Visual Basic
Public Shared ReadOnly UPS_PROGRESS_INFO_SET_RSP As String
Visual C++
public:
static initonly String^ UPS_PROGRESS_INFO_SET_RSP

See Also

MCitems Structure
MCitems Members


UPS_REF_REQUEST_CREATE_RQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REF_REQUEST_CREATE_RQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REF_REQUEST_CREATE_RQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REF_REQUEST_CREATE_RQ
Visual Basic
Public Shared ReadOnly UPS_REF_REQUEST_CREATE_RQ As String
Visual C++
public:
static initonly String^ UPS_REF_REQUEST_CREATE_RQ

See Also

MCitems Structure
MCitems Members


UPS_REF_REQUEST_CREATE_RSP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REF_REQUEST_CREATE_RSP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REF_REQUEST_CREATE_RSP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REF_REQUEST_CREATE_RSP
Visual Basic
Public Shared ReadOnly UPS_REF_REQUEST_CREATE_RSP As String
Visual C++
public:
static initonly String^ UPS_REF_REQUEST_CREATE_RSP

See Also

MCitems Structure
MCitems Members


UPS_REF_REQUEST_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REF_REQUEST_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REF_REQUEST_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REF_REQUEST_GET
Visual Basic
Public Shared ReadOnly UPS_REF_REQUEST_GET As String
Visual C++
public:
static initonly String^ UPS_REF_REQUEST_GET

See Also

MCitems Structure
MCitems Members


UPS_REF_SOP_ACCESS_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REF_SOP_ACCESS_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REF_SOP_ACCESS_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REF_SOP_ACCESS_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_REF_SOP_ACCESS_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_REF_SOP_ACCESS_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_REF_SOP_ACCESS_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REF_SOP_ACCESS_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REF_SOP_ACCESS_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REF_SOP_ACCESS_GET
Visual Basic
Public Shared ReadOnly UPS_REF_SOP_ACCESS_GET As String
Visual C++
public:
static initonly String^ UPS_REF_SOP_ACCESS_GET

See Also

MCitems Structure
MCitems Members


UPS_REFERENCED_SOP_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_REFERENCED_SOP_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_REFERENCED_SOP_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_REFERENCED_SOP_GET
Visual Basic
Public Shared ReadOnly UPS_REFERENCED_SOP_GET As String
Visual C++
public:
static initonly String^ UPS_REFERENCED_SOP_GET

See Also

MCitems Structure
MCitems Members


UPS_SCHED_HUMAN_PERF_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_SCHED_HUMAN_PERF_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_SCHED_HUMAN_PERF_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_SCHED_HUMAN_PERF_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_SCHED_HUMAN_PERF_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_SCHED_HUMAN_PERF_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_SCHED_HUMAN_PERF_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_SCHED_HUMAN_PERF_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_SCHED_HUMAN_PERF_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_SCHED_HUMAN_PERF_GET
Visual Basic
Public Shared ReadOnly UPS_SCHED_HUMAN_PERF_GET As String
Visual C++
public:
static initonly String^ UPS_SCHED_HUMAN_PERF_GET

See Also

MCitems Structure
MCitems Members


UPS_SOP_INSTANCE_REF_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_SOP_INSTANCE_REF_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_SOP_INSTANCE_REF_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_SOP_INSTANCE_REF_GET
Visual Basic
Public Shared ReadOnly UPS_SOP_INSTANCE_REF_GET As String
Visual C++
public:
static initonly String^ UPS_SOP_INSTANCE_REF_GET

See Also

MCitems Structure
MCitems Members


UPS_WADO_RETRIEVAL_CREATE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_WADO_RETRIEVAL_CREATE_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_WADO_RETRIEVAL_CREATE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_WADO_RETRIEVAL_CREATE_SET
Visual Basic
Public Shared ReadOnly UPS_WADO_RETRIEVAL_CREATE_SET As String
Visual C++
public:
static initonly String^ UPS_WADO_RETRIEVAL_CREATE_SET

See Also

MCitems Structure
MCitems Members


UPS_WADO_RETRIEVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_WADO_RETRIEVAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_WADO_RETRIEVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_WADO_RETRIEVAL_GET
Visual Basic
Public Shared ReadOnly UPS_WADO_RETRIEVAL_GET As String
Visual C++
public:
static initonly String^ UPS_WADO_RETRIEVAL_GET

See Also

MCitems Structure
MCitems Members


UPS_WADO_RS_RETRIEVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_WADO_RS_RETRIEVAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_WADO_RS_RETRIEVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_WADO_RS_RETRIEVAL_GET
Visual Basic
Public Shared ReadOnly UPS_WADO_RS_RETRIEVAL_GET As String
Visual C++
public:
static initonly String^ UPS_WADO_RS_RETRIEVAL_GET

See Also

MCitems Structure
MCitems Members


UPS_XDS_RETRIEVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UPS_XDS_RETRIEVAL_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UPS_XDS_RETRIEVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_XDS_RETRIEVAL_GET
Visual Basic
Public Shared ReadOnly UPS_XDS_RETRIEVAL_GET As String
Visual C++
public:
static initonly String^ UPS_XDS_RETRIEVAL_GET

See Also

MCitems Structure
MCitems Members


US_IMAGE_DESCRIPTION_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..US_IMAGE_DESCRIPTION_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.US_IMAGE_DESCRIPTION_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string US_IMAGE_DESCRIPTION_SQ
Visual Basic
Public Shared ReadOnly US_IMAGE_DESCRIPTION_SQ As String
Visual C++
public:
static initonly String^ US_IMAGE_DESCRIPTION_SQ

See Also

MCitems Structure
MCitems Members


USED_FIDUCIALS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..USED_FIDUCIALS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.USED_FIDUCIALS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string USED_FIDUCIALS
Visual Basic
Public Shared ReadOnly USED_FIDUCIALS As String
Visual C++
public:
static initonly String^ USED_FIDUCIALS

See Also

MCitems Structure
MCitems Members


USED_RT_STRUCTURE_SET_ROI Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..USED_RT_STRUCTURE_SET_ROI Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.USED_RT_STRUCTURE_SET_ROI"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string USED_RT_STRUCTURE_SET_ROI
Visual Basic
Public Shared ReadOnly USED_RT_STRUCTURE_SET_ROI As String
Visual C++
public:
static initonly String^ USED_RT_STRUCTURE_SET_ROI

See Also

MCitems Structure
MCitems Members


USED_SEGMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..USED_SEGMENTS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.USED_SEGMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string USED_SEGMENTS
Visual Basic
Public Shared ReadOnly USED_SEGMENTS As String
Visual C++
public:
static initonly String^ USED_SEGMENTS

See Also

MCitems Structure
MCitems Members


UV_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..UV_MAPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.UV_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UV_MAPPING
Visual Basic
Public Shared ReadOnly UV_MAPPING As String
Visual C++
public:
static initonly String^ UV_MAPPING

See Also

MCitems Structure
MCitems Members


VARIABLE_MODALITY_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VARIABLE_MODALITY_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VARIABLE_MODALITY_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VARIABLE_MODALITY_LUT
Visual Basic
Public Shared ReadOnly VARIABLE_MODALITY_LUT As String
Visual C++
public:
static initonly String^ VARIABLE_MODALITY_LUT

See Also

MCitems Structure
MCitems Members


VECTORS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VECTORS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VECTORS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VECTORS_MACRO
Visual Basic
Public Shared ReadOnly VECTORS_MACRO As String
Visual C++
public:
static initonly String^ VECTORS_MACRO

See Also

MCitems Structure
MCitems Members


VELOCITY_ENCODING_ACQUISITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VELOCITY_ENCODING_ACQUISITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VELOCITY_ENCODING_ACQUISITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VELOCITY_ENCODING_ACQUISITION
Visual Basic
Public Shared ReadOnly VELOCITY_ENCODING_ACQUISITION As String
Visual C++
public:
static initonly String^ VELOCITY_ENCODING_ACQUISITION

See Also

MCitems Structure
MCitems Members


VERIFYING_OBSERVER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VERIFYING_OBSERVER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VERIFYING_OBSERVER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VERIFYING_OBSERVER
Visual Basic
Public Shared ReadOnly VERIFYING_OBSERVER As String
Visual C++
public:
static initonly String^ VERIFYING_OBSERVER

See Also

MCitems Structure
MCitems Members


VIEW_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VIEW_CODE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VIEW_CODE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIEW_CODE
Visual Basic
Public Shared ReadOnly VIEW_CODE As String
Visual C++
public:
static initonly String^ VIEW_CODE

See Also

MCitems Structure
MCitems Members


VIEW_CODE_BREAST Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VIEW_CODE_BREAST Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VIEW_CODE_BREAST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIEW_CODE_BREAST
Visual Basic
Public Shared ReadOnly VIEW_CODE_BREAST As String
Visual C++
public:
static initonly String^ VIEW_CODE_BREAST

See Also

MCitems Structure
MCitems Members


VIEW_CODE_OPT_VIEW_SL_PROG_DIR Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VIEW_CODE_OPT_VIEW_SL_PROG_DIR Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VIEW_CODE_OPT_VIEW_SL_PROG_DIR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIEW_CODE_OPT_VIEW_SL_PROG_DIR
Visual Basic
Public Shared ReadOnly VIEW_CODE_OPT_VIEW_SL_PROG_DIR As String
Visual C++
public:
static initonly String^ VIEW_CODE_OPT_VIEW_SL_PROG_DIR

See Also

MCitems Structure
MCitems Members


VIS_FIELD_GLOBAL_RESULTS_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VIS_FIELD_GLOBAL_RESULTS_INDEX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VIS_FIELD_GLOBAL_RESULTS_INDEX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIS_FIELD_GLOBAL_RESULTS_INDEX
Visual Basic
Public Shared ReadOnly VIS_FIELD_GLOBAL_RESULTS_INDEX As String
Visual C++
public:
static initonly String^ VIS_FIELD_GLOBAL_RESULTS_INDEX

See Also

MCitems Structure
MCitems Members


VIS_FIELD_TEST_RELI_GLOBAL_INDEX Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VIS_FIELD_TEST_RELI_GLOBAL_INDEX Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VIS_FIELD_TEST_RELI_GLOBAL_INDEX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIS_FIELD_TEST_RELI_GLOBAL_INDEX
Visual Basic
Public Shared ReadOnly VIS_FIELD_TEST_RELI_GLOBAL_INDEX As String
Visual C++
public:
static initonly String^ VIS_FIELD_TEST_RELI_GLOBAL_INDEX

See Also

MCitems Structure
MCitems Members


VISUAL_ACUITY_EYE_SQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_ACUITY_EYE_SQ Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_ACUITY_EYE_SQ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_ACUITY_EYE_SQ
Visual Basic
Public Shared ReadOnly VISUAL_ACUITY_EYE_SQ As String
Visual C++
public:
static initonly String^ VISUAL_ACUITY_EYE_SQ

See Also

MCitems Structure
MCitems Members


VISUAL_ACUITY_MEASUREMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_ACUITY_MEASUREMENT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_ACUITY_MEASUREMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_ACUITY_MEASUREMENT
Visual Basic
Public Shared ReadOnly VISUAL_ACUITY_MEASUREMENT As String
Visual C++
public:
static initonly String^ VISUAL_ACUITY_MEASUREMENT

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_RESULT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_RESULT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_RESULT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_RESULT
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_RESULT As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_RESULT

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_RESULT_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_RESULT_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_RESULT_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_RESULT_SCP
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_RESULT_SCP As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_RESULT_SCP

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_RESULT_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_RESULT_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_RESULT_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_RESULT_SCU
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_RESULT_SCU As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_RESULT_SCU

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_TEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_TEST Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_TEST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_TEST
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_TEST As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_TEST

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_TEST_SCP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_TEST_SCP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_TEST_SCP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_TEST_SCP
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_TEST_SCP As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_TEST_SCP

See Also

MCitems Structure
MCitems Members


VISUAL_EVALUATION_TEST_SCU Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_EVALUATION_TEST_SCU Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_EVALUATION_TEST_SCU"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_EVALUATION_TEST_SCU
Visual Basic
Public Shared ReadOnly VISUAL_EVALUATION_TEST_SCU As String
Visual C++
public:
static initonly String^ VISUAL_EVALUATION_TEST_SCU

See Also

MCitems Structure
MCitems Members


VISUAL_FIELD_CATCH_TRIAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_FIELD_CATCH_TRIAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_FIELD_CATCH_TRIAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_FIELD_CATCH_TRIAL
Visual Basic
Public Shared ReadOnly VISUAL_FIELD_CATCH_TRIAL As String
Visual C++
public:
static initonly String^ VISUAL_FIELD_CATCH_TRIAL

See Also

MCitems Structure
MCitems Members


VISUAL_FIELD_TEST_POINT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_FIELD_TEST_POINT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_FIELD_TEST_POINT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_FIELD_TEST_POINT
Visual Basic
Public Shared ReadOnly VISUAL_FIELD_TEST_POINT As String
Visual C++
public:
static initonly String^ VISUAL_FIELD_TEST_POINT

See Also

MCitems Structure
MCitems Members


VISUAL_FIELD_TEST_POINT_NORMALS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VISUAL_FIELD_TEST_POINT_NORMALS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VISUAL_FIELD_TEST_POINT_NORMALS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_FIELD_TEST_POINT_NORMALS
Visual Basic
Public Shared ReadOnly VISUAL_FIELD_TEST_POINT_NORMALS As String
Visual C++
public:
static initonly String^ VISUAL_FIELD_TEST_POINT_NORMALS

See Also

MCitems Structure
MCitems Members


VOI_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOI_LUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOI_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOI_LUT
Visual Basic
Public Shared ReadOnly VOI_LUT As String
Visual C++
public:
static initonly String^ VOI_LUT

See Also

MCitems Structure
MCitems Members


VOLUME_CROPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUME_CROPPING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUME_CROPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUME_CROPPING
Visual Basic
Public Shared ReadOnly VOLUME_CROPPING As String
Visual C++
public:
static initonly String^ VOLUME_CROPPING

See Also

MCitems Structure
MCitems Members


VOLUME_LOCALIZATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUME_LOCALIZATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUME_LOCALIZATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUME_LOCALIZATION
Visual Basic
Public Shared ReadOnly VOLUME_LOCALIZATION As String
Visual C++
public:
static initonly String^ VOLUME_LOCALIZATION

See Also

MCitems Structure
MCitems Members


VOLUME_STREAM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUME_STREAM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUME_STREAM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUME_STREAM
Visual Basic
Public Shared ReadOnly VOLUME_STREAM As String
Visual C++
public:
static initonly String^ VOLUME_STREAM

See Also

MCitems Structure
MCitems Members


VOLUMETRIC_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUMETRIC_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUMETRIC_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUMETRIC_ANNOTATION
Visual Basic
Public Shared ReadOnly VOLUMETRIC_ANNOTATION As String
Visual C++
public:
static initonly String^ VOLUMETRIC_ANNOTATION

See Also

MCitems Structure
MCitems Members


VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION
Visual Basic
Public Shared ReadOnly VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION As String
Visual C++
public:
static initonly String^ VOLUMETRIC_PRESENTATION_INPUT_ANNOTATION

See Also

MCitems Structure
MCitems Members


VOLUMETRIC_PRESENTATION_INPUT_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUMETRIC_PRESENTATION_INPUT_SET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUMETRIC_PRESENTATION_INPUT_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUMETRIC_PRESENTATION_INPUT_SET
Visual Basic
Public Shared ReadOnly VOLUMETRIC_PRESENTATION_INPUT_SET As String
Visual C++
public:
static initonly String^ VOLUMETRIC_PRESENTATION_INPUT_SET

See Also

MCitems Structure
MCitems Members


VOLUMETRIC_PRESENTATION_STATE_INPUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..VOLUMETRIC_PRESENTATION_STATE_INPUT Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.VOLUMETRIC_PRESENTATION_STATE_INPUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUMETRIC_PRESENTATION_STATE_INPUT
Visual Basic
Public Shared ReadOnly VOLUMETRIC_PRESENTATION_STATE_INPUT As String
Visual C++
public:
static initonly String^ VOLUMETRIC_PRESENTATION_STATE_INPUT

See Also

MCitems Structure
MCitems Members


WADO_RETRIEVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WADO_RETRIEVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WADO_RETRIEVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WADO_RETRIEVAL
Visual Basic
Public Shared ReadOnly WADO_RETRIEVAL As String
Visual C++
public:
static initonly String^ WADO_RETRIEVAL

See Also

MCitems Structure
MCitems Members


WADO_RS_RETRIEVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WADO_RS_RETRIEVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WADO_RS_RETRIEVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WADO_RS_RETRIEVAL
Visual Basic
Public Shared ReadOnly WADO_RS_RETRIEVAL As String
Visual C++
public:
static initonly String^ WADO_RS_RETRIEVAL

See Also

MCitems Structure
MCitems Members


WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WAVEFORM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WAVEFORM
Visual Basic
Public Shared ReadOnly WAVEFORM As String
Visual C++
public:
static initonly String^ WAVEFORM

See Also

MCitems Structure
MCitems Members


WAVEFORM_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WAVEFORM_ANNOTATION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WAVEFORM_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WAVEFORM_ANNOTATION
Visual Basic
Public Shared ReadOnly WAVEFORM_ANNOTATION As String
Visual C++
public:
static initonly String^ WAVEFORM_ANNOTATION

See Also

MCitems Structure
MCitems Members


WAVEFORM_FILTER_CHARACTERISTICS_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WAVEFORM_FILTER_CHARACTERISTICS_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WAVEFORM_FILTER_CHARACTERISTICS_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WAVEFORM_FILTER_CHARACTERISTICS_MACRO
Visual Basic
Public Shared ReadOnly WAVEFORM_FILTER_CHARACTERISTICS_MACRO As String
Visual C++
public:
static initonly String^ WAVEFORM_FILTER_CHARACTERISTICS_MACRO

See Also

MCitems Structure
MCitems Members


WAVEFORM_FILTER_LOOKUP_TABLE_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WAVEFORM_FILTER_LOOKUP_TABLE_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WAVEFORM_FILTER_LOOKUP_TABLE_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WAVEFORM_FILTER_LOOKUP_TABLE_MACRO
Visual Basic
Public Shared ReadOnly WAVEFORM_FILTER_LOOKUP_TABLE_MACRO As String
Visual C++
public:
static initonly String^ WAVEFORM_FILTER_LOOKUP_TABLE_MACRO

See Also

MCitems Structure
MCitems Members


WAVEFORM_PRESENTATION_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WAVEFORM_PRESENTATION_GROUP Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WAVEFORM_PRESENTATION_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WAVEFORM_PRESENTATION_GROUP
Visual Basic
Public Shared ReadOnly WAVEFORM_PRESENTATION_GROUP As String
Visual C++
public:
static initonly String^ WAVEFORM_PRESENTATION_GROUP

See Also

MCitems Structure
MCitems Members


WEDGE_DEFINITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEDGE_DEFINITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEDGE_DEFINITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEDGE_DEFINITION
Visual Basic
Public Shared ReadOnly WEDGE_DEFINITION As String
Visual C++
public:
static initonly String^ WEDGE_DEFINITION

See Also

MCitems Structure
MCitems Members


WEDGE_ITEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEDGE_ITEM Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEDGE_ITEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEDGE_ITEM
Visual Basic
Public Shared ReadOnly WEDGE_ITEM As String
Visual C++
public:
static initonly String^ WEDGE_ITEM

See Also

MCitems Structure
MCitems Members


WEDGE_POSITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEDGE_POSITION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEDGE_POSITION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEDGE_POSITION
Visual Basic
Public Shared ReadOnly WEDGE_POSITION As String
Visual C++
public:
static initonly String^ WEDGE_POSITION

See Also

MCitems Structure
MCitems Members


WEDGE_POSITION_IN_WP_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEDGE_POSITION_IN_WP_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEDGE_POSITION_IN_WP_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEDGE_POSITION_IN_WP_MACRO
Visual Basic
Public Shared ReadOnly WEDGE_POSITION_IN_WP_MACRO As String
Visual C++
public:
static initonly String^ WEDGE_POSITION_IN_WP_MACRO

See Also

MCitems Structure
MCitems Members


WEEKDAY_FRACTION_PATTERN Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEEKDAY_FRACTION_PATTERN Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEEKDAY_FRACTION_PATTERN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEEKDAY_FRACTION_PATTERN
Visual Basic
Public Shared ReadOnly WEEKDAY_FRACTION_PATTERN As String
Visual C++
public:
static initonly String^ WEEKDAY_FRACTION_PATTERN

See Also

MCitems Structure
MCitems Members


WEIGHTING_TRANSFER_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WEIGHTING_TRANSFER_FUNCTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WEIGHTING_TRANSFER_FUNCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WEIGHTING_TRANSFER_FUNCTION
Visual Basic
Public Shared ReadOnly WEIGHTING_TRANSFER_FUNCTION As String
Visual C++
public:
static initonly String^ WEIGHTING_TRANSFER_FUNCTION

See Also

MCitems Structure
MCitems Members


WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE
Visual Basic
Public Shared ReadOnly WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE As String
Visual C++
public:
static initonly String^ WHOLE_SLIDE_MICROSCOPY_IMAGE_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING
Visual Basic
Public Shared ReadOnly WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING As String
Visual C++
public:
static initonly String^ WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_RATING

See Also

MCitems Structure
MCitems Members


WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD
Visual Basic
Public Shared ReadOnly WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD As String
Visual C++
public:
static initonly String^ WIDE_FIELD_OPHTHALMIC_PHOTO_QUALITY_THRESHOLD

See Also

MCitems Structure
MCitems Members


X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO
Visual Basic
Public Shared ReadOnly X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO As String
Visual C++
public:
static initonly String^ X_RAY_3D_GEN_ACQ_PER_PROJ_MACRO

See Also

MCitems Structure
MCitems Members


XA_ACQUISITION_PHASE_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XA_ACQUISITION_PHASE_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XA_ACQUISITION_PHASE_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_ACQUISITION_PHASE_DETAILS
Visual Basic
Public Shared ReadOnly XA_ACQUISITION_PHASE_DETAILS As String
Visual C++
public:
static initonly String^ XA_ACQUISITION_PHASE_DETAILS

See Also

MCitems Structure
MCitems Members


XA_PLANE_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XA_PLANE_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XA_PLANE_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_PLANE_DETAILS
Visual Basic
Public Shared ReadOnly XA_PLANE_DETAILS As String
Visual C++
public:
static initonly String^ XA_PLANE_DETAILS

See Also

MCitems Structure
MCitems Members


XA_XRF_FRAME_CHARACTERISTICS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XA_XRF_FRAME_CHARACTERISTICS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XA_XRF_FRAME_CHARACTERISTICS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_XRF_FRAME_CHARACTERISTICS
Visual Basic
Public Shared ReadOnly XA_XRF_FRAME_CHARACTERISTICS As String
Visual C++
public:
static initonly String^ XA_XRF_FRAME_CHARACTERISTICS

See Also

MCitems Structure
MCitems Members


XA_XRF_FRAME_DISPLAY_SHUTTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XA_XRF_FRAME_DISPLAY_SHUTTER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XA_XRF_FRAME_DISPLAY_SHUTTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_XRF_FRAME_DISPLAY_SHUTTER
Visual Basic
Public Shared ReadOnly XA_XRF_FRAME_DISPLAY_SHUTTER As String
Visual C++
public:
static initonly String^ XA_XRF_FRAME_DISPLAY_SHUTTER

See Also

MCitems Structure
MCitems Members


XA_XRF_MASK_SUBTRACTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XA_XRF_MASK_SUBTRACTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XA_XRF_MASK_SUBTRACTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_XRF_MASK_SUBTRACTION
Visual Basic
Public Shared ReadOnly XA_XRF_MASK_SUBTRACTION As String
Visual C++
public:
static initonly String^ XA_XRF_MASK_SUBTRACTION

See Also

MCitems Structure
MCitems Members


XDS_RETRIEVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XDS_RETRIEVAL Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XDS_RETRIEVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XDS_RETRIEVAL
Visual Basic
Public Shared ReadOnly XDS_RETRIEVAL As String
Visual C++
public:
static initonly String^ XDS_RETRIEVAL

See Also

MCitems Structure
MCitems Members


XDS_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XDS_STORAGE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XDS_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XDS_STORAGE
Visual Basic
Public Shared ReadOnly XDS_STORAGE As String
Visual C++
public:
static initonly String^ XDS_STORAGE

See Also

MCitems Structure
MCitems Members


XDS_STORAGE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XDS_STORAGE_GET Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XDS_STORAGE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XDS_STORAGE_GET
Visual Basic
Public Shared ReadOnly XDS_STORAGE_GET As String
Visual C++
public:
static initonly String^ XDS_STORAGE_GET

See Also

MCitems Structure
MCitems Members


XRAY_3D_ACQUISITION_ANGIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_3D_ACQUISITION_ANGIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_3D_ACQUISITION_ANGIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_ACQUISITION_ANGIO
Visual Basic
Public Shared ReadOnly XRAY_3D_ACQUISITION_ANGIO As String
Visual C++
public:
static initonly String^ XRAY_3D_ACQUISITION_ANGIO

See Also

MCitems Structure
MCitems Members


XRAY_3D_ACQUISITION_CRANIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_3D_ACQUISITION_CRANIO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_3D_ACQUISITION_CRANIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_ACQUISITION_CRANIO
Visual Basic
Public Shared ReadOnly XRAY_3D_ACQUISITION_CRANIO As String
Visual C++
public:
static initonly String^ XRAY_3D_ACQUISITION_CRANIO

See Also

MCitems Structure
MCitems Members


XRAY_3D_ACQUISITION_TOMO Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_3D_ACQUISITION_TOMO Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_3D_ACQUISITION_TOMO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_ACQUISITION_TOMO
Visual Basic
Public Shared ReadOnly XRAY_3D_ACQUISITION_TOMO As String
Visual C++
public:
static initonly String^ XRAY_3D_ACQUISITION_TOMO

See Also

MCitems Structure
MCitems Members


XRAY_3D_FRAME_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_3D_FRAME_TYPE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_3D_FRAME_TYPE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_FRAME_TYPE
Visual Basic
Public Shared ReadOnly XRAY_3D_FRAME_TYPE As String
Visual C++
public:
static initonly String^ XRAY_3D_FRAME_TYPE

See Also

MCitems Structure
MCitems Members


XRAY_3D_RECONSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_3D_RECONSTRUCTION Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_3D_RECONSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_RECONSTRUCTION
Visual Basic
Public Shared ReadOnly XRAY_3D_RECONSTRUCTION As String
Visual C++
public:
static initonly String^ XRAY_3D_RECONSTRUCTION

See Also

MCitems Structure
MCitems Members


XRAY_ACQUISITION_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_ACQUISITION_DOSE Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_ACQUISITION_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_ACQUISITION_DOSE
Visual Basic
Public Shared ReadOnly XRAY_ACQUISITION_DOSE As String
Visual C++
public:
static initonly String^ XRAY_ACQUISITION_DOSE

See Also

MCitems Structure
MCitems Members


XRAY_FILTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_FILTER Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_FILTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_FILTER
Visual Basic
Public Shared ReadOnly XRAY_FILTER As String
Visual C++
public:
static initonly String^ XRAY_FILTER

See Also

MCitems Structure
MCitems Members


XRAY_FILTER_DETAILS Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_FILTER_DETAILS Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_FILTER_DETAILS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_FILTER_DETAILS
Visual Basic
Public Shared ReadOnly XRAY_FILTER_DETAILS As String
Visual C++
public:
static initonly String^ XRAY_FILTER_DETAILS

See Also

MCitems Structure
MCitems Members


XRAY_GEOMETRY Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_GEOMETRY Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_GEOMETRY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_GEOMETRY
Visual Basic
Public Shared ReadOnly XRAY_GEOMETRY As String
Visual C++
public:
static initonly String^ XRAY_GEOMETRY

See Also

MCitems Structure
MCitems Members


XRAY_GRID Field

[image]

Merge DICOM .NET/C# Toolkit
MCitems..::..XRAY_GRID Field
MCitems Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCitems.XRAY_GRID"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_GRID
Visual Basic
Public Shared ReadOnly XRAY_GRID As String
Visual C++
public:
static initonly String^ XRAY_GRID

See Also

MCitems Structure
MCitems Members


MCitems Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitems Methods
MCitems Structure See Also Send Feedback

The MCitems type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

MCitems Structure


MCmediaStorageService Class

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService Class
Members See Also Send Feedback
Represents a DICOM Media Storage Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCmediaStorageService
Visual Basic
Public Class MCmediaStorageService
Visual C++
public ref class MCmediaStorageService

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCmediaStorageService

See Also

MCmediaStorageService Members


MCmediaStorageService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService Members
MCmediaStorageService Class Constructors Methods See Also Send Feedback

The MCmediaStorageService type exposes the following members.

Constructors

 | Name | Description
Public method | MCmediaStorageService | Initializes a new instance of this class associated with a specified DICOM application.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFile | Requests that the contents of a DICOM Part 10 file be converted and placed into the provided MCfile.
Public method | readFileBypassLargeData | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeFile | Writes the contents of an MCfile into a DICOM Part 10 standard file format. The file is passed in blocks to destination.

See Also

MCmediaStorageService Class


MCmediaStorageService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService Constructor
MCmediaStorageService Class See Also Send Feedback
Initializes a new instance of this class associated with a specified DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmediaStorageService(
    MCapplication application
)
Visual Basic
Public Sub New ( _
    application As MCapplication _
)
Visual C++
public:
MCmediaStorageService(
    MCapplication^ application
)

Parameters

application
Type: Mergecom..::..MCapplication
Identifies the DICOM application for this service.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The application was null.

See Also

MCmediaStorageService Class
MCmediaStorageService Members


MCmediaStorageService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService Methods
MCmediaStorageService Class See Also Send Feedback

The MCmediaStorageService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFile | Requests that the contents of a DICOM Part 10 file be converted and placed into the provided MCfile.
Public method | readFileBypassLargeData | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | writeFile | Writes the contents of an MCfile into a DICOM Part 10 standard file format. The file is passed in blocks to destination.

See Also

MCmediaStorageService Class


readFile Method

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFile Method
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM Part 10 file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFile(
    MCfile file,
    MCdataSource source
)
Visual Basic
Public Overridable Sub readFile ( _
    file As MCfile, _
    source As MCdataSource _
)
Visual C++
public:
virtual void readFile(
    MCfile^ file,
    MCdataSource^ source
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.

Remarks

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • callback stopped without passing the entire value for an attribute.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members


readFileBypassLargeData Method

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileBypassLargeData Method
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void readFileBypassLargeData(
    MCfile file,
    MCdataSource source
)
Visual Basic
Public Overridable Sub readFileBypassLargeData ( _
    file As MCfile, _
    source As MCdataSource _
)
Visual C++
public:
virtual void readFileBypassLargeData(
    MCfile^ file,
    MCdataSource^ source
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.

Remarks

This method does not pass OB/OW/OL/OD/OF attributes to any MCattributeContainer registered with the associated application.

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • callback stopped without passing the entire value for an attribute.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members


readFileUpToTag Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileUpToTag Method
MCmediaStorageService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.
Public method | readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource, UInt32%) | Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

See Also

MCmediaStorageService Class
MCmediaStorageService Members


readFileUpToTag Method (MCfile, UInt32, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileUpToTag Method (MCfile, UInt32, MCdataSource)
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long readFileUpToTag(
    MCfile file,
    uint lastTag,
    MCdataSource source
)
Visual Basic
Public Overridable Function readFileUpToTag ( _
    file As MCfile, _
    lastTag As UInteger, _
    source As MCdataSource _
) As Long
Visual C++
public:
virtual long long readFileUpToTag(
    MCfile^ file,
    unsigned int lastTag,
    MCdataSource^ source
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
lastTag
Type: System..::..UInt32
The tag identifying the last attribute to process.
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.

Return Value

The number of source bytes processed, i.e. the file offset to the attribute immediately following lastTag.

If lastTag is zero, then the entire file is read and the return value is also zero.

Remarks

This method processes attributes only up to the attribute specified by lastTag.

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • callback stopped without passing the entire value for an attribute.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members
readFileUpToTag Overload


readFileUpToTag Method (MCfile, UInt32, MCdataSource, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileUpToTag Method (MCfile, UInt32, MCdataSource, UInt32%)
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long readFileUpToTag(
    MCfile file,
    uint lastTag,
    MCdataSource source,
    ref uint virtualNextTag
)
Visual Basic
Public Overridable Function readFileUpToTag ( _
    file As MCfile, _
    lastTag As UInteger, _
    source As MCdataSource, _
    ByRef virtualNextTag As UInteger _
) As Long
Visual C++
public:
virtual long long readFileUpToTag(
    MCfile^ file,
    unsigned int lastTag,
    MCdataSource^ source,
    unsigned int% virtualNextTag
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
lastTag
Type: System..::..UInt32
The tag identifying the last attribute to process.
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.
virtualNextTag
Type: System..::..UInt32%
Return argument set to the value of the tag after the last one that was parsed when reading the message. If the message has been parsed in its entirety, then the tag returned will be the 'virtual next', i.e. the last tag parsed plus 1. If the MCdataSource callback stopped without parsing the entire value for an attribute, the value returned will be zero. Which also means with certainty that the target tag is not present in the parsed data.

Return Value

The number of source bytes processed, i.e. the file offset to the attribute immediately following lastTag.

If lastTag is zero, then the entire file is read and the return value is also zero.

Remarks

This method processes attributes only up to the attribute specified by lastTag.

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

The overloaded method readFileUpToTag(MCfile, UInt32, MCdataSource) returns an MCinvalidEncodingException when the MCdataSource callback has stopped without returning the entire value for an attribute. In certain (repetitive) scenarios the raising and handling of the exception is costly. This method forgoes raising the exception in favour of returning zero in the virtualNextTag argument.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members
readFileUpToTag Overload


readFileUpToTag Method (MCfile, UInt32, Boolean, MCdataSource)

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileUpToTag Method (MCfile, UInt32, Boolean, MCdataSource)
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long readFileUpToTag(
    MCfile file,
    uint lastTag,
    bool bypassOBOW,
    MCdataSource source
)
Visual Basic
Public Overridable Function readFileUpToTag ( _
    file As MCfile, _
    lastTag As UInteger, _
    bypassOBOW As Boolean, _
    source As MCdataSource _
) As Long
Visual C++
public:
virtual long long readFileUpToTag(
    MCfile^ file,
    unsigned int lastTag,
    bool bypassOBOW,
    MCdataSource^ source
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
lastTag
Type: System..::..UInt32
The tag identifying the last attribute to process.
bypassOBOW
Type: System..::..Boolean
Bypass the tag value if true
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.

Return Value

If lastTag is zero, then the entire file is read and the return value is also zero.

If lastTag is not zero, the return value depends on the value of bypassOBOW:

  • If bypassOBOW is false, the return value is the offset in bytes from the beginning of the file of the first attribute greater than lastTag.
  • If bypassOBOW is true, the return value is the offset in bytes from the beginning of the file of the data of the attribute at lastTag.

Remarks

This method processes attributes only up to the attribute specified by lastTag, but does not pass tag's OB/OW/OL/OD/OF value to any MCattributeContainer registered with the associated application.

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • callback stopped without passing the entire value for an attribute.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members
readFileUpToTag Overload


readFileUpToTag Method (MCfile, UInt32, Boolean, MCdataSource, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..readFileUpToTag Method (MCfile, UInt32, Boolean, MCdataSource, UInt32%)
MCmediaStorageService Class See Also Send Feedback
Requests that the contents of a DICOM file be converted and placed into the provided MCfile.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual long readFileUpToTag(
    MCfile file,
    uint lastTag,
    bool bypassOBOW,
    MCdataSource source,
    ref uint virtualNextTag
)
Visual Basic
Public Overridable Function readFileUpToTag ( _
    file As MCfile, _
    lastTag As UInteger, _
    bypassOBOW As Boolean, _
    source As MCdataSource, _
    ByRef virtualNextTag As UInteger _
) As Long
Visual C++
public:
virtual long long readFileUpToTag(
    MCfile^ file,
    unsigned int lastTag,
    bool bypassOBOW,
    MCdataSource^ source,
    unsigned int% virtualNextTag
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile reference.
lastTag
Type: System..::..UInt32
The tag identifying the last attribute to process.
bypassOBOW
Type: System..::..Boolean
Bypass the tag value if true
source
Type: Mergecom..::..MCdataSource
A not null MCdataSource reference.
virtualNextTag
Type: System..::..UInt32%
Return argument set to the value of the tag after the last one that was parsed when reading the message. If the message has been parsed in its entirety, then the tag returned will be the 'virtual next', i.e. the last tag parsed plus 1. If the MCdataSource callback stopped without parsing the entire value for an attribute, the value returned will be zero. Which also means with certainty that the target tag is not present in the parsed data.

Return Value

If lastTag is zero, then the entire file is read and the return value is also zero.

If lastTag is not zero, the return value depends on the value of bypassOBOW:

  • If bypassOBOW is false, the return value is the offset in bytes from the beginning of the file of the first attribute greater than lastTag.
  • If bypassOBOW is true, the return value is the offset in bytes from the beginning of the file of the data of the attribute at lastTag.

Remarks

This method processes attributes only up to the attribute specified by lastTag, but does not pass tag's OB/OW/OL/OD/OF value to any MCattributeContainer registered with the associated application.

If the file contains any attributes with a value representation of SQ (i.e. the file contains one or more sequence of items), an MCitem object is automatically opened for each item in the file. The MCitem object is used as the value for each item in the sequence attribute.

This method reads in the DICOM File Meta Information attributes in Explicit VR Little Endian transfer syntax. The remainder of the file is read in with the transfer syntax specified in the attribute (0002,0010).

The overloaded method readFileUpToTag(MCfile, UInt32, Boolean, MCdataSource) returns an MCinvalidEncodingException when the MCdataSource callback has stopped without returning the entire value for an attribute. In certain (repetitive) scenarios the raising and handling of the exception is costly. This method forgoes raising the exception in favour of returning zero in the virtualNextTag argument.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException May be caused by one of the following:
  • an invalid DICOM file prefix was found.
  • a tag was found in the stream that was not in ascending order.
  • an invalid DICOM tag was detected in the stream.
  • too many private blocks were encountered in the stream.
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while reading the source. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException | Uneven data size returned by the source.

See Also

MCmediaStorageService Class
MCmediaStorageService Members
readFileUpToTag Overload


writeFile Method

[image]

Merge DICOM .NET/C# Toolkit
MCmediaStorageService..::..writeFile Method
MCmediaStorageService Class See Also Send Feedback
Writes the contents of an MCfile into a DICOM Part 10 standard file format. The file is passed in blocks to destination.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void writeFile(
    MCfile file,
    int padBytes,
    MCdataSink destination
)
Visual Basic
Public Overridable Sub writeFile ( _
    file As MCfile, _
    padBytes As Integer, _
    destination As MCdataSink _
)
Visual C++
public:
virtual void writeFile(
    MCfile^ file,
    int padBytes,
    MCdataSink^ destination
)

Parameters

file
Type: Mergecom..::..MCfile
A not null MCfile object identifying the file to be streamed.
padBytes
Type: System..::..Int32
The file will be padded a multiple of this number of bytes.
destination
Type: Mergecom..::..MCdataSink
A not null MCdataSink object that will be used to store the stream data.

Remarks

This method will automatically fill in two group 2 attributes within the file meta information - if they are not set. This is the Implementation Class UID (0002,0012) and the Implementation Version Name (0002,0013). These values are set according to the configuration options for these values.

Note: If file is an MCdir instance a warning will be logged if the file's transfer syntax is not Explicit Little Endian according to the DICOM standard. If the file's transfer syntax is Deflated Little Endian or is encapsulated an MCinvalidTransferSyntaxException will be thrown.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An argument was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The file has been disposed.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | The transfer syntax is improperly specified or is not specified in the DICOM File Meta Information attributes.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | An exception occurred while writing data to the destination. Check the inner exception for details.
Mergecom.Exceptions..::..MCinvalidEncodingException | One of the attributes had an invalid value.

See Also

MCmediaStorageService Class
MCmediaStorageService Members


MCmemoryDataSink Class

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Class
Members See Also Send Feedback
A memory buffer that implements both MCdataSink and MCdataSource interfaces.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCmemoryDataSink : MCdataSource,
    MCdataSink, IDisposable
Visual Basic
Public Class MCmemoryDataSink _
    Implements MCdataSource, MCdataSink, IDisposable
Visual C++
public ref class MCmemoryDataSink : MCdataSource,
    MCdataSink, IDisposable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCmemoryDataSink

See Also

MCmemoryDataSink Members


MCmemoryDataSink Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Members
MCmemoryDataSink Class Constructors Methods Properties See Also Send Feedback

The MCmemoryDataSink type exposes the following members.

Constructors

 | Name | Description
Public method | MCmemoryDataSink()()()() | Initializes a new instance of MCmemoryDataSink for updating.
Public method | MCmemoryDataSink(UInt32) | Initializes a new instance of MCmemoryDataSink based on an unmanaged memory buffer.
Public method | MCmemoryDataSink(MCdata) | Initializes a new instance of MCmemoryDataSink using an existing MCdata instance as buffer.

Methods

 | Name | Description
Public method | close | Disposes the data in this instance. This method is the same with Dispose().
Public method | Dispose | Implements IDisposable. Disposes the data in this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getData | Gets the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData | Implementation of provideData method of MCdataSource interface.
Public method | receiveData | Implementation of the receiveData method as defined by MCdataSink.
Public method | replaceData | When working with a non-contiguous data sink, replaces one of the specific values received with a new value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Length | The length of the current data.

See Also

MCmemoryDataSink Class


MCmemoryDataSink Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Constructor
MCmemoryDataSink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCmemoryDataSink()()()() | Initializes a new instance of MCmemoryDataSink for updating.
Public method | MCmemoryDataSink(UInt32) | Initializes a new instance of MCmemoryDataSink based on an unmanaged memory buffer.
Public method | MCmemoryDataSink(MCdata) | Initializes a new instance of MCmemoryDataSink using an existing MCdata instance as buffer.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


MCmemoryDataSink Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Constructor
MCmemoryDataSink Class See Also Send Feedback
Initializes a new instance of MCmemoryDataSink for updating.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmemoryDataSink()
Visual Basic
Public Sub New
Visual C++
public:
MCmemoryDataSink()

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members
MCmemoryDataSink Overload


MCmemoryDataSink Constructor (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Constructor (UInt32)
MCmemoryDataSink Class See Also Send Feedback
Initializes a new instance of MCmemoryDataSink based on an unmanaged memory buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmemoryDataSink(
    uint size
)
Visual Basic
Public Sub New ( _
    size As UInteger _
)
Visual C++
public:
MCmemoryDataSink(
    unsigned int size
)

Parameters

size
Type: System..::..UInt32
The size of the buffer to allocate.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members
MCmemoryDataSink Overload


MCmemoryDataSink Constructor (MCdata)

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Constructor (MCdata)
MCmemoryDataSink Class See Also Send Feedback
Initializes a new instance of MCmemoryDataSink using an existing MCdata instance as buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmemoryDataSink(
    MCdata content
)
Visual Basic
Public Sub New ( _
    content As MCdata _
)
Visual C++
public:
MCmemoryDataSink(
    MCdata^ content
)

Parameters

content
Type: Mergecom..::..MCdata
An MCdata object containing the buffer to use for this instance.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members
MCmemoryDataSink Overload


MCmemoryDataSink Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Methods
MCmemoryDataSink Class See Also Send Feedback

The MCmemoryDataSink type exposes the following members.

Methods

 | Name | Description
Public method | close | Disposes the data in this instance. This method is the same with Dispose().
Public method | Dispose | Implements IDisposable. Disposes the data in this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getData | Gets the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData | Implementation of provideData method of MCdataSource interface.
Public method | receiveData | Implementation of the receiveData method as defined by MCdataSink.
Public method | replaceData | When working with a non-contiguous data sink, replaces one of the specific values received with a new value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCmemoryDataSink Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..close Method
MCmemoryDataSink Class See Also Send Feedback
Disposes the data in this instance. This method is the same with Dispose().

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


Dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..Dispose Method
MCmemoryDataSink Class See Also Send Feedback
Implements IDisposable. Disposes the data in this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


getData Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..getData Method
MCmemoryDataSink Class See Also Send Feedback
Gets the data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata getData()
Visual Basic
Public Function getData As MCdata
Visual C++
public:
MCdata^ getData()

Return Value

An MCdata instance containing the data.

Remarks

The returned data object is the data buffer owned by this instance, except if the data is non-contigous and contains more than one buffer, in which case the returned data is a newly created MCdata object containing data from all buffers concatenated.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


provideData Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..provideData Method
MCmemoryDataSink Class See Also Send Feedback
Implementation of provideData method of MCdataSource interface.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata provideData(
    bool first,
    Object origin
)
Visual Basic
Public Function provideData ( _
    first As Boolean, _
    origin As Object _
) As MCdata
Visual C++
public:
virtual MCdata^ provideData(
    bool first,
    Object^ origin
) sealed

Parameters

first
Type: System..::..Boolean
true when requesting the first chunk of data.
origin
Type: System..::..Object
The object that originated the call.

Return Value

An MCdata intance containing the requested data.

Implements

MCdataSource..::..provideData(Boolean, Object)

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


receiveData Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..receiveData Method
MCmemoryDataSink Class See Also Send Feedback
Implementation of the receiveData method as defined by MCdataSink.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void receiveData(
    MCdata bulk,
    Object origin
)
Visual Basic
Public Sub receiveData ( _
    bulk As MCdata, _
    origin As Object _
)
Visual C++
public:
virtual void receiveData(
    MCdata^ bulk,
    Object^ origin
) sealed

Parameters

bulk
Type: Mergecom..::..MCdata
The data to receive.
origin
Type: System..::..Object
The origin of this call.

Implements

MCdataSink..::..receiveData(MCdata, Object)

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


replaceData Method

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..replaceData Method
MCmemoryDataSink Class See Also Send Feedback
When working with a non-contiguous data sink, replaces one of the specific values received with a new value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void replaceData(
    int val,
    MCdata bulk,
    Object origin
)
Visual Basic
Public Sub replaceData ( _
    val As Integer, _
    bulk As MCdata, _
    origin As Object _
)
Visual C++
public:
void replaceData(
    int val,
    MCdata^ bulk,
    Object^ origin
)

Parameters

val
Type: System..::..Int32
A zero offset array location to replace with this data.
bulk
Type: Mergecom..::..MCdata
The data to replace.
origin
Type: System..::..Object
The origin of this call.

Remarks

This is a customization for dealing with the specific purpose of replacing the Basic Offset Table when MCmemoryDataSink is being used to manage bulk data.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Invalid operation when working with a contiguous data sink or the value to replace does not exist.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


MCmemoryDataSink Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink Properties
MCmemoryDataSink Class See Also Send Feedback

The MCmemoryDataSink type exposes the following members.

Properties

 | Name | Description
Public property | Length | The length of the current data.

See Also

MCmemoryDataSink Class


Length Property

[image]

Merge DICOM .NET/C# Toolkit
MCmemoryDataSink..::..Length Property
MCmemoryDataSink Class See Also Send Feedback
The length of the current data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public uint Length { get; }
Visual Basic
Public ReadOnly Property Length As UInteger
    Get
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

Field Value

The size of the data in bytes.

See Also

MCmemoryDataSink Class
MCmemoryDataSink Members


MCnegotiationInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo Class
Members See Also Send Feedback
Represents base methods for extended user information during association negotiation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCnegotiationInfo
Visual Basic
Public MustInherit Class MCnegotiationInfo
Visual C++
public ref class MCnegotiationInfo abstract

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCnegotiationInfo
Mergecom..::..MCqueryRetrieveNegotiation
Mergecom..::..MCstorageNegotiation

See Also

MCnegotiationInfo Members


MCnegotiationInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo Members
MCnegotiationInfo Class Constructors Methods See Also Send Feedback

The MCnegotiationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MCnegotiationInfo | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | decode | Examines a byte buffer and extracts specific negotiation information.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toByteArray | Converts extended user negotiation information into a byte buffer defined by the DICOM standard.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCnegotiationInfo Class


MCnegotiationInfo Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo Constructor
MCnegotiationInfo Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnegotiationInfo()
Visual Basic
Public Sub New
Visual C++
public:
MCnegotiationInfo()

See Also

MCnegotiationInfo Class
MCnegotiationInfo Members


MCnegotiationInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo Methods
MCnegotiationInfo Class See Also Send Feedback

The MCnegotiationInfo type exposes the following members.

Methods

 | Name | Description
Public method | decode | Examines a byte buffer and extracts specific negotiation information.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toByteArray | Converts extended user negotiation information into a byte buffer defined by the DICOM standard.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCnegotiationInfo Class


decode Method

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo..::..decode Method
MCnegotiationInfo Class See Also Send Feedback
Examines a byte buffer and extracts specific negotiation information.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract void decode(
    byte[] byteArray
)
Visual Basic
Public MustOverride Sub decode ( _
    byteArray As Byte() _
)
Visual C++
public:
virtual void decode(
    array<unsigned char>^ byteArray
) abstract

Parameters

byteArray
Type: array<System..::..Byte>[]()[][]
A buffer containing the extended negotiation information.

See Also

MCnegotiationInfo Class
MCnegotiationInfo Members


toByteArray Method

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationInfo..::..toByteArray Method
MCnegotiationInfo Class See Also Send Feedback
Converts extended user negotiation information into a byte buffer defined by the DICOM standard.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract byte[] toByteArray()
Visual Basic
Public MustOverride Function toByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ toByteArray() abstract

Return Value

A properly formatted buffer containing the negotiation information.

See Also

MCnegotiationInfo Class
MCnegotiationInfo Members


MCpatientManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Class
Members See Also Send Feedback
Represents a DICOM Patient Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpatientManagementService : MCdimseService
Visual Basic
Public Class MCpatientManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCpatientManagementService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:
  • Detached Patient Management Meta SOP Class
  • Detached Patient Management SOP Class
  • Detached Visit Management SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCpatientManagementService

See Also

MCpatientManagementService Members


MCpatientManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Members
MCpatientManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCpatientManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCpatientManagementService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCpatientManagementService Class


MCpatientManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Constructor
MCpatientManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpatientManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCpatientManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCpatientManagementService Class
MCpatientManagementService Members


MCpatientManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Fields
MCpatientManagementService Class See Also Send Feedback

The MCpatientManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCpatientManagementService Class


MCpatientManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Methods
MCpatientManagementService Class See Also Send Feedback

The MCpatientManagementService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCpatientManagementService Class


MCpatientManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientManagementService Properties
MCpatientManagementService Class See Also Send Feedback

The MCpatientManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCpatientManagementService Class


MCpersonName Class

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName Class
Members See Also Send Feedback
Represents a DICOM person name value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpersonName
Visual Basic
Public Class MCpersonName
Visual C++
public ref class MCpersonName

Remarks

For the purpose of writing names in ideographic characters and in phonetic characters, up to 3 groups of components may be used. The delimiter for component groups shall be the equals character "=".

The three component groups of components in their order of occurrence are: a single-byte character representation, an ideographic representation, and a phonetic representation. Any component group may be absent, including the first component group. In this case, the person name may start with one or more "=" delimiters. Delimiters are required for interior null component groups. Trailing null component groups and their delimiters may be omitted.

Each of the component groups may contain representations of the following name components:

  • family name complex
  • given name complex
  • middle name
  • name prefix
  • name suffix

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCpersonName

See Also

MCpersonName Members


MCpersonName Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonName Members
MCpersonName Class Constructors Methods Properties See Also Send Feedback

The MCpersonName type exposes the following members.

Constructors

 | Name | Description
Public method | MCpersonName(String) | Initializes a new instance of this class using the completely formatted DICOM name string provided.
Public method | MCpersonName(MCpnComponentGroup, MCpnComponentGroup, MCpnComponentGroup) | Initializes a new instance of this class based on the specified component groups.
Public method | MCpersonName(String, String, String, String, String) | Initializes a new instance of this class using values for the first and only component group (Character representation).

Methods

 | Name | Description
Public method | Equals | Determines whether this instance of MCpersonName and a specified object, have the same value. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a unicode string representing the DICOM encoded person name. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CharacterRepresentation | Gets the character representation of the person name as an MCpnComponentGroup object.
Public property | CharacterRepValue | Gets the character representation of the person name as a string.
Public property | IdeographicRepresentation | Gets the ideographic representation of the person name as an MCpnComponentGroup object.
Public property | IdeographicRepValue | Retrieves the ideographic representation of the person name as a string.
Public property | PhoneticRepresentation | Gets the phonetic representation of the person name as an MCpnComponentGroup object.
Public property | PhoneticRepValue | Gets the phonetic representation of the person name as a string.

See Also

MCpersonName Class


MCpersonName Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonName Constructor
MCpersonName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpersonName(String) | Initializes a new instance of this class using the completely formatted DICOM name string provided.
Public method | MCpersonName(MCpnComponentGroup, MCpnComponentGroup, MCpnComponentGroup) | Initializes a new instance of this class based on the specified component groups.
Public method | MCpersonName(String, String, String, String, String) | Initializes a new instance of this class using values for the first and only component group (Character representation).

See Also

MCpersonName Class
MCpersonName Members


MCpersonName Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName Constructor (String)
MCpersonName Class See Also Send Feedback
Initializes a new instance of this class using the completely formatted DICOM name string provided.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonName(
    string personName
)
Visual Basic
Public Sub New ( _
    personName As String _
)
Visual C++
public:
MCpersonName(
    String^ personName
)

Parameters

personName
Type: System..::..String
A String containing the properly formatted DICOM person name.

See Also

MCpersonName Class
MCpersonName Members
MCpersonName Overload


MCpersonName Constructor (MCpnComponentGroup, MCpnComponentGroup, MCpnComponentGroup)

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName Constructor (MCpnComponentGroup, MCpnComponentGroup, MCpnComponentGroup)
MCpersonName Class See Also Send Feedback
Initializes a new instance of this class based on the specified component groups.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonName(
    MCpnComponentGroup charRepresentation,
    MCpnComponentGroup ideographicRepresentation,
    MCpnComponentGroup phoneticRepresentation
)
Visual Basic
Public Sub New ( _
    charRepresentation As MCpnComponentGroup, _
    ideographicRepresentation As MCpnComponentGroup, _
    phoneticRepresentation As MCpnComponentGroup _
)
Visual C++
public:
MCpersonName(
    MCpnComponentGroup^ charRepresentation,
    MCpnComponentGroup^ ideographicRepresentation,
    MCpnComponentGroup^ phoneticRepresentation
)

Parameters

charRepresentation
Type: Mergecom..::..MCpnComponentGroup
The single byte character representation of the person name, or null if it is not known.
ideographicRepresentation
Type: Mergecom..::..MCpnComponentGroup
The ideographic representation of the person name, or null if it is not known.
phoneticRepresentation
Type: Mergecom..::..MCpnComponentGroup
The phonetic representation of the name, or null if it is not known.

Remarks

This form of the constructor constructs a DICOM person name using 1 to 3 different representations of the name.

See Also

MCpersonName Class
MCpersonName Members
MCpersonName Overload


MCpersonName Constructor (String, String, String, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName Constructor (String, String, String, String, String)
MCpersonName Class See Also Send Feedback
Initializes a new instance of this class using values for the first and only component group (Character representation).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonName(
    string familyName,
    string givenName,
    string middleName,
    string namePrefix,
    string nameSuffix
)
Visual Basic
Public Sub New ( _
    familyName As String, _
    givenName As String, _
    middleName As String, _
    namePrefix As String, _
    nameSuffix As String _
)
Visual C++
public:
MCpersonName(
    String^ familyName,
    String^ givenName,
    String^ middleName,
    String^ namePrefix,
    String^ nameSuffix
)

Parameters

familyName
Type: System..::..String
The family name complex.
givenName
Type: System..::..String
The given name complex.
middleName
Type: System..::..String
The middle name.
namePrefix
Type: System..::..String
The name prefix.
nameSuffix
Type: System..::..String
The name suffix.

Remarks

Any of the five arguments may be empty or null.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | caret(^) or equals(=) characters in one of the arguments.

See Also

MCpersonName Class
MCpersonName Members
MCpersonName Overload


MCpersonName Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonName Methods
MCpersonName Class See Also Send Feedback

The MCpersonName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this instance of MCpersonName and a specified object, have the same value. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a unicode string representing the DICOM encoded person name. (Overrides Object..::..ToString()()()().)

See Also

MCpersonName Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..Equals Method
MCpersonName Class See Also Send Feedback
Determines whether this instance of MCpersonName and a specified object, have the same value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare against.

Return Value

true if the specified object is an instance of MCpersonName and it represents the same person name as the current object; otherwise false.

See Also

MCpersonName Class
MCpersonName Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..GetHashCode Method
MCpersonName Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCpersonName Class
MCpersonName Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..ToString Method
MCpersonName Class See Also Send Feedback
Gets a unicode string representing the DICOM encoded person name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The person name value represented as a String.

See Also

MCpersonName Class
MCpersonName Members


MCpersonName Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonName Properties
MCpersonName Class See Also Send Feedback

The MCpersonName type exposes the following members.

Properties

 | Name | Description
Public property | CharacterRepresentation | Gets the character representation of the person name as an MCpnComponentGroup object.
Public property | CharacterRepValue | Gets the character representation of the person name as a string.
Public property | IdeographicRepresentation | Gets the ideographic representation of the person name as an MCpnComponentGroup object.
Public property | IdeographicRepValue | Retrieves the ideographic representation of the person name as a string.
Public property | PhoneticRepresentation | Gets the phonetic representation of the person name as an MCpnComponentGroup object.
Public property | PhoneticRepValue | Gets the phonetic representation of the person name as a string.

See Also

MCpersonName Class


CharacterRepresentation Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..CharacterRepresentation Property
MCpersonName Class See Also Send Feedback
Gets the character representation of the person name as an MCpnComponentGroup object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpnComponentGroup CharacterRepresentation { get; }
Visual Basic
Public Overridable ReadOnly Property CharacterRepresentation As MCpnComponentGroup
    Get
Visual C++
public:
virtual property MCpnComponentGroup^ CharacterRepresentation {
    MCpnComponentGroup^ get ();
}

Field Value

An MCpnComponentGroup containing the character representation of the person name, or null if the character representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


CharacterRepValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..CharacterRepValue Property
MCpersonName Class See Also Send Feedback
Gets the character representation of the person name as a string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CharacterRepValue { get; }
Visual Basic
Public Overridable ReadOnly Property CharacterRepValue As String
    Get
Visual C++
public:
virtual property String^ CharacterRepValue {
    String^ get ();
}

Field Value

A String containing the character representation of the person name, or null if the character representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


IdeographicRepresentation Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..IdeographicRepresentation Property
MCpersonName Class See Also Send Feedback
Gets the ideographic representation of the person name as an MCpnComponentGroup object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpnComponentGroup IdeographicRepresentation { get; }
Visual Basic
Public Overridable ReadOnly Property IdeographicRepresentation As MCpnComponentGroup
    Get
Visual C++
public:
virtual property MCpnComponentGroup^ IdeographicRepresentation {
    MCpnComponentGroup^ get ();
}

Field Value

An MCpnComponentGroup containing the ideographic representation of the person name, or null if the ideographic representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


IdeographicRepValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..IdeographicRepValue Property
MCpersonName Class See Also Send Feedback
Retrieves the ideographic representation of the person name as a string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IdeographicRepValue { get; }
Visual Basic
Public Overridable ReadOnly Property IdeographicRepValue As String
    Get
Visual C++
public:
virtual property String^ IdeographicRepValue {
    String^ get ();
}

Field Value

A String containing the ideographic representation of the person name, or null if the ideographic representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


PhoneticRepresentation Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..PhoneticRepresentation Property
MCpersonName Class See Also Send Feedback
Gets the phonetic representation of the person name as an MCpnComponentGroup object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpnComponentGroup PhoneticRepresentation { get; }
Visual Basic
Public Overridable ReadOnly Property PhoneticRepresentation As MCpnComponentGroup
    Get
Visual C++
public:
virtual property MCpnComponentGroup^ PhoneticRepresentation {
    MCpnComponentGroup^ get ();
}

Field Value

An MCpnComponentGroup containing the phonetic representation of the person name, or null if the phonetic representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


PhoneticRepValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonName..::..PhoneticRepValue Property
MCpersonName Class See Also Send Feedback
Gets the phonetic representation of the person name as a string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PhoneticRepValue { get; }
Visual Basic
Public Overridable ReadOnly Property PhoneticRepValue As String
    Get
Visual C++
public:
virtual property String^ PhoneticRepValue {
    String^ get ();
}

Field Value

A String containing the phonetic representation of the person name, or null if the phonetic representation is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The Person name value is incorrectly formatted.

See Also

MCpersonName Class
MCpersonName Members


MCpnComponentGroup Class

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Class
Members See Also Send Feedback
Represents a DICOM person name component group.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpnComponentGroup
Visual Basic
Public Class MCpnComponentGroup
Visual C++
public ref class MCpnComponentGroup

Remarks

A DICOM person name component group contains optional values for five name components:

  • family name complex
  • given name complex
  • middle name
  • name prefix
  • name suffix

A DICOM person name value (VR=PN) may consist of up to three different person name component groups. Each is optional and appear in this order:

  • A character representation of the component group
  • An ideographic representation of the component group
  • A phonetic representation of the component group

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCpnComponentGroup

See Also

MCpnComponentGroup Members


MCpnComponentGroup Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Members
MCpnComponentGroup Class Constructors Methods Properties See Also Send Feedback

The MCpnComponentGroup type exposes the following members.

Constructors

 | Name | Description
Public method | MCpnComponentGroup(String) | Initializes a new instance of this class using a string containing the person name.
Public method | MCpnComponentGroup(String, String, String, String, String) | Initializes a new instance of this class using separate values for each component.

Methods

 | Name | Description
Public method | Equals | Determines whether this instance of MCpnComponentGroup and a specified object, have the same value. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the unicode string representation of the DICOM encoded person name. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FamilyNameValue | The Family Name Component value.
Public property | GivenNameValue | The Given Name Component value.
Public property | MiddleNameValue | The Middle Name Component value.
Public property | NamePrefixValue | The Name Prefix Component value.
Public property | NameSuffixValue | The Name Suffix Component value.

See Also

MCpnComponentGroup Class


MCpnComponentGroup Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Constructor
MCpnComponentGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpnComponentGroup(String) | Initializes a new instance of this class using a string containing the person name.
Public method | MCpnComponentGroup(String, String, String, String, String) | Initializes a new instance of this class using separate values for each component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


MCpnComponentGroup Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Constructor (String)
MCpnComponentGroup Class See Also Send Feedback
Initializes a new instance of this class using a string containing the person name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpnComponentGroup(
    string groupString
)
Visual Basic
Public Sub New ( _
    groupString As String _
)
Visual C++
public:
MCpnComponentGroup(
    String^ groupString
)

Parameters

groupString
Type: System..::..String
A String containing the name components, each separated by the caret (^) character as specified in the DICOM standard. It may be null, indicating an empty component group.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument contains more than four caret characters or it contains an equals character.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members
MCpnComponentGroup Overload


MCpnComponentGroup Constructor (String, String, String, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Constructor (String, String, String, String, String)
MCpnComponentGroup Class See Also Send Feedback
Initializes a new instance of this class using separate values for each component.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpnComponentGroup(
    string familyName,
    string givenName,
    string middleName,
    string namePrefix,
    string nameSuffix
)
Visual Basic
Public Sub New ( _
    familyName As String, _
    givenName As String, _
    middleName As String, _
    namePrefix As String, _
    nameSuffix As String _
)
Visual C++
public:
MCpnComponentGroup(
    String^ familyName,
    String^ givenName,
    String^ middleName,
    String^ namePrefix,
    String^ nameSuffix
)

Parameters

familyName
Type: System..::..String
The family name complex.
givenName
Type: System..::..String
The given name complex.
middleName
Type: System..::..String
The middle name.
namePrefix
Type: System..::..String
The name prefix.
nameSuffix
Type: System..::..String
The name suffix.

Remarks

Any of the five arguments may be empty or null.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | caret(^) or equals(=) characters in one of the arguments.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members
MCpnComponentGroup Overload


MCpnComponentGroup Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Methods
MCpnComponentGroup Class See Also Send Feedback

The MCpnComponentGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this instance of MCpnComponentGroup and a specified object, have the same value. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the unicode string representation of the DICOM encoded person name. (Overrides Object..::..ToString()()()().)

See Also

MCpnComponentGroup Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..Equals Method
MCpnComponentGroup Class See Also Send Feedback
Determines whether this instance of MCpnComponentGroup and a specified object, have the same value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare against.

Return Value

true if the specified object is an instance of MCpnComponentGroup and it represents the same group of the same person name as the current object.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..GetHashCode Method
MCpnComponentGroup Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..ToString Method
MCpnComponentGroup Class See Also Send Feedback
Gets the unicode string representation of the DICOM encoded person name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The person name component group value represented as a String.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


MCpnComponentGroup Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup Properties
MCpnComponentGroup Class See Also Send Feedback

The MCpnComponentGroup type exposes the following members.

Properties

 | Name | Description
Public property | FamilyNameValue | The Family Name Component value.
Public property | GivenNameValue | The Given Name Component value.
Public property | MiddleNameValue | The Middle Name Component value.
Public property | NamePrefixValue | The Name Prefix Component value.
Public property | NameSuffixValue | The Name Suffix Component value.

See Also

MCpnComponentGroup Class


FamilyNameValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..FamilyNameValue Property
MCpnComponentGroup Class See Also Send Feedback
The Family Name Component value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FamilyNameValue { get; }
Visual Basic
Public Overridable ReadOnly Property FamilyNameValue As String
    Get
Visual C++
public:
virtual property String^ FamilyNameValue {
    String^ get ();
}

Field Value

A String containing the Family Name Component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


GivenNameValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..GivenNameValue Property
MCpnComponentGroup Class See Also Send Feedback
The Given Name Component value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string GivenNameValue { get; }
Visual Basic
Public Overridable ReadOnly Property GivenNameValue As String
    Get
Visual C++
public:
virtual property String^ GivenNameValue {
    String^ get ();
}

Field Value

A String containing the Given Name Component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


MiddleNameValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..MiddleNameValue Property
MCpnComponentGroup Class See Also Send Feedback
The Middle Name Component value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MiddleNameValue { get; }
Visual Basic
Public Overridable ReadOnly Property MiddleNameValue As String
    Get
Visual C++
public:
virtual property String^ MiddleNameValue {
    String^ get ();
}

Field Value

A String containing the Middle Name Component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


NamePrefixValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..NamePrefixValue Property
MCpnComponentGroup Class See Also Send Feedback
The Name Prefix Component value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string NamePrefixValue { get; }
Visual Basic
Public Overridable ReadOnly Property NamePrefixValue As String
    Get
Visual C++
public:
virtual property String^ NamePrefixValue {
    String^ get ();
}

Field Value

A String containing the Name Prefix Component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


NameSuffixValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCpnComponentGroup..::..NameSuffixValue Property
MCpnComponentGroup Class See Also Send Feedback
The Name Suffix Component value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string NameSuffixValue { get; }
Visual Basic
Public Overridable ReadOnly Property NameSuffixValue As String
    Get
Visual C++
public:
virtual property String^ NameSuffixValue {
    String^ get ();
}

Field Value

A String containing the Name Suffix Component.

See Also

MCpnComponentGroup Class
MCpnComponentGroup Members


MCprintManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Class
Members See Also Send Feedback
Represents a DICOM Print Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCprintManagementService : MCdimseService
Visual Basic
Public Class MCprintManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCprintManagementService : public MCdimseService

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCprintManagementService

See Also

MCprintManagementService Members


MCprintManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Members
MCprintManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCprintManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCprintManagementService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCprintManagementService Class


MCprintManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Constructor
MCprintManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCprintManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCprintManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCprintManagementService Class
MCprintManagementService Members


MCprintManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Fields
MCprintManagementService Class See Also Send Feedback

The MCprintManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCprintManagementService Class


MCprintManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Methods
MCprintManagementService Class See Also Send Feedback

The MCprintManagementService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCprintManagementService Class


MCprintManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprintManagementService Properties
MCprintManagementService Class See Also Send Feedback

The MCprintManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCprintManagementService Class


MCproposedContext Class

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Class
Members See Also Send Feedback
Represents a DICOM service which is being proposed for use in a DICOM association between two DICOM application entities.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCproposedContext
Visual Basic
Public Class MCproposedContext
Visual C++
public ref class MCproposedContext

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCproposedContext

See Also

MCproposedContext Members


MCproposedContext Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Members
MCproposedContext Class Constructors Methods Properties See Also Send Feedback

The MCproposedContext type exposes the following members.

Constructors

 | Name | Description
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList) | Initializes a new instance of this class for a specified SOP class and transfer syntax list, using unspecified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, MCnegotiationInfo) | Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using unspecified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, Boolean, Boolean) | Initializes a new instance of this class for a specified SOP class and transfer syntax list, using specified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, Boolean, Boolean, MCnegotiationInfo) | Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using specified SCU and SCP roles.

Methods

 | Name | Description
Public method | clearNegotiationInfo | Clears any stored extended negotiation information as used by the specified application for this context's service.
Public method | dispose | dispose of the resources associated with this context.
Public method | Equals | Determines if this object is equal to another object (context). (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getNegotiationInfo | Obsolete. Returns any extended negotiation information that may have been set for this context's service for a specific application.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setNegotiationInfo | Obsolete. Sets extended user negotiation information for this context as used by a specific application.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AbstractSyntax | Represents the abstract syntax UID associated with this proposed service.
Public property | SCProle | Gets the SCP role negotiation value.
Public property | SCUrole | Gets the SCU role negotiation value.
Public property | ServiceName | Gets the name associated with this proposed service.
Public property | SopInfo | Gets the SOP class associated with this proposed context.
Public property | TransferSyntaxList | Gets the transfer syntax list associated with this proposed service.

See Also

MCproposedContext Class


MCproposedContext Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Constructor
MCproposedContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList) | Initializes a new instance of this class for a specified SOP class and transfer syntax list, using unspecified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, MCnegotiationInfo) | Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using unspecified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, Boolean, Boolean) | Initializes a new instance of this class for a specified SOP class and transfer syntax list, using specified SCU and SCP roles.
Public method | MCproposedContext(MCsopClass, MCtransferSyntaxList, Boolean, Boolean, MCnegotiationInfo) | Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using specified SCU and SCP roles.

See Also

MCproposedContext Class
MCproposedContext Members


MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList)
MCproposedContext Class See Also Send Feedback
Initializes a new instance of this class for a specified SOP class and transfer syntax list, using unspecified SCU and SCP roles.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContext(
    MCsopClass sopInfo,
    MCtransferSyntaxList tsList
)
Visual Basic
Public Sub New ( _
    sopInfo As MCsopClass, _
    tsList As MCtransferSyntaxList _
)
Visual C++
public:
MCproposedContext(
    MCsopClass^ sopInfo,
    MCtransferSyntaxList^ tsList
)

Parameters

sopInfo
Type: Mergecom..::..MCsopClass
The SOP class of the service.
tsList
Type: Mergecom..::..MCtransferSyntaxList
The list of acceptable transfer syntaxes.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP class argument was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCproposedContext Class
MCproposedContext Members
MCproposedContext Overload


MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, MCnegotiationInfo)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, MCnegotiationInfo)
MCproposedContext Class See Also Send Feedback
Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using unspecified SCU and SCP roles.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContext(
    MCsopClass sopInfo,
    MCtransferSyntaxList tsList,
    MCnegotiationInfo infoObject
)
Visual Basic
Public Sub New ( _
    sopInfo As MCsopClass, _
    tsList As MCtransferSyntaxList, _
    infoObject As MCnegotiationInfo _
)
Visual C++
public:
MCproposedContext(
    MCsopClass^ sopInfo,
    MCtransferSyntaxList^ tsList,
    MCnegotiationInfo^ infoObject
)

Parameters

sopInfo
Type: Mergecom..::..MCsopClass
The SOP class of the service.
tsList
Type: Mergecom..::..MCtransferSyntaxList
The list of acceptable transfer syntaxes.
infoObject
Type: Mergecom..::..MCnegotiationInfo
Extended negotiation info object.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP class argument was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCproposedContext Class
MCproposedContext Members
MCproposedContext Overload


MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, Boolean, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, Boolean, Boolean)
MCproposedContext Class See Also Send Feedback
Initializes a new instance of this class for a specified SOP class and transfer syntax list, using specified SCU and SCP roles.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContext(
    MCsopClass sopInfo,
    MCtransferSyntaxList tsList,
    bool scuRole,
    bool scpRole
)
Visual Basic
Public Sub New ( _
    sopInfo As MCsopClass, _
    tsList As MCtransferSyntaxList, _
    scuRole As Boolean, _
    scpRole As Boolean _
)
Visual C++
public:
MCproposedContext(
    MCsopClass^ sopInfo,
    MCtransferSyntaxList^ tsList,
    bool scuRole,
    bool scpRole
)

Parameters

sopInfo
Type: Mergecom..::..MCsopClass
The SOP class of the service.
tsList
Type: Mergecom..::..MCtransferSyntaxList
The list of acceptable transfer syntaxes.
scuRole
Type: System..::..Boolean
true if the application is willing to perform the SCU role.
scpRole
Type: System..::..Boolean
true if the application is willing to perform the SCP role.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP class was invalid or an invalid role was specified (both role arguments were false.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCproposedContext Class
MCproposedContext Members
MCproposedContext Overload


MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, Boolean, Boolean, MCnegotiationInfo)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Constructor (MCsopClass, MCtransferSyntaxList, Boolean, Boolean, MCnegotiationInfo)
MCproposedContext Class See Also Send Feedback
Initializes a new instance of this class for a specified SOP class and transfer syntax list with extended negotiation object, using specified SCU and SCP roles.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContext(
    MCsopClass sopInfo,
    MCtransferSyntaxList tsList,
    bool scuRole,
    bool scpRole,
    MCnegotiationInfo infoObject
)
Visual Basic
Public Sub New ( _
    sopInfo As MCsopClass, _
    tsList As MCtransferSyntaxList, _
    scuRole As Boolean, _
    scpRole As Boolean, _
    infoObject As MCnegotiationInfo _
)
Visual C++
public:
MCproposedContext(
    MCsopClass^ sopInfo,
    MCtransferSyntaxList^ tsList,
    bool scuRole,
    bool scpRole,
    MCnegotiationInfo^ infoObject
)

Parameters

sopInfo
Type: Mergecom..::..MCsopClass
The SOP class of the service.
tsList
Type: Mergecom..::..MCtransferSyntaxList
The list of acceptable transfer syntaxes.
scuRole
Type: System..::..Boolean
true if the application is willing to perform the SCU role.
scpRole
Type: System..::..Boolean
true if the application is willing to perform the SCP role.
infoObject
Type: Mergecom..::..MCnegotiationInfo
Extended negotiation info object.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP class was invalid or an invalid role was specified (both role arguments were false.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCproposedContext Class
MCproposedContext Members
MCproposedContext Overload


MCproposedContext Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Methods
MCproposedContext Class See Also Send Feedback

The MCproposedContext type exposes the following members.

Methods

 | Name | Description
Public method | clearNegotiationInfo | Clears any stored extended negotiation information as used by the specified application for this context's service.
Public method | dispose | dispose of the resources associated with this context.
Public method | Equals | Determines if this object is equal to another object (context). (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | getNegotiationInfo | Obsolete. Returns any extended negotiation information that may have been set for this context's service for a specific application.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setNegotiationInfo | Obsolete. Sets extended user negotiation information for this context as used by a specific application.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCproposedContext Class


clearNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..clearNegotiationInfo Method
MCproposedContext Class See Also Send Feedback
Clears any stored extended negotiation information as used by the specified application for this context's service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void clearNegotiationInfo(
    MCapplication application
)
Visual Basic
Public Overridable Sub clearNegotiationInfo ( _
    application As MCapplication _
)
Visual C++
public:
virtual void clearNegotiationInfo(
    MCapplication^ application
)

Parameters

application
Type: Mergecom..::..MCapplication
MCapplication object identifying an application entity.

Remarks

Any stored extended negotiation information is removed, therefore, no such information will be used for the service when negotiating an association using this proposed context list.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCproposedContext Class
MCproposedContext Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..dispose Method
MCproposedContext Class See Also Send Feedback
dispose of the resources associated with this context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCproposedContext Class
MCproposedContext Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..Equals Method
MCproposedContext Class See Also Send Feedback
Determines if this object is equal to another object (context).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
An object to compare to this one.

Return Value

true if the object is an MCproposedContext instance and has the same SOP Class, transfer syntax and roles.

See Also

MCproposedContext Class
MCproposedContext Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..GetHashCode Method
MCproposedContext Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCproposedContext Class
MCproposedContext Members


getNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..getNegotiationInfo Method
MCproposedContext Class See Also Send Feedback
Returns any extended negotiation information that may have been set for this context's service for a specific application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete; use method in MCresultContext class instead")]
public virtual MCnegotiationInfo getNegotiationInfo(
    MCapplication application
)
Visual Basic
<ObsoleteAttribute("This method is obsolete; use method in MCresultContext class instead")> _
Public Overridable Function getNegotiationInfo ( _
    application As MCapplication _
) As MCnegotiationInfo
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete; use method in MCresultContext class instead")]
virtual MCnegotiationInfo^ getNegotiationInfo(
    MCapplication^ application
)

Parameters

application
Type: Mergecom..::..MCapplication
The MCapplication object identifying an application entity.

Return Value

The MCnegotiationInfo object identifying the extended negotiation information set for this context's service for the application or null if no extended negotiation info has been set or if the info was cleared for application.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The application parameter was null.

See Also

MCproposedContext Class
MCproposedContext Members


setNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..setNegotiationInfo Method
MCproposedContext Class See Also Send Feedback
Sets extended user negotiation information for this context as used by a specific application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")]
public virtual void setNegotiationInfo(
    MCapplication application,
    MCnegotiationInfo infoObject
)
Visual Basic
<ObsoleteAttribute("This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")> _
Public Overridable Sub setNegotiationInfo ( _
    application As MCapplication, _
    infoObject As MCnegotiationInfo _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")]
virtual void setNegotiationInfo(
    MCapplication^ application,
    MCnegotiationInfo^ infoObject
)

Parameters

application
Type: Mergecom..::..MCapplication
The MCapplication object identifying an application entity.
infoObject
Type: Mergecom..::..MCnegotiationInfo
A non-null MCnegotiationInfo instance.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters was invalid.

See Also

MCproposedContext Class
MCproposedContext Members


MCproposedContext Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContext Properties
MCproposedContext Class See Also Send Feedback

The MCproposedContext type exposes the following members.

Properties

 | Name | Description
Public property | AbstractSyntax | Represents the abstract syntax UID associated with this proposed service.
Public property | SCProle | Gets the SCP role negotiation value.
Public property | SCUrole | Gets the SCU role negotiation value.
Public property | ServiceName | Gets the name associated with this proposed service.
Public property | SopInfo | Gets the SOP class associated with this proposed context.
Public property | TransferSyntaxList | Gets the transfer syntax list associated with this proposed service.

See Also

MCproposedContext Class


AbstractSyntax Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..AbstractSyntax Property
MCproposedContext Class See Also Send Feedback
Represents the abstract syntax UID associated with this proposed service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AbstractSyntax { get; }
Visual Basic
Public Overridable ReadOnly Property AbstractSyntax As String
    Get
Visual C++
public:
virtual property String^ AbstractSyntax {
    String^ get ();
}

Return Value

The abstract syntax UID associated with the proposed service

See Also

MCproposedContext Class
MCproposedContext Members


SCProle Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..SCProle Property
MCproposedContext Class See Also Send Feedback
Gets the SCP role negotiation value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte SCProle { get; }
Visual Basic
Public Overridable ReadOnly Property SCProle As Byte
    Get
Visual C++
public:
virtual property unsigned char SCProle {
    unsigned char get ();
}

Field Value

1 if the application is willing to perform the SCP role; 0 if the application unwilling to perform the SCP role; or 2 if the role is unspecified. (Defaults to 1 for association acceptor and 0 for association requester.)

See Also

MCproposedContext Class
MCproposedContext Members


SCUrole Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..SCUrole Property
MCproposedContext Class See Also Send Feedback
Gets the SCU role negotiation value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte SCUrole { get; }
Visual Basic
Public Overridable ReadOnly Property SCUrole As Byte
    Get
Visual C++
public:
virtual property unsigned char SCUrole {
    unsigned char get ();
}

Field Value

1 if the application is willing to perform the SCU role; 0 if the application is unwilling to perform the SCU role; or 2 if the role is unspecified. (Defaults to 1 for association requester and 0 for association acceptor.)

See Also

MCproposedContext Class
MCproposedContext Members


ServiceName Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..ServiceName Property
MCproposedContext Class See Also Send Feedback
Gets the name associated with this proposed service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceName { get; }
Visual Basic
Public Overridable ReadOnly Property ServiceName As String
    Get
Visual C++
public:
virtual property String^ ServiceName {
    String^ get ();
}

Field Value

The name associated with the proposed service.

Remarks

This is the name configured in the Mergecom.srv file.

See Also

MCproposedContext Class
MCproposedContext Members


SopInfo Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..SopInfo Property
MCproposedContext Class See Also Send Feedback
Gets the SOP class associated with this proposed context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCsopClass SopInfo { get; }
Visual Basic
Public Overridable ReadOnly Property SopInfo As MCsopClass
    Get
Visual C++
public:
virtual property MCsopClass^ SopInfo {
    MCsopClass^ get ();
}

Field Value

A non-null MCsopClass object.

See Also

MCproposedContext Class
MCproposedContext Members


TransferSyntaxList Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContext..::..TransferSyntaxList Property
MCproposedContext Class See Also Send Feedback
Gets the transfer syntax list associated with this proposed service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntaxList TransferSyntaxList { get; }
Visual Basic
Public Overridable ReadOnly Property TransferSyntaxList As MCtransferSyntaxList
    Get
Visual C++
public:
virtual property MCtransferSyntaxList^ TransferSyntaxList {
    MCtransferSyntaxList^ get ();
}

Return Value

The MCtransferSyntaxList object associated with the proposed service.

See Also

MCproposedContext Class
MCproposedContext Members


MCproposedContextList Class

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Class
Members See Also Send Feedback
Represents a list of presentation contexts that are being proposed for association negotiation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCproposedContextList
Visual Basic
Public Class MCproposedContextList
Visual C++
public ref class MCproposedContextList

Remarks

When an association is being established, the association acceptor and association requester each offer a list of contexts that the application entity is willing to support. Each context is a DICOM service and one or more transfer syntaxes that can be used.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCproposedContextList

See Also

MCproposedContextList Members


MCproposedContextList Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Members
MCproposedContextList Class Constructors Methods Properties See Also Send Feedback

The MCproposedContextList type exposes the following members.

Constructors

 | Name | Description
Public method | MCproposedContextList(String, array<MCproposedContext>[]()[][]) | Initializes a new instance of this class.
Public method | MCproposedContextList(String, array<MCproposedContext>[]()[][], UInt16, UInt16) | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | clearNegotiationInfo | Clears any stored extended negotiation information for a specified service.
Public method | contains(String) | Determines if this list contains a proposed context for a particular service.
Public method | contains(MCproposedContext) | Determines if this list contains a particular proposed context.
Public method | dispose | Cleans up this list by removing it from the list of known context lists.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getContext | Retrieves the MCproposedContext object for a given service.
Public method | GetEnumerator | Gets an enumerator for the MCproposedContext instances in this list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNegotiationInfo | Obsolete. Returns any extended negotiation information that may have been set for a context's service for a specific application.
 | getObject | Gets the context list for the specified name.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setNegotiationInfo | Obsolete. Sets extended user negotiation information for a specific service.
Public method | toArray()()()() | Returns the context list as an array of MCproposedContext objects.
Public method | toArray(Int32) | Returns the context list as an array of MCproposedContext objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ListName | Gets the name of this context collection.
Public property | MaxOperationsInvoked | Gets the maximum number of asynchronous operations invoked.
Public property | MaxOperationsPerformed | Gets the maximum number of asynchronous operations performed.
Public property | Size | Returns the number of contexts in this list.

See Also

MCproposedContextList Class


MCproposedContextList Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Constructor
MCproposedContextList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCproposedContextList(String, array<MCproposedContext>[]()[][]) | Initializes a new instance of this class.
Public method | MCproposedContextList(String, array<MCproposedContext>[]()[][], UInt16, UInt16) | Initializes a new instance of this class.

See Also

MCproposedContextList Class
MCproposedContextList Members


MCproposedContextList Constructor (String, MCproposedContext[])

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Constructor (String, array<MCproposedContext>[]()[][])
MCproposedContextList Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContextList(
    string contextListName,
    MCproposedContext[] contexts
)
Visual Basic
Public Sub New ( _
    contextListName As String, _
    contexts As MCproposedContext() _
)
Visual C++
public:
MCproposedContextList(
    String^ contextListName,
    array<MCproposedContext^>^ contexts
)

Parameters

contextListName
Type: System..::..String
The name identifying this list.
contexts
Type: array< Mergecom..::..MCproposedContext >[]()[][]
An array of MCproposedContext objects.

Remarks

The new object will encapsulate the contexts array of MCproposedContext objects. An MCalreadyExistsException is thrown if an MCproposedContextList object has already been created with the specified name. The name must consist of 1 to 129 characters.

Note that proposed context lists may be defined in a section of the app configuration file. If contextListName matches the service list defined in the app file, MCalreadyExistsException will be thrown. You can retrieve such a pre-defined proposed context list by using the getObject(String) static method.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The name argument was null or was an empty string; or contexts was null or had a length of zero; or the name consisted of more than 129 characters.
Mergecom.Exceptions..::..MCalreadyExistsException | A proposed context list has already been registered with the specified name.

See Also

MCproposedContextList Class
MCproposedContextList Members
MCproposedContextList Overload


MCproposedContextList Constructor (String, MCproposedContext[], UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Constructor (String, array<MCproposedContext>[]()[][], UInt16, UInt16)
MCproposedContextList Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCproposedContextList(
    string contextListName,
    MCproposedContext[] contexts,
    ushort maxOperationsInvoked,
    ushort maxOperationsPerformed
)
Visual Basic
Public Sub New ( _
    contextListName As String, _
    contexts As MCproposedContext(), _
    maxOperationsInvoked As UShort, _
    maxOperationsPerformed As UShort _
)
Visual C++
public:
MCproposedContextList(
    String^ contextListName,
    array<MCproposedContext^>^ contexts,
    unsigned short maxOperationsInvoked,
    unsigned short maxOperationsPerformed
)

Parameters

contextListName
Type: System..::..String
The name identifying this list.
contexts
Type: array< Mergecom..::..MCproposedContext >[]()[][]
An array of MCproposedContext objects.
maxOperationsInvoked
Type: System..::..UInt16
The maximum number of asynchronous operations invoked.
maxOperationsPerformed
Type: System..::..UInt16
The maximum number of asynchronous operations performed.

Remarks

MCproposedContextList objects are used to identify those services a DICOM association partner is willing to perform. The services can be used for asynchronous DICOM communications.

The new object will encapsulate the contexts array of MCproposedContext objects. An MCalreadyExistsException is thrown if an MCproposedContextList object has already been created with the specified name. The name must consist of 1 to 129 characters.

Note that proposed context lists may be defined in a [<service_list_name>] section of the app configuration file. If contextListName matches the <service_list_name> defined in the app file, MCalreadyExistsException will be thrown. You can retrieve such a pre-defined proposed context list by using the getObject(String) method.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The name argument was null or was an empty string; or contexts was null or had a length of zero; or contextListName consisted of more than 129 characters.
Mergecom.Exceptions..::..MCalreadyExistsException | A proposed context list has already been registered with a name of contextListName.

See Also

MCproposedContextList Class
MCproposedContextList Members
MCproposedContextList Overload


MCproposedContextList Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Methods
MCproposedContextList Class See Also Send Feedback

The MCproposedContextList type exposes the following members.

Methods

 | Name | Description
Public method | clearNegotiationInfo | Clears any stored extended negotiation information for a specified service.
Public method | contains(String) | Determines if this list contains a proposed context for a particular service.
Public method | contains(MCproposedContext) | Determines if this list contains a particular proposed context.
Public method | dispose | Cleans up this list by removing it from the list of known context lists.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getContext | Retrieves the MCproposedContext object for a given service.
Public method | GetEnumerator | Gets an enumerator for the MCproposedContext instances in this list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNegotiationInfo | Obsolete. Returns any extended negotiation information that may have been set for a context's service for a specific application.
 | getObject | Gets the context list for the specified name.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setNegotiationInfo | Obsolete. Sets extended user negotiation information for a specific service.
Public method | toArray()()()() | Returns the context list as an array of MCproposedContext objects.
Public method | toArray(Int32) | Returns the context list as an array of MCproposedContext objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCproposedContextList Class


clearNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..clearNegotiationInfo Method
MCproposedContextList Class See Also Send Feedback
Clears any stored extended negotiation information for a specified service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void clearNegotiationInfo(
    MCapplication application,
    string service
)
Visual Basic
Public Overridable Sub clearNegotiationInfo ( _
    application As MCapplication, _
    service As String _
)
Visual C++
public:
virtual void clearNegotiationInfo(
    MCapplication^ application,
    String^ service
)

Parameters

application
Type: Mergecom..::..MCapplication
A not null MCapplication object identifying an application entity
service
Type: System..::..String
A not null name of a service contained in this list.

Remarks

After clearing the extended negotiation information, no such information will be used for the service when negotiating an association on the specified application using this proposed context list. This call is ignored if the service is not in this proposed context list.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | Application or service was null.

See Also

MCproposedContextList Class
MCproposedContextList Members


contains Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..contains Method
MCproposedContextList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | contains(String) | Determines if this list contains a proposed context for a particular service.
Public method | contains(MCproposedContext) | Determines if this list contains a particular proposed context.

See Also

MCproposedContextList Class
MCproposedContextList Members


contains Method (String)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..contains Method (String)
MCproposedContextList Class See Also Send Feedback
Determines if this list contains a proposed context for a particular service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool contains(
    string serviceName
)
Visual Basic
Public Overridable Function contains ( _
    serviceName As String _
) As Boolean
Visual C++
public:
virtual bool contains(
    String^ serviceName
)

Parameters

serviceName
Type: System..::..String
The name of a service to search for.

Return Value

true if this list contains the specified context; otherwise false.

See Also

MCproposedContextList Class
MCproposedContextList Members
contains Overload


contains Method (MCproposedContext)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..contains Method (MCproposedContext)
MCproposedContextList Class See Also Send Feedback
Determines if this list contains a particular proposed context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool contains(
    MCproposedContext context
)
Visual Basic
Public Overridable Function contains ( _
    context As MCproposedContext _
) As Boolean
Visual C++
public:
virtual bool contains(
    MCproposedContext^ context
)

Parameters

context
Type: Mergecom..::..MCproposedContext
An MCproposedContext object to search for.

Return Value

true if this list contains the specified context; otherwise false.

See Also

MCproposedContextList Class
MCproposedContextList Members
contains Overload


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..dispose Method
MCproposedContextList Class See Also Send Feedback
Cleans up this list by removing it from the list of known context lists.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCproposedContextList Class
MCproposedContextList Members


getContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..getContext Method
MCproposedContextList Class See Also Send Feedback
Retrieves the MCproposedContext object for a given service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCproposedContext getContext(
    string serviceName
)
Visual Basic
Public Overridable Function getContext ( _
    serviceName As String _
) As MCproposedContext
Visual C++
public:
virtual MCproposedContext^ getContext(
    String^ serviceName
)

Parameters

serviceName
Type: System..::..String
The name of a service contained in this list.

Return Value

An MCproposedContext object or null if the specified service is not in this list.

See Also

MCproposedContextList Class
MCproposedContextList Members


GetEnumerator Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..GetEnumerator Method
MCproposedContextList Class See Also Send Feedback
Gets an enumerator for the MCproposedContext instances in this list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

A non-null enumerator.

See Also

MCproposedContextList Class
MCproposedContextList Members


getNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..getNegotiationInfo Method
MCproposedContextList Class See Also Send Feedback
Returns any extended negotiation information that may have been set for a context's service for a specific application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete; use method in MCresultContext class instead")]
public virtual MCnegotiationInfo getNegotiationInfo(
    MCapplication application,
    string service
)
Visual Basic
<ObsoleteAttribute("This method is obsolete; use method in MCresultContext class instead")> _
Public Overridable Function getNegotiationInfo ( _
    application As MCapplication, _
    service As String _
) As MCnegotiationInfo
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete; use method in MCresultContext class instead")]
virtual MCnegotiationInfo^ getNegotiationInfo(
    MCapplication^ application,
    String^ service
)

Parameters

application
Type: Mergecom..::..MCapplication
An MCapplication object identifying an application entity.
service
Type: System..::..String
The name of a service contained in this list.

Return Value

The MCnegotiationInfo object identifying the extended negotiation information set for this context's service for the application or null if no extended negotiation info has been set or if the info was cleared for the application.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCproposedContextList Class
MCproposedContextList Members


getObject Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..getObject Method
MCproposedContextList Class See Also Send Feedback
Gets the context list for the specified name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCproposedContextList getObject(
    string contextListName
)
Visual Basic
Public Shared Function getObject ( _
    contextListName As String _
) As MCproposedContextList
Visual C++
public:
static MCproposedContextList^ getObject(
    String^ contextListName
)

Parameters

contextListName
Type: System..::..String
The name which uniquely identifies a context list.

Return Value

An MCproposedContextList object, or null if not found.

Remarks

MCproposedContextList objects are used to identify those services a DICOM association partner is willing to perform. The MCproposedContextList object was previously created by calling new MCproposedContextList or it is automatically created for proposed contexts configured in a service list section of the app configuration file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCproposedContextList Class
MCproposedContextList Members


setNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..setNegotiationInfo Method
MCproposedContextList Class See Also Send Feedback
Sets extended user negotiation information for a specific service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")]
public virtual bool setNegotiationInfo(
    MCapplication application,
    string service,
    MCnegotiationInfo infoObject
)
Visual Basic
<ObsoleteAttribute("This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")> _
Public Overridable Function setNegotiationInfo ( _
    application As MCapplication, _
    service As String, _
    infoObject As MCnegotiationInfo _
) As Boolean
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete; use MCproposedContext constructor to set extended negotiation info instead")]
virtual bool setNegotiationInfo(
    MCapplication^ application,
    String^ service,
    MCnegotiationInfo^ infoObject
)

Parameters

application
Type: Mergecom..::..MCapplication
An MCapplication object identifying an application entity.
service
Type: System..::..String
The name of the service for which the extended negotiation information should be set.
infoObject
Type: Mergecom..::..MCnegotiationInfo
A MCnegotiationInfo instance containing the extended negotiation info.

Return Value

false if the service was not in the list; otherwise true.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCproposedContextList Class
MCproposedContextList Members


toArray Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..toArray Method
MCproposedContextList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | toArray()()()() | Returns the context list as an array of MCproposedContext objects.
Public method | toArray(Int32) | Returns the context list as an array of MCproposedContext objects.

See Also

MCproposedContextList Class
MCproposedContextList Members


toArray Method

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..toArray Method
MCproposedContextList Class See Also Send Feedback
Returns the context list as an array of MCproposedContext objects.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCproposedContext[] toArray()
Visual Basic
Public Overridable Function toArray As MCproposedContext()
Visual C++
public:
virtual array<MCproposedContext^>^ toArray()

Return Value

The array of MCproposedContext objects.

See Also

MCproposedContextList Class
MCproposedContextList Members
toArray Overload


toArray Method (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..toArray Method (Int32)
MCproposedContextList Class See Also Send Feedback
Returns the context list as an array of MCproposedContext objects.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCproposedContext[] toArray(
    int additionalElements
)
Visual Basic
Public Overridable Function toArray ( _
    additionalElements As Integer _
) As MCproposedContext()
Visual C++
public:
virtual array<MCproposedContext^>^ toArray(
    int additionalElements
)

Parameters

additionalElements
Type: System..::..Int32
The number of null elements to be added to the returned array.

Return Value

The array of MCproposedContext objects.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The number of elements was negative.

See Also

MCproposedContextList Class
MCproposedContextList Members
toArray Overload


MCproposedContextList Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList Properties
MCproposedContextList Class See Also Send Feedback

The MCproposedContextList type exposes the following members.

Properties

 | Name | Description
Public property | ListName | Gets the name of this context collection.
Public property | MaxOperationsInvoked | Gets the maximum number of asynchronous operations invoked.
Public property | MaxOperationsPerformed | Gets the maximum number of asynchronous operations performed.
Public property | Size | Returns the number of contexts in this list.

See Also

MCproposedContextList Class


ListName Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..ListName Property
MCproposedContextList Class See Also Send Feedback
Gets the name of this context collection.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ListName { get; }
Visual Basic
Public Overridable ReadOnly Property ListName As String
    Get
Visual C++
public:
virtual property String^ ListName {
    String^ get ();
}

Field Value

A name representing this MCproposedContextList.

See Also

MCproposedContextList Class
MCproposedContextList Members


MaxOperationsInvoked Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..MaxOperationsInvoked Property
MCproposedContextList Class See Also Send Feedback
Gets the maximum number of asynchronous operations invoked.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MaxOperationsInvoked { get; }
Visual Basic
Public Overridable ReadOnly Property MaxOperationsInvoked As UShort
    Get
Visual C++
public:
virtual property unsigned short MaxOperationsInvoked {
    unsigned short get ();
}

See Also

MCproposedContextList Class
MCproposedContextList Members


MaxOperationsPerformed Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..MaxOperationsPerformed Property
MCproposedContextList Class See Also Send Feedback
Gets the maximum number of asynchronous operations performed.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MaxOperationsPerformed { get; }
Visual Basic
Public Overridable ReadOnly Property MaxOperationsPerformed As UShort
    Get
Visual C++
public:
virtual property unsigned short MaxOperationsPerformed {
    unsigned short get ();
}

See Also

MCproposedContextList Class
MCproposedContextList Members


Size Property

[image]

Merge DICOM .NET/C# Toolkit
MCproposedContextList..::..Size Property
MCproposedContextList Class See Also Send Feedback
Returns the number of contexts in this list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

Field Value

The number of contexts in this proposed context list.

See Also

MCproposedContextList Class
MCproposedContextList Members


MCqueryRetrieveNegotiation Class

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Class
Members See Also Send Feedback
Contains Query/Retrieve Service Class Extended Negotiation data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCqueryRetrieveNegotiation : MCnegotiationInfo
Visual Basic
Public Class MCqueryRetrieveNegotiation _
    Inherits MCnegotiationInfo
Visual C++
public ref class MCqueryRetrieveNegotiation : public MCnegotiationInfo

Remarks

The Query/Retrieve Service can negotiated whether or not relational queries are supported.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCnegotiationInfo
Mergecom..::..MCqueryRetrieveNegotiation

See Also

MCqueryRetrieveNegotiation Members


MCqueryRetrieveNegotiation Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Members
MCqueryRetrieveNegotiation Class Constructors Methods See Also Send Feedback

The MCqueryRetrieveNegotiation type exposes the following members.

Constructors

 | Name | Description
Public method | MCqueryRetrieveNegotiation(Boolean) | Initializes a new instance of this class.
Public method | MCqueryRetrieveNegotiation(Boolean, Boolean, Boolean) | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | datetimeCombinedMatchingSupported | Specifies the relational query support.
Public method | decode | Determines whether relational queries are supported by examining the extended negotiation information buffer provided. (Overrides MCnegotiationInfo..::..decode(array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | fuzzySemanticsMatchingSupported | Specifies the relational query support.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | relationalSupported | Specifies the relational query support.
Public method | toByteArray | Constructs a DICOM extended negotiation information buffer that indicates whether or not relational queries are supported. (Overrides MCnegotiationInfo..::..toByteArray()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCqueryRetrieveNegotiation Class


MCqueryRetrieveNegotiation Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Constructor
MCqueryRetrieveNegotiation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCqueryRetrieveNegotiation(Boolean) | Initializes a new instance of this class.
Public method | MCqueryRetrieveNegotiation(Boolean, Boolean, Boolean) | Initializes a new instance of this class.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


MCqueryRetrieveNegotiation Constructor (Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Constructor (Boolean)
MCqueryRetrieveNegotiation Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCqueryRetrieveNegotiation(
    bool relationalSupported
)
Visual Basic
Public Sub New ( _
    relationalSupported As Boolean _
)
Visual C++
public:
MCqueryRetrieveNegotiation(
    bool relationalSupported
)

Parameters

relationalSupported
Type: System..::..Boolean
true if relational queries|retrievals are supported; otherwise false.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members
MCqueryRetrieveNegotiation Overload


MCqueryRetrieveNegotiation Constructor (Boolean, Boolean, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Constructor (Boolean, Boolean, Boolean)
MCqueryRetrieveNegotiation Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCqueryRetrieveNegotiation(
    bool relationalSupported,
    bool datetimeCombinedMatchingSupported,
    bool fuzzySemanticsMatchingSupported
)
Visual Basic
Public Sub New ( _
    relationalSupported As Boolean, _
    datetimeCombinedMatchingSupported As Boolean, _
    fuzzySemanticsMatchingSupported As Boolean _
)
Visual C++
public:
MCqueryRetrieveNegotiation(
    bool relationalSupported,
    bool datetimeCombinedMatchingSupported,
    bool fuzzySemanticsMatchingSupported
)

Parameters

relationalSupported
Type: System..::..Boolean
true if relational queries|retrievals are supported; otherwise false.
datetimeCombinedMatchingSupported
Type: System..::..Boolean
true if Date-time combined matching is supported; otherwise false.
fuzzySemanticsMatchingSupported
Type: System..::..Boolean
true if fuzzy semantic matching of person is supported; otherwise false.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members
MCqueryRetrieveNegotiation Overload


MCqueryRetrieveNegotiation Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation Methods
MCqueryRetrieveNegotiation Class See Also Send Feedback

The MCqueryRetrieveNegotiation type exposes the following members.

Methods

 | Name | Description
Public method | datetimeCombinedMatchingSupported | Specifies the relational query support.
Public method | decode | Determines whether relational queries are supported by examining the extended negotiation information buffer provided. (Overrides MCnegotiationInfo..::..decode(array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | fuzzySemanticsMatchingSupported | Specifies the relational query support.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | relationalSupported | Specifies the relational query support.
Public method | toByteArray | Constructs a DICOM extended negotiation information buffer that indicates whether or not relational queries are supported. (Overrides MCnegotiationInfo..::..toByteArray()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCqueryRetrieveNegotiation Class


datetimeCombinedMatchingSupported Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation..::..datetimeCombinedMatchingSupported Method
MCqueryRetrieveNegotiation Class See Also Send Feedback
Specifies the relational query support.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool datetimeCombinedMatchingSupported()
Visual Basic
Public Overridable Function datetimeCombinedMatchingSupported As Boolean
Visual C++
public:
virtual bool datetimeCombinedMatchingSupported()

Return Value

true if Date-time combined matching is supported; otherwise false.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


decode Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation..::..decode Method
MCqueryRetrieveNegotiation Class See Also Send Feedback
Determines whether relational queries are supported by examining the extended negotiation information buffer provided.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void decode(
    byte[] byteArray
)
Visual Basic
Public Overrides Sub decode ( _
    byteArray As Byte() _
)
Visual C++
public:
virtual void decode(
    array<unsigned char>^ byteArray
) override

Parameters

byteArray
Type: array<System..::..Byte>[]()[][]
The one byte buffer as defined by the standard.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


fuzzySemanticsMatchingSupported Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation..::..fuzzySemanticsMatchingSupported Method
MCqueryRetrieveNegotiation Class See Also Send Feedback
Specifies the relational query support.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool fuzzySemanticsMatchingSupported()
Visual Basic
Public Overridable Function fuzzySemanticsMatchingSupported As Boolean
Visual C++
public:
virtual bool fuzzySemanticsMatchingSupported()

Return Value

true if fuzzy semantic matching of person is supported; otherwise false.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


relationalSupported Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation..::..relationalSupported Method
MCqueryRetrieveNegotiation Class See Also Send Feedback
Specifies the relational query support.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool relationalSupported()
Visual Basic
Public Overridable Function relationalSupported As Boolean
Visual C++
public:
virtual bool relationalSupported()

Return Value

true if relational queries are supported; otherwise false.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


toByteArray Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveNegotiation..::..toByteArray Method
MCqueryRetrieveNegotiation Class See Also Send Feedback
Constructs a DICOM extended negotiation information buffer that indicates whether or not relational queries are supported.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override byte[] toByteArray()
Visual Basic
Public Overrides Function toByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ toByteArray() override

Return Value

A one byte buffer containing the relational support setting.

See Also

MCqueryRetrieveNegotiation Class
MCqueryRetrieveNegotiation Members


MCqueryRetrieveService Class

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Class
Members See Also Send Feedback
Represents a DICOM Query Retrieve Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCqueryRetrieveService : MCdimseService
Visual Basic
Public Class MCqueryRetrieveService _
    Inherits MCdimseService
Visual C++
public ref class MCqueryRetrieveService : public MCdimseService

Remarks

The Query/Retrieve Service Class defines an application-level class-of-service which facilitates the simple management of composite object instances. The types of queries which are allowed are not complex. This Service Class is not intended to provide a comprehensive generalized database query mechanism such as SQL. Instead, the Query/Retrieve Service Class is focused towards basic composite object instance information queries using a small set of common Key Attributes.

In addition, the Query/Retrieve Service Class provides the ability to retrieve/transfer a well-identified set of composite object instances. The retrieve/transfer capability allows a DICOM Application Entity(AE) to retrieve composite object instances from a remote DICOM AE or request the remote DICOM AE to initiate a transfer of composite object instances to another DICOM AE.

Refer to Part 4 of the DICOM standard for more detailed information.

This class provides methods to support the following standard SOP Classes:

  • Patient Root Query/Retrieve Information Model - FIND
  • Patient Root Query/Retrieve Information Model - MOVE
  • Patient Root Query/Retrieve Information Model - GET
  • Study Root Query/Retrieve Information Model - FIND
  • Study Root Query/Retrieve Information Model - MOVE
  • Study Root Query/Retrieve Information Model - GET
  • Patient/Study Only Query/Retrieve Information Model - FIND
  • Patient/Study Only Query/Retrieve Information Model - MOVE
  • Patient/Study Only Query/Retrieve Information Model - GET

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCqueryRetrieveService

See Also

MCqueryRetrieveService Members


MCqueryRetrieveService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Members
MCqueryRetrieveService Class Constructors Methods Fields Properties See Also Send Feedback

The MCqueryRetrieveService type exposes the following members.

Constructors

 | Name | Description
Public method | MCqueryRetrieveService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelRequest | Sends a C-CANCEL DIMSE message to the network peer.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendFindRequest(MCdataSet, String) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing he identifier to send and the affected SOP Class UID.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendGetRequest(MCdataSet) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send.
Public method | sendGetRequest(MCdataSet, String) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and the affected SOP Class UID to use.
Public method | sendGetRequest(MCdataSet, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendGetRequest(MCdataSet, String, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendMoveDestinationUnknownResponse | Sends a Response message to a C-MOVE request with a status of MCdimseService.C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN.
Public method | sendMoveRequest(MCdataSet, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendMoveRequest(MCdataSet, String, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and the affected SOP Class UID to use.
Public method | sendMoveRequest(MCdataSet, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and message priority.
Public method | sendMoveRequest(MCdataSet, String, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier, the affected SOP Class UID and message priority.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, MCdataSet, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of success.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of success.
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCqueryRetrieveService Class


MCqueryRetrieveService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Constructor
MCqueryRetrieveService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCqueryRetrieveService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCqueryRetrieveService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


MCqueryRetrieveService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Fields
MCqueryRetrieveService Class See Also Send Feedback

The MCqueryRetrieveService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCqueryRetrieveService Class


MCqueryRetrieveService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Methods
MCqueryRetrieveService Class See Also Send Feedback

The MCqueryRetrieveService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelRequest | Sends a C-CANCEL DIMSE message to the network peer.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendFindRequest(MCdataSet, String) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing he identifier to send and the affected SOP Class UID.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendGetRequest(MCdataSet) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send.
Public method | sendGetRequest(MCdataSet, String) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and the affected SOP Class UID to use.
Public method | sendGetRequest(MCdataSet, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendGetRequest(MCdataSet, String, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendMoveDestinationUnknownResponse | Sends a Response message to a C-MOVE request with a status of MCdimseService.C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN.
Public method | sendMoveRequest(MCdataSet, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendMoveRequest(MCdataSet, String, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and the affected SOP Class UID to use.
Public method | sendMoveRequest(MCdataSet, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and message priority.
Public method | sendMoveRequest(MCdataSet, String, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier, the affected SOP Class UID and message priority.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, MCdataSet, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of success.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of success.
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCqueryRetrieveService Class


sendCancelRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendCancelRequest Method
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-CANCEL DIMSE message to the network peer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCancelRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Function sendCancelRequest ( _
    requestMsg As MCdimseMessage _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCancelRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
Message used to send the original operation request.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

This method is used to cancel a pending C-FIND, C-GET or C-MOVE operation.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The request message argument was invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is unacceptable for the association.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no request message outstanding.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendCompletedWithFailuresResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendCompletedWithFailuresResponse Method
MCqueryRetrieveService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.
Public method | sendCompletedWithFailuresResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendCompletedWithFailuresResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendCompletedWithFailuresResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCompletedWithFailuresResponse(
    MCdimseMessage requestMsg,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendCompletedWithFailuresResponse ( _
    requestMsg As MCdimseMessage, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendCompletedWithFailuresResponse(
    MCdimseMessage^ requestMsg,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
completedSubOperations
Type: System..::..UInt16
completed sub-operation count
failedSubOperations
Type: System..::..UInt16
failed sub-operation count
warningSubOperations
Type: System..::..UInt16
warning sub-operation count

Remarks

This method sends a response message indicating that the C-GET or C-MOVE operation contained in requestMsg completed, but one or more failures were encountered.

Each of the last three arguments are optional, marked by a value of MaxValue. If the value is not MaxValue, completedSubOperations will be encoded in attribute (0000,1021), failedSubOperations will be encoded in attribute (0000,1022), and warningSubOperations will be encoded in attribute (0000,1023).

The status attribute (0000,0900) will be set to 0xB000 (completed with failures).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | - This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendCompletedWithFailuresResponse Overload


sendCompletedWithFailuresResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendCompletedWithFailuresResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of MCdimseService.C_MOVE_WARNING_ONE_OR_MORE_FAILURES.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCompletedWithFailuresResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendCompletedWithFailuresResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendCompletedWithFailuresResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
Contains Failed SOP Instance UID List.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This method sends a response message indicating that the C-GET or C-MOVE operation contained in requestMsg completed, but one or more failures were encountered.

Each of the last three arguments are optional, marked by a value of MaxValue. If the value is not MaxValue, completedSubOperations will be encoded in attribute (0000,1021), failedSubOperations will be encoded in attribute (0000,1022), and warningSubOperations will be encoded in attribute (0000,1023).

This form of the call must be used when the C-STORE sub-operation for one or more SOP instances failed. In that case, the identifier must contain the Failed SOP Instance UID List (0008,0048) attribute that specifies a list of UIDs of the C-STORE sub-operation SOP Instances for which the C-GET or C-MOVE operation has failed. If there were no sub-operation failures, there is no need for an identifier data set and the other form of the method can be used.

The status attribute (0000,0900) will be set to 0xB000 (completed with failures).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendCompletedWithFailuresResponse Overload


sendFindRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendFindRequest Method
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner.

Overload List

 | Name | Description
Public method | sendFindRequest(MCdataSet) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendFindRequest(MCdataSet, String) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing he identifier to send and the affected SOP Class UID.
Public method | sendFindRequest(MCdataSet, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendFindRequest(MCdataSet, String, UInt16) | Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendFindRequest Method (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendFindRequest Method (MCdataSet)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

When using this form of the method, the message priority will be medium, and the affected SOP Class UID will be taken from the message's presentation context.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCnoAttributesException | The data set has been disposed.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendFindRequest Method (MCdataSet, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner, providing he identifier to send and the affected SOP Class UID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    string affectedSopClassUID
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

If the second argument is null or empty the affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The message priority will be medium.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-FIND-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendFindRequest Method (MCdataSet, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    ushort priority
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-FIND-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendFindRequest Overload


sendFindRequest Method (MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendFindRequest Method (MCdataSet, String, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-FIND-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendFindRequest(
    MCdataSet identifier,
    string affectedSopClassUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendFindRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendFindRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association if the affectedClassUID parameter is null or an empty string.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | his method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-FIND-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendFindRequest Overload


sendGetRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendGetRequest Method
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-GET-RQ DIMSE request message to the association partner.

Overload List

 | Name | Description
Public method | sendGetRequest(MCdataSet) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send.
Public method | sendGetRequest(MCdataSet, String) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and the affected SOP Class UID to use.
Public method | sendGetRequest(MCdataSet, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.
Public method | sendGetRequest(MCdataSet, String, UInt16) | Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendGetRequest Method (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendGetRequest Method (MCdataSet)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetRequest(
    MCdataSet identifier
)
Visual Basic
Public Overridable Function sendGetRequest ( _
    identifier As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetRequest(
    MCdataSet^ identifier
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

When using this form of the method, the message priority will be medium, and the affected SOP Class UID will be taken from the message's presentation context.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-GET-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendGetRequest Overload


sendGetRequest Method (MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendGetRequest Method (MCdataSet, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and the affected SOP Class UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetRequest(
    MCdataSet identifier,
    string affectedSopClassUID
)
Visual Basic
Public Overridable Function sendGetRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The message priority defaults to medium.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-GET-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendGetRequest Overload


sendGetRequest Method (MCdataSet, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendGetRequest Method (MCdataSet, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetRequest(
    MCdataSet identifier,
    ushort priority
)
Visual Basic
Public Overridable Function sendGetRequest ( _
    identifier As MCdataSet, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetRequest(
    MCdataSet^ identifier,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-GET-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendGetRequest Overload


sendGetRequest Method (MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendGetRequest Method (MCdataSet, String, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-GET-RQ DIMSE request message to the association partner, providing the identifier to send, the affected SOP Class UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetRequest(
    MCdataSet identifier,
    string affectedSopClassUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendGetRequest ( _
    identifier As MCdataSet, _
    affectedSopClassUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetRequest(
    MCdataSet^ identifier,
    String^ affectedSopClassUID,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association if the affectedClassUID parameter is null or an empty string.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | The MCdataSet being set is not a C-GET-RQ message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendGetRequest Overload


sendMoveDestinationUnknownResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveDestinationUnknownResponse Method
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message to a C-MOVE request with a status of MCdimseService.C_MOVE_FAILURE_REFUSED_DEST_UNKNOWN.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendMoveDestinationUnknownResponse(
    MCdimseMessage requestMsg,
    string errorComment
)
Visual Basic
Public Overridable Sub sendMoveDestinationUnknownResponse ( _
    requestMsg As MCdimseMessage, _
    errorComment As String _
)
Visual C++
public:
virtual void sendMoveDestinationUnknownResponse(
    MCdimseMessage^ requestMsg,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
errorComment
Type: System..::..String
The error description.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The message or the command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendMoveRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveRequest Method
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-MOVE-RQ DIMSE request message to the association partner.

Overload List

 | Name | Description
Public method | sendMoveRequest(MCdataSet, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier.
Public method | sendMoveRequest(MCdataSet, String, String) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and the affected SOP Class UID to use.
Public method | sendMoveRequest(MCdataSet, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and message priority.
Public method | sendMoveRequest(MCdataSet, String, String, UInt16) | Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier, the affected SOP Class UID and message priority.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendMoveRequest Method (MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveRequest Method (MCdataSet, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMoveRequest(
    MCdataSet identifier,
    string moveDestination
)
Visual Basic
Public Overridable Function sendMoveRequest ( _
    identifier As MCdataSet, _
    moveDestination As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMoveRequest(
    MCdataSet^ identifier,
    String^ moveDestination
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
moveDestination
Type: System..::..String
The DICOM AE that will perform the C-STORE sub-operations.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

When using this form of the method, the message priority will be medium, and the affected SOP Class UID will be taken from the message's presentation context.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier or the command associated with the identifier was invalid.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendMoveRequest Overload


sendMoveRequest Method (MCdataSet, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveRequest Method (MCdataSet, String, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and the affected SOP Class UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMoveRequest(
    MCdataSet identifier,
    string moveDestination,
    string affectedSopClassUID
)
Visual Basic
Public Overridable Function sendMoveRequest ( _
    identifier As MCdataSet, _
    moveDestination As String, _
    affectedSopClassUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMoveRequest(
    MCdataSet^ identifier,
    String^ moveDestination,
    String^ affectedSopClassUID
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
moveDestination
Type: System..::..String
The DICOM AE that will perform the C-STORE sub-operations.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The message priority defaults to MCdimseService.MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier or the command associated with the identifier was invalid.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendMoveRequest Overload


sendMoveRequest Method (MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveRequest Method (MCdataSet, String, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMoveRequest(
    MCdataSet identifier,
    string moveDestination,
    ushort priority
)
Visual Basic
Public Overridable Function sendMoveRequest ( _
    identifier As MCdataSet, _
    moveDestination As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMoveRequest(
    MCdataSet^ identifier,
    String^ moveDestination,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
moveDestination
Type: System..::..String
The DICOM AE that will perform the C-STORE sub-operations.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier or the command associated with the identifier was invalid.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendMoveRequest Overload


sendMoveRequest Method (MCdataSet, String, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendMoveRequest Method (MCdataSet, String, String, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a C-MOVE-RQ DIMSE request message to the association partner, providing the identifier, the affected SOP Class UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMoveRequest(
    MCdataSet identifier,
    string moveDestination,
    string affectedSopClassUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendMoveRequest ( _
    identifier As MCdataSet, _
    moveDestination As String, _
    affectedSopClassUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMoveRequest(
    MCdataSet^ identifier,
    String^ moveDestination,
    String^ affectedSopClassUID,
    unsigned short priority
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
moveDestination
Type: System..::..String
The DICOM AE that will perform the C-STORE sub-operations.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

An MCdimseMessage encapsulating the sent request message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association if the affectedClassUID parameter is null or an empty string.

The message priority is provided by the priority parameter and it should be one of the priority values defined in the MCdimseService class:

  • LOW_PRIORITY_MESSAGE
  • MEDIUM_PRIORITY_MESSAGE
  • HIGH_PRIORITY_MESSAGE

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier or the command associated with the identifier was invalid.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendMoveRequest Overload


sendProcessingFailureResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendProcessingFailureResponse Method
MCqueryRetrieveService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendProcessingFailureResponse Method (MCdimseMessage, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendProcessingFailureResponse Method (MCdimseMessage, array<UInt32>[]()[][], String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
The elements involved with the error.
errorComment
Type: System..::..String
The error description.

Remarks

This response may be sent in response to: C-FIND, C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendProcessingFailureResponse Overload


sendProcessingFailureResponse Method (MCdimseMessage, MCdataSet, UInt32[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendProcessingFailureResponse Method (MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE UNABLE TO PROCESS".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
A data set containing the Failed SOP Instance UID List.
offendingElements
Type: array<System..::..UInt32>[]()[][]
Elements involved with the error.
errorComment
Type: System..::..String
The error description.

Remarks

This response may be sent in response to: C-FIND, C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendProcessingFailureResponse Overload


sendRefusedCantCalculateResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantCalculateResponse Method
MCqueryRetrieveService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".
Public method | sendRefusedCantCalculateResponse(MCdimseMessage, MCdataSet, String) | Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendRefusedCantCalculateResponse Method (MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantCalculateResponse Method (MCdimseMessage, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRefusedCantCalculateResponse(
    MCdimseMessage requestMsg,
    string errorComment
)
Visual Basic
Public Overridable Sub sendRefusedCantCalculateResponse ( _
    requestMsg As MCdimseMessage, _
    errorComment As String _
)
Visual C++
public:
virtual void sendRefusedCantCalculateResponse(
    MCdimseMessage^ requestMsg,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
errorComment
Type: System..::..String
The error description.

Remarks

This response may be sent in response to: C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendRefusedCantCalculateResponse Overload


sendRefusedCantCalculateResponse Method (MCdimseMessage, MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantCalculateResponse Method (MCdimseMessage, MCdataSet, String)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE REFUSED CANT CALCULATE".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRefusedCantCalculateResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    string errorComment
)
Visual Basic
Public Overridable Sub sendRefusedCantCalculateResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    errorComment As String _
)
Visual C++
public:
virtual void sendRefusedCantCalculateResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the response data.
errorComment
Type: System..::..String
The error description.

Remarks

This response may be sent in response to: C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendRefusedCantCalculateResponse Overload


sendRefusedCantPerformSuboperationsResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantPerformSuboperationsResponse Method
MCqueryRetrieveService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".
Public method | sendRefusedCantPerformSuboperationsResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16) | Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendRefusedCantPerformSuboperationsResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantPerformSuboperationsResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRefusedCantPerformSuboperationsResponse(
    MCdimseMessage requestMsg,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendRefusedCantPerformSuboperationsResponse ( _
    requestMsg As MCdimseMessage, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendRefusedCantPerformSuboperationsResponse(
    MCdimseMessage^ requestMsg,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This response may be sent in response to: C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendRefusedCantPerformSuboperationsResponse Overload


sendRefusedCantPerformSuboperationsResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendRefusedCantPerformSuboperationsResponse Method (MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of "FAILURE REFUSED CANT PERFORM".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendRefusedCantPerformSuboperationsResponse(
    MCdimseMessage requestMsg,
    MCdataSet identifier,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendRefusedCantPerformSuboperationsResponse ( _
    requestMsg As MCdimseMessage, _
    identifier As MCdataSet, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendRefusedCantPerformSuboperationsResponse(
    MCdimseMessage^ requestMsg,
    MCdataSet^ identifier,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
identifier
Type: Mergecom..::..MCdataSet
The data set containing the Failed SOP Instance UID List.
completedSubOperations
Type: System..::..UInt16
completed sub-operation count
failedSubOperations
Type: System..::..UInt16
failed sub-operation count
warningSubOperations
Type: System..::..UInt16
warning sub-operation count

Remarks

This response may be sent in response to: C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | - This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendRefusedCantPerformSuboperationsResponse Overload


sendSuccessResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendSuccessResponse Method
MCqueryRetrieveService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSuccessResponse(MCdimseMessage) | Sends a Response message with a status of success.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, UInt16, UInt16, UInt16) | Sends a Response message with a status of success.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members


sendSuccessResponse Method (MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendSuccessResponse Method (MCdimseMessage)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of success.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendSuccessResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.

Remarks

This response may be sent in response to: C-FIND, C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendSuccessResponse Overload


sendSuccessResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService..::..sendSuccessResponse Method (MCdimseMessage, UInt16, UInt16, UInt16)
MCqueryRetrieveService Class See Also Send Feedback
Sends a Response message with a status of success.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    MCdimseMessage requestMsg,
    ushort completedSubOperations,
    ushort failedSubOperations,
    ushort warningSubOperations
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    requestMsg As MCdimseMessage, _
    completedSubOperations As UShort, _
    failedSubOperations As UShort, _
    warningSubOperations As UShort _
)
Visual C++
public:
virtual void sendSuccessResponse(
    MCdimseMessage^ requestMsg,
    unsigned short completedSubOperations,
    unsigned short failedSubOperations,
    unsigned short warningSubOperations
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The request message being responded to.
completedSubOperations
Type: System..::..UInt16
Completed sub-operation count.
failedSubOperations
Type: System..::..UInt16
Failed sub-operation count.
warningSubOperations
Type: System..::..UInt16
Warning sub-operation count.

Remarks

This response may be sent in response to: C-FIND, C-GET or C-MOVE requests.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid.

See Also

MCqueryRetrieveService Class
MCqueryRetrieveService Members
sendSuccessResponse Overload


MCqueryRetrieveService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueryRetrieveService Properties
MCqueryRetrieveService Class See Also Send Feedback

The MCqueryRetrieveService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCqueryRetrieveService Class


MCqueueManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Class
Members See Also Send Feedback
Represents a DICOM Queue Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCqueueManagementService : MCdimseService
Visual Basic
Public Class MCqueueManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCqueueManagementService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Class:
  • Print Queue Management SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCqueueManagementService

See Also

MCqueueManagementService Members


MCqueueManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Members
MCqueueManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCqueueManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCqueueManagementService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCqueueManagementService Class


MCqueueManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Constructor
MCqueueManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCqueueManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCqueueManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCqueueManagementService Class
MCqueueManagementService Members


MCqueueManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Fields
MCqueueManagementService Class See Also Send Feedback

The MCqueueManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCqueueManagementService Class


MCqueueManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Methods
MCqueueManagementService Class See Also Send Feedback

The MCqueueManagementService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCqueueManagementService Class


MCqueueManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCqueueManagementService Properties
MCqueueManagementService Class See Also Send Feedback

The MCqueueManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCqueueManagementService Class


MCReadError Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCReadError Enumeration
See Also Send Feedback
Define the status of a "Read" operation in an association

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCReadError
Visual Basic
Public Enumeration MCReadError
Visual C++
public enum class MCReadError

Members

Member name | Value | Description
SUCCESS | 0 | Operation succeeds
ASSOC_WAS_CLOSED | 1 | Association was released
INACTIVITY_TIMEOUT | 2 | Network inactivity timeout
INVALID_MESSAGE_RCVD | 3 | Invalid message received
CONFIG_INFO_ERROR | 4 | Configuration information missing
NETWORK_SHUTDOWN | 5 | Network Unexpectedly Shutdown
ASSOC_WAS_ABORTED | 6 | Association was aborted
INVALID_STATE_ERROR | 7 | Read may not be called now
TIMED_OUT | 8 | Read timed out
OPERATION_NOT_ALLOWED | 9 | Message must be read to the end before issuing a new read. Continuing reading requires that a previous readToTag or continueReadToTag function was called.
UNKNOWN_ERROR | 10 | Unknown error

See Also


MCrefSopInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Class
Members See Also Send Feedback
Represents a Referenced SOP Sequence item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCrefSopInfo
Visual Basic
Public Class MCrefSopInfo
Visual C++
public ref class MCrefSopInfo

Remarks

This class wraps the five values that describe a Referenced SOP Sequence item:

  • refSopClassUid - retrieved from tag (0008,1150)
  • refSopInstanceUid - retrieved from tag (0008,1155)
  • fileSetUid - retrieved from tag (0088,0140)
  • fileSetId - retrieved from tag (0088,0130)
  • retrieveAEtitle - retrieved from tag (0008,0054)

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCrefSopInfo

See Also

MCrefSopInfo Members


MCrefSopInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Members
MCrefSopInfo Class Constructors Methods Properties See Also Send Feedback

The MCrefSopInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MCrefSopInfo(MCattributeSet) | Initializes a new instance of this class based on values from an existing sequence item.
Public method | MCrefSopInfo(String, String) | Initializes a new instance of this class based on SOP class/instance uids.
Public method | MCrefSopInfo(String, String, String) | Initializes a new instance of this class based on SOP class/instance uids and Retrieve AE Title.
Public method | MCrefSopInfo(String, String, String, String) | Initializes a new instance of this class based on SOP class/instance uids and file set properties.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileSetId | The human readable file set ID identifying the media storage from which the referenced object may be retrieved.
Public property | FileSetUid | The file set UID identifying the media storage from which the referenced object may be retrieved.
Public property | RetrieveAeTitle | The Application Entity Title of the DICOM node from which the referenced object may be retrieved.
Public property | SopClassUid | The UID identifying the Referenced SOP Class.
Public property | SopInstanceUid | The UID identifying the Referenced SOP Instance.

See Also

MCrefSopInfo Class


MCrefSopInfo Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Constructor
MCrefSopInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCrefSopInfo(MCattributeSet) | Initializes a new instance of this class based on values from an existing sequence item.
Public method | MCrefSopInfo(String, String) | Initializes a new instance of this class based on SOP class/instance uids.
Public method | MCrefSopInfo(String, String, String) | Initializes a new instance of this class based on SOP class/instance uids and Retrieve AE Title.
Public method | MCrefSopInfo(String, String, String, String) | Initializes a new instance of this class based on SOP class/instance uids and file set properties.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


MCrefSopInfo Constructor (MCattributeSet)

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Constructor (MCattributeSet)
MCrefSopInfo Class See Also Send Feedback
Initializes a new instance of this class based on values from an existing sequence item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefSopInfo(
    MCattributeSet item
)
Visual Basic
Public Sub New ( _
    item As MCattributeSet _
)
Visual C++
public:
MCrefSopInfo(
    MCattributeSet^ item
)

Parameters

item
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing values for this instance.

Remarks

Initializes the five fields of this class with values from a DICOM attribute set, usually a Referenced Image Sequence (SQ) item. Note that the values will be null if their values were not encoded in the specified attribute set, or if they were encoded as null values.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members
MCrefSopInfo Overload


MCrefSopInfo Constructor (String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Constructor (String, String)
MCrefSopInfo Class See Also Send Feedback
Initializes a new instance of this class based on SOP class/instance uids.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefSopInfo(
    string refSopClassUid,
    string refSopInstanceUid
)
Visual Basic
Public Sub New ( _
    refSopClassUid As String, _
    refSopInstanceUid As String _
)
Visual C++
public:
MCrefSopInfo(
    String^ refSopClassUid,
    String^ refSopInstanceUid
)

Parameters

refSopClassUid
Type: System..::..String
The non-null SOP Class UID.
refSopInstanceUid
Type: System..::..String
The non-null SOP Instance UID.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members
MCrefSopInfo Overload


MCrefSopInfo Constructor (String, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Constructor (String, String, String)
MCrefSopInfo Class See Also Send Feedback
Initializes a new instance of this class based on SOP class/instance uids and Retrieve AE Title.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefSopInfo(
    string refSopClassUid,
    string refSopInstanceUid,
    string retrieveAEtitle
)
Visual Basic
Public Sub New ( _
    refSopClassUid As String, _
    refSopInstanceUid As String, _
    retrieveAEtitle As String _
)
Visual C++
public:
MCrefSopInfo(
    String^ refSopClassUid,
    String^ refSopInstanceUid,
    String^ retrieveAEtitle
)

Parameters

refSopClassUid
Type: System..::..String
The non-null SOP Class UID.
refSopInstanceUid
Type: System..::..String
The non-null SOP Instance UID.
retrieveAEtitle
Type: System..::..String
The Retrieve AE Title.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP Class UID or SOP Instance UID was null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members
MCrefSopInfo Overload


MCrefSopInfo Constructor (String, String, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Constructor (String, String, String, String)
MCrefSopInfo Class See Also Send Feedback
Initializes a new instance of this class based on SOP class/instance uids and file set properties.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefSopInfo(
    string refSopClassUid,
    string refSopInstanceUid,
    string fileSetUid,
    string fileSetId
)
Visual Basic
Public Sub New ( _
    refSopClassUid As String, _
    refSopInstanceUid As String, _
    fileSetUid As String, _
    fileSetId As String _
)
Visual C++
public:
MCrefSopInfo(
    String^ refSopClassUid,
    String^ refSopInstanceUid,
    String^ fileSetUid,
    String^ fileSetId
)

Parameters

refSopClassUid
Type: System..::..String
The non-null SOP Class UID.
refSopInstanceUid
Type: System..::..String
The non-null SOP Instance UID.
fileSetUid
Type: System..::..String
The file set UID.
fileSetId
Type: System..::..String
The file set ID.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The SOP Class UID or SOP Instance UID was null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members
MCrefSopInfo Overload


MCrefSopInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Methods
MCrefSopInfo Class See Also Send Feedback

The MCrefSopInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrefSopInfo Class


MCrefSopInfo Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo Properties
MCrefSopInfo Class See Also Send Feedback

The MCrefSopInfo type exposes the following members.

Properties

 | Name | Description
Public property | FileSetId | The human readable file set ID identifying the media storage from which the referenced object may be retrieved.
Public property | FileSetUid | The file set UID identifying the media storage from which the referenced object may be retrieved.
Public property | RetrieveAeTitle | The Application Entity Title of the DICOM node from which the referenced object may be retrieved.
Public property | SopClassUid | The UID identifying the Referenced SOP Class.
Public property | SopInstanceUid | The UID identifying the Referenced SOP Instance.

See Also

MCrefSopInfo Class


FileSetId Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo..::..FileSetId Property
MCrefSopInfo Class See Also Send Feedback
The human readable file set ID identifying the media storage from which the referenced object may be retrieved.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FileSetId { get; set; }
Visual Basic
Public Overridable Property FileSetId As String
    Get
    Set
Visual C++
public:
virtual property String^ FileSetId {
    String^ get ();
    void set (String^ value);
}

Field Value

A String containing file set ID or null if the file set ID is not set.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


FileSetUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo..::..FileSetUid Property
MCrefSopInfo Class See Also Send Feedback
The file set UID identifying the media storage from which the referenced object may be retrieved.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FileSetUid { get; set; }
Visual Basic
Public Overridable Property FileSetUid As String
    Get
    Set
Visual C++
public:
virtual property String^ FileSetUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String containing file set UID or null if the file set UID is not set.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


RetrieveAeTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo..::..RetrieveAeTitle Property
MCrefSopInfo Class See Also Send Feedback
The Application Entity Title of the DICOM node from which the referenced object may be retrieved.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RetrieveAeTitle { get; set; }
Visual Basic
Public Overridable Property RetrieveAeTitle As String
    Get
    Set
Visual C++
public:
virtual property String^ RetrieveAeTitle {
    String^ get ();
    void set (String^ value);
}

Field Value

A String containing the Retrieve AE Title, or null if the AE Title is unknown.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


SopClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo..::..SopClassUid Property
MCrefSopInfo Class See Also Send Feedback
The UID identifying the Referenced SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SopClassUid { get; set; }
Visual Basic
Public Overridable Property SopClassUid As String
    Get
    Set
Visual C++
public:
virtual property String^ SopClassUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the SOP Class UID. The value can be set to null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


SopInstanceUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefSopInfo..::..SopInstanceUid Property
MCrefSopInfo Class See Also Send Feedback
The UID identifying the Referenced SOP Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SopInstanceUid { get; set; }
Visual Basic
Public Overridable Property SopInstanceUid As String
    Get
    Set
Visual C++
public:
virtual property String^ SopInstanceUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the SOP Instance UID. The value can be set to null.

See Also

MCrefSopInfo Class
MCrefSopInfo Members


MCrefStudyInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Class
Members See Also Send Feedback
Represents a Referenced Performed Procedure Step Sequence item (formerly Referenced Study Component Sequence item).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCrefStudyInfo
Visual Basic
Public Class MCrefStudyInfo
Visual C++
public ref class MCrefStudyInfo

Remarks

This class wraps two values:

  • refSopClassUid - retrieved from tag (0008,1150)
  • refSopInstanceUid - retrieved from tag (0008,1155)

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCrefStudyInfo

See Also

MCrefStudyInfo Members


MCrefStudyInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Members
MCrefStudyInfo Class Constructors Methods Properties See Also Send Feedback

The MCrefStudyInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MCrefStudyInfo(MCattributeSet) | Initializes a new instance of this class based on values from an existing sequence item.
Public method | MCrefStudyInfo(String, String) | Initializes a new instance of this class based on SOP class/instance uids.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SopClassUid | The unique identifier of the referenced SOP Class.
Public property | SopInstanceUid | The unique identifier of the referenced (Study) Instance.

See Also

MCrefStudyInfo Class


MCrefStudyInfo Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Constructor
MCrefStudyInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCrefStudyInfo(MCattributeSet) | Initializes a new instance of this class based on values from an existing sequence item.
Public method | MCrefStudyInfo(String, String) | Initializes a new instance of this class based on SOP class/instance uids.

See Also

MCrefStudyInfo Class
MCrefStudyInfo Members


MCrefStudyInfo Constructor (MCattributeSet)

[image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Constructor (MCattributeSet)
MCrefStudyInfo Class See Also Send Feedback
Initializes a new instance of this class based on values from an existing sequence item.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefStudyInfo(
    MCattributeSet item
)
Visual Basic
Public Sub New ( _
    item As MCattributeSet _
)
Visual C++
public:
MCrefStudyInfo(
    MCattributeSet^ item
)

Parameters

item
Type: Mergecom..::..MCattributeSet
The MCattributeSet containing values for this instance.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCrefStudyInfo Class
MCrefStudyInfo Members
MCrefStudyInfo Overload


MCrefStudyInfo Constructor (String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Constructor (String, String)
MCrefStudyInfo Class See Also Send Feedback
Initializes a new instance of this class based on SOP class/instance uids.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrefStudyInfo(
    string refSopClassUid,
    string refSopInstanceUid
)
Visual Basic
Public Sub New ( _
    refSopClassUid As String, _
    refSopInstanceUid As String _
)
Visual C++
public:
MCrefStudyInfo(
    String^ refSopClassUid,
    String^ refSopInstanceUid
)

Parameters

refSopClassUid
Type: System..::..String
The non-null SOP Class UID.
refSopInstanceUid
Type: System..::..String
The non-null SOP Instance UID.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was null.

See Also

MCrefStudyInfo Class
MCrefStudyInfo Members
MCrefStudyInfo Overload


MCrefStudyInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Methods
MCrefStudyInfo Class See Also Send Feedback

The MCrefStudyInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrefStudyInfo Class


MCrefStudyInfo Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo Properties
MCrefStudyInfo Class See Also Send Feedback

The MCrefStudyInfo type exposes the following members.

Properties

 | Name | Description
Public property | SopClassUid | The unique identifier of the referenced SOP Class.
Public property | SopInstanceUid | The unique identifier of the referenced (Study) Instance.

See Also

MCrefStudyInfo Class


SopClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo..::..SopClassUid Property
MCrefStudyInfo Class See Also Send Feedback
The unique identifier of the referenced SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SopClassUid { get; set; }
Visual Basic
Public Property SopClassUid As String
    Get
    Set
Visual C++
public:
property String^ SopClassUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the SOP Class UID value.

See Also

MCrefStudyInfo Class
MCrefStudyInfo Members


SopInstanceUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCrefStudyInfo..::..SopInstanceUid Property
MCrefStudyInfo Class See Also Send Feedback
The unique identifier of the referenced (Study) Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string SopInstanceUid { get; set; }
Visual Basic
Public Property SopInstanceUid As String
    Get
    Set
Visual C++
public:
property String^ SopInstanceUid {
    String^ get ();
    void set (String^ value);
}

Field Value

A String representing the SOP Instance UID value.

See Also

MCrefStudyInfo Class
MCrefStudyInfo Members


MCrejectReason Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCrejectReason Enumeration
See Also Send Feedback
Enumerated value used by MCassociation.reject(MCrejectReason) to set a reason as specified in the DICOM standard for rejecting an association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCrejectReason
Visual Basic
Public Enumeration MCrejectReason
Visual C++
public enum class MCrejectReason

Members

Member name | Value | Description
PERMANENT_NO_REASON_GIVEN | 0 | The rejection is permanent with no reason given (UL service user).
PERMANENT_NO_REASON_GIVEN_SERV_USER | 0 | The rejection is permanent with no reason given (UL Service user).
PERMANENT_NO_REASON_GIVEN_SERV_PROV_ACSE | 1 | The rejection is permanent with no reason given (UL service provider ACSE).
TRANSIENT_NO_REASON_GIVEN | 2 | The rejection is transient with no reason given (UL service user).
TRANSIENT_NO_REASON_GIVEN_SERV_USER | 2 | The rejection is transient with no reason given (UL service user).
TRANSIENT_NO_REASON_GIVEN_SERV_PROV_ACSE | 3 | The rejection is transient with no reason given (UL service provider ACSE).
PERMANENT_APPLICATION_CONTEXT_NAME_NOT_SUPPORTED | 4 | The rejection is permanent and was issued because the application context name was not recognized (UL service user).
PERMANENT_CALLING_AE_TITLE_NOT_RECOGNIZED | 5 | The rejection is permanent and was issued because the calling AE title was not recognized (UL service user).
PERMANENT_CALLED_AE_TITLE_NOT_RECOGNIZED | 6 | The rejection is permanent and was issued because the called AE title was not recognized (UL service user).
PERMANENT_ACSE_PROTOCOL_VERSION_NOT_SUPPORTED | 13 | The rejection is permanent and was issued because the protocol version was not recognized (UL service provider ACSE).
TRANSIENT_TEMPORARY_CONGESTION | 14 | The rejection is transient and due to the acceptor having temporary congestion (UL service provider Presentation).
TRANSIENT_LOCAL_LIMIT_EXCEEDED | 15 | The rejection is transient and due to the acceptor being out of resources (UL service provider Presentation).

See Also


MCremoteApplication Class

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Class
Members See Also Send Feedback
Contains information about a remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCremoteApplication
Visual Basic
Public Class MCremoteApplication
Visual C++
public ref class MCremoteApplication

Remarks

Specifically the class contains the remote application's Application Entitiy Title, its IPEndPoint, and the default proposed context list that will be used when negotiating an association with the remote application.

Instances can be created using the constructor or with the getObject(String) method.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCremoteApplication

See Also

MCremoteApplication Members


MCremoteApplication Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Members
MCremoteApplication Class Constructors Methods Properties See Also Send Feedback

The MCremoteApplication type exposes the following members.

Constructors

 | Name | Description
Public method | MCremoteApplication(String, IPEndPoint, MCproposedContextList) | Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.
Public method | MCremoteApplication(String, String, Int32, MCproposedContextList) | Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.

Methods

 | Name | Description
Public method | Equals | Determines if this object is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
 | getObject | Gets an MCremoteApplication object for the remote DICOM application identified by the specified Application Entity Title.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application.

Properties

 | Name | Description
Public property | AeTitle | Gets the Application Entity Title that identifies the remote DICOM application.
Public property | RemoteAddress | Gets the network address of the remote DICOM application.
Public property | ServiceList | Gets or sets the presentation context list identifying the services that will be negotiated with the remote DICOM application.

See Also

MCremoteApplication Class


MCremoteApplication Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Constructor
MCremoteApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCremoteApplication(String, IPEndPoint, MCproposedContextList) | Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.
Public method | MCremoteApplication(String, String, Int32, MCproposedContextList) | Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.

See Also

MCremoteApplication Class
MCremoteApplication Members


MCremoteApplication Constructor (String, IPEndPoint, MCproposedContextList)

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Constructor (String, IPEndPoint, MCproposedContextList)
MCremoteApplication Class See Also Send Feedback
Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCremoteApplication(
    string aeTitle,
    IPEndPoint remoteAddress,
    MCproposedContextList serviceList
)
Visual Basic
Public Sub New ( _
    aeTitle As String, _
    remoteAddress As IPEndPoint, _
    serviceList As MCproposedContextList _
)
Visual C++
public:
MCremoteApplication(
    String^ aeTitle,
    IPEndPoint^ remoteAddress,
    MCproposedContextList^ serviceList
)

Parameters

aeTitle
Type: System..::..String
The DICOM Application Entity Title by which the remote application is known.
remoteAddress
Type: System.Net..::..IPEndPoint
An IPEndPoint containing the network address of the remote application.
serviceList
Type: Mergecom..::..MCproposedContextList
The list of services that will be negotiated with the remote application.

Remarks

The Merge DICOM toolkit accepts IPv4, IPv6 or both address types depending on the IP_TYPE configuration option specified in mergecom.pro.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments had an illegal value.

See Also

MCremoteApplication Class
MCremoteApplication Members
MCremoteApplication Overload


MCremoteApplication Constructor (String, String, Int32, MCproposedContextList)

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Constructor (String, String, Int32, MCproposedContextList)
MCremoteApplication Class See Also Send Feedback
Initializes a new instance of this class that describes the properties of a remote DICOM Application Entity.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCremoteApplication(
    string aeTitle,
    string hostname,
    int port,
    MCproposedContextList serviceList
)
Visual Basic
Public Sub New ( _
    aeTitle As String, _
    hostname As String, _
    port As Integer, _
    serviceList As MCproposedContextList _
)
Visual C++
public:
MCremoteApplication(
    String^ aeTitle,
    String^ hostname,
    int port,
    MCproposedContextList^ serviceList
)

Parameters

aeTitle
Type: System..::..String
The DICOM Application Entity Title by which the remote application is known.
hostname
Type: System..::..String
The hostname of the remote application.
port
Type: System..::..Int32
The port address of the remote application.
serviceList
Type: Mergecom..::..MCproposedContextList
The list of services that will be negotiated with the remote application.

Remarks

If the value of the IP_TYPE configuration option is 'IPV4' or 'IPV6 the toolkit will use only IPv4 or IPv6 addresses respectively. If the value is 'AVAILABLE' the toolkit will use an IPv6 address if available and an IPv4 address if not.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments had an illegal value.

See Also

MCremoteApplication Class
MCremoteApplication Members
MCremoteApplication Overload


MCremoteApplication Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Methods
MCremoteApplication Class See Also Send Feedback

The MCremoteApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines if this object is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
 | getObject | Gets an MCremoteApplication object for the remote DICOM application identified by the specified Application Entity Title.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application.

See Also

MCremoteApplication Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..Equals Method
MCremoteApplication Class See Also Send Feedback
Determines if this object is equal to another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object
The object to be compared to this one.

Return Value

true if the object is an instance of MCremoteApplication and the Application Entity Title, remoteAddress and service list of both objects match; otherwise false.

See Also

MCremoteApplication Class
MCremoteApplication Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..GetHashCode Method
MCremoteApplication Class See Also Send Feedback
Hash code for this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

MCremoteApplication Class
MCremoteApplication Members


getObject Method

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..getObject Method
MCremoteApplication Class See Also Send Feedback
Gets an MCremoteApplication object for the remote DICOM application identified by the specified Application Entity Title.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCremoteApplication getObject(
    string aeTitle
)
Visual Basic
Public Shared Function getObject ( _
    aeTitle As String _
) As MCremoteApplication
Visual C++
public:
static MCremoteApplication^ getObject(
    String^ aeTitle
)

Parameters

aeTitle
Type: System..::..String
The DICOM Application Entity Title by which the remote application is known.

Return Value

An MCremoteApplication instance or null if the object could not be loaded.

Remarks

If the object was previously requested it will be returned from a cache of such requested objects. Otherwise the object will be constructed by reading its content from the Mergecom.app configuration file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The AE title specified was invalid.

See Also

MCremoteApplication Class
MCremoteApplication Members


ToString Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..ToString Method
MCremoteApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application.

See Also

MCremoteApplication Class
MCremoteApplication Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..ToString Method
MCremoteApplication Class See Also Send Feedback
Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String containing all the information contained in this object.

See Also

MCremoteApplication Class
MCremoteApplication Members
ToString Overload


ToString Method (String)

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..ToString Method (String)
MCremoteApplication Class See Also Send Feedback
Returns a string containing the Application Entity Title identifying the remote application, plus the network address of the application and the services that will be used to negotiate with the application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ToString(
    string prefix
)
Visual Basic
Public Overridable Function ToString ( _
    prefix As String _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
A possibly null prefix that will be prepended to the returned string.

Return Value

A String containing all the information contained in this object.

See Also

MCremoteApplication Class
MCremoteApplication Members
ToString Overload


MCremoteApplication Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication Properties
MCremoteApplication Class See Also Send Feedback

The MCremoteApplication type exposes the following members.

Properties

 | Name | Description
Public property | AeTitle | Gets the Application Entity Title that identifies the remote DICOM application.
Public property | RemoteAddress | Gets the network address of the remote DICOM application.
Public property | ServiceList | Gets or sets the presentation context list identifying the services that will be negotiated with the remote DICOM application.

See Also

MCremoteApplication Class


AeTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..AeTitle Property
MCremoteApplication Class See Also Send Feedback
Gets the Application Entity Title that identifies the remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AeTitle { get; }
Visual Basic
Public Overridable ReadOnly Property AeTitle As String
    Get
Visual C++
public:
virtual property String^ AeTitle {
    String^ get ();
}

Field Value

A String representing the remote Application Entity Title.

See Also

MCremoteApplication Class
MCremoteApplication Members


RemoteAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..RemoteAddress Property
MCremoteApplication Class See Also Send Feedback
Gets the network address of the remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IPEndPoint RemoteAddress { get; }
Visual Basic
Public Overridable ReadOnly Property RemoteAddress As IPEndPoint
    Get
Visual C++
public:
virtual property IPEndPoint^ RemoteAddress {
    IPEndPoint^ get ();
}

Field Value

An IPEndPoint containing the network address of the remote application.

See Also

MCremoteApplication Class
MCremoteApplication Members


ServiceList Property

[image]

Merge DICOM .NET/C# Toolkit
MCremoteApplication..::..ServiceList Property
MCremoteApplication Class See Also Send Feedback
Gets or sets the presentation context list identifying the services that will be negotiated with the remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCproposedContextList ServiceList { get; set; }
Visual Basic
Public Overridable Property ServiceList As MCproposedContextList
    Get
    Set
Visual C++
public:
virtual property MCproposedContextList^ ServiceList {
    MCproposedContextList^ get ();
    void set (MCproposedContextList^ value);
}

Field Value

An MCproposedContextList containing the services to negociate with the remote DICOM application.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | When setting this property, the value was null.

See Also

MCremoteApplication Class
MCremoteApplication Members


MCrequester Interface

[image]

Merge DICOM .NET/C# Toolkit
MCrequester Interface
Members See Also Send Feedback
Defines the methods required for handling a newly created association as a requester.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCrequester
Visual Basic
Public Interface MCrequester
Visual C++
public interface class MCrequester

See Also

MCrequester Members


MCrequester Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequester Members
MCrequester Interface Methods See Also Send Feedback

The MCrequester type exposes the following members.

Methods

 | Name | Description
Public method | start | Called by the toolkit to process the association communication for a requester.

See Also

MCrequester Interface


MCrequester Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequester Methods
MCrequester Interface See Also Send Feedback

The MCrequester type exposes the following members.

Methods

 | Name | Description
Public method | start | Called by the toolkit to process the association communication for a requester.

See Also

MCrequester Interface


start Method

[image]

Merge DICOM .NET/C# Toolkit
MCrequester..::..start Method
MCrequester Interface See Also Send Feedback
Called by the toolkit to process the association communication for a requester.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void start(
    MCassociation assoc
)
Visual Basic
Sub start ( _
    assoc As MCassociation _
)
Visual C++
void start(
    MCassociation^ assoc
)

Parameters

assoc
Type: Mergecom..::..MCassociation
The opened association object.

Remarks

This method is called in a separate thread for each concurrent association. Threads are recycled by the toolkit as associations are released or aborted.

If this method throws an exception a message will be logged and the association will end.

See Also

MCrequester Interface
MCrequester Members


MCresultContext Class

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext Class
Members See Also Send Feedback
Contains information about a DICOM service that has been rejected or accepted by the remote DICOM application.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCresultContext
Visual Basic
Public Class MCresultContext
Visual C++
public ref class MCresultContext

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCresultContext

See Also

MCresultContext Members


MCresultContext Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultContext Members
MCresultContext Class Methods Properties See Also Send Feedback

The MCresultContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNegotiationInfo | Retrieves negotiation information by decoding the provided MCnegotiationInfo.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NegotiationInfo | Gets the extended negotiation info associated with this result context.
Public property | PresentationContextID | Gets the Presentation Context ID of this negotiated context.
Public property | ResultCode | Gets the 1-byte Code returned during negotiation for this context.
Public property | RoleNegotiated | Gets the role negotiated.
Public property | ServiceName | Gets the service name for this result context.
Public property | TransferSyntax | Gets the transfer syntax associated with this result context.

See Also

MCresultContext Class


MCresultContext Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultContext Methods
MCresultContext Class See Also Send Feedback

The MCresultContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNegotiationInfo | Retrieves negotiation information by decoding the provided MCnegotiationInfo.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCresultContext Class


getNegotiationInfo Method

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..getNegotiationInfo Method
MCresultContext Class See Also Send Feedback
Retrieves negotiation information by decoding the provided MCnegotiationInfo.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool getNegotiationInfo(
    MCnegotiationInfo infoObject
)
Visual Basic
Public Overridable Function getNegotiationInfo ( _
    infoObject As MCnegotiationInfo _
) As Boolean
Visual C++
public:
virtual bool getNegotiationInfo(
    MCnegotiationInfo^ infoObject
)

Parameters

infoObject
Type: Mergecom..::..MCnegotiationInfo
An MCnegotiationInfo instance.

Return Value

true if the decoding succeded.

See Also

MCresultContext Class
MCresultContext Members


MCresultContext Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultContext Properties
MCresultContext Class See Also Send Feedback

The MCresultContext type exposes the following members.

Properties

 | Name | Description
Public property | NegotiationInfo | Gets the extended negotiation info associated with this result context.
Public property | PresentationContextID | Gets the Presentation Context ID of this negotiated context.
Public property | ResultCode | Gets the 1-byte Code returned during negotiation for this context.
Public property | RoleNegotiated | Gets the role negotiated.
Public property | ServiceName | Gets the service name for this result context.
Public property | TransferSyntax | Gets the transfer syntax associated with this result context.

See Also

MCresultContext Class


NegotiationInfo Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..NegotiationInfo Property
MCresultContext Class See Also Send Feedback
Gets the extended negotiation info associated with this result context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte[] NegotiationInfo { get; internal set; }
Visual Basic
Public Overridable Property NegotiationInfo As Byte()
    Get
    Friend Set
Visual C++
public:
virtual property array<unsigned char>^ NegotiationInfo {
    array<unsigned char>^ get ();
    internal: void set (array<unsigned char>^ value);
}

Field Value

The accepted MCtransferSyntax.

See Also

MCresultContext Class
MCresultContext Members


PresentationContextID Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..PresentationContextID Property
MCresultContext Class See Also Send Feedback
Gets the Presentation Context ID of this negotiated context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte PresentationContextID { get; internal set; }
Visual Basic
Public Overridable Property PresentationContextID As Byte
    Get
    Friend Set
Visual C++
public:
virtual property unsigned char PresentationContextID {
    unsigned char get ();
    internal: void set (unsigned char value);
}

Field Value

The Presentation Context ID.

See Also

MCresultContext Class
MCresultContext Members


ResultCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..ResultCode Property
MCresultContext Class See Also Send Feedback
Gets the 1-byte Code returned during negotiation for this context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual byte ResultCode { get; }
Visual Basic
Public Overridable ReadOnly Property ResultCode As Byte
    Get
Visual C++
public:
virtual property unsigned char ResultCode {
    unsigned char get ();
}

Field Value

A byte containing the result code.

Remarks

The following result codes are defined:
  • 0 - acceptance
  • 1 - user-rejection
  • 2 - no-reason (provider rejection)
  • 3 - abstract-syntax-not-supported (provider rejection)
  • 4 - transfer-syntax-not-supported (provider rejection)

See Also

MCresultContext Class
MCresultContext Members


RoleNegotiated Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..RoleNegotiated Property
MCresultContext Class See Also Send Feedback
Gets the role negotiated.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual char RoleNegotiated { get; internal set; }
Visual Basic
Public Overridable Property RoleNegotiated As Char
    Get
    Friend Set
Visual C++
public:
virtual property wchar_t RoleNegotiated {
    wchar_t get ();
    internal: void set (wchar_t value);
}

Field Value

'U' if SCU, 'P' if SCP or 'B' if both.

See Also

MCresultContext Class
MCresultContext Members


ServiceName Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..ServiceName Property
MCresultContext Class See Also Send Feedback
Gets the service name for this result context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceName { get; internal set; }
Visual Basic
Public Overridable Property ServiceName As String
    Get
    Friend Set
Visual C++
public:
virtual property String^ ServiceName {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

Name of the service associated with this context.

See Also

MCresultContext Class
MCresultContext Members


TransferSyntax Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultContext..::..TransferSyntax Property
MCresultContext Class See Also Send Feedback
Gets the transfer syntax associated with this result context.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax TransferSyntax { get; internal set; }
Visual Basic
Public Overridable Property TransferSyntax As MCtransferSyntax
    Get
    Friend Set
Visual C++
public:
virtual property MCtransferSyntax^ TransferSyntax {
    MCtransferSyntax^ get ();
    internal: void set (MCtransferSyntax^ value);
}

Field Value

The accepted MCtransferSyntax.

See Also

MCresultContext Class
MCresultContext Members


MCresultsManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Class
Members See Also Send Feedback
Represents a DICOM Results Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCresultsManagementService : MCdimseService
Visual Basic
Public Class MCresultsManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCresultsManagementService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:
  • Detached Results Management Meta SOP Class
  • Detached Results Management SOP Class
  • Detached Interpretation Management SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCresultsManagementService

See Also

MCresultsManagementService Members


MCresultsManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Members
MCresultsManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCresultsManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCresultsManagementService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCresultsManagementService Class


MCresultsManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Constructor
MCresultsManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCresultsManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCresultsManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCresultsManagementService Class
MCresultsManagementService Members


MCresultsManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Fields
MCresultsManagementService Class See Also Send Feedback

The MCresultsManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCresultsManagementService Class


MCresultsManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Methods
MCresultsManagementService Class See Also Send Feedback

The MCresultsManagementService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCresultsManagementService Class


MCresultsManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultsManagementService Properties
MCresultsManagementService Class See Also Send Feedback

The MCresultsManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCresultsManagementService Class


MCrleCompressor Class

[image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor Class
Members See Also Send Feedback
This standard compressor implements the MCcompression interface and it can be used to compress images into the Run-length encoding (RLE) transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCrleCompressor : MCcompression
Visual Basic
Public Class MCrleCompressor _
    Implements MCcompression
Visual C++
public ref class MCrleCompressor : MCcompression

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCrleCompressor

See Also

MCrleCompressor Members


MCrleCompressor Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor Members
MCrleCompressor Class Constructors Methods See Also Send Feedback

The MCrleCompressor type exposes the following members.

Constructors

 | Name | Description
Public method | MCrleCompressor | Initializes a new instance of the RLE compressor.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the RLE compressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the RLE compressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the RLE compressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrleCompressor Class


MCrleCompressor Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor Constructor
MCrleCompressor Class See Also Send Feedback
Initializes a new instance of the RLE compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrleCompressor()
Visual Basic
Public Sub New
Visual C++
public:
MCrleCompressor()

See Also

MCrleCompressor Class
MCrleCompressor Members


MCrleCompressor Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor Methods
MCrleCompressor Class See Also Send Feedback

The MCrleCompressor type exposes the following members.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the RLE compressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the RLE compressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the RLE compressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrleCompressor Class


createContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor..::..createContext Method
MCrleCompressor Class See Also Send Feedback
Implementation of MCcompression.createContext method for the RLE compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object createContext(
    MCattributeSet ats,
    MCtransferSyntax source,
    MCtransferSyntax destination
)
Visual Basic
Public Function createContext ( _
    ats As MCattributeSet, _
    source As MCtransferSyntax, _
    destination As MCtransferSyntax _
) As Object
Visual C++
public:
virtual Object^ createContext(
    MCattributeSet^ ats,
    MCtransferSyntax^ source,
    MCtransferSyntax^ destination
) sealed

Parameters

ats
Type: Mergecom..::..MCattributeSet
The attribute set containing the pixel data being compressed.
source
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the source data.
destination
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the destination data.

Return Value

The context object for RLE compression.

Implements

MCcompression..::..createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax)

See Also

MCrleCompressor Class
MCrleCompressor Members


processData Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor..::..processData Method
MCrleCompressor Class See Also Send Feedback
Implementation of the MCcompression.processData method for the RLE compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata processData(
    Object context,
    MCdata inputData,
    bool isFirst
)
Visual Basic
Public Function processData ( _
    context As Object, _
    inputData As MCdata, _
    isFirst As Boolean _
) As MCdata
Visual C++
public:
virtual MCdata^ processData(
    Object^ context,
    MCdata^ inputData,
    bool isFirst
) sealed

Parameters

context
Type: System..::..Object
The context created by the createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.
inputData
Type: Mergecom..::..MCdata
The input data to the compressor.
isFirst
Type: System..::..Boolean
Set to true on the first call to process data.

Return Value

Returns compressed data. May return null if no compressed data is available.

Implements

MCcompression..::..processData(Object, MCdata, Boolean)

See Also

MCrleCompressor Class
MCrleCompressor Members


releaseContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleCompressor..::..releaseContext Method
MCrleCompressor Class See Also Send Feedback
Implementation of the MCcompression.releaseContext method for the RLE compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void releaseContext(
    Object context
)
Visual Basic
Public Sub releaseContext ( _
    context As Object _
)
Visual C++
public:
virtual void releaseContext(
    Object^ context
) sealed

Parameters

context
Type: System..::..Object
The context object created by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.

Implements

MCcompression..::..releaseContext(Object)

See Also

MCrleCompressor Class
MCrleCompressor Members


MCrleDecompressor Class

[image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor Class
Members See Also Send Feedback
This standard decompressor implements the MCcompression interface and it can be used to decompress images from the Run-length encoding (RLE) transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCrleDecompressor : MCcompression
Visual Basic
Public Class MCrleDecompressor _
    Implements MCcompression
Visual C++
public ref class MCrleDecompressor : MCcompression

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCrleDecompressor

See Also

MCrleDecompressor Members


MCrleDecompressor Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor Members
MCrleDecompressor Class Constructors Methods See Also Send Feedback

The MCrleDecompressor type exposes the following members.

Constructors

 | Name | Description
Public method | MCrleDecompressor | Initializes a new instance of the RLE decompressor.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the RLE decompressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the RLE decompressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the RLE decompressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrleDecompressor Class


MCrleDecompressor Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor Constructor
MCrleDecompressor Class See Also Send Feedback
Initializes a new instance of the RLE decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrleDecompressor()
Visual Basic
Public Sub New
Visual C++
public:
MCrleDecompressor()

See Also

MCrleDecompressor Class
MCrleDecompressor Members


MCrleDecompressor Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor Methods
MCrleDecompressor Class See Also Send Feedback

The MCrleDecompressor type exposes the following members.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the RLE decompressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the RLE decompressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the RLE decompressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrleDecompressor Class


createContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor..::..createContext Method
MCrleDecompressor Class See Also Send Feedback
Implementation of MCcompression.createContext method for the RLE decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object createContext(
    MCattributeSet ats,
    MCtransferSyntax source,
    MCtransferSyntax destination
)
Visual Basic
Public Function createContext ( _
    ats As MCattributeSet, _
    source As MCtransferSyntax, _
    destination As MCtransferSyntax _
) As Object
Visual C++
public:
virtual Object^ createContext(
    MCattributeSet^ ats,
    MCtransferSyntax^ source,
    MCtransferSyntax^ destination
) sealed

Parameters

ats
Type: Mergecom..::..MCattributeSet
The attribute set containing the pixel data being decompressed.
source
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the source data.
destination
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the destination data.

Return Value

The context object for RLE decompression.

Implements

MCcompression..::..createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax)

See Also

MCrleDecompressor Class
MCrleDecompressor Members


processData Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor..::..processData Method
MCrleDecompressor Class See Also Send Feedback
Implementation of the MCcompression.processData method for the RLE decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata processData(
    Object context,
    MCdata inputData,
    bool isFirst
)
Visual Basic
Public Function processData ( _
    context As Object, _
    inputData As MCdata, _
    isFirst As Boolean _
) As MCdata
Visual C++
public:
virtual MCdata^ processData(
    Object^ context,
    MCdata^ inputData,
    bool isFirst
) sealed

Parameters

context
Type: System..::..Object
The context created by the createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.
inputData
Type: Mergecom..::..MCdata
The input data to the decompressor.
isFirst
Type: System..::..Boolean
Set to true on the first call to process data.

Return Value

Returns decompressed data. May return null if no data is available.

Implements

MCcompression..::..processData(Object, MCdata, Boolean)

See Also

MCrleDecompressor Class
MCrleDecompressor Members


releaseContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCrleDecompressor..::..releaseContext Method
MCrleDecompressor Class See Also Send Feedback
Implementation of the MCcompression.releaseContext method for the RLE decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void releaseContext(
    Object context
)
Visual Basic
Public Sub releaseContext ( _
    context As Object _
)
Visual C++
public:
virtual void releaseContext(
    Object^ context
) sealed

Parameters

context
Type: System..::..Object
The context object created by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.

Implements

MCcompression..::..releaseContext(Object)

See Also

MCrleDecompressor Class
MCrleDecompressor Members


MCsecureContext Class

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Class
Members See Also Send Feedback
SSL context is used to to support Mergecom secure associations in DICOM applications

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCsecureContext
Visual Basic
Public MustInherit Class MCsecureContext
Visual C++
public ref class MCsecureContext abstract

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCsecureContext

See Also

MCsecureContext Members


MCsecureContext Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Members
MCsecureContext Class Constructors Methods Fields Properties See Also Send Feedback

The MCsecureContext type exposes the following members.

Constructors

 | Name | Description
Public method | MCsecureContext | SSL context object constructor

Methods

 | Name | Description
Public method | Association | Returns MCassociation object associated with socket handle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TcpClient | Returns TcpClient(IntPtr) object associated with socket handle
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ApplicationContext | SSL application context

Properties

 | Name | Description
Public property | Associations | Session MCassociation objects
Public property | ReadFunction | SSL Read callback
Public property | ShutdownFunction | SSL Shutdown session callback
Public property | StartFunction | SSL Start session callback
Public property | WriteFunction | SSL Read callback

See Also

MCsecureContext Class


MCsecureContext Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Constructor
MCsecureContext Class See Also Send Feedback
SSL context object constructor

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsecureContext()
Visual Basic
Public Sub New
Visual C++
public:
MCsecureContext()

See Also

MCsecureContext Class
MCsecureContext Members


MCsecureContext Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Fields
MCsecureContext Class See Also Send Feedback

The MCsecureContext type exposes the following members.

Fields

 | Name | Description
Public field | ApplicationContext | SSL application context

See Also

MCsecureContext Class


ApplicationContext Field

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..ApplicationContext Field
MCsecureContext Class See Also Send Feedback
SSL application context

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object ApplicationContext
Visual Basic
Public ApplicationContext As Object
Visual C++
public:
Object^ ApplicationContext

See Also

MCsecureContext Class
MCsecureContext Members


MCsecureContext Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Methods
MCsecureContext Class See Also Send Feedback

The MCsecureContext type exposes the following members.

Methods

 | Name | Description
Public method | Association | Returns MCassociation object associated with socket handle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TcpClient | Returns TcpClient(IntPtr) object associated with socket handle
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCsecureContext Class


Association Method

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Association Method
MCsecureContext Class See Also Send Feedback
Returns MCassociation object associated with socket handle

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociation Association(
    IntPtr socket
)
Visual Basic
Public Function Association ( _
    socket As IntPtr _
) As MCassociation
Visual C++
public:
MCassociation^ Association(
    IntPtr socket
)

Parameters

socket
Type: System..::..IntPtr
Socket handle

Return Value

MCassociation object

See Also

MCsecureContext Class
MCsecureContext Members


Finalize Method

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Finalize Method
MCsecureContext Class See Also Send Feedback

[Missing <summary> documentation for "M:Mergecom.MCsecureContext.Finalize"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

MCsecureContext Class
MCsecureContext Members


TcpClient Method

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..TcpClient Method
MCsecureContext Class See Also Send Feedback
Returns TcpClient(IntPtr) object associated with socket handle

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public TcpClient TcpClient(
    IntPtr socket
)
Visual Basic
Public Function TcpClient ( _
    socket As IntPtr _
) As TcpClient
Visual C++
public:
TcpClient^ TcpClient(
    IntPtr socket
)

Parameters

socket
Type: System..::..IntPtr
Socket handle

Return Value

TcpClient(IntPtr) object

See Also

MCsecureContext Class
MCsecureContext Members


MCsecureContext Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext Properties
MCsecureContext Class See Also Send Feedback

The MCsecureContext type exposes the following members.

Properties

 | Name | Description
Public property | Associations | Session MCassociation objects
Public property | ReadFunction | SSL Read callback
Public property | ShutdownFunction | SSL Shutdown session callback
Public property | StartFunction | SSL Start session callback
Public property | WriteFunction | SSL Read callback

See Also

MCsecureContext Class


Associations Property

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Associations Property
MCsecureContext Class See Also Send Feedback
Session MCassociation objects

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public IList<MCassociation> Associations { get; }
Visual Basic
Public ReadOnly Property Associations As IList(Of MCassociation)
    Get
Visual C++
public:
property IList<MCassociation^>^ Associations {
    IList<MCassociation^>^ get ();
}

See Also

MCsecureContext Class
MCsecureContext Members


ReadFunction Property

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..ReadFunction Property
MCsecureContext Class See Also Send Feedback
SSL Read callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsecureContext..::..Read ReadFunction { get; set; }
Visual Basic
Public Property ReadFunction As MCsecureContext..::..Read
    Get
    Set
Visual C++
public:
property MCsecureContext..::..Read^ ReadFunction {
    MCsecureContext..::..Read^ get ();
    void set (MCsecureContext..::..Read^ value);
}

See Also

MCsecureContext Class
MCsecureContext Members


ShutdownFunction Property

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..ShutdownFunction Property
MCsecureContext Class See Also Send Feedback
SSL Shutdown session callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsecureContext..::..Shutdown ShutdownFunction { get; set; }
Visual Basic
Public Property ShutdownFunction As MCsecureContext..::..Shutdown
    Get
    Set
Visual C++
public:
property MCsecureContext..::..Shutdown^ ShutdownFunction {
    MCsecureContext..::..Shutdown^ get ();
    void set (MCsecureContext..::..Shutdown^ value);
}

See Also

MCsecureContext Class
MCsecureContext Members


StartFunction Property

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..StartFunction Property
MCsecureContext Class See Also Send Feedback
SSL Start session callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsecureContext..::..Start StartFunction { get; set; }
Visual Basic
Public Property StartFunction As MCsecureContext..::..Start
    Get
    Set
Visual C++
public:
property MCsecureContext..::..Start^ StartFunction {
    MCsecureContext..::..Start^ get ();
    void set (MCsecureContext..::..Start^ value);
}

See Also

MCsecureContext Class
MCsecureContext Members


WriteFunction Property

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..WriteFunction Property
MCsecureContext Class See Also Send Feedback
SSL Read callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsecureContext..::..Write WriteFunction { get; set; }
Visual Basic
Public Property WriteFunction As MCsecureContext..::..Write
    Get
    Set
Visual C++
public:
property MCsecureContext..::..Write^ WriteFunction {
    MCsecureContext..::..Write^ get ();
    void set (MCsecureContext..::..Write^ value);
}

See Also

MCsecureContext Class
MCsecureContext Members


MCsecureContext.Read Delegate

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Read Delegate
MCsecureContext Class See Also Send Feedback
SSL read session delegate

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public delegate MCsecureContext..::..Status Read(
    IntPtr SecureContext,
    IntPtr ApplicationContext,
    IntPtr Buffer,
    uint BytesToRead,
    ref uint BytesRead,
    int Timeout
)
Visual Basic
Public Delegate Function Read ( _
    SecureContext As IntPtr, _
    ApplicationContext As IntPtr, _
    Buffer As IntPtr, _
    BytesToRead As UInteger, _
    ByRef BytesRead As UInteger, _
    Timeout As Integer _
) As MCsecureContext..::..Status
Visual C++
public delegate MCsecureContext..::..Status Read(
    IntPtr SecureContext,
    IntPtr ApplicationContext,
    IntPtr Buffer,
    unsigned int BytesToRead,
    unsigned int% BytesRead,
    int Timeout
)

Parameters

SecureContext
Type: System..::..IntPtr
SSL session context
ApplicationContext
Type: System..::..IntPtr
Application context
Buffer
Type: System..::..IntPtr
Read buffer
BytesToRead
Type: System..::..UInt32
Bytes to read
BytesRead
Type: System..::..UInt32%
Bytes read
Timeout
Type: System..::..Int32
Timeout

Return Value

SSL operation status

See Also


MCsecureContext.SecureSocketFunctions Structure

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions Structure
MCsecureContext Class Members See Also Send Feedback
Structure referenced to SSL session callbacks

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public struct SecureSocketFunctions
Visual Basic
Public Structure SecureSocketFunctions
Visual C++
public value class SecureSocketFunctions

See Also

MCsecureContext..::..SecureSocketFunctions Members


MCsecureContext.SecureSocketFunctions Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions Members
MCsecureContext..::..SecureSocketFunctions Structure Methods Fields See Also Send Feedback

The MCsecureContext..::..SecureSocketFunctions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | read | SSL Read callback
Public field | shutdown | SSL Shutdown session callback
Public field | start | SSL Start session callback
Public field | write | SSL Write callback

See Also

MCsecureContext..::..SecureSocketFunctions Structure


MCsecureContext.SecureSocketFunctions Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions Fields
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback

The MCsecureContext..::..SecureSocketFunctions type exposes the following members.

Fields

 | Name | Description
Public field | read | SSL Read callback
Public field | shutdown | SSL Shutdown session callback
Public field | start | SSL Start session callback
Public field | write | SSL Write callback

See Also

MCsecureContext..::..SecureSocketFunctions Structure


read Field

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions..::..read Field
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback
SSL Read callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public IntPtr read
Visual Basic
Public read As IntPtr
Visual C++
public:
IntPtr read

See Also

MCsecureContext..::..SecureSocketFunctions Structure
MCsecureContext..::..SecureSocketFunctions Members


shutdown Field

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions..::..shutdown Field
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback
SSL Shutdown session callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public IntPtr shutdown
Visual Basic
Public shutdown As IntPtr
Visual C++
public:
IntPtr shutdown

See Also

MCsecureContext..::..SecureSocketFunctions Structure
MCsecureContext..::..SecureSocketFunctions Members


start Field

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions..::..start Field
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback
SSL Start session callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public IntPtr start
Visual Basic
Public start As IntPtr
Visual C++
public:
IntPtr start

See Also

MCsecureContext..::..SecureSocketFunctions Structure
MCsecureContext..::..SecureSocketFunctions Members


write Field

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions..::..write Field
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback
SSL Write callback

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public IntPtr write
Visual Basic
Public write As IntPtr
Visual C++
public:
IntPtr write

See Also

MCsecureContext..::..SecureSocketFunctions Structure
MCsecureContext..::..SecureSocketFunctions Members


MCsecureContext.SecureSocketFunctions Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..SecureSocketFunctions Methods
MCsecureContext..::..SecureSocketFunctions Structure See Also Send Feedback

The MCsecureContext..::..SecureSocketFunctions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

MCsecureContext..::..SecureSocketFunctions Structure


MCsecureContext.Shutdown Delegate

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Shutdown Delegate
MCsecureContext Class See Also Send Feedback
SSL shutdown session delegate

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public delegate void Shutdown(
    IntPtr SecureContext,
    IntPtr ApplicationContext
)
Visual Basic
Public Delegate Sub Shutdown ( _
    SecureContext As IntPtr, _
    ApplicationContext As IntPtr _
)
Visual C++
public delegate void Shutdown(
    IntPtr SecureContext,
    IntPtr ApplicationContext
)

Parameters

SecureContext
Type: System..::..IntPtr
SSL session context
ApplicationContext
Type: System..::..IntPtr
Application context

See Also


MCsecureContext.Start Delegate

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Start Delegate
MCsecureContext Class See Also Send Feedback
SSL start session delegate

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public delegate MCsecureContext..::..Status Start(
    IntPtr Socket,
    int ConnType,
    IntPtr ApplicationContext,
    ref IntPtr SecureContext
)
Visual Basic
Public Delegate Function Start ( _
    Socket As IntPtr, _
    ConnType As Integer, _
    ApplicationContext As IntPtr, _
    ByRef SecureContext As IntPtr _
) As MCsecureContext..::..Status
Visual C++
public delegate MCsecureContext..::..Status Start(
    IntPtr Socket,
    int ConnType,
    IntPtr ApplicationContext,
    IntPtr% SecureContext
)

Parameters

Socket
Type: System..::..IntPtr
SSL socket
ConnType
Type: System..::..Int32
SSL connection type
ApplicationContext
Type: System..::..IntPtr
Application context
SecureContext
Type: System..::..IntPtr%
SSL session context

Return Value

SSL operation status

See Also


MCsecureContext.Status Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Status Enumeration
MCsecureContext Class See Also Send Feedback
SSL status for secure association operation (Open, Read, Write and Shutdown)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum Status
Visual Basic
Public Enumeration Status
Visual C++
public enum class Status

Members

Member name | Value | Description
NORMAL_COMPLETION | 0 | Normal completion
ERROR | 1 | Error
TIMEOUT | 2 | Timeout
SESSION_CLOSED | 3 | Session closed

See Also


MCsecureContext.Write Delegate

[image]

Merge DICOM .NET/C# Toolkit
MCsecureContext..::..Write Delegate
MCsecureContext Class See Also Send Feedback
SSL write session delegate

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public delegate MCsecureContext..::..Status Write(
    IntPtr SecureContext,
    IntPtr ApplicationContext,
    IntPtr Buffer,
    uint BytesToWrite,
    ref uint BytesWritten,
    int Timeout
)
Visual Basic
Public Delegate Function Write ( _
    SecureContext As IntPtr, _
    ApplicationContext As IntPtr, _
    Buffer As IntPtr, _
    BytesToWrite As UInteger, _
    ByRef BytesWritten As UInteger, _
    Timeout As Integer _
) As MCsecureContext..::..Status
Visual C++
public delegate MCsecureContext..::..Status Write(
    IntPtr SecureContext,
    IntPtr ApplicationContext,
    IntPtr Buffer,
    unsigned int BytesToWrite,
    unsigned int% BytesWritten,
    int Timeout
)

Parameters

SecureContext
Type: System..::..IntPtr
SSL session context
ApplicationContext
Type: System..::..IntPtr
Application context
Buffer
Type: System..::..IntPtr
Read buffer
BytesToWrite
Type: System..::..UInt32
Bytes to write
BytesWritten
Type: System..::..UInt32%
Bytes written
Timeout
Type: System..::..Int32
Timeout

Return Value

SSL operation status

See Also


MCservices Structure

[image]

Merge DICOM .NET/C# Toolkit
MCservices Structure
Members See Also Send Feedback
The MCservices structure contains constant strings representing names for the DICOM services as defined in the mergecom.srv configuration file. It eliminates the need to hard code these names and makes possible compile time checking.

As the standard evolves the structure will be updated in order to remain current. In particular, the following changes can be expected:

  1. New fields will be added as new services are defined in new Supplements and Change Proposals.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public struct MCservices
Visual Basic
Public Structure MCservices
Visual C++
public value class MCservices

See Also

MCservices Members


MCservices Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCservices Members
MCservices Structure Methods Fields See Also Send Feedback

The MCservices type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
ACQUISITION_CONTEXT_SR |
ADVANCED_BLENDING_PRESENTATION_STATE |
ARTERIAL_PULSE_WAVEFORM |
AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION |
AUTOREFRACTION_MEASUREMENTS |
BASIC_ANNOTATION_BOX |
BASIC_COLOR_IMAGE_BOX |
BASIC_FILM_BOX |
BASIC_FILM_SESSION |
BASIC_GRAYSCALE_IMAGE_BOX |
BASIC_PRINT_IMAGE_OVERLAY_BOX |
BASIC_STRUCTURED_DISPLAY |
BODY_POSITION_WAVEFORM |
BREAST_IMAGING_RPI_QUERY |
BREAST_PROJ_PRESENT |
BREAST_PROJ_PROCESS |
BREAST_TOMO_IMAGE_STORAGE |
C_ARM_PHOTON_ELECTRON_RADIATION |
C_ARM_PHOTON_ELECTRON_RADIATION_RECORD |
CARDIAC_RPI_QUERY |
CHEST_CAD_SR |
COLON_CAD_SR |
COLOR_PALETTE_FIND |
COLOR_PALETTE_GET |
COLOR_PALETTE_MOVE |
COLOR_PALETTE_STORAGE |
COMPOSITE_INST_RET_NO_BULK_GET |
COMPOSITE_INSTANCE_ROOT_RET_GET |
COMPOSITE_INSTANCE_ROOT_RET_MOVE |
COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS |
COMPREHENSIVE_3D_SR |
CONTENT_ASSESSMENT_RESULTS |
CORNEAL_TOPOGRAPHY_MAP |
CT_DEFINED_PROCEDURE_PROTOCOL |
CT_PERFORMED_PROCEDURE_PROTOCOL |
DEFINED_PROCEDURE_PROTOCOL_FIND |
DEFINED_PROCEDURE_PROTOCOL_GET |
DEFINED_PROCEDURE_PROTOCOL_MOVE |
DEFORMABLE_SPATIAL_REGISTRATION |
DERMOSCOPIC_PHOTOGRAPHY_IMAGE |
DETACHED_INTERP_MANAGEMENT |
DETACHED_PATIENT_MANAGEMENT |
DETACHED_RESULTS_MANAGEMENT |
DETACHED_STUDY_MANAGEMENT |
DETACHED_VISIT_MANAGEMENT |
DICOMDIR |
DISPLAY_SYSTEM |
ELECTROMYOGRAM_WAVEFORM |
ELECTROOCULOGRAM_WAVEFORM |
ENCAPSULATED_CDA |
ENCAPSULATED_MTL |
ENCAPSULATED_OBJ |
ENCAPSULATED_STL |
ENHANCED_CONTINUOUS_RT_IMAGE |
ENHANCED_CT_IMAGE |
ENHANCED_MR_COLOR_IMAGE |
ENHANCED_MR_IMAGE |
ENHANCED_PET_IMAGE |
ENHANCED_RT_IMAGE |
ENHANCED_US_VOLUME |
ENHANCED_XA_IMAGE |
ENHANCED_XRAY_RADIATION_DOSE_SR |
ENHANCED_XRF_IMAGE |
EXTENSIBLE_SR |
G_P_PERFORMED_PROCEDURE_STEP_RETIRED |
G_P_SCHEDULED_PROCEDURE_STEP_RETIRED |
G_P_WORKLIST_RETIRED |
GENERAL_AUDIO_WAVEFORM |
GENERAL_RPI_QUERY |
GENERIC_IMPLANT_TEMPLATE |
GENERIC_IMPLANT_TEMPLATE_FIND |
GENERIC_IMPLANT_TEMPLATE_GET |
GENERIC_IMPLANT_TEMPLATE_MOVE |
GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS |
HANGING_PROTOCOL |
HANGING_PROTOCOL_FIND |
HANGING_PROTOCOL_GET |
HANGING_PROTOCOL_MOVE |
IMAGE_OVERLAY_BOX_RETIRED |
IMPLANT_ASSEMBLY_TEMPLATE |
IMPLANT_ASSEMBLY_TEMPLATE_FIND |
IMPLANT_ASSEMBLY_TEMPLATE_GET |
IMPLANT_ASSEMBLY_TEMPLATE_MOVE |
IMPLANT_TEMPLATE_GROUP |
IMPLANT_TEMPLATE_GROUP_FIND |
IMPLANT_TEMPLATE_GROUP_GET |
IMPLANT_TEMPLATE_GROUP_MOVE |
IMPLANTATION_PLAN_SR_DOCUMENT |
INSTANCE_AVAIL_NOTIFICATION |
INTRAOCULAR_LENS_CALCULATIONS |
INVENTORY |
INVENTORY_CREATION |
INVENTORY_FIND |
INVENTORY_GET |
INVENTORY_MOVE |
KERATOMETRY_MEASUREMENTS |
KEY_OBJECT_SELECTION_DOC |
LEGACY_CONVERTED_ENHANCED_CT_IMAGE |
LEGACY_CONVERTED_ENHANCED_MR_IMAGE |
LEGACY_CONVERTED_ENHANCED_PET_IMAGE |
LENSOMETRY_MEASUREMENTS |
MACULAR_GRID_THIICKNESS_VOLUME |
MAMMOGRAPHY_CAD_SR |
MEDIA_CREATION_MANAGEMENT |
MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MODALITY_WORKLIST_FIND |
MR_SPECTROSCOPY |
MULTI_CHANNEL_RESPIRATORY_WAVEFORM |
MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
OPHT_VIS_FIELD_STATIC_PERIM_MEAS |
OPHTHALMIC_AXIAL_MEASUREMENTS |
OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS |
OPHTHALMIC_OCT_EN_FACE_IMAGE |
OPHTHALMIC_TOMOGRAPHY_IMAGE |
OPM_THICKNESS_MAP |
PARAMETRIC_MAP |
PATIENT_RADIATION_DOSE_SR |
PATIENT_ROOT_QR_FIND |
PATIENT_ROOT_QR_GET |
PATIENT_ROOT_QR_MOVE |
PATIENT_STUDY_ONLY_QR_FIND_RETIRED |
PATIENT_STUDY_ONLY_QR_GET_RETIRED |
PATIENT_STUDY_ONLY_QR_MOVE_RETIRED |
PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR |
PERFORMED_PROCEDURE_STEP |
PERFORMED_PROCEDURE_STEP_NOTIFY |
PERFORMED_PROCEDURE_STEP_RETRIEVE |
PHOTOACOUSTIC_IMAGE |
PLANNED_IMAGING_AGENT_ADMINISTRATION_SR |
PRESENTATION_LUT |
PRINT_JOB |
PRINT_QUEUE_MANAGEMENT |
PRINTER |
PRINTER_CONFIGURATION |
PROCEDURAL_EVENT_LOGGING |
PROCEDURE_LOG |
PRODUCT_CHARACTERISTICS_QUERY |
PROTOCOL_APPROVAL |
PROTOCOL_APPROVAL_FIND |
PROTOCOL_APPROVAL_GET |
PROTOCOL_APPROVAL_MOVE |
PULL_PRINT_REQUEST |
RADIOPHARMACEUTICAL_RADIATION_DOSE_SR |
RAW_DATA |
REAL_WORLD_VALUE_MAPPING |
REFERENCED_IMAGE_BOX |
RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION |
REPOSITORY_QUERY |
RESPIRATORY_WAVEFORM |
ROBOTIC_ARM_RADIATION |
ROBOTIC_ARM_RADIATION_RECORD |
ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM |
RT_BEAMS_DELIVERY_INSTR_RET |
RT_BEAMS_DELIVERY_INSTRUCTION |
RT_BRACHY_APP_SETUP_DELIVERY_INSTR |
RT_CONV_MACHINE_VERIF_RET |
RT_CONVENTIONAL_MACHINE_VERIFICATION |
RT_ION_MACHINE_VERIF_RET |
RT_ION_MACHINE_VERIFICATION |
RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION |
RT_PHYSICIAN_INTENT |
RT_RADIATION_RECORD_SET |
RT_RADIATION_SALVAGE_RECORD |
RT_RADIATION_SET |
RT_RADIATION_SET_DELIVERY_INSTRUCTION |
RT_SEGMENT_ANNOTATION |
RT_TREATMENT_PREPARATION |
SC_MULTIFRAME_GRAYSCALE_BYTE |
SC_MULTIFRAME_GRAYSCALE_WORD |
SC_MULTIFRAME_SINGLE_BIT |
SC_MULTIFRAME_TRUE_COLOR |
SEGMENTATION |
SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
SIMPLIFIED_ADULT_ECHO_SR |
SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM |
SPATIAL_FIDUCIALS |
SPATIAL_REGISTRATION |
SPECTACLE_PRESCRIPTION_REPORT |
STANDARD_BASIC_TEXT_SR |
STANDARD_BLENDING_SOFTCOPY_PS |
STANDARD_COLOR_SOFTCOPY_PS |
STANDARD_COMPREHENSIVE_SR |
STANDARD_CR |
STANDARD_CT |
STANDARD_CURVE |
STANDARD_DX_PRESENT |
STANDARD_DX_PROCESS |
STANDARD_ECHO |
STANDARD_ENCAPSULATED_PDF |
STANDARD_ENHANCED_SR |
STANDARD_GRAYSCALE_SOFTCOPY_PS |
STANDARD_HARDCOPY_COLOR |
STANDARD_HARDCOPY_GRAYSCALE |
STANDARD_IO_PRESENT |
STANDARD_IO_PROCESS |
STANDARD_IVOCT_PRESENT |
STANDARD_IVOCT_PROCESS |
STANDARD_MG_PRESENT |
STANDARD_MG_PROCESS |
STANDARD_MODALITY_LUT |
STANDARD_MR |
STANDARD_NM |
STANDARD_NM_RETIRED |
STANDARD_OPHTHALMIC_16_BIT |
STANDARD_OPHTHALMIC_8_BIT |
STANDARD_OVERLAY |
STANDARD_PET |
STANDARD_PET_CURVE |
STANDARD_PRINT_STORAGE |
STANDARD_PSEUDOCOLOR_SOFTCOPY_PS |
STANDARD_RT_BEAMS_TREAT |
STANDARD_RT_BRACHY_TREAT |
STANDARD_RT_DOSE |
STANDARD_RT_IMAGE |
STANDARD_RT_ION_BEAMS_TREAT |
STANDARD_RT_ION_PLAN |
STANDARD_RT_PLAN |
STANDARD_RT_STRUCTURE_SET |
STANDARD_RT_TREAT_SUM |
STANDARD_SEC_CAPTURE |
STANDARD_US |
STANDARD_US_MF |
STANDARD_US_MF_RETIRED |
STANDARD_US_RETIRED |
STANDARD_VIDEO_ENDOSCOPIC |
STANDARD_VIDEO_MICROSCOPIC |
STANDARD_VIDEO_PHOTOGRAPHIC |
STANDARD_VL_ENDOSCOPIC |
STANDARD_VL_MICROSCOPIC |
STANDARD_VL_PHOTOGRAPHIC |
STANDARD_VL_SLIDE_MICROSCOPIC |
STANDARD_VOI_LUT |
STANDARD_WAVEFORM_12_LEAD_ECG |
STANDARD_WAVEFORM_AMBULATORY_ECG |
STANDARD_WAVEFORM_BASIC_VOICE_AUDIO |
STANDARD_WAVEFORM_CARDIAC_EP |
STANDARD_WAVEFORM_GENERAL_32_BIT_ECG |
STANDARD_WAVEFORM_GENERAL_ECG |
STANDARD_WAVEFORM_HEMODYNAMIC |
STANDARD_XRAY_ANGIO |
STANDARD_XRAY_ANGIO_BIPLANE |
STANDARD_XRAY_RF |
STEREOMETRIC_RELATIONSHIP |
STORAGE_COMMITMENT_PULL |
STORAGE_COMMITMENT_PUSH |
STUDY_COMPONENT_MANAGEMENT |
STUDY_CONTENT_NOTIFICATION |
STUDY_ROOT_QR_FIND |
STUDY_ROOT_QR_GET |
STUDY_ROOT_QR_MOVE |
SUBJ_REFRACTION_MEASUREMENTS |
SUBSTANCE_ADMIN_LOGGING |
SUBSTANCE_APPROVAL_QUERY |
SURFACE_SCAN_MESH |
SURFACE_SCAN_POINT_CLOUD |
SURFACE_SEGMENTATION |
TOMOTHERAPEUTIC_RADIATION |
TOMOTHERAPEUTIC_RADIATION_RECORD |
TRACTOGRAPHY_RESULTS |
UPS_EVENT_SOP |
UPS_EVENT_SOP_TRIAL_RETIRED |
UPS_PULL_SOP |
UPS_PULL_SOP_TRIAL_RETIRED |
UPS_PUSH_SOP |
UPS_PUSH_SOP_TRIAL_RETIRED |
UPS_QUERY_SOP |
UPS_WATCH_SOP |
UPS_WATCH_SOP_TRIAL_RETIRED |
VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE |
VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION |
VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION |
VISUAL_ACUITY_MEASUREMENTS |
VL_WHOLE_SLIDE_MICROSCOPY_IMAGE |
VOI_LUT_BOX |
VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES |
WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ |
XA_DEFINED_PROCEDURE_PROTOCOL |
XA_PERFORMED_PROCEDURE_PROTOCOL |
XA_XRF_GRAYSCALE_SOFTCOPY_PS |
XRAY_3D_ANGIO_IMAGE |
XRAY_3D_CRANIO_IMAGE |
XRAY_RADIATION_DOSE_SR |

See Also

MCservices Structure


MCservices Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCservices Fields
MCservices Structure See Also Send Feedback

The MCservices type exposes the following members.

Fields

Name | Description
ACQUISITION_CONTEXT_SR |
ADVANCED_BLENDING_PRESENTATION_STATE |
ARTERIAL_PULSE_WAVEFORM |
AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION |
AUTOREFRACTION_MEASUREMENTS |
BASIC_ANNOTATION_BOX |
BASIC_COLOR_IMAGE_BOX |
BASIC_FILM_BOX |
BASIC_FILM_SESSION |
BASIC_GRAYSCALE_IMAGE_BOX |
BASIC_PRINT_IMAGE_OVERLAY_BOX |
BASIC_STRUCTURED_DISPLAY |
BODY_POSITION_WAVEFORM |
BREAST_IMAGING_RPI_QUERY |
BREAST_PROJ_PRESENT |
BREAST_PROJ_PROCESS |
BREAST_TOMO_IMAGE_STORAGE |
C_ARM_PHOTON_ELECTRON_RADIATION |
C_ARM_PHOTON_ELECTRON_RADIATION_RECORD |
CARDIAC_RPI_QUERY |
CHEST_CAD_SR |
COLON_CAD_SR |
COLOR_PALETTE_FIND |
COLOR_PALETTE_GET |
COLOR_PALETTE_MOVE |
COLOR_PALETTE_STORAGE |
COMPOSITE_INST_RET_NO_BULK_GET |
COMPOSITE_INSTANCE_ROOT_RET_GET |
COMPOSITE_INSTANCE_ROOT_RET_MOVE |
COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS |
COMPREHENSIVE_3D_SR |
CONTENT_ASSESSMENT_RESULTS |
CORNEAL_TOPOGRAPHY_MAP |
CT_DEFINED_PROCEDURE_PROTOCOL |
CT_PERFORMED_PROCEDURE_PROTOCOL |
DEFINED_PROCEDURE_PROTOCOL_FIND |
DEFINED_PROCEDURE_PROTOCOL_GET |
DEFINED_PROCEDURE_PROTOCOL_MOVE |
DEFORMABLE_SPATIAL_REGISTRATION |
DERMOSCOPIC_PHOTOGRAPHY_IMAGE |
DETACHED_INTERP_MANAGEMENT |
DETACHED_PATIENT_MANAGEMENT |
DETACHED_RESULTS_MANAGEMENT |
DETACHED_STUDY_MANAGEMENT |
DETACHED_VISIT_MANAGEMENT |
DICOMDIR |
DISPLAY_SYSTEM |
ELECTROMYOGRAM_WAVEFORM |
ELECTROOCULOGRAM_WAVEFORM |
ENCAPSULATED_CDA |
ENCAPSULATED_MTL |
ENCAPSULATED_OBJ |
ENCAPSULATED_STL |
ENHANCED_CONTINUOUS_RT_IMAGE |
ENHANCED_CT_IMAGE |
ENHANCED_MR_COLOR_IMAGE |
ENHANCED_MR_IMAGE |
ENHANCED_PET_IMAGE |
ENHANCED_RT_IMAGE |
ENHANCED_US_VOLUME |
ENHANCED_XA_IMAGE |
ENHANCED_XRAY_RADIATION_DOSE_SR |
ENHANCED_XRF_IMAGE |
EXTENSIBLE_SR |
G_P_PERFORMED_PROCEDURE_STEP_RETIRED |
G_P_SCHEDULED_PROCEDURE_STEP_RETIRED |
G_P_WORKLIST_RETIRED |
GENERAL_AUDIO_WAVEFORM |
GENERAL_RPI_QUERY |
GENERIC_IMPLANT_TEMPLATE |
GENERIC_IMPLANT_TEMPLATE_FIND |
GENERIC_IMPLANT_TEMPLATE_GET |
GENERIC_IMPLANT_TEMPLATE_MOVE |
GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS |
HANGING_PROTOCOL |
HANGING_PROTOCOL_FIND |
HANGING_PROTOCOL_GET |
HANGING_PROTOCOL_MOVE |
IMAGE_OVERLAY_BOX_RETIRED |
IMPLANT_ASSEMBLY_TEMPLATE |
IMPLANT_ASSEMBLY_TEMPLATE_FIND |
IMPLANT_ASSEMBLY_TEMPLATE_GET |
IMPLANT_ASSEMBLY_TEMPLATE_MOVE |
IMPLANT_TEMPLATE_GROUP |
IMPLANT_TEMPLATE_GROUP_FIND |
IMPLANT_TEMPLATE_GROUP_GET |
IMPLANT_TEMPLATE_GROUP_MOVE |
IMPLANTATION_PLAN_SR_DOCUMENT |
INSTANCE_AVAIL_NOTIFICATION |
INTRAOCULAR_LENS_CALCULATIONS |
INVENTORY |
INVENTORY_CREATION |
INVENTORY_FIND |
INVENTORY_GET |
INVENTORY_MOVE |
KERATOMETRY_MEASUREMENTS |
KEY_OBJECT_SELECTION_DOC |
LEGACY_CONVERTED_ENHANCED_CT_IMAGE |
LEGACY_CONVERTED_ENHANCED_MR_IMAGE |
LEGACY_CONVERTED_ENHANCED_PET_IMAGE |
LENSOMETRY_MEASUREMENTS |
MACULAR_GRID_THIICKNESS_VOLUME |
MAMMOGRAPHY_CAD_SR |
MEDIA_CREATION_MANAGEMENT |
MICROSCOPY_BULK_SIMPLE_ANNOTATIONS |
MODALITY_WORKLIST_FIND |
MR_SPECTROSCOPY |
MULTI_CHANNEL_RESPIRATORY_WAVEFORM |
MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
OPHT_VIS_FIELD_STATIC_PERIM_MEAS |
OPHTHALMIC_AXIAL_MEASUREMENTS |
OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS |
OPHTHALMIC_OCT_EN_FACE_IMAGE |
OPHTHALMIC_TOMOGRAPHY_IMAGE |
OPM_THICKNESS_MAP |
PARAMETRIC_MAP |
PATIENT_RADIATION_DOSE_SR |
PATIENT_ROOT_QR_FIND |
PATIENT_ROOT_QR_GET |
PATIENT_ROOT_QR_MOVE |
PATIENT_STUDY_ONLY_QR_FIND_RETIRED |
PATIENT_STUDY_ONLY_QR_GET_RETIRED |
PATIENT_STUDY_ONLY_QR_MOVE_RETIRED |
PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR |
PERFORMED_PROCEDURE_STEP |
PERFORMED_PROCEDURE_STEP_NOTIFY |
PERFORMED_PROCEDURE_STEP_RETRIEVE |
PHOTOACOUSTIC_IMAGE |
PLANNED_IMAGING_AGENT_ADMINISTRATION_SR |
PRESENTATION_LUT |
PRINT_JOB |
PRINT_QUEUE_MANAGEMENT |
PRINTER |
PRINTER_CONFIGURATION |
PROCEDURAL_EVENT_LOGGING |
PROCEDURE_LOG |
PRODUCT_CHARACTERISTICS_QUERY |
PROTOCOL_APPROVAL |
PROTOCOL_APPROVAL_FIND |
PROTOCOL_APPROVAL_GET |
PROTOCOL_APPROVAL_MOVE |
PULL_PRINT_REQUEST |
RADIOPHARMACEUTICAL_RADIATION_DOSE_SR |
RAW_DATA |
REAL_WORLD_VALUE_MAPPING |
REFERENCED_IMAGE_BOX |
RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION |
REPOSITORY_QUERY |
RESPIRATORY_WAVEFORM |
ROBOTIC_ARM_RADIATION |
ROBOTIC_ARM_RADIATION_RECORD |
ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM |
RT_BEAMS_DELIVERY_INSTR_RET |
RT_BEAMS_DELIVERY_INSTRUCTION |
RT_BRACHY_APP_SETUP_DELIVERY_INSTR |
RT_CONV_MACHINE_VERIF_RET |
RT_CONVENTIONAL_MACHINE_VERIFICATION |
RT_ION_MACHINE_VERIF_RET |
RT_ION_MACHINE_VERIFICATION |
RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION |
RT_PHYSICIAN_INTENT |
RT_RADIATION_RECORD_SET |
RT_RADIATION_SALVAGE_RECORD |
RT_RADIATION_SET |
RT_RADIATION_SET_DELIVERY_INSTRUCTION |
RT_SEGMENT_ANNOTATION |
RT_TREATMENT_PREPARATION |
SC_MULTIFRAME_GRAYSCALE_BYTE |
SC_MULTIFRAME_GRAYSCALE_WORD |
SC_MULTIFRAME_SINGLE_BIT |
SC_MULTIFRAME_TRUE_COLOR |
SEGMENTATION |
SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
SIMPLIFIED_ADULT_ECHO_SR |
SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM |
SPATIAL_FIDUCIALS |
SPATIAL_REGISTRATION |
SPECTACLE_PRESCRIPTION_REPORT |
STANDARD_BASIC_TEXT_SR |
STANDARD_BLENDING_SOFTCOPY_PS |
STANDARD_COLOR_SOFTCOPY_PS |
STANDARD_COMPREHENSIVE_SR |
STANDARD_CR |
STANDARD_CT |
STANDARD_CURVE |
STANDARD_DX_PRESENT |
STANDARD_DX_PROCESS |
STANDARD_ECHO |
STANDARD_ENCAPSULATED_PDF |
STANDARD_ENHANCED_SR |
STANDARD_GRAYSCALE_SOFTCOPY_PS |
STANDARD_HARDCOPY_COLOR |
STANDARD_HARDCOPY_GRAYSCALE |
STANDARD_IO_PRESENT |
STANDARD_IO_PROCESS |
STANDARD_IVOCT_PRESENT |
STANDARD_IVOCT_PROCESS |
STANDARD_MG_PRESENT |
STANDARD_MG_PROCESS |
STANDARD_MODALITY_LUT |
STANDARD_MR |
STANDARD_NM |
STANDARD_NM_RETIRED |
STANDARD_OPHTHALMIC_16_BIT |
STANDARD_OPHTHALMIC_8_BIT |
STANDARD_OVERLAY |
STANDARD_PET |
STANDARD_PET_CURVE |
STANDARD_PRINT_STORAGE |
STANDARD_PSEUDOCOLOR_SOFTCOPY_PS |
STANDARD_RT_BEAMS_TREAT |
STANDARD_RT_BRACHY_TREAT |
STANDARD_RT_DOSE |
STANDARD_RT_IMAGE |
STANDARD_RT_ION_BEAMS_TREAT |
STANDARD_RT_ION_PLAN |
STANDARD_RT_PLAN |
STANDARD_RT_STRUCTURE_SET |
STANDARD_RT_TREAT_SUM |
STANDARD_SEC_CAPTURE |
STANDARD_US |
STANDARD_US_MF |
STANDARD_US_MF_RETIRED |
STANDARD_US_RETIRED |
STANDARD_VIDEO_ENDOSCOPIC |
STANDARD_VIDEO_MICROSCOPIC |
STANDARD_VIDEO_PHOTOGRAPHIC |
STANDARD_VL_ENDOSCOPIC |
STANDARD_VL_MICROSCOPIC |
STANDARD_VL_PHOTOGRAPHIC |
STANDARD_VL_SLIDE_MICROSCOPIC |
STANDARD_VOI_LUT |
STANDARD_WAVEFORM_12_LEAD_ECG |
STANDARD_WAVEFORM_AMBULATORY_ECG |
STANDARD_WAVEFORM_BASIC_VOICE_AUDIO |
STANDARD_WAVEFORM_CARDIAC_EP |
STANDARD_WAVEFORM_GENERAL_32_BIT_ECG |
STANDARD_WAVEFORM_GENERAL_ECG |
STANDARD_WAVEFORM_HEMODYNAMIC |
STANDARD_XRAY_ANGIO |
STANDARD_XRAY_ANGIO_BIPLANE |
STANDARD_XRAY_RF |
STEREOMETRIC_RELATIONSHIP |
STORAGE_COMMITMENT_PULL |
STORAGE_COMMITMENT_PUSH |
STUDY_COMPONENT_MANAGEMENT |
STUDY_CONTENT_NOTIFICATION |
STUDY_ROOT_QR_FIND |
STUDY_ROOT_QR_GET |
STUDY_ROOT_QR_MOVE |
SUBJ_REFRACTION_MEASUREMENTS |
SUBSTANCE_ADMIN_LOGGING |
SUBSTANCE_APPROVAL_QUERY |
SURFACE_SCAN_MESH |
SURFACE_SCAN_POINT_CLOUD |
SURFACE_SEGMENTATION |
TOMOTHERAPEUTIC_RADIATION |
TOMOTHERAPEUTIC_RADIATION_RECORD |
TRACTOGRAPHY_RESULTS |
UPS_EVENT_SOP |
UPS_EVENT_SOP_TRIAL_RETIRED |
UPS_PULL_SOP |
UPS_PULL_SOP_TRIAL_RETIRED |
UPS_PUSH_SOP |
UPS_PUSH_SOP_TRIAL_RETIRED |
UPS_QUERY_SOP |
UPS_WATCH_SOP |
UPS_WATCH_SOP_TRIAL_RETIRED |
VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE |
VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION |
VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION |
VISUAL_ACUITY_MEASUREMENTS |
VL_WHOLE_SLIDE_MICROSCOPY_IMAGE |
VOI_LUT_BOX |
VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE |
WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES |
WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ |
XA_DEFINED_PROCEDURE_PROTOCOL |
XA_PERFORMED_PROCEDURE_PROTOCOL |
XA_XRF_GRAYSCALE_SOFTCOPY_PS |
XRAY_3D_ANGIO_IMAGE |
XRAY_3D_CRANIO_IMAGE |
XRAY_RADIATION_DOSE_SR |

See Also

MCservices Structure


ACQUISITION_CONTEXT_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ACQUISITION_CONTEXT_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ACQUISITION_CONTEXT_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ACQUISITION_CONTEXT_SR
Visual Basic
Public Shared ReadOnly ACQUISITION_CONTEXT_SR As String
Visual C++
public:
static initonly String^ ACQUISITION_CONTEXT_SR

See Also

MCservices Structure
MCservices Members


ADVANCED_BLENDING_PRESENTATION_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ADVANCED_BLENDING_PRESENTATION_STATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ADVANCED_BLENDING_PRESENTATION_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ADVANCED_BLENDING_PRESENTATION_STATE
Visual Basic
Public Shared ReadOnly ADVANCED_BLENDING_PRESENTATION_STATE As String
Visual C++
public:
static initonly String^ ADVANCED_BLENDING_PRESENTATION_STATE

See Also

MCservices Structure
MCservices Members


ARTERIAL_PULSE_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ARTERIAL_PULSE_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ARTERIAL_PULSE_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ARTERIAL_PULSE_WAVEFORM
Visual Basic
Public Shared ReadOnly ARTERIAL_PULSE_WAVEFORM As String
Visual C++
public:
static initonly String^ ARTERIAL_PULSE_WAVEFORM

See Also

MCservices Structure
MCservices Members


AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION
Visual Basic
Public Shared ReadOnly AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION As String
Visual C++
public:
static initonly String^ AUDIO_WAVEFORM_REAL_TIME_COMMUNICATION

See Also

MCservices Structure
MCservices Members


AUTOREFRACTION_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..AUTOREFRACTION_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.AUTOREFRACTION_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string AUTOREFRACTION_MEASUREMENTS
Visual Basic
Public Shared ReadOnly AUTOREFRACTION_MEASUREMENTS As String
Visual C++
public:
static initonly String^ AUTOREFRACTION_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


BASIC_ANNOTATION_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_ANNOTATION_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_ANNOTATION_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_ANNOTATION_BOX
Visual Basic
Public Shared ReadOnly BASIC_ANNOTATION_BOX As String
Visual C++
public:
static initonly String^ BASIC_ANNOTATION_BOX

See Also

MCservices Structure
MCservices Members


BASIC_COLOR_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_COLOR_IMAGE_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_COLOR_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_COLOR_IMAGE_BOX
Visual Basic
Public Shared ReadOnly BASIC_COLOR_IMAGE_BOX As String
Visual C++
public:
static initonly String^ BASIC_COLOR_IMAGE_BOX

See Also

MCservices Structure
MCservices Members


BASIC_FILM_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_FILM_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_FILM_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_FILM_BOX
Visual Basic
Public Shared ReadOnly BASIC_FILM_BOX As String
Visual C++
public:
static initonly String^ BASIC_FILM_BOX

See Also

MCservices Structure
MCservices Members


BASIC_FILM_SESSION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_FILM_SESSION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_FILM_SESSION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_FILM_SESSION
Visual Basic
Public Shared ReadOnly BASIC_FILM_SESSION As String
Visual C++
public:
static initonly String^ BASIC_FILM_SESSION

See Also

MCservices Structure
MCservices Members


BASIC_GRAYSCALE_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_GRAYSCALE_IMAGE_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_GRAYSCALE_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_GRAYSCALE_IMAGE_BOX
Visual Basic
Public Shared ReadOnly BASIC_GRAYSCALE_IMAGE_BOX As String
Visual C++
public:
static initonly String^ BASIC_GRAYSCALE_IMAGE_BOX

See Also

MCservices Structure
MCservices Members


BASIC_PRINT_IMAGE_OVERLAY_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_PRINT_IMAGE_OVERLAY_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_PRINT_IMAGE_OVERLAY_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_PRINT_IMAGE_OVERLAY_BOX
Visual Basic
Public Shared ReadOnly BASIC_PRINT_IMAGE_OVERLAY_BOX As String
Visual C++
public:
static initonly String^ BASIC_PRINT_IMAGE_OVERLAY_BOX

See Also

MCservices Structure
MCservices Members


BASIC_STRUCTURED_DISPLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BASIC_STRUCTURED_DISPLAY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BASIC_STRUCTURED_DISPLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BASIC_STRUCTURED_DISPLAY
Visual Basic
Public Shared ReadOnly BASIC_STRUCTURED_DISPLAY As String
Visual C++
public:
static initonly String^ BASIC_STRUCTURED_DISPLAY

See Also

MCservices Structure
MCservices Members


BODY_POSITION_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BODY_POSITION_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BODY_POSITION_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BODY_POSITION_WAVEFORM
Visual Basic
Public Shared ReadOnly BODY_POSITION_WAVEFORM As String
Visual C++
public:
static initonly String^ BODY_POSITION_WAVEFORM

See Also

MCservices Structure
MCservices Members


BREAST_IMAGING_RPI_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BREAST_IMAGING_RPI_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BREAST_IMAGING_RPI_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_IMAGING_RPI_QUERY
Visual Basic
Public Shared ReadOnly BREAST_IMAGING_RPI_QUERY As String
Visual C++
public:
static initonly String^ BREAST_IMAGING_RPI_QUERY

See Also

MCservices Structure
MCservices Members


BREAST_PROJ_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BREAST_PROJ_PRESENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BREAST_PROJ_PRESENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_PROJ_PRESENT
Visual Basic
Public Shared ReadOnly BREAST_PROJ_PRESENT As String
Visual C++
public:
static initonly String^ BREAST_PROJ_PRESENT

See Also

MCservices Structure
MCservices Members


BREAST_PROJ_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BREAST_PROJ_PROCESS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BREAST_PROJ_PROCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_PROJ_PROCESS
Visual Basic
Public Shared ReadOnly BREAST_PROJ_PROCESS As String
Visual C++
public:
static initonly String^ BREAST_PROJ_PROCESS

See Also

MCservices Structure
MCservices Members


BREAST_TOMO_IMAGE_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..BREAST_TOMO_IMAGE_STORAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.BREAST_TOMO_IMAGE_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string BREAST_TOMO_IMAGE_STORAGE
Visual Basic
Public Shared ReadOnly BREAST_TOMO_IMAGE_STORAGE As String
Visual C++
public:
static initonly String^ BREAST_TOMO_IMAGE_STORAGE

See Also

MCservices Structure
MCservices Members


C_ARM_PHOTON_ELECTRON_RADIATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..C_ARM_PHOTON_ELECTRON_RADIATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.C_ARM_PHOTON_ELECTRON_RADIATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string C_ARM_PHOTON_ELECTRON_RADIATION
Visual Basic
Public Shared ReadOnly C_ARM_PHOTON_ELECTRON_RADIATION As String
Visual C++
public:
static initonly String^ C_ARM_PHOTON_ELECTRON_RADIATION

See Also

MCservices Structure
MCservices Members


C_ARM_PHOTON_ELECTRON_RADIATION_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..C_ARM_PHOTON_ELECTRON_RADIATION_RECORD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.C_ARM_PHOTON_ELECTRON_RADIATION_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string C_ARM_PHOTON_ELECTRON_RADIATION_RECORD
Visual Basic
Public Shared ReadOnly C_ARM_PHOTON_ELECTRON_RADIATION_RECORD As String
Visual C++
public:
static initonly String^ C_ARM_PHOTON_ELECTRON_RADIATION_RECORD

See Also

MCservices Structure
MCservices Members


CARDIAC_RPI_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CARDIAC_RPI_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CARDIAC_RPI_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CARDIAC_RPI_QUERY
Visual Basic
Public Shared ReadOnly CARDIAC_RPI_QUERY As String
Visual C++
public:
static initonly String^ CARDIAC_RPI_QUERY

See Also

MCservices Structure
MCservices Members


CHEST_CAD_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CHEST_CAD_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CHEST_CAD_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CHEST_CAD_SR
Visual Basic
Public Shared ReadOnly CHEST_CAD_SR As String
Visual C++
public:
static initonly String^ CHEST_CAD_SR

See Also

MCservices Structure
MCservices Members


COLON_CAD_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COLON_CAD_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COLON_CAD_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLON_CAD_SR
Visual Basic
Public Shared ReadOnly COLON_CAD_SR As String
Visual C++
public:
static initonly String^ COLON_CAD_SR

See Also

MCservices Structure
MCservices Members


COLOR_PALETTE_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COLOR_PALETTE_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COLOR_PALETTE_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLOR_PALETTE_FIND
Visual Basic
Public Shared ReadOnly COLOR_PALETTE_FIND As String
Visual C++
public:
static initonly String^ COLOR_PALETTE_FIND

See Also

MCservices Structure
MCservices Members


COLOR_PALETTE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COLOR_PALETTE_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COLOR_PALETTE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLOR_PALETTE_GET
Visual Basic
Public Shared ReadOnly COLOR_PALETTE_GET As String
Visual C++
public:
static initonly String^ COLOR_PALETTE_GET

See Also

MCservices Structure
MCservices Members


COLOR_PALETTE_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COLOR_PALETTE_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COLOR_PALETTE_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLOR_PALETTE_MOVE
Visual Basic
Public Shared ReadOnly COLOR_PALETTE_MOVE As String
Visual C++
public:
static initonly String^ COLOR_PALETTE_MOVE

See Also

MCservices Structure
MCservices Members


COLOR_PALETTE_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COLOR_PALETTE_STORAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COLOR_PALETTE_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COLOR_PALETTE_STORAGE
Visual Basic
Public Shared ReadOnly COLOR_PALETTE_STORAGE As String
Visual C++
public:
static initonly String^ COLOR_PALETTE_STORAGE

See Also

MCservices Structure
MCservices Members


COMPOSITE_INST_RET_NO_BULK_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COMPOSITE_INST_RET_NO_BULK_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COMPOSITE_INST_RET_NO_BULK_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPOSITE_INST_RET_NO_BULK_GET
Visual Basic
Public Shared ReadOnly COMPOSITE_INST_RET_NO_BULK_GET As String
Visual C++
public:
static initonly String^ COMPOSITE_INST_RET_NO_BULK_GET

See Also

MCservices Structure
MCservices Members


COMPOSITE_INSTANCE_ROOT_RET_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COMPOSITE_INSTANCE_ROOT_RET_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COMPOSITE_INSTANCE_ROOT_RET_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPOSITE_INSTANCE_ROOT_RET_GET
Visual Basic
Public Shared ReadOnly COMPOSITE_INSTANCE_ROOT_RET_GET As String
Visual C++
public:
static initonly String^ COMPOSITE_INSTANCE_ROOT_RET_GET

See Also

MCservices Structure
MCservices Members


COMPOSITE_INSTANCE_ROOT_RET_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COMPOSITE_INSTANCE_ROOT_RET_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COMPOSITE_INSTANCE_ROOT_RET_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPOSITE_INSTANCE_ROOT_RET_MOVE
Visual Basic
Public Shared ReadOnly COMPOSITE_INSTANCE_ROOT_RET_MOVE As String
Visual C++
public:
static initonly String^ COMPOSITE_INSTANCE_ROOT_RET_MOVE

See Also

MCservices Structure
MCservices Members


COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS
Visual Basic
Public Shared ReadOnly COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS As String
Visual C++
public:
static initonly String^ COMPOSITING_PLANAR_MPR_VOLUMETRIC_PS

See Also

MCservices Structure
MCservices Members


COMPREHENSIVE_3D_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..COMPREHENSIVE_3D_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.COMPREHENSIVE_3D_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string COMPREHENSIVE_3D_SR
Visual Basic
Public Shared ReadOnly COMPREHENSIVE_3D_SR As String
Visual C++
public:
static initonly String^ COMPREHENSIVE_3D_SR

See Also

MCservices Structure
MCservices Members


CONTENT_ASSESSMENT_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CONTENT_ASSESSMENT_RESULTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CONTENT_ASSESSMENT_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CONTENT_ASSESSMENT_RESULTS
Visual Basic
Public Shared ReadOnly CONTENT_ASSESSMENT_RESULTS As String
Visual C++
public:
static initonly String^ CONTENT_ASSESSMENT_RESULTS

See Also

MCservices Structure
MCservices Members


CORNEAL_TOPOGRAPHY_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CORNEAL_TOPOGRAPHY_MAP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CORNEAL_TOPOGRAPHY_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CORNEAL_TOPOGRAPHY_MAP
Visual Basic
Public Shared ReadOnly CORNEAL_TOPOGRAPHY_MAP As String
Visual C++
public:
static initonly String^ CORNEAL_TOPOGRAPHY_MAP

See Also

MCservices Structure
MCservices Members


CT_DEFINED_PROCEDURE_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CT_DEFINED_PROCEDURE_PROTOCOL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CT_DEFINED_PROCEDURE_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_DEFINED_PROCEDURE_PROTOCOL
Visual Basic
Public Shared ReadOnly CT_DEFINED_PROCEDURE_PROTOCOL As String
Visual C++
public:
static initonly String^ CT_DEFINED_PROCEDURE_PROTOCOL

See Also

MCservices Structure
MCservices Members


CT_PERFORMED_PROCEDURE_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..CT_PERFORMED_PROCEDURE_PROTOCOL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.CT_PERFORMED_PROCEDURE_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string CT_PERFORMED_PROCEDURE_PROTOCOL
Visual Basic
Public Shared ReadOnly CT_PERFORMED_PROCEDURE_PROTOCOL As String
Visual C++
public:
static initonly String^ CT_PERFORMED_PROCEDURE_PROTOCOL

See Also

MCservices Structure
MCservices Members


DEFINED_PROCEDURE_PROTOCOL_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DEFINED_PROCEDURE_PROTOCOL_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DEFINED_PROCEDURE_PROTOCOL_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINED_PROCEDURE_PROTOCOL_FIND
Visual Basic
Public Shared ReadOnly DEFINED_PROCEDURE_PROTOCOL_FIND As String
Visual C++
public:
static initonly String^ DEFINED_PROCEDURE_PROTOCOL_FIND

See Also

MCservices Structure
MCservices Members


DEFINED_PROCEDURE_PROTOCOL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DEFINED_PROCEDURE_PROTOCOL_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DEFINED_PROCEDURE_PROTOCOL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINED_PROCEDURE_PROTOCOL_GET
Visual Basic
Public Shared ReadOnly DEFINED_PROCEDURE_PROTOCOL_GET As String
Visual C++
public:
static initonly String^ DEFINED_PROCEDURE_PROTOCOL_GET

See Also

MCservices Structure
MCservices Members


DEFINED_PROCEDURE_PROTOCOL_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DEFINED_PROCEDURE_PROTOCOL_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DEFINED_PROCEDURE_PROTOCOL_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFINED_PROCEDURE_PROTOCOL_MOVE
Visual Basic
Public Shared ReadOnly DEFINED_PROCEDURE_PROTOCOL_MOVE As String
Visual C++
public:
static initonly String^ DEFINED_PROCEDURE_PROTOCOL_MOVE

See Also

MCservices Structure
MCservices Members


DEFORMABLE_SPATIAL_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DEFORMABLE_SPATIAL_REGISTRATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DEFORMABLE_SPATIAL_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DEFORMABLE_SPATIAL_REGISTRATION
Visual Basic
Public Shared ReadOnly DEFORMABLE_SPATIAL_REGISTRATION As String
Visual C++
public:
static initonly String^ DEFORMABLE_SPATIAL_REGISTRATION

See Also

MCservices Structure
MCservices Members


DERMOSCOPIC_PHOTOGRAPHY_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DERMOSCOPIC_PHOTOGRAPHY_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DERMOSCOPIC_PHOTOGRAPHY_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DERMOSCOPIC_PHOTOGRAPHY_IMAGE
Visual Basic
Public Shared ReadOnly DERMOSCOPIC_PHOTOGRAPHY_IMAGE As String
Visual C++
public:
static initonly String^ DERMOSCOPIC_PHOTOGRAPHY_IMAGE

See Also

MCservices Structure
MCservices Members


DETACHED_INTERP_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DETACHED_INTERP_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DETACHED_INTERP_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETACHED_INTERP_MANAGEMENT
Visual Basic
Public Shared ReadOnly DETACHED_INTERP_MANAGEMENT As String
Visual C++
public:
static initonly String^ DETACHED_INTERP_MANAGEMENT

See Also

MCservices Structure
MCservices Members


DETACHED_PATIENT_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DETACHED_PATIENT_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DETACHED_PATIENT_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETACHED_PATIENT_MANAGEMENT
Visual Basic
Public Shared ReadOnly DETACHED_PATIENT_MANAGEMENT As String
Visual C++
public:
static initonly String^ DETACHED_PATIENT_MANAGEMENT

See Also

MCservices Structure
MCservices Members


DETACHED_RESULTS_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DETACHED_RESULTS_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DETACHED_RESULTS_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETACHED_RESULTS_MANAGEMENT
Visual Basic
Public Shared ReadOnly DETACHED_RESULTS_MANAGEMENT As String
Visual C++
public:
static initonly String^ DETACHED_RESULTS_MANAGEMENT

See Also

MCservices Structure
MCservices Members


DETACHED_STUDY_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DETACHED_STUDY_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DETACHED_STUDY_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETACHED_STUDY_MANAGEMENT
Visual Basic
Public Shared ReadOnly DETACHED_STUDY_MANAGEMENT As String
Visual C++
public:
static initonly String^ DETACHED_STUDY_MANAGEMENT

See Also

MCservices Structure
MCservices Members


DETACHED_VISIT_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DETACHED_VISIT_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DETACHED_VISIT_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DETACHED_VISIT_MANAGEMENT
Visual Basic
Public Shared ReadOnly DETACHED_VISIT_MANAGEMENT As String
Visual C++
public:
static initonly String^ DETACHED_VISIT_MANAGEMENT

See Also

MCservices Structure
MCservices Members


DICOMDIR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DICOMDIR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DICOMDIR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DICOMDIR
Visual Basic
Public Shared ReadOnly DICOMDIR As String
Visual C++
public:
static initonly String^ DICOMDIR

See Also

MCservices Structure
MCservices Members


DISPLAY_SYSTEM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..DISPLAY_SYSTEM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.DISPLAY_SYSTEM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string DISPLAY_SYSTEM
Visual Basic
Public Shared ReadOnly DISPLAY_SYSTEM As String
Visual C++
public:
static initonly String^ DISPLAY_SYSTEM

See Also

MCservices Structure
MCservices Members


ELECTROMYOGRAM_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ELECTROMYOGRAM_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ELECTROMYOGRAM_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ELECTROMYOGRAM_WAVEFORM
Visual Basic
Public Shared ReadOnly ELECTROMYOGRAM_WAVEFORM As String
Visual C++
public:
static initonly String^ ELECTROMYOGRAM_WAVEFORM

See Also

MCservices Structure
MCservices Members


ELECTROOCULOGRAM_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ELECTROOCULOGRAM_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ELECTROOCULOGRAM_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ELECTROOCULOGRAM_WAVEFORM
Visual Basic
Public Shared ReadOnly ELECTROOCULOGRAM_WAVEFORM As String
Visual C++
public:
static initonly String^ ELECTROOCULOGRAM_WAVEFORM

See Also

MCservices Structure
MCservices Members


ENCAPSULATED_CDA Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENCAPSULATED_CDA Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENCAPSULATED_CDA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENCAPSULATED_CDA
Visual Basic
Public Shared ReadOnly ENCAPSULATED_CDA As String
Visual C++
public:
static initonly String^ ENCAPSULATED_CDA

See Also

MCservices Structure
MCservices Members


ENCAPSULATED_MTL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENCAPSULATED_MTL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENCAPSULATED_MTL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENCAPSULATED_MTL
Visual Basic
Public Shared ReadOnly ENCAPSULATED_MTL As String
Visual C++
public:
static initonly String^ ENCAPSULATED_MTL

See Also

MCservices Structure
MCservices Members


ENCAPSULATED_OBJ Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENCAPSULATED_OBJ Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENCAPSULATED_OBJ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENCAPSULATED_OBJ
Visual Basic
Public Shared ReadOnly ENCAPSULATED_OBJ As String
Visual C++
public:
static initonly String^ ENCAPSULATED_OBJ

See Also

MCservices Structure
MCservices Members


ENCAPSULATED_STL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENCAPSULATED_STL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENCAPSULATED_STL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENCAPSULATED_STL
Visual Basic
Public Shared ReadOnly ENCAPSULATED_STL As String
Visual C++
public:
static initonly String^ ENCAPSULATED_STL

See Also

MCservices Structure
MCservices Members


ENHANCED_CONTINUOUS_RT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_CONTINUOUS_RT_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_CONTINUOUS_RT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_CONTINUOUS_RT_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_CONTINUOUS_RT_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_CONTINUOUS_RT_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_CT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_CT_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_CT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_CT_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_CT_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_CT_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_MR_COLOR_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_MR_COLOR_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_MR_COLOR_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_MR_COLOR_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_MR_COLOR_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_MR_COLOR_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_MR_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_MR_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_MR_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_MR_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_MR_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_MR_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_PET_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_PET_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_PET_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_PET_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_PET_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_PET_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_RT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_RT_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_RT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_RT_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_RT_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_RT_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_US_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_US_VOLUME Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_US_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_US_VOLUME
Visual Basic
Public Shared ReadOnly ENHANCED_US_VOLUME As String
Visual C++
public:
static initonly String^ ENHANCED_US_VOLUME

See Also

MCservices Structure
MCservices Members


ENHANCED_XA_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_XA_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_XA_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_XA_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_XA_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_XA_IMAGE

See Also

MCservices Structure
MCservices Members


ENHANCED_XRAY_RADIATION_DOSE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_XRAY_RADIATION_DOSE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_XRAY_RADIATION_DOSE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_XRAY_RADIATION_DOSE_SR
Visual Basic
Public Shared ReadOnly ENHANCED_XRAY_RADIATION_DOSE_SR As String
Visual C++
public:
static initonly String^ ENHANCED_XRAY_RADIATION_DOSE_SR

See Also

MCservices Structure
MCservices Members


ENHANCED_XRF_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ENHANCED_XRF_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ENHANCED_XRF_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ENHANCED_XRF_IMAGE
Visual Basic
Public Shared ReadOnly ENHANCED_XRF_IMAGE As String
Visual C++
public:
static initonly String^ ENHANCED_XRF_IMAGE

See Also

MCservices Structure
MCservices Members


EXTENSIBLE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..EXTENSIBLE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.EXTENSIBLE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string EXTENSIBLE_SR
Visual Basic
Public Shared ReadOnly EXTENSIBLE_SR As String
Visual C++
public:
static initonly String^ EXTENSIBLE_SR

See Also

MCservices Structure
MCservices Members


G_P_PERFORMED_PROCEDURE_STEP_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..G_P_PERFORMED_PROCEDURE_STEP_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.G_P_PERFORMED_PROCEDURE_STEP_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string G_P_PERFORMED_PROCEDURE_STEP_RETIRED
Visual Basic
Public Shared ReadOnly G_P_PERFORMED_PROCEDURE_STEP_RETIRED As String
Visual C++
public:
static initonly String^ G_P_PERFORMED_PROCEDURE_STEP_RETIRED

See Also

MCservices Structure
MCservices Members


G_P_SCHEDULED_PROCEDURE_STEP_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..G_P_SCHEDULED_PROCEDURE_STEP_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.G_P_SCHEDULED_PROCEDURE_STEP_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string G_P_SCHEDULED_PROCEDURE_STEP_RETIRED
Visual Basic
Public Shared ReadOnly G_P_SCHEDULED_PROCEDURE_STEP_RETIRED As String
Visual C++
public:
static initonly String^ G_P_SCHEDULED_PROCEDURE_STEP_RETIRED

See Also

MCservices Structure
MCservices Members


G_P_WORKLIST_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..G_P_WORKLIST_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.G_P_WORKLIST_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string G_P_WORKLIST_RETIRED
Visual Basic
Public Shared ReadOnly G_P_WORKLIST_RETIRED As String
Visual C++
public:
static initonly String^ G_P_WORKLIST_RETIRED

See Also

MCservices Structure
MCservices Members


GENERAL_AUDIO_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERAL_AUDIO_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERAL_AUDIO_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_AUDIO_WAVEFORM
Visual Basic
Public Shared ReadOnly GENERAL_AUDIO_WAVEFORM As String
Visual C++
public:
static initonly String^ GENERAL_AUDIO_WAVEFORM

See Also

MCservices Structure
MCservices Members


GENERAL_RPI_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERAL_RPI_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERAL_RPI_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERAL_RPI_QUERY
Visual Basic
Public Shared ReadOnly GENERAL_RPI_QUERY As String
Visual C++
public:
static initonly String^ GENERAL_RPI_QUERY

See Also

MCservices Structure
MCservices Members


GENERIC_IMPLANT_TEMPLATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERIC_IMPLANT_TEMPLATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERIC_IMPLANT_TEMPLATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERIC_IMPLANT_TEMPLATE
Visual Basic
Public Shared ReadOnly GENERIC_IMPLANT_TEMPLATE As String
Visual C++
public:
static initonly String^ GENERIC_IMPLANT_TEMPLATE

See Also

MCservices Structure
MCservices Members


GENERIC_IMPLANT_TEMPLATE_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERIC_IMPLANT_TEMPLATE_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERIC_IMPLANT_TEMPLATE_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERIC_IMPLANT_TEMPLATE_FIND
Visual Basic
Public Shared ReadOnly GENERIC_IMPLANT_TEMPLATE_FIND As String
Visual C++
public:
static initonly String^ GENERIC_IMPLANT_TEMPLATE_FIND

See Also

MCservices Structure
MCservices Members


GENERIC_IMPLANT_TEMPLATE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERIC_IMPLANT_TEMPLATE_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERIC_IMPLANT_TEMPLATE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERIC_IMPLANT_TEMPLATE_GET
Visual Basic
Public Shared ReadOnly GENERIC_IMPLANT_TEMPLATE_GET As String
Visual C++
public:
static initonly String^ GENERIC_IMPLANT_TEMPLATE_GET

See Also

MCservices Structure
MCservices Members


GENERIC_IMPLANT_TEMPLATE_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GENERIC_IMPLANT_TEMPLATE_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GENERIC_IMPLANT_TEMPLATE_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GENERIC_IMPLANT_TEMPLATE_MOVE
Visual Basic
Public Shared ReadOnly GENERIC_IMPLANT_TEMPLATE_MOVE As String
Visual C++
public:
static initonly String^ GENERIC_IMPLANT_TEMPLATE_MOVE

See Also

MCservices Structure
MCservices Members


GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS
Visual Basic
Public Shared ReadOnly GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS As String
Visual C++
public:
static initonly String^ GRAYSCALE_PLANAR_MPR_VOLUMETRIC_PS

See Also

MCservices Structure
MCservices Members


HANGING_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..HANGING_PROTOCOL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.HANGING_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HANGING_PROTOCOL
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOL As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOL

See Also

MCservices Structure
MCservices Members


HANGING_PROTOCOL_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..HANGING_PROTOCOL_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.HANGING_PROTOCOL_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HANGING_PROTOCOL_FIND
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOL_FIND As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOL_FIND

See Also

MCservices Structure
MCservices Members


HANGING_PROTOCOL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..HANGING_PROTOCOL_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.HANGING_PROTOCOL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HANGING_PROTOCOL_GET
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOL_GET As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOL_GET

See Also

MCservices Structure
MCservices Members


HANGING_PROTOCOL_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..HANGING_PROTOCOL_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.HANGING_PROTOCOL_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string HANGING_PROTOCOL_MOVE
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOL_MOVE As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOL_MOVE

See Also

MCservices Structure
MCservices Members


IMAGE_OVERLAY_BOX_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMAGE_OVERLAY_BOX_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMAGE_OVERLAY_BOX_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMAGE_OVERLAY_BOX_RETIRED
Visual Basic
Public Shared ReadOnly IMAGE_OVERLAY_BOX_RETIRED As String
Visual C++
public:
static initonly String^ IMAGE_OVERLAY_BOX_RETIRED

See Also

MCservices Structure
MCservices Members


IMPLANT_ASSEMBLY_TEMPLATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_ASSEMBLY_TEMPLATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_ASSEMBLY_TEMPLATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_ASSEMBLY_TEMPLATE
Visual Basic
Public Shared ReadOnly IMPLANT_ASSEMBLY_TEMPLATE As String
Visual C++
public:
static initonly String^ IMPLANT_ASSEMBLY_TEMPLATE

See Also

MCservices Structure
MCservices Members


IMPLANT_ASSEMBLY_TEMPLATE_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_ASSEMBLY_TEMPLATE_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_ASSEMBLY_TEMPLATE_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_ASSEMBLY_TEMPLATE_FIND
Visual Basic
Public Shared ReadOnly IMPLANT_ASSEMBLY_TEMPLATE_FIND As String
Visual C++
public:
static initonly String^ IMPLANT_ASSEMBLY_TEMPLATE_FIND

See Also

MCservices Structure
MCservices Members


IMPLANT_ASSEMBLY_TEMPLATE_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_ASSEMBLY_TEMPLATE_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_ASSEMBLY_TEMPLATE_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_ASSEMBLY_TEMPLATE_GET
Visual Basic
Public Shared ReadOnly IMPLANT_ASSEMBLY_TEMPLATE_GET As String
Visual C++
public:
static initonly String^ IMPLANT_ASSEMBLY_TEMPLATE_GET

See Also

MCservices Structure
MCservices Members


IMPLANT_ASSEMBLY_TEMPLATE_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_ASSEMBLY_TEMPLATE_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_ASSEMBLY_TEMPLATE_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_ASSEMBLY_TEMPLATE_MOVE
Visual Basic
Public Shared ReadOnly IMPLANT_ASSEMBLY_TEMPLATE_MOVE As String
Visual C++
public:
static initonly String^ IMPLANT_ASSEMBLY_TEMPLATE_MOVE

See Also

MCservices Structure
MCservices Members


IMPLANT_TEMPLATE_GROUP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_TEMPLATE_GROUP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_TEMPLATE_GROUP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GROUP
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GROUP As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GROUP

See Also

MCservices Structure
MCservices Members


IMPLANT_TEMPLATE_GROUP_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_TEMPLATE_GROUP_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_TEMPLATE_GROUP_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GROUP_FIND
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GROUP_FIND As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GROUP_FIND

See Also

MCservices Structure
MCservices Members


IMPLANT_TEMPLATE_GROUP_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_TEMPLATE_GROUP_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_TEMPLATE_GROUP_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GROUP_GET
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GROUP_GET As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GROUP_GET

See Also

MCservices Structure
MCservices Members


IMPLANT_TEMPLATE_GROUP_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANT_TEMPLATE_GROUP_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANT_TEMPLATE_GROUP_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANT_TEMPLATE_GROUP_MOVE
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATE_GROUP_MOVE As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATE_GROUP_MOVE

See Also

MCservices Structure
MCservices Members


IMPLANTATION_PLAN_SR_DOCUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..IMPLANTATION_PLAN_SR_DOCUMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.IMPLANTATION_PLAN_SR_DOCUMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string IMPLANTATION_PLAN_SR_DOCUMENT
Visual Basic
Public Shared ReadOnly IMPLANTATION_PLAN_SR_DOCUMENT As String
Visual C++
public:
static initonly String^ IMPLANTATION_PLAN_SR_DOCUMENT

See Also

MCservices Structure
MCservices Members


INSTANCE_AVAIL_NOTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INSTANCE_AVAIL_NOTIFICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INSTANCE_AVAIL_NOTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INSTANCE_AVAIL_NOTIFICATION
Visual Basic
Public Shared ReadOnly INSTANCE_AVAIL_NOTIFICATION As String
Visual C++
public:
static initonly String^ INSTANCE_AVAIL_NOTIFICATION

See Also

MCservices Structure
MCservices Members


INTRAOCULAR_LENS_CALCULATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INTRAOCULAR_LENS_CALCULATIONS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INTRAOCULAR_LENS_CALCULATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INTRAOCULAR_LENS_CALCULATIONS
Visual Basic
Public Shared ReadOnly INTRAOCULAR_LENS_CALCULATIONS As String
Visual C++
public:
static initonly String^ INTRAOCULAR_LENS_CALCULATIONS

See Also

MCservices Structure
MCservices Members


INVENTORY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INVENTORY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INVENTORY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY
Visual Basic
Public Shared ReadOnly INVENTORY As String
Visual C++
public:
static initonly String^ INVENTORY

See Also

MCservices Structure
MCservices Members


INVENTORY_CREATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INVENTORY_CREATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INVENTORY_CREATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY_CREATION
Visual Basic
Public Shared ReadOnly INVENTORY_CREATION As String
Visual C++
public:
static initonly String^ INVENTORY_CREATION

See Also

MCservices Structure
MCservices Members


INVENTORY_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INVENTORY_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INVENTORY_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY_FIND
Visual Basic
Public Shared ReadOnly INVENTORY_FIND As String
Visual C++
public:
static initonly String^ INVENTORY_FIND

See Also

MCservices Structure
MCservices Members


INVENTORY_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INVENTORY_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INVENTORY_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY_GET
Visual Basic
Public Shared ReadOnly INVENTORY_GET As String
Visual C++
public:
static initonly String^ INVENTORY_GET

See Also

MCservices Structure
MCservices Members


INVENTORY_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..INVENTORY_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.INVENTORY_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string INVENTORY_MOVE
Visual Basic
Public Shared ReadOnly INVENTORY_MOVE As String
Visual C++
public:
static initonly String^ INVENTORY_MOVE

See Also

MCservices Structure
MCservices Members


KERATOMETRY_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..KERATOMETRY_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.KERATOMETRY_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string KERATOMETRY_MEASUREMENTS
Visual Basic
Public Shared ReadOnly KERATOMETRY_MEASUREMENTS As String
Visual C++
public:
static initonly String^ KERATOMETRY_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


KEY_OBJECT_SELECTION_DOC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..KEY_OBJECT_SELECTION_DOC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.KEY_OBJECT_SELECTION_DOC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string KEY_OBJECT_SELECTION_DOC
Visual Basic
Public Shared ReadOnly KEY_OBJECT_SELECTION_DOC As String
Visual C++
public:
static initonly String^ KEY_OBJECT_SELECTION_DOC

See Also

MCservices Structure
MCservices Members


LEGACY_CONVERTED_ENHANCED_CT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..LEGACY_CONVERTED_ENHANCED_CT_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.LEGACY_CONVERTED_ENHANCED_CT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LEGACY_CONVERTED_ENHANCED_CT_IMAGE
Visual Basic
Public Shared ReadOnly LEGACY_CONVERTED_ENHANCED_CT_IMAGE As String
Visual C++
public:
static initonly String^ LEGACY_CONVERTED_ENHANCED_CT_IMAGE

See Also

MCservices Structure
MCservices Members


LEGACY_CONVERTED_ENHANCED_MR_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..LEGACY_CONVERTED_ENHANCED_MR_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.LEGACY_CONVERTED_ENHANCED_MR_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LEGACY_CONVERTED_ENHANCED_MR_IMAGE
Visual Basic
Public Shared ReadOnly LEGACY_CONVERTED_ENHANCED_MR_IMAGE As String
Visual C++
public:
static initonly String^ LEGACY_CONVERTED_ENHANCED_MR_IMAGE

See Also

MCservices Structure
MCservices Members


LEGACY_CONVERTED_ENHANCED_PET_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..LEGACY_CONVERTED_ENHANCED_PET_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.LEGACY_CONVERTED_ENHANCED_PET_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LEGACY_CONVERTED_ENHANCED_PET_IMAGE
Visual Basic
Public Shared ReadOnly LEGACY_CONVERTED_ENHANCED_PET_IMAGE As String
Visual C++
public:
static initonly String^ LEGACY_CONVERTED_ENHANCED_PET_IMAGE

See Also

MCservices Structure
MCservices Members


LENSOMETRY_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..LENSOMETRY_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.LENSOMETRY_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string LENSOMETRY_MEASUREMENTS
Visual Basic
Public Shared ReadOnly LENSOMETRY_MEASUREMENTS As String
Visual C++
public:
static initonly String^ LENSOMETRY_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


MACULAR_GRID_THIICKNESS_VOLUME Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MACULAR_GRID_THIICKNESS_VOLUME Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MACULAR_GRID_THIICKNESS_VOLUME"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MACULAR_GRID_THIICKNESS_VOLUME
Visual Basic
Public Shared ReadOnly MACULAR_GRID_THIICKNESS_VOLUME As String
Visual C++
public:
static initonly String^ MACULAR_GRID_THIICKNESS_VOLUME

See Also

MCservices Structure
MCservices Members


MAMMOGRAPHY_CAD_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MAMMOGRAPHY_CAD_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MAMMOGRAPHY_CAD_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MAMMOGRAPHY_CAD_SR
Visual Basic
Public Shared ReadOnly MAMMOGRAPHY_CAD_SR As String
Visual C++
public:
static initonly String^ MAMMOGRAPHY_CAD_SR

See Also

MCservices Structure
MCservices Members


MEDIA_CREATION_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MEDIA_CREATION_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MEDIA_CREATION_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MEDIA_CREATION_MANAGEMENT
Visual Basic
Public Shared ReadOnly MEDIA_CREATION_MANAGEMENT As String
Visual C++
public:
static initonly String^ MEDIA_CREATION_MANAGEMENT

See Also

MCservices Structure
MCservices Members


MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MICROSCOPY_BULK_SIMPLE_ANNOTATIONS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MICROSCOPY_BULK_SIMPLE_ANNOTATIONS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MICROSCOPY_BULK_SIMPLE_ANNOTATIONS
Visual Basic
Public Shared ReadOnly MICROSCOPY_BULK_SIMPLE_ANNOTATIONS As String
Visual C++
public:
static initonly String^ MICROSCOPY_BULK_SIMPLE_ANNOTATIONS

See Also

MCservices Structure
MCservices Members


MODALITY_WORKLIST_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MODALITY_WORKLIST_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MODALITY_WORKLIST_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MODALITY_WORKLIST_FIND
Visual Basic
Public Shared ReadOnly MODALITY_WORKLIST_FIND As String
Visual C++
public:
static initonly String^ MODALITY_WORKLIST_FIND

See Also

MCservices Structure
MCservices Members


MR_SPECTROSCOPY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MR_SPECTROSCOPY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MR_SPECTROSCOPY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MR_SPECTROSCOPY
Visual Basic
Public Shared ReadOnly MR_SPECTROSCOPY As String
Visual C++
public:
static initonly String^ MR_SPECTROSCOPY

See Also

MCservices Structure
MCservices Members


MULTI_CHANNEL_RESPIRATORY_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MULTI_CHANNEL_RESPIRATORY_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MULTI_CHANNEL_RESPIRATORY_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTI_CHANNEL_RESPIRATORY_WAVEFORM
Visual Basic
Public Shared ReadOnly MULTI_CHANNEL_RESPIRATORY_WAVEFORM As String
Visual C++
public:
static initonly String^ MULTI_CHANNEL_RESPIRATORY_WAVEFORM

See Also

MCservices Structure
MCservices Members


MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE
Visual Basic
Public Shared ReadOnly MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE As String
Visual C++
public:
static initonly String^ MULTIPLE_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE

See Also

MCservices Structure
MCservices Members


OPHT_VIS_FIELD_STATIC_PERIM_MEAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPHT_VIS_FIELD_STATIC_PERIM_MEAS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPHT_VIS_FIELD_STATIC_PERIM_MEAS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHT_VIS_FIELD_STATIC_PERIM_MEAS
Visual Basic
Public Shared ReadOnly OPHT_VIS_FIELD_STATIC_PERIM_MEAS As String
Visual C++
public:
static initonly String^ OPHT_VIS_FIELD_STATIC_PERIM_MEAS

See Also

MCservices Structure
MCservices Members


OPHTHALMIC_AXIAL_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPHTHALMIC_AXIAL_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPHTHALMIC_AXIAL_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_AXIAL_MEASUREMENTS
Visual Basic
Public Shared ReadOnly OPHTHALMIC_AXIAL_MEASUREMENTS As String
Visual C++
public:
static initonly String^ OPHTHALMIC_AXIAL_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS
Visual Basic
Public Shared ReadOnly OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS As String
Visual C++
public:
static initonly String^ OPHTHALMIC_OCT_BSCAN_VOLUME_ANALYSIS

See Also

MCservices Structure
MCservices Members


OPHTHALMIC_OCT_EN_FACE_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPHTHALMIC_OCT_EN_FACE_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPHTHALMIC_OCT_EN_FACE_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_OCT_EN_FACE_IMAGE
Visual Basic
Public Shared ReadOnly OPHTHALMIC_OCT_EN_FACE_IMAGE As String
Visual C++
public:
static initonly String^ OPHTHALMIC_OCT_EN_FACE_IMAGE

See Also

MCservices Structure
MCservices Members


OPHTHALMIC_TOMOGRAPHY_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPHTHALMIC_TOMOGRAPHY_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPHTHALMIC_TOMOGRAPHY_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPHTHALMIC_TOMOGRAPHY_IMAGE
Visual Basic
Public Shared ReadOnly OPHTHALMIC_TOMOGRAPHY_IMAGE As String
Visual C++
public:
static initonly String^ OPHTHALMIC_TOMOGRAPHY_IMAGE

See Also

MCservices Structure
MCservices Members


OPM_THICKNESS_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..OPM_THICKNESS_MAP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.OPM_THICKNESS_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string OPM_THICKNESS_MAP
Visual Basic
Public Shared ReadOnly OPM_THICKNESS_MAP As String
Visual C++
public:
static initonly String^ OPM_THICKNESS_MAP

See Also

MCservices Structure
MCservices Members


PARAMETRIC_MAP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PARAMETRIC_MAP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PARAMETRIC_MAP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PARAMETRIC_MAP
Visual Basic
Public Shared ReadOnly PARAMETRIC_MAP As String
Visual C++
public:
static initonly String^ PARAMETRIC_MAP

See Also

MCservices Structure
MCservices Members


PATIENT_RADIATION_DOSE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_RADIATION_DOSE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_RADIATION_DOSE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_RADIATION_DOSE_SR
Visual Basic
Public Shared ReadOnly PATIENT_RADIATION_DOSE_SR As String
Visual C++
public:
static initonly String^ PATIENT_RADIATION_DOSE_SR

See Also

MCservices Structure
MCservices Members


PATIENT_ROOT_QR_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_ROOT_QR_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_ROOT_QR_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ROOT_QR_FIND
Visual Basic
Public Shared ReadOnly PATIENT_ROOT_QR_FIND As String
Visual C++
public:
static initonly String^ PATIENT_ROOT_QR_FIND

See Also

MCservices Structure
MCservices Members


PATIENT_ROOT_QR_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_ROOT_QR_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_ROOT_QR_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ROOT_QR_GET
Visual Basic
Public Shared ReadOnly PATIENT_ROOT_QR_GET As String
Visual C++
public:
static initonly String^ PATIENT_ROOT_QR_GET

See Also

MCservices Structure
MCservices Members


PATIENT_ROOT_QR_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_ROOT_QR_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_ROOT_QR_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_ROOT_QR_MOVE
Visual Basic
Public Shared ReadOnly PATIENT_ROOT_QR_MOVE As String
Visual C++
public:
static initonly String^ PATIENT_ROOT_QR_MOVE

See Also

MCservices Structure
MCservices Members


PATIENT_STUDY_ONLY_QR_FIND_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_STUDY_ONLY_QR_FIND_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_STUDY_ONLY_QR_FIND_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_STUDY_ONLY_QR_FIND_RETIRED
Visual Basic
Public Shared ReadOnly PATIENT_STUDY_ONLY_QR_FIND_RETIRED As String
Visual C++
public:
static initonly String^ PATIENT_STUDY_ONLY_QR_FIND_RETIRED

See Also

MCservices Structure
MCservices Members


PATIENT_STUDY_ONLY_QR_GET_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_STUDY_ONLY_QR_GET_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_STUDY_ONLY_QR_GET_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_STUDY_ONLY_QR_GET_RETIRED
Visual Basic
Public Shared ReadOnly PATIENT_STUDY_ONLY_QR_GET_RETIRED As String
Visual C++
public:
static initonly String^ PATIENT_STUDY_ONLY_QR_GET_RETIRED

See Also

MCservices Structure
MCservices Members


PATIENT_STUDY_ONLY_QR_MOVE_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PATIENT_STUDY_ONLY_QR_MOVE_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PATIENT_STUDY_ONLY_QR_MOVE_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PATIENT_STUDY_ONLY_QR_MOVE_RETIRED
Visual Basic
Public Shared ReadOnly PATIENT_STUDY_ONLY_QR_MOVE_RETIRED As String
Visual C++
public:
static initonly String^ PATIENT_STUDY_ONLY_QR_MOVE_RETIRED

See Also

MCservices Structure
MCservices Members


PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR
Visual Basic
Public Shared ReadOnly PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR As String
Visual C++
public:
static initonly String^ PERFORMED_IMAGING_AGENT_ADMINISTRATION_SR

See Also

MCservices Structure
MCservices Members


PERFORMED_PROCEDURE_STEP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PERFORMED_PROCEDURE_STEP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PERFORMED_PROCEDURE_STEP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_PROCEDURE_STEP
Visual Basic
Public Shared ReadOnly PERFORMED_PROCEDURE_STEP As String
Visual C++
public:
static initonly String^ PERFORMED_PROCEDURE_STEP

See Also

MCservices Structure
MCservices Members


PERFORMED_PROCEDURE_STEP_NOTIFY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PERFORMED_PROCEDURE_STEP_NOTIFY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PERFORMED_PROCEDURE_STEP_NOTIFY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_PROCEDURE_STEP_NOTIFY
Visual Basic
Public Shared ReadOnly PERFORMED_PROCEDURE_STEP_NOTIFY As String
Visual C++
public:
static initonly String^ PERFORMED_PROCEDURE_STEP_NOTIFY

See Also

MCservices Structure
MCservices Members


PERFORMED_PROCEDURE_STEP_RETRIEVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PERFORMED_PROCEDURE_STEP_RETRIEVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PERFORMED_PROCEDURE_STEP_RETRIEVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PERFORMED_PROCEDURE_STEP_RETRIEVE
Visual Basic
Public Shared ReadOnly PERFORMED_PROCEDURE_STEP_RETRIEVE As String
Visual C++
public:
static initonly String^ PERFORMED_PROCEDURE_STEP_RETRIEVE

See Also

MCservices Structure
MCservices Members


PHOTOACOUSTIC_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PHOTOACOUSTIC_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PHOTOACOUSTIC_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PHOTOACOUSTIC_IMAGE
Visual Basic
Public Shared ReadOnly PHOTOACOUSTIC_IMAGE As String
Visual C++
public:
static initonly String^ PHOTOACOUSTIC_IMAGE

See Also

MCservices Structure
MCservices Members


PLANNED_IMAGING_AGENT_ADMINISTRATION_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PLANNED_IMAGING_AGENT_ADMINISTRATION_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PLANNED_IMAGING_AGENT_ADMINISTRATION_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PLANNED_IMAGING_AGENT_ADMINISTRATION_SR
Visual Basic
Public Shared ReadOnly PLANNED_IMAGING_AGENT_ADMINISTRATION_SR As String
Visual C++
public:
static initonly String^ PLANNED_IMAGING_AGENT_ADMINISTRATION_SR

See Also

MCservices Structure
MCservices Members


PRESENTATION_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRESENTATION_LUT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRESENTATION_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRESENTATION_LUT
Visual Basic
Public Shared ReadOnly PRESENTATION_LUT As String
Visual C++
public:
static initonly String^ PRESENTATION_LUT

See Also

MCservices Structure
MCservices Members


PRINT_JOB Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRINT_JOB Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRINT_JOB"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINT_JOB
Visual Basic
Public Shared ReadOnly PRINT_JOB As String
Visual C++
public:
static initonly String^ PRINT_JOB

See Also

MCservices Structure
MCservices Members


PRINT_QUEUE_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRINT_QUEUE_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRINT_QUEUE_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINT_QUEUE_MANAGEMENT
Visual Basic
Public Shared ReadOnly PRINT_QUEUE_MANAGEMENT As String
Visual C++
public:
static initonly String^ PRINT_QUEUE_MANAGEMENT

See Also

MCservices Structure
MCservices Members


PRINTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRINTER Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRINTER"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINTER
Visual Basic
Public Shared ReadOnly PRINTER As String
Visual C++
public:
static initonly String^ PRINTER

See Also

MCservices Structure
MCservices Members


PRINTER_CONFIGURATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRINTER_CONFIGURATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRINTER_CONFIGURATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRINTER_CONFIGURATION
Visual Basic
Public Shared ReadOnly PRINTER_CONFIGURATION As String
Visual C++
public:
static initonly String^ PRINTER_CONFIGURATION

See Also

MCservices Structure
MCservices Members


PROCEDURAL_EVENT_LOGGING Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROCEDURAL_EVENT_LOGGING Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROCEDURAL_EVENT_LOGGING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURAL_EVENT_LOGGING
Visual Basic
Public Shared ReadOnly PROCEDURAL_EVENT_LOGGING As String
Visual C++
public:
static initonly String^ PROCEDURAL_EVENT_LOGGING

See Also

MCservices Structure
MCservices Members


PROCEDURE_LOG Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROCEDURE_LOG Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROCEDURE_LOG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROCEDURE_LOG
Visual Basic
Public Shared ReadOnly PROCEDURE_LOG As String
Visual C++
public:
static initonly String^ PROCEDURE_LOG

See Also

MCservices Structure
MCservices Members


PRODUCT_CHARACTERISTICS_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PRODUCT_CHARACTERISTICS_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PRODUCT_CHARACTERISTICS_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PRODUCT_CHARACTERISTICS_QUERY
Visual Basic
Public Shared ReadOnly PRODUCT_CHARACTERISTICS_QUERY As String
Visual C++
public:
static initonly String^ PRODUCT_CHARACTERISTICS_QUERY

See Also

MCservices Structure
MCservices Members


PROTOCOL_APPROVAL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROTOCOL_APPROVAL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROTOCOL_APPROVAL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_APPROVAL
Visual Basic
Public Shared ReadOnly PROTOCOL_APPROVAL As String
Visual C++
public:
static initonly String^ PROTOCOL_APPROVAL

See Also

MCservices Structure
MCservices Members


PROTOCOL_APPROVAL_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROTOCOL_APPROVAL_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROTOCOL_APPROVAL_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_APPROVAL_FIND
Visual Basic
Public Shared ReadOnly PROTOCOL_APPROVAL_FIND As String
Visual C++
public:
static initonly String^ PROTOCOL_APPROVAL_FIND

See Also

MCservices Structure
MCservices Members


PROTOCOL_APPROVAL_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROTOCOL_APPROVAL_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROTOCOL_APPROVAL_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_APPROVAL_GET
Visual Basic
Public Shared ReadOnly PROTOCOL_APPROVAL_GET As String
Visual C++
public:
static initonly String^ PROTOCOL_APPROVAL_GET

See Also

MCservices Structure
MCservices Members


PROTOCOL_APPROVAL_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PROTOCOL_APPROVAL_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PROTOCOL_APPROVAL_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PROTOCOL_APPROVAL_MOVE
Visual Basic
Public Shared ReadOnly PROTOCOL_APPROVAL_MOVE As String
Visual C++
public:
static initonly String^ PROTOCOL_APPROVAL_MOVE

See Also

MCservices Structure
MCservices Members


PULL_PRINT_REQUEST Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..PULL_PRINT_REQUEST Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.PULL_PRINT_REQUEST"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string PULL_PRINT_REQUEST
Visual Basic
Public Shared ReadOnly PULL_PRINT_REQUEST As String
Visual C++
public:
static initonly String^ PULL_PRINT_REQUEST

See Also

MCservices Structure
MCservices Members


RADIOPHARMACEUTICAL_RADIATION_DOSE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RADIOPHARMACEUTICAL_RADIATION_DOSE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RADIOPHARMACEUTICAL_RADIATION_DOSE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RADIOPHARMACEUTICAL_RADIATION_DOSE_SR
Visual Basic
Public Shared ReadOnly RADIOPHARMACEUTICAL_RADIATION_DOSE_SR As String
Visual C++
public:
static initonly String^ RADIOPHARMACEUTICAL_RADIATION_DOSE_SR

See Also

MCservices Structure
MCservices Members


RAW_DATA Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RAW_DATA Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RAW_DATA"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RAW_DATA
Visual Basic
Public Shared ReadOnly RAW_DATA As String
Visual C++
public:
static initonly String^ RAW_DATA

See Also

MCservices Structure
MCservices Members


REAL_WORLD_VALUE_MAPPING Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..REAL_WORLD_VALUE_MAPPING Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.REAL_WORLD_VALUE_MAPPING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REAL_WORLD_VALUE_MAPPING
Visual Basic
Public Shared ReadOnly REAL_WORLD_VALUE_MAPPING As String
Visual C++
public:
static initonly String^ REAL_WORLD_VALUE_MAPPING

See Also

MCservices Structure
MCservices Members


REFERENCED_IMAGE_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..REFERENCED_IMAGE_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.REFERENCED_IMAGE_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REFERENCED_IMAGE_BOX
Visual Basic
Public Shared ReadOnly REFERENCED_IMAGE_BOX As String
Visual C++
public:
static initonly String^ REFERENCED_IMAGE_BOX

See Also

MCservices Structure
MCservices Members


RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION
Visual Basic
Public Shared ReadOnly RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION As String
Visual C++
public:
static initonly String^ RENDITION_SELECTION_DOCUMENT_REAL_TIME_COMMUNICATION

See Also

MCservices Structure
MCservices Members


REPOSITORY_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..REPOSITORY_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.REPOSITORY_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string REPOSITORY_QUERY
Visual Basic
Public Shared ReadOnly REPOSITORY_QUERY As String
Visual C++
public:
static initonly String^ REPOSITORY_QUERY

See Also

MCservices Structure
MCservices Members


RESPIRATORY_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RESPIRATORY_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RESPIRATORY_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RESPIRATORY_WAVEFORM
Visual Basic
Public Shared ReadOnly RESPIRATORY_WAVEFORM As String
Visual C++
public:
static initonly String^ RESPIRATORY_WAVEFORM

See Also

MCservices Structure
MCservices Members


ROBOTIC_ARM_RADIATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ROBOTIC_ARM_RADIATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ROBOTIC_ARM_RADIATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROBOTIC_ARM_RADIATION
Visual Basic
Public Shared ReadOnly ROBOTIC_ARM_RADIATION As String
Visual C++
public:
static initonly String^ ROBOTIC_ARM_RADIATION

See Also

MCservices Structure
MCservices Members


ROBOTIC_ARM_RADIATION_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ROBOTIC_ARM_RADIATION_RECORD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ROBOTIC_ARM_RADIATION_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROBOTIC_ARM_RADIATION_RECORD
Visual Basic
Public Shared ReadOnly ROBOTIC_ARM_RADIATION_RECORD As String
Visual C++
public:
static initonly String^ ROBOTIC_ARM_RADIATION_RECORD

See Also

MCservices Structure
MCservices Members


ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM
Visual Basic
Public Shared ReadOnly ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM As String
Visual C++
public:
static initonly String^ ROUTINE_SCALP_ELECTROENCEPHALOGRAM_WAVEFORM

See Also

MCservices Structure
MCservices Members


RT_BEAMS_DELIVERY_INSTR_RET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_BEAMS_DELIVERY_INSTR_RET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_BEAMS_DELIVERY_INSTR_RET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BEAMS_DELIVERY_INSTR_RET
Visual Basic
Public Shared ReadOnly RT_BEAMS_DELIVERY_INSTR_RET As String
Visual C++
public:
static initonly String^ RT_BEAMS_DELIVERY_INSTR_RET

See Also

MCservices Structure
MCservices Members


RT_BEAMS_DELIVERY_INSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_BEAMS_DELIVERY_INSTRUCTION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_BEAMS_DELIVERY_INSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BEAMS_DELIVERY_INSTRUCTION
Visual Basic
Public Shared ReadOnly RT_BEAMS_DELIVERY_INSTRUCTION As String
Visual C++
public:
static initonly String^ RT_BEAMS_DELIVERY_INSTRUCTION

See Also

MCservices Structure
MCservices Members


RT_BRACHY_APP_SETUP_DELIVERY_INSTR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_BRACHY_APP_SETUP_DELIVERY_INSTR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_BRACHY_APP_SETUP_DELIVERY_INSTR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_BRACHY_APP_SETUP_DELIVERY_INSTR
Visual Basic
Public Shared ReadOnly RT_BRACHY_APP_SETUP_DELIVERY_INSTR As String
Visual C++
public:
static initonly String^ RT_BRACHY_APP_SETUP_DELIVERY_INSTR

See Also

MCservices Structure
MCservices Members


RT_CONV_MACHINE_VERIF_RET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_CONV_MACHINE_VERIF_RET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_CONV_MACHINE_VERIF_RET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_CONV_MACHINE_VERIF_RET
Visual Basic
Public Shared ReadOnly RT_CONV_MACHINE_VERIF_RET As String
Visual C++
public:
static initonly String^ RT_CONV_MACHINE_VERIF_RET

See Also

MCservices Structure
MCservices Members


RT_CONVENTIONAL_MACHINE_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_CONVENTIONAL_MACHINE_VERIFICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_CONVENTIONAL_MACHINE_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_CONVENTIONAL_MACHINE_VERIFICATION
Visual Basic
Public Shared ReadOnly RT_CONVENTIONAL_MACHINE_VERIFICATION As String
Visual C++
public:
static initonly String^ RT_CONVENTIONAL_MACHINE_VERIFICATION

See Also

MCservices Structure
MCservices Members


RT_ION_MACHINE_VERIF_RET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_ION_MACHINE_VERIF_RET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_ION_MACHINE_VERIF_RET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ION_MACHINE_VERIF_RET
Visual Basic
Public Shared ReadOnly RT_ION_MACHINE_VERIF_RET As String
Visual C++
public:
static initonly String^ RT_ION_MACHINE_VERIF_RET

See Also

MCservices Structure
MCservices Members


RT_ION_MACHINE_VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_ION_MACHINE_VERIFICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_ION_MACHINE_VERIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_ION_MACHINE_VERIFICATION
Visual Basic
Public Shared ReadOnly RT_ION_MACHINE_VERIFICATION As String
Visual C++
public:
static initonly String^ RT_ION_MACHINE_VERIFICATION

See Also

MCservices Structure
MCservices Members


RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION
Visual Basic
Public Shared ReadOnly RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION As String
Visual C++
public:
static initonly String^ RT_PATIENT_POSITION_ACQUISITION_INSTRUCTION

See Also

MCservices Structure
MCservices Members


RT_PHYSICIAN_INTENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_PHYSICIAN_INTENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_PHYSICIAN_INTENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_PHYSICIAN_INTENT
Visual Basic
Public Shared ReadOnly RT_PHYSICIAN_INTENT As String
Visual C++
public:
static initonly String^ RT_PHYSICIAN_INTENT

See Also

MCservices Structure
MCservices Members


RT_RADIATION_RECORD_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_RADIATION_RECORD_SET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_RADIATION_RECORD_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_RECORD_SET
Visual Basic
Public Shared ReadOnly RT_RADIATION_RECORD_SET As String
Visual C++
public:
static initonly String^ RT_RADIATION_RECORD_SET

See Also

MCservices Structure
MCservices Members


RT_RADIATION_SALVAGE_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_RADIATION_SALVAGE_RECORD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_RADIATION_SALVAGE_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_SALVAGE_RECORD
Visual Basic
Public Shared ReadOnly RT_RADIATION_SALVAGE_RECORD As String
Visual C++
public:
static initonly String^ RT_RADIATION_SALVAGE_RECORD

See Also

MCservices Structure
MCservices Members


RT_RADIATION_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_RADIATION_SET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_RADIATION_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_SET
Visual Basic
Public Shared ReadOnly RT_RADIATION_SET As String
Visual C++
public:
static initonly String^ RT_RADIATION_SET

See Also

MCservices Structure
MCservices Members


RT_RADIATION_SET_DELIVERY_INSTRUCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_RADIATION_SET_DELIVERY_INSTRUCTION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_RADIATION_SET_DELIVERY_INSTRUCTION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_RADIATION_SET_DELIVERY_INSTRUCTION
Visual Basic
Public Shared ReadOnly RT_RADIATION_SET_DELIVERY_INSTRUCTION As String
Visual C++
public:
static initonly String^ RT_RADIATION_SET_DELIVERY_INSTRUCTION

See Also

MCservices Structure
MCservices Members


RT_SEGMENT_ANNOTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_SEGMENT_ANNOTATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_SEGMENT_ANNOTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_SEGMENT_ANNOTATION
Visual Basic
Public Shared ReadOnly RT_SEGMENT_ANNOTATION As String
Visual C++
public:
static initonly String^ RT_SEGMENT_ANNOTATION

See Also

MCservices Structure
MCservices Members


RT_TREATMENT_PREPARATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..RT_TREATMENT_PREPARATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.RT_TREATMENT_PREPARATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string RT_TREATMENT_PREPARATION
Visual Basic
Public Shared ReadOnly RT_TREATMENT_PREPARATION As String
Visual C++
public:
static initonly String^ RT_TREATMENT_PREPARATION

See Also

MCservices Structure
MCservices Members


SC_MULTIFRAME_GRAYSCALE_BYTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SC_MULTIFRAME_GRAYSCALE_BYTE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SC_MULTIFRAME_GRAYSCALE_BYTE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SC_MULTIFRAME_GRAYSCALE_BYTE
Visual Basic
Public Shared ReadOnly SC_MULTIFRAME_GRAYSCALE_BYTE As String
Visual C++
public:
static initonly String^ SC_MULTIFRAME_GRAYSCALE_BYTE

See Also

MCservices Structure
MCservices Members


SC_MULTIFRAME_GRAYSCALE_WORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SC_MULTIFRAME_GRAYSCALE_WORD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SC_MULTIFRAME_GRAYSCALE_WORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SC_MULTIFRAME_GRAYSCALE_WORD
Visual Basic
Public Shared ReadOnly SC_MULTIFRAME_GRAYSCALE_WORD As String
Visual C++
public:
static initonly String^ SC_MULTIFRAME_GRAYSCALE_WORD

See Also

MCservices Structure
MCservices Members


SC_MULTIFRAME_SINGLE_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SC_MULTIFRAME_SINGLE_BIT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SC_MULTIFRAME_SINGLE_BIT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SC_MULTIFRAME_SINGLE_BIT
Visual Basic
Public Shared ReadOnly SC_MULTIFRAME_SINGLE_BIT As String
Visual C++
public:
static initonly String^ SC_MULTIFRAME_SINGLE_BIT

See Also

MCservices Structure
MCservices Members


SC_MULTIFRAME_TRUE_COLOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SC_MULTIFRAME_TRUE_COLOR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SC_MULTIFRAME_TRUE_COLOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SC_MULTIFRAME_TRUE_COLOR
Visual Basic
Public Shared ReadOnly SC_MULTIFRAME_TRUE_COLOR As String
Visual C++
public:
static initonly String^ SC_MULTIFRAME_TRUE_COLOR

See Also

MCservices Structure
MCservices Members


SEGMENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SEGMENTATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SEGMENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENTATION
Visual Basic
Public Shared ReadOnly SEGMENTATION As String
Visual C++
public:
static initonly String^ SEGMENTATION

See Also

MCservices Structure
MCservices Members


SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE
Visual Basic
Public Shared ReadOnly SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE As String
Visual C++
public:
static initonly String^ SEGMENTED_VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE

See Also

MCservices Structure
MCservices Members


SIMPLIFIED_ADULT_ECHO_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SIMPLIFIED_ADULT_ECHO_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SIMPLIFIED_ADULT_ECHO_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SIMPLIFIED_ADULT_ECHO_SR
Visual Basic
Public Shared ReadOnly SIMPLIFIED_ADULT_ECHO_SR As String
Visual C++
public:
static initonly String^ SIMPLIFIED_ADULT_ECHO_SR

See Also

MCservices Structure
MCservices Members


SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM
Visual Basic
Public Shared ReadOnly SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM As String
Visual C++
public:
static initonly String^ SLEEP_ELECTROENCEPHALOGRAM_WAVEFORM

See Also

MCservices Structure
MCservices Members


SPATIAL_FIDUCIALS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SPATIAL_FIDUCIALS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SPATIAL_FIDUCIALS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPATIAL_FIDUCIALS
Visual Basic
Public Shared ReadOnly SPATIAL_FIDUCIALS As String
Visual C++
public:
static initonly String^ SPATIAL_FIDUCIALS

See Also

MCservices Structure
MCservices Members


SPATIAL_REGISTRATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SPATIAL_REGISTRATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SPATIAL_REGISTRATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPATIAL_REGISTRATION
Visual Basic
Public Shared ReadOnly SPATIAL_REGISTRATION As String
Visual C++
public:
static initonly String^ SPATIAL_REGISTRATION

See Also

MCservices Structure
MCservices Members


SPECTACLE_PRESCRIPTION_REPORT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SPECTACLE_PRESCRIPTION_REPORT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SPECTACLE_PRESCRIPTION_REPORT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SPECTACLE_PRESCRIPTION_REPORT
Visual Basic
Public Shared ReadOnly SPECTACLE_PRESCRIPTION_REPORT As String
Visual C++
public:
static initonly String^ SPECTACLE_PRESCRIPTION_REPORT

See Also

MCservices Structure
MCservices Members


STANDARD_BASIC_TEXT_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_BASIC_TEXT_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_BASIC_TEXT_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_BASIC_TEXT_SR
Visual Basic
Public Shared ReadOnly STANDARD_BASIC_TEXT_SR As String
Visual C++
public:
static initonly String^ STANDARD_BASIC_TEXT_SR

See Also

MCservices Structure
MCservices Members


STANDARD_BLENDING_SOFTCOPY_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_BLENDING_SOFTCOPY_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_BLENDING_SOFTCOPY_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_BLENDING_SOFTCOPY_PS
Visual Basic
Public Shared ReadOnly STANDARD_BLENDING_SOFTCOPY_PS As String
Visual C++
public:
static initonly String^ STANDARD_BLENDING_SOFTCOPY_PS

See Also

MCservices Structure
MCservices Members


STANDARD_COLOR_SOFTCOPY_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_COLOR_SOFTCOPY_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_COLOR_SOFTCOPY_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_COLOR_SOFTCOPY_PS
Visual Basic
Public Shared ReadOnly STANDARD_COLOR_SOFTCOPY_PS As String
Visual C++
public:
static initonly String^ STANDARD_COLOR_SOFTCOPY_PS

See Also

MCservices Structure
MCservices Members


STANDARD_COMPREHENSIVE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_COMPREHENSIVE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_COMPREHENSIVE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_COMPREHENSIVE_SR
Visual Basic
Public Shared ReadOnly STANDARD_COMPREHENSIVE_SR As String
Visual C++
public:
static initonly String^ STANDARD_COMPREHENSIVE_SR

See Also

MCservices Structure
MCservices Members


STANDARD_CR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_CR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_CR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_CR
Visual Basic
Public Shared ReadOnly STANDARD_CR As String
Visual C++
public:
static initonly String^ STANDARD_CR

See Also

MCservices Structure
MCservices Members


STANDARD_CT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_CT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_CT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_CT
Visual Basic
Public Shared ReadOnly STANDARD_CT As String
Visual C++
public:
static initonly String^ STANDARD_CT

See Also

MCservices Structure
MCservices Members


STANDARD_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_CURVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_CURVE
Visual Basic
Public Shared ReadOnly STANDARD_CURVE As String
Visual C++
public:
static initonly String^ STANDARD_CURVE

See Also

MCservices Structure
MCservices Members


STANDARD_DX_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_DX_PRESENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_DX_PRESENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_DX_PRESENT
Visual Basic
Public Shared ReadOnly STANDARD_DX_PRESENT As String
Visual C++
public:
static initonly String^ STANDARD_DX_PRESENT

See Also

MCservices Structure
MCservices Members


STANDARD_DX_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_DX_PROCESS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_DX_PROCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_DX_PROCESS
Visual Basic
Public Shared ReadOnly STANDARD_DX_PROCESS As String
Visual C++
public:
static initonly String^ STANDARD_DX_PROCESS

See Also

MCservices Structure
MCservices Members


STANDARD_ECHO Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_ECHO Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_ECHO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_ECHO
Visual Basic
Public Shared ReadOnly STANDARD_ECHO As String
Visual C++
public:
static initonly String^ STANDARD_ECHO

See Also

MCservices Structure
MCservices Members


STANDARD_ENCAPSULATED_PDF Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_ENCAPSULATED_PDF Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_ENCAPSULATED_PDF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_ENCAPSULATED_PDF
Visual Basic
Public Shared ReadOnly STANDARD_ENCAPSULATED_PDF As String
Visual C++
public:
static initonly String^ STANDARD_ENCAPSULATED_PDF

See Also

MCservices Structure
MCservices Members


STANDARD_ENHANCED_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_ENHANCED_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_ENHANCED_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_ENHANCED_SR
Visual Basic
Public Shared ReadOnly STANDARD_ENHANCED_SR As String
Visual C++
public:
static initonly String^ STANDARD_ENHANCED_SR

See Also

MCservices Structure
MCservices Members


STANDARD_GRAYSCALE_SOFTCOPY_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_GRAYSCALE_SOFTCOPY_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_GRAYSCALE_SOFTCOPY_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_GRAYSCALE_SOFTCOPY_PS
Visual Basic
Public Shared ReadOnly STANDARD_GRAYSCALE_SOFTCOPY_PS As String
Visual C++
public:
static initonly String^ STANDARD_GRAYSCALE_SOFTCOPY_PS

See Also

MCservices Structure
MCservices Members


STANDARD_HARDCOPY_COLOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_HARDCOPY_COLOR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_HARDCOPY_COLOR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_HARDCOPY_COLOR
Visual Basic
Public Shared ReadOnly STANDARD_HARDCOPY_COLOR As String
Visual C++
public:
static initonly String^ STANDARD_HARDCOPY_COLOR

See Also

MCservices Structure
MCservices Members


STANDARD_HARDCOPY_GRAYSCALE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_HARDCOPY_GRAYSCALE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_HARDCOPY_GRAYSCALE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_HARDCOPY_GRAYSCALE
Visual Basic
Public Shared ReadOnly STANDARD_HARDCOPY_GRAYSCALE As String
Visual C++
public:
static initonly String^ STANDARD_HARDCOPY_GRAYSCALE

See Also

MCservices Structure
MCservices Members


STANDARD_IO_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_IO_PRESENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_IO_PRESENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_IO_PRESENT
Visual Basic
Public Shared ReadOnly STANDARD_IO_PRESENT As String
Visual C++
public:
static initonly String^ STANDARD_IO_PRESENT

See Also

MCservices Structure
MCservices Members


STANDARD_IO_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_IO_PROCESS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_IO_PROCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_IO_PROCESS
Visual Basic
Public Shared ReadOnly STANDARD_IO_PROCESS As String
Visual C++
public:
static initonly String^ STANDARD_IO_PROCESS

See Also

MCservices Structure
MCservices Members


STANDARD_IVOCT_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_IVOCT_PRESENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_IVOCT_PRESENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_IVOCT_PRESENT
Visual Basic
Public Shared ReadOnly STANDARD_IVOCT_PRESENT As String
Visual C++
public:
static initonly String^ STANDARD_IVOCT_PRESENT

See Also

MCservices Structure
MCservices Members


STANDARD_IVOCT_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_IVOCT_PROCESS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_IVOCT_PROCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_IVOCT_PROCESS
Visual Basic
Public Shared ReadOnly STANDARD_IVOCT_PROCESS As String
Visual C++
public:
static initonly String^ STANDARD_IVOCT_PROCESS

See Also

MCservices Structure
MCservices Members


STANDARD_MG_PRESENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_MG_PRESENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_MG_PRESENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_MG_PRESENT
Visual Basic
Public Shared ReadOnly STANDARD_MG_PRESENT As String
Visual C++
public:
static initonly String^ STANDARD_MG_PRESENT

See Also

MCservices Structure
MCservices Members


STANDARD_MG_PROCESS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_MG_PROCESS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_MG_PROCESS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_MG_PROCESS
Visual Basic
Public Shared ReadOnly STANDARD_MG_PROCESS As String
Visual C++
public:
static initonly String^ STANDARD_MG_PROCESS

See Also

MCservices Structure
MCservices Members


STANDARD_MODALITY_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_MODALITY_LUT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_MODALITY_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_MODALITY_LUT
Visual Basic
Public Shared ReadOnly STANDARD_MODALITY_LUT As String
Visual C++
public:
static initonly String^ STANDARD_MODALITY_LUT

See Also

MCservices Structure
MCservices Members


STANDARD_MR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_MR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_MR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_MR
Visual Basic
Public Shared ReadOnly STANDARD_MR As String
Visual C++
public:
static initonly String^ STANDARD_MR

See Also

MCservices Structure
MCservices Members


STANDARD_NM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_NM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_NM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_NM
Visual Basic
Public Shared ReadOnly STANDARD_NM As String
Visual C++
public:
static initonly String^ STANDARD_NM

See Also

MCservices Structure
MCservices Members


STANDARD_NM_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_NM_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_NM_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_NM_RETIRED
Visual Basic
Public Shared ReadOnly STANDARD_NM_RETIRED As String
Visual C++
public:
static initonly String^ STANDARD_NM_RETIRED

See Also

MCservices Structure
MCservices Members


STANDARD_OPHTHALMIC_16_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_OPHTHALMIC_16_BIT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_OPHTHALMIC_16_BIT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_OPHTHALMIC_16_BIT
Visual Basic
Public Shared ReadOnly STANDARD_OPHTHALMIC_16_BIT As String
Visual C++
public:
static initonly String^ STANDARD_OPHTHALMIC_16_BIT

See Also

MCservices Structure
MCservices Members


STANDARD_OPHTHALMIC_8_BIT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_OPHTHALMIC_8_BIT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_OPHTHALMIC_8_BIT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_OPHTHALMIC_8_BIT
Visual Basic
Public Shared ReadOnly STANDARD_OPHTHALMIC_8_BIT As String
Visual C++
public:
static initonly String^ STANDARD_OPHTHALMIC_8_BIT

See Also

MCservices Structure
MCservices Members


STANDARD_OVERLAY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_OVERLAY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_OVERLAY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_OVERLAY
Visual Basic
Public Shared ReadOnly STANDARD_OVERLAY As String
Visual C++
public:
static initonly String^ STANDARD_OVERLAY

See Also

MCservices Structure
MCservices Members


STANDARD_PET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_PET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_PET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_PET
Visual Basic
Public Shared ReadOnly STANDARD_PET As String
Visual C++
public:
static initonly String^ STANDARD_PET

See Also

MCservices Structure
MCservices Members


STANDARD_PET_CURVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_PET_CURVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_PET_CURVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_PET_CURVE
Visual Basic
Public Shared ReadOnly STANDARD_PET_CURVE As String
Visual C++
public:
static initonly String^ STANDARD_PET_CURVE

See Also

MCservices Structure
MCservices Members


STANDARD_PRINT_STORAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_PRINT_STORAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_PRINT_STORAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_PRINT_STORAGE
Visual Basic
Public Shared ReadOnly STANDARD_PRINT_STORAGE As String
Visual C++
public:
static initonly String^ STANDARD_PRINT_STORAGE

See Also

MCservices Structure
MCservices Members


STANDARD_PSEUDOCOLOR_SOFTCOPY_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_PSEUDOCOLOR_SOFTCOPY_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_PSEUDOCOLOR_SOFTCOPY_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_PSEUDOCOLOR_SOFTCOPY_PS
Visual Basic
Public Shared ReadOnly STANDARD_PSEUDOCOLOR_SOFTCOPY_PS As String
Visual C++
public:
static initonly String^ STANDARD_PSEUDOCOLOR_SOFTCOPY_PS

See Also

MCservices Structure
MCservices Members


STANDARD_RT_BEAMS_TREAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_BEAMS_TREAT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_BEAMS_TREAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_BEAMS_TREAT
Visual Basic
Public Shared ReadOnly STANDARD_RT_BEAMS_TREAT As String
Visual C++
public:
static initonly String^ STANDARD_RT_BEAMS_TREAT

See Also

MCservices Structure
MCservices Members


STANDARD_RT_BRACHY_TREAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_BRACHY_TREAT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_BRACHY_TREAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_BRACHY_TREAT
Visual Basic
Public Shared ReadOnly STANDARD_RT_BRACHY_TREAT As String
Visual C++
public:
static initonly String^ STANDARD_RT_BRACHY_TREAT

See Also

MCservices Structure
MCservices Members


STANDARD_RT_DOSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_DOSE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_DOSE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_DOSE
Visual Basic
Public Shared ReadOnly STANDARD_RT_DOSE As String
Visual C++
public:
static initonly String^ STANDARD_RT_DOSE

See Also

MCservices Structure
MCservices Members


STANDARD_RT_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_IMAGE
Visual Basic
Public Shared ReadOnly STANDARD_RT_IMAGE As String
Visual C++
public:
static initonly String^ STANDARD_RT_IMAGE

See Also

MCservices Structure
MCservices Members


STANDARD_RT_ION_BEAMS_TREAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_ION_BEAMS_TREAT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_ION_BEAMS_TREAT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_ION_BEAMS_TREAT
Visual Basic
Public Shared ReadOnly STANDARD_RT_ION_BEAMS_TREAT As String
Visual C++
public:
static initonly String^ STANDARD_RT_ION_BEAMS_TREAT

See Also

MCservices Structure
MCservices Members


STANDARD_RT_ION_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_ION_PLAN Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_ION_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_ION_PLAN
Visual Basic
Public Shared ReadOnly STANDARD_RT_ION_PLAN As String
Visual C++
public:
static initonly String^ STANDARD_RT_ION_PLAN

See Also

MCservices Structure
MCservices Members


STANDARD_RT_PLAN Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_PLAN Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_PLAN"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_PLAN
Visual Basic
Public Shared ReadOnly STANDARD_RT_PLAN As String
Visual C++
public:
static initonly String^ STANDARD_RT_PLAN

See Also

MCservices Structure
MCservices Members


STANDARD_RT_STRUCTURE_SET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_STRUCTURE_SET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_STRUCTURE_SET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_STRUCTURE_SET
Visual Basic
Public Shared ReadOnly STANDARD_RT_STRUCTURE_SET As String
Visual C++
public:
static initonly String^ STANDARD_RT_STRUCTURE_SET

See Also

MCservices Structure
MCservices Members


STANDARD_RT_TREAT_SUM Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_RT_TREAT_SUM Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_RT_TREAT_SUM"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_RT_TREAT_SUM
Visual Basic
Public Shared ReadOnly STANDARD_RT_TREAT_SUM As String
Visual C++
public:
static initonly String^ STANDARD_RT_TREAT_SUM

See Also

MCservices Structure
MCservices Members


STANDARD_SEC_CAPTURE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_SEC_CAPTURE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_SEC_CAPTURE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_SEC_CAPTURE
Visual Basic
Public Shared ReadOnly STANDARD_SEC_CAPTURE As String
Visual C++
public:
static initonly String^ STANDARD_SEC_CAPTURE

See Also

MCservices Structure
MCservices Members


STANDARD_US Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_US Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_US"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_US
Visual Basic
Public Shared ReadOnly STANDARD_US As String
Visual C++
public:
static initonly String^ STANDARD_US

See Also

MCservices Structure
MCservices Members


STANDARD_US_MF Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_US_MF Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_US_MF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_US_MF
Visual Basic
Public Shared ReadOnly STANDARD_US_MF As String
Visual C++
public:
static initonly String^ STANDARD_US_MF

See Also

MCservices Structure
MCservices Members


STANDARD_US_MF_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_US_MF_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_US_MF_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_US_MF_RETIRED
Visual Basic
Public Shared ReadOnly STANDARD_US_MF_RETIRED As String
Visual C++
public:
static initonly String^ STANDARD_US_MF_RETIRED

See Also

MCservices Structure
MCservices Members


STANDARD_US_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_US_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_US_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_US_RETIRED
Visual Basic
Public Shared ReadOnly STANDARD_US_RETIRED As String
Visual C++
public:
static initonly String^ STANDARD_US_RETIRED

See Also

MCservices Structure
MCservices Members


STANDARD_VIDEO_ENDOSCOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VIDEO_ENDOSCOPIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VIDEO_ENDOSCOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VIDEO_ENDOSCOPIC
Visual Basic
Public Shared ReadOnly STANDARD_VIDEO_ENDOSCOPIC As String
Visual C++
public:
static initonly String^ STANDARD_VIDEO_ENDOSCOPIC

See Also

MCservices Structure
MCservices Members


STANDARD_VIDEO_MICROSCOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VIDEO_MICROSCOPIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VIDEO_MICROSCOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VIDEO_MICROSCOPIC
Visual Basic
Public Shared ReadOnly STANDARD_VIDEO_MICROSCOPIC As String
Visual C++
public:
static initonly String^ STANDARD_VIDEO_MICROSCOPIC

See Also

MCservices Structure
MCservices Members


STANDARD_VIDEO_PHOTOGRAPHIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VIDEO_PHOTOGRAPHIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VIDEO_PHOTOGRAPHIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VIDEO_PHOTOGRAPHIC
Visual Basic
Public Shared ReadOnly STANDARD_VIDEO_PHOTOGRAPHIC As String
Visual C++
public:
static initonly String^ STANDARD_VIDEO_PHOTOGRAPHIC

See Also

MCservices Structure
MCservices Members


STANDARD_VL_ENDOSCOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VL_ENDOSCOPIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VL_ENDOSCOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VL_ENDOSCOPIC
Visual Basic
Public Shared ReadOnly STANDARD_VL_ENDOSCOPIC As String
Visual C++
public:
static initonly String^ STANDARD_VL_ENDOSCOPIC

See Also

MCservices Structure
MCservices Members


STANDARD_VL_MICROSCOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VL_MICROSCOPIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VL_MICROSCOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VL_MICROSCOPIC
Visual Basic
Public Shared ReadOnly STANDARD_VL_MICROSCOPIC As String
Visual C++
public:
static initonly String^ STANDARD_VL_MICROSCOPIC

See Also

MCservices Structure
MCservices Members


STANDARD_VL_PHOTOGRAPHIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VL_PHOTOGRAPHIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VL_PHOTOGRAPHIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VL_PHOTOGRAPHIC
Visual Basic
Public Shared ReadOnly STANDARD_VL_PHOTOGRAPHIC As String
Visual C++
public:
static initonly String^ STANDARD_VL_PHOTOGRAPHIC

See Also

MCservices Structure
MCservices Members


STANDARD_VL_SLIDE_MICROSCOPIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VL_SLIDE_MICROSCOPIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VL_SLIDE_MICROSCOPIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VL_SLIDE_MICROSCOPIC
Visual Basic
Public Shared ReadOnly STANDARD_VL_SLIDE_MICROSCOPIC As String
Visual C++
public:
static initonly String^ STANDARD_VL_SLIDE_MICROSCOPIC

See Also

MCservices Structure
MCservices Members


STANDARD_VOI_LUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_VOI_LUT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_VOI_LUT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_VOI_LUT
Visual Basic
Public Shared ReadOnly STANDARD_VOI_LUT As String
Visual C++
public:
static initonly String^ STANDARD_VOI_LUT

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_12_LEAD_ECG Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_12_LEAD_ECG Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_12_LEAD_ECG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_12_LEAD_ECG
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_12_LEAD_ECG As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_12_LEAD_ECG

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_AMBULATORY_ECG Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_AMBULATORY_ECG Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_AMBULATORY_ECG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_AMBULATORY_ECG
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_AMBULATORY_ECG As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_AMBULATORY_ECG

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_BASIC_VOICE_AUDIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_BASIC_VOICE_AUDIO Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_BASIC_VOICE_AUDIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_BASIC_VOICE_AUDIO
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_BASIC_VOICE_AUDIO As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_BASIC_VOICE_AUDIO

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_CARDIAC_EP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_CARDIAC_EP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_CARDIAC_EP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_CARDIAC_EP
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_CARDIAC_EP As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_CARDIAC_EP

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_GENERAL_32_BIT_ECG Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_GENERAL_32_BIT_ECG Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_GENERAL_32_BIT_ECG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_GENERAL_32_BIT_ECG
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_GENERAL_32_BIT_ECG As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_GENERAL_32_BIT_ECG

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_GENERAL_ECG Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_GENERAL_ECG Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_GENERAL_ECG"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_GENERAL_ECG
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_GENERAL_ECG As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_GENERAL_ECG

See Also

MCservices Structure
MCservices Members


STANDARD_WAVEFORM_HEMODYNAMIC Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_WAVEFORM_HEMODYNAMIC Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_WAVEFORM_HEMODYNAMIC"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_WAVEFORM_HEMODYNAMIC
Visual Basic
Public Shared ReadOnly STANDARD_WAVEFORM_HEMODYNAMIC As String
Visual C++
public:
static initonly String^ STANDARD_WAVEFORM_HEMODYNAMIC

See Also

MCservices Structure
MCservices Members


STANDARD_XRAY_ANGIO Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_XRAY_ANGIO Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_XRAY_ANGIO"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_XRAY_ANGIO
Visual Basic
Public Shared ReadOnly STANDARD_XRAY_ANGIO As String
Visual C++
public:
static initonly String^ STANDARD_XRAY_ANGIO

See Also

MCservices Structure
MCservices Members


STANDARD_XRAY_ANGIO_BIPLANE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_XRAY_ANGIO_BIPLANE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_XRAY_ANGIO_BIPLANE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_XRAY_ANGIO_BIPLANE
Visual Basic
Public Shared ReadOnly STANDARD_XRAY_ANGIO_BIPLANE As String
Visual C++
public:
static initonly String^ STANDARD_XRAY_ANGIO_BIPLANE

See Also

MCservices Structure
MCservices Members


STANDARD_XRAY_RF Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STANDARD_XRAY_RF Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STANDARD_XRAY_RF"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STANDARD_XRAY_RF
Visual Basic
Public Shared ReadOnly STANDARD_XRAY_RF As String
Visual C++
public:
static initonly String^ STANDARD_XRAY_RF

See Also

MCservices Structure
MCservices Members


STEREOMETRIC_RELATIONSHIP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STEREOMETRIC_RELATIONSHIP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STEREOMETRIC_RELATIONSHIP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STEREOMETRIC_RELATIONSHIP
Visual Basic
Public Shared ReadOnly STEREOMETRIC_RELATIONSHIP As String
Visual C++
public:
static initonly String^ STEREOMETRIC_RELATIONSHIP

See Also

MCservices Structure
MCservices Members


STORAGE_COMMITMENT_PULL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STORAGE_COMMITMENT_PULL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STORAGE_COMMITMENT_PULL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORAGE_COMMITMENT_PULL
Visual Basic
Public Shared ReadOnly STORAGE_COMMITMENT_PULL As String
Visual C++
public:
static initonly String^ STORAGE_COMMITMENT_PULL

See Also

MCservices Structure
MCservices Members


STORAGE_COMMITMENT_PUSH Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STORAGE_COMMITMENT_PUSH Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STORAGE_COMMITMENT_PUSH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STORAGE_COMMITMENT_PUSH
Visual Basic
Public Shared ReadOnly STORAGE_COMMITMENT_PUSH As String
Visual C++
public:
static initonly String^ STORAGE_COMMITMENT_PUSH

See Also

MCservices Structure
MCservices Members


STUDY_COMPONENT_MANAGEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STUDY_COMPONENT_MANAGEMENT Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STUDY_COMPONENT_MANAGEMENT"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDY_COMPONENT_MANAGEMENT
Visual Basic
Public Shared ReadOnly STUDY_COMPONENT_MANAGEMENT As String
Visual C++
public:
static initonly String^ STUDY_COMPONENT_MANAGEMENT

See Also

MCservices Structure
MCservices Members


STUDY_CONTENT_NOTIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STUDY_CONTENT_NOTIFICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STUDY_CONTENT_NOTIFICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDY_CONTENT_NOTIFICATION
Visual Basic
Public Shared ReadOnly STUDY_CONTENT_NOTIFICATION As String
Visual C++
public:
static initonly String^ STUDY_CONTENT_NOTIFICATION

See Also

MCservices Structure
MCservices Members


STUDY_ROOT_QR_FIND Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STUDY_ROOT_QR_FIND Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STUDY_ROOT_QR_FIND"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDY_ROOT_QR_FIND
Visual Basic
Public Shared ReadOnly STUDY_ROOT_QR_FIND As String
Visual C++
public:
static initonly String^ STUDY_ROOT_QR_FIND

See Also

MCservices Structure
MCservices Members


STUDY_ROOT_QR_GET Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STUDY_ROOT_QR_GET Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STUDY_ROOT_QR_GET"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDY_ROOT_QR_GET
Visual Basic
Public Shared ReadOnly STUDY_ROOT_QR_GET As String
Visual C++
public:
static initonly String^ STUDY_ROOT_QR_GET

See Also

MCservices Structure
MCservices Members


STUDY_ROOT_QR_MOVE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..STUDY_ROOT_QR_MOVE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.STUDY_ROOT_QR_MOVE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string STUDY_ROOT_QR_MOVE
Visual Basic
Public Shared ReadOnly STUDY_ROOT_QR_MOVE As String
Visual C++
public:
static initonly String^ STUDY_ROOT_QR_MOVE

See Also

MCservices Structure
MCservices Members


SUBJ_REFRACTION_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SUBJ_REFRACTION_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SUBJ_REFRACTION_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SUBJ_REFRACTION_MEASUREMENTS
Visual Basic
Public Shared ReadOnly SUBJ_REFRACTION_MEASUREMENTS As String
Visual C++
public:
static initonly String^ SUBJ_REFRACTION_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


SUBSTANCE_ADMIN_LOGGING Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SUBSTANCE_ADMIN_LOGGING Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SUBSTANCE_ADMIN_LOGGING"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SUBSTANCE_ADMIN_LOGGING
Visual Basic
Public Shared ReadOnly SUBSTANCE_ADMIN_LOGGING As String
Visual C++
public:
static initonly String^ SUBSTANCE_ADMIN_LOGGING

See Also

MCservices Structure
MCservices Members


SUBSTANCE_APPROVAL_QUERY Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SUBSTANCE_APPROVAL_QUERY Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SUBSTANCE_APPROVAL_QUERY"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SUBSTANCE_APPROVAL_QUERY
Visual Basic
Public Shared ReadOnly SUBSTANCE_APPROVAL_QUERY As String
Visual C++
public:
static initonly String^ SUBSTANCE_APPROVAL_QUERY

See Also

MCservices Structure
MCservices Members


SURFACE_SCAN_MESH Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SURFACE_SCAN_MESH Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SURFACE_SCAN_MESH"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_SCAN_MESH
Visual Basic
Public Shared ReadOnly SURFACE_SCAN_MESH As String
Visual C++
public:
static initonly String^ SURFACE_SCAN_MESH

See Also

MCservices Structure
MCservices Members


SURFACE_SCAN_POINT_CLOUD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SURFACE_SCAN_POINT_CLOUD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SURFACE_SCAN_POINT_CLOUD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_SCAN_POINT_CLOUD
Visual Basic
Public Shared ReadOnly SURFACE_SCAN_POINT_CLOUD As String
Visual C++
public:
static initonly String^ SURFACE_SCAN_POINT_CLOUD

See Also

MCservices Structure
MCservices Members


SURFACE_SEGMENTATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..SURFACE_SEGMENTATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.SURFACE_SEGMENTATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string SURFACE_SEGMENTATION
Visual Basic
Public Shared ReadOnly SURFACE_SEGMENTATION As String
Visual C++
public:
static initonly String^ SURFACE_SEGMENTATION

See Also

MCservices Structure
MCservices Members


TOMOTHERAPEUTIC_RADIATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..TOMOTHERAPEUTIC_RADIATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.TOMOTHERAPEUTIC_RADIATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TOMOTHERAPEUTIC_RADIATION
Visual Basic
Public Shared ReadOnly TOMOTHERAPEUTIC_RADIATION As String
Visual C++
public:
static initonly String^ TOMOTHERAPEUTIC_RADIATION

See Also

MCservices Structure
MCservices Members


TOMOTHERAPEUTIC_RADIATION_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..TOMOTHERAPEUTIC_RADIATION_RECORD Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.TOMOTHERAPEUTIC_RADIATION_RECORD"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TOMOTHERAPEUTIC_RADIATION_RECORD
Visual Basic
Public Shared ReadOnly TOMOTHERAPEUTIC_RADIATION_RECORD As String
Visual C++
public:
static initonly String^ TOMOTHERAPEUTIC_RADIATION_RECORD

See Also

MCservices Structure
MCservices Members


TRACTOGRAPHY_RESULTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..TRACTOGRAPHY_RESULTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.TRACTOGRAPHY_RESULTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string TRACTOGRAPHY_RESULTS
Visual Basic
Public Shared ReadOnly TRACTOGRAPHY_RESULTS As String
Visual C++
public:
static initonly String^ TRACTOGRAPHY_RESULTS

See Also

MCservices Structure
MCservices Members


UPS_EVENT_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_EVENT_SOP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_EVENT_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_EVENT_SOP
Visual Basic
Public Shared ReadOnly UPS_EVENT_SOP As String
Visual C++
public:
static initonly String^ UPS_EVENT_SOP

See Also

MCservices Structure
MCservices Members


UPS_EVENT_SOP_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_EVENT_SOP_TRIAL_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_EVENT_SOP_TRIAL_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_EVENT_SOP_TRIAL_RETIRED
Visual Basic
Public Shared ReadOnly UPS_EVENT_SOP_TRIAL_RETIRED As String
Visual C++
public:
static initonly String^ UPS_EVENT_SOP_TRIAL_RETIRED

See Also

MCservices Structure
MCservices Members


UPS_PULL_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_PULL_SOP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_PULL_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PULL_SOP
Visual Basic
Public Shared ReadOnly UPS_PULL_SOP As String
Visual C++
public:
static initonly String^ UPS_PULL_SOP

See Also

MCservices Structure
MCservices Members


UPS_PULL_SOP_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_PULL_SOP_TRIAL_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_PULL_SOP_TRIAL_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PULL_SOP_TRIAL_RETIRED
Visual Basic
Public Shared ReadOnly UPS_PULL_SOP_TRIAL_RETIRED As String
Visual C++
public:
static initonly String^ UPS_PULL_SOP_TRIAL_RETIRED

See Also

MCservices Structure
MCservices Members


UPS_PUSH_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_PUSH_SOP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_PUSH_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PUSH_SOP
Visual Basic
Public Shared ReadOnly UPS_PUSH_SOP As String
Visual C++
public:
static initonly String^ UPS_PUSH_SOP

See Also

MCservices Structure
MCservices Members


UPS_PUSH_SOP_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_PUSH_SOP_TRIAL_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_PUSH_SOP_TRIAL_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_PUSH_SOP_TRIAL_RETIRED
Visual Basic
Public Shared ReadOnly UPS_PUSH_SOP_TRIAL_RETIRED As String
Visual C++
public:
static initonly String^ UPS_PUSH_SOP_TRIAL_RETIRED

See Also

MCservices Structure
MCservices Members


UPS_QUERY_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_QUERY_SOP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_QUERY_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_QUERY_SOP
Visual Basic
Public Shared ReadOnly UPS_QUERY_SOP As String
Visual C++
public:
static initonly String^ UPS_QUERY_SOP

See Also

MCservices Structure
MCservices Members


UPS_WATCH_SOP Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_WATCH_SOP Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_WATCH_SOP"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_WATCH_SOP
Visual Basic
Public Shared ReadOnly UPS_WATCH_SOP As String
Visual C++
public:
static initonly String^ UPS_WATCH_SOP

See Also

MCservices Structure
MCservices Members


UPS_WATCH_SOP_TRIAL_RETIRED Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..UPS_WATCH_SOP_TRIAL_RETIRED Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.UPS_WATCH_SOP_TRIAL_RETIRED"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_WATCH_SOP_TRIAL_RETIRED
Visual Basic
Public Shared ReadOnly UPS_WATCH_SOP_TRIAL_RETIRED As String
Visual C++
public:
static initonly String^ UPS_WATCH_SOP_TRIAL_RETIRED

See Also

MCservices Structure
MCservices Members


VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE
Visual Basic
Public Shared ReadOnly VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE As String
Visual C++
public:
static initonly String^ VARIABLE_MODALITY_LUT_SOFTCOPY_PRESENTATION_STATE

See Also

MCservices Structure
MCservices Members


VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION
Visual Basic
Public Shared ReadOnly VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION As String
Visual C++
public:
static initonly String^ VIDEO_ENDOSCOPIC_IMAGE_REAL_TIME_COMMUNICATION

See Also

MCservices Structure
MCservices Members


VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION
Visual Basic
Public Shared ReadOnly VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION As String
Visual C++
public:
static initonly String^ VIDEO_PHOTOGRAPHIC_IMAGE_REAL_TIME_COMMUNICATION

See Also

MCservices Structure
MCservices Members


VISUAL_ACUITY_MEASUREMENTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VISUAL_ACUITY_MEASUREMENTS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VISUAL_ACUITY_MEASUREMENTS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VISUAL_ACUITY_MEASUREMENTS
Visual Basic
Public Shared ReadOnly VISUAL_ACUITY_MEASUREMENTS As String
Visual C++
public:
static initonly String^ VISUAL_ACUITY_MEASUREMENTS

See Also

MCservices Structure
MCservices Members


VL_WHOLE_SLIDE_MICROSCOPY_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VL_WHOLE_SLIDE_MICROSCOPY_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VL_WHOLE_SLIDE_MICROSCOPY_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VL_WHOLE_SLIDE_MICROSCOPY_IMAGE
Visual Basic
Public Shared ReadOnly VL_WHOLE_SLIDE_MICROSCOPY_IMAGE As String
Visual C++
public:
static initonly String^ VL_WHOLE_SLIDE_MICROSCOPY_IMAGE

See Also

MCservices Structure
MCservices Members


VOI_LUT_BOX Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VOI_LUT_BOX Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VOI_LUT_BOX"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOI_LUT_BOX
Visual Basic
Public Shared ReadOnly VOI_LUT_BOX As String
Visual C++
public:
static initonly String^ VOI_LUT_BOX

See Also

MCservices Structure
MCservices Members


VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE
Visual Basic
Public Shared ReadOnly VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE As String
Visual C++
public:
static initonly String^ VOLUME_RENDERING_VOLUMETRIC_PRESENTATION_STATE

See Also

MCservices Structure
MCservices Members


WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES
Visual Basic
Public Shared ReadOnly WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES As String
Visual C++
public:
static initonly String^ WIDE_FIELD_OPHTHALMIC_PHOTO_3D_COORDINATES

See Also

MCservices Structure
MCservices Members


WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ
Visual Basic
Public Shared ReadOnly WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ As String
Visual C++
public:
static initonly String^ WIDE_FIELD_OPHTHALMIC_PHOTO_STEREOGRAPHIC_PROJ

See Also

MCservices Structure
MCservices Members


XA_DEFINED_PROCEDURE_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XA_DEFINED_PROCEDURE_PROTOCOL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XA_DEFINED_PROCEDURE_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_DEFINED_PROCEDURE_PROTOCOL
Visual Basic
Public Shared ReadOnly XA_DEFINED_PROCEDURE_PROTOCOL As String
Visual C++
public:
static initonly String^ XA_DEFINED_PROCEDURE_PROTOCOL

See Also

MCservices Structure
MCservices Members


XA_PERFORMED_PROCEDURE_PROTOCOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XA_PERFORMED_PROCEDURE_PROTOCOL Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XA_PERFORMED_PROCEDURE_PROTOCOL"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_PERFORMED_PROCEDURE_PROTOCOL
Visual Basic
Public Shared ReadOnly XA_PERFORMED_PROCEDURE_PROTOCOL As String
Visual C++
public:
static initonly String^ XA_PERFORMED_PROCEDURE_PROTOCOL

See Also

MCservices Structure
MCservices Members


XA_XRF_GRAYSCALE_SOFTCOPY_PS Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XA_XRF_GRAYSCALE_SOFTCOPY_PS Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XA_XRF_GRAYSCALE_SOFTCOPY_PS"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XA_XRF_GRAYSCALE_SOFTCOPY_PS
Visual Basic
Public Shared ReadOnly XA_XRF_GRAYSCALE_SOFTCOPY_PS As String
Visual C++
public:
static initonly String^ XA_XRF_GRAYSCALE_SOFTCOPY_PS

See Also

MCservices Structure
MCservices Members


XRAY_3D_ANGIO_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XRAY_3D_ANGIO_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XRAY_3D_ANGIO_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_ANGIO_IMAGE
Visual Basic
Public Shared ReadOnly XRAY_3D_ANGIO_IMAGE As String
Visual C++
public:
static initonly String^ XRAY_3D_ANGIO_IMAGE

See Also

MCservices Structure
MCservices Members


XRAY_3D_CRANIO_IMAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XRAY_3D_CRANIO_IMAGE Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XRAY_3D_CRANIO_IMAGE"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_3D_CRANIO_IMAGE
Visual Basic
Public Shared ReadOnly XRAY_3D_CRANIO_IMAGE As String
Visual C++
public:
static initonly String^ XRAY_3D_CRANIO_IMAGE

See Also

MCservices Structure
MCservices Members


XRAY_RADIATION_DOSE_SR Field

[image]

Merge DICOM .NET/C# Toolkit
MCservices..::..XRAY_RADIATION_DOSE_SR Field
MCservices Structure See Also Send Feedback

[Missing <summary> documentation for "F:Mergecom.MCservices.XRAY_RADIATION_DOSE_SR"]

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string XRAY_RADIATION_DOSE_SR
Visual Basic
Public Shared ReadOnly XRAY_RADIATION_DOSE_SR As String
Visual C++
public:
static initonly String^ XRAY_RADIATION_DOSE_SR

See Also

MCservices Structure
MCservices Members


MCservices Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCservices Methods
MCservices Structure See Also Send Feedback

The MCservices type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

MCservices Structure


MCsocket Class

[image]

Merge DICOM .NET/C# Toolkit
MCsocket Class
Members See Also Send Feedback
Helper class to create System.Net objects

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static class MCsocket
Visual Basic
Public NotInheritable Class MCsocket
Visual C++
public ref class MCsocket abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCsocket

See Also

MCsocket Members


MCsocket Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsocket Members
MCsocket Class Methods Fields See Also Send Feedback

The MCsocket type exposes the following members.

Methods

Name | Description
getAddress | Returns IPAddress object for given host.
getAddressAny | Returns any available IPAddress object
getEndPoint(Int32) | Returns IPEndPoint object for any available IP address
getEndPoint(IPAddress, Int32) | Creates IPEndPoint for given IPAddress
getEndPoint(String, Int32) | Returns IPEndPoint object for give host
getSocket | Creates Socket object
isAvailable | Checks if given port is available

Fields

Name | Description
ACCEPTOR | Server connection type
REQUESTER | Client connection type

See Also

MCsocket Class


MCsocket Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsocket Fields
MCsocket Class See Also Send Feedback

The MCsocket type exposes the following members.

Fields

Name | Description
ACCEPTOR | Server connection type
REQUESTER | Client connection type

See Also

MCsocket Class


ACCEPTOR Field

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..ACCEPTOR Field
MCsocket Class See Also Send Feedback
Server connection type

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int ACCEPTOR
Visual Basic
Public Shared ACCEPTOR As Integer
Visual C++
public:
static int ACCEPTOR

See Also

MCsocket Class
MCsocket Members


REQUESTER Field

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..REQUESTER Field
MCsocket Class See Also Send Feedback
Client connection type

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int REQUESTER
Visual Basic
Public Shared REQUESTER As Integer
Visual C++
public:
static int REQUESTER

See Also

MCsocket Class
MCsocket Members


MCsocket Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsocket Methods
MCsocket Class See Also Send Feedback

The MCsocket type exposes the following members.

Methods

Name | Description
getAddress | Returns IPAddress object for given host.
getAddressAny | Returns any available IPAddress object
getEndPoint(Int32) | Returns IPEndPoint object for any available IP address
getEndPoint(IPAddress, Int32) | Creates IPEndPoint for given IPAddress
getEndPoint(String, Int32) | Returns IPEndPoint object for give host
getSocket | Creates Socket object
isAvailable | Checks if given port is available

See Also

MCsocket Class


getAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getAddress Method
MCsocket Class See Also Send Feedback
Returns IPAddress object for given host.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static IPAddress getAddress(
    string host
)
Visual Basic
Public Shared Function getAddress ( _
    host As String _
) As IPAddress
Visual C++
public:
static IPAddress^ getAddress(
    String^ host
)

Parameters

host
Type: System..::..String
Host name

Return Value

IPAddress object

See Also

MCsocket Class
MCsocket Members


getAddressAny Method

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getAddressAny Method
MCsocket Class See Also Send Feedback
Returns any available IPAddress object

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static IPAddress getAddressAny()
Visual Basic
Public Shared Function getAddressAny As IPAddress
Visual C++
public:
static IPAddress^ getAddressAny()

Return Value

IPAddress object

See Also

MCsocket Class
MCsocket Members


getEndPoint Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getEndPoint Method
MCsocket Class See Also Send Feedback

Overload List

Name | Description
getEndPoint(Int32) | Returns IPEndPoint object for any available IP address
getEndPoint(IPAddress, Int32) | Creates IPEndPoint for given IPAddress
getEndPoint(String, Int32) | Returns IPEndPoint object for give host

See Also

MCsocket Class
MCsocket Members


getEndPoint Method (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getEndPoint Method (Int32)
MCsocket Class See Also Send Feedback
Returns IPEndPoint object for any available IP address

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static IPEndPoint getEndPoint(
    int port
)
Visual Basic
Public Shared Function getEndPoint ( _
    port As Integer _
) As IPEndPoint
Visual C++
public:
static IPEndPoint^ getEndPoint(
    int port
)

Parameters

port
Type: System..::..Int32
IP listening port

Return Value

IPEndPoint object

See Also

MCsocket Class
MCsocket Members
getEndPoint Overload


getEndPoint Method (IPAddress, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getEndPoint Method (IPAddress, Int32)
MCsocket Class See Also Send Feedback
Creates IPEndPoint for given IPAddress

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static IPEndPoint getEndPoint(
    IPAddress addr,
    int port
)
Visual Basic
Public Shared Function getEndPoint ( _
    addr As IPAddress, _
    port As Integer _
) As IPEndPoint
Visual C++
public:
static IPEndPoint^ getEndPoint(
    IPAddress^ addr,
    int port
)

Parameters

addr
Type: System.Net..::..IPAddress
IPAddress object
port
Type: System..::..Int32
IP listening port

Return Value

IPEndPoint object

See Also

MCsocket Class
MCsocket Members
getEndPoint Overload


getEndPoint Method (String, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getEndPoint Method (String, Int32)
MCsocket Class See Also Send Feedback
Returns IPEndPoint object for give host

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static IPEndPoint getEndPoint(
    string host,
    int port
)
Visual Basic
Public Shared Function getEndPoint ( _
    host As String, _
    port As Integer _
) As IPEndPoint
Visual C++
public:
static IPEndPoint^ getEndPoint(
    String^ host,
    int port
)

Parameters

host
Type: System..::..String
Host name
port
Type: System..::..Int32
IP listening port

Return Value

IPEndPoint object

See Also

MCsocket Class
MCsocket Members
getEndPoint Overload


getSocket Method

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..getSocket Method
MCsocket Class See Also Send Feedback
Creates Socket object

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static Socket getSocket(
    IPEndPoint ep,
    bool dual
)
Visual Basic
Public Shared Function getSocket ( _
    ep As IPEndPoint, _
    dual As Boolean _
) As Socket
Visual C++
public:
static Socket^ getSocket(
    IPEndPoint^ ep,
    bool dual
)

Parameters

ep
Type: System.Net..::..IPEndPoint
IPEndPoint object
dual
Type: System..::..Boolean
True if dual mode is required (IPv4 and IPv6)

Return Value

Socket object

See Also

MCsocket Class
MCsocket Members


isAvailable Method

[image]

Merge DICOM .NET/C# Toolkit
MCsocket..::..isAvailable Method
MCsocket Class See Also Send Feedback
Checks if given port is available

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool isAvailable(
    int port
)
Visual Basic
Public Shared Function isAvailable ( _
    port As Integer _
) As Boolean
Visual C++
public:
static bool isAvailable(
    int port
)

Parameters

port
Type: System..::..Int32
IP port

Return Value

True if port is available

See Also

MCsocket Class
MCsocket Members


MCsopClass Class

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass Class
Members See Also Send Feedback
Represents a DICOM SOP (Service-Object Pair) Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCsopClass
Visual Basic
Public Class MCsopClass
Visual C++
public ref class MCsopClass

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCsopClass

See Also

MCsopClass Members


MCsopClass Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopClass Members
MCsopClass Class Methods Properties See Also Send Feedback

The MCsopClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines if this object equals another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code equal to this object's internal numeric ID. (Overrides Object..::..GetHashCode()()()().)
 | getSopClassByName | Gets the MCsopClass object which encapsulates the DICOM service identified by the specified name.
 | getSopClassByUid | Gets the MCsopClass object that encapsulates the DICOM service identified by a specific UID.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseClass | Tells whether this is a base SOP class, as opposed to a meta SOP Class.
Public property | BaseClasses | The list containing MCsopClass objects describing the base classes of a DICOM meta SOP class.
Public property | Commands | The array which reflects which DICOM commands are supported by this service.
Public property | MetaClass | Tells whether this is a meta SOP class, as opposed to a base SOP Class.
Public property | Name | The name of this service class.
Public property | Number | The service number assigned to the SOP Class in the Mergecom.srv file.
Public property | Uid | The SOP Class UID for this service.

See Also

MCsopClass Class


MCsopClass Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopClass Methods
MCsopClass Class See Also Send Feedback

The MCsopClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines if this object equals another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code equal to this object's internal numeric ID. (Overrides Object..::..GetHashCode()()()().)
 | getSopClassByName | Gets the MCsopClass object which encapsulates the DICOM service identified by the specified name.
 | getSopClassByUid | Gets the MCsopClass object that encapsulates the DICOM service identified by a specific UID.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCsopClass Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..Equals Method
MCsopClass Class See Also Send Feedback
Determines if this object equals another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object
The object to compare to this object

Return Value

true if both objects refer to the same DICOM SOP Class

Remarks

The other object is considered equal to this object if it is a non-null MCsopClass instance and its library-assigned id is the same as that assigned to this object.

See Also

MCsopClass Class
MCsopClass Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..GetHashCode Method
MCsopClass Class See Also Send Feedback
Returns a hash code equal to this object's internal numeric ID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A code usable for hash tables.

See Also

MCsopClass Class
MCsopClass Members


getSopClassByName Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..getSopClassByName Method
MCsopClass Class See Also Send Feedback
Gets the MCsopClass object which encapsulates the DICOM service identified by the specified name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCsopClass getSopClassByName(
    string name
)
Visual Basic
Public Shared Function getSopClassByName ( _
    name As String _
) As MCsopClass
Visual C++
public:
static MCsopClass^ getSopClassByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name of a DICOM service.

Return Value

A not null MCsopClass object.

Remarks

Each DICOM service supported by Merge DICOM Toolkit is identified by its DICOM unique identifier (the UID) and by a unique name (serviceName).

The library maintains a collection of MCsopClass objects. As objects are retrieved from the C tool kit, they are maintained in the collection so subsequent calls to this method will return the same instance for the same name.

If the method cannot find the requested MCsopClass instance, an MCnotFoundException exception is thrown.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument is not a valid service name.
Mergecom.Exceptions..::..MCnotFoundException | No SOP class is defined with the specified name.

See Also

MCsopClass Class
MCsopClass Members


getSopClassByUid Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..getSopClassByUid Method
MCsopClass Class See Also Send Feedback
Gets the MCsopClass object that encapsulates the DICOM service identified by a specific UID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCsopClass getSopClassByUid(
    string uid
)
Visual Basic
Public Shared Function getSopClassByUid ( _
    uid As String _
) As MCsopClass
Visual C++
public:
static MCsopClass^ getSopClassByUid(
    String^ uid
)

Parameters

uid
Type: System..::..String
The not null DICOM unique identifier assigned to the requested SOP Class.

Return Value

A not null MCsopClass object.

Remarks

The library maintains a collection of MCsopClass objects. As objects are retrieved from the C tool kit, they are maintained in the collection so subsequent calls to this method will return the same instance for the same UID.

If the method cannot find an instance matching the provided UID, an MCnotFoundException exception is thrown.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument is not a valid DICOM UID string.
Mergecom.Exceptions..::..MCnotFoundException | No SOP class is defined for the specified UID.

See Also

MCsopClass Class
MCsopClass Members


MCsopClass Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopClass Properties
MCsopClass Class See Also Send Feedback

The MCsopClass type exposes the following members.

Properties

 | Name | Description
Public property | BaseClass | Tells whether this is a base SOP class, as opposed to a meta SOP Class.
Public property | BaseClasses | The list containing MCsopClass objects describing the base classes of a DICOM meta SOP class.
Public property | Commands | The array which reflects which DICOM commands are supported by this service.
Public property | MetaClass | Tells whether this is a meta SOP class, as opposed to a base SOP Class.
Public property | Name | The name of this service class.
Public property | Number | The service number assigned to the SOP Class in the Mergecom.srv file.
Public property | Uid | The SOP Class UID for this service.

See Also

MCsopClass Class


BaseClass Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..BaseClass Property
MCsopClass Class See Also Send Feedback
Tells whether this is a base SOP class, as opposed to a meta SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool BaseClass { get; }
Visual Basic
Public Overridable ReadOnly Property BaseClass As Boolean
    Get
Visual C++
public:
virtual property bool BaseClass {
    bool get ();
}

Field Value

true if this is a base SOP class; false if this is a meta SOP class.

See Also

MCsopClass Class
MCsopClass Members


BaseClasses Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..BaseClasses Property
MCsopClass Class See Also Send Feedback
The list containing MCsopClass objects describing the base classes of a DICOM meta SOP class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IList BaseClasses { get; }
Visual Basic
Public Overridable ReadOnly Property BaseClasses As IList
    Get
Visual C++
public:
virtual property IList^ BaseClasses {
    IList^ get ();
}

Field Value

An IList of MCsopClass objects, or null if this is not a meta SOP class.

See Also

MCsopClass Class
MCsopClass Members


Commands Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..Commands Property
MCsopClass Class See Also Send Feedback
The array which reflects which DICOM commands are supported by this service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual BitArray Commands { get; }
Visual Basic
Public Overridable ReadOnly Property Commands As BitArray
    Get
Visual C++
public:
virtual property BitArray^ Commands {
    BitArray^ get ();
}

Field Value

A BitArray reflecting the commands supported by this service.

Remarks

MCdimseService defines values which can be used to identify index values into the bit array for each DICOM command.

See Also

MCsopClass Class
MCsopClass Members


MetaClass Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..MetaClass Property
MCsopClass Class See Also Send Feedback
Tells whether this is a meta SOP class, as opposed to a base SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MetaClass { get; }
Visual Basic
Public Overridable ReadOnly Property MetaClass As Boolean
    Get
Visual C++
public:
virtual property bool MetaClass {
    bool get ();
}

Field Value

false if this is a base SOP class; true if this is a meta SOP class.

See Also

MCsopClass Class
MCsopClass Members


Name Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..Name Property
MCsopClass Class See Also Send Feedback
The name of this service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

A String containing the name of this service class.

See Also

MCsopClass Class
MCsopClass Members


Number Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..Number Property
MCsopClass Class See Also Send Feedback
The service number assigned to the SOP Class in the Mergecom.srv file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int Number { get; }
Visual Basic
Public Overridable ReadOnly Property Number As Integer
    Get
Visual C++
public:
virtual property int Number {
    int get ();
}

Field Value

The number assigned to the SOP Class.

See Also

MCsopClass Class
MCsopClass Members


Uid Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopClass..::..Uid Property
MCsopClass Class See Also Send Feedback
The SOP Class UID for this service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Uid { get; }
Visual Basic
Public Overridable ReadOnly Property Uid As String
    Get
Visual C++
public:
virtual property String^ Uid {
    String^ get ();
}

Field Value

A String containing the SOP Class UID for this service.

See Also

MCsopClass Class
MCsopClass Members


MCsopInstanceReference Class

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Class
Members See Also Send Feedback
Encapsulates the attributes that reference an SOP instance

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCsopInstanceReference : MCdataSetSerializable
Visual Basic
Public Class MCsopInstanceReference _
    Implements MCdataSetSerializable
Visual C++
public ref class MCsopInstanceReference : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCsopInstanceReference

See Also

MCsopInstanceReference Members


MCsopInstanceReference Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Members
MCsopInstanceReference Class Constructors Methods Properties See Also Send Feedback

The MCsopInstanceReference type exposes the following members.

Constructors

 | Name | Description
Public method | MCsopInstanceReference()()()() | Default constructor
Public method | MCsopInstanceReference(String, String) | Creates a new instance of MCsopInstanceReference

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

Properties

 | Name | Description
Public property | ReferencedSopClassUid | Uniquely identifies the referenced SOP Class.
Public property | ReferencedSopInstanceUid | Uniquely identifies the referenced SOP Instance.

See Also

MCsopInstanceReference Class


MCsopInstanceReference Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Constructor
MCsopInstanceReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCsopInstanceReference()()()() | Default constructor
Public method | MCsopInstanceReference(String, String) | Creates a new instance of MCsopInstanceReference

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members


MCsopInstanceReference Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Constructor
MCsopInstanceReference Class See Also Send Feedback
Default constructor

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReference()
Visual Basic
Public Sub New
Visual C++
public:
MCsopInstanceReference()

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members
MCsopInstanceReference Overload


MCsopInstanceReference Constructor (String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Constructor (String, String)
MCsopInstanceReference Class See Also Send Feedback
Creates a new instance of MCsopInstanceReference

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReference(
    string referencedSopClassUid,
    string referencedSopInstanceUid
)
Visual Basic
Public Sub New ( _
    referencedSopClassUid As String, _
    referencedSopInstanceUid As String _
)
Visual C++
public:
MCsopInstanceReference(
    String^ referencedSopClassUid,
    String^ referencedSopInstanceUid
)

Parameters

referencedSopClassUid
Type: System..::..String
Uniquely identifies the referenced SOP Class.
referencedSopInstanceUid
Type: System..::..String
Uniquely identifies the referenced SOP Instance.

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members
MCsopInstanceReference Overload


MCsopInstanceReference Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Methods
MCsopInstanceReference Class See Also Send Feedback

The MCsopInstanceReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

See Also

MCsopInstanceReference Class


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference..::..Read Method
MCsopInstanceReference Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Read(
    MCattributeSet source
)
Visual Basic
Public Overridable Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
)

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet in REFERENCED_SOP_SEQUENCE

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference..::..Write Method
MCsopInstanceReference Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Write(
    MCattributeSet destination
)
Visual Basic
Public Overridable Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
)

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet in REFERENCED_SOP_SEQUENCE

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members


MCsopInstanceReference Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference Properties
MCsopInstanceReference Class See Also Send Feedback

The MCsopInstanceReference type exposes the following members.

Properties

 | Name | Description
Public property | ReferencedSopClassUid | Uniquely identifies the referenced SOP Class.
Public property | ReferencedSopInstanceUid | Uniquely identifies the referenced SOP Instance.

See Also

MCsopInstanceReference Class


ReferencedSopClassUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference..::..ReferencedSopClassUid Property
MCsopInstanceReference Class See Also Send Feedback
Uniquely identifies the referenced SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ReferencedSopClassUid { get; set; }
Visual Basic
Public Property ReferencedSopClassUid As String
    Get
    Set
Visual C++
public:
property String^ ReferencedSopClassUid {
    String^ get ();
    void set (String^ value);
}

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members


ReferencedSopInstanceUid Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReference..::..ReferencedSopInstanceUid Property
MCsopInstanceReference Class See Also Send Feedback
Uniquely identifies the referenced SOP Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ReferencedSopInstanceUid { get; set; }
Visual Basic
Public Property ReferencedSopInstanceUid As String
    Get
    Set
Visual C++
public:
property String^ ReferencedSopInstanceUid {
    String^ get ();
    void set (String^ value);
}

See Also

MCsopInstanceReference Class
MCsopInstanceReference Members


MCstandardCompressor Class

[image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor Class
Members See Also Send Feedback
This standard compressor implements the MCcompression interface and it can be used to compress the JPEG Lossless Non-Hierarchical 14 transfer syntax, the JPEG Baseline transfer syntax and the JPEG Extended 2,4 transfer syntaxes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstandardCompressor : MCcompression
Visual Basic
Public Class MCstandardCompressor _
    Implements MCcompression
Visual C++
public ref class MCstandardCompressor : MCcompression

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCstandardCompressor

See Also

MCstandardCompressor Members
Mergecom Namespace
MCtransferSyntax..::..JpegLosslesNonHier14
MCtransferSyntax..::..JpegBaseline
MCtransferSyntax..::..JpegExtended2_4


MCstandardCompressor Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor Members
MCstandardCompressor Class Constructors Methods See Also Send Feedback

The MCstandardCompressor type exposes the following members.

Constructors

 | Name | Description
Public method | MCstandardCompressor | Initializes a new instance of the JPEG compressor.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the JPEG compressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the JPEG compressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the JPEG compressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstandardCompressor Class


MCstandardCompressor Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor Constructor
MCstandardCompressor Class See Also Send Feedback
Initializes a new instance of the JPEG compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstandardCompressor()
Visual Basic
Public Sub New
Visual C++
public:
MCstandardCompressor()

See Also

MCstandardCompressor Class
MCstandardCompressor Members


MCstandardCompressor Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor Methods
MCstandardCompressor Class See Also Send Feedback

The MCstandardCompressor type exposes the following members.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the JPEG compressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the JPEG compressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the JPEG compressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstandardCompressor Class


createContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor..::..createContext Method
MCstandardCompressor Class See Also Send Feedback
Implementation of MCcompression.createContext method for the JPEG compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object createContext(
    MCattributeSet ats,
    MCtransferSyntax source,
    MCtransferSyntax destination
)
Visual Basic
Public Function createContext ( _
    ats As MCattributeSet, _
    source As MCtransferSyntax, _
    destination As MCtransferSyntax _
) As Object
Visual C++
public:
virtual Object^ createContext(
    MCattributeSet^ ats,
    MCtransferSyntax^ source,
    MCtransferSyntax^ destination
) sealed

Parameters

ats
Type: Mergecom..::..MCattributeSet
The attribute set containing the pixel data being compressed.
source
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the source data.
destination
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the destination data.

Return Value

The context object for JPEG compression.

Implements

MCcompression..::..createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax)

See Also

MCstandardCompressor Class
MCstandardCompressor Members


processData Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor..::..processData Method
MCstandardCompressor Class See Also Send Feedback
Implementation of the MCcompression.processData method for the JPEG compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata processData(
    Object context,
    MCdata inputData,
    bool isFirst
)
Visual Basic
Public Function processData ( _
    context As Object, _
    inputData As MCdata, _
    isFirst As Boolean _
) As MCdata
Visual C++
public:
virtual MCdata^ processData(
    Object^ context,
    MCdata^ inputData,
    bool isFirst
) sealed

Parameters

context
Type: System..::..Object
The context created by the createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.
inputData
Type: Mergecom..::..MCdata
The input data to the decompressor.
isFirst
Type: System..::..Boolean
Set to true on the first call to process data.

Return Value

Returns compressed data. May return null if no data is available.

Implements

MCcompression..::..processData(Object, MCdata, Boolean)

See Also

MCstandardCompressor Class
MCstandardCompressor Members


releaseContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardCompressor..::..releaseContext Method
MCstandardCompressor Class See Also Send Feedback
Implementation of the MCcompression.releaseContext method for the JPEG compressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void releaseContext(
    Object context
)
Visual Basic
Public Sub releaseContext ( _
    context As Object _
)
Visual C++
public:
virtual void releaseContext(
    Object^ context
) sealed

Parameters

context
Type: System..::..Object
The context object created by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.

Implements

MCcompression..::..releaseContext(Object)

See Also

MCstandardCompressor Class
MCstandardCompressor Members


MCstandardDecompressor Class

[image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor Class
Members See Also Send Feedback
This standard decompressor implements the MCcompression interface and it can be used to decompress the JPEG Lossless Non-Hierarchical 14 transfer syntax, the JPEG Baseline transfer syntax and the JPEG Extended 2,4 transfer syntaxes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstandardDecompressor : MCcompression
Visual Basic
Public Class MCstandardDecompressor _
    Implements MCcompression
Visual C++
public ref class MCstandardDecompressor : MCcompression

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCstandardDecompressor

See Also

MCstandardDecompressor Members
Mergecom Namespace
MCtransferSyntax..::..JpegLosslesNonHier14
MCtransferSyntax..::..JpegBaseline
MCtransferSyntax..::..JpegExtended2_4


MCstandardDecompressor Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor Members
MCstandardDecompressor Class Constructors Methods See Also Send Feedback

The MCstandardDecompressor type exposes the following members.

Constructors

 | Name | Description
Public method | MCstandardDecompressor | Initializes a new instance of the JPEG decompressor.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the JPEG decompressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the JPEG decompressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the JPEG decompressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstandardDecompressor Class


MCstandardDecompressor Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor Constructor
MCstandardDecompressor Class See Also Send Feedback
Initializes a new instance of the JPEG decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstandardDecompressor()
Visual Basic
Public Sub New
Visual C++
public:
MCstandardDecompressor()

See Also

MCstandardDecompressor Class
MCstandardDecompressor Members


MCstandardDecompressor Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor Methods
MCstandardDecompressor Class See Also Send Feedback

The MCstandardDecompressor type exposes the following members.

Methods

 | Name | Description
Public method | createContext | Implementation of MCcompression.createContext method for the JPEG decompressor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | processData | Implementation of the MCcompression.processData method for the JPEG decompressor.
Public method | releaseContext | Implementation of the MCcompression.releaseContext method for the JPEG decompressor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstandardDecompressor Class


createContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor..::..createContext Method
MCstandardDecompressor Class See Also Send Feedback
Implementation of MCcompression.createContext method for the JPEG decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object createContext(
    MCattributeSet ats,
    MCtransferSyntax source,
    MCtransferSyntax destination
)
Visual Basic
Public Function createContext ( _
    ats As MCattributeSet, _
    source As MCtransferSyntax, _
    destination As MCtransferSyntax _
) As Object
Visual C++
public:
virtual Object^ createContext(
    MCattributeSet^ ats,
    MCtransferSyntax^ source,
    MCtransferSyntax^ destination
) sealed

Parameters

ats
Type: Mergecom..::..MCattributeSet
The attribute set containing the pixel data being decompressed.
source
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the source data.
destination
Type: Mergecom..::..MCtransferSyntax
The transfer syntax of the destination data.

Return Value

The context object for JPEG decompression.

Implements

MCcompression..::..createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax)

See Also

MCstandardDecompressor Class
MCstandardDecompressor Members


processData Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor..::..processData Method
MCstandardDecompressor Class See Also Send Feedback
Implementation of the MCcompression.processData method for the JPEG decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata processData(
    Object context,
    MCdata inputData,
    bool isFirst
)
Visual Basic
Public Function processData ( _
    context As Object, _
    inputData As MCdata, _
    isFirst As Boolean _
) As MCdata
Visual C++
public:
virtual MCdata^ processData(
    Object^ context,
    MCdata^ inputData,
    bool isFirst
) sealed

Parameters

context
Type: System..::..Object
The context created by the createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.
inputData
Type: Mergecom..::..MCdata
The input data to the decompressor.
isFirst
Type: System..::..Boolean
Set to true on the first call to process data.

Return Value

Returns decompressed data. May return null if no data is available.

Implements

MCcompression..::..processData(Object, MCdata, Boolean)

See Also

MCstandardDecompressor Class
MCstandardDecompressor Members


releaseContext Method

[image]

Merge DICOM .NET/C# Toolkit
MCstandardDecompressor..::..releaseContext Method
MCstandardDecompressor Class See Also Send Feedback
Implementation of the MCcompression.releaseContext method for the JPEG decompressor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void releaseContext(
    Object context
)
Visual Basic
Public Sub releaseContext ( _
    context As Object _
)
Visual C++
public:
virtual void releaseContext(
    Object^ context
) sealed

Parameters

context
Type: System..::..Object
The context object created by createContext(MCattributeSet, MCtransferSyntax, MCtransferSyntax) method.

Implements

MCcompression..::..releaseContext(Object)

See Also

MCstandardDecompressor Class
MCstandardDecompressor Members


MCstorageCommitmentService Class

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Class
Members See Also Send Feedback
Represents a DICOM Storage Commitment Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstorageCommitmentService : MCdimseService
Visual Basic
Public Class MCstorageCommitmentService _
    Inherits MCdimseService
Visual C++
public ref class MCstorageCommitmentService : public MCdimseService

Remarks

his class provides methods to support the following standard SOP Classes:
  • Storage Commitment Push Model SOP Class
  • Storage Commitment Pull Model SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCstorageCommitmentService

See Also

MCstorageCommitmentService Members


MCstorageCommitmentService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Members
MCstorageCommitmentService Class Constructors Methods Fields Properties See Also Send Feedback

The MCstorageCommitmentService type exposes the following members.

Constructors

 | Name | Description
Public method | MCstorageCommitmentService | Initializes a new instance of this class for the specified association.

Methods

 | Name | Description
Public method | acceptCommitmentNotification | Sends a N-EVENT_NOTIFICATION Response message with a status of success.
Public method | acceptCommitmentRequest | Sends a N-ACTION Response message with a status of success.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getFailedSops | Retrieves the list of failed SOP instances contained in a Storage Commit Notification.
Public method | getFileSetId | Retrieves the Storage Commitment Media File Set ID from a DIMSE message.
Public method | getFileSetUid | Retrieve the Storage Commitment Media File Set UID from a DIMSE message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getReferencedSops | Retrieves the list of referenced SOP instances from a Storage Commit message.
Public method | getReferencedStudy | Retrieves the Referenced Study Component from a DIMSE message.
Public method | getRetrieveAeTitle | Retrieves the Storage Commitment Retrieve AE Title from a DIMSE message.
Public method | getSuccessfulSops | Retrieves the list of referenced SOP instances.
Public method | getTransactionUid | Retrieves the Storage Commitment Transaction UID from a DIMSE message.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | rejectCommitmentNotification | Sends a N-EVENT_NOTIFICATION Response message with a specified failure status code.
Public method | rejectCommitmentRequest | Sends a N-ACTION Response message with a specified failure status code.
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCommitmentNotification(String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)
 | PULL_MODEL | Constant used to specify that the Pull Model of the Storage Commitment Service Class is being used.
 | PUSH_MODEL | Constant used to specify that the Push Model of the Storage Commitment Service Class is being used.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstorageCommitmentService Class


MCstorageCommitmentService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Constructor
MCstorageCommitmentService Class See Also Send Feedback
Initializes a new instance of this class for the specified association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstorageCommitmentService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCstorageCommitmentService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


MCstorageCommitmentService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Fields
MCstorageCommitmentService Class See Also Send Feedback

The MCstorageCommitmentService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)
 | PULL_MODEL | Constant used to specify that the Pull Model of the Storage Commitment Service Class is being used.
 | PUSH_MODEL | Constant used to specify that the Push Model of the Storage Commitment Service Class is being used.

See Also

MCstorageCommitmentService Class


PULL_MODEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..PULL_MODEL Field
MCstorageCommitmentService Class See Also Send Feedback
Constant used to specify that the Pull Model of the Storage Commitment Service Class is being used.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short PULL_MODEL
Visual Basic
Public Const PULL_MODEL As Short
Visual C++
public:
literal short PULL_MODEL

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


PUSH_MODEL Field

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..PUSH_MODEL Field
MCstorageCommitmentService Class See Also Send Feedback
Constant used to specify that the Push Model of the Storage Commitment Service Class is being used.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short PUSH_MODEL
Visual Basic
Public Const PUSH_MODEL As Short
Visual C++
public:
literal short PUSH_MODEL

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


MCstorageCommitmentService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Methods
MCstorageCommitmentService Class See Also Send Feedback

The MCstorageCommitmentService type exposes the following members.

Methods

 | Name | Description
Public method | acceptCommitmentNotification | Sends a N-EVENT_NOTIFICATION Response message with a status of success.
Public method | acceptCommitmentRequest | Sends a N-ACTION Response message with a status of success.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getFailedSops | Retrieves the list of failed SOP instances contained in a Storage Commit Notification.
Public method | getFileSetId | Retrieves the Storage Commitment Media File Set ID from a DIMSE message.
Public method | getFileSetUid | Retrieve the Storage Commitment Media File Set UID from a DIMSE message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getReferencedSops | Retrieves the list of referenced SOP instances from a Storage Commit message.
Public method | getReferencedStudy | Retrieves the Referenced Study Component from a DIMSE message.
Public method | getRetrieveAeTitle | Retrieves the Storage Commitment Retrieve AE Title from a DIMSE message.
Public method | getSuccessfulSops | Retrieves the list of referenced SOP instances.
Public method | getTransactionUid | Retrieves the Storage Commitment Transaction UID from a DIMSE message.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | rejectCommitmentNotification | Sends a N-EVENT_NOTIFICATION Response message with a specified failure status code.
Public method | rejectCommitmentRequest | Sends a N-ACTION Response message with a specified failure status code.
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCommitmentNotification(String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstorageCommitmentService Class


acceptCommitmentNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..acceptCommitmentNotification Method
MCstorageCommitmentService Class See Also Send Feedback
Sends a N-EVENT_NOTIFICATION Response message with a status of success.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptCommitmentNotification(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptCommitmentNotification ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptCommitmentNotification(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-EVENT-NOTIFICATION Request message being responded to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException |
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCillegalArgumentException | The request message was to null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


acceptCommitmentRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..acceptCommitmentRequest Method
MCstorageCommitmentService Class See Also Send Feedback
Sends a N-ACTION Response message with a status of success.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptCommitmentRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptCommitmentRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptCommitmentRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-ACTION Request message being responded to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException |
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCillegalArgumentException | The request message was to null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getFailedSops Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getFailedSops Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the list of failed SOP instances contained in a Storage Commit Notification.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCfailedSopInfo[] getFailedSops(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getFailedSops ( _
    msg As MCdimseMessage _
) As MCfailedSopInfo()
Visual C++
public:
virtual array<MCfailedSopInfo^>^ getFailedSops(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage containing the Storage Commit Notification message.

Return Value

An array of MCfailedSopInfo objects or null if FAILED_SOP_SEQUENCE is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidMessageReceivedException | msg was not formatted properly and the failed SOPs could not be retrieved from the message.
Mergecom.Exceptions..::..MCillegalArgumentException | The message argument was invalid.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getFileSetId Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getFileSetId Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the Storage Commitment Media File Set ID from a DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string getFileSetId(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getFileSetId ( _
    msg As MCdimseMessage _
) As String
Visual C++
public:
virtual String^ getFileSetId(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

Media File Set ID or null if STORAGE_MEDIA_FILE_SET_ID is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getFileSetUid Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getFileSetUid Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieve the Storage Commitment Media File Set UID from a DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string getFileSetUid(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getFileSetUid ( _
    msg As MCdimseMessage _
) As String
Visual C++
public:
virtual String^ getFileSetUid(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing Storage Commit message.

Return Value

Media File Set UID or null if STORAGE_MEDIA_FILE_SET_UID is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getReferencedSops Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getReferencedSops Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the list of referenced SOP instances from a Storage Commit message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCrefSopInfo[] getReferencedSops(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getReferencedSops ( _
    msg As MCdimseMessage _
) As MCrefSopInfo()
Visual C++
public:
virtual array<MCrefSopInfo^>^ getReferencedSops(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

An array of MCrefSopInfo objects or null if REFERENCED_SOP_SEQUENCE is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidMessageReceivedException | msg was not formatted properly and the failed SOPs could not be retrieved from the message.
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getReferencedStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getReferencedStudy Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the Referenced Study Component from a DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCrefStudyInfo getReferencedStudy(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getReferencedStudy ( _
    msg As MCdimseMessage _
) As MCrefStudyInfo
Visual C++
public:
virtual MCrefStudyInfo^ getReferencedStudy(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

An MCrefStudyInfo object or null if REFERENCED_STUDY_COMPONENT_SEQUENCE is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidMessageReceivedException | msg was not formatted properly and the Referenced Study could not be retrieved from the message.
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getRetrieveAeTitle Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getRetrieveAeTitle Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the Storage Commitment Retrieve AE Title from a DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string getRetrieveAeTitle(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getRetrieveAeTitle ( _
    msg As MCdimseMessage _
) As String
Visual C++
public:
virtual String^ getRetrieveAeTitle(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

The Retrieve AE Title or null if RETRIEVE_AE_TITLE is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getSuccessfulSops Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getSuccessfulSops Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the list of referenced SOP instances.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCrefSopInfo[] getSuccessfulSops(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getSuccessfulSops ( _
    msg As MCdimseMessage _
) As MCrefSopInfo()
Visual C++
public:
virtual array<MCrefSopInfo^>^ getSuccessfulSops(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

An array of MCrefSopInfo objects or null if REFERENCED_SOP_SEQUENCE is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidMessageReceivedException | msg was not formatted properly and the failed SOPs could not be retrieved from the message.
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


getTransactionUid Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..getTransactionUid Method
MCstorageCommitmentService Class See Also Send Feedback
Retrieves the Storage Commitment Transaction UID from a DIMSE message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string getTransactionUid(
    MCdimseMessage msg
)
Visual Basic
Public Overridable Function getTransactionUid ( _
    msg As MCdimseMessage _
) As String
Visual C++
public:
virtual String^ getTransactionUid(
    MCdimseMessage^ msg
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage object containing the Storage Commit message.

Return Value

The Transaction UID or null if TRANSACTION_UID is not encoded or is empty.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | Message has been cleaned up.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was null.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


rejectCommitmentNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..rejectCommitmentNotification Method
MCstorageCommitmentService Class See Also Send Feedback
Sends a N-EVENT_NOTIFICATION Response message with a specified failure status code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void rejectCommitmentNotification(
    MCdimseMessage requestMsg,
    ushort reason
)
Visual Basic
Public Overridable Sub rejectCommitmentNotification ( _
    requestMsg As MCdimseMessage, _
    reason As UShort _
)
Visual C++
public:
virtual void rejectCommitmentNotification(
    MCdimseMessage^ requestMsg,
    unsigned short reason
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-EVENT-REPORT Request message being responded to.
reason
Type: System..::..UInt16
A valid DICOM status code providing the reason the N-EVENT-NOTIFICATION was unacceptable.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | - The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The request message was invalid.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


rejectCommitmentRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..rejectCommitmentRequest Method
MCstorageCommitmentService Class See Also Send Feedback
Sends a N-ACTION Response message with a specified failure status code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void rejectCommitmentRequest(
    MCdimseMessage requestMsg,
    ushort reason
)
Visual Basic
Public Overridable Sub rejectCommitmentRequest ( _
    requestMsg As MCdimseMessage, _
    reason As UShort _
)
Visual C++
public:
virtual void rejectCommitmentRequest(
    MCdimseMessage^ requestMsg,
    unsigned short reason
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-ACTION Request message being responded to.
reason
Type: System..::..UInt16
A valid DICOM status code providing the reason the N-ACTION was unacceptable.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | - This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | - The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The request message was invalid.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


requestStorageCommitment Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method
MCstorageCommitmentService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String, Int16) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], String) | Requests Storage Commitment.
Public method | requestStorageCommitment(String, String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String) | Requests Storage Commitment.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


requestStorageCommitment Method (String, MCrefSopInfo[], String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, array<MCrefSopInfo>[]()[][], String, Int16)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    MCrefSopInfo[] referencedSops,
    string serviceName,
    short model
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    referencedSops As MCrefSopInfo(), _
    serviceName As String, _
    model As Short _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    array<MCrefSopInfo^>^ referencedSops,
    String^ serviceName,
    short model
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitmentrequest.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH" or "STORAGE_COMMITMENT_PULL".
model
Type: System..::..Int16
Model to use: PUSH_MODEL or PULL_MODEL.

Return Value

An MCdimseMessage object encapsulating the N_ACTION messagethat was just sent.

Remarks

This form may be used with the PUSH or PULL Model.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


requestStorageCommitment Method (String, String, MCrefSopInfo[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, String, array<MCrefSopInfo>[]()[][], String)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    string retrieveAeTitle,
    MCrefSopInfo[] referencedSops,
    string serviceName
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    retrieveAeTitle As String, _
    referencedSops As MCrefSopInfo(), _
    serviceName As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    String^ retrieveAeTitle,
    array<MCrefSopInfo^>^ referencedSops,
    String^ serviceName
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitment request.
retrieveAeTitle
Type: System..::..String
Application Entity Title of application to be used for SOP instance retrieval.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PULL".

Return Value

An MCdimseMessage object encapsulating the N_ACTION message that was just sent.

Remarks

This form may be used for PULL Model, when all of the referenced SOP instances are retrievable from the application entity specified by retrieveAeTitle.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


requestStorageCommitment Method (String, MCrefSopInfo[], MCrefStudyInfo, String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String, Int16)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    MCrefSopInfo[] referencedSops,
    MCrefStudyInfo referencedStudy,
    string serviceName,
    short model
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    referencedSops As MCrefSopInfo(), _
    referencedStudy As MCrefStudyInfo, _
    serviceName As String, _
    model As Short _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    array<MCrefSopInfo^>^ referencedSops,
    MCrefStudyInfo^ referencedStudy,
    String^ serviceName,
    short model
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitment request.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
referencedStudy
Type: Mergecom..::..MCrefStudyInfo
An MCrefStudyInfo object describing the study to which the referenced SOP instances (referencedSops) belong.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH" or "STORAGE_COMMITMENT_PULL"
model
Type: System..::..Int16
Model to use: PUSH_MODEL or PULL_MODEL.

Return Value

An MCdimseMessage object encapsulating the N_ACTION message that was just sent.

Remarks

This form may be used with the PUSH or PULL Model, when all of the instances belong to the same Study Component and represent the complete set of SOP instances for that Study Component.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


requestStorageCommitment Method (String, String, MCrefSopInfo[], MCrefStudyInfo, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    string retrieveAeTitle,
    MCrefSopInfo[] referencedSops,
    MCrefStudyInfo referencedStudy,
    string serviceName
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    retrieveAeTitle As String, _
    referencedSops As MCrefSopInfo(), _
    referencedStudy As MCrefStudyInfo, _
    serviceName As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    String^ retrieveAeTitle,
    array<MCrefSopInfo^>^ referencedSops,
    MCrefStudyInfo^ referencedStudy,
    String^ serviceName
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitment request.
retrieveAeTitle
Type: System..::..String
Application Entity Title of application to be used for SOP instance retrieval.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
referencedStudy
Type: Mergecom..::..MCrefStudyInfo
An MCrefStudyInfo object describing the study to which the referenced SOP instances (referencedSops) belong.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PULL".

Return Value

An MCdimseMessage object encapsulating the N_ACTION message that was just sent.

Remarks

This form may be used for PULL Model, when all of the referenced SOP instances are retrievable from the application entity specified by retrieveAeTitle, and all of the instances belong to the same Study Component and represent the complete set of SOP instances for that Study Component.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


requestStorageCommitment Method (String, String, String, MCrefSopInfo[], String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, String, String, array<MCrefSopInfo>[]()[][], String)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    string fileSetId,
    string fileSetUid,
    MCrefSopInfo[] referencedSops,
    string serviceName
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    fileSetId As String, _
    fileSetUid As String, _
    referencedSops As MCrefSopInfo(), _
    serviceName As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    String^ fileSetId,
    String^ fileSetUid,
    array<MCrefSopInfo^>^ referencedSops,
    String^ serviceName
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitment request.
fileSetId
Type: System..::..String
Storage Media File Set ID.
fileSetUid
Type: System..::..String
Storage Media File Set UID.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH".

Return Value

An MCdimseMessage object encapsulating the N_ACTION message that was just sent.

Remarks

This form may be used for PUSH Model, when all of the referenced SOP instances are located on the same media file set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


requestStorageCommitment Method (String, String, String, MCrefSopInfo[], MCrefStudyInfo, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..requestStorageCommitment Method (String, String, String, array<MCrefSopInfo>[]()[][], MCrefStudyInfo, String)
MCstorageCommitmentService Class See Also Send Feedback
Requests Storage Commitment.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage requestStorageCommitment(
    string transactionUid,
    string fileSetId,
    string fileSetUid,
    MCrefSopInfo[] referencedSops,
    MCrefStudyInfo referencedStudy,
    string serviceName
)
Visual Basic
Public Overridable Function requestStorageCommitment ( _
    transactionUid As String, _
    fileSetId As String, _
    fileSetUid As String, _
    referencedSops As MCrefSopInfo(), _
    referencedStudy As MCrefStudyInfo, _
    serviceName As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ requestStorageCommitment(
    String^ transactionUid,
    String^ fileSetId,
    String^ fileSetUid,
    array<MCrefSopInfo^>^ referencedSops,
    MCrefStudyInfo^ referencedStudy,
    String^ serviceName
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies this storage commitment request.
fileSetId
Type: System..::..String
Storage Media File Set ID.
fileSetUid
Type: System..::..String
Storage Media File Set UID.
referencedSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects that describe a set of referenced SOP instances.
referencedStudy
Type: Mergecom..::..MCrefStudyInfo
An MCrefStudyInfo object describing the study to which the referenced SOP instances (referencedSops) belong.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH".

Return Value

An MCdimseMessage object encapsulating the N_ACTION message that was just sent.

Remarks

This form may be used for PUSH Model, when all of the referenced SOP instances are located on the same media file set, and all of the instances belong to the same Study Component and represent the complete set of SOP instances for that Study Component.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCconfigurationError | An error occurred involving the message info file. The exact error is logged in the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
requestStorageCommitment Overload


sendCommitmentNotification Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..sendCommitmentNotification Method
MCstorageCommitmentService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCommitmentNotification(String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.
Public method | sendCommitmentNotification(String, String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16) | Sends Storage Commitment Notification.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members


sendCommitmentNotification Method (String, MCrefSopInfo[], MCfailedSopInfo[], String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..sendCommitmentNotification Method (String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16)
MCstorageCommitmentService Class See Also Send Feedback
Sends Storage Commitment Notification.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCommitmentNotification(
    string transactionUid,
    MCrefSopInfo[] successfulSops,
    MCfailedSopInfo[] failedSops,
    string serviceName,
    short model
)
Visual Basic
Public Overridable Function sendCommitmentNotification ( _
    transactionUid As String, _
    successfulSops As MCrefSopInfo(), _
    failedSops As MCfailedSopInfo(), _
    serviceName As String, _
    model As Short _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCommitmentNotification(
    String^ transactionUid,
    array<MCrefSopInfo^>^ successfulSops,
    array<MCfailedSopInfo^>^ failedSops,
    String^ serviceName,
    short model
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies a storage commitment request previously received.
successfulSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects describing a set of referenced SOP instances whose storage is being committed to.
failedSops
Type: array< Mergecom..::..MCfailedSopInfo >[]()[][]
Array of MCfailedSopInfo objects describing a set of referenced SOP instances for which storage commitment could not be achieved.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH" or "STORAGE_COMMITMENT_PULL".
model
Type: System..::..Int16
Model to use: PUSH_MODEL or PULL_MODEL

Return Value

An MCdimseMessage object encapsulating the N_EVENT_REPORT message that was just sent.

Remarks

This form may be used with the PUSH or PULL Model.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
sendCommitmentNotification Overload


sendCommitmentNotification Method (String, String, MCrefSopInfo[], MCfailedSopInfo[], String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..sendCommitmentNotification Method (String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16)
MCstorageCommitmentService Class See Also Send Feedback
Sends Storage Commitment Notification.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCommitmentNotification(
    string transactionUid,
    string retrieveAeTitle,
    MCrefSopInfo[] successfulSops,
    MCfailedSopInfo[] failedSops,
    string serviceName,
    short model
)
Visual Basic
Public Overridable Function sendCommitmentNotification ( _
    transactionUid As String, _
    retrieveAeTitle As String, _
    successfulSops As MCrefSopInfo(), _
    failedSops As MCfailedSopInfo(), _
    serviceName As String, _
    model As Short _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCommitmentNotification(
    String^ transactionUid,
    String^ retrieveAeTitle,
    array<MCrefSopInfo^>^ successfulSops,
    array<MCfailedSopInfo^>^ failedSops,
    String^ serviceName,
    short model
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies a storage commitment request previously received.
retrieveAeTitle
Type: System..::..String
All of the successfulSops may be retrieved from this DICOM application entity.
successfulSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects describing a set of referenced SOP instances whose storage is being committed to.
failedSops
Type: array< Mergecom..::..MCfailedSopInfo >[]()[][]
Array of MCfailedSopInfo objects describing a set of referenced SOP instances for which storage commitment could not be achieved.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH" or "STORAGE_COMMITMENT_PULL".
model
Type: System..::..Int16
Model to use: PUSH_MODEL or PULL_MODEL.

Return Value

An MCdimseMessage object encapsulating the N_EVENT_REPORT message that was just sent.

Remarks

This form may be used with the PUSH or PULL Model when all of the successfulSops instances are retrievable from the specified retrieveAeTitle.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
sendCommitmentNotification Overload


sendCommitmentNotification Method (String, String, String, MCrefSopInfo[], MCfailedSopInfo[], String, Int16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService..::..sendCommitmentNotification Method (String, String, String, array<MCrefSopInfo>[]()[][], array<MCfailedSopInfo>[]()[][], String, Int16)
MCstorageCommitmentService Class See Also Send Feedback
Sends Storage Commitment Notification.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCommitmentNotification(
    string transactionUid,
    string fileSetId,
    string fileSetUid,
    MCrefSopInfo[] successfulSops,
    MCfailedSopInfo[] failedSops,
    string serviceName,
    short model
)
Visual Basic
Public Overridable Function sendCommitmentNotification ( _
    transactionUid As String, _
    fileSetId As String, _
    fileSetUid As String, _
    successfulSops As MCrefSopInfo(), _
    failedSops As MCfailedSopInfo(), _
    serviceName As String, _
    model As Short _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCommitmentNotification(
    String^ transactionUid,
    String^ fileSetId,
    String^ fileSetUid,
    array<MCrefSopInfo^>^ successfulSops,
    array<MCfailedSopInfo^>^ failedSops,
    String^ serviceName,
    short model
)

Parameters

transactionUid
Type: System..::..String
Uniquely identifies a storage commitment request previously received.
fileSetId
Type: System..::..String
Storage Media File Set ID.
fileSetUid
Type: System..::..String
Storage Media File Set UID.
successfulSops
Type: array< Mergecom..::..MCrefSopInfo >[]()[][]
Array of MCrefSopInfo objects describing a set of referenced SOP instances whose storage is being committed to.
failedSops
Type: array< Mergecom..::..MCfailedSopInfo >[]()[][]
Array of MCfailedSopInfo objects describing a set of referenced SOP instances for which storage commitment could not be achieved.
serviceName
Type: System..::..String
Normally "STORAGE_COMMITMENT_PUSH" or "STORAGE_COMMITMENT_PULL".
model
Type: System..::..Int16
Model to use: PUSH_MODEL or PULL_MODEL.

Return Value

An MCdimseMessage object encapsulating the N_EVENT_REPORT message that was just sent.

Remarks

This form may be used with the PUSH or PULL Model when all of the successfulSops instances are retrievable from the specified Storage Media File Set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCruntimeException | A problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | Required attribute were missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCunacceptableServiceException | The storage commitment service was not valid for the association.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted when attempting to send the message.

See Also

MCstorageCommitmentService Class
MCstorageCommitmentService Members
sendCommitmentNotification Overload


MCstorageCommitmentService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageCommitmentService Properties
MCstorageCommitmentService Class See Also Send Feedback

The MCstorageCommitmentService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstorageCommitmentService Class


MCstorageNegotiation Class

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Class
Members See Also Send Feedback
Contains Storage Service Class Extended Negotiation data.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstorageNegotiation : MCnegotiationInfo
Visual Basic
Public Class MCstorageNegotiation _
    Inherits MCnegotiationInfo
Visual C++
public ref class MCstorageNegotiation : public MCnegotiationInfo

Remarks

The Storage Service Class can negotiate the degree of Element Coercion and the SCP support level.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCnegotiationInfo
Mergecom..::..MCstorageNegotiation

See Also

MCstorageNegotiation Members


MCstorageNegotiation Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Members
MCstorageNegotiation Class Constructors Methods Properties See Also Send Feedback

The MCstorageNegotiation type exposes the following members.

Constructors

 | Name | Description
Public method | MCstorageNegotiation()()()() | Initializes a new instance of this class that specifies an SCP level of 3 and a coercion level 2.
Public method | MCstorageNegotiation(Int32, Int32) | Initializes a new instance of this class for the provided SCP level and coercion.

Methods

 | Name | Description
Public method | decode | Retrieves Storage Service support data from DICOM extended negotiation info buffer. (Overrides MCnegotiationInfo..::..decode(array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toByteArray | Converts Storage Service negotiation info to buffer as defined by DICOM. (Overrides MCnegotiationInfo..::..toByteArray()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementCoercion | Represents the Element Coercion level.
Public property | SCPsupportLevel | Represents the SCP support level.

See Also

MCstorageNegotiation Class


MCstorageNegotiation Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Constructor
MCstorageNegotiation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstorageNegotiation()()()() | Initializes a new instance of this class that specifies an SCP level of 3 and a coercion level 2.
Public method | MCstorageNegotiation(Int32, Int32) | Initializes a new instance of this class for the provided SCP level and coercion.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members


MCstorageNegotiation Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Constructor
MCstorageNegotiation Class See Also Send Feedback
Initializes a new instance of this class that specifies an SCP level of 3 and a coercion level 2.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstorageNegotiation()
Visual Basic
Public Sub New
Visual C++
public:
MCstorageNegotiation()

Remarks

See ElementCoercion and SCPsupportLevel properties for defined values of the SCP level and coercion.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members
MCstorageNegotiation Overload


MCstorageNegotiation Constructor (Int32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Constructor (Int32, Int32)
MCstorageNegotiation Class See Also Send Feedback
Initializes a new instance of this class for the provided SCP level and coercion.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstorageNegotiation(
    int coercion,
    int scpLevel
)
Visual Basic
Public Sub New ( _
    coercion As Integer, _
    scpLevel As Integer _
)
Visual C++
public:
MCstorageNegotiation(
    int coercion,
    int scpLevel
)

Parameters

coercion
Type: System..::..Int32
DICOM specified coercion value (0, 1 or 2).
scpLevel
Type: System..::..Int32
DICOM specified Level of Support value (0, 1, 2 or 3).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The value of one of the parameters was invalid

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members
MCstorageNegotiation Overload


MCstorageNegotiation Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Methods
MCstorageNegotiation Class See Also Send Feedback

The MCstorageNegotiation type exposes the following members.

Methods

 | Name | Description
Public method | decode | Retrieves Storage Service support data from DICOM extended negotiation info buffer. (Overrides MCnegotiationInfo..::..decode(array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toByteArray | Converts Storage Service negotiation info to buffer as defined by DICOM. (Overrides MCnegotiationInfo..::..toByteArray()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstorageNegotiation Class


decode Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation..::..decode Method
MCstorageNegotiation Class See Also Send Feedback
Retrieves Storage Service support data from DICOM extended negotiation info buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void decode(
    byte[] byteArray
)
Visual Basic
Public Overrides Sub decode ( _
    byteArray As Byte() _
)
Visual C++
public:
virtual void decode(
    array<unsigned char>^ byteArray
) override

Parameters

byteArray
Type: array<System..::..Byte>[]()[][]
A six byte buffer as received during the negotiation.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members


toByteArray Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation..::..toByteArray Method
MCstorageNegotiation Class See Also Send Feedback
Converts Storage Service negotiation info to buffer as defined by DICOM.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override byte[] toByteArray()
Visual Basic
Public Overrides Function toByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ toByteArray() override

Return Value

A six byte buffer containing the extended negotiation information.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members


MCstorageNegotiation Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation Properties
MCstorageNegotiation Class See Also Send Feedback

The MCstorageNegotiation type exposes the following members.

Properties

 | Name | Description
Public property | ElementCoercion | Represents the Element Coercion level.
Public property | SCPsupportLevel | Represents the SCP support level.

See Also

MCstorageNegotiation Class


ElementCoercion Property

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation..::..ElementCoercion Property
MCstorageNegotiation Class See Also Send Feedback
Represents the Element Coercion level.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int ElementCoercion { get; set; }
Visual Basic
Public Overridable Property ElementCoercion As Integer
    Get
    Set
Visual C++
public:
virtual property int ElementCoercion {
    int get ();
    void set (int value);
}

Field Value

An integer representing the element coercion level.

Remarks

This property sets or gets the element coercion level for a Storage Service Class.

coercion levels are defined by the DICOM standard:

  • 0: While performing the SCP role, the application does not coerce any Data Element.
  • 1: While performing the SCP role, the application may coerce Data Elements.
  • 2: N/A - The application is SCU only.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The value for the coercion is an invalid value.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members


SCPsupportLevel Property

[image]

Merge DICOM .NET/C# Toolkit
MCstorageNegotiation..::..SCPsupportLevel Property
MCstorageNegotiation Class See Also Send Feedback
Represents the SCP support level.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int SCPsupportLevel { get; set; }
Visual Basic
Public Overridable Property SCPsupportLevel As Integer
    Get
    Set
Visual C++
public:
virtual property int SCPsupportLevel {
    int get ();
    void set (int value);
}

Field Value

An integer representing the SCP support level.

Remarks

Sets or gets the SCP support level for a Storage Service Class as defined by DICOM:

  • 0: level 0 SCP
  • 1: level 1 SCP
  • 2: level 2 SCP
  • 3: N/A SCU only

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The value for the SCP support level is an invalid value.

See Also

MCstorageNegotiation Class
MCstorageNegotiation Members


MCstorageService Class

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService Class
Members See Also Send Feedback
Represents the DICOM Storage Service Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstorageService : MCdimseService
Visual Basic
Public Class MCstorageService _
    Inherits MCdimseService
Visual C++
public ref class MCstorageService : public MCdimseService

Remarks

This class provides methods to send request and response messages, enforcing the requirements of the DICOM Storage Service Class. In general it relieves the user of the responsibility to update command set attributes.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCstorageService

See Also

MCstorageService Members


MCstorageService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService Members
MCstorageService Class Constructors Methods Fields Properties See Also Send Feedback

The MCstorageService type exposes the following members.

Constructors

 | Name | Description
Public method | MCstorageService | Initializes a new instance of this class used to support the DICOM Storage Service on the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandFailureResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_CANNOT_UNDERSTAND.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCoercionWarningResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENT_COERCION.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendElementsDiscardedWarningResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENTS_DISCARDED.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoResourcesFailureResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_REFUSED_NO_RESOURCES.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendStoreRequest(MCdataSet, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSource, String) | Sends a C-STORE DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendStoreRequest(MCdimseMessage, String) | Sends a C-STORE DIMSE request message, providing the message to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, MCtransferSyntax, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the transfer syntax and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message.
Public method | sendStoreRequest(MCdimseMessage, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the message priority.
Public method | sendStoreRequest(MCdimseMessage, String, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the affected SOP Class UID and the priority.
Public method | sendSuccessResponse(MCdimseMessage) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(String, UInt16) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstorageService Class


MCstorageService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService Constructor
MCstorageService Class See Also Send Feedback
Initializes a new instance of this class used to support the DICOM Storage Service on the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstorageService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCstorageService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCstorageService Class
MCstorageService Members


MCstorageService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService Fields
MCstorageService Class See Also Send Feedback

The MCstorageService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCstorageService Class


MCstorageService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService Methods
MCstorageService Class See Also Send Feedback

The MCstorageService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandFailureResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_CANNOT_UNDERSTAND.
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCoercionWarningResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENT_COERCION.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendElementsDiscardedWarningResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENTS_DISCARDED.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoResourcesFailureResponse | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_REFUSED_NO_RESOURCES.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendStoreRequest(MCdataSet, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSource, String) | Sends a C-STORE DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendStoreRequest(MCdimseMessage, String) | Sends a C-STORE DIMSE request message, providing the message to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, MCtransferSyntax, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the transfer syntax and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message.
Public method | sendStoreRequest(MCdimseMessage, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the message priority.
Public method | sendStoreRequest(MCdimseMessage, String, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the affected SOP Class UID and the priority.
Public method | sendSuccessResponse(MCdimseMessage) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(String, UInt16) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstorageService Class


sendCannotUnderstandFailureResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendCannotUnderstandFailureResponse Method
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_CANNOT_UNDERSTAND.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCannotUnderstandFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendCannotUnderstandFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendCannotUnderstandFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
An array of elements involved in the error.
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members


sendCoercionWarningResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendCoercionWarningResponse Method
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENT_COERCION.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendCoercionWarningResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendCoercionWarningResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendCoercionWarningResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
An array of elements involved in the error.
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members


sendElementsDiscardedWarningResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendElementsDiscardedWarningResponse Method
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_WARNING_ELEMENTS_DISCARDED.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendElementsDiscardedWarningResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendElementsDiscardedWarningResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendElementsDiscardedWarningResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
An array of elements involved in the error
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members


sendNoResourcesFailureResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendNoResourcesFailureResponse Method
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_REFUSED_NO_RESOURCES.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendNoResourcesFailureResponse(
    MCdimseMessage requestMsg,
    uint[] offendingElements,
    string errorComment
)
Visual Basic
Public Overridable Sub sendNoResourcesFailureResponse ( _
    requestMsg As MCdimseMessage, _
    offendingElements As UInteger(), _
    errorComment As String _
)
Visual C++
public:
virtual void sendNoResourcesFailureResponse(
    MCdimseMessage^ requestMsg,
    array<unsigned int>^ offendingElements,
    String^ errorComment
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.
offendingElements
Type: array<System..::..UInt32>[]()[][]
An array of elements involved in the error
errorComment
Type: System..::..String
Possibly null comment describing the error.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members


sendProcessingFailureResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendProcessingFailureResponse Method
MCstorageService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, String, UInt16, String, String) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.

See Also

MCstorageService Class
MCstorageService Members


sendProcessingFailureResponse Method (String, String, UInt16, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendProcessingFailureResponse Method (String, String, UInt16, String, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    string serviceName,
    string errorComment,
    ushort errorID,
    string affectedSopClassUid,
    string affectedSopInstanceUid
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    serviceName As String, _
    errorComment As String, _
    errorID As UShort, _
    affectedSopClassUid As String, _
    affectedSopInstanceUid As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    String^ serviceName,
    String^ errorComment,
    unsigned short errorID,
    String^ affectedSopClassUid,
    String^ affectedSopInstanceUid
)

Parameters

serviceName
Type: System..::..String
The C-STORE Request message service being responded to.
errorComment
Type: System..::..String
Possibly null comment describing the error.
errorID
Type: System..::..UInt16
The ID for the error, set to MaxValue if not to be sent.
affectedSopClassUid
Type: System..::..String
The Affected SOP Class UID.
affectedSopInstanceUid
Type: System..::..String
The affected SOP Instance UID if overriding the value in the request message.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members
sendProcessingFailureResponse Overload


sendProcessingFailureResponse Method (MCdimseMessage, String, UInt16, String, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendProcessingFailureResponse Method (MCdimseMessage, String, UInt16, String, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_FAILURE_PROCESSING_FAILURE.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendProcessingFailureResponse(
    MCdimseMessage requestMsg,
    string errorComment,
    ushort errorID,
    string affectedSopClassUid,
    string affectedSopInstanceUid
)
Visual Basic
Public Overridable Sub sendProcessingFailureResponse ( _
    requestMsg As MCdimseMessage, _
    errorComment As String, _
    errorID As UShort, _
    affectedSopClassUid As String, _
    affectedSopInstanceUid As String _
)
Visual C++
public:
virtual void sendProcessingFailureResponse(
    MCdimseMessage^ requestMsg,
    String^ errorComment,
    unsigned short errorID,
    String^ affectedSopClassUid,
    String^ affectedSopInstanceUid
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.
errorComment
Type: System..::..String
Possibly null comment describing the error.
errorID
Type: System..::..UInt16
The ID for the error, set to MaxValue if not to be sent.
affectedSopClassUid
Type: System..::..String
The Affected SOP Class UID.
affectedSopInstanceUid
Type: System..::..String
The affected SOP Instance UID if overriding the value in the request message.

Remarks

If provided, the Error Comment attribute (0000,0902) is set in the command set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message argument was null.

See Also

MCstorageService Class
MCstorageService Members
sendProcessingFailureResponse Overload


sendStoreRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner.

Overload List

 | Name | Description
Public method | sendStoreRequest(MCdataSet, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSource, String) | Sends a C-STORE DIMSE request message to the association partner, providing the stream for message data to send
Public method | sendStoreRequest(MCdimseMessage, String) | Sends a C-STORE DIMSE request message, providing the message to send and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, MCtransferSyntax, String) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the transfer syntax and the affected SOP Instance UID to use.
Public method | sendStoreRequest(MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message.
Public method | sendStoreRequest(MCdimseMessage, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Instance UID and message priority.
Public method | sendStoreRequest(MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message to the association partner, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the message priority.
Public method | sendStoreRequest(MCdimseMessage, String, String, UInt16) | This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.
Public method | sendStoreRequest(MCdimseMessage, MCdataSet, String, String, UInt16) | Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the affected SOP Class UID and the priority.

See Also

MCstorageService Class
MCstorageService Members


sendStoreRequest Method (MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdataSet, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner, providing the data set to send and the affected SOP Instance UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdataSet ds,
    string affectedSopInstanceUID
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    ds As MCdataSet, _
    affectedSopInstanceUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdataSet^ ds,
    String^ affectedSopInstanceUID
)

Parameters

ds
Type: Mergecom..::..MCdataSet
The data set to send with the message.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.

Return Value

The MCdimseMessage object encapsulating the sent message.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority defaults to MCdimseService.MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The data set was null.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdataSource, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdataSource, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner, providing the stream for message data to send

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendStoreRequest(
    MCdataSource dataSource,
    string name
)
Visual Basic
Public Overridable Sub sendStoreRequest ( _
    dataSource As MCdataSource, _
    name As String _
)
Visual C++
public:
virtual void sendStoreRequest(
    MCdataSource^ dataSource,
    String^ name
)

Parameters

dataSource
Type: Mergecom..::..MCdataSource
The data source for the message to send
name
Type: System..::..String
The name of data source (may be null).

Remarks

The message priority defaults to MCdimseService.MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not present in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | The data set was null.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message, providing the message to send and the affected SOP Instance UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage sendStoreRequest(
    MCdimseMessage msg,
    string affectedSopInstanceUID
)
Visual Basic
Public Function sendStoreRequest ( _
    msg As MCdimseMessage, _
    affectedSopInstanceUID As String _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ msg,
    String^ affectedSopInstanceUID
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage message to send in the request
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID

Return Value

The MCdimseMessage message object

Remarks

The data set is provided by the data set contained in the message.

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority defaults to MC_MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdataSet, MCtransferSyntax, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdataSet, MCtransferSyntax, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the transfer syntax and the affected SOP Instance UID to use.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdataSet ds,
    MCtransferSyntax syntax,
    string affectedSopInstanceUID
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    ds As MCdataSet, _
    syntax As MCtransferSyntax, _
    affectedSopInstanceUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdataSet^ ds,
    MCtransferSyntax^ syntax,
    String^ affectedSopInstanceUID
)

Parameters

ds
Type: Mergecom..::..MCdataSet
The data set to send with the message.
syntax
Type: Mergecom..::..MCtransferSyntax
The transfer syntax for encoding the data set.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.

Return Value

The MCdimseMessage object encapsulating the sent message.

Remarks

The transfer syntax will be used to encode the data set when it is streamed. This is necessary if the message is being sent over an association that has more than one presentation context acceptable to both network partners.

The affected SOP Class UID defaults to the data set's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority defaults to MCdimseService.MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdataSet, String, UInt16)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner, providing the data set to send, the affected SOP Instance UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdataSet ds,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    ds As MCdataSet, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdataSet^ ds,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

ds
Type: Mergecom..::..MCdataSet
The data set to send with the message.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

The MCdimseMessage encapsulating the message sent.

Remarks

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter and it must be one of the priority values defined in the MCdimseService class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, MCdataSet, String)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, MCdataSet, String)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdimseMessage moveMsg,
    MCdataSet ds,
    string affectedSopInstanceUID
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    moveMsg As MCdimseMessage, _
    ds As MCdataSet, _
    affectedSopInstanceUID As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ moveMsg,
    MCdataSet^ ds,
    String^ affectedSopInstanceUID
)

Parameters

moveMsg
Type: Mergecom..::..MCdimseMessage
The C-MOVE-RQ message being processed.
ds
Type: Mergecom..::..MCdataSet
The data set to send with the request.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.

Return Value

The MCdimseMessage that was sent.

Remarks

The moveMsg parameter provides the MCdimseMessage object containing the received C-MOVE-RQ message. The library will use the remote application entity title of the moveMsg's association as the "Move Originator Application Entity Title" (0000,1030), and it will use the message ID assigned to moveMsg as the "Move Originator Message ID" (0000,1031) in the command set of the message sent.

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority defaults to MCdimseService.MEDIUM_PRIORITY_MESSAGE.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, String, UInt16)
MCstorageService Class See Also Send Feedback
This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Instance UID and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage sendStoreRequest(
    MCdimseMessage msg,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Function sendStoreRequest ( _
    msg As MCdimseMessage, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ msg,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage message to send in the request
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID
priority
Type: System..::..UInt16
The message priority

Return Value

The MCdimseMessage message object

Remarks

The data set is provided by the dataSet contained in the message.

The affected SOP Class UID defaults to the dataSet's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdataSet, String, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdataSet, String, String, UInt16)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message to the association partner, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdataSet ds,
    string affectedSopClassUID,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    ds As MCdataSet, _
    affectedSopClassUID As String, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdataSet^ ds,
    String^ affectedSopClassUID,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

ds
Type: Mergecom..::..MCdataSet
The data set to send with the message.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

The MCdimseMessage encapsulating the message sent.

Remarks

The affected SOP Class UID is provided by the affectedSopClassUID parameter. If affectedSopClassUID is null or it is an empty string, the SOP Class UID associated with the dataSet's presentation context for the service's association will be used.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter and it must be one of the priority values defined in the MCdimseService class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, MCdataSet, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, MCdataSet, String, UInt16)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdimseMessage moveMsg,
    MCdataSet ds,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    moveMsg As MCdimseMessage, _
    ds As MCdataSet, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ moveMsg,
    MCdataSet^ ds,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

moveMsg
Type: Mergecom..::..MCdimseMessage
The C-MOVE-RQ message being processed.
ds
Type: Mergecom..::..MCdataSet
The data set to send with the request.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

The MCdimseMessage that was sent.

Remarks

The moveMsg parameter provides the MCdimseMessage object encapsulating a received C-MOVE-RQ message. The library will use the remote application entity title of the moveMsg's association as the "Move Originator Application Entity Title" (0000,1030), and it will use the message ID assigned to moveMsg as the "Move Originator Message ID" (0000,1031) in the command set of the message sent.

The affected SOP Class UID defaults to the data set's presentation context for the service's association.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter and it must be one of the priority values defined in the MCdimseService class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, String, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, String, String, UInt16)
MCstorageService Class See Also Send Feedback
This form of the method is used for normal C-STORE requests, providing the message to send, the affected SOP Class UID, the affected SOP Instance UID, and message priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage sendStoreRequest(
    MCdimseMessage msg,
    string affectedSopClassUID,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Function sendStoreRequest ( _
    msg As MCdimseMessage, _
    affectedSopClassUID As String, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ msg,
    String^ affectedSopClassUID,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

msg
Type: Mergecom..::..MCdimseMessage
The MCdimseMessage message to send in the request
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID
priority
Type: System..::..UInt16
The message priority

Return Value

The MCdimseMessage message object

Remarks

The data set is provided by the dataSet contained in the message.

The affected SOP Class UID is provided by the affectedSopClassUID parameter. If affectedSopClassUID is null or it is an empty string, the SOP Class UID associated with the dataSet's presentation context for the service's association will be used.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendStoreRequest Method (MCdimseMessage, MCdataSet, String, String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendStoreRequest Method (MCdimseMessage, MCdataSet, String, String, UInt16)
MCstorageService Class See Also Send Feedback
Sends a C-STORE DIMSE request message in response to a received C-MOVE-RQ message, providing the affected SOP Class UID and the priority.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStoreRequest(
    MCdimseMessage moveMsg,
    MCdataSet ds,
    string affectedSopClassUID,
    string affectedSopInstanceUID,
    ushort priority
)
Visual Basic
Public Overridable Function sendStoreRequest ( _
    moveMsg As MCdimseMessage, _
    ds As MCdataSet, _
    affectedSopClassUID As String, _
    affectedSopInstanceUID As String, _
    priority As UShort _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStoreRequest(
    MCdimseMessage^ moveMsg,
    MCdataSet^ ds,
    String^ affectedSopClassUID,
    String^ affectedSopInstanceUID,
    unsigned short priority
)

Parameters

moveMsg
Type: Mergecom..::..MCdimseMessage
The C-MOVE-RQ message being processed.
ds
Type: Mergecom..::..MCdataSet
The data set to send with the request.
affectedSopClassUID
Type: System..::..String
The affected SOP Class UID.
affectedSopInstanceUID
Type: System..::..String
The affected SOP Instance UID.
priority
Type: System..::..UInt16
The message priority.

Return Value

The MCdimseMessage that was sent.

Remarks

The moveMsg parameter provides the MCdimseMessage object encapsulating a received C-MOVE-RQ message. The library will use the remote application entity title of the moveMsg's association as the "Move Originator Application Entity Title" (0000,1030), and it will use the message ID assigned to moveMsg as the "Move Originator Message ID" (0000,1031) in the command set of the message sent.

The affected SOP Class UID is provided by the affectedSopClassUID parameter. If affectedSopClassUID is null or it is an empty string, the SOP Class UID associated with the dataSet's presentation context for the service's association will be used.

The affected SOP Instance UID is provided by the affectedSopInstanceUID parameter. If the affectedSopInstanceUID parameter is null or is an empty string, an MCillegalArgumentException will be thrown.

The message priority is provided by the priority parameter and it must be one of the priority values defined in the MCdimseService class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was passed to this method.

See Also

MCstorageService Class
MCstorageService Members
sendStoreRequest Overload


sendSuccessResponse Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendSuccessResponse Method
MCstorageService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSuccessResponse(MCdimseMessage) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(String, UInt16) | Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)

See Also

MCstorageService Class
MCstorageService Members


sendSuccessResponse Method (MCdimseMessage)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendSuccessResponse Method (MCdimseMessage)
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendSuccessResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The C-STORE Request message being responded to.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstorageService Class
MCstorageService Members
sendSuccessResponse Overload


sendSuccessResponse Method (String, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCstorageService..::..sendSuccessResponse Method (String, UInt16)
MCstorageService Class See Also Send Feedback
Sends a C-STORE Response message with a status of MCdimseService.C_STORE_SUCCESS.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendSuccessResponse(
    string reqServiceName,
    ushort reqCommand
)
Visual Basic
Public Overridable Sub sendSuccessResponse ( _
    reqServiceName As String, _
    reqCommand As UShort _
)
Visual C++
public:
virtual void sendSuccessResponse(
    String^ reqServiceName,
    unsigned short reqCommand
)

Parameters

reqServiceName
Type: System..::..String
The service name of the request message
reqCommand
Type: System..::..UInt16
The command of the request message

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for the request message.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The reqServiceName is not one that was negotiated for the association, or is null.
Mergecom.Exceptions..::..MCillegalArgumentException | The reqCommand is invalid.

See Also

MCstorageService Class
MCstorageService Members
sendSuccessResponse Overload


MCstorageService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstorageService Properties
MCstorageService Class See Also Send Feedback

The MCstorageService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstorageService Class


MCstreamDataSink Class

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink Class
Members See Also Send Feedback
An implementation of the MCdataSink interface which writes to a Stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstreamDataSink : MCdataSink
Visual Basic
Public Class MCstreamDataSink _
    Implements MCdataSink
Visual C++
public ref class MCstreamDataSink : MCdataSink

Remarks

This class is not implemented yet.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCstreamDataSink

See Also

MCstreamDataSink Members


MCstreamDataSink Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink Members
MCstreamDataSink Class Constructors Methods See Also Send Feedback

The MCstreamDataSink type exposes the following members.

Constructors

 | Name | Description
Public method | MCstreamDataSink | Initializes a new stream data sink.

Methods

 | Name | Description
Public method | close | Closes the destination stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | receiveData | An implementation of the receiveData method as defined in MCdataSink.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstreamDataSink Class


MCstreamDataSink Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink Constructor
MCstreamDataSink Class See Also Send Feedback
Initializes a new stream data sink.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstreamDataSink(
    Stream destination
)
Visual Basic
Public Sub New ( _
    destination As Stream _
)
Visual C++
public:
MCstreamDataSink(
    Stream^ destination
)

Parameters

destination
Type: System.IO..::..Stream
The destination stream.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null or it is not writable.

See Also

MCstreamDataSink Class
MCstreamDataSink Members


MCstreamDataSink Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink Methods
MCstreamDataSink Class See Also Send Feedback

The MCstreamDataSink type exposes the following members.

Methods

 | Name | Description
Public method | close | Closes the destination stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | receiveData | An implementation of the receiveData method as defined in MCdataSink.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstreamDataSink Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink..::..close Method
MCstreamDataSink Class See Also Send Feedback
Closes the destination stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

See Also

MCstreamDataSink Class
MCstreamDataSink Members


receiveData Method

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSink..::..receiveData Method
MCstreamDataSink Class See Also Send Feedback
An implementation of the receiveData method as defined in MCdataSink.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void receiveData(
    MCdata bulk,
    Object origin
)
Visual Basic
Public Sub receiveData ( _
    bulk As MCdata, _
    origin As Object _
)
Visual C++
public:
virtual void receiveData(
    MCdata^ bulk,
    Object^ origin
) sealed

Parameters

bulk
Type: Mergecom..::..MCdata
The data to receive.
origin
Type: System..::..Object
The origin of this call.

Implements

MCdataSink..::..receiveData(MCdata, Object)

See Also

MCstreamDataSink Class
MCstreamDataSink Members


MCstreamDataSource Class

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Class
Members See Also Send Feedback
Implementation of the MCdataSource interface which reads from a Stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstreamDataSource : MCdataSourceEx,
    MCdataSource, IDisposable
Visual Basic
Public Class MCstreamDataSource _
    Implements MCdataSourceEx, MCdataSource, IDisposable
Visual C++
public ref class MCstreamDataSource : MCdataSourceEx,
    MCdataSource, IDisposable

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCstreamDataSource

See Also

MCstreamDataSource Members


MCstreamDataSource Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Members
MCstreamDataSource Class Constructors Methods See Also Send Feedback

The MCstreamDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | MCstreamDataSource(Stream) | Initializes a new instance of this class.
Public method | MCstreamDataSource(Stream, UInt32) | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | close | Releases the buffer used by this instance, but doesn't close the source stream.
Public method | Dispose | Implements IDisposable. Releases the buffer used by this instance, but doesn't close the source stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSourceEx.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstreamDataSource Class


MCstreamDataSource Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Constructor
MCstreamDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstreamDataSource(Stream) | Initializes a new instance of this class.
Public method | MCstreamDataSource(Stream, UInt32) | Initializes a new instance of this class.

See Also

MCstreamDataSource Class
MCstreamDataSource Members


MCstreamDataSource Constructor (Stream)

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Constructor (Stream)
MCstreamDataSource Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstreamDataSource(
    Stream source
)
Visual Basic
Public Sub New ( _
    source As Stream _
)
Visual C++
public:
MCstreamDataSource(
    Stream^ source
)

Parameters

source
Type: System.IO..::..Stream
A Stream instance to read from.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The stream passed to the constructor was a null reference.

See Also

MCstreamDataSource Class
MCstreamDataSource Members
MCstreamDataSource Overload


MCstreamDataSource Constructor (Stream, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Constructor (Stream, UInt32)
MCstreamDataSource Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstreamDataSource(
    Stream source,
    uint bufferSize
)
Visual Basic
Public Sub New ( _
    source As Stream, _
    bufferSize As UInteger _
)
Visual C++
public:
MCstreamDataSource(
    Stream^ source,
    unsigned int bufferSize
)

Parameters

source
Type: System.IO..::..Stream
A Stream instance to read from
bufferSize
Type: System..::..UInt32
The size of the internal buffer

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The stream passed to the constructor was a null reference.

See Also

MCstreamDataSource Class
MCstreamDataSource Members
MCstreamDataSource Overload


MCstreamDataSource Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource Methods
MCstreamDataSource Class See Also Send Feedback

The MCstreamDataSource type exposes the following members.

Methods

 | Name | Description
Public method | close | Releases the buffer used by this instance, but doesn't close the source stream.
Public method | Dispose | Implements IDisposable. Releases the buffer used by this instance, but doesn't close the source stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSourceEx.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstreamDataSource Class


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource..::..close Method
MCstreamDataSource Class See Also Send Feedback
Releases the buffer used by this instance, but doesn't close the source stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

Remarks

This method is equivalent to Dispose()()()().

See Also

MCstreamDataSource Class
MCstreamDataSource Members


Dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource..::..Dispose Method
MCstreamDataSource Class See Also Send Feedback
Implements IDisposable. Releases the buffer used by this instance, but doesn't close the source stream.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MCstreamDataSource Class
MCstreamDataSource Members


provideData Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource..::..provideData Method
MCstreamDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | provideData(Boolean, Object) | Implementation of the provideData method as defined in MCdataSource.
Public method | provideData(Boolean, UInt32, Object) | Implementation of the provideData method as defined in MCdataSourceEx.

See Also

MCstreamDataSource Class
MCstreamDataSource Members


provideData Method (Boolean, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource..::..provideData Method (Boolean, Object)
MCstreamDataSource Class See Also Send Feedback
Implementation of the provideData method as defined in MCdataSource.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata provideData(
    bool first,
    Object origin
)
Visual Basic
Public Function provideData ( _
    first As Boolean, _
    origin As Object _
) As MCdata
Visual C++
public:
virtual MCdata^ provideData(
    bool first,
    Object^ origin
) sealed

Parameters

first
Type: System..::..Boolean
true if this is the first block being requested.
origin
Type: System..::..Object
The origin of this call.

Return Value

An MCdata instance containing the requested data.

Implements

MCdataSource..::..provideData(Boolean, Object)

See Also

MCstreamDataSource Class
MCstreamDataSource Members
provideData Overload


provideData Method (Boolean, UInt32, Object)

[image]

Merge DICOM .NET/C# Toolkit
MCstreamDataSource..::..provideData Method (Boolean, UInt32, Object)
MCstreamDataSource Class See Also Send Feedback
Implementation of the provideData method as defined in MCdataSourceEx.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdata provideData(
    bool first,
    uint pos,
    Object origin
)
Visual Basic
Public Function provideData ( _
    first As Boolean, _
    pos As UInteger, _
    origin As Object _
) As MCdata
Visual C++
public:
virtual MCdata^ provideData(
    bool first,
    unsigned int pos,
    Object^ origin
) sealed

Parameters

first
Type: System..::..Boolean
true if this is the first block being requested.
pos
Type: System..::..UInt32
The data offset.
origin
Type: System..::..Object
The origin of this call.

Return Value

An MCdata instance containing the requested data.

Implements

MCdataSourceEx..::..provideData(Boolean, UInt32, Object)

See Also

MCstreamDataSource Class
MCstreamDataSource Members
provideData Overload


MCstringEncoder Interface

[image]

Merge DICOM .NET/C# Toolkit
MCstringEncoder Interface
Members See Also Send Feedback
Defines the interface used to encode/decode strings in attribute values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCstringEncoder
Visual Basic
Public Interface MCstringEncoder
Visual C++
public interface class MCstringEncoder

See Also

MCstringEncoder Members


MCstringEncoder Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstringEncoder Members
MCstringEncoder Interface Methods See Also Send Feedback

The MCstringEncoder type exposes the following members.

Methods

 | Name | Description
Public method | decode | Called to decode a byte array representing a Dicom encoded string.
Public method | encode | Called to encode a string attribute into a byte buffer.

See Also

MCstringEncoder Interface


MCstringEncoder Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstringEncoder Methods
MCstringEncoder Interface See Also Send Feedback

The MCstringEncoder type exposes the following members.

Methods

 | Name | Description
Public method | decode | Called to decode a byte array representing a Dicom encoded string.
Public method | encode | Called to encode a string attribute into a byte buffer.

See Also

MCstringEncoder Interface


decode Method

[image]

Merge DICOM .NET/C# Toolkit
MCstringEncoder..::..decode Method
MCstringEncoder Interface See Also Send Feedback
Called to decode a byte array representing a Dicom encoded string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
string decode(
    byte[] value,
    int offset,
    int len,
    string characterSet
)
Visual Basic
Function decode ( _
    value As Byte(), _
    offset As Integer, _
    len As Integer, _
    characterSet As String _
) As String
Visual C++
String^ decode(
    array<unsigned char>^ value,
    int offset,
    int len,
    String^ characterSet
)

Parameters

value
Type: array<System..::..Byte>[]()[][]
Buffer containing the encoded string.
offset
Type: System..::..Int32
The position where the encoded string begins in the buffer.
len
Type: System..::..Int32
The length of the encoded string.
characterSet
Type: System..::..String
The Dicom defined term of the characterset to start the decoding with.

Return Value

The decoded Unicode string.

See Also

MCstringEncoder Interface
MCstringEncoder Members


encode Method

[image]

Merge DICOM .NET/C# Toolkit
MCstringEncoder..::..encode Method
MCstringEncoder Interface See Also Send Feedback
Called to encode a string attribute into a byte buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
byte[] encode(
    MCattribute value,
    string[] charsets
)
Visual Basic
Function encode ( _
    value As MCattribute, _
    charsets As String() _
) As Byte()
Visual C++
array<unsigned char>^ encode(
    MCattribute^ value,
    array<String^>^ charsets
)

Parameters

value
Type: Mergecom..::..MCattribute
The attribute to encode.
charsets
Type: array<System..::..String>[]()[][]
List of character set names as defined by DICOM. If this parameter has more than one value, code extensions should be used.

Return Value

The byte array containing the encoded string.

See Also

MCstringEncoder Interface
MCstringEncoder Members


MCstringEncoderEx Interface

[image]

Merge DICOM .NET/C# Toolkit
MCstringEncoderEx Interface
Members See Also Send Feedback
Defines extended interface used to encode/decode strings in attribute values.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MCstringEncoderEx : MCstringEncoder
Visual Basic
Public Interface MCstringEncoderEx _
    Inherits MCstringEncoder
Visual C++
public interface class MCstringEncoderEx : MCstringEncoder

See Also

MCstringEncoderEx Members


MCstringEncoderEx Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstringEncoderEx Members
MCstringEncoderEx Interface Methods See Also Send Feedback

The MCstringEncoderEx type exposes the following members.

Methods

 | Name | Description
Public method | decode | Called to decode a byte array representing a Dicom encoded string. (Inherited from MCstringEncoder.)
Public method | encode(String, array<String>[]()[][]) | Called to encode a String into a byte buffer.
Public method | encode(MCattribute, array<String>[]()[][]) | Called to encode a string attribute into a byte buffer. (Inherited from MCstringEncoder.)

See Also

MCstringEncoderEx Interface


MCstringEncoderEx Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstringEncoderEx Methods
MCstringEncoderEx Interface See Also Send Feedback

The MCstringEncoderEx type exposes the following members.

Methods

 | Name | Description
Public method | decode | Called to decode a byte array representing a Dicom encoded string. (Inherited from MCstringEncoder.)
Public method | encode(String, array<String>[]()[][]) | Called to encode a String into a byte buffer.
Public method | encode(MCattribute, array<String>[]()[][]) | Called to encode a string attribute into a byte buffer. (Inherited from MCstringEncoder.)

See Also

MCstringEncoderEx Interface


encode Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstringEncoderEx..::..encode Method
MCstringEncoderEx Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | encode(String, array<String>[]()[][]) | Called to encode a String into a byte buffer.
Public method | encode(MCattribute, array<String>[]()[][]) | Called to encode a string attribute into a byte buffer. (Inherited from MCstringEncoder.)

See Also

MCstringEncoderEx Interface
MCstringEncoderEx Members


encode Method (String, String[])

[image]

Merge DICOM .NET/C# Toolkit
MCstringEncoderEx..::..encode Method (String, array<String>[]()[][])
MCstringEncoderEx Interface See Also Send Feedback
Called to encode a String into a byte buffer.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
byte[] encode(
    string value,
    string[] charsets
)
Visual Basic
Function encode ( _
    value As String, _
    charsets As String() _
) As Byte()
Visual C++
array<unsigned char>^ encode(
    String^ value,
    array<String^>^ charsets
)

Parameters

value
Type: System..::..String
The String to encode.
charsets
Type: array<System..::..String>[]()[][]
List of character set names as defined by DICOM. If this parameter has more than one value, code extensions should be used.

Return Value

The byte array containing the encoded string.

See Also

MCstringEncoderEx Interface
MCstringEncoderEx Members
encode Overload


MCstudyContentNotificationService Class

[image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Class
Members See Also Send Feedback
Represents a DICOM Study Content Notification Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstudyContentNotificationService : MCdimseService
Visual Basic
Public Class MCstudyContentNotificationService _
    Inherits MCdimseService
Visual C++
public ref class MCstudyContentNotificationService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:

Basic Study Content Notification SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCstudyContentNotificationService

See Also

MCstudyContentNotificationService Members


MCstudyContentNotificationService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Members
MCstudyContentNotificationService Class Constructors Methods Fields Properties See Also Send Feedback

The MCstudyContentNotificationService type exposes the following members.

Constructors

 | Name | Description
Public method | MCstudyContentNotificationService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstudyContentNotificationService Class


MCstudyContentNotificationService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Constructor
MCstudyContentNotificationService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyContentNotificationService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCstudyContentNotificationService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCstudyContentNotificationService Class
MCstudyContentNotificationService Members


MCstudyContentNotificationService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Fields
MCstudyContentNotificationService Class See Also Send Feedback

The MCstudyContentNotificationService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCstudyContentNotificationService Class


MCstudyContentNotificationService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Methods
MCstudyContentNotificationService Class See Also Send Feedback

The MCstudyContentNotificationService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstudyContentNotificationService Class


MCstudyContentNotificationService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyContentNotificationService Properties
MCstudyContentNotificationService Class See Also Send Feedback

The MCstudyContentNotificationService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstudyContentNotificationService Class


MCstudyManagementService Class

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Class
Members See Also Send Feedback
Represents a DICOM Study Management Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstudyManagementService : MCdimseService
Visual Basic
Public Class MCstudyManagementService _
    Inherits MCdimseService
Visual C++
public ref class MCstudyManagementService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:
  • Detatched Study Management Meta SOP Class
  • Detached Study Management SOP Class
  • Study Component Management SOP Class
  • Modality Performed Procedure Step SOP Class
  • Modality Performed Procedure Step Notification SOP Class
  • Modality Performed Procedure Step Retrieve SOP Class
  • General Purpose Scheduled Procedure Step
  • General Purpose Performed Procedure Step

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCstudyManagementService

See Also

MCstudyManagementService Members


MCstudyManagementService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Members
MCstudyManagementService Class Constructors Methods Fields Properties See Also Send Feedback

The MCstudyManagementService type exposes the following members.

Constructors

 | Name | Description
Public method | MCstudyManagementService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | acceptCreateRequest | Accepts an N-CREATE request to create a new instance of the GP PPS, MPPS or Study Component SOP Class.
Public method | acceptGetInformationRequest | Accepts an N-GET request for GP PPS, MPPS, study or study component information and sends the attribute values requested to the SCU requester.
Public method | acceptModifyGPspsInformationRequest | Accepts an N-ACTION request to modify status of a General Purpose Scheduled Procedure Step object.
Public method | acceptMppsNotification | Accepts an N-EVENT-REPORT request message.
Public method | acceptSetGPppsRequest | Accepts an N-SET request for General Purpose Performed Procedure Step update.
Public method | acceptSetMppsRequest | Accepts an N-SET request for Modality Performed Procedure Step update.
Public method | acceptSetStudyComponentRequest | Accepts an N-SET request for study component information update.
Public method | acceptSetStudyInformationRequest | Accepts an N-SET request for study information update.
Public method | acceptStudyManagementNotification | Accepts an N-EVENT-REPORT request message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCreateGPppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.
Public method | sendCreateGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.
Public method | sendCreateMppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.
Public method | sendCreateMppsRequest(MCsopClass, String, MCperformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.
Public method | sendDSMeventNotification(MCsopClass, String, MCdetachedStudyManagementEventReport, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.
Public method | sendDSMeventNotification(MCsopClass, String, MCdataSet, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendGetGPppsInformationRequest | Requests Performed Procedure Step Information from a GP PPS SCP.
Public method | sendGetMppsInformationRequest | Requests Performed Procedure Step Information from an MPPS SCP.
Public method | sendGetStudyComponentInformationRequest | Requests Study Component Information from a Study Component Management SCP.
Public method | sendGetStudyInformationRequest | Requests Study Information from a Detached Study Management SCP.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCdataSet) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCgpScheduledProcedureStep, Boolean) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.
Public method | sendMppsCompletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsDeletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsDiscontinuedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsInProgressNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsUpdatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPatientArrivedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Detached Study Management SOP Class.
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSetGPppsRequest(MCsopClass, String, MCdataSet) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.
Public method | sendSetGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepSet, Boolean) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.
Public method | sendSetMppsRequest(MCsopClass, String, MCdataSet) | Requests that Modality Performed Procedure Step Information be updated by an MPPS SCP.
Public method | sendSetMppsRequest(MCsopClass, String, MCperformedProcedureStepSet, Boolean) | Requests that Performed Procedure Step Information be updated by an MPSS SCP.
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementSet) | Requests that Study Component Information be updated by a Study Component Management SCP.
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCdataSet) | Requests that Study Component Information be updated by a Study Component Management SCP.
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdetachedStudyManagementSet) | Requests that Study Information be updated by a Detached Study Management SCP.
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdataSet) | Requests that Study Information be updated by a Detached Study Management SCP.
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendStudyCompletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyCreatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyDeletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 8 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyReadNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 7 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyScheduledNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyStartedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyUpdatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 9 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyVerifiedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 6 to an SCU using a Detached Study Management SOP Class.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstudyManagementService Class


MCstudyManagementService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Constructor
MCstudyManagementService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyManagementService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCstudyManagementService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


MCstudyManagementService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Fields
MCstudyManagementService Class See Also Send Feedback

The MCstudyManagementService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCstudyManagementService Class


MCstudyManagementService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Methods
MCstudyManagementService Class See Also Send Feedback

The MCstudyManagementService type exposes the following members.

Methods

 | Name | Description
Public method | acceptCreateRequest | Accepts an N-CREATE request to create a new instance of the GP PPS, MPPS or Study Component SOP Class.
Public method | acceptGetInformationRequest | Accepts an N-GET request for GP PPS, MPPS, study or study component information and sends the attribute values requested to the SCU requester.
Public method | acceptModifyGPspsInformationRequest | Accepts an N-ACTION request to modify status of a General Purpose Scheduled Procedure Step object.
Public method | acceptMppsNotification | Accepts an N-EVENT-REPORT request message.
Public method | acceptSetGPppsRequest | Accepts an N-SET request for General Purpose Performed Procedure Step update.
Public method | acceptSetMppsRequest | Accepts an N-SET request for Modality Performed Procedure Step update.
Public method | acceptSetStudyComponentRequest | Accepts an N-SET request for study component information update.
Public method | acceptSetStudyInformationRequest | Accepts an N-SET request for study information update.
Public method | acceptStudyManagementNotification | Accepts an N-EVENT-REPORT request message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendCreateGPppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.
Public method | sendCreateGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.
Public method | sendCreateMppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.
Public method | sendCreateMppsRequest(MCsopClass, String, MCperformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.
Public method | sendDSMeventNotification(MCsopClass, String, MCdetachedStudyManagementEventReport, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.
Public method | sendDSMeventNotification(MCsopClass, String, MCdataSet, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendGetGPppsInformationRequest | Requests Performed Procedure Step Information from a GP PPS SCP.
Public method | sendGetMppsInformationRequest | Requests Performed Procedure Step Information from an MPPS SCP.
Public method | sendGetStudyComponentInformationRequest | Requests Study Component Information from a Study Component Management SCP.
Public method | sendGetStudyInformationRequest | Requests Study Information from a Detached Study Management SCP.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCdataSet) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCgpScheduledProcedureStep, Boolean) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.
Public method | sendMppsCompletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsDeletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsDiscontinuedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsInProgressNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendMppsUpdatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Modality Performed Procedure Step Notification SOP Class.
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPatientArrivedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Detached Study Management SOP Class.
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSetGPppsRequest(MCsopClass, String, MCdataSet) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.
Public method | sendSetGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepSet, Boolean) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.
Public method | sendSetMppsRequest(MCsopClass, String, MCdataSet) | Requests that Modality Performed Procedure Step Information be updated by an MPPS SCP.
Public method | sendSetMppsRequest(MCsopClass, String, MCperformedProcedureStepSet, Boolean) | Requests that Performed Procedure Step Information be updated by an MPSS SCP.
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementSet) | Requests that Study Component Information be updated by a Study Component Management SCP.
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCdataSet) | Requests that Study Component Information be updated by a Study Component Management SCP.
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdetachedStudyManagementSet) | Requests that Study Information be updated by a Detached Study Management SCP.
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdataSet) | Requests that Study Information be updated by a Detached Study Management SCP.
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendStudyCompletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyCreatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyDeletedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 8 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyReadNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 7 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyScheduledNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyStartedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyUpdatedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 9 to an SCU using a Detached Study Management SOP Class.
Public method | sendStudyVerifiedNotification | Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 6 to an SCU using a Detached Study Management SOP Class.
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstudyManagementService Class


acceptCreateRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptCreateRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-CREATE request to create a new instance of the GP PPS, MPPS or Study Component SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptCreateRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptCreateRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptCreateRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-CREATE request message.

Remarks

This method sends an N-CREATE Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptGetInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptGetInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-GET request for GP PPS, MPPS, study or study component information and sends the attribute values requested to the SCU requester.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptGetInformationRequest(
    MCdimseMessage requestMsg,
    MCdataSet attributeList,
    bool allOptionalAttributesSupported
)
Visual Basic
Public Overridable Sub acceptGetInformationRequest ( _
    requestMsg As MCdimseMessage, _
    attributeList As MCdataSet, _
    allOptionalAttributesSupported As Boolean _
)
Visual C++
public:
virtual void acceptGetInformationRequest(
    MCdimseMessage^ requestMsg,
    MCdataSet^ attributeList,
    bool allOptionalAttributesSupported
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-GET request message.
attributeList
Type: Mergecom..::..MCdataSet
The data set containing the requested values.
allOptionalAttributesSupported
Type: System..::..Boolean
true if the SCP supports all of the optional attributes requested. If false, the response message will have a status of 0001.

Remarks

If requested, the response status code is set to 0x0001, warning that all of the optional requested attributes were not supported.

This method sends an N-GET response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | - This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | - The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptModifyGPspsInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptModifyGPspsInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-ACTION request to modify status of a General Purpose Scheduled Procedure Step object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptModifyGPspsInformationRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptModifyGPspsInformationRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptModifyGPspsInformationRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-SET request message

Remarks

This method sends an N-ACTION Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptMppsNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptMppsNotification Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-EVENT-REPORT request message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptMppsNotification(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptMppsNotification ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptMppsNotification(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-EVENT-REPORT request message.

Remarks

This method sends an N-EVENT-REPORT Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptSetGPppsRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptSetGPppsRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-SET request for General Purpose Performed Procedure Step update.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptSetGPppsRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptSetGPppsRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptSetGPppsRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-SET request message.

Remarks

This method sends an N-SET Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptSetMppsRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptSetMppsRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-SET request for Modality Performed Procedure Step update.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptSetMppsRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptSetMppsRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptSetMppsRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-SET request message.

Remarks

This method sends an N-SET Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptSetStudyComponentRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptSetStudyComponentRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-SET request for study component information update.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptSetStudyComponentRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptSetStudyComponentRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptSetStudyComponentRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-SET request message.

Remarks

This method sends an N-SET Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptSetStudyInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptSetStudyInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-SET request for study information update.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptSetStudyInformationRequest(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptSetStudyInformationRequest ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptSetStudyInformationRequest(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-SET request message.

Remarks

This method sends an N-SET Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


acceptStudyManagementNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..acceptStudyManagementNotification Method
MCstudyManagementService Class See Also Send Feedback
Accepts an N-EVENT-REPORT request message.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void acceptStudyManagementNotification(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub acceptStudyManagementNotification ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void acceptStudyManagementNotification(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
The N-EVENT-REPORT request message.

Remarks

This method sends an N-EVENT-REPORT Success response message.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The command associated with the message was invalid or the message was null.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendCreateGPppsRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateGPppsRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCreateGPppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.
Public method | sendCreateGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendCreateGPppsRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateGPppsRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateGPppsRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendCreateGPppsRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateGPppsRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "G_P_PERFORMED_PROCEDURE_STEP" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to create the new SOP instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world Performed Procedure Step that is under control of the SCU.

If the affectedSopInstanceUid is not null, the SCP will use this value to uniquely identify the General Purpose Performed Procedure Step SOP Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateGPppsRequest Overload


sendCreateGPppsRequest Method (MCsopClass, String, MCgpPerformedProcedureStepCreate, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateGPppsRequest Method (MCsopClass, String, MCgpPerformedProcedureStepCreate, Boolean)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the General Purpose Performed Procedure Step SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateGPppsRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCgpPerformedProcedureStepCreate createInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendCreateGPppsRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    createInfo As MCgpPerformedProcedureStepCreate, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateGPppsRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCgpPerformedProcedureStepCreate^ createInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "G_P_PERFORMED_PROCEDURE_STEP" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
createInfo
Type: Mergecom.Gen..::..MCgpPerformedProcedureStepCreate
Non-null MCgpPerformedProcedureStepCreate containing a set of attributes and their values which are to be used by the SCP to create the new SOP instance.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world Performed Procedure Step that is under control of the SCU.

If affectedSopInstanceUid is not null, the SCP will use this value to uniquely identify the General Purpose Performed Procedure Step SOP Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateGPppsRequest Overload


sendCreateMppsRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateMppsRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCreateMppsRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.
Public method | sendCreateMppsRequest(MCsopClass, String, MCperformedProcedureStepCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendCreateMppsRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateMppsRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateMppsRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendCreateMppsRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateMppsRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "PERFORMED_PROCEDURE_STEP" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to create the new SOP instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the MPPS SOP Class and provide information about a specific real-world Performed Procedure Step that is under the control of the SCU. The service associated with the data set provided will be set to the "PERFORMED_PROCEDURE_STEP" service or the service identified by the affectedSopClass parameter. The data set's command will be set to MCdimseService.N_CREATE_RQ.

If affectedSopInstanceUid is not null the SCP will use this value to uniquely identify the MPPS Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateMppsRequest Overload


sendCreateMppsRequest Method (MCsopClass, String, MCperformedProcedureStepCreate, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateMppsRequest Method (MCsopClass, String, MCperformedProcedureStepCreate, Boolean)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the Modality Performed Procedure Step SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateMppsRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCperformedProcedureStepCreate createInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendCreateMppsRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    createInfo As MCperformedProcedureStepCreate, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateMppsRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCperformedProcedureStepCreate^ createInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "PERFORMED_PROCEDURE_STEP" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
createInfo
Type: Mergecom.Gen..::..MCperformedProcedureStepCreate
Non-null MCperformedProcedureStepCreate object containing a set of attributes and their values which are to be used by the SCP to create the new SOP instance.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the MPPS SOP Class and provide information about a specific real-world Performed Procedure Step that is under the control of the SCU. The service associated with the data set provided will be set to the "PERFORMED_PROCEDURE_STEP" service or the service identified by the affectedSopClass parameter. The data set's command will be set to N_CREATE_RQ.

If affectedSopInstanceUid is not null, the SCP will use this value to uniquely identify the MPPS Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateMppsRequest Overload


sendCreateStudyComponentRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateStudyComponentRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCdataSet) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.
Public method | sendCreateStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementCreate, Boolean) | Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendCreateStudyComponentRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateStudyComponentRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateStudyComponentRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendCreateStudyComponentRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateStudyComponentRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "STUDY_COMPONENT_MANAGEMENT" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to create the new SOP instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the Study Component SOP and provide information about a specific real-world Study (more specifically the portion of the real-world Study that is under the control of the SCU). The service associated with the data set provided will be set to the "STUDY_COMPONENT_MANAGEMENT" service or the service identified by the affectedSopClass parameter. The data set's command will be set to N_CREATE_RQ.

If affectedSopInstanceUid is not null, the SCP will use this value to uniquely identify the Study Component Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateStudyComponentRequest Overload


sendCreateStudyComponentRequest Method (MCsopClass, String, MCstudyComponentManagementCreate, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendCreateStudyComponentRequest Method (MCsopClass, String, MCstudyComponentManagementCreate, Boolean)
MCstudyManagementService Class See Also Send Feedback
Sends an N-CREATE request message to an SCP supporting the Study Component Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendCreateStudyComponentRequest(
    MCsopClass affectedSopClass,
    string affectedSopInstanceUid,
    MCstudyComponentManagementCreate createInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendCreateStudyComponentRequest ( _
    affectedSopClass As MCsopClass, _
    affectedSopInstanceUid As String, _
    createInfo As MCstudyComponentManagementCreate, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendCreateStudyComponentRequest(
    MCsopClass^ affectedSopClass,
    String^ affectedSopInstanceUid,
    MCstudyComponentManagementCreate^ createInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null affected SOP Class. If null, "STUDY_COMPONENT_MANAGEMENT" is used.
affectedSopInstanceUid
Type: System..::..String
Possibly-null instance UID.
createInfo
Type: Mergecom.Gen..::..MCstudyComponentManagementCreate
Non-null MCstudyComponentManagementCreate object containing the set of attributes and their values which are to be used by the SCP to create the new SOP instance.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that they are set properly. An MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation allows an SCU to create an instance of the Study Component SOP and provide information about a specific real-world Study (more specifically the portion of the real-world Study that is under the control of the SCU). The service associated with the data set provided will be set to the "STUDY_COMPONENT_MANAGEMENT" service or the service identified by the affectedSopClass parameter. The data set's command will be set to N_CREATE_RQ.

If affectedSopInstanceUid is not null, the SCP will use this value to uniquely identify the Study Component Instance it creates. If null, the SCP will assign an instance UID and return it in the response message as the affected SOP Instance Uid.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendCreateStudyComponentRequest Overload


sendDSMeventNotification Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendDSMeventNotification Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendDSMeventNotification(MCsopClass, String, MCdetachedStudyManagementEventReport, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.
Public method | sendDSMeventNotification(MCsopClass, String, MCdataSet, Int32) | Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendDSMeventNotification Method (MCsopClass, String, MCdetachedStudyManagementEventReport, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendDSMeventNotification Method (MCsopClass, String, MCdetachedStudyManagementEventReport, Int32)
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendDSMeventNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    int eventType
)
Visual Basic
Public Overridable Function sendDSMeventNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    eventType As Integer _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendDSMeventNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    int eventType
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport containing the attribute values related to the event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
eventType
Type: System..::..Int32
Number identifying the event.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

The eventInfo dataset is NOT checked to insure all type 1 and type 2 attributes have been set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendDSMeventNotification Overload


sendDSMeventNotification Method (MCsopClass, String, MCdataSet, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendDSMeventNotification Method (MCsopClass, String, MCdataSet, Int32)
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with a specified Event Type ID to the SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendDSMeventNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdataSet eventInfo,
    int eventType
)
Visual Basic
Public Overridable Function sendDSMeventNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdataSet, _
    eventType As Integer _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendDSMeventNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdataSet^ eventInfo,
    int eventType
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the Affected Study Instance.
eventInfo
Type: Mergecom..::..MCdataSet
Non-null MCdataSet object containing the attribute values related to the event. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
eventType
Type: System..::..Int32
Number identifying the event.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

The eventInfo dataset is NOT checked to insure all type 1 and type 2 attributes have been set. The service associated with the data set provided will be set to the "DETACHED_STUDY_MANAGEMENT" service or the service identified by the affectedSopClass parameter. The data set's command will be set to N_EVENT_REPORT_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by studyInstanceUid and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendDSMeventNotification Overload


sendGetGPppsInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendGetGPppsInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Requests Performed Procedure Step Information from a GP PPS SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetGPppsInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    uint[] attributeIdList
)
Visual Basic
Public Overridable Function sendGetGPppsInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeIdList As UInteger() _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetGPppsInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    array<unsigned int>^ attributeIdList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null SOP Class owning the requested instance. If null, "G_P_PERFORMED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null UID of a GP PPS SOP instance.
attributeIdList
Type: array<System..::..UInt32>[]()[][]
Non-null array of attribute tags identifying attributes whose values are requested.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This method sends an N-GET request message for the General Purpose Performed Procedure Step SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendGetMppsInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendGetMppsInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Requests Performed Procedure Step Information from an MPPS SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetMppsInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    uint[] attributeIdList
)
Visual Basic
Public Overridable Function sendGetMppsInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeIdList As UInteger() _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetMppsInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    array<unsigned int>^ attributeIdList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null SOP Class owning the requested instance. If null, "PERFORMED_PROCEDURE_STEP_RETRIEVE" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null UID of an MPPS SOP instance.
attributeIdList
Type: array<System..::..UInt32>[]()[][]
Non-null array of attribute tags identifying attributes whose values are requested.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This method sends an N-GET request message for the Modality Performed Procedure Step Retrieve SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendGetStudyComponentInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendGetStudyComponentInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Requests Study Component Information from a Study Component Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetStudyComponentInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    uint[] attributeIdList
)
Visual Basic
Public Overridable Function sendGetStudyComponentInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeIdList As UInteger() _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetStudyComponentInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    array<unsigned int>^ attributeIdList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null SOP Class owning the requested instance. If null, "STUDY_COMPONENT_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null UID of a Detached Study Management SOP instance.
attributeIdList
Type: array<System..::..UInt32>[]()[][]
Non-null array of attribute tags identifying attributes whose values are requested.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This method sends an N-GET request message for the Study Component Management SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendGetStudyInformationRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendGetStudyInformationRequest Method
MCstudyManagementService Class See Also Send Feedback
Requests Study Information from a Detached Study Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendGetStudyInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    uint[] attributeIdList
)
Visual Basic
Public Overridable Function sendGetStudyInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeIdList As UInteger() _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendGetStudyInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    array<unsigned int>^ attributeIdList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null SOP Class owning the requested instance. If null, "DETACHED_STUDY_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null UID of a Detached Study Management SOP instance.
attributeIdList
Type: array<System..::..UInt32>[]()[][]
Non-null array of attribute tags identifying attributes whose values are requested.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This method sends an N-GET request message for the Detached Study Management SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendModifyGPspsInformationRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendModifyGPspsInformationRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCdataSet) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.
Public method | sendModifyGPspsInformationRequest(MCsopClass, String, MCgpScheduledProcedureStep, Boolean) | Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendModifyGPspsInformationRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendModifyGPspsInformationRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendModifyGPspsInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdataSet actionInformation
)
Visual Basic
Public Overridable Function sendModifyGPspsInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    actionInformation As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendModifyGPspsInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdataSet^ actionInformation
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly null affected SOP Class. If null, "G_P_SCHEDULED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Not null UID of the General Purpose Scheduled Procedure Step SOP Instance for which it wants to modify Action Information,
actionInformation
Type: Mergecom..::..MCdataSet
Not null data set containing the set of attributes and their values which are to be used by the SCP to modify the SOP instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation is invoked through the DIMSE N-ACTION Service, with an Action Type ID of 1.

The service associated with the data set provided will be set to the "G_P_SCHEDULED_PROCEDURE_STEP" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_ACTION_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendModifyGPspsInformationRequest Overload


sendModifyGPspsInformationRequest Method (MCsopClass, String, MCgpScheduledProcedureStep, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendModifyGPspsInformationRequest Method (MCsopClass, String, MCgpScheduledProcedureStep, Boolean)
MCstudyManagementService Class See Also Send Feedback
Requests the modification of Attribute Values of an instance of the General Purpose Scheduled Procedure Step SOP Class and provide information about a specific real-world General Purpose Scheduled Procedure Step that is under control of the SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendModifyGPspsInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCgpScheduledProcedureStep actionInformation,
    bool validate
)
Visual Basic
Public Overridable Function sendModifyGPspsInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    actionInformation As MCgpScheduledProcedureStep, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendModifyGPspsInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCgpScheduledProcedureStep^ actionInformation,
    bool validate
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly null affected SOP Class. If null, "G_P_SCHEDULED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Not null UID of the General Purpose Scheduled Procedure Step SOP Instance for which it wants to modify Action Information,
actionInformation
Type: Mergecom.Gen..::..MCgpScheduledProcedureStep
Not null MCgpScheduledProcedureStep object containing the set of attributes and their values which are to be used by the SCP to modify the SOP instance.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that they are set properly and an MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This operation is invoked through the DIMSE N-ACTION Service, with an Action Type ID of 1.

The service associated with the data set provided will be set to the "G_P_SCHEDULED_PROCEDURE_STEP" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_ACTION_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendModifyGPspsInformationRequest Overload


sendMppsCompletedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendMppsCompletedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Modality Performed Procedure Step Notification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMppsCompletedNotification(
    MCsopClass affectedSopClass,
    string mppsInstanceUid
)
Visual Basic
Public Overridable Function sendMppsCompletedNotification ( _
    affectedSopClass As MCsopClass, _
    mppsInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMppsCompletedNotification(
    MCsopClass^ affectedSopClass,
    String^ mppsInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "PERFORMED_PROCEDURE_STEP_NOTIFY" is used.
mppsInstanceUid
Type: System..::..String
Non-null UID assigned to the affected MPPS Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Performed Procedure Step is completed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendMppsDeletedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendMppsDeletedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Modality Performed Procedure Step Notification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMppsDeletedNotification(
    MCsopClass affectedSopClass,
    string mppsInstanceUid
)
Visual Basic
Public Overridable Function sendMppsDeletedNotification ( _
    affectedSopClass As MCsopClass, _
    mppsInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMppsDeletedNotification(
    MCsopClass^ affectedSopClass,
    String^ mppsInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "PERFORMED_PROCEDURE_STEP_NOTIFY" is used.
mppsInstanceUid
Type: System..::..String
Non-null UID assigned to the affected MPPS Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Performed Procedure Step has been deleted.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendMppsDiscontinuedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendMppsDiscontinuedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Modality Performed Procedure Step Notification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMppsDiscontinuedNotification(
    MCsopClass affectedSopClass,
    string mppsInstanceUid
)
Visual Basic
Public Overridable Function sendMppsDiscontinuedNotification ( _
    affectedSopClass As MCsopClass, _
    mppsInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMppsDiscontinuedNotification(
    MCsopClass^ affectedSopClass,
    String^ mppsInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "PERFORMED_PROCEDURE_STEP_NOTIFY" is used.
mppsInstanceUid
Type: System..::..String
Non-null UID assigned to the affected MPPS Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Performed Procedure Step has been discontinued.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendMppsInProgressNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendMppsInProgressNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Modality Performed Procedure Step Notification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMppsInProgressNotification(
    MCsopClass affectedSopClass,
    string mppsInstanceUid
)
Visual Basic
Public Overridable Function sendMppsInProgressNotification ( _
    affectedSopClass As MCsopClass, _
    mppsInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMppsInProgressNotification(
    MCsopClass^ affectedSopClass,
    String^ mppsInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "PERFORMED_PROCEDURE_STEP_NOTIFY" is used.
mppsInstanceUid
Type: System..::..String
Non-null UID assigned to the affected MPPS Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Performed Procedure Step is in progress.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendMppsUpdatedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendMppsUpdatedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Modality Performed Procedure Step Notification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendMppsUpdatedNotification(
    MCsopClass affectedSopClass,
    string mppsInstanceUid
)
Visual Basic
Public Overridable Function sendMppsUpdatedNotification ( _
    affectedSopClass As MCsopClass, _
    mppsInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendMppsUpdatedNotification(
    MCsopClass^ affectedSopClass,
    String^ mppsInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "PERFORMED_PROCEDURE_STEP_NOTIFY" is used.
mppsInstanceUid
Type: System..::..String
Non-null UID assigned to the affected MPPS Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Performed Procedure Step has been updated.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendPatientArrivedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendPatientArrivedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 3 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendPatientArrivedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendPatientArrivedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendPatientArrivedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport collection containing the attribute values related to a Patient Arrived Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that they are set properly and an MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null; StudyArrivalDate; StudyArrivalTime.

This event is used to notify the SCU that the Patient has arrived.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | A required attribute was missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendSetGPppsRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetGPppsRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSetGPppsRequest(MCsopClass, String, MCdataSet) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.
Public method | sendSetGPppsRequest(MCsopClass, String, MCgpPerformedProcedureStepSet, Boolean) | Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendSetGPppsRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetGPppsRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetGPppsRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendSetGPppsRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetGPppsRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "G_P_PERFORMED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | A required attribute was missing.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetGPppsRequest Overload


sendSetGPppsRequest Method (MCsopClass, String, MCgpPerformedProcedureStepSet, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetGPppsRequest Method (MCsopClass, String, MCgpPerformedProcedureStepSet, Boolean)
MCstudyManagementService Class See Also Send Feedback
Sets Attribute Values of an instance of the General Purpose Performed Procedure Step SOP Class and provide information about a specific real-world General Purpose Performed Procedure Step that is under control of the SCU. This operation is invoked through the DIMSE N-SET Service.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetGPppsRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCgpPerformedProcedureStepSet setInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendSetGPppsRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    setInfo As MCgpPerformedProcedureStepSet, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetGPppsRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCgpPerformedProcedureStepSet^ setInfo,
    bool validate
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "G_P_PERFORMED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
setInfo
Type: Mergecom.Gen..::..MCgpPerformedProcedureStepSet
Non-null MCperformedProcedureStepSet object containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetGPppsRequest Overload


sendSetMppsRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetMppsRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSetMppsRequest(MCsopClass, String, MCdataSet) | Requests that Modality Performed Procedure Step Information be updated by an MPPS SCP.
Public method | sendSetMppsRequest(MCsopClass, String, MCperformedProcedureStepSet, Boolean) | Requests that Performed Procedure Step Information be updated by an MPSS SCP.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendSetMppsRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetMppsRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Requests that Modality Performed Procedure Step Information be updated by an MPPS SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetMppsRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendSetMppsRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetMppsRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "PERFORMED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is see, the PERFORMED_PROCEDURE_STEP SOP Class is assumed. The service associated with the data set provided will be set to the "PERFORMED_PROCEDURE_STEP" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetMppsRequest Overload


sendSetMppsRequest Method (MCsopClass, String, MCperformedProcedureStepSet, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetMppsRequest Method (MCsopClass, String, MCperformedProcedureStepSet, Boolean)
MCstudyManagementService Class See Also Send Feedback
Requests that Performed Procedure Step Information be updated by an MPSS SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetMppsRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCperformedProcedureStepSet al,
    bool validate
)
Visual Basic
Public Overridable Function sendSetMppsRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    al As MCperformedProcedureStepSet, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetMppsRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCperformedProcedureStepSet^ al,
    bool validate
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "PERFORMED_PROCEDURE_STEP" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
al
Type: Mergecom.Gen..::..MCperformedProcedureStepSet
Non-null MCperformedProcedureStepSet object containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is null, the PERFORMED_PROCEDURE_STEP SOP Class is assumed. The service associated with the data set provided will be set to the "PERFORMED_PROCEDURE_STEP" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

The following fields are required:

Type 3: but element required if it exists; MCprocedureCodeItem (only 1 item); CodeValue must exist in the item; CodingSchemeDesignator must exist in the item.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetMppsRequest Overload


sendSetStudyComponentRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyComponentRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCstudyComponentManagementSet) | Requests that Study Component Information be updated by a Study Component Management SCP.
Public method | sendSetStudyComponentRequest(MCsopClass, String, MCdataSet) | Requests that Study Component Information be updated by a Study Component Management SCP.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendSetStudyComponentRequest Method (MCsopClass, String, MCstudyComponentManagementSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyComponentRequest Method (MCsopClass, String, MCstudyComponentManagementSet)
MCstudyManagementService Class See Also Send Feedback
Requests that Study Component Information be updated by a Study Component Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetStudyComponentRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCstudyComponentManagementSet attributeList
)
Visual Basic
Public Overridable Function sendSetStudyComponentRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCstudyComponentManagementSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetStudyComponentRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCstudyComponentManagementSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "STUDY_COMPONENT_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
attributeList
Type: Mergecom.Gen..::..MCstudyComponentManagementSet
Non-null MCstudyComponentManagementSet object containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is null, the STUDY_COMPONENT_MANAGEMENT SOP Class is assumed. The service associated with the data set provided will be set to the "STUDY_COMPONENT_MANAGEMENT" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetStudyComponentRequest Overload


sendSetStudyComponentRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyComponentRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Requests that Study Component Information be updated by a Study Component Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetStudyComponentRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendSetStudyComponentRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetStudyComponentRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "STUDY_COMPONENT_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is null, the STUDY_COMPONENT_MANAGEMENT SOP Class is assumed. The service associated with the data set provided will be set to the "STUDY_COMPONENT_MANAGEMENT" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetStudyComponentRequest Overload


sendSetStudyInformationRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyInformationRequest Method
MCstudyManagementService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdetachedStudyManagementSet) | Requests that Study Information be updated by a Detached Study Management SCP.
Public method | sendSetStudyInformationRequest(MCsopClass, String, MCdataSet) | Requests that Study Information be updated by a Detached Study Management SCP.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendSetStudyInformationRequest Method (MCsopClass, String, MCdetachedStudyManagementSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyInformationRequest Method (MCsopClass, String, MCdetachedStudyManagementSet)
MCstudyManagementService Class See Also Send Feedback
Requests that Study Information be updated by a Detached Study Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetStudyInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdetachedStudyManagementSet attributeList
)
Visual Basic
Public Overridable Function sendSetStudyInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCdetachedStudyManagementSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetStudyInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdetachedStudyManagementSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "DETACHED_STUDY_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested study instance UID.
attributeList
Type: Mergecom.Gen..::..MCdetachedStudyManagementSet
Non-null MCdetachedStudyManagementSet object containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is null, the DETACHED_STUDY_MANAGEMENT SOP Class is assumed. The service associated with the attribute list's data set will be set to the "DETACHED_STUDY_MANAGEMENT" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetStudyInformationRequest Overload


sendSetStudyInformationRequest Method (MCsopClass, String, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendSetStudyInformationRequest Method (MCsopClass, String, MCdataSet)
MCstudyManagementService Class See Also Send Feedback
Requests that Study Information be updated by a Detached Study Management SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendSetStudyInformationRequest(
    MCsopClass requestedSopClass,
    string requestedSopInstanceUid,
    MCdataSet attributeList
)
Visual Basic
Public Overridable Function sendSetStudyInformationRequest ( _
    requestedSopClass As MCsopClass, _
    requestedSopInstanceUid As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendSetStudyInformationRequest(
    MCsopClass^ requestedSopClass,
    String^ requestedSopInstanceUid,
    MCdataSet^ attributeList
)

Parameters

requestedSopClass
Type: Mergecom..::..MCsopClass
Possibly-null requested SOP Class. If null, "DETACHED_STUDY_MANAGEMENT" is used.
requestedSopInstanceUid
Type: System..::..String
Non-null requested SOP instance UID.
attributeList
Type: Mergecom..::..MCdataSet
Non-null data set containing the set of attributes and their values which are to be used by the SCP to replace the current values of the attributes specified.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

An N-SET request message is sent to update the requestedSopInstanceUid instance of the requestedSopClass specified. If requestedSopClass is null, the DETACHED_STUDY_MANAGEMENT SOP Class is assumed. The service associated with the data set provided will be set to the "DETACHED_STUDY_MANAGEMENT" service or the service identified by the requestedSopClass parameter. The data set's command will be set to N_SET_RQ.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members
sendSetStudyInformationRequest Overload


sendStudyCompletedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyCompletedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 5 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyCompletedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyCompletedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyCompletedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Completed Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null; StudyCompletionDate; StudyCompletionTime;
ReferencedStudyComponents; ReferencedStudyComponents->ReferencedSOPClassUID;
ReferencedStudyComponents->ReferencedSOPInstanceUID

This event is used to notify the SCU that a Study has completed.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyCreatedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyCreatedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 1 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyCreatedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyCreatedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyCreatedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Created Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null; InstanceCreationDate;
RefPatients; RefPatients->ReferencedSOPClassUID; RefPatients->ReferencedSOPInstanceUID;
RefVisits; RefVisits->ReferencedSOPClassUID; RefVisits->ReferencedSOPInstanceUID;
Type 2: must be set but may be null; InstanceCreationTime; InstanceCreatorUID; StudyStatusID

This event is used to notify the SCU that a Study has been created.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyDeletedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyDeletedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 8 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyDeletedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid
)
Visual Basic
Public Overridable Function sendStudyDeletedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyDeletedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that a Study has been deleted.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyReadNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyReadNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 7 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyReadNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyReadNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyReadNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Read Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null;
StudyReadDate;
StudyReadTime;

This event is used to notify the SCU that the Study has been read.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyScheduledNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyScheduledNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 2 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyScheduledNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyScheduledNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyScheduledNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Scheduled Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null;
RefPatients;
RefPatients->ReferencedSOPClassUID;
RefPatients->ReferencedSOPInstanceUID;

RefVisits;
RefVisits->ReferencedSOPClassUID;
RefVisits->ReferencedSOPInstanceUID;

ScheduledStudyStartDate;
ScheduledStudyStartTime;

if RequestedProcedureCodes is set:
RequestedProcedureCodes->CodeValue;
RequestedProcedureCodes->CodingSchemeDesignator;
RequestedProcedureCodes->CodeMeaning;

Type 2: must be set but may be null;
RequestedProcedureCodes;
ScheduledStudyLocation;
ScheduledStudyLocationAETitles;
RequestedProcedureDescription;

This event is used to notify the SCU that a Study has been scheduled.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyStartedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyStartedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 4 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyStartedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyStartedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyStartedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Started Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

Type 1: must be set and may not be null; StudyDate; StudyTime.

This event is used to notify the SCU that the Study has started.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyUpdatedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyUpdatedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 9 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyUpdatedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo
)
Visual Basic
Public Overridable Function sendStudyUpdatedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyUpdatedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Update Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

This event is used to notify the SCU that the Study has been updated.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


sendStudyVerifiedNotification Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService..::..sendStudyVerifiedNotification Method
MCstudyManagementService Class See Also Send Feedback
Sends an N-EVENT-REPORT DIMSE message with an Event Type ID of 6 to an SCU using a Detached Study Management SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdimseMessage sendStudyVerifiedNotification(
    MCsopClass affectedSopClass,
    string studyInstanceUid,
    MCdetachedStudyManagementEventReport eventInfo,
    bool validate
)
Visual Basic
Public Overridable Function sendStudyVerifiedNotification ( _
    affectedSopClass As MCsopClass, _
    studyInstanceUid As String, _
    eventInfo As MCdetachedStudyManagementEventReport, _
    validate As Boolean _
) As MCdimseMessage
Visual C++
public:
virtual MCdimseMessage^ sendStudyVerifiedNotification(
    MCsopClass^ affectedSopClass,
    String^ studyInstanceUid,
    MCdetachedStudyManagementEventReport^ eventInfo,
    bool validate
)

Parameters

affectedSopClass
Type: Mergecom..::..MCsopClass
The SOP Class affected by this notification. If null, "DETACHED_STUDY_MANAGEMENT" is used.
studyInstanceUid
Type: System..::..String
Non-null UID assigned to the affected Study Instance.
eventInfo
Type: Mergecom.Gen..::..MCdetachedStudyManagementEventReport
Non-null MCdetachedStudyManagementEventReport container containing the attribute values related to a Study Verified Event. It must have been constructed using a data set. The data set will have its service set per the affectedSopClass parameter, and its command will be set to N_EVENT_REPORT_RQ.
validate
Type: System..::..Boolean
If true the Type 1 and Type 2 attributes will be checked to ensure that that are set properly and MCrequiredAttributeMissingException will be thrown if they are not.

Return Value

The MCdimseMessage object that was used to send the DIMSE request.

Remarks

If requested, the eventInfo container is checked to insure all type 1 and type 2 attributes have been set.

The following fields are required:

  • Type 1: must be set and may not be null
  • StudyVerifiedDate
  • StudyVerifiedTime
  • ReferencedStudyComponents
  • ReferencedStudyComponents->ReferencedSOPClassUID
  • ReferencedStudyComponents->ReferencedSOPInstanceUID

This event is used to notify the SCU that a Study has been Verified.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | An attribute required by the service was not supplied in the message.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCstudyManagementService Class
MCstudyManagementService Members


MCstudyManagementService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyManagementService Properties
MCstudyManagementService Class See Also Send Feedback

The MCstudyManagementService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCstudyManagementService Class


MCtag Class

[image]

Merge DICOM .NET/C# Toolkit
MCtag Class
Members See Also Send Feedback
Represents a DICOM data element identifier normally referred to as a "tag".

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtag
Visual Basic
Public Class MCtag
Visual C++
public ref class MCtag

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCtag

See Also

MCtag Members


MCtag Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtag Members
MCtag Class Constructors Methods Properties See Also Send Feedback

The MCtag type exposes the following members.

Constructors

 | Name | Description
Public method | MCtag(UInt32) | Constructs a non-private DICOM tag.
Public method | MCtag(UInt32, String) | Constructs a DICOM tag from creator code and a tag number.
Public method | MCtag(UInt32, UInt32) | Constructs a non-private DICOM tag from group and element numbers expressed as integers.
Public method | MCtag(String, UInt32, UInt32) | Constructs a private DICOM tag from creator code, group and element numbers expressed as integers.

Methods

 | Name | Description
Public method | Compare | Compares this object to another object.
Public method | Equals | Determines whether this tag is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code based on this tag's number and private code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | isPrivate | Determines if a tag is private element.
 | isPrivateCode | Determines if a tag is a private creator element tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this tag. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ElementNumber | The element portion of the tag number.
Public property | GroupNumber | The group portion of the tag number.
Public property | IsPrivateCode | Determines whether this tag represents a private creator element.
Public property | IsPrivateTag | Determines whether this tag represents a private element.
Public property | PrivateCode | The private creator code associated with this tag's private group.
Public property | PrivateElementNumber | The number identifying the private attribute within the private Group.
Public property | TagNumber | The tag number.

See Also

MCtag Class


MCtag Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtag Constructor
MCtag Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtag(UInt32) | Constructs a non-private DICOM tag.
Public method | MCtag(UInt32, String) | Constructs a DICOM tag from creator code and a tag number.
Public method | MCtag(UInt32, UInt32) | Constructs a non-private DICOM tag from group and element numbers expressed as integers.
Public method | MCtag(String, UInt32, UInt32) | Constructs a private DICOM tag from creator code, group and element numbers expressed as integers.

See Also

MCtag Class
MCtag Members


MCtag Constructor (UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCtag Constructor (UInt32)
MCtag Class See Also Send Feedback
Constructs a non-private DICOM tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtag(
    uint tagNumber
)
Visual Basic
Public Sub New ( _
    tagNumber As UInteger _
)
Visual C++
public:
MCtag(
    unsigned int tagNumber
)

Parameters

tagNumber
Type: System..::..UInt32
The tag number.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The tagNumber argument represents a private element.

See Also

MCtag Class
MCtag Members
MCtag Overload


MCtag Constructor (UInt32, String)

[image]

Merge DICOM .NET/C# Toolkit
MCtag Constructor (UInt32, String)
MCtag Class See Also Send Feedback
Constructs a DICOM tag from creator code and a tag number.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtag(
    uint tagNumber,
    string privateCode
)
Visual Basic
Public Sub New ( _
    tagNumber As UInteger, _
    privateCode As String _
)
Visual C++
public:
MCtag(
    unsigned int tagNumber,
    String^ privateCode
)

Parameters

tagNumber
Type: System..::..UInt32
The tag number.
privateCode
Type: System..::..String
DICOM code string for private group; null for a standard dicom tag.

Remarks

This constructor can be used to create a private creator code tag.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCtag Class
MCtag Members
MCtag Overload


MCtag Constructor (UInt32, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCtag Constructor (UInt32, UInt32)
MCtag Class See Also Send Feedback
Constructs a non-private DICOM tag from group and element numbers expressed as integers.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtag(
    uint group,
    uint element
)
Visual Basic
Public Sub New ( _
    group As UInteger, _
    element As UInteger _
)
Visual C++
public:
MCtag(
    unsigned int group,
    unsigned int element
)

Parameters

group
Type: System..::..UInt32
Most significant 2 bytes of the tag number.
element
Type: System..::..UInt32
Least significant 2 bytes of the tag number.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The arguments represent a private element.

See Also

MCtag Class
MCtag Members
MCtag Overload


MCtag Constructor (String, UInt32, UInt32)

[image]

Merge DICOM .NET/C# Toolkit
MCtag Constructor (String, UInt32, UInt32)
MCtag Class See Also Send Feedback
Constructs a private DICOM tag from creator code, group and element numbers expressed as integers.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtag(
    string privateCode,
    uint privateGroupNumber,
    uint privateElementNumber
)
Visual Basic
Public Sub New ( _
    privateCode As String, _
    privateGroupNumber As UInteger, _
    privateElementNumber As UInteger _
)
Visual C++
public:
MCtag(
    String^ privateCode,
    unsigned int privateGroupNumber,
    unsigned int privateElementNumber
)

Parameters

privateCode
Type: System..::..String
Creator code string for the private group.
privateGroupNumber
Type: System..::..UInt32
The private tag's group (an odd number).
privateElementNumber
Type: System..::..UInt32
The private tag's element number (0-255).

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCtag Class
MCtag Members
MCtag Overload


MCtag Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtag Methods
MCtag Class See Also Send Feedback

The MCtag type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this object to another object.
Public method | Equals | Determines whether this tag is equal to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code based on this tag's number and private code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | isPrivate | Determines if a tag is private element.
 | isPrivateCode | Determines if a tag is a private creator element tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this tag. (Overrides Object..::..ToString()()()().)

See Also

MCtag Class


Compare Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..Compare Method
MCtag Class See Also Send Feedback
Compares this object to another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int Compare(
    Object other
)
Visual Basic
Public Function Compare ( _
    other As Object _
) As Integer
Visual C++
public:
int Compare(
    Object^ other
)

Parameters

other
Type: System..::..Object
The object to compare against this object.

Return Value

-1 if this object is less than other, 1 if object is greater than other and 0 if they are equal.

Remarks

MCtag instances can be compared to each other or to unsigned integers (uint) representing DICOM tag numbers.

The order of two tags is given by the order of their tag numbers. For private tags that have the same group number but different private creator codes the order is based on the order of the private creator code strings.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The type of the argument was invalid for comparison.

See Also

MCtag Class
MCtag Members


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..Equals Method
MCtag Class See Also Send Feedback
Determines whether this tag is equal to another object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object
The object to compare to this object.

Return Value

true if both objects refer to the same DICOM tag.

Remarks

The objects are declared equal if the other object is a non-null instance of MCtag and the tag numbers are equal and (if this is a private tag) both private codes are equal.

See Also

MCtag Class
MCtag Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..GetHashCode Method
MCtag Class See Also Send Feedback
Returns a hash code based on this tag's number and private code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code value for this object.

See Also

MCtag Class
MCtag Members


isPrivate Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..isPrivate Method
MCtag Class See Also Send Feedback
Determines if a tag is private element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool isPrivate(
    uint tag
)
Visual Basic
Public Shared Function isPrivate ( _
    tag As UInteger _
) As Boolean
Visual C++
public:
static bool isPrivate(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag value.

Return Value

true if the argument represents a private element; otherwise false.

Remarks

A tag is considered private element if its group number is odd and its element number is not in the range [0x0010,0x00FF]. Odd numbered groups 1, 3, 5, 7 and 0xFFFF, and element numbers in the range [0x0001,0x000F] or [0x0100,0x0FFF] are DICOM non-compliant (will generate warning message). Note: element 0 (group length - retired) isn't treated as private data element and will return false.

See Also

MCtag Class
MCtag Members


isPrivateCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..isPrivateCode Method
MCtag Class See Also Send Feedback
Determines if a tag is a private creator element tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static bool isPrivateCode(
    uint tag
)
Visual Basic
Public Shared Function isPrivateCode ( _
    tag As UInteger _
) As Boolean
Visual C++
public:
static bool isPrivateCode(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
The tag value.

Return Value

true if the argument represents a private creator element; otherwise false.

Remarks

A tag is considered private creator element tag if its group number is odd and it has element numbers between 0x0010 and 0x00FF inclusively. Odd numbered groups 1, 3, 5, 7 and 0xFFFF will generate a warning message since these are DICOM non-compliant.

See Also

MCtag Class
MCtag Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..ToString Method
MCtag Class See Also Send Feedback
Returns a string that represents this tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of this DICOM tag.

Remarks

The returned String contains the tag number as a hexadecimal number. If the tag is private, its private code is included.

See Also

MCtag Class
MCtag Members


MCtag Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtag Properties
MCtag Class See Also Send Feedback

The MCtag type exposes the following members.

Properties

 | Name | Description
Public property | ElementNumber | The element portion of the tag number.
Public property | GroupNumber | The group portion of the tag number.
Public property | IsPrivateCode | Determines whether this tag represents a private creator element.
Public property | IsPrivateTag | Determines whether this tag represents a private element.
Public property | PrivateCode | The private creator code associated with this tag's private group.
Public property | PrivateElementNumber | The number identifying the private attribute within the private Group.
Public property | TagNumber | The tag number.

See Also

MCtag Class


ElementNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..ElementNumber Property
MCtag Class See Also Send Feedback
The element portion of the tag number.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort ElementNumber { get; }
Visual Basic
Public Overridable ReadOnly Property ElementNumber As UShort
    Get
Visual C++
public:
virtual property unsigned short ElementNumber {
    unsigned short get ();
}

Field Value

The least significant 16 bits of the 32-bit tag number.

See Also

MCtag Class
MCtag Members


GroupNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..GroupNumber Property
MCtag Class See Also Send Feedback
The group portion of the tag number.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort GroupNumber { get; }
Visual Basic
Public Overridable ReadOnly Property GroupNumber As UShort
    Get
Visual C++
public:
virtual property unsigned short GroupNumber {
    unsigned short get ();
}

Field Value

The most significant 16 bits of the 32-bit tag number.

See Also

MCtag Class
MCtag Members


IsPrivateCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..IsPrivateCode Property
MCtag Class See Also Send Feedback
Determines whether this tag represents a private creator element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool IsPrivateCode { get; }
Visual Basic
Public ReadOnly Property IsPrivateCode As Boolean
    Get
Visual C++
public:
property bool IsPrivateCode {
    bool get ();
}

Return Value

true if this is a private creator element tag; otherwise false.

Remarks

A tag is considered private creator element tag if its group number is odd and it has element numbers between 0x0010 and 0x00FF inclusively. Odd numbered groups 1, 3, 5, 7 and 0xFFFF will generate a warning message since these are DICOM non-compliant.

See Also

MCtag Class
MCtag Members


IsPrivateTag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..IsPrivateTag Property
MCtag Class See Also Send Feedback
Determines whether this tag represents a private element.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool IsPrivateTag { get; }
Visual Basic
Public ReadOnly Property IsPrivateTag As Boolean
    Get
Visual C++
public:
property bool IsPrivateTag {
    bool get ();
}

Return Value

true if this is a private tag; otherwise false.

Remarks

A tag is considered private element if its group number is odd and its element number is not in the range [0x0010,0x00FF]. Odd numbered groups 1, 3, 5, 7 and 0xFFFF, and element numbers in the range [0x0001,0x000F] or [0x0100,0x0FFF] are DICOM non-compliant (will generate warning message). Note: element 0 (group length - retired) isn't treated as private data element and will return false.

See Also

MCtag Class
MCtag Members


PrivateCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..PrivateCode Property
MCtag Class See Also Send Feedback
The private creator code associated with this tag's private group.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PrivateCode { get; }
Visual Basic
Public Overridable ReadOnly Property PrivateCode As String
    Get
Visual C++
public:
virtual property String^ PrivateCode {
    String^ get ();
}

Field Value

The tag's private creator code, or null if this is not a private tag.

See Also

MCtag Class
MCtag Members


PrivateElementNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..PrivateElementNumber Property
MCtag Class See Also Send Feedback
The number identifying the private attribute within the private Group.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public byte PrivateElementNumber { get; }
Visual Basic
Public ReadOnly Property PrivateElementNumber As Byte
    Get
Visual C++
public:
property unsigned char PrivateElementNumber {
    unsigned char get ();
}

Field Value

A byte representing the private element number.

See Also

MCtag Class
MCtag Members


TagNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtag..::..TagNumber Property
MCtag Class See Also Send Feedback
The tag number.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint TagNumber { get; }
Visual Basic
Public Overridable ReadOnly Property TagNumber As UInteger
    Get
Visual C++
public:
virtual property unsigned int TagNumber {
    unsigned int get ();
}

Field Value

The 32 bit DICOM tag number.

See Also

MCtag Class
MCtag Members


MCtime Class

[image]

Merge DICOM .NET/C# Toolkit
MCtime Class
Members See Also Send Feedback
Represents a DICOM time value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtime
Visual Basic
Public Class MCtime
Visual C++
public ref class MCtime

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCtime

See Also

MCtime Members


MCtime Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtime Members
MCtime Class Constructors Methods Properties See Also Send Feedback

The MCtime type exposes the following members.

Constructors

 | Name | Description
Public method | MCtime(Int32) | Initializes a new instance of this class for the specified hours.
Public method | MCtime(String) | Initializes a new instance of this class using a DICOM time string.
Public method | MCtime(Int32, Int32) | Initializes a new instance of this class for the specified hours and minutes.
Public method | MCtime(Int32, Int32, Int32) | Initializes a new instance of this class for the specified hours, minutes and seconds.
Public method | MCtime(Int32, Int32, Int32, Double) | Initializes a new instance of this class for the specified hours, minutes, seconds and fractional seconds.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Retrieves the string representation of this time string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Fraction | The fraction portion of the DICOM time string.
Public property | Hours | The hours portion of the DICOM time string.
Public property | Minutes | The minutes portion of the DICOM time string.
Public property | Seconds | The seconds portion of the DICOM time string.
Public property | Time | The DICOM formatted time string.

See Also

MCtime Class


MCtime Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor
MCtime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtime(Int32) | Initializes a new instance of this class for the specified hours.
Public method | MCtime(String) | Initializes a new instance of this class using a DICOM time string.
Public method | MCtime(Int32, Int32) | Initializes a new instance of this class for the specified hours and minutes.
Public method | MCtime(Int32, Int32, Int32) | Initializes a new instance of this class for the specified hours, minutes and seconds.
Public method | MCtime(Int32, Int32, Int32, Double) | Initializes a new instance of this class for the specified hours, minutes, seconds and fractional seconds.

See Also

MCtime Class
MCtime Members


MCtime Constructor (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor (Int32)
MCtime Class See Also Send Feedback
Initializes a new instance of this class for the specified hours.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime(
    int hours
)
Visual Basic
Public Sub New ( _
    hours As Integer _
)
Visual C++
public:
MCtime(
    int hours
)

Parameters

hours
Type: System..::..Int32
The hours portion of the time string, range 0 to 23, where 00 means midnight

Remarks

Using this constructor insures a properly formatted DICOM time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.

See Also

MCtime Class
MCtime Members
MCtime Overload


MCtime Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor (String)
MCtime Class See Also Send Feedback
Initializes a new instance of this class using a DICOM time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime(
    string timeStr
)
Visual Basic
Public Sub New ( _
    timeStr As String _
)
Visual C++
public:
MCtime(
    String^ timeStr
)

Parameters

timeStr
Type: System..::..String
The DICOM formatted time string.

Remarks

This form of the constructor does not validate the time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCtime Class
MCtime Members
MCtime Overload


MCtime Constructor (Int32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor (Int32, Int32)
MCtime Class See Also Send Feedback
Initializes a new instance of this class for the specified hours and minutes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime(
    int hours,
    int minutes
)
Visual Basic
Public Sub New ( _
    hours As Integer, _
    minutes As Integer _
)
Visual C++
public:
MCtime(
    int hours,
    int minutes
)

Parameters

hours
Type: System..::..Int32
The hours portion of the time string, range 0 to 23, where 00 means midnight
minutes
Type: System..::..Int32
The minutes portion of the time string, range 0 to 59.

Remarks

Using this constructor insures a properly formatted DICOM time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.

See Also

MCtime Class
MCtime Members
MCtime Overload


MCtime Constructor (Int32, Int32, Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor (Int32, Int32, Int32)
MCtime Class See Also Send Feedback
Initializes a new instance of this class for the specified hours, minutes and seconds.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime(
    int hours,
    int minutes,
    int seconds
)
Visual Basic
Public Sub New ( _
    hours As Integer, _
    minutes As Integer, _
    seconds As Integer _
)
Visual C++
public:
MCtime(
    int hours,
    int minutes,
    int seconds
)

Parameters

hours
Type: System..::..Int32
The hours portion of the time string, range 0 to 23, where 00 means midnight
minutes
Type: System..::..Int32
The minutes portion of the time string, range 0 to 59.
seconds
Type: System..::..Int32
The seconds portion of the time string, range 0 to 59.

Remarks

Using this constructor insures a properly formatted DICOM time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.

See Also

MCtime Class
MCtime Members
MCtime Overload


MCtime Constructor (Int32, Int32, Int32, Double)

[image]

Merge DICOM .NET/C# Toolkit
MCtime Constructor (Int32, Int32, Int32, Double)
MCtime Class See Also Send Feedback
Initializes a new instance of this class for the specified hours, minutes, seconds and fractional seconds.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime(
    int hours,
    int minutes,
    int seconds,
    double frac
)
Visual Basic
Public Sub New ( _
    hours As Integer, _
    minutes As Integer, _
    seconds As Integer, _
    frac As Double _
)
Visual C++
public:
MCtime(
    int hours,
    int minutes,
    int seconds,
    double frac
)

Parameters

hours
Type: System..::..Int32
The hours portion of the time string, range 0 to 23, where 00 means midnight
minutes
Type: System..::..Int32
The minutes portion of the time string, range 0 to 59.
seconds
Type: System..::..Int32
The seconds portion of the time string, range 0 to 59.
frac
Type: System..::..Double
The fractional seconds portion of the time string, range 0.0 to 0.999999.

Remarks

Using this constructor insures a properly formatted DICOM time string.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | An invalid argument was specified.

See Also

MCtime Class
MCtime Members
MCtime Overload


MCtime Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtime Methods
MCtime Class See Also Send Feedback

The MCtime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code representing this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Retrieves the string representation of this time string. (Overrides Object..::..ToString()()()().)

See Also

MCtime Class


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Equals Method
MCtime Class See Also Send Feedback
Determines whether the specified Object is equal to the current instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current time.

Return Value

true if the specified Object is an MCtime instance and it represents the same time as the current instance; otherwise false.

See Also

MCtime Class
MCtime Members


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..GetHashCode Method
MCtime Class See Also Send Feedback
Returns a hash code representing this instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current instance.

See Also

MCtime Class
MCtime Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..ToString Method
MCtime Class See Also Send Feedback
Retrieves the string representation of this time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String representing this time string as it was or will be sent on a DICOM stream.

See Also

MCtime Class
MCtime Members


MCtime Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtime Properties
MCtime Class See Also Send Feedback

The MCtime type exposes the following members.

Properties

 | Name | Description
Public property | Fraction | The fraction portion of the DICOM time string.
Public property | Hours | The hours portion of the DICOM time string.
Public property | Minutes | The minutes portion of the DICOM time string.
Public property | Seconds | The seconds portion of the DICOM time string.
Public property | Time | The DICOM formatted time string.

See Also

MCtime Class


Fraction Property

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Fraction Property
MCtime Class See Also Send Feedback
The fraction portion of the DICOM time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Fraction { get; }
Visual Basic
Public Overridable ReadOnly Property Fraction As String
    Get
Visual C++
public:
virtual property String^ Fraction {
    String^ get ();
}

Field Value

The 1 to 6 digit fraction number, preceded by a period.

Remarks

An empty string is returned if the time string is not at least 8 characters in length (or 10 characters if old hh:mm:ss.ff format is used).

Note: the period is returned. For example ".0234"

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The fraction number is not in the range .0-.999999. (Use ToString to retrieve the time string.)

See Also

MCtime Class
MCtime Members


Hours Property

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Hours Property
MCtime Class See Also Send Feedback
The hours portion of the DICOM time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Hours { get; }
Visual Basic
Public Overridable ReadOnly Property Hours As String
    Get
Visual C++
public:
virtual property String^ Hours {
    String^ get ();
}

Field Value

A String containing the two digit hours number or nothing (empty string) if the time string is not at least two characters.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The hours number is not in the range 00-23. (Use ToString to retrieve the time string.)

See Also

MCtime Class
MCtime Members


Minutes Property

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Minutes Property
MCtime Class See Also Send Feedback
The minutes portion of the DICOM time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Minutes { get; }
Visual Basic
Public Overridable ReadOnly Property Minutes As String
    Get
Visual C++
public:
virtual property String^ Minutes {
    String^ get ();
}

Field Value

A String containing the two digit minutes number or nothing (empty string) if the time string is not at least four characters.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The minutes number is not in the range 00-59. (Use toString to retrieve the time string.)

See Also

MCtime Class
MCtime Members


Seconds Property

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Seconds Property
MCtime Class See Also Send Feedback
The seconds portion of the DICOM time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Seconds { get; }
Visual Basic
Public Overridable ReadOnly Property Seconds As String
    Get
Visual C++
public:
virtual property String^ Seconds {
    String^ get ();
}

Field Value

A String containing the two digit seconds number or nothing (empty string) if the time string is not at least six characters.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The seconds number is not in the range 00-59. (Use toString to retrieve the time string.)

See Also

MCtime Class
MCtime Members


Time Property

[image]

Merge DICOM .NET/C# Toolkit
MCtime..::..Time Property
MCtime Class See Also Send Feedback
The DICOM formatted time string.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Time { get; }
Visual Basic
Public Overridable ReadOnly Property Time As String
    Get
Visual C++
public:
virtual property String^ Time {
    String^ get ();
}

Field Value

A String containing the DICOM formatted time.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | The time string in this object is not a valid DICOM string.

See Also

MCtime Class
MCtime Members


MCtransferSyntax Class

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax Class
Members See Also Send Feedback
Represents a DICOM Transfer Syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtransferSyntax
Visual Basic
Public Class MCtransferSyntax
Visual C++
public ref class MCtransferSyntax

Remarks

Instances of this class are created by the library for each known transfer syntax. These instances can be accessed either by static properties or by the getSyntaxByUid static method.

Each transfer syntax is identified by a unique DICOM UID. The transfer syntax also has a name by which it is widely known.

A transfer syntax defines the use of either Explicit Value Representation or Implicit Value Representation of values; and it uses either Big Endian or Little Endian encoding techniques. Also, a transfer syntax may represent a DICOM encapsulated syntax.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCtransferSyntax

See Also

MCtransferSyntax Members


MCtransferSyntax Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax Members
MCtransferSyntax Class Methods Properties See Also Send Feedback

The MCtransferSyntax type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getSyntaxByUid | Gets the MCtransferSyntax instance for the requested DICOM Transfer Syntax UID.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a text representation of this transfer syntax. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | BigEndian | Determines whether this transfer syntax uses big endian encoding.
 | DeflatedExplicitLittleEndian | The MCtransferSyntax instance representing the Deflated Explicit VR Little Endian transfer syntax.
Public property | Encapsulated | Determines whether this transfer syntax uses encapsulation.
 | EncapsulatedUncompressedELE | The MCtransferSyntax instance representing the Encapsulated Uncompressed Explicit VR Little Endian transfer syntax.
 | ExplicitBigEndian | The MCtransferSyntax instance representing the Explicit VR Big Endian transfer syntax.
 | ExplicitLittleEndian | The MCtransferSyntax instance representing the Explicit VR Little Endian transfer syntax.
Public property | ExplicitVR | Determines whether this transfer syntax uses explicit VR encoding.
 | HevcH265M10PLevel5_1 | The MCtransferSyntax instance representing the HEVC/H.265 Main 10 Profile / Level 5.1 transfer syntax
 | HevcH265MPLevel5_1 | The MCtransferSyntax instance representing the HEVC/H.265 Main Profile / Level 5.1 transfer syntax
 | ImplicitBigEndian | The MCtransferSyntax instance representing the Implicit VR Big Endian transfer syntax.
 | ImplicitLittleEndian | The default MCtransferSyntax instance representing the Implicit VR Little Endian transfer syntax.
 | Jpeg2000 | The MCtransferSyntax instance representing the JPEG 2000 transfer syntax.
 | Jpeg2000LosslessOnly | The MCtransferSyntax instance representing the JPEG 2000 (Lossless Only) transfer syntax.
 | Jpeg2000Mc | The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component Image Compression transfer syntax.
 | Jpeg2000McLosslessOnly | The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component (Lossless Only) Image Compression transfer syntax.
 | JpegBaseline | The MCtransferSyntax instance representing the JPEG Baseline (Process 1) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
 | JpegExtended2_4 | The MCtransferSyntax instance representing the JPEG Extended (Process 2 & 4) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only).
 | JpegExtended3_5 | The MCtransferSyntax instance representing the JPEG Extended (Process 3 & 5) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegExtendedHier16_18 | The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 16 & 18)transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegExtendedHier17_19 | The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 17 & 19) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgHier24_26 | The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 24 & 26) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgHier25_27 | The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 25 & 27) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgNonHier10_12 | The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 10 & 12) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgNonHier11_13 | The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 11 & 13) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslesHier29 | The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 29) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslesNonHier14 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 14) transfer syntax.
 | JpegLosslessHier14 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) transfer syntax. This is the default Transfer Syntax for Lossless JPEG Image Compression.
 | JpegLosslessHier28 | The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 28) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslessNonHier15 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 15) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLsLossless | The MCtransferSyntax instance representing the JPEG-LS Lossless Image Compression transfer syntax.
 | JpegLsLossy | The MCtransferSyntax instance representing the JPEG-LS Lossy (Near-Lossless) Image Compression transfer syntax.
 | JpegSpecHier20_22 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 20 & 22) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecHier21_23 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 21 & 23) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecNonHier6_8 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecNonHier7_9 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpipReferenced | The MCtransferSyntax instance representing the JPIP Referenced transfer syntax.
 | JpipReferencedDeflate | The MCtransferSyntax instance representing the JPIP Referenced Deflate transfer syntax.
Public property | LittleEndian | Determines whether this transfer syntax uses little endian encoding.
 | Mpeg2Mphl | The MCtransferSyntax instance representing the MPEG2 Main Profile @ High Level transfer syntax.
 | Mpeg2Mphl_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ High Level transfer syntax.
 | Mpeg2Mpml | The MCtransferSyntax instance representing the MPEG2 Main Profile @ Main Level transfer syntax.
 | Mpeg2Mpml_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ Main Level transfer syntax.
 | Mpeg4AvcH264BdcHpLevel4_1 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264BdcHpLevel4_1_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_1 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_1_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_2D | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_2D_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_3D | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_3D_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.
 | Mpeg4AvcH264StereoHpLevel4_2 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.
 | Mpeg4AvcH264StereoHpLevel4_2_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.
Public property | Name | The transfer syntax name.
 | PrivateSyntax1 | The MCtransferSyntax instance representing the Private Syntax 1 transfer syntax configured in the Mergecom.pro file.
 | PrivateSyntax2 | The MCtransferSyntax instance representing the Private Syntax 2 transfer syntax configured in the Mergecom.pro file.
 | Rle | The MCtransferSyntax instance representing the RLE (run length encoding) transfer syntax.
 | SmpteSt2110_20PcmDigitalAudio | The MCtransferSyntax instance representing the SMPTE ST 2110-30 PCM Digital Audio transfer syntax.
 | SmpteSt2110_20UncompressedInterlacedActiveVideo | The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Interlaced Active Video transfer syntax.
 | SmpteSt2110_20UncompressedProgressiveActiveVideo | The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Progressive Active Video transfer syntax.
Public property | Uid | The transfer syntax DICOM UID.

See Also

MCtransferSyntax Class


MCtransferSyntax Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax Methods
MCtransferSyntax Class See Also Send Feedback

The MCtransferSyntax type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getSyntaxByUid | Gets the MCtransferSyntax instance for the requested DICOM Transfer Syntax UID.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a text representation of this transfer syntax. (Overrides Object..::..ToString()()()().)

See Also

MCtransferSyntax Class


getSyntaxByUid Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..getSyntaxByUid Method
MCtransferSyntax Class See Also Send Feedback
Gets the MCtransferSyntax instance for the requested DICOM Transfer Syntax UID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax getSyntaxByUid(
    string uid
)
Visual Basic
Public Shared Function getSyntaxByUid ( _
    uid As String _
) As MCtransferSyntax
Visual C++
public:
static MCtransferSyntax^ getSyntaxByUid(
    String^ uid
)

Parameters

uid
Type: System..::..String
The DICOM UID of the requested instance.

Return Value

The requested MCtransferSyntax object or null if the UID does not match any known tranfer syntax.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The uid parameter was null.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ToString Method
MCtransferSyntax Class See Also Send Feedback
Gets a text representation of this transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String representing the name of this transfer syntax.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


MCtransferSyntax Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax Properties
MCtransferSyntax Class See Also Send Feedback

The MCtransferSyntax type exposes the following members.

Properties

 | Name | Description
Public property | BigEndian | Determines whether this transfer syntax uses big endian encoding.
 | DeflatedExplicitLittleEndian | The MCtransferSyntax instance representing the Deflated Explicit VR Little Endian transfer syntax.
Public property | Encapsulated | Determines whether this transfer syntax uses encapsulation.
 | EncapsulatedUncompressedELE | The MCtransferSyntax instance representing the Encapsulated Uncompressed Explicit VR Little Endian transfer syntax.
 | ExplicitBigEndian | The MCtransferSyntax instance representing the Explicit VR Big Endian transfer syntax.
 | ExplicitLittleEndian | The MCtransferSyntax instance representing the Explicit VR Little Endian transfer syntax.
Public property | ExplicitVR | Determines whether this transfer syntax uses explicit VR encoding.
 | HevcH265M10PLevel5_1 | The MCtransferSyntax instance representing the HEVC/H.265 Main 10 Profile / Level 5.1 transfer syntax
 | HevcH265MPLevel5_1 | The MCtransferSyntax instance representing the HEVC/H.265 Main Profile / Level 5.1 transfer syntax
 | ImplicitBigEndian | The MCtransferSyntax instance representing the Implicit VR Big Endian transfer syntax.
 | ImplicitLittleEndian | The default MCtransferSyntax instance representing the Implicit VR Little Endian transfer syntax.
 | Jpeg2000 | The MCtransferSyntax instance representing the JPEG 2000 transfer syntax.
 | Jpeg2000LosslessOnly | The MCtransferSyntax instance representing the JPEG 2000 (Lossless Only) transfer syntax.
 | Jpeg2000Mc | The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component Image Compression transfer syntax.
 | Jpeg2000McLosslessOnly | The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component (Lossless Only) Image Compression transfer syntax.
 | JpegBaseline | The MCtransferSyntax instance representing the JPEG Baseline (Process 1) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
 | JpegExtended2_4 | The MCtransferSyntax instance representing the JPEG Extended (Process 2 & 4) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only).
 | JpegExtended3_5 | The MCtransferSyntax instance representing the JPEG Extended (Process 3 & 5) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegExtendedHier16_18 | The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 16 & 18)transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegExtendedHier17_19 | The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 17 & 19) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgHier24_26 | The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 24 & 26) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgHier25_27 | The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 25 & 27) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgNonHier10_12 | The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 10 & 12) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegFullProgNonHier11_13 | The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 11 & 13) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslesHier29 | The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 29) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslesNonHier14 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 14) transfer syntax.
 | JpegLosslessHier14 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) transfer syntax. This is the default Transfer Syntax for Lossless JPEG Image Compression.
 | JpegLosslessHier28 | The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 28) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLosslessNonHier15 | The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 15) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegLsLossless | The MCtransferSyntax instance representing the JPEG-LS Lossless Image Compression transfer syntax.
 | JpegLsLossy | The MCtransferSyntax instance representing the JPEG-LS Lossy (Near-Lossless) Image Compression transfer syntax.
 | JpegSpecHier20_22 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 20 & 22) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecHier21_23 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 21 & 23) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecNonHier6_8 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpegSpecNonHier7_9 | The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) transfer syntax. (This transfer syntax is retired in the DICOM standard.)
 | JpipReferenced | The MCtransferSyntax instance representing the JPIP Referenced transfer syntax.
 | JpipReferencedDeflate | The MCtransferSyntax instance representing the JPIP Referenced Deflate transfer syntax.
Public property | LittleEndian | Determines whether this transfer syntax uses little endian encoding.
 | Mpeg2Mphl | The MCtransferSyntax instance representing the MPEG2 Main Profile @ High Level transfer syntax.
 | Mpeg2Mphl_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ High Level transfer syntax.
 | Mpeg2Mpml | The MCtransferSyntax instance representing the MPEG2 Main Profile @ Main Level transfer syntax.
 | Mpeg2Mpml_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ Main Level transfer syntax.
 | Mpeg4AvcH264BdcHpLevel4_1 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264BdcHpLevel4_1_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_1 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_1_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_2D | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_2D_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_3D | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.
 | Mpeg4AvcH264HpLevel4_2_3D_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.
 | Mpeg4AvcH264StereoHpLevel4_2 | The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.
 | Mpeg4AvcH264StereoHpLevel4_2_Frag | The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.
Public property | Name | The transfer syntax name.
 | PrivateSyntax1 | The MCtransferSyntax instance representing the Private Syntax 1 transfer syntax configured in the Mergecom.pro file.
 | PrivateSyntax2 | The MCtransferSyntax instance representing the Private Syntax 2 transfer syntax configured in the Mergecom.pro file.
 | Rle | The MCtransferSyntax instance representing the RLE (run length encoding) transfer syntax.
 | SmpteSt2110_20PcmDigitalAudio | The MCtransferSyntax instance representing the SMPTE ST 2110-30 PCM Digital Audio transfer syntax.
 | SmpteSt2110_20UncompressedInterlacedActiveVideo | The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Interlaced Active Video transfer syntax.
 | SmpteSt2110_20UncompressedProgressiveActiveVideo | The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Progressive Active Video transfer syntax.
Public property | Uid | The transfer syntax DICOM UID.

See Also

MCtransferSyntax Class


BigEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..BigEndian Property
MCtransferSyntax Class See Also Send Feedback
Determines whether this transfer syntax uses big endian encoding.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool BigEndian { get; }
Visual Basic
Public Overridable ReadOnly Property BigEndian As Boolean
    Get
Visual C++
public:
virtual property bool BigEndian {
    bool get ();
}

Field Value

true if this transfer syntax uses big endian encoding; otherwise false.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


DeflatedExplicitLittleEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..DeflatedExplicitLittleEndian Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Deflated Explicit VR Little Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax DeflatedExplicitLittleEndian { get; }
Visual Basic
Public Shared ReadOnly Property DeflatedExplicitLittleEndian As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ DeflatedExplicitLittleEndian {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Encapsulated Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Encapsulated Property
MCtransferSyntax Class See Also Send Feedback
Determines whether this transfer syntax uses encapsulation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool Encapsulated { get; }
Visual Basic
Public Overridable ReadOnly Property Encapsulated As Boolean
    Get
Visual C++
public:
virtual property bool Encapsulated {
    bool get ();
}

Field Value

true if this transfer syntax uses encapsulation for pixel data; otherwise false.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


EncapsulatedUncompressedELE Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..EncapsulatedUncompressedELE Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Encapsulated Uncompressed Explicit VR Little Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax EncapsulatedUncompressedELE { get; }
Visual Basic
Public Shared ReadOnly Property EncapsulatedUncompressedELE As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ EncapsulatedUncompressedELE {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ExplicitBigEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ExplicitBigEndian Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Explicit VR Big Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax ExplicitBigEndian { get; }
Visual Basic
Public Shared ReadOnly Property ExplicitBigEndian As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ ExplicitBigEndian {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ExplicitLittleEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ExplicitLittleEndian Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Explicit VR Little Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax ExplicitLittleEndian { get; }
Visual Basic
Public Shared ReadOnly Property ExplicitLittleEndian As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ ExplicitLittleEndian {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ExplicitVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ExplicitVR Property
MCtransferSyntax Class See Also Send Feedback
Determines whether this transfer syntax uses explicit VR encoding.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool ExplicitVR { get; }
Visual Basic
Public Overridable ReadOnly Property ExplicitVR As Boolean
    Get
Visual C++
public:
virtual property bool ExplicitVR {
    bool get ();
}

Field Value

true if this transfer syntax uses explicit Value Representation; otherwise false.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


HevcH265M10PLevel5_1 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..HevcH265M10PLevel5_1 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the HEVC/H.265 Main 10 Profile / Level 5.1 transfer syntax

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax HevcH265M10PLevel5_1 { get; }
Visual Basic
Public Shared ReadOnly Property HevcH265M10PLevel5_1 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ HevcH265M10PLevel5_1 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


HevcH265MPLevel5_1 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..HevcH265MPLevel5_1 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the HEVC/H.265 Main Profile / Level 5.1 transfer syntax

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax HevcH265MPLevel5_1 { get; }
Visual Basic
Public Shared ReadOnly Property HevcH265MPLevel5_1 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ HevcH265MPLevel5_1 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ImplicitBigEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ImplicitBigEndian Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Implicit VR Big Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax ImplicitBigEndian { get; }
Visual Basic
Public Shared ReadOnly Property ImplicitBigEndian As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ ImplicitBigEndian {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


ImplicitLittleEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..ImplicitLittleEndian Property
MCtransferSyntax Class See Also Send Feedback
The default MCtransferSyntax instance representing the Implicit VR Little Endian transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax ImplicitLittleEndian { get; }
Visual Basic
Public Shared ReadOnly Property ImplicitLittleEndian As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ ImplicitLittleEndian {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Jpeg2000 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Jpeg2000 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG 2000 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Jpeg2000 { get; }
Visual Basic
Public Shared ReadOnly Property Jpeg2000 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Jpeg2000 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Jpeg2000LosslessOnly Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Jpeg2000LosslessOnly Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG 2000 (Lossless Only) transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Jpeg2000LosslessOnly { get; }
Visual Basic
Public Shared ReadOnly Property Jpeg2000LosslessOnly As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Jpeg2000LosslessOnly {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Jpeg2000Mc Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Jpeg2000Mc Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component Image Compression transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Jpeg2000Mc { get; }
Visual Basic
Public Shared ReadOnly Property Jpeg2000Mc As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Jpeg2000Mc {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Jpeg2000McLosslessOnly Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Jpeg2000McLosslessOnly Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG 2000 Part 2 Multi-component (Lossless Only) Image Compression transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Jpeg2000McLosslessOnly { get; }
Visual Basic
Public Shared ReadOnly Property Jpeg2000McLosslessOnly As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Jpeg2000McLosslessOnly {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegBaseline Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegBaseline Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Baseline (Process 1) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegBaseline { get; }
Visual Basic
Public Shared ReadOnly Property JpegBaseline As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegBaseline {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegExtended2_4 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegExtended2_4 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Extended (Process 2 & 4) transfer syntax. This is the default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegExtended2_4 { get; }
Visual Basic
Public Shared ReadOnly Property JpegExtended2_4 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegExtended2_4 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegExtended3_5 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegExtended3_5 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Extended (Process 3 & 5) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegExtended3_5 { get; }
Visual Basic
Public Shared ReadOnly Property JpegExtended3_5 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegExtended3_5 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegExtendedHier16_18 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegExtendedHier16_18 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 16 & 18)transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegExtendedHier16_18 { get; }
Visual Basic
Public Shared ReadOnly Property JpegExtendedHier16_18 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegExtendedHier16_18 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegExtendedHier17_19 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegExtendedHier17_19 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Extended, Hierarchical (Process 17 & 19) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegExtendedHier17_19 { get; }
Visual Basic
Public Shared ReadOnly Property JpegExtendedHier17_19 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegExtendedHier17_19 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegFullProgHier24_26 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegFullProgHier24_26 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 24 & 26) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegFullProgHier24_26 { get; }
Visual Basic
Public Shared ReadOnly Property JpegFullProgHier24_26 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegFullProgHier24_26 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegFullProgHier25_27 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegFullProgHier25_27 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Full Progression, Hierarchical (Process 25 & 27) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegFullProgHier25_27 { get; }
Visual Basic
Public Shared ReadOnly Property JpegFullProgHier25_27 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegFullProgHier25_27 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegFullProgNonHier10_12 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegFullProgNonHier10_12 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 10 & 12) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegFullProgNonHier10_12 { get; }
Visual Basic
Public Shared ReadOnly Property JpegFullProgNonHier10_12 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegFullProgNonHier10_12 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegFullProgNonHier11_13 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegFullProgNonHier11_13 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Full Progression, Non-Hierarchical (Process 11 & 13) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegFullProgNonHier11_13 { get; }
Visual Basic
Public Shared ReadOnly Property JpegFullProgNonHier11_13 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegFullProgNonHier11_13 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLosslesHier29 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLosslesHier29 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 29) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLosslesHier29 { get; }
Visual Basic
Public Shared ReadOnly Property JpegLosslesHier29 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLosslesHier29 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLosslesNonHier14 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLosslesNonHier14 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 14) transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLosslesNonHier14 { get; }
Visual Basic
Public Shared ReadOnly Property JpegLosslesNonHier14 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLosslesNonHier14 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLosslessHier14 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLosslessHier14 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]) transfer syntax. This is the default Transfer Syntax for Lossless JPEG Image Compression.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLosslessHier14 { get; }
Visual Basic
Public Shared ReadOnly Property JpegLosslessHier14 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLosslessHier14 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLosslessHier28 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLosslessHier28 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Lossless, Hierarchical (Process 28) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLosslessHier28 { get; }
Visual Basic
Public Shared ReadOnly Property JpegLosslessHier28 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLosslessHier28 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLosslessNonHier15 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLosslessNonHier15 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Lossless, Non-Hierarchical (Process 15) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLosslessNonHier15 { get; }
Visual Basic
Public Shared ReadOnly Property JpegLosslessNonHier15 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLosslessNonHier15 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLsLossless Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLsLossless Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG-LS Lossless Image Compression transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLsLossless { get; }
Visual Basic
Public Shared ReadOnly Property JpegLsLossless As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLsLossless {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegLsLossy Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegLsLossy Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG-LS Lossy (Near-Lossless) Image Compression transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegLsLossy { get; }
Visual Basic
Public Shared ReadOnly Property JpegLsLossy As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegLsLossy {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegSpecHier20_22 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegSpecHier20_22 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 20 & 22) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegSpecHier20_22 { get; }
Visual Basic
Public Shared ReadOnly Property JpegSpecHier20_22 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegSpecHier20_22 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegSpecHier21_23 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegSpecHier21_23 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Spectral Selection, Hierarchical (Process 21 & 23) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegSpecHier21_23 { get; }
Visual Basic
Public Shared ReadOnly Property JpegSpecHier21_23 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegSpecHier21_23 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegSpecNonHier6_8 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegSpecNonHier6_8 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegSpecNonHier6_8 { get; }
Visual Basic
Public Shared ReadOnly Property JpegSpecNonHier6_8 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegSpecNonHier6_8 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpegSpecNonHier7_9 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpegSpecNonHier7_9 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) transfer syntax. (This transfer syntax is retired in the DICOM standard.)

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpegSpecNonHier7_9 { get; }
Visual Basic
Public Shared ReadOnly Property JpegSpecNonHier7_9 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpegSpecNonHier7_9 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpipReferenced Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpipReferenced Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPIP Referenced transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpipReferenced { get; }
Visual Basic
Public Shared ReadOnly Property JpipReferenced As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpipReferenced {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


JpipReferencedDeflate Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..JpipReferencedDeflate Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the JPIP Referenced Deflate transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax JpipReferencedDeflate { get; }
Visual Basic
Public Shared ReadOnly Property JpipReferencedDeflate As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ JpipReferencedDeflate {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


LittleEndian Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..LittleEndian Property
MCtransferSyntax Class See Also Send Feedback
Determines whether this transfer syntax uses little endian encoding.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool LittleEndian { get; }
Visual Basic
Public Overridable ReadOnly Property LittleEndian As Boolean
    Get
Visual C++
public:
virtual property bool LittleEndian {
    bool get ();
}

Field Value

true if this transfer syntax uses little endian encoding; otherwise false.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg2Mphl Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg2Mphl Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG2 Main Profile @ High Level transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg2Mphl { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg2Mphl As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg2Mphl {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg2Mphl_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg2Mphl_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ High Level transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg2Mphl_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg2Mphl_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg2Mphl_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg2Mpml Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg2Mpml Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG2 Main Profile @ Main Level transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg2Mpml { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg2Mpml As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg2Mpml {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg2Mpml_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg2Mpml_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG2 Main Profile @ Main Level transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg2Mpml_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg2Mpml_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg2Mpml_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264BdcHpLevel4_1 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264BdcHpLevel4_1 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264BdcHpLevel4_1 { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264BdcHpLevel4_1 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264BdcHpLevel4_1 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264BdcHpLevel4_1_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264BdcHpLevel4_1_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 BD-compatible High Profile / Level 4.1 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264BdcHpLevel4_1_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264BdcHpLevel4_1_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264BdcHpLevel4_1_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_1 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_1 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_1 { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_1 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_1 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_1_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_1_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.1 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_1_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_1_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_1_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_2_2D Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_2_2D Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_2_2D { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_2_2D As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_2_2D {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_2_2D_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_2_2D_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 2D Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_2_2D_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_2_2D_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_2_2D_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_2_3D Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_2_3D Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_2_3D { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_2_3D As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_2_3D {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264HpLevel4_2_3D_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264HpLevel4_2_3D_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 High Profile / Level 4.2 For 3D Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264HpLevel4_2_3D_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264HpLevel4_2_3D_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264HpLevel4_2_3D_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264StereoHpLevel4_2 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264StereoHpLevel4_2 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264StereoHpLevel4_2 { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264StereoHpLevel4_2 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264StereoHpLevel4_2 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Mpeg4AvcH264StereoHpLevel4_2_Frag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Mpeg4AvcH264StereoHpLevel4_2_Frag Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Fragmentable MPEG-4 AVC/H.264 Stereo High Profile / Level 4.2 transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Mpeg4AvcH264StereoHpLevel4_2_Frag { get; }
Visual Basic
Public Shared ReadOnly Property Mpeg4AvcH264StereoHpLevel4_2_Frag As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Mpeg4AvcH264StereoHpLevel4_2_Frag {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Name Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Name Property
MCtransferSyntax Class See Also Send Feedback
The transfer syntax name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

A String representing the name of this transfer syntax.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


PrivateSyntax1 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..PrivateSyntax1 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Private Syntax 1 transfer syntax configured in the Mergecom.pro file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax PrivateSyntax1 { get; }
Visual Basic
Public Shared ReadOnly Property PrivateSyntax1 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ PrivateSyntax1 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


PrivateSyntax2 Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..PrivateSyntax2 Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the Private Syntax 2 transfer syntax configured in the Mergecom.pro file.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax PrivateSyntax2 { get; }
Visual Basic
Public Shared ReadOnly Property PrivateSyntax2 As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ PrivateSyntax2 {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Rle Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Rle Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the RLE (run length encoding) transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax Rle { get; }
Visual Basic
Public Shared ReadOnly Property Rle As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ Rle {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


SmpteSt2110_20PcmDigitalAudio Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..SmpteSt2110_20PcmDigitalAudio Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the SMPTE ST 2110-30 PCM Digital Audio transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax SmpteSt2110_20PcmDigitalAudio { get; }
Visual Basic
Public Shared ReadOnly Property SmpteSt2110_20PcmDigitalAudio As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ SmpteSt2110_20PcmDigitalAudio {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


SmpteSt2110_20UncompressedInterlacedActiveVideo Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..SmpteSt2110_20UncompressedInterlacedActiveVideo Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Interlaced Active Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax SmpteSt2110_20UncompressedInterlacedActiveVideo { get; }
Visual Basic
Public Shared ReadOnly Property SmpteSt2110_20UncompressedInterlacedActiveVideo As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ SmpteSt2110_20UncompressedInterlacedActiveVideo {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


SmpteSt2110_20UncompressedProgressiveActiveVideo Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..SmpteSt2110_20UncompressedProgressiveActiveVideo Property
MCtransferSyntax Class See Also Send Feedback
The MCtransferSyntax instance representing the SMPTE ST 2110-20 Uncompressed Progressive Active Video transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntax SmpteSt2110_20UncompressedProgressiveActiveVideo { get; }
Visual Basic
Public Shared ReadOnly Property SmpteSt2110_20UncompressedProgressiveActiveVideo As MCtransferSyntax
    Get
Visual C++
public:
static property MCtransferSyntax^ SmpteSt2110_20UncompressedProgressiveActiveVideo {
    MCtransferSyntax^ get ();
}

See Also

MCtransferSyntax Class
MCtransferSyntax Members


Uid Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntax..::..Uid Property
MCtransferSyntax Class See Also Send Feedback
The transfer syntax DICOM UID.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Uid { get; }
Visual Basic
Public Overridable ReadOnly Property Uid As String
    Get
Visual C++
public:
virtual property String^ Uid {
    String^ get ();
}

Field Value

A String representing the DICOM UID of this transfer syntax.

See Also

MCtransferSyntax Class
MCtransferSyntax Members


MCtransferSyntaxList Class

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList Class
Members See Also Send Feedback
Represents a list of transfer syntaxes used in association negotiation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtransferSyntaxList
Visual Basic
Public Class MCtransferSyntaxList
Visual C++
public ref class MCtransferSyntaxList

Remarks

When an association is being established, the association acceptor and association requester each offer a list of contexts that the application entity is willing to support. Each context is a DICOM service and one or more transfer syntaxes that can be used. The transfer syntax list is encapsulated in objects of this class.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCtransferSyntaxList

See Also

MCtransferSyntaxList Members


MCtransferSyntaxList Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList Members
MCtransferSyntaxList Class Constructors Methods Properties See Also Send Feedback

The MCtransferSyntaxList type exposes the following members.

Constructors

 | Name | Description
Public method | MCtransferSyntaxList | Initializes a new instance of this class using a name and a list of transfer syntaxes.

Methods

 | Name | Description
Public method | contains(String) | Determines if this list contains a particular transfer syntax.
Public method | contains(MCtransferSyntax) | Determines if this list contains a particular transfer syntax.
Public method | containsUID | Determines if this list contains a particular transfer syntax.
Public method | dispose | Cleanup the resources associated with the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getObject | Gets the transfer syntax list with the specified name.
Public method | getSyntax(Int32) | Retrieves the MCtransferSyntax at a specified index.
Public method | getSyntax(String) | Retrieves a named MCtransferSyntax object from the list.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | iterator | Gets an enumerator for the transfer syntaxes in this list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toArray | Returns the transfer syntax list as an array of MCtransferSyntax objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ListName | Retrieves the name of the transfer syntax list.
Public property | Size | Returns the number of transfer syntaxes in this list.

See Also

MCtransferSyntaxList Class


MCtransferSyntaxList Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList Constructor
MCtransferSyntaxList Class See Also Send Feedback
Initializes a new instance of this class using a name and a list of transfer syntaxes.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtransferSyntaxList(
    string syntaxListName,
    MCtransferSyntax[] syntaxes
)
Visual Basic
Public Sub New ( _
    syntaxListName As String, _
    syntaxes As MCtransferSyntax() _
)
Visual C++
public:
MCtransferSyntaxList(
    String^ syntaxListName,
    array<MCtransferSyntax^>^ syntaxes
)

Parameters

syntaxListName
Type: System..::..String
A name which uniquely identifies this transfer syntax list to the Merge DICOM toolkit. It must consist of 1 to 33 characters.
syntaxes
Type: array< Mergecom..::..MCtransferSyntax >[]()[][]
A non null reference to an array of MCtransferSyntax objects.

Remarks

MCtransferSyntaxList objects are used to identify the transfer syntaxes supported for the services a DICOM association partner is willing to perform.

The object will encapsulate the specified array of MCtransferSyntax objects. An MCalreadyExistsException is thrown if an MCtransferSyntaxList object has already been created with the name syntaxListName. The syntaxListName

The array of syntaxes specified in the syntaxes parameter is copied so later it may be changed without affecting the created MCtransferSyntaxList object.

Note that transfer syntax lists may be defined in a [<syntax_list_name >] section of the app configuration file. If syntaxListName matches a <syntax_list_name> defined in the app file, an MCalreadyExistsException will be thrown. You can retrieve such a pre-defined proposed context list by using the getObject(String) method.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments had an invalid value. Check the exception message for details.
Mergecom.Exceptions..::..MCalreadyExistsException | A transfer syntax list has already been registered with this name.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


MCtransferSyntaxList Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList Methods
MCtransferSyntaxList Class See Also Send Feedback

The MCtransferSyntaxList type exposes the following members.

Methods

 | Name | Description
Public method | contains(String) | Determines if this list contains a particular transfer syntax.
Public method | contains(MCtransferSyntax) | Determines if this list contains a particular transfer syntax.
Public method | containsUID | Determines if this list contains a particular transfer syntax.
Public method | dispose | Cleanup the resources associated with the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getObject | Gets the transfer syntax list with the specified name.
Public method | getSyntax(Int32) | Retrieves the MCtransferSyntax at a specified index.
Public method | getSyntax(String) | Retrieves a named MCtransferSyntax object from the list.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | iterator | Gets an enumerator for the transfer syntaxes in this list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | toArray | Returns the transfer syntax list as an array of MCtransferSyntax objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCtransferSyntaxList Class


contains Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..contains Method
MCtransferSyntaxList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | contains(String) | Determines if this list contains a particular transfer syntax.
Public method | contains(MCtransferSyntax) | Determines if this list contains a particular transfer syntax.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


contains Method (String)

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..contains Method (String)
MCtransferSyntaxList Class See Also Send Feedback
Determines if this list contains a particular transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool contains(
    string syntaxName
)
Visual Basic
Public Overridable Function contains ( _
    syntaxName As String _
) As Boolean
Visual C++
public:
virtual bool contains(
    String^ syntaxName
)

Parameters

syntaxName
Type: System..::..String
The name of the transfer syntax to search for.

Return Value

true if this list contains the specified transfer syntax.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members
contains Overload


contains Method (MCtransferSyntax)

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..contains Method (MCtransferSyntax)
MCtransferSyntaxList Class See Also Send Feedback
Determines if this list contains a particular transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool contains(
    MCtransferSyntax syntax
)
Visual Basic
Public Overridable Function contains ( _
    syntax As MCtransferSyntax _
) As Boolean
Visual C++
public:
virtual bool contains(
    MCtransferSyntax^ syntax
)

Parameters

syntax
Type: Mergecom..::..MCtransferSyntax
The MCtransferSytnax to search for.

Return Value

true if this list contains the specified transfer syntax.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members
contains Overload


containsUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..containsUID Method
MCtransferSyntaxList Class See Also Send Feedback
Determines if this list contains a particular transfer syntax.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool containsUID(
    string syntaxUid
)
Visual Basic
Public Overridable Function containsUID ( _
    syntaxUid As String _
) As Boolean
Visual C++
public:
virtual bool containsUID(
    String^ syntaxUid
)

Parameters

syntaxUid
Type: System..::..String
The UID of the transfer syntax to search for.

Return Value

true if this list contains the specified transfer syntax.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..dispose Method
MCtransferSyntaxList Class See Also Send Feedback
Cleanup the resources associated with the object.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void dispose()
Visual Basic
Public Sub dispose
Visual C++
public:
void dispose()

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


getObject Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..getObject Method
MCtransferSyntaxList Class See Also Send Feedback
Gets the transfer syntax list with the specified name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCtransferSyntaxList getObject(
    string syntaxListName
)
Visual Basic
Public Shared Function getObject ( _
    syntaxListName As String _
) As MCtransferSyntaxList
Visual C++
public:
static MCtransferSyntaxList^ getObject(
    String^ syntaxListName
)

Parameters

syntaxListName
Type: System..::..String
The name identifying the requested list.

Return Value

An MCtransferSyntaxList object, or null if there is no syntax list with the specified name.

Remarks

The returned MCtransferSyntaxList object was previously created by calling MCtransferSyntaxList constructor or it is automatically created from transfer syntax lists configured in the app configuration file.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The argument was null.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


getSyntax Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..getSyntax Method
MCtransferSyntaxList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | getSyntax(Int32) | Retrieves the MCtransferSyntax at a specified index.
Public method | getSyntax(String) | Retrieves a named MCtransferSyntax object from the list.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


getSyntax Method (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..getSyntax Method (Int32)
MCtransferSyntaxList Class See Also Send Feedback
Retrieves the MCtransferSyntax at a specified index.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax getSyntax(
    int idx
)
Visual Basic
Public Overridable Function getSyntax ( _
    idx As Integer _
) As MCtransferSyntax
Visual C++
public:
virtual MCtransferSyntax^ getSyntax(
    int idx
)

Parameters

idx
Type: System..::..Int32
The index of the transfer syntax to return.

Return Value

An MCtransferSyntax object stored at the specified index.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The specified index was out of range.
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members
getSyntax Overload


getSyntax Method (String)

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..getSyntax Method (String)
MCtransferSyntaxList Class See Also Send Feedback
Retrieves a named MCtransferSyntax object from the list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax getSyntax(
    string syntaxNameOrUid
)
Visual Basic
Public Overridable Function getSyntax ( _
    syntaxNameOrUid As String _
) As MCtransferSyntax
Visual C++
public:
virtual MCtransferSyntax^ getSyntax(
    String^ syntaxNameOrUid
)

Parameters

syntaxNameOrUid
Type: System..::..String
The name of a transfer syntax or a UID

Return Value

An MCtransferSyntax object or null if the syntax is not in the list

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members
getSyntax Overload


iterator Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..iterator Method
MCtransferSyntaxList Class See Also Send Feedback
Gets an enumerator for the transfer syntaxes in this list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual IEnumerator iterator()
Visual Basic
Public Overridable Function iterator As IEnumerator
Visual C++
public:
virtual IEnumerator^ iterator()

Return Value

A non-null enumerator.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


toArray Method

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..toArray Method
MCtransferSyntaxList Class See Also Send Feedback
Returns the transfer syntax list as an array of MCtransferSyntax objects.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtransferSyntax[] toArray()
Visual Basic
Public Overridable Function toArray As MCtransferSyntax()
Visual C++
public:
virtual array<MCtransferSyntax^>^ toArray()

Return Value

The array of MCtransferSyntax objects.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


MCtransferSyntaxList Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList Properties
MCtransferSyntaxList Class See Also Send Feedback

The MCtransferSyntaxList type exposes the following members.

Properties

 | Name | Description
Public property | ListName | Retrieves the name of the transfer syntax list.
Public property | Size | Returns the number of transfer syntaxes in this list.

See Also

MCtransferSyntaxList Class


ListName Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..ListName Property
MCtransferSyntaxList Class See Also Send Feedback
Retrieves the name of the transfer syntax list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ListName { get; }
Visual Basic
Public Overridable ReadOnly Property ListName As String
    Get
Visual C++
public:
virtual property String^ ListName {
    String^ get ();
}

Field Value

A String representing the name of this list.

Remarks

The name of a transfer syntax list is defined in the configuration files. If this list was not created from a named list in the configuration files its name will be "Unnamed_Transfer_Syntax_List".

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


Size Property

[image]

Merge DICOM .NET/C# Toolkit
MCtransferSyntaxList..::..Size Property
MCtransferSyntaxList Class See Also Send Feedback
Returns the number of transfer syntaxes in this list.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

Field Value

The number of transfer syntaxes in this list.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCdisposedException | This object has been disposed.

See Also

MCtransferSyntaxList Class
MCtransferSyntaxList Members


MCunifiedProcedureStepService Class

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Class
Members See Also Send Feedback
Represents a DICOM Unified Worklist and Procedure Step Service class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCunifiedProcedureStepService : MCdimseService
Visual Basic
Public Class MCunifiedProcedureStepService _
    Inherits MCdimseService
Visual C++
public ref class MCunifiedProcedureStepService : public MCdimseService

Remarks

This class provides methods to support the following standard SOP Classes:
  • UPS Push SOP Class
  • UPS Watch SOP Class
  • UPS Pull SOP Class
  • UPS Event SOP Class

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCunifiedProcedureStepService

See Also

MCunifiedProcedureStepService Members


MCunifiedProcedureStepService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Members
MCunifiedProcedureStepService Class Constructors Methods Fields Properties See Also Send Feedback

The MCunifiedProcedureStepService type exposes the following members.

Constructors

 | Name | Description
Public method | MCunifiedProcedureStepService | Initializes a new instance of this class for the specified association.

Methods

 | Name | Description
Public method | changeUPSState | Sends a Change UPS State N-ACTION request message to an SCP.
Public method | createUPS | Sends a UPS N-CREATE request to an SCP.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | getUPS | Sends a UPS N-GET request to an SCP.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | requestUPSCancel | Sends a UPS Cancel N-ACTION request to an SCP.
Public method | searchForUPS(MCdataSet) | Sends a UPS C-FIND message to an SCP.
Public method | searchForUPS(MCdataSet, UInt16, Boolean) | Sends a UPS C-FIND message to an SCP.
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendUPSChangeReport | Sends a UPS N-EVENT-REPORT message to an SCP.
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | setUPS | Sends a UPS N-SET request to an SCP.
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean, MCdataSet) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | suspendGlobalSubscriptionOnUPSEvents | Sends a UPS Suspend Global Subscription to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | unsubscribeFromReceivingUPSEvents | Sends a UPS Unsubscribe to Receive UPS Event Reports N-ACTION request to an SCP.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)
 | UPS_FILTERED_SOP_INSTANCE_UID | UPS Filtered Global Subscription (well-known) SOP Instance.
 | UPS_SOP_INSTANCE_UID | UPS Global Subscription (well-known) SOP Instance.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)
Public property | UseTrialRetiredSOPClasses | Set this property to true in order to use the UPS 'trial retired' SOP classes (1.2.840.10008.5.1.4.34.4.x) instead of the ones officially supported by the DICOM Standard (1.2.840.10008.5.1.4.34.6.x).

See Also

MCunifiedProcedureStepService Class


MCunifiedProcedureStepService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Constructor
MCunifiedProcedureStepService Class See Also Send Feedback
Initializes a new instance of this class for the specified association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunifiedProcedureStepService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCunifiedProcedureStepService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


MCunifiedProcedureStepService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Fields
MCunifiedProcedureStepService Class See Also Send Feedback

The MCunifiedProcedureStepService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)
 | UPS_FILTERED_SOP_INSTANCE_UID | UPS Filtered Global Subscription (well-known) SOP Instance.
 | UPS_SOP_INSTANCE_UID | UPS Global Subscription (well-known) SOP Instance.

See Also

MCunifiedProcedureStepService Class


UPS_FILTERED_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..UPS_FILTERED_SOP_INSTANCE_UID Field
MCunifiedProcedureStepService Class See Also Send Feedback
UPS Filtered Global Subscription (well-known) SOP Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_FILTERED_SOP_INSTANCE_UID
Visual Basic
Public Shared ReadOnly UPS_FILTERED_SOP_INSTANCE_UID As String
Visual C++
public:
static initonly String^ UPS_FILTERED_SOP_INSTANCE_UID

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


UPS_SOP_INSTANCE_UID Field

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..UPS_SOP_INSTANCE_UID Field
MCunifiedProcedureStepService Class See Also Send Feedback
UPS Global Subscription (well-known) SOP Instance.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly string UPS_SOP_INSTANCE_UID
Visual Basic
Public Shared ReadOnly UPS_SOP_INSTANCE_UID As String
Visual C++
public:
static initonly String^ UPS_SOP_INSTANCE_UID

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


MCunifiedProcedureStepService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Methods
MCunifiedProcedureStepService Class See Also Send Feedback

The MCunifiedProcedureStepService type exposes the following members.

Methods

 | Name | Description
Public method | changeUPSState | Sends a Change UPS State N-ACTION request message to an SCP.
Public method | createUPS | Sends a UPS N-CREATE request to an SCP.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | getUPS | Sends a UPS N-GET request to an SCP.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | requestUPSCancel | Sends a UPS Cancel N-ACTION request to an SCP.
Public method | searchForUPS(MCdataSet) | Sends a UPS C-FIND message to an SCP.
Public method | searchForUPS(MCdataSet, UInt16, Boolean) | Sends a UPS C-FIND message to an SCP.
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendUPSChangeReport | Sends a UPS N-EVENT-REPORT message to an SCP.
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | setUPS | Sends a UPS N-SET request to an SCP.
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean, MCdataSet) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | suspendGlobalSubscriptionOnUPSEvents | Sends a UPS Suspend Global Subscription to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | unsubscribeFromReceivingUPSEvents | Sends a UPS Unsubscribe to Receive UPS Event Reports N-ACTION request to an SCP.

See Also

MCunifiedProcedureStepService Class


changeUPSState Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..changeUPSState Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a Change UPS State N-ACTION request message to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage changeUPSState(
    string upsInstanceUID,
    string upsState,
    string transactionUID
)
Visual Basic
Public Function changeUPSState ( _
    upsInstanceUID As String, _
    upsState As String, _
    transactionUID As String _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ changeUPSState(
    String^ upsInstanceUID,
    String^ upsState,
    String^ transactionUID
)

Parameters

upsInstanceUID
Type: System..::..String
The SOP Instance UID of the UPS to change the state on.
upsState
Type: System..::..String
The new state of the UPS. (0074,1000)
transactionUID
Type: System..::..String
The transaction UID if required, otherwise null. (0008,1195).

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCillegalArgumentException | One of the arguments was invalid.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


createUPS Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..createUPS Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS N-CREATE request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage createUPS(
    string upsInstanceUID,
    MCdataSet attributeList
)
Visual Basic
Public Function createUPS ( _
    upsInstanceUID As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ createUPS(
    String^ upsInstanceUID,
    MCdataSet^ attributeList
)

Parameters

upsInstanceUID
Type: System..::..String
The UPS instance UID to create. This parameter can be null.
attributeList
Type: Mergecom..::..MCdataSet
The list of attributes for the new UPS.

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The attribute list parameter is null.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


getUPS Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..getUPS Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS N-GET request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage getUPS(
    string upsInstanceUID,
    MCdataSet attributeList,
    bool useUPSWatchSOPClass
)
Visual Basic
Public Function getUPS ( _
    upsInstanceUID As String, _
    attributeList As MCdataSet, _
    useUPSWatchSOPClass As Boolean _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ getUPS(
    String^ upsInstanceUID,
    MCdataSet^ attributeList,
    bool useUPSWatchSOPClass
)

Parameters

upsInstanceUID
Type: System..::..String
The UPS instance UID.
attributeList
Type: Mergecom..::..MCdataSet
The set of attributes to get.
useUPSWatchSOPClass
Type: System..::..Boolean
If true the N-GET request will be done on the UPS WATCH SOP class, otherwise the UPS PULL SOP class is used.

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters is null.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


requestUPSCancel Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..requestUPSCancel Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS Cancel N-ACTION request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage requestUPSCancel(
    string upsInstanceUID,
    string reason,
    string contactURI,
    string contactDisplayName,
    MCcodeItem[] reasonCodeItems,
    bool useUPSWatchSOPClass
)
Visual Basic
Public Function requestUPSCancel ( _
    upsInstanceUID As String, _
    reason As String, _
    contactURI As String, _
    contactDisplayName As String, _
    reasonCodeItems As MCcodeItem(), _
    useUPSWatchSOPClass As Boolean _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ requestUPSCancel(
    String^ upsInstanceUID,
    String^ reason,
    String^ contactURI,
    String^ contactDisplayName,
    array<MCcodeItem^>^ reasonCodeItems,
    bool useUPSWatchSOPClass
)

Parameters

upsInstanceUID
Type: System..::..String
The SOP Instance UID of the UPS to cancel.
reason
Type: System..::..String
The reason for cancellation. (0074,1238)
contactURI
Type: System..::..String
Contact URI for the person with whom the cancel request may be discussed. (0074,100a)
contactDisplayName
Type: System..::..String
The Contact Display Name for the person with whom the cancel request may be discussed. (0074,100c)
reasonCodeItems
Type: array< Mergecom.Gen..::..MCcodeItem >[]()[][]
Unified Procedure Step Discontinuation Reason Code Sequence items. (0074,100e)
useUPSWatchSOPClass
Type: System..::..Boolean
If true the N-ACTION request will be done on the UPS WATCH SOP class, otherwise the UPS PUSH SOP class is used.

Return Value

The MCdimseMessage object that was used to send the request.

Remarks

All arguments except the sopInstanceUID are optional and can be null.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The UPS instance UID is null.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


searchForUPS Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..searchForUPS Method
MCunifiedProcedureStepService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | searchForUPS(MCdataSet) | Sends a UPS C-FIND message to an SCP.
Public method | searchForUPS(MCdataSet, UInt16, Boolean) | Sends a UPS C-FIND message to an SCP.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


searchForUPS Method (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..searchForUPS Method (MCdataSet)
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS C-FIND message to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage searchForUPS(
    MCdataSet identifier
)
Visual Basic
Public Function searchForUPS ( _
    identifier As MCdataSet _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ searchForUPS(
    MCdataSet^ identifier
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.

Return Value

The MCdimseMessage object that was used to send the request.

Remarks

The C-FIND message is sent using medium priority (MCdimseService.MEDIUM_PRIORITY_MESSAGE) using the UPS PULL SOP Class.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The identifier parameters is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members
searchForUPS Overload


searchForUPS Method (MCdataSet, UInt16, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..searchForUPS Method (MCdataSet, UInt16, Boolean)
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS C-FIND message to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage searchForUPS(
    MCdataSet identifier,
    ushort priority,
    bool useUPSWatchSOPClass
)
Visual Basic
Public Function searchForUPS ( _
    identifier As MCdataSet, _
    priority As UShort, _
    useUPSWatchSOPClass As Boolean _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ searchForUPS(
    MCdataSet^ identifier,
    unsigned short priority,
    bool useUPSWatchSOPClass
)

Parameters

identifier
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the query.
priority
Type: System..::..UInt16
The message priority. One of MCdimseService.MEDIUM_PRIORITY_MESSAGE, MCdimseService.LOW_PRIORITY_MESSAGE or MCdimseService.HIGH_PRIORITY_MESSAGE
useUPSWatchSOPClass
Type: System..::..Boolean
If true the C-FIND request will be sent using the UPS WATCH SOP class, otherwise the UPS PULL SOP class is used.

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members
searchForUPS Overload


sendUPSChangeReport Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..sendUPSChangeReport Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS N-EVENT-REPORT message to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage sendUPSChangeReport(
    string upsInstanceUID,
    ushort eventTypeID,
    MCdataSet eventData
)
Visual Basic
Public Function sendUPSChangeReport ( _
    upsInstanceUID As String, _
    eventTypeID As UShort, _
    eventData As MCdataSet _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ sendUPSChangeReport(
    String^ upsInstanceUID,
    unsigned short eventTypeID,
    MCdataSet^ eventData
)

Parameters

upsInstanceUID
Type: System..::..String
The UPS instance to report on.
eventTypeID
Type: System..::..UInt16
The event type ID. It must be 1, 2, 3, or 4.
eventData
Type: Mergecom..::..MCdataSet
The MCdataSet object containing the event data.

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


setUPS Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..setUPS Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS N-SET request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage setUPS(
    string upsInstanceUID,
    MCdataSet attributeList
)
Visual Basic
Public Function setUPS ( _
    upsInstanceUID As String, _
    attributeList As MCdataSet _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ setUPS(
    String^ upsInstanceUID,
    MCdataSet^ attributeList
)

Parameters

upsInstanceUID
Type: System..::..String
The UPS instance UID.
attributeList
Type: Mergecom..::..MCdataSet
The set of attributes and values to change.

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | One of the parameters is null.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


subscribeToReceiveUPSEventReports Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..subscribeToReceiveUPSEventReports Method
MCunifiedProcedureStepService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.
Public method | subscribeToReceiveUPSEventReports(String, String, Boolean, MCdataSet) | Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


subscribeToReceiveUPSEventReports Method (String, String, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..subscribeToReceiveUPSEventReports Method (String, String, Boolean)
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage subscribeToReceiveUPSEventReports(
    string upsInstanceUID,
    string receivingAE,
    bool deletionLock
)
Visual Basic
Public Function subscribeToReceiveUPSEventReports ( _
    upsInstanceUID As String, _
    receivingAE As String, _
    deletionLock As Boolean _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ subscribeToReceiveUPSEventReports(
    String^ upsInstanceUID,
    String^ receivingAE,
    bool deletionLock
)

Parameters

upsInstanceUID
Type: System..::..String
The SOP Instance UID of the UPS for which event notifications are requested. If this parameter is null the toolkit will use the Well-known SOP Instance UID of the UPS (1.2.840.10008.5.1.4.34.5) to request a global subscription.
receivingAE
Type: System..::..String
The AE title of the application to receive notifications. (0074,1234)
deletionLock
Type: System..::..Boolean
Specifies whether to request a deletion lock on the UPS. (0074,1230)

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The Receiving AE title argument is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members
subscribeToReceiveUPSEventReports Overload


subscribeToReceiveUPSEventReports Method (String, String, Boolean, MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..subscribeToReceiveUPSEventReports Method (String, String, Boolean, MCdataSet)
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS Subscribe to Receive UPS Event Reports N-ACTION request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage subscribeToReceiveUPSEventReports(
    string upsInstanceUID,
    string receivingAE,
    bool deletionLock,
    MCdataSet matchingKeys
)
Visual Basic
Public Function subscribeToReceiveUPSEventReports ( _
    upsInstanceUID As String, _
    receivingAE As String, _
    deletionLock As Boolean, _
    matchingKeys As MCdataSet _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ subscribeToReceiveUPSEventReports(
    String^ upsInstanceUID,
    String^ receivingAE,
    bool deletionLock,
    MCdataSet^ matchingKeys
)

Parameters

upsInstanceUID
Type: System..::..String
The SOP Instance UID of the UPS for which event notifications are requested. If this parameter is null the toolkit will use the Well-known SOP Instance UID of the UPS (1.2.840.10008.5.1.4.34.5) to request a global subscription.
receivingAE
Type: System..::..String
The AE title of the application to receive notifications. (0074,1234)
deletionLock
Type: System..::..Boolean
Specifies whether to request a deletion lock on the UPS. (0074,1230)
matchingKeys
Type: Mergecom..::..MCdataSet
Set of Matching Keys and values to a filtered subset of current and subsequently created UPS instances

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The Receiving AE title argument is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members
subscribeToReceiveUPSEventReports Overload


suspendGlobalSubscriptionOnUPSEvents Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..suspendGlobalSubscriptionOnUPSEvents Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS Suspend Global Subscription to Receive UPS Event Reports N-ACTION request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage suspendGlobalSubscriptionOnUPSEvents(
    string receivingAE
)
Visual Basic
Public Function suspendGlobalSubscriptionOnUPSEvents ( _
    receivingAE As String _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ suspendGlobalSubscriptionOnUPSEvents(
    String^ receivingAE
)

Parameters

receivingAE
Type: System..::..String
The AE title of the application receiving notifications. (0074,1234)

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The Receiving AE title argument is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


unsubscribeFromReceivingUPSEvents Method

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..unsubscribeFromReceivingUPSEvents Method
MCunifiedProcedureStepService Class See Also Send Feedback
Sends a UPS Unsubscribe to Receive UPS Event Reports N-ACTION request to an SCP.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdimseMessage unsubscribeFromReceivingUPSEvents(
    string upsInstanceUID,
    string receivingAE
)
Visual Basic
Public Function unsubscribeFromReceivingUPSEvents ( _
    upsInstanceUID As String, _
    receivingAE As String _
) As MCdimseMessage
Visual C++
public:
MCdimseMessage^ unsubscribeFromReceivingUPSEvents(
    String^ upsInstanceUID,
    String^ receivingAE
)

Parameters

upsInstanceUID
Type: System..::..String
The SOP Instance UID of the UPS or null for global unsubscription.
receivingAE
Type: System..::..String
The AE title of the application receiving notifications. (0074,1234)

Return Value

The MCdimseMessage object that was used to send the request.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The Receiving AE title argument is invalid.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


MCunifiedProcedureStepService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService Properties
MCunifiedProcedureStepService Class See Also Send Feedback

The MCunifiedProcedureStepService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)
Public property | UseTrialRetiredSOPClasses | Set this property to true in order to use the UPS 'trial retired' SOP classes (1.2.840.10008.5.1.4.34.4.x) instead of the ones officially supported by the DICOM Standard (1.2.840.10008.5.1.4.34.6.x).

See Also

MCunifiedProcedureStepService Class


UseTrialRetiredSOPClasses Property

[image]

Merge DICOM .NET/C# Toolkit
MCunifiedProcedureStepService..::..UseTrialRetiredSOPClasses Property
MCunifiedProcedureStepService Class See Also Send Feedback
Set this property to true in order to use the UPS 'trial retired' SOP classes (1.2.840.10008.5.1.4.34.4.x) instead of the ones officially supported by the DICOM Standard (1.2.840.10008.5.1.4.34.6.x).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public bool UseTrialRetiredSOPClasses { get; set; }
Visual Basic
Public Property UseTrialRetiredSOPClasses As Boolean
    Get
    Set
Visual C++
public:
property bool UseTrialRetiredSOPClasses {
    bool get ();
    void set (bool value);
}

Remarks

Default value = false

See Also

MCunifiedProcedureStepService Class
MCunifiedProcedureStepService Members


MCuserIdentity Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCuserIdentity Enumeration
See Also Send Feedback
The User Identity used to notify the association acceptor of the user identity of the association requestor.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCuserIdentity
Visual Basic
Public Enumeration MCuserIdentity
Visual C++
public enum class MCuserIdentity

Members

Member name | Value | Description
NO_USER_IDENTITY | 0 | Undefined User Identity.
USERNAME | 1 | Username as a string in UTF-8.
USERNAME_AND_PASSCODE | 2 | Username as a string in UTF-8 and passcode.
KERBEROS_SERVICE_TICKET | 3 | Kerberos Service ticket.
SAML_ASSERTION | 4 | SAML Assertion.
JSON_WEB_TOKEN | 5 | JSON Web Token (JWT).

See Also


MCvalidationError Class

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError Class
Members See Also Send Feedback
Represents a dataset validation error.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCvalidationError
Visual Basic
Public Class MCvalidationError
Visual C++
public ref class MCvalidationError

Remarks

Validation error objects are created by the library whenever a validation method returns false. The following calls can result in validation errors:
  • MCabstractMessage.validate()
  • MCabstractMessage.validateAttribute()
  • MCdataSet.validate()
  • MCdataSet.validateAttribute()

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCvalidationError

See Also

MCvalidationError Members


MCvalidationError Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvalidationError Members
MCvalidationError Class Methods Fields See Also Send Feedback

The MCvalidationError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a multi-line string describing the validation error. (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | AttributeSet | The MCattributeSet object that contained the invalid attribute value.
Public field | ErrorDescription | Description of the validation error encountered.
Public field | ErrorNumber | The error code.
Public field | Tag | The MCtag object that identifies the invalid attribute.
Public field | ValueNumber | Indicates which of the attribute's values was involved with the validation error.

See Also

MCvalidationError Class


MCvalidationError Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvalidationError Fields
MCvalidationError Class See Also Send Feedback

The MCvalidationError type exposes the following members.

Fields

 | Name | Description
Public field | AttributeSet | The MCattributeSet object that contained the invalid attribute value.
Public field | ErrorDescription | Description of the validation error encountered.
Public field | ErrorNumber | The error code.
Public field | Tag | The MCtag object that identifies the invalid attribute.
Public field | ValueNumber | Indicates which of the attribute's values was involved with the validation error.

See Also

MCvalidationError Class


AttributeSet Field

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..AttributeSet Field
MCvalidationError Class See Also Send Feedback
The MCattributeSet object that contained the invalid attribute value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly MCattributeSet AttributeSet
Visual Basic
Public ReadOnly AttributeSet As MCattributeSet
Visual C++
public:
initonly MCattributeSet^ AttributeSet

See Also

MCvalidationError Class
MCvalidationError Members


ErrorDescription Field

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..ErrorDescription Field
MCvalidationError Class See Also Send Feedback
Description of the validation error encountered.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string ErrorDescription
Visual Basic
Public ReadOnly ErrorDescription As String
Visual C++
public:
initonly String^ ErrorDescription

See Also

MCvalidationError Class
MCvalidationError Members


ErrorNumber Field

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..ErrorNumber Field
MCvalidationError Class See Also Send Feedback
The error code.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly int ErrorNumber
Visual Basic
Public ReadOnly ErrorNumber As Integer
Visual C++
public:
initonly int ErrorNumber

Remarks

The value of this field represents the validation violation and it can have one of the following values:

Information statuses:

  • MCexception.NO_CONDITION_FUNCTION: The attribute's DICOM type is "1C" or "2C" and no function was available to check the condition. A user-defined condition function was not correctly linked with the program.
  • MCexception.UNABLE_TO_CHECK_CONDITION: Not enough information is available to check whether or not a DICOM type "1C" or "2C" attribute is required.

Warnings:

  • MCexception.NOT_ONE_OF_DEFINED_TERMS: A value setfor this attribute is not one of the valid defined terms assigned to this attribute.
  • MCexception.NON_SERVICE_ATTRIBUTE: The attribute is not one of those defined for the message's service. Note that private attributes will not cause this violation

Errors:

  • MCexception.INVALID_VR_CODE: The attribute's value representation is unknown.
  • MCexception.REQUIRED_ATTRIBUTE_MISSING: An attribute which is required for the message service has been deleted from the message object.
  • MCexception.REQUIRED_VALUE_MISSING: The attribute is required to have a value but it is empty.
  • MCexception.VALUE_MAY_NOT_BE_NULL: The attribute is DICOM type "1" or type "1C" and it has been encoded with a NULL value.
  • MCexception.VALUE_NOT_ALLOWED: This DICOM type "1C" or type "2C" attribute may not have a value under current conditions.
  • MCexception.TOO_FEW_VALUES: The attribute is required to have more values set.
  • MCexception.TOO_MANY_VALUES: The attribute has more values set than are allowed.
  • MCexception.INVALID_ITEM_ID: This sequence of items (SQ) attribute has an invalid value assigned to it.
  • MCexception.NOT_ONE_OF_ENUMERATED_VALUES: A value set for this attribute is not one of the valid enumerated values assigned to this attribute.
  • MCexception.INVALID_VALUE_FOR_VR: A value for this attribute does not conform to the requirements of its value representation.
  • MCexception.INVALID_CHARS_IN_VALUE: A value for this attribute does not contain valid characters for its value representation.

See Also

MCvalidationError Class
MCvalidationError Members


Tag Field

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..Tag Field
MCvalidationError Class See Also Send Feedback
The MCtag object that identifies the invalid attribute.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly uint Tag
Visual Basic
Public ReadOnly Tag As UInteger
Visual C++
public:
initonly unsigned int Tag

See Also

MCvalidationError Class
MCvalidationError Members


ValueNumber Field

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..ValueNumber Field
MCvalidationError Class See Also Send Feedback
Indicates which of the attribute's values was involved with the validation error.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly int ValueNumber
Visual Basic
Public ReadOnly ValueNumber As Integer
Visual C++
public:
initonly int ValueNumber

Remarks

A value of 1 means the first value is invalid, 2 means the second value and so on. Zero means the validation error was not caused by the value of the attribute.

See Also

MCvalidationError Class
MCvalidationError Members


MCvalidationError Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvalidationError Methods
MCvalidationError Class See Also Send Feedback

The MCvalidationError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a multi-line string describing the validation error. (Overrides Object..::..ToString()()()().)

See Also

MCvalidationError Class


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationError..::..ToString Method
MCvalidationError Class See Also Send Feedback
Returns a multi-line string describing the validation error.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string object describing the validation error.

See Also

MCvalidationError Class
MCvalidationError Members


MCvalidationLevel Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCvalidationLevel Enumeration
See Also Send Feedback
Defines levels at which attribute sets can be validated.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCvalidationLevel
Visual Basic
Public Enumeration MCvalidationLevel
Visual C++
public enum class MCvalidationLevel

Members

Member name | Value | Description
Errors_Only | 1 | Only Errors will cause validation failure.
Errors_And_Warnings | 2 | Errors and Warnings will cause validation failure.
Full | 3 | Errors, Warnings and Info messages will cause validation failure.

See Also


MCverificationService Class

[image]

Merge DICOM .NET/C# Toolkit
MCverificationService Class
Members See Also Send Feedback
Represents the DICOM Verification Service Class and it provides methods to support the Verification SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCverificationService : MCdimseService
Visual Basic
Public Class MCverificationService _
    Inherits MCdimseService
Visual C++
public ref class MCverificationService : public MCdimseService

Remarks

This class provides methods to send request and response messages, enforcing the requirements of this service class. In general it relieves the user of the responsibility to update command set attributes.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCdimseService
Mergecom..::..MCverificationService

See Also

MCverificationService Members


MCverificationService Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCverificationService Members
MCverificationService Class Constructors Methods Fields Properties See Also Send Feedback

The MCverificationService type exposes the following members.

Constructors

 | Name | Description
Public method | MCverificationService | Initializes a new instance of this class for the specified DICOM association.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendEchoRequest()()()() | Sends a normal C-ECHO request.
Public method | sendEchoRequest(String) | Sends a C-ECHO request using the specified SOP Class.
Public method | sendEchoResponse | Sends an C-ECHO response message to reply to a received request.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCverificationService Class


MCverificationService Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCverificationService Constructor
MCverificationService Class See Also Send Feedback
Initializes a new instance of this class for the specified DICOM association.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCverificationService(
    MCassociation association
)
Visual Basic
Public Sub New ( _
    association As MCassociation _
)
Visual C++
public:
MCverificationService(
    MCassociation^ association
)

Parameters

association
Type: Mergecom..::..MCassociation
A non-null MCassociation reference.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The association argument was null.

See Also

MCverificationService Class
MCverificationService Members


MCverificationService Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCverificationService Fields
MCverificationService Class See Also Send Feedback

The MCverificationService type exposes the following members.

Fields

 | Name | Description
Protected field | assoc | The DICOM association this DIMSE class is servicing. Constructors for all sub-classes must set this protected field to the appropriate MCassociation object. (Inherited from MCdimseService.)

See Also

MCverificationService Class


MCverificationService Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCverificationService Methods
MCverificationService Class See Also Send Feedback

The MCverificationService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | sendAlreadyInProgressResponse | Sends a Response message with a status of 0xA503. (Inherited from MCdimseService.)
Public method | sendAttributeListErrorResponse | Sends a Response message with a status of 0x0107. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCancelledResponse(MCdimseMessage, MCdataSet, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFE00. (Inherited from MCdimseService.)
Public method | sendCannotUnderstandResponse | Sends a Response message with a status of 0xC000. (Inherited from MCdimseService.)
Public method | sendClassInstanceConflictResponse | Sends a Response message with a status of 0x0119. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(MCdimseMessage, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendDuplicateSopInstanceResponse(String, UInt16, String) | Sends a Response message with a status of 0x0111. (Inherited from MCdimseService.)
Public method | sendEchoRequest()()()() | Sends a normal C-ECHO request.
Public method | sendEchoRequest(String) | Sends a C-ECHO request using the specified SOP Class.
Public method | sendEchoResponse | Sends an C-ECHO response message to reply to a received request.
Public method | sendInvalidArgumentValueResponse | Sends a Response message with a status of 0x0115. (Inherited from MCdimseService.)
Public method | sendInvalidAttributeValueResponse | Sends a Response message with a status of 0x0106 (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetFailureResponse(MCdimseMessage, MCdataSet, array<UInt32>[]()[][], String) | Sends a Response message with a status of 0xA900. (Inherited from MCdimseService.)
Public method | sendInvalidDatasetWarningResponse | Sends a Response message with a status of 0xB007. (Inherited from MCdimseService.)
Public method | sendInvalidSopInstanceResponse | Sends a Response message with a status of 0x0117. (Inherited from MCdimseService.)
Public method | sendMayNoLongerBeUpdatedResponse | Sends a Response message with a status of 0xA501. (Inherited from MCdimseService.)
Public method | sendMissingAttributeResponse | Sends a Response message with a status of 0x0120. (Inherited from MCdimseService.)
Public method | sendMissingAttributeValueResponse | Sends a Response message with a status of 0x0121 (Inherited from MCdimseService.)
Public method | sendMistypedArgumentResponse | Sends a Response message with a status of 0x0212. (Inherited from MCdimseService.)
Public method | sendNoSuchActionTypeResponse | Sends a Response message with a status of 0x0123. (Inherited from MCdimseService.)
Public method | sendNoSuchArgumentResponse | Sends a Response message with a status of 0x0114. (Inherited from MCdimseService.)
Public method | sendNoSuchAttributeResponse | Sends a Response message with a status of 0x0105. (Inherited from MCdimseService.)
Public method | sendNoSuchEventTypeResponse | Sends a Response message with a status of 0x0113. (Inherited from MCdimseService.)
Public method | sendNoSuchSopInstanceResponse | Sends a Response message with a status of 0x0112. (Inherited from MCdimseService.)
Public method | sendOptionalAttributesUnsupportedResponse | Sends a Response message with a status of 0x0001. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponse(MCdimseMessage, UInt16, UInt16, UInt16, UInt16) | Sends a Response message with a status of 0xFF00. (Inherited from MCdimseService.)
Public method | sendPendingResponseWithOptionalKeyWarning | Sends a Response message with a status of 0xFF01. (Inherited from MCdimseService.)
Public method | sendPPSnotInProgressResponse | Sends a Response message with a status of 0xA506. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(String, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendProcessingFailureResponse(MCdimseMessage, UInt16, array<UInt32>[]()[][], String, MCinstanceUid) | Sends a Response message with a status of 0x0110. (Inherited from MCdimseService.)
Public method | sendRefusedOutOfResourcesResponse | Sends a Response message with a status of 0xA700. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdataSource, String) | Sends a DIMSE request message to the association partner, providing the stream for message data to send (Inherited from MCdimseService.)
Public method | sendRequestMessage(String, MCdimseMessage, String) | Sends a DIMSE request message to the association partner. (Inherited from MCdimseService.)
Public method | sendResourceLimitationResponse | Sends a Response message with a status of 0x0213. (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(String, UInt16, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendResponseMessage(UInt16, MCdataSource, String) | Allows the caller to respond to a message received from the remote application, providing the stream for the message data to send (Inherited from MCdimseService.)
Public method | sendResponseMessage(MCdimseMessage, MCdimseMessage, UInt16) | Allows the caller to respond to a message received from the remote application. (Inherited from MCdimseService.)
Public method | sendSPSnotInProgressResponse | Sends a Response message with a status of 0xA504. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(MCdimseMessage, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendSuccessResponse(String, UInt16, MCdataSet) | Sends a Response message with a status of 0x0000. (Inherited from MCdimseService.)
Public method | sendUnmatchedTransactionUidResponse | Sends a Response message with a status of 0xA505. (Inherited from MCdimseService.)
Public method | sendUnrecognizedOperationResponse | Sends a Response message with a status of 0x0211. (Inherited from MCdimseService.)
Public method | sendWrongTransactionIdResponse | Sends a Response message with a status of 0xA502. (Inherited from MCdimseService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCverificationService Class


sendEchoRequest Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCverificationService..::..sendEchoRequest Method
MCverificationService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | sendEchoRequest()()()() | Sends a normal C-ECHO request.
Public method | sendEchoRequest(String) | Sends a C-ECHO request using the specified SOP Class.

See Also

MCverificationService Class
MCverificationService Members


sendEchoRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCverificationService..::..sendEchoRequest Method
MCverificationService Class See Also Send Feedback
Sends a normal C-ECHO request.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendEchoRequest()
Visual Basic
Public Overridable Sub sendEchoRequest
Visual C++
public:
virtual void sendEchoRequest()

Remarks

An MCdimseMessage is created and sent to the network partner. The affected SOP Class UID defaults to "1.2.840.10008.1.1"

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.

See Also

MCverificationService Class
MCverificationService Members
sendEchoRequest Overload


sendEchoRequest Method (String)

[image]

Merge DICOM .NET/C# Toolkit
MCverificationService..::..sendEchoRequest Method (String)
MCverificationService Class See Also Send Feedback
Sends a C-ECHO request using the specified SOP Class.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendEchoRequest(
    string affectedSopClassUID
)
Visual Basic
Public Overridable Sub sendEchoRequest ( _
    affectedSopClassUID As String _
)
Visual C++
public:
virtual void sendEchoRequest(
    String^ affectedSopClassUID
)

Parameters

affectedSopClassUID
Type: System..::..String
The affected SOP Class UID to use

Remarks

An MCdimseMessage is created and sent to the network partner.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called by an association acceptor before calling the accept method of the MCassociation object associated with this service.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with message is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCrequiredAttributeMissingException | The Affected SOP Instance UID is required by the service and was not supplied by affectedSopInstanceUID and it was not already in the message's command set.
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning | Sending this request message will cause the maximum operations negotiated to be exceeded.
Mergecom.Exceptions..::..MCruntimeException | A problem occurred while sending the message. Check the mergecom log file for further details.

See Also

MCverificationService Class
MCverificationService Members
sendEchoRequest Overload


sendEchoResponse Method

[image]

Merge DICOM .NET/C# Toolkit
MCverificationService..::..sendEchoResponse Method
MCverificationService Class See Also Send Feedback
Sends an C-ECHO response message to reply to a received request.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void sendEchoResponse(
    MCdimseMessage requestMsg
)
Visual Basic
Public Overridable Sub sendEchoResponse ( _
    requestMsg As MCdimseMessage _
)
Visual C++
public:
virtual void sendEchoResponse(
    MCdimseMessage^ requestMsg
)

Parameters

requestMsg
Type: Mergecom..::..MCdimseMessage
An MCdimseMessage encapsulating the request.

Remarks

The requestMsg parameter must be a reference to the received C-ECHO request message. The service always responds with success status.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | This method was called at an inappropriate time. This would be thrown, for example, if this method were called when there is no response message pending for requestMsg.
Mergecom.Exceptions..::..MCassociationAbortedException | The association was aborted. No further calls may be made for the association.
Mergecom.Exceptions..::..MCunacceptableServiceException | The service associated with requestMsg is not one that was negotiated for the association, or it was never set.
Mergecom.Exceptions..::..MCillegalArgumentException | The message was invalid.

See Also

MCverificationService Class
MCverificationService Members


MCverificationService Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCverificationService Properties
MCverificationService Class See Also Send Feedback

The MCverificationService type exposes the following members.

Properties

 | Name | Description
Public property | Association | Retrieves the association on which this service is running. (Inherited from MCdimseService.)

See Also

MCverificationService Class


MCvr Class

[image]

Merge DICOM .NET/C# Toolkit
MCvr Class
Members See Also Send Feedback
This class represents a DICOM Value Representation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCvr
Visual Basic
Public MustInherit Class MCvr
Visual C++
public ref class MCvr abstract

Remarks

The library creates instances of this class for every known Value Representation. These instances can be accessed through static readonly fileds.

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCvr

See Also

MCvr Members


MCvr Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr Members
MCvr Class Methods Fields Properties See Also Send Feedback

The MCvr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | fixedWidthSize | Returns the number of bytes it takes to store one fixed width value. If the Value Representation is not a fixed width binary type, zero will be returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | getVRforName | Retrieve the MCvr object associated with a DICOM defined name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of this Value Representation. (Overrides Object..::..ToString()()()().)
Public method | validateValue(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValue(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValueStrict(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValueStrict(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.

Fields

Name | Description
vrAE | DICOM Value Representation for Application Entity
vrAS | DICOM Value Representation for Age String.
vrAT | DICOM Value Representation for Attribute Tag.
vrCS | DICOM Value Representation for Code String.
vrDA | DICOM Value Representation for Date.
vrDS | DICOM Value Representation for Decimal String.
vrDT | DICOM Value Representation for Date Time.
vrFD | DICOM Value Representation for Floating Point Double.
vrFL | DICOM Value Representation for Floating Point Single.
vrIS | DICOM Value Representation for Integer String.
vrLO | DICOM Value Representation for Long String.
vrLT | DICOM Value Representation for Long Text.
vrOB | DICOM Value Representation for Other Byte.
vrOD | DICOM Value Representation for Other Double.
vrOF | DICOM Value Representation for Other Float.
vrOL | DICOM Value Representation for Other Long.
vrOV | DICOM Value Representation for Other 64-bit Very Long.
vrOW | DICOM Value Representation for Other Word.
vrPN | DICOM Value Representation for Person Name.
vrSH | DICOM Value Representation for Short String.
vrSL | DICOM Value Representation for Signed Long.
vrSQ | DICOM Value Representation for Sequence of Items.
vrSS | DICOM Value Representation for Signed Short.
vrST | DICOM Value Representation for Short Text.
vrSV | DICOM Value Representation for Signed 64-bit Very Long.
vrTM | DICOM Value Representation for Time.
vrUC | DICOM Value Representation for Unlimited Characters
vrUI | DICOM Value Representation for Unique Identifier (UID).
vrUL | DICOM Value Representation for Unsigned Long.
vrUN | DICOM Value Representation for Unknown.
vrUR | DICOM value Representation for URI/URL.
vrUS | DICOM Value Representation for Unsigned Short.
vrUT | DICOM Value Representation for Unlimited Text.
vrUV | DICOM Value Representation for Unsigned 64-bit Very Long.

Properties

 | Name | Description
Public property | AcceptableForCallback | Determines whether this Value Representation is one of those for which an attribute container may be used to process the data element's value.
Public property | BinaryVR | Determines whether this Value Representation is for a binary value.
Public property | BulkDataUriVR | Determines whether the Value Representation is for a BulkDataURI.
Public property | FloatingPointVR | Determines whether this Value Representation is for a binary floating point value.
Public property | MaxSize | Gets the maximum size of a value of this VR.
Public property | MultiByteBinaryVR | Determines whether this Value Representation is for binary value that is represented by more than one byte.
Public property | MultiValuedBinaryVR | Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements.
Public property | MultiValuedIntegerVR | Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements, and is an integer number (short or long).
Public property | MultiValuedTextVR | Determines whether this Value Representation is for a text string value that can be used for Multi-Valued Data Elements.
Public property | MultiValuedVR | Determines whether this Value Representation is for a value that can be used for Multi-Valued Data Elements only.
Public property | Name | The DICOM 2-character name by which this VR is known.
Public property | SingleValuedBinaryVR | Determines whether this Value Representation is for a binary string value that can be used for Single Valued Data Elements only.
Public property | SingleValuedTextVR | Determines whether this Value Representation is for a text string value that can be used for Single Valued Data Elements only.
Public property | SingleValuedVR | Determines whether this Value Representation is for a value that can be used for Single Valued Data Elements only.
Public property | TextVR | Determines whether the Value Representation is for a text value.
Public property | ValueType | The .NET type for values of this VR.

See Also

MCvr Class


MCvr Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr Fields
MCvr Class See Also Send Feedback

The MCvr type exposes the following members.

Fields

Name | Description
vrAE | DICOM Value Representation for Application Entity
vrAS | DICOM Value Representation for Age String.
vrAT | DICOM Value Representation for Attribute Tag.
vrCS | DICOM Value Representation for Code String.
vrDA | DICOM Value Representation for Date.
vrDS | DICOM Value Representation for Decimal String.
vrDT | DICOM Value Representation for Date Time.
vrFD | DICOM Value Representation for Floating Point Double.
vrFL | DICOM Value Representation for Floating Point Single.
vrIS | DICOM Value Representation for Integer String.
vrLO | DICOM Value Representation for Long String.
vrLT | DICOM Value Representation for Long Text.
vrOB | DICOM Value Representation for Other Byte.
vrOD | DICOM Value Representation for Other Double.
vrOF | DICOM Value Representation for Other Float.
vrOL | DICOM Value Representation for Other Long.
vrOV | DICOM Value Representation for Other 64-bit Very Long.
vrOW | DICOM Value Representation for Other Word.
vrPN | DICOM Value Representation for Person Name.
vrSH | DICOM Value Representation for Short String.
vrSL | DICOM Value Representation for Signed Long.
vrSQ | DICOM Value Representation for Sequence of Items.
vrSS | DICOM Value Representation for Signed Short.
vrST | DICOM Value Representation for Short Text.
vrSV | DICOM Value Representation for Signed 64-bit Very Long.
vrTM | DICOM Value Representation for Time.
vrUC | DICOM Value Representation for Unlimited Characters
vrUI | DICOM Value Representation for Unique Identifier (UID).
vrUL | DICOM Value Representation for Unsigned Long.
vrUN | DICOM Value Representation for Unknown.
vrUR | DICOM value Representation for URI/URL.
vrUS | DICOM Value Representation for Unsigned Short.
vrUT | DICOM Value Representation for Unlimited Text.
vrUV | DICOM Value Representation for Unsigned 64-bit Very Long.

See Also

MCvr Class


vrAE Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrAE Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Application Entity

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrAE
Visual Basic
Public Shared ReadOnly vrAE As MCvr
Visual C++
public:
static initonly MCvr^ vrAE

Remarks

Definition | A string of characters with leading and trailing spaces (20H) being non-significant. The value made of 16 spaces, meaning "no application name specified", shall not be used.
Character Repertoire | Default Character Repertoire excluding control characters LF, FF, CR and ESC.
Length of Value | 16 bytes maximum

See Also

MCvr Class
MCvr Members


vrAS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrAS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Age String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrAS
Visual Basic
Public Shared ReadOnly vrAS As MCvr
Visual C++
public:
static initonly MCvr^ vrAS

Remarks

Definition | A string of characters with one of the following formats -- nnnD, nnnW, nnnM, nnnY; where nnn shall contain the number of days for D, weeks for W, months for M, or years for Y. Example: "018M" would represent an age of 18 months.
Character Repertoire | '0'-'9', 'D', 'W', 'M', 'Y' of Default Character Repertoire
Length of Value | 4 bytes fixed

See Also

MCvr Class
MCvr Members


vrAT Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrAT Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Attribute Tag.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrAT
Visual Basic
Public Shared ReadOnly vrAT As MCvr
Visual C++
public:
static initonly MCvr^ vrAT

Remarks

Definition

Ordered pair of 16-bit unsigned integers that is the value of a Data Element Tag.

Example:

A Data Element Tag of (0018,00FF) would be encoded as a series of 4 bytes in a Little-Endian Transfer Syntax as 18H,00H,FFH,00H and in a Big-Endian Transfer Syntax as 00H,18H,00H,FFH.

Note: The encoding of an AT value is exactly the same as the encoding of a Data Element Tag. That is it consists of two 2-byte integers with the high-order value specifying the tag group and the low-order value specifying the tag element.

Character Repertoire | not applicable
Length of Value | 4 bytes fixed

See Also

MCvr Class
MCvr Members


vrCS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrCS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Code String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrCS
Visual Basic
Public Shared ReadOnly vrCS As MCvr
Visual C++
public:
static initonly MCvr^ vrCS

Remarks

Definition | A string of characters with leading or trailing spaces (20H) being non-significant.
Character Repertoire | Uppercase characters, '0'-'9', the SPACE character, and underscore '_', of the Default Character Repertoire
Length of Value | 16 bytes maximum

See Also

MCvr Class
MCvr Members


vrDA Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrDA Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Date.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrDA
Visual Basic
Public Shared ReadOnly vrDA As MCvr
Visual C++
public:
static initonly MCvr^ vrDA

Remarks

Definition

A string of characters of the format yyyymmdd; where yyyy shall contain year, mm shall contain the month, and dd shall contain the day. This conforms to the ANSI HISPP MSDS Date common data type.

Example:

"19930822" would represent August 22, 1993.

Notes:

1. For reasons of backward compatibility with versions of this standard prior to V3.0, it is recommended that implementations also support a string of characters of the format yyyy.mm.dd for this VR.

2. See also DT VR.

Character Repertoire

'0'-'9' of Default Character Repertoire

Note: For reasons specified in the previous column, implementations may wish to support the '.' character as well.

Length of Value

8 bytes fixed

Note: For reasons specified in the previous columns, implementations may also wish to support a 10 byte fixed length as well.

See Also

MCvr Class
MCvr Members


vrDS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrDS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Decimal String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrDS
Visual Basic
Public Shared ReadOnly vrDS As MCvr
Visual C++
public:
static initonly MCvr^ vrDS

Remarks

Definition | A string of characters representing either a fixed point number or a floating point number. A fixed point number shall contain only the characters '0'-'9' with an optional leading '+' or '-' and an optional '.' to mark the decimal point. A floating point number shall be conveyed as defined in ANSI X3.9, with an 'E' or 'e' to indicate the start of the exponent. Decimal Strings may be padded with leading or trailing spaces. Embedded spaces are not allowed.
Character Repertoire | '0'-'9', '+', '-', 'E', 'e', '.' of Default Character Repertoire
Length of Value | 16 bytes maximum

See Also

MCvr Class
MCvr Members


vrDT Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrDT Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Date Time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrDT
Visual Basic
Public Shared ReadOnly vrDT As MCvr
Visual C++
public:
static initonly MCvr^ vrDT

Remarks

Definition

The Date Time common data type. Indicates a concatenated date-time ASCII string in the format: YYYYMMDDHHMMSS.FFFFFFZZZZ

The components of this string, from left to right, are YYYY = Year, MM = Month, DD = Day, HH = Hour, MM = Minute, SS = Second, FFFFFF = Fractional Second, Z = '+' or '-', and ZZZ = Hours and Minutes of offset.

ZZZZ is an optional suffix for plus/minus offset from Coordinated Universal Time.

A component that is omitted from the string is termed a null component. Trailing null components of Date Time are ignored. Non-trailing null components are prohibited, given that the optional suffix is not considered as a component.

Note: For reasons of backward compatibility with versions of this standard prior to V3.0, many existing DICOM Data Elements use the separate DA and TM VRs. Standard and Private Data Elements defined in the future should use DT, when appropriate, to be more compliant with ANSI HISPP MSDS.

Character Repertoire | "0"-"9", "+", "-", "." of Default Character Repertoire
Length of Value | 26 bytes maximum

See Also

MCvr Class
MCvr Members


vrFD Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrFD Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Floating Point Double.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrFD
Visual Basic
Public Shared ReadOnly vrFD As MCvr
Visual C++
public:
static initonly MCvr^ vrFD

Remarks

Definition | Double precision binary floating point number represented in IEEE 754:1985 64-bit Floating Point Number Format.
Character Repertoire | not applicable
Length of Value | 8 bytes fixed

See Also

MCvr Class
MCvr Members


vrFL Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrFL Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Floating Point Single.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrFL
Visual Basic
Public Shared ReadOnly vrFL As MCvr
Visual C++
public:
static initonly MCvr^ vrFL

Remarks

Definition | Single precision binary floating point number represented in IEEE 754:1985 32-bit Floating Point Number Format.
Character Repertoire | not applicable
Length of Value | 4 bytes fixed

See Also

MCvr Class
MCvr Members


vrIS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrIS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Integer String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrIS
Visual Basic
Public Shared ReadOnly vrIS As MCvr
Visual C++
public:
static initonly MCvr^ vrIS

Remarks

Definition | A string of characters representing an Integer in base-10 (decimal), shall contain only the characters 0 - 9, with an optional leading "+" or "-". It may be padded with leading and/or trailing spaces. Embedded spaces are not allowed. The integer, n, represented shall be in the range: -231 <= n <= (231 - 1).
Character Repertoire | '0'-'9', '+', '-' of Default Character Repertoire
Length of Value | 12 bytes maximum

See Also

MCvr Class
MCvr Members


vrLO Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrLO Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Long String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrLO
Visual Basic
Public Shared ReadOnly vrLO As MCvr
Visual C++
public:
static initonly MCvr^ vrLO

Remarks

Definition | A character string that may be padded with leading and/or trailing spaces. The character code 5CH (the BACKSLASH '\' in ISO-IR 6) shall not be present, as it is used as the delimiter between values in multiple valued data elements. The string shall not have Control Characters except for ESC.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 64 chars maximum (Note that this is the number of characters, not the number of bytes)

See Also

MCvr Class
MCvr Members


vrLT Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrLT Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Long Text.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrLT
Visual Basic
Public Shared ReadOnly vrLT As MCvr
Visual C++
public:
static initonly MCvr^ vrLT

Remarks

Definition | A character string that may contain one or more paragraphs. It may contain the Graphic Character set and the Control Characters, CR, LF, FF, and ESC. It may be padded with trailing spaces, which may be ignored, but leading spaces are considered to be significant. Data Elements with this VR shall not be multi-valued and therefore character code 5CH (the BACKSLASH '\' in ISO-IR 6) may be used.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 10240 chars maximum (Note that this is the number of characters, not the number of bytes)

See Also

MCvr Class
MCvr Members


vrOB Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOB Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other Byte.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOB
Visual Basic
Public Shared ReadOnly vrOB As MCvr
Visual C++
public:
static initonly MCvr^ vrOB

Remarks

Definition | A stream of bytes where the encoding of the contents is specified by the negotiated Transfer Syntax. OB is a VR which is insensitive to Little/Big Endian byte ordering. The string of bytes shall be padded with a single trailing NULL byte value (00H) when necessary to achieve even length.
Character Repertoire | not applicable
Length of Value | As Defined by DICOM Transfer Syntax rules

See Also

MCvr Class
MCvr Members


vrOD Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOD Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other Double.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOD
Visual Basic
Public Shared ReadOnly vrOD As MCvr
Visual C++
public:
static initonly MCvr^ vrOD

Remarks

This Value Representation was proposed for the standard but not accepted. It is supported for backward compatibility for users that may have implemented it.
Definition | A stream of 64-bit IEEE 754:1985 floating point words. OD is a VR which requires byte swapping within each 64-bit word when changing between Little Endian and Big Endian byte ordering.
Character Repertoire | not applicable
Length of Value | 2 32 - 8 maximum

See Also

MCvr Class
MCvr Members


vrOF Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOF Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other Float.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOF
Visual Basic
Public Shared ReadOnly vrOF As MCvr
Visual C++
public:
static initonly MCvr^ vrOF

Remarks

Definition | A stream of 32-bit IEEE 754:1985 floating point words. OF is a VR which requires byte swapping within each 32-bit word when changing between Little Endian and Big Endian byte ordering.
Character Repertoire | not applicable
Length of Value | 2 32 - 4 maximum

See Also

MCvr Class
MCvr Members


vrOL Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOL Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOL
Visual Basic
Public Shared ReadOnly vrOL As MCvr
Visual C++
public:
static initonly MCvr^ vrOL

Remarks

Definition | A stream of 32-bit words where the encoding of the contents is specified by the negotiated Transfer Syntax. OL is a VR that requires byte swapping within each word when changing between Little Endian and Big Endian byte ordering.
Character Repertoire | not applicable
Length of Value | As Defined by DICOM Transfer Syntax rules

See Also

MCvr Class
MCvr Members


vrOV Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOV Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other 64-bit Very Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOV
Visual Basic
Public Shared ReadOnly vrOV As MCvr
Visual C++
public:
static initonly MCvr^ vrOV

Remarks

Definition | A stream of 64-bit words where the encoding of the contents is specified by the negotiated Transfer Syntax. OV is a VR that requires byte swapping within each word when changing byte ordering.
Character Repertoire | not applicable
Length of Value | As Defined by DICOM Transfer Syntax rules

See Also

MCvr Class
MCvr Members


vrOW Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrOW Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Other Word.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrOW
Visual Basic
Public Shared ReadOnly vrOW As MCvr
Visual C++
public:
static initonly MCvr^ vrOW

Remarks

Definition | A stream of 16-bit words where the encoding of the contents is specified by the negotiated Transfer Syntax. OW is a VR which requires byte swapping within each word when changing between Little Endian and Big Endian byte ordering.
Character Repertoire | not applicable
Length of Value | As Defined by DICOM Transfer Syntax rules

See Also

MCvr Class
MCvr Members


vrPN Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrPN Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Person Name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrPN
Visual Basic
Public Shared ReadOnly vrPN As MCvr
Visual C++
public:
static initonly MCvr^ vrPN

Remarks

Definition

A character string encoded using a 5 component convention. The character code 5CH (the BACKSLASH '\' in ISO-IR 6) shall not be present, as it is used as the delimiter between values in multiple valued data elements. The string may be padded with trailing spaces. The five components in their order of occurrence are: family name complex, given name complex, middle name, name prefix, name suffix. Any of the five components may be an empty string. The component delimiter shall be the caret '^' character (5EH).

Delimiters are required for interior null components. Trailing null components and their delimiters may be omitted. Multiple entries are permitted in each component and are encoded as natural text strings, in the format preferred by the named person. This conforms to the ANSI HISPP MSDS Person Name common data type.

This group of five components is referred to as a Person Name component group.

For the purpose of writing names in ideographic characters and in phonetic characters, up to 3 groups of components (see Annex H examples 1 and 2) may be used. The delimiter for component groups shall be the equals character '=' (3DH). The three component groups of components in their order of occurrence are: a single-byte character representation, an ideographic representation, and a phonetic representation.

Any component group may be absent, including the first component group. In this case, the person name may start with one or more '=' delimiters. Delimiters are required for interior null component groups. Trailing null component groups and their delimiters may be omitted.

Precise semantics are defined for each component group.

Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005) excluding Control Characters LF, FF, and CR but allowing Control Character ESC.
Length of Value | 64 chars maximum per component group (Note that this is the number of characters, not the number of bytes)

See Also

MCvr Class
MCvr Members


vrSH Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrSH Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Short String.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrSH
Visual Basic
Public Shared ReadOnly vrSH As MCvr
Visual C++
public:
static initonly MCvr^ vrSH

Remarks

Definition | A character string that may be padded with leading and/or trailing spaces. The character code 05CH (the BACKSLASH '\' in ISO-IR 6) shall not be present, as it is used as the delimiter between values for multiple data elements. The string shall not have Control Characters except ESC.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 16 chars maximum (Note that this is the number of characters, not the number of bytes)

See Also

MCvr Class
MCvr Members


vrSL Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrSL Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Signed Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrSL
Visual Basic
Public Shared ReadOnly vrSL As MCvr
Visual C++
public:
static initonly MCvr^ vrSL

Remarks

Definition | Signed binary integer 32 bits long in 2's complement form. Represents an integer, n, in the range: -231 <= n <= (231 - 1).
Character Repertoire | not applicable
Length of Value | 4 bytes fixed

See Also

MCvr Class
MCvr Members


vrSQ Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrSQ Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Sequence of Items.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrSQ
Visual Basic
Public Shared ReadOnly vrSQ As MCvr
Visual C++
public:
static initonly MCvr^ vrSQ

Remarks

Definition | Value is a Sequence of zero or more Items
Character Repertoire | not applicable
Length of Value | not applicable

See Also

MCvr Class
MCvr Members


vrSS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrSS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Signed Short.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrSS
Visual Basic
Public Shared ReadOnly vrSS As MCvr
Visual C++
public:
static initonly MCvr^ vrSS

Remarks

Definition | Signed binary integer 16 bits long in 2's complement form. Represents an integer, n, in the range: -215 <= n <= (215 - 1).
Character Repertoire | not applicable
Length of Value | 2 bytes fixed

See Also

MCvr Class
MCvr Members


vrST Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrST Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Short Text.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrST
Visual Basic
Public Shared ReadOnly vrST As MCvr
Visual C++
public:
static initonly MCvr^ vrST

Remarks

Definition | A character string that may contain one or more paragraphs. It may contain the Graphic Character set and the Control Characters, CR, LF, FF, and ESC. It may be padded with trailing spaces, which may be ignored, but leading spaces are considered to be significant. Data Elements with this VR shall not be multi-valued and therefore character code 5CH (the BACKSLASH '\' in ISO-IR 6) may be used.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 1024 chars maximum (Note that this is the number of characters, not the number of bytes)

See Also

MCvr Class
MCvr Members


vrSV Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrSV Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Signed 64-bit Very Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrSV
Visual Basic
Public Shared ReadOnly vrSV As MCvr
Visual C++
public:
static initonly MCvr^ vrSV

Remarks

Definition | Signed binary integer 64 bits long. Represents an integer, n, in the range: -263 <= n <= (263 - 1).
Character Repertoire | not applicable
Length of Value | 8 bytes fixed

See Also

MCvr Class
MCvr Members


vrTM Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrTM Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Time.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrTM
Visual Basic
Public Shared ReadOnly vrTM As MCvr
Visual C++
public:
static initonly MCvr^ vrTM

Remarks

Definition

A string of characters of the format hhmmss.frac; where hh contains hours (range "00" - "23"), mm contains minutes (range "00" - "59"), ss contains seconds (range "00" - "59"), and frac contains a fractional part of a second as small as 1 millionth of a second (range "000000" - "999999"). A 24 hour clock is assumed. Midnight can be represented by only "0000" since "2400" would violate the hour range. The string may be padded with trailing spaces. Leading and embedded spaces are not allowed. One or more of the components mm, ss, or frac may be unspecified as long as every component to the right of an unspecified component is also unspecified. If frac is unspecified the preceding '.' may not be included. Frac shall be held to six decimal places or less to ensure its format conforms to the ANSI HISPP MSDS Time common data type.

Examples:

1. "070907.0705 " represents a time of 7 hours, 9 minutes and 7.0705 seconds.

2. "1010" represents a time of 10 hours, and 10 minutes.

3. "021 " is an invalid value.

Notes:

1. For reasons of backward compatibility with versions of this standard prior to V3.0, it is recommended that implementations also support a string of characters of the format hh:mm:ss.frac for this VR.

2. See also DT VR.

Character Repertoire | '0'-'9', '.' of Default Character Repertoire
Length of Value | 16 bytes maximum

See Also

MCvr Class
MCvr Members


vrUC Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUC Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unlimited Characters

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUC
Visual Basic
Public Shared ReadOnly vrUC As MCvr
Visual C++
public:
static initonly MCvr^ vrUC

Remarks

Definition | A character string that may be of unlimited length that may be padded with trailing spaces. The character code 5CH (the BACKSLASH "\"in ISO-IR 6) shall not be present, as it is used as the delimiter between values in multiple valued data elements. The string shall not have Control Characters except for ESC.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 232 - 2 Note: limited only by the size of the maximum unsigned integer representable in a 32 bit Value Length field minus one, since FFFFFFFFH is reserved.

See Also

MCvr Class
MCvr Members


vrUI Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUI Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unique Identifier (UID).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUI
Visual Basic
Public Shared ReadOnly vrUI As MCvr
Visual C++
public:
static initonly MCvr^ vrUI

Remarks

Definition | A character string containing a UID that is used to uniquely identify a wide variety of items. The UID is a series of numeric components separated by the period '.' character. If a Value Field containing one or more UIDs is an odd number of bytes in length, the Value Field shall be padded with a single trailing NULL (00H) character to ensure that the Value Field is an even number of bytes in length. See Section 9 and Annex B for a complete specification and examples.
Character Repertoire | '0'-'9', '.' of Default Character Repertoire
Length of Value | 64 bytes maximum

See Also

MCvr Class
MCvr Members


vrUL Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUL Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unsigned Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUL
Visual Basic
Public Shared ReadOnly vrUL As MCvr
Visual C++
public:
static initonly MCvr^ vrUL

Remarks

Definition | Unsigned binary integer 32 bits long. Represents an integer n in the range: 0 <= n < 2^32.
Character Repertoire | not applicable
Length of Value | 4 bytes fixed

See Also

MCvr Class
MCvr Members


vrUN Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUN Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unknown.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUN
Visual Basic
Public Shared ReadOnly vrUN As MCvr
Visual C++
public:
static initonly MCvr^ vrUN

Remarks

Definition | A string of bytes where the encoding of the contents is unknown.
Character Repertoire | not applicable
Length of Value | Any length valid for any of the other DICOM Value Representations

See Also

MCvr Class
MCvr Members


vrUR Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUR Field
MCvr Class See Also Send Feedback
DICOM value Representation for URI/URL.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUR
Visual Basic
Public Shared ReadOnly vrUR As MCvr
Visual C++
public:
static initonly MCvr^ vrUR

Remarks

Definition | A string of characters that identifies a URI or a URL as defined in [RFC 3986]. Leading spaces are not allowed. Trailing spaces shall be ignored. Data Elements with this VR shall not be multi-valued. Both absolute and relative URIs are permitted. If the URI is relative, then it is relative to the base URI of the object within which it is contained. The Backslash (5CH) character is among those disallowed inURIs.
Character Repertoire | The subset of the Default Character Repertoire required for the URI as defined in IETF RFC3986 Section 2, plus the space (20H) character permitted only as trailing padding. Characters outside the permitted character setmust be "percent encoded"..
Length of Value | 232 - 2 Note: limited only by the size of the maximum unsigned integer representable in a 32 bit Value Length field minus one, since FFFFFFFFH is reserved.

See Also

MCvr Class
MCvr Members


vrUS Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUS Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unsigned Short.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUS
Visual Basic
Public Shared ReadOnly vrUS As MCvr
Visual C++
public:
static initonly MCvr^ vrUS

Remarks

Definition | Unsigned binary integer 16 bits long. Represents an integer n in the range: 0 <= n < 2^16.
Character Repertoire | not applicable
Length of Value | 2 bytes fixed

See Also

MCvr Class
MCvr Members


vrUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUT Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unlimited Text.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUT
Visual Basic
Public Shared ReadOnly vrUT As MCvr
Visual C++
public:
static initonly MCvr^ vrUT

Remarks

Definition | A character string that may contain one or more paragraphs. It may contain the Graphic Character set and the Control Characters, CR, LF, FF, and ESC. It may be padded with trailing spaces, which may be ignored, but leading spaces are considered to be significant. Data Elements with this VR shall not be multi-valued and therefore character code 5CH (the BACKSLASH '\' in ISO-IR 6) may be used.
Character Repertoire | Default Character Repertoire and/or as defined by (0008,0005).
Length of Value | 232 - 2 Note: limited only by the size of the maximum unsigned integer representable in a 32 bit value length field minus one, since FFFFFFFFH is reserved.

See Also

MCvr Class
MCvr Members


vrUV Field

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..vrUV Field
MCvr Class See Also Send Feedback
DICOM Value Representation for Unsigned 64-bit Very Long.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static readonly MCvr vrUV
Visual Basic
Public Shared ReadOnly vrUV As MCvr
Visual C++
public:
static initonly MCvr^ vrUV

Remarks

Definition | Unsigned binary integer 64 bits long. Represents an integer n in the range: 0 <= n < 2^64.
Character Repertoire | not applicable
Length of Value | 8 bytes fixed

See Also

MCvr Class
MCvr Members


MCvr Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr Methods
MCvr Class See Also Send Feedback

The MCvr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | fixedWidthSize | Returns the number of bytes it takes to store one fixed width value. If the Value Representation is not a fixed width binary type, zero will be returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | getVRforName | Retrieve the MCvr object associated with a DICOM defined name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of this Value Representation. (Overrides Object..::..ToString()()()().)
Public method | validateValue(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValue(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValueStrict(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValueStrict(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.

See Also

MCvr Class


fixedWidthSize Method

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..fixedWidthSize Method
MCvr Class See Also Send Feedback
Returns the number of bytes it takes to store one fixed width value. If the Value Representation is not a fixed width binary type, zero will be returned.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual int fixedWidthSize()
Visual Basic
Public Overridable Function fixedWidthSize As Integer
Visual C++
public:
virtual int fixedWidthSize()

Return Value

The number of bytes it takes to store one fixed width value, or zero if the Value Representation is not a fixed binary type.

See Also

MCvr Class
MCvr Members


getVRforName Method

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..getVRforName Method
MCvr Class See Also Send Feedback
Retrieve the MCvr object associated with a DICOM defined name.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MCvr getVRforName(
    string vrName
)
Visual Basic
Public Shared Function getVRforName ( _
    vrName As String _
) As MCvr
Visual C++
public:
static MCvr^ getVRforName(
    String^ vrName
)

Parameters

vrName
Type: System..::..String
The 2 character name of the VR.

Return Value

an MCvr object identified by vrName

See Also

MCvr Class
MCvr Members


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..ToString Method
MCvr Class See Also Send Feedback
Gets the string representation of this Value Representation.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String representing the name of this Value Representation.

Remarks

See getVRforName(String) method for a complete list of VR names.

See Also

MCvr Class
MCvr Members


validateValue Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValue Method
MCvr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | validateValue(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValue(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.

See Also

MCvr Class
MCvr Members


validateValue Method (Object)

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValue Method (Object)
MCvr Class See Also Send Feedback
Verifies whether a Unicode string is properly formatted for a given VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void validateValue(
    Object val
)
Visual Basic
Public Sub validateValue ( _
    val As Object _
)
Visual C++
public:
void validateValue(
    Object^ val
)

Parameters

val
Type: System..::..Object
A not-null Unicode string.

Remarks

For the applicable VRs, characters used in C-FIND requests for wildcard and range matching, such as '*', '?' and '-' are accepted. This is not new behaviour.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingWarning | if invalid characters used for the VR.

See Also

MCvr Class
MCvr Members
validateValue Overload


validateValue Method (Object, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValue Method (Object, Boolean)
MCvr Class See Also Send Feedback
Verifies whether a Unicode string is properly formatted for a given VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete because Unicode strings cannot contain escape sequences.")]
public void validateValue(
    Object val,
    bool usingExtCharSet
)
Visual Basic
<ObsoleteAttribute("This method is obsolete because Unicode strings cannot contain escape sequences.")> _
Public Sub validateValue ( _
    val As Object, _
    usingExtCharSet As Boolean _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete because Unicode strings cannot contain escape sequences.")]
void validateValue(
    Object^ val,
    bool usingExtCharSet
)

Parameters

val
Type: System..::..Object
A not-null Unicode string.
usingExtCharSet
Type: System..::..Boolean
true if the value can contain escape characters used to change to different encoding schemes.

Remarks

For the applicable VRs, characters used in C-FIND requests for wildcard and range matching, such as '*', '?' and '-' are accepted. This is not new behaviour.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingWarning | if invalid characters used for the VR.

See Also

MCvr Class
MCvr Members
validateValue Overload


validateValueStrict Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValueStrict Method
MCvr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | validateValueStrict(Object) | Verifies whether a Unicode string is properly formatted for a given VR.
Public method | validateValueStrict(Object, Boolean) | Obsolete. Verifies whether a Unicode string is properly formatted for a given VR.

See Also

MCvr Class
MCvr Members


validateValueStrict Method (Object)

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValueStrict Method (Object)
MCvr Class See Also Send Feedback
Verifies whether a Unicode string is properly formatted for a given VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void validateValueStrict(
    Object val
)
Visual Basic
Public Sub validateValueStrict ( _
    val As Object _
)
Visual C++
public:
void validateValueStrict(
    Object^ val
)

Parameters

val
Type: System..::..Object
A not-null Unicode string.

Remarks

For the applicable VRs, characters used in C-FIND requests for wildcard and range matching, such as '*', '?' and '-' are not accepted. The validation is said to be strict in this particular sense.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingWarning | if invalid characters used for the VR.

See Also

MCvr Class
MCvr Members
validateValueStrict Overload


validateValueStrict Method (Object, Boolean)

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..validateValueStrict Method (Object, Boolean)
MCvr Class See Also Send Feedback
Verifies whether a Unicode string is properly formatted for a given VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete because Unicode strings cannot contain escape sequences.")]
public void validateValueStrict(
    Object val,
    bool usingExtCharSet
)
Visual Basic
<ObsoleteAttribute("This method is obsolete because Unicode strings cannot contain escape sequences.")> _
Public Sub validateValueStrict ( _
    val As Object, _
    usingExtCharSet As Boolean _
)
Visual C++
public:
[ObsoleteAttribute(L"This method is obsolete because Unicode strings cannot contain escape sequences.")]
void validateValueStrict(
    Object^ val,
    bool usingExtCharSet
)

Parameters

val
Type: System..::..Object
A not-null Unicode string.
usingExtCharSet
Type: System..::..Boolean
true if the value can contain escape characters used to change to different encoding schemes.

Remarks

For the applicable VRs, characters used in C-FIND requests for wildcard and range matching, such as '*', '?' and '-' are not accepted. The validation is said to be strict in this particular sense.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingWarning | if invalid characters used for the VR.

See Also

MCvr Class
MCvr Members
validateValueStrict Overload


MCvr Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCvr Properties
MCvr Class See Also Send Feedback

The MCvr type exposes the following members.

Properties

 | Name | Description
Public property | AcceptableForCallback | Determines whether this Value Representation is one of those for which an attribute container may be used to process the data element's value.
Public property | BinaryVR | Determines whether this Value Representation is for a binary value.
Public property | BulkDataUriVR | Determines whether the Value Representation is for a BulkDataURI.
Public property | FloatingPointVR | Determines whether this Value Representation is for a binary floating point value.
Public property | MaxSize | Gets the maximum size of a value of this VR.
Public property | MultiByteBinaryVR | Determines whether this Value Representation is for binary value that is represented by more than one byte.
Public property | MultiValuedBinaryVR | Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements.
Public property | MultiValuedIntegerVR | Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements, and is an integer number (short or long).
Public property | MultiValuedTextVR | Determines whether this Value Representation is for a text string value that can be used for Multi-Valued Data Elements.
Public property | MultiValuedVR | Determines whether this Value Representation is for a value that can be used for Multi-Valued Data Elements only.
Public property | Name | The DICOM 2-character name by which this VR is known.
Public property | SingleValuedBinaryVR | Determines whether this Value Representation is for a binary string value that can be used for Single Valued Data Elements only.
Public property | SingleValuedTextVR | Determines whether this Value Representation is for a text string value that can be used for Single Valued Data Elements only.
Public property | SingleValuedVR | Determines whether this Value Representation is for a value that can be used for Single Valued Data Elements only.
Public property | TextVR | Determines whether the Value Representation is for a text value.
Public property | ValueType | The .NET type for values of this VR.

See Also

MCvr Class


AcceptableForCallback Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..AcceptableForCallback Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is one of those for which an attribute container may be used to process the data element's value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool AcceptableForCallback { get; }
Visual Basic
Public Overridable ReadOnly Property AcceptableForCallback As Boolean
    Get
Visual C++
public:
virtual property bool AcceptableForCallback {
    bool get ();
}

Field Value

true if an attribute container can be used; otherwise false.

Remarks

An MCattributeContainer may only be used if the data element involved uses one of these Value Representations: LT, OB, OW, OV, OL, OD, OF, ST, UN, UT, SS, US, AT, SL, UL, SV, UV, FL, FD.

See Also

MCvr Class
MCvr Members


BinaryVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..BinaryVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a binary value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool BinaryVR { get; }
Visual Basic
Public Overridable ReadOnly Property BinaryVR As Boolean
    Get
Visual C++
public:
virtual property bool BinaryVR {
    bool get ();
}

Field Value

true for the following Value Representations: SS, US, AT, SL, UL, SV, UV, FL, FD, UN, OB, OW, OL, OD, OF; otherwise false.

Remarks

If this property is true, attributes of this VR can be single valued only.

See Also

MCvr Class
MCvr Members


BulkDataUriVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..BulkDataUriVR Property
MCvr Class See Also Send Feedback
Determines whether the Value Representation is for a BulkDataURI.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool BulkDataUriVR { get; }
Visual Basic
Public Overridable ReadOnly Property BulkDataUriVR As Boolean
    Get
Visual C++
public:
virtual property bool BulkDataUriVR {
    bool get ();
}

Field Value

true if this Value Representation is for a value that can be used for BulkDataURI; otherwise false.

Remarks

These VRs meet this requirement: FL, FD, IS, LT, OB, OV, OL, OD, OF, OW, SL, SS, ST, UL, SV, UV, UN, US, or UT

See Also

MCvr Class
MCvr Members


FloatingPointVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..FloatingPointVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a binary floating point value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool FloatingPointVR { get; }
Visual Basic
Public Overridable ReadOnly Property FloatingPointVR As Boolean
    Get
Visual C++
public:
virtual property bool FloatingPointVR {
    bool get ();
}

Field Value

true if this Value Representation is for a binary floating point value; otherwise false.

Remarks

These VRs meet this requirement: FL, FD.

See Also

MCvr Class
MCvr Members


MaxSize Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MaxSize Property
MCvr Class See Also Send Feedback
Gets the maximum size of a value of this VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint MaxSize { get; }
Visual Basic
Public Overridable ReadOnly Property MaxSize As UInteger
    Get
Visual C++
public:
virtual property unsigned int MaxSize {
    unsigned int get ();
}

Field Value

The maximum size of a value of this VR or Int32.MaxValue if the size is unlimited.

Remarks

For VR's that are characterset specific the size is given in characters for all other VR's the size is in bytes.

See Also

MCvr Class
MCvr Members


MultiByteBinaryVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MultiByteBinaryVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for binary value that is represented by more than one byte.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultiByteBinaryVR { get; }
Visual Basic
Public Overridable ReadOnly Property MultiByteBinaryVR As Boolean
    Get
Visual C++
public:
virtual property bool MultiByteBinaryVR {
    bool get ();
}

Field Value

true if this Value Representation is for a binary value that is represented by more than one byte; otherwise false.

Remarks

These VRs meet this requirement: SS, US, AT, SL, UL, FL, FD, OW, OV, OL, OD, OF.

See Also

MCvr Class
MCvr Members


MultiValuedBinaryVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MultiValuedBinaryVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultiValuedBinaryVR { get; }
Visual Basic
Public Overridable ReadOnly Property MultiValuedBinaryVR As Boolean
    Get
Visual C++
public:
virtual property bool MultiValuedBinaryVR {
    bool get ();
}

Field Value

true if this Value Representation is for a binary value that can be used for Multi-Valued Data Elements; otherwise false.

Remarks

These VRs meet this requirement: SS, US, AT, SL, UL, SV, UV, FL, FD.

See Also

MCvr Class
MCvr Members


MultiValuedIntegerVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MultiValuedIntegerVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a binary value that can be used for Multi-Valued Data Elements, and is an integer number (short or long).

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultiValuedIntegerVR { get; }
Visual Basic
Public Overridable ReadOnly Property MultiValuedIntegerVR As Boolean
    Get
Visual C++
public:
virtual property bool MultiValuedIntegerVR {
    bool get ();
}

Field Value

true if this Value Representation is for a binary value that can be used for Multi-Valued Data Elements, and is an integer number (short or long); otherwise false.

Remarks

These VRs meet this requirement: SS, US, AT, SL, UL, SV, UV.

See Also

MCvr Class
MCvr Members


MultiValuedTextVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MultiValuedTextVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a text string value that can be used for Multi-Valued Data Elements.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultiValuedTextVR { get; }
Visual Basic
Public Overridable ReadOnly Property MultiValuedTextVR As Boolean
    Get
Visual C++
public:
virtual property bool MultiValuedTextVR {
    bool get ();
}

Field Value

true if this Value Representation is for a text string value that can be used for Multi-Valued Data Elements; otherwise false.

Remarks

These VRs meet this requirement: AE, AS, CS, DA, DS, DT, IS, LO, PN, SH, TM, UI, UC.

See Also

MCvr Class
MCvr Members


MultiValuedVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..MultiValuedVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a value that can be used for Multi-Valued Data Elements only.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool MultiValuedVR { get; }
Visual Basic
Public Overridable ReadOnly Property MultiValuedVR As Boolean
    Get
Visual C++
public:
virtual property bool MultiValuedVR {
    bool get ();
}

Field Value

true if this Value Representation is for a value that can be used for Single Valued Data Elements only; otherwise false.

Remarks

These VRs meet this requirement: SQ, SS, US, AT, SL, UL, SV, UV, FL, FD, AE, AS, CS, DA, DS, DT, IS, LO, PN, SH, TM, UI, UC.

See Also

MCvr Class
MCvr Members


Name Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..Name Property
MCvr Class See Also Send Feedback
The DICOM 2-character name by which this VR is known.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

MCvr Class
MCvr Members


SingleValuedBinaryVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..SingleValuedBinaryVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a binary string value that can be used for Single Valued Data Elements only.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool SingleValuedBinaryVR { get; }
Visual Basic
Public Overridable ReadOnly Property SingleValuedBinaryVR As Boolean
    Get
Visual C++
public:
virtual property bool SingleValuedBinaryVR {
    bool get ();
}

Field Value

true if this Value Representation is for a binary string value that can be used for Single Valued Data Elements only; otherwise false.

Remarks

These VRs meet this requirement: UN, OB, OW, OV, OL, OD, OF.

See Also

MCvr Class
MCvr Members


SingleValuedTextVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..SingleValuedTextVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a text string value that can be used for Single Valued Data Elements only.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool SingleValuedTextVR { get; }
Visual Basic
Public Overridable ReadOnly Property SingleValuedTextVR As Boolean
    Get
Visual C++
public:
virtual property bool SingleValuedTextVR {
    bool get ();
}

Field Value

true if this Value Representation is for a text string value that can be used for Single Valued Data Elements only; otherwise false.

Remarks

These VRs meet this requirement: LT, ST, UT, UR.

See Also

MCvr Class
MCvr Members


SingleValuedVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..SingleValuedVR Property
MCvr Class See Also Send Feedback
Determines whether this Value Representation is for a value that can be used for Single Valued Data Elements only.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool SingleValuedVR { get; }
Visual Basic
Public Overridable ReadOnly Property SingleValuedVR As Boolean
    Get
Visual C++
public:
virtual property bool SingleValuedVR {
    bool get ();
}

Field Value

true if this Value Representation is for a value that can be used for Single Valued Data Elements only; otherwise false.

Remarks

These VRs meet this requirement: UN, OB, OW, OV, OL, OD, OF, LT, ST, UT, UR.

See Also

MCvr Class
MCvr Members


TextVR Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..TextVR Property
MCvr Class See Also Send Feedback
Determines whether the Value Representation is for a text value.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool TextVR { get; }
Visual Basic
Public Overridable ReadOnly Property TextVR As Boolean
    Get
Visual C++
public:
virtual property bool TextVR {
    bool get ();
}

Field Value

true if this Value Representation is for a value that can be used for text values; otherwise false.

Remarks

These VRs meet this requirement: AE, AS, CS, DA, DS, DT, IS, LO, PN, SH, TM, UI, UC, LT, ST, UT, UR.

See Also

MCvr Class
MCvr Members


ValueType Property

[image]

Merge DICOM .NET/C# Toolkit
MCvr..::..ValueType Property
MCvr Class See Also Send Feedback
The .NET type for values of this VR.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual Type ValueType { get; }
Visual Basic
Public Overridable ReadOnly Property ValueType As Type
    Get
Visual C++
public:
virtual property Type^ ValueType {
    Type^ get ();
}

Field Value

The Type of values for this VR.

See Also

MCvr Class
MCvr Members


MCxmlOptions Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCxmlOptions Enumeration
See Also Send Feedback
Defines Xml conversion configuration options.

Namespace: Mergecom
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCxmlOptions
Visual Basic
Public Enumeration MCxmlOptions
Visual C++
public enum class MCxmlOptions

Members

Member name | Value | Description
XmlOptDefault | 0 | Use the default settings: attributes with very large value fields (e.g. pixel data, any OB, OW, OL, OD or OF) are not stored in the XML by default. By default the standard encoding is used except Native DICOM Model will always use Base64 encoding.
XmlOptIncludeBulks | 1 | Store bulk attribute (VR is OB or OW) in the XML.
XmlOptIncludePixelData | 2 | Store Pixel Data buffer in the XML.
XmlOptExcludeSequences | 4 | Do not store Sequence attributes in the XML.
XmlOptExcludePrivateAttributes | 8 | Do not store Private attributes in the XML.
XmlOptBase64Binary | 16 | Use Base64 encoding when storing bulks in the XML.

See Also


Mergecom.Dicomdir Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom.Dicomdir Namespace
Send Feedback
This namespace contains classes for fast and efficient DICOMDIR manipulation functionality.

Classes

 | Class | Description
Public class | MCdicomDir | Provides functionality to manipulate DICOMDIR files.
Public class | MCdicomDirRecord | Represents a directory record in a DICOMDIR file.

Delegates

 | Delegate | Description
Public delegate | MCdicomDirRecord..::..RecordHandler | Delegate called by the toolkit when visiting directory records as a result of traverse(MCdicomDirRecord..::..RecordHandler) call.

Enumerations

 | Enumeration | Description
Public enumeration | DirRecordType | Enumeration of DICOM directory record types.
Public enumeration | MCdicomDirRecord..::..TraversalStatus | Enum for controlling directory record traversal when using the traverse(MCdicomDirRecord..::..RecordHandler) method.


DirRecordType Enumeration

[image]

Merge DICOM .NET/C# Toolkit
DirRecordType Enumeration
See Also Send Feedback
Enumeration of DICOM directory record types.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum DirRecordType
Visual Basic
Public Enumeration DirRecordType
Visual C++
public enum class DirRecordType

Members

Member name | Value | Description
PATIENT | 0 | Patient record type.
STUDY | 1 | Study record type.
SERIES | 2 | Series record type.
IMAGE | 3 | Image record type.
RADIOTHERAPY | 4 | Radiotherapy record type
RT_DOSE | 5 | RT Dose record type.
RT_STRUCTURE_SET | 6 | RT Structure Set record type.
RT_PLAN | 7 | RT Plan record type.
RT_TREAT_RECORD | 8 | RT Treatment Record record type.
PRESENTATION | 9 | Presentation State record type.
WAVEFORM | 10 | Waveform record type.
SR_DOCUMENT | 11 | SR Document record type.
KEY_OBJECT_DOC | 12 | Key Object Document record type.
SPECTROSCOPY | 13 | Spectroscopy record type.
RAW_DATA | 14 | Raw Data record type.
REGISTRATION | 15 | Registration record type.
FIDUCIAL | 16 | Fiducial record type.
HANGING_PROTOCOL | 17 | Hanging Protocol record type.
ENCAP_DOC | 18 | Encapsulated Document record type.
HL7_STRUC_DOC | 19 | HL7 Structured Document record type.
VALUE_MAP | 20 | Real World Value Mapping record type.
STEREOMETRIC | 21 | Stereometric Relationship record type.
PALETTE | 22 | Palette record type.
IMPLANT | 23 | Implant record type.
IMPLANT_GROUP | 24 | Implant Group record type.
IMPLANT_ASSY | 25 | Implant Assembly record type.
MEASUREMENT | 26 | Measurement record type.
SURFACE | 27 | Surface record type
SURFACE_SCAN | 28 | Surface Scan Mesh record type
TRACT | 29 | Tractography Results record type
ASSESSMENT | 30 | Content Assessment Results record type
PRIVATE | 31 | Private record type.
UNKNOWN | 32 | Unknown record type. This type is used by the toolkit for records types other then the ones defined in this enum.
ROOT | 33 | Root record type. This type is used for the root entity.

See Also

Mergecom.Dicomdir Namespace


MCdicomDir Class

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Class
Members See Also Send Feedback
Provides functionality to manipulate DICOMDIR files.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdicomDir
Visual Basic
Public Class MCdicomDir
Visual C++
public ref class MCdicomDir

Remarks

This class provides enhanced DICOMDIR functionality in contrast to the class with basic, in memory, DICOMDIR functionality.

MCdicomDir reads records from the DICOMDIR file only when they are required speeding up the access to specific records. This class also allows updates to existing DICOMDIR files without the need to rewrite the whole file when a directory record is added or deleted.

Instances of this class allow the application to incrementally add new records or delete existing records using the MCdicomDirRecord.addRecord, MCdicomDirRecord.delete and update()()()() methods, without rewriting the whole file.

Attributes of the directory entity can be read through the root record object provided by the RootRecord property. The Directory Record Sequence (0004,1220) attribute and its content is not accessible to the application as it is managed internally by the toolkit.

Although the toolkit allows the application to modify the content of existing directory records or the attributes in the directory object itself, the changes will not be reflected in the DICOMDIR file.

Inheritance Hierarchy

System..::..Object
Mergecom.Dicomdir..::..MCdicomDir

See Also

MCdicomDir Members
Mergecom.Dicomdir Namespace


MCdicomDir Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Members
MCdicomDir Class Constructors Methods Properties See Also Send Feedback

The MCdicomDir type exposes the following members.

Constructors

 | Name | Description
Public method | MCdicomDir(String) | Creates a new instance of this class providing access to an existing DICOMDIR file.
Public method | MCdicomDir(String, String, MCfile) | Creates a new instance of this class to handle a new DICOMDIR file.

Methods

 | Name | Description
Public method | close | Closes the DICOMDIR file and releases all record objects associated with it.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | update | Commits all pending changes to the DICOMDIR file.

Properties

 | Name | Description
Public property | FileSetID | Gets the value of the File-set ID (0004,1130) attribute.
Public property | ImplementationClassUID | Gets the value of the Implementation Class UID (0002,0012) attribute.
Public property | ImplementationVersionName | Gets the value of the Implementation Version Name (0002,0013) attribute.
Public property | MediaStorageSOPInstanceUID | Gets the value of the Media Storage SOP Instance UID (0002,0003) attribute.
Public property | RootRecord | Gets the record object representing the root of the directory record hierarchy.

See Also

MCdicomDir Class
Mergecom.Dicomdir Namespace


MCdicomDir Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Constructor
MCdicomDir Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdicomDir(String) | Creates a new instance of this class providing access to an existing DICOMDIR file.
Public method | MCdicomDir(String, String, MCfile) | Creates a new instance of this class to handle a new DICOMDIR file.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


MCdicomDir Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Constructor (String)
MCdicomDir Class See Also Send Feedback
Creates a new instance of this class providing access to an existing DICOMDIR file.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomDir(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
MCdicomDir(
    String^ path
)

Parameters

path
Type: System..::..String
The file path to the DICOMDIR file.

Remarks

This constructor opens an existing DICOMDIR file for reading and/or updating.

As opposed to opening DICODMIR files using the MCdir class, this class does not read the whole content of the DICOMDIR in the memory, instead it reads only the first directory record if it exists. Subsequent directory records are read only on demand, when the application requires access to them, providing fast and efficient access to large DICOMDIRs.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The path argument was invalid.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The toolkit failed to open the DICOMDIR file.
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException | An invalid transfer syntax code was found within the file's DICOM File Meta Information.
Mergecom.Exceptions..::..MCinvalidEncodingException | There was a problem decoding the DICOMDIR file. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | The toolkit failed to read the first directory record.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDir Class
MCdicomDir Members
MCdicomDir Overload
Mergecom.Dicomdir Namespace


MCdicomDir Constructor (String, String, MCfile)

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Constructor (String, String, MCfile)
MCdicomDir Class See Also Send Feedback
Creates a new instance of this class to handle a new DICOMDIR file.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomDir(
    string path,
    string fileSetID,
    MCfile fileTemplate
)
Visual Basic
Public Sub New ( _
    path As String, _
    fileSetID As String, _
    fileTemplate As MCfile _
)
Visual C++
public:
MCdicomDir(
    String^ path,
    String^ fileSetID,
    MCfile^ fileTemplate
)

Parameters

path
Type: System..::..String
The file path to the new DICOMDIR file.
fileSetID
Type: System..::..String
The value to be assigned to the File Set ID attribute (0004,1130). If this argument is null the toolkit will copy the value of the File Set ID attribute from the template file, if specified
fileTemplate
Type: Mergecom..::..MCfile
A file object containing attribute values for the new DICODMIR. If this argument is null the toolkit creates an empty DICOMDIR with a minimal number of attributes.

Remarks

This constructor creates a DICOMDIR file with no records. If a file with the same name exist its content is overwritten.

The toolkit copies group 2 and 4 attribute values from the specified template file object. If the Media Storage SOP Instance UID attribute is not present in the template file or the template file argument is null the toolkit will generate a UID based on the IMPLEMENTATION_CLASS_UID configuration item.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The path argument was invalid.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The toolkit failed to write the DICOMDIR file.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDir Class
MCdicomDir Members
MCdicomDir Overload
Mergecom.Dicomdir Namespace


MCdicomDir Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Methods
MCdicomDir Class See Also Send Feedback

The MCdicomDir type exposes the following members.

Methods

 | Name | Description
Public method | close | Closes the DICOMDIR file and releases all record objects associated with it.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | update | Commits all pending changes to the DICOMDIR file.

See Also

MCdicomDir Class
Mergecom.Dicomdir Namespace


close Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..close Method
MCdicomDir Class See Also Send Feedback
Closes the DICOMDIR file and releases all record objects associated with it.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void close()
Visual Basic
Public Sub close
Visual C++
public:
void close()

Remarks

This method ignores any changes made to the record hierarchy (new or deleted records) since the last call to update()()()() method.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


update Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..update Method
MCdicomDir Class See Also Send Feedback
Commits all pending changes to the DICOMDIR file.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void update()
Visual Basic
Public Sub update
Visual C++
public:
void update()

Remarks

This method updates the DICOMDIR file to reflect all changes to the dicomdir object as the result of adding and deleting records. The toolkit writes new records to the end of the directory record seqeunce and bridges over deleted records so that they are no longer accessible.

The toolkit does not make changes to existing records or the attributes of the directory object, except for the values of the offset attributes required to represent the modified record hierarchy.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCinvalidEncodingException | A failure occured while writing the file. The DICOMDIR file may be corrupted.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | The DICOMDIR file could not be opened for writing or a file read or write operation failed. The DICOMDIR file is in a consistent state but the directory object can not be reliably used and it should be disposed using the close()()()() method.
Mergecom.Exceptions..::..MCdicomdirException | A directory record offset value is not correct and new records can not be written, the directory object can still be used in readonly mode.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge log file. The DICOMDIR file is in a consistent state but the directory object can not be reliably used and it should be freed using close()()()() method.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


MCdicomDir Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDir Properties
MCdicomDir Class See Also Send Feedback

The MCdicomDir type exposes the following members.

Properties

 | Name | Description
Public property | FileSetID | Gets the value of the File-set ID (0004,1130) attribute.
Public property | ImplementationClassUID | Gets the value of the Implementation Class UID (0002,0012) attribute.
Public property | ImplementationVersionName | Gets the value of the Implementation Version Name (0002,0013) attribute.
Public property | MediaStorageSOPInstanceUID | Gets the value of the Media Storage SOP Instance UID (0002,0003) attribute.
Public property | RootRecord | Gets the record object representing the root of the directory record hierarchy.

See Also

MCdicomDir Class
Mergecom.Dicomdir Namespace


FileSetID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..FileSetID Property
MCdicomDir Class See Also Send Feedback
Gets the value of the File-set ID (0004,1130) attribute.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string FileSetID { get; }
Visual Basic
Public ReadOnly Property FileSetID As String
    Get
Visual C++
public:
property String^ FileSetID {
    String^ get ();
}

Field Value

A String object representing the first value of the File-set ID (0004,1130) attribute or null if the attribute is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The DICOMDIR object has been dispose.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


ImplementationClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..ImplementationClassUID Property
MCdicomDir Class See Also Send Feedback
Gets the value of the Implementation Class UID (0002,0012) attribute.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ImplementationClassUID { get; }
Visual Basic
Public ReadOnly Property ImplementationClassUID As String
    Get
Visual C++
public:
property String^ ImplementationClassUID {
    String^ get ();
}

Field Value

A String object representing the first value of the Implementation Class UID (0002,0012) attribute or null if the attribute is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The DICOMDIR object has been dispose.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


ImplementationVersionName Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..ImplementationVersionName Property
MCdicomDir Class See Also Send Feedback
Gets the value of the Implementation Version Name (0002,0013) attribute.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ImplementationVersionName { get; }
Visual Basic
Public ReadOnly Property ImplementationVersionName As String
    Get
Visual C++
public:
property String^ ImplementationVersionName {
    String^ get ();
}

Field Value

A String object representing the first value of the Implementation Version Name (0002,0013) attribute or null if the attribute is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The DICOMDIR object has been dispose.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


MediaStorageSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..MediaStorageSOPInstanceUID Property
MCdicomDir Class See Also Send Feedback
Gets the value of the Media Storage SOP Instance UID (0002,0003) attribute.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string MediaStorageSOPInstanceUID { get; }
Visual Basic
Public ReadOnly Property MediaStorageSOPInstanceUID As String
    Get
Visual C++
public:
property String^ MediaStorageSOPInstanceUID {
    String^ get ();
}

Field Value

A String object representing the first value of the Media Storage SOP Instance UID (0002,0003) attribute or null if the attribute is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The DICOMDIR object has been disposed.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


RootRecord Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDir..::..RootRecord Property
MCdicomDir Class See Also Send Feedback
Gets the record object representing the root of the directory record hierarchy.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomDirRecord RootRecord { get; }
Visual Basic
Public ReadOnly Property RootRecord As MCdicomDirRecord
    Get
Visual C++
public:
property MCdicomDirRecord^ RootRecord {
    MCdicomDirRecord^ get ();
}

Field Value

The record object representing the root entity of the directory.

Remarks

The Root record does not represent a physical record in the DICOMDIR file, instead it provides access to attributes of the directory object and it allows consistent navigation throughout the record hierarchy.

See Also

MCdicomDir Class
MCdicomDir Members
Mergecom.Dicomdir Namespace


MCdicomDirRecord Class

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord Class
Members See Also Send Feedback
Represents a directory record in a DICOMDIR file.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdicomDirRecord : MCattributeSet
Visual Basic
Public Class MCdicomDirRecord _
    Inherits MCattributeSet
Visual C++
public ref class MCdicomDirRecord : public MCattributeSet

Inheritance Hierarchy

System..::..Object
Mergecom..::..MCattributeSet
Mergecom.Dicomdir..::..MCdicomDirRecord

See Also

MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


MCdicomDirRecord Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord Members
MCdicomDirRecord Class Methods Properties See Also Send Feedback

The MCdicomDirRecord type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addRecord | Adds a new lower level directory record to this record.
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | copyValues | Copies attribute values from the specified attribute set into this record.
Public method | delete | Deletes this directory record.
Public method | dispose | Disposes this record and its associated native resources. (Overrides MCattributeSet..::..dispose()()()().)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | traverse | Provides easy record traversal and search functionality.
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | DICOMDIR | Gets the directory object containing this record.
Public property | DirectoryRecordType | Gets or sets the value of the Directory Record Type (0004,1430) attribute of this record.
Public property | FirstLowerRecord | Gets the first lower level directory record of this record.
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | IsRoot | Tells whether this record is the root record of the DICODMIR.
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | NextRecord | Gets the next directory record in the directory entity of the current record.
Public property | ParentRecord | Gets the parent record of this record.
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | RecordType | Gets an enum representation of the value of the Directory Record Type (0004,1430) attribute of this record.
Public property | ReferencedFileID | Gets or sets the values of the Referenced File ID (0004,1500) attribute of this record.
Public property | ReferencedSOPClassUIDinFile | Gets or sets the value of the Referenced SOP Class UID in File (0004,1510) attribute of this record.
Public property | ReferencedSOPInstanceUIDinFile | Gets or sets the value of the Referenced SOP Instance UID in File (0004,1511) attribute of this record.
Public property | ReferencedTSUIDinFile | Gets or sets the value of the Referenced Transfer Syntax UID in File (0004,1512) attribute of this record.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCdicomDirRecord Class
Mergecom.Dicomdir Namespace


MCdicomDirRecord Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord Methods
MCdicomDirRecord Class See Also Send Feedback

The MCdicomDirRecord type exposes the following members.

Methods

 | Name | Description
Public method | add(UInt32) | Adds an empty standard attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | add(MCtag) | Adds an empty attribute to this attribute set. (Inherited from MCattributeSet.)
Public method | addRecord | Adds a new lower level directory record to this record.
Public method | addValue(UInt32, Object) | Adds a value to the list of values of a standard attribute. (Inherited from MCattributeSet.)
Public method | addValue(MCtag, Object) | Adds a value to the list of values of an attribute. (Inherited from MCattributeSet.)
Public method | clear | Removes all attributes. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | compareTo(MCattributeSet, UInt32, UInt32, array<UInt32>[]()[][]) | Compares another MCattributeSet instance to this one. (Inherited from MCattributeSet.)
Public method | contains(UInt32) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | contains(MCtag) | Checks if an attribute is present in this attribute set. (Inherited from MCattributeSet.)
Public method | copyTo | Copies the attributes within this set to another attribute set. (Inherited from MCattributeSet.)
Public method | copyValues | Copies attribute values from the specified attribute set into this record.
Public method | delete | Deletes this directory record.
Public method | dispose | Disposes this record and its associated native resources. (Overrides MCattributeSet..::..dispose()()()().)
Public method | emptyValues | Sets all attributes to empty. (Inherited from MCattributeSet.)
Public method | Equals | Determines if this attribute set is equal to another object. (Inherited from MCattributeSet.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MCattributeSet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | list()()()() | Lists the contents of this attribute set to the console output. (Inherited from MCattributeSet.)
Public method | list(TextWriter) | Lists the contents of this attribute set. (Inherited from MCattributeSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | readFromJSON(TextReader) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromJSON(TextReader, MCbulkDataUriHandler) | Converts an JSON representation (DICOM JSON Model PS3.18) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(TextReader) | Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXML(XmlReader) | Obsolete. Converts a Merge DICOM Toolkit proprietary XML representation of the DICOM attributes into an attribute set. Note: The content of the DataSet is not cleared before processing XML attributes. The existing attributes in the attribute set will be overridden if they are present in the XML string. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | readFromXMLNative(TextReader, MCbulkDataUriHandler) | Converts an XML representation (Native DICOM Model schema PS3.19) of the DICOM attributes into an attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(UInt32) | Removes a standard attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | removeAttribute(MCtag) | Removes an attribute from this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(UInt32, Object) | Sets the value of a standard attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | setValue(MCtag, Object) | Sets the value of an attribute in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamIn(UInt32, UInt32, MCtransferSyntax, MCdataSource) | Requests the contents of a "streamed message" (i.e. a message in the form defined by the DICOM standard) be converted and placed in this attribute set. (Inherited from MCattributeSet.)
Public method | streamOut(MCtransferSyntax, MCdataSink) | Requests that the contents of the attributes set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | streamOut(UInt32, UInt32, MCtransferSyntax, MCdataSink) | Requests that the contents of the attribute set be "streamed" (i.e. put in the form defined by the DICOM standard). (Inherited from MCattributeSet.)
Public method | syncAttribute | Obsolete. Triggers the immediate propagation of the value(s) of an attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | syncPixelData | Triggers the immediate propagation of the value of the pixel data attribute to the underlying native layer, allowing associated managed resources to be freed sooner. (Inherited from MCattributeSet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | traverse | Provides easy record traversal and search functionality.
Public method | writeToJSON(TextWriter) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToJSON(TextWriter, MCbulkDataUriHandler) | Converts DICOM attribute set into its Json representation (DICOM JSON Model PS3.18). (Inherited from MCattributeSet.)
Public method | writeToXML(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXML(XmlWriter, MCxmlOptions) | Obsolete. Converts DICOM attribute set into its XML representation (Merge DICOM Toolkit proprietary schema). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)
Public method | writeToXMLNative(TextWriter, MCxmlOptions, MCbulkDataUriHandler) | Converts DICOM attribute set into its XML representation (Native DICOM Model schema PS3.19). (Inherited from MCattributeSet.)

See Also

MCdicomDirRecord Class
Mergecom.Dicomdir Namespace


addRecord Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..addRecord Method
MCdicomDirRecord Class See Also Send Feedback
Adds a new lower level directory record to this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomDirRecord addRecord(
    string recordType
)
Visual Basic
Public Function addRecord ( _
    recordType As String _
) As MCdicomDirRecord
Visual C++
public:
MCdicomDirRecord^ addRecord(
    String^ recordType
)

Parameters

recordType
Type: System..::..String
The directory record type name for the new record or the SOP Class UID of the referenced instance. If this argument is null the toolkit will set the record type based on the type of this record: "PATIENT" for root record, "STUDY" if the parent is "PATIENT", "SERIES" if the parent is "STUDY" and "IMAGE" if the parent is "SERIES". The application can change the record type on the returned record object before calling update()()()().

Return Value

The new directory record object.

Remarks

This method creates a new directory record object and appends it to the end of the child record list of this record or to the end of the root entity if this record is the root record.

If the type of the record is not specified the toolkit will try to determine it based on the type of the parent record. For instance level records, the application can specify the SOP Class UID of the referenced object in the recordType argument and the toolkit will determine the corresponding record type.

The new record and any values set for its attributes are written to the DICOMDIR file when the application calls MCdicomDir.update. If the directory object is closed without calling MCdicomDir.update, changes to the record hierarchy will be lost.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | A file read operation failed.
Mergecom.Exceptions..::..MCinvalidEncodingException | There was a problem decoding the DICOMDIR file. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | There is a problem with the structure of the DICOMDIR file.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


copyValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..copyValues Method
MCdicomDirRecord Class See Also Send Feedback
Copies attribute values from the specified attribute set into this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void copyValues(
    MCattributeSet source,
    uint[] tags
)
Visual Basic
Public Sub copyValues ( _
    source As MCattributeSet, _
    tags As UInteger() _
)
Visual C++
public:
void copyValues(
    MCattributeSet^ source,
    array<unsigned int>^ tags
)

Parameters

source
Type: Mergecom..::..MCattributeSet
The attribute set to copy values from.
tags
Type: array<System..::..UInt32>[]()[][]
The list of tag numbers of the attributes to be copied. If a tag is a group length tag, the attributes in the whole group are copied. If this parameter is null, all attributes are copied.

Remarks

This method can be used to fill in directory record values from messages when adding instances to a file set.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The source was null.
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


delete Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..delete Method
MCdicomDirRecord Class See Also Send Feedback
Deletes this directory record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void delete()
Visual Basic
Public Sub delete
Visual C++
public:
void delete()

Remarks

This method removes this directory record and any lower level record from the record hierarchy.

The changes made by this method are not reflected in the DICOMDIR file until the application calls update()()()() on the DICOM directory object.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


dispose Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..dispose Method
MCdicomDirRecord Class See Also Send Feedback
Disposes this record and its associated native resources.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void dispose()
Visual Basic
Public Overrides Sub dispose
Visual C++
public:
virtual void dispose() override

Remarks

This method releases the resources allocated for this record but it does not delete the record from the DICOMDIR file. Subsequent navigation to the record represented by this object will cause the toolkit to reload the content of the record from the file and create a new record object for it.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


traverse Method

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..traverse Method
MCdicomDirRecord Class See Also Send Feedback
Provides easy record traversal and search functionality.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void traverse(
    MCdicomDirRecord..::..RecordHandler handler
)
Visual Basic
Public Sub traverse ( _
    handler As MCdicomDirRecord..::..RecordHandler _
)
Visual C++
public:
void traverse(
    MCdicomDirRecord..::..RecordHandler^ handler
)

Parameters

handler
Type: Mergecom.Dicomdir..::..MCdicomDirRecord..::..RecordHandler
A delegate to be called for each record traversed.

Remarks

This method traverses all directory records that are below this directory record, or all records if this record is the root record.

The toolkit makes a depth-first traversal of the record hierarchy calling the record handler delegate for each record. The application can control the traversal through the return value of the delegate.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | The record handler argument was null.
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | A file read operation failed.
Mergecom.Exceptions..::..MCinvalidEncodingException | There was a problem decoding the DICOMDIR file. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | There is a problem with the structure of the DICOMDIR file.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


MCdicomDirRecord Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord Properties
MCdicomDirRecord Class See Also Send Feedback

The MCdicomDirRecord type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Gets or sets the value of the Accession Number (0008,0050) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Attributes | Gets a collection view of the attributes of this attribute set. (Inherited from MCattributeSet.)
Public property | Count | Gets the number of attributes in this set. (Inherited from MCattributeSet.)
Public property | DICOMDIR | Gets the directory object containing this record.
Public property | DirectoryRecordType | Gets or sets the value of the Directory Record Type (0004,1430) attribute of this record.
Public property | FirstLowerRecord | Gets the first lower level directory record of this record.
Public property | InstanceNumber | Gets or sets the value of the Instance Number (0020,0013) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | IsEmpty | Tells whether this attribute set is empty (no attributes). (Inherited from MCattributeSet.)
Public property | IsRoot | Tells whether this record is the root record of the DICODMIR.
Public property | Item[([( UInt32])]) | Gets or sets a non-private attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag])]) | Gets or sets an attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32])]) | Gets or sets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( UInt32, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Item[([( MCtag, Int32, Object])]) | Gets attribute values of this attribute set. (Inherited from MCattributeSet.)
Public property | Modality | Gets or sets the value of the Modality (0008,0060) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | NextRecord | Gets the next directory record in the directory entity of the current record.
Public property | ParentRecord | Gets the parent record of this record.
Public property | PatientID | Gets or sets the value of the Patient ID (0010,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | PatientsName | Gets or sets the value of the Patient's Name (0010,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | RecordType | Gets an enum representation of the value of the Directory Record Type (0004,1430) attribute of this record.
Public property | ReferencedFileID | Gets or sets the values of the Referenced File ID (0004,1500) attribute of this record.
Public property | ReferencedSOPClassUIDinFile | Gets or sets the value of the Referenced SOP Class UID in File (0004,1510) attribute of this record.
Public property | ReferencedSOPInstanceUIDinFile | Gets or sets the value of the Referenced SOP Instance UID in File (0004,1511) attribute of this record.
Public property | ReferencedTSUIDinFile | Gets or sets the value of the Referenced Transfer Syntax UID in File (0004,1512) attribute of this record.
Public property | SeriesDescription | Gets or sets the value of the Series Description (0008,103E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesInstanceUID | Gets or sets the value of the Series Instance UID (0020,000E) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SeriesNumber | Gets or sets the value of the Series Number (0020,0011) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPClassUID | Gets or sets the value of the SOP Class UID (0008,0016) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SOPInstanceUID | Gets or sets the value of the SOP Instance UID (0008,0018) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | SpecificCharacterSet | Gets or sets the values of the Specific Character Set (0008,0005) attribute. (Inherited from MCattributeSet.)
Public property | StudyDate | Gets or sets the value of the Study Date (0008,0020) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyDescription | Gets or sets the value of the Study Description (0008,1030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyID | Gets or sets the value of the Study ID (0020,0010) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyInstanceUID | Gets or sets the value of the Study Instance UID (0020,000D) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | StudyTime | Gets or sets the value of the Study Time (0008,0030) attribute of this attribute set. (Inherited from MCattributeSet.)
Public property | TransferSyntax | Gets or sets the transfer syntax used to encode or decode this attribute set. (Inherited from MCattributeSet.)

See Also

MCdicomDirRecord Class
Mergecom.Dicomdir Namespace


DICOMDIR Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..DICOMDIR Property
MCdicomDirRecord Class See Also Send Feedback
Gets the directory object containing this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdicomDir DICOMDIR { get; }
Visual Basic
Public Overridable ReadOnly Property DICOMDIR As MCdicomDir
    Get
Visual C++
public:
virtual property MCdicomDir^ DICOMDIR {
    MCdicomDir^ get ();
}

Field Value

The DICOMDIR object of this record.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


DirectoryRecordType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..DirectoryRecordType Property
MCdicomDirRecord Class See Also Send Feedback
Gets or sets the value of the Directory Record Type (0004,1430) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DirectoryRecordType { get; set; }
Visual Basic
Public Overridable Property DirectoryRecordType As String
    Get
    Set
Visual C++
public:
virtual property String^ DirectoryRecordType {
    String^ get ();
    void set (String^ value);
}

Field Value

A String object containing the record type.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


FirstLowerRecord Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..FirstLowerRecord Property
MCdicomDirRecord Class See Also Send Feedback
Gets the first lower level directory record of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdicomDirRecord FirstLowerRecord { get; }
Visual Basic
Public Overridable ReadOnly Property FirstLowerRecord As MCdicomDirRecord
    Get
Visual C++
public:
virtual property MCdicomDirRecord^ FirstLowerRecord {
    MCdicomDirRecord^ get ();
}

Field Value

The record object representing the first lower level record of this record or null if this record does not have lower level records.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | A file read operation failed.
Mergecom.Exceptions..::..MCinvalidEncodingException | There was a problem decoding the DICOMDIR file. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | There is a problem with the structure of the DICOMDIR file.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


IsRoot Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..IsRoot Property
MCdicomDirRecord Class See Also Send Feedback
Tells whether this record is the root record of the DICODMIR.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual bool IsRoot { get; }
Visual Basic
Public Overridable ReadOnly Property IsRoot As Boolean
    Get
Visual C++
public:
virtual property bool IsRoot {
    bool get ();
}

Field Value

true if this is the root record, false otherwise.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


NextRecord Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..NextRecord Property
MCdicomDirRecord Class See Also Send Feedback
Gets the next directory record in the directory entity of the current record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdicomDirRecord NextRecord { get; }
Visual Basic
Public Overridable ReadOnly Property NextRecord As MCdicomDirRecord
    Get
Visual C++
public:
virtual property MCdicomDirRecord^ NextRecord {
    MCdicomDirRecord^ get ();
}

Field Value

The record object following the current one in the record hierarchy or null if the current record is the last in the directory entity.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.
Mergecom.Exceptions..::..MCcallbackCannotComplyException | A file read operation failed.
Mergecom.Exceptions..::..MCinvalidEncodingException | There was a problem decoding the DICOMDIR file. A message describing the error has been written to the Merge DICOM toolkit log file.
Mergecom.Exceptions..::..MCdicomdirException | There is a problem with the structure of the DICOMDIR file.
Mergecom.Exceptions..::..MCnotInitializedError | The library has not been properly initialized.
Mergecom.Exceptions..::..MCruntimeException | An unexpected, potentially serious, problem was detected in the operating environment. A message describing the error has been written to the Merge DICOM toolkit log file.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


ParentRecord Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..ParentRecord Property
MCdicomDirRecord Class See Also Send Feedback
Gets the parent record of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdicomDirRecord ParentRecord { get; }
Visual Basic
Public Overridable ReadOnly Property ParentRecord As MCdicomDirRecord
    Get
Visual C++
public:
virtual property MCdicomDirRecord^ ParentRecord {
    MCdicomDirRecord^ get ();
}

Field Value

The record object that has this object in its lower level record list, or null if this record is the root record of the DICOMDIR.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record has been disposed.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


RecordType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..RecordType Property
MCdicomDirRecord Class See Also Send Feedback
Gets an enum representation of the value of the Directory Record Type (0004,1430) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual DirRecordType RecordType { get; }
Visual Basic
Public Overridable ReadOnly Property RecordType As DirRecordType
    Get
Visual C++
public:
virtual property DirRecordType RecordType {
    DirRecordType get ();
}

Field Value

The record type enum matching the value of the record type attribute.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


ReferencedFileID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..ReferencedFileID Property
MCdicomDirRecord Class See Also Send Feedback
Gets or sets the values of the Referenced File ID (0004,1500) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedFileID { get; set; }
Visual Basic
Public Overridable Property ReferencedFileID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedFileID {
    String^ get ();
    void set (String^ value);
}

Field Value

A string representation of the values of the Referenced File ID (0004,1500) attribute with each value separated by the backslash '\' character.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


ReferencedSOPClassUIDinFile Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..ReferencedSOPClassUIDinFile Property
MCdicomDirRecord Class See Also Send Feedback
Gets or sets the value of the Referenced SOP Class UID in File (0004,1510) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUIDinFile { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUIDinFile As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUIDinFile {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Referenced SOP Class UID in File (0004,1510) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


ReferencedSOPInstanceUIDinFile Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..ReferencedSOPInstanceUIDinFile Property
MCdicomDirRecord Class See Also Send Feedback
Gets or sets the value of the Referenced SOP Instance UID in File (0004,1511) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUIDinFile { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUIDinFile As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUIDinFile {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Referenced SOP Instance UID in File (0004,1511) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


ReferencedTSUIDinFile Property

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..ReferencedTSUIDinFile Property
MCdicomDirRecord Class See Also Send Feedback
Gets or sets the value of the Referenced Transfer Syntax UID in File (0004,1512) attribute of this record.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedTSUIDinFile { get; set; }
Visual Basic
Public Overridable Property ReferencedTSUIDinFile As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedTSUIDinFile {
    String^ get ();
    void set (String^ value);
}

Field Value

A string object containing the value of the Referenced Transfer Syntax UID in File (0004,1512) attribute, or null if the attribute has no value or it is missing.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnoAttributesException | The record object has been dispose.
Mergecom.Exceptions..::..MCinvalidEncodingWarning | The value contains invalid characters for the VR of the attribute.

See Also

MCdicomDirRecord Class
MCdicomDirRecord Members
Mergecom.Dicomdir Namespace


MCdicomDirRecord.RecordHandler Delegate

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..RecordHandler Delegate
MCdicomDirRecord Class See Also Send Feedback
Delegate called by the toolkit when visiting directory records as a result of traverse(MCdicomDirRecord..::..RecordHandler) call.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public delegate MCdicomDirRecord..::..TraversalStatus RecordHandler(
    MCdicomDirRecord currentRecord
)
Visual Basic
Public Delegate Function RecordHandler ( _
    currentRecord As MCdicomDirRecord _
) As MCdicomDirRecord..::..TraversalStatus
Visual C++
public delegate MCdicomDirRecord..::..TraversalStatus RecordHandler(
    MCdicomDirRecord^ currentRecord
)

Parameters

currentRecord
Type: Mergecom.Dicomdir..::..MCdicomDirRecord
The record currently being visited.

Return Value

The status indicating how the traversal should continue.

See Also

Mergecom.Dicomdir Namespace


MCdicomDirRecord.TraversalStatus Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCdicomDirRecord..::..TraversalStatus Enumeration
MCdicomDirRecord Class See Also Send Feedback
Enum for controlling directory record traversal when using the traverse(MCdicomDirRecord..::..RecordHandler) method.

Namespace: Mergecom.Dicomdir
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum TraversalStatus
Visual Basic
Public Enumeration TraversalStatus
Visual C++
public enum class TraversalStatus

Members

Member name | Value | Description
Continue | 0 | The traversal continues normally with the lower level records of the current record or with the next record if the current record does not have lower level records.
StopLevel | 1 | The traversal continues with the next record of the current record's parent, skipping all lower level records and next records of the current record.
StopLower | 2 | The traversal continues with the next record of the current record, skipping the current record's lower level records.
StopAll | 3 | Stop the traversal.

See Also

Mergecom.Dicomdir Namespace


Mergecom.Exceptions Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom.Exceptions Namespace
Send Feedback
This namespace contains classes related to exceptions defined by MergeCOM.

Classes

 | Class | Description
Public class | MCalreadyExistsException | Exception that indicates an element being added already exists.
Public class | MCalreadyInitializedException | Exception that indicates the MergeCOM library has already been initialized.
Public class | MCalreadyListeningException | Exception that indicates an application is already listening on a given port.
Public class | MCassociationAbortedException | Exception that indicates an association was aborted.
Public class | MCassociationRejectedException | Exception that indicates an association request has been rejected by the remote application.
Public class | MCassociationReleasedStatus | Exception that indicates an association was released (closed).
Public class | MCattributeNotFoundException | Exception that indicates an attribute was not in the data set.
Public class | MCcallbackCannotComplyException | Exception hat indicates a method of a callback class cannot comply with requirements of the interface.
Public class | MCcallbackInvalidArgumentException | Exception that indicates a callback routine returned an invalid value for an argument.
Public class | MCconfigFileErrorException | Exception thrown when the library is unable to access config files.
Public class | MCconfigurationError | Exception thrown when an error involving configuration files is detected.
Public class | MCconnectionFailedException | Exception thrown when a TCP/IP connection to a remote host failed.
Public class | MCdicomdirException | Exception thrown when a problem was experienced navigating a DICOMDIR.
Public class | MCdisposedException | Exception thrown when the application is trying to access an object that was disposed.
Public class | MCexception | Base class for predefined exceptions thrown by MergeCOM library.
Public class | MCillegalArgumentException | Exception thrown when an invalid argument was presented to a MergeCOM class library method.
Public class | MCinactivityTimeoutException | Exception thrown when too much time elapsed with no network activity.
Public class | MCincompatibleValueException | Exception thrown when a value is incompatible with the DICOM Value Representation.
Public class | MCinvalidCharacterEncodingWarning | Exception thrown when a value contains characters incompatible with an attribute's Value Representation.
Public class | MCinvalidDirRecordTypeException | Exception thrown when an attempt to use an invalid record type string for a DICOMDIR directory record.
Public class | MCinvalidEncodingException | Exception thrown when an invalid DICOM encoding is encountered.
Public class | MCinvalidEncodingWarning | Exception thrown when a value contained characters incompatible with an attribute's Value Representation.
Public class | MCinvalidFormatEncodingWarning | Exception thrown when a value has a format incompatible with an attribute's Value Representation.
Public class | MCinvalidLengthEncodingWarning | Exception thrown when a value has a length incompatible with an attribute's Value Representation.
Public class | MCinvalidLicenseInfoError | Exception thrown when there is invalid license info in configuration files.
Public class | MCinvalidMessageReceivedException | Exception thrown when an invalid DIMSE message was received.
Public class | MCinvalidTransferSyntaxException | Exception thrown when an invalid transfer syntax was encountered.
Public class | MClostConnectionException | Exception thrown when the connection for an association is lost.
Public class | MCmaxOperationsExceededWarning | Exception that is thrown when sending a DICOM message over an association would cause the maximum operations negotiated for an associations to be exceeded.
Public class | MCnegotiationAbortedException | Exception thrown when an association request was aborted before it could complete.
Public class | MCnetworkShutdownException | Exception thrown when the network unexpectedly shut down.
Public class | MCnoAttributesException | Exception thrown when there are no attributes in an attribute set.
Public class | MCnoSuchValueException | Exception thrown when a specified attribute value does not exist.
Public class | MCnotFoundException | Exception thrown when something requested could not be found.
Public class | MCnotInitializedError | Exception thrown when the MergeCOM library has not yet been initialized or it has been released.
Public class | MCnotStandardElementException | Exception thrown when a non-standard data element was specified when a standard element was required.
Public class | MCoperationNotAllowedException | Exception thrown when an attempt was made to perform an operation that is not allowed in the current context.
Public class | MCrequiredAttributeMissingException | Exception thrown when a required attribute is missing from a DIMSE message.
Public class | MCruntimeException | Represents a general error condition that is not specific to the operation that caused it.
Public class | MCseverity | Represents the severity of a MergeCOM exception.
Public class | MCtimeoutException | Exception thrown when a timeout has occurred.
Public class | MCunacceptableServiceException | Exception thrown when an attempt was made to send a DIMSE message for a service that was not successfully negotiated.
Public class | MCunknownHostNameException | Exception thrown when an attempt to connect to an unknown host.


MCalreadyExistsException Class

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Class
Members See Also Send Feedback
Exception that indicates an element being added already exists.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCalreadyExistsException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCalreadyExistsException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCalreadyExistsException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCalreadyExistsException

See Also

MCalreadyExistsException Members
Mergecom.Exceptions Namespace


MCalreadyExistsException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Members
MCalreadyExistsException Class Constructors Methods Fields Properties See Also Send Feedback

The MCalreadyExistsException type exposes the following members.

Constructors

 | Name | Description
Public method | MCalreadyExistsException()()()() | Initializes a new instance of this class.
Public method | MCalreadyExistsException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyExistsException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyExistsException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyExistsException Class
Mergecom.Exceptions Namespace


MCalreadyExistsException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Constructor
MCalreadyExistsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCalreadyExistsException()()()() | Initializes a new instance of this class.
Public method | MCalreadyExistsException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyExistsException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyExistsException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCalreadyExistsException Class
MCalreadyExistsException Members
Mergecom.Exceptions Namespace


MCalreadyExistsException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Constructor
MCalreadyExistsException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyExistsException()
Visual Basic
Public Sub New
Visual C++
public:
MCalreadyExistsException()

Remarks

The exception number will be set to MCexception.ALREADY_EXISTS.

See Also

MCalreadyExistsException Class
MCalreadyExistsException Members
MCalreadyExistsException Overload
Mergecom.Exceptions Namespace


MCalreadyExistsException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Constructor (String)
MCalreadyExistsException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyExistsException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCalreadyExistsException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ALREADY_EXISTS.

See Also

MCalreadyExistsException Class
MCalreadyExistsException Members
MCalreadyExistsException Overload
Mergecom.Exceptions Namespace


MCalreadyExistsException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Constructor (SerializationInfo, StreamingContext)
MCalreadyExistsException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCalreadyExistsException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCalreadyExistsException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCalreadyExistsException Class
MCalreadyExistsException Members
MCalreadyExistsException Overload
Mergecom.Exceptions Namespace


MCalreadyExistsException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Constructor (String, Exception)
MCalreadyExistsException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyExistsException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCalreadyExistsException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ALREADY_EXISTS.

See Also

MCalreadyExistsException Class
MCalreadyExistsException Members
MCalreadyExistsException Overload
Mergecom.Exceptions Namespace


MCalreadyExistsException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Fields
MCalreadyExistsException Class See Also Send Feedback

The MCalreadyExistsException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCalreadyExistsException Class
Mergecom.Exceptions Namespace


MCalreadyExistsException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Methods
MCalreadyExistsException Class See Also Send Feedback

The MCalreadyExistsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCalreadyExistsException Class
Mergecom.Exceptions Namespace


MCalreadyExistsException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyExistsException Properties
MCalreadyExistsException Class See Also Send Feedback

The MCalreadyExistsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyExistsException Class
Mergecom.Exceptions Namespace


MCalreadyInitializedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Class
Members See Also Send Feedback
Exception that indicates the MergeCOM library has already been initialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCalreadyInitializedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCalreadyInitializedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCalreadyInitializedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCalreadyInitializedException

See Also

MCalreadyInitializedException Members
Mergecom.Exceptions Namespace


MCalreadyInitializedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Members
MCalreadyInitializedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCalreadyInitializedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCalreadyInitializedException()()()() | Initializes a new instance of this class.
Public method | MCalreadyInitializedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyInitializedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyInitializedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyInitializedException Class
Mergecom.Exceptions Namespace


MCalreadyInitializedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Constructor
MCalreadyInitializedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCalreadyInitializedException()()()() | Initializes a new instance of this class.
Public method | MCalreadyInitializedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyInitializedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyInitializedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCalreadyInitializedException Class
MCalreadyInitializedException Members
Mergecom.Exceptions Namespace


MCalreadyInitializedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Constructor
MCalreadyInitializedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyInitializedException()
Visual Basic
Public Sub New
Visual C++
public:
MCalreadyInitializedException()

Remarks

The exception number will be set to MCexception.ALREADY_INITIALIZED_EXCEPTION.

See Also

MCalreadyInitializedException Class
MCalreadyInitializedException Members
MCalreadyInitializedException Overload
Mergecom.Exceptions Namespace


MCalreadyInitializedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Constructor (String)
MCalreadyInitializedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyInitializedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCalreadyInitializedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ALREADY_INITIALIZED_EXCEPTION.

See Also

MCalreadyInitializedException Class
MCalreadyInitializedException Members
MCalreadyInitializedException Overload
Mergecom.Exceptions Namespace


MCalreadyInitializedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Constructor (SerializationInfo, StreamingContext)
MCalreadyInitializedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCalreadyInitializedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCalreadyInitializedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCalreadyInitializedException Class
MCalreadyInitializedException Members
MCalreadyInitializedException Overload
Mergecom.Exceptions Namespace


MCalreadyInitializedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Constructor (String, Exception)
MCalreadyInitializedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyInitializedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCalreadyInitializedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ALREADY_INITIALIZED_EXCEPTION.

See Also

MCalreadyInitializedException Class
MCalreadyInitializedException Members
MCalreadyInitializedException Overload
Mergecom.Exceptions Namespace


MCalreadyInitializedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Fields
MCalreadyInitializedException Class See Also Send Feedback

The MCalreadyInitializedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCalreadyInitializedException Class
Mergecom.Exceptions Namespace


MCalreadyInitializedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Methods
MCalreadyInitializedException Class See Also Send Feedback

The MCalreadyInitializedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCalreadyInitializedException Class
Mergecom.Exceptions Namespace


MCalreadyInitializedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyInitializedException Properties
MCalreadyInitializedException Class See Also Send Feedback

The MCalreadyInitializedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyInitializedException Class
Mergecom.Exceptions Namespace


MCalreadyListeningException Class

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Class
Members See Also Send Feedback
Exception that indicates an application is already listening on a given port.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCalreadyListeningException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCalreadyListeningException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCalreadyListeningException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCalreadyListeningException

See Also

MCalreadyListeningException Members
Mergecom.Exceptions Namespace


MCalreadyListeningException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Members
MCalreadyListeningException Class Constructors Methods Fields Properties See Also Send Feedback

The MCalreadyListeningException type exposes the following members.

Constructors

 | Name | Description
Public method | MCalreadyListeningException()()()() | Initializes a new instance of this class.
Public method | MCalreadyListeningException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyListeningException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyListeningException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyListeningException Class
Mergecom.Exceptions Namespace


MCalreadyListeningException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Constructor
MCalreadyListeningException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCalreadyListeningException()()()() | Initializes a new instance of this class.
Public method | MCalreadyListeningException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCalreadyListeningException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCalreadyListeningException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCalreadyListeningException Class
MCalreadyListeningException Members
Mergecom.Exceptions Namespace


MCalreadyListeningException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Constructor
MCalreadyListeningException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyListeningException()
Visual Basic
Public Sub New
Visual C++
public:
MCalreadyListeningException()

Remarks

The exception number will be set to MCexception.ALREADY_LISTENING.

See Also

MCalreadyListeningException Class
MCalreadyListeningException Members
MCalreadyListeningException Overload
Mergecom.Exceptions Namespace


MCalreadyListeningException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Constructor (String)
MCalreadyListeningException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyListeningException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCalreadyListeningException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ALREADY_LISTENING.

See Also

MCalreadyListeningException Class
MCalreadyListeningException Members
MCalreadyListeningException Overload
Mergecom.Exceptions Namespace


MCalreadyListeningException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Constructor (SerializationInfo, StreamingContext)
MCalreadyListeningException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCalreadyListeningException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCalreadyListeningException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCalreadyListeningException Class
MCalreadyListeningException Members
MCalreadyListeningException Overload
Mergecom.Exceptions Namespace


MCalreadyListeningException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Constructor (String, Exception)
MCalreadyListeningException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCalreadyListeningException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCalreadyListeningException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ALREADY_LISTENING.

See Also

MCalreadyListeningException Class
MCalreadyListeningException Members
MCalreadyListeningException Overload
Mergecom.Exceptions Namespace


MCalreadyListeningException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Fields
MCalreadyListeningException Class See Also Send Feedback

The MCalreadyListeningException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCalreadyListeningException Class
Mergecom.Exceptions Namespace


MCalreadyListeningException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Methods
MCalreadyListeningException Class See Also Send Feedback

The MCalreadyListeningException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCalreadyListeningException Class
Mergecom.Exceptions Namespace


MCalreadyListeningException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCalreadyListeningException Properties
MCalreadyListeningException Class See Also Send Feedback

The MCalreadyListeningException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCalreadyListeningException Class
Mergecom.Exceptions Namespace


MCassociationAbortedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Class
Members See Also Send Feedback
Exception that indicates an association was aborted.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCassociationAbortedException : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCassociationAbortedException _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCassociationAbortedException : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCassociationAbortedException

See Also

MCassociationAbortedException Members
Mergecom.Exceptions Namespace


MCassociationAbortedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Members
MCassociationAbortedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCassociationAbortedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCassociationAbortedException()()()() | Initializes a new instance of this class.
Public method | MCassociationAbortedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationAbortedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCassociationAbortedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationAbortedException Class
Mergecom.Exceptions Namespace


MCassociationAbortedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Constructor
MCassociationAbortedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCassociationAbortedException()()()() | Initializes a new instance of this class.
Public method | MCassociationAbortedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationAbortedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCassociationAbortedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCassociationAbortedException Class
MCassociationAbortedException Members
Mergecom.Exceptions Namespace


MCassociationAbortedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Constructor
MCassociationAbortedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationAbortedException()
Visual Basic
Public Sub New
Visual C++
public:
MCassociationAbortedException()

Remarks

The exception number will be set to MCexception.ASSOCIATION_ABORTED.

See Also

MCassociationAbortedException Class
MCassociationAbortedException Members
MCassociationAbortedException Overload
Mergecom.Exceptions Namespace


MCassociationAbortedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Constructor (String)
MCassociationAbortedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationAbortedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCassociationAbortedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ASSOCIATION_ABORTED.

See Also

MCassociationAbortedException Class
MCassociationAbortedException Members
MCassociationAbortedException Overload
Mergecom.Exceptions Namespace


MCassociationAbortedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Constructor (SerializationInfo, StreamingContext)
MCassociationAbortedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCassociationAbortedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCassociationAbortedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCassociationAbortedException Class
MCassociationAbortedException Members
MCassociationAbortedException Overload
Mergecom.Exceptions Namespace


MCassociationAbortedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Constructor (String, Exception)
MCassociationAbortedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationAbortedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCassociationAbortedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ASSOCIATION_ABORTED.

See Also

MCassociationAbortedException Class
MCassociationAbortedException Members
MCassociationAbortedException Overload
Mergecom.Exceptions Namespace


MCassociationAbortedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Fields
MCassociationAbortedException Class See Also Send Feedback

The MCassociationAbortedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCassociationAbortedException Class
Mergecom.Exceptions Namespace


MCassociationAbortedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Methods
MCassociationAbortedException Class See Also Send Feedback

The MCassociationAbortedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCassociationAbortedException Class
Mergecom.Exceptions Namespace


MCassociationAbortedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationAbortedException Properties
MCassociationAbortedException Class See Also Send Feedback

The MCassociationAbortedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationAbortedException Class
Mergecom.Exceptions Namespace


MCassociationRejectedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Class
Members See Also Send Feedback
Exception that indicates an association request has been rejected by the remote application.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCassociationRejectedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCassociationRejectedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCassociationRejectedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCassociationRejectedException

See Also

MCassociationRejectedException Members
Mergecom.Exceptions Namespace


MCassociationRejectedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Members
MCassociationRejectedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCassociationRejectedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCassociationRejectedException()()()() | Initializes a new instance of this class.
Public method | MCassociationRejectedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationRejectedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCassociationRejectedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | RejectInfo | This property contains the information describing the circumstances and reasons that an association requests was rejected.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationRejectedException Class
Mergecom.Exceptions Namespace


MCassociationRejectedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Constructor
MCassociationRejectedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCassociationRejectedException()()()() | Initializes a new instance of this class.
Public method | MCassociationRejectedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationRejectedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCassociationRejectedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
Mergecom.Exceptions Namespace


MCassociationRejectedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Constructor
MCassociationRejectedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationRejectedException()
Visual Basic
Public Sub New
Visual C++
public:
MCassociationRejectedException()

Remarks

The exception number will be set to MCexception.ASSOCIATION_REJECTED.

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
MCassociationRejectedException Overload
Mergecom.Exceptions Namespace


MCassociationRejectedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Constructor (String)
MCassociationRejectedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationRejectedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCassociationRejectedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ASSOCIATION_REJECTED.

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
MCassociationRejectedException Overload
Mergecom.Exceptions Namespace


MCassociationRejectedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Constructor (SerializationInfo, StreamingContext)
MCassociationRejectedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCassociationRejectedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCassociationRejectedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
MCassociationRejectedException Overload
Mergecom.Exceptions Namespace


MCassociationRejectedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Constructor (String, Exception)
MCassociationRejectedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationRejectedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCassociationRejectedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ASSOCIATION_REJECTED.

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
MCassociationRejectedException Overload
Mergecom.Exceptions Namespace


MCassociationRejectedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Fields
MCassociationRejectedException Class See Also Send Feedback

The MCassociationRejectedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCassociationRejectedException Class
Mergecom.Exceptions Namespace


MCassociationRejectedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Methods
MCassociationRejectedException Class See Also Send Feedback

The MCassociationRejectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCassociationRejectedException Class
Mergecom.Exceptions Namespace


MCassociationRejectedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException Properties
MCassociationRejectedException Class See Also Send Feedback

The MCassociationRejectedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | RejectInfo | This property contains the information describing the circumstances and reasons that an association requests was rejected.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationRejectedException Class
Mergecom.Exceptions Namespace


RejectInfo Property

[image]

Merge DICOM .NET/C# Toolkit
MCassociationRejectedException..::..RejectInfo Property
MCassociationRejectedException Class See Also Send Feedback
This property contains the information describing the circumstances and reasons that an association requests was rejected.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassocRejectInfo RejectInfo { get; }
Visual Basic
Public ReadOnly Property RejectInfo As MCassocRejectInfo
    Get
Visual C++
public:
property MCassocRejectInfo^ RejectInfo {
    MCassocRejectInfo^ get ();
}

See Also

MCassociationRejectedException Class
MCassociationRejectedException Members
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Class

[image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Class
Members See Also Send Feedback
Exception that indicates an association was released (closed).

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCassociationReleasedStatus : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCassociationReleasedStatus _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCassociationReleasedStatus : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCassociationReleasedStatus

See Also

MCassociationReleasedStatus Members
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Members
MCassociationReleasedStatus Class Constructors Methods Fields Properties See Also Send Feedback

The MCassociationReleasedStatus type exposes the following members.

Constructors

 | Name | Description
Public method | MCassociationReleasedStatus()()()() | Initializes a new instance of this class.
Public method | MCassociationReleasedStatus(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationReleasedStatus(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationReleasedStatus Class
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Constructor
MCassociationReleasedStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCassociationReleasedStatus()()()() | Initializes a new instance of this class.
Public method | MCassociationReleasedStatus(String) | Initializes a new instance of this class for a given error message.
Protected method | MCassociationReleasedStatus(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.

See Also

MCassociationReleasedStatus Class
MCassociationReleasedStatus Members
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Constructor
MCassociationReleasedStatus Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationReleasedStatus()
Visual Basic
Public Sub New
Visual C++
public:
MCassociationReleasedStatus()

Remarks

The exception number will be set to MCexception.ASSOCIATION_RELEASED.

See Also

MCassociationReleasedStatus Class
MCassociationReleasedStatus Members
MCassociationReleasedStatus Overload
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Constructor (String)
MCassociationReleasedStatus Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCassociationReleasedStatus(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCassociationReleasedStatus(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ASSOCIATION_RELEASED.

See Also

MCassociationReleasedStatus Class
MCassociationReleasedStatus Members
MCassociationReleasedStatus Overload
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Constructor (SerializationInfo, StreamingContext)
MCassociationReleasedStatus Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCassociationReleasedStatus(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCassociationReleasedStatus(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCassociationReleasedStatus Class
MCassociationReleasedStatus Members
MCassociationReleasedStatus Overload
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Fields
MCassociationReleasedStatus Class See Also Send Feedback

The MCassociationReleasedStatus type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCassociationReleasedStatus Class
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Methods
MCassociationReleasedStatus Class See Also Send Feedback

The MCassociationReleasedStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCassociationReleasedStatus Class
Mergecom.Exceptions Namespace


MCassociationReleasedStatus Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCassociationReleasedStatus Properties
MCassociationReleasedStatus Class See Also Send Feedback

The MCassociationReleasedStatus type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCassociationReleasedStatus Class
Mergecom.Exceptions Namespace


MCattributeNotFoundException Class

[image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Class
Members See Also Send Feedback
Exception that indicates an attribute was not in the data set.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCattributeNotFoundException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCattributeNotFoundException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCattributeNotFoundException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCattributeNotFoundException

See Also

MCattributeNotFoundException Members
Mergecom.Exceptions Namespace


MCattributeNotFoundException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Members
MCattributeNotFoundException Class Constructors Methods Fields Properties See Also Send Feedback

The MCattributeNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | MCattributeNotFoundException()()()() | Initializes a new instance of this class.
Public method | MCattributeNotFoundException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCattributeNotFoundException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCattributeNotFoundException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCattributeNotFoundException Class
Mergecom.Exceptions Namespace


MCattributeNotFoundException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Constructor
MCattributeNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCattributeNotFoundException()()()() | Initializes a new instance of this class.
Public method | MCattributeNotFoundException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCattributeNotFoundException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCattributeNotFoundException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCattributeNotFoundException Class
MCattributeNotFoundException Members
Mergecom.Exceptions Namespace


MCattributeNotFoundException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Constructor
MCattributeNotFoundException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattributeNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
MCattributeNotFoundException()

Remarks

The exception number will be set to MCexception.ATTRIBUTE_NOT_FOUND.

See Also

MCattributeNotFoundException Class
MCattributeNotFoundException Members
MCattributeNotFoundException Overload
Mergecom.Exceptions Namespace


MCattributeNotFoundException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Constructor (String)
MCattributeNotFoundException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattributeNotFoundException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCattributeNotFoundException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ATTRIBUTE_NOT_FOUND.

See Also

MCattributeNotFoundException Class
MCattributeNotFoundException Members
MCattributeNotFoundException Overload
Mergecom.Exceptions Namespace


MCattributeNotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Constructor (SerializationInfo, StreamingContext)
MCattributeNotFoundException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCattributeNotFoundException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCattributeNotFoundException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCattributeNotFoundException Class
MCattributeNotFoundException Members
MCattributeNotFoundException Overload
Mergecom.Exceptions Namespace


MCattributeNotFoundException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Constructor (String, Exception)
MCattributeNotFoundException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattributeNotFoundException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCattributeNotFoundException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ATTRIBUTE_NOT_FOUND.

See Also

MCattributeNotFoundException Class
MCattributeNotFoundException Members
MCattributeNotFoundException Overload
Mergecom.Exceptions Namespace


MCattributeNotFoundException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Fields
MCattributeNotFoundException Class See Also Send Feedback

The MCattributeNotFoundException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCattributeNotFoundException Class
Mergecom.Exceptions Namespace


MCattributeNotFoundException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Methods
MCattributeNotFoundException Class See Also Send Feedback

The MCattributeNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCattributeNotFoundException Class
Mergecom.Exceptions Namespace


MCattributeNotFoundException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCattributeNotFoundException Properties
MCattributeNotFoundException Class See Also Send Feedback

The MCattributeNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCattributeNotFoundException Class
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Class

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Class
Members See Also Send Feedback
Exception hat indicates a method of a callback class cannot comply with requirements of the interface.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCcallbackCannotComplyException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCcallbackCannotComplyException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCcallbackCannotComplyException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCcallbackCannotComplyException

See Also

MCcallbackCannotComplyException Members
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Members
MCcallbackCannotComplyException Class Constructors Methods Fields Properties See Also Send Feedback

The MCcallbackCannotComplyException type exposes the following members.

Constructors

 | Name | Description
Public method | MCcallbackCannotComplyException()()()() | Initializes a new instance of this class.
Public method | MCcallbackCannotComplyException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCcallbackCannotComplyException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCcallbackCannotComplyException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCcallbackCannotComplyException Class
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Constructor
MCcallbackCannotComplyException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcallbackCannotComplyException()()()() | Initializes a new instance of this class.
Public method | MCcallbackCannotComplyException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCcallbackCannotComplyException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCcallbackCannotComplyException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCcallbackCannotComplyException Class
MCcallbackCannotComplyException Members
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Constructor
MCcallbackCannotComplyException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackCannotComplyException()
Visual Basic
Public Sub New
Visual C++
public:
MCcallbackCannotComplyException()

Remarks

The exception number will be set to MCexception.CALLBACK_CANNOT_COMPLY.

See Also

MCcallbackCannotComplyException Class
MCcallbackCannotComplyException Members
MCcallbackCannotComplyException Overload
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Constructor (String)
MCcallbackCannotComplyException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackCannotComplyException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCcallbackCannotComplyException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.CALLBACK_CANNOT_COMPLY.

See Also

MCcallbackCannotComplyException Class
MCcallbackCannotComplyException Members
MCcallbackCannotComplyException Overload
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Constructor (SerializationInfo, StreamingContext)
MCcallbackCannotComplyException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCcallbackCannotComplyException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCcallbackCannotComplyException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCcallbackCannotComplyException Class
MCcallbackCannotComplyException Members
MCcallbackCannotComplyException Overload
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Constructor (String, Exception)
MCcallbackCannotComplyException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackCannotComplyException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCcallbackCannotComplyException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.CALLBACK_CANNOT_COMPLY.

See Also

MCcallbackCannotComplyException Class
MCcallbackCannotComplyException Members
MCcallbackCannotComplyException Overload
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Fields
MCcallbackCannotComplyException Class See Also Send Feedback

The MCcallbackCannotComplyException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCcallbackCannotComplyException Class
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Methods
MCcallbackCannotComplyException Class See Also Send Feedback

The MCcallbackCannotComplyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCcallbackCannotComplyException Class
Mergecom.Exceptions Namespace


MCcallbackCannotComplyException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackCannotComplyException Properties
MCcallbackCannotComplyException Class See Also Send Feedback

The MCcallbackCannotComplyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCcallbackCannotComplyException Class
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Class

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Class
Members See Also Send Feedback
Exception that indicates a callback routine returned an invalid value for an argument.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCcallbackInvalidArgumentException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCcallbackInvalidArgumentException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCcallbackInvalidArgumentException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException

See Also

MCcallbackInvalidArgumentException Members
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Members
MCcallbackInvalidArgumentException Class Constructors Methods Fields Properties See Also Send Feedback

The MCcallbackInvalidArgumentException type exposes the following members.

Constructors

 | Name | Description
Public method | MCcallbackInvalidArgumentException()()()() | Initializes a new instance of this class.
Public method | MCcallbackInvalidArgumentException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCcallbackInvalidArgumentException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCcallbackInvalidArgumentException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCcallbackInvalidArgumentException Class
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Constructor
MCcallbackInvalidArgumentException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcallbackInvalidArgumentException()()()() | Initializes a new instance of this class.
Public method | MCcallbackInvalidArgumentException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCcallbackInvalidArgumentException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCcallbackInvalidArgumentException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCcallbackInvalidArgumentException Class
MCcallbackInvalidArgumentException Members
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Constructor
MCcallbackInvalidArgumentException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackInvalidArgumentException()
Visual Basic
Public Sub New
Visual C++
public:
MCcallbackInvalidArgumentException()

Remarks

The exception number will be set to MCexception.CALLBACK_INVALID_ARGUMENT.

See Also

MCcallbackInvalidArgumentException Class
MCcallbackInvalidArgumentException Members
MCcallbackInvalidArgumentException Overload
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Constructor (String)
MCcallbackInvalidArgumentException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackInvalidArgumentException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCcallbackInvalidArgumentException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.CALLBACK_INVALID_ARGUMENT.

See Also

MCcallbackInvalidArgumentException Class
MCcallbackInvalidArgumentException Members
MCcallbackInvalidArgumentException Overload
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Constructor (SerializationInfo, StreamingContext)
MCcallbackInvalidArgumentException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCcallbackInvalidArgumentException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCcallbackInvalidArgumentException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCcallbackInvalidArgumentException Class
MCcallbackInvalidArgumentException Members
MCcallbackInvalidArgumentException Overload
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Constructor (String, Exception)
MCcallbackInvalidArgumentException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcallbackInvalidArgumentException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCcallbackInvalidArgumentException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.CALLBACK_INVALID_ARGUMENT.

See Also

MCcallbackInvalidArgumentException Class
MCcallbackInvalidArgumentException Members
MCcallbackInvalidArgumentException Overload
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Fields
MCcallbackInvalidArgumentException Class See Also Send Feedback

The MCcallbackInvalidArgumentException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCcallbackInvalidArgumentException Class
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Methods
MCcallbackInvalidArgumentException Class See Also Send Feedback

The MCcallbackInvalidArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCcallbackInvalidArgumentException Class
Mergecom.Exceptions Namespace


MCcallbackInvalidArgumentException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcallbackInvalidArgumentException Properties
MCcallbackInvalidArgumentException Class See Also Send Feedback

The MCcallbackInvalidArgumentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCcallbackInvalidArgumentException Class
Mergecom.Exceptions Namespace


MCconfigFileErrorException Class

[image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Class
Members See Also Send Feedback
Exception thrown when the library is unable to access config files.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCconfigFileErrorException : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCconfigFileErrorException _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCconfigFileErrorException : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCconfigFileErrorException

See Also

MCconfigFileErrorException Members
Mergecom.Exceptions Namespace


MCconfigFileErrorException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Members
MCconfigFileErrorException Class Constructors Methods Fields Properties See Also Send Feedback

The MCconfigFileErrorException type exposes the following members.

Constructors

 | Name | Description
Public method | MCconfigFileErrorException()()()() | Initializes a new instance of this class.
Public method | MCconfigFileErrorException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconfigFileErrorException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconfigFileErrorException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconfigFileErrorException Class
Mergecom.Exceptions Namespace


MCconfigFileErrorException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Constructor
MCconfigFileErrorException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCconfigFileErrorException()()()() | Initializes a new instance of this class.
Public method | MCconfigFileErrorException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconfigFileErrorException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconfigFileErrorException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCconfigFileErrorException Class
MCconfigFileErrorException Members
Mergecom.Exceptions Namespace


MCconfigFileErrorException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Constructor
MCconfigFileErrorException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigFileErrorException()
Visual Basic
Public Sub New
Visual C++
public:
MCconfigFileErrorException()

Remarks

The exception number will be set to MCexception.CONFIG_INFO_ERROR.

See Also

MCconfigFileErrorException Class
MCconfigFileErrorException Members
MCconfigFileErrorException Overload
Mergecom.Exceptions Namespace


MCconfigFileErrorException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Constructor (String)
MCconfigFileErrorException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigFileErrorException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCconfigFileErrorException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.CONFIG_INFO_ERROR.

See Also

MCconfigFileErrorException Class
MCconfigFileErrorException Members
MCconfigFileErrorException Overload
Mergecom.Exceptions Namespace


MCconfigFileErrorException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Constructor (SerializationInfo, StreamingContext)
MCconfigFileErrorException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCconfigFileErrorException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCconfigFileErrorException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCconfigFileErrorException Class
MCconfigFileErrorException Members
MCconfigFileErrorException Overload
Mergecom.Exceptions Namespace


MCconfigFileErrorException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Constructor (String, Exception)
MCconfigFileErrorException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigFileErrorException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCconfigFileErrorException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.CONFIG_INFO_ERROR.

See Also

MCconfigFileErrorException Class
MCconfigFileErrorException Members
MCconfigFileErrorException Overload
Mergecom.Exceptions Namespace


MCconfigFileErrorException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Fields
MCconfigFileErrorException Class See Also Send Feedback

The MCconfigFileErrorException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCconfigFileErrorException Class
Mergecom.Exceptions Namespace


MCconfigFileErrorException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Methods
MCconfigFileErrorException Class See Also Send Feedback

The MCconfigFileErrorException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCconfigFileErrorException Class
Mergecom.Exceptions Namespace


MCconfigFileErrorException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigFileErrorException Properties
MCconfigFileErrorException Class See Also Send Feedback

The MCconfigFileErrorException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconfigFileErrorException Class
Mergecom.Exceptions Namespace


MCconfigurationError Class

[image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Class
Members See Also Send Feedback
Exception thrown when an error involving configuration files is detected.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCconfigurationError : MCruntimeException
Visual Basic
<SerializableAttribute> _
Public Class MCconfigurationError _
    Inherits MCruntimeException
Visual C++
[SerializableAttribute]
public ref class MCconfigurationError : public MCruntimeException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCruntimeException
Mergecom.Exceptions..::..MCconfigurationError

See Also

MCconfigurationError Members
Mergecom.Exceptions Namespace


MCconfigurationError Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Members
MCconfigurationError Class Constructors Methods Fields Properties See Also Send Feedback

The MCconfigurationError type exposes the following members.

Constructors

 | Name | Description
Public method | MCconfigurationError()()()() | Initializes a new instance of this class.
Public method | MCconfigurationError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconfigurationError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconfigurationError(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconfigurationError Class
Mergecom.Exceptions Namespace


MCconfigurationError Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Constructor
MCconfigurationError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCconfigurationError()()()() | Initializes a new instance of this class.
Public method | MCconfigurationError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconfigurationError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconfigurationError(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCconfigurationError Class
MCconfigurationError Members
Mergecom.Exceptions Namespace


MCconfigurationError Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Constructor
MCconfigurationError Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigurationError()
Visual Basic
Public Sub New
Visual C++
public:
MCconfigurationError()

Remarks

The exception number will be set to MCexception.CONFIGURATION_ERROR.

See Also

MCconfigurationError Class
MCconfigurationError Members
MCconfigurationError Overload
Mergecom.Exceptions Namespace


MCconfigurationError Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Constructor (String)
MCconfigurationError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigurationError(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCconfigurationError(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.CONFIGURATION_ERROR.

See Also

MCconfigurationError Class
MCconfigurationError Members
MCconfigurationError Overload
Mergecom.Exceptions Namespace


MCconfigurationError Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Constructor (SerializationInfo, StreamingContext)
MCconfigurationError Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCconfigurationError(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCconfigurationError(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCconfigurationError Class
MCconfigurationError Members
MCconfigurationError Overload
Mergecom.Exceptions Namespace


MCconfigurationError Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Constructor (String, Exception)
MCconfigurationError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconfigurationError(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCconfigurationError(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.CONFIGURATION_ERROR.

See Also

MCconfigurationError Class
MCconfigurationError Members
MCconfigurationError Overload
Mergecom.Exceptions Namespace


MCconfigurationError Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Fields
MCconfigurationError Class See Also Send Feedback

The MCconfigurationError type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCconfigurationError Class
Mergecom.Exceptions Namespace


MCconfigurationError Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Methods
MCconfigurationError Class See Also Send Feedback

The MCconfigurationError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCconfigurationError Class
Mergecom.Exceptions Namespace


MCconfigurationError Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconfigurationError Properties
MCconfigurationError Class See Also Send Feedback

The MCconfigurationError type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconfigurationError Class
Mergecom.Exceptions Namespace


MCconnectionFailedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Class
Members See Also Send Feedback
Exception thrown when a TCP/IP connection to a remote host failed.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCconnectionFailedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCconnectionFailedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCconnectionFailedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCconnectionFailedException

See Also

MCconnectionFailedException Members
Mergecom.Exceptions Namespace


MCconnectionFailedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Members
MCconnectionFailedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCconnectionFailedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCconnectionFailedException()()()() | Initializes a new instance of this class.
Public method | MCconnectionFailedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconnectionFailedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconnectionFailedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconnectionFailedException Class
Mergecom.Exceptions Namespace


MCconnectionFailedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Constructor
MCconnectionFailedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCconnectionFailedException()()()() | Initializes a new instance of this class.
Public method | MCconnectionFailedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCconnectionFailedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCconnectionFailedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCconnectionFailedException Class
MCconnectionFailedException Members
Mergecom.Exceptions Namespace


MCconnectionFailedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Constructor
MCconnectionFailedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconnectionFailedException()
Visual Basic
Public Sub New
Visual C++
public:
MCconnectionFailedException()

Remarks

The exception number will be set to MCexception.CONNECTION_FAILED.

See Also

MCconnectionFailedException Class
MCconnectionFailedException Members
MCconnectionFailedException Overload
Mergecom.Exceptions Namespace


MCconnectionFailedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Constructor (String)
MCconnectionFailedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconnectionFailedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCconnectionFailedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.CONNECTION_FAILED.

See Also

MCconnectionFailedException Class
MCconnectionFailedException Members
MCconnectionFailedException Overload
Mergecom.Exceptions Namespace


MCconnectionFailedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Constructor (SerializationInfo, StreamingContext)
MCconnectionFailedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCconnectionFailedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCconnectionFailedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCconnectionFailedException Class
MCconnectionFailedException Members
MCconnectionFailedException Overload
Mergecom.Exceptions Namespace


MCconnectionFailedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Constructor (String, Exception)
MCconnectionFailedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconnectionFailedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCconnectionFailedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.CONNECTION_FAILED.

See Also

MCconnectionFailedException Class
MCconnectionFailedException Members
MCconnectionFailedException Overload
Mergecom.Exceptions Namespace


MCconnectionFailedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Fields
MCconnectionFailedException Class See Also Send Feedback

The MCconnectionFailedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCconnectionFailedException Class
Mergecom.Exceptions Namespace


MCconnectionFailedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Methods
MCconnectionFailedException Class See Also Send Feedback

The MCconnectionFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCconnectionFailedException Class
Mergecom.Exceptions Namespace


MCconnectionFailedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconnectionFailedException Properties
MCconnectionFailedException Class See Also Send Feedback

The MCconnectionFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCconnectionFailedException Class
Mergecom.Exceptions Namespace


MCdicomdirException Class

[image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Class
Members See Also Send Feedback
Exception thrown when a problem was experienced navigating a DICOMDIR.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCdicomdirException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCdicomdirException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCdicomdirException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCdicomdirException

See Also

MCdicomdirException Members
Mergecom.Exceptions Namespace


MCdicomdirException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Members
MCdicomdirException Class Constructors Methods Fields Properties See Also Send Feedback

The MCdicomdirException type exposes the following members.

Constructors

 | Name | Description
Public method | MCdicomdirException()()()() | Initializes a new instance of this class.
Public method | MCdicomdirException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCdicomdirException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCdicomdirException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCdicomdirException Class
Mergecom.Exceptions Namespace


MCdicomdirException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Constructor
MCdicomdirException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdicomdirException()()()() | Initializes a new instance of this class.
Public method | MCdicomdirException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCdicomdirException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCdicomdirException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCdicomdirException Class
MCdicomdirException Members
Mergecom.Exceptions Namespace


MCdicomdirException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Constructor
MCdicomdirException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomdirException()
Visual Basic
Public Sub New
Visual C++
public:
MCdicomdirException()

Remarks

The exception number will be set to MCexception.DICOMDIR_ERROR.

See Also

MCdicomdirException Class
MCdicomdirException Members
MCdicomdirException Overload
Mergecom.Exceptions Namespace


MCdicomdirException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Constructor (String)
MCdicomdirException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomdirException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCdicomdirException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.DICOMDIR_ERROR.

See Also

MCdicomdirException Class
MCdicomdirException Members
MCdicomdirException Overload
Mergecom.Exceptions Namespace


MCdicomdirException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Constructor (SerializationInfo, StreamingContext)
MCdicomdirException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCdicomdirException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCdicomdirException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCdicomdirException Class
MCdicomdirException Members
MCdicomdirException Overload
Mergecom.Exceptions Namespace


MCdicomdirException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Constructor (String, Exception)
MCdicomdirException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdicomdirException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCdicomdirException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.DICOMDIR_ERROR.

See Also

MCdicomdirException Class
MCdicomdirException Members
MCdicomdirException Overload
Mergecom.Exceptions Namespace


MCdicomdirException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Fields
MCdicomdirException Class See Also Send Feedback

The MCdicomdirException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCdicomdirException Class
Mergecom.Exceptions Namespace


MCdicomdirException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Methods
MCdicomdirException Class See Also Send Feedback

The MCdicomdirException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCdicomdirException Class
Mergecom.Exceptions Namespace


MCdicomdirException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdicomdirException Properties
MCdicomdirException Class See Also Send Feedback

The MCdicomdirException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCdicomdirException Class
Mergecom.Exceptions Namespace


MCdisposedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Class
Members See Also Send Feedback
Exception thrown when the application is trying to access an object that was disposed.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCdisposedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCdisposedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCdisposedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCdisposedException

See Also

MCdisposedException Members
Mergecom.Exceptions Namespace


MCdisposedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Members
MCdisposedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCdisposedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCdisposedException()()()() | Initializes a new instance of this class.
Public method | MCdisposedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCdisposedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCdisposedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCdisposedException Class
Mergecom.Exceptions Namespace


MCdisposedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Constructor
MCdisposedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdisposedException()()()() | Initializes a new instance of this class.
Public method | MCdisposedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCdisposedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCdisposedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCdisposedException Class
MCdisposedException Members
Mergecom.Exceptions Namespace


MCdisposedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Constructor
MCdisposedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdisposedException()
Visual Basic
Public Sub New
Visual C++
public:
MCdisposedException()

Remarks

The exception number will be set to MCexception.OBJECT_DISPOSED.

See Also

MCdisposedException Class
MCdisposedException Members
MCdisposedException Overload
Mergecom.Exceptions Namespace


MCdisposedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Constructor (String)
MCdisposedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdisposedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCdisposedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.OBJECT_DISPOSED.

See Also

MCdisposedException Class
MCdisposedException Members
MCdisposedException Overload
Mergecom.Exceptions Namespace


MCdisposedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Constructor (SerializationInfo, StreamingContext)
MCdisposedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCdisposedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCdisposedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCdisposedException Class
MCdisposedException Members
MCdisposedException Overload
Mergecom.Exceptions Namespace


MCdisposedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Constructor (String, Exception)
MCdisposedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdisposedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCdisposedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.OBJECT_DISPOSED.

See Also

MCdisposedException Class
MCdisposedException Members
MCdisposedException Overload
Mergecom.Exceptions Namespace


MCdisposedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Fields
MCdisposedException Class See Also Send Feedback

The MCdisposedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCdisposedException Class
Mergecom.Exceptions Namespace


MCdisposedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Methods
MCdisposedException Class See Also Send Feedback

The MCdisposedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCdisposedException Class
Mergecom.Exceptions Namespace


MCdisposedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdisposedException Properties
MCdisposedException Class See Also Send Feedback

The MCdisposedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCdisposedException Class
Mergecom.Exceptions Namespace


MCexception Class

[image]

Merge DICOM .NET/C# Toolkit
MCexception Class
Members See Also Send Feedback
Base class for predefined exceptions thrown by MergeCOM library.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCexception : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class MCexception _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class MCexception : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCalreadyExistsException
Mergecom.Exceptions..::..MCalreadyInitializedException
Mergecom.Exceptions..::..MCalreadyListeningException
Mergecom.Exceptions..::..MCassociationRejectedException
Mergecom.Exceptions..::..MCattributeNotFoundException
Mergecom.Exceptions..::..MCcallbackCannotComplyException
Mergecom.Exceptions..::..MCcallbackInvalidArgumentException
Mergecom.Exceptions..::..MCconnectionFailedException
Mergecom.Exceptions..::..MCdicomdirException
Mergecom.Exceptions..::..MCdisposedException
Mergecom.Exceptions..::..MCillegalArgumentException
Mergecom.Exceptions..::..MCincompatibleValueException
Mergecom.Exceptions..::..MCinvalidDirRecordTypeException
Mergecom.Exceptions..::..MCinvalidEncodingException
Mergecom.Exceptions..::..MCinvalidEncodingWarning
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning
Mergecom.Exceptions..::..MCnegotiationAbortedException
Mergecom.Exceptions..::..MCnoAttributesException
Mergecom.Exceptions..::..MCnoSuchValueException
Mergecom.Exceptions..::..MCnotFoundException
Mergecom.Exceptions..::..MCnotStandardElementException
Mergecom.Exceptions..::..MCoperationNotAllowedException
Mergecom.Exceptions..::..MCrequiredAttributeMissingException
Mergecom.Exceptions..::..MCruntimeException
Mergecom.Exceptions..::..MCtimeoutException
Mergecom.Exceptions..::..MCunacceptableServiceException
Mergecom.Exceptions..::..MCunknownHostNameException

See Also

MCexception Members
Mergecom.Exceptions Namespace


MCexception Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexception Members
MCexception Class Constructors Methods Fields Properties See Also Send Feedback

The MCexception type exposes the following members.

Constructors

 | Name | Description
Public method | MCexception(Int32) | Initializes an exception instance with ERROR type, the message of "MCexception number n" where n is provided.
Public method | MCexception(String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.
Public method | MCexception(Int32, MCseverity) | Initializes an exception instance for a specified severity with a message of "MCexception number n" where n is provided.
Public method | MCexception(Int32, String) | Initializes an exception instance with an exception number and message.
Protected method | MCexception(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCexception(MCseverity, String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number and the specified severity level and message.
Public method | MCexception(Int32, MCseverity, String) | Initializes an exception instance identified by an exception number, with a specified severity level and message.
Public method | MCexception(Int32, String, Exception) | Initializes a new instance of exception with ERROR severity.
Public method | MCexception(Int32, MCseverity, String, Exception) | Initializes a new instance of exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
 | ALREADY_EXISTS | Constant that exceptionNumber is set to on MCalreadyExistsException exceptions.
 | ALREADY_INITIALIZED_EXCEPTION | Constant that exceptionNumber is set to on MCalreadyInitializedException exceptions.
 | ALREADY_LISTENING | Constant that exceptionNumber is set to on MCalreadyListeningException exceptions.
 | ASSOCIATION_ABORTED | Constant that exceptionNumber is set to on MCassociationAbortedException exceptions.
 | ASSOCIATION_REJECTED | Constant that exceptionNumber is set to on MCassociationRejectedException exceptions.
 | ASSOCIATION_RELEASED | Constant that exceptionNumber is set to on MCassociationReleasedStatus exceptions.
 | ATTRIBUTE_NOT_FOUND | Constant that exceptionNumber is set to on MCattributeNotFoundException exceptions.
 | CALLBACK_CANNOT_COMPLY | Constant that exceptionNumber is set to on MCcallbackCannotComplyException exceptions.
 | CALLBACK_INVALID_ARGUMENT | Constant that exceptionNumber is set to on MCcallbackInvalidArgumentException exceptions.
 | CONFIG_INFO_ERROR | Constant that exceptionNumber is set to on MCconfigFileErrorException exceptions.
 | CONFIGURATION_ERROR | Constant that exceptionNumber is set to on MCconfigurationError exceptions.
 | CONNECTION_FAILED | Constant that exceptionNumber is set to on MCconnectionFailedException exceptions.
 | DICOMDIR_ERROR | Constant that exceptionNumber is set to on MCdicomdirException exceptions.
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception.
 | ILLEGAL_ARGUMENT_EXCEPTION | Constant that exceptionNumber is set to on MCillegalArgumentException exceptions.
 | INCOMPATIBLE_VALUE | Constant that exceptionNumber is set to on MCincompatibleValueException exceptions.
 | INVALID_CHARACTERS_FOR_VR | Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.
 | INVALID_CHARS_IN_VALUE | Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.
 | INVALID_DIR_RECORD_TYPE | Constant that exceptionNumber is set to on MCinvalidDirRecordTypeException exceptions.
 | INVALID_ENCODING | Constant that exceptionNumber is set to on MCinvalidEncodingException exceptions.
 | INVALID_FORMAT_FOR_VR | Constant that exceptionNumber is set to on MCinvalidFormatEncodingWarning exceptions.
 | INVALID_ITEM_ID | Constant used for message validation.
 | INVALID_LENGTH_FOR_VR | Constant that exceptionNumber is set to on MCinvalidLengthEncodingWarning exceptions.
 | INVALID_LICENSE | Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.
 | INVALID_MESSAGE_RECEIVED | Constant that exceptionNumber is set to on MCinvalidMessageReceivedException exceptions.
 | INVALID_TRANSFER_SYNTAX | Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.
 | INVALID_TRANSFER_SYNTAX_CODE | Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.
 | INVALID_VALUE_FOR_VR | Constant used for message validation.
 | INVALID_VR_CODE | Constant used for message validation.
 | LOST_CONNECTION | Constant that exceptionNumber is set to on MClostConnectionException exceptions.
 | MAX_OPERATIONS_EXCEEDED | Constant that exceptionNumber is set to on MCmaxOperationsExceededWarning exceptions.
 | NEGOTIATION_ABORTED | Constant that exceptionNumber is set to on MCnegotiationAbortedException exceptions.
 | NETWORK_INACTIVITY_TIMEOUT | Constant that exceptionNumber is set to on MCinactivityTimeoutException exceptions.
 | NETWORK_SHUTDOWN | Constant that exceptionNumber is set to on MCnetworkShutdownException exceptions.
 | NO_ATTRIBUTES | Constant that exceptionNumber is set to on MCnoAttributesException exceptions.
 | NO_CONDITION_FUNCTION | Constant used for message validation.
 | NO_LICENSE | Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.
 | NO_SUCH_RECORD | Constant that exceptionNumber is set to on MCnoSuchRecordException exceptions.
 | NO_SUCH_VALUE | Constant that exceptionNumber is set to on MCnoSuchValueException exceptions.
 | NON_SERVICE_ATTRIBUTE | Constant used for message validation.
 | NORMAL_COMPLETION | Constant representing no Exceptions occurred.
 | NOT_A_STANDARD_DATA_ELEMENT | Constant that exceptionNumber is set to on MCnotStandardElementException exceptions.
 | NOT_FOUND | Constant that exceptionNumber is set to on MCnotFoundException exceptions.
 | NOT_INITIALIZED_EXCEPTION | Constant that exceptionNumber is set to on MCnotInitializedError exceptions.
 | NOT_ONE_OF_DEFINED_TERMS | Constant used for message validation.
 | NOT_ONE_OF_ENUMERATED_VALUES | Constant used for message validation.
 | OBJECT_DISPOSED | Constant that exceptionNumber is set to on MCdisposedException exceptions.
 | OPERATION_NOT_ALLOWED | Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.
 | REQUIRED_ATTRIBUTE_IS_MISSING | Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.
 | REQUIRED_ATTRIBUTE_MISSING | Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.
 | REQUIRED_VALUE_MISSING | Constant used for message validation.
 | STATE_VIOLATION | Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.
 | TIMEOUT | Constant that exceptionNumber is set to on MCtimeoutException exceptions.
 | TOO_FEW_VALUES | Constant used for message validation.
 | TOO_MANY_VALUES | Constant used for message validation.
 | UNABLE_TO_CHECK_CONDITION | Constant used for message validation.
 | UNKNOWN_ERROR | Constant representing an unknown error.
 | UNKNOWN_HOST | Constant that exceptionNumber is set to on MCunknownHostNameException exceptions.
 | UNNACCEPTABLE_SERVICE | Constant that exceptionNumber is set to on MCunacceptableServiceException exceptions.
 | VALUE_MAY_NOT_BE_NULL | Constant used for message validation.
 | VALUE_NOT_ALLOWED | Constant used for message validation.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCexception Class
Mergecom.Exceptions Namespace


MCexception Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor
MCexception Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCexception(Int32) | Initializes an exception instance with ERROR type, the message of "MCexception number n" where n is provided.
Public method | MCexception(String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.
Public method | MCexception(Int32, MCseverity) | Initializes an exception instance for a specified severity with a message of "MCexception number n" where n is provided.
Public method | MCexception(Int32, String) | Initializes an exception instance with an exception number and message.
Protected method | MCexception(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCexception(MCseverity, String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number and the specified severity level and message.
Public method | MCexception(Int32, MCseverity, String) | Initializes an exception instance identified by an exception number, with a specified severity level and message.
Public method | MCexception(Int32, String, Exception) | Initializes a new instance of exception with ERROR severity.
Public method | MCexception(Int32, MCseverity, String, Exception) | Initializes a new instance of exception.

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


MCexception Constructor (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32)
MCexception Class See Also Send Feedback
Initializes an exception instance with ERROR type, the message of "MCexception number n" where n is provided.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer _
)
Visual C++
public:
MCexception(
    int exceptionNumber
)

Parameters

exceptionNumber
Type: System..::..Int32
Merge DICOM Toolkit defined exception number.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (String)
MCexception Class See Also Send Feedback
Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCexception(
    String^ msg
)

Parameters

msg
Type: System..::..String
The exception message.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (Int32, MCseverity)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32, MCseverity)
MCexception Class See Also Send Feedback
Initializes an exception instance for a specified severity with a message of "MCexception number n" where n is provided.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber,
    MCseverity severity
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    severity As MCseverity _
)
Visual C++
public:
MCexception(
    int exceptionNumber,
    MCseverity^ severity
)

Parameters

exceptionNumber
Type: System..::..Int32
Merge DICOM Toolkit defined exception number.
severity
Type: Mergecom.Exceptions..::..MCseverity
Severity of the exception.MCseverity

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (Int32, String)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32, String)
MCexception Class See Also Send Feedback
Initializes an exception instance with an exception number and message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber,
    string msg
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    msg As String _
)
Visual C++
public:
MCexception(
    int exceptionNumber,
    String^ msg
)

Parameters

exceptionNumber
Type: System..::..Int32
The exception number.
msg
Type: System..::..String
Exception message.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (SerializationInfo, StreamingContext)
MCexception Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCexception(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCexception(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (MCseverity, String)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (MCseverity, String)
MCexception Class See Also Send Feedback
Initializes an exception instance by using UNKNOWN_ERROR as the exception number and the specified severity level and message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    MCseverity severity,
    string msg
)
Visual Basic
Public Sub New ( _
    severity As MCseverity, _
    msg As String _
)
Visual C++
public:
MCexception(
    MCseverity^ severity,
    String^ msg
)

Parameters

severity
Type: Mergecom.Exceptions..::..MCseverity
The severity of the exception.
msg
Type: System..::..String
The exception message.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (Int32, MCseverity, String)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32, MCseverity, String)
MCexception Class See Also Send Feedback
Initializes an exception instance identified by an exception number, with a specified severity level and message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber,
    MCseverity severity,
    string msg
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    severity As MCseverity, _
    msg As String _
)
Visual C++
public:
MCexception(
    int exceptionNumber,
    MCseverity^ severity,
    String^ msg
)

Parameters

exceptionNumber
Type: System..::..Int32
Merge DICOM Toolkit defined exception number.
severity
Type: Mergecom.Exceptions..::..MCseverity
Severity of the exception.
msg
Type: System..::..String
Exception message.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (Int32, String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32, String, Exception)
MCexception Class See Also Send Feedback
Initializes a new instance of exception with ERROR severity.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber,
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCexception(
    int exceptionNumber,
    String^ msg,
    Exception^ innerException
)

Parameters

exceptionNumber
Type: System..::..Int32
The exception number.
msg
Type: System..::..String
The exception message.
innerException
Type: System..::..Exception
The inner exception causing this exception.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Constructor (Int32, MCseverity, String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCexception Constructor (Int32, MCseverity, String, Exception)
MCexception Class See Also Send Feedback
Initializes a new instance of exception.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexception(
    int exceptionNumber,
    MCseverity severity,
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    severity As MCseverity, _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCexception(
    int exceptionNumber,
    MCseverity^ severity,
    String^ msg,
    Exception^ innerException
)

Parameters

exceptionNumber
Type: System..::..Int32
The exception number.
severity
Type: Mergecom.Exceptions..::..MCseverity
The severity of the exception.
msg
Type: System..::..String
The exception message.
innerException
Type: System..::..Exception
The inner exception causing this exception.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCexception Class
MCexception Members
MCexception Overload
Mergecom.Exceptions Namespace


MCexception Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexception Fields
MCexception Class See Also Send Feedback

The MCexception type exposes the following members.

Fields

 | Name | Description
 | ALREADY_EXISTS | Constant that exceptionNumber is set to on MCalreadyExistsException exceptions.
 | ALREADY_INITIALIZED_EXCEPTION | Constant that exceptionNumber is set to on MCalreadyInitializedException exceptions.
 | ALREADY_LISTENING | Constant that exceptionNumber is set to on MCalreadyListeningException exceptions.
 | ASSOCIATION_ABORTED | Constant that exceptionNumber is set to on MCassociationAbortedException exceptions.
 | ASSOCIATION_REJECTED | Constant that exceptionNumber is set to on MCassociationRejectedException exceptions.
 | ASSOCIATION_RELEASED | Constant that exceptionNumber is set to on MCassociationReleasedStatus exceptions.
 | ATTRIBUTE_NOT_FOUND | Constant that exceptionNumber is set to on MCattributeNotFoundException exceptions.
 | CALLBACK_CANNOT_COMPLY | Constant that exceptionNumber is set to on MCcallbackCannotComplyException exceptions.
 | CALLBACK_INVALID_ARGUMENT | Constant that exceptionNumber is set to on MCcallbackInvalidArgumentException exceptions.
 | CONFIG_INFO_ERROR | Constant that exceptionNumber is set to on MCconfigFileErrorException exceptions.
 | CONFIGURATION_ERROR | Constant that exceptionNumber is set to on MCconfigurationError exceptions.
 | CONNECTION_FAILED | Constant that exceptionNumber is set to on MCconnectionFailedException exceptions.
 | DICOMDIR_ERROR | Constant that exceptionNumber is set to on MCdicomdirException exceptions.
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception.
 | ILLEGAL_ARGUMENT_EXCEPTION | Constant that exceptionNumber is set to on MCillegalArgumentException exceptions.
 | INCOMPATIBLE_VALUE | Constant that exceptionNumber is set to on MCincompatibleValueException exceptions.
 | INVALID_CHARACTERS_FOR_VR | Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.
 | INVALID_CHARS_IN_VALUE | Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.
 | INVALID_DIR_RECORD_TYPE | Constant that exceptionNumber is set to on MCinvalidDirRecordTypeException exceptions.
 | INVALID_ENCODING | Constant that exceptionNumber is set to on MCinvalidEncodingException exceptions.
 | INVALID_FORMAT_FOR_VR | Constant that exceptionNumber is set to on MCinvalidFormatEncodingWarning exceptions.
 | INVALID_ITEM_ID | Constant used for message validation.
 | INVALID_LENGTH_FOR_VR | Constant that exceptionNumber is set to on MCinvalidLengthEncodingWarning exceptions.
 | INVALID_LICENSE | Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.
 | INVALID_MESSAGE_RECEIVED | Constant that exceptionNumber is set to on MCinvalidMessageReceivedException exceptions.
 | INVALID_TRANSFER_SYNTAX | Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.
 | INVALID_TRANSFER_SYNTAX_CODE | Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.
 | INVALID_VALUE_FOR_VR | Constant used for message validation.
 | INVALID_VR_CODE | Constant used for message validation.
 | LOST_CONNECTION | Constant that exceptionNumber is set to on MClostConnectionException exceptions.
 | MAX_OPERATIONS_EXCEEDED | Constant that exceptionNumber is set to on MCmaxOperationsExceededWarning exceptions.
 | NEGOTIATION_ABORTED | Constant that exceptionNumber is set to on MCnegotiationAbortedException exceptions.
 | NETWORK_INACTIVITY_TIMEOUT | Constant that exceptionNumber is set to on MCinactivityTimeoutException exceptions.
 | NETWORK_SHUTDOWN | Constant that exceptionNumber is set to on MCnetworkShutdownException exceptions.
 | NO_ATTRIBUTES | Constant that exceptionNumber is set to on MCnoAttributesException exceptions.
 | NO_CONDITION_FUNCTION | Constant used for message validation.
 | NO_LICENSE | Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.
 | NO_SUCH_RECORD | Constant that exceptionNumber is set to on MCnoSuchRecordException exceptions.
 | NO_SUCH_VALUE | Constant that exceptionNumber is set to on MCnoSuchValueException exceptions.
 | NON_SERVICE_ATTRIBUTE | Constant used for message validation.
 | NORMAL_COMPLETION | Constant representing no Exceptions occurred.
 | NOT_A_STANDARD_DATA_ELEMENT | Constant that exceptionNumber is set to on MCnotStandardElementException exceptions.
 | NOT_FOUND | Constant that exceptionNumber is set to on MCnotFoundException exceptions.
 | NOT_INITIALIZED_EXCEPTION | Constant that exceptionNumber is set to on MCnotInitializedError exceptions.
 | NOT_ONE_OF_DEFINED_TERMS | Constant used for message validation.
 | NOT_ONE_OF_ENUMERATED_VALUES | Constant used for message validation.
 | OBJECT_DISPOSED | Constant that exceptionNumber is set to on MCdisposedException exceptions.
 | OPERATION_NOT_ALLOWED | Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.
 | REQUIRED_ATTRIBUTE_IS_MISSING | Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.
 | REQUIRED_ATTRIBUTE_MISSING | Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.
 | REQUIRED_VALUE_MISSING | Constant used for message validation.
 | STATE_VIOLATION | Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.
 | TIMEOUT | Constant that exceptionNumber is set to on MCtimeoutException exceptions.
 | TOO_FEW_VALUES | Constant used for message validation.
 | TOO_MANY_VALUES | Constant used for message validation.
 | UNABLE_TO_CHECK_CONDITION | Constant used for message validation.
 | UNKNOWN_ERROR | Constant representing an unknown error.
 | UNKNOWN_HOST | Constant that exceptionNumber is set to on MCunknownHostNameException exceptions.
 | UNNACCEPTABLE_SERVICE | Constant that exceptionNumber is set to on MCunacceptableServiceException exceptions.
 | VALUE_MAY_NOT_BE_NULL | Constant used for message validation.
 | VALUE_NOT_ALLOWED | Constant used for message validation.

See Also

MCexception Class
Mergecom.Exceptions Namespace


ALREADY_EXISTS Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ALREADY_EXISTS Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCalreadyExistsException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ALREADY_EXISTS
Visual Basic
Public Const ALREADY_EXISTS As Integer
Visual C++
public:
literal int ALREADY_EXISTS

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ALREADY_INITIALIZED_EXCEPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ALREADY_INITIALIZED_EXCEPTION Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCalreadyInitializedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ALREADY_INITIALIZED_EXCEPTION
Visual Basic
Public Const ALREADY_INITIALIZED_EXCEPTION As Integer
Visual C++
public:
literal int ALREADY_INITIALIZED_EXCEPTION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ALREADY_LISTENING Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ALREADY_LISTENING Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCalreadyListeningException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ALREADY_LISTENING
Visual Basic
Public Const ALREADY_LISTENING As Integer
Visual C++
public:
literal int ALREADY_LISTENING

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ASSOCIATION_ABORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ASSOCIATION_ABORTED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCassociationAbortedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ASSOCIATION_ABORTED
Visual Basic
Public Const ASSOCIATION_ABORTED As Integer
Visual C++
public:
literal int ASSOCIATION_ABORTED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ASSOCIATION_REJECTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ASSOCIATION_REJECTED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCassociationRejectedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ASSOCIATION_REJECTED
Visual Basic
Public Const ASSOCIATION_REJECTED As Integer
Visual C++
public:
literal int ASSOCIATION_REJECTED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ASSOCIATION_RELEASED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ASSOCIATION_RELEASED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCassociationReleasedStatus exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ASSOCIATION_RELEASED
Visual Basic
Public Const ASSOCIATION_RELEASED As Integer
Visual C++
public:
literal int ASSOCIATION_RELEASED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ATTRIBUTE_NOT_FOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ATTRIBUTE_NOT_FOUND Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCattributeNotFoundException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ATTRIBUTE_NOT_FOUND
Visual Basic
Public Const ATTRIBUTE_NOT_FOUND As Integer
Visual C++
public:
literal int ATTRIBUTE_NOT_FOUND

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


CALLBACK_CANNOT_COMPLY Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..CALLBACK_CANNOT_COMPLY Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCcallbackCannotComplyException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int CALLBACK_CANNOT_COMPLY
Visual Basic
Public Const CALLBACK_CANNOT_COMPLY As Integer
Visual C++
public:
literal int CALLBACK_CANNOT_COMPLY

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


CALLBACK_INVALID_ARGUMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..CALLBACK_INVALID_ARGUMENT Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCcallbackInvalidArgumentException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int CALLBACK_INVALID_ARGUMENT
Visual Basic
Public Const CALLBACK_INVALID_ARGUMENT As Integer
Visual C++
public:
literal int CALLBACK_INVALID_ARGUMENT

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


CONFIG_INFO_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..CONFIG_INFO_ERROR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCconfigFileErrorException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int CONFIG_INFO_ERROR
Visual Basic
Public Const CONFIG_INFO_ERROR As Integer
Visual C++
public:
literal int CONFIG_INFO_ERROR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


CONFIGURATION_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..CONFIGURATION_ERROR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCconfigurationError exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int CONFIGURATION_ERROR
Visual Basic
Public Const CONFIGURATION_ERROR As Integer
Visual C++
public:
literal int CONFIGURATION_ERROR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


CONNECTION_FAILED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..CONNECTION_FAILED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCconnectionFailedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int CONNECTION_FAILED
Visual Basic
Public Const CONNECTION_FAILED As Integer
Visual C++
public:
literal int CONNECTION_FAILED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


DICOMDIR_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..DICOMDIR_ERROR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCdicomdirException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int DICOMDIR_ERROR
Visual Basic
Public Const DICOMDIR_ERROR As Integer
Visual C++
public:
literal int DICOMDIR_ERROR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


exceptionNumber Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..exceptionNumber Field
MCexception Class See Also Send Feedback
The number assigned by the Merge DICOM toolkit to this exception.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly int exceptionNumber
Visual Basic
Public ReadOnly exceptionNumber As Integer
Visual C++
public:
initonly int exceptionNumber

Remarks

The values used are defined in MCexception.

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


ILLEGAL_ARGUMENT_EXCEPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..ILLEGAL_ARGUMENT_EXCEPTION Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCillegalArgumentException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int ILLEGAL_ARGUMENT_EXCEPTION
Visual Basic
Public Const ILLEGAL_ARGUMENT_EXCEPTION As Integer
Visual C++
public:
literal int ILLEGAL_ARGUMENT_EXCEPTION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INCOMPATIBLE_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INCOMPATIBLE_VALUE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCincompatibleValueException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INCOMPATIBLE_VALUE
Visual Basic
Public Const INCOMPATIBLE_VALUE As Integer
Visual C++
public:
literal int INCOMPATIBLE_VALUE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_CHARACTERS_FOR_VR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_CHARACTERS_FOR_VR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_CHARACTERS_FOR_VR
Visual Basic
Public Const INVALID_CHARACTERS_FOR_VR As Integer
Visual C++
public:
literal int INVALID_CHARACTERS_FOR_VR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_CHARS_IN_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_CHARS_IN_VALUE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidEncodingWarning exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_CHARS_IN_VALUE
Visual Basic
Public Const INVALID_CHARS_IN_VALUE As Integer
Visual C++
public:
literal int INVALID_CHARS_IN_VALUE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_DIR_RECORD_TYPE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_DIR_RECORD_TYPE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidDirRecordTypeException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_DIR_RECORD_TYPE
Visual Basic
Public Const INVALID_DIR_RECORD_TYPE As Integer
Visual C++
public:
literal int INVALID_DIR_RECORD_TYPE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_ENCODING Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_ENCODING Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidEncodingException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_ENCODING
Visual Basic
Public Const INVALID_ENCODING As Integer
Visual C++
public:
literal int INVALID_ENCODING

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_FORMAT_FOR_VR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_FORMAT_FOR_VR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidFormatEncodingWarning exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_FORMAT_FOR_VR
Visual Basic
Public Const INVALID_FORMAT_FOR_VR As Integer
Visual C++
public:
literal int INVALID_FORMAT_FOR_VR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_ITEM_ID Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_ITEM_ID Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_ITEM_ID
Visual Basic
Public Const INVALID_ITEM_ID As Integer
Visual C++
public:
literal int INVALID_ITEM_ID

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_LENGTH_FOR_VR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_LENGTH_FOR_VR Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidLengthEncodingWarning exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_LENGTH_FOR_VR
Visual Basic
Public Const INVALID_LENGTH_FOR_VR As Integer
Visual C++
public:
literal int INVALID_LENGTH_FOR_VR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_LICENSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_LICENSE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_LICENSE
Visual Basic
Public Const INVALID_LICENSE As Integer
Visual C++
public:
literal int INVALID_LICENSE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_MESSAGE_RECEIVED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_MESSAGE_RECEIVED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidMessageReceivedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_MESSAGE_RECEIVED
Visual Basic
Public Const INVALID_MESSAGE_RECEIVED As Integer
Visual C++
public:
literal int INVALID_MESSAGE_RECEIVED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_TRANSFER_SYNTAX Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_TRANSFER_SYNTAX Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_TRANSFER_SYNTAX
Visual Basic
Public Const INVALID_TRANSFER_SYNTAX As Integer
Visual C++
public:
literal int INVALID_TRANSFER_SYNTAX

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_TRANSFER_SYNTAX_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_TRANSFER_SYNTAX_CODE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidTransferSyntaxException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_TRANSFER_SYNTAX_CODE
Visual Basic
Public Const INVALID_TRANSFER_SYNTAX_CODE As Integer
Visual C++
public:
literal int INVALID_TRANSFER_SYNTAX_CODE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_VALUE_FOR_VR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_VALUE_FOR_VR Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_VALUE_FOR_VR
Visual Basic
Public Const INVALID_VALUE_FOR_VR As Integer
Visual C++
public:
literal int INVALID_VALUE_FOR_VR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


INVALID_VR_CODE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..INVALID_VR_CODE Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int INVALID_VR_CODE
Visual Basic
Public Const INVALID_VR_CODE As Integer
Visual C++
public:
literal int INVALID_VR_CODE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


LOST_CONNECTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..LOST_CONNECTION Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MClostConnectionException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int LOST_CONNECTION
Visual Basic
Public Const LOST_CONNECTION As Integer
Visual C++
public:
literal int LOST_CONNECTION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


MAX_OPERATIONS_EXCEEDED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..MAX_OPERATIONS_EXCEEDED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCmaxOperationsExceededWarning exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MAX_OPERATIONS_EXCEEDED
Visual Basic
Public Const MAX_OPERATIONS_EXCEEDED As Integer
Visual C++
public:
literal int MAX_OPERATIONS_EXCEEDED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NEGOTIATION_ABORTED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NEGOTIATION_ABORTED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnegotiationAbortedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NEGOTIATION_ABORTED
Visual Basic
Public Const NEGOTIATION_ABORTED As Integer
Visual C++
public:
literal int NEGOTIATION_ABORTED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NETWORK_INACTIVITY_TIMEOUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NETWORK_INACTIVITY_TIMEOUT Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinactivityTimeoutException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NETWORK_INACTIVITY_TIMEOUT
Visual Basic
Public Const NETWORK_INACTIVITY_TIMEOUT As Integer
Visual C++
public:
literal int NETWORK_INACTIVITY_TIMEOUT

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NETWORK_SHUTDOWN Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NETWORK_SHUTDOWN Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnetworkShutdownException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NETWORK_SHUTDOWN
Visual Basic
Public Const NETWORK_SHUTDOWN As Integer
Visual C++
public:
literal int NETWORK_SHUTDOWN

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NO_ATTRIBUTES Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NO_ATTRIBUTES Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnoAttributesException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NO_ATTRIBUTES
Visual Basic
Public Const NO_ATTRIBUTES As Integer
Visual C++
public:
literal int NO_ATTRIBUTES

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NO_CONDITION_FUNCTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NO_CONDITION_FUNCTION Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NO_CONDITION_FUNCTION
Visual Basic
Public Const NO_CONDITION_FUNCTION As Integer
Visual C++
public:
literal int NO_CONDITION_FUNCTION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NO_LICENSE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NO_LICENSE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCinvalidLicenseInfoError exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NO_LICENSE
Visual Basic
Public Const NO_LICENSE As Integer
Visual C++
public:
literal int NO_LICENSE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NO_SUCH_RECORD Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NO_SUCH_RECORD Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnoSuchRecordException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NO_SUCH_RECORD
Visual Basic
Public Const NO_SUCH_RECORD As Integer
Visual C++
public:
literal int NO_SUCH_RECORD

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NO_SUCH_VALUE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NO_SUCH_VALUE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnoSuchValueException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NO_SUCH_VALUE
Visual Basic
Public Const NO_SUCH_VALUE As Integer
Visual C++
public:
literal int NO_SUCH_VALUE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NON_SERVICE_ATTRIBUTE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NON_SERVICE_ATTRIBUTE Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NON_SERVICE_ATTRIBUTE
Visual Basic
Public Const NON_SERVICE_ATTRIBUTE As Integer
Visual C++
public:
literal int NON_SERVICE_ATTRIBUTE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NORMAL_COMPLETION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NORMAL_COMPLETION Field
MCexception Class See Also Send Feedback
Constant representing no Exceptions occurred.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NORMAL_COMPLETION
Visual Basic
Public Const NORMAL_COMPLETION As Integer
Visual C++
public:
literal int NORMAL_COMPLETION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NOT_A_STANDARD_DATA_ELEMENT Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NOT_A_STANDARD_DATA_ELEMENT Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnotStandardElementException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NOT_A_STANDARD_DATA_ELEMENT
Visual Basic
Public Const NOT_A_STANDARD_DATA_ELEMENT As Integer
Visual C++
public:
literal int NOT_A_STANDARD_DATA_ELEMENT

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NOT_FOUND Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NOT_FOUND Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnotFoundException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NOT_FOUND
Visual Basic
Public Const NOT_FOUND As Integer
Visual C++
public:
literal int NOT_FOUND

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NOT_INITIALIZED_EXCEPTION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NOT_INITIALIZED_EXCEPTION Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCnotInitializedError exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NOT_INITIALIZED_EXCEPTION
Visual Basic
Public Const NOT_INITIALIZED_EXCEPTION As Integer
Visual C++
public:
literal int NOT_INITIALIZED_EXCEPTION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NOT_ONE_OF_DEFINED_TERMS Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NOT_ONE_OF_DEFINED_TERMS Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NOT_ONE_OF_DEFINED_TERMS
Visual Basic
Public Const NOT_ONE_OF_DEFINED_TERMS As Integer
Visual C++
public:
literal int NOT_ONE_OF_DEFINED_TERMS

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


NOT_ONE_OF_ENUMERATED_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..NOT_ONE_OF_ENUMERATED_VALUES Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int NOT_ONE_OF_ENUMERATED_VALUES
Visual Basic
Public Const NOT_ONE_OF_ENUMERATED_VALUES As Integer
Visual C++
public:
literal int NOT_ONE_OF_ENUMERATED_VALUES

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


OBJECT_DISPOSED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..OBJECT_DISPOSED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCdisposedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int OBJECT_DISPOSED
Visual Basic
Public Const OBJECT_DISPOSED As Integer
Visual C++
public:
literal int OBJECT_DISPOSED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


OPERATION_NOT_ALLOWED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..OPERATION_NOT_ALLOWED Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int OPERATION_NOT_ALLOWED
Visual Basic
Public Const OPERATION_NOT_ALLOWED As Integer
Visual C++
public:
literal int OPERATION_NOT_ALLOWED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


REQUIRED_ATTRIBUTE_IS_MISSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..REQUIRED_ATTRIBUTE_IS_MISSING Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int REQUIRED_ATTRIBUTE_IS_MISSING
Visual Basic
Public Const REQUIRED_ATTRIBUTE_IS_MISSING As Integer
Visual C++
public:
literal int REQUIRED_ATTRIBUTE_IS_MISSING

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


REQUIRED_ATTRIBUTE_MISSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..REQUIRED_ATTRIBUTE_MISSING Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCrequiredAttributeMissingException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int REQUIRED_ATTRIBUTE_MISSING
Visual Basic
Public Const REQUIRED_ATTRIBUTE_MISSING As Integer
Visual C++
public:
literal int REQUIRED_ATTRIBUTE_MISSING

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


REQUIRED_VALUE_MISSING Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..REQUIRED_VALUE_MISSING Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int REQUIRED_VALUE_MISSING
Visual Basic
Public Const REQUIRED_VALUE_MISSING As Integer
Visual C++
public:
literal int REQUIRED_VALUE_MISSING

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


STATE_VIOLATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..STATE_VIOLATION Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCoperationNotAllowedException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int STATE_VIOLATION
Visual Basic
Public Const STATE_VIOLATION As Integer
Visual C++
public:
literal int STATE_VIOLATION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


TIMEOUT Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..TIMEOUT Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCtimeoutException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int TIMEOUT
Visual Basic
Public Const TIMEOUT As Integer
Visual C++
public:
literal int TIMEOUT

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


TOO_FEW_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..TOO_FEW_VALUES Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int TOO_FEW_VALUES
Visual Basic
Public Const TOO_FEW_VALUES As Integer
Visual C++
public:
literal int TOO_FEW_VALUES

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


TOO_MANY_VALUES Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..TOO_MANY_VALUES Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int TOO_MANY_VALUES
Visual Basic
Public Const TOO_MANY_VALUES As Integer
Visual C++
public:
literal int TOO_MANY_VALUES

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


UNABLE_TO_CHECK_CONDITION Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..UNABLE_TO_CHECK_CONDITION Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int UNABLE_TO_CHECK_CONDITION
Visual Basic
Public Const UNABLE_TO_CHECK_CONDITION As Integer
Visual C++
public:
literal int UNABLE_TO_CHECK_CONDITION

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


UNKNOWN_ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..UNKNOWN_ERROR Field
MCexception Class See Also Send Feedback
Constant representing an unknown error.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int UNKNOWN_ERROR
Visual Basic
Public Const UNKNOWN_ERROR As Integer
Visual C++
public:
literal int UNKNOWN_ERROR

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


UNKNOWN_HOST Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..UNKNOWN_HOST Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCunknownHostNameException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int UNKNOWN_HOST
Visual Basic
Public Const UNKNOWN_HOST As Integer
Visual C++
public:
literal int UNKNOWN_HOST

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


UNNACCEPTABLE_SERVICE Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..UNNACCEPTABLE_SERVICE Field
MCexception Class See Also Send Feedback
Constant that exceptionNumber is set to on MCunacceptableServiceException exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int UNNACCEPTABLE_SERVICE
Visual Basic
Public Const UNNACCEPTABLE_SERVICE As Integer
Visual C++
public:
literal int UNNACCEPTABLE_SERVICE

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


VALUE_MAY_NOT_BE_NULL Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..VALUE_MAY_NOT_BE_NULL Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int VALUE_MAY_NOT_BE_NULL
Visual Basic
Public Const VALUE_MAY_NOT_BE_NULL As Integer
Visual C++
public:
literal int VALUE_MAY_NOT_BE_NULL

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


VALUE_NOT_ALLOWED Field

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..VALUE_NOT_ALLOWED Field
MCexception Class See Also Send Feedback
Constant used for message validation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int VALUE_NOT_ALLOWED
Visual Basic
Public Const VALUE_NOT_ALLOWED As Integer
Visual C++
public:
literal int VALUE_NOT_ALLOWED

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


MCexception Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexception Methods
MCexception Class See Also Send Feedback

The MCexception type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCexception Class
Mergecom.Exceptions Namespace


GetObjectData Method

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..GetObjectData Method
MCexception Class See Also Send Feedback
Populates a SerializationInfo with the data needed to serialize this exception.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


MCexception Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexception Properties
MCexception Class See Also Send Feedback

The MCexception type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCexception Class
Mergecom.Exceptions Namespace


Message Property

[image]

Merge DICOM .NET/C# Toolkit
MCexception..::..Message Property
MCexception Class See Also Send Feedback
Returns a string description this exception.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Field Value

A string representation of the error that caused this exception.

Implements

_Exception..::..Message

See Also

MCexception Class
MCexception Members
Mergecom.Exceptions Namespace


MCillegalArgumentException Class

[image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Class
Members See Also Send Feedback
Exception thrown when an invalid argument was presented to a MergeCOM class library method.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCillegalArgumentException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCillegalArgumentException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCillegalArgumentException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCillegalArgumentException

See Also

MCillegalArgumentException Members
Mergecom.Exceptions Namespace


MCillegalArgumentException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Members
MCillegalArgumentException Class Constructors Methods Fields Properties See Also Send Feedback

The MCillegalArgumentException type exposes the following members.

Constructors

 | Name | Description
Public method | MCillegalArgumentException()()()() | Initializes a new instance of this class.
Public method | MCillegalArgumentException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCillegalArgumentException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCillegalArgumentException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCillegalArgumentException Class
Mergecom.Exceptions Namespace


MCillegalArgumentException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Constructor
MCillegalArgumentException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCillegalArgumentException()()()() | Initializes a new instance of this class.
Public method | MCillegalArgumentException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCillegalArgumentException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCillegalArgumentException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCillegalArgumentException Class
MCillegalArgumentException Members
Mergecom.Exceptions Namespace


MCillegalArgumentException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Constructor
MCillegalArgumentException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCillegalArgumentException()
Visual Basic
Public Sub New
Visual C++
public:
MCillegalArgumentException()

Remarks

The exception number will be set to MCexception.ILLEGAL_ARGUMENT_EXCEPTION.

See Also

MCillegalArgumentException Class
MCillegalArgumentException Members
MCillegalArgumentException Overload
Mergecom.Exceptions Namespace


MCillegalArgumentException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Constructor (String)
MCillegalArgumentException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCillegalArgumentException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCillegalArgumentException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.ILLEGAL_ARGUMENT_EXCEPTION.

See Also

MCillegalArgumentException Class
MCillegalArgumentException Members
MCillegalArgumentException Overload
Mergecom.Exceptions Namespace


MCillegalArgumentException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Constructor (SerializationInfo, StreamingContext)
MCillegalArgumentException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCillegalArgumentException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCillegalArgumentException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCillegalArgumentException Class
MCillegalArgumentException Members
MCillegalArgumentException Overload
Mergecom.Exceptions Namespace


MCillegalArgumentException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Constructor (String, Exception)
MCillegalArgumentException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCillegalArgumentException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCillegalArgumentException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.ILLEGAL_ARGUMENT_EXCEPTION.

See Also

MCillegalArgumentException Class
MCillegalArgumentException Members
MCillegalArgumentException Overload
Mergecom.Exceptions Namespace


MCillegalArgumentException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Fields
MCillegalArgumentException Class See Also Send Feedback

The MCillegalArgumentException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCillegalArgumentException Class
Mergecom.Exceptions Namespace


MCillegalArgumentException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Methods
MCillegalArgumentException Class See Also Send Feedback

The MCillegalArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCillegalArgumentException Class
Mergecom.Exceptions Namespace


MCillegalArgumentException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCillegalArgumentException Properties
MCillegalArgumentException Class See Also Send Feedback

The MCillegalArgumentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCillegalArgumentException Class
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Class

[image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Class
Members See Also Send Feedback
Exception thrown when too much time elapsed with no network activity.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinactivityTimeoutException : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCinactivityTimeoutException _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCinactivityTimeoutException : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCinactivityTimeoutException

See Also

MCinactivityTimeoutException Members
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Members
MCinactivityTimeoutException Class Constructors Methods Fields Properties See Also Send Feedback

The MCinactivityTimeoutException type exposes the following members.

Constructors

 | Name | Description
Public method | MCinactivityTimeoutException()()()() | Initializes a new instance of this class.
Public method | MCinactivityTimeoutException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinactivityTimeoutException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinactivityTimeoutException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinactivityTimeoutException Class
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Constructor
MCinactivityTimeoutException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinactivityTimeoutException()()()() | Initializes a new instance of this class.
Public method | MCinactivityTimeoutException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinactivityTimeoutException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinactivityTimeoutException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinactivityTimeoutException Class
MCinactivityTimeoutException Members
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Constructor
MCinactivityTimeoutException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinactivityTimeoutException()
Visual Basic
Public Sub New
Visual C++
public:
MCinactivityTimeoutException()

Remarks

The exception number will be set to MCexception.NETWORK_INACTIVITY_TIMEOUT.

See Also

MCinactivityTimeoutException Class
MCinactivityTimeoutException Members
MCinactivityTimeoutException Overload
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Constructor (String)
MCinactivityTimeoutException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinactivityTimeoutException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinactivityTimeoutException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NETWORK_INACTIVITY_TIMEOUT.

See Also

MCinactivityTimeoutException Class
MCinactivityTimeoutException Members
MCinactivityTimeoutException Overload
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Constructor (SerializationInfo, StreamingContext)
MCinactivityTimeoutException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinactivityTimeoutException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinactivityTimeoutException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinactivityTimeoutException Class
MCinactivityTimeoutException Members
MCinactivityTimeoutException Overload
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Constructor (String, Exception)
MCinactivityTimeoutException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinactivityTimeoutException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinactivityTimeoutException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NETWORK_INACTIVITY_TIMEOUT.

See Also

MCinactivityTimeoutException Class
MCinactivityTimeoutException Members
MCinactivityTimeoutException Overload
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Fields
MCinactivityTimeoutException Class See Also Send Feedback

The MCinactivityTimeoutException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinactivityTimeoutException Class
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Methods
MCinactivityTimeoutException Class See Also Send Feedback

The MCinactivityTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinactivityTimeoutException Class
Mergecom.Exceptions Namespace


MCinactivityTimeoutException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinactivityTimeoutException Properties
MCinactivityTimeoutException Class See Also Send Feedback

The MCinactivityTimeoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinactivityTimeoutException Class
Mergecom.Exceptions Namespace


MCincompatibleValueException Class

[image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Class
Members See Also Send Feedback
Exception thrown when a value is incompatible with the DICOM Value Representation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCincompatibleValueException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCincompatibleValueException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCincompatibleValueException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCincompatibleValueException

See Also

MCincompatibleValueException Members
Mergecom.Exceptions Namespace


MCincompatibleValueException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Members
MCincompatibleValueException Class Constructors Methods Fields Properties See Also Send Feedback

The MCincompatibleValueException type exposes the following members.

Constructors

 | Name | Description
Public method | MCincompatibleValueException()()()() | Initializes a new instance of this class.
Public method | MCincompatibleValueException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCincompatibleValueException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCincompatibleValueException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCincompatibleValueException Class
Mergecom.Exceptions Namespace


MCincompatibleValueException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Constructor
MCincompatibleValueException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCincompatibleValueException()()()() | Initializes a new instance of this class.
Public method | MCincompatibleValueException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCincompatibleValueException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCincompatibleValueException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCincompatibleValueException Class
MCincompatibleValueException Members
Mergecom.Exceptions Namespace


MCincompatibleValueException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Constructor
MCincompatibleValueException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCincompatibleValueException()
Visual Basic
Public Sub New
Visual C++
public:
MCincompatibleValueException()

Remarks

The exception number will be set to MCexception.INCOMPATIBLE_VALUE.

See Also

MCincompatibleValueException Class
MCincompatibleValueException Members
MCincompatibleValueException Overload
Mergecom.Exceptions Namespace


MCincompatibleValueException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Constructor (String)
MCincompatibleValueException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCincompatibleValueException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCincompatibleValueException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INCOMPATIBLE_VALUE.

See Also

MCincompatibleValueException Class
MCincompatibleValueException Members
MCincompatibleValueException Overload
Mergecom.Exceptions Namespace


MCincompatibleValueException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Constructor (SerializationInfo, StreamingContext)
MCincompatibleValueException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCincompatibleValueException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCincompatibleValueException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCincompatibleValueException Class
MCincompatibleValueException Members
MCincompatibleValueException Overload
Mergecom.Exceptions Namespace


MCincompatibleValueException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Constructor (String, Exception)
MCincompatibleValueException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCincompatibleValueException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCincompatibleValueException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to INCOMPATIBLE_VALUE.

See Also

MCincompatibleValueException Class
MCincompatibleValueException Members
MCincompatibleValueException Overload
Mergecom.Exceptions Namespace


MCincompatibleValueException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Fields
MCincompatibleValueException Class See Also Send Feedback

The MCincompatibleValueException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCincompatibleValueException Class
Mergecom.Exceptions Namespace


MCincompatibleValueException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Methods
MCincompatibleValueException Class See Also Send Feedback

The MCincompatibleValueException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCincompatibleValueException Class
Mergecom.Exceptions Namespace


MCincompatibleValueException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCincompatibleValueException Properties
MCincompatibleValueException Class See Also Send Feedback

The MCincompatibleValueException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCincompatibleValueException Class
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Class
Members See Also Send Feedback
Exception thrown when a value contains characters incompatible with an attribute's Value Representation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidCharacterEncodingWarning : MCinvalidEncodingWarning
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidCharacterEncodingWarning _
    Inherits MCinvalidEncodingWarning
Visual C++
[SerializableAttribute]
public ref class MCinvalidCharacterEncodingWarning : public MCinvalidEncodingWarning

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidEncodingWarning
Mergecom.Exceptions..::..MCinvalidCharacterEncodingWarning

See Also

MCinvalidCharacterEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Members
MCinvalidCharacterEncodingWarning Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidCharacterEncodingWarning type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidCharacterEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidCharacterEncodingWarning(String) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidCharacterEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Constructor
MCinvalidCharacterEncodingWarning Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidCharacterEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidCharacterEncodingWarning(String) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidCharacterEncodingWarning Class
MCinvalidCharacterEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Constructor
MCinvalidCharacterEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidCharacterEncodingWarning()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidCharacterEncodingWarning()

Remarks

The exception number will be set to MCexception.INVALID_CHARACTERS_FOR_VR.

See Also

MCinvalidCharacterEncodingWarning Class
MCinvalidCharacterEncodingWarning Members
MCinvalidCharacterEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Constructor (String)
MCinvalidCharacterEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidCharacterEncodingWarning(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidCharacterEncodingWarning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_CHARACTERS_FOR_VR.

See Also

MCinvalidCharacterEncodingWarning Class
MCinvalidCharacterEncodingWarning Members
MCinvalidCharacterEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Fields
MCinvalidCharacterEncodingWarning Class See Also Send Feedback

The MCinvalidCharacterEncodingWarning type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidCharacterEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Methods
MCinvalidCharacterEncodingWarning Class See Also Send Feedback

The MCinvalidCharacterEncodingWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidCharacterEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidCharacterEncodingWarning Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidCharacterEncodingWarning Properties
MCinvalidCharacterEncodingWarning Class See Also Send Feedback

The MCinvalidCharacterEncodingWarning type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidCharacterEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Class
Members See Also Send Feedback
Exception thrown when an attempt to use an invalid record type string for a DICOMDIR directory record.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidDirRecordTypeException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidDirRecordTypeException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCinvalidDirRecordTypeException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidDirRecordTypeException

See Also

MCinvalidDirRecordTypeException Members
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Members
MCinvalidDirRecordTypeException Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidDirRecordTypeException type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidDirRecordTypeException()()()() | Initializes a new instance of this class.
Public method | MCinvalidDirRecordTypeException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidDirRecordTypeException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidDirRecordTypeException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidDirRecordTypeException Class
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Constructor
MCinvalidDirRecordTypeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidDirRecordTypeException()()()() | Initializes a new instance of this class.
Public method | MCinvalidDirRecordTypeException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidDirRecordTypeException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidDirRecordTypeException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidDirRecordTypeException Class
MCinvalidDirRecordTypeException Members
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Constructor
MCinvalidDirRecordTypeException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidDirRecordTypeException()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidDirRecordTypeException()

Remarks

The exception number will be set to MCexception.INVALID_DIR_RECORD_TYPE.

See Also

MCinvalidDirRecordTypeException Class
MCinvalidDirRecordTypeException Members
MCinvalidDirRecordTypeException Overload
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Constructor (String)
MCinvalidDirRecordTypeException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidDirRecordTypeException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidDirRecordTypeException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_DIR_RECORD_TYPE.

See Also

MCinvalidDirRecordTypeException Class
MCinvalidDirRecordTypeException Members
MCinvalidDirRecordTypeException Overload
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Constructor (SerializationInfo, StreamingContext)
MCinvalidDirRecordTypeException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidDirRecordTypeException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidDirRecordTypeException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidDirRecordTypeException Class
MCinvalidDirRecordTypeException Members
MCinvalidDirRecordTypeException Overload
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Constructor (String, Exception)
MCinvalidDirRecordTypeException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidDirRecordTypeException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidDirRecordTypeException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_DIR_RECORD_TYPE.

See Also

MCinvalidDirRecordTypeException Class
MCinvalidDirRecordTypeException Members
MCinvalidDirRecordTypeException Overload
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Fields
MCinvalidDirRecordTypeException Class See Also Send Feedback

The MCinvalidDirRecordTypeException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidDirRecordTypeException Class
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Methods
MCinvalidDirRecordTypeException Class See Also Send Feedback

The MCinvalidDirRecordTypeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidDirRecordTypeException Class
Mergecom.Exceptions Namespace


MCinvalidDirRecordTypeException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidDirRecordTypeException Properties
MCinvalidDirRecordTypeException Class See Also Send Feedback

The MCinvalidDirRecordTypeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidDirRecordTypeException Class
Mergecom.Exceptions Namespace


MCinvalidEncodingException Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Class
Members See Also Send Feedback
Exception thrown when an invalid DICOM encoding is encountered.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidEncodingException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidEncodingException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCinvalidEncodingException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidEncodingException

See Also

MCinvalidEncodingException Members
Mergecom.Exceptions Namespace


MCinvalidEncodingException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Members
MCinvalidEncodingException Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidEncodingException type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidEncodingException()()()() | Initializes a new instance of this class.
Public method | MCinvalidEncodingException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidEncodingException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidEncodingException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingException Class
Mergecom.Exceptions Namespace


MCinvalidEncodingException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Constructor
MCinvalidEncodingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidEncodingException()()()() | Initializes a new instance of this class.
Public method | MCinvalidEncodingException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidEncodingException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidEncodingException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidEncodingException Class
MCinvalidEncodingException Members
Mergecom.Exceptions Namespace


MCinvalidEncodingException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Constructor
MCinvalidEncodingException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingException()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidEncodingException()

Remarks

The exception number will be set to MCexception.INVALID_ENCODING.

See Also

MCinvalidEncodingException Class
MCinvalidEncodingException Members
MCinvalidEncodingException Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Constructor (String)
MCinvalidEncodingException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidEncodingException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_ENCODING.

See Also

MCinvalidEncodingException Class
MCinvalidEncodingException Members
MCinvalidEncodingException Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Constructor (SerializationInfo, StreamingContext)
MCinvalidEncodingException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidEncodingException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidEncodingException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidEncodingException Class
MCinvalidEncodingException Members
MCinvalidEncodingException Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Constructor (String, Exception)
MCinvalidEncodingException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidEncodingException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_ENCODING.

See Also

MCinvalidEncodingException Class
MCinvalidEncodingException Members
MCinvalidEncodingException Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Fields
MCinvalidEncodingException Class See Also Send Feedback

The MCinvalidEncodingException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidEncodingException Class
Mergecom.Exceptions Namespace


MCinvalidEncodingException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Methods
MCinvalidEncodingException Class See Also Send Feedback

The MCinvalidEncodingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingException Class
Mergecom.Exceptions Namespace


MCinvalidEncodingException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingException Properties
MCinvalidEncodingException Class See Also Send Feedback

The MCinvalidEncodingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingException Class
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Class
Members See Also Send Feedback
Exception thrown when a value contained characters incompatible with an attribute's Value Representation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidEncodingWarning : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidEncodingWarning _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCinvalidEncodingWarning : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidEncodingWarning
Mergecom.Exceptions..::..MCinvalidCharacterEncodingWarning
Mergecom.Exceptions..::..MCinvalidFormatEncodingWarning
Mergecom.Exceptions..::..MCinvalidLengthEncodingWarning

See Also

MCinvalidEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidEncodingWarning type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidEncodingWarning()()()() | Initializes a new instance of this class.
Protected method | MCinvalidEncodingWarning(Int32) | Initializes a new instance of this class with given exception number to be set.
Public method | MCinvalidEncodingWarning(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidEncodingWarning(Int32, String) | Initializes a new instance of this class with given exception number to be set and error message.
Protected method | MCinvalidEncodingWarning(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidEncodingWarning(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor
MCinvalidEncodingWarning Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidEncodingWarning()()()() | Initializes a new instance of this class.
Protected method | MCinvalidEncodingWarning(Int32) | Initializes a new instance of this class with given exception number to be set.
Public method | MCinvalidEncodingWarning(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidEncodingWarning(Int32, String) | Initializes a new instance of this class with given exception number to be set and error message.
Protected method | MCinvalidEncodingWarning(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidEncodingWarning(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor
MCinvalidEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingWarning()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidEncodingWarning()

Remarks

The exception number will be set to MCexception.INVALID_CHARS_IN_VALUE.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor (Int32)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor (Int32)
MCinvalidEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class with given exception number to be set.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidEncodingWarning(
    int exceptionNumber
)
Visual Basic
Protected Sub New ( _
    exceptionNumber As Integer _
)
Visual C++
protected:
MCinvalidEncodingWarning(
    int exceptionNumber
)

Parameters

exceptionNumber
Type: System..::..Int32
Merge DICOM Toolkit defined exception number.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor (String)
MCinvalidEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingWarning(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidEncodingWarning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_CHARS_IN_VALUE.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor (Int32, String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor (Int32, String)
MCinvalidEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class with given exception number to be set and error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidEncodingWarning(
    int exceptionNumber,
    string msg
)
Visual Basic
Protected Sub New ( _
    exceptionNumber As Integer, _
    msg As String _
)
Visual C++
protected:
MCinvalidEncodingWarning(
    int exceptionNumber,
    String^ msg
)

Parameters

exceptionNumber
Type: System..::..Int32
Merge DICOM Toolkit defined exception number.
msg
Type: System..::..String
Exception message.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor (SerializationInfo, StreamingContext)
MCinvalidEncodingWarning Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidEncodingWarning(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidEncodingWarning(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Constructor (String, Exception)
MCinvalidEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidEncodingWarning(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidEncodingWarning(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_CHARS_IN_VALUE.

See Also

MCinvalidEncodingWarning Class
MCinvalidEncodingWarning Members
MCinvalidEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Fields
MCinvalidEncodingWarning Class See Also Send Feedback

The MCinvalidEncodingWarning type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Methods
MCinvalidEncodingWarning Class See Also Send Feedback

The MCinvalidEncodingWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidEncodingWarning Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidEncodingWarning Properties
MCinvalidEncodingWarning Class See Also Send Feedback

The MCinvalidEncodingWarning type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Class
Members See Also Send Feedback
Exception thrown when a value has a format incompatible with an attribute's Value Representation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidFormatEncodingWarning : MCinvalidEncodingWarning
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidFormatEncodingWarning _
    Inherits MCinvalidEncodingWarning
Visual C++
[SerializableAttribute]
public ref class MCinvalidFormatEncodingWarning : public MCinvalidEncodingWarning

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidEncodingWarning
Mergecom.Exceptions..::..MCinvalidFormatEncodingWarning

See Also

MCinvalidFormatEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Members
MCinvalidFormatEncodingWarning Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidFormatEncodingWarning type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidFormatEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidFormatEncodingWarning(String) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidFormatEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Constructor
MCinvalidFormatEncodingWarning Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidFormatEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidFormatEncodingWarning(String) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidFormatEncodingWarning Class
MCinvalidFormatEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Constructor
MCinvalidFormatEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidFormatEncodingWarning()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidFormatEncodingWarning()

Remarks

The exception number will be set to MCexception.INVALID_FORMAT_FOR_VR.

See Also

MCinvalidFormatEncodingWarning Class
MCinvalidFormatEncodingWarning Members
MCinvalidFormatEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Constructor (String)
MCinvalidFormatEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidFormatEncodingWarning(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidFormatEncodingWarning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_FORMAT_FOR_VR.

See Also

MCinvalidFormatEncodingWarning Class
MCinvalidFormatEncodingWarning Members
MCinvalidFormatEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Fields
MCinvalidFormatEncodingWarning Class See Also Send Feedback

The MCinvalidFormatEncodingWarning type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidFormatEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Methods
MCinvalidFormatEncodingWarning Class See Also Send Feedback

The MCinvalidFormatEncodingWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidFormatEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidFormatEncodingWarning Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidFormatEncodingWarning Properties
MCinvalidFormatEncodingWarning Class See Also Send Feedback

The MCinvalidFormatEncodingWarning type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidFormatEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Class
Members See Also Send Feedback
Exception thrown when a value has a length incompatible with an attribute's Value Representation.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidLengthEncodingWarning : MCinvalidEncodingWarning
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidLengthEncodingWarning _
    Inherits MCinvalidEncodingWarning
Visual C++
[SerializableAttribute]
public ref class MCinvalidLengthEncodingWarning : public MCinvalidEncodingWarning

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidEncodingWarning
Mergecom.Exceptions..::..MCinvalidLengthEncodingWarning

See Also

MCinvalidLengthEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Members
MCinvalidLengthEncodingWarning Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidLengthEncodingWarning type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidLengthEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidLengthEncodingWarning(String) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidLengthEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Constructor
MCinvalidLengthEncodingWarning Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidLengthEncodingWarning()()()() | Initializes a new instance of this class.
Public method | MCinvalidLengthEncodingWarning(String) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidLengthEncodingWarning Class
MCinvalidLengthEncodingWarning Members
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Constructor
MCinvalidLengthEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidLengthEncodingWarning()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidLengthEncodingWarning()

Remarks

The exception number will be set to MCexception.INVALID_LENGTH_FOR_VR.

See Also

MCinvalidLengthEncodingWarning Class
MCinvalidLengthEncodingWarning Members
MCinvalidLengthEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Constructor (String)
MCinvalidLengthEncodingWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidLengthEncodingWarning(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidLengthEncodingWarning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_LENGTH_FOR_VR.

See Also

MCinvalidLengthEncodingWarning Class
MCinvalidLengthEncodingWarning Members
MCinvalidLengthEncodingWarning Overload
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Fields
MCinvalidLengthEncodingWarning Class See Also Send Feedback

The MCinvalidLengthEncodingWarning type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidLengthEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Methods
MCinvalidLengthEncodingWarning Class See Also Send Feedback

The MCinvalidLengthEncodingWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidLengthEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidLengthEncodingWarning Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLengthEncodingWarning Properties
MCinvalidLengthEncodingWarning Class See Also Send Feedback

The MCinvalidLengthEncodingWarning type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidLengthEncodingWarning Class
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Class
Members See Also Send Feedback
Exception thrown when there is invalid license info in configuration files.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidLicenseInfoError : MCruntimeException
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidLicenseInfoError _
    Inherits MCruntimeException
Visual C++
[SerializableAttribute]
public ref class MCinvalidLicenseInfoError : public MCruntimeException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCruntimeException
Mergecom.Exceptions..::..MCinvalidLicenseInfoError

See Also

MCinvalidLicenseInfoError Members
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Members
MCinvalidLicenseInfoError Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidLicenseInfoError type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidLicenseInfoError()()()() | Initializes a new instance of this class.
Public method | MCinvalidLicenseInfoError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidLicenseInfoError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidLicenseInfoError(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidLicenseInfoError Class
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Constructor
MCinvalidLicenseInfoError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidLicenseInfoError()()()() | Initializes a new instance of this class.
Public method | MCinvalidLicenseInfoError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidLicenseInfoError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidLicenseInfoError(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidLicenseInfoError Class
MCinvalidLicenseInfoError Members
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Constructor
MCinvalidLicenseInfoError Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidLicenseInfoError()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidLicenseInfoError()

Remarks

The exception number will be set to MCexception.INVALID_LICENSE.

See Also

MCinvalidLicenseInfoError Class
MCinvalidLicenseInfoError Members
MCinvalidLicenseInfoError Overload
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Constructor (String)
MCinvalidLicenseInfoError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidLicenseInfoError(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidLicenseInfoError(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_LICENSE.

See Also

MCinvalidLicenseInfoError Class
MCinvalidLicenseInfoError Members
MCinvalidLicenseInfoError Overload
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Constructor (SerializationInfo, StreamingContext)
MCinvalidLicenseInfoError Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidLicenseInfoError(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidLicenseInfoError(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidLicenseInfoError Class
MCinvalidLicenseInfoError Members
MCinvalidLicenseInfoError Overload
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Constructor (String, Exception)
MCinvalidLicenseInfoError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidLicenseInfoError(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidLicenseInfoError(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_LICENSE.

See Also

MCinvalidLicenseInfoError Class
MCinvalidLicenseInfoError Members
MCinvalidLicenseInfoError Overload
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Fields
MCinvalidLicenseInfoError Class See Also Send Feedback

The MCinvalidLicenseInfoError type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidLicenseInfoError Class
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Methods
MCinvalidLicenseInfoError Class See Also Send Feedback

The MCinvalidLicenseInfoError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidLicenseInfoError Class
Mergecom.Exceptions Namespace


MCinvalidLicenseInfoError Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidLicenseInfoError Properties
MCinvalidLicenseInfoError Class See Also Send Feedback

The MCinvalidLicenseInfoError type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidLicenseInfoError Class
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Class
Members See Also Send Feedback
Exception thrown when an invalid DIMSE message was received.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidMessageReceivedException : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidMessageReceivedException _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCinvalidMessageReceivedException : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCinvalidMessageReceivedException

See Also

MCinvalidMessageReceivedException Members
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Members
MCinvalidMessageReceivedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidMessageReceivedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidMessageReceivedException()()()() | Initializes a new instance of this class.
Public method | MCinvalidMessageReceivedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidMessageReceivedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidMessageReceivedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidMessageReceivedException Class
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Constructor
MCinvalidMessageReceivedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidMessageReceivedException()()()() | Initializes a new instance of this class.
Public method | MCinvalidMessageReceivedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidMessageReceivedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidMessageReceivedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidMessageReceivedException Class
MCinvalidMessageReceivedException Members
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Constructor
MCinvalidMessageReceivedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidMessageReceivedException()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidMessageReceivedException()

Remarks

The exception number will be set to MCexception.INVALID_MESSAGE_RECEIVED.

See Also

MCinvalidMessageReceivedException Class
MCinvalidMessageReceivedException Members
MCinvalidMessageReceivedException Overload
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Constructor (String)
MCinvalidMessageReceivedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidMessageReceivedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidMessageReceivedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_MESSAGE_RECEIVED.

See Also

MCinvalidMessageReceivedException Class
MCinvalidMessageReceivedException Members
MCinvalidMessageReceivedException Overload
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Constructor (SerializationInfo, StreamingContext)
MCinvalidMessageReceivedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidMessageReceivedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidMessageReceivedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidMessageReceivedException Class
MCinvalidMessageReceivedException Members
MCinvalidMessageReceivedException Overload
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Constructor (String, Exception)
MCinvalidMessageReceivedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidMessageReceivedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidMessageReceivedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_MESSAGE_RECEIVED.

See Also

MCinvalidMessageReceivedException Class
MCinvalidMessageReceivedException Members
MCinvalidMessageReceivedException Overload
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Fields
MCinvalidMessageReceivedException Class See Also Send Feedback

The MCinvalidMessageReceivedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidMessageReceivedException Class
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Methods
MCinvalidMessageReceivedException Class See Also Send Feedback

The MCinvalidMessageReceivedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidMessageReceivedException Class
Mergecom.Exceptions Namespace


MCinvalidMessageReceivedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidMessageReceivedException Properties
MCinvalidMessageReceivedException Class See Also Send Feedback

The MCinvalidMessageReceivedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidMessageReceivedException Class
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Class

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Class
Members See Also Send Feedback
Exception thrown when an invalid transfer syntax was encountered.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCinvalidTransferSyntaxException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCinvalidTransferSyntaxException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCinvalidTransferSyntaxException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCinvalidTransferSyntaxException

See Also

MCinvalidTransferSyntaxException Members
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Members
MCinvalidTransferSyntaxException Class Constructors Methods Fields Properties See Also Send Feedback

The MCinvalidTransferSyntaxException type exposes the following members.

Constructors

 | Name | Description
Public method | MCinvalidTransferSyntaxException()()()() | Initializes a new instance of this class.
Public method | MCinvalidTransferSyntaxException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidTransferSyntaxException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidTransferSyntaxException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidTransferSyntaxException Class
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Constructor
MCinvalidTransferSyntaxException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCinvalidTransferSyntaxException()()()() | Initializes a new instance of this class.
Public method | MCinvalidTransferSyntaxException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCinvalidTransferSyntaxException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCinvalidTransferSyntaxException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCinvalidTransferSyntaxException Class
MCinvalidTransferSyntaxException Members
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Constructor
MCinvalidTransferSyntaxException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidTransferSyntaxException()
Visual Basic
Public Sub New
Visual C++
public:
MCinvalidTransferSyntaxException()

Remarks

The exception number will be set to MCexception.INVALID_TRANSFER_SYNTAX_CODE.

See Also

MCinvalidTransferSyntaxException Class
MCinvalidTransferSyntaxException Members
MCinvalidTransferSyntaxException Overload
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Constructor (String)
MCinvalidTransferSyntaxException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidTransferSyntaxException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCinvalidTransferSyntaxException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.INVALID_TRANSFER_SYNTAX_CODE.

See Also

MCinvalidTransferSyntaxException Class
MCinvalidTransferSyntaxException Members
MCinvalidTransferSyntaxException Overload
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Constructor (SerializationInfo, StreamingContext)
MCinvalidTransferSyntaxException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCinvalidTransferSyntaxException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCinvalidTransferSyntaxException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCinvalidTransferSyntaxException Class
MCinvalidTransferSyntaxException Members
MCinvalidTransferSyntaxException Overload
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Constructor (String, Exception)
MCinvalidTransferSyntaxException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCinvalidTransferSyntaxException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCinvalidTransferSyntaxException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.INVALID_TRANSFER_SYNTAX_CODE.

See Also

MCinvalidTransferSyntaxException Class
MCinvalidTransferSyntaxException Members
MCinvalidTransferSyntaxException Overload
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Fields
MCinvalidTransferSyntaxException Class See Also Send Feedback

The MCinvalidTransferSyntaxException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCinvalidTransferSyntaxException Class
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Methods
MCinvalidTransferSyntaxException Class See Also Send Feedback

The MCinvalidTransferSyntaxException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCinvalidTransferSyntaxException Class
Mergecom.Exceptions Namespace


MCinvalidTransferSyntaxException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCinvalidTransferSyntaxException Properties
MCinvalidTransferSyntaxException Class See Also Send Feedback

The MCinvalidTransferSyntaxException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCinvalidTransferSyntaxException Class
Mergecom.Exceptions Namespace


MClostConnectionException Class

[image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Class
Members See Also Send Feedback
Exception thrown when the connection for an association is lost.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MClostConnectionException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MClostConnectionException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MClostConnectionException : public MCexception

Remarks

Typically one of the sub-classes of this exception is thrown.

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCassociationAbortedException
Mergecom.Exceptions..::..MCassociationReleasedStatus
Mergecom.Exceptions..::..MCconfigFileErrorException
Mergecom.Exceptions..::..MCinactivityTimeoutException
Mergecom.Exceptions..::..MCinvalidMessageReceivedException
Mergecom.Exceptions..::..MCnetworkShutdownException

See Also

MClostConnectionException Members
Mergecom.Exceptions Namespace


MClostConnectionException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Members
MClostConnectionException Class Constructors Methods Fields Properties See Also Send Feedback

The MClostConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | MClostConnectionException()()()() | Initializes a new instance of this class.
Public method | MClostConnectionException(String) | Initializes a new instance of this class for a given error message.
Protected method | MClostConnectionException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MClostConnectionException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MClostConnectionException Class
Mergecom.Exceptions Namespace


MClostConnectionException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Constructor
MClostConnectionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MClostConnectionException()()()() | Initializes a new instance of this class.
Public method | MClostConnectionException(String) | Initializes a new instance of this class for a given error message.
Protected method | MClostConnectionException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MClostConnectionException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MClostConnectionException Class
MClostConnectionException Members
Mergecom.Exceptions Namespace


MClostConnectionException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Constructor
MClostConnectionException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClostConnectionException()
Visual Basic
Public Sub New
Visual C++
public:
MClostConnectionException()

Remarks

The exception number will be set to MCexception.LOST_CONNECTION.

See Also

MClostConnectionException Class
MClostConnectionException Members
MClostConnectionException Overload
Mergecom.Exceptions Namespace


MClostConnectionException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Constructor (String)
MClostConnectionException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClostConnectionException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MClostConnectionException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.LOST_CONNECTION.

See Also

MClostConnectionException Class
MClostConnectionException Members
MClostConnectionException Overload
Mergecom.Exceptions Namespace


MClostConnectionException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Constructor (SerializationInfo, StreamingContext)
MClostConnectionException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MClostConnectionException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MClostConnectionException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MClostConnectionException Class
MClostConnectionException Members
MClostConnectionException Overload
Mergecom.Exceptions Namespace


MClostConnectionException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Constructor (String, Exception)
MClostConnectionException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClostConnectionException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MClostConnectionException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.LOST_CONNECTION.

See Also

MClostConnectionException Class
MClostConnectionException Members
MClostConnectionException Overload
Mergecom.Exceptions Namespace


MClostConnectionException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Fields
MClostConnectionException Class See Also Send Feedback

The MClostConnectionException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MClostConnectionException Class
Mergecom.Exceptions Namespace


MClostConnectionException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Methods
MClostConnectionException Class See Also Send Feedback

The MClostConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MClostConnectionException Class
Mergecom.Exceptions Namespace


MClostConnectionException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MClostConnectionException Properties
MClostConnectionException Class See Also Send Feedback

The MClostConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MClostConnectionException Class
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Class

[image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Class
Members See Also Send Feedback
Exception that is thrown when sending a DICOM message over an association would cause the maximum operations negotiated for an associations to be exceeded.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCmaxOperationsExceededWarning : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCmaxOperationsExceededWarning _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCmaxOperationsExceededWarning : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCmaxOperationsExceededWarning

See Also

MCmaxOperationsExceededWarning Members
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Members
MCmaxOperationsExceededWarning Class Constructors Methods Fields Properties See Also Send Feedback

The MCmaxOperationsExceededWarning type exposes the following members.

Constructors

 | Name | Description
Public method | MCmaxOperationsExceededWarning()()()() | Initializes a new instance of this class.
Public method | MCmaxOperationsExceededWarning(String) | Initializes a new instance of this class for a given error message.
Protected method | MCmaxOperationsExceededWarning(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCmaxOperationsExceededWarning(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCmaxOperationsExceededWarning Class
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Constructor
MCmaxOperationsExceededWarning Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCmaxOperationsExceededWarning()()()() | Initializes a new instance of this class.
Public method | MCmaxOperationsExceededWarning(String) | Initializes a new instance of this class for a given error message.
Protected method | MCmaxOperationsExceededWarning(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCmaxOperationsExceededWarning(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCmaxOperationsExceededWarning Class
MCmaxOperationsExceededWarning Members
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Constructor
MCmaxOperationsExceededWarning Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmaxOperationsExceededWarning()
Visual Basic
Public Sub New
Visual C++
public:
MCmaxOperationsExceededWarning()

Remarks

The exception number will be set to MCexception.MAX_OPERATIONS_EXCEEDED.

See Also

MCmaxOperationsExceededWarning Class
MCmaxOperationsExceededWarning Members
MCmaxOperationsExceededWarning Overload
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Constructor (String)
MCmaxOperationsExceededWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmaxOperationsExceededWarning(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCmaxOperationsExceededWarning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.MAX_OPERATIONS_EXCEEDED.

See Also

MCmaxOperationsExceededWarning Class
MCmaxOperationsExceededWarning Members
MCmaxOperationsExceededWarning Overload
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Constructor (SerializationInfo, StreamingContext)
MCmaxOperationsExceededWarning Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCmaxOperationsExceededWarning(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCmaxOperationsExceededWarning(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCmaxOperationsExceededWarning Class
MCmaxOperationsExceededWarning Members
MCmaxOperationsExceededWarning Overload
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Constructor (String, Exception)
MCmaxOperationsExceededWarning Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmaxOperationsExceededWarning(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCmaxOperationsExceededWarning(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.MAX_OPERATIONS_EXCEEDED.

See Also

MCmaxOperationsExceededWarning Class
MCmaxOperationsExceededWarning Members
MCmaxOperationsExceededWarning Overload
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Fields
MCmaxOperationsExceededWarning Class See Also Send Feedback

The MCmaxOperationsExceededWarning type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCmaxOperationsExceededWarning Class
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Methods
MCmaxOperationsExceededWarning Class See Also Send Feedback

The MCmaxOperationsExceededWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCmaxOperationsExceededWarning Class
Mergecom.Exceptions Namespace


MCmaxOperationsExceededWarning Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmaxOperationsExceededWarning Properties
MCmaxOperationsExceededWarning Class See Also Send Feedback

The MCmaxOperationsExceededWarning type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCmaxOperationsExceededWarning Class
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Class
Members See Also Send Feedback
Exception thrown when an association request was aborted before it could complete.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnegotiationAbortedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCnegotiationAbortedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCnegotiationAbortedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCnegotiationAbortedException

See Also

MCnegotiationAbortedException Members
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Members
MCnegotiationAbortedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnegotiationAbortedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnegotiationAbortedException()()()() | Initializes a new instance of this class.
Public method | MCnegotiationAbortedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnegotiationAbortedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnegotiationAbortedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnegotiationAbortedException Class
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Constructor
MCnegotiationAbortedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnegotiationAbortedException()()()() | Initializes a new instance of this class.
Public method | MCnegotiationAbortedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnegotiationAbortedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnegotiationAbortedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnegotiationAbortedException Class
MCnegotiationAbortedException Members
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Constructor
MCnegotiationAbortedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnegotiationAbortedException()
Visual Basic
Public Sub New
Visual C++
public:
MCnegotiationAbortedException()

Remarks

The exception number will be set to MCexception.NEGOTIATION_ABORTED.

See Also

MCnegotiationAbortedException Class
MCnegotiationAbortedException Members
MCnegotiationAbortedException Overload
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Constructor (String)
MCnegotiationAbortedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnegotiationAbortedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnegotiationAbortedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NEGOTIATION_ABORTED.

See Also

MCnegotiationAbortedException Class
MCnegotiationAbortedException Members
MCnegotiationAbortedException Overload
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Constructor (SerializationInfo, StreamingContext)
MCnegotiationAbortedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnegotiationAbortedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnegotiationAbortedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnegotiationAbortedException Class
MCnegotiationAbortedException Members
MCnegotiationAbortedException Overload
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Constructor (String, Exception)
MCnegotiationAbortedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnegotiationAbortedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnegotiationAbortedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NEGOTIATION_ABORTED.

See Also

MCnegotiationAbortedException Class
MCnegotiationAbortedException Members
MCnegotiationAbortedException Overload
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Fields
MCnegotiationAbortedException Class See Also Send Feedback

The MCnegotiationAbortedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnegotiationAbortedException Class
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Methods
MCnegotiationAbortedException Class See Also Send Feedback

The MCnegotiationAbortedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnegotiationAbortedException Class
Mergecom.Exceptions Namespace


MCnegotiationAbortedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnegotiationAbortedException Properties
MCnegotiationAbortedException Class See Also Send Feedback

The MCnegotiationAbortedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnegotiationAbortedException Class
Mergecom.Exceptions Namespace


MCnetworkShutdownException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Class
Members See Also Send Feedback
Exception thrown when the network unexpectedly shut down.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnetworkShutdownException : MClostConnectionException
Visual Basic
<SerializableAttribute> _
Public Class MCnetworkShutdownException _
    Inherits MClostConnectionException
Visual C++
[SerializableAttribute]
public ref class MCnetworkShutdownException : public MClostConnectionException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MClostConnectionException
Mergecom.Exceptions..::..MCnetworkShutdownException

See Also

MCnetworkShutdownException Members
Mergecom.Exceptions Namespace


MCnetworkShutdownException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Members
MCnetworkShutdownException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnetworkShutdownException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnetworkShutdownException()()()() | Initializes a new instance of this class.
Public method | MCnetworkShutdownException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnetworkShutdownException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnetworkShutdownException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnetworkShutdownException Class
Mergecom.Exceptions Namespace


MCnetworkShutdownException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Constructor
MCnetworkShutdownException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnetworkShutdownException()()()() | Initializes a new instance of this class.
Public method | MCnetworkShutdownException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnetworkShutdownException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnetworkShutdownException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnetworkShutdownException Class
MCnetworkShutdownException Members
Mergecom.Exceptions Namespace


MCnetworkShutdownException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Constructor
MCnetworkShutdownException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnetworkShutdownException()
Visual Basic
Public Sub New
Visual C++
public:
MCnetworkShutdownException()

Remarks

The exception number will be set to MCexception.NETWORK_SHUTDOWN.

See Also

MCnetworkShutdownException Class
MCnetworkShutdownException Members
MCnetworkShutdownException Overload
Mergecom.Exceptions Namespace


MCnetworkShutdownException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Constructor (String)
MCnetworkShutdownException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnetworkShutdownException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnetworkShutdownException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NETWORK_SHUTDOWN.

See Also

MCnetworkShutdownException Class
MCnetworkShutdownException Members
MCnetworkShutdownException Overload
Mergecom.Exceptions Namespace


MCnetworkShutdownException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Constructor (SerializationInfo, StreamingContext)
MCnetworkShutdownException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnetworkShutdownException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnetworkShutdownException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnetworkShutdownException Class
MCnetworkShutdownException Members
MCnetworkShutdownException Overload
Mergecom.Exceptions Namespace


MCnetworkShutdownException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Constructor (String, Exception)
MCnetworkShutdownException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnetworkShutdownException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnetworkShutdownException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NETWORK_SHUTDOWN.

See Also

MCnetworkShutdownException Class
MCnetworkShutdownException Members
MCnetworkShutdownException Overload
Mergecom.Exceptions Namespace


MCnetworkShutdownException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Fields
MCnetworkShutdownException Class See Also Send Feedback

The MCnetworkShutdownException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnetworkShutdownException Class
Mergecom.Exceptions Namespace


MCnetworkShutdownException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Methods
MCnetworkShutdownException Class See Also Send Feedback

The MCnetworkShutdownException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnetworkShutdownException Class
Mergecom.Exceptions Namespace


MCnetworkShutdownException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnetworkShutdownException Properties
MCnetworkShutdownException Class See Also Send Feedback

The MCnetworkShutdownException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnetworkShutdownException Class
Mergecom.Exceptions Namespace


MCnoAttributesException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Class
Members See Also Send Feedback
Exception thrown when there are no attributes in an attribute set.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnoAttributesException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCnoAttributesException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCnoAttributesException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCnoAttributesException

See Also

MCnoAttributesException Members
Mergecom.Exceptions Namespace


MCnoAttributesException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Members
MCnoAttributesException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnoAttributesException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnoAttributesException()()()() | Initializes a new instance of this class.
Public method | MCnoAttributesException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnoAttributesException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnoAttributesException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnoAttributesException Class
Mergecom.Exceptions Namespace


MCnoAttributesException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Constructor
MCnoAttributesException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnoAttributesException()()()() | Initializes a new instance of this class.
Public method | MCnoAttributesException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnoAttributesException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnoAttributesException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnoAttributesException Class
MCnoAttributesException Members
Mergecom.Exceptions Namespace


MCnoAttributesException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Constructor
MCnoAttributesException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoAttributesException()
Visual Basic
Public Sub New
Visual C++
public:
MCnoAttributesException()

Remarks

The exception number will be set to MCexception.NO_ATTRIBUTES.

See Also

MCnoAttributesException Class
MCnoAttributesException Members
MCnoAttributesException Overload
Mergecom.Exceptions Namespace


MCnoAttributesException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Constructor (String)
MCnoAttributesException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoAttributesException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnoAttributesException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NO_ATTRIBUTES.

See Also

MCnoAttributesException Class
MCnoAttributesException Members
MCnoAttributesException Overload
Mergecom.Exceptions Namespace


MCnoAttributesException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Constructor (SerializationInfo, StreamingContext)
MCnoAttributesException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnoAttributesException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnoAttributesException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnoAttributesException Class
MCnoAttributesException Members
MCnoAttributesException Overload
Mergecom.Exceptions Namespace


MCnoAttributesException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Constructor (String, Exception)
MCnoAttributesException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoAttributesException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnoAttributesException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NO_ATTRIBUTES.

See Also

MCnoAttributesException Class
MCnoAttributesException Members
MCnoAttributesException Overload
Mergecom.Exceptions Namespace


MCnoAttributesException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Fields
MCnoAttributesException Class See Also Send Feedback

The MCnoAttributesException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnoAttributesException Class
Mergecom.Exceptions Namespace


MCnoAttributesException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Methods
MCnoAttributesException Class See Also Send Feedback

The MCnoAttributesException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnoAttributesException Class
Mergecom.Exceptions Namespace


MCnoAttributesException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoAttributesException Properties
MCnoAttributesException Class See Also Send Feedback

The MCnoAttributesException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnoAttributesException Class
Mergecom.Exceptions Namespace


MCnoSuchValueException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Class
Members See Also Send Feedback
Exception thrown when a specified attribute value does not exist.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnoSuchValueException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCnoSuchValueException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCnoSuchValueException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCnoSuchValueException

See Also

MCnoSuchValueException Members
Mergecom.Exceptions Namespace


MCnoSuchValueException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Members
MCnoSuchValueException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnoSuchValueException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnoSuchValueException()()()() | Initializes a new instance of this class.
Public method | MCnoSuchValueException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnoSuchValueException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnoSuchValueException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnoSuchValueException Class
Mergecom.Exceptions Namespace


MCnoSuchValueException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Constructor
MCnoSuchValueException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnoSuchValueException()()()() | Initializes a new instance of this class.
Public method | MCnoSuchValueException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnoSuchValueException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnoSuchValueException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnoSuchValueException Class
MCnoSuchValueException Members
Mergecom.Exceptions Namespace


MCnoSuchValueException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Constructor
MCnoSuchValueException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoSuchValueException()
Visual Basic
Public Sub New
Visual C++
public:
MCnoSuchValueException()

Remarks

The exception number will be set to MCexception.NO_SUCH_VALUE.

See Also

MCnoSuchValueException Class
MCnoSuchValueException Members
MCnoSuchValueException Overload
Mergecom.Exceptions Namespace


MCnoSuchValueException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Constructor (String)
MCnoSuchValueException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoSuchValueException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnoSuchValueException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NO_SUCH_VALUE.

See Also

MCnoSuchValueException Class
MCnoSuchValueException Members
MCnoSuchValueException Overload
Mergecom.Exceptions Namespace


MCnoSuchValueException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Constructor (SerializationInfo, StreamingContext)
MCnoSuchValueException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnoSuchValueException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnoSuchValueException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnoSuchValueException Class
MCnoSuchValueException Members
MCnoSuchValueException Overload
Mergecom.Exceptions Namespace


MCnoSuchValueException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Constructor (String, Exception)
MCnoSuchValueException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnoSuchValueException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnoSuchValueException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NO_SUCH_VALUE.

See Also

MCnoSuchValueException Class
MCnoSuchValueException Members
MCnoSuchValueException Overload
Mergecom.Exceptions Namespace


MCnoSuchValueException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Fields
MCnoSuchValueException Class See Also Send Feedback

The MCnoSuchValueException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnoSuchValueException Class
Mergecom.Exceptions Namespace


MCnoSuchValueException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Methods
MCnoSuchValueException Class See Also Send Feedback

The MCnoSuchValueException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnoSuchValueException Class
Mergecom.Exceptions Namespace


MCnoSuchValueException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnoSuchValueException Properties
MCnoSuchValueException Class See Also Send Feedback

The MCnoSuchValueException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnoSuchValueException Class
Mergecom.Exceptions Namespace


MCnotFoundException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Class
Members See Also Send Feedback
Exception thrown when something requested could not be found.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnotFoundException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCnotFoundException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCnotFoundException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCnotFoundException

See Also

MCnotFoundException Members
Mergecom.Exceptions Namespace


MCnotFoundException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Members
MCnotFoundException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnotFoundException()()()() | Initializes a new instance of this class.
Public method | MCnotFoundException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotFoundException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotFoundException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotFoundException Class
Mergecom.Exceptions Namespace


MCnotFoundException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Constructor
MCnotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnotFoundException()()()() | Initializes a new instance of this class.
Public method | MCnotFoundException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotFoundException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotFoundException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnotFoundException Class
MCnotFoundException Members
Mergecom.Exceptions Namespace


MCnotFoundException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Constructor
MCnotFoundException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
MCnotFoundException()

Remarks

The exception number will be set to MCexception.NOT_FOUND.

See Also

MCnotFoundException Class
MCnotFoundException Members
MCnotFoundException Overload
Mergecom.Exceptions Namespace


MCnotFoundException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Constructor (String)
MCnotFoundException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotFoundException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnotFoundException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NOT_FOUND.

See Also

MCnotFoundException Class
MCnotFoundException Members
MCnotFoundException Overload
Mergecom.Exceptions Namespace


MCnotFoundException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Constructor (SerializationInfo, StreamingContext)
MCnotFoundException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnotFoundException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnotFoundException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnotFoundException Class
MCnotFoundException Members
MCnotFoundException Overload
Mergecom.Exceptions Namespace


MCnotFoundException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Constructor (String, Exception)
MCnotFoundException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotFoundException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnotFoundException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NOT_FOUND.

See Also

MCnotFoundException Class
MCnotFoundException Members
MCnotFoundException Overload
Mergecom.Exceptions Namespace


MCnotFoundException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Fields
MCnotFoundException Class See Also Send Feedback

The MCnotFoundException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnotFoundException Class
Mergecom.Exceptions Namespace


MCnotFoundException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Methods
MCnotFoundException Class See Also Send Feedback

The MCnotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnotFoundException Class
Mergecom.Exceptions Namespace


MCnotFoundException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotFoundException Properties
MCnotFoundException Class See Also Send Feedback

The MCnotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotFoundException Class
Mergecom.Exceptions Namespace


MCnotInitializedError Class

[image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Class
Members See Also Send Feedback
Exception thrown when the MergeCOM library has not yet been initialized or it has been released.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnotInitializedError : MCruntimeException
Visual Basic
<SerializableAttribute> _
Public Class MCnotInitializedError _
    Inherits MCruntimeException
Visual C++
[SerializableAttribute]
public ref class MCnotInitializedError : public MCruntimeException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCruntimeException
Mergecom.Exceptions..::..MCnotInitializedError

See Also

MCnotInitializedError Members
Mergecom.Exceptions Namespace


MCnotInitializedError Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Members
MCnotInitializedError Class Constructors Methods Fields Properties See Also Send Feedback

The MCnotInitializedError type exposes the following members.

Constructors

 | Name | Description
Public method | MCnotInitializedError()()()() | Initializes a new instance of this class.
Public method | MCnotInitializedError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotInitializedError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotInitializedError(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotInitializedError Class
Mergecom.Exceptions Namespace


MCnotInitializedError Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Constructor
MCnotInitializedError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnotInitializedError()()()() | Initializes a new instance of this class.
Public method | MCnotInitializedError(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotInitializedError(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotInitializedError(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnotInitializedError Class
MCnotInitializedError Members
Mergecom.Exceptions Namespace


MCnotInitializedError Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Constructor
MCnotInitializedError Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotInitializedError()
Visual Basic
Public Sub New
Visual C++
public:
MCnotInitializedError()

Remarks

The exception number will be set to MCexception.NOT_INITIALIZED_EXCEPTION.

See Also

MCnotInitializedError Class
MCnotInitializedError Members
MCnotInitializedError Overload
Mergecom.Exceptions Namespace


MCnotInitializedError Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Constructor (String)
MCnotInitializedError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotInitializedError(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnotInitializedError(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NOT_INITIALIZED_EXCEPTION.

See Also

MCnotInitializedError Class
MCnotInitializedError Members
MCnotInitializedError Overload
Mergecom.Exceptions Namespace


MCnotInitializedError Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Constructor (SerializationInfo, StreamingContext)
MCnotInitializedError Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnotInitializedError(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnotInitializedError(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnotInitializedError Class
MCnotInitializedError Members
MCnotInitializedError Overload
Mergecom.Exceptions Namespace


MCnotInitializedError Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Constructor (String, Exception)
MCnotInitializedError Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotInitializedError(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnotInitializedError(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NOT_INITIALIZED_EXCEPTION.

See Also

MCnotInitializedError Class
MCnotInitializedError Members
MCnotInitializedError Overload
Mergecom.Exceptions Namespace


MCnotInitializedError Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Fields
MCnotInitializedError Class See Also Send Feedback

The MCnotInitializedError type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnotInitializedError Class
Mergecom.Exceptions Namespace


MCnotInitializedError Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Methods
MCnotInitializedError Class See Also Send Feedback

The MCnotInitializedError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnotInitializedError Class
Mergecom.Exceptions Namespace


MCnotInitializedError Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotInitializedError Properties
MCnotInitializedError Class See Also Send Feedback

The MCnotInitializedError type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotInitializedError Class
Mergecom.Exceptions Namespace


MCnotStandardElementException Class

[image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Class
Members See Also Send Feedback
Exception thrown when a non-standard data element was specified when a standard element was required.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCnotStandardElementException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCnotStandardElementException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCnotStandardElementException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCnotStandardElementException

See Also

MCnotStandardElementException Members
Mergecom.Exceptions Namespace


MCnotStandardElementException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Members
MCnotStandardElementException Class Constructors Methods Fields Properties See Also Send Feedback

The MCnotStandardElementException type exposes the following members.

Constructors

 | Name | Description
Public method | MCnotStandardElementException()()()() | Initializes a new instance of this class.
Public method | MCnotStandardElementException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotStandardElementException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotStandardElementException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotStandardElementException Class
Mergecom.Exceptions Namespace


MCnotStandardElementException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Constructor
MCnotStandardElementException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnotStandardElementException()()()() | Initializes a new instance of this class.
Public method | MCnotStandardElementException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCnotStandardElementException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCnotStandardElementException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCnotStandardElementException Class
MCnotStandardElementException Members
Mergecom.Exceptions Namespace


MCnotStandardElementException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Constructor
MCnotStandardElementException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotStandardElementException()
Visual Basic
Public Sub New
Visual C++
public:
MCnotStandardElementException()

Remarks

The exception number will be set to MCexception.NOT_A_STANDARD_DATA_ELEMENT.

See Also

MCnotStandardElementException Class
MCnotStandardElementException Members
MCnotStandardElementException Overload
Mergecom.Exceptions Namespace


MCnotStandardElementException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Constructor (String)
MCnotStandardElementException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotStandardElementException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCnotStandardElementException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.NOT_A_STANDARD_DATA_ELEMENT.

See Also

MCnotStandardElementException Class
MCnotStandardElementException Members
MCnotStandardElementException Overload
Mergecom.Exceptions Namespace


MCnotStandardElementException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Constructor (SerializationInfo, StreamingContext)
MCnotStandardElementException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCnotStandardElementException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCnotStandardElementException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCnotStandardElementException Class
MCnotStandardElementException Members
MCnotStandardElementException Overload
Mergecom.Exceptions Namespace


MCnotStandardElementException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Constructor (String, Exception)
MCnotStandardElementException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnotStandardElementException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCnotStandardElementException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.NOT_A_STANDARD_DATA_ELEMENT.

See Also

MCnotStandardElementException Class
MCnotStandardElementException Members
MCnotStandardElementException Overload
Mergecom.Exceptions Namespace


MCnotStandardElementException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Fields
MCnotStandardElementException Class See Also Send Feedback

The MCnotStandardElementException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCnotStandardElementException Class
Mergecom.Exceptions Namespace


MCnotStandardElementException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Methods
MCnotStandardElementException Class See Also Send Feedback

The MCnotStandardElementException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCnotStandardElementException Class
Mergecom.Exceptions Namespace


MCnotStandardElementException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnotStandardElementException Properties
MCnotStandardElementException Class See Also Send Feedback

The MCnotStandardElementException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCnotStandardElementException Class
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Class

[image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Class
Members See Also Send Feedback
Exception thrown when an attempt was made to perform an operation that is not allowed in the current context.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCoperationNotAllowedException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCoperationNotAllowedException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCoperationNotAllowedException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCoperationNotAllowedException

See Also

MCoperationNotAllowedException Members
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Members
MCoperationNotAllowedException Class Constructors Methods Fields Properties See Also Send Feedback

The MCoperationNotAllowedException type exposes the following members.

Constructors

 | Name | Description
Public method | MCoperationNotAllowedException()()()() | Initializes a new instance of this class.
Public method | MCoperationNotAllowedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCoperationNotAllowedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCoperationNotAllowedException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCoperationNotAllowedException Class
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Constructor
MCoperationNotAllowedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCoperationNotAllowedException()()()() | Initializes a new instance of this class.
Public method | MCoperationNotAllowedException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCoperationNotAllowedException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCoperationNotAllowedException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCoperationNotAllowedException Class
MCoperationNotAllowedException Members
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Constructor
MCoperationNotAllowedException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCoperationNotAllowedException()
Visual Basic
Public Sub New
Visual C++
public:
MCoperationNotAllowedException()

Remarks

The exception number will be set to MCexception.OPERATION_NOT_ALLOWED.

See Also

MCoperationNotAllowedException Class
MCoperationNotAllowedException Members
MCoperationNotAllowedException Overload
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Constructor (String)
MCoperationNotAllowedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCoperationNotAllowedException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCoperationNotAllowedException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.OPERATION_NOT_ALLOWED.

See Also

MCoperationNotAllowedException Class
MCoperationNotAllowedException Members
MCoperationNotAllowedException Overload
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Constructor (SerializationInfo, StreamingContext)
MCoperationNotAllowedException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCoperationNotAllowedException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCoperationNotAllowedException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCoperationNotAllowedException Class
MCoperationNotAllowedException Members
MCoperationNotAllowedException Overload
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Constructor (String, Exception)
MCoperationNotAllowedException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCoperationNotAllowedException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCoperationNotAllowedException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.OPERATION_NOT_ALLOWED.

See Also

MCoperationNotAllowedException Class
MCoperationNotAllowedException Members
MCoperationNotAllowedException Overload
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Fields
MCoperationNotAllowedException Class See Also Send Feedback

The MCoperationNotAllowedException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCoperationNotAllowedException Class
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Methods
MCoperationNotAllowedException Class See Also Send Feedback

The MCoperationNotAllowedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCoperationNotAllowedException Class
Mergecom.Exceptions Namespace


MCoperationNotAllowedException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoperationNotAllowedException Properties
MCoperationNotAllowedException Class See Also Send Feedback

The MCoperationNotAllowedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCoperationNotAllowedException Class
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Class

[image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Class
Members See Also Send Feedback
Exception thrown when a required attribute is missing from a DIMSE message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCrequiredAttributeMissingException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCrequiredAttributeMissingException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCrequiredAttributeMissingException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCrequiredAttributeMissingException

See Also

MCrequiredAttributeMissingException Members
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Members
MCrequiredAttributeMissingException Class Constructors Methods Fields Properties See Also Send Feedback

The MCrequiredAttributeMissingException type exposes the following members.

Constructors

 | Name | Description
Public method | MCrequiredAttributeMissingException()()()() | Initializes a new instance of this class.
Public method | MCrequiredAttributeMissingException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCrequiredAttributeMissingException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCrequiredAttributeMissingException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCrequiredAttributeMissingException Class
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Constructor
MCrequiredAttributeMissingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCrequiredAttributeMissingException()()()() | Initializes a new instance of this class.
Public method | MCrequiredAttributeMissingException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCrequiredAttributeMissingException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCrequiredAttributeMissingException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCrequiredAttributeMissingException Class
MCrequiredAttributeMissingException Members
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Constructor
MCrequiredAttributeMissingException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrequiredAttributeMissingException()
Visual Basic
Public Sub New
Visual C++
public:
MCrequiredAttributeMissingException()

Remarks

The exception number will be set to MCexception.REQUIRED_ATTRIBUTE_MISSING.

See Also

MCrequiredAttributeMissingException Class
MCrequiredAttributeMissingException Members
MCrequiredAttributeMissingException Overload
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Constructor (String)
MCrequiredAttributeMissingException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrequiredAttributeMissingException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCrequiredAttributeMissingException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.REQUIRED_ATTRIBUTE_MISSING.

See Also

MCrequiredAttributeMissingException Class
MCrequiredAttributeMissingException Members
MCrequiredAttributeMissingException Overload
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Constructor (SerializationInfo, StreamingContext)
MCrequiredAttributeMissingException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCrequiredAttributeMissingException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCrequiredAttributeMissingException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCrequiredAttributeMissingException Class
MCrequiredAttributeMissingException Members
MCrequiredAttributeMissingException Overload
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Constructor (String, Exception)
MCrequiredAttributeMissingException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrequiredAttributeMissingException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCrequiredAttributeMissingException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.REQUIRED_ATTRIBUTE_MISSING.

See Also

MCrequiredAttributeMissingException Class
MCrequiredAttributeMissingException Members
MCrequiredAttributeMissingException Overload
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Fields
MCrequiredAttributeMissingException Class See Also Send Feedback

The MCrequiredAttributeMissingException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCrequiredAttributeMissingException Class
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Methods
MCrequiredAttributeMissingException Class See Also Send Feedback

The MCrequiredAttributeMissingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCrequiredAttributeMissingException Class
Mergecom.Exceptions Namespace


MCrequiredAttributeMissingException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCrequiredAttributeMissingException Properties
MCrequiredAttributeMissingException Class See Also Send Feedback

The MCrequiredAttributeMissingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCrequiredAttributeMissingException Class
Mergecom.Exceptions Namespace


MCruntimeException Class

[image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Class
Members See Also Send Feedback
Represents a general error condition that is not specific to the operation that caused it.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCruntimeException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCruntimeException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCruntimeException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCruntimeException
Mergecom.Exceptions..::..MCconfigurationError
Mergecom.Exceptions..::..MCinvalidLicenseInfoError
Mergecom.Exceptions..::..MCnotInitializedError

See Also

MCruntimeException Members
Mergecom.Exceptions Namespace


MCruntimeException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Members
MCruntimeException Class Constructors Methods Fields Properties See Also Send Feedback

The MCruntimeException type exposes the following members.

Constructors

 | Name | Description
Public method | MCruntimeException(String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.
Protected method | MCruntimeException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCruntimeException(Int32, String, Exception) | Initializes a new instance of exception with ERROR severity.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCruntimeException Class
Mergecom.Exceptions Namespace


MCruntimeException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Constructor
MCruntimeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCruntimeException(String) | Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.
Protected method | MCruntimeException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCruntimeException(Int32, String, Exception) | Initializes a new instance of exception with ERROR severity.

See Also

MCruntimeException Class
MCruntimeException Members
Mergecom.Exceptions Namespace


MCruntimeException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Constructor (String)
MCruntimeException Class See Also Send Feedback
Initializes an exception instance by using UNKNOWN_ERROR as the exception number, ERROR severity and the specified message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCruntimeException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCruntimeException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The exception message.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCruntimeException Class
MCruntimeException Members
MCruntimeException Overload
Mergecom.Exceptions Namespace


MCruntimeException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Constructor (SerializationInfo, StreamingContext)
MCruntimeException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCruntimeException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCruntimeException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCruntimeException Class
MCruntimeException Members
MCruntimeException Overload
Mergecom.Exceptions Namespace


MCruntimeException Constructor (Int32, String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Constructor (Int32, String, Exception)
MCruntimeException Class See Also Send Feedback
Initializes a new instance of exception with ERROR severity.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCruntimeException(
    int exceptionNumber,
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    exceptionNumber As Integer, _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCruntimeException(
    int exceptionNumber,
    String^ msg,
    Exception^ innerException
)

Parameters

exceptionNumber
Type: System..::..Int32
The exception number.
msg
Type: System..::..String
The exception message.
innerException
Type: System..::..Exception
The inner exception causing this exception.

Remarks

This constructor sends a log message about the exception being created to the log system.

See Also

MCruntimeException Class
MCruntimeException Members
MCruntimeException Overload
Mergecom.Exceptions Namespace


MCruntimeException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Fields
MCruntimeException Class See Also Send Feedback

The MCruntimeException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCruntimeException Class
Mergecom.Exceptions Namespace


MCruntimeException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Methods
MCruntimeException Class See Also Send Feedback

The MCruntimeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCruntimeException Class
Mergecom.Exceptions Namespace


MCruntimeException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCruntimeException Properties
MCruntimeException Class See Also Send Feedback

The MCruntimeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCruntimeException Class
Mergecom.Exceptions Namespace


MCseverity Class

[image]

Merge DICOM .NET/C# Toolkit
MCseverity Class
Members See Also Send Feedback
Represents the severity of a MergeCOM exception.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCseverity
Visual Basic
Public Class MCseverity
Visual C++
public ref class MCseverity

Remarks

This class contains a severity code and its string representation. For example ERROR has a string code "E".

Inheritance Hierarchy

System..::..Object
Mergecom.Exceptions..::..MCseverity

See Also

MCseverity Members
Mergecom.Exceptions Namespace


MCseverity Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCseverity Members
MCseverity Class Constructors Methods Fields See Also Send Feedback

The MCseverity type exposes the following members.

Constructors

 | Name | Description
Public method | MCseverity | Initializes a new instance of this class.

Methods

 | Name | Description
Public method | Equals | Determines whether this object is equivalent to the specified object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | code | The severity Code.
 | ERROR | Constant used to represent Error level exceptions.
 | INFORMATION | Constant used to represent Informational level exceptions.
Public field | stringCode | The severity String.
 | VERIFICATION | Constant used to represent Verification level exceptions.
 | WARNING | Constant used to represent Warning level exceptions.

See Also

MCseverity Class
Mergecom.Exceptions Namespace


MCseverity Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCseverity Constructor
MCseverity Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCseverity(
    short code,
    string stringCode
)
Visual Basic
Public Sub New ( _
    code As Short, _
    stringCode As String _
)
Visual C++
public:
MCseverity(
    short code,
    String^ stringCode
)

Parameters

code
Type: System..::..Int16
Code indicating the severity as defined by the constants in this class.
stringCode
Type: System..::..String
String showing severity or null if the default string for the code should be used.

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


MCseverity Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCseverity Fields
MCseverity Class See Also Send Feedback

The MCseverity type exposes the following members.

Fields

 | Name | Description
Public field | code | The severity Code.
 | ERROR | Constant used to represent Error level exceptions.
 | INFORMATION | Constant used to represent Informational level exceptions.
Public field | stringCode | The severity String.
 | VERIFICATION | Constant used to represent Verification level exceptions.
 | WARNING | Constant used to represent Warning level exceptions.

See Also

MCseverity Class
Mergecom.Exceptions Namespace


code Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..code Field
MCseverity Class See Also Send Feedback
The severity Code.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly short code
Visual Basic
Public ReadOnly code As Short
Visual C++
public:
initonly short code

Remarks

One of the codes declared by these constants: ERROR, WARNING, INFORMATION, VERIFICATION.

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


ERROR Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..ERROR Field
MCseverity Class See Also Send Feedback
Constant used to represent Error level exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short ERROR
Visual Basic
Public Const ERROR As Short
Visual C++
public:
literal short ERROR

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


INFORMATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..INFORMATION Field
MCseverity Class See Also Send Feedback
Constant used to represent Informational level exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short INFORMATION
Visual Basic
Public Const INFORMATION As Short
Visual C++
public:
literal short INFORMATION

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


stringCode Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..stringCode Field
MCseverity Class See Also Send Feedback
The severity String.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public readonly string stringCode
Visual Basic
Public ReadOnly stringCode As String
Visual C++
public:
initonly String^ stringCode

Remarks

One of these strings: "E" (Error), "W" (Warning), "I" (Information), "V" (Verification message).

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


VERIFICATION Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..VERIFICATION Field
MCseverity Class See Also Send Feedback
Constant used to represent Verification level exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short VERIFICATION
Visual Basic
Public Const VERIFICATION As Short
Visual C++
public:
literal short VERIFICATION

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


WARNING Field

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..WARNING Field
MCseverity Class See Also Send Feedback
Constant used to represent Warning level exceptions.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const short WARNING
Visual Basic
Public Const WARNING As Short
Visual C++
public:
literal short WARNING

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


MCseverity Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCseverity Methods
MCseverity Class See Also Send Feedback

The MCseverity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this object is equivalent to the specified object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCseverity Class
Mergecom.Exceptions Namespace


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..Equals Method
MCseverity Class See Also Send Feedback
Determines whether this object is equivalent to the specified object.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare to.

Return Value

true if the object is an instance of MCseverity and its code is the same as the curent object's code.

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCseverity..::..GetHashCode Method
MCseverity Class See Also Send Feedback
Gets the hash code for this instance.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

MCseverity Class
MCseverity Members
Mergecom.Exceptions Namespace


MCtimeoutException Class

[image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Class
Members See Also Send Feedback
Exception thrown when a timeout has occurred.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCtimeoutException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCtimeoutException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCtimeoutException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCtimeoutException

See Also

MCtimeoutException Members
Mergecom.Exceptions Namespace


MCtimeoutException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Members
MCtimeoutException Class Constructors Methods Fields Properties See Also Send Feedback

The MCtimeoutException type exposes the following members.

Constructors

 | Name | Description
Public method | MCtimeoutException()()()() | Initializes a new instance of this class.
Public method | MCtimeoutException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCtimeoutException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCtimeoutException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCtimeoutException Class
Mergecom.Exceptions Namespace


MCtimeoutException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Constructor
MCtimeoutException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtimeoutException()()()() | Initializes a new instance of this class.
Public method | MCtimeoutException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCtimeoutException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCtimeoutException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCtimeoutException Class
MCtimeoutException Members
Mergecom.Exceptions Namespace


MCtimeoutException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Constructor
MCtimeoutException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtimeoutException()
Visual Basic
Public Sub New
Visual C++
public:
MCtimeoutException()

Remarks

The exception number will be set to MCexception.TIMEOUT.

See Also

MCtimeoutException Class
MCtimeoutException Members
MCtimeoutException Overload
Mergecom.Exceptions Namespace


MCtimeoutException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Constructor (String)
MCtimeoutException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtimeoutException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCtimeoutException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.TIMEOUT.

See Also

MCtimeoutException Class
MCtimeoutException Members
MCtimeoutException Overload
Mergecom.Exceptions Namespace


MCtimeoutException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Constructor (SerializationInfo, StreamingContext)
MCtimeoutException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCtimeoutException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCtimeoutException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCtimeoutException Class
MCtimeoutException Members
MCtimeoutException Overload
Mergecom.Exceptions Namespace


MCtimeoutException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Constructor (String, Exception)
MCtimeoutException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtimeoutException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCtimeoutException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.TIMEOUT.

See Also

MCtimeoutException Class
MCtimeoutException Members
MCtimeoutException Overload
Mergecom.Exceptions Namespace


MCtimeoutException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Fields
MCtimeoutException Class See Also Send Feedback

The MCtimeoutException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCtimeoutException Class
Mergecom.Exceptions Namespace


MCtimeoutException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Methods
MCtimeoutException Class See Also Send Feedback

The MCtimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCtimeoutException Class
Mergecom.Exceptions Namespace


MCtimeoutException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeoutException Properties
MCtimeoutException Class See Also Send Feedback

The MCtimeoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCtimeoutException Class
Mergecom.Exceptions Namespace


MCunacceptableServiceException Class

[image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Class
Members See Also Send Feedback
Exception thrown when an attempt was made to send a DIMSE message for a service that was not successfully negotiated.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCunacceptableServiceException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCunacceptableServiceException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCunacceptableServiceException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCunacceptableServiceException

See Also

MCunacceptableServiceException Members
Mergecom.Exceptions Namespace


MCunacceptableServiceException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Members
MCunacceptableServiceException Class Constructors Methods Fields Properties See Also Send Feedback

The MCunacceptableServiceException type exposes the following members.

Constructors

 | Name | Description
Public method | MCunacceptableServiceException()()()() | Initializes a new instance of this class.
Public method | MCunacceptableServiceException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCunacceptableServiceException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCunacceptableServiceException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCunacceptableServiceException Class
Mergecom.Exceptions Namespace


MCunacceptableServiceException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Constructor
MCunacceptableServiceException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCunacceptableServiceException()()()() | Initializes a new instance of this class.
Public method | MCunacceptableServiceException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCunacceptableServiceException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCunacceptableServiceException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCunacceptableServiceException Class
MCunacceptableServiceException Members
Mergecom.Exceptions Namespace


MCunacceptableServiceException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Constructor
MCunacceptableServiceException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunacceptableServiceException()
Visual Basic
Public Sub New
Visual C++
public:
MCunacceptableServiceException()

Remarks

The exception number will be set to MCexception.UNNACCEPTABLE_SERVICE.

See Also

MCunacceptableServiceException Class
MCunacceptableServiceException Members
MCunacceptableServiceException Overload
Mergecom.Exceptions Namespace


MCunacceptableServiceException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Constructor (String)
MCunacceptableServiceException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunacceptableServiceException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCunacceptableServiceException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.UNNACCEPTABLE_SERVICE.

See Also

MCunacceptableServiceException Class
MCunacceptableServiceException Members
MCunacceptableServiceException Overload
Mergecom.Exceptions Namespace


MCunacceptableServiceException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Constructor (SerializationInfo, StreamingContext)
MCunacceptableServiceException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCunacceptableServiceException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCunacceptableServiceException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCunacceptableServiceException Class
MCunacceptableServiceException Members
MCunacceptableServiceException Overload
Mergecom.Exceptions Namespace


MCunacceptableServiceException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Constructor (String, Exception)
MCunacceptableServiceException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunacceptableServiceException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCunacceptableServiceException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.UNNACCEPTABLE_SERVICE.

See Also

MCunacceptableServiceException Class
MCunacceptableServiceException Members
MCunacceptableServiceException Overload
Mergecom.Exceptions Namespace


MCunacceptableServiceException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Fields
MCunacceptableServiceException Class See Also Send Feedback

The MCunacceptableServiceException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCunacceptableServiceException Class
Mergecom.Exceptions Namespace


MCunacceptableServiceException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Methods
MCunacceptableServiceException Class See Also Send Feedback

The MCunacceptableServiceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCunacceptableServiceException Class
Mergecom.Exceptions Namespace


MCunacceptableServiceException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunacceptableServiceException Properties
MCunacceptableServiceException Class See Also Send Feedback

The MCunacceptableServiceException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCunacceptableServiceException Class
Mergecom.Exceptions Namespace


MCunknownHostNameException Class

[image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Class
Members See Also Send Feedback
Exception thrown when an attempt to connect to an unknown host.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
[SerializableAttribute]
public class MCunknownHostNameException : MCexception
Visual Basic
<SerializableAttribute> _
Public Class MCunknownHostNameException _
    Inherits MCexception
Visual C++
[SerializableAttribute]
public ref class MCunknownHostNameException : public MCexception

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Mergecom.Exceptions..::..MCexception
Mergecom.Exceptions..::..MCunknownHostNameException

See Also

MCunknownHostNameException Members
Mergecom.Exceptions Namespace


MCunknownHostNameException Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Members
MCunknownHostNameException Class Constructors Methods Fields Properties See Also Send Feedback

The MCunknownHostNameException type exposes the following members.

Constructors

 | Name | Description
Public method | MCunknownHostNameException()()()() | Initializes a new instance of this class.
Public method | MCunknownHostNameException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCunknownHostNameException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCunknownHostNameException(String, Exception) | Initializes a new instance of this class for a given error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCunknownHostNameException Class
Mergecom.Exceptions Namespace


MCunknownHostNameException Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Constructor
MCunknownHostNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCunknownHostNameException()()()() | Initializes a new instance of this class.
Public method | MCunknownHostNameException(String) | Initializes a new instance of this class for a given error message.
Protected method | MCunknownHostNameException(SerializationInfo, StreamingContext) | Constructor used when exceptions of this type are de-serialized.
Public method | MCunknownHostNameException(String, Exception) | Initializes a new instance of this class for a given error message.

See Also

MCunknownHostNameException Class
MCunknownHostNameException Members
Mergecom.Exceptions Namespace


MCunknownHostNameException Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Constructor
MCunknownHostNameException Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunknownHostNameException()
Visual Basic
Public Sub New
Visual C++
public:
MCunknownHostNameException()

Remarks

The exception number will be set to MCexception.UNKNOWN_HOST.

See Also

MCunknownHostNameException Class
MCunknownHostNameException Members
MCunknownHostNameException Overload
Mergecom.Exceptions Namespace


MCunknownHostNameException Constructor (String)

[image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Constructor (String)
MCunknownHostNameException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunknownHostNameException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
MCunknownHostNameException(
    String^ msg
)

Parameters

msg
Type: System..::..String
The string describing the exception.

Remarks

The exception number will be set to MCexception.UNKNOWN_HOST.

See Also

MCunknownHostNameException Class
MCunknownHostNameException Members
MCunknownHostNameException Overload
Mergecom.Exceptions Namespace


MCunknownHostNameException Constructor (SerializationInfo, StreamingContext)

[image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Constructor (SerializationInfo, StreamingContext)
MCunknownHostNameException Class See Also Send Feedback
Constructor used when exceptions of this type are de-serialized.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected MCunknownHostNameException(
    SerializationInfo information,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    information As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MCunknownHostNameException(
    SerializationInfo^ information,
    StreamingContext context
)

Parameters

information
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
The serialization context.

See Also

MCunknownHostNameException Class
MCunknownHostNameException Members
MCunknownHostNameException Overload
Mergecom.Exceptions Namespace


MCunknownHostNameException Constructor (String, Exception)

[image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Constructor (String, Exception)
MCunknownHostNameException Class See Also Send Feedback
Initializes a new instance of this class for a given error message.

Namespace: Mergecom.Exceptions
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCunknownHostNameException(
    string msg,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
Visual C++
public:
MCunknownHostNameException(
    String^ msg,
    Exception^ innerException
)

Parameters

msg
Type: System..::..String
The string describing the exception.
innerException
Type: System..::..Exception
The exception that caused this exception.

Remarks

The exception number will be set to MCexception.UNKNOWN_HOST.

See Also

MCunknownHostNameException Class
MCunknownHostNameException Members
MCunknownHostNameException Overload
Mergecom.Exceptions Namespace


MCunknownHostNameException Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Fields
MCunknownHostNameException Class See Also Send Feedback

The MCunknownHostNameException type exposes the following members.

Fields

 | Name | Description
Public field | exceptionNumber | The number assigned by the Merge DICOM toolkit to this exception. (Inherited from MCexception.)

See Also

MCunknownHostNameException Class
Mergecom.Exceptions Namespace


MCunknownHostNameException Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Methods
MCunknownHostNameException Class See Also Send Feedback

The MCunknownHostNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize this exception. (Inherited from MCexception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MCunknownHostNameException Class
Mergecom.Exceptions Namespace


MCunknownHostNameException Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCunknownHostNameException Properties
MCunknownHostNameException Class See Also Send Feedback

The MCunknownHostNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string description this exception. (Inherited from MCexception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MCunknownHostNameException Class
Mergecom.Exceptions Namespace


Mergecom.Gen Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom.Gen Namespace
Send Feedback
This namespace contains classes generated from the Dicom dataabase that deal with specific messages.

Classes

 | Class | Description
Public class | MCactualHumanPerformersItem | This class serves as a container for attributes of the ACTUAL_HUMAN_PERFORMERS Item.
Public class | MCanatomicStructureSpaceOrRegionItem | This class serves as a container for attributes of the ANATOMIC_STRUCT_SPACE_OR_REGION Item.
Public class | MCbillingItemItem | This class serves as a container for attributes of the BILLING_ITEM Item.
Public class | MCbillingProcedureStepItem | This class serves as a container for attributes of the BILLING_PROCEDURE_STEP Item.
Public class | MCbillingSuppliesAndDevicesItem | This class serves as a container for attributes of the BILLING_SUPPLIES_AND_DEVICES Item.
Public class | MCbreedRegistrationItem | This class serves as a container for attributes of the BREED_REGISTRATION Item.
Public class | MCcodeItem | This class serves as a container for attributes of the CODE_SEQUENCE_MACRO Item.
Public class | MCcodingSchemeIdentificationItem | This class serves as a container for attributes of the CODING_SCHEME_IDENTIFICATION Item.
Public class | MCconsentForClinicalTrialUseItem | This class serves as a container for attributes of the CONSENT_FOR_CLINICAL_TRIAL_USE Item.
Public class | MCcontributingEquipmentItem | This class serves as a container for attributes of the CONTRIBUTING_EQUIPMENT Item.
Public class | MCdetachedStudyManagementEventReport | This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.
Public class | MCdetachedStudyManagementGet | This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.
Public class | MCdetachedStudyManagementSet | This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.
Public class | MCdigitalSignaturesItem | This class serves as a container for attributes of the DIGITAL_SIGNATURES Item.
Public class | MCexposureDoseItem | This class serves as a container for attributes of the EXPOSURE_DOSE Item.
Public class | MCfilmConsumptionItem | This class serves as a container for attributes of the FILM_CONSUMPTION Item.
Public class | MCgpPerformedProcedureStepCreate | This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.
Public class | MCgpPerformedProcedureStepGet | This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.
Public class | MCgpPerformedProcedureStepSet | This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.
Public class | MCgpScheduledProcedureStep | This class serves as a container for attributes of the G_P_SCHEDULED_PROCEDURE_STEP IOD.
Public class | MChierarchicalSOPInstRefItem | This class serves as a container for attributes of the HIERARCHICAL_SOP_INST_REF_MACRO Item.
Public class | MChL7HierarchicDesignatorItem | This class serves as a container for attributes of the HL7_HIERARCHIC_DESIGNATOR_MACRO Item.
Public class | MChL7StructuredDocumentReferenceItem | This class serves as a container for attributes of the HL7_STRUCT_DOC_REF Item.
Public class | MCimageSopInstanceReferenceItem | This class serves as a container for attributes of the IMAGE_SOP_INSTANCE_REF_MACRO Item.
Public class | MCmACParametersItem | This class serves as a container for attributes of the MAC_PARAMETERS Item.
Public class | MCmeasuringUnitsItem | This class serves as a container for attributes of the MEASURING_UNITS Item.
Public class | MCmodalityWorklistFind | This class serves as a container for attributes of the MODALITY_WORKLIST_FIND IOD.
Public class | MCoutputInformationItem | This class serves as a container for attributes of the OUTPUT_INFORMATION Item.
Public class | MCpatientClinicalTrialParticipationItem | This class serves as a container for attributes of the PATIENT_CLINICAL_TRIAL Item.
Public class | MCperformedProcedureStepCreate | This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP IOD.
Public class | MCperformedProcedureStepGet | This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP_RETRIEVE IOD.
Public class | MCperformedProcedureStepSet | This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP IOD.
Public class | MCperformedProcessingParametersItem | This class serves as a container for attributes of the CONTENT_ITEM_MACRO Item.
Public class | MCperformedSeriesItem | This class serves as a container for attributes of the PERFORMED_SERIES Item.
Public class | MCpersonIdentificationMacro | This class serves as a container for attributes of the PERSON_IDENTIFICATION_MACRO Item.
Public class | MCpertinentDocumentsItem | This class serves as a container for attributes of the PERTINENT_DOCUMENTS Item.
Public class | MCprotocolContextItem | This class serves as a container for attributes of the PROTOCOL_CONTEXT Item.
Public class | MCquantityItem | This class serves as a container for attributes of the QUANTITY Item.
Public class | MCreferencedDigitalSignatureItem | This class serves as a container for attributes of the REF_DIGITAL_SIGNATURE Item.
Public class | MCreferencedGeneralPurposeScheduledProcedureSteItem | This class serves as a container for attributes of the REF_G_P_SCHEDULED_PROCEDURE_STEP Item.
Public class | MCreferencedImageItem | This class serves as a container for attributes of the REF_IMAGE_IN_REF_SERIES Item.
Public class | MCreferencedPatientAliasItem | This class serves as a container for attributes of the REF_PATIENT_ALIAS Item.
Public class | MCreferencedPatientItem | This class serves as a container for attributes of the REF_PATIENT Item.
Public class | MCreferencedPerformedProcedureStepItem | This class serves as a container for attributes of the REF_STUDY_COMPONENT Item.
Public class | MCreferencedRequestItem | This class serves as a container for attributes of the REFERENCED_REQUEST Item.
Public class | MCreferencedResultsItem | This class serves as a container for attributes of the REF_RESULTS Item.
Public class | MCreferencedRTPlanItem | This class serves as a container for attributes of the REF_RT_PLAN Item.
Public class | MCreferencedSeriesItem | This class serves as a container for attributes of the REF_SERIES Item.
Public class | MCreferencedSOPInstanceMACItem | This class serves as a container for attributes of the REF_SOP_INSTANCE_MAC Item.
Public class | MCreferencedSOPItem | This class serves as a container for attributes of the REFERENCED_SOP Item.
Public class | MCreferencedStandaloneSOPInstanceItem | This class serves as a container for attributes of the REF_STANDALONE_SOP_INSTANCE Item.
Public class | MCreferencedStudyItem | This class serves as a container for attributes of the REF_STUDY Item.
Public class | MCreferencedVisitItem | This class serves as a container for attributes of the REF_VISIT Item.
Public class | MCresultingGeneralPurposePerformedProcedureStepItem | This class serves as a container for attributes of the RESULTING_G_P_PERFORMED_PROCEDUR Item.
Public class | MCscheduledHumanPerformersItem | This class serves as a container for attributes of the SCHED_HUMAN_PERFORMERS Item.
Public class | MCscheduledProcedureStepItem | This class serves as a container for attributes of the SCHEDULED_PROCEDURE_STEP Item.
Public class | MCscheduledProtocolCodeItem | This class serves as a container for attributes of the SCHEDULED_ACTION_ITEM_CODE Item.
Public class | MCscheduledStepAttributesItem | This class serves as a container for attributes of the SCHEDULED_STEP_ATTRIBUTE Item.
Public class | MCsopInstanceReferenceItem | This class serves as a container for attributes of the SOP_INSTANCE_REF_MACRO Item.
Public class | MCstudyComponentManagementCreate | This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.
Public class | MCstudyComponentManagementGet | This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.
Public class | MCstudyComponentManagementSet | This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.


MCactualHumanPerformersItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the ACTUAL_HUMAN_PERFORMERS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCactualHumanPerformersItem
Visual Basic
Public Class MCactualHumanPerformersItem
Visual C++
public ref class MCactualHumanPerformersItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00404009) Human Performer Code Sequence
  • (00404036) Human Performer's Organization
  • (00404037) Human Performer's Name

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCactualHumanPerformersItem

See Also

MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


MCactualHumanPerformersItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Members
MCactualHumanPerformersItem Class Constructors Methods Properties See Also Send Feedback

The MCactualHumanPerformersItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCactualHumanPerformersItem()()()() | Constructs an MCactualHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCactualHumanPerformersItem(MCitem) | Constructs an MCactualHumanPerformersItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHumanPerformerCodes | This method removes all the values that may have been set for Human Performer Code Sequence.
Public method | removeHumanPerformersName | This method removes all the values that may have been set for Human Performer's Name.
Public method | removeHumanPerformersOrganization | This method removes all the values that may have been set for Human Performer's Organization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | HumanPerformerCodes | Represents the values for the Human Performer Code Sequence attribute.
Public property | HumanPerformersName | Represents the value for the Human Performer's Name attribute.
Public property | HumanPerformersOrganization | Represents the value for the Human Performer's Organization attribute.

See Also

MCactualHumanPerformersItem Class
Mergecom.Gen Namespace


MCactualHumanPerformersItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Constructor
MCactualHumanPerformersItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCactualHumanPerformersItem()()()() | Constructs an MCactualHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCactualHumanPerformersItem(MCitem) | Constructs an MCactualHumanPerformersItem collection by wrapping an existing MCitem instance.

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


MCactualHumanPerformersItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Constructor
MCactualHumanPerformersItem Class See Also Send Feedback
Constructs an MCactualHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCactualHumanPerformersItem()
Visual Basic
Public Sub New
Visual C++
public:
MCactualHumanPerformersItem()

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
MCactualHumanPerformersItem Overload
Mergecom.Gen Namespace


MCactualHumanPerformersItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Constructor (MCitem)
MCactualHumanPerformersItem Class See Also Send Feedback
Constructs an MCactualHumanPerformersItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCactualHumanPerformersItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCactualHumanPerformersItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
MCactualHumanPerformersItem Overload
Mergecom.Gen Namespace


MCactualHumanPerformersItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Methods
MCactualHumanPerformersItem Class See Also Send Feedback

The MCactualHumanPerformersItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHumanPerformerCodes | This method removes all the values that may have been set for Human Performer Code Sequence.
Public method | removeHumanPerformersName | This method removes all the values that may have been set for Human Performer's Name.
Public method | removeHumanPerformersOrganization | This method removes all the values that may have been set for Human Performer's Organization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCactualHumanPerformersItem Class
Mergecom.Gen Namespace


removeHumanPerformerCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..removeHumanPerformerCodes Method
MCactualHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformerCodes()
Visual Basic
Public Overridable Sub removeHumanPerformerCodes
Visual C++
public:
virtual void removeHumanPerformerCodes()

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


removeHumanPerformersName Method

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..removeHumanPerformersName Method
MCactualHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformersName()
Visual Basic
Public Overridable Sub removeHumanPerformersName
Visual C++
public:
virtual void removeHumanPerformersName()

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


removeHumanPerformersOrganization Method

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..removeHumanPerformersOrganization Method
MCactualHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer's Organization.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformersOrganization()
Visual Basic
Public Overridable Sub removeHumanPerformersOrganization
Visual C++
public:
virtual void removeHumanPerformersOrganization()

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


MCactualHumanPerformersItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem Properties
MCactualHumanPerformersItem Class See Also Send Feedback

The MCactualHumanPerformersItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | HumanPerformerCodes | Represents the values for the Human Performer Code Sequence attribute.
Public property | HumanPerformersName | Represents the value for the Human Performer's Name attribute.
Public property | HumanPerformersOrganization | Represents the value for the Human Performer's Organization attribute.

See Also

MCactualHumanPerformersItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..Host Property
MCactualHumanPerformersItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformerCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..HumanPerformerCodes Property
MCactualHumanPerformersItem Class See Also Send Feedback
Represents the values for the Human Performer Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] HumanPerformerCodes { get; set; }
Visual Basic
Public Overridable Property HumanPerformerCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ HumanPerformerCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformersName Property

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..HumanPerformersName Property
MCactualHumanPerformersItem Class See Also Send Feedback
Represents the value for the Human Performer's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName HumanPerformersName { get; set; }
Visual Basic
Public Overridable Property HumanPerformersName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ HumanPerformersName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformersOrganization Property

[image]

Merge DICOM .NET/C# Toolkit
MCactualHumanPerformersItem..::..HumanPerformersOrganization Property
MCactualHumanPerformersItem Class See Also Send Feedback
Represents the value for the Human Performer's Organization attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string HumanPerformersOrganization { get; set; }
Visual Basic
Public Overridable Property HumanPerformersOrganization As String
    Get
    Set
Visual C++
public:
virtual property String^ HumanPerformersOrganization {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCactualHumanPerformersItem Class
MCactualHumanPerformersItem Members
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the ANATOMIC_STRUCT_SPACE_OR_REGION Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCanatomicStructureSpaceOrRegionItem
Visual Basic
Public Class MCanatomicStructureSpaceOrRegionItem
Visual C++
public ref class MCanatomicStructureSpaceOrRegionItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00080117) Context UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCanatomicStructureSpaceOrRegionItem

See Also

MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Members
MCanatomicStructureSpaceOrRegionItem Class Constructors Methods Properties See Also Send Feedback

The MCanatomicStructureSpaceOrRegionItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCanatomicStructureSpaceOrRegionItem()()()() | Constructs an MCanatomicStructureSpaceOrRegionItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCanatomicStructureSpaceOrRegionItem(MCitem) | Constructs an MCanatomicStructureSpaceOrRegionItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCanatomicStructureSpaceOrRegionItem Class
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Constructor
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCanatomicStructureSpaceOrRegionItem()()()() | Constructs an MCanatomicStructureSpaceOrRegionItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCanatomicStructureSpaceOrRegionItem(MCitem) | Constructs an MCanatomicStructureSpaceOrRegionItem collection by wrapping an existing MCitem instance.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Constructor
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Constructs an MCanatomicStructureSpaceOrRegionItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCanatomicStructureSpaceOrRegionItem()
Visual Basic
Public Sub New
Visual C++
public:
MCanatomicStructureSpaceOrRegionItem()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
MCanatomicStructureSpaceOrRegionItem Overload
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Constructor (MCitem)
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Constructs an MCanatomicStructureSpaceOrRegionItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCanatomicStructureSpaceOrRegionItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCanatomicStructureSpaceOrRegionItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
MCanatomicStructureSpaceOrRegionItem Overload
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Methods
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback

The MCanatomicStructureSpaceOrRegionItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCanatomicStructureSpaceOrRegionItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeCodeMeaning Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeCodeValue Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeCodingSchemeDesignator Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeCodingSchemeVersion Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextGroupExtensionCreatorUID Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextGroupExtensionFlag Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextGroupLocalVersion Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextGroupVersion Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextIdentifier Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeContextUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeContextUID Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Context UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextUID()
Visual Basic
Public Overridable Sub removeContextUID
Visual C++
public:
virtual void removeContextUID()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..removeMappingResource Method
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


MCanatomicStructureSpaceOrRegionItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem Properties
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback

The MCanatomicStructureSpaceOrRegionItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCanatomicStructureSpaceOrRegionItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..CodeMeaning Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..CodeValue Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..CodingSchemeDesignator Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..CodingSchemeVersion Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextGroupExtensionCreatorUID Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextGroupExtensionFlag Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextGroupLocalVersion Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextGroupVersion Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextIdentifier Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


ContextUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..ContextUID Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Context UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextUID { get; set; }
Visual Basic
Public Overridable Property ContextUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..Host Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCanatomicStructureSpaceOrRegionItem..::..MappingResource Property
MCanatomicStructureSpaceOrRegionItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCanatomicStructureSpaceOrRegionItem Class
MCanatomicStructureSpaceOrRegionItem Members
Mergecom.Gen Namespace


MCbillingItemItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the BILLING_ITEM Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbillingItemItem
Visual Basic
Public Class MCbillingItemItem
Visual C++
public ref class MCbillingItemItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00080117) Context UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCbillingItemItem

See Also

MCbillingItemItem Members
Mergecom.Gen Namespace


MCbillingItemItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Members
MCbillingItemItem Class Constructors Methods Properties See Also Send Feedback

The MCbillingItemItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCbillingItemItem()()()() | Constructs an MCbillingItemItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingItemItem(MCitem) | Constructs an MCbillingItemItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCbillingItemItem Class
Mergecom.Gen Namespace


MCbillingItemItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Constructor
MCbillingItemItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCbillingItemItem()()()() | Constructs an MCbillingItemItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingItemItem(MCitem) | Constructs an MCbillingItemItem collection by wrapping an existing MCitem instance.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


MCbillingItemItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Constructor
MCbillingItemItem Class See Also Send Feedback
Constructs an MCbillingItemItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingItemItem()
Visual Basic
Public Sub New
Visual C++
public:
MCbillingItemItem()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
MCbillingItemItem Overload
Mergecom.Gen Namespace


MCbillingItemItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Constructor (MCitem)
MCbillingItemItem Class See Also Send Feedback
Constructs an MCbillingItemItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingItemItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCbillingItemItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
MCbillingItemItem Overload
Mergecom.Gen Namespace


MCbillingItemItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Methods
MCbillingItemItem Class See Also Send Feedback

The MCbillingItemItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbillingItemItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeCodeMeaning Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeCodeValue Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeCodingSchemeDesignator Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeCodingSchemeVersion Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextGroupExtensionCreatorUID Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextGroupExtensionFlag Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextGroupLocalVersion Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextGroupVersion Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextIdentifier Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeContextUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeContextUID Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Context UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextUID()
Visual Basic
Public Overridable Sub removeContextUID
Visual C++
public:
virtual void removeContextUID()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..removeMappingResource Method
MCbillingItemItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


MCbillingItemItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem Properties
MCbillingItemItem Class See Also Send Feedback

The MCbillingItemItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCbillingItemItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..CodeMeaning Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..CodeValue Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..CodingSchemeDesignator Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..CodingSchemeVersion Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextGroupExtensionCreatorUID Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextGroupExtensionFlag Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextGroupLocalVersion Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextGroupVersion Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextIdentifier Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


ContextUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..ContextUID Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Context UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextUID { get; set; }
Visual Basic
Public Overridable Property ContextUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..Host Property
MCbillingItemItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingItemItem..::..MappingResource Property
MCbillingItemItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingItemItem Class
MCbillingItemItem Members
Mergecom.Gen Namespace


MCbillingProcedureStepItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the BILLING_PROCEDURE_STEP Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbillingProcedureStepItem
Visual Basic
Public Class MCbillingProcedureStepItem
Visual C++
public ref class MCbillingProcedureStepItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00080117) Context UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCbillingProcedureStepItem

See Also

MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


MCbillingProcedureStepItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Members
MCbillingProcedureStepItem Class Constructors Methods Properties See Also Send Feedback

The MCbillingProcedureStepItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCbillingProcedureStepItem()()()() | Constructs an MCbillingProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingProcedureStepItem(MCitem) | Constructs an MCbillingProcedureStepItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCbillingProcedureStepItem Class
Mergecom.Gen Namespace


MCbillingProcedureStepItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Constructor
MCbillingProcedureStepItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCbillingProcedureStepItem()()()() | Constructs an MCbillingProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingProcedureStepItem(MCitem) | Constructs an MCbillingProcedureStepItem collection by wrapping an existing MCitem instance.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


MCbillingProcedureStepItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Constructor
MCbillingProcedureStepItem Class See Also Send Feedback
Constructs an MCbillingProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingProcedureStepItem()
Visual Basic
Public Sub New
Visual C++
public:
MCbillingProcedureStepItem()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
MCbillingProcedureStepItem Overload
Mergecom.Gen Namespace


MCbillingProcedureStepItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Constructor (MCitem)
MCbillingProcedureStepItem Class See Also Send Feedback
Constructs an MCbillingProcedureStepItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingProcedureStepItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCbillingProcedureStepItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
MCbillingProcedureStepItem Overload
Mergecom.Gen Namespace


MCbillingProcedureStepItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Methods
MCbillingProcedureStepItem Class See Also Send Feedback

The MCbillingProcedureStepItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbillingProcedureStepItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeCodeMeaning Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeCodeValue Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeCodingSchemeDesignator Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeCodingSchemeVersion Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextGroupExtensionCreatorUID Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextGroupExtensionFlag Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextGroupLocalVersion Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextGroupVersion Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextIdentifier Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeContextUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeContextUID Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Context UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextUID()
Visual Basic
Public Overridable Sub removeContextUID
Visual C++
public:
virtual void removeContextUID()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..removeMappingResource Method
MCbillingProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


MCbillingProcedureStepItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem Properties
MCbillingProcedureStepItem Class See Also Send Feedback

The MCbillingProcedureStepItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCbillingProcedureStepItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..CodeMeaning Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..CodeValue Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..CodingSchemeDesignator Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..CodingSchemeVersion Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextGroupExtensionCreatorUID Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextGroupExtensionFlag Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextGroupLocalVersion Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextGroupVersion Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextIdentifier Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


ContextUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..ContextUID Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Context UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextUID { get; set; }
Visual Basic
Public Overridable Property ContextUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..Host Property
MCbillingProcedureStepItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingProcedureStepItem..::..MappingResource Property
MCbillingProcedureStepItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingProcedureStepItem Class
MCbillingProcedureStepItem Members
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the BILLING_SUPPLIES_AND_DEVICES Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbillingSuppliesAndDevicesItem
Visual Basic
Public Class MCbillingSuppliesAndDevicesItem
Visual C++
public ref class MCbillingSuppliesAndDevicesItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00400293) Quantity Sequence
  • (00400296) Billing Item Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCbillingSuppliesAndDevicesItem

See Also

MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Members
MCbillingSuppliesAndDevicesItem Class Constructors Methods Properties See Also Send Feedback

The MCbillingSuppliesAndDevicesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCbillingSuppliesAndDevicesItem()()()() | Constructs an MCbillingSuppliesAndDevicesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingSuppliesAndDevicesItem(MCitem) | Constructs an MCbillingSuppliesAndDevicesItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeBillingItems | This method removes all the values that may have been set for Billing Item Sequence.
Public method | removeQuantities | This method removes all the values that may have been set for Quantity Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillingItems | Represents the values for the Billing Item Sequence attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | Quantities | Represents the values for the Quantity Sequence attribute.

See Also

MCbillingSuppliesAndDevicesItem Class
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Constructor
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCbillingSuppliesAndDevicesItem()()()() | Constructs an MCbillingSuppliesAndDevicesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbillingSuppliesAndDevicesItem(MCitem) | Constructs an MCbillingSuppliesAndDevicesItem collection by wrapping an existing MCitem instance.

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Constructor
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
Constructs an MCbillingSuppliesAndDevicesItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingSuppliesAndDevicesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCbillingSuppliesAndDevicesItem()

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
MCbillingSuppliesAndDevicesItem Overload
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Constructor (MCitem)
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
Constructs an MCbillingSuppliesAndDevicesItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbillingSuppliesAndDevicesItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCbillingSuppliesAndDevicesItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
MCbillingSuppliesAndDevicesItem Overload
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Methods
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback

The MCbillingSuppliesAndDevicesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeBillingItems | This method removes all the values that may have been set for Billing Item Sequence.
Public method | removeQuantities | This method removes all the values that may have been set for Quantity Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbillingSuppliesAndDevicesItem Class
Mergecom.Gen Namespace


removeBillingItems Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem..::..removeBillingItems Method
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
This method removes all the values that may have been set for Billing Item Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingItems()
Visual Basic
Public Overridable Sub removeBillingItems
Visual C++
public:
virtual void removeBillingItems()

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


removeQuantities Method

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem..::..removeQuantities Method
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
This method removes all the values that may have been set for Quantity Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeQuantities()
Visual Basic
Public Overridable Sub removeQuantities
Visual C++
public:
virtual void removeQuantities()

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


MCbillingSuppliesAndDevicesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem Properties
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback

The MCbillingSuppliesAndDevicesItem type exposes the following members.

Properties

 | Name | Description
Public property | BillingItems | Represents the values for the Billing Item Sequence attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | Quantities | Represents the values for the Quantity Sequence attribute.

See Also

MCbillingSuppliesAndDevicesItem Class
Mergecom.Gen Namespace


BillingItems Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem..::..BillingItems Property
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
Represents the values for the Billing Item Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingItemItem[] BillingItems { get; set; }
Visual Basic
Public Overridable Property BillingItems As MCbillingItemItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingItemItem^>^ BillingItems {
    array<MCbillingItemItem^>^ get ();
    void set (array<MCbillingItemItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem..::..Host Property
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


Quantities Property

[image]

Merge DICOM .NET/C# Toolkit
MCbillingSuppliesAndDevicesItem..::..Quantities Property
MCbillingSuppliesAndDevicesItem Class See Also Send Feedback
Represents the values for the Quantity Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCquantityItem[] Quantities { get; set; }
Visual Basic
Public Overridable Property Quantities As MCquantityItem()
    Get
    Set
Visual C++
public:
virtual property array<MCquantityItem^>^ Quantities {
    array<MCquantityItem^>^ get ();
    void set (array<MCquantityItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbillingSuppliesAndDevicesItem Class
MCbillingSuppliesAndDevicesItem Members
Mergecom.Gen Namespace


MCbreedRegistrationItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the BREED_REGISTRATION Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCbreedRegistrationItem
Visual Basic
Public Class MCbreedRegistrationItem
Visual C++
public ref class MCbreedRegistrationItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00102295) Breed Registration Number
  • (00102296) Breed Registry Code Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCbreedRegistrationItem

See Also

MCbreedRegistrationItem Members
Mergecom.Gen Namespace


MCbreedRegistrationItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Members
MCbreedRegistrationItem Class Constructors Methods Properties See Also Send Feedback

The MCbreedRegistrationItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCbreedRegistrationItem()()()() | Constructs an MCbreedRegistrationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbreedRegistrationItem(MCitem) | Constructs an MCbreedRegistrationItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeBreedRegistrationNumber | This method removes all the values that may have been set for Breed Registration Number.
Public method | removeBreedRegistryCodes | This method removes all the values that may have been set for Breed Registry Code Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BreedRegistrationNumber | Represents the value for the Breed Registration Number attribute.
Public property | BreedRegistryCodes | Represents the values for the Breed Registry Code Sequence attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCbreedRegistrationItem Class
Mergecom.Gen Namespace


MCbreedRegistrationItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Constructor
MCbreedRegistrationItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCbreedRegistrationItem()()()() | Constructs an MCbreedRegistrationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCbreedRegistrationItem(MCitem) | Constructs an MCbreedRegistrationItem collection by wrapping an existing MCitem instance.

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


MCbreedRegistrationItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Constructor
MCbreedRegistrationItem Class See Also Send Feedback
Constructs an MCbreedRegistrationItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbreedRegistrationItem()
Visual Basic
Public Sub New
Visual C++
public:
MCbreedRegistrationItem()

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
MCbreedRegistrationItem Overload
Mergecom.Gen Namespace


MCbreedRegistrationItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Constructor (MCitem)
MCbreedRegistrationItem Class See Also Send Feedback
Constructs an MCbreedRegistrationItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbreedRegistrationItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCbreedRegistrationItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
MCbreedRegistrationItem Overload
Mergecom.Gen Namespace


MCbreedRegistrationItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Methods
MCbreedRegistrationItem Class See Also Send Feedback

The MCbreedRegistrationItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeBreedRegistrationNumber | This method removes all the values that may have been set for Breed Registration Number.
Public method | removeBreedRegistryCodes | This method removes all the values that may have been set for Breed Registry Code Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbreedRegistrationItem Class
Mergecom.Gen Namespace


removeBreedRegistrationNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem..::..removeBreedRegistrationNumber Method
MCbreedRegistrationItem Class See Also Send Feedback
This method removes all the values that may have been set for Breed Registration Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBreedRegistrationNumber()
Visual Basic
Public Overridable Sub removeBreedRegistrationNumber
Visual C++
public:
virtual void removeBreedRegistrationNumber()

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


removeBreedRegistryCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem..::..removeBreedRegistryCodes Method
MCbreedRegistrationItem Class See Also Send Feedback
This method removes all the values that may have been set for Breed Registry Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBreedRegistryCodes()
Visual Basic
Public Overridable Sub removeBreedRegistryCodes
Visual C++
public:
virtual void removeBreedRegistryCodes()

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


MCbreedRegistrationItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem Properties
MCbreedRegistrationItem Class See Also Send Feedback

The MCbreedRegistrationItem type exposes the following members.

Properties

 | Name | Description
Public property | BreedRegistrationNumber | Represents the value for the Breed Registration Number attribute.
Public property | BreedRegistryCodes | Represents the values for the Breed Registry Code Sequence attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCbreedRegistrationItem Class
Mergecom.Gen Namespace


BreedRegistrationNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem..::..BreedRegistrationNumber Property
MCbreedRegistrationItem Class See Also Send Feedback
Represents the value for the Breed Registration Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string BreedRegistrationNumber { get; set; }
Visual Basic
Public Overridable Property BreedRegistrationNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ BreedRegistrationNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


BreedRegistryCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem..::..BreedRegistryCodes Property
MCbreedRegistrationItem Class See Also Send Feedback
Represents the values for the Breed Registry Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] BreedRegistryCodes { get; set; }
Visual Basic
Public Overridable Property BreedRegistryCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ BreedRegistryCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCbreedRegistrationItem..::..Host Property
MCbreedRegistrationItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCbreedRegistrationItem Class
MCbreedRegistrationItem Members
Mergecom.Gen Namespace


MCcodeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the CODE_SEQUENCE_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcodeItem
Visual Basic
Public Class MCcodeItem
Visual C++
public ref class MCcodeItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00080117) Context UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCcodeItem

See Also

MCcodeItem Members
Mergecom.Gen Namespace


MCcodeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Members
MCcodeItem Class Constructors Methods Properties See Also Send Feedback

The MCcodeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcodeItem()()()() | Constructs an MCcodeItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcodeItem(MCitem) | Constructs an MCcodeItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCcodeItem Class
Mergecom.Gen Namespace


MCcodeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor
MCcodeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcodeItem()()()() | Constructs an MCcodeItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcodeItem(MCitem) | Constructs an MCcodeItem collection by wrapping an existing MCitem instance.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


MCcodeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor
MCcodeItem Class See Also Send Feedback
Constructs an MCcodeItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcodeItem()

See Also

MCcodeItem Class
MCcodeItem Members
MCcodeItem Overload
Mergecom.Gen Namespace


MCcodeItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor (MCitem)
MCcodeItem Class See Also Send Feedback
Constructs an MCcodeItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodeItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCcodeItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCcodeItem Class
MCcodeItem Members
MCcodeItem Overload
Mergecom.Gen Namespace


MCcodeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Methods
MCcodeItem Class See Also Send Feedback

The MCcodeItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCcodeItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeCodeMeaning Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeCodeValue Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeCodingSchemeDesignator Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeCodingSchemeVersion Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextGroupExtensionCreatorUID Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextGroupExtensionFlag Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextGroupLocalVersion Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextGroupVersion Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextIdentifier Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeContextUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeContextUID Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextUID()
Visual Basic
Public Overridable Sub removeContextUID
Visual C++
public:
virtual void removeContextUID()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..removeMappingResource Method
MCcodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


MCcodeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Properties
MCcodeItem Class See Also Send Feedback

The MCcodeItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCcodeItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..CodeMeaning Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..CodeValue Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..CodingSchemeDesignator Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..CodingSchemeVersion Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextGroupExtensionCreatorUID Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextGroupExtensionFlag Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextGroupLocalVersion Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextGroupVersion Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextIdentifier Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


ContextUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContextUID Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Context UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextUID { get; set; }
Visual Basic
Public Overridable Property ContextUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..Host Property
MCcodeItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..MappingResource Property
MCcodeItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the CODING_SCHEME_IDENTIFICATION Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcodingSchemeIdentificationItem
Visual Basic
Public Class MCcodingSchemeIdentificationItem
Visual C++
public ref class MCcodingSchemeIdentificationItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (0008010C) Coding Scheme UID
  • (00080112) Coding Scheme Registry
  • (00080114) Coding Scheme External ID
  • (00080115) Coding Scheme Name
  • (00080116) Coding Scheme Responsible Organization

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCcodingSchemeIdentificationItem

See Also

MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Members
MCcodingSchemeIdentificationItem Class Constructors Methods Properties See Also Send Feedback

The MCcodingSchemeIdentificationItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcodingSchemeIdentificationItem()()()() | Constructs an MCcodingSchemeIdentificationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcodingSchemeIdentificationItem(MCitem) | Constructs an MCcodingSchemeIdentificationItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeExternalID | This method removes all the values that may have been set for Coding Scheme External ID.
Public method | removeCodingSchemeName | This method removes all the values that may have been set for Coding Scheme Name.
Public method | removeCodingSchemeRegistry | This method removes all the values that may have been set for Coding Scheme Registry.
Public method | removeCodingSchemeResponsibleOrganization | This method removes all the values that may have been set for Coding Scheme Responsible Organization.
Public method | removeCodingSchemeUID | This method removes all the values that may have been set for Coding Scheme UID.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeExternalID | Represents the value for the Coding Scheme External ID attribute.
Public property | CodingSchemeName | Represents the value for the Coding Scheme Name attribute.
Public property | CodingSchemeRegistry | Represents the value for the Coding Scheme Registry attribute.
Public property | CodingSchemeResponsibleOrganization | Represents the value for the Coding Scheme Responsible Organization attribute.
Public property | CodingSchemeUID | Represents the value for the Coding Scheme UID attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCcodingSchemeIdentificationItem Class
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Constructor
MCcodingSchemeIdentificationItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcodingSchemeIdentificationItem()()()() | Constructs an MCcodingSchemeIdentificationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcodingSchemeIdentificationItem(MCitem) | Constructs an MCcodingSchemeIdentificationItem collection by wrapping an existing MCitem instance.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Constructor
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Constructs an MCcodingSchemeIdentificationItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodingSchemeIdentificationItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcodingSchemeIdentificationItem()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
MCcodingSchemeIdentificationItem Overload
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Constructor (MCitem)
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Constructs an MCcodingSchemeIdentificationItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodingSchemeIdentificationItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCcodingSchemeIdentificationItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
MCcodingSchemeIdentificationItem Overload
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Methods
MCcodingSchemeIdentificationItem Class See Also Send Feedback

The MCcodingSchemeIdentificationItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeExternalID | This method removes all the values that may have been set for Coding Scheme External ID.
Public method | removeCodingSchemeName | This method removes all the values that may have been set for Coding Scheme Name.
Public method | removeCodingSchemeRegistry | This method removes all the values that may have been set for Coding Scheme Registry.
Public method | removeCodingSchemeResponsibleOrganization | This method removes all the values that may have been set for Coding Scheme Responsible Organization.
Public method | removeCodingSchemeUID | This method removes all the values that may have been set for Coding Scheme UID.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCcodingSchemeIdentificationItem Class
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeDesignator Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeExternalID Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeExternalID Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme External ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeExternalID()
Visual Basic
Public Overridable Sub removeCodingSchemeExternalID
Visual C++
public:
virtual void removeCodingSchemeExternalID()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeName Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeName Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeName()
Visual Basic
Public Overridable Sub removeCodingSchemeName
Visual C++
public:
virtual void removeCodingSchemeName()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeRegistry Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeRegistry Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Registry.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeRegistry()
Visual Basic
Public Overridable Sub removeCodingSchemeRegistry
Visual C++
public:
virtual void removeCodingSchemeRegistry()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeResponsibleOrganization Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeResponsibleOrganization Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Responsible Organization.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeResponsibleOrganization()
Visual Basic
Public Overridable Sub removeCodingSchemeResponsibleOrganization
Visual C++
public:
virtual void removeCodingSchemeResponsibleOrganization()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeUID Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeUID()
Visual Basic
Public Overridable Sub removeCodingSchemeUID
Visual C++
public:
virtual void removeCodingSchemeUID()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..removeCodingSchemeVersion Method
MCcodingSchemeIdentificationItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


MCcodingSchemeIdentificationItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem Properties
MCcodingSchemeIdentificationItem Class See Also Send Feedback

The MCcodingSchemeIdentificationItem type exposes the following members.

Properties

 | Name | Description
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeExternalID | Represents the value for the Coding Scheme External ID attribute.
Public property | CodingSchemeName | Represents the value for the Coding Scheme Name attribute.
Public property | CodingSchemeRegistry | Represents the value for the Coding Scheme Registry attribute.
Public property | CodingSchemeResponsibleOrganization | Represents the value for the Coding Scheme Responsible Organization attribute.
Public property | CodingSchemeUID | Represents the value for the Coding Scheme UID attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCcodingSchemeIdentificationItem Class
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeDesignator Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeExternalID Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeExternalID Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme External ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeExternalID { get; set; }
Visual Basic
Public Overridable Property CodingSchemeExternalID As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeExternalID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeName Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeName { get; set; }
Visual Basic
Public Overridable Property CodingSchemeName As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeRegistry Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeRegistry Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme Registry attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeRegistry { get; set; }
Visual Basic
Public Overridable Property CodingSchemeRegistry As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeRegistry {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeResponsibleOrganization Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeResponsibleOrganization Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme Responsible Organization attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeResponsibleOrganization { get; set; }
Visual Basic
Public Overridable Property CodingSchemeResponsibleOrganization As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeResponsibleOrganization {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeUID Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeUID { get; set; }
Visual Basic
Public Overridable Property CodingSchemeUID As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..CodingSchemeVersion Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodingSchemeIdentificationItem..::..Host Property
MCcodingSchemeIdentificationItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCcodingSchemeIdentificationItem Class
MCcodingSchemeIdentificationItem Members
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the CONSENT_FOR_CLINICAL_TRIAL_USE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCconsentForClinicalTrialUseItem
Visual Basic
Public Class MCconsentForClinicalTrialUseItem
Visual C++
public ref class MCconsentForClinicalTrialUseItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00120020) Clinical Trial Protocol ID
  • (00120084) Distribution Type
  • (00120085) Consent for Distribution Flag

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCconsentForClinicalTrialUseItem

See Also

MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Members
MCconsentForClinicalTrialUseItem Class Constructors Methods Properties See Also Send Feedback

The MCconsentForClinicalTrialUseItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCconsentForClinicalTrialUseItem()()()() | Constructs an MCconsentForClinicalTrialUseItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCconsentForClinicalTrialUseItem(MCitem) | Constructs an MCconsentForClinicalTrialUseItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeClinicalTrialProtocolID | This method removes all the values that may have been set for Clinical Trial Protocol ID.
Public method | removeConsentForDistributionFlag | This method removes all the values that may have been set for Consent for Distribution Flag.
Public method | removeDistributionType | This method removes all the values that may have been set for Distribution Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClinicalTrialProtocolID | Represents the value for the Clinical Trial Protocol ID attribute.
Public property | ConsentForDistributionFlag | Represents the value for the Consent for Distribution Flag attribute.
Public property | DistributionType | Represents the value for the Distribution Type attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCconsentForClinicalTrialUseItem Class
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Constructor
MCconsentForClinicalTrialUseItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCconsentForClinicalTrialUseItem()()()() | Constructs an MCconsentForClinicalTrialUseItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCconsentForClinicalTrialUseItem(MCitem) | Constructs an MCconsentForClinicalTrialUseItem collection by wrapping an existing MCitem instance.

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Constructor
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Constructs an MCconsentForClinicalTrialUseItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconsentForClinicalTrialUseItem()
Visual Basic
Public Sub New
Visual C++
public:
MCconsentForClinicalTrialUseItem()

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
MCconsentForClinicalTrialUseItem Overload
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Constructor (MCitem)
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Constructs an MCconsentForClinicalTrialUseItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCconsentForClinicalTrialUseItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCconsentForClinicalTrialUseItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
MCconsentForClinicalTrialUseItem Overload
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Methods
MCconsentForClinicalTrialUseItem Class See Also Send Feedback

The MCconsentForClinicalTrialUseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeClinicalTrialProtocolID | This method removes all the values that may have been set for Clinical Trial Protocol ID.
Public method | removeConsentForDistributionFlag | This method removes all the values that may have been set for Consent for Distribution Flag.
Public method | removeDistributionType | This method removes all the values that may have been set for Distribution Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCconsentForClinicalTrialUseItem Class
Mergecom.Gen Namespace


removeClinicalTrialProtocolID Method

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..removeClinicalTrialProtocolID Method
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Protocol ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialProtocolID()
Visual Basic
Public Overridable Sub removeClinicalTrialProtocolID
Visual C++
public:
virtual void removeClinicalTrialProtocolID()

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


removeConsentForDistributionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..removeConsentForDistributionFlag Method
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
This method removes all the values that may have been set for Consent for Distribution Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConsentForDistributionFlag()
Visual Basic
Public Overridable Sub removeConsentForDistributionFlag
Visual C++
public:
virtual void removeConsentForDistributionFlag()

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


removeDistributionType Method

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..removeDistributionType Method
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
This method removes all the values that may have been set for Distribution Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistributionType()
Visual Basic
Public Overridable Sub removeDistributionType
Visual C++
public:
virtual void removeDistributionType()

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


MCconsentForClinicalTrialUseItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem Properties
MCconsentForClinicalTrialUseItem Class See Also Send Feedback

The MCconsentForClinicalTrialUseItem type exposes the following members.

Properties

 | Name | Description
Public property | ClinicalTrialProtocolID | Represents the value for the Clinical Trial Protocol ID attribute.
Public property | ConsentForDistributionFlag | Represents the value for the Consent for Distribution Flag attribute.
Public property | DistributionType | Represents the value for the Distribution Type attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCconsentForClinicalTrialUseItem Class
Mergecom.Gen Namespace


ClinicalTrialProtocolID Property

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..ClinicalTrialProtocolID Property
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Represents the value for the Clinical Trial Protocol ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialProtocolID { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialProtocolID As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialProtocolID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


ConsentForDistributionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..ConsentForDistributionFlag Property
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Represents the value for the Consent for Distribution Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ConsentForDistributionFlag { get; set; }
Visual Basic
Public Overridable Property ConsentForDistributionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ConsentForDistributionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


DistributionType Property

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..DistributionType Property
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Represents the value for the Distribution Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistributionType { get; set; }
Visual Basic
Public Overridable Property DistributionType As String
    Get
    Set
Visual C++
public:
virtual property String^ DistributionType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCconsentForClinicalTrialUseItem..::..Host Property
MCconsentForClinicalTrialUseItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCconsentForClinicalTrialUseItem Class
MCconsentForClinicalTrialUseItem Members
Mergecom.Gen Namespace


MCcontributingEquipmentItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the CONTRIBUTING_EQUIPMENT Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcontributingEquipmentItem
Visual Basic
Public Class MCcontributingEquipmentItem
Visual C++
public ref class MCcontributingEquipmentItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080070) Manufacturer
  • (00080080) Institution Name
  • (00080081) Institution Address
  • (00081010) Station Name
  • (00081040) Institutional Department Name
  • (00081070) Operators' Name
  • (00081072) Operator Identification Sequence
  • (00081090) Manufacturer's Model Name
  • (00181000) Device Serial Number
  • (00181020) Software Version(s)
  • (00181050) Spatial Resolution
  • (00181200) Date of Last Calibration
  • (00181201) Time of Last Calibration
  • (0018A002) Contribution DateTime
  • (0018A003) Contribution Description
  • (0040A170) Purpose of Reference Code Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCcontributingEquipmentItem

See Also

MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


MCcontributingEquipmentItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Members
MCcontributingEquipmentItem Class Constructors Methods Properties See Also Send Feedback

The MCcontributingEquipmentItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcontributingEquipmentItem()()()() | Constructs an MCcontributingEquipmentItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcontributingEquipmentItem(MCitem) | Constructs an MCcontributingEquipmentItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeContributionDateTime | This method removes all the values that may have been set for Contribution DateTime.
Public method | removeContributionDescription | This method removes all the values that may have been set for Contribution Description.
Public method | removeDateOfLastCalibrations | This method removes all the values that may have been set for Date of Last Calibration.
Public method | removeDeviceSerialNumber | This method removes all the values that may have been set for Device Serial Number.
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionalDepartmentName | This method removes all the values that may have been set for Institutional Department Name.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removeManufacturer | This method removes all the values that may have been set for Manufacturer.
Public method | removeManufacturersModelName | This method removes all the values that may have been set for Manufacturer's Model Name.
Public method | removeOperatorIdentifications | This method removes all the values that may have been set for Operator Identification Sequence.
Public method | removeOperatorsNames | This method removes all the values that may have been set for Operators' Name.
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeSoftwareVersions | This method removes all the values that may have been set for Software Version(s).
Public method | removeSpatialResolution | This method removes all the values that may have been set for Spatial Resolution.
Public method | removeStationName | This method removes all the values that may have been set for Station Name.
Public method | removeTimeOfLastCalibrations | This method removes all the values that may have been set for Time of Last Calibration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContributionDateTime | Represents the value for the Contribution DateTime attribute.
Public property | ContributionDescription | Represents the value for the Contribution Description attribute.
Public property | DateOfLastCalibrations | Represents the values for the Date of Last Calibration attribute.
Public property | DeviceSerialNumber | Represents the value for the Device Serial Number attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionalDepartmentName | Represents the value for the Institutional Department Name attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | Manufacturer | Represents the value for the Manufacturer attribute.
Public property | ManufacturersModelName | Represents the value for the Manufacturer's Model Name attribute.
Public property | OperatorIdentifications | Represents the values for the Operator Identification Sequence attribute.
Public property | OperatorsNames | Represents the values for the Operators' Name attribute.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | SoftwareVersions | Represents the values for the Software Version(s) attribute.
Public property | SpatialResolution | Represents the value for the Spatial Resolution attribute.
Public property | StationName | Represents the value for the Station Name attribute.
Public property | TimeOfLastCalibrations | Represents the values for the Time of Last Calibration attribute.

See Also

MCcontributingEquipmentItem Class
Mergecom.Gen Namespace


MCcontributingEquipmentItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Constructor
MCcontributingEquipmentItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcontributingEquipmentItem()()()() | Constructs an MCcontributingEquipmentItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCcontributingEquipmentItem(MCitem) | Constructs an MCcontributingEquipmentItem collection by wrapping an existing MCitem instance.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


MCcontributingEquipmentItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Constructor
MCcontributingEquipmentItem Class See Also Send Feedback
Constructs an MCcontributingEquipmentItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontributingEquipmentItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcontributingEquipmentItem()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
MCcontributingEquipmentItem Overload
Mergecom.Gen Namespace


MCcontributingEquipmentItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Constructor (MCitem)
MCcontributingEquipmentItem Class See Also Send Feedback
Constructs an MCcontributingEquipmentItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontributingEquipmentItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCcontributingEquipmentItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
MCcontributingEquipmentItem Overload
Mergecom.Gen Namespace


MCcontributingEquipmentItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Methods
MCcontributingEquipmentItem Class See Also Send Feedback

The MCcontributingEquipmentItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeContributionDateTime | This method removes all the values that may have been set for Contribution DateTime.
Public method | removeContributionDescription | This method removes all the values that may have been set for Contribution Description.
Public method | removeDateOfLastCalibrations | This method removes all the values that may have been set for Date of Last Calibration.
Public method | removeDeviceSerialNumber | This method removes all the values that may have been set for Device Serial Number.
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionalDepartmentName | This method removes all the values that may have been set for Institutional Department Name.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removeManufacturer | This method removes all the values that may have been set for Manufacturer.
Public method | removeManufacturersModelName | This method removes all the values that may have been set for Manufacturer's Model Name.
Public method | removeOperatorIdentifications | This method removes all the values that may have been set for Operator Identification Sequence.
Public method | removeOperatorsNames | This method removes all the values that may have been set for Operators' Name.
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeSoftwareVersions | This method removes all the values that may have been set for Software Version(s).
Public method | removeSpatialResolution | This method removes all the values that may have been set for Spatial Resolution.
Public method | removeStationName | This method removes all the values that may have been set for Station Name.
Public method | removeTimeOfLastCalibrations | This method removes all the values that may have been set for Time of Last Calibration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCcontributingEquipmentItem Class
Mergecom.Gen Namespace


removeContributionDateTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeContributionDateTime Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Contribution DateTime.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContributionDateTime()
Visual Basic
Public Overridable Sub removeContributionDateTime
Visual C++
public:
virtual void removeContributionDateTime()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeContributionDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeContributionDescription Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Contribution Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContributionDescription()
Visual Basic
Public Overridable Sub removeContributionDescription
Visual C++
public:
virtual void removeContributionDescription()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeDateOfLastCalibrations Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeDateOfLastCalibrations Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Date of Last Calibration.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDateOfLastCalibrations()
Visual Basic
Public Overridable Sub removeDateOfLastCalibrations
Visual C++
public:
virtual void removeDateOfLastCalibrations()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeDeviceSerialNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeDeviceSerialNumber Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Device Serial Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDeviceSerialNumber()
Visual Basic
Public Overridable Sub removeDeviceSerialNumber
Visual C++
public:
virtual void removeDeviceSerialNumber()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeInstitutionAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeInstitutionAddress Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Institution Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionAddress()
Visual Basic
Public Overridable Sub removeInstitutionAddress
Visual C++
public:
virtual void removeInstitutionAddress()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeInstitutionalDepartmentName Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeInstitutionalDepartmentName Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Institutional Department Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionalDepartmentName()
Visual Basic
Public Overridable Sub removeInstitutionalDepartmentName
Visual C++
public:
virtual void removeInstitutionalDepartmentName()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeInstitutionName Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeInstitutionName Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Institution Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionName()
Visual Basic
Public Overridable Sub removeInstitutionName
Visual C++
public:
virtual void removeInstitutionName()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeManufacturer Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeManufacturer Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Manufacturer.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeManufacturer()
Visual Basic
Public Overridable Sub removeManufacturer
Visual C++
public:
virtual void removeManufacturer()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeManufacturersModelName Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeManufacturersModelName Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Manufacturer's Model Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeManufacturersModelName()
Visual Basic
Public Overridable Sub removeManufacturersModelName
Visual C++
public:
virtual void removeManufacturersModelName()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeOperatorIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeOperatorIdentifications Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Operator Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOperatorIdentifications()
Visual Basic
Public Overridable Sub removeOperatorIdentifications
Visual C++
public:
virtual void removeOperatorIdentifications()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeOperatorsNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeOperatorsNames Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Operators' Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOperatorsNames()
Visual Basic
Public Overridable Sub removeOperatorsNames
Visual C++
public:
virtual void removeOperatorsNames()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removePurposeOfReferenceCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removePurposeOfReferenceCodes Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Purpose of Reference Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePurposeOfReferenceCodes()
Visual Basic
Public Overridable Sub removePurposeOfReferenceCodes
Visual C++
public:
virtual void removePurposeOfReferenceCodes()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeSoftwareVersions Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeSoftwareVersions Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Software Version(s).

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSoftwareVersions()
Visual Basic
Public Overridable Sub removeSoftwareVersions
Visual C++
public:
virtual void removeSoftwareVersions()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeSpatialResolution Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeSpatialResolution Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Spatial Resolution.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpatialResolution()
Visual Basic
Public Overridable Sub removeSpatialResolution
Visual C++
public:
virtual void removeSpatialResolution()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeStationName Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeStationName Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Station Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStationName()
Visual Basic
Public Overridable Sub removeStationName
Visual C++
public:
virtual void removeStationName()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


removeTimeOfLastCalibrations Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..removeTimeOfLastCalibrations Method
MCcontributingEquipmentItem Class See Also Send Feedback
This method removes all the values that may have been set for Time of Last Calibration.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTimeOfLastCalibrations()
Visual Basic
Public Overridable Sub removeTimeOfLastCalibrations
Visual C++
public:
virtual void removeTimeOfLastCalibrations()

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


MCcontributingEquipmentItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem Properties
MCcontributingEquipmentItem Class See Also Send Feedback

The MCcontributingEquipmentItem type exposes the following members.

Properties

 | Name | Description
Public property | ContributionDateTime | Represents the value for the Contribution DateTime attribute.
Public property | ContributionDescription | Represents the value for the Contribution Description attribute.
Public property | DateOfLastCalibrations | Represents the values for the Date of Last Calibration attribute.
Public property | DeviceSerialNumber | Represents the value for the Device Serial Number attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionalDepartmentName | Represents the value for the Institutional Department Name attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | Manufacturer | Represents the value for the Manufacturer attribute.
Public property | ManufacturersModelName | Represents the value for the Manufacturer's Model Name attribute.
Public property | OperatorIdentifications | Represents the values for the Operator Identification Sequence attribute.
Public property | OperatorsNames | Represents the values for the Operators' Name attribute.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | SoftwareVersions | Represents the values for the Software Version(s) attribute.
Public property | SpatialResolution | Represents the value for the Spatial Resolution attribute.
Public property | StationName | Represents the value for the Station Name attribute.
Public property | TimeOfLastCalibrations | Represents the values for the Time of Last Calibration attribute.

See Also

MCcontributingEquipmentItem Class
Mergecom.Gen Namespace


ContributionDateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..ContributionDateTime Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Contribution DateTime attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContributionDateTime { get; set; }
Visual Basic
Public Overridable Property ContributionDateTime As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContributionDateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


ContributionDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..ContributionDescription Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Contribution Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContributionDescription { get; set; }
Visual Basic
Public Overridable Property ContributionDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ContributionDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


DateOfLastCalibrations Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..DateOfLastCalibrations Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Date of Last Calibration attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate[] DateOfLastCalibrations { get; set; }
Visual Basic
Public Overridable Property DateOfLastCalibrations As MCdate()
    Get
    Set
Visual C++
public:
virtual property array<MCdate^>^ DateOfLastCalibrations {
    array<MCdate^>^ get ();
    void set (array<MCdate^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


DeviceSerialNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..DeviceSerialNumber Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Device Serial Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DeviceSerialNumber { get; set; }
Visual Basic
Public Overridable Property DeviceSerialNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ DeviceSerialNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..Host Property
MCcontributingEquipmentItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


InstitutionAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..InstitutionAddress Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Institution Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionAddress { get; set; }
Visual Basic
Public Overridable Property InstitutionAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


InstitutionalDepartmentName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..InstitutionalDepartmentName Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Institutional Department Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionalDepartmentName { get; set; }
Visual Basic
Public Overridable Property InstitutionalDepartmentName As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionalDepartmentName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


InstitutionName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..InstitutionName Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Institution Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionName { get; set; }
Visual Basic
Public Overridable Property InstitutionName As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


Manufacturer Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..Manufacturer Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Manufacturer attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Manufacturer { get; set; }
Visual Basic
Public Overridable Property Manufacturer As String
    Get
    Set
Visual C++
public:
virtual property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


ManufacturersModelName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..ManufacturersModelName Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Manufacturer's Model Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ManufacturersModelName { get; set; }
Visual Basic
Public Overridable Property ManufacturersModelName As String
    Get
    Set
Visual C++
public:
virtual property String^ ManufacturersModelName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


OperatorIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..OperatorIdentifications Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Operator Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] OperatorIdentifications { get; set; }
Visual Basic
Public Overridable Property OperatorIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ OperatorIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


OperatorsNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..OperatorsNames Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Operators' Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] OperatorsNames { get; set; }
Visual Basic
Public Overridable Property OperatorsNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ OperatorsNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


PurposeOfReferenceCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..PurposeOfReferenceCodes Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Purpose of Reference Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PurposeOfReferenceCodes { get; set; }
Visual Basic
Public Overridable Property PurposeOfReferenceCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PurposeOfReferenceCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


SoftwareVersions Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..SoftwareVersions Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Software Version(s) attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SoftwareVersions { get; set; }
Visual Basic
Public Overridable Property SoftwareVersions As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SoftwareVersions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


SpatialResolution Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..SpatialResolution Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Spatial Resolution attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SpatialResolution { get; set; }
Visual Basic
Public Overridable Property SpatialResolution As String
    Get
    Set
Visual C++
public:
virtual property String^ SpatialResolution {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


StationName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..StationName Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the value for the Station Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StationName { get; set; }
Visual Basic
Public Overridable Property StationName As String
    Get
    Set
Visual C++
public:
virtual property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


TimeOfLastCalibrations Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontributingEquipmentItem..::..TimeOfLastCalibrations Property
MCcontributingEquipmentItem Class See Also Send Feedback
Represents the values for the Time of Last Calibration attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime[] TimeOfLastCalibrations { get; set; }
Visual Basic
Public Overridable Property TimeOfLastCalibrations As MCtime()
    Get
    Set
Visual C++
public:
virtual property array<MCtime^>^ TimeOfLastCalibrations {
    array<MCtime^>^ get ();
    void set (array<MCtime^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCcontributingEquipmentItem Class
MCcontributingEquipmentItem Members
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Class

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Class
Members See Also Send Feedback
This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdetachedStudyManagementEventReport
Visual Basic
Public Class MCdetachedStudyManagementEventReport
Visual C++
public ref class MCdetachedStudyManagementEventReport

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080012) Instance Creation Date
  • (00080013) Instance Creation Time
  • (00080014) Instance Creator UID
  • (00080020) Study Date
  • (00080030) Study Time
  • (00080050) Accession Number
  • (00080060) Modality
  • (00081030) Study Description
  • (00081032) Procedure Code Sequence
  • (00081050) Performing Physician's Name
  • (00081060) Name of Physician(s) Reading Study
  • (00081100) Referenced Results Sequence
  • (00081110) Referenced Study Sequence
  • (00081111) Referenced Performed Procedure Step Sequence
  • (00081115) Referenced Series Sequence
  • (00081120) Referenced Patient Sequence
  • (00081125) Referenced Visit Sequence
  • (0020000D) Study Instance UID
  • (00200010) Study ID
  • (00201000) Series in Study
  • (00201004) Acquisitions in Study
  • (00201070) Other Study Numbers
  • (0032000A) Study Status ID
  • (0032000C) Study Priority ID
  • (00320012) Study ID Issuer
  • (00320032) Study Verified Date
  • (00320033) Study Verified Time
  • (00320034) Study Read Date
  • (00320035) Study Read Time
  • (00321000) Scheduled Study Start Date
  • (00321001) Scheduled Study Start Time
  • (00321010) Scheduled Study Stop Date
  • (00321011) Scheduled Study Stop Time
  • (00321020) Scheduled Study Location
  • (00321021) Scheduled Study Location AE Title(s)
  • (00321030) Reason for Study
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321040) Study Arrival Date
  • (00321041) Study Arrival Time
  • (00321050) Study Completion Date
  • (00321051) Study Completion Time
  • (00321055) Study Component Status ID
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00321070) Requested Contrast Agent
  • (00324000) Study Comments

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCdetachedStudyManagementEventReport

See Also

MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Members
MCdetachedStudyManagementEventReport Class Constructors Methods Properties See Also Send Feedback

The MCdetachedStudyManagementEventReport type exposes the following members.

Constructors

 | Name | Description
Public method | MCdetachedStudyManagementEventReport()()()() | Constructs an MCdetachedStudyManagementEventReport collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementEventReport(MCdataSet) | Constructs an MCdetachedStudyManagementEventReport collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeInstanceCreationDate | This method removes all the values that may have been set for Instance Creation Date.
Public method | removeInstanceCreationTime | This method removes all the values that may have been set for Instance Creation Time.
Public method | removeInstanceCreatorUID | This method removes all the values that may have been set for Instance Creator UID.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | InstanceCreationDate | Represents the value for the Instance Creation Date attribute.
Public property | InstanceCreationTime | Represents the value for the Instance Creation Time attribute.
Public property | InstanceCreatorUID | Represents the value for the Instance Creator UID attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementEventReport Class
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Constructor
MCdetachedStudyManagementEventReport Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdetachedStudyManagementEventReport()()()() | Constructs an MCdetachedStudyManagementEventReport collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementEventReport(MCdataSet) | Constructs an MCdetachedStudyManagementEventReport collection by wrapping an existing MCdataSet instance.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Constructor
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Constructs an MCdetachedStudyManagementEventReport collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementEventReport()
Visual Basic
Public Sub New
Visual C++
public:
MCdetachedStudyManagementEventReport()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
MCdetachedStudyManagementEventReport Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Constructor (MCdataSet)
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Constructs an MCdetachedStudyManagementEventReport collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementEventReport(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCdetachedStudyManagementEventReport(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
MCdetachedStudyManagementEventReport Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Methods
MCdetachedStudyManagementEventReport Class See Also Send Feedback

The MCdetachedStudyManagementEventReport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeInstanceCreationDate | This method removes all the values that may have been set for Instance Creation Date.
Public method | removeInstanceCreationTime | This method removes all the values that may have been set for Instance Creation Time.
Public method | removeInstanceCreatorUID | This method removes all the values that may have been set for Instance Creator UID.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdetachedStudyManagementEventReport Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeAccessionNumber Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeAcquisitionsInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeAcquisitionsInStudy Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Acquisitions in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAcquisitionsInStudy()
Visual Basic
Public Overridable Sub removeAcquisitionsInStudy
Visual C++
public:
virtual void removeAcquisitionsInStudy()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeInstanceCreationDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeInstanceCreationDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Instance Creation Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstanceCreationDate()
Visual Basic
Public Overridable Sub removeInstanceCreationDate
Visual C++
public:
virtual void removeInstanceCreationDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeInstanceCreationTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeInstanceCreationTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Instance Creation Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstanceCreationTime()
Visual Basic
Public Overridable Sub removeInstanceCreationTime
Visual C++
public:
virtual void removeInstanceCreationTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeInstanceCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeInstanceCreatorUID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Instance Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstanceCreatorUID()
Visual Basic
Public Overridable Sub removeInstanceCreatorUID
Visual C++
public:
virtual void removeInstanceCreatorUID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeModality Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeNameOfPhysiciansReadingStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeNameOfPhysiciansReadingStudies Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Name of Physician(s) Reading Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNameOfPhysiciansReadingStudies()
Visual Basic
Public Overridable Sub removeNameOfPhysiciansReadingStudies
Visual C++
public:
virtual void removeNameOfPhysiciansReadingStudies()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeOtherStudyNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeOtherStudyNumbers Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Other Study Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherStudyNumbers()
Visual Basic
Public Overridable Sub removeOtherStudyNumbers
Visual C++
public:
virtual void removeOtherStudyNumbers()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removePerformingPhysiciansNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removePerformingPhysiciansNames Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysiciansNames()
Visual Basic
Public Overridable Sub removePerformingPhysiciansNames
Visual C++
public:
virtual void removePerformingPhysiciansNames()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeProcedureCodes Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReasonForStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReasonForStudy Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForStudy()
Visual Basic
Public Overridable Sub removeReasonForStudy
Visual C++
public:
virtual void removeReasonForStudy()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedPatients Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedPerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedPerformedProcedureSteps Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeReferencedPerformedProcedureSteps
Visual C++
public:
virtual void removeReferencedPerformedProcedureSteps()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedResults Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedResults Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Results Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedResults()
Visual Basic
Public Overridable Sub removeReferencedResults
Visual C++
public:
virtual void removeReferencedResults()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedSeries Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedStudies Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeReferencedVisits Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeReferencedVisits Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Visit Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedVisits()
Visual Basic
Public Overridable Sub removeReferencedVisits
Visual C++
public:
virtual void removeReferencedVisits()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeRequestedContrastAgent Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeRequestedContrastAgent Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Requested Contrast Agent.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedContrastAgent()
Visual Basic
Public Overridable Sub removeRequestedContrastAgent
Visual C++
public:
virtual void removeRequestedContrastAgent()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeRequestedProcedureCodes Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeRequestedProcedureDescription Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeRequestingPhysician Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeRequestingService Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyLocation Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocation()
Visual Basic
Public Overridable Sub removeScheduledStudyLocation
Visual C++
public:
virtual void removeScheduledStudyLocation()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyLocationAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyLocationAETitles Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location AE Title(s).

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocationAETitles()
Visual Basic
Public Overridable Sub removeScheduledStudyLocationAETitles
Visual C++
public:
virtual void removeScheduledStudyLocationAETitles()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyStartDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStartDate
Visual C++
public:
virtual void removeScheduledStudyStartDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyStartTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStartTime
Visual C++
public:
virtual void removeScheduledStudyStartTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyStopDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyStopDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStopDate
Visual C++
public:
virtual void removeScheduledStudyStopDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeScheduledStudyStopTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeScheduledStudyStopTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStopTime
Visual C++
public:
virtual void removeScheduledStudyStopTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeSeriesInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeSeriesInStudy Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Series in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInStudy()
Visual Basic
Public Overridable Sub removeSeriesInStudy
Visual C++
public:
virtual void removeSeriesInStudy()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyArrivalDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyArrivalDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalDate()
Visual Basic
Public Overridable Sub removeStudyArrivalDate
Visual C++
public:
virtual void removeStudyArrivalDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyArrivalTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyArrivalTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalTime()
Visual Basic
Public Overridable Sub removeStudyArrivalTime
Visual C++
public:
virtual void removeStudyArrivalTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyComments Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComments()
Visual Basic
Public Overridable Sub removeStudyComments
Visual C++
public:
virtual void removeStudyComments()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyCompletionDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyCompletionDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionDate()
Visual Basic
Public Overridable Sub removeStudyCompletionDate
Visual C++
public:
virtual void removeStudyCompletionDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyCompletionTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyCompletionTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionTime()
Visual Basic
Public Overridable Sub removeStudyCompletionTime
Visual C++
public:
virtual void removeStudyCompletionTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyComponentStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyComponentStatusID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Component Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComponentStatusID()
Visual Basic
Public Overridable Sub removeStudyComponentStatusID
Visual C++
public:
virtual void removeStudyComponentStatusID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyDescription Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDescription()
Visual Basic
Public Overridable Sub removeStudyDescription
Visual C++
public:
virtual void removeStudyDescription()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyIDIssuer Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyIDIssuer Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study ID Issuer.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyIDIssuer()
Visual Basic
Public Overridable Sub removeStudyIDIssuer
Visual C++
public:
virtual void removeStudyIDIssuer()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyInstanceUID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyPriorityID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyPriorityID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Priority ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyPriorityID()
Visual Basic
Public Overridable Sub removeStudyPriorityID
Visual C++
public:
virtual void removeStudyPriorityID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyReadDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyReadDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadDate()
Visual Basic
Public Overridable Sub removeStudyReadDate
Visual C++
public:
virtual void removeStudyReadDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyReadTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyReadTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadTime()
Visual Basic
Public Overridable Sub removeStudyReadTime
Visual C++
public:
virtual void removeStudyReadTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyStatusID Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyStatusID()
Visual Basic
Public Overridable Sub removeStudyStatusID
Visual C++
public:
virtual void removeStudyStatusID()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyVerifiedDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyVerifiedDate Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedDate()
Visual Basic
Public Overridable Sub removeStudyVerifiedDate
Visual C++
public:
virtual void removeStudyVerifiedDate()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


removeStudyVerifiedTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..removeStudyVerifiedTime Method
MCdetachedStudyManagementEventReport Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedTime()
Visual Basic
Public Overridable Sub removeStudyVerifiedTime
Visual C++
public:
virtual void removeStudyVerifiedTime()

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


MCdetachedStudyManagementEventReport Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport Properties
MCdetachedStudyManagementEventReport Class See Also Send Feedback

The MCdetachedStudyManagementEventReport type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | InstanceCreationDate | Represents the value for the Instance Creation Date attribute.
Public property | InstanceCreationTime | Represents the value for the Instance Creation Time attribute.
Public property | InstanceCreatorUID | Represents the value for the Instance Creator UID attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementEventReport Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..AccessionNumber Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


AcquisitionsInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..AcquisitionsInStudy Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Acquisitions in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AcquisitionsInStudy { get; set; }
Visual Basic
Public Overridable Property AcquisitionsInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ AcquisitionsInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..Host Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


InstanceCreationDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..InstanceCreationDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Instance Creation Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate InstanceCreationDate { get; set; }
Visual Basic
Public Overridable Property InstanceCreationDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ InstanceCreationDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


InstanceCreationTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..InstanceCreationTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Instance Creation Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime InstanceCreationTime { get; set; }
Visual Basic
Public Overridable Property InstanceCreationTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ InstanceCreationTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


InstanceCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..InstanceCreatorUID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Instance Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstanceCreatorUID { get; set; }
Visual Basic
Public Overridable Property InstanceCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ InstanceCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..Modality Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


NameOfPhysiciansReadingStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..NameOfPhysiciansReadingStudies Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Name of Physician(s) Reading Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] NameOfPhysiciansReadingStudies { get; set; }
Visual Basic
Public Overridable Property NameOfPhysiciansReadingStudies As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ NameOfPhysiciansReadingStudies {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


OtherStudyNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..OtherStudyNumbers Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Other Study Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] OtherStudyNumbers { get; set; }
Visual Basic
Public Overridable Property OtherStudyNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ OtherStudyNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


PerformingPhysiciansNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..PerformingPhysiciansNames Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] PerformingPhysiciansNames { get; set; }
Visual Basic
Public Overridable Property PerformingPhysiciansNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ PerformingPhysiciansNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ProcedureCodes Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReasonForStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReasonForStudy Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Reason for Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForStudy { get; set; }
Visual Basic
Public Overridable Property ReasonForStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedPatients Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedPerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedPerformedProcedureSteps Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Performed Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPerformedProcedureStepItem[] ReferencedPerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property ReferencedPerformedProcedureSteps As MCreferencedPerformedProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPerformedProcedureStepItem^>^ ReferencedPerformedProcedureSteps {
    array<MCreferencedPerformedProcedureStepItem^>^ get ();
    void set (array<MCreferencedPerformedProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedResults Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedResults Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Results Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedResultsItem[] ReferencedResults { get; set; }
Visual Basic
Public Overridable Property ReferencedResults As MCreferencedResultsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedResultsItem^>^ ReferencedResults {
    array<MCreferencedResultsItem^>^ get ();
    void set (array<MCreferencedResultsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedSeries Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedStudies Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ReferencedVisits Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ReferencedVisits Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Referenced Visit Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedVisitItem[] ReferencedVisits { get; set; }
Visual Basic
Public Overridable Property ReferencedVisits As MCreferencedVisitItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedVisitItem^>^ ReferencedVisits {
    array<MCreferencedVisitItem^>^ get ();
    void set (array<MCreferencedVisitItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


RequestedContrastAgent Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..RequestedContrastAgent Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Requested Contrast Agent attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedContrastAgent { get; set; }
Visual Basic
Public Overridable Property RequestedContrastAgent As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedContrastAgent {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..RequestedProcedureCodes Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..RequestedProcedureDescription Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..RequestingPhysician Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..RequestingService Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyLocation Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Scheduled Study Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledStudyLocation { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledStudyLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyLocationAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyLocationAETitles Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the values for the Scheduled Study Location AE Title(s) attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStudyLocationAETitles { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocationAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStudyLocationAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyStartDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Scheduled Study Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStartDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyStartTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Scheduled Study Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStartTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyStopDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyStopDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStopDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStopDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


ScheduledStudyStopTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..ScheduledStudyStopTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStopTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStopTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


SeriesInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..SeriesInStudy Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Series in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInStudy { get; set; }
Visual Basic
Public Overridable Property SeriesInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyArrivalDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyArrivalDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Arrival Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyArrivalDate { get; set; }
Visual Basic
Public Overridable Property StudyArrivalDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyArrivalDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyArrivalTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyArrivalTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Arrival Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyArrivalTime { get; set; }
Visual Basic
Public Overridable Property StudyArrivalTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyArrivalTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyComments Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComments { get; set; }
Visual Basic
Public Overridable Property StudyComments As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyCompletionDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyCompletionDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Completion Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyCompletionDate { get; set; }
Visual Basic
Public Overridable Property StudyCompletionDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyCompletionDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyCompletionTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyCompletionTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Completion Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyCompletionTime { get; set; }
Visual Basic
Public Overridable Property StudyCompletionTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyCompletionTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyComponentStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyComponentStatusID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Component Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComponentStatusID { get; set; }
Visual Basic
Public Overridable Property StudyComponentStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComponentStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyDescription Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyDescription { get; set; }
Visual Basic
Public Overridable Property StudyDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyIDIssuer Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyIDIssuer Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study ID Issuer attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyIDIssuer { get; set; }
Visual Basic
Public Overridable Property StudyIDIssuer As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyIDIssuer {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyInstanceUID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyPriorityID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyPriorityID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Priority ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyPriorityID { get; set; }
Visual Basic
Public Overridable Property StudyPriorityID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyPriorityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyReadDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyReadDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Read Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyReadDate { get; set; }
Visual Basic
Public Overridable Property StudyReadDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyReadDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyReadTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyReadTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Read Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyReadTime { get; set; }
Visual Basic
Public Overridable Property StudyReadTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyReadTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyStatusID Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyStatusID { get; set; }
Visual Basic
Public Overridable Property StudyStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyVerifiedDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyVerifiedDate Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Verified Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyVerifiedDate { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyVerifiedDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


StudyVerifiedTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementEventReport..::..StudyVerifiedTime Property
MCdetachedStudyManagementEventReport Class See Also Send Feedback
Represents the value for the Study Verified Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyVerifiedTime { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyVerifiedTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementEventReport Class
MCdetachedStudyManagementEventReport Members
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Class

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Class
Members See Also Send Feedback
This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdetachedStudyManagementGet
Visual Basic
Public Class MCdetachedStudyManagementGet
Visual C++
public ref class MCdetachedStudyManagementGet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080020) Study Date
  • (00080030) Study Time
  • (00080050) Accession Number
  • (00080060) Modality
  • (00081030) Study Description
  • (00081032) Procedure Code Sequence
  • (00081050) Performing Physician's Name
  • (00081060) Name of Physician(s) Reading Study
  • (00081100) Referenced Results Sequence
  • (00081110) Referenced Study Sequence
  • (00081111) Referenced Performed Procedure Step Sequence
  • (00081115) Referenced Series Sequence
  • (00081120) Referenced Patient Sequence
  • (00081125) Referenced Visit Sequence
  • (0020000D) Study Instance UID
  • (00200010) Study ID
  • (00201000) Series in Study
  • (00201004) Acquisitions in Study
  • (00201070) Other Study Numbers
  • (0032000A) Study Status ID
  • (0032000C) Study Priority ID
  • (00320012) Study ID Issuer
  • (00320032) Study Verified Date
  • (00320033) Study Verified Time
  • (00320034) Study Read Date
  • (00320035) Study Read Time
  • (00321000) Scheduled Study Start Date
  • (00321001) Scheduled Study Start Time
  • (00321010) Scheduled Study Stop Date
  • (00321011) Scheduled Study Stop Time
  • (00321020) Scheduled Study Location
  • (00321021) Scheduled Study Location AE Title(s)
  • (00321030) Reason for Study
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321040) Study Arrival Date
  • (00321041) Study Arrival Time
  • (00321050) Study Completion Date
  • (00321051) Study Completion Time
  • (00321055) Study Component Status ID
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00321070) Requested Contrast Agent
  • (00324000) Study Comments

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCdetachedStudyManagementGet

See Also

MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Members
MCdetachedStudyManagementGet Class Constructors Methods Properties See Also Send Feedback

The MCdetachedStudyManagementGet type exposes the following members.

Constructors

 | Name | Description
Public method | MCdetachedStudyManagementGet()()()() | Constructs an MCdetachedStudyManagementGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementGet(MCdataSet) | Constructs an MCdetachedStudyManagementGet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementGet Class
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Constructor
MCdetachedStudyManagementGet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdetachedStudyManagementGet()()()() | Constructs an MCdetachedStudyManagementGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementGet(MCdataSet) | Constructs an MCdetachedStudyManagementGet collection by wrapping an existing MCdataSet instance.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Constructor
MCdetachedStudyManagementGet Class See Also Send Feedback
Constructs an MCdetachedStudyManagementGet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementGet()
Visual Basic
Public Sub New
Visual C++
public:
MCdetachedStudyManagementGet()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
MCdetachedStudyManagementGet Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Constructor (MCdataSet)
MCdetachedStudyManagementGet Class See Also Send Feedback
Constructs an MCdetachedStudyManagementGet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementGet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCdetachedStudyManagementGet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
MCdetachedStudyManagementGet Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Methods
MCdetachedStudyManagementGet Class See Also Send Feedback

The MCdetachedStudyManagementGet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdetachedStudyManagementGet Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeAccessionNumber Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeAcquisitionsInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeAcquisitionsInStudy Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Acquisitions in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAcquisitionsInStudy()
Visual Basic
Public Overridable Sub removeAcquisitionsInStudy
Visual C++
public:
virtual void removeAcquisitionsInStudy()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeModality Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeNameOfPhysiciansReadingStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeNameOfPhysiciansReadingStudies Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Name of Physician(s) Reading Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNameOfPhysiciansReadingStudies()
Visual Basic
Public Overridable Sub removeNameOfPhysiciansReadingStudies
Visual C++
public:
virtual void removeNameOfPhysiciansReadingStudies()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeOtherStudyNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeOtherStudyNumbers Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Other Study Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherStudyNumbers()
Visual Basic
Public Overridable Sub removeOtherStudyNumbers
Visual C++
public:
virtual void removeOtherStudyNumbers()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removePerformingPhysiciansNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removePerformingPhysiciansNames Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysiciansNames()
Visual Basic
Public Overridable Sub removePerformingPhysiciansNames
Visual C++
public:
virtual void removePerformingPhysiciansNames()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeProcedureCodes Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReasonForStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReasonForStudy Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForStudy()
Visual Basic
Public Overridable Sub removeReasonForStudy
Visual C++
public:
virtual void removeReasonForStudy()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedPatients Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedPerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedPerformedProcedureSteps Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeReferencedPerformedProcedureSteps
Visual C++
public:
virtual void removeReferencedPerformedProcedureSteps()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedResults Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedResults Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Results Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedResults()
Visual Basic
Public Overridable Sub removeReferencedResults
Visual C++
public:
virtual void removeReferencedResults()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedSeries Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedStudies Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeReferencedVisits Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeReferencedVisits Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Visit Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedVisits()
Visual Basic
Public Overridable Sub removeReferencedVisits
Visual C++
public:
virtual void removeReferencedVisits()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeRequestedContrastAgent Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeRequestedContrastAgent Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Contrast Agent.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedContrastAgent()
Visual Basic
Public Overridable Sub removeRequestedContrastAgent
Visual C++
public:
virtual void removeRequestedContrastAgent()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeRequestedProcedureCodes Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeRequestedProcedureDescription Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeRequestingPhysician Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeRequestingService Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyLocation Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocation()
Visual Basic
Public Overridable Sub removeScheduledStudyLocation
Visual C++
public:
virtual void removeScheduledStudyLocation()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyLocationAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyLocationAETitles Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location AE Title(s).

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocationAETitles()
Visual Basic
Public Overridable Sub removeScheduledStudyLocationAETitles
Visual C++
public:
virtual void removeScheduledStudyLocationAETitles()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyStartDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStartDate
Visual C++
public:
virtual void removeScheduledStudyStartDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyStartTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStartTime
Visual C++
public:
virtual void removeScheduledStudyStartTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStopDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyStopDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStopDate
Visual C++
public:
virtual void removeScheduledStudyStopDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStopTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeScheduledStudyStopTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStopTime
Visual C++
public:
virtual void removeScheduledStudyStopTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeSeriesInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeSeriesInStudy Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Series in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInStudy()
Visual Basic
Public Overridable Sub removeSeriesInStudy
Visual C++
public:
virtual void removeSeriesInStudy()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeSpecificCharacterSets Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyArrivalDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyArrivalDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalDate()
Visual Basic
Public Overridable Sub removeStudyArrivalDate
Visual C++
public:
virtual void removeStudyArrivalDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyArrivalTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyArrivalTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalTime()
Visual Basic
Public Overridable Sub removeStudyArrivalTime
Visual C++
public:
virtual void removeStudyArrivalTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyComments Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComments()
Visual Basic
Public Overridable Sub removeStudyComments
Visual C++
public:
virtual void removeStudyComments()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyCompletionDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyCompletionDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionDate()
Visual Basic
Public Overridable Sub removeStudyCompletionDate
Visual C++
public:
virtual void removeStudyCompletionDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyCompletionTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyCompletionTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionTime()
Visual Basic
Public Overridable Sub removeStudyCompletionTime
Visual C++
public:
virtual void removeStudyCompletionTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyComponentStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyComponentStatusID Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Component Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComponentStatusID()
Visual Basic
Public Overridable Sub removeStudyComponentStatusID
Visual C++
public:
virtual void removeStudyComponentStatusID()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyDescription Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDescription()
Visual Basic
Public Overridable Sub removeStudyDescription
Visual C++
public:
virtual void removeStudyDescription()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyID Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyIDIssuer Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyIDIssuer Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID Issuer.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyIDIssuer()
Visual Basic
Public Overridable Sub removeStudyIDIssuer
Visual C++
public:
virtual void removeStudyIDIssuer()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyInstanceUID Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyPriorityID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyPriorityID Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Priority ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyPriorityID()
Visual Basic
Public Overridable Sub removeStudyPriorityID
Visual C++
public:
virtual void removeStudyPriorityID()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyReadDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyReadDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadDate()
Visual Basic
Public Overridable Sub removeStudyReadDate
Visual C++
public:
virtual void removeStudyReadDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyReadTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyReadTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadTime()
Visual Basic
Public Overridable Sub removeStudyReadTime
Visual C++
public:
virtual void removeStudyReadTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyStatusID Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyStatusID()
Visual Basic
Public Overridable Sub removeStudyStatusID
Visual C++
public:
virtual void removeStudyStatusID()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyVerifiedDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyVerifiedDate Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedDate()
Visual Basic
Public Overridable Sub removeStudyVerifiedDate
Visual C++
public:
virtual void removeStudyVerifiedDate()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


removeStudyVerifiedTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..removeStudyVerifiedTime Method
MCdetachedStudyManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedTime()
Visual Basic
Public Overridable Sub removeStudyVerifiedTime
Visual C++
public:
virtual void removeStudyVerifiedTime()

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementGet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet Properties
MCdetachedStudyManagementGet Class See Also Send Feedback

The MCdetachedStudyManagementGet type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementGet Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..AccessionNumber Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


AcquisitionsInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..AcquisitionsInStudy Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Acquisitions in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AcquisitionsInStudy { get; set; }
Visual Basic
Public Overridable Property AcquisitionsInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ AcquisitionsInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..Host Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..Modality Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


NameOfPhysiciansReadingStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..NameOfPhysiciansReadingStudies Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Name of Physician(s) Reading Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] NameOfPhysiciansReadingStudies { get; set; }
Visual Basic
Public Overridable Property NameOfPhysiciansReadingStudies As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ NameOfPhysiciansReadingStudies {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


OtherStudyNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..OtherStudyNumbers Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Other Study Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] OtherStudyNumbers { get; set; }
Visual Basic
Public Overridable Property OtherStudyNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ OtherStudyNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


PerformingPhysiciansNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..PerformingPhysiciansNames Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] PerformingPhysiciansNames { get; set; }
Visual Basic
Public Overridable Property PerformingPhysiciansNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ PerformingPhysiciansNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ProcedureCodes Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReasonForStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReasonForStudy Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Reason for Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForStudy { get; set; }
Visual Basic
Public Overridable Property ReasonForStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedPatients Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedPerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedPerformedProcedureSteps Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Performed Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPerformedProcedureStepItem[] ReferencedPerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property ReferencedPerformedProcedureSteps As MCreferencedPerformedProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPerformedProcedureStepItem^>^ ReferencedPerformedProcedureSteps {
    array<MCreferencedPerformedProcedureStepItem^>^ get ();
    void set (array<MCreferencedPerformedProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedResults Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedResults Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Results Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedResultsItem[] ReferencedResults { get; set; }
Visual Basic
Public Overridable Property ReferencedResults As MCreferencedResultsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedResultsItem^>^ ReferencedResults {
    array<MCreferencedResultsItem^>^ get ();
    void set (array<MCreferencedResultsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedSeries Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedStudies Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ReferencedVisits Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ReferencedVisits Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Referenced Visit Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedVisitItem[] ReferencedVisits { get; set; }
Visual Basic
Public Overridable Property ReferencedVisits As MCreferencedVisitItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedVisitItem^>^ ReferencedVisits {
    array<MCreferencedVisitItem^>^ get ();
    void set (array<MCreferencedVisitItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


RequestedContrastAgent Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..RequestedContrastAgent Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Requested Contrast Agent attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedContrastAgent { get; set; }
Visual Basic
Public Overridable Property RequestedContrastAgent As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedContrastAgent {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..RequestedProcedureCodes Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..RequestedProcedureDescription Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..RequestingPhysician Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..RequestingService Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyLocation Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledStudyLocation { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledStudyLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyLocationAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyLocationAETitles Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Scheduled Study Location AE Title(s) attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStudyLocationAETitles { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocationAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStudyLocationAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyStartDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStartDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyStartTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStartTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStopDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyStopDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStopDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStopDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStopTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..ScheduledStudyStopTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStopTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStopTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


SeriesInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..SeriesInStudy Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Series in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInStudy { get; set; }
Visual Basic
Public Overridable Property SeriesInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..SpecificCharacterSets Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyArrivalDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyArrivalDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Arrival Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyArrivalDate { get; set; }
Visual Basic
Public Overridable Property StudyArrivalDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyArrivalDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyArrivalTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyArrivalTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Arrival Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyArrivalTime { get; set; }
Visual Basic
Public Overridable Property StudyArrivalTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyArrivalTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyComments Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComments { get; set; }
Visual Basic
Public Overridable Property StudyComments As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyCompletionDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyCompletionDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Completion Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyCompletionDate { get; set; }
Visual Basic
Public Overridable Property StudyCompletionDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyCompletionDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyCompletionTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyCompletionTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Completion Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyCompletionTime { get; set; }
Visual Basic
Public Overridable Property StudyCompletionTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyCompletionTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyComponentStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyComponentStatusID Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Component Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComponentStatusID { get; set; }
Visual Basic
Public Overridable Property StudyComponentStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComponentStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyDescription Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyDescription { get; set; }
Visual Basic
Public Overridable Property StudyDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyID Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyIDIssuer Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyIDIssuer Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study ID Issuer attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyIDIssuer { get; set; }
Visual Basic
Public Overridable Property StudyIDIssuer As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyIDIssuer {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyInstanceUID Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyPriorityID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyPriorityID Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Priority ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyPriorityID { get; set; }
Visual Basic
Public Overridable Property StudyPriorityID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyPriorityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyReadDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyReadDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Read Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyReadDate { get; set; }
Visual Basic
Public Overridable Property StudyReadDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyReadDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyReadTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyReadTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Read Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyReadTime { get; set; }
Visual Basic
Public Overridable Property StudyReadTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyReadTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyStatusID Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyStatusID { get; set; }
Visual Basic
Public Overridable Property StudyStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyVerifiedDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyVerifiedDate Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Verified Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyVerifiedDate { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyVerifiedDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


StudyVerifiedTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementGet..::..StudyVerifiedTime Property
MCdetachedStudyManagementGet Class See Also Send Feedback
Represents the value for the Study Verified Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyVerifiedTime { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyVerifiedTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementGet Class
MCdetachedStudyManagementGet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Class
Members See Also Send Feedback
This class serves as a container for attributes of the DETACHED_STUDY_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdetachedStudyManagementSet
Visual Basic
Public Class MCdetachedStudyManagementSet
Visual C++
public ref class MCdetachedStudyManagementSet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080020) Study Date
  • (00080030) Study Time
  • (0032000A) Study Status ID
  • (00320032) Study Verified Date
  • (00320033) Study Verified Time
  • (00321040) Study Arrival Date
  • (00321041) Study Arrival Time
  • (00321050) Study Completion Date
  • (00321051) Study Completion Time

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCdetachedStudyManagementSet

See Also

MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Members
MCdetachedStudyManagementSet Class Constructors Methods Properties See Also Send Feedback

The MCdetachedStudyManagementSet type exposes the following members.

Constructors

 | Name | Description
Public method | MCdetachedStudyManagementSet()()()() | Constructs an MCdetachedStudyManagementSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementSet(MCdataSet) | Constructs an MCdetachedStudyManagementSet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementSet Class
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Constructor
MCdetachedStudyManagementSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdetachedStudyManagementSet()()()() | Constructs an MCdetachedStudyManagementSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCdetachedStudyManagementSet(MCdataSet) | Constructs an MCdetachedStudyManagementSet collection by wrapping an existing MCdataSet instance.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Constructor
MCdetachedStudyManagementSet Class See Also Send Feedback
Constructs an MCdetachedStudyManagementSet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementSet()
Visual Basic
Public Sub New
Visual C++
public:
MCdetachedStudyManagementSet()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
MCdetachedStudyManagementSet Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Constructor (MCdataSet)
MCdetachedStudyManagementSet Class See Also Send Feedback
Constructs an MCdetachedStudyManagementSet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdetachedStudyManagementSet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCdetachedStudyManagementSet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
MCdetachedStudyManagementSet Overload
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Methods
MCdetachedStudyManagementSet Class See Also Send Feedback

The MCdetachedStudyManagementSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdetachedStudyManagementSet Class
Mergecom.Gen Namespace


removeStudyArrivalDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyArrivalDate Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalDate()
Visual Basic
Public Overridable Sub removeStudyArrivalDate
Visual C++
public:
virtual void removeStudyArrivalDate()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyArrivalTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyArrivalTime Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalTime()
Visual Basic
Public Overridable Sub removeStudyArrivalTime
Visual C++
public:
virtual void removeStudyArrivalTime()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyCompletionDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyCompletionDate Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionDate()
Visual Basic
Public Overridable Sub removeStudyCompletionDate
Visual C++
public:
virtual void removeStudyCompletionDate()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyCompletionTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyCompletionTime Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionTime()
Visual Basic
Public Overridable Sub removeStudyCompletionTime
Visual C++
public:
virtual void removeStudyCompletionTime()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyDate Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyStatusID Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyStatusID()
Visual Basic
Public Overridable Sub removeStudyStatusID
Visual C++
public:
virtual void removeStudyStatusID()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyTime Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyVerifiedDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyVerifiedDate Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedDate()
Visual Basic
Public Overridable Sub removeStudyVerifiedDate
Visual C++
public:
virtual void removeStudyVerifiedDate()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


removeStudyVerifiedTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..removeStudyVerifiedTime Method
MCdetachedStudyManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedTime()
Visual Basic
Public Overridable Sub removeStudyVerifiedTime
Visual C++
public:
virtual void removeStudyVerifiedTime()

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


MCdetachedStudyManagementSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet Properties
MCdetachedStudyManagementSet Class See Also Send Feedback

The MCdetachedStudyManagementSet type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCdetachedStudyManagementSet Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..Host Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyArrivalDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyArrivalDate Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Arrival Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyArrivalDate { get; set; }
Visual Basic
Public Overridable Property StudyArrivalDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyArrivalDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyArrivalTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyArrivalTime Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Arrival Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyArrivalTime { get; set; }
Visual Basic
Public Overridable Property StudyArrivalTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyArrivalTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyCompletionDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyCompletionDate Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Completion Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyCompletionDate { get; set; }
Visual Basic
Public Overridable Property StudyCompletionDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyCompletionDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyCompletionTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyCompletionTime Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Completion Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyCompletionTime { get; set; }
Visual Basic
Public Overridable Property StudyCompletionTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyCompletionTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyDate Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyStatusID Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyStatusID { get; set; }
Visual Basic
Public Overridable Property StudyStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyTime Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyVerifiedDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyVerifiedDate Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Verified Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyVerifiedDate { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyVerifiedDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


StudyVerifiedTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdetachedStudyManagementSet..::..StudyVerifiedTime Property
MCdetachedStudyManagementSet Class See Also Send Feedback
Represents the value for the Study Verified Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyVerifiedTime { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyVerifiedTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdetachedStudyManagementSet Class
MCdetachedStudyManagementSet Members
Mergecom.Gen Namespace


MCdigitalSignaturesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the DIGITAL_SIGNATURES Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdigitalSignaturesItem
Visual Basic
Public Class MCdigitalSignaturesItem
Visual C++
public ref class MCdigitalSignaturesItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (04000005) MAC ID Number
  • (04000100) Digital Signature UID
  • (04000105) Digital Signature DateTime
  • (04000110) Certificate Type
  • (04000305) Certified Timestamp Type
  • (04000401) Digital Signature Purpose Code Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCdigitalSignaturesItem

See Also

MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


MCdigitalSignaturesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Members
MCdigitalSignaturesItem Class Constructors Methods Properties See Also Send Feedback

The MCdigitalSignaturesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCdigitalSignaturesItem()()()() | Constructs an MCdigitalSignaturesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCdigitalSignaturesItem(MCitem) | Constructs an MCdigitalSignaturesItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCertificateType | This method removes all the values that may have been set for Certificate Type.
Public method | removeCertifiedTimestampType | This method removes all the values that may have been set for Certified Timestamp Type.
Public method | removeDigitalSignatureDateTime | This method removes all the values that may have been set for Digital Signature DateTime.
Public method | removeDigitalSignaturePurposeCodes | This method removes all the values that may have been set for Digital Signature Purpose Code Sequence.
Public method | removeDigitalSignatureUID | This method removes all the values that may have been set for Digital Signature UID.
Public method | removeMACIDNumber | This method removes all the values that may have been set for MAC ID Number.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CertificateType | Represents the value for the Certificate Type attribute.
Public property | CertifiedTimestampType | Represents the value for the Certified Timestamp Type attribute.
Public property | DigitalSignatureDateTime | Represents the value for the Digital Signature DateTime attribute.
Public property | DigitalSignaturePurposeCodes | Represents the values for the Digital Signature Purpose Code Sequence attribute.
Public property | DigitalSignatureUID | Represents the value for the Digital Signature UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACIDNumber | Represents the value for the MAC ID Number attribute.

See Also

MCdigitalSignaturesItem Class
Mergecom.Gen Namespace


MCdigitalSignaturesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Constructor
MCdigitalSignaturesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdigitalSignaturesItem()()()() | Constructs an MCdigitalSignaturesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCdigitalSignaturesItem(MCitem) | Constructs an MCdigitalSignaturesItem collection by wrapping an existing MCitem instance.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


MCdigitalSignaturesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Constructor
MCdigitalSignaturesItem Class See Also Send Feedback
Constructs an MCdigitalSignaturesItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdigitalSignaturesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCdigitalSignaturesItem()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
MCdigitalSignaturesItem Overload
Mergecom.Gen Namespace


MCdigitalSignaturesItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Constructor (MCitem)
MCdigitalSignaturesItem Class See Also Send Feedback
Constructs an MCdigitalSignaturesItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdigitalSignaturesItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCdigitalSignaturesItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
MCdigitalSignaturesItem Overload
Mergecom.Gen Namespace


MCdigitalSignaturesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Methods
MCdigitalSignaturesItem Class See Also Send Feedback

The MCdigitalSignaturesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCertificateType | This method removes all the values that may have been set for Certificate Type.
Public method | removeCertifiedTimestampType | This method removes all the values that may have been set for Certified Timestamp Type.
Public method | removeDigitalSignatureDateTime | This method removes all the values that may have been set for Digital Signature DateTime.
Public method | removeDigitalSignaturePurposeCodes | This method removes all the values that may have been set for Digital Signature Purpose Code Sequence.
Public method | removeDigitalSignatureUID | This method removes all the values that may have been set for Digital Signature UID.
Public method | removeMACIDNumber | This method removes all the values that may have been set for MAC ID Number.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdigitalSignaturesItem Class
Mergecom.Gen Namespace


removeCertificateType Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeCertificateType Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for Certificate Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCertificateType()
Visual Basic
Public Overridable Sub removeCertificateType
Visual C++
public:
virtual void removeCertificateType()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


removeCertifiedTimestampType Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeCertifiedTimestampType Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for Certified Timestamp Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCertifiedTimestampType()
Visual Basic
Public Overridable Sub removeCertifiedTimestampType
Visual C++
public:
virtual void removeCertifiedTimestampType()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


removeDigitalSignatureDateTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeDigitalSignatureDateTime Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for Digital Signature DateTime.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDigitalSignatureDateTime()
Visual Basic
Public Overridable Sub removeDigitalSignatureDateTime
Visual C++
public:
virtual void removeDigitalSignatureDateTime()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


removeDigitalSignaturePurposeCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeDigitalSignaturePurposeCodes Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for Digital Signature Purpose Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDigitalSignaturePurposeCodes()
Visual Basic
Public Overridable Sub removeDigitalSignaturePurposeCodes
Visual C++
public:
virtual void removeDigitalSignaturePurposeCodes()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


removeDigitalSignatureUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeDigitalSignatureUID Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for Digital Signature UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDigitalSignatureUID()
Visual Basic
Public Overridable Sub removeDigitalSignatureUID
Visual C++
public:
virtual void removeDigitalSignatureUID()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


removeMACIDNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..removeMACIDNumber Method
MCdigitalSignaturesItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC ID Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACIDNumber()
Visual Basic
Public Overridable Sub removeMACIDNumber
Visual C++
public:
virtual void removeMACIDNumber()

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


MCdigitalSignaturesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem Properties
MCdigitalSignaturesItem Class See Also Send Feedback

The MCdigitalSignaturesItem type exposes the following members.

Properties

 | Name | Description
Public property | CertificateType | Represents the value for the Certificate Type attribute.
Public property | CertifiedTimestampType | Represents the value for the Certified Timestamp Type attribute.
Public property | DigitalSignatureDateTime | Represents the value for the Digital Signature DateTime attribute.
Public property | DigitalSignaturePurposeCodes | Represents the values for the Digital Signature Purpose Code Sequence attribute.
Public property | DigitalSignatureUID | Represents the value for the Digital Signature UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACIDNumber | Represents the value for the MAC ID Number attribute.

See Also

MCdigitalSignaturesItem Class
Mergecom.Gen Namespace


CertificateType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..CertificateType Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the value for the Certificate Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CertificateType { get; set; }
Visual Basic
Public Overridable Property CertificateType As String
    Get
    Set
Visual C++
public:
virtual property String^ CertificateType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


CertifiedTimestampType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..CertifiedTimestampType Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the value for the Certified Timestamp Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CertifiedTimestampType { get; set; }
Visual Basic
Public Overridable Property CertifiedTimestampType As String
    Get
    Set
Visual C++
public:
virtual property String^ CertifiedTimestampType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


DigitalSignatureDateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..DigitalSignatureDateTime Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the value for the Digital Signature DateTime attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime DigitalSignatureDateTime { get; set; }
Visual Basic
Public Overridable Property DigitalSignatureDateTime As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ DigitalSignatureDateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


DigitalSignaturePurposeCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..DigitalSignaturePurposeCodes Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the values for the Digital Signature Purpose Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] DigitalSignaturePurposeCodes { get; set; }
Visual Basic
Public Overridable Property DigitalSignaturePurposeCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ DigitalSignaturePurposeCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


DigitalSignatureUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..DigitalSignatureUID Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the value for the Digital Signature UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DigitalSignatureUID { get; set; }
Visual Basic
Public Overridable Property DigitalSignatureUID As String
    Get
    Set
Visual C++
public:
virtual property String^ DigitalSignatureUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..Host Property
MCdigitalSignaturesItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


MACIDNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCdigitalSignaturesItem..::..MACIDNumber Property
MCdigitalSignaturesItem Class See Also Send Feedback
Represents the value for the MAC ID Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MACIDNumber { get; set; }
Visual Basic
Public Overridable Property MACIDNumber As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short MACIDNumber {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCdigitalSignaturesItem Class
MCdigitalSignaturesItem Members
Mergecom.Gen Namespace


MCexposureDoseItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the EXPOSURE_DOSE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCexposureDoseItem
Visual Basic
Public Class MCexposureDoseItem
Visual C++
public ref class MCexposureDoseItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00180060) KVP
  • (00181150) Exposure Time
  • (0018115A) Radiation Mode
  • (00181160) Filter Type
  • (00187050) Filter Material
  • (00188151) X-Ray Tube Current in uA
  • (00400310) Comments on Radiation Dose

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCexposureDoseItem

See Also

MCexposureDoseItem Members
Mergecom.Gen Namespace


MCexposureDoseItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Members
MCexposureDoseItem Class Constructors Methods Properties See Also Send Feedback

The MCexposureDoseItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCexposureDoseItem()()()() | Constructs an MCexposureDoseItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCexposureDoseItem(MCitem) | Constructs an MCexposureDoseItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeExposureTime | This method removes all the values that may have been set for Exposure Time.
Public method | removeFilterMaterials | This method removes all the values that may have been set for Filter Material.
Public method | removeFilterType | This method removes all the values that may have been set for Filter Type.
Public method | removeKVP | This method removes all the values that may have been set for KVP.
Public method | removeRadiationMode | This method removes all the values that may have been set for Radiation Mode.
Public method | removeXRayTubeCurrentInUA | This method removes all the values that may have been set for X-Ray Tube Current in uA.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | ExposureTime | Represents the value for the Exposure Time attribute.
Public property | FilterMaterials | Represents the values for the Filter Material attribute.
Public property | FilterType | Represents the value for the Filter Type attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | KVP | Represents the value for the KVP attribute.
Public property | RadiationMode | Represents the value for the Radiation Mode attribute.
Public property | XRayTubeCurrentInUA | Represents the value for the X-Ray Tube Current in uA attribute.

See Also

MCexposureDoseItem Class
Mergecom.Gen Namespace


MCexposureDoseItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Constructor
MCexposureDoseItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCexposureDoseItem()()()() | Constructs an MCexposureDoseItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCexposureDoseItem(MCitem) | Constructs an MCexposureDoseItem collection by wrapping an existing MCitem instance.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


MCexposureDoseItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Constructor
MCexposureDoseItem Class See Also Send Feedback
Constructs an MCexposureDoseItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexposureDoseItem()
Visual Basic
Public Sub New
Visual C++
public:
MCexposureDoseItem()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
MCexposureDoseItem Overload
Mergecom.Gen Namespace


MCexposureDoseItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Constructor (MCitem)
MCexposureDoseItem Class See Also Send Feedback
Constructs an MCexposureDoseItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCexposureDoseItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCexposureDoseItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
MCexposureDoseItem Overload
Mergecom.Gen Namespace


MCexposureDoseItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Methods
MCexposureDoseItem Class See Also Send Feedback

The MCexposureDoseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeExposureTime | This method removes all the values that may have been set for Exposure Time.
Public method | removeFilterMaterials | This method removes all the values that may have been set for Filter Material.
Public method | removeFilterType | This method removes all the values that may have been set for Filter Type.
Public method | removeKVP | This method removes all the values that may have been set for KVP.
Public method | removeRadiationMode | This method removes all the values that may have been set for Radiation Mode.
Public method | removeXRayTubeCurrentInUA | This method removes all the values that may have been set for X-Ray Tube Current in uA.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCexposureDoseItem Class
Mergecom.Gen Namespace


removeCommentsOnRadiationDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeCommentsOnRadiationDose Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for Comments on Radiation Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnRadiationDose()
Visual Basic
Public Overridable Sub removeCommentsOnRadiationDose
Visual C++
public:
virtual void removeCommentsOnRadiationDose()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeExposureTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeExposureTime Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for Exposure Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposureTime()
Visual Basic
Public Overridable Sub removeExposureTime
Visual C++
public:
virtual void removeExposureTime()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeFilterMaterials Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeFilterMaterials Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for Filter Material.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilterMaterials()
Visual Basic
Public Overridable Sub removeFilterMaterials
Visual C++
public:
virtual void removeFilterMaterials()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeFilterType Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeFilterType Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for Filter Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilterType()
Visual Basic
Public Overridable Sub removeFilterType
Visual C++
public:
virtual void removeFilterType()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeKVP Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeKVP Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for KVP.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeKVP()
Visual Basic
Public Overridable Sub removeKVP
Visual C++
public:
virtual void removeKVP()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeRadiationMode Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeRadiationMode Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for Radiation Mode.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRadiationMode()
Visual Basic
Public Overridable Sub removeRadiationMode
Visual C++
public:
virtual void removeRadiationMode()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


removeXRayTubeCurrentInUA Method

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..removeXRayTubeCurrentInUA Method
MCexposureDoseItem Class See Also Send Feedback
This method removes all the values that may have been set for X-Ray Tube Current in uA.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeXRayTubeCurrentInUA()
Visual Basic
Public Overridable Sub removeXRayTubeCurrentInUA
Visual C++
public:
virtual void removeXRayTubeCurrentInUA()

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


MCexposureDoseItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem Properties
MCexposureDoseItem Class See Also Send Feedback

The MCexposureDoseItem type exposes the following members.

Properties

 | Name | Description
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | ExposureTime | Represents the value for the Exposure Time attribute.
Public property | FilterMaterials | Represents the values for the Filter Material attribute.
Public property | FilterType | Represents the value for the Filter Type attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | KVP | Represents the value for the KVP attribute.
Public property | RadiationMode | Represents the value for the Radiation Mode attribute.
Public property | XRayTubeCurrentInUA | Represents the value for the X-Ray Tube Current in uA attribute.

See Also

MCexposureDoseItem Class
Mergecom.Gen Namespace


CommentsOnRadiationDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..CommentsOnRadiationDose Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the Comments on Radiation Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnRadiationDose { get; set; }
Visual Basic
Public Overridable Property CommentsOnRadiationDose As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnRadiationDose {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


ExposureTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..ExposureTime Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the Exposure Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ExposureTime { get; set; }
Visual Basic
Public Overridable Property ExposureTime As String
    Get
    Set
Visual C++
public:
virtual property String^ ExposureTime {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


FilterMaterials Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..FilterMaterials Property
MCexposureDoseItem Class See Also Send Feedback
Represents the values for the Filter Material attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] FilterMaterials { get; set; }
Visual Basic
Public Overridable Property FilterMaterials As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ FilterMaterials {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


FilterType Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..FilterType Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the Filter Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FilterType { get; set; }
Visual Basic
Public Overridable Property FilterType As String
    Get
    Set
Visual C++
public:
virtual property String^ FilterType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..Host Property
MCexposureDoseItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


KVP Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..KVP Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the KVP attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string KVP { get; set; }
Visual Basic
Public Overridable Property KVP As String
    Get
    Set
Visual C++
public:
virtual property String^ KVP {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


RadiationMode Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..RadiationMode Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the Radiation Mode attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RadiationMode { get; set; }
Visual Basic
Public Overridable Property RadiationMode As String
    Get
    Set
Visual C++
public:
virtual property String^ RadiationMode {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


XRayTubeCurrentInUA Property

[image]

Merge DICOM .NET/C# Toolkit
MCexposureDoseItem..::..XRayTubeCurrentInUA Property
MCexposureDoseItem Class See Also Send Feedback
Represents the value for the X-Ray Tube Current in uA attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string XRayTubeCurrentInUA { get; set; }
Visual Basic
Public Overridable Property XRayTubeCurrentInUA As String
    Get
    Set
Visual C++
public:
virtual property String^ XRayTubeCurrentInUA {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCexposureDoseItem Class
MCexposureDoseItem Members
Mergecom.Gen Namespace


MCfilmConsumptionItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the FILM_CONSUMPTION Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCfilmConsumptionItem
Visual Basic
Public Class MCfilmConsumptionItem
Visual C++
public ref class MCfilmConsumptionItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (20000030) Medium Type
  • (20100050) Film Size ID
  • (21000170) Number of Films

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCfilmConsumptionItem

See Also

MCfilmConsumptionItem Members
Mergecom.Gen Namespace


MCfilmConsumptionItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Members
MCfilmConsumptionItem Class Constructors Methods Properties See Also Send Feedback

The MCfilmConsumptionItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCfilmConsumptionItem()()()() | Constructs an MCfilmConsumptionItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCfilmConsumptionItem(MCitem) | Constructs an MCfilmConsumptionItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeFilmSizeID | This method removes all the values that may have been set for Film Size ID.
Public method | removeMediumType | This method removes all the values that may have been set for Medium Type.
Public method | removeNumberOfFilms | This method removes all the values that may have been set for Number of Films.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilmSizeID | Represents the value for the Film Size ID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MediumType | Represents the value for the Medium Type attribute.
Public property | NumberOfFilms | Represents the value for the Number of Films attribute.

See Also

MCfilmConsumptionItem Class
Mergecom.Gen Namespace


MCfilmConsumptionItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Constructor
MCfilmConsumptionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCfilmConsumptionItem()()()() | Constructs an MCfilmConsumptionItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCfilmConsumptionItem(MCitem) | Constructs an MCfilmConsumptionItem collection by wrapping an existing MCitem instance.

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


MCfilmConsumptionItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Constructor
MCfilmConsumptionItem Class See Also Send Feedback
Constructs an MCfilmConsumptionItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfilmConsumptionItem()
Visual Basic
Public Sub New
Visual C++
public:
MCfilmConsumptionItem()

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
MCfilmConsumptionItem Overload
Mergecom.Gen Namespace


MCfilmConsumptionItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Constructor (MCitem)
MCfilmConsumptionItem Class See Also Send Feedback
Constructs an MCfilmConsumptionItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCfilmConsumptionItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCfilmConsumptionItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
MCfilmConsumptionItem Overload
Mergecom.Gen Namespace


MCfilmConsumptionItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Methods
MCfilmConsumptionItem Class See Also Send Feedback

The MCfilmConsumptionItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeFilmSizeID | This method removes all the values that may have been set for Film Size ID.
Public method | removeMediumType | This method removes all the values that may have been set for Medium Type.
Public method | removeNumberOfFilms | This method removes all the values that may have been set for Number of Films.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCfilmConsumptionItem Class
Mergecom.Gen Namespace


removeFilmSizeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..removeFilmSizeID Method
MCfilmConsumptionItem Class See Also Send Feedback
This method removes all the values that may have been set for Film Size ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilmSizeID()
Visual Basic
Public Overridable Sub removeFilmSizeID
Visual C++
public:
virtual void removeFilmSizeID()

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


removeMediumType Method

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..removeMediumType Method
MCfilmConsumptionItem Class See Also Send Feedback
This method removes all the values that may have been set for Medium Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMediumType()
Visual Basic
Public Overridable Sub removeMediumType
Visual C++
public:
virtual void removeMediumType()

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


removeNumberOfFilms Method

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..removeNumberOfFilms Method
MCfilmConsumptionItem Class See Also Send Feedback
This method removes all the values that may have been set for Number of Films.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNumberOfFilms()
Visual Basic
Public Overridable Sub removeNumberOfFilms
Visual C++
public:
virtual void removeNumberOfFilms()

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


MCfilmConsumptionItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem Properties
MCfilmConsumptionItem Class See Also Send Feedback

The MCfilmConsumptionItem type exposes the following members.

Properties

 | Name | Description
Public property | FilmSizeID | Represents the value for the Film Size ID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MediumType | Represents the value for the Medium Type attribute.
Public property | NumberOfFilms | Represents the value for the Number of Films attribute.

See Also

MCfilmConsumptionItem Class
Mergecom.Gen Namespace


FilmSizeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..FilmSizeID Property
MCfilmConsumptionItem Class See Also Send Feedback
Represents the value for the Film Size ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FilmSizeID { get; set; }
Visual Basic
Public Overridable Property FilmSizeID As String
    Get
    Set
Visual C++
public:
virtual property String^ FilmSizeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..Host Property
MCfilmConsumptionItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


MediumType Property

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..MediumType Property
MCfilmConsumptionItem Class See Also Send Feedback
Represents the value for the Medium Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MediumType { get; set; }
Visual Basic
Public Overridable Property MediumType As String
    Get
    Set
Visual C++
public:
virtual property String^ MediumType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


NumberOfFilms Property

[image]

Merge DICOM .NET/C# Toolkit
MCfilmConsumptionItem..::..NumberOfFilms Property
MCfilmConsumptionItem Class See Also Send Feedback
Represents the value for the Number of Films attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string NumberOfFilms { get; set; }
Visual Basic
Public Overridable Property NumberOfFilms As String
    Get
    Set
Visual C++
public:
virtual property String^ NumberOfFilms {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCfilmConsumptionItem Class
MCfilmConsumptionItem Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Class

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Class
Members See Also Send Feedback
This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCgpPerformedProcedureStepCreate
Visual Basic
Public Class MCgpPerformedProcedureStepCreate
Visual C++
public ref class MCgpPerformedProcedureStepCreate

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00100010) Patient's Name
  • (00100020) Patient ID
  • (00100021) Issuer of Patient ID
  • (00100024) Issuer of Patient ID Qualifiers Sequence
  • (00100030) Patient's Birth Date
  • (00100040) Patient's Sex
  • (00380010) Admission ID
  • (00380014) Issuer of Admission ID Sequence
  • (00380060) Service Episode ID
  • (00380062) Service Episode Description
  • (00380064) Issuer of Service Episode ID Sequence
  • (00400244) Performed Procedure Step Start Date
  • (00400245) Performed Procedure Step Start Time
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400253) Performed Procedure Step ID
  • (00400254) Performed Procedure Step Description
  • (00400280) Comments on the Performed Procedure Steps
  • (00404002) General Purpose Performed Procedure Step Status
  • (00404007) Performed Processing Applications Code Sequence
  • (00404016) Referenced General Purpose Scheduled Procedure Ste
  • (00404019) Performed Workitem Code Sequence
  • (00404028) Performed Station Name Code Sequence
  • (00404029) Performed Station Class Code Sequence
  • (00404030) Performed Station Geographic Location Code Sequenc
  • (00404031) Requested Subsequent Workitem Code Sequence
  • (00404032) Non-DICOM Output Code Sequence
  • (00404033) Output Information Sequence
  • (00404035) Actual Human Performers Sequence
  • (0040A370) Referenced Request Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCgpPerformedProcedureStepCreate

See Also

MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Members
MCgpPerformedProcedureStepCreate Class Constructors Methods Properties See Also Send Feedback

The MCgpPerformedProcedureStepCreate type exposes the following members.

Constructors

 | Name | Description
Public method | MCgpPerformedProcedureStepCreate()()()() | Constructs an MCgpPerformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepCreate(MCdataSet) | Constructs an MCgpPerformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcessingApplicationsCodes | This method removes all the values that may have been set for Performed Processing Applications Code Sequence.
Public method | removePerformedStationClassCodes | This method removes all the values that may have been set for Performed Station Class Code Sequence.
Public method | removePerformedStationGeographicLocationCodes | This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.
Public method | removePerformedStationNameCodes | This method removes all the values that may have been set for Performed Station Name Code Sequence.
Public method | removePerformedWorkitemCodes | This method removes all the values that may have been set for Performed Workitem Code Sequence.
Public method | removeReferencedGeneralPurposeScheduledProcedureStes | This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.
Public method | removeReferencedRequests | This method removes all the values that may have been set for Referenced Request Sequence.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcessingApplicationsCodes | Represents the values for the Performed Processing Applications Code Sequence attribute.
Public property | PerformedStationClassCodes | Represents the values for the Performed Station Class Code Sequence attribute.
Public property | PerformedStationGeographicLocationCodes | Represents the values for the Performed Station Geographic Location Code Sequenc attribute.
Public property | PerformedStationNameCodes | Represents the values for the Performed Station Name Code Sequence attribute.
Public property | PerformedWorkitemCodes | Represents the values for the Performed Workitem Code Sequence attribute.
Public property | ReferencedGeneralPurposeScheduledProcedureStes | Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.
Public property | ReferencedRequests | Represents the values for the Referenced Request Sequence attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.

See Also

MCgpPerformedProcedureStepCreate Class
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Constructor
MCgpPerformedProcedureStepCreate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCgpPerformedProcedureStepCreate()()()() | Constructs an MCgpPerformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepCreate(MCdataSet) | Constructs an MCgpPerformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Constructor
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepCreate()
Visual Basic
Public Sub New
Visual C++
public:
MCgpPerformedProcedureStepCreate()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
MCgpPerformedProcedureStepCreate Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Constructor (MCdataSet)
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepCreate(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCgpPerformedProcedureStepCreate(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
MCgpPerformedProcedureStepCreate Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Methods
MCgpPerformedProcedureStepCreate Class See Also Send Feedback

The MCgpPerformedProcedureStepCreate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcessingApplicationsCodes | This method removes all the values that may have been set for Performed Processing Applications Code Sequence.
Public method | removePerformedStationClassCodes | This method removes all the values that may have been set for Performed Station Class Code Sequence.
Public method | removePerformedStationGeographicLocationCodes | This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.
Public method | removePerformedStationNameCodes | This method removes all the values that may have been set for Performed Station Name Code Sequence.
Public method | removePerformedWorkitemCodes | This method removes all the values that may have been set for Performed Workitem Code Sequence.
Public method | removeReferencedGeneralPurposeScheduledProcedureStes | This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.
Public method | removeReferencedRequests | This method removes all the values that may have been set for Referenced Request Sequence.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCgpPerformedProcedureStepCreate Class
Mergecom.Gen Namespace


removeActualHumanPerformers Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeActualHumanPerformers Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Actual Human Performers Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeActualHumanPerformers()
Visual Basic
Public Overridable Sub removeActualHumanPerformers
Visual C++
public:
virtual void removeActualHumanPerformers()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeAdmissionID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeAdmissionID Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Admission ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmissionID()
Visual Basic
Public Overridable Sub removeAdmissionID
Visual C++
public:
virtual void removeAdmissionID()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeCommentsOnThePerformedProcedureSteps Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeGeneralPurposePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeGeneralPurposePerformedProcedureStepStatus Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeGeneralPurposePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removeGeneralPurposePerformedProcedureStepStatus
Visual C++
public:
virtual void removeGeneralPurposePerformedProcedureStepStatus()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfAdmissionIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeIssuerOfAdmissionIDs Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Admission ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAdmissionIDs()
Visual Basic
Public Overridable Sub removeIssuerOfAdmissionIDs
Visual C++
public:
virtual void removeIssuerOfAdmissionIDs()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfPatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeIssuerOfPatientID Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfPatientID()
Visual Basic
Public Overridable Sub removeIssuerOfPatientID
Visual C++
public:
virtual void removeIssuerOfPatientID()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfServiceEpisodeIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeIssuerOfServiceEpisodeIDs Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfServiceEpisodeIDs()
Visual Basic
Public Overridable Sub removeIssuerOfServiceEpisodeIDs
Visual C++
public:
virtual void removeIssuerOfServiceEpisodeIDs()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeNonDICOMOutputCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeNonDICOMOutputCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Non-DICOM Output Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNonDICOMOutputCodes()
Visual Basic
Public Overridable Sub removeNonDICOMOutputCodes
Visual C++
public:
virtual void removeNonDICOMOutputCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeOutputInformation Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeOutputInformation Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Output Information Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOutputInformation()
Visual Basic
Public Overridable Sub removeOutputInformation
Visual C++
public:
virtual void removeOutputInformation()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePatientID Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsBirthDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePatientsBirthDate Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthDate()
Visual Basic
Public Overridable Sub removePatientsBirthDate
Visual C++
public:
virtual void removePatientsBirthDate()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsName Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePatientsName Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsName()
Visual Basic
Public Overridable Sub removePatientsName
Visual C++
public:
virtual void removePatientsName()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsSex Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePatientsSex Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSex()
Visual Basic
Public Overridable Sub removePatientsSex
Visual C++
public:
virtual void removePatientsSex()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepDescription Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepEndDate Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepEndTime Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepID Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepID()
Visual Basic
Public Overridable Sub removePerformedProcedureStepID
Visual C++
public:
virtual void removePerformedProcedureStepID()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepStartDate Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartDate
Visual C++
public:
virtual void removePerformedProcedureStepStartDate()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcedureStepStartTime Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartTime
Visual C++
public:
virtual void removePerformedProcedureStepStartTime()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcessingApplicationsCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedProcessingApplicationsCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Processing Applications Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcessingApplicationsCodes()
Visual Basic
Public Overridable Sub removePerformedProcessingApplicationsCodes
Visual C++
public:
virtual void removePerformedProcessingApplicationsCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedStationClassCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedStationClassCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Class Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationClassCodes()
Visual Basic
Public Overridable Sub removePerformedStationClassCodes
Visual C++
public:
virtual void removePerformedStationClassCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedStationGeographicLocationCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedStationGeographicLocationCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationGeographicLocationCodes()
Visual Basic
Public Overridable Sub removePerformedStationGeographicLocationCodes
Visual C++
public:
virtual void removePerformedStationGeographicLocationCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedStationNameCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedStationNameCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Name Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationNameCodes()
Visual Basic
Public Overridable Sub removePerformedStationNameCodes
Visual C++
public:
virtual void removePerformedStationNameCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedWorkitemCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removePerformedWorkitemCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Workitem Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedWorkitemCodes()
Visual Basic
Public Overridable Sub removePerformedWorkitemCodes
Visual C++
public:
virtual void removePerformedWorkitemCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeReferencedGeneralPurposeScheduledProcedureStes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeReferencedGeneralPurposeScheduledProcedureStes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedGeneralPurposeScheduledProcedureStes()
Visual Basic
Public Overridable Sub removeReferencedGeneralPurposeScheduledProcedureStes
Visual C++
public:
virtual void removeReferencedGeneralPurposeScheduledProcedureStes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeReferencedRequests Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeReferencedRequests Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Request Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedRequests()
Visual Basic
Public Overridable Sub removeReferencedRequests
Visual C++
public:
virtual void removeReferencedRequests()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeRequestedSubsequentWorkitemCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeRequestedSubsequentWorkitemCodes Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedSubsequentWorkitemCodes()
Visual Basic
Public Overridable Sub removeRequestedSubsequentWorkitemCodes
Visual C++
public:
virtual void removeRequestedSubsequentWorkitemCodes()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeServiceEpisodeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeServiceEpisodeDescription Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeDescription()
Visual Basic
Public Overridable Sub removeServiceEpisodeDescription
Visual C++
public:
virtual void removeServiceEpisodeDescription()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeServiceEpisodeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeServiceEpisodeID Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeID()
Visual Basic
Public Overridable Sub removeServiceEpisodeID
Visual C++
public:
virtual void removeServiceEpisodeID()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..removeSpecificCharacterSets Method
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepCreate Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate Properties
MCgpPerformedProcedureStepCreate Class See Also Send Feedback

The MCgpPerformedProcedureStepCreate type exposes the following members.

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcessingApplicationsCodes | Represents the values for the Performed Processing Applications Code Sequence attribute.
Public property | PerformedStationClassCodes | Represents the values for the Performed Station Class Code Sequence attribute.
Public property | PerformedStationGeographicLocationCodes | Represents the values for the Performed Station Geographic Location Code Sequenc attribute.
Public property | PerformedStationNameCodes | Represents the values for the Performed Station Name Code Sequence attribute.
Public property | PerformedWorkitemCodes | Represents the values for the Performed Workitem Code Sequence attribute.
Public property | ReferencedGeneralPurposeScheduledProcedureStes | Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.
Public property | ReferencedRequests | Represents the values for the Referenced Request Sequence attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.

See Also

MCgpPerformedProcedureStepCreate Class
Mergecom.Gen Namespace


ActualHumanPerformers Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..ActualHumanPerformers Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Actual Human Performers Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCactualHumanPerformersItem[] ActualHumanPerformers { get; set; }
Visual Basic
Public Overridable Property ActualHumanPerformers As MCactualHumanPerformersItem()
    Get
    Set
Visual C++
public:
virtual property array<MCactualHumanPerformersItem^>^ ActualHumanPerformers {
    array<MCactualHumanPerformersItem^>^ get ();
    void set (array<MCactualHumanPerformersItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


AdmissionID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..AdmissionID Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Admission ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdmissionID { get; set; }
Visual Basic
Public Overridable Property AdmissionID As String
    Get
    Set
Visual C++
public:
virtual property String^ AdmissionID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..CommentsOnThePerformedProcedureSteps Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


GeneralPurposePerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..GeneralPurposePerformedProcedureStepStatus Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the General Purpose Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string GeneralPurposePerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property GeneralPurposePerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ GeneralPurposePerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..Host Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfAdmissionIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..IssuerOfAdmissionIDs Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Issuer of Admission ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAdmissionIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfAdmissionIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAdmissionIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfPatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..IssuerOfPatientID Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Issuer of Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IssuerOfPatientID { get; set; }
Visual Basic
Public Overridable Property IssuerOfPatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ IssuerOfPatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfServiceEpisodeIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..IssuerOfServiceEpisodeIDs Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Issuer of Service Episode ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfServiceEpisodeIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfServiceEpisodeIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfServiceEpisodeIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


NonDICOMOutputCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..NonDICOMOutputCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Non-DICOM Output Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] NonDICOMOutputCodes { get; set; }
Visual Basic
Public Overridable Property NonDICOMOutputCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ NonDICOMOutputCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


OutputInformation Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..OutputInformation Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Output Information Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCoutputInformationItem[] OutputInformation { get; set; }
Visual Basic
Public Overridable Property OutputInformation As MCoutputInformationItem()
    Get
    Set
Visual C++
public:
virtual property array<MCoutputInformationItem^>^ OutputInformation {
    array<MCoutputInformationItem^>^ get ();
    void set (array<MCoutputInformationItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PatientID Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsBirthDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PatientsBirthDate Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Birth Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PatientsBirthDate { get; set; }
Visual Basic
Public Overridable Property PatientsBirthDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PatientsBirthDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PatientsName Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsName { get; set; }
Visual Basic
Public Overridable Property PatientsName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsSex Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PatientsSex Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Sex attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSex { get; set; }
Visual Basic
Public Overridable Property PatientsSex As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSex {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepDescription Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepEndDate Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepEndTime Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepID Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepID { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepStartDate Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepStartDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcedureStepStartTime Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepStartTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcessingApplicationsCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedProcessingApplicationsCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Processing Applications Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedProcessingApplicationsCodes { get; set; }
Visual Basic
Public Overridable Property PerformedProcessingApplicationsCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedProcessingApplicationsCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedStationClassCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedStationClassCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Station Class Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationClassCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationClassCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationClassCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedStationGeographicLocationCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedStationGeographicLocationCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Station Geographic Location Code Sequenc attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationGeographicLocationCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationGeographicLocationCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationGeographicLocationCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedStationNameCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedStationNameCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Station Name Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationNameCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationNameCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationNameCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedWorkitemCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..PerformedWorkitemCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Workitem Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedWorkitemCodes { get; set; }
Visual Basic
Public Overridable Property PerformedWorkitemCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedWorkitemCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


ReferencedGeneralPurposeScheduledProcedureStes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..ReferencedGeneralPurposeScheduledProcedureStes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedGeneralPurposeScheduledProcedureSteItem[] ReferencedGeneralPurposeScheduledProcedureStes { get; set; }
Visual Basic
Public Overridable Property ReferencedGeneralPurposeScheduledProcedureStes As MCreferencedGeneralPurposeScheduledProcedureSteItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ ReferencedGeneralPurposeScheduledProcedureStes {
    array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ get ();
    void set (array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


ReferencedRequests Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..ReferencedRequests Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Referenced Request Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedRequestItem[] ReferencedRequests { get; set; }
Visual Basic
Public Overridable Property ReferencedRequests As MCreferencedRequestItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedRequestItem^>^ ReferencedRequests {
    array<MCreferencedRequestItem^>^ get ();
    void set (array<MCreferencedRequestItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


RequestedSubsequentWorkitemCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..RequestedSubsequentWorkitemCodes Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Requested Subsequent Workitem Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedSubsequentWorkitemCodes { get; set; }
Visual Basic
Public Overridable Property RequestedSubsequentWorkitemCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedSubsequentWorkitemCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


ServiceEpisodeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..ServiceEpisodeDescription Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Service Episode Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeDescription { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


ServiceEpisodeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..ServiceEpisodeID Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Service Episode ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeID { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeID As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepCreate..::..SpecificCharacterSets Property
MCgpPerformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepCreate Class
MCgpPerformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Class

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Class
Members See Also Send Feedback
This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCgpPerformedProcedureStepGet
Visual Basic
Public Class MCgpPerformedProcedureStepGet
Visual C++
public ref class MCgpPerformedProcedureStepGet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00100010) Patient's Name
  • (00100020) Patient ID
  • (00100021) Issuer of Patient ID
  • (00100024) Issuer of Patient ID Qualifiers Sequence
  • (00100030) Patient's Birth Date
  • (00100040) Patient's Sex
  • (00380010) Admission ID
  • (00380014) Issuer of Admission ID Sequence
  • (00380060) Service Episode ID
  • (00380062) Service Episode Description
  • (00380064) Issuer of Service Episode ID Sequence
  • (00400244) Performed Procedure Step Start Date
  • (00400245) Performed Procedure Step Start Time
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400253) Performed Procedure Step ID
  • (00400254) Performed Procedure Step Description
  • (00400280) Comments on the Performed Procedure Steps
  • (00404002) General Purpose Performed Procedure Step Status
  • (00404007) Performed Processing Applications Code Sequence
  • (00404016) Referenced General Purpose Scheduled Procedure Ste
  • (00404019) Performed Workitem Code Sequence
  • (00404028) Performed Station Name Code Sequence
  • (00404029) Performed Station Class Code Sequence
  • (00404030) Performed Station Geographic Location Code Sequenc
  • (00404031) Requested Subsequent Workitem Code Sequence
  • (00404032) Non-DICOM Output Code Sequence
  • (00404033) Output Information Sequence
  • (00404035) Actual Human Performers Sequence
  • (0040A370) Referenced Request Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCgpPerformedProcedureStepGet

See Also

MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Members
MCgpPerformedProcedureStepGet Class Constructors Methods Properties See Also Send Feedback

The MCgpPerformedProcedureStepGet type exposes the following members.

Constructors

 | Name | Description
Public method | MCgpPerformedProcedureStepGet()()()() | Constructs an MCgpPerformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepGet(MCdataSet) | Constructs an MCgpPerformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcessingApplicationsCodes | This method removes all the values that may have been set for Performed Processing Applications Code Sequence.
Public method | removePerformedStationClassCodes | This method removes all the values that may have been set for Performed Station Class Code Sequence.
Public method | removePerformedStationGeographicLocationCodes | This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.
Public method | removePerformedStationNameCodes | This method removes all the values that may have been set for Performed Station Name Code Sequence.
Public method | removePerformedWorkitemCodes | This method removes all the values that may have been set for Performed Workitem Code Sequence.
Public method | removeReferencedGeneralPurposeScheduledProcedureStes | This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.
Public method | removeReferencedRequests | This method removes all the values that may have been set for Referenced Request Sequence.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcessingApplicationsCodes | Represents the values for the Performed Processing Applications Code Sequence attribute.
Public property | PerformedStationClassCodes | Represents the values for the Performed Station Class Code Sequence attribute.
Public property | PerformedStationGeographicLocationCodes | Represents the values for the Performed Station Geographic Location Code Sequenc attribute.
Public property | PerformedStationNameCodes | Represents the values for the Performed Station Name Code Sequence attribute.
Public property | PerformedWorkitemCodes | Represents the values for the Performed Workitem Code Sequence attribute.
Public property | ReferencedGeneralPurposeScheduledProcedureStes | Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.
Public property | ReferencedRequests | Represents the values for the Referenced Request Sequence attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.

See Also

MCgpPerformedProcedureStepGet Class
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Constructor
MCgpPerformedProcedureStepGet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCgpPerformedProcedureStepGet()()()() | Constructs an MCgpPerformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepGet(MCdataSet) | Constructs an MCgpPerformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Constructor
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepGet()
Visual Basic
Public Sub New
Visual C++
public:
MCgpPerformedProcedureStepGet()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
MCgpPerformedProcedureStepGet Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Constructor (MCdataSet)
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepGet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCgpPerformedProcedureStepGet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
MCgpPerformedProcedureStepGet Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Methods
MCgpPerformedProcedureStepGet Class See Also Send Feedback

The MCgpPerformedProcedureStepGet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcessingApplicationsCodes | This method removes all the values that may have been set for Performed Processing Applications Code Sequence.
Public method | removePerformedStationClassCodes | This method removes all the values that may have been set for Performed Station Class Code Sequence.
Public method | removePerformedStationGeographicLocationCodes | This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.
Public method | removePerformedStationNameCodes | This method removes all the values that may have been set for Performed Station Name Code Sequence.
Public method | removePerformedWorkitemCodes | This method removes all the values that may have been set for Performed Workitem Code Sequence.
Public method | removeReferencedGeneralPurposeScheduledProcedureStes | This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.
Public method | removeReferencedRequests | This method removes all the values that may have been set for Referenced Request Sequence.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCgpPerformedProcedureStepGet Class
Mergecom.Gen Namespace


removeActualHumanPerformers Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeActualHumanPerformers Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Actual Human Performers Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeActualHumanPerformers()
Visual Basic
Public Overridable Sub removeActualHumanPerformers
Visual C++
public:
virtual void removeActualHumanPerformers()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeAdmissionID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeAdmissionID Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Admission ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmissionID()
Visual Basic
Public Overridable Sub removeAdmissionID
Visual C++
public:
virtual void removeAdmissionID()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeCommentsOnThePerformedProcedureSteps Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeGeneralPurposePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeGeneralPurposePerformedProcedureStepStatus Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeGeneralPurposePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removeGeneralPurposePerformedProcedureStepStatus
Visual C++
public:
virtual void removeGeneralPurposePerformedProcedureStepStatus()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfAdmissionIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeIssuerOfAdmissionIDs Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Admission ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAdmissionIDs()
Visual Basic
Public Overridable Sub removeIssuerOfAdmissionIDs
Visual C++
public:
virtual void removeIssuerOfAdmissionIDs()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfPatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeIssuerOfPatientID Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfPatientID()
Visual Basic
Public Overridable Sub removeIssuerOfPatientID
Visual C++
public:
virtual void removeIssuerOfPatientID()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfServiceEpisodeIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeIssuerOfServiceEpisodeIDs Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfServiceEpisodeIDs()
Visual Basic
Public Overridable Sub removeIssuerOfServiceEpisodeIDs
Visual C++
public:
virtual void removeIssuerOfServiceEpisodeIDs()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeNonDICOMOutputCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeNonDICOMOutputCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Non-DICOM Output Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNonDICOMOutputCodes()
Visual Basic
Public Overridable Sub removeNonDICOMOutputCodes
Visual C++
public:
virtual void removeNonDICOMOutputCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeOutputInformation Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeOutputInformation Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Output Information Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOutputInformation()
Visual Basic
Public Overridable Sub removeOutputInformation
Visual C++
public:
virtual void removeOutputInformation()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePatientID Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsBirthDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePatientsBirthDate Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthDate()
Visual Basic
Public Overridable Sub removePatientsBirthDate
Visual C++
public:
virtual void removePatientsBirthDate()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsName Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePatientsName Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsName()
Visual Basic
Public Overridable Sub removePatientsName
Visual C++
public:
virtual void removePatientsName()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsSex Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePatientsSex Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSex()
Visual Basic
Public Overridable Sub removePatientsSex
Visual C++
public:
virtual void removePatientsSex()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepDescription Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepEndDate Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepEndTime Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepID Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepID()
Visual Basic
Public Overridable Sub removePerformedProcedureStepID
Visual C++
public:
virtual void removePerformedProcedureStepID()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepStartDate Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartDate
Visual C++
public:
virtual void removePerformedProcedureStepStartDate()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcedureStepStartTime Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartTime
Visual C++
public:
virtual void removePerformedProcedureStepStartTime()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcessingApplicationsCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedProcessingApplicationsCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Processing Applications Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcessingApplicationsCodes()
Visual Basic
Public Overridable Sub removePerformedProcessingApplicationsCodes
Visual C++
public:
virtual void removePerformedProcessingApplicationsCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedStationClassCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedStationClassCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Class Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationClassCodes()
Visual Basic
Public Overridable Sub removePerformedStationClassCodes
Visual C++
public:
virtual void removePerformedStationClassCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedStationGeographicLocationCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedStationGeographicLocationCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Geographic Location Code Sequenc.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationGeographicLocationCodes()
Visual Basic
Public Overridable Sub removePerformedStationGeographicLocationCodes
Visual C++
public:
virtual void removePerformedStationGeographicLocationCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedStationNameCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedStationNameCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Name Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationNameCodes()
Visual Basic
Public Overridable Sub removePerformedStationNameCodes
Visual C++
public:
virtual void removePerformedStationNameCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedWorkitemCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removePerformedWorkitemCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Workitem Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedWorkitemCodes()
Visual Basic
Public Overridable Sub removePerformedWorkitemCodes
Visual C++
public:
virtual void removePerformedWorkitemCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeReferencedGeneralPurposeScheduledProcedureStes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeReferencedGeneralPurposeScheduledProcedureStes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced General Purpose Scheduled Procedure Ste.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedGeneralPurposeScheduledProcedureStes()
Visual Basic
Public Overridable Sub removeReferencedGeneralPurposeScheduledProcedureStes
Visual C++
public:
virtual void removeReferencedGeneralPurposeScheduledProcedureStes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeReferencedRequests Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeReferencedRequests Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Request Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedRequests()
Visual Basic
Public Overridable Sub removeReferencedRequests
Visual C++
public:
virtual void removeReferencedRequests()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeRequestedSubsequentWorkitemCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeRequestedSubsequentWorkitemCodes Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedSubsequentWorkitemCodes()
Visual Basic
Public Overridable Sub removeRequestedSubsequentWorkitemCodes
Visual C++
public:
virtual void removeRequestedSubsequentWorkitemCodes()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeServiceEpisodeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeServiceEpisodeDescription Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeDescription()
Visual Basic
Public Overridable Sub removeServiceEpisodeDescription
Visual C++
public:
virtual void removeServiceEpisodeDescription()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeServiceEpisodeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeServiceEpisodeID Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeID()
Visual Basic
Public Overridable Sub removeServiceEpisodeID
Visual C++
public:
virtual void removeServiceEpisodeID()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..removeSpecificCharacterSets Method
MCgpPerformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepGet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet Properties
MCgpPerformedProcedureStepGet Class See Also Send Feedback

The MCgpPerformedProcedureStepGet type exposes the following members.

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcessingApplicationsCodes | Represents the values for the Performed Processing Applications Code Sequence attribute.
Public property | PerformedStationClassCodes | Represents the values for the Performed Station Class Code Sequence attribute.
Public property | PerformedStationGeographicLocationCodes | Represents the values for the Performed Station Geographic Location Code Sequenc attribute.
Public property | PerformedStationNameCodes | Represents the values for the Performed Station Name Code Sequence attribute.
Public property | PerformedWorkitemCodes | Represents the values for the Performed Workitem Code Sequence attribute.
Public property | ReferencedGeneralPurposeScheduledProcedureStes | Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.
Public property | ReferencedRequests | Represents the values for the Referenced Request Sequence attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.

See Also

MCgpPerformedProcedureStepGet Class
Mergecom.Gen Namespace


ActualHumanPerformers Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..ActualHumanPerformers Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Actual Human Performers Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCactualHumanPerformersItem[] ActualHumanPerformers { get; set; }
Visual Basic
Public Overridable Property ActualHumanPerformers As MCactualHumanPerformersItem()
    Get
    Set
Visual C++
public:
virtual property array<MCactualHumanPerformersItem^>^ ActualHumanPerformers {
    array<MCactualHumanPerformersItem^>^ get ();
    void set (array<MCactualHumanPerformersItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


AdmissionID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..AdmissionID Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Admission ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdmissionID { get; set; }
Visual Basic
Public Overridable Property AdmissionID As String
    Get
    Set
Visual C++
public:
virtual property String^ AdmissionID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..CommentsOnThePerformedProcedureSteps Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


GeneralPurposePerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..GeneralPurposePerformedProcedureStepStatus Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the General Purpose Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string GeneralPurposePerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property GeneralPurposePerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ GeneralPurposePerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..Host Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfAdmissionIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..IssuerOfAdmissionIDs Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Issuer of Admission ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAdmissionIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfAdmissionIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAdmissionIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfPatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..IssuerOfPatientID Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Issuer of Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IssuerOfPatientID { get; set; }
Visual Basic
Public Overridable Property IssuerOfPatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ IssuerOfPatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfServiceEpisodeIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..IssuerOfServiceEpisodeIDs Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Issuer of Service Episode ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfServiceEpisodeIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfServiceEpisodeIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfServiceEpisodeIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


NonDICOMOutputCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..NonDICOMOutputCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Non-DICOM Output Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] NonDICOMOutputCodes { get; set; }
Visual Basic
Public Overridable Property NonDICOMOutputCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ NonDICOMOutputCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


OutputInformation Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..OutputInformation Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Output Information Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCoutputInformationItem[] OutputInformation { get; set; }
Visual Basic
Public Overridable Property OutputInformation As MCoutputInformationItem()
    Get
    Set
Visual C++
public:
virtual property array<MCoutputInformationItem^>^ OutputInformation {
    array<MCoutputInformationItem^>^ get ();
    void set (array<MCoutputInformationItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PatientID Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsBirthDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PatientsBirthDate Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Birth Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PatientsBirthDate { get; set; }
Visual Basic
Public Overridable Property PatientsBirthDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PatientsBirthDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PatientsName Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsName { get; set; }
Visual Basic
Public Overridable Property PatientsName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsSex Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PatientsSex Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Sex attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSex { get; set; }
Visual Basic
Public Overridable Property PatientsSex As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSex {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepDescription Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepEndDate Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepEndTime Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepID Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepID { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepStartDate Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepStartDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcedureStepStartTime Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepStartTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcessingApplicationsCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedProcessingApplicationsCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Processing Applications Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedProcessingApplicationsCodes { get; set; }
Visual Basic
Public Overridable Property PerformedProcessingApplicationsCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedProcessingApplicationsCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedStationClassCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedStationClassCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Station Class Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationClassCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationClassCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationClassCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedStationGeographicLocationCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedStationGeographicLocationCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Station Geographic Location Code Sequenc attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationGeographicLocationCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationGeographicLocationCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationGeographicLocationCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedStationNameCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedStationNameCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Station Name Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedStationNameCodes { get; set; }
Visual Basic
Public Overridable Property PerformedStationNameCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedStationNameCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedWorkitemCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..PerformedWorkitemCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Workitem Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedWorkitemCodes { get; set; }
Visual Basic
Public Overridable Property PerformedWorkitemCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedWorkitemCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


ReferencedGeneralPurposeScheduledProcedureStes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..ReferencedGeneralPurposeScheduledProcedureStes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Referenced General Purpose Scheduled Procedure Ste attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedGeneralPurposeScheduledProcedureSteItem[] ReferencedGeneralPurposeScheduledProcedureStes { get; set; }
Visual Basic
Public Overridable Property ReferencedGeneralPurposeScheduledProcedureStes As MCreferencedGeneralPurposeScheduledProcedureSteItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ ReferencedGeneralPurposeScheduledProcedureStes {
    array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ get ();
    void set (array<MCreferencedGeneralPurposeScheduledProcedureSteItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


ReferencedRequests Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..ReferencedRequests Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Referenced Request Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedRequestItem[] ReferencedRequests { get; set; }
Visual Basic
Public Overridable Property ReferencedRequests As MCreferencedRequestItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedRequestItem^>^ ReferencedRequests {
    array<MCreferencedRequestItem^>^ get ();
    void set (array<MCreferencedRequestItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


RequestedSubsequentWorkitemCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..RequestedSubsequentWorkitemCodes Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Requested Subsequent Workitem Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedSubsequentWorkitemCodes { get; set; }
Visual Basic
Public Overridable Property RequestedSubsequentWorkitemCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedSubsequentWorkitemCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


ServiceEpisodeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..ServiceEpisodeDescription Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Service Episode Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeDescription { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


ServiceEpisodeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..ServiceEpisodeID Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Service Episode ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeID { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeID As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepGet..::..SpecificCharacterSets Property
MCgpPerformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepGet Class
MCgpPerformedProcedureStepGet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Class
Members See Also Send Feedback
This class serves as a container for attributes of the G_P_PERFORMED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCgpPerformedProcedureStepSet
Visual Basic
Public Class MCgpPerformedProcedureStepSet
Visual C++
public ref class MCgpPerformedProcedureStepSet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400254) Performed Procedure Step Description
  • (00400280) Comments on the Performed Procedure Steps
  • (00404002) General Purpose Performed Procedure Step Status
  • (00404031) Requested Subsequent Workitem Code Sequence
  • (00404032) Non-DICOM Output Code Sequence
  • (00404033) Output Information Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCgpPerformedProcedureStepSet

See Also

MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Members
MCgpPerformedProcedureStepSet Class Constructors Methods Properties See Also Send Feedback

The MCgpPerformedProcedureStepSet type exposes the following members.

Constructors

 | Name | Description
Public method | MCgpPerformedProcedureStepSet()()()() | Constructs an MCgpPerformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepSet(MCdataSet) | Constructs an MCgpPerformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.

See Also

MCgpPerformedProcedureStepSet Class
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Constructor
MCgpPerformedProcedureStepSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCgpPerformedProcedureStepSet()()()() | Constructs an MCgpPerformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpPerformedProcedureStepSet(MCdataSet) | Constructs an MCgpPerformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Constructor
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepSet()
Visual Basic
Public Sub New
Visual C++
public:
MCgpPerformedProcedureStepSet()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
MCgpPerformedProcedureStepSet Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Constructor (MCdataSet)
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Constructs an MCgpPerformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpPerformedProcedureStepSet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCgpPerformedProcedureStepSet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
MCgpPerformedProcedureStepSet Overload
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Methods
MCgpPerformedProcedureStepSet Class See Also Send Feedback

The MCgpPerformedProcedureStepSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeGeneralPurposePerformedProcedureStepStatus | This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.
Public method | removeNonDICOMOutputCodes | This method removes all the values that may have been set for Non-DICOM Output Code Sequence.
Public method | removeOutputInformation | This method removes all the values that may have been set for Output Information Sequence.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removeRequestedSubsequentWorkitemCodes | This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCgpPerformedProcedureStepSet Class
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removeCommentsOnThePerformedProcedureSteps Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removeGeneralPurposePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removeGeneralPurposePerformedProcedureStepStatus Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for General Purpose Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeGeneralPurposePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removeGeneralPurposePerformedProcedureStepStatus
Visual C++
public:
virtual void removeGeneralPurposePerformedProcedureStepStatus()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removeNonDICOMOutputCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removeNonDICOMOutputCodes Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Non-DICOM Output Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNonDICOMOutputCodes()
Visual Basic
Public Overridable Sub removeNonDICOMOutputCodes
Visual C++
public:
virtual void removeNonDICOMOutputCodes()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removeOutputInformation Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removeOutputInformation Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Output Information Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOutputInformation()
Visual Basic
Public Overridable Sub removeOutputInformation
Visual C++
public:
virtual void removeOutputInformation()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removePerformedProcedureStepDescription Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removePerformedProcedureStepEndDate Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removePerformedProcedureStepEndTime Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


removeRequestedSubsequentWorkitemCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..removeRequestedSubsequentWorkitemCodes Method
MCgpPerformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Subsequent Workitem Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedSubsequentWorkitemCodes()
Visual Basic
Public Overridable Sub removeRequestedSubsequentWorkitemCodes
Visual C++
public:
virtual void removeRequestedSubsequentWorkitemCodes()

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


MCgpPerformedProcedureStepSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet Properties
MCgpPerformedProcedureStepSet Class See Also Send Feedback

The MCgpPerformedProcedureStepSet type exposes the following members.

Properties

 | Name | Description
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | GeneralPurposePerformedProcedureStepStatus | Represents the value for the General Purpose Performed Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | NonDICOMOutputCodes | Represents the values for the Non-DICOM Output Code Sequence attribute.
Public property | OutputInformation | Represents the values for the Output Information Sequence attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | RequestedSubsequentWorkitemCodes | Represents the values for the Requested Subsequent Workitem Code Sequence attribute.

See Also

MCgpPerformedProcedureStepSet Class
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..CommentsOnThePerformedProcedureSteps Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


GeneralPurposePerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..GeneralPurposePerformedProcedureStepStatus Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the value for the General Purpose Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string GeneralPurposePerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property GeneralPurposePerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ GeneralPurposePerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..Host Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


NonDICOMOutputCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..NonDICOMOutputCodes Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Non-DICOM Output Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] NonDICOMOutputCodes { get; set; }
Visual Basic
Public Overridable Property NonDICOMOutputCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ NonDICOMOutputCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


OutputInformation Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..OutputInformation Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Output Information Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCoutputInformationItem[] OutputInformation { get; set; }
Visual Basic
Public Overridable Property OutputInformation As MCoutputInformationItem()
    Get
    Set
Visual C++
public:
virtual property array<MCoutputInformationItem^>^ OutputInformation {
    array<MCoutputInformationItem^>^ get ();
    void set (array<MCoutputInformationItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..PerformedProcedureStepDescription Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..PerformedProcedureStepEndDate Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..PerformedProcedureStepEndTime Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


RequestedSubsequentWorkitemCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpPerformedProcedureStepSet..::..RequestedSubsequentWorkitemCodes Property
MCgpPerformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Requested Subsequent Workitem Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedSubsequentWorkitemCodes { get; set; }
Visual Basic
Public Overridable Property RequestedSubsequentWorkitemCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedSubsequentWorkitemCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpPerformedProcedureStepSet Class
MCgpPerformedProcedureStepSet Members
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Class

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Class
Members See Also Send Feedback
This class serves as a container for attributes of the G_P_SCHEDULED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCgpScheduledProcedureStep
Visual Basic
Public Class MCgpScheduledProcedureStep
Visual C++
public ref class MCgpScheduledProcedureStep

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081195) Transaction UID
  • (00404001) General Purpose Scheduled Procedure Step Status
  • (00404035) Actual Human Performers Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCgpScheduledProcedureStep

See Also

MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Members
MCgpScheduledProcedureStep Class Constructors Methods Properties See Also Send Feedback

The MCgpScheduledProcedureStep type exposes the following members.

Constructors

 | Name | Description
Public method | MCgpScheduledProcedureStep()()()() | Constructs an MCgpScheduledProcedureStep collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpScheduledProcedureStep(MCdataSet) | Constructs an MCgpScheduledProcedureStep collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeGeneralPurposeScheduledProcedureStepStatus | This method removes all the values that may have been set for General Purpose Scheduled Procedure Step Status.
Public method | removeTransactionUID | This method removes all the values that may have been set for Transaction UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | GeneralPurposeScheduledProcedureStepStatus | Represents the value for the General Purpose Scheduled Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | TransactionUID | Represents the value for the Transaction UID attribute.

See Also

MCgpScheduledProcedureStep Class
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Constructor
MCgpScheduledProcedureStep Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCgpScheduledProcedureStep()()()() | Constructs an MCgpScheduledProcedureStep collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCgpScheduledProcedureStep(MCdataSet) | Constructs an MCgpScheduledProcedureStep collection by wrapping an existing MCdataSet instance.

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Constructor
MCgpScheduledProcedureStep Class See Also Send Feedback
Constructs an MCgpScheduledProcedureStep collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpScheduledProcedureStep()
Visual Basic
Public Sub New
Visual C++
public:
MCgpScheduledProcedureStep()

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
MCgpScheduledProcedureStep Overload
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Constructor (MCdataSet)
MCgpScheduledProcedureStep Class See Also Send Feedback
Constructs an MCgpScheduledProcedureStep collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCgpScheduledProcedureStep(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCgpScheduledProcedureStep(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
MCgpScheduledProcedureStep Overload
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Methods
MCgpScheduledProcedureStep Class See Also Send Feedback

The MCgpScheduledProcedureStep type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeActualHumanPerformers | This method removes all the values that may have been set for Actual Human Performers Sequence.
Public method | removeGeneralPurposeScheduledProcedureStepStatus | This method removes all the values that may have been set for General Purpose Scheduled Procedure Step Status.
Public method | removeTransactionUID | This method removes all the values that may have been set for Transaction UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCgpScheduledProcedureStep Class
Mergecom.Gen Namespace


removeActualHumanPerformers Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..removeActualHumanPerformers Method
MCgpScheduledProcedureStep Class See Also Send Feedback
This method removes all the values that may have been set for Actual Human Performers Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeActualHumanPerformers()
Visual Basic
Public Overridable Sub removeActualHumanPerformers
Visual C++
public:
virtual void removeActualHumanPerformers()

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


removeGeneralPurposeScheduledProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..removeGeneralPurposeScheduledProcedureStepStatus Method
MCgpScheduledProcedureStep Class See Also Send Feedback
This method removes all the values that may have been set for General Purpose Scheduled Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeGeneralPurposeScheduledProcedureStepStatus()
Visual Basic
Public Overridable Sub removeGeneralPurposeScheduledProcedureStepStatus
Visual C++
public:
virtual void removeGeneralPurposeScheduledProcedureStepStatus()

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


removeTransactionUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..removeTransactionUID Method
MCgpScheduledProcedureStep Class See Also Send Feedback
This method removes all the values that may have been set for Transaction UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTransactionUID()
Visual Basic
Public Overridable Sub removeTransactionUID
Visual C++
public:
virtual void removeTransactionUID()

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


MCgpScheduledProcedureStep Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep Properties
MCgpScheduledProcedureStep Class See Also Send Feedback

The MCgpScheduledProcedureStep type exposes the following members.

Properties

 | Name | Description
Public property | ActualHumanPerformers | Represents the values for the Actual Human Performers Sequence attribute.
Public property | GeneralPurposeScheduledProcedureStepStatus | Represents the value for the General Purpose Scheduled Procedure Step Status attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | TransactionUID | Represents the value for the Transaction UID attribute.

See Also

MCgpScheduledProcedureStep Class
Mergecom.Gen Namespace


ActualHumanPerformers Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..ActualHumanPerformers Property
MCgpScheduledProcedureStep Class See Also Send Feedback
Represents the values for the Actual Human Performers Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCactualHumanPerformersItem[] ActualHumanPerformers { get; set; }
Visual Basic
Public Overridable Property ActualHumanPerformers As MCactualHumanPerformersItem()
    Get
    Set
Visual C++
public:
virtual property array<MCactualHumanPerformersItem^>^ ActualHumanPerformers {
    array<MCactualHumanPerformersItem^>^ get ();
    void set (array<MCactualHumanPerformersItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


GeneralPurposeScheduledProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..GeneralPurposeScheduledProcedureStepStatus Property
MCgpScheduledProcedureStep Class See Also Send Feedback
Represents the value for the General Purpose Scheduled Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string GeneralPurposeScheduledProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property GeneralPurposeScheduledProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ GeneralPurposeScheduledProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..Host Property
MCgpScheduledProcedureStep Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


TransactionUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCgpScheduledProcedureStep..::..TransactionUID Property
MCgpScheduledProcedureStep Class See Also Send Feedback
Represents the value for the Transaction UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string TransactionUID { get; set; }
Visual Basic
Public Overridable Property TransactionUID As String
    Get
    Set
Visual C++
public:
virtual property String^ TransactionUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCgpScheduledProcedureStep Class
MCgpScheduledProcedureStep Members
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Class

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the HIERARCHICAL_SOP_INST_REF_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MChierarchicalSOPInstRefItem
Visual Basic
Public Class MChierarchicalSOPInstRefItem
Visual C++
public ref class MChierarchicalSOPInstRefItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081115) Referenced Series Sequence
  • (0020000D) Study Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MChierarchicalSOPInstRefItem

See Also

MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Members
MChierarchicalSOPInstRefItem Class Constructors Methods Properties See Also Send Feedback

The MChierarchicalSOPInstRefItem type exposes the following members.

Constructors

 | Name | Description
Public method | MChierarchicalSOPInstRefItem()()()() | Constructs an MChierarchicalSOPInstRefItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChierarchicalSOPInstRefItem(MCitem) | Constructs an MChierarchicalSOPInstRefItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MChierarchicalSOPInstRefItem Class
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Constructor
MChierarchicalSOPInstRefItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MChierarchicalSOPInstRefItem()()()() | Constructs an MChierarchicalSOPInstRefItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChierarchicalSOPInstRefItem(MCitem) | Constructs an MChierarchicalSOPInstRefItem collection by wrapping an existing MCitem instance.

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Constructor
MChierarchicalSOPInstRefItem Class See Also Send Feedback
Constructs an MChierarchicalSOPInstRefItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChierarchicalSOPInstRefItem()
Visual Basic
Public Sub New
Visual C++
public:
MChierarchicalSOPInstRefItem()

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
MChierarchicalSOPInstRefItem Overload
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Constructor (MCitem)
MChierarchicalSOPInstRefItem Class See Also Send Feedback
Constructs an MChierarchicalSOPInstRefItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChierarchicalSOPInstRefItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MChierarchicalSOPInstRefItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
MChierarchicalSOPInstRefItem Overload
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Methods
MChierarchicalSOPInstRefItem Class See Also Send Feedback

The MChierarchicalSOPInstRefItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MChierarchicalSOPInstRefItem Class
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem..::..removeReferencedSeries Method
MChierarchicalSOPInstRefItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem..::..removeStudyInstanceUID Method
MChierarchicalSOPInstRefItem Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


MChierarchicalSOPInstRefItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem Properties
MChierarchicalSOPInstRefItem Class See Also Send Feedback

The MChierarchicalSOPInstRefItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MChierarchicalSOPInstRefItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem..::..Host Property
MChierarchicalSOPInstRefItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem..::..ReferencedSeries Property
MChierarchicalSOPInstRefItem Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MChierarchicalSOPInstRefItem..::..StudyInstanceUID Property
MChierarchicalSOPInstRefItem Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChierarchicalSOPInstRefItem Class
MChierarchicalSOPInstRefItem Members
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Class

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the HL7_HIERARCHIC_DESIGNATOR_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MChL7HierarchicDesignatorItem
Visual Basic
Public Class MChL7HierarchicDesignatorItem
Visual C++
public ref class MChL7HierarchicDesignatorItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00400031) Local Namespace Entity ID
  • (00400032) Universal Entity ID
  • (00400033) Universal Entity ID Type

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MChL7HierarchicDesignatorItem

See Also

MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Members
MChL7HierarchicDesignatorItem Class Constructors Methods Properties See Also Send Feedback

The MChL7HierarchicDesignatorItem type exposes the following members.

Constructors

 | Name | Description
Public method | MChL7HierarchicDesignatorItem()()()() | Constructs an MChL7HierarchicDesignatorItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChL7HierarchicDesignatorItem(MCitem) | Constructs an MChL7HierarchicDesignatorItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeLocalNamespaceEntityID | This method removes all the values that may have been set for Local Namespace Entity ID.
Public method | removeUniversalEntityID | This method removes all the values that may have been set for Universal Entity ID.
Public method | removeUniversalEntityIDType | This method removes all the values that may have been set for Universal Entity ID Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | LocalNamespaceEntityID | Represents the value for the Local Namespace Entity ID attribute.
Public property | UniversalEntityID | Represents the value for the Universal Entity ID attribute.
Public property | UniversalEntityIDType | Represents the value for the Universal Entity ID Type attribute.

See Also

MChL7HierarchicDesignatorItem Class
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Constructor
MChL7HierarchicDesignatorItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MChL7HierarchicDesignatorItem()()()() | Constructs an MChL7HierarchicDesignatorItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChL7HierarchicDesignatorItem(MCitem) | Constructs an MChL7HierarchicDesignatorItem collection by wrapping an existing MCitem instance.

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Constructor
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Constructs an MChL7HierarchicDesignatorItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChL7HierarchicDesignatorItem()
Visual Basic
Public Sub New
Visual C++
public:
MChL7HierarchicDesignatorItem()

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
MChL7HierarchicDesignatorItem Overload
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Constructor (MCitem)
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Constructs an MChL7HierarchicDesignatorItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChL7HierarchicDesignatorItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MChL7HierarchicDesignatorItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
MChL7HierarchicDesignatorItem Overload
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Methods
MChL7HierarchicDesignatorItem Class See Also Send Feedback

The MChL7HierarchicDesignatorItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeLocalNamespaceEntityID | This method removes all the values that may have been set for Local Namespace Entity ID.
Public method | removeUniversalEntityID | This method removes all the values that may have been set for Universal Entity ID.
Public method | removeUniversalEntityIDType | This method removes all the values that may have been set for Universal Entity ID Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MChL7HierarchicDesignatorItem Class
Mergecom.Gen Namespace


removeLocalNamespaceEntityID Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..removeLocalNamespaceEntityID Method
MChL7HierarchicDesignatorItem Class See Also Send Feedback
This method removes all the values that may have been set for Local Namespace Entity ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeLocalNamespaceEntityID()
Visual Basic
Public Overridable Sub removeLocalNamespaceEntityID
Visual C++
public:
virtual void removeLocalNamespaceEntityID()

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


removeUniversalEntityID Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..removeUniversalEntityID Method
MChL7HierarchicDesignatorItem Class See Also Send Feedback
This method removes all the values that may have been set for Universal Entity ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeUniversalEntityID()
Visual Basic
Public Overridable Sub removeUniversalEntityID
Visual C++
public:
virtual void removeUniversalEntityID()

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


removeUniversalEntityIDType Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..removeUniversalEntityIDType Method
MChL7HierarchicDesignatorItem Class See Also Send Feedback
This method removes all the values that may have been set for Universal Entity ID Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeUniversalEntityIDType()
Visual Basic
Public Overridable Sub removeUniversalEntityIDType
Visual C++
public:
virtual void removeUniversalEntityIDType()

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


MChL7HierarchicDesignatorItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem Properties
MChL7HierarchicDesignatorItem Class See Also Send Feedback

The MChL7HierarchicDesignatorItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | LocalNamespaceEntityID | Represents the value for the Local Namespace Entity ID attribute.
Public property | UniversalEntityID | Represents the value for the Universal Entity ID attribute.
Public property | UniversalEntityIDType | Represents the value for the Universal Entity ID Type attribute.

See Also

MChL7HierarchicDesignatorItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..Host Property
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


LocalNamespaceEntityID Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..LocalNamespaceEntityID Property
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Represents the value for the Local Namespace Entity ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string LocalNamespaceEntityID { get; set; }
Visual Basic
Public Overridable Property LocalNamespaceEntityID As String
    Get
    Set
Visual C++
public:
virtual property String^ LocalNamespaceEntityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


UniversalEntityID Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..UniversalEntityID Property
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Represents the value for the Universal Entity ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string UniversalEntityID { get; set; }
Visual Basic
Public Overridable Property UniversalEntityID As String
    Get
    Set
Visual C++
public:
virtual property String^ UniversalEntityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


UniversalEntityIDType Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7HierarchicDesignatorItem..::..UniversalEntityIDType Property
MChL7HierarchicDesignatorItem Class See Also Send Feedback
Represents the value for the Universal Entity ID Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string UniversalEntityIDType { get; set; }
Visual Basic
Public Overridable Property UniversalEntityIDType As String
    Get
    Set
Visual C++
public:
virtual property String^ UniversalEntityIDType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7HierarchicDesignatorItem Class
MChL7HierarchicDesignatorItem Members
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Class

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the HL7_STRUCT_DOC_REF Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MChL7StructuredDocumentReferenceItem
Visual Basic
Public Class MChL7StructuredDocumentReferenceItem
Visual C++
public ref class MChL7StructuredDocumentReferenceItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (0040E001) HL7 Instance Identifier
  • (0040E010) Retrieve URI

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MChL7StructuredDocumentReferenceItem

See Also

MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Members
MChL7StructuredDocumentReferenceItem Class Constructors Methods Properties See Also Send Feedback

The MChL7StructuredDocumentReferenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | MChL7StructuredDocumentReferenceItem()()()() | Constructs an MChL7StructuredDocumentReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChL7StructuredDocumentReferenceItem(MCitem) | Constructs an MChL7StructuredDocumentReferenceItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHL7InstanceIdentifier | This method removes all the values that may have been set for HL7 Instance Identifier.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | removeRetrieveURI | This method removes all the values that may have been set for Retrieve URI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HL7InstanceIdentifier | Represents the value for the HL7 Instance Identifier attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.
Public property | RetrieveURI | Represents the value for the Retrieve URI attribute.

See Also

MChL7StructuredDocumentReferenceItem Class
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Constructor
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MChL7StructuredDocumentReferenceItem()()()() | Constructs an MChL7StructuredDocumentReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MChL7StructuredDocumentReferenceItem(MCitem) | Constructs an MChL7StructuredDocumentReferenceItem collection by wrapping an existing MCitem instance.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Constructor
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Constructs an MChL7StructuredDocumentReferenceItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChL7StructuredDocumentReferenceItem()
Visual Basic
Public Sub New
Visual C++
public:
MChL7StructuredDocumentReferenceItem()

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
MChL7StructuredDocumentReferenceItem Overload
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Constructor (MCitem)
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Constructs an MChL7StructuredDocumentReferenceItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MChL7StructuredDocumentReferenceItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MChL7StructuredDocumentReferenceItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
MChL7StructuredDocumentReferenceItem Overload
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Methods
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback

The MChL7StructuredDocumentReferenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHL7InstanceIdentifier | This method removes all the values that may have been set for HL7 Instance Identifier.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | removeRetrieveURI | This method removes all the values that may have been set for Retrieve URI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MChL7StructuredDocumentReferenceItem Class
Mergecom.Gen Namespace


removeHL7InstanceIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..removeHL7InstanceIdentifier Method
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for HL7 Instance Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHL7InstanceIdentifier()
Visual Basic
Public Overridable Sub removeHL7InstanceIdentifier
Visual C++
public:
virtual void removeHL7InstanceIdentifier()

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..removeReferencedSOPClassUID Method
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..removeReferencedSOPInstanceUID Method
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


removeRetrieveURI Method

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..removeRetrieveURI Method
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Retrieve URI.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRetrieveURI()
Visual Basic
Public Overridable Sub removeRetrieveURI
Visual C++
public:
virtual void removeRetrieveURI()

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


MChL7StructuredDocumentReferenceItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem Properties
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback

The MChL7StructuredDocumentReferenceItem type exposes the following members.

Properties

 | Name | Description
Public property | HL7InstanceIdentifier | Represents the value for the HL7 Instance Identifier attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.
Public property | RetrieveURI | Represents the value for the Retrieve URI attribute.

See Also

MChL7StructuredDocumentReferenceItem Class
Mergecom.Gen Namespace


HL7InstanceIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..HL7InstanceIdentifier Property
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Represents the value for the HL7 Instance Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string HL7InstanceIdentifier { get; set; }
Visual Basic
Public Overridable Property HL7InstanceIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ HL7InstanceIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..Host Property
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..ReferencedSOPClassUID Property
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..ReferencedSOPInstanceUID Property
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


RetrieveURI Property

[image]

Merge DICOM .NET/C# Toolkit
MChL7StructuredDocumentReferenceItem..::..RetrieveURI Property
MChL7StructuredDocumentReferenceItem Class See Also Send Feedback
Represents the value for the Retrieve URI attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RetrieveURI { get; set; }
Visual Basic
Public Overridable Property RetrieveURI As String
    Get
    Set
Visual C++
public:
virtual property String^ RetrieveURI {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MChL7StructuredDocumentReferenceItem Class
MChL7StructuredDocumentReferenceItem Members
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the IMAGE_SOP_INSTANCE_REF_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCimageSopInstanceReferenceItem
Visual Basic
Public Class MCimageSopInstanceReferenceItem
Visual C++
public ref class MCimageSopInstanceReferenceItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (00081160) Referenced Frame Number
  • (0062000B) Referenced Segment Number

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCimageSopInstanceReferenceItem

See Also

MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Members
MCimageSopInstanceReferenceItem Class Constructors Methods Properties See Also Send Feedback

The MCimageSopInstanceReferenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCimageSopInstanceReferenceItem()()()() | Constructs an MCimageSopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCimageSopInstanceReferenceItem(MCitem) | Constructs an MCimageSopInstanceReferenceItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedFrameNumbers | This method removes all the values that may have been set for Referenced Frame Number.
Public method | removeReferencedSegmentNumbers | This method removes all the values that may have been set for Referenced Segment Number.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedFrameNumbers | Represents the values for the Referenced Frame Number attribute.
Public property | ReferencedSegmentNumbers | Represents the values for the Referenced Segment Number attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCimageSopInstanceReferenceItem Class
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Constructor
MCimageSopInstanceReferenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCimageSopInstanceReferenceItem()()()() | Constructs an MCimageSopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCimageSopInstanceReferenceItem(MCitem) | Constructs an MCimageSopInstanceReferenceItem collection by wrapping an existing MCitem instance.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Constructor
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Constructs an MCimageSopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCimageSopInstanceReferenceItem()
Visual Basic
Public Sub New
Visual C++
public:
MCimageSopInstanceReferenceItem()

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
MCimageSopInstanceReferenceItem Overload
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Constructor (MCitem)
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Constructs an MCimageSopInstanceReferenceItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCimageSopInstanceReferenceItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCimageSopInstanceReferenceItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
MCimageSopInstanceReferenceItem Overload
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Methods
MCimageSopInstanceReferenceItem Class See Also Send Feedback

The MCimageSopInstanceReferenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedFrameNumbers | This method removes all the values that may have been set for Referenced Frame Number.
Public method | removeReferencedSegmentNumbers | This method removes all the values that may have been set for Referenced Segment Number.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCimageSopInstanceReferenceItem Class
Mergecom.Gen Namespace


removeReferencedFrameNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..removeReferencedFrameNumbers Method
MCimageSopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Frame Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedFrameNumbers()
Visual Basic
Public Overridable Sub removeReferencedFrameNumbers
Visual C++
public:
virtual void removeReferencedFrameNumbers()

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSegmentNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..removeReferencedSegmentNumbers Method
MCimageSopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Segment Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSegmentNumbers()
Visual Basic
Public Overridable Sub removeReferencedSegmentNumbers
Visual C++
public:
virtual void removeReferencedSegmentNumbers()

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..removeReferencedSOPClassUID Method
MCimageSopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..removeReferencedSOPInstanceUID Method
MCimageSopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCimageSopInstanceReferenceItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem Properties
MCimageSopInstanceReferenceItem Class See Also Send Feedback

The MCimageSopInstanceReferenceItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedFrameNumbers | Represents the values for the Referenced Frame Number attribute.
Public property | ReferencedSegmentNumbers | Represents the values for the Referenced Segment Number attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCimageSopInstanceReferenceItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..Host Property
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedFrameNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..ReferencedFrameNumbers Property
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Represents the values for the Referenced Frame Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ReferencedFrameNumbers { get; set; }
Visual Basic
Public Overridable Property ReferencedFrameNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ReferencedFrameNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedSegmentNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..ReferencedSegmentNumbers Property
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Represents the values for the Referenced Segment Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort[] ReferencedSegmentNumbers { get; set; }
Visual Basic
Public Overridable Property ReferencedSegmentNumbers As UShort()
    Get
    Set
Visual C++
public:
virtual property array<unsigned short>^ ReferencedSegmentNumbers {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..ReferencedSOPClassUID Property
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageSopInstanceReferenceItem..::..ReferencedSOPInstanceUID Property
MCimageSopInstanceReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCimageSopInstanceReferenceItem Class
MCimageSopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCmACParametersItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the MAC_PARAMETERS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCmACParametersItem
Visual Basic
Public Class MCmACParametersItem
Visual C++
public ref class MCmACParametersItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (04000005) MAC ID Number
  • (04000010) MAC Calculation Transfer Syntax UID
  • (04000015) MAC Algorithm
  • (04000020) Data Elements Signed

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCmACParametersItem

See Also

MCmACParametersItem Members
Mergecom.Gen Namespace


MCmACParametersItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Members
MCmACParametersItem Class Constructors Methods Properties See Also Send Feedback

The MCmACParametersItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCmACParametersItem()()()() | Constructs an MCmACParametersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCmACParametersItem(MCitem) | Constructs an MCmACParametersItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDataElementsSigneds | This method removes all the values that may have been set for Data Elements Signed.
Public method | removeMACAlgorithm | This method removes all the values that may have been set for MAC Algorithm.
Public method | removeMACCalculationTransferSyntaxUID | This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.
Public method | removeMACIDNumber | This method removes all the values that may have been set for MAC ID Number.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataElementsSigneds | Represents the values for the Data Elements Signed attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACAlgorithm | Represents the value for the MAC Algorithm attribute.
Public property | MACCalculationTransferSyntaxUID | Represents the value for the MAC Calculation Transfer Syntax UID attribute.
Public property | MACIDNumber | Represents the value for the MAC ID Number attribute.

See Also

MCmACParametersItem Class
Mergecom.Gen Namespace


MCmACParametersItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Constructor
MCmACParametersItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCmACParametersItem()()()() | Constructs an MCmACParametersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCmACParametersItem(MCitem) | Constructs an MCmACParametersItem collection by wrapping an existing MCitem instance.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MCmACParametersItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Constructor
MCmACParametersItem Class See Also Send Feedback
Constructs an MCmACParametersItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmACParametersItem()
Visual Basic
Public Sub New
Visual C++
public:
MCmACParametersItem()

See Also

MCmACParametersItem Class
MCmACParametersItem Members
MCmACParametersItem Overload
Mergecom.Gen Namespace


MCmACParametersItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Constructor (MCitem)
MCmACParametersItem Class See Also Send Feedback
Constructs an MCmACParametersItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmACParametersItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCmACParametersItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
MCmACParametersItem Overload
Mergecom.Gen Namespace


MCmACParametersItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Methods
MCmACParametersItem Class See Also Send Feedback

The MCmACParametersItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDataElementsSigneds | This method removes all the values that may have been set for Data Elements Signed.
Public method | removeMACAlgorithm | This method removes all the values that may have been set for MAC Algorithm.
Public method | removeMACCalculationTransferSyntaxUID | This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.
Public method | removeMACIDNumber | This method removes all the values that may have been set for MAC ID Number.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCmACParametersItem Class
Mergecom.Gen Namespace


removeDataElementsSigneds Method

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..removeDataElementsSigneds Method
MCmACParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Data Elements Signed.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDataElementsSigneds()
Visual Basic
Public Overridable Sub removeDataElementsSigneds
Visual C++
public:
virtual void removeDataElementsSigneds()

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


removeMACAlgorithm Method

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..removeMACAlgorithm Method
MCmACParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC Algorithm.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACAlgorithm()
Visual Basic
Public Overridable Sub removeMACAlgorithm
Visual C++
public:
virtual void removeMACAlgorithm()

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


removeMACCalculationTransferSyntaxUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..removeMACCalculationTransferSyntaxUID Method
MCmACParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACCalculationTransferSyntaxUID()
Visual Basic
Public Overridable Sub removeMACCalculationTransferSyntaxUID
Visual C++
public:
virtual void removeMACCalculationTransferSyntaxUID()

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


removeMACIDNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..removeMACIDNumber Method
MCmACParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC ID Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACIDNumber()
Visual Basic
Public Overridable Sub removeMACIDNumber
Visual C++
public:
virtual void removeMACIDNumber()

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MCmACParametersItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem Properties
MCmACParametersItem Class See Also Send Feedback

The MCmACParametersItem type exposes the following members.

Properties

 | Name | Description
Public property | DataElementsSigneds | Represents the values for the Data Elements Signed attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACAlgorithm | Represents the value for the MAC Algorithm attribute.
Public property | MACCalculationTransferSyntaxUID | Represents the value for the MAC Calculation Transfer Syntax UID attribute.
Public property | MACIDNumber | Represents the value for the MAC ID Number attribute.

See Also

MCmACParametersItem Class
Mergecom.Gen Namespace


DataElementsSigneds Property

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..DataElementsSigneds Property
MCmACParametersItem Class See Also Send Feedback
Represents the values for the Data Elements Signed attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint[] DataElementsSigneds { get; set; }
Visual Basic
Public Overridable Property DataElementsSigneds As UInteger()
    Get
    Set
Visual C++
public:
virtual property array<unsigned int>^ DataElementsSigneds {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..Host Property
MCmACParametersItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MACAlgorithm Property

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..MACAlgorithm Property
MCmACParametersItem Class See Also Send Feedback
Represents the value for the MAC Algorithm attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MACAlgorithm { get; set; }
Visual Basic
Public Overridable Property MACAlgorithm As String
    Get
    Set
Visual C++
public:
virtual property String^ MACAlgorithm {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MACCalculationTransferSyntaxUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..MACCalculationTransferSyntaxUID Property
MCmACParametersItem Class See Also Send Feedback
Represents the value for the MAC Calculation Transfer Syntax UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MACCalculationTransferSyntaxUID { get; set; }
Visual Basic
Public Overridable Property MACCalculationTransferSyntaxUID As String
    Get
    Set
Visual C++
public:
virtual property String^ MACCalculationTransferSyntaxUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MACIDNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCmACParametersItem..::..MACIDNumber Property
MCmACParametersItem Class See Also Send Feedback
Represents the value for the MAC ID Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort MACIDNumber { get; set; }
Visual Basic
Public Overridable Property MACIDNumber As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short MACIDNumber {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmACParametersItem Class
MCmACParametersItem Members
Mergecom.Gen Namespace


MCmeasuringUnitsItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the MEASURING_UNITS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCmeasuringUnitsItem
Visual Basic
Public Class MCmeasuringUnitsItem
Visual C++
public ref class MCmeasuringUnitsItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00080117) Context UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCmeasuringUnitsItem

See Also

MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


MCmeasuringUnitsItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Members
MCmeasuringUnitsItem Class Constructors Methods Properties See Also Send Feedback

The MCmeasuringUnitsItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCmeasuringUnitsItem()()()() | Constructs an MCmeasuringUnitsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCmeasuringUnitsItem(MCitem) | Constructs an MCmeasuringUnitsItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCmeasuringUnitsItem Class
Mergecom.Gen Namespace


MCmeasuringUnitsItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Constructor
MCmeasuringUnitsItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCmeasuringUnitsItem()()()() | Constructs an MCmeasuringUnitsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCmeasuringUnitsItem(MCitem) | Constructs an MCmeasuringUnitsItem collection by wrapping an existing MCitem instance.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


MCmeasuringUnitsItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Constructor
MCmeasuringUnitsItem Class See Also Send Feedback
Constructs an MCmeasuringUnitsItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmeasuringUnitsItem()
Visual Basic
Public Sub New
Visual C++
public:
MCmeasuringUnitsItem()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
MCmeasuringUnitsItem Overload
Mergecom.Gen Namespace


MCmeasuringUnitsItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Constructor (MCitem)
MCmeasuringUnitsItem Class See Also Send Feedback
Constructs an MCmeasuringUnitsItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmeasuringUnitsItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCmeasuringUnitsItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
MCmeasuringUnitsItem Overload
Mergecom.Gen Namespace


MCmeasuringUnitsItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Methods
MCmeasuringUnitsItem Class See Also Send Feedback

The MCmeasuringUnitsItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeContextUID | This method removes all the values that may have been set for Context UID.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCmeasuringUnitsItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeCodeMeaning Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeCodeValue Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeCodingSchemeDesignator Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeCodingSchemeVersion Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextGroupExtensionCreatorUID Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextGroupExtensionFlag Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextGroupLocalVersion Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextGroupVersion Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextIdentifier Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeContextUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeContextUID Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Context UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextUID()
Visual Basic
Public Overridable Sub removeContextUID
Visual C++
public:
virtual void removeContextUID()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..removeMappingResource Method
MCmeasuringUnitsItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


MCmeasuringUnitsItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem Properties
MCmeasuringUnitsItem Class See Also Send Feedback

The MCmeasuringUnitsItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | ContextUID | Represents the value for the Context UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.

See Also

MCmeasuringUnitsItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..CodeMeaning Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..CodeValue Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..CodingSchemeDesignator Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..CodingSchemeVersion Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextGroupExtensionCreatorUID Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextGroupExtensionFlag Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextGroupLocalVersion Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextGroupVersion Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextIdentifier Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


ContextUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..ContextUID Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Context UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextUID { get; set; }
Visual Basic
Public Overridable Property ContextUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..Host Property
MCmeasuringUnitsItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCmeasuringUnitsItem..::..MappingResource Property
MCmeasuringUnitsItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmeasuringUnitsItem Class
MCmeasuringUnitsItem Members
Mergecom.Gen Namespace


MCmodalityWorklistFind Class

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Class
Members See Also Send Feedback
This class serves as a container for attributes of the MODALITY_WORKLIST_FIND IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCmodalityWorklistFind
Visual Basic
Public Class MCmodalityWorklistFind
Visual C++
public ref class MCmodalityWorklistFind

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080020) Study Date
  • (00080030) Study Time
  • (00080050) Accession Number
  • (00080051) Issuer of Accession Number Sequence
  • (00080080) Institution Name
  • (00080081) Institution Address
  • (00080082) Institution Code Sequence
  • (00080090) Referring Physician's Name
  • (00080092) Referring Physician's Address
  • (00080094) Referring Physician's Telephone Numbers
  • (00080096) Referring Physician Identification Sequence
  • (00081080) Admitting Diagnosis Description
  • (00081084) Admitting Diagnosis Code Sequence
  • (00081110) Referenced Study Sequence
  • (00081120) Referenced Patient Sequence
  • (00081125) Referenced Visit Sequence
  • (00100010) Patient's Name
  • (00100020) Patient ID
  • (00100021) Issuer of Patient ID
  • (00100024) Issuer of Patient ID Qualifiers Sequence
  • (00100030) Patient's Birth Date
  • (00100032) Patient's Birth Time
  • (00100040) Patient's Sex
  • (00100050) Patient's Insurance Plan Code Sequence
  • (00100101) Patient's Primary Language Code Sequence
  • (00100102) Patient's Primary Language Modifier Code Sequence
  • (00101000) Other Patient IDs
  • (00101001) Other Patient Names
  • (00101002) Other Patient IDs Sequence
  • (00101005) Patient's Birth Name
  • (00101020) Patient's Size
  • (00101021) Patient's Size Code Sequence
  • (00101030) Patient's Weight
  • (00101040) Patient's Address
  • (00101060) Patient's Mother's Birth Name
  • (00101080) Military Rank
  • (00101081) Branch of Service
  • (00101090) Medical Record Locator
  • (00102000) Medical Alerts
  • (00102110) Allergies
  • (00102150) Country of Residence
  • (00102152) Region of Residence
  • (00102154) Patient's Telephone Numbers
  • (00102160) Ethnic Group
  • (001021A0) Smoking Status
  • (001021B0) Additional Patient History
  • (001021C0) Pregnancy Status
  • (001021D0) Last Menstrual Date
  • (001021F0) Patient's Religious Preference
  • (00102201) Patient Species Description
  • (00102202) Patient Species Code Sequence
  • (00102203) Patient's Sex Neutered
  • (00102292) Patient Breed Description
  • (00102293) Patient Breed Code Sequence
  • (00102294) Breed Registration Sequence
  • (00102297) Responsible Person
  • (00102298) Responsible Person Role
  • (00102299) Responsible Organization
  • (00104000) Patient Comments
  • (0020000D) Study Instance UID
  • (00321031) Requesting Physician Identification Sequence
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321034) Requesting Service Code Sequence
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00380004) Referenced Patient Alias Sequence
  • (00380008) Visit Status ID
  • (00380010) Admission ID
  • (00380014) Issuer of Admission ID Sequence
  • (00380016) Route of Admissions
  • (00380020) Admitting Date
  • (00380021) Admitting Time
  • (00380050) Special Needs
  • (00380060) Service Episode ID
  • (00380062) Service Episode Description
  • (00380064) Issuer of Service Episode ID Sequence
  • (00380100) Pertinent Documents Sequence
  • (00380300) Current Patient Location
  • (00380400) Patient's Institution Residence
  • (00380500) Patient State
  • (00380502) Patient Clinical Trial Participation Sequence
  • (00384000) Visit Comments
  • (00400026) Order Placer Identifier Sequence
  • (00400027) Order Filler Identifier Sequence
  • (00400100) Scheduled Procedure Step Sequence
  • (00400500) Scheduled Specimen Sequence
  • (00401001) Requested Procedure ID
  • (00401002) Reason for the Requested Procedure
  • (00401003) Requested Procedure Priority
  • (00401004) Patient Transport Arrangements
  • (00401005) Requested Procedure Location
  • (00401006) Placer Order Number / Procedure RETIRED
  • (00401007) Filler Order Number Procedure RETIRED
  • (00401008) Confidentiality Code
  • (00401009) Reporting Priority
  • (0040100A) Reason for Requested Procedure Code Sequence
  • (00401010) Names of Intended Recipients of Results
  • (00401011) Intended Recp of Results Identification Sequence
  • (00401400) Requested Procedure Comments
  • (00402004) Issue Date of Imaging Service Request
  • (00402005) Issue Time of Imaging Service Request
  • (00402008) Order Entered By
  • (00402009) Order Enterer's Location
  • (00402010) Order Callback Phone Number
  • (00402016) Placer Order Number / Imaging Service Request
  • (00402017) Filler Order Number / Imaging Service Request
  • (00402400) Imaging Service Request Comments
  • (0040A390) HL7 Structured Document Reference Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCmodalityWorklistFind

See Also

MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MCmodalityWorklistFind Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Members
MCmodalityWorklistFind Class Constructors Methods Properties See Also Send Feedback

The MCmodalityWorklistFind type exposes the following members.

Constructors

 | Name | Description
Public method | MCmodalityWorklistFind()()()() | Constructs an MCmodalityWorklistFind collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCmodalityWorklistFind(MCdataSet) | Constructs an MCmodalityWorklistFind collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAdditionalPatientHistory | This method removes all the values that may have been set for Additional Patient History.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAdmittingDate | This method removes all the values that may have been set for Admitting Date.
Public method | removeAdmittingDiagnosisCodes | This method removes all the values that may have been set for Admitting Diagnosis Code Sequence.
Public method | removeAdmittingDiagnosisDescriptions | This method removes all the values that may have been set for Admitting Diagnosis Description.
Public method | removeAdmittingTime | This method removes all the values that may have been set for Admitting Time.
Public method | removeAllergies | This method removes all the values that may have been set for Allergies.
Public method | removeBranchOfService | This method removes all the values that may have been set for Branch of Service.
Public method | removeBreedRegistrations | This method removes all the values that may have been set for Breed Registration Sequence.
Public method | removeConfidentialityCode | This method removes all the values that may have been set for Confidentiality Code.
Public method | removeCountryOfResidence | This method removes all the values that may have been set for Country of Residence.
Public method | removeCurrentPatientLocation | This method removes all the values that may have been set for Current Patient Location.
Public method | removeEthnicGroup | This method removes all the values that may have been set for Ethnic Group.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeFillerOrderNumberProcedureRETIRED | This method removes all the values that may have been set for Filler Order Number Procedure RETIRED.
Public method | removeHL7StructuredDocumentReferences | This method removes all the values that may have been set for HL7 Structured Document Reference Sequence.
Public method | removeImagingServiceRequestComments | This method removes all the values that may have been set for Imaging Service Request Comments.
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionCodes | This method removes all the values that may have been set for Institution Code Sequence.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removeIntendedRecpOfResultsIdentifications | This method removes all the values that may have been set for Intended Recp of Results Identification Sequence.
Public method | removeIssueDateOfImagingServiceRequest | This method removes all the values that may have been set for Issue Date of Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeIssueTimeOfImagingServiceRequest | This method removes all the values that may have been set for Issue Time of Imaging Service Request.
Public method | removeLastMenstrualDate | This method removes all the values that may have been set for Last Menstrual Date.
Public method | removeMedicalAlerts | This method removes all the values that may have been set for Medical Alerts.
Public method | removeMedicalRecordLocator | This method removes all the values that may have been set for Medical Record Locator.
Public method | removeMilitaryRank | This method removes all the values that may have been set for Military Rank.
Public method | removeNamesOfIntendedRecipientsOfResults | This method removes all the values that may have been set for Names of Intended Recipients of Results.
Public method | removeOrderCallbackPhoneNumber | This method removes all the values that may have been set for Order Callback Phone Number.
Public method | removeOrderEnteredBy | This method removes all the values that may have been set for Order Entered By.
Public method | removeOrderEnterersLocation | This method removes all the values that may have been set for Order Enterer's Location.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removeOtherPatientIDs | This method removes all the values that may have been set for Other Patient IDs.
Public method | removeOtherPatientNames | This method removes all the values that may have been set for Other Patient Names.
Public method | removePatientBreedCodes | This method removes all the values that may have been set for Patient Breed Code Sequence.
Public method | removePatientBreedDescription | This method removes all the values that may have been set for Patient Breed Description.
Public method | removePatientClinicalTrialParticipations | This method removes all the values that may have been set for Patient Clinical Trial Participation Sequence.
Public method | removePatientComments | This method removes all the values that may have been set for Patient Comments.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsAddress | This method removes all the values that may have been set for Patient's Address.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsBirthName | This method removes all the values that may have been set for Patient's Birth Name.
Public method | removePatientsBirthTime | This method removes all the values that may have been set for Patient's Birth Time.
Public method | removePatientsInstitutionResidence | This method removes all the values that may have been set for Patient's Institution Residence.
Public method | removePatientsInsurancePlanCodes | This method removes all the values that may have been set for Patient's Insurance Plan Code Sequence.
Public method | removePatientsMothersBirthName | This method removes all the values that may have been set for Patient's Mother's Birth Name.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientSpeciesCodes | This method removes all the values that may have been set for Patient Species Code Sequence.
Public method | removePatientSpeciesDescription | This method removes all the values that may have been set for Patient Species Description.
Public method | removePatientsPrimaryLanguageCodes | This method removes all the values that may have been set for Patient's Primary Language Code Sequence.
Public method | removePatientsPrimaryLanguageModifierCodes | This method removes all the values that may have been set for Patient's Primary Language Modifier Code Sequence.
Public method | removePatientsReligiousPreference | This method removes all the values that may have been set for Patient's Religious Preference.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePatientsSexNeutered | This method removes all the values that may have been set for Patient's Sex Neutered.
Public method | removePatientsSize | This method removes all the values that may have been set for Patient's Size.
Public method | removePatientsSizeCodes | This method removes all the values that may have been set for Patient's Size Code Sequence.
Public method | removePatientState | This method removes all the values that may have been set for Patient State.
Public method | removePatientsTelephoneNumbers | This method removes all the values that may have been set for Patient's Telephone Numbers.
Public method | removePatientsWeight | This method removes all the values that may have been set for Patient's Weight.
Public method | removePatientTransportArrangements | This method removes all the values that may have been set for Patient Transport Arrangements.
Public method | removePertinentDocuments | This method removes all the values that may have been set for Pertinent Documents Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removePlacerOrderNumberProcedureRETIRED | This method removes all the values that may have been set for Placer Order Number / Procedure RETIRED.
Public method | removePregnancyStatus | This method removes all the values that may have been set for Pregnancy Status.
Public method | removeReasonForRequestedProcedureCodes | This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.
Public method | removeReasonForTheRequestedProcedure | This method removes all the values that may have been set for Reason for the Requested Procedure.
Public method | removeReferencedPatientAlias | This method removes all the values that may have been set for Referenced Patient Alias Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeReferringPhysicianIdentifications | This method removes all the values that may have been set for Referring Physician Identification Sequence.
Public method | removeReferringPhysiciansAddress | This method removes all the values that may have been set for Referring Physician's Address.
Public method | removeReferringPhysiciansName | This method removes all the values that may have been set for Referring Physician's Name.
Public method | removeReferringPhysiciansTelephoneNumbers | This method removes all the values that may have been set for Referring Physician's Telephone Numbers.
Public method | removeRegionOfResidence | This method removes all the values that may have been set for Region of Residence.
Public method | removeReportingPriority | This method removes all the values that may have been set for Reporting Priority.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureComments | This method removes all the values that may have been set for Requested Procedure Comments.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeRequestedProcedureLocation | This method removes all the values that may have been set for Requested Procedure Location.
Public method | removeRequestedProcedurePriority | This method removes all the values that may have been set for Requested Procedure Priority.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingPhysicianIdentifications | This method removes all the values that may have been set for Requesting Physician Identification Sequence.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeRequestingServiceCodes | This method removes all the values that may have been set for Requesting Service Code Sequence.
Public method | removeResponsibleOrganization | This method removes all the values that may have been set for Responsible Organization.
Public method | removeResponsiblePerson | This method removes all the values that may have been set for Responsible Person.
Public method | removeResponsiblePersonRole | This method removes all the values that may have been set for Responsible Person Role.
Public method | removeRouteOfAdmissions | This method removes all the values that may have been set for Route of Admissions.
Public method | removeScheduledProcedureSteps | This method removes all the values that may have been set for Scheduled Procedure Step Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSmokingStatus | This method removes all the values that may have been set for Smoking Status.
Public method | removeSpecialNeeds | This method removes all the values that may have been set for Special Needs.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeVisitComments | This method removes all the values that may have been set for Visit Comments.
Public method | removeVisitStatusID | This method removes all the values that may have been set for Visit Status ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AdditionalPatientHistory | Represents the value for the Additional Patient History attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AdmittingDate | Represents the value for the Admitting Date attribute.
Public property | AdmittingDiagnosisCodes | Represents the values for the Admitting Diagnosis Code Sequence attribute.
Public property | AdmittingDiagnosisDescriptions | Represents the values for the Admitting Diagnosis Description attribute.
Public property | AdmittingTime | Represents the value for the Admitting Time attribute.
Public property | Allergies | Represents the values for the Allergies attribute.
Public property | BranchOfService | Represents the value for the Branch of Service attribute.
Public property | BreedRegistrations | Represents the values for the Breed Registration Sequence attribute.
Public property | ConfidentialityCode | Represents the value for the Confidentiality Code attribute.
Public property | CountryOfResidence | Represents the value for the Country of Residence attribute.
Public property | CurrentPatientLocation | Represents the value for the Current Patient Location attribute.
Public property | EthnicGroup | Represents the value for the Ethnic Group attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | FillerOrderNumberProcedureRETIRED | Represents the value for the Filler Order Number Procedure RETIRED attribute.
Public property | HL7StructuredDocumentReferences | Represents the values for the HL7 Structured Document Reference Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImagingServiceRequestComments | Represents the value for the Imaging Service Request Comments attribute.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionCodes | Represents the values for the Institution Code Sequence attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | IntendedRecpOfResultsIdentifications | Represents the values for the Intended Recp of Results Identification Sequence attribute.
Public property | IssueDateOfImagingServiceRequest | Represents the value for the Issue Date of Imaging Service Request attribute.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | IssueTimeOfImagingServiceRequest | Represents the value for the Issue Time of Imaging Service Request attribute.
Public property | LastMenstrualDate | Represents the value for the Last Menstrual Date attribute.
Public property | MedicalAlerts | Represents the values for the Medical Alerts attribute.
Public property | MedicalRecordLocator | Represents the value for the Medical Record Locator attribute.
Public property | MilitaryRank | Represents the value for the Military Rank attribute.
Public property | NamesOfIntendedRecipientsOfResults | Represents the values for the Names of Intended Recipients of Results attribute.
Public property | OrderCallbackPhoneNumber | Represents the value for the Order Callback Phone Number attribute.
Public property | OrderEnteredBy | Represents the value for the Order Entered By attribute.
Public property | OrderEnterersLocation | Represents the value for the Order Enterer's Location attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | OtherPatientIDs | Represents the values for the Other Patient IDs attribute.
Public property | OtherPatientNames | Represents the values for the Other Patient Names attribute.
Public property | PatientBreedCodes | Represents the values for the Patient Breed Code Sequence attribute.
Public property | PatientBreedDescription | Represents the value for the Patient Breed Description attribute.
Public property | PatientClinicalTrialParticipations | Represents the values for the Patient Clinical Trial Participation Sequence attribute.
Public property | PatientComments | Represents the value for the Patient Comments attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsAddress | Represents the value for the Patient's Address attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsBirthName | Represents the value for the Patient's Birth Name attribute.
Public property | PatientsBirthTime | Represents the value for the Patient's Birth Time attribute.
Public property | PatientsInstitutionResidence | Represents the value for the Patient's Institution Residence attribute.
Public property | PatientsInsurancePlanCodes | Represents the values for the Patient's Insurance Plan Code Sequence attribute.
Public property | PatientsMothersBirthName | Represents the value for the Patient's Mother's Birth Name attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientSpeciesCodes | Represents the values for the Patient Species Code Sequence attribute.
Public property | PatientSpeciesDescription | Represents the value for the Patient Species Description attribute.
Public property | PatientsPrimaryLanguageCodes | Represents the values for the Patient's Primary Language Code Sequence attribute.
Public property | PatientsPrimaryLanguageModifierCodes | Represents the values for the Patient's Primary Language Modifier Code Sequence attribute.
Public property | PatientsReligiousPreference | Represents the value for the Patient's Religious Preference attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PatientsSexNeutered | Represents the value for the Patient's Sex Neutered attribute.
Public property | PatientsSize | Represents the value for the Patient's Size attribute.
Public property | PatientsSizeCodes | Represents the values for the Patient's Size Code Sequence attribute.
Public property | PatientState | Represents the value for the Patient State attribute.
Public property | PatientsTelephoneNumbers | Represents the values for the Patient's Telephone Numbers attribute.
Public property | PatientsWeight | Represents the value for the Patient's Weight attribute.
Public property | PatientTransportArrangements | Represents the value for the Patient Transport Arrangements attribute.
Public property | PertinentDocuments | Represents the values for the Pertinent Documents Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | PlacerOrderNumberProcedureRETIRED | Represents the value for the Placer Order Number / Procedure RETIRED attribute.
Public property | PregnancyStatus | Represents the value for the Pregnancy Status attribute.
Public property | ReasonForRequestedProcedureCodes | Represents the values for the Reason for Requested Procedure Code Sequence attribute.
Public property | ReasonForTheRequestedProcedure | Represents the value for the Reason for the Requested Procedure attribute.
Public property | ReferencedPatientAlias | Represents the values for the Referenced Patient Alias Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | ReferringPhysicianIdentifications | Represents the values for the Referring Physician Identification Sequence attribute.
Public property | ReferringPhysiciansAddress | Represents the value for the Referring Physician's Address attribute.
Public property | ReferringPhysiciansName | Represents the value for the Referring Physician's Name attribute.
Public property | ReferringPhysiciansTelephoneNumbers | Represents the values for the Referring Physician's Telephone Numbers attribute.
Public property | RegionOfResidence | Represents the value for the Region of Residence attribute.
Public property | ReportingPriority | Represents the value for the Reporting Priority attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureComments | Represents the value for the Requested Procedure Comments attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | RequestedProcedureLocation | Represents the value for the Requested Procedure Location attribute.
Public property | RequestedProcedurePriority | Represents the value for the Requested Procedure Priority attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingPhysicianIdentifications | Represents the values for the Requesting Physician Identification Sequence attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | RequestingServiceCodes | Represents the values for the Requesting Service Code Sequence attribute.
Public property | ResponsibleOrganization | Represents the value for the Responsible Organization attribute.
Public property | ResponsiblePerson | Represents the value for the Responsible Person attribute.
Public property | ResponsiblePersonRole | Represents the value for the Responsible Person Role attribute.
Public property | RouteOfAdmissions | Represents the value for the Route of Admissions attribute.
Public property | ScheduledProcedureSteps | Represents the values for the Scheduled Procedure Step Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SmokingStatus | Represents the value for the Smoking Status attribute.
Public property | SpecialNeeds | Represents the value for the Special Needs attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | VisitComments | Represents the value for the Visit Comments attribute.
Public property | VisitStatusID | Represents the value for the Visit Status ID attribute.

See Also

MCmodalityWorklistFind Class
Mergecom.Gen Namespace


MCmodalityWorklistFind Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Constructor
MCmodalityWorklistFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCmodalityWorklistFind()()()() | Constructs an MCmodalityWorklistFind collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCmodalityWorklistFind(MCdataSet) | Constructs an MCmodalityWorklistFind collection by wrapping an existing MCdataSet instance.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MCmodalityWorklistFind Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Constructor
MCmodalityWorklistFind Class See Also Send Feedback
Constructs an MCmodalityWorklistFind collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmodalityWorklistFind()
Visual Basic
Public Sub New
Visual C++
public:
MCmodalityWorklistFind()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
MCmodalityWorklistFind Overload
Mergecom.Gen Namespace


MCmodalityWorklistFind Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Constructor (MCdataSet)
MCmodalityWorklistFind Class See Also Send Feedback
Constructs an MCmodalityWorklistFind collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCmodalityWorklistFind(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCmodalityWorklistFind(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
MCmodalityWorklistFind Overload
Mergecom.Gen Namespace


MCmodalityWorklistFind Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Methods
MCmodalityWorklistFind Class See Also Send Feedback

The MCmodalityWorklistFind type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAdditionalPatientHistory | This method removes all the values that may have been set for Additional Patient History.
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAdmittingDate | This method removes all the values that may have been set for Admitting Date.
Public method | removeAdmittingDiagnosisCodes | This method removes all the values that may have been set for Admitting Diagnosis Code Sequence.
Public method | removeAdmittingDiagnosisDescriptions | This method removes all the values that may have been set for Admitting Diagnosis Description.
Public method | removeAdmittingTime | This method removes all the values that may have been set for Admitting Time.
Public method | removeAllergies | This method removes all the values that may have been set for Allergies.
Public method | removeBranchOfService | This method removes all the values that may have been set for Branch of Service.
Public method | removeBreedRegistrations | This method removes all the values that may have been set for Breed Registration Sequence.
Public method | removeConfidentialityCode | This method removes all the values that may have been set for Confidentiality Code.
Public method | removeCountryOfResidence | This method removes all the values that may have been set for Country of Residence.
Public method | removeCurrentPatientLocation | This method removes all the values that may have been set for Current Patient Location.
Public method | removeEthnicGroup | This method removes all the values that may have been set for Ethnic Group.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeFillerOrderNumberProcedureRETIRED | This method removes all the values that may have been set for Filler Order Number Procedure RETIRED.
Public method | removeHL7StructuredDocumentReferences | This method removes all the values that may have been set for HL7 Structured Document Reference Sequence.
Public method | removeImagingServiceRequestComments | This method removes all the values that may have been set for Imaging Service Request Comments.
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionCodes | This method removes all the values that may have been set for Institution Code Sequence.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removeIntendedRecpOfResultsIdentifications | This method removes all the values that may have been set for Intended Recp of Results Identification Sequence.
Public method | removeIssueDateOfImagingServiceRequest | This method removes all the values that may have been set for Issue Date of Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeIssueTimeOfImagingServiceRequest | This method removes all the values that may have been set for Issue Time of Imaging Service Request.
Public method | removeLastMenstrualDate | This method removes all the values that may have been set for Last Menstrual Date.
Public method | removeMedicalAlerts | This method removes all the values that may have been set for Medical Alerts.
Public method | removeMedicalRecordLocator | This method removes all the values that may have been set for Medical Record Locator.
Public method | removeMilitaryRank | This method removes all the values that may have been set for Military Rank.
Public method | removeNamesOfIntendedRecipientsOfResults | This method removes all the values that may have been set for Names of Intended Recipients of Results.
Public method | removeOrderCallbackPhoneNumber | This method removes all the values that may have been set for Order Callback Phone Number.
Public method | removeOrderEnteredBy | This method removes all the values that may have been set for Order Entered By.
Public method | removeOrderEnterersLocation | This method removes all the values that may have been set for Order Enterer's Location.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removeOtherPatientIDs | This method removes all the values that may have been set for Other Patient IDs.
Public method | removeOtherPatientNames | This method removes all the values that may have been set for Other Patient Names.
Public method | removePatientBreedCodes | This method removes all the values that may have been set for Patient Breed Code Sequence.
Public method | removePatientBreedDescription | This method removes all the values that may have been set for Patient Breed Description.
Public method | removePatientClinicalTrialParticipations | This method removes all the values that may have been set for Patient Clinical Trial Participation Sequence.
Public method | removePatientComments | This method removes all the values that may have been set for Patient Comments.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsAddress | This method removes all the values that may have been set for Patient's Address.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsBirthName | This method removes all the values that may have been set for Patient's Birth Name.
Public method | removePatientsBirthTime | This method removes all the values that may have been set for Patient's Birth Time.
Public method | removePatientsInstitutionResidence | This method removes all the values that may have been set for Patient's Institution Residence.
Public method | removePatientsInsurancePlanCodes | This method removes all the values that may have been set for Patient's Insurance Plan Code Sequence.
Public method | removePatientsMothersBirthName | This method removes all the values that may have been set for Patient's Mother's Birth Name.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientSpeciesCodes | This method removes all the values that may have been set for Patient Species Code Sequence.
Public method | removePatientSpeciesDescription | This method removes all the values that may have been set for Patient Species Description.
Public method | removePatientsPrimaryLanguageCodes | This method removes all the values that may have been set for Patient's Primary Language Code Sequence.
Public method | removePatientsPrimaryLanguageModifierCodes | This method removes all the values that may have been set for Patient's Primary Language Modifier Code Sequence.
Public method | removePatientsReligiousPreference | This method removes all the values that may have been set for Patient's Religious Preference.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePatientsSexNeutered | This method removes all the values that may have been set for Patient's Sex Neutered.
Public method | removePatientsSize | This method removes all the values that may have been set for Patient's Size.
Public method | removePatientsSizeCodes | This method removes all the values that may have been set for Patient's Size Code Sequence.
Public method | removePatientState | This method removes all the values that may have been set for Patient State.
Public method | removePatientsTelephoneNumbers | This method removes all the values that may have been set for Patient's Telephone Numbers.
Public method | removePatientsWeight | This method removes all the values that may have been set for Patient's Weight.
Public method | removePatientTransportArrangements | This method removes all the values that may have been set for Patient Transport Arrangements.
Public method | removePertinentDocuments | This method removes all the values that may have been set for Pertinent Documents Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removePlacerOrderNumberProcedureRETIRED | This method removes all the values that may have been set for Placer Order Number / Procedure RETIRED.
Public method | removePregnancyStatus | This method removes all the values that may have been set for Pregnancy Status.
Public method | removeReasonForRequestedProcedureCodes | This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.
Public method | removeReasonForTheRequestedProcedure | This method removes all the values that may have been set for Reason for the Requested Procedure.
Public method | removeReferencedPatientAlias | This method removes all the values that may have been set for Referenced Patient Alias Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeReferringPhysicianIdentifications | This method removes all the values that may have been set for Referring Physician Identification Sequence.
Public method | removeReferringPhysiciansAddress | This method removes all the values that may have been set for Referring Physician's Address.
Public method | removeReferringPhysiciansName | This method removes all the values that may have been set for Referring Physician's Name.
Public method | removeReferringPhysiciansTelephoneNumbers | This method removes all the values that may have been set for Referring Physician's Telephone Numbers.
Public method | removeRegionOfResidence | This method removes all the values that may have been set for Region of Residence.
Public method | removeReportingPriority | This method removes all the values that may have been set for Reporting Priority.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureComments | This method removes all the values that may have been set for Requested Procedure Comments.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeRequestedProcedureLocation | This method removes all the values that may have been set for Requested Procedure Location.
Public method | removeRequestedProcedurePriority | This method removes all the values that may have been set for Requested Procedure Priority.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingPhysicianIdentifications | This method removes all the values that may have been set for Requesting Physician Identification Sequence.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeRequestingServiceCodes | This method removes all the values that may have been set for Requesting Service Code Sequence.
Public method | removeResponsibleOrganization | This method removes all the values that may have been set for Responsible Organization.
Public method | removeResponsiblePerson | This method removes all the values that may have been set for Responsible Person.
Public method | removeResponsiblePersonRole | This method removes all the values that may have been set for Responsible Person Role.
Public method | removeRouteOfAdmissions | This method removes all the values that may have been set for Route of Admissions.
Public method | removeScheduledProcedureSteps | This method removes all the values that may have been set for Scheduled Procedure Step Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSmokingStatus | This method removes all the values that may have been set for Smoking Status.
Public method | removeSpecialNeeds | This method removes all the values that may have been set for Special Needs.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeVisitComments | This method removes all the values that may have been set for Visit Comments.
Public method | removeVisitStatusID | This method removes all the values that may have been set for Visit Status ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCmodalityWorklistFind Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAccessionNumber Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdditionalPatientHistory Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdditionalPatientHistory Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Additional Patient History.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdditionalPatientHistory()
Visual Basic
Public Overridable Sub removeAdditionalPatientHistory
Visual C++
public:
virtual void removeAdditionalPatientHistory()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdmissionID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdmissionID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Admission ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmissionID()
Visual Basic
Public Overridable Sub removeAdmissionID
Visual C++
public:
virtual void removeAdmissionID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdmittingDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdmittingDate Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Admitting Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmittingDate()
Visual Basic
Public Overridable Sub removeAdmittingDate
Visual C++
public:
virtual void removeAdmittingDate()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdmittingDiagnosisCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdmittingDiagnosisCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Admitting Diagnosis Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmittingDiagnosisCodes()
Visual Basic
Public Overridable Sub removeAdmittingDiagnosisCodes
Visual C++
public:
virtual void removeAdmittingDiagnosisCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdmittingDiagnosisDescriptions Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdmittingDiagnosisDescriptions Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Admitting Diagnosis Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmittingDiagnosisDescriptions()
Visual Basic
Public Overridable Sub removeAdmittingDiagnosisDescriptions
Visual C++
public:
virtual void removeAdmittingDiagnosisDescriptions()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAdmittingTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAdmittingTime Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Admitting Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmittingTime()
Visual Basic
Public Overridable Sub removeAdmittingTime
Visual C++
public:
virtual void removeAdmittingTime()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeAllergies Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeAllergies Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Allergies.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAllergies()
Visual Basic
Public Overridable Sub removeAllergies
Visual C++
public:
virtual void removeAllergies()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeBranchOfService Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeBranchOfService Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Branch of Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBranchOfService()
Visual Basic
Public Overridable Sub removeBranchOfService
Visual C++
public:
virtual void removeBranchOfService()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeBreedRegistrations Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeBreedRegistrations Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Breed Registration Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBreedRegistrations()
Visual Basic
Public Overridable Sub removeBreedRegistrations
Visual C++
public:
virtual void removeBreedRegistrations()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeConfidentialityCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeConfidentialityCode Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Confidentiality Code.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConfidentialityCode()
Visual Basic
Public Overridable Sub removeConfidentialityCode
Visual C++
public:
virtual void removeConfidentialityCode()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeCountryOfResidence Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeCountryOfResidence Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Country of Residence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCountryOfResidence()
Visual Basic
Public Overridable Sub removeCountryOfResidence
Visual C++
public:
virtual void removeCountryOfResidence()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeCurrentPatientLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeCurrentPatientLocation Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Current Patient Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCurrentPatientLocation()
Visual Basic
Public Overridable Sub removeCurrentPatientLocation
Visual C++
public:
virtual void removeCurrentPatientLocation()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeEthnicGroup Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeEthnicGroup Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Ethnic Group.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEthnicGroup()
Visual Basic
Public Overridable Sub removeEthnicGroup
Visual C++
public:
virtual void removeEthnicGroup()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeFillerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeFillerOrderNumberImagingServiceRequest Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFillerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removeFillerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removeFillerOrderNumberImagingServiceRequest()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeFillerOrderNumberProcedureRETIRED Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeFillerOrderNumberProcedureRETIRED Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Filler Order Number Procedure RETIRED.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFillerOrderNumberProcedureRETIRED()
Visual Basic
Public Overridable Sub removeFillerOrderNumberProcedureRETIRED
Visual C++
public:
virtual void removeFillerOrderNumberProcedureRETIRED()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeHL7StructuredDocumentReferences Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeHL7StructuredDocumentReferences Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for HL7 Structured Document Reference Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHL7StructuredDocumentReferences()
Visual Basic
Public Overridable Sub removeHL7StructuredDocumentReferences
Visual C++
public:
virtual void removeHL7StructuredDocumentReferences()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeImagingServiceRequestComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeImagingServiceRequestComments Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Imaging Service Request Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeImagingServiceRequestComments()
Visual Basic
Public Overridable Sub removeImagingServiceRequestComments
Visual C++
public:
virtual void removeImagingServiceRequestComments()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeInstitutionAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeInstitutionAddress Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Institution Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionAddress()
Visual Basic
Public Overridable Sub removeInstitutionAddress
Visual C++
public:
virtual void removeInstitutionAddress()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeInstitutionCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeInstitutionCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Institution Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionCodes()
Visual Basic
Public Overridable Sub removeInstitutionCodes
Visual C++
public:
virtual void removeInstitutionCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeInstitutionName Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeInstitutionName Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Institution Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionName()
Visual Basic
Public Overridable Sub removeInstitutionName
Visual C++
public:
virtual void removeInstitutionName()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIntendedRecpOfResultsIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIntendedRecpOfResultsIdentifications Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Intended Recp of Results Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIntendedRecpOfResultsIdentifications()
Visual Basic
Public Overridable Sub removeIntendedRecpOfResultsIdentifications
Visual C++
public:
virtual void removeIntendedRecpOfResultsIdentifications()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssueDateOfImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssueDateOfImagingServiceRequest Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issue Date of Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssueDateOfImagingServiceRequest()
Visual Basic
Public Overridable Sub removeIssueDateOfImagingServiceRequest
Visual C++
public:
virtual void removeIssueDateOfImagingServiceRequest()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssuerOfAccessionNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssuerOfAccessionNumbers Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Accession Number Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAccessionNumbers()
Visual Basic
Public Overridable Sub removeIssuerOfAccessionNumbers
Visual C++
public:
virtual void removeIssuerOfAccessionNumbers()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssuerOfAdmissionIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssuerOfAdmissionIDs Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Admission ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAdmissionIDs()
Visual Basic
Public Overridable Sub removeIssuerOfAdmissionIDs
Visual C++
public:
virtual void removeIssuerOfAdmissionIDs()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssuerOfPatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssuerOfPatientID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfPatientID()
Visual Basic
Public Overridable Sub removeIssuerOfPatientID
Visual C++
public:
virtual void removeIssuerOfPatientID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssuerOfServiceEpisodeIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssuerOfServiceEpisodeIDs Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfServiceEpisodeIDs()
Visual Basic
Public Overridable Sub removeIssuerOfServiceEpisodeIDs
Visual C++
public:
virtual void removeIssuerOfServiceEpisodeIDs()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeIssueTimeOfImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeIssueTimeOfImagingServiceRequest Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Issue Time of Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssueTimeOfImagingServiceRequest()
Visual Basic
Public Overridable Sub removeIssueTimeOfImagingServiceRequest
Visual C++
public:
virtual void removeIssueTimeOfImagingServiceRequest()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeLastMenstrualDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeLastMenstrualDate Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Last Menstrual Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeLastMenstrualDate()
Visual Basic
Public Overridable Sub removeLastMenstrualDate
Visual C++
public:
virtual void removeLastMenstrualDate()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeMedicalAlerts Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeMedicalAlerts Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Medical Alerts.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMedicalAlerts()
Visual Basic
Public Overridable Sub removeMedicalAlerts
Visual C++
public:
virtual void removeMedicalAlerts()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeMedicalRecordLocator Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeMedicalRecordLocator Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Medical Record Locator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMedicalRecordLocator()
Visual Basic
Public Overridable Sub removeMedicalRecordLocator
Visual C++
public:
virtual void removeMedicalRecordLocator()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeMilitaryRank Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeMilitaryRank Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Military Rank.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMilitaryRank()
Visual Basic
Public Overridable Sub removeMilitaryRank
Visual C++
public:
virtual void removeMilitaryRank()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeNamesOfIntendedRecipientsOfResults Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeNamesOfIntendedRecipientsOfResults Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Names of Intended Recipients of Results.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNamesOfIntendedRecipientsOfResults()
Visual Basic
Public Overridable Sub removeNamesOfIntendedRecipientsOfResults
Visual C++
public:
virtual void removeNamesOfIntendedRecipientsOfResults()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOrderCallbackPhoneNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOrderCallbackPhoneNumber Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Order Callback Phone Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderCallbackPhoneNumber()
Visual Basic
Public Overridable Sub removeOrderCallbackPhoneNumber
Visual C++
public:
virtual void removeOrderCallbackPhoneNumber()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOrderEnteredBy Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOrderEnteredBy Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Order Entered By.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderEnteredBy()
Visual Basic
Public Overridable Sub removeOrderEnteredBy
Visual C++
public:
virtual void removeOrderEnteredBy()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOrderEnterersLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOrderEnterersLocation Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Order Enterer's Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderEnterersLocation()
Visual Basic
Public Overridable Sub removeOrderEnterersLocation
Visual C++
public:
virtual void removeOrderEnterersLocation()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOrderFillerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOrderFillerIdentifiers Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Order Filler Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderFillerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderFillerIdentifiers
Visual C++
public:
virtual void removeOrderFillerIdentifiers()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOrderPlacerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOrderPlacerIdentifiers Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Order Placer Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderPlacerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderPlacerIdentifiers
Visual C++
public:
virtual void removeOrderPlacerIdentifiers()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOtherPatientIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOtherPatientIDs Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Other Patient IDs.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherPatientIDs()
Visual Basic
Public Overridable Sub removeOtherPatientIDs
Visual C++
public:
virtual void removeOtherPatientIDs()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeOtherPatientNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeOtherPatientNames Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Other Patient Names.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherPatientNames()
Visual Basic
Public Overridable Sub removeOtherPatientNames
Visual C++
public:
virtual void removeOtherPatientNames()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientBreedCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientBreedCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Breed Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientBreedCodes()
Visual Basic
Public Overridable Sub removePatientBreedCodes
Visual C++
public:
virtual void removePatientBreedCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientBreedDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientBreedDescription Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Breed Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientBreedDescription()
Visual Basic
Public Overridable Sub removePatientBreedDescription
Visual C++
public:
virtual void removePatientBreedDescription()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientClinicalTrialParticipations Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientClinicalTrialParticipations Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Clinical Trial Participation Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientClinicalTrialParticipations()
Visual Basic
Public Overridable Sub removePatientClinicalTrialParticipations
Visual C++
public:
virtual void removePatientClinicalTrialParticipations()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientComments Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientComments()
Visual Basic
Public Overridable Sub removePatientComments
Visual C++
public:
virtual void removePatientComments()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsAddress Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsAddress()
Visual Basic
Public Overridable Sub removePatientsAddress
Visual C++
public:
virtual void removePatientsAddress()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsBirthDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsBirthDate Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthDate()
Visual Basic
Public Overridable Sub removePatientsBirthDate
Visual C++
public:
virtual void removePatientsBirthDate()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsBirthName Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsBirthName Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthName()
Visual Basic
Public Overridable Sub removePatientsBirthName
Visual C++
public:
virtual void removePatientsBirthName()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsBirthTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsBirthTime Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthTime()
Visual Basic
Public Overridable Sub removePatientsBirthTime
Visual C++
public:
virtual void removePatientsBirthTime()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsInstitutionResidence Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsInstitutionResidence Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Institution Residence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsInstitutionResidence()
Visual Basic
Public Overridable Sub removePatientsInstitutionResidence
Visual C++
public:
virtual void removePatientsInstitutionResidence()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsInsurancePlanCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsInsurancePlanCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Insurance Plan Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsInsurancePlanCodes()
Visual Basic
Public Overridable Sub removePatientsInsurancePlanCodes
Visual C++
public:
virtual void removePatientsInsurancePlanCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsMothersBirthName Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsMothersBirthName Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Mother's Birth Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsMothersBirthName()
Visual Basic
Public Overridable Sub removePatientsMothersBirthName
Visual C++
public:
virtual void removePatientsMothersBirthName()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsName Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsName Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsName()
Visual Basic
Public Overridable Sub removePatientsName
Visual C++
public:
virtual void removePatientsName()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientSpeciesCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientSpeciesCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Species Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientSpeciesCodes()
Visual Basic
Public Overridable Sub removePatientSpeciesCodes
Visual C++
public:
virtual void removePatientSpeciesCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientSpeciesDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientSpeciesDescription Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Species Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientSpeciesDescription()
Visual Basic
Public Overridable Sub removePatientSpeciesDescription
Visual C++
public:
virtual void removePatientSpeciesDescription()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsPrimaryLanguageCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsPrimaryLanguageCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Primary Language Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsPrimaryLanguageCodes()
Visual Basic
Public Overridable Sub removePatientsPrimaryLanguageCodes
Visual C++
public:
virtual void removePatientsPrimaryLanguageCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsPrimaryLanguageModifierCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsPrimaryLanguageModifierCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Primary Language Modifier Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsPrimaryLanguageModifierCodes()
Visual Basic
Public Overridable Sub removePatientsPrimaryLanguageModifierCodes
Visual C++
public:
virtual void removePatientsPrimaryLanguageModifierCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsReligiousPreference Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsReligiousPreference Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Religious Preference.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsReligiousPreference()
Visual Basic
Public Overridable Sub removePatientsReligiousPreference
Visual C++
public:
virtual void removePatientsReligiousPreference()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsSex Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsSex Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSex()
Visual Basic
Public Overridable Sub removePatientsSex
Visual C++
public:
virtual void removePatientsSex()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsSexNeutered Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsSexNeutered Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex Neutered.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSexNeutered()
Visual Basic
Public Overridable Sub removePatientsSexNeutered
Visual C++
public:
virtual void removePatientsSexNeutered()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsSize Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsSize Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Size.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSize()
Visual Basic
Public Overridable Sub removePatientsSize
Visual C++
public:
virtual void removePatientsSize()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsSizeCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsSizeCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Size Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSizeCodes()
Visual Basic
Public Overridable Sub removePatientsSizeCodes
Visual C++
public:
virtual void removePatientsSizeCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientState Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientState Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient State.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientState()
Visual Basic
Public Overridable Sub removePatientState
Visual C++
public:
virtual void removePatientState()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsTelephoneNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsTelephoneNumbers Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Telephone Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsTelephoneNumbers()
Visual Basic
Public Overridable Sub removePatientsTelephoneNumbers
Visual C++
public:
virtual void removePatientsTelephoneNumbers()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientsWeight Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientsWeight Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Weight.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsWeight()
Visual Basic
Public Overridable Sub removePatientsWeight
Visual C++
public:
virtual void removePatientsWeight()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePatientTransportArrangements Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePatientTransportArrangements Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Patient Transport Arrangements.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientTransportArrangements()
Visual Basic
Public Overridable Sub removePatientTransportArrangements
Visual C++
public:
virtual void removePatientTransportArrangements()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePertinentDocuments Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePertinentDocuments Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Pertinent Documents Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePertinentDocuments()
Visual Basic
Public Overridable Sub removePertinentDocuments
Visual C++
public:
virtual void removePertinentDocuments()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePlacerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePlacerOrderNumberImagingServiceRequest Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePlacerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removePlacerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removePlacerOrderNumberImagingServiceRequest()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePlacerOrderNumberProcedureRETIRED Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePlacerOrderNumberProcedureRETIRED Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Placer Order Number / Procedure RETIRED.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePlacerOrderNumberProcedureRETIRED()
Visual Basic
Public Overridable Sub removePlacerOrderNumberProcedureRETIRED
Visual C++
public:
virtual void removePlacerOrderNumberProcedureRETIRED()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removePregnancyStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removePregnancyStatus Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Pregnancy Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePregnancyStatus()
Visual Basic
Public Overridable Sub removePregnancyStatus
Visual C++
public:
virtual void removePregnancyStatus()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReasonForRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReasonForRequestedProcedureCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeReasonForRequestedProcedureCodes
Visual C++
public:
virtual void removeReasonForRequestedProcedureCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReasonForTheRequestedProcedure Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReasonForTheRequestedProcedure Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Reason for the Requested Procedure.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForTheRequestedProcedure()
Visual Basic
Public Overridable Sub removeReasonForTheRequestedProcedure
Visual C++
public:
virtual void removeReasonForTheRequestedProcedure()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferencedPatientAlias Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferencedPatientAlias Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Alias Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatientAlias()
Visual Basic
Public Overridable Sub removeReferencedPatientAlias
Visual C++
public:
virtual void removeReferencedPatientAlias()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferencedPatients Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferencedStudies Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferencedVisits Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferencedVisits Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Visit Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedVisits()
Visual Basic
Public Overridable Sub removeReferencedVisits
Visual C++
public:
virtual void removeReferencedVisits()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferringPhysicianIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferringPhysicianIdentifications Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referring Physician Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferringPhysicianIdentifications()
Visual Basic
Public Overridable Sub removeReferringPhysicianIdentifications
Visual C++
public:
virtual void removeReferringPhysicianIdentifications()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferringPhysiciansAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferringPhysiciansAddress Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referring Physician's Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferringPhysiciansAddress()
Visual Basic
Public Overridable Sub removeReferringPhysiciansAddress
Visual C++
public:
virtual void removeReferringPhysiciansAddress()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferringPhysiciansName Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferringPhysiciansName Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referring Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferringPhysiciansName()
Visual Basic
Public Overridable Sub removeReferringPhysiciansName
Visual C++
public:
virtual void removeReferringPhysiciansName()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReferringPhysiciansTelephoneNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReferringPhysiciansTelephoneNumbers Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Referring Physician's Telephone Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferringPhysiciansTelephoneNumbers()
Visual Basic
Public Overridable Sub removeReferringPhysiciansTelephoneNumbers
Visual C++
public:
virtual void removeReferringPhysiciansTelephoneNumbers()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRegionOfResidence Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRegionOfResidence Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Region of Residence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRegionOfResidence()
Visual Basic
Public Overridable Sub removeRegionOfResidence
Visual C++
public:
virtual void removeRegionOfResidence()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeReportingPriority Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeReportingPriority Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Reporting Priority.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReportingPriority()
Visual Basic
Public Overridable Sub removeReportingPriority
Visual C++
public:
virtual void removeReportingPriority()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedureCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedureComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedureComments Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureComments()
Visual Basic
Public Overridable Sub removeRequestedProcedureComments
Visual C++
public:
virtual void removeRequestedProcedureComments()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedureDescription Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedureID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedureID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureID()
Visual Basic
Public Overridable Sub removeRequestedProcedureID
Visual C++
public:
virtual void removeRequestedProcedureID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedureLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedureLocation Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureLocation()
Visual Basic
Public Overridable Sub removeRequestedProcedureLocation
Visual C++
public:
virtual void removeRequestedProcedureLocation()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestedProcedurePriority Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestedProcedurePriority Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Priority.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedurePriority()
Visual Basic
Public Overridable Sub removeRequestedProcedurePriority
Visual C++
public:
virtual void removeRequestedProcedurePriority()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestingPhysician Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestingPhysicianIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestingPhysicianIdentifications Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysicianIdentifications()
Visual Basic
Public Overridable Sub removeRequestingPhysicianIdentifications
Visual C++
public:
virtual void removeRequestingPhysicianIdentifications()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestingService Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRequestingServiceCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRequestingServiceCodes Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingServiceCodes()
Visual Basic
Public Overridable Sub removeRequestingServiceCodes
Visual C++
public:
virtual void removeRequestingServiceCodes()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeResponsibleOrganization Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeResponsibleOrganization Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Responsible Organization.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeResponsibleOrganization()
Visual Basic
Public Overridable Sub removeResponsibleOrganization
Visual C++
public:
virtual void removeResponsibleOrganization()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeResponsiblePerson Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeResponsiblePerson Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Responsible Person.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeResponsiblePerson()
Visual Basic
Public Overridable Sub removeResponsiblePerson
Visual C++
public:
virtual void removeResponsiblePerson()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeResponsiblePersonRole Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeResponsiblePersonRole Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Responsible Person Role.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeResponsiblePersonRole()
Visual Basic
Public Overridable Sub removeResponsiblePersonRole
Visual C++
public:
virtual void removeResponsiblePersonRole()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeRouteOfAdmissions Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeRouteOfAdmissions Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Route of Admissions.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRouteOfAdmissions()
Visual Basic
Public Overridable Sub removeRouteOfAdmissions
Visual C++
public:
virtual void removeRouteOfAdmissions()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeScheduledProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeScheduledProcedureSteps Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureSteps()
Visual Basic
Public Overridable Sub removeScheduledProcedureSteps
Visual C++
public:
virtual void removeScheduledProcedureSteps()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeServiceEpisodeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeServiceEpisodeDescription Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeDescription()
Visual Basic
Public Overridable Sub removeServiceEpisodeDescription
Visual C++
public:
virtual void removeServiceEpisodeDescription()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeServiceEpisodeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeServiceEpisodeID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeID()
Visual Basic
Public Overridable Sub removeServiceEpisodeID
Visual C++
public:
virtual void removeServiceEpisodeID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeSmokingStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeSmokingStatus Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Smoking Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSmokingStatus()
Visual Basic
Public Overridable Sub removeSmokingStatus
Visual C++
public:
virtual void removeSmokingStatus()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeSpecialNeeds Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeSpecialNeeds Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Special Needs.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecialNeeds()
Visual Basic
Public Overridable Sub removeSpecialNeeds
Visual C++
public:
virtual void removeSpecialNeeds()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeSpecificCharacterSets Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeStudyDate Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeStudyInstanceUID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeStudyTime Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeVisitComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeVisitComments Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Visit Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeVisitComments()
Visual Basic
Public Overridable Sub removeVisitComments
Visual C++
public:
virtual void removeVisitComments()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


removeVisitStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..removeVisitStatusID Method
MCmodalityWorklistFind Class See Also Send Feedback
This method removes all the values that may have been set for Visit Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeVisitStatusID()
Visual Basic
Public Overridable Sub removeVisitStatusID
Visual C++
public:
virtual void removeVisitStatusID()

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MCmodalityWorklistFind Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind Properties
MCmodalityWorklistFind Class See Also Send Feedback

The MCmodalityWorklistFind type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AdditionalPatientHistory | Represents the value for the Additional Patient History attribute.
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AdmittingDate | Represents the value for the Admitting Date attribute.
Public property | AdmittingDiagnosisCodes | Represents the values for the Admitting Diagnosis Code Sequence attribute.
Public property | AdmittingDiagnosisDescriptions | Represents the values for the Admitting Diagnosis Description attribute.
Public property | AdmittingTime | Represents the value for the Admitting Time attribute.
Public property | Allergies | Represents the values for the Allergies attribute.
Public property | BranchOfService | Represents the value for the Branch of Service attribute.
Public property | BreedRegistrations | Represents the values for the Breed Registration Sequence attribute.
Public property | ConfidentialityCode | Represents the value for the Confidentiality Code attribute.
Public property | CountryOfResidence | Represents the value for the Country of Residence attribute.
Public property | CurrentPatientLocation | Represents the value for the Current Patient Location attribute.
Public property | EthnicGroup | Represents the value for the Ethnic Group attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | FillerOrderNumberProcedureRETIRED | Represents the value for the Filler Order Number Procedure RETIRED attribute.
Public property | HL7StructuredDocumentReferences | Represents the values for the HL7 Structured Document Reference Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImagingServiceRequestComments | Represents the value for the Imaging Service Request Comments attribute.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionCodes | Represents the values for the Institution Code Sequence attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | IntendedRecpOfResultsIdentifications | Represents the values for the Intended Recp of Results Identification Sequence attribute.
Public property | IssueDateOfImagingServiceRequest | Represents the value for the Issue Date of Imaging Service Request attribute.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | IssueTimeOfImagingServiceRequest | Represents the value for the Issue Time of Imaging Service Request attribute.
Public property | LastMenstrualDate | Represents the value for the Last Menstrual Date attribute.
Public property | MedicalAlerts | Represents the values for the Medical Alerts attribute.
Public property | MedicalRecordLocator | Represents the value for the Medical Record Locator attribute.
Public property | MilitaryRank | Represents the value for the Military Rank attribute.
Public property | NamesOfIntendedRecipientsOfResults | Represents the values for the Names of Intended Recipients of Results attribute.
Public property | OrderCallbackPhoneNumber | Represents the value for the Order Callback Phone Number attribute.
Public property | OrderEnteredBy | Represents the value for the Order Entered By attribute.
Public property | OrderEnterersLocation | Represents the value for the Order Enterer's Location attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | OtherPatientIDs | Represents the values for the Other Patient IDs attribute.
Public property | OtherPatientNames | Represents the values for the Other Patient Names attribute.
Public property | PatientBreedCodes | Represents the values for the Patient Breed Code Sequence attribute.
Public property | PatientBreedDescription | Represents the value for the Patient Breed Description attribute.
Public property | PatientClinicalTrialParticipations | Represents the values for the Patient Clinical Trial Participation Sequence attribute.
Public property | PatientComments | Represents the value for the Patient Comments attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsAddress | Represents the value for the Patient's Address attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsBirthName | Represents the value for the Patient's Birth Name attribute.
Public property | PatientsBirthTime | Represents the value for the Patient's Birth Time attribute.
Public property | PatientsInstitutionResidence | Represents the value for the Patient's Institution Residence attribute.
Public property | PatientsInsurancePlanCodes | Represents the values for the Patient's Insurance Plan Code Sequence attribute.
Public property | PatientsMothersBirthName | Represents the value for the Patient's Mother's Birth Name attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientSpeciesCodes | Represents the values for the Patient Species Code Sequence attribute.
Public property | PatientSpeciesDescription | Represents the value for the Patient Species Description attribute.
Public property | PatientsPrimaryLanguageCodes | Represents the values for the Patient's Primary Language Code Sequence attribute.
Public property | PatientsPrimaryLanguageModifierCodes | Represents the values for the Patient's Primary Language Modifier Code Sequence attribute.
Public property | PatientsReligiousPreference | Represents the value for the Patient's Religious Preference attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PatientsSexNeutered | Represents the value for the Patient's Sex Neutered attribute.
Public property | PatientsSize | Represents the value for the Patient's Size attribute.
Public property | PatientsSizeCodes | Represents the values for the Patient's Size Code Sequence attribute.
Public property | PatientState | Represents the value for the Patient State attribute.
Public property | PatientsTelephoneNumbers | Represents the values for the Patient's Telephone Numbers attribute.
Public property | PatientsWeight | Represents the value for the Patient's Weight attribute.
Public property | PatientTransportArrangements | Represents the value for the Patient Transport Arrangements attribute.
Public property | PertinentDocuments | Represents the values for the Pertinent Documents Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | PlacerOrderNumberProcedureRETIRED | Represents the value for the Placer Order Number / Procedure RETIRED attribute.
Public property | PregnancyStatus | Represents the value for the Pregnancy Status attribute.
Public property | ReasonForRequestedProcedureCodes | Represents the values for the Reason for Requested Procedure Code Sequence attribute.
Public property | ReasonForTheRequestedProcedure | Represents the value for the Reason for the Requested Procedure attribute.
Public property | ReferencedPatientAlias | Represents the values for the Referenced Patient Alias Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | ReferringPhysicianIdentifications | Represents the values for the Referring Physician Identification Sequence attribute.
Public property | ReferringPhysiciansAddress | Represents the value for the Referring Physician's Address attribute.
Public property | ReferringPhysiciansName | Represents the value for the Referring Physician's Name attribute.
Public property | ReferringPhysiciansTelephoneNumbers | Represents the values for the Referring Physician's Telephone Numbers attribute.
Public property | RegionOfResidence | Represents the value for the Region of Residence attribute.
Public property | ReportingPriority | Represents the value for the Reporting Priority attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureComments | Represents the value for the Requested Procedure Comments attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | RequestedProcedureLocation | Represents the value for the Requested Procedure Location attribute.
Public property | RequestedProcedurePriority | Represents the value for the Requested Procedure Priority attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingPhysicianIdentifications | Represents the values for the Requesting Physician Identification Sequence attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | RequestingServiceCodes | Represents the values for the Requesting Service Code Sequence attribute.
Public property | ResponsibleOrganization | Represents the value for the Responsible Organization attribute.
Public property | ResponsiblePerson | Represents the value for the Responsible Person attribute.
Public property | ResponsiblePersonRole | Represents the value for the Responsible Person Role attribute.
Public property | RouteOfAdmissions | Represents the value for the Route of Admissions attribute.
Public property | ScheduledProcedureSteps | Represents the values for the Scheduled Procedure Step Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SmokingStatus | Represents the value for the Smoking Status attribute.
Public property | SpecialNeeds | Represents the value for the Special Needs attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | VisitComments | Represents the value for the Visit Comments attribute.
Public property | VisitStatusID | Represents the value for the Visit Status ID attribute.

See Also

MCmodalityWorklistFind Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AccessionNumber Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdditionalPatientHistory Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdditionalPatientHistory Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Additional Patient History attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdditionalPatientHistory { get; set; }
Visual Basic
Public Overridable Property AdditionalPatientHistory As String
    Get
    Set
Visual C++
public:
virtual property String^ AdditionalPatientHistory {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdmissionID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdmissionID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Admission ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdmissionID { get; set; }
Visual Basic
Public Overridable Property AdmissionID As String
    Get
    Set
Visual C++
public:
virtual property String^ AdmissionID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdmittingDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdmittingDate Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Admitting Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate AdmittingDate { get; set; }
Visual Basic
Public Overridable Property AdmittingDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ AdmittingDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdmittingDiagnosisCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdmittingDiagnosisCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Admitting Diagnosis Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] AdmittingDiagnosisCodes { get; set; }
Visual Basic
Public Overridable Property AdmittingDiagnosisCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ AdmittingDiagnosisCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdmittingDiagnosisDescriptions Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdmittingDiagnosisDescriptions Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Admitting Diagnosis Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] AdmittingDiagnosisDescriptions { get; set; }
Visual Basic
Public Overridable Property AdmittingDiagnosisDescriptions As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ AdmittingDiagnosisDescriptions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


AdmittingTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..AdmittingTime Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Admitting Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime AdmittingTime { get; set; }
Visual Basic
Public Overridable Property AdmittingTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ AdmittingTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


Allergies Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..Allergies Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Allergies attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] Allergies { get; set; }
Visual Basic
Public Overridable Property Allergies As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ Allergies {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


BranchOfService Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..BranchOfService Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Branch of Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string BranchOfService { get; set; }
Visual Basic
Public Overridable Property BranchOfService As String
    Get
    Set
Visual C++
public:
virtual property String^ BranchOfService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


BreedRegistrations Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..BreedRegistrations Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Breed Registration Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbreedRegistrationItem[] BreedRegistrations { get; set; }
Visual Basic
Public Overridable Property BreedRegistrations As MCbreedRegistrationItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbreedRegistrationItem^>^ BreedRegistrations {
    array<MCbreedRegistrationItem^>^ get ();
    void set (array<MCbreedRegistrationItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ConfidentialityCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ConfidentialityCode Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Confidentiality Code attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ConfidentialityCode { get; set; }
Visual Basic
Public Overridable Property ConfidentialityCode As String
    Get
    Set
Visual C++
public:
virtual property String^ ConfidentialityCode {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


CountryOfResidence Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..CountryOfResidence Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Country of Residence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CountryOfResidence { get; set; }
Visual Basic
Public Overridable Property CountryOfResidence As String
    Get
    Set
Visual C++
public:
virtual property String^ CountryOfResidence {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


CurrentPatientLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..CurrentPatientLocation Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Current Patient Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CurrentPatientLocation { get; set; }
Visual Basic
Public Overridable Property CurrentPatientLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ CurrentPatientLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


EthnicGroup Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..EthnicGroup Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Ethnic Group attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string EthnicGroup { get; set; }
Visual Basic
Public Overridable Property EthnicGroup As String
    Get
    Set
Visual C++
public:
virtual property String^ EthnicGroup {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


FillerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..FillerOrderNumberImagingServiceRequest Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Filler Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FillerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property FillerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ FillerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


FillerOrderNumberProcedureRETIRED Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..FillerOrderNumberProcedureRETIRED Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Filler Order Number Procedure RETIRED attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FillerOrderNumberProcedureRETIRED { get; set; }
Visual Basic
Public Overridable Property FillerOrderNumberProcedureRETIRED As String
    Get
    Set
Visual C++
public:
virtual property String^ FillerOrderNumberProcedureRETIRED {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


HL7StructuredDocumentReferences Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..HL7StructuredDocumentReferences Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the HL7 Structured Document Reference Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7StructuredDocumentReferenceItem[] HL7StructuredDocumentReferences { get; set; }
Visual Basic
Public Overridable Property HL7StructuredDocumentReferences As MChL7StructuredDocumentReferenceItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7StructuredDocumentReferenceItem^>^ HL7StructuredDocumentReferences {
    array<MChL7StructuredDocumentReferenceItem^>^ get ();
    void set (array<MChL7StructuredDocumentReferenceItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..Host Property
MCmodalityWorklistFind Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ImagingServiceRequestComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ImagingServiceRequestComments Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Imaging Service Request Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ImagingServiceRequestComments { get; set; }
Visual Basic
Public Overridable Property ImagingServiceRequestComments As String
    Get
    Set
Visual C++
public:
virtual property String^ ImagingServiceRequestComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


InstitutionAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..InstitutionAddress Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Institution Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionAddress { get; set; }
Visual Basic
Public Overridable Property InstitutionAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


InstitutionCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..InstitutionCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Institution Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] InstitutionCodes { get; set; }
Visual Basic
Public Overridable Property InstitutionCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ InstitutionCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


InstitutionName Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..InstitutionName Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Institution Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionName { get; set; }
Visual Basic
Public Overridable Property InstitutionName As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IntendedRecpOfResultsIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IntendedRecpOfResultsIdentifications Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Intended Recp of Results Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] IntendedRecpOfResultsIdentifications { get; set; }
Visual Basic
Public Overridable Property IntendedRecpOfResultsIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ IntendedRecpOfResultsIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssueDateOfImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssueDateOfImagingServiceRequest Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Issue Date of Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate IssueDateOfImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property IssueDateOfImagingServiceRequest As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ IssueDateOfImagingServiceRequest {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssuerOfAccessionNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssuerOfAccessionNumbers Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Issuer of Accession Number Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAccessionNumbers { get; set; }
Visual Basic
Public Overridable Property IssuerOfAccessionNumbers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAccessionNumbers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssuerOfAdmissionIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssuerOfAdmissionIDs Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Issuer of Admission ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAdmissionIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfAdmissionIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAdmissionIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssuerOfPatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssuerOfPatientID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Issuer of Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IssuerOfPatientID { get; set; }
Visual Basic
Public Overridable Property IssuerOfPatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ IssuerOfPatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssuerOfServiceEpisodeIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssuerOfServiceEpisodeIDs Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Issuer of Service Episode ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfServiceEpisodeIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfServiceEpisodeIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfServiceEpisodeIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


IssueTimeOfImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..IssueTimeOfImagingServiceRequest Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Issue Time of Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime IssueTimeOfImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property IssueTimeOfImagingServiceRequest As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ IssueTimeOfImagingServiceRequest {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


LastMenstrualDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..LastMenstrualDate Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Last Menstrual Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate LastMenstrualDate { get; set; }
Visual Basic
Public Overridable Property LastMenstrualDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ LastMenstrualDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MedicalAlerts Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..MedicalAlerts Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Medical Alerts attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] MedicalAlerts { get; set; }
Visual Basic
Public Overridable Property MedicalAlerts As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ MedicalAlerts {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MedicalRecordLocator Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..MedicalRecordLocator Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Medical Record Locator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MedicalRecordLocator { get; set; }
Visual Basic
Public Overridable Property MedicalRecordLocator As String
    Get
    Set
Visual C++
public:
virtual property String^ MedicalRecordLocator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MilitaryRank Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..MilitaryRank Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Military Rank attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MilitaryRank { get; set; }
Visual Basic
Public Overridable Property MilitaryRank As String
    Get
    Set
Visual C++
public:
virtual property String^ MilitaryRank {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


NamesOfIntendedRecipientsOfResults Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..NamesOfIntendedRecipientsOfResults Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Names of Intended Recipients of Results attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] NamesOfIntendedRecipientsOfResults { get; set; }
Visual Basic
Public Overridable Property NamesOfIntendedRecipientsOfResults As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ NamesOfIntendedRecipientsOfResults {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OrderCallbackPhoneNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OrderCallbackPhoneNumber Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Order Callback Phone Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string OrderCallbackPhoneNumber { get; set; }
Visual Basic
Public Overridable Property OrderCallbackPhoneNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ OrderCallbackPhoneNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OrderEnteredBy Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OrderEnteredBy Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Order Entered By attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName OrderEnteredBy { get; set; }
Visual Basic
Public Overridable Property OrderEnteredBy As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ OrderEnteredBy {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OrderEnterersLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OrderEnterersLocation Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Order Enterer's Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string OrderEnterersLocation { get; set; }
Visual Basic
Public Overridable Property OrderEnterersLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ OrderEnterersLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OrderFillerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OrderFillerIdentifiers Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Order Filler Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderFillerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderFillerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderFillerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OrderPlacerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OrderPlacerIdentifiers Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Order Placer Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderPlacerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderPlacerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderPlacerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OtherPatientIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OtherPatientIDs Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Other Patient IDs attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] OtherPatientIDs { get; set; }
Visual Basic
Public Overridable Property OtherPatientIDs As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ OtherPatientIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


OtherPatientNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..OtherPatientNames Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Other Patient Names attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] OtherPatientNames { get; set; }
Visual Basic
Public Overridable Property OtherPatientNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ OtherPatientNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientBreedCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientBreedCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient Breed Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientBreedCodes { get; set; }
Visual Basic
Public Overridable Property PatientBreedCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientBreedCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientBreedDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientBreedDescription Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient Breed Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientBreedDescription { get; set; }
Visual Basic
Public Overridable Property PatientBreedDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientBreedDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientClinicalTrialParticipations Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientClinicalTrialParticipations Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient Clinical Trial Participation Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpatientClinicalTrialParticipationItem[] PatientClinicalTrialParticipations { get; set; }
Visual Basic
Public Overridable Property PatientClinicalTrialParticipations As MCpatientClinicalTrialParticipationItem()
    Get
    Set
Visual C++
public:
virtual property array<MCpatientClinicalTrialParticipationItem^>^ PatientClinicalTrialParticipations {
    array<MCpatientClinicalTrialParticipationItem^>^ get ();
    void set (array<MCpatientClinicalTrialParticipationItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientComments Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientComments { get; set; }
Visual Basic
Public Overridable Property PatientComments As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsAddress Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsAddress { get; set; }
Visual Basic
Public Overridable Property PatientsAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsBirthDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsBirthDate Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Birth Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PatientsBirthDate { get; set; }
Visual Basic
Public Overridable Property PatientsBirthDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PatientsBirthDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsBirthName Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsBirthName Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Birth Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsBirthName { get; set; }
Visual Basic
Public Overridable Property PatientsBirthName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsBirthName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsBirthTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsBirthTime Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Birth Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PatientsBirthTime { get; set; }
Visual Basic
Public Overridable Property PatientsBirthTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PatientsBirthTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsInstitutionResidence Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsInstitutionResidence Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Institution Residence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsInstitutionResidence { get; set; }
Visual Basic
Public Overridable Property PatientsInstitutionResidence As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsInstitutionResidence {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsInsurancePlanCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsInsurancePlanCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient's Insurance Plan Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientsInsurancePlanCodes { get; set; }
Visual Basic
Public Overridable Property PatientsInsurancePlanCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientsInsurancePlanCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsMothersBirthName Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsMothersBirthName Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Mother's Birth Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsMothersBirthName { get; set; }
Visual Basic
Public Overridable Property PatientsMothersBirthName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsMothersBirthName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsName Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsName { get; set; }
Visual Basic
Public Overridable Property PatientsName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientSpeciesCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientSpeciesCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient Species Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientSpeciesCodes { get; set; }
Visual Basic
Public Overridable Property PatientSpeciesCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientSpeciesCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientSpeciesDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientSpeciesDescription Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient Species Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientSpeciesDescription { get; set; }
Visual Basic
Public Overridable Property PatientSpeciesDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientSpeciesDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsPrimaryLanguageCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsPrimaryLanguageCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient's Primary Language Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientsPrimaryLanguageCodes { get; set; }
Visual Basic
Public Overridable Property PatientsPrimaryLanguageCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientsPrimaryLanguageCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsPrimaryLanguageModifierCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsPrimaryLanguageModifierCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient's Primary Language Modifier Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientsPrimaryLanguageModifierCodes { get; set; }
Visual Basic
Public Overridable Property PatientsPrimaryLanguageModifierCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientsPrimaryLanguageModifierCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsReligiousPreference Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsReligiousPreference Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Religious Preference attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsReligiousPreference { get; set; }
Visual Basic
Public Overridable Property PatientsReligiousPreference As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsReligiousPreference {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsSex Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsSex Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Sex attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSex { get; set; }
Visual Basic
Public Overridable Property PatientsSex As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSex {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsSexNeutered Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsSexNeutered Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Sex Neutered attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSexNeutered { get; set; }
Visual Basic
Public Overridable Property PatientsSexNeutered As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSexNeutered {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsSize Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsSize Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Size attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSize { get; set; }
Visual Basic
Public Overridable Property PatientsSize As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSize {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsSizeCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsSizeCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient's Size Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PatientsSizeCodes { get; set; }
Visual Basic
Public Overridable Property PatientsSizeCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PatientsSizeCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientState Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientState Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient State attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientState { get; set; }
Visual Basic
Public Overridable Property PatientState As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientState {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsTelephoneNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsTelephoneNumbers Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Patient's Telephone Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] PatientsTelephoneNumbers { get; set; }
Visual Basic
Public Overridable Property PatientsTelephoneNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ PatientsTelephoneNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientsWeight Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientsWeight Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient's Weight attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsWeight { get; set; }
Visual Basic
Public Overridable Property PatientsWeight As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsWeight {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PatientTransportArrangements Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PatientTransportArrangements Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Patient Transport Arrangements attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientTransportArrangements { get; set; }
Visual Basic
Public Overridable Property PatientTransportArrangements As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientTransportArrangements {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PertinentDocuments Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PertinentDocuments Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Pertinent Documents Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpertinentDocumentsItem[] PertinentDocuments { get; set; }
Visual Basic
Public Overridable Property PertinentDocuments As MCpertinentDocumentsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCpertinentDocumentsItem^>^ PertinentDocuments {
    array<MCpertinentDocumentsItem^>^ get ();
    void set (array<MCpertinentDocumentsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PlacerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PlacerOrderNumberImagingServiceRequest Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Placer Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PlacerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property PlacerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ PlacerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PlacerOrderNumberProcedureRETIRED Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PlacerOrderNumberProcedureRETIRED Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Placer Order Number / Procedure RETIRED attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PlacerOrderNumberProcedureRETIRED { get; set; }
Visual Basic
Public Overridable Property PlacerOrderNumberProcedureRETIRED As String
    Get
    Set
Visual C++
public:
virtual property String^ PlacerOrderNumberProcedureRETIRED {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


PregnancyStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..PregnancyStatus Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Pregnancy Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort PregnancyStatus { get; set; }
Visual Basic
Public Overridable Property PregnancyStatus As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short PregnancyStatus {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReasonForRequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReasonForRequestedProcedureCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Reason for Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ReasonForRequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ReasonForRequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ReasonForRequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReasonForTheRequestedProcedure Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReasonForTheRequestedProcedure Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Reason for the Requested Procedure attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForTheRequestedProcedure { get; set; }
Visual Basic
Public Overridable Property ReasonForTheRequestedProcedure As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForTheRequestedProcedure {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferencedPatientAlias Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferencedPatientAlias Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referenced Patient Alias Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientAliasItem[] ReferencedPatientAlias { get; set; }
Visual Basic
Public Overridable Property ReferencedPatientAlias As MCreferencedPatientAliasItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientAliasItem^>^ ReferencedPatientAlias {
    array<MCreferencedPatientAliasItem^>^ get ();
    void set (array<MCreferencedPatientAliasItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferencedPatients Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferencedStudies Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferencedVisits Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferencedVisits Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referenced Visit Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedVisitItem[] ReferencedVisits { get; set; }
Visual Basic
Public Overridable Property ReferencedVisits As MCreferencedVisitItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedVisitItem^>^ ReferencedVisits {
    array<MCreferencedVisitItem^>^ get ();
    void set (array<MCreferencedVisitItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferringPhysicianIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferringPhysicianIdentifications Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referring Physician Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] ReferringPhysicianIdentifications { get; set; }
Visual Basic
Public Overridable Property ReferringPhysicianIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ ReferringPhysicianIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferringPhysiciansAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferringPhysiciansAddress Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Referring Physician's Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferringPhysiciansAddress { get; set; }
Visual Basic
Public Overridable Property ReferringPhysiciansAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferringPhysiciansAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferringPhysiciansName Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferringPhysiciansName Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Referring Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName ReferringPhysiciansName { get; set; }
Visual Basic
Public Overridable Property ReferringPhysiciansName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ ReferringPhysiciansName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReferringPhysiciansTelephoneNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReferringPhysiciansTelephoneNumbers Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Referring Physician's Telephone Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ReferringPhysiciansTelephoneNumbers { get; set; }
Visual Basic
Public Overridable Property ReferringPhysiciansTelephoneNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ReferringPhysiciansTelephoneNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RegionOfResidence Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RegionOfResidence Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Region of Residence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RegionOfResidence { get; set; }
Visual Basic
Public Overridable Property RegionOfResidence As String
    Get
    Set
Visual C++
public:
virtual property String^ RegionOfResidence {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ReportingPriority Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ReportingPriority Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Reporting Priority attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReportingPriority { get; set; }
Visual Basic
Public Overridable Property ReportingPriority As String
    Get
    Set
Visual C++
public:
virtual property String^ ReportingPriority {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedureCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedureComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedureComments Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requested Procedure Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureComments { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureComments As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedureDescription Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedureID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedureID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requested Procedure ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureID { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureID As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedureLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedureLocation Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requested Procedure Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureLocation { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestedProcedurePriority Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestedProcedurePriority Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requested Procedure Priority attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedurePriority { get; set; }
Visual Basic
Public Overridable Property RequestedProcedurePriority As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedurePriority {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestingPhysician Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestingPhysicianIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestingPhysicianIdentifications Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Requesting Physician Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] RequestingPhysicianIdentifications { get; set; }
Visual Basic
Public Overridable Property RequestingPhysicianIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ RequestingPhysicianIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestingService Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RequestingServiceCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RequestingServiceCodes Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Requesting Service Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestingServiceCodes { get; set; }
Visual Basic
Public Overridable Property RequestingServiceCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestingServiceCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ResponsibleOrganization Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ResponsibleOrganization Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Responsible Organization attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ResponsibleOrganization { get; set; }
Visual Basic
Public Overridable Property ResponsibleOrganization As String
    Get
    Set
Visual C++
public:
virtual property String^ ResponsibleOrganization {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ResponsiblePerson Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ResponsiblePerson Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Responsible Person attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName ResponsiblePerson { get; set; }
Visual Basic
Public Overridable Property ResponsiblePerson As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ ResponsiblePerson {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ResponsiblePersonRole Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ResponsiblePersonRole Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Responsible Person Role attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ResponsiblePersonRole { get; set; }
Visual Basic
Public Overridable Property ResponsiblePersonRole As String
    Get
    Set
Visual C++
public:
virtual property String^ ResponsiblePersonRole {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


RouteOfAdmissions Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..RouteOfAdmissions Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Route of Admissions attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RouteOfAdmissions { get; set; }
Visual Basic
Public Overridable Property RouteOfAdmissions As String
    Get
    Set
Visual C++
public:
virtual property String^ RouteOfAdmissions {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ScheduledProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ScheduledProcedureSteps Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Scheduled Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCscheduledProcedureStepItem[] ScheduledProcedureSteps { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureSteps As MCscheduledProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCscheduledProcedureStepItem^>^ ScheduledProcedureSteps {
    array<MCscheduledProcedureStepItem^>^ get ();
    void set (array<MCscheduledProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ServiceEpisodeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ServiceEpisodeDescription Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Service Episode Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeDescription { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


ServiceEpisodeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..ServiceEpisodeID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Service Episode ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeID { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeID As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


SmokingStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..SmokingStatus Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Smoking Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SmokingStatus { get; set; }
Visual Basic
Public Overridable Property SmokingStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ SmokingStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


SpecialNeeds Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..SpecialNeeds Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Special Needs attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SpecialNeeds { get; set; }
Visual Basic
Public Overridable Property SpecialNeeds As String
    Get
    Set
Visual C++
public:
virtual property String^ SpecialNeeds {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..SpecificCharacterSets Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..StudyDate Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..StudyInstanceUID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..StudyTime Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


VisitComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..VisitComments Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Visit Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string VisitComments { get; set; }
Visual Basic
Public Overridable Property VisitComments As String
    Get
    Set
Visual C++
public:
virtual property String^ VisitComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


VisitStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCmodalityWorklistFind..::..VisitStatusID Property
MCmodalityWorklistFind Class See Also Send Feedback
Represents the value for the Visit Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string VisitStatusID { get; set; }
Visual Basic
Public Overridable Property VisitStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ VisitStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCmodalityWorklistFind Class
MCmodalityWorklistFind Members
Mergecom.Gen Namespace


MCoutputInformationItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the OUTPUT_INFORMATION Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCoutputInformationItem
Visual Basic
Public Class MCoutputInformationItem
Visual C++
public ref class MCoutputInformationItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081115) Referenced Series Sequence
  • (0020000D) Study Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCoutputInformationItem

See Also

MCoutputInformationItem Members
Mergecom.Gen Namespace


MCoutputInformationItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Members
MCoutputInformationItem Class Constructors Methods Properties See Also Send Feedback

The MCoutputInformationItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCoutputInformationItem()()()() | Constructs an MCoutputInformationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCoutputInformationItem(MCitem) | Constructs an MCoutputInformationItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCoutputInformationItem Class
Mergecom.Gen Namespace


MCoutputInformationItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Constructor
MCoutputInformationItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCoutputInformationItem()()()() | Constructs an MCoutputInformationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCoutputInformationItem(MCitem) | Constructs an MCoutputInformationItem collection by wrapping an existing MCitem instance.

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


MCoutputInformationItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Constructor
MCoutputInformationItem Class See Also Send Feedback
Constructs an MCoutputInformationItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCoutputInformationItem()
Visual Basic
Public Sub New
Visual C++
public:
MCoutputInformationItem()

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
MCoutputInformationItem Overload
Mergecom.Gen Namespace


MCoutputInformationItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Constructor (MCitem)
MCoutputInformationItem Class See Also Send Feedback
Constructs an MCoutputInformationItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCoutputInformationItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCoutputInformationItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
MCoutputInformationItem Overload
Mergecom.Gen Namespace


MCoutputInformationItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Methods
MCoutputInformationItem Class See Also Send Feedback

The MCoutputInformationItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCoutputInformationItem Class
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem..::..removeReferencedSeries Method
MCoutputInformationItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem..::..removeStudyInstanceUID Method
MCoutputInformationItem Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


MCoutputInformationItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem Properties
MCoutputInformationItem Class See Also Send Feedback

The MCoutputInformationItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCoutputInformationItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem..::..Host Property
MCoutputInformationItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem..::..ReferencedSeries Property
MCoutputInformationItem Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCoutputInformationItem..::..StudyInstanceUID Property
MCoutputInformationItem Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCoutputInformationItem Class
MCoutputInformationItem Members
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the PATIENT_CLINICAL_TRIAL Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpatientClinicalTrialParticipationItem
Visual Basic
Public Class MCpatientClinicalTrialParticipationItem
Visual C++
public ref class MCpatientClinicalTrialParticipationItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00120010) Clinical Trial Sponsor Name
  • (00120020) Clinical Trial Protocol ID
  • (00120021) Clinical Trial Protocol Name
  • (00120030) Clinical Trial Site ID
  • (00120031) Clinical Trial Site Name
  • (00120040) Clinical Trial Subject ID
  • (00120042) Clinical Trial Subject Reading ID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCpatientClinicalTrialParticipationItem

See Also

MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Members
MCpatientClinicalTrialParticipationItem Class Constructors Methods Properties See Also Send Feedback

The MCpatientClinicalTrialParticipationItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCpatientClinicalTrialParticipationItem()()()() | Constructs an MCpatientClinicalTrialParticipationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpatientClinicalTrialParticipationItem(MCitem) | Constructs an MCpatientClinicalTrialParticipationItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeClinicalTrialProtocolID | This method removes all the values that may have been set for Clinical Trial Protocol ID.
Public method | removeClinicalTrialProtocolName | This method removes all the values that may have been set for Clinical Trial Protocol Name.
Public method | removeClinicalTrialSiteID | This method removes all the values that may have been set for Clinical Trial Site ID.
Public method | removeClinicalTrialSiteName | This method removes all the values that may have been set for Clinical Trial Site Name.
Public method | removeClinicalTrialSponsorName | This method removes all the values that may have been set for Clinical Trial Sponsor Name.
Public method | removeClinicalTrialSubjectID | This method removes all the values that may have been set for Clinical Trial Subject ID.
Public method | removeClinicalTrialSubjectReadingID | This method removes all the values that may have been set for Clinical Trial Subject Reading ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClinicalTrialProtocolID | Represents the value for the Clinical Trial Protocol ID attribute.
Public property | ClinicalTrialProtocolName | Represents the value for the Clinical Trial Protocol Name attribute.
Public property | ClinicalTrialSiteID | Represents the value for the Clinical Trial Site ID attribute.
Public property | ClinicalTrialSiteName | Represents the value for the Clinical Trial Site Name attribute.
Public property | ClinicalTrialSponsorName | Represents the value for the Clinical Trial Sponsor Name attribute.
Public property | ClinicalTrialSubjectID | Represents the value for the Clinical Trial Subject ID attribute.
Public property | ClinicalTrialSubjectReadingID | Represents the value for the Clinical Trial Subject Reading ID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCpatientClinicalTrialParticipationItem Class
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Constructor
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpatientClinicalTrialParticipationItem()()()() | Constructs an MCpatientClinicalTrialParticipationItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpatientClinicalTrialParticipationItem(MCitem) | Constructs an MCpatientClinicalTrialParticipationItem collection by wrapping an existing MCitem instance.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Constructor
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Constructs an MCpatientClinicalTrialParticipationItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpatientClinicalTrialParticipationItem()
Visual Basic
Public Sub New
Visual C++
public:
MCpatientClinicalTrialParticipationItem()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
MCpatientClinicalTrialParticipationItem Overload
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Constructor (MCitem)
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Constructs an MCpatientClinicalTrialParticipationItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpatientClinicalTrialParticipationItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCpatientClinicalTrialParticipationItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
MCpatientClinicalTrialParticipationItem Overload
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Methods
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback

The MCpatientClinicalTrialParticipationItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeClinicalTrialProtocolID | This method removes all the values that may have been set for Clinical Trial Protocol ID.
Public method | removeClinicalTrialProtocolName | This method removes all the values that may have been set for Clinical Trial Protocol Name.
Public method | removeClinicalTrialSiteID | This method removes all the values that may have been set for Clinical Trial Site ID.
Public method | removeClinicalTrialSiteName | This method removes all the values that may have been set for Clinical Trial Site Name.
Public method | removeClinicalTrialSponsorName | This method removes all the values that may have been set for Clinical Trial Sponsor Name.
Public method | removeClinicalTrialSubjectID | This method removes all the values that may have been set for Clinical Trial Subject ID.
Public method | removeClinicalTrialSubjectReadingID | This method removes all the values that may have been set for Clinical Trial Subject Reading ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCpatientClinicalTrialParticipationItem Class
Mergecom.Gen Namespace


removeClinicalTrialProtocolID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialProtocolID Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Protocol ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialProtocolID()
Visual Basic
Public Overridable Sub removeClinicalTrialProtocolID
Visual C++
public:
virtual void removeClinicalTrialProtocolID()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialProtocolName Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialProtocolName Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Protocol Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialProtocolName()
Visual Basic
Public Overridable Sub removeClinicalTrialProtocolName
Visual C++
public:
virtual void removeClinicalTrialProtocolName()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialSiteID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialSiteID Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Site ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialSiteID()
Visual Basic
Public Overridable Sub removeClinicalTrialSiteID
Visual C++
public:
virtual void removeClinicalTrialSiteID()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialSiteName Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialSiteName Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Site Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialSiteName()
Visual Basic
Public Overridable Sub removeClinicalTrialSiteName
Visual C++
public:
virtual void removeClinicalTrialSiteName()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialSponsorName Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialSponsorName Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Sponsor Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialSponsorName()
Visual Basic
Public Overridable Sub removeClinicalTrialSponsorName
Visual C++
public:
virtual void removeClinicalTrialSponsorName()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialSubjectID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialSubjectID Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Subject ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialSubjectID()
Visual Basic
Public Overridable Sub removeClinicalTrialSubjectID
Visual C++
public:
virtual void removeClinicalTrialSubjectID()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


removeClinicalTrialSubjectReadingID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..removeClinicalTrialSubjectReadingID Method
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
This method removes all the values that may have been set for Clinical Trial Subject Reading ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeClinicalTrialSubjectReadingID()
Visual Basic
Public Overridable Sub removeClinicalTrialSubjectReadingID
Visual C++
public:
virtual void removeClinicalTrialSubjectReadingID()

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


MCpatientClinicalTrialParticipationItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem Properties
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback

The MCpatientClinicalTrialParticipationItem type exposes the following members.

Properties

 | Name | Description
Public property | ClinicalTrialProtocolID | Represents the value for the Clinical Trial Protocol ID attribute.
Public property | ClinicalTrialProtocolName | Represents the value for the Clinical Trial Protocol Name attribute.
Public property | ClinicalTrialSiteID | Represents the value for the Clinical Trial Site ID attribute.
Public property | ClinicalTrialSiteName | Represents the value for the Clinical Trial Site Name attribute.
Public property | ClinicalTrialSponsorName | Represents the value for the Clinical Trial Sponsor Name attribute.
Public property | ClinicalTrialSubjectID | Represents the value for the Clinical Trial Subject ID attribute.
Public property | ClinicalTrialSubjectReadingID | Represents the value for the Clinical Trial Subject Reading ID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCpatientClinicalTrialParticipationItem Class
Mergecom.Gen Namespace


ClinicalTrialProtocolID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialProtocolID Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Protocol ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialProtocolID { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialProtocolID As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialProtocolID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialProtocolName Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialProtocolName Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Protocol Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialProtocolName { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialProtocolName As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialProtocolName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialSiteID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialSiteID Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Site ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialSiteID { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialSiteID As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialSiteID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialSiteName Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialSiteName Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Site Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialSiteName { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialSiteName As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialSiteName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialSponsorName Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialSponsorName Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Sponsor Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialSponsorName { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialSponsorName As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialSponsorName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialSubjectID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialSubjectID Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Subject ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialSubjectID { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialSubjectID As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialSubjectID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


ClinicalTrialSubjectReadingID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..ClinicalTrialSubjectReadingID Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Represents the value for the Clinical Trial Subject Reading ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ClinicalTrialSubjectReadingID { get; set; }
Visual Basic
Public Overridable Property ClinicalTrialSubjectReadingID As String
    Get
    Set
Visual C++
public:
virtual property String^ ClinicalTrialSubjectReadingID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCpatientClinicalTrialParticipationItem..::..Host Property
MCpatientClinicalTrialParticipationItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCpatientClinicalTrialParticipationItem Class
MCpatientClinicalTrialParticipationItem Members
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Class

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCperformedProcedureStepCreate
Visual Basic
Public Class MCperformedProcedureStepCreate
Visual C++
public ref class MCperformedProcedureStepCreate

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080060) Modality
  • (00081032) Procedure Code Sequence
  • (00081120) Referenced Patient Sequence
  • (00082229) Anatomic Structure Space or Region Sequence
  • (00100010) Patient's Name
  • (00100020) Patient ID
  • (00100021) Issuer of Patient ID
  • (00100024) Issuer of Patient ID Qualifiers Sequence
  • (00100030) Patient's Birth Date
  • (00100040) Patient's Sex
  • (00181110) Distance Source to Detector
  • (0018115E) Image and Fluoroscopy Area Dose Product
  • (00200010) Study ID
  • (00380010) Admission ID
  • (00380014) Issuer of Admission ID Sequence
  • (00380060) Service Episode ID
  • (00380062) Service Episode Description
  • (00380064) Issuer of Service Episode ID Sequence
  • (00400241) Performed Station AE Title
  • (00400242) Performed Station Name
  • (00400243) Performed Location
  • (00400244) Performed Procedure Step Start Date
  • (00400245) Performed Procedure Step Start Time
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400252) Performed Procedure Step Status
  • (00400253) Performed Procedure Step ID
  • (00400254) Performed Procedure Step Description
  • (00400255) Performed Procedure Type Description
  • (00400260) Performed Protocol Code Sequence
  • (00400270) Scheduled Step Attributes Sequence
  • (00400280) Comments on the Performed Procedure Steps
  • (00400281) PPS Discontinuation Reason Code Sequence
  • (00400300) Total Time of Fluoroscopy
  • (00400301) Total Number of Exposures
  • (00400302) Entrance Dose
  • (00400303) Exposed Area
  • (00400306) Distance Source to Entrance
  • (0040030E) Exposure Dose Sequence
  • (00400310) Comments on Radiation Dose
  • (00400320) Billing Procedure Step Sequence
  • (00400321) Film Consumption Sequence
  • (00400324) Billing Supplies and Devices Sequence
  • (00400340) Performed Series Sequence
  • (00401012) Reason For Performed Procedure Code Sequence
  • (00408302) Entrance Dose in mGy

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCperformedProcedureStepCreate

See Also

MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Members
MCperformedProcedureStepCreate Class Constructors Methods Properties See Also Send Feedback

The MCperformedProcedureStepCreate type exposes the following members.

Constructors

 | Name | Description
Public method | MCperformedProcedureStepCreate()()()() | Constructs an MCperformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepCreate(MCdataSet) | Constructs an MCperformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedLocation | This method removes all the values that may have been set for Performed Location.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePerformedStationAETitle | This method removes all the values that may have been set for Performed Station AE Title.
Public method | removePerformedStationName | This method removes all the values that may have been set for Performed Station Name.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForPerformedProcedureCodes | This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeScheduledStepAttributes | This method removes all the values that may have been set for Scheduled Step Attributes Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedLocation | Represents the value for the Performed Location attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PerformedStationAETitle | Represents the value for the Performed Station AE Title attribute.
Public property | PerformedStationName | Represents the value for the Performed Station Name attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForPerformedProcedureCodes | Represents the values for the Reason For Performed Procedure Code Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ScheduledStepAttributes | Represents the values for the Scheduled Step Attributes Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepCreate Class
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Constructor
MCperformedProcedureStepCreate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCperformedProcedureStepCreate()()()() | Constructs an MCperformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepCreate(MCdataSet) | Constructs an MCperformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Constructor
MCperformedProcedureStepCreate Class See Also Send Feedback
Constructs an MCperformedProcedureStepCreate collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepCreate()
Visual Basic
Public Sub New
Visual C++
public:
MCperformedProcedureStepCreate()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
MCperformedProcedureStepCreate Overload
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Constructor (MCdataSet)
MCperformedProcedureStepCreate Class See Also Send Feedback
Constructs an MCperformedProcedureStepCreate collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepCreate(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCperformedProcedureStepCreate(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
MCperformedProcedureStepCreate Overload
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Methods
MCperformedProcedureStepCreate Class See Also Send Feedback

The MCperformedProcedureStepCreate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedLocation | This method removes all the values that may have been set for Performed Location.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePerformedStationAETitle | This method removes all the values that may have been set for Performed Station AE Title.
Public method | removePerformedStationName | This method removes all the values that may have been set for Performed Station Name.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForPerformedProcedureCodes | This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeScheduledStepAttributes | This method removes all the values that may have been set for Scheduled Step Attributes Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCperformedProcedureStepCreate Class
Mergecom.Gen Namespace


removeAdmissionID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeAdmissionID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Admission ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmissionID()
Visual Basic
Public Overridable Sub removeAdmissionID
Visual C++
public:
virtual void removeAdmissionID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeAnatomicStructureSpaceOrRegions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeAnatomicStructureSpaceOrRegions Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAnatomicStructureSpaceOrRegions()
Visual Basic
Public Overridable Sub removeAnatomicStructureSpaceOrRegions
Visual C++
public:
virtual void removeAnatomicStructureSpaceOrRegions()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeBillingProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeBillingProcedureSteps Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Billing Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingProcedureSteps()
Visual Basic
Public Overridable Sub removeBillingProcedureSteps
Visual C++
public:
virtual void removeBillingProcedureSteps()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeBillingSuppliesAndDevices Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeBillingSuppliesAndDevices Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Billing Supplies and Devices Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingSuppliesAndDevices()
Visual Basic
Public Overridable Sub removeBillingSuppliesAndDevices
Visual C++
public:
virtual void removeBillingSuppliesAndDevices()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeCommentsOnRadiationDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeCommentsOnRadiationDose Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Comments on Radiation Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnRadiationDose()
Visual Basic
Public Overridable Sub removeCommentsOnRadiationDose
Visual C++
public:
virtual void removeCommentsOnRadiationDose()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeCommentsOnThePerformedProcedureSteps Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeDistanceSourceToDetector Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeDistanceSourceToDetector Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Detector.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToDetector()
Visual Basic
Public Overridable Sub removeDistanceSourceToDetector
Visual C++
public:
virtual void removeDistanceSourceToDetector()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeDistanceSourceToEntrance Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeDistanceSourceToEntrance Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Entrance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToEntrance()
Visual Basic
Public Overridable Sub removeDistanceSourceToEntrance
Visual C++
public:
virtual void removeDistanceSourceToEntrance()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeEntranceDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeEntranceDose Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDose()
Visual Basic
Public Overridable Sub removeEntranceDose
Visual C++
public:
virtual void removeEntranceDose()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeEntranceDoseInMGy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeEntranceDoseInMGy Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose in mGy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDoseInMGy()
Visual Basic
Public Overridable Sub removeEntranceDoseInMGy
Visual C++
public:
virtual void removeEntranceDoseInMGy()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeExposedAreas Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeExposedAreas Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Exposed Area.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposedAreas()
Visual Basic
Public Overridable Sub removeExposedAreas
Visual C++
public:
virtual void removeExposedAreas()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeExposureDoses Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeExposureDoses Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Exposure Dose Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposureDoses()
Visual Basic
Public Overridable Sub removeExposureDoses
Visual C++
public:
virtual void removeExposureDoses()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeFilmConsumptions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeFilmConsumptions Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Film Consumption Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilmConsumptions()
Visual Basic
Public Overridable Sub removeFilmConsumptions
Visual C++
public:
virtual void removeFilmConsumptions()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeImageAndFluoroscopyAreaDoseProduct Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeImageAndFluoroscopyAreaDoseProduct Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeImageAndFluoroscopyAreaDoseProduct()
Visual Basic
Public Overridable Sub removeImageAndFluoroscopyAreaDoseProduct
Visual C++
public:
virtual void removeImageAndFluoroscopyAreaDoseProduct()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfAdmissionIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeIssuerOfAdmissionIDs Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Admission ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAdmissionIDs()
Visual Basic
Public Overridable Sub removeIssuerOfAdmissionIDs
Visual C++
public:
virtual void removeIssuerOfAdmissionIDs()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfPatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeIssuerOfPatientID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfPatientID()
Visual Basic
Public Overridable Sub removeIssuerOfPatientID
Visual C++
public:
virtual void removeIssuerOfPatientID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeIssuerOfServiceEpisodeIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeIssuerOfServiceEpisodeIDs Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfServiceEpisodeIDs()
Visual Basic
Public Overridable Sub removeIssuerOfServiceEpisodeIDs
Visual C++
public:
virtual void removeIssuerOfServiceEpisodeIDs()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeModality Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePatientID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsBirthDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePatientsBirthDate Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthDate()
Visual Basic
Public Overridable Sub removePatientsBirthDate
Visual C++
public:
virtual void removePatientsBirthDate()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePatientsName Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsName()
Visual Basic
Public Overridable Sub removePatientsName
Visual C++
public:
virtual void removePatientsName()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePatientsSex Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePatientsSex Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSex()
Visual Basic
Public Overridable Sub removePatientsSex
Visual C++
public:
virtual void removePatientsSex()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedLocation Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedLocation()
Visual Basic
Public Overridable Sub removePerformedLocation
Visual C++
public:
virtual void removePerformedLocation()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepDescription Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepEndDate Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepEndTime Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepID()
Visual Basic
Public Overridable Sub removePerformedProcedureStepID
Visual C++
public:
virtual void removePerformedProcedureStepID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepStartDate Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartDate
Visual C++
public:
virtual void removePerformedProcedureStepStartDate()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepStartTime Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartTime
Visual C++
public:
virtual void removePerformedProcedureStepStartTime()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureStepStatus Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStatus
Visual C++
public:
virtual void removePerformedProcedureStepStatus()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProcedureTypeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProcedureTypeDescription Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Type Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureTypeDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureTypeDescription
Visual C++
public:
virtual void removePerformedProcedureTypeDescription()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedProtocolCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedProtocolCodes Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Protocol Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProtocolCodes()
Visual Basic
Public Overridable Sub removePerformedProtocolCodes
Visual C++
public:
virtual void removePerformedProtocolCodes()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedSeries Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedSeries()
Visual Basic
Public Overridable Sub removePerformedSeries
Visual C++
public:
virtual void removePerformedSeries()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedStationAETitle Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedStationAETitle Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationAETitle()
Visual Basic
Public Overridable Sub removePerformedStationAETitle
Visual C++
public:
virtual void removePerformedStationAETitle()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePerformedStationName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePerformedStationName Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationName()
Visual Basic
Public Overridable Sub removePerformedStationName
Visual C++
public:
virtual void removePerformedStationName()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removePPSDiscontinuationReasonCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removePPSDiscontinuationReasonCodes Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePPSDiscontinuationReasonCodes()
Visual Basic
Public Overridable Sub removePPSDiscontinuationReasonCodes
Visual C++
public:
virtual void removePPSDiscontinuationReasonCodes()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeProcedureCodes Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeReasonForPerformedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeReasonForPerformedProcedureCodes Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForPerformedProcedureCodes()
Visual Basic
Public Overridable Sub removeReasonForPerformedProcedureCodes
Visual C++
public:
virtual void removeReasonForPerformedProcedureCodes()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeReferencedPatients Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeScheduledStepAttributes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeScheduledStepAttributes Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Step Attributes Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStepAttributes()
Visual Basic
Public Overridable Sub removeScheduledStepAttributes
Visual C++
public:
virtual void removeScheduledStepAttributes()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeServiceEpisodeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeServiceEpisodeDescription Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeDescription()
Visual Basic
Public Overridable Sub removeServiceEpisodeDescription
Visual C++
public:
virtual void removeServiceEpisodeDescription()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeServiceEpisodeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeServiceEpisodeID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeID()
Visual Basic
Public Overridable Sub removeServiceEpisodeID
Visual C++
public:
virtual void removeServiceEpisodeID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeSpecificCharacterSets Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeStudyID Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeTotalNumberOfExposures Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeTotalNumberOfExposures Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Total Number of Exposures.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalNumberOfExposures()
Visual Basic
Public Overridable Sub removeTotalNumberOfExposures
Visual C++
public:
virtual void removeTotalNumberOfExposures()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


removeTotalTimeOfFluoroscopy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..removeTotalTimeOfFluoroscopy Method
MCperformedProcedureStepCreate Class See Also Send Feedback
This method removes all the values that may have been set for Total Time of Fluoroscopy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalTimeOfFluoroscopy()
Visual Basic
Public Overridable Sub removeTotalTimeOfFluoroscopy
Visual C++
public:
virtual void removeTotalTimeOfFluoroscopy()

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCperformedProcedureStepCreate Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate Properties
MCperformedProcedureStepCreate Class See Also Send Feedback

The MCperformedProcedureStepCreate type exposes the following members.

Properties

 | Name | Description
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedLocation | Represents the value for the Performed Location attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PerformedStationAETitle | Represents the value for the Performed Station AE Title attribute.
Public property | PerformedStationName | Represents the value for the Performed Station Name attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForPerformedProcedureCodes | Represents the values for the Reason For Performed Procedure Code Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ScheduledStepAttributes | Represents the values for the Scheduled Step Attributes Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepCreate Class
Mergecom.Gen Namespace


AdmissionID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..AdmissionID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Admission ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdmissionID { get; set; }
Visual Basic
Public Overridable Property AdmissionID As String
    Get
    Set
Visual C++
public:
virtual property String^ AdmissionID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


AnatomicStructureSpaceOrRegions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..AnatomicStructureSpaceOrRegions Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Anatomic Structure Space or Region Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCanatomicStructureSpaceOrRegionItem[] AnatomicStructureSpaceOrRegions { get; set; }
Visual Basic
Public Overridable Property AnatomicStructureSpaceOrRegions As MCanatomicStructureSpaceOrRegionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCanatomicStructureSpaceOrRegionItem^>^ AnatomicStructureSpaceOrRegions {
    array<MCanatomicStructureSpaceOrRegionItem^>^ get ();
    void set (array<MCanatomicStructureSpaceOrRegionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


BillingProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..BillingProcedureSteps Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Billing Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingProcedureStepItem[] BillingProcedureSteps { get; set; }
Visual Basic
Public Overridable Property BillingProcedureSteps As MCbillingProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingProcedureStepItem^>^ BillingProcedureSteps {
    array<MCbillingProcedureStepItem^>^ get ();
    void set (array<MCbillingProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


BillingSuppliesAndDevices Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..BillingSuppliesAndDevices Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Billing Supplies and Devices Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingSuppliesAndDevicesItem[] BillingSuppliesAndDevices { get; set; }
Visual Basic
Public Overridable Property BillingSuppliesAndDevices As MCbillingSuppliesAndDevicesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingSuppliesAndDevicesItem^>^ BillingSuppliesAndDevices {
    array<MCbillingSuppliesAndDevicesItem^>^ get ();
    void set (array<MCbillingSuppliesAndDevicesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


CommentsOnRadiationDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..CommentsOnRadiationDose Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Comments on Radiation Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnRadiationDose { get; set; }
Visual Basic
Public Overridable Property CommentsOnRadiationDose As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnRadiationDose {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..CommentsOnThePerformedProcedureSteps Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


DistanceSourceToDetector Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..DistanceSourceToDetector Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Distance Source to Detector attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToDetector { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToDetector As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToDetector {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


DistanceSourceToEntrance Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..DistanceSourceToEntrance Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Distance Source to Entrance attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToEntrance { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToEntrance As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToEntrance {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


EntranceDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..EntranceDose Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Entrance Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort EntranceDose { get; set; }
Visual Basic
Public Overridable Property EntranceDose As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short EntranceDose {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


EntranceDoseInMGy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..EntranceDoseInMGy Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Entrance Dose in mGy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string EntranceDoseInMGy { get; set; }
Visual Basic
Public Overridable Property EntranceDoseInMGy As String
    Get
    Set
Visual C++
public:
virtual property String^ EntranceDoseInMGy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ExposedAreas Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ExposedAreas Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Exposed Area attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort[] ExposedAreas { get; set; }
Visual Basic
Public Overridable Property ExposedAreas As UShort()
    Get
    Set
Visual C++
public:
virtual property array<unsigned short>^ ExposedAreas {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ExposureDoses Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ExposureDoses Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Exposure Dose Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCexposureDoseItem[] ExposureDoses { get; set; }
Visual Basic
Public Overridable Property ExposureDoses As MCexposureDoseItem()
    Get
    Set
Visual C++
public:
virtual property array<MCexposureDoseItem^>^ ExposureDoses {
    array<MCexposureDoseItem^>^ get ();
    void set (array<MCexposureDoseItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


FilmConsumptions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..FilmConsumptions Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Film Consumption Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCfilmConsumptionItem[] FilmConsumptions { get; set; }
Visual Basic
Public Overridable Property FilmConsumptions As MCfilmConsumptionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCfilmConsumptionItem^>^ FilmConsumptions {
    array<MCfilmConsumptionItem^>^ get ();
    void set (array<MCfilmConsumptionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..Host Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ImageAndFluoroscopyAreaDoseProduct Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ImageAndFluoroscopyAreaDoseProduct Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Image and Fluoroscopy Area Dose Product attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ImageAndFluoroscopyAreaDoseProduct { get; set; }
Visual Basic
Public Overridable Property ImageAndFluoroscopyAreaDoseProduct As String
    Get
    Set
Visual C++
public:
virtual property String^ ImageAndFluoroscopyAreaDoseProduct {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfAdmissionIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..IssuerOfAdmissionIDs Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Issuer of Admission ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAdmissionIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfAdmissionIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAdmissionIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfPatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..IssuerOfPatientID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Issuer of Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IssuerOfPatientID { get; set; }
Visual Basic
Public Overridable Property IssuerOfPatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ IssuerOfPatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


IssuerOfServiceEpisodeIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..IssuerOfServiceEpisodeIDs Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Issuer of Service Episode ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfServiceEpisodeIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfServiceEpisodeIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfServiceEpisodeIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..Modality Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PatientID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsBirthDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PatientsBirthDate Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Birth Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PatientsBirthDate { get; set; }
Visual Basic
Public Overridable Property PatientsBirthDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PatientsBirthDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PatientsName Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsName { get; set; }
Visual Basic
Public Overridable Property PatientsName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PatientsSex Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PatientsSex Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Patient's Sex attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSex { get; set; }
Visual Basic
Public Overridable Property PatientsSex As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSex {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedLocation Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedLocation { get; set; }
Visual Basic
Public Overridable Property PerformedLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepDescription Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepEndDate Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepEndTime Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepID { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepStartDate Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepStartDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepStartTime Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepStartTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureStepStatus Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProcedureTypeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProcedureTypeDescription Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Procedure Type Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureTypeDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureTypeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureTypeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedProtocolCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedProtocolCodes Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Protocol Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedProtocolCodes { get; set; }
Visual Basic
Public Overridable Property PerformedProtocolCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedProtocolCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedSeries Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Performed Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCperformedSeriesItem[] PerformedSeries { get; set; }
Visual Basic
Public Overridable Property PerformedSeries As MCperformedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCperformedSeriesItem^>^ PerformedSeries {
    array<MCperformedSeriesItem^>^ get ();
    void set (array<MCperformedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedStationAETitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedStationAETitle Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Station AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedStationAETitle { get; set; }
Visual Basic
Public Overridable Property PerformedStationAETitle As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedStationAETitle {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PerformedStationName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PerformedStationName Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Performed Station Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedStationName { get; set; }
Visual Basic
Public Overridable Property PerformedStationName As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedStationName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


PPSDiscontinuationReasonCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..PPSDiscontinuationReasonCodes Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the PPS Discontinuation Reason Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PPSDiscontinuationReasonCodes { get; set; }
Visual Basic
Public Overridable Property PPSDiscontinuationReasonCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PPSDiscontinuationReasonCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ProcedureCodes Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ReasonForPerformedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ReasonForPerformedProcedureCodes Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Reason For Performed Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ReasonForPerformedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ReasonForPerformedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ReasonForPerformedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ReferencedPatients Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ScheduledStepAttributes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ScheduledStepAttributes Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Scheduled Step Attributes Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCscheduledStepAttributesItem[] ScheduledStepAttributes { get; set; }
Visual Basic
Public Overridable Property ScheduledStepAttributes As MCscheduledStepAttributesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCscheduledStepAttributesItem^>^ ScheduledStepAttributes {
    array<MCscheduledStepAttributesItem^>^ get ();
    void set (array<MCscheduledStepAttributesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ServiceEpisodeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ServiceEpisodeDescription Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Service Episode Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeDescription { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


ServiceEpisodeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..ServiceEpisodeID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Service Episode ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeID { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeID As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..SpecificCharacterSets Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..StudyID Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


TotalNumberOfExposures Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..TotalNumberOfExposures Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Total Number of Exposures attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalNumberOfExposures { get; set; }
Visual Basic
Public Overridable Property TotalNumberOfExposures As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalNumberOfExposures {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


TotalTimeOfFluoroscopy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepCreate..::..TotalTimeOfFluoroscopy Property
MCperformedProcedureStepCreate Class See Also Send Feedback
Represents the value for the Total Time of Fluoroscopy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalTimeOfFluoroscopy { get; set; }
Visual Basic
Public Overridable Property TotalTimeOfFluoroscopy As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalTimeOfFluoroscopy {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepCreate Class
MCperformedProcedureStepCreate Members
Mergecom.Gen Namespace


MCperformedProcedureStepGet Class

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP_RETRIEVE IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCperformedProcedureStepGet
Visual Basic
Public Class MCperformedProcedureStepGet
Visual C++
public ref class MCperformedProcedureStepGet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080060) Modality
  • (00081032) Procedure Code Sequence
  • (00081120) Referenced Patient Sequence
  • (00082229) Anatomic Structure Space or Region Sequence
  • (00100010) Patient's Name
  • (00100020) Patient ID
  • (00100021) Issuer of Patient ID
  • (00100024) Issuer of Patient ID Qualifiers Sequence
  • (00100030) Patient's Birth Date
  • (00100040) Patient's Sex
  • (00181110) Distance Source to Detector
  • (0018115E) Image and Fluoroscopy Area Dose Product
  • (00200010) Study ID
  • (00380010) Admission ID
  • (00380014) Issuer of Admission ID Sequence
  • (00380060) Service Episode ID
  • (00380062) Service Episode Description
  • (00380064) Issuer of Service Episode ID Sequence
  • (00400241) Performed Station AE Title
  • (00400242) Performed Station Name
  • (00400243) Performed Location
  • (00400244) Performed Procedure Step Start Date
  • (00400245) Performed Procedure Step Start Time
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400252) Performed Procedure Step Status
  • (00400253) Performed Procedure Step ID
  • (00400254) Performed Procedure Step Description
  • (00400255) Performed Procedure Type Description
  • (00400260) Performed Protocol Code Sequence
  • (00400270) Scheduled Step Attributes Sequence
  • (00400280) Comments on the Performed Procedure Steps
  • (00400281) PPS Discontinuation Reason Code Sequence
  • (00400300) Total Time of Fluoroscopy
  • (00400301) Total Number of Exposures
  • (00400302) Entrance Dose
  • (00400303) Exposed Area
  • (00400306) Distance Source to Entrance
  • (0040030E) Exposure Dose Sequence
  • (00400310) Comments on Radiation Dose
  • (00400320) Billing Procedure Step Sequence
  • (00400321) Film Consumption Sequence
  • (00400324) Billing Supplies and Devices Sequence
  • (00400340) Performed Series Sequence
  • (00408302) Entrance Dose in mGy

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCperformedProcedureStepGet

See Also

MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


MCperformedProcedureStepGet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Members
MCperformedProcedureStepGet Class Constructors Methods Properties See Also Send Feedback

The MCperformedProcedureStepGet type exposes the following members.

Constructors

 | Name | Description
Public method | MCperformedProcedureStepGet()()()() | Constructs an MCperformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepGet(MCdataSet) | Constructs an MCperformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedLocation | This method removes all the values that may have been set for Performed Location.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePerformedStationAETitle | This method removes all the values that may have been set for Performed Station AE Title.
Public method | removePerformedStationName | This method removes all the values that may have been set for Performed Station Name.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeScheduledStepAttributes | This method removes all the values that may have been set for Scheduled Step Attributes Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedLocation | Represents the value for the Performed Location attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PerformedStationAETitle | Represents the value for the Performed Station AE Title attribute.
Public property | PerformedStationName | Represents the value for the Performed Station Name attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ScheduledStepAttributes | Represents the values for the Scheduled Step Attributes Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepGet Class
Mergecom.Gen Namespace


MCperformedProcedureStepGet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Constructor
MCperformedProcedureStepGet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCperformedProcedureStepGet()()()() | Constructs an MCperformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepGet(MCdataSet) | Constructs an MCperformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


MCperformedProcedureStepGet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Constructor
MCperformedProcedureStepGet Class See Also Send Feedback
Constructs an MCperformedProcedureStepGet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepGet()
Visual Basic
Public Sub New
Visual C++
public:
MCperformedProcedureStepGet()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
MCperformedProcedureStepGet Overload
Mergecom.Gen Namespace


MCperformedProcedureStepGet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Constructor (MCdataSet)
MCperformedProcedureStepGet Class See Also Send Feedback
Constructs an MCperformedProcedureStepGet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepGet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCperformedProcedureStepGet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
MCperformedProcedureStepGet Overload
Mergecom.Gen Namespace


MCperformedProcedureStepGet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Methods
MCperformedProcedureStepGet Class See Also Send Feedback

The MCperformedProcedureStepGet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAdmissionID | This method removes all the values that may have been set for Admission ID.
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removeIssuerOfAdmissionIDs | This method removes all the values that may have been set for Issuer of Admission ID Sequence.
Public method | removeIssuerOfPatientID | This method removes all the values that may have been set for Issuer of Patient ID.
Public method | removeIssuerOfServiceEpisodeIDs | This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removePatientsBirthDate | This method removes all the values that may have been set for Patient's Birth Date.
Public method | removePatientsName | This method removes all the values that may have been set for Patient's Name.
Public method | removePatientsSex | This method removes all the values that may have been set for Patient's Sex.
Public method | removePerformedLocation | This method removes all the values that may have been set for Performed Location.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepID | This method removes all the values that may have been set for Performed Procedure Step ID.
Public method | removePerformedProcedureStepStartDate | This method removes all the values that may have been set for Performed Procedure Step Start Date.
Public method | removePerformedProcedureStepStartTime | This method removes all the values that may have been set for Performed Procedure Step Start Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePerformedStationAETitle | This method removes all the values that may have been set for Performed Station AE Title.
Public method | removePerformedStationName | This method removes all the values that may have been set for Performed Station Name.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeScheduledStepAttributes | This method removes all the values that may have been set for Scheduled Step Attributes Sequence.
Public method | removeServiceEpisodeDescription | This method removes all the values that may have been set for Service Episode Description.
Public method | removeServiceEpisodeID | This method removes all the values that may have been set for Service Episode ID.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCperformedProcedureStepGet Class
Mergecom.Gen Namespace


removeAdmissionID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeAdmissionID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Admission ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAdmissionID()
Visual Basic
Public Overridable Sub removeAdmissionID
Visual C++
public:
virtual void removeAdmissionID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeAnatomicStructureSpaceOrRegions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeAnatomicStructureSpaceOrRegions Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAnatomicStructureSpaceOrRegions()
Visual Basic
Public Overridable Sub removeAnatomicStructureSpaceOrRegions
Visual C++
public:
virtual void removeAnatomicStructureSpaceOrRegions()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeBillingProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeBillingProcedureSteps Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Billing Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingProcedureSteps()
Visual Basic
Public Overridable Sub removeBillingProcedureSteps
Visual C++
public:
virtual void removeBillingProcedureSteps()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeBillingSuppliesAndDevices Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeBillingSuppliesAndDevices Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Billing Supplies and Devices Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingSuppliesAndDevices()
Visual Basic
Public Overridable Sub removeBillingSuppliesAndDevices
Visual C++
public:
virtual void removeBillingSuppliesAndDevices()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeCommentsOnRadiationDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeCommentsOnRadiationDose Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on Radiation Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnRadiationDose()
Visual Basic
Public Overridable Sub removeCommentsOnRadiationDose
Visual C++
public:
virtual void removeCommentsOnRadiationDose()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeCommentsOnThePerformedProcedureSteps Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeDistanceSourceToDetector Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeDistanceSourceToDetector Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Detector.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToDetector()
Visual Basic
Public Overridable Sub removeDistanceSourceToDetector
Visual C++
public:
virtual void removeDistanceSourceToDetector()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeDistanceSourceToEntrance Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeDistanceSourceToEntrance Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Entrance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToEntrance()
Visual Basic
Public Overridable Sub removeDistanceSourceToEntrance
Visual C++
public:
virtual void removeDistanceSourceToEntrance()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeEntranceDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeEntranceDose Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDose()
Visual Basic
Public Overridable Sub removeEntranceDose
Visual C++
public:
virtual void removeEntranceDose()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeEntranceDoseInMGy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeEntranceDoseInMGy Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose in mGy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDoseInMGy()
Visual Basic
Public Overridable Sub removeEntranceDoseInMGy
Visual C++
public:
virtual void removeEntranceDoseInMGy()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeExposedAreas Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeExposedAreas Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Exposed Area.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposedAreas()
Visual Basic
Public Overridable Sub removeExposedAreas
Visual C++
public:
virtual void removeExposedAreas()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeExposureDoses Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeExposureDoses Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Exposure Dose Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposureDoses()
Visual Basic
Public Overridable Sub removeExposureDoses
Visual C++
public:
virtual void removeExposureDoses()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeFilmConsumptions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeFilmConsumptions Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Film Consumption Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilmConsumptions()
Visual Basic
Public Overridable Sub removeFilmConsumptions
Visual C++
public:
virtual void removeFilmConsumptions()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeImageAndFluoroscopyAreaDoseProduct Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeImageAndFluoroscopyAreaDoseProduct Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeImageAndFluoroscopyAreaDoseProduct()
Visual Basic
Public Overridable Sub removeImageAndFluoroscopyAreaDoseProduct
Visual C++
public:
virtual void removeImageAndFluoroscopyAreaDoseProduct()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfAdmissionIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeIssuerOfAdmissionIDs Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Admission ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAdmissionIDs()
Visual Basic
Public Overridable Sub removeIssuerOfAdmissionIDs
Visual C++
public:
virtual void removeIssuerOfAdmissionIDs()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfPatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeIssuerOfPatientID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfPatientID()
Visual Basic
Public Overridable Sub removeIssuerOfPatientID
Visual C++
public:
virtual void removeIssuerOfPatientID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeIssuerOfServiceEpisodeIDs Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeIssuerOfServiceEpisodeIDs Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Service Episode ID Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfServiceEpisodeIDs()
Visual Basic
Public Overridable Sub removeIssuerOfServiceEpisodeIDs
Visual C++
public:
virtual void removeIssuerOfServiceEpisodeIDs()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeModality Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePatientID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsBirthDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePatientsBirthDate Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Birth Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsBirthDate()
Visual Basic
Public Overridable Sub removePatientsBirthDate
Visual C++
public:
virtual void removePatientsBirthDate()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePatientsName Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsName()
Visual Basic
Public Overridable Sub removePatientsName
Visual C++
public:
virtual void removePatientsName()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePatientsSex Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePatientsSex Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Patient's Sex.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientsSex()
Visual Basic
Public Overridable Sub removePatientsSex
Visual C++
public:
virtual void removePatientsSex()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedLocation Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedLocation()
Visual Basic
Public Overridable Sub removePerformedLocation
Visual C++
public:
virtual void removePerformedLocation()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepDescription Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepEndDate Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepEndTime Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepID()
Visual Basic
Public Overridable Sub removePerformedProcedureStepID
Visual C++
public:
virtual void removePerformedProcedureStepID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepStartDate Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartDate
Visual C++
public:
virtual void removePerformedProcedureStepStartDate()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepStartTime Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStartTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStartTime
Visual C++
public:
virtual void removePerformedProcedureStepStartTime()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureStepStatus Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStatus
Visual C++
public:
virtual void removePerformedProcedureStepStatus()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProcedureTypeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProcedureTypeDescription Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Type Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureTypeDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureTypeDescription
Visual C++
public:
virtual void removePerformedProcedureTypeDescription()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedProtocolCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedProtocolCodes Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Protocol Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProtocolCodes()
Visual Basic
Public Overridable Sub removePerformedProtocolCodes
Visual C++
public:
virtual void removePerformedProtocolCodes()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedSeries Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedSeries()
Visual Basic
Public Overridable Sub removePerformedSeries
Visual C++
public:
virtual void removePerformedSeries()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedStationAETitle Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedStationAETitle Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationAETitle()
Visual Basic
Public Overridable Sub removePerformedStationAETitle
Visual C++
public:
virtual void removePerformedStationAETitle()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePerformedStationName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePerformedStationName Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Station Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedStationName()
Visual Basic
Public Overridable Sub removePerformedStationName
Visual C++
public:
virtual void removePerformedStationName()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removePPSDiscontinuationReasonCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removePPSDiscontinuationReasonCodes Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePPSDiscontinuationReasonCodes()
Visual Basic
Public Overridable Sub removePPSDiscontinuationReasonCodes
Visual C++
public:
virtual void removePPSDiscontinuationReasonCodes()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeProcedureCodes Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeReferencedPatients Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeScheduledStepAttributes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeScheduledStepAttributes Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Step Attributes Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStepAttributes()
Visual Basic
Public Overridable Sub removeScheduledStepAttributes
Visual C++
public:
virtual void removeScheduledStepAttributes()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeServiceEpisodeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeServiceEpisodeDescription Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeDescription()
Visual Basic
Public Overridable Sub removeServiceEpisodeDescription
Visual C++
public:
virtual void removeServiceEpisodeDescription()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeServiceEpisodeID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeServiceEpisodeID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Service Episode ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeServiceEpisodeID()
Visual Basic
Public Overridable Sub removeServiceEpisodeID
Visual C++
public:
virtual void removeServiceEpisodeID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeSpecificCharacterSets Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeStudyID Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeTotalNumberOfExposures Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeTotalNumberOfExposures Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Total Number of Exposures.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalNumberOfExposures()
Visual Basic
Public Overridable Sub removeTotalNumberOfExposures
Visual C++
public:
virtual void removeTotalNumberOfExposures()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


removeTotalTimeOfFluoroscopy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..removeTotalTimeOfFluoroscopy Method
MCperformedProcedureStepGet Class See Also Send Feedback
This method removes all the values that may have been set for Total Time of Fluoroscopy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalTimeOfFluoroscopy()
Visual Basic
Public Overridable Sub removeTotalTimeOfFluoroscopy
Visual C++
public:
virtual void removeTotalTimeOfFluoroscopy()

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


MCperformedProcedureStepGet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet Properties
MCperformedProcedureStepGet Class See Also Send Feedback

The MCperformedProcedureStepGet type exposes the following members.

Properties

 | Name | Description
Public property | AdmissionID | Represents the value for the Admission ID attribute.
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | IssuerOfAdmissionIDs | Represents the values for the Issuer of Admission ID Sequence attribute.
Public property | IssuerOfPatientID | Represents the value for the Issuer of Patient ID attribute.
Public property | IssuerOfServiceEpisodeIDs | Represents the values for the Issuer of Service Episode ID Sequence attribute.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | PatientsBirthDate | Represents the value for the Patient's Birth Date attribute.
Public property | PatientsName | Represents the value for the Patient's Name attribute.
Public property | PatientsSex | Represents the value for the Patient's Sex attribute.
Public property | PerformedLocation | Represents the value for the Performed Location attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepID | Represents the value for the Performed Procedure Step ID attribute.
Public property | PerformedProcedureStepStartDate | Represents the value for the Performed Procedure Step Start Date attribute.
Public property | PerformedProcedureStepStartTime | Represents the value for the Performed Procedure Step Start Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PerformedStationAETitle | Represents the value for the Performed Station AE Title attribute.
Public property | PerformedStationName | Represents the value for the Performed Station Name attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ScheduledStepAttributes | Represents the values for the Scheduled Step Attributes Sequence attribute.
Public property | ServiceEpisodeDescription | Represents the value for the Service Episode Description attribute.
Public property | ServiceEpisodeID | Represents the value for the Service Episode ID attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepGet Class
Mergecom.Gen Namespace


AdmissionID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..AdmissionID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Admission ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AdmissionID { get; set; }
Visual Basic
Public Overridable Property AdmissionID As String
    Get
    Set
Visual C++
public:
virtual property String^ AdmissionID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


AnatomicStructureSpaceOrRegions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..AnatomicStructureSpaceOrRegions Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Anatomic Structure Space or Region Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCanatomicStructureSpaceOrRegionItem[] AnatomicStructureSpaceOrRegions { get; set; }
Visual Basic
Public Overridable Property AnatomicStructureSpaceOrRegions As MCanatomicStructureSpaceOrRegionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCanatomicStructureSpaceOrRegionItem^>^ AnatomicStructureSpaceOrRegions {
    array<MCanatomicStructureSpaceOrRegionItem^>^ get ();
    void set (array<MCanatomicStructureSpaceOrRegionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


BillingProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..BillingProcedureSteps Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Billing Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingProcedureStepItem[] BillingProcedureSteps { get; set; }
Visual Basic
Public Overridable Property BillingProcedureSteps As MCbillingProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingProcedureStepItem^>^ BillingProcedureSteps {
    array<MCbillingProcedureStepItem^>^ get ();
    void set (array<MCbillingProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


BillingSuppliesAndDevices Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..BillingSuppliesAndDevices Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Billing Supplies and Devices Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingSuppliesAndDevicesItem[] BillingSuppliesAndDevices { get; set; }
Visual Basic
Public Overridable Property BillingSuppliesAndDevices As MCbillingSuppliesAndDevicesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingSuppliesAndDevicesItem^>^ BillingSuppliesAndDevices {
    array<MCbillingSuppliesAndDevicesItem^>^ get ();
    void set (array<MCbillingSuppliesAndDevicesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


CommentsOnRadiationDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..CommentsOnRadiationDose Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Comments on Radiation Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnRadiationDose { get; set; }
Visual Basic
Public Overridable Property CommentsOnRadiationDose As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnRadiationDose {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..CommentsOnThePerformedProcedureSteps Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


DistanceSourceToDetector Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..DistanceSourceToDetector Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Distance Source to Detector attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToDetector { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToDetector As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToDetector {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


DistanceSourceToEntrance Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..DistanceSourceToEntrance Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Distance Source to Entrance attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToEntrance { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToEntrance As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToEntrance {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


EntranceDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..EntranceDose Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Entrance Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort EntranceDose { get; set; }
Visual Basic
Public Overridable Property EntranceDose As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short EntranceDose {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


EntranceDoseInMGy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..EntranceDoseInMGy Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Entrance Dose in mGy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string EntranceDoseInMGy { get; set; }
Visual Basic
Public Overridable Property EntranceDoseInMGy As String
    Get
    Set
Visual C++
public:
virtual property String^ EntranceDoseInMGy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ExposedAreas Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ExposedAreas Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Exposed Area attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort[] ExposedAreas { get; set; }
Visual Basic
Public Overridable Property ExposedAreas As UShort()
    Get
    Set
Visual C++
public:
virtual property array<unsigned short>^ ExposedAreas {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ExposureDoses Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ExposureDoses Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Exposure Dose Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCexposureDoseItem[] ExposureDoses { get; set; }
Visual Basic
Public Overridable Property ExposureDoses As MCexposureDoseItem()
    Get
    Set
Visual C++
public:
virtual property array<MCexposureDoseItem^>^ ExposureDoses {
    array<MCexposureDoseItem^>^ get ();
    void set (array<MCexposureDoseItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


FilmConsumptions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..FilmConsumptions Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Film Consumption Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCfilmConsumptionItem[] FilmConsumptions { get; set; }
Visual Basic
Public Overridable Property FilmConsumptions As MCfilmConsumptionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCfilmConsumptionItem^>^ FilmConsumptions {
    array<MCfilmConsumptionItem^>^ get ();
    void set (array<MCfilmConsumptionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..Host Property
MCperformedProcedureStepGet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ImageAndFluoroscopyAreaDoseProduct Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ImageAndFluoroscopyAreaDoseProduct Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Image and Fluoroscopy Area Dose Product attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ImageAndFluoroscopyAreaDoseProduct { get; set; }
Visual Basic
Public Overridable Property ImageAndFluoroscopyAreaDoseProduct As String
    Get
    Set
Visual C++
public:
virtual property String^ ImageAndFluoroscopyAreaDoseProduct {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfAdmissionIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..IssuerOfAdmissionIDs Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Issuer of Admission ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAdmissionIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfAdmissionIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAdmissionIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfPatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..IssuerOfPatientID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Issuer of Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string IssuerOfPatientID { get; set; }
Visual Basic
Public Overridable Property IssuerOfPatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ IssuerOfPatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


IssuerOfServiceEpisodeIDs Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..IssuerOfServiceEpisodeIDs Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Issuer of Service Episode ID Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfServiceEpisodeIDs { get; set; }
Visual Basic
Public Overridable Property IssuerOfServiceEpisodeIDs As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfServiceEpisodeIDs {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..Modality Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PatientID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsBirthDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PatientsBirthDate Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Birth Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PatientsBirthDate { get; set; }
Visual Basic
Public Overridable Property PatientsBirthDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PatientsBirthDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PatientsName Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PatientsName { get; set; }
Visual Basic
Public Overridable Property PatientsName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PatientsName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PatientsSex Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PatientsSex Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Patient's Sex attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientsSex { get; set; }
Visual Basic
Public Overridable Property PatientsSex As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientsSex {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedLocation Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedLocation { get; set; }
Visual Basic
Public Overridable Property PerformedLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepDescription Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepEndDate Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepEndTime Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepID { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepStartDate Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepStartDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepStartTime Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepStartTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureStepStatus Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProcedureTypeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProcedureTypeDescription Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Procedure Type Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureTypeDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureTypeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureTypeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedProtocolCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedProtocolCodes Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Protocol Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedProtocolCodes { get; set; }
Visual Basic
Public Overridable Property PerformedProtocolCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedProtocolCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedSeries Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Performed Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCperformedSeriesItem[] PerformedSeries { get; set; }
Visual Basic
Public Overridable Property PerformedSeries As MCperformedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCperformedSeriesItem^>^ PerformedSeries {
    array<MCperformedSeriesItem^>^ get ();
    void set (array<MCperformedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedStationAETitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedStationAETitle Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Station AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedStationAETitle { get; set; }
Visual Basic
Public Overridable Property PerformedStationAETitle As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedStationAETitle {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PerformedStationName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PerformedStationName Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Performed Station Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedStationName { get; set; }
Visual Basic
Public Overridable Property PerformedStationName As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedStationName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


PPSDiscontinuationReasonCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..PPSDiscontinuationReasonCodes Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the PPS Discontinuation Reason Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PPSDiscontinuationReasonCodes { get; set; }
Visual Basic
Public Overridable Property PPSDiscontinuationReasonCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PPSDiscontinuationReasonCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ProcedureCodes Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ReferencedPatients Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ScheduledStepAttributes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ScheduledStepAttributes Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Scheduled Step Attributes Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCscheduledStepAttributesItem[] ScheduledStepAttributes { get; set; }
Visual Basic
Public Overridable Property ScheduledStepAttributes As MCscheduledStepAttributesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCscheduledStepAttributesItem^>^ ScheduledStepAttributes {
    array<MCscheduledStepAttributesItem^>^ get ();
    void set (array<MCscheduledStepAttributesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ServiceEpisodeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ServiceEpisodeDescription Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Service Episode Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeDescription { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


ServiceEpisodeID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..ServiceEpisodeID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Service Episode ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ServiceEpisodeID { get; set; }
Visual Basic
Public Overridable Property ServiceEpisodeID As String
    Get
    Set
Visual C++
public:
virtual property String^ ServiceEpisodeID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..SpecificCharacterSets Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..StudyID Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


TotalNumberOfExposures Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..TotalNumberOfExposures Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Total Number of Exposures attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalNumberOfExposures { get; set; }
Visual Basic
Public Overridable Property TotalNumberOfExposures As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalNumberOfExposures {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


TotalTimeOfFluoroscopy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepGet..::..TotalTimeOfFluoroscopy Property
MCperformedProcedureStepGet Class See Also Send Feedback
Represents the value for the Total Time of Fluoroscopy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalTimeOfFluoroscopy { get; set; }
Visual Basic
Public Overridable Property TotalTimeOfFluoroscopy As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalTimeOfFluoroscopy {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepGet Class
MCperformedProcedureStepGet Members
Mergecom.Gen Namespace


MCperformedProcedureStepSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERFORMED_PROCEDURE_STEP IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCperformedProcedureStepSet
Visual Basic
Public Class MCperformedProcedureStepSet
Visual C++
public ref class MCperformedProcedureStepSet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081032) Procedure Code Sequence
  • (00082229) Anatomic Structure Space or Region Sequence
  • (00181110) Distance Source to Detector
  • (0018115E) Image and Fluoroscopy Area Dose Product
  • (00400250) Performed Procedure Step End Date
  • (00400251) Performed Procedure Step End Time
  • (00400252) Performed Procedure Step Status
  • (00400254) Performed Procedure Step Description
  • (00400255) Performed Procedure Type Description
  • (00400260) Performed Protocol Code Sequence
  • (00400280) Comments on the Performed Procedure Steps
  • (00400281) PPS Discontinuation Reason Code Sequence
  • (00400300) Total Time of Fluoroscopy
  • (00400301) Total Number of Exposures
  • (00400302) Entrance Dose
  • (00400303) Exposed Area
  • (00400306) Distance Source to Entrance
  • (0040030E) Exposure Dose Sequence
  • (00400310) Comments on Radiation Dose
  • (00400320) Billing Procedure Step Sequence
  • (00400321) Film Consumption Sequence
  • (00400324) Billing Supplies and Devices Sequence
  • (00400340) Performed Series Sequence
  • (00401012) Reason For Performed Procedure Code Sequence
  • (00408302) Entrance Dose in mGy

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCperformedProcedureStepSet

See Also

MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


MCperformedProcedureStepSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Members
MCperformedProcedureStepSet Class Constructors Methods Properties See Also Send Feedback

The MCperformedProcedureStepSet type exposes the following members.

Constructors

 | Name | Description
Public method | MCperformedProcedureStepSet()()()() | Constructs an MCperformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepSet(MCdataSet) | Constructs an MCperformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForPerformedProcedureCodes | This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForPerformedProcedureCodes | Represents the values for the Reason For Performed Procedure Code Sequence attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepSet Class
Mergecom.Gen Namespace


MCperformedProcedureStepSet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Constructor
MCperformedProcedureStepSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCperformedProcedureStepSet()()()() | Constructs an MCperformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCperformedProcedureStepSet(MCdataSet) | Constructs an MCperformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


MCperformedProcedureStepSet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Constructor
MCperformedProcedureStepSet Class See Also Send Feedback
Constructs an MCperformedProcedureStepSet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepSet()
Visual Basic
Public Sub New
Visual C++
public:
MCperformedProcedureStepSet()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
MCperformedProcedureStepSet Overload
Mergecom.Gen Namespace


MCperformedProcedureStepSet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Constructor (MCdataSet)
MCperformedProcedureStepSet Class See Also Send Feedback
Constructs an MCperformedProcedureStepSet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcedureStepSet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCperformedProcedureStepSet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
MCperformedProcedureStepSet Overload
Mergecom.Gen Namespace


MCperformedProcedureStepSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Methods
MCperformedProcedureStepSet Class See Also Send Feedback

The MCperformedProcedureStepSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAnatomicStructureSpaceOrRegions | This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.
Public method | removeBillingProcedureSteps | This method removes all the values that may have been set for Billing Procedure Step Sequence.
Public method | removeBillingSuppliesAndDevices | This method removes all the values that may have been set for Billing Supplies and Devices Sequence.
Public method | removeCommentsOnRadiationDose | This method removes all the values that may have been set for Comments on Radiation Dose.
Public method | removeCommentsOnThePerformedProcedureSteps | This method removes all the values that may have been set for Comments on the Performed Procedure Steps.
Public method | removeDistanceSourceToDetector | This method removes all the values that may have been set for Distance Source to Detector.
Public method | removeDistanceSourceToEntrance | This method removes all the values that may have been set for Distance Source to Entrance.
Public method | removeEntranceDose | This method removes all the values that may have been set for Entrance Dose.
Public method | removeEntranceDoseInMGy | This method removes all the values that may have been set for Entrance Dose in mGy.
Public method | removeExposedAreas | This method removes all the values that may have been set for Exposed Area.
Public method | removeExposureDoses | This method removes all the values that may have been set for Exposure Dose Sequence.
Public method | removeFilmConsumptions | This method removes all the values that may have been set for Film Consumption Sequence.
Public method | removeImageAndFluoroscopyAreaDoseProduct | This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.
Public method | removePerformedProcedureStepDescription | This method removes all the values that may have been set for Performed Procedure Step Description.
Public method | removePerformedProcedureStepEndDate | This method removes all the values that may have been set for Performed Procedure Step End Date.
Public method | removePerformedProcedureStepEndTime | This method removes all the values that may have been set for Performed Procedure Step End Time.
Public method | removePerformedProcedureStepStatus | This method removes all the values that may have been set for Performed Procedure Step Status.
Public method | removePerformedProcedureTypeDescription | This method removes all the values that may have been set for Performed Procedure Type Description.
Public method | removePerformedProtocolCodes | This method removes all the values that may have been set for Performed Protocol Code Sequence.
Public method | removePerformedSeries | This method removes all the values that may have been set for Performed Series Sequence.
Public method | removePPSDiscontinuationReasonCodes | This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForPerformedProcedureCodes | This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.
Public method | removeTotalNumberOfExposures | This method removes all the values that may have been set for Total Number of Exposures.
Public method | removeTotalTimeOfFluoroscopy | This method removes all the values that may have been set for Total Time of Fluoroscopy.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCperformedProcedureStepSet Class
Mergecom.Gen Namespace


removeAnatomicStructureSpaceOrRegions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeAnatomicStructureSpaceOrRegions Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Anatomic Structure Space or Region Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAnatomicStructureSpaceOrRegions()
Visual Basic
Public Overridable Sub removeAnatomicStructureSpaceOrRegions
Visual C++
public:
virtual void removeAnatomicStructureSpaceOrRegions()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeBillingProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeBillingProcedureSteps Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Billing Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingProcedureSteps()
Visual Basic
Public Overridable Sub removeBillingProcedureSteps
Visual C++
public:
virtual void removeBillingProcedureSteps()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeBillingSuppliesAndDevices Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeBillingSuppliesAndDevices Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Billing Supplies and Devices Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeBillingSuppliesAndDevices()
Visual Basic
Public Overridable Sub removeBillingSuppliesAndDevices
Visual C++
public:
virtual void removeBillingSuppliesAndDevices()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeCommentsOnRadiationDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeCommentsOnRadiationDose Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on Radiation Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnRadiationDose()
Visual Basic
Public Overridable Sub removeCommentsOnRadiationDose
Visual C++
public:
virtual void removeCommentsOnRadiationDose()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeCommentsOnThePerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeCommentsOnThePerformedProcedureSteps Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Performed Procedure Steps.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnThePerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeCommentsOnThePerformedProcedureSteps
Visual C++
public:
virtual void removeCommentsOnThePerformedProcedureSteps()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeDistanceSourceToDetector Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeDistanceSourceToDetector Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Detector.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToDetector()
Visual Basic
Public Overridable Sub removeDistanceSourceToDetector
Visual C++
public:
virtual void removeDistanceSourceToDetector()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeDistanceSourceToEntrance Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeDistanceSourceToEntrance Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Distance Source to Entrance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDistanceSourceToEntrance()
Visual Basic
Public Overridable Sub removeDistanceSourceToEntrance
Visual C++
public:
virtual void removeDistanceSourceToEntrance()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeEntranceDose Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeEntranceDose Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDose()
Visual Basic
Public Overridable Sub removeEntranceDose
Visual C++
public:
virtual void removeEntranceDose()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeEntranceDoseInMGy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeEntranceDoseInMGy Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Entrance Dose in mGy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeEntranceDoseInMGy()
Visual Basic
Public Overridable Sub removeEntranceDoseInMGy
Visual C++
public:
virtual void removeEntranceDoseInMGy()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeExposedAreas Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeExposedAreas Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Exposed Area.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposedAreas()
Visual Basic
Public Overridable Sub removeExposedAreas
Visual C++
public:
virtual void removeExposedAreas()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeExposureDoses Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeExposureDoses Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Exposure Dose Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeExposureDoses()
Visual Basic
Public Overridable Sub removeExposureDoses
Visual C++
public:
virtual void removeExposureDoses()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeFilmConsumptions Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeFilmConsumptions Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Film Consumption Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFilmConsumptions()
Visual Basic
Public Overridable Sub removeFilmConsumptions
Visual C++
public:
virtual void removeFilmConsumptions()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeImageAndFluoroscopyAreaDoseProduct Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeImageAndFluoroscopyAreaDoseProduct Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Image and Fluoroscopy Area Dose Product.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeImageAndFluoroscopyAreaDoseProduct()
Visual Basic
Public Overridable Sub removeImageAndFluoroscopyAreaDoseProduct
Visual C++
public:
virtual void removeImageAndFluoroscopyAreaDoseProduct()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProcedureStepDescription Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureStepDescription
Visual C++
public:
virtual void removePerformedProcedureStepDescription()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProcedureStepEndDate Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndDate()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndDate
Visual C++
public:
virtual void removePerformedProcedureStepEndDate()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProcedureStepEndTime Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepEndTime()
Visual Basic
Public Overridable Sub removePerformedProcedureStepEndTime
Visual C++
public:
virtual void removePerformedProcedureStepEndTime()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProcedureStepStatus Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureStepStatus()
Visual Basic
Public Overridable Sub removePerformedProcedureStepStatus
Visual C++
public:
virtual void removePerformedProcedureStepStatus()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProcedureTypeDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProcedureTypeDescription Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Procedure Type Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProcedureTypeDescription()
Visual Basic
Public Overridable Sub removePerformedProcedureTypeDescription
Visual C++
public:
virtual void removePerformedProcedureTypeDescription()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedProtocolCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedProtocolCodes Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Protocol Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedProtocolCodes()
Visual Basic
Public Overridable Sub removePerformedProtocolCodes
Visual C++
public:
virtual void removePerformedProtocolCodes()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePerformedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePerformedSeries Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Performed Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformedSeries()
Visual Basic
Public Overridable Sub removePerformedSeries
Visual C++
public:
virtual void removePerformedSeries()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removePPSDiscontinuationReasonCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removePPSDiscontinuationReasonCodes Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for PPS Discontinuation Reason Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePPSDiscontinuationReasonCodes()
Visual Basic
Public Overridable Sub removePPSDiscontinuationReasonCodes
Visual C++
public:
virtual void removePPSDiscontinuationReasonCodes()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeProcedureCodes Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeReasonForPerformedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeReasonForPerformedProcedureCodes Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Reason For Performed Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForPerformedProcedureCodes()
Visual Basic
Public Overridable Sub removeReasonForPerformedProcedureCodes
Visual C++
public:
virtual void removeReasonForPerformedProcedureCodes()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeTotalNumberOfExposures Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeTotalNumberOfExposures Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Total Number of Exposures.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalNumberOfExposures()
Visual Basic
Public Overridable Sub removeTotalNumberOfExposures
Visual C++
public:
virtual void removeTotalNumberOfExposures()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


removeTotalTimeOfFluoroscopy Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..removeTotalTimeOfFluoroscopy Method
MCperformedProcedureStepSet Class See Also Send Feedback
This method removes all the values that may have been set for Total Time of Fluoroscopy.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTotalTimeOfFluoroscopy()
Visual Basic
Public Overridable Sub removeTotalTimeOfFluoroscopy
Visual C++
public:
virtual void removeTotalTimeOfFluoroscopy()

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


MCperformedProcedureStepSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet Properties
MCperformedProcedureStepSet Class See Also Send Feedback

The MCperformedProcedureStepSet type exposes the following members.

Properties

 | Name | Description
Public property | AnatomicStructureSpaceOrRegions | Represents the values for the Anatomic Structure Space or Region Sequence attribute.
Public property | BillingProcedureSteps | Represents the values for the Billing Procedure Step Sequence attribute.
Public property | BillingSuppliesAndDevices | Represents the values for the Billing Supplies and Devices Sequence attribute.
Public property | CommentsOnRadiationDose | Represents the value for the Comments on Radiation Dose attribute.
Public property | CommentsOnThePerformedProcedureSteps | Represents the value for the Comments on the Performed Procedure Steps attribute.
Public property | DistanceSourceToDetector | Represents the value for the Distance Source to Detector attribute.
Public property | DistanceSourceToEntrance | Represents the value for the Distance Source to Entrance attribute.
Public property | EntranceDose | Represents the value for the Entrance Dose attribute.
Public property | EntranceDoseInMGy | Represents the value for the Entrance Dose in mGy attribute.
Public property | ExposedAreas | Represents the values for the Exposed Area attribute.
Public property | ExposureDoses | Represents the values for the Exposure Dose Sequence attribute.
Public property | FilmConsumptions | Represents the values for the Film Consumption Sequence attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ImageAndFluoroscopyAreaDoseProduct | Represents the value for the Image and Fluoroscopy Area Dose Product attribute.
Public property | PerformedProcedureStepDescription | Represents the value for the Performed Procedure Step Description attribute.
Public property | PerformedProcedureStepEndDate | Represents the value for the Performed Procedure Step End Date attribute.
Public property | PerformedProcedureStepEndTime | Represents the value for the Performed Procedure Step End Time attribute.
Public property | PerformedProcedureStepStatus | Represents the value for the Performed Procedure Step Status attribute.
Public property | PerformedProcedureTypeDescription | Represents the value for the Performed Procedure Type Description attribute.
Public property | PerformedProtocolCodes | Represents the values for the Performed Protocol Code Sequence attribute.
Public property | PerformedSeries | Represents the values for the Performed Series Sequence attribute.
Public property | PPSDiscontinuationReasonCodes | Represents the values for the PPS Discontinuation Reason Code Sequence attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForPerformedProcedureCodes | Represents the values for the Reason For Performed Procedure Code Sequence attribute.
Public property | TotalNumberOfExposures | Represents the value for the Total Number of Exposures attribute.
Public property | TotalTimeOfFluoroscopy | Represents the value for the Total Time of Fluoroscopy attribute.

See Also

MCperformedProcedureStepSet Class
Mergecom.Gen Namespace


AnatomicStructureSpaceOrRegions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..AnatomicStructureSpaceOrRegions Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Anatomic Structure Space or Region Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCanatomicStructureSpaceOrRegionItem[] AnatomicStructureSpaceOrRegions { get; set; }
Visual Basic
Public Overridable Property AnatomicStructureSpaceOrRegions As MCanatomicStructureSpaceOrRegionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCanatomicStructureSpaceOrRegionItem^>^ AnatomicStructureSpaceOrRegions {
    array<MCanatomicStructureSpaceOrRegionItem^>^ get ();
    void set (array<MCanatomicStructureSpaceOrRegionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


BillingProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..BillingProcedureSteps Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Billing Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingProcedureStepItem[] BillingProcedureSteps { get; set; }
Visual Basic
Public Overridable Property BillingProcedureSteps As MCbillingProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingProcedureStepItem^>^ BillingProcedureSteps {
    array<MCbillingProcedureStepItem^>^ get ();
    void set (array<MCbillingProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


BillingSuppliesAndDevices Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..BillingSuppliesAndDevices Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Billing Supplies and Devices Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCbillingSuppliesAndDevicesItem[] BillingSuppliesAndDevices { get; set; }
Visual Basic
Public Overridable Property BillingSuppliesAndDevices As MCbillingSuppliesAndDevicesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCbillingSuppliesAndDevicesItem^>^ BillingSuppliesAndDevices {
    array<MCbillingSuppliesAndDevicesItem^>^ get ();
    void set (array<MCbillingSuppliesAndDevicesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


CommentsOnRadiationDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..CommentsOnRadiationDose Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Comments on Radiation Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnRadiationDose { get; set; }
Visual Basic
Public Overridable Property CommentsOnRadiationDose As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnRadiationDose {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


CommentsOnThePerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..CommentsOnThePerformedProcedureSteps Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Comments on the Performed Procedure Steps attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnThePerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property CommentsOnThePerformedProcedureSteps As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnThePerformedProcedureSteps {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


DistanceSourceToDetector Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..DistanceSourceToDetector Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Distance Source to Detector attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToDetector { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToDetector As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToDetector {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


DistanceSourceToEntrance Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..DistanceSourceToEntrance Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Distance Source to Entrance attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DistanceSourceToEntrance { get; set; }
Visual Basic
Public Overridable Property DistanceSourceToEntrance As String
    Get
    Set
Visual C++
public:
virtual property String^ DistanceSourceToEntrance {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


EntranceDose Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..EntranceDose Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Entrance Dose attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort EntranceDose { get; set; }
Visual Basic
Public Overridable Property EntranceDose As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short EntranceDose {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


EntranceDoseInMGy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..EntranceDoseInMGy Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Entrance Dose in mGy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string EntranceDoseInMGy { get; set; }
Visual Basic
Public Overridable Property EntranceDoseInMGy As String
    Get
    Set
Visual C++
public:
virtual property String^ EntranceDoseInMGy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


ExposedAreas Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..ExposedAreas Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Exposed Area attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort[] ExposedAreas { get; set; }
Visual Basic
Public Overridable Property ExposedAreas As UShort()
    Get
    Set
Visual C++
public:
virtual property array<unsigned short>^ ExposedAreas {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


ExposureDoses Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..ExposureDoses Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Exposure Dose Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCexposureDoseItem[] ExposureDoses { get; set; }
Visual Basic
Public Overridable Property ExposureDoses As MCexposureDoseItem()
    Get
    Set
Visual C++
public:
virtual property array<MCexposureDoseItem^>^ ExposureDoses {
    array<MCexposureDoseItem^>^ get ();
    void set (array<MCexposureDoseItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


FilmConsumptions Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..FilmConsumptions Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Film Consumption Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCfilmConsumptionItem[] FilmConsumptions { get; set; }
Visual Basic
Public Overridable Property FilmConsumptions As MCfilmConsumptionItem()
    Get
    Set
Visual C++
public:
virtual property array<MCfilmConsumptionItem^>^ FilmConsumptions {
    array<MCfilmConsumptionItem^>^ get ();
    void set (array<MCfilmConsumptionItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..Host Property
MCperformedProcedureStepSet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


ImageAndFluoroscopyAreaDoseProduct Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..ImageAndFluoroscopyAreaDoseProduct Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Image and Fluoroscopy Area Dose Product attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ImageAndFluoroscopyAreaDoseProduct { get; set; }
Visual Basic
Public Overridable Property ImageAndFluoroscopyAreaDoseProduct As String
    Get
    Set
Visual C++
public:
virtual property String^ ImageAndFluoroscopyAreaDoseProduct {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProcedureStepDescription Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProcedureStepEndDate Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate PerformedProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ PerformedProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProcedureStepEndTime Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime PerformedProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ PerformedProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProcedureStepStatus Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProcedureTypeDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProcedureTypeDescription Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Performed Procedure Type Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PerformedProcedureTypeDescription { get; set; }
Visual Basic
Public Overridable Property PerformedProcedureTypeDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ PerformedProcedureTypeDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedProtocolCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedProtocolCodes Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Performed Protocol Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PerformedProtocolCodes { get; set; }
Visual Basic
Public Overridable Property PerformedProtocolCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PerformedProtocolCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PerformedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PerformedSeries Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Performed Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCperformedSeriesItem[] PerformedSeries { get; set; }
Visual Basic
Public Overridable Property PerformedSeries As MCperformedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCperformedSeriesItem^>^ PerformedSeries {
    array<MCperformedSeriesItem^>^ get ();
    void set (array<MCperformedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


PPSDiscontinuationReasonCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..PPSDiscontinuationReasonCodes Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the PPS Discontinuation Reason Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PPSDiscontinuationReasonCodes { get; set; }
Visual Basic
Public Overridable Property PPSDiscontinuationReasonCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PPSDiscontinuationReasonCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..ProcedureCodes Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


ReasonForPerformedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..ReasonForPerformedProcedureCodes Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the values for the Reason For Performed Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ReasonForPerformedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ReasonForPerformedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ReasonForPerformedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


TotalNumberOfExposures Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..TotalNumberOfExposures Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Total Number of Exposures attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalNumberOfExposures { get; set; }
Visual Basic
Public Overridable Property TotalNumberOfExposures As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalNumberOfExposures {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


TotalTimeOfFluoroscopy Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcedureStepSet..::..TotalTimeOfFluoroscopy Property
MCperformedProcedureStepSet Class See Also Send Feedback
Represents the value for the Total Time of Fluoroscopy attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual ushort TotalTimeOfFluoroscopy { get; set; }
Visual Basic
Public Overridable Property TotalTimeOfFluoroscopy As UShort
    Get
    Set
Visual C++
public:
virtual property unsigned short TotalTimeOfFluoroscopy {
    unsigned short get ();
    void set (unsigned short value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcedureStepSet Class
MCperformedProcedureStepSet Members
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the CONTENT_ITEM_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCperformedProcessingParametersItem
Visual Basic
Public Class MCperformedProcessingParametersItem
Visual C++
public ref class MCperformedProcessingParametersItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081199) Referenced SOP Sequence
  • (004008EA) Measurement Units Code Sequence
  • (0040A040) Value Type
  • (0040A043) Concept Name Code Sequence
  • (0040A120) DateTime
  • (0040A121) Date
  • (0040A122) Time
  • (0040A123) Person Name
  • (0040A124) UID
  • (0040A160) Text Value
  • (0040A168) Concept Code Sequence
  • (0040A30A) Numeric Value

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCperformedProcessingParametersItem

See Also

MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Members
MCperformedProcessingParametersItem Class Constructors Methods Properties See Also Send Feedback

The MCperformedProcessingParametersItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCperformedProcessingParametersItem()()()() | Constructs an MCperformedProcessingParametersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCperformedProcessingParametersItem(MCitem) | Constructs an MCperformedProcessingParametersItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeConceptCodes | This method removes all the values that may have been set for Concept Code Sequence.
Public method | removeConceptNameCodes | This method removes all the values that may have been set for Concept Name Code Sequence.
Public method | removeDate | This method removes all the values that may have been set for Date.
Public method | removeDateTime | This method removes all the values that may have been set for DateTime.
Public method | removeMeasurementUnitsCodes | This method removes all the values that may have been set for Measurement Units Code Sequence.
Public method | removeNumericValues | This method removes all the values that may have been set for Numeric Value.
Public method | removePersonName | This method removes all the values that may have been set for Person Name.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeTextValue | This method removes all the values that may have been set for Text Value.
Public method | removeTime | This method removes all the values that may have been set for Time.
Public method | removeUID | This method removes all the values that may have been set for UID.
Public method | removeValueType | This method removes all the values that may have been set for Value Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConceptCodes | Represents the values for the Concept Code Sequence attribute.
Public property | ConceptNameCodes | Represents the values for the Concept Name Code Sequence attribute.
Public property | Date | Represents the value for the Date attribute.
Public property | DateTime | Represents the value for the DateTime attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasurementUnitsCodes | Represents the values for the Measurement Units Code Sequence attribute.
Public property | NumericValues | Represents the values for the Numeric Value attribute.
Public property | PersonName | Represents the value for the Person Name attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | TextValue | Represents the value for the Text Value attribute.
Public property | Time | Represents the value for the Time attribute.
Public property | UID | Represents the value for the UID attribute.
Public property | ValueType | Represents the value for the Value Type attribute.

See Also

MCperformedProcessingParametersItem Class
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Constructor
MCperformedProcessingParametersItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCperformedProcessingParametersItem()()()() | Constructs an MCperformedProcessingParametersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCperformedProcessingParametersItem(MCitem) | Constructs an MCperformedProcessingParametersItem collection by wrapping an existing MCitem instance.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Constructor
MCperformedProcessingParametersItem Class See Also Send Feedback
Constructs an MCperformedProcessingParametersItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcessingParametersItem()
Visual Basic
Public Sub New
Visual C++
public:
MCperformedProcessingParametersItem()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
MCperformedProcessingParametersItem Overload
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Constructor (MCitem)
MCperformedProcessingParametersItem Class See Also Send Feedback
Constructs an MCperformedProcessingParametersItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedProcessingParametersItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCperformedProcessingParametersItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
MCperformedProcessingParametersItem Overload
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Methods
MCperformedProcessingParametersItem Class See Also Send Feedback

The MCperformedProcessingParametersItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeConceptCodes | This method removes all the values that may have been set for Concept Code Sequence.
Public method | removeConceptNameCodes | This method removes all the values that may have been set for Concept Name Code Sequence.
Public method | removeDate | This method removes all the values that may have been set for Date.
Public method | removeDateTime | This method removes all the values that may have been set for DateTime.
Public method | removeMeasurementUnitsCodes | This method removes all the values that may have been set for Measurement Units Code Sequence.
Public method | removeNumericValues | This method removes all the values that may have been set for Numeric Value.
Public method | removePersonName | This method removes all the values that may have been set for Person Name.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeTextValue | This method removes all the values that may have been set for Text Value.
Public method | removeTime | This method removes all the values that may have been set for Time.
Public method | removeUID | This method removes all the values that may have been set for UID.
Public method | removeValueType | This method removes all the values that may have been set for Value Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCperformedProcessingParametersItem Class
Mergecom.Gen Namespace


removeConceptCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeConceptCodes Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Concept Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConceptCodes()
Visual Basic
Public Overridable Sub removeConceptCodes
Visual C++
public:
virtual void removeConceptCodes()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeConceptNameCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeConceptNameCodes Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Concept Name Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConceptNameCodes()
Visual Basic
Public Overridable Sub removeConceptNameCodes
Visual C++
public:
virtual void removeConceptNameCodes()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeDate Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDate()
Visual Basic
Public Overridable Sub removeDate
Visual C++
public:
virtual void removeDate()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeDateTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeDateTime Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for DateTime.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDateTime()
Visual Basic
Public Overridable Sub removeDateTime
Visual C++
public:
virtual void removeDateTime()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeMeasurementUnitsCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeMeasurementUnitsCodes Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Measurement Units Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMeasurementUnitsCodes()
Visual Basic
Public Overridable Sub removeMeasurementUnitsCodes
Visual C++
public:
virtual void removeMeasurementUnitsCodes()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeNumericValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeNumericValues Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Numeric Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNumericValues()
Visual Basic
Public Overridable Sub removeNumericValues
Visual C++
public:
virtual void removeNumericValues()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removePersonName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removePersonName Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Person Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePersonName()
Visual Basic
Public Overridable Sub removePersonName
Visual C++
public:
virtual void removePersonName()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeReferencedSOPs Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeReferencedSOPs Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPs()
Visual Basic
Public Overridable Sub removeReferencedSOPs
Visual C++
public:
virtual void removeReferencedSOPs()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeTextValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeTextValue Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Text Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTextValue()
Visual Basic
Public Overridable Sub removeTextValue
Visual C++
public:
virtual void removeTextValue()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeTime Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTime()
Visual Basic
Public Overridable Sub removeTime
Visual C++
public:
virtual void removeTime()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeUID Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeUID()
Visual Basic
Public Overridable Sub removeUID
Visual C++
public:
virtual void removeUID()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


removeValueType Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..removeValueType Method
MCperformedProcessingParametersItem Class See Also Send Feedback
This method removes all the values that may have been set for Value Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeValueType()
Visual Basic
Public Overridable Sub removeValueType
Visual C++
public:
virtual void removeValueType()

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


MCperformedProcessingParametersItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem Properties
MCperformedProcessingParametersItem Class See Also Send Feedback

The MCperformedProcessingParametersItem type exposes the following members.

Properties

 | Name | Description
Public property | ConceptCodes | Represents the values for the Concept Code Sequence attribute.
Public property | ConceptNameCodes | Represents the values for the Concept Name Code Sequence attribute.
Public property | Date | Represents the value for the Date attribute.
Public property | DateTime | Represents the value for the DateTime attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasurementUnitsCodes | Represents the values for the Measurement Units Code Sequence attribute.
Public property | NumericValues | Represents the values for the Numeric Value attribute.
Public property | PersonName | Represents the value for the Person Name attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | TextValue | Represents the value for the Text Value attribute.
Public property | Time | Represents the value for the Time attribute.
Public property | UID | Represents the value for the UID attribute.
Public property | ValueType | Represents the value for the Value Type attribute.

See Also

MCperformedProcessingParametersItem Class
Mergecom.Gen Namespace


ConceptCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..ConceptCodes Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the values for the Concept Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ConceptCodes { get; set; }
Visual Basic
Public Overridable Property ConceptCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ConceptCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


ConceptNameCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..ConceptNameCodes Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the values for the Concept Name Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ConceptNameCodes { get; set; }
Visual Basic
Public Overridable Property ConceptNameCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ConceptNameCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


Date Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..Date Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate Date { get; set; }
Visual Basic
Public Overridable Property Date As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ Date {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


DateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..DateTime Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the DateTime attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime DateTime { get; set; }
Visual Basic
Public Overridable Property DateTime As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ DateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..Host Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


MeasurementUnitsCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..MeasurementUnitsCodes Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the values for the Measurement Units Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] MeasurementUnitsCodes { get; set; }
Visual Basic
Public Overridable Property MeasurementUnitsCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ MeasurementUnitsCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


NumericValues Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..NumericValues Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the values for the Numeric Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] NumericValues { get; set; }
Visual Basic
Public Overridable Property NumericValues As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ NumericValues {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


PersonName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..PersonName Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the Person Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PersonName { get; set; }
Visual Basic
Public Overridable Property PersonName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PersonName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


ReferencedSOPs Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..ReferencedSOPs Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the values for the Referenced SOP Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSOPItem[] ReferencedSOPs { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPs As MCreferencedSOPItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSOPItem^>^ ReferencedSOPs {
    array<MCreferencedSOPItem^>^ get ();
    void set (array<MCreferencedSOPItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


TextValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..TextValue Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the Text Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string TextValue { get; set; }
Visual Basic
Public Overridable Property TextValue As String
    Get
    Set
Visual C++
public:
virtual property String^ TextValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


Time Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..Time Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime Time { get; set; }
Visual Basic
Public Overridable Property Time As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ Time {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


UID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..UID Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string UID { get; set; }
Visual Basic
Public Overridable Property UID As String
    Get
    Set
Visual C++
public:
virtual property String^ UID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


ValueType Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedProcessingParametersItem..::..ValueType Property
MCperformedProcessingParametersItem Class See Also Send Feedback
Represents the value for the Value Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ValueType { get; set; }
Visual Basic
Public Overridable Property ValueType As String
    Get
    Set
Visual C++
public:
virtual property String^ ValueType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedProcessingParametersItem Class
MCperformedProcessingParametersItem Members
Mergecom.Gen Namespace


MCperformedSeriesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERFORMED_SERIES Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCperformedSeriesItem
Visual Basic
Public Class MCperformedSeriesItem
Visual C++
public ref class MCperformedSeriesItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080054) Retrieve AE Title
  • (0008103E) Series Description
  • (0008103F) Series Description Code Sequence
  • (00081050) Performing Physician's Name
  • (00081052) Performing Physician Identification Sequence
  • (00081070) Operators' Name
  • (00081072) Operator Identification Sequence
  • (00081140) Referenced Image Sequence
  • (00181030) Protocol Name
  • (0020000E) Series Instance UID
  • (00400220) Referenced Standalone SOP Instance Sequence
  • (0040A494) Archive Requested

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCperformedSeriesItem

See Also

MCperformedSeriesItem Members
Mergecom.Gen Namespace


MCperformedSeriesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Members
MCperformedSeriesItem Class Constructors Methods Properties See Also Send Feedback

The MCperformedSeriesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCperformedSeriesItem()()()() | Constructs an MCperformedSeriesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCperformedSeriesItem(MCitem) | Constructs an MCperformedSeriesItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeArchiveRequested | This method removes all the values that may have been set for Archive Requested.
Public method | removeOperatorIdentifications | This method removes all the values that may have been set for Operator Identification Sequence.
Public method | removeOperatorsNames | This method removes all the values that may have been set for Operators' Name.
Public method | removePerformingPhysicianIdentifications | This method removes all the values that may have been set for Performing Physician Identification Sequence.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProtocolName | This method removes all the values that may have been set for Protocol Name.
Public method | removeReferencedImages | This method removes all the values that may have been set for Referenced Image Sequence.
Public method | removeReferencedStandaloneSOPInstances | This method removes all the values that may have been set for Referenced Standalone SOP Instance Sequence.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesDescription | This method removes all the values that may have been set for Series Description.
Public method | removeSeriesDescriptionCodes | This method removes all the values that may have been set for Series Description Code Sequence.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArchiveRequested | Represents the value for the Archive Requested attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | OperatorIdentifications | Represents the values for the Operator Identification Sequence attribute.
Public property | OperatorsNames | Represents the values for the Operators' Name attribute.
Public property | PerformingPhysicianIdentifications | Represents the values for the Performing Physician Identification Sequence attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProtocolName | Represents the value for the Protocol Name attribute.
Public property | ReferencedImages | Represents the values for the Referenced Image Sequence attribute.
Public property | ReferencedStandaloneSOPInstances | Represents the values for the Referenced Standalone SOP Instance Sequence attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesDescription | Represents the value for the Series Description attribute.
Public property | SeriesDescriptionCodes | Represents the values for the Series Description Code Sequence attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.

See Also

MCperformedSeriesItem Class
Mergecom.Gen Namespace


MCperformedSeriesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Constructor
MCperformedSeriesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCperformedSeriesItem()()()() | Constructs an MCperformedSeriesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCperformedSeriesItem(MCitem) | Constructs an MCperformedSeriesItem collection by wrapping an existing MCitem instance.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


MCperformedSeriesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Constructor
MCperformedSeriesItem Class See Also Send Feedback
Constructs an MCperformedSeriesItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedSeriesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCperformedSeriesItem()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
MCperformedSeriesItem Overload
Mergecom.Gen Namespace


MCperformedSeriesItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Constructor (MCitem)
MCperformedSeriesItem Class See Also Send Feedback
Constructs an MCperformedSeriesItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCperformedSeriesItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCperformedSeriesItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
MCperformedSeriesItem Overload
Mergecom.Gen Namespace


MCperformedSeriesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Methods
MCperformedSeriesItem Class See Also Send Feedback

The MCperformedSeriesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeArchiveRequested | This method removes all the values that may have been set for Archive Requested.
Public method | removeOperatorIdentifications | This method removes all the values that may have been set for Operator Identification Sequence.
Public method | removeOperatorsNames | This method removes all the values that may have been set for Operators' Name.
Public method | removePerformingPhysicianIdentifications | This method removes all the values that may have been set for Performing Physician Identification Sequence.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProtocolName | This method removes all the values that may have been set for Protocol Name.
Public method | removeReferencedImages | This method removes all the values that may have been set for Referenced Image Sequence.
Public method | removeReferencedStandaloneSOPInstances | This method removes all the values that may have been set for Referenced Standalone SOP Instance Sequence.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesDescription | This method removes all the values that may have been set for Series Description.
Public method | removeSeriesDescriptionCodes | This method removes all the values that may have been set for Series Description Code Sequence.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCperformedSeriesItem Class
Mergecom.Gen Namespace


removeArchiveRequested Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeArchiveRequested Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Archive Requested.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeArchiveRequested()
Visual Basic
Public Overridable Sub removeArchiveRequested
Visual C++
public:
virtual void removeArchiveRequested()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeOperatorIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeOperatorIdentifications Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Operator Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOperatorIdentifications()
Visual Basic
Public Overridable Sub removeOperatorIdentifications
Visual C++
public:
virtual void removeOperatorIdentifications()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeOperatorsNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeOperatorsNames Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Operators' Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOperatorsNames()
Visual Basic
Public Overridable Sub removeOperatorsNames
Visual C++
public:
virtual void removeOperatorsNames()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removePerformingPhysicianIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removePerformingPhysicianIdentifications Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysicianIdentifications()
Visual Basic
Public Overridable Sub removePerformingPhysicianIdentifications
Visual C++
public:
virtual void removePerformingPhysicianIdentifications()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removePerformingPhysiciansNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removePerformingPhysiciansNames Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysiciansNames()
Visual Basic
Public Overridable Sub removePerformingPhysiciansNames
Visual C++
public:
virtual void removePerformingPhysiciansNames()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeProtocolName Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeProtocolName Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Protocol Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProtocolName()
Visual Basic
Public Overridable Sub removeProtocolName
Visual C++
public:
virtual void removeProtocolName()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeReferencedImages Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeReferencedImages Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Image Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedImages()
Visual Basic
Public Overridable Sub removeReferencedImages
Visual C++
public:
virtual void removeReferencedImages()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeReferencedStandaloneSOPInstances Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeReferencedStandaloneSOPInstances Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Standalone SOP Instance Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStandaloneSOPInstances()
Visual Basic
Public Overridable Sub removeReferencedStandaloneSOPInstances
Visual C++
public:
virtual void removeReferencedStandaloneSOPInstances()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeRetrieveAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeRetrieveAETitles Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Retrieve AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRetrieveAETitles()
Visual Basic
Public Overridable Sub removeRetrieveAETitles
Visual C++
public:
virtual void removeRetrieveAETitles()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeSeriesDescription Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesDescription()
Visual Basic
Public Overridable Sub removeSeriesDescription
Visual C++
public:
virtual void removeSeriesDescription()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesDescriptionCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeSeriesDescriptionCodes Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Description Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesDescriptionCodes()
Visual Basic
Public Overridable Sub removeSeriesDescriptionCodes
Visual C++
public:
virtual void removeSeriesDescriptionCodes()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..removeSeriesInstanceUID Method
MCperformedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInstanceUID()
Visual Basic
Public Overridable Sub removeSeriesInstanceUID
Visual C++
public:
virtual void removeSeriesInstanceUID()

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


MCperformedSeriesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem Properties
MCperformedSeriesItem Class See Also Send Feedback

The MCperformedSeriesItem type exposes the following members.

Properties

 | Name | Description
Public property | ArchiveRequested | Represents the value for the Archive Requested attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | OperatorIdentifications | Represents the values for the Operator Identification Sequence attribute.
Public property | OperatorsNames | Represents the values for the Operators' Name attribute.
Public property | PerformingPhysicianIdentifications | Represents the values for the Performing Physician Identification Sequence attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProtocolName | Represents the value for the Protocol Name attribute.
Public property | ReferencedImages | Represents the values for the Referenced Image Sequence attribute.
Public property | ReferencedStandaloneSOPInstances | Represents the values for the Referenced Standalone SOP Instance Sequence attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesDescription | Represents the value for the Series Description attribute.
Public property | SeriesDescriptionCodes | Represents the values for the Series Description Code Sequence attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.

See Also

MCperformedSeriesItem Class
Mergecom.Gen Namespace


ArchiveRequested Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..ArchiveRequested Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the value for the Archive Requested attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ArchiveRequested { get; set; }
Visual Basic
Public Overridable Property ArchiveRequested As String
    Get
    Set
Visual C++
public:
virtual property String^ ArchiveRequested {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..Host Property
MCperformedSeriesItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


OperatorIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..OperatorIdentifications Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Operator Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] OperatorIdentifications { get; set; }
Visual Basic
Public Overridable Property OperatorIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ OperatorIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


OperatorsNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..OperatorsNames Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Operators' Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] OperatorsNames { get; set; }
Visual Basic
Public Overridable Property OperatorsNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ OperatorsNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


PerformingPhysicianIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..PerformingPhysicianIdentifications Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Performing Physician Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] PerformingPhysicianIdentifications { get; set; }
Visual Basic
Public Overridable Property PerformingPhysicianIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ PerformingPhysicianIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


PerformingPhysiciansNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..PerformingPhysiciansNames Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] PerformingPhysiciansNames { get; set; }
Visual Basic
Public Overridable Property PerformingPhysiciansNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ PerformingPhysiciansNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


ProtocolName Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..ProtocolName Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the value for the Protocol Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ProtocolName { get; set; }
Visual Basic
Public Overridable Property ProtocolName As String
    Get
    Set
Visual C++
public:
virtual property String^ ProtocolName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


ReferencedImages Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..ReferencedImages Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Referenced Image Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedImageItem[] ReferencedImages { get; set; }
Visual Basic
Public Overridable Property ReferencedImages As MCreferencedImageItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedImageItem^>^ ReferencedImages {
    array<MCreferencedImageItem^>^ get ();
    void set (array<MCreferencedImageItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


ReferencedStandaloneSOPInstances Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..ReferencedStandaloneSOPInstances Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Referenced Standalone SOP Instance Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStandaloneSOPInstanceItem[] ReferencedStandaloneSOPInstances { get; set; }
Visual Basic
Public Overridable Property ReferencedStandaloneSOPInstances As MCreferencedStandaloneSOPInstanceItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStandaloneSOPInstanceItem^>^ ReferencedStandaloneSOPInstances {
    array<MCreferencedStandaloneSOPInstanceItem^>^ get ();
    void set (array<MCreferencedStandaloneSOPInstanceItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


RetrieveAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..RetrieveAETitles Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Retrieve AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] RetrieveAETitles { get; set; }
Visual Basic
Public Overridable Property RetrieveAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ RetrieveAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


SeriesDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..SeriesDescription Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the value for the Series Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesDescription { get; set; }
Visual Basic
Public Overridable Property SeriesDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


SeriesDescriptionCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..SeriesDescriptionCodes Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the values for the Series Description Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] SeriesDescriptionCodes { get; set; }
Visual Basic
Public Overridable Property SeriesDescriptionCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ SeriesDescriptionCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


SeriesInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCperformedSeriesItem..::..SeriesInstanceUID Property
MCperformedSeriesItem Class See Also Send Feedback
Represents the value for the Series Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInstanceUID { get; set; }
Visual Basic
Public Overridable Property SeriesInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCperformedSeriesItem Class
MCperformedSeriesItem Members
Mergecom.Gen Namespace


MCpersonIdentificationMacro Class

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERSON_IDENTIFICATION_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpersonIdentificationMacro
Visual Basic
Public Class MCpersonIdentificationMacro
Visual C++
public ref class MCpersonIdentificationMacro

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080080) Institution Name
  • (00080081) Institution Address
  • (00080082) Institution Code Sequence
  • (00401101) Person identification Code Sequence
  • (00401102) Person's Address
  • (00401103) Person's Telephone Numbers

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCpersonIdentificationMacro

See Also

MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


MCpersonIdentificationMacro Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Members
MCpersonIdentificationMacro Class Constructors Methods Properties See Also Send Feedback

The MCpersonIdentificationMacro type exposes the following members.

Constructors

 | Name | Description
Public method | MCpersonIdentificationMacro()()()() | Constructs an MCpersonIdentificationMacro collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpersonIdentificationMacro(MCitem) | Constructs an MCpersonIdentificationMacro collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionCodes | This method removes all the values that may have been set for Institution Code Sequence.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removePersonIdentificationCodes | This method removes all the values that may have been set for Person identification Code Sequence.
Public method | removePersonsAddress | This method removes all the values that may have been set for Person's Address.
Public method | removePersonsTelephoneNumbers | This method removes all the values that may have been set for Person's Telephone Numbers.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionCodes | Represents the values for the Institution Code Sequence attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | PersonIdentificationCodes | Represents the values for the Person identification Code Sequence attribute.
Public property | PersonsAddress | Represents the value for the Person's Address attribute.
Public property | PersonsTelephoneNumbers | Represents the values for the Person's Telephone Numbers attribute.

See Also

MCpersonIdentificationMacro Class
Mergecom.Gen Namespace


MCpersonIdentificationMacro Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Constructor
MCpersonIdentificationMacro Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpersonIdentificationMacro()()()() | Constructs an MCpersonIdentificationMacro collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpersonIdentificationMacro(MCitem) | Constructs an MCpersonIdentificationMacro collection by wrapping an existing MCitem instance.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


MCpersonIdentificationMacro Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Constructor
MCpersonIdentificationMacro Class See Also Send Feedback
Constructs an MCpersonIdentificationMacro collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonIdentificationMacro()
Visual Basic
Public Sub New
Visual C++
public:
MCpersonIdentificationMacro()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
MCpersonIdentificationMacro Overload
Mergecom.Gen Namespace


MCpersonIdentificationMacro Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Constructor (MCitem)
MCpersonIdentificationMacro Class See Also Send Feedback
Constructs an MCpersonIdentificationMacro collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonIdentificationMacro(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCpersonIdentificationMacro(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
MCpersonIdentificationMacro Overload
Mergecom.Gen Namespace


MCpersonIdentificationMacro Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Methods
MCpersonIdentificationMacro Class See Also Send Feedback

The MCpersonIdentificationMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeInstitutionAddress | This method removes all the values that may have been set for Institution Address.
Public method | removeInstitutionCodes | This method removes all the values that may have been set for Institution Code Sequence.
Public method | removeInstitutionName | This method removes all the values that may have been set for Institution Name.
Public method | removePersonIdentificationCodes | This method removes all the values that may have been set for Person identification Code Sequence.
Public method | removePersonsAddress | This method removes all the values that may have been set for Person's Address.
Public method | removePersonsTelephoneNumbers | This method removes all the values that may have been set for Person's Telephone Numbers.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCpersonIdentificationMacro Class
Mergecom.Gen Namespace


removeInstitutionAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removeInstitutionAddress Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Institution Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionAddress()
Visual Basic
Public Overridable Sub removeInstitutionAddress
Visual C++
public:
virtual void removeInstitutionAddress()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


removeInstitutionCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removeInstitutionCodes Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Institution Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionCodes()
Visual Basic
Public Overridable Sub removeInstitutionCodes
Visual C++
public:
virtual void removeInstitutionCodes()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


removeInstitutionName Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removeInstitutionName Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Institution Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeInstitutionName()
Visual Basic
Public Overridable Sub removeInstitutionName
Visual C++
public:
virtual void removeInstitutionName()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


removePersonIdentificationCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removePersonIdentificationCodes Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Person identification Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePersonIdentificationCodes()
Visual Basic
Public Overridable Sub removePersonIdentificationCodes
Visual C++
public:
virtual void removePersonIdentificationCodes()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


removePersonsAddress Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removePersonsAddress Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Person's Address.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePersonsAddress()
Visual Basic
Public Overridable Sub removePersonsAddress
Visual C++
public:
virtual void removePersonsAddress()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


removePersonsTelephoneNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..removePersonsTelephoneNumbers Method
MCpersonIdentificationMacro Class See Also Send Feedback
This method removes all the values that may have been set for Person's Telephone Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePersonsTelephoneNumbers()
Visual Basic
Public Overridable Sub removePersonsTelephoneNumbers
Visual C++
public:
virtual void removePersonsTelephoneNumbers()

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


MCpersonIdentificationMacro Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro Properties
MCpersonIdentificationMacro Class See Also Send Feedback

The MCpersonIdentificationMacro type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | InstitutionAddress | Represents the value for the Institution Address attribute.
Public property | InstitutionCodes | Represents the values for the Institution Code Sequence attribute.
Public property | InstitutionName | Represents the value for the Institution Name attribute.
Public property | PersonIdentificationCodes | Represents the values for the Person identification Code Sequence attribute.
Public property | PersonsAddress | Represents the value for the Person's Address attribute.
Public property | PersonsTelephoneNumbers | Represents the values for the Person's Telephone Numbers attribute.

See Also

MCpersonIdentificationMacro Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..Host Property
MCpersonIdentificationMacro Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


InstitutionAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..InstitutionAddress Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the value for the Institution Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionAddress { get; set; }
Visual Basic
Public Overridable Property InstitutionAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


InstitutionCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..InstitutionCodes Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the values for the Institution Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] InstitutionCodes { get; set; }
Visual Basic
Public Overridable Property InstitutionCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ InstitutionCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


InstitutionName Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..InstitutionName Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the value for the Institution Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string InstitutionName { get; set; }
Visual Basic
Public Overridable Property InstitutionName As String
    Get
    Set
Visual C++
public:
virtual property String^ InstitutionName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


PersonIdentificationCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..PersonIdentificationCodes Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the values for the Person identification Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PersonIdentificationCodes { get; set; }
Visual Basic
Public Overridable Property PersonIdentificationCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PersonIdentificationCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


PersonsAddress Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..PersonsAddress Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the value for the Person's Address attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PersonsAddress { get; set; }
Visual Basic
Public Overridable Property PersonsAddress As String
    Get
    Set
Visual C++
public:
virtual property String^ PersonsAddress {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


PersonsTelephoneNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonIdentificationMacro..::..PersonsTelephoneNumbers Property
MCpersonIdentificationMacro Class See Also Send Feedback
Represents the values for the Person's Telephone Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] PersonsTelephoneNumbers { get; set; }
Visual Basic
Public Overridable Property PersonsTelephoneNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ PersonsTelephoneNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpersonIdentificationMacro Class
MCpersonIdentificationMacro Members
Mergecom.Gen Namespace


MCpertinentDocumentsItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the PERTINENT_DOCUMENTS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpertinentDocumentsItem
Visual Basic
Public Class MCpertinentDocumentsItem
Visual C++
public ref class MCpertinentDocumentsItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (0040A170) Purpose of Reference Code Sequence
  • (00420010) Document Title

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCpertinentDocumentsItem

See Also

MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


MCpertinentDocumentsItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Members
MCpertinentDocumentsItem Class Constructors Methods Properties See Also Send Feedback

The MCpertinentDocumentsItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCpertinentDocumentsItem()()()() | Constructs an MCpertinentDocumentsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpertinentDocumentsItem(MCitem) | Constructs an MCpertinentDocumentsItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDocumentTitle | This method removes all the values that may have been set for Document Title.
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DocumentTitle | Represents the value for the Document Title attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCpertinentDocumentsItem Class
Mergecom.Gen Namespace


MCpertinentDocumentsItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Constructor
MCpertinentDocumentsItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpertinentDocumentsItem()()()() | Constructs an MCpertinentDocumentsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCpertinentDocumentsItem(MCitem) | Constructs an MCpertinentDocumentsItem collection by wrapping an existing MCitem instance.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


MCpertinentDocumentsItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Constructor
MCpertinentDocumentsItem Class See Also Send Feedback
Constructs an MCpertinentDocumentsItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpertinentDocumentsItem()
Visual Basic
Public Sub New
Visual C++
public:
MCpertinentDocumentsItem()

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
MCpertinentDocumentsItem Overload
Mergecom.Gen Namespace


MCpertinentDocumentsItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Constructor (MCitem)
MCpertinentDocumentsItem Class See Also Send Feedback
Constructs an MCpertinentDocumentsItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpertinentDocumentsItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCpertinentDocumentsItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
MCpertinentDocumentsItem Overload
Mergecom.Gen Namespace


MCpertinentDocumentsItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Methods
MCpertinentDocumentsItem Class See Also Send Feedback

The MCpertinentDocumentsItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDocumentTitle | This method removes all the values that may have been set for Document Title.
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCpertinentDocumentsItem Class
Mergecom.Gen Namespace


removeDocumentTitle Method

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..removeDocumentTitle Method
MCpertinentDocumentsItem Class See Also Send Feedback
This method removes all the values that may have been set for Document Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDocumentTitle()
Visual Basic
Public Overridable Sub removeDocumentTitle
Visual C++
public:
virtual void removeDocumentTitle()

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


removePurposeOfReferenceCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..removePurposeOfReferenceCodes Method
MCpertinentDocumentsItem Class See Also Send Feedback
This method removes all the values that may have been set for Purpose of Reference Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePurposeOfReferenceCodes()
Visual Basic
Public Overridable Sub removePurposeOfReferenceCodes
Visual C++
public:
virtual void removePurposeOfReferenceCodes()

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..removeReferencedSOPClassUID Method
MCpertinentDocumentsItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..removeReferencedSOPInstanceUID Method
MCpertinentDocumentsItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


MCpertinentDocumentsItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem Properties
MCpertinentDocumentsItem Class See Also Send Feedback

The MCpertinentDocumentsItem type exposes the following members.

Properties

 | Name | Description
Public property | DocumentTitle | Represents the value for the Document Title attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCpertinentDocumentsItem Class
Mergecom.Gen Namespace


DocumentTitle Property

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..DocumentTitle Property
MCpertinentDocumentsItem Class See Also Send Feedback
Represents the value for the Document Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DocumentTitle { get; set; }
Visual Basic
Public Overridable Property DocumentTitle As String
    Get
    Set
Visual C++
public:
virtual property String^ DocumentTitle {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..Host Property
MCpertinentDocumentsItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


PurposeOfReferenceCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..PurposeOfReferenceCodes Property
MCpertinentDocumentsItem Class See Also Send Feedback
Represents the values for the Purpose of Reference Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PurposeOfReferenceCodes { get; set; }
Visual Basic
Public Overridable Property PurposeOfReferenceCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PurposeOfReferenceCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..ReferencedSOPClassUID Property
MCpertinentDocumentsItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCpertinentDocumentsItem..::..ReferencedSOPInstanceUID Property
MCpertinentDocumentsItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCpertinentDocumentsItem Class
MCpertinentDocumentsItem Members
Mergecom.Gen Namespace


MCprotocolContextItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the PROTOCOL_CONTEXT Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCprotocolContextItem
Visual Basic
Public Class MCprotocolContextItem
Visual C++
public ref class MCprotocolContextItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081199) Referenced SOP Sequence
  • (00400441) Content Item Modifier Sequence
  • (004008EA) Measurement Units Code Sequence
  • (0040A040) Value Type
  • (0040A043) Concept Name Code Sequence
  • (0040A120) DateTime
  • (0040A121) Date
  • (0040A122) Time
  • (0040A123) Person Name
  • (0040A124) UID
  • (0040A160) Text Value
  • (0040A168) Concept Code Sequence
  • (0040A30A) Numeric Value

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCprotocolContextItem

See Also

MCprotocolContextItem Members
Mergecom.Gen Namespace


MCprotocolContextItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Members
MCprotocolContextItem Class Constructors Methods Properties See Also Send Feedback

The MCprotocolContextItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCprotocolContextItem()()()() | Constructs an MCprotocolContextItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCprotocolContextItem(MCitem) | Constructs an MCprotocolContextItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeConceptCodes | This method removes all the values that may have been set for Concept Code Sequence.
Public method | removeConceptNameCodes | This method removes all the values that may have been set for Concept Name Code Sequence.
Public method | removeContentItemModifiers | This method removes all the values that may have been set for Content Item Modifier Sequence.
Public method | removeDate | This method removes all the values that may have been set for Date.
Public method | removeDateTime | This method removes all the values that may have been set for DateTime.
Public method | removeMeasurementUnitsCodes | This method removes all the values that may have been set for Measurement Units Code Sequence.
Public method | removeNumericValues | This method removes all the values that may have been set for Numeric Value.
Public method | removePersonName | This method removes all the values that may have been set for Person Name.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeTextValue | This method removes all the values that may have been set for Text Value.
Public method | removeTime | This method removes all the values that may have been set for Time.
Public method | removeUID | This method removes all the values that may have been set for UID.
Public method | removeValueType | This method removes all the values that may have been set for Value Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConceptCodes | Represents the values for the Concept Code Sequence attribute.
Public property | ConceptNameCodes | Represents the values for the Concept Name Code Sequence attribute.
Public property | ContentItemModifiers | Represents the values for the Content Item Modifier Sequence attribute.
Public property | Date | Represents the value for the Date attribute.
Public property | DateTime | Represents the value for the DateTime attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasurementUnitsCodes | Represents the values for the Measurement Units Code Sequence attribute.
Public property | NumericValues | Represents the values for the Numeric Value attribute.
Public property | PersonName | Represents the value for the Person Name attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | TextValue | Represents the value for the Text Value attribute.
Public property | Time | Represents the value for the Time attribute.
Public property | UID | Represents the value for the UID attribute.
Public property | ValueType | Represents the value for the Value Type attribute.

See Also

MCprotocolContextItem Class
Mergecom.Gen Namespace


MCprotocolContextItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Constructor
MCprotocolContextItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCprotocolContextItem()()()() | Constructs an MCprotocolContextItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCprotocolContextItem(MCitem) | Constructs an MCprotocolContextItem collection by wrapping an existing MCitem instance.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


MCprotocolContextItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Constructor
MCprotocolContextItem Class See Also Send Feedback
Constructs an MCprotocolContextItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCprotocolContextItem()
Visual Basic
Public Sub New
Visual C++
public:
MCprotocolContextItem()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
MCprotocolContextItem Overload
Mergecom.Gen Namespace


MCprotocolContextItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Constructor (MCitem)
MCprotocolContextItem Class See Also Send Feedback
Constructs an MCprotocolContextItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCprotocolContextItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCprotocolContextItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
MCprotocolContextItem Overload
Mergecom.Gen Namespace


MCprotocolContextItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Methods
MCprotocolContextItem Class See Also Send Feedback

The MCprotocolContextItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeConceptCodes | This method removes all the values that may have been set for Concept Code Sequence.
Public method | removeConceptNameCodes | This method removes all the values that may have been set for Concept Name Code Sequence.
Public method | removeContentItemModifiers | This method removes all the values that may have been set for Content Item Modifier Sequence.
Public method | removeDate | This method removes all the values that may have been set for Date.
Public method | removeDateTime | This method removes all the values that may have been set for DateTime.
Public method | removeMeasurementUnitsCodes | This method removes all the values that may have been set for Measurement Units Code Sequence.
Public method | removeNumericValues | This method removes all the values that may have been set for Numeric Value.
Public method | removePersonName | This method removes all the values that may have been set for Person Name.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeTextValue | This method removes all the values that may have been set for Text Value.
Public method | removeTime | This method removes all the values that may have been set for Time.
Public method | removeUID | This method removes all the values that may have been set for UID.
Public method | removeValueType | This method removes all the values that may have been set for Value Type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCprotocolContextItem Class
Mergecom.Gen Namespace


removeConceptCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeConceptCodes Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Concept Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConceptCodes()
Visual Basic
Public Overridable Sub removeConceptCodes
Visual C++
public:
virtual void removeConceptCodes()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeConceptNameCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeConceptNameCodes Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Concept Name Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeConceptNameCodes()
Visual Basic
Public Overridable Sub removeConceptNameCodes
Visual C++
public:
virtual void removeConceptNameCodes()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeContentItemModifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeContentItemModifiers Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Content Item Modifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContentItemModifiers()
Visual Basic
Public Overridable Sub removeContentItemModifiers
Visual C++
public:
virtual void removeContentItemModifiers()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeDate Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDate()
Visual Basic
Public Overridable Sub removeDate
Visual C++
public:
virtual void removeDate()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeDateTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeDateTime Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for DateTime.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDateTime()
Visual Basic
Public Overridable Sub removeDateTime
Visual C++
public:
virtual void removeDateTime()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeMeasurementUnitsCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeMeasurementUnitsCodes Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Measurement Units Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMeasurementUnitsCodes()
Visual Basic
Public Overridable Sub removeMeasurementUnitsCodes
Visual C++
public:
virtual void removeMeasurementUnitsCodes()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeNumericValues Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeNumericValues Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Numeric Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNumericValues()
Visual Basic
Public Overridable Sub removeNumericValues
Visual C++
public:
virtual void removeNumericValues()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removePersonName Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removePersonName Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Person Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePersonName()
Visual Basic
Public Overridable Sub removePersonName
Visual C++
public:
virtual void removePersonName()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeReferencedSOPs Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeReferencedSOPs Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPs()
Visual Basic
Public Overridable Sub removeReferencedSOPs
Visual C++
public:
virtual void removeReferencedSOPs()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeTextValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeTextValue Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Text Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTextValue()
Visual Basic
Public Overridable Sub removeTextValue
Visual C++
public:
virtual void removeTextValue()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeTime Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeTime()
Visual Basic
Public Overridable Sub removeTime
Visual C++
public:
virtual void removeTime()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeUID Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeUID()
Visual Basic
Public Overridable Sub removeUID
Visual C++
public:
virtual void removeUID()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


removeValueType Method

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..removeValueType Method
MCprotocolContextItem Class See Also Send Feedback
This method removes all the values that may have been set for Value Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeValueType()
Visual Basic
Public Overridable Sub removeValueType
Visual C++
public:
virtual void removeValueType()

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


MCprotocolContextItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem Properties
MCprotocolContextItem Class See Also Send Feedback

The MCprotocolContextItem type exposes the following members.

Properties

 | Name | Description
Public property | ConceptCodes | Represents the values for the Concept Code Sequence attribute.
Public property | ConceptNameCodes | Represents the values for the Concept Name Code Sequence attribute.
Public property | ContentItemModifiers | Represents the values for the Content Item Modifier Sequence attribute.
Public property | Date | Represents the value for the Date attribute.
Public property | DateTime | Represents the value for the DateTime attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasurementUnitsCodes | Represents the values for the Measurement Units Code Sequence attribute.
Public property | NumericValues | Represents the values for the Numeric Value attribute.
Public property | PersonName | Represents the value for the Person Name attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | TextValue | Represents the value for the Text Value attribute.
Public property | Time | Represents the value for the Time attribute.
Public property | UID | Represents the value for the UID attribute.
Public property | ValueType | Represents the value for the Value Type attribute.

See Also

MCprotocolContextItem Class
Mergecom.Gen Namespace


ConceptCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..ConceptCodes Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Concept Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ConceptCodes { get; set; }
Visual Basic
Public Overridable Property ConceptCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ConceptCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


ConceptNameCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..ConceptNameCodes Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Concept Name Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ConceptNameCodes { get; set; }
Visual Basic
Public Overridable Property ConceptNameCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ConceptNameCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


ContentItemModifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..ContentItemModifiers Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Content Item Modifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCperformedProcessingParametersItem[] ContentItemModifiers { get; set; }
Visual Basic
Public Overridable Property ContentItemModifiers As MCperformedProcessingParametersItem()
    Get
    Set
Visual C++
public:
virtual property array<MCperformedProcessingParametersItem^>^ ContentItemModifiers {
    array<MCperformedProcessingParametersItem^>^ get ();
    void set (array<MCperformedProcessingParametersItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


Date Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..Date Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate Date { get; set; }
Visual Basic
Public Overridable Property Date As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ Date {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


DateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..DateTime Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the DateTime attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime DateTime { get; set; }
Visual Basic
Public Overridable Property DateTime As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ DateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..Host Property
MCprotocolContextItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


MeasurementUnitsCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..MeasurementUnitsCodes Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Measurement Units Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] MeasurementUnitsCodes { get; set; }
Visual Basic
Public Overridable Property MeasurementUnitsCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ MeasurementUnitsCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


NumericValues Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..NumericValues Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Numeric Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] NumericValues { get; set; }
Visual Basic
Public Overridable Property NumericValues As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ NumericValues {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


PersonName Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..PersonName Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the Person Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName PersonName { get; set; }
Visual Basic
Public Overridable Property PersonName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ PersonName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


ReferencedSOPs Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..ReferencedSOPs Property
MCprotocolContextItem Class See Also Send Feedback
Represents the values for the Referenced SOP Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSOPItem[] ReferencedSOPs { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPs As MCreferencedSOPItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSOPItem^>^ ReferencedSOPs {
    array<MCreferencedSOPItem^>^ get ();
    void set (array<MCreferencedSOPItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


TextValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..TextValue Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the Text Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string TextValue { get; set; }
Visual Basic
Public Overridable Property TextValue As String
    Get
    Set
Visual C++
public:
virtual property String^ TextValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


Time Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..Time Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime Time { get; set; }
Visual Basic
Public Overridable Property Time As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ Time {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


UID Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..UID Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string UID { get; set; }
Visual Basic
Public Overridable Property UID As String
    Get
    Set
Visual C++
public:
virtual property String^ UID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


ValueType Property

[image]

Merge DICOM .NET/C# Toolkit
MCprotocolContextItem..::..ValueType Property
MCprotocolContextItem Class See Also Send Feedback
Represents the value for the Value Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ValueType { get; set; }
Visual Basic
Public Overridable Property ValueType As String
    Get
    Set
Visual C++
public:
virtual property String^ ValueType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCprotocolContextItem Class
MCprotocolContextItem Members
Mergecom.Gen Namespace


MCquantityItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the QUANTITY Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCquantityItem
Visual Basic
Public Class MCquantityItem
Visual C++
public ref class MCquantityItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00400294) Quantity
  • (00400295) Measuring Units Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCquantityItem

See Also

MCquantityItem Members
Mergecom.Gen Namespace


MCquantityItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Members
MCquantityItem Class Constructors Methods Properties See Also Send Feedback

The MCquantityItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCquantityItem()()()() | Constructs an MCquantityItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCquantityItem(MCitem) | Constructs an MCquantityItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeMeasuringUnits | This method removes all the values that may have been set for Measuring Units Sequence.
Public method | removeQuantity | This method removes all the values that may have been set for Quantity.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasuringUnits | Represents the values for the Measuring Units Sequence attribute.
Public property | Quantity | Represents the value for the Quantity attribute.

See Also

MCquantityItem Class
Mergecom.Gen Namespace


MCquantityItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Constructor
MCquantityItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCquantityItem()()()() | Constructs an MCquantityItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCquantityItem(MCitem) | Constructs an MCquantityItem collection by wrapping an existing MCitem instance.

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


MCquantityItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Constructor
MCquantityItem Class See Also Send Feedback
Constructs an MCquantityItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCquantityItem()
Visual Basic
Public Sub New
Visual C++
public:
MCquantityItem()

See Also

MCquantityItem Class
MCquantityItem Members
MCquantityItem Overload
Mergecom.Gen Namespace


MCquantityItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Constructor (MCitem)
MCquantityItem Class See Also Send Feedback
Constructs an MCquantityItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCquantityItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCquantityItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCquantityItem Class
MCquantityItem Members
MCquantityItem Overload
Mergecom.Gen Namespace


MCquantityItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Methods
MCquantityItem Class See Also Send Feedback

The MCquantityItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeMeasuringUnits | This method removes all the values that may have been set for Measuring Units Sequence.
Public method | removeQuantity | This method removes all the values that may have been set for Quantity.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCquantityItem Class
Mergecom.Gen Namespace


removeMeasuringUnits Method

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem..::..removeMeasuringUnits Method
MCquantityItem Class See Also Send Feedback
This method removes all the values that may have been set for Measuring Units Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMeasuringUnits()
Visual Basic
Public Overridable Sub removeMeasuringUnits
Visual C++
public:
virtual void removeMeasuringUnits()

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


removeQuantity Method

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem..::..removeQuantity Method
MCquantityItem Class See Also Send Feedback
This method removes all the values that may have been set for Quantity.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeQuantity()
Visual Basic
Public Overridable Sub removeQuantity
Visual C++
public:
virtual void removeQuantity()

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


MCquantityItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCquantityItem Properties
MCquantityItem Class See Also Send Feedback

The MCquantityItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MeasuringUnits | Represents the values for the Measuring Units Sequence attribute.
Public property | Quantity | Represents the value for the Quantity attribute.

See Also

MCquantityItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem..::..Host Property
MCquantityItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


MeasuringUnits Property

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem..::..MeasuringUnits Property
MCquantityItem Class See Also Send Feedback
Represents the values for the Measuring Units Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCmeasuringUnitsItem[] MeasuringUnits { get; set; }
Visual Basic
Public Overridable Property MeasuringUnits As MCmeasuringUnitsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCmeasuringUnitsItem^>^ MeasuringUnits {
    array<MCmeasuringUnitsItem^>^ get ();
    void set (array<MCmeasuringUnitsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


Quantity Property

[image]

Merge DICOM .NET/C# Toolkit
MCquantityItem..::..Quantity Property
MCquantityItem Class See Also Send Feedback
Represents the value for the Quantity attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Quantity { get; set; }
Visual Basic
Public Overridable Property Quantity As String
    Get
    Set
Visual C++
public:
virtual property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCquantityItem Class
MCquantityItem Members
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_DIGITAL_SIGNATURE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedDigitalSignatureItem
Visual Basic
Public Class MCreferencedDigitalSignatureItem
Visual C++
public ref class MCreferencedDigitalSignatureItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (04000100) Digital Signature UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedDigitalSignatureItem

See Also

MCreferencedDigitalSignatureItem Members
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Members
MCreferencedDigitalSignatureItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedDigitalSignatureItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedDigitalSignatureItem()()()() | Constructs an MCreferencedDigitalSignatureItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedDigitalSignatureItem(MCitem) | Constructs an MCreferencedDigitalSignatureItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDigitalSignatureUID | This method removes all the values that may have been set for Digital Signature UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DigitalSignatureUID | Represents the value for the Digital Signature UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCreferencedDigitalSignatureItem Class
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Constructor
MCreferencedDigitalSignatureItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedDigitalSignatureItem()()()() | Constructs an MCreferencedDigitalSignatureItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedDigitalSignatureItem(MCitem) | Constructs an MCreferencedDigitalSignatureItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Constructor
MCreferencedDigitalSignatureItem Class See Also Send Feedback
Constructs an MCreferencedDigitalSignatureItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedDigitalSignatureItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedDigitalSignatureItem()

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
MCreferencedDigitalSignatureItem Overload
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Constructor (MCitem)
MCreferencedDigitalSignatureItem Class See Also Send Feedback
Constructs an MCreferencedDigitalSignatureItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedDigitalSignatureItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedDigitalSignatureItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
MCreferencedDigitalSignatureItem Overload
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Methods
MCreferencedDigitalSignatureItem Class See Also Send Feedback

The MCreferencedDigitalSignatureItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDigitalSignatureUID | This method removes all the values that may have been set for Digital Signature UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedDigitalSignatureItem Class
Mergecom.Gen Namespace


removeDigitalSignatureUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem..::..removeDigitalSignatureUID Method
MCreferencedDigitalSignatureItem Class See Also Send Feedback
This method removes all the values that may have been set for Digital Signature UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDigitalSignatureUID()
Visual Basic
Public Overridable Sub removeDigitalSignatureUID
Visual C++
public:
virtual void removeDigitalSignatureUID()

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
Mergecom.Gen Namespace


MCreferencedDigitalSignatureItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem Properties
MCreferencedDigitalSignatureItem Class See Also Send Feedback

The MCreferencedDigitalSignatureItem type exposes the following members.

Properties

 | Name | Description
Public property | DigitalSignatureUID | Represents the value for the Digital Signature UID attribute.
Public property | Host | Gets the MCitem object wrapped by this container.

See Also

MCreferencedDigitalSignatureItem Class
Mergecom.Gen Namespace


DigitalSignatureUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem..::..DigitalSignatureUID Property
MCreferencedDigitalSignatureItem Class See Also Send Feedback
Represents the value for the Digital Signature UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string DigitalSignatureUID { get; set; }
Visual Basic
Public Overridable Property DigitalSignatureUID As String
    Get
    Set
Visual C++
public:
virtual property String^ DigitalSignatureUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedDigitalSignatureItem..::..Host Property
MCreferencedDigitalSignatureItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedDigitalSignatureItem Class
MCreferencedDigitalSignatureItem Members
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_G_P_SCHEDULED_PROCEDURE_STEP Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedGeneralPurposeScheduledProcedureSteItem
Visual Basic
Public Class MCreferencedGeneralPurposeScheduledProcedureSteItem
Visual C++
public ref class MCreferencedGeneralPurposeScheduledProcedureSteItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (00404023) Referenced GP Scheduled Procedure Step Transaction

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedGeneralPurposeScheduledProcedureSteItem

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
MCreferencedGeneralPurposeScheduledProcedureSteItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedGeneralPurposeScheduledProcedureSteItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedGeneralPurposeScheduledProcedureSteItem()()()() | Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedGeneralPurposeScheduledProcedureSteItem(MCitem) | Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedGPScheduledProcedureStepTransaction | This method removes all the values that may have been set for Referenced GP Scheduled Procedure Step Transaction.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedGPScheduledProcedureStepTransaction | Represents the value for the Referenced GP Scheduled Procedure Step Transaction attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedGeneralPurposeScheduledProcedureSteItem()()()() | Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedGeneralPurposeScheduledProcedureSteItem(MCitem) | Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedGeneralPurposeScheduledProcedureSteItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedGeneralPurposeScheduledProcedureSteItem()

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
MCreferencedGeneralPurposeScheduledProcedureSteItem Overload
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Constructor (MCitem)
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Constructs an MCreferencedGeneralPurposeScheduledProcedureSteItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedGeneralPurposeScheduledProcedureSteItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedGeneralPurposeScheduledProcedureSteItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
MCreferencedGeneralPurposeScheduledProcedureSteItem Overload
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Methods
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback

The MCreferencedGeneralPurposeScheduledProcedureSteItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedGPScheduledProcedureStepTransaction | This method removes all the values that may have been set for Referenced GP Scheduled Procedure Step Transaction.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
Mergecom.Gen Namespace


removeReferencedGPScheduledProcedureStepTransaction Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..removeReferencedGPScheduledProcedureStepTransaction Method
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced GP Scheduled Procedure Step Transaction.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedGPScheduledProcedureStepTransaction()
Visual Basic
Public Overridable Sub removeReferencedGPScheduledProcedureStepTransaction
Visual C++
public:
virtual void removeReferencedGPScheduledProcedureStepTransaction()

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..removeReferencedSOPClassUID Method
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..removeReferencedSOPInstanceUID Method
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


MCreferencedGeneralPurposeScheduledProcedureSteItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem Properties
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback

The MCreferencedGeneralPurposeScheduledProcedureSteItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedGPScheduledProcedureStepTransaction | Represents the value for the Referenced GP Scheduled Procedure Step Transaction attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..Host Property
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


ReferencedGPScheduledProcedureStepTransaction Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..ReferencedGPScheduledProcedureStepTransaction Property
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Represents the value for the Referenced GP Scheduled Procedure Step Transaction attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedGPScheduledProcedureStepTransaction { get; set; }
Visual Basic
Public Overridable Property ReferencedGPScheduledProcedureStepTransaction As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedGPScheduledProcedureStepTransaction {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..ReferencedSOPClassUID Property
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedGeneralPurposeScheduledProcedureSteItem..::..ReferencedSOPInstanceUID Property
MCreferencedGeneralPurposeScheduledProcedureSteItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedGeneralPurposeScheduledProcedureSteItem Class
MCreferencedGeneralPurposeScheduledProcedureSteItem Members
Mergecom.Gen Namespace


MCreferencedImageItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_IMAGE_IN_REF_SERIES Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedImageItem
Visual Basic
Public Class MCreferencedImageItem
Visual C++
public ref class MCreferencedImageItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080054) Retrieve AE Title
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (00880130) Storage Media File-set ID
  • (00880140) Storage Media File-set UID
  • (00081160) Referenced Frame Number
  • (00100020) Patient ID
  • (0020000D) Study Instance UID
  • (0020000E) Series Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedImageItem

See Also

MCreferencedImageItem Members
Mergecom.Gen Namespace


MCreferencedImageItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Members
MCreferencedImageItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedImageItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedImageItem()()()() | Constructs an MCreferencedImageItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedImageItem(MCitem) | Constructs an MCreferencedImageItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removeReferencedFrameNumbers | This method removes all the values that may have been set for Referenced Frame Number.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | removeStorageMediaFilesetID | This method removes all the values that may have been set for Storage Media File-set ID.
Public method | removeStorageMediaFilesetUID | This method removes all the values that may have been set for Storage Media File-set UID.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | ReferencedFrameNumbers | Represents the values for the Referenced Frame Number attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.
Public property | StorageMediaFilesetID | Represents the value for the Storage Media File-set ID attribute.
Public property | StorageMediaFilesetUID | Represents the value for the Storage Media File-set UID attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCreferencedImageItem Class
Mergecom.Gen Namespace


MCreferencedImageItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Constructor
MCreferencedImageItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedImageItem()()()() | Constructs an MCreferencedImageItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedImageItem(MCitem) | Constructs an MCreferencedImageItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


MCreferencedImageItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Constructor
MCreferencedImageItem Class See Also Send Feedback
Constructs an MCreferencedImageItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedImageItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedImageItem()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
MCreferencedImageItem Overload
Mergecom.Gen Namespace


MCreferencedImageItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Constructor (MCitem)
MCreferencedImageItem Class See Also Send Feedback
Constructs an MCreferencedImageItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedImageItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedImageItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
MCreferencedImageItem Overload
Mergecom.Gen Namespace


MCreferencedImageItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Methods
MCreferencedImageItem Class See Also Send Feedback

The MCreferencedImageItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removePatientID | This method removes all the values that may have been set for Patient ID.
Public method | removeReferencedFrameNumbers | This method removes all the values that may have been set for Referenced Frame Number.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | removeStorageMediaFilesetID | This method removes all the values that may have been set for Storage Media File-set ID.
Public method | removeStorageMediaFilesetUID | This method removes all the values that may have been set for Storage Media File-set UID.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedImageItem Class
Mergecom.Gen Namespace


removePatientID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removePatientID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Patient ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePatientID()
Visual Basic
Public Overridable Sub removePatientID
Visual C++
public:
virtual void removePatientID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeReferencedFrameNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeReferencedFrameNumbers Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Frame Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedFrameNumbers()
Visual Basic
Public Overridable Sub removeReferencedFrameNumbers
Visual C++
public:
virtual void removeReferencedFrameNumbers()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeReferencedSOPClassUID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeReferencedSOPInstanceUID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeRetrieveAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeRetrieveAETitles Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Retrieve AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRetrieveAETitles()
Visual Basic
Public Overridable Sub removeRetrieveAETitles
Visual C++
public:
virtual void removeRetrieveAETitles()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeSeriesInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeSeriesInstanceUID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInstanceUID()
Visual Basic
Public Overridable Sub removeSeriesInstanceUID
Visual C++
public:
virtual void removeSeriesInstanceUID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeStorageMediaFilesetID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeStorageMediaFilesetID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Storage Media File-set ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStorageMediaFilesetID()
Visual Basic
Public Overridable Sub removeStorageMediaFilesetID
Visual C++
public:
virtual void removeStorageMediaFilesetID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeStorageMediaFilesetUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeStorageMediaFilesetUID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Storage Media File-set UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStorageMediaFilesetUID()
Visual Basic
Public Overridable Sub removeStorageMediaFilesetUID
Visual C++
public:
virtual void removeStorageMediaFilesetUID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..removeStudyInstanceUID Method
MCreferencedImageItem Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


MCreferencedImageItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem Properties
MCreferencedImageItem Class See Also Send Feedback

The MCreferencedImageItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PatientID | Represents the value for the Patient ID attribute.
Public property | ReferencedFrameNumbers | Represents the values for the Referenced Frame Number attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.
Public property | StorageMediaFilesetID | Represents the value for the Storage Media File-set ID attribute.
Public property | StorageMediaFilesetUID | Represents the value for the Storage Media File-set UID attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCreferencedImageItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..Host Property
MCreferencedImageItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


PatientID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..PatientID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Patient ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PatientID { get; set; }
Visual Basic
Public Overridable Property PatientID As String
    Get
    Set
Visual C++
public:
virtual property String^ PatientID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


ReferencedFrameNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..ReferencedFrameNumbers Property
MCreferencedImageItem Class See Also Send Feedback
Represents the values for the Referenced Frame Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ReferencedFrameNumbers { get; set; }
Visual Basic
Public Overridable Property ReferencedFrameNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ReferencedFrameNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..ReferencedSOPClassUID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..ReferencedSOPInstanceUID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


RetrieveAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..RetrieveAETitles Property
MCreferencedImageItem Class See Also Send Feedback
Represents the values for the Retrieve AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] RetrieveAETitles { get; set; }
Visual Basic
Public Overridable Property RetrieveAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ RetrieveAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


SeriesInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..SeriesInstanceUID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Series Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInstanceUID { get; set; }
Visual Basic
Public Overridable Property SeriesInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


StorageMediaFilesetID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..StorageMediaFilesetID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Storage Media File-set ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StorageMediaFilesetID { get; set; }
Visual Basic
Public Overridable Property StorageMediaFilesetID As String
    Get
    Set
Visual C++
public:
virtual property String^ StorageMediaFilesetID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


StorageMediaFilesetUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..StorageMediaFilesetUID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Storage Media File-set UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StorageMediaFilesetUID { get; set; }
Visual Basic
Public Overridable Property StorageMediaFilesetUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StorageMediaFilesetUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedImageItem..::..StudyInstanceUID Property
MCreferencedImageItem Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedImageItem Class
MCreferencedImageItem Members
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_PATIENT_ALIAS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedPatientAliasItem
Visual Basic
Public Class MCreferencedPatientAliasItem
Visual C++
public ref class MCreferencedPatientAliasItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedPatientAliasItem

See Also

MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Members
MCreferencedPatientAliasItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedPatientAliasItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedPatientAliasItem()()()() | Constructs an MCreferencedPatientAliasItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPatientAliasItem(MCitem) | Constructs an MCreferencedPatientAliasItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPatientAliasItem Class
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Constructor
MCreferencedPatientAliasItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedPatientAliasItem()()()() | Constructs an MCreferencedPatientAliasItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPatientAliasItem(MCitem) | Constructs an MCreferencedPatientAliasItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Constructor
MCreferencedPatientAliasItem Class See Also Send Feedback
Constructs an MCreferencedPatientAliasItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPatientAliasItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedPatientAliasItem()

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
MCreferencedPatientAliasItem Overload
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Constructor (MCitem)
MCreferencedPatientAliasItem Class See Also Send Feedback
Constructs an MCreferencedPatientAliasItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPatientAliasItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedPatientAliasItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
MCreferencedPatientAliasItem Overload
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Methods
MCreferencedPatientAliasItem Class See Also Send Feedback

The MCreferencedPatientAliasItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedPatientAliasItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem..::..removeReferencedSOPClassUID Method
MCreferencedPatientAliasItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem..::..removeReferencedSOPInstanceUID Method
MCreferencedPatientAliasItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


MCreferencedPatientAliasItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem Properties
MCreferencedPatientAliasItem Class See Also Send Feedback

The MCreferencedPatientAliasItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPatientAliasItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem..::..Host Property
MCreferencedPatientAliasItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem..::..ReferencedSOPClassUID Property
MCreferencedPatientAliasItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientAliasItem..::..ReferencedSOPInstanceUID Property
MCreferencedPatientAliasItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPatientAliasItem Class
MCreferencedPatientAliasItem Members
Mergecom.Gen Namespace


MCreferencedPatientItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_PATIENT Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedPatientItem
Visual Basic
Public Class MCreferencedPatientItem
Visual C++
public ref class MCreferencedPatientItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedPatientItem

See Also

MCreferencedPatientItem Members
Mergecom.Gen Namespace


MCreferencedPatientItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Members
MCreferencedPatientItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedPatientItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedPatientItem()()()() | Constructs an MCreferencedPatientItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPatientItem(MCitem) | Constructs an MCreferencedPatientItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPatientItem Class
Mergecom.Gen Namespace


MCreferencedPatientItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Constructor
MCreferencedPatientItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedPatientItem()()()() | Constructs an MCreferencedPatientItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPatientItem(MCitem) | Constructs an MCreferencedPatientItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


MCreferencedPatientItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Constructor
MCreferencedPatientItem Class See Also Send Feedback
Constructs an MCreferencedPatientItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPatientItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedPatientItem()

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
MCreferencedPatientItem Overload
Mergecom.Gen Namespace


MCreferencedPatientItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Constructor (MCitem)
MCreferencedPatientItem Class See Also Send Feedback
Constructs an MCreferencedPatientItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPatientItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedPatientItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
MCreferencedPatientItem Overload
Mergecom.Gen Namespace


MCreferencedPatientItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Methods
MCreferencedPatientItem Class See Also Send Feedback

The MCreferencedPatientItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedPatientItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem..::..removeReferencedSOPClassUID Method
MCreferencedPatientItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem..::..removeReferencedSOPInstanceUID Method
MCreferencedPatientItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


MCreferencedPatientItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem Properties
MCreferencedPatientItem Class See Also Send Feedback

The MCreferencedPatientItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPatientItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem..::..Host Property
MCreferencedPatientItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem..::..ReferencedSOPClassUID Property
MCreferencedPatientItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPatientItem..::..ReferencedSOPInstanceUID Property
MCreferencedPatientItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPatientItem Class
MCreferencedPatientItem Members
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_STUDY_COMPONENT Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedPerformedProcedureStepItem
Visual Basic
Public Class MCreferencedPerformedProcedureStepItem
Visual C++
public ref class MCreferencedPerformedProcedureStepItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedPerformedProcedureStepItem

See Also

MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Members
MCreferencedPerformedProcedureStepItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedPerformedProcedureStepItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedPerformedProcedureStepItem()()()() | Constructs an MCreferencedPerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPerformedProcedureStepItem(MCitem) | Constructs an MCreferencedPerformedProcedureStepItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPerformedProcedureStepItem Class
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Constructor
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedPerformedProcedureStepItem()()()() | Constructs an MCreferencedPerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedPerformedProcedureStepItem(MCitem) | Constructs an MCreferencedPerformedProcedureStepItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Constructor
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
Constructs an MCreferencedPerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPerformedProcedureStepItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedPerformedProcedureStepItem()

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
MCreferencedPerformedProcedureStepItem Overload
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Constructor (MCitem)
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
Constructs an MCreferencedPerformedProcedureStepItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedPerformedProcedureStepItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedPerformedProcedureStepItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
MCreferencedPerformedProcedureStepItem Overload
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Methods
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback

The MCreferencedPerformedProcedureStepItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedPerformedProcedureStepItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem..::..removeReferencedSOPClassUID Method
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem..::..removeReferencedSOPInstanceUID Method
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCreferencedPerformedProcedureStepItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem Properties
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback

The MCreferencedPerformedProcedureStepItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedPerformedProcedureStepItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem..::..Host Property
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem..::..ReferencedSOPClassUID Property
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedPerformedProcedureStepItem..::..ReferencedSOPInstanceUID Property
MCreferencedPerformedProcedureStepItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedPerformedProcedureStepItem Class
MCreferencedPerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCreferencedRequestItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REFERENCED_REQUEST Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedRequestItem
Visual Basic
Public Class MCreferencedRequestItem
Visual C++
public ref class MCreferencedRequestItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080050) Accession Number
  • (00080051) Issuer of Accession Number Sequence
  • (00081110) Referenced Study Sequence
  • (0020000D) Study Instance UID
  • (00321031) Requesting Physician Identification Sequence
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321034) Requesting Service Code Sequence
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00400026) Order Placer Identifier Sequence
  • (00400027) Order Filler Identifier Sequence
  • (00401001) Requested Procedure ID
  • (00401002) Reason for the Requested Procedure
  • (0040100A) Reason for Requested Procedure Code Sequence
  • (00402016) Placer Order Number / Imaging Service Request
  • (00402017) Filler Order Number / Imaging Service Request

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedRequestItem

See Also

MCreferencedRequestItem Members
Mergecom.Gen Namespace


MCreferencedRequestItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Members
MCreferencedRequestItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedRequestItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedRequestItem()()()() | Constructs an MCreferencedRequestItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedRequestItem(MCitem) | Constructs an MCreferencedRequestItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removeReasonForRequestedProcedureCodes | This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.
Public method | removeReasonForTheRequestedProcedure | This method removes all the values that may have been set for Reason for the Requested Procedure.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingPhysicianIdentifications | This method removes all the values that may have been set for Requesting Physician Identification Sequence.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeRequestingServiceCodes | This method removes all the values that may have been set for Requesting Service Code Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | ReasonForRequestedProcedureCodes | Represents the values for the Reason for Requested Procedure Code Sequence attribute.
Public property | ReasonForTheRequestedProcedure | Represents the value for the Reason for the Requested Procedure attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingPhysicianIdentifications | Represents the values for the Requesting Physician Identification Sequence attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | RequestingServiceCodes | Represents the values for the Requesting Service Code Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCreferencedRequestItem Class
Mergecom.Gen Namespace


MCreferencedRequestItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Constructor
MCreferencedRequestItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedRequestItem()()()() | Constructs an MCreferencedRequestItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedRequestItem(MCitem) | Constructs an MCreferencedRequestItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


MCreferencedRequestItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Constructor
MCreferencedRequestItem Class See Also Send Feedback
Constructs an MCreferencedRequestItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedRequestItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedRequestItem()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
MCreferencedRequestItem Overload
Mergecom.Gen Namespace


MCreferencedRequestItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Constructor (MCitem)
MCreferencedRequestItem Class See Also Send Feedback
Constructs an MCreferencedRequestItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedRequestItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedRequestItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
MCreferencedRequestItem Overload
Mergecom.Gen Namespace


MCreferencedRequestItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Methods
MCreferencedRequestItem Class See Also Send Feedback

The MCreferencedRequestItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removeReasonForRequestedProcedureCodes | This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.
Public method | removeReasonForTheRequestedProcedure | This method removes all the values that may have been set for Reason for the Requested Procedure.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingPhysicianIdentifications | This method removes all the values that may have been set for Requesting Physician Identification Sequence.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeRequestingServiceCodes | This method removes all the values that may have been set for Requesting Service Code Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedRequestItem Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeAccessionNumber Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeFillerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeFillerOrderNumberImagingServiceRequest Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFillerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removeFillerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removeFillerOrderNumberImagingServiceRequest()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeIssuerOfAccessionNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeIssuerOfAccessionNumbers Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Accession Number Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAccessionNumbers()
Visual Basic
Public Overridable Sub removeIssuerOfAccessionNumbers
Visual C++
public:
virtual void removeIssuerOfAccessionNumbers()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeOrderFillerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeOrderFillerIdentifiers Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Order Filler Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderFillerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderFillerIdentifiers
Visual C++
public:
virtual void removeOrderFillerIdentifiers()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeOrderPlacerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeOrderPlacerIdentifiers Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Order Placer Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderPlacerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderPlacerIdentifiers
Visual C++
public:
virtual void removeOrderPlacerIdentifiers()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removePlacerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removePlacerOrderNumberImagingServiceRequest Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePlacerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removePlacerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removePlacerOrderNumberImagingServiceRequest()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeReasonForRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeReasonForRequestedProcedureCodes Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeReasonForRequestedProcedureCodes
Visual C++
public:
virtual void removeReasonForRequestedProcedureCodes()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeReasonForTheRequestedProcedure Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeReasonForTheRequestedProcedure Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Reason for the Requested Procedure.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForTheRequestedProcedure()
Visual Basic
Public Overridable Sub removeReasonForTheRequestedProcedure
Visual C++
public:
virtual void removeReasonForTheRequestedProcedure()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeReferencedStudies Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestedProcedureCodes Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestedProcedureDescription Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestedProcedureID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestedProcedureID Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureID()
Visual Basic
Public Overridable Sub removeRequestedProcedureID
Visual C++
public:
virtual void removeRequestedProcedureID()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestingPhysician Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestingPhysicianIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestingPhysicianIdentifications Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysicianIdentifications()
Visual Basic
Public Overridable Sub removeRequestingPhysicianIdentifications
Visual C++
public:
virtual void removeRequestingPhysicianIdentifications()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestingService Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeRequestingServiceCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeRequestingServiceCodes Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingServiceCodes()
Visual Basic
Public Overridable Sub removeRequestingServiceCodes
Visual C++
public:
virtual void removeRequestingServiceCodes()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..removeStudyInstanceUID Method
MCreferencedRequestItem Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


MCreferencedRequestItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem Properties
MCreferencedRequestItem Class See Also Send Feedback

The MCreferencedRequestItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | ReasonForRequestedProcedureCodes | Represents the values for the Reason for Requested Procedure Code Sequence attribute.
Public property | ReasonForTheRequestedProcedure | Represents the value for the Reason for the Requested Procedure attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingPhysicianIdentifications | Represents the values for the Requesting Physician Identification Sequence attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | RequestingServiceCodes | Represents the values for the Requesting Service Code Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCreferencedRequestItem Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..AccessionNumber Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


FillerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..FillerOrderNumberImagingServiceRequest Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Filler Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FillerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property FillerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ FillerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..Host Property
MCreferencedRequestItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


IssuerOfAccessionNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..IssuerOfAccessionNumbers Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Issuer of Accession Number Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAccessionNumbers { get; set; }
Visual Basic
Public Overridable Property IssuerOfAccessionNumbers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAccessionNumbers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


OrderFillerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..OrderFillerIdentifiers Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Order Filler Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderFillerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderFillerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderFillerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


OrderPlacerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..OrderPlacerIdentifiers Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Order Placer Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderPlacerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderPlacerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderPlacerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


PlacerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..PlacerOrderNumberImagingServiceRequest Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Placer Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PlacerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property PlacerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ PlacerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


ReasonForRequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..ReasonForRequestedProcedureCodes Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Reason for Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ReasonForRequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ReasonForRequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ReasonForRequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


ReasonForTheRequestedProcedure Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..ReasonForTheRequestedProcedure Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Reason for the Requested Procedure attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForTheRequestedProcedure { get; set; }
Visual Basic
Public Overridable Property ReasonForTheRequestedProcedure As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForTheRequestedProcedure {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..ReferencedStudies Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestedProcedureCodes Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestedProcedureDescription Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestedProcedureID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestedProcedureID Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Requested Procedure ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureID { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureID As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestingPhysician Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestingPhysicianIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestingPhysicianIdentifications Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Requesting Physician Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] RequestingPhysicianIdentifications { get; set; }
Visual Basic
Public Overridable Property RequestingPhysicianIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ RequestingPhysicianIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestingService Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


RequestingServiceCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..RequestingServiceCodes Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the values for the Requesting Service Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestingServiceCodes { get; set; }
Visual Basic
Public Overridable Property RequestingServiceCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestingServiceCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRequestItem..::..StudyInstanceUID Property
MCreferencedRequestItem Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRequestItem Class
MCreferencedRequestItem Members
Mergecom.Gen Namespace


MCreferencedResultsItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_RESULTS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedResultsItem
Visual Basic
Public Class MCreferencedResultsItem
Visual C++
public ref class MCreferencedResultsItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedResultsItem

See Also

MCreferencedResultsItem Members
Mergecom.Gen Namespace


MCreferencedResultsItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Members
MCreferencedResultsItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedResultsItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedResultsItem()()()() | Constructs an MCreferencedResultsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedResultsItem(MCitem) | Constructs an MCreferencedResultsItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedResultsItem Class
Mergecom.Gen Namespace


MCreferencedResultsItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Constructor
MCreferencedResultsItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedResultsItem()()()() | Constructs an MCreferencedResultsItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedResultsItem(MCitem) | Constructs an MCreferencedResultsItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


MCreferencedResultsItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Constructor
MCreferencedResultsItem Class See Also Send Feedback
Constructs an MCreferencedResultsItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedResultsItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedResultsItem()

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
MCreferencedResultsItem Overload
Mergecom.Gen Namespace


MCreferencedResultsItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Constructor (MCitem)
MCreferencedResultsItem Class See Also Send Feedback
Constructs an MCreferencedResultsItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedResultsItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedResultsItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
MCreferencedResultsItem Overload
Mergecom.Gen Namespace


MCreferencedResultsItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Methods
MCreferencedResultsItem Class See Also Send Feedback

The MCreferencedResultsItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedResultsItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem..::..removeReferencedSOPClassUID Method
MCreferencedResultsItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem..::..removeReferencedSOPInstanceUID Method
MCreferencedResultsItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


MCreferencedResultsItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem Properties
MCreferencedResultsItem Class See Also Send Feedback

The MCreferencedResultsItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedResultsItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem..::..Host Property
MCreferencedResultsItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem..::..ReferencedSOPClassUID Property
MCreferencedResultsItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedResultsItem..::..ReferencedSOPInstanceUID Property
MCreferencedResultsItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedResultsItem Class
MCreferencedResultsItem Members
Mergecom.Gen Namespace


MCreferencedRTPlanItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_RT_PLAN Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedRTPlanItem
Visual Basic
Public Class MCreferencedRTPlanItem
Visual C++
public ref class MCreferencedRTPlanItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedRTPlanItem

See Also

MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


MCreferencedRTPlanItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Members
MCreferencedRTPlanItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedRTPlanItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedRTPlanItem()()()() | Constructs an MCreferencedRTPlanItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedRTPlanItem(MCitem) | Constructs an MCreferencedRTPlanItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedRTPlanItem Class
Mergecom.Gen Namespace


MCreferencedRTPlanItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Constructor
MCreferencedRTPlanItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedRTPlanItem()()()() | Constructs an MCreferencedRTPlanItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedRTPlanItem(MCitem) | Constructs an MCreferencedRTPlanItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


MCreferencedRTPlanItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Constructor
MCreferencedRTPlanItem Class See Also Send Feedback
Constructs an MCreferencedRTPlanItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedRTPlanItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedRTPlanItem()

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
MCreferencedRTPlanItem Overload
Mergecom.Gen Namespace


MCreferencedRTPlanItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Constructor (MCitem)
MCreferencedRTPlanItem Class See Also Send Feedback
Constructs an MCreferencedRTPlanItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedRTPlanItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedRTPlanItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
MCreferencedRTPlanItem Overload
Mergecom.Gen Namespace


MCreferencedRTPlanItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Methods
MCreferencedRTPlanItem Class See Also Send Feedback

The MCreferencedRTPlanItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedRTPlanItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem..::..removeReferencedSOPClassUID Method
MCreferencedRTPlanItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem..::..removeReferencedSOPInstanceUID Method
MCreferencedRTPlanItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


MCreferencedRTPlanItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem Properties
MCreferencedRTPlanItem Class See Also Send Feedback

The MCreferencedRTPlanItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedRTPlanItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem..::..Host Property
MCreferencedRTPlanItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem..::..ReferencedSOPClassUID Property
MCreferencedRTPlanItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedRTPlanItem..::..ReferencedSOPInstanceUID Property
MCreferencedRTPlanItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedRTPlanItem Class
MCreferencedRTPlanItem Members
Mergecom.Gen Namespace


MCreferencedSeriesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_SERIES Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedSeriesItem
Visual Basic
Public Class MCreferencedSeriesItem
Visual C++
public ref class MCreferencedSeriesItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080054) Retrieve AE Title
  • (00081140) Referenced Image Sequence
  • (0020000E) Series Instance UID
  • (00880130) Storage Media File-set ID
  • (00880140) Storage Media File-set UID
  • (00080021) Series Date
  • (00080031) Series Time
  • (00081199) Referenced SOP Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedSeriesItem

See Also

MCreferencedSeriesItem Members
Mergecom.Gen Namespace


MCreferencedSeriesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Members
MCreferencedSeriesItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedSeriesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedSeriesItem()()()() | Constructs an MCreferencedSeriesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSeriesItem(MCitem) | Constructs an MCreferencedSeriesItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedImages | This method removes all the values that may have been set for Referenced Image Sequence.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesDate | This method removes all the values that may have been set for Series Date.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | removeSeriesTime | This method removes all the values that may have been set for Series Time.
Public method | removeStorageMediaFilesetID | This method removes all the values that may have been set for Storage Media File-set ID.
Public method | removeStorageMediaFilesetUID | This method removes all the values that may have been set for Storage Media File-set UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedImages | Represents the values for the Referenced Image Sequence attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesDate | Represents the value for the Series Date attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.
Public property | SeriesTime | Represents the value for the Series Time attribute.
Public property | StorageMediaFilesetID | Represents the value for the Storage Media File-set ID attribute.
Public property | StorageMediaFilesetUID | Represents the value for the Storage Media File-set UID attribute.

See Also

MCreferencedSeriesItem Class
Mergecom.Gen Namespace


MCreferencedSeriesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Constructor
MCreferencedSeriesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedSeriesItem()()()() | Constructs an MCreferencedSeriesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSeriesItem(MCitem) | Constructs an MCreferencedSeriesItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


MCreferencedSeriesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Constructor
MCreferencedSeriesItem Class See Also Send Feedback
Constructs an MCreferencedSeriesItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSeriesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedSeriesItem()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
MCreferencedSeriesItem Overload
Mergecom.Gen Namespace


MCreferencedSeriesItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Constructor (MCitem)
MCreferencedSeriesItem Class See Also Send Feedback
Constructs an MCreferencedSeriesItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSeriesItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedSeriesItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
MCreferencedSeriesItem Overload
Mergecom.Gen Namespace


MCreferencedSeriesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Methods
MCreferencedSeriesItem Class See Also Send Feedback

The MCreferencedSeriesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedImages | This method removes all the values that may have been set for Referenced Image Sequence.
Public method | removeReferencedSOPs | This method removes all the values that may have been set for Referenced SOP Sequence.
Public method | removeRetrieveAETitles | This method removes all the values that may have been set for Retrieve AE Title.
Public method | removeSeriesDate | This method removes all the values that may have been set for Series Date.
Public method | removeSeriesInstanceUID | This method removes all the values that may have been set for Series Instance UID.
Public method | removeSeriesTime | This method removes all the values that may have been set for Series Time.
Public method | removeStorageMediaFilesetID | This method removes all the values that may have been set for Storage Media File-set ID.
Public method | removeStorageMediaFilesetUID | This method removes all the values that may have been set for Storage Media File-set UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedSeriesItem Class
Mergecom.Gen Namespace


removeReferencedImages Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeReferencedImages Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Image Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedImages()
Visual Basic
Public Overridable Sub removeReferencedImages
Visual C++
public:
virtual void removeReferencedImages()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeReferencedSOPs Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeReferencedSOPs Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPs()
Visual Basic
Public Overridable Sub removeReferencedSOPs
Visual C++
public:
virtual void removeReferencedSOPs()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeRetrieveAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeRetrieveAETitles Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Retrieve AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRetrieveAETitles()
Visual Basic
Public Overridable Sub removeRetrieveAETitles
Visual C++
public:
virtual void removeRetrieveAETitles()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeSeriesDate Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesDate()
Visual Basic
Public Overridable Sub removeSeriesDate
Visual C++
public:
virtual void removeSeriesDate()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeSeriesInstanceUID Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInstanceUID()
Visual Basic
Public Overridable Sub removeSeriesInstanceUID
Visual C++
public:
virtual void removeSeriesInstanceUID()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeSeriesTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeSeriesTime Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Series Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesTime()
Visual Basic
Public Overridable Sub removeSeriesTime
Visual C++
public:
virtual void removeSeriesTime()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeStorageMediaFilesetID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeStorageMediaFilesetID Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Storage Media File-set ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStorageMediaFilesetID()
Visual Basic
Public Overridable Sub removeStorageMediaFilesetID
Visual C++
public:
virtual void removeStorageMediaFilesetID()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


removeStorageMediaFilesetUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..removeStorageMediaFilesetUID Method
MCreferencedSeriesItem Class See Also Send Feedback
This method removes all the values that may have been set for Storage Media File-set UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStorageMediaFilesetUID()
Visual Basic
Public Overridable Sub removeStorageMediaFilesetUID
Visual C++
public:
virtual void removeStorageMediaFilesetUID()

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


MCreferencedSeriesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem Properties
MCreferencedSeriesItem Class See Also Send Feedback

The MCreferencedSeriesItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedImages | Represents the values for the Referenced Image Sequence attribute.
Public property | ReferencedSOPs | Represents the values for the Referenced SOP Sequence attribute.
Public property | RetrieveAETitles | Represents the values for the Retrieve AE Title attribute.
Public property | SeriesDate | Represents the value for the Series Date attribute.
Public property | SeriesInstanceUID | Represents the value for the Series Instance UID attribute.
Public property | SeriesTime | Represents the value for the Series Time attribute.
Public property | StorageMediaFilesetID | Represents the value for the Storage Media File-set ID attribute.
Public property | StorageMediaFilesetUID | Represents the value for the Storage Media File-set UID attribute.

See Also

MCreferencedSeriesItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..Host Property
MCreferencedSeriesItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


ReferencedImages Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..ReferencedImages Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the values for the Referenced Image Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedImageItem[] ReferencedImages { get; set; }
Visual Basic
Public Overridable Property ReferencedImages As MCreferencedImageItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedImageItem^>^ ReferencedImages {
    array<MCreferencedImageItem^>^ get ();
    void set (array<MCreferencedImageItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


ReferencedSOPs Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..ReferencedSOPs Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the values for the Referenced SOP Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSOPItem[] ReferencedSOPs { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPs As MCreferencedSOPItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSOPItem^>^ ReferencedSOPs {
    array<MCreferencedSOPItem^>^ get ();
    void set (array<MCreferencedSOPItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


RetrieveAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..RetrieveAETitles Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the values for the Retrieve AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] RetrieveAETitles { get; set; }
Visual Basic
Public Overridable Property RetrieveAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ RetrieveAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


SeriesDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..SeriesDate Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the value for the Series Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate SeriesDate { get; set; }
Visual Basic
Public Overridable Property SeriesDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ SeriesDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


SeriesInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..SeriesInstanceUID Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the value for the Series Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInstanceUID { get; set; }
Visual Basic
Public Overridable Property SeriesInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


SeriesTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..SeriesTime Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the value for the Series Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime SeriesTime { get; set; }
Visual Basic
Public Overridable Property SeriesTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ SeriesTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


StorageMediaFilesetID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..StorageMediaFilesetID Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the value for the Storage Media File-set ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StorageMediaFilesetID { get; set; }
Visual Basic
Public Overridable Property StorageMediaFilesetID As String
    Get
    Set
Visual C++
public:
virtual property String^ StorageMediaFilesetID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


StorageMediaFilesetUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSeriesItem..::..StorageMediaFilesetUID Property
MCreferencedSeriesItem Class See Also Send Feedback
Represents the value for the Storage Media File-set UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StorageMediaFilesetUID { get; set; }
Visual Basic
Public Overridable Property StorageMediaFilesetUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StorageMediaFilesetUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSeriesItem Class
MCreferencedSeriesItem Members
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_SOP_INSTANCE_MAC Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedSOPInstanceMACItem
Visual Basic
Public Class MCreferencedSOPInstanceMACItem
Visual C++
public ref class MCreferencedSOPInstanceMACItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (04000010) MAC Calculation Transfer Syntax UID
  • (04000015) MAC Algorithm
  • (04000020) Data Elements Signed

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedSOPInstanceMACItem

See Also

MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Members
MCreferencedSOPInstanceMACItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedSOPInstanceMACItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedSOPInstanceMACItem()()()() | Constructs an MCreferencedSOPInstanceMACItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSOPInstanceMACItem(MCitem) | Constructs an MCreferencedSOPInstanceMACItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDataElementsSigneds | This method removes all the values that may have been set for Data Elements Signed.
Public method | removeMACAlgorithm | This method removes all the values that may have been set for MAC Algorithm.
Public method | removeMACCalculationTransferSyntaxUID | This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataElementsSigneds | Represents the values for the Data Elements Signed attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACAlgorithm | Represents the value for the MAC Algorithm attribute.
Public property | MACCalculationTransferSyntaxUID | Represents the value for the MAC Calculation Transfer Syntax UID attribute.

See Also

MCreferencedSOPInstanceMACItem Class
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Constructor
MCreferencedSOPInstanceMACItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedSOPInstanceMACItem()()()() | Constructs an MCreferencedSOPInstanceMACItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSOPInstanceMACItem(MCitem) | Constructs an MCreferencedSOPInstanceMACItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Constructor
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Constructs an MCreferencedSOPInstanceMACItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSOPInstanceMACItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedSOPInstanceMACItem()

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
MCreferencedSOPInstanceMACItem Overload
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Constructor (MCitem)
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Constructs an MCreferencedSOPInstanceMACItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSOPInstanceMACItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedSOPInstanceMACItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
MCreferencedSOPInstanceMACItem Overload
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Methods
MCreferencedSOPInstanceMACItem Class See Also Send Feedback

The MCreferencedSOPInstanceMACItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeDataElementsSigneds | This method removes all the values that may have been set for Data Elements Signed.
Public method | removeMACAlgorithm | This method removes all the values that may have been set for MAC Algorithm.
Public method | removeMACCalculationTransferSyntaxUID | This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedSOPInstanceMACItem Class
Mergecom.Gen Namespace


removeDataElementsSigneds Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..removeDataElementsSigneds Method
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
This method removes all the values that may have been set for Data Elements Signed.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeDataElementsSigneds()
Visual Basic
Public Overridable Sub removeDataElementsSigneds
Visual C++
public:
virtual void removeDataElementsSigneds()

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


removeMACAlgorithm Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..removeMACAlgorithm Method
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC Algorithm.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACAlgorithm()
Visual Basic
Public Overridable Sub removeMACAlgorithm
Visual C++
public:
virtual void removeMACAlgorithm()

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


removeMACCalculationTransferSyntaxUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..removeMACCalculationTransferSyntaxUID Method
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
This method removes all the values that may have been set for MAC Calculation Transfer Syntax UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMACCalculationTransferSyntaxUID()
Visual Basic
Public Overridable Sub removeMACCalculationTransferSyntaxUID
Visual C++
public:
virtual void removeMACCalculationTransferSyntaxUID()

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MCreferencedSOPInstanceMACItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem Properties
MCreferencedSOPInstanceMACItem Class See Also Send Feedback

The MCreferencedSOPInstanceMACItem type exposes the following members.

Properties

 | Name | Description
Public property | DataElementsSigneds | Represents the values for the Data Elements Signed attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MACAlgorithm | Represents the value for the MAC Algorithm attribute.
Public property | MACCalculationTransferSyntaxUID | Represents the value for the MAC Calculation Transfer Syntax UID attribute.

See Also

MCreferencedSOPInstanceMACItem Class
Mergecom.Gen Namespace


DataElementsSigneds Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..DataElementsSigneds Property
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Represents the values for the Data Elements Signed attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual uint[] DataElementsSigneds { get; set; }
Visual Basic
Public Overridable Property DataElementsSigneds As UInteger()
    Get
    Set
Visual C++
public:
virtual property array<unsigned int>^ DataElementsSigneds {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..Host Property
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MACAlgorithm Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..MACAlgorithm Property
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Represents the value for the MAC Algorithm attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MACAlgorithm { get; set; }
Visual Basic
Public Overridable Property MACAlgorithm As String
    Get
    Set
Visual C++
public:
virtual property String^ MACAlgorithm {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MACCalculationTransferSyntaxUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPInstanceMACItem..::..MACCalculationTransferSyntaxUID Property
MCreferencedSOPInstanceMACItem Class See Also Send Feedback
Represents the value for the MAC Calculation Transfer Syntax UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MACCalculationTransferSyntaxUID { get; set; }
Visual Basic
Public Overridable Property MACCalculationTransferSyntaxUID As String
    Get
    Set
Visual C++
public:
virtual property String^ MACCalculationTransferSyntaxUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPInstanceMACItem Class
MCreferencedSOPInstanceMACItem Members
Mergecom.Gen Namespace


MCreferencedSOPItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REFERENCED_SOP Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedSOPItem
Visual Basic
Public Class MCreferencedSOPItem
Visual C++
public ref class MCreferencedSOPItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID
  • (0040A170) Purpose of Reference Code Sequence
  • (04000402) Referenced Digital Signature Sequence
  • (04000403) Referenced SOP Instance MAC Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedSOPItem

See Also

MCreferencedSOPItem Members
Mergecom.Gen Namespace


MCreferencedSOPItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Members
MCreferencedSOPItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedSOPItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedSOPItem()()()() | Constructs an MCreferencedSOPItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSOPItem(MCitem) | Constructs an MCreferencedSOPItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeReferencedDigitalSignatures | This method removes all the values that may have been set for Referenced Digital Signature Sequence.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceMACs | This method removes all the values that may have been set for Referenced SOP Instance MAC Sequence.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | ReferencedDigitalSignatures | Represents the values for the Referenced Digital Signature Sequence attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceMACs | Represents the values for the Referenced SOP Instance MAC Sequence attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedSOPItem Class
Mergecom.Gen Namespace


MCreferencedSOPItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Constructor
MCreferencedSOPItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedSOPItem()()()() | Constructs an MCreferencedSOPItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedSOPItem(MCitem) | Constructs an MCreferencedSOPItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


MCreferencedSOPItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Constructor
MCreferencedSOPItem Class See Also Send Feedback
Constructs an MCreferencedSOPItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSOPItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedSOPItem()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
MCreferencedSOPItem Overload
Mergecom.Gen Namespace


MCreferencedSOPItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Constructor (MCitem)
MCreferencedSOPItem Class See Also Send Feedback
Constructs an MCreferencedSOPItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedSOPItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedSOPItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
MCreferencedSOPItem Overload
Mergecom.Gen Namespace


MCreferencedSOPItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Methods
MCreferencedSOPItem Class See Also Send Feedback

The MCreferencedSOPItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removePurposeOfReferenceCodes | This method removes all the values that may have been set for Purpose of Reference Code Sequence.
Public method | removeReferencedDigitalSignatures | This method removes all the values that may have been set for Referenced Digital Signature Sequence.
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceMACs | This method removes all the values that may have been set for Referenced SOP Instance MAC Sequence.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedSOPItem Class
Mergecom.Gen Namespace


removePurposeOfReferenceCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..removePurposeOfReferenceCodes Method
MCreferencedSOPItem Class See Also Send Feedback
This method removes all the values that may have been set for Purpose of Reference Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePurposeOfReferenceCodes()
Visual Basic
Public Overridable Sub removePurposeOfReferenceCodes
Visual C++
public:
virtual void removePurposeOfReferenceCodes()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


removeReferencedDigitalSignatures Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..removeReferencedDigitalSignatures Method
MCreferencedSOPItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Digital Signature Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedDigitalSignatures()
Visual Basic
Public Overridable Sub removeReferencedDigitalSignatures
Visual C++
public:
virtual void removeReferencedDigitalSignatures()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..removeReferencedSOPClassUID Method
MCreferencedSOPItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceMACs Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..removeReferencedSOPInstanceMACs Method
MCreferencedSOPItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance MAC Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceMACs()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceMACs
Visual C++
public:
virtual void removeReferencedSOPInstanceMACs()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..removeReferencedSOPInstanceUID Method
MCreferencedSOPItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


MCreferencedSOPItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem Properties
MCreferencedSOPItem Class See Also Send Feedback

The MCreferencedSOPItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | PurposeOfReferenceCodes | Represents the values for the Purpose of Reference Code Sequence attribute.
Public property | ReferencedDigitalSignatures | Represents the values for the Referenced Digital Signature Sequence attribute.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceMACs | Represents the values for the Referenced SOP Instance MAC Sequence attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedSOPItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..Host Property
MCreferencedSOPItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


PurposeOfReferenceCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..PurposeOfReferenceCodes Property
MCreferencedSOPItem Class See Also Send Feedback
Represents the values for the Purpose of Reference Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] PurposeOfReferenceCodes { get; set; }
Visual Basic
Public Overridable Property PurposeOfReferenceCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ PurposeOfReferenceCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


ReferencedDigitalSignatures Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..ReferencedDigitalSignatures Property
MCreferencedSOPItem Class See Also Send Feedback
Represents the values for the Referenced Digital Signature Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedDigitalSignatureItem[] ReferencedDigitalSignatures { get; set; }
Visual Basic
Public Overridable Property ReferencedDigitalSignatures As MCreferencedDigitalSignatureItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedDigitalSignatureItem^>^ ReferencedDigitalSignatures {
    array<MCreferencedDigitalSignatureItem^>^ get ();
    void set (array<MCreferencedDigitalSignatureItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..ReferencedSOPClassUID Property
MCreferencedSOPItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceMACs Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..ReferencedSOPInstanceMACs Property
MCreferencedSOPItem Class See Also Send Feedback
Represents the values for the Referenced SOP Instance MAC Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSOPInstanceMACItem[] ReferencedSOPInstanceMACs { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceMACs As MCreferencedSOPInstanceMACItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSOPInstanceMACItem^>^ ReferencedSOPInstanceMACs {
    array<MCreferencedSOPInstanceMACItem^>^ get ();
    void set (array<MCreferencedSOPInstanceMACItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedSOPItem..::..ReferencedSOPInstanceUID Property
MCreferencedSOPItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedSOPItem Class
MCreferencedSOPItem Members
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_STANDALONE_SOP_INSTANCE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedStandaloneSOPInstanceItem
Visual Basic
Public Class MCreferencedStandaloneSOPInstanceItem
Visual C++
public ref class MCreferencedStandaloneSOPInstanceItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedStandaloneSOPInstanceItem

See Also

MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Members
MCreferencedStandaloneSOPInstanceItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedStandaloneSOPInstanceItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedStandaloneSOPInstanceItem()()()() | Constructs an MCreferencedStandaloneSOPInstanceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedStandaloneSOPInstanceItem(MCitem) | Constructs an MCreferencedStandaloneSOPInstanceItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedStandaloneSOPInstanceItem Class
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Constructor
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedStandaloneSOPInstanceItem()()()() | Constructs an MCreferencedStandaloneSOPInstanceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedStandaloneSOPInstanceItem(MCitem) | Constructs an MCreferencedStandaloneSOPInstanceItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Constructor
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
Constructs an MCreferencedStandaloneSOPInstanceItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedStandaloneSOPInstanceItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedStandaloneSOPInstanceItem()

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
MCreferencedStandaloneSOPInstanceItem Overload
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Constructor (MCitem)
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
Constructs an MCreferencedStandaloneSOPInstanceItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedStandaloneSOPInstanceItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedStandaloneSOPInstanceItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
MCreferencedStandaloneSOPInstanceItem Overload
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Methods
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback

The MCreferencedStandaloneSOPInstanceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedStandaloneSOPInstanceItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem..::..removeReferencedSOPClassUID Method
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem..::..removeReferencedSOPInstanceUID Method
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


MCreferencedStandaloneSOPInstanceItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem Properties
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback

The MCreferencedStandaloneSOPInstanceItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedStandaloneSOPInstanceItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem..::..Host Property
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem..::..ReferencedSOPClassUID Property
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStandaloneSOPInstanceItem..::..ReferencedSOPInstanceUID Property
MCreferencedStandaloneSOPInstanceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedStandaloneSOPInstanceItem Class
MCreferencedStandaloneSOPInstanceItem Members
Mergecom.Gen Namespace


MCreferencedStudyItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_STUDY Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedStudyItem
Visual Basic
Public Class MCreferencedStudyItem
Visual C++
public ref class MCreferencedStudyItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedStudyItem

See Also

MCreferencedStudyItem Members
Mergecom.Gen Namespace


MCreferencedStudyItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Members
MCreferencedStudyItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedStudyItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedStudyItem()()()() | Constructs an MCreferencedStudyItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedStudyItem(MCitem) | Constructs an MCreferencedStudyItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedStudyItem Class
Mergecom.Gen Namespace


MCreferencedStudyItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Constructor
MCreferencedStudyItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedStudyItem()()()() | Constructs an MCreferencedStudyItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedStudyItem(MCitem) | Constructs an MCreferencedStudyItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


MCreferencedStudyItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Constructor
MCreferencedStudyItem Class See Also Send Feedback
Constructs an MCreferencedStudyItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedStudyItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedStudyItem()

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
MCreferencedStudyItem Overload
Mergecom.Gen Namespace


MCreferencedStudyItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Constructor (MCitem)
MCreferencedStudyItem Class See Also Send Feedback
Constructs an MCreferencedStudyItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedStudyItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedStudyItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
MCreferencedStudyItem Overload
Mergecom.Gen Namespace


MCreferencedStudyItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Methods
MCreferencedStudyItem Class See Also Send Feedback

The MCreferencedStudyItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedStudyItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem..::..removeReferencedSOPClassUID Method
MCreferencedStudyItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem..::..removeReferencedSOPInstanceUID Method
MCreferencedStudyItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


MCreferencedStudyItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem Properties
MCreferencedStudyItem Class See Also Send Feedback

The MCreferencedStudyItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedStudyItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem..::..Host Property
MCreferencedStudyItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem..::..ReferencedSOPClassUID Property
MCreferencedStudyItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedStudyItem..::..ReferencedSOPInstanceUID Property
MCreferencedStudyItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedStudyItem Class
MCreferencedStudyItem Members
Mergecom.Gen Namespace


MCreferencedVisitItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the REF_VISIT Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCreferencedVisitItem
Visual Basic
Public Class MCreferencedVisitItem
Visual C++
public ref class MCreferencedVisitItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCreferencedVisitItem

See Also

MCreferencedVisitItem Members
Mergecom.Gen Namespace


MCreferencedVisitItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Members
MCreferencedVisitItem Class Constructors Methods Properties See Also Send Feedback

The MCreferencedVisitItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCreferencedVisitItem()()()() | Constructs an MCreferencedVisitItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedVisitItem(MCitem) | Constructs an MCreferencedVisitItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedVisitItem Class
Mergecom.Gen Namespace


MCreferencedVisitItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Constructor
MCreferencedVisitItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCreferencedVisitItem()()()() | Constructs an MCreferencedVisitItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCreferencedVisitItem(MCitem) | Constructs an MCreferencedVisitItem collection by wrapping an existing MCitem instance.

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


MCreferencedVisitItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Constructor
MCreferencedVisitItem Class See Also Send Feedback
Constructs an MCreferencedVisitItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedVisitItem()
Visual Basic
Public Sub New
Visual C++
public:
MCreferencedVisitItem()

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
MCreferencedVisitItem Overload
Mergecom.Gen Namespace


MCreferencedVisitItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Constructor (MCitem)
MCreferencedVisitItem Class See Also Send Feedback
Constructs an MCreferencedVisitItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCreferencedVisitItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCreferencedVisitItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
MCreferencedVisitItem Overload
Mergecom.Gen Namespace


MCreferencedVisitItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Methods
MCreferencedVisitItem Class See Also Send Feedback

The MCreferencedVisitItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCreferencedVisitItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem..::..removeReferencedSOPClassUID Method
MCreferencedVisitItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem..::..removeReferencedSOPInstanceUID Method
MCreferencedVisitItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


MCreferencedVisitItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem Properties
MCreferencedVisitItem Class See Also Send Feedback

The MCreferencedVisitItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCreferencedVisitItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem..::..Host Property
MCreferencedVisitItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem..::..ReferencedSOPClassUID Property
MCreferencedVisitItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCreferencedVisitItem..::..ReferencedSOPInstanceUID Property
MCreferencedVisitItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCreferencedVisitItem Class
MCreferencedVisitItem Members
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the RESULTING_G_P_PERFORMED_PROCEDUR Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCresultingGeneralPurposePerformedProcedureStepItem
Visual Basic
Public Class MCresultingGeneralPurposePerformedProcedureStepItem
Visual C++
public ref class MCresultingGeneralPurposePerformedProcedureStepItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCresultingGeneralPurposePerformedProcedureStepItem

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Members
MCresultingGeneralPurposePerformedProcedureStepItem Class Constructors Methods Properties See Also Send Feedback

The MCresultingGeneralPurposePerformedProcedureStepItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCresultingGeneralPurposePerformedProcedureStepItem()()()() | Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCresultingGeneralPurposePerformedProcedureStepItem(MCitem) | Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Constructor
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCresultingGeneralPurposePerformedProcedureStepItem()()()() | Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCresultingGeneralPurposePerformedProcedureStepItem(MCitem) | Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection by wrapping an existing MCitem instance.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Constructor
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCresultingGeneralPurposePerformedProcedureStepItem()
Visual Basic
Public Sub New
Visual C++
public:
MCresultingGeneralPurposePerformedProcedureStepItem()

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
MCresultingGeneralPurposePerformedProcedureStepItem Overload
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Constructor (MCitem)
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
Constructs an MCresultingGeneralPurposePerformedProcedureStepItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCresultingGeneralPurposePerformedProcedureStepItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCresultingGeneralPurposePerformedProcedureStepItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
MCresultingGeneralPurposePerformedProcedureStepItem Overload
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Methods
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback

The MCresultingGeneralPurposePerformedProcedureStepItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem..::..removeReferencedSOPClassUID Method
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem..::..removeReferencedSOPInstanceUID Method
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCresultingGeneralPurposePerformedProcedureStepItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem Properties
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback

The MCresultingGeneralPurposePerformedProcedureStepItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem..::..Host Property
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem..::..ReferencedSOPClassUID Property
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCresultingGeneralPurposePerformedProcedureStepItem..::..ReferencedSOPInstanceUID Property
MCresultingGeneralPurposePerformedProcedureStepItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCresultingGeneralPurposePerformedProcedureStepItem Class
MCresultingGeneralPurposePerformedProcedureStepItem Members
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the SCHED_HUMAN_PERFORMERS Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCscheduledHumanPerformersItem
Visual Basic
Public Class MCscheduledHumanPerformersItem
Visual C++
public ref class MCscheduledHumanPerformersItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00404009) Human Performer Code Sequence
  • (00404036) Human Performer's Organization
  • (00404037) Human Performer's Name

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCscheduledHumanPerformersItem

See Also

MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Members
MCscheduledHumanPerformersItem Class Constructors Methods Properties See Also Send Feedback

The MCscheduledHumanPerformersItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCscheduledHumanPerformersItem()()()() | Constructs an MCscheduledHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledHumanPerformersItem(MCitem) | Constructs an MCscheduledHumanPerformersItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHumanPerformerCodes | This method removes all the values that may have been set for Human Performer Code Sequence.
Public method | removeHumanPerformersName | This method removes all the values that may have been set for Human Performer's Name.
Public method | removeHumanPerformersOrganization | This method removes all the values that may have been set for Human Performer's Organization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | HumanPerformerCodes | Represents the values for the Human Performer Code Sequence attribute.
Public property | HumanPerformersName | Represents the value for the Human Performer's Name attribute.
Public property | HumanPerformersOrganization | Represents the value for the Human Performer's Organization attribute.

See Also

MCscheduledHumanPerformersItem Class
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Constructor
MCscheduledHumanPerformersItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCscheduledHumanPerformersItem()()()() | Constructs an MCscheduledHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledHumanPerformersItem(MCitem) | Constructs an MCscheduledHumanPerformersItem collection by wrapping an existing MCitem instance.

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Constructor
MCscheduledHumanPerformersItem Class See Also Send Feedback
Constructs an MCscheduledHumanPerformersItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledHumanPerformersItem()
Visual Basic
Public Sub New
Visual C++
public:
MCscheduledHumanPerformersItem()

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
MCscheduledHumanPerformersItem Overload
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Constructor (MCitem)
MCscheduledHumanPerformersItem Class See Also Send Feedback
Constructs an MCscheduledHumanPerformersItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledHumanPerformersItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCscheduledHumanPerformersItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
MCscheduledHumanPerformersItem Overload
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Methods
MCscheduledHumanPerformersItem Class See Also Send Feedback

The MCscheduledHumanPerformersItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeHumanPerformerCodes | This method removes all the values that may have been set for Human Performer Code Sequence.
Public method | removeHumanPerformersName | This method removes all the values that may have been set for Human Performer's Name.
Public method | removeHumanPerformersOrganization | This method removes all the values that may have been set for Human Performer's Organization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCscheduledHumanPerformersItem Class
Mergecom.Gen Namespace


removeHumanPerformerCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..removeHumanPerformerCodes Method
MCscheduledHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformerCodes()
Visual Basic
Public Overridable Sub removeHumanPerformerCodes
Visual C++
public:
virtual void removeHumanPerformerCodes()

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


removeHumanPerformersName Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..removeHumanPerformersName Method
MCscheduledHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformersName()
Visual Basic
Public Overridable Sub removeHumanPerformersName
Visual C++
public:
virtual void removeHumanPerformersName()

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


removeHumanPerformersOrganization Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..removeHumanPerformersOrganization Method
MCscheduledHumanPerformersItem Class See Also Send Feedback
This method removes all the values that may have been set for Human Performer's Organization.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeHumanPerformersOrganization()
Visual Basic
Public Overridable Sub removeHumanPerformersOrganization
Visual C++
public:
virtual void removeHumanPerformersOrganization()

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


MCscheduledHumanPerformersItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem Properties
MCscheduledHumanPerformersItem Class See Also Send Feedback

The MCscheduledHumanPerformersItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | HumanPerformerCodes | Represents the values for the Human Performer Code Sequence attribute.
Public property | HumanPerformersName | Represents the value for the Human Performer's Name attribute.
Public property | HumanPerformersOrganization | Represents the value for the Human Performer's Organization attribute.

See Also

MCscheduledHumanPerformersItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..Host Property
MCscheduledHumanPerformersItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformerCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..HumanPerformerCodes Property
MCscheduledHumanPerformersItem Class See Also Send Feedback
Represents the values for the Human Performer Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] HumanPerformerCodes { get; set; }
Visual Basic
Public Overridable Property HumanPerformerCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ HumanPerformerCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformersName Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..HumanPerformersName Property
MCscheduledHumanPerformersItem Class See Also Send Feedback
Represents the value for the Human Performer's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName HumanPerformersName { get; set; }
Visual Basic
Public Overridable Property HumanPerformersName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ HumanPerformersName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


HumanPerformersOrganization Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledHumanPerformersItem..::..HumanPerformersOrganization Property
MCscheduledHumanPerformersItem Class See Also Send Feedback
Represents the value for the Human Performer's Organization attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string HumanPerformersOrganization { get; set; }
Visual Basic
Public Overridable Property HumanPerformersOrganization As String
    Get
    Set
Visual C++
public:
virtual property String^ HumanPerformersOrganization {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledHumanPerformersItem Class
MCscheduledHumanPerformersItem Members
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the SCHEDULED_PROCEDURE_STEP Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCscheduledProcedureStepItem
Visual Basic
Public Class MCscheduledProcedureStepItem
Visual C++
public ref class MCscheduledProcedureStepItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080060) Modality
  • (00102210) Anatomical Orientation Type
  • (00321070) Requested Contrast Agent
  • (00400001) Scheduled Station AE Title
  • (00400002) Scheduled Procedure Step Start Date
  • (00400003) Scheduled Procedure Step Start Time
  • (00400004) Scheduled Procedure Step End Date
  • (00400005) Scheduled Procedure Step End Time
  • (00400006) Scheduled Performing Physician's Name
  • (00400007) Scheduled Procedure Step Description
  • (00400008) Scheduled Protocol Code Sequence
  • (00400009) Scheduled Procedure Step ID
  • (0040000B) Scheduled Performing Phys Identification Sequence
  • (00400010) Scheduled Station Name
  • (00400011) Scheduled Procedure Step Location
  • (00400012) Pre-Medication
  • (00400020) Scheduled Procedure Step Status
  • (00400400) Comments on the Scheduled Procedure Step
  • (00404040) Raw Data Handling

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCscheduledProcedureStepItem

See Also

MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Members
MCscheduledProcedureStepItem Class Constructors Methods Properties See Also Send Feedback

The MCscheduledProcedureStepItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCscheduledProcedureStepItem()()()() | Constructs an MCscheduledProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledProcedureStepItem(MCitem) | Constructs an MCscheduledProcedureStepItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAnatomicalOrientationType | This method removes all the values that may have been set for Anatomical Orientation Type.
Public method | removeCommentsOnTheScheduledProcedureStep | This method removes all the values that may have been set for Comments on the Scheduled Procedure Step.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePreMedication | This method removes all the values that may have been set for Pre-Medication.
Public method | removeRawDataHandling | This method removes all the values that may have been set for Raw Data Handling.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeScheduledPerformingPhysiciansName | This method removes all the values that may have been set for Scheduled Performing Physician's Name.
Public method | removeScheduledPerformingPhysIdentifications | This method removes all the values that may have been set for Scheduled Performing Phys Identification Sequence.
Public method | removeScheduledProcedureStepDescription | This method removes all the values that may have been set for Scheduled Procedure Step Description.
Public method | removeScheduledProcedureStepEndDate | This method removes all the values that may have been set for Scheduled Procedure Step End Date.
Public method | removeScheduledProcedureStepEndTime | This method removes all the values that may have been set for Scheduled Procedure Step End Time.
Public method | removeScheduledProcedureStepID | This method removes all the values that may have been set for Scheduled Procedure Step ID.
Public method | removeScheduledProcedureStepLocation | This method removes all the values that may have been set for Scheduled Procedure Step Location.
Public method | removeScheduledProcedureStepStartDate | This method removes all the values that may have been set for Scheduled Procedure Step Start Date.
Public method | removeScheduledProcedureStepStartTime | This method removes all the values that may have been set for Scheduled Procedure Step Start Time.
Public method | removeScheduledProcedureStepStatus | This method removes all the values that may have been set for Scheduled Procedure Step Status.
Public method | removeScheduledProtocolCodes | This method removes all the values that may have been set for Scheduled Protocol Code Sequence.
Public method | removeScheduledStationAETitles | This method removes all the values that may have been set for Scheduled Station AE Title.
Public method | removeScheduledStationNames | This method removes all the values that may have been set for Scheduled Station Name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnatomicalOrientationType | Represents the value for the Anatomical Orientation Type attribute.
Public property | CommentsOnTheScheduledProcedureStep | Represents the value for the Comments on the Scheduled Procedure Step attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PreMedication | Represents the value for the Pre-Medication attribute.
Public property | RawDataHandling | Represents the value for the Raw Data Handling attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | ScheduledPerformingPhysiciansName | Represents the value for the Scheduled Performing Physician's Name attribute.
Public property | ScheduledPerformingPhysIdentifications | Represents the values for the Scheduled Performing Phys Identification Sequence attribute.
Public property | ScheduledProcedureStepDescription | Represents the value for the Scheduled Procedure Step Description attribute.
Public property | ScheduledProcedureStepEndDate | Represents the value for the Scheduled Procedure Step End Date attribute.
Public property | ScheduledProcedureStepEndTime | Represents the value for the Scheduled Procedure Step End Time attribute.
Public property | ScheduledProcedureStepID | Represents the value for the Scheduled Procedure Step ID attribute.
Public property | ScheduledProcedureStepLocation | Represents the value for the Scheduled Procedure Step Location attribute.
Public property | ScheduledProcedureStepStartDate | Represents the value for the Scheduled Procedure Step Start Date attribute.
Public property | ScheduledProcedureStepStartTime | Represents the value for the Scheduled Procedure Step Start Time attribute.
Public property | ScheduledProcedureStepStatus | Represents the value for the Scheduled Procedure Step Status attribute.
Public property | ScheduledProtocolCodes | Represents the values for the Scheduled Protocol Code Sequence attribute.
Public property | ScheduledStationAETitles | Represents the values for the Scheduled Station AE Title attribute.
Public property | ScheduledStationNames | Represents the values for the Scheduled Station Name attribute.

See Also

MCscheduledProcedureStepItem Class
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Constructor
MCscheduledProcedureStepItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCscheduledProcedureStepItem()()()() | Constructs an MCscheduledProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledProcedureStepItem(MCitem) | Constructs an MCscheduledProcedureStepItem collection by wrapping an existing MCitem instance.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Constructor
MCscheduledProcedureStepItem Class See Also Send Feedback
Constructs an MCscheduledProcedureStepItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledProcedureStepItem()
Visual Basic
Public Sub New
Visual C++
public:
MCscheduledProcedureStepItem()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
MCscheduledProcedureStepItem Overload
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Constructor (MCitem)
MCscheduledProcedureStepItem Class See Also Send Feedback
Constructs an MCscheduledProcedureStepItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledProcedureStepItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCscheduledProcedureStepItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
MCscheduledProcedureStepItem Overload
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Methods
MCscheduledProcedureStepItem Class See Also Send Feedback

The MCscheduledProcedureStepItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAnatomicalOrientationType | This method removes all the values that may have been set for Anatomical Orientation Type.
Public method | removeCommentsOnTheScheduledProcedureStep | This method removes all the values that may have been set for Comments on the Scheduled Procedure Step.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removePreMedication | This method removes all the values that may have been set for Pre-Medication.
Public method | removeRawDataHandling | This method removes all the values that may have been set for Raw Data Handling.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeScheduledPerformingPhysiciansName | This method removes all the values that may have been set for Scheduled Performing Physician's Name.
Public method | removeScheduledPerformingPhysIdentifications | This method removes all the values that may have been set for Scheduled Performing Phys Identification Sequence.
Public method | removeScheduledProcedureStepDescription | This method removes all the values that may have been set for Scheduled Procedure Step Description.
Public method | removeScheduledProcedureStepEndDate | This method removes all the values that may have been set for Scheduled Procedure Step End Date.
Public method | removeScheduledProcedureStepEndTime | This method removes all the values that may have been set for Scheduled Procedure Step End Time.
Public method | removeScheduledProcedureStepID | This method removes all the values that may have been set for Scheduled Procedure Step ID.
Public method | removeScheduledProcedureStepLocation | This method removes all the values that may have been set for Scheduled Procedure Step Location.
Public method | removeScheduledProcedureStepStartDate | This method removes all the values that may have been set for Scheduled Procedure Step Start Date.
Public method | removeScheduledProcedureStepStartTime | This method removes all the values that may have been set for Scheduled Procedure Step Start Time.
Public method | removeScheduledProcedureStepStatus | This method removes all the values that may have been set for Scheduled Procedure Step Status.
Public method | removeScheduledProtocolCodes | This method removes all the values that may have been set for Scheduled Protocol Code Sequence.
Public method | removeScheduledStationAETitles | This method removes all the values that may have been set for Scheduled Station AE Title.
Public method | removeScheduledStationNames | This method removes all the values that may have been set for Scheduled Station Name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCscheduledProcedureStepItem Class
Mergecom.Gen Namespace


removeAnatomicalOrientationType Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeAnatomicalOrientationType Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Anatomical Orientation Type.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAnatomicalOrientationType()
Visual Basic
Public Overridable Sub removeAnatomicalOrientationType
Visual C++
public:
virtual void removeAnatomicalOrientationType()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeCommentsOnTheScheduledProcedureStep Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeCommentsOnTheScheduledProcedureStep Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Comments on the Scheduled Procedure Step.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCommentsOnTheScheduledProcedureStep()
Visual Basic
Public Overridable Sub removeCommentsOnTheScheduledProcedureStep
Visual C++
public:
virtual void removeCommentsOnTheScheduledProcedureStep()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeModality Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removePreMedication Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removePreMedication Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Pre-Medication.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePreMedication()
Visual Basic
Public Overridable Sub removePreMedication
Visual C++
public:
virtual void removePreMedication()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeRawDataHandling Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeRawDataHandling Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Raw Data Handling.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRawDataHandling()
Visual Basic
Public Overridable Sub removeRawDataHandling
Visual C++
public:
virtual void removeRawDataHandling()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeRequestedContrastAgent Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeRequestedContrastAgent Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Contrast Agent.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedContrastAgent()
Visual Basic
Public Overridable Sub removeRequestedContrastAgent
Visual C++
public:
virtual void removeRequestedContrastAgent()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledPerformingPhysiciansName Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledPerformingPhysiciansName Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledPerformingPhysiciansName()
Visual Basic
Public Overridable Sub removeScheduledPerformingPhysiciansName
Visual C++
public:
virtual void removeScheduledPerformingPhysiciansName()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledPerformingPhysIdentifications Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledPerformingPhysIdentifications Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Performing Phys Identification Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledPerformingPhysIdentifications()
Visual Basic
Public Overridable Sub removeScheduledPerformingPhysIdentifications
Visual C++
public:
virtual void removeScheduledPerformingPhysIdentifications()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepDescription Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepDescription()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepDescription
Visual C++
public:
virtual void removeScheduledProcedureStepDescription()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepEndDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepEndDate Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step End Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepEndDate()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepEndDate
Visual C++
public:
virtual void removeScheduledProcedureStepEndDate()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepEndTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepEndTime Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step End Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepEndTime()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepEndTime
Visual C++
public:
virtual void removeScheduledProcedureStepEndTime()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepID Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepID()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepID
Visual C++
public:
virtual void removeScheduledProcedureStepID()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepLocation Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepLocation()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepLocation
Visual C++
public:
virtual void removeScheduledProcedureStepLocation()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepStartDate Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepStartDate()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepStartDate
Visual C++
public:
virtual void removeScheduledProcedureStepStartDate()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepStartTime Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepStartTime()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepStartTime
Visual C++
public:
virtual void removeScheduledProcedureStepStartTime()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepStatus Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProcedureStepStatus Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Status.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepStatus()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepStatus
Visual C++
public:
virtual void removeScheduledProcedureStepStatus()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledProtocolCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledProtocolCodes Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Protocol Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProtocolCodes()
Visual Basic
Public Overridable Sub removeScheduledProtocolCodes
Visual C++
public:
virtual void removeScheduledProtocolCodes()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledStationAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledStationAETitles Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Station AE Title.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStationAETitles()
Visual Basic
Public Overridable Sub removeScheduledStationAETitles
Visual C++
public:
virtual void removeScheduledStationAETitles()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


removeScheduledStationNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..removeScheduledStationNames Method
MCscheduledProcedureStepItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Station Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStationNames()
Visual Basic
Public Overridable Sub removeScheduledStationNames
Visual C++
public:
virtual void removeScheduledStationNames()

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


MCscheduledProcedureStepItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem Properties
MCscheduledProcedureStepItem Class See Also Send Feedback

The MCscheduledProcedureStepItem type exposes the following members.

Properties

 | Name | Description
Public property | AnatomicalOrientationType | Represents the value for the Anatomical Orientation Type attribute.
Public property | CommentsOnTheScheduledProcedureStep | Represents the value for the Comments on the Scheduled Procedure Step attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | PreMedication | Represents the value for the Pre-Medication attribute.
Public property | RawDataHandling | Represents the value for the Raw Data Handling attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | ScheduledPerformingPhysiciansName | Represents the value for the Scheduled Performing Physician's Name attribute.
Public property | ScheduledPerformingPhysIdentifications | Represents the values for the Scheduled Performing Phys Identification Sequence attribute.
Public property | ScheduledProcedureStepDescription | Represents the value for the Scheduled Procedure Step Description attribute.
Public property | ScheduledProcedureStepEndDate | Represents the value for the Scheduled Procedure Step End Date attribute.
Public property | ScheduledProcedureStepEndTime | Represents the value for the Scheduled Procedure Step End Time attribute.
Public property | ScheduledProcedureStepID | Represents the value for the Scheduled Procedure Step ID attribute.
Public property | ScheduledProcedureStepLocation | Represents the value for the Scheduled Procedure Step Location attribute.
Public property | ScheduledProcedureStepStartDate | Represents the value for the Scheduled Procedure Step Start Date attribute.
Public property | ScheduledProcedureStepStartTime | Represents the value for the Scheduled Procedure Step Start Time attribute.
Public property | ScheduledProcedureStepStatus | Represents the value for the Scheduled Procedure Step Status attribute.
Public property | ScheduledProtocolCodes | Represents the values for the Scheduled Protocol Code Sequence attribute.
Public property | ScheduledStationAETitles | Represents the values for the Scheduled Station AE Title attribute.
Public property | ScheduledStationNames | Represents the values for the Scheduled Station Name attribute.

See Also

MCscheduledProcedureStepItem Class
Mergecom.Gen Namespace


AnatomicalOrientationType Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..AnatomicalOrientationType Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Anatomical Orientation Type attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AnatomicalOrientationType { get; set; }
Visual Basic
Public Overridable Property AnatomicalOrientationType As String
    Get
    Set
Visual C++
public:
virtual property String^ AnatomicalOrientationType {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


CommentsOnTheScheduledProcedureStep Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..CommentsOnTheScheduledProcedureStep Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Comments on the Scheduled Procedure Step attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CommentsOnTheScheduledProcedureStep { get; set; }
Visual Basic
Public Overridable Property CommentsOnTheScheduledProcedureStep As String
    Get
    Set
Visual C++
public:
virtual property String^ CommentsOnTheScheduledProcedureStep {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..Host Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..Modality Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


PreMedication Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..PreMedication Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Pre-Medication attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PreMedication { get; set; }
Visual Basic
Public Overridable Property PreMedication As String
    Get
    Set
Visual C++
public:
virtual property String^ PreMedication {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


RawDataHandling Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..RawDataHandling Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Raw Data Handling attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RawDataHandling { get; set; }
Visual Basic
Public Overridable Property RawDataHandling As String
    Get
    Set
Visual C++
public:
virtual property String^ RawDataHandling {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


RequestedContrastAgent Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..RequestedContrastAgent Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Requested Contrast Agent attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedContrastAgent { get; set; }
Visual Basic
Public Overridable Property RequestedContrastAgent As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedContrastAgent {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledPerformingPhysiciansName Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledPerformingPhysiciansName Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName ScheduledPerformingPhysiciansName { get; set; }
Visual Basic
Public Overridable Property ScheduledPerformingPhysiciansName As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ ScheduledPerformingPhysiciansName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledPerformingPhysIdentifications Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledPerformingPhysIdentifications Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the values for the Scheduled Performing Phys Identification Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonIdentificationMacro[] ScheduledPerformingPhysIdentifications { get; set; }
Visual Basic
Public Overridable Property ScheduledPerformingPhysIdentifications As MCpersonIdentificationMacro()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonIdentificationMacro^>^ ScheduledPerformingPhysIdentifications {
    array<MCpersonIdentificationMacro^>^ get ();
    void set (array<MCpersonIdentificationMacro^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepDescription Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepEndDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepEndDate Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step End Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledProcedureStepEndDate { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepEndDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledProcedureStepEndDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepEndTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepEndTime Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step End Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledProcedureStepEndTime { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepEndTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledProcedureStepEndTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepID Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepID { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepLocation Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepLocation { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepStartDate Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledProcedureStepStartDate { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledProcedureStepStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepStartTime Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledProcedureStepStartTime { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledProcedureStepStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepStatus Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProcedureStepStatus Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Status attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepStatus { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepStatus As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepStatus {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledProtocolCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledProtocolCodes Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the values for the Scheduled Protocol Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCscheduledProtocolCodeItem[] ScheduledProtocolCodes { get; set; }
Visual Basic
Public Overridable Property ScheduledProtocolCodes As MCscheduledProtocolCodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCscheduledProtocolCodeItem^>^ ScheduledProtocolCodes {
    array<MCscheduledProtocolCodeItem^>^ get ();
    void set (array<MCscheduledProtocolCodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledStationAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledStationAETitles Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the values for the Scheduled Station AE Title attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStationAETitles { get; set; }
Visual Basic
Public Overridable Property ScheduledStationAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStationAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


ScheduledStationNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProcedureStepItem..::..ScheduledStationNames Property
MCscheduledProcedureStepItem Class See Also Send Feedback
Represents the values for the Scheduled Station Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStationNames { get; set; }
Visual Basic
Public Overridable Property ScheduledStationNames As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStationNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProcedureStepItem Class
MCscheduledProcedureStepItem Members
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the SCHEDULED_ACTION_ITEM_CODE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCscheduledProtocolCodeItem
Visual Basic
Public Class MCscheduledProtocolCodeItem
Visual C++
public ref class MCscheduledProtocolCodeItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080100) Code Value
  • (00080102) Coding Scheme Designator
  • (00080103) Coding Scheme Version
  • (00080104) Code Meaning
  • (00080105) Mapping Resource
  • (00080106) Context Group Version
  • (00080107) Context Group Local Version
  • (0008010B) Context Group Extension Flag
  • (0008010C) Coding Scheme UID
  • (0008010D) Context Group Extension Creator UID
  • (0008010F) Context Identifier
  • (00400440) Protocol Context Sequence

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCscheduledProtocolCodeItem

See Also

MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Members
MCscheduledProtocolCodeItem Class Constructors Methods Properties See Also Send Feedback

The MCscheduledProtocolCodeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCscheduledProtocolCodeItem()()()() | Constructs an MCscheduledProtocolCodeItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledProtocolCodeItem(MCitem) | Constructs an MCscheduledProtocolCodeItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeUID | This method removes all the values that may have been set for Coding Scheme UID.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | removeProtocolContexts | This method removes all the values that may have been set for Protocol Context Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeUID | Represents the value for the Coding Scheme UID attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.
Public property | ProtocolContexts | Represents the values for the Protocol Context Sequence attribute.

See Also

MCscheduledProtocolCodeItem Class
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Constructor
MCscheduledProtocolCodeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCscheduledProtocolCodeItem()()()() | Constructs an MCscheduledProtocolCodeItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledProtocolCodeItem(MCitem) | Constructs an MCscheduledProtocolCodeItem collection by wrapping an existing MCitem instance.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Constructor
MCscheduledProtocolCodeItem Class See Also Send Feedback
Constructs an MCscheduledProtocolCodeItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledProtocolCodeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCscheduledProtocolCodeItem()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
MCscheduledProtocolCodeItem Overload
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Constructor (MCitem)
MCscheduledProtocolCodeItem Class See Also Send Feedback
Constructs an MCscheduledProtocolCodeItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledProtocolCodeItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCscheduledProtocolCodeItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
MCscheduledProtocolCodeItem Overload
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Methods
MCscheduledProtocolCodeItem Class See Also Send Feedback

The MCscheduledProtocolCodeItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeCodeMeaning | This method removes all the values that may have been set for Code Meaning.
Public method | removeCodeValue | This method removes all the values that may have been set for Code Value.
Public method | removeCodingSchemeDesignator | This method removes all the values that may have been set for Coding Scheme Designator.
Public method | removeCodingSchemeUID | This method removes all the values that may have been set for Coding Scheme UID.
Public method | removeCodingSchemeVersion | This method removes all the values that may have been set for Coding Scheme Version.
Public method | removeContextGroupExtensionCreatorUID | This method removes all the values that may have been set for Context Group Extension Creator UID.
Public method | removeContextGroupExtensionFlag | This method removes all the values that may have been set for Context Group Extension Flag.
Public method | removeContextGroupLocalVersion | This method removes all the values that may have been set for Context Group Local Version.
Public method | removeContextGroupVersion | This method removes all the values that may have been set for Context Group Version.
Public method | removeContextIdentifier | This method removes all the values that may have been set for Context Identifier.
Public method | removeMappingResource | This method removes all the values that may have been set for Mapping Resource.
Public method | removeProtocolContexts | This method removes all the values that may have been set for Protocol Context Sequence.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCscheduledProtocolCodeItem Class
Mergecom.Gen Namespace


removeCodeMeaning Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeCodeMeaning Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Meaning.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeMeaning()
Visual Basic
Public Overridable Sub removeCodeMeaning
Visual C++
public:
virtual void removeCodeMeaning()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeCodeValue Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeCodeValue Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Code Value.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodeValue()
Visual Basic
Public Overridable Sub removeCodeValue
Visual C++
public:
virtual void removeCodeValue()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeCodingSchemeDesignator Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeCodingSchemeDesignator Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Designator.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeDesignator()
Visual Basic
Public Overridable Sub removeCodingSchemeDesignator
Visual C++
public:
virtual void removeCodingSchemeDesignator()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeCodingSchemeUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeCodingSchemeUID Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeUID()
Visual Basic
Public Overridable Sub removeCodingSchemeUID
Visual C++
public:
virtual void removeCodingSchemeUID()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeCodingSchemeVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeCodingSchemeVersion Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Coding Scheme Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeCodingSchemeVersion()
Visual Basic
Public Overridable Sub removeCodingSchemeVersion
Visual C++
public:
virtual void removeCodingSchemeVersion()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionCreatorUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeContextGroupExtensionCreatorUID Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Creator UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionCreatorUID()
Visual Basic
Public Overridable Sub removeContextGroupExtensionCreatorUID
Visual C++
public:
virtual void removeContextGroupExtensionCreatorUID()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeContextGroupExtensionFlag Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeContextGroupExtensionFlag Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Extension Flag.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupExtensionFlag()
Visual Basic
Public Overridable Sub removeContextGroupExtensionFlag
Visual C++
public:
virtual void removeContextGroupExtensionFlag()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeContextGroupLocalVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeContextGroupLocalVersion Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Local Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupLocalVersion()
Visual Basic
Public Overridable Sub removeContextGroupLocalVersion
Visual C++
public:
virtual void removeContextGroupLocalVersion()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeContextGroupVersion Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeContextGroupVersion Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Group Version.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextGroupVersion()
Visual Basic
Public Overridable Sub removeContextGroupVersion
Visual C++
public:
virtual void removeContextGroupVersion()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeContextIdentifier Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeContextIdentifier Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Context Identifier.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeContextIdentifier()
Visual Basic
Public Overridable Sub removeContextIdentifier
Visual C++
public:
virtual void removeContextIdentifier()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeMappingResource Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeMappingResource Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Mapping Resource.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeMappingResource()
Visual Basic
Public Overridable Sub removeMappingResource
Visual C++
public:
virtual void removeMappingResource()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


removeProtocolContexts Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..removeProtocolContexts Method
MCscheduledProtocolCodeItem Class See Also Send Feedback
This method removes all the values that may have been set for Protocol Context Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProtocolContexts()
Visual Basic
Public Overridable Sub removeProtocolContexts
Visual C++
public:
virtual void removeProtocolContexts()

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


MCscheduledProtocolCodeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem Properties
MCscheduledProtocolCodeItem Class See Also Send Feedback

The MCscheduledProtocolCodeItem type exposes the following members.

Properties

 | Name | Description
Public property | CodeMeaning | Represents the value for the Code Meaning attribute.
Public property | CodeValue | Represents the value for the Code Value attribute.
Public property | CodingSchemeDesignator | Represents the value for the Coding Scheme Designator attribute.
Public property | CodingSchemeUID | Represents the value for the Coding Scheme UID attribute.
Public property | CodingSchemeVersion | Represents the value for the Coding Scheme Version attribute.
Public property | ContextGroupExtensionCreatorUID | Represents the value for the Context Group Extension Creator UID attribute.
Public property | ContextGroupExtensionFlag | Represents the value for the Context Group Extension Flag attribute.
Public property | ContextGroupLocalVersion | Represents the value for the Context Group Local Version attribute.
Public property | ContextGroupVersion | Represents the value for the Context Group Version attribute.
Public property | ContextIdentifier | Represents the value for the Context Identifier attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | MappingResource | Represents the value for the Mapping Resource attribute.
Public property | ProtocolContexts | Represents the values for the Protocol Context Sequence attribute.

See Also

MCscheduledProtocolCodeItem Class
Mergecom.Gen Namespace


CodeMeaning Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..CodeMeaning Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Code Meaning attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeMeaning { get; set; }
Visual Basic
Public Overridable Property CodeMeaning As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeMeaning {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


CodeValue Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..CodeValue Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Code Value attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodeValue { get; set; }
Visual Basic
Public Overridable Property CodeValue As String
    Get
    Set
Visual C++
public:
virtual property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


CodingSchemeDesignator Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..CodingSchemeDesignator Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Coding Scheme Designator attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeDesignator { get; set; }
Visual Basic
Public Overridable Property CodingSchemeDesignator As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeDesignator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


CodingSchemeUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..CodingSchemeUID Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Coding Scheme UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeUID { get; set; }
Visual Basic
Public Overridable Property CodingSchemeUID As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


CodingSchemeVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..CodingSchemeVersion Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Coding Scheme Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string CodingSchemeVersion { get; set; }
Visual Basic
Public Overridable Property CodingSchemeVersion As String
    Get
    Set
Visual C++
public:
virtual property String^ CodingSchemeVersion {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ContextGroupExtensionCreatorUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ContextGroupExtensionCreatorUID Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Context Group Extension Creator UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionCreatorUID { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionCreatorUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionCreatorUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ContextGroupExtensionFlag Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ContextGroupExtensionFlag Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Context Group Extension Flag attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextGroupExtensionFlag { get; set; }
Visual Basic
Public Overridable Property ContextGroupExtensionFlag As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextGroupExtensionFlag {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ContextGroupLocalVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ContextGroupLocalVersion Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Context Group Local Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupLocalVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupLocalVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupLocalVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ContextGroupVersion Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ContextGroupVersion Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Context Group Version attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdateTime ContextGroupVersion { get; set; }
Visual Basic
Public Overridable Property ContextGroupVersion As MCdateTime
    Get
    Set
Visual C++
public:
virtual property MCdateTime^ ContextGroupVersion {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ContextIdentifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ContextIdentifier Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Context Identifier attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ContextIdentifier { get; set; }
Visual Basic
Public Overridable Property ContextIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ ContextIdentifier {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..Host Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


MappingResource Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..MappingResource Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the value for the Mapping Resource attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string MappingResource { get; set; }
Visual Basic
Public Overridable Property MappingResource As String
    Get
    Set
Visual C++
public:
virtual property String^ MappingResource {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


ProtocolContexts Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledProtocolCodeItem..::..ProtocolContexts Property
MCscheduledProtocolCodeItem Class See Also Send Feedback
Represents the values for the Protocol Context Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCprotocolContextItem[] ProtocolContexts { get; set; }
Visual Basic
Public Overridable Property ProtocolContexts As MCprotocolContextItem()
    Get
    Set
Visual C++
public:
virtual property array<MCprotocolContextItem^>^ ProtocolContexts {
    array<MCprotocolContextItem^>^ get ();
    void set (array<MCprotocolContextItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledProtocolCodeItem Class
MCscheduledProtocolCodeItem Members
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the SCHEDULED_STEP_ATTRIBUTE Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCscheduledStepAttributesItem
Visual Basic
Public Class MCscheduledStepAttributesItem
Visual C++
public ref class MCscheduledStepAttributesItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080050) Accession Number
  • (00080051) Issuer of Accession Number Sequence
  • (00081110) Referenced Study Sequence
  • (0020000D) Study Instance UID
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00400007) Scheduled Procedure Step Description
  • (00400008) Scheduled Protocol Code Sequence
  • (00400009) Scheduled Procedure Step ID
  • (00400026) Order Placer Identifier Sequence
  • (00400027) Order Filler Identifier Sequence
  • (00401001) Requested Procedure ID
  • (00402016) Placer Order Number / Imaging Service Request
  • (00402017) Filler Order Number / Imaging Service Request

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCscheduledStepAttributesItem

See Also

MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Members
MCscheduledStepAttributesItem Class Constructors Methods Properties See Also Send Feedback

The MCscheduledStepAttributesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCscheduledStepAttributesItem()()()() | Constructs an MCscheduledStepAttributesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledStepAttributesItem(MCitem) | Constructs an MCscheduledStepAttributesItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeScheduledProcedureStepDescription | This method removes all the values that may have been set for Scheduled Procedure Step Description.
Public method | removeScheduledProcedureStepID | This method removes all the values that may have been set for Scheduled Procedure Step ID.
Public method | removeScheduledProtocolCodes | This method removes all the values that may have been set for Scheduled Protocol Code Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | ScheduledProcedureStepDescription | Represents the value for the Scheduled Procedure Step Description attribute.
Public property | ScheduledProcedureStepID | Represents the value for the Scheduled Procedure Step ID attribute.
Public property | ScheduledProtocolCodes | Represents the values for the Scheduled Protocol Code Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCscheduledStepAttributesItem Class
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Constructor
MCscheduledStepAttributesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCscheduledStepAttributesItem()()()() | Constructs an MCscheduledStepAttributesItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCscheduledStepAttributesItem(MCitem) | Constructs an MCscheduledStepAttributesItem collection by wrapping an existing MCitem instance.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Constructor
MCscheduledStepAttributesItem Class See Also Send Feedback
Constructs an MCscheduledStepAttributesItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledStepAttributesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCscheduledStepAttributesItem()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
MCscheduledStepAttributesItem Overload
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Constructor (MCitem)
MCscheduledStepAttributesItem Class See Also Send Feedback
Constructs an MCscheduledStepAttributesItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCscheduledStepAttributesItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCscheduledStepAttributesItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
MCscheduledStepAttributesItem Overload
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Methods
MCscheduledStepAttributesItem Class See Also Send Feedback

The MCscheduledStepAttributesItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeFillerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.
Public method | removeIssuerOfAccessionNumbers | This method removes all the values that may have been set for Issuer of Accession Number Sequence.
Public method | removeOrderFillerIdentifiers | This method removes all the values that may have been set for Order Filler Identifier Sequence.
Public method | removeOrderPlacerIdentifiers | This method removes all the values that may have been set for Order Placer Identifier Sequence.
Public method | removePlacerOrderNumberImagingServiceRequest | This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestedProcedureID | This method removes all the values that may have been set for Requested Procedure ID.
Public method | removeScheduledProcedureStepDescription | This method removes all the values that may have been set for Scheduled Procedure Step Description.
Public method | removeScheduledProcedureStepID | This method removes all the values that may have been set for Scheduled Procedure Step ID.
Public method | removeScheduledProtocolCodes | This method removes all the values that may have been set for Scheduled Protocol Code Sequence.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCscheduledStepAttributesItem Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeAccessionNumber Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeFillerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeFillerOrderNumberImagingServiceRequest Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Filler Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeFillerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removeFillerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removeFillerOrderNumberImagingServiceRequest()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeIssuerOfAccessionNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeIssuerOfAccessionNumbers Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Issuer of Accession Number Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeIssuerOfAccessionNumbers()
Visual Basic
Public Overridable Sub removeIssuerOfAccessionNumbers
Visual C++
public:
virtual void removeIssuerOfAccessionNumbers()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeOrderFillerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeOrderFillerIdentifiers Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Order Filler Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderFillerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderFillerIdentifiers
Visual C++
public:
virtual void removeOrderFillerIdentifiers()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeOrderPlacerIdentifiers Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeOrderPlacerIdentifiers Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Order Placer Identifier Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOrderPlacerIdentifiers()
Visual Basic
Public Overridable Sub removeOrderPlacerIdentifiers
Visual C++
public:
virtual void removeOrderPlacerIdentifiers()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removePlacerOrderNumberImagingServiceRequest Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removePlacerOrderNumberImagingServiceRequest Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Placer Order Number / Imaging Service Request.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePlacerOrderNumberImagingServiceRequest()
Visual Basic
Public Overridable Sub removePlacerOrderNumberImagingServiceRequest
Visual C++
public:
virtual void removePlacerOrderNumberImagingServiceRequest()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeReferencedStudies Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeRequestedProcedureCodes Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeRequestedProcedureDescription Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeRequestedProcedureID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeRequestedProcedureID Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureID()
Visual Basic
Public Overridable Sub removeRequestedProcedureID
Visual C++
public:
virtual void removeRequestedProcedureID()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeScheduledProcedureStepDescription Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepDescription()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepDescription
Visual C++
public:
virtual void removeScheduledProcedureStepDescription()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeScheduledProcedureStepID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeScheduledProcedureStepID Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Procedure Step ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProcedureStepID()
Visual Basic
Public Overridable Sub removeScheduledProcedureStepID
Visual C++
public:
virtual void removeScheduledProcedureStepID()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeScheduledProtocolCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeScheduledProtocolCodes Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Protocol Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledProtocolCodes()
Visual Basic
Public Overridable Sub removeScheduledProtocolCodes
Visual C++
public:
virtual void removeScheduledProtocolCodes()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..removeStudyInstanceUID Method
MCscheduledStepAttributesItem Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


MCscheduledStepAttributesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem Properties
MCscheduledStepAttributesItem Class See Also Send Feedback

The MCscheduledStepAttributesItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | FillerOrderNumberImagingServiceRequest | Represents the value for the Filler Order Number / Imaging Service Request attribute.
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | IssuerOfAccessionNumbers | Represents the values for the Issuer of Accession Number Sequence attribute.
Public property | OrderFillerIdentifiers | Represents the values for the Order Filler Identifier Sequence attribute.
Public property | OrderPlacerIdentifiers | Represents the values for the Order Placer Identifier Sequence attribute.
Public property | PlacerOrderNumberImagingServiceRequest | Represents the value for the Placer Order Number / Imaging Service Request attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestedProcedureID | Represents the value for the Requested Procedure ID attribute.
Public property | ScheduledProcedureStepDescription | Represents the value for the Scheduled Procedure Step Description attribute.
Public property | ScheduledProcedureStepID | Represents the value for the Scheduled Procedure Step ID attribute.
Public property | ScheduledProtocolCodes | Represents the values for the Scheduled Protocol Code Sequence attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.

See Also

MCscheduledStepAttributesItem Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..AccessionNumber Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


FillerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..FillerOrderNumberImagingServiceRequest Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Filler Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string FillerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property FillerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ FillerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..Host Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


IssuerOfAccessionNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..IssuerOfAccessionNumbers Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Issuer of Accession Number Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] IssuerOfAccessionNumbers { get; set; }
Visual Basic
Public Overridable Property IssuerOfAccessionNumbers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ IssuerOfAccessionNumbers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


OrderFillerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..OrderFillerIdentifiers Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Order Filler Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderFillerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderFillerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderFillerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


OrderPlacerIdentifiers Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..OrderPlacerIdentifiers Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Order Placer Identifier Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MChL7HierarchicDesignatorItem[] OrderPlacerIdentifiers { get; set; }
Visual Basic
Public Overridable Property OrderPlacerIdentifiers As MChL7HierarchicDesignatorItem()
    Get
    Set
Visual C++
public:
virtual property array<MChL7HierarchicDesignatorItem^>^ OrderPlacerIdentifiers {
    array<MChL7HierarchicDesignatorItem^>^ get ();
    void set (array<MChL7HierarchicDesignatorItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


PlacerOrderNumberImagingServiceRequest Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..PlacerOrderNumberImagingServiceRequest Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Placer Order Number / Imaging Service Request attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string PlacerOrderNumberImagingServiceRequest { get; set; }
Visual Basic
Public Overridable Property PlacerOrderNumberImagingServiceRequest As String
    Get
    Set
Visual C++
public:
virtual property String^ PlacerOrderNumberImagingServiceRequest {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..ReferencedStudies Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..RequestedProcedureCodes Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..RequestedProcedureDescription Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


RequestedProcedureID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..RequestedProcedureID Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Requested Procedure ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureID { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureID As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..ScheduledProcedureStepDescription Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepDescription { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


ScheduledProcedureStepID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..ScheduledProcedureStepID Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Scheduled Procedure Step ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledProcedureStepID { get; set; }
Visual Basic
Public Overridable Property ScheduledProcedureStepID As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledProcedureStepID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


ScheduledProtocolCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..ScheduledProtocolCodes Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the values for the Scheduled Protocol Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCscheduledProtocolCodeItem[] ScheduledProtocolCodes { get; set; }
Visual Basic
Public Overridable Property ScheduledProtocolCodes As MCscheduledProtocolCodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCscheduledProtocolCodeItem^>^ ScheduledProtocolCodes {
    array<MCscheduledProtocolCodeItem^>^ get ();
    void set (array<MCscheduledProtocolCodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCscheduledStepAttributesItem..::..StudyInstanceUID Property
MCscheduledStepAttributesItem Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCscheduledStepAttributesItem Class
MCscheduledStepAttributesItem Members
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Class
Members See Also Send Feedback
This class serves as a container for attributes of the SOP_INSTANCE_REF_MACRO Item.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCsopInstanceReferenceItem
Visual Basic
Public Class MCsopInstanceReferenceItem
Visual C++
public ref class MCsopInstanceReferenceItem

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081150) Referenced SOP Class UID
  • (00081155) Referenced SOP Instance UID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCsopInstanceReferenceItem

See Also

MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Members
MCsopInstanceReferenceItem Class Constructors Methods Properties See Also Send Feedback

The MCsopInstanceReferenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCsopInstanceReferenceItem()()()() | Constructs an MCsopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCsopInstanceReferenceItem(MCitem) | Constructs an MCsopInstanceReferenceItem collection by wrapping an existing MCitem instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCsopInstanceReferenceItem Class
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Constructor
MCsopInstanceReferenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCsopInstanceReferenceItem()()()() | Constructs an MCsopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.
Public method | MCsopInstanceReferenceItem(MCitem) | Constructs an MCsopInstanceReferenceItem collection by wrapping an existing MCitem instance.

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Constructor
MCsopInstanceReferenceItem Class See Also Send Feedback
Constructs an MCsopInstanceReferenceItem collection. This constructor creates an empty MCitem object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReferenceItem()
Visual Basic
Public Sub New
Visual C++
public:
MCsopInstanceReferenceItem()

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
MCsopInstanceReferenceItem Overload
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Constructor (MCitem)

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Constructor (MCitem)
MCsopInstanceReferenceItem Class See Also Send Feedback
Constructs an MCsopInstanceReferenceItem collection by wrapping an existing MCitem instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReferenceItem(
    MCitem host
)
Visual Basic
Public Sub New ( _
    host As MCitem _
)
Visual C++
public:
MCsopInstanceReferenceItem(
    MCitem^ host
)

Parameters

host
Type: Mergecom..::..MCitem
A non-null MCitem object to wrap.

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
MCsopInstanceReferenceItem Overload
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Methods
MCsopInstanceReferenceItem Class See Also Send Feedback

The MCsopInstanceReferenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeReferencedSOPClassUID | This method removes all the values that may have been set for Referenced SOP Class UID.
Public method | removeReferencedSOPInstanceUID | This method removes all the values that may have been set for Referenced SOP Instance UID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCsopInstanceReferenceItem Class
Mergecom.Gen Namespace


removeReferencedSOPClassUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem..::..removeReferencedSOPClassUID Method
MCsopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Class UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPClassUID()
Visual Basic
Public Overridable Sub removeReferencedSOPClassUID
Visual C++
public:
virtual void removeReferencedSOPClassUID()

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


removeReferencedSOPInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem..::..removeReferencedSOPInstanceUID Method
MCsopInstanceReferenceItem Class See Also Send Feedback
This method removes all the values that may have been set for Referenced SOP Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSOPInstanceUID()
Visual Basic
Public Overridable Sub removeReferencedSOPInstanceUID
Visual C++
public:
virtual void removeReferencedSOPInstanceUID()

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCsopInstanceReferenceItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem Properties
MCsopInstanceReferenceItem Class See Also Send Feedback

The MCsopInstanceReferenceItem type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCitem object wrapped by this container.
Public property | ReferencedSOPClassUID | Represents the value for the Referenced SOP Class UID attribute.
Public property | ReferencedSOPInstanceUID | Represents the value for the Referenced SOP Instance UID attribute.

See Also

MCsopInstanceReferenceItem Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem..::..Host Property
MCsopInstanceReferenceItem Class See Also Send Feedback
Gets the MCitem object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCitem Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCitem
    Get
Visual C++
public:
virtual property MCitem^ Host {
    MCitem^ get ();
}

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPClassUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem..::..ReferencedSOPClassUID Property
MCsopInstanceReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Class UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPClassUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPClassUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPClassUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


ReferencedSOPInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCsopInstanceReferenceItem..::..ReferencedSOPInstanceUID Property
MCsopInstanceReferenceItem Class See Also Send Feedback
Represents the value for the Referenced SOP Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReferencedSOPInstanceUID { get; set; }
Visual Basic
Public Overridable Property ReferencedSOPInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ ReferencedSOPInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCsopInstanceReferenceItem Class
MCsopInstanceReferenceItem Members
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Class

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Class
Members See Also Send Feedback
This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstudyComponentManagementCreate
Visual Basic
Public Class MCstudyComponentManagementCreate
Visual C++
public ref class MCstudyComponentManagementCreate

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080020) Study Date
  • (00080030) Study Time
  • (00080050) Accession Number
  • (00080060) Modality
  • (00081030) Study Description
  • (00081032) Procedure Code Sequence
  • (00081050) Performing Physician's Name
  • (00081060) Name of Physician(s) Reading Study
  • (00081100) Referenced Results Sequence
  • (00081110) Referenced Study Sequence
  • (00081111) Referenced Performed Procedure Step Sequence
  • (00081115) Referenced Series Sequence
  • (00081120) Referenced Patient Sequence
  • (00081125) Referenced Visit Sequence
  • (0020000D) Study Instance UID
  • (00200010) Study ID
  • (00201000) Series in Study
  • (00201004) Acquisitions in Study
  • (00201070) Other Study Numbers
  • (0032000A) Study Status ID
  • (0032000C) Study Priority ID
  • (00320012) Study ID Issuer
  • (00320032) Study Verified Date
  • (00320033) Study Verified Time
  • (00320034) Study Read Date
  • (00320035) Study Read Time
  • (00321000) Scheduled Study Start Date
  • (00321001) Scheduled Study Start Time
  • (00321010) Scheduled Study Stop Date
  • (00321011) Scheduled Study Stop Time
  • (00321020) Scheduled Study Location
  • (00321021) Scheduled Study Location AE Title(s)
  • (00321030) Reason for Study
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321040) Study Arrival Date
  • (00321041) Study Arrival Time
  • (00321050) Study Completion Date
  • (00321051) Study Completion Time
  • (00321055) Study Component Status ID
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00321070) Requested Contrast Agent
  • (00324000) Study Comments

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCstudyComponentManagementCreate

See Also

MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Members
MCstudyComponentManagementCreate Class Constructors Methods Properties See Also Send Feedback

The MCstudyComponentManagementCreate type exposes the following members.

Constructors

 | Name | Description
Public method | MCstudyComponentManagementCreate()()()() | Constructs an MCstudyComponentManagementCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementCreate(MCdataSet) | Constructs an MCstudyComponentManagementCreate collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCstudyComponentManagementCreate Class
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Constructor
MCstudyComponentManagementCreate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstudyComponentManagementCreate()()()() | Constructs an MCstudyComponentManagementCreate collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementCreate(MCdataSet) | Constructs an MCstudyComponentManagementCreate collection by wrapping an existing MCdataSet instance.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Constructor
MCstudyComponentManagementCreate Class See Also Send Feedback
Constructs an MCstudyComponentManagementCreate collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementCreate()
Visual Basic
Public Sub New
Visual C++
public:
MCstudyComponentManagementCreate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
MCstudyComponentManagementCreate Overload
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Constructor (MCdataSet)
MCstudyComponentManagementCreate Class See Also Send Feedback
Constructs an MCstudyComponentManagementCreate collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementCreate(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCstudyComponentManagementCreate(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
MCstudyComponentManagementCreate Overload
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Methods
MCstudyComponentManagementCreate Class See Also Send Feedback

The MCstudyComponentManagementCreate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyCompletionTime | This method removes all the values that may have been set for Study Completion Time.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstudyComponentManagementCreate Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeAccessionNumber Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeAcquisitionsInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeAcquisitionsInStudy Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Acquisitions in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAcquisitionsInStudy()
Visual Basic
Public Overridable Sub removeAcquisitionsInStudy
Visual C++
public:
virtual void removeAcquisitionsInStudy()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeModality Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeNameOfPhysiciansReadingStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeNameOfPhysiciansReadingStudies Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Name of Physician(s) Reading Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNameOfPhysiciansReadingStudies()
Visual Basic
Public Overridable Sub removeNameOfPhysiciansReadingStudies
Visual C++
public:
virtual void removeNameOfPhysiciansReadingStudies()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeOtherStudyNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeOtherStudyNumbers Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Other Study Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherStudyNumbers()
Visual Basic
Public Overridable Sub removeOtherStudyNumbers
Visual C++
public:
virtual void removeOtherStudyNumbers()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removePerformingPhysiciansNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removePerformingPhysiciansNames Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysiciansNames()
Visual Basic
Public Overridable Sub removePerformingPhysiciansNames
Visual C++
public:
virtual void removePerformingPhysiciansNames()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeProcedureCodes Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReasonForStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReasonForStudy Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForStudy()
Visual Basic
Public Overridable Sub removeReasonForStudy
Visual C++
public:
virtual void removeReasonForStudy()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedPatients Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedPerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedPerformedProcedureSteps Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeReferencedPerformedProcedureSteps
Visual C++
public:
virtual void removeReferencedPerformedProcedureSteps()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedResults Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedResults Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Results Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedResults()
Visual Basic
Public Overridable Sub removeReferencedResults
Visual C++
public:
virtual void removeReferencedResults()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedSeries Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedStudies Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeReferencedVisits Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeReferencedVisits Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Visit Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedVisits()
Visual Basic
Public Overridable Sub removeReferencedVisits
Visual C++
public:
virtual void removeReferencedVisits()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeRequestedContrastAgent Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeRequestedContrastAgent Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requested Contrast Agent.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedContrastAgent()
Visual Basic
Public Overridable Sub removeRequestedContrastAgent
Visual C++
public:
virtual void removeRequestedContrastAgent()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeRequestedProcedureCodes Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeRequestedProcedureDescription Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeRequestingPhysician Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeRequestingService Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyLocation Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocation()
Visual Basic
Public Overridable Sub removeScheduledStudyLocation
Visual C++
public:
virtual void removeScheduledStudyLocation()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyLocationAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyLocationAETitles Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location AE Title(s).

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocationAETitles()
Visual Basic
Public Overridable Sub removeScheduledStudyLocationAETitles
Visual C++
public:
virtual void removeScheduledStudyLocationAETitles()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyStartDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStartDate
Visual C++
public:
virtual void removeScheduledStudyStartDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyStartTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStartTime
Visual C++
public:
virtual void removeScheduledStudyStartTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyStopDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyStopDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStopDate
Visual C++
public:
virtual void removeScheduledStudyStopDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeScheduledStudyStopTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeScheduledStudyStopTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStopTime
Visual C++
public:
virtual void removeScheduledStudyStopTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeSeriesInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeSeriesInStudy Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Series in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInStudy()
Visual Basic
Public Overridable Sub removeSeriesInStudy
Visual C++
public:
virtual void removeSeriesInStudy()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeSpecificCharacterSets Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyArrivalDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyArrivalDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalDate()
Visual Basic
Public Overridable Sub removeStudyArrivalDate
Visual C++
public:
virtual void removeStudyArrivalDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyArrivalTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyArrivalTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalTime()
Visual Basic
Public Overridable Sub removeStudyArrivalTime
Visual C++
public:
virtual void removeStudyArrivalTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyComments Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComments()
Visual Basic
Public Overridable Sub removeStudyComments
Visual C++
public:
virtual void removeStudyComments()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyCompletionDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyCompletionDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionDate()
Visual Basic
Public Overridable Sub removeStudyCompletionDate
Visual C++
public:
virtual void removeStudyCompletionDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyCompletionTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyCompletionTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionTime()
Visual Basic
Public Overridable Sub removeStudyCompletionTime
Visual C++
public:
virtual void removeStudyCompletionTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyComponentStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyComponentStatusID Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Component Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComponentStatusID()
Visual Basic
Public Overridable Sub removeStudyComponentStatusID
Visual C++
public:
virtual void removeStudyComponentStatusID()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyDescription Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDescription()
Visual Basic
Public Overridable Sub removeStudyDescription
Visual C++
public:
virtual void removeStudyDescription()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyID Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyIDIssuer Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyIDIssuer Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study ID Issuer.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyIDIssuer()
Visual Basic
Public Overridable Sub removeStudyIDIssuer
Visual C++
public:
virtual void removeStudyIDIssuer()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyInstanceUID Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyPriorityID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyPriorityID Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Priority ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyPriorityID()
Visual Basic
Public Overridable Sub removeStudyPriorityID
Visual C++
public:
virtual void removeStudyPriorityID()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyReadDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyReadDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadDate()
Visual Basic
Public Overridable Sub removeStudyReadDate
Visual C++
public:
virtual void removeStudyReadDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyReadTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyReadTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadTime()
Visual Basic
Public Overridable Sub removeStudyReadTime
Visual C++
public:
virtual void removeStudyReadTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyStatusID Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyStatusID()
Visual Basic
Public Overridable Sub removeStudyStatusID
Visual C++
public:
virtual void removeStudyStatusID()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyVerifiedDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyVerifiedDate Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedDate()
Visual Basic
Public Overridable Sub removeStudyVerifiedDate
Visual C++
public:
virtual void removeStudyVerifiedDate()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


removeStudyVerifiedTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..removeStudyVerifiedTime Method
MCstudyComponentManagementCreate Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedTime()
Visual Basic
Public Overridable Sub removeStudyVerifiedTime
Visual C++
public:
virtual void removeStudyVerifiedTime()

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


MCstudyComponentManagementCreate Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate Properties
MCstudyComponentManagementCreate Class See Also Send Feedback

The MCstudyComponentManagementCreate type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyCompletionTime | Represents the value for the Study Completion Time attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCstudyComponentManagementCreate Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..AccessionNumber Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


AcquisitionsInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..AcquisitionsInStudy Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Acquisitions in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AcquisitionsInStudy { get; set; }
Visual Basic
Public Overridable Property AcquisitionsInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ AcquisitionsInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..Host Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..Modality Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


NameOfPhysiciansReadingStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..NameOfPhysiciansReadingStudies Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Name of Physician(s) Reading Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] NameOfPhysiciansReadingStudies { get; set; }
Visual Basic
Public Overridable Property NameOfPhysiciansReadingStudies As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ NameOfPhysiciansReadingStudies {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


OtherStudyNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..OtherStudyNumbers Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Other Study Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] OtherStudyNumbers { get; set; }
Visual Basic
Public Overridable Property OtherStudyNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ OtherStudyNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


PerformingPhysiciansNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..PerformingPhysiciansNames Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] PerformingPhysiciansNames { get; set; }
Visual Basic
Public Overridable Property PerformingPhysiciansNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ PerformingPhysiciansNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ProcedureCodes Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReasonForStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReasonForStudy Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Reason for Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForStudy { get; set; }
Visual Basic
Public Overridable Property ReasonForStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedPatients Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedPerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedPerformedProcedureSteps Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Performed Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPerformedProcedureStepItem[] ReferencedPerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property ReferencedPerformedProcedureSteps As MCreferencedPerformedProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPerformedProcedureStepItem^>^ ReferencedPerformedProcedureSteps {
    array<MCreferencedPerformedProcedureStepItem^>^ get ();
    void set (array<MCreferencedPerformedProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedResults Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedResults Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Results Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedResultsItem[] ReferencedResults { get; set; }
Visual Basic
Public Overridable Property ReferencedResults As MCreferencedResultsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedResultsItem^>^ ReferencedResults {
    array<MCreferencedResultsItem^>^ get ();
    void set (array<MCreferencedResultsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedSeries Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedStudies Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ReferencedVisits Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ReferencedVisits Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Referenced Visit Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedVisitItem[] ReferencedVisits { get; set; }
Visual Basic
Public Overridable Property ReferencedVisits As MCreferencedVisitItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedVisitItem^>^ ReferencedVisits {
    array<MCreferencedVisitItem^>^ get ();
    void set (array<MCreferencedVisitItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


RequestedContrastAgent Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..RequestedContrastAgent Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Requested Contrast Agent attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedContrastAgent { get; set; }
Visual Basic
Public Overridable Property RequestedContrastAgent As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedContrastAgent {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..RequestedProcedureCodes Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..RequestedProcedureDescription Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..RequestingPhysician Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..RequestingService Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyLocation Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Scheduled Study Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledStudyLocation { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledStudyLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyLocationAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyLocationAETitles Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Scheduled Study Location AE Title(s) attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStudyLocationAETitles { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocationAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStudyLocationAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyStartDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Scheduled Study Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStartDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyStartTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Scheduled Study Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStartTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyStopDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyStopDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStopDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStopDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


ScheduledStudyStopTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..ScheduledStudyStopTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStopTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStopTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


SeriesInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..SeriesInStudy Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Series in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInStudy { get; set; }
Visual Basic
Public Overridable Property SeriesInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..SpecificCharacterSets Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyArrivalDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyArrivalDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Arrival Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyArrivalDate { get; set; }
Visual Basic
Public Overridable Property StudyArrivalDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyArrivalDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyArrivalTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyArrivalTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Arrival Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyArrivalTime { get; set; }
Visual Basic
Public Overridable Property StudyArrivalTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyArrivalTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyComments Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComments { get; set; }
Visual Basic
Public Overridable Property StudyComments As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyCompletionDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyCompletionDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Completion Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyCompletionDate { get; set; }
Visual Basic
Public Overridable Property StudyCompletionDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyCompletionDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyCompletionTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyCompletionTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Completion Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyCompletionTime { get; set; }
Visual Basic
Public Overridable Property StudyCompletionTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyCompletionTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyComponentStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyComponentStatusID Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Component Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComponentStatusID { get; set; }
Visual Basic
Public Overridable Property StudyComponentStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComponentStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyDescription Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyDescription { get; set; }
Visual Basic
Public Overridable Property StudyDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyID Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyIDIssuer Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyIDIssuer Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study ID Issuer attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyIDIssuer { get; set; }
Visual Basic
Public Overridable Property StudyIDIssuer As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyIDIssuer {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyInstanceUID Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyPriorityID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyPriorityID Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Priority ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyPriorityID { get; set; }
Visual Basic
Public Overridable Property StudyPriorityID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyPriorityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyReadDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyReadDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Read Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyReadDate { get; set; }
Visual Basic
Public Overridable Property StudyReadDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyReadDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyReadTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyReadTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Read Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyReadTime { get; set; }
Visual Basic
Public Overridable Property StudyReadTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyReadTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyStatusID Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyStatusID { get; set; }
Visual Basic
Public Overridable Property StudyStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyVerifiedDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyVerifiedDate Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Verified Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyVerifiedDate { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyVerifiedDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


StudyVerifiedTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementCreate..::..StudyVerifiedTime Property
MCstudyComponentManagementCreate Class See Also Send Feedback
Represents the value for the Study Verified Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyVerifiedTime { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyVerifiedTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementCreate Class
MCstudyComponentManagementCreate Members
Mergecom.Gen Namespace


MCstudyComponentManagementGet Class

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Class
Members See Also Send Feedback
This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstudyComponentManagementGet
Visual Basic
Public Class MCstudyComponentManagementGet
Visual C++
public ref class MCstudyComponentManagementGet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00080005) Specific Character Set
  • (00080020) Study Date
  • (00080030) Study Time
  • (00080050) Accession Number
  • (00080060) Modality
  • (00081030) Study Description
  • (00081032) Procedure Code Sequence
  • (00081050) Performing Physician's Name
  • (00081060) Name of Physician(s) Reading Study
  • (00081100) Referenced Results Sequence
  • (00081110) Referenced Study Sequence
  • (00081111) Referenced Performed Procedure Step Sequence
  • (00081115) Referenced Series Sequence
  • (00081120) Referenced Patient Sequence
  • (00081125) Referenced Visit Sequence
  • (0020000D) Study Instance UID
  • (00200010) Study ID
  • (00201000) Series in Study
  • (00201004) Acquisitions in Study
  • (00201070) Other Study Numbers
  • (0032000A) Study Status ID
  • (0032000C) Study Priority ID
  • (00320012) Study ID Issuer
  • (00320032) Study Verified Date
  • (00320033) Study Verified Time
  • (00320034) Study Read Date
  • (00320035) Study Read Time
  • (00321000) Scheduled Study Start Date
  • (00321001) Scheduled Study Start Time
  • (00321010) Scheduled Study Stop Date
  • (00321011) Scheduled Study Stop Time
  • (00321020) Scheduled Study Location
  • (00321021) Scheduled Study Location AE Title(s)
  • (00321030) Reason for Study
  • (00321032) Requesting Physician
  • (00321033) Requesting Service
  • (00321040) Study Arrival Date
  • (00321041) Study Arrival Time
  • (00321050) Study Completion Date
  • (00321055) Study Component Status ID
  • (00321060) Requested Procedure Description
  • (00321064) Requested Procedure Code Sequence
  • (00321070) Requested Contrast Agent
  • (00324000) Study Comments

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCstudyComponentManagementGet

See Also

MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


MCstudyComponentManagementGet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Members
MCstudyComponentManagementGet Class Constructors Methods Properties See Also Send Feedback

The MCstudyComponentManagementGet type exposes the following members.

Constructors

 | Name | Description
Public method | MCstudyComponentManagementGet()()()() | Constructs an MCstudyComponentManagementGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementGet(MCdataSet) | Constructs an MCstudyComponentManagementGet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCstudyComponentManagementGet Class
Mergecom.Gen Namespace


MCstudyComponentManagementGet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Constructor
MCstudyComponentManagementGet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstudyComponentManagementGet()()()() | Constructs an MCstudyComponentManagementGet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementGet(MCdataSet) | Constructs an MCstudyComponentManagementGet collection by wrapping an existing MCdataSet instance.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


MCstudyComponentManagementGet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Constructor
MCstudyComponentManagementGet Class See Also Send Feedback
Constructs an MCstudyComponentManagementGet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementGet()
Visual Basic
Public Sub New
Visual C++
public:
MCstudyComponentManagementGet()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
MCstudyComponentManagementGet Overload
Mergecom.Gen Namespace


MCstudyComponentManagementGet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Constructor (MCdataSet)
MCstudyComponentManagementGet Class See Also Send Feedback
Constructs an MCstudyComponentManagementGet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementGet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCstudyComponentManagementGet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
MCstudyComponentManagementGet Overload
Mergecom.Gen Namespace


MCstudyComponentManagementGet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Methods
MCstudyComponentManagementGet Class See Also Send Feedback

The MCstudyComponentManagementGet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeAccessionNumber | This method removes all the values that may have been set for Accession Number.
Public method | removeAcquisitionsInStudy | This method removes all the values that may have been set for Acquisitions in Study.
Public method | removeModality | This method removes all the values that may have been set for Modality.
Public method | removeNameOfPhysiciansReadingStudies | This method removes all the values that may have been set for Name of Physician(s) Reading Study.
Public method | removeOtherStudyNumbers | This method removes all the values that may have been set for Other Study Numbers.
Public method | removePerformingPhysiciansNames | This method removes all the values that may have been set for Performing Physician's Name.
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReasonForStudy | This method removes all the values that may have been set for Reason for Study.
Public method | removeReferencedPatients | This method removes all the values that may have been set for Referenced Patient Sequence.
Public method | removeReferencedPerformedProcedureSteps | This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.
Public method | removeReferencedResults | This method removes all the values that may have been set for Referenced Results Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeReferencedStudies | This method removes all the values that may have been set for Referenced Study Sequence.
Public method | removeReferencedVisits | This method removes all the values that may have been set for Referenced Visit Sequence.
Public method | removeRequestedContrastAgent | This method removes all the values that may have been set for Requested Contrast Agent.
Public method | removeRequestedProcedureCodes | This method removes all the values that may have been set for Requested Procedure Code Sequence.
Public method | removeRequestedProcedureDescription | This method removes all the values that may have been set for Requested Procedure Description.
Public method | removeRequestingPhysician | This method removes all the values that may have been set for Requesting Physician.
Public method | removeRequestingService | This method removes all the values that may have been set for Requesting Service.
Public method | removeScheduledStudyLocation | This method removes all the values that may have been set for Scheduled Study Location.
Public method | removeScheduledStudyLocationAETitles | This method removes all the values that may have been set for Scheduled Study Location AE Title(s).
Public method | removeScheduledStudyStartDate | This method removes all the values that may have been set for Scheduled Study Start Date.
Public method | removeScheduledStudyStartTime | This method removes all the values that may have been set for Scheduled Study Start Time.
Public method | removeScheduledStudyStopDate | This method removes all the values that may have been set for Scheduled Study Stop Date.
Public method | removeScheduledStudyStopTime | This method removes all the values that may have been set for Scheduled Study Stop Time.
Public method | removeSeriesInStudy | This method removes all the values that may have been set for Series in Study.
Public method | removeSpecificCharacterSets | This method removes all the values that may have been set for Specific Character Set.
Public method | removeStudyArrivalDate | This method removes all the values that may have been set for Study Arrival Date.
Public method | removeStudyArrivalTime | This method removes all the values that may have been set for Study Arrival Time.
Public method | removeStudyComments | This method removes all the values that may have been set for Study Comments.
Public method | removeStudyCompletionDate | This method removes all the values that may have been set for Study Completion Date.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDate | This method removes all the values that may have been set for Study Date.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | removeStudyIDIssuer | This method removes all the values that may have been set for Study ID Issuer.
Public method | removeStudyInstanceUID | This method removes all the values that may have been set for Study Instance UID.
Public method | removeStudyPriorityID | This method removes all the values that may have been set for Study Priority ID.
Public method | removeStudyReadDate | This method removes all the values that may have been set for Study Read Date.
Public method | removeStudyReadTime | This method removes all the values that may have been set for Study Read Time.
Public method | removeStudyStatusID | This method removes all the values that may have been set for Study Status ID.
Public method | removeStudyTime | This method removes all the values that may have been set for Study Time.
Public method | removeStudyVerifiedDate | This method removes all the values that may have been set for Study Verified Date.
Public method | removeStudyVerifiedTime | This method removes all the values that may have been set for Study Verified Time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstudyComponentManagementGet Class
Mergecom.Gen Namespace


removeAccessionNumber Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeAccessionNumber Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Accession Number.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAccessionNumber()
Visual Basic
Public Overridable Sub removeAccessionNumber
Visual C++
public:
virtual void removeAccessionNumber()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeAcquisitionsInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeAcquisitionsInStudy Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Acquisitions in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeAcquisitionsInStudy()
Visual Basic
Public Overridable Sub removeAcquisitionsInStudy
Visual C++
public:
virtual void removeAcquisitionsInStudy()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeModality Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeModality Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Modality.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeModality()
Visual Basic
Public Overridable Sub removeModality
Visual C++
public:
virtual void removeModality()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeNameOfPhysiciansReadingStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeNameOfPhysiciansReadingStudies Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Name of Physician(s) Reading Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeNameOfPhysiciansReadingStudies()
Visual Basic
Public Overridable Sub removeNameOfPhysiciansReadingStudies
Visual C++
public:
virtual void removeNameOfPhysiciansReadingStudies()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeOtherStudyNumbers Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeOtherStudyNumbers Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Other Study Numbers.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeOtherStudyNumbers()
Visual Basic
Public Overridable Sub removeOtherStudyNumbers
Visual C++
public:
virtual void removeOtherStudyNumbers()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removePerformingPhysiciansNames Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removePerformingPhysiciansNames Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Performing Physician's Name.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removePerformingPhysiciansNames()
Visual Basic
Public Overridable Sub removePerformingPhysiciansNames
Visual C++
public:
virtual void removePerformingPhysiciansNames()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeProcedureCodes Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReasonForStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReasonForStudy Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Reason for Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReasonForStudy()
Visual Basic
Public Overridable Sub removeReasonForStudy
Visual C++
public:
virtual void removeReasonForStudy()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedPatients Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedPatients Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Patient Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPatients()
Visual Basic
Public Overridable Sub removeReferencedPatients
Visual C++
public:
virtual void removeReferencedPatients()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedPerformedProcedureSteps Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedPerformedProcedureSteps Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Performed Procedure Step Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedPerformedProcedureSteps()
Visual Basic
Public Overridable Sub removeReferencedPerformedProcedureSteps
Visual C++
public:
virtual void removeReferencedPerformedProcedureSteps()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedResults Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedResults Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Results Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedResults()
Visual Basic
Public Overridable Sub removeReferencedResults
Visual C++
public:
virtual void removeReferencedResults()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedSeries Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedStudies Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedStudies Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Study Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedStudies()
Visual Basic
Public Overridable Sub removeReferencedStudies
Visual C++
public:
virtual void removeReferencedStudies()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeReferencedVisits Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeReferencedVisits Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Visit Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedVisits()
Visual Basic
Public Overridable Sub removeReferencedVisits
Visual C++
public:
virtual void removeReferencedVisits()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeRequestedContrastAgent Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeRequestedContrastAgent Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Contrast Agent.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedContrastAgent()
Visual Basic
Public Overridable Sub removeRequestedContrastAgent
Visual C++
public:
virtual void removeRequestedContrastAgent()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeRequestedProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeRequestedProcedureCodes Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureCodes()
Visual Basic
Public Overridable Sub removeRequestedProcedureCodes
Visual C++
public:
virtual void removeRequestedProcedureCodes()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeRequestedProcedureDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeRequestedProcedureDescription Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requested Procedure Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestedProcedureDescription()
Visual Basic
Public Overridable Sub removeRequestedProcedureDescription
Visual C++
public:
virtual void removeRequestedProcedureDescription()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeRequestingPhysician Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeRequestingPhysician Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Physician.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingPhysician()
Visual Basic
Public Overridable Sub removeRequestingPhysician
Visual C++
public:
virtual void removeRequestingPhysician()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeRequestingService Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeRequestingService Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Requesting Service.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeRequestingService()
Visual Basic
Public Overridable Sub removeRequestingService
Visual C++
public:
virtual void removeRequestingService()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyLocation Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyLocation Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocation()
Visual Basic
Public Overridable Sub removeScheduledStudyLocation
Visual C++
public:
virtual void removeScheduledStudyLocation()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyLocationAETitles Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyLocationAETitles Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Location AE Title(s).

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyLocationAETitles()
Visual Basic
Public Overridable Sub removeScheduledStudyLocationAETitles
Visual C++
public:
virtual void removeScheduledStudyLocationAETitles()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStartDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyStartDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStartDate
Visual C++
public:
virtual void removeScheduledStudyStartDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStartTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyStartTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Start Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStartTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStartTime
Visual C++
public:
virtual void removeScheduledStudyStartTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStopDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyStopDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopDate()
Visual Basic
Public Overridable Sub removeScheduledStudyStopDate
Visual C++
public:
virtual void removeScheduledStudyStopDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeScheduledStudyStopTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeScheduledStudyStopTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Scheduled Study Stop Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeScheduledStudyStopTime()
Visual Basic
Public Overridable Sub removeScheduledStudyStopTime
Visual C++
public:
virtual void removeScheduledStudyStopTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeSeriesInStudy Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeSeriesInStudy Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Series in Study.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSeriesInStudy()
Visual Basic
Public Overridable Sub removeSeriesInStudy
Visual C++
public:
virtual void removeSeriesInStudy()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeSpecificCharacterSets Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeSpecificCharacterSets Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Specific Character Set.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeSpecificCharacterSets()
Visual Basic
Public Overridable Sub removeSpecificCharacterSets
Visual C++
public:
virtual void removeSpecificCharacterSets()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyArrivalDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyArrivalDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalDate()
Visual Basic
Public Overridable Sub removeStudyArrivalDate
Visual C++
public:
virtual void removeStudyArrivalDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyArrivalTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyArrivalTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Arrival Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyArrivalTime()
Visual Basic
Public Overridable Sub removeStudyArrivalTime
Visual C++
public:
virtual void removeStudyArrivalTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyComments Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyComments Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Comments.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComments()
Visual Basic
Public Overridable Sub removeStudyComments
Visual C++
public:
virtual void removeStudyComments()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyCompletionDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyCompletionDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Completion Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyCompletionDate()
Visual Basic
Public Overridable Sub removeStudyCompletionDate
Visual C++
public:
virtual void removeStudyCompletionDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyComponentStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyComponentStatusID Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Component Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComponentStatusID()
Visual Basic
Public Overridable Sub removeStudyComponentStatusID
Visual C++
public:
virtual void removeStudyComponentStatusID()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDate()
Visual Basic
Public Overridable Sub removeStudyDate
Visual C++
public:
virtual void removeStudyDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyDescription Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDescription()
Visual Basic
Public Overridable Sub removeStudyDescription
Visual C++
public:
virtual void removeStudyDescription()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyID Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyIDIssuer Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyIDIssuer Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID Issuer.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyIDIssuer()
Visual Basic
Public Overridable Sub removeStudyIDIssuer
Visual C++
public:
virtual void removeStudyIDIssuer()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyInstanceUID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyInstanceUID Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Instance UID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyInstanceUID()
Visual Basic
Public Overridable Sub removeStudyInstanceUID
Visual C++
public:
virtual void removeStudyInstanceUID()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyPriorityID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyPriorityID Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Priority ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyPriorityID()
Visual Basic
Public Overridable Sub removeStudyPriorityID
Visual C++
public:
virtual void removeStudyPriorityID()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyReadDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyReadDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadDate()
Visual Basic
Public Overridable Sub removeStudyReadDate
Visual C++
public:
virtual void removeStudyReadDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyReadTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyReadTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Read Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyReadTime()
Visual Basic
Public Overridable Sub removeStudyReadTime
Visual C++
public:
virtual void removeStudyReadTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyStatusID Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyStatusID()
Visual Basic
Public Overridable Sub removeStudyStatusID
Visual C++
public:
virtual void removeStudyStatusID()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyTime()
Visual Basic
Public Overridable Sub removeStudyTime
Visual C++
public:
virtual void removeStudyTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyVerifiedDate Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyVerifiedDate Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Date.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedDate()
Visual Basic
Public Overridable Sub removeStudyVerifiedDate
Visual C++
public:
virtual void removeStudyVerifiedDate()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


removeStudyVerifiedTime Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..removeStudyVerifiedTime Method
MCstudyComponentManagementGet Class See Also Send Feedback
This method removes all the values that may have been set for Study Verified Time.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyVerifiedTime()
Visual Basic
Public Overridable Sub removeStudyVerifiedTime
Visual C++
public:
virtual void removeStudyVerifiedTime()

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


MCstudyComponentManagementGet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet Properties
MCstudyComponentManagementGet Class See Also Send Feedback

The MCstudyComponentManagementGet type exposes the following members.

Properties

 | Name | Description
Public property | AccessionNumber | Represents the value for the Accession Number attribute.
Public property | AcquisitionsInStudy | Represents the value for the Acquisitions in Study attribute.
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | Modality | Represents the value for the Modality attribute.
Public property | NameOfPhysiciansReadingStudies | Represents the values for the Name of Physician(s) Reading Study attribute.
Public property | OtherStudyNumbers | Represents the values for the Other Study Numbers attribute.
Public property | PerformingPhysiciansNames | Represents the values for the Performing Physician's Name attribute.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReasonForStudy | Represents the value for the Reason for Study attribute.
Public property | ReferencedPatients | Represents the values for the Referenced Patient Sequence attribute.
Public property | ReferencedPerformedProcedureSteps | Represents the values for the Referenced Performed Procedure Step Sequence attribute.
Public property | ReferencedResults | Represents the values for the Referenced Results Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | ReferencedStudies | Represents the values for the Referenced Study Sequence attribute.
Public property | ReferencedVisits | Represents the values for the Referenced Visit Sequence attribute.
Public property | RequestedContrastAgent | Represents the value for the Requested Contrast Agent attribute.
Public property | RequestedProcedureCodes | Represents the values for the Requested Procedure Code Sequence attribute.
Public property | RequestedProcedureDescription | Represents the value for the Requested Procedure Description attribute.
Public property | RequestingPhysician | Represents the value for the Requesting Physician attribute.
Public property | RequestingService | Represents the value for the Requesting Service attribute.
Public property | ScheduledStudyLocation | Represents the value for the Scheduled Study Location attribute.
Public property | ScheduledStudyLocationAETitles | Represents the values for the Scheduled Study Location AE Title(s) attribute.
Public property | ScheduledStudyStartDate | Represents the value for the Scheduled Study Start Date attribute.
Public property | ScheduledStudyStartTime | Represents the value for the Scheduled Study Start Time attribute.
Public property | ScheduledStudyStopDate | Represents the value for the Scheduled Study Stop Date attribute.
Public property | ScheduledStudyStopTime | Represents the value for the Scheduled Study Stop Time attribute.
Public property | SeriesInStudy | Represents the value for the Series in Study attribute.
Public property | SpecificCharacterSets | Represents the values for the Specific Character Set attribute.
Public property | StudyArrivalDate | Represents the value for the Study Arrival Date attribute.
Public property | StudyArrivalTime | Represents the value for the Study Arrival Time attribute.
Public property | StudyComments | Represents the value for the Study Comments attribute.
Public property | StudyCompletionDate | Represents the value for the Study Completion Date attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDate | Represents the value for the Study Date attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.
Public property | StudyIDIssuer | Represents the value for the Study ID Issuer attribute.
Public property | StudyInstanceUID | Represents the value for the Study Instance UID attribute.
Public property | StudyPriorityID | Represents the value for the Study Priority ID attribute.
Public property | StudyReadDate | Represents the value for the Study Read Date attribute.
Public property | StudyReadTime | Represents the value for the Study Read Time attribute.
Public property | StudyStatusID | Represents the value for the Study Status ID attribute.
Public property | StudyTime | Represents the value for the Study Time attribute.
Public property | StudyVerifiedDate | Represents the value for the Study Verified Date attribute.
Public property | StudyVerifiedTime | Represents the value for the Study Verified Time attribute.

See Also

MCstudyComponentManagementGet Class
Mergecom.Gen Namespace


AccessionNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..AccessionNumber Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Accession Number attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AccessionNumber { get; set; }
Visual Basic
Public Overridable Property AccessionNumber As String
    Get
    Set
Visual C++
public:
virtual property String^ AccessionNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


AcquisitionsInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..AcquisitionsInStudy Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Acquisitions in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string AcquisitionsInStudy { get; set; }
Visual Basic
Public Overridable Property AcquisitionsInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ AcquisitionsInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..Host Property
MCstudyComponentManagementGet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


Modality Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..Modality Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Modality attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string Modality { get; set; }
Visual Basic
Public Overridable Property Modality As String
    Get
    Set
Visual C++
public:
virtual property String^ Modality {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


NameOfPhysiciansReadingStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..NameOfPhysiciansReadingStudies Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Name of Physician(s) Reading Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] NameOfPhysiciansReadingStudies { get; set; }
Visual Basic
Public Overridable Property NameOfPhysiciansReadingStudies As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ NameOfPhysiciansReadingStudies {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


OtherStudyNumbers Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..OtherStudyNumbers Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Other Study Numbers attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] OtherStudyNumbers { get; set; }
Visual Basic
Public Overridable Property OtherStudyNumbers As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ OtherStudyNumbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


PerformingPhysiciansNames Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..PerformingPhysiciansNames Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Performing Physician's Name attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName[] PerformingPhysiciansNames { get; set; }
Visual Basic
Public Overridable Property PerformingPhysiciansNames As MCpersonName()
    Get
    Set
Visual C++
public:
virtual property array<MCpersonName^>^ PerformingPhysiciansNames {
    array<MCpersonName^>^ get ();
    void set (array<MCpersonName^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ProcedureCodes Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReasonForStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReasonForStudy Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Reason for Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ReasonForStudy { get; set; }
Visual Basic
Public Overridable Property ReasonForStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ ReasonForStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedPatients Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedPatients Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Patient Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPatientItem[] ReferencedPatients { get; set; }
Visual Basic
Public Overridable Property ReferencedPatients As MCreferencedPatientItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPatientItem^>^ ReferencedPatients {
    array<MCreferencedPatientItem^>^ get ();
    void set (array<MCreferencedPatientItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedPerformedProcedureSteps Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedPerformedProcedureSteps Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Performed Procedure Step Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedPerformedProcedureStepItem[] ReferencedPerformedProcedureSteps { get; set; }
Visual Basic
Public Overridable Property ReferencedPerformedProcedureSteps As MCreferencedPerformedProcedureStepItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedPerformedProcedureStepItem^>^ ReferencedPerformedProcedureSteps {
    array<MCreferencedPerformedProcedureStepItem^>^ get ();
    void set (array<MCreferencedPerformedProcedureStepItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedResults Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedResults Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Results Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedResultsItem[] ReferencedResults { get; set; }
Visual Basic
Public Overridable Property ReferencedResults As MCreferencedResultsItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedResultsItem^>^ ReferencedResults {
    array<MCreferencedResultsItem^>^ get ();
    void set (array<MCreferencedResultsItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedSeries Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedStudies Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedStudies Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Study Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedStudyItem[] ReferencedStudies { get; set; }
Visual Basic
Public Overridable Property ReferencedStudies As MCreferencedStudyItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedStudyItem^>^ ReferencedStudies {
    array<MCreferencedStudyItem^>^ get ();
    void set (array<MCreferencedStudyItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ReferencedVisits Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ReferencedVisits Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Referenced Visit Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedVisitItem[] ReferencedVisits { get; set; }
Visual Basic
Public Overridable Property ReferencedVisits As MCreferencedVisitItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedVisitItem^>^ ReferencedVisits {
    array<MCreferencedVisitItem^>^ get ();
    void set (array<MCreferencedVisitItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


RequestedContrastAgent Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..RequestedContrastAgent Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Requested Contrast Agent attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedContrastAgent { get; set; }
Visual Basic
Public Overridable Property RequestedContrastAgent As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedContrastAgent {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


RequestedProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..RequestedProcedureCodes Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Requested Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] RequestedProcedureCodes { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ RequestedProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


RequestedProcedureDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..RequestedProcedureDescription Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Requested Procedure Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestedProcedureDescription { get; set; }
Visual Basic
Public Overridable Property RequestedProcedureDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestedProcedureDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


RequestingPhysician Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..RequestingPhysician Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Requesting Physician attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCpersonName RequestingPhysician { get; set; }
Visual Basic
Public Overridable Property RequestingPhysician As MCpersonName
    Get
    Set
Visual C++
public:
virtual property MCpersonName^ RequestingPhysician {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


RequestingService Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..RequestingService Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Requesting Service attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string RequestingService { get; set; }
Visual Basic
Public Overridable Property RequestingService As String
    Get
    Set
Visual C++
public:
virtual property String^ RequestingService {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyLocation Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyLocation Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Location attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string ScheduledStudyLocation { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocation As String
    Get
    Set
Visual C++
public:
virtual property String^ ScheduledStudyLocation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyLocationAETitles Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyLocationAETitles Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Scheduled Study Location AE Title(s) attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] ScheduledStudyLocationAETitles { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyLocationAETitles As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ ScheduledStudyLocationAETitles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStartDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyStartDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Start Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStartDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStartDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStartTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyStartTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Start Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStartTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStartTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStartTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStopDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyStopDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate ScheduledStudyStopDate { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ ScheduledStudyStopDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


ScheduledStudyStopTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..ScheduledStudyStopTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Scheduled Study Stop Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime ScheduledStudyStopTime { get; set; }
Visual Basic
Public Overridable Property ScheduledStudyStopTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ ScheduledStudyStopTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


SeriesInStudy Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..SeriesInStudy Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Series in Study attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string SeriesInStudy { get; set; }
Visual Basic
Public Overridable Property SeriesInStudy As String
    Get
    Set
Visual C++
public:
virtual property String^ SeriesInStudy {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


SpecificCharacterSets Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..SpecificCharacterSets Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the values for the Specific Character Set attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string[] SpecificCharacterSets { get; set; }
Visual Basic
Public Overridable Property SpecificCharacterSets As String()
    Get
    Set
Visual C++
public:
virtual property array<String^>^ SpecificCharacterSets {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyArrivalDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyArrivalDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Arrival Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyArrivalDate { get; set; }
Visual Basic
Public Overridable Property StudyArrivalDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyArrivalDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyArrivalTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyArrivalTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Arrival Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyArrivalTime { get; set; }
Visual Basic
Public Overridable Property StudyArrivalTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyArrivalTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyComments Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyComments Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Comments attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComments { get; set; }
Visual Basic
Public Overridable Property StudyComments As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComments {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyCompletionDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyCompletionDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Completion Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyCompletionDate { get; set; }
Visual Basic
Public Overridable Property StudyCompletionDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyCompletionDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyComponentStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyComponentStatusID Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Component Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComponentStatusID { get; set; }
Visual Basic
Public Overridable Property StudyComponentStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComponentStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyDate { get; set; }
Visual Basic
Public Overridable Property StudyDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyDescription Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyDescription { get; set; }
Visual Basic
Public Overridable Property StudyDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyID Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyIDIssuer Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyIDIssuer Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study ID Issuer attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyIDIssuer { get; set; }
Visual Basic
Public Overridable Property StudyIDIssuer As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyIDIssuer {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyInstanceUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyInstanceUID Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Instance UID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyInstanceUID { get; set; }
Visual Basic
Public Overridable Property StudyInstanceUID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyInstanceUID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyPriorityID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyPriorityID Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Priority ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyPriorityID { get; set; }
Visual Basic
Public Overridable Property StudyPriorityID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyPriorityID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyReadDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyReadDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Read Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyReadDate { get; set; }
Visual Basic
Public Overridable Property StudyReadDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyReadDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyReadTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyReadTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Read Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyReadTime { get; set; }
Visual Basic
Public Overridable Property StudyReadTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyReadTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyStatusID Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyStatusID { get; set; }
Visual Basic
Public Overridable Property StudyStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyTime { get; set; }
Visual Basic
Public Overridable Property StudyTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyVerifiedDate Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyVerifiedDate Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Verified Date attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdate StudyVerifiedDate { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedDate As MCdate
    Get
    Set
Visual C++
public:
virtual property MCdate^ StudyVerifiedDate {
    MCdate^ get ();
    void set (MCdate^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


StudyVerifiedTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementGet..::..StudyVerifiedTime Property
MCstudyComponentManagementGet Class See Also Send Feedback
Represents the value for the Study Verified Time attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCtime StudyVerifiedTime { get; set; }
Visual Basic
Public Overridable Property StudyVerifiedTime As MCtime
    Get
    Set
Visual C++
public:
virtual property MCtime^ StudyVerifiedTime {
    MCtime^ get ();
    void set (MCtime^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementGet Class
MCstudyComponentManagementGet Members
Mergecom.Gen Namespace


MCstudyComponentManagementSet Class

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Class
Members See Also Send Feedback
This class serves as a container for attributes of the STUDY_COMPONENT_MANAGEMENT IOD.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstudyComponentManagementSet
Visual Basic
Public Class MCstudyComponentManagementSet
Visual C++
public ref class MCstudyComponentManagementSet

Remarks

The following DICOM attributes are maintained in this collection:
  • (00081030) Study Description
  • (00081032) Procedure Code Sequence
  • (00081115) Referenced Series Sequence
  • (00200010) Study ID
  • (00321055) Study Component Status ID

Inheritance Hierarchy

System..::..Object
Mergecom.Gen..::..MCstudyComponentManagementSet

See Also

MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


MCstudyComponentManagementSet Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Members
MCstudyComponentManagementSet Class Constructors Methods Properties See Also Send Feedback

The MCstudyComponentManagementSet type exposes the following members.

Constructors

 | Name | Description
Public method | MCstudyComponentManagementSet()()()() | Constructs an MCstudyComponentManagementSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementSet(MCdataSet) | Constructs an MCstudyComponentManagementSet collection by wrapping an existing MCdataSet instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.

See Also

MCstudyComponentManagementSet Class
Mergecom.Gen Namespace


MCstudyComponentManagementSet Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Constructor
MCstudyComponentManagementSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstudyComponentManagementSet()()()() | Constructs an MCstudyComponentManagementSet collection. This constructor creates an empty MCdataSet object to wrap.
Public method | MCstudyComponentManagementSet(MCdataSet) | Constructs an MCstudyComponentManagementSet collection by wrapping an existing MCdataSet instance.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


MCstudyComponentManagementSet Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Constructor
MCstudyComponentManagementSet Class See Also Send Feedback
Constructs an MCstudyComponentManagementSet collection. This constructor creates an empty MCdataSet object to wrap.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementSet()
Visual Basic
Public Sub New
Visual C++
public:
MCstudyComponentManagementSet()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
MCstudyComponentManagementSet Overload
Mergecom.Gen Namespace


MCstudyComponentManagementSet Constructor (MCdataSet)

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Constructor (MCdataSet)
MCstudyComponentManagementSet Class See Also Send Feedback
Constructs an MCstudyComponentManagementSet collection by wrapping an existing MCdataSet instance.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstudyComponentManagementSet(
    MCdataSet host
)
Visual Basic
Public Sub New ( _
    host As MCdataSet _
)
Visual C++
public:
MCstudyComponentManagementSet(
    MCdataSet^ host
)

Parameters

host
Type: Mergecom..::..MCdataSet
A non-null MCdataSet object to wrap.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
MCstudyComponentManagementSet Overload
Mergecom.Gen Namespace


MCstudyComponentManagementSet Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Methods
MCstudyComponentManagementSet Class See Also Send Feedback

The MCstudyComponentManagementSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | removeProcedureCodes | This method removes all the values that may have been set for Procedure Code Sequence.
Public method | removeReferencedSeries | This method removes all the values that may have been set for Referenced Series Sequence.
Public method | removeStudyComponentStatusID | This method removes all the values that may have been set for Study Component Status ID.
Public method | removeStudyDescription | This method removes all the values that may have been set for Study Description.
Public method | removeStudyID | This method removes all the values that may have been set for Study ID.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCstudyComponentManagementSet Class
Mergecom.Gen Namespace


removeProcedureCodes Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..removeProcedureCodes Method
MCstudyComponentManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Procedure Code Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeProcedureCodes()
Visual Basic
Public Overridable Sub removeProcedureCodes
Visual C++
public:
virtual void removeProcedureCodes()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


removeReferencedSeries Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..removeReferencedSeries Method
MCstudyComponentManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Referenced Series Sequence.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeReferencedSeries()
Visual Basic
Public Overridable Sub removeReferencedSeries
Visual C++
public:
virtual void removeReferencedSeries()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


removeStudyComponentStatusID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..removeStudyComponentStatusID Method
MCstudyComponentManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Component Status ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyComponentStatusID()
Visual Basic
Public Overridable Sub removeStudyComponentStatusID
Visual C++
public:
virtual void removeStudyComponentStatusID()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


removeStudyDescription Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..removeStudyDescription Method
MCstudyComponentManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study Description.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyDescription()
Visual Basic
Public Overridable Sub removeStudyDescription
Visual C++
public:
virtual void removeStudyDescription()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


removeStudyID Method

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..removeStudyID Method
MCstudyComponentManagementSet Class See Also Send Feedback
This method removes all the values that may have been set for Study ID.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void removeStudyID()
Visual Basic
Public Overridable Sub removeStudyID
Visual C++
public:
virtual void removeStudyID()

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


MCstudyComponentManagementSet Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet Properties
MCstudyComponentManagementSet Class See Also Send Feedback

The MCstudyComponentManagementSet type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets the MCdataSet object wrapped by this container.
Public property | ProcedureCodes | Represents the values for the Procedure Code Sequence attribute.
Public property | ReferencedSeries | Represents the values for the Referenced Series Sequence attribute.
Public property | StudyComponentStatusID | Represents the value for the Study Component Status ID attribute.
Public property | StudyDescription | Represents the value for the Study Description attribute.
Public property | StudyID | Represents the value for the Study ID attribute.

See Also

MCstudyComponentManagementSet Class
Mergecom.Gen Namespace


Host Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..Host Property
MCstudyComponentManagementSet Class See Also Send Feedback
Gets the MCdataSet object wrapped by this container.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCdataSet Host { get; }
Visual Basic
Public Overridable ReadOnly Property Host As MCdataSet
    Get
Visual C++
public:
virtual property MCdataSet^ Host {
    MCdataSet^ get ();
}

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


ProcedureCodes Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..ProcedureCodes Property
MCstudyComponentManagementSet Class See Also Send Feedback
Represents the values for the Procedure Code Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCcodeItem[] ProcedureCodes { get; set; }
Visual Basic
Public Overridable Property ProcedureCodes As MCcodeItem()
    Get
    Set
Visual C++
public:
virtual property array<MCcodeItem^>^ ProcedureCodes {
    array<MCcodeItem^>^ get ();
    void set (array<MCcodeItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


ReferencedSeries Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..ReferencedSeries Property
MCstudyComponentManagementSet Class See Also Send Feedback
Represents the values for the Referenced Series Sequence attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual MCreferencedSeriesItem[] ReferencedSeries { get; set; }
Visual Basic
Public Overridable Property ReferencedSeries As MCreferencedSeriesItem()
    Get
    Set
Visual C++
public:
virtual property array<MCreferencedSeriesItem^>^ ReferencedSeries {
    array<MCreferencedSeriesItem^>^ get ();
    void set (array<MCreferencedSeriesItem^>^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


StudyComponentStatusID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..StudyComponentStatusID Property
MCstudyComponentManagementSet Class See Also Send Feedback
Represents the value for the Study Component Status ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyComponentStatusID { get; set; }
Visual Basic
Public Overridable Property StudyComponentStatusID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyComponentStatusID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


StudyDescription Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..StudyDescription Property
MCstudyComponentManagementSet Class See Also Send Feedback
Represents the value for the Study Description attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyDescription { get; set; }
Visual Basic
Public Overridable Property StudyDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyDescription {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


StudyID Property

[image]

Merge DICOM .NET/C# Toolkit
MCstudyComponentManagementSet..::..StudyID Property
MCstudyComponentManagementSet Class See Also Send Feedback
Represents the value for the Study ID attribute.

Namespace: Mergecom.Gen
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual string StudyID { get; set; }
Visual Basic
Public Overridable Property StudyID As String
    Get
    Set
Visual C++
public:
virtual property String^ StudyID {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCattributeNotFoundException | The attribute has not been defined for the message.
Mergecom.Exceptions..::..MCnoSuchValueException | The attribute does not have a value.

See Also

MCstudyComponentManagementSet Class
MCstudyComponentManagementSet Members
Mergecom.Gen Namespace


Mergecom.Logging Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom.Logging Namespace
Send Feedback
This namespace contains classes related to the logging feature in MergeCOM.

Classes

 | Class | Description
Public class | MClog | Contains Logging functionality for the Merge DICOM toolkit library.
Public class | MClogInfo | Represents a log message.
Public class | MClogTime | Represents the time a message was logged.

Interfaces

 | Interface | Description
Public interface | MClogHandler | This interface defines the requirements for a class which is to serve as a handler for processing log messages generated by Merge DICOM toolkit.

Enumerations

 | Enumeration | Description
Public enumeration | MClogLevel | Enumerated value to represent the log levels available.


MClog Class

[image]

Merge DICOM .NET/C# Toolkit
MClog Class
Members See Also Send Feedback
Contains Logging functionality for the Merge DICOM toolkit library.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MClog
Visual Basic
Public Class MClog
Visual C++
public ref class MClog

Remarks

In normal operation, the log lines are written to a log file configured in the merge.ini file. It is also possible to register a log handler that will be called whenever a log line is generated. The log handler can then display this log if necessary in the user application.

The Merge DICOM toolkit library generates a number of different "message types". The following is a summary of the types:

  • Error messages have a message type of "E" and are used to convey a serious problem that has occurred.
  • Warning messages have a message type of "W" and are used to convey warning situations that could possibly be a problem.
  • Info messages have a message type of "I" and are simple informational type messages.
  • (T1): Internal tracing.
  • (T2): Network messages received or sent are displayed at this level.
  • (T3): Association Negotiation information is displayed at this level.
  • (T4): Association rejections are displayed at this level.
  • (T5): Message validation information is displayed at this level.
  • (T6): Configuration information (the content of toolkit's configuration files when the library is initialized) is displayed at this level.
  • (T7): Command elements of received or sent messages are displayed at this level.
  • (T8): Warnings encountered during stream operations are displayed at this level.
  • (T9): Protocol Data Units (PDUs) contained in received or sent messages are displayed at this level.

All methods on MClog are thread safe.

Inheritance Hierarchy

System..::..Object
Mergecom.Logging..::..MClog

See Also

MClog Members
Mergecom.Logging Namespace


MClog Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MClog Members
MClog Class Methods Fields Properties See Also Send Feedback

The MClog type exposes the following members.

Methods

 | Name | Description
 | addHandler | Adds a log handler to receive logging messages.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | error | Logs an Error message using the Merge DICOM toolkit logger.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getLogPrefix | Returns the string that is currently being used as a prefix for all log messages.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | info | Logs an INFO message using the Merge DICOM toolkit logger.
 | log | Logs a message using the Merge DICOM toolkit logger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | removeHandler | Removes a log handler from the list of active handlers.
 | setLogPrefix | Sets a string that will prefix each log message line.
 | t1 | Logs a T1 message using the Merge DICOM toolkit logger.
 | t2 | Logs a T2 message using the Merge DICOM toolkit logger.
 | t3 | Logs a T3 message using the Merge DICOM toolkit logger.
 | t4 | Logs a T4 message using the Merge DICOM toolkit logger.
 | t5 | Logs a T5 message using the Merge DICOM toolkit logger.
 | t6 | Logs a T6 message using the Merge DICOM toolkit logger.
 | t7 | Logs a T7 message using the Merge DICOM toolkit logger.
 | t8 | Logs a T8 message using the Merge DICOM toolkit logger.
 | t9 | Logs a T9 message using the Merge DICOM toolkit logger.
 | throwing | Logs an exception using the Merge DICOM toolkit logger.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | warning | Logs a WARNING message using the Merge DICOM toolkit logger.

Fields

Name | Description
Bitbucket_Destination | Bitmask used to set the destination for a log level to bitbucket.
File_Destination | Bitmask used to set the destination for a log level to file.
Memory_Destination | Bitmask used to set the destination for a log level to a callback function.
Screen_Destination | Bitmask used to set the destination for a log level to print to the screen.

Properties

Name | Description
ErrorLogDestinations | Set or get the destinations for ERROR level log messages.
Handlers | Gets the list of log handlers associated with the Merge DICOM toolkit logger.
InfoLogDestinations | Set or get the destinations for INFO level log messages.
T1LogDestinations | Set or get the destinations for T1 level log messages.
T2LogDestinations | Set or get the destinations for T2 level log messages.
T3LogDestinations | Set or get the destinations for T3 level log messages.
T4LogDestinations | Set or get the destinations for T4 level log messages.
T5LogDestinations | Set or get the destinations for T5 level log messages.
T6LogDestinations | Set or get the destinations for T6 level log messages.
T7LogDestinations | Set or get the destinations for T7 level log messages.
T8LogDestinations | Set or get the destinations for T8 level log messages.
T9LogDestinations | Set or get the destinations for T9 level log messages.
WarningLogDestinations | Set or get the destinations for WARNING level log messages.

See Also

MClog Class
Mergecom.Logging Namespace


MClog Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MClog Fields
MClog Class See Also Send Feedback

The MClog type exposes the following members.

Fields

Name | Description
Bitbucket_Destination | Bitmask used to set the destination for a log level to bitbucket.
File_Destination | Bitmask used to set the destination for a log level to file.
Memory_Destination | Bitmask used to set the destination for a log level to a callback function.
Screen_Destination | Bitmask used to set the destination for a log level to print to the screen.

See Also

MClog Class
Mergecom.Logging Namespace


Bitbucket_Destination Field

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..Bitbucket_Destination Field
MClog Class See Also Send Feedback
Bitmask used to set the destination for a log level to bitbucket.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int Bitbucket_Destination
Visual Basic
Public Const Bitbucket_Destination As Integer
Visual C++
public:
literal int Bitbucket_Destination

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


File_Destination Field

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..File_Destination Field
MClog Class See Also Send Feedback
Bitmask used to set the destination for a log level to file.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int File_Destination
Visual Basic
Public Const File_Destination As Integer
Visual C++
public:
literal int File_Destination

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


Memory_Destination Field

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..Memory_Destination Field
MClog Class See Also Send Feedback
Bitmask used to set the destination for a log level to a callback function.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int Memory_Destination
Visual Basic
Public Const Memory_Destination As Integer
Visual C++
public:
literal int Memory_Destination

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


Screen_Destination Field

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..Screen_Destination Field
MClog Class See Also Send Feedback
Bitmask used to set the destination for a log level to print to the screen.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int Screen_Destination
Visual Basic
Public Const Screen_Destination As Integer
Visual C++
public:
literal int Screen_Destination

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


MClog Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MClog Methods
MClog Class See Also Send Feedback

The MClog type exposes the following members.

Methods

 | Name | Description
 | addHandler | Adds a log handler to receive logging messages.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | error | Logs an Error message using the Merge DICOM toolkit logger.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getLogPrefix | Returns the string that is currently being used as a prefix for all log messages.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | info | Logs an INFO message using the Merge DICOM toolkit logger.
 | log | Logs a message using the Merge DICOM toolkit logger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | removeHandler | Removes a log handler from the list of active handlers.
 | setLogPrefix | Sets a string that will prefix each log message line.
 | t1 | Logs a T1 message using the Merge DICOM toolkit logger.
 | t2 | Logs a T2 message using the Merge DICOM toolkit logger.
 | t3 | Logs a T3 message using the Merge DICOM toolkit logger.
 | t4 | Logs a T4 message using the Merge DICOM toolkit logger.
 | t5 | Logs a T5 message using the Merge DICOM toolkit logger.
 | t6 | Logs a T6 message using the Merge DICOM toolkit logger.
 | t7 | Logs a T7 message using the Merge DICOM toolkit logger.
 | t8 | Logs a T8 message using the Merge DICOM toolkit logger.
 | t9 | Logs a T9 message using the Merge DICOM toolkit logger.
 | throwing | Logs an exception using the Merge DICOM toolkit logger.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | warning | Logs a WARNING message using the Merge DICOM toolkit logger.

See Also

MClog Class
Mergecom.Logging Namespace


addHandler Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..addHandler Method
MClog Class See Also Send Feedback
Adds a log handler to receive logging messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void addHandler(
    MClogHandler handler
)
Visual Basic
Public Shared Sub addHandler ( _
    handler As MClogHandler _
)
Visual C++
public:
static void addHandler(
    MClogHandler^ handler
)

Parameters

handler
Type: Mergecom.Logging..::..MClogHandler
The handler to add.

Remarks

This method adds an implementation of the MClogHandler interface to the list of handler that will receive log messages.

Every log message will be given to all registered handlers.

Registering twice the same handler will result in that handler receiving twice every message.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


error Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..error Method
MClog Class See Also Send Feedback
Logs an Error message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void error(
    string msg
)
Visual Basic
Public Shared Sub error ( _
    msg As String _
)
Visual C++
public:
static void error(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to log.

Remarks

If the logger is currently enabled for the ERROR message level then the given message is forwarded to all the registered log handler objects. The caller's class and method name are automatically added to the log record.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


getLogPrefix Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..getLogPrefix Method
MClog Class See Also Send Feedback
Returns the string that is currently being used as a prefix for all log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static string getLogPrefix()
Visual Basic
Public Shared Function getLogPrefix As String
Visual C++
public:
static String^ getLogPrefix()

Return Value

A String that is used as prefix, it may be empty but not null.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


info Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..info Method
MClog Class See Also Send Feedback
Logs an INFO message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void info(
    string msg
)
Visual Basic
Public Shared Sub info ( _
    msg As String _
)
Visual C++
public:
static void info(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the INFO message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


log Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..log Method
MClog Class See Also Send Feedback
Logs a message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void log(
    MClogLevel level,
    string msg
)
Visual Basic
Public Shared Sub log ( _
    level As MClogLevel, _
    msg As String _
)
Visual C++
public:
static void log(
    MClogLevel level,
    String^ msg
)

Parameters

level
Type: Mergecom.Logging..::..MClogLevel
One of the message level identifiers, e.g. SEVERE
msg
Type: System..::..String
The string message (or a key in the message catalog)

Remarks

If the logger is currently enabled for the given message level then the message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


removeHandler Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..removeHandler Method
MClog Class See Also Send Feedback
Removes a log handler from the list of active handlers.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void removeHandler(
    MClogHandler handler
)
Visual Basic
Public Shared Sub removeHandler ( _
    handler As MClogHandler _
)
Visual C++
public:
static void removeHandler(
    MClogHandler^ handler
)

Parameters

handler
Type: Mergecom.Logging..::..MClogHandler
A log handler that was previously added to the list.

Remarks

Returns silently if the given handler is not found.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


setLogPrefix Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..setLogPrefix Method
MClog Class See Also Send Feedback
Sets a string that will prefix each log message line.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void setLogPrefix(
    string logPrefix
)
Visual Basic
Public Shared Sub setLogPrefix ( _
    logPrefix As String _
)
Visual C++
public:
static void setLogPrefix(
    String^ logPrefix
)

Parameters

logPrefix
Type: System..::..String
The string to prefix log messages.

Remarks

The first 10 characters of the string provided will be used for the new log prefix. If prefix is null or an empty value string, the new log prefix will be an empty string.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t1 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t1 Method
MClog Class See Also Send Feedback
Logs a T1 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t1(
    string msg
)
Visual Basic
Public Shared Sub t1 ( _
    msg As String _
)
Visual C++
public:
static void t1(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T1 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t2 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t2 Method
MClog Class See Also Send Feedback
Logs a T2 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t2(
    string msg
)
Visual Basic
Public Shared Sub t2 ( _
    msg As String _
)
Visual C++
public:
static void t2(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T2 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t3 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t3 Method
MClog Class See Also Send Feedback
Logs a T3 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t3(
    string msg
)
Visual Basic
Public Shared Sub t3 ( _
    msg As String _
)
Visual C++
public:
static void t3(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T3 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t4 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t4 Method
MClog Class See Also Send Feedback
Logs a T4 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t4(
    string msg
)
Visual Basic
Public Shared Sub t4 ( _
    msg As String _
)
Visual C++
public:
static void t4(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T4 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t5 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t5 Method
MClog Class See Also Send Feedback
Logs a T5 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t5(
    string msg
)
Visual Basic
Public Shared Sub t5 ( _
    msg As String _
)
Visual C++
public:
static void t5(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T5 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t6 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t6 Method
MClog Class See Also Send Feedback
Logs a T6 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t6(
    string msg
)
Visual Basic
Public Shared Sub t6 ( _
    msg As String _
)
Visual C++
public:
static void t6(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T6 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t7 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t7 Method
MClog Class See Also Send Feedback
Logs a T7 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t7(
    string msg
)
Visual Basic
Public Shared Sub t7 ( _
    msg As String _
)
Visual C++
public:
static void t7(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T7 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t8 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t8 Method
MClog Class See Also Send Feedback
Logs a T8 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t8(
    string msg
)
Visual Basic
Public Shared Sub t8 ( _
    msg As String _
)
Visual C++
public:
static void t8(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T8 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


t9 Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..t9 Method
MClog Class See Also Send Feedback
Logs a T9 message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void t9(
    string msg
)
Visual Basic
Public Shared Sub t9 ( _
    msg As String _
)
Visual C++
public:
static void t9(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to be logged.

Remarks

If the logger is currently enabled for the T9 message level then the given message is forwarded to all the registered log handler objects.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


throwing Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..throwing Method
MClog Class See Also Send Feedback
Logs an exception using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void throwing(
    string msg,
    Exception thrown
)
Visual Basic
Public Shared Sub throwing ( _
    msg As String, _
    thrown As Exception _
)
Visual C++
public:
static void throwing(
    String^ msg,
    Exception^ thrown
)

Parameters

msg
Type: System..::..String
The message to log.
thrown
Type: System..::..Exception
The exception that is being thrown or has been thrown.

Remarks

This is a convenience method to log that a method is terminating by throwing an exception. The logging is done using the ERROR level.

If the logger is currently enabled for the given message level then the given arguments are stored in a LogRecord which is forwarded to all registered log handler objects. The caller's class and method name are automatically added to the log record.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


warning Method

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..warning Method
MClog Class See Also Send Feedback
Logs a WARNING message using the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static void warning(
    string msg
)
Visual Basic
Public Shared Sub warning ( _
    msg As String _
)
Visual C++
public:
static void warning(
    String^ msg
)

Parameters

msg
Type: System..::..String
The message to log.

Remarks

If the logger is currently enabled for the WARNING message level then the given message is forwarded to all the registered log handler objects. The caller's class and method names are automatically added to the log record.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


MClog Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MClog Properties
MClog Class See Also Send Feedback

The MClog type exposes the following members.

Properties

Name | Description
ErrorLogDestinations | Set or get the destinations for ERROR level log messages.
Handlers | Gets the list of log handlers associated with the Merge DICOM toolkit logger.
InfoLogDestinations | Set or get the destinations for INFO level log messages.
T1LogDestinations | Set or get the destinations for T1 level log messages.
T2LogDestinations | Set or get the destinations for T2 level log messages.
T3LogDestinations | Set or get the destinations for T3 level log messages.
T4LogDestinations | Set or get the destinations for T4 level log messages.
T5LogDestinations | Set or get the destinations for T5 level log messages.
T6LogDestinations | Set or get the destinations for T6 level log messages.
T7LogDestinations | Set or get the destinations for T7 level log messages.
T8LogDestinations | Set or get the destinations for T8 level log messages.
T9LogDestinations | Set or get the destinations for T9 level log messages.
WarningLogDestinations | Set or get the destinations for WARNING level log messages.

See Also

MClog Class
Mergecom.Logging Namespace


ErrorLogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..ErrorLogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for ERROR level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int ErrorLogDestinations { get; set; }
Visual Basic
Public Shared Property ErrorLogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int ErrorLogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


Handlers Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..Handlers Property
MClog Class See Also Send Feedback
Gets the list of log handlers associated with the Merge DICOM toolkit logger.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static MClogHandler[] Handlers { get; }
Visual Basic
Public Shared ReadOnly Property Handlers As MClogHandler()
    Get
Visual C++
public:
static property array<MClogHandler^>^ Handlers {
    array<MClogHandler^>^ get ();
}

Return Value

An array of all registered log handlers.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


InfoLogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..InfoLogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for INFO level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int InfoLogDestinations { get; set; }
Visual Basic
Public Shared Property InfoLogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int InfoLogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T1LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T1LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T1 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T1LogDestinations { get; set; }
Visual Basic
Public Shared Property T1LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T1LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T2LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T2LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T2 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T2LogDestinations { get; set; }
Visual Basic
Public Shared Property T2LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T2LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T3LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T3LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T3 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T3LogDestinations { get; set; }
Visual Basic
Public Shared Property T3LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T3LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T4LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T4LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T4 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T4LogDestinations { get; set; }
Visual Basic
Public Shared Property T4LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T4LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T5LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T5LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T5 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T5LogDestinations { get; set; }
Visual Basic
Public Shared Property T5LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T5LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T6LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T6LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T6 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T6LogDestinations { get; set; }
Visual Basic
Public Shared Property T6LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T6LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T7LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T7LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T7 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T7LogDestinations { get; set; }
Visual Basic
Public Shared Property T7LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T7LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T8LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T8LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T8 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T8LogDestinations { get; set; }
Visual Basic
Public Shared Property T8LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T8LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


T9LogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..T9LogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for T9 level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int T9LogDestinations { get; set; }
Visual Basic
Public Shared Property T9LogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int T9LogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


WarningLogDestinations Property

[image]

Merge DICOM .NET/C# Toolkit
MClog..::..WarningLogDestinations Property
MClog Class See Also Send Feedback
Set or get the destinations for WARNING level log messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public static int WarningLogDestinations { get; set; }
Visual Basic
Public Shared Property WarningLogDestinations As Integer
    Get
    Set
Visual C++
public:
static property int WarningLogDestinations {
    int get ();
    void set (int value);
}

Field Value

One or more of the following constants or'd together: File_Destination, Memory_Destination, Memory_Destination, Bitbucket_Destination.

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCnotInitializedError | The library was released.

See Also

MClog Class
MClog Members
Mergecom.Logging Namespace


MClogHandler Interface

[image]

Merge DICOM .NET/C# Toolkit
MClogHandler Interface
Members See Also Send Feedback
This interface defines the requirements for a class which is to serve as a handler for processing log messages generated by Merge DICOM toolkit.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public interface MClogHandler
Visual Basic
Public Interface MClogHandler
Visual C++
public interface class MClogHandler

Remarks

A class that implements this interface may be registered, using the addHandler(MClogHandler) method, to receive information about every message logged by Merge DICOM toolkit.

See Also

MClogHandler Members
Mergecom.Logging Namespace


MClogHandler Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogHandler Members
MClogHandler Interface Methods See Also Send Feedback

The MClogHandler type exposes the following members.

Methods

 | Name | Description
Public method | receiveLogMessage | Receives messages to be logged.

See Also

MClogHandler Interface
Mergecom.Logging Namespace


MClogHandler Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogHandler Methods
MClogHandler Interface See Also Send Feedback

The MClogHandler type exposes the following members.

Methods

 | Name | Description
Public method | receiveLogMessage | Receives messages to be logged.

See Also

MClogHandler Interface
Mergecom.Logging Namespace


receiveLogMessage Method

[image]

Merge DICOM .NET/C# Toolkit
MClogHandler..::..receiveLogMessage Method
MClogHandler Interface See Also Send Feedback
Receives messages to be logged.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
void receiveLogMessage(
    MClogInfo logInfo
)
Visual Basic
Sub receiveLogMessage ( _
    logInfo As MClogInfo _
)
Visual C++
void receiveLogMessage(
    MClogInfo^ logInfo
)

Parameters

logInfo
Type: Mergecom.Logging..::..MClogInfo
An MClogInfo instance describing a log message.

See Also

MClogHandler Interface
MClogHandler Members
Mergecom.Logging Namespace


MClogInfo Class

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo Class
Members See Also Send Feedback
Represents a log message.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MClogInfo
Visual Basic
Public Class MClogInfo
Visual C++
public ref class MClogInfo

Inheritance Hierarchy

System..::..Object
Mergecom.Logging..::..MClogInfo

See Also

MClogInfo Members
Mergecom.Logging Namespace


MClogInfo Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogInfo Members
MClogInfo Class Constructors Methods Fields See Also Send Feedback

The MClogInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MClogInfo | Initializes a new instance of the MClogInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | logTime | Detailed log time information
 | MC_ERROR_MESSAGE | Constant representing Error messages.
 | MC_INFO_MESSAGE | Constant representing Info messages.
 | MC_OTHER_MESSAGE | Constant representing "Other" messages.
 | MC_T1_MESSAGE | Constant representing T1 messages.
 | MC_T2_MESSAGE | Constant representing T2 messages.
 | MC_T3_MESSAGE | Constant representing T3 messages.
 | MC_T4_MESSAGE | Constant representing T4 messages.
 | MC_T5_MESSAGE | Constant representing T5 messages.
 | MC_T6_MESSAGE | Constant representing T6 messages.
 | MC_T7_MESSAGE | Constant representing T7 messages.
 | MC_T8_MESSAGE | Constant representing T8 messages.
 | MC_T9_MESSAGE | Constant representing T9 messages.
 | MC_WARNING_MESSAGE | Constant representing Warning messages.
Public field | message | The log message.
Public field | method | Optional method name that generated the log message.
Public field | prefix | Optional user defined prefix for the log line.
Public field | processID | Process / ThreadID that generated the log.
Public field | timeStamp | Timestamp for the log line.
Public field | type | Type string (e.g. "T1" or "ERROR")
Public field | typeCode | Type code, one of the static constants defined for the class.

See Also

MClogInfo Class
Mergecom.Logging Namespace


MClogInfo Constructor

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo Constructor
MClogInfo Class See Also Send Feedback
Initializes a new instance of the MClogInfo class

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClogInfo()
Visual Basic
Public Sub New
Visual C++
public:
MClogInfo()

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MClogInfo Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogInfo Fields
MClogInfo Class See Also Send Feedback

The MClogInfo type exposes the following members.

Fields

 | Name | Description
Public field | logTime | Detailed log time information
 | MC_ERROR_MESSAGE | Constant representing Error messages.
 | MC_INFO_MESSAGE | Constant representing Info messages.
 | MC_OTHER_MESSAGE | Constant representing "Other" messages.
 | MC_T1_MESSAGE | Constant representing T1 messages.
 | MC_T2_MESSAGE | Constant representing T2 messages.
 | MC_T3_MESSAGE | Constant representing T3 messages.
 | MC_T4_MESSAGE | Constant representing T4 messages.
 | MC_T5_MESSAGE | Constant representing T5 messages.
 | MC_T6_MESSAGE | Constant representing T6 messages.
 | MC_T7_MESSAGE | Constant representing T7 messages.
 | MC_T8_MESSAGE | Constant representing T8 messages.
 | MC_T9_MESSAGE | Constant representing T9 messages.
 | MC_WARNING_MESSAGE | Constant representing Warning messages.
Public field | message | The log message.
Public field | method | Optional method name that generated the log message.
Public field | prefix | Optional user defined prefix for the log line.
Public field | processID | Process / ThreadID that generated the log.
Public field | timeStamp | Timestamp for the log line.
Public field | type | Type string (e.g. "T1" or "ERROR")
Public field | typeCode | Type code, one of the static constants defined for the class.

See Also

MClogInfo Class
Mergecom.Logging Namespace


logTime Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..logTime Field
MClogInfo Class See Also Send Feedback
Detailed log time information

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClogTime logTime
Visual Basic
Public logTime As MClogTime
Visual C++
public:
MClogTime^ logTime

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_ERROR_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_ERROR_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing Error messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_ERROR_MESSAGE
Visual Basic
Public Const MC_ERROR_MESSAGE As Integer
Visual C++
public:
literal int MC_ERROR_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_INFO_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_INFO_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing Info messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_INFO_MESSAGE
Visual Basic
Public Const MC_INFO_MESSAGE As Integer
Visual C++
public:
literal int MC_INFO_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_OTHER_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_OTHER_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing "Other" messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_OTHER_MESSAGE
Visual Basic
Public Const MC_OTHER_MESSAGE As Integer
Visual C++
public:
literal int MC_OTHER_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T1_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T1_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T1 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T1_MESSAGE
Visual Basic
Public Const MC_T1_MESSAGE As Integer
Visual C++
public:
literal int MC_T1_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T2_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T2_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T2 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T2_MESSAGE
Visual Basic
Public Const MC_T2_MESSAGE As Integer
Visual C++
public:
literal int MC_T2_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T3_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T3_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T3 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T3_MESSAGE
Visual Basic
Public Const MC_T3_MESSAGE As Integer
Visual C++
public:
literal int MC_T3_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T4_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T4_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T4 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T4_MESSAGE
Visual Basic
Public Const MC_T4_MESSAGE As Integer
Visual C++
public:
literal int MC_T4_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T5_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T5_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T5 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T5_MESSAGE
Visual Basic
Public Const MC_T5_MESSAGE As Integer
Visual C++
public:
literal int MC_T5_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T6_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T6_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T6 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T6_MESSAGE
Visual Basic
Public Const MC_T6_MESSAGE As Integer
Visual C++
public:
literal int MC_T6_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T7_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T7_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T7 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T7_MESSAGE
Visual Basic
Public Const MC_T7_MESSAGE As Integer
Visual C++
public:
literal int MC_T7_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T8_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T8_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T8 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T8_MESSAGE
Visual Basic
Public Const MC_T8_MESSAGE As Integer
Visual C++
public:
literal int MC_T8_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_T9_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_T9_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing T9 messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_T9_MESSAGE
Visual Basic
Public Const MC_T9_MESSAGE As Integer
Visual C++
public:
literal int MC_T9_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MC_WARNING_MESSAGE Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..MC_WARNING_MESSAGE Field
MClogInfo Class See Also Send Feedback
Constant representing Warning messages.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public const int MC_WARNING_MESSAGE
Visual Basic
Public Const MC_WARNING_MESSAGE As Integer
Visual C++
public:
literal int MC_WARNING_MESSAGE

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


message Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..message Field
MClogInfo Class See Also Send Feedback
The log message.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string message
Visual Basic
Public message As String
Visual C++
public:
String^ message

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


method Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..method Field
MClogInfo Class See Also Send Feedback
Optional method name that generated the log message.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string method
Visual Basic
Public method As String
Visual C++
public:
String^ method

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


prefix Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..prefix Field
MClogInfo Class See Also Send Feedback
Optional user defined prefix for the log line.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string prefix
Visual Basic
Public prefix As String
Visual C++
public:
String^ prefix

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


processID Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..processID Field
MClogInfo Class See Also Send Feedback
Process / ThreadID that generated the log.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string processID
Visual Basic
Public processID As String
Visual C++
public:
String^ processID

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


timeStamp Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..timeStamp Field
MClogInfo Class See Also Send Feedback
Timestamp for the log line.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string timeStamp
Visual Basic
Public timeStamp As String
Visual C++
public:
String^ timeStamp

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


type Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..type Field
MClogInfo Class See Also Send Feedback
Type string (e.g. "T1" or "ERROR")

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string type
Visual Basic
Public type As String
Visual C++
public:
String^ type

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


typeCode Field

[image]

Merge DICOM .NET/C# Toolkit
MClogInfo..::..typeCode Field
MClogInfo Class See Also Send Feedback
Type code, one of the static constants defined for the class.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int typeCode
Visual Basic
Public typeCode As Integer
Visual C++
public:
int typeCode

See Also

MClogInfo Class
MClogInfo Members
Mergecom.Logging Namespace


MClogInfo Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogInfo Methods
MClogInfo Class See Also Send Feedback

The MClogInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MClogInfo Class
Mergecom.Logging Namespace


MClogLevel Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MClogLevel Enumeration
See Also Send Feedback
Enumerated value to represent the log levels available.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MClogLevel
Visual Basic
Public Enumeration MClogLevel
Visual C++
public enum class MClogLevel

Members

Member name | Value | Description
ERROR | 1 | Error logs.
WARNING | 2 | Warning logs.
INFO | 3 | Informational logs.
T1 | 4 | Trace level 1 logs.
T2 | 5 | Trace level 2 logs.
T3 | 6 | Trace level 3 logs.
T4 | 7 | Trace level 4 logs.
T5 | 8 | Trace level 5 logs.
T6 | 9 | Trace level 6 logs.
T7 | 10 | Trace level 7 logs.
T8 | 11 | Trace level 8 logs.
T9 | 12 | Trace level 9 logs.

See Also

Mergecom.Logging Namespace


MClogTime Class

[image]

Merge DICOM .NET/C# Toolkit
MClogTime Class
Members See Also Send Feedback
Represents the time a message was logged.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MClogTime
Visual Basic
Public Class MClogTime
Visual C++
public ref class MClogTime

Inheritance Hierarchy

System..::..Object
Mergecom.Logging..::..MClogTime

See Also

MClogTime Members
Mergecom.Logging Namespace


MClogTime Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogTime Members
MClogTime Class Constructors Methods Fields See Also Send Feedback

The MClogTime type exposes the following members.

Constructors

 | Name | Description
Public method | MClogTime | Initializes a new instance of the MClogTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | day | Day of the month - [1,31].
Public field | hour | Hours since midnight - [0,23].
Public field | hun | Hundreths of a sec after the sec - [0,99].
Public field | min | Minutes after the hour - [0,59].
Public field | mon | Months since January - [0,11].
Public field | sec | Seconds after the minute - [0,59].
Public field | year | Years since 1900.

See Also

MClogTime Class
Mergecom.Logging Namespace


MClogTime Constructor

[image]

Merge DICOM .NET/C# Toolkit
MClogTime Constructor
MClogTime Class See Also Send Feedback
Initializes a new instance of the MClogTime class

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MClogTime()
Visual Basic
Public Sub New
Visual C++
public:
MClogTime()

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


MClogTime Fields

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogTime Fields
MClogTime Class See Also Send Feedback

The MClogTime type exposes the following members.

Fields

 | Name | Description
Public field | day | Day of the month - [1,31].
Public field | hour | Hours since midnight - [0,23].
Public field | hun | Hundreths of a sec after the sec - [0,99].
Public field | min | Minutes after the hour - [0,59].
Public field | mon | Months since January - [0,11].
Public field | sec | Seconds after the minute - [0,59].
Public field | year | Years since 1900.

See Also

MClogTime Class
Mergecom.Logging Namespace


day Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..day Field
MClogTime Class See Also Send Feedback
Day of the month - [1,31].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int day
Visual Basic
Public day As Integer
Visual C++
public:
int day

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


hour Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..hour Field
MClogTime Class See Also Send Feedback
Hours since midnight - [0,23].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int hour
Visual Basic
Public hour As Integer
Visual C++
public:
int hour

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


hun Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..hun Field
MClogTime Class See Also Send Feedback
Hundreths of a sec after the sec - [0,99].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int hun
Visual Basic
Public hun As Integer
Visual C++
public:
int hun

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


min Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..min Field
MClogTime Class See Also Send Feedback
Minutes after the hour - [0,59].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int min
Visual Basic
Public min As Integer
Visual C++
public:
int min

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


mon Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..mon Field
MClogTime Class See Also Send Feedback
Months since January - [0,11].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int mon
Visual Basic
Public mon As Integer
Visual C++
public:
int mon

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


sec Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..sec Field
MClogTime Class See Also Send Feedback
Seconds after the minute - [0,59].

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int sec
Visual Basic
Public sec As Integer
Visual C++
public:
int sec

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


year Field

[image]

Merge DICOM .NET/C# Toolkit
MClogTime..::..year Field
MClogTime Class See Also Send Feedback
Years since 1900.

Namespace: Mergecom.Logging
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int year
Visual Basic
Public year As Integer
Visual C++
public:
int year

See Also

MClogTime Class
MClogTime Members
Mergecom.Logging Namespace


MClogTime Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MClogTime Methods
MClogTime Class See Also Send Feedback

The MClogTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MClogTime Class
Mergecom.Logging Namespace


Mergecom.Sr Namespace

[image]

Merge DICOM .NET/C# Toolkit
Mergecom.Sr Namespace
Send Feedback
This namespace contains DICOM Structured Reporting support.

Classes

 | Class | Description
Public class | MCcodeItem | Categorical coded value. Representation of nominal or non-numeric ordinal values.
Public class | MCcompositeItem | A reference to one Composite SOP Instance which is not an Image or Waveform.
Public class | MCcontainerItem | CONTAINER groups Content Items and defines the heading or category of observation that applies to that content. The heading describes the content of the CONTAINER Content Item and may map to a document section heading in a printed or displayed document.
Public class | MCcontentItem | A base class for all Content Items
Public class | MCdateItem | Date of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public class | MCdateTimeItem | Date and time of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public class | MCimageItem | A reference to one Image. IMAGE Content Item may convey a reference to a Softcopy Presentation State associated with the Image.
Public class | MCitemIdentifer | Represents the Content Item position An ordered set of one or more integers that uniquely identifies the Target Content Item of the relationship. The root Content Item is referenced by a single value of 1. Each subsequent integer represents an ordinal position of a Content Item in the Content Sequence (0040,A730) in which it belongs. The number of values in this Multi-Value Attribute is exactly the number of relationships traversed in the SR content tree plus one.
Public class | MCitemRelationship | Encapsulates relationship and the target item
Public class | MCnumItem | Numeric value fully qualified by coded representation of the measurement name and unit of measurement.
Public class | MCpersonNameItem | Person name of the person whose role is described by the Concept Name.
Public class | MCspatialCoordinates3DItem | Spatial coordinates of a geometric region of interest in the DICOM image coordinate system. The IMAGE Content Item from which spatial coordinates are selected is denoted by a SELECTED FROM relationship Note: Spatial coordinates may be used to associate observational data with a set of Image features. Spatial coordinates also may be used to convey coordinates that are input data for a measurement.
Public class | MCspatialCoordinates3DItem..::..Position | An ordered set of (x,y,z) triplets (in mm and may be negative) that define a region of interest in the patient-relative Reference Coordinate System defined by Referenced Frame of Reference UID (3006,0024).
Public class | MCspatialCoordinatesItem | Spatial coordinates of a geometric region of interest in the DICOM image coordinate system. The IMAGE Content Item from which spatial coordinates are selected is denoted by a SELECTED FROM relationship Note: Spatial coordinates may be used to associate observational data with a set of Image features. Spatial coordinates also may be used to convey coordinates that are input data for a measurement.
Public class | MCspatialCoordinatesItem..::..Position | A column and row pair that denote position in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image.
Public class | MCstructuredReport | Represents the SR Document Content Module and supports following contents - Basic Text SR IOD Content - Enhanced SR IOD Content - Comprehensive SR IOD Content
Public class | MCtableCellValues | The values of each populated cell in the table, identified by row and column.
Public class | MCtableColumnDefinition | Concepts that define the meaning of the columns of the table.
Public class | MCtableItem | Table that represents the value of the Content Item.
Public class | MCtableRowDefinition | Concepts that defines the meaning of the rows of the table.
Public class | MCtemporalCoordDateTimeItem | Represents a DICOM TCOORD content item specifying temporal points for reference by absolute time.
Public class | MCtemporalCoordinatesItem | A base class for the Temporal Coordinates (i.e. time or eventbased coordinates) of a region of interest in the DICOM waveform coordinate system. The WAVEFORM or IMAGE or SCOORD Content Item from which Temporal Coordinates are selected is denoted by a SELECTED FROM relationship.
Public class | MCtemporalCoordPositionsItem | Represents a DICOM TCOORD content item specifying temporal points for reference by waveform sample offsets.
Public class | MCtemporalCoordTimeOffsetsItem | Represents a DICOM TCOORD content item specifying temporal points for reference by number of seconds after start of data.
Public class | MCtextItem | Free text, narrative description of unlimited length. May also be used to provide a label or identifier value.
Public class | MCtimeItem | Time of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public class | MCuidReferenceItem | Unique Identifier (UID) of the entity identified by the Concept Name.
Public class | MCwaveformItem | A reference to one Waveform Composite SOP Instance.
Public class | MCwaveformItem..::..Channel | Referenced Waveform Channel Each channel is specified as a pair of values (M,C), where the first value is the sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number), and the second value is the sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group. If the specified channel number is 0, the annotation applies to all channels in the multiplex group.

Enumerations

 | Enumeration | Description
Public enumeration | ContentItemType | Enumerates Content Item Value Types. The Value Type (0040,A040) attribute explicitly conveys the type of Content Item value encoding.
Public enumeration | MCcontainerItem..::..Continuity | Specifies for a CONTAINER whether or not its contained Content Items are logically linked in a continuous textual flow, or are separate items.
Public enumeration | MCrelationshipType | The type of relationship between the (enclosing) Source Content Item and the Target Content Item.
Public enumeration | MCspatialCoordinates3DItem..::..GraphicTypes | This attribute defines the type of geometry of the region of interest specified for 3D spatial coordinate geometries
Public enumeration | MCspatialCoordinatesItem..::..GraphicTypes | When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.
Public enumeration | MCtemporalCoordinatesItem..::..RangeTypes | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time.


ContentItemType Enumeration

[image]

Merge DICOM .NET/C# Toolkit
ContentItemType Enumeration
See Also Send Feedback
Enumerates Content Item Value Types. The Value Type (0040,A040) attribute explicitly conveys the type of Content Item value encoding.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum ContentItemType
Visual Basic
Public Enumeration ContentItemType
Visual C++
public enum class ContentItemType

Members

Member name | Value | Description
TEXT | 0 | Content Item Value Type is TEXT
NUM | 1 | Content Item Value Type is NUM
CODE | 2 | Content Item Value Type is CODE
DATE | 3 | Content Item Value Type is DATE
TIME | 4 | Content Item Value Type is TIME
DATETIME | 5 | Content Item Value Type is DATETIME
UIDREF | 6 | Content Item Value Type is UIDREF
PNAME | 7 | Content Item Value Type is PNAME
COMPOSITE | 8 | Content Item Value Type is COMPOSITE
IMAGE | 9 | Content Item Value Type is IMAGE
WAVEFORM | 10 | Content Item Value Type is WAVEFORM
SCOORD | 11 | Content Item Value Type is SCOORD
SCOORD3D | 12 | Content Item Value Type is SCOORD3D
TCOORD_DATE | 13 | Content Item Value Type is TCOORD with Referenced DateTime
TCOORD_TIME | 14 | Content Item Value Type is TCOORD with Referenced Time Offsets
TCOORD_POSITION | 15 | Content Item Value Type is TCOORD Referenced Sample Positions
CONTAINER | 16 | Content Item Value Type is CONTAINER
TABLE | 17 | Content Item Value Type is TABLE
UNKNOWN | 18 | Content Item Value Type is unknown (used internally)

See Also

Mergecom.Sr Namespace


MCcodeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Class
Members See Also Send Feedback
Categorical coded value. Representation of nominal or non-numeric ordinal values.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcodeItem : MCcontentItem
Visual Basic
Public Class MCcodeItem _
    Inherits MCcontentItem
Visual C++
public ref class MCcodeItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcodeItem

See Also

MCcodeItem Members
Mergecom.Sr Namespace


MCcodeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Members
MCcodeItem Class Constructors Methods Properties See Also Send Feedback

The MCcodeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcodeItem()()()() | Default constructor
Public method | MCcodeItem(MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the CODE Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | Code | Categorical coded value. Representation of nominal or non-numeric ordinal values.
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCcodeItem Class
Mergecom.Sr Namespace


MCcodeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor
MCcodeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcodeItem()()()() | Default constructor
Public method | MCcodeItem(MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the CODE Content Item

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Sr Namespace


MCcodeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor
MCcodeItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcodeItem()

See Also

MCcodeItem Class
MCcodeItem Members
MCcodeItem Overload
Mergecom.Sr Namespace


MCcodeItem Constructor (MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Constructor (MCbasicCodedEntry, MCbasicCodedEntry)
MCcodeItem Class See Also Send Feedback
Creates a new instance of the CODE Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcodeItem(
    MCbasicCodedEntry code,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    code As MCbasicCodedEntry, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCcodeItem(
    MCbasicCodedEntry^ code,
    MCbasicCodedEntry^ conceptName
)

Parameters

code
Type: Mergecom..::..MCbasicCodedEntry
Coded expression of the concept
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCcodeItem Class
MCcodeItem Members
MCcodeItem Overload
Mergecom.Sr Namespace


MCcodeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Methods
MCcodeItem Class See Also Send Feedback

The MCcodeItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCcodeItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..Read Method
MCcodeItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..Write Method
MCcodeItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Sr Namespace


MCcodeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcodeItem Properties
MCcodeItem Class See Also Send Feedback

The MCcodeItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | Code | Categorical coded value. Representation of nominal or non-numeric ordinal values.
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCcodeItem Class
Mergecom.Sr Namespace


Code Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..Code Property
MCcodeItem Class See Also Send Feedback
Categorical coded value. Representation of nominal or non-numeric ordinal values.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry Code { get; set; }
Visual Basic
Public Property Code As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ Code {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCcodeItem..::..ContentItemType Property
MCcodeItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCcodeItem Class
MCcodeItem Members
Mergecom.Sr Namespace


MCcompositeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Class
Members See Also Send Feedback
A reference to one Composite SOP Instance which is not an Image or Waveform.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcompositeItem : MCcontentItem
Visual Basic
Public Class MCcompositeItem _
    Inherits MCcontentItem
Visual C++
public ref class MCcompositeItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcompositeItem
Mergecom.Sr..::..MCimageItem
Mergecom.Sr..::..MCwaveformItem

See Also

MCcompositeItem Members
Mergecom.Sr Namespace


MCcompositeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Members
MCcompositeItem Class Constructors Methods Properties See Also Send Feedback

The MCcompositeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcompositeItem()()()() | Default constructor
Public method | MCcompositeItem(MCsopInstanceReference) | Creates a new instance of the COMPOSITE Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform.

See Also

MCcompositeItem Class
Mergecom.Sr Namespace


MCcompositeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Constructor
MCcompositeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcompositeItem()()()() | Default constructor
Public method | MCcompositeItem(MCsopInstanceReference) | Creates a new instance of the COMPOSITE Content Item

See Also

MCcompositeItem Class
MCcompositeItem Members
Mergecom.Sr Namespace


MCcompositeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Constructor
MCcompositeItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcompositeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcompositeItem()

See Also

MCcompositeItem Class
MCcompositeItem Members
MCcompositeItem Overload
Mergecom.Sr Namespace


MCcompositeItem Constructor (MCsopInstanceReference)

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Constructor (MCsopInstanceReference)
MCcompositeItem Class See Also Send Feedback
Creates a new instance of the COMPOSITE Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcompositeItem(
    MCsopInstanceReference sopReference
)
Visual Basic
Public Sub New ( _
    sopReference As MCsopInstanceReference _
)
Visual C++
public:
MCcompositeItem(
    MCsopInstanceReference^ sopReference
)

Parameters

sopReference
Type: Mergecom..::..MCsopInstanceReference
Composite SOP Instance

See Also

MCcompositeItem Class
MCcompositeItem Members
MCcompositeItem Overload
Mergecom.Sr Namespace


MCcompositeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Methods
MCcompositeItem Class See Also Send Feedback

The MCcompositeItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCcompositeItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem..::..Read Method
MCcompositeItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCcompositeItem Class
MCcompositeItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem..::..Write Method
MCcompositeItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCcompositeItem Class
MCcompositeItem Members
Mergecom.Sr Namespace


MCcompositeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem Properties
MCcompositeItem Class See Also Send Feedback

The MCcompositeItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform.

See Also

MCcompositeItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem..::..ContentItemType Property
MCcompositeItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCcompositeItem Class
MCcompositeItem Members
Mergecom.Sr Namespace


SopReference Property

[image]

Merge DICOM .NET/C# Toolkit
MCcompositeItem..::..SopReference Property
MCcompositeItem Class See Also Send Feedback
A reference to one Composite SOP Instance which is not an Image or Waveform.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReference SopReference { get; set; }
Visual Basic
Public Property SopReference As MCsopInstanceReference
    Get
    Set
Visual C++
public:
property MCsopInstanceReference^ SopReference {
    MCsopInstanceReference^ get ();
    void set (MCsopInstanceReference^ value);
}

See Also

MCcompositeItem Class
MCcompositeItem Members
Mergecom.Sr Namespace


MCcontainerItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Class
Members See Also Send Feedback
CONTAINER groups Content Items and defines the heading or category of observation that applies to that content. The heading describes the content of the CONTAINER Content Item and may map to a document section heading in a printed or displayed document.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCcontainerItem : MCcontentItem
Visual Basic
Public Class MCcontainerItem _
    Inherits MCcontentItem
Visual C++
public ref class MCcontainerItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcontainerItem

See Also

MCcontainerItem Members
Mergecom.Sr Namespace


MCcontainerItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Members
MCcontainerItem Class Constructors Methods Properties See Also Send Feedback

The MCcontainerItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcontainerItem()()()() | Default constructor
Public method | MCcontainerItem(String, MCcontainerItem..::..Continuity, MCbasicCodedEntry) | Creates a new instance of the CONTAINER Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | ContinuityOfContent | Continuity of Content (0040,A050) specifies whether or not all the Content Items contained in a CONTAINER are logically linked in a continuous textual flow, or are separate entities. It only applies to the children contained in the container, and not their children (which if containers themselves, will have the attribute specified explicitly).
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | TemplateId | Identifies the Template that was used in the creation of the associated Content Item and its subsidiary Content Items. A Template is identified by a Mapping Resource (0008,0105) (the entity that manages or registers the Template), and an identifier of the Template. DICOM Standard Templates are identified in Template Identifier (0040,DB00) using the CS value representation. The DICOM Template identifier (0040,DB00) is a string of digits, without leading zeroes, and does not include the string "TID".

See Also

MCcontainerItem Class
Mergecom.Sr Namespace


MCcontainerItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Constructor
MCcontainerItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCcontainerItem()()()() | Default constructor
Public method | MCcontainerItem(String, MCcontainerItem..::..Continuity, MCbasicCodedEntry) | Creates a new instance of the CONTAINER Content Item

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


MCcontainerItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Constructor
MCcontainerItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontainerItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcontainerItem()

See Also

MCcontainerItem Class
MCcontainerItem Members
MCcontainerItem Overload
Mergecom.Sr Namespace


MCcontainerItem Constructor (String, MCcontainerItem.Continuity, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Constructor (String, MCcontainerItem..::..Continuity, MCbasicCodedEntry)
MCcontainerItem Class See Also Send Feedback
Creates a new instance of the CONTAINER Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontainerItem(
    string templateId,
    MCcontainerItem..::..Continuity continuityOfContent,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    templateId As String, _
    continuityOfContent As MCcontainerItem..::..Continuity, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCcontainerItem(
    String^ templateId,
    MCcontainerItem..::..Continuity continuityOfContent,
    MCbasicCodedEntry^ conceptName
)

Parameters

templateId
Type: System..::..String
Identifies the Template that was used in the creation of the associated Content Item
continuityOfContent
Type: Mergecom.Sr..::..MCcontainerItem..::..Continuity
Continuity of Content
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCcontainerItem Class
MCcontainerItem Members
MCcontainerItem Overload
Mergecom.Sr Namespace


MCcontainerItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Methods
MCcontainerItem Class See Also Send Feedback

The MCcontainerItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCcontainerItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..Read Method
MCcontainerItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..Write Method
MCcontainerItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


MCcontainerItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem Properties
MCcontainerItem Class See Also Send Feedback

The MCcontainerItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | ContinuityOfContent | Continuity of Content (0040,A050) specifies whether or not all the Content Items contained in a CONTAINER are logically linked in a continuous textual flow, or are separate entities. It only applies to the children contained in the container, and not their children (which if containers themselves, will have the attribute specified explicitly).
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | TemplateId | Identifies the Template that was used in the creation of the associated Content Item and its subsidiary Content Items. A Template is identified by a Mapping Resource (0008,0105) (the entity that manages or registers the Template), and an identifier of the Template. DICOM Standard Templates are identified in Template Identifier (0040,DB00) using the CS value representation. The DICOM Template identifier (0040,DB00) is a string of digits, without leading zeroes, and does not include the string "TID".

See Also

MCcontainerItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..ContentItemType Property
MCcontainerItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


ContinuityOfContent Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..ContinuityOfContent Property
MCcontainerItem Class See Also Send Feedback
Continuity of Content (0040,A050) specifies whether or not all the Content Items contained in a CONTAINER are logically linked in a continuous textual flow, or are separate entities. It only applies to the children contained in the container, and not their children (which if containers themselves, will have the attribute specified explicitly).

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontainerItem..::..Continuity ContinuityOfContent { get; set; }
Visual Basic
Public Property ContinuityOfContent As MCcontainerItem..::..Continuity
    Get
    Set
Visual C++
public:
property MCcontainerItem..::..Continuity ContinuityOfContent {
    MCcontainerItem..::..Continuity get ();
    void set (MCcontainerItem..::..Continuity value);
}

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


TemplateId Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..TemplateId Property
MCcontainerItem Class See Also Send Feedback
Identifies the Template that was used in the creation of the associated Content Item and its subsidiary Content Items. A Template is identified by a Mapping Resource (0008,0105) (the entity that manages or registers the Template), and an identifier of the Template. DICOM Standard Templates are identified in Template Identifier (0040,DB00) using the CS value representation. The DICOM Template identifier (0040,DB00) is a string of digits, without leading zeroes, and does not include the string "TID".

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

See Also

MCcontainerItem Class
MCcontainerItem Members
Mergecom.Sr Namespace


MCcontainerItem.Continuity Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCcontainerItem..::..Continuity Enumeration
MCcontainerItem Class See Also Send Feedback
Specifies for a CONTAINER whether or not its contained Content Items are logically linked in a continuous textual flow, or are separate items.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum Continuity
Visual Basic
Public Enumeration Continuity
Visual C++
public enum class Continuity

Members

Member name | Value | Description
SEPARATE | 0 | Content Items are separate entities
CONTINUOUS | 1 | Content Items are logically linked in a continuous textual flow
UNKNOWN | 2 | Unknown or illegal value

See Also

Mergecom.Sr Namespace


MCcontentItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem Class
Members See Also Send Feedback
A base class for all Content Items

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCcontentItem : MCdataSetSerializable
Visual Basic
Public MustInherit Class MCcontentItem _
    Implements MCdataSetSerializable
Visual C++
public ref class MCcontentItem abstract : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcodeItem
Mergecom.Sr..::..MCcompositeItem
Mergecom.Sr..::..MCcontainerItem
Mergecom.Sr..::..MCdateItem
Mergecom.Sr..::..MCdateTimeItem
Mergecom.Sr..::..MCnumItem
Mergecom.Sr..::..MCpersonNameItem
Mergecom.Sr..::..MCspatialCoordinates3DItem
Mergecom.Sr..::..MCspatialCoordinatesItem
Mergecom.Sr..::..MCtableItem
Mergecom.Sr..::..MCtemporalCoordinatesItem
Mergecom.Sr..::..MCtextItem
Mergecom.Sr..::..MCtimeItem
Mergecom.Sr..::..MCuidReferenceItem

See Also

MCcontentItem Members
Mergecom.Sr Namespace


MCcontentItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontentItem Members
MCcontentItem Class Constructors Methods Properties See Also Send Feedback

The MCcontentItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCcontentItem | Default constructor

Methods

 | Name | Description
Public method | AddChild | Adds child to the node
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted
Public method | AddReference | Adds a reference to another node in the tree
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id.
Public method | GetPosition | Return a position of this item in the parent's content
Public method | getRootItem | Returns the Root content item
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | RemoveChild | Removes child node
Public method | RemoveReference(MCcontentItem) | Removes reference to the node
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence.
Public property | ContentItemType | Returns the value type. Must be overwritten in the derived class
Public property | DataContext | Optional data associated with the node
Public property | DataSet | MCattributeSet object associated with the node
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise.
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID.
Public property | Parent | Parent Item Content
Public property | References | A collection of references that are referenced by this content item
Public property | RelationshipType | Relationship type between parent and this item

See Also

MCcontentItem Class
Mergecom.Sr Namespace


MCcontentItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem Constructor
MCcontentItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontentItem()
Visual Basic
Public Sub New
Visual C++
public:
MCcontentItem()

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


MCcontentItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontentItem Methods
MCcontentItem Class See Also Send Feedback

The MCcontentItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted
Public method | AddReference | Adds a reference to another node in the tree
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id.
Public method | GetPosition | Return a position of this item in the parent's content
Public method | getRootItem | Returns the Root content item
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet
Public method | RemoveChild | Removes child node
Public method | RemoveReference(MCcontentItem) | Removes reference to the node
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

See Also

MCcontentItem Class
Mergecom.Sr Namespace


AddChild Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..AddChild Method
MCcontentItem Class See Also Send Feedback
Adds child to the node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void AddChild(
    MCcontentItem childItem,
    MCrelationshipType relationshipType
)
Visual Basic
Public Sub AddChild ( _
    childItem As MCcontentItem, _
    relationshipType As MCrelationshipType _
)
Visual C++
public:
void AddChild(
    MCcontentItem^ childItem,
    MCrelationshipType relationshipType
)

Parameters

childItem
Type: Mergecom.Sr..::..MCcontentItem
a new child node
relationshipType
Type: Mergecom.Sr..::..MCrelationshipType
relationship betwen parent and child

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the child Item already has a parent node

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


AddChildAt Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..AddChildAt Method
MCcontentItem Class See Also Send Feedback
Inserts a child at the specific position. The other children will be shifted

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void AddChildAt(
    MCcontentItem childItem,
    MCrelationshipType relationshipType,
    int position
)
Visual Basic
Public Sub AddChildAt ( _
    childItem As MCcontentItem, _
    relationshipType As MCrelationshipType, _
    position As Integer _
)
Visual C++
public:
void AddChildAt(
    MCcontentItem^ childItem,
    MCrelationshipType relationshipType,
    int position
)

Parameters

childItem
Type: Mergecom.Sr..::..MCcontentItem
a new child node
relationshipType
Type: Mergecom.Sr..::..MCrelationshipType
relationship betwen parent and child
position
Type: System..::..Int32
position for the child node that starts from 1

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the child Item already has a parent node or if the position is invalid

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


AddReference Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..AddReference Method
MCcontentItem Class See Also Send Feedback
Adds a reference to another node in the tree

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void AddReference(
    MCitemRelationship reference
)
Visual Basic
Public Sub AddReference ( _
    reference As MCitemRelationship _
)
Visual C++
public:
void AddReference(
    MCitemRelationship^ reference
)

Parameters

reference
Type: Mergecom.Sr..::..MCitemRelationship
a target node for the reference

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the child Item does not belong to this document

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


GetItemId Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..GetItemId Method
MCcontentItem Class See Also Send Feedback
Traverses current position and returns the Item Id.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitemIdentifer GetItemId()
Visual Basic
Public Function GetItemId As MCitemIdentifer
Visual C++
public:
MCitemIdentifer^ GetItemId()

Return Value

Item identifer for this item

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


GetPosition Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..GetPosition Method
MCcontentItem Class See Also Send Feedback
Return a position of this item in the parent's content

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int GetPosition()
Visual Basic
Public Function GetPosition As Integer
Visual C++
public:
int GetPosition()

Return Value

position of the item or -1 if the content item doesn't have a parent. Position is 1 based

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


getRootItem Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..getRootItem Method
MCcontentItem Class See Also Send Feedback
Returns the Root content item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontentItem getRootItem()
Visual Basic
Public Function getRootItem As MCcontentItem
Visual C++
public:
MCcontentItem^ getRootItem()

Return Value

Root content item

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..Read Method
MCcontentItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Read(
    MCattributeSet source
)
Visual Basic
Public Overridable Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
)

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


RemoveChild Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..RemoveChild Method
MCcontentItem Class See Also Send Feedback
Removes child node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void RemoveChild(
    MCcontentItem childItem
)
Visual Basic
Public Sub RemoveChild ( _
    childItem As MCcontentItem _
)
Visual C++
public:
void RemoveChild(
    MCcontentItem^ childItem
)

Parameters

childItem
Type: Mergecom.Sr..::..MCcontentItem
child node to remove

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the child Item does not belong to this node

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


RemoveReference Method

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..RemoveReference Method
MCcontentItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveReference(MCcontentItem) | Removes reference to the node
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


RemoveReference Method (MCcontentItem)

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..RemoveReference Method (MCcontentItem)
MCcontentItem Class See Also Send Feedback
Removes reference to the node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void RemoveReference(
    MCcontentItem targetItem
)
Visual Basic
Public Sub RemoveReference ( _
    targetItem As MCcontentItem _
)
Visual C++
public:
void RemoveReference(
    MCcontentItem^ targetItem
)

Parameters

targetItem
Type: Mergecom.Sr..::..MCcontentItem
referenced node to remove

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the targetItem is not referenced by this node

See Also

MCcontentItem Class
MCcontentItem Members
RemoveReference Overload
Mergecom.Sr Namespace


RemoveReference Method (MCitemRelationship)

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..RemoveReference Method (MCitemRelationship)
MCcontentItem Class See Also Send Feedback
Removes reference to the node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void RemoveReference(
    MCitemRelationship reference
)
Visual Basic
Public Sub RemoveReference ( _
    reference As MCitemRelationship _
)
Visual C++
public:
void RemoveReference(
    MCitemRelationship^ reference
)

Parameters

reference
Type: Mergecom.Sr..::..MCitemRelationship
reference to remove

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the reference does not belong to this node

See Also

MCcontentItem Class
MCcontentItem Members
RemoveReference Overload
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..Write Method
MCcontentItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Write(
    MCattributeSet destination
)
Visual Basic
Public Overridable Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
)

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


MCcontentItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCcontentItem Properties
MCcontentItem Class See Also Send Feedback

The MCcontentItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence.
Public property | ContentItemType | Returns the value type. Must be overwritten in the derived class
Public property | DataContext | Optional data associated with the node
Public property | DataSet | MCattributeSet object associated with the node
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise.
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID.
Public property | Parent | Parent Item Content
Public property | References | A collection of references that are referenced by this content item
Public property | RelationshipType | Relationship type between parent and this item

See Also

MCcontentItem Class
Mergecom.Sr Namespace


Children Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..Children Property
MCcontentItem Class See Also Send Feedback
Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ReadOnlyCollection<MCcontentItem> Children { get; }
Visual Basic
Public ReadOnly Property Children As ReadOnlyCollection(Of MCcontentItem)
    Get
Visual C++
public:
property ReadOnlyCollection<MCcontentItem^>^ Children {
    ReadOnlyCollection<MCcontentItem^>^ get ();
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


ConceptName Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..ConceptName Property
MCcontentItem Class See Also Send Feedback
Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry ConceptName { get; set; }
Visual Basic
Public Property ConceptName As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ ConceptName {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..ContentItemType Property
MCcontentItem Class See Also Send Feedback
Returns the value type. Must be overwritten in the derived class

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract ContentItemType ContentItemType { get; }
Visual Basic
Public MustOverride ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () abstract;
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


DataContext Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..DataContext Property
MCcontentItem Class See Also Send Feedback
Optional data associated with the node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Object DataContext { get; set; }
Visual Basic
Public Property DataContext As Object
    Get
    Set
Visual C++
public:
property Object^ DataContext {
    Object^ get ();
    void set (Object^ value);
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


DataSet Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..DataSet Property
MCcontentItem Class See Also Send Feedback
MCattributeSet object associated with the node

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCattributeSet DataSet { get; }
Visual Basic
Public ReadOnly Property DataSet As MCattributeSet
    Get
Visual C++
public:
property MCattributeSet^ DataSet {
    MCattributeSet^ get ();
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


ObservationDateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..ObservationDateTime Property
MCcontentItem Class See Also Send Feedback
Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTime ObservationDateTime { get; set; }
Visual Basic
Public Property ObservationDateTime As MCdateTime
    Get
    Set
Visual C++
public:
property MCdateTime^ ObservationDateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


ObservationUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..ObservationUID Property
MCcontentItem Class See Also Send Feedback
Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ObservationUID { get; set; }
Visual Basic
Public Property ObservationUID As String
    Get
    Set
Visual C++
public:
property String^ ObservationUID {
    String^ get ();
    void set (String^ value);
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


Parent Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..Parent Property
MCcontentItem Class See Also Send Feedback
Parent Item Content

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontentItem Parent { get; }
Visual Basic
Public ReadOnly Property Parent As MCcontentItem
    Get
Visual C++
public:
property MCcontentItem^ Parent {
    MCcontentItem^ get ();
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


References Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..References Property
MCcontentItem Class See Also Send Feedback
A collection of references that are referenced by this content item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ReadOnlyCollection<MCitemRelationship> References { get; }
Visual Basic
Public ReadOnly Property References As ReadOnlyCollection(Of MCitemRelationship)
    Get
Visual C++
public:
property ReadOnlyCollection<MCitemRelationship^>^ References {
    ReadOnlyCollection<MCitemRelationship^>^ get ();
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


RelationshipType Property

[image]

Merge DICOM .NET/C# Toolkit
MCcontentItem..::..RelationshipType Property
MCcontentItem Class See Also Send Feedback
Relationship type between parent and this item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrelationshipType RelationshipType { get; }
Visual Basic
Public ReadOnly Property RelationshipType As MCrelationshipType
    Get
Visual C++
public:
property MCrelationshipType RelationshipType {
    MCrelationshipType get ();
}

See Also

MCcontentItem Class
MCcontentItem Members
Mergecom.Sr Namespace


MCdateItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem Class
Members See Also Send Feedback
Date of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdateItem : MCcontentItem
Visual Basic
Public Class MCdateItem _
    Inherits MCcontentItem
Visual C++
public ref class MCdateItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCdateItem

See Also

MCdateItem Members
Mergecom.Sr Namespace


MCdateItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateItem Members
MCdateItem Class Constructors Methods Properties See Also Send Feedback

The MCdateItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCdateItem()()()() | Default constructor
Public method | MCdateItem(MCdate, MCbasicCodedEntry) | Creates a new instance of the DATE Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | Date | Date of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCdateItem Class
Mergecom.Sr Namespace


MCdateItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateItem Constructor
MCdateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdateItem()()()() | Default constructor
Public method | MCdateItem(MCdate, MCbasicCodedEntry) | Creates a new instance of the DATE Content Item

See Also

MCdateItem Class
MCdateItem Members
Mergecom.Sr Namespace


MCdateItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem Constructor
MCdateItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateItem()
Visual Basic
Public Sub New
Visual C++
public:
MCdateItem()

See Also

MCdateItem Class
MCdateItem Members
MCdateItem Overload
Mergecom.Sr Namespace


MCdateItem Constructor (MCdate, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem Constructor (MCdate, MCbasicCodedEntry)
MCdateItem Class See Also Send Feedback
Creates a new instance of the DATE Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateItem(
    MCdate date,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    date As MCdate, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCdateItem(
    MCdate^ date,
    MCbasicCodedEntry^ conceptName
)

Parameters

date
Type: Mergecom..::..MCdate
Date of occurrence of event
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name for the event

See Also

MCdateItem Class
MCdateItem Members
MCdateItem Overload
Mergecom.Sr Namespace


MCdateItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateItem Methods
MCdateItem Class See Also Send Feedback

The MCdateItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCdateItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem..::..Read Method
MCdateItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCdateItem Class
MCdateItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem..::..Write Method
MCdateItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCdateItem Class
MCdateItem Members
Mergecom.Sr Namespace


MCdateItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateItem Properties
MCdateItem Class See Also Send Feedback

The MCdateItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | Date | Date of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCdateItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem..::..ContentItemType Property
MCdateItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCdateItem Class
MCdateItem Members
Mergecom.Sr Namespace


Date Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateItem..::..Date Property
MCdateItem Class See Also Send Feedback
Date of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdate Date { get; set; }
Visual Basic
Public Property Date As MCdate
    Get
    Set
Visual C++
public:
property MCdate^ Date {
    MCdate^ get ();
    void set (MCdate^ value);
}

See Also

MCdateItem Class
MCdateItem Members
Mergecom.Sr Namespace


MCdateTimeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Class
Members See Also Send Feedback
Date and time of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCdateTimeItem : MCcontentItem
Visual Basic
Public Class MCdateTimeItem _
    Inherits MCcontentItem
Visual C++
public ref class MCdateTimeItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCdateTimeItem

See Also

MCdateTimeItem Members
Mergecom.Sr Namespace


MCdateTimeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Members
MCdateTimeItem Class Constructors Methods Properties See Also Send Feedback

The MCdateTimeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCdateTimeItem()()()() | Default constructor
Public method | MCdateTimeItem(MCdateTime, MCbasicCodedEntry) | Creates a new instance of the DATETIME Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | DateTime | Date and time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCdateTimeItem Class
Mergecom.Sr Namespace


MCdateTimeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Constructor
MCdateTimeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdateTimeItem()()()() | Default constructor
Public method | MCdateTimeItem(MCdateTime, MCbasicCodedEntry) | Creates a new instance of the DATETIME Content Item

See Also

MCdateTimeItem Class
MCdateTimeItem Members
Mergecom.Sr Namespace


MCdateTimeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Constructor
MCdateTimeItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTimeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCdateTimeItem()

See Also

MCdateTimeItem Class
MCdateTimeItem Members
MCdateTimeItem Overload
Mergecom.Sr Namespace


MCdateTimeItem Constructor (MCdateTime, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Constructor (MCdateTime, MCbasicCodedEntry)
MCdateTimeItem Class See Also Send Feedback
Creates a new instance of the DATETIME Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTimeItem(
    MCdateTime dateTime,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    dateTime As MCdateTime, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCdateTimeItem(
    MCdateTime^ dateTime,
    MCbasicCodedEntry^ conceptName
)

Parameters

dateTime
Type: Mergecom..::..MCdateTime
Date and time of occurrence of event
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name for the event

See Also

MCdateTimeItem Class
MCdateTimeItem Members
MCdateTimeItem Overload
Mergecom.Sr Namespace


MCdateTimeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Methods
MCdateTimeItem Class See Also Send Feedback

The MCdateTimeItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCdateTimeItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem..::..Read Method
MCdateTimeItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCdateTimeItem Class
MCdateTimeItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem..::..Write Method
MCdateTimeItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCdateTimeItem Class
MCdateTimeItem Members
Mergecom.Sr Namespace


MCdateTimeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem Properties
MCdateTimeItem Class See Also Send Feedback

The MCdateTimeItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | DateTime | Date and time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCdateTimeItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem..::..ContentItemType Property
MCdateTimeItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCdateTimeItem Class
MCdateTimeItem Members
Mergecom.Sr Namespace


DateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCdateTimeItem..::..DateTime Property
MCdateTimeItem Class See Also Send Feedback
Date and time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCdateTime DateTime { get; set; }
Visual Basic
Public Property DateTime As MCdateTime
    Get
    Set
Visual C++
public:
property MCdateTime^ DateTime {
    MCdateTime^ get ();
    void set (MCdateTime^ value);
}

See Also

MCdateTimeItem Class
MCdateTimeItem Members
Mergecom.Sr Namespace


MCimageItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem Class
Members See Also Send Feedback
A reference to one Image. IMAGE Content Item may convey a reference to a Softcopy Presentation State associated with the Image.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCimageItem : MCcompositeItem
Visual Basic
Public Class MCimageItem _
    Inherits MCcompositeItem
Visual C++
public ref class MCimageItem : public MCcompositeItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcompositeItem
Mergecom.Sr..::..MCimageItem

See Also

MCimageItem Members
Mergecom.Sr Namespace


MCimageItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageItem Members
MCimageItem Class Constructors Methods Properties See Also Send Feedback

The MCimageItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCimageItem()()()() | Default constructor
Public method | MCimageItem(MCsopInstanceReference) | Creates a new instance of the IMAGE Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcompositeItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcompositeItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcompositeItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | ReferencedFrames | Identifies the frame numbers within the Referenced SOP Instance to which the reference applies. The first frame shall be denoted as frame number 1. Required if the Referenced SOP Instance is a multi-frame image and the reference does not apply to all frames, and Referenced Segment Number (0062,000B) is not present.
Public property | ReferencedRealWorldVm | Optional reference to a Real World Value Mapping SOP Class/SOP Instance pair.
Public property | ReferencedSegments | Identifies the segments to which the reference applies identified by Segment Number (0062,0004). Required if the Referenced SOP Instance is a Segmentation and the reference does not apply to all segments and Referenced Frame Number (0008,1160) is not present.
Public property | ReferencedSps | Optional reference to a Softcopy Presentation State SOP Class/SOP Instance pair.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform. (Inherited from MCcompositeItem.)

See Also

MCimageItem Class
Mergecom.Sr Namespace


MCimageItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageItem Constructor
MCimageItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCimageItem()()()() | Default constructor
Public method | MCimageItem(MCsopInstanceReference) | Creates a new instance of the IMAGE Content Item

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


MCimageItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem Constructor
MCimageItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCimageItem()
Visual Basic
Public Sub New
Visual C++
public:
MCimageItem()

See Also

MCimageItem Class
MCimageItem Members
MCimageItem Overload
Mergecom.Sr Namespace


MCimageItem Constructor (MCsopInstanceReference)

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem Constructor (MCsopInstanceReference)
MCimageItem Class See Also Send Feedback
Creates a new instance of the IMAGE Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCimageItem(
    MCsopInstanceReference sopReference
)
Visual Basic
Public Sub New ( _
    sopReference As MCsopInstanceReference _
)
Visual C++
public:
MCimageItem(
    MCsopInstanceReference^ sopReference
)

Parameters

sopReference
Type: Mergecom..::..MCsopInstanceReference
Image SOP Instance

See Also

MCimageItem Class
MCimageItem Members
MCimageItem Overload
Mergecom.Sr Namespace


MCimageItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageItem Methods
MCimageItem Class See Also Send Feedback

The MCimageItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcompositeItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcompositeItem..::..Write(MCattributeSet).)

See Also

MCimageItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..Read Method
MCimageItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..Write Method
MCimageItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


MCimageItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCimageItem Properties
MCimageItem Class See Also Send Feedback

The MCimageItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcompositeItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | ReferencedFrames | Identifies the frame numbers within the Referenced SOP Instance to which the reference applies. The first frame shall be denoted as frame number 1. Required if the Referenced SOP Instance is a multi-frame image and the reference does not apply to all frames, and Referenced Segment Number (0062,000B) is not present.
Public property | ReferencedRealWorldVm | Optional reference to a Real World Value Mapping SOP Class/SOP Instance pair.
Public property | ReferencedSegments | Identifies the segments to which the reference applies identified by Segment Number (0062,0004). Required if the Referenced SOP Instance is a Segmentation and the reference does not apply to all segments and Referenced Frame Number (0008,1160) is not present.
Public property | ReferencedSps | Optional reference to a Softcopy Presentation State SOP Class/SOP Instance pair.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform. (Inherited from MCcompositeItem.)

See Also

MCimageItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..ContentItemType Property
MCimageItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


ReferencedFrames Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..ReferencedFrames Property
MCimageItem Class See Also Send Feedback
Identifies the frame numbers within the Referenced SOP Instance to which the reference applies. The first frame shall be denoted as frame number 1. Required if the Referenced SOP Instance is a multi-frame image and the reference does not apply to all frames, and Referenced Segment Number (0062,000B) is not present.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<int> ReferencedFrames { get; set; }
Visual Basic
Public Property ReferencedFrames As List(Of Integer)
    Get
    Set
Visual C++
public:
property List<int>^ ReferencedFrames {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


ReferencedRealWorldVm Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..ReferencedRealWorldVm Property
MCimageItem Class See Also Send Feedback
Optional reference to a Real World Value Mapping SOP Class/SOP Instance pair.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReference ReferencedRealWorldVm { get; set; }
Visual Basic
Public Property ReferencedRealWorldVm As MCsopInstanceReference
    Get
    Set
Visual C++
public:
property MCsopInstanceReference^ ReferencedRealWorldVm {
    MCsopInstanceReference^ get ();
    void set (MCsopInstanceReference^ value);
}

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


ReferencedSegments Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..ReferencedSegments Property
MCimageItem Class See Also Send Feedback
Identifies the segments to which the reference applies identified by Segment Number (0062,0004). Required if the Referenced SOP Instance is a Segmentation and the reference does not apply to all segments and Referenced Frame Number (0008,1160) is not present.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<int> ReferencedSegments { get; set; }
Visual Basic
Public Property ReferencedSegments As List(Of Integer)
    Get
    Set
Visual C++
public:
property List<int>^ ReferencedSegments {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


ReferencedSps Property

[image]

Merge DICOM .NET/C# Toolkit
MCimageItem..::..ReferencedSps Property
MCimageItem Class See Also Send Feedback
Optional reference to a Softcopy Presentation State SOP Class/SOP Instance pair.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCsopInstanceReference ReferencedSps { get; set; }
Visual Basic
Public Property ReferencedSps As MCsopInstanceReference
    Get
    Set
Visual C++
public:
property MCsopInstanceReference^ ReferencedSps {
    MCsopInstanceReference^ get ();
    void set (MCsopInstanceReference^ value);
}

See Also

MCimageItem Class
MCimageItem Members
Mergecom.Sr Namespace


MCitemIdentifer Class

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Class
Members See Also Send Feedback
Represents the Content Item position An ordered set of one or more integers that uniquely identifies the Target Content Item of the relationship. The root Content Item is referenced by a single value of 1. Each subsequent integer represents an ordinal position of a Content Item in the Content Sequence (0040,A730) in which it belongs. The number of values in this Multi-Value Attribute is exactly the number of relationships traversed in the SR content tree plus one.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCitemIdentifer
Visual Basic
Public Class MCitemIdentifer
Visual C++
public ref class MCitemIdentifer

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCitemIdentifer

See Also

MCitemIdentifer Members
Mergecom.Sr Namespace


MCitemIdentifer Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Members
MCitemIdentifer Class Constructors Methods Properties See Also Send Feedback

The MCitemIdentifer type exposes the following members.

Constructors

 | Name | Description
Public method | MCitemIdentifer(List<(Of <<'(Int32>)>>)) | Constructs identifer from the list
Public method | MCitemIdentifer(array<Int32>[]()[][]) | Constructs identifer from the array

Methods

 | Name | Description
Public method | Equals | Compares two item identifers (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code value (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation for the identifer (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Returns an ordered set of one or more integers that uniquely identifies the Target Content Item

See Also

MCitemIdentifer Class
Mergecom.Sr Namespace


MCitemIdentifer Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Constructor
MCitemIdentifer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCitemIdentifer(List<(Of <<'(Int32>)>>)) | Constructs identifer from the list
Public method | MCitemIdentifer(array<Int32>[]()[][]) | Constructs identifer from the array

See Also

MCitemIdentifer Class
MCitemIdentifer Members
Mergecom.Sr Namespace


MCitemIdentifer Constructor (List(Int32))

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Constructor (List<(Of <(<'Int32>)>)>)
MCitemIdentifer Class See Also Send Feedback
Constructs identifer from the list

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitemIdentifer(
    List<int> id
)
Visual Basic
Public Sub New ( _
    id As List(Of Integer) _
)
Visual C++
public:
MCitemIdentifer(
    List<int>^ id
)

Parameters

id
Type: System.Collections.Generic..::..List<(Of <(<'Int32>)>)>
The list of identifers

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the id has less than one item

See Also

MCitemIdentifer Class
MCitemIdentifer Members
MCitemIdentifer Overload
Mergecom.Sr Namespace


MCitemIdentifer Constructor (Int32[])

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Constructor (array<Int32>[]()[][])
MCitemIdentifer Class See Also Send Feedback
Constructs identifer from the array

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitemIdentifer(
    int[] id
)
Visual Basic
Public Sub New ( _
    id As Integer() _
)
Visual C++
public:
MCitemIdentifer(
    array<int>^ id
)

Parameters

id
Type: array<System..::..Int32>[]()[][]
The array of identifers

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the id has less than one item

See Also

MCitemIdentifer Class
MCitemIdentifer Members
MCitemIdentifer Overload
Mergecom.Sr Namespace


MCitemIdentifer Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Methods
MCitemIdentifer Class See Also Send Feedback

The MCitemIdentifer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two item identifers (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code value (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation for the identifer (Overrides Object..::..ToString()()()().)

See Also

MCitemIdentifer Class
Mergecom.Sr Namespace


Equals Method

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer..::..Equals Method
MCitemIdentifer Class See Also Send Feedback
Compares two item identifers

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Object to compare with

Return Value

True if equal

See Also

MCitemIdentifer Class
MCitemIdentifer Members
Mergecom.Sr Namespace


GetHashCode Method

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer..::..GetHashCode Method
MCitemIdentifer Class See Also Send Feedback
Returns a hash code value

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

hash code value

See Also

MCitemIdentifer Class
MCitemIdentifer Members
Mergecom.Sr Namespace


ToString Method

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer..::..ToString Method
MCitemIdentifer Class See Also Send Feedback
Returns a string representation for the identifer

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

a string representation for the identifer

See Also

MCitemIdentifer Class
MCitemIdentifer Members
Mergecom.Sr Namespace


MCitemIdentifer Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer Properties
MCitemIdentifer Class See Also Send Feedback

The MCitemIdentifer type exposes the following members.

Properties

 | Name | Description
Public property | Id | Returns an ordered set of one or more integers that uniquely identifies the Target Content Item

See Also

MCitemIdentifer Class
Mergecom.Sr Namespace


Id Property

[image]

Merge DICOM .NET/C# Toolkit
MCitemIdentifer..::..Id Property
MCitemIdentifer Class See Also Send Feedback
Returns an ordered set of one or more integers that uniquely identifies the Target Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int[] Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer()
    Get
Visual C++
public:
property array<int>^ Id {
    array<int>^ get ();
}

See Also

MCitemIdentifer Class
MCitemIdentifer Members
Mergecom.Sr Namespace


MCitemRelationship Class

[image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship Class
Members See Also Send Feedback
Encapsulates relationship and the target item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCitemRelationship
Visual Basic
Public Class MCitemRelationship
Visual C++
public ref class MCitemRelationship

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCitemRelationship

See Also

MCitemRelationship Members
Mergecom.Sr Namespace


MCitemRelationship Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship Members
MCitemRelationship Class Constructors Methods Properties See Also Send Feedback

The MCitemRelationship type exposes the following members.

Constructors

 | Name | Description
Public method | MCitemRelationship | Creates a new instance of MCitemRelationship

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RelationshipType | Type of relationship
Public property | Target | Target content item

See Also

MCitemRelationship Class
Mergecom.Sr Namespace


MCitemRelationship Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship Constructor
MCitemRelationship Class See Also Send Feedback
Creates a new instance of MCitemRelationship

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCitemRelationship(
    MCrelationshipType relationshipType,
    MCcontentItem target
)
Visual Basic
Public Sub New ( _
    relationshipType As MCrelationshipType, _
    target As MCcontentItem _
)
Visual C++
public:
MCitemRelationship(
    MCrelationshipType relationshipType,
    MCcontentItem^ target
)

Parameters

relationshipType
Type: Mergecom.Sr..::..MCrelationshipType
type of relationship
target
Type: Mergecom.Sr..::..MCcontentItem
Target content item

See Also

MCitemRelationship Class
MCitemRelationship Members
Mergecom.Sr Namespace


MCitemRelationship Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship Methods
MCitemRelationship Class See Also Send Feedback

The MCitemRelationship type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCitemRelationship Class
Mergecom.Sr Namespace


MCitemRelationship Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship Properties
MCitemRelationship Class See Also Send Feedback

The MCitemRelationship type exposes the following members.

Properties

 | Name | Description
Public property | RelationshipType | Type of relationship
Public property | Target | Target content item

See Also

MCitemRelationship Class
Mergecom.Sr Namespace


RelationshipType Property

[image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship..::..RelationshipType Property
MCitemRelationship Class See Also Send Feedback
Type of relationship

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCrelationshipType RelationshipType { get; set; }
Visual Basic
Public Property RelationshipType As MCrelationshipType
    Get
    Set
Visual C++
public:
property MCrelationshipType RelationshipType {
    MCrelationshipType get ();
    void set (MCrelationshipType value);
}

See Also

MCitemRelationship Class
MCitemRelationship Members
Mergecom.Sr Namespace


Target Property

[image]

Merge DICOM .NET/C# Toolkit
MCitemRelationship..::..Target Property
MCitemRelationship Class See Also Send Feedback
Target content item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontentItem Target { get; set; }
Visual Basic
Public Property Target As MCcontentItem
    Get
    Set
Visual C++
public:
property MCcontentItem^ Target {
    MCcontentItem^ get ();
    void set (MCcontentItem^ value);
}

See Also

MCitemRelationship Class
MCitemRelationship Members
Mergecom.Sr Namespace


MCnumItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem Class
Members See Also Send Feedback
Numeric value fully qualified by coded representation of the measurement name and unit of measurement.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCnumItem : MCcontentItem
Visual Basic
Public Class MCnumItem _
    Inherits MCcontentItem
Visual C++
public ref class MCnumItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCnumItem

See Also

MCnumItem Members
Mergecom.Sr Namespace


MCnumItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnumItem Members
MCnumItem Class Constructors Methods Properties See Also Send Feedback

The MCnumItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCnumItem()()()() | default constructor
Public method | MCnumItem(List<(Of <<'(String>)>>), MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the NUM Content Item
Public method | MCnumItem(String, MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the NUM Content Item with a single value

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | Qualifier | Qualification of Numeric Value in Measured Value Sequence, or reason for absence of Measured Value Sequence Item.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Units | Unit of Measurement associated with value
Public property | Values | Numeric value(s)

See Also

MCnumItem Class
Mergecom.Sr Namespace


MCnumItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnumItem Constructor
MCnumItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCnumItem()()()() | default constructor
Public method | MCnumItem(List<(Of <<'(String>)>>), MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the NUM Content Item
Public method | MCnumItem(String, MCbasicCodedEntry, MCbasicCodedEntry) | Creates a new instance of the NUM Content Item with a single value

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


MCnumItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem Constructor
MCnumItem Class See Also Send Feedback
default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnumItem()
Visual Basic
Public Sub New
Visual C++
public:
MCnumItem()

See Also

MCnumItem Class
MCnumItem Members
MCnumItem Overload
Mergecom.Sr Namespace


MCnumItem Constructor (List(String), MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem Constructor (List<(Of <(<'String>)>)>, MCbasicCodedEntry, MCbasicCodedEntry)
MCnumItem Class See Also Send Feedback
Creates a new instance of the NUM Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnumItem(
    List<string> values,
    MCbasicCodedEntry units,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    values As List(Of String), _
    units As MCbasicCodedEntry, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCnumItem(
    List<String^>^ values,
    MCbasicCodedEntry^ units,
    MCbasicCodedEntry^ conceptName
)

Parameters

values
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
Numeric value(s)
units
Type: Mergecom..::..MCbasicCodedEntry
Unit of Measurement
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCnumItem Class
MCnumItem Members
MCnumItem Overload
Mergecom.Sr Namespace


MCnumItem Constructor (String, MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem Constructor (String, MCbasicCodedEntry, MCbasicCodedEntry)
MCnumItem Class See Also Send Feedback
Creates a new instance of the NUM Content Item with a single value

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCnumItem(
    string value,
    MCbasicCodedEntry units,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    value As String, _
    units As MCbasicCodedEntry, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCnumItem(
    String^ value,
    MCbasicCodedEntry^ units,
    MCbasicCodedEntry^ conceptName
)

Parameters

value
Type: System..::..String
Numeric value that can be null
units
Type: Mergecom..::..MCbasicCodedEntry
Unit of Measurement
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCnumItem Class
MCnumItem Members
MCnumItem Overload
Mergecom.Sr Namespace


MCnumItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnumItem Methods
MCnumItem Class See Also Send Feedback

The MCnumItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCnumItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..Read Method
MCnumItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..Write Method
MCnumItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


MCnumItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCnumItem Properties
MCnumItem Class See Also Send Feedback

The MCnumItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | Qualifier | Qualification of Numeric Value in Measured Value Sequence, or reason for absence of Measured Value Sequence Item.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Units | Unit of Measurement associated with value
Public property | Values | Numeric value(s)

See Also

MCnumItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..ContentItemType Property
MCnumItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


Qualifier Property

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..Qualifier Property
MCnumItem Class See Also Send Feedback
Qualification of Numeric Value in Measured Value Sequence, or reason for absence of Measured Value Sequence Item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry Qualifier { get; set; }
Visual Basic
Public Property Qualifier As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ Qualifier {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


Units Property

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..Units Property
MCnumItem Class See Also Send Feedback
Unit of Measurement associated with value

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry Units { get; set; }
Visual Basic
Public Property Units As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ Units {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


Values Property

[image]

Merge DICOM .NET/C# Toolkit
MCnumItem..::..Values Property
MCnumItem Class See Also Send Feedback
Numeric value(s)

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<string> Values { get; set; }
Visual Basic
Public Property Values As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ Values {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

MCnumItem Class
MCnumItem Members
Mergecom.Sr Namespace


MCpersonNameItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Class
Members See Also Send Feedback
Person name of the person whose role is described by the Concept Name.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCpersonNameItem : MCcontentItem
Visual Basic
Public Class MCpersonNameItem _
    Inherits MCcontentItem
Visual C++
public ref class MCpersonNameItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCpersonNameItem

See Also

MCpersonNameItem Members
Mergecom.Sr Namespace


MCpersonNameItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Members
MCpersonNameItem Class Constructors Methods Properties See Also Send Feedback

The MCpersonNameItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCpersonNameItem()()()() | Default constructor
Public method | MCpersonNameItem(MCpersonName, MCbasicCodedEntry) | Creates a new instance of the PNAME Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | PersonName | Person name of the person whose role is described by the Concept Name.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCpersonNameItem Class
Mergecom.Sr Namespace


MCpersonNameItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Constructor
MCpersonNameItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCpersonNameItem()()()() | Default constructor
Public method | MCpersonNameItem(MCpersonName, MCbasicCodedEntry) | Creates a new instance of the PNAME Content Item

See Also

MCpersonNameItem Class
MCpersonNameItem Members
Mergecom.Sr Namespace


MCpersonNameItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Constructor
MCpersonNameItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonNameItem()
Visual Basic
Public Sub New
Visual C++
public:
MCpersonNameItem()

See Also

MCpersonNameItem Class
MCpersonNameItem Members
MCpersonNameItem Overload
Mergecom.Sr Namespace


MCpersonNameItem Constructor (MCpersonName, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Constructor (MCpersonName, MCbasicCodedEntry)
MCpersonNameItem Class See Also Send Feedback
Creates a new instance of the PNAME Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonNameItem(
    MCpersonName personName,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    personName As MCpersonName, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCpersonNameItem(
    MCpersonName^ personName,
    MCbasicCodedEntry^ conceptName
)

Parameters

personName
Type: Mergecom..::..MCpersonName
Person name
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCpersonNameItem Class
MCpersonNameItem Members
MCpersonNameItem Overload
Mergecom.Sr Namespace


MCpersonNameItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Methods
MCpersonNameItem Class See Also Send Feedback

The MCpersonNameItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCpersonNameItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem..::..Read Method
MCpersonNameItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCpersonNameItem Class
MCpersonNameItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem..::..Write Method
MCpersonNameItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCpersonNameItem Class
MCpersonNameItem Members
Mergecom.Sr Namespace


MCpersonNameItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem Properties
MCpersonNameItem Class See Also Send Feedback

The MCpersonNameItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | PersonName | Person name of the person whose role is described by the Concept Name.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCpersonNameItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem..::..ContentItemType Property
MCpersonNameItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCpersonNameItem Class
MCpersonNameItem Members
Mergecom.Sr Namespace


PersonName Property

[image]

Merge DICOM .NET/C# Toolkit
MCpersonNameItem..::..PersonName Property
MCpersonNameItem Class See Also Send Feedback
Person name of the person whose role is described by the Concept Name.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCpersonName PersonName { get; set; }
Visual Basic
Public Property PersonName As MCpersonName
    Get
    Set
Visual C++
public:
property MCpersonName^ PersonName {
    MCpersonName^ get ();
    void set (MCpersonName^ value);
}

See Also

MCpersonNameItem Class
MCpersonNameItem Members
Mergecom.Sr Namespace


MCrelationshipType Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCrelationshipType Enumeration
See Also Send Feedback
The type of relationship between the (enclosing) Source Content Item and the Target Content Item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum MCrelationshipType
Visual Basic
Public Enumeration MCrelationshipType
Visual C++
public enum class MCrelationshipType

Members

Member name | Value | Description
CONTAINS | 0 | Source Item contains Target Content Item. E.g.: CONTAINER "History" {CONTAINS: TEXT: "mother had breast cancer"; CONTAINS IMAGE 36}
HAS_OBS_CONTEXT | 1 | Target Content Items shall convey any specialization of Observation Context needed for unambiguous documentation of the Source Content Item. E.g: CONTAINER: "Report" {HAS OBS CONTEXT: PNAME: "Recording Observer" = "Smith^John^^Dr^"}
HAS_ACQ_CONTEXT | 2 | The Target Content Item describes the conditions present during data acquisition of the Source Content Item. E.g: IMAGE 36 {HAS ACQ CONTEXT: CODE "contrast agent", HAS ACQ CONTEXT: CODE "position of imaging subject", ...}.
HAS_CONCEPT_MOD | 3 | Used to qualify or describe the Concept Name of the Source Content item, such as to create a post-coordinated description of a concept, or to further describe a concept. E.g. CODE "Chest X-Ray" {HAS CONCEPT MOD: CODE "View = PA and Lateral"} E.g. CODE "Breast" {HAS CONCEPT MOD: TEXT "French Translation" = "Sein"} E.g. CODE "2VCXRPALAT" {HAS CONCEPT MOD: TEXT "Further Explanation" = "Chest X-Ray, Two Views, Posteroanterior and Lateral"}
HAS_PROPERTIES | 4 | Description of properties of the Source Content Item. E.g: CODE "Mass" {HAS PROPERTIES: CODE "anatomic location", HAS PROPERTIES: CODE "diameter", HAS PROPERTIES: CODE "margin", ...}.
INFERRED_FROM | 5 | Source Content Item conveys a measurement or other inference made from the Target Content Items. Denotes the supporting evidence for a measurement or judgment. E.g: CODE "Malignancy" {INFERRED FROM: CODE "Mass", INFERRED FROM: CODE "Lymphadenopathy",...}. E.g: NUM: "BPD = 5mm" {INFERRED FROM: SCOORD}.
SELECTED_FROM | 6 | Source Content Item conveys spatial or temporal coordinates selected from the Target Content Item(s). E.g: SCOORD: "CLOSED 1,1 5,10" {SELECTED FROM: IMAGE 36}. E.g: TCOORD: "SEGMENT 60-200mS" {SELECTED FROM: WAVEFORM}.
UNDEFINED | 7 | The relationship is not defined yet. It is valid only if there is no parent

See Also

Mergecom.Sr Namespace


MCspatialCoordinates3DItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Class
Members See Also Send Feedback
Spatial coordinates of a geometric region of interest in the DICOM image coordinate system. The IMAGE Content Item from which spatial coordinates are selected is denoted by a SELECTED FROM relationship Note: Spatial coordinates may be used to associate observational data with a set of Image features. Spatial coordinates also may be used to convey coordinates that are input data for a measurement.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCspatialCoordinates3DItem : MCcontentItem
Visual Basic
Public Class MCspatialCoordinates3DItem _
    Inherits MCcontentItem
Visual C++
public ref class MCspatialCoordinates3DItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCspatialCoordinates3DItem

See Also

MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Members
MCspatialCoordinates3DItem Class Constructors Methods Properties See Also Send Feedback

The MCspatialCoordinates3DItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCspatialCoordinates3DItem()()()() | Default constructor
Public method | MCspatialCoordinates3DItem(String, MCspatialCoordinates3DItem..::..GraphicTypes, List<(Of <<'(MCspatialCoordinates3DItem..::..Position>)>>)) | Creates a new instance of the SCOORD3D Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | GraphicData | An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image
Public property | GraphicType | When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | ReferencedUID | Uniquely identifies the Frame of Reference within which the coordinates are defined.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCspatialCoordinates3DItem Class
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Constructor
MCspatialCoordinates3DItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCspatialCoordinates3DItem()()()() | Default constructor
Public method | MCspatialCoordinates3DItem(String, MCspatialCoordinates3DItem..::..GraphicTypes, List<(Of <<'(MCspatialCoordinates3DItem..::..Position>)>>)) | Creates a new instance of the SCOORD3D Content Item

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Constructor
MCspatialCoordinates3DItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinates3DItem()
Visual Basic
Public Sub New
Visual C++
public:
MCspatialCoordinates3DItem()

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
MCspatialCoordinates3DItem Overload
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Constructor (String, MCspatialCoordinates3DItem.GraphicTypes, List(MCspatialCoordinates3DItem.Position))

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Constructor (String, MCspatialCoordinates3DItem..::..GraphicTypes, List<(Of <(<'MCspatialCoordinates3DItem..::..Position>)>)>)
MCspatialCoordinates3DItem Class See Also Send Feedback
Creates a new instance of the SCOORD3D Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinates3DItem(
    string referencedUID,
    MCspatialCoordinates3DItem..::..GraphicTypes graphicType,
    List<MCspatialCoordinates3DItem..::..Position> graphicData
)
Visual Basic
Public Sub New ( _
    referencedUID As String, _
    graphicType As MCspatialCoordinates3DItem..::..GraphicTypes, _
    graphicData As List(Of MCspatialCoordinates3DItem..::..Position) _
)
Visual C++
public:
MCspatialCoordinates3DItem(
    String^ referencedUID,
    MCspatialCoordinates3DItem..::..GraphicTypes graphicType,
    List<MCspatialCoordinates3DItem..::..Position^>^ graphicData
)

Parameters

referencedUID
Type: System..::..String
Uniquely identifies the Frame of Reference within which the coordinates are defined.
graphicType
Type: Mergecom.Sr..::..MCspatialCoordinates3DItem..::..GraphicTypes
Defines the type of geometry of the annotated region of interest
graphicData
Type: System.Collections.Generic..::..List<(Of <(<' MCspatialCoordinates3DItem..::..Position >)>)>
An ordered set of (column,row) pairs that denote positions in an image

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
MCspatialCoordinates3DItem Overload
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Methods
MCspatialCoordinates3DItem Class See Also Send Feedback

The MCspatialCoordinates3DItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCspatialCoordinates3DItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Read Method
MCspatialCoordinates3DItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Write Method
MCspatialCoordinates3DItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem Properties
MCspatialCoordinates3DItem Class See Also Send Feedback

The MCspatialCoordinates3DItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | GraphicData | An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image
Public property | GraphicType | When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | ReferencedUID | Uniquely identifies the Frame of Reference within which the coordinates are defined.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCspatialCoordinates3DItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..ContentItemType Property
MCspatialCoordinates3DItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


GraphicData Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..GraphicData Property
MCspatialCoordinates3DItem Class See Also Send Feedback
An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCspatialCoordinates3DItem..::..Position> GraphicData { get; set; }
Visual Basic
Public Property GraphicData As List(Of MCspatialCoordinates3DItem..::..Position)
    Get
    Set
Visual C++
public:
property List<MCspatialCoordinates3DItem..::..Position^>^ GraphicData {
    List<MCspatialCoordinates3DItem..::..Position^>^ get ();
    void set (List<MCspatialCoordinates3DItem..::..Position^>^ value);
}

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


GraphicType Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..GraphicType Property
MCspatialCoordinates3DItem Class See Also Send Feedback
When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinates3DItem..::..GraphicTypes GraphicType { get; set; }
Visual Basic
Public Property GraphicType As MCspatialCoordinates3DItem..::..GraphicTypes
    Get
    Set
Visual C++
public:
property MCspatialCoordinates3DItem..::..GraphicTypes GraphicType {
    MCspatialCoordinates3DItem..::..GraphicTypes get ();
    void set (MCspatialCoordinates3DItem..::..GraphicTypes value);
}

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


ReferencedUID Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..ReferencedUID Property
MCspatialCoordinates3DItem Class See Also Send Feedback
Uniquely identifies the Frame of Reference within which the coordinates are defined.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string ReferencedUID { get; private set; }
Visual Basic
Public Property ReferencedUID As String
    Get
    Private Set
Visual C++
public:
property String^ ReferencedUID {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCspatialCoordinates3DItem Class
MCspatialCoordinates3DItem Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.GraphicTypes Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..GraphicTypes Enumeration
MCspatialCoordinates3DItem Class See Also Send Feedback
This attribute defines the type of geometry of the region of interest specified for 3D spatial coordinate geometries

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum GraphicTypes
Visual Basic
Public Enumeration GraphicTypes
Visual C++
public enum class GraphicTypes

Members

Member name | Value | Description
POINT | 0 | A single location denoted by a single (x,y,z) triplet.
MULTIPOINT | 1 | Multiple locations each denoted by an (x,y,z) triplet; the points need not be coplanar.
POLYLINE | 2 | A series of connected line segments with ordered vertices denoted by (x,y,z) triplets; the points need not be coplanar.
POLYGON | 3 | A series of connected line segments with ordered vertices denoted by (x,y,z) triplets, where the first and last vertices shall be the same forming a polygon; the points shall be coplanar.
ELLIPSE | 4 | An ellipse defined by four (x,y,z) triplets, the first two triplets specifying the endpoints of the major axis and the second two triplets specifying the endpoints of the minor axis.
ELLIPSOID | 5 | A three-dimensional geometric surface whose plane sections are either ellipses or circles and contains three intersecting orthogonal axes, "a", "b", and "c". The ellipsoid is defined by six (x,y,z) triplets, the first and second triplets specifying the endpoints of axis "a", the third and fourth triplets specifying the endpoints of axis "b", and the fifth and sixth triplets specifying the endpoints of axis "c".
UNKNOWN | 6 | An unknown illegal value

See Also

Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Class

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem Class Members See Also Send Feedback
An ordered set of (x,y,z) triplets (in mm and may be negative) that define a region of interest in the patient-relative Reference Coordinate System defined by Referenced Frame of Reference UID (3006,0024).

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class Position
Visual Basic
Public Class Position
Visual C++
public ref class Position

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCspatialCoordinates3DItem..::..Position

See Also

MCspatialCoordinates3DItem..::..Position Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Members
MCspatialCoordinates3DItem..::..Position Class Constructors Methods Properties See Also Send Feedback

The MCspatialCoordinates3DItem..::..Position type exposes the following members.

Constructors

 | Name | Description
Public method | MCspatialCoordinates3DItem..::..Position()()()() | Default constructor
Public method | MCspatialCoordinates3DItem..::..Position(Single, Single, Single) | Creates a new Position with data

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | X | X coordinate
Public property | Y | Y coordinate
Public property | Z | Z coordinate

See Also

MCspatialCoordinates3DItem..::..Position Class
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Constructor
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCspatialCoordinates3DItem..::..Position()()()() | Default constructor
Public method | MCspatialCoordinates3DItem..::..Position(Single, Single, Single) | Creates a new Position with data

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Constructor
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Position()
Visual Basic
Public Sub New
Visual C++
public:
Position()

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
MCspatialCoordinates3DItem..::..Position Overload
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Constructor (Single, Single, Single)

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Constructor (Single, Single, Single)
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback
Creates a new Position with data

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Position(
    float x,
    float y,
    float z
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
Position(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::..Single
X coordinate
y
Type: System..::..Single
Y coordinate
z
Type: System..::..Single
Z coordinate

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
MCspatialCoordinates3DItem..::..Position Overload
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Methods
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback

The MCspatialCoordinates3DItem..::..Position type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCspatialCoordinates3DItem..::..Position Class
Mergecom.Sr Namespace


MCspatialCoordinates3DItem.Position Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position Properties
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback

The MCspatialCoordinates3DItem..::..Position type exposes the following members.

Properties

 | Name | Description
Public property | X | X coordinate
Public property | Y | Y coordinate
Public property | Z | Z coordinate

See Also

MCspatialCoordinates3DItem..::..Position Class
Mergecom.Sr Namespace


X Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position..::..X Property
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback
X coordinate

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
Mergecom.Sr Namespace


Y Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position..::..Y Property
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback
Y coordinate

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
Mergecom.Sr Namespace


Z Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinates3DItem..::..Position..::..Z Property
MCspatialCoordinates3DItem..::..Position Class See Also Send Feedback
Z coordinate

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public float Z { get; set; }
Visual Basic
Public Property Z As Single
    Get
    Set
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

MCspatialCoordinates3DItem..::..Position Class
MCspatialCoordinates3DItem..::..Position Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Class
Members See Also Send Feedback
Spatial coordinates of a geometric region of interest in the DICOM image coordinate system. The IMAGE Content Item from which spatial coordinates are selected is denoted by a SELECTED FROM relationship Note: Spatial coordinates may be used to associate observational data with a set of Image features. Spatial coordinates also may be used to convey coordinates that are input data for a measurement.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCspatialCoordinatesItem : MCcontentItem
Visual Basic
Public Class MCspatialCoordinatesItem _
    Inherits MCcontentItem
Visual C++
public ref class MCspatialCoordinatesItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCspatialCoordinatesItem

See Also

MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Members
MCspatialCoordinatesItem Class Constructors Methods Properties See Also Send Feedback

The MCspatialCoordinatesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCspatialCoordinatesItem()()()() | Default constructor
Public method | MCspatialCoordinatesItem(MCspatialCoordinatesItem..::..GraphicTypes, List<(Of <<'(MCspatialCoordinatesItem..::..Position>)>>)) | Creates a new instance of the SCOORD Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | GraphicData | An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image
Public property | GraphicType | When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCspatialCoordinatesItem Class
Mergecom.Sr Namespace


MCspatialCoordinatesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Constructor
MCspatialCoordinatesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCspatialCoordinatesItem()()()() | Default constructor
Public method | MCspatialCoordinatesItem(MCspatialCoordinatesItem..::..GraphicTypes, List<(Of <<'(MCspatialCoordinatesItem..::..Position>)>>)) | Creates a new instance of the SCOORD Content Item

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Constructor
MCspatialCoordinatesItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinatesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCspatialCoordinatesItem()

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
MCspatialCoordinatesItem Overload
Mergecom.Sr Namespace


MCspatialCoordinatesItem Constructor (MCspatialCoordinatesItem.GraphicTypes, List(MCspatialCoordinatesItem.Position))

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Constructor (MCspatialCoordinatesItem..::..GraphicTypes, List<(Of <(<'MCspatialCoordinatesItem..::..Position>)>)>)
MCspatialCoordinatesItem Class See Also Send Feedback
Creates a new instance of the SCOORD Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinatesItem(
    MCspatialCoordinatesItem..::..GraphicTypes graphicType,
    List<MCspatialCoordinatesItem..::..Position> graphicData
)
Visual Basic
Public Sub New ( _
    graphicType As MCspatialCoordinatesItem..::..GraphicTypes, _
    graphicData As List(Of MCspatialCoordinatesItem..::..Position) _
)
Visual C++
public:
MCspatialCoordinatesItem(
    MCspatialCoordinatesItem..::..GraphicTypes graphicType,
    List<MCspatialCoordinatesItem..::..Position^>^ graphicData
)

Parameters

graphicType
Type: Mergecom.Sr..::..MCspatialCoordinatesItem..::..GraphicTypes
defines the type of geometry of the annotated region of interest
graphicData
Type: System.Collections.Generic..::..List<(Of <(<' MCspatialCoordinatesItem..::..Position >)>)>
An ordered set of (column,row) pairs that denote positions in an image

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
MCspatialCoordinatesItem Overload
Mergecom.Sr Namespace


MCspatialCoordinatesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Methods
MCspatialCoordinatesItem Class See Also Send Feedback

The MCspatialCoordinatesItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCspatialCoordinatesItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Read Method
MCspatialCoordinatesItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Write Method
MCspatialCoordinatesItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem Properties
MCspatialCoordinatesItem Class See Also Send Feedback

The MCspatialCoordinatesItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | GraphicData | An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image
Public property | GraphicType | When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCspatialCoordinatesItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..ContentItemType Property
MCspatialCoordinatesItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


GraphicData Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..GraphicData Property
MCspatialCoordinatesItem Class See Also Send Feedback
An ordered set of (column,row) pairs that denote positions in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCspatialCoordinatesItem..::..Position> GraphicData { get; set; }
Visual Basic
Public Property GraphicData As List(Of MCspatialCoordinatesItem..::..Position)
    Get
    Set
Visual C++
public:
property List<MCspatialCoordinatesItem..::..Position^>^ GraphicData {
    List<MCspatialCoordinatesItem..::..Position^>^ get ();
    void set (List<MCspatialCoordinatesItem..::..Position^>^ value);
}

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


GraphicType Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..GraphicType Property
MCspatialCoordinatesItem Class See Also Send Feedback
When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCspatialCoordinatesItem..::..GraphicTypes GraphicType { get; set; }
Visual Basic
Public Property GraphicType As MCspatialCoordinatesItem..::..GraphicTypes
    Get
    Set
Visual C++
public:
property MCspatialCoordinatesItem..::..GraphicTypes GraphicType {
    MCspatialCoordinatesItem..::..GraphicTypes get ();
    void set (MCspatialCoordinatesItem..::..GraphicTypes value);
}

See Also

MCspatialCoordinatesItem Class
MCspatialCoordinatesItem Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem.GraphicTypes Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..GraphicTypes Enumeration
MCspatialCoordinatesItem Class See Also Send Feedback
When annotation applies to an image, this attribute defines the type of geometry of the annotated region of interest.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum GraphicTypes
Visual Basic
Public Enumeration GraphicTypes
Visual C++
public enum class GraphicTypes

Members

Member name | Value | Description
POINT | 0 | a single pixel denoted by a single (column,row) pair
MULTIPOINT | 1 | multiple pixels each denoted by an (column,row) pair
POLYLINE | 2 | a series of connected line segments with ordered vertices denoted by (column,row) pairs; if the first and last vertices are the same it is a closed polygon
CIRCLE | 3 | a circle defined by two (column,row) pairs. The first point is the central pixel. The second point is a pixel on the perimeter of the circle.
ELLIPSE | 4 | an ellipse defined by four pixel (column,row) pairs, the first two points specifying the endpoints of the major axis and the second two points specifying the endpoints of the minor axis of an ellipse
UNKNOWN | 5 | an unknown illegal value

See Also

Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Class

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem Class Members See Also Send Feedback
A column and row pair that denote position in an image specified with sub-pixel resolution such that the origin at the TLHC of the TLHC pixel is 0.0\0.0, the BRHC of the TLHC pixel is 1.0\1.0, and the BRHC of the BRHC pixel is Columns\Rows. The values must be within the range 0\0 to Columns\Rows. The values Columns (0028,0011) and Rows (0028,0010) are those contained in the referenced image.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class Position
Visual Basic
Public Class Position
Visual C++
public ref class Position

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCspatialCoordinatesItem..::..Position

See Also

MCspatialCoordinatesItem..::..Position Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Members
MCspatialCoordinatesItem..::..Position Class Constructors Methods Properties See Also Send Feedback

The MCspatialCoordinatesItem..::..Position type exposes the following members.

Constructors

 | Name | Description
Public method | MCspatialCoordinatesItem..::..Position()()()() | Default constructor
Public method | MCspatialCoordinatesItem..::..Position(Single, Single) | Creates a new Position with data

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Column | Image column
Public property | Row | Image row

See Also

MCspatialCoordinatesItem..::..Position Class
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Constructor
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCspatialCoordinatesItem..::..Position()()()() | Default constructor
Public method | MCspatialCoordinatesItem..::..Position(Single, Single) | Creates a new Position with data

See Also

MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem..::..Position Members
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Constructor
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Position()
Visual Basic
Public Sub New
Visual C++
public:
Position()

See Also

MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem..::..Position Members
MCspatialCoordinatesItem..::..Position Overload
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Constructor (Single, Single)

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Constructor (Single, Single)
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback
Creates a new Position with data

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Position(
    float column,
    float row
)
Visual Basic
Public Sub New ( _
    column As Single, _
    row As Single _
)
Visual C++
public:
Position(
    float column,
    float row
)

Parameters

column
Type: System..::..Single
Image column
row
Type: System..::..Single
Image row

See Also

MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem..::..Position Members
MCspatialCoordinatesItem..::..Position Overload
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Methods
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback

The MCspatialCoordinatesItem..::..Position type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCspatialCoordinatesItem..::..Position Class
Mergecom.Sr Namespace


MCspatialCoordinatesItem.Position Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position Properties
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback

The MCspatialCoordinatesItem..::..Position type exposes the following members.

Properties

 | Name | Description
Public property | Column | Image column
Public property | Row | Image row

See Also

MCspatialCoordinatesItem..::..Position Class
Mergecom.Sr Namespace


Column Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position..::..Column Property
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback
Image column

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public float Column { get; set; }
Visual Basic
Public Property Column As Single
    Get
    Set
Visual C++
public:
property float Column {
    float get ();
    void set (float value);
}

See Also

MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem..::..Position Members
Mergecom.Sr Namespace


Row Property

[image]

Merge DICOM .NET/C# Toolkit
MCspatialCoordinatesItem..::..Position..::..Row Property
MCspatialCoordinatesItem..::..Position Class See Also Send Feedback
Image row

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public float Row { get; set; }
Visual Basic
Public Property Row As Single
    Get
    Set
Visual C++
public:
property float Row {
    float get ();
    void set (float value);
}

See Also

MCspatialCoordinatesItem..::..Position Class
MCspatialCoordinatesItem..::..Position Members
Mergecom.Sr Namespace


MCstructuredReport Class

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Class
Members See Also Send Feedback
Represents the SR Document Content Module and supports following contents - Basic Text SR IOD Content - Enhanced SR IOD Content - Comprehensive SR IOD Content

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCstructuredReport : MCdataSetSerializable
Visual Basic
Public Class MCstructuredReport _
    Implements MCdataSetSerializable
Visual C++
public ref class MCstructuredReport : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCstructuredReport

See Also

MCstructuredReport Members
Mergecom.Sr Namespace


MCstructuredReport Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Members
MCstructuredReport Class Constructors Methods Properties See Also Send Feedback

The MCstructuredReport type exposes the following members.

Constructors

 | Name | Description
Public method | MCstructuredReport()()()() | Default constructor
Public method | MCstructuredReport(String, MCcontainerItem..::..Continuity, MCbasicCodedEntry) | Creates a new instance of the structured report and initializes the root CONTAINER item

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindContentItem
Returns a content item specified by item ID
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Read
Reads attributes from the DataSet
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UpdateItemFactory
This function allows to update the Content Item Class Factory with new extended classes The classes instances created automatically during reading the content tree and by default it always creates known classes as follows: ContentItemType.TEXT MCtextItem ContentItemType.NUM MCnumItem ContentItemType.CODE MCcodeItem ContentItemType.DATE MCdateItem ContentItemType.TIME MCtimeItem ContentItemType.DATETIME MCdateTimeItem ContentItemType.UIDREF MCuidReferenceItem ContentItemType.PNAME MCpersonNameItem ContentItemType.COMPOSITE MCcompositeItem ContentItemType.IMAGE MCimageItem ContentItemType.WAVEFORM MCwaveformItem ContentItemType.SCOORD MCspatialCoordinatesItem ContentItemType.SCOORD3D MCspatialCoordinates3DItem ContentItemType.TCOORD_DATE MCtemporalCoordDateTimeItem ContentItemType.TCOORD_TIME MCtemporalCoordTimeOffsetsItem ContentItemType.TCOORD_POSITION MCtemporalCoordPositionsItem ContentItemType.CONTAINER MCcontainerItem ContentItemType.TABLE MCtableItem Note: Factory map is local to the MCstructuredReport class instance and can be updated through this method. To make sure the default classes resuable, the new class type is defined to be the subclass of the default class type as shown in the tableabove. One special case is that there is no default specific class type for ContentItemType.UNKNOWN value type. By default MCillegalArgumentException will be thrown if it encounters any value type that is not defined by DICOM during the reading. However, the class type for the unkown value type can be specified here by the user to tolerate such kinds of illegal data instead of throwing an exception. Any class that is derived from MCcontentItem is acceptable for ContentItemType.UNKNOWN value type.
Public method Write
Saves attributes to DataSet

Properties

 | Name | Description
Protected property | FactoryMap | Returns a class factory map for the Content Items Map values can be overwritten to support reading data into derived classes
Public property | RootItem | The root Content Item is of type CONTAINER This root Content Item shall have a heading in the Concept Name Code Sequence (0040,A043) that conveys the title of the SR Document, i.e. the Document Title.

See Also

MCstructuredReport Class
Mergecom.Sr Namespace


MCstructuredReport Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Constructor
MCstructuredReport Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCstructuredReport()()()() | Default constructor
Public method | MCstructuredReport(String, MCcontainerItem..::..Continuity, MCbasicCodedEntry) | Creates a new instance of the structured report and initializes the root CONTAINER item

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


MCstructuredReport Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Constructor
MCstructuredReport Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstructuredReport()
Visual Basic
Public Sub New
Visual C++
public:
MCstructuredReport()

See Also

MCstructuredReport Class
MCstructuredReport Members
MCstructuredReport Overload
Mergecom.Sr Namespace


MCstructuredReport Constructor (String, MCcontainerItem.Continuity, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Constructor (String, MCcontainerItem..::..Continuity, MCbasicCodedEntry)
MCstructuredReport Class See Also Send Feedback
Creates a new instance of the structured report and initializes the root CONTAINER item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCstructuredReport(
    string templateId,
    MCcontainerItem..::..Continuity continuityOfContent,
    MCbasicCodedEntry documentTitle
)
Visual Basic
Public Sub New ( _
    templateId As String, _
    continuityOfContent As MCcontainerItem..::..Continuity, _
    documentTitle As MCbasicCodedEntry _
)
Visual C++
public:
MCstructuredReport(
    String^ templateId,
    MCcontainerItem..::..Continuity continuityOfContent,
    MCbasicCodedEntry^ documentTitle
)

Parameters

templateId
Type: System..::..String
The DICOM Template identifier (0040,DB00) is a string of digits, without leading zeroes, and does not include the string "TID".
continuityOfContent
Type: Mergecom.Sr..::..MCcontainerItem..::..Continuity
specifies whether or not all the Content Items contained in a CONTAINER are logically linked in a continuous textual flow, or are separate entities
documentTitle
Type: Mergecom..::..MCbasicCodedEntry
Document Title

See Also

MCstructuredReport Class
MCstructuredReport Members
MCstructuredReport Overload
Mergecom.Sr Namespace


MCstructuredReport Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Methods
MCstructuredReport Class See Also Send Feedback

The MCstructuredReport type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindContentItem
Returns a content item specified by item ID
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Read
Reads attributes from the DataSet
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UpdateItemFactory
This function allows to update the Content Item Class Factory with new extended classes The classes instances created automatically during reading the content tree and by default it always creates known classes as follows: ContentItemType.TEXT MCtextItem ContentItemType.NUM MCnumItem ContentItemType.CODE MCcodeItem ContentItemType.DATE MCdateItem ContentItemType.TIME MCtimeItem ContentItemType.DATETIME MCdateTimeItem ContentItemType.UIDREF MCuidReferenceItem ContentItemType.PNAME MCpersonNameItem ContentItemType.COMPOSITE MCcompositeItem ContentItemType.IMAGE MCimageItem ContentItemType.WAVEFORM MCwaveformItem ContentItemType.SCOORD MCspatialCoordinatesItem ContentItemType.SCOORD3D MCspatialCoordinates3DItem ContentItemType.TCOORD_DATE MCtemporalCoordDateTimeItem ContentItemType.TCOORD_TIME MCtemporalCoordTimeOffsetsItem ContentItemType.TCOORD_POSITION MCtemporalCoordPositionsItem ContentItemType.CONTAINER MCcontainerItem ContentItemType.TABLE MCtableItem Note: Factory map is local to the MCstructuredReport class instance and can be updated through this method. To make sure the default classes resuable, the new class type is defined to be the subclass of the default class type as shown in the tableabove. One special case is that there is no default specific class type for ContentItemType.UNKNOWN value type. By default MCillegalArgumentException will be thrown if it encounters any value type that is not defined by DICOM during the reading. However, the class type for the unkown value type can be specified here by the user to tolerate such kinds of illegal data instead of throwing an exception. Any class that is derived from MCcontentItem is acceptable for ContentItemType.UNKNOWN value type.
Public method Write
Saves attributes to DataSet

See Also

MCstructuredReport Class
Mergecom.Sr Namespace


FindContentItem Method

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..FindContentItem Method
MCstructuredReport Class See Also Send Feedback
Returns a content item specified by item ID

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontentItem FindContentItem(
    MCitemIdentifer itemId
)
Visual Basic
Public Function FindContentItem ( _
    itemId As MCitemIdentifer _
) As MCcontentItem
Visual C++
public:
MCcontentItem^ FindContentItem(
    MCitemIdentifer^ itemId
)

Parameters

itemId
Type: Mergecom.Sr..::..MCitemIdentifer
Item identifer

Return Value

Content item that matches the itemId or null if not found

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..Read Method
MCstructuredReport Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Read(
    MCattributeSet source
)
Visual Basic
Public Overridable Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
)

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | Will be thrown if the root content item (CONTAINER) is not found

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


UpdateItemFactory Method

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..UpdateItemFactory Method
MCstructuredReport Class See Also Send Feedback
This function allows to update the Content Item Class Factory with new extended classes The classes instances created automatically during reading the content tree and by default it always creates known classes as follows: ContentItemType.TEXT MCtextItem ContentItemType.NUM MCnumItem ContentItemType.CODE MCcodeItem ContentItemType.DATE MCdateItem ContentItemType.TIME MCtimeItem ContentItemType.DATETIME MCdateTimeItem ContentItemType.UIDREF MCuidReferenceItem ContentItemType.PNAME MCpersonNameItem ContentItemType.COMPOSITE MCcompositeItem ContentItemType.IMAGE MCimageItem ContentItemType.WAVEFORM MCwaveformItem ContentItemType.SCOORD MCspatialCoordinatesItem ContentItemType.SCOORD3D MCspatialCoordinates3DItem ContentItemType.TCOORD_DATE MCtemporalCoordDateTimeItem ContentItemType.TCOORD_TIME MCtemporalCoordTimeOffsetsItem ContentItemType.TCOORD_POSITION MCtemporalCoordPositionsItem ContentItemType.CONTAINER MCcontainerItem ContentItemType.TABLE MCtableItem Note: Factory map is local to the MCstructuredReport class instance and can be updated through this method. To make sure the default classes resuable, the new class type is defined to be the subclass of the default class type as shown in the tableabove. One special case is that there is no default specific class type for ContentItemType.UNKNOWN value type. By default MCillegalArgumentException will be thrown if it encounters any value type that is not defined by DICOM during the reading. However, the class type for the unkown value type can be specified here by the user to tolerate such kinds of illegal data instead of throwing an exception. Any class that is derived from MCcontentItem is acceptable for ContentItemType.UNKNOWN value type.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void UpdateItemFactory(
    ContentItemType itemType,
    Type classType
)
Visual Basic
Public Sub UpdateItemFactory ( _
    itemType As ContentItemType, _
    classType As Type _
)
Visual C++
public:
void UpdateItemFactory(
    ContentItemType itemType,
    Type^ classType
)

Parameters

itemType
Type: Mergecom.Sr..::..ContentItemType
Content Item type to be updated
classType
Type: System..::..Type
New class type to be used for that content. It shall be derived from the default class for that type

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCillegalArgumentException | Will be thrown if the new class is not derived from the original class used for that type

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..Write Method
MCstructuredReport Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public virtual void Write(
    MCattributeSet destination
)
Visual Basic
Public Overridable Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
)

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

Exceptions

Exception | Condition
Mergecom.Exceptions..::..MCoperationNotAllowedException | Will be thrown if the root item is not initialized

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


MCstructuredReport Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport Properties
MCstructuredReport Class See Also Send Feedback

The MCstructuredReport type exposes the following members.

Properties

 | Name | Description
Protected property | FactoryMap | Returns a class factory map for the Content Items Map values can be overwritten to support reading data into derived classes
Public property | RootItem | The root Content Item is of type CONTAINER This root Content Item shall have a heading in the Concept Name Code Sequence (0040,A043) that conveys the title of the SR Document, i.e. the Document Title.

See Also

MCstructuredReport Class
Mergecom.Sr Namespace


FactoryMap Property

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..FactoryMap Property
MCstructuredReport Class See Also Send Feedback
Returns a class factory map for the Content Items Map values can be overwritten to support reading data into derived classes

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
protected Dictionary<ContentItemType, Type> FactoryMap { get; }
Visual Basic
Protected ReadOnly Property FactoryMap As Dictionary(Of ContentItemType, Type)
    Get
Visual C++
protected:
property Dictionary<ContentItemType, Type^>^ FactoryMap {
    Dictionary<ContentItemType, Type^>^ get ();
}

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


RootItem Property

[image]

Merge DICOM .NET/C# Toolkit
MCstructuredReport..::..RootItem Property
MCstructuredReport Class See Also Send Feedback
The root Content Item is of type CONTAINER This root Content Item shall have a heading in the Concept Name Code Sequence (0040,A043) that conveys the title of the SR Document, i.e. the Document Title.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCcontainerItem RootItem { get; set; }
Visual Basic
Public Property RootItem As MCcontainerItem
    Get
    Set
Visual C++
public:
property MCcontainerItem^ RootItem {
    MCcontainerItem^ get ();
    void set (MCcontainerItem^ value);
}

See Also

MCstructuredReport Class
MCstructuredReport Members
Mergecom.Sr Namespace


MCtableCellValues Class

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Class
Members See Also Send Feedback
The values of each populated cell in the table, identified by row and column.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtableCellValues : MCdataSetSerializable
Visual Basic
Public Class MCtableCellValues _
    Implements MCdataSetSerializable
Visual C++
public ref class MCtableCellValues : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCtableCellValues

See Also

MCtableCellValues Members
Mergecom.Sr Namespace


MCtableCellValues Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Members
MCtableCellValues Class Constructors Methods Properties See Also Send Feedback

The MCtableCellValues type exposes the following members.

Constructors

 | Name | Description
Public method | MCtableCellValues()()()() | Default constructor
Public method | MCtableCellValues(Int32, Int32, List<(Of <<'(Int32>)>>), UInt32, List<(Of <<'(Object>)>>), MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of MCtableCellValues. Represents an item of the Cell Values Sequence (0040,A808) attribute

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this cell values instance from an attribute set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write all the attributes in this cell values instance to an attribute set

Properties

 | Name | Description
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this cell.
Public property | NumericValueQualifierCode | The reason for the absence of the numeric value.
Public property | ReferencedContentItemIds | An ordered set of one or more integers that uniquely identifies the Content Item that is the value for this cell.
Public property | SelectorAttributeTag | Selector attribute tag.
Public property | SelectorAttributeValues | Numeric/DateTime/text/coded value(s) of the cell(s) in this Item
Public property | TableColumnNumber | The column, numbered from 1, of the table.
Public property | TableRowNumber | The row, numbered from 1, of the table.

See Also

MCtableCellValues Class
Mergecom.Sr Namespace


MCtableCellValues Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Constructor
MCtableCellValues Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtableCellValues()()()() | Default constructor
Public method | MCtableCellValues(Int32, Int32, List<(Of <<'(Int32>)>>), UInt32, List<(Of <<'(Object>)>>), MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of MCtableCellValues. Represents an item of the Cell Values Sequence (0040,A808) attribute

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


MCtableCellValues Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Constructor
MCtableCellValues Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableCellValues()
Visual Basic
Public Sub New
Visual C++
public:
MCtableCellValues()

See Also

MCtableCellValues Class
MCtableCellValues Members
MCtableCellValues Overload
Mergecom.Sr Namespace


MCtableCellValues Constructor (Int32, Int32, List(Int32), UInt32, List(Object), MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Constructor (Int32, Int32, List<(Of <(<'Int32>)>)>, UInt32, List<(Of <(<'Object>)>)>, MCbasicCodedEntry, MCbasicCodedEntry)
MCtableCellValues Class See Also Send Feedback
Create a new instance of MCtableCellValues. Represents an item of the Cell Values Sequence (0040,A808) attribute

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableCellValues(
    int tableRow,
    int tableColumn,
    List<int> refContentItemIds,
    uint selectorAttrTag,
    List<Object> selectorAttrValues,
    MCbasicCodedEntry measurementUnits,
    MCbasicCodedEntry numericValueQualifier
)
Visual Basic
Public Sub New ( _
    tableRow As Integer, _
    tableColumn As Integer, _
    refContentItemIds As List(Of Integer), _
    selectorAttrTag As UInteger, _
    selectorAttrValues As List(Of Object), _
    measurementUnits As MCbasicCodedEntry, _
    numericValueQualifier As MCbasicCodedEntry _
)
Visual C++
public:
MCtableCellValues(
    int tableRow,
    int tableColumn,
    List<int>^ refContentItemIds,
    unsigned int selectorAttrTag,
    List<Object^>^ selectorAttrValues,
    MCbasicCodedEntry^ measurementUnits,
    MCbasicCodedEntry^ numericValueQualifier
)

Parameters

tableRow
Type: System..::..Int32
The row, numbered from 1, of the table.
tableColumn
Type: System..::..Int32
The column, numbered from 1, of the table.
refContentItemIds
Type: System.Collections.Generic..::..List<(Of <(<'Int32>)>)>
An ordered set of one or more integers that uniquely identifies the Content Item that is the value for this cell.
selectorAttrTag
Type: System..::..UInt32
Tag of the attribute containing the value(s) of the cell(s) in this Item.
selectorAttrValues
Type: System.Collections.Generic..::..List<(Of <(<'Object>)>)>
The numeric/DateTime/text/coded value(s) of the cell(s) in this Item.
measurementUnits
Type: Mergecom..::..MCbasicCodedEntry
The units of measurement that apply to all the numeric value in this cell.
numericValueQualifier
Type: Mergecom..::..MCbasicCodedEntry
The reason for the absence of the numeric value.

See Also

MCtableCellValues Class
MCtableCellValues Members
MCtableCellValues Overload
Mergecom.Sr Namespace


MCtableCellValues Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Methods
MCtableCellValues Class See Also Send Feedback

The MCtableCellValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this cell values instance from an attribute set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write all the attributes in this cell values instance to an attribute set

See Also

MCtableCellValues Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..Read Method
MCtableCellValues Class See Also Send Feedback
Read all the attributes in this cell values instance from an attribute set.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Read(
    MCattributeSet source
)
Visual Basic
Public Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) sealed

Parameters

source
Type: Mergecom..::..MCattributeSet
The source attribute set

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..Write Method
MCtableCellValues Class See Also Send Feedback
Write all the attributes in this cell values instance to an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Write(
    MCattributeSet destination
)
Visual Basic
Public Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) sealed

Parameters

destination
Type: Mergecom..::..MCattributeSet
The destination attribute set

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


MCtableCellValues Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues Properties
MCtableCellValues Class See Also Send Feedback

The MCtableCellValues type exposes the following members.

Properties

 | Name | Description
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this cell.
Public property | NumericValueQualifierCode | The reason for the absence of the numeric value.
Public property | ReferencedContentItemIds | An ordered set of one or more integers that uniquely identifies the Content Item that is the value for this cell.
Public property | SelectorAttributeTag | Selector attribute tag.
Public property | SelectorAttributeValues | Numeric/DateTime/text/coded value(s) of the cell(s) in this Item
Public property | TableColumnNumber | The column, numbered from 1, of the table.
Public property | TableRowNumber | The row, numbered from 1, of the table.

See Also

MCtableCellValues Class
Mergecom.Sr Namespace


MeasurementUnitsCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..MeasurementUnitsCode Property
MCtableCellValues Class See Also Send Feedback
Units of measurement that apply to all the numeric values in this cell.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry MeasurementUnitsCode { get; set; }
Visual Basic
Public Property MeasurementUnitsCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ MeasurementUnitsCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

Remarks

Only a single Item shall be included in this Sequence.

Required if this cell is a numeric value (Selector Attribute VR is DS, FD, FL, IS, SL, SS, SV, UL, US or UV) has a unit (is not dimensionless), and the unit is not specified within the Table Row Definition Sequence for this row or Table Column Definition Sequence for this column.

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


NumericValueQualifierCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..NumericValueQualifierCode Property
MCtableCellValues Class See Also Send Feedback
The reason for the absence of the numeric value.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry NumericValueQualifierCode { get; set; }
Visual Basic
Public Property NumericValueQualifierCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ NumericValueQualifierCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

Remarks

Only a single Item is permitted in this Sequence.

Required if this cell is a numeric value (Selector Attribute VR is DS, FD, FL, IS, SL, SS, SV, UL, US or UV), and the numeric value cannot be provided.

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


ReferencedContentItemIds Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..ReferencedContentItemIds Property
MCtableCellValues Class See Also Send Feedback
An ordered set of one or more integers that uniquely identifies the Content Item that is the value for this cell.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<int> ReferencedContentItemIds { get; set; }
Visual Basic
Public Property ReferencedContentItemIds As List(Of Integer)
    Get
    Set
Visual C++
public:
property List<int>^ ReferencedContentItemIds {
    List<int>^ get ();
    void set (List<int>^ value);
}

Remarks

Required if Selector Attribute VR (0072,0050) is not present.

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


SelectorAttributeTag Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..SelectorAttributeTag Property
MCtableCellValues Class See Also Send Feedback
Selector attribute tag.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public uint SelectorAttributeTag { get; set; }
Visual Basic
Public Property SelectorAttributeTag As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SelectorAttributeTag {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


SelectorAttributeValues Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..SelectorAttributeValues Property
MCtableCellValues Class See Also Send Feedback
Numeric/DateTime/text/coded value(s) of the cell(s) in this Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<Object> SelectorAttributeValues { get; set; }
Visual Basic
Public Property SelectorAttributeValues As List(Of Object)
    Get
    Set
Visual C++
public:
property List<Object^>^ SelectorAttributeValues {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


TableColumnNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..TableColumnNumber Property
MCtableCellValues Class See Also Send Feedback
The column, numbered from 1, of the table.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int TableColumnNumber { get; set; }
Visual Basic
Public Property TableColumnNumber As Integer
    Get
    Set
Visual C++
public:
property int TableColumnNumber {
    int get ();
    void set (int value);
}

Remarks

Represents the Table Column Number (0040,A805) attribute. Required if Table Row Number is absent, or all the columns for the row specified in Table Row Number are not encoded in a single Attribute (containing multiple values) in this Item (i.e., with a single VR).

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


TableRowNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableCellValues..::..TableRowNumber Property
MCtableCellValues Class See Also Send Feedback
The row, numbered from 1, of the table.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int TableRowNumber { get; set; }
Visual Basic
Public Property TableRowNumber As Integer
    Get
    Set
Visual C++
public:
property int TableRowNumber {
    int get ();
    void set (int value);
}

Remarks

Represents the Table Row Number (0040,A804) attribute. Required if Table Column Number is absent, or all the rows for the column specified in Table Column Number are not encoded in a single Attribute (containing multiple values) in this Item (i.e., with a single VR).

See Also

MCtableCellValues Class
MCtableCellValues Members
Mergecom.Sr Namespace


MCtableColumnDefinition Class

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Class
Members See Also Send Feedback
Concepts that define the meaning of the columns of the table.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtableColumnDefinition : MCdataSetSerializable
Visual Basic
Public Class MCtableColumnDefinition _
    Implements MCdataSetSerializable
Visual C++
public ref class MCtableColumnDefinition : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCtableColumnDefinition

See Also

MCtableColumnDefinition Members
Mergecom.Sr Namespace


MCtableColumnDefinition Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Members
MCtableColumnDefinition Class Constructors Methods Properties See Also Send Feedback

The MCtableColumnDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | MCtableColumnDefinition()()()() | Default Constructor
Public method | MCtableColumnDefinition(Int32, MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of the table column definition sequence item

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this table column definition from an attribute set
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Save all the attributes in this table column definition to an attribute set

Properties

 | Name | Description
Public property | ColumnNumber | The column, numbered from 1, of the table that this concept describes.
Public property | ConceptNameCode | The concept that describes the meaning of the column(s).
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this column.

See Also

MCtableColumnDefinition Class
Mergecom.Sr Namespace


MCtableColumnDefinition Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Constructor
MCtableColumnDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtableColumnDefinition()()()() | Default Constructor
Public method | MCtableColumnDefinition(Int32, MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of the table column definition sequence item

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


MCtableColumnDefinition Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Constructor
MCtableColumnDefinition Class See Also Send Feedback
Default Constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableColumnDefinition()
Visual Basic
Public Sub New
Visual C++
public:
MCtableColumnDefinition()

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
MCtableColumnDefinition Overload
Mergecom.Sr Namespace


MCtableColumnDefinition Constructor (Int32, MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Constructor (Int32, MCbasicCodedEntry, MCbasicCodedEntry)
MCtableColumnDefinition Class See Also Send Feedback
Create a new instance of the table column definition sequence item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableColumnDefinition(
    int column,
    MCbasicCodedEntry conceptName,
    MCbasicCodedEntry measurementUnits
)
Visual Basic
Public Sub New ( _
    column As Integer, _
    conceptName As MCbasicCodedEntry, _
    measurementUnits As MCbasicCodedEntry _
)
Visual C++
public:
MCtableColumnDefinition(
    int column,
    MCbasicCodedEntry^ conceptName,
    MCbasicCodedEntry^ measurementUnits
)

Parameters

column
Type: System..::..Int32
The column, numbered from 1, of the table that this concept describes.
conceptName
Type: Mergecom..::..MCbasicCodedEntry
The concept that describes the meaning of the column(s).
measurementUnits
Type: Mergecom..::..MCbasicCodedEntry
Units of measurement that apply to all the numeric values in this column.

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
MCtableColumnDefinition Overload
Mergecom.Sr Namespace


MCtableColumnDefinition Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Methods
MCtableColumnDefinition Class See Also Send Feedback

The MCtableColumnDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this table column definition from an attribute set
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Save all the attributes in this table column definition to an attribute set

See Also

MCtableColumnDefinition Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition..::..Read Method
MCtableColumnDefinition Class See Also Send Feedback
Read all the attributes in this table column definition from an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Read(
    MCattributeSet source
)
Visual Basic
Public Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) sealed

Parameters

source
Type: Mergecom..::..MCattributeSet
The source attribute set

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition..::..Write Method
MCtableColumnDefinition Class See Also Send Feedback
Save all the attributes in this table column definition to an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Write(
    MCattributeSet destination
)
Visual Basic
Public Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) sealed

Parameters

destination
Type: Mergecom..::..MCattributeSet
The destination attribute set

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


MCtableColumnDefinition Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition Properties
MCtableColumnDefinition Class See Also Send Feedback

The MCtableColumnDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ColumnNumber | The column, numbered from 1, of the table that this concept describes.
Public property | ConceptNameCode | The concept that describes the meaning of the column(s).
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this column.

See Also

MCtableColumnDefinition Class
Mergecom.Sr Namespace


ColumnNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition..::..ColumnNumber Property
MCtableColumnDefinition Class See Also Send Feedback
The column, numbered from 1, of the table that this concept describes.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int ColumnNumber { get; set; }
Visual Basic
Public Property ColumnNumber As Integer
    Get
    Set
Visual C++
public:
property int ColumnNumber {
    int get ();
    void set (int value);
}

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


ConceptNameCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition..::..ConceptNameCode Property
MCtableColumnDefinition Class See Also Send Feedback
The concept that describes the meaning of the column(s).

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry ConceptNameCode { get; set; }
Visual Basic
Public Property ConceptNameCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ ConceptNameCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


MeasurementUnitsCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableColumnDefinition..::..MeasurementUnitsCode Property
MCtableColumnDefinition Class See Also Send Feedback
Units of measurement that apply to all the numeric values in this column.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry MeasurementUnitsCode { get; set; }
Visual Basic
Public Property MeasurementUnitsCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ MeasurementUnitsCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCtableColumnDefinition Class
MCtableColumnDefinition Members
Mergecom.Sr Namespace


MCtableItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem Class
Members See Also Send Feedback
Table that represents the value of the Content Item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtableItem : MCcontentItem
Visual Basic
Public Class MCtableItem _
    Inherits MCcontentItem
Visual C++
public ref class MCtableItem : public MCcontentItem

Remarks

Shall consist of a single Item whose Attributes convey the cell value(s), which represent rows and columns consisting of text, codes, integers, real numbers or DateTimes.

Only a single Item shall be included in this Sequence.

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtableItem

See Also

MCtableItem Members
Mergecom.Sr Namespace


MCtableItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableItem Members
MCtableItem Class Constructors Methods Properties See Also Send Feedback

The MCtableItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtableItem()()()() | Default constructor
Public method | MCtableItem(Int32, Int32, List<(Of <<'(MCtableRowDefinition>)>>), List<(Of <<'(MCtableColumnDefinition>)>>), List<(Of <<'(MCtableCellValues>)>>), MCbasicCodedEntry) | Create a new instance of the TABLE Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read the TABLE content item from an attribute set (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write the TABLE content item to an attribute set (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | TableCellValues | List of the values of each populated cell in the table, identified by row and column. Represents the Cell Values Sequence (0040,A808) attribute.
Public property | TableColumnDefinitions | List of the concepts that define the meaning of the columns of the table. Represents the value of the Table Column Definition Sequence (0040,A807) attribute.
Public property | TableColumns | The number of columns in this table. Represents the value of the Number of Table Columns (0040,A803) attribute.
Public property | TableRowDefinitions | List of the concepts that define the meaning of the rows of the table. Represents the value of the Table Row Definition Sequence (0040,A806) attribute.
Public property | TableRows | The number of rows in this table. Represents the value of the Number of Table Rows (0040,A802) attribute.

See Also

MCtableItem Class
Mergecom.Sr Namespace


MCtableItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableItem Constructor
MCtableItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtableItem()()()() | Default constructor
Public method | MCtableItem(Int32, Int32, List<(Of <<'(MCtableRowDefinition>)>>), List<(Of <<'(MCtableColumnDefinition>)>>), List<(Of <<'(MCtableCellValues>)>>), MCbasicCodedEntry) | Create a new instance of the TABLE Content Item

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


MCtableItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem Constructor
MCtableItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtableItem()

See Also

MCtableItem Class
MCtableItem Members
MCtableItem Overload
Mergecom.Sr Namespace


MCtableItem Constructor (Int32, Int32, List(MCtableRowDefinition), List(MCtableColumnDefinition), List(MCtableCellValues), MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem Constructor (Int32, Int32, List<(Of <(<'MCtableRowDefinition>)>)>, List<(Of <(<'MCtableColumnDefinition>)>)>, List<(Of <(<'MCtableCellValues>)>)>, MCbasicCodedEntry)
MCtableItem Class See Also Send Feedback
Create a new instance of the TABLE Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableItem(
    int rows,
    int columns,
    List<MCtableRowDefinition> rowDefs,
    List<MCtableColumnDefinition> columnDefs,
    List<MCtableCellValues> cellValues,
    MCbasicCodedEntry conceptName = null
)
Visual Basic
Public Sub New ( _
    rows As Integer, _
    columns As Integer, _
    rowDefs As List(Of MCtableRowDefinition), _
    columnDefs As List(Of MCtableColumnDefinition), _
    cellValues As List(Of MCtableCellValues), _
    Optional conceptName As MCbasicCodedEntry = Nothing _
)
Visual C++
public:
MCtableItem(
    int rows,
    int columns,
    List<MCtableRowDefinition^>^ rowDefs,
    List<MCtableColumnDefinition^>^ columnDefs,
    List<MCtableCellValues^>^ cellValues,
    MCbasicCodedEntry^ conceptName = nullptr
)

Parameters

rows
Type: System..::..Int32
The number of rows in this table
columns
Type: System..::..Int32
The number of columns in this table
rowDefs
Type: System.Collections.Generic..::..List<(Of <(<' MCtableRowDefinition >)>)>
The concepts that define the meaning of the rows of the table.
columnDefs
Type: System.Collections.Generic..::..List<(Of <(<' MCtableColumnDefinition >)>)>
The concepts that define the meaning of the columns of the table.
cellValues
Type: System.Collections.Generic..::..List<(Of <(<' MCtableCellValues >)>)>
The values of each populated cell in the table, identified by row and column.
conceptName (Optional)
Type: Mergecom..::..MCbasicCodedEntry
Code describing the concept represented by this Content Item.

See Also

MCtableItem Class
MCtableItem Members
MCtableItem Overload
Mergecom.Sr Namespace


MCtableItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableItem Methods
MCtableItem Class See Also Send Feedback

The MCtableItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read the TABLE content item from an attribute set (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Write the TABLE content item to an attribute set (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCtableItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..Read Method
MCtableItem Class See Also Send Feedback
Read the TABLE content item from an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
The source attribute set

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..Write Method
MCtableItem Class See Also Send Feedback
Write the TABLE content item to an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
The destination attribute set

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


MCtableItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableItem Properties
MCtableItem Class See Also Send Feedback

The MCtableItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | TableCellValues | List of the values of each populated cell in the table, identified by row and column. Represents the Cell Values Sequence (0040,A808) attribute.
Public property | TableColumnDefinitions | List of the concepts that define the meaning of the columns of the table. Represents the value of the Table Column Definition Sequence (0040,A807) attribute.
Public property | TableColumns | The number of columns in this table. Represents the value of the Number of Table Columns (0040,A803) attribute.
Public property | TableRowDefinitions | List of the concepts that define the meaning of the rows of the table. Represents the value of the Table Row Definition Sequence (0040,A806) attribute.
Public property | TableRows | The number of rows in this table. Represents the value of the Number of Table Rows (0040,A802) attribute.

See Also

MCtableItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..ContentItemType Property
MCtableItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


TableCellValues Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..TableCellValues Property
MCtableItem Class See Also Send Feedback
List of the values of each populated cell in the table, identified by row and column. Represents the Cell Values Sequence (0040,A808) attribute.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCtableCellValues> TableCellValues { get; set; }
Visual Basic
Public Property TableCellValues As List(Of MCtableCellValues)
    Get
    Set
Visual C++
public:
property List<MCtableCellValues^>^ TableCellValues {
    List<MCtableCellValues^>^ get ();
    void set (List<MCtableCellValues^>^ value);
}

Remarks

One or more Items shall be included in this Sequence.

The table may be sparse (i.e., not every cell is required to be populated).

Entire rows may be specified in a single Item if all the columns have the same VR.

Entire columns may be specified in a single Item if all the rows have the same VR.

Items of this Sequence shall be in row-major order, then sorted by column.

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


TableColumnDefinitions Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..TableColumnDefinitions Property
MCtableItem Class See Also Send Feedback
List of the concepts that define the meaning of the columns of the table. Represents the value of the Table Column Definition Sequence (0040,A807) attribute.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCtableColumnDefinition> TableColumnDefinitions { get; set; }
Visual Basic
Public Property TableColumnDefinitions As List(Of MCtableColumnDefinition)
    Get
    Set
Visual C++
public:
property List<MCtableColumnDefinition^>^ TableColumnDefinitions {
    List<MCtableColumnDefinition^>^ get ();
    void set (List<MCtableColumnDefinition^>^ value);
}

Remarks

One or more Items are permitted in this Sequence.

If a single Item is present, then the concept applies to all the columns.

Not all columns need to be described.

Items of this Sequence shall be sorted by Table Column Number.

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


TableColumns Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..TableColumns Property
MCtableItem Class See Also Send Feedback
The number of columns in this table. Represents the value of the Number of Table Columns (0040,A803) attribute.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int TableColumns { get; set; }
Visual Basic
Public Property TableColumns As Integer
    Get
    Set
Visual C++
public:
property int TableColumns {
    int get ();
    void set (int value);
}

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


TableRowDefinitions Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..TableRowDefinitions Property
MCtableItem Class See Also Send Feedback
List of the concepts that define the meaning of the rows of the table. Represents the value of the Table Row Definition Sequence (0040,A806) attribute.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCtableRowDefinition> TableRowDefinitions { get; set; }
Visual Basic
Public Property TableRowDefinitions As List(Of MCtableRowDefinition)
    Get
    Set
Visual C++
public:
property List<MCtableRowDefinition^>^ TableRowDefinitions {
    List<MCtableRowDefinition^>^ get ();
    void set (List<MCtableRowDefinition^>^ value);
}

Remarks

One or more Items are permitted in this Sequence.

If a single Item is present, then the concept applies to all the rows.

Not all rows need to be described.

Items of this Sequence shall be sorted by Table Row Number.

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


TableRows Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableItem..::..TableRows Property
MCtableItem Class See Also Send Feedback
The number of rows in this table. Represents the value of the Number of Table Rows (0040,A802) attribute.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int TableRows { get; set; }
Visual Basic
Public Property TableRows As Integer
    Get
    Set
Visual C++
public:
property int TableRows {
    int get ();
    void set (int value);
}

See Also

MCtableItem Class
MCtableItem Members
Mergecom.Sr Namespace


MCtableRowDefinition Class

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Class
Members See Also Send Feedback
Concepts that defines the meaning of the rows of the table.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtableRowDefinition : MCdataSetSerializable
Visual Basic
Public Class MCtableRowDefinition _
    Implements MCdataSetSerializable
Visual C++
public ref class MCtableRowDefinition : MCdataSetSerializable

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCtableRowDefinition

See Also

MCtableRowDefinition Members
Mergecom.Sr Namespace


MCtableRowDefinition Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Members
MCtableRowDefinition Class Constructors Methods Properties See Also Send Feedback

The MCtableRowDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | MCtableRowDefinition()()()() | Default Constructor
Public method | MCtableRowDefinition(Int32, MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of the table row definition sequence item

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this table row definition from an attribute set
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

Properties

 | Name | Description
Public property | ConceptNameCode | The concept that describes the meaning of the row(s).
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this row.
Public property | RowNumber | The row, numbered from 1, of the table that this concept describes.

See Also

MCtableRowDefinition Class
Mergecom.Sr Namespace


MCtableRowDefinition Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Constructor
MCtableRowDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtableRowDefinition()()()() | Default Constructor
Public method | MCtableRowDefinition(Int32, MCbasicCodedEntry, MCbasicCodedEntry) | Create a new instance of the table row definition sequence item

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


MCtableRowDefinition Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Constructor
MCtableRowDefinition Class See Also Send Feedback
Default Constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableRowDefinition()
Visual Basic
Public Sub New
Visual C++
public:
MCtableRowDefinition()

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
MCtableRowDefinition Overload
Mergecom.Sr Namespace


MCtableRowDefinition Constructor (Int32, MCbasicCodedEntry, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Constructor (Int32, MCbasicCodedEntry, MCbasicCodedEntry)
MCtableRowDefinition Class See Also Send Feedback
Create a new instance of the table row definition sequence item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtableRowDefinition(
    int row,
    MCbasicCodedEntry conceptName,
    MCbasicCodedEntry measurementUnits
)
Visual Basic
Public Sub New ( _
    row As Integer, _
    conceptName As MCbasicCodedEntry, _
    measurementUnits As MCbasicCodedEntry _
)
Visual C++
public:
MCtableRowDefinition(
    int row,
    MCbasicCodedEntry^ conceptName,
    MCbasicCodedEntry^ measurementUnits
)

Parameters

row
Type: System..::..Int32
The row, numbered from 1, of the table that this concept describes.
conceptName
Type: Mergecom..::..MCbasicCodedEntry
The concept that describes the meaning of the row(s).
measurementUnits
Type: Mergecom..::..MCbasicCodedEntry
Units of measurement that apply to all the numeric values in this row.

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
MCtableRowDefinition Overload
Mergecom.Sr Namespace


MCtableRowDefinition Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Methods
MCtableRowDefinition Class See Also Send Feedback

The MCtableRowDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Read all the attributes in this table row definition from an attribute set
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet

See Also

MCtableRowDefinition Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition..::..Read Method
MCtableRowDefinition Class See Also Send Feedback
Read all the attributes in this table row definition from an attribute set

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Read(
    MCattributeSet source
)
Visual Basic
Public Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) sealed

Parameters

source
Type: Mergecom..::..MCattributeSet
The source attribute set

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition..::..Write Method
MCtableRowDefinition Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public void Write(
    MCattributeSet destination
)
Visual Basic
Public Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) sealed

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


MCtableRowDefinition Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition Properties
MCtableRowDefinition Class See Also Send Feedback

The MCtableRowDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ConceptNameCode | The concept that describes the meaning of the row(s).
Public property | MeasurementUnitsCode | Units of measurement that apply to all the numeric values in this row.
Public property | RowNumber | The row, numbered from 1, of the table that this concept describes.

See Also

MCtableRowDefinition Class
Mergecom.Sr Namespace


ConceptNameCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition..::..ConceptNameCode Property
MCtableRowDefinition Class See Also Send Feedback
The concept that describes the meaning of the row(s).

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry ConceptNameCode { get; set; }
Visual Basic
Public Property ConceptNameCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ ConceptNameCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


MeasurementUnitsCode Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition..::..MeasurementUnitsCode Property
MCtableRowDefinition Class See Also Send Feedback
Units of measurement that apply to all the numeric values in this row.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCbasicCodedEntry MeasurementUnitsCode { get; set; }
Visual Basic
Public Property MeasurementUnitsCode As MCbasicCodedEntry
    Get
    Set
Visual C++
public:
property MCbasicCodedEntry^ MeasurementUnitsCode {
    MCbasicCodedEntry^ get ();
    void set (MCbasicCodedEntry^ value);
}

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


RowNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCtableRowDefinition..::..RowNumber Property
MCtableRowDefinition Class See Also Send Feedback
The row, numbered from 1, of the table that this concept describes.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public int RowNumber { get; set; }
Visual Basic
Public Property RowNumber As Integer
    Get
    Set
Visual C++
public:
property int RowNumber {
    int get ();
    void set (int value);
}

See Also

MCtableRowDefinition Class
MCtableRowDefinition Members
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Class
Members See Also Send Feedback
Represents a DICOM TCOORD content item specifying temporal points for reference by absolute time.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtemporalCoordDateTimeItem : MCtemporalCoordinatesItem
Visual Basic
Public Class MCtemporalCoordDateTimeItem _
    Inherits MCtemporalCoordinatesItem
Visual C++
public ref class MCtemporalCoordDateTimeItem : public MCtemporalCoordinatesItem

Remarks

This type of content item has the Referenced DateTime attribute (0040, A13A) present.

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtemporalCoordinatesItem
Mergecom.Sr..::..MCtemporalCoordDateTimeItem

See Also

MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Members
MCtemporalCoordDateTimeItem Class Constructors Methods Properties See Also Send Feedback

The MCtemporalCoordDateTimeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtemporalCoordDateTimeItem()()()() | Default constructor
Public method | MCtemporalCoordDateTimeItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(MCdateTime>)>>)) | Creates a new instance of the TCOORD Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedDateTime | Specifies temporal points for reference by absolute time.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordDateTimeItem Class
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Constructor
MCtemporalCoordDateTimeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtemporalCoordDateTimeItem()()()() | Default constructor
Public method | MCtemporalCoordDateTimeItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(MCdateTime>)>>)) | Creates a new instance of the TCOORD Content Item

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Constructor
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordDateTimeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtemporalCoordDateTimeItem()

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
MCtemporalCoordDateTimeItem Overload
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Constructor (MCtemporalCoordinatesItem.RangeTypes, List(MCdateTime))

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Constructor (MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <(<'MCdateTime>)>)>)
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Creates a new instance of the TCOORD Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordDateTimeItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<MCdateTime> referencedDateTime
)
Visual Basic
Public Sub New ( _
    rangeType As MCtemporalCoordinatesItem..::..RangeTypes, _
    referencedDateTime As List(Of MCdateTime) _
)
Visual C++
public:
MCtemporalCoordDateTimeItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<MCdateTime^>^ referencedDateTime
)

Parameters

rangeType
Type: Mergecom.Sr..::..MCtemporalCoordinatesItem..::..RangeTypes
type of temporal extent of the region of interest
referencedDateTime
Type: System.Collections.Generic..::..List<(Of <(<' MCdateTime >)>)>
Specifies temporal points for reference by absolute time.

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
MCtemporalCoordDateTimeItem Overload
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Methods
MCtemporalCoordDateTimeItem Class See Also Send Feedback

The MCtemporalCoordDateTimeItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

See Also

MCtemporalCoordDateTimeItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem..::..Read Method
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem..::..Write Method
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


MCtemporalCoordDateTimeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem Properties
MCtemporalCoordDateTimeItem Class See Also Send Feedback

The MCtemporalCoordDateTimeItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedDateTime | Specifies temporal points for reference by absolute time.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordDateTimeItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem..::..ContentItemType Property
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


ReferencedDateTime Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordDateTimeItem..::..ReferencedDateTime Property
MCtemporalCoordDateTimeItem Class See Also Send Feedback
Specifies temporal points for reference by absolute time.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCdateTime> ReferencedDateTime { get; set; }
Visual Basic
Public Property ReferencedDateTime As List(Of MCdateTime)
    Get
    Set
Visual C++
public:
property List<MCdateTime^>^ ReferencedDateTime {
    List<MCdateTime^>^ get ();
    void set (List<MCdateTime^>^ value);
}

See Also

MCtemporalCoordDateTimeItem Class
MCtemporalCoordDateTimeItem Members
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Class
Members See Also Send Feedback
A base class for the Temporal Coordinates (i.e. time or eventbased coordinates) of a region of interest in the DICOM waveform coordinate system. The WAVEFORM or IMAGE or SCOORD Content Item from which Temporal Coordinates are selected is denoted by a SELECTED FROM relationship.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public abstract class MCtemporalCoordinatesItem : MCcontentItem
Visual Basic
Public MustInherit Class MCtemporalCoordinatesItem _
    Inherits MCcontentItem
Visual C++
public ref class MCtemporalCoordinatesItem abstract : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtemporalCoordinatesItem
Mergecom.Sr..::..MCtemporalCoordDateTimeItem
Mergecom.Sr..::..MCtemporalCoordPositionsItem
Mergecom.Sr..::..MCtemporalCoordTimeOffsetsItem

See Also

MCtemporalCoordinatesItem Members
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Members
MCtemporalCoordinatesItem Class Constructors Methods Properties See Also Send Feedback

The MCtemporalCoordinatesItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtemporalCoordinatesItem()()()() | Default constructor
Public method | MCtemporalCoordinatesItem(MCtemporalCoordinatesItem..::..RangeTypes) | Creates a new instance of the TCOORD Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the value type. Must be overwritten in the derived class (Inherited from MCcontentItem.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordinatesItem Class
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Constructor
MCtemporalCoordinatesItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtemporalCoordinatesItem()()()() | Default constructor
Public method | MCtemporalCoordinatesItem(MCtemporalCoordinatesItem..::..RangeTypes) | Creates a new instance of the TCOORD Content Item

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Constructor
MCtemporalCoordinatesItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordinatesItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtemporalCoordinatesItem()

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
MCtemporalCoordinatesItem Overload
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Constructor (MCtemporalCoordinatesItem.RangeTypes)

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Constructor (MCtemporalCoordinatesItem..::..RangeTypes)
MCtemporalCoordinatesItem Class See Also Send Feedback
Creates a new instance of the TCOORD Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordinatesItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType
)
Visual Basic
Public Sub New ( _
    rangeType As MCtemporalCoordinatesItem..::..RangeTypes _
)
Visual C++
public:
MCtemporalCoordinatesItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType
)

Parameters

rangeType
Type: Mergecom.Sr..::..MCtemporalCoordinatesItem..::..RangeTypes
type of temporal extent of the region of interest

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
MCtemporalCoordinatesItem Overload
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Methods
MCtemporalCoordinatesItem Class See Also Send Feedback

The MCtemporalCoordinatesItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCtemporalCoordinatesItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem..::..Read Method
MCtemporalCoordinatesItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem..::..Write Method
MCtemporalCoordinatesItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
Mergecom.Sr Namespace


MCtemporalCoordinatesItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem Properties
MCtemporalCoordinatesItem Class See Also Send Feedback

The MCtemporalCoordinatesItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the value type. Must be overwritten in the derived class (Inherited from MCcontentItem.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordinatesItem Class
Mergecom.Sr Namespace


RangeType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem..::..RangeType Property
MCtemporalCoordinatesItem Class See Also Send Feedback
This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordinatesItem..::..RangeTypes RangeType { get; set; }
Visual Basic
Public Property RangeType As MCtemporalCoordinatesItem..::..RangeTypes
    Get
    Set
Visual C++
public:
property MCtemporalCoordinatesItem..::..RangeTypes RangeType {
    MCtemporalCoordinatesItem..::..RangeTypes get ();
    void set (MCtemporalCoordinatesItem..::..RangeTypes value);
}

See Also

MCtemporalCoordinatesItem Class
MCtemporalCoordinatesItem Members
Mergecom.Sr Namespace


MCtemporalCoordinatesItem.RangeTypes Enumeration

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordinatesItem..::..RangeTypes Enumeration
MCtemporalCoordinatesItem Class See Also Send Feedback
This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public enum RangeTypes
Visual Basic
Public Enumeration RangeTypes
Visual C++
public enum class RangeTypes

Members

Member name | Value | Description
POINT | 0 | a single temporal point
MULTIPOINT | 1 | multiple temporal points
SEGMENT | 2 | a range between two temporal points
MULTISEGMENT | 3 | multiple segments, each denoted by two temporal points
BEGIN | 4 | a range beginning at one temporal point, and extending beyond the end of the acquired data
END | 5 | a range beginning before the start of the acquired data, and extending to (and including) the identified temporal point
UNKNOWN | 6 | an unknown illegal value

See Also

Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Class
Members See Also Send Feedback
Represents a DICOM TCOORD content item specifying temporal points for reference by waveform sample offsets.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtemporalCoordPositionsItem : MCtemporalCoordinatesItem
Visual Basic
Public Class MCtemporalCoordPositionsItem _
    Inherits MCtemporalCoordinatesItem
Visual C++
public ref class MCtemporalCoordPositionsItem : public MCtemporalCoordinatesItem

Remarks

This type of content item has the Referenced Sample Positions attribute (0040, A132) present.

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtemporalCoordinatesItem
Mergecom.Sr..::..MCtemporalCoordPositionsItem

See Also

MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Members
MCtemporalCoordPositionsItem Class Constructors Methods Properties See Also Send Feedback

The MCtemporalCoordPositionsItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtemporalCoordPositionsItem()()()() | Default constructor
Public method | MCtemporalCoordPositionsItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(UInt32>)>>)) | Creates a new instance of the TCOORD Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedSamplePositions | List of samples within a multiplex group specifying temporal points of the referenced data. Position of first sample is 1. Required if the Referenced SOP Instance is a Waveform May be used only if Referenced Channels (0040,A0B0) refers to channels within a single multiplex group
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordPositionsItem Class
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Constructor
MCtemporalCoordPositionsItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtemporalCoordPositionsItem()()()() | Default constructor
Public method | MCtemporalCoordPositionsItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(UInt32>)>>)) | Creates a new instance of the TCOORD Content Item

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Constructor
MCtemporalCoordPositionsItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordPositionsItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtemporalCoordPositionsItem()

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
MCtemporalCoordPositionsItem Overload
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Constructor (MCtemporalCoordinatesItem.RangeTypes, List(UInt32))

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Constructor (MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <(<'UInt32>)>)>)
MCtemporalCoordPositionsItem Class See Also Send Feedback
Creates a new instance of the TCOORD Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordPositionsItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<uint> referencedSamplePositions
)
Visual Basic
Public Sub New ( _
    rangeType As MCtemporalCoordinatesItem..::..RangeTypes, _
    referencedSamplePositions As List(Of UInteger) _
)
Visual C++
public:
MCtemporalCoordPositionsItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<unsigned int>^ referencedSamplePositions
)

Parameters

rangeType
Type: Mergecom.Sr..::..MCtemporalCoordinatesItem..::..RangeTypes
type of temporal extent of the region of interest
referencedSamplePositions
Type: System.Collections.Generic..::..List<(Of <(<'UInt32>)>)>
List of samples within a multiplex group specifying temporal points of the referenced data.

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
MCtemporalCoordPositionsItem Overload
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Methods
MCtemporalCoordPositionsItem Class See Also Send Feedback

The MCtemporalCoordPositionsItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

See Also

MCtemporalCoordPositionsItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem..::..Read Method
MCtemporalCoordPositionsItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem..::..Write Method
MCtemporalCoordPositionsItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


MCtemporalCoordPositionsItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem Properties
MCtemporalCoordPositionsItem Class See Also Send Feedback

The MCtemporalCoordPositionsItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedSamplePositions | List of samples within a multiplex group specifying temporal points of the referenced data. Position of first sample is 1. Required if the Referenced SOP Instance is a Waveform May be used only if Referenced Channels (0040,A0B0) refers to channels within a single multiplex group
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordPositionsItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem..::..ContentItemType Property
MCtemporalCoordPositionsItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


ReferencedSamplePositions Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordPositionsItem..::..ReferencedSamplePositions Property
MCtemporalCoordPositionsItem Class See Also Send Feedback
List of samples within a multiplex group specifying temporal points of the referenced data. Position of first sample is 1. Required if the Referenced SOP Instance is a Waveform May be used only if Referenced Channels (0040,A0B0) refers to channels within a single multiplex group

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<uint> ReferencedSamplePositions { get; set; }
Visual Basic
Public Property ReferencedSamplePositions As List(Of UInteger)
    Get
    Set
Visual C++
public:
property List<unsigned int>^ ReferencedSamplePositions {
    List<unsigned int>^ get ();
    void set (List<unsigned int>^ value);
}

See Also

MCtemporalCoordPositionsItem Class
MCtemporalCoordPositionsItem Members
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Class
Members See Also Send Feedback
Represents a DICOM TCOORD content item specifying temporal points for reference by number of seconds after start of data.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtemporalCoordTimeOffsetsItem : MCtemporalCoordinatesItem
Visual Basic
Public Class MCtemporalCoordTimeOffsetsItem _
    Inherits MCtemporalCoordinatesItem
Visual C++
public ref class MCtemporalCoordTimeOffsetsItem : public MCtemporalCoordinatesItem

Remarks

This type of content item has the Referenced Time Offsets attribute (0040, A138) present.

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtemporalCoordinatesItem
Mergecom.Sr..::..MCtemporalCoordTimeOffsetsItem

See Also

MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Members
MCtemporalCoordTimeOffsetsItem Class Constructors Methods Properties See Also Send Feedback

The MCtemporalCoordTimeOffsetsItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtemporalCoordTimeOffsetsItem()()()() | Default constructor
Public method | MCtemporalCoordTimeOffsetsItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(Double>)>>)) | Creates a new instance of the TCOORD Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedTimeOffsets | Specifies temporal points for reference by number of seconds after start of data.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordTimeOffsetsItem Class
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Constructor
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtemporalCoordTimeOffsetsItem()()()() | Default constructor
Public method | MCtemporalCoordTimeOffsetsItem(MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <<'(Double>)>>)) | Creates a new instance of the TCOORD Content Item

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Constructor
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordTimeOffsetsItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtemporalCoordTimeOffsetsItem()

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
MCtemporalCoordTimeOffsetsItem Overload
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Constructor (MCtemporalCoordinatesItem.RangeTypes, List(Double))

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Constructor (MCtemporalCoordinatesItem..::..RangeTypes, List<(Of <(<'Double>)>)>)
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Creates a new instance of the TCOORD Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtemporalCoordTimeOffsetsItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<double> referencedTimeOffsets
)
Visual Basic
Public Sub New ( _
    rangeType As MCtemporalCoordinatesItem..::..RangeTypes, _
    referencedTimeOffsets As List(Of Double) _
)
Visual C++
public:
MCtemporalCoordTimeOffsetsItem(
    MCtemporalCoordinatesItem..::..RangeTypes rangeType,
    List<double>^ referencedTimeOffsets
)

Parameters

rangeType
Type: Mergecom.Sr..::..MCtemporalCoordinatesItem..::..RangeTypes
type of temporal extent of the region of interest
referencedTimeOffsets
Type: System.Collections.Generic..::..List<(Of <(<'Double>)>)>
Specifies temporal points for reference by number of seconds after start of data.

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
MCtemporalCoordTimeOffsetsItem Overload
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Methods
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback

The MCtemporalCoordTimeOffsetsItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCtemporalCoordinatesItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCtemporalCoordinatesItem..::..Write(MCattributeSet).)

See Also

MCtemporalCoordTimeOffsetsItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem..::..Read Method
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem..::..Write Method
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


MCtemporalCoordTimeOffsetsItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem Properties
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback

The MCtemporalCoordTimeOffsetsItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | RangeType | This Attribute defines the type of temporal extent of the region of interest. A temporal point (or instant of time) may be defined by a waveform sample offset (for a single waveform multiplex group only), time offset, or absolute time. (Inherited from MCtemporalCoordinatesItem.)
Public property | ReferencedTimeOffsets | Specifies temporal points for reference by number of seconds after start of data.
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)

See Also

MCtemporalCoordTimeOffsetsItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem..::..ContentItemType Property
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


ReferencedTimeOffsets Property

[image]

Merge DICOM .NET/C# Toolkit
MCtemporalCoordTimeOffsetsItem..::..ReferencedTimeOffsets Property
MCtemporalCoordTimeOffsetsItem Class See Also Send Feedback
Specifies temporal points for reference by number of seconds after start of data.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<double> ReferencedTimeOffsets { get; set; }
Visual Basic
Public Property ReferencedTimeOffsets As List(Of Double)
    Get
    Set
Visual C++
public:
property List<double>^ ReferencedTimeOffsets {
    List<double>^ get ();
    void set (List<double>^ value);
}

See Also

MCtemporalCoordTimeOffsetsItem Class
MCtemporalCoordTimeOffsetsItem Members
Mergecom.Sr Namespace


MCtextItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem Class
Members See Also Send Feedback
Free text, narrative description of unlimited length. May also be used to provide a label or identifier value.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtextItem : MCcontentItem
Visual Basic
Public Class MCtextItem _
    Inherits MCcontentItem
Visual C++
public ref class MCtextItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtextItem

See Also

MCtextItem Members
Mergecom.Sr Namespace


MCtextItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtextItem Members
MCtextItem Class Constructors Methods Properties See Also Send Feedback

The MCtextItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtextItem()()()() | Default constructor
Public method | MCtextItem(String, MCbasicCodedEntry) | Creates a new instance of the TEXT Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Text | This is the value of the Content Item. Text data which is unformatted and whose manner of display is implementation dependent. The text value may contain spaces, as well as multiple lines separated by either LF, CR, CR LF or LF CR, but otherwise no format control characters (such as horizontal or vertical tab and form feed) shall be present, even if permitted by the Value Representation of UT.

See Also

MCtextItem Class
Mergecom.Sr Namespace


MCtextItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtextItem Constructor
MCtextItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtextItem()()()() | Default constructor
Public method | MCtextItem(String, MCbasicCodedEntry) | Creates a new instance of the TEXT Content Item

See Also

MCtextItem Class
MCtextItem Members
Mergecom.Sr Namespace


MCtextItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem Constructor
MCtextItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtextItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtextItem()

See Also

MCtextItem Class
MCtextItem Members
MCtextItem Overload
Mergecom.Sr Namespace


MCtextItem Constructor (String, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem Constructor (String, MCbasicCodedEntry)
MCtextItem Class See Also Send Feedback
Creates a new instance of the TEXT Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtextItem(
    string text,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    text As String, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCtextItem(
    String^ text,
    MCbasicCodedEntry^ conceptName
)

Parameters

text
Type: System..::..String
Textual expression of the concept
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCtextItem Class
MCtextItem Members
MCtextItem Overload
Mergecom.Sr Namespace


MCtextItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtextItem Methods
MCtextItem Class See Also Send Feedback

The MCtextItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCtextItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem..::..Read Method
MCtextItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtextItem Class
MCtextItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem..::..Write Method
MCtextItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtextItem Class
MCtextItem Members
Mergecom.Sr Namespace


MCtextItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtextItem Properties
MCtextItem Class See Also Send Feedback

The MCtextItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Text | This is the value of the Content Item. Text data which is unformatted and whose manner of display is implementation dependent. The text value may contain spaces, as well as multiple lines separated by either LF, CR, CR LF or LF CR, but otherwise no format control characters (such as horizontal or vertical tab and form feed) shall be present, even if permitted by the Value Representation of UT.

See Also

MCtextItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem..::..ContentItemType Property
MCtextItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtextItem Class
MCtextItem Members
Mergecom.Sr Namespace


Text Property

[image]

Merge DICOM .NET/C# Toolkit
MCtextItem..::..Text Property
MCtextItem Class See Also Send Feedback
This is the value of the Content Item. Text data which is unformatted and whose manner of display is implementation dependent. The text value may contain spaces, as well as multiple lines separated by either LF, CR, CR LF or LF CR, but otherwise no format control characters (such as horizontal or vertical tab and form feed) shall be present, even if permitted by the Value Representation of UT.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

MCtextItem Class
MCtextItem Members
Mergecom.Sr Namespace


MCtimeItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Class
Members See Also Send Feedback
Time of occurrence of the type of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCtimeItem : MCcontentItem
Visual Basic
Public Class MCtimeItem _
    Inherits MCcontentItem
Visual C++
public ref class MCtimeItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCtimeItem

See Also

MCtimeItem Members
Mergecom.Sr Namespace


MCtimeItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Members
MCtimeItem Class Constructors Methods Properties See Also Send Feedback

The MCtimeItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCtimeItem()()()() | Default constructor
Public method | MCtimeItem(MCtime, MCbasicCodedEntry) | Creates a new instance of the TIME Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Time | Time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

See Also

MCtimeItem Class
Mergecom.Sr Namespace


MCtimeItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Constructor
MCtimeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCtimeItem()()()() | Default constructor
Public method | MCtimeItem(MCtime, MCbasicCodedEntry) | Creates a new instance of the TIME Content Item

See Also

MCtimeItem Class
MCtimeItem Members
Mergecom.Sr Namespace


MCtimeItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Constructor
MCtimeItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtimeItem()
Visual Basic
Public Sub New
Visual C++
public:
MCtimeItem()

See Also

MCtimeItem Class
MCtimeItem Members
MCtimeItem Overload
Mergecom.Sr Namespace


MCtimeItem Constructor (MCtime, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Constructor (MCtime, MCbasicCodedEntry)
MCtimeItem Class See Also Send Feedback
Creates a new instance of the TIME Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtimeItem(
    MCtime time,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    time As MCtime, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCtimeItem(
    MCtime^ time,
    MCbasicCodedEntry^ conceptName
)

Parameters

time
Type: Mergecom..::..MCtime
Time of occurrence of event
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name for the event

See Also

MCtimeItem Class
MCtimeItem Members
MCtimeItem Overload
Mergecom.Sr Namespace


MCtimeItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Methods
MCtimeItem Class See Also Send Feedback

The MCtimeItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCtimeItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem..::..Read Method
MCtimeItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCtimeItem Class
MCtimeItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem..::..Write Method
MCtimeItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCtimeItem Class
MCtimeItem Members
Mergecom.Sr Namespace


MCtimeItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCtimeItem Properties
MCtimeItem Class See Also Send Feedback

The MCtimeItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | Time | Time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

See Also

MCtimeItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem..::..ContentItemType Property
MCtimeItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCtimeItem Class
MCtimeItem Members
Mergecom.Sr Namespace


Time Property

[image]

Merge DICOM .NET/C# Toolkit
MCtimeItem..::..Time Property
MCtimeItem Class See Also Send Feedback
Time of occurrence of event denoted by the Concept Name which is a code sequence describing the concept represented by this content item.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCtime Time { get; set; }
Visual Basic
Public Property Time As MCtime
    Get
    Set
Visual C++
public:
property MCtime^ Time {
    MCtime^ get ();
    void set (MCtime^ value);
}

See Also

MCtimeItem Class
MCtimeItem Members
Mergecom.Sr Namespace


MCuidReferenceItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Class
Members See Also Send Feedback
Unique Identifier (UID) of the entity identified by the Concept Name.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCuidReferenceItem : MCcontentItem
Visual Basic
Public Class MCuidReferenceItem _
    Inherits MCcontentItem
Visual C++
public ref class MCuidReferenceItem : public MCcontentItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCuidReferenceItem

See Also

MCuidReferenceItem Members
Mergecom.Sr Namespace


MCuidReferenceItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Members
MCuidReferenceItem Class Constructors Methods Properties See Also Send Feedback

The MCuidReferenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCuidReferenceItem()()()() | Default constructor
Public method | MCuidReferenceItem(String, MCbasicCodedEntry) | Creates a new instance of the UIDREF Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | UidRef | Unique Identifier (UID) of the entity identified by the Concept Name.

See Also

MCuidReferenceItem Class
Mergecom.Sr Namespace


MCuidReferenceItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Constructor
MCuidReferenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCuidReferenceItem()()()() | Default constructor
Public method | MCuidReferenceItem(String, MCbasicCodedEntry) | Creates a new instance of the UIDREF Content Item

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
Mergecom.Sr Namespace


MCuidReferenceItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Constructor
MCuidReferenceItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCuidReferenceItem()
Visual Basic
Public Sub New
Visual C++
public:
MCuidReferenceItem()

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
MCuidReferenceItem Overload
Mergecom.Sr Namespace


MCuidReferenceItem Constructor (String, MCbasicCodedEntry)

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Constructor (String, MCbasicCodedEntry)
MCuidReferenceItem Class See Also Send Feedback
Creates a new instance of the UIDREF Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCuidReferenceItem(
    string uidRef,
    MCbasicCodedEntry conceptName
)
Visual Basic
Public Sub New ( _
    uidRef As String, _
    conceptName As MCbasicCodedEntry _
)
Visual C++
public:
MCuidReferenceItem(
    String^ uidRef,
    MCbasicCodedEntry^ conceptName
)

Parameters

uidRef
Type: System..::..String
Unique Identifier
conceptName
Type: Mergecom..::..MCbasicCodedEntry
Concept Name

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
MCuidReferenceItem Overload
Mergecom.Sr Namespace


MCuidReferenceItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Methods
MCuidReferenceItem Class See Also Send Feedback

The MCuidReferenceItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcontentItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcontentItem..::..Write(MCattributeSet).)

See Also

MCuidReferenceItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem..::..Read Method
MCuidReferenceItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem..::..Write Method
MCuidReferenceItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
Mergecom.Sr Namespace


MCuidReferenceItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem Properties
MCuidReferenceItem Class See Also Send Feedback

The MCuidReferenceItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcontentItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | UidRef | Unique Identifier (UID) of the entity identified by the Concept Name.

See Also

MCuidReferenceItem Class
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem..::..ContentItemType Property
MCuidReferenceItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
Mergecom.Sr Namespace


UidRef Property

[image]

Merge DICOM .NET/C# Toolkit
MCuidReferenceItem..::..UidRef Property
MCuidReferenceItem Class See Also Send Feedback
Unique Identifier (UID) of the entity identified by the Concept Name.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public string UidRef { get; set; }
Visual Basic
Public Property UidRef As String
    Get
    Set
Visual C++
public:
property String^ UidRef {
    String^ get ();
    void set (String^ value);
}

See Also

MCuidReferenceItem Class
MCuidReferenceItem Members
Mergecom.Sr Namespace


MCwaveformItem Class

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Class
Members See Also Send Feedback
A reference to one Waveform Composite SOP Instance.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class MCwaveformItem : MCcompositeItem
Visual Basic
Public Class MCwaveformItem _
    Inherits MCcompositeItem
Visual C++
public ref class MCwaveformItem : public MCcompositeItem

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCcontentItem
Mergecom.Sr..::..MCcompositeItem
Mergecom.Sr..::..MCwaveformItem

See Also

MCwaveformItem Members
Mergecom.Sr Namespace


MCwaveformItem Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Members
MCwaveformItem Class Constructors Methods Properties See Also Send Feedback

The MCwaveformItem type exposes the following members.

Constructors

 | Name | Description
Public method | MCwaveformItem()()()() | Default constructor
Public method | MCwaveformItem(MCsopInstanceReference) | Creates a new instance of the WAVEFORM Content Item

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcompositeItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcompositeItem..::..Write(MCattributeSet).)

Properties

 | Name | Description
Public property | Channels | Optional list of channels in Waveform to which the reference applies. See C.18.5.1.1 Required if the Referenced SOP Instance is a Waveform that contains multiple Channels and not all Channels in the Waveform are referenced
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcompositeItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform. (Inherited from MCcompositeItem.)

See Also

MCwaveformItem Class
Mergecom.Sr Namespace


MCwaveformItem Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Constructor
MCwaveformItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCwaveformItem()()()() | Default constructor
Public method | MCwaveformItem(MCsopInstanceReference) | Creates a new instance of the WAVEFORM Content Item

See Also

MCwaveformItem Class
MCwaveformItem Members
Mergecom.Sr Namespace


MCwaveformItem Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Constructor
MCwaveformItem Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCwaveformItem()
Visual Basic
Public Sub New
Visual C++
public:
MCwaveformItem()

See Also

MCwaveformItem Class
MCwaveformItem Members
MCwaveformItem Overload
Mergecom.Sr Namespace


MCwaveformItem Constructor (MCsopInstanceReference)

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Constructor (MCsopInstanceReference)
MCwaveformItem Class See Also Send Feedback
Creates a new instance of the WAVEFORM Content Item

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public MCwaveformItem(
    MCsopInstanceReference sopReference
)
Visual Basic
Public Sub New ( _
    sopReference As MCsopInstanceReference _
)
Visual C++
public:
MCwaveformItem(
    MCsopInstanceReference^ sopReference
)

Parameters

sopReference
Type: Mergecom..::..MCsopInstanceReference
Image SOP Instance

See Also

MCwaveformItem Class
MCwaveformItem Members
MCwaveformItem Overload
Mergecom.Sr Namespace


MCwaveformItem Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Methods
MCwaveformItem Class See Also Send Feedback

The MCwaveformItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Adds child to the node (Inherited from MCcontentItem.)
Public method | AddChildAt | Inserts a child at the specific position. The other children will be shifted (Inherited from MCcontentItem.)
Public method | AddReference | Adds a reference to another node in the tree (Inherited from MCcontentItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemId | Traverses current position and returns the Item Id. (Inherited from MCcontentItem.)
Public method | GetPosition | Return a position of this item in the parent's content (Inherited from MCcontentItem.)
Public method | getRootItem | Returns the Root content item (Inherited from MCcontentItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads attributes from the DataSet (Overrides MCcompositeItem..::..Read(MCattributeSet).)
Public method | RemoveChild | Removes child node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCcontentItem) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | RemoveReference(MCitemRelationship) | Removes reference to the node (Inherited from MCcontentItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves attributes to DataSet (Overrides MCcompositeItem..::..Write(MCattributeSet).)

See Also

MCwaveformItem Class
Mergecom.Sr Namespace


Read Method

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Read Method
MCwaveformItem Class See Also Send Feedback
Reads attributes from the DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Read(
    MCattributeSet source
)
Visual Basic
Public Overrides Sub Read ( _
    source As MCattributeSet _
)
Visual C++
public:
virtual void Read(
    MCattributeSet^ source
) override

Parameters

source
Type: Mergecom..::..MCattributeSet
source DataSet

Implements

MCdataSetSerializable..::..Read(MCattributeSet)

See Also

MCwaveformItem Class
MCwaveformItem Members
Mergecom.Sr Namespace


Write Method

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Write Method
MCwaveformItem Class See Also Send Feedback
Saves attributes to DataSet

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override void Write(
    MCattributeSet destination
)
Visual Basic
Public Overrides Sub Write ( _
    destination As MCattributeSet _
)
Visual C++
public:
virtual void Write(
    MCattributeSet^ destination
) override

Parameters

destination
Type: Mergecom..::..MCattributeSet
Destination DataSet

Implements

MCdataSetSerializable..::..Write(MCattributeSet)

See Also

MCwaveformItem Class
MCwaveformItem Members
Mergecom.Sr Namespace


MCwaveformItem Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem Properties
MCwaveformItem Class See Also Send Feedback

The MCwaveformItem type exposes the following members.

Properties

 | Name | Description
Public property | Channels | Optional list of channels in Waveform to which the reference applies. See C.18.5.1.1 Required if the Referenced SOP Instance is a Waveform that contains multiple Channels and not all Channels in the Waveform are referenced
Public property | Children | Child content items. The relationship is accessable as RelationshipType property of child. Note: it is a standard array where index starts from 0. Index = Position - 1 (Inherited from MCcontentItem.)
Public property | ConceptName | Code describing the concept represented by this Content Item. Also conveys the value of Document Title and section headings in documents. Only a single Item shall be permitted in this sequence. (Inherited from MCcontentItem.)
Public property | ContentItemType | Returns the content node type. Can be used for upcasting. (Overrides MCcompositeItem..::..ContentItemType.)
Public property | DataContext | Optional data associated with the node (Inherited from MCcontentItem.)
Public property | DataSet | MCattributeSet object associated with the node (Inherited from MCcontentItem.)
Public property | ObservationDateTime | Optional attribute. The date and time on which this Content Item was completed. For the purpose of recording measurements or logging events, completion time is defined as the time of data acquisition of the measurement, or the time of occurrence of the event. Required if the date and time are different from the Content Date (0008,0023) and Content Time (0008,0033) or the Observation DateTime (0040,A032) defined in higher items. May be present otherwise. (Inherited from MCcontentItem.)
Public property | ObservationUID | Optional attribute. Unique identifier for the observation Content Item (and its subsidiary Content Items, if any). The UID represents the semantic content of the observation; an encoding of the same observation with the same context into another representation (e.g., a CDA Entry) may use the same UID. (Inherited from MCcontentItem.)
Public property | Parent | Parent Item Content (Inherited from MCcontentItem.)
Public property | References | A collection of references that are referenced by this content item (Inherited from MCcontentItem.)
Public property | RelationshipType | Relationship type between parent and this item (Inherited from MCcontentItem.)
Public property | SopReference | A reference to one Composite SOP Instance which is not an Image or Waveform. (Inherited from MCcompositeItem.)

See Also

MCwaveformItem Class
Mergecom.Sr Namespace


Channels Property

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channels Property
MCwaveformItem Class See Also Send Feedback
Optional list of channels in Waveform to which the reference applies. See C.18.5.1.1 Required if the Referenced SOP Instance is a Waveform that contains multiple Channels and not all Channels in the Waveform are referenced

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public List<MCwaveformItem..::..Channel> Channels { get; set; }
Visual Basic
Public Property Channels As List(Of MCwaveformItem..::..Channel)
    Get
    Set
Visual C++
public:
property List<MCwaveformItem..::..Channel^>^ Channels {
    List<MCwaveformItem..::..Channel^>^ get ();
    void set (List<MCwaveformItem..::..Channel^>^ value);
}

See Also

MCwaveformItem Class
MCwaveformItem Members
Mergecom.Sr Namespace


ContentItemType Property

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..ContentItemType Property
MCwaveformItem Class See Also Send Feedback
Returns the content node type. Can be used for upcasting.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public override ContentItemType ContentItemType { get; }
Visual Basic
Public Overrides ReadOnly Property ContentItemType As ContentItemType
    Get
Visual C++
public:
virtual property ContentItemType ContentItemType {
    ContentItemType get () override;
}

See Also

MCwaveformItem Class
MCwaveformItem Members
Mergecom.Sr Namespace


MCwaveformItem.Channel Class

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Class
MCwaveformItem Class Members See Also Send Feedback
Referenced Waveform Channel Each channel is specified as a pair of values (M,C), where the first value is the sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number), and the second value is the sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group. If the specified channel number is 0, the annotation applies to all channels in the multiplex group.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public class Channel
Visual Basic
Public Class Channel
Visual C++
public ref class Channel

Inheritance Hierarchy

System..::..Object
Mergecom.Sr..::..MCwaveformItem..::..Channel

See Also

MCwaveformItem..::..Channel Members
Mergecom.Sr Namespace


MCwaveformItem.Channel Members

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Members
MCwaveformItem..::..Channel Class Constructors Methods Properties See Also Send Feedback

The MCwaveformItem..::..Channel type exposes the following members.

Constructors

 | Name | Description
Public method | MCwaveformItem..::..Channel()()()() | Default constructor
Public method | MCwaveformItem..::..Channel(UInt16, UInt16) | Creates a new Waveform Channel reference

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChannelNumber | The sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group.
Public property | MultiplexGroupNumber | The sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number).

See Also

MCwaveformItem..::..Channel Class
Mergecom.Sr Namespace


MCwaveformItem.Channel Constructor

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Constructor
MCwaveformItem..::..Channel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCwaveformItem..::..Channel()()()() | Default constructor
Public method | MCwaveformItem..::..Channel(UInt16, UInt16) | Creates a new Waveform Channel reference

See Also

MCwaveformItem..::..Channel Class
MCwaveformItem..::..Channel Members
Mergecom.Sr Namespace


MCwaveformItem.Channel Constructor

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Constructor
MCwaveformItem..::..Channel Class See Also Send Feedback
Default constructor

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Channel()
Visual Basic
Public Sub New
Visual C++
public:
Channel()

See Also

MCwaveformItem..::..Channel Class
MCwaveformItem..::..Channel Members
MCwaveformItem..::..Channel Overload
Mergecom.Sr Namespace


MCwaveformItem.Channel Constructor (UInt16, UInt16)

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Constructor (UInt16, UInt16)
MCwaveformItem..::..Channel Class See Also Send Feedback
Creates a new Waveform Channel reference

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public Channel(
    ushort multiplexGroupNumber,
    ushort channelNumber
)
Visual Basic
Public Sub New ( _
    multiplexGroupNumber As UShort, _
    channelNumber As UShort _
)
Visual C++
public:
Channel(
    unsigned short multiplexGroupNumber,
    unsigned short channelNumber
)

Parameters

multiplexGroupNumber
Type: System..::..UInt16
The sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number).
channelNumber
Type: System..::..UInt16
The sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group.

See Also

MCwaveformItem..::..Channel Class
MCwaveformItem..::..Channel Members
MCwaveformItem..::..Channel Overload
Mergecom.Sr Namespace


MCwaveformItem.Channel Methods

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Methods
MCwaveformItem..::..Channel Class See Also Send Feedback

The MCwaveformItem..::..Channel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwaveformItem..::..Channel Class
Mergecom.Sr Namespace


MCwaveformItem.Channel Properties

[image] [image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel Properties
MCwaveformItem..::..Channel Class See Also Send Feedback

The MCwaveformItem..::..Channel type exposes the following members.

Properties

 | Name | Description
Public property | ChannelNumber | The sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group.
Public property | MultiplexGroupNumber | The sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number).

See Also

MCwaveformItem..::..Channel Class
Mergecom.Sr Namespace


ChannelNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel..::..ChannelNumber Property
MCwaveformItem..::..Channel Class See Also Send Feedback
The sequence item number of the Channel Definition Sequence (003A,0200) attribute (i.e., the Channel Number) within the multiplex group.

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ushort ChannelNumber { get; set; }
Visual Basic
Public Property ChannelNumber As UShort
    Get
    Set
Visual C++
public:
property unsigned short ChannelNumber {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

MCwaveformItem..::..Channel Class
MCwaveformItem..::..Channel Members
Mergecom.Sr Namespace


MultiplexGroupNumber Property

[image]

Merge DICOM .NET/C# Toolkit
MCwaveformItem..::..Channel..::..MultiplexGroupNumber Property
MCwaveformItem..::..Channel Class See Also Send Feedback
The sequence item number of the Waveform Sequence (5400,0100) attribute in the referenced object (i.e. the Multiplex Group Number).

Namespace: Mergecom.Sr
Assembly: Mergecom (in Mergecom.dll) Version: 5.18.0.0

Syntax

C#
public ushort MultiplexGroupNumber { get; set; }
Visual Basic
Public Property MultiplexGroupNumber As UShort
    Get
    Set
Visual C++
public:
property unsigned short MultiplexGroupNumber {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

MCwaveformItem..::..Channel Class
MCwaveformItem..::..Channel Members
Mergecom.Sr Namespace


Json.NET License

[image]

Merge DICOM .NET/C# Toolkit
Json.NET License
Send Feedback

Json.NET is open source software and is completely free for commercial use. Json.NET is licensed under the MIT License which allows its use in any type of application without any restriction.

The MIT License (MIT)

Copyright (c) 2007 James Newton-King

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.